home *** CD-ROM | disk | FTP | other *** search
/ Crawly Crypt Collection 1 / crawlyvol1.bin / program / compiler / nasm20b / libinc / demo / makefile.nix < prev    next >
Makefile  |  1993-01-19  |  637b  |  36 lines

  1. NASM=nasm65
  2. NLINK=nlink65
  3. NLIB=nlib65
  4. # if you have UNIX you don't need this kludge
  5. # SHELL=callgu
  6.  
  7. AFLAGS=-x
  8.  
  9. .SUFFIXES:
  10.  
  11. .SUFFIXES:    .l65 .o65 .s65 .h65 .com
  12.  
  13. .s65.o65:
  14.     $(NASM) $(AFLAGS) $<
  15.  
  16. .o65.com:
  17.     $(NLINK) $(LFLAGS) $*.o65 -o $*.com
  18.  
  19. .s65.com:
  20.     $(NASM) $(AFLAGS) $<
  21.     $(NLINK) $(LFLAGS) $*.o65 -o $*.com
  22.  
  23. #
  24. # --------------------------------------------------------------
  25. all:    handler.com readsect.com readboot.com strtest.com fill.com
  26.  
  27. clean:
  28.     $(SHELL) rm *.d* *.o*
  29.  
  30. install.o65:    handler.h65 install.s65
  31.  
  32. resident.o65:    handler.h65 resident.s65
  33.  
  34. handler.com:    install.o65 resident.o65
  35.     $(NLINK) -b handler -o handler.com -s 4000 -m
  36.