home *** CD-ROM | disk | FTP | other *** search
/ OS/2 Shareware BBS: 35 Internet / 35-Internet.zip / nmap254b.zip / nmap-2.54BETA30-1.spec < prev    next >
Text File  |  2001-10-14  |  4KB  |  143 lines

  1. %define name nmap
  2. %define version 2.54BETA30
  3. %define release 1
  4. %define prefix /usr
  5.  
  6. # to not build the frontend, add:
  7. #   --define "buildfe 0"
  8. # ...to the rpm build command-line
  9.  
  10. %if "%{buildfe}" != "0"
  11. %define buildfe 1
  12. %endif
  13.  
  14. Summary: Network exploration tool and security scanner
  15. Name: %{name}
  16. Version: %{version}
  17. Release: %{release}
  18. Copyright: GPL
  19. Group: Applications/System
  20. Source0: http://www.insecure.org/nmap/dist/%{name}-%{version}.tgz
  21. URL: http://www.insecure.org/nmap/
  22. BuildRoot: /var/tmp/%{name}-root
  23. # RPM can't be relocatable until I stop storing path info in the binary
  24. # Prefix: %{prefix}
  25.  
  26. %description
  27. Nmap is a utility for network exploration or security auditing. It
  28. supports ping scanning (determine which hosts are up), many port
  29. scanning techniques (determine what services the hosts are offering),
  30. and TCP/IP fingerprinting (remote host operating system
  31. identification). Nmap also offers flexible target and port
  32. specification, decoy scanning, determination of TCP sequence
  33. predictability characteristics, sunRPC scanning, reverse-identd
  34. scanning, and more.
  35.  
  36. %if "%{buildfe}" == "1"
  37. %package frontend
  38. Summary: Gtk+ frontend for nmap
  39. Group: Applications/System
  40. Requires: nmap, gtk+
  41. Version: 0.%{version}
  42. %description frontend
  43. This package includes nmapfe, a Gtk+ frontend for nmap. The nmap package must
  44. be installed before installing nmap-frontend.
  45. %endif
  46.  
  47. %prep
  48. %setup -q
  49.  
  50. %build
  51. CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix}
  52. make 
  53.  
  54. %install
  55. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  56.  
  57. make prefix=$RPM_BUILD_ROOT%{prefix} install
  58.  
  59. mkdir -p $RPM_BUILD_ROOT%{prefix}/share/gnome/apps/Utilities
  60.  
  61. strip $RPM_BUILD_ROOT%{prefix}/bin/* || :
  62. gzip $RPM_BUILD_ROOT%{prefix}/man/man1/* || :
  63.  
  64. %if "%{buildfe}" == "1"
  65. %post frontend
  66. rm -f ${prefix}/bin/xnmap
  67. ln -s nmapfe ${prefix}/bin/xnmap
  68. %endif
  69.  
  70. %if "%{buildfe}" == "1"
  71. %postun frontend
  72. rm -f ${prefix}/bin/xnmap
  73. %endif
  74.  
  75. %clean
  76. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  77.  
  78. %files 
  79. %defattr(-,root,root)
  80. %doc COPYING
  81. %doc docs/README docs/copying.html docs/nmap-fingerprinting-article.txt
  82. %doc docs/nmap.deprecated.txt docs/nmap.usage.txt docs/nmap_doc.html
  83. %doc docs/nmap_manpage.html docs/nmap_manpage-es.html
  84. %doc docs/nmap_manpage-fr.html docs/nmap_manpage-lt.html 
  85. %doc docs/nmap_manpage-it.html
  86. %doc docs/nmap_manpage-ru.html
  87. %{prefix}/bin/nmap
  88. %{prefix}/share/nmap
  89. %{prefix}/man/man1/nmap.1.gz
  90.  
  91. %if "%{buildfe}" == "1"
  92. %files frontend
  93. %defattr(-,root,root)
  94. %{prefix}/bin/nmapfe
  95. %{prefix}/bin/xnmap
  96. %{prefix}/share/gnome/apps/Utilities/nmapfe.desktop
  97. %{prefix}/man/man1/xnmap.1.gz
  98. %{prefix}/man/man1/nmapfe.1.gz
  99. %endif
  100.  
  101. %changelog
  102.  
  103. * Fri Jun 01 2001 GOMEZ Henri (hgomez@slib.fr)
  104. - Patch which checks that $RPM_BUILD_ROOT is not "/" before rm'ing it.
  105.  
  106. * Tue Mar 06 2001 Ben Reed <ben@opennms.org>
  107. - changed spec to handle not building the frontend
  108.  
  109. * Thu Dec 30 1999 Fyodor <fyodor@insecure.org>
  110. - Updated description
  111. - Eliminated source1 (nmapfe.desktop) directive and simply packaged it with Nmap
  112. - Fixed nmap distribution URL (source0)
  113. - Added this .rpm to base Nmap distribution
  114.  
  115. * Mon Dec 13 1999 Tim Powers <timp@redhat.com>
  116. - based on origional spec file from
  117.     http://www.insecure.org/nmap/index.html#download
  118. - general cleanups, removed lots of commenrts since it made the spec hard to
  119.     read
  120. - changed group to Applications/System
  121. - quiet setup
  122. - no need to create dirs in the install section, "make
  123.     prefix=$RPM_BUILD_ROOT&{prefix} install" does this.
  124. - using defined %{prefix}, %{version} etc. for easier/quicker maint.
  125. - added docs
  126. - gzip man pages
  127. - strip after files have been installed into buildroot
  128. - created separate package for the frontend so that Gtk+ isn't needed for the
  129.     CLI nmap 
  130. - not using -f in files section anymore, no need for it since there aren't that
  131.     many files/dirs
  132. - added desktop entry for gnome
  133.  
  134. * Sun Jan 10 1999 Fyodor <fyodor@insecure.org>
  135. - Merged in spec file sent in by Ian Macdonald <ianmacd@xs4all.nl>
  136.  
  137. * Tue Dec 29 1998 Fyodor <fyodor@insecure.org>
  138. - Made some changes, and merged in another .spec file sent in
  139.   by Oren Tirosh <oren@hishome.net>
  140.  
  141. * Mon Dec 21 1998 Riku Meskanen <mesrik@cc.jyu.fi>
  142. - initial build for RH 5.x
  143.