home *** CD-ROM | disk | FTP | other *** search
/ OS/2 Shareware BBS: 6 File / 06-File.zip / mc454src.zip / mc-4.5.4.src / mc-4.5.4 / mc.spec < prev    next >
Text File  |  1999-01-04  |  7KB  |  236 lines

  1. # Note that this is NOT a relocatable package
  2. %define ver      4.5.3
  3. %define rel      SNAP
  4. %define prefix   /usr
  5.  
  6. Summary:   Midnight Commander visual shell
  7. Name:      mc
  8. Version:   %ver
  9. Release:   %rel
  10. Copyright: GPL
  11. Group:     Shells
  12. Source0:   ftp://ftp.nuclecu.unam.mx/linux/local/devel/mc-%{PACKAGE_VERSION}.tar.gz
  13. URL:       http://www.gnome.org/mc/
  14. BuildRoot: /tmp/mc-%{PACKAGE_VERSION}-root
  15. Requires:  pam >= 0.59
  16. Prereq:    /sbin/chkconfig
  17.  
  18. %description
  19. Midnight Commander is a visual shell much like a file manager, only with way
  20. more features.  It is text mode, but also includes mouse support if you are
  21. running GPM.  Its coolest feature is the ability to ftp, view tar, zip
  22. files, and poke into RPMs for specific files.  :-)
  23.  
  24. %package -n gmc
  25. Summary:  Midnight Commander visual shell (GNOME version)
  26. Requires: mc >= 4.1.31
  27. Group:    X11/Shells
  28. %description -n gmc
  29. Midnight Commander is a visual shell much like a file manager, only with
  30. way more features.  This is the GNOME version. It's coolest feature is the
  31. ability to ftp, view tar, zip files and poke into RPMs for specific files.
  32. The GNOME version of Midnight Commander is not yet finished though. :-(
  33.  
  34. %package -n mcserv
  35. Summary:  Midnight Commander file server
  36. Group:    X11/Shells
  37. Requires: portmap
  38. %description -n mcserv
  39. mcserv is the server program for the Midnight Commander networking file
  40. system. It provides access to the host file system to clients running the
  41. Midnight file system (currently, only the Midnight Commander file manager).
  42.  
  43. %prep
  44. %setup
  45.  
  46. %build
  47. CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" ./autogen.sh \
  48.     --prefix=%{prefix} \
  49.     --with-gnome \
  50.     --without-debug
  51.  
  52. if [ "$SMP" != "" ]; then
  53.   (make "MAKE=make -k -j $SMP"; exit 0)
  54.   make
  55. else
  56.   make
  57. fi
  58.  
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,profile.d,X11/wmconfig}
  62.  
  63. make prefix=$RPM_BUILD_ROOT%{prefix} install
  64. (cd icons; make prefix=$RPM_BUILD_ROOT%{prefix} install_icons)
  65. install lib/mcserv.init $RPM_BUILD_ROOT/etc/rc.d/init.d/mcserv
  66.  
  67. install lib/mcserv.pamd $RPM_BUILD_ROOT/etc/pam.d/mcserv
  68. install lib/{mc.sh,mc.csh} $RPM_BUILD_ROOT/etc/profile.d
  69.  
  70. # clean up this setuid problem for now
  71. chmod 755 $RPM_BUILD_ROOT/usr/lib/mc/bin/cons.saver
  72.  
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75.  
  76. %post   -n mcserv
  77. /sbin/chkconfig --add mcserv
  78.  
  79. %postun -n mcserv
  80. /sbin/chkconfig --del mcserv
  81.  
  82. %files
  83. %defattr(-, root, root)
  84.  
  85. %doc FAQ COPYING NEWS README
  86. /usr/bin/mc
  87. /usr/bin/mcedit
  88. /usr/bin/mcmfmt
  89. /usr/lib/mc/mc.ext
  90. /usr/lib/mc/mc.hint
  91. /usr/lib/mc/mc.hlp
  92. /usr/lib/mc/mc.lib
  93. /usr/lib/mc/mc.menu
  94. /usr/lib/mc/bin/cons.saver
  95. /usr/lib/mc/extfs/*
  96. /usr/man/man1/*
  97. %config /etc/profile.d/*
  98. %dir /usr/lib/mc
  99. %dir /usr/lib/mc/bin
  100. %dir /usr/lib/mc/extfs
  101. %dir /usr/share/mime-info
  102.  
  103. %files -n mcserv
  104. %defattr(-, root, root)
  105.  
  106. %config /etc/pam.d/mcserv
  107. %config /etc/rc.d/init.d/mcserv
  108. %attr(-, root, man)  /usr/man/man8/mcserv.8
  109. /usr/bin/mcserv
  110.  
  111. %files -n gmc
  112. %defattr(-, root, root)
  113.  
  114. /usr/bin/gmc
  115. /usr/lib/mc/layout
  116. /usr/share/icons/mc/*
  117.  
  118. %changelog
  119. * Thu Aug 20 1998 Michael Fulbright <msf@redhat.com>
  120. - rebuilt against gnome-libs 0.27 and gtk+-1.1
  121.  
  122. * Thu Jul 09 1998 Michael Fulbright <msf@redhat.com>
  123. - made cons.saver not setuid
  124.  
  125. * Sun Apr 19 1998 Marc Ewing <marc@redhat.com>
  126. - removed tkmc
  127.  
  128. * Wed Apr 8 1998 Marc Ewing <marc@redhat.com>
  129. - add /usr/lib/mc/layout to gmc
  130.  
  131. * Tue Dec 23 1997 Tomasz K│oczko <kloczek@rudy.mif.pg.gda.pl>
  132. - added --without-debug to configure,
  133. - modification in %build and %install and cosmetic modification in packages
  134.   headers,
  135. - added %%{PACKAGE_VERSION} macro to Buildroot,
  136. - removed "rm -rf $RPM_BUILD_ROOT" from %prep.
  137. - removed Packager field.
  138.  
  139. * Thu Dec 18 1997 Michele Marziani <marziani@fe.infn.it>
  140. - Merged spec file with that from RedHat-5.0 distribution
  141.   (now a Hurricane-based distribution is needed)
  142. - Added patch for RPM script (didn't always work with rpm-2.4.10)
  143. - Corrected patch for mcserv init file (chkconfig init levels)
  144. - Added more documentation files on termcap, terminfo, xterm
  145.  
  146. * Thu Oct 30 1997 Michael K. Johnson <johnsonm@redhat.com>
  147.  
  148. - Added dependency on portmap
  149.  
  150. * Wed Oct 29 1997 Michael K. Johnson <johnsonm@redhat.com>
  151.  
  152. - fixed spec file.
  153. - Updated to 4.1.8
  154.  
  155. * Sun Oct 26 1997 Tomasz K│oczko <kloczek@rudy.mif.pg.gda.pl>
  156.  
  157. - updated to 4.1.6
  158. - added %attr macros in %files,
  159. - a few simplification in %install,
  160. - removed glibc patch,
  161. - fixed installing /etc/X11/wmconfig/tkmc.
  162.  
  163. * Thu Oct 23 1997 Michael K. Johnson <johnsonm@redhat.com>
  164.  
  165. - updated to 4.1.5
  166. - added wmconfig
  167.  
  168. * Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
  169.  
  170. - chkconfig is for mcserv package, not mc one
  171.  
  172. * Tue Oct 14 1997 Erik Troan <ewt@redhat.com>
  173.  
  174. - patched init script for chkconfig
  175. - don't turn on the service by default
  176.  
  177. * Fri Oct 10 1997 Michael K. Johnson <johnsonm@redhat.com>
  178.  
  179. - Converted to new PAM conventions.
  180. - Updated to 4.1.3
  181. - No longer needs glibc patch.
  182.  
  183. * Thu May 22 1997 Michele Marziani <marziani@fe.infn.it>
  184.  
  185. - added support for mc alias in /etc/profile.d/mc.csh (for csh and tcsh)
  186. - lowered number of SysV init scripts in /etc/rc.d/rc[0,1,6].d
  187.   (mcserv needs to be killed before inet)
  188. - removed all references to $RPM_SOURCE_DIR
  189. - restored $RPM_OPT_FLAGS when compiling
  190. - minor cleanup of spec file: redundant directives and comments removed
  191.  
  192. * Sun May 18 1997 Michele Marziani <marziani@fe.infn.it>
  193.  
  194. - removed all references to non-existent mc.rpmfs
  195. - added mcedit.1 to the %files section
  196. - reverted to un-gzipped man pages (RedHat style)
  197. - removed double install line for mcserv.pamd
  198.  
  199. * Tue May 13 1997 Tomasz K│oczko <kloczek@rudy.mif.pg.gda.pl>
  200.  
  201. - added new rpmfs script,
  202. - removed mcfn_install from mc (adding mc() to bash enviroment is in
  203.   /etc/profile.d/mc.sh),
  204. - /etc/profile.d/mc.sh changed to %config,
  205. - removed /usr/lib/mc/bin/create_vcs,
  206. - removed /usr/lib/mc/term.
  207.  
  208. * Wed May 9 1997 Tomasz K│oczko <kloczek@rudy.mif.pg.gda.pl>
  209.  
  210. - changed source url,
  211. - fixed link mcedit to mc,
  212.  
  213. * Tue May 7 1997 Tomasz K│oczko <kloczek@rudy.mif.pg.gda.pl>
  214.  
  215. - new version 3.5.27,
  216. - %dir /usr/lib/mc/icons and icons removed from tkmc,
  217. - added commented xmc part.
  218.  
  219. * Tue Apr 22 1997 Tomasz K│oczko <kloczek@rudy.mif.pg.gda.pl>
  220.  
  221. - FIX spec:
  222.    - added URL field,
  223.    - in mc added missing /usr/lib/mc/mc.ext, /usr/lib/mc/mc.hint,
  224.      /usr/lib/mc/mc.hlp, /usr/lib/mc/mc.lib, /usr/lib/mc/mc.menu.
  225.  
  226. * Fri Apr 18 1997 Tomasz K│oczko <kloczek@rudy.mif.pg.gda.pl>
  227.  
  228. - added making packages: tkmc, mcserv (xmc not work yet),
  229. - gziped man pages,
  230. - added /etc/pamd.d/mcserv PAM config file.
  231. - added instaling icons,
  232. - added /etc/profile.d/mc.sh,
  233. - in %doc added NEWS README,
  234. - removed /usr/lib/mc/FAQ,
  235. - added mcserv.init script for mcserv (start/stop on level 86).
  236.