home *** CD-ROM | disk | FTP | other *** search
/ c't freeware shareware 2001 January / CT_SW0101.ISO / pc / software / kommunik / ftp / kmago112.tgz / kmago112.tar / kmago-1.1.2 / debian / rules < prev    next >
Text File  |  2001-04-19  |  2KB  |  99 lines

  1. #!/usr/bin/make -f
  2. # Sample debian/rules that uses debhelper.
  3. # GNU copyright 1997 to 1999 by Joey Hess.
  4.  
  5. # Uncomment this to turn on verbose mode.
  6. #export DH_VERBOSE=1
  7.  
  8. # This is the debhelper compatability version to use.
  9. export DH_COMPAT=2
  10.  
  11. CFLAGS = -O2
  12. ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
  13. CFLAGS+= -g
  14. endif
  15.  
  16. configure: configure-stamp
  17. configure-stamp:
  18.     dh_testdir
  19.     # Add here commands to configure the package.
  20.     ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --disable-rpath
  21.  
  22.     touch configure-stamp
  23.  
  24. build: configure-stamp build-stamp
  25. build-stamp:
  26.     dh_testdir
  27.  
  28.     # Add here commands to compile the package.
  29.     $(MAKE) CFLAGS=$(CFLAGS)
  30.     #/usr/bin/docbook-to-man debian/kmago.sgml > kmago.1
  31.  
  32.     touch build-stamp
  33.  
  34. clean:
  35.     dh_testdir
  36.     dh_testroot
  37.     rm -f build-stamp configure-stamp
  38.  
  39.     # Add here commands to clean up after the build process.
  40.     -$(MAKE) distclean
  41.  
  42.     dh_clean
  43.  
  44. install: build
  45.     dh_testdir
  46.     dh_testroot
  47.     dh_clean -k
  48.     dh_installdirs
  49.  
  50.     # Add here commands to install the package into debian/kmago.
  51.     uudecode -o debian/kmago/usr/share/icons/locolor/16x16/apps/kmago.png \
  52.       debian/kmago16x16lo.png.in
  53.     uudecode -o debian/kmago/usr/share/icons/locolor/32x32/apps/kmago.png \
  54.       debian/kmago32x32lo.png.in
  55.  
  56.     rm -f debian/kmago/usr/share/icons/locolor/16x16/apps/kmago.xpm
  57.     rm -f debian/kmago/usr/share/icons/locolor/32x32/apps/kmago.xpm
  58.  
  59.     $(MAKE) install prefix=$(CURDIR)/debian/kmago/usr
  60.  
  61.  
  62. # Build architecture-independent files here.
  63. binary-indep: build install
  64. # We have nothing to do by default.
  65.  
  66. # Build architecture-dependent files here.
  67. binary-arch: build install
  68. #    dh_testversion 2
  69.     dh_testdir
  70.     dh_testroot
  71. #    dh_installdebconf    
  72.     dh_installdocs
  73. #    dh_installexamples
  74.     dh_installmenu
  75. #    dh_installemacsen
  76. #    dh_installpam
  77. #    dh_installinit
  78. #    dh_installcron
  79.     dh_installmanpages
  80. #    dh_installinfo
  81. #    dh_undocumented
  82.     dh_installchangelogs ChangeLog
  83.     dh_link
  84.     dh_strip
  85.     dh_compress
  86.     dh_fixperms
  87.     # You may want to make some executables suid here.
  88. #    dh_suidregister
  89. #    dh_makeshlibs
  90.     dh_installdeb
  91. #    dh_perl
  92.     dh_shlibdeps
  93.     dh_gencontrol
  94.     dh_md5sums
  95.     dh_builddeb
  96.  
  97. binary: binary-indep binary-arch
  98. .PHONY: build clean binary-indep binary-arch binary install configure
  99.