home *** CD-ROM | disk | FTP | other *** search
/ OS/2 Shareware BBS: 10 Tools / 10-Tools.zip / wxos2240.zip / wxWindows-2.4.0 / wxMGL.spec < prev    next >
Text File  |  2002-12-05  |  3KB  |  124 lines

  1. %define pref /usr
  2. %define ver 2.4.0
  3. %define ver2 2.4
  4. %define rel 1
  5.  
  6. Summary: The SciTech MGL port of the wxWindows library
  7. Name: wxMGL
  8. Version: %{ver}
  9. Release: %{rel}
  10. Copyright: wxWindows Licence
  11. Group: System/Libraries
  12. Source: wxMGL-%{ver}.tar.bz2
  13. URL: http://www.wxwindows.org
  14. Packager: Vaclav Slavik <vaclav@wxwindows.org>
  15. Prefix: %{pref}
  16. BuildRoot: /var/tmp/%{name}-root
  17.  
  18. # all packages providing an implementation of wxWindows library (regardless of
  19. # the toolkit used) should provide the (virtual) wxwin package, this makes it
  20. # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
  21. Provides: wxwin
  22.  
  23. Provides: libwx_mgl.so
  24. Provides: libwx_mgl-%{ver2}.so
  25.  
  26. Requires: mgl
  27. BuildRequires: mgl-devel
  28.  
  29. %description
  30. wxWindows is a free C++ library for cross-platform GUI development.
  31. With wxWindows, you can create applications for different GUIs (GTK+,
  32. Motif/LessTif, MS Windows, Mac) from the same source code.
  33.  
  34. %package devel
  35. Summary: The SciTech MGL port of the wxWindows library
  36. Group: Development/Libraries
  37. Requires: wxMGL = %{ver}
  38.  
  39. %description devel
  40. Header files for wxMGL, the SciTech MGL port of the wxWindows library.
  41.  
  42. %package static
  43. Summary: wxMGL static libraries
  44. Group: Development/Libraries
  45.  
  46. %description static
  47. Static libraries for wxMGL. You need them if you want to link statically against wxMGL.
  48.  
  49. %prep
  50. %setup -n wxMGL-%{ver}
  51.  
  52. %build
  53. if [ "$SMP" != "" ]; then
  54.   export MAKE="make -j$SMP"
  55. else
  56.   export MAKE="make"
  57. fi
  58.  
  59. mkdir obj-shared
  60. cd obj-shared
  61. ../configure --prefix=%{pref} --enable-soname --with-mgl
  62. $MAKE
  63. cd ..
  64.  
  65. mkdir obj-static
  66. cd obj-static
  67. ../configure --prefix=%{pref} --disable-shared --with-mgl
  68. $MAKE
  69. cd ..
  70.  
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
  74. (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
  75.  
  76. %find_lang wxstd
  77.  
  78. %clean
  79. rm -rf $RPM_BUILD_ROOT
  80.  
  81. %post
  82. /sbin/ldconfig
  83.  
  84. %postun
  85. /sbin/ldconfig
  86.  
  87. %post devel
  88. # Install wx-config if there isn't any
  89. if test ! -f %{_bindir}/wx-config ; then
  90.     ln -sf wxmgl-%{ver2}-config %{_bindir}/wx-config
  91. fi
  92.  
  93. %preun devel
  94. # Remove wx-config if it points to this package
  95. if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
  96.   SUM1=`md5sum %{_bindir}/wxmgl-%{ver2}-config | cut -c 0-32`
  97.   SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
  98.   if test "x$SUM1" = "x$SUM2" ; then
  99.     rm -f %{_bindir}/wx-config
  100.   fi
  101. fi
  102.  
  103.  
  104. %files -f wxstd.lang
  105. %defattr(-,root,root)
  106. %doc COPYING.LIB *.txt
  107. %dir %{_datadir}/wx
  108. %{_datadir}/wx/*
  109. %{_libdir}/libwx_mgl*-%{ver2}*.so.*
  110.  
  111. %files devel
  112. %defattr(-,root,root)
  113. %{_libdir}/libwx_mgl*-%{ver2}*.so
  114. %dir %{_includedir}/wx
  115. %{_includedir}/wx/*
  116. %dir %{_libdir}/wx
  117. %{_libdir}/wx/*
  118. %{_bindir}/wxmgl*-config
  119. %{_datadir}/aclocal/*.m4
  120.  
  121. %files static
  122. %defattr (-,root,root)
  123. %{_libdir}/lib*.a
  124.