home *** CD-ROM | disk | FTP | other *** search
/ OS/2 Shareware BBS: 10 Tools / 10-Tools.zip / wxos2233.zip / wxOS2-2_3_3.zip / wxWindows-2.3.3 / wxGTK.spec < prev    next >
Text File  |  2002-08-20  |  3KB  |  141 lines

  1. %define pref /usr
  2. %define ver 2.3.3
  3. %define ver2 2.3
  4. %define rel 1
  5.  
  6. Summary: The GTK+ 1.2 port of the wxWindows library
  7. Name: wxGTK
  8. Version: %{ver}
  9. Release: %{rel}
  10. Copyright: wxWindows Licence
  11. Group: X11/Libraries
  12. Source: wxGTK-%{ver}.tar.bz2
  13. URL: http://www.wxwindows.org
  14. Packager: Vadim Zeitlin <vadim@wxwindows.org>
  15. Prefix: %{pref}
  16. BuildRoot: /var/tmp/%{name}-root
  17.  
  18. # all packages providing an implementation of wxWindows library (regardless of
  19. # the toolkit used) should provide the (virtual) wxwin package, this makes it
  20. # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
  21. Provides: wxwin
  22.  
  23. # in addition, we should provide libwx_gtk as automatic generator only notices
  24. # libwx_gtk-%{ver}-%{rel}
  25. Provides: libwx_gtk.so
  26. Provides: libwx_gtk-%{ver2}.so
  27.  
  28. %description
  29. wxWindows is a free C++ library for cross-platform GUI development.
  30. With wxWindows, you can create applications for different GUIs (GTK+,
  31. Motif/LessTif, MS Windows, Mac) from the same source code.
  32.  
  33. %package devel
  34. Summary: The GTK+ 1.2 port of the wxWindows library
  35. Group: X11/Libraries
  36. Requires: wxGTK = %{ver}
  37.  
  38. %description devel
  39. Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
  40.  
  41. %package gl
  42. Summary: The GTK+ 1.2 port of the wxWindows library, OpenGL add-on.
  43. Group: X11/Libraries
  44. Requires: wxGTK = %{ver}
  45.  
  46. %description gl
  47. OpenGL add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
  48.  
  49. %package static
  50. Summary: wxGTK static libraries
  51. Group: Development/Libraries
  52.  
  53. %description static
  54. Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
  55.  
  56. %prep
  57. %setup -n wxGTK-%{ver}
  58.  
  59. %build
  60. if [ "$SMP" != "" ]; then
  61.   export MAKE="make -j$SMP"
  62. else
  63.   export MAKE="make"
  64. fi
  65.  
  66. mkdir obj-shared
  67. cd obj-shared
  68. ../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
  69. $MAKE
  70. cd ..
  71.  
  72. mkdir obj-static
  73. cd obj-static
  74. ../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl
  75. $MAKE
  76. cd ..
  77.  
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
  81. (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
  82.  
  83. %find_lang wxstd
  84.  
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87.  
  88. %post
  89. /sbin/ldconfig
  90.  
  91. %postun
  92. /sbin/ldconfig
  93.  
  94. %post gl
  95. /sbin/ldconfig
  96.  
  97. %postun gl
  98. /sbin/ldconfig
  99.  
  100. %post devel
  101. # Install wx-config if there isn't any
  102. if test ! -f %{_bindir}/wx-config ; then
  103.     ln -sf wxgtk-%{ver2}-config %{_bindir}/wx-config
  104. fi
  105.  
  106. %preun devel
  107. # Remove wx-config if it points to this package
  108. if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
  109.   SUM1=`md5sum %{_bindir}/wxgtk-%{ver2}-config | cut -c 0-32`
  110.   SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
  111.   if test "x$SUM1" = "x$SUM2" ; then
  112.     rm -f %{_bindir}/wx-config
  113.   fi
  114. fi
  115.  
  116.  
  117. %files -f wxstd.lang
  118. %defattr(-,root,root)
  119. %doc COPYING.LIB *.txt
  120. %dir %{_datadir}/wx
  121. %{_datadir}/wx/*
  122. %{_libdir}/libwx_gtk-%{ver2}*.so.*
  123.  
  124. %files devel
  125. %defattr(-,root,root)
  126. %{_libdir}/libwx_gtk-%{ver2}*.so
  127. %dir %{_includedir}/wx
  128. %{_includedir}/wx/*
  129. %dir %{_libdir}/wx
  130. %{_libdir}/wx/*
  131. %{_bindir}/wxgtk-%{ver2}-config
  132. %{_datadir}/aclocal/*.m4
  133.  
  134. %files gl
  135. %defattr(-,root,root)
  136. %{_libdir}/libwx_gtk_gl*
  137.  
  138. %files static
  139. %defattr (-,root,root)
  140. %{_libdir}/lib*.a
  141.