
What is ISB
ParaGraph International’s Internet 3D-Space Builder (ISB) lets you easily create 3D worlds and publish them on 
the World Wide Web. Anyone can visit and experience your 3D Web site using standard VRML2.0 browsers. ISB 
adds a new dimension of reality to your Web sites with a complete library of editable 3D shapes. Combined with 
interactive texture mapping ISB brings your 3D space to life. 



What’s new
ISB includes new advanced features that help you work conveniently and quickly. These features include:
· Creating and loading scenes in VRML 2.0. format.
· Creating true 3D scenes with any 3D shapes including spheres, pyramids, and cones, not just vertical or 

horizontal faces.    
· Creating and editing 3D scenes using logical operations (union, subtraction) with basic and custom    shapes. 
· Utilizing rich galleries with standard shapes, textures, pictures, objects and movies. 
· The ability to create custom shapes, textures, pictures, and objects and to save them to libraries.
· Creating and formatting 3D fonts. 
· Drag and drop functionality with automatic "gravity type" arrangement of objects.
· Multimedia attachments (sound, movies), and URL attachments to arbitrary objects.
· Using top and custom vertical views.
· Visual support for a user-defined object hierarchy on the Scene tree. 
· Customizable interface, particularly enhance over the VHSB interface.
· Using 8-bit (256 color mode), 16-bit (high color mode), 24-bit (true color mode) and 32-bit (true color mode 

with advanced lighting) rendering modes.
· Support for Intel's MMX instruction set.
· Optimization of VRML output.



Getting assistance
You can get help without interrupting your work. 
For an explanation of any item such as a menu command, a toolbar button, a dialog box, or a screen item:

·     Click the Help button on the Standard toolbar, and then click the item. Or
· Position the pointer over the menu item and press F1.

For a brief description of a menu command:
· Position the pointer over the command. The description will appear on the Status bar.

For a description of a toolbar button:
· Position the pointer over the button. The name will appear below the button.



Hardware and system requirements
· Operating system: Microsoft Windows 95, Microsoft Windows NT 4.0.
· Computer: 486 or better, Pentium    is recommended.
· Random Access Memory (RAM): minimum of 8 MB.
· Free disk space: 6.5 MB of hard disk space for program files, recommended free space for swap file growing - 

40 MB.
· Display: SVGA/256 colors. The 800x600, high color mode is recommended.
· Mouse and keyboard.
· CD-ROM drive.
· Sound card: optional, Sound Blaster or compatible is recommended.



Installation
The software for ISB is delivered on a single CD-ROM. A setup program creates a new directory and its 
subdirectories on your hard disk and then transfers ISB. 
1 Start Windows.
2 Insert ISB CD-ROM into your CD-ROM drive.
3 Run setup.exe program from the ISB CD-ROM. An ISB Setup splash screen appears.
4 Follow the Setup/Install instructions.

The Setup program automatically creates an ISB program group. 
· Double-click on the ReadMe icon for up-to-the-moment product news.
· Double-click on the Internet3D Space Builder icon to start ISB.
Note:

You may read the ISB QuickStart Guide document by double clicking its icon. 



Uninstalling ISB
To remove the ISB program:
1 Click on the Start button and then point to Settings. 
2 Click on Control Panel, and then double click on the Add/Remove Programs icon .    
3 In the dialog box select Internet 3D Space Builder and click on Add/Remove button.
4 Click on Yes if you want to remove the ISB installation completely. Click    on No if you decided to keep ISB.
Notes:    
n The UninstallShield program deletes all the standard ISB components, standard gallery files and registry 

entries. You must manually remove any shortcuts to ISB you have created elsewhere.
n The UninstallShield program does not delete the elements which you created by yourself in any gallery. The 

corresponding gallery folders are also not deleted. You may use them later with the newly installed ISB.



Technical support
Once you’ve registered your Internet3D Space Builder, you are entitled to free technical support.
You can receive technical support by e-mail info@paragraph.com or by phone.
Before calling technical support, please follow these simple steps:
1 Check QuickStart and On-Line Help. If you can access the WWW, check the ParaGraph Home Page, 

http://www.paragraph.com.
2 Write down any information that could help solve the problem, such as error messages.
3 You should know your system configuration: DOS version, Windows version, CPU type, memory, sound card, 

graphics card, monitor, etc.
4 Please call from your computer workplace, with ISB up and running.

(408) 364-7700
Technical Support is available Monday through Friday, 6AM-6PM Pacific Standard Time.



ParaGraph International Web Site
Visit http://www.paragraph.com on the World Wide Web for the latest information on our company, future product
releases, and as a central location for visiting other ISB 3D spaces. 



Frequently asked questions
· The only format I can save in is VRLM 2.0. I cannot save in .MUS or VRML 1.0 formats.

ISB allows you to save the created    scene only in the VRML 2.0 format. The MUS format (the VHSB format) is 
supported for reading only. That is to say, if you have a scene    in VHSB, you can view and edit it in ISB, but 
cannot save it as a .MUS file again. 

· Even if my resolution is set to high color, it seems to lose that resolution when I go to full screen. 
A full screen scene is displayed in the 256 color mode. High color mode is restored when you come back to any
of the ISB layouts.

· Can ISB read a VRML 2.0 file prepared in any other editor? 
Yes, ISB can read VRML 2.0 files prepared in other editors. If the file contains any sentence not implemented in
ISB that sentence is ignored with warning “This VRML 2.0 feature is not supported”. 

· Will you include interfaces to create script nodes and routes?
Behaviors will be implemented in the next ISB version. The release date is planned for    2Q 1997.

· May    I create my own objects?
Yes, you may create your own objects using ISB and save them in the Object Gallery, or import    the objects 
from the 3D Studio file format. 

· Can I walk through the walls in ISB?
To walk through the walls in the Perspective View window clear the “Collider ”check box under the Tools\
Options\Camera. You can freely navigate a camera through the walls in the Plan window.

· Can I place links to HTML pages or other VRML worlds?
Yes, the HTML links can be attached to pictures, movies and other scene objects. To link a URL, right click the 
object you wish to link in the Scene Tree window, a pop-up menu appears which contains the Link URL option.

· I couldn't find an option to get the split modeling screen for top and side viewpoints. Is there an option 
somewhere that I don't know of?
To simulate a side-view, you can use the Plan wheel located on the bottom of the Plan window.    For example, 
to get the plan left view, rotate the Plan wheel to the right until its next black mark fit the red triangle. You can
rotate the Plan wheel with the mouse.

· Can I make the shape rotation smooth?
Yes, to do this, rotate the shape while holding down the Ctrl key.

· Can I increase or decrease a shape in two directions simultaneously?
Yes, to do this, increase or decrease the shape while holding down the Shift key. 

· Can I increase or decrease a shape in all directions keeping its proportions?
Yes, to do this, press Gray Plus key on your keyboard to increase the shape or press Gray Minus key on your 
keyboard to reduce the shape.

· Can I texture a whole object?
Yes, to texture a whole object, you must texture one of its faces, click on the Spread toolbar button in the 
Camera toolbar, then double click the face in the Perspective View window. The whole object will then be 
textured.



Screen layout
Screen elements can be grouped in a variety of standard and custom layouts. When you launch ISB for the first 
time, the following Normal screen layout appears:

By default, this layout includes Perspective View window, Plan window, Scene Tree window, Texture gallery, Shape 
gallery, Object gallery, Standard toolbar, Edit toolbar, and Plan toolbar. 

Other ISB layouts are the Simple and Professional layouts. The Simple layout is familiar to VHSB    users. The 
Professional layout allows you to build sophisticated scenes using advanced ISB features.



Customizing layout
The following options are supported in customization:
· You can choose different layouts using the Layout menu.
· It is possible to enable/disable various screen elements using the View menu.
· The screen elements can be resized and positioned.
· You can also save custom layouts using the List item feature on the Layout menu.

To choose a layout:
· Choose one of the available layouts from the Layout menu. Three layouts are available by default: Normal, 

Simple and Professional. You may add new layouts to this set.

To add a new, user defined    layout to the set of available layouts in the Layout menu:
1. Customize the screen layout to your desired standards.
2. Choose List from the Layout menu. 
3. In the dialog box choose Add command and specify the name of new layout. 

To resize and change the position of screen elements:
· Drag the window border to set the desired window size.
· Drag the window margin to change its position on the ISB screen.

To customize the toolbars refer to the Customizing Toolbars topic of this help file. 
Notes:
n You may delete the user-defined layout by choosing List/Remove command from the Layout menu. The default

layouts can not be removed.
n ISB saves the layout you used before closing. Thus, restarting the program returns you to the same layout 

type, set of visible windows, their sizes and positions, toolbars, that were in place when you closed the ISB 
session. 

n The scene image in the 3D view window is re-sized together with the window, not clipped. This is similar to 
viewing a real video camera image on TV screens of different sizes: you always see the same image, but re-
sized    to accommodate the screen size.



Working with menus
Working with ISB, you can use the main menu and toolbar commands to create and edit virtual 3D space. Refer 
to the Quick Start Guide documentation Reference chapter for the description of all menu commands. You may 
also use on-line context help for brief description of commands.
Most of the operations in ISB can be performed in several ways: using the Main Menu, clicking on the Toolbar 
buttons, drag and drop operations or the context-dependent pop-up menu commands.
To activate the context-sensitive pop-up menu:
· Right click the item anywhere on the ISB screen. The context sensitive menu appears. This operation, 

achieved    by a double-clicking on the item is displayed in a bold font. Some operations are not available for 
the certain objects and are grayed out. You can get help on each item by selecting it with the mouse pointer 
and pressing F1 button. 



3D Scene
The fundamental notion describing the 3D space you are creating is the scene. It is actually the world you 
create, edit    and see in the Perspective View and Plan windows. All items of your virtual space are inside the 
scene. As a living 3D space, the scene always exists, and you can not delete or resize it.
Every scene may include a “frozen” and the “mobile” parts:
· The frozen part is created by adding shapes directly to the scene. Later you can carve them using other 

shapes from the scene. But when you add a shape directly everything you do in the scene becomes 
unmovable.    You can not move or resize these items in the scene itself. Here is an    example of stone statue 
which illustrates the concept.

· The mobile part of scene consists of objects. Objects can be created by merging and carving with shapes 
which are imported from ISB’s Object galleries, or directly from geometry files like 3DS files. Objects can be 
edited and may include sub-objects, thus forming the Scene tree (object hierarchy). Creating objects and 
establishing the relationship between them, you make the structured scene, containing information about the
world you have created.

· The frozen and mobile parts of the scene are both important for the creation of a 3D world. Read our 
comments on how to use them effectively and keep your virtual world clear and easy for editing.

We recommend you to read these three highlighted topics for a better understanding of the ISB world creation 
concept. 



Example of stone statue
The following example from the real world may help you to understand the concept of a frozen part in the scene.
· Imagine you decide to make a big stone statue somewhere (a 3D scene in ISB). Although you may choose 

any piece of stone, typically you go to some shop (Shape gallery in ISB) and decide what should be the shape
of the piece you would like to buy. After choosing a shape from a set in the shop you have to decide what 
shape dimensions are suitable for your statue. For this, you draw a shape on the plan of your working space 
(include ready shape into scene operation in ISB). You may re-draw it several times, changing shape position, 
orientation, size and proportions (doing the same in ISB), until you make a decision regarding which piece to 
order from the shop.    After the piece of stone (shape) has been moved to the place you specified (Add to 
scene operation), you can not move it, because it is too heavy. For you, it is frozen and all you can do is to cut
a piece from it or add another. You can not re-size the stone or change its proportions in our real world 
through    commands or magic. The same is true for the scene in ISB, with the only one difference: the stone 
may float in the air, but is still too “heavy” to move it.

· Adding a new piece of stone is similar to the above operation. You choose a shape, make a decision about the
position, orientation, etc., and order with which to place it (Add to scene). If the new shape intercepts with 
the existing one, in the real world you would glue the additions to the already existing shape’s faces. The 
glue you use is perfect, so the result is anew, solid piece of stone. After adding the piece, you cannot 
distinguish between    the “old” stone and    the “new” stone. If you place a separate piece of stone 
somewhere near the previous one, it is always too heavy to move it by yourself. In the ISB scene you have 
the same situation. 

· To cut the stone you have to use different tools. First, decide what shape you want to extract from the stone. 
Go to the    workshop (Shape gallery in ISB) and select the tool, suitable to cut the cubic, cylindrical, spherical 
or other shape you would like to carve in the stone. Then you draw it several times (place draft shapes into 
the scene in ISB) on the plan of your statue to define the shape’s position, orientation and proportions. Finally
you use the tool (Extract shape from the scene in ISB) and cut the piece from the stone. In contrast to the 
real world, in the ISB scene you may cut the “stone” into several parts, floating in the air, without being afraid
that they fall down.      

The concept of frozen stones works in the ISB scene. In other words, the ISB program treats the scene as a set of
faces, which do not differ from each other and do not have any history of creation.    The model of frozen stones 
allows you to simplify the structure of the scene file and reduce its size. The more complex concept of a 
Structured scene is described in the next section. 



Structured scene
Construction of complex scenes requires that you    structure the scene. This allows you to have different 
moveable items and to introduce relationships between them. In the    example of stone statue the information 
about scene structure was lost immediately after applying the shape to it. 
Now, imagine that you are creating the statue in the bed of a truck. While you are still unable to change the 
statue, you can move the statue as a whole in the scene space. In ISB terms, you have defined the statue as an 
object, which is now moveable over the scene. The “truck” is not visible in the 3D space, but you can move and 
turn the object in any direction and even re-size it at any time. While some of this capability has no direct 
analogy in the real world, the concept allows you to edit complex scenes easily. 
The bed of the virtual “truck” (object) has similar properties as the scene itself. The building and editing rules for 
the object are the same as for the scene. You may add and extract shapes to/from an object. As in the scene, you
can not resize or move items inside the object separately from each other. The difference is that now you can 
move and resize the entire object and save it in the Objects gallery in order to use it later. 
The items inside the object are the same “frozen stones” as in the scene. However, you may define a “secondary
truck” (sub-object), which can move items over the primary (parent) truck. The rules for creating and editing    
items in sub-object are the same as for its parent object. Further more, you may create third-, fourth-, etc. order 
“trucks” each having the “frozen stones“ structure inside and one or more moveable sub-objects. 
The set of objects form the moveable part of the scene, but this part also has a structure. This means, that each 
object is a sub-object of some parent object or the whole scene and may have sub-objects inside. Such 
relationship is defined by the    following rules:
· When any object is re-sized/moved all its sub-objects and their child sub-objects are re-sized/moved by the 

same factor/distance.
· When any object is saved/deleted, all its sub-objects and their child sub-objects are saved/deleted too. 
· The above two operations, when applied to the sub-object, do not affect its higher level (parent) object.
· Editing of the frozen part of an object does not affect any other object.
· You may change the relationship between the objects freely.
The scheme of relationships between the objects is displayed in the Scene Tree window in a form of a tree. The 
root of a Scene Tree is a scene itself. It may have a number of nodes-objects, and each of them may have sub-
objects. 
The structured scene concept helps you in editing your 3D space. Imagine you are creating the Galaxy (scene) 
with the Sun (object) and the planets (sub-objects) around, among which is the planet Earth with your house 
(third level object of scene tree). Inside the house you may have a table. When you move the Sun, you expect 
that all planets and everything on them move too. You expect also, that the house where you live stay on ground
in the same place while the Earth is moving around the Sun. And you are sure, that changing or destroying the 
table in your house does not destroy the Earth or entire Galaxy. The concept of structured scene tree in ISB helps
you to keep the relationships between objects according to the common sense. 
 Advise on keeping your virtual world clear is located within the next topic.



Keeping the virtual world clear
The model of structured world in ISB is very useful. You may define the structure and the relationship between 
the items in    the virtual world in any way you like. However, it is important to keep your virtual world “clear” : 
the dependencies you introduce must be easy to understand even after    returning to the editing of your virtual 
world several weeks after its creation. Although it may be humorous enough to state that the wind is the result 
of ocean waves, you may forget this joke later and return in your mind to the common concept. The following 
notes may help you to keep the space in order:    
· When using ISB you are creating virtual world, so you do not have to rely on normal rules of reality. You can 

make the Sun a sub-object of the table in your room. However, introducing “strange” dependencies into the 
scene tree makes editing difficult. You may get unexpected transformations of    items or suddenly delete the 
Sun along with your table. We recommend to keep the “native” order of the objects in your virtual world. 

· Although you can make the frozen part of the object complex enough by applying the shapes, we recommend
to create the visually separated items as new objects. Doing so you may easily rearrange them in space and 
in the Scene Tree as well as save them in the Objects gallery separately. 

· Contrary to what is mentioned above, you should try to make items, consisting of several merged shapes as 
a frozen part of single object. In this case the internal, not visible faces of item are destroyed while applying 
the shape, thus simplifying the object structure, reducing the file size and increasing the speed of any VRML 
2.0 viewer. 

· Be careful creating and importing new objects. Always track their position in the Scene Tree. This will help 
you to escape the “strange” dependencies and make your virtual world easy to edit.      



Two modes of a scene construction
ISB has the two main modes for 3D virtual reality construction. They are: the Scene assembling mode and the 
Object editing mode. 
The first - Scene assembling mode, is intended for assembling a scene from the different parts prepared before. 
These parts can be the frozen scene components, different shapes, objects from the Object gallery, pictures and 
movies. In this mode you usually construct the frozen scene parts (using shapes, textures and colors), and then 
place into the scene different mobile parts (objects, pictures and movies) adjusting their size, location, and color 
and texture attributes. In this mode the whole scene is displayed both in the Perspective View and Plan windows.
The Scene assembling mode is the ISB default mode.
The second - Object editing mode, allows you to construct a new object or modify the existing one to use during 
scene assembly.    In this mode only the editing object is displayed in the Perspective View and Plan windows. The
whole scene is returned to display mode after the object editing is finished and the Scene assembly mode is 
restored. The edited object can be saved in the Object gallery, or placed into the clipboard or scene.



Using galleries of ready items in ISB
The ISB compact disk contains not only the executable program, but also a rich collection of pre-built items, 
located in the Galleries of Scenes, Objects, Pictures, Textures and    Movies. 
All    items in the Scene and Object galleries were built with ISB. You may load the ready scenes to see the 
capabilities of ISB. While viewing the scenes, you may also see their internal structure in the Scene Tree window. 
Note, that most of the scenes contain both the frozen and the mobile parts (objects). Explore the scene structure
to learn more about how to build your own scenes.
The items in the scenes of the Scene gallery are painted with colors and textures. However, all scenes are also 
saved as non-colored objects in the Examples category of Object gallery. So, if you want to start building your 3D
space with the ready-made “house” you may place the corresponding object from the Object gallery into your 
new scene and apply the colors and textures to its faces in any way you like.    
Aside from the Examples category, the Objects gallery also contains two more ready categories: Furniture and 
Plants, which are the collection of 3D furniture items and plants. You can also find on the ISB compact disk two 
samples of 3D models created by 3Name3D/YWD, Inc. and Acuris, Inc. All items are already colored and can be 
included into any scene.



How does ISB store the files of galleries 

The way, in which the ISB program stores and saves the contents of its galleries (resources), depends on the 
type of installation:
· For a Typical installation, the files of all galleries are copied and stored in the correspondingly named sub-

directories of the main ISB directory on your hard disk. For the galleries, which are divided into several 
categories, all items are saved into the sub-directory of the gallery directory. 

· Using the Compact installation, all files from the galleries, except the Shape gallery are stored on the 
compact disk.

· With the Custom installation you may choose the galleries, and therefore which files will be copied to the 
hard disk. 

Note:
All newly created or edited items (Scenes, Objects, Pictures, Textures and Movies) are saved in the sub-
directories of the ISB directory, regardless of the type of installation of the ISB program. So every time when 
you edit an item, the corresponding file with modified item is copied to the gallery’s sub-directory on your hard
disk.    



Phases of building the virtual space
The ISB compact disk contains an example of phased building - a virtual 3D house. Look in the directory ISB\
Scenes\Phases for files Phase1-6.wrl. These scenes illustrate the process of building a virtual home. The final 
project is presented in the main Scenes gallery with the name Los Gatos. Phases 1 to 6 show the structure as it 
gets more and more complex by adding more faces to the frozen part of    the scene. More cameras are added for
viewing the scene, and later one object is added as an example of a mobile part of the scene. Look at the phases
for a better understanding of the scene building concept.    
Related topics:
{button ,JI(`Isb.HLP>(w95sec)',`Scene')}    Main scene parts
{button ,JI(`Isb.HLP>(w95sec)',`frozen_stones')}    Frozen part of scene description and example
{button ,JI(`Isb.HLP>(w95sec)',`Structured_scene')}    Structured Scene description and    example



Create a new scene
To create a new scene:

·     Click New on the Standard toolbar or choose New from the File menu. A new scene is created. All its 
parameters, such as camera position, grid spacing, etc. are set by default. 

Each new scene can be empty or contain a ground plane. To choose a ground plane for a new scene:
1 Choose Options from the Tools menu. A dialog box appears.
2 Click on the General tab. 
3 Select the ground plane of your choice from the Initial ground menu or choose None if you don’t want a to 

establish a ground plane.
Note:

You have to choose a ground plane for a new scene before you create this scene using New command.



Open an existing scene
You can open a scene from a file or choose one from the Scene gallery. 

To open a scene from a specified file:

·     Click the Open button on the Standard toolbar or choose Open from the File menu. A new scene is 
opened and is shown in the Perspective View window. The plan is displayed in the Plan window.

Note:
The following formats are supported: VRML 2.0 and MUS (the VHSB format). If a scene in the VRML 2.0 format 
contains data on a camera’s position, it is placed in this position or at the scene coordinate system origin by 
default. The scene in the MUS format does not contain information on the camera’s position, and the camera 
assumes the default position.

To choose a scene from the Scene gallery: 

1  Click the Choose button on the Standard toolbar or select Choose from the File menu. The Scene gallery 
is displayed. 

2 Look through the gallery to find the required scene.
3 Double click the desired scene or drag it to the Plan or Perspective View window. The scene is opened and 
is shown in the Perspective View window. Its plan is displayed in the Plan window. 



Save a scene
To save a new, unnamed scene:

1     Click the Save button on the Standard toolbar or choose Save from the File menu. A dialog box for the 
file name appears.

2 Specify a file name for your scene.
To save the scene in a location other than the default ISB Scenes directory, click a different drive name or directory 
name. For example, if ISB is installed in C:\ISB, its default scene directory is C:\ISB\Scenes. The scenes located in 
the ISB scene directory are automatically included into the Scene gallery. 
In the File Name box, type a name for the document.

3 Select the VRML 2.0 item in the Save as type list box to save the scene in the VRML 2.0 format or choose the 
VRML 2.0 compressed item to save the scene in the VRML 2.0 compressed (gzip) format. Note that both 
options create the files with the same extension .wrl. Compressed file format is automatically identified by 
VRML 2.0 browsers.

4 Click Save.

To save an existing scene: 

·  Click Save on the Standard toolbar or 
· Choose Save on the File menu or 
· Drag the scene from the Scene Tree window to the Scene gallery. 



Control cameras
Cameras are used to view a scene in the Perspective View window. Any number of cameras can be used. Only 
one camera can be active at any time. A scene is viewed through the active camera. Each camera is represented
in the Plan window with the Pinocchio icon .
In a 3D scene, a camera has six degrees of freedom. You can move it in X,Y, and Z directions. You can also 
change its orientation: 
· Yaw - it appears as if you are turning your head to the left or to the right.
· Pitch - it appears as if you are lifting your head up or drop it down.
· Roll - it appears as if you are inclining your head to the left or to the right.
The camera’s movement and orientation are reflected in the Plan window. During the movement and rotation of 
the active camera, the view in the Perspective View window changes accordingly. 



Navigate cameras in the Plan window
To move a camera along a plan: 

·     Position the pointer over the Pinocchio icon. The pointer looks like a camera. 
· Drag the Pinocchio icon in the desired direction.

Note: 
You may navigate the camera through walls while moving in the Plan window.

To change a camera’s orientation: 

·     Position the pointer over the Pinocchio icon. The pointer looks like a camera.
· Rotate the Pinocchio icon tip with your mouse (yawing in the Top View window, pitching in the Front View 
window).

To place a camera in a required position:
· Double click on the desired position in the Plan window. The active camera moves to that location. Its position 

is changed in the Top and Front View windows.    



Navigate active camera in the Perspective View window
To control the active camera in the Perspective View window:
· Click anywhere in the Perspective View window. Now you can move and rotate the active camera using the 

mouse or keyboard.

To control the active camera using the mouse in the Scene assembling mode:
· Move the mouse in the desired direction while holding down the left mouse button: 

Forward - move closer Shift+forward - move up Ctrl+forward - turn up 
Backward - move 
further

Shift+backward - move 
down

Ctrl+backward - turn 
down 

Right - turn to the 
right

Shift+right - move to the 
right

Left -    turn to the left Shift+left - move to the 
left 

To control the active camera using the mouse in the Object editing mode:
· Move the mouse in the desired direction while holding down the left mouse button: 

Forward/Bacward
- move camera 
closer/further to 
the current 
object

Shift+forward/
Shift+backward - move 
camera around the object in
the vertical plane

Ctrl+forward/
Ctrl_backward - turn 
camera up/down 

Right/Left - move
camera around 
the object in the 
horizontal plane

Shift+right /Shift+left- turn 
camera to the right/left in 
the vertical plane

Ctrl+right/Ctrl+left - turn 
camera to the right/left

· Double clicking on a face in the Perspective View window directs the active camera to the face and brings it 
closer to the scene.    

 
To control the active camera using a keyboard:
· Arrow Up - move closer; 
· Arrow Down - move further; 
· Arrow Right - move to the right;
· Arrow Left - move to the left;
· PgUp - turn to the right;
· Home - turn to the left;
· Gray Plus - move up;
· Gray Minus - move down;
· 1 on the alphanumeric keyboard - incline to the left;
· 2 on the alphanumeric keyboard - incline to the right;
· 3 on the alphanumeric keyboard - turn up;
· 4 on the alphanumeric keyboard - turn down;
· T - increase a focal length;
· W - decrease a focal length.

To accelerate the camera’s movement/rotation:
· Press Shift and one of the above keys simultaneously. 
Note: 

You may not move a camera through walls while moving in the Perspective View window while the “collider” is 
on. To turn the collider on/off:

· Choose Options from the Tools menu
· Mark the Collider check box to turn the collider on or clear the check box to turn the collider off.





Navigate active camera in the Ruler window

    The active camera is controlled in the Ruler window by using the Camera icon. 

This icon has a handle with two rings: the left one is used to move the camera, the right one to change the 
camera’s orientation. You can also change the focal length of the camera’s view.

To control the active camera in the Ruler window:

·     Position the pointer over the Camera icon.    The camera picture appears below the pointer.

To move the active camera up or down:
· Drag the Camera icon using the left ring

To turn the active camera up or down:
· Drag the Camera Icon using the right ring.

To change a focal length of the active camera:

·     Click More Tele button on the top of the Ruler window to increase the focal length.

·  Click More Wide button    on the top of the Ruler window to decrease the focal length.



Align cameras
To position the camera’s horizontal axis parallel to the scene horizontal:

·     Click Align Horizontal on the Camera toolbar or choose Align Horizontal on the Camera menu. 

To position the camera’s longitudinal axis parallel to the scene horizontal:

·     Click Align Vertical    on the Camera toolbar or choose Align Vertical on the Camera menu. 



Duplicate cameras
To duplicate a camera do one of the following:
· Double click the camera icon in the Plan window. 

·  Click Duplicate on the Camera toolbar.
· Choose Duplicate on the Camera menu.
· Drag and drop the camera into another object in the Scene Tree window while holding down the Ctrl key. 

The new camera has the same location and orientation as the one you’ve just duplicated. 



Set active camera
To set an active camera do one of the following:
· Click the corresponding Pinocchio icon in the Plan window.
· Double click the camera name in the Scene Tree window.
· Click the camera tab in the Perspective View window with the name of camera to be activated.
The Pinocchio icon of the active camera is colored red in the Plan window. Its icon in the Scene Tree window is 
marked with a red box. The camera name in the Perspective View window camera tab is shown in bold font.



Rename cameras
To rename a camera:
1 In the Scene Tree window, right click the name of the camera you want to rename, and after a pop-up window 

appears, choose Rename. Or, in the Scene Tree window you can click twice the name of the camera you want 
to rename. Or, in the Perspective View window you can double click the camera tab. The edit box for the 
camera name appears.

2 Enter the new camera name and press Enter.
Note:

The Free camera is assumed to belong to the scene. This camera cannot be removed. 



Delete cameras
To delete a camera:
1 Right click the Pinocchio icon  in the Plan window or right click on the camera’s name in the Scene Tree 

window. A pop-up window appears.
2 Choose Delete.
Note:

The Free camera is assumed to belong to the scene. This camera cannot be renamed. 



Construct scene
ISB enables you to build a scene with complex shapes, rather than with individual polygons. 
A shape is the basic unit for a scene construction. A shape represents a solid object. It can be as simple as a 
rectangle, or a cone, or it can be as complex as an entire scene. ISB allows you to easily manipulate shapes of 
any size.
The construction process consists of three steps:
· Including a shape into scene. As a result, a draft of the shape is shown in the Top View, Front View and 

Perspective View windows. The scene is not changed.
· Adjusting shape size, position, and orientation with the help of the Shape manipulator. 
· Applying the shape to the scene using the Add, Extract, Cut or Copy    operation . When this step is completed, 

the scene is changed. 
A shape may be taken from the Shape gallery or built on the fly. 

Related topics:
· Include ready shapes into a scene.  
· Include shapes created on the fly.  



Include ready shapes into a scene
To include a ready shape into a scene:

1  Click Build Mode on the Plan toolbar. The pointer 

 looks like an arrow with a hammer near it.

2  Drag the shape into the Top View window. The pointer looks like a shape with an arrow while 
dragging it.
Or, you may click the shape in the Shape gallery and draw a bounding box for it in the Plan window. 

Note: 
To draw a box, click anywhere in the Top or Front View window, then hold down the left mouse button, draw a 
box and release the button. 

TIP:
n To replace a shape, double click another shape in the Shape gallery. You may do this only when a shape is 

included into, but not yet applied to the scene (Add, Extract, Cut or Copy    operations have not yet been 
made).

n A draft shape changes if you accidentally click somewhere in the Plan window while moving your mouse: the 
shape bounding box and the shape manipulator are replaced with the new ones located in the place where you
last clicked. To remove this shape from the scene press Esc. 



Include shapes created on the fly
You can create shapes on the fly using a polygon or closed curve inscribed into the polygon. 
To create a shape using a polygon and to include it into a scene:

1  

    Click Polygon Mode on the Plan toolbar. The pointer looks like a polygon with an arrow.
2 Specify polygon vertexes in the Top View window. 
To specify a vertex, click somewhere in Top View window. A new vertex with edges connecting it to its neighbors are 
created. 

    To move a vertex - drag the vertex onto another place.
To insert a new vertex between the existing ones - click between them, the edge connecting the two vertexes is 
deleted, a new vertex is inserted, and two new edges are created. 
To delete a vertex - right click on it and when a pop-up menu appears, click the Delete Vertex item.

3 Click either Solid  , Walls 

 , Room 

 , or Pyramid 

 button on the Edit toolbar depending on the shape you want to create. The walls, ceiling and floor have default
thickness. To change default thickness, use Options on the Tools menu. 

To get an opportunity of using a closed curve include    the Spline Mode button into the Plan toolbar, and Increase
Granularity, Decrease Granularity, Increase Tension and Decrease Tension buttons into the Edit toolbar using the 
Customize item on the Options menu.
To create a shape using a smooth curve and include it into a scene:

1  

 Click Spline Mode on the Plan toolbar. The pointer looks like a smooth loop.
2 Specify polygon vertexes in the Top View window. 
To specify a vertex, click somewhere in the Top View window. A new vertex with edges connecting it to its neighbors 
is created. The smooth curve inscribed into the polygon is displayed:

To move a vertex - drag it into another place.
To insert a new vertex between the existing ones - click between them, the edge connecting the two vertex is 
deleted, a new vertex is inserted, and two new edges are created. 
To delete a vertex - right click on it and when a pop-up menu appears, click the Delete Vertex item.

4 Click either Solid  , Walls 

 , Room 

 , or Pyramid 

 button on the Edit toolbar depending on the shape you want to create. The walls, ceiling and floor have default
thickness. To change default thickness, use Options on the Tools menu. 

TIPS:
If you want polygon vertexes to snap to the grid cells complete the following before creating a new shape. 

n Choose Options on the Tools menu and, after a dialog box appears, check the Active grid item on the Plan tab.
To change the curve smoothness: 

n     

    Click the Increase Spline Smoothing or Decrease Spline Smoothing button.    



To draw the curve closer to the polygon vertexes: 

n     

    Click the Increase Spline Tension or Decrease Spline Tension button.



Set shape position, size, and orientation
Click on the picture below to get the explanation of Shape Manipulator controls. 

To set a shape position:

·  Drag the Shape Manipulator’s moving point. The moving point coordinates are seen on the status bar
while moving. To move the box in the horizontal direction, use the front view Shape Manipulator. To move the 
box in the vertical direction, use the top view Shape Manipulator.

To set a shape size:

·  Drag the Shape Manipulator’s resize jack. Three values that specify the shape’s bounding box are 
shown on the status bar. The first and second values are the coordinates of the bottom left corner of the 
bounding box. The third value is the bounding box size in the direction defined with the lever. To define a 
shape’s horizontal dimensions, manipulate the top view resize jack. To define a shape’s vertical dimensions, 
manipulate the front view resize jack.

To set a shape orientation:

·  Drag the Shape Manipulator’s lever. To rotate the box in the horizontal plane, rotate the top view. To 
rotate (incline) the box in the vertical plane, rotate the front view.

To skew a shape:
· Drag the Shape Manipulator’s moving point while holding down the Shift key. The center of the shape’s 

bounding box will drag with your pointer’s movements. The bottom of the shape remains unchanged.

To achieve smooth shape rotation: 
· Hold down the Ctrl key while rotating.

To resize a shape in all dimensions at once:
· Press Gray Plus to increase the size of the shape or Gray Minus to decrease the size of the shape. 



Apply shapes to scene
You can use Add, Extract, Cut or Copy operations to apply a shape to a scene. If you define the scene structure 
using objects, please take into consideration that a shape is applied not to the whole scene but to the current 
object only.    
After part of the scene is brought onto the clipboard using the Cut or Copy operations, it can be pasted 
elsewhere in any scene. 

To add a shape to a scene:

·     Click Add on the Edit toolbar or choose Add Shape on the Object menu.

To extract a shape from a scene:

·     Click Extract on the Edit toolbar or choose Extract Shape on the Object menu.

To cut part of a scene onto the clipboard:

·     Click Cut on the Standard toolbar or choose Cut on the Edit menu. 

To copy part of a scene onto a clipboard:

·     Click Copy on the Standard toolbar    or choose Copy on the Edit menu
Note: 

The Extract, Cut and Copy operations are not available to the Room and Walls shapes and to convex custom 
shapes. 

To paste part of a scene from the clipboard do one of the following things:

·     To paste it onto the scene coordinates origin, click Paste on the Standard toolbar    or choose Paste on 
the Edit menu.

· To paste it onto a particular place of a scene, right click the chosen site in the Perspective View or Plan 
window. After the pop-up window appears, choose Paste.



ISB limits
Several restrictions exist regarding the size of scenes and shapes, and the scale of a plan. 
Maximum size of a scene: 1000 m (1km).
Minimum size of a shape: 0.01m (1cm).
Minimum scale of a plan: 0.001 m/pixel (1mm/pixel).
Maximum scale of a plan: 10m/pixel.



Create custom shapes
ISB can remember the steps made during a scene construction and repeat them to create a custom shape in the 
Shape gallery. You can construct a new shape using ready made shapes from the Shape gallery or from shapes 
built on the fly. 

To record and create a custom shape:

1       Choose Record Shape from the Object menu. The pointer looks like a cassette tape with a hammer 
and an arrow.

2 Create a custom shape.    
3 Choose Stop from the Object menu. The sequence of operations between the Record Shape and Stop 
commands is retained. The dialog box for custom shape specification appears.
4 In the field Name specify the name of the file for the new shape.
5 In the field Title specify the gallery name of the shape.

6 In the field Category specify the name of the tab in the Shape gallery where you want to save your shape. You 
can define a new tab name or use the existing one. 



Control shape heights
Each shape you include into a scene is assigned a default size and position. You define default height using the 
guide lines of the Front View window. After a shape is included you can change its position and size with the help 
of the Shape manipulator. The top view Shape manipulator is used to control the shape’s horizontal dimensions 
and position while the front view Shape manipulator is used to control the shape’s vertical dimensions and 
position. 
If you have    an experience of constructing scenes with VHSB and prefer to work without the front view, you can 
use the Ruler window. Here you control the height and vertical position of a shape with the help of the Ruler’s 
latches and Guide lines shown in the Ruler window. 

To turn the Ruler window on/off:

·     Click Ruler on the Edit toolbar. The Ruler window is displayed when the Ruler button is pressed. The 
Ruler window is hidden if the Ruler button is not pressed.



Set shape’s default height

The default height of a shape (when included into the scene) is set using the Guide lines shown in the Front View 
and in the Ruler window. The top guide line defines the vertical position of the top face of the shape bounding 
box. The bottom guide line defines the vertical position of the bottom face of the shape bounding box. 

To turn Guide on/off:
1 Right click anywhere in the Plan window. A pop-up menu appears.
2 Check Guide to turn the Guide on or clear it to turn the Guide off.

To see the guide line height and the distance between the two guides:

1     Position the pointer over the guide line for a height description. A guide line crossed with a double 
arrow appears near the pointer.

2 Click the line. Its height and the distance between the two guides are shown on the status bar. All values 
are given in meters. 

To move a guide line:

1     Position the pointer over the guide line to be moved. A guide line crossed with a double arrow appears
near the pointer.

2 Drag the guide line up or down. The line’s height and the distance between the two guides are shown on 
the status bar. All values are given in meters. 



Change shape heights
Two Rulers can be shown in the Ruler window:
· The gray Ruler corresponds to the shape currently included into a scene but not yet applied. With the help of 

the gray Ruler you can set the height for this not yet applied shape. 
· The red Ruler corresponds to the current scene object. With the help of the red Ruler you can change the 

height of the current object.
The top latch of the gray Ruler defines the position of the top face of the shape bounding box. The bottom latch 
of the Ruler defines the position of the bottom face of the shape bounding box. 

To move the Ruler’s latches:

·     Position the pointer over the latch. The pointer looks like an arrow and a hammer. 
· Drag the latch up or down. 



Scroll the Ruler
There are two ways to scroll the ruler: You may scroll the Ruler smoothly or move it by half a point.

To scroll the Ruler smoothly:
· Hold down the left mouse button somewhere in the Ruler window and drag it up or down. The Ruler is scrolled 

in this direction.

To scroll the Ruler by half a point:

· Click Scroll Up     in the Ruler window to scroll the Ruler up, or click Scroll Down    

 to scroll it down. The Ruler is scrolled by half a point in the desired direction.



Split the Plan window
To split the Plan window when it shows the Top View only:

1     Position the pointer over the splitting box in the upper right corner of the top view. The pointer looks like 
a double line with two arrows.

2 Drag down the splitting box. The Plan window is spliced, and the front view window is displayed. 

To change the Plan window splitting:

1     Position the pointer over the splitting line of the Plan window. The pointer looks like a double line with 
two arrows.

2 Drag the splitting line up to make Top View smaller and Front View larger or drag it down to make Top View 
larger and Front View smaller. 



Turn the Grid on/off
The Grid is shown in the Plan window by default. 

To turn the Grid on/off:
1 Right click anywhere in the Plan window. A pop-up menu appears.
2 Check Grid to turn the Grid on or clear it to turn the Grid off.



Rotate a plan    
To rotate a plan you should rotate the Plan wheel shown on the bottom of the Plan window. You can rotate the 
Plan wheel with your pointing device. The rotation angle is shown on the status bar. Each point of the Plan wheel 
is equal to 6 degrees. Rotation of the wheel to the next longer mark corresponds to a rotation by 30 degrees. 
Rotation of the wheel to the next bold mark corresponds to a rotation by 90 degrees. 
To rotate a plan: 
1 Position the pointer to the Plan wheel, then hold down the left mouse button.
2 Rotate the Plan wheel by moving your mouse in the opposite direction desired to rotate the plan. For example, 

for the left plan view, rotate the Plan wheel to the right until its next black mark fits the red triangle. 
3 Release the mouse button. 
Note: 

To get a smooth rotation hold down the Ctrl key while moving the mouse.

To restore the plan and Plan wheel initial positions:
· Double click the wheel. The rotation angle shown on the status bar is equal to zero.



Scroll a plan (pan the view port)
Besides scrolling a plan using the ordinary scroll bars of the Plan window you may also use the Moving Plan 
mode. In this mode both views are scrolled at once by moving your mouse.

To move plan views:

1  Click Moving Plan on the Edit toolbar.

2  Position the pointer anywhere on the Plan window. The pointer looks like an arrow with a hand below
it. 
3 Hold down the left mouse button and move the mouse in the direction desired. Both plan views are moved 
simultaneously.
4 Release the mouse button. The Moving Plan mode is turned off. The Build mode is restored.



Zoom of plan
To increase view magnification:

·     Click Zoom In on the Plan toolbar. The two plan views magnification is increased. 

To reduce view magnification:

·     Click Zoom Out on the Plan toolbar. The two plan views magnification is reduced. 

To magnify a selected part of a plan:

·     Click Zoom Mode on the Plan toolbar to turn on the Zoom mode. In this mode you can select a particular
area in the top or front view to zoom in on. 

·     Select an area to zoom in on. To select an area, hold the left mouse button anywhere in the Plan 
window, draw a corresponding rectangle, then release the button. The area is immediately magnified in both views.

Note: 
The grid can be hidden as a result of zooming.



Fit a window to a scene
To make both scene views fully visible in the Plan window:

·  Click Fit to Scene on the Edit toolbar. 
Note: 

If only one view is displayed then only that view is fitted to the window. The scene may not fit in the other view
when it becomes visible.



Print a plan
To print both plan views:

·     Click Print on the Standard toolbar or choose Print on the File menu.
Note: 

The printer output should look the same as the current Plan Window configuration, including the presence and 
relative size of    top and front views.    



Using colors and textures

The following options are supported:
· You can texture or paint on all faces of a shape directly when it is applied to a scene. 
· After a shape or an object is applied, it is possible to change the texture or color of any of its particular faces 

or of all the faces at once.    
· Color or texture can be spread from one face to others. 
The textures are selected from the Texture gallery, the colors are selected from the Color toolbar.

To display the Texture gallery:
· Click on    the Textures item on the View menu.

To display the Colors toolbar:
1 Click Toolbars on the View menu. The Toolbars dialog box appears.
2 Click on the Colors checkbox. The Colors toolbar appears.
TIP:

·     To quickly display the Colors toolbar click Fill on the Camera toolbar. 



Applying the default texture 
In the Automatic Texturing mode the texture selected in the Texture gallery is automatically applied to the whole 
shape. When the shape is applied to a scene with the Add or Extract operations, all faces are textured with 
selected texture. When this mode is turned off, the faces are painted in the color selected on the Color toolbar.
To turn on/off the Automatic Texturing mode:

·     Click Use Texture button on the Edit toolbar. The Automatic Texturing mode is turned on if the button is 
pressed. It is turned off if the button is released.



Apply    textures
To texture a face:
1 Look for the texture you want in the Texture gallery. To open another texture category, click its tab on the tab 

strip of the Texture gallery window. 
2 Drag the texture to the face in the Perspective View window.

To texture all faces of the object simultaneously:
1 Look for the texture you want in the Texture gallery. To open another texture category, click its tab on the tab 

strip of the Texture gallery window. 

2  Make sure that Use Texture on the Edit toolbar is pressed. 

3  Click Fill on the Camera toolbar. 
4 Click the texture of your choice.
5  Move the pointer into the Perspective View window. It looks like a pail. 
6 To texture only one face, click the face in the Perspective View window. The face is textured. To texture the 
whole object double click any of its faces. The whole object is then textured.

Notes: 
n When an object is textured, its sub-objects are not changed. 
n If the Texture Mapper window is displayed when faces are textured using the Fill button, the texture is taken 

from the Texture Mapper, not from the Texture gallery. 
n If the object to be textured via double clicking its face, consists of several separated parts, then only one part 

is textured. You have to repeat this operation for each separate part of the object to texture the entire thing. 



Set    colors
To color a face:
1 Make sure that the Color toolbar is displayed. 

2  Drag the color from the Colors toolbar to the face in the Perspective View    window. The pointer on the 
face in the Perspective View window looks like an arrow with “+” sign and a rectangle filled by the current 
color. 

To color all faces of the object simultaneously:

1     Make sure that Use Texture on the Edit toolbar is not pressed in. 

2  Click Fill on the Camera toolbar. 
3 Click the desired color on the Colors toolbar.
4  Move the pointer into the Perspective View window. It looks like a pail. 
5 To color only one face, click the face in the Perspective View window. The face is colored. To color the whole
object double click any of its faces. The whole object is colored.

Note: 
When an object is painted, its sub-objects are not changed. 



Spread    textures and colors
To spread a texture or color from one face to the others:

1  Click Spread on the Camera toolbar.
2 Position the pointer over the face with the required texture or color in the Perspective View window. 
The pointer looks like a brush. 
3 Hold the left mouse button.
4 Drag the texture or color through all faces to be applied.

To spread a    texture or color over the whole object:

1  Click Spread on the Camera toolbar.
2 Position the pointer over the face with the required texture or color in the Perspective View window. 
The pointer looks like a brush.
3 Double click the face - all other faces of the object are textured or colored.



Set    pictures/movies onto a face
To set a picture/movie onto a face:
1 Look for the picture/movie in the Picture/Movie gallery.

2 Drag the picture/movie to the face. The pointer looks like a picture/movie with name and an 
arrow.

Note: 
Pictures and movies are not shown on the scene plan.



Specify movies play order
Each movie can be played forward, backward or in turn: forward - backward, forward - backward, etc. 

To specify the movie play order:

1     Position the pointer over the movie you want in the Perspective View window. The pointer looks like a 
picture with an arrow.

2 Right click on the movie. A pop-up menu appears.
3 Click Play order.    A pop-up menu with available modes of play appears.
4 Click Forward to play the movie in the forward direction, click Backward to play the movie in the backward 
direction, click Ping Pong to play in turn.



Copy pictures/movies
You can have several copies of picture/movie in a scene. You can make a copy using the Picture/Movie gallery or 
by using the Scene Tree window.

To copy a picture/movie using the Picture/Movie gallery:
· Put it into the scene once more.

To copy a picture/movie using the Scene Tree    window:
1 Look for the picture/movie name in the Scene Tree    window. 

2  Drag the name to the Perspective View window while holding down the Ctrl key.
The pointer looks like an arrow with a small picture near it when been dragged over the scene parts where the 
picture can be placed.



Change    pictures/movies location
You can change a picture/movie location in a scene by dragging it through the Perspective View window or by 
dragging its name from the Scene Tree window. 
To change a picture/movie location using the Perspective View window: 

1     Position the pointer over the picture/movie in the Perspective View window. The pointer looks like a 
picture/movie with an arrow. 

2 Drag the picture/movie in the direction desired. 

To change a picture/movie location using the Scene Tree window: 
1 Look for the picture/movie name in the Scene Tree window. 

2  Drag the name to the desired location in the Perspective View window. The pointer appears like 
an arrow with a small picture near it when being dragged over the scene parts where the picture can be 
placed.



Resize pictures/movies
To resize a picture/movie:

1     Position the pointer over the upper right corner of the picture/movie in the Perspective View window. 
The pointer looks like a picture with two arrows.

2 Drag the upper right corner of the picture/movie to achieve the desired size.



Delete pictures/movies
To delete a picture/movie:

1  Position the pointer over the picture/movie in the Perspective View window. The pointer looks like a 
picture with an arrow.

2 Right click on the picture/movie. A pop-up menu appears.
3 Click Delete. The picture/movie is deleted.



Use objects
You can take a ready object from the Object gallery or construct your own object entering the Object editing 
mode. You can also import objects made with Autodesk 3D Studio.



The Scene tree
The Scene Tree.  presents the information about a scene structure. 
The Scene Tree is very similar to a genealogical tree. The Scene Tree root node represents a whole scene. Each 
tree node represents an object, picture or movie. Each node can have any number of child nodes (sub-objects). 
Each node, with the exception of the root node, has a parent. 
The operations of changing position, size and orientation applied to the current object are automatically applied 
to its sub-objects too. So that when a house is moved or re-sized its furniture is moved also. 
Notes: 
n The scene is your world, and like the real world we can’t move, resize, or turn it. This means that there are no 

Object manipulators for the scene, and that you may not change its heights using the Ruler. You also cannot 
apply the Cut, Copy, and Delete operations to the whole scene. 

n Pictures and movies appear in the Scene Tree under their gallery names. 



Select objects
To manipulate an object you should select it in the Perspective View, in the Scene Tree, or in the Plan window.
Note: Pictures and movies can be selected only in the Scene Tree window.    

To select an object in the Perspective View window:

·     Click the object. The selected object is marked with a yellow bounding box.

To select an object in the Scene Tree window:
· Click the object’s name. The name of the selected object is highlighted.

To select an object in the Plan window

1  Click Object Mode in the Plan toolbar    and move the pointer into the Plan window. The pointer should look
like an arrow with a house near it.

2  Double click one of the visible edges of an object. Both views are shown in red.

The selected object is displayed in the following manner:

·     In the Perspective View window the object is marked by a yellow bounding box.

·  In the Scene Tree window the object’s name is highlighted.

·  In the Plan window the object’s views are red. Its sub-objects appear in magenta.
Note: 

When the whole scene is selected there is no yellow bounding box in the Perspective View window. All scene 
objects are indicated by the color magenta in the Plan window.



Create objects
To create a new object:

1  Click New Object on the Edit toolbar. The Object editing mode is entered. The default name for the object 
appears in the Scene Tree. It becomes the sub-object of the current object.

2 Construct an object using shapes. All operations described in the scene construction chapter are valid for 
objects too.



Saving current object
To save the current object:
1 Click Save on the Object menu. The pop-up menu appears.
2 In the field Name, define the name under which the object will be displayed in the Object gallery.
3 In the field Category, define the name of the gallery where the object is to be included.
4 Click OK.

To save an object in the current Object Gallery:
· Drag the name of the object from the Scene Tree window to the Object gallery. The object is copied into the 

specified gallery.



Print current object
To print the current object:
· Click Print on the Object menu. 



Deleting objects
To delete an object:
1 Select the object to be deleted.
2 Choose Delete on the Edit menu or press Del key. 



Renaming objects
To rename an object:
1 Right click the object name in the Scene Tree window. When the pop-up window appears choose Rename. You 

may also click on the object name in the Scene Tree window. An edit box for the object name appears.
2 Enter the new name and press Enter.



Get object info
To get information about an object:
1 Right click the object in the Scene Tree window.
2 Choose Info in the pop-up menu. The window describing the object appears. 



Move and copy objects into another place in scene
To transfer an object to another scene place: 
1 Click the object name in the Scene Tree.
2 Drag the name to the desired location in the Perspective View window. The object is placed in the new 

location. 

To copy an object to another scene place: 
1 Click the object name in the Scene Tree.
2 Drag the name to the desired location in the Perspective View window while holding down the Ctrl key. A copy 

of the object appears in the pointed place. 
Note: 

The object rests against a face. So that it will not appear in the air or under a face.



Move and copy objects into another hierarchy level
To move an object:
· Drag its name to the name of the object you want to make a parent - drag until the parent’s name becomes 

highlighted.



Fitting windows to objects
To make object views visible in the Plan window:

·  Click Fit to Object on the Plan toolbar.
Note: 

If only one view is displayed, only this view is fitted. The other one is not changed.



Edit objects
You can edit objects in the Scene Assembling and Object Editing modes. 
It is convenient to edit an object in the Scene Assembling mode if you want to adjust its size or orientation 
relative to the other components in the scene. For example, you would use this mode to make two tables of the 
same height. The edited object is not saved automatically in the Object gallery. You must save it by yourself 
using the procedure described in the Save current object section. 
Note:

In the Scene Assembling mode the results of an Add or Extract operation are saved. The rotation, scaling and 
skewing modifications are not saved. 

The Object Editing mode allows you to create a new object or completely modify the existing one. The object is 
automatically saved in the Object gallery or placed into the scene or clipboard. All modifications including 
rotation, scaling and skewing are saved.



Editing objects in the Object Editing mode
To enter the Object editing mode do one of the following:
· Choose Edit on the Object menu to edit the current scene object
· Choose New on the Object menu to create a new object
· Double click an object in the Object gallery to edit the selected object

·  Click New Object on the Edit toolbar 

·  Click Object Edit button on the Edit toolbar to edit the selected object.
The Perspective View and Plan windows are cleared. The selected object is displayed for editing.    

To edit the object you can use the Object manipulator, the Ruler, and shapes.
After the editing is finished:

1       Click the Object Edit button or choose Back to Scene on the Object menu. The dialog box appears that 
allows you to specify where to save the object. 

2 Check mark Scene to place the object into the scene. Check mark Clipboard to place the object into the 
clipboard. Check mark Object gallery to place the object into the Object gallery, specify the name of the object, and 
place it into a gallery category. 
3 Click OK.



Changing size, position and orientation using the Object manipulator

To display the Object manipulator:
1 Select the object to be edited.

2  

    Make sure the Object Mode on the Plan toolbar is pressed and the pointer is over the selected object in the 
Plan window. The pointer appears as an arrow with a house near it.
3 Click any of the visible edges of the object. The Object manipulator appears.

To change an object ’s position:

·  Drag the Object manipulator’s moving point (it’s center). The moving point coordinates are seen on the 
status bar as the pointer is in motion. To maneuver the box in the horizontal direction, move the object in the 
top view (upper window). To maneuver the box in the vertical direction, move the object in the front view 
(lower window).

To change an object ’s size:

·  Drag the Object manipulator’s resize jack (the boxes at the end of the object axes or “levers”). Three 
values specifying the object’s bounding box are shown on the status bar. The first and the second values are 
the coordinates of the bottom left corner of the bounding box. The third value is the bounding box size in the 
direction defined by the lever. To define a shape or object’s horizontal dimensions, manipulate the object in the
top view by dragging the resize jack. To define a shape or object’s vertical dimensions, manipulate it in the 
front view by dragging the resize jack.

To change an object ’s orientation:

·  Drag the Object manipulator’s lever. To rotate the box in the horizontal plane, rotate in the top view. To 
rotate (incline) the box in the vertical plane, rotate in the front view.

To skew an object:
· Drag the Object manipulator’s moving point or resize jacks while holding down the Shift key. Skewing from the 

moving point stretches the object in a horizontal or vertical direction depending on which window you are in 
when you initiate the skew.    This skew essentially drags the geometry from the center of the object’s 
bounding box while anchoring the bounding box’s bottom center. Skewing from the resize jack anchors the 
directly opposing side of the bounding box and along the direction of the lever.

To achieve smooth object rotation: 
· Hold down the Ctrl key while dragging a lever.

To resize an object in all dimensions at once:
· Press Gray Plus key on the number key pad to enlarge the object or the Gray Minus key to shrink the object. 

Related topic: Changing the shape position, size, and orientation. 



Changing object’s height using the Ruler
Two Rulers can be displayed    in the Ruler window:
· The gray Ruler corresponds to the current shape, included into the scene. Use the gray Ruler to change the 

shape’s height. 
· The red Ruler corresponds to the current scene object (previously added to the scene). Use the red Ruler to 

change the height of the current object.
The top latch (the gray box on the top end) of the red Ruler defines the position of the top face of the current 
object’s bounding box. The bottom latch of the red Ruler defines the position of the bottom face of the current 
object’s bounding box. 

To move the Ruler’s latches:

·     Position the pointer over the latch. The pointer looks like an arrow and a house. 
· Drag the latch up or down.

Note: 
If the current object is a scene itself, the Ruler latches can’t be moved.



Add and extract shapes
1 Select the object you want to edit.
2 Include a draft shape into the scene, set its position, size and orientation with respect to the shape or object it 

will affect and then apply the shape to the object using the Add or Extract tools. 
Note: 

The shape is applied to the current object only, not to its sub-objects or parent object. 



Cut, copy, and paste objects and their parts
You can cut or copy an object or part of an object to the clipboard and paste it into another place in your scene. 
You define an object part for cutting or copying using a shape.

To cut or copy the whole of the object to the clipboard:
1 Select the object you want to edit.

2  Click the Cut tool on the Standard toolbar or choose Cut from the Edit menu to cut the object to the 
clipboard. 

    Click the Copy tool on the Standard toolbar or choose Copy from the Edit menu to copy the object to the 
clipboard.

To cut or copy part of the object to the clipboard:
1 Select an object you want to edit.
2 Include a draft shape into the scene. Set the shape  ’  s position, size and orientation   

3 Click the Cut on the Standard toolbar or choose Cut from the Edit menu to cut part of the original object to
the clipboard. 

    Click the Copy on the Standard toolbar or choose Copy from the Edit menu to copy that portion of the object 
removed by the shape to the clipboard. 

To paste data from the clipboard, do one of the following:

·     Click Paste on the Standard toolbar    or choose Paste on the Edit menu to paste data from the clipboard 
to the scene’s origin coordinates. 

· Right click on the place in the Perspective View or Plan window where you want to paste data. The pop-up 
menu appears. Click Paste.      

Notes:
· When you paste data from clipboard, the resulting object is always a sub-object of the currently selected 

object or scene. Be sure to select the desired parent object before doing the Paste operation.
· If you paste data that has been previously cut or copied from a scene into a scene, the result is a new 

independent object in the scene.
TIP:
To convert a part of the scene to an object, extract this part using a shape, and then paste it back into the scene.



Place Objects into the scene
To place an object from the Object gallery to scene:
1 Click a tab in the Object gallery, then scroll the gallery to find the object you need. Repeat this step with other 

tabs till the object is found. 

2  Drag the object to the scene with the mouse.
Notes: 
You can drag and drop objects into the Plan, Perspective View and Scene Tree windows. 
n Plan window. The object becomes a child of the current object. It is located in the place where you dropped it. 
n Perspective View window. The object becomes a child of the object associated with the face upon which you 

drop the object. The object attaches to the face with its own bottom face. This guarantees, for example, that 
when a chair is placed on the floor, it is directly on the floor, not suspended above it or passing through it.

n Scene Tree window. The object becomes a child of the object upon which it was dropped. An object placed in 
this manner occupies a default scene location. 

Objects placed according to the above methods are eligible for all object operations, such as rotation, resizing,  
linking URLs and, renaming etc..



Import objects
To import an object:
1 Choose Import on the Object menu. The standard dialog box for file specification appears.
2 Specify the name of the    file to import and click OK. The data in each imported file is considered a single 3D 

object and is immediately added to the Object gallery. It then becomes available for scene construction like 
any other object from the Object gallery.
 



Using 3D fonts
Using any of the True Type fonts installed in your Windows systemy you can enter text and format it as a three-
dimensional object..

To enter 3D text:
1 Choose Text from the Object menu. A dialog box appears.
2 In the Font list box, select the desired font and font style.
3 In the Color list box, select the color for text.
4 In the Size field, specify the size of the font.
5 In the Quality field, select the quality of font rendering. 
6 In the Text field, enter the desired text.
7 In the Insert to box, choose Clipboard to place text object onto the clipboard, Object gallery to place it to the 

Object gallery, or Scene to place it into the scene.
8 Click OK.
Notes: 
n You may preview the animated (rotating) text string in the bottom window of the Add Text dialog box. In the 

right bottom corner of the dialog box you can view the number of faces and vertexes of the 3D text object. 
Note that complex objects having a large number of faces occupy more disk space and memory . 
Consequently they may take longer to load.

n You can paste text from the clipboard into a scene using the Paste command. 
n Text placed into the Object gallery becomes available for scene construction like any other object from the 

Object gallery. 
n Text placed into a scene becomes a sub-object of the current object. It appears at the origin of the scene’s 

coordinate system. 



Attach sound
You may attach sound to any scene object, including pictures and movies. You may attach sound from a file ,you 
can record it from a microphone or from any audio source supported by your sound card.    

To attach sound from a file:
1 Select an object.
2 Choose Attach sound on the Object menu. The Edit Sound Attachment dialog box appears.
3 Click the Browse button to specify a sound file. 
4 Specify the sound file and click OK.

To record sound:
1 Select an object.
2 Choose Attach sound on the Object menu. The Edit Sound Attachment dialog box appears.
3 Click Record to start recording. The length of a record may not exceed 1 minute.
4 Click Stop when recording is finished. 
5 Click Play to hear recording.
6 Click OK. The standard dialog box for file specification appears. 
7 Name the sound file and click OK.
Notes: 
n The internal sound recorder is working in 8 bit mono mode. Use the volume control program of your operating 

system to set the recording levels for all sound sources, such as microphone, line in, midi, etc. For better 
sound quality prepare the sound file using specialized sound recording software. 

n The ISB sound set is located in the Sounds sub-directory. For example, if ISB is installed in C:\ISB, the Sounds 
directory is C:\ISB\Sounds.

n You can attach sound to Pictures and movies in the Scene Tree window by right clicking on the object in the 
hierarchy or you may position the pointer over the picture/movie in the Perspective View window (the pointer 

appears like an arrow with a picture near it  ), and right click on it. The pop-up window appears ,allowing 
you to work with sound and    URL links.



Play    sound
To play sound:
1 Select an object whose sound you want to play.
2 Choose Play sound on the Object menu. The sound attached to the object is played.
Note:

You can play sound associated with Pictures and movies listed in the Scene Tree window by right clicking on 
the object in the hierarchy or you may position the pointer over the picture/movie in the Perspective View 

window (the pointer appears like an arrow with a picture near it     ), and right click on it. The pop-up 
window appears, allowing you to work with sound and    URL links.



Detach    sound
To detach sound:
1 Select object whose sound you want detach.
2 Choose Detach sound on the Object menu. The sound attached to the object is detached.
Note:

You can detach sound from Pictures and movies in the Scene Tree window by right clicking on the object in the 
hierarchy or you may position the pointer over the picture/movie in the Perspective View window (the pointer 

appears like an arrow with a picture near it     ), and right click on it. The pop-up window appears, allowing 
you to work with sound and URL links.



Link URLs
You can link a URL to any object, including pictures and movies.
To link URLs:
1 Select the object you want to link URL to.
2 Choose Link URL on the Object menu. The Link Internet Shortcut dialog box for URL specification appears.
3 Enter the full URL in the URL field.
4 Enter text in the Description field. 
5 Click OK.
Note: 

    You can attach a URL link to Pictures and movies in the Scene Tree window by right clicking on the object in 
the hierarchy or you may position the pointer over the picture/movie in the Perspective View window (the pointer 
appears like an arrow with a picture near it), and right click on it. The pop-up window appears, allowing you to work 
with sound and URL links.



Removing URLs
To remove URLs:
1 Select an object whose URL link you want to remove.
2 Choose Remove URL on the Object menu. The URL link is removed.
Note: 

      You can remove URL links from Pictures and movies in the Scene Tree window by right clicking on the object 
in the hierarchy or you may position the pointer over the picture/movie in the Perspective View window (the pointer 
appears like an arrow with a picture near it), and right click on it. The pop-up window appears, allowing you to work 
with sound andURL links.



Preparing the scene for publishing
To prepare a scene for publishing ISB creates a new directory in which all data describing the scene is placed. 
This sub-directory will contain the scene’s .wrl file and other resource files, for example, textures, sounds, 
pictures, etc. After the directory is created you may upload the scene to your Web site.
To prepare the scene for publishing:
1 Choose Publish on the File menu. The dialog box for the scene specification appears.
2 Enter the name of your scene .wrl file in the Scene name field.
3 Enter the full path name of a directory in the Location field. ISB creates a sub-directory with the name of the 

scene and places all required data there.
4 Mark the checkbox “Put all resources in one folder” to have all scene files in one folder. Clear the checkbox to 

place resources independently, i.e. one sub-directory for the scene textures, another sub-directory for scene 
pictures, etc.

5 Click OK.



Upload scene to the World Wide Web
To upload a scene to Web:
· Choose Post to Web from the File menu and then follow the instructions displayed on the screen.

Note:
· Consult with your Internet Service Provider or Network administrator regarding how to set the correct data in 

the dialogs displayed on your screen. 
· Install the Web Publishing Wizard software, distributed freely by Microsoft Corp. to use this feature of ISB.



Switching to the Texture Mapper window
To switch to the Texture Mapper window:
· Choose Texture Mapper on the View menu. The Texture Mapper window appears.



Placing textures into the Texture Mapper window
To place a texture in the Texture Mapper window for editing:
· Double click a textured face    in the Perspective View window. The texture is displayed in the Texture Mapper 

window.

To replace a texture on a face and in the Texture Mapper window:

·  Drag a texture from the Texture gallery to the Texture Mapper window. The new texture is placed 
in the Texture Mapper window for editing. The face texture is also replaced in the Perspective View window. 



Moving textures
To move a texture:

·     Click and drag the texture in the Texture Mapper window in any direction. If you drag while the Shift 
key is pressed, texture movement is limited to the horizontal direction. If you drag while the Ctrl key is 
pressed, texture movement    is limited to the vertical direction.



Mapping the texture relative to a pivot point
To establish the pivot point:
·     Double click any point of a texture in the Texture Mapper window - a push pin appears stuck into the 

texture at the click point. 

To rotate a texture around the pin: 

·  Drag the texture in the Texture Mapper window in any direction. 

To stretch or shrink a texture relative to the point:

·     Drag the texture while the Shift key is pressed.

To rotate and stretch or shrink a texture simultaneously: 

·     Drag the texture while the Ctrl key is pressed. 

To make a central symmetry transformation:

·  Click Central Symmetry on the Texture toolbar. 

To rotate a texture 90 degrees counter-clockwise

·
 Click Rotate on the Texture toolbar.



Mapping textures relative to a line
To establish the relative line:

1 {     Double click any point of a texture in the Texture Mapper window - a push pin appears stuck into the 
texture at the click point.

2  Double click any other point of the texture in the Texture Mapper window - one more pin appears, with
a line connecting the two pins. Position the pins by dragging them on the texture to establish mapping 
directionality.

To stretch or shrink a texture:

·     Drag the texture in the Texture Mapper window in any direction - the texture is stretched/shrunk 
relative to the line. 

To displace a texture:

·     Drag the texture while the Shift key is pressed - the texture is displaced relative to the line. 

To displace and stretch or shrink a texture:

·  Drag the texture while the Ctrl key is pressed - the texture is simultaneously displaced and stretched
or shrunk. 

To mirror a texture relative to the line:

·  Click Mirror on the Texture toolbar. 

To make a horizontal texture axis ,parallel to the relative line:

·  Click the Align Horizontal tool on the Texture toolbar.

To make a vertical texture axis parallel to the relative line:

·  Click the Align Vertical tool on the Texture toolbar.



Restoring the initial texture
To return a texture to default state:

·     Click Default on the Texture toolbar - the texture reverts to its original state. 



Changing texture transparency
You can select one of the predefined texture transparency masks or define a new one, using the Texture Mapper 
bar.

To select a predefined texture transparency:

·     Click the left or right arrow on the Transparency Mask area of the Texture Mapper bar. A 
predefined transparency mask is loaded each time you click the arrow..

To define a new texture transparency:

·     Click the grid cell son the Transparency Mask area of the Texture Mapper bar -    black cells 
become white, white cells s become black. Black cells define transparent points in the mask, while white ones 
define opaque points.



Removing textures
You may remove a texture from a face to restore its initial color. You may also change the initial color. 

To remove a texture from a face:

·  Click Clear - the texture is removed. The face returns to    its original, non-textured base color. 

To change the base color of the face under the texture:
1 Click the Color area of the Texture Mapper bar. The color window appears. 
2 Click the desired color.
3 Click OK.



Animating textures
To create animated (moving) textures:

·  Drag the red arm from the center of the Texture Mapper bar to set the direction and the speed of 
the texture’s movement. A longer arm results in faster motion.      

To start the motion:

·     Click on Start on the Texture Mapper bar. The Start button is replaced with the Stop button.

To stop the motion:

·     Click the Stop button on the Texture Mapper bar. The Stop button is replaced with the Start 
button.



Copy modified textures to faces
To move a texture to a different    face in the Perspective View window:

1     Make sure that Use Texture on the Edit toolbar is depressed. 
2 Make sure that the Texture Mapper window is displayed.

3  Click Fill on the Camera toolbar. 

4  Move the pointer into the Perspective View window. It transforms into a tipped pail.
5 To texture only one face, click a face in the Perspective View window. To texture the whole object double 
click any of its faces.

Note: 
When an object is textured, its sub-objects are not changed. 



Switching to the Painter window
The Painter window allows for pen and mouse-based drawing on textures and pictures. 
To switch to the Painter window:
· Choose Painter from the View menu.



Creating a new picture or texture
Textures and Pictures are created while in the Painter window::
1 Choose Painter from the View menu to display the Painter window.

2  Click the New picture or New texture tool on the Painter toolbar    

. The window presents an empty canvas, upon which you will create or edit your picture or texture .. Its default 
name is displayed in the Name field of the Painter toolbar.



Placing pre-existing textures or pictures into the Painter window
To place a texture or picture in the Painter window for editing:
1 Display the Painter window.

2  Drag the texture or picture from the corresponding gallery into the Painter window. The name of the 
picture or texture is displayed    in the Name field of the Painter toolbar.



Draw a straight line or rectangle
1 Click Line on the Paint toolbar to draw a line or click Rectangle to draw a rectangle.
2 Click a line width on the Width and Shape box to select a drawing width.
3 Click a color on the color toolbar to select a drawing color.
4 Drag the handle of the Transparency slider to define the color transparency.
5 Drag the handle of the Blur slider to define the color intensity. 
6 Drag the mouse while holding down the mouse left button to draw a line or rectangle. 



Draw a free-form line
1 Click Pencil, Stylus or Brush on the Paint toolbar to select a drawing tool.
2 Click Weight on the Width and Shape box to select thickness of the drawing tool.
3 Click Color on the color toolbar to select a color.
4 Drag the handle of the Transparency slider to define the color transparency.
5 Drag the handle of the Blur slider to define the color intensity. 
6 Drag the mouse pointer to draw.



Fill an area with a color
You may fill an area of connected points whose colors are about the same. To fill an area:
1 Click the Fill button on the Paint toolbar.
2 Click a color on the color toolbar to select a color.
3 Drag the handle of the Transparency slider to define the color transparency.
4 Drag the handle of the Tolerance slider to define the tolerance, or allowable difference between points of color 

to be replaced in the selected area.
5 Click anywhere in the area to be painted. The area is filled.



Manipulating selected areas
To select an area of the picture or texture:
1 Click Select on the Paint toolbar.
2 Draw a selection rectangle by left clicking and dragging with your mouse.

To move or copy the selected part over the picture or texture:
1 Click the movement mode in the Width and Shape control(movement mode is represented by two icons, both 

sunset drawings differentiated by how the sun looks in a selection rectangle). To move or copy a selected 
rectangle as a whole click the upper icon. To move or copy only those points of the area    whose colors are 
different than the current color selected in the Colors toolbar, click the bottom icon. 

2 Drag the selection area to move and place it. 

To copy the selected area to the clipboard:
· Click Copy on the Standard toolbar or choose Copy on the Edit menu.

To clear the selected area:
· Choose Delete on the Edit menu.

To cut the selected area to the clipboard:
· Click Cut on the Standard toolbar or choose Cut on the Edit menu.



Pick    up a point color
You may pick a color to paint with from any point on the picture or texture. To pick a    color: 
1 Click Select Color (eyedropper) on the Paint toolbar.
2 Click the    desired color on the existing picture or texture. That color becomes the current color and is placed 

on the current color box of the Painter toolbar.



Zoom    on a picture or texture
To magnify an area of a picture or texture:
1 Click Zoom on the Paint toolbar.
2 Click anywhere in the area to be magnified.

To change the picture or texture magnification:
1 Click Zoom on the Paint toolbar again.
2 Click the appropriate magnification value in the Width and Shape box to zoom in or out from the original view..

To return the picture or texture to its original size:
1 Click Zoom on the Paint toolbar. 
2 Click anywhere in the picture or texture again. 



On-line picture or texture editing 
You may edit a picture or texture already placed into a scene. When you edit on-line all changes are immediately
displayed in the Perspective View window. 
To make edit a picture or texture on-line:
1 Display the Painter window.
2 Double click the desired texture or picture in the Perspective View window. The picture or texture is placed on 

the canvas in the Painter window. Its name and category is displayed in the Painter window toolbar.
3 Edit the picture or texture. All editing is displayed in the Perspective View window.



Resizing a picture or texture

·     Drag the black box on the edge of the picture or texture.



Saving a picture or texture
To save a picture or texture to a gallery:
1 To rename a picture or texture enter the new name in the Name field of the Painter window toolbar. 
2 To define another category enter the new name in the Category field of the Painter window toolbar.

3  Click Save on the Painter window    toolbar. The edited picture or texture is saved.

Instead of saving a picture or texture in a gallery you may save them    to any folder and file location available to 
your system.
To save a picture or texture to the file:
1 Choose Save as from the Paint menu. The dialog box for file specification appears. 
2 Click a drive name or folder name.
3 In the File Name box, type a name for the picture or texture.
4 Click Save.
Note: 

ISB stores the texture galleries in the ISB\Textures directory by default. 



Moving, adding and deleting gallery resources
You can move, add or delete resources in each gallery. 

To move, add or delete gallery resources:
1 Right click anywhere in the gallery. The pop-up window appears.
2 Click the Explore menu item. The standard Windows Explorer window with the gallery’s file names appears. 
3 Add or delete files using the Windows Explorer. All modifications are immediately displayed in the appropriate 

gallery.



Customizing Toolbars
Click on the topic below to get the explanation.
{button ,JI(`Isb.HLP>bottom',`Display_or_hide_toolbar')}    Display or hide toolbar
{button ,JI(`Isb.HLP>bottom',`Disable_or_Enable_toolbar')}    Disable or Enable custom toolbar
{button ,JI(`ISB.HLP>bottom',`Move_a_toolbar')}    Move a toolbar
{button ,JI(`Isb.HLP>bottom',`Resize_a_toolbar')}    Resize a toolbar
{button ,JI(`ISB.HLP>bottom',`Restore_a_built_in_toolbar')}    Restore a built-in toolbar
{button ,JI(`ISB.HLP>bottom',`Create_a_custom_toolbar')}    Create a custom toolbar
{button ,JI(`Isb.HLP>bottom',`Delete_a_custom_toolbar')}    Delete a custom toolbar
{button ,JI(`Isb.HLP>bottom',`Rename_a_custom_toolbar')}    Rename a custom toolbar
{button ,JI(`Isb.HLP>bottom',`Add_or_delete_a_toolbar_button')}    Add or delete a toolbar button
{button ,JI(`Isb.HLP>bottom',`Change_the_spacing_between_toolbar_button')}    Change the spacing between 
toolbar button
{button ,JI(`Isb.HLP>bottom',`Move_or_copy_a_toolbar_button')}    Move or copy a toolbar utton



Display or hide toolbar
To display or hide a toolbar:
1 Choose Toolbars from the View menu. The Toolbars dialog box, listing the default toolbars appears.
2 Mark the toolbar checkbox to display the toolbar, or clear the checkbox to hide it.
Note:

To quickly display or hide a toolbar right click over    any toolbar. After the pop-up menu appears click on the 
toolbar name to affect its display. A check mark indicates the toolbar Is active and displayed. Clicking on it 
again removes the check mark and hides the toolbar.



Disable or enable custom toolbar
You may disable a custom toolbar in the Plan, Texture Mapper or Painter window.
To disable a toolbar:
1 Choose Toolbars on the View menu. The dialog box with toolbar names appears.
2 Click the name of the custom toolbar to be disabled in the current window. 
3 Click Disable to disable the toolbar. The Disable button changes to Enable.
Note:

You cannot disable ISB’s built-in toolbars.

To enable a toolbar:
1 Choose Toolbars from the View menu. The dialog box with toolbar names appears.
2 Click the name of the custom toolbar to be enabled.
3 Click Enable to enable the toolbar for work in the current window. The Enable button changes to Disable.



Move a toolbar
1 Point between buttons on a toolbar, or point to the toolbar title bar if it is a floating toolbar.
2 Drag the toolbar to a new location. If you drag it to the edge of an ISB window, the toolbar docks to this edge 

automatically.



Resize a toolbar
· To resize a floating toolbar, drag any of its sides.
Note:        

You cannot resize a docked toolbar. 



Restore a built-in toolbar
1 Choose Toolbars on the View menu. The dialog box with toolbar names appears.
2 Click the name of the built-in toolbar to be restored.
3 Click Reset. The built-in, default state of the toolbar is restored.



Create a custom toolbar
To create a custom toolbar:
1 Choose Toolbars from the View menu. The dialog box with toolbar names appears.
2 Click New. The Customize Toolbars dialog box appears.
3 In the field “Toolbar name ”enter the name of the new toolbar. 
4 Mark the “Available in global scope ”checkbox to make the toolbar available while working in the Plan, Texture 

Mapper, and Painter windows. Clear the checkbox to make the toolbar available during work in the current 
view only.

5 Click OK. An empty toolbar appears on the screen. The Customize Toolbars dialog box appears.
6 In the Categories box, click the category that contains the desired button.
7 Drag the desired button onto the new toolbar. 
8 Repeat the last two steps for all required buttons.
9 Click Close. The Customize Toolbars    dialog box disappears.



Delete a custom toolbar
To delete a custom toolbar:
1 Choose Toolbars from the View menu. The Customize Toolbars dialog box appears.
2 Click the name of the toolbar to be deleted.
3 Click Remove. The toolbar is removed.
Note:

You cannot remove the ISB built-in toolbars.



Rename a custom toolbar
To rename a custom toolbar:
1 Choose Toolbars on the View menu. The Customize Toolbars dialog box appears.
2 Click the name of the toolbar.
3 Enter the new name in the Toolbar name field.
4 Click Close. The toolbar is renamed.
Note:

You cannot rename the ISB built-in toolbars.



Add or delete a toolbar button
To add a toolbar button:
1 Choose Customize on the Tools menu. The Customize Toolbars dialog box.    
2 In the Categories box, click the category that contains the desired button. All buttons of this category appear 

in the Buttons box.
3 Drag the desired button from the Buttons box to the new toolbar. The button appears on the toolbar.
4 Click Close. The button is added.

To delete a toolbar button:
1 Hold down the Alt key and then drag the button to be deleted from the toolbar onto any ISB window.
2 Release the Alt key. The button is deleted.
Note:

If the Customize Toolbars dialog box is open you may drag buttons without pressing the Alt key.



Change the spacing between toolbar button
To increase a space between two toolbar buttons:
1 Hold down the Alt key and drag the right button a little bit to the right.
2 Release the Alt key. The distance between the tools is increased.

To decrease a space between two toolbar buttons:
1 Hold down the Alt key and drag the right button a little bit to the left.
2 Release the Alt key. The space is decreased.



Move or copy a toolbar button
To move a toolbar button to another toolbar:
1 Hold down the Alt key and then drag the button to the required toolbar.
2 Release the Alt key. The button is moved.

To copy a toolbar button:
1 Hold down the Alt and Ctrl keys and then drag the button to the required toolbar.
2 Release the Alt and Ctrl keys. The button is copied.



Troubleshooting
· The General Protection fault appears when you rename an object. 

This error usually appears after a right click on the object name edit box. Update the COMCTL32.DLL in the 
Windows 95 System directory.

· A texture won’t spread to another face. 
The face belongs to another object. You can only spread textures over faces of the same object.

· Only the top view of a plan is printed as a result of the Print command on the File menu. 
You can only print views shown on the screen. To print a front view make sure it is visible.

· The objects in the Object gallery are not textured. 
This means the textures are loading. In this case the rotating globe is shown on the bottom of the ISB window. 
The objects will display any textures after they are loaded.

· The Use Texture button on the Edit toolbar is grayed out.
The Texture gallery isn’t set. To specify the path to the Texture gallery click Options on the Tools menu, then 
click the Galleries tab . Specify the appropriate gallery in the Path to resources edit box.

· The picture is too small when placed into the Perspective View window. 
If you want the pictures to be larger when you place them into the Perspective View window click Options on 
the Tools menu, then click the Camera tab . Define smaller values in the Horizontal and Vertical edit boxes. 
These boxes specify how many pixels of picture imaging correspond to one meter of virtual scene. 

· CosmoPlayer doesn’t process an URL link when you click the object.
If an object has an URL link as well as a sound file attached to it, CosmoPlayer will only play the sound after 
the object is clicked.

· A scene isn’t    textured when viewing with CosmoPlayer. 
If you save the scene using the Save or Save as command on the File menu, the scene references textures, 
pictures, movies, and objects locally. For correct URL links which allow you to publish a scene and view it using 
any VRML viewer use the Publish or Post to Web command from the File menu.

· When a picture is placed into another location it changes its size.
Each time a picture is placed onto an object’s face ISB calculates an appropriate size, one corresponding to the
size of the face. Place a picture in the correct position before specifying its size. 

· The Cut, Copy or Extract commands are not working in certain cases. 
The Extract, Cut and Copy operations are not available to the Room and Walls shapes and to convex custom 
shapes



Painter window toolbar





 





Choose command (File menu)
Opens a scene from the Scene gallery. Look for the scene and then double click on it. 



New command (Object menu) 
Creates a new object and switch to the Object Editing mode. The object appears in the Scene tree and becomes 
a sub-object of the current object.    



Save command (Object menu) 
Saves the current object.



Info command (File menu) 
Displays statistical information about the current scene for managing overall scene size and complexity.



Options command (Tools menu) 
Sets general ISB configuration parameters. The parameters control screen appearance, editing, rendering, 
navigation, resources, and other options. 



ParaGraph Home Page command (Help menu)
Downloads the Paragraph Web site.



Product News command (Help menu) 
Downloads the ISB news page from the Paragraph Web site.



Attach MIDI command (File menu)
Attaches a MIDI file to the current scene. This file is played while the scene is loading.



Detach MIDI command (File menu)
Detaches the MIDI file from the current scene.



Attach Sound command (Object menu) 
Attaches a sound file to the selected object.



Play Sound command (Object menu)
Plays the sound file attached to the selected object.



Detach Sound command (Object menu)
Detaches the sound file from the selected object.



Link URL command (Object menu)
Attaches a URL to the selected object.



Remove URL command (Object menu) 
Removes the URL from the selected object.



Import command (Object menu)
Imports an object from a file into the Object gallery.



Text command (Object menu)
Creates a text object. You can enter a text and format it with any of the True Type fonts installed in your Windows
system.



Cuts the selected object or the whole scene onto the clipboard.



Copies the selected object or the whole scene onto the clipboard.



Delete the selected object or the whole scene.



Center the Ruler    over the zero mark in the middle of the Ruler window.



Use the Texture button (Edit toolbar)
Turns on and off the Automatic Texture mode. In this mode a selected texture is automatically applied to all faces
when the shape is added to the scene.



Perspective View command (View menu) 
Displays or hides the Perspective View    window. This window is used for viewing and navigating 3D scenes.



Scene Tree command (View menu)
Displays or hides the Scene Tree window. This window is used for viewing and selecting objects within the 
hierarchical structure of the current scene. 



Scenes command (View menu) 
Displays or hides the Scene gallery. 



Textures command (View menu)
Displays or hides the Texture gallery. Textures are used to decorate the object faces.



Pictures command (View menu)
Displays or hides the Picture gallery. Pictures are placed onto scene faces.



Movies command (View menu)
Displays or hides the Movie gallery. Movies are placed onto scene faces.



Shapes command (View menu)
Displays or hides the Shape gallery. Shapes are the main tools for constructing a scene’s geometry, the objects 
which make up the scene.



Objects command (View menu)
Displays or hides the Object gallery. The objects are separate geometrical entities which can be placed into a 
scene.



Displays or hides the Colors toolbar.



Ruler button (Plan toolbar) 
Displays or hides the Ruler window. This window is used to set shape and object height as well as to control the 
placement andlens angles of the active camera.



Texture Mapper Bar button (Texture toolbar)
Displays or hides the Texture Mapper bar. The Texture Mapper bar allows you to define the texture transparency 
and animation, or the color of the current face. 



Displays or hides the attribute controls in the Painter window. These controls are used to define the current color 
tolerance, transparency, and blur/color intensity.



Displays or hides the toolbar for a new picture or texture creation.



Plan View command (View menu)
When checked displays the Plan window. In the Plan window you may view and manipulate the top and front 
views of the current scene. 



Texture Mapper command (View menu)
When checked displays the Texture Mapper window. The Texture Mapper window allows you to edit the current 
texture using mapping operations.



Painter command (View menu)
When checked displays the Painter window. The Painter window allows you to create and edit textures and 
pictures using painting operations.



Object Mode button (Plan toolbar)
Turns on/off the Object mode. In this mode you select an object and:
n Cut or copy it to the clipboard. 
n Cut or copy part of it using a current shape.
n Create its sub-object.
n Move, resize or rotate the object with the Object manipulator. 



Build Mode button (Plan toolbar)
Turn on/off the Build mode. In this mode you work with a shape selected in the Shape gallery. To include a shape 
into the scene, drag and drop the shape onto the Plan window or draw a bounding box around the shape.



Zoom Mode button (Plan toolbar)
Turn on/off the Zoom mode. In this mode select an area in the top or front view for zooming. To select an area, 
draw a corresponding rectangle with the mouse.



Move Plan Mode button (Plan toolbar)
Turn on/off the Move Plan mode. In this mode move the top and front views in the Plan window in the direction 
desired.



Polygon Mode button (Plan toolbar)
Turn on/off the Polygon mode. In this mode you specify the underlying polygon from which you create a solid 
polyhedral, pyramid, walls, or room.



Zoom In button (Plan toolbar)
Increases the view magnification in the window.



Zoom Out button (Plan toolbar)
Reduces view magnification in the window.



Fit to Object button (Plan toolbar)
Adjusts views in the Plan window to maximize the display    of the selected object.



Fit to Scene button (Plan toolbar)
Adjusts views in the Plan window to maximize the display of all objects in the scene.



Displays or hides the Guides in the Front View and the Ruler windows. The Guides allow you to define the default 
height of a new shape.



Add command (Object menu)
Adds the current shape to a scene.



Extract command (Object menu)
Extracts the current shape from the current object.



Record/Cancel Shape command (Tools menu) 
Starts/cancels recording of merging and carving operations resulting in a new shape creation.



Stop Recording command (Tools menu)
Stops recording, opens the dialog box to save the new shape.



Solid button (Edit toolbar)
Creates a solid polyhedral after the vertexes of the underlying polygon are defined. Accessible in the Polygon 
mode.



Walls button (Edit toolbar)
Creates walls after the vertexes of the underlying polygon are specified. Accessible in the Polygon mode.



Room button (Edit toolbar)
Creates a room after the vertexes of the underlying polygon are specified. Accessible in the Polygon mode.



Pyramid button (Edit toolbar)
Creates a pyramid after the vertexes of the underlying polygon are specified. Accessible in the Polygon mode.



Defines grid cells of the Plan window and specifies the polygonal shapes.



Turns on/off the Grid in the Plan window.



Creates a new camera for the pointer’s current position.



Includes a new shape into the current scene. The shape selected in the Shape gallery is included.



Places the active camera into the pointer’s current position. 



Print command (File menu) 
Prints the Plan window of the current scene. 



Print command (Object menu)
Prints the Plan window of the current object.



Inserts an object from the clipboard onto the current pointer position.



Duplicates the selected camera. An additional camera with the same position and orientation is created.



Deletes the selected camera.



Sets the camera’s default focal distance.



Sets the name of the camera.



Restores the initial orientation of the shape. 



Enlarges the shape.



Reduces the shape.



Displays the name of the shape and the number of its faces, vertexes and textures.



Restores the initial orientation of the object.



Enlarges the selected object.



Reduces the selected object.



Cuts the selected object onto the clipboard.



Copies the selected object onto the clipboard.



Deletes the selected object.



Changes the current node of a Scene Tree to the parent.



Sets the object as current.



Saves the current object into the Object gallery.



Displays information about the object. Such as the name of the object, the number of textures, sub-objects, 
attached sound files, etc.



Hides the Guides in the Front View and Ruler windows.



Sets the height of the guide lines.



Deletes the vertex of the polygon. 



Deletes the polygon.



Displays the table of the polygon vertexes and their coordinates.



Duplicate command (Camera menu)
Creates a new camera that coincides with location and orientation of the current camera.



Align Horizontal command (Camera menu)
Makes the camera’s horizontal axis parallel to the scene’s horizontal plane..



Align Vertical command (Camera menu)
Makes the camera’s longitudinal axis parallel to the scene’s vertical plane.



Sets the camera position and orientation so that it is pointed at the selected face from a distance of 7 meters. 



Full Screen command (Camera menu)
Shows the current scene in the full screen mode. To return to the previous screen, click the right mouse button or
press Alt+Enter.

Note: 
n Full Screen mode is not available for the Windows NT 4.0 operating system.



Rename command (Camera menu)
Specifies a new name for the current camera.



Delete command (Camera menu)
Deletes the current camera. As every scene requires at least one camera, two cameras must be in the scene for 
this function to work..



Spread button (Camera toolbar)
Spreads a texture from one face to other specified faces (on the same object).



Hides the Perspective View window.



Sets the properties for the rendering engine, picture resolution, background color, and collider.    



Opens the Texture Mapper window with the face texture loaded on the canvas.



Deletes the picture or movie.



Links a URL to the picture or movie.



Removes a URL from the picture or movie.



Plays the movie forward.



Plays the movie backwards.



Plays the movie continuously forward then backwards: ping-pong style.



Sets the height Guides to correspond with the faces of the object’s bounding box. The upper guide line is set to 
the height of the upper face of the bounding box. The bottom guide line is set to the height of the bottom face of
the bounding box.



Opens the Painter window to edit the picture.



Attaches a sound file to a picture or movie.



Plays the sound file attached to the picture or movie.



Detaches the sound file attached to the picture or movie.



Cuts the object (which belongs to the current face) onto the clipboard. 



Copies the object (which belongs to the current face) onto the clipboard.



Inserts the object from the clipboard. The object’s vertical axis becomes perpendicular to the selected face.



Fill button (Edit toolbar)
In the Plan and Painter views this tool fills faces with the current texture from the Texture gallery or with the 
current color from the Colors toolbar:
n If you have singleclicked a face in the Perspective View window, the tool fills this face with the texture if the 

Use Texture button is depressed .    The tool fills the selected face(s) with the current color in the color box if 
the Use Texture button is released. 

n If you have double -clicked a face in the Perspective View window, the tool fills all faces of the current object 
and those connected with it with the active texture (if the Use Texture button is depressed ).If the Use Texture 
button is released the object is filled with the current color.

In the Texture Mapper view the tool fills face(s )with the texture from the Texture Mapper panel:
n If you have single -clicked a face in the Perspective View window, the tool fills this face. 
n If you have double -clicked a face in the Perspective View window, the tool fills all faces of the object 

connected with the current one.



Grow command (Transform menu)
Expands a texture. It appears as if you are moving closer to the texture.



Shrink command (Transform menu)
Reduces a texture. It appears as if you are moving away from the texture.



Reset command (Transform menu)
Reverses all texture editing. The current texture returns to its default state.



Clear command (Transform menu)
Removes the texture from the current face. The face is filled with its initial color. 



Orthogonalize command (Transform menu)
Creates perpendicular texture mapping. Cancels the operation of texture displacement (two pins mapping 
procedure).



Invert command (Transform menu)
Applies a central symmetry transformation to the texture.



Rotate command (Transform menu)
Rotates the texture 90 degrees counter-clockwise around the pin.



Mirror command (Transform menu)
Mirrors the texture relative to the line between the two pins.



Align Horizontal command (Transform menu)
Rotates the texture to make the horizontal axis parallel to the line between the two pins.



Align Vertical command (Transform menu)
Rotates the texture to make its longitudinal axis parallel to the line between the two pins.



Displays or hides the Transparency Mask control of the Texture Mapper bar. This control allows you to select one 
of the predefined texture transparency mask sor to define a custom one.



Displays or hides the color control of the Texture Mapper bar. This control allows you to select a color for the 
current face. To see the color of the face click Clear on the Texture toolbar.



Displays or hides the transparent color control of the Texture Mapper bar.



Displays or hides the moving texture control of the Texture Mapper bar. This control allows you to animate the 
current texture.



Sets texture tiling parameters. This setting affects all textures.



Places the pin into the texture.



Removes the pin from the texture.



Opens the folder containing the gallery resources. You can add additional resource files into the folder or delete 
the files that are no longer required.



Enables or disables the tool tips which describe gallery resources.



Enables or disables animation of the gallery resource when the pointer is placed over the resource image. 



Hides the gallery window.



Displays the dialog box to set the properties for the gallery. You can then specify the path to the gallery folder, 
resources sorting order, size of the resources preview, etc.



Reloads the gallery.



Deletes the selected resource from the gallery.



Pencil button (Paint toolbar) 
Selects a pen for drawing. 



Stylus button (Paint toolbar)
Selects a stylus for drawing.



Brush button (Paint toolbar)
Selects a brush for drawing.



Fill button (Paint toolbar)
Paints an area with the current color.



Airbrush button (Paint toolbar)
Selects the airbrush for drawing.



Select Color button (Paint toolbar)
Select a color from the image for drawing. 



Line button (Paint toolbar)
Draws a line with the current color.



Rectangle button (Paint toolbar)
Draws a rectangle with the current color.



Ellipse button (Paint toolbar)
Draws an ellipse with the current color.



Select button (Paint toolbar)
Selects a rectangular part of the image.



Select region button (Paint toolbar)
Selects a    part of the image based on color differences.



Magnify button (Paint toolbar)
Controls how large or small the picture or texture appears on the screen.



Save command (Paint menu)
Saves a picture or texture into the gallery.



Save as command (Paint menu)
Saves a picture or texture as the file specified.



Creates a new empty picture.



Creates a new empty texture.



Opens a dialog box for setting the properties of the edited picture or texture. 



Hides the Scene Tree window.



Saves the scene or object into the Scene or Object gallery. 



Activates an inactive camera. Available only if two or more cameras are present.    



Renames the selected object, camera, picture, or movie.



Deletes the selected object, camera, picture, or movie.



Displays general information about the selected scene or object.



Opens the Painter window for picture editing.



Links a URL to the selected object, picture or movie.



Removes the URL attached to an object, picture, or movie.



Attaches sound to the selected object, picture, or movie.



Plays a sound attached to the selected object, picture, or movie.



Detaches a sound attached to the object, picture, or movie.



This is the name of the current layout.



This is the Plan rotation angel.



These are the coordinates of the pointer’s current position.



This is the size of a bounding box in the Plan window or the size of a picture or texture in the Painter window.



This is the Texture Loading indicator. It indicates background loading of textures. 



Wrong path to the Shape gallery. Choose Options on the Tools menu and specify the correct path in the field Path
to resources field under the Galleries tab. 



The name, title, and/or category of a new shape are not specified.    



A shape with the same name already exists. Click Yes to overwrite the existing shape. Click No to cancel.



An error occurred while trying to save the shape into the file. Check for adequate    disk space, remove write 
protection and make sure that the file is not in use by another application.



An object with the same name already exists. Choose Yes to overwrite the object. Choose No to cancel.



The name, title, or category of a new object isn’t specified.



Wrong path to the Object gallery. Choose Options in the Tools menu and specify the correct path to the resources
field iel under the Galleries tab.



An error occurred while trying to save the object into the file. Check the disk space, remove write protection and 
make sure that the file is not in use by another application.



The name of the object cannot begin with a digit. Please choose another object name.



The camera name you have specified already exists. Please choose another name.



 An internal error occurred while applying the shape. Try to include the shape from another position. 



The picture or scene was modified. Choose Yes to save the picture or scene, No to exit without saving, or Cancel 
to cancel.



A picture with the same name already exists. Choose Yes to overwrite the existing picture or No to cancel.



Confirm the deletion of the selected item. Choose Yes to delete or No to cancel the operation.



This message box shows the ISB version and Copyright information.



This dialog box allows you to define the general parameters of the scene. 
n Initial ground. Select the name of the ground for your scene or select None. 
n Undo buffer size. Specify a limit for the number of undo operations.
n Play background MIDI. Mark the checkbox to play a MIDI file attached to a scene. Clear the checkbox if you 

don’t want the file to play.
n Auto Repeat. Mark the checkbox to repeat MIDI after it is finished. Clear the checkbox if you want to play 

MIDI once.



This dialog allows you to set options for saving the scene.
n Use compression. Mark the checkbox to save new scenes, objects and previously published scenes in 

compressed format.
n User info. Specify the user and company names in the corresponding fields. These names will be documented

in the scene’s VRML 2.0 file.
n HTML document post to Web. You may edit the HTML file to be uploaded to your Web page in this field. A 

default HTML text file is already loaded, however you may modify the text manually prior to posting the scene.
n Insert.    Automatically insert HTML language keywords from a menu opened by clicking this button.
n Reset. Click this button to revert to the default HTML document text.
Note:

Please refer to the HTML document’s syntax description papers while using the editor.



This dialog box allows you to specify a grid for the Plan window and to set the thickness of the walls for 
polygonal shapes.
n Spacing. Specify the Grid cell in meters.
n Visible grid. Mark the checkbox to turn the Grid on, or clear the checkbox to turn the Grid off.
n Active grid. Mark the checkbox to turn the snapping on, or clear the checkbox to turn the snapping off. If the 

Grid is activated, specify the snapping proportion: select 1:1 radio button to specify snap to grid cell, select 1:2
to specify snap to 1/2 cell, etc. 

n Thickness. Specify the thickness of the wall, floor and ceiling for the Room and Wall polygonal shapes. 
n Spline. Specify the default spline parameters.



This dialog box allows you to control scene appearance and navigation in the Perspective View window. 
n Rendering engine. Select a rendering mode. The 256 Color/High Color/True Color ParaGraph 3D Render 

Engine options are preferable if your display works in the corresponding color mode. The Render Engines with 
MMX characters in their name are available only for the computers with processors supporting Intel's MMX 
instruction set.

n Default picture resolution. The number of pixels of picture image per 1 meter of the virtual space. To make 
a picture larger when it is on screen, decrease the number in the Horizontal and/or Vertical field.

n Background color. Select a background color for a scene in the Perspective View window.
n Collider. Mark the checkbox to turn the Perspective View window collider on, or clear the checkbox to turn the

collider off.



This dialog box allows you to control the ISB resources. 
n Category. Select the name of the gallery.
n Path to the resources. Enter the name of the folder with the gallery resources or click Browse to browse to 

the gallery folder.
n Include subfolders. Mark the check box to use resources from the subfolders of the folder specified in the 

Path to the resources edit box. If the checkbox is marked, the subfolder’s resources are shown in the 
corresponding gallery with a tab. The name of the tab coincides with the name of the subfolder.

n Preview size. Specify the size of the screen area for the resource preview. The size is specified in pixels.
n Sort by. Define the sort order for the resources. They can be sorted in ascending order by name, or in 

ascending or descending order by creation date. 
n Show ToolTips. Mark the checkbox to display tool tips for gallery resources.
n Enable animation. Mark the checkbox if you want a resource to rotate when you point to it.
n Allow fast load. Mark the checkbox to save a resource preview image after the resource is loaded. This 

option is intended for complex resources such as scenes or objects. These resources are displayed much faster
when their preview images are stored on the disk. If you modify a resource it’s image is automatically 
updated.

n Show titles. Mark the checkbox to display names of gallery resources.



In the field Name enter the new name of the camera.



This dialog box allows you to define texture tiling parameters.
n Default scene texture tiling. The number of meters of virtual space per one tiling unit. These parameters 

are used when you drag and drop a texture from the Texture gallery to a scene.
n Default shape texture tiling. The number of meters of virtual space per one tiling unit. These parameters 

are used when you apply a shape to a scene in the Default Texture mode.



This dialog box allows you to control custom layouts.
Select a layout from the Select layout list box. Press Activate to activate the selected layout, or press Remove to 
remove the name of the layout from the layout list. Press Add to add the current layout into the list. 



Specify the name of the new layout in the field Name and press OK.



This dialog box allows you to set guide lines. 
Specify the heights of the top and bottom guide lines in the Top and Bottom guide fields. Press Apply to set guide
lines to the specified position (the dialog box on screen) or press OK to set guide lines and hide the dialog box.



These are the coordinates (in meters) of the basic vertexes. You cannot edit these coordinates. They are 
displayed for information purposes only. 



This dialog box allows you to specify where to save the object.
In the field Name, specify the name of the file for the object. In the field Category, specify the Objects gallery tab
for the object. Click OK to save the object or Cancel to cancel the operation.



This dialog box displays statistics for the selected object or current scene.
n Name: the name of the selected object. 
n Parent name: the name of the object’s parent. 
n Number of sub-objects: the number of sub-objects in the selected object. 
Information about the number of vertexes, holes, faces, textures, cameras, attached sounds, midi, pictures, 
movies or Internet shortcuts are also displayed. You cannot edit these properties, they are displayed for 
information purposes only. 



This dialog box allows you to link an Internet shortcut to an object, picture, or movie.
In the URL field, enter the desired URL. In the Description field, enter the description to be displayed while the 
pointer is over the link.        



This dialog box allows you to attach a sound file to an object, picture, or movie. You can also record a sound 
using a microphone.
Click Browse to specify a sound file to be attached. When the file is specified click OK.
Click Record to start recording from the microphone. Click Stop when recording is finished. After sound is 
recorded click OK to specify a file in which to save the sound.



This dialog box allows you to enter information about your scene. 
The fields Title, Author and Company are the names of corresponding items. You may place information about 
the scene version number in the field Version and any comments in the field Comments.



This dialog box allows you to define a text object for your scene.
Select font, font style, font color and script (language) using the corresponding lists in the dialog box. Set the 
font quality as well as height and depth in meters in the Geometry section of the dialog. The item Quality defines
the number of faces used to display each character. The more faces, the smoother the character will appear. 
Enter the text string you wish to create in the Text field. 



This message box displays general information about the current scene. 
The items Location and Size display the scene file location and size in your computer. The items Created, 
Modified and Accessed display the information about the creation date of the scene, date of its last modification, 
and last access. The item, Last Saved By, displays the name of the user who saved the last scene file. The item 
Total Editing Time gives the total time for which the scene file was open for editing.



This dialog displays information about the current scene. 
The numbers in each item help you to evaluate the complexity of the scene and view the number of sound, 
picture, and Internet shortcut attachments. You cannot edit these values. 



This is a gallery tab. It selects a resource category from the list.



This modifier allows you to set the desired transparency of a painting color.



This modifier allows you to define the desired strength of the painting color.



This modifier allows you to define the color difference.



Use this field to enter the name of the picture or texture.



Use this field to choose the category of a picture or texture.



Publish command (File menu)
Creates a directory and copies the scene’s .wrl file and resources, for example, textures, pictures etc., to this 
directory. These files are used for scene publishing on the WWW.



Post To Web command (File menu)
Opens a dialog box for publishing your scene on the Web. After all parameters are entered, your scene will be 
uploaded to the Internet site.



This dialog box allows you to specify a custom shape.
n Name. Specify the name of a file for the shape. The name must be specified without an extension. 
n Title. Specify the title of the shape when it is appears in the Shape gallery. 
n Category. Enter the name of the Shape gallery tab under which the shape will be placed or select a name in 

the list box. 
n Keep texturing. Mark the checkbox to save the shape with its textures. Clear the checkbox to save the shape

without textures.
n Keep aspect ratio. Mark the checkbox to maintain shape proportions when resizing with the Shape 

manipulator.



This message box appears as a result of an internal error while saving a file. Make sure that you have enough 
disk space and the disk is not write protected. 



This message box appears if the scene files were not successfully copied. Make sure that you have enough disk 
space and the disk is not write protected. 



This message box appears as a result of an error while saving a file. Make sure that you have enough disk space 
and the disk is not write protected. 



A toolbar with this name already exists. Please use another name. Toolbar names are case sensitive.



This dialog box allows you to prepare all information necessary for publishing your scene on the WWW.
n Scene. Enter the name of your scene. 
n Location. Enter or browse the directory where all information required for scene publication will be copied.



This dialog box is used for toolbar customization. To customize a toolbar, click desired category, then drag the 
button to the toolbar. 
n Close. Closes the Customize Toolbars dialog box and completes the customization. 
n Categories. Contains a list of button categories. 
n Buttons. Contains all buttons in the selected category. 
n Description. Describes the selected button.



This dialog box allows you to specify a new toolbar.
n Toolbar name. Enter a name of the new toolbar being created. 
n Available in global scope. Mark this check box if you want the new toolbar to be available when working in 

the Plan, Texture Mapper and Painter windows. Clear the checkbox if you want the toolbar to be available 
during work in the current view only. 



This dialog box is used for toolbar customization. 
n Close. Closes the Toolbars dialog box.
n New. Creates a new toolbar. When the toolbar’s name is defined, the empty toolbar appears on the screen.
n Customize. Opens the dialog box for the selected toolbar customization.
n Disable. Disables the selected toolbar in the current view. You cannot disable ISB’s built-in toolbars. The 

Disable button for the toolbar is changed to Enable.
n Enable. Enables the selected toolbar in the current view. 
n Reset. Restores the default state of the ISB built-in toolbars. The Reset button for custom toolbars changes to 

Remove. 
n Remove. Removes the selected toolbar. You cannot remove ISB’s default toolbars. 
n Toolbar name. The edit box for custom toolbar name. You cannot rename ISB built-in toolbars.



This is a bottom guide line. It defines the vertical position of the bottom face of the shape bounding box when 
included into the scene. 



This is a camera. There can be several cameras in one scene. A scene is viewed in the Perspective View window 
through an active camera. The active camera is indicated by the color red in the Plan window.



Click this button to scroll down. 



This is the Front View window. The front view of the plan is shown here. You can change the size of the Front View
window by dragging the splitting box of the Plan window.



This is the Shape manipulator. With the help of the manipulator, you can move, resize, rotate and skew the 
shape.



This is the Top View window. The top view of the plan is shown here. You can change the size of the Top    View 
window by dragging the splitting box of the Plan window.



This is a polygon for Solid, Walls, Room or Pyramid shape construction. 



This is an Object manipulator. With the help of the manipulator, you can move, resize, rotate and skew the 
object.



This is the Ruler window. You can control the height and vertical position of a new shape with the help of the 
Ruler’s lathes and Guide lines shown in the Ruler window. You can also control position, orientation and focal 
distance of the active camera.



Click this button to decrease the focal distance of the current camera.



This is a shape to be used in a scene. 



This is a top guide line. It defines the vertical position of the top face of the shape bounding box when included 
into a scene. 



Click this button to scroll up. 



This is the Plan wheel. To rotate the plan, drag the Plan wheel with the mouse. The plan rotates in the direction 
opposite from that indicated by the mouse.



Click this button to increase the focal distance of the camera.



This is the Texture Mapper window. In this window, you can edit a texture using mapping operations. 



This is the Color control of the Texture Mapper bar. 
To color the current face:
n Click on the Color control. After the dialog box appears, click the desired color, then click OK.



This is the texture transparency control. Click this button to cycle through the predefined texture transparency 
masks.



This is the pin that is used in texture mapping operations. 



This is the Perspective View window. 3D scenes are viewed here. You may navigate the current camera using the 
mouse or keyboard.



Customize command (Tools menu) 
Customizes the toolbars. Allows you to modify a toolbar’s button set. 



Toolbars command (View menu)
Displays or hides selected toolbars. Creates or resets toolbars to their built-in settings.



Displays or hides the Painter toolbar.



This is the Transparency Mask control of the Texture Mapper bar. 
To define the current texture transparency mask: 
n Click a grid cell to invert its color. Black cells define transparent points, while white ones define opaque points. 



This is the texture animation control of the Texture Mapper bar. It is used to create moving textures.
To animate the current texture:    
1 Drag the red arm of the animation control to set the direction and speed of the texture motion. 
2 To start motion, click the Start button.
A longer arm means faster motion. The direction of the texture motion is defined with arm direction.



This is the camera tab.    Selects the camera from the list.



This is a user defined layout.



This is a user defined layout.



This is a user defined layout.



This is a user defined layout.



This is a user defined layout.



This is a user defined layout.



Drag and drop this ISB screen item onto another screen location. Hold down the Ctrl key while dragging it to 
prevent it from docking prematurely. 



New command (File menu) 
Creates a new scene. The scene is initially empty. All its parameters, such as camera position, grid spacing, etc. 
have default values. 



Open command (File menu) 
Opens a scene from a specified file. 



Save command (File menu) 
Save the current scene into the same file it was taken from. 



Save as command (File menu) 
Save the current scene into the specified file. 



Print Setup command (File menu) 
Displays printing options. 



Delete command (Edit menu) 
Deletes the selected object from the scene. Extracts a shape from the current object. 



Copy command (Edit menu) 
Copies the selected object onto the clipboard. Copies a part of the current object (specified with a shape) onto 
the clipboard. 



Cut command (Edit menu) 
Cuts the selected object from the current scene and places it into the clipboard. Cuts a part of the current object 
(specified with a shape) onto the clipboard. 



Paste command (Edit menu) 
Inserts an object currently stored on the clipboard onto a scene. The object can be inserted at the scene origin 
coordinate, or at a particular place in a scene. 



Undo command (Edit menu) 
Reverses the last editing operation. 



Redo command (Edit menu) 
Recreates the last undone operation. 



About ISB command (Help menu) 
Displays ISB copyright and version number. 



Exit command (File menu) 
Exits from ISB. Asks for confirmation if the current scene is not saved. 



Help button (Standard toolbar)
Use this button to get help without interrupting your work. 

For an explanation of any item such as a menu command, a toolbar button, a dialog box, or a screen item:
n Click the Help button on the Standard toolbar, then click on the item,
n Position the pointer over the item and press F1 while holding down the left mouse button.

For a brief description of a menu command:
n Position the pointer over the command. The description appears on the Status bar.

For a description of a toolbar button:
n Position the pointer over the button. The name appears below the button.



Toolbars command (View menu)
 Displays or hides the selected toolbars, creates new toolbars, resets toolbars to built-in settings and defines 
availability of toolbars. 



Status bar command (View menu) 
Displays or hides the ISB status bar. 



To close ISB, click Close on the ISB Control menu. 



To restore the ISB window to its previous size and location, click Restore on the ISB Control menu. 



This is the Texture gallery. To texture a face, drag & drop the texture onto the face in the Perspective View 
window. To view another texture category, click it’s tab on the tab strip. 



This is the Picture gallery. To place a picture onto a face, drag & drop the picture onto the face in the Perspective 
View window. To view another picture category, click its tab on the tab strip. 



This is the Shape gallery. To include a shape into a scene, drag & drop the shape into the Plan window. To view 
another shape category, click its tab on the tab strip. 



This is the Object gallery. To place a object into a scene, drag & drop the object into the Perspective View 
window. To view another object category, click its tab on the tab strip. 



This is the Scene gallery. To open a scene, double click on its preview. To view another scene category, click its 
tab on the tab strip.



Save Next Shape button (Tools toolbar) 
Saves the next shape you will create in the Shape gallery for future use. 



Floating toolbar
A toolbar that is not docked to the edge of any ISB Window. Such a toolbar has a title on the top of its window.



Docked toolbar
A toolbar that is attached, or anchored, to an edge of an ISB window. Its window has no title. You may dock the 
toolbar below the menu or to the left, right, top, or bottom edge of the window. When you drag a toolbar to the 
edge of the window, the toolbar outline snaps to the edge. When you drop the toolbar after its outline snaps, it 
docks to the edge of the window.



Flip Horizontal command (Paint menu)
Flips a picture or texture horizontally. 



Flip Vertical command (Paint menu)
Flips a picture or texture vertically.



Adjust Colors command (Paint menu)
Displays the dialog box to adjust the current color of the Colors toolbar. 



This is the Scene tree window. This window represents the scene graph and scene objects hierarchy.



Turns on the Normal layout. 



Turns on the Simple layout. 



Turns on the Professional layout. 



Decrease Smoothness
Simplifies the Spline Shape (it will appear rougher).



Increase Smoothness
Smoothes out the Spline Shape.



Decrease Tension.
Rounds out the curves of the Spline shape.



Increase Tension.
Aligns the Spline shape curve to the polygon vertexes more closely. 



Object edit    
Starts the Object Editing mode.
Back to scene
Returns the user to the default scene editing mode from the object editing mode.
Note:
Only one of the above commands is available at a time.



Spline 
Turns on and off the Spline mode to create a shape using a smooth curve. 



Go to object button (Camera toolbar)
Fits the current object’s bounding box to the Perspective View window.



This is the Painter window. In this window you can draw or edit the picture or texture using the Painter tools.    





Set tool properties box (Paint toolbar)
You can set the properties of current painting/editing tool by clicking the items in this box.
The following options are available:

n     Drawing shape - for Pencil, Stylus and Brush.

n     Line width - for Line and Rectangle.

n  Selection mode - for Select tool. 

n  Zoom value - for the Magnify button.    



This dialog box allows you to set options for saving an object.
n Scene. Choose this item to place the object in the scene.
n Clipboard. Choose this item to place the object on the clipboard.
n Object gallery. Choose this item to save the object to the Object gallery.
n Name. Define the text label with which is displayed with the object preview in the Object gallery.
n Category. Choose the gallery where the object is to be included.



Opens the gallery item for editing.



Enable/disable moving and resizing the picture or movie along face in the Perspective View window with your 
mouse.



Shape properties
This dialog box displays statistics for the shape included into the scene:
n Name: the name of the shape included into the scene. 
n Shapes: the number of shapes in the current shape (may be more than one for composite shape).
Information about the number of vertexes, faces, textures are also displayed. You cannot edit these properties, 
they are displayed for information purposes only.



This command starts the Object Editing mode.



To move the active camera up or down:
n Drag the Camera icon using the left ring



To turn the active camera up or down:
n Drag the Camera Icon using the right ring.



Shape gallery
Gallery of    basic and custom shapes used to create scene, objects and composite shapes. The basic shapes are 
already defined in ISB. You may add your own shapes to any category of the Shape gallery. 



Manipulator’s moving point



Manipulator’s resize jack



Manipulator’s lever



Ruler Window
Click on the picture below to get the explanation of Ruler Window controls.



Ruler height control latch
The top and bottom latches of the Ruler define the position of the top and bottom faces of the shape or object 
bounding box.



Gray Ruler.    
Corresponds to the shape currently included into a scene but not yet applied. With the help of the gray Ruler, 
you can set the height for this shape. 



Red Ruler.
Corresponds to the current scene object. With the help of the red Ruler, you can change the height of the current
object.



Top Guide line.
It defines the vertical position of the top face of the shape bounding box when included into the scene.



Bottom Guide line.
It defines the vertical position of the bottom face of the shape bounding box when included into the scene.



Ruler scale. 
Shows the camera and objects vertical position in meters. 



Camera Icon. 
Shows the vertical position and orientation of the current camera in the Ruler window. 



Texture gallery 
A collection of textures, sorted by category. You may edit, remove or add new textures into any category of the 
gallery.



Color toolbar
Displayed in the 
right side of ISB 
window. Pick the 
color to paint the
face of the 
object here.



Object gallery
A collection of pre-built objects, sorted by category. You may add, edit or delete any object to any gallery 
category.



Texture Mapper bar
Click on the 
image to get the
explanation of 
texture mapper 
bar controls.

Face color. Displays the color under the texture of the currently selected face.



Transparency mask grid. Displays the transparency mask pattern. 



Texture motion velocity control area. Drag the red arm to set the motion speed and direction. 



Predefined transparency mask selection buttons.



Texture moving Start / Stop button.



Paint toolbar

Click on the image to get the explanations of the controls.



Choose color area
Pick the desired color for painting in this area of toolbox.





Main menu

Located at the top of the screen. 



Standard toolbar
File operations and Undo/Redo operations.



Camera toolbar

Operations with camera (alignment, duplication, etc.)



Edit toolbar
Scene editing and shape creation operations



Plan toolbar
Controls for basic building modes, zooming, enabling plan ruler and fitting plan to the window.



Simple layout 
Click on the image below to get the explanation for each window.



Switch toolbar
Allows you to turn the galleries of textures, pictures and movies on and off. 



Zoom Control toolbar
Allows you to change the plan window scale.



Pinocchio Icon





Scene gallery
A collection of already built Scenes which you can load, view and edit. You can add your own scene to any 
category of the Scene gallery. 



Picture gallery
A collection of pictures. You can edit any picture or add your own to the Picture gallery. 



Movie gallery
A collection of ready movies. You may edit movies or add your own to the Movie gallery. 





Color control box.
Click the desired color to paint.



This is the Movie gallery. To place a movie onto a face drag & drop the movie onto the face in the Perspective 
View window. 



Scene Tree window
This window represents the scene graph and scene objects hierarchy.



Plan window
The top and front    views of the plan are shown here. You can change the relative sizes of the Top and Front    
View windows by dragging the splitting box of the Plan window.



Perspective View window
3D scenes are viewed here. You may navigate the current camera using the mouse or keyboard.



Builder toolbar
Combines the functions of the Edit and Plan toolbars in the Normal layout. Contains controls for scene editing 
and shape creation operations, basic building modes and for enabling the plan ruler.



Scene Tree.
This is an example 
of the Scene Tree. 
You see a number of
objects and sub-
objects, organized 
into a hierarchic 
structure.



    Line width 
Select the desired line width for line or rectangle in this area. 



    Selection mode 
Click this icon to move or copy a selected rectangle as a whole.



    Selection mode 
Click this icon to move or copy only those points of the area    whose colors are different than the current color 
selected in the Colors toolbar.



    Zoom level
Choose the level of magnification in this area.



    Select the drawing shape
Click here to select the drawing shape for the Pencil, Stylus and Brush tools. 




