
Palette Images

Palette images use a color table which determines the color usage for the image. Each pixel in the image is 
mapped to a particular color in the table, or palette. Each color in the palette is identified by its index number, or
value which corresponds to its position in the table. 
The image palette appears as a table of color bars, located at the bottom of the image window. Each bar (or 
square) in the palette represents a color and has its own index value, which ranges from 0 to 255 (256 colors). 
The first, top-left, position has an index value of 0, and the last, bottom-right, position has an index value of 255.
Palettes can also exist independently of an image. You can create and save palette documents from a Palette 
window. 
If an opened image appears in an Image window without an associated palette, it is an RGB image and does not 
use a palette. Although all images use colors which are defined by their RGB values, we refer to a non-indexed 
image as an RGB image, as its pixel colors are independent of a color table.



Opening a Saved Palette 

You can open any saved palette using the File>Open>Palette command to open the Open Palette dialog and 
selecting the desired palette file on your system. 
The Open Palette dialog window defaults to the designated palette directory, as it is set in the Directories 
Preferences. You can also use the open controls to select a saved palette from another directory.
The Open Palette dialog also defaults to the palette file type and displays only files of that type. Saved palettes 
have a default file extension of .PAL. You can view all available files by selecting All Files from the Files of type 
drop-down menu..
Once you have selected the desired palette file, click OK to open the palette. The opened palette appears in a 
Palette window  within the DeBabelizer Pro main window.
By default, the palette color table contains 256 spaces. If the displayed palette has less than 256 colors, the 
unused spaces appear with white circles (indicating that these index values are undefined.)
Palettes may contain the same color in more than one space, or index value. You can remove duplicate colors 
using the Palette>Remove Colors submenu. 



Using Palette Files

Palettes are one of the most important resources that you will use when processing images in DeBabelizer Pro. 
Therefore, management functions such as creating, editing, saving, and saving palettes enable you to streamline
and coordinate your work more effectively. 
DeBabelizer Pro automatically loads a number of pre-defined, default palettes, in the Palettes subdirectory. You 
can edit any one of these palettes, save the modified palette as a new palette, and add it to the Palette drop-
down list.



Creating a New Palette

There are a few ways that you can create a new stand-alone palette. The method you choose depends upon the 
color information you want to include and hoe you plan to use the palette.
To create a new palette you can:
n Select the File>New>Palette... command, and specify the number of palette colors in the New Palette dialog. 

The new palette appears in a Palette window containing the number of specified color bars, filled with a 
standard grayscale.

n If you have a selected SuperPalette window, select the SuperPalette>Create Palette command. DeBabelizer 
Pro creates a new palette using the number and colors identical to those contained in the SuperPalette. 

n If you have a selected Image window containing a palette image, select the Palette>Create Palette command. 
DeBabelizer Pro creates a new Palette window using the number and colors identical to those contained in the 
image’s palette. 



Viewing Palette Information

The Palette Info dialog displays the color information for each color contained in the palette. This dialog displays 
a table listing of each index value, its color swatch, RGB, HSV, or YIQ information, and (for image palettes only) 
the number of pixels used.
To view information for the selected palette window, select the View>Properties... command. To view the palette 
information for a selected image, select View>:Properties... and click the Palette Info tab. 
You can also print palette property information.



Printing Palette Information

The Palette Properties information can be printed from the default printer. To print the property information for 
the selected palette or palette image, select the File>Print>Print Properties... command. The Print Palette Info 
Options dialog appears.
Use this dialog to specify the palette information you want to print. You can print the color information using HSV
or RGB values, and list all palette colors or (for image palettes) only those used by the associated image. Select 
the Print colors option to print a color sample of each color next to its property information (useful for printing 
from a color printer).



Saving Palettes

Any modifications that you have made to an image’s palette are saved when you save the image. You can also 
save any palette as a palette file, and then access and apply that palette to any image. 
To save any modifications made to the selected palette, select the File>Save command. DeBabelizer Pro saves 
the current palette, overwriting the original. 
To save a new palette or save a modified palette using another name, select the File>:Save As... command. The 
Save As dialog appears displaying the default file name and directory for palette files.
This dialog defaults to the designated palette directory, specified in the Preferences dialog. You can also use the 
dialog controls to select another directory. 
Enter the desired file name in the File name field and click Save to save the palette. Using the .PAL extension is 
recommended and will make retrieving the palette document easier.



Combining Palettes

You can combine, or merge the palette of the currently selected image or the currently selected Palette window 
with any saved palette. To merge, or combine two palettes:
1 Select the Palette>Merge... command. The Merge Palette dialog appears. The Merge Palette dialog displays 

the source palette (on the left), the current palette (in the middle), and a final palette (on the right). 
2 Use the Merge Palette drop-down list to select a source palette. You can select any saved palette in the default

palette directory from the drop-down list. To select a palette that does not appear in the Source Palette list, 
click on the arrow button and select any open palette or use the Open dialog to select another palette file from
any directory on your system.

3 Specify the number of colors to be copied. Use the first field to enter the number of colors to be copied from 
the source palette to the current palette. The copied colors must be a range, or sequence of colors in the 
palette. You can also use the mouse to select the colors directly from the displayed source palette.

4 Identify the source and current range index values. Enter the first index value for the source palette (colors to 
be copied) and the starting index value for the current palette (colors to be replaced) in the second and third 
fields. DeBabelizer Pro automatically calculates the ending values based upon the number of colors specified. 
You can also use the mouse to select index values directly on the displayed current palette.

5 Click OK to save the current palette as it appears in the dialog. If the palette is an image palette, DeBabelizer 
Pro automatically remaps the image to the modified palette. 



Sorting Palettes

You can sort the colors in an image palette based upon a number of criteria. You can select the Palette>Sort 
submenu and choose one of the sort command options to sort the selected image palette or palette document. 
When you sort an image palette, the pixels are remapped to the new index value. Sorting the palette does not 
change the color usage of the image pixels, only the index values to which they are mapped. The following 
options are available for sorting palette colors in either ascending or descending order:
n RGB 
n Brightness
n HSB
n HBS
n Popularity
You can also perform a custom sort, which allows you to omit a specified color or range of colors during the sort. 
To perform a custom sort on the selected palette:
1 Select the Palette>Sort>Specify... command. The Sort Palette dialog appears. The Sort Palette dialog displays 

the current palette, and a preview of the sorted palette based upon the current option settings.
2 Set the sort Options. Use the Sort by drop-down menu to select the criteria by which DeBabelizer Pro will sort 

the palette. The options available in the drop-down menu are the same as the sort command options, listed 
above. When you change the sort option, the sorted palette immediately displays a preview of the resulting 
palette.

3 Specify the Sort Order. You can select either an ascending (low to high) or descending (high to low) sort order. 
When you change the sort order, the sorted palette immediately displays a preview of the resulting palette.

4 Specify any color or range or colors to be omitted from the sort. You can use the mouse to mark these colors 
on the current palette displayed in the dialog (hold the Shift key down to select    range of colors, or the Ctrl 
key to select multiple, non-sequential colors). Select the Do NOT use off limit  option to omit the marked colors
from the sort operation. When this option is selected, the marked colors are protected.

5 Click OK to sort the current palette using the current settings. The displayed palette in the Image or Palette 
window changes to reflect the specified sort.



Removing Unused and Duplicate Colors

A palette image may have extra colors in its color table. Extra colors may be colors which are duplicates (the 
same color is used for more than one index value, or colors that are not used by any pixels in the associated 
image).
To remove duplicate colors from the selected palette or image palette, select the Palette>Remove Colors: 
Duplicates Only command. To remove unused colors from the selected image palette, select the Palette>Remove
Colors> Unused Only command. To remove both the duplicate and the unused colors from the selected image 
palette, select the Palette>Remove Colors>Unused and Duplicates command. 
When you select any of these commands, DeBabelizer Pro removes the colors and remaps the appropriate image
pixels; the empty spaces on the palette are grayed out.
 



Remapping an Image to a Palette

You can remap any RGB or palette image to any palette in    DeBabelizer Pro’s main window. Select an open 
palette window and use the mouse to grab the ActionArrow at the top of the window, and then drag and drop it 
onto the desired image. DeBabelizer Pro automatically remaps pixels in the image to the palette. 
If the image is currently a palette image, DeBabelizer replaces the image's palette with the new palette and 
remaps the pixels accordingly. If the image is currently an RGB image, DeBabelizer remaps the pixels to the 
palette and converts the image to palette image, adjusting the pixel depth accordingly.



Modifying Palettes

DeBabelizer Pro includes a number of functions that allow you to manipulate and adjust palettes. Most of these 
functions are available only when you have selected a Palette window or Image window containing a palette 
image.
You can adjust the rearrange palette colors, as well as equalize the saturation and brightness. You can also adjust
the palette for NTSC/PAL output.



Marking Palette Colors

You can mark, or flag, an individual color or range of colors  on a palette as transparent, undefined, or off limits. 
To flag a single palette color, double-click on a the color square in the palette. To flag a range of palette colors, 
place the eye dropper cursor over the first color in the range, hold down the Shift key and click on the last color, 
and continue to hold the Shift key while double-clicking on the last color in the range. The Palette Properties 
dialog appears displaying property setting for the settings for the selected index value(s).
To flag a palette color as transparent, select the Transparent option; that color becomes transparent for any 
floater on an image. Any pixel in the floating selection using a palette color that is flagged transparent will 
appear transparent, and the selection pixels will not overwrite the underlying pixels when the selection is 
stamped onto the image. 
To flag a palette color as off limit (or protected), select the Off Limit option; command functions such as Adjust 
HSV, Adjust Intensity/Contrast, and Sort Palette exclude the off limit color from the executed adjustment.
To flag a palette color as undefined, select the Undefined option. This index value is treated as an empty space in
the palette. You can un-select this option at any time and return the index value to its original color.



Creating a Gradient

You can use the Palette Properties dialog to create a color gradient across a range of palette colors. To create a 
color gradient, select a range of colors on the desired palette and double-click while holding the Shift key. The 
Palette Properties dialog appears displaying general properties options.
The Range Info settings allow you to specify an RGB value for the first and last palette color in the selected index
range. You can click on the tab for either the first or last index value of the range and use the color window to 
select a new color for that index value, or you can use the RGB field in the General options to enter known RGB 
values.
When you change the color values for the first and last index value in the range and click OK, DeBabelizer Pro 
changes the first and last palette color as specified and changes the remaining colors in the range to represent a
gradient between the first and last.
You can also use the Transparent, Off Limit, and Undefined options to flag the selected range of palette colors. 



Rearranging/Translating Palette Colors

Translating palette colors involves rearranging the colors within the color table, which changes the index value of
a moved or replaced color. You can move a range of values or an individual color for an image palette, or a 
palette document. 
Use the Palette pop-up menu (right-click on the palette) to select a rearrange/remap setting. The check mark 
indicates the currently active setting. The setting that you select determines the way that DeBabelizer Pro 
executes the specified rearrangement.
n Remap Pixels
n Rearrange Palette
n Rearrange Palette and Remap Pixels 
In addition to the above settings, you can select the Remap to closest setting from the Palette pop-up menu.
To rearrange palette colors:
1 Move the cursor over an open palette window or image palette. The cursor becomes an Eyedropper.
2 Click on one color, or select a color range. The selected color or range appears highlighted.
3 Drag the selected color(s) to a new location. DeBabelizer Pro performs the specified translation based upon 

the current translation setting
When you are working with an image palette (a palette associated with an image), rearranging the colors in the 
palette can modify the palette only, the image pixels only, or both. DeBabelizer Pro executes the color 
movement based upon the current setting in the image palette pop-up menu.



The Palette Pop-up Menu

Palettes and image palettes have a unique pop-up menu containing command functions that allow you to change
a number of palette properties, including rearranging palette colors and changing the size of the palette bars. 
These functions are specific to palettes that are contained in an image document. To access the Image Palette 
pop-up menu, move the cursor over the image palette, and right-click. You can then select the appropriate menu
command.



Changing the Palette Bars

You can change the size of the image palette color bars and display the index values using the Palette Bar Size 
dialog. To open the dialog, select the Set Palette Size... command from the Palette pop-up menu.
Use the up and down arrow buttons to increase or decrease the width or height of the palette bars in pixels, or 
enter the desired number into the field. 
Select the Show Indexes option to display index values in the palette bars. When this option is selected the index
values appear in the upper left corner of each bar. You can also use the Show Indexes command in the Image 
Palette pop-up menu to display and hide index values. 



Color Reduction

Select the Palette>Reduce Colors... command to set the color reduction options and reduce the number of image
colors. You can use this function to index an RGB image to 256 colors or less, reduce the current number of 
colors for a palette image, or reduce the number of colors in a palette document. 
The Reduce Colors dialog contains a number of options that you can use to specify the way that you want to 
perform the color reduction. You can then apply the reduction to the selected image, movie, or BatchList.
To reduce the number of colors in the selected image:
1 Select the Palette>Reduce Colors... command. The Reduce Colors dialog appears.

Image Info - If the selected image is a palette image, the Image Info panel at the bottom of the dialog displays 
the highest color index value used and the number of colors currently used in the selected palette. 

2 Specify the target number for the reduced palette. You can select a number from the Target number of colors 
drop-down menu, or manually enter the desired number of colors (between 1 and 256).

3 Select the Dither option to automatically apply dithering during the reduction process. A check mark appears 
in the checkbox when this option is selected. DeBabelizer Pro uses the current dithering options settings when 
dithering the image. You can access dithering options by selecting the Dithering Options tab.

4 Select a Reduction Method option. DeBabelizer Pro uses one of two methods for analyzing and reducing color 
usage.
n Fast
n Slow

5 Select a base palette  to be included in the reduced palette. 
6 Click OK to reduce the number of colors for the selected image and remap the pixels based upon the current 

settings. If the selected image is a palette image, DeBabelizer Pro alters the palette based upon the dialog 
settings. If the selected image is an RGB image, DeBabelizer Pro converts it to a palette image, creating a new
palette based upon the dialog settings.

Another method of performing a quick color reduction for an image is reducing its bit (pixel) depth. When you 
reduce the bit depth of an RGB image to 8-bits or less (256 colors or less), DeBabelizer Pro automatically 
generates a color palette and performs the necessary remapping. You can also select a lower pixel depth for a 
palette image to reduce the number of colors in the image’s palette.



Using a Base Palette

If you want to designate a base palette which will automatically be included in a new palette or SuperPalette, 
select the Use Base Palette option in the New Palette, New SuperPalette, or SuperPalette Properties dialogs and 
choose the desired palette from the Palette drop-down list. Only palettes with fewer than the specified target 
number are available for selection. The selected base palette appears in the dialog.
To omit any of the base palette colors, select the Do NOT use marked colors option and specify the undesired 
colors. Move the cursor over the palette and click on the colors you want to mark. You can also click the Check 
All button to mark all of the colors, or the Clear All button to clear (unmark) all marked colors. 



Remapping an Image to a Palette

You can remap any open RGB or palette image to any palette in a Palette window using your mouse. Select the 
Palette window and use the mouse to drag the ActionArrow    at the top of the window, and drop it onto the 
desired image. DeBabelizer Pro automatically remaps pixels in the image to the palette. 
You can also remap images in an open BatchList window to a Palette by dragging the ActionArrow    of the Palette 
window onto the BatchList window
Use the Set Palette and Remap dialog to remap the selected image to any open or saved palette document, and 
set remapping options. You can also designate colors on the palette for DeBabelizer Pro to omit when performing
the image remapping process. To use this dialog for remapping an image to a palette:
1 Select the Palette>Set Palette & Remap... command. The Set Palette and Remap dialog appears.
2 Use the Palette drop-down list to select a saved palette from the default palette directory, or click the arrow 

button to access any open palette document or access the Open dialog to select a palette file from anywhere 
on your system.

3 Set the Remap options. You can turn dithering and remapping on or off by clicking on the appropriate 
checkbox. To set the selected palette to the image without remapping the pixels, turn off the Remap Pixels 
option (if this option is turned off, the palette becomes a part of the image document, but the image pixels 
remain unaltered). This results in a color shifted image.

4 Specify any color or range of colors to be designated as off limit during the remapping process, if desired. Use 
the mouse to mark colors on the selected palette displayed in the dialog. Select the Do NOT use marked colors
option and DeBabelizer Pro includes the colors in the image’s palette but does not include them when 
remapping the pixels.

5 Click OK to set the selected palette to the image according to the current dialog settings. The selected image 
document changes to reflect its new palette.

If the image is currently a palette image, DeBabelizer Pro replaces the image’s palette with the new palette and 
remaps the pixels accordingly. If the image is currently an RGB image, DeBabelizer Pro remaps the pixels to the 
palette and the image becomes a palette (indexed) image.



Converting Color Images to Grayscale

You can use DeBabelizer Pro’s grayscale conversion functions to convert a color image to grayscale, or reduce 
the number of grays for a grayscale image. When you convert an image to a grayscale you are essentially 
performing a color reduction, restricting the image to a palette of a specified number of gray shades. Each 
function applies a particular number of grays (shades of gray), with or without dithering. 
You can select the desired Grayscale conversion command from the Palette>Convert to Grayscale submenu.
n 4 Grays Dithered
n 16 Grays Dithered
n 32 Grays Dithered
n 64 Grays Dithered
n 128 Grays Dithered
n 4 Grays
n 16 Grays
n 32 Grays
n 64 Grays
n 128 Grays
n 256 Grays
If you select an option that applies dithering, DeBabelizer Pro dithers the image based upon the current dithering
option settings. 
You can also specify a Grayscale conversion using the Convert to Grayscale dialog. To access this dialog, select 
the Palette>Convert to Grayscale>Specify... command.
You can select from any of the number of grays available from the Palette>Convert to Grayscale submenu and 
access the dithering options.



Converting Images to Black and White

Converting images to black and white is a special color reduction function. There are two methods that 
DeBabelizer Pro uses for translating image colors to black and white. You can use either method by selecting a 
black and white conversion command from the Palette>Convert to Black and White submenu, or using the 
Convert to Black and White dialog.
To convert the selected image to black and white using a command function, select the Palette>Convert to Black
and White submenu and choose the appropriate command.
Black & White Dithered... 
Use this command to convert the selected image using dithering. The Black and White Dither dialog appears, 
allowing you to adjust the dithering setting for the currently selected image. 
Black & White Threshold...
Select this command to convert the selected image using a threshold to determine which image pixels are 
translated to black and which are translated to white. DeBabelizer Pro converts the pixels based upon the current
threshold option settings.    



Black and White Threshold

The Black and White Threshold dialog contains a histogram of the pixel intensity values of the selected image. 
Use this graph as a guide for selecting the appropriate threshold value for black and white conversion.
To adjust the black and white conversion on-screen:
1 Select a Threshold Conversion option. Thresholding uses a pixel’s color usage level to determine how the pixel 

is converted. Pixels with a color usage value below the specified threshold value become black and those 
above it become white. 

n To specify a percentage threshold value, select the Do by black percentage option and enter the desired 
percentage value (between 1 and 99) in the field. This is the default method.

n To specify a straight threshold value, select the Do by threshold value option and enter the desired absolute 
threshold value (between 1 and 255) in the field. 

2 Click OK to reduce the selected image to black and white using the current settings. You can also click Cancel 
to exit the dialog without modifying the selected image.



Changing Pixel Depth

Pixel depth refers to the number of bits used to store the colors for each pixel. The greater the pixel depth, the 
more colors that are available for each pixel. You can increase or decrease the pixel depth of a selected image.
If you decrease the pixel depth, the available colors are reduced and color values in the image may change. If 
you increase the pixel depth, DeBabelizer Pro does not add colors to the image, but it does change the way that 
the image’s color palette is stored.
When selecting a new pixel depth of eight bits or less, you can apply dithering. DeBabelizer Pro will dither the 
image based upon the current dithering options settings.
To change pixel depth of the selected image:
1 Choose the Palette>Set Pixel Depth submenu, and select the desired pixel depth, with or without dithering. 

DeBabelizer Pro immediately converts the image to the selected pixel depth and performs any necessary 
remapping. (You can also select the Specify... command or click on the    toolbar button to open the Pixel Depth
dialog and select a pixel depth.)

2 Click OK to change the pixel depth using the current settings. DeBabelizer Pro remaps image pixels if 
necessary.

When you save the modified image, you should select a file format which supports the final pixel depth of the 
image, otherwise important color information may be lost. 



Equalizing Palettes

Equalizing an image palette evenly distributes the brightness and/or saturation levels of the pixels in the 
selected palette image. You may want to experiment with this feature in order to achieve the desired result.
To equalize the colors in a palette:
1 Select the Palette>Equalize... command. The Equalize palette dialog appears.
2 Select the appropriate Equalize setting. You can choose one of the three Equalize option settings.
n Brightness
n Saturation
n Brightness and Saturation
3 Click OK to equalize the selected palette using the current setting.



Creating a SuperPalette

When you construct a SuperPalette, DeBabelizer Pro analyzes the color usage of a group of images and selects 
the colors with highest usage across all the contributing images. These contributing images can have any 
number of colors, but the resulting SuperPalette is limited to 256 colors or less. 
You construct a SuperPalette by polling the images that contribute to the palette. You can allow each contributing
image an equal vote, or you can skew the results and weight the SuperPalette in favor of certain images by 
giving them more votes.
To create a new SuperPalette:
1 Select the File>New>SuperPalette... command. The New SuperPalette dialog appears.
2 Specify the Number of Colors. Select a number from the Target number of colors drop-down menu, or enter the

desired number of colors, between 1 and 256, in the field. The default number is 256.
3 Select a base palette to be included in the SuperPalette. 
4 Select the Factor in all open images option to automatically construct the Super Palette using all open images. 

When you select this option, DeBabelizer Pro analyzes the color usage for each open image, and constructs 
the appropriate SuperPalette. (If you do not select this option, the newly created SuperPalette will contain any 
selected base palette and gray in the remaining spaces in its color table.)

5 Click OK to create the SuperPalette using the current option settings. The newly created SuperPalette appears 
in a SuperPalette window within the DeBabelizer Pro main window.

If you specified a base palette to be included in the new SuperPalette, the base palette colors appear flagged at 
the top of the palette. These flagged colors will remain unchanged even if you add other images into the 
calculation.
You can also create a new SuperPalette for a selected BatchList using the Batch>Create SuperPalette command. 
When you select this command, DeBabelizer Pro automatically calculates the new SuperPalette using each 
image in the selected BatchList.



Adding Images to the SuperPalette

When you add an image or movie frame to a SuperPalette, DeBabelizer Pro analyzes the color usage of the 
pixels in that image and recalculates the SuperPalette based upon the additional image information. There are a 
number of ways to add an image or movie to the selected SuperPalette. You can use any of these methods: 
n Select the SuperPalette>Factor in File... command and select the desired image file from the SuperPalette Add 

Files dialog. Click Factor In to automatically add the selected image to the SuperPalette. You can repeat this 
process to add as many files as you like. 

n Use the mouse to select the ActionArrow    on the title bar of any open Image window and drag it onto the 
SuperPalette window. DeBabelizer Pro automatically adds the image to the SuperPalette.

n Use the mouse to select image and/or movie files from any open BatchList window and drag the file(s) onto 
the SuperPalette window. DeBabelizer Pro automatically adds the file(s) to the SuperPalette.

n Use the mouse to select image or movie (.AVI) files from any system window on the Windows desktop and 
drag the image(s) onto the SuperPalette window. DeBabelizer Pro automatically adds the file(s) to the 
SuperPalette.



Changing SuperPalette Properties

A palette contains only information for its 256 or less colors. A SuperPalette not only contains color information 
for its current number of colors, but all the color information of each pixel in every contributing image or movie. 
This allows DeBabelizer Pro to re-calculate the SuperPalette if you change any of the parameters, or properties.
To view and/or change the properties of a selected SuperPalette, select the View>Properties... command. The 
SuperPalette Properties dialog appears.
The Statistics panel of the dialog displays information about the current SuperPalette including the number of 
images (frames), the number of colors, and the number of pixels factored.
You can use this dialog to change the number of colors in the SuperPalette and/or a base palette to the 
SuperPalette. You can also use this dialog to include a base palette  in the selected SuperPalette. 
When you click OK, DeBabelizer Pro re-calculates the SuperPalette based upon the changed properties.



Changing the Number of Colors in a SuperPalette

You can reduce or increase the number of colors in the selected SuperPalette at any time. DeBabelizer Pro re-
calculates the SuperPalette based upon the original color information, and produces a revised SuperPalette with 
the specified number of colors.
To change the number of color in the selected SuperPalette:
1 Select the View>Properties... command. The SuperPalette Properties dialog appears.
2 Specify the desired number of colors. Select a number from the Target number of colors drop-down menu, or 

enter a number, between 1 and 256, in the field.
3 Click OK to re-calculate the SuperPalette with the specified number of colors. The SuperPalette changes to 

reflect the specified number of colors.



Saving a SuperPalette

You can save any SuperPalette document as a SuperPalette (.DBP) file, which can then be opened during any 
DeBabelizer Pro session or applied during a Batch Automation process. 
To save the selected SuperPalette:
1 Select the File>Save or File>Save As... command or press Ctrl+S. The Save As dialog appears. This is a typical 

Windows Save dialog which defaults to the SuperPalette file type and .DBP extension.
2 Designate a directory where the saved SuperPalette file will reside. Use the dialog controls to browse through 

the available directories. The palette directory designated in the Preferences dialog is the default.
3 Enter the desired file name. You can use any name which conforms to Windows 95/NT standards. It is 

important to use the .DBP extension for easy recognition of the SuperPalette in the future.
4 Click Save to save the current SuperPalette to the designated file name and directory. 



Remapping Images to the SuperPalette

There are a number of ways to remap images and movies to a SuperPalette. You can remap images open in an 
Image window, movie frames, or images and/or movie frames listed in a BatchList window. Use any of these 
methods to remap images and movies to a SuperPalette.
n If the SuperPalette and image or movie are both open in the DeBabelizer Pro main window, you can use the 

mouse to grab the ActionArrow on the title bar of the SuperPalette and drag it onto the Image or Movie 
window. DeBabelizer Pro then remaps the image or movie to the SuperPalette.

n If the SuperPalette is open in the DeBabelizer Pro main window and the image(s) and/or movie(s) are listed in 
an open BatchList window, you can grab the ActionArrow from the title bar of the SuperPalette and drag it onto
any image in the BatchList, or drag it onto the BatchList folder to remap every image in the BatchList.

n Select an Image window and then select the Palette>Set Palette & Remap... command. Use the arrow button 
to select an open SuperPalette window or access the Open dialog and select any saved SuperPalette from 
anywhere on your system.



Fast

Select this option to use DeBabelizer Pro’s proprietary fastest high quality color reduction algorithm. 



Slow

Select this option to use DeBabelizer Pro’s proprietary slower high quality color reduction algorithm, especially 
made for images with 256 colors or less. This reduction can be used only for reducing image palettes with 256 
colors or less.



Single

Use this setting to perform a one to one translation or to translate a range of colors to one color. 



Range

Use this setting to translate a range, or number of palette colors to an equal number of colors. 



Closest

Use this setting to translate the specified colors and remap the associated pixels to the closest color on the 
palette.



Palette

Use this setting to change only the palette index values when you translate palette colors. DeBabelizer Pro 
changes the color index values according to the specified translation.



Both

Use this setting to translate both the image pixels and the palette index values. DeBabelizer Pro changes the 
color index values of the translated colors and remaps the appropriate pixels to the new index. 



Equalize Brightness

Choose this setting to evenly distribute the brightness level across the image. This process usually gives the 
image a higher contrast while preserving color information



Equalize Saturation

Choose this setting to evenly space the saturation levels across the image. This process usually results in a more
colorful image, although sometimes to the point of being too colorful (overly saturated).



Equalize Brightness and Saturation

Choose this setting to evenly distribute the brightness level and space the saturation levels across the image.



Sort by RGB

Select this command option to sort the palette according to Red, Green, and Blue values.



Sort by Brightness

Select this command option to sort the palette according to color brightness.



Sort by HSB

Select this command option to sort the palette according to Hue, Saturation, and Brightness values.



Sort by HBS

Select this command option to sort the palette according to Hue, Brightness, and Saturation values.



Sort by Popularity

Select this command option sorts an image palette according to pixel usage. This command option is available 
only for image palettes.



Remap Pixels

Use this setting to translate only the image pixels when you rearrange palette colors. DeBabelizer Pro remaps 
the appropriate image pixels according to specified color translation. If you are translating colors on a palette 
document, using this option will produce no effect, as there are no associated image pixels



Remap Pixels

Use this setting to change only the image pixels when you rearrange colors on the palette. DeBabelizer Pro 
remaps the appropriate pixels according to specified color translation.



Rearrange Palette

Use this setting to change only the palette index values when you rearrange colors on the palette. DeBabelizer 
Pro changes the color index values according to the specified translation. The image pixels appear unaffected.



Rearrange Palette and Remap Pixels

Use this setting to rearrange the palette index values and remap the corresponding image pixels. DeBabelizer 
Pro changes the color index values of the translated colors and remaps the appropriate pixels to the new index 
value. This setting results in an image that appears the same, but a palette that is rearranged.



Rearrange to Closest

Use this setting to rearrange the specified colors and remap the associated pixels to the closest color on the 
palette. You can then use the Remove Unused Colors function to remove the colors that have been replaced from
the palette. This allows you to consolidate your color usage. 



Creating a New Batch List

To create a new BatchList, select the File>New>BatchList command. A BatchList window appears in the 
DeBabelizer Pro main window, containing and empty batch folder. This window is titled BatchList1 (or BatchList2,
BatchList3, etc.) by default.
When a BatchList window is the selected item in the main window, the Batch menu appears. This menu includes 
command functions you can use to construct and save BatchListed files, as well as construct a SuperPalette for 
the BatchList. These commands are also available when you right-click on an open BatchList window, using the 
Batch pop-up menu.



Adding Files to a BatchList

When you open a new BatchList, it is empty (there are no image files in the list). You construct the BatchList by 
adding the desired document files to the list. There are a number of ways to add files to the list.

n Select the Batch>Add Files... command. The Add Files to BatchList dialog appears. This dialog operates as a 
standard Windows open dialog. Use the controls to browse and select file(s) or folder(s), and click Add to Batch 
to add the selected file(s) or folder(s)to the current BatchList.

n Select document files from any system window. Select the Tools>Start Explorer... command to start the 
Windows Explorer, or the start the My Computer utility from the Windows desktop to access any directory 
folder on your system. You can then use the mouse to drag the selected file(s) or folder(s) from the directory 
window into the BatchList window.

n Select images from another open BatchList window. Select any combination of files or folders from another 
BatchList and drag the selected items into the desired BatchList window.

Note : When you add a folder containing multiple sub-folders to a BatchList, only the first sub-directory 
containing valid graphics files is added as a sub-directory of files within the BatchList.
Note: Open images, movies, and BatchLists can be dragged into the BatchList window; however, dragging a 
palette or SuperPalette into a BatchList window would remap any image or movies documents in the list, and 
dragging a script onto a BatchList window would apply the script to the files contained in the BatchList. 



Adding Graphics to a BatchList from an HTML File

DeBabelizer Pro's HTML parsing feature allows you to extract each graphic file embedded in an HTML file into a 
BatchList. You can then use any of DeBabelizer Pro's powerful image processing functions to modify all of your 
web graphics and then save them over the original graphics files or to a new location of your web site. We 
suggest creating a BatchList for each web site that you want to work with, so that your web graphics or 
SuperPalettes do not become mixed up. 
For existing web sites, this feature will help you to quickly begin using the power of DeBabelizer Pro without the 
necessity of locating all of your graphics individually.
To extract graphics from an HTML file to a BatchList:
1 Open the desired BatchList. You can create a new BatchList or open an existing BatchList file.
2 Open the system directory window containing the HTML file. You can use the Windows Explorer or My 

Computer utility to locate the desired file.
3 Drag the HTML file onto the open BatchList window. DeBabelizer Pro automatically scans the contents of the 

HTML file, parses for valid graphics files, and places them in the BatchList.
Once you have created a BatchList containing your web graphics, create a SuperPalette and remap the images, 
change the pixel depth, or make any other image modification. After you have completed the desired changes, 
select the Batch>Batch Save command to save the contents of the BatchList. The HTML file(s) now reference the
updated graphics files.



Saving a BatchList

Once you have constructed a BatchList, you will likely want to save it. DeBabelizer Pro saves BatchLists as a 
unique file type (.DBB), which can then be opened into a BatchList window.
To save the selected BatchList:
1 Select the File>Save As... command. The Save As... dialog appears. This is a typical Windows Save dialog 

which defaults to the BatchList file type and .DBB extension.
2 Designate a directory where the saved BatchList file will reside. The dialog defaults to the designated 

BatchList directory, as specified in the Directories Preferences options. You can use the directory controls to 
select a directory from anywhere on your system.

3 Enter the desired file name. You can use any name which conforms to Windows 95/NT standards. It is 
important to use the .DBB extension in order to retrieve the BatchList for later use.

4 Click Save to save the current BatchList to the designated file name and directory.



Opening a Batch List

You can open any saved BatchList using the File>Open>BatchList... command. Select the desired BatchList from 
the Open BatchList dialog. 
The Open BatchList dialog defaults to the designated BatchList default directory. You can also use the open 
controls to select a saved BatchList from anywhere on your system. BatchList files typically have a .DBB 
extension.
Once you have selected the desired BatchList file, click OK to open the BatchList. The opened BatchList appears 
in the DeBabelizer Pro main window in a BatchList window.
The icons that appear next to each file name indicate the status of that file, or document. When the closed icon   
with a red arrow appears next to the file name, the file is closed, and when the open icon appears (green arrow), 
the file is currently open in the DeBabelizer Pro main window. 



Editing a Batch List

BatchLists are completely customizable. You can add or delete files from any list. You can then save the edited 
version as the original list, or save it as a new list. You can also utilize the Windows Explorer utility to access files 
from anywhere on your system.
In addition to images, BatchLists can contain other DeBabelizer Pro documents; this allows you to keep most of 
the files associated with a project in one list. You can also add palette files, SuperPalette files, movie (.AVI) files, 
as well as another BatchList file to any BatchList. 



Deleting files from the BatchList 

The BatchList windows use standard Windows file management operations. Files within the BatchList appear in 
the window in a hierarchical fashion. 
To delete a file from an open BatchList:
1 Use the mouse to select the file to be removed from the BatchList window. You can use the Shift and Ctrl keys 

to select multiple files. The selected files appear highlighted.
2 Press the Delete key. The highlighted files are removed from the BatchList window. 
Note: This operation removes files from the BatchList only; it does not delete the files from your system.



Using Batch Save

In many cases you will find it useful to convert or translate the entire contents of a BatchList to another image 
file format, or to simply save the image files to another directory. Instead of running a Batch Automation process,
you can use DeBabelizer Pro's Batch Save feature to save the files contained in a BatchList. 
In addition to performing simple file translation, you can rename, apply a saved script, and/or specify the bit 
depth to be output.
To save the image files in the selected BatchList window:
1 Select Batch>Batch Save... command. The Naming options dialog, prompting you to set naming options for 

the BatchListed files.
2 Use the directory controls to specify a destination directory for the saved files. You can specify any 

directory/folder on your system. You may want to make sure that there is enough available memory for the 
saved files.

3 Designate the File name parameters. The File name field displays the way that DeBabelizer Pro will generate 
the file names and extensions based currently selected naming options. If you want to overwrite the orginal 
files, select the Auto overwrite option.

4 Select the desired image file format. Use the Save in File Format drop-down menu to select a file format for the
saved image files. You can also use the Set form Image option to save files to their original file format. Some 
file formats have writer preference settings that you can access by clicking the Writer Preferences… button.

5 Select the desired number of colors. Use the Save at color depth drop-down menu to specify the number of 
colors for each saved image file. You can also select the Set from Image option. When this option is selected, 
DeBabelizer Pro saves each image file using the same number of colors as the original file.

6 Select a script to apply to each image before it is saved. Use the Pre Save do script drop-down list to select a 
saved script from the Scripts folder. If you do not want to apply a script to the image files before saving them, 
select None.

7 Select Save to save the BatchList image files. DeBabelizer Pro processes and saves each image in the 
BatchList based upon the option settings.



Using Naming Options

Naming options determine the default file name that appears when you open the Save As dialog and during a 
batch save  operation or batch automation process. These options allow you to save the processed images using 
a specified naming structure.
The window at the bottom of the Naming Options dialog displays the file naming structure based upon the 
currently selected options.
Use the Save Directory options to specify the destination directory. The directory selected in the Saving Options 
dialog (the specified directory) appears in the Save Directory window. You can select one of the following options:

n Specified Directory
n Original Directory relative to the specified directory
n Original Directory
Use the Save Filename options to specify the automatic naming of the processed and saved image files. You can 
select one of the following options.

n Specified File Name
n Original File Name
To append each filename with an incremented digit, select the Add batch iteration number after name check box.
Use Save Extension options to automatically generate file extensions for the processed and saved image files. 
You can select one of the following options.

n Specified extension
n No extension
n Use default extension for the specified file format
To append each file extension with an incremented digit, select the Add batch iteration number  after extension 
check box. When this option is selected, DeBabelizer Pro adds an incremented number to at the end of the 
extension of each saved image file. 



Using Batch Iteration Numbers

When the Add batch iteration number option is selected in the Naming Options dialog, DeBabelizer Pro adds an 
incremented number to each saved image file using the following logic:

n If the last character of the file name is not a number, 01(or 02, or 03, etc.) is appended to the file name.
n If the last character of the file name is a numeric character, that character will be incremented. (For example; 

FISH01.BMP would become FISH16.BMP, and FISH02.BMP would become FISH17.BMP, and so on.)



Specified Directory

Use this option to use the specified directory. This is the default setting.



Original Directory relative to the specified directory

Use this option to save each processed image to a directory of the same name as the original directory, and 
contained within the specified directory.



Original Directory

Use this option to save each processed image to its original directory. 



Specified File Name

Use this option to specify a file name to be used for each saved file. Enter the desired name in the 
accompanying field. This option should only be used when the processed files will be saved to different 
directories, are single animation files that will be saved to a movie (.AVI) file, or will be appended with an 
iteration number; otherwise each saved file will overwrite the previous one.



Original File Name

Use this option to save each processed file under the original file name.



Specified Extension

Use this option to specify a file name to be used for each saved file. Enter the desired extension in the 
accompanying field.



No Extension

Use this option to save processed image files without adding an extension.



use default extension for the specified format

Use this option to add the properly defined extension based upon the selected file format. (For example; a 
bitmap file format is saved with a .BMP extension, a JPEG image file format is saved with a .JPG extension, etc.)



Opening Images

Many of DeBabelizer Pro’s image manipulation and processing functions center around opening images into the 
main window. Opening an image not only displays it for viewing, but makes the image available for selection. 
When an Image window is selected, all of the Image menu commands are available, and their operations can be 
applied to the selected image. 
There are a number of ways to open an image file: 
n use the Open Image dialog, 
n use the mouse to drag-and-drop a file from an Explorer window into the DeBabelizer Pro main window, 
n double-click on an image file in a BatchList window, or
n execute an open operation from a script.



The Open Image Dialog

You can open any saved image file that DeBabelizer Pro reads using the Open Image dialog. This dialog contains 
standard Windows directory controls that you can use to select image files from anywhere in your system. It also 
allows you to filter the available image files in the current directory by file format.
To access the Open Image dialog, you can:
n select the File>Open>Image... command,
n press Ctrl+O, or
n click the Open Image toolbar button.
The Open Image dialog defaults to the designated image directory, as specified in the Preferences dialog.
In addition to navigating your system directories, you can use file filtering, image preview, view image file 
information, change reader preferences, and add an image file to a BatchList.



File Filtering

In the Open Image dialog, select Mac and Windows Image Files from the Files of Type drop-down menu to view all
image files in the selected directory. To view only image files of a specific format, select that format from the File 
of Type drop-down menu (this menu includes every graphic file format that DeBabelizer Pro currently reads). 
Only those files with the specified extension for the selected format are displayed in the file window.
Although, DeBabelizer Pro filters files by their extension for display purposes, when you select a file, DeBabelizer
Pro scans the file and determines the format by its contents. The format information is displayed under the 
preview window. 
The format setting is retained in the Open dialog until you change it by selecting another file format from the 
drop-down menu. 



File Information

When you select a file in the Open Image dialog, DeBabelizer Pro quickly scans it and then displays basic 
information about the selected file. You can use this information to determine that this file is the one that you 
want to open. 
n Format
n Attributes
n Size
n Created
n Modified



Image Preview

When working with large sets of image files, it is useful to be able to preview a file before opening it, to ensure 
that it is the file that you want to open. This is especially important when you have forgotten the name of the 
desired file or when a file name does not clearly describe its contents.
To preview an image file in the Open Image dialog, select the image by file name, and    select the Preview 
checkbox. DeBabelizer Pro displays the selected image in the preview window.
You can click Open to open the previewed image, or you can select another file name. Use the up and down 
arrow keys to scroll through the image files listed in the file window. The preview window changes, displaying 
each image that you select.



Adding the Image to a BatchList

You can add the selected image file to a BatchList from the Open Image dialog by selecting a BatchList from the 
BatchList drop-down list and clicking the Add to Batch button. The drop-down list contains only BatchLists that 
are currently open. 
You can also select a saved BatchList from anywhere on your system or create a new BatchList by clicking the 
Open button to the left of the BatchList drop-down list. Select Open from the pop-up menu to access the Open 
BatchList dialog and open a saved BatchList. Select New to create a new BatchList.



Image Properties

You can view property information for the selected image at any time by selecting the View>Properties... 
command. The Image Info dialog appears displaying information about the location, size, and last modification 
date of the image file. It also displays information about horizontal and vertical size (in pixels), dpi, bit depth, 
colors per pixel, and the active Selection Marquee (if there is one).
If the selected image has an associated palette, you can view palette property information by clicking the Palette
Info tab. 



Creating a New Image

You can create a new image by opening a new Image window. Select the File>New>Image... command or press 
Ctrl+N. The New Image dialog appears.
Use the New Image dialog to define the resolution and color parameters of the new image. You can set the 
following options:
n Units
n Size/DPI
n Colors
n Fill Color
When you have set the options for the new image as desired, click OK; an Image window  appears in the main 
window containing the selected fill color. You can use cut, copy any paste functions to copy graphics from other 
Image windows, or from other Windows applications.
You can also use the Set all from clipboard contents option to automatically set the size and dpi of the new 
image based upon the current contents of the Windows Clipboard. This option is useful if you have recently 
copied or cut graphic information to the Clipboard and intend to paste the contents into the newly created 
image.
If the Clipboard currently contains information in a recognizable format, you can also select the File>New>From 
Clipboard command to automatically create a new image using the contents of the Clipboard.



Select Number of Colors

Use this option in the New Image dialog to specify the number of colors (bit depth) for the image. Select one of 
the following options:
n RGB 17M Colors + Alpha - Use this option to create a 32 bit RGB image.
n RGB 17M Colors - Use this option to create a 24 bit RGB image.
n RGB 32768 Colors - Use this option to create a 15 bit RGB image.
n Select Palette - Use this option to create a palette (indexed) image. You can select a saved palette from the 

drop-down menu or an open palette using the arrow button. The number of colors in the selected palette is 
displayed below the palette.



Fill Color

When you create a new image, DeBabelizer Pro produces the new image using a single fill color. To change the 
current fill color, click the Fill Color tab. You can select an color using known RGB or HSV values, or click on the 
color window. If you are creating a palette image using a palette that does not contain this particular color, 
DeBabelizer Pro automatically determines the closest color in the palette and uses that as the fill color. You can 
also select a palette index value when creating a palette image.



Selecting an Image Area 

The Selection Marquee is the default tool in the Paint Tools toolbar, and it is active when you launch DeBabelizer 
Pro. When this tool is active, you can use the cursor as a selection device and define an area on an image. 
To select an area on an image using the Selection Marquee tool:
1 Move the cursor over an image. Notice that the cursor changes to cross-hair (+).
2 Holding the mouse button down, drag diagonally across the desired area. The marquee forms a selection 

frame around the area as you define it.
3 Release the mouse button. The selected portion of the image is contained within the marquee. This selection 

remains active until you make another selection or de-activate the current selection (select nothing). 
To replace the current marquee using the mouse, simply select another area on the image. To resize the 
marquee using the mouse, move the cursor over a corner of the marquee, and drag it to the desired location. 
Use the Shift key to maintain the aspect ratio. The mouse method usually works best for selecting larger areas 
visually.
You can also define a new selection or modify the current selection    on an image using the Select dialog. You can
use this dialog to define a selection using pixel measurements, which allows you to make a more precise 
selection. 



The Select Dialog

The Select dialog allows you to define a marquee (selected area) by specifying an exact location on the image 
where the marquee will be placed. 

To define a new selection on an image using the Select dialog:
1 Select the Edit>Select>Specify... command. The Select dialog appears.
2 Define the new selection. The values that you use to define the selection will depend upon the selection 

method that you choose.
n Absolute
n Relative 
3 Click OK to display the newly defined marquee. The marquee frames the selected area on the image.

To move or resize an existing marquee on an image using the Select dialog:
1 Select the Edit>Select>Specify... command. The Select dialog appears.
2 Specify the change in the boundaries of the current marquee. The values that you use to define the selection 

will depend upon the selection method that you choose.
n Move Absolute
n Move Relative
n Resize Absolute
n Resize Relative
3 Click OK to display the defined marquee. The marquee frames the selected area on the image.

You can also use the Select dialog to the entire image, using the All option. This equivalent to selecting the 
Edit>Select>All command, or pressing Ctrl + A. This removes any existing marquee and selects the entire 
image. You can also remove an existing marquee by selecting None from the Select dialog, selecting the 
Edit>Select>None command, or pressing Ctrl+D. 



Floating the Selection Marquee

Once you have a defined area on an image (framed by a marquee), you can either cut or copy the pixels inside 
of the marquee and float the selection on top of the existing image. A floating marquee can be moved to any 
location on the image, but does not alter any of the underlying pixels until the selection is stamped. Stamping a 
selection overwrites the underlying pixels with the selection, using the current transparency settings.
When you create a floating marquee using a copy function, the original image pixels in the selected area remain 
untouched and DeBabelizer Pro places a copy of the selected pixels in the marquee, which floats on top of the 
original image. 
To create a copy floater you can:
n hold the Ctrl key down and use the mouse to move the marquee, or 
n select the Edit>Select>Specify... command and use the Select Float option in the Select dialog.
When you create a floating marquee using a cut function, DeBabelizer Pro replaces the original image pixels with
the selected background color and places a copy of the selection pixels in the marquee, which floats on top of 
the original image. 
To create a cut floater, hold the Alt key down and use the mouse to move the marquee. You can move the floater
to any location on the image. It remains a floater until it is either stamped onto the image or deleted. 
If you place the Selection Marquee tool in a floating marquee and hold either the Ctrl or Alt key down while 
dragging the marquee to move it, DeBabelizer Pro stamps down the existing floater contents, copies the 
contents of the marquee and moves it with the cursor to the desired position. 



De-selecting an Active Selection

When an image is selected, or active, the title bar of the Image window is highlighted. When an area on an 
image is selected, the Selection Marquee  appears on the image, outlining the selected area. If it is a floating 
marquee, de-selecting it stamps the contents of the marquee onto the image.
To de-select, or de-activate, an active marquee you can:
n Click on another image.
n Select the Edit>Select...>None command.
n Open the Select dialog and select the None option.
n Press Ctrl + D.
You can also de-select an active marquee, by selecting the entire image. To change the selection from an area to 
the entire image you can:
n Click on any point on the image, but outside of the current marquee. 
n Select the Edit>Select...>All command.
n Open the Select dialog and select the All option.
n Press Ctrl + A.



Selecting Images in a Batch List

You can select images from a BatchList window in the same manner that you would select a file from an Explorer 
window. When a BatchList window is open in the main window, you can use the mouse to select an image and 
use the Shift and Ctrl keys to select a group of images. 
You can open any image file by double-clicking on the image name in the BatchList window. DeBabelizer Pro 
opens the image in an Image window. You can then modify the individual image as desired. 
If you execute a function or command when the BatchList window is selected, each item in the BatchList is 
opened (if not already open) and the operation is applied to each file in the BatchList. 



Editing Images

Image editing involves manipulating the displayed elements in the Image window. In addition to using the Paint 
Tools to modify pixels in an image, you can copy elements from one image and paste them to another and also 
rearrange the contents of an Image window in a number of different ways. Editing functions can be applied to an 
entire image, or a selected area on an image. 



Cutting, Copying, and Pasting Images

To copy, cut, or clear an image, select the image or image area, then choose the appropriate Edit menu 
command, press the appropriate key commands, or use the toolbar buttons. Cutting or copying an image places 
a copy of the selected image in the Windows Clipboard. The Clipboard contents can then be pasted into any 
DeBabelizer Pro Image window, or into other Windows applications.
To paste the contents of the Clipboard in the selected Image window, select the Edit>Paste command, press Ctrl 
+ V, or click the Paste toolbar button. DeBabelizer Pro pastes the Clipboard contents into the Image window. You 
can then use the mouse to move the selection to the desired spot on the original image. 
If there is currently an active Selection Marquee when you perform a paste operation, DeBabelizer Pro replaces 
the existing marquee with a new marquee containing the pasted item. 
If there is not an active Selection Marquee when you perform a paste operation, DeBabelizer Pro places the 
pasted item in a new marquee located at the most recently selected pixel on the image. If there is not a recently 
selected pixel on the image, DeBabelizer Pro centers the pasted selection in the Image window in a new 
marquee. 
The marquee for a pasted selection is a floater; the original image pixels in the selected area remain untouched 
and the pasted item exists on top of the original image until you stamp it. 
When you de-activate the Selection Marquee, the pasted selection (as it is displayed in the marquee) stamps, or 
overwrites the pixels underneath. Use the Image>Transparency submenu settings to specify the criteria that 
DeBabelizer Pro will use to overwrite the underlying pixels.
Another method for altering the way that a selection is pasted to an Image window is controlling the channel 
display. Each image consists of a red, green, and blue channel. When you paste and stamp a selection into an 
Image window, only the currently displayed channels are overwritten. 
To permanently erase an image selection without copying it to the Clipboard, select the image or image area, 
then select the Edit>Delete command or press the Delete key. DeBabelizer Pro removes the selected item and 
replaces it with the current background color. This function is useful when you want to erase an image selection 
while leaving the Clipboard contents intact.



Reversing Image Edits

As you experiment with DeBabelizer Pro’s image manipulation features, there will be times when the function 
produces an undesired result. As with most Windows applications, you can always close and reopen the file if you
have not saved the changes. Although, using this method is time consuming and may also cause you to lose 
work that you want to keep.
DeBabelizer Pro includes Undo and Revert to Original functions which allow you to quickly return to a previous 
version of the image. Select the File>Revert to Original command to return to the most recently saved version of
the image.
Select the Edit>Undo command to reverse, or undo, the most recently executed function(s). You can select this 
command multiple times to undo the most recent operations in reverse order. The number of operations that you
can undo depends upon the number designated in the Preferences dialog and is limited only by your available 
system memory. 
If you decide that you want to undo the undo, you can select the Edit>Redo command to reverse the undo. You 
can redo as many operations as you can undo. Combining the undo and redo function allows you to scroll 
forwards and backwards through a series of executed operations and locate the version of the image that you 
want to continue working with.



Rotating Images

You can rotate a selected image or the contents of the current Selection Marquee in either clockwise or 
counterclockwise directions, between one and 360 degrees. DeBabelizer Pro allows you to perform an automated
rotation, or specify a custom rotation for creating animation effects.
To perform a quick rotation, select the image or area on the image and then select the Image>Rotate submenu 
to access the quick rotation commands, or click the rotation toolbar buttons. DeBabelizer Pro automatically 
rotates the selected image 90, 180 or 270 degrees in the clockwise direction using the current rotation option 
settings in the Rotate dialog. 
To apply a custom rotation to the selected image or area:
1 Select the Image>Rotate>Specify... command. The Rotate dialog appears.
2 Specify the image rotation distance and direction. You can enter a value between 1 and 360 in the Degrees 

field, and choose either the clockwise or counter clockwise direction.
3 Modify the Bounds setting. There are two options for determining the selection boundaries for the rotated 

image. Depending upon the option you choose, DeBabelizer Pro may need to crop and/or pad the selection 
when performing the specified rotation.

n Expand
n Same Size
4 Click OK to rotate the image document using the current settings.



Flipping Images

You can flip an image or a selected image area horizontally (left to right) or vertically (top to bottom). This 
function produces a mirror of the original image.
To flip the selected image or area, select the Image>Flip submenu and choose either the Left to Right or Top to 
Bottom command. You can also click either of the Flip toolbar buttons. 



Image Resolution

DeBabelizer Pro produces raster images  which are resolution dependent. The more pixels used to draw the 
image, the more detailed the image appears. Therefore, image resolution is measured in PPI, pixels per inch. An 
80 ppi image contains a total of 6400 pixels (80 pixels wide x 80 pixels high = 6400) per inch. If you increase the
size (height and width) of an image without increasing the number of pixels, you lower the resolution and the 
image appears less detailed.
You can adjust the density resolution setting for an image, and adjust your monitor’s screen resolution to alter 
the display the image.



Raster Images

Raster images are made up of a grid (or raster) of squares (or pixels). Each of these pixels has a different color 
value and depth. The sum of these pixels is the image that you see. When you modify an image you are actually 
making changes to specific pixels, which alters the on screen image.
Image resolution refers to the spacing of the pixels, or dots, in the image. Image size refers to the physical 
dimensions of the image. The size of an image and its resolution determine the size (amount of memory) of an 
image file. If you increase the dpi while maintaining the size (height x width) of the image, the size of the image 
file increases.



Screen Resolution

Monitor, or screen, resolution determines the number of pixels per unit length of output onto the display screen. 
This is usually measured in dpi (dots per inch) or ppi (pixels per inch). 
The image resolution determines the spacing of the pixels and the monitor resolution determines the size of the 
displayed image. A 144 ppi image would be displayed at twice its actual size on a 72 dpi monitor. The same 
image would appear only slightly larger on a 120 dpi monitor, because more pixels can be displayed per inch of 
viewing space.
You can use the Windows Control Panel Display Properties to adjust the screen resolution. The settings available 
depend upon your monitor and graphics adapter. Higher resolutions display objects smaller on the desktop, 
lower resolutions display them larger. 



Adjusting Image Density (DPI) Resolution

An image’s density resolution refers to its dpi during printing. The resolution of an image is key in determining 
the quality of the printed output. If the resolution is set too low, the result is pixelization, or a very grainy output. 
If it is set too high, the image includes more information than is necessary, the printed size is smaller, and it 
requires more memory and time to print.
Changing only the density resolution of an image to a higher or lower setting has no effect on the displayed 
image, but it does affect the size of the printed output.
You can use the quick DPI commands to apply a standard dpi to the selected image, you can also apply scaling. 
You can select one of the following dpi settings from the Image>Set DPI Resolution submenu:
n 72 x 72 
n 75 x 75
n 144 x 144
n 150 x 150
n 288 x 288
n 300 x 300
You can apply any of these standard dpi settings alone, or in conjunction with scaling (i.e.; 72 x 72 dpi, scale 
image). When you select a menu item that includes scaling, DeBabelizer Pro scales the image to maintain the 
current print size and applies dithering based upon the current dithering options settings. 
You can also change the dpi of the selected image using custom settings. To specify the dpi resolution setting for 
the selected image, select the Image>Set DPI Resolution>Specify... command to change the dpi of the selected 
image using custom settings in the    Set DPI Resolution dialog. 



Trimming Images

You can trim the edges of an image using any of the six Trim command functions. Each of these command 
functions trims the selected image  using a different criterion for determining the area to remove from the 
image.
To trim the currently selected image, select the Image>Trim submenu and choose one of the following menu 
commands.
n To Selection
n Color 0 Edges
n White Edges
n Black Edges
n Solid Edges
n Background Color Edges



Custom Cropping and Padding

You can increase the size of the image document (contents of the Image window) by adding padding, or canvas 
of a specified color around an image. You can decrease the size of the image document by trimming (cropping) 
areas from the image. 
To crop or pad an image using the Resize dialog:
1 Select the Image>Resize Canvas... command, or click the Resize Canvas toolbar button. The Resize Canvas 

dialog appears with the current image dimensions displayed in the upper left of the General options.
2 Choose the desired units of measurement. Select the desired units of measurement from the Units drop-down 

menu. 
3 Select a re-sizing method from the Method list window and specify a new size for the image document. When 

you select a different method, the contents of the dialog change. 
If the specified size is larger than the current image document, DeBabelizer Pro adds padding around the 
edges. If the specified size is smaller, DeBabelizer Pro crops the edges of the image selection.

n Absolute
n Common
n Specific
n Relative
n Percentage
4 Select a box on the Placement grid as a location for the existing image. This step applies only to the Absolute, 

Common, and Percentage re-sizing methods.
5 Click OK to resize the image document using the current settings. You can also select another option tab to 

change pad, background, and foreground color before resizing the image.



Selecting a Pad Color

When you change the contents of the image document using the Resize Canvas or the Rotate dialog, 
DeBabelizer Pro pads the area around the modified image using the defined pad color. You can use the Pad Color 
options to change the pad color. These options are available from the Resize and Rotate dialogs and retain their 
settings until you change them.
To define a pad color:
1 Select the Image>Resize Canvas... command. The Resize Canvas dialog appears displaying the General 

options. 
2 Click the Pad Color tab to access pad color options. (These options are also available from the Rotate dialog.)
3 Specify a pad color. You can define the pad color using one of the six option settings.
n Background color - Use this option to set the pad color to the defined background color.
n Foreground color - Use this option to set the pad color to the defined foreground color. 
n Most popular color - Select this option to define the pad color as the one used by the most number of pixels in 

the image that you are currently modifying.
n Background selection mid color - Select this option to select the mid color of the image background range if 

you have previously used the Blue Screen Removal dialog to define that range. DeBabelizer Pro determines 
the middle of the defined range and uses that color as the pad color.

n RGB color value - Select this option to define the pad color using its RGB and HSV values. To define the color, 
you can enter the known values in the RGB or HSV fields, or move the cursor over the image and use the Eye 
Dropper tool to click on the desired color and DeBabelizer Pro automatically fills the fields with the values for 
the selected color. 

n Palette index - Select this option to set the pad color to one of the palette colors using its palette index value. 
To define the color, you can enter the known index value in the Palette Index field, click on the color on the 
palette on the right of the dialog, or move the cursor over the image and use the Eye Dropper tool to click on 
the desired color. When you select the color from the palette or image, DeBabelizer Pro automatically fills the 
field with the index value for the selected color.

4 Click OK to retain the specified pad color and exit the dialog. 



Automatic Scaling 

Use DeBabelizer Pro’s scaling functions to reduce and enlarge image size. Select the Image>Scale submenu and 
choose the appropriate scaling command. You can apply these functions to the entire image, or a selected area 
of the image. 
n Half Size
n Double Size
n Half Horizontal
n Half Vertical
n Double Horizontal
n Double Vertical
n PC to Mac Aspect Ratio
n Mac to PC Aspect Ratio
You can also use the Scale dialog to apply a custom scale.



Custom Scaling

Use the Scale dialog to apply custom scaling to an image and set scaling options. To apply a custom scale:
1 Select the Image>Scale>Specify... command. The Scale dialog appears.
2 Choose the desired units of measurement. 
3 Select a scaling method and enter the desired values. 
n Absolute
n Common 
n Relative
n Percentage
n Best Fit
4 Set additional scaling options. You can change the scaling algorithm, apply dithering, lock the aspect ratio, and

use Smart Shrink when scaling images.
5 Click OK to scale the image using the current settings. 



Scaling Options

The Scale dialog includes a number of options which determine how DeBabelizer Pro processes the image during
scaling. These option settings are retained and used whenever a scale function is executed (i.e.; selecting a 
scaling command, applying a scale within a script).

Algorithm - This option determines the method that DeBabelizer Pro will use when reducing or enlarging 
an image.

à Averaging for Shrink, Simple Sample for Grow 
à  Bell - Smoother  
à B-Spline - Smooth+Blur  
à Box - Jaggy
à Simple Sample - Jaggy  
à Sine - Sharp  
à Cubic - Smooth  

Dither - Use this option to automatically apply dithering to the image during scaling, using the current 
dithering settings. To modify these settings from the Scale dialog, select the Dithering Options tab. 
Constrain Proportions - Use this option to automatically adjust the scale so that the initial aspect ratio 
of the image remains the same. When this option is selected, the Width and Height field values in the 
dialog automatically adjust to maintain the aspect ratio. 
Smart Shrink (for indexed color images) - Use this option to obtain the best possible quality when 
reducing an image with a palette of 256 colors or less.
Ignore Background color - Use this option when scaling an image containing an object surrounded by a
solid background color. This option produces a sharper edge (although it may appear jagged) that is not 
tinted by the background color. 



Adjusting HSV Values

You can modify the hue, saturation, and brightness of an image by adjusting the HSV values. Using this feature 
requires some trial and error in order to obtain the desired results.
You can adjust the HSV for an entire image, or a selected RGB image area within a floating marquee. To adjust 
the HSV values for the selected image or image area:
1 Select the Image>Adjust HSV Values... command. The Adjust HSV Values dialog appears. (If the selected 

image is an indexed image, the Adjust HSV dialog displays the image palette and reflects any changes made 
to the dialog settings.)

2 Eliminate the desired colors. You can eliminate, or protect, any palette color or range of colors from the HSV 
value changes by selecting the color(s) on the Adjusted Palette, and selecting the Do Not touch off limit colors 
option. DeBabelizer Pro will ignore the selected colors when making the HSV value adjustments.

3 Make adjustments to the Hue, Saturation, and Brightness values. You can change these values using the 
mouse to drag the slider control bars to the left or right, or you can enter a numeric value into any of the 
fields. The changes are reflected on the Adjusted palette contained in the dialog and on the selected image.
n Hue
n Saturation
n Brightness

4 Click OK to accept the HSV adjustments for the selected image. You can also click Cancel to exit the dialog and
return the image to its original HSV values.



Off Limit Colors

To designate colors on the image that you want to remain unaltered, use the Selection Marquee to select an area
on the image. All colors used by any pixels in the selected area are marked in the Adjusted palette. 
To designate colors on the image that you want to alter and leave all others unaltered, click the Check All button 
and then hold down the Ctrl key while selecting an area on the image. All colors within the selection are 
unmarked in the Adjusted Palette. 



Adjusting Intensity and Contrast

You can modify the intensity and contrast of an image by altering the intensity of the Red/Green/Blue 
environment. This method of modification may result in undesired changes to the original hue and saturation of 
the image. 
You can adjust the intensity and contrast for an entire image, or a selected RGB image area within a floating 
marquee. To adjust the intensity and contrast of the colors in the selected image or image area:
1 Select the Image>Adjust Intensity and Contrast... command. The Adjust Intensity/Contrast dialog appears. (If 

the selected image is an indexed, or palette image, the Adjust Intensity/Contrast dialog displays the image 
palette and reflects any changes made to the dialog settings.)

2 Eliminate colors from the calculation, if desired. If you are working with a palette image, you can eliminate, or 
protect, any palette color from the intensity/contrast changes by selecting the color in the Adjusted Palette, 
and selecting the Do Not touch off limit  option. DeBabelizer Pro will ignore the selected colors when making 
the intensity/contrast adjustments.

3 Make adjustments to the Intensity, Contrast, Red, Green, and Blue values. You can change these values using 
the mouse to drag the slider control bars to the left or right, or you can enter a numeric value into any of the 
fields. The selected image reflects any changes that you make to these values. 
n Intensity
n Contrast
n Red/Green/Blue

4 Select a method of intensity calculation. DeBabelizer Pro provides two different methods for calculating 
intensity:
n Prevent clipping
n Maintain contrast

5 Click OK to apply the specified intensity/contrast adjustments to the selected image. You can also click Cancel 
to exit the dialog and return the image to its original intensity and contrast settings.



The NTSC/PAL Hot Pixel Fixer

DeBabelizer Pro’s NTSC/PAL Hot pixel fixer scans each color value in the image and makes the necessary 
adjustments for display on a NTSC or PAL device (such as a television screen). 
In DeBabelizer Pro, each pixel in an image is represented by a RGB value. Sending an image to an NTSC or PAL 
device, converts each pixel to a YIQ value and then into a composite signal. During the conversion process, some
fully saturated colors with high intensity result in amplitudes that go beyond the capability of most video 
equipment. This produces drastic color errors on those areas of the image. Thus, these colors need to be reduced
in intensity or saturation in order to avoid distortion when the image is broadcast.
You can apply the filter to an image by selecting the Image window and then selecting the Tools>NTSC/PAL Hot 
Pixel Fixer… command. DeBabelizer Pro automatically makes the appropriate adjustments to the image pixels 
based upon the current settings. 
You must select an open palette to access the NTSC Hot Pixel Fixer options. To set NTSC Hot Pixel Fixer options:
1 Select the Tools>NTSC/PAL Hot Pixel Fixer... command. The NTSC/PAL Hot Pixel Fixer dialog appears.
2 Adjust the maximum chrominance and amplitude values. You can change these values using the mouse to 

drag the slider controls to the left or right, or you can manually enter a numeric value into either of the fields.
n Maximum Chrominance Component
n Maximum Amplitude of Composite

1 Choose either a luminance or saturation reduction. DeBabelizer Pro can correct the offending palette colors, or
pixels, by reducing either their luminance or saturation. Select the desired Reduce option.

2 Select the video mode. You can choose either the NTSC (USA) video standard or the PAL (Europe) video 
standard.

3 Apply gamma correction, if desired. Select the Apply gamma correction checkbox to perform gamma 
correction before testing and adjusting the pixel colors. 

4 Click OK to modify the selected image based upon the current settings.



Gamma and Gun Controls

Use gamma controls to make adjustments to the level of each color gun in the monitor.    Adjusting the gamma 
levels allows you to change the brightness and contrast of the mid-level gray tones without dramatically altering 
the shadows and highlights in an image.
A monitor has a gun for each color channel (Red, Green, and Blue). For each gun there is a total of 256 levels. 
Each of these levels is plotted as a dot, or point on the RGB Settings graph in the Gamma Control dialog. 
The RGB Settings graph represents the mapping of the gamma levels. The x axis represents the current level 
values of the image, and the y axis represents the new values. The red, green, and blue lines (series or plotted 
points) represent their respective color guns. When the Red, Green, and Blue values overlap (are equal) the 
points appear black. When Red overlaps with Blue, the points appear magenta; when Red overlaps with Green, 
the points appear yellow; and when Green overlaps with Blue, the points appear cyan.
You can apply gamma correction to an entire image, or an image selection within a floating marquee.



Adjusting Gamma Level Settings

To adjust gamma level settings for an image or image selection:
1 Select the Image>Gamma Control... command. The Gamma Control dialog appears with the current levels 

plotted on a graph on the right.
2 Specify the color value(s) to set. You can set any combination of Red, Blue, and Green levels. Use the Set 

checkbox controls to select the desired color(s).
3 Specify the color value(s) to show. You can show any combination of Red, Blue, and Green levels on the RGB 

Settings graph. Use the Show checkbox controls to select the desired color(s).
4 Set the desired color levels. There are two ways to change the gamma level values:    using the automatic 

setting options, or changing the values manually using the mouse to draw the new values on the RGB Settings
graph. 

5 Click OK to change the gamma color levels of the current image using the current settings. 



Automatic Gamma Control Settings

DeBabelizer Pro provide s a number of pre-set options of popular gamma level settings that you can choose from
to automatically adjust gamma levels of an image. 

Normal - Use this option to set gamma levels to a neutral mapping (no change). This mapping is 
represented as a diagonal line drawn from the lower left corner to the upper right corner.
Invert - Use this option to invert the gamma levels. This mapping is represented as a diagonal line drawn 
from the upper left corner to the lower right corner.
Revert - Use this option to return gamma levels back to their original settings (when the dialog was 
opened).
CD-I CCIR Clip - Use this option to set gamma levels to the accepted CD-I levels by forcing levels 0 to 15 
to fit in 16 and levels 236 to 255 to fit in 235.
CD-I CCIR Normalize - Use this option to set gamma levels to accepted CD-I levels by scaling input levels 
from 0 to 255 to fit in 16 to 235.
Levels/Gun - Use this option to set gamma levels for each gun to the specified number. Enter a number 
between 0 and 255 in the field. This option has a posterizing effect on the image.
Set all to front - Use this option to copy the front map to the other guns’ maps.
Smoother - Use this option to smooth jags from the map by averaging the value distribution.
Move all up - Use this option to move the entire map up by the number of specified levels. Enter a 
number between 0 and 255 in the field. 
Move all Down - Use this option to move the entire map down by the number of specified levels. Enter a 
number between 0 and 255 in the field.
Move all Left - Use this option to move the entire map left by the number of specified levels. Enter a 
number between 0 and 255 in the field.
Move all Right - Use this option to move the entire map right by the number of specified levels. Enter a 
number between 0 and 255 in the field.
Gamma NTSC (2.2) - Use this option to set the color gun(s) to the standard NTSC gamma curve, which is 
2.2.
Gamma PAL (2.8) - Use this option to set the color gun(s) to the standard PAL gamma curve, which is 2.8.
Gamma - Use this option to set the color gun(s) to the specified gamma curve. Enter the curve value in 
the field.
Inverse Gamma - Use this option to set the color gun(s) to the inverse of the specified gamma curve. 
Enter the curve value in the field.



Changing the Gamma RGB Settings Manually

You can also change the selected gamma control color levels using the mouse to draw new X,Y values on the 
RGB Settings graph in the Gamma Control dialog. To change color levels graphically:
1 Use the Set and Show check boxes to specify the colors levels to be changed and shown on the graph in the 

Gamma Control dialog.
2 Move the cursor over the graph to select the In/Out starting point for the range of new values. Notice the 

middle Cursor Position values change as the cursor moves. 
3 Select the In/Out range of values by pressing the mouse button and holding it down as you drag it over the 

desired points on the graph. Notice that the previous points plotted on the graph are replaced as you draw the 
new level values.

4 Release the mouse button to complete the level value selection. The upper Cursor Position values indicate the 
last point drawn.



Changing the Background/Foreground Color

When you load DeBabelizer Pro, the specified background and foreground colors appear in the Paint Tools 
toolbar, beneath the tool icons. The background and foreground colors are retained settings; they are the same 
colors that were specified at the close of the previous DeBabelizer Pro session. If this is the first time you have 
loaded DeBabelizer Pro, the background color defaults to white and the foreground color to black.
To change the background/foreground color:
1 Click on the background or foreground color swatch in the Paint Tools  toolbar. The Background and Foreground

Colors dialog appears.
2 Select the desired color.

n Use the RGB color value option to define the color using RBG/HSV values. If you are executing an operation 
on a palette image or palette movie which does not contain the specified color, DeBabelizer Pro finds the 
closest color in the palette and uses that as the background or foreground color.

n Use the Palette index option (if there is a currently selected palette image, palette movie, or stand-alone 
palette) to define the background or foreground using a palette index value.

1 Click OK to set the background/foreground color to the selected color. The color square in the Paint Tools 
toolbar changes to reflect the new background or foreground color.

The background and foreground colors can also be changed using preference settings in the Preferences dialog.



Removing an Image Background or Blue Screen

You can separate the subject(s) of an image from the background by replacing a range of colors with a single fill 
color. This is used for images which have been digitized against a blue or green screen, and allows you to 
superimpose the image subject(s) on another image. This is especially useful for automatically separating image 
objects for placement on web sites or in multimedia authoring programs.
The blue screen removal process (also called background removal) replaces a range of color values (or 
background) with a specified fill color. You can replace any range of colors in an image with a fill or middle value 
color. DeBabelizer Pro looks at each pixel in the image and translates each pixel that falls within the specified 
range.
To remove an image’s background and replace it with a fill or mid range color:
1 Use the Selection Marquee to select a portion of the background (blue screen) area. It is best to select the 

largest area possible so that the most number of colors that make up the image background are included.
2 Select the Tools>Blue Screen Removal... command. The Blue Screen Removal dialog appears.
3 Select colors for the translation range. The Current Range Preview window displays a visual representation of 

the hue, saturation, and brightness of the pixels in the area within the Selection Marquee. The Select Low 
Range values indicate the lowest RGB and HSV values within in the selected area, and the Select High Range 
values indicate the highest RGB and HSV values within in the selected area. 

4 Specify a fill color to replace the colors in the translation range.
n Select Fill Color
n Select Mid Color
1 Click Preview to view the results of the background removal on the current image. Click OK to accept the 

image modifications and exit the Blue Screen Removal dialog. 



Floaters

Use the editing commands (cut, copy, paste) to place a selected image onto another image. When you select the
Paste command, DeBabelizer Pro pastes the current contents of the clipboard onto the selected image. The 
Selection Marquee surrounds the pasted item, and allows you to drag the selection and move it to the desired 
location. This is called a floater. As long as the pasted item is contained within the marquee, it floats on top, and 
the pixels in the original image exist underneath, unchanged. 
When you click outside of the active marquee, the pasted image is stamped onto the existing image, overwriting
the pixels that lay underneath. You can control this process using the image transparency settings.



Setting Transparency Options

The transparency settings determine how DeBabelizer Pro overwrites or blends pixels when image selections are 
pasted onto an image.
To turn any selection transparency setting on or off, select the Image>Transparency submenu to select the 
desired selection transparency setting command. Active settings are indicated with a check mark. You can also 
click the appropriate transparency toolbar button to toggle the setting on and off.
n Not Transparent
n White
n Black  
n Alpha Channel
n Background Color
n Red/Green/Blue
n Even Lines/Odd Lines



Text Overlays

Select the Tools>Text Overlay... command or click the Text tool in the Paint Tools toolbar to add a text string 
(series of characters) on top of the image. Both actions open the Text Overlay dialog, which you can use to 
specify the text, font, location, and color of the overlay.
To define the text string:
1 Select the Text tab to access the text overlay edit options. You can use these options to define the text string.
2 Click the cursor on the text edit box, and enter the desired text string. You can use the keyboard to type the 

string and/or use the Insert Keyword and Default String  options to automatically generate text when the 
overlay is placed.

3 Specify font style and color settings. You can access these options by clicking the Select Font... and Select 
Color... buttons. 

4 Select the Transparent option, if desired. When this option is selected, DeBabelizer Pro places the specified 
text over the image without a background box. 

5 Select the Preview tab to preview the overlay. The preview window displays the text string using the current 
settings. You can then select any other tab to change any option setting.

6 Click OK to place the specified text overlay on the image. DeBabelizer Pro places the text on the image within 
a marquee, as a floater. 

You can use your mouse to move the marquee on the image. Once you de-select the marquee, the text overlay 
is stamped onto the image. 



Transparent Text Background

A text overlay  appears within a background box using the current background color, unless you specify that the 
background be transparent. To specify a transparent background, select the Transparent checkbox in the Text 
Overlay dialog Text options. When this option is selected, the specified text string appears directly on the image, 
without a background box.



Text Overlay Location

To define the location of a text overlay:
1 Click the Location tab to access the text overlay location options. You can use these options to define the text 

overlay location.
2 Select a box on the Set Location grid to specify a location origin. Each box represents an edge, corner, or 

center of the image. The text string will be aligned using the selected location. 
3 Use the Offset setting(s) to specify the distance the text will be placed from its point of origin. These options 

reflect the box that you select from the Set Location grid. 
4 Use the Units pop-up menu to change the units of measurement setting. 
5 Click the Text tab to return to the text options, or OK to place the specified text overlay on the image. You can 

also select the Preview tab to preview the overlay without placing it on the image. 



Editing the Type Style

You can specify the type style for overlaid text using the Font dialog. DeBabelizer Pro overlays text of the default 
type style, unless you use these options to select another. 
To edit the type style for the text overlay:
1 Click the Select Font... button in the Text Overlay dialog. The Font dialog appears. 
2 Select a font from the Font drop-down menu. The fonts available from this menu depend upon the fonts 

installed on your system. Information about the selected font appears at the bottom of the dialog.
3 Select a font size. You can select one of the default point sizes from the Size drop-down menu, or use the 

cursor to enter a custom point size in the field.
4 Select a font style. Use the Font Style scroll box to select a text style. You can choose either regular (plain), 

italic, bold, or bold italic text styles. You can also select the Strikeout or Underline checkbox options to apply 
either of these effects to the text string.

5 Click OK to apply the font settings to the text string. The Font dialog closes, returning to the Text Overlay 
dialog. You can view the effects of the modified type style by selecting the Preview tab.



Changing the Type Color

You can specify the type color for overlaid text using the Color dialog. DeBabelizer Pro overlays text in black, 
unless you use these options to specify another color.
To change the text color:
1 Click the Select Color... button from the Text Overlay  dialog. The Color dialog appears. The dialog contains a 

palette of basic colors as well as a smaller palette of custom colors. 
2 Select a color for the text. You can click on any one of the Basic or Custom colors to select it. 
3 Click OK to set the selected text color. The Color dialog closes, returning to the Text Overlay dialog. You can 

view the effects of the modified text color by selecting the Preview tab.



Image Fields

An image is composed of two fields, or sets of odd or even horizontal lines (rows of pixels). The Even field is the 
set of even numbered lines, beginning with line 0 (the first line in the image). The Odd field is the set of odd 
numbered lines, beginning with line 1. You can manipulate and interpolate image fields across an entire image, 
or for a selected area on an image. 
Lines are numbered from the top down. You can place the cursor directly over an image to view the Y value (line 
number) of any pixel of the image. The line number, and X,Y values, are relative to the top left corner of the 
entire image; the first pixel has an X,Y value of 0,0 (line 0).



Field Interpolation

Field interpolation allows you to correct motion distortion in images digitized from video by replacing blurred 
scan lines with new interpolated scan lines (de-interlace), which usually results in a clearer image. You can also 
use this function to clean up horizontal streaks that can appear in digitized video images, or sub-rendered 3-D 
animations.
To perform a field interpolation:
1 Select the image or image area to interpolate. 
2 Select the Tools>Field Interpolate submenu and choose the appropriate command function. The command 

functions are grouped according to their functionality. The first three commands are used for interpolation:
n Interpolate Even Lines
n Interpolate Odd Lines
n Interpolate Top Line of Selection

3 Click OK to interpolate the selected image.



Field Manipulation

In addition to interpolation, fields can be manipulated in a number of ways. Select the Tools>Field Interpolate 
submenu and choose the desired field manipulation command function.
To delete or insert even and odd lines, use one of the field delete and insert functions:

n Delete Even/Odd Lines
n Insert Blank Even/Odd Lines

The field delete and insert functions can be used together. For example, you can delete odd lines from an image 
and then insert blank odd lines. The result is an image of the same size as the original, with the odd line pixels 
replaced with the background color. 
To rearrange even and odd lines, use one of the field movement functions:

n Top Half ->Odd Lines, Bottom Half -> Even Lines
n Odd Lines ->Top Half, Even Lines -> Bottom Half
n Top Half ->Even Lines, Bottom Half -> Odd Lines
n Even Lines ->Top Half, Odd Lines -> Bottom Half
n Swap Even and Odd Lines



Saving Images

Once you have opened an image into the main window and applied the desired image processing functions, you 
will likely want to save the image. You can save the modified version as a new, separate image file, or replace 
the original image file with the modified version. 
Replacing the Original Image
To replace, or overwrite the original image file, select the File>Save command, or click the    toolbar button. 
DeBabelizer Pro automatically saves the modified image as the original file name using the same file 
parameters. If you make further modifications and use the Revert to Original  function, DeBabelizer Pro will 
return to this saved version.
Saving to Another File
To save the modified image to another file name or using another file format, select the File>Save As... 
command. The Save As dialog appears. Use this dialog to specify a file name and directory. You can also use the 
dialog to select a file format, set the number of colors, and apply a saved script to the image.
The Save As dialog contains standard Windows directory controls, and additional options which are specific to 
image processing and translation. These additional options are located at the bottom of the dialog.
Click Save to save the current image to the specified file name and directory, and using the current option 
settings.



Save in File Format

Use this drop-down menu in the Save As dialog to select a file format type for the saved image. The list includes 
all graphic file formats that DeBabelizer Pro can write. Select the Set From Image checkbox and DeBabelizer Pro 
will determine the format of the original image and save the file using the same file format.



Save at Color Depth

Use this drop-down menu in the Save As dialog to specify the number of colors for the saved image. The bit 
depths available depend upon the selected file format and the number of colors it supports. If you select a 
number lower than the current number of colors in the image, DeBabelizer Pro will automatically perform the 
color reduction and remapping before saving the image. Select the Set From Image checkbox and DeBabelizer 
Pro will determine the number of colors for the current image and save the file using the same number. 



Pre Save do script

Use this drop-down list in the Save As dialog to select a saved script to be executed before DeBabelizer Pro 
saves the image. 



Setting Writer Preferences

Many of the file formats available for saving an image have their own writer preferences  and sub-formats (i.e.; 
TIFF G3, G4, etc.). Writer preferences allow you to control specific aspects of the way that DeBabelizer Pro writes 
a file to the specified format.
When you select a file format from the Save in File Format drop-down menu, the Writer Options button at the 
bottom of the Save As dialog is grayed out, or dimmed if that format does not have Writer preference options 
that can be modified. If the selected format does have writer options, the button is available for selection.
To set writer preferences:
1 Click the Writer Preferences button at the bottom of the Save As dialog. The Preferences dialog for the 

selected file format appears.
2 Modify the writer preference options as desired. The option settings available depend upon the specifics of the 

selected file format.
3 Click OK to set the modified writer preferences. These options settings are used whenever you save an image 

to that file format, until you change the preference settings.



Format
This is the graphic file format that DeBabelizer Pro has identified. If there is no format indicated, the file may not 
be a graphics file, or may be a format that DeBabelizer Pro does not read at this time.



Attributes
This describes the height and width of the image in pixels, and the number of colors. 



Size
This describes the size of the file, in bytes, and indicates the disk space occupied by the file. 



Created
This indicates the date and time that the selected file was originally created.



Modified
This indicates the last date and time that the selected file was modified, or changed.



Units
Select the desired units of measurement from the Units drop-down menu. You can choose to display image 
dimensions in inches, millimeters, centimeters, picas, pixels, or points.



Size/DPI
Use the Size fields to specify the horizontal and vertical size of the new image, using the selected units of 
measurement. Use the DPI fields to specify the horizontal and vertical dpi of the new image.



Absolute
Use this selection option to define a new Selection Marquee by specifying the location of its boundaries. The 
numbers that you enter in the Top, Left, Bottom, and Right fields define the location of the new Selection 
Marquee, regardless of any previous selection.



Relative
Use this selection option to define a new Selection Marquee relative to the edges of the selected image. The 
numbers that you enter in the Top, Left, Bottom, and Right fields define the movement of the boundaries of the 
existing selection.



Move Absolute
Use this selection option to move the marquee absolutely. The numbers that you enter in the Up/Down and 
Left/Right fields determine the direction and distance of the move.



Move Relative
Use this selection option to move the marquee relative to the edges of the image. The numbers that you enter in
the Up/Down and Left/Right fields determine the direction and distance of the move.



Resize Absolute
Use this selection option to resize the existing Selection Marquee absolutely. The numbers that you enter in the 
Top, Left, Bottom, and Right fields define the change in width and/or height of the marquee.



Resize Relative
Use this selection option to resize the existing Selection Marquee relative to the edges of the image. The 
numbers that you enter in the Top, Left, Bottom, and Right fields define the change in width and/or height of the 
marquee.



Expand
Select this option to automatically expand the image document to fit the resulting rotated image. The blank 
areas of the document are filled with the defined pad color. 



Same Size
Select this option to maintain the image document size. Portions of the rotated image falling outside of the 
image document are cropped. It may also be necessary to fill in blank areas of the document with the defined 
pad color. 



To Selection
Select this command to crop the image to the currently selected area. All areas outside of the Selection Marquee
are removed and the Image window is resized to the selected area. This command is only available when there is
an active marquee selection.



Color 0 Edges
Select this command to crop an indexed image to the smallest bounding rectangle excluding the palette index 
color 0, and resizes the Image window to the remaining image. This command is only available for palette 
images.



White Edges
Select this command to crop the image to the smallest bounding rectangle, excluding absolute white. This 
function removes unused white space from around the image, and resizes the Image window to the remaining 
image.



Black Edges
Select this command to crop the image to the smallest bounding rectangle, excluding absolute black. This 
function removes unused black space from around the image, and resizes the Image window to the remaining 
image.



Solid Edges
Select this command to crop the image to the smallest bounding rectangle where every edge has the same 
color. All portions of the image that lie outside of the rectangle are removed and the Image window is resized to 
the remaining area.



Background Color Edges
Select this command to crop the image to the smallest bounding rectangle, excluding the selected background 
color. This function removes unused background color area from around the image, and resizes the Image 
window to the remaining image. 



Absolute
Select this method to specify target width and height dimensions for the entire image document. 



Common
Select this method to select a standard image size from the Sizes drop-down menu. The top four choices in the 
list indicate the last four sizes selected.



Specific
Select this option to specify the portion to crop from each edge of the current image. Enter a distance value for 
the Left, Right, Top, and Bottom boundary fields. 



Relative
Select this option to enlarge or reduce the image document relative to each edge. You can specify the padding 
(positive value) or cropping (negative value) for each edge of the current image using the Left, Right, Top, and 
Bottom fields.



Percentage
Select this method to reduce or enlarge the height and width of the image document by a specified percentage. 
DeBabelizer Pro crops or pads the image to reduce or enlarge the image dimensions by the specified 
percentage(s). You can use a different percentage for each, however this will change the aspect ratio of the 
image.



Half Size
Select this command to automatically reduce each dimension of the selected image by 50 percent, while 
maintaining the aspect ratio. Since both width and height are halved, the resulting image occupies 25 percent of 
the original area. You can also execute this scaling function by clicking the    toolbar button.



Double Size
Select this command to automatically enlarge each dimension of the selected image by 200 percent, while 
maintaining the aspect ratio. Since both width and height are doubled, the resulting image occupies four times 
the original area. You can also execute this scaling function by clicking the    toolbar button.



Half Horizontal
Select this command to automatically reduce the width of the selected image by 50 percent. This command does
not maintain the aspect ratio; the resulting image will appear stretched vertically. You can also execute this 
scaling function by clicking the    toolbar button.



Half Vertical
Select this command to automatically reduce the height of the selected image by 50 percent. This command 
does not maintain the aspect ratio; the resulting image will appear stretched horizontally. You can also execute 
this scaling function by clicking the    toolbar button.



Double Horizontal
Select this command to automatically enlarge the width of the selected image by 200 percent. This command 
does not maintain the aspect ratio; the resulting image will appear stretched horizontally. You can also execute 
this scaling function by clicking the    toolbar button.



Double Vertical
Select this command to automatically enlarge the height of the selected image by 200 percent. This command 
does not maintain the aspect ratio; the resulting image will appear stretched vertically. You can also execute this 
scaling function by clicking the    toolbar button. 



PC to Mac Aspect Ratio
Select this command to convert an image from the DOS/Windows OS display aspect ratio to the Macintosh OS 
display aspect ratio. The resulting image is reduced horizontally to 83 percent of its original width and will 
appear distorted. The image will appear correctly when it is opened with a Macintosh application. You can also 
execute this scaling function by clicking the    toolbar button.



Mac to PC Aspect Ratio
Select this command to convert an image from the Macintosh OS display aspect ratio to the DOS/Windows OS 
display aspect ratio. The resulting image is reduced vertically to 83 percent of its original height. This operation 
will correct an image which has been distorted during transfer from Macintosh to a DOS/Windows operating 
system. You can also execute this scaling function by clicking the    toolbar button.



Absolute
Select this method to scale the image to specified height and width measurements. 



Common
Select this method to select a standard image size from the Sizes drop-down list. The top four choices in the list 
indicate the last four sizes selected.



Relative
Select this option to specify the amount to increase (positive value) or reduce (negative value) from the width 
and height of the image. Enter a distance value for the Width and Height fields.



Percentage
Select this method to reduce or enlarge the height and width of the image window by a specified percentage. 
You can use different scaling for each, however this will change the aspect ratio of the image.



Averaging for Shrink, Simple Sample for Grow
This method allows DeBabelizer Pro to process scaling very quickly and with clean results. DeBabelizer Pro 
samples pixels at various intervals to determine the resulting image. 



Bell - Smoother
This method produces a smooth result, but may cause some blurring. 



B-Spline - Smooth + Blur
This method produces a smoother image, but with increased blurring.



Box - Jaggy
This method produces a jaggy result, but eliminates the blurring that smoothing may cause.



Simple Sample - Jaggy
This method also produces a jaggy result, while eliminating the blurring that smoothing may cause, but allows 
DeBabelizer Pro to process scaling much quicker; DeBabelizer Pro samples pixels at various intervals to 
determine the result.



Sine - Sharp
This method produces the sharpest image, but may also produce ringing around the image objects during 
enlarging. It is a good method for retaining thin lines during reducing. This is the default setting.



Cubic Smooth
This method is a good compromise between the Sine-Sharp and B-Spline methods when enlarging. It can also 
produce good results when reducing.



Hue
Use this control to adjust the basic colors of all pixels in the image. This is equivalent to moving all of the color 
values in an image or selection along a color wheel. As you move the slider control to the left or right, the colors 
change with respect to one another. You may need to experiment with this control to achieve the desired results.



Saturation
Use this control to adjust the saturation of all pixels in the image. Using a negative value makes colors weaker 
and paler, while positive values make colors stronger and purer.



Brightness
Use this setting to adjust the brightness level of the pixels in the image. Using a negative value makes image 
colors darker, while positive values make colors brighter.



Intensity
Use this control to adjust the intensity of the Red, Green, and Blue channels collectively.



Contrast
Use this control to adjust the contrast centered around the master intensity level. Levels above the setting will 
become lighter and levels below will become darker.



Red/Green/Blue
Use each of these controls to offset each of the color channels from the master intensity setting.



Prevent Clipping
This method calculates values proportionally, using the specified values as a percentage by which to move the 
original values up or down. For example, increasing the intensity value by 50% (value =128) results in an 
original intensity value of 0 becoming 128, and an original value of 128 value becoming 192.



Maintain Contrast
This method calculates values additively; DeBabelizer Pro adds the specified values to the original values. If the 
sum of the values exceeds 256 or is less than 0, the value is clipped. For example, specifying a saturation value 
of 128 moves the original saturation value of each pixel up by 128. An original 0 value becomes 128, and original
130 value becomes 256.



Maximum Chrominance Component
Adjust this value to limit the chrominance component of the IRE signal to a maximum value. The default value is 
52.



Maximum Amplitude of Composite
Adjust this value to limit the amplitude of the composite signal to a maximum value. The default value is 112.



Custom Color
To define a new Custom color, select a square in the Custom colors palette and then click on the color window or 
enter the known HSV and RGB values in the appropriate fields. The selected color appears in the color swatch 
below the color window. Click the Add to Custom Colors button to add the selected color to the Custom colors 
palette.



Select Fill Color
Select this option to select a particular fill color. You can specify the color by moving the cursor over the image 
and clicking on the desired pixel, using the Color Picker, or manually entering the desired values in the HSV and 
RGB fields. 



Select Mid Color
Select this option to automatically calculate and select the fill color using a mid-range average of the low and 
high range values. DeBabelizer Pro calculates the appropriate color and enters the RGB and HSV values in the 
fields.



Not Transparent
Select this setting to remove any existing transparencies and overwrite all underlying pixels in the original 
image. When an object is pasted onto an image, it will replace all of the pixels underneath. You can select this 
setting by clicking the toolbar button.



White
Select this setting to make all white pixels in the selection transparent. When you add an object to the image, 
only non-white pixels are pasted to the image. You can also toggle this setting on or off by clicking the toolbar 
button.



Black
Select this setting to make all black pixels in the selection transparent. When you add an object to the image, 
only non-black pixels are pasted to the image. You can also toggle this setting on or off by clicking the toolbar 
button.



Alpha Channel
Select this setting to overwrite all pixels in the original image in the following manner: 
Alpha value 0 - Pixels in the original image with an Alpha value of 0 remain unchanged.
Alpha value 255 - Pixels in the original image with an Alpha value of 255 are overwritten.
Alpha values 1 through 254 - Pixels in the original image with an Alpha value between 1 and 254 are blended 
with the pixels of the pasted selection.



Background Color
Select this setting to make all pixels in the selection using the selected background color transparent. When you 
add an object to the image, only non-background pixels are pasted to the image. You can also toggle this setting 
on or off by clicking the toolbar button.



Red/Green/Blue
Select one of these settings to make all pixels in the associated channel of the selection transparent. When you 
add an object to the image, only the color information of the non-transparent channels is overwritten for each 
pixel. You can also toggle any combination of these settings on or off by clicking the appropriately colored    
toolbar button.



Even Lines/Odd Lines
Select one of these settings to make all pixels in the selection in either the odd or even lines transparent. When 
you add an object to the image, the pixels on every other line (either even or odd) are overwritten. These 
settings are useful for manipulating digitized images. You can also toggle these settings on or off by clicking the 
toolbar buttons.



Interpolate Even Lines
Select this option to replace each even line with the average of the odd lines above and below it.



Interpolate Odd Lines
Select this option to replace each odd line with the average of the even lines above and below it.



Interpolate Top Line of Selection
Select this option to replace the top line of the selected area with the average of the lines above and below it. If 
the entire image is selected, the top line does not have a line above it; in this case DeBabelizer Pro uses only the
line below to replace the top line.



Delete Even/Odd Lines
Use these functions to delete even or odd lines from the selected image. The resulting image is half as high, as 
half of its pixels have been deleted.



Insert Blank Even/Odd Lines
Use these functions to insert even or odd lines in the selected image with blank (background color) lines. The 
resulting image is twice as high.



Top Half -> Odd Lines, Bottom Half -> Even Lines
This function divides the image into top and bottom halves, and moves all lines in the top half to the odd line 
positions and all lines in the bottom half to the even line positions.



Odd Lines ->Top Half, Even Lines -> Bottom Half
This function moves all odd lines to the top half of the image and all even lines to the bottom half of the image.



Top Half ->Even Lines, Bottom Half -> Odd Lines
This function divides the image into top and bottom halves, and moves all lines in the top half to the even line 
positions and all lines in the bottom half to the odd line positions.



Even Lines ->Top Half, Odd Lines -> Bottom Half
This function moves all even lines to the top half of the image and all odd lines to the bottom half of the image.



Swap Even and Odd Lines
This function moves the odd lines into the even line positions and the even lines to the odd line positions. 



Best Fit
Select this method to reduce or enlarge the height and width of the image within specified boundaries. 
DeBabelizer pro automatically determines the largest size to fit within the specified boundaries while maintaining
the aspect ratio.



Opening Movies 

You can open movie files in the same manner that you open other DeBabelizer Pro document types. You can 
open any movie (.AVI) file by dragging a file from a window and dropping it onto the DeBabelizer Pro main 
window, double-clicking on the file from a BatchList window, or using the Open Movie dialog. 



Opening MIFs (Multiple-image Files)

You can open multiple-image files in the same manner that you open other DeBabelizer Pro document types. You 
can open any MIF by dragging a file from a window and dropping it onto the DeBabelizer Pro main window, 
double-clicking on the file from a BatchList window, or using the Open Image dialog. 



The Open Movie Dialog

Select the File>Open Movie... command to access the Open Movie dialog. This dialog is a standard Open dialog 
which defaults to the movie directory, designated in the directories preferences options. 
DeBabelizer Pro currently supports only .AVI (Audio/visual interleaved data) movie file formats. The Open Movie 
dialog filters the available files to display files of that format by default. You can select All Files from the Files of 
type drop-down menu to view all file types in the selected directory. 
When you save movie files, you should use the .AVI file extension. 
Once you have located the desired file, click Open from the Open Movie dialog and open the movie file. The first 
frame of the movie appears in the Movie window. 



Video Controls

Use the video controls located at the bottom of the Movie window to control the display of the movie's graphic 
information. You can play the movie back in real time, scroll through the frames one by one, or go directly to a 
specified frame. You can also use these controls to select a specific range of movie frames.
When a Movie window is the selected item in the DeBabelizer Pro main window, the Movie menu appears. Use 
this menu to access commands for creating a SuperPalette for the selected movie, setting the frame rate, and 
setting compression options. These command functions are also available by right-clicking when the cursor is 
over a Movie window.

Play Forward - Use this button to playback the frames in real-time from the currently displayed frame to the 
next ending marker. The movie or animation plays forward to the last frame of the currently selected range, or
the end of the movie or animation. During playback of the frame sequence, this button changes to a    button, 
allowing you to pause the movie or animation at any point during the playback.
Advance to End - Use this button to advance the displayed frame to the next ending marker (either the last 
frame of the currently selected range, or the last frame of the movie or animation).
Return to Start - Use this button to return the displayed frame to the next starting marker (either the first 
frame of the currently selected range, or the beginning frame of the movie or animation).



Creating a Movie from a BatchList

You can create a new movie (.AVI) from a series of images contained in a BatchList. DeBabelizer Pro generates 
the movies using the BatchList images as frames and orders them as they appear in the BatchList. 
It is important that each image be the same size and pixel depth, as movies cannot contain frames of differing 
sizes and/or depths. If you attempt to create a movie using images of varying sizes and/or depths, DeBabelizer 
Pro uses the size and depth settings from the first image (frame) and rejects all subsequent images of a different
size or depth.
To create a movie using the images contained in a selected BatchList, select the Batch>Create Movie command. 
DeBabelizer Pro automatically generates a new movie using the BatchList files. This new movie contains an 
video stream, but does not contain an audio stream.
A new movie uses a default setting of 15 frames per second, as well as the default video compression  setting. 



Viewing and Selecting Frames

You are most likely familiar with the methods used for selecting portions of a still image. You can also specify a 
portion of a movie when applying a number of graphic processing functions by selecting a specific range of 
frames. This allows you to make the identical modifications to a number of frames at the same time.
Any single operation or script can be applied to the a single frame, a range of frames, or the entire movie or MIF. 
Before you apply a process to a movie or MIF to a range of frames, you should first designate the range that you 
want to modify.

Selecting a Frame Range
The red and green triangles that appear in the video controls  beneath the scroll bar at the bottom of the Movie 
window act as markers and determine the currently selected range of frames. 
When you use the mouse to drag the green triangle along the scroll bar, the number in the frame field becomes 
green and indicates the number of the first frame in the selected range. When you move the red triangle, the 
frame number becomes red and indicates the last frame in the selected range. You can also use the arrow 
buttons to move the marker positions one frame at a time. When the two triangles are together, forming one 
triangle, a single movie frame is selected.

Viewing Frames
You can view either a single frame in the Movie window (or an Image window containing an MIF) or playback a 
series of frames. When you are viewing a frame or series of frames, the frame field acts as a frame counter, and 
displays the number of the currently displayed frame. Use the video controls to scroll forward or backward 
through the frame sequence.



The Apply Operation dialog

When you manipulate movies, any command function that you choose from the Image, Palette, Tools, or Movie 
menus or apply from a script can be executed upon this selected range of frames. When you apply an operation 
to a movie the Apply Movie Operation dialog appears. Use this dialog to specify how the operation should be 
applied.



Changing Movie Properties

Select the View>Properties command to view the properties associated with the currently selected movie. The 
Movie Info dialog displays information about the currently displayed frame, and the entire movie file.
Click the Image Info tab to view information about the currently displayed movie frame. The properties displayed
are identical to the properties associated with a single, still image. Click the Movie Info tab to view information 
and change the properties associated with the current movie file. 
n Default Writer
n Frame Rate
The following items are for information purposes only, and are not properties that you can change from this 
dialog
n Number of Streams
n Length (Frames/Time) 
n Current Frame
n Color Depth
n Palette Changes



Editing Movies and MIFs

AVI movie files consist of both a video and audio stream. You can use many of DeBabelizer Pro's advanced image
processing functions to modify the video information in the file; however, to preserve the audio/video 
synchronization, DeBabelizer Pro requires that you not change the length of the video segment. Multiple image 
files do not have these restrictions, and many formats support varying frame sizes.
Movies are a unique DeBabelizer Pro document with a unique set of command functions. Movie command 
functions, available from the Movie toolbar menu or pop-up menu, can be applied to a selected movie or a range
of frames within a movie. However, you can use any of DeBabelizer Pro's Image and Palette command functions 
to modify the individual frames in a movie by extracting the frames from a movie into a BatchList. 
You can also apply a number of Image, Palette, and Tools menu commands to movies, including remapping the 
entire movie or a selection of frames to a palette or SuperPalette. It is a good idea to keep palette changes 
between frames to a minimum, as having many palette changes will affect the playback speed and the amount 
of compression that can be used when saving the file. While DeBabelizer Pro allows you to change frame color 
depth, remap frame ranges to palettes and/or SuperPalettes, and re-compress movie files using any installable 
compression handler, care should be taken to ensure that your movie file actually becomes smaller and more 
efficient.
Although they are image documents, you can edit MIFs using many of the same functions that you use to edit 
movies. Unlike a movie file, you do not need to separate the image frames in order to use the Image and Palette 
menu command functions to modify a frame or selected range of frames of an MIF.



Movie Processing Limitations

DeBabelizer Pro allows you to process the video portion of .AVI for use in web pages and multimedia. However, 
these files are unique and cannot be processed using all of the same functions with which images can be 
processed. 
The following Palette menu operations can be applied to movie (.AVI) files, modifying one frame, a range of 
frames, or the entire movie.
n Set Palette and Remap
n Set Pixel Depth
n Reduce Colors
n Convert to Grayscale
n Convert to Black and White
To perform other image modification functions to movie frames, you must first save the frames to a BatchList of 
individual image files and process them as single images.



Creating a Movie SuperPalette

You can create a SuperPalette for an animation (MIF) file in the same way that you create one for any group of 
images. When a multiple image file is added to the SuperPalette, DeBabelizer Pro adds each frame in the 
selected range of the MIF as if they were single image files.
Creating a SuperPalette for a movie requires a slightly different process. To create a movie SuperPalette and 
remap the selected range of movie frames:
1 Select the Movie>Create SuperPalette command. The SuperPalette Properties dialog appears.
2 Specify the Number of Colors. Select a number from the Target number of colors drop-down menu, or enter the

desired number of colors, between 1 and 256, in the field. The default number is 256.
3 Select a base palette  to be included in the SuperPalette. 
4 Click OK to create the SuperPalette using the current option settings. The newly created SuperPalette appears 

in a SuperPalette window within the DeBabelizer Pro main window
5 Drag the ActionArrow    at the top of the SuperPalette window and drop it onto the Movie window. DeBabelizer 

Pro remaps each frame in the selected range to the SuperPalette.
You can also apply any palette to a movie or MIF selection by selecting the Palette>Set Palette and Remap 
command or dragging the ActionArrow    of an open Palette window onto the Movie (or MIF) window. 



Adding a Movie file to a BatchList

You can add a movie or multiple image file to an open BatchList just as you would add a single image or palette 
file to a BatchList, but with one difference. When you drag the ActionArrow    from a movie or MIF onto a BatchList
window, the currently selected frame range is added to the BatchList. This enables you modify only those 
designated frames when applying a script to a BatchList, or processing the BatchList in other manner.



Creating a Movie or MIF BatchList

When you create a BatchList from a movie or multi-image file, DeBabelizer Pro generates an single image file for 
each frame and places all of these files in a new BatchList. This allows you to alter each frame of the movie or 
MIF animation in the same manner and using the same functions available for single image files. 
Once you have made the desired modifications to the images (frames) in the BatchList, you can then create a 
movie (.AVI) file and view the results using the movie playback controls.
To create a movie BatchList:
1 Select the desired range of movie frames.
2 Select the Movie>Create BatchList command. DeBabelizer Pro creates an image file for each frame in the 

selected range and places them in a new BatchList window. DeBabelizer Pro automatically generates the file 
names based upon the name of the movie file and the frame number of each image, using the writer 
designated in the Movie Properties dialog

3 Double-click on any file name in the BatchList window to open the movie frame into an Image window. You can
modify any individual frame using the Image, Palette, or Tools menu command functions. 

You can also apply these functions to the entire BatchList of frames.
Note:    If you plan to create a movie from the BatchList images, you do not want to perform image modifications 
that result in a different size or color depth between frames. When you create a movie the BatchList images, 
DeBabelizer Pro will use the size and depth settings from the first image (frame) and reject all subsequent 
images of a different size or depth. 



Using Filter Interpolation

Filter interpolation works with third party Photoshop plug-in filters, interpolating the filter level across a series of 
image frames. This feature can be applied to any movie, multiple image file, or a series of single (still) images. 
Filter interpolation, also called filter animation, is used primarily in batch automation and scripts that are applied 
to a series of animation or MIF frames. 
The specifications for Filter Interpolation were created by the designers of Adobe Premiere. Unique to 
DeBabelizer Pro is the ability to interpolate any image or series of images, where Premiere requires QuickTime 
movies. 
Filter interpolation works best with Photoshop plug-in filters that have an FltD resource (check with the specific 
filter vendor to determine if their filter has this resource). As a general rule, filters containing settings and 
created after 1994 typically have this special resource.
DeBabelizer Pro calculates the filter level based upon the following information:
n the starting level value for the filter
n the ending level value for the filter
n the total number of image frames
n the number of the currently selected frame
For example, if you designate a starting level of 90% and an ending value of 10% across five frames, 
DeBabelizer Pro calculates the filter level for each frame. If the currently selected frame is number four, the filter
level applied to that frame is 30%.
To apply a filter interpolation to a series of frames:
1 Select the Tools>Filter Interpolate... command. The Filter interpolate dialog appears.
2 Select the desired third party Photoshop plug-in filter. Click on the arrow button and select an installed filter 

from the pop-up menu. The filter must be installed and reside in the designated filters directory. You can 
access the directory preferences setting by clicking the Directories tab. 

3 Set the start value(s). Click the Set Start Values... button to open the option settings for the selected filter. The 
options available depend upon the filter you have selected. Set the options using the appropriate values for 
the first image frame. (Refer to the documentation included with the filter software for detailed information 
about setting filer options and values.)

4 Set the end value(s). Click the Set End Values... button to open the option settings for the selected filter. The 
options available depend upon the filter you have selected. Set the options using the appropriate values for 
the last image frame.

5 Specify the number of frames. Select the first option setting to specify a number of frames by manually 
entering the number into the field. Select the Use frame count from image setting to automatically designate 
the number of frames from the selected image file. Use the drop-down list to select an open file. Select the 
Use the number of frames in BatchList setting to automatically designate the number of frames contained in 
the selected BatchList. use the drop-down list to select an open BatchList file.

6 Set the Extra Frames option. Use this option to determine what DeBabelizer Pro does when the interpolation 
function is executed over move than the specified number of frames (i.e.; the number of frames is set to 10 
and the file contains 20). 
n Hold at end values
n Wrap around
n Backwards and Forwards
n No Filtering

7 Click OK to interpolate the filter across the specified range of frames. 



Saving Movie Files

Movie files have different saving options than image files. You can set these options from the Save As dialog 
when you save a movie, or you can set video compression options by selecting the Movie>Compression 
Options... command. 
You can save a multiple image file in the same manner that you save a single image file; however you must use 
a file format which supports multiple frames.
To save a movie (.AVI) file you can:
n select the File>Save command to overwrite the current file with the modified version, or
n select the File>Save As... command to save the movie to another filename or alter the save settings using the 

Save As dialog.
The Save As dialog contains standard Windows directory controls that you can use to designate a filename and 
location.



Setting Compression Options

You can set compression options for the current movie by selecting the Movie>Compression Options... command.
You can also set these options when saving a movie file. Compression options control the way that the movie is 
compressed when saved to the .AVI file format. 
Compression settings for movie (.AVI) files are built into the Windows 95/NT 4.0 operating system. For more 
information about setting these options, refer to the Windows 95/NT reference materials.



Default Writer
Use this option to designate the default writer for saving movie frames to a BatchList. Select the desired file 
format from the drop-down list. 



Frame Rate
Use this option to change the frame rate of the movie. A higher number slows the playback speed of the movie 
frames, and a lower number increases it.



Number of Streams
This value indicates the number of streams contained in the movie (.AVI) file. DeBabelizer Pro only operates on 
the primary video stream, but other streams may reside in the file.



Length (Frames/Time)
This value indicates the playback time of the movie. This information can change, based upon changes in the 
frame rate.



Current Frame
This value indicates the frame number of the currently displayed frame. You can view the properties of the image
contained in this frame by clicking the Image Info tab.



Color Depth
This indicates the color depth of the movie (.AVI) file.



Palette Changes
This value indicates the number of palette changes in the movie. For example, in a 50 frame movie, if frames 1-
25 use one palette, and frames 26-50 another, there is one palette change. The value displayed when the dialog 
is opened reflects the number of palette changes when the file was last saved. If you have made unsaved 
palette changes, click the Scan button and DeBabelizer Pro scans the file and reports the current number of 
palette changes.



Hold at end values
Choose this setting to use the end (final) values for all extra frames.



Wrap around
Choose this setting to restart the Frame Counter at the first frame past the Number of Frames setting. For 
example, if the Number of Frames is set to 10 for a 20 frame file, frames 11 through 20 are treated identically to 
frames 1 through 10.



Backwards and Forwards
Choose this setting to restart the Frame Counter at the first frame past the Number of Frames setting and 
interpolate in the reverse direction. For example, if the Number of Frames is set to 10 for a 30 frame file, frames 
11 through 20 would use filter values of frames 10 through 1, and frames 21 through 30 would use filter values 
of frames 1 through 10. 



No filtering
Choose this setting to discontinue all filtering past the designated number of frames.



Creating a Script

There are actually two ways of creating a new script. You can create a new script or open a saved script, modify 
it, and save it as a separate script. 
To create a new script, select the File>New>Script command. A new Script window appears with a blank script. 
DeBabelizer Pro assigns a default title of Script1 (or Script2, or Script3, etc.) to the unsaved script.
The Script window contains Operations and Parameters column headings. When you add operations, or 
functions, to the script they are listed in order of execution in the script window. 9you can rearrange the 
operations to change the order of execution.)The Operation column lists the command function, and the 
Parameters column provides information about the associated parameters, or options settings. You can double-
click on the operation item in the script to open the associated options dialog, and change the parameters of 
that operation. The information in the Parameters column changes to reflect the modified parameter information.



Adding Operations to a Script

A new script is blank until you build it by adding operations to the list. There are a number of ways you can add 
operations to the selected script.
n Select the Script>Insert Command submenu and choose the desired menu command, or operation. The 

selected command is added to the bottom of the script. You can also move the cursor over the Script window 
and right-click to open the Script pop-up menu and access the Insert command submenu. 

n Select the Script>WatchMe command to record operations as you execute them. The operations are 
automatically added to the open script as you implement them. 

n Open any Log window and use your mouse to drag-and-drop operation items from the Log window to the 
Script window. You can select an operation or multiple operations in the Log window and drag them to the 
Script window. These operation items are copied to the Script window. 

n Open any other Script window and use the mouse to drag-and-drop operation items to the other Script 
window. You can select an operation or multiple operations in any open Script window and drag them to a 
target Script window. The items are then copied to the destination script. 



Rearranging a Script

The order of the operation items in the Script window is the order that DeBabelizer Pro uses to execute the 
operations when the script is applied to a document. Changing the order of the items can change the final 
results of the script. You can move the operation items around within a script in order to achieve the desired 
effect.
As with the other script editing functions there is more than one way or method of rearranging the items within a
script. To move selected item(s), use the mouse to drag the selected items to a the desired location in the script.



Deleting Operations from a Script

You can also delete, or remove any operation item from an open script. To remove items from the Script window, 
use the mouse to select an item (you can also use the Ctrl and Shift keys to select multiple items), and select the
Edit>Delete command or press the Delete key.



WatchMe Scripting

DeBabelizer Pro's WatchMe Scripting feature enables you to build a script as you perform various operations. 
WatchMe Scripting acts as a recorder, which you can turn on and off. You must have an open Script window in 
the DeBabelizer Pro main window to use WatchMe Scripting. 
To use DeBabelizer Pro's WatchMe Scripting to add operations to the selected script:
1 Select the Script>WatchMe command. This turns the recording process on.    (Notice that the Watch Me 

command changes to Stop Recording. This lets you know that the recorder is turned on.)
2 Perform the desired operations just as you would like them to be executed from the script. DeBabelizer Pro 

adds each operation to the end of the script as it is performed in the main window including all selected 
commands, option settings, and selections.

3 Select the Script>Stop Recording command. This stops the recorder. You can    then review the added 
operations and make any desired modifications.



Saving Scripts

Once you have created and/or edited a script, you will likely want to save it so that you can use it in future 
DeBabelizer Pro sessions. To save the selected script:
1 Select the File>Save... command (if you have modified an existing script and want to save the new version as 

a separate script, select the File>Save As... command). The Save As dialog appears.
2 Designate a directory where the saved script file will reside. The dialog defaults to the scripts directory 

designated in the directories preference settings. You can use the directory controls to browse and select from 
the other available directories on your system.

3 Enter the desired file name. You can use any name which conforms to Windows 95/NT file name standards. It is
important to use the default .DBS extension in order to retrieve the script for later use.

4 Click Save to save the current script to the designated file.



Opening a Saved Script

You can open any saved script using the File>Open>Script command. Select the desired script from the Open 
Script dialog. 
The Open Script dialog window defaults to the script directory, designated in the Preferences dialog. You can also
use the directory controls to select a saved script from anywhere on your system. DeBabelizer Pro script files 
typically have a .DBS extension.
Once you have selected the desired script file, click OK to open the script. The opened script appears in the 
DeBabelizer Pro main window in a Script window. 



Using Script Functions

In addition to the menu command functions, you can also add special script functions to any script. These 
functions allow you to further customize the way that a script is executed. Special script functions include adding
delays (pauses),  defining selections, adding loops, and printing property information.



Adding Script Delays

Script delays are useful when you want to view the results of an operation during the script execution. You can 
add a delay, or pause, at any point of the script for a specified period of time. 
To add a delay to an open script:
1 Select the item below the point where you want to add the delay and select the Script>Insert Pause... 

command. The Pause dialog appears. (You can also access the Insert Pause... command from the Script pop-up
menu by right-clicking while the cursor is over the Script window.)

2 Select a Pause option setting. 
n Delay for ___ seconds 
n Stop and wait
n Delay off
3 Add a display message, if desired. You can specify any message text to be displayed during the inserted 

pause. Select the Display message option, click in the text window, and enter the desired text
4 Click OK to insert the pause in the script using the current settings. You can change the pause settings at any 

time by double-clicking on the Pause operation item in the Script window.



Scripting the Selection Marquee

You can add a defined Selection Marquee to any script which can be used for trim, flip, background removal, and 
other operations. You can also move an existing marquee. 
To add a new marquee definition or move marquee operation, select the Script>Insert Command submenu and 
choose the Edit>Select>Specify... command. The Select dialog appears. Use this dialog to define the location of 
the Selection Marquee on the image.
You can also add selections to a script using the WatchMe recorder. When the recorder is on, simply use the 
Selection Marquee tool to select areas within an Image window. DeBabelizer Pro automatically records the 
parameters of your selections and adds them to the selected script. 



Scripting Program Preferences

Preference settings affect many of DeBabelizer Pro's operations. For example, you may have script operation for 
Set Pixel Depth, using the 8 bits, dithered setting. In this case, the dithering option setting determines the 
amount of dither when this operation is executed. 
To allow you to achieve total automation and duplication using scripts, each operation remembers the program 
preferences it uses. When you add an operation you can either use the default program preferences (the current 
settings), or access the preference page(s) from the operation’s options dialog.



Printing Properties from a Script

Use the script print functions to print image and palette properties from within a script. You can view image and 
palette properties for a selected image and/or palette by selecting the View>Properties... command. Adding an 
image properties  or palette properties  print function downloads this information to your default printer during 
script execution.
To add a print image properties function to the selected script:
1 Select the Script>Insert Command>File>Print Properties>Start Print Job command. This function begins a print

job from the script. Once the print job has been opened within a script, you can execute an unlimited number 
of print operations for the same print job. 

2 Select the Script>Insert Command>File>Print Properties>Print Image Properties command. This function 
downloads the current image properties to the open print job. If a print job is not open at the time this 
operation is executed, DeBabelizer Pro automatically starts a print job and ends it after the information is 
generated, printing the properties information on its own page.

3 Select the Script>Insert Command>File:Print Properties>End Print Job command. This function closes the open
print job and downloads all of the collected print information to the default printer.

If you printed more than one set of image properties between starting and ending the print job, DeBabelizer Pro 
prints them on the same page, until that page is full, adding additional pages if necessary.
To add a print palette properties function to the selected script: 
1 Select the Script>Insert Command>File>Print Properties>Start Print Job command. This function begins a print

job from the script. Once the print job has been opened within a script, you can execute an unlimited number 
of print operations for the same print job.

2 Select the Script>Insert Command>File:Print Properties>Print Palette Properties.... command. This function 
downloads the current palette properties to the open print job. If a print job is not open at the time this 
operation is executed, DeBabelizer Pro automatically starts a print job and ends it after the information is 
generated, printing the properties information on its own page.

3 Set Palette Info parameters. Double-click on the Print Palette Properties item in the script to access the Print 
Palette Info Options dialog. Use this dialog to specify what palette information to print. 

4 Select the Script>Insert Command>File>Print Properties>End Print Job command. This function closes the 
print job and downloads it to the default printer.



Looping Script Operations

A loop is a special script function which allows you to repeat a series of operations within the defined conditions. 
When you execute a script, DeBabelizer Pro repeats the designated operations until the conditions of the loop 
are no longer met.
To add a loop routine to the selected script:
1 Select the Script>Insert Loop... command. The Loop dialog appears. Select the desired Loop option and click 

OK; DeBabelizer Pro adds the Loop operation to the script.
n Loop forever
n Loop ___ times
n Loop while there is a selection
2 Add the operations that you want to loop. After the Loop operation item, add the desired operation to the 

script. 
3 Select the Script>Insert Loop End command. DeBabelizer Pro adds the Loop End operation to the script. All 

operations between the Loop and Loop End Operation items will be looped when the script is executed.



Inserting a Log Comment

Another special script operation is adding a comment to a document's log. When a script contains this type of 
operation and is applied to a document, DeBabelizer Pro inserts a comment into the document's log reflecting 
the state of the document at that point in time. 
You can insert one of the pre-defined comments or define your own custom comment. The pre-defined 
comments are:
n Date and Time
n Available Memory
n Free Space on Drive... 
To add a custom comment insertion to the selected script:
1 Select the Script>Insert Comment>Specify... command. The Insert Comment dialog appears.
2 Click the cursor on the text edit box, and enter the desired text string. You can use the keyboard to type the 

string and/or use the Insert Keyword and Default String options to dynamically generate text when the 
comment is recorded.

3 Click OK. The comment insertion operation is added to the script using the current settings.



Dynamic Keyword

Dynamic keyword are available for inclusion when inserting comments into a log from a script, or when placing a 
text overlay.
To imbed a dynamic key word in a text string, use the Insert Keyword option. Place the cursor at the desired point
in the text string, and click the Insert Keyword arrow button. Select the item from the pop-up menu; the item 
appears in the text string surrounded by back slashes (/). DeBabelizer Pro parses, or generates text information, 
only the first instance of a particular keyword. 
To use the default text string, click the Default String button. This option automatically overwrites the text box 
contents using the default string. The default string is a series of dynamic keywords, which generate general 
information about the image file. Included are file name, date, size, number of colors, dpi, and cell number.



Executing Scripts

Once you have created or built a script, you can apply the script to an image, a group of images in a BatchList, 
or a palette. Scripts can be applied from a number of places within DeBabelizer Pro. You can determine the best 
way to use scripts in your work. 
When you apply a script to an image, palette, movie, or file in a BatchList, DeBabelizer Pro executes all 
operations within the script that are viable for that particular file and data type and its current status. Operations
that cannot be applied are recorded in the error column of the document's log. For example, if you apply a script 
containing the Rearrange Palette operation to an RGB image, DeBabelizer Pro cannot apply that operation 
(because an RGB image does not contain a palette) and records a message in the image's log. To view the log for
a selected document, select View>Log or click the    button.



Applying Scripts to Images, Movies, and Palettes

Any script can be applied to an open Image window, an open Movie window, an open BatchList window, an open 
Palette window, and during execution of other DeBabelizer Pro functions. As with many of DeBabelizer Pro's 
features, there are multiple ways of applying a script.
n Drag the ActionArrow    at the top of the open Script window and drop it onto any open Image or Movie window.

DeBabelizer Pro immediately applies the script to the image or movie.
n Drag the ActionArrow    at the top of the open Script window and drop it onto any open Palette window. 

DeBabelizer Pro immediately applies the script to the palette.
n Drag the ActionArrow    at the top of the open Script window and drop it onto any open BatchList window. 

DeBabelizer Pro immediately applies the script to each image, movie, or palette in the BatchList. 
n Select the Tools>Apply Script submenu and choose an open script from the menu. DeBabelizer Pro applies the 

script to the currently selected document.
n Select an open Script window and then select the Script>Execute command. DeBabelizer Pro applies the 

selected script to the most recently selected open document that the script can be applied to. 
n Select any operation item(s) from an open Script window and drag them onto an open Image, Movie, or Palette

window. DeBabelizer Pro immediately applies only those operation items to the document. You can also use 
this method when applying selected operations to a BatchList.

n When saving an image, select a saved script from the Pre Save Do Script drop-down list. DeBabelizer Pro 
applies the selected script to the image before saving it.

n When running a Save, Save with SuperPalette, or Print Batch Automation process, you can select a script to 
apply to source files before the save or print operation in the Batch Automation is executed. 



Using Batch Automation

While DeBabelizer Pro allows you to automate nearly every executable feature using scripts with BatchLists, 
Batch Automation provides additional automation capabilities that can streamline your work even further. An 
automation process is essentially a script template that you can use to apply a particular combination of 
operations to any group of images, from a BatchList or another source.
Each Batch Automation process contains a pre-set list of operations, for which you define the parameters. To 
execute and define a Batch Automation process, select the Tools>Batch Automation... submenu and select one 
of the automation processes:
n Create SuperPalette
n Create SuperPalette and Remap
n Save
n Save with SuperPalette
n Print
Each of these commands executes a Batch Automation script containing the pre-set operations, while providing 
explanatory messages and prompting you to set the parameters. 



Create SuperPalette - Batch Automation

Use the Batch Automation Create SuperPalette process to automatically create a SuperPalette for a group of 
images. To execute this batch automation process:
1 Select the Tools>BatchAutomation>Create SuperPalette... command. DeBabelizer Pro automatically begins 

generating a Batch Automation script.
2 Select the source and display option. DeBabelizer Pro prompts you to select the source for the automation 

process. 
3 Set the SuperPalette parameters. The SuperPalette Properties  dialog appears, prompting you to define the 

parameters of the SuperPalette. Click OK when you have set the options as desired.
n Enter the desired number of colors, between one and 256, in the Target number of colors field.
n Select the Use Base Palette  option, if desired, and select a base palette from the Base Palette drop-down 

list, or use the arrow key to select a saved palette file to use as a base palette. Only palettes containing a 
number of colors less than the specified target number of colors.

n Select the Display option to display the new SuperPalette.
n Select the Save option to save the created SuperPalette, if desired. 

Note: The Display and/or Save option must be selected in order to continue with the automation process.
4 Click OK. DeBabelizer Pro automatically creates a SuperPalette for the specified source files using the defined 

parameters. If the Save option was selected, the Save As dialog appears, prompting you to designate a 
filename and set save options for the new SuperPalette.



Create SuperPalette and Remap - Batch Automation

Use this Batch Automation command to automatically create a SuperPalette for a group of images and remap 
them to the created SuperPalette. To execute this batch automation process:
1 Select the Tools>BatchAutomation>Create SuperPalette and Remap... command. DeBabelizer Pro 

automatically begins generating a Batch Automation script and adds each operation in order.
2 Select the source and display option. DeBabelizer Pro prompts you to select the source for the automation 

process. 
3 Set the SuperPalette parameters. The SuperPalette Properties dialog appears, prompting you to define the 

parameters of the SuperPalette. 
n Enter the desired number of colors, between one and 256, in the Target number of colors field.
n Select the Use Base Palette  option, if desired, and select a base palette from the Base Palette drop-down 

list, or use the arrow key to select a saved palette file to use as a base palette. Only palettes containing a 
number of colors less than the specified target number of colors.

n Select the Display option to display the new SuperPalette.
n Select the Save option to save the created SuperPalette, if desired. 

Click OK when you have set the options as desired. If the Save option was selected, the Save As dialog 
appears, prompting you to designate a filename and set save options for the new SuperPalette.

4 Set Remapping options. The Set Palette and Remap dialog appears, prompting you to specify the parameters 
for remapping the source file(s). 
n Select the desired palette from the drop-down list. The newly created SuperPalette appears as the default.
n Select the desired remap options.

Click OK when you have set the options as desired. DeBabelizer Pro automatically applies the selected 
SuperPalette or palette to the source file(s) according to the selected options.



Save - Batch Automation

Use this Batch Automation command to automatically save a group of image files. This is a useful process for 
performing a routine file format translation for a large group of image files. 
To execute this batch automation process:
1 Select the Tools>BatchAutomation>Save... command. DeBabelizer Pro automatically begins generating a 

Batch Automation script and adds each operation in order.
2 Select the source and display option. DeBabelizer Pro prompts you to select the source for the automation 

process. 
3 Set the Save parameters. The Save Setup dialog appears, prompting you to define the parameters for saving 

the modified source files.
n Specify a destination directory for the saved files.
n Specify a file format for the saved files.
n Modify the Naming Options  settings to specify how file names are generated when saving the modified source

files. 
n Specify a saved or open script to be applied to the modified source files before they are saved. Use the Pre 

Save Do Script drop-down list to select an open script, or click the Open button to specify any saved script in 
your system. Select (none) from the drop-down list if you do not want to apply a script to the files before 
saving them.

4 Click OK to save the source files using the defined save and naming parameters.



Save with SuperPalette - Batch Automation

Use this Batch Automation command to automatically create a SuperPalette  for a group of images, remap them 
to the created SuperPalette, and save the images to another file format. To execute this batch automation 
process:
1 Select the Tools>BatchAutomation>Create SuperPalette and Remap command. DeBabelizer Pro automatically 

begins generating a Batch Automation script and adds each operation in order.
2 Select the source and display option. DeBabelizer Pro prompts you to select the source for the automation 

process. 
3 Set the SuperPalette parameters. The SuperPalette Properties dialog appears, prompting you to define the 

parameters of the SuperPalette. 
n Enter the desired number of colors, between one and 256, in the Target number of colors field.
n Select the Use Base Palette option, if desired, and select a base palette from the Base Palette drop-down list, 

or use the arrow key to select a saved palette file to use as a base palette. Only palettes containing a number 
of colors less than the specified target number of colors.

n Select the Display option to display the new SuperPalette.
n Select the Save option to save the created SuperPalette, if desired. 

Click OK when you have set the options as desired. DeBabelizer Pro automatically creates the SuperPalette 
and remaps the source images. If the Save option was selected, the Save As dialog appears, prompting you to 
designate a filename and set save options for the new SuperPalette. 

4 Set the Save parameters. The Save As dialog appears, prompting you to define the parameters for saving the 
modified source files.

n Specify a destination directory for the saved files.
n Specify a file format for the saved files.
n Modify the Naming Options  settings to specify how file names are generated when saving the modified source

files. 
n Specify a saved or open script to be applied to the modified source files before they are saved. Use the Pre 

Save Do Script drop-down list to select an open script, or click the Open button to specify any saved script in 
your system. Select (none) from the drop-down list if you do not want to apply a script to the files before 
saving them.

5 Click OK. DeBabelizer Pro automatically creates a SuperPalette for the specified source files, remaps them, and
saves the modified files using the defined parameters.



Print - Batch Automation

Use this Batch Automation command to automatically print a selected group of images To execute this batch 
automation process:
1 Select the Tools>BatchAutomation>Print command. DeBabelizer Pro automatically begins generating a Batch 

Automation script.
2 Select the source and display option. DeBabelizer Pro prompts you to select the source for the automation 

process. 
3 Set Print options. The Print dialog appears, prompting you to select printing options. 
4 Click OK to print the selected source file(s) using the specified print option settings.



Selecting a Source

The first item to be defined in any Batch Automation process is the source. Defining the source is essentially 
specifying which files you want to process. Unlike standard script operations, which can be applied only to open 
documents, BatchLists, and system files, Batch Automation processes allow you to access files from a greater 
number of sources. 
When you select any of the Batch Automation commands from the Tools>Batch Automation... submenu, the 
Select Source dialog appears, prompting you to define the source:
Use one of the following options to select a source for Batch Automation processing:

Image - Use this option to designate any saved image file for automated processing. Click the Browse... 
button to access the Open Image dialog. You can then locate and select the desired image file. Click Open, and
the selected image file name and path appears in the adjacent field.
Open Image - Use this option to designate one of the currently open image files for automated processing. 
Select the desired file from the drop-down list.
All Open Images - Use this option to designate all currently open image files for automated processing.
BatchList - Use this option to designate any saved BatchList file for automated processing. Click the Browse 
button to access the Open dialog. You can then locate and select the desired BatchList. Click Open, and the 
selected BatchList file name and path appears in the adjacent field.
Open BatchList - Use this option to designate one of the currently open BatchList files for automated 
processing. Select the desired BatchList from the drop-down list.
Directory - Use this option to designate a directory (folder) from your system containing the files you want to 
process. Click the Browse button to access the Browse for Folder dialog. You can then locate the desired 
directory. Click OK and the selected folder file name and path appear in the adjacent field.

Once you have selected the source, click OK. DeBabelizer Pro continues with the Batch Automation process and 
prompts you define the additional parameters. 



Delay for ____ Seconds
Use this setting to insert a pause of a specified duration. Five seconds is the default, but you can specify any 
number of seconds for the pause.



Stop and Wait
Use this function to stop the script at that point and wait for the user to press the Return key or click OK before 
continuing with the remainder of the script. You should not use this setting if you want to run the script 
unattended.



Delay off
Use this option to turn the pause off. If you want to remove the pause permanently, you should delete the item 
from the script.



Loop forever
Use this loop option to continue the loop infinitely. DeBabelizer Pro continues to repeat the looped operation 
items until you press the Esc key, or conditions change so that it cannot continue to execute the looped 
operations.



Loop ___ times
Use this loop option to continue the loop for a specified number of repetitions. DeBabelizer Pro repeats the 
looped operations, and when it has completed the number of repetition, it proceeds with any remaining script 
operations after the loop.



Loop while there is a selection
Use this loop option to continue the loop as long as there is a current Selection Marquee. DeBabelizer Pro repeats
the looped operations until there is no longer an active selection. For example, if reducing the marquee by 10 
pixels on the top and left were one of the operations in the loop, eventually there would no longer be an active 
selection.



Date and Time
Insert this comment to add a date and time stamp to the document's log during the script execution. When 
DeBabelizer Pro executes the script, it records the date and time in the log of the document it is currently 
processing. 



Available Memory
Insert this comment to record the available memory in the document's log during the script execution. When 
DeBabelizer Pro executes the script, it records the currently available memory in the log of the document it is 
currently processing.



Free Space on Drive...
Insert this comment to record the available storage space on the specified drive in the document's log during the
script execution. When DeBabelizer Pro executes the script, it records the currently available space of the 
selected drive/folder in the log of the document it is currently processing.
When you select this Insert Comment command, the Browse for Folder dialog appears. Select the desired 
drive/folder from your system and click OK.



Displaying Image Channels

Every image is comprised of a set of channels. The number and depth of each channel depends upon the image 
type.

32 bit RGB images - These images have four channels: alpha, red, green, and blue. Each channel is eight 
bits deep, containing intensity levels from 0 to 255 for the particular component of the image that the channel 
represents.
24 bit RGB images - These images have three channels: red, green, and blue. Each channel is eight bits 
deep, containing intensity levels from 0 to 255 for the particular component of the image that the channel 
represents. This is equivalent to a 32 bit RGB image, but without the alpha channel.
15 bit RGB images - These images have three channels: red, green, and blue. Each channel is five bits deep,
containing 32 intensity levels each. Some formats also support a 16 bit image, which contains an additional bit
in the green channel, or a one bit alpha channel. DeBabelizer Pro currently reads and these images as 15 bit.
Palette images - These images are also called indexed images and have a palette that determines the color 
usage of the image pixels. Palette images can be treated as having Red, Green, and Blue channels. The bit 
depth  of the channels depends upon the pixel depth of the image. Palette images can have pixel depths 
between one and eight.

An image is displayed on the monitor combining the red, green, and blue channels for each pixel. The alpha 
channel is non-standard and is typically used for masking. 
You can display any combination of red, green and blue channels for an image at any time. Turn channels on or 
off using the red, green, and blue channel buttons located at the bottom of the Image window or in the toolbar. 
You can also toggle the image channels on or off using the appropriate command from the View>Channels 
submenu.
For a 32 bit image, you can turn the alpha channel on and off using the alpha    button located at the bottom of 
the Image window or in the toolbar. When the alpha channel is displayed, the red, green, and blue channels are 
hidden.
When you execute most image and palette operations, only currently displayed channels are affected. For 
example, you can display only the green channel and then use the Adjust HSV dialog to adjust the hue saturation
and brightness. When you turn on the red and blue channels, the red and blue color usage of each pixel is 
unaffected by the color modification.



Swapping Image Channels

Swapping channels involves taking the color usage information from one channel and switching it with another. 
For an RGB image, the channels are swapped for each pixel in the image. For a palette image, the channels of 
the palette are swapped and the pixels are then remapped to the resulting palette colors. 
DeBabelizer Pro contains three functions that you can use to swap image channels. Select the Tools>Channels 
submenu to access these command functions.
n Swap R <-> G    
n Swap R <-> B 
n Swap G <-> B 



Rotating Image Channels

Rotating channels is similar to swapping channels as it also involves taking the color usage information from one 
channel and placing it another. When you rotate channels you alter the channel color usage between three or 
four channels.
DeBabelizer Pro contains two functions that you can use to rotate image channels. Select the Tools>Channels 
submenu to access these command functions.
n R -> G -> B -> R 
n R -> G -> B -> A -> R 



Converting Image Channels to Grayscale

Converting an image channel to grayscale strips the color information from the channel, while leaving the 
brightness information intact for each pixel. When you select a conversion command, you convert the color 
information of the channel to grayscale.
DeBabelizer Pro contains four functions that you can use to convert image channels to grayscale. Select the 
Tools>Channels submenu to access these command functions.
n Convert R -> Grayscale
n Convert G -> Grayscale
n Convert B -> Grayscale
n Convert A -> Grayscale



Inverting Image Channels

Inverting a channel involves taking the taking the pixel color values of that channel and inverting them. For 
example, a value of 0 becomes 255, 1 becomes 254, and so on. You can use the inversion functions to create a 
"negative" of the specified channel. Inverting all of the image channels will produce a negative of the entire 
image.
You can invert the displayed channels using the Image>Invert Colors command. Only those channels currently 
displayed are inverted. You can then display the previously hidden channels to view the effect of the inverted 
channel(s) combined with the un-inverted channel(s). 



Using Masks 

Masking creates a silhouette of the image, using the alpha channel, which you can use to isolate various pixels in
the image. You can create masks for a selected area on an image or the entire image.
Alpha channels do not contain color; they contain only black and white or grayscale information. When you paste
an image selection into an Alpha channel, DeBabelizer Pro automatically strips the color/hue information from 
the pasted selection, leaving a mask which represents the intensity value of each pixel in the image.
You can paste any image selection into the alpha channel of that image or another image. Use the cut or copy 
function to copy an image selection to the Clipboard, and then use the paste function to paste the image 
information to the alpha channel.
If you have created a mask which is stored in an image's alpha channel, you can use the mask to combine 
different versions of the image. You should first create an appropriate mask in the image's alpha channel. 
Use the Edit>Transparency submenu to activate the Alpha Channel setting. The image pixels become 
transparent according to their alpha channel values.



Creating an Alpha Channel

A 32-bit image has an alpha channel, and using the Create Alpha Channel command overwrites the existing 
alpha channel with a new one, using the specified parameters. You can also use this function to add an alpha 
channel to a 15 or 24-bit image. You cannot add an alpha channel to an indexed (palette) image.
To create an alpha channel and insert a mask of the image:
1 Select an open image. The image must be 32, 24 or 15-bits in color depth.
2 Select the Tools>Channels>Create Alpha Channel command. The Create Alpha Channel dialog appears.
3 Select the Transparency Factors. These settings determine how the pixels in the image are copied into the new

alpha channel. These are the same transparency settings used for selections pasted into an Image window, 
and can be selected in any combination to create the desired effect.

4 Set the Non-Transparent Pixels option. You can choose one of the two settings to determine what type of copy, 
or mask, is placed in the new alpha channel.

n Use Luminance
n Fully Opaque
1 Click OK. The new alpha channel is displayed in the Image window with the resulting grayscale or black and 

white copy (mask) of the image.



Swap R <-> G
Use this command function to swap the Red and Green channels of the selected image or area.



Swap R <-> B
Use this command function to swap the Red and Blue channels of the selected image or area.



Swap G <-> B
Use this command function to swap the Green and Blue channels of the selected image or area.



R -> G -> B -> R
Use this command function to shift red, green and blue channels in the image or area to the right. The current 
red moves to green, the current green moves to blue, and the current blue moves to red. 



R -> G -> B -> A -> R
Use this command function to shift all channels in the image or area to the right. The current alpha moves to red,
the current red moves to green, the current green moves to blue, and the current blue moves to alpha. This 
command is available only for 32 bit images; images of a lower bit depth do not contain an alpha channel. 



Use Luminance
Choose this setting to produce a grayscale representation of the image, using the brightness value of each non-
transparent pixel.



Fully Opaque
Choose this setting to produce a black and white representation of the image, using only the non-transparent 
pixels.



Vector Images

These images are defined by the locations of the end points of sets of lines. Individual lines are combined to 
create the image. Vector images are also called object-oriented graphics. The location of a line is defined by 
mathematical formulas and numeric attributes with different properties of transparency, so that each line has a 
unique identity which can be saved and later recalled to recreate the image.
DeBabelizer Pro currently does not read or write vector images.



Raster Images

Also called bit mapped images, raster images are defined as a set of pixels (picture elements or dots), in a 
column and row format. Individual pixels are combined to create the image similar to using tiles to create a 
design. The color value at each location is defined by number so that each pixel has a unique identity which can 
be saved and then recalled to recreate the image.
Currently, DeBabelizer Pro reads and writes over 90 different raster graphic file formats. 
The following parameters define the characteristics of a raster image:
n Bit Depth 
n Palette 
n Image Size 
n Compression 
n File Extensions 



Graphic File Formats

Each format has distinctive characteristics which determine its memory usage, the number of colors it supports, 
as well as other parameters. 
DeBabelizer Pro currently supports the following general    graphic file formats.
n Abekas Digital Video
n Alias 
n Amiga IFF/LBM
n Atari Degas
n Atari Neochrome
n BOB
n Compuserve RLE
n Digital F/X
n Dr. Halo
n Encapsulated PostScript
n FITS Astronomical 
n Graphics Interchange
n JPEG File Interchange
n MacPaint
n Microsoft Paintbrush
n PC Paintbrush
n PhotoCD
n Pixar
n QDV
n Raw RGB
n Silicon Graphics Bitmap
n SoftImage
n Sun Raster
n Targa/Truevision
n Thunderscan Uncompressed
n TIFF (Tag Image File Format)  
n Ventura Publisher/GEM
n WaveFront
n Windows/OS2 Bitmap
n X Window Bitmap



Reader Preferences

Some of the file formats read by DeBabelizer Pro have preference settings which you can change to adjust the 
way that these files are read. 
To change the reader preferences for any of the following formats, click the Reader Prefs... button in the Open 
Image dialog. The File Reader Preferences dialog appears, click on the appropriate tab to access reader 
preference options for the desired file format.
The following file formats have reader preference settings:
n Raw RGB
n PhotoCD
n SoftImage



Writer Preferences

Some of the file formats written by DeBabelizer Pro have preference settings which you can change to adjust the
way that these files are written. 
To change the writer preferences for any of the following formats, select the desired file format in the Save As 
dialog and click the Writer Preferences button (this button is dimmed if the selected does not have writer 
preferences). The writer preferences dialog for the selected format appear.
The following file formats have writer preference settings:
n BMP 
n Targa
n SoftImageSGI  
n EPSF
n Digital F/X
n GEM/IMG
n GIF
n Amiga IFF/LBM/CD-I
n JPEG/JFIF
n Raw RGB
n TIFF



Bit Depth
Bit mapped images use a specific number of colors to recreate an image. Bit depths refer to how much memory 
is used to store the color in each pixel and determine the total number of colors in the image. Images with larger
bit depths require more memory for both storage and display.
Different formats support different ranges of bit depths. If you save an image to another graphic file format, 
DeBabelizer Pro automatically changes the bit depth of the image and remaps its pixels while maintaining the 
color.



Palette
Bit mapped images of 256 or fewer colors store their colors in a palette. These palette images are also called 
indexed images, as each position in a color palette is referred to by an index or number. Some formats require 
specific palettes that contain specific colors at specific locations on the palette.
If you save an image to a format which has palette specifications, DeBabelizer Pro automatically adjusts the 
image's palette and remaps its pixels to conform to the formats parameters without distortion.



Image Size
Some graphic file formats can save images at particular sizes. When you save an image to a format which does 
not support the full size of the current image, DeBabelizer Pro automatically crops the image to the center. If the 
format only supports a larger size, DeBabelizer Pro centers the image within the document, and adds padding 
around the edges.



Compression
Many format designers have developed methods of storing image data more efficiently by compressing their 
data so that the storage size of the data is minimized. Compression methods vary, but essentially they all use 
mathematical formulas to perform the data compression.
You can set compression options in the writer preferences for formats which support compression. 



File Extensions
When a graphic is written to a specific file format, its name usually contains an extension (a three to four letter 
sequence added to the file name after the . character). Many programs require a correct extension or they 
cannot correctly identify the file format and read the image. 
DeBabelizer Pro can read the supported file formats regardless of the file's name and extension. And when you 
save a to a particular format, DeBabelizer Pro allows you to designate any extension you wish.



Abekas Digital Video 

This is a digital video file format  engineered by Abekas, Inc. DeBabelizer Pro writes this format at 720 x 486 
pixels, 17 million colors.
The default file extension is YUV. A file must use this extension in order for DeBabelizer Pro to read it correctly.



Alias

This image file format, created by Alias, supports 8 and 24 bits of color information. 
The default file extension is PIX.



Amiga IFF/LBM

This is a general purpose data storage format that can associate and store multiple types of data and is fully 
supported by the Amiga operating system, It is a bitmap format which can store between 1 and 24 bits of color. 
The maximum image size for this format is 64k x 64k pixels. It also supports multiple images per file. 
DeBabelizer Pro reads up to 32 bits of color information in this format and writes up to 8 bits.
The default file extension is IFF.

Writer Preferences
DeBabelizer Pro reads IFF files using the CD-I formats for Phillips CD-I compliance. Choose the appropriate CD-I 
format from the IFF output option settings. If the CD-I YUV setting is selected, you can also specify the YUV 
values, or allow DeBabelizer Pro to calculate the values for each scan line.



Atari Degas

This is an animation file format  engineered by Atari, Corp. for use on Atari ST computers. This format is used 
specifically for storing a single image of the display. It supports up to 16 colors, and 320 x 200 pixels. 
The default file extension is PLN.



Atari Neochrome

This is an animation file format  engineered by Atari, Corp. for use on Atari ST computers. This format is used 
specifically for storing a series of multiple images for display. It supports up to 16 colors, and 320 x 200 pixels. 
The default file extension is ANI.



BOB

This is a raw image file format  used for storing 256 color palette images designed for ray-trace applications. It 
contains the picture width, height, a palette, and the uncompressed image. 
The default file extension is BOB.



Compuserve RLE

This is a compressed image file format  which is supported by most bitmap file formats, such as .TIFF, .BMP, 
and .PCX. RLE stands for run-length encoding. This format is widely used on Compuserve and similar internet 
service provider for reducing the size of graphic files.
The default file extension is RLE.



Digital F/X

This file format  is used by Video F/X and Titleman and supports up to 32 bits of color information. These files 
contain two versions of the image: the main version and a preview version. DeBabelizer Pro reads the main 
version.
The default extension is .TDIM for a Titleman image file, and .GRAF for a Video F/X image file.

Writer Preferences
DeBabelizer Pro two types (sub-formats) of Digital FX image files. You can select either the TitleMan format, 
which adds TDIM as the default filename extension, or the Video FX format, which adds GRAF as the default 
filename extension.



Dr. Halo

This is a device independent file interchange format used for transporting image data from one hardware 
environment or operating system to another. It may contain up to 256 colors, up to 8 bits, with a maximum 
image size of 64k x 64k pixels. Only one image may be stored per file. 
The default file extension is CUT.



Encapsulated PostScript

This is a device independent file format  used to contain the graphics and images portions of a larger document. 
The graphics contained in an EPSF file are typically monochrome (black and white) and commonly referred to as 
line art. DeBabelizer Pro supports EPSF formats up to 32 bits of color. Only one image may be stored per file. 
Vector EPS images from Adobe Illustrator or Freehand or a PostScript screen dump are not supported at this time.
The default file extension is EPSF.

Writer Preferences
DeBabelizer Pro does not currently support preview in EPSF files. You write an EPSF file as either a 24 bit color 
image or a grayscale image. 



FITS Astronomical 

This is a general purpose data storage format primarily used as a method of exchanging bitmap data between 
different hardware platforms and software applications that do not support a common image file format. It is 
used mostly by scientific and governmental organizations that require storage of astronomical image data. This 
format supports unlimited grayscale and multiple images per file. 
The default file extension is FITS.



Graphics Interchange (GIF)

This format, commonly called "Gif," is a creation of Compuserve and is used to store multiple bitmap images in a
single file for exchange between platforms and systems. It supports 1 to 8 bits, and up to 64k x 64k pixels. It is 
widely used for 16 to 256 color photographic quality images.
DeBabelizer Pro supports both interlaced and non-interlaced GIF files.
The default file extension is GIF.

Writer Preferences
DeBabelizer Pro can write GIF image files as both single and multiple image files. When saving multiple frames in
a GIF file there are a number of options for formatting Multiple image GIF files. 

Transparent Color - You can use this option to designate a transparent color in the saved image file. If you 
select the None option, no transparent information is written. If you select the Use first transparent index 
option, the first palette color flagged as transparent is set to transparent in the saved GIF file. If you select the 
Use palette index option, the index value entered in the adjacent field is set to transparent in the saved GIF 
file. And if you select the Use ULC option, the color at index value 0 (upper left corner) is set to transparent in 
the saved GIF file.
File Options - Select the Interlaced option to save GIF files using an interlaced format (useful for web pages). 
Select the Multi-image per file option to save every frame in a multiple image file, or the Single image per file 
option to save only the first frame in the saved GIF file.
Multi-Image - Use these options to set display options for multiple frames in a GIF file. The setting you choose 
will depend upon the intended display program for the saved GIF files. Some programs support a key press 
slideshow and/or frame times. Use the default Use current frame time setting to save the file using its current 
display settings.
Disposal Method - Use these options to determine how each image delta in a multiple image file is saved. 
These settings do not modify the raw image data, only the way that it is displayed. 
n Not specified - this is the default setting and allows for compatibility with programs that do not properly 

follow the GIF specifications.
n Do not dispose - this setting does not erase the previously written frame when displaying the next frame.
n Overwrite with background - this setting replaces the previous frame with the background color (usually the

transparent color) when the next frame is displayed.
n Overwrite with previous frame - this setting restores the previous image before displaying the next frame in

the sequence.
Comment - Use these options to include comment information in the saved GIF file(s). Select the One 
comment option to include one comment for the entire multiple image file, or select the Multiple comments 
option to duplicate the comment for each image in the file. Enter the desired comment in the text window.



JPEG File Interchange

This image file format  is a development of C-Cube Microsystems for the purpose of storing JPEG-encoded data. It
supports up to 24 bits and 64k x 64k pixels, and is used primarily in graphics and image manipulation 
applications. It incorporates the JPEG compression method, which offers superior compression for deep-pixel 
images.
DeBabelizer Pro's JPEG writer follows the guidelines from the Independent JPEG Group, version 4. This permits 
the writing of JPEG files that most Windows, Macintosh, and DOS programs can use.
The default file extension is JPG.

Writer Preferences
DeBabelizer Pro writes JPEG files following guidelines from the Independent JPEG Group, version 4. This permits 
the writing of JPEG files that most Windows, DOS, and Macintosh programs (which support JPEG) can use.
Use the slider control to set image output quality (the default is 75%). A lower setting produces a smaller image 
file, at the cost of quality.
The JPEG specification defines a minimal subset of the standard called baseline JPEG, which all JPEG software 
applications are required to support. The minimum quality setting is 25, which is enforced if the Force baseline 
compatibility option is selected; however, settings lower than 25 will are likely to be readable by all JPEG 
programs.
Use the Progressive option to save images in a progressive format. A progressive format allows web browsers 
that support this feature to load the image in steps, starting with a low resolution image and gradually increasing
the resolution as the user waits for the image to transfer from the web page.



MacPaint

This is the original and most common graphics file format  used on the Apple Macintosh. However, it supports 
only monochrome (black and white) images, and is a fixed size of 576 x 720 pixels. It is typically used to store 
clip art and line drawings. 
The default file extension is MAC.



Microsoft Paintbrush

This is one of the most common graphics file format  used by Microsoft Windows applications. However, it 
supports only monochrome (black and white) images, and up to 64k x 64k pixels. It is typically used to store clip 
art and line drawings. 
The default file extension is MSP.



PC Paintbrush

This format is used mainly an exchange and storage format for monochrome, 4-bit, 8-bit, and 24-bit images, and 
is used in a number of Microsoft Windows and Windows-based applications. It supports up to 32-bits, 64k x 64k 
pixels. 
The default file extension is PCX.



PhotoCD

This format  was designed by Kodak to be used for static data storage of multi-resolution deep-pixel images on 
CD-ROM. Some images stored in this format are encrypted and require you to provide a password. DeBabelizer 
Pro reads this format at 24 bits of color information and sizes up to 4096 x 6144, but cannot write (save) an 
image file to this format. 
The default file extension is PCD.

Reader Preferences
Photo CD files can be read at one of six sizes. The size you select determines how much memory will be required
to open each file.
n 64 x 96
n 128 x 192
n 256 x 384
n 512 x 768
n 1024 x 1536
n 2048 x 3072
n 4096 x 6144
You must have at least 96 mb of physical RAM installed in order to effectively use the largest (4096 x 6144) 
setting.
Skip password dialog for watermarked images

Some images contain watermarks. Typically, when you attempt to open this type of image, you are prompted 
for a password in order to load the image without the watermark. Selecting this option eliminates this prompt 
and DeBabelizer Pro loads the image with the watermark. 
Note: Some images are also encrypted. In this case, you must supply a password regardless of this preference 
setting.

Find nearest image size if requested one not found
If this option is selected and the current image size preference is not stored in the PhotoCD PAK, DeBabelizer 
Pro searches for the nearest higher image size. If a higher image size does not exist, it searches for a lower 
size.



Pixar

This format was originally a proprietary format created for Pixar's RenderMan software. It has evolved into the 
standard for scene descriptions used for high-end rendering. It supports up to 32-bits, compressed and 
uncompressed. 
The default file extension is PXR.



QDV

This format is a simple image storage format that does not use compression, engineered for Random Dot 
software. It supports up to 8 bits of color information
The default file extension is QDV.



Raw RGB

This is the simplest possible format  for storing RGB (also called direct color) type pictures, where red, green, and
blue values are stored for each pixel. It contains the picture width, height, and the uncompressed image. It 
supports up to 32 bits.
The default file extension is RGB.

Reader Preferences
Raw RGB image files are simple uncompressed image files. Using the reader preferences you can specify the 
characteristics of these files. Click the Raw tab in the File Reader preferences dialog to access reader preference 
options for this file format.

Raw Filename - The reader preferences for this file format allow you to use a sample file to determine the 
settings for these options. To designate a sample file, click the ... button to access the Open dialog and select 
the appropriate file from your system. The selected file appears in the Raw Filename window and the size of 
the file is displayed to the right.
File Info - If you have selected a sample file, you can use the Guess buttons to fill in the Image offset and 
Width and Height option fields. The best method is to enter the desired bit depth, check the Auto set check 
boxes, and then click the large Guess button. 
When Mac Pixel Order option is selected (checked) and there is more than one pixel per byte, the pixels are 
packed in the byte starting at the left (high order bit) of the byte. If this option is selected and there more than
one byte per pixel, the pixel data is entered from the left (highest order bit) to the right (i.e.; red, green, blue).
Palette - These options are available only when the bit depth is set to a 8 or less. Select the Standard option to
use a standard Windows color format. Select the ...... Start -> End Bits to read files with colors arranged in 
another format, and enter the appropriate values in the start and end field for each color channel.
Bit numbering starts with a bit 0 at the far left (highest order bit) and goes up from left to right. For example, if
colors are coming in with 2 bytes for red, 2 bytes for green, and 2 bytes for blue, enter a 6 in the Bytes/Color 
field and then enter 8, 15, 24, 31, 40, 47 in the Red, Green, and Blue start and end fields for.
Channel Order - These options apply only to RGB images with three or four bytes per pixel. Typically, with 
three bytes per pixel, the channels are ordered R, G, B. With four bytes per pixel, they are ordered, A, R, G, B. 
If the file(s) that you want to open sends the channels in a different order, use the Alpha, Red, Green, and Blue
fields to specify the channel order. To specify the way that the channels are arranged, select one of three 
setting in the drop-down menu.
n Interleaved - this is the most common setting and groups the channels for each pixel (i.e.; rgb rgb rgb rgb 

rgb)
n Planar by Row - this setting groups channels separately for each row (i.e.; row 1 = rrrrr ggggg bbbbb)
n Planar by Image - this setting groups each channel separately for the entire image (bytes per row should 

specify bytes per row for each channel, which is most likely the same as the width).

Writer Preferences
DeBabelizer Pro currently writes two types of Raw RGB image files. You can write these files with a 12 byte 
header that identifies the data and contains the image width and height values. or you can write these files 
without a header, using only the raw data.



Silicon Graphics Bitmap

This file format is a Unix bitmap format that is actually part of the SGI image library found on all Silicon Graphics 
computers. It supports up the 32bits, 64k x 64k pixels, in both RLE and uncompressed.
The default file extension is SGI.

Writer Preferences
DeBabelizer Pro writes SGI image files as compressed or uncompressed. You can use any bit depth supported by 
the format in a compressed or uncompressed file. Select the appropriate option from the SGI Output Options 
dialog.



SoftImage

This format supports up to 32 bits of color information, compressed and uncompressed.
The default file extension is PIC.

Reader Preferences
You can use the reader preference options for this file format to correct images that have been corrupted during 
network transfer. Click the SoftImage tab in the File Reader Preferences dialog to access these options.
Text transfer modes will often swap carriage returns (CRs) and line feeds (LFs). When reading files which have 
been corrupted in this manner, select the Swap CR/LFs option in the SoftImage reader preferences. When this 
option is selected DeBabelizer Pro swaps bytes with values of 10 and 13. Use the Do not swap CR/LFs option to 
read all other SoftImage files.

Writer Preferences
DeBabelizer Pro writes SoftImage image files as compressed or uncompressed. You can use any bit depth 
supported by the format in a compressed or uncompressed file. Select the appropriate option from the SoftImage
Output Options dialog.



Sun Raster

This is a bitmap format native to the Sun Microsystems UNIX platforms using the SunOS operating system. It 
supports up to 32bits. It is used primarily for screen dumps.
The default file extension is RAS.



Targa/Truevision

This image file format  is used for storage and interchange of deep-pixel images, paint, and image manipulation 
programs. It supports 8, 16, 24, and 32bits, compressed and uncompressed. It was developed by Truevision, Inc. 
for use with their product line, which can capture NTSC and/or PAL video signals and store them in a digital frame
buffer. 
The default file extension is TGA.

Writer Preferences
DeBabelizer Pro writes Targa image files as compressed or uncompressed. You can use any bit depth supported 
by the format in a compressed or uncompressed file. Select the appropriate option from the Targa Output 
Options dialog.



Thunderscan Uncompressed

This file format  supports up to 8 bits of color information, uncompressed.
The default file extension is SCN.



TIFF (Tag Image File Format)

This is a bitmap file format used for data storage and interchange, particularly cross platform. It supports up to 
24bits and multiple images per file. TIFF is a standard file format found in most paint, imaging, and desktop 
publishing programs.
The default file extension is TIF.

Writer Preferences
DeBabelizer Pro currently writes TIFF files using one of four different modes. You can select one of these mode 
options from the TIFF Output Options dialog.
n CCITT - this mode uses the RLE monochrome compression format
n Group 3 FAX - this mode produces a file conforming to the Group 3 FAX format 
n Group 4 FAX - this mode produces a file conforming to the Group 4 FAX format 
n Grayscale - this mode produces 4 and 8 bit grayscale image files. Use the Grayscale Options to set the color 

compression method.
n Color - this mode produces 4, 8, 24, and 32 bit color images. Use the Color Options to set the color 

compression method.
Byte Ordering - Use these options to control how the data is ordered in the image. The standard for ordering is 
different in PC and Macintosh systems, and some programs handle only one type of ordering.



Ventura Publisher/GEM

This bitmap file format was developed by Digital Research and used primarily in GEM-based application 
environments. It supports up to 8bits, and 64k x 64k pixels. 
The default file extension is IMG.

Writer Preferences
DeBabelizer Pro currently writes two types of GEM/IMG files. You can write a GEM file as grayscale in 1, 2, 4, or 8 
bit depths. You can also save a GEM file using the GEM/IMG fixed 16 color palette. If you are saving files using 
the fixed colors option, you should first remap the image(s) to the IMG colors palette.



WaveFront

This is a run-length-encoded multiple image format created by WaveFront. Frames may be different sizes and 
different color resolutions. Each frame is stored intact (there is no frame differencing). It supports up to 32 bits of
color information.
The default file extension is RLA.



Windows/OS2 Bitmap

This file format is used as the standard bitmap storage format for the Microsoft Windows environment, but is also
supported by many non-Windows applications. It supports up to 32bits, and 32k x 32k and 2G x2G pixels. This 
format is also referred to as a DIB.
The default file extension is BMP.

Writer Preferences
DeBabelizer Pro writes .BMP image files as compressed or uncompressed. Compressed files are limited to 4 bit 
images. Uncompressed files can be 1, 4, 8, 15, or 24 bits. Select the appropriate option from the BMP Output 
Options dialog.



X Window Bitmap

This file format is used specifically to store screen dumps created by the Unix X Windows system. Many image-
processing and display applications and toolkits read and write XWD format image files. It supports up to 32bit, 
and 64k x 64k pixels. 
The default file extension is XWD.



The Image Window

Any open image is displayed in an Image window. This window can be re-sized and moved around within the 
main window  in any way that you wish. You can apply any executable function directly to an open image and 
view the results on screen. The Image menu commands are available only when there is an active image 
selection.

The Status Bar
The Image window includes a status bar that displays information about the image. Included is the size of the 
image (in pixels), the number of colors, and the magnification level. This status bar appears at the bottom of the 
Image window and can be turned on and off using the View>Status Bar command. The Status Bar is displayed 
when there is a check mark by the menu command.
The Image Controls
The Image window also includes control buttons that you can use to control the display of the red, green, blue, 
and alpha channels of the image. Click these buttons to hide or display the associated channels. Use the log 
button to open and close the image log. 
The Image Palette
If the image has an associated palette, the color table of that palette also appears by default at the bottom of 
the Image window. This image palette can be separated from the Image window and moved around within the 
main window, and re-docked at any edge of the Image window. 
The Video Controls
Image    windows containing multiple-image files (MIFs) also include control buttons that you can use to control 
the display of the image frames. Use these video controls to play the animation sequence, advance to a starting 
or ending marker, or select a range of frames. These controls are identical to those that appear in Movie 
windows.



The Palette Window

Palettes function in DeBabelizer Pro as color tables containing 256 colors or less which can be applied to images 
and movies to manage the color usage of the pixels. Any saved palette can be opened into the main window 
within a Palette window. You can then modify the palette independently, save it  and/or apply it to any image or 
movie.
The Palette menu is always available, however, many of its commands are dimmed unless you have a selected 
palette or palette image. 



The SuperPalette Window

The SuperPalette is a specialized custom palette that you create for a group of images. An open SuperPalette 
appears within the main window    in a    SuperPalette window. When you remap a group of images using one 
SuperPalette, they can be opened and presented together without the need for switching palettes. 
When a SuperPalette window is the selected item in the main window, the SuperPalette menu appears. You can 
use these menu commands to modify the selected SuperPalette. There are also a number of ways you can edit, 
or modify a SuperPalette within the SuperPalette window.



The Movie Window

Movie (.AVI) files are displayed in a Movie window. You can use this window to view and manipulate the primary 
video stream of a movie file. Movies have limited processing functions, which include applying functions from the
Movie menu to the selected movie and playback of the results on screen. You can also generate a BatchList of 
image files from a selected range of frames.
The Video Controls
The Movie window also includes control buttons that you can use to control the display of the frames in a movie. 
Use these video controls to play the movie, advance to a starting or ending marker, or select a range of frames. 
These controls also appear in Image windows containing multiple-image files (MIFs) .



The Script Window

DeBabelizer Pro scripts are lists of command operations that can be applied to a document or group of 
documents. An open script appears within the main window in a Script window. You can edit the script within it’s 
window, as well as apply it to any open image, movie, palette, or BatchList. You can use the Script menu 
commands, which are available whenever a Script window is the selected item in the main window, to modify 
and execute open scripts.



The BatchList Window

BatchList windows provide access to DeBabelizer Pro BatchLists, which are groups of files which can be 
processed together, in order. You can edit any BatchList which is displayed in a BatchList window, as well as 
apply command functions to the whole list or any combination of selected files.
When a BatchList window is the selected item in the main window, the Batch menu appears. This menu includes 
command functions you can use to construct and save BatchLists and create a SuperPalette using the BatchList 
files. These commands are also available when you right-click on an open BatchList window.



The Log Window

Each open image, palette, movie, and BatchList has a log which records every operation executed upon the 
document during the current DeBabelizer Pro session. To view the log of an open image, movie, or palette, click 
on the document to select it, and then select the View>Log command, or click on the log button at the bottom of
an Image window. The Log window appears.
A log is organized as a table, containing information about each function executed upon its associated 
document. Each row of information represents a particular function, or operation. The first column indicates the 
name of the operation, the second column the parameters of the operation, the third column the name of the 
affected document, the fourth column the date and time of the operation execution, and the fifth contains any 
error information generated during the operation execution.
You cannot modify the contents of the Log window. You can, however, copy operations from the Log window and 
paste them to an open Script window. 



Toolbars

Nearly every executable DeBabelizer Pro function has an associated icon which is accessible from one or more 
toolbars. These toolbars are grouped according to their associated command menu or control bar. Clicking on a 
toolbar button is equivalent to selecting its associated menu command. 
Every toolbar can be docked or un-docked and moved around the main window to any location. You can also 
display or hide toolbars by selecting the View>Toolbars… command and using the checkbox controls in the View 
Toolbars dialog.



The DeBabelizer Pro Main Window

As with most Windows applications, DeBabelizer Pro is organized as a program window which provides access to 
all of its functions. This main window contains all the document windows, tools, and menu commands for 
performing advanced graphics processing.
You can have multiple Image windows open at one time, as well as any other DeBabelizer pro document type. 
The number of windows that can be open simultaneously is limited by your system memory. All document 
window can appear minimized or maximized within the main window.
The main window displays a status bar at the bottom, which displays information about the current location of 
the cursor and the properties of the pixel at that location. The status bar displays the current x,y coordinates, 
Alpha value, RGB values, and HSV values of that pixel. If the cursor is currently located over a non-image 
window, the values displayed reflect the last image pixel that the cursor was located. 



The Paint Tools 

The DeBabelizer Pro main window includes a set of basic tools that you can use to select, draw, and zoom on 
images. DeBabelizer Pro    is not designed to be an image editing program; however, these tools are included to 
allow you to perform touch-ups and other minor paint modifications without leaving the application.
The selection and drawing tools are accessible from the Paint Tools toolbar, which appears by default on the right
edge of the main window. You can drag the Paint Tools away from the edge of the main window to make it a 
floating tool box (window), or dock it at any other edge of the main window. You can also hide and display the 
Paint Tools by selecting the View>Toolbars command, or close an un-docked Toolbox by clicking the X button in 
its title bar.
The Selection Marquee is the active tool by default, but you can activate any other tool by clicking on its icon in 
the Paint Tools toolbar. You can then draw or select with the active tool simply by moving the cursor over any 
image in the main window and using a click and drag motion. Other tools included are the magnifying glass, Eye 
Dropper, Pencil, Eraser, and Text tools.
The color swatches at the bottom of the Paint Tools toolbar display the currently selected foreground and 
background colors. The foreground color replaces pixels on an image when you draw with the pencil drawing 
tool. Both the foreground and background color are used in a number of image modification functions.
To change the currently selected foreground color, you can click on the eyedropper tool and move it over an 
image and click on the desired color, or double-click on the foreground color swatch to open the Foreground and 
Background Colors dialog.
To change the currently selected background color, you can click on the Eye Dropper tool and move it over an 
image and hold down the Alt key while clicking on the desired color, or double-click on the background color 
swatch to open the Foreground and Background Colors dialog.



The Selection Marquee

Use this tool to select an area on an image by drawing a rectangle. When this tool is active, the cursor becomes 
a cross-hair when moved over the image. Hold the left mouse button down and drag diagonally to select the 
area. You can perform nearly any DeBabelizer Pro operation on the selected area. 
To maintain the current aspect ratio of the marquee, hold down the Shift key while re-sizing the selection. You 
can    modify the boundaries of the Selection Marquee by placing the tool over the edge of the marquee frame 
and dragging left, right, up, or down. 



Magnifying Glass

Use this tool to change the magnification of an image, centering on a specified point on the image. When this 
tool is active, the cursor becomes a magnifying glass when moved over the image. To zoom in on an area, click 
on the spot. To zoom out on an area, hold the Alt key down and click on the spot. 
You can zoom in or out multiple times to achieve the desired level of magnification. The magnification index 
appears in the status bar of the Image window. To reset the image to its original magnification, select the 
View>Zoom>1x command. You can also select one of the other pre-set magnification levels from the 
View>Zoom submenu.



Eye Dropper

Use this tool to select a foreground (or background) color directly from an image. The selected color appears in 
the foreground or background color swatch in the Paint Tools toolbar. When this tool is active, the cursor 
becomes an eye dropper when moved over the image. To select a color on the image, click on a pixel of the 
desired color. 
To activate the Eye Dropper tool when using the pencil tool, hold down the Alt key. The cursor becomes an Eye 
Dropper and you can then click on another color pixel to change the foreground, or drawing color. Press the Alt 
key again to return the cursor to the Pencil tool.



Pencil

Use this tool to replace pixels on the image with the selected foreground color. When this tool is active, the 
cursor becomes a pencil when moved over the image. Hold the left mouse button down and drag the tool over 
the desired pixel(s). 
You can change the selected foreground, or drawing, color by holding the Alt key down. When this key is down 
the cursor changes to the Eye Dropper  tool. Click on a pixel in the image and the foreground color changes to 
the selected pixel color. Press the Alt key again to return to the Pencil tool and continue drawing.



Text

Use this tool to access the Text Overlay dialog and place text on the selected image. You can also open the Text 
Overlay dialog by selecting the Tools>Text Overlay… command.



Eraser

Use this tool to replace pixels on the image with the selected background color. When this tool is active, the 
cursor becomes a square when moved over the image, and covers an area 15 pixels high and 15 pixels wide. 
Hold the left mouse button down and drag the tool over the desired pixel(s).



Program Preferences

Many of DeBabelizer Pro's functions have specific preferences and options which you can modify to your 
specifications. Program, or global, preferences affect many functions throughout the program. To access and 
modify program preference settings, select the File>Prefences>Set Preferences… command.
The Preferences dialog contains Directories, Undo, Frame Counter, Palette, Palette Bar, Background color, 
Foreground color, and Dithering preference options. 



Directories Preferences

Directory preference options allow you to specify default directories for each DeBabelizer Pro file type. Click the 
Directories tab in the Preferences dialog to access these preference options. 
Use the Browse... button to navigate your system and locate the desired directory. Select the folder and click OK;
the directory name and the path name of that folder appears in the designated directory field. You can also 
manually enter the desired path name.
You can specify a default directory for each of the following file types, or documents:
n Images
n Movies
n Palettes
n SuperPalettes
n BatchLists
n Scripts
You can also designate a default directory for third party Photoshop plug-ins. Select the directory where you have
installed plug-ins. DeBabelizer Pro references the designated Plug-ins directory when you select the Tools>Filters,
File>Import, and File>export commands, as well as from the Filter Interpolate dialog.
Also included in the Directories preferences is an option that you can use to designate your favorite image editor.
Enter the name of the application in the Name field, and enter the executable file name in the Executable field. 
You can then access the selected application from the Tools menu.



Palette Preferences

Click the Palette tab in the Preferences dialog to access palette preference options. These    options affect the 
way that DeBabelizer Pro performs color reduction and remaps images and movies to a palette or SuperPalette. 
The settings that you choose affect the quality of the color reduction as well as the speed at which your systems 
performs these operations. 
n Use the RGB polling setting to select a maximum number of RGB colors to track. The recommended setting is 

4096.
n Use the Reduction Threshold setting to specify the lower threshold for the color reduction. The recommended 

value is .0001.
n Use the Bits per Gun setting to control the gun level when reducing images. The recommended setting is 8 

bits. You should only use a lower number if you are reducing colors for output to a specialized device that 
supports a lower number.

n Use the Color Selection Bias option to specify the color selection bias that DeBabelizer Pro use to select the 
colors for a reduced palette.



Frame Counter Preferences

Click the Frame Counter tab in the Preferences dialog to access frame counter preference options. These options 
allow you to set the current value for the filter interpolate frame counter and select options for automatically 
resetting the frame counter value during automated processing. 
To set the frame counter value to a specified number, enter the desired value in the Current frame counter field. 
(The default value is 0.)
To automatically set the current frame counter to one at the start of each process, select the first checkbox. And 
to add one to the frame counter after applying a filer, select the second checkbox option.



Dithering Options Preferences

Click the Dithering Options tab in the Preferences dialog to access dithering preference options. Dithering is a 
useful feature when performing color reductions and converting images or movies to black and white or 
grayscale. This function diffuses adjacent pixels to represent colors which are not actually in the image or movie,
resulting in a closer representation of the original color balance.
DeBabelizer Pro dithers an image or movie according to the Dithering Options settings, which are retained until 
you change them. To change the Dithering Options settings:
1 Adjust the Dithering Amount setting. (The default value is 87%).
2 Select a Dithering Method Select either Diffusion or Albie.
3 Select the Don’t Dither Background color option, if desired. This option prevents changes to the pixels using 

the currently selected background color.
4 Click OK.



Background and Foreground Color Preferences

The current background and foreground color can be set from a number of places within DeBabelizer Pro. These 
colors are program preferences and affect a number of different operations. 
Click the Background Color or Foreground Color tab in the Preferences dialog to access background and 
foreground color options. There are two ways to specify a new background or foreground color from the 
Preferences dialog.
n Use the RGB color value option to define the color using RBG/HSV values. If you are executing an operation on 

a palette image or palette movie which does not contain the specified color, DeBabelizer Pro finds the closest 
color in the palette and uses that as the background or foreground color.

n Use the Palette index option (if there is a currently selected palette image, palette movie, or stand-alone 
palette) to define the background or foreground using a palette index value. If you are executing an operation 
a RGB image, DeBabelizer pro uses the RGB values of the color corresponding to the originally selected index 
value.



Undo Preferences

Click the Undo tab in the Preferences dialog to access undo (and redo) preference options. These preference 
settings control the way that the Undo function operates in DeBabelizer Pro. Click the Undo tab to access the 
undo preference options. 
Undo Amount 
Use the this option to designate the number of image operations DeBabelizer Pro can reverse (and un-reverse). 
This function requires that DeBabelizer Pro create temporary files as you work; the higher the number, the more 
memory that required to store the operation and image information. You may want to experiment with this 
setting to find what works best for you and your system. If you are running low on memory, you may want to 
reduce this number or turn this setting off (enter a 0).
File Location
Use these option settings to specify how DeBabelizer Pro stores temporary files created for the Undo function. By
default, DeBabelizer Pro stores these files on the local drive with the most available space.



Palette Bar Preferences

Click the Palette Bar tab in the Preferences dialog to access palette bar preference options. These preference 
settings control the way that the image palette is sized within an Image window.    Use the size options to change
the width and height of each color bar in the palette. You can also select the Show Indexes option to display the 
index value of each color bar.



View Toolbar Preferences

Click the View Toolbars tab in the Preferences dialog to access toolbar preference options. These preference 
settings control the display of the DeBabelizer Pro toolbars. Use the checkbox controls to display or hide 
toolbars.



Original Preferences Settings

At any time, you can reset all program preferences to their original default settings. The original settings are 
those that were active the first time that DeBabelizer Pro was launched. To reset program preferences to their 
original settings, select the File>Preferences>Factory Defaults command. This overrides all previous preference 
settings and returns them to their original selections.



Printing

You can print the contents of any Image, Palette, Log or Script    window that is open in the DeBabelizer Pro main 
window. There are three methods of executing a print function for a selected document:
n Select the Print... command (Ctrl + P) and use the Print dialog.
n Click the Print toolbar button.
n Create a print file, and then download the file to a printer.
Each of these actions opens the Print dialog. Use the Print dialog to set print options. If you are printing the 
contents of a Log window, the Print Log Options dialog appears, prompting you to set the print parameters for 
the selected log.
Select the File Print>Print Setup… command to open the Print Setup dialog to select an installed printer and set 
printer options. 
You can also automate the printing of a specified group of source files using the Batch Automation>Print 
command.



Print Log Options

If a Log window is the selected item when you execute the print function, the Print Log dialog appears. Use the 
checkbox controls to turn options on or off for printing each of the log columns and the column headings. Select 
the Send to default printer option to automatically print the log information from the current default printer. You 
can also designate a font size by specifying how many characters are printed across the page.



Print Options

You can use the Print dialog to modify print options settings and print the currently selected image from a printer
loaded on your system. To open the Print dialog, select the File>Print... command, click the Print toolbar button, 
or press Ctrl + P. 
The Print dialog is a standard Windows 95/NT print dialog. You can select an installed printer from the Printer 
Name drop-down list, select a range of pages to print, and specify the number of copies.
You can install or add a printer to your system using the Add Printer function, located in the Windows Control 
Panel. For more information about adding a printer to your system, consult the Windows 95/NT User Guide or 
your printer's reference manual.
To set options specific to the selected printer, click the Properties button. The options depend upon the printer 
and print setup option settings you have selected. 
Select the Print to File option to print the selected image to a file.



Printing to a File

You can print an image to a file by selecting the Print to file checkbox in the Print dialog. When this option is 
selected and you click OK from the Print dialog, the Print to File dialog appears.
Use the dialog to specify a file name and destination. The default file extension is .PRN. DeBabelizer Pro uses the
driver for the printer selected in the Print dialog. If the selected printer uses a PostScript driver, the Print to File 
function creates a PostScript file which can be downloaded to nearly any PostScript output device. It is a good 
idea, however, to experiment with drivers in order to achieve the desired results. 
Print files are useful if you are generating files for slide or high resolution output at a service bureau, or if you are
creating file for export to another application.



Print Setup Options

Use the Print Setup options to specify the default printer, paper size, source, and orientation as well as specify a 
saved script to be executed before an image prints. DeBabelizer Pro uses these option settings when printing 
images. You can also access the Properties option for the selected printer.
The available paper size and source settings depend upon the selected printer. When you add a printer to your 
system. Windows defines the parameters of that printer. Option settings available in the Print Setup and printer 
specific Properties dialogs depend upon the defined parameters.
If you print a color image using a monochrome, or black and white, printer, the image prints as an emulated 
grayscale image. Monochrome printers emulate a grayscale using dithering, and the quality of the output 
depends upon how well the printer can produce the emulation.
You do not need to set these options each time you print. Use the Print Setup dialog only if you want to change 
the default printer and change the paper size or orientation. 



Diffusion

This dithering method is based upon the Floyd-Steinberg method of diffusing colors into varying patterns and 
creates the appearance of more than one level of brightness.



Albie

This dithering method is based upon the Albie algorithm and results in dithering patterns with a higher contrast.




