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Getting Started

Beta Testing 

Like all McNeel products, we developed Rhino™ to serve your wants, needs, and expectations. 
We're idiots when it comes to reading your mind. We need your help. Rhino's great technology 
will only be useful if we can get everything right. Your feedback can guide us to that goal. 

When you're using Rhino, please keep the bug/comment report form open. That way you can 
send a steady stream of ideas, bugs, comments, and threat of bodily harm while you're working 
with Rhino. Don't be bashful. 

Also, let us know what works well. Otherwise, we may make foolish improvements. 

Bug Report 

To report bugs, use the Rhino Newsgroup, alt.3d.rhino, or use our Feedback Form. 

E-mail 

We will notify you via e-mail each time a new beta release is posted, if you add your e-mail 
address to the Rhino Update Mailing List. 



Software Expiration 

The Rhino beta software expires April 1, 1997. 

Send Models 

Are you proud of a model you made in Rhino? Upload an image or model, description, and 
credits. It may appear as an illustration in the user's guide. 

Before You Start 

Print this manual. 
Read the rest of the Getting Started section of this manual. We haven't done a great job of 
making it obvious how to use Rhino yet. 

(Who knows? It may never be easy to take advantage of a rhinoceros.) 

Setup

To set up Rhino 

1.Download Rhino. If you haven't done so yet.
2.Click Run from the Start button.
3.Type rhino32. Include your drive and directory designation as necessary.
4.Click OK.
5.Follow the instructions on the screen. 



Using Rhino

Rhino's interface includes menus, a command line, and customizable button toolboxes. 

Command Line 

Prompts and messages are displayed on the command line. You can type commands, 
coordinates, distances, angles, and drawing aid shortcuts on the command line. After typing, 
press ENTER or SPACEBAR to execute. 

To repeat the last command, press ENTER or SPACEBAR. 

Toolboxes 

Rhino has toolboxes containing customizable command buttons. Each command button has two 
functions, one for the left mouse button and one for the right mouse button. The tooltips separate
the function descriptions with a vertical line. 

Buttons with a white spot in the corner cascade additional toolboxes. Hold down a mouse button
over the button to cascade the linked toolbox. 

To open additional toolboxes, click Assist>Toolboxes. 

Workspaces 

You can save any arrangement of toolboxes as a named workspace by clicking 
Assist>Workspace>Save. 

Buttons 

You can customize buttons as follows: 

· To move a button, hold down the SHIFT key and drag with the left mouse button.
· To copy a button, hold down the CTRL key and drag with the left mouse button.
· To edit a button properties, hold down the SHIFT key and click with the right mouse button.
· To link a toolbox to another toolbox, hold down the CTRL key and drag with the right 

mouse button. 

Viewports



With Rhino you can open an unlimited number of viewports. Each viewport has its own 
projection, view, construction plane, and grid. A viewport becomes active when you move the 
mouse over it. 

Parallel vs. Perspective Projection 

Unlike other modelers, Rhino lets you work in both parallel and perspective views. To toggle a 
viewport between parallel and perspective, click View>Projection. 

Pan and Zoom 

Use the right mouse button to pan or zoom when you are not in another command. 

· To rotate in a perspective view, drag with the right mouse button.
· To pan in a parallel projection view, drag with right mouse button.
· To pan in perspective view, hold down the SHIFT key and drag with the right mouse button.
· To zoom in or out, hold down the CTRL key and drag up or down with the right mouse 

button. 

Use keys to change your view any time, even in the middle of a command. 

Key Action + CTRL Key
Left Rotate left Pan left
Right Rotate right Pan right
Up Rotate up Pan up
Down Rotate down Pan down
Page Up Zoom in
Page Down Zoom out

Defined Views 

To use previously defined views or save and restore your own named views, click 
View>Defined Views. 

Lost In Space? 



If you get lost in a viewport: 

· Type plan and press ENTER to set your view looking down on the construction plane. 
· Type ZE and press ENTER to bring all your objects into view. 

If you get really lost: 

· Type 3view and press ENTER to reset the viewport configuration.
· Type ZEA and press ENTER to bring all your objects into view in all viewports. 



Entering Coordinates

When prompted for a point, you can click on a viewport's construction plane or type in 
coordinates at the command prompt. 

Typing Exact Coordinates 

When prompted for a point, you can enter the x-, y- and z-coordinates of the point you want. 
Each coordinate indicates a distance along the active viewport's construction plane axis from its 
origin. Type the coordinates in the format: x,y,z. For example, if you want a point at the origin, 
type 0,0,0 and press ENTER. The z-coordinate is optional. 

To enter coordinates relative to the previous point, enter the coordinates in the format: @x,y. 
For example, to enter a point 2 units in the x-direction and 3 units in the y-direction from the last
point entered, type @2,3 and press ENTER. 

You can also enter polar coordinates. Polar coordinates refer to distance and direction. To enter 
absolute polar coordinates, enter the coordinates in the format: d<a, where d is the distance and 
a is the angle. For example, if you want a point four units away from the construction plane 
origin, at a 45° angle from the construction plane x-axis, type 4<45 and press ENTER. 

To enter relative polar coordinates, enter the coordinates in the format: @d<a, where d is the 
distance and a is the angle. For example, to enter a point four units away from the last point 
entered, at a 45° angle from the construction plane x-axis, type @4<45 and press ENTER. 

Other Methods of Entering Points 

· You can type a number at a prompt to enter a distance, press ENTER, and then enter a point 
to show the direction.

· Elevator mode lets you move off the construction plane. To try elevator mode, draw a 
multiple segment line in a perspective view. Place a few points, then press SHIFT and place 
a point, the cursor now drags off the construction plane. 



Selecting Objects

Click an object to select it. To select additional objects, hold down SHIFT and click them. To 
deselect an object, hold down SHIFT and click it again. 

You can also select with a rectangular window: 

· To select objects completely enclosed in the rectangle, drag the mouse diagonally from left 
to right.

· To select objects lying inside or partially inside the rectangle, drag the mouse diagonally 
from right to left. 

To edit the shape of a curve or surface you need to be able to select control points. 

· To turn on the control points of selected objects, click Edit>Select>Points.
· To turn off control points, click Edit>Select>Entire Objects 

Note: Some commands work on objects you select after starting the command; some commands 
work on objects selected before starting the command. We'll fix this. 



Modeling Aids

Construction Plane 

Each viewport has a construction plane with its own x-, y- and z-axes, which can be different 
from another viewport's x-, y- and z-axes. To change a viewport's construction plane, click 
View>Set Construction Plane. 

The cursor always tracks on the viewport's construction plane. If you want to enter points not on 
the construction plane, you can use object snaps, elevator mode, or type x-, y-, and z-coordinates
at the command line. 

Grid 

The grid is a visual representation of the construction plane. The red grid line is the x-axis and 
the green line is the y-axis. The construction plane origin is where the red and green lines meet. 

Grid Snap 

Grid snap restricts point input to points where grid lines intersect. To turn grid snap on and off, 
click Assist>Grid Snap or the Grid Snap command button, or type S and press ENTER. 

Ortho 

Ortho moves the cursor at a specified angle (the default is 90 degrees) from the last point 
created. To turn ortho on and off, click Assist>Ortho or the Ortho command button, or type O 
and press ENTER. 

Object Snaps 

Object Snaps (for example, endpoint, midpoint, center, knot) locate exact positions on objects. 
When an object snap is active, moving the cursor near a specified point on an object causes the 
cursor target to jump to that point. To use an object snap, click Assist>Object Snap or a button 
in the Object Snap toolbox. 



Layers 

You can create an unlimited number of layers. The current layer is assigned to each object as it's 
created. Click Assist>Layers to create or delete layers, change layer properties, set a layer as 
current, or toggle layer visibility. 

Tutorial

Play around with Rhino a bit before starting the tutorial. Some commands are reasonably self-
explanatory. Try some of the following: 

· Draw some curves and surfaces by placing points and sketching. Follow the prompts on the 
command line.

· Use the Undo command.
· Click in different viewports to see how you can easily create 3-D objects using different 

construction planes.
· Draw some solid objects from the Solid menu.
· Click an object, hold down the left mouse button and drag to move it.
· Use object snaps to snap to points on existing objects.
· Change the view with the right mouse button and the arrow keys. Use the CTRL key 

modifiers.
· Practice selecting and deselecting objects and points. Try the rectangular selection methods.
· Press F2 to view the history screen. 

The Examples 

The following examples will help you understand some Rhino concepts and help clarify some of
the differences between the various commands. 

Layer colors are used to highlight the new objects. Click Render>Quick Render to see the 
shaded results. 



Surface from Side Curves

Creates a surface from three or four side curves that form a closed loop. 

To create a surface from side curves: 

1.Open the file SIDECRV.3DM.
2.Click Surface>3 or 4 curves.
3.At Choose 3 or 4 edge curves:, select the four curves C1, C2, C3, and C4. 
   Rhino creates a surface using the curves to define the edges. 

Try on your own 

· Click Render>Quick Render to see a shaded view of the surface. 



Revolved Surface

Creates a surface by revolving a shape curve about an axis. The resulting object can be either an 
open surface or a closed solid depending on whether or not the shape curve is open or closed and
how far you revolve it. In this example, both endpoints of the shape curve intersect the axis of 
revolution, so Revolve creates a solid. 

To create a revolved surface: 

1. Open the file REVOLVE.3DM.
2. Click Surface>Revolve.
3. At Choose an object:, select the shape curve.
4. At First axis point:, select axis point 1.

(Use the endpoint object snap.)
5. At Second axis point:, select axis point 2.

(Use the endpoint object snap.)
6. At Start angle:, press ENTER.
7. At End angle:, press ENTER.

The Delete Input Objects message box appears.
8. Click Yes.

Rhino creates the revolved surface.



Try on your own 

•Click Edit>Undo and make the surface again with different start and end angles. 

Extrude Perpendicular to the Construction Plane

Creates a surface from a curve perpendicular to the construction plane. 

To extrude a curve perpendicular to the construction plane: 



1. Open the file EXTRUDE.3DM.
2. Click Surface>Extrude from curve>Straight.
3. At Choose a curve or face to extrude:, select curve 1.
4. At Choose a point:, pick a base point on a construction plane perpendicular to the direction 

you would like to extrude.
5. At the next Choose a point:, type a number of units to extrude the curve. 

To create a surface similar to the example, type 1 and press ENTER.

Try on your own 

· Click Edit>Undo 
· Extrude the same curve, but this time enter the extrude distance by clicking two points. 



Extrude Along a Path Curve

Creates a surface from a curve following a path curve. 

To extrude a curve along a path curve: 

1. Click Surface>Extrude from curve>Along a curve.
2. At Choose the shape curve:, select Curve 2.
3. At Choose the path curve:, select the path curve. 



Sweep a Surface Along a Path

Creates an open surface with cross sections that maintain the initial orientation of the shape 
curve(s) to the path curve. Note the difference between the surface created with this command 
and with Extrude using the same path curve. 

To create a sweep along a path: 

1. Open the file 1RAIL.3DM.
2. Click Surface>Sweep Along Path.
3. At Select shape curve near start:, select the shape curve.
4. At Select closed curve:, press ENTER.

You will sweep only one curve in this case.
5. At Select rail curve:, select the rail curve.
6. At Sweeping options:, press ENTER.

The Delete Input Objects message box appears.
7. Click Yes.

Rhino creates the swept surface.



Ruled Surface from Shape Curves

Creates surfaces with ruled (straight) edges by drawing straight lines through the endpoints of 
each shape curve. Contrast this with the edges created using Loft Curves, which creates a smooth
spline curve through the endpoints of the shape curves. 

To create a ruled surface: 

1. Open the file RULE.3DM.
2. Click Surface>Ruled.
3. At Select shape curve near start:, select the first curve near point C1.
4. At the next Select shape curve near start:, select the second curve near point C2.
5. At the next Select shape curve near start:, select the third curve near point C3.
6. At the next Select shape curve near start:, select the fourth curve near point C4.
7. At the next Select shape curve near start:, press ENTER.
8. At Ruled surface options:, press ENTER.

The Delete Input Objects message box appears.
9. Click Yes.

Rhino creates the ruled surface.



Lofted Surface from Shape Curves

Creates a smooth surface that blends between the selected shape curves. This surface looks 
similar to the 2-Rail Sweep example, but does not need the rail curves. Instead, the edges of the 
surface are created by fitting a smooth curve through the endpoints of the shape curves. 

To create a lofted surface: 

1. Open the file LOFT.3DM.
2. Click Surface>Loft curves.
3. At Select shape curve near start:, select the first shape curve near point C1.
4. At the next Select shape curve near start:, select the second shape curve near point C2.
5. At the next Select shape curve near start:, select the third shape curve near point C3.
6. At the next Select shape curve near start:, press ENTER.
7. At Lofted surface options:, press ENTER.

The Delete Input Objects message box appears.
8. Click Yes.

Rhino creates the lofted surface.



Try on your own 

· Click Edit>Undo and make a ruled surface using the same curves.
· Click Render>Quick Render to see the model shaded. 



Sweep Along 2 Rails

Creates a smooth surface through two or more shape curves that follow two curve rails. Use this 
command when you want to control the location of the edges of the surface. 

To create a two-rail sweep: 

1. Open the file 2RAIL.3DM.
2. Click Surface>Sweep 2 rails.
3. At Select shape curve:, select shape curve 1.
4. At the next Select shape curve:, select shape curve 2.
5. At the next Select shape curve:, press ENTER.
6. At Select rail curve:, select rail 1.
7. At the next Select rail curve:, select rail 2.
8. At Sweeping options:, press ENTER.

The Delete Input Objects message box appears.
9. Click Yes.

Rhino creates the 2-rail sweep surface.



Reshape Curves

You can edit Rhino curves by moving control points located on the curve or control points. 

To edit a curve through the control points: 

1. Open the file CURVES1.3DM.
2. Click the red curve to select it.
3. Click Curve>Edit Tools>Show Control Points.
4. Drag the points to reshape the curve.
5. To turn the points off, click Edit>Select>Entire Objects. 

Try on your own 

· You can also move points that lie on a curve. Click Curve>Edit Tools>Show Greville 
Points.

· Try moving the points in different viewports. 



Trim Curves

The Trim command trims a curve with another object. 

To trim a curve: 

1. Open the file TRIMCRV.3DM.
2. Click Edit>Trim.
3. At Choose cutting edge(s):, select curve 1.
4. At the next Choose cutting edge(s):, press ENTER.
5. At Choose object to trim:, select curve 2.

Select the curve at the end you want to trim off. You can perform this operation on multiple 
curves.

6. Press ENTER to end the command.



Aligning Curves to Other Geometry

Moves, scales, and rotates a curve to orient it with a desired piece of geometry. 

To move, scale, and rotate a curve: 

1. Open the file ALIGN.3DM.
2. Click curve A to select it.
3. Click Transform>Align.
4. At Choose a point:, use endpoint snap to pick point P1.
5. At the next Choose a point:, use endpoint snap to pick point P2.
6. At the next Choose a point:, use endpoint snap to pick point P3.
7. At the next Choose a point:, use endpoint snap to pick point P4.

The curve moves and fits to the new end points.
8. Try the command again.

This time align Curve B using points P5, P6, P7, and P8. 

Split a Surface



Split can cut any curve or surface with any combination of curves, surfaces, and solid objects or 
a curve at a point. In this example, a solid cylinder, a partial solid, and a curve are used in one 
operation to split the surface. 

To create a split surface: 

1. Open the file SPLIT.3DM.
2. Click Edit>Split.
3. At Object to split:, select the surface.
4. At Choose cutting objects:, select cutting object 1 (solid cylinder).
5. At the next Choose cutting objects:, select cutting object 2 (partial solid).
6. At the next Choose cutting objects:, select cutting object 3 (curve).
7. At the next Choose cutting objects:, press ENTER.

Rhino cuts the surface with all the cutting objects. You must delete the parts you don't want.
8. Delete the cutting surfaces and split parts as shown. 

     



Editing with Booleans

Boolean operations are a quick way of combining and subtracting parts. You can use Boolean 
operations with both solids and open surfaces. In the following exercises you will use the three 
Boolean operations on both solids and open surfaces. The cube and pyramid are both solid, 
while the plane and cylinder are open surfaces. 

To add two solids: 

1. Open the file BOOLEAN.3DM.
2. Click Solid>Add.
3. At Select first object:, select the cube.
4. At Select second object:, select the pyramid.
5. Click Edit>Undo to return the objects to their original state so you can try the next 

operation. 

To add two surfaces: 

1. Try this again using the surfaces.
2. Click Edit>Undo to return the objects to their original state. 



To subtract the pyramid from the cube: 

1. Click Solid>Subtract.
2. At Select first object:, select the cube.

With Subtract, the result depends on the order the objects are selected.
3. At Select second object:, select the pyramid.

Result = cube - pyramid.
4. Click Edit>Undo to return the objects to their original state. 

To subtract the cone from the plane: 

1. Try this again using the surfaces. Select the plane first.
2. Click Edit>Undo to return the objects to their original state. 

To subtract the cube from the pyramid: 

1. Click Solid>Subtract.



2. At Select first object:, select the pyramid.
3. At Select second object:, select the cube.

Result = pyramid - cube.
4. Click Edit>Undo to return the objects to their original state. 

To subtract the plane from the cone: 

1. Try this again using the surfaces. Select the cone first.
2. Click Edit>Undo to return the objects to their original state. 

To intersect two solids: 

1. Click Solid>Intersection.
2. At Select first object:, select the cube.
3. At Select second object:, select the pyramid. 

To intersect two surfaces: 

· Try this again using the surfaces.
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