
PFW Scenario Assembler Help Index

Help is available in the following areas:

Assembler Commands

Procedures for Creating a PFW Scenario

Symbols that Appear on the Map



Commands

To get help with a particular command, choose the appropriate menu.

File Menu Commands
New...
Open...
Save
Save As...
Create .PKS File...
Exit

Edit Menu Commands
Cut
Copy
Paste
Rotate Map Section
Mirror Map Segment Horizontally
Mirror Map Segment Vertically

Segments, More Segments, and Coastline Segments Menus

Map Menu Commands
Edit Setup Areas...
Show All Setup Areas

Teams Menu Commands
Rename First Team...
Setup First Team...
Rename Second Team...
Setup Second Team...

Other Items Menu Commands
Set Scenario Name...
Set Scenario Author...
Set Scenario Visibility...
Set Scenario Time Limit...
Edit Scenario Description...
Edit Tactical Advice...



New

This option allows you to start assembling a new scenario.    You'll be prompted for the size of
the scenario map in terms of map segments.



Open...

This option allows you to open an assembly file you previously saved.    You can then 
continue to work on that scenario.



Save

This option allows you to save your current work in an assembly file.    You can then come 
back and continue work on this scenario later.



Save As

This option allows you to specify an assembly file to save your current work in.    You can 
then come back and continue work on this scenario later.



Create .PKS File...

This option allows you to generate a scenario file (.PKS) that can be loaded by Panzerkrieg 
for Windows and played.



Exit 

This option allows you to exit the PFW Scenario Assembler.



Cut

You can remove a map segment you have previously placed on the board by clicking on that 
board area and picking Cut.    The board area is cleared, and a copy of the map segment 
there (including any mirroring or rotations you have applied) is saved in the Paste buffer.



Copy

You can save a copy of a map segment you have previously placed on the board by clicking 
on that board area and picking Copy.    The map segment (including any mirroring or 
rotations you have applied) is saved in the Paste buffer.



Paste

If you have previously placed a map segment in the Paste buffer by using the Cut or Copy 
commands, you can then place that segment on the board by clicking on the board and 
picking Paste.



Rotate Map Segment

You can apply transformations to the map segments you place on the game board.    To apply
a transformation, click on the game board segment you want to transform, and then choose 
the transformation you want from the Edit menu.

The Rotate Map Segment transformation rotates the map segment 180 degrees.



Mirror Map Segment Horizontally

You can apply transformations to the map segments you place on the game board.    To apply
a transformation, click on the game board segment you want to transform, and then choose 
the transformation you want from the Edit menu.

The Mirror Map Segment Horizontally transformation flips the map segment around the 
Y-axis.



Mirror Map Segment Vertically

You can apply transformations to the map segments you place on the game board.    To apply
a transformation, click on the game board segment you want to transform, and then choose 
the transformation you want from the Edit menu.

The Mirror Map Segment Vertically transformation flips the map segment around the X-
axis.



Map Segments

The scenario assembler comes with a number of map segments to choose from.    To 
assemble a scenario map, you choose from the available segments and place these 
segments on your game board.

To place a segment, you first choose the segment you wish to place from the Map 
Segments, More Map Segments, or Coastline Map Segments menus.    You then 
double-click on the board in the location you wish to have that segment placed.

The map segments available on the Map Segments and More Map Segments menus can
be used anywhere on a map.    No matter what order you use them in, the terrain features on
them will line up correctly.

The map segments available on the Coastline Segments menu have one restriction placed
upon them:    Only coastline segments should be placed adjacent to each other horizontally.   
The assembler does not enforce this restriction, but you should follow it in order to create a 
map that makes logical sense.



Edit Setup Areas...

This option allows you to manage the setup areas you create for unit deployment.    You can 
create and delete areas, and assign them meaningful names.    (Examples:    German Rescue 
Force Deployment Area, American Depot Area.)    You can also review units assigned to these
setup areas.



Show All Setup Areas

This option can be toggled on and off.    If it is on, setup areas you have defined on the map 
are always displayed in the PFW Scenario Assembler.    This is the default setting.    If this 
option is off, the areas are not displayed.



Rename Team

This option is used to assign an appropriate name to each team.



Setup Team

This option is used to assign the units each team will be able to employ.

The first step here is to choose which units will be assigned to the team.    Click on the Add 
button to see a list of units that you can choose from.    If you click on a unit in this list, the 
unit characteristics will be displayed.    Double-clicking on a unit in the list adds that unit to 
the current team.    When you are done adding units to this team, click Done.

Each team may have a maximum of 40 units assigned.

After you have chosen the units for this team, you must assign each to a setup area.    Click 
on the unit name, and then double-click on the setup area you want it assigned to.    A check 
mark will appear next to the unit name when it has been assigned to a setup area.

You may also designate units to employ indirect fire.    If a unit is capable of indirect fire the 
check box below the unit name will become active.    Check this box to enable indirect fire for
that unit.    Note:    There must be a Forward Observer assigned to the team for the indirect 
fire selection to have any effect.



Set Scenario Name

This option allows you to assign a name to your scenario.    This name will be the title of your
scenario.



Set Scenario Author

This option allows you to record your name as the author of this scenario.



Set Scenario Visibility

This option allows you to specify the sighting ranges permitted in the scenario.    

You need to set two visibility ranges:    Long Range and Short Range.

Long Range visibility represents the distance at which a unit can first determine an enemy 
unit is present.    If an enemy unit is within long range it will be visible to your unit as an .

Short Range visibility represents the distance at which a unit can first see an enemy unit 
clearly.    If an enemy unit is within short range it will be clearly visible to you.

Use larger ranges to represent good visibility.    Smaller ranges are suitable to represent 
night or bad weather.



Set Scenario Time Limit

This option allows you to set a time limit for the players to achieve their game objectives.    A
time limit is optional.    If no time limit is supplied, play continues at the players discretion.

Remember the time limit specifies game time (turns), not time on the clock.



Edit Scenario Description

This option allows you to write the text description of your scenario.

The description is one of the most important parts of your scenario.    It should convey to the 
players the background of the scenario (how the tactical situation came about) and the 
objectives (victory conditions) for each team.



Edit Tactical Advice

This option allows you to write tactical advice for the players of your scenario.

This advice might include several alternative courses of action for each of the players.    
Combat is a complex business, and many players (especially novice players) can benefit 
from your suggestions.

While you're not required to supply advice, do remember that many players will enjoy your 
scenario more if your supply some guidance for their first few games.



Procedures

To get help with a particular procedure, choose the appropriate menu.

Assembling the Map
Defining Setup Areas
Assigning Units to Teams
Miscellaneous Options
Create the Scenario File



Assembling the Map

The first step in assembling a scenario is to create the map the scenario will be played on.    
A new map is begun by selecting New... from the File menu.

The size of the map is defined by the number of map segments it supports.    PFW supports 
map up to 4 segments wide and 8 segments high.    This represents an area approximately 
16 Km by 8 Km.    That is a very large area to effectively manage for the players.    It is 
suggested that you first try creating scenarios that are 2 by 2 or 2 by 3.    While this seems 
small, experience shows this to be a good size for PFW scenarios.

Once the map size has been chosen the next step is to assemble the map segments on the 
board.    Browse the segments available, and place them on the board where desired.    
Segments are placed by selecting them from their menu, and then double-clicking on the 
board where you want the segment placed.    Once a segment is placed it may be rotated or 
mirrored using the options from the Edit menu.

Map sections, with the exception of the Coastline Segments, may be placed in any order.   
You should be sure that Coastline Segments only abut other Coastline Segments 
horizontally.



Defining Setup Areas

You need to specify areas on the map in which the players will be allowed to initially position 
their units.    There might be as few as two setup areas - one for each team.

More complex scenarios may require additional setup areas.    For example, one team may 
have a setup area for the main force and a second area for the relief force.

To create a setup area, choose Edit Setup Areas... from the Setup Areas menu.    You're 
presented with a list of existing areas.    Click on the Create button to add a new area.    You 
then specify the area by moving the cursor over the map to one corner of the area, pressing 
and holding the left mouse button, dragging the cursor to the opposite corner of the area, 
and releasing the mouse button.    You can then delete the area if you're not satisfied with 
the position, or rename it to something appropriate (such as "Relief Force Area").



Assigning Units to Teams

Once the map and setup areas are defined you should select the units for each team.    You 
place units on teams using the Teams menu.

When you choose one of the Setup options you'll see a list of units assigned to that team.    
Click on the Add button to add units to a team.

You can choose from the 150 units available.    Clicking once on these units will display some 
statistics describing that unit.    Double-click on the unit to assign it to the team.    Click Done
when you're finished adding units.

Each team can have a maximum of 40 units assigned to it.    Most of the time you will have 
many fewer units.    Experience has shown that the best scenarios have from 10 to 15 units 
on each team.

Each unit must be assigned to a setup area.    To make these assignments, click on the unit 
name, and then double-click on the setup area you want it assigned to.    A check mark will 
be placed next to the unit name once it has been assigned to a setup area.

Indirect fire capability can be enabled for the appropriate units.    Use the check box to 
enable this feature.    Note that you must add one or more Forward Observer units to a team 
for the indirect fire setting to have any effect.



Miscellaneous Options

Be sure to visit all of the options on the Other Items menu.    Setting these is important for 
the scenario.

Perhaps the most important is writing a good Scenario Description.    This description should 
give the players context for the engagement and clearly spell out victory conditions.

Also important is writing tactical advice for novice players.    Novices can frequently be 
overwhelmed by the possibilites.    Some sound tactical hints can help them get the most 
from your scenario.



Create the Scenario File

The PFW Assembler works with assembly files.    When you're satisfied with the scenario 
you've assembled you'll need to generate a scenario file that Panzerkrieg for Windows can 
execute.    You use the Create .PKS File... option from the File menu to create your scenario 
file.

As you play the scenario you'll probably discover changes you'll want to make.    You make 
these changes using the assembly file, and then generate a new scenario file.



Symbols on the Map

There are several types of symbols used on the map in Panzerkrieg for Windows:

Terrain Symbols

Unit Symbols



Terrain Symbols

You'll see the following terrain symbols used on the map in Panzerkrieg for Windows:

Gullys

Roads

Forests

Towns                  

Water

Hillsides

Hilltops

Swamps

Fords

The basic terrain types can be combined.    Some examples:

A Road on a Hillside

A Gully in a Forrest 

 



A Hilltop Town



Unit Symbols

You'll see the following unit symbols used on the map in Panzerkrieg for Windows:

Tank

Tank Destroyer

Self-Propelled Artillery

Self-Propelled Missles

Scout Car

Truck

Halftrack

Wagon

AntiTank Rifle

Mortar

Infantry Gun

Light Flak Gun

Fort

Infantry

Cavalry

Forward Observer

Ammunition or Fuel Dump





A scenario is the setting for a Panzerkrieg for Windows game.    It consists of a game map , 
two teams, a list of units that comprise each team, and a description of the objectives for 
each team.



An assembly file (.PKA) holds information about the scenario your are creating.    Assembly 
files are created and edited by the PFW Scenario Assembler.    Once you are satisfied with 
your scenario, you use the assembler to create a .PKS file which can be read by Panzerkrieg 
for Windows.



A scenario file (.PKS) is a file that can be loaded by Panzerkrieg for Windows.    Once you 
finish designing your scenario in the Assembler, you need to generate a .PKS file to play 
your scenario in PFW.    .PKS file can only be created by the Assembler; they can not be read 
by the Assembler or edited.



A map segment is a collection of terrain.    Each segment represents an area of 
approximately 4 by 1 kilometers.    You choose segments from the available list and place 
them on the map to create the terrain for your scenario.



A setup area is an area where players can initially place their units when they start a 
scenario.    You use the PFW Scenario Assembler to define where on the map these areas are 
located, and which units are to be deployed in them.    A scenario typically has at least two 
setup areas defined:    one for each team.    More complex scenarios may have more areas 
defined.


