
Welcome to Electro-Cute Help!

Click the forward browse button for an introduction to Electro-Cute.

Click the CONTENTS button to look for specific information.

Click here for an alphabeticINDEX.



Electro-Info

Electro-Cute is a word-guessing game from StuSoft.

Game play is pretty much like the traditional 'hangman' games:    The object 
of the game is to guess the word represented by the blanks

_ _ _ _ _ _

You may type your guesses on the keyboard
OR

use your mouse to click the letter buttons.

Click the forward browse button

for more about game play.

Click here for info on setting up Electro-Cute.



General Info++

As you make correct guesses, the letters replace the blanks in the target 
word.

As you make incorrect guesses, body parts are added to the Electro-Cute 
Guy.

If you miss too many letters, it's fry-time for our hero!    (The number of 
letters you may miss without Electro-Cution is determined by the skill level 
setting.)



Setup

Setting up Electro-Cute is pretty simple.    You need to put it on your hard 
disk--I would suggest a directory something like:

C:\GAMES\ELECTRO

Then, create an icon in Program Manager:

1 Click on the group you want Electro-Cute to live in (Games).

2 From the File menu, select New.

3 When the dialog box comes up, click OK to select Program Item.

4 Fill in the box something like this:

5 Click OK, and your done!

When you double-click on the Electro-Cute icon, an .INI file will be created (if 
it doesn't already exist, that is : ).
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Electro-Menus

Electro-Cute has four menus:

Game Menu

Dictionary Menu

Options Menu

Help Menu

You can use your mouse to pull down the menus or you can hold down the 
<ALT> key and type the underlined letter from the menu name.
 (G - for the Game menu, H - for the Help menu, etc.)



Game Menu

Next Word - give up on the current word . . . counts as a miss!

Restart Game - start the game over.

High Scores - shows the players with the top 5 scores.

Exit - ends the game and the program.



Dictionary Menu

Edit Dictionary

Load Dictionary

Set Startup Dictionary

Save As



Options Menu

Sound

Garbage

Save Options

Words per Game

Skill Level



Help Menu

Help - that gets you here!

Register - goes away when you register.

About - a little about Electro-Cute and StuSoft



Electro-Dictionary

The dictionary is the list of words with which Electro-Cute challenges you.    
Electro-Cute provides a built-in Edit Dictionary function which allows you to 
change the dictionary.

You may create your own dictionaries with any text editor (like Microsoft 
NotePad).

The Electro-Cute Dictionary is an ASCII text file with some simple limitations:

Each line must contain exactly one word.
All words must have between 3 and 16 letters, inclusive.
The words may only contain the letters from
A to Z and a to z.    (Lower case letters will be converted to upper case)
Dictionaries should contain at least 12 words.

A Dictionary's name may be any valid file name, with any extension.    (I 
suggest that you use the extension .dic since that's what Electro-Cute looks 
for!)



Load Dictionary

Selecting Load Dictionary from the Dictionary menu allows you to open a 
new dictionary.    The game will restart.

Electro-Cute will attempt to open any file you select, but you should only 
attempt to open valid Electro-Cute Dictionaries!!

The default dictionary name is: ELECTRO.DIC

You may specify a different startup dictionary in the Properties box in 
Program Manager.



Edit Dictionary

Adding words

Deleting words

Finding words

Saving changes



Adding Words

1 Click the ADD WORD button

2 Type the word you wish to
add in the edit box.

3 Click the ADD WORD button
OR

press <ENTER> on the keyboard

Repeat steps 2 and 3 to add more words

Click the DONE button to end.



Deleting words

1 Use the NEXT WORD and
PREVIOUS WORD button
to locate the word you
wish to delete or type
the word you wish to
delete into the edit box.

2 Click the DELETE WORD button.

Repeat 1 and 2 to delete more words.

Click the DONE button to end.



Finding Words

To locate a word: type the word into the edit box and click the FIND WORD 
button

A message will tell you whether or not the word was located.

HINT:

You may use FIND WORD to move through the dictionary--very helpful when 
using a large dictionary.

To move the words that start with the letter T, type a T into the edit box and 
click FIND WORD.

The message will report that the word T was not found.    Click the NEXT 
WORD button to see the first T word.



Set Startup Dictionary

Electro-Cute normally starts with the default dictionary: ELECTRO.DIC

You may change the startup dictionary by selecting Set Startup Dictionary 
from the Dictionary menu.

This adds a line to the file ELECTRO.INI telling Electro-Cute to load the 
dictionary you specify the next time it runs.

THIS DOES NOT CHANGE THE CURRENT DICTIONARY!    For that, you must 
use Load Dictionary.

A dictionary name may also be specified in the Properties box in Program 
Manager.

By default, Electro-Cute looks for the a file named ELECTRO.DIC and uses it 
for the startup dictionary.

There are two ways to override this:

You may specify a dictionary name in the Properties Box in Program Manager.

Select Startup Dictionary from the Dictionary Menu.

NOTES:

In order to use the Set Startup Dictionary command, you MUST NOT have a 
dictionary name specified in the Properties Box!

If the startup dictionary cannot be found, Electro-Cute attempts to open the 
default dictionary (ELECTRO.DIC).



Properties Box

You may select a dictionary for Electro-Cute to use on startup by entering the
file name of the dictionary in the Properites Box in program Manager.

EXAMPLE:

To use the dictionary named OTHER.DIC, fill in the Properties Box entry for 
Command Line as follows:



Saving Changes

The Edit Dictionary function will request that you save the changes to your 
dictionary after you click the DONE button.

You may choose at any time during the game to save your dictionary.    Just 
choose Save As from the Dictionary menu.



Electro-Options

These options allow you to control how the game plays.

Sound

Garbage

Save Options

Words per game

Skill Level



Sound

Electro-Cute can play strange sounds on your PC!

If you have a sound card, Electro-Cute will start with sound on (checked) and 
let you hear the weirdness.    To turn sound off, select Sound from the Options
menu.

If you have don't have a sound card, but use a PC-Speaker driver you will get
the sounds with out-of sync animation.    Sorry    : (.



Garbage

What the Heck is Garbage???

Well, garbage is the bizarre stuff I dream up after tackling a difficult problem 
in logic (read as 'bug').

If you're bored and/or creative, you'll find strange and wonderful things!!

Electro-Cute starts with the garbage on (checked).    If you have an aversion 
to silliness, or just wish to turn garbage off, select Garbage from the Options 
menu.    If the check mark is gone, garbage is off.

Garbage comes 'AS IS', with no warranty expressed or implied.    StuSoft will 
accept no responsibility for disappointment over the underwhelming 
StrangeAndWonderfullness of said product . . . whew!



Save Options

If you wish, you may save the current options at most any time by choosing 
Save Options from the Options menu.

You don't need to save the options, though: When you quit, Electro-Cute will 
tell you if the options have changed and let you save the options.



Words Per Game

This option lets you select the length of each game.    Game lengths are:

10 Words
15 Words
20 Words
25 Words
All the words



Skill Level

To set the Skill Level, choose one of the three skill level settings from Skill 
Level in the Options Menu.

The three Skill levels are:

Normal Human ; easiest ; allowed 6 misses before Electro-Cution

Whiz Kid          ; pretty hard ; allowed 5 misses

Super Brain ; don't even try it! ; Allowed 4 misses



Electro-Controls

Electro-Cute has a bunch of controls!

Letter Buttons

Help Button

Exit Button

About Button

Menus



Letter Buttons

The letter buttons let you use the mouse to 'type' words during the game.    
Just put the pointer an a Letter Button and click.

You may also type your guesses on the keyboard!



Help Button

As the name implies, the Help Button activates Help--you may have used it 
to get here.

You may also press the F1 key for help, or choose Help from the Help menu.



Exit Button

The exit button terminates the game immediately!    If you click this button 
the game is over!!

This is, the fast way out of Electro-Cute . . . use it only if you're serious!



About Button

This buttons lets you see a little bit about StuSoft and the people that make 
this all possible. *sniff*



Registering Electro-Cute

You may register by sending $10.00 US to:

 StuSoft
 3337 Lexington Rd.
 Richmond, KY    40475-9145

You will receive a serial number that will register your current copy of Electro-
Cute and many more yet to come.

For $15.00 US I'll send you a disk with the latest, greatest version of Electro-
Cute and, if you ask nicely, I'll throw in a StuSoft utility or two.

NOTE: Please send a check or money order and please allow two weeks for 
delivery (if you order a disk).    We regret that we currently are not able to 
take credit cards.

Contacting the author



Contacting Stu Reedy

If you have bug reports, comments, questions, opinions, ideas, attitudes or 
inspirations about Electro-Cute please mail them to me.    I'll endeavor to 
make it worth your while!!

You may reach me at any of the following e-mail addresses:

 itcstu@ukcc.uky.edu
 71162,1607 CompuServe
 UKITC AppleLink

I will also accept SNAIL MAIL and registrations at:

 StuSoft
 3337 Lexington Rd.
 Richmond, KY    40475-9145



The .INI File Format

Electro-Cute creates its initialization file (ELECTRO.INI) the first time you run 
the program.    This file holds Options settings (like Skill Level and Sound).    
The High Score table is also stored there.

Here is a typical Electro-Cute .INI file: (Click on any line for details.)

GARBAGE = ON
SKILLLEVEL = 1
SOUND = ON
DICTIONARY = C:\GAMES\ELECTRO\COMPUTER.DIC
WPG = 1
WOW = Mike is the Top Scorer!!!
[SCORES]
Top Scorer! 293
BigTimeWinner 280
yoB sdrawkcaB 179
MOM 162
Rover48



.INI file: GARBAGE

The format for this line is:

GARBAGE = ON

OR

GARBAGE = OFF



.INI file: SKILLLEVEL

The format for this line is:

SKILLLEVEL = 1 (Normal Human)

OR

SKILLLEVEL = 2 (Whiz Kid)

OR

SKILLLEVEL = 3 (Super Brain)



.INI file: SOUND 

The format for this line is:

SOUND = ON

OR

SOUND = OFF



.INI file: DICTIONARY

The format for this line is:

DICTIONARY = C:\GAMES\ELECTRO\COMPUTER.DIC

This line would load the file COMPUTER.DIC from C:\GAMES\ELECTRO.

It is created by choosing Set Startup Dictionary from the Options Menu.



.INI file: WPG

This one is a little tricky!

WPG = 0 is 10 words per game

WPG = 1 is 15 words per game

WPG = 2 is 20 words per game

WPG = 3 is 25 words per game

WPG = 4 is All the words



.INI file: WOW

WOW is the Words of Wisdom that the person with the top score enters.

WOW = The words you wish to say!



.INI file: [SCORES]
The [SCORES] section of the .INI file holds the top five scores, and the intials 
of the top five players.
The format is:

[SCORES]Top Scorer!<TAB>293

BigTimeWinner<TAB>280

yoB sdrawkcaB<TAB>179

MOM<TAB>162

Rover<TAB>48
It's important that the name be seperated from the score by a <TAB> 
character--chr(9).    If you use a different character (like a space), the score is 
ignored!!



Electro-Index

Controls
      About Button
      Exit Button
      Help Button

Dictionary
      Creating your own dictionary
      Adding words
      Deleting words
      Edit dictionary
      Load dictionary
      Saving changes
      Startup dictionary
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      Game Menu
      Dictionary Menu
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      Sound
      Garbage
      Skill Level
      Words per game
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Registering Electro-Cute

Contacting the author




