CRYP-IT
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Cryp-lt Version 1.0, the Cryptogram Entertainment
System, makes it great fun to hone your puzzle
solving skills with your friends and family. Create
Challenging cryptograms for each other to solve.

With Cryp-It, your children improve their deductive
reasoning and strengthen their vocabularies while
increasing their familiarity with computers as well.

Glossary: - Description Of Terms Used
Menu Summary: - Commands On Each Menu

Using Cryp-it: - Instructions For Utilization



Menu Summary

Help on Cryp:-It's Menu Commands consists of the following sections. To view a
particular section click on it.

File Menu

Crytogram Menu
Maintenance Menu

Help Menu
Edit Menu



File The File menu is the first menu found on

Dpen... the menu bar and provides access to
Save As... the file system, cryptogram printing,
T oL . printer selection and setup, and program
Evint... termination. The functionality of cach of
Printer Setup... these commands is described in detail
Exit below.
Open... Loads a new puzzle file.into Cryp-It.
Save As... Saves current puzzle file under a new name.
Print... Prints current date, time, and puzzle on line printer.

Print Setup... Permits selection, setup of all available printers.
Exit Ends Cryp-It program.



Cryptogram The Cryptogram menu provides
Give Me & Hint [18 pts) | you with hints to solve puzzles

Reset Solution Scores with, solution scores resetting.
— and, tor the weary and puzzied,

and immediate solution option.

Give Me A Hint Reveals a single letter of the cryptogram.
Reset Solution Socres Resets cryptogram's Scores to 0.

Solve Now Displays solution to the cryptogram.

Solve Now [| Give Up]




Maintenance
Create New Cryplogram |
Edit Current Cryptogram

The Maintenance menu gives
wyou the ability to Create a new
| cryptogram, to Edit the current
Delete Current Cryplogram | one, or to Delete it entireby.

Create New Cryptogram Creates cryptogram in puzzle file.
Edit Current Cryptogram Edits the current cryptogram.

Delete Current Cryptogram Deletes the current cryptogram.




Help The Help menu provides several ways

Contents lo access the Crypit Help File, otfers
Menu Commands | Help on using Windows' Help program,
Using Cryp-It and displays information abowt the

Crypit program. These functionality of
Help With Help each of these commands is described

About Cryp-lt below,
Contents Detailed Index to Cryp-It Help.
Menu Commands Utilization of all menu commands.
Using Cryp-It Using Cryp-It most effectively.
Help With Help Help with the Windows' Help Facility.

About Cryp-It Release version and credits for Cryp-It.



Edit The Edit menu is available

Cut Cirl+i | only during the Create or
Copy C+C Edit modes located under
Paste Shift+lns the Maintenance menu. It
- facilitates manipulation of
Copy &ll Lines  Curl+h texdt in the lext boxes as
Multi-line Paste Ctrl+M described helow,
Cut Deletes text and moves it to the clipboard.
Copy Copies text to the clipboard.
Paste Moves text from the clipboard to an edit window.

Copy All Lines Merges all edit windows to the clipboard.
Multi-Line Paste Pastes clipboard text into all edit windows.



Using Cryp-it

Help on using the Cryp-It program consists of the following sections. To view a
particular section click on it.

Selecting A Cryptogram
Replacing The Letters
Obtaining That Hint
Suggestions For Success



Selecting A Cryptogram

When Cryp-lt starts, it randomly selects a cryptogram from the default puzzle file
"crypit.crp”. If you have already solved the one selected, you can easily choose
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another one by clicking on the down arrow 38 of the puzzle list box. If there are
more than 5 puzzles in the puzzle file, a scroll bar will appear, permitting you to scroll
quickly through the list of available puzzles. Simply click on any number and the
corresponding cryptogram will be loaded and ready to solve.

After you have solved all the puzzles in the default puzzle file, you can select a new
puzzle file to access. For new puzzle files, you can either create them or obtain them
from Bosenbach Computing.

Note: After you have solved all of the cryptograms in a puzzle file, you may wish to
rename a new puzzle file with the default name, "crypit.crp”, so that it can be
automatically accessed whenever the program is executed.



Replacing Letters

To replace any letter in the current cryptogram, simply click its button with the mouse

L
pointer. After you click it, a blank button will appear above its location. 2 ® Select
one of the Alphabet letters located on the upper panel and its letter will replace all
occurrences of the letter you wish to replace. Notice that as each Alphabet letter is
used somewhere, it is grayed.

To cancel the replacement, click on the replacement letter button above the letter you
clicked originally. It will be returned to its former state, and the Alphabet letter will be
enabled for reuse.



Obtaining That Hint

For assistance in solving cryptograms, you may wish to obtain one or more hints from
the Cryptogram menu. Each time you obtain one, you are docked the number of points
indicated to the right of the menu selection. The amount of points varies with the
number of characters in the cryptogram.

Since each puzzle is worth 1000 points, an 18 point cost for a hint is of minimal impact
compared to the 10 points per minute the hint may save you. So if the puzzle seems
particularly hard to solve, you should consider calling for more hints.

On the other hand, hints are issued in random fashion so your hint might reveal 6 or 8
characters one time, and only one character the next. And they can become quite
expensive if the puzzle is rather short. A hint for a puzzle with only 20 letters in it costs
you 100 points!



Suggestions For Success

Solving a cryptogram has a few rules of thumb to follow. The rules may vary
depending on who your teacher was, and they may not always be effective. If the
author of the puzzle knows the same rules, he or she may use care to create puzzles
which counteract the approach one takes when following them. With this in mind, here
are some suggestions from the author of Cryp-It.

1. Generally, E is the most frequently occurring letter. It is usually found at the end
of at least one word in the cryptogram.

2. A single letter is either an Aor an I. If it occurs more than once in the puzzle, it
is more often an A.

3. A single letter which follows an apostrophe (') is most often a T, although it can be
an SoraD as well.

4 If the same set of three letters appears more than once in the cryptogram, there
is a good chance the word is THE.

5 Cryptograms have a cadence when you read them. Even if you don't know what

it says, you can feel its rhythm. This can help you recognize a familiar phrase the
author may have used.

6 Cryptograms are Fun! The more you work them, the better you'll become at
solving them. And if you get good enough, you can author your own, just like | have
done. So, for goodness sake, enjoy yourself!



Open...

This command displays a File Open dialog box listing all puzzle files in your current
working directory and allows you to select one to load into Cryp-lt. You can change
drives and directories while looking for a puzzle file to open.



Save As...

This selection displays a File Save As dialog box enabling you to save the current
puzzle file to your hard disk drive (or diskette, if desired) under the original or a new
name. You can change drives and directories prior to saving the file.



Print...

This selection allows you to print the current cryptogram on any of your available
printers. The date and time will precede the cryptogram, which will be printed in
two 70-character lines, treble spaced for penciling in letters above them.

It also permits you to setup the printer, orient the page and margins, specify number of
copies, or cancel printing, if desired.



Print Setup...

This command allows you to select and setup your printer from all available print
devices on your system. It will also permit network printer connections if any exist.



Exit

This command is entered to quit the program. During cryptogram Creation or editing
modes, the Exit command is not available, so no danger of data loss exists.



Give Me A Hint

This command reveals one letter of the cryptogram's solution to you in the form: Letter
Xis Letter P. Each hint costs you points, and a running total of points are displayed
along with the hint. When a puzzle is solved, your overall solution score is reduced by
the accumulated cost of all hints you have received.

Note: The cost of a hint varies from cryptogram to cryptogram and is inversely
proportional to the number of characters used. In a smaller puzzle, each hint will cost
you more points!



Reset Solution Scores
This command resets all solution scores stored with the current cryptogram to 0.

Note: Scores are filled one at a time. That is, the first time a puzzle is solved, the
score will be stored as score #1, the second time, score #2, and so forth. Once a
puzzle has been solved four times, however, subsequent scores will overwrite score #
4. This will continue until the puzzle's solution scores have been reset.



Solve Now (I Give Up)

This command is self-explanatory. It is important to note that once you have selected
this command, the current cryptogram cannot be solved until it has been selected anew
from the puzzles list box. This is to prevent someone from using this selection to fill in
all the letters, deselecting a letter, and reselecting it so it appears as though they solved
the puzzle in record time.



Create New Cryptogram

This command invokes the Create Cryptogram mode and places four edit windows on
the screen. With the assistance of an Edit menu of text modification tools, you can
enter text as desired and save it as a cryptogram.

Note: Each of the four edit windows are limited in length to 35 characters. An attempt
to save the puzzle with any of them in excess will result in the mouse pointer preceding
the 36th letter in the offending edit window.




Edit Current Cryptogram

This command invokes the Cryptogram Edit mode and copies the current cryptogram to
all four edit windows for text editing. With the assistance of an Edit menu of text
modification tools, you can change the puzzle's contents as desired.



Delete Current Cryptogram

This command is self-explanatory. It is important to realize that a deleted cryptogram is
gone forever. It cannot be recalled, so be certain you no longer need it before using

this selection.



Help Index

This command invokes the Windows Help Facility with the Cryp-It Help Index (the help
file you are currently reading).



Help With Help

Selecting this command will give you a complete tutorial about using the Windows Help
facility, which works the same way for all help files under Windows. It shows you how
to navigate through help files, get definitions of terms, browse related topics, search for
key words or phrases, backup through your selected topics, and call up the index (or

table of contents).

If you are confused about how help works, this selection is time well spent!



About Cryp-it

This command displays the release version, date of release, and credits for the Cryp-It
program. While viewing the 'About Box', no other Cryp-It functions are available, so
click the OK button when finished viewing it, and control will return to the main program.



Cut

This command cuts (deletes) all selected text to the clipboard where it can be pasted
into the edit window of this or any other Windows application. Unlike Copy, Cut
removes the selected text from the edit window.



Copy

This command copies all selected text to the clipboard where it can be pasted into the
edit window of this or any other Windows application. Unlike Cut, Copy leaves the
selected text in the edit window unchanged.



Paste

This command takes all text previously placed on the clipboard, from this or any other
Windows application, and inserts it into the edit window at the location of the mouse
pointer. The same text may be pasted into the edit window again and again, if desired.



Copy All Lines

This command copies text from all edit windows during cryptogram creation or editing
and joins them into one sentence on the clipboard. This is useful if you prefer
modifying the text in another editor such as Windows Notepad.



Multi-Line Paste

This command takes all text previously placed on the clipboard, from this or any other
Windows application, and inserts it into all edit windows, 35 characters per window,
during cryptogram creation or editing. If the clipboard text is in excess of 140
characters, the fourth edit window contents will have to be reduced to 35 before the

puzzle can be saved.



Glossary

Copy

Cut

Edit Window
Enabled
Grayed

List Box
Mouse Pointer
Paste

Puzzle File



Clipboard

The clipboard is an area of reserved memory which allows you to copy selected text to it
and recall text from it. When you remove selected text using the cut command, it is
stored in the clipboard and can be pasted back again until it is replaced by another cut
or copy action.



Copy

Copy takes a snapshot of the highlighted text from the currently active edit window and
duplicates it on the clipboard. You can insert the copied text into another application or
edit window of the same application using the paste command.



Cut

To Cut is to remove text from the currently active edit window. In addition to the Cut
selection from the Edit Menu, cut can be performed on highlighted text by holding down
the Control Key and pressing the X key simultaneously. Cut text can be recovered by
using the Edit Menu Paste selection.




Edit Window

An Edit Window is one of the rectangular workspaces on the screen where you enter,
delete, and change text during cryptogram creation or editing. To assist you in text
manipulation, the Edit Menu offers cut, copy, and paste support.



Enabled

When a button, menu selection, or other control responds to a mouse click, it is said to
be enabled. If there is no response, the control is said to be disabled or grayed.



Grayed

If a Button or menu selection is grayed it is disabled. Clicking it with the mouse pointer
will have no effect. The opposite state for a grayed control is enabled




List Box

A list box permits you to scroll through a set of possible items and select one of them.
The Puzzle list box is used to select a cryptogram to solve in Cryp-it.



Mouse Pointer

The mouse pointer, sometimes an arrow, sometimes an hourglass, and sometimes an I-
beam (when it is located in an edit window) is used to select one of the window controls
to be clicked or double-clicked, depending upon the desired function.



Paste

To Paste is to add previously cut or copied text into the currently active edit window. In
addition to the Paste selection from the Edit Menu, paste can be performed by holding
down the Control Key and pressing the Insert key simultaneously. The text will be

inserted at the location of the mouse pointer.



Puzzle file

A puzzle file is an Ascii text file containing Cryp-It puzzles. Its file name extension is
"CRP'. Each puzzle is stored in an encrypted form, preceded by its scores and its
encryption key set. Although the text file is editable, you should only make changes to

it through the Cryp-It program or your changes may cause incorrectable problems to
occur.

There is no physical limit to the number of puzzles stored in a puzzle file, but storage of
too many puzzles in a single puzzle file will cause some functions to be performed
noticeably slower. Since Cryp-lt lets you easily select a new puzzle file, it is
recommended that puzzles per file should not exceed 100.






