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Get the latest versions of InstallShield help files

For the latest versions of InstallShield help files, visit our documentation Web page.
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Visit the InstallShield Knowledge Base

For answers to many commonly asked questions and new information about InstallShield that may not appear in
the documentation, visit the InstallShield Knowledge Base.
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What's New

InstallShield's Integrated Development Environment (IDE) includes the InstallShield Script Editor, a full-fledged text
editor that supports bookmarks, line markers, syntax coloring, and all the editing commands common to Windows-
based text editors.

Syntax coloring

In the Script Editor, keywords, predefined constants, InstallShield function names, and other InstallScript identifiers
are color-coded to assist you in identifying InstallScript language elements and to improve readability.

Script editing commands

The Script Editor uses a powerful array of standard text editor navigation and editing commands. The Script Editor
supports find, search and replace, columnar text selection, line markers , and bookmarks , just to name a few.

{button ,Inet("http://www.installshield.com/IS5/ISSTALK.htm");PI("", Internet')} Comment on the help files via the
World Wide Web
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Open and save a file

Once listed in the Source Files pane, files are available for editing. Double-click on a filename to open the file.

When you click a filename, that file will open in a new window on the right, displaying your text with functions,
predefined constants, quoted text, and other parts of the script each uniquely colored. Lines have been counted,
and any bookmarks remaining from a previous session are available. (The bookmarks are not visible.)

You may open several files for editing at once. Each opens in its own window. To arrange windows or cycle among
open windows, see the Windows menu.

You can close an individual file by closing its window. When you click the Close button, you will see a dialog box
asking if you want to save the changes.

Click Yes to save, No to discard changes. To continue editing the file, simply open it again. There is no other way to
save an individual file, and no other way to discard changes.

To save the entire project, choose File, then choose Save. When you exit InstallShield politely, it will save all
changes made in the current session.

Whether you save files individually, or with the project, Line Markers entered in this editing session will not be
saved. Bookmarks will be saved.

{button ,AL('File menu S',0,","")}__See also
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Check the cursor position

When a script editing window is open, the exact position of your cursor is displayed as Line and Col number
coordinates in the Status bar. If the status bar is not open, open the View menu and click Status bar so that it is
checked.

{button ,Inet("http://www.installshield.com/IS5/ISSTALK.htm");PI("", Internet')} Comment on the help files via the
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Print a file

After selecting its window, there are three alternative ways you can print a file:
n At the File menu, choose Print

n  Use the Ctrl+P shortcut keystroke

n  Click the printer button on the Toolbar

Any of the above actions will bring up a standard Windows print dialog box, where you can set options as
appropriate and confirm the action.

InstallShield uses the following settings when printing scripts:

n  Left margin: 5/8” inch; top margin: 5/8”; bottom margin 1”; right margin: 3/4”
n  Header contains the full path and filename of the file, bolded

n  Footer contains the page number

n  Fontis Courier

{button ,Inet("http://www.installshield.com/IS5/ISSTALK.htm");PI("", Internet')} Comment on the help files via the
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Use the Function Wizard

The Eunction Wizard automates the process of adding function calls to your scripts. Instead of looking up a function
in the online help, deciphering parameter descriptions, and copying, pasting, and editing the function call, you just
step through two brief wizard panels and then watch as your function call is inserted into your script at the cursor!

{button ,Inet("http://www.installshield.com/IS5/ISSTALK.htm");PI("", Internet')} Comment on the help files via the
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Change Script Editor options

The Tools menu contains an Options command, which leads to a tabbed dialog containing settings for how the
screen and editorial functions work.

These settings control how the editing process works and displays.
The tabs under Options provide a way to change:

n  settings for Edit operations, including whether you want horizontal or vertical scroll bars enable, drag-and-drop
enabled, and selection margin to be enabled;

n  settings for Tab stops, including the number of characters that the Tab key should indent, and whether you want
to save tabs (ASCII 09) or spaces,

n  settings that affect screen Format, such as display font and syntax colors

n  settings that affect command keystrokes (that is, changing the keystrokes to ones you prefer).

{button ,AL("Edit tab (Options dialog) S',0,",)} See also
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Commands

The following editing shortcut commands follow the conventions seen in most Windows text editors. You can
change the shortcut commands if you wish. Select Options from the Tools menu and click the Keys tab. You will be
able to view, remove, and reassign shortcut commands.

Insert rows
Insert a line after the current line Alt+Shift+N
Insert a line before the current line Ctrl+Shift+N

Cut/delete text

Cut the selection to the Clipboard Ctrl + X, Shift+Del

Delete the selection or, if there is no Backspace
selection, the character to the left of

the cursor

Cut the selected lines to the Clipboard Ctrl+L

Delete the current line Alt+Del

Delete the word to the right of the Ctrl+Del

cursor

Delete the word to the left of the cursor ~ Ctrl+Backspace
Clear the current selection Ctrl+Shift+Del

Copy text

Copy the selection to the Clipboard Ctrl + C, Ctrl+Insert
Paste text

Ctrl + V, Shift+Insert

Insert the Clipboard contents at the
insertion point

Move the cursor

Move the cursor one character to the Left Arrow
left

Move the cursor one character to the Right Arrow
right

Move to the beginning of the file Ctrl+Home
Move to the end of the file CtrlI+End

Move to the start of the current line Home

Move the cursor down one line Down Arrow
Move the cursor up one line Up Arrow
Move to the right end of the current line  End

Move the cursor down one screenful Page Down
Move the cursor up one screenful Page Up

Move the cursor back one word Ctrl+Left Arrow
Move the cursor forward one word Ctrl+Right Arrow
Open Go To Line number dialog box Ctrl+G

Move to the line containing the next F2

Line Marker.



Move to the line containing the
previous Line Marker.

Move cursor to left left one tab stop
Select text

Extend the selection one character to
the left

Extend the selection one character to
the right

Extend the selection to the end of the
file

Extend the selection to the beginning
of the file

Extend the selection to the start of the
current line

Extend the selection to the end of the
current line

Extend the selection down one line
Extend the selection up one line

Extend the selection down one
screenful

Extend the selection up one screenful
Select the entire document
Select a line of text
Extend the selection back one word
Extend the selection forward one word
Find text
Launch Find dialog
Launch Find dialog
Replace text
Launch Find/Replace dialog

Open the Replace dialog
Indent

Indent the selected text left one tab
stop

Change case
Make the selection all lowercase

Convert the selections to all
UPPERCASE

Mark text
Start character selection mode
Select a columnar block of text

Toggle a Line Marker on and off at the
current line

Clear all line markers
Open the Bookmark dialog
Undo actions

Shift+F2

Shift+Tab

Shift+Left Arrow

Shift+Right Arrow

Ctrl+Shift+End

Ctrl+Shift+Home

Shift+Home

Shift+End

Shift+Down Arrow
Shift+Up Arrow
Shift+PageDown

Shift+Page Up
Ctrl+A
Ctrl+F8

Ctrl+Shift+Left Arrow
Ctrl+Shift+Right Arrow

At+E, F
Ctrl+F

Alt+E, E
Ctrl+H

Tab

Ctrl+U
Ctrl+Shift+U

F8
Ctrl+Shift+F8
Ctrl+F2

Ctrl+Shift+F2
Alt+F2



Undo the last action Ctrl+Z, or select Undo from the Edit menu

{button ,AL('Keys tab (Options dialog) S',0,™",™)} See also
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Syntax coloring

When displaying a .rul or a .h file in the editing window, InstallShield color-keys items which it recognizes as having
special meaning in the script language. This syntax coloring brings out the meaning of your text at a glance, and
helps you locate such things as misspelled function names, missing quotes, even grouping and sequence
irregularities.

Here are the default colors for the various InstallShield identifiers:

Hormal text n  You can change which colors are used for
Selected text which kinds of terms by selecting Tools
Line marker from the menu, then Options, then clicking
Function the Format tab.

'IEL-.]rw\nrr] X . . .
Caian and n  Spelling errors in keywords will result in the
ouoted text terms not being recognized, therefore not
Comment colored correctly.

n  Quoted text is colored from the first quote
mark to the second quote mark or to the
end of the line, if the trailing quote is
missing. Any following text that should
have been outside the quotation is
included in the colored section.

n  All text from the first occurrence of two
slashes (/ /) to the end of the line is
recognized as a comment .

When the edited file does not have.rul or .h filename extension (for example, log or report files) syntax coloring is
turned off.

{button ,Inet("http://www.installshield.com/IS5/ISSTALK.htm");PI("", Internet')} Comment on the help files via the
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Line markers

Line markers are navigational tools to help you find lines quickly. Line markers appear as colored square buttons in
the left margin. You can insert and remove line markers individually, and you can insert line markers while using the
Find dialog.

To enter line markers, do one of the following:

n Inthe Find dialog box, click the Mark All button. A line marker will be placed on each line in which the specified
text is found.

n  Press Ctrl+F2 in the line to be marked. Ctrl+F2 toggles a line marker on and off.

To go to the next line marker, press F2. To go to the previous line marker, press Shift+F2. To clear all line markers,
press Ctrl+Shift+F2.

Line markers are deleted when a file is saved.

{button ,AL('Find dialog box S;Bookmarks',0,",™)} See also
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Bookmarks

Bookmarks are invisible named placeholders that help you navigate through your file by marking specific locations.
Bookmarks are located in exact character and column positions.

To create a Bookmark, Alt+F2. You will see the Bookmark dialog box.

Bookmark |
Mame A I
bookmark 1 Close |
elete |
{E{ei [z |
Help |
File: C:hy Installationz\WJIPROUNS cript Fileshsetup. ol
Lire: 8

The Bookmark dialog box shows all bookmarks for the current file. You can add bookmarks, delete bookmarks, and
go to a selected bookmark.
Bookmarks are saved when a file is saved, but they are not part of the file itself.

{button ,AL('Line_Markers',0,”",”")}__See also
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InstallShield help is attempting to send you to the InstallShield Web site (www.installshield.com). If your preferred
Web browser is not launched, click here [ | , then restart InstallShield help.



InstallShield help found Setbrows.exe but could not run it. Open your InstallShield program folder and double-click
the Setbrows.exe icon.



InstallShield help could not find Setbrows.exe. You may have deleted this file; check to see if Setbrows.exe is in
your InstallShield program folder.



Cuts 12/19

Finds next occurrence of (previously F3
specified) text
Find the previous occurrence of Shift +F3

(currently selected) text

Find the next occurrence of (currently Ctrl+F3
selected) text

Find the previous occurrence of the Ctrl+Shift+F3
selected word

also Ctrl + D
also moved Shift tab up, changed description
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Insert/Overtype

When you are typing in Insert mode, new characters push old text to the right. When you are typing in Overtype
mode, new characters replace old characters (including spaces) to the right as you type.






