
Glass Lens

Figure 26    An example of the fish-eye lens effect with the Glass Lens.

These KPT filters go further than any previous spherical filters that take a selection and 
"bump" or "spherize" it.    The Glass Lens Filters actually use a special-case ray tracer, 
complete with a 10 position user-defined, shadow casting 3-D light source and ambient light.

The result will look like an anti-aliased 3-D rendered ball.
There are three versions:

·    Glass Lens Bright
·    Glass Lens Normal
·    Glass Lens Soft

Bright has a low ambiance setting, medium aliasing and 
high intensity spotlight, casting a "hot" spot. 



Normal reduces the intensity of the light to about 60%, 
resulting in less harsh lighting and contrast. Smooth 
spheres with small highlights and soft, rich shadows can 
be easily created.

Soft has very soft settings of a low intensity sun (<15%) 
and higher ambiance, creating less hot spot and softer 
shadows on the sphere. 

Figure 27    From top to bottom: Glass Lens Bright, Glass Lens Normal, Glass Lens Soft

Glass Lens Options



When using rectangular or free-form selections, you 
have the option of rendering the Glass Lens on the 
selection or on a black background. By default, the 
sphere is rendered onto the selection. Pressing the "Caps
Lock" key will render the selection onto the sphere and 
fill the remaining portion of the selection with black.

Positioning the highlight
To vary the "sun" position on the sphere, there is a 10-
position control via the numeric keypad.

Simply hold down the "7" key to have the light shine 
from the upper left and a shadow on the lower right and 
the "2" key to shine from bottom center. Using Scroll 
Lock key with the number pad will add eclipse effects.    
Using the Scroll Lock key and the "5" key simulates a 
total eclipse, including a halo around the outside of the 
sphere.

Glass Lens Walk Through
In Photoshop and Painter
1.    Create a new document and fill the entire document 
with a solid color (this is to best show the capabilities of 
the Lenses).
2.    Using the rectangular marquee tool, hold the shift 
key down and drag to select a square area.
3.    Apply the filter Glass Lens Bright to create a sphere.
4.    Without deselecting, apply Glass Lens Bright on the 
same selection while holding down "4" on the keypad. 
5.    Use the filter Glass Lens Soft on the same selection 
while holding down the "9" key. This will act like 
extremely complex multiple light-source renderings, 
diffuse spots, and ambient shadows. 

Tips
·    Try using Glass Lens Soft over a Gradient rainbow 
sweep with full intensity colors, creating small solid color
spheres with very subtle hue modulation.

·    You can use all the lenses in odd shaped feathered 
selections for non-"ball"-like effects.

·    Try rendering glass lenses and then apply the Texture 
Explorer using the Procedural Blend Mode. This will 
simulate texture mapping which is very time consuming 
in 3-D rendering programs. If you want the exact colors 
used in the Texture Explorer blended onto the sphere, 
first create a glass lens on a separate document that is 
50 percent black, procedurally blending the texture from 
the Texture Explorer and then cutting and pasting onto 
your final image.



·    Use the Glass Lens Bright on scanned Photographs for
"fish-eye lens" effects.

In Painter
To create a Glass Lens in the friskets find a feathered 
circular selection, then hold down the option key and 
drag the lens to another part of the image. This will 
make a copy of the selected area. By doing that 
repeatedly, you can add as many copies of the lens as 
you like, creating complex images in a matter of 
minutes! 

Or drag the selection while holding down the <Ctrl-Alt> 
keys and do repeat applies using <Ctrl>-f.

In Photoshop
Use <Ctrl>-f to repeat the filter function and vary the 
light position with every new apply. To make multiple 
identical spheres, hold down the <Ctrl-Alt> keys and 
click-drag the selection away to a new position. <Ctrl>-f 
will reapply the filter to the currently placed selection. 
Interesting results can be obtained with large areas that 
are feathered at high settings. Dragging the feathered 
selection away leaves a glow in the background color. In 
Photoshop, repeat apply on dragged circular selections 
for 200 balls can be done in 10 minutes, which may well 
take a full day to compute otherwise. 

In Painter
Try cutting odd shaped friskets and applying the Glass 
lenses for unusual partial spheres. This works especially 
well when the friskets are feathered.

In Photoshop
Create a glass lens in a circular selection, then hold 
down the option key and drag the lens to another part of
the image. This will make a copy of the selected area. By
doing that repeatedly, you can add as many copies of 
the lens as you like, creating complex images in a matter
of minutes! 



With the Scroll Lock on, from right to left: Eclipse view number 7, Eclipse view number 3, Full
Eclipse, scroll lock, number 5.

Figure 28    This sphere was created with one apply of the Glass Lens Bright.



Figure 29  Glass Lens Bright was reapplied to the same sphere while the "4" key on the 
keypad was held down.

Figure 30    Glass Lens was then applied to the same selection while holding down the "9" 
key on the keypad.



Figure 31    Using an odd shaped selection with feathering can create effects like this.



To go to any of the following topics, click on its title:

    Glass Lens Options

    Glass Lens Walk Through



Pixel Storm

This filter has been called the "Atomizer" by Russell 
Brown of Adobe. In principle, it is a super diffusion 
process that takes each pixel on the screen and 
disperses it by a factor of 200 pixels over the current 
selection area. It also includes a darkening apply transfer
mode. Repeated application in small areas can suck in 
neighboring colors and intensity and dissolve them in a 
veritable pixel storm, hence the name.

It may be a tiny little filter and look like utter chaos if 
applied indiscriminately across an entire image, but in 
the hands of a skilled artist it becomes a subtle mean to 
an aesthetic end.

Figure 32.    (Left) Original; (Right) Pixel Storm Applied

Key Controls and Apply Modes
On feathered selections, a different variation of 
PixelStorm can be achieved by holding down the Caps 
Lock key. By default, PixelStorm will decrease the 
amount of the effect on a feathered selection but will 
retain the color of the moved pixels. When the Caps Lock
is applied, the effect will fade out over the feathered 
area, actually blurring and blending the pixels for a 
subtle effect. The difference is most noticeable on color 
documents.

The amount of diffusion can be controlled by using keys 
"0" through "9" on the keyboard or keypad. "1" is 
assigned as the lowest amount of diffusion and "0" the 
greatest.

See PixelStorm, PixelWind, PixelBreeze Walk Through for 
examples of how to use PixelStorm.



Pixel Wind

While PixelStorm diffuses pixels based on a 200 pixel size
and uses a darken apply mode, PixelWind uses 
approximately 80 pixels but features a different apply 
mode that diffuses and enhances the image. So, two to 
three times PixelWind is not identical to one PixelStorm.

This filter is different from PixelStorm and PixelBreeze in 
that it uses a variation on the PixelStorm algorithm. For 
this reason, there is no variation when Caps Lock is 
applied. The amount of diffusion is controlled using the 
keyboard or keypad, same as PixelStorm and 
PixelBreeze.

See PixelStorm, PixelWind, PixelBreeze Walk Through for 
examples of how to use PixelWind.

Figure 33.    Original with Pixel Wind Applied



Pixel Breeze 

KPT Pixelbreeze is set at 30 pixels diffusion size. It 
features a lighten apply transfer mode, which will add 
light and fade the selection in repeated applies.

On feathered selections, different variations may be 
achieved by holding down the Caps Lock key. PixelBreeze
will act similarly to PixelStorm with the Caps Lock key 
down. The amount of diffusion is controlled using the 
keyboard or keypad, as in PixelStorm and PixelWind.

Each of the PixelBreeze/Wind/Storm filters has a unique 
character in repeated application and will yield subtly 
different effects.



PixelStorm, PixelWind, PixelBreeze

Walk Through
To get a feel for what kind of effects these filters can 
create, here are some sample exercises to highlight the 
different effects.

1.    Open the file named "KPTFACE.TGA" in the directory 
"KPT."

2.    In Photoshop, with the rectangular marquee tool, 
select one-third of the area of the picture.

3.    Apply PixelBreeze.

4.    Select one-third of the remaining picture area and 
apply PixelWind.

5.    Select the remaining area and apply PixelStorm. 
Once you have done this, you can see the differences 
between the filters. The different apply modes can be 
easily seen.

Photoshop Tips 
Used with Photoshop's Paste Controls, opacity, blends 
and blurs, a whole array of new Photoshop effects are 
born.

·    Open the file "KPTFACE.TGA" Choose Load>Selection 
from the Select menu. Try applying PixelWind or 
PixelStorm. The filters also work well with feathered 
selections (either double-click on the lasso tool to set a 
feather radius before selecting or select your path and 
choose Feather from the Select menu.)

·    To create a PixelStorm framing effect, use the 
rectangular marquee tool to drag an even rectangular 
selection inside the image area. Choose Select > 
Inverse. Apply PixelStorm to the selection. Try this with 
feathering to make the edges of the images appear to 
disintegrate.

Painter Tips 
·    Use repeated applies of PixelStorm/ Wind/Breeze and 
the Fade command to build up complex grainy textures.



To go to any of the following topics, click on its title:

    Pixel Storm

    Pixel Wind

    Pixel Breeze

    Walk Through



Grime Layer

Figure 32.    Starfield effect from repeated applies of KPT Grime Layer

Figure 33.    After several KPT Grime Layer applies, KPT Smudge Lighten creates a needle 
like effect.

Grime Layer is a seemingly innocuous little thing, tiny and fast. It applies a special grayscale
transparent noise over the selected area, subtly different from normal noise. It is handy as a 
quick way to add texture to an area, as a starting point for scratch textures and many other 
subtle uses. 

A simple example of an implied effect: use Grime Layer on a 
plain white background and repeat 4-5 times. The dark regions 
will obscure more and more space and choke the white area 
into a perfect "star field" background! It will even create the 
anti-aliased "less than one pixel" stars that are necessary for 
realistic screen images. (Single pixel dots do not look like stars!)
Try that!

Start with a new document and apply Grime Layer several 
times. Try using the Smudge filters repeatedly to create needle-
like effects. Try inverting the document.

Grime Layer will create nice fogs when used in moderate 
amounts and blurred.

Keypad controls
The application of Grime Layer is controlled with the numbers 
on either the keyboard or keypad. Pressing the "1" key will lay a 
faint gray haze across your selection while the "0" key (here 
interpreted to equal "10") will create a mezzotint-like layer of 



black grime.



Hue Protected Noise

The Hue Protected Noise filters act similarly to Photoshops 
Noise filter but preserve the hues so that a slight random dither 
texture is created rather than random noise of different colors. 
This is very effective when color must be preserved, such as 
original scans or skin tones. (The Photoshop Noise function 
applied to an RGB image will create tri-colored speckles. Using 
that on a face will add red green and blue dots to the skin tones
and "ruin" the look in the process.) 

In combination with some of the other smudge, diffuse and 
scatter tools, this is a new small brush to paint with. These 
three filters work in CMYK, RGB, Lab, and Grayscale modes in 
Photoshop. Each of the Hue Protected Noise filters can be 
controlled using the number keys or the keypad to vary the 
effect about 20% more or less intense.

Figure 35.    Notice the difference in pixellation between the top and the bottom.



The Maximum setting will create a serious amount of noise. The 
default is set at about 80% noise and may be controlled with 
the number keys "1" to "0" to cover a range of about 60-100% 
noise. The apply curve is weighted to preserve bright whites 
and blacks. This subtle feature makes a big difference as all 
previous noise generators would affect both highlights and 
background in black with high contrast opposite colors.

The Medium setting, about 50%, will generate noise with the 
same characteristics as the Maximum, but the resulting noise 
will be visible yet not harsh. The variable range that can be 
obtained using the number keys is 30-70%. 

The Minimum setting is at about 20% and is barely visible in 
most cases. That is exactly the purpose: an extremely fine 
control for ever-so-little texturizing. The variable range that can 
be obtained using the number keys is 1-40%. If you take 
standard blend you can create tiny micro perturbations with the
minimum Noise and then use Levels or Sharpen or Find Edges to
accentuate these little anomalies. 

In fact, it is such detail work that can bring natural looking 
images to computer generated art, taking away the all too 
smooth linearity and adding the chaotic fractal-like micro-
change that Nature so favors. Use it in many different 
situations. Dont give up if you dont see instant gross effects; 
this is a detailers tool.

Hue Protected Noise Walk Through
In Photoshop and Painter
1.    Open the file, "KPTFACES.TGA" in the directory KPT.
2.    Using the rectangular marquee selection tool, select a part 
of the image and then apply Hue Protected Noise Maximum.
3.    Selecting other areas, apply the Hue Protected Noise 
Medium and Minimum. This will give you a good comparison of 
each of the filters.
4.    Revert the image and try using the filters repeatedly on an 
image.

More tips
·    Less noise will create "photo grain" effects.
·    In grayscale, repeated heavy applications of noise will create 
images that simulate "random dot" halftones.
·    This filter works with RGB, CMYK, and Grayscale images.
·    The Hue Protected Noise Minimum applied in small amounts 
to blends will help prevent banding in printed work.

Painter Tip:
Using Hue Protected Noises with the Fade command will allow 



you to control noise amounts with a preview. Apply one of the 
noise filters at its maximum setting and then fade the effect to 
the desired amount.



Special Noises 

Here we have a trio of plug-ins providing unusual noises. These 
actually subscribe to the gradients (There's that old Lego block 
interconnectivity!). They can serve as a nice starting point or 
intermediate stage to build up backgrounds and textures.

Large feathered selections of Special Noise, when copied and 
pasted, then altered using paste controls can yield very new 
and subtle images. Also try processing the noises with the 
Smudge and Edges filters.

Each filter uses a different gradient with an alpha channel. The 
Blue Noise uses the gradient "True Blue Frame Round," the 
Green Noise uses the gradient "Floating Doughnut," and the Red
Noise uses "Red Plastic Overlay Frame." The method of deriving 
the Noise from the Gradient presets implies that each one has 
unique alpha channel opacity behavior. This is not simply one 
noise filter with three hue settings. Experiment!

Special Noises Walk Through
Besides creating cool backgrounds, the Special Noises can be 
used for other effects like simulating spray can or sandstone 
text.

1.    Create a new RGB document.

2.    Set the foreground color to white.

3.    Select the text tool and create a word or two, in a bold font, 
at least 96 points high.

4.    You should have white text outlined by "marching ants" 
(selection marque) on a white background.

5.    Apply one of the Special Noise filters to the selection area. 

This will fill the selection area with colored noise, creating a 
sandstone look. Feather the text outlines about five pixels. 
Feather the text and try the Special Noise filter again. The 
edges will be soft as though the letters were created by spray 
paint.



Diffuse More

This is a basic example of an extension of an already useful 
standard Photoshop tool. Photoshop's Diffuse shuffles the pixels 
in a small cell area of less than 25 pixels. Diffuse More simply 
gives you a bigger brush, set to about 4 times the cell size.

This is not simply saving you three repeats of the normal Diffuse
filter. No matter how many times a Diffuse filter is applied, the 
pixels affected will always be within a 25 x 25 pixel cell size. 
Diffuse More operates on a much larger set of pixels at once, so 
the diffusion effect will take place on a broader basis. Look at 
the sample images here to see how Diffuse More differs from 
Photoshops Diffuse filter. Better yet, try it out yourself!

Number key and keypad controls ranging from "1"(least 
amount) to "0"(representing 10, the most amount) will vary the 
intensity of the Diffuse More effect.



Find Edges and Invert

Figure 40.    Find Edges and Invert creates a "negative" effect.

This filter originally began as a re-engineered version of the standard Photoshop 2.0.1 Find 
Edges algorithm (no, we did not have any code from Adobe to do that). An exact recreation 
of the original Find Edges,* this filter provides a remedy for an old problem: often you are 
after a positive image effect and after the Find Edges you routinely will run <Ctrl>-I to invert
the image. Nice. Looks cool. Trouble is: if you dont like it and hit UNDO, only the invert step 
is undone. You're committed to the edge operation.    Find Edges and Invert is a very simple 
cure combining Find Edges and Invert in a single one-step filter, undo-able on the fly. 

Number key and keypad controls ("1"-"0", here the zero 
is interpreted to equal "10") will vary the intensity of the 
Find Edges effect from light to very intense.

    See Find Edges Walk Though for an example of how to use    Find 
Edges and Invert.



Find Edges Charcoal 

This filter, with alternate settings in the algorithm, will 
also invert the image. On a full color RGB scan often the 
results are faint grayish lines on white wherever the 
edges pass a certain threshold. 

While this can look strikingly like gray charcoal on white 
paper and earn its name, do not forget that these are 
algorithmic operations processing your existing image 
and the result will vary tremendously with different 
source material. It would be futile to name the filter 
across that broad spectrum and you should merely 
regard the name as a mnemonic reminder of the type. 

You should acquire more knowledge of its real range and 
capabilities by applying it to a variety of images, feather 
settings, and other effects and tools used in your 
drawing program.

Number key and keypad controls ("1"-"0") will vary the 
intensity of the Find Edges effect from very light to 
intense.



Find Edges Soft 

The third setting includes a softer algorithm than the 
original Photoshop Find Edges creating an effect that is 
less harsh and intense.    This one will, for instance, not 
create full rectangles around single bright pixels, but 
rather smooth edge outlines. Using the number keys "1" 
to "0" will modulate the amount of Find Edges from very 
soft to very intense.



Find Edges Walk Through
The Find Edges filters can be useful in alpha channels by 
isolating and defining areas. The Find Edges filters can 
also create effects that can be used as colorful elements 
in your image, such as this "Electric Aura" effect.

In Photoshop:
1.    Create a new RGB document. In this example, the 
image was 350 x 600 pixels.

2.    Use the text tool and create some text, 60 points or 
larger.

3.    Choose Select > Save Selection. This will 
automatically save a selection mask of your text in a 
new alpha channel.

4.    Fill the text with a gradient from the Gradient 
Designer. The one used here was "Blue Cones." which 
can be found under the Metallic gradients submenu.

5.    Deselect the active text choosing Deselect from the 
Edit menu. Apply the Gaussian Blur filter (Filter > Blur). 
Use a blur radius of about 25. This step looks to totally 
destroy your text image. It hasn't.

6.    Apply Find Edges & Invert to the image while holding 
down the "0". The result will look similar to a 
topographical map or radiating energy waves.

7.    Choose Select > Load Selection. You will see the 
outlines of your original text appear.

8.    Choose Image > Invert. Your text will invert, creating 
an effect of radiating electric type. Other variations on 
this could be to fill your selection with a gradient from 
the Gradient Designer, or to feather the selection mask 
5-10 pixels and apply    Gradients on Paths for a neon 
glowing text effect. For other variations on the electric 
aura, try Find Edges Charcoal or Find Edges Soft. To 
create electric neon auras on a satin black background, 
use Find Edges Soft with a high keypad ("7"-"0") setting.

In Painter:
A similar "Electric Aura" effect may be obtained, but the 
image that results will appear to be grayscale.

1.    Open the file "KPTFACE.TGA"

2.    Under the Effects menu, choose Focus > Soften. 
Soften the image 10-12 pixels. This will blur the image 
extremely.



3.    Apply "Find" Edges and Invert. This will create a 
depth gray stylized image.

Figure 41.    The original text, to be used with KPT Find Edges and Invert.

Figure 42.    Selection created with rectangle marque tool, feathered 10 pixels.

Figure 43.    Find Edges Charcoal applied to the selection.

Figure 44.    Find Edges and Invert applied to the selection.



Figure 45.    Find Edges Soft.



To go to any of the following topics, click on its title:

    Find Edges and Invert

    Find Edges Charcoal

    Find Edges Soft

    Find Edges Walk Through



Scatter Horizontal

Scatter Horizontal is an unusual special case filter: this one 
diffuses only on the horizontal axis, and it includes a lighten 
apply mode. This filter really comes into its own with several 
repeated applies, stretching a selection and swallowing certain 
features while bringing out others. A unique streaking trailing 
effect can result. It's an odd shaped brush in your palette, but it 
does have its moments. 

Here's a suggestion to expand its use: you can rotate the 
window or selection 90 degrees to get a vertical version 
(multiple crossed repeats of both can do neat cloth-like stuff) or 
invert the image to have a "darken" effect. Many peculiar 
combinations with the other filters are yet to be tried by 
someone. Be the first one to discover them! 

The degree of effect obtained with Scatter Horizontal can be 
controlled by holding down one of the number/keypad keys. "1" 
will render a faint effect, while "0"(here it equals "10") will 
render an extreme effect.

Walk Through
In Photoshop and Painter:
1.    Open an RGB file. Apply Special Green Noise. Then do 
several applies of Scatter Horizontal until it seems as though 
most of the green has disappeared. Invert the image and 
continue.
2.    Rotate the image by 90<Insert special character>.    Select 
one of the Red, Green or Blue Channels. Repeat apply Scatter 
Horizontal to that channel only. Look at the result in full RGB 
view.

Figure 46    (Bottom) Scatter Horizontal repeatedly applied 
"noisy" background, then inverted and applied a few more 
times.    A center selection was erased to white, and more 
Scatter Horizontal was applied to the entire file.    (Top) Scatter 
Horizontal applied to one channel of a rotated file (this is the 



blue channel).



Page Curl

Page Curl simulates the effect of a page being peeled back, with
a highlight running along the center of the curl and a shadow 
being thrown beneath the image.    (Your image must be light 
enough to see the shadow.)    The color beneath the curl is 
determined by the background color selection by the 
application.

The curl begins in one corner of your selection and follows a 
perfect diagonal to the opposite corner.    You may also notice a 
slight transparency to the curl if there is any pattern or texture 
in the selected portion of the image.

The origination point of the curl is controlled by using the 
numeric keypad.    The placement of hte numbers on the keypad
is analogous to the corner that will be affected.    The vertical or 
horizontal orientation of the curl is controlled by the Caps Lock 
key.

To curl this corner: Press this key:

Upper left 7
Upper right 9
Lower left 1
Lower right 3

Curl Orientation Caps Lock key is:
Vertical up (off)
Horizontal down (on)

A simple black circle with grime layer applied, and Page Curl holding "3" and then "7" on the 
Keypad.



Notice the translucent effects.    The curl was done with the "3" on the number pad.

Page Curl Walk-Through

1.    Create a new RGB or Grayscale document, 300 pixels by 
300 pixels, 72 DPI. (Or load KPTFACE.TGA)

2.    Select the entire image and fill with any color.

3.    Apply the Page Curl filter.    Notice how the page curl forms a
diagonal line across the entire image.



Welcome to Kai's Power Tools Explorer's 
Guide for Windows!

Kai's Power Tools for Windows consists of 33 different 
filters for plug-in compatible graphics programs such as 
Adobe Photoshop . 

The Kai's Power Tools for Windows plug-in filters fall into two different classes: User Interface 
Filters (U-I) and One Step Filters.    The User Interface (U-I) filters have a dialogue box that 
requires user input (read fun) before applying the output to a selected object.    The KAI 
filters which use U-I's are the Gradient Designer, Gradients on a Path, Texture Explorer and 
the Fractal Explorers.    The other KAI filters are one-step filters; select an object, choose the 
appropriate KAI filter, and enjoy the results.



Configuration

Windows
KAI for Windows requires an application that uses a 
compatible plug-in architecture like Photoshop . 

We recommend that Windows be run in Enhanced Mode.    To ensure you are running in 
enhanced mode, choose About Program Manager from the Help menu.    If you are not 
running in Enhanced Mode, please refer to your MICROSOFT WINDOWS USERS GUIDE.

You should also be familiar with basic Windows functions,
such as working with documents, windows, menus, 
dialogs, and the mouse.    If you are not familiar with 
these operations, please refer to your MICROSOFT 
WINDOWS USERS GUIDE.

Storage
KAI for Windows requires approximately of 8 MB 
(megabytes) of hard disk storage. 

System Memory
If you have enough memory to run either Photoshop or 
Painter, you probably have enough memory to run KAI 
for Windows.    In any event, 4 MB of RAM is the minimum
and 8 MB of RAM or more is recommended.

VGA Support
KAI for Windows supports all video modes from Super 
VGA (640x480x256 colors) to 24 bit color (16.7 million 
colors) at any resolution.    Some video cards attempt to 
simulate 24 bit color through their software drivers.    
These video drivers will typically allow the user 32,000 or
65,000 colors.    

It    looks much better on the screen than 256 colors.    
But, because all of software solutions used by various 
video card manufacturers are different, KAI for Windows 
cannot guarantee success with these drivers under all 
circumstances.    Use 24 bit color whenever possible, 
even if it means moving to a smaller screen resolution, 
such as from 1024x768 to 800x600.    

In the long run, the results are more impressive.        
Consult your graphics card's documentation for optimal 
setup parameters.

Mouse
KAI for Windows requires a mouse or compatible pointing



device.



Before you start

Your set of Kai's Power Tools contains the following items:

·    Read Me- This file contains important information that 
may not be in your User Guide.
·    Installer- This will install the KAI filters onto your hard 
drive.
·    KAI Sample Tips and Images-    Four of Kai's innovative
tips for use with Adobe Photoshop along with example 
images.

Your package of KAI also includes a registration card, and
this user guide. Please take a minute right now to fill in 
your registration card.    It guarantees your notification of
future upgrades and new products. You must be a 
registered user to receive telephone technical support.



Installing Kai's Power Tools for Windows

1.    Insert Disk #1 "Installing KAI for Windows" in your 
"source" or floppy drive. (Usually A:\.)

2.    Choose the "Run" command from the Program 
Manager File Menu.    The "Run" Dialog box appears.    

3.    Type "A:Setup" on the Command Line text box, and push the "Enter" key or click "OK." 
(Use your source drive if it is not the A: drive.)

4.    KAI for Windows Installer will suggest a default directory of C:\KAI.    Press "Enter" or click 
"OK." (You may change this directory location if you wish.)

5.    Another dialog box appears.    Your options for this 
dialog box are:
a.    Plug-ins
b.    Install Presets (Presets are settings used by the 
Gradient Designer, Gradients on Paths, Julia Set and 
Mandelbrot Set Explorers so you have great color 
combinations from the start.)
c.    Kai's Power Tips
d.    Sample KAI Graphics

Note: If this is a new installation, please complete a full installation.    
The KAI for Windows Installer will create a default directory called "KAI"
which will contain the "Sample Files" and the "Readme" files    The 
actual "Plug-ins" and "Preset" information will be installed in a "Plug-in"
directory with the application that uses KAI for Windows.    After making
your selections, press "Enter" or click on "OK."    The KAI Installer will 
begin to install KAI for Windows.

6.    Insert the other installation disk(s) as prompted by 
the computer. 



Technical Support

If you need technical assistance, registered users may 
call KAI Technical Support, 9 a.m. to 5 p.m. PST, Monday 
through Friday at (310) 392-8441. When you call for 
technical support, please let us know what products you 
are using with KAI, i.e. Photoshop under Windows 3.1, 
and have your video card information handy. 

The information we are looking for is what type of video 
card you have and what mode you card is running in.    
The type of video card is either a manufacture's name, 
i.e. ATI Ultra Graphics Pro, or a chip type, i.e. S3.    The 
mode describes the number of colors you can see on the
screen.    24 bit color, for instance, refers to 16.7 million 
colors, or what is considered the light spectrum for the 
human eye.    16 bit color, which still looks pretty good on
the screen, is roughly 32 thousand colors, while 8 bit 
color is 256 colors. 

The very best way to reach us and receive technical 
support, updates, great hints and other information is 
either through America Online or CompuServe.    To reach
our forum on American Online, keyword GO KAISUPPORT. 
To reach us on CompuServe, GO KAISUPPORT. You may 
also send e-mail to KAISupport for technical assistance 
and general questions. If you wish to contact us through 
the Internet, send e-mail to kaisupport@aol.com.



To go to any of the following topics, click on its title:

    Configuration

          Windows
          Storage
          System Memory
          VGA Support
          Mouse

    Before You Start

    Installing Kai's Power Tools

    Technical Support







Technical Support

Technical Support questions:
America Online:    GO KPTSUPPORT
CompuServe @ GO KPTSUPPORT
Internet:    kptsupport@aol.com

HSC Software 
1661 Lincoln Boulevard #101
Santa Monica, CA 90404
(310) 392-8441 voice
(310) 392-6015 fax

Your very best bet is to get onto America Online and get direct 
support from us.    We have a company support section in 
Industry Connection in the Computing and Software 
department.    Latest product news, discussion board, software 
and the full library of Kai's Power Tips are available there.    E-
mail should be sent to "KPTSupport." 

If you are on CompuServe, GEnie or other services, find out how
to send mail via internet gateways.

Our Internet address is "kptsupport@aol.com"
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How to use the "Explorer's Guide"

The "User's Manual" or "Explorers Guide" is not designed to 
provide a detailed definition of how Kai's Power Tools work.    In 
many cases the explanation is too complex, and in all cases, the
tools are too much fun!    Instead, all the Filters are explained, 
one by one, from the User-Interface Filters to the One-Step 
Filters.    

We recommend starting with the User-Interface Filters, 
particularly the Style Setup and Gradient Designer, it's up to 
you.    Just find a KPT Filter that looks interesting and turn to that
chapter for an description (and some cool hints).    You'll have 
some real fun on your own...With Kai's Power Tools the 
adventure is just beginning!



As you are reading this manual, we refer to Menu Items.    These Menu Items are Pulldown 
Items and Hierachial Items.    The actual syntax will be Filter>KPT Extensions>(U-I filter of 
your choice) for the U-I filters and Filter>KPT>(one-step of your choice) for the one step 
filters.    The Pulldown Item is the first one mentioned.    It belongs to the Application's Menu 
Bar.    The second item listed will be a pulldown selection underneath the Menu Item.    The 
third selection will be more menu choices. All of Kai's Power Tools are located in the 
appropriate "Plug-ins" sections of your favorite plug-in compatible program.    



Style Setup

The Style Setup is the first of the user-interface (U-I) 
filters. This filter, or plug-in allows the user to change the
default parameters of how they will interface with the 
other U-I dialog filters.    It acts as a "Central Preferences"
or    "HUB" file for the U-I filters.    When a U-I filter is 
selected, the user preferences file is scanned and user 
preferences displayed.    

The selections are very easy. The first user preference is 
what the interface looks like.    Your choices are a 24-bit 
style with turquoise green/orange, an 8-bit restrained 
"text objects in gray," or 256 color mode. 

The second selection is "Pre-lighting." "Pre-lighting" is a 
feature where the buttons and balls can "sleep" and 
"awaken" only when the cursor comes close to them.    
These are the only choices to be made at Style Setup.    
Choose the U-I style of your choice and click on the "OK" 
button.

Figure 1.

The general controls for the U-I filters are shown in Figure 1. The "?" or help button and the 
"NO" and "OK" buttons are the only buttons that work in Style Setup.

Working with the KPT User Interface
The KPT User-Interface is the Dialog Box where the U-I 
Filter requests user information before carrying out its 
designed function.    The KPT U-I filters are the Gradient 
Designer, Gradients on Paths, Julia Set Explorers, 
Mandelbrot Set Explorer, and the Texture Explorer.    
These U-I Filters have some common elements.    These 
elements are the Temporary Re-size Option, the 
Moveable Interface and keyboard controls or Keyboard 
Equivalents.



Temporary Re-size Option

Clicking on the KAI circular logo changes the U-I to a small circle or icon displaying a 
subsample of the U-I preview window. If you need to make the interface smaller to refer to 
the original image, you can toggle the interface back and forth between full size and icon 
size by clicking on the KAI logo. With the U-I reduced, you can move it around your screen by
clicking and holding while dragging to a new location.    If you are a Windows power-user and 
frequently toggle between applications using <Alt> TAB, you will notice that with a U-I filter 
fully displayed, you cannot toggle between applications.    When the U-I is reduced, you may 
toggle to other applications.    When you return, the U-I redisplays at full size.    If you reduce 
the U-I filter and cannot find it in your window (probably hiding behind something) just hit 
the <Enter> key.

Movable Interface
The U-I dialog boxes can be dragged around your screen 
by clicking and dragging anywhere on the U-I with the 
right mouse, OR with the left mouse button plus the 
Control Key.    You may also drag by clicking on the Title 
Bar except for the Gradient Designer and Fractal 
Explorers.    When you move the interface around on your
screen, the image behind the dialog box will redraw 
itself.

Keyboard Equivalents
All KPT interfaces have keyboard equivalents for the 
buttons.    They are:

OK return, enter
NO Esc
Add (preset) A
Delete (preset) D
Help (?) ? (shift-/)

To go to any of the following topics, click on its title:

    Working with KPT
              User Interface

          Temporary Resize Option
          Movable Interface



Gradient Designer

Gradient Designer is the foundation for several U-I filters 
in the KPT filter set. It enables you to design complex 
color gradients and to save them as presets to be used 
by other KPT U-I filters. This is where the "Lego<Insert 
special character>" building block philosophy behind 
Kais Power Tools becomes apparent. Not only are 
Gradient Designer Presets part of a tool for the straight-
forward creation and application of complex blends, they
are a resource for other KPT filters too.

Gradient Designer Preferences
Clicking on the large top button that says "KPT Gradient 
Designer" brings up a dialog box asking the user to 
choose the Gradient Designer viewing preferences.    
These preferences determine which gradient the user 
wishes to view when the filter launches.    They are:
·    Load normal gradient from image
·    Load smooth gradient from image
·    Return to previous state 

The first two load a gradient based on your image or 
selection area. It loads color from a horizontal strip 
across the middle of the selection. "Load normal gradient
from image" will load the color selection uninterpolated 
or anti-aliased. The second, "Load smooth gradient from 
image" includes the same colors as the normal gradient, 
interpolated to a smooth blend. 

The third, "Return to previous state," remembers the last
gradient you applied and will display that gradient the 
next time the filter launches.    If you choose "Return to 
previous state" and you forget to save your selection as 
a preset, the gradient will be waiting for you the next 
time you open Gradient Designer. You may override any 
of these preferences and display a white Gradient Bar by
holding down the Control <Ctrl> key as Gradient 
Designer is selected from the KPT Extensions menu, or 
you may clear the Gradient Bar to black by pressing 
<Ctrl-Z) just after starting the Gradient Designer. 

      Click on the boxes outlined in green for more details.



The Movable Bracket
The Movable Bracket (Figure 1, 6) defines the area within
which the blending occurs. The    default setting spans 
the entire width of the blend. You can: 

·    Drag the bracket ends to resize it. 
·    Drag the top center to move entire bracket.
·    Double-click the center to reset to full size. (default)

If the Movable Bracket spans the middle third of the 
Gradient Bar, the blend affects only that area. It will not 
change the colors outside the bracket.    Adding a new 
color at the left edge creates a smooth blend from the 
new color toward the right, but a hard blend to the color 
immediately to the left of that bracket edge.

Using the Movable Bracket enables    you to make many 
short little blends and create composite long multi-
colored complicated blends, as you will find in the 
presets.

      Click on the boxes outlined in green for more details.



Figure 1.

The Gradient Bar
The Gradient Bar is directly underneath the movable 
bracket.    It displays the gradient colors you have chosen
and blend or interpolation of those colors.    When you 
click on the Gradient Bar, the Color Spectrum Bar will 
appear.

The Color Spectrum Bar
The Color Spectrum Bar displays the main color selection
area. 

The Color Spectrum Bar has over 400 hues of the 
RGB/HSL (Red, Green Blue/Hue,Saturation,Light) color 
spectrum in the center at full saturation. Moving to the 
top of the Color Spectrum Bar, each full shade modulates
toward white; moving to the bottom of the Color 
Spectrum Bar, each hue modulates toward black.    This 
allows immediate access to about 40 shades of varying 
intensity within the one mouse click-hold-drag motion.

Also included are 7 additional spectra, including like full 
modulation (RGB range), Metallic Dark Glow, Light 
Pastels, and a spectrum optimized for CMYK 
reproduction.

The Color Picker
When you click and hold on the Gradient Bar underneath
the Movable Bracket, you will instantly access the Color 
Picker. The Eye Dropper represents the Color Picker and 
samples any color displayed in the Color Spectrum Bar, 
or on the screen.    

When you release the left mouse button, the color 
interpolates smoothly to the range of the blend area. 
There are over 500 shades of color. The gradient is 
applied and scaled to any size and resolution, so this is 
not 500 pixels "resolution", rather, there are over 500 
possible separate colors in the gradient.

With this click-drag-release motion, it takes about a half-
second to select a 24-bit color.    Above the color 
spectrum bar is a grayscale ramp for instant selection.

To cancel a selection, release the mouse in the area 
immediately underneath the Gradient Bar (the numerical
readout area) or hit the Escape Key.

Transparency



The Gradient Designer treats NONE (or completely 
transparent) as a color.    That is, you may blend 
complete transparency as part of your gradient. The 
image underneath will "show through" at that spot.    In 
the Gradient Designer, when you choose NONE, the 
underlying image is represented by a black and white 
checkerboard pattern, giving a quick and accurate 
overview of which parts of the underlying image will 
show through. 

 When applying the filter by clicking    the "OK" button, 
there is, of course, no checkerboard pattern in the 
application area.    The image underneath the area of the 
gradient represented by the checkerboard will be visible. 
Directly underneath the Color Spectrum Bar is the 
Opacity Selection Bar.

Opacity Selection Bar
The Opacity Selection Bar is a checkered bar that fades 
from totally opaque (black) to clear (transparent). 
Selecting from the right side, where it is clear, blends 
more transparency. A selection from the opaque (black) 
section on the left will blend in slight transparency. 

The Opacity Selection Bar operates independently over 
the area. It differs from "none" which treats transparency
as if it were a color. The Opacity Selection Bar controls 
the saturation of the color you are blending.    See the 
Figures 2 and 3 for a comparison of the difference.

Figure 2.

Figure 3.    Notice how the blend moves from transparent(left) to opaque(right).



Use the "Silver Coils" ("Basic Gradients" Category) preset.    Using the Opacity Selection Bar 
to blend opacity from the left side. Notice the checkerboard has appeared in the Gradient 
Bar.    

The amount of checkerboard visible allows you to judge how much of the underlying 
selection will show through. Where NONE allows everything to show through, the Opacity 
Selection Bar allows control how much will show through (opacity), and the color you use to 
"veil" the underlying object. The coloring remains in the gradient; only opacity values have 
changed.    The real-time preview allows viewing of the gradient with its relative 
transparency/opacity values and how it will apply to the selection area.

In Figure 3 the preset is altered by blending in "NONE" 
from the left hand side. Note that blend moves from 
transparent on the left to the fully opaque on the right. It
is a simple blend between two values.

Numerical Readout
When you click on the Gradient Bar to choose a color, 
you will notice a Numerical Readout directly underneath, 
between the Gradient Bar and the Color Spectrum.    The 
numerical readout represents Red, Green, Blue and 
Opacity values from the sample color picker location. 

 As you drag the cursor across the screen notice the 
values change constantly.    The numerical scale runs 
from 0-255.      255 represents full saturation of any or all 
of the red, green or blue color values. For Opacity, 0 
represents full transparency, whereas 255 represents full
opacity.    These numbers are for display only, values 
may not be entered here.    

At the left of the numerical readout bar is a circle giving 
access to the Windows System Color palette.    Colors 
selected through the Windows System Color Palette are 
applied as any color selection with the Color Picker.



Gradient Designer Apply Modes

There are several options that change the application of 
the current gradient to a selection or image. The three 
boxes in the top center will show at a glance what the 
settings are at any one time. 

The left and center are pop-up menus. Click and hold to 
see all available alternatives, drag to your choice and 
select. The Direction Control, on the right, adjusts and 
previews in real time as you click-hold-drag-release.

The Preview/Mode Control (Figure 4), the left most 
box, shows the current style by rendering a sample 
gradient into the box. It is a pop-up menu with four 
choices:

·    Linear Directional 
·    Circular Sunburst 
·    Radial Sweep
·    Square Burst    

      Click on the boxes outlined in green for more details.

Linear and Sunburst (called "radial" in Photoshop) options have always been part of the 
Photoshop blend tool dialog. New application styles in the Gradient Designer include Radial 
Sweep style, which is like a clock hand or a radar screen sweep drawing 360 degrees, and 
Square Burst, which is a rectangular and can be used with transparency to create uniform 
framing effects.

The Loop Control, the center box, displays the repeat 
mode or loop. There are four options here: 

·    Starting the gradient at the left-most color and 
executing the gradient style to the right- most color 
once. 
·    Starting the gradient at the right-most color and 
executing the gradient style to the left- most color once. 
·    Starting from the left-most color to the right-most 
color and back.
·    Starting from the right-most color to the left-most 
color and back.



The Mode Control causes different gradient effects.    
For instance, the Sunburst ("radial") blend can create 
ball (with sawtooth) or doughnut (with triangular) 
shapes. The Radial Sweep style creates symmetrical 
color blends and "dimple" like center shapes. (Try 
twirling such a shape.)

The Direction Control, the right box, controls directional 
styles. Click inside and a vector will snap to that angle. It
will apply to the linear and radial sweep styles. Holding 
the shift key while selecting direction constrains the 
angle to 45  increments.

About Presets

      Click on the boxes outlined in green for more details.

Figure 5.

The Gradient Designer comes with over 150 presets that you can use directly or gain ideas 
from for custom color blends. Presets are saved in hierarchical families. To cycle through the 
presets in a category, you can use the    arrow keys. 

To navigate to: Press this key:
Next preset down arrow
Previous preset up arrow
Next category right arrow

(also page down)
Previous category left arrow

(also page up)

Presets can be added and deleted very easily. Click on 



the ADD button to add the current blend as a preset.    A 
dialog box will ask you to    name your new preset. 

When you add a preset, you can make your own 
categories as well, such as saving all your own 
concoctions in Bobs Weird Blends. When you add a 
category, you will go through a two-step naming process.
First, you name the category, and second you name the 
preset. The top of the dialog box will direct you 
depending on whether you are naming a category or 
naming your new preset. 

Presets are saved in their own central files called 
GRADIENT.PST and PRESET.KPT.    PRESET.KPT and 
GRADIENT.PST are accessed by all other KPT filters 
using gradients. Whenever you make a new preset you 
are changing those files.    Be sure to back up 
PRESET.KPT and GRADIENT.PST files as you would any
other file or document you create.

Click the DEL button to delete the current preset. 



Gradient Designer WalkThrough

This walkthrough will provide you with some rough 
"jumping-off" places for your exploration. Approach this 
with an open mind, and click "ADD" and save anything 
you like along the way! 

There is really only one gradient rule: 
If you see something you like, save it as a preset.    Other
U-I's will use those presets.    

1.    Click and hold on the far left side of the Gradient Bar,
drag to the color you like and release, e.g. "red." Now 
repeat on the far right side of the Gradient Bar, e.g. 
"yellow." 

2.    Add a third color:    After you set the far left and right 
edges the way you like them, you can now add another 
color anywhere in the middle of the Gradient Bar by 
clickdrag-to-colorrelease. It will interpolate smoothly to 
the side colors, e.g. "red" to "white" to "yellow."

3.    Adjust the Movable Bracket. Make the bracket's size 
smaller so that it takes up a portion of the entire space. 
Sample and blend another color.

      Click on the boxes outlined in green for more details.

Figure 6.

How to soften "hard" color edges



Make the smallest possible bracket (about 512 pixels) 
and position it over a hard edge. Then click and release 
at either edge of the bracket. It will pick up the color of 
the blend at that point and smooth it to the bracket 
edges.

How to add transparency
To make a blend from "Red" to "Nothing," choose red at 
the left edge and "None" at the right. It will smoothly 
fade out the red and become increasingly transparent, 
all the way to no color at the far right.

Working in RGB and CMYK
The Gradient Designer will output to CMYK as well as 
RGB. There are two ways to produce CMYK legal colors.    
First, design in RGB and change to CMYK before you save
the file. KPT does not warn you if your colors are not 
CMYK legal as you choose them, however.    

To ensure consistent CMYK legal values, start your new 
document as an RGB and choose the "CMYK Modulated" 
from the "Sprectra" menu on the color bar in Gradient 
Designer.    

If you work solely in CMYK, it's probably best to code 
name your presets "CMYK" so you know which ones they 
are, even though you are still working in RGB, however. 
Working from the CMYK Legal Gamut means that you will
not experience any change in color from KPT generated 
artwork when you convert from RGB to CMYK mode.

Tips
Painter's "Fade" Command will enable you to "undo" the 
last change you made to any degree of transparency you
select. This allows for subtlety "after the fact." 

To create a Fade, select Edit>Fade. The "Fade Last 
Operation" dialog box appears. Move the slider until the 
preview reflects the amount youd like to fade (use the 
hand icon to scroll around in the preview window). Click 
OK. 



Designing Complex Gradients

The primary purposes of the Gradient Designer is the 
design and application of not one or two colors, but 
multiple colors, interpolated over a wide area or small 
area, including transparency, opacity.    In some respects,
the Gradient Designer is almost a sophisticated 
paintbrush, applying the colors , opacities and 
transparencies to the underlying image.

The Complex Gradient
Start with a new document, 540 pixels by 360 pixels, 
RGB.    Select the Gradient Designer.    Press Ctrl Z.    This 
will turn the Gradient Bar (where the color selection are 
displayed) black.

Grab one end of the Movable Bracket and make the 
bracket as small as possible.    (Figure A.)    

Figure A.    The highlight directly underneath the bracket represents the selection area.

Center the eyedropper directly under the bracket, click and move to a gray portion of the U-
I, and release.    (Figure B.    We are picking up a 170 gray.)

Figure B.    After releasing in the body of the U-I the color interpolates over the selection 
area.

Move the bracket to the left side of the bracket    is directly to the right and slightly past the 
gray band.    (Figure C.)



Figure C.    Ready to select gray again.

Pick the same gray color.    Continue until the entire Gradient Bar is full.    Figure D shows the 
proccess partially completed.    After completing the gradient, save it as Rolled Silver under 
Complex Gradients.

Figure D.    Note the preview window.



Figure E.    Completed and ready to save as a preset.

The Framing Gradient/Transparency
Creating a framing gradient to wrap around or apply to a
selection is the next step.    Taking the "Rolling Silver" 
preset created earlier, add transparency to the right 
side.    Shorten the Movable Bracket so that it only covers
five or six of the "coils."    Within the selection area, click 
and drag to "NONE."    None is treated as a color in 
Gradient Designer.    The Preview now shows the fanfold 
type displayed in Figure F.    Save the gradient as "Rolled 
Silver Transparent" under the Complex Gradients 
category.



Figure F.    Transparency is added which results in a "framing effect" gradient.

Load the file KPTFACE.TGA.    Bring up Gradient Designer.    Load the Rolled Silver Transparent
preset.    Apply the gradient to KPTFACE.TGA.    The results should look like Figure H.    

Figure H.    KPTFACE.TGA after the framing gradient "Rolled Silver Transparent" is applied.

The "NONE" selected in the gradient allows the underlying image to show through.    With a 
little experimentation, even neater effects can be achieved.    Do not save KPTFACE.TGA with
the gradient applied.

The Framing Gradient/Opacity
Load KPTFACE.TGA again.    Load the preset "Rolled 
Silver" again.    Use the Movable Bracket to select the 
right half of the Gradient Bar.    Position the cursor to the 
far right of the Gradient Bar.    Click (the cursor turns into 
an eyedropper) and drag to the Opacity Selection Ramp. 

As the eyedropper moves up and down the Opacity 
Selection Ramp, the values in the numerical readout 
change.    Select an opacity value of "10", and apply the 
gradient to KPTFACE.TGA.    Notice the difference 
between using "NONE" as a color and using differing 
levels of opacity, particularly applying opacity as you 
would apply a color from the opacity ramp.



Gradients on Paths

      Click on the boxes outlined in green for more details.

Gradients on Paths can "wrap" any blend smoothly around a free-form user defined path. 
This creates unique effects like glows, halos, rainbows, metallic tubes, lasers, fogs and 
complex type outlines. All gradients designed by Gradients on Paths are presets from the 
Gradient Designer.    Gradients on Path uses two blends, one for color and one as an alpha 
channel to fade in and out and blend with the original image.

In order to access Gradients on Paths:

From Photoshop
To access and use this filter, you need to create a 
feathered selection in Photoshop. To do so, use the lasso 
and/or other marquee tool to select an area. Choose 
"Feather" from the Select menu. Enter a value from 1 to 
99 pixels. This will determine the width of the path. 
Select the filter Gradients on Paths from the Filter > KPT 
Extensions menu. 

From Painter
To access and use this filter, you will need to create and 
feather a frisket in Painter. Select the frisket using the 
Frisket Selection tool, and display it with marching ants 
showing. Then select KPT Gradients on Paths from the 
Effects > KPT Extensions menu.
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Moveable Bracket    
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Opacity Selection Ramp    



Numerical Readout Bar    



Grayscale Ramp    



Color Spectrum    



Transparency Ramp    



Preview/Mode Control    



Loop Control    



Linear Direction Control    



Preset Menu    



"Shortened" Bracket    



Add/Delete Preset Buttons    



"Hard" Edge    



Blur Control    



Apply Modes    



Gradient Presets    



Color Loop Control    



Alpha Channel (inside) Gradient    



Framing (outside) Gradient    



Preview Window    



To go to any of the following topics, click on its title:

    Gradient Designer 
            Preferences

          The Movable Bracket
          The Gradient Bar
          The Color Spectrum Bar
          The Color Picker
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          How to Soften "Hard"
              Color Edges
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          Tips
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            Gradients
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          The Framing
              Gradient/Transparency
          The Framing
              Gradient/Opacity

    Gradient On Paths



Sharpen Intensity 

Sharpen Intensity applied to an image will yield stronger 
contrast and brighter colors. This is a good tool for brightening 
up an image. Use it as a first step. For correction of scanned 
images it will "unch up"the colors. In the best situations, the 
resulting image will look so much more vivid, that an undo to 
the previous version will seem as if it had a drab hazy gauze 
layer over it. 

Repeated applies of Sharpen Intensity will posterize an image. 
With extreme repetition you may converge on black and 
oversaturate your image, but used in controlled dosage the 
filter is extremely effective.

Figure 36.    Original Image

Figure 37.    Three applies

Figure 38.    Five applies



Figure 39.    Ten applies

Modulating Sharpen Intensity
The degree of Sharpen Intensity' effect is controlled with the 
keyboard/keypad. Pressing the ""key will faintly increase the 
intensity while the "0" key (here interpreted to equal "10") will 
intensify your image to the point of saturation.

Tips for Photoshop and Painter
·    Punch up the colors on scans that are too light or lack color.

·    Try it on a face or flowers or similar strong hue scanned 
image. Applying the filter to rectangular strips can create visual 
accents and variety.

·    Multiple applies creates a posterized look with intense high 
contrast colors.

·    Use with grayscale documents to create images that simulate
photocopies or line shots from a process camera.

·    Try applying the filter to feathered selections to boost the 
color and contrast on dull areas.

Tip for Photoshop only
After converting an image from RGB to CMYK, try applying this 
filter. It is not an instant color-correction filter, but will 
sometimes help regain some of the bright, contrasting colors 
that were lost.



Previews and Controls

The top right Gradients on Paths Preview Window 
displays the combined effect of the current gradient and 
alpha channel. 

The Framing Gradient Preview 
This displays in color, any preset from the Gradient 
Designer. Depress the mouse in Gradient Preview and it 
displays a menu of Gradient Designer presets.

Figure 8a.    Beginning with the Gradients on Paths setting "Luminous Metal Tube" This 
row was actual rendered with Procedural Blend (the actual preset is "Medium blur").    
Notice how the background texture affects the manner in which the gradient is rendered.    
You can also see this where one gradient is applied on top of another, right.

Figure 8b.    This row was rendered using the "transparent" setting.    Where the Alpha 
Channel Gradient is darker, the gradient is translucent. You can see this in the double apply: 
a bit of light "halo" overlays the first "metal tube."

Figure 8c.    Random Noise applies noise where the Alpha Channel Gradient is dark.    The 
darker the gradient, the more noise.    On the overlay, the second Gradient on the Paths 



overlay was rendered using the Alpha Channel Gradient Transparency Masks>Black to White
Linear.

The Alpha Channel Gradient Preview 
This displays the current alpha channel setting. It, too, is 
a pop-up menu that accesses all the presets from the 
Gradient Designer and displays them in grayscale. It has 
three other settings in addition to those presets.    They 
are "Full Opacity," "50% Opacity," and "Default to Color 
Gradient."

A full explanation of Alpha channels is available in the 
Photoshop Manual.    A brief recap: Alpha channels serve 
as masks. Masks "block out" areas and let other areas 
"show through." Whenever the channel is white, the 
channel lets the image or effects show through. 
Whenever the channel is black, it blocks out the image 
or effect. Values between black and white block out or 
show through some degree of image or effect. The Alpha
Channel Gradient controls what portion of the Framing 
Gradient will show. (This function is different from an 
alpha channel's, or Painter's Frisket Mask's function of 
storing a selection.)

Blur Control 
The box to the left of the Framing Gradient controls 
blurring of both the color gradient and the Alpha Channel
Gradient. The choices range from "None" to "Heavy." 
(Figure 8)

Apply Mode Control
The Apply Mode Control box allows you to control the 
effect that the alpha channel has on the rendered path 
effect. There are three settings: 

·    Normal Transparency
·    Random Noise
·    Procedural Blend

Normal Transparency will "airbrush" your effect onto any 
path to a degree modulated by the alpha channel. A 
white, "100% Opacity" alpha channel will completely 
wipe out whatever is below the path; darker shades of 
gray will let more and more of the underlying image 
show through. 

Random Noise replaces transparency with hue-protected 
noise (see KPT Hue-Protected Noise for a detailed 
description). "100% Opacity" as an alpha channel yields 
no noise effect; darker gray areas of the alpha channel 
yield higher amounts of noise.



Procedural Blend will "wrap" the airbrushed path around 
the contours of the image below. More details on the 
Procedural Blend are in the description of KPT Texture 
Explorer.

A side-by-side comparison of the different types of 
effects you can get with the Blur and Mode controls is 
shown on the previous page in Figure 8.



Photoshop Walk Through
Here's an example of how Gradients on Paths combined 
with Photoshop's channel calculations can create 
stunning effects. 

1.    Create a new file. Since we are going to be doing 
some channel calculations, begin with grayscale. Our file
size is 540 x 360    pixels. We will change to RGB later.    
Open "Show Channels" from pulldown menus. 
Window>Show Channels or F6.

2.    Create a feathered selection. In this case we use a 
value of 15 by double clicking on the lasso tool and 
entering the value of 15 at the feather radius dialog. 
After making the feathered selection, go to the Select 
menu and choose Save selection (selection is now #2).

3.    The Channels Dialog now shows both the black 
channel and the selection #2.    If you click on selection 
#2 you will see a feathered white selection surrounded 
by black.

4.    Deselect the "marching ants" <Ctrl D> and select 
the Type Tool. Create a character or two at 128 point 
type or larger, with the anti-aliased option checked.    
Align the type in the center of the screen.    With the type
selected (marching ants around its perimeter), go to the 
Select menu and choose Save Selection > New. This is 
now channel #3, a source for selections for future 
feathering. 

5.    Delete the character(s) if they were "dropped" onto 
the surface of channel #1, so that there's a blank white 
window and deselect. Load selection #3 
(Select>Load>#3). There should be marching ants for 
the type outlines. 

6.    Go to Select > Feather. Here we entered a value of 4.
Select > Save selection > New.    There is now a Channel 
#4 in the channel dialog box.    Deselect.

7.    Now is the time to enter into fun things with 
Photoshop's channel calculations. We are going to 
combine the two feathered selections and derive a new 
selection from that to render a gradient along a path. In 
this case, we will use the Difference command.

CHannel OPerationS (CHOPS)
8.    Under the Image menu, select Calculate >Difference.
For Source 1, select Channel #4 (the feathered type). For
Source 2, select Channel #2. If you switch these around, 
it will not affect the outcome. Make the destination the 



file you are working on, New Channel.    The channel 
dialog now shows 5 channels.

9.    Switch back to Channel #1. Under the Select menu, 
choose Load Selection > #5. Now you have a selection 
with a lot of "gray" area along which the gradient will be 
rendered.

10.    Select KPT Gradients on Paths from the Filter menu. 
Select a Gradients on Path preset.    Click OK. 

To render the gradient in color:
11.    

a. Duplicate Channel #1 
(Image >Calculate>Duplicate) to a new/new destination.
(This should be a completely blank window; erase if 
necessary.)
b. Under Mode, select RGB.
c. Now select Image>Calculate>Duplicate> Source <the
first file/Channel #5> Destination <New File/Selection> 
Click OK.

12.    Select and apply Gradients on Paths.

Figure 9.    A feathered selection saved as a channel.



Figure 10.    The final result.

This walk-through used just one of the channel 
calculation functions of Photoshop. Let this be your 
starting point for exploration of the other dazzling 
calculations. For instance, instead of calculating the 
difference between a freeform feathered path and the 
feathered outline of some type, try creating a smooth 
vertical gradient from black to white with Photoshops 
blend tool, and calculate the difference between the 
gradient and the feathered type! The key is to create 
areas of gray in which Gradients on Paths can work its 
magic.



Painter Walk Through
This walk through takes advantage of a cool feature that 
Fractal Design Painter has: Feathering is an independent 
function of the frisket. So you can make a frisket active, 
feather it, apply a gradient along a path, feather it to a 
different setting, and apply the same or different 
gradient on a path to it.

1.    Create a new document in Painter (For this one, we 
made ours 6 x 4 inches at 72 dpi.) Double-click on the 
Frisket Type tool. You'll get a dialog box that will allow 
you to select an outline font. Select a font and size. Click 
OK. (For this document, we made our type 96 point.)

2.    Click on the Document window and type your word 
or words.

3.    Using the Frisket Selection tool, select the type. You 
can select one letter at a time, or the entire thing or 
anything in between. 

4.    Feather your selection using the slider at the bottom 
of the Frisket Palette. For this image, a setting of around 
30 was used.

5.    Make sure that you click on the bottom right square 
of the frisket palette, so that the selection shows with 
both anchor points and the "marching ants" marquee.

6.    Under the Effects menu, choose KPT > Gradients on 
Paths. For this example, choose "Luminous Metal Tube."   
Click OK.

7.    The result of Gradients on Paths should be blobby 
and blurry. We'll keep the effect outside of that as is, but 
put back the inside definition of the type. Move the 
Feather slider back to 0. 

8.    From the Colors Palette, select a color to fill the 
letters with. Fill <CTRL> F).    Or, if you'd like, select KPT 
Gradient Designer. Under the Metallic category, select 
Metallic Reflection. Change the Apply Mode to Linear, 
and move the direction indicator to bottom (six o'clock) 
to make a metallic tube. Apply the Gradient.

9.    This last apply completely obliterated that heavily 
feathered blobby outline. With Painter's "Fade" 
command, that fill can be made partially transparent. 
Select Edit > Fade Scroll around in the preview window 
to see whatever portion of the image. Adjust the slider to
the desired transparency. Click OK.

10.    Now we'll do another Gradients on Paths outline of 
the text. Adjust Feather to a number somewhere 



between 3 and 8. Select KPT Gradients on Paths. Select 
Luminous Metal Tube (It should be the default when you 
open up the Gradients on Paths Dialog box.)

Click OK.

Your result should look something like Figure 11.

Figure 11.
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    Painter Walk Through



Julia Set and Mandelbrot Set Explorers

      Click on the boxes outlined in green for more details.

The Mandelbrot Set and Julia Set Explores are another jewel in the KPT collection.    They are 
four filters that create and explore Julia and Mandelbrot Set fractals.    For those that have 
not played with fractals, this will be an enjoyable, almost game-like, exploration of the 
space. Those familiar with fractals will welcome the easy interface and its placement inside 
Photoshop and Fractal Design Painter.    The output is immediately accessible for 
manipulation by other the tools of the application.

The fractal filters subscribe "lego block" style to the 
Gradient Designer blendsincluding the opacity alpha 
channel. The filter wraps the 24-bit blends around the 
Julia and Mandelbrot Sets, with control over looping, 
repeat count, and spiral angle settings. 

As plug-ins for Photoshop and Painter, these are a source
for fractal backgrounds, blends, and textures, taking 
advantage of Photoshop and/or Painter for very powerful 
post-processing.

Exploring Fractals
At every point of the famous Mandelbrot Set, there exists
another four-dimensional complex space inside which 
lays an infinite domain of Julia Sets. They can resemble 
Mandelbrot fractals, but are often more complex and 
asymmetrical, varying from needle shapes to circular 
regions all the way to dragon-like twists.



Many of the functions in the filter interface and controls 
for the Julia Sets and the Mandelbrot Set are identical to 
one another. To always refer to any particular function as
"this aspect of the Julia Set and Mandelbrot Set" quickly 
becomes cumbersome. Unless were speaking of a 
specific Julia or Mandelbrot Set function, we may lapse 
into an    umbrella term, "Julia," "Julia Set," or "Fractal 
Explorer" even though we're actually referring to both 
the Julia and Mandelbrot Set. 

Julia Set Explorer 
This plug-in explores the "classic" Julia Set. It takes 
advantage of additional algorithms that render gradients
in the Sets interior and implement the radial (spiral) 
effect. 

Julia Set Explorer II
Type II features a faster version of the Julia Set with two 
fewer variables, but a modified central formula that 
explores a different 4-D space. About one-dozen presets 
are included.

Julia Set Explorer III
Type III features an especially unusual new algorithm 
that yields astonishing self-similarity at all levels of 
magnification. One can find triplets of set features and 
zoom dozens of millions of times deeper and find an 
equally complex substructure.

Mandelbrot Set Explorer
This filter explores the classic Mandelbrot Set. This 
allows users to search for well-known features and 
published set locations, and/or compare to images they 
may have generated in other programs. In fact, 
recreating a known Mandelbrot area and then using the 
KPT 24-bit gradient technology with translucency will 
surprise even the most jaded Mandelbroter.



Special Features of KPTs Fractal 
Explorers:
The Julia/Mandelbrot Explorers will not only provide 
access to all parameters necessary to locate any 
published Julia Set, but also extend the vocabulary and 
complexity of the images with revised algorithms and 
proprietary extensions. 

Specifically:

·    The color scheme is executed in full smooth 24-bit, 
rather than the 8-bit dwell band approach of many other 
programs.

·    The colors are not only computed in a hue wheel 
rainbow, but are taken from the complex gradients 
created in the    Gradient Designer, featuring up to 512 
key colors which are interpolate at 2,000 lines, with 
looping controls, continuous transparency, etc.

·    A new algorithm allows the rare case of coloring the 
interior of the set in addition to the exterior and, better 
yet, is able to utilize separate color blends for each! 

·    In addition to the standard "equipotential" lines, the 
algorithm can also resolve the field lines which run 
perpendicular outward towards infinity. 

·    There are separate variables for the number of the 
field gradients and a powerful twist parameter that can 
vary from concentric circular modes all the way to tightly
wrapped spiraling around the sets. 

·    With these new methods, a variety of never-seen-
before pictures are at your disposal. The dozens of 
presets supplied are a mere preview of the dynamics 
inside this most complex space.



Julia/Mandelbrot Set Controls
Preferences Dialog:
There are three changeable control factors in the 
Preferences Dialog:

·    The stepsize or Zoom Ratio. Zoom a lot or zoom a 
little with each click.

·    The Panning distance. Scroll over in minute or gigantic
distances with each click.

·    Place Gradient Bar at top of image, or keep it out. You 
can have the gradients that created the fractal show at 
the top of your window. This is good for some special 
gradient designing effects. (See How to Make More Cool 
Gradients from the Fractal Explorers! below for more 
information.)

Preview Window
The Preview Window shows what the final rendered 
image will be. The preview is generated by iteration so 
that a rough idea is visible in about a quarter of a 
second, with three steps of increasingly defined 
previews. Repeat clicks pre-empt the computation. This 
allows extremely fast exploration of the space. Color 
choices are instantly mapped into the set. 

Data Picker
The Data Picker is similar to the Color Picker: a 
momentary pop-up with a slider control. The slider has a 
400 step resolution factor and features a secondary full 
Vernier scale for each point, essentially creating a 
160,000- step resolution slider.

Panning Control
The Panning Control allows 360  continuous panning of 
the Set through the Preview Window. Pan size increments
can be set in the Preferences Dialog.

Click on the Panning Control to scroll the Preview Window



Figure 13.    Here is a sample of scrolling using Panning Control.    On the left is the location 
of the cursor selection.    On the right you see how the Panning Control moved the fractal 
view.

How to Pan:
You will often find interesting regions and features.    To 
position them "just so," you need to scroll around with 
the pan control.

To the left of the Preview Window is the Panning 
Controller that provides continuous control in a 100x100 
pixel area.

You can use the 8 arrows as shown to move about as you
would expect: to see a little more of whats above the 
current picture, click on the UP arrow and a new section 
will come into view. 

Instead of clicking exactly on the 8 arrows, though, you 
can click anywhere on the Panning Control window to 
move in that direction. Clicking in the upper left corner 
will essentially scroll up and left in a large step. Clicking 
in dead-center will not move at all.

Selecting Normal in the Preferences, clicking inside the 
pan becomes the new center of the preview window.

Other methods of roaming around the set at a given 
zoom setting include zoom setting the Plane Focus 
numbers. They reflect the position in the crosscut of the 
4-D space. Though it is much more intuitive to use the 
direct Panning Control, the numerical variables are 



provided, so you can enter published data on specific 
sets.

Zoom Controls
Zoom In/Zoom Out Controls allow centered zooming; 
clicking on the Preview Window enables zooming directly.
Zoom size increments are set in the Preferences Dialog.

How to Zoom:
There are three ways to zoom into the set, revealing 
more and more of the detail.

·    Centered Zooming 
Use the two controls to the right of the Preview Window. 
The upper one zooms IN; the lower one OUT, with the 
center of the window staying constant. 

·    Direct Zooming 
Simply click on the spot you want to magnify inside the 
Preview Window. It will zoom in and make that the new 
center of the preview. Holding down the Alt key while 
clicking will zoom out from that point.

·    Data Picker "View Radius Zooming" 
The third method is the most precise. The "View Radius" 
variable is an exact expression of the zoom degree. 
Overall, the basic range is in the millions, allowing you 
very, very fine control.    Setting the View Radius to "5" 
shows the set at full distance with all edges. You can 
start with a new set this way, zoom out to "5," then set 
the gradient frequencies, find the blend you want, then 
hunt for the Set's r (real) and i (imaginary) values and 
zoom in, or the other way around.    If you become lost, 
set the View Radius to "5."



Gradient Pop-Up Menu
There are the two gradient pop-up menus in the center 
of the dialog box. The Fractal Explorers render the 
gradient blend samples here.    The left gradient governs 
the exterior of the set (usually the dominant area and in 
most other programs the only area), the right gradient 
governs for the interior of the set.

The gradient selections are arranged hierarchically.    The
first categories are Blends (Basics, Frames, Special 
Effects, Translucent, Metallic, Julia Gradients, and 
personal categories you have created using the Gradient
Designer), then the actual gradients in each family.    This
is the same menu thats used by the Gradient Designer. 
The triangle/sawtooth icon shows the looping control 
(more on that in the Gradient Designer) and has further 
effect on the draw method. 

Gradients in the Julia Explorer:
If a particular Julia Set region intrigues you and has a 
pleasing zoom and    pan, you can alter the set by playing
with the gradients. This will provide a huge array of new 
ways to view that region.

The resulting render is also affected by the Equip and 
Radial values!    See the upcoming section "About all 
those numbers in the lower half of the filter interface" for
more on the Equip and Radial values. Different portions 
of the gradient are stretched, twisted, twirled, spiraled 
and distorted differently with every new setting.

Check out the presets to get a better idea of the 
possibilities.

Notice that some gradients have dark regions that will 
render portions of the Julia Set to "vanish."    Others have
highlights, such as the metallic ones, which, in Triangle 
Loop Mode, can create thick 3-D shapes.

Many gradients include translucent portions, indicated 
by a checker board pattern. Wherever that pattern is 
visible to some degree, any image in your window is 
visible in the background. You can use the Julia Explorer 
to create interesting    overlays and shadow effects. 
Painter's "Fade..." command gives you another means of 
adjusting the overall opacity of the rendered fractal.

About The Data Picker
Whenever you need to change numbers, click and hold 
on the numbers on the interface, and the Data Picker will
pop up. 



The action is similar to the Color Picker. Select a number 
you wish to change and a sliding scale appears. This 
slider allows you to change the values of the numbers 
within the Julia Set. Holding down the <Shift> key will 
freeze your selection until you release the <Shift> key.

At the far left there are fields displaying the legal range 
of the variable. (For instance, if percentage was a field, 
the minimum number would be 0 and the maximum 
100.) It also shows you the last value set and, next to it, 
updates the current value in real time. 

The Data Picker contains two scales/sliders. The large 
scale allows a 400 step resolution. A secondary scale 
(called a "Vernier" scale) allows for additional fine 
resolution. At any one point on the main scale, you can 
drag down to the smaller Vernier and have another 400 
point of resolution! The two combined are just like a 
slider that spans 160,000 pixels.

With this Vernier scale you can set variables such as the 
imaginary Julia Seed Constant that spans from -2 to +2 
with 5 digit precision in continuous increments: 

The main slider steps like this: -0.02 -0.03 -0.04.

The small Vernier scale steps between -0.0201 -0.0202 -
0.0203, etc.

This way you can access -0.0001 to +1.9999 and get 
every increment. (In Julia Set exploration, these tiny 
differences can have major effects!)

It works better than one long slider, because you can 
separate the tasks: Use the main slider to get yourself 
into the numerical "ballpark."    When you need to "just 
bump it up a little," you can go right for the small scale 
and it will move in small increments.

When you drag the main scale pointer around, only the 
rough horizontal motion counts. At any point you can 
drag further down and then pick up the Vernier slider. 

About all those numbers in the lower half of the 
filter interface
There are 8 parameters in the basic Julia Explorer. Three 
of them can be set using direct controls as well as the 
Data Picker. They are the zoom depth and the 2-D cross-
section position. The direct method to change this was 
explained in the Zoom and Panning Control descriptions 
earlier in this chapter.    The five remaining parameters 
are set only with the Data Picker.

Julie Seed Constant



The Julia Sets "Seed Constant" is the first of many 
traditional methods to define the Julia Set.    It is a 
complex number with a real and an imaginary 
component. For any point of the real there are a very 
large number of potential "imaginary" settings. It has 
nothing to do with "imagination," of course; "imaginary" 
is a mathematical term. 

These values vary for every preset. The legal range is -2 
to +2 with 4-8 digit precision after the decimal point. 
There are numerous books on the subject, many with 
exhaustive examples of r and i values. 

Complex Plane Focus
The Complex Plane Focus deals with a complex number 
that defines the position of the 3-D space within the 4-D 
"potential," of which a 2-D cross-section is the picture we
are rendering.    The Complex Plane Focus can be 
changed by the 360° Panning Control or set directly by 
the Data Picker. 

The View Radius is an expression of the size of the 
rendering window and adjustments made in the Data 
Picker in fine increments or by using the Zoom Controls. 

Gradient Frequency
The Gradient Frequency comprises three variables that 
form the nucleus of the determinate draw engine.

·    Number of Iterations (Iterate)
The Number of Iterations, (abbreviated as "Iterate" in the
filter) controls the repetitive or iterative process to find 
the color for each pixel. This is determined by the Julia 
Set formula expressing whether a given point belongs to 
the set or not and is colored according to its potential to 
fall toward so-called "attractors" inside the set.

The number of iterations has a dramatic effect on the 
ability to discern small changes, particularly inside the 
sets interior. The larger the number of iterations, the 
longer your computing time.

You might note certain speed differences between 
presets. The majority of examples will use closed sets 
and only one gradient. Here low settings of the Iteration 
number are used, often between 10 and 90, whereas 
other examples show very deep zoom levels and subtle 
details near the attractors. To resolve any dynamics at 
that depth, iterations on the order of 500-999 are 
necessary.

·    Equipotential Gradient Frequency (Equip)
The Equipotential Gradient Frequency ("Equip") is a 



number that controls how fast the color cycles as one 
moves from one equipotential line to the next. (The lines 
are expressing the potential of any point in 4-D space to 
fall towards the attractors, roughly analogous to rings 
around a planet with equal attraction to their 
gravitational center. Within a ring, the gravitational pull 
is the same and there can be many such rings as you fall
towards the center of the planet.) 

·    Radial Frequency
This number interacts closely with the last one. The 
Radial Frequency (Radial) defines how often the gradient 
repeats over the entire 360° unit circle around the set. 

To see "traditional" Julia Sets, set the Radial to "0," 
creating seamless images. The legal values here are -50 
to +50. This corresponds roughly (but not always) to the 
number of gradients repeated. A setting of 5 would cycle
5 gradients.

They will be affected in large degree by the "Equip" 
number which at "0" would render straight spikes 
outward. Values here range from -50 to +50 in fractional 
increments. Variations in the Equip setting will result in 
widely divergent effects. Some settings will render lines 
that go straight out, others will wrap a spiral around the 
set, and still others will create concentric circular blends.

Manipulating just these two Radial and Equip number 
values will give you a wide range of image variance.

Note that the Radial setting affects only the outside of 
the set, while the Equip value also affects interior detail.

Setting the Radial Frequency to anything other than "0" 
may allow pixellation or other artifacts at certain regions 
of unfilled sets. The variety and unusual nature of the 
images makes it well worth accepting the limitations of 
computability. If you find a region with artifacts, either 
look elsewhere or try to "close the set" by lowering the 
Imaginary component of the Constant. If all else fails, 
you can use Photoshops or Painter's tools to spot clean 
the final image. 

More about the Presets
There are large number of presets that you can add or 
delete as you wish. All parameters and settings are 
remembered including the named gradients!

The names are a little crazy sometimes, but they help to 
remember what feature you were pursuing at the time. It
can also evoke a certain mood or trigger mnemonic 
associations. 



Before you try to understand the variables in detail to 
gain predictable results, you can meander through the 
possibilities by using these controls first:

1.    Zoom. For any given preset effect (Here weve used 
Julia Set III, Spiral Study 1), click anywhere in the Preview
Window and zoom in to that point (Alt click to zoom out).
The controls on the right will zoom in and out of the 
exact center. (See illustration earlier in this chapter for 
zooming.)

2.    Pan. Use the panning field to navigate in 360 degrees
at a given zoom setting. 

3.    Gradient. Favorite quick and easy exploration: 
change the color gradient for the inside and outside! To 
match what weve shown here, select Yellow Fever from 
the Special Effects gradient category. Try the other ones 
shown here. Better yet, try others we haven't discussed.

When you choose the new gradient, the set will be 
redrawn. You never have to wait for the complete 
preview, by the way. Click, zoom, pan, as fast as you like 
to pre-empt the process.



Guided Exploration of the Parameters
Basic Exploration of Julia Sets
The easiest was to explore the Julia Sets is to start with 
the basics.    The first basic is controlling the form or 
shape of the fractal.

1.    Select the    Julia Set Explorer.    Under the Preset 
control, choose Classic Julia Set.

2.    Choose the left Gradient Menu.    This controls the 
outside color of the fractal. (Click on the interior, of the 
gradient image to access the menu.)    Change the color 
to white.    Make sure the gradient pattern indicator 
shows "Sawtooth: A to B".

3.    Choose the right Gradient Menu.    This controls the 
interior color of the fractal.    Change the color to black.

4.    Click on the Zoom Out (small globe with the arrown 
pointing down) Control. As you click on this button, 
notice the "View Radius" is increasing.    Click until the 
view radius is at its maximum value to 5.    This is a 
maximum out zoom.

Results
The gradient is now at its base form.    It should resemble
a circle with an odd shaped center.    Using the data 
picker, change all the remaining values (except for "View
Radius"), such as the Julia Seed Constant, etc., to zero.    
With all the parameters changed to their lowest value or 
zero, the shape should represent the outline of a CD.    
Now, lets vary the values and observe the changes.

Changing the Julia Set

1.    Change the outside color, (left Gradient Pop-Up 
Menu) to a" Full Intensity Hue Spectrum" under "Texture 
Blends."    The "CD" has changed from white to red.

2.    Under the "Gradient Frequency", change the radial 
setting to 5.    There are now multi-color spikes running 
straight out from the center.

3.    Under the "Equip" setting, change the value to -5.    
The Spikes are now moving in a circular pattern.    
Changing the "Equip" setting value to a 5 turns them in 
the opposite direction and partially fills the center with a 
similar pattern.

Applying this fractal to an open canvas allows other KPT 
Filters to act upon it for even greater effects.    For 
instance, applying "Glass Lens Bright" renders a 



multicolor round mobeous type strip.

4.    Change the "Complex Plane Focus" settings to .2 
each.

5.    Change the Julia Seed Constants to .7 each.    
Observe the change to the hole in the middle.    We now 
have two.    For illustration, change the "Real" Julia Seed 
Constant to -.7.    Notice how the two holes become a 
large oblong hole.

Continue to experiment with the different options.    
Remember, when you find something you like, 
something that may be needed in the future, SAVE IT as 
a preset.

Figure 14.    The same Julia set rendered with different 
gradients will give you a variety of looks.    Here are three
alternatives to the preset for Spiral Stugy 1. (Julia 
Explorer III)





Another Julia Set WalkThrough
Use the    Julia Set Explorer. The salient features are 
illustrated here for some other quick ideas.

1.    Select the preset Moire Field Lines. Notice the 
Gradient Frequency settings on the right hand side. 
Iterate: 19, Equip: 50, Radial: 50. (Note: The maximum 
values for both Equip and Radial are +50.) This is the 
high end of the range for both of these. Lets change the 
values.

2.    First, change the outside gradient. Select Basic > 
Avacadoid Universe. 

3.    Using the top slider on the Data Picker, change the 
Equip to lower values, say 30, 35, 16, 10, 5, 1.25. 

When in the 14-15 range, use the bottom slider to 
change the Equip value by factors of 0.1 or so. What is 
14.2 like? 14.6? 14.8? See how you can get differing 
effects with just one gradient with adjustments made at 
seemingly minute levels. The minor changes affect what 
part of the light part of the gradient in the center is 
bumping out or receding. Before moving on to the next 
step, leave the Equip value at 1.25.

4.    Now, lets look at the Radial. Adjust the number down
about every 10 points or so to 40, 30, 25, 10, 8, 5, 1, 0. 
Compare positive values with negative values (2 and -2; 
10 and -10.)

5.    Change both the Radial and Equip values so that 
they are positive and negative. Compare 19, 1.25, 8 with
19, -1.25, -8. 
Do you have a feel for the way that the different Data 
Picker numbers change the appearance of the fractal? 
Keep on playing and have fun!

After you've rendered
One main thing to realize is that you are in Photoshop or 
Painter! There are zillions of ways to modify these 
fractals once youve rendered them. Think of them as 
mere starting points that beg for further processing. Try 
Embossing, Find Edges, Adjust Curves, Levels, Diffusion, 
Arbitrary Maps, Hue Changes, Sharpen, Distorts, etc. Use
Spherize (or the    Glass Lens) on it, Twirling a region or 
channel, sharpen, diffuse, etc.

Painter's "Fade" command will allow you to layer 
translucent fractals upon one another. Or, create a paper
texture from a fractal and render other imagery and 
effects on top of that. (See the section on creating paper 
textures in the chapter on the Texture Explorer, or refer 



to Painters manual.)



General Suggestions
For greatest effect, try out the presets on a larger 
window, at least 300x300 pixels.

For transparent fractals, make sure there is an image 
underneath. Start with a 24-bit image of a face or other 
recognizable feature and color. 

As a tip: select a smaller rectangular area and apply the 
filter to see your preset.    You can make larger ones and 
just use <Ctrl>-f (Photoshop) or <Ctrl>-/ (Painter) to 
repeat the filter.

You can also achieve something akin to Draft, Medium, 
Best quality by creating a window that is only a third of 
the size of your monitor. After rendering a fractal, 
enlarge the size by typing    <Ctrl>+ (Photoshop) three 
times.    In Painter, set the zoom factor by choosing 
Windows > Zoom Factor. This will render nine times 
faster and give you blocky pixels but at the correct final 
size. If you like it, go for the final.

For a huge file, or if your PC is under powered, consider 
rendering your fractals overnight if you need extremely 
high quality.

If you encounter aliasing or other artifacts, read the 
section earlier in this chapter for technical explanations 
of the mathematical source. You can smooth out the 
gradients, set the loop to Triangle, change the viewing 
area to other regions, change the Radial and Equip 
settings, or simply touch up anomalies with tools such as
the clone tool, or the water drop blur (set it to 33% in the
dialog or hold down the "3" key). To smooth out long 
straight lines, use the shift key and click on the end 
points, the tool will travel in a straight line (use multiple 
vectors for curves).

A good book on fractals will have many new suggestions,
and settings for many of the areas discussed in this walk 
through.

Consider that far and above the plain old "fractal" 
pictures, this provides you with a source of highly 
unusual blends and gradients with distorted paths. In 
fact, you can use it simply to generate complex shadows
or overlays without any hint of their fractal origin. This is 
not just for Mandelbrot groupies...

Image-To-Gradient Transfer and How to Make More Cool 
Gradients from the Fractal Explorers!
Here is a powerful feature using the Gradient Designer 
and Julia Explorer in combination to make cool gradients.



Its the non-obvious way to come up with some very nice 
surprises.

1.    In the Gradient Designer, change the Preferences to 
"Load Smooth Gradient From Image." Click "OK" to exit 
back to the Gradient Designer. Click "NO." (You dont 
want to render a gradient at this time. The Gradient 
Designer will remember the new    preferences.)

2.    In the Julia or Mandelbrot Explorer, open up the 
Preferences pop-up menu and select "Display Gradient 
Strip Across Top."

3.    Find a Julia/Mandelbrot Fractal of your liking. Render 
it by clicking "OK." 

4.    Select Image>Adjust>Variations.    Make your 
changes in the RGB values, midtones, shadows, etc., and
apply them to the image.    There are now two ways to 
save the color scheme as a gradient.    Either select the 
Gradient Bar displayed across the top of the fractal, or 
launch Gradient Designer.    Gradient Designer extracts 
the gradient from a single scan line across the vertical 
midpoint of the selection and displays this in the 
Gradient Bar.    Save the new color scheme as a preset.

5.    Open up the Julia/Mandelbrot Explorer and pop up 
the Gradient Preview menu to the gradient you just 
created. Now you can render any Julia with it, inheriting 
all the subtle color advantages that you so masterfully 
tweaked.

When you normally create a gradient, it is a conscious 
choice of tools and a straightforward effort to get 
something that looks good.    Remember, it is almost 
impossible to predict how a blend will look when applied 
to the fractals. This feedback process totally 
disassociates the gradient design from the tools. (Note: 
Many of the blends in the Gradient Designer presets 
were created this way and the non linear transitions, odd
gaps and highlights, etc., would have been very hard, if 
not impossible, to design as a conscious choice.) 

Alterations to the image using techniques such as 
filtering and spatial distorts will change the image in 
ways that cannot be transferred back to the gradient.    
After developing a pleasing gradient, save it as a preset, 
and recall it at will.



Figure 15.    Julia Set with the Equip. settings gradually reduced.    Maximum setting is 50 
(top).    Below a medium setting of 35 shows fewer light-edged ridges.    Bottom two 
demonstrate the dramatic changes which result from small adjustments. (Low settings 



shown last)

Figure 16.    Julia Sets and Different Radial Settings.    The top two images show a range 



from 30 (roughly halfway between the maximum possibilities) and zero.    The lower three 
sets of images are side-by-side comparisons of positive and negative values of Equip and 
Radial.    As the radial setting moves closer to zero, the gradient rendering effect decreases 
in complexity.

Figure 17.    The arrows demonstrate the zoom in (top) and zoom out (bottom) controls.
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Texture Explorer

      Click on the boxes outlined in green for more details.

The graphic (above) was created in Photoshop with Texture Explorer and Gradient Designer.   



After a basic texture was applied (with normal apply, 96x96), the magic Wand, set at 10 
pixels was used to select the lighter portions of hthe texture.    Gradient Designer then did a 
procedural apply of a gradient to the Magic Wand selection.    Finally, the HSC logo was 
pasted from a mask developed in a previous session.

Textures have become a staple component in graphic 
arts creation. As technology has progressed, it has 
become standard practice to embellish components with 
more than trivial color. The term "Texture" encompasses 
anything that "fills a shape with something more than a 
simple flat color." Now readily available, scanned marble,
wood and stone have become common fare as 
backgrounds. The    Texture Explorer puts a new twist on 
this background texture movement.

Algorithmically Generated Textures
The Texture Explorer generates completely algorithmic 
mathematical output, there are no scans or pict files 
involved. It can render any texture it creates into the 
current window, selection, or feathered selection and 
then be able to use all Photoshop and Painter tools to 
process them.

While the possible "space" of textures is vast, including a
variety of natural components like woods, marbles, 
minerals, cloth, and clouds, the door opens to a much 
larger space    of things not seen before, like plasma and 
fire and luminous blobs and alien hieroglyphs. These 
textures are not "scannable" since they do not exist.

Textures the Easy Way
Inside the heart of the Texture Explorer there are very 
complex math routines involving dozens of variables and
parameters and interactions. These parameters include 
things such as waves, frequency, correlators, diffusion, 
distortions, stretch, squeeze, overlays, blends, multi 
layer combinations, twirliness and bumpiness, scale 
factors and constants, a dozen color control variables 
and looping, repeat, transfer modes, gradient indices, 
multiple alpha channels and so on. 

Each parameter and variable is a "gene" contributing to 
the final texture produced; to change the texture, 
mutate the genes! This gene mutation is not the gene 
mutation that concerns geneticists and ethicists. It is 
using various algorithms that scientists use to describe 
the mutation process. Applying basic gradients, colors 
and shapes derives a vast array of texture space.

Preview & Variations
In the center of the preview box is the current texture, 
shown at 96 x 96 pixels. Around the preview, you will 



notice 12 small previews produced on the fly that are 
derivatives of the main texture. These 12 outer previews 
change depending on which "mutation ball" is selected.

Clicking on any of the outer preview squares moves that 
particular texture into the middle, and the mutation 
process begins all over again around the outside. 

The Mutation Tree

Figure 19    Texture Explorer with no mutation.



Figure 20    Texture Explorer with highest level of mutation.

The only control necessary for the process of exploring textures is the series of control 
points, represented by little balls ascending a tree. The lowest ball, partially in the ground, 
represents very little change. Rising higher on the tree approaches an abstract "mutation 
rate" of 100 percent. If we vary one percent of the genes in 100 parameters, that means in 
every generation, one number will have changed randomly, or "mutated." 

The highest point creates vast change, or 100 percent 
mutation. Every time the Texture Explorer creates a 
derivative "cousin" of the current texture, it will vary 
every parameter by some random amount. The result: in
one cycle there are 12 new textures that bear very little 
resemblance to the current one in the center.

What is really happening (outside the mutation 
metaphor) is a demonstration of random examples of 
textures, spread throughout the universe of possibilities. 
You get to see random areas of the potential space what 
certain combinations can look like.

If you click on the Main Texture Preview itself you'll see 
another reason for the vastness.    Without changing a 
single gene or color you are re-seeding the starting 
values of all our stochastics (read "random generators"). 
It's like buying a huge roll of textured wallpaper.    Visible 
is a square inch.    With every click in the center, there is 
a different "square inch" from the same roll.    There are 
roughly 16 millions variations to each theme.



Color Mutation
The Color Only Mutation Ball has a special decoupled 
mutation function.    It    will keep all parameters of the 
texture frozen and simply change the colors. The Texture
Explorer subscribes to the endless array of Gradients 
that are available from the Gradient Designer. 

If the Gradient Designer has a puce-mauve-off-lilac-lime 
blend, those blends will eventually show up in the 
TEXTURE EXPLORER and completely redefine the 
textures displayed.

If the textures looks interesting, but the color isn't quite 
right, use the color mutation ball.

The Options Menu

Figure 21.    Apply Options for Texture Explorer

The Texture Explorer contains a pop-up menu when the Options feature (on the user-
interface) is selected.    Five selections are possible.    Two deal with tiling the pattern, and 
three deal with applying the selections.

Tiling Options
The textures apply as repeating 96 x 96 pixel seamless 
tiles. Another option recalculates the algorithm as an 
"Infinite Autostretch," scaling the texture to any size and 
resolution. CapsLock, when depressed, will force the 
texture to Autostretch into the current selection. 

The Infinite Autostretch, too, can be tiled seamlessly (in 
a square or rectangular selection). This will go to the 



Walk Through section under Photoshop. Make a 
selection. Apply a texture using Infinite Autostretch. 
Under Edit, select "Make Pattern." Select all. Under Edit, 
select "Fill"
 Click on the radio button that says "Pattern" then click 
okay. 



The Apply Modes
The Texture Explorer has several methods of application 
of the texture to the existing image. These apply modes 
are:

·    Normal apply
·    Procedural blend
·    Reverse Blend
·    Darken only
·    Lighten only

Normal Apply
This acts similarly to the paint bucket in Photoshop, 
except that it fills an area with texture.

Procedural Blend
This is an innovation with KPT. In the Procedural Blend 
mode, the Texture Explorer blends the texture over a 
selected area based on light/dark value. Where the 
selection is light, the texture is lightened accordingly. 
Where the selection is darker, the texture is darkened. 
This creates the effect of "wrapping the texture around" 
the existing image or selection. To see this in action you 
need something with shadows. The accompanying image
file "KPTFACE.TGA" is provided for this purpose. 

Theoretically, if you apply a texture to a white window 
when Procedural Blend is selected, nothing will happen.   
However, the Texture Explorer senses when there is an 
all white or all black image and automatically reverts to 
"Normal Apply" in these cases.

Reverse Blend
This is similar to procedurally blending.    Instead of 
applying the texture to the image, the image is applied 
to the texture.

Lighten Only and Darken Only
These functions are the same as in Photoshop. Lighten 
only will only affect values in the image that are darker 
than the values in the texture. Darken only will darken 
those values in the image that are lighter than the 
texture. 

Keyboard Shortcuts

Arrow Keys
To cycle through the presets in a category, you can use 
the arrow keys. 



To navigate to: Press this key:

Next preset down arrow
Previous preset up arrow
Next category right arrow 

(also page down)
Previous category left arrow 

(also page up)
First preset/category home
Last preset/category end

Global Transparency
Holding the number keys down when applying the filter 
will vary the transparency. The number keys 1-0 
correspond to opacity, with 1 representing 10% , 5 
representing 50% and 0 representing 100%. The number
keys modulate global transparency (applied on top of 
whatever transparency the original texture contained) 
and should work in all apply modes. 

Try holding down '6' while procedurally blending a 
texture onto KPTFACE.TGA.    Much clearer 3D features 
are retained this way than when using the full 100% 
procedural apply.



Exploring textures: A "Ramble Through"
Due to the random nature of the Texture Explorer, it 
would be impossible to give a walk through in which 
we'd say, "click on the third mutation ball and observe. 
Now click on the variation second down from the right 
and observe...", to guide you to a specific place or 
feature. There is no way of predicting    exactly where 
you'll end up. Instead, we'll provide you with some 
general guidelines to launch you into Happy Texturedom.

1-ish. The Texture Explorer arrives with over 200 presets.
Roam through them and choose a preset name that 
strikes your fancy. It will render a main image with 
twelve derivatives all along the outside. 

2-ish. Click on a mutation ball, and watch the derivative 
cousins change. If one of the twelve intrigues you, click 
on it and POP, it becomes your new chosen current 
texture, now drawn in full-size in the center. Before you 
can say "algorithmic mutation process," it starts the 
mutation cycle anew! Not only did you get the one you 
wanted, you get 12 new cousins right with it. This cycle 
may be repeated indefinitely creating an infinite number 
of textures. 

Traverse the space and sample the results every time 
you click. You can even do this in mid-cycle, trying out 
new ones just about every second if you like.

3-ish. Suppose you really have become interested in one 
texture and you don't want it to keep generating wild 
mutations. Click on a lower ball and the mutation rate 
will go down, reducing the difference between cousins so
you slowly converge on your favorite texture.

You are ending up seeing dozens and maybe hundreds of
examples of the potential space of possibilities. What 
you finally end up with and call "my happy magma blob" 
is something where you don't know quite what it is or 
even why you like it and most certainly you would not 
have the foggiest idea of how to create it from scratch. 

Saving Your Own Presets
At anytime that you're exploring textures, you can say, "I
like it! save it, saving just the algorithm definition in a 
few hundred bytes. The process is as easy as clicking on 
the "Add" button and naming your preset. You may save 
as many as you like for future use.

When you see one you like, save it! Save it now, because
if you don't, theres no guarantee you'll see it again. (If 
for some reason, you end up not liking it, you can always
delete it later.) . One idea    would be to set up a new 



category called "Textures In Progress" or "Continue 
Exploring Me" for textures that need more attention than
youre able to devote at the moment with that urgent 
deadline looming!

Texture Explorer Tips
You can overlay multiple layers with GREAT results. Try 
choosing complementary color schemes and complexity. 
Or slightly mutate a texture and then use a darken-only 
second layer, adding depth shadows and get bump map-
like effects. The sky is the limit!

Large feathered selections work wellconsider using a 
selection with one texture then the Select > Inverse area
with another.

Try a Texture in individual channels, like RGB or just the 
hue channel, for instance. (Or do it to a floating selection
<CTRL>-C then <CTRL>-V your selection.)    Then use 
paste controls for even more apply options.

Woods. Create a new document. Make a rectangular 
selection in the top fourth of the file across the image.

Open Texture Explorer. Select the Preset Woods 
>Bleached White Ash. Under the Options Pop-up menu, 
make sure that "Normal Apply" is selected. Click Ok. 

Select Image > Effects> Scale. Drag the bottom part of 
the rectangle to the bottom of the window. Voilá! 
Stretched wood!

Texture Explorer and Paper Textures in Fractal 
Design Painter
Any texture created with the    Texture Explorer can be 
used to create a paper texture in Painter. (For that 
matter, anything that you create with KPT can be made 
into a paper texture with Painter!) The paper texture will 
be grayscale.

To create a Painter paper texture:

1.    To take advantage of the textures which seamlessly 
tile, create a Painter file thats 96x96 pixels. 

2.    Select Effects > KPT Extensions >Texture Explorer 
from the Painter menu. 

3.    From the Texture Explorers preset pop-up menu, 
select Grids > FbOaRcEkground (fore/background). 
Under the Options menu, select Normal Apply and Tile 
96 x 96. Click OK. The pattern rendered into your new 
file is one tile size. Now well make it into a paper texture 



that will tile seamlessly throughout any selection or 
Painter document.

4.    In Painter's Toolbox, click on the selection marquee 
tool. Select all. Under the Options menu, select Capture 
Texture.

5.    Youll get a dialog that will allow you to name your 
texture and to set the cross-fade amount. For those 
textures which seamlessly tile, no cross-fade is 
necessary to get a smooth paper texture tiling. For this 
sample, move the cross-fade slider to zero. Name your 
texture and click OK. You should now have a new paper 
texture in your Papers palette!

6.    To see how the texture applies to a document, create
a new one, larger than 96 x 96 pixels of course! (300 x 
200 will be adequate to give you a test sample.) 

7.    Color it a solid color, say a medium gray. Select the 
color using the color palette and then type <Ctrl>-f (fill).

8.    Select Effects >Surface Control >Apply Surface 
Texture. Youll get a dialog that will allow you to adjust 
lighting and shininess, with a preview. All paper textures 
shown here were made with the default "light from 1 
o'clock direction." 

Incidentally, this is how the backgrounds for the 
Gradients on Paths sample images were created.

To see how this fore-back texture was used with cross 
fading and the resulting paper textures, see Figure 22. 



Figure 22.    Paper textures created with the Texture Explorer and Painters "Capture Texture"
command.    This set of diagrams shows different levels of cross-fading.    Paper textures 
applied to a middle-gray file are on the left.    The actual textual swatch is on the right.    
(Numbers refer to the amount of cross-fade.)

Paper textures created with the Texture Explorer and 
Painters "Capture Texture" command.    This set of 
diagrams shows different levels of crossfading.    Paper 
textures applied to a middle-gray file are on the left.    
The actual texture swatch is on the right.    (Numbers 
refer to the amount of cross-fade.)
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          Preview & Variations
          The Mutation Tree
          Color Mutation
          The Options Menu
          Tiling Options

    The Apply Modes

          Normal Apply and Blends
          Lighten Only and 
              Darken Only
          Global Transparency

    Exploring Textures

          Explorer Tips



3-D Stereo Noise

Figure 23.    Stereo Noise for you viewing enjoyment.

A researcher at Bell Labs discovered a method to create a special dithered noise where 
certain points will be seen by both eyes as if they converge on a plane. This filter creates 
this effect by processing any grayscale    image into a single-bit black and white noise.    The 
result has incredible stereo 3-D depth properties and can be seen without special glasses. 

You would swear there is a    hole in your monitor when certain 
figures or letters seem to mysteriously appear 3 to 6 inches 
inside your monitor. Printed versions have been shown with 
great response in Omni and Games magazines. Its a specialized 
interest. Some people cannot perceive the depth effect at all. 
Still, it will amuse the majority and drive others completely 
bonkers.



Figure 24.    This is the image converted to gray scale stereo noise in Figure 23.

The images that produce the best results with the 3-D Stereo 
Noise filter use gray levels, are blurred slightly, and don't use 
extreme contrast. The filter generates a pixellated noise pattern
that has horizontal frequencies that correspond to the gray 
levels of the initial image. This means that white maps to the 
highest frequency and appears closest to the viewer; black 
maps to the lowest frequency, appearing furthest away. 

In Photoshop 
Create a grayscale image that uses text and simple objects. 
Although the filter will apply in all modes, the best images use 
gray levels initially. The smaller and more detailed the image 
you choose, the harder it will be to focus the stereo image. 
Apply the standard Photoshop filter, "Blur More." This will soften
the edges of the image for easier viewing. Apply the 3-D Stereo 
Noise filter to the entire image. The results will appear to be a 
random array of black and white noise. 

In Painter
Using black as your selected color, create an image using large 
text or simple images. Under the Effects Menu, scroll to Focus 
and select Soften. Soften the image with a radius of 1-2 pixels. 
Apply the    Stereo 3-D Noise filter to the image to produce the 
random noise.

Viewing 3-D Stereo Noise pictures
Now that you have created a stereo noise picture, it is time to 



focus your eyes and energies to see the image. Try our A B C 
example first. Don't feel bad if you don't see it right away; it 
may take a few tries. There are several ways to view the image 
in-depth. Try placing two black dots about    a half-inch apart at 
the bottom of the image. Defocus your eyes and gaze through 
the image as if you were looking in the distance. The dots you 
placed at the bottom will separate into four. If you focus so the 
middle two dots fuse, depth will pop in or out. Another way is to 
try crossing your eyes to fuse the four dots into three. You may 
also try holding a thin object like a floppy disk or your hand 
between your eyes to separate each eye's vision.

Controlling Depth in Stereo Images
When you see a 3-D object close-up, the object seems to be in a
slightly different place depending on which eye looks at it. Hold 
your finger about five inches from your computer monitor and 
look at it with one eye, then the other. Observe how it seems to 
move left and right with respect to objects on the screen. This 
discrepancy gives your brain information on how far away the 
object is. Against the background of your screen, for instance, 
your finger that is five inches away is displaced about one inch 
depending on which eye views it.

Using this principle, it is possible to fool your brain into 
perceiving this binocular 3-D effect on a flat surface. For 
example, if you have a texture on a piece of paper that repeats 
itself every inch horizontally, consider what happens if your 
eyes focus about five inches beyond the texture. The texture 
will still appear to be one inch displaced depending on which 
eye views it, but notice that in this case each eye will see 
exactly the same thing! The texture will appear to your brain to 
be located five inches further back than it really is.

Now, what if the pattern is spaced every half-inch horizontally? 
The same trick still works, but the texture will now appear to be 
two and a half inches back, instead of five. The higher the 
horizontal frequency of the pattern, the smaller the depth 
effect.

The amount of depth is modulated by the keypad, using keys 
"1" through "9." The default setting is "5." Using the "1" key 
setting is very shallow, whereas "9" is so deep that it can be 
very difficult to see the effect up close. 

Creating Colored 3-D Stereo Noise RGB Files
In Photoshop only
This filter may be applied to individual channels as well as 
entire documents. For best results, create your image in 
grayscale mode and then convert to RGB mode. Apply the filter 
to each channel (Red, Green, Blue) in your document (be sure 
that you only write to the channel you are working on). When 
you are done, you have a tri-colored noise image.





Smudge Darken/Lighten

These Smudge filters are two sets of symmetrical effects
decoupled to be standalone. They are directional motion 
blurs that take the current selection and create a multi-
level blurry blend using a transfer mode (either lighten 
or darken). They are unlike Photoshops Motion Blur in 
that the latter extends in both directions and has no 
apply mode. They are also totally unlike other blur filters 
in that they are constrained to horizontal features, not 
cell-based, and utilize lighten and darken apply modes.

Tips on using smudges
You can easily create subtle trailing motion and wind 
effects, as well as interesting alterations of textures.

The Darken version will slowly build up the dark content 
in the selection. After about 4-6 repeat applies the image
converges on black. Repeated Darken works particularly 
well on a mostly light background with black speckled 
noise. Darken creates smooth trails which eventually 
result in needle-like structures.

Smudge Darken Right is a complement to the left 
version. Note that a Right after a Left Smudge will not 
recreate the original image. In the multi-layer process 
information is irretrievably lost. Consider it a donation to 
entropy.

The Smudge Lighten filters are similar except they use a 
lighten transfer mode. The combination of darken and 
lighten can be very effective. 

Consider making macros of multiple applications and/or 
combinations of the four.



Smudge Filters Walk Through
This demonstration shows the versatility of the Smudge 
filters.

In Photoshop
1.    Create a new document, 300 x 300 pixels.
2.    Under the Filters menu, select "Add Noise" from the 
Noise menu.
3.    Set the value to 99 and select "Gaussian Noise."
4.    You should now have a document speckled with RGB 
noise. Select a small rectangular area and apply the filter
"Smudge Darken Left."
5.    Repeat this filter on the same area five or six times.
6.    Repeat this process using Smudge Darken Right, 
Smudge Lighten Left and Right. Try overlapping areas of 
each to see how combinations of the filters affect each 
other. To achieve variations on these you can rotate 90 
degrees and apply, obtaining a    perpendicular vertical 
smudge once you rotate back. 
7.    Create another document as you did in step three. 
Double-click on the lasso tool and specify a feather 
radius of ten.
8.    Create a freeform feathered selection. Experiment 
with the four filters using feathered selections. Try 
overlapping the selections.

In Painter
1.    Create a new document, 300 x 300 pixels.

2.    Under the Effects menu, apply the filter "Grime 
Layer."

3.    You should now have a document speckled with 
noise. Select a small rectangular area and apply the filter
"Smudge Darken Left."

4.    Repeat this filter on the same area five or six times.

5.    Repeat this process using Smudge Darken Right, 
Smudge Lighten Left and Right. Try overlapping areas of 
each to see how combinations of the filters affect each 
other. To achieve variations on these you can rotate 90 
degrees and apply, obtaining a perpendicular vertical 
smudge once you rotate back.



Figure 25    Far left:    Smudge Right, 1 apply.    Form left, Smudge Darket Left with 1,3,5 and 
10 applies.



To go to any of the following topics, click on its title:

    Tips on Using Smudges

    Smudge Filters Walk Through



Foreword by Kai Krause

Really, I ought to write two totally different introductions here, 
one for those of you who have never seen the KPT plug-ins 
before, the virgins, the innocent souls who don't know what's 
coming...

...and those who know better and already lost countless hours 
of productivity over the stuff. I get an awful lot of mail along the
lines of Dear Kai, I haven't seen my husband in three days..., 
and sometimes I work myself into a mood where the guilt 
creeps up on me.

Then of course, I snap right out of that and go back to wreak 
even worse havoc, which you can experience when the next 
series heads your way.

Just to create the proper mindset as you encounter the loss of a 
perfectly good weekend, let me explain a little of what I would 
like you to get out of this, what it is and what it is not.

KPT is not:
...brain surgery or accounting software.    This should be fun, 
dudes and dudettes.    Please don't forget that.    A lot of the 
design was approached that way. Push the buttons, yank the 
dial, click everywhere and see what happens.    There is nothing 
to break.

KPT is:
...almost a little game at times.    We spent a fair amount of time
creating a certain play value within the context of a tool. But, it 
is not a mere toy.    Not by a long shot.    There has been some 
very serious fine art created with the first edition for the 
Macintosh, as well as lots of down to earth, bread and butter 
production work. Now that the tools are available for Windows, I 
expect even more serious accomplishments. It may sneak up on
you just how useful and universal the individual components 
can be.    In fact, we ourselves had not anticipated what all the 
combinations could suddenly concoct.

Explore!
So, I encourage you to explore with the knowledge that only a 
fraction of the territory has yet been seen by anyone.    You may 
tread on the proverbial "virgin snow."    Check out the presets we
have supplied, (by the hundreds), but do understand that they 
are merely that:    examples we have saved as we looked around
the "potential space."
There are seriously trillions of combinations between the 



Gradients, Fractals and Textures.    Since many of them deal with
blending and translucent effects, even your own initial image 
will change how the final result will appear.    I am convinced 
that some of the best output has not been seen yet. (If you 
happen to be the one who stumbles upon the motherlode, drop 
us a note on-line, or pop a floppy in the mail accompanied with 
a one page "how to.")

A few notes about the User-Interface.
Here is my philosophy on the successful User-Interface (U-I).

The whole notion of the interface is for it to fade into the 
background and be forgotten and taken for granted.

My criterion for a successful U-I is that those folks who really get
the use of these tools still find it enjoyable and rewarding to 
come back to the dialog the 101st time, not whether a stranger 
without reading an explorers guide can make a great effect 
instantly.    I did not design things here for the first three 
minutes of entering the dialog.    

For this reason, I created an interface that has a semi-faded 
type, and buttons that go to sleep.    Not every element on the 
Interface is labeled.    In fact, many elements are part of a whole
visual metaphor.

Concerning those buttons with faded type.    After the second or 
third time you used the damn things, they fade into the 
background...as well they should.      Thats why the writing, 
where there is some, is not the big black on white or strong 
colors.    It is simply not done for legibility.    Once you realize 
where the ADD PRESET button is, I dont even want you to read 
those letters any longer, and neither do I think would you.

In contrast, consider some other contemporary user interfaces.   
There are those cars that will squeak at you "the door is ajar" or
beep relentlessly when the belt isn't fastened.    In that same 
vein the mirrors will bear that constant reminder about "objects 
in mirrors are nearer than they appear."    I don't know about 
you, but I find these things annoyingly condescending.    Those 
kinds of user interfaces are "in your face" and do not 
accomplish their goals with grace and finesse.

In designing the KPT Interface, the goal was to make things 
friendly and fairly intuitive, without insulting your intelligence or
including eyesores for labels.    So youll see that there isnt a title
and description for each and every element; each and every 
pop-up menu is not indicated.    Some new concepts such as our 
Gradient Designer Moveable Bracket and Texture Explorer 
Mutation Balls have neither description, title or precedent.    Had
I writin "Bracket" over the Moveable Bracket or labeled the 
marbles in the Texture Explorer, or spelled out the metaphor in 
excessive detail, I would be losing sight of the long-haul use of 



the tools in the interest of making something easy to 
understand in the first two minutes.    After going into the 
Texture Explorer for the ninety-fifth time, a label on each marble
declaring what the mutation percentage is, or numbering the 
balls simply wouldnt be pretty.    Rather, there is a tree with 
some balls, an abstract metaphor loosely mirroring the concept 
of increasing complexity in each new texture derivative.

Software designers have studied the user interface for years.    
Apple had a great idea when it released its human interface 
guidelines initially.    Out of the universe of possibilities it 
condensed a series of common rules and parameters to unite 
the efforts of software designers.    However, a decade has 
passed and it surely is time to redefine what has become more 
confining than enabling in the almost Holy Grail of User-
Interface.

I predict that our children will laugh at us for having used 
computers with single bit interfaces and non anti-aliased fonts, 
in coarse pixel grids.    The entire interface is forced to be 
compatible with the lowest member of the chain.    You many be 
running a $20,000 dollar machine, with a million pixel 24 bit 
screen and yet the U-I is designed to run on machines designed 
more than a generation ago, with simple 1 bit screens.

Ideas such as radio buttons I take serious issue with.    Showing 
you all choices at all times, including all the ones you have not 
chosen, leads to the "Boeing 747 Cockpit" effect very quickly.    
The five boxes in the Gradient Designer act rather as a quick 
overview of the current state, i.e. the chosen settings. While the
process of changing these is accomplished separately by a 
click-double click-release motion.    The distinction is not subtle, 
and it has other consequences.    Not only does the 'state-
display' take up a lot less space and can be understood on an 
almost subconscious level by the experience user, the pop-up 
list of choices can also always be extended at any time without 
disturbing the original U-I.

This may sound simple, but I know for a fact that often times 
programmers will enable functionality or new parameters which 
then are locked out in order not to disturb the user interface.    
There may already be several new choices in the radio buttons 
in many dialogs, but the marketing department may not want to
print new screen shots, etc....so they won't get used.

Problems such as this have had a habit of lingering around 
much too long, and merely because everyone else does it, does 
not make a 'standard' a good thing, as a quick laughing gesture 
at eight character files names attests.

Blasphemously, I refused to use other color picker conventions.  
They reminded me of going to another room to pick a small 
sample patch of color and then returning to see if it worked, all 
the while building up a dialog, clicking on buttons to exit, etc.    
Worse yet, color space in 24 bits RGB is intrinsically a three 



dimensional entity and what most color programs use is a 2-D 
representation of the hues and an additional vector for the third 
axis, i.e. a slider to darken the chosen color.    At no time can 
you even see two intensities of RED at the same time.    By 
contrast, the KPT color picker uses special cross-cuts of the 3-D 
color space including a selection of 400 hues and 40 intensity 
variations of EACH at a moments drag and release action.

Each one of these small innovations was added during the 
design phase and the end result strayed as far away from 
standard practice as imaginable.    And yet...I have no regrets in 
doing so and hope you are not put off purely by its unfamiliarity.

The fact that you are even reading this is an encouraging sign, 
because whatever subtleties may be missed by some who 
never read a manual (a rather silly concept of macho-ism) you 
really WILL get more out of the software by giving the following 
pages a chance.

About this Explorers Guide
This is a working, read and play document, rather than an 
engaging late night light browsing.

Wishing you many hours of discovery and surprises. I remain 
with greetings from the entire growing KPT team here at HSC.

Toodles,
Kai



Letter from the President

Imaging Aficionados:
We are pleased to be able to bring to you the preeminent plug-
in creativity tools, Kai's Power Tools for Windows.
This Explorers Guide (manual) is our humble attempt to put our 
minds (and arms) around the power of KPT.    Many of you who 
have used KPT on the Macintosh can appreciate the challenge 
to document the vastness of the environment that KPT provides.
This was the intent in the development of the productto provide 
true creativity tools that allow you to go where no one else has 
ever been before. We trust that we ably provide you with the 
starting points (and some special tips) on how to produce the 
amazing imaging that only KPT can generate.
As a company, HSC Software is committed to providing you with
advanced, new tools for the creation and production of imaging 
and creative arts. We encourage you to join our rapidly growing 
electronic community of imaging and graphic professionals on 
American On-Line (AOL), CompuServe and Internet. The on-line,
electronic chats championed by Kai are a great way to meet 
others who are pushing the envelope.
Join us at one of the many events we sponsor at MacWorld, 
Seybold, Digital World, Comdex, etc., and you'll find an ever 
growing group of people who know each other well before they 
ever physically meet. Their name tags don't carry the typical 
"Mary Jones" or "John Smith" but on-line monochres like "KPT 
Susan," "Virtuality," "DigtlSmudg," "Sushiman," "PixelAnglo" etc.
If you haven't explored the on-line arena, we strongly suggest 
doing so. We fully support you with on-line technical support, 
uploading samples images, publishing power tips and tricks, 
periodically posting free software utilities and, in general, 
working to build a mutually beneficial relationship.
We welcome your feedback and suggestions as they help us 
pave the way for ideas for future generations of our products. 
We promise to continue testing the boundaries of user interface 
design, creative and production tools. Please visit us at the 
trade shows we attend, send samples of your creativity and 
most of all, have fun using Kai's Power Tools. KPT was meant to 
deliver something that very few products deliver, that being a 
sense of discovery within the creative process.

John Wilczak
AOL Cool Tools
President
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Software License Notice
Your software license agreement with HSC Software is included 
in this package.    The license agreement specifies all permitted 
and prohibited uses of the product.    Any unauthorized 
duplication or use of KPT for Windows, in whole or in part, in 
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forbidden. Please read the license agreement carefully before 
agreeing to its restrictions.
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Kai logo and Kai's Power Tools lettering treatment designed by 
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Limited Use license Agreement

You should carefully read the following terms and conditions 
before opening the package. By opening the disk package you 
are agreeing and indicating your acceptance of these terms and
conditions If you do not agree with them you should return the 
package unopened to the dealer from whom you purchased the 
software within 15 days from the date of purchase and your 
money will be refunded. If the dealer from whom you purchased
this package fails to refund your money, contact HSC Software 
immediately at the address below.

HSC Software (hereinafter referred to as Company), the 
software publishing division of Harvard Systems Corp., a 
California based Corporation, provides the computer software 
(hereinafter referred to as Program) contained on the medium in
this package, and licenses its use. You assume full responsibility
for the selection of the Program to achieve your intended 
results, and for the installation, use, and results obtained from 
the Program.



License

A In consideration of the payment of a license fee, you are 
granted a personal, non-transferable and non-exclusive license 
to use the Program under the terms stated in the Agreement. 
You own the diskette or other physical media on which the 
Program is provided under the terms of this agreement, but all 
title and ownership of the Program and enclosed related 
documentation (hereinafter referred to as Documentation), and 
all other rights not expressly granted to you under this 
Agreement, remain with Company.

B The Program may be used by you only on a single computer. 
Therefore, you must treat this software just like a book. With the
exception of Item D below, just like a book means that this 
software may be used by any number of people and may be 
freely moved from one computer location to another, so long as 
there is no possibility of it being used at one location while the 
same copy is at the same time being used at another location. 
Just like a book that the same copy cannot be read by two 
different people in two different places at the same time, 
neither can the same copy of software be used by two different 
people in two different places at the same time. (Unless, of 
course, this license agreement has been violated). Site licenses 
for multiple single users are available. Contact HSC Software for
details.

C You and your employees and agents are required to protect 
the confidentiality of the Program. You may not distribute or 
otherwise make the Program or Documentation available to any 
third party.

D. You may not copy or reproduce the Program or 
Documentation for any purpose except to make one (1) archival
copy of the Program, in machine readable or printed form for 
back up purposes only in support of your use of the Program on 
a single computer. You must reproduce and include the 
Company copyright notice on the backup copy of the Program.

E. Any portion of the Program merged into or used in 
conjunction with another program will continue to be the 
property of Company and subject to the terms and conditions of
this Agreement. You must reproduce and include Company's 
copyright notice on any portion merged in or used in 
conjunction with another program.

F. You may not sublease, assign or otherwise transfer the 
Program or this license to any other person without the prior 
written consent of Company; and

G. You acknowledge that you are receiving on a LIMITED 
LICENSE TO USE the Program and Documentation and that 
Company retains title to the Program and Documentation. You 
acknowledge that Company has valuable proprietary interest in 



the Program and Documentation. You may not use, copy, 
modify, or transfer the program or documentation or any copy 
modification or merged portion in whole or in part except as 
expressly provided for in this agreement. If you transfer 
possession of any copy modification or merged portion of the 
program or documentation to another party, your license is 
automatically terminated.

H. If you have purchased a NETWORK version of the software, 
this license agreement applies to the installation of the software
on to a single file server.    it may not be copied on to multiple 
systems.    Each node connected to the file server must also 
have its own node copy of the software that becomes a license 
for that specific user.



Term

The license granted to you is effective until terminated. You may
terminate it at any time by returning the Program and 
Documentation to Company together with all copies 
modification and merged portions in any form. 

The license will also terminate upon conditions set forth 
elsewhere in the Agreement, or if you fail to comply with any 
term or condition of this Agreement. You agree upon such 
termination to return the Program and Documentation to 
Company together with all copies, modifications, and merged 
portion in any form. 

Upon termination, Company can also enforce any rights 
provided by law. The provision of this Agreement which protect 
the proprietary rights of Company will continue in force after 
termination.



Limited Warranty

Company warrants, as the sole warranty, that the diskette(s) on 
which the program is furnished will be free from defects in 
materials and workmanship under normal use and conditions for
a period of ninety (90) days from the date of delivery to you as 
evidenced by a copy of your receipt. No distributor, dealer, or 
any other entity or person is authorized to expand or alter 
either this warranty or this agreement. Any such 
representations will not bind Company. 

Company does not warrant that the functions contained in the 
Program will meet your requirements or that the operation of 
the Program will be uninterrupted or error-free. Except as stated
above in this section, the program and documentation are 
provided as-is without warranty of any kind either expressed or 
implied, including but not limited to the implied warranties of 
merchantability and fitness for a particular purpose. You assume
entire risk as it applies to the quality and performance of the 
program and documentation. 

Should the program prove defective you (and not Company, 
authorized Company Distributor or dealer) assume the entire 
cost of all necessary servicing repair or correction.    This 
warranty gives you specific legal rights and you may also have 
other rights which vary from state to state. Some states do not 
allow the exclusion or implied warranties, so the above 
exclusion may not apply to you.



Limitation of Remedies

Company's entire liability and remedy will be:

A. The replacement of any diskette not meeting Company's 
Limited Warranty explained above and which is returned to 
Company or an authorized Company distributor or dealer with a 
copy of your receipt; or

B. If Company is unable to deliver a replacement diskette which 
conforms to the warranty provided under this agreement, you 
may terminate this agreement by returning the program and 
documentation to Company, authorized Company distributor, or
dealer from whom you obtained the program and your license 
fee will be refunded.



Product Returns

If you must ship the program and documentation to an 
authorized Company distributor, dealer, or to Company, you 
must prepay shipping and either insure the program and 
documentation or assume all risk of loss or damage in transit. 

To replace a defective diskette during the ninety (90) day 
warranty period, if you are returning the medium to Company, 
please send us your name and address, the defective medium 
and a copy of your receipt at the address provided below. In no 
event will Company be liable to you for any damages direct, 
indirect, incidental, or consequential, including damages for any
lost profits, lost savings, or other incidental or consequential 
damages arising out of the use or inability to use such program 
and documentation, even if Company has been advised of the 
possibility of such damages, or for any claim by any other party.

Some states do not allow the limitation or exclusion of liability 
for incidental or consequential damages so the above limitation 
or exclusion may not apply to you. In no event will Company 
liability of damages to you or any other person ever exceed the 
amount of the license fee paid by you to use the program 
regardless of the form of the claim.



US Government Restricted Rights

The Program and Documentation are provided with restricted 
rights. Use duplication or disclosure by the US Government is 
subject to restrictions as set Forth in subdivision (b) (3) (ii) of 
the Rights in Technical Data and Computer Software Clause at 
252.227-7013. Contractor/Manufacturer is HSC Software, 1661 
Lincoln Boulevard, Suite 101, Santa Monica, CA 90404.



General

This agreement is governed by the laws of the state of 
California (except federal law governs copyrights and register 
trademarks). If any provision of this agreement is deemed 
invalid by any court having jurisdiction, that particular provision 
will be deemed deleted and will not affect the validity of any 
other provision of this Agreement. Should you have any 
questions concerning this agreement you may contact HSC 
Software at the address below.

HSC Software 
1661 Lincoln Boulevard - Suite 101 
Santa Monica, CA 90404 
(213)392-8441 Voice 
(213)392-6015 Fax




