
NewsScan Overview

The number of news articles that appear on the World Wide Web's many newsgroups is growing 
everyday. Finding articles that are of interest to you is becoming more difficult and can take a 
considerable amount of time. NewsScan is a time saving utility that monitors a Usenet news server 
for articles that meet criteria that you select. You specify how often you want NewsScan to monitor the
newsgroups and it looks for articles each day, each hour, or whenever you tell it to scan the 
newsgroups. When NewsScan finds articles that meet your criteria, it downloads them to your 
computer for easy viewing.

The number of search criteria that you can add to NewsScan is almost unlimited and the monitoring 
process takes place without you having to do anything after you've entered your search criteria. Just 
keep NewsScan running in the background and it will keep you up-to-date on the news articles you 
consider important. No more wading through hundreds of articles and missing the important ones that
are surrounded by articles that don't interest you.
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How NewsScan works

When you start NewsScan for the first time, you need to specify some criteria for NewsScan to use 
when monitoring the newsgroups. After you've added some search criteria, you need to specify how 
often you want NewsScan to monitor the newsgroups for your criteria. By default, the frequency is set
to Daily.

You can leave NewsScan running in the background and it will scan the newsgroups for your criteria 
at the frequency you've specified. If you choose not to leave NewsScan running in the background, 
each time you start the program, it checks the current time and date to determine if it needs to scan 
the newsgroups for articles that meet your criteria.
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Getting Started

Add a scan criteria
Before NewsScan can start sorting through the newsgroups and retrieving articles that interest you, 
you must tell it what criteria to look for. {button ,AL(`To add a scan criteria to the list',1,`',`second')}

Set the scan frequency
After you've set one or more scan criteria, you should specify how often you want NewsScan to check
the newsgroups for articles that meet your criteria. {button ,AL(`To specify the frequency that you want
NewsScan to check the newsgroups',1,`',`second')}

Configure the news reader
Before you begin reading news articles, you should specify which reader you want to use. 
{button ,AL(`To specify the name of the news server',1,`',`second')}

Read an article
After NewsScan has created a list of articles based on your search criteria, reading the articles is 
easy. Simply double click on any article and NewsScan automatically launches the news reader and 
opens the article.
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Exit command (File menu)

Commands: Exit

Shortcuts: Alt+F4

If you want to stop NewsScan from running on your system, you can exit the application. You may 
also run other applications and leave NewsScan running in the background.    While running in the 
background, NewsScan continues to scan the newsgroups, using your criteria, at the frequency you 
specified in the Options dialog box.

When NewsScan is minimized, it appears next to the clock on the task bar.

To exit NewsScan:
1. From the File menu, choose the Exit command.

To leave NewsScan running in the background:
1. From the System menu, choose the Minimize command.
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Status Bar command (View menu)

Commands: Status Bar

Shortcuts: N/A

The status bar displays status and help information for NewsScan across the bottom of the 
NewsScan window. By default, the status bar is visible and displays a prompt for Help. The Status Bar
command has a check-mark beside it when the status bar is visible.

To turn the status bar on or off:
1. From the View menu, Choose Status Bar.



Scan Now command (Tools menu)

Commands: Scan Now

Shortcuts: N/A

NewsScan can be set to scan newsgroups for specific topics on a regular basis. However, you may 
want to check the newsgroups for those topics at a time other than on the interval you've selected in 
the properties dialog box. Therefore, at any time, you can request that NewsScan check the 
newsgroups for articles that meet your criteria using the Scan Now command. 

The Scan Now command won't find any articles that you've already read and deleted. If you want 
NewsScan to display all the articles on a topic, including articles you've already read, use the Re-scan
All Criteria, All Groups command.

To scan a selected page for activity:
1. From the Tools menu, choose the Scan Now command.
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Edit Scan Criteria (Tools menu)

Commands: Edit Scan Criteria

Shortcuts: N/A

The key to making NewsScan work for you is the criteria that you select for scanning. The Edit Scan 
Criteria command displays a dialog box that allows you to add, edit, and remove scan criteria. When 
you start NewsScan for the first time and choose the Edit Scan Criteria command, the list is empty. 
You need to add at least one scan criteria to the list before NewsScan can provide an article list for 
you.

To add a scan criteria to the list:
1. From the Tools menu, choose the Edit Scan Criteria command.
2. Click the Add button.
3. Type a name to identify this criteria selection
4. Type the name of the newsgroup you want to scan in the Newsgroup to Scan text box. If you're 

unsure of the exact name of a newsgroup, click the browse button and scroll through the Available 
Newsgroups list until you find the appropriate newsgroup name. Select the newsgroup from the list 
and click the Add button. You can select as many newsgroups as you think might contain 
information on the topic you want to search. Click OK.

5. In the Text to scan for text box, type the text that you want NewsScan to look for in the newsgroup 
articles.

6. Click the Close button.

To remove a scan criteria from the list:
1. Select a scan criteria in the list.
2. Click the Remove button.
3. Click the Close button.

To modify a scan criteria's parameters:
1. Select a scan criteria in the list.
2. Click the Edit button.
3. Make any changes to the scan criteria you require and click OK.
4. Click the Close button.



Delete Selected command (Tools menu)

Commands: Delete Selected

Shortcuts: N/A

The list of articles that meet all your scan criteria may be very large. After viewing articles, you may 
want them to be removed from the list to make viewing the list of remaining articles easier. 

To delete a single news article from the list:
1. Select an article in the list.
2. From the Tools menu, choose the Delete Selected command.
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Delete Seen Articles command (Tools menu)

Commands: Delete Seen Articles

Shortcuts: N/A

The list of articles that meet all your scan criteria may be very large. After viewing articles, you may 
want them to be removed from the list to make viewing the list of remaining articles easier. The Delete
Seen Articles command removes all articles that you've read from the list.

To delete all the articles you've read from the list:
1. From the Tools menu, choose the Delete Seen Articles command.
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Refresh Newsgroup List command (Tools menu)

Commands: Refresh Newsgroup List

Shortcuts: N/A

The number and names of newsgroups that are available on the Web change from time to time. As a 
result, you may need to refresh the list of newsgroups that NewsScan will monitor. 

To refresh the newsgroup list:
1. From the Tools menu, choose the Refresh newsgroup List command.



Re-scan All Criteria, All Groups command (Tools menu)

Commands: Re-scan All Criteria, All Groups

Shortcuts: N/A

If you've read an article that appeared in a newsgroup and deleted that article from the list, using 
either the Delete Selected or Delete Seen Articles commands, it will not appear in your list again. You 
can force NewsScan to display all news articles which meet your criteria, including articles you've 
already deleted, using the Re-scan All Criteria, All Groups command.

To display articles you've already deleted:
1. From the Tools menu, choose the Re-scan All Criteria, All Groups.
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Options command (Tools menu)

Commands: Options

Shortcuts: N/A

The Options command provides access to a dialog box that has two tabs: General and Reader. 

The General Tab allows you to specify the name of the news server you're going to access and the 
frequency that you want NewsScan to scan for news articles.

The Reader tab allows you to specify the news reader you're going to use to read the articles.

To specify the name of the news server:
1. From the Tools menu, choose the Options command.
2. Type the name of the Usenet news server.
3. Click the Test button to confirm that you can access the server properly.
4. Click the OK button.

To specify the frequency that you want NewsScan to check the newsgroups:
1. From the Tools menu, choose the Options command.
2. Choose Hourly, Daily, or Manual from the Scan Frequency group.
3. Click the OK button.

To specify when NewsScan uses its built-in or an external reader:
1. From the Tools menu, choose the options command.
2. Click the Reader tab.
3. Select when you want NewsScan to use its built-in or an external reader.
4. Click the OK button.

To use an external news reader:
1. From the Tools menu, choose the options command.
2. Click the Reader tab.
3. Choose either Use the built-in reader only for expired articles or Always use the external news 

reader from the News Article Reader Selection group.
4. Type the executable name of your Web browser, including its path, in the path dialog box. If you're 

unsure of the path and executable name of your browser, use the Browse button to look through 
your hard disk.

5. Click the OK button.

{button ,AL(`General tab (Options dialog box);Options;Reader tab (Options dialog box);Scan 
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Contents command (Help menu)

Commands: Contents

Shortcuts: N/A

Choosing the Contents command displays a list of topics available in this Help file.



Using Help command (Help menu)

Commands: Using Help

Shortcuts: N/A

Many different types of online help are available with the NewsScan. If you need help while using 
NewsScan and you're unsure of how to access the appropriate help information, the Using Help 
command provides a description of the Help that's available.

You can browse through this Help file to become familiar with the help features available in 
NewsScan.

You can also use context-sensitive Help to display information about specific commands, dialog 
boxes, and other window elements.

To open the online NewsScan Help files:
1. From the Help menu, choose the Contents command or press the F1 key.

Using context-sensitive Help
When you use context-sensitive Help, NewsScan determines your current status and displays related 
help information. For example, if a dialog box is open, NewsScan displays information about the 
dialog box. If you've highlighted a command, the information describes the function of that command.

To display Help for a specific command:
1. Highlight the command.
2. Press the F1 key.

To display Help for a specific dialog box:
1. Press the Help button on the dialog box.

To display Help for window elements such as buttons and list boxes:
1. Press the Shift and F1 keys at the same time and then click the element.



About NewsScan command (Help menu)

Commands: About

Shortcuts: N/A

The About NewsScan command displays version information about NewsScan.

To display the version of NewsScan that you're using:
1. From the Help menu, choose the About command.



Keyboard Short-cuts

Function Keyboard Short-cut

Delete Selected 
{button ,AL(`Delete 
Selected command 
(Tools menu)')}

Del

System menu is activated by clicking on the NewsScan icon in the upper-left corner of the 
NewsScan window. It contains commands which allow you to restore, move, size, minimize, 
maximize, and close the NewsScan window.



Minimize reduces the window to an icon beside the clock on the task bar. This action occurs when 
you either choose the Minimize command from the System menu or click the left button in the upper 
right-hand corner of the window.



Maximize increases the window to the size of your screen. This action occurs when you either 
choose the Maximize command from the System menu or click the right button in the upper right-
hand corner of the window.



Size allows you to drag a border on the window to resize it.



Close shuts down the window.



Restore returns the window to its original size.



Move allows you to drag the window to a new location.



Switch To displays the Task List from which you can activate another application.



Caption bar displays the name of the current directory contents and pane.



Scroll bars advance the information in the current panel.



News Scan Criteria

The criteria that are listed in the News Scan Criteria dialog box are used by NewsScan to find articles 
that you're interested in. You must have at least one entry in this list before NewsScan will display 
articles in the main NewsScan window. If you don't have any criteria listed in the News Scan Criteria 
list box, you must add at least one entry.

Help button displays this help topic.

Add button adds a new scan criteria to the list.

Edit button modifies the selected scan criteria.

Remove button deletes the selected scan criteria from the list.

Close button exits from the NewsScan Criteria dialog box.

{button ,AL(`Edit Scan Criteria (Tools menu)')}



About NewsScan

The About NewsScan dialog box displays version information about NewsScan.



Search Criteria

The Search Criteria dialog box allows you to specify the parameters of a search criteria that 
NewsScan uses while scanning newsgroups. The search criteria is comprised of three components: a
name, a newsgroup name, and the text that you want NewsScan to search for. Type the text you want
NewsScan to watch for in the Text to scan for text box and select a newsgroup that may contain that 
text. Type a name for this search in the Criteria name text box.

Criteria Name text box specifies the name that you want assigned to this criteria.

Newsgroup to scan text box specifies the name of the newsgroup that you want NewsScan to 
search.

Browse button allows you to select a newsgroup from a list of all the newsgroups that are available 
on the Web.

Text to scan for text box specifies the text that you want NewsScan to look for in the newsgroup.

OK button accepts the criteria you've specified and exits from the Search Criteria dialog box.

Cancel button exits from the Search Criteria dialog box and discards the search criteria you've 
specified.

Help button displays this help topic.

{button ,AL(`Edit Scan Criteria (Tools menu)')} Related Topics



Status

The Status dialog box displays the number of newsgroups that NewsScan has located on the news 
server. NewsScan returns to the main window when it has compiled a list of all available newsgroups.

Cancel button stops the search for newsgroups and exist from the Status dialog box.

{button ,AL(`Refresh Newsgroup List command (Tools menu)')} Related Topics



Newsgroup Selection

The Newsgroup Selection dialog box appears when you press the Browse button on the Search 
Criteria dialog box. It allows you to browse through the a list of available newsgroup names and select
the groups that you want NewsScan to monitor for your selected words. Select an appropriate 
newsgroup in the Available Newsgroups list box and click the Add button. The newsgroup name is 
added to the Selected Newsgroups list box. The list of newsgroups that you select will be used in the 
current search criteria.

Available Newsgroups list box displays a list of newsgroups that are available for you to select.

Selected Newsgroups list box displays the list of newsgroups that you've selected.

Add button adds the newsgroup you've selected in the Available Newsgroups list box to the Selected
Newsgroups list box.

Remove button deletes the newsgroup you've highlighted in the Selected Newsgroups list box.

Major newsgroup hierarchies only check box displays only the major newsgroups in the Available 
Newsgroups list box. Disabling this check box displays many more newsgroups.

OK button accepts the newsgroups you've selected and exits from the Newsgroup Selection dialog 
box.

Cancel button exits from the Newsgroup Selection dialog box and discards the list of newsgroups 
you've selected.

Help button displays this help topic.
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Options

The options dialog box contains two tabs; the General tab and the Reader tab. Select either of the 
tabs and modify the settings as are appropriate for your system.

The General tab allows you to specify the name of the news server, test your access to the server, 
and specify the frequency with which you want NewsScan to check the newsgroups for your selected 
criteria.

The Reader tab allows you to specify how you will view articles. If you don't have an application that 
allows you to read news, you can use NewsScan's built-in reader. You can also instruct NewsScan to 
use another reader.

OK button accepts the options you've selected and exits from the Options dialog box.

Cancel button exits from the Options dialog box and discards the options you've selected.

Apply button applies the option changes you've made.

Help button displays the help topic for the currently selected tab.

{button ,AL(`General tab (Options dialog box);Reader tab (Options dialog box)')} Related 
topics



General tab (Options dialog box)

The General tab allows you to specify the name of the news server, test your access to the server, 
and specify the frequency with which you want NewsScan to check the newsgroups for your selected 
criteria.

Usenet news server name specifies the name of the News server that NewsScan will monitor for 
your selected criteria.

Test Now button tests whether your computer can properly access the news server specified in the 
Usenet news server name text box.

Scan frequency hourly specifies that NewsScan will check the news server for articles that meet 
your search criteria each hour.

Scan frequency daily specifies that NewsScan will check the news server for articles that meet your 
search criteria once each day.

Scan frequency manual specifies that NewsScan won't check the news server for topics that meet 
your search criteria on a regular basis. If you make this selection, you must use the Scan Now or the 
Re-scan All Criteria, All Groups commands to update your list of articles that meet your search 
criteria.

OK button accepts the options you've selected and exits from the Options dialog box.

Cancel button exits from the Options dialog box and discards the options you've selected.

Apply button applies the option changes you've made.

Help button displays this help topic.



Specifies the name of the News server that NewsScan will monitor for your selected criteria.



Tests whether your computer can properly access the news server specified in the Usenet news server name text box.



Selects how often you want NewsScan to check the news server for the criteria you've specified.



Specifies that NewsScan will check the news server for articles that meet your search criteria each hour.



Specifies that NewsScan will check the news server for articles that meet your search criteria once each day.



Specifies that NewsScan won't check the news server for topics that meet your search criteria on a regular basis. If you make 
this selection, you must use the Scan Now or the Re-scan All Criteria, All Groups commands to update your list of articles that 
meet your search criteria.



Reader tab (Options dialog box)

The Reader tab allows you to specify how you will view articles. If you don't have an application that 
allows you to read news, you can use NewsScan's built-in reader. You can also instruct NewsScan to 
use another reader.

Reader tab News article reader group selects the circumstances under which you will use a specific
reader.

Reader tab Always use the built in specifies that NewsScan will always use its built-in reader for 
displaying articles from the newsgroups.

Reader tab Use the built in for expired specifies that the built-in reader will only be used for reading
articles that the news server has marked as expired. Some external reader applications won't allow 
you to read expired articles.

Reader tab Always use external specifies that NewsScan will always use an external reader 
application for displaying news articles.

Web browser path specifies the path and name of your news reader if you don't want to use 
NewsScan's built-in reader all the time.

Reader tab Path to reader specifies the path and executable file name of a news reader if you don't 
want to use NewsScan's built-in reader all the time.

Reader tab Browse button allows you to view the folders on any drives that are available to your 
system to make it easier to locate your news reader if you don't want to use NewsScan's built-in 
reader all the time.

OK button accepts the options you've selected and exits from the Options dialog box.

Cancel button exits from the Options dialog box and discards the options you've selected.

Apply button applies the option changes you've made.

Help button displays this help topic.



Selects the circumstances under which you will use a specific reader.



Specifies that NewsScan will always use its built-in reader for displaying articles from the newsgroups.



Specifies that the built-in reader will only be used for reading articles that the news server has marked as expired. Some 
external reader applications won't allow you to read expired articles.



Specifies that NewsScan will always use an external reader application for displaying news articles.



Specifies the path and executable file name of a news reader if you don't want to use NewsScan's built-in reader all the time.



Allows you to view the folders on any drives that are available to your system to make it easier to locate your news reader if 
you don't want to use NewsScan's built-in reader all the time.



Specifies the name that you want assigned to this criteria.



Specifies the name of the newsgroup that you want NewsScan to search.



Allows you to select a newsgroup from a list of all the newsgroups that are available on the Web.



Specifies the text that you want NewsScan to look for in the newsgroup.



Accepts the criteria you've specified and exits from the Search Criteria dialog box.



Exits from the Search Criteria dialog box and discards the search criteria you've specified.



Displays this help topic.



Just an icon



Lists all of the search criteria that you want NewsScan to use when monitoring the newsgroups. If this list is empty, click on the 
Add... button in this dialog box.



Displays this help topic.



Adds a new scan criteria to the list.



Modifies the selected scan criteria.



Deletes the selected scan criteria from the list.



Exits from the NewsScan Criteria dialog box.



Stops the search for newsgroups and exist from the Status dialog box.



Displays a list of newsgroups that are available for you to select.



Displays the list of newsgroups that you've selected.



Adds the newsgroup you've selected in the Available Newsgroups list box to the Selected Newsgroups list box.



Deletes the newsgroup you've highlighted in the Selected Newsgroups list box from the list.



Displays only the major newsgroups in the Available Newsgroups list box. Disabling this check box displays many more 
newsgroups in the list.



Accepts the newsgroups you've selected and exits from the Newsgroup Selection dialog box.



Exits from the Newsgroup Selection dialog box and discards the list of newsgroups you've selected.



Displays this help topic.



 



Minimizing NewsScan on startup

After you’ve selected the Web pages you want to monitor, you’ll probably want NewsScan to run in 
the background (minimized) whenever your system is up and running. You can add NewsScan to 
your Windows 95 Startup group and it will start whenever you system first starts. 

For information on adding a program to the Startup group, click {button ,AL(`Adding a program to 
the Starup group',1,`',`second')}.

You can specify that you want NewsScan to run minimized whenever it starts by modifying its Run 
setting in the NewsScan application properties settings. 

To change the Run setting to minimized:
1. Open the Internet Mania folder and click the NewsScan icon. Don’t double click.
2. From the File menu in the Internet Mania folder, choose the Properties command.
3. Choose the Shortcut tab.
4. In the Run list box, select Minimized.
5. Click the OK button.



Adding a program to the Startup group
To add a program to the Start or Programs menu
1 Click the Start button, and choose Settings.
2 Click Taskbar, and click the Start Menu Programs tab.
3 Click the Add button.
4. Click the Browse button.
5. Locate the program you want to add, and double-click it.
6. Click the Next button, and double-click the menu on which you want the program to appear.
7. Type the name that you want to see on the menu, and click the Finish button.

If Windows prompts you to choose an icon, click one, and then click the Finish button.



How to...

Using NewsScan
add a scan criteria to the list
delete a single new article from the list
delete all the articles you've read from the list
display articles you've already deleted
exit NewsScan
leave NewsScan running in the background
modify a scan criteria's parameters
refresh the Newsgroup list
remove a scan criteria from the list
scan a selected page for activity
turn the status bar on or off

Configuring NewsScan
specify the frequency that you want NewsScan to check the newsgroups
specify the name of the news server
specify when NewsScan uses a built-in or external reader

Help topics
display Help for a specific command
display Help for a specific dialog box
display Help for window elements such as buttons and list boxes
display the version of NewsScan that you're using
open the online NewsScan Help files




