
Telnet Index

The Index contains a list of all Help topics available for Telnet.    You can use the scroll bar to see the 
entries that are not currently visible in the Help window.

For information on how to use Help, press F1 or choose Using Help from the Help menu.
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New

New creates a new configuration template.

When you choose New, Custom lets you start with a blank configuration template(file).

To select a new file:

1. Point to the File menu and click the mouse button.

2. Click the New command.



Open...

Open an existing configuration file.

When you choose Open, Custom lets you load an existing configuration file.

To Open a new configuration file:

1. Point to the File menu and click the mouse button.

2. Click the Open command.

3. Select the Drive and directory by double click the selected item.

4. Enter or double click the filename into the text box.

4. Choose OK.



Save

To save configuration parameter changes, to the default file:

1. Point to the File menu and click the mouse button.

2. Click the Save command.



Save As...

The Save As enables you to select the file name, directory, and drive to be used for saving configuration 
parameters.

To select a new Filename:

1. Point to the File menu and click the mouse button.

2. Click the Save As command.

3. Select the Drive and directory by double click the selected item.

4. Enter the filename into the text box.

5. Choose OK.



Exit

To exit TELNET:

1. Point to the File menu and click the mouse button.

2. Click the Exit command.



Overview

TELNET is a terminal emulation communication program using NEWT-Enhanced Windows TCP/IP stack. 
TELNET communicates with another host using the TELNET protocol.    TELNET can be invoked with 
arguments {telnet [ host [ port ] ]}.    If TELNET is invoked without arguments, it enters a window mode.    
In this mode, it accepts and executes the commands listed below.    If it is invoked with arguments, it 
performs an open command with those arguments.    Default port is assumed to be the well known 
TELNET port 23, passing a "?" will result in a dialog box appearing up, prompting for the port number(see
Connect).

In addition to the Host and Port parameters, TELNET takes the following arguments:

-f "file"              A configuration file to be loaded with TELNET 
-k "file"              A keyboard configuration file to be loaded with TELNET 
-t "Type"          Terminal Type to emulate

In the absence of any or all of the above arguments the default files are used. (defaults can be changed 
using the "Save" commands. See appropriate help topic)

Once a connection has been opened, TELNET enters input mode.    In this mode, text typed is sent to the 
remote host.

Upon startup, TELNET will size the window to 24 lines by 80 characters based on the selected/default 
font size. TELNET configurations can be stored in a file.    If a default configuration file (TELNET.CFG) 
exist it will be loaded at start up.

An animated icon is provided, to signal that a connection is active or non-active.



Copy

Copy copies the selected text from the TELNET window onto Clipboard, leaving the original intact and 
erasing the previous Clipboard contents.

To copy text:

1. Select the text.

2. Choose Copy from the Edit menu to copy text.



Paste

Use Paste to place the Clipboard content in the TELNET window.

To paste text:

1. Choose Paste from the Edit menu to paste text.



Clear Buffer

Clear buffer is used to reset the information in the buffer to the initial state, all Blank.

To clear the buffer:

1. Choose Clear Buffer from the Edit menu.



Connect

Connect is used to establish a connection between this computer and a host on the network.    A 
connection can be established by using the target host name or IP address.    Default port is assumed to 
be the well known TELNET port 23, any port can be specified by entering the desired port number in the 
appropriate text box.

To Connect to a host:

1. Point to the Connect menu and click the mouse button.

2. Enter the Host Name, or the IP address into the text box.

3. Enter a port number if appropriate(default 23).

4. Choose OK.



Disconnect

Disconnect is used to close the connection between this computer and a host on the network.

To Disconnect:

1. Point to the Disconnect menu and click the mouse button.



Terminal Modes

To specify terminal modes, select the appropriate Terminal Modes check boxes in the Terminal 
Preferences dialog box:

Local Echo Display your keystrokes on your terminal.    If the remote computer echoes your 
keystrokes back to you, leave Local Echo off.

Sound Turn on the system bell for the remote computer.



CR -> CR/LF

Specifying Carriage Returns and Linefeeds (CR to CR/LF)

To cause a carriage return to be interpreted as a carriage return plus a linefeed:

Select Inbound and/or Outbound check boxes in the Terminal Preferences dialog box. Then 
choose OK.

Select the Inbound or Outbound option according to how the remote computer handles the end of
a line and what it expects from other computers. If the remote computer sends carriage returns 
only, select Inbound. If the remote computer sends carriage returns followed by linefeeds, don't 
select Inbound. If the remote computer expects to get carriage returns and add its own linefeeds, 
don't select Outbound.



Cursor

Specifying the Cursor

To specify how the cursor will appear:

1 Select the Block or Vertical line option button to specify the cursor's shape.

2 Select the Dim check box in the Terminal Preferences dialog box for a dim cursor.



Columns

Specifying Columns for Your Monitor

To specify columns:

Select the 80 or 132 option button in the Terminal Preferences dialog box.

You can have an 80-column monitor behave as if it were a wide monitor. If you specify 132, 
Terminal will reserve 132 columns for text whether or not 132 columns are entered or received.



Buffer Lines
Setting the Buffer Lines

To set how many lines of information can be saved in the buffer:

1 Choose Terminal Preferences from the Settings menu.

2 Type a number between 25 and 400 in the Buffer Lines text box.    If you type a number higher 
than available memory permits, Terminal sets the buffer lines to the largest number permitted.



National Character Set
NRC (National Replacement Character) is a method that partially solves multinational character problem 
in 7 bit mode.    It replaces some of the ASCII characters to the specified language's characters.
The NRC has 12 languages support including USASCII. 

Note: In this mode, characters such as    #,@,[,\,]..can not be used. 

If you set the NRC option on, your keyboard input will be filtered before transmitted to the remote host.

Note: There are NRC filters for incoming data in the currently shipping version of TELNET



Enable Alt+Keypad Input

If you want to use extended ASCII characters, select the Enable Alt+Keypad Input option.    To use 
extended ascii characters, type desired keypad numbers, while holding the Alt key down.



Colors...

Use Colors... to select both the foreground and the background colors for your screen display. A palette of
16 colors is available. An area that shows the resulted combination is also displayed. To set the colors 
back to the default, click on Default. Clicking the All Defaults sets all fields to the factory-set default 
colors.

To select color:

1. From the menu item Settings, select Color...

2. Select background and foreground colors.

3. Select OK.



Fonts...

To select fonts:

1. From the menu item Settings, select Fonts...

2. Select the font, font type and font size you want to use.

3. Select OK.



Keyboard...

The Keyboard setting feature lets you map the keys of the keyboard to specific functions as may be 
needed by your host system.    Multiple maps can be defined and stored in different files for use with 
different host systems.

1. Select Keyboard from your Setting menu.

2. Hit the key you need to be mapped. Note that you can combine every key with Shift, Control or the 
Alt keys (Hold down the appropriate key or keys or check the appropriate box or boxes.

3. Move the cursor to the "Mapped To" side and select one of the pre-defined functions, or enter your 
own desired mapping (see conventions below)

4. Click the Add button.    Click on the Delete button to remove a mapping from the table.

5. Save the mapping onto a file as appropriate (use Save if you are always using one single mapping, 
use Save As if you plan to maintain multiple maps)

Conventions used in the "Mapped To:" field for manual entry:

\E - Escape character.

^X - Control character, a carriage return can be represented ^M.    An escape character can be 
represented as ^[.

\OOO - Octal equivalent of the character.    As an example character 'A' can be represented as \101.    A 
carriage return character, ^M, can be represented as \015. The "Delete" key (used by 
many systems for "Backspace") is \177.

Following you will find ASCII table:

      Octal - Character

|000 NUL|001 SOH|002 STX|003 ETX|004 EOT|005 ENQ|006 ACK|007 BEL|
|010 BS |011 HT |012 NL |013 VT |014 NP |015 CR |016 SO |017 SI |
|020 DLE|021 DC1|022 DC2|023 DC3|024 DC4|025 NAK|026 SYN|027 ETB|
|030 CAN|031 EM |032 SUB|033 ESC|034 FS |035 GS |036 RS |037 US |
|040 SP |041  ! |042  " |043  # |044  $ |045  % |046  & |047  ' |
|050  ( |051  ) |052  * |053  + |054  , |055  - |056  . |057  / |
|060  0 |061  1 |062  2 |063  3 |064  4 |065  5 |066  6 |067  7 |
|070  8 |071  9 |072  : |073  ; |074  < |075  = |076  > |077  ? |
|100  @ |101  A |102  B |103  C |104  D |105  E |106  F |107  G |
|110  H |111  I |112  J |113  K |114  L |115  M |116  N |117  O |
|120  P |121  Q |122  R |123  S |124  T |125  U |126  V |127  W |
|130  X |131  Y |132  Z |133  [ |134  \ |135  ] |136  ^ |137  _ |
|140  ` |141  a |142  b |143  c |144  d |145  e |146  f |147  g |
|150  h |151  i |152  j |153  k |154  l |155  m |156  n |157  o |
|160  p |161  q |162  r |163  s |164  t |165  u |166  v |167  w |
|170  x |171  y |172  z |173  { |174  | |175  } |176  ~ |177 DEL|

      Hexadecimal - Character

| 00 NUL| 01 SOH| 02 STX| 03 ETX| 04 EOT| 05 ENQ| 06 ACK| 07 BEL|
| 08 BS | 09 HT | 0A NL | 0B VT | 0C NP | 0D CR | 0E SO | 0F SI |
| 10 DLE| 11 DC1| 12 DC2| 13 DC3| 14 DC4| 15 NAK| 16 SYN| 17 ETB|



| 18 CAN| 19 EM | 1A SUB| 1B ESC| 1C FS | 1D GS | 1E RS | 1F US |
| 20 SP | 21  ! | 22  " | 23  # | 24  $ | 25  % | 26  & | 27  ' |
| 28  ( | 29  ) | 2A  * | 2B  + | 2C  , | 2D  - | 2E  . | 2F  / |
| 30  0 | 31  1 | 32  2 | 33  3 | 34  4 | 35  5 | 36  6 | 37  7 |
| 38  8 | 39  9 | 3A  : | 3B  ; | 3C  < | 3D  = | 3E  > | 3F  ? |
| 40  @ | 41  A | 42  B | 43  C | 44  D | 45  E | 46  F | 47  G |
| 48  H | 49  I | 4A  J | 4B  K | 4C  L | 4D  M | 4E  N | 4F  O |
| 50  P | 51  Q | 52  R | 53  S | 54  T | 55  U | 56  V | 57  W |
| 58  X | 59  Y | 5A  Z | 5B  [ | 5C  \ | 5D  ] | 5E  ^ | 5F  _ |
| 60  ` | 61  a | 62  b | 63  c | 64  d | 65  e | 66  f | 67  g |
| 68  h | 69  i | 6A  j | 6B  k | 6C  l | 6D  m | 6E  n | 6F  o |
| 70  p | 71  q | 72  r | 73  s | 74  t | 75  u | 76  v | 77  w |
| 78  x | 79  y | 7A  z | 7B  { | 7C  | | 7D  } | 7E  ~ | 7F DEL|

      Decimal - Character

|  0 NUL|  1 SOH|  2 STX|  3 ETX|  4 EOT|  5 ENQ|  6 ACK|  7 BEL|
|  8 BS |  9 HT | 10 NL | 11 VT | 12 NP | 13 CR | 14 SO | 15 SI |
| 16 DLE| 17 DC1| 18 DC2| 19 DC3| 20 DC4| 21 NAK| 22 SYN| 23 ETB|
| 24 CAN| 25 EM | 26 SUB| 27 ESC| 28 FS | 29 GS | 30 RS | 31 US |
| 32 SP | 33  ! | 34  " | 35  # | 36  $ | 37  % | 38  & | 39  ' |
| 40  ( | 41  ) | 42  * | 43  + | 44  , | 45  - | 46  . | 47  / |
| 48  0 | 49  1 | 50  2 | 51  3 | 52  4 | 53  5 | 54  6 | 55  7 |
| 56  8 | 57  9 | 58  : | 59  ; | 60  < | 61  = | 62  > | 63  ? |
| 64  @ | 65  A | 66  B | 67  C | 68  D | 69  E | 70  F | 71  G |
| 72  H | 73  I | 74  J | 75  K | 76  L | 77  M | 78  N | 79  O |
| 80  P | 81  Q | 82  R | 83  S | 84  T | 85  U | 86  V | 87  W |
| 88  X | 89  Y | 90  Z | 91  [ | 92  \ | 93  ] | 94  ^ | 95  _ |
| 96  ` | 97  a | 98  b | 99  c |100  d |101  e |102  f |103  g |
|104  h |105  i |106  j |107  k |108  l |109  m |110  n |111  o |
|112  p |113  q |114  r |115  s |116  t |117  u |118  v |119  w |
|120  x |121  y |122  z |123  { |124  | |125  } |126  ~ |127 DEL|



Reset Size

Upon startup, TELNET will size the window to 24 lines by 80 characters based on the selected/default 
font size.    Reset Size can be used to reset the window to the original default size.

To Reset the window size:

1. Choose Reset Size from the Settings menu.



Are You There?...

Are you there is used to send an ARE YOU THERE? TELNET command to the connected host.

If the host is connected, the host will replay [Yes}, which will be sent to the window.



Help

Using Help

To choose a Help topic:

Mouse Point to the underlined topic you want to view and click the mouse button.

When the pointer is over an item you can choose, the pointer changes to a hand 
icon.

Keyboard Press Tab to move the highlight to the underlined topic you want to view, and 
then press Enter.

To exit Help:

Mouse                        1      Point to the File menu and click the mouse button.

2      Click the Exit command.

Keyboard                    1      Press Alt.
2      Type the letter F.
3      Type the letter X.



About

Information about the program etc.

1. Choose OK to continue.




