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Overview

The Mail application provides electronic mail services using the Simple Mail Transfer Protocol to both 
send and receive mail, and the Post Office Protocol and POP3 to retrieve mail from a server.    You can 
use these protocols to create your own mail network, or directly integrate with UNIX mail.

Setting up Mail

When you set up a mail account for a user for the first time you need to login as Postmaster to define a 
user's name, password, real name, and mail directory.    Then, after the account is set up you need to 
login as the user to define a mail gateway and mail server. The steps are listed and described below:

Postmaster login steps are:

1.      Login as Postmaster

2.      Define the user's name, password, real name, and mail directory.

User login steps are:

1.      Log in as a user

2.      Define a mail gateway

3.      Define a mail server (if necessary)

Postmaster Login Steps

To log in as Postmaster, define a user's name, password, mail directory, and Real Name, do the following:

1.      Choose the Mail icon to display the User Login screen.

2.      Enter Postmaster in the Username field and choose the OK button.    The Mail-Postmaster 
screen appears.

3.      Select the Mailboxes... option from the Services menu to display the Mailboxes dialog box.

Note:    The Mailboxes... option under the Services menu only appears when you are logged in as 
Postmaster.    This is the only dialog box in which you can add and delete users and specify a user's 
mail directory.

4.      Enter the user's name in the User: field and choose the Add... button.    A dialog box with your 
username appears.

5.      Enter the user's password, name in real life, and mail directory and choose the Add button.    
Then, choose the Save button on the Mailboxes dialog box to save changes.

The mail directory identifies where all configuration files and individual mail messages are saved.    You 
should set up a separate mail directory for each user.    For example, the mail directory, c:\mail\steven, in 
the above screen, is set up for only user Steven.

If you are configuring this system to be a mail server, you may define additional users, but be sure to give 
each user a password and a separate mail directory.

To avoid the possibility of an unauthorized use of your mail application, modify the password for the main 
Username - POSTMASTER as well as create your own account and password.



For more information:

Set Password

To receive mail addressed to your user name, you must define your user ID and Password

To define a User name and Password:

Users

You must quit the Mail application, and login with your new defined user ID and password.

If you are configuring this system to be a mail server, you may define additional users in the same 
manner.    Be sure to give each user a password and a separate mail directory.

Once you have added a new user, you can enter a password and a mail directory.    The mail directory 
identifies where all configuration files and individual mail messages are saved.    There should normally be
a separate directory for each user (for example, c:\mail\steven).

Main Window - the Inbox

Once you have logged in as a particular user, the main window for the Mail application appears.    A 
palette of functions is provided as buttons along the top of the window.    Multiple mail messages may be 
selected simultaneously for many functions.    New mail is inserted at the top of the list and appears with 
an asterisk (*) as the first character until it is viewed for the first time.    An audible alert can be used to 
signal new mail as well.

Users each have their own inbox, and these inboxes are saved throughout all invocations of the Mail 
application.    There is no need to explicitly save current inbox contents.    You must use the Delete button 
to remove mail from your inbox.    All deleted messages will be stored in the Trash folder until removed by 
the user.      Individual mail messages may be saved to a specified file in text format.

Note:    An animated icon of a mailbox is used to indicate newly received mail when the Mail application 
(inbox) is minimized.    The mailbox door opens and shows that a mail message has arrived.



User Login

User Login screen is used to open the mail application and register with a specific user name.

To login into Mail as a user, do the following:

1. Choose the Mail icon to display the User Login screen.

2. Enter your previously defined username and password in the Username and Password fields 
and choose the OK button.    The main window (Inbox folder) appears.

A number of functions, some of which allow you to create, forward, reply to, file and print, are provided as 
menus and buttons along the top of the window.

You may save individual messages to specified folders or leave them in the Inbox folder.    To delete a 
message, simply select it then choose the Delete button or Delete key.

When you minimize the Mail application, an animated icon of a mailbox appears.    When new mail 
arrives, the mailbox door opens and displays a message.

Configuration Files

You can save current mail settings to a configuration file (default is MAIL.CFG) which is loaded when you 
start the Mail application.    Other files that are created by Mail are dependent on the name of the current 
user and are kept in the user's mail directory.    For example, if the current user is Steven then mail files 
residing in Steven's mail directory include:

STEVEN.ADB - personal address book
STEVEN.FLD - list of folders
STEVEN.MBO - outbox list of mail
STEVEN.CFG - personal settings
12345678.LTR - individual numbered mail messages



New

Creates a new configuration template.    Your settings for a mail session can be saved to a configuration 
file which will be loaded when the Mail application is started. The default file is MAIL.CFG.

When you choose New, Mail lets you start with a blank configuration template(file).

To select a new file:

1.      Point to the File menu and click the mouse button.

2.        Click the New command.



Open...

Opens an existing configuration file.    Your settings for a mail session can be saved to a configuration file 
which will be loaded when the Mail application is started.    The default file is MAIL.CFG.

When you choose Open, Mail lets you load an existing configuration file.

To Open a configuration file:

1. Point to the File menu and click the mouse button.

2. Click the Open command.

3. Select the Drive and directory by double click the selected item.

4. Enter or double click the filename of the configuration file.

5. Choose OK.



Save

Saves your Mail settings to a configuration file which is automatically loaded each time you start the Mail 
application. The default file is MAIL.CFG.

1.        Point to the File menu and click the mouse button.

2.        Click the Save command.



Save As...

The Save As enables you to select the file name, directory, and drive to be used for saving configuration 
parameters.

To select a new Filename:

1.        Point to the File menu and click the mouse button.

2.        Click the Save As command.

3.        Select the drive and directory by double clicking the selected item.

4.        Enter the file name into the text box.

5.        Choose OK.



Print

Send your message to the printer. Verify (e.g. send a print from Notepad) that your printer is defined by 
Windows and connected before you attempt to print a message.

To print the information to your default printer:

1.        Point to the File menu and click the mouse button.

2.        Click the Print command.



Exit

To exit the Mail program:

1.        Point to the File menu and click the mouse button.

2.        Click the Exit command.

Note: The mail application remembers your window setting (size and position) as you exit (per user). The 
next time you log into Mail, the window will appear in the same place and same size.



Create

To send a new mail message, press Create from the inbox.    This brings up a new window, representing 
the mail to be sent.    The caption for the window uniquely identifies your mail message.    The Edit menu 
provides Undo, Cut, Copy, and Paste functions.    The Date field is automatically set to the current date 
and time.

The From field is automatically set to your local address (user@local) or your server address 
(user@server) if a mail server is defined.    If a mail server is defined, you may select the local address 
form as an alternative; this can be useful if you wish reply mail to return directly to your desktop without 
waiting for mail server retrieval.

The list of recipients for your message is specified using the Names button.    Pressing the Names button 
brings up a dialog box containing your address book entries.    Select or type each entry you wish as a 
recipient and press the To (primary recipient), Cc (carbon copy), or Bcc (blind carbon copy) button.    
Press the OK button to return to the inbox; you can always modify or delete recipients from the inbox.

Type the subject and message text, and press the Send button to transmit it.    The message is 
immediately queued to the outbox for transmission.    The Send button is disabled to indicate that the mail 
has been put into the outbox; any subsequent changes to the mail message causes the Send button to be
reenabled.

The Insert button can be used to insert text files into the message text at the current insertion point.    You 
may also Save or Print this mail message at any point.    Closing the window or pressing the Cancel 
button dismisses the mail message.    

When you create a new message you can select the Feelings    option, that is, Happy, Sad and Wink to 
determine the icon that will appear in your message where you insert it.    ( :-), :-(, and ;-) respectively)



View

Any mail message may be viewed by selecting one or more messages and pressing the View button from
the inbox or outbox.    The view window displays the date, source address, subject, list of recipients, and 
the message text.    None of these fields can be modified, but the Copy item within the Edit menu is 
available.

Functions available from within the view window include Reply, Forward, Save, Print, and Delete.    You 
may also press the Next button to display the next mail message within the view window.    See specific 
help topics for replying and forwarding mail.    Save is used to store the mail message to a specific file, 
while Delete removes it from the inbox or outbox. 

The Edit menu provides the copy function for transferring message text to other applications.    An 
override option to show the mail header is also provided.    The initial setting of Show Header is 
determined from the setting in the Preferences dialog box.



Delete

That will delete a message from your inbox. The deleted message will be stored in the Trash folder until 
you choose to select the Empty Trash command under the Services Menu. While it is still in the Trash 
folder, you can forward the message back to yourself or to others.

You can set the Empty trash on exit under the Preferences... selection under your Setting Menu to 
automatically delete all your mail messages stored in the Trash folder when you exit Mail.



Reply To

To reply to mail received in the inbox, select or view the mail and press the Reply to button with the 
Sender or All selections .    A window identical to the sending mail display appears.    The Date and From 
fields are set as usual.    If All was selected, the list of recipients contains the source address of the 
original message and any carbon copy addresses as well.

Note that in many cases your OWN address will appear as well. If you are not interested in getting a copy 
of the message you are about to send, delete your name from the list or turn off the Send a copy to 
myself option under Preferences in the Setting menu.

The text of the original message is left intact, with a separator indicating where the original message 
begins.    

The original copy may be included or not by setting the Preferences as required. You can also select 
Indented or Bracketed to specify the format of the included message or set it in your Preferences.
 
The text insertion point is placed above this separator so that you can type your reply above the original 
message.    Press the    button when you are ready to send the mail message. Closing the window or 
pressing the Cancel button dismisses the mail message.



Forward

To forward mail received in the inbox, select or view the mail and press the Forward button.    A window 
identical to the sending mail display appears.    The Date field is set as usual and the From field is 
maintained.    The list of recipients is cleared to allow specification of the addresses for forwarding.

The text of the original message is left intact, with a separator indicating where the original message 
begins.    The text insertion point is placed above this separator so that you can type your forward text 
above the original message.    Press the    button when you are ready to send the mail message.    Closing 
the window or pressing the Cancel button dismisses the mail message.



Move to Folder...

To move mail received in the inbox to a folder, select the message and then select the Move to Folder... 
option from the Message Menu.    A dialog box that contains a list of folders appears.

Select the desired folder and choose the OK button.    Your message will be placed in the specified folder.



Copy to File...

To copy mail received in the inbox to a file, select the desired mail message and then select the Copy to 
File ... option from the Message menu.    A dialog box appears.

In the File Name box, type the name of the file and the desired format to which you want to copy the 
message.    Or, select the drive and directory and then the name of the existing file to which you want to 
copy the message and choose the OK button.



Retrieve Mail

Select Retrieve Mail under the Message menu if you have received some mail on another server and your
messages have not yet been retrieved.

Mail will be retrieved periodically by the Timers settings under the Settings Menu. 



Send

Send is used to send the message to the destination address.    After you complete the preparing the 
letter/message, simply point and click the Send button.



Insert

Insert is used for inclusion of files into messages.

To Insert a file:

1.      Position the insertion point in the appropriate position in the message.

2.      Point to the Insert button and click the mouse button.

3.      Select the file to insert, and click the O.K. button.



Save

Saves messages for future reference.    To save a message, point to the save button, provide the 
appropriate name, and choose the OK.button.



Print

Sends your message to the printer.    Point to the File menu and click the mouse button. Click the Print 
command.



Cancel

Cancels a message that was prepared and will not send it through.



Create...

Creates a new folder.

To create a new folder:

1.        Point to the Folder menu and click the mouse button.

2.        Click the Create...    command.

3.        Type in the Folder name in the    Folder name dialog box and click the OK button.

The new folder will be added to the list of available folders.



Rename...

Renames an existing folder.

To rename a folder:

1.        Point to the Folder menu and click the mouse button.

2.        Click the Rename... command.

3.        Select the Folder name you wish to rename from the Rename Folder dialog box.

4.      Type the new folder name in the To: dialog box and click the OK button.

The new folder name will appear on to the list of available folders.



Open...

Opens an existing folder.

To open an folder:

1.      Point to the Folder menu and click the mouse button.

2.      Click the Open... command.

3.        Select the Folder name you wish to open from the list of existing folders and click the OK 
button.

The specified folder will open and its contents will be displayed.



Delete...

Deletes an existing folder.

Note: The Inbox and Trash folders can not be deleted.    The Trash folder will disappear if all messages 
inside Trash were deleted.

To delete a folder:

1.        Point to the Folder menu and click the mouse button.

2.        Click the Delete... command.

3.        Select the Folder name you wish to delete from the list of existing folders and click the OK 
button.

The specified folder with all of its included messages will be deleted.



Folder List...

Folder List... allows you to view a list of all existing mail folders.    To view all folders, do the following:

1.      Select Folder List... from the Folders menu to display the Folder List dialog box.

This dialog box lists all folders including the total number of all messages and the number of 
unread messages.

2.      If desired, open or delete existing folders or create new folders.



Address Book...

The address book can be used to simplify the selection of recipients of mail.    Normally, you must type the
full specification of a destination address (for example, support@netmanage.com), but the address book 
uses a simple point-and-click interface.    Individual addresses and group addresses may be specified with
groups displayed within brackets (for example, [sales]).

To add a new user or group, type the name and select the address type (individual or group), and then 
press the Add button.    You may rename entries by selecting them and pressing the Rename button.    
Select one or more entries and press the Delete button to remove them from the address book.    Press 
the Save button at any time to update the address book.

Select an entry and press the Modify button to display either the groups to which an individual belongs, or
the members of a group entry.    You may delete multiple members from one group, or delete an individual
member from one or more groups, using the Delete button.    When modifying a group, select one or more
individual names and press the Add button to add them to the group.    Press the OK button when all 
modifications have been completed.



Outbox...

All outgoing mail is first queued in the outbox for subsequent delivery to the mail gateway, if defined, or to 
the final destination, as specified in each of the recipient addresses.    The outbox attempts to deliver mail 
when mail is first queued, when the application has just been started, and when the send timer has 
expired.    Mail that has remained in the outbox beyond a specified amount of time is expired and returned
as undeliverable.    These time values can be changed by selecting Timers from the Settings menu.

Mail that is queued in the outbox may be viewed in the same way that new mail is viewed.    You may 
delete one or more messages from the outbox by using the Delete button.    The Send button is used to 
force delivery of one or more mail messages immediately; this can be useful if you know that the remote 
system is running after a previous failure to deliver.

Note:    An animated icon of a mail truck is used to indicate queued mail awaiting delivery when the 
outbox is minimized.    The door of the mail truck opens when one or more mail messages are queued for 
delivery and closes when empty.



Rules...

You can associate attributes to your incoming messages by selecting the Rules... option from the 
Services menu.    For example, you can create a rule so that all messages addressed to you are 
automatically moved to a specific folder. Or, create a rule so that all messages you receive from a 
particular person are automatically moved to a previously defined mail group.

To create a rule where all messages whose subject field contains a specific name to be automatically 
moved to specific folder, do the following:

1.      Enter the name of the rule in the Rule name: field.    For example,suppose test1 is the name of 
the rule.

2.      Enter the string (single word or several words) you want the system to search for in the String 
to match: field.    In this example, the name Natan is the string.

3.      Select the field (From, To or Subject) where the string is located. In this example, the name 
Natan would have to appear somewhere in the subject field of an incoming message.

4.      Select the action (Move to Folder, Forward, Delete) you want executed when the matched 
string is found.    In this example, any message whose Subject field contains the name Natan 
will be automatically moved to a folder named Development.

If you want to select a folder to which incoming messages are automatically sent, the folder 
does not have to previously exist.    You can define the folder at the time you select that action.

Note:  If you have more than one rule that contains the identical string to match, then the system will 
apply the first rule that is listed in the Rules: field.



Empty Trash...

Empties your trash folder that stores all deleted messages.

To empty your trash folder, point to the Services Menu and click on the Empty Trash... command.

Note: You can also set under the Preferences Menu the Empty trash on exit. If you set this option on, 
upon exiting mail your Trash folder will automatically be deleted.



Mail Boxes (Postmaster Only)...

1.      Select Mailboxes... from the menu. A dialog box is displayed for entering additional users to 
the system. 

2.      Type in the user name you want to add and click Add...

3.      A second dialog box is displayed. Enter the user's name in real life and the password (optional)
and select the directory where his/her mail is to be stored.

Note: it is advised to assign each user a unique directory for the mail.

4.      When done click OK.

5.      Click Save if you are pleased with the change, or click Cancel to ignore the addition.

6.      A Delete button is provided to take currently defined users off the system.



Preferences...

Select the Preferences... option from the Settings menu and select each preference you want to activate.

There are several options under each of the following settings:    incoming, viewing, and outgoing mail, 
start-up and exit.

You can also choose the Advanced button if you want to set the From field in a message to something 
other than the default.

Incoming Mail:

o Audible notification for newly arrived mail
o Confirmation on deleting a letter from the inbox
o Placing a new message on top

View Mail:

o Show/ Don't show SMTP headers in mail views
o Show automatically the next message in the inbox after deleting the current one.

Outgoing Mail:

o After sending a mail message, close the window. If not checked, the "Send" button will go gray and 
stay until you modify the text or mailing list. This allows you to easily re-send messages with slight 
modifications.

o Confirm on exit without send. This protects you from accidently exiting a message you are currently 
writing and about to send.                    

o Reply only to sender.
o Include original message in reply.
o Indent included message.

o Use NRC conversion.    The NRC has 12 languages support including USASCII. NRC is a 
method that partially solves multinational character problem in 7 bit mode.    It replaces some of the 
ASCII characters to the specified language's characters.    Therefore, in this mode, characters such as
#,@,[,\,]..can not be used. 

o Send copy to myself.    This allows you to automatically receive a copy of every message you send.

Start-up:

o Load the address book automatically when starting Mail.
o Load the outbox window automatically when starting Mail.

On Exit:

o Empty trash when exiting Mail.



Advanced Preferences...

Choose the Advanced button if you want to set the From field in a message to something other than the 
default.

Make sure that the mail address you type in the From field is a valid one.



Fonts...

Set font type style ( including bold and italic ), size and width for the message body.

To select a font:

1.      From the menu item Settings, select Fonts...

2.      Select the font, font type and font size you want to use.

3.      Select OK.



Colors...

Use the Colors... option to set colors for your mail folders and individual messages. You can set both 
foreground and background colors for the Inbox and Trash folders, message body and list of message 
headers.    Colors can be selected from a palette of 16 colors. An area that shows the resulting 
combination is also displayed.

Each of the above fields has also a built-in default. To set the default colors color for a particular folder, 
select it from the "items" list. and click "Default". Clicking the "All Defaults" sets all fields to the factory-set 
default colors.

To select color for a folder:

1.      From the menu item Settings, select Colors...

2.      Select the folder you want to change from the "items" list.

3.      Select the desired background and foreground colors and click on the OK button.

To select color for a particular message when it is open on your screen:

1.      From the menu item Settings, select Color...

2.      Select the folder you want to change from the "items" list.

3.      Select the desired background and foreground colors and click on the OK button.



Log...

Select the Log... option from the Settings menu to help diagnose client transmission and mail server 
retrieval problems.    Check replies for connection errors or destination address errors.



Signature...

To design a signature template that is automatically attached to the end of each mail message you send 
out.    To create a mail signature, do the following:

From within Mail, select the Signature... option from the Settings menu.    The Signature... dialog box 
appears.

1.    Type in your own personal signature that you want to attach to outgoing mail.    

2.      If desired, select the Attach to outgoing mail box if you want it automatically attached to every 
outgoing message.    



Password...

The password for the current user can be changed at any time by selecting Password from the Settings 
menu.    Type the original password and the new password twice for confirmation and press the OK 
button.    Passwords for all users can be changed by the Postmaster user from the Mailboxes dialog box.



Timers...

Various timing parameters can be specified by selecting Timers... from the Settings menu.    Send time 
values are used to specify mail delivery times for the outbox.    The outbox retransmits all pending mail 
every retry time, and returns mail to the original user after the timeout period.    Retrieve time values are 
used in conjunction with a Mail Server definition.    The inbox queries the server periodically, as specified 
by this time value.    The Mail Server dialog box can also be used to manually retrieve server mail, if 
periodic retrieval is not enabled.



Network...

A mail gateway can be defined to route all mail messages that are transmitted. Select Mail Gateway... 
from the Settings menu and type or select the mail gateway system if required. 

If you are using a mail server, you must define it for each of the mail clients. Select Mail Server... from the 
Settings menu.    Type or select the server system name and the user name and password for your 
current login as well as your mail directory.



Mail Gateway...

A mail gateway routes all mail messages that are transmitted.    Normally, the Mail application attempts to 
connect to the domain portion of a mail address and transmit the mail to the specified user.

To define a mail gateway, do the following:

1.      Select Network and then the Mail Gateway... option from the Setting menu.

2.      Type or select the name of the mail gateway in the Host: field and choose the OK button.

Note that a mail gateway is often used for access to the Internet.    Be sure to specify a mail gateway that 
is configured to perform as an SMTP relay, because the Mail application does not support SMTP relay 
functions.



Mail Server...

If you are using a mail server, you must define it for each of the mail clients.    A mail server is the host 
machine from where you retrieve your mail using the POP protocol.    

To define a mail server, do the following:

1.      Select Network and then the Mail Server... option from the Settings menu.

2.      Enter the name of the host (the machine acting as the mail server), user, and user's password 
on the host machine, and if required, the directory on the host in the corresponding fields.

3.      If desired, select the Delete retrieved mail from server option if you want your mail 
automatically deleted from the server after you have retrieved it.    Otherwise, every time you 
retrieve your mail you will receive duplicate copies of your messages.

4.      Choose the OK button.



Help

Using Help

To choose a Help topic:

Mouse Point to the underlined topic you want to view and click the mouse button.

When the pointer is over an item you can choose, the pointer changes to a hand 
icon.

Keyboard Press Tab to move the highlight to the underlined topic you want to view, and 
then press Enter.

To exit Help:

Mouse                        1      Point to the File menu and click the mouse button.

2      Click the Exit command.

Keyboard                    1      Press Alt.
2      Type the letter F.
3      Type the letter X.



About
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Network Information Center, SRI International, Menlo Park, Calif., August 1982.

Postel, Jon, Simple Mail Transfer Protocol, RFC 821, Network Information Center, SRI International, 
Menlo Park, Calif., August 1982.

Crocker, Dave, Standard for the Format of ARPA-Internet Text Messages,    RFC 822, Network 
Information Center, SRI International, Menlo Park, Calif., August 1982.

Choose the OK button to continue.



Troubleshooting

If you experience difficulties using the Mail application, refer to the following items:

o Verify that the installation and setup verification steps have been successfully completed.

o If you cannot open your mailbox because you forgot your password, then edit the MAIL.CFG file and 
remove the encrypted password next to your name.    For example, if John=fg78%$, then fg78%$ is the 
encrypted password.

o If you are having trouble retrieving mail, make sure that the remote system supports the SMTP protocol.
Verify that the POP2 or POP3 daemons are running on the mail server system. The POP2 known port is 
109 and the POP3 port is 110.    To verify if the daemons are running, use the Telnet application to 
connect to ports 109 or 110.    The system replies with a message indicating if the correct daemons are 
running on ports 109 or 110.

o If you have trouble sending mail verify that SMTP is available on the remote host, and you have 
specified the correct mail gateway address under Network settings.    Also verify that the To: field 
(destination address) is complete.    For example, steven@netmanage.com.

o You also need to verify that the network server settings are correct.    Make sure that your password and
mail path (/user/spool/mail/username) are correct.

o Use the Ping application to verify connectivity to the domain portion of any destination address if Mail 
reports a failure to deliver.    Verify connectivity to your mail server is defined.

o Use the logging feature to help diagnose client transmission and mail server retrieval problems.    Check
replies for connection errors or destination address errors.

o Make sure the user name portion of the destination address is defined at the destination.    The 
Postmaster may define new users by using the Mailboxes item under the Services menu.


