
FTP Index

The Index contains a list of all Help topics available for FTP.    You can use the scroll bar to see the entries
that are not currently visible in the Help window.

For information on how to use Help, press F1 or choose Using Help from the Help menu.
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Overview

FTP is the user interface to the ARPANET standard File Transfer Protocol (FTP).    FTP transfers files to 
and from a remote network site.

FTP employs the NetManage FTP.DLL which is using NEWT-Enhanced Windows TCP/IP stack.    FTP is 
implemented both as a client and server.    The number of clients that can be served concurrently by the 
FTP server is limited only by the system's resources (memory etc.).    Only one user can use the FTP at 
any given time.

The client host with which FTP is to communicate, as well as all configuration information may be saved 
into a default configuration file FTP.CFG.    If a default configuration file (FTP.CFG) exist it will be loaded at
start up.

You can also invoke the FTP application using the following command line:

win ftp [<host>] [option]

where host is the name of the system you are logging into, and option is -f<config> for use configuration 
file.

Notes on operation: 

1. When a file transfer, initiated by the client, is in progress, a progress bar is displayed, graphically 
showing the progress of the transfer.

2 While in progress, most command buttons are disabled (grayed). You can still perform informative
operations, such as viewing directory and file info, and checking help.

3. For your convenience, to accommodate large remote file names, the window can be stretched (to
the right) causing the display boxes to stretch as well.

4. While file transfer is in progress, you can minimize the FTP window as to not occupy space on 
your screen's "desk space". An animated icon is provided to signal that data transfer is in 
progress: black "packets" move on the "network" part of the icon at a rate corresponding to the 
transfer rate. When the transfer is completed, the "network" is cleared back to yellow.



New

New creates a new configuration template.

When you choose New, FTP lets you start with a blank configuration template (file).

To select a new file:

1. Point to the File menu and click the mouse button.

2. Click the New command.



Open...

Open an existing configuration file.

When you choose Open, FTP lets you load an existing configuration file.

To Open a new configuration file:

1. Point to the File menu and click the mouse button.

2. Click the Open command.

3. Select the Drive and directory by double click the selected item.

4. Enter or double click the filename into the text box.

4. Choose OK.



Save

To save configuration parameter changes, to the default or the currently selected configuration file:

1. Point to the File menu and click the mouse button.

2. Click the Save command.



Save As...

The Save As enables you to select the file name, directory, and drive to be used for saving configuration 
parameters.

To select a new Filename:

1. Point to the File menu and click the mouse button.

2. Click the Save As command.

3. Select the Drive and directory by double click the selected item.

4. Enter the filename into the text box.

5. Choose OK.



Exit

To exit the FTP program:

1. Point to the File menu and click the mouse button.

2. Click the Exit command.

Note:    When you exit the application, your current window size, window position, and local directory are 
automatically saved. Next time you start FTP, these settings will be used.



Connect

The client host with which FTP is to communicate may be specified, along with the user name, 
password [optional] type of System ( such as UNIX, VMS, Windows ) and a Description [optional].

The System information is needed for parsing the file list into directories and files as the file and directory 
representation differs for different Operating Systems.    FTP will adopt its operation to the specified OS. If 
you are not sure about the remote system, select auto. The software will attempt to match it for you. 

After the appropriate information was supplied in the text boxes, and the OK. button was clicked, FTP will 
attempt to establish a connection to an FTP server on that host.

Upon establishing a connection, the current working directory on the remote machine is placed in the 
remote section of the screen.

Note: In case your remote server has a special file format that has no match in the Chameleon built-in 
parsing types, use "other". When connected click on the button "Info" pointing to the remote side--the 
remote file system directory, in its native form, will be displayed.

To Connect to a host:

1. Point to the Connect menu and click the mouse button.

To set a host:    Enter the host name, or the IP address into the Host text box    (or click the down 
arrow and select from the pull-down list. This list is the list you entered using "Host Table..." under
"services" menu in "Custom")

To set the user name:    Enter the user's name into the User text box.

To set the Password:    Enter the password into the Password text box.

To set the Description    Enter the Description into the text box in the Connection Profile Menu 
under Setting.

To set the System type.    Select a system from the list of supported systems (or "Other" if no 
match.)

Double clicking on the description also performs a connect operation based on the information 
supplied in the connection profile.



Disconnect

Disconnect - Terminate the FTP session with the remote server.

Exit - Terminate the FTP session with the remote server, and exit FTP.

To close the current connection:

1. Point to the Disconnect menu and click the mouse button

2. Point to Disconnect or Exit and click the mouse button.

3. To return to the active FTP connection, point to the Cancel button and click the mouse button.



ASCII Mode

ASCII - Network ASCII type for transferring text files.

To select ASCII mode:

1. Point to the ASCII radio button and click the mouse button.



Binary Mode

Binary - Network Binary type for transferring image files (Default.)

To select BINARY mode:

1. Point to the Binary radio button and click the mouse button.



Change Command

Change will change the working directory on the local or remote machine to the designated directory.

Note: Selecting "change" without a selected directory performs a "refresh" operation. Select it if 
you know that some file operations have been made on the remote directory (other than directly via the 
FTP).

To change directory:

1. Point to the directory text box, click the mouse button.    Type the name of the directory.

2. Or, point to the selected directory in the directory list box, and click the mouse button.

3. Point to the arrow pointing to the local or remote Change command and click the mouse button.

Note: Using the windows double click convention will be interpreted as a change command.



Create Command

Create will create a new directory on the Local or remote machine.

To Create a new directory:

1. Point to the directory text box, click the mouse button.    Type the name of the directory.

2. Or, point to the selected directory in the directory list box, and click the mouse button.

3. Point to the arrow pointing to the local or remote Create command and click the mouse button.



Dir Info Command

Dir Info will display a dialog box containing information on the selected directory(s) on the Local or remote
machine. The information presented is the full details on the directories info as would be presented locally
by the native system (for the local side it is equivalent to performing a windows "dir" command. For the 
remote machine it performs the equivalent to this function as appropriate for that machine (e.g., "ls -lg" in 
Unix)

To view the directory information:

1. Point to the selected directory in the directory list box, click the mouse button.

2. Point to the the local or remote Dir Info command and click the mouse button.



Remove Command

Remove will delete the selected directory on the Local or remote machine.

To Remove a directory:

1. Point to the selected directory in the directory list box, click the mouse button.

2. Point to the arrow pointing to the local or remote Remove command and click the mouse button.



Append Command

Append will append a local file to a file on    the    remote machine, or a remote file to a file on the local 
machine.

File transfer uses the current settings for "transfer mode".

To Append a file:

1. Point to the selected files in the file list box (both Local and Remote), click the mouse button.

2. Point to the arrow pointing to the local or remote Append command and click the mouse button.



Copy Command

Copy file(s) will transfer a remote/local file and store it on the local/remote machine.    If the destinations 
file name is not specified, it is given the same name it has on the original machine.

File transfer uses the current settings for "transfer mode".

To Copy a file:

1. Point to the selected file(s) in the file list box (Local, Remote or both), click the mouse button.

2. Point to the arrow pointing to the local or remote Copy command and click the mouse button.

Note: Multiple files can be selected by pointing and dragging the mouse.



Info Command

The Info command displays a dialog box with detailed information on the files selected (as would appear 
on the native system). One dialog box is created for local files info, and a separate one for the remote 
files info. The title of the window tells you which is which.

To receive information on files (local or remote)

1. Point to the selected file in the file list box (Local, Remote or both), click the mouse button.

2. Point to the arrow pointing to the local or remote Info command and click the mouse button.

Note: Multiple files can be selected by pointing and dragging the mouse.



Delete Command

Delete a file will remove the file from local or remote machine.

To Delete a file:

1. Point to the selected files in the file list box (Local or Remote), click the mouse button.

2. Point to the arrow pointing to the local or remote Delete command and click the mouse button.

Note: Multiple files can be selected by pointing and dragging the mouse.



Rename Command

Rename a file on the local/remote from current name to the new specified name.

To Rename a file:

1. Point to the file list box (Local or Remote), click the mouse button to select a file.

2. Point to the arrow pointing to the local or remote Rename command and click the mouse button.

3. Enter the new name in the text box.

4. Point to the Rename and click the mouse button.



Server Settings

A Server can be turned on or off by toggling the check box state.    FTP server is using the well known port
21.    The server supports multiple concurrent transfers (limited by the memory in your machine).    The 
server can be set with a directory within which the clients can manipulate (send and/or receive) files.

To change the server settings:

1. Point to the Server menu and click the mouse button.

2. Click the Settings command.

To set the Server On(Server Mode is Off):

1. Point to the selected server directory.

2. Click the mouse button.

3. Point to Server check box(X in the box = server on)..

4. Click the mouse button.

To set the Server Off (Server Mode is On):

1. Point to the Server check box.

2. Click the mouse button.

3. Choose OK.



Server Users

Multiple users can use this machines FTP server.    Users can be added to the list with the appropriate 
password.

To add users to the authorized list:

1. Point to the Server menu and click the mouse button.

2. Click the Users command.

To add a user:

1. Point to the User Name text box, and click the mouse button.

2. Type the User Name.

3. Point to the Password text box, and click the mouse button.

4. Type the password.

5. Point to the ADD command button, and click the mouse button.

To Modify or Delete a user:

1. Point to the user list box, and click the mouse button to select a user.

2. Point to the Modify/Delete command button, and click the mouse button.

3. Choose OK.



Server Connections...

The connections dialog box shows the list of clients currently connected to the FTP server on your 
machine. The list shows the IP address of the clients connected, and the User Name and Password they 
have logged with.

To disconnect a client from the server while connected:

1. Point to the selected client in the list box and click the mouse button.

2. Click the Disconnect button.



Preferences...

The Preferences... command lets you select or de-select the following preferences:

Confirm on directory remove
Confirm on file append
Confirm on file delete
Confirm on file replace
Automatic rename on file copy

1. Point to the Preferences... menu and click the mouse button.

2. Point to the appropriate check boxes, and check the preferences of your choice.

3. Click the OK button.



Colors...

Use Color to select both the foreground and the background colors for your FTP display. A palette of 16 
colors is available. An area that shows the resulted combination is also displayed. To set the colors back 
to the default, click on Default. Clicking the All Defaults sets all fields to the factory-set default colors.

To select color:

1. From the menu item Settings, select Color...

2. Select background and foreground colors.

3. Select OK.



Log Option

Log allows you to record the File Transfer Protocol messages exchanged between the client and the 
server. Log collection can be started and stopped, saved to a file, printed and deleted.
The log file is very useful for debug, tracing interoperability issues, and alike. It is not intended as a tool 
for the desk user, but rather, it is intended to be used by a networking professional.



Connection Profile...

The Connection Profile box allows you to set and store a list of frequent destinations.    You can define a 
host, user, password, account, local directory, and type of system for each destination.

To set up your Connection Profile

1. Select Connection Profile from the Settings menu.

2. Enter the information as desired.

3. Click on Add to save your selections.



Quote...

The Quote... option allows you to send FTP commands. To send FTP commands, do the following:

1.      Select the Quote... option from the Settings    menu.

2.      Enter the desired FTP command in the Quote field and choose the Send button.    Choose the 
Log... option from the Settings menu to view the selection results.

To save an entry, choose the Add the button.    To delete an existing entry, choose the Delete button.

Note:    Enter Help in the Quote field to display a list of all available FTP commands.



Troubleshooting

If you experience difficulties using the FTP application, refer to the following items:

o Verify that the installation and setup verification steps have been successfully completed.

o Make sure the remote system provides an FTP server and that the server is running.    Note that some 
operating systems do not supply TCP/IP services with the standard package (for example, VMS).    Note 
also that the Chameleon FTP server must be explicitly turned on and the application must be running.

o Use the Ping application to verify connectivity to any remote system to which you want access if the 
FTP application reports a failure to connect.

o Verify that the user name and password were entered correctly if the FTP application reports a failure to 
login.

o Verify that the system type was specified correctly.    The Auto choice attempts to make a smart 
determination of the system type, if you are unsure.    If it can not determine the system type, no files or 
directories appear in the listboxes; you must then use the Info buttons to see the listings and type when 
performing actions such as copy.

o Make sure that the transfer type /binary) is chosen correctly.    Transferring a binary file when the 
transfer type specifies ASCII, may cause a failure.

o Make sure you have permission for specific operations (for example, write access to a directory).    The 
FTP log can be used to help diagnose access failures.



Help

Using Help

To choose a Help topic:

Mouse Point to the underlined topic you want to view and click the mouse button.

When the pointer is over an item you can choose, the pointer changes to a hand 
icon.

Keyboard Press Tab to move the highlight to the underlined topic you want to view, and 
then press Enter.

To exit Help:

Mouse                        1      Point to the File menu and click the mouse button.

2      Click the Exit command.

Keyboard                    1      Press Alt.
2      Type the letter F.
3      Type the letter X.



About

For more information about the program choose the OK button to continue.




