
    Help File Contents
    Quick Start Guide 

A quick introduction, to get you started and whet your appetite.

    Welcome to HotCargo Express 
A short introduction, to get an overview and general understanding.

    How To... 
A cookbook, for those who like step-by-step instructions.

    Reference Information 
A reference, for those who have specific questions and those who like detail.    
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     Quick Start Guide

HotCargo Express  turbo-charges your Web browser. You use Express to get your favorite
Web pages and put them on your local computer, and then you use your favorite browser to 
read them    same browser, same pages, but no waiting.
Express has its own window, which appears whenever you start Windows.    There is also an 
Express toolbar that attaches to your browser, to make Express commands easily accessible.
Check the How To Section for information on how to use the browser toolbar.
Here is a quick introduction to using Express.    If you have a printer, you might want to print 
this page using the Print Topic command on the File menu.    You can also get back to this 
page later with the Quick Start item on the Help menu.

Getting Pages: Ask Express to go to the Web and get the pages in a package

1) Go to the Express window. Select a folder and open it by single-clicking on it. Inside, 
choose a package by single-clicking on its name.

2) In the toolbar at the top of the Express window, click on . Express will start bringing 
Web pages onto your computer.    

3) The package name will get slanty while Express is getting pages and go back to normal 
when it is done.    The package name will turn blue, to show you that there is something
new.

4) Double-click on the name of the package in the Express window.    Express will load the 
first page of the package into your browser and you can browse away to your heart's 
content.

Scheduling a Package: Ask Express to go get a package regularly

1) Go to the Express window and choose a package by single-clicking on its name.

2) In the toolbar at the top of the Express window, click on .    Express will mark the 
package with an alarm clock ( 

 ) to show that the package schedule is turned on.
3) Express will go get the package whenever the schedule says.    (Weekly makes sense for 

some packages, daily or even hourly for others.)
4) To turn the schedule off, click :    Express will remove the alarm clock    and not schedule

more retrievals.

Published Packages:    Add new packages from our collection of published packages

1) Go to the Express window. If the DocuMagix folder is closed, open it by single-clicking 
on it.

2) Double-click on Sites to Download Using HotCargo Express to load our Web page of 
published packages into your browser.    

3) Browse through our list of packages on the Web page, pick one that interests you, and 

click on the  button next to it. 



4) Express will add a new package to your Express window, with an alarm clock to show 
that the package is scheduled, using the schedule set up by the package author.

5) Select the package in your Express window and click  to start retrieving the package 
immediately (or wait until the next scheduled retrieval).

Create Your Own Package:    Make packages for your own favorite Web pages

1) Suppose you are browsing the Web, find an interesting page, and want to make a 
package for it.

2) In the Express toolbar, click on . Express will create a new package and open the 
package Properties sheet.

3) In the package Properties, check the URL, which Express will set up with the page 
currently loaded in your browser.    You can change it, if you like.

4) Click the OK button, which will close the Properties sheet and add the new package to 
your Express window.

5) In the Express toolbar, click  to start retrieving the package.

Password-Protected Pages: Using sites that require passwords

1) Select a package that includes a web site that requires a password.    Click on  to start 
getting the pages in the package.

2) The package icon will remain  to show that there was a problem trying to retrieve the 
package.    This error is because the the web site requires you to log on.    

3) Double-click on the package to load it into your browser.    If you are a subscriber, enter 
your name and password for the site into the prompt in your browser.

4) Go back to Express, select the package again, and click  to restart the retrieval. If you 
are a subscriber, and have entered your name and password, the retrieval will succeed:   
Express has a key ring      for remembering names and passwords, so that Express can 
access password-protected sites when you are not around.

What Next: What to do next

When you are ready to learn more about HotCargo Express, go back to the Help Menu, bring 
up Topics and browse around to learn about what else Express can do for you.
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    How To...
A cookbook introduction to the things people most often want to do with HotCargo Express.

How to....
Make a New Package 
Set Up a Retrieval Schedule 
Find Error and Status Messages 
Tailor Custom Packages 
Read Pages that Require Passwords 
Use Predefined Packages 
Use the Browser Toolbar 
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    How To ... Make a New Package
Suppose you are browsing the Web, find an interesting page, and want to create a new 
package for it. (A package is just a group of Web pages linked from particular Web page.    
Packages are a convenient way to get a group of pages together:    if you are interested in 
one Web page, you are typically also interested in the pages linked from it.)
Here is how to set up a package based on any Web page you choose:
1) Using your Web browser, browse to some Web page that you find interesting and would 

like to use as the beginning of a package.
2) Click , either in the HotCargo Express toolbar or the browser toolbar.    Express will open

the package Properties sheet.
3) Express will set up the URL for the new package with the URL of the page that is 

currently displayed in your browser. (You can type in anything you like here, but Express 
sets it up initially as a convenience.)

4) Click the OK button, which will close the Properties sheet and add the new package to 
your Express window, using the standard package properties that Express sets up for all 
newly-created packages.

5) Select the package and click  to start retrieving the package.

 Copyright © 1996, DocuMagix, Inc. All Rights Reserved.

HotCargo Express Website Customer Service 



 How To ... Set Up a Retrieval Schedule
If you want HotCargo Express to retrieve the pages in a package regularly, you can set that 
package up with a retrieval schedule telling Express when and how often to get the pages in 
that package.    Here is how to set up a retrieval schedule:
1) Select the package in your Express window, right-click, and choose Properties to bring 

up the package Properties sheet.
2) On the Basic package properties sheet, turn on the scheduling checkbox, like this:

3) Choose a frequency for the retrieval, such as Weekly.    You can choose the details from 
the menus that Express supplies or you can customize to anything you like by typing into
the fields.

4) If you choose Every, you can specify any interval you like    you can use minutes, hours, 
seconds, days, or even weeks as your interval.    Again, you can type any value you like 
into the fields. For example:

5) Finally, look at this property, which appears at the bottom of the Basic tab:

This means that the starting time for the retrieval will not be exactly at the specified 
starting time    instead it has some slop to vary the starting time. So if you set your 
starting time to be 3 AM, and the delay is an hour, then the retrieval will start at some 
random time between 3 AM and 4 AM. This is a very important way to prevent servers 
from having too many connections at exactly the same time, but can be surprising if you 
think the retrieval will start at exactly 3 AM.    If the exact time is important to you, you 
can set this property to 0 hours, or to some small number of seconds.
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    How To... Find Error and Status Messages
When HotCargo Express encounters an error trying to retrieve a Web page, it marks the 
package name with  as well as marking each page that had an error with 

.    Here is what to do when you see 
 on a package name:

1) In Express, use the View -> Next Error command to find the page with the error. 
(Sometimes the page with errors is the starting page for the package; more often it is a 
page inside the package.)

2) When you have found the right page, select it with your mouse, right-click, and roll to 
Status.

3) The error or status message is listed at the top of the page. (If you are not sure what the 
error message means, check the section on Page Status Messages.)
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    How To ... Tailor Custom Packages
The standard package properties are a good starting point for a new package, but you will 
often want to refine them somewhat for your own favorite packages. Here are some hints on
how to make those refinements:
1) Set up a package with the standard package properties and retrieve it. 
2) Bring up the Package Status Sheet (using the View -> Status menu command) and 

check the size.    There is no right size for a package, but you might want to try to keep 
them under, say, 5000 Kbytes (5 MB).    

3) If you find the size is too big, try reducing the depth or adding some Filters. Some 
common ways to filter are by removing particular extensions, say like this:

or by including or excluding only particular directories, say like this:

For detailed examples and suggestions on setting up package filters, see the instructions
for package authors, on our Website at:

http://www.documagix.com/products/hotcargo_express/packages/docs/
examples.html

4) To try out your new package, to see if it has the pages you want, take your browser off 
line (with the View -> Browser Offline command) and try to browse around in the 
package using your browser.    If you find pages that are not in Express, consider 
increasing the depth of the package.
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    How To ... Read Pages that Use Passwords
Some Web pages, typically sites with frequent news updates, ask you to register as a user to
be able to access the pages on the site. Registering means that you have a user name and 
password for that site.    (Sometimes it means that you pay a fee; sometimes not.)
HotCargo Express can remember any passwords and user names that you use to view 
password-protected pages, by storing them on a key ring. Once you have your user name 
and password for a particular site in the Express key ring, Express will remember them and 
use them to access the site when you are not around.
Here is how to add a password-protected page or area to the Express key ring:
1) While Express is running, make sure your browser is online (using the View -> Browser 

Online command), and visit the protected page or area in your browser.
2) Type in your name and password when your browser prompts you to do so.
3) Go back to Express, use the File -> Key Ring command in Express to bring up the Key 

Ring sheet.    Check to make sure that the new entry appears in the key ring.
4) If your new entry does not appear, then use the Add Entry Command on the key ring to 

add the new site yourself. (Some sites are set up to expect particular browsers, and do 
not allow Express to grab your password information.) 

5) Try to retrieve the site again. If Express is still unable to access the site, and the entry in 
the key ring looks okay, select the package in Express, bring up the properties, and turn 
on the option on the Logon Properties sheet.
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    How To ... Use Predefined Packages
Whenever you see this image on a Web page:

It means there is an HotCargo Express package available, ready for you to add to your 
Express window in a single click.
Package links can appear on any Web page, on any site. To get you started, we have 
collected a large number on our Website. Here is how to try them out:
· Go to your Express window. If the DocuMagix folder is closed, open it by single-clicking 

on it.
· Double-click on Sites to Download Using HotCargo Express, which will load our Web 

page of published packages into your browser.    
· Browse through the Web page, pick a package that interests you, and click on the 

Express-It button next to the package.    Express will add the new package to your 
Express window, using the package properties set up by the author of the package script.

· Click on the  to get Express to retrieve it immediately (or wait until the next scheduled 
retrieval).

· Keep the package for the Sites to Download Using HotCargo Express in your 
Express window and wait for it to turn blue    then check to see what new sites we have 
added.
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    How To ... Use the Browser Toolbar
HotCargo Express has a toolbar that attaches to your browser, to make it easy to do basic 
Express commands without opening the Express window. The toolbar is visible when you 
first start Express, though you can turn it on and off using the View -> Browser Toolbar 
menu command.    (The toolbar is not available on Windows NT 3.51.)
The toolbar looks something like this:

The command buttons are the same as those in the Express window: New Package, Next 
Unread Page, Start Retrieval, Stop Retrieval, Browser Online, and a Help button. 
The scrolling menu lists the packages you have in your Express window:    when you select a 
package from the scrolling list, Express will load the starting page of that package into your 
browser, and also use that package as the target for other toolbar commands, like Start and 
Stop retrieval.
The Express logo is a shortcut to the Express window:    click on the logo to bring up the 
Express window.    When your browser is getting pages from Express    when Express is 
working for you    the logo will turn neon green, like this:
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    Welcome to HotCargo Express
A short narrative introduction, for those who want an overview of how the program works. About 15 minutes of 
reading.

About HotCargo Express 
HotCargo Express Packages 
The Outline View: HotCargo Express Icons 
Reading Pages 
Starting a Retrieval 
What's Changed? 
Scheduling Regular Retrievals 
Package Links 
Making Your Own Packages 
Stopping a Retrieval 
That's It!  

 
 Copyright © 1996, DocuMagix, Inc. All Rights Reserved.

HotCargo Express Website Customer Service 



    About HotCargo Express
DocuMagix HotCargo Express will make your Web browsing faster, easier, more reliable, and 
more fun:    

Faster, because Express gets Web pages for you and puts them on your own 
computer.    Then you can read them when you like, using your favorite Web browser: 
the same pages, the same browser    but no wait.
Easier, because Express will let you know when pages change and have the new 
versions waiting for you.
More reliable, because Express will make sure Web pages are there when you want 
them.
More fun, because you can browse off line. Store the pages on your laptop and take 
them anywhere you take your laptop.

Express builds a small Web on your own computer, one that is always available, has your 
own favorite pages, and does not take forever to browse.    
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    HotCargo Express Packages
A HotCargo Express package is just a collection of linked Web pages.      When you want to 
read one Web page, you typically also want to read many of the pages linked to that page.    
Express makes it easy to browse a group of Web pages by describing them, collectively, as 
an Express package.
Every package has exactly one starting page and some other number of pages that can be 
found by following links from the starting page. So, for example, the package for a magazine
would contain the articles and ads in the magazine, the package for a commercial store 
would have the products in the store, and an order form, and so on.
You use Express to set up packages, decide when to retrieve them, and how often, and then 
you use your Web browser to browse through the pages, as always.
You can also use folders for grouping and organizing your packages.
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    The Outline View: HotCargo Express Icons
There are three kinds of items that appear in the HotCargo Express window: folders, 
packages, and pages.    Each can have things inside: to open or close an item in the outline 
view, single-click on it.

The plus (+) symbol on an icon indicates that the item is closed (has contents that are not 
visible).    The minus (-) symbol indicates that it is open (the contents are visible).    The error 
symbol ( ) indicates that there was a retrieval error.

Here is a screen shot that shows some of the possible icons:
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    Reading Pages
HotCargo Express is an accelerator for your browser, an accessory that works hand-in-hand 
with your browser.    When you are running Express, you read pages in your browser, as 
always    the difference is that Express makes it faster to browse and easier to know what to 
browse.
To load a page from your Express window into your browser, double-click on it in the Express
window, and then click on links as usual to reach other pages. 
Whenever you click on a link to read a Web page, your browser will check to see if Express 
has a copy of that page on your machine before trying to get it from the network. But you 
never need to know where the page comes from:    Express hides the details from you.    So:

If you are reading a local page and click on a link to a page that Express does not have, 
your browser will get the page from the network and show it to you.
If you are browsing a page that is not part of a package, and stumble across a link to a 
page that is in Express, your browser will quietly (but quickly!) show you the copy from 
Express.

If you are curious about when Express is actually talking to the network, watch the modem 
lights at the bottom of the Express window, which shows Express    (  ) between the 
network ( 

 ) and your own computer ( 
).    The connections blink to show you when Express is talking to the network and when it 

is talking to the local copies on your own computer.
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    Starting a Retrieval
You can ask HotCargo Express to go get the pages in a package immediately, on demand, 
whenever you like.    To start an immediate retrieval, select the package in the Express 
window and use the Start Retrieval command button:

Express will start getting the pages in the package immediately.    The Start Retrieval 
command will not change the package properties, schedule any future retrievals, or change 
any future scheduled retrievals:    it just starts a one-time-only immediate retrieval. 
Express lets you know what is going on by changing the typeface of the pages it is going to 
retrieve:    when a page is lined up for retrieval, Express makes the name of that page italic.   
When it is actually getting a page, Express makes the name of that page Bold Italic 
Purple.    
At the bottom of the Express window you can check how many objects are queued    (left) to 
retrieve
If you have already retrieved the package once, each new retrieval will retrieve only the 
pages that have changed, and will not re-retrieve every page in the package.    

Note:    Starting a new retrieval will also delete any leftover pages from your local 
copy:    that is, it will delete any that are in the Express copy but no longer on the 
Website itself.
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    What's Changed?
Whenever it retrieves a package, HotCargo Express will check each page in the package and
let you know which pages have changed since you last looked at them.
Express marks unread pages and packages by making the title bold-face blue. If Express is
still in the middle of the retrieval, but has noticed that at least one page in the package has 
changed, the package will be bold-face blue italic.
When you look at a page (by double-clicking on the page in the Express window), Express 
returns the font and color to normal. Or you can use the View -> Mark Read command to 
explicitly mark the pages as read.
To browse through just the pages that have changed, use the Next Unread command, 
which skips from one blue page to the next. Click on some page in the Express window, and 
then click on the  command button to see the next unread page.    The Next Unread 
starts at the currently selected page and searches toward the bottom of the Express window.
If you are already at the bottom of your Express window, it will not go back up to the top 
again to look for unread pages.
Here is a snippet of the Express window.    The Wood Home Page and New Comics 
packages have pages that have changed since you last looked at them.    The Comics 
Weekly package has also changed:    it is italic because Express is still in the middle of 
retrieving the package.
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    Scheduling Regular Retrievals
It is fun to watch HotCargo Express retrieve a large package of Web pages, but it is even 
more fun to come in the next day and find the pages waiting.    You can schedule Express to 
get Web pages any time of day or night, even if (especially if!) you are not around.
Scheduling package retrievals is like using an alarm clock. With an alarm clock you might 
have the time set for 1:43 AM, but only turn on the alarm on weekdays. With Express, you 
might set the retrieval schedule to retrieve once a week on Sundays, and turn it on and off 
as you like.
To set up or change the retrieval schedule for a package, right-click on the package in your 
Express window and select Properties to bring up the package property sheets.    On the 
Basic properties, you can see and change the retrieval schedule for that package. 
To turn scheduling for a package on or off, select the package and use the Schedule 
command button: .    This is like turning your alarm clock on or off once you have already 
set the time for the alarm.
When scheduling for a package is turned on, Express marks it with an alarm clock.    Here is a
screen shot that shows some scheduled and unscheduled packages:
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    Package Links
When you first install HotCargo Express, it comes with a set of initial packages set up for 
you, to give you a place to start. When you are ready to add new packages, the first place to
look is our Website, which has a collection of published packages ready for you to grab with 
a single click.
To browse our collection of packages, go to your Express window and open the DocuMagix 
folder.    Select the entry called Sites to Download using HotCargo Express, which will 
load our page of package links into your browser. Browse around, and when you find a 
package that interests you, click on the 

 
button for that package.    You can add as many packages as you like, though you can only 
add one package at a time.
When you click on an Express It button, Express adds a new package to your running copy 
of Express. The new package will be scheduled for retrieval, at whatever time the author of 
the package has chosen. If you are the impatient sort and want to see it quickly, you can 
select the package and use the  to start an immediate retrieval.
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    Making Your Own Packages
No matter how many packages we publish on our Website, there will always be other sites 
that interest you. You can build your own packages quickly and easily, with the     
command, which is available both from the HotCargo Express toolbar and from the browser 
toolbar.
When you use the  command, Express will set up the starting URL for the new package to 
be the page that is currently visible in your browser. You can either leave this URL as the 
starting page or type in another.    
Express will set the package properties for your new package from the standard package 
properties. You can either leave those properties as they are or modify them to suit.
Once you have created a new package, you can start an immediate retrieval, schedule it for 
regular retrieval, refine the package properties, drag it to a new location in the Express 
outline view, and so on.
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    Stopping a Retrieval
To stop a running retrieval, select the package or any page inside the package and use the 
Stop Retrieval command button:

    
Whenever you stop a retrieval, HotCargo Express will mark the package with  and write an 
appropriate message in the Package Status sheet.
When you stop a retrieval part-way through, you will end up with an incomplete package:    
Express will not keep pages left from earlier versions.    Do not expect to be able to use a 
package if you stop the retrieval in the middle    even if you had previously retrieved the 
entire package.
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    That's It!
And that is the basics:    how to create and schedule packages, start and stop retrievals, and 
browse through the pages HotCargo Express has retrieved for you.
As you become a more advanced user, you can browse the reference section to learn details
about other Express features, like retrieval schedules, the key ring (for accessing Web pages 
that use a password), package filters and limits (for refining packages that you have 
created), and changing the properties that Express uses for new packages.
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    Reference Section
HotCargo Express Toolbar

Browser Toolbar

 

 

Package Properties and Preferences

Package Properties
Basic Images Limits Filters Script Logon    

Preferences
Basic Images Limits Filters Advanced 

Status
Package Status 
Page Status 

Key Ring:    Accessing Password-Protected Pages

Key Ring 
Adding and Modifying Entries 
Key Ring Master Password 

Menu Commands
File View Retrieval Help

New Package Browser Online Preferences Quick Start Guide
New Folder            Browser Offline    Schedule On Topics
Properties Next Error Schedule Off      Search for Help On
Delete                            Next Unread                  Start Customer Service
Key Ring Mark Read Stop                                  About DocuMagix
Logon Mark Unread                Stop All About HotCargo Express
Logoff                            Status
Exit Page                                    

Browser Toolbar
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    The New Folder Command
The New Folder  command adds a new empty folder to your HotCargo Express window.
Here is how to use it:
· Select an existing folder.
· Click on the     command button. Express will create a new folder, insert it in the 

display, and open the Folder Properties sheet.
· Type in a name for the folder.
· Click the OK button on the Properties sheet to save your new folder name.

Express will put your new folder as the first item inside the currently selected folder.    If you 
want to move it later, use your mouse to drag it to a new location.    
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    The New Package Command
The New Package  command is available both from the browser toolbar and from the 
HotCargo Express toolbar.
The New Package command creates a new package in your Express window and opens the 
package Properties sheet for it.    Express will set up the starting URL of the new package 
with the URL that is currently displayed in your browser. You can either use this URL or type 
in something different. 
The initial properties for the package will be set from your new package preferences.    You 
can either leave them as they are or make changes, and then click the OK button to save 
your changes and close the Properties sheet.
If you use New Package from the Express toolbar, Express will use the current selection in 
the Express window to choose where to put the package.    If you use New Package from 
the browser toolbar, Express will always put the new package first in the outline view.    To 
move a package after you create it, use your mouse to drag it to a new location.
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    The Delete Command
The Delete  command removes the selected folder, package, or page from the HotCargo 
Express display.    When you remove a package, Express will also remove all underlying files 
from your computer.
Express will ask you to confirm each deletion. 
The Delete command can be slow if you are deleting a large package.
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    The Next Unread Page Command
The Next Unread Page  command is available from the HotCargo Express toolbar and 
from the browser toolbar.
The Next Unread Page command lets you browse through unread pages (pages that have 
changed since you last double-clicked to load the page into your browser).    It starts at the 
currently selected page and searches toward the bottom of the Express window, and loads 
the next unread page into your browser. If you are already at the bottom of your Express 
window, the Next Unread command will not go back up to the top again to look for unread 
pages.
When Express retrieves a new version of a page, it will mark the page as unread (bold-face 
blue), to draw your attention to the change.    If you visit the page in your browser, without 
going through Express, Express has no way of knowing that you have seen the new version, 
and the name will stay unread.
If you want to mark pages as read without actually loading them into your browser, use the 
Mark Read command on the View Menu.
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    The Schedule Command
The Schedule  command turns the schedule for a package on or off.    It does not change 
the schedule; it just turns it on or off, sort of like turning your alarm clock on or off.
To turn scheduling on or off for some package, select the package in HotCargo Express and 
click the  command button.
When scheduling for a package is turned on, HotCargo Express will begin retrieving the 
pages in the package, according to the schedule described in the package properties.
Some points to notice about scheduling:
· The basic package properties include a frequency, which specifies whether to retrieve 

Once or on some particular frequency. If you turn on scheduling for a package that has 
retrieve once, Express will remove the alarm clock after the first retrieval.    If you want 
the scheduling to stay on, you have to change the schedule to retrieve regularly, using 
the Basic Properties on the package properties sheet.

· The schedule for most packages varies    (that is, it is set to be sometime between, say, 
midnight and 2 AM, rather than exactly 1 AM on the dot). This feature is an important 
way to keep from overloading servers by having too many connections at exactly the 
same time.    If the exact time is important to you, you can remove the variance with the 
Basic Properties on the package properties sheet.
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    The Start Retrieval Command
The Start Retrieval  command is available from the HotCargo Express toolbar and from 
the browser toolbar.
The Start Retrieval command starts an immediate retrieval for the selected package.    It 
does not change any of the package properties or schedule regular retrievals:    it just starts 
a one-time only immediate retrieval.
If you have already retrieved the package once, each new retrieval will retrieve only the 
pages that have changed, and will not re-retrieve every page in the package.    

Note:    Starting a new retrieval will also delete any leftover pages from your local copy:   
that is, it will delete any that are in the Express copy but no longer on the Website itself.
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    The Stop Retrieval Command
The Stop Retrieval  command is available from the HotCargo Express toolbar and the 
browser toolbar.
The Stop Retrieval command stops the retrieval of the currently selected package.    The 
Stop Retrieval command always applies to the entire package, and not to a particular 
page. If you hit the Stop Retrieval button when the current selection is a page, Express will
stop the retrieval of the package that contains that page.
Whenever you stop a retrieval, HotCargo Express will mark the package with . The status 
window for the package will display an error message saying you stopped the retrieval, as a 
reminder that the package was not successfully retrieved. 
When you stop a retrieval part-way through, you will end up with an incomplete package:    
Express will not keep pages left from earlier versions.    Do not expect to be able to use a 
package if you stop the retrieval in the middle    even if you had previously retrieved a 
complete version.
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    The Browser On Line Command
The Browser Online  command is available from the HotCargo Express toolbar and the 
browser toolbar.
The Browser Online command determines whether your browser is currently connected to 
the network. It has nothing to do with HotCargo Express itself.    Express will continue to 
retrieve pages regardless of whether the browser is on line or off line.    
When your browser is off line, Express will display  in the toolbar; click on it to take the 
browser online again.

When your browser is on line, Express will display  in the toolbar; click on it to take the 
browser offline.
You might want to take your browser off line if, say, you have a dial-up connection to the 
Internet and do not want your browser to initiate a dial-up connection or if you are 
constructing a new package and want to be able to easily tell which pages are part of the 
package.
In many ways, Express is just an extension to your browsers cache (another place that your 
browser can keep pages to give them to you quickly). So when you ask to see a page, your 
browser will check with Express, check in its own cache, and then go out to the network as a
last resort.
If you ask your browser for a page and your browser is on line, here is where it will look for 
the page:

· When you double-click on a page in Express, the browser will look first in its own 
cache, and then check with Express, and finally go out to the network.    

· When you use your browsers Reload command, your browser will always go out to
the network to get the page, bypassing both its own cache and Express.

If you ask your browser for a page and your browser is off line, here is where it will look:
· When you double-click on a page in Express, your browser will look first in its own 

cache, and then check with Express.    It will not go out to the network for the 
page:    if it does not find the page in either of those two places, it will show you 
an error message suggesting that you put your browser back online.

· When you use the Reload command, your browser will check with Express only 
and not look in its cache or on the network.
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    The Toolbar Help Command
The Help  command is available from the browser toolbar.    It brings up this Help file.
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    Menu of Packages
The browser toolbar has a pop-up menu area that lists the packages currently in your 
HotCargo Express window. When you select a package from the list, Express will load the 
starting page of that package into your browser window, and also use that package as the 
target package for commands such as Start Retrieval and Stop Retrieval.
Here is a sample snapshot of the menu before you make a package selection:
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    Package Properties
Each package has a set of properties, which describe exactly which pages are in the 
package and when you want HotCargo Express to get them.
You can see the properties of a package with the File -> Properties menu command, or by 
clicking your right mouse button over the starting page for the package and selecting 
Properties.
The most general package properties appear on all property sheets:    the name and title of 
the starting page, and the source of the properties themselves. Click on any of the active 
areas in the image below for details on each field:
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    Basic
The properties on the Basic tab describe when and how often HotCargo Express should 
retrieve a package.    
To change the values for a particular package, right-click on the package in Express and roll 
to Properties. To change the properties given to newly created packages, use the Retrieval 
-> Preferences command.
Click on any of the active areas of this image for details.
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    Images
The Images properties describe how HotCargo Express should handle pages that are not 
text, such as images and Java applets:    whether it should retrieve them after text files, 
before text files, or not at all. 
To change the values for a particular package, right-click on the package in Express and roll 
to Properties. To change the properties given to newly created packages, use the Retrieval 
-> Preferences command.
Click on any of the active areas in this image for details.

 Copyright © 1996, DocuMagix, Inc. All Rights Reserved.

HotCargo Express Website Customer Service 



    Limits
The properties on the Limits tab describe limits on the retrieval for the package, to help 
control the size of the package that HotCargo Express retrieves. 
To change the values for a particular package, right-click on the package in Express and roll 
to Properties. To change the properties given to newly created packages, use the Retrieval 
-> Preferences command.
Click on any of the active areas in this image for details.
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    Filters
The Filters properties give you detailed control over which pages HotCargo Express will 
include in a package.    So, for example, you could use filters to retrieve only particular parts 
of a site or you could use filters to leave out all files with old or archive in the file name, or 
you could use filters to ignore all files with the extension .exe, and so on.
Filters do not apply to page resources that are considered part of the loaded page, such as 
images and Java applets.        
There are three kinds of filters.    You can use any or all of them, although things can get 
confusing if you combine too many different kinds of filters. When you do use several filters, 
Express always combines them with AND.

Filters on URLs 
Label Filter Properties 
Extension Filter Properties 
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    Filters on URLs
Filters in general let you include or exclude particular pages from a package: Filters on 
URLs do that filtering based on the name of the page.    
Filters apply to individual Web pages only and not to resources that are considered part of 
the loaded page, such as images and Java applets.      So you can not use filters to control the
retrieval of images or applets.
When you are writing filters, be careful to include the trailing slash at the end of directory 
names, and be sure that any patterns you write include the name of the starting page itself.  
In general, use wildcards freely, since there are sometimes surprises when you try to do 
exact matches.
If you use more than one filter, HotCargo Express will apply the Match filters first, and then 
the Exclude filter.      For a detailed and annotated set of examples of filters, see our Website

http://www.documagix.com/products/hotcargo_express/packages/docs/
examples.html

Click on any of the active areas in this image for details.
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    Filters on Labels
The Filters properties let you include or exclude particular pages from a package: filters on 
Labels do that filtering based on PICS labels.    (PICS labels are for labeling content, for 
example to indicate whether it is appropriate for children. If you can find a PICS label on a 
page, you can filter on it, but at the moment very few Web pages are tagged with PICS 
labels.)
Click on any of the active areas in this image for details about a particular property.    
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    Filters on Extensions
Filters in general let you include or exclude particular pages from a package:    Filters on 
Extensions do that filtering based on file extensions.      If you supply no filters, Express will 
match all extensions. If you supply both matching and excluding, HotCargo Express will 
apply the Match filter first and then the Exclude filter.
To change the values for a particular package, right-click on the package in Express and roll 
to Properties. To change the properties given to newly created packages, use the Retrieval 
-> Preferences command.
Click on any of the active areas in this image for details about a particular property.    
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    Script Properties
The Script properties apply when there is a package script; that is, when the package 
properties are set from a file on some Web page.    (See our Website, at 
http://www.documagix.com/products/hotcargo_express/ for information on how to 
write your own package scripts.)
Notice that some package scripts are read-only:    that is, the package author has set up the 
script in such a way that you can not change the properties in your Express window. This is a
deliberate choice on the part of the package author.
Click on any of the active areas in this image for details about a particular property.    
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    Logon Properties
The Logon properties apply only when you are having trouble making the key ring work with
some particular site. Some sites, particularly those running the Netscape Commerce Server, 
customize their authentication based on a guess of what browser you are running, and 
guess wrong when you are running Express.    This option tries to circumvent that behavior 
on the part of the server. 
You should use this option only if you have an entry in your key ring for some site but 
Express is still unable to access pages on that site.
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    Package Preferences
When you create a new package, Express gives it a set of standard package properties. To 
change the standard properties, use the Preferences command on the Retrieval menu and 
make your changes to the appropriate property tab.
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    Advanced Preferences
The Advanced preferences sheet contains preferences that are not part of package 
properties. Click on any active area of the image below for information:
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    Key Ring:    Accessing Password-Protected Pages
Some Web pages are available only to subscribers:    you have to supply your user name and
password before your browser will let you see the page.    HotCargo Express has a Key Ring 
for remembering these user names and passwords, so that Express can get pages from 
those sites when you are not around.
The File -> Key Ring menu command brings up the main key ring page, which shows the 
current entries in the key ring and lets you add, modify, or delete entries.
The easiest way to use the key ring is to check the Automatically add... box, and let Express 
do the work.    When you have got this option turned on, Express will snoop when you log on 
to a particular Web page, remember your name and password for that page, and store them 
in the key ring. 
However, because of variations among Websites, the snooping will not always work. When 
you want to read a site that uses a password, check the How To section for a recipe to make 
sure the key ring entry is added correctly.
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    Key Ring Entries
You use this page to add or change an entry in the key ring.    To add a new entry, enter the 
name of the host, and the user name and password you use to access that host.    
Click on any area of the image for details.
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    Key Ring Master Password
The master password is a password you use to protect the information on your key ring.    
You only need a master password if you are concerned about protecting your key ring 
information from other people    either people who might actually sit at your computer, or 
people who share your local network and have access to your files.
If you use a master password, you will need to enter it each time you start HotCargo 
Express. Your master password can be anything you like    it can be the same as the 
password you use to log on to Windows, but does not have to be.
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    Package Status
The package status sheet shows retrieval information for the current package; click on any 
area of the image below for details: 
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    Page Status
The page status sheet gives the name and URL of the current page, plus an error message 
or status message showing the current retrieval status for the page. Click on any area of the 
image below for details:
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    Package Status Messages
Here is an explanation of the most common status messages:

    This retrieval is queued and waiting to start.

Express has queued the page or package for retrieval but not yet started actively retrieving 
pages (usually because it is still retrieving some other package).

    This retrieval is now in progress.

Express has started retrieving the pages in the package, but has not yet finished.

    Request finished. This request completed normally but 1 page(s) could not be retrieved.

Express finished retrieving the package, but there were problems with one or more 
individual pages. To see which pages had errors, use the View -> Next Error command.

    This request was cancelled by the user.

Express stopped the retrieval in response to an explicit Stop Retrieval command, exiting 
Windows, or exiting Express. When this message appears, you will need to re-retrieve the 
package before you try to use any of the pages in it.

    Request finished.    No pages were retrieved because the URL names a page that is not 
text and the policies request text only.

Express finished the retrieval but did not retrieve any pages, because the pages did not 
match the filters on the Image Properties sheet.

    Request finished. No pages were retrieved because either the starting URL is not valid or
it does not match one of the filters.

Express finished the retrieval, but did not retrieve any pages. The most common cause of 
this error is that you have used Filter properties, but have not included the starting page 
itself as part of the filters. See the Property sheet for filtering on URLs page for details.

    This request was cancelled because the time limit was exceeded.
    This request was cancelled because the byte limit was exceeded.
    This request was cancelled because the page limit was exceeded.

Express stopped the retrieval because it reached a policy limit on retrievals (on disk space, 
overall number of bytes, time, or number of pages).    If Express hits any of these limits, 
either daily limits or per-package limits, or if the store fills up completely, Express will stop 
doing retrievals, mark each page with an error symbol, and wait for you to decide what to 
do.    Express will never try to guess which pages to delete, or to expire pages that you have 
had for a while.

    Request finished.    The retrieval was cancelled because of a problem with its script:    
This page could not be retrieved because the requested URL was not found on this site.

    Request finished.    The retrieval was cancelled because of a problem with its script: The 
script was not found or there was no RETRIEVE tag on the page.



Express was trying to retrieve a package whose properties come from a package script, but 
was unable to retrieve the specified script or unable to find a script on the specified page.    

There are a variety of other errors related to package scripts as well. In each case Express 
tries to give you as much information about the error as possible.    See our Website, at 
http://www.documagix.com/products/hotcargo_express/, for information on writing 
package scripts.
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Page Status Messages
    This page was successfully retrieved.

You will see this message when Express retrieves a page successfully.

    This page could not be retrieved because: Unauthorized
    This page could not be retrieved because: Forbidden

Messages of this style are messages reported back from the server:    they mean that the 
server has not allowed the request for some reason.    The message can be any message 
returned from a server, such as Bad Request or No response or Hostname could not be 
resolved.

    This page could not be retrieved because the requested URL was not found on this site.

This message means that the URL named a file that was not found on the server. This error 
is marked with  in the Express display, rather than with the Express error symbol (the red 
dot). This type of error is different from the others:    it is not a retrieval error; it is a oops the 
page has moved error.    (This is 404 Not Found.)



    File Menu
New Package

The New Package command creates a new package. See the description of the  
command button.

New Folder
The New Folder command creates a new folder. See the description of the  
command button.

Properties
The Properties command brings up the Properties sheet for the selected page or 
folder.    See the section on Property Sheets.

Delete
The Delete command deletes the selected page or folder.    See the description of the

 command_button.

Key Ring...
The Key Ring command brings up a property sheet for viewing and editing key ring 
information.    See the section on the key ring.

Logon
Logoff

If you share your computer with others, you may want to protect your key ring 
information with a password.    See the section on using a master password .    

Exit
The Exit command exits from Express.
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    View Menu
Browser Online
Browser Offline

These commands determine whether your browser is currently hooked to the 
network. See the description of the  command button.

Next Error
This command displays the next page or package with an error; that is, the next page
marked with the  symbol.

Next Unread
This command displays the next unread page; see the description of the  command
button.

Mark Read
Mark Unread

These commands let you manually change the unread status of a page or package. 
Normally HotCargo Express keeps track of which pages have changed since you last 
double-clicked to load them into your browser.    To change the marking without 
actually loading the page, select a page or package and use one of these commands.
If you select a page with children, Express will ask you whether you want to mark just
the original page, or its children as well.

Status...
The Status command brings up a window that shows the retrieval status for the 
selected package or page.

Page...
The Page command displays the selected Web page in your browser; this is the same
as double-clicking on the Web page in the Express display.

Browser Toolbar
The Browser Toolbar command determines whether the Browser Toolbar is currently
active. 
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    Retrieval Menu
Preferences

This option allows you to customize HotCargo Express with your own personal 
preferences for standard package properties, limits, and so on.    See the section on 
Preferences.

Schedule On
The Schedule On command turns on the retrieval schedule for the selected 
package.    See the
description of the  command_button.

Schedule Off
The Schedule Off command turns off the retrieval schedule for the selected 
package.      See the
description of the  command_button.

Start
The Start command starts a retrieval of the selected package immediately.    See the 
description of the  command_button.

Stop
The Stop command stops the retrieval of the currently selected package 
immediately.    See the description of the  command button.

Stop All
The Stop All command stops all running or queued retrievals immediately.
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    Help Menu
Quick Start Guide...

The Quick Start Guide command brings up the Quick Start guide.

Topics...
The Topics command brings up the table of contents for this Help File.

Search For Help On...
The Search For Help command brings up the index for this Help File.

Customer Service...
The Customer Service command brings up information on how to obtain technical 
support for HotCargo Express.

About DocuMagix
The About DocuMagix command brings information about how to reach DocuMagix.

About HotCargo Express
The About HotCargo Express command brings up version and serial number 
information.
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    HotCargo Express Website
For more information about HotCargo Express, visit our Website at: 

http:// www.documagix.com/products/hotcargo_express/

Thank you for using HotCargo Express.    We hope you enjoy it.
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    Customer Service
All retail copies of HotCargo Express and subscription copies such as Pathfinder Personal 
Edition come with 30 days free Customer Support.

Before contacting us for support, be sure to do the following:
1) Try to identify the problem's source.

Verify that your computer and Web Browser are functioning properly. Windows, 
Windows 95 and Windows NT should be installed and working properly. If you are 
having difficulty with your browser, please contact the manufacturer of your browser. 
If you are unable to connect to your local provider, please contact your local Internet 
Provider. For issues related to Windows, please contact Microsoft.

2) Check your documentation
Once you have verified your browser, connection and Windows are functioning 
properly, you should read through the Troubleshooting section of the Help and 
Readme files.

3) Have your information ready
Please include or be ready to provide your serial number whenever contacting 
DocuMagix Customer Support. To find your serial number, use the Help ->About 
HotCargo Express menu command.
In addition, we need to know your computer model, operating system and Windows 
version, as well as the browser you are currently using.

If you choose to write or Fax us for assistance, please be sure to write Customer Support on 
the envelope or cover sheet. also, please include your daytime phone number and the best 
time to reach you.
If you choose to call for support, please be at your system so that you may provide any 
additional information which may be necessary.

Please check your README file for addresses and phone numbers for contacting 
DocuMagix Customer Support.

 Copyright © 1996, DocuMagix, Inc. All Rights Reserved.

HotCargo Express Website Customer Service 



Location Field
This field shows the URL of the current starting page.    HotCargo Express will set up this field
for you but you can always edit it yourself if you want to make changes.    If you do not type 
the http:// part, Express will fill it in for you.



Title Field
The title of the page, which is what appears in the HotCargo Express display.    
If you leave the title field empty, Express will use the TITLE field of the page itself.
If the page has moved to a new location on the server, Express will display the redirection 
message from the server as the title of the package.    Different servers report different 
redirection messages; for example, you may see Redirect or Redirection or Document 
Moved or Found and so on. Express will retrieve the redirected pages correctly, however.    
You can change the title of a package at any time in your Express window at any time. You 
cannot change the title of a page.



Retrieval Scheduling On or Off
This property specifies whether the retrieval schedule for this package is currently turned on
or off.    When the schedule is on, HotCargo Express marks the page in the display with an 
alarm clock icon and schedules retrievals for the package according to the current schedule 
for that package.    When the schedule is off, Express will remove the alarm clock icon and 
not schedule retrievals for the package.
The  command button is a shorthand way to set this property.



Where do the properties for this package come from?
This area tells you where Express is getting the package properties. There are four 
possibilities: 

·  From the default preferences    HotCargo Express is using its standard values for
this package. Express comes with a set of standard package properties, which you    can 
change with the Retrieval->Preferences command. Any modifications you make to your
standard package properties will apply to every new package you create.

·  Fetched from a script on the Web  Express is getting the properties from a 
package script. Express will get a new version of the script each time it schedules a 
package retrieval, to make sure that the script has not changed.    You can see more 
about the script on the Script Properties page.

·  Fetched from a read-only script on the Web  Express is getting the properties 
from a package script, but the script is set up in such a way that you can not retrieve the
script and then modify the properties.    This is a deliberate choice on the part of the 
script author.

·  Customized for this package      The properties for this package were 
originally set from the standard package properties or from a script, but are now from the 
property sheets themselves, since you have changed one or more properties.



Starting Time
This property describes the time of day when HotCargo Express should start getting this 
package.    You can either choose a time from the menu or type one in.    You can either let 
Express set the date (to the current date) or type one in.    The format should be:

12/9/96 12:00:00 AM
Notice that Express typically varies the starting time to have some slack, rather than 
retrieving at exactly the precise starting time.      So if your starting time is noon, say, the 
retrieval might start at any time between noon and 1 PM, depending on the value in the 
Smooth load on this Website box.



Varying the Starting Time
This property adds some slack to the starting time, so that servers do not have to cope with 
too many Express users all trying to retrieve at exactly the same time.      Instead, Express 
will create some random starting time for each retrieval, using the retrieval schedule and 
the slack described here. 
For example, a package might be set up to retrieve at midnight or sometime in the next 4 
hours. You can see the actual scheduled starting time for each retrieval on the Package 
Status page.
If you want some interval other than hours you can type it in, using units of:

minutes
seconds
hours
days
weeks



Frequency Properties
You can choose to retrieve a package only once, or on some regular schedule. If you choose 
Once, Express will let you set the time of the one retrieval; if you choose Daily, Express will 
let you choose the time of day; if you choose Weekly, Express will let you choose the day of
the week; if you choose Every you can create your own schedule.
If you want some interval other than hours you can type it in, using units of:

minutes
seconds
hours
days
weeks

The scheduling options are quite flexible    if you choose Every you can create any schedule 
you like, with any frequency and any time of day. We provide the other options as 
conveniences for commonly-used scheduling choices.



Depth Level
The depth describes how many links HotCargo Express will follow from the starting page.    
The links can be to any other server or directory, but resources that are considered part of 
the page, such as inline images or Java applets, do not count as a different depth level. So 
for example:
A level of 1 means that Express will retrieve the named starting page, and any resources 
that are part of the page, such as inline images or Java applets, and then stop.    
A level of 2 means that Express will retrieve the starting page, and each link on that starting 
page, plus any images or Java applets, and then stop.
And so on, up to a level of 6.    Finally, the level of All means to retrieve all pages on the site. 
Be careful with depth levels greater than 3:    it is easy to retrieve a huge number of pages if 
you are not familiar with the site.        (To set a limit larger than 6, just type it in.)



Retry Properties
The retry properties specify what HotCargo Express should do when it finds a server that is 
not responding. Retry properties are for advanced users:    if you are not careful, you can 
easily cause Express to be very inefficient by experimenting with the retry properties.

 Retries 
This field specifies the number of times Express should retry a retrieval, if the first attempt 
fails. 0 means fail after the first attempt, 1 means try a second time, and so on. 

    Delay
    Interval
    Backoff

These three fields together specify how long Express should wait between retries.      Delay is
the approximate time Express should wait before the first retry. Interval is a second 
interval, to make the retry occur at a random time, so retries do not overload the server. 
Backoff is a multiplier, so that successive retries can occur at increasingly infrequent 
intervals.    (For example, if a server is down, it makes no sense to retry frequently.) For 
example, if you set Delay to 3600 seconds (60 minutes), Interval to 600 seconds (10 
minutes), and Backoff to 2, then:

· The first retry will occur 60 to 70 minutes after the first retrieval fails
· The second retry will occur 120 to 140 minutes after the first retry fails
· The third retry will occur 240 to 280 minutes after the second retry fails

And so on.



Limits
The Limits give you a way to prevent Express from retrieving more pages than you expect.    
You can provide limits on how much Express will retrieve or on how long Express will spend 
trying to do the retrieval, or both    whatever you find easiest.
Express will stop whenever it hits any of the limits you supply:    on number of Web pages, on
number of kilobytes, or amount of time.    Whenever Express hits any of these limits, it will 
stop the retrieval immediately, mark the package with , and write an appropriate message
in the status sheet.
If you want a time limit that is not on the menu, you can type it in, using units of:

minutes
seconds
hours
days
weeks

There is no way to turn limits off altogether, but you can specify large values if you are sure 
you want Express to go ahead and retrieve a large package.



Estimated Size
This area shows the estimated size of the package. Express uses this information to gauge 
the progress of the retrieval, as shown in the Status Sheets.



Order
This property lets you prioritize the order in which Express retrieves the pages in a package. 
If, for example, you think you might hit an overall limit on the number of pages, you might 
want to retrieve the textual pages first.    This is sometimes a good way to start when you 
are first learning your way around a site.



Retrieve These Kinds of Pages
This property provides a simple way to filter out files that are not text files that is, files like 
images or sound files that are not meant for humans to read.    (More precisely, a text file is 
one that has the MIME-type of text.) 
For example, you might want to use this property to keep Express from retrieving Java 
applets, big sound files, images, programs (.exe files), movies, and so on.    For more detailed
control, use the Filter Properties.



Retrieve URLs Matching...
Express will retrieve any URLs that match the pattern specified in this field.    If you do not 
specify a pattern, Express will retrieve everything.    If you specify both MATCH and 
EXCLUDE, Express will do the match first and then the exclude.
Here are some hints on constructing patterns.

Þ The character * acts as a wildcard to match any number of characters.
Þ The patterns are case-sensitive.    
Þ The pattern SERVER matches any file on the same server as the starting page.    (The

string SERVER must appear in all uppercase and cannot be combined with * 
wildcards.)    
Be careful when you use SERVER, since there are sites that change the name of the 
server. For example, a site might advertise itself as http://www.site.com but use 
the name http://www2.site.com internally    and Express uses the internal site 
name for matching.    If SERVER does not seem to do what you expect, try using 
wildcards instead.

Þ The pattern DIRECTORY matches any file in the same directory (or folder) as the 
starting page. So, for example, if the starting page is 
http://www.documagix.com/hotcargo_express, then DIRECTORY is the same as 
the pattern http://www.documagix.com/hotcargo_express/*.      (The string 
DIRECTORY must appear in all uppercase and cannot be combined with * wildcards.)

Þ To specify more than one pattern, separate the patterns with commas.    Express will 
retrieve any URL that matches any of the patterns.    So in this example, Express will 
retrieve any URLs with ng-bin in the name, and any URLs with crafts in the name, 
and any pages with welcome in the name, and so on, and then apply the Exclude 
filters to remove any of the files specified in the exclusion filters.



Do not Retrieve URLs matching....
Express will not retrieve any URLs that match the pattern specified in this field.    Here is 
what you need to know about patterns:

Þ The character * acts as a wildcard to match any number of characters.
Þ The patterns are case-sensitive.
Þ To exclude files matching more than one pattern, separate the patterns with 

commas.    So in this example, Express will find all the pages that match the filters 
specified in the MATCH filters and then ignore any URLs that include the directory 
names money, kidstuff, Fact, city, features, or politics.



Do not Retrieve Past....
Express will not follow links from any page whose URL matches one of the patterns in this 
field. Here is what you need to know about patterns:

Þ The character * acts as a wildcard to match any number of characters.
Þ The patterns are case-sensitive.
Þ The pattern SERVER matches any file on the same server as the starting page. (The 

string SERVER must appear in all uppercase and cannot be combined with wildcards.)
Þ The pattern DIRECTORY matches any file in the same directory as the starting page. 

(The string DIRECTORY must appear in all uppercase and cannot be combined with 
wildcards.)

Þ To specify more than one pattern, separate the patterns with commas.



Filtering on File Extensions
The Extensions filters let you include or exclude files from a package based on the extension
of the filename.    
If you want to specify more than one extension, separate them with commas. Filters on 
extensions are not case-sensitive:    JPEG and jpeg are treated alike.    So in this example, 
Express will not retrieve any file with the extension au, or the extension aiff, or the 
extension mov or the extension mpeg or the extension mpg.



Filtering on PICS labels
These fields allow you to filter URLs based on the PICS label in a Web page. A PICS label is a 
label added by the content provider to indicate whether a page has adult content.    At the 
moment, very few Web pages are tagged with PICS labels.



Fetching Properties
The Script Location field gives the location of the script; the checkbox specifies whether 
Express is currently using the package script as the source of the properties.
If you want to start from a script and then make some changes, you can turn off the 
checkbox and leave the Location field unchanged, as a reminder of the location of the 
original script.



Fetch and Stop Buttons
The Fetch command tells Express to go get (fetch) properties from a package script, and 
insert those properties into the fields of the property sheet.    You do not need to use the 
Fetch command before you retrieve a package    HotCargo Express always does that 
automatically, just before it starts a retrieval. 
However, you might want to use Fetch to get properties from a script and then modify them,
or to explicitly retrieve a script that you know has changed on the server.
The Stop button stops a Fetch command that is already running.



Restore Defaults
This button clears any changes you have made to the package properties and restores your 
standard package properties (the ones that HotCargo Express uses for new packages.)    For 
information on how to change your standard properties, see the section on setting your 
Preferences.



Status Schedule
This area shows the start and stop times of the last completed retrieval.    If there is no stop 
time, then Express is currently in the middle of retrieving the package.
If the package is scheduled for another retrieval in the future, this area will show the  
symbol, with the time of the next scheduled retrieval.    Express uses the properties on the 
Basic Property Sheet to decide when to schedule the next retrieval.      Notice that most 
retrievals have some variation in the starting time, to avoid overloading the server    the 
starting time listed here is the time Express will actually start the retrieval. So do not be 
surprised if it seems to be at a slightly offbeat time.



Status Information
This table shows statistics on the package retrieval. The Status column shows the statistics 
for the currently-running retrieval, if there is one, or the last completed one, if the retrieval is
not currently running.    The Limits column shows the limits for this particular package, as 
described by the Limit Properties Tab for the package.



Location and Title
This field shows the URL and name of the package or page.    



Adding to the Key Ring
When you turn this property on, HotCargo Express will snoop when you type user names and
passwords into sites that require authentication. Express will then use those names and 
passwords when it retrieves from that site. If the automatic add does not seem to work, see 
the How To section for what to do next.



Host
This is the name of the host you are trying to access, such as www.crafters.com or 
www.documagix.com.    



User ID
The login name you use to access this site. This field is case-sensitive:    use the same 
capitalization all the time.



Password
The password you use to access this site. This field is case-sensitive; use the same 
capitalization all the time.



Realm
A realm is a name for a group of Web pages that are protected by a password.    In this 
version of Express, you do not need to supply a realm: you can just leave it blank, if you like.
The easiest way to get the name of the realm is to look in the box that your browser pops up
when you try to access a site that requires a password. For example, in this snapshot, the 
realm is Britannica Online.



 Daily Limits
These properties describe overall daily limits on retrievals.    For example, if you are worried 
about connection charges, you might want to set your overall daily limits to avoid surprises 
on the phone bill.



Concurrent Requests
HotCargo Express is capable of doing several Web page requests at the same time. You can 
make retrievals faster by making this number larger    but the Express user interface will 
then respond more slowly to your mouse clicks and keystrokes.    The largest value you can 
supply here is 4.



 Firewall Proxy
People who use the Internet at work typically go outside the building" via a firewall, designed
to protect internal material from the outside world. Their browsers use a proxy, a go-
between whose job it is to get through the firewall securely. 
If you are using the Web through a firewall, you use these fields to tell HotCargo Express 
about your proxy.
Ask your system administrator what proxy to use. You need to supply values for both HTTP 
proxy and port.    In this example, the proxy is www-proxy.company.com and the port is 
8000.    



 Store Preferences
HotCargo Express keeps its local copies of pages in a store on your local computer.
When your store is full    that is, when your current size is the same as your maximum size    
Express will stop doing retrievals, mark each package that fails with an , and put an 
appropriate message in the Page Status sheet.
Express will never expire pages from the store to make room for new ones. It will always 
stop doing retrievals and wait for you to make some room, either by choosing which pages 
to delete or by making the store larger.    
To remove pages from the store, select them in the Express window and use the  
command.
To make your store size larger, change the value in this property. You can make your 
maximum size as large as you like, as long as you have the disk space.



Objects Queued
As you are retrieving pages from the web the number of objects (text, java script) left to 
download is listed in the bottom right corner of the Express window.




