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What is ‘Net Pal?

‘Net Pal allows you to dial your internet service provider and connect your computer to the internet. ‘Net 
Pal works with the Dial-up Networking feature of Windows 95 to make the connection and has the 
following features :

· Re-dials until a connection is obtained.
· Reconnects automatically when disconnected by the remote host.
· Automatically dials a connection whenever a winsock application requires a connection to the internet. 
· Keeps track of how much time and money you have spent on each of your connections
· Ping option can provide network activity at intervals to prevent connections being dropped.
· IP address is displayed when connected.



The main ‘Net Pal window

Click on various parts of the image below to see a description of the functions of the different components
on the main ‘Net Pal window.

You can press the F1 key at any time while running ‘Net Pal to get help on the current procedure.



The ‘Net Pal Connect window

The ‘Net Pal connect window is displayed when a connection has been established. It displays 
information such as your local IP address and the time connected.

Click on various parts of the image below to see a description of the functions of the different components
on the connect window.



Command line options

‘Net Pal supports a single command line option which allows a connection to be dialed immediately when 
‘Net Pal is started. 

The option takes the following form: 

/D:”Connection Name”

where “Connection Name” is the name of one of your dial-up networking connections. The double quote 
characters must be present.

To modify a shortcut icon so that a connection is immediately dialed when you click on the shortcut icon, 
do the following:

· Right-click on the shortcut icon and select the Properties option.
· Select the Shortcut tab.
· In the Target edit box, enter a space and the “/D:”Connection Name” at the end of the existing 

command text, where “Connection Name“ is the name of the connection you want to dial.
· Select OK



The Connect command
Selecting the Connect command from the File menu will dial the selected connection in the Connections 
list box. You will see the status of the dialing process below the Connections list box during this process. 

When the connection is established ‘Net Pal will display the Connect Window, which will display 
information about the call.

A connection can also be established by clicking on the  toolbar icon, or by double-clicking on the 
connection name in the Connections list box.



The Disconnect command

Selecting the Disconnect command from the File menu will disconnect from the currently connected 
remote computer. 

A connection can also be disconnected by clicking on the  toolbar icon. If ‘Net Pal is shut down while a
connection is active, then the connection will be terminated before ‘Net Pal closes.



The Stop command

The Stop command on the File menu is active only while a connection is being dialed. Selecting this 
command will cause the current dialing operation to be canceled.

The  toolbar icon can also be used to terminate a dialing operation.



The Options dialog

The Options dialog can be displayed by selecting the Options command from the View menu. The options
that can be set in this dialog are global, and affect all connections in ‘Net Pal. The following options can 
be set in this dialog:

Redial Connections
Selecting this option will cause ‘Net Pal to keep re-dialing your connections until a connection is made. If 
the remote computer does not answer the phone, is busy or cannot log you into it’s network then the 
number will be dialed again if this option is enabled. The interval allows you to set the number of minutes
and seconds to wait before attempting to dial the remote computer again after an unsuccessful attempt.

Minimize on connect
Selecting this option will cause the ‘Net Pal window to automatically minimize (shrink to a taskbar icon) 
when a connection is established.

Copy IP to clipboard
If this option is enabled then the IP (Internet Protocol) address of your local machine will be copied to the 
clipboard when a connection is established. This allows you to paste your IP address into another 
application (such as an e-mail message) by using the clipboard.

Auto reconnect
This option will cause ‘Net Pal to immediately dial a connection again if you are unexpectedly 
disconnected from the remote computer for any reason. This can happen if the remote computer logs you
off for any reason or because of phone line problems.

Disable if auto-dialed
If this option is checked then the auto reconnect option will be disabled if the connection was 
made as a result of auto-dialing when another application required an internet connection. This 
may be required to prevent the connection from being constantly re-established and hence 
adding to your charges. This will most likely be useful for applications which connect to the 
internet at regular intervals and which may occur while your computer is unattended.



The connection properties dialog

The Connection Properties dialog can be displayed by selecting the Connection Options command from 
the Connection menu. This dialog allows options to be set for each connection you have. The dialog 
contains tabbed pages for the following categories:

· Properties page - sets usage tracking options and password for the connection.
· Ping page - sets ping options for the connection to help prevent dropped connections.



The connection properties page

The options on this page allow you to set usage tracking options and your password for this connection.

Track Usage
When this option is enabled ‘Net Pal will keep track of the time and money you spend when online. 
Whenever a connection is made the length and cost of the call will be accumulated on a monthly basis, 
and you can view your usage history for the last 12 months.

Fixed Fee
If your Internet Service Provider charges a fixed fee per month, enter that amount here. ‘Net Pal will factor
this amount into the monthly cost.

Free Hours
If you are granted a fixed number of hours of connect time per month free (or for your fixed monthly fee) 
then enter that number of hours here.

Hourly Charge
Enter that amount you are charged per hour of online time here. This charge will be used to calculate cost
once you have spent more time than your free hours online each month.

Billing Cycle Day
Enter the day of the month on which your Internet Service Provider bills you. ‘Net Pal will roll over your 
monthly time and cost totals on this day of every month.

Log All Calls
If this item is checked then ‘Net Pal will keep track of every call that is made individually. ‘Net Pal will keep
track of the date, time and duration of every call that you make.

Password
You can enter your password to be used for this connection here. The password will not be displayed as 
you type for privacy. You must enter your password exactly the same in both edit boxes. If you do not 
enter a password here then you will prompted to enter your password every time you connect using this 
connection.



The Ping page
This page allows you to set ping options for this connection. By setting a ping option ‘Net Pal will generate
activity on your connection at an interval you specify. This can prevent your Internet Service provider from
logging you off when your connection is idle for too long.

Don’t Ping
Disables the Ping feature.

Ping DNS Server
Choosing this option will cause ‘Net Pal to ping your DNS server at the interval you specify. ‘Net Pal will 
send an echo packet to the DNS server and wait for a reply.

Interval
This option is enabled if you choose a ping option and allows you to set the interval in minutes between 
pings.

Don’t ping if auto-dialed
Selecting this option will prevent ‘Net Pal from performing the ping when the connection was made 
automatically as a result of another application requiring an internet connection. You may want to use this 
option if you do not want the connection to be kept alive unless you explicitly establish the connection 
through ‘Net Pal yourself.



The Connection Status dialog

This dialog displays usage history for the currently selected connection. If you have enabled the Track 
History options in the Connection Properties dialog, then this dialog will display the totals for (up to) the 
last 12 months.

Only 12 months of history are stored and the totals will be rolled back each new month. After 12 months 
your totals for those periods will not be available in ‘Net Pal.

The list box displays the number of calls, the time spent online and the total cost for each month. The 
date displayed is the date on which the monthly period started.

To close this dialog, click the X icon in the upper right corner of the window.

Include fixed fee
When this option is checked the fixed monthly fee for this connection will be included in the Cost column 
of the list box in this dialog. If you clear this option, then the cost displayed will not include the fixed 
monthly fee and will display the amount over the fixed fee which has been spent each month.

Clear
This button allows you to delete all of your usage history. You will be prompted to make sure you really 
want to do this, as once you clear your usage history you cannot recover it again.

Show Log >>
If you have chosen to keep a call log for this connection then this button will be enabled. This button will 
expand this dialog to display a log of all the calls you have made on this connection. The date, time and 
duration of each call is displayed, with the most recent calls displayed first. Once the dialog has been 
expanded, pressing this button again will hide the log and shrink the dialog again.



Toggle Auto Dial command

This command will toggle the Auto Dial feature for the currently selected connection. Only one connection
can be designated as an Auto Dial connection. The connection which is designated as the Auto Dial 
connection will be displayed with a lightning bolt icon next to it in the connections list box.

When you use the auto dial feature of ‘Net Pal, ‘Net Pal will load automatically and dial the selected 
connection whenever any (32 bit) application requires a connection to the internet and there is no 
currently active connection. If ‘Net Pal is already loaded but is not connected then the existing instance of 
it will just dial the selected connection.

Using this feature you can set up another application (such as an e-mail program) to automatically check 
for mail at a given interval (say once an hour). Every hour when the e-mail program attempts to retrieve 
your e-mail, ‘Net Pal will automatically dial your connection if there is no active connection. 

Some applications allow you to set the connection method to the internet and let you choose between 
using a dial-up networking connection or using a direct network-based connection to the internet. In these
cases, choose the direct network-based connection method. Otherwise each application will dial the 
connection independently of ‘Net Pal, and the time/cost online will not be tracked by ‘Net Pal.



What is Registration?
‘Net Pal is a “Shareware” program. This means that you are free to use the software for up to 30 days 
free of charge for evaluation purposes. If you decide to keep the software after 30 days then you must 
register your copy with Kookaburra Software for a small fee.

The shareware (or unregistered) version of ‘Net Pal contains all of the functionality of the registered 
version. This allows you to make sure that it works satisfactorily for you before you purchase the software.

When you register ‘Net Pal the nag screen which is displayed when you start the program will be 
removed. In addition registration entitles you to free technical support and minor upgrades to the 
software. And don’t forget that registering this and other shareware programs allows the authors to 
continue development on those and new products.

Click here to find out how to register.



How to Register ‘Net Pal

The registration fee for a single copy license of ‘Net Pal is US$19.

When you place an order you will receive by return e-mail or regular mail a product registration number. 
You must then enter your name and this registration number into your existing copy of ‘Net Pal using the 
Registration dialog box, which is accessed by selecting the Register option from the ‘Net Pal Help menu. 
You should keep your registration number safe, so that you can re-enter it if you need to re-install 
Windows or if you upgrade to a new computer at any time in the future.

Ordering by check
To order by check print and send the order form and a check to Kookaburra Software. Instructions for 
ordering by check are included on the order form. Payment must be in US dollars drawn on a US bank, 
or you can send international postal money orders in US dollars. Your registration information will be sent 
to you via e-mail or post.

Ordering through Compuserve
To order on the Compuserve online service and have the registration fee added to your CompuServe bill 
use the CompuServe command GO SWREG (click on the traffic light icon or the Go button in WINCIM 
and enter SWREG) and follow the menus.    You can search on the keyword Kookaburra or Net Pal. The 
Compuserve registration ID for ‘Net Pal is 13571.
Your registration information will be electronically mailed to your CompuServe account within a few 
business days.

Ordering by Credit Card
For information on ordering by credit card, click here: Credit Card Ordering Information. 
Your registration information will be sent to you via e-mail or post.



Credit Card Ordering
You can order with MasterCard, Visa, American Express, or Discover through PsL. Note that credit card 
orders are taken through PsL, an independent company which provides a credit card ordering service - 
PsL cannot provide support or any other information about this product. Please contact Kookaburra 
Software for support or general information.

The best ways to reach PsL are:

· FAX to (713) 524-6398
· CompuServe E-Mail to 71355,470
· Internet E-Mail to 71355.470@compuserve.com. 

You can also call PsL between the hours of 8:30 am and 5:00 pm CST Monday-Friday, except holidays, at
the following numbers:

· (800) 242-4PSL      (800-242-4775)
· (713) 524 6394

You can also mail credit card orders to PsL at:

· P.O. Box 35705, Houston, TX 77235 USA.

THE ABOVE NUMBERS ARE FOR CREDIT CARD ORDERS ONLY.
THE AUTHOR OF THIS PROGRAM CANNOT BE REACHED AT THESE NUMBERS.

When you contact PsL they will require the following information:

Product Name: ‘Net Pal
Product ID: 14948
Your Name: ______________________________________

Company: ______________________________________

Your E-Mail Address: ______________________________________

Credit Card [ ] MasterCard      [ ] VISA      [ ] AMEX      [ ] Discover

Credit Card Number: ______________________________________ 

Expiration Date: ______________________________________ 

Name On Card: ______________________________________ 

Billing Address: ______________________________________ 

______________________________________ 

                                                                                                                  
Any questions about the status of the shipment of the order, registration options, product details, technical
support, volume discounts, dealer pricing, site licenses, non-credit card orders, etc, must be directed to 
Kookaburra Software, P.O. Box 23200-394, San Jose, CA 95153 or by internet e-mail to 
sales@kburra.com.

PsL will notify us the day that they receive your order and we will send your registration number to you.



‘Net Pal Order Form
This order form is for ordering by check or money order only.

To print this order form click the Print button above or select the Print Topic option on the File pull-down 
menu.

These prices are guaranteed through September, 1997. An up-to-date version of ‘Net Pal can be obtained
from the Kookaburra Software web-site at www.kburra.com. 

Send this order form to: Kookaburra Software
P.O. Box 23200-394
San Jose,    CA      95153
U.S.A.

Name: _______________________________________________

Company: _______________________________________________

Address: _______________________________________________

City: _______________________________________________

State/Province: _______________________________________________

Zip/Post Code: ____________________      Country: __________________

Phone: (daytime) _______________ (evening)________________

E-Mail Address: _______________________________________________

Order Information

I would like to register _____ copies of ‘Net Pal at $19 each.

Total payment enclosed: $__________

Payment must be in US dollars drawn on a US bank, or you can send international postal money orders 
in US dollars. Make checks payable to Kookaburra Software.

How did you hear about ‘Net Pal? ______________________________________

Comments:



How to enter your registration number

You can enter your registration number (obtained by registering your copy of ‘Net Pal) using the Register 
dialog. The Register dialog can be displayed by selecting the Register option from the Help menu.

Name
Enter your name as it appears on your registration notice from Kookaburra Software. You must enter you 
name exactly as it appears on this notice.

Registration Number
Enter your registration number exactly as it appears on your registration notice from Kookaburra 
Software.

Once you have entered your registration information correctly and selected OK, your copy of ‘Net Pal will 
be registered. You must save your registration information (name and number) as you will need to re-
enter it if you re-install Windows or if you upgrade to a new computer.



Support options
Kookaburra Software currently provides technical support to registered users of ‘Net Pal by e-mail and by 
regular postal mail only. You should always check the Kookaburra Software web-site (www.kburra.com) 
before requesting support to make sure you are using the latest version of ‘Net Pal and to view any 
common support issues which may be on the web-site.

When requesting support please be sure to include the following information:

· Your name and contact information (either e-mail address (preferred) or street address for regular mail).
· What operating system are you using? For example, Windows 95, Windows NT 4.0 etc.
· What version of ‘Net Pal are you using? You can select the About option from the Help menu to find the 

version of ‘Net Pal you are using.
· If your copy of ‘Net Pal is registered, what is your registration number? You can select the About option 

from the Help menu to find this information.
· Nature of the problem?
· Is the problem reproducible?
· If an error message was displayed, please include the full text of the error message.

Requesting support by E-Mail
Please send e-mail to support@kburra.com. Be sure to include the above information

Requesting support by regular mail
Please send mail to the following address:

Kookaburra Software
P.O. Box 23200-394
San Jose,    CA      95153
U.S.A.

Be sure to include the above information.



'Net Pal License Agreement

By installing 'Net Pal from Kookaburra Software on your computer you agree to the following terms and 
conditions:

· This product is distributed as a SHAREWARE computer software program. You may evaluate this 
product for a maximum of thirty (30) days from the time you first install it onto your computer. After this
time you must either remove this product from your computer or register the product with Kookaburra 
Software.

· This product may be installed on a single computer only and used by one person only.

· Kookaburra Software makes NO WARRANTIES regarding this product. You accept this product on an
AS IS basis. Kookaburra Software is not responsible for any damages whatsoever, including loss of 
information, interruption of business, personal injury and/or any damage or consequential damage 
without limitation, incurred before, during or after the use of our products.

· This program is owned by Kookaburra Software and is copyright protected. No program, code, part, 
image, text or sound may be copied or used in any way by the user except as detailed in this license 
agreement.

· You are permitted to make one (1) back-up copy of the registered program for your personal 
protection. 

· The shareware (unregistered) version of this product may be redistributed freely under the following 
conditions:

à The distribution format is not modified in any way from the original supplied by Kookaburra 
Software. Specifically no files may be altered, deleted or added to the distribution file(s).

à The distribution does not include a registration number.    In particular, you may not distribute 
a registered piece of software.

à No money is charged to the person receiving the software, beyond reasonable cost of 
packaging and other overhead.



The File menu displays commands which allow you to Connect to a connection, disconnect from an 
active connection, stop a dialing operation and exit the application.



The View menu displays an Options command which allows you to set global options for ‘Net Pal.



The Connection menu displays commands which allow you to set properties, view status and enable or 
disable auto-dial for the selected connection.



The Help menu displays commands which allow you to view help, register your copy of ‘Net Pal and 
display the About box for ‘Net Pal.



The Connect button will dial and attempt to connect to the selected connection in the connections list 
box.



The Disconnect button will be enabled only when you are currently connected to a remote computer 
through one of your connections. Pressing this button will disconnect from the current connection and 
hang up the phone.



The Stop button will be enabled only when ‘Net Pal is attempting to dial and connect to a connection. 
Pressing this button will stop the dialing operation and return ‘Net Pal to its idle state.



The About button displays a dialog box, showing the version and copyright message for ‘Net Pal. It also 
displays the name and registration number of the person who has registered this copy of ‘Net Pal.



The Connections list box displays all of the dial-up networking connections which are defined on your 
system.



This little lightning bolt icon is displayed next to the connection which has been designated as the auto-
dial connection.



The status bar displays context sensitive information for ‘Net Pal. For example, when you select a menu 
item, a description of the menu item will be displayed in the status bar.



This field displays the name of the dial-up networking connection which you are currently connected to.



This field displays the speed at which your modem is connected to the remote computer. The speed is 
displayed as the number of bits per second (bps).



This field displays the Internet Protocol (IP) address of your machine while it is connected to the internet. 
If your Internet Service provider assigns you a dynamic IP address, then this will be different every time 
you connect to the internet. You can set an option to copy your IP address to the clipboard when you 
connect, if you desire.



The field displays the host name of the computer you are connected to.



This field displays the length of time you have been connected for the current call.



This field displays the cost of the current call. This field is only displayed if you select the Track Usage 
option in the properties for this connection.



This field displays the total time you have spent online for this connection for the current month. This 
field is only displayed if you select the Track Usage option in the properties for this connection.



This field displays the total cost for the current month for the time you have spent online with this 
connection. This field is only displayed if you select the Track Usage option in the properties for this 
connection.



This icon is displayed when you are connected. It displays as a hand if the connection was manually 
dialed, or as a lightning bolt if the connection was dialed automatically.




