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File menu commands

The File menu offers the following commands:

New Clears the current deal.
Open Opens an existing deal.
Save Saves the current deal using the same file name.
Save As Saves the current deal using a specified file name.
Deal Deals a new set of hands.
Print Prints a deal.
Print 
Preview

Displays the deal on the screen as it would appear printed.

Print Setup Selects a printer and printer connection.
Exit Exits Bridge Assistant.

Bridge menu commands

The Bridge menu offers the following commands:

Call Makes a call.
Play Plays a card.
Undo Takes back the last action, use to undo the last call or play.
Clear Trick Clears the cards from the table when the trick is completed.
Auction Makes all the remaining bids in the auction automatically.
Rotate Rotates the hands clockwise.



Edit menu commands

The Edit menu offers the following commands:

Call Allows the auction to be edited; use to undo or clear all 
bids.

Play Allows the play to be edited; use to undo or clear the cards
played.

Layout Displays the layout editor, use to change the layout.
Filter Displays the filter editor, use to change the filter.
Deck Displays the deck, use to create a particular deal.



View menu commands

The View menu offers the following commands:

Palette Shows or hides the bid palette.
Auction Shows or hides the auction.
Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
South Shows or hides the cards in the south hand.
West Shows or hides the cards in the west hand.
North Shows or hides the cards in the north hand.
East Shows or hides the cards in the east hand.
Show All Shows the cards in all the hands.
Arrange Arrange the windows.
Refresh Redraws all the hands.

Options menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

Position Selects the hand you are playing.
Dealer Selects the hand that is the dealer.
Filter On Turns the filter on and off.
Auto Call Turns the auto call function on and off.
Auto Play Turns the auto play function on and off.
Auto Arrange Turns the auto arrange function on and off.
Allow Hints Allows hints during the auction; the program will bid for 

you.
Allow Overrides Allows you to bid for one of the hands controlled by the 

program.
Allow Overcalls Allows overcalls.
Save Settings on 
Exit 

Saves the settings when the program ends.

Config Displays the configuration editor, use to set program 
parameters.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Contents Offers you a list of topics on which you can get help.
How to Use 
Help

Provides general instructions on using help.

Shareware Help Provides information about Shareware and how to register.
Registration Displays the registration information screen again.
About Displays the version number of this copy of Bridge 

Assistant.



New command (File menu)

Use this command to clear the current deal and reset the game.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing deal.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which deal to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:

Drives
Select the drive in which Bridge Assistant stores the deal that you want to open. 

Directories
Select the directory in which Bridge Assistant stores the deal that you want to open.



Save command (File menu)

Use this command to save the current deal using the same file name and directory.    When 
you save a deal for the first time, Bridge Assistant displays the Save As dialog box so you 
can choose a name.    If you want to change the name and directory of an existing deal 
before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and choose a file name for the current deal.    Bridge Assistant 
displays the Save As dialog box so you can name the deal.    

To save a deal with its existing name and directory, use the Save command.



Deal command (File menu)

Use this command to deal a new set of hands. Bridge Assistant shuffles the deck and deals 
the cards. If you want a particular type of hand use the filter.

Shortcuts

Toolbar:
Keys: CTRL+D



File Save As dialog box

The following options allow you to specify the name and location of the deal you're about to 
save:
File Name

Type a new filename to save a deal with a different name.    A filename can contain up to 
eight characters and an extension of up to three characters.    Bridge Assistant adds the 
extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the deal.

Directories
Select the directory in which you want to store the deal.



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
deals you closed.    Choose the number that corresponds with the deal you want to open.



Exit command (File menu)

Use this command to end your Bridge Assistant session.    You can also use the Close 
command on the application Control menu.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Call command (Bridge menu)

Use this command to make the program call on its turn.

Shortcuts

Toolbar:
Keys: F3



Play command (Bridge menu)

Use this command to make the program play on its turn.

Shortcuts

Toolbar:
Keys: F4



Undo command (Bridge menu)

Use this command to make the program take back the last action. This will undo the last call
made or card played by either side.

Shortcuts

Toolbar:
Keys: F5



Clear Trick command (Bridge menu)

Use this command to clear the table after a trick has been completed.



Auction command (Bridge menu)

Use this command to make all the remaining calls in the auction automatically.



Rotate command (Bridge menu)

Use this command to rotate the hands clockwise. This will cause the program to reset in the 
same way as after a file is opened or a new deal is made.



Auction command (Edit menu)

Use this command to edit the auction. The undo command will take back the last bid made. 
The clear command will undo the entire auction.

Undo 

Use to undo the last bid.

shortcuts

Toolbar:
Keys: F5

Clear 

Use to clear the auction.



Play command (Edit menu)

Use this command to edit the play. The undo command will take back the last card played. 
The clear command will clear all the cards.

Undo 

Use to take back the last card played.

shortcuts

Toolbar:
Keys: F5

Clear 

Use to clear all the cards played.



Layout command (Edit menu)

Use this command to modify the layout.    Bridge Assistant displays the Edit Layout dialog 
box so you can make the changes.    

Shortcuts

Toolbar:



Edit Layout dialog box

The following options allow you to specify the layout of the current and subsequent deals.

Layout
Select what aspect of the layout you want to modify. You can either modify the current 
layout or set defaults to be used when various actions are performed, for example: 
opening a file, dealing, or changing which hand you are playing. 

Show
Select which hands should be visible and which hidden. 

Use Default After
Select the actions after which the defaults should be used.



Filter (Edit menu)

Use this command to modify the filter.    Bridge Assistant displays the Edit Filter dialog box so
you can make the changes.    

Shortcuts

Toolbar:



Edit Filter dialog box

The following options allow you to specify the filter to be used when the 'Filter On' option is 
chosen and Bridge Assistant deals.

Partnership
Select the partnership for which you want to edit the filter parameters. 

Hand
Select the hand for which you want to edit the filter parameters. 

Suit
Select the suit for which you want to edit the filter parameters.

High Card Points
For Partnerships, hands and suits you can set the minimum and maximum high card 
points allowed. 

Shape
For hands you can select the range of shapes allowed. The higher the number the more 
unbalanced the hand. Values range from 1 to 39. 

Length
For suits you can select a range for the number of cards allowed.



Deck command (Edit menu)

Use this command to display the deck.    Bridge Assistant displays the Edit Deck dialog box 
so you can make changes.    

Shortcuts

Toolbar:



Edit Deck dialog box

This dialog box can be used at the same time as the main window. You can use it to 
rearrange the cards in each hand. The following options allow you to make these changes:

List
Select cards to move to a hand. 

All Cards
Move all cards to the deck.



Palette command (View menu)

Use this command to display and hide the Palette, which contains buttons for making bids in
Bridge Assistant.    A check mark appears next to the menu item when the Palette is 
displayed.



Auction command (View menu)

Use this command to display and hide the Auction, which shows bids as they are made.    A 
check mark appears next to the menu item when the Auction is displayed.



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in Bridge Assistant, such as File Open.    A check mark appears 
next to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Bridge Assistant,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Deal a new set of hands.    Bridge Assistant shuffles the deck and displays the new 
deal.

Open an existing deal.    Bridge Assistant displays the Open dialog box, in which you 
can locate and open the desired file.

Save the current deal using the same file name.    If you have not named the deal, 
Bridge Assistant displays the Save As dialog box.

Print the current deal using the current printer settings.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



South command (View menu)

Use this command to display and hide the cards in south hand.



West command (View menu)

Use this command to display and hide the cards in west hand.



North command (View menu)

Use this command to display and hide the cards in north hand.



East command (View menu)

Use this command to display and hide the cards in east hand.



Show All command (View menu)

Use this command to display the cards in all the hands.



Arrange (View menu)

Use this command to arrange the windows on the screen. The program will move the auction
box, the bid palette and any other windows to their default positions.



Refresh command (View menu)

Use this command to redraw all the hands.



Status Bar

The status bar is displayed at the bottom of the Bridge Assistant window.    To display or hide 
the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate the following:

Indicator Description
PLAYER The hand you are playing.
FILTER The status of the filter.
DEALER The hand that is the dealer.
COUNT The counter.
MAXIMUM The maximum number of hands generated before stopping.



Player command (Options menu)

Use this command to select the hand you are playing. When you select this option in the 
menu Bridge Assistant displays another menu and you can select the hand you wish to play.



Dealer command (Options menu)

Use this command to select the hand that is the dealer. When you select this option in the 
menu Bridge Assistant displays another menu and you can select the hand that is the dealer.



Filter On command (Options menu)

Use this command to turn the filter on and off.

Shortcuts

Toolbar:



Auto Call (Options menu)

Use this command to turn the auto call function on and off. Auto call means that the 
program will make a call for the hands it controls without waiting for the call command to be
given. Note that this does not apply to the first call in any auction, the program needs the 
call command if it is to make the first call.



Auto Play (Options menu)

Use this command to turn the auto play function on and off. Auto play means that the 
program plays cards for the hands it controls without waiting for the play command. Note 
that this does not apply to the opening lead, the program needs the play command if it is to 
play the first card.



Auto Arrange (Options menu)

Use this command to turn the auto arrange function on and off. When auto arrange is turned
on and the main program window is resized the other program windows are moved to their 
default positions.



Allow Hints (Options menu)

Use this command to allow the computer to bid for you. If you do not like what the program 
suggests you can use the undo command and bid again.



Allow Overrides (Options menu)

Use this command to allow you to be for one of the hands that the computer controls. This 
allows you to setup a particular contract, or to change a bid that you do not think is correct.



Allow Overcalls (Options menu)

Use this command to allow overcalls. By default this should be turned on and the check 
mark next to the menu item will indicate this. It can be turned off if you do not want the 
opponents to take part in the auction.



Save Settings on Exit (Options menu)

Use this command to turn the save settings option on and off. When turned on the current 
program settings will be saved when Bridge Assistant is closed.



Config command (Options menu)

Use this command to display the configuration editor. Bridge Assistant displays the Options   
Config dialog box so you can make changes.



Options Config dialog box

Using this dialog box you can set the    following program parameters.

Maximum Search Count
The maximum number of hands to be generated when the filter is on and you have told 
the program to deal a new set of hands.



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using Bridge Assistant and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



Shareware Help command (Help menu)

Use this command for information about Shareware.



Registration command (Help menu)

Use this command to display the initial screen again.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of Bridge
Assistant.



Context Help command 

Use the Context Help command to obtain help on some portion of Bridge Assistant.    When 
you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow 
and question mark.    Then click somewhere in the Bridge Assistant window, such as another 
Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of the main window.    It contains the name of the 
program and the current open file.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar contains the following elements:
Application Control-menu button
Maximize button
Minimize button
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the 

pointer to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Bridge Assistant window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the application or the active dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Table

The table is displayed in the middle of the application window.    The table provides buttons 
for quick mouse access to some actions performed by Bridge Assistant on hands. For more 
information on what the buttons do see: Table button.



Table button

You use buttons in two ways:

Showing and hiding a hand
To show and hide the hand. This only works if the deal is valid.

Moving cards to a hand
To move the cards selected in the deck to a hand. This action only works if the deck is 
visible.



Deck object

You can display the Deck by using the Deck command in the View menu. Bridge Assistant 
displays the Edit Deck dialog box. This takes the place of the ordinary deck of cards; you can
move cards to the Deck and then from the Deck to the required hand.

You can move cards to a particular hand by selecting the cards in the Deck and then clicking 
one of the buttons on the Table. To move cards from a hand to the Deck simply click on the 
particular card that you want to move.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



Print command (File menu)

Use this command to print a deal.      This command presents a Print dialog box, where you 
may specify the destination printer, the number of copies, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print command (Toolbar)

Use this command to print a deal.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the deal should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that Bridge Assistant is sending output to 
the printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the current deal as it would appear when printed.    When you 
choose this command, the main window will be replaced with a print preview window in 
which the page will be displayed in its printed format.    The print preview toolbar offers you 
options to zoom in and out of the page and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the printer should use.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.



Page Setup command (File menu)

<< Write application-specific help here. >>




