Herramientas de Windows Media

Esta documentación proporciona información acerca de las herramientas que puede utilizar para crear y administrar contenido ASF para los servicios de Windows Media. La mayoría de estas herramientas tienen también Ayuda en pantalla adicional.

La información acerca del Reproductor de Windows Media y de los algoritmos de compresión y descompresión (códecs) que utilizan las Tecnologías de Windows Media se proporciona como información de apoyo para ayudarle a determinar el mejor método para crear el contenido.

Esta documentación también se incluye en formato .doc en el directorio UnidadDelSistema\Archivos de programa\Windows Media Components\Docs\print y se puede consultar con Microsoft WordPad o Microsoft Word.

Temas relacionados

  • Herramientas de creación de contenido
  • Herramientas de administración de contenido
  • reproductor de Windows Media
  • Códecs de Window Media

© 1996-1999 Microsoft Corporation. Reservados todos los derechos.


Herramientas de creación de contenido

La siguiente lista describe las Herramientas de Windows Media que puede utilizar para crear contenido en formato ASF:

  • Codificador de Windows Media. Devuelve contenido (como entrada en directo desde un micrófono o una cámara de vídeo o archivos multimedia almacenados) en una secuencia ASF o un archivo. El Codificador de Windows Media convierte y comprime contenido de audio, contenido de vídeo y secuencias de comandos en contenido ASF, mediante las técnicas de compresión más recientes.
  • Complemento de Windows Media para Adobe Premiere. Proporciona una compresión y una conversión fáciles de los archivos de vídeo al formato ASF desde Adobe Premiere. Para obtener más información, consulte la Ayuda de Adobe Premiere.
  • Autor de Windows Media. Proporciona una interfaz gráfica para combinar y sincronizar archivos de imagen y audio. Autor de Windows Media puede mostrar una simulación del archivo .asf antes de crearlo. Admite diferentes anchos de banda de destino y secuencias de comandos
  • Presentador de Windows Media para Microsoft PowerPoint 97. Un complemento para utilizar con PowerPoint que, junto con el Codificador de Windows Media, le ayuda a devolver una presentación de PowerPoint en una secuencia ASF.
  • Publicar Windows Media a ASF para Microsoft PowerPoint 97. Un complemento que devuelve su presentación de PowerPoint con narraciones en un archivo .asf.
  • VidToASF. Una herramienta de la línea de comandos que convierte archivos .avi or .mov en archivos .asf. Utilice la opción de la línea de comandos para especificar archivos de comandos que agreguen marcadores, llamen a direcciones URL y ejecuten secuencias de comandos.
  • WavToASF. Una herramienta de la línea de comandos que convierte archivos .wav o .mp3 en archivos .asf. Utilice la opción de la línea de comandos para especificar archivos de comandos que agreguen marcadores, llamen a direcciones URL y ejecuten secuencias de comandos.


Herramientas de administración de contenido

Junto con las herramientas y programas para la creación de contenido, estas herramientas le ayudarán a administrar los archivos .asf una vez creados:

  • Indizador ASF de Windows Media. Una herramienta gráfica para modificar archivos .asf. Utilice el Indizador de formato ASF de Windows Media para agregar índices, propiedades, marcadores y secuencias de comandos a un archivo .asf existente y para recortar las partes del principio y del final del archivo .asf .
  • ASFChop. Una herramienta de la línea de comandos para modificar archivos .asf. Use ASFChop para agregar marcadores, secuencias de comandos y propiedades a un archivo .asf, o para borrar períodos de tiempo de un archivo .asf.
  • ASFCheck. Una herramienta de la línea e comandos para verificar formatos de archivo .asf. ASFCheck puede identificar problemas en un archivo .asf y efectuar reparaciones cuando sea posible.


Requisitos hardware y software para utilizar las Herramientas de Windows Media

Las siguientes Herramientas de Windows Media dependen de otro hardware y software para funcionar correctamente. Asegúrese de que cumple estos requisitos antes de intentar usar la herramienta.

Codificador de Windows Media

Para codificar contenido en directo, el equipo en el que instale el Codificador de Windows Media debe contener:

  • Una tarjeta de sonido para codificar audio
  • Una tarjeta de captura de vídeo para codificar el vídeo (opcional)

Para codificar un archivo .avi, .wav o .mp3 en un archivo .asf, no es necesaria ninguna de estas tarjetas.

Las clavijas de entrada de las tarjetas de audio y vídeo reciben los datos y, a continuación, los transmiten al Codificador de Windows Media. Por ejemplo, para realizar una multidifusión de una voz en directo, debe conectar la salida de una cámara de vídeo en la clavija de entrada de la tarjeta de vídeo, y conectar la salida del micrófono a la clavija de entrada de audio de la tarjeta de vídeo o a la clavija de entrada de la tarjeta de sonido (en función de la tarjeta que vaya a usar el codificador). El codificador reconoce estas fuentes de entrada, recibe la entrada y codifica el audio y el vídeo en una secuencia ASF que, después, se entrega a un servidor Windows Media.

Si piensa utilizar vídeo de velocidad de bits múltiple para codificar contenido en directoen anchos de banda múltiples, el procesador de su equipo debe tener los siguientes requisitos mínimos:

  • Procesador dual Intel Pentium II a 266 MHz
  • Procesador Intel Pentium II a 400 MHz

Para obtener los mejores resultados al codificar contenido en directo en múltiples anchos de banda, se recomiendan los siguientes procesadores:

  • Procesador Intel Pentium III a 450 MHz
  • Procesador dual Intel Pentium II a 400 MHz

Indizador de formato ASF de Windows Media

Si tiene pensado usar el Indizador de formato ASF de Windows Media para agregar índices, marcadores, secuencias de comandos y propiedades a archivos .asf existentes, debe instalar el Reproductor de Windows Media de Microsoft. El Reproductor de Windows Media es también necesario para procesar contenido ASF.

Temas relacionados

  • Codificador de Windows Media
  • Vídeo de velocidad de bits múltiple
  • Indizador ASF de Windows Media
  • reproductor de Windows Media


Conceptos

Microsoft Windows NT Server utiliza los Servicios de Windows Media para transmitir contenido de audio y vídeo ASF sobre una red informática. El contenido ASF puede ser una secuencia de contenido en directo o un archivo .ASF almacenado.

Para crear contenido en formato ASF se utilizan las Herramientas de Windows Media y las herramientas de terceros disponibles. Puede crear un archivo .asf desde medios almacenados, como sonido, imagen y archivos de vídeo, o desde secuencias en directo.

En esta sección se estudian los conceptos subyacentes en la creación de contenido ASF. No se trata el proceso preliminar de preparación y modificación de los archivos multimedia.


Secuencias ASF

El Codificador de Windows Media toma información de origen de cada secuencia en directo o almacenada y la devuelve en contenido ASF que puede transmitirse por un servidor de Windows Media. El origen de la información en directo puede ser cualquier señal para la que exista una conexión de entrada en la tarjeta de sonido o de vídeo, como un reproductor de CD, micrófono, vídeo o cámara de vídeo. La información almacenada puede ser archivos de película, de imagen o de audio. Una vez convertida a formato ASF, puede entregarla a un servidor de Windows Media para que la trasmita. Una secuencia ASF también se puede guardar como archivo .ASF.


Archivos .ASF

Un archivo .asf es un archivo de transmisión multimedia que se escala para encajar en un ancho de banda.disponible de red.

Puede crear archivos .ASF a partir de diversos orígenes, incluidos:

  • Vídeo. Un archivo .MOV o .AVI.
  • Imágenes. Cualquier imagen con formato .bmp, .dib, .rle, .jpg o .gif.
  • Audio. Cualquier archivo .wav o .mp3 que utilice cualquier códec ACM ; es ecir, cualquier archivo de audio puede sejecutarse en su equipo (los sistemas operativos Microsoft Windows contienen varios códecs ACM).
  • Presentaciones de Microsoft PowerPoint. Dependiendo de la versión de PowerPoint que esté utilizando, puede guardar su presentación de PowerPoint como un archivo .asf o guardar sus diapositivas de PowerPoint como imágenes .jpg y, después, utilizar el Autor de Windows Media para incorporar estas imágenes en un archivo .asf.
  • Audio y vídeo en directo. Con el Codificador de Windows Media, puede convertir cualquier evento en directo que pueda capturar con un micrófono o una cámara de vídeo en un archivo .asf.


Transmitir contenido ASF

Se diseñó el contenido ASF para ser transmitido desde un servidor de Windows Media a un Reproductor de Windows Media cliente. El servidor Windows Media y el Reproductor de Windows Media cliente pueden utilizarse tanto en internet como en una intranet, y pueden separarse por servidores de seguridad. Como creador del contenido, lo primero que debe hacer es informarse de la cantidad de ancho de banda disponible en la red para entregar contenido.

Ancho de banda y velocidad de bits son, esencialmente, lo mismo en términos de transmisión de contenido ASF. A menudo se utiliza el ancho de banda para describir el tamaño de una red y la velocidad de bits para describir la velocidad a la que se entrega el contenido ASF. El contenido creado para su transmisión a través de una red con un ancho de banda de 28,8 kilobits por segundo (Kbps) no se puede transmitir a más de 28,8 Kbps. Esto significa que a través de la red no puede haber viajado más de 28,800 bits de información por segundo. Un usuario no puede recibir contenido transmitido a un ancho de banda superior al que acepta la conexión de la red.

Las intranets pueden controlar contenido que se transmite mediante secuencias a una velocidad de bits mucho más alta que en Internet. En el entorno de intranet, el administrador de la red o el ancho de banda de la red exigirán restricciones al ancho de banda disponible para transmitir contenido. El administrador de la red puede configurar el servidor de Windows Media para restringir la cantidad de información que transmite. Esta restricción evita que el servidor, durante los períodos de alta utilización, transmita tanta información que ralentice el flujo general de información en la red. Si el administrador de la red no establece un límite en la cantidad de información que un servidor de Windows Media puede transmitir, el ancho de banda de la red es el factor de limitación para la entrega de contenido.


Consideraciones acerca del ancho de banda

Antes de crear contenido ASF, compruebe el ancho de banda máximo que admite el servidor.

Una vez que sepa cuál es el ancho de banda máximo del contenido ASF que puede crear, puede comenzar. Aparte del Codificador de Windows Media y del Autor de Windows Media, las herramientas que utiliza para crear archivos .asf no le obligan a escalar los archivos de origen para que se ajusten a determinado ancho de banda. Las herramientas de la línea de comandos de las Herramientas de Windows Media convierten archivos fuente directamente a ASF. El contenido ASF creado a partir de otro tipo de archivo conserva los requisitos de ancho de banda originales.

Para averiguar rápidamente el ancho de banda necesario para el contenido, puede reproducirlo con el Reproductor de Windows Media. Mientras se reproduce el archivo, en el menú Ver, haga clic en Estadísticas. En el cuadro de diálogo situado bajo Red hay una entrada con la etiqueta Ancho de banda. El valor mostrado le indica los kilobits por segundo (Kbps) requeridos para transmitir el contenido. Existen muchas formas de reducir la cantidad de ancho de banda requerido por un archivo .asf, incfluyendo la edición de archivos fuente o mediante códecs para comprimir los archivos fuente.

Si crea el contenido con una herramienta que supervise el ancho de banda utilizado, ésta reservará automáticamente parte del ancho de banda para otros tipos de tráfico de la red. Por ejemplo, si establece el ancho de banda en 28,8 Kbps, en realidad utilizará aproximadamente 22 Kbps del ancho de banda. Si utiliza una herramienta que le obliga a efectuar el seguimiento de la velocidad de bits del contenido, deberá basarse en la velocidad de bits real que se necesita para entregar el contenido al supervisar la cantidad de información.


Colocar archivos .asf en un servidor de Windows Media

Para transmitir archivos .asf una vez creados, debe colocarlos en un servidor de Windows Media o en un servidor HTTP. Se recomienda que los coloque en un servidor Windows Media porque sólo hay recibirá toda la funcionalidad ASF Aunque un servidor HTTP puede transmitir archivos .asf, no puede duplicar toda la funcionalidad de un servidor de Windows Media.

Para crear vínculos entre páginas Web y archivos .ASF, se recomienda colocar los archivos en el directorio de contenido del Reproductor de Windows Media. Por ejemplo, unidadDelSistema\ASFRoot es el directorio de contenido predeterminado para el servidor de Windows Media. El servidor de Windows Media busca en su directorio de contenido el archivo .asf que va a transmitir cuando reciba una petición. Para determinar qué directorio del servidor de Windows Media actúa como directorio de contenido, abra el Administrador de Windows Media y haga clic en Puntos de publicación de unidifusión; la ruta de acceso al directorio de contenido aparece junto al punto de publicación <Principal>. Para obtener más información acerca del uso del Administrador de Windows Media, puntos de publicación y la colocación de archivos .asf para transmisión, consulte la documentación de Windows Media instalada con los Servicios de Windows Media.


Colocar archivos en un servidor Web

Si tiene un servidor Web que quiere utilizar para transmitir contenido ASF, puede colocar los archivos .asf en un directorio Web, vincularlos desde su página Web y después usar HTTP para transmitir el contenido a sus usrios. En este escenario, el servidor Web administra la transmisión y no se requiere la instalación de los Servicios de Windows Media o Windows NT. Cuando transmita archivos .asf desde un servidor Web, tenga presente las limitaciones siguientes:

  • Los servidores Web no pueden utilizar vídeo de velocidad de bits múltiple y transmisión inteligente para negociar el ancho de banda disponible para el usuario.
  • El contenido debe codificarse mediante configuración de vídeo de transmisión simple, como los formatos de secuencia de plantilla de servidor Web o una configuración personalizada.
  • El contenido transmitido mediante HTTP no tiene la misma capacidad para corregir errores de transmisión. Si utiliza este método, la misma secuencia tendrá menos calidad que si su la transmite mediante los Servicios de Windows Media.
  • El usuario puede descargar directamente el contenido publicado por un directorio Web en vez de transmitirse.

Temas relacionados

  • Colocar archivos .asf en un servidor Windows Media
  • Vídeo de velocidad de bits múltiple
  • Configuración personalizada
  • Acerca de los formatos de secuencia de plantilla


Vídeo de velocidad de bits múltiple

Si crea contenido para difusión en directo o distribución a petición, puede utilizar vídeo de velocidad de bits múltiple para hacer accesible su contenido para los usuarios que tengan conexiones que incluya desde módems de acceso telefónico de 28.8 Kbps a LAN de ancho de banda alto. Al codificar contenido con vídeo de velocidad de bits múltiple se crean secuencias de vídeo múltiple junto con secuencias de audio y secuencias de comandos (si está seleccionado). Las secuencias de vídeo se codifican para diferentes anchos de banda de destino. Por ejemplo, si elije usar vídeo de velocidad de bits múltiple conm un ancho de banda de destino simple de 56 Kbps, se crearán dos secuencias de vídeo que utilizan mayor y menor cantidad de ancho de banda, pero no creará una secuencia de vídeo que sea lo suficientemente baja como para crear contenido accesible a los usuarios con una conexión de red de 28.8 Kbps. Si desea proporcionar el contenido a los usuarios con conexiones de 28,8 Kbps, elija una plantilla que incluya ambas redes o especifique ambas audiencias cuando cree una configuración personalizada.

Cuando cree una configuración de cliente con vídeo de velocidad de bits múltiple, seleccione primero si es compatible con audiencias con conexiones de red de ancho de banda bajo (18 Kbps a 300 Kbps) o alto (81 Kbps a 10 Mbps). En cada categoría, Ancho de banda bajo y Ancho de banda alto, puede seleccionar hasta cinco audiencias para su contenido. Cada audiencia es compatible con un intervalo distinto de anchos de banda de red. También puede especificar la misma audiencia varias veces en la categoría y, después, especificar cantidades mayores o menores de ancho de banda para cada una. La tabla siguiente detalla los intervalos de ancho de banda disponibles y la categoría pretedeterminada para cada audiencia.

Audiencia | Categoría predeterminada | Intervalo de ancho de banda
Módem a 28,8. | Ancho de banda bajo | 18 -27 Kbps
Módem de acceso telefónico a 56 | Ancho de banda bajo | 28 -37 Kbps
ISDN de canal individual | Ancho de banda bajo | 38 -55 Kbps
ISDN dual | Ancho de banda alto | 56 -120 Kbps
Intranet | Ancho de banda alto | 121 -250 Kbps
Internet de alta velocidad. | Ancho de banda alto | 251 -500 Kbps
LAN | Ancho de banda alto | 501 - 700 Kbps
LAN de alta velocidad | Ancho de banda alto | 701 Kbps - 10 Mbps

Si se utiliza el vídeo de velocidad de bits múltiple, el Reproductor de Windows Media podrá continuar con la presentación del contenido aunque se reduzca el ancho de banda de la red. Si el servidor detecta una reducción de la cantidad de ancho de banda de red disponible durante la transmisión, se envía al reproductor la secuencia de vídeo de ancho de banda más bajo. El usuario notará un descenso en la calidad de la transmisión mientras se utilice un ancho de banda menor, pero la transmisión no se interrumpirá ni hará falta utilizar el búfer para recuperar la pérdida de ancho de banda.

Cuando codifique una secuencia de velocidad de bits múltiple, asegúrese de que hay suficiente ancho de banda disponible para transferir la secuencia ASF completa entre equipo que codifica y el servidor de Windows Media. Como se están codificando datos adicionales y deben enviarse todas las secuencias de vídeo codificadas al servidor, las secuencias de velocidad de bits múltiple tienen un requisito de ancho de banda agregado más alto para la distribución de secuencias en directo desde un codificador a un servidor de Windows Media. El servidor de Windows Media determina la secuencia apropiada para enviar a cada cliente individual.

La tabla siguiente muestra los requisitos agregados para los formatos de secuencia de plantilla de velocidad de bits múltiple. La columna de anchos de banda de destino representa los anchos de banda en los que el equipo del cliente puede conectar al servidor y recibir el contenido. El ancho de banda agregado es la cantidad de ancho de banda necesaria para distribuir la secuencia desde el codificador al servidor. El número que se proporciona es aproximado, este número varía significantemente dependiendo de su contenido.

Plantilla | Anchos de banda de destino (Kbps) | Ancho de banda de audio (Kbps) | Ancho de banda agregado (Kbps)
Módems de acceso telefónico - Vídeo de velocidad de bits múltiple RDSI. | 57, 37, 34, 29, 22, 17 | 8 | 204
Intranet – Vídeo de velocidad de bits múltiple de LAN de alta velocidad. | 700, 500, 300, 150, 120 | 10 | 1780
Vídeo de velocidad de bits múltiple a 28,8, 56 y 100 | 100, 35, 22, 17 | 8 | 174
Voz de vídeo de 28.8 | 22, 17 | 5 | 34
Énfasis de audio de vídeo de 28.8 | 22, 17 | 8 | 30
Vídeo de módem de acceso telefónico a 56 | 37, 22, 17 | 10 | 52

El ancho de banda más bajo es un ancho de banda “de seguridad” automático que se crea cuando se habilita el codificado de velocidad de bits múltiple. El ancho de banda de seguridad se crea cada vez que utiliza el codificado de velocidad de bits múltiple, incluso cuando se crea una configuración personalizada

Si utiliza una configuración de codificación personalizada puede estimar el requerimiento de ancho de banda agregado agregando los valores siguientes:

  • Anchos de banda especificados por audiencia seleccionada
  • Ancho de banda de audio seleccionado
  • Ancho de banda de seguridad

Calcule su ancho de banda de seguridad como un porcentaje del ancho de banda de la audiencia más bajo que ha seleccionado. La tabla siguiente proporciona los porcentajes utilizados para cada audiencia.

Audiencia | Porcentaje
Módem a 28,8. | 80%
Módem de acceso telefónico a 56 | 70%
ISDN de canal individual | 66%
Todas la audiencias de ancho de banda alto | 66%

Finalmente, tenga en cuenta que sólo se codifica una secuencia de audio individual para todos los anchos de banda de vídeo seleccionados. Por tanto, debe restar la cantidad de ancho de banda requerida para la secuencia de audio de cada audiencia seleccionada antes de realizar la suma.


Mejorar el contenido ASF

Cuando cree y albergue contenido ASF, puede elegir agregar características y funciones a su contenido. Éstas son algunas de las opciones disponibles:

  • Indización y marcadores. Permite realizar búsquedas en el contenido y proporciona funciones de avance rápido, rebobinado y búsqueda en archivos .asf transmitidos mediante unidifusión desde un servidor de Windows Media.
  • Secuencias de comandos. Mediante vínculos Web y temas relacionados con el contenido, hace que la experiencia del usuario sea más interactiva.
  • Listas de reproducción. Muestra varios elementos de contenido ASF en un orden determinado. Normalmente se utiliza para incluir publicidad en el contenido.


Marcadores

Un marcador es un puntero a un tiempo específico de un archivo .asf. El Reproductor de Windows Media utiliza los marcadores para buscar directamente un punto de un archivo .ASF. Los marcadores permiten desplazarse a través de un archivo .asf a quienes lo reproducen. Un usuario puede avanzar o retroceder a un marcador anterior para volver a ver una parte del archivo .asf. Los marcadores sólo se utilizan con archivos .asf almacenados. Puede utilizar el Indizador de formato ASF de Windows Media para colocar marcadores en un archivo .asf o puede utilizar un archivo de comandos con el programa de línea de comandos ASFChop.

Para crear un marcador con un archivo de comandos, especifique la hora en que desea establecer el marcador y proporcione un nombre al marcador. Puede dar el nombre que desee a los marcadores. Un archivo de comandos de marcador tiene esta apariencia:

; Ejemplo de marcador script.txt
start_marker_table
8 Marker 1
01:00:00 Marker 2
01:15:00 Marker 3
3:00:03 Marker 4
end_marker_table

Temas relacionados

  • Indizador ASF de Windows Media
  • ASFChop


Secuencias de comandos

Las secuencias de comandos indican al Reproductor de Windows Media que realice tareas adicionales, denominadas secuencias de comandos, mientras reproduce la secuencia ASF. Se pueden utilizar secuencias de comandos con secuencias ASF en directo y con archivos .asf almacenados. Es posible agregar secuencias de comandos a secuencias en directo mediante el Codificador de Windows Media y a archivos guardados mediante el Indizador de formato ASF de Windows Media o el programa de línea de comandos ASFChop.

Además, mediante un archivo de comandos que ejecute los programas de línea de comandos incluidos con las Herramientas de Windows Media, es posible anexar secuencias de comandos a un archivo ya existente. Los archivos de comandos se pueden crear con un editor de textos. Inserte secuencias de comandos en un archivo .ASF mediante la opción -script y el archivo de texto.

Temas relacionados

  • Indizador ASF de Windows Media
  • ASFChop
  • Codificador de Windows Media


Tabla de secuencias de comandos

El Reproductor de Windows Media admite los siguientes tipos de secuencias de comandos.

Tipo de secuencia de comandos | Función
Dirección URL | El reproductor envía la dirección URL especificada al explorador para mostrarla al usuario. Si utiliza un control incrustado del reproductor, puede agregar una referencia a un marco específico a la dirección URL con la sintaxis &&nombreDeMarco.
FILENAME | Dirección URL de otro archivo multimedia que se reproducirá.
TEXT | Cadena de texto que se muestra en la zona de títulos del reproductor multimedia. Este tipo acepta el formato HTML estándar, de forma que puede dar el formato que desee al texto. Un ejemplo de uso son los subtítulos.
EVENT | Nombre de un evento que se va a producir. El tipo EVENT acepta que lo personalice para su propio uso. El código para el suceso especificado debe definirse en el archivo .asx para la secuencia con el fin de que el reproductor realice el suceso especificado. Un ejemplo de uso es la inserción de un anuncio.
OPENEVENT | Esta secuencia de comandos precede al EVENT real. OPENEVENT permite a los reproductores guardar previamente en el búfer el contenido de forma que, cuando se produce el evento, el cambio de secuencias aparece casi sin interrupción.


Archivos de comandos

Al crear los archivos de comandos se aplican las siguientes reglas:

  • Las líneas que comienzan con puntos y comas se tratan como comentarios.
  • Las líneas en blanco y espacios adicionales en blanco se pasan por alto, generalmente.
  • Especifique la hora de los marcadores y las direcciones URL con el formato hh:mm:ss.t, donde h son las horas, m los minutos, s los segundos y t las décimas de segundo.
  • Especifique las horas en términos de la escala de tiempos del archivo de origen.

El Generador de secuencias ASF le ayudará a crear archivos de comandos. Si desea obtener más información, consulte Programa Generador de secuencias ASF en la sección Ejemplos de soluciones de las Tecnologías de Windows Media del Kit de desarrollo de software (SDK) de las Tecnologías de Windows Media. Descargue el SDK de las Tecnologías de Windows Media desde la página Tecnologías de Windows Media en el sitio Web de Microsoft.


Ejemplos de secuencias de comandos

En los ejemplos siguientes se muestran posibles usos de las secuencias de comandos:

  • Volteo de direcciones URL
  • Títulos

Voltear direcciones URL funciona bien por sí mismo, pero otras secuencias de comandos requieren asistencia del cliente. El título del segundo ejemplo requiere alguna asistencia del cliente. Si desea obtener más información acerca de cómo proporcionar ayuda a los clientes acerca de las secuencias de comandos, consulte el evento ScriptCommand en el Kit de desarrollo de software de Microsoft Windows Media en el sitio Web de Microsoft.

; Así es como puede colocar información de contenido en su archivo
; .asf al utilizar VidToASF o WavToASF.
Title: Éste es el título
Author: ASF Maker
Copyright: 1998
Description: texto que describe el archivo .asf
Rating: PG

; Demostración de cómo voltear y poner títulos a direcciones URL
start_script_table
1.0 URL http://Windows Media/images/austr1.html&&Display
5.0 Caption  Sydney Opera House
12.0 URL http://Windows Media/images/austr2.html&&Display
15.0 Caption  Una bonita playa al norte de Sydney
32.0 URL http://Windows Media/images/austr3.html&&Display
35.0 Caption  La selva de Australia
end_script_table

Nota

  • En el ejemplo anterior, se utiliza && para indicar el marco de la página Web en que se supone que aparecerá la dirección URL. Para que esto funcione correctamente, el explorador debe ser capaz de tener acceso a la dirección URL. Si incluye una dirección URL que no existe, el explorador devuelve un mensaje de error.


Listas de reproducción

Las listas de reproducción son punteros a archivos .asf o secuencias ASF. Se hace referencia a cada archivo o secuencia mediante una dirección URL; por ejemplo, mms://servidor/ejemplo.asf o mms://servidor/alias. En los servicios de Windows Media hay dos tipos de listas de reproducción: de cliente y de servidor.

Listas de reproducción de cliente

Las listas de reproducción del cliente son listas de archivos y secuencias de un archivo .asx. Las listas de reproducción se crean con un editor de textos y la sintaxis del lenguaje de marcado extensible (XML) para crear una lista de referencias a archivos .asf en un archivo .asx.

En ocasiones, es posible que desee crear listas de reproducción basadas en las peticiones de los usuarios o en datos demográficos. Puede utilizar páginas Active Server para crear dinámicamente archivos .asx personalizados según los requisitos de un usuario. Además, mediante las características Membership Server y Ad Server de Microsoft Site Server versión 3.0, puede crear páginas Web que generen dinámicamente listas de reproducción de direcciones URL de secuencias en directo, mezcladas con archivos .asf comerciales personalizados según los gustos personales de los usuarios.

Listas de reproducción de servidor

Las listas de reproducción de servidor son listas de archivos .asf y secuencias en un programa de Windows Media. Utilice listas de reproducción de servidor para establecer las duraciones y los bucles de las secuencias. Las listas de reproducción de servidor se pueden generar dinámicamente mediante páginas Web. Para obtener más información acerca de las listas de reproducción de servidor, consulte Utilizar programas y secuencias en la documentación instalada con los Servicios de Windows Media.


Archivos de sonido de Windows Media

Los archivos de audio de Windows Media (.wma) constituyen una forma especializada de los archivos de Formato avanzado de secuencias (.asf). Estos archivos contienen datos de audio, comprimidos mediante un nuevo esquema de compresión de alta calidad con pérdida (códec) llamado Audio de Windows Media. Los archivos de audio de Windows Media están pensados para ser utilizados únicamente con contenido en formato de audio de alta calidad.

Es posible distribuir un archivo .wma con los Servicios de Windows Media. Cuando un usuario solicita un archivo .wma, los Servicios de Windows Media crean automáticamente un tipo especial de archivo de anuncio (.wax) que indica al reproductor dónde está el contenido.

Es posible registrar las extensiones .wma y .wax para el reproductor predeterminado elegido por el usuario. Así, si utiliza las Herramientas de Windows Media para crear los archivos .asf de sonido, al cambiar su extensión por .wma podrá reproducirlos en otros programas.

Actualmente, el Reproductor de Windows Media es el único reproductor que tiene las claves de descodificación del códec de audio de Windows Media. Si desea obtener más información acerca de la distribución de claves de descodificación, consulte el Kit de desarrollo de software de audio de Windows Media.

Nota

  • Se puede codificar un archivo .wma con el Empaquetador de Windows Media.


Codificador de Windows Media

El Codificador de Windows Media codifica audio o vídeo, directo o almacenado, en una secuencia ASF, un archivo .asf, o ambos. El Codificador de Windows Media es la herramienta que necesita si:

  • Utiliza un origen en directo.
  • Necesita comprimir el origen del vídeo (directo o almacenado), de forma que la secuencia ASF o el archivo .asf resultante se ajuste al ancho de banda de destino.
  • Desea crear contenido que se pueda distribuir mediante diferentes anchos de banda.
  • Desea convertir el contenido de un archivo .avi, .mp3 o .wav y utilizar un códec diferente o seleccionar el tamaño de la imagen de vídeo.

Nota

  • Esta documentación pretende proporcionar una introducción a los conceptos que forman parte de la creación de contenido ASF con el Codificador multimedia de Windows. Si desea obtener Ayuda acerca de los procedimientos para utilizar el Codificador multimedia de Windows, abra el Codificador multimedia de Windows y haga clic en Ayuda y Contenido para ver la Ayuda en pantalla.


Utilizar el Codificador de Windows Media

Debe configurar el Codificador de Windows Media para poder utilizarlo. Son tres los asistentes que se pueden usar para configurar el Codificador de Windows Media:

  • Tutorial. Se utiliza un formato de plantilla de secuencia(TSF) para configurar la secuencia ASF. El tutorial da por supuesto que la codificación se realiza a partir de un origen en directo y que el contenido se entrega a un servidor de Windows Media.
  • Plantilla con opciones de E/S. Este método utiliza los TSF para escribir las opciones de códec y de ancho de banda, pero el usuario selecciona los dispositivos de entrada y las ubicaciones de salida.
  • Personalizado. El usuario controla todas las opciones del codificador.

El Codificador de Windows Media no proporciona secuencias ASF a los clientes (excepto para pruebas). Entrega la secuencia ASF a un servidor de Windows Media que, a continuación, puede realizar una multidifusión o unidifusión de las secuencias ASF a través de la red. Si el Codificador de Windows Media crea un archivo .asf, el archivo se guarda en la carpeta especificada en la configuración. Para probar un archivo .asf creado por el Codificador de Windows Media, use el Reproductor de Windows Media de Microsoft para abrirlo.


Configuración mediante el Tutorial

Si no sabe con seguridad qué códecs usar para configurar el Codificador de Windows Media para codificar el contenido en directo para que lo transmita el servidor de Windows Media, use el Tutorial y seleccione uno de los formatos de plantilla de secuencias (TSFs) para establecer los códecs.

Nota

  • El Tutorial utiliza los dispositivos predeterminados de entrada del sistema para capturar el contenido en directo de audio y vídeo. Para saber cuál es el dispositivo de captura predeterminado, mire los dispositivos multimedia en el Panel de control. Para seleccionar un dispositivo de entrada distinto del predeterminado, configure el Codificador de Windows Media con el método Plantilla con opciones E/S.

Temas relacionados

  • Acerca de los formatos de secuencia de plantilla


Configuración mediante Plantilla con opciones de E/S

Cuando seleccione Plantilla con opciones de E/S, elija primero un formato de secuencia de plantilla (TSF),lo mismo que hace para el Tutorial. Sin embargo, una vez seleccionado el TSF, se avanza a través de las pantallas de configuración y se especifican las entradas de audio y vídeo, el puerto IP o un servidor de Windows Media que reciba la secuencia ASF y si se desea o no que el codificador genere la secuencia ASF en un archivo .asf. Las pantallas que aparecerán cambian según el TSF seleccionado. Cuando haya acabado de crear la configuración, puede guardar toda la configuración como un archivo .asd.


Acerca de los formatos de plantilla de secuencias

Los formatos de plantilla de secuencias(TSFs) están preconfigurados para el Codificador de Windows Media. El TSF identifica la configuración de las secuencias ASF estándar para los servicios de componente de Windows Media y el Reproductor de Windows Media. El TSF contiene información acerca de los parámetros siguientes:

  • Ancho de banda de la red de destino. Este valor identifica el ancho de banda mínimo de la conexión a la red del usuario. El usuario no podrá recibir la secuencia si su conexión a la red no admite el ancho de banda de destino. El ancho de banda de los TSF de Windows Media oscila entre 28,8 kilobits por segundo (Kbps) y 3 megabits por segundo (Mbps). Si sus usuarios utilizan una gran variedad de anchos de banda, considere la posibilidad de emplear una plantilla de vídeo de velocidad de bits múltiple para crear una secuencia que admita múltiples anchos de banda.
  • Tipo de contenido. El tipo de contenido que piense transmitir riene un gran impacto en los códecs de audio y vídeo utilizados y la configuración de vídeo que proporciona el rendimiento opcional. Existe una gran variedad de TSF de Windows Media para secuencias de sólo audio, así como plantillas para secuencias multimedia.
  • Vídeo de velocidad de bits múltiple. Las plantillas de vídeo de velocidad de bits múltiple codifican múltiples bandas de vídeo en una sola secuencia o archivo ASF para que el contenido se pueda transmitir en entornos de ancho de banda de red variable. Esto proporciona la mejor experiencia para los clientes que utilizan mayores anchos de banda, manteniendo al mismo tiempo la compatibilidad con las conexiones de red de menor ancho de banda. También es aconsejable utilizarlo en los momentos en que el ancho de banda de red disponible está restringido y la secuencia debe adaptarse a diferentes condiciones. Para codificar vídeos de velocidad de bits múltiple en anchos de banda de Internet se requiere como mínimo un procesador Pentium II a 266 MHz. Para codificar vídeos de velocidad de bits múltiple en anchos de banda mayores se requiere un procesador Pentium II 400 MHz dual.
  • Vídeo de servidor Web. Las plantilla de vídeo de servidor Web se diseñaron para contenido ASF que está destinado para transmitirse desde un servidor Web cin utilizar los Servicios de Windows Media. Estas plantillas proporcionan una secuencia de audio y vídeo simple indicada para transmisión HTTP.

Nota

  • Los Servicios de Windows Media también pueden utilizarse para transmisión HTTP y proporcionan un transporte HTTP más fiable para transmisión multimedia que los métodos que utiliza un sercvidor Web. Si utiliza los Servicios de Windows Media para transmisión HTTP, puede utilizar cualquiera de las plantillas de codificación. Para obtener nmás información acerca de habilitar y utilizar los servicios de Windows media para trnsmisión HTTP, consulte Utilizar transmisión HTTP en la Ayuda de los Servicios de Windows Media.


Generar contenido para la versión 2.0

Si aú tiene usuarios que utilizan la versión 2.0 del Reproductor de NetShow o que proporcionan contenido a un servidor con la versión 2.0 de los servicios de Windows Media, necesitará utilizar el método de configuración personalizada para crear archivos .asd o utilizar archivos .asd de la la versión 2.0 que ya tienen creado el contenido.

Si decide crear desde el principio archivos .asd compatibles con la versión 2.0, siga las directrices siguientes:

  • Seleccione el códec de vídeo Microsoft MPEG v1.
  • Seleccione el códec de formato de audio Voxware MetaSound V1 o el códec de audio MPEG Layer-3.
  • No utilice vídeo de velocidad de bits múltiple.
  • No use los archivos de anuncio actuales (.asx) de los Servicios de Windows Media.


Configuración personalizada

Cuando personalice la configuración del Codificador de Windows media, debe identificar el ancho de banda de red que esté utilizando, los medios qe crean la secuencia ASF, los códecs que utiliza para que sus medios coincidan con el ancho de banda de red y otros detalles del proceso de condificación.

Una vez configurado el codificador, haga clic en Inicio para empezar a transmitir la información del archivo ASF. Sin embargo, si el servidor de Windows Media va a utilizar la salida desde el Codificador de Windows Media, debe guardar la configuración como un archivo .asd. El archivo .asd contiene toda la configuración y especificaciones de la secuencia ASF. Para difundir esta secuencia ASF, haga que el archivo .asd esté disponible para el administrador del sistema que está instalando el servidor de Windows Media. Al configurar la difusión, el administrador del sistema importa los datos de la configuración del archivo .asd. Cuando cree una configuración mediante un formato de plantilla de secuencia (TSF), los servicios de componente de Windows Media se preconfiguran con la configuración y especificaciones de la secuencia ASF, por lo que no se requiere un archivo .asf.

Nota

  • El método de configuración personalizada está dirigido a los usuarios avanzados y presupone un conocimiento detallado de la capacidad de ancho de banda, de los valores de los medios y de la utilización de los códecs. Los Servicios de Windows Media pueden utilizar una gran variedad de códecs de audio y vídeo. Se recomienda el códec de audio de Windows Media versión 2 para el contenido de audio y el códec Microsoft MPEG 4 versión 3 para el de vídeo. La velocidad de bits de formato que se seleccione con el códec de audio determinará cuánto ancho de banda se reserva para el vídeo. Si aumenta el ancho de banda dedicado al audio mejorará la calidad del sonido, pero se contrarrestará con una pérdida de calidad de vídeo.


Modificar las propiedades

Una vez que ha creado un archivo (.asd) de configuración para el Codificador de Windows Media, puede realizar cambios a dicha configuración modificando sus páginas de propiedades. Las páginas de propiedades disponibles difieren si utiliza un formato de plantilla de secuencia (TSF) o una configuración personalizada.

Las propiedades disponibles al utilizar TSF son:

  • Plantilla. Controla cuál es el TSF que usará el archivo .ASD.
  • Entrada. Controla el origen del contenido: si es Directo o un archivo AVI/WAV/MP3.
  • Salida. Controle dónde se envía el archivo .asf o la secuencia ASF si a un servidor de Windows Media, un archivo .asf local o ambos.

Las propiedades disponibles al usar la configuración personalizada son:

  • Entrada. Controla el origen del contenido: si es Directo o un archivo AVI/WAV/MP3.
  • Ancho de banda. Controla el ancho de banda al que se transmite el contenido.
  • Compresión. Controla los códecs de audio y de vídeo utilizados para la compresión del contenido. Asimismo proporciona acceso a configuraciones avanzadas para el tamaño de imagen, número de cuadros por segundo, número de segundos por IFrame, formato de los píxeles, búfer de retardo y calidad de la imagen.
  • Salida. Controla a dónde se envía el archivo o secuencia ASF: a un servidor de Windows Media, a un archivo ASF o a ambos.

Nota

  • Si el origen es un archivo .MP3 con propiedades ID3, éstas se conservarán en un archivo .ASF. Es posible modificar estas propiedades mediante el Indizador de formato ASF de Windows Media.


Utilizar el códec de audio de Windows Media

Audio de Windows Media es un códec de audio nuevo creado por Microsoft. El Codificador de Windows Media incluido en las Herramients de Windows Media versión 4.0 contiene la última versión de este códec, códec de audio de Windows Media versión 2. Se dieñó el códec para tratar todos los tipos de contenido de audio, desde ancho de banda bajo de velocidad de 8 kilohertzios (kHz) a música estéreo de 48-kHz. Este códec es muy resistente a la degradación debido a la pérdida del paquete, ya que no usa memoria de marco interno. La tolerancia perdida lo hace excelente para usarlo con transmisión de contenido. Además, mediante un cifrado mejorado, este códec codifica y decodifica mucho más rápido. El algoritmo de compresión mejorado crea archivos de audio que necesitan mucho menos espacio en disco para almacenamiento que el mismo contenido creado con otros códecs. El contenido creado mediante el códec de audio de Windows Media se distribuye fácilmente en Internet porque los archivos pueden descargarse más rápidamente. Por lo tanto, si crea archivos de audio para ser descargados, el códec MSAudio es una gran opción, pues proporciona sonido casi con calidad de CD y necesita la mitad de ancho de banda que la mayoría de los códecs.

Durante las pruebas con códecs comparables, el códec de audio de Windows Media proporcionó un sonido mucho más claro con una distinción tonal mayor que los otros. La combinación de una claridad una profundidad tonal magnífica produce un contenido de música que suena mejor a través de todos los anchos de banda compatibles. El códec de audio de Windows Media es un códec muy escalable que proporciona contenido de audio de alta calidad en estéreo y mono en una gran variedad de anchos de banda. Así, puede elegir la mejor combinación entre ancho de banda y frecuencias de muestreo para el contenido. Así, Microsoft ha elegido convertirlo en el códec de audio predeterminado para la mayoría de las plantillas de configuración del Codificador de Windows Media.


Ver las estadísticas

El Codificador de Windows Media proporciona diferentes estadísticas que le ayudarán a evaluar la efectividad de la codificación. Las estadísticas son útiles cuando se intenta trazar el efecto de los cambios en la configuración de los códecs y frecuencia de bits para poder obtener la mejor renderización de contenido. Además, si utiliza vídeos de velocidad de bits múltiple, puede ver y comparar estadísticas desde las secuencias de vídeo disponibles.

Las estadísticas disponibles son:

  • Estadísticas de formato ASF. Incluye la cantidad de datos enviados, la cantidad de relleno enviado y la frecuencia de bits utilizada para transmitir los datos.
  • Estadísticas de audio. Incluyen la cantidad de datos enviados y la velocidad de bits usada para transmitir los datos.
  • Secuencias de comandos. Proporciona una medición del número de bytes de secuencias de comandos enviados, y a cuántos comandos representan.
  • Estadísticas de vídeo. Proporcionan la medida de la cantidad de datos enviados y de la cantidad de datos perdidos. Proporciona un resumen de estadísticas de velocidad de bits y del número de fotogramas transmitidos por segundo.
  • Conexiones actuales. Muestra la dirección IP de los sistemas conectados actualmente al codificador.


Iniciar el codificador

Una vez configurado el Codificador de Windows Media, está preparado para iniciar la codificación del contenido ASF. Seleccione Inicio en el menú Codificar o presione el botón de inicio.

La ventana de inicio se presenta cuando se finaliza la configuración y cuando abre el Codificador de Windows Media desde el botón de inicio, después de guardar un archivo de configuración. La ventana de inicio se compone de una barra de herramientas y de tres paneles de información. La barra de herramientas contiene accesos directos a los comandos comunes del menú, como iniciar y detener el codificador, vista preliminar del vídeo y ayuda. Los paneles contienen la información siguiente:

  • El panel Resumen de estadísticas proporciona información acerca de la sesión de codificación, cuánto tiempo ha estado codificando, cuántos datos se han codificado en la sesión, la velocidad actual de bits del contenido que se esté codificando actualmente y el número de fotogramas por segundo que se están codificando. Esto le ofrece una manera rápida de ver si la sesión de codificación está proporcionando contenido de calidad.
  • El panel Resumen de configuración proporciona información acerca de la configuración que esté utilizando. Muestra qué códecs se están utilizando, qué fuentes de entrada se están utilizando, el archivo de entrada (si lo hay) y el nombre del formato de secuencia de plantilla (TSF) , si se utiliza.
  • El panel Información de conexión proporciona la referencia de la secuencia para el codificador. Ésta es la información que se utiliza para conectar un Servidor de Windows Media o un cliente Reproductor de Windows Media a la secuencia de contenido del Codificador de Windows Media.

Si ha habilitado comandos de secuencia, el cuadro de comandos de secuencia se encuentra al principio de la ventana de inicio. Para enviar una secuencia de comandos, escríbala en el cuadro, por ejemplo:

URL HTTP://www.ejemplo.microsoft.com

y, a continuación, haga clic en el icono Enviar en el punto de la secuencia de contenido en el que desea que ocurra la acción especificada. Una vez enviada, la secuencia de comandos se incrusta en la secuencia ASF y la lleva a cabo el Reproductor de Windows Media durante la reproducción.

Una vez que inicia el codificador, las estadísticas se inician y se acumulan en el panel Resumen de estadísticas y el icono de la cámara cambiará desde Fuera del aire a En el aire.

Temas relacionados

  • Acerca de los formatos de secuencia de plantilla
  • Secuencias de comandos
  • Detener el codificador
  • Ver estadísticas


Utilizar secuencias HTTP con el Codificador de Windows Media

Aunque el servidor de Windows Media esté protegido por un servidor de seguridad, puede recibir contenido de origen desde un Codificador de Windows Media situado fuera del servidor de seguridad por medio de una función denominada transmisión HTTP.

Esta opción se diseñó para habilitar un Codificador de Windows Media en Internet para distribuir una secuencia ASF a un servidor Windows Media ubicado sin servidor de seguridad. La configuración estándar del servidor de seguridad no permite la distribución de una secuencia desde el Codificador de Windows Media dentro del servidor de seguridad a una instalación de servidor de Windows Media en Internet.

Las secuencias HTTP se habilitan de manera predeterminada en las configuraciones realizadas mediante el Tutorial. El puerto de referencia para las conexiones HTTP se enumera en la casilla de referencia de secuencia del codificador. Para cambiar el puerto o deshabilitar las secuencias HTTP, en la página de propiedades de salida de la configuración del codificador, desactive la casilla de verificación correspondiente a las secuencias HTTP.

Si utiliza los métodos de configuración Plantilla o Personalizado, podrá seleccionar las secuencias HTTP desde Configuración de salida, en la página Transmisiones del asistente de configuración.

Nota

  • Consulte a su administrador de red para evitar que se produzcan conflictos de puerto HTTP o para abrir el puerto en su servidor de seguridad.


Habilitar conexiones remotas con el Codificador de Windows Media

El Codificador de Windows Media es compatible con conexiones remotas a través del Acceso telefónico a redes. El Presentador de Windows Media para Microsoft PowerPoint 97 utiliza esta conexión para enviar comandos de inicio, detención y secuencia de comandos al Codificador de Windows Media durante la presentación.

De manera predeterminada, el Codificador de Windows Media acepta conexiones remotas, salvo que el equipo en el que está instalado el Codificador de Windows Media tenga una conexión de Acceso telefónico a redes activa en el momento de la instalación. En dicho caso, después de reiniciar el equipo, se mostrará un cuadro de diálogo en el que se le preguntará si desea habilitar conexiones remotas.

Si elige no habilitar inicialmente las conexiones remotas, podrá hacerlo más tarde ejecutando el archivo Enable_Remote_Connection.reg. Este archivo se encuentra en el directorio unidadDelSistema\Archivos de programa\Windows Media Components\Tools. En este mismo directorio también se encuentra el archivo Disable_Remote_Connection.reg, que se utiliza para deshabilitar conexiones remotas.

Nota

  • En esta sección se hace referencia sólo a los codificadores de Windows Media que se ejecutan en un equipo que utilice los sistemas operativos Microsoft Windows 95 o Microsoft Windows 98.


Detener el codificador

Al detener el Codificador de Windows Media se interrumpe la codificación de las secuencias de contenido. Cualquier equipo que se encuentre recibiendo la secuencia de contenido dejará de recibir el contenido. Después de la detención del codificador, las tarjetas de captura pueden tardar unos segundos en reiniciarse. Si intenta volver a iniciar el codificador antes de que se reinicien las tarjetas, recibirá un mensaje que le indicará que el dispositivo de vídeo no se pudo iniciar. Espere unos segundos y pruebe a iniciar el codificador de nuevo.

El Codificador de Windows Media puede detenerse haciendo clic en el botón Detener o estableciendo límites durante la sesión de codificación como, por ejemplo, un límite para el tamaño o la duración del archivo.

Temas relacionados

  • Iniciar el codificador
  • Modificar propiedades


Probar las secuencias ASF

Después de configurar e iniciar el Codificador de Windows Media , es aconsejable probarlo antes de suministrar contenido a los usuarios.

Para probar el codificador, utilice el reproductor de Microsoft Windows Media para recibir la secuencia ASF desde el Codificador de Windows Media y el servidor de Windows Media.

No utilice más de quince clientes para probar el codificador, ya que la secuencia proveniente del Codificador de Windows Media no es una secuencia de multidifusión.


Publicar en World Wide Web

Una vez creado el contenido ASF con el Codificador de Windows Media, ¿cómo distribuirlo de forma efectiva a la mayor audiencia posible? Microsoft creó el Programa de proveedores de servicios de Windows Media para proporcionar a los creadores de contenido un conjunto de proveedores de servicios que puedan instalar y mantener soluciones de secuencias multimedia basadas en los Servicios de Windows Media.

En el menú Archivo del Codificador de Windows Media, seleccione Publicar en Web para ver la lista de los Proveedores de servicios de Windows Media aprobados actualmente y que pueden publicar el contenido en Web.


Presentador de Windows Media

El Presentador de Windows Media para Microsoft PowerPoint 97 es una herramienta complementaria que permite sincronizar una presentación de PowerPoint con una secuencia ASF. Este complemento permite a PowerPoint:

  • Conectarse con el Codificador de Windows Media.
  • Enviar secuencias de comandos de direcciones URL al Codificador de Windows Media.
  • Exportar diapositivas.
  • Crear y controlar una presentación de PowerPoint que pueden presenciar usuarios remotos a través de una red en sus propios equipos de sobremesa.

Para ver un ejemplo del mundo real acerca de cómo el Presentador de Windows Media puede agregar datos a una secuencia ASF, suponga que el director general (CEO) de una organización realiza una presentación a los empleados. Debido a las limitaciones de tiempo y otros compromisos, muchos empleados no pueden asistir a la presentación. Con el Presentador de Windows Media y un servidor Microsoft Windows NT los empleados podrán utilizar sus equipos para ver un vídeo en directo de la conferencia del presidente, así como imágenes sincronizadas con las diapositivas. El Servidor de Windows Media entrega el contenido de vídeo en directo y el Presentador de Windows Media permiten al CEO sincronizar la entrega de las diapositivas de la presentación en puntos específicos del contenido de vídeo en directo. Los empleados que desean ver la presentación pueden descargar la presentación desde una página Web y recibirla como si estuvieran en la misma sala que el presentador.

El Presentador de Windows Media se combina con otros muchos componentes, como el Codificador de Windows Media, los Servicios de Windows Media, Servicios de Internet Information Server (IIS), PowerPoint y el Reproductor de Windows Media de Microsoft, para proporcionar el contenido a los empleados. El Presentador de Windows Media se diseñó para servir de suplemento a una secuencia ASF y desempeñar el papel de agregar información a una secuencia ASF.

Nota

  • Si desea proporcionar contenido creado con el Presentador de Windows Media a equipos que utilicen Netscape Navigator, éstos deberán utilizar la versión 4.05 o posterior de Netscape Navigator. De no ser así, el contenido no se reproducirá correctamente con el Reproductor de Windows Media.


Cómo...

Esta sección trata los procedimientos que se suelen realizar al utilizar el Presentador de Windows Media para Microsoft PowerPoint 97.


Para exportar diapositivas desde PowerPoint al servidor de IIS

  1. Inicie PowerPoint. En el menú Archivo, haga clic en Abrir y seleccione la presentación que desea transmitir.
  2. En el menú Herramientas, seleccione Presentador de Windows Media y haga clic en Exportar diapositivas.
    Exportar diapositivas
  3. En el cuadro de diálogo Exportar diapositivas, especifique la Dirección URL de destino. Se trata de la carpeta de Servicios de Internet Information Server (IIS) o del servidor HTTP al que desea exportar las imágenes. El Presentador de Windows Media puede copiar los archivos de imágenes a una carpeta local o remota o puede utilizar el protocolo de transferencia de archivos (FTP) para exportar las imágenes.
  4. En el panel Propiedades de la imagen del cuadro de diálogo Exportar diapositivas, establezca las propiedades para reflejar la dimensión, calidad y formato de las imágenes que desea exportar. Si no está seguro de cómo desea que aparezcan las imágenes, utilice los valores predeterminados.

    El Presentador de Windows Media se conecta con el equipo especificado y exporta las diapositivas de PowerPoint como imágenes.


Para crear un archivo de configuración del Codificador de Windows Media

  1. Inicie PowerPoint. En el menú Herramientas, seleccione Presentador de Windows Media y haga clic en Nuevo archivo de configuración del Codificador de Windows Media para crear un archivo .NSE.

    Aparece el cuadro de diálogo Configuración del Codificador de Windows Media.
    Configuración del Codificador de Windows Media

  2. En el cuadro Codificador, escriba la ruta de acceso del equipo que ejecuta el Codificador de Windows Media. Si el Codificador de Windows Media se ejecuta en la emisora de PowerPoint, acepte la configuración predeterminada de localhost.
  3. En el cuadro de diálogo Dirección URL base, escriba la dirección URL de la ubicación de las diapositivas en el servidor de IIS. La dirección URL base es importante debido a que cuando cambie de diapositiva en la presentación, el Presentador de Windows Media agrega el nombre de cada imagen a la dirección URL y, a continuación, envía esta dirección URL como una secuencia de comandos al cliente.
  4. En el menú Formato de imagen, seleccione el mismo formato especificado al exportar las diapositivas al Servicio Internet Information Server (IIS). Se recomienda JPEG para obtener imágenes de mayor calidad.
  5. Seleccione Omitir errores del Codificador de Windows Media. Esto le permite continuar la presentación sin tener en cuenta los errores del codificador. Si no selecciona esta opción, la presentación de PowerPoint termina si falla el Codificador de Windows Media.
  6. Seleccione Iniciar nuevo Codificador de Windows Media si desea que el Presentador de Windows Media inicie una nueva sesión del Codificador de Windows Media. Seleccione el archivo de configuración del Codificador de Windows Media (.ASD) que desee utilizar con la presentación.

    O bien, seleccione Conectar para ejecutar el Codificador de Windows Media si desea que el Presentador de Windows Media se conecte a una sesión existente del Codificador de Windows Media.

    Si selecciona conectarse con un Codificador de Windows Media en ejecución, puede seleccionar Volver a configurar utilizando el archivo ASD para modificar la configuración del codificador.

  7. Para aplicar esta modificación a la presentación abierta, seleccione Usar esta configuración con la presentación de diapositivas actual.


Para modificar un archivo de configuración del Codificador de Windows Media

  1. Inicie PowerPoint. En el menú Herramientas, seleccione Presentador de Windows Media y haga clic en Modificar archivo de configuración del Codificador de Windows Media para crear un archivo .NSE.
  2. Aparece el cuadro de diálogo Abrir el archivo de configuración del Codificador de Windows Media. Seleccione el archivo .NSE que desee modificar y, a continuación, haga clic en Abrir.

    Aparece el cuadro de diálogo Configuración del Codificador de Windows Media.

  3. Si necesita cambiar a otro equipo que ejecuta el Codificador de Windows Media, en el cuadro Codificador, escriba el nombre de dicho equipo. Si el Codificador de Windows Media se ejecuta en el equipo de PowerPoint, escriba localhost.
  4. Si necesita configurar una nueva Dirección URL base, en el cuadro de diálogo Dirección URL base, escriba la dirección URL. La dirección URL base es importante debido a que cuando cambie de diapositiva en la presentación, el Presentador de Windows Media agrega el nombre de cada imagen a la dirección URL y, a continuación, envía esta dirección URL como una secuencia de comandos al cliente.
  5. Si necesita modificar el formato de la imagen, seleccione el formato en la lista Formato de imagen. La imagen debe tener el mismo formato en que exportó las diapositivas. Se recomienda JPEG para obtener imágenes de mayor calidad.
  6. Seleccione Omitir errores del Codificador de Windows Media. Esto le permite continuar la presentación sin tener en cuenta los errores del codificador. Si no selecciona esta opción, la presentación de Microsoft PowerPoint termina si falla el Codificador de Windows Media.
  7. Seleccione Iniciar nuevo Codificador de Windows Media si desea que el Presentador de Windows Media inicie una nueva sesión del Codificador de Windows Media. Seleccione el archivo de configuración del Codificador de Windows Media (.ASD) que desee utilizar con la presentación.

    O bien, seleccione Conectar con un Codificador de Windows Media en ejecución si quiere que el Presentador de Windows Media se conecte a una sesión existente del Codificador de Windows Media.

    Si decide conectarse con un Codificador de Windows Media que esté en ejecución, puede seleccionar Volver a configurar con un archivo ASD para modificar la configuración del codificador.

  8. Para aplicar esta modificación a la presentación abierta, seleccione Usar esta configuración con la presentación de diapositivas actual.


Para configurar el Presentador de Windows Media

  1. Inicie PowerPoint. En el menú Herramientas, seleccione Presentador de Windows Media y haga clic en Configuración del presentador.

    Aparecerá el cuadro de diálogo Configuración de presentador.
    Configuración del Presentador

  2. Si seleccionó Usar esta configuración con la presentación de diapositivas actual al crear el archivo del Codificador de Windows Media (.NSE), la ruta de acceso del archivo .NSE ya está completada; si no es así, haga clic en Examinar para seleccionar un archivo .NSE existente.
  3. Seleccione Usar el Codificador de Windows Media durante la presentación de diapositivas para transmitir una presentación de diapositivas al Codificador de Windows Media. No seleccione esta opción si desea ensayar la presentación sin codificarla.
  4. Para iniciar la presentación de diapositivas, en el menú Presentación de diapositivas, haga clic en Ver presentación. La emisora de PowerPoint está configurada para utilizar el Presentador de Windows Media.


Para configurar el Codificador de Windows Media para crear una secuencia ASF

  1. Abra el Codificador de Windows Media. Cree una configuración del Codificador de Windows Media para la presentación y guárdela como un archivo .ASD. Puede utilizar tres métodos diferentes de configuración:
    • Tutorial
    • Plantilla con opciones E/S
    • Personalizado

    Cualquier método de configuración que seleccione debe admitir secuencias de comandos. Puede seleccionar un formato de plantilla de secuencia que acepte secuencias de comandos o puede utilizar una configuración personalizada con secuencias de comandos. Si no se habilita las secuencias de comandos, las secuencias de comandos que envía Microsoft PowerPoint al cambiar de diapositiva en la presentación no se incluyen en la secuencia ASF y las imágenes de las diapositivas no aparecen en la pantalla del usuario.

  2. En el equipo en que se ejecuta el Codificador de Windows Media, prepare la cámara de vídeo y el micrófono que utilizará para grabar la presentación. Pruebe la cámara de vídeo para asegurarse de que se envía la señal a la tarjeta de vídeo del Codificador de Windows Media. Asimismo, pruebe el micrófono para asegurarse de que envía una señal a la tarjeta de sonido.
  3. Si no seleccionó Iniciar nuevo Codificador de Windows Media al crear el archivo .NSE, abra e inicie el archivo de configuración (.ASD) que creó.

Nota

  • El Codificador de Windows Media comienza a entregar el vídeo al servidor de Windows Media, pero éste no puede transmitirlo a los usuarios hasta que se inicie un programa de Windows Media.

Temas relacionados

  • Codificador de Windows Media
  • Preparar el Servidor de Windows Media
  • Habilitar conexiones remotas con el Codificador de Windows Media


Para preparar el servidor de Windows Media para difundir una presentación

  1. Abra el Administrador de Windows Media.
  2. Cree los programas y secuencias para difundir mediante multidifusión la presentación y las diapositivas. Necesita crear también los siguientes elementos:
    • Dos programas de transferencia de archivos mediante multidifusión y dos secuencias: una secuencia de ancho de banda alto para transferir las diapositivas a la caché del explorador antes de que comience la presentación y una secuencia de transferencia de archivos de ancho de banda alto para continuar la transferencia de archivos durante la presentación. Consulte Crear el programa de transferencia de archivos de multidifusión para el Presentador de Windows Media y Agregar una secuencia de transferencia de archivos a un programa del Presentador de Windows Media para obtener procedimientos detallados paso a paso.
    • Una emisora de multidifusión con un programa y una secuencia para difundir mediante multidifusión la secuencia ASF que contiene el contenido de sonido, el contenido de vídeo y la secuencia de comandos. Consulte Crear una emisora, programa y secuencia de multidifusión para el Presentador de Windows Media para obtener el procedimiento detallado paso a paso.
  3. Antes de que comience la presentación en el momento programado, mediante el Administrador de Windows Media, inicie los programas que configuró. Cuando inicie los programas, el servidor de Windows Media comenzará a entregar la información. Los usuarios que vayan a la página Web inicial pueden comenzar a recibir las imágenes de la presentación.

Nota

  • Si desea obtener más información acerca de cómo crear programas y secuencias, consulte Servicios de Windows Media en la documentación de Windows Media que se instala con los Servicios de Windows Media.


Para crear un programa de transferencia de archivos de multidifusión para el Presentador de Windows Media

  1. Abra el Administrador de Windows Media.
  2. En el marco de menús del Administrador de Windows Media, haga clic en Transferencias de archivos de multidifusión.

    Aparece la página Transferencias de archivos de multidifusión.

  3. Haga clic en Programas y, a continuación, haga clic en Nuevo.

    Aparece el cuadro de diálogo Programa.

  4. En el campo Nombre, escriba el nombre del programa.
  5. (Opcional) En los cuadros Descripción, Autor y Copyright, escriba la información apropiada del programa.
  6. En el área Opciones de reproducción, escriba el número de veces que desea que se reproduzca el programa en el cuadro Tiempos de reproducción.

    O bien, para repetir el programa hasta que decida detenerlo, haga clic en Reproducción continua.

  7. Para detener el programa cuando se produce un error, active el cuadro Detener el programa si se produce un error. De forma predeterminada, si se produce un error en la reproducción de una secuencia, el programa continúa e intenta reproducir la siguiente secuencia de la serie.

    El programa aparece en la lista de programas. Ahora está preparado para crear secuencias de transferencia de archivos. Para obtener información acerca de cómo crear secuencias, consulte Agregar una secuencia de transferencia de archivos a un programa del Presentador de Windows Media


Agregar una secuencia de transferencia de archivos a un programa del Presentador de Windows Media

  1. Abra el Administrador de Windows Media.
  2. En el marco de menús del Administrador de Windows Media, haga clic en Transferencias de archivos de multidifusión.

    Aparece la página Transferencias de archivos de multidifusión.

  3. Bajo Difusiones de archivos de multidifusión, haga clic en el nombre del programa al que desea agregar la secuencia.
  4. Haga clic en Secuencias y, a continuación, haga clic en Nuevo.
  5. Para proporcionar a la secuencia un nombre y una descripción, haga clic en la ficha General.
    • En el cuadro Nombre, escriba el nombre de la secuencia.
    • En el cuadro Descripción, escriba la descripción de la secuencia.
  6. Para definir el origen y el destino de la secuencia, haga clic en la ficha Origen o destino.
  7. En Origen, haga clic en Archivo para transferir archivos y carpetas.
    • En el cuadro Archivo, escriba la ruta de acceso de la carpeta a la que exportó las diapositivas de PowerPoint o haga clic en Examinar para ubicar y seleccionar una carpeta.
    • En Destino, especifique la ubicación a la que se transfieren los archivos. El cliente puede anular este destino.
    • Para especificar varios archivos en una carpeta para transferirlos, utilice un carácter comodín, por ejemplo, C:\Content\*.jpg.
  8. En Dirección de destino:
    • En el cuadro Dirección IP, escriba la dirección IP de destino.
    • En el cuadro Puerto, escriba el puerto de destino.

    Para que un cliente pueda recibir la multidifusión, la dirección y el puerto que establezca para la secuencia deben coincidir con la dirección y el puerto que especifica el control de la página Web del cliente. El control, Nsfile.ocx, configura la tarjeta de red del cliente correctamente.

    Las direcciones de multidifusión están comprendidas entre 224.0.0.0 y 239.255.255.255. Se recomienda una dirección del intervalo 239.*.*.* para las intranet. Evite la utilización de direcciones del intervalo 224.*.*.*. Están reservadas para los protocolos de bajo nivel.

    Los números de puerto IP van de 1 a 65535.

  9. Para especificar el alcance de la multidifusión, seleccione una opción de Tiempo de vida:
    • Haga clic en Red local para limitar la difusión al nodo de la red local.
    • Haga clic en Intranet para limitar la difusión a su sitio.
    • Haga clic en Internet para expandir el alcance de la difusión a Internet.
    • Haga clic en Otros para escribir un valor personalizado. Los valores pueden variar de 1 a 255.
  10. En Destino, seleccione el destino de la transferencia de archivos:
    • Haga clic en Directorio y escriba el nombre del directorio en el cuadro para transferir los archivos y carpetas que ha especificado a la carpeta del cliente. Puede utilizar variables de entorno para especificar una ubicación en el cliente. De forma predeterminada, se transfiere los archivos y subcarpetas a la carpeta especificada en la variable de entorno %temp% del cliente.
    • Haga clic en Archivo y escriba un nombre de archivo en el cuadro para transferir un archivo y cambiar su nombre en el cliente.
    • Haga clic en Dirección URL base y escriba la dirección URL para transferir los archivos que ha especificado a la memoria caché del explorador del cliente. La dirección URL que especifique se utiliza como prefijo de cada uno de los archivos transferidos.

    Esta opción le permite cargar en la memoria caché del cliente los archivos antes de necesitarlos. Por ejemplo, si va a transmitir un archivo .ASF que incluye direcciones URL de archivos gráficos, puede transferirlos al cliente antes de que se necesite mostrarlos. Debido a que ya están en la memoria caché, el cliente puede mostrarlos rápidamente.

  11. Haga clic en la ficha Avanzadas para establecer el límite de ancho de banda de la secuencia.

    Para obtener más información acerca de la ficha Avanzadas, consulte Utilizar la ficha Avanzadas de transferencia de archivos.

Nota

  • Para utilizar la Transferencia de archivos de multidifusión para transferir archivos a los usuarios, los clientes deben tener instalado Microsoft Internet Explorer 4.01.


Crear una emisora, un programa y una secuencia de multidifusión para el Presentador de Windows Media con el Asistente para tutorial de emisoras

  1. En el Servidor de Windows Media, abra el Administrador de Windows Media. En el marco de menús, haga clic en Estaciones de multidifusión.

    Se abre la página Estaciones de multidifusión.

  2. En Estaciones, compruebe que la casilla de verificación Usar asistente para crear la nueva emisora está activada, haga clic en Estaciones y, a continuación, haga clic en Nueva.

    Aparece el Asistente para tutorial de configuración y publicación de secuencias de difusión y multidifusión. Haga clic en Siguiente para continuar.

  3. En la pantalla Seleccione una emisora, active la casilla de verificación Crear una nueva emisora y haga clic en Siguiente.
  4. En la pantalla Crear una nueva emisora, escriba el nombre de la emisora y, a continuación, una descripción. Seleccione un Modo de distribución y, a continuación, haga clic en Siguiente.
  5. En la pantalla Especifique el nombre de un programa y de una secuencia, en Nombre de programa escriba el nombre del programa y en Nombre de secuencia escriba el nombre de la secuencia. También puede activar dos opciones de programa:
    • Si selecciona Iniciar el programa cuando el asistente termine se inicia el programa en el momento en que se crea el programa y la secuencia; de forma que estén disponibles inmediatamente para verlos.
    • Si selecciona Volver a reproducir los objetos de la secuencia una vez terminada (bucle) el programa se inicia de nuevo una vez que haya terminado su reproducción. El programa se reproducirá continuamente hasta que se detenga.
  6. En la pantalla Especificar un origen para el objeto de secuencia, seleccione un origen para la secuencia.
    • El Codificador de Windows Media es el origen de las presentaciones de PowerPoint en directo.
    • Para continuar, haga clic en Siguiente.
  7. En la pantalla Especifique la dirección URL de origen del objeto de la secuencia, en el cuadro de diálogo Dirección URL de origen, escriba la dirección URL de la secuencia del Codificador de Windows Media, por ejemplo, msbd://encoder:XXXX, donde XXX es el puerto que utiliza el Codificador de Windows Media para entregar la secuencia. A continuación, haga clic en Siguiente.
  8. En la pantalla Especifique la información de formato de la secuencia, identifique si el Codificador de Windows Media realiza la codificación con una configuración estándar que utiliza formatos de plantillas de secuencia o si creó una configuración personalizada. Si creó una configuración personalizada, debe haber guardado dicha configuración como archivo .ASD.

    Si utilizó una configuración personalizada, escriba la ruta de acceso acorde a la convención de nomenclatura universal (UNC) del archivo .ASD, por ejemplo, \\Servidor\ASDshare\File.asd. A continuación, haga clic en Siguiente

  9. En la pantalla Ruta de acceso de exportación de la información de la emisora, en Ruta de acceso, escriba la ruta de acceso UNC donde se guardará el archivo .NSC de la emisora y, a continuación, haga clic en Siguiente.

    Como es necesario tener acceso al archivo .NSC desde el Reproductor de Windows Media, la carpeta en la que guarde el archivo .NSC tiene que estar compartida o el archivo tiene que estar almacenado en un servidor HTTP.

  10. En la pantalla Dirección URL del archivo de información de emisora, especifique el tipo de ruta de acceso (ruta de acceso HTTP o directorio compartido de la red) y, a continuación, escriba la ruta de acceso. Haga clic en Siguiente.

    La ruta de acceso que escriba debe permitir que el Reproductor de Windows Media tenga acceso al archivo .NSC que especificó en el paso 7.

  11. En la pantalla Seleccione un método de publicación, seleccione los métodos de publicación que desee y haga clic en Siguiente.
    • Cuando se activa un método de publicación, el asistente crea dicho archivo .HTM, o copia el código HTML en el Portapapeles de Windows (para que pueda pegarlo en una página HTML). Cada uno de estos métodos es una forma de probar que la emisora de multidifusión funciona. La opción ASX es la selección predeterminada. Es posible que desee utilizar esta opción con el Presentador de Windows Media debido a que tiene una página Web en la que puede incrustar el archivo .ASX.
  12. En la pantalla Preparado para publicar, revise la lista de opciones que ha seleccionado. Para modificar cualquier opción, haga clic en Atrás una o más veces para volver a la información apropiada de emisora. En caso contrario, haga clic en Finalizar.
  13. Guarde el archivo .ASX creado en un directorio al que se pueda tener acceso y, a continuación, haga clic en Siguiente.
  14. Según las opciones de publicación que seleccione, es posible que haya terminado. Si seleccionó Crear un archivo .htm con una etiqueta <HREF> que vincule un archivo ASX o Crear un archivo .htm que contenga etiquetas <OBJECT> y <EMBED> para el Reproductor de Windows Media, o ambos, entonces debe guardar los archivos .htm en un directorio. Los archivos .HTM se llaman emisora_href_tag.htm y emisora_object_tag.htm, donde emisora es el nombre de la emisora.
  15. En el panel Publicación completa, puede probar la emisora. Para probar la emisora, haga clic en el botón Probar .asx. Se abrirá el Reproductor de Windows Media y comenzará a reproducir la secuencia.


Presentador de Windows Media

Esta sección explica una de las formas de utilizar el Presentador de Windows Media para Microsoft PowerPoint 97. Mediante el Reproductor de Windows Media, los usuarios pueden ver un vídeo en el que habla un presentador y, al mismo tiempo, las diapositivas de PowerPoint en una página Web.

La documentación de Windows Media no proporciona la secuencia ASF y la presentación de PowerPoint; sin embargo, las páginas Web desde las que los usuarios descargan el material de la presentación y ven la secuencia ASF y la presentación de diapositivas, se encuentran en la carpeta \Archivos de programa\Windows Media Components\Tools\Presenter\. Para que estas páginas Web funcionen, debe reemplazar las rutas de acceso y las direcciones IP de las secuencias de comandos con las ubicaciones de sus imágenes y servidores. Si desea utilizar esas páginas de ejemplo y necesita instrucciones acerca de cómo modificarlas, consulte Páginas de ejemplo del Presentador.

Los procedimientos de esta sección le muestran cómo configurar y utilizar el Presentador de Windows Media para enviar diapositivas de PowerPoint como parte de una secuencia ASF. Estos procedimientos utilizan los siguientes programas: El Codificador de Windows Media, un servidor de Windows Media (para la transmisión mediante unidifusión y multidifusión), PowerPoint, los Servicios de Internet Information Server (IIS) y el Reproductor de Windows Media. Se recomienda utilizar un equipo diferente para cada programa, aunque no siempre es necesario. La codificación de contenido de vídeo y sonido en una secuencia ASF puede requerir gran cantidad de capacidad de procesamiento; por lo que obligar a un equipo a codificar sonido y vídeo mientras realiza otras tareas pueden hacer que falle el Codificador de Windows Media.

Para poder utilizar el Presentador de Windows Media se requiere la colaboración de diferentes equipos de la red.

Se debe realizar los pasos siguientes antes de proporcionar la presentación:

  • El equipo de PowerPoint debe estar preparado adecuadamente para dar salida a la presentación.
  • El Codificador de Windows Media debe estar configurado para aceptar la entrada desde el equipo de PowerPoint y el contendido de sonido y vídeo en directo.
  • El servidor de Windows Media debe tener configurada una emisora para transmitir la presentación.
  • El servidor de IIS debe estar configurado adecuadamente para aceptar los comandos del servidor de Windows Media y de los usuarios.
  • Los usuarios deben estar preparados para aceptar la presentación.

Antes de comenzar la presentación, se debe proporcionar a los usuarios potenciales la hora de inicio y las direcciones URL utilizadas para la presentación. Cuando el usuario abre la página Web inicial, comienza la transferencia de las imágenes de las diapositivas de PowerPoint a la memoria caché del explorador. Así, se elimina el tiempo que necesita el explorador para descargar las imágenes desde el servidor de IIS durante la presentación.

Cuando comienza la presentación de PowerPoint, el Presentador de Windows Media se conecta con el Codificador de Windows Media, que comienza a transmitir secuencias con el vídeo y el sonido. Cuando el presentador cambia de diapositiva, el Presentador de Windows Media envía una secuencia de comandos de dirección URL al Codificador de Windows Media, que incluye el comando como parte de la secuencia ASF. Cuando el Reproductor de Windows Media recibe la secuencia de comandos de dirección URL, envía la dirección URL al explorador, que comprueba en su memoria caché para mostrar la imagen que pertenece a la dirección URL en el marco del explorador. Si la imagen no está en la memoria caché, el explorador la descarga del servidor de IIS. El usuario ve las diapositivas de PowerPoint en la ventana de su explorador y el vídeo del presentador en la ventana del Reproductor de Windows Media. El contenido de sonido y vídeo está sincronizado con el cambio de diapositivas.

Nota

  • Si está conectado a través del Acceso telefónico a redes a un Codificador de Windows Media que utiliza tanto el sistema operativo Microsoft Windows 95 como Microsoft Windows 98, consulte Habilitar conexiones remotas con el Codificador de Windows Media para obtener más información.


Preparar el equipo de PowerPoint

La preparación del equipo de PowerPoint consta de tres procedimientos:

  1. Exportar diapositivas de PowerPoint al servidor IIS
    Las diapositivas deben colocarse en el servidor de los Servicios de Internet Information Server (IIS), pues no se agregan a la secuencia ASF. La secuencia ASF únicamente incluye una secuencia de comandos que hace referencia a las diapositivas. La secuencia de comandos indica al explorador del usuario cuándo debe cambiar de una diapositiva a otra cuando el presentador cambia de diapositiva a través de un comando de ruta de acceso de dirección URL.
  2. Crear un archivo de configuración del Codificador de Windows Media (.NSE).
    El archivo .NSE indica a PowerPoint cómo debe conectarse con el Codificador de Windows Media e indica a éste el formato de imagen y ubicación de las diapositivas de PowerPoint. Tiene la opción de conectarse con un codificador que ya esté en ejecución o iniciar una nueva sesión del codificador. Si selecciona iniciar una nueva sesión del codificador, se requiere un archivo .asd, por lo que debe asegurarse de que crea u obtiene un archivo .asd antes de realizar este paso.

    Si decide conectarse con un codificador que esté en ejecución, utilice de forma predeterminada la configuración actual del codificador. Sin embargo, cuando se crea el archivo .NSE, se le ofrece la opción de especificar un archivo .ASD diferente para utilizar con la presentación de PowerPoint. Esto puede resultar útil si va a transmitir otro contenido a través de su emisora de Windows Media antes de que comience la presentación. Por ejemplo, podría tener una emisora de radio que proporciona contenido a los usuarios que conectan antes de la hora de inicio programada. Este contenido utiliza un archivo .asd diferente del utilizado para la presentación. Si vuelve a configurar un Codificador de Windows Media mientras se ejecuta, puede utilizar los recursos de forma más eficiente.

  3. Configurar el Presentador de Windows Media para Microsoft PowerPoint 97s
    Prepara el Presentador de Windows Media para transmitir la presentación. Utilícelo inmediatamente antes de comenzar la presentación. Una vez que haya seleccionado el Codificador de Windows Media para utilizarlo durante la presentación de diapositivas, enviará datos cuando inicie la presentación. Asegúrese de que la persona que realiza la presentación es consciente de este paso para que no se transmitan inadvertidamente los ensayos de la presentación.


Preparar el Codificador de Windows Media

El Codificador de Windows Media se utiliza para codificar contenido de sonido y vídeo en directo en secuencias y archivos ASF. Cuando se utiliza el Presentador de Windows Media para Microsoft PowerPoint 97, el Codificador de Windows Media se usa para crear la secuencia ASF de la presentación que transmitirá el servidor de Windows Media.

El Codificador de Windows Media debe estar configurado para crear la secuencia ASF con el formato adecuado para el entorno.

Temas relacionados

  • Codificador de Windows Media
  • Secuencias ASF
  • Para configurar el Codificador de Windows Media para crear una secuencia ASF


Preparar el Servidor de Windows Media

El servidor de Windows Media es el responsable de difundir la presentación a través de la red. El servidor de Windows Media envía el contenido organizado en programas y secuencias. Para utilizar el Presentador de Windows Media para Microsoft PowerPoint 97, debe crear programas y secuencias para la presentación, crear una emisora de multidifusión y, a continuación, iniciar la difusión.


Utilizar la ficha Avanzadas de transferencia de archivos

Al crear una nueva secuencia de transferencia de archivos o modificar una existente, utilice la ficha Avanzadas de la página de propiedades de la Secuencia para establecer las opciones siguientes:

  • En el cuadro Dirección del adaptador de multidifusión, seleccione la dirección del adaptador de red que utilizará para difundir en el servidor. Si el servidor sólo tiene un adaptador, no modifique la selección predeterminada. En los equipos con varios adaptadores, puede utilizar esta opción para difundir programas independientes simultáneamente; para ello, asigne una dirección de adaptador diferente a cada programa.
  • En el cuadro Ancho de banda máximo, escriba la cantidad máxima de ancho de banda que utilizará para difundir el archivo.

    Cuando se realiza la difusión a clientes conectados a la red mediante módem, se recomienda utilizar valores en el intervalo de 10 kilobits por segundo (Kbps) a 20 Kbps.

    Cuando realice difusiones a clientes en una red de área local Ethernet típica (LAN), se recomienda utilizar valores por debajo de los 1.000 Kbps.

  • En el cuadro Redundancia, establezca la cantidad de corrección de errores que se vaya a utilizar al difundir el programa.

    El valor que escriba en el cuadro Redundancia se redondea hacia arriba hasta el siguiente porcentaje. La configuración de redundancia puede variar del 0,4 por ciento al 100 por cien.

    Aunque los porcentajes mayores de corrección de errores ayudan a asegurar una recepción correcta por parte del cliente, también aumentan el tiempo que se tarda en enviar el archivo. Por ejemplo, una redundancia del 100 por ciento duplica el tiempo.

  • En el cuadro Duración, escriba el período de tiempo de ejecución de la secuencia. Utilice el formato hh:mm:ss, donde h representa las horas, m los minutos y s los segundos. Cuando llega la hora, el programa finaliza o, si hay otra secuencia a continuación de la actual, comienza la siguiente secuencia.
  • En el cuadro Registro, cree un registro de la difusión de transferencia de archivos. Escriba la ruta de acceso y el nombre del archivo de registro en el cuadro Ruta de acceso del archivo. Cuando se produce la transferencia de archivos, se crea un archivo de registro que contiene una lista con los archivos transferidos e información de destino de cada uno.
  • Haga clic en Completamente confiable para habilitar la transferencia de archivos completamente confiable.

La transferencia de archivos completamente confiable permite a los clientes pedir al servidor que vuelva a enviar los datos si se produce un error al recibirlos. Una vez recibida la petición de reenvío, el servidor difunde los datos pedidos a todos los clientes. Utilizar la transferencia de archivos completamente confiable puede aumentar el ancho de banda de red que utiliza el sistema.


Preparar el servidor de IIS

Para preparar el servidor para que los usuarios vean la presentación a través de una red, debe crear dos páginas Web: una página Web inicial y la página Web principal. En la carpeta unidadDelSistema\Archivos de programa\Windows Media Components\Tools\Presenter encontrará ejemplos de estas páginas. Si desea utilizarlas en una presentación, reemplace las rutas de acceso a las imágenes y direcciones IP del servidor en la secuencia de comandos que incluye las ubicaciones de la imágenes y los servidores. Para obtener más información acerca de la utilización de estas páginas, consulte Páginas de ejemplo del Presentador.

La página Web inicial contiene un control de transferencia de archivos que se utiliza para transferir las diapositivas de PowerPoint a la memoria caché del explorador del usuario. Así, se reduce la cantidad de tiempo que el usuario debe esperar para ver las diapositivas y permite una presentación de diapositivas con una apariencia más uniforme.

La página principal de visión contiene un marco para observar la secuencia de vídeo, un marco para ver las diapositivas de la presentación y un control de transferencia de archivos. Si el usuario no recibe todas las imágenes de la página inicial, el control transfiere las imágenes restantes a la memoria caché del explorador. Si la página Web principal recibe una secuencia de comandos que llama a una imagen que no está en la memoria caché del equipo, el explorador descarga la imagen del servidor HTTP que contiene las copias de las imágenes de la presentación.

Antes de la presentación, proporcione a los usuarios la dirección URL de la página Web inicial y aconséjeles que vayan a la dirección URL unos minutos antes de comenzar la presentación.

Cuando los usuarios abren la página Web inicial, el canal de transferencia de archivos abre y comienza a transferir las imágenes de la presentación a la memoria caché del equipo. Cuando inicia la presentación, la página Web inicial cambia automáticamente a la página Web principal. El código que pide este cambio está incrustado en la página Web inicial. Escriba la hora en que debe cambiar la página Web y la dirección URL de la página Web principal.


Páginas de ejemplo del Presentador

Cuando instala el Presentador de Windows Media para Microsoft PowerPoint 97, se instala también una serie de páginas Web de ejemplo. Puede personalizar estas páginas para crear su propio escenario para el Presentador de Windows Media.

Se escribieron las páginas con secuencias de comandos ECMA (Asociación de fabricantes europeos de PC), que es compatible con Microsoft JScript y Netscape JavaScript. Se recomienda tener conocimientos previos de HTML y de creación de páginas Active Server. Se puede utilizar el Presentador de Windows Media tanto con los clientes Microsoft Internet Explorer versión 4.01 o Netscape Navigator versión 4.0.

Puede encontrar las páginas de ejemplo del Presentador de Windows Media en la carpeta unidadDelSistema\Archivos de programa\Windows Media Components\Tools\Presenter. El primer conjunto de archivos se utiliza en la página inicial cuando un cliente se conecta por primera vez con el sitio del Presentador. La página inicial muestra el nombre de la presentación, la hora en que comienza y un cronómetro de cuenta atrás que indica el tiempo que falta para que comience la presentación. Un control que se ejecuta en el segundo plano de la página realiza la carga preliminar de las imágenes en la memoria caché del equipo cliente para tener un acceso más rápido durante la presentación.

Esta tabla describe la función de cada archivo.

Nombre de archivo | Función
Clbl.class | Un control de etiqueta que realiza la cuenta atrás del tiempo que queda para iniciar la presentación para los clientes de Netscape Navigator.
Default.asp | La página inicial en la que entra el usuario. La secuencia de comandos de esta página comprueba que el cliente utiliza un explorador Web y un sistema operativo admitidos. Si no se admite la configuración del cliente, aparece un mensaje.
Filelist.htm | Utilice esta página para enumerar todas las imágenes utilizadas en la presentación. Esta lista sólo se utiliza si proporciona contenidos a clientes de Netscape Navigator o si no utiliza el servicio de transferencia de archivos de multidifusión de Windows Media. En este caso, los archivos enumerados aquí se transfieren a la memoria caché del explorador mediante el protocolo estándar de transferencia de archivos.
Global.asa | Este archivo define las propiedades del suceso del Presentador de Windows Media). Consulte Personalizar Global.asa.
Showmult.asp | Esta página se carga si la variable MULTICAST del archivo Global.asa está establecida como true. La página comprueba si el Reproductor de Windows Media y el control del servicio de transferencia de archivos (FTS) están instalados en el cliente. Si no es así, se instalan. La página comienza a transferir diapositivas en la memoria caché del equipo mediante el control FTS. Esta página también proporciona el cronómetro de cuenta atrás al usuario, que muestra el tiempo que queda para que comience la presentación. Si se produce un error en el archivo Global.asa, aparece un mensaje.
Showreg.asp | Esta página se carga si se detecta un cliente de Netscape Navigator o si se estableció la variable MULTICAST del archivo Global.asa como false. Esta página comprueba si el Reproductor de Windows Media está instalado en el cliente. Si no es así, se instala. Llama al archivo Filelist.htm y carga las imágenes especificadas en la matriz en la memoria caché del equipo cliente. Muestra también cuándo comenzará la presentación y un cronómetro de cuenta atrás.

Esta carpeta contiene dos subcarpetas: First e Images. First contiene las páginas utilizadas una vez que comienza la presentación. Images contiene archivos .GIF a los que se hace referencia en las páginas que están en First.

En la siguiente tabla se describe la función de las páginas de la carpeta unidadDelSistema\Archivos de programa\Windows Media Components\Tools\Presenter\First.

Nombre de archivo | Función
Bleft.asp | El archivo Default.asp llama a esta página y carga el Reproductor de Windows Media en la sección superior del marco izquierdo. Si no se ha instalado el reproductor, se instala. Este archivo utiliza los valores establecidos en el archivo Global.asa para localizar la secuencia de contenido.
Bottom.htm | Este archivo establece el borde inferior.
Default.asp | Ésta es la página a la que cambia el usuario automáticamente una vez alcanzada la hora de inicio de la presentación. El Reproductor de Windows Media aparece en el marco superior izquierdo y muestra al orador. Las diapositivas de la presentación aparecen en el marco derecho.
Download.asp | Los clientes de Netscape Navigator que no tienen instalado el Reproductor de Windows Media utilizan esta página. Proporciona instrucciones al usuario acerca de cómo descargar el reproductor manualmente.
Empty.htm | Es una página vacía que se proporciona para su personalización.
Le.asp | El archivo Default.asp llama a esta página para establecer los atributos de la tabla y continuar la descarga de las diapositivas en la memoria caché del cliente mediante una secuencia de inferior ancho de banda.
Led.htm | Esta página establece los bordes alrededor de la página.
Left.htm | Esta página establece el borde del marco izquierdo.
Right.htm | Esta página establece el borde del marco derecho.
Sdisplay.asp | Esta página llama a las diapositivas y las coloca en el marco derecho.
Tb.htm | Esta página establece el borde superior de la página.
Test.htm | Esta página se utiliza para probar la configuración de los marcos para un cliente de Netscape Navigator.
Top.htm | Esta página establece el borde superior del marco derecho.

Notas

  • Las páginas Active Server (ASP) utilizan el componente Browser Capabilities (capacidades del explorador) para determinar qué explorador realizó la petición de la página ASP. Microsoft mantiene archivos Browscap.ini actualizados que podrá utilizar para identificar los distintos exploradores. Se puede descargar el archivo Browscap.ini actual de la página de Microsoft BackOffice del sitio Web de Microsoft. En el sitio Web de Cyscape encontrará una versión del archivo BrowsCap.ini que se actualiza constantemente.
  • Si desea proporcionar contenido creado con el Presentador de Windows Media a equipos que utilicen Netscape Navigator, éstos deberán utilizar la versión 4.05 o posterior de Netscape Navigator. De no ser así, el contenido no se reproducirá correctamente con el Reproductor de Windows Media.


Personalizar Global.asa

El archivo Global.asa controla las propiedades de las variables de la presentación en línea. En Global.asa se define la hora de inicio y finalización de la presentación, si la presentación es de multidifusión, el título del evento y la dirección IP utilizada para transferir imágenes de las diapositivas a los usuarios.

La forma en que se configura este archivo difiere dependiendo de si la presentación necesita ser vista desde clientes de Netscape Navigator o no. La ubicación predeterminada del archivo Global.asa es unidadDelSistema\Archivos de programa\Windows Media Components\Tools\Presenter. Esta ruta de acceso será diferente si seleccionó una ubicación de instalación personalizada para los servicios de Windows Media.

La tabla siguiente enumera las variables definidas en Global.asa y sus funciones en el Presentador.

Variable | Función
NS_PLAY | Ruta de acceso de un reproductor que cumple con la norma de Netscape Navigator.
NS_CORE | Ruta de acceso para instalar el Reproductor de Windows Media si el cliente no lo ha instalado.
NS_FILE | Ruta de acceso para instalar el control Servicio de transferencia de archivos si el cliente no lo ha instalado.
MCSIControls | Ruta de acceso para instalar el control de cronómetro si no está instalado.
VS_FTS_IP | Dirección IP de la secuencia de transferencia de archivos de alto ancho de banda creada para transferir diapositivas mientras el usuario está en la página Web inicial, antes de la hora de inicio de la presentación. Reemplace la dirección IP que aparece entre comillas con su dirección IP. Se utiliza con presentaciones de multidifusión.
VS_FTS_PORT | Puerto a través del cual se envían las imágenes durante la transferencia de archivos de alto ancho de banda. Reemplace el puerto que aparece entre comillas con su puerto. Se utiliza con presentaciones de multidifusión.
LOW_FTS_IP | Dirección IP de la secuencia de transferencia de archivos de bajo ancho de banda creada para transferir diapositivas durante la presentación. Reemplace la dirección IP que aparece entre comillas con su dirección IP. Se utiliza con presentaciones de multidifusión.
LOW_FTS_PORT | Puerto a través del cual se envían las imágenes durante la transferencia de archivos de bajo ancho de banda. Reemplace el puerto que aparece entre comillas con su puerto. Se utiliza con presentaciones de multidifusión.
SHOW_TIME | Fecha y hora en que comenzará la presentación, especificadas en hora media de Greenwich (GMT). Por ejemplo, si la presentación está programada para el 8 de julio de 1998, a la 1 p.m. en California, la configuración sería: "07/08/1998 21:00:00". Se utiliza GMT para que la hora de la presentación y el contador hacia atrás del cronómetro se conviertan correctamente para los usuarios de diferentes zonas horarias.
SHOW_END_TIME | Fecha y hora en que terminará la presentación, especificada en GMT. Por ejemplo, si la presentación está programada para el 8 de julio de 1998, a las 3 p.m. en California, la configuración sería "07/08/1998 23:00:00". Se utiliza GMT para que la hora de la presentación y el contador hacia atrás del cronómetro se conviertan correctamente para los usuarios de diferentes zonas horarias.
EVENT_TITLE | Título de la presentación que aparece en la página Web inicial y en la página Web del Presentador.
ADMIN_NAME | Nombre de la persona responsable de dar soporte al suceso. Este nombre aparece en la página que se muestra si se produce un error. Es opcional.
ADMIN_EMAIL | Dirección de correo electrónico de la persona responsable de dar soporte al suceso. Esta dirección aparece en la página que se muestra si se produce un error. Es opcional.
VIDEO_WIDTH | Ancho en píxeles del objeto del reproductor. Debe corresponder al ancho real de la ventana del reproductor como lo define el Codificador de Windows Media.
VIDEO_HEIGHT | Alto en píxeles del objeto del reproductor. Debe corresponder al alto real de la ventana del reproductor como lo define el Codificador de Windows Media.
ASX | Ruta de acceso del archivo .ASX utilizado para la presentación. Por ejemplo, C:\Public\Presenter.asx. Este archivo .asx está incrustado en la página Web y se utiliza para localizar la secuencia de presentación.
MULTICAST | Esta variable determina si se utilizará una multidifusión de Windows Media. Escriba "True" si utiliza un servidor de Windows Media para la multidifusión de la presentación y de las secuencias de transferencia de archivos. Escriba "False" si utiliza otro método.


Programas de la línea de comandos

Al instalar las Herramientas de Windows Media, se le proporcionan cuatro herramientas de la línea de comandos para ayudarle a la creación de contenido. Las herramientas de la línea de comandos se invocan desde el símbolo del sistema del servidor. Esta sección proporciona la sintaxis de los comandos y las opciones disponibles.


Cómo...

Esta sección contiene los procedimientos que se llevan a cabo habitualmente al utilizar los programas de línea de comandos de las Herramientas de Windows Media.


Para convertir archivos .AVI y .MOV en archivos .ASF

  1. En el menú Inicio de Windows, seleccione Programas y, a continuación, haga clic en Símbolo del sistema.
  2. En Símbolo del sistema, ubique el directorio que contiene el archivo de origen de entrada y escriba el comando siguiente (sustituya los nombres de sus archivos .AVI, .MOV y .ASF):
    VidToAsf -in {nombreArchivo.avi | nombreArchivo.mov} -out nombreArchivo.asf

Nota

  • La opción -out es opcional. Si no especifica esta opción, VidToASF crea un archivo de salida con el mismo nombre que el archivo de entrada y agrega la extensión .ASF.


Para convertir un archivo de audio en un archivo .ASF

  1. En el menú Inicio de Windows, seleccione Programas y, a continuación, haga clic en Símbolo del sistema.
  2. En el Símbolo del sistema, ubique el directorio que contiene el archivo del origen de entrada y escriba el comando siguiente (sustituya los nombres de sus archivos .WAV o MP3 y .ASF):
     WavToASF -in nombreArchivo.[wav][mp3] -out nombreArchivo.asf

Nota

  • La opción -out es opcional. Si no especifica esta opción, WavToASF crea un archivo de salida con el mismo nombre que el archivo de entrada y le agrega la extensión .ASF.


Para preparar y utilizar la opción -audiofile

  1. Para extraer el audio del archivo de vídeo, utilice una herramienta de edición de vídeo o de audio (como VidEdit, Sound Forge o AVIEdit).
  2. Abra el archivo de audio extraído en la grabadora de audio de Microsoft Windows (o en una herramienta de edición de audio del equipo) y comprima el audio con uno de los códecs disponibles.
  3. Al convertir el archivo de vídeo en un archivo .ASF, utilice el archivo de audio que acaba de comprimir en la opción -audiofile.
    VidToASF -in {nombrearchivo.avi | nombrearchivo.mov} -audiofile {nombrearchivo.wav}-out nombrearchivo.asf

Nota

  • Para comprimir audio, utilice uno de los códecs estándar proporcionados con el sistema operativo Microsoft Windows o con el Reproductor de Windows Media de Microsoft. Si utiliza un códec que no esté residente en la máquina del usuario, el usuario no podrá escuchar el contenido de audio al reproducir el archivo .ASF.


Para utilizar ASFChop en un archivo .asf

  1. En el menú Inicio de Windows, seleccione Programas y, a continuación, haga clic en Símbolo del sistema.
  2. En la Línea de comandos, loalice el directorio que contiene el archivo fuente de entrada y escriba el comando siguiente (sustituyendo los nombres de sus archivos .asf)
     ASFChop -in nombreArchivo.asf -out nombreArchivo.asf
  3. Después de la opción -out, incluya cualquier otra opción deseada, como -duration, -end y -script. Después, presione ENTRAR.

Temas relacionados

  • Opciones de la línea de comandos de ASFChop

Nota

  • La opción -out es opcional. Si no especifica esta opción, ASFChop crea un archivo de salida con el mismo nombre que el archivo de entrada y agrega la extensión .ASF.


Para ejecutar ASFCheck en los archivos .ASF

  1. En el menú Inicio de Windows, seleccione Programas y, a continuación, haga clic en Símbolo del sistema.
  2. En Símbolo del sistema, ubique el directorio en que están guardados los archivos .ASF.
  3. En el símbolo del sistema, escriba
    asfcheck [/f] [/v] nombreArchivo.asf

    Si tiene muchos archivos .asf para comprobar y éstos están organizados en directorios, escriba

    asfcheck [/f] [/v] /s *.asf


VidToASF

La herramienta de la línea de comandos VidToASF convierte archivos de vídeo .avi o .mov a archivos .asf VidToAsf convierte un formato directamente en formato avanzado de secuencias. VidToASF no puede modificar los archivos de origen y no comprime el origen automáticamente de forma que el archivo .ASF resultante se ajusta a un ancho de banda particular. Para utilizar un archivo que no sea .AVI o .MOV (por ejemplo, un archivo MPEG) como origen de entrada, convierta dicho archivo en .MOV o .AVI antes de utilizar VidToASF. Si necesita modificar el archivo .AVI o .MOV (por ejemplo, para reducir la profundidad de color, ajustar el ancho o alto de la ventana o la calidad de la pista de audio) de forma que el archivo .ASF resultante se ajuste a un ancho de banda particular, efectúe todas las revisiones antes de utilizar VidToAsf.

Nota

  • Los archivos de Quicktime con datos no ACM o ICM no se pueden convertir en archivos .ASF. No se admite Quicktime VR.

Temas relacionados

  • Para convertir archivos .AVI y .MOV a formato .ASF


Opciones de línea de comandos de VidToASF

Estas opciones de la línea de comandos le permiten especificar una configuración determinada o incluir archivos adicionales en el archivo archivo .asf. Para ver en la pantalla una lista con las opciones, en el menú Inicio, seleccione Programas y haga clic en Símbolo del sistema, escriba el nombre del programa y presione ENTRAR.

Opción | Argumento de la opción | Descripción
-audio | secuencia | Especifica la secuencia que desea utilizar si el archivo de audio tiene más de una secuencia.
-audiofile | nombreArchivo | Especifica el archivo de vídeo que tomará el lugar del archivo de audio en el archivo de vídeo. Utilice esta opción para reemplazar la pista de audio de un archivo .AVI con un archivo .WAV comprimido.
-eccspan | on|off | Habilita la corrección de errores. La corrección de errores está activada, de forma predeterminada, para todos los archivos .asf de menos de 150.000 kilobits por segundo (Kbps) y desactivada de forma predterminada para todos los archivos .asf de más de dicha cifra. Para suplantar el valor predeterminado, establezca la opción eccspan de la línea de comandos.
-in | nombreArchivo.ext | Especifica el archivo de entrada de vídeo (.AVI o .mov) que está convirtiendo en archivo .ASF. Se trata de la única opción necesaria.
-leadtime | # de milisegundos | Especifica el tiempo que desea que espere el archivo .ASF una vez que está en el búfer, pero antes de reproducirse. El valor predeterminado es 1.000 milisegundos. Si va a convertir archivos .AVI con velocidades de bits menores (menos de 100 Kbps), aumente el tiempo de espera (hasta 3.000 milisegundos).
-out | nombreArchivo.asf | Especifica el nombre del archivo de salida. Si no proporciona un nombre al archivo de salida, VidToASF utiliza el nombre del archivo de entrada y sustituye la extensión .ASF.
-script | nombreArchivo | Especifica el nombre del archivo de comandos que se utilizará para agregar direcciones URL, secuencias de comandos, información de contenido o marcadores al archivo de salida.
-seekable | on|off | Avanza o retrocede rápidamente a través de un archivo .ASF. Cuando o crea un archivo .ASF, algunas veces, VidToASF emite una advertencia, "No se generó el índice", si no hay suficientes cuadros clave para que VidToASF genere un índice. Si esto sucede, no puede buscar en el archivo .ASF. Sin embargo, si utiliza la opción -seekable para activar la búsqueda, VidToADF permite buscar en el archivo .ASF, pero el archivo .ASF no parece estar perfecto durante la búsqueda. El valor predeterminado de esta opción es off.
-video | secuencia | Especifica la secuencia que se utilizará si el archivo de vídeo tiene más de una secuencia. Debido a que la mayor parte de los archivos de vídeo sólo tienen una secuencia, el valor predeterminado es utilizar la secuencia de vídeo estándar.
-wavespan | # de milisegundos | Especifica la longitud de tiempo (en milisegundos) sobre la que se extenderá el audio del archivo. Si se pierden paquetes, la extensión del audio ayuda a crear mejores resultados. A menos que esté seguro de que no se perderán paquetes, es mejor utilizar la configuración predeterminada (400 milisegundos).

Temas relacionados

  • VidToASF
  • WavToASF
  • Secuencias de comandos
  • Acerca de la opción de la línea de comandos de arhivo de audio


Opción de la línea de comandos -audiofile

La opción -audiofile tiene esta apariencia:

VidToASF -in nombreArchivo.avi -audiofile nombreArchivo.wav -out nombreArchivo.asf

La opción -audiofile indica a VidToASF que utilice el archivo de audio dado (nombreArchivo.wav) en lugar del audio actual del archivo .AVI o .MOV. Con esta opción, puede utilizar los códecs que vienen con las Herramientas de Windows Media para comprimir el archivo de audio. Muchas herramientas de edición de vídeo no contienen muchos códecs, ni aceptan los códecs incluidos en las Herramientas de Windows Media.

Temas relacionados

  • Preparar y utilizar opciones de archivo de audio


WavToASF

Use la herramienta de conversión de la línea de comandos WavToASF para convertir archivos de audio .WAV o .MP3 en archivos .ASF. WavToASF crea archivos .asf de audio que no contienen imágenes. WavToASF sigue las mismas convenciones que VidToASF ya que debe realizar la modificación o conversión del origen antes de convertirlo en un archivo .ASF. Los archivos .WAV o .MP3 de origen de entrada pueden estar comprimidos o descomprimidos. Si el archivo de entrada está comprimido, debe comprimirse con uno de los códecs residentes en el equipo. Se pueden utilizar muchos códecs diferentes con los formatos .WAV o .MP3. Para averiguar si el códec utilizado con el archivo de destino está en el equipo, intente reproducir el archivo. Si puede reproducirlo, puede utilizarlo para crear un archivo .ASF.

Nota

  • Si el origen es un archivo .MP3 con propiedades ID3, éstas se mantendrán en el archivo .ASF.

Temas relacionados

  • Convertir un archivo de audio a formato .asf


Opciones de línea de comandos de WavToASF

Las opciones de la línea de comandos le permiten especificar una configuración particular o incluir archivos adicionales en el archivo asf Para ver en la pantalla una lista con las opciones, en el menú Inicio, seleccione Programas y haga clic en Símbolo del sistema, escriba el nombre del programa y presione ENTRAR.

Opción | Argumento de la opción | Descripción
-eccspan | on|off | Activa o desactiva la corrección de errores. La configuración predeterminada es on.
-in | nombreArchivo.wav nombreArchivo.mp3 | Especifica el archivo de audio de entrada que se va a convertir a archivo .ASF.
-leadtime | # de milisegundos | Especifica el tiempo máximo antes de que comience la reproducción de un archivo. Si hay pérdida de paquetes, los valores más bajos producen a veces una extensión de audio más pobre. La configuración predeterminada es 4.000 milisegundos.
-out | nombreArchivo.asf | Especifica el nombre del archivo de salida. Si no proporciona un nombre al archivo de salida, WavToASF utiliza el nombre del archivo de entrada como nombre del archivo de salida y le agrega la extensión .ASF.
-script | nombreArchivo | Especifica el nombre del archivo de comandos que se utilizará si desea agregar direcciones URL, secuencias de comandos o marcadores al archivo de salida.

Temas relacionados

  • VidToASF
  • WavToASF
  • Acerca de la opción de la línea de comandos de arhivo de audio


ASFChop

ASFChop es una herramienta de la línea de comandos que puede utilizar para eliminar partes de un archivo .aasf y para agregar indización, secuencias de comandos, marcadores y propiedades generales a un archivo .asf. Al eliminar partes de un archivo se reduce la cantidad de tiempo requerida para transmitirlo. ASFChop crea un índice para dicho archivo de forma que se puede buscar (de forma similar al avance rápido) en el archivo. El Codificador de Windows Media se puede utilizar también para crear archivos .ASF en los que se pueden realizar búsquedas. Un archivo .ASF tiene que tener al menos 10 segundos de contenido para que se pueda indizar.

Temas relacionados

  • Archivos de secuencias de comandos
  • Marcadores
  • Secuencias de comandos
  • Indizador ASF de Windows Media
  • Utilizar ASFChop en su archivo


Opciones de línea de comandos de ASFChop

Las opciones de la línea de comandos le permite especificar una configuración particular o incluir archivos adicionales en el archivo asf Para ver en la pantalla una lista con las opciones, en el menú Inicio, seleccione Programas y haga clic en Símbolo del sistema, escriba el nombre del programa y presione ENTRAR.

Nombre de la opción | Argumento de la opción | Descripción
-duration | hora | Proporciona la duración de los archivos .ASF de salida. Nota: Utilice las opciones -duration o -end.
-eccspan | on|off | Activa o desactiva la corrección de errores. Si no se proporciona esta opción, se mantiene la configuración de corrección de errores del archivo de entrada.
-end | hora | Especifica la hora en que desea que finalice el archivo .ASF.
-in | nombreArchivo.asf | Especifica el archivo .ASF que desea modificar.
-out | nombreArchivo.asf | Especifica el nombre del archivo de salida. Si no proporciona un nombre al archivo de salida, ASFChop le dará al nuevo archivo el mismo nombre que al archivo de entrada.
-script | nombreArchivo | Especifica el nombre del archivo de comandos que se utilizará para agregar direcciones URL, secuencias de comandos, información de contenido o marcadores al archivo de salida.
-start | hora | Corta el comienzo de un archivo .ASF. Cuando establece el tiempo de inicio, ASFChop elimina todo el contenido antes de dicho tiempo. Cuando se guarda el archivo .ASF, ese tiempo se convierte en el comienzo del archivo .ASF.

Nota

  • Los tiempos de las opciones deben especificarse como hh:mm:ss.t, donde h son las horas, m los minutos, s los segundos y t las décimas de segundo. Por ejemplo, 04:12:28.9 es 4 horas, 12 minutos, 28 segundos y 0,9 décimas de segundo.


ASFCheck

ASFCheck es una herramienta de comprobación de archivos .ASF. Se puede utilizar ASFCheck para detectar y corregir algunos problemas que se producen en los archivos ASF de la versión 1.0. No es posible detectar o reparar todos los problemas con este programa. Este programa admite la utilización de un modo de ejecución por lotes, lo que permite comprobar todos los archivos .ASF de un directorio si escribe "*.asf" , en lugar del nombre de archivo, en la línea de comandos.

ASFCheck tiene tres opciones de la línea de comandos.

Opción | Descripción
/f | Instruye a ASFCheck para que repare el archivo, si es posible. Si se selecciona esta opción, se produce la reparación del archivo en el momento y el archivo reparado reemplaza al archivo dañado. Si desea mantener la versión anterior, realice una copia de seguridad del archivo en otro directorio.
/v | Instruye a ASFCheck para que proporcione una salida con una explicación.
/s | Instruye a ASFCheck para que recorra los subdirectorios, comenzando por el directorio actual.

Los mensajes predeterminados que crea ASFCheck se muestran en la ventana de la consola. Para guardarlos en un archivo, utilice la sintaxis del ejemplo siguiente:

asfcheck /f /v /s c:\*.asf > work.log 2> error.log

Este comando crea dos archivos: work.log y error.log. El archivo work.log contendrá los mensajes relacionados con la corrección del archivo; error.log contendrá los mensajes relacionados con los errores encontrados en el archivo .ASF.


Mensajes de finalización de ASFCheck

Mensaje | Resolución
Correcto: nombreArchivo.asf se procesó sin errores | El archivo .asf está listo para verse.
ADVERTENCIA: nombreArchivo.asf contenía algunos problemas menores. Se puede reproducir el archivo, pero algunos resultados pueden no ser óptimos. | Si no especificó la opción /f en ASFCheck, ejecute la herramienta de nuevo con la opción de reparación /f habilitada. Si se especificó /f, ASFCheck solucionó todos los problemas que pudo. Pruebe la calidad del archivo .asf antes de proporcionarlo a los visores.
ERROR: nombreArchivo.asf contenía algunos errores reparables. | Si no especificó la opción /f en ASFCheck, ejecute la herramienta de nuevo con la opción de reparación /f habilitada.
FATAL: nombreArchivo.asf no es válido o está dañado y no se puede reparar. | Debe volver a crear este archivo .ASF.
ERROR: se produjo un error al procesar nombreArchivo.asf. | Debe volver a crear este archivo .ASF.


Mensajes de error de ASFCheck

Mensaje | Resultado
Error inesperado. | ASFCheck no reconoce el error encontrado en el archivo .asf; es posible que no se ejecute este archivo correctamente.
No se puede abrir el archivo ASF. | Compruebe que escribió el nombre del archivo correctamente. A continuación compruebe que no hay otro programa utilizando el archivo .ASF . Finalmente, compruebe los atributos del archivo .ASF para asegurarse de que no es un archivo de sólo lectura.
El archivo especificado no es un archivo ASF válido. | Compruebe que el archivo tiene extensión .ASF. Si es así, no se creó el archivo con una herramienta de creación de archivos .ASF válida.
El archivo ASF está afectado por el error de sobrecarga de trabajo. | Este archivo puede producir resultados impredecibles al reproducirlo.
El archivo ASF parece estar truncado. | No toda la información especificada está disponible en el archivo .ASF. No se puede reproducir este archivo correctamente y el error no se puede corregir. Se debe volver a crear el archivo.
El archivo ASF se dañó. | ASFCheck no puede leer este archivo y no se puede reparar. No se puede reproducir este archivo y se debe volver a crear.
El campo preroll del archivo ASF es cero. | El contenido creado con versiones anteriores de los Servicios de Windows Media tiene el campo preroll establecido como cero. Para obtener un rendimiento óptimo, se debe restablecer el valor del campo preroll. ASFCheck puede corregir esta configuración.
El campo preroll del archivo ASF no es preciso. | Algunas herramientas establecen valores en el campo preroll que no son correctos para el contenido ASF. Para optimizar la calidad del contenido ASF, utilice ASFCheck para corregir este valor.
Se ha establecido un valor no válido en el campo preroll del archivo ASF. | Algunas herramientas establecen valores en el campo preroll que no son correctos para el contenido ASF. Para optimizar la calidad del contenido ASF, utilice ASFCheck para corregir este valor.
El archivo ASF contiene horas de presentación no válidas. | Las horas de presentación controlan cuándo se procesa el contenido. Si no son válidas, el archivo no se reproduce correctamente. Este problema no se puede solucionar. Se debe volver a crear el archivo .ASF.
El archivo ASF contiene objetos que se reproducen antes de enviarlos. | En este error, las horas de presentación no están correctamente sincronizadas. ASFCheck puede corregir este problema.
El archivo ASF contiene una secuencia de vídeo sin información del cuadro clave. El archivo ASF contiene un índice, por lo que será posible reconstruir parcialmente la información del cuadro clave. | Se requieren los cuadros clave para procesar el contenido. Si el archivo .ASF está indizado, se puede extrapolar la información del cuadro clave a partir del índice, de forma que se pueda reproducir el contenido.
El archivo ASF contiene una secuencia de vídeo sin información del cuadro clave. No se incluye un índice, por lo que no se puede reconstruir la información del cuadro clave. | Se requieren los cuadros clave para procesar el contenido. Si el archivo .ASF no está indizado, no se puede extrapolar la información del cuadro clave a partir del índice, de forma que no se puede reproducir el contenido.
No se encuentran algunos de los objetos del archivo ASF o no funcionan. | Cada objeto de un archivo ASF tiene un identificador de objeto que indica al reproductor cuándo debe procesar el contenido específico. Si algunos de estos identificadores no se encuentran o no funcionan, ASFCheck puede volver a ordenar el archivo ASF, de forma que se reproduzca correctamente.
Este archivo ASF contiene campos de identificadores de objetos no válidos. | Cada objeto de un archivo ASF tiene un identificador de objeto que indica al reproductor cuándo debe procesar el contenido específico. Si estos identificadores no son válidos, el reproductor no puede procesar el archivo. Este problema es irreparable. Se debe volver a crear el archivo .ASF.
Ocurrió un problema y no se pudo reparar el archivo .ASF | ASFCheck intentó arreglar el problema y no pudo llevar a cabo el proceso. Esto suele ser debido a que el archivo está designado como de sólo lectura. Asegúrese de que ninguno de los archivos .ASF que se va a comprobar está marcado como de sólo lectura antes de utilizar ASFCheck.
El sistema no puede encontrar el archivo. | Compruebe que la ruta y el nombre de archivo proporcionados a ASFCheck son los correctos.
No se encontraron archivos coincidentes. | Los caracteres comodín de * y ? no son compatibles con ASFCheck. Cuando se utilizan en el parámetro del nombre de archivo, ASFCheck buscará en el directorio especificado el archivo que coincida con las especificaciones. Este mensaje aparece cuando no hay nombres de archivo que coincidan con los parámetros especificados.
Ruta de acceso no válida. | La ruta de acceso especificada no es correcta o no existe. Compruebe la ruta especificada por si tuviera errores de escritura. Asegúrese también de que tiene acceso a la unidad especificada si los archivos .ASF no están en el equipo local.
Directorio no válido. | El directorio especificado no es correcto o no existe.
No se pudo abrir el archivo porque otro proceso lo está utilizando. | El archivo está bloqueado por otra aplicación. Asegúrese de que no hay ningún archivo .ASF en uso antes de ejecutar ASFCheck.
Los datos de corrección de errores no son válidos. | Los datos de corrección del error del archivo .ASF no son correctos. ASFCheck puede reparar este problema.
Se detectaron datos adicionales no indizados al final del archivo. | El archivo .ASF contenía algunos datos dañados al final del archivo.
No se pudieron encontrar todas las secuencias que se suponía que debían estar en el archivo. | Se han perdido una o más de las secuencias indicadas en el encabezado ASF. Este archivo no se reproducirá como se esperaba y no se puede reparar. Si la calidad de reproducción no es aceptable, vuelva a crear el archivo .ASF.
No se pudo leer un Id. de secuencia. | No se pudo leer el Id. de secuencia de una carga de trabajo tanto en la secuencia de vídeo como en la de audio. Este archivo está dañado y no se puede reparar. Debe volver a crear este archivo .ASF.
Un Id. de secuencia no es válido. | El Id. de secuencia de una carga de trabajo tanto en la secuencia de vídeo como en la de audio no tiene un objeto de propiedades de secuencia correspondiente en el encabezado de archivo ASF. Este problema no tiene solución. Debe volver a crear este archivo .ASF.
Se trata de un archivo ASF con bandas. | Sólo sirve a fines informativos.
Los índices no señalan al cuadro clave apropiado. | Los índices de la secuencia de vídeo deben señalar al cuadro clave más reciente. Este problema tiene solución. Debe volver a crear este archivo .ASF.
No se registró el OCX de ASFChop. | ASFCheck utiliza ASFChop.ocx para corregir los índices en archivos .ASF. ASFChop debe estar instalado en el equipo en que se ejecute ASFCheck.
Se registró una versión errónea del OCX de ASFChop en este sistema. | ASFCheck utiliza ASFChop.ocx para corregir los índices en archivos .ASF. ASFChop debe estar instalado en el equipo en que se ejecute ASFCheck. Si recibe este error, quite y vuelva a instalar las Herramientas de Windows Media.
Este archivo ASF no es válido porque contiene un encabezado con un tamaño mayor que 64 kilobytes. | El tamaño del encabezado ASF, incluidos secuencias de comandos y marcadores, debe ser menor que 64 kilobytes (KB). Este problema no tiene solución. Debe volver a crear este archivo .ASF.


Otras herramientas de Windows Media

Esta sección proporciona información acerca de las siguientes Herramientas de Windows Media:

  • Publicar en formato ASF de Windows Media
  • Autor de Windows Media
  • Indizador de formato ASF de Windows Media


Publicar en formato ASF de Windows Media

Publicar en formato ASF de Windows Media para Microsoft PowerPoint 97 es una útil herramienta que permite convertir presentaciones de PowerPoint en archivos .asf.

Al convertir una presentación de PowerPoint en formato .ASF lo pone a disposición de más usuarios y permite que los usuarios tengan acceso a la presentación desde cualquier ubicación de la red. Una vez convertida en formato .ASF, es posible reproducir su presentación desde:

  • Un servidor HTTP de Internet
  • Una intranet corporativa
  • Un servidor de Windows Media
  • Un equipo local

Si desea transmitir la presentación desde una página Web, debe crear un archivo .ASX. Este archivo de texto transfiere el control de la secuencia de datos desde el explorador HTTP al Reproductor de Windows Media de Microsoft, de forma que se puede transmitir los datos. Consulte al administrador del sistema acerca de cómo debe colocar la presentación ASF en un servidor de Internet o de una intranet.

Si desea transmitir la presentación desde un Servidor de Windows Media, tiene varias opciones. Para obtener más información acerca de cómo guardar y transmitir la presentación desde un servidor de Windows Media, consulte la documentación que se instala con los servicios de Windows Media o consulte al administrador del sistema de Windows Media.

Dado que el Reproductor de Windows Media es extensible, puede incrustar las presentaciones ASF en aplicaciones escritas en Microsoft Visual Basic, Visual C++ o en C y vincularlas con controles ActiveX. Esto le permite activar presentaciones de secuencias ASF desde páginas Web personalizadas de múltiples maneras.

Si desea obtener más información acerca de cómo utilizar Publicar en formato ASF de Windows Media, consulte la Ayuda de Publicar en formato ASF.


Autor de Windows Media

Microsoft desarrolló el Autor de Windows Media junto con Digital Renaissance, Inc. Si desea obtener más información acerca de Digital Renaissance, Inc. y sus productos, visite el sitio Web de Digital Renaissance, Inc..

El Autor de Windows Media es una herramienta flexible que se utiliza para crear archivos .asf a partir de archivos existentes de imágenes y de audio. Un uso común del Autor de Windows Media es la creación de archivos de audio ilustrados. A diferencia de otras herramientas que convierten un archivo u origen en directo existente en archivos .asf, Autor de Windows Media combina varios tipos de medios en un archivo .asf. Proporciona dos velocidades de bits predefinidas: 28.8 y 56 kilobits por segundo (Kbps). Puede usar también códecs para comprimir archivos de imagen y de audio, lo que hace más fácil la condensación de archivos de varios medios para que puedan ajustarse al ancho de banda deseado. El Autor de Windows Media no permite generar archivos .asf demasiado grandes para el ancho de banda disponible.

Utilice el Autor de Windows Media para combinar archivos de origen, como imágenes y audio, con direcciones URL y secuencias de comandos. Con esta combinación de medios, puede crear archivos audiovisuales dinámicos y completamente interactivos que puedan llevar a un usuario a cualquiera de los sitios de Internet o de una intranet.

El Autor de Windows Media no acepta como origen vídeo almacenado o en directo. Para convertir los archivos existentes (como archivos .avi, .wav, .mov o .mp3 ) en archivos .asf sin cambiar la cantidad de compresión, use VidToASF o WavToASF. Utilice el Codificador de Windows Media para utilizar vídeo en directo para crear archivos .asf. El Codificador de Windows Media también se emplea cuando tiene archivos (como por ejemplo archivos .AVI, .WAW, .MOV o .MP3) que no están comprimidos o con los que desea utilizar un códec diferente para comprimir el contenido a fin de crear un archivo .ASF que se ajuste a un ancho de banda de destino específico.

Para obtener instrucciones acerca de cómo usar el Autor de Windows Media para crear archivos .asf, consulte la Ayuda del Autor de Windows Media.

Nota

  • El Autor de Windows Media permite utilizar archivos de proyecto de Editor ASF de Windows Media, versión 2.0.

Temas relacionados

  • Secuencias ASF


Indizador de formato ASF de Windows Media

El Indizador de formato ASF de Windows Media es una herramienta que se utiliza para agregar propiedades, marcadores, secuencias de comandos e índices a un archivo .asf existente. El Indizador de formato ASF de Windows Media requiere que esté instalado el Reproductor de Windows Media de Microsoft antes de usar la herramienta.

Cuando utiliza esta herramienta, el archivo .asf se reproduce en la ventana de presentación, y, en cualquier momento, se pueden agregar marcadores y secuencias de comandos al archivo mediante un clic en el botón adecuado.

Para agregar propiedades, complete los campos de propiedad que se suministran. Las propiedades disponibles son:

  • Título
  • Autor
  • Copyright
  • Descripción
  • Clasificación

La indización del archivo se produce automáticamente cuando se abre en el Indizador de formato ASF. La indización del archivo permite a los usuarios avanzar y retroceder rápidamente las secuencias cuando se ven desde un punto de publicación a petición de Windows Media.

Los marcadores y las secuencias de comandos existentes se pueden modificar mediante el Indizador de formato ASF.

El Indizador de formato ASF se puede usar también para recortar los tiempos de inicio y de fin de los archivos .asf, de forma que no se incluya contenido superfluo.

Temas relacionados

  • Marcadores
  • Secuencias de comandos


El Reproductor de Windows Media

El Reproductor de Windows Media es la aplicación de software cliente que se utiliza para recibir secuencias en formato ASF desde un servidor de Windows Media. Un usuario puede utilizar el Reproductor de Windows Media para tener acceso directo a las secuencias, aunque también es posible iniciar el Reproductor de Windows Media si se abre un archivo ASX. El Reproductor de Windows Media se utiliza para reproducir muchos otros tipos de contenido. Para saber cómo utilizarlo con otras aplicaciones, consulte la Ayuda del Reproductor de Windows Media.


Utilizar el Reproductor de Windows Media

Hay tres formas de utilizar el Reproductor de Windows Media de Microsoft para entregar contenido ASF a los usuarios. Como programa independiente, iniciándolo desde un hipervínculo o incrustado en una página Web.

El contenido ASF puede encontrarse como archivos .ASF o secuencias en formato ASF. El Reproductor de Windows Media puede abrir y reproducir los archivos .ASF guardados, pero no se transmiten al reproductor. Sólo el contenido entregado directamente al cliente desde un servidor de Windows Media se transmite al Reproductor de Windows Media.


Tener acceso a contenidos desde el Reproductor de Windows Media independiente

Cuando instala el Reproductor de Windows Media, éste configura el equipo para crear asociaciones con tipos específicos de medios, basadas en el protocolo y en las extensiones de archivos. Esto significa que puede utilizar el Reproductor de Windows Media para tener acceso a cualquier tipo de archivo que le ayude a recibir contenido ASF.

Para tener acceso a contenido con el Reproductor de Windows Media, haga clic en Abrir en el menú Archivo y, a continuación, escriba una ubicación en el cuadro de diálogo Abrir.

Puede utilizar muchos protocolos diferentes y abrir muchos tipos de contenido con el Reproductor de Windows Media. Para obtener más información acerca de cómo abrir contenido desde aplicaciones distintas al Reproductor de Windows Media, consulte la Ayuda del Reproductor de Windows Media.

Reproducir archivos .ASF almacenados

Para reproducir un archivo archivo .asf almacenado desde un servidor de Windows Media, en el cuadro de diálogo Abrir, escriba:

mms://servidor/archivo.asf

Si el servidor de Windows Media está configurado para transmitir mediante HTTP, debería escribir:

http://servidor/archivo.asf

El servidor transmite el archivo desde la carpeta de contenido ASF (por ejemplo, UnidadDelSistema\ASFRoot) al cliente. Cuando un servidor de Windows Media tiene habilitada la transmisión HTTP, el servidor sigue utilizando la carpeta de contenido ASF como directorio principal; el servidor no utiliza la raíz virtual HTTP (por ejemplo, UnidadDelSistema\wwwroot) como directorio principal.

Reproducir contenido mediante archivos ASX

Utilice archivos ASX para tener acceso a archivos .ASF desde un servidor de Windows Media, puntos de publicación de unidifusión o estaciones de multidifusión. El archivo ASX es un puntero al contenido ASF. Para utilizar archivos ASX con un reproductor independiente, debe conocer la ruta de acceso del archivo ASX. La forma más común de tener acceso a archivos ASX con el reproductor independiente consiste en escribir la ruta de acceso del archivo en el cuadro de diálogo Abrir. Esta ruta de acceso puede ser una carpeta compartida o un sitio Web. Por ejemplo, para tener acceso a una carpeta compartida, escriba:

\\servidor\share\archivo.asx

O bien, para tener acceso a un sitio Web escriba:

http://servidor/archivo.asx

El Reproductor de Windows Media descarga el archivo ASX, analiza la ruta de acceso del contenido ASF y, a continuación, transmite el contenido desde el servidor.

Reproducir contenido desde páginas HTML

Cuando una página HTML contiene un reproductor incrustado (el control ActiveX de Microsoft), no necesita utilizar el reproductor independiente para tener acceso a la página Web. Si decide utilizar este método, puede hacerlo, pero el método preferido consiste en abrir el explorador Web y tener acceso a la página HTML. Para tener acceso a páginas Web con el Reproductor de Windows Media, en el cuadro de diálogo Abrir, escriba:

http://ServidorWeb/página.htm

El Reproductor de Windows Media pasa la dirección URL al explorador local, que abre y encuentra la página Web. Una vez cargada la página HTML, aparecerá el Reproductor de Windows Media incrustado y comienza a procesar el contenido ASF asociado con el reproductor.


Iniciar el Reproductor de Windows Media desde un vínculo

Hay dos formas de iniciar el Reproductor de Windows Media desde un vínculo en una página Web o una aplicación Web y recibir el contenido transmitido desde un servidor de Windows Media:

  1. Puede habilitar la transmisión HTTP y utilizar directamente vínculos de HTTP al contenido ASF. Debe utilizar las transmisiones de HTTP para transmitir contenido a través de un servidor de seguridad.
  2. Puede utilizar vínculos de HTTP a archivos .ASX, que contienen instrucciones que utiliza el Reproductor de Windows Media para tener acceso al contenido ASF. El archivo .ASX debe residir en un servidor de HTTP, como Internet Information Server (IIS), en un directorio al que el usuario pueda tener acceso.

Para ejecutar el Reproductor de Windows Media desde un vínculo de una página o aplicación Web con un metarchivo .ASX, cree una dirección URL en el código HTML, similar al siguiente ejemplo:

<A HREF=http://server/file.asx>

Este vínculo enviará al cliente al archivo .ASX, que a su vez indicará al reproductor el punto de acceso al contenido.


Incrustar el control ActiveX del Reproductor de Windows Media

Puede incrustar el control ActiveX del Reproductor de Windows Media de Microsoft en una página Web o en otro contenedor de aplicaciones que admita ActiveX, de forma que el reproductor no se inicia como aplicación independiente. En su lugar, la secuencia de contenido que especifique en las propiedades del control se reproduce en el marco del explorador una vez procesada la página. Esto le permite tener más control sobre el modo en que el usuario recibe el contenido transmitido y también constituye una forma sencilla de proporcionar el Reproductor de Windows Media a usuarios que no lo han instalado en sus equipos.

Cuando un usuario tiene acceso a una página en la que está incrustado el control, aparece un certificado que identifica al editor del control. El certificado pregunta al usuario si acepta la descarga del control o si desea continuar procesando la página sin descargar el control. No se entrega el contenido si el control no está instalado.

Puede establecer las propiedades del control mediante la etiqueta <OBJECT> del lenguaje HTML, para definir qué archivo .ASF, punto de publicación o emisora se va a abrir, así como la forma en que se reproducirá. También puede utilizar las secuencias de comandos de Microsoft Visual Basic para definir las propiedades del control como, por ejemplo, los botones que se mostrarán. La siguiente etiqueta <OBJECT> de HTML muestra el Id. de clase del Reproductor de Windows Media del control y algunas de sus propiedades.

<OBJECT CLASSID="clsid:22d6f312-b0f6-11d0-94ab-0080c74c7e95F"
HEIGHT=240
WIDTH=320
NAME=Msshow1
ID=Msshow1
>
<PARAM NAME="FileName" VALUE="mms://MSserver/Msshow1.asf">
</OBJECT>

Si desea obtener más información acerca del control del Reproductor de Windows Media y de sus propiedades, consulte Microsoft Windows Media Player Control SDK en el sitio Web de Microsoft.

La forma en que establezca las propiedades determinará el funcionamiento del Reproductor de Windows Media. El parámetro NombreArchivo identifica el archivo .ASF que se reproduce. Establezca el valor de este parámetro como una dirección URL como si fuera a reproducir el archivo .ASF desde la opción Abrir del menú Archivo del Reproductor de Windows Media.


Códecs de Windows Media

Las herramientas de creación de contenido en formato ASF utilizan algoritmos de compresión y descompresión (códecs) para comprimir los medios de audio y de vídeo, a partir de orígenes en directo o de otros formatos multimedia, para ajustarse al ancho de banda disponible de una red. El Reproductor de Windows Media de Microsoft, utiliza el mismo códec para descomprimir la información de ASF antes de reproducirla. Se aplica códecs independientes a la porción de audio y de vídeo de la secuencia ASF.

Se ha diseñado los códecs para comprimir sus archivos de origen a una velocidad de bits determinada, por lo que no se puede utilizar todos los códecs par comprimir un archivo a un tamaño determinado. La diferencia en la razón de compresión también implica una diferencia en la calidad de la reproducción. Los códecs que no comprimen mucho el origen hacen que normalmente éste suene y se vea más completo y dinámico.

El Codificador de Windows Media puede utilizar cualquier códec instalado en el equipo; sin embargo, el equipo en que está instalado el Reproductor de Windows Media también debe contar con el códec necesario para poder reproducir el archivo .asf o la secuencia ASF. El Codificador de Windows Media no incluye el mismo número de códecs que el Reproductor de Windows Media.


Códecs instalados con el Codificador de Windows Media

El Codificador de Windows Media instala en el equipo varios códecs de audio y de vídeo. Los códecs se instalan también como parte del sistema operativo y, en algunas ocasiones, se agregan al descargar un archivo de Internet. El Codificador de Windows Media puede utilizar cualquier códec instalado en el sistema para codificar contenido ASF; sin embargo, el Reproductor de Windows Media de Microsoft debe tener acceso al mismo códec para descodificar el contenido. Para estar seguro de que el Reproductor de Windows Media podrá descodificar el contenido, elija los códecs que se instalan con el Codificador de Windows Media.

Temas relacionados

  • Tabla de códecs de audio
  • Tabla de códecs de vídeo
  • Códecs básicos del Reproductor de Windows Media
  • Códecs de la instalación completa del Reproductor de Windows Media


Códecs de audio

Los códecs siguientes se instalan con el Codificador de Windows Media. Se recomienda el códe de audio de Windows Media para la mayoría del contenido, ya que normalmente produce la mejor calidad de sonido en un archivo multimedia que mezcla contenido basado en tipos multimedia y música. Sin embargo, si crear secuencias de ancho de banda pequeño (menos de 20 Kbps) que sólo tiene contenido de audio de voz, se pueden obtener mejores resultados mediante el códec Sipro Labs ACELP.net codec.

Códec | Descripción
Códec de audio de Windows Media versión 2 El códec de audio de Windows Media es un códec muy escalable que proporciona contenido de audio de alta calidad en estéreo y mono en una gran variedad de anchos de banda. Se puede utilizar para codificar audio para anchos de banda entre 5 y 160 kilobits por segundo (Kbps). El intervalo de la frecuencia de muestro de audio abarca desde 8 kilohercios (kHz) hasta 48 kHz. Así, puede elegir la mejor combinación entre ancho de banda y frecuencias de muestreo para el contenido.

También es muy tolerante a las pérdidas, por lo que es excelente para transmitir el contenido. Su gran claridad y profundidad tonal hacen que el contenido musical suene mejor que con otros códecs similares.

Además, es posible utilizarlo para quitar una pista de audio de un elemento si se selecciona el formato de audio de 0 kilobits por segundo (Kbps). Si crea archivos de audio para ser descargados, el códec de audio de Windows Media es una gran opción, pues proporciona sonido casi con calidad de CD y necesita la mitad de la frecuencia de datos de la mayoría de los códecs.

Códec de audio de Windows Media versión 1 | A este códec se le conoce también como MSAudio. Se proporciona para hacer compatible la reproducción del contenido existente, pero no se debe usar para codificar contenido.
FhG MPEG Layer-3 | Moving Picture Experts Group (MPEG) Layer-3, creado por FhG, es un códec de audio mono de alta fidelidad, que resulta particularmente útil para el audio con calidad de CD de una intranet o de Internet. MPEG Layer-3 se suministra con varios formatos, según el ancho de banda de red que seleccione.
Sipro ACELP.net | ACELP es un códec de baja velocidad de bits que proporciona una excelente compresión de voz. ACELP se suministra con varios formatos de audio, según el ancho de banda de red que seleccione.
Voxware | Voxware proporciona audio de alta calidad mediante velocidades de bits de intervalo bajo a medio. Se suministra con diversos formatos de audio mono y estéreo entre los que se puede elegir, según el ancho de banda de la red. También es idóneo para codificar contenido mono sólo de voz a velocidades de bits extremadamente bajas.

Temas relacionados

  • Utilizar el códec de audio de Windows Media
  • Descripción de los archivos de audio de Windows Media


Códecs de vídeo

Los siguientes códecs de vídeo se instalan con el Codificador de Windows Media. Siempre que sea posible, utilice el códec de vídeo Microsoft MPEG-4, versión 3, para codificar el contenido de vídeo.

Códec | Descripción
Códec de vídeo Microsoft MPEG-4, versión 1 | El códec Microsoft MPEG-4 es un códec de vídeo de velocidad de bits de intervalo bajo o medio. La ventaja de este códec consiste en que se ajusta a los estándares del Grupo de expertos de imágenes en movimiento (MPEG, Moving Picture Experts Group). Utilice la versión 1 para proporcionar contenido a servidores o reproductores de la versión 2.0.
Códec de vídeo Microsoft MPEG-4, versión 2 | El códec Microsoft MPEG-4 es un códec de vídeo de velocidad de bits de intervalo bajo o medio. La versión 2 se proporciona por motivos de compatibilidad con el contenido y las configuraciones del codificador creadas con la versión 3.0 de las Herramientas de Windows Media.
Códec de vídeo Microsoft MPEG-4, versión 3 | Microsoft MPEG-4 es un códec de vídeo muy escalable que admite un amplio intervalo de anchos de banda de red. La versión más reciente del códec de vídeo Microsoft MPEG-4 está optimizada para los procesadores Pentium III de Intel. Con este códec se obtiene codificación a petición más rápida y velocidades de datos más altas, mayor resolución y mayor velocidad de cuadro para la codificación en directo. Si utiliza un procesador Pentium II de Intel el rendimiento de la codificación de vídeo será aún mayor. La versión 3 del códec también admite múltiples anchos de banda y codificación para ancho de banda alto. Además, incluye el filtro para reducción del efecto mosaico, que mejora la calidad del contenido al eliminar el efecto mosaico que produce la compresión de vídeo, en especial en velocidades de transferencia de datos bajas, como 28.8 Kbps.
Microsoft H.263 | H.263 es útil para proporcionar vídeo con velocidad de bits de intervalo bajo o medio. Este códec está optimizado para conferencia por vídeo, por lo que resulta una buena elección para presentaciones y otro contenido de vídeo de bajo movimiento.


Códecs instalados con el Reproductor de Windows Media

Existen dos opciones de instalación para el Reproductor de Windows Media: una instalación completa y una instalación reducida. La instalación completa contiene todos los códecs que Microsoft está autorizado a proporcionar, pero es voluminosa y tarda bastante tiempo en descargarse. La instalación reducida contiene un conjunto mínimo de códecs y se puede cargar mucho más rápidamente. Las secciones siguientes enumeran los códecs que forman parte de cada instalación. Si no está seguro de que un equipo cliente contenga el códec necesario para procesar un archivo .asf o secuencias ASF, puede utilizar la característica de código base Microsoft ActiveX. Así obliga a una página Web a comprobar si el equipo cliente contiene los códecs necesarios para reproducir el archivo .asf o la secuencia ASF.

Temas relacionados

  • Códecs de la instalación completa del Reproductor de Windows Media
  • Códecs básicos del Reproductor de Windows Media


Códecs de la instalación completa del Reproductor de Windows Media

Los códecs siguientes se instalan como parte de la instalación completa del Reproductor de Windows Media de Microsoft:

  • Códecs de vídeo Microsoft MPEG-4 versión 1, versión 2 y versión 3
  • Códec de audio FhG MPEG Layer-3
  • Códec de audio Voxware
  • Códec de audio de Windows Media versión 1 y versión 2
  • Sipro ACELP.net


Códecs básicos del Reproductor de Windows Media

Los códecs siguientes se instalan como parte de la instalación reducida del Reproductor de Windows Media de Microsoft.

  • Códec de audio Voxware
  • Códec de audio FhG MPEG Layer-3
  • Códec de audio de Windows Media versión 1 y versión 2
  • Códec de vídeo Microsoft MPEG-4


Glosario de las tecnologías de Windows Media

Este glosario contiene muchos términos que le ayudarán a comprender las Tecnologías de Microsoft Windows Media.

  • A—B
  • C—H
  • I—O
  • P—T
  • U—Z

A—B

a petición
Describe contenido multimedia almacenado que está disponible para transmitirse en secuencias en un sistema de Servicios de Windows Media. Los Servicios de Windows Media pueden transmitir contenido almacenado, desde un punto de publicación, o contenido en directo, mediante el Codificador de NetShow.
ActiveX
Tecnología de Microsoft que permite que programas diferentes compartan información. ActiveX amplía la arquitectura basada en Microsoft Windows para incluir características y capacidades de Internet e intranets corporativas. Los programadores la utilizan para conseguir la interactividad del usuario en programas y páginas de World Wide Web.
Administrador de compresión de audio (ACM)
Un administrador de controladores de dispositivos que controla qué aplicaciones son necesarias para reproducir o grabar sonidos. ACM administra los siguientes tipos de controladores:
  • Controladores de compresión y descompresión (códec)
  • Controladores de conversión de formato
  • Controladores de filtros

Es posible que un archivo creado en un equipo que no utiliza Windows no contenga un códec ACM, lo que impediría utilizarlo con las Tecnologías de Windows Media.

Administrador de Windows Media
Aplicación administrativa basada en Web para supervisar el uso en tiempo real de los servicios componentes de Windows Media, administrar contenidos y configurar el sistema.
alcance
En multidifusión, el ámbito de una secuencia. El Administrador de Windows Media permite que el usuario defina el alcance de una multidifusión. El alcance de una secuencia de multidifusión puede establecerse de forma que llegue sólo a una subred intermedia o a todo Internet. El alcance también es igual al tiempo de vida (TTL).
alias
Un nombre que sustituye una dirección URL. Por ejemplo, cuando crea una emisora, puede utilizar un alias para especificar la información que define la conexión entre los componentes del Servidor de Windows Media y el Codificador de Windows Media. Por ejemplo, Secuencia1 es el alias de la dirección URL, msbd://servidor:puerto. Al crear una emisora, puede escribir Secuencia1 en el cuadro de diálogo Alias. Los componentes del servidor resuelven este alias cotejándolo con la definición del decodificador. Los alias son útiles para no tener que memorizar direcciones URL que cambian constantemente. Mientras conozca el nombre del alias, la dirección URL podrá resolverse correctamente.
ancho de banda
La cantidad de datos que pueden transmitirse en una cantidad de tiempo fija. En redes informáticas, un mayor ancho de banda significa una transferencia de datos más rápida. El ancho de banda de la red se expresa en bits por segundo (bps).

En el entorno de los Servicios de Windows Media, el Administrador de Windows Media puede especificar restricciones en el ancho de banda para una serie de funciones, incluidos el valor máximo del ancho de banda agregado de unidifusión desde un servidor, el ancho de banda máximo para una sola secuencia de unidifusión desde un servidor y anchos de banda continuos utilizados por una transferencia de archivos de multidifusión desde un servidor.

anuncio
Un sencillo archivo .asx que contiene información acerca de la dirección URL de una secuencia. El Administrador de Windows Media crea los archivos de anuncio al crear un punto de publicación de unidifusión o una emisora de multidifusión. El cliente carga el archivo de anuncio y, a continuación, abre la secuencia ASF del punto de publicación de unidifusión o extrae de un archivo .nsc la dirección URL de acceso a la secuencia ASF y reproduce un programa en la emisora de multidifusión.
API de servidor de Internet (ISAPI)
Entorno de trabajo para crear una biblioteca de vínculos dinámicos (DLL) para proporcionar funcionalidad de servidor de Internet. Los Servicios de Windows Media utilizan ISAPI para proporcionar una de las opciones para seguridad.
Archivo de audio de Windows Media (.wma)
Un tipo especial de archivo de formato de secuencia que se utiliza únicamente con audio codificado con el códec de audio de Windows Media.
archivo de emisora de Windows Media (.NSC)
Archivo que describe una emisora para el reproductor. El reproductor tiene acceso al archivo de emisora indirectamente por medio de un archivo .ASX que dirige al cliente a un archivo .NSC específico.
Archivo de formato avanzado de secuencias (.ASF)
Archivo de audio o de vídeo con formato ASF.
archivo de programa de Windows Media (.NSP)
Archivo que contiene información acerca de un programa de los servicios de Windows Media, utilizado principalmente para hacer copias de seguridad y restaurar definiciones de programas de los servicios de Windows Media.
Archivo del Redirector de audio de Windows Media (.wax)
Un tipo especial de metarchivo .ASX que se utiliza con archivos .WMA. El archivo .WAX incluye información acerca de la ubicación del archivo .WMA en el Servidor de Windows Media y de sus propiedades.
archivo descriptor de secuencia ASF (.ASD)
Archivo de configuración creado y leído por el Codificador de Windows Media. Contiene la configuración del codificador que describe las características de una secuencia multimedia. El archivo también lo lee el servicio de emisoras de Windows Media para definir el formato de secuencia que admite una emisora determinada.
archivo redirector de secuencia ASF (.ASX)
Un metarchivo ASX que proporciona información que el Reproductor de Windows Media de Microsoft utiliza para recibir secuencias de unidifusión, de multidifusión y otros elementos multimedia compatibles, desde una intranet o desde Internet. El reproductor de Windows Media carga rápidamente estos archivos, que contienen información útil para cumplir los objetivos siguientes:
  • Transferir el control del explorador HTTP al Reproductor de Windows Media, de forma que las secuencias se pueden dirigir al Reproductor de Windows Media.
  • Proporcionar un anuncio que el Reproductor de Windows Media podrá utilizar para obtener acceso a un programa de una emisora de Windows Media.
  • Proporcionar referencias de secuencias y las reglas de conversión de protocolo que utiliza el Reproductor de Windows Media para procesarlas.
  • Proporcionar una lista de reproducción que define el orden de transmisión de las secuencias al Reproductor de Windows Media.

ASFCheck
Herramienta de la línea de comandos que se utiliza para detectar y reparar algunos problemas que se suelen encontrar en archivos ASF versión 1.0.
ASFChop
Herramienta de la línea de comandos que se utiliza para recortar el principio o el final de una secuencia ASF almacenada por el Codificador de Windows Media.
ASFEditor
Consulte Autor de Windows Media.
atributo
En un archivo .ASX, un calificador que describe una propiedad de un elemento ASX. Por ejemplo, un archivo .ASX puede incluir el elemento Repeat que contiene el atributo Count. Este elemento y atributo en particular definen el número de veces que el cliente repite la reproducción de un fragmento del contenido o de la lista de reproducción.
audio ilustrado
Secuencia que combina contenido de audio con imágenes sincronizadas para constituir una presentación de diapositivas en pantalla que funciona con anchos de banda reducidos.
autenticación
Proceso de comprobación de la información de inicio de sesión de un cliente. Es posible configurar un Servidor de Windows Media para que autentique a los clientes antes de concederles acceso al contenido o a las secuencias ASF.
Autor de Windows Media
Herramienta de interfaz gráfica para crear y comprobar audio ilustrado. Se diseñó para combinar y sincronizar archivos de audio y de imagen. Mediante su uso, el autor puede administrar objetos (sonidos, imágenes y direcciones URL) de forma que aparezcan en el momento adecuado durante la reproducción. Utiliza tecnología de Digital Renaissance, Inc.
autorización
Proceso de conceder o denegar el permiso de acceso a los clientes. Es posible configurar un Servidor de Windows Media para que autorice las peticiones de contenido ASF de los clientes.
búfer
Área de memoria reservada para su uso como almacén intermedio, en el que los datos se mantienen temporalmente para transferirlos entre dos ubicaciones. Un búfer garantiza un flujo de datos ininterrumpido entre dos equipos.

C—H

canal
Consulte emisora.
carga de trabajo
Unidad de datos que contiene uno o varios objetos de datos de secuencias.
cliente
Normalmente, el software que realiza peticiones en comunicaciones cliente-servidor. El software del cliente solicita conexiones y se comunica con servidores.
Cliente de Windows Media
Control ActiveX, llamado Reproductor de Windows Media de Microsoft, que recibe y genera contenidos ASF desde los componentes del servidor de Windows Media. El cliente puede estar en el mismo equipo que el servidor o en otro equipo.
códec
Abreviatura de compresor y descompresor. Un algoritmo o esquema utilizado para grabar vídeo o audio digital. Un códec se emplea, por ejemplo, cuando se transmite vídeo por Internet; el vídeo se comprime en el extremo emisor y se descomprime en el extremo receptor. Las Herramientas de Windows Media proporcionan diferentes códecs para el contenido ASF. Los usuarios pueden seleccionar un códec según la calidad de audio o de imagen y el tamaño de la imagen preferido.
codificador
Consulte Codificador de Windows Media.
Codificador de Windows Media
Una característica de las Tecnologías de Windows Media que se utiliza para crear secuencias ASF en directo. El Codificador de Windows Media convierte el contenido de audio y de vídeo en directo en una secuencia ASF y la distribuye a través de un puerto. También puede guardar una secuencia ASF como un archivo .ASF. El Codificador de Windows Media puede distribuir una secuencia ASF mediante el protocolo MSBD o HTTP.
Código de corrección de errores (ECC)
El método de corrección de errores utilizado en una versión anterior de los Servicios de Windows Media. Se envían datos redundantes con la secuencia de datos para detectar y controlar errores en los bits de la secuencia de datos. En la versión actual de los Servicios de Windows Media, los errores en las secuencias se corrigen mediante el reenvío UDP.
coincidencia de color de imagen (ICM)
Interfaz entre aplicaciones que comunica la información de color de cada dispositivo, lo que permite que las aplicaciones muestren, impriman o pasen colores con precisión a otros usuarios y aplicaciones. Es posible que otros sistemas operativos utilicen esquemas de coincidencia de color diferentes. Los vídeos creados sin datos ICM no se representan correctamente en equipos basados en Windows.
Complemento de Windows Media para Adobe Premiere
Programa que permite que un generador de contenidos utilice Adobe Premiere para producir contenidos ASF para las Tecnologías de Windows Media.
componentes del servidor de Windows Media
Otro término para los servicios de Windows Media, que se utilizan para transmitir por multidifusión y unidifusión presentaciones de audio y vídeo en directo y archivos almacenados a los clientes. Incluye los servicios componentes de Windows Media, que se ejecutan en un servidor de Windows Media, y el Administrador de Windows Media, que se utiliza para administrar los servicios.
Comprobación de la lista de control de acceso (ACL)
Una parte de la seguridad de Microsoft Windows que los servicios de Windows Media utilizan para comprobar si un cliente tiene permiso para obtener acceso a un archivo o carpeta determinados. Mediante la comprobación ACL, un administrador de sistema puede establecer restricciones de permisos sobre archivos .ASF y sobre carpetas.
contenido
Datos que los servidores transmiten en secuencias a un cliente o clientes mediante unidifusión o multidifusión. El contenido puede originarse desde una presentación de audio o de vídeo en directo, archivos de audio o de vídeo almacenados, imágenes fijas o diapositivas. Es necesario transformar el contenido desde su estado original a ASF para que un servidor pueda transmitirlo. Los servidores de Windows Media pueden transmitir como contenido secuencias ASF en directo o archivos .ASF almacenados.
controles ActiveX
Controles que utilizan la tecnología ActiveX. Estos controles pueden descargarse automáticamente desde una página Web y ejecutarse mediante un explorador Web.
Convención de nomenclatura universal (UNC)
También llamada Convención de nomenclatura uniforme. Una convención para especificar directorios, servidores u otros recursos de una red, que utiliza dos barras diagonales // o barras diagonales inversas \\ para indicar el nombre del equipo y una barra diagonal para indicar la ruta de acceso o los niveles de directorios dentro del equipo, en este formato: \\equipo\directorio.
conversión de dirección URL
Método de conversión utilizado para especificar diferentes Servidores de Windows Media con el mismo contenido. Por ejemplo, si la primera etiqueta REF de un archivo .asx especifica un archivo .asf en el servidor sabueso1 y la segunda etiqueta REF especifica una copia del archivo en sabueso2, el Reproductor de Windows Media podrá tener acceso al archivo mediante cualquiera de los dos servidores. Si sabueso1 está ocupado o si se produce un error, el Reproductor de Windows Media se conecta automáticamente a sabueso2.
conversión de protocolo
Procedimiento que permite conmutar desde un protocolo a otro cuando un Servidor de Windows Media no puede establecer una conexión mediante un determinado protocolo. Por ejemplo, si un cliente realiza una petición de contenido ASF mediante el protocolo MMS, el servidor intentará transmitir la secuencia de contenido ASF mediante UDP. Si este protocolo no funciona, entonces el servidor trata de transmitir el contenido mediante el protocolo TCP y, a continuación, si éste tampoco funciona, el servidor trata de utilizar el protocolo HTTP, si está habilitado. La conversión de protocolo no se aplica si se utiliza el protocolo MMSU (MMS sobre UDP) o el protocolo MMST (MMS sobre TCP) para pedir contenido de formato ASF.
conversión de unidifusión
Procedimiento que sigue el Reproductor de Windows Media si no puede recibir una multidifusión desde una emisora de un servidor de Windows Media. Algunas veces, el Reproductor de Windows Media no puede recibir una multidifusión por varias razones, incluida la ausencia de enrutadores que admitan multidifusión en la red. Si el Reproductor de Windows Media no puede recibir la multidifusión, utiliza la dirección URL de conversión de unidifusión contenida en el archivo .NSC para conectarse con un servidor y pedir una unidifusión de la secuencia.
Copia de seguridad de Microsoft Windows
Una utilidad que ayuda a proteger datos frente a pérdidas accidentales si se producen errores de hardware o de almacenamiento en el sistema.
corrección de errores
Método para controlar los errores de transferencia de datos en un sistema de comunicación unidireccional. Consiste en enviar información adicional, junto con los datos, que el receptor utiliza para comprobarlos y corregirlos.
cuadro
Una imagen estática de entre las muchas imágenes en secuencia que componen un vídeo.
difusión
Describe la forma en que un cliente experimenta la recepción de una secuencia. Una secuencia de difusión puede ser de multidifusión o de unidifusión. En una conexión de difusión, el cliente es un elemento pasivo y no controla cuándo comienza o se detiene la secuencia. Por el contrario, en una conexión a petición, el cliente es un elemento activo y controla cuándo se inicia o se detiene la secuencia.
dirección de destino
Una dirección IP y un puerto, desde los que un cliente receptor puede recibir una multidifusión. Un cliente le indica a su tarjeta de red que esté pendiente de paquetes que llegan a la dirección y puerto de destino.
dirección de protocolo Internet (dirección IP)
Un número de 32 bits que es la dirección IP exclusiva de cada equipo o dispositivo de Internet. Este número especifica la ubicación física, o nodo, de la red.
directorio principal
Consulte punto de publicación principal.
directorio raíz de ASF
Consulte punto de publicación principal.
distribución
Entrega de una secuencia ASF desde un servidor a otro. La distribución sirve para muchos propósitos, como:
  • Distribuir una secuencia a otro servidor que, a continuación, la entrega mediante unidifusión, con lo que permite que los clientes de una parte de la red que no están habilitados para multidifusiones reciban la secuencia.
  • Distribuir una secuencia a un servidor que está habilitado para secuencias HTTP. Esto permite que los usuarios que están detrás de un servidor de seguridad reciban una secuencia que, de otra forma, no podrían recibir.
  • Distribuir una secuencia desde un servidor de Windows Media a otro, para crear así más secuencias de unidifusión. Por ejemplo, si se alcanzó el número máximo de secuencias de unidifusión para un servidor, es posible enviar una secuencia a otro servidor, que podrá transmitirla mediante unidifusión a más clientes.

elemento
En un archivo .ASX, es una entidad que define un parámetro particular o acción al cliente. Un elemento puede ser modificado mediante un atributo. Por ejemplo, un elemento ref tiene atributos que definen la dirección URL que apunta a un contenido determinado.
emisora
Ubicación definida desde la que un reproductor puede recibir secuencias. Es una dirección IP y un puerto. Los componentes del Servidor de Windows Media utilizan las emisoras sólo con secuencias ASF y guardan información en forma de archivo con extensión .NSC.
enrutador
Dispositivo que conecta dos o más redes y transporta datos. Un enrutador determina dónde está ubicado el equipo destino y, a continuación, busca la mejor forma de transmitir los datos allí.
escuchar
Supervisar una dirección IP de multidifusión específica. El Reproductor de Windows Media de Microsoft supervisa en una dirección IP de multidifusión los datos distribuidos en secuencia desde un servidor.
Formato avanzado de secuencias (ASF)
Formato de datos para transmitir y procesar en paquetes secuencias de contenido de audio y vídeo, imágenes y secuencias de comandos a través de una red. El contenido ASF puede estar formado por un archivo .asf o una secuencia en directo generada por un Codificador de Windows Media. El contenido ASF, mientras se distribuye a través de una red, se denomina secuencia ASF.
formato de plantilla de secuencia (TSF)
En las Tecnologías de Windows Media, un grupo de opciones predefinidas que enlazan el tipo de contenido y la velocidad de bits con los códecs de audio y vídeo apropiados. El Codificador de Windows Media utiliza esta característica para ayudar al usuario a configurar rápidamente el codificador para crear el contenido ASF.
formato de secuencia
Información acerca de la configuración correcta necesaria para que un reproductor genere una secuencia apropiadamente. Esta información contiene parámetros como la velocidad de bits, el tamaño de la imagen y el códec. El formato de las secuencias puede ser un formato de plantillas de secuencia o un formato de secuencias personalizado. Estos formatos se almacenan en archivos .NSC, .ASD y .ASF.
Herramientas de Windows Media
Conjunto de herramientas que se utilizan para crear contenido ASF para los Servicios de Windows Media. Incluyen el Codificador de Windows Media, el Autor de Windows Media y el Indizador de formato ASF de Windows Media; los programas de conversión VidToASF y WavToASF y las herramientas de archivos ASFCheck, ASFChop y ASX3Test.

I—O

Indizador de formato ASF de Windows Media
Programa basado en Windows para eliminar partes de una secuencia ASF que ha sido almacenada por el Codificador de Windows Media. También se puede utilizar para modificar las propiedades, marcadores y secuencias de comandos.
intranet
Red que pertenece a una organización. Sólo los miembros de esa organización tienen acceso a ella. Una intranet que está conectada a Internet está protegida normalmente por un servidor de seguridad u otro dispositivo.
lista de reproducción
Una lista de secuencias que el Reproductor de Windows Media de Microsoft reproducirá en orden. Los Servicios de Windows Media admiten listas de reproducción tanto de servidor como de cliente.
  • Una lista de reproducción de servidor se reproduce como parte de un programa en una emisora. Para crear la lista de reproducción se utiliza el botón Secuencias de la página Emisoras del Administrador de Windows Media. Una lista de reproducción de servidor puede incluir direcciones URL que señalen secuencias, e incluso archivos .ASF.
  • Una lista de reproducción de cliente es un archivo .ASX que contiene múltiples elementos de entrada. El Reproductor de Windows Media reproduce los elementos de entrada en el orden en el que aparecen en el archivo .ASX.

local
Próximo o restringido a un área concreta. En comunicaciones, un dispositivo local es aquél al que se puede tener acceso directamente sin mediar vínculos de comunicaciones. Al procesar la información, una operación local es la realizada por un equipo próximo no por un equipo remoto. Por ejemplo, el equipo servidor en el que están instalados los Servicios de Windows Media es el equipo local con respecto al servidor.
marcador
Un puntero a un lugar específico, medido en tiempo, en un archivo .ASF. El Reproductor de Windows Media utiliza los marcadores para ir directamente a un punto de un archivo .ASF. Los marcadores de un archivo .ASF permiten que los observadores salten al siguiente o al anterior marcador para ver de nuevo una determinada parte del archivo .ASF.
metadato
En un sistema con Tecnologías de Windows Media es la información acerca del contenido; como el título, el autor o el copyright. La información se guarda en un archivo .ASX.
metarchivo
En un sistema con Tecnologías de Windows Media, se trata de un archivo de texto que contiene información acerca del contenido multimedia. Los Servicios de Windows Media utilizan tres clases de metarchivos: metarchivos .ASD, metarchivos .ASX y metarchivos .NSC.
Microsoft Internet Explorer
Explorador Web basado en Windows producido por Microsoft Corporation. Los Servicios de Windows Media utilizan de varias maneras la versión 5 de Microsoft Internet Explorer. Por ejemplo, el Administrador de Windows Media utiliza Internet Explorer para mostrar sus páginas Web. Los generadores de contenido pueden incrustar el control ActiveX del Reproductor de Windows Media de Microsoft en una página HTML, que se ve con Internet Explorer.
Modelo de objetos componentes distribuido (DCOM)
Extensión del Modelo de objetos componentes (COM). DCOM permite que los componentes de software se comuniquen directamente entre ellos en redes, incluidas Internet y las intranets, de una forma confiable, segura y eficiente.
modo de distribución
Parámetro de los componentes del servidor de Windows Media que indica si los componentes del Servidor de Windows Media difundirán secuencias ASF mediante multidifusión, distribuirán secuencias ASF (mediante unidifusión) o ambas cosas. Si el modo de distribución se establece como multidifusión solamente, entonces el servidor difunde la secuencia ASF mediante multidifusión y unidifusión. Si el modo de distribución se establece como distribución solamente, entonces el servidor entrega la secuencia ASF si se la pide otro servidor que va a difundir la secuencia ASF. Si el modo de distribución se establece a ambos, el modo de multidifusión y el modo de distribución están operativos.
Monitor de sucesos del punto de publicación
Herramienta que supervisa y muestra los sucesos del servidor de unidifusión. Especialmente, el Monitor de sucesos del punto de publicación muestra las actividades del servidor de unidifusión (punto de publicación).
multidifusión
Conexión de uno a varios en la que múltiples clientes pueden recibir la misma secuencia desde un servidor. Para recibir una multidifusión, un cliente debe tener acceso a una red habilitada para multidifusión. En cambio, una unidifusión es una conexión uno a uno en la que un cliente recibe una secuencia de un servidor.
multidifusión
Entrega de una secuencia desde un Servidor de Windows Media a muchos clientes, que vigilan la dirección IP por la que se realiza la multidifusión de la secuencia para escucharla. Desde la perspectiva del cliente, una multidifusión es una experiencia sin conexión, ya que nunca se conecta a un servidor de Windows Media.
objeto de datos de secuencia
Datos que representan un tipo particular de datos en la secuencia ASF, por ejemplo, un cuadro de vídeo comprimido.
.OCX
Utilizado frecuentemente como sinónimo de control ActiveX, .OCX es la extensión del nombre del archivo para un control.

P—T

paquete
Unidad de datos que se transmite a través de una red. Tiene un tamaño fijo y se enruta entre un origen y un destino. Contiene información binaria que representa los datos y un encabezado que contiene un número de identificación, la dirección de origen y la dirección de destino.
Presentador de Windows Media para Microsoft PowerPoint 97
Una característica de las Tecnologías de Windows Media, disponible en Microsoft PowerPoint 97. Permite que PowerPoint se conecte con el Codificador de Windows Media y envíe una presentación de PowerPoint a un Servidor de Windows Media para distribuirla a los clientes.
programa
Una o más secuencias que los componentes del servidor de Windows Media administran como una única entidad. Un programa es un contenedor de secuencias.
propiedad
Característica de un objeto, como una secuencia. Por ejemplo, el Codificador de Windows Media muestra las propiedades de la secuencia, como el ancho de banda y el códec utilizado, en una página de propiedades.
protocolo
Conjunto de formatos y procedimientos que permiten que los equipos intercambien información. Entre los protocolos que utilizan los Servicios de Windows Media se encuentran HTTP, MMS y MSBD.
Protocolo de datagramas de usuarios (UDP)
Protocolo de transporte sin conexión de la pila del protocolo TCP/IP que, al igual que TCP, se ejecuta sobre redes IP.
protocolo Distribución por difusión de secuencias multimedia (protocolo MSBD, Media Streaming Broadcast Definition)
Protocolo utilizado para hacer referencia a un Codificador de Windows Media, que es el origen de una secuencia, como msbd://nombreServidor. También se utiliza cuando se transmiten secuencias desde el servicio de emisoras de Windows Media a un servidor de almacenamiento de contenidos. Además, se usa para la distribución de servidor a servidor.
protocolo Microsoft Media Server (protocolo MMS)
Protocolo utilizado para hacer referencia y transmitir secuencias de archivos .ASF desde un servidor de Windows Media.
puerto
Ubicación del servidor desde el que se transmiten secuencias de contenido a un cliente. Se representa mediante un número que forma parte de una dirección URL. Los componentes del servidor de Windows Media, cuando están en uso, se enlazan con los puertos. De forma predeterminada, el servicio de unidifusión de Windows Media se enlaza al puerto 1755 y el servicio de emisora de Windows Media se enlaza al puerto 7007. Si está habilitada la secuencia HTTP para un servicio, entonces dicho servicio pasa a utilizar el puerto 80, que es el puerto preferido para cualquier secuencia HTTP. Es posible cambiar los puertos que utilizan componentes del Servidor de Windows Media si modifica el Registro.
punto de publicación
Directorio virtual que se utiliza para almacenar contenido que está disponible para clientes o para tener acceso a una secuencia en directo. Los clientes utilizan la dirección URL de un punto de publicación para tener acceso a él.
Punto de publicación principal
Directorio raíz para la publicación de contenido ASF. El Reproductor multimedia de Microsoft Windows puede transmitir cualquier archivo .asf ubicado en este directorio o en sus subdirectorios. Un punto de publicación principal es también un punto de publicación a petición. A diferencia de otros puntos de publicación, un punto de publicación principal no tiene un alias. En su lugar, para tener acceso al punto de publicación principal se utiliza el nombre del equipo en una dirección URL. También se llama directorio principal ASF.
Red digital de servicios integrados, RDSI (ISDN)
Red telefónica y de telecomunicaciones completamente digital que transporta voz, texto, imágenes y vídeo a alta velocidad mediante el envío de señales codificadas digitalmente.
red habilitada para multidifusión
Red que tiene enrutadores que pueden interpretar direcciones IP de clase D.
registrar

Recoger y almacenar datos sobre sucesos de los Servicios de Windows Media. El Administrador de Windows Media puede registrar información acerca de unidifusiones, multidifusiones y clientes.

relleno
Espacio vacío que se agrega a un paquete de una secuencia de contenidos para mantener constante el tamaño del paquete. Los Servicios de Windows Media admiten paquetes de longitud variable. Sin embargo, el Codificador de Windows Media limita los paquetes a una longitud fija para garantizar la compatibilidad con las versiones anteriores de los Servicios de Windows Media.
remoto
Que no está próximo o accesible directamente. Un equipo u otro dispositivo ubicado en otro lugar (habitación, edificio o ciudad) y accesible a través de algún tipo de vínculo de comunicación. Por ejemplo, el Administrador de Windows Media puede ejecutarse en un equipo (un equipo remoto) distinto del Servidor de Windows Media, de forma que un administrador remoto pueda administrar el servidor. El Codificador de Windows Media también puede ejecutarse en un equipo remoto.
reproductor
Un programa o control de cliente que recibe contenido enviado en forma de secuencias desde un servidor de Windows Media. En la Ayuda en pantalla, se refiere al Reproductor de Windows Media de Microsoft.
Reproductor de Windows Media de Microsoft
Un programa o control de cliente que recibe secuencias desde un servidor de Windows Media. Este control puede utilizarse como programa ejecutable independiente o puede incrustarse en una página Web, un programa de C++ o un programa de Microsoft Visual Basic que utilice el control ActiveX de cliente. El Reproductor de Windows Media de Microsoft es la primera versión universal de un reproductor.
secuencia
Datos transmitidos a través de una red y sus propiedades asociadas. La secuencia de datos permite que el reproductor comience a generar los datos inmediatamente, en lugar de esperar a que se descargue todo el archivo.
secuencias de comandos
Instrucciones especiales que se incluyen en secuencias de datos ASF y se entregan al cliente. El Reproductor de Windows Media de Microsoft pasa las secuencias de comandos a un dispositivo o a una aplicación que los interpreta. Se utilizan para llevar a cabo tareas como llamar a archivos específicos o explorar un sitio Web específico.
seguridad
Proceso de controlar el acceso a los recursos basándose en credenciales y permisos de usuario. En un entorno de Servicios de Windows Media, la seguridad significa restringir y controlar el acceso a los componentes del Servidor de Windows Media, al Administrador de Windows Media y al contenido de Windows Media, tanto almacenados como transmitidos. Los Servicios de Windows Media incorporan mecanismos de seguridad que se integran con Microsoft NTLM. Los Servicios de Windows Media admiten listas de reproducción tanto de servidor como de cliente.
servicio de emisoras de Windows Media
Uno de los servicios componentes de Windows Media, que proporciona funciones de multidifusión, distribución y almacenamiento para secuencias ASF. Puede administrar múltiples emisoras, con una secuencia ASF como entrada para cada emisora, y puede dirigir la secuencia a una dirección de multidifusión, a uno o más servidores de distribución, a un disco o a una combinación de los tres. Una opción similar, el servicio de unidifusión de Windows Media, está disponible para secuencias ASF de unidifusión.
servicio de Programa de Windows Media
Uno de los servicios componentes de Windows Media.
Servicio de transferencia de archivos (FTS)
Una opción de los Servicios de Windows Media que distribuye archivos mediante multidifusión por una red a un control ActiveX (Nsfile.ocx) en un equipo cliente.
servicio de unidifusión de Windows Media
Uno de los servicios componentes de Windows Media, que proporciona funciones de unidifusión para secuencias ASF. Este servicio administra los puntos de publicación a los que se conectan los clientes para recibir secuencias de unidifusión o secuencias de unidifusión a petición. Una opción similar, el servicio de emisoras de Windows Media, está disponible para secuencias ASF de multidifusión.
servicio Monitor de Windows Media
Uno de los servicios componentes de Windows Media.
# servicios componentes de Windows Media
Conjunto de servicios que se ejecutan en un servidor de Windows Media. Estos servicios distribuyen, mediante multidifusión y unidifusión, presentaciones de audio y de vídeo, en directo y almacenadas en equipos cliente.
Servicios de Windows Media
Otro término para los servicios de Windows Media, que se utilizan para transmitir por multidifusión y unidifusión presentaciones de audio y vídeo en directo y archivos almacenados a los clientes. Incluye los servicios componentes de Windows Media, que se ejecutan en un servidor de Windows Media, y el Administrador de Windows Media, que se utiliza para administrar los servicios.
servidor de seguridad
Un sistema o combinación de sistemas que impone un límite entre dos o más redes y mantiene a los usuarios no autorizados fuera de las redes privadas. Un sistema de servidor de seguridad comprueba todos los mensajes de entrada y de salida para asegurarse de que cumplen los criterios de seguridad predeterminados.
servidor proxy
Equipo servidor que controla el tráfico de Web entre redes de área local e Internet u otras intranets.
tarjeta de captura de vídeo
Tarjeta adicional para proporcionar imágenes digitalizadas en un equipo. Con una tarjeta de captura de vídeo, se puede proporcionar entrada de cámara en directo o de VCR al Codificador de Windows Media.
Tecnologías de Windows Media
Familia de aplicaciones de secuencias multimedia que incluye los Servicios de Windows Media, las Herramientas de Windows Media y el Reproductor de Windows Media. Las Herramientas de Windows Media permiten crear contenido ASF para su distribución a los clientes mediante los Servicios de Windows Media para ser reproducidos con el Reproductor de Windows Media.
tiempo de vida (TTL)
En multidifusión, un valor que define el número de enrutadores a través de los que puede pasar una multidifusión antes de que un enrutador la detenga. TTL es equivalente al alcance.
Título
Característica que envía un archivo de Synchronized Accessible Media Interchange (SAMI) (un archivo en formato subtitulado) con una secuencia ASF. La titulación es una característica de accesibilidad que muestra títulos junto con vídeo y audio, de forma parecida a los subtítulos que acompañan a algunos programas de televisión. También puede utilizarse para mostrar subtítulos en un idioma extranjero.
Tutorial
Grupo de asistentes de las Tecnologías de Windows Media que se utilizan para realizar tareas como la configuración del Codificador de Windows Media y la creación de emisoras o puntos de publicación.

U—Z

unidifusión
Conexión cliente-servidor en la que un cliente recibe a petición una secuencia de contenido almacenado desde un servidor o recibe una difusión de contenido en directo. Ningún otro cliente tiene acceso a esta secuencia. En cambio, una única secuencia de multidifusión está disponible para varios clientes.
unidifusión
Conexión punto a punto que inicia un cliente con un punto de publicación en un servidor de Windows Media.
unidifusión a petición
Conexión punto a punto que inicia un cliente con un punto de publicación. En una unidifusión a petición, el servidor transmite secuencias de contenido almacenado para el usuario.
velocidad de bits
La velocidad a la que se puede transmitir en secuencias el contenido binario a través de una red. Normalmente se mide en kilobits por segundo (Kbps), por ejemplo, 28.8 Kbps. El Codificador de Windows Media y el Administrador de Windows Media tienen parámetros para la velocidad de bits de contenidos de formato ASF.
velocidad de cuadro
La velocidad a la que cambian los cuadros. Una velocidad de cuadros elevada produce mejor calidad de imagen.
vídeo de velocidad de bits múltiple
Una característica de las Tecnologías de Windows Media que permite crear y transmitir secuencias de vídeo codificadas de seis formas dentro de una única secuencia ASF. Al utilizar vídeo de velocidad de bits múltiple en el Codificador de Windows Media se crea contenido en formato ASF que tiene una variedad de secuencias de vídeo en anchos de banda variables para cada audiencia de destino de ancho de banda inferior o superior. Cuando se crea contenido de frecuencia de bits múltiple para audiencias de ancho de banda bajo, las secuencias de vídeo pueden oscilar de 18 Kbps a 300 Kbps. Alternativamente, las audiencias de destino de ancho de banda alto, incluyen secuencias de vídeo que oscilan de 81 Kbps a 10 Mbps. Ambas audiencias de destino incluyen una secuencia de audio codificado por separado. Cuando se codifica vídeo de frecuencia de bits múltiple, también se codifica una secuencia de vídeo de seguridad adicional que se basa en un porcentaje del ancho de banda más bajo. Después de recibir esta secuencia de codificación múltiple, el servidor determina qué ancho de banda se utilizará para la secuencia, según el ancho de banda disponible en la red. El vídeo de velocidad de bits múltiple no es compatible con servidores HTTP genéricos.
VidToASF
Herramienta de la línea de comandos que convierte rápidamente un archivo .AVI o .MOV modificado en un archivo .ASF, de forma que pueda almacenarse en un servidor que ejecute los Servicios de Windows Media y se pueda transmitir a clientes.
volteos de dirección URL
Conjunto de instrucciones para que el explorador cambie el contenido de una página Web, independientemente del estado de la pantalla. Esto es lo que permite que el usuario vincule desde una página a otra sin esperar a que se genere completamente el contenido de la primera página.
WavToASF
Herramienta de la línea de comandos que convierte rápidamente un archivo .WAV modificado en un archivo .ASF, de forma que pueda almacenarse en un servidor que ejecute los Servicios de Windows Media y se pueda transmitir a clientes.


Digital Rights Management

La tecnología Digital Rights Management (administración de derechos digitales, DRM) permite proteger el contenido y administrar los derechos de acceso al mismo. Aunque todavía está en fase de investigación y desarrollo, con la presentación del Administrador de derechos de Windows Media se da el primer paso para evitar la piratería del contenido multimedia digital. Windows Media Rights Manager le ayudará a proteger y asegurar su contenido de audio y vídeo mediante la codificación de archivos origen .asf , .mp3 y .wav empaquetándolos como archivos .asf y proporcionando licencias a sus usuarios. Al implementar esta característica, podrá saber quién tiene copias del contenido e incluir una firma digital en cada elemento de contenido que distribuya.

Rights Manager de Windows Media tendrá una gran repercusión en todo el sistema de transmisión de secuencias. Esta introducción abarca algunas de las áreas de interés para los creadores de contenido, publicadores en Web y usuarios finales. Para obtener una información detallada, consulte la página de Tecnologías de Windows Media en el sitio Web de Microsoft o la documentación de Rights Manager de Windows Media.


Creadores de contenido

El Administrador de derechos de Windows Media permite proteger el contenido antes de distribuirlo a los proveedores de servicios Internet, gracias al Empaquetador de Windows Media. Al crear contenido en formato ASF, existen dos métodos para implementar DRM en el archivo .asf:

  • Utilizar las Herramientas de Windows Media para crear el archivo .asf y, después, utilizar el Empaquetador de Windows Media para empaquetar el archivo.
  • Utilizar el Empaquetador de Windows Media para crear directamente un archivo empaquetado.

Al empaquetar un archivo se realizan diversas cosas:

  • Se cifra el archivo con una clave privada
  • Se establece la dirección URL del servidor de licencias
  • Se establece la dirección URL del sitio Web oficial
  • Se incluye en el archivo cualquier imagen o encabezado
  • Se establece los valores de las propiedades Título, Intérprete, Copyright y Género.

Una vez empaquetado el archivo, no es posible modificarlo con las Herramientas de Windows Media. Tras establecer las propiedades del archivo, se protegen para impedir la modificación. Por lo tanto, si desea modificar más tarde el contenido creado, lo mejor es crear el archivo asf con las Herramientas de Windows Media, guardar una copia de seguridad y, a continuación, crear el archivo empaquetado.


Publicación en Web

El Administrador de derechos de Windows Media incluye un Asistente para sitios que le ayudará a publicar el contenido, una vez empaquetado, en un sitio Web. Después de empaquetar el contenido, los usuarios necesitarán una licencia válida para reproducirlo. La comprobación de licencias se realiza cuando los usuarios intentan reproducir el contenido. Si no tienen una licencia válida en el equipo, se iniciará el explorador con su sitio Web para que puedan registrar el contenido. Una vez se haya registrado el usuario, se descargará en su equipo una licencia y una clave para descifrar y reproducir el contenido.

Como publicador, deberá mantener las bases de datos de licencias y usuarios. El administrador de derechos de Windows Media utiliza una base de datos de SQL Server, por lo que debe tener instalado SQL Server antes de instalar aquél. Para transmitir la secuencia de contenido empaquetado se requieren también los Servicios de Windows Media 4.0.

La instalación del Administrador de derechos de Windows Media incluye la instalación del Empaquetador de Windows Media para administrar el contenido y las licencias en el sitio Web:


Usuarios

Para reproducir archivos empaquetados se necesita el Reproductor de Windows Media 6.2. Los archivos empaquetados se pueden transmitir desde un servidor de Windows Media o se pueden descargar para reproducirlos de forma local. Si no está instalada en el equipo la versión correcta del Reproductor de Windows Media, al intentar reproducir el contenido protegido se abrirá el explorador Web en la página de descarga, desde donde el usuario podrá descargar el Reproductor de Windows Media.

El Reproductor de Windows Media comprueba si el usuario dispone de la licencia necesaria para reproducir el contenido. Si no la tiene, se abre el explorador Web en la página de registro de licencias del sitio Web. Tras completar la información de registro, se emite una licencia y el Reproductor de Windows Media reproduce el contenido. El usuario podrá reproducir el contenido hasta que caduque la licencia. Mientras se descarga la licencia, el usuario recibe información acerca de los términos de la misma. Una licencia puede ser válida para un período de tiempo indefinido, un período concreto o para un número de reproducciones establecido. Sin embargo, si un usuario registrado copia el contenido y lo comparte con otro usuario, éste último deberá realizar el proceso de registro. No es posible copiar y compartir las licencias y claves de descifrado entre diferentes equipos.

Cuando el Reproductor de Windows Media reproduce contenido protegido, el usuario puede ver los siguientes elementos:

  • El título del contenido.
  • El nombre del intérprete.
  • Un aviso de copyright.
  • Una imagen de titular.
  • Imágenes de vídeo.
  • Un icono de legitimidad, que indica que el contenido está protegido y no fue manipulado.

Además, al hacer clic en diferentes áreas de la ventana se abre el explorador Web en la dirección URL correspondiente. Por ejemplo, si hace clic en la imagen del titular podría abrirse el sitio Web del distribuidor y si hace clic en el título podría abrirse el sitio Web del intérprete.


Buscar más información

Rights Manager de Windows Media es una tecnología nueva para utilizar con contenido de audio y vídeo. Puede obtener La guía de instalación y requisitos del Administrador de derechos de Windows Media de la página de Tecnologías de Windows Media en el sitio Web de Microsoft.

Esta guía enumera los requisitos de hardware y software que debe tener antes de poder instalar el Administrador de derechos Windows Media. También describe el proceso de instalación del Administrador de derechos de Windows Media, habla acerca de los formatos de archivo de imagen y multimedia requeridos, explica el proceso de cifrado y habla acerca de marcas de agua y opciones de precodificación para su contenido.

Utilice la Guía del Tutorial para obtener su sitio Web del Administrador de derechos de Windows Media y ejecutar rápidamente.

Se puede descargar el Administrador de derechos de Windows Media desde la página de descargas de las Tecnologías de Windows Media Windows Media en el sitio Web de Microsoft.


Apéndice acerca de la accesibilidad

Microsoft ha adquirido el compromiso de crear productos y servicios que sean fáciles de utilizar para todo el mundo. Este apéndice proporciona información acerca de las siguientes características, productos y servicios, que hacen que Microsoft Windows y los Servicios multimedia de Microsoft Windows sean más accesibles para la gente con discapacidades:

  • Características y sugerencias para personalizar Windows
  • Servicios de Microsoft para las personas sordas o con problemas de audición
  • Documentación en pantalla del software de Microsoft o en cassette de audio, disquete o disco compacto (CD)
  • Programas de otras empresas para mejorar la accesibilidad
  • Otros productos y servicios para personas con discapacidades

Nota

  • La información de este apéndice sólo es aplicable si adquirió el producto en Estados Unidos. Si adquirió Windows fuera de Estados Unidos, el paquete contiene una tarjeta de información de la subsidiaria con una lista de los números de teléfono y las direcciones de los servicios de Soporte técnico de Microsoft. Póngase en contacto con la subsidiaria para averiguar si el tipo de productos y servicios que se describen en este apéndice están disponibles en su área.


Personalizar Windows

Existen muchos métodos para personalizar Microsoft Windows, de forma que el equipo sea más accesible.

  • En Windows 95, las características de accesibilidad están incorporadas en Windows. Estas características son útiles para las personas que tienen problemas para utilizar el teclado o para utilizar el mouse (ratón), problemas visuales moderados o son sordas o tienen problemas de audición. Estas características se instalan con el programa, aunque también es posible agregarlas más tarde mediante los discos de instalación de Windows. Busque “accesibilidad” en el índice de la Ayuda HTML de Windows si desea encontrar más información acerca de cómo instalar y utilizar estas características.
  • También puede utilizar el Panel de control, así como otras características integradas, para ajustar la apariencia y el comportamiento de Windows para que se adapte a diferentes capacidades motoras y visuales. Incluye, entre otras, el ajuste del color y del tamaño de distintos elementos, el volumen del sonido y el comportamiento del mouse (ratón) y del teclado.
  • Si tiene dificultades para utilizar el teclado con la disposición “QWERTY” estándar, la disposición de teclado tipo Dvorak facilita el acceso a los caracteres utilizados con más frecuencia. Existen tres disposiciones de teclado Dvorak: una para usuarios que utilizan las dos manos, otra para usuarios que sólo utilizan la mano izquierda y otra para los que sólo utilizan la mano derecha. No es necesario adquirir equipamiento especial para utilizar estas características.

Las características específicas disponibles, y si están integradas o se deben obtener por separado, dependerán del sistema operativo que utilice.

Para ver la documentación completa acerca de las características de accesibilidad disponibles en el sistema operativo que utiliza, obtenga las notas de la aplicación correspondientes a la misma, indicadas en la siguiente lista. Las características de accesibilidad también aparecen documentadas en el Kit de recursos de Microsoft Windows NT.


Servicios de Microsoft para las personas sordas o con problemas de audición

Si tiene problemas de audición, podrá disponer del Soporte técnico completo mediante un servicio de teléfono de texto (TT/TDD).


Información de ventas

Si desea ponerse en contacto con Microsoft Sales Information Center mediante un teléfono de texto, llame al (800) 892-5234 entre las 6:30 a.m. y las 5:30 p.m. hora del Pacífico (servicio en inglés).


Asistencia técnica

Para obtener asistencia técnica en Estados Unidos, póngase en contacto con Microsoft Support Network en el teléfono de texto (425) 635-4948 entre las 6:00 a.m. y las 6:00 p.m. hora del Pacífico, de lunes a viernes, excepto festivos (servicio en inglés). In Canadá, llame al (905) 568-9641 entre las 8:00 a.m. y las 8:00 p.m. hora Oriental, de lunes a viernes, excepto festivos (servicio en inglés). Los servicios de soporte técnico de Microsoft están sujetos a los precios, términos y condiciones de Microsoft en vigor en el momento de utilización del servicio.


Documentación de Microsoft en formatos alternativos

Además de los formatos estándar de documentación, muchos productos de Microsoft también están disponibles en otros formatos para que sean más accesibles.

La documentación de los Servicios de Windows Media está disponible como Ayuda en pantalla o documentación imprimible. Puede imprimir la documentación a partir de los archivos .doc de UnidadSistema\RaízSistema\system32\Windows Media\docs\print. Los archivos de este directorio son documentos neutralizados, lo que quiere decir que se pueden abrir en cualquier procesador de textos.

Si encuentra dificultades al leer o tratar la documentación impresa, puede obtener muchas publicaciones de Microsoft de Recording for the Blind & Dyslexic, Inc. Recording for the Blind & Dyslexic distribuye estos documentos para miembros registrados de su servicio de distribución, tanto en cintas de audio como en disquetes. La colección de Recording for the Blind & Dyslexic contiene más de 80,000 títulos, entre los que se incluye la documentación de los productos de Microsoft y los libros de Microsoft Press. Puede ponerse en contacto con Recording for the Blind & Dyslexic en la siguiente dirección o en los números de teléfono indicados si desea obtener información acerca de la autorización y disponibilidad para obtener la documentación de los productos de Microsoft y los libros de Microsoft Press:

Recording for the Blind & Dyslexic, Inc.
20 Roszel Road
Princeton, NJ 08540

Teléfono: (609) 452-0606
Fax: (609) 987-8116
Sitio Web: http://www.rfbd.org/


Programas de otras empresas para mejorar la accesibilidad

Existe una gran variedad de productos de hardware y software de otras empresas destinados a facilitar la utilización de los equipos. Entre los diferentes tipos de productos disponibles para los sistemas operativos MS-DOS y Microsoft Windows están:

  • Programas que aumentan o modifican el color de la información en pantalla para las personas con problemas visuales.
  • Programas que describen en Braille o mediante voz sintetizada la información de la pantalla, para las personas ciegas o con problemas de lectura.
  • Herramientas de hardware y software que modifican el comportamiento del mouse y del teclado.
  • Programas que permiten que las personas “escriban” con el mouse o con su propia voz.
  • Software de predicción de palabras o frases que permite que las personas escriban más rápido y con un menor uso del teclado.
  • Dispositivos de entrada alternativos, como dispositivos de interruptor único o por aliento, para las personas que no pueden utilizar un teclado o un mouse.

Para aprender más acerca de estos productos, consulte Obtener más información acerca de la accesibilidad.


Obtener más información acerca de la accesibilidad

Además de las características y los recursos ya descritos en este apéndice, existen otros productos, servicios y recursos de Microsoft y otras organizaciones.


Productos y servicios adicionales de Microsoft para personas con discapacidades

Para obtener más información acerca de los productos para personas con discapacidades, póngase en contacto con:

Microsoft Sales Information Center
One Microsoft Way
Redmond, WA 98052-6393

Sitio Web: http://www.microsoft.com/
Teléfono de voz: (800) 426-9400
Teléfono de texto: (800) 892-5234


Directorios de productos informáticos para personas con discapacidades

El Trace R&D Center de la Universidad de Wisconsin-Madison dispone de un libro y un disco compacto (CD) que describen productos que facilitan el uso de los equipos a las personas con discapacidades. El libro Trace Resource Book proporciona descripciones (en inglés) y fotografías de unos 2.000 productos. El CD CO-NET CD incluye una base de datos con más de 18,000 productos, así como otra información útil (en inglés) para personas con discapacidades. Se publica dos veces al año.

Si desea obtener estos directorios, póngase en contacto con:

Trace R&D Center (Centro Trace de I+D)
University of Wisconsin
S-151 Waisman Center
1500 Highland Avenue
Madison, WI 53705-2280

Sitio Web: http://trace.wisc.edu/
Fax: (608) 262-8848


Programas de asistencia tecnológica para personas con discapacidades

Para obtener información general y recomendaciones acerca de cómo la informática puede ayudar a solucionar necesidades específicas, consulte a un evaluador preparado. Los programas de asistencia tecnológica de su área pueden ofrecerle información acerca de los programas y servicios disponibles.

Para encontrar el programa de asistencia tecnológica más cercano, póngase en contacto con:

National Information System
University of South Carolina
Center for Developmental Disabilities
Columbia, SC 29208

Teléfono de voz y texto: (803) 935-5231
Fax: (803) 935-5059


Aviso legal

La información contenida en este documento está sujeta a modificaciones sin previo aviso. Las empresas, organizaciones, productos, personas y hechos de los ejemplos que aquí se presentan son ficticios. No se pretende ni se debe asociar con ninguna empresa, organización, producto, persona o hecho real. Es responsabilidad del usuario el cumplimiento de todas las leyes de derechos de autor aplicables. Sin limitar los derechos de autor, no se permite reproducir, almacenar o incluir en un sistema de recuperación o transmitir, en cualquier forma o por cualquier medio (electrónico, mecánico, fotocopias, grabaciones u otros) o con cualquier otro propósito, todo o parte de este documento sin el permiso expreso por escrito de Microsoft Corporation.

Microsoft puede ser titular de patentes, solicitudes de patentes, marcas, derechos de autor, y otros derechos de propiedad intelectual sobre los contenidos de este documento. El suministro de este documento no le otorga ninguna licencia sobre estas patentes, marcas, derechos de autor, u otros derechos de propiedad intelectual, a menos que ello se prevea en un contrato por escrito de licencia de Microsoft.

Ó 1996-1999 Microsoft Corporation. Reservados todos los derechos.

Microsoft, MS-DOS, MS, Windows, Windows NT, ActiveX, FrontPage, JScript, Microsoft Press, NetShow, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Win32 y Win32s son marcas registradas o marcas comerciales de Microsoft Corporation en Estados Unidos y/o en otros países.

Macintosh es una marca registrada de Apple Computer, Inc. utilizada bajo licencia.

QuickTime y QuickTime VR son marcas registradas de Apple Corporation.

Premiere es una marca registrada de Adobe Corporation.

Otros productos y nombres de compañías que aquí se mencionan pueden ser marcas registradas de sus propietarios.

Las siguientes instrucciones se aplican únicamente al lenguaje Python en tiempo de ejecución:

Copyright © 1991-1995, Stichting Mathematisch Centrum, Amsterdam, Países Bajos. Todos los derechos reservados. Se concede permiso para utilizar, copiar, modificar y distribuir este software y su documentación para cualquier propósito y sin el pago de tarifa alguna, siempre que el aviso de copyright y este permiso aparezcan en la documentación que lo acompaña y que no se utilicen los nombres de Stichting Mathematisch Centrum o CWI en anuncios o publicidad relacionada con la distribución del software, si no se dispone de un permiso específico por escrito.