Datenquellen-Assistent - Bildschirm 1

Send us feedback about this page Hilfe für Datenquellen-Assistent

Datenquellen-Assistent – Bildschirm 1

Auf dem ersten Bildschirm des Assistenten geben Sie den Namen und die Beschreibung der Datenquelle sowie den Namen des Servers ein, der Microsoft® SQL Server™ ausführt und zu dem die Datenquelle eine Verbindung herstellt.

Feld "Name"

Der Datenquellenname, der von ODBC-Anwendungen beim Anfordern einer Verbindung zu der Datenquelle verwendet wird. Beispiel: "Personal". Der Datenquellenname wird im Dialogfeld ODBC-Datenquellen-Administrator angezeigt.

Feld "Beschreibung"

Ein optionale Beschreibung der Datenquelle. Beispiel: "Einstelldatum, Gehaltsverlauf und aktuelle Bewertungen aller Angestellten".

Feld "Server"

Der Name eines SQL Servers im Netzwerk. Wenn Sie einen Servernamen aus der Liste auswählen, sind keine weiteren Konfigurationseinstellungen erforderlich. Falls Sie jedoch den Namen eines Servers eingeben, der noch nicht als Eintrag im SQL Clientkonfigurationsprogramm vorhanden ist, können Sie auf dem nächsten Bildschirm des Assistenten einen SQL Clientkonfigurationseintrag für den neuen Namen erstellen.

Sie können (lokal) in dem Serverfeld auswählen, wenn sich auf dem Computer, an dem Sie arbeiten, auch SQL Server befindet. Der Benutzer kann dann eine Verbindung zur lokalen Kopie von SQL Server herstellen, sogar dann, wenn eine Version von SQL Server ausgeführt wird, die sich nicht im Netzwerk befindet. SQL Server 2000 unterstützt mehrere auf dem gleichen Computer ausgeführte Instanzen von SQL Server. Beim Angeben einer benannten Instanz von SQL Server wird der Servername als Servername\Instanzname angegeben.

Weitere Informationen über Servernamen für verschiedene Netzwerkarten finden Sie in der Installationsdokumentation von SQL Server in der Onlinedokumentation von SQL Server.

Wenn die in dieser Anzeige festgelegten Informationen ausreichen, um eine Verbindung zu SQL Server herzustellen, können Sie auf Fertig stellen klicken. Für die in den restlichen Anzeigen des Assistenten festgelegten Attribute werden Standardeinstellungen verwendet.

©1988-2000 Microsoft Corporation. Alle Rechte vorbehalten.


Datenquellen-Assistent - Bildschirm 2

Datenquellen-Assistent – Bildschirm 2

Auf dem zweiten Bildschirm des Assistenten können Sie das Authentifizierungsverfahren angeben, erweiterte Client-Einträge für Microsoft® SQL Server™ festlegen und den Benutzernamen und das Kennwort bestimmen, das vom SQL Server ODBC-Treiber beim Konfigurieren der Datenquelle zum Herstellen der Verbindung zum SQL Server verwendet wird.

Optionsfeld Mit Windows NT-Authentifizierung anhand des Benutzernamens im Netzwerk

Legt fest, dass der SQL Server-ODBC-Treiber eine sichere (vertraute) Verbindung mit einem SQL Server anfordert, auf dem Microsoft Windows NT® oder Windows® 2000 ausgeführt wird. Bei aktivierter Option verwendet SQL Server die integrierte Anmeldungssicherheit, um Verbindungen mit dieser Datenquelle herzustellen, und zwar unabhängig vom aktuellen Ameldungssicherheitsmodus auf dem Server. Angegebene Benutzernamen oder Kennwörter werden ignoriert. Der Systemadministrator von SQL Server muss Ihren Microsoft Windows®-Benutzernamen mit einer SQL Server-Anmeldungs-ID verknüpft haben.

Optionsfeld Mit SQL Server-Authentifizierung anhand des vom Benutzer eingegebenen Benutzernamens und Kennworts

Diese Einstellung legt fest, dass der ODBC-Treiber für den SQL Server keine gesicherte (oder vertraute) Verbindung zu einem SQL Server anfordert. Der SQL Server verwendet dann die standardmäßige Anmeldungssicherheit zum Herstellen von Verbindungen unter Verwendung dieser Datenquelle. Sie müssen eine SQL Server-Anmeldungs-ID und ein Kennwort für alle Verbindungsanforderungen eingeben.

Schaltfläche Clientkonfiguration

Startet das Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen der SQL Server-Clientkonfiguration.

Wenn Sie im Feld Server im ersten Bildschirm des Assistenten einen neuen Namen eingegeben haben, benötigen Sie u.U. dieses Dialogfeld, um einen Eintrag für die Serveralias-Konfiguration hinzuzufügen, dessen Namen mit dem Namen identisch ist, der im ersten Bildschirm des ODBC-Assistenten im Feld Server eingegeben wurde. Der Aliasname muss mit dem Namen übereinstimmen, den Sie im Feld Server angegeben haben. Für Microsoft SQL Server benötigen Sie normalerweise keine Serveralias-Konfiguration. In den meisten Fällen kann der SQL Server-ODBC-Treiber unter Verwendung der Standardnetzwerkbibliothek und des Netzwerknamens, der im Feld Server im ersten Bildschirm des Assistenten angegeben wurde, eine Verbindung herstellen.

Klicken Sie auf Clientkonfiguration, wenn die Verbindung nicht die Netzwerkbibliothek des Clients, sondern eine andere Standardnetzwerkbibliothek verwenden soll. Klicken Sie außerdem auf Clientkonfiguration, falls die tatsächliche Netzwerkadresse des Servers für das erfolgreiche Herstellen einer Verbindung eingegeben werden muss. Wenn Sie z.B. die TCP/IP-Netzwerkbibliothek verwenden, müssen Sie möglicherweise den Anschluss und die Socket-Adresse des Servers angeben oder, wenn ein SQL Server eine alternative Named Pipe überwacht, in dem erweiterten Eintrag den Pipe-Namen festlegen.

Weitere Informationen über das Konfigurieren von Clients finden Sie in der Onlinedokumentation von SQL Server.

Kontrollkästchen Zum SQL Server verbinden, um Standardeinstellungen für die zusätzlichen Konfigurationsoptionen zu erhalten

Wenn dieses Kontrollkästchen aktiviert ist, ruft der SQL Server-Treiber vom SQL Server die Ursprungseinstellungen für die Optionen auf den folgenden Bildschirmen des Assistenten ab. Der SQL Server-Treiber stellt eine Verbindung zum SQL Server her, der in dem Feld Server auf dem ersten Bildschirm angegeben wurde.

Ist diese Einstellung deaktiviert, verwendet der Treiber Standardeinstellungen als Ursprungseinstellung für die Optionen auf den folgenden Bildschirmen des Assistenten.

Feld Benutzername

Diese Einstellung legt den Benutzernamen fest, den der SQL Server-Treiber beim Herstellen einer Verbindung zum SQL Server verwendet, wenn die Option Mit SQL Server-Authentifizierung anhand des vom Benutzer eingegebenen Benutzernamens und Kennworts aktiviert ist. Dies gilt nur für die Verbindung, die zum Feststellen der Server-Standardeinstellungen eingerichtet wurde; es gilt nicht für Verbindungen, die nach Erstellung der Datenquelle hergestellt werden.

Feld Kennwort

Diese Einstellung legt das Kennwort fest, das der SQL Server beim Herstellen einer Verbindung zum SQL Server verwendet, wenn die Option Mit SQL Server-Authentifizierung anhand des vom Benutzer eingegebenen Benutzernamens und Kennworts aktiviert ist. Dies gilt nur für die Verbindung, die zum Feststellen der Server-Standardeinstellungen eingerichtet wurde; es gilt nicht für Verbindungen, die später unter Verwendung der neuen Datenquelle hergestellt werden.

Die Felder Benutzername und Kennwort sind deaktiviert, wenn die Option Mit Windows NT-Authentifizierung anhand des Benutzernamens im Netzwerk aktiviert ist, oder wenn die Option Zum SQL Server verbinden, um Standardeinstellungen für die zusätzlichen Konfigurationsoptionen zu erhalten nicht markiert wurde.


Datenquellen-Assistent - Bildschirm 3

Datenquellen-Assistent – Bildschirm 3

Auf dem dritten Bildschirm des Assistenten legen Sie die Standarddatenbank fest, die Art, wie der Treiber gespeicherte Prozeduren verwendet, damit sie SQLPrepare unterstützen, verschiedene ANSI-Optionen, die der Treiber verwenden soll, und ob ein Failover-Server verwendet werden soll.

Feld Die Standarddatenbank ändern auf

Hier wird der Name der Standarddatenbank für alle Verbindungen festgelegt, die diese Datenquelle verwenden. Ist dieses Kontrollkästchen deaktiviert, verwenden Verbindungen die Standarddatenbank, die für den Benutzernamen auf dem Server definiert wurde. Ist das Kontrollkästchen aktiviert, überschreibt die Datenbank in diesem Feld die Standarddatenbank, die für den Benutzernamen definiert wurde. Wenn im Feld Datenbank-Dateinamen anfügen der Name einer Primärdatei angegeben wird, wird die durch die Primärdatei angegebene Datenbank als Datenbank angehängt, wobei der Name verwendet wird, der im Feld Die Standarddatenbank ändern auf angegeben wurde.

Das Verwenden der Standarddatenbank für den Benutzernamen ist effizienter als das Festlegen einer Standarddatenbank in der ODBC-Datenquelle.

Datenbank-Dateinamen anfügen

Legt den Namen der Primärdatei für eine anzuhängende Datenbank fest. Diese Datenbank wird für die Datenquelle als Standarddatenbank angehängt und verwendet. Geben Sie für die Primärdatei den vollständigen Pfad und Dateinamen ein. Der im Feld Die Standarddatenbank ändern auf angegebene Datenbankname wird als Name für die angehängte Datenbank verwendet.

Kontrollkästchen Temporär gespeicherte Prozeduren für vorbereitete SQL-Anweisungen erstellen und gespeicherte Prozeduren löschen

Ist diese Einstellung deaktiviert, erstellt der Microsoft® SQL Server™-Treiber keine gespeicherten Prozeduren, um die ODBC-Funktion SQLPrepare zu unterstützen. Ist diese Einstellung aktiviert, erstellt der SQL Server-Treiber temporär gespeicherte Prozeduren, die die ODBC-Funktion SQLPrepare zu unterstützen. Dieses Kontrollkästchen und die dazugehörigen Optionen sind nur bei der Verbindung zu älteren Versionen von SQL Server relevant.

Optionsfeld Nur beim Trennen

Hier wird festgelegt, dass temporär gespeicherte Prozeduren, die für SQLPrepare erstellt wurden, beim Aufrufen der ODBC-Funktion SQLDisconnect gelöscht werden. Dadurch kann der Treiber gespeicherte Prozeduren erneut verwenden, wenn dieselbe SQL-Anweisung mehrfach vorbereitet wird; außerdem wird der Speicherraum reduziert, der dem Löschen von gespeicherten Prozeduren zugewiesen wird, während die Anwendung ausgeführt wird. Das Aktivieren dieser Option für eine Anwendung, die lange Zeit ohne Abtrennen der Verbindung ausgeführt wird, oder für eine Anwendung, die viele SQLPrepare-Aufrufe ausgibt, führt zu einer Anhäufung von temporär gespeicherten Prozeduren.

Optionsfeld Beim Trennen und bei geeigneter Situation während der Verbindung

Diese Einstellung legt fest, dass für SQLPrepare erstellte, temporär gespeicherte Prozeduren gelöscht werden, wenn SQLDisconnect aufgerufen wird, wenn SQLFreeHandle für das Anweisungshandle aufgerufen wird, wenn SQLPrepare oder SQLExecDirect zur Verarbeitung einer neuen SQL-Anweisung an der gleichen Anweisungszugriffsnummer aufgerufen wird, oder wenn eine Katalogfunktion aufgerufen wird. Es wird etwas Speicherraum belegt, da temporär gespeicherte Prozeduren während des Ausführens der Anwendung gelöscht werden. Trotzdem verhindert diese Einstellung eine Anhäufung von temporär gespeicherten Prozeduren für Anwendungen, die über lange Zeit hinweg ausgeführt werden.

Kontrollkästchen ANSI-Anführungszeichen verwenden

Diese Einstellung legt fest, dass QUOTED_IDENTIFIERS aktiviert sind, wenn der SQL Server ODBC-Treiber eine Verbindung herstellt. Ist dieses Kontrollkästchen aktiviert, wendet der SQL Server die ANSI-Regeln bezüglich Anführungszeichen an. Doppelte Anführungszeichen können nur für Kennungen wie Spalten- und Tabellennamen verwendet werden. Zeichenfolgen müssen in einfachen Anführungszeichen stehen:

SELECT "au_id"

FROM "authors"

WHERE "au_lname" = 'O''Brien'

Ist das Kontrollkästchen nicht aktiviert, treten bei Anwendungen, die Bezeichner in Anführungszeichen setzen, Fehler auf, sobald SQL-Anweisungen mit Bezeichnern in Anführungszeichen erzeugt werden. Ein Beispiel dafür ist das Microsoft Query-Programm, das mit Microsoft Excel geliefert wird.

Kontrollkästchen ANSI-Nullen, -Leerstellen und -Warnungen verwenden

Diese Einstellung legt fest, dass die Optionen ANSI_NULLS, ANSI_WARNINGS und ANSI_PADDINGS aktiviert sind, wenn der SQL Server-Treiber eine Verbindung herstellt.

Ist ANSI_NULLS aktiviert, wendet der Server ANSI-Regeln ungeachtet der Vergleichsspalten für NULL an. Die ANSI-Syntax IS NULL oder IS NOT NULL muss für alle NULL-Vergleichsvorgänge verwendet werden. Die Transact-SQL-Syntax = NULL wird nicht unterstützt.

Ist ANSI_WARNINGS aktiviert, gibt der SQL Server Warnmeldungen bei Bedingungen aus, die die ANSI-Regeln, aber nicht die Regeln einer Transact-SQL-Anweisung verletzen. Beispiele für diese Fehler sind das Abschneiden von Daten beim Ausführen einer INSERT- oder UPDATE-Anweisung oder das Auftreten eines Null-Wertes während einer Aggregatfunktion.

Ist ANSI_PADDING aktiviert, werden nachstehende Leerzeichen bei varchar-Werten und nachstehende Nullen bei varbinary-Werten nicht automatisch abgeschnitten.

Kontrollkästchen Failover-SQL Server verwenden, wenn der primäre SQL Server nicht verfügbar ist

Diese Einstellung legt fest, dass der SQL Server-Treiber beim Herstellen einer Verbindung zum festgelegten Primärserver Verbindungsinformationen für den Failover-Server sammelt. Dies gilt für den Fall, dass ein Failover SQL-Server für den SQL Server in der Datenquelle festgelegt wurde. Sollte die Anwendung die Verbindung zum Primär-SQL Server verlieren, wird die aktuelle Transaktion gelöscht und versucht, erneut eine Verbindung zum Primär-SQL Server herzustellen. Wenn der Treiber feststellt, dass der Primärserver nicht mehr verfügbar ist, wird automatisch eine Verbindung zum Failover-Server hergestellt. Diese Option ist deaktiviert, wenn der Server Failover-Vorgänge nicht unterstützt.


Datenquellen-Assistent - Bildschirm 4

Datenquellen-Assistent – Bildschirm 4

Auf dem vierten Bildschirm des Assistenten legen Sie die Sprache fest, die für Microsoft® SQL Server™-Meldungen verwendet werden soll, die Zeichensatzumwandlung, und ob der SQL Server-Treiber die Ländereinstellungen des Clients verwenden soll. Sie können auch das Protokollieren von langfristigen Anfragen und Treiber-Statistikeinstellungen steuern.

Feld Sprache der SQL Server-Systemmeldungen ändern auf:

Jeder SQL Server kann über mehrere Reihen von Systemmeldungen verfügen, wobei jede Reihe in einer anderen Sprache vorhanden ist (Englisch, Spanisch, Französisch usw.). Wenn eine Datenquelle für einen Server definiert wurde, der über mehrere Reihen von Systemmeldungen verfügt, können Sie eine Sprache für die Systemmeldungen auswählen. Klicken Sie in der Liste auf eine Sprache. Diese Option ist nicht verfügbar, wenn auf dem SQL Server nur eine Sprache installiert ist.

Kontrollkästchen Konvertierung für Zeichendaten ausführen

Ist dieses Kästchen aktiviert, konvertiert der SQL Server-ODBC-Treiber ANSI-Zeichenfolgen, die zwischen dem Clientcomputer und SQL Server unter Verwendung von Unicode gesendet werden. Der SQL Server ODBC-Treiber konvertiert gelegentlich zwischen der SQL Server-Codeseite und Unicode auf dem Client. Dazu muss die vom SQL Server verwendete Codeseite eine der auf dem Clientcomputer verfügbaren Codeseiten sein.

Wenn dieses Feld deaktiviert ist, werden erweiterte Zeichen nicht in ANSI-Zeichenfolgen umgewandelt, wenn sie zwischen Clientanwendung und SQL Server ausgetauscht werden. Wenn der Clientcomputer eine ANSI-Codeseite (ACP) verwendet, die sich von der Codeseite des SQL Servers unterscheidet, werden erweiterte ANSI-Zeichenfolgen u.U. falsch interpretiert. Wenn die ANSI-Codeseite (ACP) auf dem Clientcomputer der Codeseite des SQL Servers entspricht, werden erweiterte ANSI-Zeichenfolgen richtig interpretiert.

Kontrollkästchen Ländereinstellungen bei der Anzeige von Währungs-, Zahlen-, Datums- und Zeitangaben verwenden

Diese Einstellung legt fest, dass der Treiber für das Format von Währung, Zahlen, Datum und Zeit in Ausgabezeichenfolgen die Ländereinstellungen des Client-Computers verwendet. Der Treiber verwendet die standardmäßigen Ländereinstellungen für das Microsoft Windows® 95/98-, Microsoft Windows NT®- oder Microsoft Windows® 2000-Anmeldekonto des Benutzers, der mit der Datenquelle eine Verbindung herstellt. Wählen Sie diese Option für Anwendungen aus, die nur Daten anzeigen, jedoch nicht für Anwendungen, die Daten verarbeiten.

Feld Abfragen mit langer Laufzeit in dieser Protokolldatei speichern:

Diese Einstellung legt fest, dass der Treiber jede Abfrage protokolliert, die länger dauert als unter Mindestlaufzeit für Protokollierung angegeben. Abfragen mit langer Laufzeit werden in der angegebenen Datei protokolliert. Im darauffolgenden Dialogfeld können Sie die vorhandenen Ordner nach der gewünschten Protokolldatei durchsuchen.

Feld Mindestlaufzeit für Protokollierung (in Millisekunden)

Hier wird ein Schwellenwert für das Protokollieren von Abfragen mit langer Laufzeit festgelegt (in Millisekunden). Jede Abfrage, die länger ausgeführt wird, wird protokolliert.

Feld ODBC-Treiberstatistik in dieser Protokolldatei protokollieren:

Hier wird festgelegt, dass die Statistik protokolliert wird. Die Statistik wird in der angegebenen Datei protokolliert. Im darauffolgenden Dialogfeld können Sie die vorhandenen Ordner nach der gewünschten Protokolldatei durchsuchen.

Das Statistikprotokoll ist eine tabulatorbegrenzte Datei, die in Microsoft Excel oder jedem anderen Programm analysiert werden kann, das tabulatorbegrenzte Dateien unterstützt.


Dialogfeld "SQL Server-Anmeldung"

Dialogfeld "SQL Server-Anmeldung"

Das Dialogfeld SQL Server-Anmeldung wird vom Microsoft® SQL Server™ ODBC-Treiber angezeigt, wenn Sie eine ODBC-Verbindung aufrufen, ohne genügend Informationen zum Herstellen einer Verbindung durch den Treiber anzugeben.

Wenn das Dialogfeld SQL Server-Anmeldung zum ersten Mal angezeigt wird, enthält es nur folgende Elemente:

Das Feld Server oder den Namen einer Datenquelle.

Kontrollkästchen Vertrauenswürdige Verbindung verwenden

Feld Benutzername

Feld Kennwort

Schaltflächen OK, Abbrechen und Optionen

Wenn Sie auf die Schaltfläche Optionen klicken, wird auch die Gruppe mit Optionen angezeigt:

Feld Datenbank

Feld Sprache

Feld Anwendungsname

Feld Arbeitsstations-ID

Feld Server

Der Name eines SQL Servers im Netzwerk. Wenn Sie einen Servernamen aus der Liste auswählen, sind keine weiteren Konfigurationseinstellungen erforderlich. Wenn Sie den Namen eines Servers eingeben, muss dies ein erweiterter Eintrag in dem SQL Clientkonfigurationsprogramm sein oder der Netzwerkname eines Servers, auf dem SQL Server ausgeführt wird. Dieses Feld wird mit den Datenquellennamen (DSN) ersetzt, wenn Sie einen Datenquellennamen für die Verbindung angeben.

Sie können (lokal) in dem Serverfeld auswählen, wenn sich auf dem Computer, an dem Sie arbeiten, auch SQL Server befindet. Der Benutzer kann dann eine Verbindung zur lokalen Kopie vom SQL Server herstellen, sogar dann, wenn eine Version vom SQL Server ausgeführt wird, die sich nicht im Netzwerk befindet.

Weitere Informationen über Servernamen für verschiedene Netzwerkarten finden Sie in der Installationsdokumentation von SQL Server in der Onlinedokumentation von SQL Server.

Kontrollkästchen Vertrauenswürdige Verbindung verwenden

Ist das Kontrollkästchen aktiviert, legt es fest, dass der SQL Server-ODBC-Treiber eine sichere (vertraute) Verbindung mit einem SQL Server anfordert, auf dem Microsoft Windows NT® oder Microsoft Windows® 2000 ausgeführt wird. Bei aktivierter Option verwendet SQL Server die integrierte Anmeldungssicherheit, um Verbindungen mit dieser Datenquelle herzustellen, und zwar unabhängig vom aktuellen Ameldungssicherheitsmodus auf dem Server. Angegebene Benutzernamen oder Kennwörter werden ignoriert. Der Systemadministrator vom SQL Server muss Ihrer Windows Netzwerk-ID eine ID für die SQL Server-Anmeldungs-ID zugeordnet haben.

Ist dieses Kontrollkästchen nicht aktiviert, verwendet der SQL Server zum Herstellen von Verbindungen mit dieser Datenquelle die standardmäßige Anmeldungssicherheit. Hier müssen Sie bei allen Verbindungsanforderungen einen Benutzernamen und ein Kennwort angeben.

Feld Benutzername

Hier wird die SQL Server-Anmeldungs-ID festgelegt, die für die Verbindung verwendet werden soll, wenn Vertrauenswürdige Verbindung verwenden nicht aktiviert ist. Wenn Vertrauenswürdige Verbindung verwenden ausgewählt wurde, ist das Feld Benutzername deaktiviert.

Feld Kennwort

Hier wird das Kennwort für die SQL Server-Anmeldungs-ID festgelegt, das verwendet wird, wenn Vertrauenswürdige Verbindung verwenden nicht aktiviert ist. Wenn Vertrauenswürdige Verbindung verwenden ausgewählt wurde, ist das Feld Kennwort deaktiviert.

Feld Datenbank

Hier wird die Standarddatenbank angegeben, die bei der Verbindung verwendet werden soll. Diese Angabe überschreibt die Standarddatenbank, die für die Anmeldung auf dem Server angegeben wurde. Wird keine Datenbank festgelegt, verwendet die Verbindung die Standarddatenbank, die für die Anmeldung auf dem Server festgelegt wurde.

Feld Sprache

Hier wird die Landessprache für SQL Server-Systemmeldungen festgelegt. Die ausgewählte Sprache muss auf dem SQL Server installiert sein. Hierdurch wird die Standardsprache überschrieben, die für die Anmeldung beim Server angegeben wurde. Wenn keine Sprache festgelegt wurde, wird für die Verbindung die Standardsprache verwendet, die für die Anmeldung beim Server angegeben wurde.

Feld Anwendungsname

Hier kann optional der Anwendungsname angegeben werden, der unter master.dbo.sysprocesses in der Spalte program_name in der Zeile für diese Verbindung gespeichert wird.

Feld Arbeitsstations-ID

Hier kann optional die Arbeitsstations-ID angegeben werden, die unter master.dbo.sysprocesses in der Spalte hostname in der Zeile für diese Verbindung gespeichert wird.


SQL Server 2000 Copyright und Verzichterklärung

Dieses Dokument, einschließlich der enthaltenen Beispielanwendungen, wird nur zu Informationszwecken bereitgestellt; Microsoft übernimmt in diesem Dokument keine Garantien, weder ausdrücklich noch stillschweigend. In diesem Dokument enthaltene Informationen, einschließlich Beispiele, URL und andere Internet-Website-Referenzen, können ohne vorherige Ankündigung geändert werden. Der Benutzer trägt das vollständige Risiko für die Verwendung oder für die sich aus der Verwendung dieses Dokuments ergebenden Konsequenzen.

Ein Beispiel hat die primäre Aufgabe, ein Konzept oder die angemessene Verwendung einer bestimmten Anweisung oder Klausel zu verdeutlichen. Die meisten Beispiele enthalten nicht sämtlichen Code, der normalerweise in einem vollständigen Produktionssystem zu finden ist. Es wurden viele der üblichen Datenbestätigungs- und Fehlerbehandlungsinformationen entfernt, damit sich das Beispiel auf ein bestimmtes Konzept oder eine bestimmte Anweisung konzentrieren kann. Für diese Beispiele oder für den bereitgestellten Quellcode ist keine technische Unterstützung verfügbar.

Wenn nicht anders angegeben, sind die hier als Beispiel genannten Firmen, Organisationen, Produkte, Personen und Ereignisse fiktiv, und es wird kein Zusammenhang mit irgend einer tatsächlichen Firma, Organisation, Produkt, Person oder Ereignis beabsichtigt oder abgeleitet. Das Einhalten sämtlicher zur Anwendung kommenden Copyright-Vorschriften liegt in der Verantwortung des Benutzers. Ohne die durch das Copyright geschützten Rechte einzuschränken, darf kein Teil dieses Dokuments reproduziert, gespeichert oder in ein Abrufsystem eingeführt werden, oder in irgend einer Form, auf irgend eine Weise (elektronisch, mechanisch, per Fotokopie, Aufnahme oder anderweitig) oder für irgend einen Zweck übertragen werden, ohne daß eine ausdrückliche schriftliche Genehmigung der Microsoft Corporation erteilt wurde.

Microsoft kann Patente, Patentanwendungen, Warenzeichen, Copyrights oder andere geistige Eigentumsrechte haben, die Themenbereiche in diesem Dokument abdecken. Sie erhalten durch Bereitstellung dieses Dokument keine Lizenz für diese Patente, Warenzeichen, Copyrights oder anderes geistiges Eigentum, es sei denn, dies ist ausdrücklich in einer schriftlichen Lizenzvereinbarung von Microsoft festgelegt.

©1996-2000 Microsoft Corporation. Alle Rechte vorbehalten.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Win32, Windows 2000, Windows und Windows NT sind entweder eingetragene Warenzeichen oder Warenzeichen der Microsoft Corporation in den USA und/oder anderen Ländern.

Die Namen von in diesem Dokument erwähnten tatsächlichen Firmen und Produkten können Warenzeichen des jeweiligen Eigentümers sein.