Was ist das SQL Server-Clientkonfigurationsprogramm?

Send us feedback about this page Hilfe zum SQL Server-Clientkonfigurationsprogramm

Was ist das SQL Server-Clientkonfigurationsprogramm?

Das SQL Server-Clientkonfigurationsprogramm ist ein grafisches Tool, mit dem Sie folgende Operationen durchführen können:

  • Erstellen von Netzwerkprotokollverbindungen zu angegebenen Servern und Ändern des Standardnetzwerkprotokolls.

  • Anzeigen von Informationen über die aktuell auf dem System installierten Netzwerkbibliotheken.

  • Anzeigen der aktuell auf dem System installierten DB-Library-Version und Setzen von Standards für DB-Bibliotheksoptionen.

Weitere Informationen über das SQL Server-Clientkonfigurationsprogramm finden Sie unter dem Abschnitt zur Verwaltung von Clients in der Onlinedokumentation von SQL Server.

©1988-2000 Microsoft Corporation. Alle Rechte vorbehalten.


Registerkarte "Allgemein"

Registerkarte "Allgemein"

Dieser Abschnitt zeigt die auf der Registerkarte Allgemein verfügbaren Optionen und ihre Funktionen.

Optionen

Deaktivierte Protokolle

Zeigt die verfügbaren Protokolle, die aktuell auf diesem Computer nicht aktiviert sind. Zum Aktivieren eines Protokolls wählen Sie das Protokoll aus und drücken auf Aktivieren.

Aktivierte Protokolle in Reihenfolge

Zeigt die aktuell auf diesem Computer aktivierten Protokolle. Die Protokolle sind in der Reihenfolge aufgelistet, in der das System versucht, sie für Verbindungen zu verwenden.

Aktivieren

Aktiviert das in der Liste Deaktivierte Protokolle aktuell ausgewählte Protokoll. Durch Doppelklicken auf das Protokoll wird diese Funktion ebenfalls ausgeführt.

Deaktivieren

Deaktiviert das in der Liste Aktivierte Protokolle in Reihenfolge aktuell ausgewählte Protokoll. Durch Doppelklicken auf das Protokoll wird diese Funktion ebenfalls ausgeführt.

Schaltflächen "Nach oben" und "Nach unten"

Verschiebt das ausgewählte Protokoll in der Liste nach oben oder unten. Damit können Sie die Reihenfolge ändern, in der die Netzwerkbibliothek versucht, die Protokolle für Verbindungen zu verwenden.

Eigenschaften

Zeigt die standardmäßigen Verbindungseigenschaften des ausgewählten Protokolls an.

Protokollverschlüsselung erzwingen

Aktiviert die Protokollverschlüsselung mit Secure Sockets Layer (SSL).

Gemeinsam genutztes Speicherprotokoll aktivieren

Aktiviert die Protokollierung im gemeinsam genutzten Speicherbereich für Verbindungen innerhalb desselben Computers.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration

Überprüfen, dass SQL Server AppleTalk überwacht


Named Pipes-Protokoll-Standardwert Setup

Named Pipes-Protokoll-Standardwert Setup

Dieser Abschnitt zeigt die im Dialogfeld Einrichten des Standardwertes für das Netzwerkprotokoll für Named Pipes verfügbaren Optionen und ihre Funktionen.

Optionen

Standardpipe

Gibt die Standardpipe an, die die Named Pipes-Netzwerkbibliothek für Verbindungsversuche zur Zielinstanz von Microsoft® SQL Server™ verwendet.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Anlegen eines Alias zu einer alternativen Pipe

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


TCP/IP-Protokoll-Standardwert Setup

TCP/IP-Protokoll-Standardwert Setup

Dieser Abschnitt zeigt die im Dialogfeld Einrichten des Standardwertes für das Netzwerkprotokoll für TCP/IP verfügbaren Optionen und ihre Funktionen.

Optionen

Standardanschluss

Gibt den Anschluss an, den die TCP/IP-Netzwerkbibliothek für Verbindungsversuche zur Zielinstanz von Microsoft® SQL Server™ verwendet. Der Standard lautet 1433.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung von TCP/IP

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Multiprotokoll-Protokoll-Standardwert Setup

Multiprotokoll-Protokoll-Standardwert Setup

Dieser Abschnitt zeigt die im Dialogfeld Einrichten des Standardwertes für das Netzwerkprotokoll für Multiprotokoll verfügbaren Optionen und ihre Funktionen.

Optionen

RPC-Protokolle

Listet die Protokolle auf, die von der Multiprotokoll-Netzwerkbibliothek verwendet werden, um die Verbindung mit der Zielinstanz von Microsoft® SQL Server™ herzustellen. Die Multiprotokoll-Netzwerkbibliothek verwendet die Protokolle in der angegebenen Reihenfolge, bis eine Verbindung hergestellt werden kann. Die Namen der Protokolle sind unten aufgelistet. Die Protokollnamen müssen durch ein Leerzeichen getrennt werden.

Protokoll | Name
Multiprotokoll | nlrpc
Named Pipes | nacn_np
TCP/IP | nacn_ip_tcp
IPX/SPX | nacn_spx

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung der Multiprotokoll-Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


NWLink IPX/SPX-Protokoll-Standardwert Setup

NWLink IPX/SPX-Protokoll-Standardwert Setup

Dieser Abschnitt zeigt die im Dialogfeld Einrichten des Standardwertes für das Netzwerkprotokoll für NWLink IPX/SPX verfügbaren Optionen und ihre Funktionen.

Optionen

Standardnetzwerk

Gibt die NetWare-Netzwerknummer an. Der Standardwert ist 0.

Standardanschluss

Gibt die Socket-Nummer an. Der Standardwert ist 33854.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung der NWLink IPX/SPX-Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


AppleTalk-Protokoll-Standardwert Setup

AppleTalk-Protokoll-Standardwert Setup

Dieser Abschnitt zeigt die im Dialogfeld Einrichten des Standardwertes für das Netzwerkprotokoll für AppleTalk verfügbaren Optionen und ihre Funktionen.

Optionen

Standardzone

Gibt die Zone beim Registrieren des Dienstes an.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung der AppleTalk-Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Banyan VINES-Protokoll-Standardwert Setup

Banyan VINES-Protokoll-Standardwert Setup

Dieser Abschnitt zeigt die im Dialogfeld Einrichten des Standardwertes für das Netzwerkprotokoll für Banyan VINES verfügbaren Optionen und ihre Funktionen.

Optionen

Standardgruppe

Gibt die Gruppe an, zu der der Dienst gehört.

Standardunternehmen

Gibt das Unternehmen an, zu der die Gruppe gehört.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung der Banyan VINES-Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Einrichten des Standardwertes für das Netzwerkprotoll für VIA

Einrichten des Standardwertes für das Netzwerkprotokoll für VIA

Dieser Abschnitt zeigt die im Dialogfeld Einrichten des Standardwertes für das Netzwerkprotokoll für VIA verfügbaren Optionen und ihre Funktionen.

Optionen

Hersteller

Gibt den Hardwareanbieter an, der mit dem VIA-Protokoll verwendet wird.

Standardserveranschluss

Gibt den Standardserveranschluss an. Der Standardwert ist 0:1433.

Standardclient-NIC

Gibt die Netzwerkschnittstellenkarte für den Standardclient an. Der Standardwert ist 0.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Registerkarte "Alias"

Registerkarte "Alias"

Dieser Abschnitt zeigt die auf der Registerkarte Alias verfügbaren Optionen und ihre Funktionen.

Optionen

Serveraliaskonfigurationen

Listet Informationen zu den Serveraliasen der Computer auf, zu denen der Client eine Verbindung herstellt.

Serveralias

Zeigt den für den Computer verwendeten Serveralias, zu dem der Client eine Verbindung herstellt.

Netzwerkbibliothek

Zeigt die Client-Netzwerkbibliothek, die für den Konfigurationseintrag verwendet wird.

Verbindungsparameter

Zeigt die Parameter, die mit der Verbindungsadresse für die Netzwerkbibliothekskonfiguration verknüpft sind.

Hinzufügen

Fügt eine neue Netzwerkbibliothekskonfiguration hinzu.

Entfernen

Entfernt eine Netzwerkbibliothekskonfiguration.

Bearbeiten

Bearbeitet eine Netzwerkbibliothekskonfiguration.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration

Überprüfen, dass SQL Server AppleTalk überwacht


Hinzufügen (oder Bearbeiten) der Named Pipes-Bibliothekskonfiguration

Hinzufügen (oder Bearbeiten) der Named Pipes-Bibliothekskonfiguration

Dieser Abschnitt zeigt die im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen (oder bearbeiten) für Named Pipes verfügbaren Optionen und ihre Funktionen.

Optionen

Serveralias

Gibt einen eindeutigen Namen für die Instanz von Microsoft® SQL Server™ an, die die Named Pipes-Netzwerkbibliothek überwacht.

Netzwerkbibliotheken

Gibt die Netzwerkbibliothek an, die für die Verbindung zum Server verwendet wird. Named Pipes ist ausgewählt.

Servername

Gibt den Servernamen der Zielinstanz von SQL Server an.

Pipename

Gibt die Pipe an, die die Named Pipes-Netzwerkbibliothek für Verbindungsversuche zur Zielinstanz von SQL Server verwendet.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Anlegen eines Alias zu einer alternativen Pipe

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Hinzufügen (oder Bearbeiten) der TCP/IP-Bibliothekskonfiguration

Hinzufügen (oder Bearbeiten) der TCP/IP-Bibliothekskonfiguration

Dieser Abschnitt zeigt die im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen (oder bearbeiten) für TCP/IP verfügbaren Optionen und ihre Funktionen.

Optionen

Serveralias

Gibt einen eindeutigen Namen für den Server an, auf dem eine Instanz von Microsoft® SQL Server™ ausgeführt wird, die die TCP/IP-Sockets-Netzwerkbibliothek überwacht.

Netzwerkbibliotheken

Gibt die Netzwerkbibliothek an, die für die Verbindung zum Server verwendet wird. TCP/IP ist ausgewählt.

Servername

Gibt die Instanz von SQL Server an, die die TCP/IP-Socketsclients überwacht.

Anschluss dynamisch bestimmen

Gibt an, dass die Netzwerkbibliothek dynamisch bestimmt wird. Der im Feld Anschlussnummer angegebene Anschluss wird nicht verwendet.

Anschlussnummer

Gibt den Anschluss an, den die TCP/IP-Netzwerkbibliothek verwendet, um die Verbindung mit der Zielinstanz von SQL Server herzustellen. Der Standardwert ist 1433. Diese Anschlussnummer wird von der Windows Sockets-Netzwerkbibliothek normalerweise für SQL Server verwendet. Sie können in den meisten Fällen die Standardanschlussnummer verwenden. Dieses Feld ist nur aktiv, wenn das Kontrollkästchen Anschluss dynamisch bestimmen deaktiviert ist.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung von TCP/IP

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Hinzufügen (oder Bearbeiten) der Multiprotokoll-Bibliothekskonfiguration

Hinzufügen (oder Bearbeiten) der Multiprotokoll-Bibliothekskonfiguration

Dieser Abschnitt zeigt die im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen (oder bearbeiten) für Multiprotokoll verfügbaren Optionen und ihre Funktionen.

Optionen

Serveralias

Gibt einen eindeutigen Namen für den Server an, auf dem eine Instanz von Microsoft® SQL Server™ ausgeführt wird, die die Multiprotokoll-Netzwerkbibliothek überwacht.

Netzwerkbibliotheken

Gibt die Netzwerkbibliothek an, die für die Verbindung zum Server verwendet wird. Multiprotokoll ist ausgewählt.

Servername

Gibt die Instanz von SQL Server an, die Multiprotokoll-Clients überwacht.

Weitere Parameter

Gibt zusätzliche Konfigurationsparameter für die Multiprotokoll-Netzwerkbibliothek an. Diese Parameter sind optional.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung der Multiprotokoll-Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Hinzufügen (oder Bearbeiten) der NWLink IPX/SPX-Bibliothekskonfiguration (Dienstname)

Hinzufügen (oder Bearbeiten) der NWLink IPX/SPX-Bibliothekskonfiguration (Dienstname)

Dieser Abschnitt zeigt die im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen (oder bearbeiten) für NWLink IPX/SPX verfügbaren Optionen und ihre Funktionen.

Optionen

Serveralias

Gibt einen eindeutigen Namen für den Server an, auf dem eine Instanz von Microsoft® SQL Server™ ausgeführt wird, die die NWLink IPX/SPX-Netzwerkbibliothek überwacht.

Netzwerkbibliotheken

Gibt die Netzwerkbibliothek an, die für die Verbindung zum Server verwendet wird. NWLink IPX/SPX ist ausgewählt.

Parameter angeben nach

Gibt an, wie Parameter festgelegt sind. Dienstname ist ausgewählt.

Dienstname

Gibt den Microsoft Windows NT® 4.0- oder Windows® 2000-Computernamen an, unter dem eine Instanz von SQL Server ausgeführt wird. Diese Informationen werden in der Bindery des Servers gespeichert.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung der NWLink IPX/SPX-Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Hinzufügen (oder Bearbeiten) der NWLink IPX/SPX-Bibliothekskonfiguration (Netzwerkadresse)

Hinzufügen (oder Bearbeiten) der NWLink IPX/SPX-Bibliothekskonfiguration (Netzwerkadresse)

Dieser Abschnitt zeigt die im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen (oder bearbeiten) für NWLink IPX/SPX verfügbaren Optionen und ihre Funktionen.

Optionen

Serveralias

Gibt einen eindeutigen Namen für den Server an, auf dem eine Instanz von Microsoft® SQL Server™ ausgeführt wird, die die NWLink IPX/SPX-Netzwerkbibliothek überwacht.

Netzwerkbibliotheken

Gibt die Netzwerkbibliothek an, die für die Verbindung zum Server verwendet wird. NWLink IPX/SPX ist ausgewählt.

Parameter angeben nach

Gibt an, wie Parameter festgelegt sind. Netzwerkadresse ist ausgewählt.

Adresse

Gibt die MAC-Adresse an.

Anschluss

Gibt die Socket-Nummer an. Der Standardwert ist 33854.

Netzwerk

Gibt die NetWare-Netzwerknummer an. Der Standardwert ist 0.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung der NWLink IPX/SPX-Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Hinzufügen (oder Bearbeiten) der AppleTalk-Bibliothekskonfiguration

Hinzufügen (oder Bearbeiten) der AppleTalk-Bibliothekskonfiguration

Dieser Abschnitt zeigt die im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen (oder bearbeiten) für AppleTalk verfügbaren Optionen und ihre Funktionen.

Optionen

Serveralias

Gibt einen eindeutigen Namen für den Server an, auf dem eine Instanz von Microsoft® SQL Server™ ausgeführt wird, die die AppleTalk-Netzwerkbibliothek überwacht.

Netzwerkbibliotheken

Gibt die Netzwerkbibliothek an, die für die Verbindung zum Server verwendet wird. AppleTalk ist ausgewählt.

Objektname

Geben Sie das vom Systemadministrator zugewiesene Dienstobjekt an.

Zone

Gibt die Zone beim Registrieren des Dienstes an.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung der AppleTalk-Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Hinzufügen (oder Bearbeiten) der Banyan VINES-Bibliothekskonfiguration

Hinzufügen (oder Bearbeiten) der Banyan VINES-Bibliothekskonfiguration

Dieser Abschnitt zeigt die im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen (oder bearbeiten) für Banyan VINES verfügbaren Optionen und ihre Funktionen.

Optionen

Serveralias

Gibt einen eindeutigen Namen für den Server an, auf dem eine Instanz von Microsoft® SQL Server™ ausgeführt wird, die die Banyan VINES-Netzwerkbibliothek überwacht.

Netzwerkbibliotheken

Gibt die Netzwerkbibliothek an, die für die Verbindung zum Server verwendet wird. Banyan VINES ist ausgewählt.

Dienst

Gibt den vom Server verwendeten StreetTalk PC-basierten Dienstnamen an.

Gruppe

Gibt die Gruppe an, zu der der Dienst gehört.

Organisation

Gibt das Unternehmen an, zu der die Gruppe gehört.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung der Banyan VINES-Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Hinzufügen (oder Bearbeiten) der VIA-Bibliothekskonfiguration

Hinzufügen (oder Bearbeiten) der VIA-Bibliothekskonfiguration

Dieser Abschnitt zeigt die im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen (oder bearbeiten) für VIA verfügbaren Optionen und ihre Funktionen.

Optionen

Serveralias

Gibt einen eindeutigen Namen für den Server an, auf dem eine Instanz von Microsoft® SQL Server™ ausgeführt wird, die die VIA-Netzwerkbibliothek überwacht.

Netzwerkbibliotheken

Gibt die Netzwerkbibliothek an, die für die Verbindung zum Server verwendet wird. VIA ist ausgewählt.

Servername

Gibt die Instanz von SQL Server an, die VIA-Clients überwacht.

Serveranschlussnummer

Gibt die Serveranschlussnummer an, die beim Herstellen der Verbindung mit der Instanz von SQL Server verwendet wird. Der Standardwert ist 0:1433.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Hinzufügen (oder Bearbeiten) anderer Bibliothekskonfigurationen

Hinzufügen (oder Bearbeiten) anderer Bibliothekskonfigurationen

Dieser Abschnitt zeigt die im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen (oder bearbeiten) für andere Protokolle verfügbaren Optionen und ihre Funktionen.

Optionen

Serveralias

Gibt einen eindeutigen Namen für den Server an, auf dem eine Instanz von Microsoft® SQL Server™ ausgeführt wird, die die neue Netzwerkbibliothekskonfiguration überwacht.

Netzwerkbibliotheken

Gibt die Netzwerkbibliothek an, die für die Verbindung zum Server verwendet wird. Andere ist ausgewählt.

Dateiname

Gibt den Namen und Speicherort der DLL für die von dritter Seite bereitgestellte Netzwerkbibliothek an.

Parameter

Gibt alle erforderlichen Parameter und ihr Format an.

Hinzufügen einer Netzwerkbibliothekskonfiguration

Konfigurieren eines Clients für die Verwendung einer nicht dem Standard entsprechenden Netzwerkbibliothek

Löschen einer Netzwerkbibliothekskonfiguration

Bearbeiten einer Netzwerkbibliothekskonfiguration


Registerkarte "DB-Bibliotheksoptionen"

Registerkarte "DB-Bibliotheksoptionen"

Dieser Abschnitt zeigt die auf der Registerkarte DB-Bibliotheksoptionen verfügbaren Optionen und ihre Funktionen.

Optionen

Dateiname

Zeigt den Dateinamen und Speicherort der auf diesem Computer installierten DB-Bibliothek.

Version

Zeigt die Versionsnummer der auf diesem Computer installierten DB-Bibliothek.

Datum

Zeigt das Datum, an dem die DB-Bibliothek auf diesem Computer installiert wurde.

Größe

Zeigt die Dateigröße der auf diesem Computer installierten DB-Bibliothek.

Automatische Konvertierung von ANSI in OEM

Ermöglicht DB-Library die Konvertierung eines Zeichensatzes von OEM in ANSI bei der Kommunikation mit Microsoft® SQL Server™ vom Client und von ANSI in OEM bei der Kommunikation mit dem Client von SQL Server. Standardmäßig ausgewählt.

Internationale Einstellungen verwenden

Ermöglicht DB-Library das Abrufen von Datums-, Zeit- und Währungsformaten vom System anstelle der Verwendung von hart codierten Parametern. Standardmäßig ausgewählt für Clients, die auf Microsoft Windows® 32-Bit-Betriebssystemen ausgeführt werden.

Setzen von DB-Library-Konvertierungspräferenzen


Registerkarte "Netzwerkbibliotheken"

Registerkarte "Netzwerkbibliotheken"

Dieser Abschnitt zeigt die auf der Registerkarte Netzwerkbibliotheken verfügbaren Optionen und ihre Funktionen.

Optionen

Netzwerkbibliothek

Listet die auf diesem Computer installierten Microsoft® SQL Server™-Client-Netzwerkbibliotheken auf.

Bibliotheksdateiname

Listet den Speicherort der auf diesem Computer installierten SQL Server-Client-Netzwerkbibliotheken auf.

Version

Listet die Versionsnummern der auf diesem Computer installierten SQL Server-Client-Netzwerkbibliotheken auf.

Dateidatum

Listet das Datum auf, an dem die SQL Server-Client-Netzwerkbibliotheken auf diesem Computer installiert wurden.

Größe

Listet die Dateigrößen der auf diesem Computer installierten SQL Server-Client-Netzwerkbibliotheken auf.

Anzeigen der Bibliotheksversionsnummern


Verwalten von Clients

Verwalten von Clients

Ein Client ist eine Schnittstellenanwendung, die die von einem Server bereitgestellten Dienste verwendet. Der Computer, auf dem die Anwendung installiert ist, wird als Clientcomputer bezeichnet. Mit Clientsoftware können Computer auf einem Netzwerk eine Verbindung zu einer Instanz von Microsoft® SQL Server™ herstellen.

SQL Server-Clients können Anwendungen verschiedener Art sein, z.B.:

  • OLE DB-Consumer.

Diese Anwendungen verwenden den Microsoft OLE DB-Provider für SQL Server oder den Microsoft OLE DB-Provider für ODBC für Verbindungen und Konvertierungen mit Instanzen von SQL Server. Die OLE DB-Providers dienen als Vermittler zwischen einer Instanz von SQL Server und Clientanwendungen, die SQL Server-Daten als OLE DB-Rowsets abnehmen.

  • ODBC-Anwendungen.

Hierzu gehören mit SQL Server installierte Clientdienstprogramme wie SQL Server Enterprise Manager und SQL Query Analyzer sowie andere Anwendungen, die den SQL Server ODBC-Treiber für Verbindungen und Konvertierungen mit einer Instanz von SQL Server verwenden.

  • DB-Bibliothekclients, einschließlich des SQL Server isql-Eingabeaufforderungs-Dienstprogramms und zu DB-Bibliothek geschriebene Clients.

Die Verwaltung eines Clients besteht unabhängig von der Art der Anwendung hauptsächlich aus der Konfiguration seiner Verbindung mit den Serverkomponenten von SQL Server. Je nach den Anforderungen der Website kann das Verwalten von Clients von wenig mehr als der Eingabe des Namens des Servercomputers über das Erstellen einer Bibliothek mit benutzerdefinierten Konfigurationseinträgen bis zum Einrichten einer vielfältigen Multiserverumgebung reichen.


Starten des Clientkonfigurationsprogramms (Windows)

Starten des Clientkonfigurationsprogramms (Windows)

So starten Sie das Clientkonfigurationsprogramm

  • Zeigen Sie im Menü Start auf Programme/Microsoft SQL Server, und klicken Sie dann auf Clientkonfigurationsprogramm.


Anzeigen der Versionsnummern der Netzwerkbibliothek (Clientkonfigurationsprogramm)

Anzeigen der Versionsnummern der Netzwerkbibliothek (Clientkonfigurationsprogramm)

So zeigen Sie die Bibliotheksversionsnummern an

  • Klicken Sie auf die Registerkarte Netzwerkbibliotheken.

Netzwerkbibliothek, Bibliotheksdateiname, Version, Dateidatum und Größe werden angezeigt.


Setzen von DB-Bibliothekskonvertierungspräferenzen (Clientkonfigurationsprogramm)

Setzen von DB-Bibliothekskonvertierungspräferenzen (Clientkonfigurationsprogramm)

So setzen Sie die DB-Bibliothekskonvertierungspräferenzen (Windows 32-Bit-Betriebssystemclient)

  1. Klicken Sie auf die Registerkarte DB-Bibliotheksoptionen.

  2. Aktivieren oder deaktivieren Sie das Kontrollkästchen Automatische Konvertierung von ANSI in OEM.

  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen Internationale Einstellungen verwenden.


Hinzufügen einer Netzwerkbibliothekskonfiguration (Clientkonfigurationsprogramm)

Hinzufügen einer Netzwerkbibliothekskonfiguration (Clientkonfigurationsprogramm)

So fügen Sie eine Netzwerkbibliothekskonfiguration hinzu

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf Hinzufügen.

  2. Wählen Sie im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen unter Netzwerkbibliotheken eine Netzwerkbibliothek aus.

  3. Geben Sie den Serveralias und alle für die ausgewählte Netzwerkbibliothek erforderlichen Parameterinformationen ein.


Bearbeiten einer Netzwerkbibliothekskonfiguration (Clientkonfigurationsprogramm)

Bearbeiten einer Netzwerkbibliothekskonfiguration (Clientkonfigurationsprogramm)

So bearbeiten Sie eine Netzwerkbibliothekskonfiguration

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf die zu bearbeitende Netzwerkprotokollkonfiguration.

  2. Klicken Sie auf Bearbeiten.

  3. Bearbeiten Sie im Dialogfeld Netzwerkbibliothekskonfiguration bearbeiten die zu ändernden Informationen.


Löschen einer Netzwerkbibliothekskonfiguration (Clientkonfigurationsprogramm)

Löschen einer Netzwerkbibliothekskonfiguration (Clientkonfigurationsprogramm)

So löschen Sie die Netzwerkbibliothekskonfiguration

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf die zu löschende Netzwerkbibliothekskonfiguration.

  2. Klicken Sie auf Entfernen.


Anlegen eines Alias für einen Client zu einer alternativen Pipe (Clientkonfigurationsprogramm)

Anlegen eines Alias für einen Client zu einer alternativen Pipe (Clientkonfigurationsprogramm)

So legen Sie für einen Client einen Alias zu einer alternativen Pipe an

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf Hinzufügen.

  2. Klicken Sie im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen auf Named Pipes.

  3. Geben Sie im Feld Serveralias den Serveralias ein.

  4. Geben Sie unter Verbindungsparameter im Feld Pipename den alternativen Pipenamen ein (z.B. \\myserver\pipe\altpipe).


Konfigurieren eines Clients für die Verwendung der Multiprotokoll-Netzwerkbibliothek (Clientkonfigurationsprogramm)

Konfigurieren eines Clients für die Verwendung der Multiprotokoll-Netzwerkbibliothek (Clientkonfigurationsprogramm)

Überpüfen Sie vor dem Erstellen einer Multiprotokoll-Clientkonfiguration, dass auf dem Computer mindestens ein IPC-Protokoll unter Multiprotokoll auf dem Server geladen ist (Named Pipes, NWLink IPX/SPX, TCP/IP oder Windows Sockets).

So konfigurieren Sie einen Client für die Verwendung der Multiprotokoll-Netzwerkbibliothek

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf Hinzufügen.

  2. Klicken Sie im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen auf Multiprotokoll.

  3. Geben Sie in das Feld Serveralias den Namen der Instanz von Microsoft® SQL Server™ ein, die die Multiprotokoll-Netzwerkbibliothek überwacht.

  4. Lassen Sie das Feld Weitere Parameter frei, es sei denn, der Server erfordert spezifische Parameter. (Wenden Sie sich an den Netzwerkadministrator, bevor Sie Parameter eingeben.)


Konfigurieren eines Clients für die Verwendung von TCP/IP (Clientkonfigurationsprogramm)

Konfigurieren eines Clients für die Verwendung von TCP/IP (Clientkonfigurationsprogramm)

So konfigurieren Sie einen Client für die Verwendung von TCP/IP

  1. Klicken Sie auf die Registerkarte Allgemein und anschließend auf Hinzufügen.

  2. Klicken Sie im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen auf TCP/IP.

  3. Geben Sie in das Feld Serveralias den Alias der Instanz von Microsoft® SQL Server™ ein, die die Windows Sockets-Netzwerkbibliothek überwacht.

Mit TCP/IP können Sie auch den Server mit seiner IP-Adresse statt des Namens angeben.

  4. Wählen Sie eine Option aus:
    • Aktivieren Sie das Kontrollkästchen Anschluss dynamisch bestimmen, um den Anschluss automatisch festzulegen.

    • Deaktivieren Sie das Kontrollkästchen Anschluss dynamisch bestimmen, um den Anschluss manuell festzulegen, und geben Sie im Feld Anschlussnummer die entsprechende Nummer ein.

Weitere Informationen zu anderen TCP/IP-Protokollen, die Windows Sockets unterstützen, finden Sie in der TCP/IP-Dokumentation.


Konfigurieren eines Clients für die Verwendung der NWLink IPX/SPX-Netzwerkbibliothek (Clientkonfigurationsprogramm)

Konfigurieren eines Clients für die Verwendung der NWLink IPX/SPX-Netzwerkbibliothek (Clientkonfigurationsprogramm)

So konfigurieren Sie einen Client für die Verwendung der NWLink IPX/SPX-Netzwerkbibliothek

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf Hinzufügen.

  2. Klicken Sie im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen auf NWLink IPX/SPX.

  3. Geben Sie in das Feld Serveralias den Alias der Instanz von Microsoft® SQL Server™ ein, die die NWLink IPX/SPX-Netzwerkbibliothek überwacht.

  4. Klicken Sie unter Verbindungsparamter auf Dienstname oder auf Netzwerkadresse.

  5. Wenn Sie Dienstname ausgewählt haben, geben Sie den Dienstnamen ein.

  6. Der Dienstname ist der Microsoft Windows NT® 4.0- oder Windows® 2000-Computername, unter dem eine Instanz von SQL-Server ausgeführt wird. Dieser Name wird in der Bindery des Servers gespeichert.

  7. Wenn Sie auf Netzwerkadresse geklickt haben, geben Sie die Adresse (MAC-Adresse), den Anschluss (Socket-Nummer) und das Netzwerk (NetWare-Netzwerknummer) ein.


Konfigurieren eines Clients für die Verwendung der AppleTalk-Netzwerkbibliothek (Clientkonfigurationsprogramm)

Konfigurieren eines Clients für die Verwendung der AppleTalk-Netzwerkbibliothek (Clientkonfigurationsprogramm)

So konfigurieren Sie einen Client für die Verwendung der AppleTalk-Netzwerkbibliothek

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf Hinzufügen.

  2. Klicken Sie im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen auf AppleTalk.

  3. Geben Sie in das Feld Serveralias den Namen der Instanz von Microsoft® SQL Server™ ein, die die AppleTalk-Netzwerkbibliothek überwacht.

  4. Geben Sie unter Verbindungsparameter den AppleTalk-Objektnamen und optionale Zonenbezeichner ein.


Konfigurieren eines Clients für die Verwendung der Banyan VINES-Netzwerkbibliothek (Clientkonfigurationsprogramm)

Konfigurieren eines Clients für die Verwendung der Banyan VINES-Netzwerkbibliothek (Clientkonfigurationsprogramm)

So konfigurieren Sie einen Client für die Verwendung der Banyan VINES-Netzwerkbibliothek

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf Hinzufügen.

  2. Klicken Sie im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen auf Banyan VINES.

  3. Geben Sie in das Feld Serveralias den Alias der Instanz von Microsoft® SQL Server™ ein, die die Banyan VINES-Netzwerkbibliothek überwacht.

  4. Geben Sie unter Verbindungsparameter den Dienst und die VINES-Organisation ein. Sie können den Standardwert von MSSQL für Gruppe verwenden.


Konfigurieren eines Clients für die Verwendung der VIA-Netzwerkbibliothek (Clientkonfigurationsprogramm)

Konfigurieren eines Clients für die Verwendung der VIA-Netzwerkbibliothek (Clientkonfigurationsprogramm)

So konfigurieren Sie einen Client für die Verwendung der Banyan VINES-Netzwerkbibliothek

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf Hinzufügen.

  2. Klicken Sie im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen auf VIA.

  3. Geben Sie in das Feld Serveralias den Alias der Instanz von Microsoft® SQL Server™ ein, die die VIA-Netzwerkbibliothek überwacht.

  4. Geben Sie unter Verbindungsparameter den Servernamen und die Serveranschlussnummer ein.


Konfigurieren eines Clients für die Verwendung einer nicht dem Standard entsprechenden Netzwerkbibliothek (Clientkonfigurationsprogramm)

Konfigurieren eines Clients für die Verwendung einer nicht dem Standard entsprechenden Netzwerkbibliothek (Clientkonfigurationsprogramm)

So konfigurieren Sie einen Client für die Verwendung einer nicht dem Standard entsprechenden Netzwerkbibliothek

  1. Klicken Sie auf die Registerkarte Alias und anschließend auf Hinzufügen.

  2. Klicken Sie im Dialogfeld Netzwerkbibliothekskonfiguration hinzufügen auf Andere.

  3. Geben Sie in das Feld Serveralias den Alias der Instanz von Microsoft® SQL Server™ ein, die die zu installierende Netzwerkbibliothek überwacht.

  4. Geben Sie unter Verbindungsparameter den Dateinamen (DLL-Datei) der installierten Netzwerkbibliothek ein. Geben Sie die Erweiterung DLL nicht ein.

  5. Geben Sie, falls erforderlich, zusätzliche Informationen im Feld Parameter ein (z.B. Benutzername und Kennwort). Verwenden Sie Kommas als Trennzeichen zwischen Parametern.


Überprüfen, dass SQL Server AppleTalk überwacht und eine Clientverbindung akzeptieren kann (Clientkonfigurationsprogramm)

Überprüfen, dass SQL Server AppleTalk überwacht und eine Clientverbindung akzeptieren kann (Clientkonfigurationsprogramm)

So überprüfen Sie, dass SQL Server AppleTalk überwacht und eine Clientverbindung akzeptieren kann

  1. Kopieren Sie die AppleTalk-Netzwerkbibliothek (Dbmsadsn.dll) des Clients aus dem Verzeichnis \WINNT\system32 des Servers in das gleiche Verzeichnis eines Remote-Computers, der Microsoft® Windows NT® oder Microsoft Windows® 2000 Services für Macintosh® ausführt.

  2. Starten Sie auf der Remote-Arbeitsstation das SQL Server-Clientkonfigurationsprogramm.

  3. Wenn AppleTalk in der Liste Deaktivierte Protokolle aufgeführt ist, klicken Sie auf AppleTalk und anschließend auf Aktivieren.

  4. Klicken Sie in der Liste Aktivierte Protokolle in Reihenfolge auf AppleTalk und anschließend auf Nach oben, bis AppleTalk als erster Eintrag in der Liste angezeigt wird.

  5. Klicken Sie auf OK.

  6. Versuchen Sie, eine ISQL-Verbindung mit dem AppleTalk-Dienstobjektnamen herzustellen.

Geben Sie z.B. folgendes in der Befehlszeile ein:

isql -Usa -P -Sdienstname

Wenn eine ISQL-Verbindung möglich ist und Sie Abfragen ausführen können, ist der Server korrekt konfiguriert und akzeptiert Verbindungen.

The Microsoft Win32® AppleTalk (ADSP) client side Net-Library (Dbmsadsn.dll) is included for testing ADSP connections and troubleshooting AppleTalk connections between Macintosh clients and Microsoft SQL Server™. Diese Netzwerkbibliothek sollte nur beim Testen einer Verbindung von einem Remote-Client zu einer Instanz von SQL Server verwendet werden. Wenn Sie versuchen, lokale Verbindungen über die ADSP-Netzwerkbibliothek zu einer Instanz von SQL Server, die AppleTalk überwacht, herzustellen, erhalten Sie den folgenden Netzwerkfehler: Netzwerkbibliothek-Fehler 11: getsockopt().


Prüfen der ODBC SQL Server-Treiberversion (Windows)

Prüfen der ODBC SQL Server-Treiberversion (Windows)

You can follow these steps only if you are running the Microsoft® Windows NT® 4.0 operating system.

So prüfen Sie die ODBC SQL Server-Treiberversion (32-Bit ODBC)

  1. Doppelklicken Sie in der Systemsteuerung auf ODBC-Datenquellen.

  2. Klicken Sie auf die Registerkarte Treiber.

Informationen für den Microsoft SQL Server™-Eintrag werden in der Spalte Version angezeigt.


SQL Server 2000 Copyright und Verzichterklärung

Dieses Dokument, einschließlich der enthaltenen Beispielanwendungen, wird nur zu Informationszwecken bereitgestellt; Microsoft übernimmt in diesem Dokument keine Garantien, weder ausdrücklich noch stillschweigend. In diesem Dokument enthaltene Informationen, einschließlich Beispiele, URL und andere Internet-Website-Referenzen, können ohne vorherige Ankündigung geändert werden. Der Benutzer trägt das vollständige Risiko für die Verwendung oder für die sich aus der Verwendung dieses Dokuments ergebenden Konsequenzen.

Ein Beispiel hat die primäre Aufgabe, ein Konzept oder die angemessene Verwendung einer bestimmten Anweisung oder Klausel zu verdeutlichen. Die meisten Beispiele enthalten nicht sämtlichen Code, der normalerweise in einem vollständigen Produktionssystem zu finden ist. Es wurden viele der üblichen Datenbestätigungs- und Fehlerbehandlungsinformationen entfernt, damit sich das Beispiel auf ein bestimmtes Konzept oder eine bestimmte Anweisung konzentrieren kann. Für diese Beispiele oder für den bereitgestellten Quellcode ist keine technische Unterstützung verfügbar.

Wenn nicht anders angegeben, sind die hier als Beispiel genannten Firmen, Organisationen, Produkte, Personen und Ereignisse fiktiv, und es wird kein Zusammenhang mit irgend einer tatsächlichen Firma, Organisation, Produkt, Person oder Ereignis beabsichtigt oder abgeleitet. Das Einhalten sämtlicher zur Anwendung kommenden Copyright-Vorschriften liegt in der Verantwortung des Benutzers. Ohne die durch das Copyright geschützten Rechte einzuschränken, darf kein Teil dieses Dokuments reproduziert, gespeichert oder in ein Abrufsystem eingeführt werden, oder in irgend einer Form, auf irgend eine Weise (elektronisch, mechanisch, per Fotokopie, Aufnahme oder anderweitig) oder für irgend einen Zweck übertragen werden, ohne daß eine ausdrückliche schriftliche Genehmigung der Microsoft Corporation erteilt wurde.

Microsoft kann Patente, Patentanwendungen, Warenzeichen, Copyrights oder andere geistige Eigentumsrechte haben, die Themenbereiche in diesem Dokument abdecken. Sie erhalten durch Bereitstellung dieses Dokument keine Lizenz für diese Patente, Warenzeichen, Copyrights oder anderes geistiges Eigentum, es sei denn, dies ist ausdrücklich in einer schriftlichen Lizenzvereinbarung von Microsoft festgelegt.

©1996-2000 Microsoft Corporation. Alle Rechte vorbehalten.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Win32, Windows 2000, Windows und Windows NT sind entweder eingetragene Warenzeichen oder Warenzeichen der Microsoft Corporation in den USA und/oder anderen Ländern.

Die Namen von in diesem Dokument erwähnten tatsächlichen Firmen und Produkten können Warenzeichen des jeweiligen Eigentümers sein.


Eine Übersicht zu diesem Thema finden Sie in der Onlinedokumentation von SQL Server.

©1988-2000 Microsoft Corporation. Alle Rechte vorbehalten.