DotNET-

DotNET-IDE Version 2.5

DotNET-IDE ist eine kleine Entwicklungsumgebung für .NET-Framework, die die Programmentwicklung für Visual Basic und C# unterstützt und auch unter Windows 98 und Windows Millennium läuft.

DotNET-IDE Version 2.5 ist Freeware by Günter Born. Keine Haftung oder Gewährleistung hinsichtlich Funktionalität und Ablaufverhalten. Keine Unterstützung bezüglich Installation und Betrieb. Rückmeldungen bezüglich Bugs an mich über: GBorn@web.de.

Ansonsten wünsche ich viel Spaß beim Arbeiten mit der IDE.

Günter Born

www.borncity.de


Allgemeines

DotNET-IDE ist eine kleine Entwicklungsumgebung für .NET-Framework, die die Programmentwicklung für Visual Basic und C# unterstützt. Der Benutzer kann eine Quelldatei in einem Editor (Standard ist Notepad) öffnen, diese bearbeiten und dann über die Schaltflächen der DotNET-IDE übersetzen und ausführen. Die Optionen der IDE erlauben es dabei, Compileroptionen oder einzubindende Bibliotheksdateien sehr komfortabel abzurufen bzw. in Textfeldern einzutragen. Beim Testen bietet die IDE die Möglichkeit, der Anwendung Parameter zu übergeben und den Process-Exit-Code zurückzulesen.

Entstanden ist die DotNET-IDE aus einer vor einigen Jahren von mir geschriebenen HTA-Anwendung zur vereinfachten Entwicklung von Windows Script Host .vbs und .js Dateien. Nachdem ich diese HTA-Anwendung so erweitert hatte, dass sie auch unter .NET-Framework lief, wurde die betreffende Lösung mit Visual Basic nach .NET-Framework portiert (die Benutzeroberfläche wurde unter VB.NET gestaltet).

Mit dieser DotNET-IDE und dem .NET-Framework SDK ist eine Entwicklung mit Visual Basic und C# auch ohne Visual Studio .NET möglich. Besitzer von Windows 98 und Windows ME können sich die .NET-Redistributable auf dem Rechner installieren und dann IDE auf die gleiche Maschine kopieren. Anschließend steht eine Möglichkeit zur Entwicklung von Visual Basic- und C#-Programmen zur Verfügung. Die .NET-Framework SDK-Hilfe lässt sich zwar nicht unter Win 9x installieren, aber die betreffenden Informationen lassen sich auch über das Internet von Microsofts Webseiten http://msdn.microsoft.com abrufen.

Das ganze Projekt entstand als Abschluss zum von mir bei Markt + Technik publizierten Titel "Visual Basic.NET - Magnum". Dort finden Ein-, Um- und Aufsteiger viele Anregungen, wie sich .NET-Anwendungen ohne Verwendung von VB.NET (Visual Studio .NET mit installiertem Visual Basic) mit Visual Basic erstellen und dann per IDE übersetzen lassen. Mit diesem Know How steht die Technologie quasi zum Nulltarif zur Verfügung.

Die IDE ist als Ergänzung zu der zur Zeit entstehenden SharpDevelop-Entwicklungsumgebung gedacht (bei meinen Tests bot SharpDevelop zwar viele Features, aber nicht unbedingt das, was ich zum schnellen Testen von VB.NET-Anwendungen benötigte). Das Programm DotNET-IDE ist Freeware und darf frei weitergegeben werden (sofern alle Dateien einschließlich dieser Hilfe mit kopiert werden - verwenden Sie zur Weitergabe daher entweder die Archivdatei DotNET-IDE.V2.5.Ger.zip oder die Datei DotNET-IDE.V2.5.Ger.exe). Bei einem Vertrieb auf kommerziellen CDs ist meine Genehmigung einzuholen (die in der Regel erteilt wird). Bei Veröffentlichung auf Webseiten zum Download bitte einen Link zu meiner http://www.borncity.de setzen, da ich eine zentrale Version pflegen und auf meiner Webseite zum Download anbieten möchte. Selbstverständlich übernehme ich als Autor keine Haftung oder Gewährleistung für die Funktionalität des Programms.

Günter Born

http://www.borncity.de


Bedienung

Nach dem Programmstart zeigt die IDE ein einfaches Dialogfeld, über welches Sie Dateien, Compiler-Optionen oder Befehle zum Ausführen spezifizieren können. Die Bedienung sollte weitgehend intuitiv sein.

Hier eine kurze Beschreibung der wichtigsten Schaltflächen und Optionen.

 | Edit & Compile (Quellcodebearbeitung)
VB C# | Über die beiden Optionsfelder VB und C# in der rechten oberen Ecke des Formulars wählen Sie, mit welchem Compiler Sie arbeiten möchten. Zum Arbeiten mit Visual Basic ist also VB zu markieren. Beim Laden von Quelldateien schaltet die IDE diese Optionen, in Abhängigkeit von der Dateinamenerweiterung der ausgewählten Quelldatei, automatisch um. Dies verhindert den falschen Compileraufruf.
Datei | In diesem Textfeld wird der Name samt Pfad der Quelldatei (.vbs oder .cs) gehalten. Klicken Sie auf die Schaltfläche Open, um die gewünschte Datei interaktiv auszuwählen. Die Dateiextension im Dialogfeld Öffnen hängt dabei von der gewählten Compileroption ab, Sie können aber auch den Dateityp manuell im Dialogfeld wählen.
Neu | Diese Schaltfläche erlaubt eine neue Quelldatei, basierend auf einer Vorlage, anzulegen. Bei Anwahl öffnet sich ein Dialogfeldmit dem Inhalt des Ordners \Templates. Sie können eine Vorlagedatei wählen und werden dann automatisch in einem zweiten Ordner zum Speichern aufgefordert. War bereits eine Datei im Feld Datei geöffnet, wird deren Ordner als Zielverzeichnis vorgeschlagen. Andernfalls stellt die IDE den Ordner Eigene Dateien als Speicherort ein. Das Dateiformat hängt dabei vom Dateityp der gewählten Vorlagedatei ab (.cs-Vorlagen lassen sich nicht als .vb-Dateien speichern und umgekehrt).
Edit | Öffnet die im Feld File angezeigte Quelldatei im Editor. Standardmäßig ist dies der Windows-Editor. Sie können aber auch andere Editoren (z.B. Proton) einbinden.
View | Erzeugt ein Listung mit Zeilennummerierung und öffnet dieses im Windows-Editor. Sie können dadurch sehr schnell vom Compiler als fehlerhaft gemeldete Zeilen identifizieren. Über den Editor lässt sich zudem ein Ausdruck anfertigen.
 | Compilieren
Target | Die .NET-Compiler können Code für verschiedene Ziele (Konsoleanwendungen, Windows-Anwendungen, Bibliotheken oder Module) generieren. Dies wird über den Schalter /t:... gesteuert. Sobald Sie ein Optionsfeld in der Gruppe Target markieren, setzt die IDE den benötigten Schalter in den Kommandooptionen des Compilers. Markieren Sie WinExe, werden Windows-Anwendungen erstellt, die sich mit einem Symbol versehen lassen.
Icon | In diesem Textfeld wird der Pfad und Name der der exe-Datei zuzuweisenden Symboldatei gehalten. Verwenden Sie die Schaltfläche Open, um eine Symboldatei aus dem Verzeichnis \Icons zuzuweisen. Diese Option wird jedoch nur beim Target WinExe benutzt.
Compile Options | In diesem Textfeld tragen Sie die einzubindenden Bibliotheksdateien und Referenzen auf Ressourcendateien (/ref:<pfad>name.ressources) ein. Bei allen Dateiangaben muss dabei der absolute Pfad verwendet werden! Nur wenn die Assemblies im Assemblycache liegen, kann die Pfadangabe entfallen. Die Standardbibliotheken (für Formulare etc.) lassen sich automatisch einblenden (siehe nächste Option).
Form | Möchten Sie Anwendungen mit Formularen übersetzen, markieren Sie einfach das betreffende Kontrollkästchen Form. Die IDE fügt die Refrenzen (/r:...) auf die benötigten Bibliotheksdateien im zweiten (vor Benutzereingaben geschützten) Textfeld automatisch ein.
ADO-NET | Markieren Sie dieses Kontrollkästchen, falls Sie Funktionen von ADO.NET in Ihrer Anwendung benutzt haben. Dies bindet die benötigte Bibliothek System.Data.dll automatisch mit ein.
XML | Markieren Sie dieses Kontrollkästchen, falls Sie XML-Funktionenin Ihrer Anwendung benutzt haben. Dies bindet die benötigte Bibliothek System.xml.dll automatisch mit ein.
Debug | Markieren Sie dieses Kontrollkästchen, wenn der Compiler eine Debug-Symboldatei erzeugen soll. Diese ist zur Anzeige des Quellcodes im symbolischen Debugger erforderlich.
Console | Beim Übersetzen greift die IDE die Compilerausgaben ab und zeigt diese im als Command Monitor bezeichneten Textfeld am unteren Fensterrand an. Falls es Schwierigkeiten beim Übersetzen gibt oder falls Sie die Meldungen besser sehen möchten, markieren Sie das Kontrollkästchen Console. Dann öffnet sich beim Compilieren ein Konsolefenster, in dem Sie die Compilerausgaben verfolgen können. Das Fenster muss geschlossen werden, bevor Sie zur IDE zurückkehren können! Das Kontrollkästchen wird unter Windows 9x deaktiviert, da es Probleme beim Aufruf des Shell-Befehs gibt.
Compile | Diese Schaltfläche startet den Übersetzungsvorgang mit den aktuell eingestellten Optionen.
 | Execute
Run | Führt den im Textfeld Run-Cmd enthaltenen Befehl aus. Dieses Feld wird beim Übersetzen automatisch mit dem Namen der erzeugten exe-Datei gefüllt. Sie können aber auch eigene Befehle eingeben.
Parameter | Geben Sie in diesem Textfeld Argumente an, die dem Programm beim Aufruf zu übergeben sind. Dateinamen mit Leerzeichen im Pfad sollten mit Anführungszeichen "...." eingeschlossen werden, damit diese als ein Argument erkannt werden. Nach Abschluss der Anwendung wird deren Process-Exit-Code im Fenster des Command Monitors ausgegeben.
Shell | Beim Ausführen greift die IDE die Ausgaben von Programmen auf der Standard Ein-/Ausgabe ab und zeigt diese im Command Monitor an. Bei Konsoleanwendungen gibt es dann das Problem, dass Ausgaben im gleichzeitig geöffneten Konsolefenster nicht mehr zu sehen sind. Sie können dieses Problem lösen, indem Sie das Kontrollkästchen Shell markieren. Dann gibt die IDE die Standard Ein-/Ausgabe frei und die Anwendung läuft im Fenster der Konsole. Alle Ein-/Ausgaben werden über das Konsolefenster abgewickelt.
Command Monitor | Dieses Textfeld dient zur Kontrolle der beim Compilieren und Ausführen von der IDE abgesetzten Befehle. Zudem werden die von der IDE abgegriffenen Programmausgaben der Standardausgabeeinheit sowie der Prozess-Exit-Code im Textfeld angezeigt. Diese Informationen fehlen aber, falls die Kontrollkästchen Console oder Shell markiert sind.
Hilfe | Ruft die der Anwendung zugeordnete Hilfedatei (also diese Datei) auf.
Beenden | Beendet die IDE.

Wenn Sie auf ein Element zeigen, sollte zudem eine QuickInfo mit einer kurzen Funktionsbeschreibung gezeigt werden.


Installation

Das Programm erfordert keine besondere Installation und nimmt auch keine Anpassungen an der Registrierung vor. Kopieren Sie einfach die ausführbare Programmdatei DotNET-IDE.exe in einen Ordner der Festplatte. Zudem sollte in diesem Ordner diese Hilfedatei mit enthalten sein. Ein Unterordner \Templates ist zur Ablage von Vorlagedateien vorgesehen. Der Unterordner \Icons nimmt Symboldateien auf, die beim Übersetzen von Windows-Anwendungen den exe-Dateien zugewiesen werden. Sie können die Ordner manuell einrichten und eigene Dateien hinterlegen. Oder Sie verwenden die von mir vorbereiteten Dateien.

Starten Sie die Programmdatei DotNET-IDE.exe mit einem Doppelklick auf die exe-Datei. Bei Bedarf können Sie eine Verknüpfung im Startmenü oder auf dem Desktop einrichten (exe-Datei mit der rechten Maustaste zum Desktop ziehen und im Kontextmenü den Befehl Verknüpfung(en) hier erstellen) wählen.

Die DotNET-IDE.exe benötigt die .NET-Framework Laufzeitumgebung (auch als Redistributable bezeichnet). Sie brauchen diese Laufzeitumgebung nur einmal auf der Zielmaschine zu installieren. Ist der .NET-Framework SDK installiert, befindet sich die Laufzeitumgebung auf der Maschine.

Achtung: Die .NET-Framework-Redistributable oder der .NET-Framework SDK müssen so auf der Entwicklungsmaschine eingerichtet sein, dass der Pfad auf das .NET-Framework-Verzeichnis verweist (z.B. C:\WINNT\Microsoft.NET\Framework\v1.0.3705). Bei Windows 9x passen Sie die path-Anweisung in der Autoexec.bat an, unter Windows NT und höher ist die path-Umgebungsvariable über die Option Umgebungsvariablen zu setzen. Bei fehlenden Pfadeinstellungen kommt es in der IDE zu diversen Fehlern.

Den .NET-Framework SDK, die .NET-Redistributable und weiteres finden Sie im Internet, wenn Sie diese Seite besuchen: http://www.microsoft.com/germany/ms/entwicklerprodukte.


Konfigurierung

Die IDE ist so angelegt, dass sich verschiedene Einstellungen ohne Eingriff in den Quellcode ändern lassen. Diese Einstellungen werden in der Datei DotNET-IDE.exe.config geführt. Es handelt sich um eine XML-Datei, die die dynamischen Eigenschaften der Steuerelemente enthält.

<?xml version="1.0" encoding="Windows-1252"?>
<configuration>
<appSettings>
<!-- Benutzeranwendung und konfigurierte Eigenschafteneinstellungen hier einfügen.-->
<add key="Button1.Text" value="Open" />
<add key="Button2.Text" value="Open" />
<add key="Button6.Text" value="New" />
...
<add key="Editor.Text" value="Notepad.exe" />
...
<add key="vbc.Text" value="vbc.exe" />
</appSettings>
</configuration>

Ich habe einige unsichtbare Steuerelemente im Formular hinterlegt, in denen der benutzte Editor, die Befehle für die Compileraufrufe etc. eingetragen sind. Falls Sie also die Pfade zum NET-Framework-Ordner im Windows-Verzeichnis nicht gesetzt haben, können Sie den Pfad zum Compileraufruf in der Config-Datei anpassen. Möchten Sie einen neuen Editor einbinden, haben Sie zwei Möglichkeiten. Entweder Sie kopieren den Editor in den Ordner der IDE und benennen die Programmdatei in Notepad.exe. Oder Sie ändern einfach den Value-Wert des Key-Eintrags "Editor" auf den Namen und Pfad des gewünschten Editors. Über die Anpassung der Value-Werte besteht auch die Möglichkeit, die Beschriftung der Steuerelemente der Benutzeroberfläche in andere Sprachen umzusetzen oder die Hilfedatei anzupassen.

Achtung: Sie können den Windows-Editor zwar zum Editieren der config-Datei verwenden. In der Windows-NT-Version (also auch bei Windows 2000 und XP) müssen Sie aber anschließend den Befehl Speichern unter wählen. Im Dialogfeld Speichern unter stellen Sie als Dateiformat "ANSI" ein. Vergessen Sie dies, schreibt der Windows-NT-Editor eine 3-Byte-Kennung an den Anfang der XML-Datei, wodurch diese zerstört wird (es kommt anschließend beim Start der IDE zu einem Laufzeitfehler). Nur wenn Sie das Format "ANSI" wählen, unterlässt der Editor das Schreiben der Zeichen.

Ansonsten wünsche ich viel Spaß beim Arbeiten mit der IDE. Rückmeldungen bezüglich Bugs an mich über: GBorn@web.de.

Zurück