Welcome to Visual DataFlex 12.0

Welcome to Visual DataFlex Studio

Visual DataFlex’s operations center for application building

The finely tuned interaction among Studio’s components enhance developer productivity; Data Dictionaries, Web and Business Process Objects eliminate huge amounts of redundant, high maintenance code. Visual DataFlex’s rich, object oriented language and robust class library provide developers with everything needed for successful custom projects and high quality commercial products.

Welcome to the world's most exciting and comprehensive development environment for Windows and Web database applications and web services.

New to Visual DataFlex? Start here...

We recommend the following steps to accelerate your learning curve and enhance your initial use of Visual DataFlex.

  1. Check out why developers worldwide choose Visual DataFlex.

  2. Use Quick Start to learn the basics of the Visual DataFlex environment.

  3. Read the Language Guide to familiarize yourself with the capabilities and nuances of the Visual DataFlex language.

  4. Experiment with the various Examples. They illustrate techniques from client and server web services to basic data entry and everything in between. Run them, load them into the Studio, examine their data structures and code, and even make changes and recompile.

  5. Read about the Application Framework.

  6. Read about Data Dictionaries.

  7. Work through the various Tutorials.

Experienced Visual DataFlex Developers Start Here...

We recommend that you review the following sections:

  • What's New

  • Compatibility and Upgrade Guide

  • Using and Publishing Web Services


Why Visual DataFlex

Professional developers worldwide choose Visual DataFlex when they need a fast, easy way to create reliable, high-performance corporate solutions, commercial software products, departmental and personal applications. Why?

Visual DataFlex is Complete

It gives developers everything needed to succeed with Windows, web and web services projects and products...

  • A highly integrated combination of visual design tools

  • Code-generating wizards

  • An Application Framework

  • A comprehensive class library

  • A compiler & debugger

  • A scalable Web Application Server

  • Windows deployment components

  • An embedded, transaction optimized DBMS

  • Connectivity for leading DBMSs

  • A mature, object-oriented 4GL.

Visual DataFlex is Innovative and Productive

Visual DataFlex uses a structured Application Framework as the foundation for building consistent, reliable, applications. Data Dictionaries are Visual DataFlex's central repository where information is written once and then used consistently and automatically throughout the Windows and web application environment. Data Dictionaries contain a wealth of information about an application’s database and data: table definitions and relationships, display labels, the type of control to use to display the data, look-up lists, validations, allowable operations, core business rules and more. Together, the Application Framework and Data Dictionaries mean faster, less error-prone development, more reliable applications and easier changes and maintenance.

Learn more about the Application Framework

Learn more about Data Dictionaries

There is a Strong, Global Visual DataFlex Community

Data Access Worldwide partners with its customers to help build the great applications. The Visual DataFlex product is surrounded by an active worldwide community of users offering mutual support for mutual success. Join us!

For more information about Visual DataFlex, see www.VisualDataFlex.com.

See Also

New to Visual DataFlex? Start Here...