Visual DataFlex Registration

Visual DataFlex

Visual DataFlex Rules

  1. A Visual DataFlex evaluation license is removed when a real (Visual DataFlex or Web Application Server) license is entered.

  2. If an evaluation license is added, all other Visual DataFlex and Web Application Server licenses are removed.

  3. There cannot be multiple licenses for Visual DataFlex Studio; only one Studio version and license will be allowed.

  4. Between Visual DataFlex and Web Application Server licenses, only one license can be active at a time.

  5. The total number of users able to use Visual DataFlex will be the result of adding the number of users of each Visual DataFlex license entered. If one of the licenses is ‘unlimited’, the total number of users will be unlimited.

See Also

Product Registration

Registration Program Error Messages

Common Registration Errors


Web Application Server Registration

Web Application Server

Web Application Server Rules

  1. A Web Application Server evaluation license is removed when a real (Visual DataFlex or Web Application Server) license is entered.

  2. If a Web Application Server evaluation license is added, all other Visual DataFlex and Web Application Server licenses are removed.

  3. Between Visual DataFlex and Web Application Server licenses, only one license can be active at a time.

  4. There will not be a total number of users listed for Web Application Servers. The type of license bought (Internet, Lite or Enterprise) only determines how requests can be handled.

  5. Since Web Application Servers are not licensed per user, no user number will be displayed in the registration code line.

  6. There cannot be multiple licenses for Web Application Server; only one Web Application Server version and license will be allowed.

See Also

Product Registration

Registration Program Error Messages


Microsoft SQL Server Connectivity Kit Registration

Microsoft SQL Server Connectivity Kit

Microsoft SQL Server Connectivity Kit Rules

  1. There cannot be multiple licenses for Microsoft SQL Connectivity Kit; only one Microsoft SQL Connectivity Kit version and license will be allowed

  2. A Microsoft SQL Connectivity Kit license is removed when another license is entered.

See Also

Product Registration

Registration Program Error Messages


Pervasive.SQL Connectivity Kit Registration

Pervasive.SQL Connectivity Kit

Pervasive.SQL Connectivity Kit Rules

  1. There cannot be multiple licenses for Pervasive.SQL Connectivity Kit; only one Pervasive.SQL Connectivity Kit version and license will be allowed

  2. A Pervasive.SQL Connectivity Kit license is removed when another license is entered.

See Also

Product Registration

Registration Program Error Messages


IBM DB2 Connectivity Kit Registration

IBM DB2 Connectivity Kit

IBM DB2 Connectivity Kit Rules

  1. There cannot be multiple licenses for IBM DB2 Connectivity Kit; only one IBM DB2 Connectivity Kit version and license will be allowed.

  2. An IBM DB2 Connectivity Kit license is replaced by another DB2 Connectivity Kit license that is entered.

See Also

Product Registration

Registration Program Error Messages


ODBC Connectivity Kit Registration

ODBC Connectivity Kit

ODBC Connectivity Kit Rules

  1. There cannot be multiple licenses for ODBC Connectivity Kit; only one ODBC Connectivity Kit version and license will be allowed

  2. An ODBC Connectivity Kit license is removed when another license is entered.

See Also

Product Registration

Registration Program Error Messages


Crystal Reports Connectivity Kit Registration

Crystal Reports Connectivity Kit

See Also

Product Registration

Registration Program Error Messages


Electos Registration

Electos

Electos Rules

  1. A Web Application Server or Visual DataFlex Studio license needs to be found in order for you to be allowed to enter an Electos license.

  2. There cannot be multiple licenses for Electos; only one Electos version and license will be allowed.

  3. The license entered will replace any Electos license already in the system.

See Also

Product Registration

Registration Program Error Messages


CrossMerge Registration

CrossMerge

See Also

Product Registration

Registration Program Error Messages


Common Registration Errors

The following messages are imbedded in the runtime and cannot be altered or extended by developers. They concern those situations in which the runtime is prevented from accessing the error database files.

28676 - DataFlex is not installed in termlist.cfg, please run DFSETUP

28678 - File termlist.cfg not found

28679 - File termlist.cfg is unreadable or corrupt

28681 – Maximum number of DataFlex users exceeded

28682 – Internal user count file error

28671 - Unable to initialize user counting system

28672 - Cannot Open User Count .DFR File

28673 - Cannot Read User Count .DFR File

28674 - Cannot Decrypt User Count .DFR File

28675 - Bad Version of User Count .DFR File

28676 - DataFlex is not installed in termlist.cfg, please run DFSETUP

Cause

An invalid registration code is installed or a termlist.cfg file from a prior version of Visual DataFlex or DataFlex is found along DFPath.

Resolution

  1. Run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license. Even with a valid registration code in termlist.cfg, the user count file may not be valid or found along the path. Re-registering the license will create a new user count file.

  2. Check if somewhere along the DFPath, there is another version of termlist.cfg that is registered using another version of Visual DataFlex or DataFlex. Typically, this happens when upgrading from character-mode DataFlex and a termlist.cfg file that contains registration information for an older version of DataFlex is found in the Data folder.

28678 - File termlist.cfg not found

Cause

No termlist.cfg file is found.

Resolution

Run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license.

28679 - File termlist.cfg is unreadable or corrupt

Cause

File termlist.cfg file is corrupt.

Resolution

Delete termlist.cfg, then run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license.

28680 - Internal DataFlex Window System Error!!

Cause

Resolution

28681 – Maximum number of DataFlex users exceeded

Cause

The number of licensed Visual DataFlex users is exceeded.

Resolution

Purchase a Visual DataFlex license with the number of users needed, then run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license.

28682 – Internal user count file error

Cause

Corrupted user count file or a mismatched (from another version of Visual DataFlex or DataFlex) user count file.

Resolution

1. Run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license. Even with a valid registration code in termlist.cfg, the user count file may not be valid or found along the path. Re-registering the license will create a new user count file.

2. Check if somewhere along the DFPath, there is another version of termlist.cfg that is registered using another version of Visual DataFlex or DataFlex. Typically, this happens when upgrading from character-mode DataFlex and a termlist.cfg file that contains registration information for an older version of DataFlex is found in the Data folder.

28671 - Unable to initialize user counting system

Cause

Corrupted user count file or a mismatched (from another version of Visual DataFlex or DataFlex) user count file.

Resolution

  1. Run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license. Even with a valid registration code in termlist.cfg, the user count file may not be valid or found along the path. Re-registering the license will create a new user count file.

  2. Check if somewhere along the DFPath, there is another version of termlist.cfg that is registered using another version of Visual DataFlex or DataFlex. Typically, this happens when upgrading from character-mode DataFlex and a termlist.cfg file that contains registration information for an older version of DataFlex is found in the Data folder.

28672 - Cannot Open User Count .DFR File

Cause

User -count file not found.

Resolution

Run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license. Even with a valid registration code in termlist.cfg, the user count file may not be valid or found along the path. Re-registering the license will create a new user count file.

28673 - Cannot Read User Count .DFR File

Cause

The system was unable to read the user -count file.

Resolution

  1. Run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license. Even with a valid registration code in termlist.cfg, the user count file may not be valid or found along the path. Re-registering the license will create a new user count file.

  2. Check for user rights in the folder where the Visual DataFlex user count file is located, typically the \Visual DataFlex\bin folder.

28674 - Cannot Decrypt User Count .DFR File

Cause

Corrupted user count file or a mismatched (from another version of Visual DataFlex or DataFlex) user count file.

Resolution

  1. Run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license. Even with a valid registration code in termlist.cfg, the user count file may not be valid or found along the path. Re-registering the license will create a new user count file.

  2. Check if somewhere along the DFPath, there is another version of termlist.cfg that is registered using another version of Visual DataFlex or DataFlex. Typically, this happens when upgrading from character-mode DataFlex and a termlist.cfg file that contains registration information for an older version of DataFlex is found in the Data folder.

28675 - Bad Version of User Count .DFR File

Cause

The user -count file may be from another operating system, such as Linux/ Unix.

Corrupted user count file or a mismatched (from another version of Visual DataFlex or DataFlex) user count file.

Resolution

  1. Run Register.exe, the Visual DataFlex registration program, to register your Visual DataFlex license. Even with a valid registration code in termlist.cfg, the user count file may not be valid or found along the path. Re-registering the license will create a new user count file.

  2. Check if somewhere along the DFPath, there is another version of termlist.cfg that is registered using another version of Visual DataFlex or DataFlex. Typically, this happens when upgrading from character-mode DataFlex and a termlist.cfg file that contains registration information for an older version of DataFlex is found in the Data folder.


Registration Program Error Messages

Selected registration is already active

Users should not see this message – the button will be disabled when it shouldn't be used. If this message is displayed, contact Data Access Technical Support.

Bad registration code

This happens when either the serial number, the registration name, or the registration code is wrong.

Make sure the registration is for the product you are trying to register and review the information entered – it should be typed exactly how it is printed in your registration card.

Bad serial number of registration

Users should not see this message – it is an internal check when trying to set a license active. If this message is displayed, contact Data Access Technical Support.

You need to select some registration for this operation

Users should not see this message – the button will be disabled when it shouldn't be used. If this message is displayed, contact Data Access Technical Support.

Cannot make registration Active

The only products that can be made active are: CrossMerge, Web Application Server and Visual DataFlex.

Users should not see this message – the button will be disabled when it shouldn't be used. If this message is displayed, contact Data Access Technical Support.

Cannot store license in file

Process of adding license was not completed successfully because write operation failed. This may be caused by a read-only registration file (e.g. Termlist.cfg) or because the user does not have writing rights, for example.

Cannot read registration file

The registration file (e.g.Termlist.cfg) is found, can be opened but the system fails to read it. This may happen because the user does not have reading privileges, for example.

Unable to find any product installed in current directory

No product files (EXE or DLL) in the current directory or registry entries were found.

Cannot find installed product for the license

The registration information entered does not belong to any of the installed products or revisions found by the registration program.

Example: The registration entered is for Visual DataFlex 8 and you have Visual DataFlex 11 installed

Cannot read registry for needed license data

The registry entries containing registration data could be accessed when trying to delete a Web Application Server license.

Registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Data Access Worldwide\Visual DataFlex\11.0\WebApp Server

Cannot delete license

The selected license cannot be removed. This can be caused by a read-only registration file (e.g. Termlist.cfg), for example.

Unknown type of product for the license

Users should not see this message – the product code of the license being added is not one of the Data Access’ products recognized by the program. If this message is displayed, contact Data Access Technical Support.

Cannot delete active license

Users should not see this message – the button will be disabled when it shouldn't be used. If this message is displayed, contact Data Access Technical Support.

In order to add Electos license, you need to have Web Application Server installed

If Web Application Server is not found in the current directory, this error is displayed. The program looks for WebAppServer.exe.

Cannot install Electos license because your Web Application Server license seems to be invalid

The registration is in the registry but no registration file (e.g. Termlist.cfg) is found. Deleting termlist.cfg from the current directory can cause this error.


Product Registration

How the Registration Program Works

The registration program will search for all Data Access’ products in the current directory – where the registration program is running from – and list them in its product tree. For each product found, the program tries to locate their licenses and displays the registration details under the product name.

The directory being searched will be displayed at the bottom of the tree, next to “Information read from” phrase.

In order to enable the Register button, all three forms – Serial Number, Registration Name and Registration Code – need to be filled in. The Make Active (for Web Application Server, Visual DataFlex and CrossMerge licenses) and Delete buttons will only be enabled when a registration line is highlighted in the tree.

When registering a product, the tree will be automatically refreshed and the new registration will be displayed. The total number of users licensed will be displayed on the same line as the product name.

General Rules

  1. An evaluation license is always replaced and removed from the tree when you enter a real license

  2. Active licenses cannot be deleted. In order to delete an Active license, you will need to first make another license active and then delete the license that was active before.

  3. A license can only be entered for the products and product versions found in the current directory.

  4. The only products that can have their licenses selected as active are: CrossMerge, Visual DataFlex and Web Application Server.

Product Specific Rules

Visual DataFlex

Web Application Server

Microsoft SQL Server Connectivity Kit

Pervasive.SQL Connectivity Kit

IBM DB2 Connectivity Kit

ODBC Connectivity Kit

Crystal Reports

Electos

CrossMerge

See Also

Registration Program Error Messages