Deployment Guide

Deploying Applications

  • Deploying Windows Applications

  • Deploying Web Applications

  • Connectivity Options

  • Deployment Reference


Deploying Windows Applications

  • Installing the Visual DataFlex Client Engine

  • Configuring the Visual DataFlex Client Engine

  • Client Engine Configuration Control File

  • Installing Your Windows Application

See Also

Deploying Applications


Installing the Visual DataFlex Client Engine

The Visual DataFlex Client Engine is provided in a configurable installation program. The program will automatically install the Visual DataFlex Client Components and optionally install Database Builder, Database Explorer and other utilities provided by Data Access Worldwide.

The Client Engine installs all files and makes all necessary Windows Registry settings to allow Visual DataFlex Windows applications to run on the destination computer. You can configure which optional components are installed and certain installation display options by using the Client Engine Configuration Control File.

You can download the most current Visual DataFlex Client Installation and Visual DataFlex Client Installation Configuration File for the version of Visual DataFlex you are using from the download section of our Web site: http://www.dataaccess.com.

You may choose to develop an installation program for your Visual DataFlex application(s) using any available software installation tool, such as Wise Installer or InstallShield. For licensing reasons, you must install the Visual DataFlex Client Engine using the Client installation program provided. You can implement this by calling the Client installation program from your installation program.

Client Network Installation

Most likely, you will install your application on a network rather than a standalone PC.

In order to run a Visual DataFlex Windows application on a Windows workstation from a server, the Visual DataFlex Client Engine has to be installed on the server, and the workstation needs to know the location of the Client Engine. The way the workstation knows where to find the Client Engine is via Registry settings installed by the Client installation. The question is how to get these Registry settings onto each workstation. There are 2 common approaches:

Install the Client Engine from each workstation to the server.

Run the Client installation on one workstation, while pointing it at the desired server location (via a mapped drive or \\ServerName\Path). This will install the Client Engine on the server, while registering its location on the workstation.

Run the Client installation on each workstation the same way as you did on the first.

You will only have to execute the Visual DataFlex Registration program only once. This will register the license on the server. All workstations will then have access to the registration information on the server.

Install the Client Engine from one workstation to the server, then import the required registry settings on the remaining workstation.

Run the Client installation on one workstation, while pointing it at the desired server location (via a mapped drive or \\ServerName\Path). This will install the Client Engine on the server, while registering its location on the workstation.

Export the Registry settings installed by the Client installation on this workstation to Registry (.reg) files.

You have to export the following Registry keys:

HKey_Local_Machine\Software\Data Access Worldwide

The Registry settings in this key must be installed on each workstation

Place the .reg files with the exported Registry keys on a removable disk or a network location that all workstation have access to.

Import the Registry settings on each of the remaining workstations.

Ensure that the required minimum revisions of the below DLLs are installed on each workstation.

The Client installation does this for you, but you'll have to make sure the workstation where you do not run the Client installation has these minimum DLL versions as well.

psapi.dll = 4.0.1371.1

msvcrt.dll = 6.0.8797.0

mfc42.dll = 6.0.8665.0

See Also

Deploying Windows Applications


Configuring the Visual DataFlex Client Engine

The Client Engine Configuration Control File allows you to customize how the Client Engine is installed. The file itself is nothing more than an ASCII file that contains keywords and values. When run from a command line, the Client installation can automatically extract the values based on those keywords, and change the behavior of the installation process.

%PATH%\VDF.xxxx.Client.exe /m=VDF.xxxx.Client.cfg

The control file provided with the product also contains the complete documentation of the keywords

See Also

Deploying Windows Applications


Client Engine Configuration Control File

========================================================================

This is the Visual DataFlex Client Engine Configuration Control File

========================================================================

Please note that all uppercase keywords contained in the file must

not be duplicated (even in lowercase). Also, the format of the

keyword settings are very important to the proper function of the

automatic Client configuration. If you change any setting, be sure

to fully test the Client installation.

When you execute the Visual DataFlex Client Engine installation

program in the following form...

%PATH%\VDF.xxxx.Client.exe /m=VDF.xxxx.Client.cfg

... the settings below determine where the client components are

installed and which optional components are included.

=====================================================================

The SHOWSUMMARY setting determines if the Client Engine installation

program will show a summary of the installation configuration options

during installation. This value should be set to Y or N. If the

Client Engine installation program cannot find this setting, or the

setting contains a value other than Y or N, the default action is to

show the summary.

SHOWSUMMARY=Y

=====================================================================

The PROMPTLOCATION setting determines if the Client Engine

installation will prompt the user for a target folder for the Visual

DataFlex 10.1 Client Engine. If set to N, the dialog that supports

this function is suppressed. This value should be set to Y or N. If

the Client Engine installation program cannot find this setting, or

the setting contains a value other than Y or N, the default action is

to prompt the user for a target folder.

PROMPTLOCATION=Y

=====================================================================

The VDFLOCATION setting determines where the Client Engine

components are installed. If the Client Engine installation program

cannot find this setting, the default of "Visual DataFlex 11.0" is

used.

VDFLOCATION=Visual DataFlex 11.0

=====================================================================

The PROGRAMFILES setting determines if the machine default setting

for "Program Files" will be used in conjunction with the

VDFLOCATION setting. This value should be set to Y or N. If the

Client Engine installation program cannot find this setting, the

default action is to use the machine default setting of "Program

Files".

NOTE: If you set PROGRAMFILES to N, you MUST supply the complete and

valid path for the installation in the VDFLOCATION variable. If

the path is incomplete or invalid, serious errors may occur,

including problems attempting to uninstall the Client License.

PROGRAMFILES=Y

=====================================================================

The SELECTLANGUAGE setting determines if the Client Engine

installation will allow non-English languages to be selected during

installation. If you are installing df_collate.cfg and the

appropriate error files along with your application, we suggest that

you keep the default setting of N and continue to control the

language in your application installation. This value should be set

to Y or N. If the Client Engine installation cannot find this

setting, the default action is to not prompt the user for any

information about language selection.

SELECTLANGUAGE=N

=====================================================================

The setting below determines if non-English df_collate.cfg and error

files are automatically installed instead of the English versions.

If SELECTLANGUAGE (above) is set to N, the appropriate language

selection is made automatically. If SELECTLANGUAGE is set to Y, the

language default will be adjusted from English to the appropriate

language, but the user will still be prompted to select the language

during installation. This value should be set to one of the

following; DANSK, DEUTSCH, ENGLISH, ESPANOL, FRANCAIS, ITALIANO,

NEDERLANDS, PORTUGUES or SVENSKA. If the Client Engine installation

cannot find this setting, the default action is to install the

ENGLISH language df_collate.cfg and error files.

LANGUAGEFILES=ENGLISH

=====================================================================

The VDFREGISTRATION setting determines if the Client Engine

installation will prompt the user for a Client License registration

code. This value should be set to Y or N. If the Client Engine

installation program cannot find this setting, or the setting

contains a value other than Y or N, the default action is to prompt

the user for a Client Engine registration code.

This setting should only be set to N if you are expecting the user to

register the Client Engine at a later date (such as installing as an

evaluation license) or will supply pre-registered termlist.cfg and

license.dfr files in the application installation.

VDFREGISTRATION=Y

=====================================================================

The settings below determine which optional components are installed.

These values should be set to Y or N. If the Client Engine

installation program cannot find any of these settings, or any of

the settings contain a value other than Y or N, the default action is

to install that component.

DataBase Builder and associated files:

DBBUILDER=Y

DataBase Explorer and associated files:

DBEXPLORER=Y

Error Maintenance Utility and associated files:

FLEXERRS=Y

Visual DataFlex Client Evaluation Registration:

EVAL=Y

See Also

Deploying Windows Applications


Installing Your Windows Application

Once the Visual DataFlex Client Engine is installed, you need to install your Windows application.

This process may include some or all of the following:

  • Installing Application Files

  • Creating and Setting Registry Settings

  • Installing and Registering ActiveX Controls

  • Installing Crystal Reports Runtime Files

The best way to simplify application installation is to mirror the workspace setup of your development environment on the deployment PC or network server. If you need to change the workspace setup to be different than on your development PC, you will have to modify the workspace (.ws) file installed with your application accordingly.

Installing Application Files

Generally, files in the data, programs, help and bitmaps folders of a Windows application workspace are deployed. So, your deployed workspace's folder structure should look like this:

\Workspace

\Bitmaps

\Data

\Help

\Programs

The files listed below are only those created by the Visual DataFlex development tools when building a Visual DataFlex Windows application. If your application uses additional files, you must deploy these as well.

Data Folder

Depending on the database you are using, the required files may vary. If you are using databases in your application other than the embedded (DataFlex) database, please consult the documentation for those databases and drivers (Connectivity Kits) about additional files that may need to be distributed.

Embedded (DataFlex) database:

filelist.cfg

*.dat

*.hdr

*.k??

*.tag

*.vld (if present)

Pervasive.SQL:

filelist.cfg

*.btr

*.int

*.ddf

codemast.*

codetype.*

Microsoft.SQL:

filelist.cfg

*.mdf

*.int

codemast.*

codetype.*

Programs Folder

*.exe - compiled program files

*.ws - workspace file(s)

You must install the workspace (.ws) file for your workspace in the same folder where your compiled program (.exe) resides, unless you specify the path to this file in your application.

Help Folder

If you have created help files for your application, you want to deploy these. If you are using HTML Help, you should only need to deploy *.chm. Consult the documentation of the help authoring system you use for more details about which files you need to deploy.

Bitmaps Folder

If you are taking advantage of the ability to embed bitmaps and icons as resources into a compiled application, you do not have to deploy those bitmap and icon files separately.

Creating and Setting Registry Settings

All Client Engine-specific and utility-specific Registry settings are automatically created during installation.

If there are additional Registry settings required for your application, you must create them as part of your application installation.

DF_Collate.cfg Special Note

When deploying applications which use a collating sequence other than the one used for the English language, it is critical that the df_collate.cfg file for the language you select is deployed to the Bin folder of the Client or Server installation.

See Also

Deploying Windows Applications


Deploying Web Applications

  • Installing Your Web Application

  • Installing the Web Application Server

See Also

Deploying Applications


Installing Your Web Application

Once the Visual DataFlex Web Application Server is installed, you need to install the files needed by your application.

This may include any or all of the following:

  • Installing Application Files

  • Creating a Virtual Directory

  • Creating and Setting Registry Settings

  • Adding the Web Application to the Web Application Administrator

  • Installing Application Files

  • Configuring Deployed Workspaces

The best way to simplify application installation is to mirror the workspace setup of your development environment on the deployment PC. If you need to change the workspace setup to be different than on your development PC, you will have to modify the workspace (.ws) file installed with your application.

Files to Install

Generally, files in the apphtml, data, and programs folders of a Web application workspace are deployed. So, your deployed workspace's folder structure should look like this:

\Workspace

\apphtml

\data

\programs

The files listed below are only those created by the Visual DataFlex development tools when building a VDF application. If your application uses additional files, you must deploy these as well.

AppHTML Folder

  • global.asa, *.asp, *.htm?

  • apphtml\css\*.css

  • apphtml\images\*.*

  • apphtml\inc\*.inc

Data Folder

Depending on the database you are using, the required files may vary. If you are using databases in your application other than the embedded (DataFlex) database, please consult the documentation for those databases and drivers (Connectivity Kits) about additional files that may need to be distributed.

Embedded (DataFlex) Database

filelist.cfg, *.dat, *.hdr, *.k??, *.tag, *.vld (if present)

Pervasive.SQL

filelist.cfg, *.btr, *.int, *.ddf, codemast.*, codetype.*

Microsoft.SQL

filelist.cfg, *.mdf, *.int, codemast.*, codetype.*

Programs Folder

webapp.exe - compiled Web application file

*.ws - workspace file(s)

You must install the workspace (.ws) file for your workspace in the same folder where your compiled program (.exe) resides, unless you specify the path to this file in your application.

Creating a web share (Virtual Directory)

An Internet Information Server (IIS)-based Web Application requires a virtual directory (sometimes called a web share) to run in. This is the second part of the path that is used to access a Web Application:

http://ServerName/VirtualDirectoryName/FileName.asp

For example, the Visual DataFlex Web Application Data Entry and Report Example application typically uses this URL to be accessed:

http://localhost/Order_Entry_12/default.asp

where Order_Entry_12 is the name of the virtual directory this sample application runs in.

In most cases you will create the web share automatically as part of configuring the web application in the Web Application Administrator described below. But you can also create the web share programmatically. To help create virtual directories programmatically, a program named wincrtvdir.exe is installed in the bin folder. It accepts parameters for creating virtual directories. There are 2 calls required to create a working virtual directory:

wincrtvdir.exe -q CD WindowsFolderName VirtualDirectoryName 513

wincrtvdir.exe -q CA w3svc/1/root/VirtualDirectoryName INPROC

where:

  • WindowsFolderName is the name of the AppHtml folder for which the virtual directory is to be created

  • VirtualDirectoryName is the name of the virtual directory to be created

For example, the calls to create the virtual directory for the Order_Entry_12 sample application are these:

"c:\program files\Visual DataFlex 12.0\bin\wincrtvdir.exe" -q CD "C:\Program Files\Visual DataFlex 12.0\Examples\Order Entry\AppHtml" Order_Entry_12 513

"c:\program files\Visual DataFlex 12.0\bin\wincrtvdir.exe" -q CA w3svc/1/root/Order_Entry_12 INPROC

Creating and Setting Registry Settings

All Web Application Server-specific and utility-specific Registry settings are installed by the Server installation.

If there are Registry settings required for your application, you must install them as part of your application installation.

Adding the Web Application to the Web Application Administrator

There are 2 ways you can register a Visual DataFlex Web Application for the Web Application Administrator (and the Visual DataFlex Web Application Service):

Via the Visual DataFlex Web Application Administrator

Select File -> New Web Application Configuration and follow the steps outlined by the New Web Application Configuration wizard. The wizard is the easiest way to configure the web application, it can also automatically creates the web share (virtual directory).

By installing the required Registry settings for the application

For each Web Application, a set of Registry settings needs to be installed. A Registry key with the Web Application Name must be installed into the key:

HKey_Local_Machine\Software\Visual DataFlex\12.0\WebApp Server

For example, the Registry key for the Order Entry sample application is:

HKey_Local_Machine\Software\Visual DataFlex\12.0\WebApp Server\Order_Entry

You need to install a number of Registry values into the Registry key for your web application. When you are finished, the Registry values for your web application should look like the image below.

After you have installed the Registry settings for your web application, the Visual DataFlex Web Application Server Service will immediately start the application if the service is running or it will automatically start the application the next time the service is started (after a reboot, for example).

DF_Collate.cfg Special Note

When deploying applications which use a collating sequence other than the one used for the English language, it is critical that the df_collate.cfg file for the language you select is deployed to the Bin folder of the Client or Server installation.

See Also

Deploying Web Applications


Installing the Web Application Server

The Visual DataFlex Web Application Server Installation is an installation program, provided by Data Access Worldwide, that installs the Visual DataFlex Web Application Server, Web Application Administrator, Database Builder, Database Explorer and Error Codes Maintenance.

The Server installation always installs all files and makes all necessary Windows Registry settings to allow Visual DataFlex Web applications to run on the destination computer.

You can download the most current Visual DataFlex Web Application Server Installation for the version of Visual DataFlex you are using from the download section of our Web site: http://www.dataaccess.com.

You may choose to develop an installation program for your Visual DataFlex application(s) using any available software installation tool, such as Wise Installer or InstallShield. For licensing reasons, you must install the Visual DataFlex Web Application Server using the Server installation. You can implement this by calling the Server installation program from your application installation program.

See Also

Deploying Web Applications


Connectivity Options

Data Access Corporation has several database drivers (Connectivity Kits) available:

  • Pervasive.SQL Connectivity Kit

  • Microsoft SQL Server Connectivity Kit

  • IBM DB2 Connectivity Kit

  • ODBC Connectivity Kit

Your Visual DataFlex Studio license includes 2-user, development and testing licenses for all the Connectivity Kits, so you can start developing client/server applications now, and at no additional cost. When you deploy your Visual DataFlex applications that use any of the Connectivity Kits, you must obtain the appropriate deployment license. To make this process easier (and save money), you can purchase your Client Engine licenses with the Connectivity Kit license in a bundle.

The Visual DataFlex Client Engine has the ability to load the driver(s) for any database(s) you wish to use; often without having to recompile the application.

Please consult the documentation for the individual Connectivity Kits for more information.

See Also

Deploying Applications


Deployment Reference

  • Deploying Web Applications on Windows Server 2003

  • Deploying with ActiveX Components

  • Deploying with Crystal Reports Components

  • Finding DLLs

  • Universal Naming Convention

  • Registry File Formats

  • Additional Reading

See Also

Deploying Applications


Deploying Web Applications on Windows Server 2003

On Windows Server 2003, Active Server Pages (ASP) are not enabled by default even after installing Internet Information Server 6 (IIS). Since Visual DataFlex Web applications use ASP pages, you must enable this before your applications can run on Windows Server 2003.

To install IIS 6.0:

  • Select Start | Manage Your Server (if Manage Your Server does not come up automatically)

  • Select Add or Remove role on the right-top side of the panel

  • Click Next on the first screen

  • Select Custom Configuration and press Next

  • Highlight Application Server (IIS, ASP.NET) and press Next

  • Check the boxes to add tools you would like to install (not needed for ASP support)

  • Review the options selected to confirm your options and press Next

  • Wait until the installation is completed (the Windows 2003 CD may be needed) and click Finish at the "This Server is Now an Application server" panel

After having IIS 6.0 installed, you will still not be able to run WebApp Server applications on it. You need to enable ASP to run on that machine -- this is also disabled by default -- otherwise you will experience 404 error messages when running the samples or even your applications.

In order to enable ASP, you need to:

  • Select Start | Manage Your Server (if Manage Your Server does not come up automatically)

  • Click on Manage this Application server

  • Expand Internet Information Services (IIS) | <your_machine_name> (local computer)

  • Highlight Web Service Extensions

  • On the right-side panel, highlight Active Server Pages (the default status is prohibited)

  • Click on the Allow button from the group of buttons on the left

See Also

Deployment Reference


Deploying with ActiveX Components

Deploying Applications with ActiveX Components

The necessary support files for the FlexCOM component of Visual DataFlex, which allows your Windows application to use ActiveX controls, are automatically installed with the Client Engine.

You must install and register any files for the ActiveX controls your application uses. This must be done on each workstation running your application. Consult the documentation provided with the specified controls on how to install them at a client site.

Note

If your Windows application is still using the legacy FlexCOM interface, you need to deploy the appropriate .ocp files for your ActiveX controls. These files should be in your Programs folder for deployment.

The newer FlexCOM 2 interface removes this requirement.

See Also

Deployment Reference


Deploying with Crystal Reports Components

Deploying Applications with Crystal Reports Components

This information contained in this sections only applies if you are using Crystal Reports 10 (or earlier) and the legacy Crystal runtime interface. If you are using Crystal Reports XI (or later), please see Visual DataFlex and Crystal Reports in the Using Crystal Reports in Applications section of the help.

If your application includes reports based on Crystal Reports, your application installation must include the required files to run those reports. In addition to the reports themselves, you must install the appropriate Crystal Reports runtime files. If your reports access the embedded database, you must also install the appropriate Crystal Reports Connectivity Kit runtime files.

The runtime files that you should install vary based upon the specific revision of Crystal Reports that you use.

Be sure that the Crystal Reports edition for which you are licensed allows the deployment of runtime files. In Crystal Reports 9 and higher, you must have either the Developer or Advanced Developer editions to deploy Crystal runtime files.

Important Time-saving Note

The leading products for creating application installations (including Wise and InstallShield) provide scripts or plug-in components that will automate the installation of the appropriate Crystal Reports runtime files. We strongly recommend that you take advantage of these automated installations so that you can concentrate on your application installation.

Crystal Reports 10

The Visual DataFlex 11 Studio does not install Crystal Reports or the Crystal Reports Connectivity Kit. You must install Crystal Reports 10 and the Crystal Reports Connectivity Kit 10 separately to develop Crystal Reports 10 reports for use with Visual DataFlex applications.

The files listed here are the minimum set you need to install for any Crystal Reports 10 report. Most likely, other files will be needed for specific reports, such as files for certain export formats. We recommend that you always install all of the Crystal Reports runtime files, so you never had to worry about a missing file for a specific report. This includes all DLLs in the Crystal Reports 10 Bin folder;

C:\Program Files\Common Files\Crystal Decisions\2.5\Bin

Consult the Crystal Reports 10 Developer Runtime Help...

C:\Program Files\Crystal Decisions\Crystal Reports 10\Developer Files\Help\En\Runtime.chm

..., installed with the Crystal Reports 10 Developer or Advanced Developer edition, for more information about the files that make up the Crystal Reports 10 runtime.

To see which of the Crystal Reports 10 runtime files are necessary for a specific report, open the report in Crystal Reports 10 and check the list of DLLs displayed when clicking on the More Info button from the Help | About Crystal Reports menu.

The More Info button may list winmm.dll, msshrui.dll and other DLLs that are part of the Windows operating system. Do not distribute these files with your report. These files are part of the Windows operating system and are operating system and build specific.

Files

WindowsSystemDir refers to the full path to the Windows System folder, the folder in which Windows system files are installed on the current PC. The default value for this on Windows 98, ME and XP is c:\Windows\System. The default value for this on Windows NT 4, 2000 and 2003 is c:\WinNT\System32.

RtDeployPath refers to the full path to the folder in which the Client Engine is installed on the deployment PC.

CrystalReportsDevPath refers to the full path to the folder in which the Crystal Reports development license is installed on your development PC. This should be C:\Program Files\Common Files\Crystal Decisions\2.5\Bin.

Crystal Reports 10 32-bit Runtime files

Development Location | Destination Location
CrystalReportsDevPath\crpe32.dll | RtDeployPath\bin\crpe32.dll
CrystalReportsDevPath\crqe.dll * | RtDeployPath\bin\crqe.dll
CrystalReportsDevPath\crwrap32.dll ** | RtDeployPath\bin\crwrap32.dll
CrystalReportsDevPath\Implode.dll *** | RtDeployPath\bin\Implode.dll
CrystalReportsDevPath\querybuilder.dll | RtDeployPath\bin\querybuilder.dll
CrystalReportsDevPath\ufmanager.dll | RtDeployPath\bin\ufmanager.dl
CrystalReportsDevPath\unicows.dll **** | RtDeployPath\bin\unicows.dll
WindowsSystemDir\msvcrt.dll ***** | RtDeployPath\bin\msvcrt.dll
WindowsSystemDir\msvcp60.dll ****** | RtDeployPath\bin\msvcp60.dll
WindowsSystemDir\riched20.dll | RtDeployPath\bin\riched20.dll
WindowsSystemDir\cxlib-1-6.dll | RtDeployPath\bin\cxlib-1-6.dll
WindowsSystemDir\cxlibw-1-6.dll | RtDeployPath\bin\cxlibw-1-6.dll
WindowsSystemDir\usp10.dll | RtDeployPath\bin\usp10.dll

* You must register crqe.dll on each workstation that will run your Crystal Reports 10 reports. Most installation tools, like Wise Installer, have automated methods for doing this. The manual way to do this is as follows:

Start > Run > regsvr32 RtDeployPath\bin\crqe.dll

Remember to place quotes around RtDeployPath\bin\crqe.dll if this path contains a space.

** Include crwrap32.dll if your application makes calls to Crystal Reports functions ExportToDisk, ExportToMapi, ExportToHTML, ExportToODBC, SelectPrinter or GetSelectedPrinter.

*** Include Implode.dll only for applications using reports created in versions previous to Crystal Reports 8.

**** Include unicows.dll only for applications installed on Win9x machines. Due to licensing restrictions, you must get unicows.dll from the Microsoft web site. Go to http://www.microsoft.com/msdownload/platformsdk/sdkupdate/default.htm? and select "Microsoft Layer for Unicode on Windows 95/98/ME Systems (MSLU) version 1.0".

***** Msvcrt.dll should only be installed if it does not already exist on the deployment PC.

****** Msvcp60.dll should only be installed if it does not already exist on the deployment PC.

Crystal Reports Connectivity Kit 10 files

Development Location | Destination Location
CrystalReportsDevPath\p2bdfapi.dll | RtDeployPath\bin\p2bdfapi.dll
CrystalReportsDevPath\crdb_p2bdfapi.dll | RtDeployPath\bin\crdb_p2bdfapi.dll
WindowsSystemDir\apidll.dll | RtDeployPath\bin\apidll.dll
WindowsSystemDir\df_collate.cfg | RtDeployPath\bin\df_collate.cfg

The reason the files in the chart have been moved from the development computer's \WindowsSystemDir to the deployment computer's \bin folder is to avoid possible conflicts with software already loaded on the deployment computers. This chart assumes you are using Crystal Reports .rpt files with your Visual DataFlex application.

If you are using Crystal Reports .exe files (with all the required distribution files), you need to copy the .exe (and distribution files) to the \bin folder so the Connectivity Kit files listed in the chart can be found by the .exe program. If your .exe files cannot be located in the \bin folder, then the Connectivity files listed in the chart need to be copied to the deployment \WindowsSystemDir or to the same folder as the .exe (and distribution files). If the Connectivity Kit files are copied to the deployment computer’s \WindowsSystemDir folder be sure to check that no conflicts with other software exist.

Crystal Reports 9

The Visual DataFlex 11 Studio does not install Crystal Reports or the Crystal Reports Connectivity Kit. You must install Crystal Reports 9 and the Crystal Reports Connectivity Kit 9 separately to develop Crystal Reports 9 reports for use with Visual DataFlex applications.

The files listed here are the minimum set you need to install for any Crystal Reports 9 report. Most likely, other files will be needed for specific reports, such as files for certain export formats. We recommend that you always install all of the Crystal Reports runtime files, so you never had to worry about a missing file for a specific report. This includes all DLLs in the Crystal Reports 9 Bin folder;

C:\Program Files\Common Files\Crystal Decisions\2.0\Bin

Consult the Crystal Reports 9 Developer Runtime Help...

C:\Program Files\Crystal Decisions\Crystal Reports 9\Developer Files\Help\En\Runtime.chm

...installed with the Crystal Reports 9 Developer or Advanced Developer edition) for more information about the files that make up the Crystal Reports 9 runtime.

To see which of the Crystal Reports 9 runtime files are necessary for a specific report, open the report in Crystal Reports 9 and check the list of DLLs displayed when clicking on the More Info button from the Help | About Crystal Reports menu.

The More Info button may list winmm.dll, msshrui.dll and other DLLs that are part of the Windows operating system. Do not distribute these files with your report. These files are part of the Windows operating system and are operating system and build specific.

Files

WindowsSystemDir refers to the full path to the Windows System folder, the folder in which Windows system files are installed on the current PC. The default value for this on Windows 98, ME and XP is c:\Windows\System. The default value for this on Windows NT 4, 2000 and 2003 is c:\WinNT\System32.

RtDeployPath refers to the full path to the folder in which the Client Engine is installed on the deployment PC.

CrystalReportsDevPath refers to the full path to the folder in which the Crystal Reports development license is installed on your development PC. This should be C:\Program Files\Common Files\Crystal Decisions\2.0\Bin.

Crystal Reports 9 32-bit Runtime files

Development Location | Destination Location
CrystalReportsDevPath\crpe32.dll | RtDeployPath\bin\crpe32.dll
CrystalReportsDevPath\crqe.dll * | RtDeployPath\bin\crqe.dll
CrystalReportsDevPath\crwrap32.dll ** | RtDeployPath\bin\crwrap32.dll
CrystalReportsDevPath\Implode.dll *** | RtDeployPath\bin\Implode.dll
CrystalReportsDevPath\querybuilder.dll | RtDeployPath\bin\querybuilder.dll
CrystalReportsDevPath\ufmanager.dll | RtDeployPath\bin\ufmanager.dl
CrystalReportsDevPath\unicows.dll **** | RtDeployPath\bin\unicows.dll
WindowsSystemDir\msvcrt.dll ***** | RtDeployPath\bin\msvcrt.dll
WindowsSystemDir\msvcp60.dll ****** | RtDeployPath\bin\msvcp60.dll
WindowsSystemDir\riched20.dll | RtDeployPath\bin\riched20.dll
WindowsSystemDir\usp10.dll | RtDeployPath\bin\usp10.dll

* You must register crqe.dll on each workstation that will run your Crystal Reports 9 reports. Most installation tools, like Wise Installer, have automated methods for doing this. The manual way to do this is as follows:

Start > Run > regsvr32 RtDeployPath\bin\crqe.dll

Remember to place quotes around RtDeployPath\bin\crqe.dll if this path contains a space.

** Include crwrap32.dll if your application makes calls to Crystal Reports functions ExportToDisk, ExportToMapi, ExportToHTML, ExportToODBC, SelectPrinter or GetSelectedPrinter.

*** Include Implode.dll only for applications using reports created in versions previous to Crystal Reports 8.

**** Include unicows.dll only for applications installed on Win9x machines. Due to licensing restrictions, you must get unicows.dll from the Microsoft web site. Go to http://www.microsoft.com/msdownload/platformsdk/sdkupdate/default.htm? and select "Microsoft Layer for Unicode on Windows 95/98/ME Systems (MSLU) version 1.0".

***** Msvcrt.dll should only be installed if it does not already exist on the deployment PC.

****** Msvcp60.dll should only be installed if it does not already exist on the deployment PC.

DataFlex Connectivity Kit for Crystal Reports 9 files

Development Location | Destination Location
CrystalReportsDevPath\p2bdfapi.dll | RtDeployPath\bin\p2bdfapi.dll
CrystalReportsDevPath\crdb_p2bdfapi.dll | RtDeployPath\bin\crdb_p2bdfapi.dll
WindowsSystemDir\apidll.dll | RtDeployPath\bin\apidll.dll
WindowsSystemDir\df_collate.cfg | RtDeployPath\bin\df_collate.cfg

The reason the files in the chart have been moved from the development computer's \WindowsSystemDir to the deployment computer's \bin folder is to avoid possible conflicts with software already loaded on the deployment computers. This chart assumes you are using Crystal Reports .rpt files with your Visual DataFlex application.

If you are using Crystal Reports .exe files (with all the required distribution files), you need to copy the .exe (and distribution files) to the \bin folder so the Connectivity Kit files listed in the chart can be found by the .exe program. If your .exe files cannot be located in the \bin folder, then the Connectivity files listed in the chart need to be copied to the deployment \WindowsSystemDir or to the same folder as the .exe (and distribution files). If the Connectivity Kit files are copied to the deployment computer’s \WindowsSystemDir folder be sure to check that no conflicts with other software exist.

Crystal Reports 8

This section will show files needed for the DataFlex Connectivity Kit for Crystal Reports, version 2.0. You need to know which version of the Connectivity Kit you are using to determine which files you need to deploy.

The Visual DataFlex 11 development installation does not install Crystal Reports or the Crystal Reports Connectivity Kit. You must install Crystal Reports 8 and the DataFlex Connectivity Kit for Crystal Reports, version 2.0 separately to develop Crystal Reports 8 reports for use with Visual DataFlex applications.

This section tells you which files you need to install with your Visual DataFlex application to run Crystal Reports 8 .rpt files. If you are deploying reports developed in Crystal Reports 9, please see the Crystal Reports 9 section. If you are using versions of Crystal Reports other than 9 or 8, please consult the Crystal Reports documentation of that revision for more details on which files to deploy with your reports.

The files listed here are those you need to install for any Crystal Reports 8 report. Most likely, other files will be needed for specific reports, such as files for certain export formats. We recommend that you always install all of the Crystal Reports 8 runtime files, so you never had to worry about a missing file for a specific report. Consult the Crystal Reports 8 documentation to see which files make up the Crystal Reports 8 runtime.

To see which of the Crystal Reports 8 runtime files are necessary for a specific report, open the report in Crystal Reports 8 and check the list of DLLs displayed when clicking on the More Info button from the Help | About Crystal Reports menu.

The More Info button may list winmm.dll, msshrui.dll and other DLLs that are part of the Windows operating system. Do not distribute these files with your report. These files are part of the Windows operating system and are operating system and build specific.

Crystal Reports 8 installs numerous files into your Windows System folder. When deploying your application, these files should be installed into the \visual dataflex 10\bin folder instead, so that they do not interfere with existing Crystal Reports installations, which may be Crystal Reports revisions different from 8.

Files

WindowsSystemDir refers to the full path to the Windows System folder, the folder in which Windows system files are installed on the current PC. The default value for this on Windows 98, ME and XP is c:\Windows\System. The default value for this on Windows NT 4, 2000 and 2003 is c:\WinNT\System32.

RtDeployPath refers to the full path to the folder in which the VDFCEI is installed on the deployment PC.

VDFDevPath refers to the full path to the folder in which your Visual DataFlex development license is installed on your development PC

Crystal Reports 8 32-bit Client Engine files

Development Location | Destination Location
WindowsSystemDir\Crpe32.dll | RtDeployPath\bin\crpe32.dll
WindowsSystemDir\Implode.dll | RtDeployPath\bin\Implode.dll
WindowsSystemDir\mfc42.dll | RtDeployPath\bin\mfc42.dll
WindowsSystemDir\msvcrt.dll | RtDeployPath\bin\msvcrt.dll
WindowsSystemDir\msvcp60.dll * | RtDeployPath\bin\msvcp60.dll

* Msvcp60.dll should only be installed if it does not already exist on the deployment PC.

DataFlex Connectivity Kit for Crystal Reports 8 version 2.0 files

Development Location | Destination Location
WindowsSystemDir\Apidll.dll | RtDeployPath\bin\Apidll.dll
WindowsSystemDir\Crystal\P2bdfapi.dll | RtDeployPath\bin\P2bdfapi.dll
VDFDevPath\bin\Crpaig80.dll | RtDeployPath\bin\Crpaig80.dll
WindowsSystemDir\df_collate.cfg | RtDeployPath\bin\df_collate.cfg

The reason the files in the chart have been moved from the development computer's \WindowsSystemDir to the deployment computer's \bin folder is to avoid possible conflicts with software already loaded on the deployment computers. This chart assumes you are using Crystal Reports .rpt files with your Visual DataFlex application.

If you are using Crystal Reports .exe files (with all the required distribution files), you need to copy the .exe (and distribution files) to the \bin folder so the Connectivity Kit files listed in the chart can be found by the .exe program. If your .exe files cannot be located in the \bin folder, then the Connectivity files listed in the chart need to be copied to the deployment \WindowsSystemDir or to the same folder as the .exe (and distribution files). If the Connectivity Kit files are copied to the deployment computer’s \WindowsSystemDir folder be sure to check that no conflicts with other software exist.

See Also

Deployment Reference


Finding DLLs

The locations Windows executable (.exe) programs search for DLLs they need to load is these (in order):

  • The same folder as the .exe file

  • The Windows system folders

  • Along the PATH

You compiled Visual DataFlex applications will use this standard Windows executable behavior when searching for DLLs.

Legacy Information

The finding of DLLs (.dll files or dynamic link libraries) has changed from older revisions of Visual DataFlex that did not compile to .exe files (revisions 7 and prior). This may especially affect you if you use products such as Crystal Reports and/or one or more of our Connectivity Kits.

In Visual DataFlex revisions 7 and below, the main Windows executable file was dfrun.exe, which was located in the same folder (bin) where all related DLLs were installed. So, the DLLs installed there would be found first and any older versions of the same DLLs located in the Windows system folders were ignored. Now, older versions of DLLs used by Visual DataFlex that are found in the Windows system folders may be loaded first, resulting in error messages from applications expecting newer versions of these DLLs.

To solve this problem, you may have to install DLLs that cause such problems to the same folder where your compiled application (.exe) is located, so that they are found first by your application.

See Also

Deployment Reference


Universal Naming Convention

You may want to consider using the Universal Naming Convention (UNC) for your network installations. This will prevent problems with mapped drive mismatches.

For example:

User 1 may have F: mapped to \\Server1\Drive1\Visual DataFlex 12.0

User 2 may have G: mapped to \\Server1\Drive1\Visual DataFlex 12.0

In this scenario, without using UNC, you would have to:

  • Customize each user's Registry entries or

  • Synchronize all user's drive mappings

Universal naming convention does not use mapped drives, but instead addresses networked folders and files using this method:

\\ServerName\ShareName\Path\FileName

where:

  • ServerName is the name of the server (PC) where the files are located

  • ShareName is the shared folder name where the files are located

  • Path is the additional path to the files (if applicable) below the shared folder

  • FileName is the name of the file (if applicable) to access

See Also

Deployment Reference


Registry File Formats

Windows 2003, 2000 and XP use a newer format for Registry files than do older version of Windows (98, ME and NT). When exporting Registry information from the Windows Registry Editor on a 2003, 2000 or XP machine, the default format is "Registration Files", which uses the 2003/2000/XP format, but you can also select "Win9x/NT4 Registration Files" as the format, which will export the information using the old file format. For network installations, the best tip is to export all necessary Registry settings in both formats, so that they can be imported onto any type of Windows PC.

See Also

Deployment Reference


Additional Reading

Visit the Visual DataFlex site to learn more about Visual DataFlex:

Visit the Visual DataFlex Support page for information about all of our support offerings, including free support offerings, such as the Technical Knowledge Base, White Papers and Peer Support Newsgroups.

Opportunistic Locking and Read Caching on Microsoft Windows Networks, White Paper, Data Access Corporation, May 2002, available from the Download section of Data Access Website.

Integrating DataFlex with Netware, White Paper, Jim Albright, Wizard Systems, January 1997, available from the Download section of Data Access Website.

See Also

Deployment Reference