Onlineeye Pro

Erste Schritte - Tutorial Web Index

Onlineeye optimiert die Internet Performance ihres PC's. Ihre Up/Download Geschwindigkeit und Zeit wird in Echtzeit gemessen und für spätere Analyse aufgezeichnet. Die so aufgezeichneten Daten der letzten 24 Stunden erlauben es ihnen die Internetaktivität auch dann zu kontrollieren wenn sie nicht gerade am Rechner sitzen.

Um die vielfälltigen Anwendungsgebiete auch verwenden zu können sollten sie sich folgenden Tutorials durchlesen, sie bieten einen guten Einstieg in OnlineEye Pro.

1) Onlineeye (OE) konfigurieren und anwenden

2) Transfervolumen bzw. Bandbreite überwachen, kontrollieren und aufzeichnen

3) Spyware ausfindig machen und entfernen

4) Verdächtige Programme aufspüren

5) Werden Daten übertragen, und wenn ja, wohin werden sie übertragen ?

6) Schutz vor 0190 Dialern

7) Router und Server direkt mit Hilfe von SNMP überwachen

8) Überwachung und Fernsteuerung von Rechnern im Netzwerk


Einstellungen ( Welches Interface soll überwacht werden, Check der Verbindung ) Web Index

Startup

Onlineeye mit Windows starten :
Onlineeye beim jedem Windowsneustart mitstarten

Grafikfenster automatisch starten:
Grafikfenster beim starten von Onlineeye automatisch zeigen

Onlinezeit in jedem Fenster zeigen:
Falls eine Verbindung zum Internet besteht wird die Verbindungszeit in jedem Fenster das sich im Vordergrund befinden angezeigt.

Sampling Rate und Mittelwertbildung

Die Samplingrate legt fest in welchen Zeitabständen die Transferraten des gewälten Interfaces gemessen werden. Wenn sie also eine Samplingrate von 1sec einstellen, wird jede Sekunde ein neuer Wert für die Down/Uploadrate ermittelt.
Das "Averaging Window" legt den Zeitraum für die Mittelung der Transferrate fest, wenn sie also 30sec einstellen werden die Messwerte der letzten 30 Samples gemittelt und in der Grafik angezeigt.

Das Verhältnis dieser beiden Einstellungen wird automatisch ermittelt, kann aber auch frei gewählt werden.

Netzwerk Interface:

Sie haben die Möglichkeit auszuwählen welches Interface sie im Bezug auf die Transferraten zu überwachen, wählen sie "Gesamten Traffic" wird jeglicher Datentransfer von und zu ihrem Rechner überwacht und aufgezeichnet. Also weitere Option besteht die Möglichkeit nur das Modem zu überwachen, genauer alle RAS Verbindungen.
Des weiteren werden alle Netzwerkinterfaces die sie in ihrem Windows-System zur Verfügung stehen ermittelt und in eine Auswahlbox eingetragen, sie können nun eines Wählen und überwachen.

Hier finden sie Infos um Router und Windows Workstations/Server zu überwachen

Modus zum checken ob eine Internetverbindung besteht:

Leider ist es nicht möglich eine einzige Funktion zu verwenden die in jeder Situation feststellen kann ob
ihr Rechner gerade eine Internetverbindung zur Verfügung steht. Je nach Windowssystem, Modem, Netzwerkverbindung, Firewall oder sonstigen Einstellungen muß man verschiedene Funktionen verwenden.

Unzählige Suchstunden im Internet brachten folgende Varianten zu Tage, die für jeden User eine Möglichkeit bieten sollten seine spezielle Einstellung zu finden um den Onlinecheck erfolgreich durchzuführen.

+InternetCheckConnection ........ Windowsfunktion Google auf Verfügbarkeit testet
+InternetAttemptConnect .......... Windows Funktion, funktioniert nicht immer
+IsModem Connected ............... Falls sie eine Modemverbindung verwenden, sollte das ihre Wahl sein
+gethostbyname ...................... Checkt ob Google erreicht werden kann
+InternetGetConnectedState ...... Wenn alles nicht zu klappen scheint, versuchen sie diese Funktion

Es werden bei allen Möglichkeiten keine Daten ins Internet übertragen, es wird jeweils entweder eine Windows-API Funktion verwendet oder eben auf die Verfügbarkeit eines Hosts im Internet, hier Google, getestet, sollte eine Verbindung möglich sein haben wir eine Internetverbindung.


Feedback ( Fragen? Beschwerden? Anregungen? Verbesserungsvorschläge ?) Web Index

Bei Onlineeye können sie aktiv mitgestalten wenn es um die Funktionen für kommende
Versionen geht, sie einen Verbesserungswunsch, eine Beschwerde oder aber auch Lob
mitteilen wollen.

Tragen sie einfach ihre Email-Adresse ein und schreiben sie uns was sie schon immer
mal loswerden möchten, also mittendrin anstatt nur anwenden ;-)

Falls sie Probleme haben drücken sie bitte auf den "Systeminfo" Button und es werden
ihre OnlineEye-Einstellungen in ihr Mail eingefügt.

Bei gröberen Problemen sollten sie uns auch das Logfile senden, es ist max. 65kB groß
und wird dann umkopiert (Old), und dann in ein neues File geloggt. Das Loggerfile enthält
viele Tätigkeiten die sie durchgeführt haben, diese werden protokolliert und die
mögliche bzw. aufgetretene Fehlerursachen eingetragen.

Dieses Loggerfile wird nicht automatisch mitübertragen, beim Drücken auf den Logfile
Button wird das Loggerfile mit einem Texteditor geöffnet, sie müßten es dann speichern
und an Onlineeye@pmasoft.net senden.


Grafische Darstellung des Netzwerkverkehrs (Internet Traffic) Web Index

Hier konfiguriert man die Darstellung des Netzwerkverkehrs für die gesendeten und empfangenen Daten für das gewählte Interface. Die Darstellung erfolgt getrennt nach Up/Download , wobei noch jeweils der aktuelle Wert, der Mittelwert und der Maximalwert angezeigt wird. Die Y-Achse für den Durchsatz wird je nach Auswahl skaliert, mögliche Einstellungen sind:

Achsen

- Auto Scale ... die Achse wird automatisch skaliert
- Fixe Skalierung von 14.4K bis 10MByte

Grafik Anzeige

Diese Einstellung betrifft die empfangenen Daten als auch die gesendeten Daten.
Aktuell ...... Der aktuelle Durchsatz wird angezeigt
Mittelwert .. Der Mittelwert wird angezeigt, die Zeit für die Mittelwertbildung kann man im "Einstellungen" Dialog festlegen

Grafik

Die Grafikdarstellung erfolgt als Balkengrafik oder als Linie.

Datenverkehr Normierung

Die Skalierung und Anzeige aller Daten erfolgt entweder in Bit/sec oder Byte/sec, wobei 1Byte = 8Bit.
Außerdem wird automatisch die Umrechnung in KB/sec bzw. MB/sec vorgenommen, wobei 1MB = 1024KB,
1KB = 1024Byte

Hier konfiguriert man die Darstellung des Netzwerkverkehrs für die gesendeten und empfangenen Daten für das kleine Grafikfenster.

Farbauswahl :

- Hintergrund .... gilt für senden/empfangen
- Mittelwert ....... gilt für senden/empfangen

Diese Einstellungen werden durch drücken von "Änderung übernehmen" aktiviert.

Fensteraufteilung :

Für die Aufteilung des Fensters können in 4 verschiedenen Darstellungen gewählt werden.

Balkengrafik :

Die Balkengrafik kann von oben nach unten oder umgekehrt dargestellt werden

Fenster durchsichtig darstellen :

Bei Win2000 oder neuer kann das Fenster durchsichtig dargestellt werden.


Historischer Trend ihres Internet/Netzwerkverkehrs Web Index

Ihr gesamter Up/Downloadtransfer wird 24 Stunden aufgezeichnet und in grafischer Form dargestellt. Das ist das ultimative Tool um Bandbreitenschwankungen ihres Providers festzustellen.

Sie können die Grafik abspeichern, später wieder öffnen sowie auszudrucken.

Analyse:

Mit diesem Tool können sie sich genaue Information an der gewählten Position des Graphen anzeigen lassen
Markieren sie einen Bereich in den sie hineinzoomen möchten
Wiederherstellen des Originalzooms

Zeit:

Im Menü "Zeitraum" können sie die Zeit einstellen die sie in die Vergangenheit zurückgehen wollen.

Darstellung:

Die Y-Achse also die Transferrate wird aus den Einstellungen von Onlineeye übernommen, wollen sie das die Darstellung automatisch gewählt wird, dann wählen sie "Automatisch Skalieren" und zeichnen sie den Graphen neu.

Der Mittelwert wird als Linie dargestellt, die Mittelungszeit kann frei gewählt werden, jedoch ist ein Neuzeichnen nötig um den geänderten Mittelwert darzustellen.


Kindersicherung (Onlineeye sperren und das Beenden von Onlineeye verhindern ) Web Index

Falls sie ihre Kinder oder sonstige Benutzer ihres Rechners daran hindern wollen an den Einstellungen von Onlineeye zu drehen oder es gar zu beenden sollten sie folgende Funktionen aktivieren.

Kennwortschutz:

Sie können das verändern von Einstellungen mittels Passwortabfrage verhindern, sobald sie den Passwortschutz aktiviert haben und eine Passwort vergeben, wird beim Versuch Onlineeye zu öffnen eine Passwortabfrage durchgeführt.
Wollen sie ein bestehends Password durch eine neues ersetzen müssen sie auf "Übernehmen" drücken, damit wird das neue Passwort sofort aktiviert.

TrayIcon anzeigen:

Das kleine Icon in der rechten unteren Ecke ihres Desktops zeigt die aktuelle Transferrate ihrer Verbindung an, sollten sie das nicht wollen, deaktivieren sie diese Funktionalität. Es könnte ja sein das sie das aus Prinzip nicht möchten oder "Spuren" vor ihren Kindern verwischen wollen.

Beenden verhindern:

Sollte jemand versuchen Onlineeye zu stoppen ist es falls sie den Kennwortschutz aktiviert haben nur noch mittels des Taskmangers möglich. Das läßt sich für alle Windows-Varianten mit NT-Kernel verhindern, also WinNT,2000,XP und neuere.

Shortcut:

Falls sie das Tray-Icon dekativieren ist es nicht mehr möglich die Einstellungen von OnlineEye zu verändern, daher können sie mittels dieser Tastenkombination zu den Einstellungen von Onlineeye gelangen.


Interner Dialer und 0190 Schutz Web Index

OnlineEye bietet auch einen sehr komfortablen Dialer der alle in Windows konfigurierten RAS-Verbindungen anzeigt und den Rechner mit der gewählten Verbindung verbindet.

Wählen:

Ist eine Verbindung ausgewählt kann man mittels Wählen eine Verbindung aufbauen, der jeweilige Status des Verbindungsaufbaus wird im Logfenster angezeigt.

Abbrechen:

Wurde der Verbindungsaufbau mittels "Wählen" gestartet kann er mittels "Abbrechen" abgebrochen werden.

Auflegen:

Wurde erfolgreich eine Verbindung aufgebaut, das erkennt man am Status = Connected kann die Verbindung mittels "Auflegen" beendet werden

Einstellungen:

Zeigt die Einstellungen der gewählten Verbindunge, dient nur zur Anzeige !

Zusätzlicher Vorteil des Onlineeye Dialers:

Der OE Dialer hat aber noch ein zusätzliches Feature das sie nur schwerlich wieder missen werden. Ich nehme mal an es geht ihnen wie uns, sie wählen sich ins Internet ein und starten dann ihre Programme die sie für das Internet benötigen, das wird wohl der Email Client, ihr Browser und möglichweise noch das eine oder andere Programm sein. Und genau hier erleichtert ihnen OE dieses tägliche Spiel, sie können Programme definieren die sie nach erfolgreicher Verbindung automatisch starten möchten.

Zu diesem Zweck ziehen sie einfach die Programme vom Desktop oder dem Explorer in das Listenfeld.


Internet Protokolle Web Index

ARP
Das "Address Resolution Protocol" weist die IP-Adresse einer physikalischen Adresse eines Netzwerk-Interfaces zu.

Der Ursprungsrechner schickt ein ARP Broadcoast an alle Rechner, die physikalisch am selben Netzwerk angeschlossen sind um nach Daten zu suchen. Die Antwort des Broadcoast's enthält die Paarung zwischen physikalischer Adresse und IP-Adresse. Die Antwort muss nicht unbedingt vom lokalen Rechner kommen, sondern kann auch von einem anderen kommen, auf dem sie gespeichert ist.

Sobald die ARP-Antwort den Ursprungsrechner erreicht, beginnt der mit dem Datentransfer - wobei er die IP Pakete nur an das Netzwerk-Interface des Rechners schickt, dessen physische Adresse er erfragt hat. Die anderen Rechner reagieren darauf nicht, also wird keine unnötige Rechenzeit verbraucht. Das ist der Grund, wegen dem das ARP eingeführt wurde.

FTP
FTP steht für File-Transfer-Protocol (Port 21). FTP ist die Standardmethode zur Datenübertragung zwischen zwei entfernten Systemen. Ausgeführt wird das in der Client-/Server-Umgebung und funktioniert so:

Der anfragende Rechner startet einen FTP-Client und stellt eine Anfrage, die an den Host eines anderen Netzwerkes übertragen wird. Damit eine Verbindung zu diesem Host auch funktioniert, muss auf diesem auch ein FTP-Server bzw. ein FTP-Daemon laufen. FTPD ist ein Standard-FTP-Server-Daemon der normalerweise in den meisten Unix-Versionen integriert ist. Dieser Daemon hat die einfache Aufgabe auf Verbindungsanfragen zu reagieren. Wenn diese Verbindung steht, verlangt der FTP-Server den Benutzername, und ein Passwort. Ist ein Benutzer über FTP eingeloggt, kann er Dateien downloaden und/oder auch uploaden, das hängt natürlich ganz von den Sicherheitsmaßnahmen des Servers ab.

Die Aufgaben von FTP sind laut RFC 0765:

das gemeinnützige Verbreiten von Dateien (Programme und/oder Daten),
die indirekte oder implizite (durch Programme) Benutzung entfernter Rechner zu fördern,
dem Benutzer die Mühseligkeit der strukturellen Unterschiede der Dateisysteme zwischen verschiedenen Systemen zu ersparen und
Daten zuverlässig und effektiv zu übertragen.
Obwohl FTP auch direkt auf einem Terminal benutzt werden kann ist es hauptsächlich für die Benutzung über Programme entwickelt.

Gopher
Der Gopher-Dienst arbeitet eigentlich größtenteils im Textmodus und eignet sich für Textdokumente, Sound und andere Medien. Daher ist er im Vergleich zu HTTP (Hypertext Transfer Protocol), welches über einen Browser läuft, viel schneller.

Zu der Benutzung von Gopher startet der Benutzer wie üblich einen Gopher-Client (Gopher-Clients sind heute eigentlich für jedes Betriebssystem verfügbar) und kontaktiert einen Gopher-Server. Danach überträgt der Gopher-Server ein Auswahlmenü, das vorgegebene Ziele oder Dateiverzeichnisse und Suchmasken enthalten kann. Der Gopher-Server antwortet nur mit Informationen, welche der Client angefordert hat, und sonst nichts weiter, bis der Benutzer ein Objekt anfordert.

In einem FYI (For Your Interest) der Universität von Minnesota vom März 1993 wird Gopher so beschrieben:

"Das Internet Gopher Protocol ist hauptsächlich als ein hierarchisches Informationssystem entwickelt. Während Dokumente (und Dienste) auf vielen Servern liegen, präsentiert die Gopher-Client-Software dem Benutzer eine Hierarchie von Dokumenten und Verzeichnissen, ähnlich einem Dateisystem. Tatsächlich wurde das Gopher-Interface so entwickelt, das es einem Dateisystem ähnelt, da ein Dateisystem für das Ablegen von Dateien und Diensten hervorragend geeignet ist."

HTTP
HTTP (Hypertext Transfer Protocol) macht das Internet erst für alle Leute zugänglich. Es funktioniert in mancher Hinsicht eigentlich so wie Gopher, also auf einem Frage/Antwort-Schema. HTTP bietet auch den Vorteil (wie Gopher) das es nur dann Systemressourcen verbraucht, wenn es aktiv ist, also nur dann wenn man eine Anfrage stellt und/oder eine Antwort darauf bekommt. Telnet dagegen verlangt das der Benutzer eingeloggt bleibt und somit Systemressourcen verbraucht.

Über HTTP kann man jegliche Formen von Multimedia anfordern, welche entweder eingebettet sind oder über HTML-basierte Webseiten übermittelt werden können. Dies macht HTTP zu einem sehr effektiven Protokoll, welches extrem einfach ist.

HTTP ist in RFC 1945 so erklärt:

"Ein einfaches und schnelles Protokoll der Anwendungsschicht für hierarchische, kollaborative Hypermedia-Informationssysteme. Es ist ein auswählbares, statusloses, objktorientiertes Protokoll, das für viele Aufgaben wie Name-Server und verteilte Objekt-Management-Systeme durch die Erweiterung seiner Anfragemethoden (Befehle) eingesetzt werden kann. Ein Merkmal von HTTP ist die Wahl der Datendarstellung, was einen Aufbau von Systemen unabhängig von den übertragenen Daten ermöglicht."

Die HTTP-Befehle:
DELETE
Clientseitiger Befehl zum Löschen von Ressourcen auf einem Webserver.
GET
Clientseitiger Befehl zur Anforderung von Ressourcen von einem Webserver.
HEAD
Entspricht dem GET-Befehl mit der Ausnahme, dass der Server bei seiner Antwort die angegebene Ressource nicht mit übertragen muss. Dieser Befehl wird oft benutzt, um z.B. vorhandene Hyperlinks nur zu testen.
OPTIONS
Clientseitiger Befehl zur Übergabe von Informationen über die Kommunikation zwischen Client und Server.
POST
Der POST-Befehl wird benutzt, um Formulardaten direkt an ein serverseitiges Programm zu schicken (im Gegensatz zum GET-Befehl, der Formulardaten serverseitig zunächst in eine Variable speichert, die von einem CGI-Programm ausgelesen werden muss).
PUT
Dieser Befehl positioniert eine beigelegte Ressource an den angegebenen Ort innerhalb des Webservers.
TRACE
Dieser Befehl fungiert als Echo-Befehl, d.h. der Server sendet dem Client bei diesem Befehl genau das zurück, was er von ihm erhalten hat.

ICMP
Das "Internet Control Message Protocol" ist wichtig für die Diagnose von Netzwerkproblemen. Es sammelt z.B. Informationen darüber, ob ein Host heruntergefahren ist, ob ein Gateway betriebsunfähig oder ausgelastet ist oder ob ein anderer Fehler innerhalb des Netzwerks aufgetreten ist.

Ein Beispiel für die Verwendung von ICMP:
Wenn man einen Rechner anpingt um z.B. sicherzustellen, dass er momentan am Netz hängt, dann sendet man IP Pakete über ICMP und waret auf das Echo. Wenn kein Echo am Ursprungsrechner vom Zielrechner zu vermerken ist, wird der Host als "nicht erreichbar" klassifiziert. Wenn es ein Echo gibt, dann sieht man die Zeit, die es gedauert hat bis das Echo eintraf.

IP
Das "Internet Protocol" ist für die Datenübertragung jedes Protokolls der TCP/IP Protokollfamilie verantwortlich. Ein IP Datagramm besteht aus mehreren Teilen. Der erste Teil, der Header besteht u.a. aus der jeweiligen IP-Adresse des Absenders und Empfängers. Der Rest enthält die zu versendenden Daten.

Etwas Besonderes am Internet Protokoll ist, das Datagramme während des Übertragens fragmentiert und wieder zusammengesetzt werden. Auch wenn sie nicht in derselben Reihenfolge ankommen.

Ein IP Datagramm enthält noch weitere Infos wie z.B. die Identität des benutzten Protokolls, eine Header-Prüfsumme und eine Time-to-Live Spezifikation. Diese Spezifikation ist nichts anderes als eine Zahl. Während das Datagramm sich durch das Netz bewegt, wird die Zahl andauernd verkleinert. Wenn die Zahl gleich 0 ist, dann wird das Datagramm verworfen. Viele Paket Typen haben Time-to-Live Einschränkungen.

NNTP
Jeder kennt Usenet, oder hat schon ein Mal davon gehört. NNTP (Network News Transfer Protocol) ermöglicht den Zugang zu diesem Nachrichtendienst und benutzt üblicherweise den TCP-Port 119. Es ist eigentlich so ziemlich gleich wie SMTP (Simple Mail Transfer Protocol) indem es TCP als Netzwerkprotokoll benutzt und einfache Befehle von einem Prompt akzeptiert.

Der Zweck ist in RFC 977 so beschrieben:

"NNTP spezifiziert ein Protokoll für die Verteilung, die Recherche, die Wiedergewinnung und die Veröffentlichung von Nachrichtenartikeln durch eine zuverlässige Datenstrom-basierte Übertragung von Nachrichten innerhalb der ARPA-Internet-Gemeinde. NNETP ist so aufgebaut, dass Nachrichtenartikel in einer zentralen Datenbank gespeichert werden. Dem Abonnent wird ermöglicht, nur auf die Artikel zuzugreifen, die er lesen möchte. Indexierung, Querverweise und das Löschen von veralteten Artikeln sind ebenfalls vorgesehen."

POP3
Das "Post Office Protocol 3" dient zum Download von E-Mails vom Server. Die folgenden Befehle führt ein E-Mail-Programm, etwa Microsoft Outlook, selbständig aus. In manchen Fällen ist es aber sinnvoller diese Befehle manuell einzugeben.

Stelle eine Verbindung mit dem POP3-Server her. Falls kein besseres Programm zur Verfügung steht, kann auch mit Microsoft Telnet gearbeitet werden. Das POP3-Protokoll läuft auf dem Port 110. Alle Rückmeldungen des Servers beginnen entweder mit "+OK" oder mit "-ERR". "+OK" steht für einen erfolgreichen Befehl, "-ERR" für einen fehlgeschlagenen Befehl.

Die POP3-Befehle:
(Hier ist die Reihenfolge der Befehle einzuhalten!)

user [benutzername]
Legt bei der Anmeldung den angegebenen Benutzer fest.
("user" muss vor "pass" angegeben werden.)
pass [passwort]
Sendet das eingegebene Passwort an den Server.
stat
Zeigt die Anzahl der verfügbaren Nachrichten an. Dahinter folgt die Gesamtgröße der Nachrichten in Bytes.
list [n]
Zeigt die Nummer der Nachricht [n] und die Länge der Nachricht in Bytes an. Wird [n] nicht angegeben, werden alle Nachrichten mit der dazugehörigen Länge angezeigt.
top [n] [z]
Zeigt die ersten [z] Zeichen der Nachricht [n] an. Wenn [z] gleich 1 ist, dann werden nur die Headerzeilen angezeigt.
dele [n]
Löscht die Nachricht mit der Nummer [n].
retr [n]
Ruft die Nachricht [n] ab.
quit
Beendet die Verbindung zum POP3-Server.

SMTP
Das Simple Mail Transport Protocol dient zum Versenden von E-Mail Nachrichten an einen Mailserver. Wie auch beim POP3 Protokoll kann man diese Befehle mit Telnet eingeben. Das SMTP Protokoll läuft auf dem Port 25.

Die SMTP-Befehle:
(Hier ist die Reihenfolge der Befehle einzuhalten!)

helo [computername] oder ehlo [computername]
Meldet den Computer [computername] am Mailserver an.
mail from:[name@absender.com]
Gibt die E-Mail Adresse des Absenders an.
rcpt to:[name@empfänger.com]
Gibt die E-Mail Adresse des Empfängers an.
data
Gibt an, dass jetzt der Nachrichtentext folgt. Hier werden auch die eigentlichen Headerzeilen angeführt. Diese werden durch eine Leerzeile vom Nachrichtentext getrennt.
.
Ein einzelner Punkt in einer Zeile beendet die Eingabe und versendet die Nachricht.
quit
Beendet die Verbindung zum SMTP-Server.

Meldungscodes
Der Mailserver gibt am Beginn jeder Meldung eine Nummer aus, die angibt, um welche Meldung es sich handelt. Die folgende Liste ist nicht vollständig.

Code Beschreibung
220 Normale Meldung, kein Fehler.
221 Bestätigung des Befehls quit (die Verbindung wurde geschlossen).
250 Bestätigung für einen gültigen Befehl.
354 Fordert zum Eingeben der Nachricht auf.
Diese Meldung wird nach dem Befehl data übermittelt.
Nach dem Code folgt der Text
"Enter mail, end with "." on a line by itself".

Telnet
Telnet bietet dem Benutzer nicht nur die Möglichkeit sich in einem entfernten Host einzuloggen, sondern auch noch Befehle auf ihm auszuführen. So kann jemand auf einem weit entfernten Rechner Programme aufrufen oder ausführen, als ob er selbst vor diesem sitzen würde.

Telnet ist im Wesentlichen eine Textbasierte Applikation, welche sehr beliebt durch ihre vielen Funktionen wie z.B. auch das Abrufen von E-Mails geworden ist. Noch dazu belegt Telnet kaum Systemressourcen.

Telnet ist in RFC 854 beschrieben:

"Zweck des Telnet-Protokolls ist es, eine eher generelle, in beide Richtungen gerichtete, 8-bit Byte-Orientierte Kommunikationsmöglichkeit zur Verfügung stellen. Das Hauptziel ist das realisieren einer Standard-Methode, um Endgeräte oder Endgerät-basierende Prozesse miteinander zu verbinden."

Obwohl FTP auch direkt auf einem Terminal benutzt werden kann ist es hauptsächlich für die Benutzung über Programme entwickelt.


Windows Password + **** Passwort Spion Web Index

Windowsuser + Passwort:

Bei Win2000/NT ist es möglich den aktuellen User plus dessen Passwort anzeigen zu lassen.

Password Spion:

Es ist bestimmt jedem schon passiert das er eines seiner vielen Passwörter vergessen hat, das kann mitunter recht schlimme Folgen haben.
Mit dem Passwort-Spy machen sie Passwörter die hinter ********* versteckt sind wieder sichtbar. Dazu starteb sie das Programm indem sie den Password-Spy Button drücken, danach bewegen sie das Zielsucher Symbol mit der Maus über das betreffende Anzeige oder Eingabefeld.


Netzwerk + Internet Ping Web Index

Automatisches Ping:

Normalerweise verhindert das kontinuierliche Pingen eines Hosts oder des eigenen Providers, das man nach einer bestimmten Zeit ohne Internetaktivität automatisch vom Provider getrennt wird.

Zu diesem Zweck kann man nun einen zyklischen Ping an einen Host ihrer Wahl mit einem bestimmten Interval aktivieren.

Ping Test:

Sendet ein Ping-Signal an den angegebenen Host mit dem gewählten Timeout in Millisekunden.

Ping-Einführung

ping. heute machen wir mal unser erstes netzwerkkomando.
vorher haber einige netzwerkgrundlagen:

unix spricht viele netzwerkprotokolle. wie inzwischen fast ueberall ist
aber das im internet verwendete TCP/IP am beliebtesten und am
verbreitetsten.

die kommuniktaion zwischen den computern laueft in ueber kleine
datenpackete die von einem computer zum anderen verschickt werden.
typischerweise sind diese kleinen packete einige 100 bis 1500 bytes lang.
groessere datenstroeme werden aus mehreren packten zusammengesetzt.

jedes der IP packte hat:

* eine empfaengeraddresse (anhand dieser findet das packet im netz sein
ziel)

* eine absenderaddresse (anhand dieser weiss der empfaenger wem er eine
antwort auf das packet schicken soll)

die beiden addressen sind im normalen internetz 4 bytes (32 bit) lang
und werden per convention in 4 durch 3 punkte getrennten dezimalzahlen
geschrieben. z.b.:

198.182.196.56

* die laenge des packets

* einige zusaetzliche technische informationen...

in diese IP packete hinein werden dann datenpackte gepackt. und zwar
folgende meist folgende arten:

* TCP (transmission control protocol) packete: fuer verbindungen die sich
nicht fuer die packte interessieren sonder nur einen kontinuierlichen
datenstrom benoetigen. (z.b. eine ssh oder telnet verbidnung) (TCP
packete sind z.b. durchnummeriert und das betriebsystem (in unserem
fall unix) kuemmert sich darum dass fals ein packet verlorgen geht dass
es neu gesendet wird, etc..etc.. der benutzer von TCP muss sich also
nicht um die schmutzigen details des netzwerks kuemmern...)

* UDP (user datagram protocol) packte: wo noch jedes packet einzeln
gesendet und epfangen werden kann. wer UDP packete benutzt muss damit
rechnen dass seine packete eventuell auf dem weg vom sender zum
empfaenger verlorgen gehen oder nicht in der selben reihenfolge ankommen
wie sie gesendet wurden etc.. dafuer hat man aber einen etwas
direkteren zugang zum netz.

* ICMP (internet control message protocol). diese packte dienen dem netz
selbst als information. es gibt z.b. ICMP packete die stau auf der
datenautobahn melden.. fuer dich praktisch nuetzlich ist das ICMP echo
packet dass den empfaenger auffordert mit einem ICMP reply packet zu
antworten. das macht der ping befehl:

kapitaen: "geben sie mir ein ping!"

der name "ping" kommt aus dem sonar jargon. ein kurzer ultrashall impuls
der ausgesendet wurde um andere uboote zu orten.. (die diesen ton
reflectirten..)

ping schickt ein kurzes netzwerkpacket zu einem anderen computer im
internet und der sollte das wieder retour schicken. und dann kann man die
zeit messen wielange es gebraucht hat (oder ob es ueberhaupt retour
gekommen ist). ueblicherweise schaut man damit ob sein eigenes netzwerk
funktioniert und ob man andere computer erreichen kann.

insofern ist der ping befehl vorallem dann nuetzlich wenn mal was mit dem
netzwerk nicht funktioniert und man rausfinden will was.

z.b.:

ping 194.152.178.12

ausgabe:

PING bozo.sil.at (194.152.178.12): 56 data bytes
64 bytes from 194.152.178.12: icmp_seq=0 ttl=59 time=11.9 ms
64 bytes from 194.152.178.12: icmp_seq=1 ttl=59 time=4.5 ms
64 bytes from 194.152.178.12: icmp_seq=2 ttl=59 time=4.5 ms
64 bytes from 194.152.178.12: icmp_seq=3 ttl=59 time=4.5 ms

--- bozo.sil.at ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 4.5/6.3/11.9 ms

die ausgesendenten packte sind durchnummeriert da sieht man gleich ob
welche verlorgen gehen. die zeit gibt an wieviele millisekunden das packte
vom ausssenden bis zum epmfangen gebraucht hat. (im obigen fall
durchschnittlich 6.3 ms. auf grossen entfernungen oder langsamen strecken
koennen schon mal einige 100ms oder 1000 ms zusammenkommen (1000 ms = 1
sekunde)

aus dem ttl wert (time to life) kann man sehen wieviel computer (router)
zwischen uns sind. dabei haengt es ab mit welchem startwert der
gegencomputer die packete wegschickt meist. 256, 128 oder 64 in obigen
beispiel eher 64 d.h. es waeren 5 computer zwischen meinem derzeitigen
standort und dem www.sil.at (diese zwischenstationen werden auch "hops"
(singular: hop) genannt.)

falls du hinter einer firewall sitzt geht das ping ebentuell nicht weil
deien firewall keine pings durchlaesst.

anstatt einer IP addresse in form der 4 mit 3 punkten getrennten zahlen
kannst du auch einen namen verwenden. z.b.:

ping www.sil.at

waere das selbe. wenn du mal irgendwo bist wo zwar nummern pingen aber
namen nicht dann funktinioert die namensaufloesung (DNS) nicht. da sollte
man dann z.b. ins /etc/resolv.conf schaun ob nicht ein falscher
"nameserver" eingetragen ist. ueber die umsetzung von namen wie www.sil.at
in nummer wie 194.152.178.12 und umgekehrt lernen wir spaeter noch
genauer...

nuetzliche optionen beim ping befehl:

-c 20 wuerde genau nur 20 packete verschicken und sich dann beenden ohne
dass man es mit control-c abbrechen muss.

-l 1000 wuerde packte mit einer laenge von 1000 bytes schicken (das darf
normalerweise nur der root user)

-f flood ping. schickt soviele ping packete wie moeglich. darf
normaler weise auch nur der root user. VORSICHT: -f sollte man nur
verwenden wenn man genau weiss was man tut. man kann sich sonst
BETRAECHTLICHEN AERGER mit den netzwerkbetreuern heinheimsen..

EXERCISES:

verwende den ping befehl um die entfernung (gemessen in hops und in
zeitlicher verzoegerung (millisecunden)) zu messen. welche numerische IP
addressen haben diese websites?


Onlineeye kaufen Web Index

Vorteile der Registrierung

Alle Funktionen, Vollversion der Software
Gratis: Updates für alle V1.x Versionen
Gratis: technischer Support

Onlineeye Pro | Preis | Online - PayPal | Online - ShareIt
1 User Lizenz | 15.95 Euro | Jetzt kaufen | Jetzt kaufen
Familien Lizenz | 29.95 Euro | Jetzt kaufen | Jetzt kaufen
Firmenlizenz | 69.95 Euro | Jetzt kaufen | Jetzt kaufen
Konzernlizenz | 500.0 Euro | Jetzt kaufen | Jetzt kaufen

Familien Lizenz:

Erlaubt die Installation von Onlineeye auf allen Rechnern in einem Haushalt

Firmen Lizenz

Mehrere Computer einer Firma an einem Standort

Konzern Lizenz

Alle Rechner einer Firma an allen Standorten

Welche Zahlungsoptionen gibt es bei ShareIt ?

Kreditkarte
Überweisung
Scheck
Barzahlung
Zur geschützten und sicheren Übermittlung aller von Ihnen eingegebenen Daten verwenden wir die SSL (Secure Sockets Layer)-Verschlüsselungstechnik. Bedingung dafür ist eine Beglaubigung durch eine Zertifizierungsinstanz, in unserem Fall erfolgte die Bestätigung durch VeriSign.

Kreditkarte

Wir akzeptieren Kreditkarten von Visa, MasterCard/Eurocard, American Express, JCB und Diners Club.
Bei der Bezahlung mit Kreditkarte wird Ihre Bestellung sofort weiterverarbeitet. Die physische Auslieferung wird von uns im Normalfall direkt veranlasst, elektronisch auszuliefernde Produkte stehen i.d.R. sofort oder spätestens innerhalb von 48 Stunden nach der Bestellung zur Verfügung.
Überweisung
Um Gebühren für Auslandsüberweisungen zu vermeiden, bieten wir Ihnen die Möglichkeit, auf ein Konto in Deutschland, Frankreich, Großbritannien oder Finnland zu überweisen.
Die Bankverbindungsdaten werden Ihnen nach Verarbeitung Ihrer Bestellung per E-Mail mitgeteilt.
Die Produktlieferung erfolgt nach Zahlungseingang.

Online-Überweisung

Online-Überweisungen sind nur möglich bei Bestellungen innerhalb Deutschlands in der Abrechnungswährung Euro.
Voraussetzung: Ihr Bankkonto ist für Online-Banking freigeschaltet und Sie verfügen über gültige Autorisierungs- und Authentifizierungsdaten (z.B. PIN/ TAN).
Die Überweisung wird mittels eines Java-Applets auf Ihrem Rechner durchgeführt. Dabei werden alle Daten ausschließlich zwischen dem Kontoinhaber und dem kontoführenden Institut verschlüsselt ausgetauscht.
Bei der Online-Überweisung wird die Produktlieferung i.d.R. sofort veranlasst, bei der herkömmlichen Überweisung erst nach Zahlungseingang.

Scheck

Wir akzeptieren alle Schecks, auch Barschecks und Cashier's Checks. Beachten Sie bitte, dass zur Überprüfung auf Deckung des Schecks bis zu 10 Werktage vergehen können.
Zahlungsanweisungen von US-Banken werden ebenfalls akzeptiert, wenn Sie von einer US-Bank ausgestellt worden sind. Schicken Sie diese Zahlungsanweisungen bitte an folgende Adresse:
ShareIt! Inc.
PO Box 844
Greensburg, PA 15601-0844
USA

Detaillierte Informationen erhalten Sie nach der Verarbeitung Ihrer Bestellung per E-Mail.
Die Produktlieferung erfolgt nach Zahlungseingang.

Barzahlung

Sie können uns natürlich auch Bargeld per Post zukommen lassen. Die Postadresse wird Ihnen nach der Verarbeitung Ihrer Bestellung per E-Mail mitgeteilt.
Die Produktlieferung erfolgt nach Zahlungseingang

Barzahlung per Post für Österreicher (Email Adresse nicht vergessen)
Legen sie 15 Euro in einen Brief und schicken sie ihn an:

pmaSoft
Reichendorf 140
8212 Pischelsdorf
Österreich

Banküberweisung für Österreicher
Schicken sie bitte ein Mail an uns um die Bankinformationen zu erhalten.

Fallen trotz Währungsunion noch Spesen bei einer Banküberweisung an?
Ab 1.7.2003 gilt eine EU-Verordnung die besagt, dass Überweisungen im EURO-Raum nicht mehr kosten dürfen als im Inland.


Rechner Fernsteuerung ( WakeOnLan, Remote Control ) Web Index

Angenommen Sie haben ein kleines Netzwerk und verwenden einen Rechner zum Verbindungsaufbau
zum Internet und die anderen Rechner verwenden diese Verbindung für ihren Internetzugang. Soweit
so gut, aber was machen sie wenn diese Rechner ebenfalls den Durchsatz anzeigen möchten.
Ganz einfach sie installieren Onlineeye auf dem Rechner der den Verbindungsaufbau macht und
konfigurieren Onlineeye als Server, auf allen Rechnern die diese Verbindung verwenden installieren
sie ebenfalls Onlineeye und konfigurieren diese als Clients.

Befehl an den Server senden:

Sind sie mit einem Server verbunden können sie diesen in verschiedener Weise herunterfahren.

1) Logoff
Meldet den zurzeit angemeldeten User vom System ab

1.2 Reboot
Starten den Rechner neu, bootet neu.

1.3 Shutdown
Den Rechner abschalten.
Bei n NT/2000/XP erscheint die Standardmeldung 'It is safe to shutdown your computer'.
Bei n Win9x/Me wird der Rechner abgeschaltet, sollte es die Hardware erlauben.

1.4 Poweroff
Diese Aktion schaltet den Rechner komplett aus. Ihre Hardware muß das aber unterstützen,
z.B sollte eine ATX Motherboard und Netzteil funktionieren, aber ein altes AT Motherboard
wird es möglicherweise nicht unterstützen. Auch müssen sie h ACPI oder APM in ihrem Bios
aktiviert haben, und nicht zu vergessen das die Power Optionen in Windows richtig konfiguriert
sind. Wenn ein "normaler" Windows Shutdown funktioniert das wird es auch mit Onlineeye
klappen .

Windows NT - Microsoft Checkliste für Poweroff

To enable poweroff in Windows NT, you will need a hal.dll that is capable of shutting down
your workstation. You can try one that's supplied with service pack 4 (or higher): hal.dll.softex
Just extract the service pack (with the /x option),

There are several machine-specific HAL.DLL's, and you MUST extract the matching HAL*.DLL.SOFTEX
from the service pack. To avoid problems when someone overwrites the good HAL.DLL with a bad
one it's better to rename HAL*.DLL.SOFTEX to %SystemRoot%\System32\HALPOWER.DLL for instance,
copy the line in %SystemDrive%\BOOT.INI which loads the current system, alter the description
and append " /HAL=HALPOWER.DLL". Now one can choose between the two HALs and has a fallback if
the new one fails.

If you like NT to automatically poweroff at shutdown, set the following registry key to 1:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\PowerdownAfterShutdown

1.5 Standby
Wenn es ihr Rechner unterstützt wird hiermit bei ihrem Rechner der Standby Modus aktiviert.
Sollten sie Fehlermeldungen erhalten unterstützt möglicherweise eines ihrer Geräte im Rechner
den Standby-Modus nicht, NT unterstützt Standby nicht.

1.6 Hibernate
Wenn es ihr Rechner unterstützt wird hiermit bei ihrem Rechner der Standby Modus aktiviert.
Sollten sie Fehlermeldungen erhalten unterstützt möglicherweise eines ihrer Geräte im Rechner
den Standby-Modus nicht. Sie müssen auch "Hibernate" in der Windows Systemsteuerung
aktivieren( Win200 oder neuer). Hibernate wird von Win95 und WinNT nicht unterstützt.

1.7 Windows sperren
Diese Aktion sperrt ihre Windows Workstation, jedoch nur bei Win2000 oder neuer.

WakeOn Lan:

Diese Aktion erlaubt es einen Remote Rechner zu starten. Dieser Rechner muß Wake-On-LAN
unterstützen, das heißt das sie eine Netzwerkkarte haben die mit einem extra Kabel an die
Spannungsversorgung ihres Motherboards angeschlossen ist. Im Bios muß WakeOn-Lan
auch aktiviert sein.

Wie funktioniert das:
Die Netzwerkkarte überwacht laufend den Netzwerkverkehr auf der Suche nach dem "Magic Packet"
wenn der Rechner ausgeschaltet ist. Das "Magic Packet" ist eine Bytefolge mit einem Header
(6*0xFF) und 16x der MAC-Adresse der Netzwerkkarte. Wenn also ihre MAC-Adresse folgender-
massen aussehen würde 01:02:03:04:05:06 (6 bytes), dann schaut des Packet so aus:
FFFFFFFFFFFF010203040506010203040506010203040506010203040506010203040506010
2030405060102030405060102030405060102030405060102030405060102030405060102
03040506010203040506010203040506010203040506010203040506

Die Netzwerkkarte erkennt dieses Packet und schaltet die Spannungsversorgung ihres Rechners ein.

Doch zuerst müssen sie den Remote-Rechner spezifizieren, und das geht wie folgt:

Sie müssen die IP-Adresse, Subnet-Maske und MAC-Adresse des Zielrechner eingeben.
Die IP-Adresse und Subnetmaske sind notwendig um die Broadcast-Adresse zu errechnen.
Das Magic Packet wird nur an das richtige Subnet gesendet. Die MAC-Adresse ist eine
weltweit eindeutige Adresse ihrer Netzwerkkarte. Sie können auf "Suchen" drücken um
nach der MAC-Adresse des Zielrechners zu suchen nachdem sie IP+Subnet eingegeben
haben. Es wird ein Ping an den Zielrechner gesendet und dann in der ARP Tabelle nach
der MAC-Adresse gesucht, sollte das nicht funktionieren müssen sie zum Zielrechner
gehen und die MAC-Adresse ausfindig machen. Die MAC-Adresse eine 12-stellige Nummer
aus Hex-Zahlen die möglicherweise so dargestellt werden 12-12-23-45-67-12, beim
Eintragen in Onlineeye müssen sie die Beistriche weglassen.


Client / Server ( Transferraten eines anderem Rechners anzeigen ! ) Web Index

Angenommen Sie haben ein kleines Netzwerk und verwenden einen Rechner zum Verbindungsaufbau zum Internet und die anderen Rechner verwenden diese Verbindung für ihren Internetzugang. Soweit so gut, aber was machen sie wenn diese Rechner ebenfalls den Durchsatz anzeigen möchten.
Ganz einfach sie installieren Onlineeye auf dem Rechner der den Verbindungsaufbau macht und konfigurieren Onlineeye als Server, auf allen Rechnern die diese Verbindung verwenden installieren sie ebenfalls Onlineeye und konfigurieren diese als Clients.

Client oder Server ?:

Falls sie Onlineeye als Server betreiben sendet er an alle verbundenen Clients die aktuelle Up/Downloadrate mit der Samplingrate die sie beim Server eingestellt haben. Wählen sie Onlineeye als Client wird das gewählte lokale Interface nicht mehr überwacht, sondern auf Daten des Servers gewartet, auch wenn noch keine Verbindung zu einem Server besteht.

Serverdienst:

Sie haben nur ein Verbindungs-Port zu wählen und den Server mittels "Server aktivieren" zu starten, das ist schon alles. Wollen sie den Serverbetrieb wieder stoppen deaktivieren sie das "Server aktivieren" Kästchen.
Wollen sie OnlineEye immer als Server betreiben selektieren sie "Beim Start autom. aktiviern" damit wird beim Starten von Onlineeye der Server automatisch gestartet. Ein Server kann max. 10 Clients betreuen, es können sich also bis zu 10 Clients mit einem Server verbinden.

Clientdienst:

Haben sie auf einem Netzwerkrechner ihres Subnetzes einen OnlineEye-Server laufen können sich sich mit diesem Server verbinden nachdem sie den Server spezifizieren, indem sie dessen IP-Adresse und Port-Adresse ausfüllen.
Danach drücken sie auf denn "Verbinden" Button und die Verbindung wird hergestellt. Auch hier haben sie die Möglichkeit das sich Onlineeye beim Programmstart automatisch mit einem Server verbindet, sollte der Server zu diesem Zeitpunkt nicht aktiviert sein wird kein weiterer Verbindungsversuch gestartet. Sie müßten sich dann händisch verbinden.


Netzwerk Freigaben ( Wer verwendet ihre Netzwerkfreigaben? Kollegen oder Internet ?) Web Index

Wenn sie ihn ihrem Firmennetzwerk schon immer mal wissen wollten wer unbefugt auf ihrem Rechner zugreift oder persönliche Daten liest oder anschaut dann sollten sie ihre Netzwerkfreigaben regelmässig überprüfen.

Mit diesem Tool können sie sich anzeigen lassen wer auf ihrem Rechner angemeldet ist und welche Netzwerkfreigeben er gerade verwendet. Fast allen Usern ist gar nicht klar das in den Windows Betriebssystemen Standardfreigaben definiert sind auf die der Administrator oder sonstige Kollegen mit entsprechendem Fachwissen zugreifen können.

Des weiteren können sie bei entsprechenden Rechten diese Informationen auch auf einem Netzwerkrechner anzeigen lassen.


Rechner automatisch ausschalten ( Onlinezeit beschränken ) Web Index

Angenommen sie haben Kinder die nicht länger als 1std täglich im Internet surfen dürfen, danach soll der Rechner ausgeschaltet werden, und weil durch ein Bios Passwort oder Window Login geschütz können ihre Sprößlinge sich nicht erneut einwählen.

Aktionen für den Fall das die Zeit abgelaufen ist:

1) Logoff
Meldet den zurzeit angemeldeten User vom System ab

1.2 Reboot
Starten den Rechner neu, bootet neu.

1.3 Shutdown
Den Rechner abschalten.
Bei n NT/2000/XP erscheint die Standardmeldung 'It is safe to shutdown your computer'.
Bei n Win9x/Me wird der Rechner abgeschaltet, sollte es die Hardware erlauben.

1.4 Poweroff
Diese Aktion schaltet den Rechner komplett aus. Ihre Hardware muß das aber unterstützen,
z.B sollte eine ATX Motherboard und Netzteil funktionieren, aber ein altes AT Motherboard
wird es möglicherweise nicht unterstützen. Auch müssen sie h ACPI oder APM in ihrem Bios
aktiviert haben, und nicht zu vergessen das die Power Optionen in Windows richtig konfiguriert
sind. Wenn ein "normaler" Windows Shutdown funktioniert das wird es auch mit Onlineeye
klappen .

Windows NT - Microsoft Checkliste für Poweroff

To enable poweroff in Windows NT, you will need a hal.dll that is capable of shutting down
your workstation. You can try one that's supplied with service pack 4 (or higher): hal.dll.softex
Just extract the service pack (with the /x option),

There are several machine-specific HAL.DLL's, and you MUST extract the matching HAL*.DLL.SOFTEX
from the service pack. To avoid problems when someone overwrites the good HAL.DLL with a bad
one it's better to rename HAL*.DLL.SOFTEX to %SystemRoot%\System32\HALPOWER.DLL for instance,
copy the line in %SystemDrive%\BOOT.INI which loads the current system, alter the description
and append " /HAL=HALPOWER.DLL". Now one can choose between the two HALs and has a fallback if
the new one fails.

If you like NT to automatically poweroff at shutdown, set the following registry key to 1:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\PowerdownAfterShutdown

1.5 Standby
Wenn es ihr Rechner unterstützt wird hiermit bei ihrem Rechner der Standby Modus aktiviert.
Sollten sie Fehlermeldungen erhalten unterstützt möglicherweise eines ihrer Geräte im Rechner
den Standby-Modus nicht, NT unterstützt Standby nicht.

1.6 Hibernate
Wenn es ihr Rechner unterstützt wird hiermit bei ihrem Rechner der Standby Modus aktiviert.
Sollten sie Fehlermeldungen erhalten unterstützt möglicherweise eines ihrer Geräte im Rechner
den Standby-Modus nicht. Sie müssen auch "Hibernate" in der Windows Systemsteuerung
aktivieren( Win200 oder neuer). Hibernate wird von Win95 und WinNT nicht unterstützt.

1.7 Windows sperren
Diese Aktion sperrt ihre Windows Workstation, jedoch nur bei Win2000 oder neuer.


Verbindungs-Überwachung ( Auf schlechte Transferrate reagieren ) Web Index

Angenommen sie haben eine schlechte Internetverbindung, ihre Transferrate entspricht nicht ihren Erwartungen, sie bricht immer wieder ein oder wird von ihrem Provider getrennt, dann sind sie auf dieser Seite goldrichtig.

Automatische Wahlwiederholung:

Wird ihre Verbindung getrennt, wählt sich Onlineeye automatisch wieder für sie ein.

Verbindung automatisch trennen:

Soll aus einem bestimmten Grund nach einer bestimmten Zeit ihre Verbindung getrennt werden
erledigt das OnlineEye für sie.

Reaktion auf eine schlechte Verbindung:

Bricht ihre Downloadrate immer wieder ein, oder sind sie mit ihrer Uploadrate wieder mal nicht einverstanden und ein erneuter Verbindungsaufbau behebt ihre Probleme dann sollte sie diese Option wählen.

Eine Konfiguration wie beim Bild aud dieser Seite würde also für den Upload folgendermassen aussehen. Wenn 1min lang die mittlere Downloadrate kleiner 1kb beträgt wird die Verbindung unterbrochen. Es müßte nur noch das Aktiv-Kästchen aktiviert werden!

Mögliche Aktionen sind:
- Redail .............. Verbindung trennen und sofort neu öffnen
- Hangup ............ Verbindung trennen
- Shutdown ......... Rechner ausschalten
- Reboot ............ Rechner neu starten
- Standby ........... Rechner in den Standbymodus schalten ( Infos hier )


Netzwerk-Statistik ( Welche IP Adresse hat mein Rechner? Up/Download Statistik) Web Index

Hier können sie ihre Netzwerkadresse sehen sollten sie eine eingebaut haben, die 2-te Adresse ist dann ihre vom Provider zugewiesene Internet IP-Adresse. Ist keine Netzwerkkarte vorhanden und sie sind Online entspricht die 1-te Adresse ihrer Internet IP-Adresse. Des weiteren wird ihnen ihr Computername angezeigt.

Statistik:

Es stehen 2 Zähler zur Verfügung die Onlineeye für sie verwaltet bzw. von ihrem Windowssystem bezieht. Die gesamten gesendeten/empfangenen Daten beziehen sich auf die Daten die von ihrem gewählten Adapter während sie Windows gestartet haben transferiert wurden. Der 2-te Zähler wird bei jeder neuen Verbindung auf NULL gesetzt und zeigt somit die Daten die während der aktuellen Onlineverbindung übertragen wurden.
Sollten sie die Client/Server Funktion verwenden werden entsprechend die Daten des Servers angezeigt.

Profiwerkzeuge:

Die Dialoge mit den TCP/UDP Informationen geben ihnen den genauen Überblick über alle relevanten Informationen ihrer TCP/IP Verbindungen, eine genaue Beschreibung aller angezeigten Werte würde den Rahmen dieser Hilfedatei sprengen.

Internetprotokolle

* TCP (transmission control protocol) packete: fuer verbindungen die sich
nicht fuer die packte interessieren sonder nur einen kontinuierlichen
datenstrom benoetigen. (z.b. eine ssh oder telnet verbidnung) (TCP
packete sind z.b. durchnummeriert und das betriebsystem (in unserem
fall unix) kuemmert sich darum dass fals ein packet verlorgen geht dass
es neu gesendet wird, etc..etc.. der benutzer von TCP muss sich also
nicht um die schmutzigen details des netzwerks kuemmern...)

* UDP (user datagram protocol) packte: wo noch jedes packet einzeln
gesendet und epfangen werden kann. wer UDP packete benutzt muss damit
rechnen dass seine packete eventuell auf dem weg vom sender zum
empfaenger verlorgen gehen oder nicht in der selben reihenfolge ankommen
wie sie gesendet wurden etc.. dafuer hat man aber einen etwas
direkteren zugang zum netz.

* ICMP (internet control message protocol). diese packte dienen dem netz
selbst als information. es gibt z.b. ICMP packete die stau auf der
datenautobahn melden.. fuer dich praktisch nuetzlich ist das ICMP echo
packet dass den empfaenger auffordert mit einem ICMP reply packet zu
antworten. das macht der ping befehl:


Stopuhr ( Netzwerkdurchsatz messen ) Web Index

OnlineEye bietet auch eine sehr komfortable Stopuhr mit der sie die Bandbreite ihrer Netzwerk- oder Internetverbindung messn können.


°

Netzwerk-Verbindungen ( Zeigt Programme mit Internetverbindung, Spyware?) Web Index

Wissen sie welche Programme die auf ihrem Rechner laufen gerade eine offene Internetverbindung haben, ob sie mal schnell nach Hause telefonieren oder einfach nur private Daten übertragen. Es ist schon sehr interessant welche Programme gerade eine Internetverbindung aufgebaut haben ohne das wir es ahnen würden.

Im Prinzip ist jedes Programm das auf ihrem Rechner läuft ein potenzieller Schnüffler und Datenspion, denn wird es erstmal ausgeführt und der User hat die benötigten Rechte auf einem System, bei Win9x ja standardmäßig alle, kann das Programm eigentlich alles nur denkbare auf ihrem Rechner machen.

Onlineeye kann die Verbindung zwar nicht verhindern, hierfür benötigen sie eine Firewall die ich hiermit drigend empfehlen würde, aber kann ihnen trotzdem sehr behilflich sein indem es die offenen Verbindungen sowie den Zielrechner anzeigt. Mit der Zieladresse und Mithilfe von Whois können sie den Besitzer und somit möglicherweise auch den Übeltäter feststellen und belangen.
Aber eines können sie in jedem Fall, sie können das betreffende Programm schliessen und sich beim Hersteller nach seinen Beweggründen erkundigen oder in Zukunft auf dessen Produkte verzichten.

- Alle TCP/UDP Verbindungen anzeigen .... Es werden nicht nur die gerade bestehenden Verbindungen
angezeigt sondern auch alle nichtaktiven, jene Ports auf denen gerade gelauscht wird.
- Zeige nur numerische IP-Adressen ........ Es wird keine Namensauflösung durchgeführt

Profiwerkzeuge:

Die Dialoge mit den TCP/UDP Informationen geben ihnen den genauen Überblick über alle relevanten Informationen ihrer TCP/IP Verbindungen, eine genaue Beschreibung aller angezeigten Werte würde den Rahmen dieser Hilfedatei sprengen.

Internetprotokolle

* TCP (transmission control protocol) packete: fuer verbindungen die sich
nicht fuer die packte interessieren sonder nur einen kontinuierlichen
datenstrom benoetigen. (z.b. eine ssh oder telnet verbidnung) (TCP
packete sind z.b. durchnummeriert und das betriebsystem (in unserem
fall unix) kuemmert sich darum dass fals ein packet verlorgen geht dass
es neu gesendet wird, etc..etc.. der benutzer von TCP muss sich also
nicht um die schmutzigen details des netzwerks kuemmern...)

* UDP (user datagram protocol) packte: wo noch jedes packet einzeln
gesendet und epfangen werden kann. wer UDP packete benutzt muss damit
rechnen dass seine packete eventuell auf dem weg vom sender zum
empfaenger verlorgen gehen oder nicht in der selben reihenfolge ankommen
wie sie gesendet wurden etc.. dafuer hat man aber einen etwas
direkteren zugang zum netz.

* ICMP (internet control message protocol). diese packte dienen dem netz
selbst als information. es gibt z.b. ICMP packete die stau auf der
datenautobahn melden.. fuer dich praktisch nuetzlich ist das ICMP echo
packet dass den empfaenger auffordert mit einem ICMP reply packet zu
antworten. das macht der ping befehl:


Erste Schritte (Tutorials)
Internet Protokolle
Grafik
Port Scanner
Netzwerkfreigaben
Passwörter
Kindersicherung
Ping, Stay Online
Trace
Whois
Modem
Stopuhr
Verbindungsstatistik
Transfervolumen
Historische Grafik
Traffic Monitor
Überwachung
Warnhinweise
Rechner Abschalten
Client/Server
Einstellungen
Feedback
Registrierung


Trace ( Der Weg zu einem bestimmten Host und dessen Geschwindigkeit) Web Index

Mit TRACE kann man den Weg zum Server herausfinden. Wenn Sie jedoch die genaue Zeit festellen wollen, die ein Datenpaket zum Zielpunkt benötigt müßen Sie PING benutzen. Als Beispiel dient wieder die Verbindung zu unserem Server. Nun werden z.B drei Datenpakete zum Server gesendet, wobei max. 30 Server zwischen uns und dem Ziel liegen dürfen und max. 3000ms auf die Antwort eines Servers gewartet wird.

Je kleiner der Wert, desto besser ist die Verbindung.

Hier ein Überblick wie "Pingzeiten" zu bewerten sind.
0-100ms ......... Sehr gut, sollte zum Provider immer der Fall sein
100-500ms ..... Normal Surfen ist gut möglich
500-1000ms ... Befriedigend. Etwas träge Datenübertragung
ab 1000ms ..... Schlecht. Teilweise bei Auslandsverbindungen


Traffic Watch - Netzwerk/Internetmonitor Web Index

Traffic-Monitor - überwacht den Netzwerkverkehr des gewählten Adapters und zeigt den Traffic kontinuierlich an.
Er kann dafür verwendet werden um verdächtigen Netzwerkverkehr aufzuspüren oder die Beanspruchung des gewählten Adapters festzustellen.

Überwachung starten:

a) Als erstes wählen sie den Adapter den sie überwachen wollen
b) Danach drücken sie auf den GO Button um die Überwachung zu starten
c) Mit dem X Button wir die Überwachung wieder deaktiviert

Einstellungen:

a) Sie haben die Möglichkeit die Anzeige des Netzwerkverkehrs nach TCP/UDP/ICMP zu filtern indem
sie den jeweiligen Button aktivieren

b) Zusätzlich lassen sie auch die Netzwerkadressen auflösen und soweit bekannt auch noch die Ports mit den entsprechenden Bezeichnungen anzeigen.

c) In den Einstellungen läßt sich zusätzlich auch die Zeit einstellen die eine nicht mehr aktive Verbindung in der Liste der Verbindungen angezeigt wird, bevor sie aus der Liste gelöscht wird.

Hinweise:

- Es kann einige Zeit dauern bis die Traffic Information angezeigt wird nachdem sie die Überwachung gestartet haben wenn sie die Auflösung der Netzwerkadressen aktiviert haben.
- Wenn sie es während der Überwachung aktivieren werden nur die neuen Verbindungen aufgelöst.
- Wenn die Überwachung aktiviert haben kann die Netzwerkperformance ihres Computers etwas verringert werden wenn zu viel Netzwerkverkehr zu verarbeiten ist.


Transfervolumina und Onlinezeit Web Index

Sobald Daten auf dem von ihen gewählten Adapter übertragen werden, wird das Transfervolumen aufgezeichnet.
Wobei der Abrechnungszeitraum für das aktuelle Monats insofern konfiguriert werden kann, als das man den ersten Tag des Abrechnungszeitraum festlegen kann, die Änderung wird bei einem Neustart automatisch aktiviert, will man eine unmittelbare Änderung muß man den Update Button drücken.

Historische Datenvolumen:

Zusätzlich zu dem Gesamtvolumen eines Monats und des Tagesvolumens können sie jederzeit auch die historischen Daten aller Tage analysieren an denen Onlineeye gestartet wurde. So läßt sich das eigene Datenvolumen sehr gut analysieren.

Wenn sie mit der rechten Maustaste auf einen Eintrag drücken erhalten sie ein Menü und können diesen Eintrag löschen oder nach Excel exportieren. Wobei darauf zu achten ist wenn sie einen Monatsordner auswählen das ganze Monat gelöscht wird, das gleiche gilt für den Jahresordner !


Onlineeye nach erstmaligem Start konfigurieren ! Web Index

Erstmaliger Start:

Bild (Kleines Fenster + Tray-Icon)

Nach dem erstmaligen Start von OE sieht man nur ein kleines Fenster sowie ein schwarzes Tray-Icon, wobei beide die aktuelle Up/Downloadrate grafisch darstellen. In der Standardeinstellung bedeutet der obere Graph (rot) den Download und der untere Graph (Blau) den Upload. Das kleine Fenster lässt sich frei verschieben und in der Größe ändern, ein Mausklick auf das Tray-Icon lässt das Fenster schwinden, ein erneuter Klick bringt es wieder zum Vorschein.
Ein Klick mit der rechten Maustaste zeigt sowohl beim Grafikfenster als auch beim Tray-Icon das Hauptmenü von OE, von hier aus lassen sich alle wichtigen Funktionen mit einem Klick auswählen.

Standardeinstellungen ändern:

Bild (Einstellungen)

Um die Datenaufzeichnung sinnvoll nutzen zu können ist es natürlich notwendig das OE immer gestartet ist, um das zu gewährleisten ist die Autostart Option aktiviert.

Verbindung wählen die sie überwachen möchten:

Das ist die entscheidende Einstellung wenn es darum geht welche Verbindung sie eigentlich überwachen wollen, wählen sie hier ob sie das Modem oder einen Netzwerkadapter für z.B DSL Zugang überwachen wollen. In der Standardeinstellung werden alle Verbindungen von und zu ihrem Rechner überwacht

Onlinezeit und Warnungen anzeigen lassen:

Bei zeitlich begrenzten Internetzugängen ist es für viele Anwender sehr sinnvoll immer zu wissen wie lange sie schon online sind. OE bietet hierfür mehrere Möglichkeiten. Zuallererst muss OE natürlich wissen ob sie Online sind, das festzustellen ist aber leider alles andere als einfach da Windows hierfür keine Mittel zur Verfügung stellt, da müssen wir also selbst Hand anlegen. Gehen sie bitte wie folgt vor:
- aktivieren sie die Option „Onlinezeit in jedem Fenster anzeigen“
- sollten sie gerade Online sein und im Fenstertitel wird keine Zeit angezeigt dann probieren sie bitte die nacheinander die Checkmodi 1-5 aus.
Sollte nun der richtige Checkmodi gefunden sein können sie sich die Onlinezeit in dem gerade aktiven Fenster anzeigen lassen, sowie nach bestimmten Zeitintervallen Meldungen anzeigen lassen, dazu mehr im Abschnitt „Warnhinweise“

Anzeige der grafischen Transferrate (Bit, Byte, Farben und Max Up/Downloadrate)

Je nachdem welchen Internetzugang sie haben oder welches Netzwerk sie überwachen können sie die Maximalen Transferraten getrennt in Up/Download frei einstellen. Diese Einstellungen wirkt sich sowohl auf das kleine Grafikfenster, Tray-Icon und auch die Anzeige des historischen Datentransfers aus. Mehr dazu im Abschnitt „Grafik“.


Transfervolumen überwachen, kontrollieren und aufzeichnen Web Index

Onlineeye optimiert die Internet Performance ihres PC's. Ihre Up/Download Geschwindigkeit und Zeit wird in Echtzeit gemessen und für spätere Analyse aufgezeichnet. Die so aufgezeichneten Daten der letzten 24 Stunden erlauben es ihnen die Internetaktivität auch dann zu kontrollieren wenn sie nicht gerade am Rechner sitzen.

Monatliches Transfervolumen:

Details sind hier zu finden „Transfervolumen“.

Historische Datentransfergrafik der letzten 24 Stunden:

Zusätzlich zum Aufsummieren der gesendeten und empfangenen Daten bietet OE die wirklich geniale Möglichkeit den grafischen Verlauf der letzten 24 Stunden darzustellen, somit verpasst man keine Bandbreiteneinbrüche seines Providers und kann sehr genau die Bandbreite im Tagesverlauf beobachten. Dadurch ist man erstmals wirklich in der Lage den Provider mittels einer Grafik auf Probleme hinzuweisen, um so auch entsprechende Leistung für die Providergebühren einzufordern.

Details sind hier zu finden „Historische Grafik“.


Spyware finden und entfernen Web Index

Wissen sie welche Programme die auf ihrem Rechner laufen gerade eine offene Internetverbindung haben, ob sie mal schnell nach Hause telefonieren oder einfach nur private Daten übertragen. Es ist schon sehr interessant welche Programme gerade eine Internetverbindung aufgebaut haben ohne das wir es ahnen würden.

Im Prinzip ist jedes Programm das auf ihrem Rechner läuft ein potenzieller Schnüffler und Datenspion, denn wird es erstmal ausgeführt und der User hat die benötigten Rechte auf einem System, bei Win9x ja standardmäßig alle, kann das Programm eigentlich alles nur denkbare auf ihrem Rechner machen.

OE kann die Verbindung zwar nicht verhindern, hierfür benötigen sie eine Firewall die ich hiermit dringend empfehlen würde, aber kann ihnen trotzdem sehr behilflich sein indem es die offenen Verbindungen sowie den Zielrechner anzeigt. Mit der Zieladresse und Mithilfe von „Whois“ können sie den Besitzer und somit möglicherweise auch den Übeltäter feststellen und belangen.
Aber eines können sie in jedem Fall, sie können das betreffende Programm schließen und sich beim Hersteller nach seinen Beweggründen erkundigen oder in Zukunft auf dessen Produkte verzichten.

1.Schritt: Verdächtige Programme aufspüren

„Sicherheitsdialog öffnen“

Zumeist fallen kompromittierte Systeme zuerst durch verstärkte Netzwerk-, Festplatten- oder CPU-Aktivitäten auf. Beachten Sie, dass jede Systemveränderung potentiell Spuren des Angreifers überschreibt, daher lassen wir uns nun mit „Zeige aktive Programme“ alle Programme und Windows Services die gerade eine Netzwerk-Internetverbindung aufgebaut haben anzeigen, wobei die einzelnen Spalten folgende Bedeutung haben:

Type | Ist entweder TCP oder UDP, genaueres finden sie hier „Protokolle“
PID | Prozess Identifikation, wenn sie den Windows - Taskmanager öffnen können sie nähere Informationen zu dem entsprechenden Prozess = Anwendung finden.
Port | Ist das lokale Port auf das der Prozess zugreift, welche Bedeutung ein bestimmtes Port hat können sie hier nachlesen: http://www.neohapsis.com/neolabs/neo-ports/neo-ports.html
Process | Ist jene Anwendung oder Systemdienst der die Verbindung aufgebaut hat.

Nun kann man die verdächtigen Prozesse mit dem Taskmanager killen und wenn nötig von der Festplatte löschen, bzw. deren Einträge in der Registry löschen.

Verdächtige Eintragungen in der Registry

Viele trojanische Pferde werden über Registrierungsschlüssel beim Systemstart bzw. der Anmeldung eines Benutzers ausgeführt. Die typischen Registry-Schlüssel werden von diesem Freewaretool von Sysinternals untersucht und entsprechende Einträge angezeigt, sie können das Programm hier herunterladen: http://www.sysinternals.com/files/autoruns.zip

2. Schritt: Wohin werden meine Daten übertragen

Nachdem wir wissen welche Programme nun befugt oder unbefugt eine Internetverbindung aufgebaut haben, wäre es doch auch gut zu wissen wohin sie sich verbinden und ob Daten übertragen werden.

Mit „Zeige offene Ports“ sehen wir welche Verbindungen ins Internet bestehen, welches Port auf unserem Rechner geöffnet wurde uns wo sich das Ziel befindet. Mit den Standardeinstellungen werden nur die geraden aktiven „Established“ Verbindungen angezeigt.

+ Alle TCP/UDP Verbindungen anzeigen : Es werden nicht nur die gerade bestehenden Verbindungen angezeigt sondern auch alle nichtaktiven, jene Ports auf denen gerade gelauscht wird.
+ Zeige nur numerische IP-Adressen : Es wird keine Namensauflösung durchgeführt

Bild (Ports)

Type | Ist entweder TCP oder UDP, genaueres finden sie hier „Protokolle“
Status | + Established ... Die Verbindung besteht gerade + Listening ....... Die Anwendung wartet auf ein Ereignis, Wartestellung + Closed ........... Verbindung wurde beendet
Local | Die Quelladresse auf dem eigenen Rechner
Local Port | Das Quellport auf dem eigenen Rechner
Remote | Die Zieladresse dieser Verbindung ( kann auch der eigene Rechner sein)
Remote Port | Das Zielport dieser Verbindung

Mit der Zieladresse und dem Zielport kann man den Übeltäter noch nicht wirklich identifizieren, doch hierfür bietet OE noch 2 weitere nützliche Tools, nämlich Trace und Whois.

Trace: Mit Trace lässt sich der Weg vom eigenen Rechner bis zum Zielrechner der Verbindung darstellen, somit können sie feststellen wo sich der Übeltäter befindet. Näheres finden sie unter „Trace“

Whois: Sollte sich herausstellen das es sich um eine gültige Adresse handelt können sie den Inhaber dieser Adresse feststellen, zu diesem Zweck notieren sie die Adresse und geben sie diese im „Whois“ Fenster ein und drücken den „Whois“ Knopf.

3. Schritt: Werden Daten übertragen, und wenn ja, wohin werden sie übertragen ?

Mithilfe des Netzwerkmonitors können sie alle Verbindungen ihrer Netzwerkkarte überwachen, und somit auch alle Verbindungen die über DSL oder Standleitung ins Internet führen.
Das ist ein mächtiges Tool um festzustellen welche Verbindungen bestehen und ob Daten übertragen werden. Weiter Informationen finden sie hier „Traffic Monitor“


Onlineeye als Dialer und 0190 Warner ! Web Index

Da sie Onlineeye auch als Dialer verwenden können bietet sich ein 0190 Warner geradezu an. Sollte sich ein 0190 Dialer in ihrem Rechner eingenistet haben, bedeutet es ja nichts anderes als das er die Telefonnummer ihres Internetzugangs ändert.

Sie sollten also ab jetzt nur noch den Dialer von Onlineeye verwenden, da dieser vor jedem Wählvorgang überprüft ob die zu wählende Nummer eine 0190 Nummer ist, sollte das der Fall sein, erhalten sie einen Hinweis und der Wählvorgang wird sofort abgebrochen.

Wählen:

Das Einwählen ist extrem einfach, wie sie am Screenshot gleich unterhalb sehen können

Anzeige beim Wählen:

Sollte es keine Probleme geben erhalten sie folgende Meldung, die ihnen den aktuellen Provider und dessen Telefonnummer anzeigt.
Schon hier können sie Probleme festellen, sollte hier eines Tages etwas anderes angezeigt werden.

Sollte eine 0190 Nummer gewählt werden erhalten sie folgende Warnung:

Zusätzliche Vorteile des Onlineeye Dialers:

Der OE Dialer hat aber noch ein zusätzliches Feature das sie nur schwerlich wieder missen werden. Ich nehme mal an es geht ihnen wie uns, sie wählen sich ins Internet ein und starten dann ihre Programme die sie für das Internet benötigen, das wird wohl der Email Client, ihr Browser und möglichweise noch das eine oder andere Programm sein. Und genau hier erleichtert ihnen OE dieses tägliche Spiel, sie können Programme definieren die sie nach erfolgreicher Verbindung automatisch starten möchten.

Zu diesem Zweck ziehen sie einfach die Programme vom Desktop oder dem Explorer in das Listenfeld.


Onlineeye zur Überwachung von Rechnern im Netzwerk! Web Index

Sie können Onlineeye mittels SNMP verwenden um Rechner und deren aktuelles Transfervolumen zu überwachen. Doch vielerorts ist es
auch notwendig das zusätzlich das historische Transfervolumen z.B eines Servers zu überwachen. So kann Onlineeye dazu verwendet
werden zusätzlich zum lokalen Traffic auch den Traffic eines anderen Rechners anzuzeigen.

Eine mögliche Konfiguration könnte so aussehen wie in der Abbildung dargestellt .

Onlineeye als Server:

Onlineeye muß auf allen Rechner installiert werden, auf den Server-Rechnern muß Onlineeye als Server konfiguriert werden.

Wie sie in der Abbildung sehen aktivieren sie zum einen das Onlineeye der Server ist, und zum anderen das Feld
"Server aktivieren". Wollen sie das Onlineeye auf diesem Rechner immer mit diesen Einstellungen gestartet wird
aktivieren sie zusätzlich das entsprechende Feld.

Wurde der Server ordnungsgemäß gestartet sehen sie das im darunterliegenden Ausgabefeld.

Onlineeye als Client:

Um sich nun mit einem Server zu verbinden brauchen sie nur noch die IP-Adresse und den gewählten Server Port einzustellen,
danach drücken sie noch auf Verbinden.

Wollen sie sich mit einem anderen Server verbinden, drücken sie Trennen, danach ändern sie die IP-Adresse und drücken wieder
Verbinden.

Onlineeye als Client, Ansicht der historischen und aktuellen Daten des Onlineeye-Server Rechners:

Mittels der Remotefunktionen können sie den Serverrechner sogar fernsteuern, nähere Informationen finden sie hier!


Router und Server direkt mit Hilfe von SNMP überwachen Web Index

Der SNMP-Standard:

Das SNMP (Simple Network Management Protocol) ist ein Standard für die Netzwerkverwaltung, der hauptsächlich in TCP/IP-Netzwerken und in letzter Zeit auch in IPX-Netzwerken (Internet Packet Exchange) eingesetzt wird.

Unter Verwendung von SNMP können Netzwerkhosts, z. B. Arbeitsstationen oder Server, Router, Brücken und Hubs, von einem zentralen Computer aus verwaltet werden, auf dem ein Netzwerkverwaltungsprogramm ausgeführt wird. SNMP führt Verwaltungsdienste aus und verwendet dazu eine verteilte Architektur von Verwaltungssystemen und Agents.

Router überwachen:

Um den Datentransfer eines Routers oder sonstigen Netzwerkgeräts mit Onlineeye zu überwachen muß das Gerät das SNMP Protokol unterstützen und dasselbige auf dem Gerät aktiviert sein. Bitte prüfen sie die Dokumentation und Einstellungen ihres Routers.

Sollte ihr Router, wie die meisten modernen Router, SNMP unterstützen ist die Konfiguration ein Kinderspiel.

1) Aktiviern sie unter "Einstellungen" den Schaltknopf Router
2) Öffnen sie das Router-Konfigurationsfenster indem sie auf Einstellungen drücken
3) Geben sie die IP-Adresse ihres Routers ein
4) Drücken sie Verbinden
5) Wählen sie die zu überwachende Schnittstelle ihres Routers aus

Es ist jedoch zu beachten das nur eine Schnittstelle zur selben Zeit überwacht werden kann, und bei der Überwachnung bei bestimmten Geräten die Samplerate auf mehr als 10 Sekunden erhöht werden muß um richtige Ergbnisse zu erhalten.

Windows Rechner/Server überwachen:

Um z.B einen Windows Rechner mittels Onlineeye zu überwachen muß der SNMP Dienst gestartet sein, sollte das nicht der Fall sein, dann installieren sie SNMP bitte wie folgt.

So installieren Sie den SNMP-Dienst

1) Öffnen Sie den Assistenten für Windows-Komponenten.
2) Klicken Sie unter Komponenten auf Verwaltungs- und Überwachungsprogramme, ohne jedoch das zugehörige Kontrollkästchen zu aktivieren oder zu deaktivieren, und klicken Sie anschließend auf Details.
3) Aktivieren Sie das Kontrollkästchen SNMP (Simple Network Management Protocol), und klicken Sie dann auf OK.
4) Klicken Sie auf Weiter.

Anmerkungen

  • Klicken Sie zum Öffnen des Assistenten für Windows-Komponenten auf Start, zeigen Sie auf Einstellungen, und klicken Sie auf Systemsteuerung. Doppelklicken Sie dann auf Software, und klicken Sie auf Windows-Komponenten hinzufügen/entfernen.
  • Einige Windows-Komponenten müssen konfiguriert werden, bevor Sie sie verwenden können. Wenn Sie eine oder mehrere dieser Komponenten installiert, jedoch noch nicht konfiguriert haben und auf Windows-Komponenten hinzufügen/entfernen klicken, wird eine Liste der zu konfigurierenden Komponenten angezeigt. Klicken Sie zum Starten des Assistenten für Windows-Komponenten auf Komponenten.
  • Sie müssen als Administrator oder Mitglied der Gruppe "Administratoren" angemeldet sein, um diese Schritte ausführen zu können. Wenn der Computer mit einem Netzwerk verbunden ist, verhindern möglicherweise auch die Richtlinieneinstellungen des Netzwerkes die Ausführung dieser Schritte.
  • Der SNMP-Dienst wird nach der Installation automatisch gestartet.
    Siehe auch

Windows Rechner überwachen:

Wählen sie wie bei der Router-Überwachnung die IP-Adresse des Rechners und klicken sie auf Verbinden, nachdem sie die Schnittstelle gewählt haben sollten sie die Sample-Rate auf minimal 10 Sekunden setzten. Sollte dieser Wert noch immer keine brauchbaren Ergebnisse liefern, erhöhen sie die Sample-Rate bitte Schritt für Schritt.

Probleme mit Win98/ME und WinNT:

Winnt 4.0:

1. Installieren von mgmtapi.dll and mib.bin sollten sie sich nicht bereits im \WINNT\system32\ Verzeichnis befinden.

Diese Files befinden sich auf der WinNT CD-ROM im i386 Verzeichnis

oder können von unserer Homepage geladen werden: http://www.pmasoft.net/download/nt4files.zip

2. Entpacken sie mgmtapi.dll und mib.bin aus nt4files.zip ins Onlineeye Installationsverzeichnis oder
nach \WINNT\system32\

Winnt 98 und Millenium:

1 . Installieren von mgmtapi.dll, mib.bin undwsnmp32.dll
- download w9xlibs.zip (39k) from

Diese Files finden sie auf unseres Homepage unter: http://www.pmasoft.net/download/w9xlibs.zip

2. Entpacken sie Files ins Onlineeye Installationsverzeichnis oder nach \windows\system


Warnhinweise ( Warnungen bei Zeit und Up/Downloadlimits) Web Index

Angenommen sie haben eine schlechte Internetverbindung, ihre Transferrate entspricht nicht ihren Erwartungen, sie bricht immer wieder ein oder wird von ihrem Provider getrennt, dann sind sie auf dieser Seite goldrichtig.

Automatische Wahlwiederholung:

Wird ihre Verbindung getrennt, wählt sich Onlineeye automatisch wieder für sie ein.

Verbindung automatisch trennen:

Soll aus einem bestimmten Grund nach einer bestimmten Zeit ihre Verbindung getrennt werden
erledigt das OnlineEye für sie.

Reaktion auf eine schlechte Verbindung:

Bricht ihre Downloadrate immer wieder ein, oder sind sie mit ihrer Uploadrate wieder mal nicht einverstanden und ein erneuter Verbindungsaufbau behebt ihre Probleme dann sollte sie diese Option wählen.

Eine Konfiguration wie beim Bild aud dieser Seite würde also für den Upload folgendermassen aussehen. Wenn 1min lang die mittlere Downloadrate kleiner 1kb beträgt wird die Verbindung unterbrochen. Es müßte nur noch das Aktiv-Kästchen aktiviert werden!

Mögliche Aktionen sind:
- Redail .............. Verbindung trennen und sofort neu öffnen
- Hangup ............ Verbindung trennen
- Shutdown ......... Rechner ausschalten
- Reboot ............ Rechner neu starten
- Standby ........... Rechner in den Standbymodus schalten ( Infos hier )


Whois ( Eigentümer einer Internetadresse feststellen ) Web Index

Mittels WhoIs können sie sehr einfach Personen- / Firmendaten zu einer IP oder Domainnamen anzeigen lassen. Der Eingebaute WhoIs Dienst funktioniert jedoch nur folgende Domains:

.biz whois.nic.biz
.com whois.internic.net
.coop whois.nic.coop
.info whois.nic.info
.name whois.nic.name
.net whois.internic.net
.org whois.internic.net
.gov whois.nic.gov
.edu whois.networksolutions.com
.mil rs.internic.net
.int whois.iana.org

.ac whois.nic.ac
.ae whois.uaenic.ae
.at whois.ripe.net
.au whois.aunic.net
.be whois.dns.be
.bg whois.ripe.net
.br whois.registro.br
.bz whois.belizenic.bz
.ca whois.cira.ca
.cc whois.nic.cc
.ch whois.nic.ch
.cl whois.nic.cl
.cn whois.cnnic.net.cn
.cz whois.nic.cz
.de whois.nic.de
.fr whois.nic.fr
.hu whois.nic.hu
.ie whois.domainregistry.ie
.il whois.isoc.org.il
.in whois.ncst.ernet.in
.ir whois.nic.ir
.is whois.isnic.is
.it whois.nic.it
.je whois.nic.je
.jp whois.nic.ad.jp
.li whois.nic.ch
.lu whois.dns.lu
.mc whois.ripe.net
.to whois.tonic.to
.tv whois.tv
.ru whois.ripn.net
.nl whois.domain-registry.nl

Sollten sie eine anderen Host suchen müssen sie auf die Homepage des jeweiligen
NIC des betreffenden Landes gehen, also Land auswählen und auch "Web Suche" klicken.
z.B www.download.de, Deutschland(de) wählen und auf suche klicken.