Welcome

DH Driver Cleaner Professional Edition -- Welcome
DH Driver Cleaner Professional Edition
--------------------------------------------------------------------------
Copyright 2002-2006 by Driverheaven, written by Ruud Ketelaars
All Rights Reserved
--------------------------------------------------------------------------
The author takes NO WARRANTY. This software is provided "AS IS", we take no
responsibility to any damage to hardware or software or to the loss of anything.
You may not reverse engineer or decompile the program. Last but not least you
are not allowed to Re-distribute this program or any part by any means
(E-mail, CD-ROM, Web-site, etc.) unless given written permission by Ruud Ketelaars.

The ATI logo and name are registered trademarks of ATI Technologies Inc.
The nVidia visual branding and name are registered trademarks of nVidia Corporation
The Creative logo and name are registered trademarks of Creative Technology Ltd.
All other logos and names are property of the rightful owners.

This program has no affiliation with any of the companies.
Copyright 2002-2006 by Driverheaven, written by Ruud Ketelaars
Distribution of this text or parts or images needs permission of the Author


Support

DH Driver Cleaner Professional Edition -- Support
If you use Driver Cleaner either for personal or business use and wish to support development so I can continue to improve this product, please donate some money. Every little bit helps in my long hours of developing this tool to further aid the community.

Please use PayPal and use as recipient's email info@drivercleaner.net

info@drivercleaner.net


Filters

DH Driver Cleaner Professional Edition -- Filters
Description | Cleaning Filter
3Dfx Drivers | 3Dfx
3Dlabs Wildcat 4 Drivers | 3Dlabs Wildcat 4
3Dlabs Wildcat REALIZM | 3Dlabs Wildcat REALIZM
3Dlabs Wildcat VP | 3Dlabs Wildcat VP
ATI Catalyst Driver + Control Panel | ATI
ATI Catalyst Control Center | ATI CCC
ATI IGP Motherboard / Chipset Driver | ATI IGP
ATI Multimedia Center | ATI MMC
ATI HydraVision | ATI HydraVision
ATI Remote Wonder | ATI Remote Wonder
ATI TV Wonder | ATI TV Wonder
ATI WDM Driver | ATI WDM
ATI Software Uninstall Utility | ATI Uninstall Utility
Creative Audio | Creative Audio
Creative Audio Driver | Creative Audio Lite
Intel Extreme Graphics | Intel Extreme
Intel Graphics Media Accelerator | Intel Extreme
kX Audio Driver | kX Audio
kX Aureal Driver | kX Aureal
Matrox Parhelia | Matrox Graphics
Matrox Millennium | Matrox Graphics
nForce Motherboard / Chipset Driver | nForce Chipset
nVidia Stereo Driver | nVidia Stereo
nVidia WDM Driver | nVidia WDM
nVidia Display Driver | nVidia
Razer Copperhead / Diamondback | Razer Mouse
Realtek Audio | Realtek Audio
S3 Savage IX/MX/3D/4 | S3 Savage
SIS Graphics Drivers | SIS Graphics
SoundMAX Audio | SoundMAX Audio
Turtle Beach Audio | Turtle Beach
VIA Envy Audio | VIA Envy Audio
VIA HD Audio | VIA HD Audio
VIA Vinyl Audio | VIA Vinyl Audio
XGI Volari | XGI Volari

Note: Do not use the ATI WDM or nVidia WDM cleaning files when you have an tv tuner card installed.

Note: To request cleaning filters look at the FAQ Can I request cleaning filters.


Readme

DH Driver Cleaner Professional Edition -- Readme
Driver Cleaner Professional Edition
Driver Cleaner Professional Edition

http://www.drivercleaner.net

=================================================================
Table Of Contents
=================================================================

Driver Cleaner Professional Edition
- Support Development
- Install Note
- Important Note
- Cleaning Filters
- Usage for Windows 2000 and Higher
- Usage for Windows 9X and ME

Cab Cleaner Professional Edition
- Description
- Usage for Windows 2000 and Higher

- System Requirements
- Reporting Problems, Bugs And Suggestions
- Copyright Notice

-----------------------------------------------------------------
Support Development
-----------------------------------------------------------------

If you use Driver Cleaner either for personal or business use and wish to support development so I can continue to improve this product, please donate some money.
Every little bit helps in my long hours of developing this tool to further aid the community.

Please use PayPal and use as recipient's email info@drivercleaner.net

For an easy link see the support section in the help file.

-----------------------------------------------------------------
Install Note
-----------------------------------------------------------------

It is recommended to uninstall all previous versions.

-----------------------------------------------------------------
Important Note
-----------------------------------------------------------------

Make sure step 1 is done, because Windows will go online and download the driver from the Microsoft site.

-----------------------------------------------------------------
Cleaning Filters
-----------------------------------------------------------------

Check the Filters page in the help file for a full list.

-----------------------------------------------------------------
Usage for Windows 2000 and Higher
-----------------------------------------------------------------

ATI:
1. Unplug nic card or modem from net or disconnect
2. Remove ATI driver from add/remove programs then remove the control panel from add/remove programs
3. Reboot into safe mode (F8 during boot up)
4. On reboot into safe mode WinXP SP1/SP2 will auto detect and install drivers. Just let it do its thing. If you can cancel out of the auto install hardware wizard then skip the rest and run Driver Cleaner! If you can NOT cancel out of auto detect wizard then...
5. Navigate to device manager->display adapter->uninstall and/or remove ATI display adapter but do not reboot
6. Disable any AntiVirus Software (If you don't disable is than it could give trouble)
7. Run Cab Cleaner (not needed, but recommended)
8. Run Driver Cleaner
9. Empty recycle bin and reboot
10. Install the new drivers and control panel

nVidia:
1. Unplug nic card or modem from net or disconnect
2. Remove nvidia from add/remove programs
3. Reboot into safe mode (F8 during boot up)
4. On reboot into safe mode WinXP SP1/SP2 will auto detect and install drivers. Just let it do its thing. If you can cancel out of the auto install hardware wizard then skip the rest and run Driver Cleaner! If you can NOT cancel out of auto detect wizard then...
5. Navigate to device manager->display adapters->highlight nVidia and click uninstall or remove but don't reboot
6. Disable any AntiVirus Software (If you don't disable is than it could give trouble)
7. Run Cab Cleaner (not needed, but recommended)
8. Run Driver Cleaner
9. Empty recycle bin and reboot
10. Install the new drivers

Other:
1. Unplug nic card or modem from net or disconnect
2. Remove driver from add/remove programs
3. Reboot into safe mode (F8 during boot up)
4. On reboot into safe mode WinXP SP1/SP2 will auto detect and install drivers. Just let it do its thing. If you can cancel out of the auto install hardware wizard then skip the rest and run Driver Cleaner! If you can NOT cancel out of auto detect wizard then...
5. Navigate to device manager->select the category->uninstall and/or remove but do not reboot
6. Disable any AntiVirus Software (If you don't disable is than it could give trouble)
7. Run Driver Cleaner
8. Empty recycle bin and reboot
9. Install the new driver

-----------------------------------------------------------------
Usage for Windows 9X and ME
-----------------------------------------------------------------

ATI:
1. Unplug nic card or modem from net or disconnect
2. Remove ATI driver from add/remove programs then remove the control panel from add/remove programs
3. Reboot into safe mode (F8 during boot up)
4. Disable any AntiVirus Software (If you don't disable is than it could give trouble)
5. Run Cab Cleaner (not needed, but recommended)
6. Run Driver Cleaner
7. Empty recycle bin and reboot
8. Install the new drivers and control panel

nVidia:
1. Unplug nic card or modem from net or disconnect
2. Remove nvidia from add/remove programs
3. Reboot into safe mode (F8 during boot up)
4. Disable any AntiVirus Software (If you don't disable is than it could give trouble)
5. Run Cab Cleaner (not needed, but recommended)
6. Run Driver Cleaner
7. Empty recycle bin and reboot
8. Install the new drivers

Other:
1. Unplug nic card or modem from net or disconnect
2. Remove driver from add/remove programs
3. Reboot into safe mode (F8 during boot up)
4. Disable any AntiVirus Software (If you don't disable is than it could give trouble)
5. Run Driver Cleaner
6. Empty recycle bin and reboot
7. Install the new driver
Cab Cleaner Professional Edition
-----------------------------------------------------------------
Description
-----------------------------------------------------------------
Windows could restore certain files from the driver cache folder out the driver.cab file or any other cab file from service packs. This could cause Windows overwriting new files with old files. This program will remove the nVidia and ATI drivers from the cab files.

It can take some time depending on your system and also because the cab files can be large in size. It is better to use it, because windows can't overwrite your new files with old ones. When you installed a new service pack you need to run it again.

-----------------------------------------------------------------
Usage for Windows 2000 and Higher
-----------------------------------------------------------------

1. Boot into safe mode (F8 during boot up) (This is not required)
2. Run Cab Cleaner it is in the tools menu from Driver Cleaner

If you are going to clean driver.cab make sure you have 400+ MB free.
-----------------------------------------------------------------
System Requirements
-----------------------------------------------------------------

Windows 98, Windows ME, WinNT 4.0
Windows 2000, Windows XP, Windows 2003, Longhorn

-----------------------------------------------------------------
Reporting Problems, Bugs And Suggestions
-----------------------------------------------------------------

Be sure to check the web site at http://www.drivercleaner.net for the newest version and other information.
Or send an email to info@drivercleaner.net with Driver Cleaner Pro and a small description in the subject.

-----------------------------------------------------------------
Copyright Notice
-----------------------------------------------------------------

The ATI logo and name are registered trademarks of ATI Technologies Inc.
The nVidia visual branding and name are registered trademarks of nVidia Corporation
The Creative logo and name are registered trademarks of Creative Technology Ltd.
All other logos and names are property of the rightful owners.

This program has no affiliation with any of the companies.

-----------------------------------------------------------------
Copyright (c) 2003-2006 Ruud Ketelaars
Copyright 2002-2006 by Driverheaven, written by Ruud Ketelaars


Description

DH Driver Cleaner Professional Edition -- Description
Driver Cleaner Professional Edition

1. Here you can select which cleaning file you want to use.
2. If you select this then there can be added more cleaning filters to 5 by selecting them in 1 and clicking on 4.
3. This is the button to remove one or more cleaning filters from 5.
4. This is the button to add the cleaning filter from 1 to 5.
5. Here you will see multiple cleaning filters if you added them.
6. With this button there will become more details visible on what files, directories and registry keys are deleted.

To use the cleaning filter profiles first check 2.
To save a profile: | first add the filters to 5. Then right mouse click on 5. In the menu press profile. In the new window that will open, enter a name and press save to save the profile.
To load a profile: | right mouse click on 5. In the menu press profile. In the new windows that will open select a profile and press load. The profile will be loaded and you can close the window.

In the settings menu you can turn options on and off. If you want to use the ability to restore deleted files and / or directories and / or registry keys, then turn the option on by Backup. By the cleaning options you can select if it should clean all or not. When you have show notify enabled, then when the backup folder or log folder reach the size you set you will get a popup notification.
Cab Cleaner Professional Edition

1. Here you can select what cab file should be cleaned.
2. Here you can see it is busy or finished.
3. Here you can see what it is doing.
4. Here you can see the duration.


Contact

DH Driver Cleaner Professional Edition -- Contact
If you find registry keys, files or directories that are not removed, then mail me the filenames and / or registry keys and / or directories.

For questions and suggestions mail me at info@drivercleaner.net

Put in the subject or the email Driver Cleaner Pro and a small description.

Please do not put this address in your address book, because it is then vulnerable for viruses.


FAQ

DH Driver Cleaner Professional Edition -- FAQ
Driver Cleaner Professional Edition
1. | How should I uninstall and install the drivers?
2. | How should I install Driver Cleaner Professional Edition?
3. | Does Driver Cleaner Professional Edition work with all Operating Systems?
4. | What about the operating system with a service pack installed?
5. | Does Driver Cleaner Professional Edition support registry cleaning?
6. | The directory ATI Technologies in the Program Files directory is still there?
7. | Does the Primary and Secondary ATI display adapter need to be removed / uninstalled?
8. | I have a motherboard with nForce/nForce2/nForce3/nForce4 chipset, will the nVidia filter remove those drivers?
9. | I get an INFSetup error after the ATI Display driver and control panel are uninstalled?
10. | After using a cleaning file I get an windows error that important system files are removed?
11. | Driver Cleaner stopped working or does not work!
12. | Which filter is for what?
13. | Can I request cleaning filters?
Cab Cleaner Professional Edition
14. | What is Cab Cleaner Professional Edition?
15. | Does Cab Cleaner Professional Edition work with all Operating Systems?
16. | Should Cab Cleaner Professional Edition be used on all Operating Systems?
17. | What cab files should be cleaned?
18. | After using Driver Cleaner Professional Edition and booting to windows there are driver files in the windows or system or system32 Folder?
Problem Reporting
19. | How to report problems!
Q: How should I uninstall and install the drivers?

A: Check the Readme
Q: How should I install Driver Cleaner Professional Edition?

A: If you have an older version installed than uninstall that and install the new version.
If you have no old versions installed you can just install the new version.
Q: Does Driver Cleaner Professional Edition work with all Operating Systems?

A: It works with Windows 95, 98, 98SE, ME, 2000, XP. It should also work with Windows 2003, Longhorn and Vista. It will work on 32bit and 64bit operating systems.
Q: What about the operating system with a service pack installed?

A: It will work on any service pack installed.
Q: Does Driver Cleaner Professional Edition support registry cleaning?

A: Yes, it will clean registry items that belong to the driver. It goes deeper than normal registry cleaners. It does this to make sure that the next driver install is clean and that there will be no conflicts with old settings.
Q: The directory ATI Technologies in the Program Files directory is still there?

A: Driver Cleaner does that, because if it would remove it then things like HydraVision would be removed also. You can just install new drivers.
Q: Does the Primary and Secondary ATI display adapter need to be removed / uninstalled?

A: Yes, you need to remove / uninstall the Primary and Secondary ATI display adapter.
Q: I have a motherboard with nForce/nForce2/nForce3/nForce4 chipset, will the nVidia filter remove those drivers?

A: No, it will not remove those drivers. It will only remove the nVidia display drivers.
Q: I get an INFSetup error after the ATI Display driver and control panel are uninstalled?

A: The problem is caused by windows. The Display adapter is set at Standaard Display Adapter (VGA). Set the display adapter at Standaard PCI Graphics Adapter (VGA). Now install the drivers and the problem should be solved.
Q: After using a cleaning file I get an windows error that important system files are removed?

A: You get that error, because windows protects some of the files. After deleting it windows says it can cause your system to become unstable, but this is not true. Just install the new driver and all is ok. Also when it asks for the cd then cancel it.
Q: Driver Cleaner stopped working or does not work!

A: It is possible that some of the VB6 runtime files is missing or another program installed older VB6 Runtime drivers or that something damaged the VB6 Runtime. Reinstall the runtime drivers. You can get download the English Runtime drivers here. You can also visit this link, it goes direct to the Microsoft VB6 Runtime downloads.
Q: Which filter is for what?

A: Check the Filters page for a full list.
Q: Can I request cleaning filters?

A: Yes, send an email to info at drivercleaner dot net and give a description of the product and driver. Also add the link of the driver.
It is not always possible to create a cleaning filter from the driver, but I will always try it.
Q: What is Cab Cleaner Professional Edition?

A: Windows could restore certain files from the driver cache folder out the driver.cab file or any other cab file from service packs. This could cause Windows overwriting new files with old files. This program will remove the nVidia and ATI drivers from the cab files.
Q: Does Cab Cleaner Professional Edition work with all Operating Systems?

A: It works on the same Operating Systems as Driver Cleaner Professional Edition.
Q: Should Cab Cleaner be used on all Operating Systems?

A: No, on Windows 95, 98, 98SE, ME it is not needed.
Q: What cab files should be cleaned?

A: Always take driver.cab and if you have a service pack installed, then also clean the service pack's cab file.
Q: After using Driver Cleaner Professional Edition and booting to windows there are driver files in the windows or system or system32 Folder?

A: If you didn't use Cab Cleaner or the pc wasn't disconnected from the internet, then that is possible. Windows will take driver files out of the cab files or download them when they are deleted. To prevent this use Cab Cleaner and disconnect the pc from the internet. It is also possible that there is another place on the pc where the drivers are.
Q: How to report problems!

A: Send an email to info at drivercleaner dot net, please use as subject Driver Cleaner Pro Support

Put in the email the following details:
- Detailed description of the problem you have.
- The driver name and version you tried to clean.
- What exactly did you do. (Exact steps and where did you do the steps, normal windows or safe mode.)
- What cleaning file(s) is/are used.
- What error message did you get and when did you get it.
- CPU (Manufacturer and Type)
- Motherboard (Manufacturer and Type)
- Videocard / Soundcard (Manufacturer and Type)

Please add other things that you think that could help.

Please attach the log files from the log folder in the installation directory. You can zip the log files into 1 zip file.


History

DH Driver Cleaner Professional Edition -- History
Version 1.5 (Date: March 04, 2006)
Added:
- Version check to see what the latest version is online
- View filters version number in settings screen
- Cleaning filter profile saving and loading (View help for details)
- Razer Mouse cleaning file
- SoundMAX Audio cleaning file

Updated:
- 3Dfx cleaning file
- ATI cleaning file
- ATI CCC cleaning file
- ATI MMC cleaning file
- ATI WDM cleaning file
- Creative Audio Lite cleaning file
- Creative Audio cleaning file
- nForce Chipset cleaning file
- nVidia cleaning file
- S3 Savage cleaning file
- Some Language files

Improved:
- Full registry backup routine
- Cab Cleaner Code
- Help file

Fixed:
- Bug in settings screen with folder size text

Version 1.4 (Date: January 21, 2006)
Added:
- Belarus language file
- Czech language file

Updated:
- ATI TV Wonder cleaning file
- VIA Envy Audio cleaning file
- VIA Vinyl Audio cleaning file
- nVidia WDM cleaning file

Fixed:
- Cab Cleaner did not clean the cab files in the windows\driver cache\amd64 folder

Version 1.3 (Date: January 05, 2006)
Added:
- 3Dlabs Wildcat 4 cleaning file
- 3Dlabs Wildcat REALIZM cleaning file
- 3Dlabs Wildcat VP cleaning file
- ATI TV Wonder cleaning file
- VIA Envy Audio cleaning file
- VIA HD Audio cleaning file
- VIA Vinyl Audio cleaning file
- Albanian language file

Updated:
- ATI cleaning file
- ATI WDM cleaning file
- ATI Uninstall Utility cleaning file
- nVidia cleaning file
- Realtek AC'97 cleaning file
- Italian language file

Improved:
- Registry searching routine

Fixed:
- Cab Cleaner not working good when cab file was read only
- Cab Cleaner did not clean the cab files in the windows\i386 folder

Version 1.2 (Date: September 20, 2005)
Added:
- Turkish language file
- Slovak language file

Updated:
- ATI cleaning file
- ATI CCC cleaning file
- nVidia cleaning file
- nForce Chipset cleaning file
- ATI IGP ATA cleaning file (Empty will not remove anything)
- ATI IGP Raid cleaning file (Empty will not remove anything)
- nForce Chipset ATA cleaning file (Empty will not remove anything)
- nForce Chipset Raid cleaning file (Empty will not remove anything)
- Help file
- French language file
- Greek language file
- Slovenian language file

Version 1.2 (Date: June 05, 2005)
Added:
- XGI Volari cleaning file
- Matrox Graphics cleaning file

Updated:
- ATI cleaning file
- ATI CCC cleaning file
- Creative Audio cleaning file
- Creative Audio Lite cleaning file
- nForce Chipset cleaning file
- nForce Chipset ATA cleaning file
- nForce Chipset Raid cleaning file
- nVidia cleaning file
- Realtek AC'97 cleaning file
- SIS Graphics cleaning file
- Language files
- Splash screen

Improved:
- Speed
- Backup routine
- Cleaning routine

Fixed:
- Problem with deleting directories
- Problem in Cab Cleaner (Cab extraction and creation routine)

Version 1.1 (Date: May 01, 2005)
Fixed:
- Cab Cleaner file creation error

Version 1.1 (Date: April 29, 2005)
Added:
- Time duration by Cab Cleaner

Updated:
- Redid most of the code
- ATI cleaning file
- nVidia cleaning file
- Some languages
- Cab Cleaner Extraction and Creating routine

Fixed:
- Cab Cleaner file creation check

Version 1.1 (Date: April 07, 2005)
Added:
- Polish language

Updated:
- ATI CCC cleaning file
- ATI WDM cleaning file
- Code optimizations
- Some languages

Fixed:
- That some files could not be deleted
- Directory check could fail
- Free disk space check in Cab Cleaner

Version 1.1 (Date: March 05, 2005)
Added:
- ATI CCC cleaning file
- ATI IGP ATA cleaning file
- ATI IGP Raid cleaning file
- nForce Chipset ATA cleaning file
- nForce Chipset Raid cleaning file
- Remember last used cleaning file
- Remember show or hide details
- Brazilian Portuguese language

Updated:
- ATI cleaning file
- ATI IGP cleaning file (Removed Raid, ATA, IDE, SATA cleaning)
- nVidia cleaning file
- nForce Chipset cleaning file (Removed Raid, ATA, IDE, SATA cleaning)
- All languages (Except Croatian and Slovenian)
- Help file

Fixed:
- Problem that show details button did not work when the language for non-Unicode programs was set on Asian languages
- Problem that Backup / Log did not work when the language for non-Unicode programs was set on Asian languages
- Problem that Restore did not work when the language for non-Unicode programs was set on Asian languages

Version 1.0 (Date: January 20, 2005)
Initial release version
Copyright 2002-2006 by Driverheaven, written by Ruud Ketelaars


Credits

DH Driver Cleaner Professional Edition -- Credits
Language File | Translator
Albanian | Genc Alikaj
Belarus | Starovoitov Sergey (OldEvrei)
Brazilian Portuguese | Tiago Lenz de Brum (Tyellbee)
Chinese | Shen Mo
Croatian | Vid Kovacic
Czech | Vlastimil Jedlička
Dutch | Davy "Dragunov" Maekelberg Checked / Improved by Ruud Ketelaars
English | Ruud Ketelaars
French | Arush "sandok" Kochhar Checked / Improved by Sephres
German | Stefan Thaller
Greek | Manos Karatarakis Checked / Improved by Thodoris Kotsilieris Updated by Filippos Karapetis Improved by Nick Mattheakis
Hebrew | Oleg Tkachenko
Hungarian | Zoltán Németh - Roadside
Italian | Alexander "H3X4D3CIM4L" Condotta Improved by Rinaldo M.
Korean | Sung Hoon Jung
Polish | Szymon Ogrodnik
Portuguese | Hélio "mainman" Brandão
Romanian | Alex Mateescu
Russian | Sergey Ponomarchuk Checked / Improved by Vitaly Pecharsky, Jr.
Serbian | Zeljko Bozin Checked / Updated by Milan Trajkovic
Slovak | Jan "Longo213" Loncik
Slovenian | Vid Kovacic Updated by 21 inch
Spanish | dream caster (J.Concha)
Swedish | Tor "kosmiq" Raswill
Turkish | Erhan Burhan
Ukrainian | Vitaly Pecharsky, Jr.