Содержание

 Top Next

1. Общие сведения о программе.

1.1. Сведения, содержащиеся в документации.

1.2. Назначение и основные функции.

1.3. Общий алгоритм работы.

2. Быстрый установка, запуск и начало использования.

3. Установка и удаление программы.

3.1. Системные требования.

3.2. Первая установка.

3.3. Повторная установка.

3.4. Удаление программы.

3.5. «Тихая» установка, установка на удаленные машины.

3.6. «Тихое» удаление, удаление с удаленных машин.

4. Настройки программы.

4.1. Основные.

4.1.1. Локальное и удаленное администрирования.

4.1.2. Параметры сервера.

4.2. Ограничения.

4.2.1. Часы работы.

4.2.2. Рабочий приоритет.

4.3. Настройки интерфейса.

4.3.1. Значок на панели задач.

4.3.2. Работа службой системы.

4.3.3. Язык интерфейса.

4.4. Настройки журнала.

4.4.1. Ведение журнала.

4.4.2. Просмотр журнала.

4.4.3. Очищение журнала.

4.4.4. Уровень детализации.

4.4.5. Ограничение размера.

4.4.6. Задание имена файла журнала.

4.5. Трактовка статистики.

4.6. Назначения общих кнопок диалога свойств.

4.7. Установка настроек в изначальное значение.

5. Контекстное меню иконки на панели задач.

6. Состояния агента.

6.1. Рабочее.

6.2. Сетевое.

7. Лицензионное соглашение.

8. Техническая поддержка.


1. Общие сведения о программе

 Top Previous Next

1.1. Сведения, содержащиеся в документации.

1.2. Назначение и основные функции.

1.3. Общий алгоритм работы


1.1. Сведения, содержащиеся в документации

В настоящей документации содержатся сведения, необходимые для установки и эксплуатации ElcomSoft Distributed Agent. Описаны процедуры установки, повторной установки, удаления, концепции, заложенные в основу программы, способ ее применения. Приведены рекомендации по настройке.


1.2. Назначение и основные функции

ElcomSoft Distributed Agent предназначен для выделения машинного времени компьютера на котором он работает ElcomSoft Distributed Password Recovery серверу, который в свою очередь использует его для восстановления документов у которых утерян или забыт пароль.

Программа позволяет:

- администрироваться локально или удаленно (в случае удаленного администрирования часы работы и приоритет настраиваются и берутся с сервера);

- управлять часами работы, в которые может быть использован процессор;

- управлять приоритетом своей работы;

- запускаться как служба системы, так и как обычное приложение;

- вести учет использованного ею машинного времени;

- вести и при необходимости просматривать отчет о своих действиях.


1.3. Общий алгоритм работы

Агент подключается к заданному на нем серверу, отдает сделанную работу, если она у него была, получает следующую часть работы, отключается и начинает производить обсчет полученного задания. Периодически, в среднем каждые шестьдесят секунд плюс некоторое случайное число секунд, не больше шестидесяти, агент подключается к серверу, чтобы сообщить о своем состоянии.


2. Быстрый установка, запуск и начало использования

Если вы хотите быстро приступить к использованию программы, то проделайте следующие действия:

- запустите программу установки (agent_setup.exe);

- ответьте на все вопросы программы установки нажатием клавиши «Enter» на клавиатуре или нажатием левой кнопки мышки на соответствующие кнопки по умолчанию на диалогах;

- в появившемся окне, запущенной программы, на первой закладке в группе настроек «Сервер» укажите имя или ip-адрес сервера, после чего нажмите внизу диалога «OK» или «Применить».

Если вы проделали все правильно, то после этого Агент будет готов к работе.


3.1. Системные требования

Для нормального функционирования программы требуется следующие аппаратное и программное обеспечение:

- 100%-совместимый c IBM PC компьютер, процессор Pentium или выше;

- 128 Mb оперативной памяти;

- 10 Mb свободного места на диске;

- одна из следующих ОС: Windows 98, Windows Me, Windows NT 4, Windows 2000 Server, Windows 2000 Advanced Server, Windows NT Workstation, Windows 2000 Professional, Windows XP Professional, Windows 2003 Server, Windows Vista (совместимость с последующими операционными системами возможна, но не гарантируется).


3.2. Первая установка

Чтобы установить ElcomSoft Distributed Agent на компьютер:

- запустите программу «agent_setup.exe»;

- выберите предпочтительный язык интерфейса программы и нажмите «OK» (рисунок 3.2.1);

Рисунок 3.2.1 . Диалоговое окно выбора предпочтительного языка интерфейса программы.

- следуйте инструкциям программы установки (рисунок 3.2.2);

Рисунок 3.2.2 Диалоговое окно начала установки программы.

- нажмите кнопку «Далее» для продолжения установки или «Отмена», для отказа от установки (рисунок 3.2.3);

Рисунок 3.2.3 Диалоговое окно подтверждения отказа от установки программы.

Рисунок 3.2.4 Диалоговое окно с лицензионным соглашением.

- нажмите «Принимаю», если вы согласны с условиями лицензионного соглашения, «Отмена», чтобы оборвать процесс установки, «Назад» чтобы вернуться на предыдущее окно программы установки (рисунок 3.2.4);

Рисунок 3.2.5 Диалоговое окно выбора компонентов для установки.

- выберите компоненты, которые вы хотите установить и нажмите «Далее» (рисунок 3.2.5);

Рисунок 3.2.6 Выбор папки на диске для установки программы.

- нажмите «Обзор», если хотите изменить папку по умолчанию (рисунок 3.2.6), далее выберите нужную папку и нажмите «OK» (рисунок 3.2.7), если вы не хотите больше менять папку, куда будет установлена программа, нажмите «Далее» (рисунок 3.2.6);

Рисунок 3.2.7 Диалоговое окно с выбором папки.

Рисунок 3.2.8 Выбор папки в стандартном меню Программы.

- в появившемся на экране диалоговом окне (рис. 3.2.8) укажите имя папки в стандартном меню Программы. Нажмите на кнопку «Установить»;

Рисунок 3.2.9 Диалоговое окно завершения процесса установки.

- уберите «галочку», на этом диалоговом окне, если вы не хотите, чтобы по нажатию кнопки «Готово» программа запустилась (рисунок 3.2.9);

- нажмите «Готово», чтобы завершить установку.


3.3. Повторная установка

Повторная установка происходит тогда, когда вы запускаете программу установки «agent_setup.exe» и на вашем компьютере уже существует инсталляция этой программы. Данная процедура может потребоваться при обновлении программы на более новую версию, при этом сохраняются настройки и файлы данных и журнала программы.

Чтобы установить ElcomSoft Distributed Agent на компьютер повторно

- запустите программу «agent_setup.exe»;

- следуйте инструкциям программы установки (рисунок 3.2.2);

- нажмите кнопку «Далее» для продолжения установки или «Отмена», для отказа от установки (рисунок 3.2.3);

- нажмите «Принимаю», если вы согласны с условиями лицензионного соглашения, «Отмена», чтобы прервать процесс установки, «Назад» чтобы вернуться на предыдущее окно программы установки (рисунок 3.2.4);

- уберите «галочку», на этом диалоговом окне, если вы не хотите, чтобы по нажатию кнопки «Готово» программа запустилась (рисунок 3.2.9);

- нажмите «Готово», чтобы завершить установку.


3.4. Удаление программы

Чтобы удалить ElcomSoft Distributed Agent с компьютера:

- инициируйте стандартными средствами процесс удаления программы;

- в появившемся на экране диалоговом окне (рисунок. 3.4.1) нажмите на кнопку «Далее»;

- уберите галочку с «удалить все log-файлы», если вы не хотите чтобы удалились файлы журнала, созданные программой (рисунок 3.4.2);

- уберите галочку с «удалить все data-файлы», если вы не хотите чтобы удалились файлы данных, созданные программой (рисунок 3.4.2);

- нажмите «Удалить», чтобы начать процесс удаления программы (рисунок 3.4.2);

- нажмите «Готово», чтобы завершить процесс удаления программы (рис. 3.4.3).

Теперь программа удалена с вашего компьютера.

Рисунок 3.4.1 Начальный диалог удаление программы.

Рисунок 3.4.2 Выбор удаляемых данных и подтверждение удаления программы.

Рисунок 3.4.3 Завершение удаления программы.


3.5. «Тихая» установка, установка на удаленные машины

«Тихая» установка предназначена для установки программы удаленно на большое число компьютер в сети. При этом программа установки не будет выводить никаких диалогов.

Для того чтобы выполнить такую установку вам необходимо создать текстовый

файл формата ASCII с именем «agent_setup.ini» и положить его рядом с программой установки «agent_setup.exe». Файл «agent_setup.ini» состоит из нескольких секций, в которых расположены названия параметров и соответствующие им значения. Секция имеет следующий вид:

[Название_секции]

Название_параметра_1=Значение_параметра_1

Название_параметра_2=Значение_параметра_2

В начале секции приводится ее название, заключенное в квадратные скобки. Далее следуют строки определения значений параметров. Слева от знака равенства - название очередного параметра, справа - его значение.

Внутри файл «agent_setup.ini» должен содержать следующие строчки:

[General]

ServerHost=<имя или ip-адрес сервера>

ServerPort=<tcp-порт сервера>

[Interface]

HideIndicator=<0 | 1>

где значение «ServerHost» - имя или ip-адрес сервера, к которому будет подключаться агент, «ServerPort» - порт сервера, к которому будет подключаться агент, «HideIndicator» - отвечает за то будет у агента видна иконка в системном трее (0 – не будет, 1 – будет).

Потом, например, имея администраторские права, вы можете:

- запустить службу «Server», если она не запущена;

- обеспечить общий доступ к папке, где лежат файлы «agent_setup.exe» и «agent_setup.ini»;

- отредактировать список задач службы AT;

- запустить службу AT.

Таким способом вы можете удаленно установить агентов на машины в сети


3.6. «Тихое» удаление, удаление с удаленных машин

«Тихое» удаление предназначено для удаления программы сразу с большого числа компьютер в сети. При этом программа удаления не будет выводить никаких диалогов.

При запуске программы «agent_setup.exe» с ключом –uninstall, вы можете автоматически удалить программу с компьютера:

agent_setup.exe –uninstall


4. Настройки программы

4.1. Основные.

4.2. Ограничения.

4.3. Настройки интерфейса.

4.4. Настройки журнала.

4.5. Трактовка статистики.

4.6. Назначения общих кнопок диалога свойств.

4.7. Установка настроек в изначальное значение.


4.1. Основные

Основные настройки программы расположены в закладке свойств основного диалога программы под названием «Основные». Здесь вы можете увидеть две группы настроек – «Администрирование» и «Сервер», которые будет описаны ниже (рисунок 4.1).

Рисунок 4.1 Основные настройки программы.

4.1.1. Локальное и удаленное администрирования.

4.1.2. Параметры сервера.


4.1.1. Локальное и удаленное администрирования

Администрирования может быть одним из двух возможных видов: локальное и удаленное.

Поставьте «Локальное», если вы хотите сами настраивать время работы и приоритет,

«Удаленное», если вы хотите, чтобы время работы и приоритет брались с сервера.


4.1.2. Параметры сервера

Параметры сервера должны быть заданы обязательно, чтобы программа смогла подключаться к серверу и брать у него часть работы.

В параметре «Хост» укажите имя или ip-адрес сервере, или нажав кнопку «Обзор» выберите из списка имеющиеся.

В параметре «Порт», если порт сервера отличается от значение по умолчанию, укажите порт сервера. Нажав на клавишу «Сбросить», параметр «Порт» примет значение по умолчанию.

Когда вы задали значение «Хоста» или «Порта», вы можете проверить удастся ли агенту подключится к серверу по этим параметрам, для этого нажмите кнопку «Проверить соединение», по иконке программы в верхнем левом углу вы поймете, что программа начала подключатся, и если после этого процесса иконка станет красного цвета, то значит

агент не смог подключится к серверу.


4.2. Ограничения

Закладка с настройками под названием «Ограничения» позволяет вам, если вы установили локальное администрирование в закладке «Основные», задать часы, в которые программа может выполнять вычисления по дням недели и системный приоритет, с которым она это будет делать. Или же, если вы задали удаленное администрирование, то просмотреть часы работы и приоритет, заданные администратором на сервере (рисунок 5.1).

Рисунок 4.2 Часы работы и приоритет.


4.2.1. Часы работы

Вы можете задать конкретные часы работы программы, как для всех дней недели, так и для каждого в отдельности. Для этого на диалоге «Ограничения» выделите день недели, часы работы которого вы хотите настроить или <все дни> и пометьте галочками соответствующие часы. Вы можете воспользоваться кнопками «Включить все», «Выключить все», чтобы включить или выключить все часы работы соответствующего дня недели или всех дней.


4.2.2. Рабочий приоритет

Приоритет, с которым программа выполняет вычисления, относительно других работающих программ. По умолчанию установлен приоритет «Простой системы», это значит, что программа будет использовать центральный процессор только тогда, когда он не нужен другим программам. Если, например, вы установите «Обычный» приоритет и запустите вместе с агентом какой-нибудь «тяжелый» процесс, то они будут делить процессор поровну.


4.3. Настройки интерфейса

Закладка «Интерфейс» позволяет настроить настройки интерфейс программы, а так же возможность работы программы как службы (рисунок 6.1).

Рисунок 4.3 Настройки интерфейса.

4.3.1. Значок на панели задач.

4.3.2. Работа службой системы.

4.3.3. Язык интерфейса.


4.3.1. Значок на панели задач

Установив эту опцию, вы позволите программе отображать свой значок на панели задач,

показывая свое состояния (подробнее о состояниях программы смотрите в соответствующем разделе). Двойной клик левой кнопкой мышки приводит к вызову диалога свойств программы, одиночное нажатие правой кнопки мышки приводит к вызову контекстного меню (подробнее о контекстном меню смотрите в соответствующем разделе).


4.3.2. Работа службой системы

По умолчанию, после установки, агент работает как обычное приложение, но вы можете сделать так, чтобы он запускался как служба, в таком случае программа будет работать до логина пользователя.

Чтобы программы работа как служба установите соответствующий переключатель в положение «Запускать как Службу» и нажмите «OK» или «Применить».


4.3.3. Язык интерфейса

Вы можете выбрать один из имеющихся языков, на котором будет отображаться интерфейс программы.


4.4. Настройки журнала

Закладка «Журнал», позволяет вам гибко управлять системой протоколирования действий работы программы.

Рисунок 4.4 Настройки журнала.

4.4.1. Ведение журнала.

4.4.2. Просмотр журнала.

4.4.3. Очищение журнала.

4.4.4. Уровень детализации.

4.4.5. Ограничение размера.

4.4.6. Задание имена файла журнала.


4.4.1. Ведение журнала

Включите опцию «Вести журнал», чтобы создавался файл отчета для программы.


4.4.2. Просмотр журнала

Нажми кнопу «Просмотр журнала», чтобы посмотреть содержимое журнала. Если журнал слишком велик, и у стандартной программы просмотра возникают трудности при его отображении, воспользуйтесь другой программой просмотра, открыв в ней файл с именем, указанным в поле «Имя файла».


4.4.3. Очищение журнала

Нажмите кнопку «Очистить журнал», чтобы освободить журнал от всех записей, содержащихся в нем и подтвердите (рисунок 4.4.3), что действительно хотите осуществить это действие.

Рисунок 4.4.3. Подтверждение очищения журнала.


4.4.4. Уровень детализации

Существуют три уровня детализации ведения журнала: все возможные сообщения – для отладочного режима работы; информация, предупреждения и ошибки – значение по умолчанию; только ошибки – если вы не хотите протоколировать действия работы программы, кроме случаев, когда происходят какие-либо сбои. Уровень детализации выставляется соответствующий положение переключателя.


4.4.5. Ограничение размера

Чтобы журнал не поглотил все свободное место на диске, вы можете ограничить его максимальный размер, при этом при достижении им максимального размера, он будет очищен и начнет создаваться заново.

Для того чтобы ограничить размер журнала включите соответствующую опцию и задайте максимальный размер в килобайтах.


4.4.6. Задание имена файла журнала

В имени поле «имя файла» задается имя файла, где хранится журнал.


4.5. Трактовка статистики

В закладке «О программе», ведется статистика о количестве перебранных паролях, ключах и потраченном на это процессорном времени. Статистика ведется за текущий день, за текущую неделю, за текущий месяц и за все время, после последнего сброса статистики (рисунок 4.5).

Рисунок 4.5 Отображение статистики.


4.6. Назначения общих кнопок диалога свойств

Кнопка «Выход из агента» используется для завершения работы программы. Стоит отметить, что если вы не выполните эту команду самостоятельно, то при следующем запуске системы программа запустится автоматически.

Кнопка «ОК» для применения измененных свойств и закрытие диалога свойств, причем закрытие диалога свойств не приводит к завершению программы.

Кнопка «Отменить» применяется для отмены измененных, но не примененных настроек и закрытия диалога свойств, причем закрытие диалога свойств не приводит к завершению программы.

Кнопка «Применить», используется для применения (вступления в силу), измененных настроек, причем если эта к кнопка находится в состоянии, когда ее нельзя нажать, то применение измененных свойств не требуется, никакие настройки не были изменены.

Рисунок 4.6 Общие кнопки диалога свойств.


4.7. Установка настроек в изначальное значение

Для того чтобы вернуть настройки в их изначальное значение необходимо кликнуть левой кнопкой мышки на системном меню диалога свойств или нажать на клавиатуре комбинация клавиш <Alt>+<Tab> и исполнить команду «Сбросить по умолчанию».


5. Контекстное меню иконки на панели задач

Когда программа отображает свою иконку в системном трее, то кликнув по ней правой кнопкой мыши вы увидите контекстное меню (рисунок 5.1).

Рисунок 5.1. Контекстное меню иконки на панели задач.

Команда «Восстановить» используется для показа на экране спрятанного диалога свойств программы.

Команда «Спрятать значок» используется для убирания иконки из панели задач. Потом чтобы вернуть значок, вы можете отключить опцию «Скрывать значок на панели задач», в диалоге свойств программы в закладке «Интерфейс».

«Приоритет» меняет приоритет работы программы, опция идентична опции приоритета в диалоге свойств программы в закладке «Ограничения».

«Выход» завершает работу программы. Стоит отметить, что если вы не выполните эту команду самостоятельно, то при следующем запуске системы программа запустится автоматически.


6. Состояния агента

У программы есть два типа состояний, которые могут меняться:

- рабочее

- сетевое


6.2. Сетевое

Сетевое состояние может быть одним из трех значений:

- автономно;

- соединение;

- оперативно.

Агент обычно пребывает в автономном состоянии большую часть своего времени, когда обсчитывает задание с сервера или ожидает его.

В состояние соединение, агент переходит, когда намеревается подключится к серверу.

В состоянии оперативно, агент пребывает, когда подключился к серверу и отдает или принимает от него задание.


6.1. Рабочее

Рабочее состояние может иметь три значения:

- в ожидании;

- работает;

- не работает.

В ожидании программа пребывает, когда у сервера нет работы для агента.

В состоянии работает программа пребывает, когда производит обработку задания от сервера.

В состоянии не работает программа пребывает, когда у нее не рабочее время.


7. Лицензионное соглашение

END USER LICENSE AGREEMENT

NOTICE TO USER:

THIS IS AN AGREEMENT GOVERNING YOUR USE OF ELCOMSOFT SOFTWARE, FURTHER DEFINED HEREIN AS “PRODUCT,” AND THE LICENSOR OF THE PRODUCT IS WILLING TO PROVIDE YOU WITH ACCESS TO THE PRODUCT ONLY ON THE CONDITION THAT YOU ACCEPT ALL OF THE TERMS AND CONDITIONS CONTAINED IN THIS AGREEMENT. BELOW, YOU ARE ASKED TO ACCEPT THIS AGREEMENT AND CONTINUE TO INSTALL OR, IF YOU DO NOT WISH TO ACCEPT THIS AGREEMENT, TO DECLINE THIS AGREEMENT, IN WHICH CASE YOU WILL NOT BE ABLE TO INSTALL OR OPERATE THE PRODUCT. BY INSTALLING THIS PRODUCT YOU ACCEPT ALL THE TERMS AND CONDITIONS OF THIS AGREEMENT.

This Electronic End User License Agreement (the “Agreement”) is a legal agreement between you (either an individual or an entity), the licensee, and ElcomSoft Co. Ltd. and its affiliates (collectively, the “Licensor”), regarding the Licensor’s software, as applicable pursuant to a valid license, you are about to download and/or other related services, including without limitation a) all of the contents of the files, disk(s), CD-ROM(s) or other media with which this Agreement is provided and including all forms of code, such as source code and object code, (the “Software”), b) all successor upgrades, modified versions, modified modules, revisions, patches, enhancements, fixes, modifications, copies, additions or maintenance releases of the Software, if any, licensed to you by the Licensor (collectively, the “Updates”), and c) related user documentation and explanatory materials or files provided in written, “online” or electronic form (the “Documentation” and together with the Software and Updates, the “Product”). You are subject to the terms and conditions of this End User License Agreement whether you access or obtain the Product directly from the Licensor, or through any other source. For purposes hereof, “you” means the individual person installing or using the Product on his or her own behalf; or, if the Product is being downloaded or installed on behalf of an organization, such as an employer, “you” means the organization for which the Product is downloaded or installed, then the person accepting this agreement represents hereby that such organization has authorized such person to accept this agreement on the organization’s behalf. For purposes hereof the term “organization,” without limitation, includes any partnership, limited liability company, corporation, association, joint stock company, trust, joint venture, labor organization, unincorporated organization, or governmental authority.

By accessing, storing, loading, installing, executing, displaying, copying the Product into the memory of a Client Device, as defined below, or otherwise benefiting from using the functionality of the Product (“Operating”), you agree to be bound by the terms and conditions of this Agreement. If you do not agree to the terms and conditions of this Agreement, the Licensor is unwilling to license the Product to you. In such event, you may not Operate or use the Product in any way.

BEFORE YOU “I AGREE” BUTTON”, PLEASE CAREFULLY READ THE TERMS AND CONDITIONS OF THIS AGREEMENT, AS SUCH ACTIONS ARE A SYMBOL OF YOUR SIGNATURE AND BY CLICKING ON THE “I AGREE” BUTTON, YOU ARE CONSENTING TO BE BOUND BY AND ARE BECOMING A PARTY TO THIS AGREEMENT AND AGREE THAT THIS AGREEMENT IS ENFORCEABLE LIKE ANY WRITTEN NEGOTIATED AGREEMENT SIGNED BY YOU. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, CLICK THE “CANCEL” BUTTON AND THE PRODUCT WILL NOT BE INSTALLED ON YOUR CLIENT DEVICE, AS SUCH TERM IS DEFINED BELOW. For your reference, you may refer to the copy of this Agreement that can be found in the Help for the Software. You may also receive a copy of this Agreement by contacting Licensor at: info@elcomsoft.com.

1. Proprietary Rights and Non-Disclosure.

1.1. Ownership Rights. You agree that the Product and the authorship, systems, ideas, methods of operation, documentation and other information contained in the Product, are proprietary intellectual properties and or the valuable trade secrets of the Licensor and are protected by civil and criminal law, and by the law of copyright, trade secret, trademark and patent of the Russian federation, other countries and international treaties. You may use trademarks only insofar as to identify printed output produced by the Product in accordance with accepted trademark practice, including identification of trademark owner’s name. Such use of any trademark does not give you any rights of ownership in that trademark. The Licensor and its suppliers own and retain all right, title, and interest in and to the Product, including without limitations any error corrections, enhancements, Updates or other modifications to the Software, whether made by Licensor or any third party, and all copyrights, patents, trade secret rights, trademarks, and other intellectual property rights therein. Your possession, installation or use of the Product does not transfer to you any title to the intellectual property in the Product, and you will not acquire any rights to the Product except as expressly set forth in this Agreement. All copies of the Product made hereunder must contain the same proprietary notices that appear on and in the Product. Except as stated herein, this Agreement does not grant you any intellectual property rights in the Product and you acknowledge that the license granted under this Agreement only provides you with a right of limited use under the terms and conditions of this Agreement.

1.2. Source Code and Modifications. You acknowledge that the source code for the Product is proprietary to the Licensor and constitutes trade secrets of the Licensor. You agree not to modify, or create derivative works based upon the Product in whole or in part nor reverse engineer, decompile, disassemble the source code of the Product in any way.

1.3. Registration Code File and Confidential Information. You agree that, unless otherwise specifically provided herein or agreed by the Licensor in writing, the Product, including the specific design and structure of individual programs and the Product, including without limitation the Registration Code File provided to you by the Licensor and/or its authorized resellers or distributors, constitute confidential proprietary information of the Licensor. For purposes hereof, “Registration Code” shall mean a unique key identification file or a combination of unique electronic characters provided to you by the Licensor confirming the purchase of the license from the Licensor, which may carry the information about the license and the number of permitted users, and enabling the full functionality of the Product in accordance with the license granted under this Agreement. You agree not to transfer, copy, disclose, provide or otherwise make available such confidential information in any form to any third party without the prior written consent of the Licensor. You agree to implement reasonable security measures to protect such confidential information, but without limitation to the foregoing, shall use best efforts to maintain the security of the Registration Code provided to you by the Licensor and/or its authorized resellers or distributors.

2. Grant of License.

2.1. License. The Licensor grants you the following rights (“License”) and you hereby agree and accept such License:

a). Trial Version. If you have received, downloaded and/or installed a trial version of the Product and are hereby granted an evaluation license for the Software and you may Operate the Product only for evaluation purposes and only during the single applicable evaluation period of thirty (30) days, unless otherwise indicated, from the date of the initial installation. Following this test period of thirty (30) days or less, if you wish to continue to use the Product, you must register. To register you have to pay for the fully functional version. Upon payment we provide the Registration Code to you. Any use of the Product for other purposes or beyond the applicable evaluation period is strictly prohibited, provided however that, subject to the restrictions contained herein, you may copy and distribute a trial version of the Software without any modifications whatsoever to any third party subject to this Agreement and further provided that you have no technical support rights during the trial period. The unregistered (trial) version may be freely distributed, provided that the distribution package is not modified. No person or company may charge a fee for the distribution of the Product without written permission from the copyright holder.

b). Grant of License. Unless otherwise specifically indicated under a valid license (e.g. volume license) granted by the Licensor, once registered you are granted a non-exclusive and non-transferable license to install one (1) copy of the Product and during the term of your license, subject to the payment of the applicable fees and your compliance with the terms hereof, this Agreement permits you or any of your employees to Operate one copy of the specified version of the Product, for internal purposes only, on one computer, workstation, or other electronic device of which the software was designed (each a “Client Device”). If you have purchased multiple licenses for the Product, then the number of multiple licenses shall determine the number of copies of the Product you may have and the number of Client Devices on which you may Operate the Product. If the Product is licensed as a suite or bundle with more than one specified software product, this license applies to all such specified software products, subject to any restrictions or usage terms specified on the applicable price list or product packaging that apply to any of such software products individually. Additionally, Licensor reserves the right to provide for specific terms and conditions in the purchased licenses and such terms may be embedded in Registration Code specifying other terms, conditions and restrictions of Operating of the Product. The Licensor reserves all rights not expressly granted herein.

c). Limitations on Personal License. With the purchase of a personal License, the Licensee may operate the Product as set forth in the Agreement for non-commercial purposes in a non-business or non-commercial environment. Use of the Product in a corporate, governmental or business environment requires the purchase of a business license.

d). Site License. With the acquisition of a Site License, the Licensee may install and use the Product on an unlimited amount of CPUs within one office in one geographic location. Within these limitations, the Licensee may install the Product as a “Network” Product and run the software from any networked computer on your LAN, provided those computers are located exclusively within one office at one geographic location.

e). Volume Use. If the Product is licensed with volume license terms specified in the applicable product invoicing or packaging for the Product, you may make use and install as many additional copies of the Product on the number of Client Devices as the volume license terms specify. You must have a reasonable mechanism in place to ensure that the number of Client Devices on which the Product has been installed does not exceed the number of licenses you have obtained.

f). Multiple Environment Product; Multiple Language Product; Dual Media Product; Multiple Copies; Bundles. If the Product supports multiple platforms or languages, if you receive the Product on multiple media, if you otherwise receive multiple copies of the Product, or if you received the Product bundled with other software, the total number of your Client Devices on which all versions of the Product are installed may not exceed the number of licenses you have obtained from the Licensor. You may not rent, lease, sublicense, lend or transfer any versions or copies of the Product you do not use.

2.2. Back-up Copies. You can make one (1) copy the Product for backup and archival purposes, provided, however, that the original and each copy is kept in your possession or control, and that your installation and use of the Product does not exceed that which is allowed in this Section 2.

2.3. Prohibitions. You may not use, copy, emulate, clone, rent, lease, sell, modify, decompile, disassemble, otherwise reverse engineer, or transfer the licensed program, or any subset of the licensed program, except as provided for in this Agreement. Any such unauthorized use shall result in immediate and automatic termination of this license and may result in criminal and/or civil prosecution. Neither ElcomSoft binary code nor source may be used or reverse engineered to re-create the program algorithm, which is proprietary, without written permission of Licensor. All rights not expressly granted here are reserved by ElcomSoft Co. Ltd.

2.4. Special Provisions Applicable to Password Recovery Programs. The Licensor has a strict return policy due to the nature of our products. If the software is unable to recover (or remove, or change) a password, a copy of the unrecovered file must be sent to the Licensor for evaluation. If the password is recovered, you will be either able to keep the software and receive the password to the file (or unprotected copy of the file), or refund can be made and the end user will need to pay for the in-house recovery in order to receive the password. If the Licensor is unable to recover the password, a full refund will be made. This subsection is applicable only to situations when password recovery or removal is guaranteed without brute-force or dictionary attacks.

2.5. Registration Code. Registration Code provided by the Licensor constitutes the confidential proprietary information of the Licensor. ElcomSoft Registration Code file may not be distributed, except as stated herein, outside of the area of legal control of the person or persons who purchased the original license, without written permission of the copyright holder. You may not give away, sell or otherwise transfer your Registration Code to a third party. Doing so will result in an infringement of copyright. ElcomSoft Co. Ltd retains the right of claims for compensation in respect of damage which occurred by your giving away the registration code. This claim shall also extend to all costs which ElcomSoft Co. Ltd incurs in defending itself.

2.6. Transfers. Under no circumstances shall Licensee sell, rent, lease, license, sublicense, publish, display, distribute, or otherwise transfer to a third party the Software, any copy thereof, in whole or in part, without Licensor's prior written consent, unless otherwise provided for in this Agreement.

2.7. Acceptance of Licensing Terms. Installing and using the Product signifies acceptance of these terms and conditions of the License. If you do not agree with the terms of the license you must remove all Product files from your storage devices, including any back-up or archival copy, and cease to use the Product.

2.8. Material Terms and Conditions. Licensee specifically agrees that each of the terms and conditions of this Section 2 are material and that failure of Licensee to comply with these terms and conditions shall constitute sufficient cause for Licensor to immediately terminate this Agreement and the License granted under this Agreement. The presence of this Section 2.7 shall not be relevant in determining the materiality of any other provision or breach of this Agreement by either party.

2.9. Term and Termination. The term of this Agreement (“Term”) shall begin when you download, access or install the Product or pay the applicable license fees (whichever is earlier) and shall continue for the term specified in your order. Without prejudice to any other rights, this Agreement will terminate automatically if you fail to comply with any of the limitations or other requirements described herein. Upon any termination or expiration of this Agreement, you must immediately cease use of the Product and destroy all copies of the Product.

2.10. No Rights Upon Termination. Upon termination of this Agreement you will no longer be authorized to Operate or use the Product in any way.

3. Support and Updates.

3.1. Terms of Support. During the one-year period you are entitled to technical services and support for the Product which is provided to you by Licensor during the regular business hours (GMT+ 03:00), except for locally-observed holidays, and includes the support provided through a special technical support section of the Licensor’s site (the “Site”) and email support@elcomsoft.com. During such period of one year e-mail support is unlimited and includes technical and support questions and patch fixes.

3.2. Updates. During the one-year period, you may download Updates to the Product when and as the Licensor publishes them on the Site, or through other online services. If the Product is an Update to a previous version of the Product, you must possess a valid license to such previous version in order to use the Update. You may continue to use the previous version of the Product on your Client Device after you receive the Update to assist you in the transition to the Update, provided that: (i) the Update and the previous version are installed on the same Client Device; (ii) the previous version or copies thereof are not transferred to another party or Client Device unless all copies of the Update are also transferred to such party or Client Device; (iii) you acknowledge that any modification that you made to the Product may be lost, altered, distorted or destroyed rendering such modifications, Product or the part thereof inoperable or non-usable; and (iv) you acknowledge that any obligation the Licensor may have to support the previous version of the Product may be ended upon availability of the Update. Except for the rights to free Updates during the one-year period, as further defined herein, nothing in this Agreement shall be construed as to grant you any rights or licenses with regard to the new releases of the Product or to entitle you to any new release. This Agreement does not obligate the Company to provide any Updates. Notwithstanding the foregoing, any Updates that you may receive become part of the Product and the terms of this Agreement apply to them (unless this Agreement is superseded by a succeeding agreement accompanying such Update or modified version of the Product).

4. Restrictions.

4.1. No Transfer of Rights. You may not transfer any rights pursuant to this Agreement nor rent, sublicense, lease, loan or resell the Product. You may not permit third parties to benefit from the use or functionality of the Product via a timesharing, service bureau or other arrangement, except to the extent such use is specified in the application price list, purchase order or product packaging for the Product. Except as otherwise provided in Section 1.2 hereof, you may not, without the Licensor’s prior written consent, reverse engineer, decompile, disassemble or otherwise reduce any party of the Product to human readable form nor permit any third party to do so, except to the extent the foregoing restriction is expressly prohibited by applicable law. Notwithstanding the foregoing sentence, decompiling the Software is permitted to the extent the laws of your jurisdiction give you the right to do so to obtain information necessary to render the Software interoperable with other software; provided, however, that you must first request such information from the Licensor and the Licensor may, in its discretion, either provide such information to you (subject to confidentiality terms) or impose reasonable conditions, including a reasonable fee, on such use of the Software to ensure that the Licensor's and its affiliates’ proprietary rights in the Software are protected. Except for the modification permitted under Section 1.2, you may not modify, or create derivative works based upon the Product in whole or in part.

4.2. Proprietary Notices and Copies. You may not remove any proprietary notices or labels on the Product. You may not copy the Product except as expressly permitted in Section 2 above.

4.3. Compliance with Law. You agree that in Operating the Product and in using any report or information derived as a result of Operating this Product, you will comply with all applicable international, national, state, regional and local laws and regulations, including, without limitation, privacy, trademark, patent, copyright, export control and obscenity law and you shall not use the Product for unethical or illegal business practices or in violation of any obligation to a third party in using, operating, accessing or running any of the Product and shall not knowingly assist any other person or entity to so violate any obligation to a third party.

4.4. Additional Protection Measures. Solely for the purpose of preventing unlicensed use of the Product, the Software may install on your Client Device technological measures that are designed to prevent unlicensed use, and the Licensor may use this technology to confirm that you have a licensed copy of the Product. The update of these technological measures may occur through the installation of the Updates. The Updates will not install on unlicensed copies of the Product. If you are not using a licensed copy of the Product, you are not allowed to install the Updates. The Licensor will not collect any personally identifiable information from your Client Device during this process.

5. WARRANTIES AND DISCLAIMERS.

5.1. Limited Warranty. The Licensor warrants that for 90 days (the “Warranty Period”) from the date the Registration Code is provided to you by Licensor, the media on which Product has been provided will be free from defects in materials and workmanship and that the Software will perform substantially in accordance with the Documentation or generally conform to the Product’s specifications published by the Licensor. Non-substantial variations of performance from the Documentation do not establish a warranty right. THIS LIMITED WARRANTY DOES NOT APPLY TO UPDATES AS APPLIED TO ANY MODIFIED PRODUCT, WHETHER OR NOT SUCH MODIFICATION IS PERMISSIBLE HEREUNDER, TRIAL AND EVALUATION VERSIONS, UPDATES, PRE-RELEASE, TRYOUT, PRODUCT SAMPLER, OR NOT FOR RESALE (NFR) COPIES OF PRODUCT. This limited warranty is void and your support right terminate if the defect has resulted from accident, abuse, or misapplication or any modification, whether or not such modification is permitted hereunder. No warranty is made as to the integrity, protection or safekeeping of any modification to the Products made by you upon installation of any of the Updates. To make a warranty claim, you must return the Product to the location where you obtained it along with proof of purchase within such sixty (60) day period of the license fee you paid for the Product. THE LIMITED WARRANTY SET FORTH IN THIS SECTION GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE ADDITIONAL RIGHTS WHICH VARY FROM JURISDICTION TO JURISDICTION.

5.2. Customer Remedies. The Licensor and its suppliers’ entire liability and your exclusive remedy for any breach of the foregoing warranty shall be at the Licensor’s option: (i) return of the purchase price paid for the license, if any, (ii) replacement of the defective media in which the Product is contained, or (iii) correction of the defects, “bugs” or errors within reasonable period of time. You must return the defective media to the Licensor at your expense with a copy of your receipt. Any replacement media will be warranted for the remainder of the original warranty period.

5.3. NO OTHER WARRANTIES. EXCEPT FOR THE FOREGOING LIMITED WARRANTY, AND FOR ANY WARRANTY, CONDITION, REPRESENTATION OR TERM TO THE EXTENT TO WHICH THE SAME CANNOT OR MAY NOT BE EXCLUDED OR LIMITED BY LAW APPLICABLE TO YOU IN YOUR JURISDICTION, THE PRODUCT IS PROVIDED “AS-IS” WITHOUT ANY WARRANTY WHATSOEVER AND THE LICENSOR MAKES NO PROMISES, REPRESENTATIONS OR WARRANTIES, WHETHER EXPRESSED OR IMPLIED, WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE, REGARDING OR RELATING TO THE PRODUCT OR CONTENT THEREIN OR TO ANY OTHER MATERIAL FURNISHED OR PROVIDED TO YOU PURSUANT TO THIS AGREEMENT OR OTHERWISE. YOU ASSUME ALL RISKS AND RESPONSIBILITIES FOR SELECTION OF THE PRODUCT TO ACHIEVE YOUR INTENDED RESULTS, AND FOR THE INSTALLATION OF, USE OF, AND RESULTS OBTAINED FROM THE PRODUCT. THE LICENSOR MAKES NO WARRANTY THAT THE PRODUCT WILL BE ERROR FREE OR FREE FROM INTERRUPTION OR FAILURE, OR THAT IT IS COMPATIBLE WITH ANY PARTICULAR HARDWARE OR SOFTWARE. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, LICENSOR DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT OF THIRD PARTY RIGHTS, INTEGRATION, SATISFACTORY QUALITY OR FITNESS FOR ANY PARTICULAR PURPOSE WITH RESPECT TO THE PRODUCT AND THE ACCOMPANYING WRITTEN MATERIALS OR THE USE THEREOF. SOME JURISDICTIONS DO NOT ALLOW LIMITATIONS ON IMPLIED WARRANTIES, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU. YOU HEREBY ACKNOWLEDGE THAT THE PRODUCT MAY NOT BE OR BECOME AVAILABLE DUE TO ANY NUMBER OF FACTORS INCLUDING WITHOUT LIMITATION PERIODIC SYSTEM MAINTENANCE, SCHEDULED OR UNSCHEDULED, ACTS OF GOD, TECHNICAL FAILURE OF THE SOFTWARE, TELECOMMUNICATIONS INFRASTRUCTURE, OR DELAY OR DISRUPTION ATTRIBUTABLE TO VIRUSES, DENIAL OF SERVICE ATTACKS, INCREASED OR FLUCTUATING DEMAND, AND ACTIONS AND OMISSIONS OF THIRD PARTIES. THEREFORE, THE LICENSOR EXPRESSLY DISCLAIMS ANY EXPRESS OR IMPLIED WARRANTY REGARDING SYSTEM AND/OR SOFTWARE AVAILABILITY, ACCESSIBILITY, OR PERFORMANCE. THE LICENSOR DISCLAIMS ANY AND ALL LIABILITY FOR THE LOSS OF DATA DURING ANY COMMUNICATIONS AND ANY LIABILITY ARISING FROM OR RELATED TO ANY FAILURE BY THE LICENSOR TO TRANSMIT ACCURATE OR COMPLETE INFORMATION TO YOU.

5.4. LIMITED LIABILITY; NO LIABILITY FOR CONSEQUENTIAL DAMAGES. YOU ASSUME THE ENTIRE COST OF ANY DAMAGE RESULTING FROM YOUR USE OF THE PRODUCT AND THE INFORMATION CONTAINED IN OR COMPILED BY THE PRODUCT, AND THE INTERACTION (OR FAILURE TO INTERACT PROPERLY) WITH ANY OTHER HARDWARE OR SOFTWARE WHETHER PROVIDED BY THE LICENSOR OR A THIRD PARTY. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT WILL THE LICENSOR OR ITS SUPPLIERS OR LICENSORS BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, LOSS OF DATA, LOSS OF GOODWILL, WORK STOPPAGE, HARDWARE OR SOFTWARE DISRUPTION IMPAIRMENT OR FAILURE, REPAIR COSTS, TIME VALUE OR OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE PRODUCT, OR THE INCOMPATIBILITY OF THE PRODUCT WITH ANY HARDWARE SOFTWARE OR USAGE, EVEN IF SUCH PARTIES HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT WILL LICENSOR’S TOTAL LIABILITY TO YOU FOR ALL DAMAGES IN ANY ONE OR MORE CAUSE OF ACTION, WHETHER IN CONTRACT, TORT OR OTHERWISE EXCEED THE AMOUNT PAID BY YOU FOR THE PRODUCT. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE EXTENT THAT APPLICABLE LAW PROHIBITS SUCH LIMITATION. FURTHERMORE, BECAUSE SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

6. Indemnification

6.1. Indemnification for Violations. Your Operating of the Product, your accessing your account with Licensor and your entering into this Agreement constitutes your consent and agreement to defend, indemnify and hold harmless Licensor and its affiliated companies, employees, contractors, officers and directors from any claim or demand, including reasonable attorney’s fees arising out of your use of the Product in violation of this Agreement.

SPECIAL PROVISION APPLICABLE TO U.S. PERSONS AND ENTITIES.

7. U.S. Government-Restricted Rights.

7.1. Notice to U.S. Government End Users. The Product and accompanying Documentation are deemed to be “Commercial Items,” as that term is defined at 48 C.F.R. par. 2.101, consisting of “Commercial Computer Software” and “Commercial Computer Software Documentation,” respectively, as such terms are used in 48 C.F.R. par. 12.212 or 48 C.F.R. par. 227.7202, as applicable. Consistent with 48 C.F.R. par. 12.212 or 48 C.F.R. par. 227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users (a) only as Commercial Items and (b) with only those rights, including any use, modification, reproduction, release, performance, display or disclosure of the Product and accompanying Documentation, as are granted to all other end users pursuant to the terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States.

7.2. Export Restrictions. You acknowledge and agree that the Product may be subject to restrictions and controls imposed by the Export Administration Act and the Export Administration Regulations of the United States (the “Acts”). You agree and certify that neither the Product nor any direct product thereof is being or will be used for any purpose prohibited by the Acts. You may not Operate, download, export, or re-export the Product (a) into, or to a national or resident of, any country to which the United States has embargoed goods, or (b) to anyone on the United States Treasury Department’s list of Specially Designated Nationals or the U.S. Commerce Department’s Table of Deny Orders. By downloading or using the Product, you are representing and warranting that you are not located in, under the control of, or a national or resident of any such country or on any such list. You acknowledge that it is your sole responsibility to comply with any and all government export and other applicable laws and that the Licensor has no further responsibility for such after the initial license to you. You warrant and represent that neither the U.S. Commerce Department, Bureau of Export Administration nor any other U.S. federal agency has suspended, revoked or denied your export privileges.

8. Your Information and the Licensor’s Privacy Policy

8.1. Privacy Policy. You acknowledge receipt of and agree to the Licensor’s privacy statement which is made available to you in connection with installation and is set forth in full at http://www.elcomsoft.com/privacy.html. You hereby expressly consent to the Licensor’s processing of your personal data (which may be collected by the Licensor or its distributors) according to the Licensor’s current privacy policy as of the date of the effectiveness hereof which is incorporated into this Agreement by reference. By entering into this Agreement, you agree that the Licensor may collect and retain information about you, including your name and email address. The Licensor employs other companies and individuals to perform certain functions on its behalf. Examples include fulfilling orders, delivering packages, sending postal mail and e-mail, removing repetitive information from customer lists, analyzing data, providing marketing assistance, processing credit card payments, and providing customer service. They have access only to personal information needed to perform their functions, but may not use it for other purposes. The Licensor publishes a privacy policy on its web site and may amend such policy from time to time in its sole discretion. You should refer to the Licensor’s privacy policy prior to agreeing to this Agreement for a more detailed explanation of how your information will be stored and used by the Licensor. If “you” are an organization, you will ensure that each member of your organization (including employees and contractors) about whom personal data may be provided to the Licensor has given his or her express consent to the Licensor’s processing of such personal data. Personal data will be processed by the Licensor or its distributors in the country where it was collected.

8.2. Public Announcements. The Licensor may identify you to the public as a customer of the Licensor and describe in a customer case study the services and solutions delivered by the Licensor to you. The Licensor may also issue one or more press releases, containing an announcement of the execution and delivery of this Agreement and/or the implementation of the Product by you. Nothing contained in this Section shall be construed as an obligation by you to disclose any of your proprietary or confidential information to any third party. In addition, you may opt-out from this Section by writing an opt-out request to the Licensor at info@elcomsoft.com.

9. Miscellaneous.

9.1. Governing Law; Jurisdiction and Venue. This Agreement shall be governed by and construed and enforced in accordance with the laws of the Russian Federation without reference to conflicts of law rules and principles. To the extent permitted by law, the provisions of this Agreement shall supersede any provisions of the Uniform Commercial Code as adopted or made applicable to the Products in any competent jurisdiction. This Agreement shall not be governed by the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly disclaimed and excluded. The courts within the Russian Federation shall have exclusive jurisdiction to adjudicate any dispute arising out of this Agreement. You agree that this Agreement is to be performed in the Russian Federation and that any action, dispute, controversy, or claim that may be instituted based on this Agreement, or arising out of or related to this Agreement or any alleged breach thereof, shall be prosecuted exclusively in the courts in of the Russian Federation and you, to the extent permitted by applicable law, hereby waive the right to change venue to any other state, county, district or jurisdiction; provided, however, that the Licensor as claimant shall be entitled to initiate proceedings in any court of competent jurisdiction.

9.2. Period for Bringing Actions. No action, regardless of form, arising out of the transactions under this Agreement, may be brought by either party hereto more than one (1) year after the cause of action has occurred, or was discovered to have occurred, except that an action for infringement of intellectual property rights may be brought within the maximum applicable statutory period.

9.3. Entire Agreement; Severability; No Waiver. This Agreement is the entire agreement between you and Licensor and supersedes any other prior agreements, proposals, communications or advertising, oral or written, with respect to the Product or to subject matter of this Agreement. You acknowledge that you have read this Agreement, understand it and agree to be bound by its terms. If any provision of this Agreement is found by a court of competent jurisdiction to be invalid, void, or unenforceable for any reason, in whole or in part, such provision will be more narrowly construed so that it becomes legal and enforceable, and the entire Agreement will not fail on account thereof and the balance of the Agreement will continue in full force and effect to the maximum extent permitted by law or equity while preserving, to the fullest extent possible, its original intent. No waiver of any provision or condition herein shall be valid unless in writing and signed by you and an authorized representative of Licensor provided that no waiver of any breach of any provisions of this Agreement will constitute a waiver of any prior, concurrent or subsequent breach. Licensor’s failure to insist upon or enforce strict performance of any provision of this Agreement or any right shall not be construed as a waiver of any such provision or right.

9.4. Contact Information. Should you have any questions concerning this Agreement contact us at legal@elcomsoft.com.

© 1998-2004 ElcomSoft Co. Ltd. All rights reserved. The Product, including the Software and any accompanying Documentation, are copyrighted and protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties.


8. Техническая поддержка

 Top Previous

For Technical Support please contact us by E-Mail at support@elcomsoft.com.

In the subject of your Mail, please write:

"EDPR x.y",

where x.y is the version number, followed by problem, suggestion or whatever else.

You can also contact our Customer Service Department at info@elcomsoft.com and sales department at sales@elcomsoft.com.

Our Fax numbers:

+1 866 448-2703 (US and Canada, toll-free)
+44 870 831-2983 (UK)
+49 692 557-7249 (Germany)

Please write in English language only.