Log Monitor

Log Monitor - это программа для контроля за изменением файлов и каталогов, способная при достижении заданных условий выполнить ряд действий. Основное назначение программы - автоматизировать рутинные операции, основанные на файловом обмене, а также отслеживать состояние процессов, основываясь на их файловой активности.

Подробнее о программе рассказывается на странице «Введение» данного раздела.

  • Раздел «Главное окно» описывает внешний вид и основное меню главного окна.
  • Раздел «Настройка мониторинга» описывает, что нужно сделать для настройки мониторинга за отдельным файлом и деревом каталогов.
  • Раздел «Действия» дает исчерпывающее описание операций, которые могут быть выполнены Лог Монитором.
  • Раздел «Справочные материалы» предназначен для детального изучения особенностей программы и содержит описание аргументов действий, различных форматов и т.д.
  • Раздел «Свойства программы» содержит описание настроек собственно Лог Монитора.


Введение

Log Monitor периодически проверяет дату и время изменения указанных файлов, в т.ч. в дереве директорий. Если время модификации какого-либо файла в течение заданного интервала изменилось (не изменилось), происходит запуск внешней программы, звуковое или визуальное оповещение и т.д. Для директорий отслеживается изменение, добавление или удаление файлов, осуществляется выборка файлов по возрасту.

Работает под Windows 95/98/NT/2000, freeware.

Что умеет программа:

  • мониторятся одновременно несколько файлов или каталогов, многопоточность;
  • при наступлении заданного условия выполняется ряд настраиваемых действий;
  • гибкая настройка выполняемых действий, параметры могут включать информацию об изменившихся файлах (путь, размер, время);
  • работа по расписанию - настройка рабочих временных интервалов;
  • возможность использовать программу как планировщик (scheduler), запуск приложений в определенное время и через определенные интервалы;
  • минимизируется в System Tray;
  • потребляет минимум ресурсов - насколько это возможно;
  • удобный интерфейс настройки параметров мониторинга.

Позиционируется программа прежде всего для администраторов различных процессов на локальной сети, а также для пользователей ЛВС.

Ознакомьтесь с основными принципами работы программы.


Принципы работы

Принципы работы программы

Цель программы - выявить файлы, соответствующие условиям мониторинга, и передать атрибуты найденных файлов действиям в виде параметров, для дальнейшей обработки. Проверка условий производится через заданные интервалы времени, периодически.

Условия мониторинга разбиваются на ряд последовательных проверок (в порядке выполнения):

Рабочий интервал - текущее системное время должно находиться в пределах заданных временных интервалов (время суток, дни недели, дни месяца);

Фильтры файлов и каталогов - условия будут проверяться только для файлов (каталогов), соответствующих заданным фильтрам (включающие и исключающие маски). Сканирование подкаталогов, не отвечающих фильтру, не производится;

Условия мониторинга - собственно проверка условий (файл изменился, добавился, был удален, а также обратные этим условия).

Файлы, соответствущие условиям мониторинга, формируют список файлов и передаются действиям. Если файлы не выявлены, то действия не производятся.

Действия получают доступ к информации о файлах с помощью настраиваемых аргументов. Перед выполнением действий вместо аргументов подставляются реальные значения (имя файла, размер, время и т.д.). Количество действий (в т.ч. одного типа), связанных с процессом мониторинга, не ограниченно.

Программа может выполнять несколько заданий одновременно, каждое задание исполняется в собственном потоке, независимом от других. Количество заданий не ограниченно.


Диалог «О программе»

О программе

Окно «О программе» показывает, с какой версией вы работаете, а также дату компиляции данной версии.

Вы также можете написать письмо автору - мне, нажав на подсвеченную ссылку, либо посетить домашнюю страницу программы. Будут запущены почтовый клиент и броузер, установленые в вашей системе по умолчанию на протоколы mailto и http.


Главное окно

Данный раздел содержит описание основного окна программы, меню, а также статуса процессов мониторинга, отображаемых в главном окне.


Основное окно

Основное окно программы содержит список файлов и директорий, за которыми осуществляется наблюдение, и является «центром управления» всех процессов.

Доступ к настройкам и командам программы может быть осуществлен через основное меню. Команды меню продублированы на панели инструментов и в контекстном меню списка процессов.

Список процессов мониторинга файлов (директорий) состоит из следующих колонок:

  • статус процессов мониторинга;
  • название файла или директории (плюс маска файлов для директорий);
  • интервал, через который проводится проверка (в секундах). В скобках указывается время, оставшееся до очередной проверки;
  • действия, которые будут совершены при достижения заданных условий;
  • произвольное описание мониторинга.

Список процессов позволяет выделить несколько записей и производить действия над группой процессов (удаление, остановку и возобновление). По нажатию правой клавиши мыши появляется контекстное меню.

Панель статуса содержит следующую информацию:

Активен | Задача активна - рабочий режим.
Остановлен | Мониторинг всех файлов приостановлен.
Изменен | Настройки были изменены и все еще не сохранены.


Статус процессов мониторинга

Процессы мониторинга могут находиться в различных состояниях. Состояния отображаются соответствующими иконками в списке процессов в основновном окне.

Состояние процесса
В данный момент производится проверка условий.
Предыдущая проверка условий закончилась, условия не выполнены. Процесс находится в состоянии ожидания момента следующей проверки.
В данный момент выполняются действия. Процесс ждет окончания (запуска) действий.
Предыдущая проверка условий закончилась, условия выполнены. В зависимости от настроек, могли быть выполнены указанные действия. Процесс перешел на следующий цикл ожидания проверки.
Предыдущая проверка условий закончилась, контрольный путь не существует. В зависимости от настроек может быть произведено действие. Процесс перешел на следующий цикл ожидания проверки.
Процесс находится в состоянии ожидания рабочего интервала времени. При наступлении рабочего интервала процесс перейдет в состояние проверки условий.
Процесс находится в состоянии паузы. Никаких проверок не производится.


Описание меню

Команда | Клавиша | Описание

Меню «Файл»
Новая конфигурация | Ctrl+N | Создание нового (пустого) файла настроек; имя по умолчанию - Untitled.mon.
Загрузить настройки... | Ctrl+O | Загрузка файла настроек. Текущий список файлов очищается.
Сохранить настройки | Ctrl+S | Сохранение настроек на диске. Если сохраняется Untitled.mon, то запрашивается имя файла.
Сохранить как... | Сохранение файла настроек под другим именем.
Добавить из файла... | Добавление процессов в текущий список из другого файла настроек.
Сохранить выделенные... | Сохранение выбранных элементов списка в файл настроек.
Выход | Alt+X | Выход из программы.
Если во время закрытия текущего файла настроек он окажется измененным, будет предложено сохранить файл на диске.

Меню «Правка»
Создать копию... | Ctrl+C | Копирование настроек выделенного процесса; открывается диалог редактирования настроек.
Добавить разделитель | Добавление разделителя в список процессов. Разделитель используется для группировки процессов по смыслу.
Переместить вверх | Alt+Up | Переместить элемент списка вверх.
Переместить вниз | Alt+Down | Переместить элемент списка вниз.
Выделить все | Ctrl+A | Выделение всех процессов в списке файлов (директорий).

Меню «Мониторинг»
Добавить файл... | Ins | Добавление процесса мониторинга файла; открывается диалог редактирования настроек для файла.
Добавить каталог... | Alt+Ins | Добавление процесса мониторинга директории; открывается диалог редактирования настроек для директории.
Удалить | Del | Удаление процесса мониторинга файла или директории из списка процессов. Если установлена соответствующая опция в настройках программы, то запрашивается подтверждение на удаление.
Свойства... | Enter | Настройка параметров процесса мониторинга; открывается диалог редактирования настроек.
Приостановить мониторинг | Ctrl+P | Приостановка (пауза) процесса мониторинга. Процесс становится неактивным, проверка на условия не производится.
Продолжить мониторинг | Ctrl+R | Возобновление приостановленного процесса с момента остановки.
Проверить сейчас | Ctrl+Q | Форсировать проверку условий мониторинга до окончания временного интервала.
Выполнить действия сейчас | Ctrl+D | Принудительно выполнить действия, которые заданы для процесса мониторинга.
Остановить все процессы | Приостановить все процессы. Используется для временного запрещения любых действий программы.
Возобновить все процессы | Возобновить работу процессов, не имеющих статус «пауза», после приостановки всех процессов.
Выключить звук | Esc | Остановить все звуки, генерируемые Лог Монитором в действиях.

Меню «Свойства»
Панель кнопок
Панель статуса 		Включение (выключение) панели инструментов и панели статуса.
Свойства программы... | Настройка параметров программы.
Язык... | Выбор языка интерфейса программы из списка доступных языков. Переключение происходит «на лету».

Меню «Помощь»
Разделы справки | F1 | Вызвать справку по программе.
Послать Email автору | Послать письмо автору. Запускается почтовый клиент, установленный в системе по умолчанию.
Домашняя страница | Посетить домашнюю страницу программы. Запускается броузер, установленный в системе по умолчанию.
О программе... | Диалог «О программе».

Контекстное меню Контекстное меню

По нажатию правой клавиши мыши на списке процессов появляется контекстное меню процесса (приведено справа). Если никакой из процессов не выделен, большинство команд меню недоступно. Меню дублирует команды, доступные из главного меню.

Меню System Tray

Tray Menu Если включена опция «Минимизировать в системную панель», то по нажатию правой кнопки мыши на иконке Log Monitor'а активизируется приведенное слева меню.


Настройка мониторинга

Различаются мониторинг файла и мониторинг каталога: объектом первого является одиночный файл, объектом второго - дерево каталогов. Различаются таже условия мониторинга и некоторые специальные настройки.

У процессов мониторинга файла и каталога есть и общие настройки:

  • Действия - настройка действий, производимых при срабатывании условий;
  • Расписание - настройка расписания, по которому производится проверка.


Мониторинг файла

Окно свойств мониторинга файла содержит настройки процесса мониторинга, разбитые на несколько закладок:

  • Условия - настройка условий запуска действий;
  • Свойства - содержит общие настройки мониторинга, относящиеся к объекту мониторинга.


Свойства файла (Условия)

Условия мониторинга файла

Закладка Conditions (условия)

Выполнить действия:

  • Если файл не изменился - выполнить действия, если с момента предыдущей проверки время модификации файла не изменилось.
  • Если файл изменился - выполнить действия, если с момента предыдущей проверки время модификации файла изменилось.

При первой проверке время модификации файла сравнивается с текущим системным временем. Если время файла больше, чем величина «текущее время минус интервал мониторинга», то считается, что файл изменился, иначе - не изменился.

Игнорировать результаты первой проверки - если опция установлена, результаты первой после запуска проверки игнорируются. Эта возможность может быть полезна, если Лог Монитор запускается при загрузке машины, а контролируемый файл еще не успевает обновиться.

Выполнить действия, если файл не существует - при установленной опции условие считается выполненным, если контролируемый файл не существует. Соответственно, будут выполнены указанные действия. Эта опция удобна, когда нужно запускать программы с указанным интервалом независимо от внешних условий. В этом случае имя файла не указывается и срабатывает условие «файл не существует».

Проверять файл на нарушение совместного доступа - если опция указана, то при срабатывании условия контролируемый файл будет проверяться на возможность совместного доступа к нему. Если файл блокирован для доступа, то возможны следующие варианты:

  • Пропустить действия - не выполнять указанных действий и перейти на следующий цикл проверки условий;
  • Ждать разблокирования - ждать разблокирования файла, затем выполнить действия. Периодичность проверки файла на разблокирование - 100 мс.


Свойства файла (Свойства)

Мониторинг файла

Закладка Options

Файл - имя файла, за которым нужно следить. Можно указывать полный или относительный от текущего каталога путь. Допускается пустое поле, результатом проверки условия тогда будет «файл не существует». Возможно также указать шаблон имени (wildcard), но объектом мониторинга станет только один файл по маске, расположенный в файловой системе первым. Поле может содержать аргументы, не зависящие от файлов, например, системную дату, переменную окружения и т.п.

Описание - произвольное описание процесса мониторинга.

Интервал - время в секундах, через которое будет производиться проверка условия. Минимальное значение - 1 с, максимальное - 2147483647 с (ок. 68 лет). С помощью кнопки справа от поля ввода вы можете выбрать одно из предустановленных значений.

Стартовать немедленно - при установленной опции процесс мониторинга стартует сразу; при выключенной - процесс добавляется приостановленным со статусом «пауза». Опция доступна только при добавлении нового процесса.


Мониторинг каталога

Окно свойств мониторинга каталога содержит настройки процесса мониторинга, разбитые на несколько закладок:

  • Условия - настройка условий запуска действий;
  • Маска файлов - настройка масок файлов и каталогов для уточнения объекта мониторинга;
  • Свойства - содержит общие настройки мониторинга, относящиеся к объекту мониторинга.


Свойства каталога

Мониторинг каталога

Закладка «Свойства»

Каталог для мониторинга - имя каталога, за которым нужно следить. Можно указывать полный путь (рекомендуется) или относительный от текущего каталога путь. Возможно использование UNC (universal naming convention): \\<server name>\<share name>, например \\server\disk_c\path. Поле может содержать аргументы, не зависящие от файлов, например, системную дату, переменную окружения и т.п.

Описание - произвольное описание процесса мониторинга.

Интервал - время в секундах, через которое будет производиться проверка условия. Минимальное значение: 1 с, максимальное: 2147483647 с (ок. 68 лет). С помощью кнопки справа от поля ввода вы можете выбрать одно из предустановленных значений.

В режиме реального времени - установите эту опцию, чтобы проверка условий производилась сразу же после изменения статуса указанного каталога (изменения файла, удаления и т.д.). По окончании интервала мониторинга также будет проведена проверка условий.

Внимание: оповещение об изменении статуса полностью поддерживается только ОС Windows NT/2000, в том числе для сетевых каталогов. Windows 95/98 оповещает об изменении только для локальных дисков. Сервера Novell Netware также не поддерживают механизма оповещения в реальном времени.

Не устанавливайте режим реального времени для больших и часто обновляемых каталогов, где сканирование файлов может занимать длительное время.

Минимальный интервал между проверками - время в секундах между двумя самыми близкими проверками условий при мониторинге в режиме реального времени. Параметр может использоваться при мониторинге больших и часто изменяемых каталогов, чтобы минимизировать нагрузку при сканировании. Например, можно установить интервал мониторинга в 600 секунд, а минимальный интервал - в 60 секунд. Это значит, что при активном изменении каталога сканирование будет производиться не чаще, чем через 60 секунд, а при длительном отсутствии изменений - не чаще, чем через 600 секунд.

Проверять условия, только если путь существует - при установленной опции перед сканированием определяется доступность объекта мониторинга. Если путь мониторинга не существует, то сканирование и проверка условий не производится. Опция позволяет более гибко следить за сетевыми ресурсами, которые могут быть временно недоступны.

Сохранять статус файлов на диске между запусками - данная опция позволяет сохранять статус файлов между запусками Лог Монитора. Сохранение статуса производится после каждого сканирования объекта мониторинга. Если опция установлена, то Лог Монитор при запуске загружает предыдущий статус файлов с диска, и после первого сканирования производится проверка условий. Каталог по умолчанию, куда сохраняются файлы статуса, задается в окне настроек программы.

Каталог кэша - каталог, куда будут сохраняться файлы статуса при включенной опции «Сохранять статус файлов между запусками». У текущего пользователя должны быть права на запись в этот каталог.

Стартовать немедленно - при установленной опции процесс мониторинга стартует сразу; при выключенной - процесс добавляется приостановленным со статусом «пауза». Опция доступна только при добавлении нового процесса.

Сбросить статус файлов - опция доступна только при редактировании параметров мониторинга. При установленной опции (по умолчанию) предыдущий статус файлов сбрасывается, производится начальное сканирование каталогов. При выключенной опции статус файлов сохраняется, и при сканировании объекта мониторинга производится проверка условий. Не рекомендуется выключать эту опцию, если при редактировании параметров изменились настройки объекта мониторинга или условия.


Условия (возраст файлов)

Закладка «Условия»

Следить за... - выбор вида условий. Кокретные параметры условия зависят от выбранного типа. Поддерживаемые типы условий:

  • Изменение статуса каталога - следить за изменением файлов в каталоге, например, за добавлением или удалением файлов.
  • Время модификации файлов - следить за файлами по их возрасту, отделяя старые файлы.

Игнорировать файлы, открытые на запись - не включать в проверку файлы, открытые на запись. Независимо от результатов проверки, такие файлы не будут передаваться в действия. Если заблокированный файл был изменен, то условие срабатывает во время следующей проверки.

Выполнить действия

Если файл старее чем - максимальное время в секундах, в течение которого файл должен не обновляться, чтобы условие сработало. Проверяется время модификации файла. Если время модификации файла меньше, чем текущее время минус интервал, то выполняются действия.

Игнорировать старые файлы, добавленные в течение интервала - добавленные файлы со временем модификации, меньшем, чем заданное («старые» файлы), не должны влиять на результаты проверки в течение интервала старения. После окончания этого интервала к таким файлам применяется общий алгоритм проверки.


Маски файлов

Фильтры на файлы и каталоги

Закладка «Фильтры»

Маски файлов - шаблон имени файлов, которые должны быть включены в проверку условий. Допустимо указывать несколько масок, разделенных точкой с запятой. Внимание: синтаксис маски отличается от принятых в DOS масок, например, шаблон *.* не будет маскировать файлы без расширения. Наиболее общая маска - *. Читайте подробнее о формате масок в разделе «Справочные материалы». Поле может содержать аргументы, не зависящие от файлов, например, системную дату, переменную окружения и т.п. Один из способов использования аргументов - загрузка списка масок из файла с помощью переменной %Include="file". Маски в этом файле должны быть разделены переводами строки или точками с запятой.

Исключающие маски файлов - шаблон имени файлов, которые должны не рассматриваться при проверке условий. Допустимо указывать несколько масок, разделенных точкой с запятой. Читайте подробнее о формате масок. Поле может содержать аргументы.

Включая подкаталоги - включает в облать проверки дерево подкаталогов начиная от указанного каталога.

Маска каталогов - маска имени подкаталогов, которые будут включены в область проверки. Допустимо указывать несколько масок, разделенных точкой с запятой. Читайте подробнее о формате масок в разделе «Справочные материалы». Поле может содержать аргументы.

Исключающая маска - шаблон имени подкаталогов, которые должны быть исключены из области проверки. Допустимо указывать несколько масок, разделенных точкой с запятой. Читайте подробнее о формате масок. Поле может содержать аргументы.

Включая скрытые и системные файлы - при включенной опции проверяются файлы с атрибутами «скрытый» или «системный».

Следить за каталогами - отслеживать изменения собственно каталогов как файлов, например фиксировать появление или удаление каталогов.

Сравнивать список масок с полными путями файлов - при включенной опции сравнение маски производится с полным путем файла (каталога), а не только с именем файла. Опция позволяет более однозначно включать или исключать файлы и каталоги по их полным путям.


Список действий

Закладка «Действия»

Список действий содержит перечень действий, которые должны быть выполнены при достижении заданных условий. Колонка «Параметры» показывает основные параметры действий. Колонка переключателей в списке активирует либо отменяет (не удаляя) конкретное действие.

Возможные действия:

  • создать файл-список;
  • выполнить программу;
  • вывести окно-оповещение;
  • проиграть звук;
  • файловые операции;
  • закрыть программу.

Новое... - добавить новое действие. При нажатии на кнопку появляется меню со списком возможных действий. Выбор одного из значений открывает диалог редактирования действия. Возможно добавление неограниченного количества действий, в том числе одинакового типа.

Свойства - при нажатии на кнопку появляется диалог редактирования свойств действия. Диалог также можно вызвать двойным щелчком мышкой на списке действий.

Удалить - удалить выбранное действие из списка.

Вверх/Вниз - переместить выбранное действие вверх или вниз на одну позицию в списке. Порядок действий в списке определяет очередность их запуска. Часть действий выполняются синхронно по отношению к процессу мониторинга, часть - асинхронно, а часть - в зависимости от настроек. Синхронное выполнение означает, что поток мониторинга будет ждать завершения действия, прежде чем перейти к другому действию либо к продолжению мониторинга. При асинхронном выполнении действие запускается в новом потоке, при этом основной поток сразу же переходит к следующему действию (либо к следующему циклу мониторинга).

Помещать в параметры данные только одного файла - при обработке параметров, передаваемых в виде аргументов действию, ограничиваться данными первого из группы файлов, подпадающих под условия. Устанавливайте эту опцию, если нет необходимости различать несколько файлов между собой, например, если в качестве аргумента используется одинаковый для всех найденных фалов путь, или текущее системное время. При большом количестве файлов это позволит сэкономить ресурсы. Опция доступна только при мониторинге каталога.

Запускать действия только раз на последовательность выполненных условий - установите эту опцию, если вы хотите, чтобы действия запускались только при первом срабатывании условий, например, если это сообщение об ошибке, и вы не хотите, чтобы это сообщение повторялось несколько раз подряд. Последовательность «незапусков» прерывается первым невыполненным условием.

Выполнить действия один раз и перейти в паузу - при установленной опции процесс после выполнения всех действий переходит в состояние «пауза». Опция может использоваться, если действия должны быть выполнены однократно.


Работа по расписанию

Закладка «Расписание»

Рабочее время - включите эту опцию, если хотите, чтобы проверка условий осуществлялась только в заданные интервалы времени. При выключенной опции Log Monitor работает круглосуточно.

Поля ввода времени - поля предназначены для ввода интервалов времени. Допустимый формат - ЧЧ:ММ:СС. Начальное значение может быть больше конечного. После ввода интервала времени, его нужно добавить в список интервалов.

Добавить - нажатие на кнопку добавляет введенный интервал в список интервалов.

Удалить - нажатие на кнопку удаляет интервал из списка, при этом поля ввода принимают значения удаленного интервала.

Список интервалов - список содержит интервалы времени, когда Log Monitor будет проверять условия данного процесса мониторинга. Ограничений на количество интервалов нет. Во все остальное время процесс будет находиться в «спящем» состоянии. Если список интервалов пуст, то проверка будет производиться круглосуточно.

Дни недели - вы можете отметить те дни недели, когда Log Monitor будет проверять условия мониторинга. Во все остальные дни процесс мониторинга будет находиться в «спящем» состоянии.

Вкл. - кнопка позволяет отметить все дни недели сразу.

Снять - кнопка позволяет снять отметку сразу со всех дней недели.

Дни месяца - в этом поле ввода можно ввести календарные дни месяца, когда должна производиться проверка условий. Во все остальные дни процесс будет находиться в «спящем» состоянии. Дни месяца могут перечисляться через запятую, а также указываться интервалом через дефис, например: «1,3,5-10,23».

Нерабочие даты - список дат, разделенных запятыми, в формате дд.мм.гггг. В эти даты процесс будет находиться в «спящем» состоянии, независимо от установок дней недели.

Рабочие даты - список дат, разделенных запятыми, в формате дд.мм.гггг. В эти даты процесс будет находиться в активном состоянии, независимо от установок дней недели. Рабочие даты имеют приоритет перед нерабочими, т.е. если одна и та же дата есть в обоих полях, то день считается рабочим.


Действия

При наступлении заданных условий последовательно выполняются операции, определенные на закладке «Действия» окна свойств процесса мониторинга. Часть действий выполняются синхронно по отношению к процессу мониторинга, часть - асинхронно, а часть - в зависимости от настроек. Синхронное выполнение означает, что поток мониторинга будет ждать завершения действия, прежде чем перейти к другому действию либо к продолжению мониторинга. При асинхронном выполнении действие запускается в новом потоке, при этом основной поток сразу же переходит к следующему действию (либо к следующему циклу мониторинга).

Действия могут быть следующих типов:

  • создать файл-список;
  • выполнить программу;
  • вывести окно-оповещение;
  • проиграть звук;
  • файловые операции;
  • закрыть программу.

Параметры действий (аргументы) могут формироваться в зависимости от данных, полученных в ходе проверки условий, например, имен файлов, времени модификации файлов и так далее. Читайте подробнее о переменных-аргументах.

Общими для всех действий являются следующие параметры:

Действие разрешено - флаг позволяет временно отключить или разрешить действие.

Задержка перед запуском - время в миллисекундах, которое нужно выдержать перед запуском данного действия. Этот параметр может использоваться для синхронизации операций между собой.

Комментарий - произвольный текст, описывающий данное действие.


Список файлов

Действие «Создать файл-список» создает (дополняет) текстовый файл на основании результатов проверки условий. Основное назначение действия - сформировать список файлов для его передачи внешнему приложению, либо для протоколирования операций с файлами.

Имя файла - имя выходного текстового файла, в который будут выводиться записи. Любое допустимое для операционной системы имя файла: абсолютный или относительный путь, UNC. Поле может содержать аргументы, полученные при формировании списка файлов, подпадающих под условия.

Записи - шаблон построчного или однократного вывода в файл. Поле может содержать аргументы, полученные при формировании списка файлов. Если поле не содержит переменных цикла и не разрешено их использовать (флаг ниже), то файл строится построчно, одна строка содержит данные только одного файла. Если в шаблоне есть переменные цикла и разрешено их использовать, то выводимые данные строятся один раз для всех файлов.

В текстовый файл выводятся строки, сформированные для всех файлов, полученных при проверке, если не указана опция «Помещать в параметры данные только одного файла» на закладке «Действия».

Разрешить использовать переменные цикла в записях - нужно ли обрабатывать переменные цикла %( и %), указанные в поле «Записи». (Флаг добавлен для совместимости с предыдущими версиями.)

Пример 1. Если шаблон не содержит переменных цикла:

[%SysDate="yyyy-mm-dd hh:nn:ss"]%Chr="9"%File%Chr="9"File was %Added="added"%Changed="changed"

то для одного изменившегося и одного добавленного файлов, выявленных при проверке условий, в выходном файле будут сформированы записи:

[2001-03-22 01:42:22] | c:\temp\dir2\file1.doc | File was changed
[2001-03-22 01:42:23] | c:\temp\dir1\file2new.doc | File was added

Пример 2. Если шаблон содержит агрументы цикла:

[%SysDate="yyyy-mm-dd hh:nn:ss"]%Chr="10"%(%File%Chr="9"File was %Added="added"%Changed="changed"%Chr="10"%)

то в выходном файле будут сформированы записи:

[2001-03-22 01:42:22] |
c:\temp\dir2\file1.doc | File was changed
c:\temp\dir1\file2new.doc | File was added

Если файл уже существует - если выходной файл уже существет, то возможны два варианта действий:

  • Перезаписать файл - создать новый файл без сохранения данных имеющегося файла;
  • Добавить к концу - добавлять записи в конец уже имеющегося файла, сохраняя предыдущие данные.

Удалить файл после завершения всех действий - при включенной опции по окончании всех действий созданный выходной файл удаляется.


Запуск программы

Действие «Запуск программы» позволяет выполнить внешнее приложение и передать ему данные о файлах, полученных при проверке условий.

Команда - исполняемый файл, без указания параметров. Это может быть как программа, так и командный файл. В качестве команды может быть также указан файл любого типа, с которым ассоциирована какая-либо программа. Для имени файла допустимо использовать UNC. Если указан не полный путь, файл будет определяться относительно текущего каталога.

В данном поле могут указываться переменные окружения (environment variables), которые будут замещаться их значениями. Например, переменная %COMSPEC% для Windows NT будет заменена на CMD.EXE, а для Windows 95 - на COMMAND.COM.

Замечание: если вы исполняете командные файлы под Windows 95/98, то вместо указания имени командного файла используйте командный интерпретатор системы явным образом:

%COMSPEC% /C <commands.bat> [params]

В противном случае, по окончании работы командного файла будет оставаться окно DOS-сессии.

Параметры - параметры, передаваемые запускаемой программе в командной строке. Параметры должны разделяться пробелами. Параметры могут содержать аргументы, полученные для файлов, подпадающих под условия. Чтобы передать в параметрах кавычку ("), необходимо каждую кавычку заключить в две кавычки. Например, если вы зададите

param """quoted param"""

то в программу будут переданы два параметра: param и "quoted param".

Стартовать в - рабочий каталог программы. Если рабочий каталог не задан, будет использован текущий каталог. В данном поле могут указываться переменные окружения (environment variables), которые будут замещаться их значениями, например, %TEMP%.

Режим - опция определяет, в каком виде будет запущено приложение:

Обычный - Окно приложения активизируется и показывается. Если окно минимизировано или максимизировано, система устанавливает его размер в первоначальный.

Минимизировать - Окно приложения минимизируется; активизируется следующее по порядку окно.

Развернуть - Окно приложения максимизируется.

Скрыть - окно скрывается (не показывается).

Ждать завершения - при установленной опции процесс мониторинга ожидает окончания запущенного приложения. Только после закрытия задачи процесс переходит к следующим действиям или продолжению мониторинга.

Закрыть программу после (сек.) выполнения - время в секундах, через которое нужно завершить запущенную программу. Может использоваться, если программа должна быть завершена, но не может сделать это сама.

Метод помещения переменных - определяет, каким образом будут обработаны переменные при помещении их в параметры программы, и сколько раз будет исполнена программа:

По одному файлу - приложение будет запущено столько раз, сколько было получено файлов при проверке условий, по одному запуску на файл. При каждом запуске в параметры программы будут помещаться данные следующего файла, согласно заданным аргументам.

Несколько файлов - в параметры будут помещены данные сразу нескольких файлов, если агрументы заключены в переменные цикла, например:

%(%File %)

где "%(" означает начало цикла по файлам, а "%)" - конец цикла.

Опция «Максимальное число файлов в параметрах» определяет максимальное количество файлов, помещаемых в параметры за один раз. Ноль означает, что в параметры будут помещены данные сразу всех файлов.

Приложение будет запускаться, пока все файлы не будут обработаны. Например, если по итогам проверки было найдено 15 файлов, а максимальное число файлов в параметрах установлено в 4, то приложение будет запущено 4 раза.


Окно-оповещение

Действие предназначено для вывода окна-оповещения (popup window) на локальном компьютере. Сообщение выводится в стандартном окне (Message Box) операционной системы.

Сообщение - текст сообщения, выводимого в окне-оповещении. Сообщение может содержать аргументы, полученные для файлов, подпадающих под условия.

Замечание: для разбиения текста сообщения на строки вы можете использовать символ перевода строки с помощью аргумента %Chr:

Строка 1%Chr="10"Строка 2

Ждать реакции пользователя для продолжения - при установленной опции процесс мониторинга, чтобы перейти к последующим действиям или к следующему циклу мониторинга, будет ожидать, когда пользователь закроет окно-оповещение. Если опция не установлена, то сразу после вывода окна-оповещения процесс переходит к последующим действиям либо к следующему циклу проверки условий.

Пропустить действия, если нажата "No" - если опция установлена, окно-оповещение будет содержать две кнопки «Да/Нет» вместо одной «OK». При нажатии на кнопку «Нет» последующие действия, заданные для данного процесса, не будут выполняться, и процесс перейдет к следующему циклу мониторинга.

Показывать сообщение поверх всех окон - окно сообщения будет выведено в режиме «самое верхнее», причем даже активация другого приложения не скроет окно. Особенностью данного режима является то, что следующее сообщение не появится, пока не закроется окно с предыдущим.

Режим оповещения под сервисом NT - этот режим рекомендуется устанавливать, если Лог Монитор запущен сервисом под NT/2000. В этом случае окна сообщений будут выводиться на экран, даже если пользователь не зашел в систему интерактивно.


Звуковое оповещение

Действие «Проиграть звук» позволяет проиграть звуковой файл на локальном компьютере. Звук может быть воспроизведен как однократно, так и циклически.

Звук - путь к звуковому файлу в формате Microsoft Waveform (*.wav). Путь может содержать аргументы, полученные для файлов, подпадающих под условия. Кнопки «Пуск» и «Стоп» позволяют предварительно проиграть звуковой файл (если путь не содержит переменных-аргументов). Звук должен помещаться в доступной физической памяти, т.е. звуковой файл не должен быть слишком большим.

Гудок на динамике - Windows 95/98/Me: если компьютер не оборудован звуковой картой, то будет произведен гудок на динамике. Windows NT/2000/XP: гудок на динамике, даже если установлена звуковая карта. Примечание: для получения звука на динамике под Windows 95 можно запускать следующую команду в действии «Запуск программы»:

%comspec% /c echo %Chr="7"

Повторять звук - циклически проигрывать указанный звук:

Играть в течение интервала - общее время повторения звука, в секундах. Если указан 0, то звук будет воспроизведен только один раз.

С промежутками - «расстояние» в миллисекундах между двумя последовательными воспроизведениями звука. Минимальный промежуток - 100 мс.


Файловые операции

Действие «Файловая операция» позволяет выпонить базовые операции с файлами: копирование, перемещение, переименование, удаление.

Внимание: Для корректной работы файловых процедур необходимо указывать полные пути файлов.

Вид операции - что нужно сделать с файлами:

  • Копирование - копирует файл(ы), указанные в поле «Откуда», в директорию, указанную в поле «Куда»;
  • Перемещение - перемещает файл(ы), указанные в поле «Откуда», в директорию, указанную в поле «Куда»;
  • Переименование - переименовывает файл, указанный в поле «Откуда», в файл, указанный в поле «Куда». Операция может быть выполнена только над одним файлом;
  • Удаление - удаляет файл(ы), указанные в поле «Откуда».

Откуда - поле, содержащее имя файла или список файлов, разделенных точкой с запятой (";"). Должны быть указаны полные пути файлов. Допускаются файловые маски DOS ("*"). В поле могут указываться аргументы, полученные для файлов, подпадающих под условия. Пример строки, формирующей список файлов:

%(%File;%)

Обратите внимание, что строка не содержит пробелов.

Куда - поле, содержащее полный путь к каталогу или файлу. В поле могут указываться аргументы, полученные для файлов, подпадающих под условия. Особенности:

  • маски DOS не допускаются;
  • для операций копирования и перемещени может быть указан несуществующий каталог, в этом случае он будет создан (вместе с подкаталогами).

Пропускать каталоги, если указана маска (*.*) - если установлена эта опция, и в поле "Откуда" содержится маска файлов "*.*", то файловая операция затронет только файлы в указанном каталоге, пропуская подкаталоги и файлы в подкаталогах.

Возможность восстановления, если возможно - относится к операции удаления; при удалении файлы помещаются в корзину с возможностью восстановления.

Показывать диалог копирования и сообщения об ошибках - при установленной опции создается окно с прогресс-индикатором (стандартное окно, возникающее при копировании файлов в Windows Explorer). При возникновении ошибок сообщения выводятся в диалоговые окна. При сброшенной опции файловая операция проходит без появления интерфейсных окон.

Внимание: не следует включать эту опцию, если мониторинг происходит на компьютере без оператора, который мог бы закрыть сообщение об ошибке или ответить на вопрос. Т.к. файловые операции запускаются в синхронном режиме, то исполнение действий и процесс мониторинга остановятся до закрытия диалогового окна.

Отвечать «Да для всех» на все вопросы - отвечать «Да для всех» на все вопросы в диалоговых окнах, возникающие в ходе файловой операции, например «Удалить файл?» или «Перезаписать файл?».

Способ помещения агрументов - определяет, каким образом будут обработаны переменные при помещении их в параметры файловой операции, и сколько раз будет выполнена операция над файлами:

Все файлы сразу - в параметры будут помещены данные сразу всех файлов, если агрументы заключены в переменные цикла "%(" и "%)". Операция будет выполнена однократно.

Способ «Все файлы» используется при копировании (перемещении) файлов в одну целевую директорию, например:

Откуда: C:\TEMP
Куда: D:\
(весь каталог C:\TEMP со всеми файлами и подкаталогами копируется в корень диска D:)

Откуда: %(%File;%)
Куда: C:\SAVE\%SysDate="YYYY-MM-DD"
(файлы, возможно из разных подкаталогов, копируются в один каталог, соответствующий системной дате)

По одному файлу - операция будет выполнена столько раз, сколько было получено файлов при проверке условий, по одному запуску на каждый файл. При каждом запуске в параметры операции будут помещаться данные следующего файла, согласно заданным аргументам. Этот способ работает значительно медленнее первого.

Способ «По одному файлу» используется, если файлы из разных каталогов необходимо поместить в разные целевые директории с сохранением структуры дерева каталогов, например:

Откуда: %File
Куда: C:\SAVE\%SysDate="YYYY-MM-DD"%File="S:2\\N.E"
(файл C:\WORK\PROJ1\DATA\log.txt будет скопирован в каталог C:\SAVE\2000-12-20\PROJ1\DATA\, а файл C:\WORK\PROJ2\INPUT\1.dat - в каталог C:\SAVE\2000-12-20\PROJ2\INPUT\)


Завершение программы

Действие предназначено для принудительного завершения программы, идентифицированной по титулу ее окна.

Титул окна - строка, с которой будет сравниваться титул окна при поиске программы для закрытия. Титул может содержать аргументы, полученные для файлов, подпадающих под условия. Строка может содержать шаблоны "*" или "?", в этом случае сравнение будет производиться с учетом маски.

Применить ко всем окнам с подходящим титулом - применить действие ко всем найденным приложениям с титулом, соответствующим заданному. Если опция не установлена, то будет закрыта только первая найденная программа (порядок окон устанавливается ОС).

Способ закрытия - определяет, насколько принудительно будет завершена программа:

  • Послать сообщение о закрытии - попросить программу закрыться, послав ей системное сообщение WM_CLOSE. Программа имеет возможность сохранить данные, задать пользователю вопрос и т.д.
  • Прервать процесс - программа прерывается принудительно и не имеет возможности отреагировать на закрытие. Измененные данные могут быть потеряны.


Справочные материалы

Раздел «Справочные материалы» предназначен для детального изучения особенностей программы и содержит описание:

  • аргументов действий;
  • форматов переменных даты/времени;
  • формата масок (шаблонов).

В поставку входит консольная версия, которая может быть установлена сервисом Windows NT/2000.


Аргументы

Файлы, соответствующие условиям мониторинга, формируют список файлов и передаются действиям. Действия получают доступ к информации о файлах с помощью настраиваемых аргументов. Перед выполнением действий вместо аргументов подставляются реальные значения (имя файла, размер, время и т.д.).

Синтаксис аргументов:

%<Обозначение>[="модификаторы"]

За знаком процента (%) следует обозначение аргумента. Регистр, в котором указано обозначение аргумента, не имеет значения. Далее, в качестве параметра (часто необязательного), через знак равенства (=) следует формат аргумента, заключенный в двойные кавычки ("). Если строка формата содержит символы двойной кавычки или обратной косой черты, то они предваряются обратной косой чертой (\), например:

%File="D\\path\"string\"" (на обработку поступит строка D\path"string")

Аргументы могут быть рекурсивно вложенными. Это значит, что один аргумент можно указывать в модификаторе другого аргумента. Уровень вложенности не ограничен. Если включаемый аргумент содержит собственный модификатор, то кодировать символы кавычки, обрамляющие модификатор, не нужно. Примеры рекурсивных переменных:

%Changed="copy %File="N.E" c:\\temp"
%Substring="1,8,%Name"
%Include="%Substring="1,8,%File="N"".txt"

Доступны следующие аргументы:

%File

Полное имя файла. Возможны следующие модификаторы:

  • D - имя диска (с двоеточием);
  • P - путь до файла, без диска, без имени файла, с открывающей (кроме корня), но без закрывающей косой черты (\);
  • N - имя файла (без точки);
  • E - расширение файла (без точки);
  • S:n - часть пути до файла, начиная с уровня n от корня, например S:3. С ведущей обратной косой чертой, кроме случаев, когда файл находится в корне или n превышает реальный уровень вложенности;
  • R - указание заменять в результирующей строке все символы обратной косой черты (\) на прямую косую черту (/);
  • 'x' или "x" - любой символ, заключенный в одинарные или двойные кавычки, не интерпретируется.

Переменной без указания формата соответствует полный путь файла. Полный путь может быть также задан как

%File="DP\\N.E" или %File="DS:1\\N.E"

%Name

Имя файла с расширением. Модификаторы отсутствуют. Аналогом является аргумент %File="N.E".

%Path

Путь до файла, без конечной косой черты (\). Модификаторы отсутствуют. Аналогом является аргумент %File="DP".

%Time

Время модификации файла. Модификаторы задают формат представления даты/времени. Читайте подробнее о формате даты/времени.

%Size

Размер файла. Модификаторы могут задаваться в виде %Size="<единицы><разделитель>". Символ <единицы> задает размерность числа и может принимать значения:

  • B - байты;
  • K - килобайты;
  • M - мегабайты;
  • G - гигабайты.

Символ <разделитель> задает разделитель групп цифр по три. Пример:

%Size="K," Кб
(для файла размером 1300140 байт будет выведено 1,269 Кб)

%Added

В качестве формата аргумента задается текст, который должен быть подставлен, если файл добавился:

%Added="Файл добавился!"

%Changed

В качестве формата аргумента задается текст, который должен быть подставлен, если файл изменился:

%Changed="Файл изменился!"

%Deleted

В качестве формата аргумента задается текст, который должен быть подставлен, если файл был удален:

%Deleted="Файл удалили!"

%SysDate

Текущее системное время. Модификаторы задают формат представления даты/времени. Читайте подробнее о формате даты/времени.

%RunTime

Время начала выполнения действий после проверки условия. Это время может отличаться от системного при выполнении продолжительных действий. Модификаторы задают формат представления даты/времени. Читайте подробнее о формате даты/времени.

%Environment

Переменная окружения, включаемая по ее имени. Имя переменной задается модификатором (обязательный параметр):

%Environment="temp"\tmp.txt

%Include

С помощью этого аргумента включается содержимое текстового файла. Аргумент может быть использован для включения масок фильтра из файла (одна маска на строку). Имя файла задается модификатором (обязательный параметр):

%Include="c:\\masks.txt"

%Substring

Аргумент служит для получения подстроки. Модификатором задается позиция подстроки (отсчет с 1) и количество символов в виде

%Substring="позиция,длина,строка"

Аргумент имеет смысл использовать с рекурсивными переменными, например, для получения части имени файла:

%Substring="1,5,%File="N"" (первые 5 символов имени файла)

%Chr

Произвольный символ, десятичный код которого задан модификатором:

%Chr="10" (перевод строки)
%Chr="9" (табуляция)

%%

Псевдо-аргумент для обозначения символа процента (%).

%(
%)

Специальные аргументы для формирования цикла по списку файлов. Например, если в результате проверки условий получено три файла (file1, file2, file3), то применение аргументов:

%SysDate="dd.mm.yyyy": %(%File; %)

приведет к строке:

20.12.2000: file1; file2; file3;

Аргументы цикла не могут быть использованы в случаях, когда происходит обработка по одному файлу:

  • в действии «Список файлов», если не указан флаг «Разрешить использовать переменные цикла»;
  • в действии «Запуск программы» при указании опции «По одному файлу»;
  • в действии «Файловая операция» при указании опции «По одному файлу».


Форматы даты

Данный документ описывает модификаторы формата даты/времени для аргументов %Time, %RunTime и %SysDate, например %SysDate="dd.mm.yyyy".

Формат | Результат
c | Дата показывается в формате, установленном в регональных настройках параметром «Короткая дата», плюс время в формате «Полное время».
d | День в виде числа без ведущего нуля (1-31).
dd | День в виде числа с ведущим нулем (01-31).
ddd | День недели в виде сокращения (Sun-Sat) в формате, заданном параметром «Короткие дни недели» в регональных настройках.
dddd | День недели полным названием (Sunday-Saturday) в формате, заданном параметром «Полные дни недели» в регональных настройках.
ddddd | Дата в формате, заданном параметром «Короткая дата» в регональных настройках.
dddddd | Дата в формате, заданном параметром «Полная дата» в регональных настройках.
m | Месяц в виде числа без ведущего нуля (1-12). Если модификатор m следует непосредственно за модификаторами h или hh, то показываются минуты вместо дня месяца.
mm | Месяц в виде числа с ведущим нулем (01-12). Если модификатор m следует непосредственно за модификаторами h или hh, то показываются минуты вместо дня месяца.
mmm | Месяц в виде сокращения (Jan-Dec) в формате, заданном параметром «Короткие названия месяца» в региональных настройках.
mmmm | Месяц полным названием (January-December) в формате, заданном параметром «Полные названия месяца» в региональных настройках.
yy | Год, сокращенный до двух последних цифр (00-99).
yyyy | Год в четырех позициях (0000-9999).
h | Часы без ведущего нуля (0-23).
hh | Часы с ведущим нулем (00-23).
n | Минуты без ведущего нуля (0-59).
nn | Минуты с ведущим нулем (00-59).
s | Секунды без ведущего нуля (0-59).
ss | Секунды с ведущим нулем (00-59).
t | Время в формате, заданном параметром «Короткое время» в региональных настройках.
tt | Время в формате, заданном параметром «Полное время» в региональных настройках.
am/pm | Используется 12-часовой формат для предшествующих модификаторов h или hh, выводится 'am' для времени до полудня и 'pm' после полудня. Модификатор am/pm может задаваться в любом регистре, результат будет соответствовать регистру.
a/p | Используется 12-часовой формат для предшествующих модификаторов h или hh, выводится 'a' для времени до полудня и 'p' после полудня. Модификатор a/p может задаваться в любом регистре, результат будет соответствовать регистру.
ampm | Используется 12-часовой формат для предшествующих модификаторов h или hh, выводится значение параметра «Строка AM» региональных настроек для времени до полудня и значение параметра «Строка PM» после полудня.
/ | Выводится символ-разделитель даты, заданный параметром «Разделитель даты» региональных настроек.
: | Выводится символ-разделитель времени, заданный параметром «Разделитель времени» региональных настроек.
'xx', "xx" | Символы, заключенные в одинарные или двойные кавычки, выводятся без изменений. Замечание: двойные кавычки в формате переменных должны заменяться на \".

Если формат переменных не задан, то дата/время форматируются, как если бы был задан модификатор c.


Маски (шаблоны)

Маски используются при настройке файловых фильтров, а также действия «Закрыть программу». Маска сравнивается со входной строкой, в результате строка может соответствовать заданной маске либо нет.

Допустимая маска состоит из литер (букв, цифр), множеств и символов-шаблонов.

Каждой литере должен соответствовать один символ строки. Результат сравнения символа с литерой не зависит от регистра.

Каждое множество начинается с открывающей квадратной скобки ([) и заканчивается закрывающей скобкой (]). Между скобками находятся элементы множества. Каждый элемент - это литера либо диапазон. Диапазон задается начальным значением, дефисом (-) и конечным значением. Не используйте пробелы или запятые для разделения элементов множества. Множеству должен соответствовать один символ строки. Символ соответствует множеству, если он совпадает с одной из литер множества либо входит в один из диапазонов множества. Символ входит в диапазон, если он равен начальному значению, конечному значению, либо попадает между двумя этими значениями. Все сравнения не зависят от регистра. Если первым символом после открывающей скобки указан восклицательный знак (!), тогда множество соответствует любому символу, не входящему во множество.

Символы-шаблоны - это звездочка (*) и вопросительный знак (?). Звездочке соответствует любое количество символов. Вопросительному знаку соответствует любой одиночный символ.

Использование масок немного отличается от файловых масок MS-DOS. Так как производится посимвольное сравнение, то маска "*.*" означает строку, обязательно содержащую символ точки. Это означает, что файл без расширения не будет соответствовать маске "*.*", в отличие от DOS. Наиболее общей маской является "*".

Примеры масок:

*.txt (строки, заканчивающиеся на '.txt')
[a-ckl]_doc* (строки, начинающиеся с 'a_doc', 'b_doc', 'c_doc', 'k_doc', 'l_doc')
[!ab][!cd]_ef_[g-m]_?? (строки типа 'cb_ef_h_12', не начинающиеся с 'ac', 'ad', 'bc', 'bd')


Консольная версия

В поставку включена консольная версия Лог Монитора - logmcon.exe. Это полнофункциональная версия программы с точки зрения мониторинга и действий. Консольная версия не содержит интерфейса для настройки заданий мониторинга, она исполняет уже настроенный файл. Соответственно, настройку рекомендуется производить версией с графическим интерфейсом.

Консольная версия потребляет меньше оперативной памяти за счет отсутствия графического интерфейса пользователя и отсутствия модуля настройки заданий.

Консольная версия может быть установлена как сервис Windows NT/2000 (см. аргументы командной строки).

Аргументы командной строки

>logmcon.exe [config file]

Загрузить указанный конфигурационный файл и стартовать мониторинг. Если аргумент не указан, то будет открыт файл default.mon, находящийся в том же каталоге, что и программа. Если не удалось открыть конфигурационный файл, то программа завершается с сообщением об ошибке.

>logmcon.exe /install

Установить сервис Windows NT/2000 на локальном компьютере. Будет инсталлирован сервис под названием LogMonSvc (сервис доступен также по имени «Log Monitor»). Устанавливается режим запуска сервиса «Manual», т.е. сервис не будет запущен автоматически при загрузке компьютера. Вы можете изменить режим запуска в панели управления сервисами.

>logmcon.exe /remove

Удалить инсталлированный ранее сервис на локальном компьютера. Никакие файлы не будут удалены, удаляется только учетная запись сервиса в системе.

>logmcon.exe /start [\\computer] [config file]

Команда позволяет стартовать сервис на указанном компьютере и загрузить указанный файл. Если компьютер не указан, то сервис будет стартован на локальном компьютере. Если не указан файл, то будет открыт default.mon, находящийся в каталоге программы. Если сервису не удается открыть конфигурационный файл, то он аварийно завершается.

>logmcon.exe /stop [\\computer]

Остановить сервис на указанном компьютере. Если компьютер не указан, то сервис останавливается на локальном компьютере.

>logmcon.exe /?

Выводится экран с подсказками по аргументам командной строки.

Особенности работы сервиса

  1. Если при старте сервису не удается загрузить конфигурационный файл, то он аварийно завершается с кодом ошибки 3000.
  2. Сервис обрабатывает команду «Пауза» (ее можно подать из системной панели управления сервисами). Действие команды аналогично команде «Остановить все процессы» в версии с графическим интерфейсом. Команда «Старт», поданная после паузы, возобновляет мониторинг с места остановки.
  3. Если необходимо обращаться к сетевым ресурсам, то сервис должен запускаться под бюджетом пользователя, имеющего доступ к сетевым ресурсам, а не LocalSystem.
  4. Если используется действие «Закрыть программу», то в свойствах сервиса необходимо указать «Разрешить сервису взаимодействовать с десктопом» (Allow service to interact with desktop), так как приложения ищутся по заголовкам окон, открытых в рабочей среде пользователя.
  5. При использовании действия «Окно-оповещение» рекомендуется включить флаг «Режим оповещения под сервисом NT». Данный режим позволяет видеть окно сообщения, даже если пользователь не вошел интерактивно в систему. Иначе, установите опцию «Разрешить сервису взаимодействовать с десктопом» в свойствах сервиса, чтобы текущий пользователь видел сообщение.


Свойства программы

Окно свойств программы содержит настройки собственно Лог Монитора. Установленные значения сохраняются в Registry при нажатии кнопки «OK», а также при выходе из программы. Настройки разбиты на несколько закладок:

  • Общие - общие настройки программы;
  • Внешний вид - настройки внешнего вида.


Свойства программы

Свойства программы - общие

Запуск

Минимизировать при запуске - при включенной опции Лог Монитор будет запускаться минимизированным. Аналогичного поведения можно добиться, установив в свойствах Shortcut на программу Run Minimized или командой START /MIN LOGMON.EXE.

Только одна копия - при установленной опции допускается запуск только одного экземпляра программы одновременно.

Стартовать при загрузке - загружать Лог Монитор при входе текущего пользователя в систему.

Подтверждения

Удаление - будет запрашиваться подтверждение при удалении процессов мониторинга из списка.

Несохраненные настройки - при выходе из программы будет предложено сохранить настройки, если они были изменены.

Выход из программы - будет запрошено подтверждение на выход из программы.

Файлы

Ассоциировать файлы .mon с Log Monitor - указывает системе, что файлы с расширением "mon" обрабатываются Лог Монитором; для данного типа файлов устанавливается иконка.

Каталог кэша - каталог по умолчанию, куда будут сохраняться файлы статуса при включенной опции «Сохранять статус файлов между запусками». Каталог кэша может быть установлен отдельно для каждого процесса мониторинга.


Свойства программы

Свойства программы - внешний вид

Системная панель

Минимизировать в System Tray - программа будет минимизироваться System Tray (область в панели задач, где живут часы и индикатор клавиатуры). В System Tray появится иконка программы, при нажатии на которую правой кнопкой мыши появится меню.

Восстанавливать по одинарному/двойному нажатию - опция позволяет выбрать, одинарное или двойное нажатие левой кнопкой мыши на иконку нужно сделать, чтобы восстановить программу из System Tray.

Спрятать иконку - не показывать иконку в трее при минимизации (с панели задач окно также исчезает). Внимание: обязательно установите горячую клавишу, по которой окно будет восстанавливаться, другого «штатного» способа восстановить невидимое окно нет.

Восстанавливать по клавише - горячая клавиша, по которой восстанавливается минимизированное (спрятанное) основное окно Лог Монитора.

Внешний вид

Пиктограммы в меню - при включенной опции в меню будут присутствовать иконки, соответствующие командам меню.

Запоминать позицию основного окна и размеры колонок - при включенной опции Лог Монитор по выходу будет запоминать позицию и размеры окон, а также размеры колонок списка процессов (и других подобных списков). При запуске установятся запомненные раннее значения.

Обновление обратного отсчета - интервал, через который будут обновляться цифры обратного отсчета в списке процессов, в секундах от 1 до 10.


Условия (статус каталога)

Закладка «Условия»

Следить за... - выбор вида условий. Конкретные параметры условия зависят от выбранного типа. Поддерживаемые типы условий:

  • Изменение статуса каталога - следить за изменением файлов в каталоге, например, за добавлением или удалением файлов.
  • Время модификации файлов - следить за файлами по их возрасту, отделяя старые файлы.

Игнорировать файлы, открытые на запись - не включать в проверку файлы, открытые на запись. Независимо от результатов проверки, такие файлы не будут передаваться в действия. Если заблокированный файл был изменен, то условие срабатывает во время следующей проверки.

Выполнить действия

Можно отслеживать одновременно несколько видов изменения статуса файлов:

Если любой файл изменился - выполнить действия, если любой файл в пределах объекта мониторинга изменился. Проверяется дата модификации файла, точность проверки - 1 мс.

Если добавился любой файл - выполнить действия, если добавился новый файл по сравнению с результатами предыдущей проверки. Если в течение интервала ожидания следующей проверки файл появляется и успевает исчезнуть, то событие не фиксируется и условие не выполняется.

Если какой-либо файл был удален - выполнить действия, если в течение интервала мониторинга хотя бы один файл был удален.

Если что-то изменилось - выполнить действия, если выполнилось одно или более из вышеприведенных условий.

Инвертировать - инвертировать условия мониторинга. Все условия меняются на противоположные: любой изменился - ни один не изменился; любой добавился - ни один не добавился; какой-либо удален - ни один не удален; что-то изменилось - ничего не изменилось.

Сохранять данные об удаленных файлах - помнить информацию об удаленных файлах, чтобы передать ее в действия. Устанавливайте эту опцию, только если вам необходимо фиксировать, какие именно файлы были удалены. Значительно возрастает потребление памяти: необходимо сохранять полную информацию обо всех файлах, т.к. неизвестно, какой из них будет удален.