Presentación

Siguiente ››

Cambiar los atributos de los archivos y las carpetas en Windows es algo incómodo - Attribute Changer te ayudará a realizar esta tarea.

Attribute Changer permite cambiar los atributos estándar (Sólo lectura, Archivo, Oculto, Sistema e Índice) de archivos y carpetas y cambiar su fecha y hora. Dispone también de ayuda y se integra en Windows añadiéndose a la shell de Windows.

Las opciones avanzadas incluyen la compresión y descompresión de archivos almacenados en volúmenes NTFS, modificaciones parciales de fecha y hora y el uso de filtros y execpciones.

Haz clic en las pestañas para saber más sobre Attribute Changer o sigue el tutorial para ver una rápida introducción.

Puedes leer también la historia del programa para saber los cambios y mejoras realizados a Attribute Changer.

Disfruta de Attribute Changer
Romain Petges

Ayuda de Attribute Changer | Copyright © Romain Petges

Siguiente ››


Novedades

‹‹ Anterior | Siguiente ››

La versión 5 de Attribute Changer incluye algunas mejoras largamente esperadas, tales como la muestra de los atributos existentes y la realización de ajustes relativos de fecha y hora en archivos y carpetas.

La aplicación ha sido reescrita completamente y tiene un nuevo interfaz de usuario basado en los comentarios de los usuarios.

Para los usuarios que utilizan una versión anterior a la 4.0:

Es muy importante señalar que los objetos archivo y carpeta objects son ahora objetos completamente diferentes, por lo que el procesamiento de los atributos de los archivos ya no dependen de la opción 'Aplicar a subcarpetas".

    Tanto la pestaña de archivo como la de carpeta poseen su propia casilla de verificación "Aplicar a subcarpetas" para hacerlas independientes.

    Ejemplo 1:

    Selecciona una carpeta que contenga muchas subcarpetas y archivos. Supongamos que quieres cambiar sólo los atributos de las carpetas pero no los de los archivos. En este caso, marca la casilla "Aplicar a subcarpetas" en la pestaña de carpeta y desmarca la misma casilla en la pestaña de archivo. En cualquier versión anterior de Attribute Changer debes establecer en gris todas las opciones de atributos de los archivos.

    Ejemplo 2:

    Selecciona una carpeta que contenga muchas subcarpetas y archivos. Supongamos que quieres cambiar todos los archivos pero no modificar las carpetas. Simplemente marca la casilla "Aplicar a subcarpetas" en la pestaña de archivo y desmarca la misma casilla en la pestaña de carpeta.

    Ejemplo 3:

    Selecciona una carpeta y varios archivos. La carpeta contiene subcarpetas y archivos y supongamos que quieres modificar los atributos de la carpeta y de todos los archivos. Para conseguirlo, desmarca la casilla "Aplicar a subcarpetas" en la pestaña de carpeta y marcala en la carpeta de archivo. Establece los atributos que quieres cambiar y aplica los cambios. Esta situación no podía realizarse con las versiones anteriores de Attribute Changer.

Ayuda de Attribute Changer | Copyright © Romain Petges


Créditos

Quiero agradecer especialmente a las siguientes personas su contribución al éxito de Attribute Changer:

    Mike Lischke por su componente ThemeManager para aplicaciones Delphi en Windows XP Delphi.

    dirección e-mail | public@lischke-online.de
Homepage | http://www.lischke-online.de
    Bartolomé Sintes por la traducción al castellano de Attribute Changer
    dirección e-mail | cdlibre@mclibre.org
Homepage | http://www.mclibre.org http://www.cdlibre.org


Licencia y Garantía

Acuerdo de licencia de usuario final de Attribute Changer

1. Instalación y uso del software

Puedes instalar, utilizar, acceder, ejecutar o interactuar con ("ejecutar") una copia del SOFTWARE en un único o en varios ordenadores. El SOFTWARE puede ser instalado, accedido, mostrado, ejecutado, compartido o usado concurrentemente en o desde diferentes ordenadores. Estos derechos son aplicables para el uso personal y comercial de este SOFTWARE.

2. Negación de daños consecuentes u otros daños

En la máxima extensión permitida por la ley aplicable, el autor no será responsable de ningún daño (incluyendo, sin limitación, daños por pérdida de beneficios empresariales, interrupción del negocio, peérdida de información empresarial, o cualquier otro daño pecuniario) que provengan del uso o de la falta de habilidad en el uso del SOFTWARE) incluso aunque el autor haya sido avisado de la posibilidad de estos daños. Puesto que puedes haber evitado estos daños tomando el cuidado necesario, lo que incluye la realización de copias de seguridad de sus programas y otros archivos, el autor y sus suministradores no serán responsables de dichos daños.

3. Ingeniería inversa, descompilación y desensamblado.

No puedes aplicar ingeniería inversa, descompilar o desensamblar el SOFTWARE.

4. Copyright

Todos los derechos de propiedad intelectual y del título relativos al SOFTWARE son propiedad del autor.

5. Separación de componentes

El SOFTWARE está licenciado como un producto único y sus partes componentes no pueden separarse.


Comentarios y Soporte

Comentarios

Como autor de software gratuito (freeware), me encantaría recibir comentarios sobre el programa. Por favor, ayudame a mejorarlo enviándo informes de fallos, sugerencias y mensajes.

Dirección e-Mail:

    romain@petges.com

Soporte

El único soporte disponible es a través de la dirección de correo electrónico romain@petges.com o en mi página web personal en http://www.petges.com. Por favor, consulta las secciones Preguntas Más Frecuentes (en inglés FAQ, frequently asked questions) y Problemas Conocidos (en inglés, Known issues) de mi página web antes de solicitar ayuda por correo electrónico.

Todas las peticiones de soporte serán atendidas lo antes posible.


Instalación y Desinstalación

Instalar Attribute Changer es bastante sencillo. El instalador empleado es el Sistema de instalación NSIS. Simplemente abre una ventana del explorador, haz doble clic en el icono y sigue las instrucciones del programa de instalación.

Sólo puedes acceder a Attribute Changer mediante los menús contextuales de discos, carpetas y archivos.

Para desinstalar Attribute Changer sigue el método habitual de Windows. Abre el icono Agragar o quitar programas del Panel de Control, selecciona Attribute Changer y haz clic en el botón Agregar o quitar para eliminar el programa de tu ordenador.

Puedes encontrar más información técnica en la sección Cambios del Sistema de este archivo de ayuda.


Tutorial - Presentación

‹‹ Anterior | Siguiente ››
Importante:

Por favor, lee cuidadosamente la sección Novedades en la versión 5 antes de proceder con el tutorial si estás actualizando desde una versión anterior a la versión 4.0.

Por favor, utiliza la ayuda disponible en Attribute Changer haciendo clic en el control ? de la barra de título y eligiendo un elemento cualquiera del interfaz de usuario de Attribute Changer.


Tutorial - Objetos archivo

Nota: Crea un entorno de prueba en tu disco duro para probar las diferentes configuraciones antes de utilizar Attribute Changer en archivos valiosos.

Haz clic derecho sobre un único archivo o sobre una selección de archivos y elige la opción Cambiar atributos... del menú contextual para ejecutar la aplicación.

Las opciones irrelevantes aparecen en gris y no son, por tanto, accesibles al usuario. Los filtros de archivo y las excepciones de archivo sólo están disponibles cuando trabajas con múltiples archivos. Estas opciones resultan útiles para aplicar diferentes atributos a un subconjunto de los archivos seleccionados.

Ejemplo:

Selecciona un conjunto de archivos que incluyan por ejemplo archivos ZIP, DLL, EXE y BMP. Supongamos que quieres eliminar el atributo Sólo lectura de todos los archivos seleccionados. Además, quieres comprimir todos los archivos (salvo los ZIP) (opción disponible únicamente en particiones NTFS), y quieres cambiar la fecha de todos los archivos EXE.

Tras elegir la opción Cambiar atributos... tienes que elegir eliminar el atributo Sólo lectura de todos los archivos seleccionados. Cada atributo puede establecerse en uno de los siguientes tres estados:

el atributo será desactivado

el atributo será activado

el atributo no se modificará

Asegúrate de que el atributo Sólo lectura está desmarcado en la pestaña de Atributos de archivo y que el resto de atributos se muestran en gris. Asegúrate de desmarcar cualquier opción de modificación de fecha u hora.

Por último, asegúrate de que las opciones Usar Filtro y Usar Excepción están desmarcadas.

Los filtros y las excepciones se utilizan para filtrar objetos basándose en criteriors de búsqueda tales como fecha, hora y atributos. Las utilizaremos en uno de los siguientes pasos para reducir el conjunto de archivos a modificar.

Haz clic en el botón Aplicar para eliminar el atributo Sólo lectura de los archivos seleccionados. Puedes seguir el desarrollo del proceso en la pestaña Actividad y resultados.

A continuación comprimiremos todos los archivos, salvo los ZIP, usando el atributo Comprimido (sólo en las particiones NTFS). Para conseguirlo, debes marcar el atributo Comprimido y hacer gris el resto de atributos. Deja desmarcadas el resto de fecha y hora.

Ahora usaremos las excepciones para reducir el conjunto de archivos a modificar, filtrando todos los archivos ZIP. Marca la casilla Usar Excepción y haz clic en el botón Excepción para abrir el diálogo de configuración.

Selecciona la opción Incluir todos los archivos, salvo y añade una nueva entrada *.ZIP a la lista de excepciones, haciendo clic derecho en la lista vacía y seleccionando la opción Añadir. Renombra la nueva entrada como *.ZIP. Haz clic en el botón OK y a continuación en Aplicar para comenzar el proceso de actualización. Puedes seguir el desarrollo del proceso en la pestaña Actividad y resultados.

Ten en cuenta que puedes utilizar cualquier comodín, como * y ? en la lista de excepciones para formar patrones de búsqueda como *.DOC, Carta*(200?).txt etc.

El último paso es cambiar la fecha de todos los archivos *.EXE. Abre nuevamente el diálogo de configuración Excepción de archivo y cambia la entrada *.ZIP a *.EXE, seleccionando la entrada y pulsando la tecla de función F2. También puedes seleccionar la entrada con el botón derecho del ratón y elegir la opción de menú Renonmbrar.

Cierra el diálogo mediante el botón OK y configura las opciones de hora a modificar. En la pestaña Atributos de archivo establece en gris todas los atributos disponibles y marca la opción Modificar fecha y hora. En este caso, quieres aplicar fechas absolutas, por lo que debe estar desmarcada la opción Usar ajustes relativos.

En todos los campos de fecha y hora el menú contextual (botón derecho) muestra varias opciones, como ajustar a la fecha y hora actual del Sistema. También puedes seleccionar la parte de la hora que quieras modificar y escribir el nuevo valor en el campo. Haz clic en el botón Configuración y selecciona la pestaña Propiedades para configurar la hora a actualizar.

Selecciona las propiedades de hora que quieres modificar (Creado, Modificado, Con acceso). La pestaña Máscaras te permite personalizar los componentes de la hora a actualizar (Horas, Minutos, Segundos). Cierra el diálogo de configuración mediante el botón OK y haz clic en el botón Aplicar para realizar las cambios a los objetos filtrados (archivo .EXE).

¡Esto es todo!


Tutorial - Objetos carpeta

Nota: Crea un entorno de prueba en tu disco duro para probar las diferentes configuraciones antes de utilizar Attribute Changer en archivos valiosos.

Attribute Changer es una herramienta muy apropiada para cambiar atributos de todos los archivos y carpetas contenidos en una carpeta. Haz clic derecho en una carpeta y selecciona la opción del menú contextual Cambiar atributos... para ejecutar la aplicación.

Las opciones irrelevantes aparecen en gris y no son, por tanto, accesibles al usuario. Debes utilizar los filtros de archivos y carpeta para restringir el número de objetos a modificar.

Ejemplo:

Selecciona un conjunto de archivos y carpetas. Supongamos que quieres eliminar el atributo de Sólo lectura de todos los archivos y carpetas y quieres comprimir todos los archivos .BMP (opción disponible únicamente en particiones NTFS).

Haz clic derecho y elige la opción Cambiar atributos... para eliminar todos los atributos Sólo lectura de los archivos seleccionados. Cada atributo puede estar en uno de los siguientes tres estados:

el atributo será activado

el atributo será desactivado

el atributo no se modificará

Asegúrate de que el atributo Sólo lectura está desmarcado en la pestaña de Atributos de archivo y que el resto de atributos se muestran en gris. Asegúrate de desmarcar cualquier opción de modificación de fecha u hora.

Puesto que queremos cambiar los atributos seleccionados de todas las subcarpetas, aseguráte de marcar la casilla de verificación Aplicar a subcarpetas, ya que si no sólo se modificarán las carpetas seleccionadas.

Para eliminar el atributo de Sólo lectura de los archivos, desmarca la opción Sólo lectura de la pestaña Atributos de archivo. Para eliminarlo de todos los archivos de las carpetas seleccionadas, marca la casilla de verificación Aplicar a subcarpetas.

Importante: Si antes de iniciar Attribute Changer has seleccionado tanto archivos como carpetas, los filtros y excepciones definidos se aplicarán únicamente a los objetos seleccionados. Si está seleccionada la opción Aplicar a subcarpetas, los filtors y excepciones también se aplican a los objetos contenidos en las carpetas seleccionadas.

Por último, asegúrate que las opciones Usar filtro y Usar Excepción están desmarcadas.

Los filtros y las excepciones se usan para filtrar los objetos basándose en criterios de búsqueda, tales como fecha, hora y atributos. Las utilizaremos en uno de los siguientes pasos para reducir el conjunto de archivos a modificar.

Haz clic en el botón Aplicar para eliminar el atributo Sólo lectura de los archivos y carpetas. Puedes seguir el desarrollo del proceso en la pestaña Actividad y resultados.

Lo siguiente que queríamos hacer era comprimir todos los archivos BMP (opción sólo disponible en particiones NTFS). Para conseguirlo, debes marcar el atributo Comprimido en la pestaña Atributos de archivo y hacer gris el resto de atributos. Desmarca el resto de opciones de fecha y hora.

Ahora usaremos las excepciones para reducir el conjunto de archivos a modificar filtrando todos los archivos BMP. Marca la casilla de verificación Usar Excepción y haz clic en el botón Excepción para abrir el diálogo de configuración.

Selecciona la opción Incluir todos las carpetas, salvo y añade una nueva entrada *.BMP a la lista de excepciones, haciendo clic derecho en la lista vacía y seleccionando la opción Añadir. Renombra la nueva entrada como *.BMP. Haz clic en el botón OK y a continuación en Aplicar para comenzar el proceso de actualización. Puedes seguir el desarrollo del proceso en la pestaña Actividad y resultados.

Ten en cuenta que puedes utilizar cualquier comodín, como * y ? en la lista de excepciones para formar patrones de búsqueda como *.DOC, Carta*(200?).txt etc.

Haz clic en el botón Aplicar para iniciar el proceso de actualización. labutton to start the update process. Puedes seguir el desarrollo del proceso en la pestaña Actividad y resultados.

¡Esto es todo!


Atributos de carpeta - Cambios básicos

Atributos de carpeta - Cambiar atributos

‹‹ Anterior | Siguiente ››

La pestaña Atributos de carpeta te permite personalizar cómo actúa Attribute Changer sobre las carpetas y en su caso en las sibcarpetas. Todos los atributos, incluso fecha, hora y compresión pueden modificarse si lo permite el sistema operativo.

Los atributos de carpetas (Sólo lectura, Oculto, Archivo, Sistema, Comprimir e Índice) pueden encontrarse en tres estados:

el atributo será desactivado

el atributo será activado

el atributo no será modificado

Si utilizas Attribute Changer en una carpeta y quieres procesar las subcarpetas, necesitarás activar la opción Aplicar a subcarpetas.

Atención: Ten cuidado al cambiar los atributos Sistema y Oculto. El sistema operativo Windows los utiliza para indicar archivos y carpetas especiales.

Nota: Los atributos Comprimir e Índice sólo pueden modificarse en los sistemas NT (NT, 2000 y XP) y sólo están disponibles en las particiones NTFS. La fecha y hora de una carpeta sólo pueden modificarse en los sistemas NT.


Atributos de carpeta - Cambios avanzados

Atributos de carpeta - Cambiar fecha y hora

‹‹ Anterior | Siguiente ››

Puedes elegir entre ajustes de fecha/hora absolutos y relativos en función del estado de la casilla de verificación Usar ajustes relativos.

Ajustes absolutos de fecha y hora

Usa ajustes absolutos si quieres aplicar fechas y horas determinadas a las carpetas. Para activar esta opción, marca la casilla de verificación Modificar fecha y hora y desmarca la casilla Usar ajustes relativos.

Hay disponible un menú contextual en las diferentes partes de la fecha y la hora para operaciones de sincronización básicas.

Hay más opciones avanzadas disponibles haciendo clic en el botón Configuración. La caja de diálogo te permite definir exactamente la parte de la fecha y hora (Creado, Modificado, Con acceso) a modificar. Además, la pestaña Máscaras se puede usar para permitir actualizaciones parciales, tales como únicamente los días y los segundos.

Vamos a ver un ejemplo:

    Has cambiado la hora de las carpetas (Creado, Modificado, Con acceso) en la pestaña Atributos de carpeta a las 21:15:30 pero sólo quieres cambiar la parte de los minutos en la hora de las carpetas.

    Abre la caja de diálogo Configuración y marca todas las propiedades de hora (Creado, Modificado y Con acceso) para permitir la actualización de la parte de la hora Creado. En la pestaña Máscaras, desmarca todas las opciones de tiempo excepto Minutos y haz clic en OK.

    Si Attribute Changer procesa ahora una carpeta con:

    Hora de creación | 22:05:14
Hora de modificación | 23:58:06
Hora de acceso | 16:01:50

    el resultado será una carpeta con las siguientes horas:

    Hora de creación | 22:15:14
Hora de modificación | 23:15:06
Hora de acceso | 16:15:50

Ajustes relativos de fecha y hora

Usa ajustes relativos si quieres aplicar desplazamientos de fecha y hora a las carpetas. Simplemente marca la casilla de verificación Modificar fecha y hora y haz clic en el botón Configuración para personalizar. La caja de diálogo te permite definir exactamente la parte de la fecha y hora (Creado, Modificado, Con acceso) a actualizar. Las pestañas Fecha y hora te permiten personalizar los despplazamientos y límites a aplicar.

La pestaña Fecha se usa para configurar desplazamientos de días, meses y años. Puedes utilizar valores positivos o negativos e incluso combinar las diferentes partes. Por ejemplo, es posible configurar un desplazamiento de -5 días y de +1 año.

Si decides no usar desplazamientos de fecha, simplemente establece los valores en 0 y desmarca la casilla Limitar fecha a.

La opción Limitar fecha a es muy útil, pues te permite definir límites de fecha que no pueden superarse. La fecha obtenida no se aplica a la carpeta si no pertenece al rango definido por los límites inferior y superior. Si la fecha obtenida rebasa uno de los límites definidos, se aplicará a la carpeta el valor límite.

Veamos un ejemplo:

    Fecha | 27 Octubre 2002
Desplazamiento de meses | 3
Fecha obtenida | 27 Enero 2003
  • Sin limitación de fecha:

      Attribute Changer establece como fecha 27 Enero 2003

  • Limitar fecha entre 19 Junio 2002 y 14 Enero 2003:

      Attribute Changer rechaza la fecha obtenida y no se aplica ningún cambio a la carpeta.

  • Limitar fecha entre 19 Junio 2002 y 14 Enero 2003 / Usando la opción Limitar fecha a

      Attribute Changer rechaza la fecha obtenida y se aplica el límite correspondiente (14 Enero 2003) a la carpeta.

Por favor, ten en cuenta que al utilizar desplazamientos de fechas se pueden producir desbordamientos. Por ejemplo, si añades 5 días a la fecha 27/03/2002 se obtendrás la fecha 01/04/2002.

La pestaña Hora ofrece exactamente la misma funcionalidad que la pestaña Fecha, explicada anteriormente.


Atributos de carpeta - Usar filtros

Usa esta caja de diálogo para buscar las carpetas que cumplen ciertos criterios (fecha, hora y atributos). Sólo se modificarán las carpetas que cumplan todos los los criterios de filtrado marcados.

El filtro Fecha se usa para seleccionar carpetas con una cierta fecha. Puedes filtrar automáticamente las carpetas con fechas corruptas en sistemas NT (con fecha de creación anterior al 1 de Enero de 1980o posterior al 31 de Diciembre de 2099) seleccionando la opción Sólo carpetas corruptas. Deberás usar filtros de Hora para filtrar carpetas basándote en criterios de hora (creación, modificación, acceso).

Filtrar carpetas por atributos puede ser útil cuando quieres excluir todas las carpetas señaladas como Sistema o Oculto. Ten en cuenta que la casilla de cada atributo puede estar en tres estados distintos:

el atributo será desactivado

el atributo será activado

el atributo no será modificado


Atributos de carpeta - Usar excepciones

‹‹ Anterior | Siguiente ››

Esta caja de diálogo se usa para incluir/excluir la modificación de carpetas que coinciden con una extensión o con un patrón.

Marca la opción Incluir todas las carpetas, salvo para actuar sobre todas las carpetas que Attribute Changer encuentre salvo las definidas en la lista de excepciones. Para excuir la carpeta C:\Mis Documentos, añade C:\Mis Documentos a la lista. Puedes usar patrones para excluir de la búsqueda por ejemplo todas las carpetas que contengan la cadena ‘Personal’, simplemente añadiendo *Personal* a la lista.


Atributos de archivo - Cambios básicos

Atributos de archivo - Cambiar atributos

‹‹ Anterior | Siguiente ››

La pestaña Atributos de archivo te permite personalizar cómo actúa Attribute Changer sobre los archivos. Todos los atributos, incluso fecha, hora y compresión pueden modificarse si lo permite el sistema operativo.

Los atributos de archivos (Sólo lectura, Oculto, Archivo, Sistema, Comprimir e Índice) pueden encontrarse en tres estados:

el atributo será desactivado
el atributo será activado
el atributo no será modificado

Si utilizas Attribute Changer en una carpeta y quieres procesar los archivos de las subcarpetas, necesitarás activar la opción Aplicar a subcarpetas.

Atención: Ten cuidado al cambiar los atributos Sistema y Oculto. El sistema operativo Windows los utiliza para indicar archivos y carpetas especiales.

Nota: Los atributos Comprimir e Índice sólo pueden modificarse en los sistemas NT (NT, 2000 y XP) y sólo están disponibles en las particiones NTFS. La fecha y hora de una carpeta sólo pueden modificarse en los sistemas NT.


Atributos de archivo - Cambios avanzados

Atributos de archivo - Cambiar fecha y hora

‹‹ Anterior | Siguiente ››
Puedes elegir entre ajustes de fecha/hora absolutos y relativos en función del estado de la casilla de verificación Usar ajustes relativos.

Ajustes absolutos de fecha y hora

Usa ajustes absolutos si quieres aplicar fechas y horas determinadas a los archivos. Para activar esta opción, marca la casilla de verificación Modificar fecha y hora y desmarca la casilla Usar ajustes relativos.

Hay disponible un menú contextual en las diferentes partes de la fecha y la hora para operaciones de sincronización básicas.

Hay más opciones avanzadas disponibles haciendo clic en el botón Configuración. La caja de diálogo te permite definir exactamente la parte de la fecha y hora (Creado, Modificado, Con acceso) a modificar. Además, la pestaña Máscaras se puede usar para permitir actualizaciones parciales, tales como únicamente los días y los segundos.

Vamos a ver un ejemplo:

Has cambiado la hora de los archivos (Creado, Modificado, Con acceso) en la pestaña Atributos de carpeta a las 21:15:30 pero sólo quieres cambiar la parte de los minutos en la hora de los archivos.

Abre la caja de diálogo Configuración y marca todas las propiedades de hora (Creado, Modificado y Con acceso) para permitir la actualización de la parte de la hora Creado. En la pestaña Máscaras, desmarca todas las opciones de tiempo excepto Minutos y haz clic en OK.

Si Attribute Changer procesa ahora un archivo con:

Hora de creación | 22:05:14
Hora de modificación | 23:58:06
Hora de acceso | 16:01:50

el resultado será un archivo con las siguientes horas:

Hora de creación | 22:15:14
Hora de modificación | 23:15:06
Hora de acceso | 16:15:50

Ajustes relativos de fecha y hora

Usa ajustes relativos si quieres aplicar desplazamientos de fecha y hora a los archivos. Simplemente marca la casilla de verificación Modificar fecha y hora y haz clic en el botón Configuración para personalizar. La caja de diálogo te permite definir exactamente la parte de la fecha y hora (Creado, Modificado, Con acceso) a actualizar. Las pestañas Fecha y hora te permiten personalizar los despplazamientos y límites a aplicar.

La pestaña Fecha se usa para configurar desplazamientos de días, meses y años. Puedes utilizar valores positivos o negativos e incluso combinar las diferentes partes. Por ejemplo, es posible configurar un desplazamiento de -5 días y de +1 año.

Si decides no usar desplazamientos de fecha, simplemente establece los valores en 0 y desmarca la casilla Limitar fecha a.

La opción Limitar fecha a es muy útil, pues te permite definir límites de fecha que no pueden superarse. La fecha obtenida no se aplica al archivo si no pertenece al rango definido por los límites inferior y superior. Si la fecha obtenida rebasa uno de los límites definidos, se aplicará al archivo el valor límite.

Veamos un ejemplo:

    Fecha | 27 Octubre 2002
Desplazamiento de meses | 3
Fecha obtenida | 27 Enero 2003
  • Sin limitación de fecha:

      Attribute Changer establece como fecha 27 Enero 2003

  • Limitar fecha entre 19 Junio 2002 y 14 Enero 2003:

      Attribute Changer rechaza la fecha obtenida y no se aplica ningún cambio al archivo.

  • Limitar fecha entre 19 Junio 2002 y 14 Enero 2003 / Usando la opción Limitar fecha a

      Attribute Changer rechaza la fecha obtenida y se aplica el límite correspondiente (14 Enero 2003) al archivo.

Por favor, ten en cuenta que al utilizar desplazamientos de fechas se pueden producir desbordamientos. Por ejemplo, si añades 5 días a la fecha 27/03/2002 se obtendrás la fecha 01/04/2002.

La pestaña Hora ofrece exactamente la misma funcionalidad que la pestaña Fecha, explicada anteriormente.


Atributos de archivo - Usar filtros

Usa esta caja de diálogo para buscar los archivos que cumplen ciertos criterios (fecha, hora y atributos). Sólo se modificarán los archivos que cumplan todos los los criterios de filtrado marcados.

El filtro Fecha se usa para seleccionar archivos con una cierta fecha. Puedes filtrar automáticamente los archivos con fechas corruptas en sistemas NT (con fecha de creación anterior al 1 de Enero de 1980o posterior al 31 de Diciembre de 2099) seleccionando la opción Sólo archivos corruptos. Deberás usar filtros de Hora para filtrar archivos basándote en criterios de hora (creación, modificación, acceso). Los filtros de tamaño son útiles para seleccionar únicamente arxhivos de cierto tamaño o en cierto rango. Puedes especificar el tamaño en byte, KBytes y MBytes, teniendo en cuenta que 1Kb son 1024 bytes y 1Mb son 1024 Kbytes.

Filtrar archivos por atributos puede ser útil cuando quieres excluir todas los archivos señalados como Sistema o Oculto. Ten en cuenta que la casilla de cada atributo puede estar en tres estados distintos:

attribute must be reset

attribute must be set

attribute will not be used


Atributos de archivo - Usar excepciones

Esta caja de diálogo se usa para incluir/excluir la modificación de archivos que coinciden con una extensión o con un patrón.

Marca la opción Incluir todas los archivos, salvo para actuar sobre todas los archivos que Attribute Changer encuentre salvo los definidas en la lista de excepciones. Para excuir todos los archivos con extensión HTML y EXE, añade *.HTML y *.EXE a la lista. Puedes incluso utilizar patrones. Para excluir todos los archivos que contengan la cadena 'carta', simplemente añade *cartal* a la lista.

Puedes añadir archivos a la lista de excepciones arrastrando y soltando. Para excluir todos los archivos de una carpeta en particular, arrastra la carpeta a la lista de excepciones y Attribute Changer añade el filtro a la lista.

Otras posibilidad interesante es la opción de grupo al arrastrar y soltar. Si esta opción está marcada, Attribute Changer convertirá cualquier nombre de archivo arrastrado en un comodín.

Supongamos que quieres excluir todos los archivos HTML de todas las carpetas. Además, todos los archivos que copincidan con el patrón ‘carta’ deben excluirse de la carpeta C:\Mis Documentos y todas sus subcarpetas.

Simplemente añade las siguientes entradas a la lista de excepciones:

  • *.HTML --> filtra todos los archivos HTML
  • C\Mis Documentos\*\*carta* --> filtra los archivos que coincidan con el patrón 'carta' en la carpeta "Mis Documentos" y sus subcarpetas

Las mismas opciones de configuración están disponibles en la opción ‘Excluir todos los archivos, salvo’.

Ejemplo de arrastrar y soltar en grupo:

Si quieres añadir todos los archivos DLL y EXE de una carpeta a la lista de excepciones desde una carpeta con archivos con muchas extensiones diferentes, simplemente marca la opción ‘Agrupar extensiones de archivos'’ y selecciona únicamente un archivo DLL y un archivo EXE. Arrástralos a la lista de excepciones y Attribute Changerlos converitrá en las reglas de excepción *.DLL y *.EXE.


Filtros y excepciones

‹‹ Anterior | Siguiente ››

Si quieres restringir el conjunto de archivos y carpetas a modificar, necesitas personalizar filtros y excepciones. Los filtros se establececn para seleccionar los objetos que cumplen ciertos criterios (fecha, hora, tamaño y atributos). Estos criterio se aplican conjuntamente con las excepciones y deben usarse simultáneamente para crear potentes filtros. Las excepciones son listas de patrones de nombres de archivo y carpeta (patrones de extensiones o de nombres) que deben incluirse/excluirse por el buscador de Attribute Changer. Las excepciones y filtros de carpeta sólo se aplican a la carpeta misma, no a su contenido.


Vigilar el proceso

‹‹ Anterior | Siguiente ››

Debes usar la pestaña Actividad y Resultados para vigilar el desarrollo del proceso que realiza Attribute Changer y verificar que todos los archivos están actualizados. Todos los archivos y carpetas bloqueados se muestran inmediatamente en el área superior de la caja de diálogo.

La parte inferior de la pestaña muestra la carpeta y archivo en proceso.

Puedes ordenar la lista por el nombre de archivo o por carpeta haciendo clic en la cabecera de la lista correspondiente. La lista obtenida puede exportarse a un archivo de texto haciendo clic derecho y seleccionando en el menú contextual la opción 'Guardar en archivo..' .


Configuración

Configuración global

Ahí están definidas las configuraciones que dependen del usuario que se escriben en la parte HKEY_CURRENT_USER del registro de Windows.. Esto permite que varios usuarios utilicen Attribute Changer en el mismo ordenador (para más información, ver la sección Cambios en el sistema).

La pestaña Configuración global se divide en tres partes: configraciones relacionadas con los atributos, configuraciones relacionadas con filtros y excepciones y configuraciones no relacionadas con ninguna de las categorías anteriores.

Configuraciones relacionadas con filtros y excepciones

La configuraciones relacionadas con filtros y excepciones permiten retener las excepciones/filtros definidas en ese momento y guardarlas en el registro.

Otras configuraciones

Ordenar la lista de resultados es útil si deseas que la aplicación automáticamente mantenga una lista ordenada de excepciones. Siempre puedes ordenarla manualmente haciendo clic en la cabecera de la columna.

Todos estos parámetros se restauran la siguiente vez que se usa Attribute Changer y no se comparten entre usuarios.

Para más información, consulta la sección Cambios en el sistema.


Información

‹‹ Anterior | Siguiente ››

La pestaña Acerca de te informa de la versión exacta de Attribute Changer que estás utilizando. Por favor incluye la versión exacta si envías un correo electrónico solicitando ayuda.


Historia de las versiones

Version 5.23 - Build 27 January 2004

Bug fixes

    Relative time changes on file and folder ignores seconds offset value

Version 5.22a - Build 4 January 2004

Updates

    Version resource strings incorrect on About tab

Version 5.22 - Build 2 January 2004

Bug fixes

    Problems with DPI settings > 96
    Fixed errors in User's guide (CHM help file)

Updates

    Optimized installation script
    Use LZMA compression in NSIS 2.0 installer

Version 5.21 - Build 4 November 2003

Bug fixes

    Registry handle not closed in shell extension
    Duplicate menu entries in context menu (Explorer with activated folder view)
    Shell extension menu entry should now rework on NT 4.0

Version 5.20a - Build 20 August 2003

Bug fixes

    Startup error message when selecting multiple objects in French version

Version 5.20 - Build 27 July 2003

Bug fixes

    .LNK and .URL files couldn't be changed
    Fixed errors in User's guide (CHM help file)
    Drag & Drop for file and folder exceptions broken

Version 5.20 - Build 20 July 2003

New features

    E-Mail and Website information on About tab are now clickable
    ESC key now cancels processing thread
    ESC key now quits application and any dialog box

Bug fixes

    Corrupted resource strings in french version
    Translated forgotten strings in french version
    Folder filters not enabled for single selection with active 'Recurse folders' option
    Folder exceptions not enabled for single selection with active 'Recurse folders' option
    Installer now takes care of user selected installation path and program group

Version 5.0 - Build 21 April 2003

New features

    Multi-Language installer now based on NSIS Install Sistema
    Absolute date/time settings are now the defaults
    Position of context menu item can be configured
    Resource DLL for localization strings
    OK button to apply changes and immediately quit the application
    Relative file and folder time adjustmentss
    Relative file and folder date adjustments
    Display current attributes, date and time
    Independant values for Accessed, Modified and Created date/time properties
    Enhanced absolute date and time properties
    Make use of font smoothing when available

Updates

    Redesigned graphical user interface
    Improved context-sensitive help
    Improved help file

Version 4.20 - Build 4 August 2002

New features

    Added code to support localizations

Bugfixes

    Compress option in attribute filters not correctly enabled/disabled
    Index option in attribute filters not correctly enabled/disabled
    Focus problem in file and folder filters
    Drag and Drop problem in listviews

Updates

    Improved help file

Version 4.10 - Build 1 May 2002

Bugfixes

    file and folder date/time filters don't work correctly
    Filter and Exception global settings are not saved in the registry
    Settings on Tuning tab are not correctly saved in the registry
    Application crash when launched from drive context menu

Updates

    Added support for Windows XP themes

Version 4.0a - Build 26 December 2001

Bug fixes

    Decompression of files and folders when altering date stamp
    Explorer.exe crashes on WinXP when exploring Start menu items

Version 4.0 - Build 11 December 2001

New features

    COM in-process server for multi-selection
    Universal attribute changer program
    Root folder attributes now changed as well
    Change Created, Modified, Accessed date/time properties
    Filter Created, Modified, Accessed date/time properties

Updates

    Complete rewrote of processing engine
    Minor graphical interface changes (new icons etc.)
    Redesigned and updated help file now in HTML format

Version 3.0a - Build 17 April 2001

Updates

    Reduced help file size by 800Kb (optimized images)
    Installation now build with Inno Setup and ISTool

Bug fixes

    ‘Created after’ date/time file filter does not work correctly
    ‘Created after’ date/time folder filter does not work correctly
    Blue screen on Win98 when accessing files and folders with corrupt dates

Version 3.0 - Build 12 February 2001

New features

    Filters and Exceptions for folders
    file and folder filter options
    - search for creation date after <date>
    - search for creation date before <date>
    - search for creation time after <time>
    - search for creation time before <time>
    Additional file filter options
    - search for size greater <size>
    - search for size smaller <size>
    Índice attribute now supported on Win2K platform for files and folders
    Comprimir attribute now supported for folders
    Setting creation date and time on files/folders can be masked (partial modifications)
    Popup menu entry to clear result list
    Options to reset date/time to the current stamp
    Drag and drop supported for exception dialogs (include group drag and drop)
    Shortcuts (Ins, Del, Ctrl+A, F2) supported in Exception dialog box
    Repair corrupt folder dates (NT/2000 only)
    Button to call user’s guide from About tab

Updates

    Finished the reengineering of Attribute Changer's code
    Redesigned exception dialogs
    Improved online help (? in Attribute Changer title bar)
    Updated help file
    Automatic registry update from any release to version 3.0 (migrates old data)
    Updated self-healing mechanism

Bug fixes

    file exceptions without folder part are not processed (ex. *.DLL)
    file exceptions with wildcards (*.BMP) also processed in subfolders
    folder time set to file time if file and folder time modifications are selected

Version 2.50a - Build 16 July 2000

Bug fixes

    Modification time is 2 seconds ahead of creation time on FAT32

Version 2.50 - Build 13 June 2000

New features

    Keep window position settings from previous session
    Option to enable/disable 'Save window positions'
    Option to enable/disable 'Automatically sort result list'
    Option to repair corrupt dates (< 1980 and > 2099)
    Option to globally enable/disable Filters
    Option to globally enable/disable Exceptions
    Escape key closes Filter and Exception dialog box and discards changes
    Filter out files based on attribute settings
    Online help now available for Filter and Exception dialog boxes
    Save results list to a file

Updates

    Windows 2000 compliant
    Complete rewrote of settings/registry management
    Complete rewrote of search and processing thread
    Important speed improvements
    Cleaner registry key HKEY_CURRENT_USER\Software\Romain’s Software
    Improved error handling
    Improved file handle sharing management
    Automatic registry update from any release to version 2.5 (migrates old data)
    Better self-healing mechanism
    file and folder information now shortened on Activity tab if necessary
    Root folder name now shortened on folder tab if necessary
    Improved online help
    Updated help file

Bug fixes

    Access violation when access to folder is denied (Win2K System folders)
    Random access violations under certain conditions at end of job (finally resolved)
    Size field in filter dialog now correctly displays decimal numbers without thousands formatting

Version 2.10 - Build 6 February 2000

Bug fixes

    Fixed problem with application crash at startup on some Sistemas
    Fixed problem with unreleased file handles when filters are used
    Fixed problem adding folder entries to exception list when no file patterns are available
    Blue screen on Windows 9x when Activity tab was active at end of job

Updates

    Added display for current file on Activity and Results tab

Version 2.00 - Build 27 January 2000

New features

    Change date and time on files
    Change date and time on folders (NT only)
    Compress and decompress files (NT only using NTFS)
    Filter options (Date, time and size)
    Include/Exclude files and folders (Supports wildcards)
    Self-healing application (Recreates missing registry entries at startup)
    Automatic registry upgrade (From version 1.10 to 2.0 with lost of current settings)
    Options to save parameters (file attributes, folder attributes, filters and exceptions)

Updates

    Restructured registry key HKEY_CURRENT_USER\Software\Romain’s Software
    Online error reporting
    Updated user interface
    Updated help file

Bug fixes

    Fixed problem with folder attributes not changed when ‘Subfolders’ checkbox not checked
    Fixed problem with window position out of screen when working on resolutions < 1152 x 864

Version 1.10 - Build 8 June 1999

New features

    Added online help

Bug fixes

    Fixed problem with saving application state

Version 1.00 - Build 5 May 1999

    Initial release (not public)


Cambios en el sistema

‹‹ Anterior

Esta aplicación ha sido escrita con Borland Delphi 5. Todos los datos de configuración se almacenan en la parte HKEY_CURRENT_USER del registro de Windows.

Los cambios seguientes son realizados por el Instalador NSIS (Gratuito) y el registro de objetos COM:

  • Crea la carpeta \Romain's Software\Attribute Changer en <Archivos de Programa> y copia los siguientes archivos en ella: acmain.exe, acshell.dll, acui.hlp, acui.cnt y ac.chm.
  • Crea un grupo de programas en el menú Inicio y añade los accesos directos: Help, Uninstall y Attribute Changer WebSite.
  • Añade una clave {D3F9A525-8824-497A-BE36-B23E22F141FC} para el objeto COM GUID en HKLM\Software\Classes\CLSID y una clave ACShell.ACShell para el objeto COM en HKLM\Software\Classes.
  • Añade las siguientes entradas de registro en HKLM\Software\Classes key:

    • *\shellex\ContextMenuHandlers: añade la clave 'ACShell' y {D3F9A525-8824-497A-BE36-B23E22F141FC} como valor por defecto.
    lnkfile\shellex\ContextMenuHandlers: añade la clave 'ACShell' y {D3F9A525-8824-497A-BE36-B23E22F141FC} como valor por defecto.
    Directory\shellex\ContextMenuHandlers: añade la clave ''ACShell' y {D3F9A525-8824-497A-BE36-B23E22F141FC} como valor por defecto.
    Drive\shellex\ContextMenuHandlers: añade la clave 'ACShell' y {D3F9A525-8824-497A-BE36-B23E22F141FC} como valor por defecto.
    InternetShortcut\shellex\ContextMenuHandlers: añade la clave 'ACShell' y {D3F9A525-8824-497A-BE36-B23E22F141FC} como valor por defecto.

  • Añade las siguientes entradas de registro a HKLM\Software\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved:

    • {D3F9A525-8824-497A-BE36-B23E22F141FC} con datos de las extensiones de shell de Attribute Changer.

  • Añade las siguientes entradas de registro a HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\HELP key:

    • ac.chm con los datos <Program Archivos>\Romain’s Software\Attribute Changer
    acui.hlp con los datos <Program Archivos>\Romain's Software\Attribute Changer

El resto de la información se almacena en la parte HKEY_CURRENT_USER\Software\Romain's Software\Attribute Changer del registro y se crea al ejecutarse por primera vez. Aquí tienes una breve descripción de los valores usados por Attribute Changer:

    File Attributes: Todos los datos de configuración disponibles en la pestaña Atributos de archivo, incluso las opciones de configuración de archivo avanzadas.

    Folder Attributes: Todos los datos de configuración disponibles en la pestaña Atributos de carpeta, incluso las opciones de configuración de carpeta avanzadas.

    File Filter: Todos los datos de configuración disponibles en Filtos y excepciones --> Filtros de archivo en la caja de diálogo Configurar filtro de archivo.

    Folder Filter: Todos los datos de configuración disponibles en Filtos y excepciones --> Filtros de carpeta en la caja de diálogo Configurar filtro de carpeta.

    Global Settings: Todos los datos de configuración disponibles en la pestaña Configuración global,

    File Exceptions: Todos los datos de configuración disponibles en Filtos y excepciones --> Excepciones de archivo en la caja de diálogo Configurar excepciones de archivo. Los valores del registro bajo la clave List representan las entradas en la lista de excepciones.

    Folder Exceptions: Todos los datos de configuración disponibles en Filtos y excepciones --> Excepciones de carpeta en la caja de diálogo Configurar excepciones de carpeta. Los valores del registro bajo la clave List representan las entradas en la lista de excepciones.

Importante: Las entradas del registro anteriores se crean automáticamente si no existen y deben eliminarse manualmente si se desinstala la Attribute Changer del Sistema.
Ayuda de Attribute Changer | Copyright © Romain Petges ‹‹ Anterior