Dialogfeld "SQL Server-Anmeldung"

Send us feedback about this page Hilfe zur Anmeldung bei OLE DB

Dialogfeld "SQL Server-Anmeldung"

Das Dialogfeld SQL Server-Anmeldung wird vom Microsoft® SQL Server™ OLE DB-Provider angezeigt, wenn Sie eine OLE DB-Verbindung aufrufen, ohne genügend Informationen zum Herstellen einer Verbindung durch den Treiber anzugeben.

Wenn das Dialogfeld SQL Server-Anmeldung zum ersten Mal angezeigt wird, enthält es nur folgende Elemente:

Feld Server

Kontrollkästchen Vertrauenswürdige Verbindung verwenden

Feld Benutzername

Feld Kennwort

Schaltflächen OK, Abbrechen, Hilfe und Optionen

Wenn Sie auf die Schaltfläche Optionen klicken, wird auch die Gruppe mit Optionen angezeigt:

Feld Datenbank

Feld Sprache

Feld Anwendungsname

Feld Arbeitsstations-ID

Feld Server

Der Name eines SQL Servers im Netzwerk. Wenn Sie einen Servernamen aus der Liste auswählen, sind keine weiteren Konfigurationseinstellungen erforderlich. Wenn Sie den Namen eines Servers eingeben, muss dieser ein erweiterter Eintrag in dem SQL Clientkonfigurationsprogramm oder der Netzwerkname eines Servers sein, auf dem SQL Server ausgeführt wird.

Sie können (lokal) in dem Serverfeld auswählen, wenn sich auf dem Computer, an dem Sie arbeiten, auch SQL Server befindet. Der Benutzer kann dann eine Verbindung zur lokalen Kopie vom SQL Server herstellen, sogar dann, wenn eine Version vom SQL Server ausgeführt wird, die sich nicht im Netzwerk befindet. Beim Angeben einer benannten Instanz von SQL Server wird der Servername als Servername\Instanzname angegeben.

Weitere Informationen über Servernamen für verschiedene Netzwerkarten finden Sie in der Installationsdokumentation von SQL Server in der Onlinedokumentation von SQL Server.

Kontrollkästchen Vertrauenswürdige Verbindung verwenden

Ist das Kontrollkästchen aktiviert, legt es fest, dass der SQL Server-OLE DB-Provider eine sichere (vertraute) Verbindung mit einem SQL Server anfordert, auf dem Microsoft Windows NT® oder Microsoft Windows® 2000 ausgeführt wird. Bei aktivierter Option verwendet SQL Server die integrierte Anmeldungssicherheit, um Verbindungen mit dieser Datenquelle herzustellen, und zwar unabhängig vom aktuellen Ameldungssicherheitsmodus auf dem Server. Angegebene Benutzernamen oder Kennwörter werden ignoriert. Der Systemadministrator von SQL Server muss Ihren Microsoft Windows®-Benutzernamen mit einer SQL Server-Anmeldungs-ID verknüpft haben.

Ist dieses Kontrollkästchen nicht aktiviert, verwendet der SQL Server zum Herstellen von Verbindungen mit dieser Datenquelle die standardmäßige Anmeldungssicherheit. Hier müssen Sie bei allen Verbindungsanforderungen einen Benutzernamen und ein Kennwort angeben.

Feld Benutzername

Hier wird die SQL Server-Anmeldungs-ID festgelegt, die für die Verbindung verwendet werden soll, wenn Vertrauenswürdige Verbindung verwenden nicht aktiviert ist. Wenn Vertrauenswürdige Verbindung verwenden ausgewählt wurde, ist das Feld Benutzername deaktiviert.

Feld Kennwort

Hier wird das Kennwort für die SQL Server-Anmeldungs-ID festgelegt, das verwendet wird, wenn Vertrauenswürdige Verbindung verwenden nicht aktiviert ist. Wenn Vertrauenswürdige Verbindung verwenden ausgewählt wurde, ist das Feld Kennwort deaktiviert.

Feld Datenbank

Hier wird die Standarddatenbank angegeben, die bei der Verbindung verwendet werden soll. Diese Angabe überschreibt die Standarddatenbank, die für die Anmeldung auf dem Server angegeben wurde. Wird keine Datenbank festgelegt, verwendet die Verbindung die Standarddatenbank, die für die Anmeldung auf dem Server festgelegt wurde.

Feld Sprache

Hier wird die Landessprache für SQL Server-Systemmeldungen festgelegt. Die ausgewählte Sprache muss auf dem SQL Server installiert sein. Hierdurch wird die Standardsprache überschrieben, die für die Anmeldung beim Server angegeben wurde. Wenn keine Sprache festgelegt wurde, wird für die Verbindung die Standardsprache verwendet, die für die Anmeldung beim Server angegeben wurde.

Feld Anwendungsname

Hier kann optional der Anwendungsname angegeben werden, der unter master.dbo.sysprocesses in der Spalte program_name in der Zeile für diese Verbindung gespeichert wird.

Feld Arbeitsstations-ID

Hier kann optional die Arbeitsstations-ID angegeben werden, die unter master.dbo.sysprocesses in der Spalte hostname in der Zeile für diese Verbindung gespeichert wird.

©1988-2000 Microsoft Corporation. Alle Rechte vorbehalten.


SQL Server 2000 Copyright und Verzichterklärung

Dieses Dokument, einschließlich der enthaltenen Beispielanwendungen, wird nur zu Informationszwecken bereitgestellt; Microsoft übernimmt in diesem Dokument keine Garantien, weder ausdrücklich noch stillschweigend. In diesem Dokument enthaltene Informationen, einschließlich Beispiele, URL und andere Internet-Website-Referenzen, können ohne vorherige Ankündigung geändert werden. Der Benutzer trägt das vollständige Risiko für die Verwendung oder für die sich aus der Verwendung dieses Dokuments ergebenden Konsequenzen.

Ein Beispiel hat die primäre Aufgabe, ein Konzept oder die angemessene Verwendung einer bestimmten Anweisung oder Klausel zu verdeutlichen. Die meisten Beispiele enthalten nicht sämtlichen Code, der normalerweise in einem vollständigen Produktionssystem zu finden ist. Es wurden viele der üblichen Datenbestätigungs- und Fehlerbehandlungsinformationen entfernt, damit sich das Beispiel auf ein bestimmtes Konzept oder eine bestimmte Anweisung konzentrieren kann. Für diese Beispiele oder für den bereitgestellten Quellcode ist keine technische Unterstützung verfügbar.

Wenn nicht anders angegeben, sind die hier als Beispiel genannten Firmen, Organisationen, Produkte, Personen und Ereignisse fiktiv, und es wird kein Zusammenhang mit irgend einer tatsächlichen Firma, Organisation, Produkt, Person oder Ereignis beabsichtigt oder abgeleitet. Das Einhalten sämtlicher zur Anwendung kommenden Copyright-Vorschriften liegt in der Verantwortung des Benutzers. Ohne die durch das Copyright geschützten Rechte einzuschränken, darf kein Teil dieses Dokuments reproduziert, gespeichert oder in ein Abrufsystem eingeführt werden, oder in irgend einer Form, auf irgend eine Weise (elektronisch, mechanisch, per Fotokopie, Aufnahme oder anderweitig) oder für irgend einen Zweck übertragen werden, ohne daß eine ausdrückliche schriftliche Genehmigung der Microsoft Corporation erteilt wurde.

Microsoft kann Patente, Patentanwendungen, Warenzeichen, Copyrights oder andere geistige Eigentumsrechte haben, die Themenbereiche in diesem Dokument abdecken. Sie erhalten durch Bereitstellung dieses Dokument keine Lizenz für diese Patente, Warenzeichen, Copyrights oder anderes geistiges Eigentum, es sei denn, dies ist ausdrücklich in einer schriftlichen Lizenzvereinbarung von Microsoft festgelegt.

©1996-2000 Microsoft Corporation. Alle Rechte vorbehalten.

Active Directory, ActiveX, BackOffice, CodeView, Developer Studio, FoxPro, JScript, Microsoft, Microsoft Press, MSDN, MS-DOS, Outlook, PivotChart, PivotTable, PowerPoint, Visual Basic, Visual C++, Win32, Windows 2000, Windows und Windows NT sind entweder eingetragene Warenzeichen oder Warenzeichen der Microsoft Corporation in den USA und/oder anderen Ländern.

Die Namen von in diesem Dokument erwähnten tatsächlichen Firmen und Produkten können Warenzeichen des jeweiligen Eigentümers sein.

©1988-2000 Microsoft Corporation. Alle Rechte vorbehalten.