remoteIC - Help

Erste Schritte mit remoteIC

Verwenden Sie diese Tabelle, um sich schnell mit remoteIC vertraut zu machen.

Thema | Weitere Informationen
remoteIC-Dokumentation | Verwenden der Hilfe Service und Support
Aufbau von remoteIC | Grundlegendes Software-Pakete
Installieren und Ausführen von remoteIC | Ausführen von remoteIC Setup Aktualisieren einer älteren Version
Verwalten von remoteIC | Neue Datenbank erstellen Haupt-Distributionserver festlegen Überwachung mittels Controlserver Pakete definieren Die erste Verteilung Kontrolle einer Verteilung
Inventarisierung | Was wird angezeigt? Software für das Inventar definieren Systemdaten
Weitere Informationen | Tipps und Tricks Problembehandlung Häufig gestellte Fragen

Für diese Dokumentation wird keine Gewährleistung übernommen. Sie dient lediglich zu Informationszwecken. Sowohl textlicher Inhalt als auch Grafiken unterliegen dem internationalem Copyright Schutz.


Verwenden des HTML-Hilfe-Viewers

Die SQL Server-Onlinedokumentation wird mithilfe des HTML-Hilfe-Viewers angezeigt.

Verwenden der Volltextsuche

Eine einfache Suche nach Hilfethemen besteht aus dem Wort oder Ausdruck, den Sie suchen möchten. Sie haben mehrere Möglichkeiten, die Suche zu präzisieren:

  • Verwenden von Wörtern, Ausdrücken und Platzhaltern
  • Verwenden von Operatoren: AND, OR, NOT und NEAR
  • Verwenden geschachtelter Ausdrücke

Beim Durchführen einer Volltextsuche müssen Sie einige Richtlinien beachten:

  • Bei der Suche wird nicht zwischen Groß- oder Kleinschreibung unterschieden, deshalb können Sie Ihren Suchbegriff in Groß- oder Kleinbuchstaben eingeben.
  • Satzzeichen wie Punkt (.), Doppelpunkt (:), Semikolon (;), Komma (,) und Bindestrich (-) werden nicht berücksichtigt.
  • Gruppieren Sie die Elemente Ihrer Suche mithilfe von doppelten Anführungszeichen oder Klammern. Wenn Sie nach einem Dateinamen mit einer Erweiterung suchen, sollten Sie die gesamte Zeichenfolge in doppelte Anführungszeichen einschließen, z. B. “filename.ext”. Andernfalls wird der Punkt im Rahmen der Suche als AND ausgewertet. Der Punkt ist ein Trennzeichen, das den Dateinamen in zwei Begriffe unterteilt.

So suchen Sie mit der Volltextsuche nach Themen und Themenüberschriften

  1. Klicken Sie im Navigationsfenster des HTML-Hilfe-Viewers auf die Registerkarte Suchen, und geben Sie das zu suchende Wort oder den zu suchenden Ausdruck ein.
    • Wenn Sie nur in den Themenüberschriften suchen möchten, aktivieren Sie die Option Nur Titel suchen.
    • Wenn eine Suche nur innerhalb der zuvor ermittelten Themengruppe durchgeführt werden soll, aktivieren Sie die Option Vorherige Ergebnisse suchen.
    • Wenn Sie bei der Suche boolesche Operatoren verwenden möchten, klicken Sie auf die Schaltfläche mit dem Pfeil nach rechts.
  2. Klicken Sie auf Themenliste, markieren Sie das gewünschte Thema, und klicken Sie dann auf Anzeigen.
    • Klicken Sie auf Titel, Position oder Rang, um die Themenliste zu sortieren.

Wörter, Ausdrücke und Platzhalter

Sie können nach Wörtern und Ausdrücken suchen und Platzhalterausdrücke verwenden. In der folgenden Tabelle werden die Ergebnisse der verschiedenen Sucharten aufgeführt.

Suche | Beispiel | Ergebnis
Einzelnes Wort | Speicher | Themen, die das Wort „Speicher“ enthalten. (Sie erhalten auch die grammatikalischen Variationen, wie z. B. „speichern“ und „gespeichert“).
Ausdruck | „Neuer Operator“ oder Neuer Operator | Themen, die genau den Ausdruck „Neuer Operator“ und alle seine grammatikalischen Variationen enthalten. Ohne Anführungszeichen entspricht die Abfrage der Angabe von „Neuer AND Operator“, in der nach Themen gesucht wird, die anstelle des Ausdrucks die beiden Wörter einzeln enthalten.
Platzhalterausdrücke | esc* | Themen, die Begriffe wie „ESC“, „Escapesequenz“ usw. enthalten. Das Sternchen kann nicht das einzige Zeichen des Begriffs sein.
 | 80?86 | Themen, die Begriffe wie „80186“, „80286“, „80386“ usw. enthalten. Das Fragezeichen kann nicht das einzige Zeichen des Begriffs sein.
 | *86 | Themen, die Begriffe wie „386“, „486“, „x86“, „QEMM386“, „8086“ usw. enthalten. Das Sternchen kann nicht das einzige Zeichen des Begriffs sein.

Anmerkung Aktivieren Sie die Option Ähnliche Wörter suchen, um grammatikalische Variationen für den/die Suchbegriff(e) einzubeziehen. Die Suche nach dem Wort „Speicher” findet z. B. „Speicher”, „speichern” und „gespeichert”.

Operatoren: AND, OR, NOT und NEAR

Die Operatoren AND, OR, NOT und NEAR ermöglichen es Ihnen, die Suche zu präzisieren. Ohne Angabe eines Operators wird AND verwendet. Die Abfrage „Abstand Rand Drucken“ ist z. B. gleichbedeutend mit „Abstand und Rand und Drucken“.

Suche | Beispiel | Ergebnis
Beide Begriffe in demselben Thema | Dib AND Palette | Themen, die die beiden Wörter „Dib“ und „Palette“ enthalten.
Einer der Begriffe in einem Thema | Raster OR Vektor | Themen, die entweder das Wort „Raster“ oder „Vektor“ enthalten.
Der erste Begriff ohne den zweiten Begriff | ole NOT dde | Themen, die das Wort „OLE“, aber nicht das Wort „DDE“ enthalten.
Beide Begriffe nah beieinander in demselben Thema | Benutzer NEAR Kernel | Themen, die die Wörter „Benutzer“ und „Kernel“ enthalten und in denen diese Wörter maximal acht Wörter voneinander entfernt sind.

Anmerkung Die Zeichen |, & und ! können nicht als boolesche Operatoren verwendet werden (Sie müssen OR, AND und NOT verwenden).

Geschachtelte Ausdrücke

Die Schachtelung ermöglicht Ihnen die Erstellung komplexerer Suchausdrücke. Beispielsweise wird durch „Steuerelement AND ((aktiv OR dde) NEAR Fenster)“ nach Themen gesucht, die den Begriff „Steuerelement“ zusammen mit den nah beieinander liegenden Begriffen „aktiv“ und „Fenster“ enthalten, oder nach Themen, die „Steuerelement“ zusammen mit den nah beieinander liegenden Begriffen „DDE“ und „Fenster“ enthalten.

Wenn Sie Hilfethemen mittels geschachtelter Ausdrücke durchsuchen, müssen Sie einige Richtlinien befolgen:

  • Verwenden Sie Klammern, um Ausdrücke in einer Abfrage zu schachteln. Die Ausdrücke in Klammern werden vor dem Rest der Abfrage ausgewertet.
  • Suchen, die keine geschachtelten Ausdrücke enthalten, werden von links nach rechts ausgewertet. Durch die Angabe „Steuerelement NOT aktiv OR dde“ wird z. B. nach Themen gesucht, die den Begriff „Steuerelement“, jedoch nicht den Begriff „aktiv“ enthalten, oder nach Themen, die den Begriff „DDE“ enthalten. (Durch die Angabe von „Steuerelement NOT (aktiv OR dde)“ wird jedoch nach Themen gesucht, die den Begriff „Steuerelement“, jedoch weder den Begriff „aktiv“ noch den Begriff „DDE“ enthalten.)
  • Sie können in einem Ausdruck maximal fünf Schachtelungsebenen verwenden.

Andere Features des HTML-Hilfe-Viewers

So suchen Sie nach Informationen in einem Hilfethema

Im Folgenden werden die Registerkarten beschrieben, die im Navigationsfenster des HTML-Hilfe-Viewers bereitgestellt werden, um nach einem Hilfethema zu suchen.

  • Wenn Sie die Themen mithilfe der Einträge im Inhaltsverzeichnis durchsuchen möchten, klicken Sie auf die Registerkarte Inhalt.
  • Klicken Sie auf die Registerkarte Index, um eine Liste von Indexeinträgen anzuzeigen, und geben Sie dann entweder ein Wort ein oder führen Sie einen Bildlauf in der Liste durch. Ähnlich wie bei dem Index in einem gedruckten Buch werden Themen häufig unter mehr als einem Eintrag indiziert.
  • Klicken Sie auf die Registerkarte Suchen, um jedes Vorkommen eines Wortes oder eines Ausdrucks zu suchen, das möglicherweise in einem Hilfethema enthalten ist. Sie können die Suche eingrenzen, indem Sie Teilmengen von Themen definieren.
  • Wenn Sie ein Thema zu einer Liste mit häufig verwendeten Themen hinzufügen möchten, zeigen Sie das Thema an, das sie hinzufügen möchten, klicken Sie auf die Registerkarte Favoriten, und klicken Sie anschließend auf Hinzufügen.

So bewegen Sie sich durch zuvor angezeigte Themen

  • Klicken Sie auf Vorheriges, um das Hilfethema anzuzeigen, das im Inhaltsverzeichnis vor dem aktuellen Hilfethema aufgeführt wird.
  • Klicken Sie auf Weiter, um das Hilfethema anzuzeigen, das im Inhaltsverzeichnis nach dem aktuellen Hilfethema aufgeführt wird.
  • Klicken Sie auf Zurück, um das letzte der zuvor angezeigten Hilfethemen anzuzeigen.
  • Klicken Sie auf Vorwärts, um das nächste Hilfethema in einer Folge zuvor angezeigter Themen anzuzeigen.
  • Klicken Sie auf Startseite, um die Startseite der von Ihnen geöffneten Hilfedatei anzuzeigen.

Anmerkung Die Symbolleiste des HTML-Hilfe-Viewers enthält möglicherweise nicht alle der zuvor aufgeführten Optionen, um sich innerhalb der Hilfethemen zu bewegen.

So zeigen Sie andere verknüpfte Hilfethemen an

  • Klicken Sie in einem Hilfethema auf farbige, unterstrichene Wörter, um weitere Informationen anzuzeigen, die mit diesem Thema verbunden sind.

So kopieren Sie ein Hilfethema und fügen es in ein Dokument ein

  1. Klicken Sie im Themenfenster des HTML-Hilfe-Viewers mit der rechten Maustaste auf eine beliebige Stelle, klicken Sie auf Alles markieren, klicken Sie erneut mit der rechten Maustaste, und klicken Sie anschließend auf Kopieren.

    Dadurch wird das Thema in die Zwischenablage kopiert.

  2. Öffnen Sie das Dokument, in das Sie das Thema kopieren möchten.
  3. Positionieren Sie den Cursor dort, wo die Informationen eingefügt werden sollen, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

Anmerkung Wenn Sie nur einen Teil eines Themas kopieren wollen, markieren Sie diesen Teil, klicken Sie mit der rechten Maustaste auf die Auswahl und klicken dann auf Kopieren.

So drucken Sie ein Hilfethema

  • Klicken Sie im Themenfenster des HTML-Hilfe-Viewers mit der rechten Maustaste auf eine beliebige Stelle, und klicken Sie dann auf Drucken.

Anmerkung Wenn Sie aus der Registerkarte Inhalt heraus drucken, haben Sie die Möglichkeit, entweder das aktuelle Thema oder alle Themen unter der ausgewählten Überschrift zu drucken.

So blenden Sie das Navigationsfenster des HTML-Hilfe-Viewers aus oder ein

  • Klicken Sie auf Ausblenden, um das Navigationsfenster auszublenden, das die Registerkarten Inhalt, Index, Suchen und Favoriten enthält. Es wird nur das Themenfenster angezeigt.
  • Klicken Sie auf Anzeigen, um das Navigationsfenster anzuzeigen.

Anmerkung Wenn Sie den HTML-Hilfe-Viewer schließen, werden beim nächsten Öffnen des Viewers die zuletzt gewählten Einstellungen für Größe, Position und Navigationsfenster verwendet.

So ändern Sie die Farbe des Themenfensters des HTML-Hilfe-Viewers

  1. Klicken Sie in Microsoft® Internet Explorer, Version 4.0, im Menü Ansicht auf Internetoptionen.
  2. Klicken Sie auf der Registerkarte Allgemein auf Farben.
  3. Wählen Sie im Dialogfeld Farben die gewünschten Optionen, und klicken Sie dann auf OK.
  4. Klicken Sie auf der Registerkarte Allgemein auf Eingabehilfen.
  5. Aktivieren Sie unter Formatierung die gewünschten Kontrollkästchen, und klicken Sie dann auf OK.
  6. Klicken Sie im Dialogfeld Internetoptionen auf OK, um die neuen Farbeinstellungen anzuwenden.

Anmerkung Hierdurch wird nur die Farbe des Themenfensters des HTML-Hilfe-Viewers geändert.

So ändern Sie die Schriftgröße im Themenfenster des HTML-Hilfe-Viewers

  • Klicken Sie auf der Hilfe-Symbolleiste auf Schriftart.

Anmerkung Hierdurch wird nur die Schriftart im Themenfenster des HTML-Hilfe-Viewers geändert.

So verwenden Sie die Tastenkombination für Eingabehilfen im HTML-Hilfe-Viewer

Mithilfe der folgenden Tastenkombinationen können Sie sich im HTML-Hilfe-Viewer, Version 1.2, bewegen.

Aktion | Tastenkombination
Schließen des HTML-Hilfe-Viewers | ALT+F4
Wechseln zwischen dem HTML-Hilfe-Viewer und anderen geöffneten Fenstern | ALT+TAB
Anzeigen des Menüs Optionen | ALT+O
Aus- oder Einblenden des Navigationsfensters | ALT+O und dann T drücken
Drucken eines Themas | ALT+O und dann D drücken
Aktualisieren des Themas, das im Themenfenster angezeigt wird | ALT+O und dann K drücken
Zurückkehren zum vorhergehenden Thema | ALT+O und dann Z drücken
Wechseln zum nächsten Thema (vorausgesetzt, Sie haben es bereits zuvor angezeigt) | ALT+O und dann V drücken
Wechseln des Fokus zwischen Navigationsfenster und Themenfenster | F6
Bildlauf in einem Thema | NACH-UNTEN-TASTE oder NACH-OBEN-TASTE
Wechseln zum Ende oder Anfang eines Themas | STRG+ENDE bzw. STRG+POS1
Durchlaufen der Verknüpfungen in einem Thema oder aller Optionen einer Registerkarte | TAB

Mithilfe der folgenden Tastenkombinationen können Sie sich auf der Registerkarte Inhalt bewegen.

Aktion | Tastenkombination
Anzeigen der Registerkarte Inhalt | ALT+I
Öffnen eines Buches oder eines Ordners | EINGABETASTE
Schließen eines Buches oder eines Ordners | EINGABETASTE
Auswählen eines Themas | NACH-UNTEN-TASTE oder NACH-OBEN-TASTE
Anzeigen des ausgewählten Themas | EINGABETASTE

Mithilfe der folgenden Tastenkombinationen können Sie sich auf der Registerkarte Index bewegen.

Aktion | Tastenkombination
Anzeigen der Registerkarte Index | ALT+N
Auswählen eines Stichwortes in der Liste | NACH-UNTEN-TASTE oder NACH-OBEN-TASTE
Anzeigen des verbundenen Themas | ALT+Z

Mithilfe der folgenden Tastenkombinationen können Sie sich auf der Registerkarte Suchen bewegen.

Aktion | Tastenkombination
Anzeigen der Registerkarte Suchen | ALT+S
Starten einer Suche | ALT+L
Auswählen eines Themas in der Ergebnisliste | ALT+M und dann NACH-OBEN-TASTE oder NACH-UNTEN-TASTE
Anzeigen des ausgewählten Themas | ALT+Z


Verwenden der Hilfe

Um Sie bei der Arbeit optimal zu unterstützen, stellt Ihnen remoteIC verschiedene Arten der Hilfe zur Verfügung.

Windows-GUI rICadmin

Klicken Sie auf einen Befehl im Menü Help, um eine Liste der Hilfethemen anzuzeigen. Klicken Sie in Dialogfeldern auf die Schaltfläche Hilfe, oder drücken Sie die F1-TASTE, um kontextbezogene Hilfe anzuzeigen.

Web-Interface rICweb

Klicken Sie auf einen Befehl im Menü Help, um eine Liste der Hilfethemen anzuzeigen. Klicken Sie im Formular auf die Schaltfläche Hilfe.


Assistenten

remoteIC bietet mehrere Assistenten, welche Ihnen die Arbeit erleichtern.

Assistent | Funktion
Datenbank-Assistent | Der Datenbank-Assistent unterstützt Sie beim generieren der Datenbank. Es sind keine Datenbankkenntnisse erforderlich. Weitere Informationen zum erstellen der Datenbank finden Sie unter Der erste Start - Datenbank anlegen.
Distributionserver-Assistent | Ohne Software-Pakete - keine Softwareverteilung. Deshalb müssen Sie als erstes den Haupt-Distributionserver definieren. Es handelt sich hierbei um den Server auf welchem alle Software-Pakete bereitliegen. Mit dem gleichen Assistenten können auch weitere Distributionserver erstellt werden.
Controlserver-Assistent | Der Controlserver überwacht die Softwareverteilung, installiert neue Computer und ist für diverse Arbeiten im remoteIC Netzwerk verantwortlich. Ein Controlserver ist für den optimalen Betrieb von remoteIC notwendig. Bei grossen, komplexeren Netzwerkumgebungen können mit dem selben Assistenten weitere Controlserver erstellt werden.
Paket Import/Export | Software-Pakete können sowohl importiert als auch exportiert werden. Von remoteIC werden eine Vielzahl von Softwarepaketen angeboten. Solche Pakete können mit dem Paket Import/Export-Assistenten eingelesen werden.


Tools

remoteIC stellt Ihnen diverse grafische Tools zu verfügung. Zudem installiert der Client-Service auf allen Computern ein nützliches Utility welches diverse Operationen auf den Computern ermöglicht.

Windows-GUI rICadmin

Diese Konsole stellt eine benutzerfreundliche und einheitliche Umgebung für die Administration von remoteIC dar.
Nach der Installation von remoteIC können Sie rICadmin sofort verwenden.

remoteIC-Tool remoteIC.exe

remoteIC.exe wird automatisch auf jedem Computer im remoteIC Netzwerk installiert und bietet eine vielzahl von Funktionen welche vor allem bei der Herstellung von Software-Paketen sehr nützlich sind.
Eine detailierte Aufstellung der Funktion und deren Beschreibung erhalten Sie, indem Sie im DOS-Fenster remoteIC.exe mit dem Parameter /? starten "remoteIC.exe /?".

Paketgenerierung rICpack

Mit rICpack können bequem Softwarepakete erstellt werden. Benötigt wird lediglich ein Installationsprogramm welches ein Silent-Setup unterstützt. rICpack analysiert die Installation und erstellt automatisch ein Installations- sowie ein DeinstallationsSkript. Das rICpack Programm wird auf der remoteIC Installations-CD mitgeliefert und kann beliebig verwendet werden.

Installationsaufzeichnung rICrecorder

rICrecorder zeichnet eine manuelle Installation auf und generiert anschliessend ein Installationsskript. Die Maus- und Tastaturbefehle werden dabei aufgezeichnet und in einem Skript festgehalten.


Support und Service

Wenn Sie eine Frage haben

Wenn Sie Fragen zu remoteIC haben, empfiehlt es sich, zuerst in der Dokumentation und der Hilfe nachzusehen. Weitere technische Hilfestellungen sowie Informationen, die erst nach Drucklegung des Handbuchs verfügbar wurden, können Sie in der INFO-Datei (README-Datei) nachlesen, die im Lieferumfang von remoteIC enthalten ist. Wenn Sie die Antwort hier nicht finden, wenden Sie sich bitte an Ihre remoteIC-Vertretung in Ihrer Nähe.

Technischer Support

Für technische Fragen können Sie sich direkt mit unserem Supportteam unter support@remoteIC.com in Verbindungs setzen.

Oder Sie stellen Ihre Frage in unserem Support-Forum, welches ebenfalls vom remoteIC Supportteam betreut wird.

Sonstige Serviceleistungen

remoteIC bietet diverse Serviceleistungen. Weitere Informationen finden Sie unter http://www.remoteIC.com


Neuigkeiten in remoteIC 2.2

remoteIC hat sich seit der letzten Version erheblich verändert. Zudem sind eine Menge neuer Funktionen implementiert worden. Folgende Aufstellung soll Ihnen einen Überblick über die neuen Funktionen verschaffen.

Funktion | Beschreibung
Controlserver | Der Controlserver nimmt Ihnen alle Arbeiten am Client ab. Er ist für die automatische Erfassung der Client Computer verantwortlich. Das Netzwerk wird dabei nach vorgegebenen Kriterien durchsucht, so dass neue Computer automatisch erfasst und einer oder mehreren Gruppen zugeordnet werden können. Zudem ermöglicht er Installationen ausserhalb der Arbeitszeiten. Der Controlserver wird auf einem beliebigen Computer (Server) installiert. Er sollte ständig aktiv sein.
Unterstützung von beliebig vielen Distributionservern | Grosser Unterschied zur letzten Version von remoteIC ist die Tatsache, dass nun beliebig viele Distributionserver eingesetzt werden können. Sie definieren selbst, welcher Distributionserver seine Software-Pakete von wo bezieht. Distributionserver können einzelnen Computern oder Computer-Gruppen zugeteilt werden. werden. Das neue System optimiert die Netzwerklast erheblich.
Wake-On-Lan | remoteIC 2.2 unterstützt WfM 2.0 und das integrierte Wake-On-Lan. Dank dieser neuen Unterstützung ist es nun möglich auch ausgeschaltete Computer mit Software zu versorgen.
Remote-Shell | Dank der einegebauten Remote-Shell können Servicearbeiten auf jedem Computer im Netzwerk durchgeführt werden. Der Benutzer wird von diesen Servicearbeiten nichts merken.
Sicherheit durch AES | remoteIC 2.2 wurde mit der aktuellsten Verschlüsselungsmethode ausgerüstet. Das System ist dank AES 128bit vor Fremdeingriffen geschützt.
Alles auf einen Blick | Die Verwaltungskonsole von remoteIC wurde komplett überarbeitet. Sie ist nun noch übersichtlicher gestaltet. Die meisten Arbeiten können mit wenigen Maus-Klicks erledigt werden.
Paket Import/Export | Software-Pakete können nun importiert und exportiert werden. Dies ermöglicht den Austausch von Software-Paketen ohne grossen Aufwand. remoteIC hat zudem die Liste der angebotenen Software-Pakete wesentlich vergrössert. Die am häufigsten verwendeten Programme können direkt von remoteIC bezogen werden.
Trouble Tickets | Auf Grund der grossen Nachfrage wurde die Version 2.2 um eine kompakte Trouble Tickets Funktion erweitert. Dieses Trouble Ticket System ist bewusst sehr einfach gehalten, erfüllt aber seinen Zweck.
Supportforum | Um schnell auf Fragen reagieren zu können wurde auf der Internetseite ein Supportforum eingerichtet. Gängige Fragen und Antworten sind dort direkt abrufbar.


Einfache Installation

Bereits bei der Installation von remoteIC werden Sie merken, dass sich dieses Produkt von anderen unterscheidet. Die gesamte Installation wird auf dem dazu vorgesehenen Server gestartet und ist in wenigen Minuten durchgeführt. Alle anderen für die Inventarisierung und Softwareverteilung benötigten Komponenten werden automatisch im Netzwerk verteilt, ohne dass Sie sich darum kümmern müssen.

Wenn neue Arbeitsstationen hinzukommen, werden diese automatisch erkannt und ebenfalls installiert.


Hardware- und Softwareanforderungen für die Installation von remoteIC

Für die Installation von remoteIC muss der Computer die folgenden Anforderungen erfüllen.

Kategorie | Anforderungen
Computer | Intel® und kompatible Systeme (Pentium 350 MHz oder höher, Pentium PRO oder besser)
Arbeitsspeicher | Minimum 64 MByte optimal > 128 MByte
Laufwerk | CD-ROM Laufwerk für die Installation CD-RW Laufwerk empfohlen für Paket-Import/Export
Festplattenspeicherplatz | 2 MByte pro Client 30 MByte für rICadmin 100 MByte für SQL-Datenbank
Betriebssystem | Microsoft Windows NT® 4.0 mit SP3 und IE 4.01 Microsoft Windows NT® 4.0 mit SP6a Microsoft Windows 2000® Microsoft Windows XP® Professional Microsoft Windows 2003®


Vor der Installation: Checkliste

Aspekte, die vor dem Ausführen von remoteIC Setup beachtet werden sollten.

  • Überprüfen, ob Hard- und Softwareanforderungen erfüllt werden.
  • Festlegen des Datenbank-Servers. Entscheiden Sie, ob remoteIC auf einem eigenständigen SQL-Server oder auf einer MSDE Datenbank eingerichtet werden soll.
  • Ein Microsoft SQL Server (oder MSDE) muss vorgängig installiert werden.
  • Festlegen des Controlservers. Der Controlserver ist für die automatische Erfassung der Clients zuständig und kann auf einem beliebigen Computer eingerichtet werden.
  • Festlegen des Distributionservers. Der Distributionserver hält die Softwarepakete für die Client Computer bereit. Sämtliche Pakete werden in einem bei der Installation festgelegten Share gespeichert.


Lokale Installation oder Remoteinstallation

Die einfachste Installation ist die Installation mittels rICadmin. Sie installieren die rICadmin Verwaltungskonsole auf einem beliebigen Computer. Die Installation der Server wird automatisch beim ersten Start der Konsole ausgeführt. Die einzelnen Komponenten können selbstverständlich auch einzeln installiert werden.

Die Vorgehensweise für eine lokale oder eine remote Installation ist weitgehend identisch

  • Sowohl auf dem lokalen als auch auf dem Remotecomputer muss Microsoft Windows NT® oder höher ausgeführt werden.
  • Sie müssen beim lokalen Computer mit einem Benutzerkonto angemeldet sein, welches auf dem Remotecomputer über lokale Administratorenrechte verfügt. Wir empfehlen ein Konto, welches über Domänen-Administratoren-Rechte verfügt.

Beim ersten Start der rICadmin Verwaltungskonsole...

  • ...wird der Datenbank-Assistent gestartet. Mit dem Assistenten können Sie auf einem loalen oder entferntem (Remote) Rechner die SQL-Datebank erstellen oder sich an einer bestehenden Datenbank anmelden.
  • ...wird der Controlserver-Assistent gestartet. Der Controlserver muss unter einem Benutzerkonto mit Administratorenrechten installiert werden.
  • ...wird der Distributionserver-Assistent gestartet. Der Distributionserver hostet sämtliche Softwarepakete.

Weitere Informationen zur Installation

Auf der remoteIC Download Seite finden Sie weitere Anleitungen, Videos, etc. für eine erfolgreiche Installation.

Im Supportforum finden Sie diverse Fragen und Antworten rund um die Installation von remoteIC.


Aktualisieren einer älteren Version von remoteIC

Wenn Sie derzeit eine ältere Version von remoteIC einsetzen, gehen Sie für die Aktualisierung wie folgt vor.

  • Deinstallieren Sie die alte Verwaltungskonsole auf allen Computern.
  • Stoppen Sie den Controlserver auf dem Haupt-Distributionserver
  • Deinstallieren Sie den Controlserver vom Haupt-Distributionserver indem Sie in der Eingabeaufforderung den Befehl "remoteIC -u" eingeben.
  • Installieren Sie die neue Verwaltungskonsole der Version 2.2
  • Starten Sie die Verwaltungskonsole. Beim ersten Start wird der Datenbank-Assistent gestartet. Folgen Sie den Anweisungen um die Datenbank zu aktualisieren.
  • Wählen Sie im Distributionserver-Assistent Ihren Haupt-Distributionserver aus.
  • Wählen Sie im Controlserver-Assistent den Server aus, auf welchem der Controlserver installiert werden soll. Die neue Version wird installiert. Der Client wird nun automatisch im Netzwerk verteilt.

Wenn Sie auf die alten Daten verzichten wollen empfielt es sich, die alte Version im gesamten Netzwerk zu deinstallieren. Löschen Sie hierzu alle Computer in der alten Verwaltungskonsole. Deinstallieren Sie alle Verwaltungskonsolen. Installieren Sie die neue rICadmin Verwaltungskonsole. Die Installation der Clients kann nun in der rICadmin Administrationskonsole bequem überwacht werden.


Dateipfade

remoteIC benötigt diverse Pfadangaben.

Verwaltungskonsole

Die Verwaltungskonsole kann auf einem beliebigen Computer in ein beliebiges Verzeichnis installiert werden. Beachten Sie hierbei, dass genügend Platz auf dem Zeillaufwerk vorhanden ist.

Controlserver

Der Controlserver installiert sich automatisch in des System32-Verzeichnis von Windows. Diese Verzeichnis kann nicht geändert werden.

Installer Service

Der Installer Service installiert sich automatisch in des System32-Verzeichnis von Windows. Diese Verzeichnis kann nicht geändert werden.

Distributionserver

Beim einrichten eines Distributionservers muss ein Share für die Softwarepakete angegeben werden. Dieser Share kann vorgängig oder mittels Assistent angelegt werden. Der für remoteIC angegebene Benutzer muss über die nötigen Rechte in diesem Verzeichnis verfügen (Leserechte).


Neue Datenbank anlegen

Die von remoteIC verwendete Datenbank kann auf 2 verschiedene Arten angelegt werden. Beide Methoden setzen jedoch einen betriebsbereiten MS SQL Server voraus. Wenn Sie noch keinen SQL Server in Betrieb haben, installieren Sie diesen bitte vorgängig. Eine ausführliche Installationsanleitung ist auf der CD-ROM des Microsoft SQL Servers vorhanden. Statt eines SQL-Servers können Sie auch die auf der CD mitgelieferte MSDE Version verwenden.

Automatische generierung per Datenbank-Assistent

Wenn Sie die rICadmin Verwaltungskonsole zum ersten Mal starten, wird automatisch der Datenbank-Assistent ausgeführt.

SQL Server: Wählen Sie den Computer auf welchem ein MS-SQL Server installiert ist.

Connection information: remoteIC bietet Ihnen die Möglichkeit sich mit einem Windows Account (Trusted) oder mit einem Datenbank Login an die Datenbank anzumelden. Wird ein Datenbankbenutzer angegeben welcher in der Datenbank noch nicht existiert, wird dieser beim Erstellen der Datenbank (Register Database) automatisch generiert.

Datenbank erstellen Wenn die remoteIC-Datenbank noch nicht erstellt wurde (z.B. beim ersten Start), können Sie die Datenbank mit Hilfe des Assistenten erstellen. Wählen Sie einfach "Create new Database".

Trusted login Der SQL Server verwendet die Windows Authentifizierung.

SA-Username Wenn eine neue Datenbank erstellt werden soll, muss der Datenbank-Systemadministrator-Benutzer angegeben werden.

SA-Password: Passwort zum SA-Benutzer.

Skript: Hier wird das Skript angezeigt, welches ausgeführt wird. Angaben zu den Datenbankbenutzern sind automatisch ersetzt worden. Wenn Sie noch Ergänzungen hinzufügen wollen, können Sie dies indem Sie das Skript anpassen.

Connection timeout: In der Regel reicht das vorgegebene Timeout aus. Bei schlechten Netzwerkbedingungen oder bei grossen Datenbanken kann der Wert jedoch angepasst werden.

Command timeout: In der Regel reicht das vorgegebene Timeout aus. Bei schlechten Netzwerkbedingungen oder bei grossen Datenbanken kann der Wert jedoch angepasst werden.

Manuelle generierung per Skript

Auf der remoteIC Setup CD finden Sie im Verzeichnis "/Skript" die Datei "remoteIC.sql". Öffnen Sie diese Datei im Query Analyser, ersetzen Sie die Platzhalter (in geschweiften Klammern) und führen Sie das Skript aus. Beim ersten Start der rICadmin Konsole können Sie nun den SQL Server auswählen und mit "Use existing Database" starten.


Bestehende Datenbank verwenden

Wenn die remoteIC Datenbank der Version 2.2 bereits existiert, können Sie diese verwenden ohne das Skript zu starten. Beim Start der rICadmin Verwaltungskonsole wählen Sie einfach die Option "Use existing database". Die Datenbank wird geprüft und wenn es sich tatsächlich um eine aktuelle Datenbank handelt, wird diese Datenbank verwendet.
Eine erneute Abfrage findet nicht statt. Sollten Sie trotzdem Änderungen an der Datenbank vornehmen oder auf einen anderen Datenbank Server wechseln wollen, können Sie dies, indem die den Datenbank-Assistenten aus der Verwaltungskonole starten "Options - Database connection wizard".


Controlserver definieren

Kernstück der Softwareverteilung ist der Controlserver. Er überwacht alle Clients, fügt neue Clients hinzu und löst zeitgesteuerte Kommandos z.B. 'Wake-On-Lan' aus. Damit remoteIC neue Clients automatisch erfassen, bestehende überprüfen und zeitgesteurte Kommandos ausführen kann, wird mindestens ein Controlserver benötigt. Bei Netzwerken mit mehreren Domänen wird pro Domäne ein Controlserver verwendet.
Beim ersten Start von remoteIC erscheint automatisch der Controlserver-Assistent.

Server: Wählen Sie den Server, auf welchem der Controlserver installiert werden soll.

Server type: Pro Domäne wird im Normalfall nur ein Controlserver benötigt. In komplexeren Umgebungen können mehrere Controlserver verwendet werden. Es kann jedoch immer nur ein Server als "Haupt Controlserver" definiert werden. Der Haupt Controlserver übernimmt die Ausführung von zeitgesteuerten Kommandos.

Service User: Geben Sie einen Windows-Benutzer mit lokalen Administratorenrechten ein (da der Controlserver die Client-Services automatisch verteilt, benötigt er auch die entsprechenden Rechte auf den Client Computer).

Service Password: Passwort des Benutzers.

Trusted: Setzen Sie diese Option wenn sich der remoteIC Dienst per Trusted Login an die Datenbank anmelden soll (nicht empfohlen).

Username: Datenbank-Benutzer mir welchem sich der remoteIC Dienst an der Datenbank anmeldet. Kann nur erfasst werden, wenn nicht "Trusted" ausgewählt ist.

Password: Passwort zum im Feld "Username" angegebenen Benutzer.

Create database user... Mit Hilfe dieses Assistenten können Sie neue Datenbankbenutzer einrichten.

Der Controlserver sollte auf einem Server oder Computer installiert werden, welcher stets läuft!


Haupt-Distributionserver definieren

Wichtiges Glied von remoteIC ist der Haupt-Distributionserver. Auf diesem Server befinden sich die Software-Pakete.
Wenn Sie die rICadmin Verwaltungskonsole das erste Mal starten, können Sie dieses "Hauptdepot" definieren. Auf dem Haupt-Distributionserver muss vorgängig ein Verzeichnis eingerichtet werden, auf welchem die Software-Pakete gespeichert werden sollen. Jede Software wird ihr eigenes Unterverzeichnis erstellen.

Da Software-Pakete viel Platz benötigen, ist es wichtig, dass der Haupt-Distributionserver über ausreichend Festplattenkapazität verfügt.

Server: Geben Sie einen Server an, welcher als Distributionserver dienen soll.

Server type: Es ist möglich mehrere Distributionserver zu definieren. Beim ersten Start wird der Hauptserver definiert.
Zusätzliche Distributionserver synchronisieren die Softwarepakete automatisch vom Hauptserver.

Package share: Freigabeverzeichnis, in welchem die Softwarepakete gelagert werden sollen. Für jedes Softwarepakete wird automatisch ein eigenes Unterverzeichnis erstellt.

Username: Windows-Benutzer, welcher auf die Freigabe (Package Share) Zugriff hat.

Password: Passwort zum oben angegebenen Benutzer.

Max. connections: Anzahl an gleichzeitigen Verbindungen (Client Installationen), welche der Server zulässt.

Max. response time (ms): Wenn ein Server bereits ausgelastet ist und nicht innerhalb der vorgegebenen Zeitspanne reagiert, sucht sich der Client einen anderen Distributionserver oder verschiebt die Installation allenfalls auf später. Wird hier ein Wert von z.B. 20 ms eingestellt, werden Installationen über langsame Datenleitungen vermieden.

Sync. interval: Der Synchronisationsinterval gibt an nach wieviel Minuten eine Synchronisation zwischen den Distributionservern stattfinden soll.

Transfer type: Art der Datenübertragen

Hostname: Bei Übertragungsart HTTP oder FTP muss ein Hostname erfasst werden.

Username: Bei Übertragungsart HTTP oder FTP muss ein Benutzer mit Leserechten auf dem Host erfasst werden.

Password: Passwort zum angegebenen Benutzer.

Port: Über welchen Port soll synchronisiert werden. Normalerweise wird für HTTP der Port 80 und für FTP der Port 21 verwendet.


Grundlegendes zur remoteIC-Architektur

remoteIC besteht aus 3 Hauptkomponenten:

  • remoteIC Administrationskonsole
  • Datenbank
  • remoteIC Service

remoteIC Administrationskonsole (rICadmin)

Trotz des hohen Funktionsumfangs ist die Bedienung äusserst einfach. Die Administrationskonsole kann auf einem beliebigen Rechner im Netzwerk installiert werden.
In dieser Konsole ist das komplette Netzwerk übersichtlich dargestellt. Hard- und Software-informationen sind für jeden Computer per Mausklick verfügbar und können einzeln oder gruppenweise verwaltet werden. In Kürze finden Sie sich zurecht und sind bereits in der Lage, die zur Verfügung gestellten Tools nützlich einzusetzen.

Datenbank

Kernpunkt von remoteIC ist die zentrale Datenbank. In der Datenbank sind alle Informationen über das komplette Netzwerk und über alle Verteilungen gespeichert. Da es sich um eine Standard-Datenbank handelt, können beliebige Verwaltungstools eingesetzt werden. Die remoteIC Verwaltungskonsole ist nur eine Möglichkeit die Datenbank zu verwalten.

remoteIC Service

Der remoteIC Service wird auf jedem Rechner im Netzwerk installiert. Je nach Art des Computers (Benutzer-PC, Server, Notebook) werden einzelne Komponenten innerhalb des Service aktiviert oder deaktiviert. So kann jederzeit sehr schnell auf Veränderungen im Netzwerk reagiert werden. Beispielsweise ist es nicht nötig, zusätzliche Software für einen Distributionserver zu installieren. Definiert man einen Computer als Distributionserver, lädt dieser die dafür nötigen Komponenten in den Speicher.

Der Service ist über diverse Konfigurationsparameter, welche bequem von einem beliebigen Rechner mittels Administrationskonsole eingestellt werden können, konfigurierbar. Sämtliche Parameter werden ohne Neustart des Rechners aktiv.

Die einzelnen Komponenten können unabhängig voneinander aktiviert werden:

  • XML Server für Steuerungskommandos
  • Hard- und Software Inventar
  • Installationsdienst
  • Remote Shell
  • Task List
  • Controlserver
  • DistributionServer

Jede Komponente funktioniert unabhängig, d.h. es kann beispielsweise gleichzeitig ein Inventoryscan, eine Softwareinstallation und eine Paketsynchronisation durchgeführt werden.

Kommunikation

Generell funktioniert die gesamte Kommunikation über TCP/IP, wobei die Kommunikations-Ports individuell festgelegt werden können. Wenn remoteIC in komplexen Netzwerken eingesetzt wird, mit Firewalls zwischen den einzelnen Subnetzwerken, kann auch ein HTTP-Tunnelling aktiviert werden. Firewall Filter können so umgangen werden.

Sicherheit

Alle relevanten Daten werden mit dem modernsten Verschlüsselungsverfahren AES (Advanced Encryption Standard) 128 Bit übertragen. Der Schlüssel entspricht den neuesten Sicherheits-standards.


Installationsdienst

Auf jedem Computer im Netzwerk wird der remoteIC Installer-Service installiert. Dieser wird beim Start des Computers automatisch gestartet und läuft ständig im Hintergrund. Er verarbeitet die Pakete und steuert die gesamte Installation. Zudem erledigt er diverse zusätzliche Aufgaben auf dem System.

Mit einem frei definierbaren Intervall fragt der Installer-Service die Datenbank nach neuen Softwarepaketen ab.
Sind neue Pakete vorhanden, sucht sich der Installer-Service einen für ihn zuständigen Distributionserver und beginnt je nach Paket-Konfiguration sofort oder auch erst zu einem gewissen Zeitpunkt mit der Installation. Sind mehrere Distributionserver im Netzwerk vorhanden, ermittelt der Client Service den für ihn idealen Distributionserver mit der schnellsten Verbindung.

Je nach Installationspaket kann die Anforderung bestehen, dass der Benutzer auf die Installation Eingriff nehmen kann. Ein Beispiel hierzu ist die Möglichkeit, die Software erst zu einem späteren Zeitpunkt zu installieren. In den Paketinformationen wird mitgeliefert, was der Benutzer einstellen kann. Gerade in Entwicklungsabteilungen besteht häufig das Bedürfnis nach Individualität. Solchen Abteilungen kann die Möglichkeit geboten werden, selbst auszuwählen welche Software installiert werden soll.


Kommunikation

Die gesammte Kommunikation von remoteIC erfolgt über das Standardprotokoll TCP/IP. Da dieses Protokoll heute Standard für Netzwerkkommunikation ist, kann remoteIC in den meisten Netzwerkumgebungen ohne Umstellungen der Infrastruktur eingesetzt werden.

In komplexen Netzwerkumgebungen mit Firewalls zwischen den einzelnen Netzwerksegmenten kann die ganze Kommunikation auf HTTP-Tunneling umgestellt werden. Auch Datenbankabfragen werden so über ein Tunneling-Verfahren übertragen. Auf dem Firewall müssen so keine neuen Ports geöffnet werden und die Sicherheit bleibt gewährleistet.

Die von remoteIC übertragenen Daten werden alle Verschlüsselt übertragen. Der verwendete Schlüssel ist auf dem akuellsten Sicherheitsstand (AES 128Bit) und wird auch von Amerikanischen Verwaltungen verwendet.


Serverkomponenten

remoteIC verwendet zwei verschiedene Server um die gesamten Abläufe sicherzustellen.

Controlserver

Der Controlserver erledigt eine zentrale Aufgabe. Er ist für die korrekte Erfassung von neuen Computern zuständig. Dies beinhaltet die Aufnahme eines neuen Computers in der Datenbank, die richtige Gruppenzuordnung sowie die Service Installation. Zudem überwacht er alle Computer und sendet Startkommandos für zeitgesteuerte Installationen. Datenbank Wartung wie auch remoteIC Service Updates werden ebenfalls vom Controlserver durchgeführt.

Distributionserver

Der Distributionserver verwaltet die Pakete. Er holt sich die neuen Pakete von einem anderen Distributionserver oder von einem beliebigen Ort im Netzwerk und stellt sie für die Verteilung bereit.

Der Distributionserver kann auf einem beliebigen Computer installiert werden. So ist es zum Beispiel möglich, für jede geografisch getrennte Lokation einen separaten Distributionserver bereitzustellen. Alle Workstations dieser Region bedienen sich dann von diesem lokalen Distributionserver. Dadurch können Installationen über langsame WAN Verbindungen vermieden werden.

Der Distributionserver synchronisiert die Softwarepakete selbständig. Die Art des Transfers der Daten kann bei jedem Distributionserver individuell bestimmt werden. Die Dateien werden in der Regel einfach über das Netzwerk kopiert, FTP- und HTTP-Transfer ermöglichen den Einsatz in heterogenen Netzwerken. Bei einer Synchronisation werden jeweils nur die veränderten Daten (Delta) kopiert.


Grundlegendes zu den Software-Paketen

Ein Paket besteht immer aus zwei Teilen. Dem Anweisungs- und dem Softwareteil. Der Anweisungsteil enthält alle Konfigurationen und InstallationsSkripte, der Softwareteil enthält das zu installierende Programm.

Damit eine Software mit remoteIC verteilt werden kann, muss als erstes in der Verwaltungskonsole ein neues Paket angelegt werden.
Ist ein solches Paket korrekt angelegt, werden auch die benötigten Dateien importiert. Hierzu können Sie ein Import-Verzeichnis angeben.

Der Anweisungsteil eines Softwarepaketes ist der Schlüssel zur erfolgreichen Verteilung. Sollten sich im Anweisungsteil Fehler eingeschlichen haben, kann es sein, dass die komplette Installation fehlschlägt.
Softwarepakete sollten von einem Softwareengineering erstellt und vorgängig getestet werden.

Fertige Pakete für gängige Software können auch direkt von remoteIC bezogen werden. Solche Pakete können per Import/Export-Assistent eingelesen werden.

Siehe auch:
Unterstütze Methoden
Paketdefinitionen


Unterstützte Methoden

Bei der Entwicklung von remoteIC wurde darauf geachtet, dass das System flexibel bleibt. remoteIC unterstützt alle Installatonsmethoden und ist auch für neue Varianten konfigurierbar.

Methode | Beschreibung
Simple Copy: | Manche Programme erfordern kein spezielles Installationsverfahren. Es müssen lediglich Dateien auf das System kopiert werden.
Snapshot: | Auch Snap-Shot-Methode. Die Software wird auf einem Computer installiert. Dann wird überprüft was sich auf dem Computer bei der Installation verändert hat. Aus dieser Methode wird dann das Installationspaket erstellt.
Silent Setup: | Die Silent-Setup Variante gilt als die sicherste Methode, da Sie die Installationsroutinen der Hersteller nutzt. Da ein „normales“ Setup durchgeführt wird, erfolgt die Installation gleich wie bei einer manuellen Installation. Somit bieten die Softwarehersteller in der Regel auch technischen Support. Bei den anderen Methoden ist dies nicht zwingend der Fall. Für die Erstellung eines Silent Setup Skripts kann das Programm rICpack verwendet werden.
MSI: | MSI-Dateien enthalten den Anweisungs- und Softwareteil in einer Datei (msi) und können direkt mit remoteIC verteilt und installiert/deinstalliert werden.
Message basierte Installation: | Für die Erstellung eines InstallationsSkript wird das Programm rICrecorder verwendet. Sämtliche Tastatur- und Mauseingaben werden dabei aufgezeichnet und in einem Skript festgehalten. rICrecorder erstellt Ihnen ein entsprechendes Setup Skript welches über die Administrationskonsole dynamisch angepasst werden kann.


Grundlegendes zur Verwaltung

Die remoteIC Datenbank kann auf verschiedene Arten verwaltet werden. Neben der rICadmin Windows-Verwaltungskonsole ist auch eine webbasierende Verwaltungskonsole erhältlich (rICweb). Weitere Informationen hierzu finden Sie unter Verwaltungs-Konsolen.

In den meisten Fällen wird wohl die Windows-Verwaltungskonsole zum Einsatz kommen. Sie ist im Lieferumfang von remoteIC enthalten.


remoteIC richtig konfigurieren

Damit remoteIC richtig funktioniert und seinen vollen Leistungsumfang genutzt werden kann, ist es wichtig, dass remoteIC korrekt konfiguriert wird.
Alle wesentlichen Einstellungen können im Menu "Option - Settings..." geändert werden.

Die Settings können auch jederzeit durch drücken der Teste F12 geöffent werden.

rICadmin

Eingabefeld | Beschreibung
Push port number | Portnummer auf welcher der Client mit dem Server und der Verwaltungskonsole kommuniziert. Hierbei sollten Sie beachten, dass der Port auf eventuellen Firewalls zwischen den Sub-Netzwerken geöffnet sein muss!
Send wake on lan to all subnets | Soll der Wake-On-Lan-Befehl auf alle Netzwerksegmente oder nur im lokalen Subnetz gesendet werden? Wenn Sie sich für alle Netzwerksegmente entschieden haben, wird der Befehl an alle Netzwerksegmente aller erfassten Computer gesendet.
Main Distributionserver | Welcher Server ist das Standarddepot für Softwarepakete? Wurden mehrere Distributionserver eingerichtet, synchronisieren diese die Pakete stets vom Hauptdistributionserver. Auch der Paket-Import/Export wird ausschliesslich auf dem Hauptdistributionserver durchgeführt.
Main Controlserver | Damit remoteIC neue Computer automatisch erfassen und zeitgesteuerte Kommandos ausführen kann, muss ein Haupt Controlserver definiert werden. Es wird dringend empfohlen den Controlserver per Assistent einzurichten. In Spezialfällen kann der Haupt Controlserver auch hier geändert werden.
Remote control utility path | Wählen Sie ein beliebiges Programm für den Remote-Control der Arbeitsstationen. Standardmässig wird mit remoteIC das Utility VNC mitgeliegert. Geben Sie als Parameter %computername (oder einen beliebigen Spaltennamen aus der Computertabelle in der Datenbank) an, um den Computernamen zu übergeben.
Default install time Default install timeout | Legen Sie die Standardwerte für die Felder im Formular "Paket" fest. Die Installationszeit (Install time) wird für die Anzeige der Installationsdauer verwendet. Dauert eine Installation länger als im Feld 'Install time' angegeben, wartet der Installationsdienst noch die im Feld 'Install timeout' angegebenen Sekunden. Wurde bis dahin kein Status (erfolgreich installiert / fehlgeschlagen) zurückgemeldet, wird die Installation abgebrochen und als 'Fehlgeschlagen' protokolliert.
Default distribution delay time Default max. reject count | Legen Sie die Standardwerte für die Felder im Formular "Distribution" fest. Damit eine vom Benutzer verschobene Installation erst nach Ablauf einer bestimmten Frist wieder zur Installation angezeigt wird, kann im Feld 'Distribution delay time' eine Verzögerungszeit in min. eingegeben werden. Im Feld 'Max. reject count' wird angegeben wie oft ein Benutzer eine Installation auf später verschieben kann.

Client

Eingabefeld | Beschreibung
Setting check interval | Intervall nach welchem der Client-Service die hier definierten Einstellungen abfragen und anwenden soll
Event log level | Aktionen, welche der Client-Service ausführt, werden in der Datenbank abgelegt. Wählen Sie die Standard Protokollierstufe in welcher der remoteIC Dienst Events protokollieren soll.
Service does self registration | Wenn der remoteIC Service gestartet wird und der Computer noch nicht in der remoteIC Datenbank vorhanden ist, trägt sich der Service selber in der Datenbank ein.
Recover client by MAC-Address | Diese Option legt fest, ob der Computer auch nach der MAC-Adresse suchen soll und gegebenenfalls den gefundenen Datensatz verwenden soll.
Autorecover software packages | Kann eingestellt werden, wenn der remoteIC Service die lokal installierte Software mit der in der Datenbank eingetragenen Software vergleichen soll und eventuell fehlende Software automatisch installieren soll.
Shutdown delay time | Der aktuell eingeloggte Benutzer erhält eine Warnung, wenn remoteIC das System herunterfährt. Diese Warnung wird während der hier angegebenen Sekunden angezeigt. Danach wird das System heruntergefahren.
Shutdown message | Eine beliebige Meldung welche als Warnung vor dem Herunterfahren angezeigt wird..
Default active processes | remoteIC Komponenten, welche beim Erfassen eines neuen Computers standardmässig ausgeführt werden.
Service Username | Der remoteIC Client-Service benötigt für den Zugriff auf den Distributionserver einen Benutzeraccount. Dieser Account benötigt Leserechte auf dem Paketshare sowie lokale Administrationsrechte auf allen Computern.
Service Passwort | Das Kennwort für das oben definierte Konto. Das Kennwort wird verschlüsselt gespeichert.
Inventory check interval | Intervall nach welchem ein Software-Inventar durchgeführt werden soll?
Installer check interval | Legt fest wie häufig der Installer-Service überprüfen soll, ob neue Pakete vorhanden sind. Zusätzlich wird bei jedem Systemstart nach neuen Verteilungen gesucht.
Countdown for user interaction | Während der hier festgelegten Zeit kann der Benutzer noch Einfluss auf eine Softwareinstallation nehmen und die installation auf einen späteren Zeitpunkt verschieben.
Default at boot install type Default at logon install type Default at work install type | Legt das Standardverhalten des Installationsdienstes fest. Je nach Status des Computers können individuelle Standardverhalten festgelegt werden. Bei "Install" wird die Installation nach Zeitablauf gestartet, bei "Later" wird sie auf einen späteren Zeitpunkt verschoben. Wurde die Installation bereits die im Feld 'Max reject count' angegebene Anzahl verschoben, wird die Installation in jedem Fall gestartet.
Temporary path for local packages | Wurde die Option 'Make local copy of package' (Computer Eigenschaften) aktiviert, werden die Pakete in dem hier angegebenen Verzeichnis zwischengespeichert.
Log installation locally | Wenn diese Checkbox aktiviert ist, wird während der Installation eines Software-Paketes ein lokales Log-File geschrieben. Legen Sie fest in welchem Verzeichnis dies geschehen soll.
Batchfile extensions | remoteIC bietet die Möglichkeit alle Text / Fehlermeldungen welche während einer Installation ausgegeben werden, in die Datenbank und somit ins Installationslog einzutragen. Dies ist jedoch nur bei Skripten möglich. Geben Sie die Dateierweiterungen an, bei welchen diese Protokollierung erfolgen soll.

Server

Eingabefeld | Beschreibung
Controlserver interval | Intervall nach welchem der der Controlserver gestartet werden soll.
Ping timeout for new Workstations | Der Controlserver erfasst alle Computer, welche in der hier angegebenen Zeitspanne reagieren. Wird hier ein tiefer Wert z.B. 20 angegeben, kann vermieden werden, dass Serviceinstallationen über langsame Datenleitungen vermieden werden.
Maintainance start time | Die Datenbank wird durch den Controlserver täglich gepflegt. Geben Sie einen Zeitpunkt an, wann die Wartung gestartet werden soll.
Maintainance duration | Die Dauer der Wartung ist abhängig von der Grösse der Datenbank. Während dieser Wartungszeit werden keine Softwareinstallationen, Scans, etc. durchgeführt. Sämtliche remoteIC Services wechseln während der Dauer in den Standby Modus.
Clear events older than | Geben Sie an, nach wievielen Tagen die Events automatisch gelöscht werden sollen.
Clear events if more then | Geben Sie an wieviele Events pro Computer maximal gespeichert werden sollen. Die überflüssigen Events werden während der Wartung entfernt.
Automatically remove empty distributions | Ein Softwarepaket kann pro Computer nur in einer einzigen Distribution verwendet werden. Wird ein Paket in mehreren Distributions eingesetzt, wird dieses Paket aus der alten Distribution entfernt. Dies kann zu leeren Distributionen führen. So angesammelte, meist nutzlose Daten werden während der Wartung automatisch entfernt.
Default max. connections Default max. response time Default distribution sync. interval | Standardwerte für das Formular "Computer". Legt die vorgeschlagenen Werte fest, welche beim erfassen eines neuen Distributionservers angezeigt werden.

Inventory

Softwareinventar: Erfassen Sie die Software welche inventarisiert werden soll. Sobald die Clients das Inventar durchgeführt haben, wird die Software unter dem jeweiligen Computer aufgeführt.

Informationfields Mit Hilfe von Info-Feldern kann das Inventar komplettiert werden. Registrierungsschlüssel können geschrieben oder ausgelesen und benutzerdefinierte Inventarfelder festgelegt werden.

Monitoring

Erfassen Sie Netzwerkports welche Sie überwachen wollen. Die hier erfassten Daten werden in den Computereinstellungen im Register Monitoring zur Auswahl angeboten. Bei Port 0 wird ein ICMP-Paket (Ping) verwendet.


Datenbank-Assistent

Der Datenbank-Assistent hat folgende 2 Aufgaben

Erstellen einer neuen Datenbank

Beim ersten Start von remoteIC wird automatisch der Datenbank-Assistent aufgerufen. Er hilft Ihnen beim erstellen der für remoteIC notwendigen Datenbank. Sie wählen den SQL Server und geben den Benutzer an, mit welchem die Verwaltungskonsole auf die Datenbank zugreift.
Anschliessend kann im Karteireiter "Database" ausgewählt werden, ob eine bestehende Datenbank verwendet oder eine neue Datenbank angelegt werden soll.
Wird eine neue Datenbank angelegt, kann zusätzlich ein Datenbank-Benutzer angegeben werden, welcher über die zum Anlegen einer Datenbank benötigen Rechte verfügt.

Bestehende Datenbank verwenden

Ist aus irgend einem Grund der Datenbank-Benutzer, welcher für die Verwaltungskonsole verwendent wird, nicht mehr gültig, wird ebenfalls der Datenbank-Assistent gestartet. Geben Sie einen gültigen Benutzer an und wählen Sie im Karteireiter "Database" die Option "use existing database".
Wenn Sie nun mit OK bestätigen, wird versucht auf die Datenbank zuzugreifen. Schlägt dies fehl, wird der Assistent erneut gestartet.


Distributionserver-Assistent

Beim ersten Start von remoteIC wird automatisch der Distributionserver-Assistent gestartet um den Haupt-Distributionserver festzulegen. Um Software verteilen zu können, benötigt remoteIC ein sogenanntes Softwaredepot wo die Installationspakete gespeichert sind.

Ablauf

  • Wählen Sie den Server, auf welchem der Distributionserver installiert werden soll
  • Geben Sie einen gültigen Paketpfad an. Es muss sich hierbei um eine im Netzwerk gültige Freigabe handeln, da die Clients später auf dieses Verzeichnis zugreifen.
  • Stellen sie die gewünschten Einstellungen ein.

Wenn Sie mit OK bestätigen, versucht der Assistent die notwendigen Arbeiten durchzuführen.


Windows-GUI (rICadmin)

Bei der Installation von remoteIC wird standardmässig die Windows Verwaltungskonsole "rICadmin" installiert. Diese Konsole ermöglicht die Verwaltung von remoteIC von einem Windows PC.

Der grösste Vorteil gegenüber anderen Verwaltungskonsolen ist sicherlich das einfache Handling. Sämtliche Computer können von dieser Konsole zentral verwaltet werden. Die remoteIC Administrationskonsole ist als MSI-Paket verfügbar und kann somit schnell und einfach auf beliebige Rechner verteilt werden.

Siehe auch
Computermanagement


Grundlegendes zur Softwareverteilung

Eine zentrale Komponente von remoteIC ist sicherlich die Softwareverteilung; die Möglichkeit jegliche Software per Mausklick auf einen oder auch auf beliebig viele Computer gleichzeitig zu installieren. Dies vereinfacht Migrations- und Update-Szenarios wesentlich.

Diverse Suchmöglichkeiten helfen die Verteilung zu vereinfachen. So können Software-Pakete auf Computer, Benutzer, NT-Gruppen und auch RemoteIC-Gruppen verteilt werden.

Siehe auch
Verteilung planen
Verteilung durchführen
Verteilen ausserhalb der Arbeitszeiten
Verteilung kontrollieren


Paketdefinitionen

General

Eingabefeld | Beschreibung
Package GUID | Eindeutige ID des Softwarepaketes. Wird von rICadmin erstellt. Diese ID wird auf dem Distributionserver als Verzeichnis für das Softwarepaket verwendet.
Package name | Bezeichnung des Softwarepaketes. Dieses Feld benötigt eine Eingabe.
Version | Version der Software. Diese Feld benötigt eine Eingabe.
Status | Aktueller Status des Softwarepaketes. Es können nur aktive Softwarepakete verteilt werden.
Installation type | Zu welchem Zeitpunkt kann dieses Softwarepaket installiert werden. Dringende Pakete können beispielsweise jederzeit ausgeführt werden. Weniger dringende werden nur bei einem Neustart (at boot) ausgeführt.
Reboot | Ist nach der installation der Software ein Neustart des Computers erforderlich?
Installation time | Benötigte Zeit für die komplette Installation der Software.
Installation timeout | Der Installationsdienst wartet normalerweise bis die Installation beendet ist. Dauert eine Installation länger als im Feld 'Install time' angegeben, wartet der Installationsdienst noch die im Feld 'Install timeout' angegebenen Sekunden. Wurde bis dahin kein Status (erfolgreich installiert / fehlgeschlagen) zurückgemeldet, wird die Installation abgebrochen und als 'Fehlgeschlagen' protokolliert.
Disk space needed | Legt fest wieviel Speicherplatz die Software auf dem Systemdrive benötigt. Ist auf dem Client nicht genügend freier Festplattenplatz verfügbar, wird die Installation nicht gestartet.
Show popup window | Wenn remoteIC dem Benutzer vor und während der Installation des Softwarepaketes ein informatives Fenster anzeigen soll, stellen Sie diese Option auf ja. Muss ein Paket den Rechner neu starten, sollte in jedem Fall ein Popup angezeigt werden. Wird ein Popup angezeigt, blockiert der Installationsdienst während der Installation die Maus und die Tastatur. Der Benutzer kann somit während der Installation nicht weiterarbeiten.
Optional package | In manchen Fällen soll der Benutzer selber entscheiden ob eine Software bei Ihm installiert werden soll oder nicht. Wenn diese Option auf ja gestellt wird, kann der Benutzer das Paket auch ablehnen. Wurde ein Paket einmal abgelehnt, wird das Paket nicht mehr installiert. Bei Bedarf kann der Benutzer via rIClient in der Windows-Startleiste (System tray icon) die Installation erneut ausführen lassen.
Package created by | Name der Person, welche dieses Softwarepaket erstellt hat. Hat lediglich informativen Stellenwert.
Description | Optionale Beschreibung des Softwarepaketes.

Files

Eingabefeld | Beschreibung
Install Skript | Skript für die Installation der Software. Jede Software benötigt einen solchen Anweisungsteil. In diesem Skript wird ein grosser Teil der Installation gesteuert. Es kann sich dabei um einen Batch, ein VB-, JavaSkript oder ein beliebig anderes Programm handeln. MSI-Pakete können direkt als Installationsskript angegeben werden. remoteIC bietet im Support-Forum unter Softwarepakete diverse Installationsskripte an, welche direkt heruntergeladen werden können.
Install parameter | Parameter welche dem Installationsskript mitgeliefert werden sollen.
Uninstall Skript | Skript für die Deinstallation der Software. Die meisten Installationsprogramm bieten eine Deinstallationsmöglichkeit. Diese kann per Uninstall-Skript ausgeführt werden. Ansonsten analog Install-Skript
Uninstall parameter | Parameter welche dem Deinstallationsskript mitgeliefert werden sollen.
Files in package | In dieser Liste werden alle Dateien angezeigt, welche sich in diesem Softwarepaket befinden.
Refresh files | Die Dateiinformationen werden neu eingelesen (Paketverzeichnis auf Haupt-Distributionserver)
Inport files | Wählen Sie ein Verzeichnis, welches alle Paketdateien enthält. Die bestehenden Dateien werden überschrieben. Alle Unterverzeichnisse werden ebenfalls eingelesen.

Dependencies

Ein Softwarepaket kann von anderen Paketen abhängig sein. Wird ein Paket verteilt, wird überprüft, ob die unter 'Dependencies' angegebenen Pakete bereits installiert sind. Ist dies nicht der Fall, werden diese automatisch mitverteilt und vorgängig installiert. Setzen Sie hierzu die Checkbox vor dem jeweiligen Paket. Es können auch mehrere Abhängigkeiten definiert werden.

Requirements

Wenn für die Installation der Software gewisse Anforderungen auf dem Computer bestehen müssen, können diese hier angegeben werden. Wurden diese Anforderungen nicht erfüllt, wird das Paket als 'Fehlgeschlagen' protokolliert und die Installation auf später verschoben.

Unterschied 'Package requirement' und 'Distribution requirement'

Package requirement Dialog 'Package' | Ein 'Package requirement' ist eine zwingende Voraussetzung für die Installation eines Paketes. Wurde diese Anforderung nicht erfüllt, kann das Paket zu diesem Zeitpunkt nicht installiert werden. Beispiel: Um zu vermeiden, dass eine Software, welche gerade in Gebrauch ist, aktualisiert wird, kann ein 'Prozess Requirement' definiert werden. Die Installation wird somit auf später verschoben.
Distribution requirement Dialog 'Distribution' | Ein 'Distribution requirement' ist eine Voraussetzung für eine Verteilung. Das zu verteilende Paket wird nur auf Computern installiert, welche die unter 'Distribution requirement' angegebenen Anforderungen erfüllen. Beispiel: Man möchte einen Patch für Office verteilen. Der Patch soll nur auf Rechnern installiert werden, welche Outlook XP installiert haben. Man erstellt folgendes 'Distribution Requirement': Requirement type: Registry Key Item name: HKLM\Software\Microsoft\Office\10.0\Outlook Operator: exists Value:

Eingabefeld | Beschreibung
Requirement type | Die Art der Abhängigkeit. Wählen Sie zwischen Registry-Eintrag, einer Datei oder einem Prozess.
Item name | Geben Sie den Namen der Abhängigkeit an. Bei Registry den Registry-Schlüssel, bei Datei den Dateinamen inklusive Pfad, bei Prozess den Prozessnamen.
Operator | Gibt die Art der Verknüpfung mit dem Wertefeld an. Definiert beispielsweise ob eine Datei existiert oder ein Prozess gestartet (runnning) wurde.
Value | Vergleichswert.

Replacements

Wenn das Softwarepaket eine neuere Version eines bestehenden Softwarepaketes darstellt, können Sie diesen Ersatz hier definieren. Selektieren Sie die ältere Version des selben Programmes, welches durch dieses Softwarepaket ersetzt wird. Es können mehrere Pakete selektiert werden.

Hinweis zu Recovery:
Wurde die Option 'Autorecover software packages' (Settings) aktiviert, installiert ein Client selbständig fehlende Pakete. Alte Pakete, welche bei anderen Paketen als 'Replaced' vermerkt sind, werden nicht mehr wiederhergestellt. Stattdessen wird beim Fehlen eines solchen Paketes die neue Version installiert.

Environment variables

Bevor das Installations- oder Deinstallationsskript gestartet wird, werden die Umgebungsvariabeln gesetzt. Sie können beliebig viele Umgebungsvariabeln verwenden.


Verteilungen planen

Eine Software richtig zu verteilen ist ein komplexer Prozess und sollte vorher gut geplant werden. Bedenken Sie, dass die Softwareverteilung eine grosse Anzahl von Computern gleichzeitig installiert und bei Problemen grosse Ausfälle die Folge wären. Es ist deshalb wichtig eine Verteilung richtig zu planen, damit später nicht ungewollte Ereignisse auftreten.

Wesentlicher Punkt bei der Softwareverteilung ist der Zeitpunkt, wann die Verteilung durchgeführt werden soll.
Handelt es sich um einen kritischen Softwareupdate welcher wesentliche Sicherheitslücken schliessen soll und welcher so schnell wie möglich auf allen Computern installiert sein soll, kann eine sofortige Verteilung durchgeführt werden.

Ausschlaggebend für eine problemlose Softwareverteilung ist das Softwarepaket. Pakete welche nach der Installation einen Neustart des Computers erfordern eignen sich nicht dazu "at work", d.h. während der Benutzer eingeloggt ist (und arbeitet), zu verteilen.

Softwarepakete welche keinen Neustart des Computers erfordern, sollten auch nur während den Arbeitszeiten verteilt werden, wenn die Installation nur ein paar wenige Minuten dauert oder wenn sie im Hintergrund ausgeführt werden können.

Mit remoteIC können Sie jede Verteilung individuell konfigurieren. Sie können Neustarts durch Pakete zusammenfassen oder Installationen nur während dem Bootvorgang vornehmen.

Siehe auch
Grundlegendes zur Softwareverteilung
Verteilung durchführen
Verteilen ausserhalb der Arbeitszeiten
Verteilung kontrollieren


Verteilungen durchführen

Distribution

Eingabefeld | Beschreibung
Distribution name | Bezeichnung der Verteilung. Tip: geben Sie eine möglichst aussagekräftige Bezeichnung ein, da dies die Kontrolle zu einem späteren Zeitpunkt wesentlich vereinfacht.
Description | Beschreibung der Verteilung. Ermöglich eine genauere Bezeichnung der Verteilung.
Computers | Auf welche Computer soll die Verteilung durchgeführt werden. Computer können entweder aus der Liste ausgewählt oder durch klicken auf "Search Computers..." auch nach diversen Kriterien gesucht werden.
Packages | Die Softwarepakete werden an die oben ausgewählten Computer verteilt. Wenn Paketabhängigkeiten definiert wurden, werden die abhängigen Softwarepakete automatisch mitverteilt. Mit den Pfeiltaste können Sie die Pakete in einer bestimmten Reihenfolge installieren.

Settings

Eingabefeld | Beschreibung
Start of installation | Geben Sie ein Startdatum inklusive Uhrzeit an, wann diese Verteilung gestartet werden soll.
Deadline of inst. reject | Nach Ablauf dieses Datums kann der Benutzer die Installation nicht mehr verzögern (reject).
Send start event | Wenn die Verteilung ausserhalb der Arbeitszeit durchgeführt werden soll, können Sie das Steuerkommando zum Aufwecken des Computers mitsenden. Dieses wird vom Controlserver zur richtigen Zeit versendet.
Send end event | Nach der Verteilung kann ein zusätzliches Kommando ausgeführt werden. Bei Verteilungen in der Nacht kann es sein, dass der Computer wieder heruntergefahren werden soll.
Sort order | Angabe der Priorität dieser Verteilung. Wenn bei einem Computer noch andere Verteilungen anstehend sind, wird nach dieser Priorität sortiert.
Detaild inst. logging | Die Installation soll detailiert ins Eventlog eingetragen werden. (empfohlen).

Settings - Für jedes Softwarepaket individuell

Eingabefeld | Beschreibung
Status | Aktueller Status der Verteilung dieses Softwarepaketes. Fehlerhafte Verteilungen können sofort gestoppt werden.
Installation type | Zu welchem Zeitpunkt soll dieses Softwarepaket installiert werden. Hier werden die im Paket definierten Werte übernommen. Sind Pakete in dieser Verteilung welche nicht "at work" installiert werden können, kann keines der Pakete "at work" installiert werden.
Force reinstall | Das Paket soll auch neu installiert werden, wenn die Software auf dem Computer bereits existiert. Wird bei fehlerhaften Paketen/Installationen benötigt.
Max. reject count | Legt fest, wie oft der Benutzer dieses Paket verzögern, d.h. auf später verschieben kann. Unterschied 'verzögert' / 'abgelehnt' Verzögerte (auf später verschobene Pakete) werden lediglich zurückgestellt (siehe Delay time). Wurde ein Paket als 'Optional' definiert, kann es komplett abgelehnt werden. Ein abgelehntes Paket wird nicht erneut installiert. Der Benutzer kann das Programm jedoch via rIClient (System tray icon) installieren lassen.
Delay time | Anzahl Minuten bis zum nächsten Installationsversuch. Verschiebt der Benutzer die Installation auf später (reject), wartet der Installer Service "Delay time" min. bis er den Benutzer erneut mit der Installation der Software konfrontiert.

Settings - Distribute if these packages are already installed

Das Softwarepaket wird nur an Computer gesendet, auf welchen die selektierten Softwarepakete bereits installiert sind. Bei allen anderen Computern wird diese Verteilung ignoriert.

Settings - Distribute if requirements are ok (Distribution requirement)

Das Softwarepaket wird nur bei Computern installiert welche die angegebenen Anforderungen erfüllen. Wenn die Anforderung nicht erfüllt wurde, ignoriert der Client dieses Softwarepaket.

Unterschied 'Package requirement' und 'Distribution requirement'

Package requirement Dialog 'Package' | Ein 'Package requirement' ist eine zwingende Voraussetzung für die Installation eines Paketes. Wurde diese Anforderung nicht erfüllt, kann das Paket zu diesem Zeitpunkt nicht installiert werden. Beispiel: Um zu vermeiden, dass eine Software, welche gerade in Gebrauch ist, aktualisiert wird, kann ein 'Prozess Requirement' definiert werden. Die Installation wird somit auf später verschoben.
Distribution requirement Dialog 'Distribution' | Ein 'Distribution requirement' ist eine Voraussetzung für eine Verteilung. Das zu verteilende Paket wird nur auf Computern installiert, welche die unter 'Distribution requirement' angegebenen Anforderungen erfüllen. Beispiel: Man möchte einen Patch für Office verteilen. Der Patch soll nur auf Rechnern installiert werden, welche Outlook XP installiert haben. Man erstellt folgendes 'Distribution Requirement': Requirement type: Registry Key Item name: HKLM\Software\Microsoft\Office\10.0\Outlook Operator: exists Value:

Eingabefeld | Beschreibung
Requirement type | Die Art der Abhängigkeit. Wählen Sie zwischen Registry-Eintrag, einer Datei oder einem Prozess.
Item name | Geben Sie den Namen der Abhängigkeit an. Bei Registry den Registry-Schlüssel, bei Datei den Dateinamen inklusive Pfad, bei Prozess den Prozessnamen.
Operator | Gibt die Art der Verknüpfung mit dem Wertefeld an. Definiert beispielsweise ob eine Datei existiert oder ein Prozess gestartet (runnning) wurde.
Value | Vergleichswert.


Verteilen ausserhalb der Arbeitszeiten

Wenn Software auserhalb der Arbeitszeiten verteilt werden soll, sind häufig nicht alle Computer eingeschaltet.
remoteIC bietet jedoch die Möglichkeit vor und nach einer Verteilung einen Steuerbefehl an alle von der Verteilung betroffenen Computer zu senden. Wenn die Computer mit WfM-Kompatiblen Netzwerkkarten ausgerüstet sind, kann ein Wake-On-Lan-Befehl versendet werden. Dieser Befehl startet die Computer automatisch auf Grund ihrer MAC-Adresse. Die MAC-Adresse wird in der Regel automatisch vom Installer-Service eingetragen.

Sind komplett neue Computer in der Verteilliste, welche noch kein Betriebssystem installiert haben, müssen einige Felder (MAC-Adresse, IP-Adresse und Subnet-Mask) vorgängig im Computermanagement eingetragen werden.

Für weitere Informationen betr. Verteilung siehe auch Verteilung durchführen.


Verteilung kontrollieren

Verteilungen können auf verschiedene Art und Weise kontrolliert werden.

Distributions - Fenster

Im Distributions-Fenster werden alle Verteilungen angezeigt (Zeile pro Softwarepaket). Sie erhalten eine direkte Übersicht auf wievielen Computern die Software installiert wurde.

Software - Inventory - Computer

Im Computermanagement kann bei jedem Computer unter Software überprüft werden, welche Software zur Zeit installiert wird oder bereits installiert wurde.

Software - Inventory - Gruppe

Im Computermanagement kann bei jeder Gruppe unter Software überprüft werden, welche Software zur Zeit installiert wird oder bereits installiert wurde.

Auswertungen

Um die Verteilungen kontrollieren zu können, sind mehrere Auswertungen verfügbar.

Siehe auch
Grundlegendes zur Softwareverteilung
Verteilung planen
Verteilung durchführen
Verteilen ausserhalb der Arbeitszeiten


Grundlegendes zum Computermanagement

Das Computermanagement umfasst neben den Computern und den Informationen zu jedem einzelnen Computer auch die Computergruppen.
Im Computermanagement ist Ihr komplettes für remoteIC definiertes Netzwerk gut überschaubar dargestellt.

Hier erhalten Sie einen raschen Überblick über den Status der Computer im Netzwerk. Sie sehen ob der Computer aktiv - eingeschaltet ist. Ausgeschaltete Computer werden mit einem halbtransparenten Symbol dargestellt.

Zu jedem Computer im Netzwerk ist eine Vielzahl von Informationen verfügbar. Mit remoteIC können Sie jeden Computer per Knopfdruck überwachen und auch Änderungen vornehmen. Sie benötigen hierzu kein zusätzliches Produkt.

Weitere Informationen zu den angezeigten Informationen finden Sie unter vorhandene Übersicht.


Ereignisanzeige

Alle auf einem Computer geschehenen Ereignisse werden dokumentiert in der Datenbank gespeichert. Wie ausführlich dies geschehen soll können Sie in den Settings oder für jeden Computer einzeln definieren.
Durch Doppelklick auf ein solches Ereignis erhalten Sie detailiertere Angaben über die Art und die Wichtigkeit der Meldung.

Spalte | Beschreibung
Date/Time | Datum und Uhrzeit des Ereignisses.
Description | Bescheibung des Ereignisses.
Type | Art des Ereignisses. Von welchem Dienst wurde das Ereignis ausgelöst.
Event level | Wichtigkeitsgrad des Ereignisses. Handelt es sich um eine einfache Statusmeldung oder ist ein Problem aufgetreten? Diesen Unterschied können Sie dem "Event level" entnehmen.
Details | Zusätzliche Details zum Ereignis wie Fehlermeldungen etc.


Services

Sofern der Computer auf welchem die Verwaltungskonsole ausgeführt wird direkten Zugriff auf den ausgewählten Computer hat und der angemeldete Benutzer über die nötigen Rechte verfügt, werden hier alle Dienste des Remote-Computers angezeigt.
Diese Dienste können direkt aus der Verwaltungskonsole gestartet, gestoppt oder auch pausiert werden.

Spalte | Beschreibung
Name | Name des Dienstes
Status | Anzeige des akuellen Status des Dienstes. Je nach Status kann der Dienst nur gestartet oder nur gestoppt werden.
Type | Die Art des Dienstes.

Durch drücken der F5-Taste kann die Liste jederzeit aktualisiert werden.


Korrekts Einrichten eines Computers

Korrektes Einrichten eines Computers

General

Eingabefeld | Beschreibung
Computername | Der Name des Computers im Netzwerk. Es muss ich um einen eindeutigen Namen handeln; duplikate sind nicht erlaubt.
Domain | In welcher Domäne befindet sich der Computer. Es kann aus einer Liste mit bestehenden Domänennamen ausgewählt werden.
Computer type | Computertyp: Arbeitsstation, Notebook, Server oder Terminalserver.
In groups | In welchen Gruppen befindet sich der Computer? Es sind beliebig viele Gruppen möglich. Um den Computer zu einer Gruppe hinzuzufügen klicken Sie auf den Knopf "Add...". Um den Computer aus einer Gruppe zu löschen selektieren Sie die Gruppe und klicken Sie auf den Knopf mit der Bezeichnung "Remove".

Computer settings

Eingabefeld | Beschreibung
Make local copy of package | Stellen Sie diese Einstellung auf ja, wenn die Softwarepakete vor der Installation lokal zwischengespeichert werden sollen. Normalerweise wird die Software direkt vom Distributionserver-Verzeichnis installiert.
Event log level | Wie detailliert soll bei diesem Computer das Protokoll geführt werden.
Act as remoteIC server | Handelt es sich bei diesem Computer um einen Distributionserver? Wenn Sie diese Option aktivieren, werden die Karteireiter "Distributionserver settings" und "Distributionserver packages" freigeschaltet. Weitere Informationen zu den Einstellungen des Distributionservers finden Sie unter Distributionserver. Wenn dieser Computer als Controlserver agieren soll, starten Sie unter 'Settings' den Controlserver-Assistenten.
Active processes | Welche Prozesse sollen auf diesem Computer ausgeführt werden? Jede Komponente kann beliebig hinzugefügt oder entfernt werden. Damit die geänderte Konfiguration sofort aktiv wird, muss ein 'Initialize settings' Kommando gesendet werden.
Mac-Address | Die eindeutige Identifikationsnummer der Netzwerkkarte im Netzwerk. Wird normalerweise automatisch vom remoteIC-Client-Service eingetragen. Bei neuen Computern können Sie dies jedoch auch manuell erledigen. Dieses Feld muss ausgefüllt sein damin Wake-On-Lan für diesen Computer funktioniert.
IP-Address | Legt die IP-Adresse dieses Computers fest. Wird automatisch vom remoteIC-Client-Service eingetragen. Bei neuen Computern muss diese Adresse definiert sein, damit Wake-On-Lan korrekt funktioniert.
Subnet Mask | Legt die Subnet-Mask-Adresse dieses Computers fest. Wird automatisch vom remoteIC-Client-Service eingetragen. Bei neuen Computern muss diese Adresse definiert sein, damit Wake-On-Lan korrekt funktioniert.

Computer User

Informative Anzeige aller Computer-Benützer. Der Haupt-Benutzer, der am Häufigsten angemeldete Benutzer, wird in der Liste fett angezeigt.

Es handelt sich hierbei um eine rein informative Liste. An den Benutzer können keine Änderungen vorgenommen werden.

Distributionservers

Normalerweise werden die Distributionserver in den Gruppen definiert. Sollte jedoch die Anforderung bestehen, dass ein Computer seine Softwarepakete von einem speziellen Distributionserver bezieht, kann dieser Distributionserver hier festgelegt werden. Es ist auch möglich mehrere Server anzugeben.

Installed packages

Die installierten Softwarepakete werden in dieser Liste dargestellt. Wenn ein Softwarepaket über ein Deinstallationsskript verfügt, können die installierten Programme deinstalliert werden. Wählen Sie hierzu die Software aus, welche entfernt werden soll und klicken auf "Remove".
In der Spalte "Status" wird der aktuelle Status der Software angezeigt.

Monitoring

Jeder Computer kann andere Computer überwachen. Hier können Sie erfassen, welche Computer auf welchem Port überwacht werden sollen.

Information

Die Informationsfelder werden für die Inventarisierung verwendet. Sie können bei benutzerdefinierten Feldern bei jedem Computer einen individuellen Wert erfassen. So lässt sich z.B. eine interne Telefonliste realisieren.


Verhandene Übersicht

Vorhandene Übersicht

Jeder Computer bietet eine Vielzahl von Informationen.

Auswahl in Übersicht | Beschreibung
Member of | Zu welchen Gruppen ist der Computer zugeordnet. Es werden detailierte Informationen zu den Gruppen angezeigt.
Computer user | Eine Liste aller Benutzer welche an diesem Computer arbeiten oder in letzer Zeit gearbeitet haben. Dient auch der Überwachung der Arbeitsstationen. Benutzer welche nichts an diesem Computer zu suchen haben werden so schnell erkannt.
Software | Jegliche durch remoteIC auf diesem Computer installierte Software wird angezeigt. Zudem kann auch Software angezeigt werden, welche nicht durch remoteIC installiert wurde. Solche Software muss in den Settings definiert werden.
Events | Alle von remoteIC erstellten Ereignisse werden angezeigt. Siehe auch Ereignisanzeige.
Monitoring | Wenn der Computer einen Dienst Überwacht, wird hier der Status angezeigt.
Trouble Tickets | Zu jedem Computer können Trouble Tickets eröffnet werden. Die Supportleistung wird dadurch erheblich erleichtert.
System Information | Bietet eine Übersicht über das System. Diverse Hardwareinformationen sowie BIOS-Versionen und Betriebssystem werden angezeigt. Zudem kann der aktuelle Stand der Arbeitsspeicherauslastung überwacht werden.
Information fields | Bei den Informationsfeldern handelt es sich um Registrierungsschlüssel oder benutzerdefinierte Eingabefelder. Sie sind vor allem für die Inventarisierung vorgesehen.
Services | Eine Liste mit allen auf dem Remote-Computer installierten Dienste. Dient dem Computermanagement. Details unter Services.
Physical disks | Detailierte Angaben zu den physikalisch vorhandene Festplatten.
Logical drives | Übersicht über die logischen Laufwerke mit Typenangabe und Filesystem.
Distributionservers | Wenn für diesen Computer individuelle Distributionserver festgelegt wurden, werden diese hier aufgelistet.
Hosted packages | Wenn es sich bei diesem Computer um einen Distributionserver handelt, werden alle zwischengelagerten Pakete mit dem aktuellen Status angezeigt. Deinstallation sowie erneute Synchronisation kann per Mausklick ausgeführt werden.


Grundlegendes zu Computergruppen

remoteIC bietet die Möglichkeit Computer in Gruppen zusammenzufassen. Dies erleichtert die Softwareverteilung und vereinfacht die Übersicht.

In remoteIC sind belibig viele Computergruppen möglich. Zudem können die Gruppen Untergruppen enthalten.
Wie Sie die Computer gruppieren wollen bleibt Ihnen überlassen. Beste Erfahrungen haben sich jedoch bei Firmen gezeigt welche die Gruppen ihrer Unternehmensstruktur entsprechend eingerichtet haben. Häufig unterscheiden sich die Softwarekonfigurationen innerhalb von Abteilungen nur minim.

Wenn Sie eine neue Gruppe einrichten, haben Sie folgende Konfigurationsmöglichkeiten:

Feld | Beschreibung
Group name | Bezeichnung der Gruppe. Die Bezeichnung muss eindeutig sein. Mehrere Gruppen mit dem selben Namen sind nicht möglich. Es empfiehlt sich die Gruppenbezeichnung möglichst genau zu definieren.
Location | Der Standort der Gruppe oder auch Filiale. Dieses Feld ergänzt die Gruppenbezeichnung.
Members | Alle Computer oder Gruppen, welche in dieser Gruppe zusammengefasst sind, werden in dieser Liste angezeigt. Neue Computer/Gruppen können durch drücken der Taste "Add..." hinzugefügt werden. Selektieren Sie einen Computer / eine Gruppe und klicken Sie auf "Remove" um Mitglieder zu entfernen.


Automatische Gruppenzuordnung

Wenn der Controlserver neue Computer im Netzwerk entdeckt, werden diese automatisch in remoteIC erfasst.
Damit diese automatische Erfassung richtig funktioniert, kann in jeder Gruppe das Format der Computerbezeichnung angegeben werden. Computer mit ähnlichen Bezeichnungen werden in die jeweilige Gruppe aufgenommen.

Beispiel:

Wenn von den Computern ZRHWS01, ZRHWS02, ZRHWS03, ZRHSV01, ZRHSV02 nur die Computer mit der Bezeichnung ZRHW?? in diese Gruppe aufgenommen werden sollen, geben Sie ZRHW* ein. Sollen nur die Computer ZRHSV?? erfasst werden, geben Sie ZRHSV* ein. Sollen alle Computer erfasst werden, geben Sie nur den * ein.
Computer welche nicht erfasst werden sollen, können mit vorangestelltem Ausrufezeichen erfasst werden (Bsp. !ZRHSVUNIX).


Standard-Pakete

Jeder Gruppe kann eine vielzahl von Standard-Paketen zugeordnet werden. Wenn ein neuer Computer in eine Gruppe erfasst wird, welche solche Standard-Pakete definiert hat, werden diese Standard-Pakete automatisch auf den neuen Computer verteilt und installiert.

Neue Computer können so mit sehr geringem Arbeitsaufwand eingerichtet werden.

Wenn ein Paket durch ein neueres ersetzt wurde, wird automatisch die neuste Version verwendet. D.h. wenn die Gruppe zuvor die Version 2 einer Software zugeordnet hatte und es eine Version 3 des Programmes gibt und diese neue Version als Ersatz der Version 2 definiert wurde, wird bei einem neuen Mitglied der Gruppe automatisch die Version 3 installiert.

Bei vielen Gruppen erleichtert dies den unterhalt erheblich. Die Definition einer "Ersatz-Version" ist einfach zu bewerkstelligen. Siehe Paketdefinition


Zuständige(r) Distributionserver

Den Gruppen kann einer oder auch mehrere Distributionserver, sogenannte Softwaredepots, zugeordnet werden. Die Mitglieder dieser Gruppe beziehen die Software nur von den der Gruppe zugeordneten Distributionserver. Dies ermöglicht eine Entlastung des Netzwerks und beschleunigt die Verteilung von neuer Software.

Um Installationen über langsame WAN Verbindungen zu vermeiden, wird oft ein Server pro Region (Filiale) eingerichtet. Weitere Informationen zum Einrichten von Distributionservern finden Sie unter Distributionserver


Grundlegende Informationen zur Inventarisierung

Die Inventarisierungsinformationen sind für jeden Computer sehr detailliert verfügbar. So können Sie zum Beispiel nachschauen, wieviel Arbeitsspeicher eine bestimmte Arbeitsstation hat, welche Software installiert wurde (durch remoteIC oder manuell) und welcher Benutzer sich am häufigsten angemeldet hat.

Die installierte Software kann auch über eine Gruppe betrachtet werden. Dies ermöglicht einen raschen Überblick und erleichtert die Analyse, wo welche Software oder Patches noch verteilt werden müssen. Auch bei dieser Funktion werden sowohl manuell installierte Programme wie auch mit remoteIC verteilte Software angezeigt und unterschieden.

Siehe auch:
Hardware Inventar

Software Inventar definieren
Software Inventar pro Computer anzeigen
Software Inventar einer Gruppe anzeigen


Angezeigte Hardware Informationen

Folgende Hardware Informationen werden von remoteIC inventarisiert:

System Information

Bezeichnung | Beschreibung
OS | Installiertes Betriebssystem
Processor | Prozessor Hersteller, Typ und Modell
System BIOS Version | Die Version des System-BIOS
System BIOS-Date | Datum der letzten BIOS-Revision
Video BIOS Version | Version des BIOS der Grafikkarte
Video BIOS Date | Datum der letzten Grafikkarten BIOS-Revision
Root Directory | Auf welchem Laufwerk ist das Betriebssystem installiert
System Directory | Welches ist das Systemverzeichnis von Windows
Total Physical Memory | Total physikalischer Arbeitsspeicher (RAM)
Avaliable Physical Memory | Verfügbarer physikalischer Arbeitsspeicher (RAM)
Total Virtual Memory | Total virtueller Arbeitsspeicher
Total Available Memory | Total verfügbarer virtueller Arbeitsspeicher
Page File Size | Grösse der Auslagerungsdatei
Available Page File Memory | Verfügbarer Speicher im Pagefile
Memory Usage | Im Moment verwendeter Arbeitsspeicher

Physical disks

Anzeige der physisch vorhandenen Festplatten. Die genaue Architektur wird für jede installierte Platte angezeigt.

Logical drives

Logische Laufwerke des Systems. Diskettenlaufwerke, CD-ROM, DVD und Festplatten-Laufwerke werden angezeigt. Informationen über Typ und Filesystem sowie Grösse und verfügbarer Speicherplatz sind ebenfalls ersichtlich.


Definieren von Software welche inventarisiert werden soll

Mit remoteIC kann einen beliebige Software in die Inventarisierung aufgenommen werden. Um ein Programm erkennen zu können benötigt remoteIC detailierte Angaben zu einer der Dateien welche für das Programm eindeutig ist.
Meistens handelt es sich dabei um die Anwendungsdatei mit der Endung ".EXE".

Diese Angaben werden in den Settings unter dem Karteireiter "Inventory" erfasst.

Damit das Programm genau identifiziert werden kann, müssen folgende Angaben zur Datei gemacht werden:

Feld | Beschreibung
Name | Bezeichnung der Software inklusive Versionsangabe. Je detailierter die Bezeichnung desto Aussagekräftiger werden die Auswertungen sein.
Filename | Name der Datei nach welcher gesucht werden soll.
Filesize | Genaue Grösse der Datei nach welcher gesucht wird.
Filedate | Datum der gesuchten Datei.
Software package | Falls es sich bei der gesuchten Software um ein Programm handelt, welches auch per remoteIC verteilt wird und zu welchem bereits ein Softwarepaket existiert, kann das zugehörige Softwarepaket in diesem Feld angegeben werden.

Leere Felder werden ignoriert! Lässt man die Felder 'Filesize' und 'Filedate' leer, wird nur nach dem Namen gesucht. So könnte man beispielsweise nur den Filenamen 'Excel.exe' definieren, um alle Versionen von 'Microsoft Excel' zusammenzufassen.

Wenn sich auf dem Computer, auf welchem die Verwaltungskonole gestartet wurde, die gesuchte Software ebenfalls befindet, kann die Datei ausgewählt werden indem der "Browse..." Knopf gedrückt wird. Alle notwendigen Angaben zur Datei werden dann automatisch übernommen.


Softwareinventar pro Computer

Sobald die erste Inventarisierung auf einem Computer vollständig durchgeführt wurde, wird auch das Softwareinventar für diesen Computer sichtbar.

Das Inventar wird im vorgegebenen Intervall (Settings) durchgeführt und läuft im Hintergrund ohne, dass der Benutzer davon gestört wird.

Die Auflistung der auf dem Computer installierten Software finden Sie unter
Computers/Groups - Computers - [Ihre Domäne] - [Computername] - Software.
Diese Aufstellung umfasst Installationsart (manuell oder durch remoteIC), Name, Version, Status und Installationspfad der Software. Version und Status werden jedoch nur bei remoteIC-Softwarepaketen angezeigt.


Softwareinventar der Gruppe

remoteIC bietet auch ein auf die Gruppe zusammengefasstes Softwareinventar. Hierbei werden alle Computer der Gruppe miteinander verglichen. Software, welche auf allen Computern in der Gruppe installiert ist, wird angezeigt.

Sie finden das Inventar über die Gruppe unter "Computers/Groups - Groups - [Gruppenname] - Software".

Diese Aufstellung erlaubt Ihnen einen raschen Überblick, welche Software auf welchen Rechnern installiert ist.


Übersicht über alle vorhandenen Kommandos

Mit der rICadmin-Verwaltungskonsole können direkt Kommandos an den Client-Computer gesendet werden. Folgende Aufstellung soll Ihnen helfen diese Steuerkommandos zu verstehen.

Die Steuerbefehle werden ausgeführt indem Sie auf einen beliebigen Computer mit der rechten Maustaste klicken.
Im Untermenu "Send command..." befinden sich eine Vielzahl von Steuerkommandos

Befehl | Beschreibung
Wake on lan | Weckt den Computer. Wenn der Computer ausgeschaltet ist, startet er automatisch. Wird nur bei Computern mit WfM kompatiblen Netzwerkkarten unterstützt.
Check for new packages | Veranlasst den Computer nach neuen In- und Deinstallations-Paketen zu suchen.
Reboot computer | Startet den Computer neu. Alle offenen Programme werden geschlossen, nicht gespeicherte Änderungen an Dokumenten gehen verlohren.
Inventory | Startet die Inventarisierung auf dem ausgewählten Computer.
Initialize settings | Alle Einstellungen werden neu eingelesen. Bei Änderungen in den Settings empfehlenswert.
Synchronize packages | Nur bei Distributionservern verfügbar. Startet die Synchronisation zwischen Distributionservern.
Wake Controlserver | Nur bei Controlservern verfügbar. Aktiviert den Controlserver damit neue Computer erkannt und installiert werden können. Kann auch bei updates von remoteIC verwendet werden.
Task list | Siehe Prozessliste
Shutdown computer | Schaltet den Computer aus. Alle offenen Programme werden geschlossen, nicht gespeicherte Änderungen an Dokumenten gehen verloren.
Remote shell | Siehe Remote Shell
Stop all remoteIC services | Beendet alle aktiven remoteIC Komponenten und stoppt den Service.
Abort shutdown/reboot | Bricht das Ausschalten oder den Neustart des Computers ab.


Remote-Control (Bildschirmübernahme)

remoteIC bietet die Möglichkeit ein Remote-Control Produkt direkt in die Verwaltungskonsole einzubinden. Hierzu muss nur das entsprechende Programm in den Settings definiert werden.

Ist das Programm in den Settings definiert und sowohl auf dem Client wie auch auf dem Computer installiert auf welchem die Verwaltungskonsole ausgeführt wird, kann per Mausklick (Rechte Maustaste) das Remote-Control-Programm gestartet werden.

Damit direkt der richtige Computer übernommen wird, kann in den Settings als Parameter zur Programmdatei der Computername mitgegeben werden. Geben Sie hierzu in den Settings den Paramenter %computername an.

remoteIC liefert das Remote-Control-Utility VNC in Form eines Softwarepaketes mit. Ist dieses Paket auf alle Computer verteilt, kann der Bildschirm von jedem Computer im Netz übernommen werden.


Remote Shell (CMD.EXE auf dem Remote-Computer)

Remote CMD Prompt. Startet auf dem ausgewählten Computer eine Eingabeaufforderung. Mit der Eingabeaufforderung können Änderungen auf dem Computer durchgeführt werden ohne, dass der Benutzer seine Arbeit unterbrechen muss.

Alle Befehle welche in der Eingabeaufforderung unterstützt werden, können auch per Remote Shell ausgeführt werden.

Die Remote Shell kann jederzeit durch Eingabe von "exit" beendet werden.

Starten Sie keine Programme per Remote Shell welche eine direkte Grafikausgabe besitzen, da nur der Textbuffer ausgegeben werden kann. Starten Sie trotzdem ein solches Programm, können Sie die Remote Shell nur mit dem Windowsdialogfeld "X" schliessen. Die Eingabeaufforderung auf dem Client wird nach Ablauf eines Timeouts automatisch beendet.
Batches hingegen können problemlos gestartet werden (Ausser es wird innerhalb des Batches ein Programm gestartet).


Prozessliste

Der Prozessliste-Steuerbefehl öffnet in der Verwaltungskonsole ein Dialogfenster mit allen Prozessen welche auf dem ausgewählen Computer aktiv sind. Einige Prozesse können von diesem Dialog direkt beendet werden.


Grundlegendes zum Controlserver

Aufgaben Controlserver

  • Zeitgesteuerte Kommandos und WOL ausführen (Haupt-Controlserver)
  • Automatische Erfassung von neuen Workstations und Gruppenzuteilung
  • Automatische Updates einer neuen remoteIC Version
  • Überwachung der Clients, evtl. Deinstallation von alten Clients etc.
  • Versenden von Defaultpaketen
  • Datenbank Wartung (Haupt-Controlserver)

Zeitgesteuerte Kommandos und WOL ausführen

Der Controlserver sollte im Netzwerk immer aktiv sein und wird deshalb auf einem Netzwerkserver installiert. Da mit remoteIC auch Softwareverteilungen ausserhalb der Arbeitszeiten möglich sind und nicht immer alle Computer über die Nacht oder über das Wochenende eingeschaltet bleiben, weckt der Controlserver die Clients vor einer Installation indem er einen Wake-On-Lan Kommando sendet.
Die Computer werden gestartet und die Installation wird durchgeführt. Nach der Installation werden die Computer wieder heruntergefahren.

Erfassen von neuen Computern

Der Controlserver vergleicht die Computerliste des Netzwerkes laufend mit der Computerliste von remoteIC. Fehlt der Computer in der remoteIC Datenbank, werden die Gruppendefinitionen überprüft. Wurde eine Übereinstimmung gefunden, wird der Rechner in die entsprechende Gruppe eingetragen und der Service wird auf dem Remotecomputer installiert. Sollte auf einem neuen Computer die Client-Komponente fehlen oder in einer älteren Version vorhanden sein, wird der Service erneut installiert.

Defaultpakete

Ein Softwarepaket kann als Defaultpaket einer Gruppe zugeordnet werden. Findet der Controlserver einen neuen Computer, welchen er einer Gruppe zuordnen kann, werden die Defaultpakete automatisch verteilt.

Deinstallation von Clients

Wird ein Computer in der Administrationskonsole gelöscht, übernimmt der Controlserver die Deinstallation des Service.


Der Haupt-Controlserver

In jedem Netzwerk, in welchem remoteIC zum Einsatz kommt, wird ein Controlserver benötigt. Der Haupt-Controlserver erledigt nebst den normalen Controlserver Tasks folgende Aufgaben:

  • Auslösen von zeitgesteuerten Kommandos
  • Datenbank Wartung

Normalerweise reicht ein einzelner Controlserver aus. Es gibt jedoch komplexere Netzwerkstrukturen, in welchen mehrere Controlserver zum Einsatz kommen.


Zusätzliche Controlserver

Bei Firmen welche geografisch getrennte Abteilungen/Filialen zentral administrieren möchten und über keine internen Datenleitungen verfügen, kann ein zusätzlicher Controlserver in den Filialnetzwerken eingesetzt werden. Der Controlserver übernimmt dabei die Umwandlung von Datenbankabfragen in verschlüsselte HTTP-Pakete. So können die Datenbankabfragen über offene Standardports durch den Firewall geleitet werden (HTTP-Tunneling).

Der zusätzliche Controlserver übernimmt auch die Aufgaben des Hauptservers in seinem Netzwerksegment und erfasst neue Computer etc.


Grundlegendes zum Distributionserver

Der Distributionserver ist das Kernstück der Softwareverteilung. Alle Softwarepakete werden auf einem oder mehreren Distributionserver zwischengelagert.

Grundsätzlich kann jeder Computer im Netzwerk die Aufgabe eines Distributionservers übernehmen, es empfiehlt sich jedoch den Distributionserver auf einem der Fileserver zu installieren. Der Distributionserver benötigt einiges an Festplattenkapazität, da alle Softwarepakete welche in remoteIC verwendet werden, auf dem Distributionserver gespeichert werden.

Der erste erstellte Distributionserver ist der Haupt-Distributionserver und kann mittels Distributionserver-Assistent erstellt werden. Weitere Distributionserver können ebenfalls per Assistent oder unter Computereigenschaften definiert werden.

Eingabefeld | Beschreibung
Status | Der Distributionserver kann auf inaktiv geschaltet werden, wenn aus irgendeinem Grund keine Software von diesem Server installiert werden soll. Kann z.B. bei Netzwerkengpässen nützlich sein.
Max. connections | Wieviele Computer dürfen gleichzeitig Software von diesem Server beziehen. Dient der Netzwerklastverteilung.
Max. response time | Maximale Antwortzeit eines Clients. Überschreitet ein Client diese Antwortzeit, kann er keine Software aus diesem Depot beziehen und bedient sich von einem Distributionserver zu welchem er eine bessere Verbindung hat.
Sync. interval | Legt fest, wie häufig der Distributionserver mit dem Haupt-Distributionserver synchronisieren soll. Handelt es sich hierbei um den Hauptserver, hat diese Einstellung keine Bedeutung.
Package path | Verzeichnis auf welchem die Softwarepakete zwischengespeichert werden sollen. Es muss sich hierbei um einen Netzwerk-Share handeln, da die Clients dieses Verzeichnis ebenfalls verwenden um die Software zu installieren.
Transfer type | Auf welche Art bezieht der Distributionserver die Softwarepakete vom Hauptdepot. bei "copy" werden die Daten normal kopiert. Die Einstellung "HTTP" und "FTP" öffnet die Felder "Hostname", "Port", "Username", und "Password". Die Daten werden dann per HTTP oder FTP übertragen.
Hostname | Von welchem Host sollen die Pakete geholt werden. Es muss sich um einen UNC-Pfad handeln.
Port | Über welchen Port wird mit dem Host kommuniziert.
Username Password | Welcher Benutzer/Passwort soll für die Übertragung verwendet werden. Der Benutzer muss über die nötigen Rechte verfügen.


Der Haupt-Server

Damit die remoteIC Softwareverteilung funktionieren kann, muss mindestens ein Distributionserver eingesetzt werden. Dieser Server ist der Haupt-Distributionserver und wird beim ersten Start der Verwaltungskonsole automatisch eingerichtet.

Wird der Haupt-Server für längere Zeit ausgeschaltet, empfiehlt es sich einen anderen Distributionserver als Haupt-Server hinaufzustufen.

Die zusätzlichen Verteilzentralen synchronisieren laufend mit dem Hauptserver. Hierbei werden aber nur Daten kopiert, welche sich geändert haben. Somit wird das Netzwerk nur minim von einer solchen Synchronisation belastet.


Zusätzliche Verteilzentralen

Bei grösseren Firmen mit hunderten von Computern ist es sinnvoll, mehrere Distributionserver zu verwenden. Da ein einzelner Server bei einer Softwareverteilung auf hunderte von Computern sonst sehr stark belastet wird.

remoteIC erlaupt den Einsatz von beliebig vieler solcher Verteilzentralen. Die Erfahrung hat gezeigt, dass es sich lohnt in jeder geografisch getrennten Lokation einen eigenen Distributionserver einzurichten.

Zusätzliche Verteilzentralen beschleunigen die Softwareverteilung und reduzieren gleichzeitig die Netzwerkauslastung.

Siehe auch:
Beispiel Netzwerkschema


Netzwerk Schema

Nachfolgend eine Illustration eines Computernetzwerkes von remoteIC wie es in der Realität vorkommen könnte.


Grundlegendes zu den Auswertungen

remoteIC bietet eine Vielzahl von Standard-Auswertungen.
Um die individuellen Bedürfnisse abzudecken, haben sie zusätzlich die Möglichkeit selbst Auswertungen zu erstellen. Zusätzlich besteht immer die Möglichkeit mit einem Produkt eines Drittherstellers direkt auf die Datenbank zuzugreifen.

Auf der remoteIC Internetseite www.remoteIC.com werden laufend neue Auswertungen angeboten, welche Sie per Copy-Paste in Ihre Verwaltungskonsole übernehmen können.


Vordefinierte Auswertungen im Überblick

Vordefininierte Auswertungen im Überblick

General

Bericht | Beschreibung
Computerlist | Listet die in remoteIC erfassten Computer mit Anzeige des Standard Benutzers, IP-Adresse, Subnetz-Adresse und Status auf.
Computerlist (Hardware) | Listet die in remoteIC erfassten Computer mit Anzeige von Hardwareinformationen auf.
Distributionserver overview | Zeigt die Auslastung der Distributionserver.
Eventlog | Ausgabe der Ereignisanzeige.
Files on distributionserver | Welche Dateien befinden sich auf welchem Distributionserver. Welcher Status hat ein Softwarepaket auf den verschiedenen Softwaredepots. Mit dieser Liste erhalten Sie die Übersicht.
Group default software packages | Zeigt welche Softwarepakete bei welchen Gruppen automatisch verteilt werden.
Groupmembers | Listet die Gruppenmitglieder auf. Sowohl Computer als auch Untergruppen werden angezeigt.
Installation status | Zeigt den Fortschritt einer Verteilung an.
Installation summary | Ausgabe einer Übersicht über alle oder auch nur über eine bestimmte Software-Verteilung. Anzahl Computer pro Status.
Replaced software packages | Welche Softwarepakete sind durch welche Softwarepakete ersetzt worden?
Software on computer | Welche Software ist auf welchem Computer installiert?
Software usage (Detail) | Welcher Benutzer benutzt welche Software.
User list | Listet Benutzer mit Detailinformationen (Informationsfelder).
User logons | Listet wie oft sich ein Benutzer an einem Computer angemeldet hat.
Trouble Tickets | Gibt die Trouble Tickets aus. Auswahl nach Computer und Gruppe.


Eigene Auswertungen erstellen

Mit remoteIC können individuelle Auswertungen erstellt werden. Klicken Sie hierzu in der Auswertungen auf "Add new report".

Eingabefeld | Beschreibung
Report name | Bezeichnet den Bericht.
Description | Beschreibung zum Bericht.
SQL Query | In diesem Feld kann eine beliebige SQL Datenbankabfrage eingegeben werden.
Field settings | Wenn vorgängig eine korrekte SQL Abfrage eingegeben wurde, können für jede Spalte individuell Einstellungen gemacht werden.
Show database information | Klicken Sie auf diesen Knopf um Datenbankinformationen anzuzeigen.
Update field | Klicken Sie auf diesen Knopf um die Felderliste zu aktualisieren.


Tipps und Tricks

  • Installation der Clients
  • Gruppen einrichten
  • Softwarepakete erstellen
  • Software verteilen
  • Überwachen einer Verteilung

Installation

Erfassen Sie die Computer nicht selber. Überlassen Sie dies dem Controlserver. Sobald Sie eine Gruppe angelegt und ein Assignment definiert haben, könne Sie ein "Wake Controlserver"-Kommando absetzen. Der Controlserver erfasst und installiert die Clients dann selbständig.

Gruppen einrichten

Wenn alle Computer im Netzwerk automatisch ein eine Gruppe erfasst werden sollen, kann bei den Assignments der Stern * verwendet werden.

Softwarepakete erstellen

Überprüfen Sie immer zuerst, ob von remoteIC bereits ein fertiges Softwarepaket vorhanden ist (RemoteIC Internetseite). Sie könne sich so einiges an Arbeit ersparen.

Software verteilen

remoteIC bietet die Möglichkeit direkt an beliebig viele Computer zu verteilen. Dies kann bei kleineren Softwarepaketen welche keine grössere Installation durchführen problemlos gemacht werden. Bei grösseren Installationen empfehlen wir jedoch in kleineren Schritten voranzuschreiten und vorerst nur abteilungsweise zu verteilen. Sollte einmal ein Softwarepaket nicht zu 100% funktionieren, hält sich der Schaden in Grenzen

Überwachen einer Verteilung

Mit remoteIC können Sie beliebige Auswertungen erstellen. Nützen Sie diese Möglichkeit um die Auswertungen Ihren Wünschen anzupassen. Das Überwachen von Verteilstadien wird so einfacher.


Hilfsprogramm remoteIC.exe

remoteIC.exe biete eine vielzahl von nützlichen Funktionen welche Sie in den Softwarepaketen verwenden können. Da remoteIC.exe auf jedem Client im remoteIC Netzwerk installiert ist, können Sie remoteIC.exe ohne weitere Anforderungen verwenden.

remoteIC.exe [Funktion] [Parameter 1] [Parameter 2] ...

Nachfolgend finden Sie eine Beschreibung zu den einzelnen Funktionen.

remoteIC.exe service

Startet den remoteIC service.

remoteIC.exe installService serviceName [/DSN] [/SYS] [/TRS] [/c:] [/d:] [/f:] [/l:] [/p:] [/s:] [/u:] [/w:]

Mit installService können Dienste installiert werden. Es sind Administratorenrechte erforderlich.

Parameter | Beschreibung
serviceName | Kurzname des Dienstes
/c: | Computername (falls nicht lokal)
/d: | Angezeigter Name des Dienstes
/f: | Dateipfad (Bsp: c:\winnt\system32\remoteIC.exe)
/l: | Datenbank Login (nur bei remoteIC)
/p: | Windows Passwort
/s: | Datenbank Servername (nur bei remoteIC)
/u: | Windows Benutzerkonto (Bsp. Domäne\Benutzer1)
/w: | Datenbank Passwort (nur bei remoteIC)
/DSN | Der remoteIC DNS wird erstellt (nur bei remoteIC)
/SYS | Der Dienst wird unter dem Lokalen Systemkonto gestartet
/TRS | Verwende Windows NT-Autentifizierung (nur bei remoteIC)

Beispiel: remoteIC.exe installService remoteIC /d:"Remote installation center" /f:c:\winnt\system32\remoteIC.exe /u:DOMAIN\Username /p: mypassword /SYS /TRS

remoteIC.exe uninstallService serviceName [/c:]

Mit uninstallService können Dienste entfernt werden. Es sind Administratorenrechte erforderlich.

Parameter | Beschreibung
serviceName | Kurzname des Dienstes
/c: | Computername (falls nicht lokal)

Beispiel: remoteIC.exe uninstallService remoteIC

remoteIC.exe startService serviceName [computerName]

Startet einen Dienst.

Parameter | Beschreibung
serviceName | Name vom Dienst (Kurzbezeichnung)
computerName | Computername wenn der Dienst nicht auf dem lokalen Computer gestartet werden soll.

Beispiel: remoteIC.exe startService remoteic testpc

remoteIC.exe stopService serviceName [computerName]

Stoppt einen Dienst.

Parameter | Beschreibung
serviceName | Name vom Dienst (Kurzbezeichnung)
computerName | Computername wenn der Dienst nicht auf dem lokalen Computer gestoppt werden soll.

Beispiel: remoteIC.exe stopService remoteic testpc

remoteIC.exe queryService serviceName [computerName]

Fragt den Status von einem Dienst ab.

Parameter | Beschreibung
serviceName | Name vom Dienst (Kurzbezeichnung)
computerName | Computername wenn der Status von einem sich nicht auf dem lokalen Computer befindenden Dienst abgefragt werden soll.

Beispiel: remoteIC.exe queryService remoteic testpc

remoteIC.exe setStatus installationStatus

Parameter | Beschreibung
installationStatus | 0: Paket erfolgreich installiert/entfernt 1: Paket fehlgeschlagen 2: Anforderung nicht erfüllt 3: Neustart innerhalb von Paket

Beispiel: remoteIC setStatus 0

remoteIC.exe sleep ms

Wartet für eine in Millisekunden angegebene Dauer.

Parameter | Beschreibung
ms | Wartezeit in Millisekunden

Beispiel: remoteIC.exe sleep 500

remoteIC.exe waitForProcess process [timeout]

Wartet bis ein bestimmter Prozess gestartet wird.

Parameter | Beschreibung
process | Prozessname oder Prozessnummerr
timeout | Timeout in Sekunden

Beispiel: remoteIC.exe waitForProcess explorer.exe 10

remoteIC.exe waitForEndProcess process [timeout]

Wartet bis ein Prozess gestoppt worden ist.

Parameter | Beschreibung
process | Prozessname oder -nummer
timeout | Timeout in Sekunden

Beispiel: remoteIC.exe waitForEndProcess explorer.exe 10

remoteIC.exe killProcess process

Beendet einen laufenden Prozess.

Parameter | Beschreibung
process | Prozessname oder -nummer

Beispiel: remoteIC.exe killProcess 1080

remoteIC.exe listProcess

Listet die aktuell aktiven Prozesse auf.

remoteIC.exe setReg rootKey key valueName [/hex:]data [dataType] [computer]

Setzt einen Registrierungseintrag.

Parameter | Beschreibung
rootKey | HKLM: HKEY_LOCAL_MACHINE HKCU: HKEY_CURRENT_USER HKCR: HKEY_CLASSES_ROOT HKU: HKEY_USERS HKCC: HKEY_CURRENT_CONFIG
key | Kompletter Registrierungsschlüssel unter dem ausgewählten rootKey
valueName | Wert welcher geändert oder hinzugefügt werden soll
/hex: | Die gelieferten Daten sind im Hexadezimalformat (ohne Abstände)
data | Neuer Wert
dataType | Einer der folgenden Werte: REG_SZ, REG_DWORD, REG_EXPAND_SZ, REG_MULTI_SZ, REG_BINARY
computer | Computername wenn der Registrierungseintrag nicht auf dem lokalen Computer geändert werden soll.

Beispiele:
remoteIC.exe setReg HKLM Software\testKey timeout 25 REG_DWORD
remoteIC.exe setReg HKLM Software\testKey timeout 25 REG_DWORD \\REMOTEPC
remoteIC.exe setReg HKLM Software\testKey "reg schlüssel" "reg wert" REG_SZ
remoteIC.exe setReg HKLM Software\testKey "reg schlüssel" "/hex:B01610" REG_BINARY

remoteIC.exe getReg rootKey key valueName [computer]

Gibt den Wert eines Registrierungseintrags aus.

Parameter | Beschreibung
rootKey | HKLM: HKEY_LOCAL_MACHINE HKCU: HKEY_CURRENT_USER HKCR: HKEY_CLASSES_ROOT HKU: HKEY_USERS HKCC: HKEY_CURRENT_CONFIG
key | Kompletter Registrierungsschlüssel unter dem ausgewählten rootKey
valueName | Wert welcher angezeigt werden soll
computer | Computername wenn nicht der lokale Registrierungseintrag angezeigt werden soll.

Beispiel: remoteIC.exe getReg HKLM Software\testKey timeout

remoteIC.exe delReg rootKey key [valueName] [computer]

Entfernt einen Registrierungseintrag oder -schlüssel.

Parameter | Beschreibung
rootKey | HKLM: HKEY_LOCAL_MACHINE HKCU: HKEY_CURRENT_USER HKCR: HKEY_CLASSES_ROOT HKU: HKEY_USERS HKCC: HKEY_CURRENT_CONFIG
key | Kompletter Registrierungsschlüssel unter dem ausgewählten rootKey
valueName | Wert welcher empfernt werden soll. Wenn kein Wert angegeben wird, wird der Schlüssel gelöscht.
computer | Computername wenn der Registrierungseintrag nicht auf dem lokalen Computer gelöscht werden soll.

Beispiel: remoteIC.exe delReg HKLM Software\testKey timeout

remoteIC.exe getRegTime rootKey key

Gibt Erstellungsdatum und -zeit eines Registrierungsschlüssels aus.

Parameter | Beschreibung
rootKey | HKLM: HKEY_LOCAL_MACHINE HKCU: HKEY_CURRENT_USER HKCR: HKEY_CLASSES_ROOT HKU: HKEY_USERS HKCC: HKEY_CURRENT_CONFIG
key | Kompletter Registrierungsschlüssel unter dem ausgewählten rootKey

Beispiel: remoteIC.exe getRegTime HKLM Software\testKey

remoteIC.exe waitForReg rootKey key valueName [\\computer] [/t:timeout]

Wartet bis ein bestimmter Registrierungsschlüssel oder -wert erstellt worden ist.

Parameter | Beschreibung
rootKey | HKLM: HKEY_LOCAL_MACHINE HKCU: HKEY_CURRENT_USER HKCR: HKEY_CLASSES_ROOT HKU: HKEY_USERS HKCC: HKEY_CURRENT_CONFIG
key | Kompletter Registrierungsschlüssel unter dem ausgewählten rootKey
valueName | Der Wert unterhalb des Schlüssels welcher abgefragt werden soll
\\computer | Computername wenn der Registrierungseintrag nicht auf dem lokalen Computer abgefragt werden soll. Bei Remotecomputern können nur Schlüssel aus HKLM und HKU abgefragt werden.
/t:[timeout] | Maximale Wartezeit in Sekunden

Beispiele:
remoteIC.exe waitForReg HKLM Software\testKey entry /t:30
remoteIC.exe waitForReg HKLM "Software\testKey key" \\remotepc /t:30

remoteIC.exe waitForDelReg rootKey key valueName [\\computer] [/t:timeout]

Wartet bis ein bestimmter Registrierungsschlüssel oder -wert gelöscht worden ist.

Parameter | Beschreibung
rootKey | HKLM: HKEY_LOCAL_MACHINE HKCU: HKEY_CURRENT_USER HKCR: HKEY_CLASSES_ROOT HKU: HKEY_USERS HKCC: HKEY_CURRENT_CONFIG
key | Kompletter Registrierungsschlüssel unter dem ausgewählten rootKey
valueName | Der Wert unterhalb des Schlüssels welcher abgefragt werden soll
\\computer | Computername wenn der Registrierungseintrag nicht auf dem lokalen Computer abgefragt werden soll. Bei Remotecomputern können nur Schlüssel aus HKLM und HKU abgefragt werden.
/t:[timeout] | Maximale Wartezeit in Sekunden

Beispiele:
remoteIC.exe waitForDelReg HKLM Software\testKey entry /t:30
remoteIC.exe waitForDelReg HKLM "Software\testKey key" \\remotepc /t:30

remoteIC.exe waitForFile path [timeout]

Wartet bis eine Datei vorhanden ist.

Parameter | Beschreibung
path | Kompletter Pfad zur Datei
[timeout] | Maximale Wartezeit in Sekunden

Beispiel: remoteIC.exe waitForFile "C:\Program Files\test.txt" 5

remoteIC.exe waitForTextInFile path searchText [timeout]

Wartet bis ein betimmter Text in einer Datei gefunden worden ist.

Parameter | Beschreibung
path | Kompletter Pfad zur Datei
searchText | Text nach welchem gesucht wird
[timeout] | Maximale Wartezeit in Sekunden

Beispiel: remoteIC.exe waitForTextInFile "C:\Program Files\test.txt" "ResultCode=0" 15

remoteIC.exe waitForTextInReg rootKey key valueName [\\computer] [/s:searchtext] [/t:timeout]

Wartet bis ein Registrierungsschlüssel einen bestimmten Wert hat.

Parameter | Beschreibung
rootKey | HKLM: HKEY_LOCAL_MACHINE HKCU: HKEY_CURRENT_USER HKCR: HKEY_CLASSES_ROOT HKU: HKEY_USERS HKCC: HKEY_CURRENT_CONFIG
key | Kompletter Registrierungsschlüssel unter dem ausgewählten rootKey
valueName | Der Wert unterhalb des Schlüssels welcher abgefragt werden soll
\\computer | Computername wenn der Registrierungseintrag nicht auf dem lokalen Computer abgefragt werden soll. Bei Remotecomputern können nur Schlüssel aus HKLM und HKU abgefragt werden.
/s:[searchtext] | Text nach welchem gesucht wird.
/t:[timeout] | Maximale Wartezeit in Sekunden

Beispiele:
remoteIC.exe waitForTextInReg HKLM Software\testKey entry "/s:my search text" /t:30
remoteIC.exe waitForTextInReg HKLM "Software\testKey key" \\remotepc /s:598 /t:10

remoteIC.exe sendClickMessage ["/windowTitle:"] ["/controlText:" | /controlID:] [/showOutput] [/exact]

Sendet ein Mausklick an ein bestimmtes Windowselement.

Parameter | Beschreibung
/windowTitle: | Text welcher innerhalb des Fenstertitels gesucht werden soll. Der Mausklick wird an dieses Fenster geschickt. Wird kein Wert eingegeben, wird der Mausklick an das dem Element (Knopf) übergeordnete Fenster geschickt.
/controlText: | Text welcher auf dem Element (Knopf) steht welcher den Mausklick erhalten soll.
/controlID: | ID vom Element (Knopf) welcher den Mausklick erhalten soll.
/showOutput | Zeigt den Rückgabewert (debug).
/exact | Der Text muss genau übereinstimmen.

Beispiele:
remoteIC.exe sendClickMessage "/windowTitle:Setup" "/controlText:&Next"
remoteIC.exe sendClickMessage "/windowTitle:Setup" /controlID:3680

remoteIC.exe sendTextMessage text ["/windowTitle:"] ["/controlText:" | /controlID:] [/showOutput] [/exact]

Füllt einen bestimmten Text in ein Windowselement ein.

Parameter | Beschreibung
text | Text welcher eingefüllt werden soll.
/windowTitle: | Text welcher innerhalb des Fenstertitels gesucht werden soll. Der Text wird an dieses Fenster geschickt. Wird kein Wert eingegeben, wird der Text an das dem Element (Eingabefeld) übergeordnete Fenster geschickt.
/controlText: | Text welcher bereits im Element erfasst ist.
/controlID: | ID vom Element (Eingabefeld) welches den Text erhalten soll.
/showOutput | Zeigt den Rückgabewert (debug).
/exact | Der Text muss genau übereinstimmen.

Beispiel: remoteIC.exe sendTextMessage "c:\program files\mypath" "/windowTitle:Setup" /controlID:3680

remoteIC.exe sendMessage handle messageID wParamLow wParamHigh lParamLow lParamHigh ["/windowTitle:"] ["/controlText:" | /controlID:] [/showOutput] [/exact]

Sendet eine Windowsmessage an ein Element oder Fenster

Parameter | Beschreibung
handle | {windowsHandle} | {controlHandle}
messageID | WM_COMMAND | WM_CHAR | WM_KEYDOWN | {Dezimalwert}
wParamLow | {windowsHandle} | {controlHandle} | {controlID} | {integer Wert}
wParamHigh | {windowsHandle} | {controlHandle} | {controlID} | {integer Wert}
lParamLow | {windowsHandle} | {controlHandle} | {controlID} | {integer Wert}
lParamHigh | {windowsHandle} | {controlHandle} | {controlID} | {integer Wert}
/windowTitle: | Text welcher innerhalb des Fenstertitels gesucht werden soll. Die Message wird an dieses Fenster geschickt. Wird kein Wert eingegeben, wird die Message an das dem Element oder Fenster übergeordnete Fenster geschickt.
/controlText: | Text welcher auf dem Element steht welcher die Message erhalten soll.
/controlID: | ID vom Element welches die Message erhalten soll.
/showOutput | Zeigt den Rückgabewert (debug).
/exact | Der Text muss genau übereinstimmen.

Beispiele:
remoteIC.exe sendMessage {windowsHandle} WM_COMMAND {controlID} 1 0 {controlHandle} "/windowTitle:Setup" /controlID:3680
remoteIC.exe sendMessage {windowsHandle} WM_COMMAND {controlID} 1 0 {controlHandle} "/windowTitle:Setup" "/controlText:Finish"

remoteIC.exe listWindow ["/searchText:"] ["/searchHandle:"] [/searchID:] [/showChildWindows]

Listet alle Fenster mit Ihren Untergeordneten Fenster auf.

Parameter | Beschreibung
/searchText: | Text nach welchem innerhalt des Fenstertitels oder der Elementbezeichnung gesucht wird.
/searchHandle: | Fenster-Handle nach welchem gesucht werden soll.
/searchID: | ControlID nach welcher gesucht werden soll
/showChildWindows | Zeigt alle untergeordneten Fenster ebenfalls an.

Beispiel: remoteIC.exe listWindow "/searchText:Setup" /showChlidWindows

remoteIC.exe waitForWindow ["/windowTitle:"] ["/controlText:" | /controlID:] [/timeout:] [/exact]

Wartet bis ein bestimmtes Fenster geöffnet wird.

Parameter | Beschreibung
/windowTitle: | Text welcher innerhalb des Fenstertitels gesucht werden soll.
/controlText: | Text von einem Element auf welches gewartet werden soll.
/controlID: | ID vom Element auf welches gewartet werden soll.
/timeout | Maximale Wartezeit
/exact | Der Text muss genau übereinstimmen.

Beispiel: remoteIC.exe waitForWindow "/windowTitle:Setup" "/controlText:&Next"

remoteIC.exe sendOptionMessage ["/radioText:"] ["/controlText:" | /controlID:] [/showOutput] [/exact]

Sendet einen Mausklick an ein Radio- oder Optionbox-Element.

Parameter | Beschreibung
/radioText: | Text der Gruppe von Radio-Knöpfen.
/controlText: | Text von einem Element welches den Mausklick erhalten soll.
/controlID: | ID vom Element welches den Mausklick erhalten soll.
/showOutput | Zeigt den Rückgabewert (debug).
/exact | Der Text muss genau übereinstimmen.

Beispiele:
remoteIC.exe sendOptionMessage "/radioText:MsiRadioButtonGroup" "/controlText:&Custom"
remoteIC.exe sendOptionMessage "/radioText:MsiRadioButtonGroup" /controlID:4063

remoteIC.exe sendCheckMessage ["/windowTitle:"] ["/controlText:" | /controlID:] [/showOutput] [/exact]

Sendet einen Mausklick an ein Checkbox-Element.

Parameter | Beschreibung
/windowTitle: | Text des übergeordneten Fensters
/controlText: | Text von einem Element welches den Mausklick erhalten soll.
/controlID: | ID vom Element welches den Mausklick erhalten soll.
/showOutput | Zeigt den Rückgabewert (debug).
/exact | Der Text muss genau übereinstimmen.

Beispiele:
remoteIC.exe sendCheckMessage "/windowTitle:Installation" "/controlText:Add icon to desktop"


InstallShield® Parameter

InstallShield® ist das wohl am meisten verbreitete Installationsprogramm. Es unterstützt schon seit längerer Zeit nützliche Parameter welche auf für die Softwareverteilung notwendig sind.

Es gibt 2 Arten von InstallShield® Setups: Das "normale" Setup und das Selbstextrahierende EXE.

Wenn es sich um ein selbstextrahierendes Setup handelt, wird beim Starten der Installation im Temp-Verzeichnis ein normales Setupprogramm extrahiert. Für Softwarepakete sollte dieses extrahierte Installationsprogramm verwendet werden.

Installation:

Setup.exe [-f] [-f1] [-f2] [-d] [-m] [-m1] [-m2] [-r] [-s] [-SMS]

Parameter | Beschreibung
-f[Skriptdatei] | Name der .ins Datei. Kann angegeben werden wenn mehrere .ins Datei vorhanden sind. Wenn ein alternatives Verzeichnis verwendet wird, muss sich die _setup.dll ebenfalls im alternativen Verzeichnis befinden.
-f1[Responsedatei] | Name der .iss Datei. Wird verwendet wenn die Installation silent gemacht wird.
-f2[Logdatei] | Name der Logdatei. Standard ist Setup.log im Setup.exe Verzeichnis
d | Setup im Debugmodus ausführen
-m | InstallShield erstellt eine Management Information Format Datei (status.mif). Die Datei wird im Windowsverzeichnis erstellt.
-m1 | Die Seriennummer wird ebenfalls in die .mif Datei geschrieben
-m2 | Lokale Einstellungen (Standard English ENU) wird ebenfalls in die .mif Datei geschrieben
-r | Eine .iss Aufzeichnungsdatei wird im Windowsverzeichnis erstellt. (Setup.iss) Im der Logdatei kann der Resultcode [ResponseResult] ausgelesen werden. 0 Success. -1 General error. -2 Invalid mode. -3 Required data not found in the Setup.iss file. -4 Not enough memory available. -5 File does not exist. -6 Cannot write to the response file. -7 Unable to write to the log file. -8 Invalid path to the InstallShield Silent response file. -9 Not a valid list type (string or number). -10 Data type is invalid. -11 Unknown error during setup. -12 Dialogs are out of order. -51 Cannot create the specified folder. -52 Cannot access the specified file or folder. -53 Invalid option selected.
-s | Setup wird Silent ausgeführt. Eine .iss Datei muss vorhanden sein
SMS | Behaltet eine Netzwerkverbindung und die Setup.exe Datei offen bis die Installation beendet ist.

DeInstallation:

IsUnist.exe oder IsUn16.exe [-y] [-x] [-f] [-c] [-a] [-d]

Parameter | Beschreibung
-y | Unterdrücke die MessageBox ob der Benutzer die Deinstallation durchführen möchte
-x | Löscht alle Dateien, auch diejenigen welche normalerweise nicht gelöscht werden (nicht in Silent mode)
-f[log Datei] | Gibt die Uninstall Log Datei an. -f"c:\program files\company name\deisl1.isu"
-c[DLL Dateiname] | Gibt den Namen einer Dll an welche während der Deinstallation verwendet wird.
-a | Wird bei Silent verwendet um die Abfrage bei Gemeinsamen Dateien zu unterdrücken
-d[Dateiname] | Löscht eine einzelne Datei. -d"c:\temp\dateiname.xyz"


VISE® Parameter

Installation:

Setup.exe [/t] [/s] [/r]

Parameter | Beschreibung
/t:[Pfad] | Installationsverzeichnis
/s | Silent Setup
/r | Setup aufzeichnen

DeInstallation:

UnVISE32.exe [/s]

Parameter | Beschreibung
/s | Silent Deinstallation


MSI Parameter

MSIEXEC.EXE [/i] [/f] [/a] [/x] [/j] [/l] [/p] [/q] [/y] [/z]

Parameter | Beschreibung
/i [Paket] | Parameter für eine Installation (alternativen sind Entfernen, ReInstallieren oder Reparieren)
/f [p,o,e,d,c,a,u,m,s,v] | ReInstallieren p = wenn eine Datei fehlt o = wenn eine Datei fehlt oder wenn eine Datei veraltet ist e = wenn eine Datei fehlt oder wenn eine Datei das gleiche Datum hat oder veraltet ist d = wenn eine Datei fehlt oder wenn eine Datei mit einer anderen Version vorhanden ist c = wenn eine Datei fehlt oder wenn die Checksumme falsch ist a = alle Dateien werden neu installiert u = Benutzerspezifische Registrierungsschlüssel werden neu geschrieben m = Computerspezifische Registrierungsschlüssel werden neu geschrieben s = Überschreibt alle Verknüpfungen v = Startet von einer Quelldatei und Cached das lokale Produkt neu
/a [Paket] | Adimistration mode; Installiert das Produkt auf dem Netzwerk
/x [Paket] | Deinstalliert das Produkt
/j [u,m] [Paket] | Zeigt das Produkt u = Aktueller Benutzer m = Alle Benutzer
/l [i,w,e,a,r,u,c,m,p,v,+,!,*] [log Datei] | Parameter um den Pfad für die Protokolldatei anzugeben (im Beispiel, "c:\temp\install.log"). i = Statusmeldungen w = Nichtfatale Warnungen e = alle Fehlermeldungen a = ausführen von Aktionen r = Aktionsspezifische Datensätze u = Benutzereingaben c = Initial Benutzerinterface (UI) Parameter m = Zuwenig Speicher p = Terminal Parameter v = Ausführiche Ausgabe + = Fügt die Ausgaben zu einer Bestehenden Datei hinzu ! = Löscht jeweils die Zeile im Log * = Wildcard. Protokolliert alles (ausser den v-Parameter). Inkl. v: /L*v
/p [patch] | Liest einen Patch ein. Um ein installiertes Administrator Image zu patchen sollte auch der /a Switch verwendet werden.
/q [n,b,r,f] | Parameter um die Installation ohne Dialoge durchzuführen. n = Kein UI b = Nur Basis UI r = Reduziertes UI f = Komplettes UI
/y | Ruft das System API "DLLRegisterServer" auf und Registriert das Modul
/z | Ruft das System API "DLLRegisterServer" auf und UnRegistriert das Modul
ALLUSERS=1 | Setzt die Verknüpfung im "all users" anstatt nur im lokalen Benutzerprofil.


Windows® Service Pack

W2kspX.exe [-u] [-f] [-n] [-o] [-z] [-q] [-s] [-x]

Parameter | Beschreibung
-u | Unbeaufsichtigtes Setup
-f | Beende alle offenen Programme beim Neustart
-n | Keine Sicherung der Dateien (Uninstall ist danach nicht mehr möglich)
-o | Überschreibe OEM Dateien ohne zu fragen
-z | Starte den Computer nicht neu nach dem Setup
-q | Quiet Mode, keine Benutzereingaben
-s:[Pfad] | Benutze integrierten Installationsmodus - auf einen Distriburionserver
-x | Extrahiere die enthaltenen Dateien


Häufig gestellte Fragen

Wieso wird auf jeder Arbeitsstation ein Dienst installiert?

remoteIC benötigt diesen Dienst um Arbeiten auf der Arbeitsstation zu erledigen welche nicht vom Server durchgeführt werden können. Vorallem die Softwareinstallation muss lokal durchgeführt werden.

Wieso benötigt remoteIC eine Datenbank?

Die Datenbank ist eine zentrale Komponente von remoteIC. Alle Informationen werden in dieser Datenbank gespeichert. Auch wenn ein Computer ausgeschaltet ist, können trotzdem Informationen zu diesem Computer abgefragt werden, da die Infos in der Datenbank gespeichert sind. Zudem sind so alle Informationen immer aktuell und müssen nicht wie bei einer Dateilösung über das Netzwerk repliziert werden.

Weitere Fragen

Weitere Fragen und Antworten finden Sie in unserem Support-Forum


Problembehandlung

Beim ersten Start von remoteIC erscheint der Datenbank Assistent. Ich habe alle Felder korrekt ausgefüllt und trotzdem erhalte ich immer die Meldung, dass der SQL Server nicht gefunden worden ist.

Der SQL Server muss vorgängig installiert worden sein. Wenn Sie in Ihrem Unternehmen keinen SQL Server im Einsatz haben, können Sie den SQL Server entweder bei Ihrem Softwarelieferanten bestellen oder Sie installieren die kompakte MSDE Version des SQL Servers von der remoteIC-CD.
Wir empfehlen eine Vollversion des SQL Servers einzusetzen, da die Performance bei der Vollversion wesentlich besser ist.

Der SQL Server ist korrekt installiert, trotzdem erhalte ich die Meldung, dass die Datenbank nicht erstellt werden konnte.

remoteIC versucht den Datenbankbenutzer anzulegen. Wenn der Benutzer schon vorhanden ist, kann es zu der genannten Meldung kommen. Die Datenbank ist aber in diesem Fall bereits erstellt worden. Versuchen Sie "Use existing database".

Der Controlserver-Assistent meldet, dass die Policy nicht gesetzt werden konnte.

Wählen Sie Ignorieren und setzen Sie das Policy-Flag "Logon as a Service" für den angegebenden Benutzer auf dem Controlserver manuell.

Der Controlserver-Assistent meldet, dass der Service nicht installiert werden konnte.

In seltenen Fällen kommt es vor, dass der Controlserverassistent den remoteIC-Service nicht installieren kann. Sie können den Service auch manuell installieren. Siehe Hilfsprogramm remoteIC.exe