Outil de diagnostic DirectX

La documentation de l'outil de diagnostic Microsoft DirectX contient les rubriques suivantes :

  • Présentation de l'outil de diagnostic DirectX
  • Utilisation de l'outil de diagnostic DirectX pour diagnostiquer les problèmes
  • Test des composants DirectX
  • Remplacement du comportement par défaut
  • Enregistrement d'informations
  • Vérification des signatures numériques WHQL


Présentation de l'outil de diagnostic DirectX

L'outil de diagnostic Microsoft DirectX fournit des informations concernant les composants API (application programming interface) de DirectX et les pilotes installés sur votre système. Il vous permet de tester la sortie de son et de graphiques ainsi que les fournisseurs de services Microsoft DirectPlay. Il vous permet également de désactiver certaines fonctionnalités d'accélération de matériel.

Vous pouvez utiliser cet outil de diagnostic pour recueillir les informations utiles à un technicien lors d'un appel au support technique. Vous pouvez enregistrer les informations collectées par l'outil et les coller dans un message électronique.

Les informations sont présentées sur plusieurs pages. Vous pouvez vous déplacer page par page :

  • En cliquant sur les onglets.
  • En cliquant sur Page suivante.
  • En appuyant sur les touches GAUCHE ou DROITE lorsque le focus se trouve sur un onglet.

Certaines pages de l'outil de diagnostic, telles que Fichiers DirectX, Musique ou Entrée, affichent les informations sous forme de tableau. Vous pouvez trier ces informations pour retrouver plus facilement celles dont vous avez besoin.

Pour trier les informations dans un tableau

  1. Identifiez la colonne contenant les informations que vous souhaitez utiliser pour trier le tableau.
  2. Cliquez sur le bouton d'en-tête en haut de la colonne.

    Le tableau est trié par ordre alphabétique ou numérique en fonction des éléments de la colonne. Pour inverser l'ordre de tri (Z à A, au lieu de A à Z, par exemple), cliquez de nouveau sur le bouton d'en-tête.

* Remarques

  • Certaines informations, telles que la quantité de mémoire d'une carte d'affichage, peuvent être des estimations.
  • Pour en savoir plus sur les informations recueillies par l'outil de diagnostic DirectX, cliquez sur Rubriques connexes.

Rubriques connexes

Test des composants DirectX

Enregistrement d'informations


Utilisation de l'outil de diagnostic DirectX pour diagnostiquer les problèmes

Si vous rencontrez des problèmes lors de l'exécution d'applications Microsoft DirectX, l'outil de diagnostic DirectX peut vous aider à rechercher la source du problème. Voici certains éléments que vous devez rechercher :

  • Versions incorrectes de composants DirectX. Dans la section Notes de la page Fichiers DirectX, recherchez les avertissements concernant les fichiers bêta et de débogage. Les fichiers bêta proviennent d'anciennes versions de test et ne doivent pas être installés avec des programmes commerciaux. Les versions de débogage, utilisées dans le développement des programmes, ne doivent pas être installées avec le produit final. Les versions de débogage des composants peuvent provoquer une exécution des programmes plus beaucoup lente qu'avec les versions commerciales.
  • Accélération de matériel insuffisante. Certains programmes s'exécutent très lentement ou pas du tout, à moins que l'accélération de matériel Microsoft DirectDraw ou Direct3D ne soit disponible. Sur la page Affichage, sous Fonctionnalités DirectX, recherchez si l'accélération DirectDraw, Direct3D ou AGP Texture est indiquée comme étant « Non disponible ». Dans ce cas, vous devez songer à mettre votre matériel à niveau. Si vous utilisez un produit de la famille Windows Server 2003, il se peut que vous deviez activer l'accélération graphique. Pour ce faire, ouvrez Affichage dans le Panneau de configuration, sélectionnez l'onglet Paramètres, puis cliquez sur Avancé. Sélectionnez l'onglet Dépannage, puis déplacez le curseur Accélération matérielle sur Complète.
  • Périphérique non connecté. Si un joystick ou un autre périphérique d'entrée ne répond pas, il n'est peut-être pas correctement configuré. Vérifiez que le périphérique est pris en compte dans la page Entrée de l'outil de diagnostic DirectX. Si tel n'est pas le cas, ajoutez-le via le Panneau de configuration.
  • Pilotes non signés. Microsoft n'a pas testé la compatibilité des pilotes non signés avec la dernière version de DirectX. Nous vous recommandons d'utiliser des pilotes signés numériquement par Microsoft WHQL (Windows Hardware Quality Labs).

* Remarque

  • Si vous utilisez les services Terminal Server afin de travailler sur un système distant qui prend en charge l'accélération matérielle, l'outil de diagnostic DirectX peut indiquer une prise en charge de l'accélération matérielle. Cependant, les services Terminal Server ne pouvant pas utiliser l'accélération matérielle, la prise en charge n'est pas disponible.

Rubriques connexes

Enregistrement d'informations

Vérification des signatures numériques WHQL


Test des composants DirectX

Vous pouvez tester Microsoft DirectDraw et Direct3D sur chaque moniteur relié à votre système. Vous pouvez également tester DirectSound sur chaque périphérique de sortie de son et DirectMusic sur chaque port musical.

Pour tester une fonctionnalité DirectX

  1. Cliquez sur le bouton Test à la page correspondante.
  2. Lisez les messages affichés.
  3. Observez ou écoutez les tests.
  4. Laissez chaque test se poursuivre jusqu'à ce qu'un message apparaisse, vous demandant si le test a réussi. Si vous répondez Non, aucun autre test n'est exécuté.

Dans le cas de DirectMusic, il n'y a qu'un seul test. Cliquez sur OK lorsque vous être satisfait de la lecture de la musique.

Vous pouvez tester la fonctionnalité Microsoft DirectPlay sur n'importe quel fournisseur de services disponible.

Pour tester DirectPlay

  1. Sur la page Réseau, cliquez sur Tester DirectPlay.
  2. Dans la boîte de dialogue Test DirectPlay, tapez un nom d'utilisateur et choisissez un fournisseur de services.
  3. Sélectionnez Créer une nouvelle session et cliquez sur OK.
  4. Si vous avez choisi une connexion modem, cliquez sur Répondre dans la boîte de dialogue Connexion modem afin que le modem soit en mode de réponse automatique.

Exécutez ensuite l'outil de diagnostic Microsoft DirectX sur un autre ordinateur qui peut établir la connexion sélectionnée avec le premier ordinateur.

  1. Cliquez sur Tester DirectPlay.
  2. Tapez un autre nom d'utilisateur.
  3. Choisissez le même fournisseur de services.
  4. Cliquez sur le bouton Se joindre à une session existante et cliquez sur OK.

    Pour certains types de connexions, il est possible que vous deviez fournir davantage d'informations, telles qu'un numéro de téléphone. Pour une connexion TCP/IP sur un réseau local, vous pouvez ne rien inscrire dans la zone de texte.

  5. Dans la Liste de sessions contenant le nom de la session que vous avez créée sur le premier ordinateur, sélectionnez le nom de la session.
  6. Les deux ordinateurs doivent maintenant afficher une boîte de dialogue de discussion. Tapez un message dans la zone d'entrée d'un ordinateur, puis cliquez sur Envoyer. Le message doit apparaître dans la zone de défilement de la boîte de dialogue de discussion sur les deux ordinateurs.


Remplacement du comportement par défaut

À partir de la page Audio, vous pouvez définir un niveau d'accélération matérielle différent en déplaçant le curseur. Vous devez être un administrateur de système pour modifier les niveaux d'accélération matérielle. Ce niveau reste effectif après la fermeture de l'outil de diagnostic Microsoft DirectX.

Vous pouvez désactiver l'accélération matérielle pour Microsoft DirectDraw ou Direct3D, si elle est disponible. Pour cela, ouvrez la page Affichage pour chaque périphérique d'affichage, puis cliquez sur Désactiver. Une fois l'accélération matérielle désactivée, elle n'est disponible pour aucune application, même après la fermeture de l'outil de diagnostic DirectX. Pour activer à nouveau l'accélération matérielle, cliquez sur Activer sur la page Affichage appropriée.

* Remarque

  • La désactivation de l'accélération DirectDraw désactive également l'accélération pour Direct3D.

Vous pouvez également remplacer le taux de rafraîchissement du moniteur défini par les applications plein-écran DirectDraw. Vous devez effectuer cela uniquement si vous rencontrez des problèmes d'affichage avec une application et possédez une raison valable de croire que l'application possède un paramètre de taux de rafraîchissement non valide.

Pour définir un taux de rafraîchissement de remplacement

  1. Sur la page Aide supplémentaire, cliquez sur Remplacer.
  2. Dans la boîte de dialogue Remplacer la fréquence de rafraîchissement par défaut de DirectDraw, sélectionnez Remplacer par la valeur et entrez un taux de rafraîchissement valide pour votre moniteur.
  3. Cliquez sur OK.

Pour annuler le taux de rafraîchissement de remplacement et permettre aux applications DirectDraw de définir leur propre taux de rafraîchissement

  1. Sur la page Aide supplémentaire, cliquez sur Remplacer.
  2. Dans la boîte de dialogue Remplacer la fréquence de rafraîchissement par défaut de DirectDraw, cliquez sur Par défaut.


Enregistrement d'informations

Pour enregistrer des informations

  1. Pour enregistrer les informations recueillies par l'outil de diagnostic Microsoft DirectX, cliquez sur Enregistrer toutes les informations.
  2. Les informations de toutes les pages sont enregistrées dans un fichier, dont vous choisissez le nom et l'emplacement. Pour un enregistrement dans un fichier XML, dans Type, cliquez sur Fichier XML (*.XML).

* Remarque

  • Vous pouvez également enregistrer les informations en tapant ce qui suit dans une invite de commandes :

    dxdiag [/x fichiersortie] [/t fichiersortie]

    Dans cette commande, /x envoie les données vers un fichier XML, /t envoie les données vers un fichier texte et fichiersortie spécifie le nom et l'emplacement du fichier.


Vérification des signatures numériques WHQL

Lorsque vous vérifiez que vos pilotes sont numériquement signés par Microsoft WHQL (Windows Hardware Quality Labs), l'outil de diagnostic DirectX peut tenter de se connecter à Internet afin de télécharger les nouveaux certificats WHQL. Pendant cette opération, aucune information n'est récupérée à partir de votre système. L'outil vous demandera l'autorisation de se connecter à Internet la première fois que vous l'exécuterez. Cette demande n'aura lieu qu'une fois. Pour modifier votre réponse, ouvrez la page Système et activez ou désactivez l'option Rechercher les signatures numériques WHQL.

Vous pouvez également effectuer cette modification en tapant ce qui suit dans une invite de commandes :

dxdiag [/whql:on] [/whql:off]

Dans cette commande, /whql:on permet à l'outil de diagnostic DirectX de rechercher les signatures numériques WHQL et /whql:off interdit à l'outil de diagnostic DirectX de rechercher les signatures numériques WHQL.