DIE MÖGLICHKEITEN VON MATHCAD

Mit Mathcad können Sie jede denkbare mathematische Aufgabenstellung lösen. Die Rechenfähigkeiten von Mathcad reichen vom Aufaddieren einer Zahlenspalte über die Berechnung von Integralen und Ableitungen bis hin zur Lösung von Gleichungssystemen etc.

Sie können Gleichungen, Text und Grafiken an jeder beliebigen Stelle des Mathcad-Arbeitsblatts plazieren. Auf diese Weise behalten Sie auch bei komplexen Berechnungen stets den Überblick, zumal Sie Ihre Daten auch mit Hilfe von zwei- oder dreidimensionalen Diagrammen darstellen lassen können.

Nachdem Sie ein präsentationsreifes Dokument erstellt haben, können Sie auch andere an Ihrer Arbeit teilhaben lassen, indem Sie das Arbeitsblatt ausdrucken, wobei es im Ausdruck genauso aussieht, wie auf dem Bildschirm, es per E-Mail versenden, oder Ihr Arbeitsblatt im World Wide Web plazieren.


DER MATHCAD-DESKTOP

Wenn Sie Mathcad starten, sehen Sie auf dem Bildschirm folgendes:

ein unbenanntes Mathcad-Arbeitsblatt

das Fenster Informationszentrum

die Menüleiste

die Rechensymbolleiste

die Standardsymbolleiste

die Formatierungssymbolleiste

Um mehr Platz für die Anzeige des Arbeitsblatts zu erhalten, können Sie mit den Befehlen des Menüs Ansicht nicht benötigte Elemente ausblenden bzw. die benötigten Elemente wieder einblenden. Außerdem haben Sie die Möglichkeit, diese Elemente innerhalb des Fensters an jeden beliebigen Platz zu verschieben. Wenn Sie Mathcad beenden und erneut öffnen, befinden sich die Elemente dort, wo sie sich vor dem Beenden des Programms befanden.


DAS MATHCAD-ARBEITSBLATT

Mathcad-Arbeitsblätter bestehen aus einer Sammlung von Gleichungen, Text, Grafiken und anderen Elementen. Jede Gleichung, Textstelle, Grafik und jedes andere Element, das Sie in das Arbeitsblatt aufnehmen, wird als "Bereich" bezeichnet. Mathcad erstellt für jeden Bereich ein unsichtbares Rechteck, das seine Grenzen definiert. Sie können die Bereiche sichtbar machen, indem Sie Bereiche im Menü Ansicht wählen.

Zum Erstellen eines neuen Bereichs gehen Sie folgendermaßen vor:

  1. Klicken Sie auf eine leere Stelle. Es wird ein kleiner Fadenkreuz-Cursor angezeigt, wenn Sie die Maustaste drücken.

  2. Geben Sie dann eine Gleichung oder Text ein, erstellen Sie ein Diagramm usw.

Beim Einfügen mehrerer Gleichungen, Textstellen und Grafiken in ein Arbeitsblatt können Sie sie nach Belieben anordnen und formatieren. Sie können außerdem bestimmte Bereiche sperren, so daß sie nicht mehr bearbeitet werden können, oder Bereiche hervorheben, so daß sie sich vom restlichen Arbeitsblatt absetzen.


AUSWERTEN VON AUSDRÜCKEN

Mathcad kann nicht nur für komplizierte mathematische Berechnungen eingesetzt werden, sondern auch als einfacher Rechner gute Dienste leisten. Mit den folgenden Schritten können Sie eine einfache numerische Berechnung durchführen:

Klicken Sie auf eine beliebige Stelle im Mathcad-Arbeitsblatt, und geben Sie den auszuwertenden Ausdruck ein.

Drücken Sie "=".

Stellen Sie sicher, daß keine der Variablen im Ausdruck links neben dem Gleichheitszeichen rot hervorgehoben sind.


DEFINIEREN VON VARIABLEN

Bevor Sie einen Ausdruck evaluieren können, der statt einer Konstante eine Variable enthält, müssen Sie die Variable definieren. Gehen Sie hierzu folgendermaßen vor:

Geben Sie den Variablennamen ein.

Geben Sie ":" ein, um das Definitionssymbol ":=" und einen Platzhalter anzuzeigen.

Geben Sie eine Zahl, einen Ausdruck oder eine Zeichenfolge in den Platzhalter ein.

Wenn Sie einen Ausdruck im Platzhalter eingeben, müssen Sie darauf achten, daß Variablen oder Funktionen in diesem Ausdruck keine rot hervorgehobenen undefinierten Variablen sind.


DEFINIEREN VON FUNKTIONEN

Eine Funktion ist eine Regel, die ihre Argumente bestimmten Operationen unterzieht und als Ergebnis einen numerischen Wert zurückgibt. Zum Definieren einer Funktion gehen Sie wie folgt vor:

Geben Sie den Funktionsnamen gefolgt von einer linken Klammer ein.

Geben Sie eine Liste von durch Kommas getrennten Argumenten gefolgt von einer rechten Klammer ein.

Geben Sie ":" ein, um das Definitionssymbol ":=" und einen Platzhalter anzuzeigen.

Geben Sie einen Ausdruck oder eine Zeichenfolge im Platzhalter ein.

Achten Sie darauf, daß alle Variablen, die Sie im rechten Ausdruck verwenden, entweder

  • vorher definiert oder

  • Teil der Argumentliste sind.

Wenn eine Variable im Ausdruck auf der rechten Seite diese Bedingungen nicht erfüllt, wird sie als undefinierte Variable rot dargestellt.

Wenn Sie eine Funktion definiert haben, versucht Mathcad, diese erst dann auszuwerten, wenn Sie sie zu einem späteren Zeitpunkt auf dem Arbeitsblatt verwenden.


Berechnen von Ausdrücken mit Bereichsvariablen

WIEDERHOLTES BEWERTEN VON AUSDRÜCKEN

Verwenden Sie Bereichsvariablen, um einen Ausdruck wiederholt über einen Variablenbereich auszuwerten (siehe unten). Mathcad wertet den Ausdruck genau einmal für jeden Wert der Bereichsvariable aus.

Wenn Sie in einer Gleichung mehrere Bereichsvariablen verwenden, berechnet Mathcad die Gleichung einmal für jede Bereichsvariable. Dies ist bei der Definition von Matrizen von Vorteil:


Einfügen von Text

ERSTELLEN EINES TEXTBEREICHS

Zum Erstellen eines Textbereichs gehen Sie wie folgt vor:

  1. Klicken Sie auf die Stelle, an der der Bereich erscheinen soll.

  2. Wählen Sie den Befehl Textbereich im Menü Einfügen. Es erscheint ein Textfeld.

  3. Beginnen Sie mit der Eingabe des Textes. Die Größe des Textfelds paßt sich automatisch der Eingabe an. Wenn Sie außerhalb des Textbereichs klicken, verschwindet das Textfeld. Die Formatierung des Textes richtet sich nach der Textformatvorlage "Normal".

Wenn Sie die Eingabe von Text beenden wollen, müssen Sie auf eine Stelle außerhalb des Textbereichs klicken. Drücken Sie nicht die Eingabetaste, da sonst eine neue Zeile im aktiven Textbereich erstellt wird.

Tip:

Eine andere Möglichkeit, einen Textbereich zu erstellen, besteht darin, von Mathcad automatisch einen Textbereich erstellen zu lassen. Klicken Sie dazu einfach an der gewünschten Position des Textes, und beginnen Sie mit der Eingabe. Zunächst wird alles, was Sie eingeben, als Rechenbereich betrachtet. Sobald Sie aber die Leertaste drücken, wird aus dem Rechenbereich automatisch ein Textbereich.


ERSTELLEN EINES X-Y-DIAGRAMMS

Zum Erstellen eines X-Y-Diagramms gehen Sie folgendermaßen vor:

  1. Wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen, um einen Diagrammbereich zu erstellen.

  2. Geben Sie im mittleren Platzhalter unter der x-Achse (horizontale Achse) die Variable ein, für die das Diagramm erstellt werden soll. Diese Variable ist normalerweise eine vorher definierte Bereichsvariable. Wenn diese Variable nicht bereits definiert wurde, erstellt Mathcad das Diagramm mit den Werten -10 bis 10. Dies wird als Quickplot bezeichnet.

  3. Geben Sie im mittleren Platzhalter neben der y-Achse (vertikale Achse) den abzubildenden Ausdruck ein.

Mathcad zeichnet für alle Werte der x-Achsenvariable Punkte und verbindet sie mit geraden Linien, wenn Sie nichts anderes festlegen.

Beispiel:

Hinweise:

  • Sie können beliebige Ausdrücke gegen andere Ausdrücke abbilden, wenn ihre unabhängigen Variablen gleich sind. Sie können auch mehrere Kurven in einem Diagramm abbilden.

  • Komplexe oder imaginäre Punkte werden von Mathcad nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", von denen die reellen oder imaginären Teile herausgearbeitet werden.

  • Wenn Ihnen die Darstellung eines Diagramms zu abrupt erscheint, können Sie für die Bereichsvariable, die beim Erstellen des Diagramms verwendet wird, kürzere Schritte verwenden.


GRAFISCHE DARSTELLUNG EINES MATHEMATISCHEN AUSDRUCKS

Zum grafischen Darstellen eines mathematischen Ausdrucks gehen Sie folgendermaßen vor:

Definieren Sie eine Bereichsvariable für den Wertebereich, über dem der mathematische Ausdruck abgebildet werden soll.

Wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen, um den X-Y-Diagrammoperator einzufügen.

Klicken Sie auf den Platzhalter auf der x-Achse.

Geben Sie die Bereichsvariable ein.

Klicken Sie auf den mittleren Platzhalter auf der y-Achse.

Geben Sie den mathematischen Ausdruck ein.

Klicken Sie auf eine Stelle außerhalb des Diagramms.

Mathcad bildet für jeden Wert der Bereichsvariable einen Punkt ab und verbindet sie mit geraden Linien, wenn Sie nichts anderes festlegen.

Hinweise:

  • Wenn Mathcad Werte für die Abbildung zuweisen soll, müssen Sie keine Bereichsvariable definieren. Geben Sie einfach den undefinierten Variablennamen im x-Achsen-Platzhalter ein. Mathcad verwendet -10 bis 10 als Standardbereich für das Diagramm. Wenn Sie Mathcad den Standardbereich wählen lassen, erstellen Sie ein Quickplot.

  • Sie können jeden Ausdruck im Vergleich zu einem anderen Ausdruck abbilden, solange ihre Bereichsvariablen gleich sind. Sie können auch ein Diagramm mit mehreren Kurven erstellen.


Ändern der Größe von Grafikbereichen

ÄNDERN DER GRÖSSE VON GRAFIKBEREICHEN

Zum Ändern der Länge und der Breite eines Grafikbereichs gehen Sie wie folgt vor:

  1. Klicken Sie in den Grafikbereich. Daraufhin wird der Bereich von einem Markierungsrechteck mit drei Haltepunkten umgeben.

  2. Setzen Sie den Zeiger auf einen der Haltepunkte am unteren oder rechten Rand des Bereichs. Er wird zu einem Doppelpfeil.

  3. Verschieben Sie die Maus bei gedrückter Maustaste. Der Grafikbereich wird in Richtung der Mausbewegung erweitert.

  4. Lassen Sie die Maustaste los, wenn der Grafikbereich die gewünschte Größe hat.


DRUCKEN EINES ARBEITSBLATTS

Zum Drucken des gegenwärtig aktiven Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Drucken aus dem Menü Datei. Daraufhin öffnet sich das Dialogfeld "Drucken".

  2. Klicken Sie auf "OK".

Wenn Sie sich vor dem Drucken ansehen wollen, wie Ihr Arbeitsblatt gedruckt aussehen wird, wählen Sie den Befehl Seitenansicht aus dem Menü Datei.


SPEICHERN EINES ARBEITSBLATTS

Zum Speichern eines Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Speichern im Menü Datei. Hierdurch wird die alte Kopie des Arbeitsblatts ersetzt.

Zum Speichern des Arbeitsblatts, ohne die alte Kopie zu ersetzen, gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Speichern unter im Menü Datei.

  2. Speichern Sie das Arbeitsblatt unter einem anderen Namen.

Mit dem Befehl Speichern unter und der Dropdown-Liste "Dateityp" können Sie ein Arbeitsblatt auch als RTF-Datei , als HTML-Datei oder als Arbeitsblatt, das kompatibel mit einer vorherigen Version ist, speichern.


EINGEBEN VON GLEICHUNGEN

Zum Erstellen mathematischer Ausdrücke in Mathcad müssen Sie lediglich den Fadenkreuz-Cursor in das Arbeitsblatt setzen und mit der Eingabe von Buchstaben, Ziffern oder Operatoren wie + oder - beginnen.

  • Wenn Sie Buchstaben oder Zahlen eingeben, werden sie zwischen Bearbeitungslinien angezeigt, die darauf hinweisen, welche Zeichen ausgewählt sind. Mit der Leertaste und den Pfeiltasten können Sie verschiedene Teile eines Ausdrucks auswählen.

  • Sie können Operatoren einfügen, indem Sie auf die entsprechende Schaltfläche in den Operator-Symbolleisten klicken oder die Tastenkombination für den Operator drücken.

Mit den folgenden Schritten erstellen Sie den Ausdruck [image] und lassen anzeigen, wie Zahlen, Bearbeitungslinien und Operatoren zusammenarbeiten:

  1. Geben Sie a ein.

  2. Geben Sie [Umschalt] + 6 ein, den Tastaturbefehl für Exponentialoperatoren.

  3. Geben Sie 2 im angezeigten Platzhalter ein.

  4. Drücken Sie + auf der Tastatur für den Additionsoperator, und geben Sie b im Platzhalter ein.

  5. Drücken Sie zweimal die Leertaste, damit der gesamte Ausdruck zwischen die Bearbeitungslinien gesetzt wird.

  6. Drücken Sie + auf der Tastatur, und geben Sie y im Platzhalter ein.

Mathcad setzt automatisch die verschiedenen Teile eines Ausdrucks entsprechend der geltenden Rangfolge und verschiedener weiterer Regeln zusammen, durch die die Eingabe von Nennern, Exponenten und Ausdrücken in Wurzeln vereinfacht wird. Zum Beispiel setzt Mathcad Ihre Eingaben neben die in den Bearbeitungslinien eingeschlossenen Zeichen.


EINGEBEN VON VARIABLEN- UND FUNKTIONSNAMEN

Variablen- und Funktionsnamen können beliebig lang sein und viele unterschiedliche Zeichen enthalten. Es gibt jedoch einige Beschränkungen.

In Variablen- und Funktionsnamen zugelassene Zeichen

Beschränkungen bei Variablen- und Funktionsnamen

Eingabe von Namen mit Operatoren

Eingabe von Namen mit Symbolen


VORDEFINIERTE KONSTANTEN

Vordefinierte mathematische Konstanten

Konstante | Tastaturbefehl
 | Strg+Umschalt+z
e | e
 | Strg+Umschalt+p
i | 1i
j | 1j
% | %

Neudefinieren von mathematischen Konstanten...

Vordefinierte Systemkonstanten

Konstante | Standardwert
TOL | .001
CTOL | .001
ORIGIN | 0
PRNPRECISION | 4
PRNCOLWIDTH | 8
CWD | aktuelles Arbeitsverzeichnis, definiert in Form einer Zeichenfolge

Neudefinieren von Systemkonstanten...


Eingeben und Anzeigen von Zahlen

EINGEBEN VON ZAHLEN

Mathcad interpretiert alles, was mit einer Ziffer beginnt, als Zahl. Als generelle Regel gilt, daß Zahlen durch einfaches Drücken der entsprechenden Tasten auf der Tastatur eingegeben werden können. Dabei ist darauf zu achten, daß in Mathcad bei Dezimalbrüchen stets ein Punkt anstelle des im deutschen Sprachraum üblichen Kommas verwendet wird. Wenn Sie auf eines der folgenden Themen klicken, erfahren Sie, welche Sonderregeln es für das jeweilige Thema gibt:

Zahlen > 999

Exponentialschreibweise

Imaginäre Zahlen

Komplexe Zahlen

Zahlen mit anderen Basen


BEARBEITUNGSCURSOR

Der Bearbeitungscursor kann die drei unten gezeigten Formen haben. Wenn Sie auf das entsprechende Bild klicken, werden Angaben zur Funktion und zum Anzeigen des jeweiligen Cursors angezeigt.

Fadenkreuz

Texteinfügemarke

Bearbeitungslinien

Der Cursor entspricht nicht dem "Zeiger". Der Zeiger wird zum Plazieren des Cursors verwendet. Die Form, die der Cursor annimmt, hängt davon ab, worauf der Zeiger zeigt, wenn Sie mit der Maus klicken.


Ändern eines Namens oder einer Zahl

Hierfür gibt es zwei Verfahren. Wenn Sie nur einige Zeichen ändern müssen...

Klicken Sie auf den Namen oder die Zahl. Verschieben Sie mit der Pfeil-nach-links- oder Pfeil-nach-rechts-Taste die Einfügelinie, falls erforderlich.

Geben Sie Buchstaben und Zahlen ein. Mit der Rücktaste löschen Sie ein Zeichen direkt hinter der Einfügelinie

...oder wenn Sie ganz neu beginnen möchten:

Klicken Sie auf den Namen oder die Zahl. Drücken Sie bei Bedarf die Leertaste, um den Namen oder die Zahl vollständig zwischen den Bearbeitungslinien einzuschließen.

Wählen Sie Ausschneiden im Menü Bearbeiten. Dadurch wird der Name oder die Zahl gelöscht und statt dessen ein Platzhalter eingefügt.

Klicken Sie auf den Platzhalter, und geben Sie den neuen Namen oder die neue Zahl ein.


EINFÜGEN EINES OPERATORS

Beachten Sie beim Einfügen eines Operators, daß das Zeichen zwischen den Bearbeitungslinien zum ersten Operand des nächsten eingegebenen Operators wird. Gehen Sie beim Einfügen eines Operators daher wie folgt vor:

Setzen Sie das Zeichen zwischen die Bearbeitungslinien, das Sie als Operand verwenden möchten. Verlängern Sie ggf. die Bearbeitungslinien, indem Sie die Leertaste drücken.

Geben Sie den Tastaturbefehl für den Operator ein.

Sie fügen einen Operator vor dem ausgewählten Ausdruck ein, indem Sie vor seiner Eingabe die Einf-Taste drücken.


EINFÜGEN VON KLAMMERN

Es ist normalerweise viel einfacher, ein Paar von Klammern mit dem folgenden Verfahren einzufügen:

Setzen Sie den Ausdruck zwischen die Bearbeitungslinien.

Drücken Sie die Apostrophtaste ('), um Klammern einzufügen.

Dies ist weit bequemer als das Einfügen einzelner Klammern wie in Textverarbeitungsprogrammen.


LÖSCHEN VON KLAMMERN

Zum Löschen eines Paars von Klammern gehen Sie folgendermaßen vor:

Setzen Sie die Einfügemarke rechts neben die runde Klammer "(".

Drücken Sie die Rücktaste.

Es ist nicht möglich, nur eine Klammer zu löschen. Wenn Sie eine der beiden Klammern löschen, wird die andere automatisch ebenfalls gelöscht.


EINFÜGEN EINES MINUSZEICHENS

Beim unten beschriebenen Verfahren wird ein Minuszeichen als negatives Vorzeichen einer Zahl eingefügt.

Klicken Sie in den Ausdruck, und drücken Sie gegebenenfalls die Leertaste, so daß er zwischen die Bearbeitungslinien gesetzt wird.

Drücken Sie die EINFG-Taste, um den vertikalen Zweig an die linke Seite zu setzen.

Drücken Sie die Taste mit dem Minuszeichen.


LÖSCHEN EINES MINUSZEICHENS

Im nachfolgend beschriebenen Vorgang wird das Minuszeichen gelöscht, das ein negatives Vorzeichen einer Zahl ist.

Klicken Sie auf den Ausdruck, und drücken Sie gegebenenfalls die Leertaste, so daß er zwischen die Bearbeitungslinien gesetzt wird.

Drücken Sie die EINFG-Taste, um die Einfügelinie nach links zu verschieben.

Drücken Sie die Rücktaste.


ANWENDEN EINER FUNKTION AUF EINEN AUSDRUCK

Mit dem folgenden Verfahren können Sie einen Ausdruck zum Argument einer Funktion machen.

Klicken Sie in den Ausdruck, und drücken Sie die Leertaste, bis sich der gesamte Ausdruck zwischen den Bearbeitungslinien befindet.

Drücken Sie die Apostrophtaste ('), um den Ausdruck in runde Klammern zu setzen.

Drücken Sie die Leertaste, um die Klammern zwischen die Bearbeitungslinien zu setzen.

Drücken Sie die EINFG-Taste, um den vertikalen Zweig nach links zu verschieben.

Geben Sie den Funktionsnamen ein.


VERSCHIEBEN VON TEILEN EINES AUSDRUCKS

Mit dem folgenden Verfahren verschieben Sie einen Teil eines Ausdrucks entweder in einen leeren Platzhalter oder in einen leeren Bereich des Arbeitsblatts.

Setzen Sie den zu verschiebenden Ausdruck zwischen die Bearbeitungslinien.

Wählen Sie Ausschneiden oder Kopieren im Menü Bearbeiten.

Klicken Sie auf eine leere Stelle oder den Platzhalter, an der/dem Sie den ausgewählten Ausdruck einfügen möchten.

Wählen Sie Einfügen im Menü Bearbeiten, damit der Ausdruck eingefügt wird.


LÖSCHEN VON TEILEN EINES AUSDRUCKS

Mit dem folgenden Verfahren können Sie einen Teil eines Ausdrucks löschen und in die Zwischenablage stellen:

  1. Positionieren Sie den zu löschenden Ausdruck zwischen den Bearbeitungslinien.

  2. Wählen Sie Ausschneiden im Menü Bearbeiten. Dadurch wird ein leerer Platzhalter gesetzt.

Wenn der Ausdruck in der Zwischenablage nicht gewünscht wird, kann mit dem folgenden Verfahren ein Teil von ihm gelöscht werden:

  1. Halten Sie die Maustaste gedrückt, und ziehen Sie den Cursor über den zu löschenden Ausdruck. Er wird in der Umkehransicht hervorgehoben.

  2. Drücken Sie die Taste Entf. Dadurch wird ein leerer Platzhalter gesetzt.


SUCHEN UND ERSETZEN VON ZEICHEN

Zum Suchen nach Zeichen gehen Sie folgendermaßen vor:

  1. Wählen Sie Suchen aus dem Menü Bearbeiten. Das Dialogfeld "Suchen" wird eingeblendet.

  2. Geben Sie die gesuchten Zeichen im Textfeld "Suchen nach:" ein.

  3. Klicken Sie auf "Weitersuchen".

Zum Suchen und Ersetzen von Zeichen gehen Sie folgendermaßen vor:

  1. Wählen Sie Ersetzen aus dem Menü Bearbeiten. Das Dialogfeld "Ersetzen" wird eingeblendet.

  2. Geben Sie die gesuchten Zeichen im Textfeld "Suchen nach:" ein.

  3. Geben Sie im Textfeld "Ersetzen durch:" die Zeichen ein, die die gefundenen Zeichen ersetzen sollen.

  4. Klicken Sie auf "Weitersuchen".

  5. Danach stehen drei Möglichkeiten für Sie zur Auswahl:

  • Klicken Sie auf "Weitersuchen", wenn Sie die nächste Stelle mit dem gesuchten Element finden und markieren möchten.

  • Klicken Sie auf "Ersetzen", wenn Sie die das gefundene, markierte Element ersetzen und nach der nächsten Fundstelle suchen möchten.

  • Klicken Sie auf "Alle ersetzen", wenn Sie das Element durchgängig ersetzen möchten.


FESTLEGEN DER OPTIONEN FÜR DIE ANZEIGE ALLER ERGEBNISSE

Wenn Sie die standardmäßige Anzeige der numerischen Ergebnisse in einem Arbeitsblatt ändern möchten, müssen Sie das Standardformat für das Arbeitsblatt ändern. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle.

  2. Wählen Sie den Befehl Ergebnis aus dem Menü Format, damit das Dialogfeld Ergebnisformat geöffnet wird.

  3. Stellen Sie sicher, daß die Option "Als Standard einrichten" aktiviert ist.

  4. Nehmen Sie die erforderlichen Änderungen im Dialogfeld Ergebnisformat vor, und klicken Sie auf "OK".

Hinweise:

  • Wenn Sie vor der Wahl von Ergebnis aus dem Menü Format auf ein bestimmtes Ergebnis klicken, können Sie "Als Standard einrichten" aktivieren und dadurch das Ergebnisformat für alle Ergebnisse im Arbeitsblatt bestimmen.

  • Veränderungen des Standardergebnisformats wirken sich nur auf Arbeitsblätter aus, in denen die Änderungen vorgenommen wurden. Für andere zu diesem Zeitpunkt geöffneten Arbeitsblätter bleiben die Standardergebnisformate erhalten.


RECHENFORMATVORLAGEN

Jedem Namen bzw. jeder Zahl in einer Gleichung ist eine Rechenformat zugeordnet, und für jedes Schriftartattribut ist die Schriftart, der Schriftgrad und ein Format definiert. Sie können somit die Schriftartmerkmale vieler Namen gleichzeitig ändern. Klicken Sie auf eines der folgenden Themen, um Informationen zur Verwendung der Schriftarten in einem bestimmten Zusammenhang zu erhalten:

Ändern der Schriftart für alle Variablen

Ändern der Schriftart für alle Konstanten

Ändern der Schriftart einer bestimmten Variable

Einfügen griechischer Variablen


Hervorheben eines Bereichs

Gehen Sie folgendermaßen vor, wenn Sie eine Gleichung, einen Textbereich, ein Diagramm oder einen Bereich durch eine Änderung der Hintergrundfarbe deutlicher abheben möchten:

  1. Klicken Sie in den Bereich.

  2. Wählen Sie Eigenschaften im Menü Format.

  3. Klicken Sie auf die Registerkarte "Anzeige".

  4. Klicken Sie auf "Farbe auswählen", um eine andere Hintergrundfarbe als die Standardhintergrundfarbe festzulegen.

  5. Aktivieren Sie das Kontrollkästchen "Bereich hervorheben".

  6. Klicken Sie auf "OK".

Sie sehen einen Rahmen um den Bereich, der mit einer Farbe gefüllt ist, die so hell ist, daß die Gleichung weiterhin sichtbar ist. Auf die Gleichung selbst hat dies keinerlei Auswirkungen.

Zum Wiederherstellen des Hintergrunds gehen Sie folgendermaßen vor:

  1. Klicken Sie in den Bereich.

  2. Wählen Sie Eigenschaften im Menü Format.

  3. Klicken Sie auf die Registerkarte "Anzeige".

  4. Aktivieren Sie das Kontrollkästchen "Bereich hervorheben".


ANZEIGE NUMERISCHER ERGEBNISSE MIT VOLLER GENAUIGKEIT

Sämtliche Arithmetik wird unabhängig von der Anzeige der Zahl im Arbeitsblatt mit voller Genauigkeit ausgeführt. Sie können ein bestimmtes Ergebnis mit voller Genauigkeit entweder permanent, durch Ändern seines Formats oder vorübergehend ändern, wie folgt:

  1. Klicken Sie auf die Zahl, die mit voller Genauigkeit angezeigt werden soll.

  2. Drücken Sie Strg+Umschalt+N.

Die Zahl wird daraufhin mit voller Genauigkeit in der Meldungszeile der Statusleiste am unteren Fensterrand angezeigt.

Hinweis: Mit voller Genauigkeit können auf diese Weise nur Einzelwerte, jedoch keine Felder von Werten angezeigt werden. Soll die volle Genauigkeit eines errechneten Feldes angezeigt werden, müssen Sie seine Formateinstellungen ändern. Erhöhen Sie hierzu die angezeigte Genauigkeit im Dialogfeld "Ergebnisformat" auf 15.


TEXT, ÜBERBLICK

Textbereiche dienen dazu, Ihr Arbeitsblatt mit Kommentaren, Erläuterungen und Anmerkungen zu versehen. Textbereiche können an jeder beliebigen Stelle eines Arbeitsblatts eingefügt, bearbeitet und formatiert werden.

Textbereiche können wie andere Bereiche auch bearbeitet werden. Sie lassen sich kopieren, ausschneiden und löschen sowie beliebig im Arbeitsblatt verschieben.

Textbereiche unterstützen viele Textformatierungsfunktionen, die auch aus Textverarbeitungsprogrammen bekannt sind. Sie können die Formatierung der Zeichen in einem Textbereich ändern und die Rechtschreibung des Textes überprüfen lassen. Auch die Absätze innerhalb von Textbereichen können formatiert werden, indem Sie deren Ausrichtung und Einzug festlegen oder ihnen Aufzählungszeichen und Numerierungen zuweisen.

Textbereiche verfügen über bestimmte Eigenschaften, die das Verhalten und Aussehen dieser Bereiche festlegen. So können Sie z. B. die Breite eines Textbereichs bestimmen. Sie können aber auch festlegen, ob die benachbarten Bereiche verschoben werden, wenn ein Textbereich bei der Eingabe von Text größer wird.

Text erstellen und bearbeiten: Textbereiche einfügen, ausschneiden, kopieren, aus der Zwischenablage einfügen usw.

Text formatieren: Schriftarten ändern, Aufzählungszeichen, Numerierungen, Ausrichtung, Einzüge hinzufügen

Attribute von Textbereichen festlegen: Breite steuern, Interaktion mit anderen Bereichen festlegen


BEARBEITEN VON TEXT

Zum Kopieren bzw. Ausschneiden von Text gehen Sie wie folgt vor:

  1. Markieren Sie den Text.

  2. Wählen Sie Kopieren bzw. Ausschneiden im Menü Bearbeiten. Der Text wird in die Zwischenablage übernommen.

Zum Einfügen von Text gehen Sie wie folgt vor:

  1. Klicken Sie in den Textbereich, in den der Text eingefügt werden soll.

  2. Verschieben Sie die Einfügemarke an die Stelle, an der der Text eingefügt werden soll.

  3. Wählen Sie Einfügen im Menü Bearbeiten. Der Text wird eingefügt.

Zum Löschen von Text aus einem bestehenden Textbereich klicken Sie in den Bereich, und gehen Sie dann folgendermaßen vor:

  • Drücken Sie die Rücktaste, um das Zeichen links neben der Einfügemarke zu löschen.

  • Drücken Sie die Taste Entf, um das Zeichen rechts neben der Einfügemarke zu löschen.

Zum Überschreiben von Text gehen Sie folgendermaßen vor:

  1. Plazieren Sie die Einfügemarke links neben dem ersten Zeichen, das Sie überschreiben wollen.

  2. Drücken Sie die Taste Einfg, und beginnen Sie mit der Eingabe. Die Einfügemarke ist jetzt in der Mitte unterbrochen, um anzuzeigen, daß Sie sich im Überschreibmodus befinden. Sie kehren zum standardmäßigen Einfügemodus zurück, indem Sie abermals die Taste Einfg drücken.


IMPORTIEREN VON TEXT

Zum Einfügen von Text aus einer anderen Anwendung in Ihr Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Kopieren Sie den gewünschten Text aus der anderen Anwendung in die Zwischenablage.

  2. Klicken Sie in das Arbeitsblatt, und wählen Sie den Befehl Einfügen im Menü Bearbeiten.


VERSCHIEBEN VON TEXT

Zum Verschieben eines Textbereichs gehen Sie folgendermaßen vor:

  1. Markieren Sie den Textbereich.

  2. Gehen Sie mit dem Mauszeiger auf einen der Ränder des Auswahlrechtecks. Der Mauszeiger wechselt seine Form von einem Pfeil zu einer kleinen Hand.

  3. Ziehen Sie die Maus. Der ausgewählte Text bewegt sich mit dem Mauszeiger mit.

Zum Ausschneiden und Einfügen eines Textbereichs gehen Sie folgendermaßen vor:

  1. Markieren Sie den Textbereich.

  2. Wählen Sie den Befehl Ausschneiden im Menü Bearbeiten, um den Textbereich in die Zwischenablage einzufügen.

  3. Klicken Sie mit der Maus auf die Stelle, an der der Textbereich eingefügt werden soll, und wählen Sie den Befehl Einfügen aus dem Menü Bearbeiten.


EINFÜGEN VON RECHENBEREICHEN IN TEXTBEREICHE

Sie können einen Rechenbereich in einen Textbereich einfügen. Solcherart eingefügte Rechenbereiche sind weiterhin "aktiv", verhalten sich also so, als wären sie außerhalb des Textes. Zum Einfügen eines Rechenbereichs in einen Textbereich gehen Sie folgendermaßen vor:

  1. Klicken Sie in den Textbereich, in dem der Rechenbereich positioniert werden soll.

  2. Wählen Sie den Befehl Rechenbereich im Menü Einfügen, oder drücken Sie Strg+ Umschalt+A, um einen leeren Platzhalter einzufügen.

  3. Geben Sie die Gleichung in diesen Platzhalter auf die gleiche Weise ein, wie Sie es an anderer Stelle Ihres Arbeitsblatts tun würden.

Klicken Sie nach der Eingabe der Gleichung auf eine andere Stelle im Textbereich, um wieder in den Textmodus zu wechseln.

Zu beachten ist, daß sich das Einfügen von Gleichungen in Text auf Berechnungen im gesamten Arbeitsblatt auswirkt. Soll die Gleichung nur Textfunktion haben und sich nicht auf Berechnungen auswirken, können Sie sie deaktivieren.


Einfügen von Hyperlinks zu anderen Arbeitsblättern

EINFÜGEN VON HYPERLINKS

Um Hyperlinks in ein Arbeitsblatt oder eine andere Datei einzufügen, gehen Sie folgendermaßen vor:

  1. Wählen Sie den Bereich aus, der zu einem Hyperlink umgewandelt werden soll. Empfehlenswert ist es, daß Sie Text auswählen; Sie können jedoch jede beliebige Stelle als Hyperlink auswählen.

  2. Wählen Sie Hyperlink aus dem Menü Einfügen, um das Dialogfeld zu öffnen.

  3. Klicken Sie im Dialogfeld auf die Schaltfläche "Durchsuchen", und wählen Sie ein geeignetes Mathcad-Arbeitsblatt, einen Pfad oder eine Internet-Adresse (URL) zu einem Arbeitsblatt aus. Der entsprechende Eintrag wird in das leere Textfeld eingefügt.

  4. Wenn Sie einen relativen Pfad festlegen möchten, klicken Sie auf das Kontrollkästchen "Relativen Pfad für Hyperlink verwenden”. Soll das Ziel-Arbeitsblatt nach dem Doppelklicken auf den Hyperlink-Bereich in einem kleinen Popup-Fenster angezeigt werden, klicken Sie auf das Feld neben "Als Popup-Dokument anzeigen".

  5. Soll in der Statuszeile unten im Mathcad-Fenster eine Meldung erscheinen, wenn sich der Mauszeiger über dem Bereich mit dem Hyperlink befindet, geben Sie im Textfeld unten im Dialogfeld "Hyperlink einfügen" einen Meldungstext ein.

  6. Klicken Sie auf “OK.”

Nach diesen Schritten werden Sie sehen, daß der als Hyperlink ausgewählte Text unterstrichen und fett hervorgehoben ist. Dadurch wird angezeigt, daß ein Hyperlink erstellt worden ist. Alle anderen Stellen, die einen Hyperlink enthalten, werden auf die gleiche Weise angezeigt. Wenn Sie auf den Text bzw. den Bereich doppelklicken, wird das verknüpfte Arbeitsblatt geöffnet.


Ändern der Schriftart von Text

ÄNDERN VON SCHRIFTARTEIGENSCHAFTEN VON TEXT

Bei der Eingabe von Text werden dessen Eigenschaften zunächst von den Standardvorgaben für das Arbeitsblatt bzw. den Standardvorgaben für die Formatvorlage "Normal" bestimmt. Zum Ändern der Schriftart, des Schriftschnittes, des Schriftgrades, der Farbe oder der Position eines bestimmten Textabschnitts gehen Sie wie folgt vor:

  1. Markieren Sie den Text.

  2. Wählen Sie den Befehl Text im Menü Format.

  3. Legen Sie im Dialogfeld die Eigenschaften für die Schriftart fest, und klicken Sie dann auf "OK".

Soll der gesamte Text verändert werden, dem eine bestimmte Textformatvorlage zugrunde liegt, müssen Sie entweder die Eigenschaften der Formatvorlage verändern oder dem Text eine andere Textformatvorlage zuweisen.


Ändern der Absatzeinstellungen für Textbereiche (Aufzählungszeichen, Numerierungen, Ausrichtung, Einzüge)

ÄNDERN DER ABSATZEINSTELLUNGEN FÜR TEXTBEREICHE

Für die Absätze in einem Textbereich können die folgenden Einstellungen vorgenommen werden:

  • Einzug

  • Ausrichtung

  • Numerierung

  • Aufzählungszeichen

Zum Ändern dieser Eigenschaften für einen oder mehrere Absätze in einem Textbereich gehen Sie wie folgt vor:

  1. Markieren Sie Text innerhalb der Absätze.

  2. Wählen Sie Absatz im Menü Format.

  3. Nehmen Sie im Dialogfeld "Absatzformat" die gewünschten Änderungen vor, und klicken Sie auf "OK".

Zum schnellen Ändern von Ausrichtung, Aufzählungszeichen und Numerierungen gehen Sie wie folgt vor:

  1. Markieren Sie Text innerhalb der Absätze.

  2. Klicken Sie auf eine der Schaltflächen für die Ausrichtung [image], die Schaltfläche für Aufzählungszeichen [image] oder die Schaltfläche für Numerierungen [image] auf der Symbolleiste "Formatierung".

Hinweise:

  • Ein neuer Absatz beginnt immer dann, wenn ein neuer Textbereich eingefügt wird oder nachdem die Eingabetaste gedrückt wurde. Ein Absatz umfaßt immer alle Zeichen bis zu dem Punkt, an dem die Eingabetaste gedrückt wird.

  • Zum Einfügen einer neuen Zeile in einen Absatz drücken Sie Umschalt+Eingabetaste.


RECHTSCHREIBPRÜFUNG

Zur Überprüfung der Rechtschreibung des Textes in Ihrem Dokument gehen Sie wie folgt vor:

  1. Markieren Sie den Text, dessen Schreibweise auf Richtigkeit überprüft werden soll. Wenn Sie keinen Text auswählen, prüft die Rechtschreibprüfung den gesamten Text im Arbeitsblatt ab dem Cursor bis zum Ende des Arbeitsblatts.

  2. Wählen Sie den Befehl Rechtschreibung im Menü Bearbeiten.

  3. Wenn die Rechtschreibprüfung ein falsch geschriebenes Wort findet, wird das Dialogfeld "Rechtschreibung" geöffnet, in dem das falsch geschriebene Wort sowie einige Ersetzungsvorschläge angezeigt werden. Die Rechtschreibprüfung betrachtet alle Wörter als fehlerhaft, die sie nicht in ihrem Wörterbuch findet. Im Dialogfeld "Rechtschreibung" können Sie auch, wenn nötig, dem Wörterbuch Wörter hinzufügen.


TEXTFORMATVORLAGEN

Mathcad verwendet Textformatvorlagen, um den Absätzen in Textbereichen Standardeigenschaften zuzuweisen. Jedes Arbeitsblatt verfügt über eine Standardformatvorlage namens "Normal"; es sind jedoch auch andere Vorlagen verfügbar. Sie können eine Textformatvorlage einem oder mehreren Absätzen zuweisen, eine vorhandene Textformatvorlage modifizieren, eine neue Textformatvorlage erstellen oder eine Textformatvorlage löschen.

Zuweisen einer Formatvorlage

Ändern einer Formatvorlage

Erstellen einer Formatvorlage

Löschen einer Formatvorlage


ZUWEISEN EINER FORMATVORLAGE

Beim Erstellen eines Textbereiches wird allen Absätzen dieses Textbereiches die Textformatvorlage "Normal" zugewiesen. Jedes Arbeitsblatt bzw. jede Arbeitsblatt-Vorlage bietet Ihnen jedoch eine oder mehrere Textformatvorlagen, die Sie den Absätzen im Text zuweisen können.

Zum Zuweisen einer anderen Textformatvorlage für einen oder mehrere Absätze gehen Sie wie folgt vor:

  1. Klicken Sie in den Absatz, um die Einfügemarke einzufügen, oder wählen Sie Text in dem oder den gewünschten Absätzen aus.

  2. Wählen Sie Formatvorlage im Menü Format. Das Dialogfeld "Textformatvorlagen" erscheint.

  3. Wählen Sie eine der verfügbaren Textformatvorlagen aus, und klicken Sie auf "Übernehmen". Der Standardtext im Bereich nimmt die Text- und Absatzeinstellungen an, die in der Formatvorlage festgelegt sind.

Hinweise:

  • Statt Formatvorlage im Menü Format zu wählen, können Sie auch eine Formatvorlage aus der äußersten linken Dropdown-Liste in der Symbolleiste "Formatierung" auswählen.

  • Wenn Sie einem Textbereich eine Textformatvorlage zuweisen, übernimmt er die Textabsatzeinstellungen der Formatvorlage.

  • Text, der durch Bearbeitung der Schriftarteigenschaften bereits zuvor ausgewählt und formatiert wurde, behält sein Erscheinungsbild bei. Wenn Sie zuvor nur andere Texteigenschaften als die Schrifteigenschaften im markierten Text geändert haben, nimmt der markierte Text die Texteigenschaften der Formatvorlage und darüber hinaus die ausgewählte Schriftart, die Schriftgröße und die zugewiesenen Effekte an.


BEARBEITEN EINER VORHANDENEN TEXTFORMATVORLAGE

Wenn Sie die Eigenschaften für den gesamten Text verändern möchten, dem eine bestimmte Textformatvorlage zugrundeliegt, zum Beispiel die Textformatvorlage "Normal", sollten Sie die Formatvorlage als solche verändern. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie den Befehl Formatvorlage im Menü Format. Es werden alle verfügbaren Formatvorlagen angezeigt.

  2. Wählen Sie die Textformatvorlage aus, die Sie verändern wollen, und klicken Sie auf "Ändern". Es wird ein Dialogfeld eingeblendet, in dem alle Definitionen der ausgewählten Textformatvorlage aufgeführt sind.

  3. Klicken Sie auf "Schriftart", um Textformate, wie z. B. die in dieser Textformatvorlage verwendeten Zahlen zu ändern.

  4. Klicken Sie auf "OK", um die vorgenommenen Änderungen zu speichern.

Alle neuen Textbereiche, denen Sie die veränderte Textformatvorlage zuweisen, werden nach der neuen Definition der Textformatvorlage formatiert. Alle Textbereiche, die bereits zuvor mit der Textformatvorlage erstellt wurden, werden ebenfalls nach der veränderten Definition der Textformatvorlage neu angezeigt.


ERSTELLEN EINER FORMATVORLAGE

Zum Erstellen einer Textformatvorlage gehen Sie folgendermaßen vor:

  1. Wählen Sie Formatvorlage im Menü Format. Im daraufhin erscheinenden Dialogfeld "Textformatvorlagen" werden die derzeit verfügbaren Textformatvorlagen angezeigt.

  2. Klicken Sie auf "Neu".

  3. Geben Sie im Dialogfeld "Formatvorlage definieren" unter "Name" einen Namen für die neue Formatvorlage ein.

  4. Wenn die neue Formatvorlage auf einer bereits vorhandenen Vorlage basieren soll, wählen Sie aus der Dropdown-Liste "Basiert auf" eine Formatvorlage aus.

  5. Klicken Sie auf "Schriftart", um die Textformateinstellungen für die neue Formatvorlage festzulegen. Klicken Sie auf "Absatz", um die Absatzformateinstellungen für die neue Formatvorlage festzulegen.

  6. Klicken Sie auf "OK", wenn Sie das Definieren der neuen Formatvorlage abgeschlossen haben.

Die von Ihnen neu erstellte Formatvorlage erscheint nun im Dialogfeld "Textformatvorlagen" und kann jedem Textabsatz zugewiesen werden. Wenn Sie Ihr Arbeitsblatt speichern, wird auch die Formatvorlage gespeichert. Soll die neue Textformatvorlage auch künftig erstellten Arbeitsblättern zur Verfügung stehen, so speichern Sie Ihr Arbeitsblatt als Arbeitsblattvorlage.


LÖSCHEN EINER FORMATVORLAGE

Textformatvorlagen können jederzeit gelöscht werden. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie Formatvorlage im Menü Format. Mathcad zeigt alle verfügbaren Textformatvorlagen an.

  2. Wählen Sie eine der in der Liste verfügbaren Textformatvorlagen aus.

  3. Klicken Sie auf "Löschen".

Die Textformatvorlage wird aus der Liste der verfügbaren Textformatvorlagen entfernt. Text in Ihrem Arbeitsblatt, dessen Eigenschaften über diese Textformatvorlage definiert wurden, behält jedoch seine Eigenschaften unverändert bei.


FESTLEGEN DER BREITE VON TEXTBEREICHEN

Bei der Eingabe in einen Textbereich wird der Bereich fortlaufend bis zum rechten Rand vergrößert. Anschließend wird eine zweite Zeile eingefügt. Soll die Breite eines Textbereichs geändert werden, können Sie dies entweder manuell tun oder Sie können festlegen, daß der Textbereich automatisch die gesamte Breite der Seite einnehmen soll.

Die Breite eines Textbereichs manuell ändern

Sie haben zwei Möglichkeiten, die Breite eines Textbereichs manuell zu verändern:

mit Hilfe der Maus und

mit Hilfe der Tastatur.

Die Breite des Textbereichs auf die Gesamtbreite der Seite vergrößern

Soll sich ein Textbereich automatisch über die gesamte Breite einer Seite erstrecken, gehen Sie wie folgt vor:

  1. Klicken Sie in den Textbereich.

  2. Wählen Sie Eigenschaften im Menü Format.

  3. Klicken Sie auf die Registerkarte "Text".

  4. Klicken Sie auf "Seitenbreite verwenden".

  5. Klicken Sie auf "OK".

Der Textbereich erstreckt sich nun über die gesamte Breite der Seite. Außerdem werden die anderen Bereiche so verschoben, daß es zu keinen Überlappungen kommt, wenn der Textbereich größer wird.

Hinweis:

Das nachträgliche Ändern des rechten Randes wirkt sich nicht mehr auf die Breite bereits existierender Textbereiche aus.


VERHALTEN DER BEREICHE RECHTS BZW. UNTERHALB VON TEXTBEREICHEN BEI EINGABE VON TEXT

Sie können festlegen, ob ein Textbereich andere Bereiche überlappen soll oder ob die anderen Bereiche sich automatisch verschieben, wenn der Textbereich, an dem Sie arbeiten, größer wird.

Standardmäßig überlappt ein Textbereich, der sich bei Eingabe von Text vergrößert, die Bereiche, die sich rechts oder direkt unterhalb des Textbereichs befinden. Je mehr Text Sie eingeben, desto mehr vergrößert sich der Textbereich, bis er an den rechten Rand stößt. Jetzt wird eine neue Zeile eingefügt. Befinden sich unterhalb oder rechts dieses Textbereichs andere Bereiche, werden diese einfach durch den Textbereich überlappt.

Wenn Sie statt dessen möchten, daß sich die angrenzenden Bereiche verschieben, statt überlappt zu werden, können Sie die Eigenschaften des jeweiligen Textbereichs ändern. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie in den Textbereich.

  2. Wählen Sie den Befehl Eigenschaften im Menü Format.

  3. Klicken Sie auf die Registerkarte "Text".

  4. Klicken Sie auf "Bereiche bei Eingabe nach unten verschieben".

  5. Klicken Sie auf "OK".


Steuern von Berechnungen (allgemein)

STEUERN VON BERECHNUNGEN

Im Berechnungsmodus wird festgelegt, wie oft die Ergebnisse auf dem Bildschirm aktualisiert werden. Ein Arbeitsblatt ist immer in einem der folgenden beiden Berechnungsmodi aktiv:

Automatischer Modus: die Ergebnisse werden fortlaufend und automatisch aktualisiert.

Manueller Modus: die Ergebnisse werden durch den Benutzer aktualisiert.

In beiden Modi können Sie Gleichungen aktivieren oder deaktivieren oder eine gerade durchgeführte Berechnung unterbrechen.


ITERATION UND SCHLEIFEN

Bereichsvariablen

Zeigt, wie Variablen definiert werden, deren Wert einer Iteration über einen Bereich unterworfen wird.

Wiederholtes Auswerten eines Ausdrucks

Zeigt die Verwendung von Bereichsvariablen zur Auswertung von Ausdrücken bei mehreren Werten.

Iteration über einen Wertebereich

Zeigt die Verwendung von Bereichsvariablen mit Feldern und Funktionen zur Durchführung von einfachen Iterationen.

Differenzengleichungen

Rekursive Auswertung der Lösung einer Differenzengleichung mit Hilfe von Bereichsvariablen.

Iterierte Berechnungen

Rekursive Auswertung der Lösung eines Systems von gekoppelten Differenzengleichungen mit Hilfe von Bereichsvariablen.


GLEICHZEITIGES AUSFÜHREN VON BERECHNUNGEN

Alle Berechnungen, die Mathcad mit einzelnen Werten durchführen kann, sind auch mit Feldern von Werten möglich. Dazu gibt es zwei Möglichkeiten:

Durch Iteration für die einzelnen Elemente mit Bereichsvariablen als unterem Index.

Durch Verwendung des Vektorisierungsoperators, mit dem Mathcad denselben Vorgang für alle Elemente eines Vektors oder eine Matrix effektiv durchführen kann.


FEHLERMELDUNGEN IN NUMERISCHEN BERECHNUNGEN

Wenn Mathcad einen Fehler in einem Ausdruck erkennt, zeigt er dies mit einer Fehlermeldung an und hebt den beanstandeten Namen oder Operator in einer anderen Farbe (normalerweise Rot) hervor.

Mathcad kann Ausdrücke mit Fehlern nicht verarbeiten. Ein Ausdruck kann nur verarbeitet werden, nachdem der Fehler behoben wurde.

Durch Klicken auf die Fehlermeldungen können Sie Angaben zu ihnen aufrufen:

"Suchen" und "Minfehl" muß jeweils eine entsprechende "Vorgabe" vorausgehen.

Alle Auswertungen ergaben einen Fehler oder ein komplexes Ergebnis.

Argumente in Funktionsdefinitionen müssen Namen sein.

Auswertung einer Ableitung n-ter Ordnung nur möglich, wenn n=0,1..5.

Es können nur positive Werte in Diagrammen dargestellt werden, wenn logarithmische Achsen verwendet werden.

Keine Konvergenz gegen eine Lösung. Die Integrandfunktion weist möglicherweise eine Singularität auf, oder das Integral ist unendlich.

Eine Variable kann in einem Ausdruck nur einmal definiert werden.

Nicht bestimmbar, welche Einheiten das Ergebnis dieser Operation haben soll.

Diese Funktion kann nicht ausgewertet werden, wenn ihr Argument Null ist.

Keine Lösung für dieses Gleichungssystem gefunden. Versuchen Sie es mit einem anderen Schätzwert, oder überprüfen Sie, ob wirklich eine Lösung existiert.

Die zu verwendende Datendatei wurde nicht gefunden.

Keine Eingabe mit Einheiten oder Dimensionen zulässig.

Diese Operation kann nicht auf das ganze Datenfeld auf einmal angewendet werden. Versuchen Sie, mit "Vektorisieren" die Operation Element für Element auszuführen.

So viele Punkte können nicht dargestellt werden.

":=" nicht zulässig in einem Gleichungssystem. Verwenden Sie statt dessen die Schaltfläche "=" auf der Palette “Ungleichheit”.

Ein Ausdruck mit Einheiten kann nicht mit einer komplexen Zahl potenziert werden.

Ein System mit mehr als fünfzig Gleichungen kann nicht aufgelöst werden.

Datendatei nicht völlig verständlich. Stammt diese Datei aus einer Tabellenkalkulation, muß sie als reiner ASCII-Text gespeichert werden.

Name dieser Funktion ist nicht verständlich. Verwenden Sie für die Multiplikation "*".

Definitionsweise dieser Bereichsvariablen nicht verständlich.

Diese Zahl ist nicht verständlich.

In einem Gleichungssystem kann keine Bereichsvariable verwendet werden.

Auswertung bei einem oder mehreren von Ihnen angegebenen Werten nicht möglich.

Produktübergreifend ist nur für die Vektoren definiert, die genau drei Elemente aufweisen.

Definitionsstapelüberlauf

Grad des Polynoms muß zwischen 1 und 99 sein.

Dimensionen müssen 4 sein.

Dateiende

Endpunkte müssen sich unterscheiden.

Gleichung zu groß

Gleitkommafehler

Zahl mit einem Betrag größer als 10^307 bei Auswertung dieses Ausdrucks gefunden.

Singularität bei Auswertung dieses Ausdrucks festgestellt. Möglicherweise dividieren Sie durch Null.

Ungültige Bedingung

Ungültiger Kontext. Drücken Sie F1 für Hilfe.

Ungültige Dimensionen

Eingabe muß ein- oder zweidimensional sein.

Ganze Zahl zu groß.

Ganze Zahl zu klein.

Ungültiger Entwicklungspunkt

Ungültiges Format

Ungültige Matrixdimension.

Liste zu lang

SmartMath nicht verfügbar

Loess kann nicht extrapolieren.

Muß <= 10000 sein.

Muß = 10^-16 sein.

Muß 1 komplexe Matrix oder 2 reelle Matrizen sein.

Muß 1 mehrdimensionales Feld sein.

Muß Zeichenfolge sein.

Muß zwischen zwei Sperrbereichen liegen.

Muß Funktion sein.

Muß aufsteigend sein.

Muß ganze Zahl >= 1 sein.

Muß kleiner als die Anzahl der Datenpunkte sein.

Muß ungerade ganze Zahl sein

Muß positiv sein

Muß reell sein

Muß reeller Skalar sein

Muß reeller Vektor sein

Muß quadratisch sein

Muß weniger als fünf Faktoren haben.

Muß mehr Datenpunkte als Parameter haben.

Muß mehr als drei Beobachtungen haben.

Muß 3 Vektoren oder 1 Matrix haben.

Muß mehr Datenpunkte als Parameter haben.

Keine Bitmaps in Arbeitsblatt gefunden.

Keine Lösung gefunden.

Nicht positive bestimmte Matrix

Nicht genügend Speicher für diese Operation.

Keine Sperre vorhanden.

Anzahl Zeilen muß eine Potenz von 2 sein.

Wurzel nicht gefunden

(Zeilen - 1) muß Potenz von 2 sein.

Singuläre Matrix

Es liegt ein Fehler in dem Gleichungssystem vor, mit dem diese Funktion definiert wird. Möglicherweise ist ein Schätzwert erforderlich.

Stapelüberlauf

Nur symbolischer Operator.

Der Ausdruck links von dem Gleichheitszeichen kann nicht definiert werden.

Matrixdimensionen inkompatibel.

Die Anzahl Zeilen und/oder Spalten in diesem Feld stehen in Konflikt.

In den Einheitenplatzhalter können nur reelle Skalare ungleich Null eingegeben werden.

Die Einheiten dieses Ausdrucks stehen in Konflikt zueinander.

Dieser Ausdruck enthält ein überflüssiges Komma.

Dieses Feld muß mehr als eine Zeile bzw. Spalte haben.

Dieser Ausdruck enthält nur eine "(", aber keine ")".

Dieser Ausdruck ist nicht vollständig. Sie müssen die Platzhalter ausfüllen.

Diese Funktion hat zu viele Argumente.

Diese Funktion ist an mindestens einem der von Ihnen angegebenen Punkte nicht definiert.

Diese Funktion benötigt mehr Argumente.

Diese Matrix muß quadratisch sein. Sie sollte die gleiche Anzahl Zeilen wie Spalten haben.

Dies muß eine ganze Zahl sein. Der verwendete Ausdruck scheint einen Bruch zu enthalten.

Dies muß der Name einer Funktion bzw. Variable sein.

Diese Operation kann nur für eine Funktion ausgeführt werden.

Diese Operation kann nur für ein Datenfeld ausgeführt werden, nicht für eine Zahl.

Diese Operation kann nur für eine Zahl oder ein Datenfeld ausgeführt werden.

Diese Operation kann nur für eine Zeichenfolge ausgeführt werden.

Dieser tiefgestellte Index ist zu groß.

Dieses Gleichungssystem weist mehr Unbekannte auf, als es Gleichungen gibt.

Dieser Wert muß ein Vektor sein. Er kann weder eine Matrix noch ein Skalar sein.

Dieser Wert muß reell sein. Der Imaginärteil muß Null sein.

Diese Variable muß eine Bereichsvariable sein.

Diese Variable bzw. Funktion ist oben nicht definiert.

Dieser Vektor hat die falsche Anzahl Elemente.

Dieser Vektor sollte mehr Elemente haben.

Zu viele Iterationen.

Zu viele Integrationsschritte.

Geben Sie “ORIGIN=” ein, um die Einstellung dieses Parameters zu überprüfen; es sollte eine ganze Zahl sein, deren Betrag geringer als 16 Millionen ist. Definieren Sie den Parameter gegebenenfalls neu.

Geben Sie “TOL=” ein, um die Einstellung der Toleranz zu überprüfen; sie sollte größer als 0 und kleiner oder gleich 1 sein. Definieren Sie den Parameter gegebenenfalls neu.

Unterlauf

Ungleiche Felddimensionen

Wert des tiefgestellten Index zu groß (oder zu klein) für dieses Feld.

Vektorelemente müssen unterschiedlich sein.

Sie versuchen, ein Datenfeld bzw. einen Bereich als Skalar zu verwenden. Drücken Sie F1, um die Hilfe aufzurufen.

Es befindet sich ein Gleichungssystem innerhalb eines anderen. Für jede "Vorgabe" muß es eine entsprechende Funktion "Suchen" oder "Minfehl" geben.

Sie haben einen Rechenvorgang unterbrochen. Um fortzufahren, klicken Sie hier, und wählen Sie im Menü "Rechnen" den Befehl "Berechnen".


Symbolische Optimierung deaktiviert

SYMBOLISCHE OPTIMIERUNG

Im Normalfall wertet Mathcad Ausdrücke genau so aus, wie Sie sie eingegeben haben. Dies geschieht ungeachtet dessen, daß oft ein klein wenig Vereinfachung dazu führen würde, daß der Ausdruck sich wesentlich leichter auswerten läßt. Mit dem Befehl Optimierung im Menü Rechnen jedoch weisen Sie den numerischen Prozessor an, Ausdrücke vor den Berechnungen zu vereinfachen. Wenn Sie auf das Bild unten klicken, können Sie sehen, was dabei passiert.

Um alle Gleichungen in einem Arbeitsblatt zu optimieren, gehen Sie folgendermaßen vor:

  • Wählen Sie den Befehl Optimierung aus dem Menü Rechnen.

Mathcad übergibt daraufhin alle Ausdrücke vor deren Auswertung zunächst dem symbolischen Prozessor, damit dieser sie vereinfachen kann. Wenn der symbolische Prozessor eine vereinfachte Form findet, wird der Ausdruck mit einem roten Sternchen markiert. Sie können den vereinfachten Ausdruck anzeigen lassen, indem Sie auf das Sternchen doppelklicken oder den Befehl Popup anzeigen aus dem Kontextmenü des Ausdrucks wählen. Mathcad verwendet für alle nachfolgenden Berechnungen nun stets diese vereinfachte Form des Ausdrucks.

Soll Mathcad jedoch einen Ausdruck genau so berechnen, wie er eingegeben wurde, ohne daß er zuvor vereinfacht wird, klicken Sie auf die Gleichung, und wählen Sie Eigenschaften im Menü Format. Klicken Sie dann auf die Registerkarte "Berechnung", und aktivieren Sie die Option "Optimierung deaktivieren".

Wenn Sie nur einen bestimmten Ausdruck und nicht das gesamte Arbeitsblatt optimieren möchten, gehen Sie wie folgt vor:

  1. Klicken Sie auf die Gleichung, und wählen Sie Eigenschaften aus dem Menü Format.

  2. Klicken Sie auf die Registerkarte "Berechnung", und deaktivieren Sie die Option "Optimierung deaktivieren".

Wenn Mathcad dann den Ausdruck optimiert, wird neben dem Ausdruck ein rotes Sternchen angezeigt. Kann Mathcad den Ausdruck nicht optimieren, wird er mit einem blauen Sternchen versehen.


LAYOUT-HILFSMITTEL

Beim Einfügen von Gleichungen, Text, Grafiken und anderen Bereichen in ein Arbeitsblatt können Sie deren Anordnung nach Belieben festlegen. Sie können auch bestimmte Bereiche sperren, so daß sie nicht bearbeitet werden können, oder Bereiche hervorheben, so daß sie leichter ins Auge fallen.

Löschen von Bereichen

Verschieben von Bereichen

Einfügen leerer Zeilen zwischen Bereichen

Ausrichten von Bereichen

Trennen von Bereichen

Sperren von Bereichen

Hervorheben von Bereichen


AUSWÄHLEN VON BEREICHEN

Zum Markieren eines einzelnen Bereichs gehen Sie wie folgt vor:

  1. Klicken Sie auf den Bereich. Dadurch wird er in ein Markierungsrechteck eingeschlossen. Drei Haltepunkte werden eingeblendet.

Zum Markieren mehrerer Bereiche gehen Sie wie folgt vor:

  1. Klicken Sie außen neben eine Ecke der Region, die die gewünschten Bereiche enthält.

  2. Halten Sie die Maustaste gedrückt, und ziehen Sie den Mauszeiger über das Arbeitsblatt. Es erscheint ein gestricheltes Markierungsrechteck.

  3. Wenn das Markierungsrechteck alle Bereiche enthält, die Sie auswählen möchten, lassen Sie die Maustaste los. Alle markierten Bereiche werden von Markierungsrechtecken umschlossen.

Sie können Bereiche auch mit einer der folgenden Methoden auswählen:

  • Halten Sie die Strg-Taste gedrückt, und klicken Sie nacheinander auf die auszuwählenden Bereiche.

  • Halten Sie die Umschalttaste gedrückt, um mehrere Bereiche gleichzeitig auszuwählen.

  • Zur Auswahl eines Rechenbereiches klicken Sie in den Bereich, halten Sie die Maustaste gedrückt, und ziehen Sie den Mauszeiger so daß der Bereich invers hervorgehoben wird. Sie können den Bereich dann ausschneiden, kopieren oder löschen.

Nach der Auswahl einer oder mehrerer Bereiche können Sie die Auswahl verschieben oder löschen. Sie können außerdem auch andere Elemente statt der gerade markierten Elemente markieren, falls dies erforderlich ist.


ZIEHEN VON BEREICHEN

Wenn Sie einen Bereich oder mehrere Bereiche markiert haben, können Sie diese entweder in einen anderen Teil Ihres Arbeitsblatts oder in ein anderes Arbeitsblatt ziehen. Gehen Sie hierzu folgendermaßen vor:

  1. Setzen Sie den Mauszeiger in einen der Bereiche, die von einem gestrichelten Markierungsrechteck umrahmt sind. Der Mauszeiger wechselt seine Form von einem Pfeil zu einer kleinen Hand.

  2. Halten Sie die Maustaste gedrückt.

  3. Verschieben Sie den Mauszeiger bei gedrückter Maustaste. Auf diese Weise können die Umrisse aller markierten Bereiche verschoben werden.

  4. Wenn sich die Umrisse an den gewünschten Positionen befinden, lassen Sie die Maustaste wieder los.


LÖSCHEN VON BEREICHEN

Zum Löschen von Bereichen gehen Sie wie folgt vor:

  1. Markieren Sie die zu löschenden Bereiche, indem Sie ein Markierungsrechteck um sie ziehen.

  2. Wählen Sie Ausschneiden im Menü Bearbeiten.


EINFÜGEN UND LÖSCHEN VON LEERZEILEN

Einfügen einer oder mehrerer Leerzeilen

Löschen einer oder mehrerer Leerzeilen


TRENNEN VON ÜBERLAPPENDEN BEREICHEN

Die Bereiche, die Gleichungen und Text in Ihrem Dokument enthalten, sind größer als sie erscheinen. Um anzuzeigen, wie groß ein Bereich eigentlich ist, gehen Sie wie folgt vor:

Wählen Sie Bereiche aus dem Menü Ansicht.

Falls sich die Bereiche überlappen, gehen Sie wie folgt vor:

Markieren Sie sie, und ziehen Sie sie auseinander oder

wählen Sie den Befehl Bereiche trennen aus dem Menü Format.


AUSRICHTEN VON BEREICHEN

Horizontales Ausrichten von Bereichen

Vertikales Ausrichten von Bereichen


Sperren einer Region im Arbeitsblatt

SPERREN EINER REGION IM ARBEITSBLATT (nur Mathcad Professional)

Sie können festlegen, daß ein bestimmter Teil Ihres Arbeitsblatts gesperrt werden soll. Die Bereiche innerhalb der gesperrten Region können dann nicht mehr geändert werden.

Festlegen der zu sperrenden Region

Sperren der Region

Freigeben der Region

Löschen einer zu sperrenden Region


BEREICHE IM ARBEITSBLATT AUSBLENDEN

Wenn Sie ein Arbeitsblatt haben, das Berechnungen, Diagramme oder andere Bereiche enthält, die andere nicht sehen sollen, können Sie diese Bereiche ausblenden. Die ausgeblendeten Bereiche werden weiterhin mit in die Berechnung einbezogen, sind jedoch nicht auf dem Bildschirm oder im Ausdruck sichtbar.

Um einen oder mehrere Bereiche auszublenden, müssen Sie zunächst im Arbeitsblatt eine Region festlegen, in der dann alle Berechnungen und anderen Bereiche, die nicht mehr sichtbar sein sollen, plaziert werden. Sie können die Region dann ausblenden, um sie unsichtbar zu machen. Solcherart unsichtbar gemachte Bereiche können auch gesperrt werden, so daß niemand, der nicht dazu berechtigt ist, sie wieder einblenden kann.

Festlegen einer auszublendenden Region...

Ausblenden der festgelegten Region...

Einblenden der festgelegten Region...

Sperren einer ausgeblendeten Region...

Löschen einer ausgeblendeten Region...


VERWALTUNG VON ARBEITSBLÄTTERN

In Mathcad können Sie Arbeitsblätter entweder auf der Grundlage einer vordefinierten Vorlage oder aber einer von Ihnen erstellten Vorlage anlegen. Alle Vorlagen können entsprechend Ihren Bedürfnissen geändert werden.

Nachdem Sie ein Arbeitsblatt erstellt haben, können Sie einen der folgenden Schritte ausführen:

Öffnen...

eines neuen Arbeitsblatts

eines bereits existierenden Arbeitsblatts

eines Arbeitsblatts im Internet

Speichern des aktuellen Arbeitsblatts...

unter demselben Namen

unter einem anderen Namen

als RTF-Datei

als Mathcad 6-Arbeitsblatt

Integrieren eines Arbeitsblatts in ein anderes durch...

Verweisen auf ein anderes Arbeitsblatt

Weitergeben Ihres Arbeitsblatts durch...

Ausdrucken

Versenden per E-Mail

Schließen Ihres Arbeitsblatts durch...

Schließen (drücken Sie Strg+F4)

Beenden (drücken Sie Alt+F4)


ERSTELLEN EINES ARBEITSBLATTS

Zum Erstellen eines neuen Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Neu im Menü Datei. Das Dialogfeld "Neu" wird geöffnet.

  2. Wählen Sie eine Vorlage aus, auf der Ihr Arbeitsblatt basieren soll.

  3. Es erscheint ein neues Fenster ohne Namen. Je nachdem, was für eine Vorlage Sie ausgewählt haben, enthält das neue Arbeitsblatt bereits Gleichungen, Text oder andere Bereiche, die Sie bearbeiten können.

  4. Wählen Sie Speichern im Menü Datei, und geben Sie einen Namen für Ihr Arbeitsblatt ein. Die Dateinamenerweiterung für das Arbeitsblatt lautet ".mcd".


ÖFFNEN EINES BEREITS BESTEHENDEN ARBEITSBLATTS

Zum Öffnen eines Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Öffnen im Menü Datei. Es erscheint eine Liste der Arbeitsblätter im aktuellen Verzeichnis.

  2. Doppelklicken Sie auf den Namen des Arbeitsblatts, das geöffnet werden soll. (Wenn sich das Arbeitsblatt in einem anderen Verzeichnis als dem aktuellen befindet, klicken Sie auf die Liste der Verzeichnisse im Dialogfeld "Öffnen".)

Zum Öffnen eines Arbeitsblatts im Internet gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl WWW-Foren im Menü Datei. Das Dialogfeld mit den WWW-Foren wird geöffnet.

  2. Geben Sie in das Feld "URL" die URL -Adresse des Arbeitsblatts ein.

  3. Klicken Sie auf "Abrufen".


Schließen eines Arbeitsblatts

SCHLIESSEN EINES ARBEITSBLATTS

Zum Schließen des aktiven Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Schließen im Menü Datei.

  2. Wenn seit dem letzten Speichern des Arbeitsblatts Änderungen vorgenommen wurden, werden Sie aufgefordert, das Arbeitsblatt vor dem Schließen zu speichern.

Wenn Sie Mathcad ganz beenden wollen, wählen Sie den Befehl Beenden im Menü Datei.


UMBENENNEN EINES ARBEITSBLATTS

Zum Umbenennen eines Arbeitsblatts gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Speichern unter im Menü Datei. Es wird ein Dialogfeld geöffnet.

  2. Geben Sie in das Textfeld den neuen Namen des Arbeitsblatts ein.


VERWALTEN VON ARBEITSBLATT-FENSTERN

Trotz der Tatsache, daß mehrere Arbeitsblätter gleichzeitig geöffnet sein können, ist immer nur ein Arbeitsblatt das aktive Arbeitsblatt. In der folgenden Liste finden Sie einige der Dinge, die Sie mit dem aktiven Arbeitsblatt machen können:

Verschieben...

Größe ändern...

Maximieren...

Minimieren...

Schließen...

Durch ein anderes ersetzen...

Arbeitsblatt-Fenster übereinander anordnen...

Arbeitsblatt-Fenster neben- und untereinander anordnen...


ERSTELLEN EINER NEUEN VORLAGE

Obgleich Mathcad eine Vielzahl von vordefinierten Vorlagen enthält, können Sie auch eigene Vorlagen erstellen und speichern. So können Sie z. B. eine Vorlage für ein Projekt anlegen, die spezifische Informationen in der Kopf- und Fußzeile sowie Diagramme und Text an bestimmten Stellen des Arbeitsblatts enthält. Auch die Werte für andere Einstellungen können geändert werden.

Zum Erstellen einer neuen Vorlage ist wie folgt vorzugehen:

Erstellen Sie ein neues Arbeitsblatt mit den gewünschten Einstellungen. Das Arbeitsblatt sollte darüber hinaus alle Gleichungen, allen Text und alle Grafiken enthalten, die in der Vorlage erscheinen sollen.

Wählen Sie den Befehl Speichern unter im Menü Datei. Das Dialogfeld "Speichern unter" wird geöffnet.

Doppelklicken Sie im Dialogfeld "Speichern unter" auf den Ordner "template".

Wählen Sie in der Dropdown-Liste "Dateityp" die Option "Mathcad-Vorlage" aus.

Geben Sie im Feld "Dateiname" einen Namen für die Vorlage ein.

Klicken Sie auf "Speichern". Standardmäßig wird die Datei als Mathcad-Vorlagendatei (mit der Erweiterung .mct) im Unterverzeichnis "template" gespeichert. Sie können aber auch einen anderen Speicherort festlegen.

Ihre Vorlage wird daraufhin in die Liste der verfügbaren Vorlagen aufgenommen. Auf diese Liste können Sie zugreifen, indem Sie den Befehl Neu aus dem Menü Datei wählen, um ein neues Arbeitsblatt zu erstellen.


ÄNDERN EINER VORLAGE

Zum Ändern einer bestehenden Arbeitsblattvorlage gehen Sie wie folgt vor:

Wählen Sie den Befehl Öffnen im Menü Datei.

Wählen Sie in der Dropdown-Liste "Dateityp" die Option "Mathcad-Vorlage".

Geben Sie im Feld "Dateiname" den Namen der Vorlage ein, oder gehen Sie zum Verzeichnis "template" (bzw. zum entsprechenden Speicherort der Vorlage).

Klicken Sie auf "Öffnen". Die Vorlage wird im Mathcad-Fenster geöffnet.

Bearbeiten Sie die Vorlage auf die gleiche Art und Weise wie jedes andere Mathcad-Arbeitsblatt.

Wählen Sie den Befehl Speichern im Menü Datei. Wenn die geänderte Vorlage einen neuen Namen erhalten soll, wählen Sie statt dessen den Befehl Speichern unter im Menü Datei, und geben Sie im Dialogfeld "Speichern unter" einen neuen Namen für die Vorlage ein.

Beachten Sie, daß die Änderungen an einer Vorlage sich nur auf die Dateien auswirken, die nach dem Ändern der Vorlage auf deren Grundlage erstellt wurden. Auf Arbeitsblätter, die auf der Grundlage einer Vorlage erstellt wurden, bevor diese geändert wurde, haben die Änderungen keinerlei Auswirkungen.


Kopf- und Fußzeilen

KOPF- UND FUSSZEILEN

Zum Einfügen von Kopf- und Fußzeilen in das gedruckte Arbeitsblatt gehen Sie wie folgt vor:

1. Wählen Sie den Befehl Kopf-/Fußzeile im Menü Format. Das Dialogfeld "Kopf-/Fußzeile" wird geöffnet.

2. Klicken Sie auf die Registerkarte "Kopfzeile" bzw. auf die Registerkarte "Fußzeile".

3. Klicken Sie in das entsprechende Textfeld für die Position der Kopf- bzw. Fußzeile.

4. Geben Sie den gewünschten Text ein. Mit Hilfe der Schaltflächen unter "Hilfsmittel" können Sie weitere Informationen, wie z. B. Seitenzahlen, Datum und Uhrzeit, einfügen. Darüber hinaus stehen Optionen für die folgenden Einstellungen zur Verfügung:

  • Die Seitennumerierung soll mit einer anderen Zahl als 1 beginnen.

  • Für die erste Seite des Arbeitsblatts wird eine spezielle Kopf- und Fußzeile definiert.

  • Kopf- und Fußzeile sowie die gesamte Seite werden in Rahmen gesetzt.

  • Es wird eine Bitmap eingefügt.

  • Die Schriftart wird formatiert.

5. Wenn Sie alle Einstellungen vorgenommen haben, klicken Sie auf "OK".


RÄNDER

Zum Einstellen der Ränder gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Seite einrichten aus dem Menü Datei.

  2. Klicken Sie auf das Feld für die jeweilige Randeinstellung.

  3. Geben Sie die Entfernung (in Zoll) vom Rand zur Kante des Papierblattes ein, auf das Sie drucken wollen.

  4. Zum Zuweisen dieser Randeinstellungen für das aktuelle Arbeitsblatt klicken Sie auf "OK."


VERSENDEN VON ARBEITSBLÄTTERN PER E-MAIL

Sie können diese Funktion nur dann nutzen, wenn Sie an ein kompatibles E-Mail-System angeschlossen sind.

Um das derzeit geöffnete Arbeitsblatt per E-Mail zu versenden, gehen Sie folgendermaßen vor:

Wählen Sie den Befehl Senden im Menü Datei.

Gegebenenfalls werden Sie zur Eingabe eines Kennworts aufgefordert. Danach wird ein Dialogfeld angezeigt, das aus Ihrem E-Mail-System stammt.


EXPORTIEREN EINES ARBEITSBLATTS IN EINE ANDERE ANWENDUNG

Zum Exportieren eines Arbeitsblatts in eine andere Anwendung können Sie das Arbeitsblatt als RTF-Datei speichern, oder Sie kopieren die entsprechenden Arbeitsblattbereiche und fügen Sie in der Zielanwendung wieder ein.

Exportieren als RTF-Datei

Sie haben die Möglichkeit, ein ganzes Arbeitsblatt mit allen Gleichungen und Diagrammen in eine RTF-Datei umzuwandeln, die von den meisten modernen Textverarbeitungsprogrammen gelesen werden kann. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie Speichern unter im Menü Datei.

  2. Wählen Sie aus der Dropdown-Liste "Dateityp" im Dialogfeld "Speichern unter" die Option "Rich Text Format (*.rtf)".

  3. Geben Sie im Feld "Dateiname" für die RTF-Datei, die Sie erstellen wollen, einen Namen ein.

Wenn Sie diese RTF-Datei in einem Textverarbeitungsprogramm öffnen, sind alle Mathcad-Bereiche am linken Rand des Dokuments ausgerichtet. Mit Hilfe des Textverarbeitungsprogramms können Sie diese Bereiche so anordnen, wie Sie es wünschen.

Kopieren und einfügen

Eine weitere Möglichkeit, ein Arbeitsblatt zu exportieren, besteht darin, alle Bereiche des Arbeitsblatts zu kopieren und diese in einer anderen Anwendung wieder einzufügen. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie den Befehl Alles markieren im Menü Bearbeiten.

  2. Wählen Sie den Befehl Kopieren im Menü Bearbeiten.

  3. Öffnen Sie die Anwendung, in die das Arbeitsblatt eingefügt werden soll, und fügen Sie es ein.


DRUCKEN BESTIMMTER SEITEN

Um nur bestimmte Seiten auszudrucken, gehen Sie wie folgt vor:

  1. Ermitteln Sie die Seitenzahlen anhand der Anzeige in der linken unteren Ecke des Fensters.

  2. Wählen Sie den Befehl Drucken aus dem Menü Datei. Daraufhin öffnet sich das Dialogfeld "Drucken".

  3. Aktivieren Sie die Option "Seiten".

  4. Geben Sie in den Feldern "Von" und "Bis" an, welche Seiten gedruckt werden sollen. Wenn nur eine Seite gedruckt werden soll, geben Sie in beiden Feldern dieselbe Seitenzahl ein.

  5. Klicken Sie auf "OK".


DRUCKEN AUSGEWÄHLTER BEREICHE

Zum Drucken ausgewählter Bereiche gehen Sie wie folgt vor:

  1. Drücken Sie die Strg-Taste, halten Sie sie gedrückt, und klicken Sie auf die Bereiche, die gedruckt werden sollen. Um jeden Bereich, auf den Sie auf diese Weise klicken, erscheint ein gestricheltes Rechteck. Dadurch wird angezeigt, daß der jeweilige Bereich markiert ist.

  2. Wenn ein bereits markierter Bereich doch nicht gedruckt werden soll, klicken Sie nochmals bei gedrückter Strg-Taste auf diesen Bereich. Das gestrichelte Rechteck um den entsprechenden Bereich wird entfernt.

  3. Wählen Sie den Befehl Drucken aus dem Menü Datei. Daraufhin öffnet sich das Dialogfeld "Drucken".

  4. Aktivieren Sie die Option "Markierung".

  5. Klicken Sie auf "OK".


SEITENANSICHT

Wenn Sie sich vor dem Drucken ansehen wollen, wie Ihr Arbeitsblatt gedruckt aussehen wird, gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Seitenansicht aus dem Menü Datei. In der Seitenansicht wird die aktuelle Seite Ihres Arbeitsblatts so angezeigt, wie sie im Ausdruck erscheinen wird.

  2. Mit Hilfe der Schaltflächen "Nächste" und "Vorherige" am oberen Rand des Bildschirms können Sie sich die anderen Seiten Ihres Arbeitsblatts anzeigen lassen.

  3. Klicken Sie auf "Schließen". Damit kehren Sie zum Haupt-Arbeitsblattfenster zurück.

Falls Sie nach der Ansicht Ihres Arbeitsblatts noch Änderungen vornehmen wollen, wählen Sie den Befehl Seite einrichten aus dem Menü Datei. Im daraufhin erscheinenden Dialogfeld können Sie die Einstellungen für die Ränder ändern oder Kopf- und Fußzeilen hinzufügen.


EINFÜGEN EINES ARBEITSBLATTS IN EIN ANDERES ARBEITSBLATT

Es kann vorkommen, daß Sie Formeln und Berechnungen aus einem Arbeitsblatt in einem anderen verwenden wollen. Eine Möglichkeit, dies zu bewerkstelligen, ist die Verwendung der Befehle Kopieren und Einfügen im Menü Bearbeiten.

Eine weitere Möglichkeit besteht darin, einen Verweis auf ein Arbeitsblatt einzufügen. Auf diese Art und Weise verhält sich das aktuelle Arbeitsblatt so, als ob Sie die betreffenden Bereiche des Arbeitsblatts, zu dem es einen Verweis gibt, tatsächlich in dieses aktuelle Arbeitsblatt eingefügt haben. Die Bereiche selbst sind aber nicht sichtbar. Statt dessen erscheint an den entsprechenden Stellen in Ihrem Arbeitsblatt ein Symbol.

Zum Einfügen eines Verweises auf ein Arbeitsblatt gehen Sie wie folgt vor:

  1. Wählen Sie Verweis im Menü Einfügen. Das Dialogfeld "Verweis einfügen" erscheint.

  2. Klicken Sie im Dialogfeld auf "Durchsuchen". Gehen Sie zum Speicherort des Mathcad-Arbeitsblatts, auf dessen Bereiche Sie in Ihrem aktiven Arbeitsblatt verweisen wollen, und wählen Sie es aus. Sie können statt dessen auch den vollständigen Pfad bzw. den Internet-Adreßpfad (URL) zu einem Arbeitsblatt im leeren Textfeld eingeben.

  3. Aktivieren Sie die Option "Relativen Pfad für Verweis verwenden", wenn Sie einen relativen Pfad verwenden wollen.

  4. Klicken Sie auf "OK".

Nach dem Ausführen dieser Schritte erscheint ein Symbol,

das Ihnen anzeigt, wo sich das Arbeitsblatt, auf das Sie verwiesen haben, auswirkt. Wenn Sie auf dieses Symbol doppelklicken, wird das Arbeitsblatt, auf das verwiesen wird, eingeblendet. Nachdem Sie einen Verweis auf ein Arbeitsblatt eingefügt haben, braucht das Arbeitsblatt, auf das verwiesen wird, nicht mehr geöffnet zu sein.


ARBEITEN MIT FELDERN

Während gewöhnliche Variablen einen einzigen Wert enthalten, weisen Felder (Überbegriff für Matrizen und Vektoren) mehrere Werte auf. Sie können Vektoren und Matrizen erstellen und in Ihren Rechnungen und Variablendefinitionen ebenso wie Zahlen verarbeiten. Viele der Operatoren und Funktionen von Mathcad können auch für Felder verwendet werden. Darüber hinaus stehen zahlreiche spezielle Operatoren und Funktionen für die Arbeit mit Feldern zur Verfügung.

Erstellen von Vektoren und Matrizen

Anzeigen von Vektoren und Matrizen

Grafische Darstellung eines Vektors

Berechnungen mit Datenfeldern

Ändern der Größe eines Feldes

Extrahieren von Elementen, Zeilen und Spalten

Starten von Feldern bei einem Element ungleich Null

Beschränkungen der Datenfeldgrößen

Vektor- und Matrixfunktionen

Vektor- und Matrixoperatoren

Symbolische Matrixmanipulation

Verschachtelte Felder


ERSTELLEN VON VEKTOREN UND MATRIZEN

Die einfachste Art, ein Feld zu erstellen, ist, ein Feld aus leeren Platzhaltern anzulegen und diese dann auszufüllen.

Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie den Befehl Matrix im Menü Einfügen. Es erscheint ein Dialogfeld.

  2. Legen Sie in diesem Dialogfeld die Anzahl der Zeilen und Spalten fest.

  3. Klicken Sie auf "ERSTELLEN", um ein Feld leerer Platzhalter zu erstellen.

  4. Klicken Sie nacheinander auf die einzelnen Platzhalter, um diese zu markieren, und geben Sie jeweils eine Zahl, einen Ausdruck oder eine Zeichenfolge ein. Sie können sich auch mit der Tabulatortaste durch die Platzhalter bewegen.

Bei Feldern mit einer Formel, die den Wert eines Feldelements auf seine Indizes bezieht, ist die Arbeit mit Bereichsvariablen und tiefgestelltem Index einfacher. Diese Technik wird im folgenden Beispiel gezeigt:

i := 0 ..9

j := 0 ..9

X[i,j := i^2+j/2

Felder können auch erstellt werden durch:

direktes Lesen aus einer Datendatei

Importieren von Werten aus einer Datendatei

Definieren der einzelnen Elemente

Eingabe von Daten in eine Eingabetabelle

Verbinden mit einer anderen Anwendung, wie z. B. Excel oder MATLAB


BERECHNUNGEN MIT DATENFELDERN

Sie können eine Variable als Feld definieren und in Berechnungen verwenden. Gehen Sie hierzu folgendermaßen vor:

Klicken Sie auf einen leeren Bereich Ihres Arbeitsblatts, und geben Sie einen Variablennamen ein.

Wählen Sie den Befehl Matrix im Menü Einfügen. Es erscheint ein Dialogfeld .

Legen Sie in diesem Dialogfeld die Anzahl der Zeilen und Spalten fest.

Klicken Sie auf "Einfügen", und füllen Sie die Platzhalter aus.

Sie können nun in Gleichungen den Namen v anstelle des eigentlichen Vektors verwenden:

Felder sind nützlich bei der Durchführung paralleler Berechnungen.


ANZEIGEN VON VEKTOR- ODER MATRIXERGEBNISSEN

Es gibt zwei Möglichkeiten, einen Vektor bzw. eine Matrix anzuzeigen:

  • Wenn ein Feld weniger als zehn Zeilen und Spalten hat, wird es in Form einer Matrix angezeigt.

  • Wenn ein Feld mehr als neun Zeilen und Spalten hat, wird ein Teil von ihm als Ausgabetabelle mit Bildlaufleiste angezeigt.

Zum Ändern der Art und Weise, wie die Feldergebnisse angezeigt werden, ist wie folgt vorzugehen:

  1. Wählen Sie den Befehl Ergebnis im Menü Format. Das Dialogfeld "Ergebnisformat" erscheint.

  2. Klicken Sie unter "Matrix-Anzeigeformat" entweder auf "Matrix" oder auf "Tabelle". Soll sich diese Änderung auf alle Felder in Ihrem Arbeitsblatt auswirken, klicken Sie auf "Als Standard einrichten".


GRAFISCHE DARSTELLUNG EINES VEKTORS

Um die Elemente eines Vektors mit N Elementen grafisch darzustellen, gehen Sie wie folgt vor:

  1. Definieren Sie eine Bereichsvariable von 1 bis N.

  2. Drücken Sie @ (Alt Gr + Q), oder wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen. Es wird ein xy-Diagramm erstellt.

  3. Setzen Sie den tiefgestellten Vektor auf eine der Achsen und die Bereichsvariable auf die andere Achse.

Die grafische Darstellung eines Vektors mit einem anderen ist für die Abbildung von Datenpunkten von Nutzen. Geben Sie die x-Werte in einen Vektor und die y-Werte in einen anderen Vektor ein. Gehen Sie nun wie folgt vor:

  1. Drücken Sie @ (Alt Gr + Q), oder wählen Sie Diagramm / X-Y-Diagramm im Menü Einfügen. Es wird ein xy-Diagramm erstellt.

  2. Geben Sie den Namen des Vektors der x-Werte auf der horizontalen Achse ein.

  3. Geben Sie den Namen des Vektors der y-Werte auf der vertikalen Achse ein.

Hinweis: Mit ganz ähnlichen Schritten können Sie auch ein Kreisdiagramm eines Vektors erstellen. Fügen Sie dazu einfach den Operator "Kreisdiagramm" ein, indem Sie Diagramm / Kreisdiagramm im Menü Einfügen wählen, und füllen Sie den unteren und den linken Platzhalter aus.


Ändern der Größe eines Feldes

ÄNDERN DER GRÖSSE EINES FELDES:

Zum Verbinden von zwei Feldern nebeneinander gehen Sie folgendermaßen vor:

Verwenden Sie die Funktion erweitern, um ein m x n Elemente großes Feld mit einem m x p Elemente großen Feld zu kombinieren, so daß ein m x (n + p) Elemente großes Feld entsteht. Beispiel:

Zum Anordnen von zwei Feldern übereinander gehen Sie folgendermaßen vor:

Verwenden Sie die Funktion stapeln, um ein m x n Elemente großes Feld mit einem p x n Elemente großen Feld zu kombinieren, so daß ein (m + p) x n Elemente großes Feld entsteht. Beispiel:

Einfügen oder Löschen von Zeilen und Spalten:

Klicken Sie auf die folgenden Themen, um weitere Informationen zu erhalten:

Einfügen von Zeilen

Löschen von Zeilen

Einfügen von Spalten

Löschen von Spalten


Herausziehen von Elementen, Zeilen und Spalten

EXTRAHIEREN VON ELEMENTEN, ZEILEN UND SPALTEN:

Zum Zugriff auf ein Feldelement verwenden Sie den Tiefstellen -Operator und geben ein Gleichheitszeichen ein. Beispiel:

Zum Zugriff auf eine ganze Spalte verwenden Sie den Hochstellen -Operator wie folgt:

Zum Zugriff auf eine ganze Zeile verwenden Sie die Transponieren - und Hochstellen-Operatoren zusammen, wie unten gezeigt:


EXTRAHIEREN KLEINERER MATRIZEN AUS EINER MATRIX

submatrix(A,ir,jr,ic,jc) Gibt eine Matrix zurück, die aus den Zeilen ir bis jr und den Spalten ic bis jc des Feldes A besteht.

Argumente:

A ist ein Feld.

ir und jr sind die oberen und unteren Indizes der zu extrahierenden Zeilen.

ic und jc sind die oberen und unteren Indizes der zu extrahierenden Spalten.

Zum Extrahieren einer einzelnen Spalte können Sie den Operator "Hochgestellter Index" verwenden. Zum Extrahieren einer einzelnen Zeile können Sie den Operator "Transponieren" oder den Operator "Hochgestellter Index" verwenden.


Erstellen von Feldern, die bei einem anderen Element beginnen

ERSTELLEN VON FELDERN, DIE BEI EINEM ANDEREN ELEMENT ALS NULL BEGINNEN

Standardmäßig beginnen Mathcad-Felder beim Element Null. Sie können dies ändern, indem Sie den Wert der vordefinierten Variable ORIGIN mit einem der folgenden Schritte ändern:

Wählen Sie den Befehl Optionen / Vordefinierte Variablen im Menü Rechnen.

Legen Sie im Arbeitsblatt eine globale Definition für ORIGIN fest (dabei sind nur Großbuchstaben zulässig).

Wenn Sie ORIGIN in etwas anderes als Null ändern, sind manche Elemente möglicherweise dann nicht mehr vorhanden. Wenn Sie zum Beispiel ORIGIN in Eins ändern, weist Mathcad nicht mehr ein Element Null für Vektoren oder eine nullte Zeile und Spalte für Matrizen auf. Es wird eine Fehlermeldung angezeigt, wenn Sie versuchen, auf ein Element zuzugreifen, das nicht mehr vorhanden ist.


VEKTOR- UND MATRIXFUNKTIONEN

Verbinden von Feldern

erweitern(A,B)

stapeln(A,B)

Lösen der Verbindung von Feldern

submatrix(M, ir, jr, ic, jc)

Erstellen von Feldern

matrix(m,n,f)

Größe eines Felds

spalten(A)

zeilen(A)

länge(v)

letzte(v)

einheit(n)

Extreme eines Feldes

max(A)

min(A)

Spezielle Typen von Matrizen

diag(v)

geninv(A)

zref(A)

Spezielle Eigenschaften einer Matrix

tr(M)

rg(M)

norm1(M)

norm2(M)

norme(M)

normi(M)

cond1(M)

cond2(M)

conde(M)

condi(M)

Eigenwerte und Eigenvektoren

eigenwerte(M)

eigenvektoren(M)

eigenvek(M,z)

genwerte(M,N)

genvektoren(M,N)

Matrix-Zerlegung

cholesky(M)

qr(A)

lu(M)

svd(A)

svds(A)


VEKTOR- UND MATRIXOPERATOREN

Die im folgenden genannten Operatoren haben für Vektoren und Matrizen eine spezielle Bedeutung. Der größte Teil dieser Operatoren steht Ihnen zwar über die Symbolleiste "Symbolik" zur Verfügung, es gibt aber für alle einen entsprechenden Tastaturbefehl. Beachten Sie, daß für die Operatoren, die Vektoren erwarten, stets Spaltenvektoren eingegeben werden müssen, nicht Zeilenvektoren.

Operator: | Tastaturbefehl:
Addition | +
Vektorprodukt | Strg+8
Determinante | |
Division | /
Skalarprodukt (inneres Produkt) | *
Inversion | ^-1
absoluter Betrag | |
Multiplikation | *
Matrixpotenzen | ^
Negation | -
tiefgestellter Index (Vektor) | [
tiefgestellter Index (Matrix) | [
Subtraktion | -
Summe der Elemente | Strg+4
hochgestellter Index | Strg+6
Transponieren | Strg+1
Vektorisieren | Strg+-


Beschränkungen der Datenfeldgrößen

BESCHRÄNKUNGEN DER DATENFELDGRÖSSEN

Beschränkungen der Eingabefelder

Wenn Sie Matrix im Menü Einfügen wählen, ist es nicht möglich, ein Feld mit mehr als 100 Elementen zu erstellen. Sie können jedoch größere Felder folgendermaßen erstellen:

  • Verbinden kleinerer Felder

  • Lesen aus einer Datendatei

  • Verwenden von Bereichsvariablen

  • Erstellen einer Eingabetabelle

Beschränkungen der Datenfeldgrößen

  • Die jeweilige Beschränkung der Feldgröße hängt vom im System verfügbaren Speicherplatz ab. Pro Feldelement werden ca. 8 Byte Speicher benötigt. Bei den meisten Systemen liegt die Beschränkung der Feldgröße bei mindestens 1 Mio. Elemente. Mehr als 8 Millionen Elemente sind in keinem System möglich.

  • Wenn Sie ein Feldergebnis in Form einer Matrix anzeigen, zeigt Mathcad lediglich bis zu 200 Zeilen und Spalten an.


Erstellen von verschachtelten Feldern

ERSTELLEN VON VERSCHACHTELTEN FELDERN (nur in Mathcad Professional)

Die Elemente eines Feldes können selbst Felder sein. Das Erstellen eines verschachtelten Feldes geschieht auf die gleiche Art und Weise wie das Erstellen von anderen Feldern. Der einzige Unterschied besteht darin, daß Sie den Befehl Matrix im Menü Einfügen nicht verwenden können, wenn sich der gewählte Platzhalter bereits in einer Matrix befindet.

Die einfachste Möglichkeit, ein Feldelement zu definieren, das selbst ein Feld ist, ist die folgende:

Weisen Sie dem Feld einem Variablennamen zu.

Definieren Sie das Matrixelement mit Hilfe dieses Variablennamens:

Das 1,1. Element von M ist nun der Vektor v.


ARBEITEN MIT ZEICHENFOLGEN

In erster Linie werden Variablen und Funktionen mit Zahlen oder mit weiteren Variablen und Funktionen definiert. Sie können sie jedoch auch als Folge von Textzeichen (Zeichenfolge) definieren. Sie können Variablen, Funktionen und Felder als Zeichenfolge definieren, indem Sie sie in doppelte Anführungszeichen setzen.

Die meisten vordefinierten Funktionen und Operatoren sind für Zeichenfolgen ungeeignet. Allerdings stehen mehrere Funktionen speziell für Zeichenfolgen zur Verfügung, mit denen Sie Zeichenfolgen zusammenfassen, Subzeichenfolgen suchen, die Länge einer Zeichenfolge bestimmen und Zeichenfolgen in Zahlen und Vektoren oder umgekehrt umwandeln können.

Definieren einer Zeichenfolgenvariable

Definieren einer Zeichenfolgenfunktion

Definieren eines Feldelements als Zeichenfolge

Integrierte Zeichenfolgefunktionen


DEFINIEREN EINER ZEICHENFOLGENVARIABLE

Zum Definieren einer Variable als Zeichenfolge gehen Sie wie folgt vor:

Geben Sie den Variablennamen ein.

Geben Sie ":" ein, um das Zeichen":=" mit einem Platzhalter zu erstellen.

Geben Sie ein Anführungszeichen (") ein. Zwischen den beiden Anführungszeichen können Sie eine Einfügelinie erkennen.

Geben Sie eine Kombination aus Buchstaben, Ziffern und/oder anderen Zeichen ein. Drücken Sie danach die Eingabetaste.


DEFINIEREN EINER ZEICHENFOLGENFUNKTION

Zur Definition einer Funktion mit einer Zeichenfolge gehen Sie folgendermaßen vor:

Geben Sie den Funktionsnamen zusammen mit seiner Argumentliste ein.

Geben Sie ":" ein, damit das Zeichen ":=" mit einem Platzhalter erstellt wird.

Geben Sie ein Anführungszeichen (“) ein. Zwischen den beiden Anführungszeichen können Sie eine Einfügelinie erkennen.

Geben Sie eine Kombination aus Buchstaben, Ziffern und/oder anderen Zeichen ein. Drücken Sie die Pfeil-nach-Rechts-Taste, um die Zeichenfolge zu verlassen.


Verketten zweier Zeichenfolgen

VERKETTEN ZWEIER ZEICHENFOLGEN (nur in Mathcad Professional)

verkett(S1, S2, S3, ...) Gibt eine Zeichenfolge zurück, die durch Anhängen der Zeichenfolge S2 an das Ende der Zeichenfolge S1, der Zeichenfolge S3 an das Ende der Zeichenfolge S2 usw. entsteht.

Argumente:

S1, S2, S3, ... sind Zeichenfolgen.

Beispiel:


Ermitteln der Länge einer Zeichenfolge

ERMITTELN DER LÄNGE EINER ZEICHENFOLGE (nur in Mathcad Professional)

zflänge(S) Gibt die Zahl der Zeichen in S zurück.

Argumente:

S ist eine Zeichenfolge bzw. ein Ausdruck, der eine Zeichenfolge zurückgibt.

Beispiel:


Umwandeln einer Zeichenfolge in eine Zahl

UMWANDELN EINER ZEICHENFOLGE IN EINE ZAHL (nur in Mathcad Professional)

zfinzahl(S) Gibt eine Konstante zurück, die gleich der in S enthaltenen Zahl ist.

Argumente:

S ist eine Zahlenzeichenfolge oder ein Ausdruck, der eine Zahlenzeichenfolge zurückgibt.

Diese Funktion ist praktisch, wenn Sie Berechnungen für eine aus Zahlen bestehende Zeichenfolge anstellen möchten.

Beispiel:


Umwandeln einer Zahl in eine Zeichenfolge

UMWANDELN EINER ZAHL IN EINE ZEICHENFOLGE (nur in Mathcad Professional)

zahlinzf(x) Gibt die zu x äquivalente Zahlenzeichenfolge zurück.

Argumente:

x ist eine Konstante oder ein Ausdruck, der eine Konstante zurückgibt.

Diese Funktion ist nützlich, wenn eine Zahl als Zeichenfolge leichter verarbeitet werden kann als auf mathematische Weise.

Beispiel:


Umwandeln eines Vektors in eine Zeichenfolge

UMWANDELN EINES VEKTORS IN EINE ZEICHENFOLE (nur in Mathcad Professional)

vekinzf(v) Gibt eine Zeichenfolge zurück, die durch Umwandeln der ASCII-Codes in v entsteht.

Argumente:

v ist ein Vektor aus ganzen Zahlen zwischen 0 und 255.

Beispiel:


Umwandeln einer Zeichenfolge in einen Vektor

UMWANDELN EINER ZEICHENFOLGE IN EINEN VEKTOR (nur in Mathcad Professional)

zfinvek(S) Gibt einen Vektor aus ASCII-Codes zurück, der durch Umwandeln der Zeichen in S entsteht.

Argumente:

S ist eine Zeichenfolge.

Beispiel:


Extrahieren einer Subzeichenfolge

EXTRAHIEREN EINER SUBZEICHENFOLGE (nur in Mathcad Professional)

subzf(S,m,n) Gibt die Subzeichenfolge von S zurück, die aus den m Zeichen ab der Position n besteht.

Argumente:

S ist eine Zeichenfolge.

n ist die Position des ersten Zeichens in der gewünschten Subzeichenfolge. n muß als natürliche ganze Zahl angegeben werden.

m ist die maximal mögliche Länge der Subzeichenfolge. m muß als natürliche ganze Zahl angegeben werden.

Beispiel:


Suchen einer Subzeichenfolge

SUCHEN EINER SUBZEICHENFOLGE (nur in Mathcad Professional)

strtpos(S,SubS,m) Gibt die Anfangsposition von SubS in S zurück , die bei Beginn der Suche an Position m gefunden wurde. Gibt als Ergebnis -1 zurück, falls SubS nicht gefunden wurde.

Argumente:

S ist eine Zeichenfolge.

SubS ist eine Subzeichenfolge von S.

m ist eine nicht-negative ganze Zahl, die die Position in S angibt, an der die Suche gestartet wird.

Beispiel:


Benutzerdefinierte Fehlermeldungen

BENUTZERDEFINIERTE FEHLERMELDUNGEN (nur in Mathcad Professional)

fehl(S) Gibt S als Fehlermeldung zurück.

Argumente:

S ist ein Zeichenfolge.

Beispiel:


VORDEFINIERTE FUNKTIONEN

Sie können beliebige der vordefinierten Funktionen aus der folgenden Liste einfügen, wenn Sie den Befehl Funktion im Menü Einfügen wählen und so das Dialogfeld "Funktion einfügen" öffnen. Sie haben außerdem die Möglichkeit, die Namen der vordefinierten Funktionen genau so einzugeben, wie sie in den Hilfeseiten gezeigt werden, die ihre Beschreibungen enthalten.

Besselfunktionen

Komplexe Funktionen

Bedingte Funktionen

Kurvenanpassungsfunktionen

Datenanalyse

Lösungsalgorithmen für Differentialgleichungen

Unstetige Funktionen

Diskrete Umwandlungen

Verteilungsfunktionen

Funktionen zum Lösen von Gleichungen

Fehlerfunktion und komplementäre Fehlerfunktion

Exponential- und logarithmische Funktionen

Ausdruckstyp

Dateizugriffsfunktionen

Funktionsoptimierung

Histogrammfunktionen

Hyperbolische Funktionen

Interpolation

Bildlesefunktionen

Bildschreibefunktionen

Invers hyperbolisch

Invers trigonometrisch

Verschiedene Funktionen

Optimierung

Populationsstatistik

Prognosefunktionen

Zufallszahlengenerierung

Regressionsfunktionen

Rundungs- und Abbruchfunktionen

Datenglättungsfunktionen

Lösungsfunktionen

Sortierfunktionen

Spezielle Funktionen

Statistische Funktionen

Zeichenfolgefunktionen

Symbolische Berechnung

Trigonometrische Funktionen

Vektor- und Matrixfunktionen


ARITHMETISCHE OPERATOREN

Jeder Operator kann auch mit Hilfe der Tastatur eingegeben werden. Die meisten Operatoren sind auch über die Schaltflächen der Operator-Schaltflächen auf der Symbolleiste "Rechnen" verfügbar.

Operator: | Tastaturbefehl:
Addition mit Zeilenumbruch | Strg+Eingabe
Addition | +
konjungiert-komplexe Zahl | "
Division | /
Fakultät | !
Potenzieren | ^
Betrag | |
Multiplikation | *
Negation | -
n-te Wurzel | Strg+\
Produkt | Strg+Umschalt+3
Bereichsprodukt | #
Bereichssumme | $
Quadratwurzel | \
Subtraktion | -
Summation | Strg+Umschalt+4


Operatioren für die Differential- und Integralrechnung

OPERATOREN FÜR DIE DIFFERENTIAL- UND INTEGRALRECHNUNG

Jeder Operator kann auch mit Hilfe der Tastatur eingegeben werden. Die meisten Operatoren sind darüber hinaus über die Symbolleiste "Differential/Integral" der Symbolleiste "Rechnen" verfügbar.

Operator: | Tastaturbefehl:
Ableitung | ?
n-te Ableitung | Strg+?
Bestimmtes Integral | &
Unbestimmtes Integral | Strg+I
Summation | Strg+Umschalt+4
Summation mit Bereichsvariablen | Strg+4
Iteriertes Produkt | Strg+Umschalt+3
Iteriertes Produkt mit Bereichsvariablen | Strg+3
Zweiseitiger Grenzwert | Strg+L
Linker Grenzwert | Strg+A
Rechter Grenzwert | Strg+B


BOOLESCHE OPERATOREN

Boolesche Operatoren unterscheiden sich von anderen Operatoren dadurch, das sie nur eine Null oder eine Eins zurückgeben. Trotzdem können sie sehr hilfreich sein.

Operator: | Tastaturbefehl:
größer als | >
kleiner als | <
größer gleich | Strg+0
kleiner gleich | Strg+9
gleich | Strg+=
ungleich | Strg+3


Benutzerdefinierte Operatoren im Überblick

BENUTZERDEFINIERTE OPERATOREN (nur in Mathcad Professional)

Operatoren und Funktionen entsprechen einander weitgehend. Beide werden mit "Argumenten" versehen und geben Ergebnisse aus. Mathcad ermöglicht daher die Definition eigener Operatoren ebenso, wie Sie eigene Funktionen definieren können. Sie können Operatoren definieren, die nur ein Argument oder zwei Argumente annehmen.

Definieren von Binäroperatoren

Definieren von einstelligen Operatoren

Verwenden von selbstdefinierten Binäroperatoren

Verwenden von selbstdefinierten einstelligen Operatoren

Verwenden von QuickSheets zum Speichern selbstdefinierter Operatoren


DATENANALYSEFUNKTIONEN

kvar(A,B)

Kovarianz der Elemente in den beiden aus m x n bestehenden Feldern A und B.

korr(A,B)

Pearsonscher Korrelationskoeffizient für die beiden aus m x n bestehenden Felder A und B.

gcd(v)

Größter gemeinsamer Divisor der Elemente in v.

gmean(v)

Geometrischer Mittelwerte der Elemente in v.

hmean(v)

Harmonischer Mittelwert der Elemente in v.

kurt(v)

Häufigkeitsgrad der Elemente in v.

lcm(v)

Geringstes gemeinsames Vielfaches der Elemente in v.

mittelwert(A)

Arithmetischer Mittelwert der Elemente in Feld A.

median(A)

Schnittpunkt der Elemente in Feld A.

mode(v)

Modus der Elemente im Vektor v.

skew(v)

Asymmetrie der Elemente von v.

stdev(A) oder Stdev(v)

Standardabweichung einer Gesamtzahlmatrix A oder eines Mustervektors v.

var(A) oder Var(v)

Varianz einer Gesamtzahlmatrix A oder eines Mustervektors v.


Verteilungsfunktionen

DICHTE- UND VERTEILUNGSFUNKTIONEN

Funktionen für die Arbeit mit allgemeinen Wahrscheinlichkeitsdichten gehören zu folgenden Kategorien:

Wahrscheinlichkeitsdichten - Diese geben die Wahrscheinlichkeit, mit der eine Zufallsvariable einen bestimmten Wert annimmt.

Kumulative Wahrscheinlichkeitsverteilungen - Diese geben die Wahrscheinlichkeit, daß eine Zufallsvariable einen Wert annimmt, der geringer oder gleich einem festgelegten Wert ist. Sie ergeben sich aus der einfachen Integration (oder gegebenenfalls Summierung) der entsprechenden Wahrscheinlichkeitsdichte über einen geeigneten Zeitraum.

Umgekehrte Wahrscheinlichkeitsverteilungen - Diese Funktionen erhalten eine Wahrscheinlichkeit als Argument und haben ein Ergebnis wie die Wahrscheinlichkeit, daß eine Zufallsvariable geringer oder gleich dem Wert ist (je nach der als Argument angegebenen Wahrscheinlichkeit).

Wählen Sie eine der folgenden Verteilungen:

Beta-Verteilung

Binomialverteilung

Cauchy-Verteilung

Chi-Quadrat-Verteilung

Exponentialverteilung

F-Verteilung

Gamma-Verteilung

Geometrische Verteilung

Hypergeometrische Verteilung

Logarithmische Normalverteilung

Logistische Verteilung

Negative Binomialverteilung

Normalverteilung

Poisson-Verteilung

Studentsche t-Verteilung

Gleichmäßige Verteilung

Weibull-Verteilung


ZUFALLSZAHLENGENERATOREN

Die unten aufgeführten Zufallszahlengeneratoren verwenden zur Generierung einer Folge von Zufallszahlen den Rekursivwert 1. Soll eine andere Folge von Zufallszahlen generiert werden, müssen Sie den Rekursivwert ändern. Wählen Sie dazu den Befehl Optionen aus dem Menü Rechnen, klicken Sie auf die Registerkarte "Vordefinierte Variablen", und geben Sie einen Rekursivwert ein.

Beta-Verteilung

Binomialverteilung

Cauchy-Verteilung

Chi-Quadrat-Verteilung

Exponentialverteilung

F-Verteilung

Gammaverteilung

geometrische Verteilung

logarithmische Normalverteilung

logistische Verteilung

negative Binomialverteilung

Normalverteilung

Poisson-Verteilung

Studentsche t-Verteilung

gleichmäßige Verteilung

Weibull-Verteilung


KUBISCHE SPLINE-INTERPOLATION

kspline(vx,vy) Gibt einen Vektor aus den zweiten Ableitungen für die Datenvektoren vx und vy zurück. Dieser Vektor wird als das erste Argument der Funktion interp verwendet. Die sich dabei ergebende Spline-Kurve ist an den Endpunkten kubisch.

pspline(vx,vy) Wie kspline, die sich ergebende Spline-Kurve ist an den Endpunkten jedoch parabolisch.

lspline(vx,vy) Wie kspline, die sich ergebende Spline-Kurve ist an den Endpunkten jedoch linear.

interp(vs,vx,vy,x) Führt eine Spline-Interpolation von vy am Punkt x aus und gibt den sich dabei ergebenden Wert zurück.

Argumente:

vx ist ein Vektor aus reellen Datenwerten in aufsteigender Reihenfolge. Diese entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. vy hat die gleiche Anzahl von Elementen wie vx.

vs ist ein Vektor, der von kspline, pspline oder lspline generiert wurde.

x ist der Wert der unabhängigen Variable, an der das Ergebnis interpoliert werden soll. Dieser Wert sollte innerhalb des von vx angegebenen Bereichs liegen.

Durch kubische Spline-Interpolation können Sie eine Kurve so über eine Reihe von Punkten legen lassen, daß die erste und die zweite Ableitung der Kurve bei jedem Punkt stetig ist. Die Kurve wird dadurch zusammengesetzt, daß ein kubisches Polynom über jeweils drei benachbarten Punkten konstruiert wird. Diese kubischen Polynome werden dann zusammengesetzt und ergeben die vollständige Kurve.

Das folgende Beispiel zeigt die Verwendung der kubischen Spline-Interpolation:


Kurvenanpassung

KURVENANPASSUNGSFUNKTIONEN

Lineare Regression

neigung(vx,vy) und achsenabschn(vx,vy)

Werden beide Funktionen zusammen verwendet, kann mit ihnen die Linie ermittelt werden, die bestimmten Datenpunkten am ehesten entspricht.

Polynomregression

regress(vx,vy,k)

Ermittelt das Polynom, das bestimmten Datenpunkten am ehesten entspricht.

loess(vx,vy,span)

Ermittelt die Polynome zweiten Grades, die bestimmten Umgebungen von Datenpunkten am ehesten entsprechen.

Multivariable Polynomregression

regress(Mxy,vz,k)

Ermittelt die Polynomfläche, die bestimmten Datenpunkten am ehesten entspricht.

loess(Mxy,vz,span)

Ermittelt die Polynome zweiten Grades, die bestimmten Umgebungen von Datenpunkten am ehesten entspechen.

Generalisierte Regression

linanp(vx,vy,F)

Ermittelt die Koeffizienten, bei denen eine lineare Kombination von Funktionen bestimmten Datenpunkten am ehesten entspricht.

genanp(vx,vy,vg,F)

Ermittelt die Parameter, bei denen eine von Ihnen festgelegte Funktion bestimmten Datenpunkten am ehesten entspricht.


DATENGLÄTTUNG

Bei der Datenglättung wird auf der Grundlage eines Satzes von y- und möglicherweise x-Werten ein neuer Satz von y-Werten ausgegeben, der im Vergleich zum ursprünglichen Satz glatter ist.

medgltt(vy,n)

Gibt einen aus m Elementen bestehenden Vektor zurück, der durch Glätten von vy mit gleitenden Mittelwerten über einem Fenster der Breite n erstellt wird.

kgltt(vx,vy,b)

Gibt einen aus m Elementen bestehenden Vektor zurück, der durch Glätten mit Hilfe eines Gaußschen Kerns erstellt wird, um gewichtete Mittel der Elemente in vy zurückzugeben.

strgltt(vx,vy)

Gibt einen aus m Elementen bestehenden Vektor zurück, der durch die stückweise Ausführung eines symmetrischen linearen MKQ-Anpassungsverfahrens unter Berücksichtigung des k am nächsten stehenden Nachbarn erstellt wird, wobei k der jeweiligen Situation angepaßt wird.


INTERPOLATION UND PROGNOSE

In Mathcad stehen Ihnen drei Interpolationsverfahren und ein Verfahren für die lineare Prognose zur Verfügung:

Lineare Interpolation: Verbinden von Punkten mit einer geraden Linie

Kubische Spline-Interpolation: Verbinden von Punkten mit einem kubischen Abschnitt

B-Spline-Interpolation: Verbinden von Punkten mit Polynomen eines bestimmten Grades an gegebenen Knoten

Multivariable kubische Spline-Interpolation: Erstellen einer Fläche durch ein Punktgitter

Lineare Prognose: Bestimmen von Werten über einen bestimmten Datensatz hinaus


Lineare Prognose

LINEARE PROGNOSE (nur in Mathcad Professional)

prognose(v,m,n) Gibt einen Vektor aus n prognostizierten Werten auf der Grundlage von m aufeinanderfolgenden Elementen von v zurück.

Argumente:

v ist ein Vektor, dessen Werte Stichproben entsprechen, die in gleichen Intervallen entnommen wurden.

m und n sind ganze Zahlen.

Die Funktion prognose prognostiziert anhand der vorhandenen Daten Datenpunkte, die hinter den vorhandenen liegen. Sie verwendet einen linearen Prognosealgorithmus, der von großem Vorteil ist, wenn die Daten gleichförmig und oszillierend sind (aber nicht unbedingt periodisch sein müssen). Die lineare Prognose kann als eine Art Extrapolationsverfahren angesehen werden, ist jedoch nicht mit Linear- oder Polynomextrapolation zu verwechseln.

Das folgende Beispiel zeigt, wie Sie die lineare Prognose verwenden können:


LÖSEN UND OPTIMIEREN – ÜBERBLICK

In Mathcad können Sie mit Hilfe der verschiedenen vordefinierten Funktionen eine Vielzahl von Optimierungsproblemen numerisch lösen. Wenn Sie eine einzelne Gleichung nach einem unbekannten Wert auflösen möchten, steht Ihnen die Funktion wurzel zur Verfügung. Zum Lösen eines Gleichungssystems können Sie auf die Funktion Suchen oder Minfehl zurückgreifen. Die Funktion Suchen sollten Sie verwenden, wenn Sie eine genaue Lösung haben wollen, die Funktion Minfehl dagegen, wenn Ihnen eine ungefähre Lösung reicht.

Mit den Mathcad-Funktionen Minimieren und Maximieren können Sie Optimierungsprobleme lösen, bei denen Sie nach Werten suchen, die eine Funktion minimieren bzw. maximieren. Zu diesen Problemen gehört auch das lineare Programmieren.

Zum Lösen einer einzelnen Differentialgleichung bzw. eines Systems von Differentialgleichungen stehen ebenfalls eine Reihe von Funktionen zur Verfügung.

Lösen einer Gleichung mit einer Unbekannten

Lösen eines Gleichungssystems

Näherungsweises Lösen eines Gleichungssystems

Optimieren einer nichtlinearen Funktion

Optimieren einer linearen Funktion

Lösen von Differentialgleichungen

Wirkungsweise der Lösungs- und Optimierungsfunktionen

Symbolisches Lösen von Gleichungen


LÖSEN EINER GLEICHUNG MIT EINER UNBEKANNTEN

Solche Gleichungen können folgendermaßen dargestellt werden:

f(x) = g(x)

Wird diese Gleichung vereinfacht, ergibt sich:

f(x) - g(x) = 0

Die Lösung wird durch die Funktion wurzel ermittelt:

wurzel(f(x) - g(x),x)

Beispiel:

Gegeben sei die Gleichung:

cos(x) = x + .2

Die Gleichung könnten Sie wie folgt lösen:

x := 1<--- Schätzwert

wurzel(cos(x) - x - .2,x) =

Bei diesem Beispiel gibt der Schätzwert der Funktion wurzel an, wo mit der Suche nach einer Wurzel begonnen werden soll.


Lösen linearer Systeme

LÖSEN LINEARER SYSTEME (nur in Mathcad Professional)

llösen(M,v) Gibt den Lösungsvektor für das lineare Gleichungssystem Mx = v zurück.

Argumente:

M it eine quadratische, nicht-singuläre Matrix.

v ist ein Vektor, der ebenso viele Zeilen aufweist wie M.


LÖSEN EINES SYSTEMS NICHTLINEARER GLEICHUNGEN

Im folgenden Beispiel wird gezeigt, wie zwei nichtlineare Gleichungen mit zwei Unbekannten mit Hilfe der Funktion suchen aufgelöst werden.


ANNÄHERUNGSLÖSUNG AN EIN SYSTEM NICHTLINEARER GLEICHUNGEN

Im folgenden Beispiel wird gezeigt, wie Sie mit der Funktion minfehl die Werte finden, die einer Lösung für ein System von Gleichungen am nächsten kommen.


WURZELN SUCHEN

wurzel(f(var1, var2, ...),var1) Gibt den Wert von var1 zurück, bei dem die Funktion f gleich Null ist.

nullstellen(v)Gibt einen Vektor zurück, der alle Wurzeln des Polynoms enthält, dessen Koeffizienten in v enthalten sind.

Argumente:

f ist eine skalarwertige Funktion einer beliebigen Anzahl von Variablen.

var1 ist eine skalare Variable in f. var1 im zweiten Argument ist die Variable, für die die Wurzel gefunden wird.

v ist ein Vektor mit Koeffizienten eines Polynoms, in dem das erste Element das konstante Glied ist.

Hinweise:

  • Die Funktion wurzel erfordert die Angabe eines Schätzwerts, bei dem das Ermitteln der Wurzel(n) begonnen werden soll. Bei Funktionen mit einer Vielzahl von Wurzeln hängt die zurückgegebene Wurzel davon ab, welcher Schätzwert eingegeben wurde. Befindet sich der Schätzwert sehr nahe an einem Minimum oder Maximum von f, kann es passieren, daß die Funktion wurzel nicht konvergiert bzw. an eine Wurzel konvergiert, die weit vom Schätzwert entfernt ist.


ARBEITEN MIT DEN FUNKTIONEN "maximieren" UND "minimieren"

Im Beispiel unten ist eine nichtlineare Optimierung mit Hilfe der Funktion m aximieren dargestellt:

Im Beispiel unten ist eine nichtlineare Optimierung mit Hilfe der Funktion minim ieren dargestellt:


SYMBOLISCHES LÖSEN EINER GLEICHUNG

Zum Auflösen von Gleichungen gehen Sie wie folgt vor:

  1. Geben Sie die linke Seite der Gleichung ein.

  2. Drücken Sie Strg+= zur Erstellung des Gleichheitszeichen. (Soll die Wurzel eines Ausdrucks gefunden werden, können Sie diesen Schritt überspringen und mit Schritt 4 fortfahren.)

  3. Geben Sie in den verbleibenden Platzhalter die rechte Seite der Gleichung ein.

  4. Wählen Sie die Variable aus, nach der aufgelöst werden soll.

  5. Wählen Sie den Befehl Variable / Auflösen im Menü Symbolik.

Mathcad löst nach der Variable auf und fügt das Ergebnis im Arbeitsblatt ein. Gibt es für die Gleichung mehrere Lösungen, wird ein Vektor mit je einem Element pro Lösung angezeigt. Enthält die Gleichung Dezimalzahlen, wird auch die Antwort dezimal angezeigt. Andernfalls erscheint eine genaue Lösung (soweit verfügbar).

Zur Auflösung einer Ungleichung folgen Sie obigen Anweisungen. Drücken Sie jedoch anstelle von Strg+= die Tasten >, <, Strg+( bzw. Strg+).

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Bewertung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


SYMBOLISCHES LÖSEN VON GLEICHUNGSSYSTEMEN

Zum symbolischen Lösen eines Gleichungssystems gehen Sie wie folgt vor:

  1. Geben Sie das Wort Vorgabe ein.

  2. Geben Sie unterhalb von Vorgabe die Gleichungen und Ungleichungen ein.

  3. Geben Sie die Funktion Suchen ein, wobei als Argumente die Unbekannten zu verwenden sind.

  4. Drücken Sie die Tastenkombination Strg+. (Punkt). In Ihrem Dokument erscheint ein nach rechts zeigender Pfeil (symbolisches Gleichheitszeichen).

  5. Klicken Sie auf eine Stelle außerhalb der Funktion Suchen. Mathcad gibt das Ergebnis in einem Vektor an. Die Ergebnisse haben dieselbe Reihenfolge wie die Argumente der Funktion Suchen.

Beispiel:


Differentialgleichungen (allgemein)

DIFFERENTIALGLEICHUNGEN

Gewöhnliche Differentialgleichungen

Lösen einer gewöhnlichen Differentialgleichung n-ter Ordnung mit Hilfe von rkfest.

Systeme von Differentialgleichungen

Lösen eines Systems mit n gewöhnlichen Differentialgleichungen mit Hilfe von rkfest

Differentialgleichungen mit besonderen Eigenschaften

Verwenden der Funktion Bulstoer für stetige Systeme, der Funktionen Stiffb und Stiffr für steife Systeme und Rkadapt für sich langsam ändernde Systeme

Einschränkung auf letzten Punkt

Zu verwendende Funktionen, wenn Sie nur der Lösungswert am letzten Punkt im Integrationsintervall interessiert

Zweipunktrandwertprobleme

Verwenden von grwanp und sgrw zum Konvertieren eines Zweipunktrandwertproblems in ein Anfangswertproblem, das sich durch rkfest lösen läßt

Teildifferentialgleichungen

Lösen von Poissonschen Gleichungen in einem quadratischen Bereich mit Hilfe von relax und multigit


ÜBERBLICK ÜBER DIE DATENVERWALTUNG

Mathcad enthält Komponenten zum Austausch von Daten zwischen Mathcad und anderen Anwendungen. Eine Komponente kommuniziert mit den mathematischen Gleichungen in Mathcad, wobei die Mathcad-Berechnungen mit der restlichen Rechenumgebung verknüpft werden. Durch diese Verknüpfung können Daten dynamisch zwischen dem Mathcad-Arbeitsblatt und einer Datenquelle oder Anwendung fließen.

Einige Komponenten dienen dem Importieren, andere dem Exportieren von Daten, und Anwendungskomponenten wie Excel, Axum und MATLAB ermöglichen die Kommunikation mit anderen im Computer installierten Anwendungen.

In Mathcad sind zwar nur begrenzt Komponenten verfügbar, aber es können auch weitere Komponenten in MathConnex verwendet werden.

Einführung in Komponenten

Importieren von Daten

Exportieren von Daten

Austauschen von Daten mit anderen Anwendungen

Verwenden von MathConnex


IMPORTIEREN VON DATEN

Sie können Daten in Mathcad übernehmen, indem Sie sie einmalig aus einer Datei importieren, sie aus einer Datei einlesen oder aus der Zwischenablage einfügen. Bei allen diesen Methoden werden Felder Ihrer Daten erstellt. Sie können die Daten natürlich auch in eine Eingabetabelle oder eine Matrix eingeben.

Importieren von Daten aus einer Datendatei

Lesen von Daten aus einer Datendatei

Erstellen einer Zahlentabelle

Erstellen einer Matrix oder eines Vektors

Einfügen von Daten aus der Zwischenablage


DATEIZUGRIFFSFUNKTIONEN

PRNLESEN("datei")

Liest ein aus mehreren Werten bestehendes Feld aus einer Datendatei.

PRNSCHREIBEN("datei")

Schreibt ein aus mehreren Werten bestehendes Feld in eine Datendatei.

PRNANFÜGEN("datei")

Fügt einer bereits bestehenden Datendatei ein aus mehreren Werten bestehendes Feld hinzu.

RGBLESEN("datei")

Liest eine Farbbilddatei.

BMPLESEN("datei")

Liest eine Bilddatei als Graustufenbild.

RGBSCHREIBEN("datei")

Erstellt eine Farbbilddatei.

BMPSCHREIBEN("datei")

Erstellt eine Graustufenbilddatei.

Spezielle Funktionen zum Einlesen von Bilddateien

Liest Bilder in den folgenden Formaten: BMP, GIF, JPG und TGA.

Spezielle Funktionen zum Schreiben von Bilddateien

Erstellt Bilddateien in speziellen Formaten.


LESEN VON DATEN AUS EINER DATENDATEI

Wenn Sie Daten aus einer Datendatei lesen lassen wollen, um sie in Ihr Mathcad-Arbeitsblatt einzufügen, können Sie die Komponente "Dateien lesen/schreiben" verwenden. Mit Hilfe der Komponente "Dateien lesen/schreiben" können Sie eine Verbindung zu einer Datendatei herstellen, die Daten aus dieser Datei lesen lassen, und diese dann einer Mathcad-Variable zuordnen. Wenn sich die Daten in der Datendatei ändern, werden sie sofort automatisch auch im Mathcad-Arbeitsblatt aktualisiert.

Zum Lesen der Daten aus einer Datendatei mit Hilfe der Komponente "Dateien lesen/schreiben" gehen Sie wie folgt vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle.

  2. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  3. Markieren Sie die Komponente "Dateien lesen/schreiben" in der Liste, und klicken Sie auf "Weiter". Dadurch wird der erste Teil des Setup-Assistenten "Dateien lesen/schreiben" gestartet.

  4. Wählen Sie den Befehl "Daten aus einer Datei lesen", und klicken Sie auf "Weiter", um zur zweiten Seite des Assistenten zu gehen.

  5. Wählen Sie im Assistenten aus der Dropdown-Liste "Dateiformat:" den Typ der Datei aus, die eingelesen werden soll.

  6. Geben Sie den Pfad der zu lesenden Datendatei ein, oder klicken Sie auf die Schaltfläche "Durchsuchen", um nach dem Pfad zu suchen.

  7. Klicken Sie auf "Fertig stellen". Daraufhin wird das Symbol der Komponente "Dateien lesen/schreiben" zusammen mit dem Pfad der Datendatei angezeigt.

  8. Geben Sie im links angezeigten Platzhalter den Namen der Mathcad-Variable ein, der die Daten aus der Datei zugewiesen werden sollen.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, wird die Datendatei gelesen, und die Daten werden der im Platzhalter angegebenen Mathcad-Variable zugeordnet. Sie können dieses Mathcad-Feld nun mit Hilfe der vordefinierten Funktionen und Operatoren ganz nach Ihren Wünschen bearbeiten. Jedesmal, wenn Sie das Arbeitsblatt berechnen, liest Mathcad die Daten aus der von Ihnen angegebenen Datei neu.


EINFÜGEN VON DATEN AUS DER ZWISCHENABLAGE

Es kann vorkommen, daß Sie Daten in einer Tabellenkalkulation oder einer anderen Anwendung haben, die in Ihrem Arbeitsblatt verwendet werden sollen, ohne daß sie als Datei importiert oder gelesen werden. Eine Alternative zum Importieren einer Datei besteht darin, die Daten über die Zwischenablage in Ihr Mathcad-Arbeitsblatt zu kopieren. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie die Daten in der anderen Anwendung aus, und kopieren Sie sie in die Zwischenablage. In den meisten Fällen geschieht dies mit Hilfe des Befehls Kopieren im Menü Bearbeiten.

  2. Öffnen Sie das Mathcad-Arbeitsblatt, in dem die Daten verwendet werden sollen.

  3. Geben Sie im Mathcad-Arbeitsblatt eine Variablendefinition wie z. B. m:= ein.

  4. Klicken Sie auf den Platzhalter rechts neben := und wählen Sie Einfügen aus dem Menü Bearbeiten.

Im Arbeitsblatt erscheint eine Matrix mit den kopierten Daten.


EINGEBEN EINER WERTETABELLE

Sie können Werte direkt in Mathcad eingeben und diese mit Hilfe einer Eingabetabelle einer Mathcad-Variable zuordnen. Gehen Sie dazu wie folgt vor:

  1. Klicken Sie auf eine leere Stelle in Ihrem Arbeitsblatt, und wählen Sie den Befehl Komponente im Menü Einfügen.

  2. Wählen Sie die Option "Eingabetabelle", und klicken Sie auf "OK".

  3. Geben Sie in den Platzhalter, der links erscheint, den Namen der Mathcad-Variable ein, der die Werte zugeordnet werden sollen.

  4. Klicken Sie auf die Tabelle, und geben Sie in die Zellen Daten (Zahlen) ein. Bei den eingegebenen Zahlen kann es sich um dezimale Zahlen oder Zahlen im e-Format handeln, wie z. B. 3,4, 2i oder 4e-6.

Wenn Sie eine Eingabetabelle erstellen, erstellen Sie eigentlich ein Feld mit dem Namen, den Sie in den Platzhalter eingegeben haben. Nachdem Sie ein Feld mit Hilfe der Eingabetabelle erstellt haben, können Sie das Feld mit den vordefinierten Funktionen und Operatoren von Mathcad ändern.

Hinweise:

  • In eine Tabelle können nur Zahlen, aber keine mathematischen Ausdrücke eingegeben werden.

  • In jeder Zeile müssen sich gleich viele Datenwerte befinden. Wenn Sie in eine Zelle keine Zahl eingeben, erhält diese Zelle automatisch den Wert 0.

  • Sie können auch Werte, die Sie aus einer anderen Anwendung kopiert haben, in eine Eingabetabelle einfügen. Statt die Werte in die Zellen der Tabelle einzugeben, können Sie auch mit der rechten Maustaste auf die Tabelle klicken und im Kontextmenü den Befehl Einfügen wählen.


EXPORTIEREN VON DATEN

Nachdem Sie Berechnungen in Mathcad vorgenommen haben, können Sie die Ergebnisse in eine Datendatei exportieren oder schreiben bzw. die Ergebnisse in die Zwischenablage stellen, von wo aus sie in andere Anwendungen eingefügt werden können.

Exportieren von Daten in eine Datendatei

Schreiben von Daten in eine Datendatei

Kopieren bzw. Verschieben von Daten in die Zwischenablage


EXPORTIEREN VON DATEN IN EINE DATENDATEI

Zum Exportieren von Daten in eine Datendatei gehen Sie wie folgt vor:

  1. Geben Sie = ein, um die Ergebnisse einer Variable anzuzeigen.

  2. Wenn die Ergebnisse als Matrix erscheinen, doppelklicken Sie auf die Matrix, und ändern Sie im Dialogfeld "Ergebnisformat" die Anzeigeoption in "Tabelle".

  3. Klicken Sie mit der rechten Maustaste auf die Ausgabetabelle. Es wird ein Kontextmenü geöffnet.

  4. Wählen Sie den Befehl Exportieren. Das Dialogfeld "In Datei schreiben" wird geöffnet.

  5. Wählen Sie im Textfeld “Dateityp” das Format der Datei aus, die erstellt werden soll. Geben Sie den Ordner an, in dem die Datendatei erstellt werden soll, und geben Sie einen Namen für die zu erstellende Datendatei ein. Klicken Sie dann auf "Öffnen".

Die Daten werden in die von Ihnen festgelegte Datei exportiert.

Hinweis: Wenn sich die Daten ändern und die Datendatei entsprechend aktualisiert werden soll, müssen Sie die Daten erneut exportieren. Wenn die Daten automatisch aktualisiert werden sollen, können Sie eine dynamische Verbindung zwischen Mathcad und der Datendatei herstellen. Verwenden Sie dazu die Komponente "Dateien lesen/schreiben".


SCHREIBEN VON DATEN IN EINE DATENDATEI

Zum Schreiben von Werten aus Mathcad in eine Datendatei steht Ihnen die Komponente "Dateien lesen/schreiben" zur Verfügung. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle.

  2. Wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  3. Markieren Sie die Komponente "Dateien lesen/schreiben" in der Liste, und klicken Sie auf "Weiter". Dadurch wird der erste Teil des Setup-Assistenten "Dateien lesen/schreiben" gestartet.

  4. Wählen Sie den Befehl “Daten in eine Datei schreiben”, und klicken Sie auf Weiter", um zur zweiten Seite des Assistenten zu gehen:

  5. Wählen Sie im Assistenten aus der Dropdown-Liste "Dateiformat:" den Typ der Datendatei aus, in die geschrieben werden soll.

  6. Geben Sie den Pfad der Datendatei ein, in die geschrieben werden soll, oder klicken Sie auf die Schaltfläche "Durchsuchen", um sie aus dem Verzeichnisbaum auszuwählen.

  7. Klicken Sie auf "Fertig stellen". Daraufhin werden das Symbol für die Komponente "Dateien lesen/schreiben" und der Pfad der Datendatei angezeigt.

  8. Geben Sie im Platzhalter, der unten in der Komponente angezeigt wird, den Namen der Mathcad-Variable ein, die die Daten enthält, die in die Datendatei geschrieben werden sollen.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, werden die Werte in der Mathcad-Variable in die von Ihnen angegebene Datei geschrieben. Jedesmal, wenn Sie das Arbeitsblatt berechnen, wird die Datendatei entsprechend aktualisiert.


DATENAUSTAUSCH MIT ANDEREN ANWENDUNGEN

Sie haben zwar die Möglichkeit, Daten in eine Datendatei zu importieren und aus ihr zu exportieren, aber Sie können Daten auch direkt mit einer Anwendung austauschen. Mathcad enthält Komponenten, mit denen Sie Verbindungen zwischen Mathcad und anderen Anwendungen herstellen können. So können Sie folgende Schritte durchführen:

Senden von Werten aus Mathcad an die Anwendung

Dynamisches Verändern der Daten mit der Anwendung, ohne die Mathcad-Umgebung verlassen zu müssen

Senden von Werten aus der Anwendung zurück an Mathcad

Wenn Sie eine Anwendungskomponente in das Mathcad-Arbeitsblatt einfügen, wird ein kleines Fenster der Umgebung dieser Anwendung im Mathcad-Arbeitsblatt angezeigt. Wenn Sie auf die Komponente doppelklicken, werden anstelle der Menüs und Symbolleisten von Mathcad die der anderen Anwendung angezeigt. So erhalten Sie Zugriff auf die Anwendung, ohne die Mathcad-Umgebung verlassen zu müssen.

Es gibt Komponenten, mit denen eine Verbindung mit den folgenden Anwendungen hergestellt werden kann:

Excel

MATLAB

Axum

Skriptobjekt-Komponente


EINFÜHRUNG IN DIE KOMPONENTEN

Mit Hilfe von Komponenten können Daten dynamisch zwischen dem Mathcad-Arbeitsblatt und einer Datenquelle oder Anwendung ausgetauscht werden. Die Daten, die von Mathcad an eine Komponente übertragen werden, werden Eingabe genannt. Die Daten, die aus einer Komponente herauskommen, werden mit dem Begriff Ausgabe bezeichnet. Die Übertragung von Ein- und Ausgabe zwischen dem Mathcad-Arbeitsblatt und einer Komponente erfolgt mittels einer Mathcad-Eingabevariable und einer Mathcad-Ausgabevariable.

Für die Verwendung einer Komponente zum Austausch von Daten mit Mathcad sind die folgenden grundlegenden Schritte erforderlich:

  1. Einfügen der Komponente in das Arbeitsblatt und Angeben der Eingabevariable(n) und Ausgabevariable(n) in den entsprechenden Platzhaltern

  2. Konfigurieren der Komponente, um ihr mitzuteilen, was mit der Eingabe geschehen soll und wohin die Ausgabe gesendet wird

Da einige Komponenten nur Eingaben annehmen oder nur Ausgaben senden, sind diese Schritte von Komponente zu Komponente leicht unterschiedlich. Die mit diesen Schritten beschriebene Richtung weist jedoch darauf hin, wie die Komponenten funktionieren.

Nachdem Sie eine Komponente in Ihr Mathcad-Arbeitsblatt eingefügt, die entsprechenden Platzhalter mit Werten versehen und die Eigenschaften festgelegt haben, müssen Sie auf eine Stelle außerhalb des Komponentenbereichs klicken, um den Datenaustausch starten zu können. Dies passiert auch, wenn Sie auf die Komponente klicken und die Taste [F9] drücken, wenn sich die Eingabevariablen ändern oder wenn Sie den Befehl Arbeitsblatt berechnen im Menü Rechnen wählen.

In Mathcad Professional können Sie mit den folgenden Komponenten arbeiten:

Axum

Dateien lesen/schreiben, zum Lesen und Schreiben von Datendateien

Excel

MATLAB

Scriptable Object-Komponente

In Mathcad sind zwar nur begrenzt Komponenten verfügbar, aber es können auch weitere Komponenten in MathConnex verwendet werden.


EXCEL-KOMPONENTE

Sie haben zwar die Möglichkeit, Excel-Datendateien mit "Dateien lesen/schreiben" und anderen Komponenten zu importieren und zu exportieren, aber mit der Excel-Komponente können Sie Daten zwischen Mathcad und Excel austauschen und die Funktionen von Excel nutzen. Beispielsweise können Sie Werte aus Mathcad an Excel senden, mit Excel verändern, an Mathcad zurücksenden und dann mit der Arbeit fortfahren.

Mit der Excel-Komponente haben Sie folgende Möglichkeiten:

Weiterleiten von Daten aus Mathcad in eine Excel-Datei

Zugreifen auf die Funktionen von Excel durch Doppelklicken auf die Excel-Komponente

Senden von Werten aus einer Excel-Datei in Mathcad

Zum Einfügen einer Excel-Komponente in ein Mathcad-Arbeitsblatt gehen Sie folgendermaßen vor:

Stellen Sie sicher, daß Microsoft Excel 7.0 oder höher im System installiert ist (es muß jedoch nicht unbedingt aktiv sein).

Klicken Sie auf eine leere Stelle im Arbeitsblatt. Wenn Sie Werte aus einer in Ihrem Arbeitsblatt definierten Mathcad-Variable an die Komponente senden möchten, müssen Sie unter oder rechts neben die Variablendefinition klicken.

Wählen Sie den Befehl Komponente im Menü Einfügen.

Wählen Sie "Excel" in der Liste, und klicken Sie auf "Weiter". Dadurch wird der erste Teil des Excel-Setup-Assistenten gestartet. Füllen Sie die Dialogfeldoptionen aus, und klicken Sie auf die Schaltfläche "Weiter". Der Assistent zeigt weitere Dialogfelder an, deren Optionen ausgefüllt werden müssen.

Wenn Sie die Schritte mit dem Assistenten abgeschlossen haben, wird im Arbeitsblatt die Excel-Komponente mit Platzhaltern für die Eingabevariablen und Ausgabevariablen angezeigt. Geben Sie die Eingabevariablen in den unteren Platzhaltern ein. Geben Sie die Ausgabevariablen in den Platzhaltern links neben ":=" ein.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, sendet Mathcad die Eingabevariablen an Excel. Excel wiederum sendet an Mathcad einen Zellenbereich, der den Ausgabevariablen zugewiesen wird. Wenn die Ausgabevariablen definiert sind, können Sie sie mit den vordefinierten Funktionen und Operatoren von Mathcad beliebig verändern.


KOMPONENTE "AXUM"

Axum ist eine MathSoft-Software für die Erstellung von technischen Graphen und die Analyse von Daten. Mit Axum haben Sie Zugriff auf mehr als 50 zwei- und dreidimensionale Graphtypen. Wenn Sie in Ihrem System Axum 5 installiert haben, können Sie mit Hilfe der Komponente "Axum" druckfertige Graphen auf der Grundlage Ihrer Mathcad-Daten anfertigen, ohne dazu die Mathcad-Umgebung zu verlassen.

Die Komponente "Axum" ermöglicht folgendes:

Erstellen unterschiedlicher Arten zwei- und dreidimensionaler Graphen auf der Grundlage von Mathcad-Daten

umfassendes Formatieren Ihrer Graphen mit Hilfe von Axum

Zum Einfügen eines Axum-Graphen in Ihr Mathcad-Arbeitsblatt gehen Sie wie folgt vor:

Stellen Sie sicher, daß Axum 5 bei Ihnen installiert ist. Es muß aber nicht unbedingt laufen.

Erstellen Sie die Felder, die die Daten für die Komponente "Axum" enthalten und die Axum im Graph darstellen soll. Wenn Sie Informationen zur Anzahl und zum Typ der Felder benötigen, die für die einzelnen Graphtypen benötigt werden, wählen Sie den Befehl "Mathcad-Axum Link" aus dem Hilfe-Menü von Axum, und gehen Sie dort zum Abschnitt mit dem Titel "Mathcad data specifications for creating Axum graphs".

Klicken Sie in Ihrem Arbeitsblatt auf eine leere Stelle. Diese muß sich entweder unterhalb oder rechts der Felder befinden.

Wählen Sie den Befehl Komponente im Menü Einfügen.

Markieren Sie in der Liste der Komponenten die Komponente "Axum", und klicken Sie auf "Weiter". Daraufhin wird der Axum-Setup-Assistent gestartet.

Markieren Sie den Typ des einzufügenden Graphen, und klicken Sie auf "Weiter", um zur nächsten Seite des Assistenten zu gelangen.

Wählen Sie einen Diagrammtyp aus. Welche Diagrammtypen zur Verfügung stehen, hängt davon ab, was für einen Graphtyp Sie gewählt haben.

Klicken Sie auf "Fertig stellen". Daraufhin wird die Komponente "Axum" in Ihr Arbeitsblatt eingefügt.

Geben Sie in die Platzhalter die entsprechenden Feld-Eingabevariablen ein.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, werden die Daten im Feld in dem von Ihnen festgelegten Axum-Diagrammtyp grafisch dargestellt. Sobald das Arbeitsblatt neu berechnet wird, werden die Daten in Axum aktualisiert.


MATLAB-Komponente

MATLAB-KOMPONENTE (nur in Mathcad Professional)

Sie haben zwar die Möglichkeit, MATLAB-Datendateien mit "Dateien lesen/schreiben" und anderen Komponenten zu importieren und zu exportieren, aber mit der MATLAB-Komponente können Sie Daten zwischen Mathcad und MATLAB austauschen und die Funktionen von MATLAB nutzen. Sie können beispielsweise Werte aus Mathcad an MATLAB senden, dort verändern und dann wieder an Mathcad senden.

Mit einer MATLAB-Komponente können Sie folgende Schritte durchführen:

Weiterleiten von in Mathcad-Variablen gespeicherten Werten an MATLAB-Variablen

Verarbeiten der Daten mit MATLAB durch Doppelklicken auf die MATLAB-Komponente

Senden von Daten aus MATLAB-Variablen in Mathcad-Variablen

Zum Einfügen einer MATLAB-Komponente in ein Mathcad-Arbeitsblatt gehen Sie folgendermaßen vor:

Stellen Sie sicher, daß MATLAB Professional Version 4.2c oder höher oder MATLAB Student Version 5.0 oder höher in Ihrem System installiert ist (dies muß jedoch nicht unbedingt aktiv sein).

Klicken Sie auf eine leere Stelle im Arbeitsblatt. Wenn Sie Werte aus einer in Ihrem Arbeitsblatt definierten Mathcad-Variable an die Komponente senden möchten, müssen Sie unter oder rechts neben die Variablendefinition klicken.

Wählen Sie den Befehl Komponente im Menü Einfügen.

Markieren Sie in der Liste die Option "MATLAB", und klicken Sie auf "Weiter". Die MATLAB-Komponente wird in das Arbeitsblatt eingefügt.

Geben Sie in dem im unteren Bereich angezeigten Platzhalter den Namen der Mathcad-Eingabevariablen ein, die an die MATLAB-Komponente weitergeleitet werden sollen. Geben Sie im Platzhalter links neben der Komponente die Namen der zu definierenden Mathcad-Ausgabevariablen ein.

Standardmäßig werden die Mathcad-Eingabevariablen an die MATLAB-Variablen in0, in1, in2 usw. gesendet. Die MATLAB-Variablen out0, out1, out2 usw. definieren die in Mathcad zu erstellenden Ausgabevariablen. Zum Ändern dieser Namen gehen Sie folgendermaßen vor:

Wählen Sie den Befehl Eigenschaften aus dem Kontextmenü der Komponente.

Geben Sie auf den Registerkarten "Ausgaben" und "Eingaben" die neuen Namen für die Ein- und Ausgaben ein.


Scriptable Object-Komponente

SKRIPTOBJEKT-KOMPONENTE (nur in Mathcad Professional)

Sie können Daten zwischen einem Mathcad-Arbeitsblatt und einer beliebigen anderen Anwendung, die OLE-Automatisierung unterstützt, auch dann austauschen, wenn Mathcad keine spezielle Komponente dafür enthält. Mit der Skriptobjekt-Komponente können selbstdefinierte Komponenten für folgende Zwecke erstellt werden:

  • Senden von Werten aus Mathcad an die Anwendung

  • Verwenden der Anwendung zum Bearbeiten der Daten, ohne Mathcad zu verlassen

  • Senden von Werten aus der anderen Anwendung zurück an Mathcad

Sie können ein selbstdefiniertes skriptfähiges Objekt aus jedem Objekt erstellen, das in ein Mathcad-Arbeitsblatt einfügt werden kann. Zum Beispiel haben Sie die Möglichkeit, Werte aus Mathcad an Lotus 1-2-3 zu senden, sie dort zu bearbeiten, und die Ergebnisse dann zurück in das Mathcad-Arbeitsblatt zu übertragen.

Zum Erstellen einer Komponente für skriptfähige Objekte gelten folgende Voraussetzungen:

  • Sie benötigen gute Kenntnisse in einer der unterstützten Skript-Sprachen, die im verwendeten System installiert ist.

  • Sie müssen wissen, wie OLE von der anderen Anwendung implementiert wurde.

  • Die andere Anwendung muß im System verfügbar sein.

Zum Einfügen einer Skriptobjekt-Komponente in ein Mathcad-Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Klicken Sie auf eine leere Stelle im Arbeitsblatt. Wenn Sie Werte aus einer Mathcad-Variable an das Objekt senden möchten, müssen Sie auf eine Stelle unterhalb oder rechts der Variablendefinition klicken.

  2. Wählen Sie den Befehl Komponente im Menü Einfügen.

  3. Wählen Sie "Skriptobjekt" in der Liste, und klicken Sie auf "Weiter". Dadurch wird der Setup-Assistent für skriptfähige Objekte gestartet.

  4. In der Liste "Objekt für Skripterstellung" werden die im System verfügbaren Anwendungen angezeigt.

  5. Geben Sie an, ob die Komponente eine neue Datei sein soll oder ob Sie eine Datei einfügen möchten, die bereits existiert, und ob in Ihrem Arbeitsblatt die eigentliche Datei oder ein Symbol angezeigt werden soll. Klicken Sie auf die Schaltfläche "Weiter".

  6. Legen Sie die zu verwendende Skript-Sprache, die Art des als Skript zu erstellenden Objekts, den Namen des Objekts und die Anzahl der Ein- und Ausgaben fest, die vom Objekt akzeptiert und verfügbar gemacht werden.

Wenn Sie die Verwendung des Assistenten abgeschlossen haben, wird im Arbeitsblatt eine skriptfähige Komponente mit Platzhaltern für die Ein- und Ausgabevariablen angezeigt. Geben Sie in den unteren Platzhaltern die Eingabevariablen ein. Geben Sie in den Platzhaltern links neben ":=" die Ausgabevariablen ein.

Der letzte Schritt ist die Erstellung des Skripts für die Komponente. Dann verfügen Sie über ein Skript-Objekt im Arbeitsblatt.

Weitere Angaben zur Skriptobjekt-Komponente sind in der MathConnex-Online-Hilfe enthalten.


KOMPONENTE "S-PLUS-GRAPH"

"S-PLUS" ist eine professionelle Datenanalyse- und Statistikanwendung, die Sie über MathSoft beziehen können. Bei der Komponete "S-PLUS-Graph" handelt es sich um ein eingebettetes S-PLUS-Graph-Blatt, mit dessen Hilfe Sie eine große Zahl von zwei- und dreidimensionalen Graphen in Ihr Mathcad-Arbeitsblatt integrieren können.

Zum Einfügen der Komponente "S-PLUS-Graph" in ein Mathcad-Arbeitsblatt ist folgendermaßen vorzugehen:

  1. Erstellen Sie die Felder, aus denen die Daten für die Komponente "S-PLUS-Graph" bezogen werden sollen.

  2. Klicken Sie auf eine leere Stelle Ihres Arbeitsblatts unterhalb oder rechts der Felder.

  3. Wählen Sie den Befehl Komponente im Menü Einfügen.

  4. Wählen Sie aus der Liste die Option "S-PLUS-Graph", und klicken Sie auf "Fertig stellen".

  5. Die Komponente "S-PLUS-Graph" wird daraufhin in Ihr Arbeitsblatt eingefügt. Die so eingefügte Komponente verfügt standardmäßig über einen Platzhalter für eine einzelne Eingabevariable.

  6. Geben Sie in den Platzhalter den bzw. die Namen des Feldes bzw. der Felder ein.

Es wird ein Standardgraph gezeichnet. Sie können jedoch, falls gewünscht, einen anderen Graphtyp auswählen.

Hinweis: Diese Komponente kann nur verwendet werden, wenn auf Ihrem Computer S-PLUS 4.5 oder höher installiert ist.


Komponente "S-PLUS-Skript"

KOMPONENTE "S-PLUS-SKRIPT" (nur in Mathcad Professional)

"S-PLUS" ist eine professionelle Datenanalyse- und Statistikanwendung, die Sie über MathSoft beziehen können. Mit der Komponente "S-PLUS-Skript" können Sie Programme in S-PLUS 4.5 oder höher schreiben und ausführen lassen und diese mit anderen Berechnungen in Mathcad Professional verknüpfen.

Zum Einfügen der Komponente "S-PLUS-Skript" in ein Mathcad-Arbeitsblatt ist wie folgt vorzugehen:

  1. Klicken Sie auf eine leere Stelle Ihres Arbeitsblatts unterhalb oder rechts von Eingabevariable-Definitionen.

  2. Wählen Sie den Befehl Komponente im Menü Einfügen.

  3. Wählen Sie aus der Liste die Option "S-PLUS-Skript", und klicken Sie auf "Fertig stellen". Die S-PLUS-Komponente wird als leerer Kasten mit der Beschriftung "S-PLUS-Skript" eingefügt.

  4. Geben Sie in den Platzhalter, der unten erscheint, den Namen der Mathcad-Eingabevariable ein, aus der die Daten für die Komponente geholt werden sollen.

  5. Geben Sie in den Platzhalter links der Komponente den Namen der Mathcad-Ausgabevariable ein, die definiert werden soll.

  6. Geben Sie das Skript ein.

Die Mathcad-Eingabevariablen werden standardmäßig als Variablen in0, in1, in2 usw. an die Komponente weitergegeben. Die S-PLUS-Variablen out0, out1, out2 usw. definieren die Ausgabevariablen, die in Mathcad erstellt werden sollen. Zum Ändern dieser Namen gehen Sie folgendermaßen vor:

Wählen Sie im Kontextmenü der Komponente den Befehl Eigenschaften.

Geben Sie in die entsprechenden Felder auf den Registerkarten "Eingabevariablen" und "Ausgabevariablen" die neuen Namen für die Eingabe- und die Ausgabevariablen ein.

Hinweis: Diese Komponente kann nur verwendet werden, wenn auf Ihrem Computer S-PLUS 4.5 oder höher installiert ist.


MathConnex

MATHCONNEX (nur in Mathcad Professional)

Mit den in Mathcad verfügbaren Komponenten wird ein Mathcad-Arbeitsblatt mit anderen Datenquellen und Anwendungen verbunden. Wenn Sie diese Datenquellen und Anwendungen sowohl untereinander als auch mit Mathcad verbinden möchten, können Sie die Anwendung "MathConnex" verwenden. Diese steht jedoch nur in Mathcad Professional zur Verfügung.

Zusätzlich zu den in Mathcad Professional verfügbaren Komponenten enthält MathConnex eine Reihe anderer Komponenten zum Verarbeiten von Daten, zum Beispiel eine Mathcad-Komponente zur Herstellung einer Verbindung mit einem Mathcad-Arbeitsblatt. In der MathConnex-Umgebung lassen sich die verfügbaren Komponenten beliebig mit anderen Komponenten verbinden. Sie können visuell Datenflußsysteme erstellen, um Projekte zu analysieren, in denen unterschiedliche Anwendungen und Datenquellen verwendet werden.

Zum Starten von MathConnex können Sie entweder auf das MathConnex-Symbol [image] in der Standard-Symbolleiste klicken oder aber Mathcad beenden und MathConnex (MathConx.exe) wie ein normales Anwendungsprogramm starten.


Mathcad als OLE-Automatisierungsserver

MATHCAD ALS OLE-AUTOMATISIERUNGSSERVER (nur in Mathcad Professional)

Mit der OLE-Automatisierungsschnittstelle von Mathcad können Sie Mathcad von einer anderen Windows-Anwendung aus als Automatisierungsserver verwenden. Die OLE-Automatisierungsschnittstelle von Mathcad ermöglicht folgendes:

  • Dynamisches Übertragen von Daten zwischen einer anderen Anwendung und Mathcad

  • Verwenden von Mathcad für die Durchführung von Berechnungen oder anderen Manipulationen an Daten

  • Senden der Ergebnisse an die ursprüngliche Anwendung

Um Mathcad als OLE-Server zu verwenden, sind die folgenden Grundschritte erforderlich:

  1. Einfügen eines Mathcad-Dokuments als OLE-Objekt in einen OLE-Automatisierungs-Client.

  2. Festlegen, welche Daten an Mathcad weitergegeben werden sollen oder/und der Orte, an denen die aus Mathcad übermittelten Daten plaziert werden sollen.

  3. Schreiben eines Programms unter Verwendung der Client-Anwendung, um die Variablen im Mathcad-Dokument-Objekt zu definieren und zu erfassen.

Klicken Sie hier, um sich ein Beispiel anzeigen zu lassen.

Hinweise:

  • Die OLE-Automatisierungsschnittstelle tritt an die Stelle der DDE-Schnittstelle, die in den Versionen 5 und 6 unterstützt wurde.

  • Aktuelle Informationen zur OLE-Automatisierungsschnittstelle sowie Beispiele für ihre Verwendung finden Sie auf der Website von MathSoft unter http://www.mathsoft.com/support/.


STATISTIK UND DATENANALYSE

Datenanalysefunktionen

Beschreibt Datenanalysefunktionen wie mittelwert, var (Varianz), stdev (Standardabweichung), kurt (Kurtosis) und korr (Korrelation).

Verteilungsfunktionen

Beschreibt die integrierte Gammafunktion, die Fehlerfunktion (fehlf) und die kumulative Normalverteilung sowie viele andere Wahrscheinlichkeitsverteilungsfunktionen.

Zufallszahlen

Beschreibt, wie Zufallszahlen generiert werden und wie man mit ihnen Zufallszahlen mit den verschiedensten Verteilungen generieren kann.

Histogramme

Beschreibt, wie man die Häufigkeitsverteilung von Datenstichproben erhalten kann.

Kombinatorische Analyse

Funktionen zum Zählen von Permutationen und Kombinationen.

Interpolation und Prognose

Beschreibt die lineare und die kubische Spline-Interpolation sowie die lineare Prognose.

Datenglättung

Beschreibt die verschiedenen Wege zur Glättung von verrauschten Daten.

Kurvenanpassung

Beschreibt lineare und nicht lineare Regressionstechniken.


X-Y-DIAGRAMME

X-Y-Diagramme sind optimal zum Abbilden von Funktionen, mathematischen Ausdrücken und Datensätzen (gespeichert in Vektoren) geeignet. Wenn Sie ein X-Y-Diagramm erstellt haben, können Sie es beliebig formatieren. Mathcad ermöglicht außerdem das Vergrößern von Teilen eines X-Y-Diagramms oder die Extrahierung der Koordinaten aus einem bestimmten Punkt.

Erstellen eines Diagramms

Grafisches Darstellen von mehreren Ausdrücken

Löschen eines Diagramms

Verschieben eines Diagramms

Ändern der Größe eines Diagramms

Achsenbegrenzungen

Achseneinstellungen

Achsenbeschriftungen

Spureinstellungen

Legenden

Vergrößern

Ablesen von Koordinaten

Titel in Diagrammen

Standardeinstellungen

Animieren eines X-Y-Diagramms


KREISDIAGRAMME

Mit den Kreisdiagrammen von Mathcad können Sie winkelabhängige mathematische Ausdrücke, Funktionen und Datensätze (gespeichert in Vektoren) abbilden. Wenn Sie ein Kreisdiagramm erstellt haben, können Sie es nach Wunsch formatieren. Mathcad ermöglicht außerdem die Vergrößerung von Teilen eines Kreisdiagramms oder das Ablesen der Koordinaten eines bestimmten Punkts.

Erstellen eines Diagramms

Grafisches Darstellen von mehreren Ausdrücken

Löschen eines Diagramms

Verschieben eines Diagramms

Ändern der Größe eines Diagramms

Achsenbegrenzungen

Achseneinstellungen

Spureinstellungen

Legenden

Vergrößern

Ablesen von Koordinaten

Titel in Diagrammen

Standardeinstellungen

Animieren eines Kreisdiagramms


3D-Diagramme (Überblick)

3D-DIAGRAMME

Sie können für die Darstellung dreidimensionaler Daten die folgenden Arten von Diagrammen erstellen:

Fläche

Parametrische Fläche

Umriß

3D-Streuung

3D-Säulendiagramm

Vektorfeld

Diese können nach Wunsch formatiert und bearbeitet werden. Sie können außerdem mehrere 3D-Diagramme kombinieren oder beliebige der einheitlichen Polyeder darstellen.


FLÄCHENDIAGRAMME

Bei der Erstellung eines Flächendiagramms setzt Mathcad eine Datenmatrix als Fläche in einem dreidimensionalen Diagramm um. Sie haben viele Formatierungsmöglichkeiten zum Verändern der Darstellung des Diagramms. Außerdem können Sie Flächendiagramme in einen anderen dreidimensionalen Diagrammtyp umwandeln.

Erstellen eines Flächendiagramms

Parametrische Flächendiagramme

Farbeinstellungen

Linieneinstellungen

Punkteinstellungen

Achseneinstellungen

Hintergrundebeneneinstellungen

Beleuchtungseinstellungen

Erweiterte Ansichtseinstellungen

Bearbeiten eines Flächendiagramms


Umrißdiagramme

UMRISSDIAGRAMME

Für Umrißdiagramme muß eine Matrix aus Werten vorliegen, die von Mathcad linear interpoliert werden, um daraus Niveaulinien zu erstellen. Bei diesen Niveaulinien kann es sich z. B. um Isotherme, Isobare, Äquipotentialkurven, Stromlinien und viele andere physikalische Phänomene handeln.

Sie können die Darstellungsweise eines Umrißdiagramms über die Formatierung gestalten. Darüber hinaus besteht die Möglichkeit, ein Umrißdiagramm in ein anderes dreidimensionales Diagramm umzuwandeln.

Erstellen eines Umrißdiagramms

Anzeigen der x- oder y-Umrisse

Farbeinstellungen

Linieneinstellungen

Punkteinstellungen

Achseneinstellungen

Hintergrundebeneneinstellungen

Beleuchtungseinstellungen

Erweiterte Ansichtseinstellungen

Bearbeiten eines Umrißdiagramms


3D-SÄULENDIAGRAMME

Mit dreidimensionalen Säulendiagrammen können Sie eine Matrix von Daten in Form von Balken unterschiedlicher Höhe darstellen. Die Darstellungsweise des Diagramms kann durch verschiedene Formatierungen bestimmt werden. Sie können ein 3D-Säulendiagramm auch in einen anderen Typ von 3D-Diagramm umwandeln.

Erstellen von 3D-Säulendiagrammen

Säulen-Layouteinstellungen

Farbeinstellungen

Linieneinstellungen

Punkteinstellungen

Achseneinstellungen

Hintergrundebeneneinstellungen

Beleuchtungseinstellungen

Erweiterte Ansichtseinstellungen

Bearbeiten eines 3D-Säulendiagramms


3D-STREUUNGSDIAGRAMME

Mit dreidimensionalen Streuungsdiagrammen können Sie x-, y- und z-Koordinaten räumlich abbilden. Deshalb sind sie hervorragend dazu geeignet, parametrische Kurven zu zeichnen oder Datengruppen im dreidimensionalen Raum darzustellen. Sie können das Symbol und die Farbe festlegen, das/die für die Darstellung der Datenpunkte verwendet wird, und Sie können bestimmen, ob die Punkte mit einer Linie verbunden werden. Sie können auch ein dreidimensionales Streuungsdiagramm in einen anderen Typ von 3D-Diagramm ändern.

Erstellen eines 3D-Streuungsdiagramms aus 3 Datenvektoren

Erstellen eines 3D-Streuungsdiagramms aus einer Matrix von Datenwerten

Punkteinstellungen

Linieneinstellungen

Achseneinstellungen

Hintergrundebeneneinstellungen

Beleuchtungseinstellungen

Erweiterte Ansichtseinstellungen

Bearbeiten eines 3D-Streuungsdiagramms


VEKTORFELDDIAGRAMME

Ein Vektorfeld ist mit einer Funktion vergleichbar, von der einem Punkt in der Ebene ein Vektor zugewiesen wird, der an einem bestimmten Punkt beginnt. Sie können ein zweidimensionales Vektorfelddiagramm in Mathcad über eine Matrix mit komplexen Zahlen erstellen. Die Ausgangspunkte der einzelnen Vektoren liegen auf den x- und y-Werten entsprechend den Zeilen und Spalten der Matrix. Die Größe und Richtung jedes Vektors richtet sich nach den reellen und imaginären Teilen der Matrixelemente.

Erstellen eines Vektorfelddiagramms

Farbeinstellungen

Linieneinstellungen

Punkteinstellungen

Achseneinstellungen

Hintergrundebeneneinstellungen

Beleuchtungseinstellungen

Erweiterte Ansichtseinstellungen

Bearbeiten eines Vektorfelddiagramms


ABBILDEN MEHRERER 3D-DIAGRAMME

Zum Abbilden mehrerer 3D-Diagramme in einem Diagramm gehen Sie folgendermaßen vor:

  1. Definieren Sie die Argumente (Matrizen oder Vektoren), die für die abzubildenden Diagramme erforderlich sind.

  2. Wählen Sie Diagramm im Menü Einfügen. Wählen Sie die Art von 3D-Diagramm, die Sie zuerst erstellen möchten.

  3. Geben Sie im Platzhalter des 3D-Diagrammoperators die Argumente für das erste 3D-Diagramm ein.

  4. Geben Sie ein Komma ein.

  5. Geben Sie die Argumente für das nächste 3D-Diagramm ein.

  6. Geben Sie weitere durch Kommas abgetrennte Argumente ein. Wenn für 3D-Diagramme mehrere Argumente erforderlich sind, müssen sie in Klammern gesetzt werden.

  7. Drücken Sie die [Eingabetaste], oder klicken Sie auf eine Stelle außerhalb des Diagrammbereichs.

  8. Doppelklicken Sie auf das Diagramm, damit das Dialogfeld "3D-Diagrammformat" geöffnet wird. Geben Sie über den Abschnitt "Darstellungsart" und die Register "Diagramm 1", "Diagramm 2" usw. an, wie die Argumentsätze angezeigt werden sollen.


FORMATIEREN EINES 3D-DIAGRAMMS

Wenn Sie ein 3D-Diagramm mit einem oder mehreren Diagrammen erstellt haben, haben Sie verschiedene Möglichkeiten, deren Darstellungsweise zu ändern.

Allgmein gehen Sie zum Formatieren eines 3D-Diagramms folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm.

  2. Formatieren Sie das Diagramm mit den Optionen im Dialogfeld mit mehreren Registerkarten.

Auf 3D-Diagrammen können Sie die Darstellung der Achsen, der Hintergrundebenen und die Position des Diagramms festlegen. Es gibt außerdem Optionen für erweiterte Ansicht und Optionen für Beleuchtung, mit denen sich die Gesamtdarstellung des Diagramms bestimmen läßt. Zusätzlich können Sie einen Titel oder eine andere Anmerkung in das Diagramm einfügen.

Jedes 3D-Diagramm kann auch mit verschiedenen Optionen zum Festlegen seiner Farben, Linien und Punkte formatiert werden. Die Methode der Formatierung eines Diagramms richtet sich nach der Art des Diagramms. Durch Klicken auf die Diagrammtypen unten können Sie weitere Angaben zu den möglichen Einstellungen aufrufen:

Fläche

Umriß

3D-Streuung

3D-Säulendiagramm

Vektorfeld


BEARBEITEN EINES 3D-DIAGRAMMS

Wenn Sie ein 3D-Diagramm erstellt haben, können Sie es bearbeiten:

Löschen eines 3D-Diagramms

Verschieben eines 3D-Diagramms

Ändern der Größe eines 3D-Diagramms

Vergrößern eines 3D-Diagrammausschnitts

Animieren eines 3D-Diagramms

Drehen eines 3D-Diagramms


DREHEN EINES 3D-DIAGRAMMS

Zum Drehen eines 3D-Diagramms mit der Maus gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm.

  2. Halten Sie die Maustaste gedrückt.

  3. Ziehen Sie die Maus in die Richtung, in die das Diagramm gedreht werden soll.

  4. Lassen Sie die Maus los, wenn sich das Diagramm an der gewünschten Position befindet.

Zum Drehen eines 3D-Diagramms um einen bestimmten Faktor gehen Sie folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf das Diagramm.

  2. Wählen Sie Eigenschaften im Popup-Menü.

  3. Klicken Sie auf die Registerkarte "Allgemein" im Dialogfeld, um die Seite "Allgemein" anzuzeigen.

  4. Nehmen Sie Änderungen an Rotation, Neigung und Verdrehung vor, und klicken Sie dann auf "OK" oder "Übernehmen".

Zum fortlaufenden Drehen eines 3D-Diagramm gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm.

  2. Halten Sie die Strg-Taste und die Maustaste gedrückt.

  3. Ziehen Sie die Maus in die Richtung, in der das Diagramm gedreht werden soll.

  4. Lassen Sie die Maus los, wenn die gewünschte Position erreicht ist.

Das Diagramm dreht sich fortlaufend in der Richtung, in die Sie die Maus gezogen haben. Klicken Sie in das Diagramm, wenn Sie dies anhalten möchten.

Hinweis:

Wenn Sie Änderungen an Gleichungen vornehmen, die sich auf das Diagramm auswirken, wird während der Drehung eine Neuberechnung durchgeführt.


ANMERKUNGEN ZU EINEM 3D-DIAGRAMM

Zum Einfügen von Anmerkungen in ein 3D-Diagramm gehen Sie folgendermaßen vor:

  1. Fügen Sie Text ein, oder importieren Sie ein Graphikbild in das Arbeitsblatt.

  2. Markieren Sie den Text, damit er hervorgehoben wird.

  3. Halten Sie die Maustaste gedrückt, und ziehen Sie den Cursor auf die Stelle im Diagramm, an der Sie die Anmerkung einfügen möchten.

  4. Lassen Sie die Maustaste los.

Zum Einfügen einer Anmerkung in ein 3D-Diagramm durch Positionieren einer Bitmap gehen Sie folgendermaßen vor:

  1. Kopiereren Sie die Bitmap aus einer anderen Anwendung in die Zwischenablage.

  2. Klicken Sie mit der rechten Maustaste auf das Diagramm.

  3. Wählen Sie Inhalte einfügen im Popup-Menü.

Zum Bearbeiten einer Anmerkung gehen Sie folgendermaßen vor:

  1. Wählen Sie sie aus.

  2. Ziehen Sie sie aus dem Diagramm

  3. Bearbeiten Sie sie.

  4. Ziehen Sie sie wieder in das Diagramm.

Zum Einfügen eines Titels in ein Diagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, damit ein Dialogfeld mit Registerkarten geöffnet wird.

  2. Klicken Sie auf die Registerkarte "Titel", damit die Seite "Titel" aufgerufen wird.

  3. Geben Sie Text für den Titel im Textfeld "Titel" ein.

  4. Klicken Sie auf "Oben" oder "Unten".

  5. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", damit das Dialogfeld ausgeblendet wird.


Symbolische Berechnung

ÜBERSICHT ÜBER DAS SYMBOLISCHE RECHNEN

Das symbolische Rechnen können Sie verwenden, wenn Sie als Antwort auf ein Problem etwas anderes als eine Zahl erhalten möchten. So können Sie z. B. eine Gleichung nach der Variable x in bezug auf y auflösen, ohne y numerisch zu definieren.

Symbolische Berechnungen können auf zweierlei Arten durchgeführt werden:

  1. mit Hilfe des symbolischen Gleichheitszeichens, so daß die Ergebnisse ständig aktualisiert werden, oder

  2. mit Hilfe der Menübefehle im Menü Symbolik.

Die Entscheidung, welche Methode Sie verwenden sollten, hängt davon ab, ob Sie ständig aktualisierte Ergebnisse benötigen. Wenn Mathcad einen Ausdruck mit Hilfe der in Ihrem Arbeitsblatt verwendeten numerischen Definitionen symbolisch auswerten soll, verwenden Sie das symbolische Gleichheitszeichen. In allen anderen Fällen verwenden Sie die Menübefehle aus dem Menü Symbolik.

Folgende Berechnungen können symbolisch ausgeführt werden:

Algebra

Differential- und Integralrechnung

Lösen

Matrixmanipulationen

Transformationen

Die meisten Operationen mit einem Operator oder einer Funktion


Symbolische Auswertung mit Hilfe des symbolischen Gleichheitszeichens

AKTIVE SYMBOLISCHE BERECHNUNGEN

Zur symbolischen Auswertung von Ausdrücken müssen Sie das symbolische Gleichheitszeichen verwenden. Gehen Sie hierzu folgendermaßen vor:

Geben Sie den Ausdruck ein, der symbolisch ausgewertet werden soll.

Drücken Sie Strg +Punkt, um den Pfeil nach rechts einzufügen, der das symbolische Gleichheitszeichen darstellt.

Drücken Sie die Eingabetaste.

Das symbolische Gleichheitszeichen gibt standardmäßig denselben Ausdruck zurück wie der Befehl Symbolisch auswerten aus dem Menü Symbolik. Sie können jedoch die Bedeutung des symbolischen Gleichheitszeichens ändern, indem Sie es mit einem Schlüsselwort modifizieren.


ÄNDERN DES SYMBOLISCHEN AUSWERTUNGSOPERATORS

Wenn Sie einen Ausdruck auf die eine oder andere Weise symbolisch auswerten möchten, stellen Sie dem Auswertungsoperator ein Schlüsselwort voran. Gehen Sie hierzu folgendermaßen vor:

Geben Sie den Ausdruck ein, der symbolisch ausgewertet werden soll.

Drücken Sie Strgl +Umschalt +Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

Geben Sie ein Schlüsselwort in den Platzhalter ein oder wählen Sie ein Schlüsselwort aus der Symbolleiste "Symbolik" aus. Wird für das Schlüsselwort ein weiteres Argument benötigt, geben Sie ein Komma und dann das Argument ein. Trennen Sie mehrere Argumente durch Kommas voneinander ab.

Drücken Sie die Eingabetaste.

Der symbolische Prozessor gibt ein Ergebnis aus, das vom eingegebenen Schlüsselwort abhängt. Sie können dieses Ergebnis mit mehreren Schlüsselwörtern weiter auswerten.


SYMBOLISCHE ALGEBRA

Vereinfachen

Entwickeln von Ausdrücken

Faktorisieren

Zusammenfassen von Gliedern

Ermitteln der Koeffizienten eines Polynoms

Reihen

Partialbruchzerlegung

Symbolische Summen und Produkte


SYMBOLISCHE DIFFERENTIAL- UND INTEGRALRECHNUNG

Symbolische Ableitungen

Symbolische Integrale

Grenzwerte


SYMBOLISCHES LÖSEN VON GLEICHUNGEN

Symbolisches Lösen einzelner Gleichung

Symbolisches Lösen von Gleichungssystemen


SYMBOLISCHE MATRIZENALGEBRA

Matrizenalgebra

Transponieren von Matrizen

Invertieren von Matrizen

Ermitteln der Determinante einer Matrix


SYMBOLISCHE TRANSFORMATIONEN

Überblick

Fourier-Transformationen

Laplace-Transformationen

z-Transformationen

Fourier invers

Laplace invers

Z invers


UMGANG MIT FUNKTIONEN UND VARIABLEN BEI SYMBOLISCHEN BERECHNUNGEN

Vordefinierte Funktionen

Die meisten vordefinierten Funktionen behalten ihre Bedeutung in symbolischen Berechnungen bei. Einige integrierte Funktionen haben im Zusammenhang mit symbolischen Berechnungen keine vernünftige Bedeutung und werden daher auch nicht ausgewertet. Dies trifft z. B. auf die statistischen Funktionen wie linterp oder rnd zu.

Vordefinierte Konstanten

Der symbolische Prozessor erkennt p, e und [image] da diese Konstanten eine allgemein anerkannte mathematische Bedeutung haben. Andere vordefinierte Konstanten wie z. B. TOL und ORIGIN haben keine solche Bedeutung und werden daher nicht ausgewertet.

Benutzerdefinierte Funktionen und Variablen

Der symbolische Prozessor erkennt benutzerdefinierte Funktionen und Variablen nur dann, wenn Sie sie mit dem symbolischen Gleichheitszeichen auswerten.


Einheiten und Dimensionen, eine Übersicht:

EINHEITEN UND DIMENSIONEN

Wenn Sie Mathcad zum ersten Mal starten, steht ein vollständiger Satz von Einheiten für Ihre Berechnungen zur Verfügung. Sie können Ihren Variablen diese vordefinierten Einheiten zuweisen oder eigenen Einheiten definieren und zuweisen. Mathcad überprüft die Einheitlichkeit der Dimensionen und zeigt die Ergebnisse automatisch in den Einheiten des gewählten Einheitensystems an.

Liste der vordefinierten Einheiten

Zuweisen von Einheiten Variablen

Umrechnen von Einheiten

Formatieren von Einheiten

Vereinfachen von Einheiten

Festlegen des Einheitensystems

Definieren neuer Einheiten

Umbenennen von Dimensionen


VERBINDEN EINER EINHEIT MIT EINER VARIABLEN ODER KONSTANTEN

Zum Verbinden einer Einheit mit einer Variablen oder Konstanten müssen Sie die Variable oder Konstante nur mit der Einheit multiplizieren. Klicken Sie auf die Schaltflächen unten, um ein Beispiel Schritt für Schritt durchzugehen:

Klicken Sie auf die Variable oder Konstante.

Drücken Sie die Taste "*", um das Multiplikationszeichen und einen Platzhalter einzufügen.

Geben Sie in den Platzhalter den Namen einer Einheit ein, oder wählen Sie den Befehl Einheit aus dem Menü Einfügen.

Wenn Sie eine Einheit in den Einheitenplatzhalter eingeben, dividiert Mathcad den Wert, der angezeigt werden soll, durch die Eingabe im Platzhalter. Dadurch wird gewährleistet, daß das gesamte angezeigte Ergebnis (also die Zahl multipliziert mit dem Ausdruck, der für den Platzhalter eingegeben wurde) den korrekten Wert für die Gleichung angibt.


UMRECHNEN VON EINHEITEN

Mathcad zeigt Ergebnisse automatisch in den Grundeinheiten des gewählten Einheitensystems an. Allerdings können Sie die Ergebnisse auch in den vordefinierten Einheiten von Mathcad anzeigen lassen.

Das Beispiel unten zeigt, wie Sie ein Einzelergebnis in Einheiten umwandeln, die keine Grundeinheiten sind. Dabei wird davon ausgegangen, daß dem Ergebnis bereits eine Einheit zugewiesen ist. Ist dies nicht der Fall, bleibt eine Umwandlung von Einheiten völlig wirkungslos. Sie müssen den Ausdruck, der das Ergebnis ausgibt, Einheiten zuweisen. Wenn Sie auf die Schaltflächen unten klicken, wird Schritt für Schritt ein Beispiel für die Umwandlung von Einheiten angezeigt.

Klicken Sie in das Ergebnis, damit der Einheitenplatzhalter angezeigt wird.

Klicken Sie auf den Einheitenplatzhalter.

Geben Sie eine Kombination von Einheiten in den Einheitenplatzhalter ein, oder wählen Sie den Befehl Einheit aus dem Menü Einfügen, und klicken Sie in der angezeigten Liste auf eine Einheit.

Klicken Sie auf eine Stelle außerhalb des Ausdrucks, um das Ergebnis in den ausgewählten Einheiten neu anzeigen zu lassen.

Aufrufen eines QuickSheet-Beispiels


FESTLEGEN DES EINHEITENSYSTEMS

Soweit Sie nicht anderes angeben, werden die Ergebnisse in den grundlegenden SI-Einheiten, m, kg, s, K, A, cd und mol wiedergegeben. Zum Festlegen eines anderen Einheitensystems gehen Sie vor wie folgt:

  1. Wählen Sie den Befehl Optionen aus dem Menü Rechnen, und klicken Sie auf die Registerkarte Einheitensystem.

  2. Klicken Sie auf das gewünschte, standardmäßige Einheitensystem.

Auch wenn Sie die Option Kein für das Einheitensystem festlegen, können Sie Ihre eigenen Einheiten definieren und verwenden. Hierzu legen Sie Ihre eigenen Einheiten in Form von speziellen, integrierten Konstanten (1L, 1M, 1T, 1Q, 1K, 1C und 1S) fest, die für die Dimensionen Länge, Masse, Zeit, Ladung oder Strom, absolute Temperatur, Leuchtstärke und Stoff stehen. Zum Beispiel können Sie die Definitionen kg:=1M, sek:=1T und m:=1L festlegen.


DEFINIEREN EINER EINHEIT

Da bereits zahlreiche vordefinierte Einheiten vorhanden sind, kommt es nur selten vor, daß Sie eigene Einheiten definieren müssen. Sie können jedoch bei Bedarf Einheiten auf die gleiche Weise wie eine Variable definieren:

  1. Geben Sie den Namen der Einheit ein, die Sie definieren möchten.

  2. Drücken Sie die Taste ":", um das Zeichen ":=" einzufügen.

  3. Geben Sie im Platzhalter die Einheit oder Einheitenkombination ein, die für Ihre neue Einheit gelten soll.

Danach steht die neue Einheit unterhalb und rechts ihrer Definition überall zur Verfügung.


Umbenennen von Dimensionen

UMBENENNEN VON DIMENSONEN

Standardmäßig werden Ergebnisse als m, kg, s, A, K, cd und mol wiedergegeben. Sollen die Angaben als meter, kilogramm, s und Grad ausgeschrieben werden, gehen Sie folgendermaßen vor:

  1. Wählen Sie den Befehl Optionen aus dem Menü Rechnen, und klicken Sie auf die Registerkarte "Dimensionen".

  2. Klicken Sie auf das Kontrollkästchen “Dimensionen anzeigen”.

  3. Überschreiben Sie die Namen in den entsprechenden Textfeldern mit den gewünschten Dimensionsnamen, und klicken Sie auf OK.

Das Umbenennen der Dimensionen kann sinnvoll sein, wenn Sie für Ihre Arbeit andere Einheiten benötigen. Ein Autohändler könnte so LKW und PKW anstellen von Länge und Masse definieren. Eine Dimension ist also einfach eine Möglichkeit, Zahlen mit Bezeichnungen zu versehen, damit sie leichter zugeordnet werden können.


EINFÜGEN VON VORDEFINIERTEN EINHEITEN

Eine einfache Möglichkeit zum Einfügen einer vordefinierten Einheit steht mit dem Dialogfeld "Einheit einfügen" zur Verfügung. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie im Menü Einfügen auf eine Einheit.

  2. Wählen Sie den Befehl Einheit aus dem Menü Einfügen, um das Dialogfeld "Einheit einfügen" zu öffnen.

  3. Suchen Sie die gewünschte Einheit aus der Einheiten-Auswahlliste rechts heraus. Sollen nur die Einheiten angezeigt werden, die für eine bestimmte physikasche Menge gelten, verwenden Sie die Auswahlliste auf der linken Seite.

  4. Doppelklicken Sie auf den Namen der gewünschten Einheit.


Programmieren

PROGRAMIEREN (nur Mathcad Professional)

Programme erleichtern die Durchführung von Aufgaben, die manuell zu aufwendig oder undurchführbar wären. Der Vorteil von Programmen liegt in den Attributen der Programmiersprachen, die die Arbeit flexibel gestalten (z. B. bedingte Verzweigungen, Schleifenfunktionen, lokale Variablendefinitionen und Fehlerbehebung) sowie ihrer Fähigkeit, sich selbst rekursiv aufzurufen.

Was ist ein Programm?

Definieren von Programmen

Bedingungsanweisungen

Programmschleifen

Unterbrechungsanweisungen

Steuern von Iterationen in einer Schleife

Ausgeben eines Werts

Erkennen von Fehlern

Rekursion

Symbolisches Auswerten eines Programms

Programmierbeispiele


WAS IST EIN PROGRAMM?

Als Programm wird ein Ausdruck bezeichnet, der aus mehr als einer Anweisung besteht (nur verfügbar in Mathcad Professional). Wenn Sie auf die folgenden Beispiele klicken, werden diese als Programm geschrieben und nicht als einzelner Ausdruck angezeigt.

Trotz der grundlegenden Äquivalenz zwischen Programmen und einfachen Ausdrücken bieten Programme zwei entscheidende Vorteile:

  • Wenn Sie Strukturen wie Schleifen und bedingte Verzweigungen kontrollieren, können Sie ein Programm weit flexibler gestalten, als dies bei einem Ausdruck möglich wäre.

  • Ein aus mehreren einfachen Schritten bestehendes Programm ist oft leichter zu erstellen als ein entsprechender, aber weit komplexerer Ausdruck mit vielen Klammern.


Definieren von Programmen

DEFINIEREN VON PROGRAMMEN (nur Mathcad Professional)

Im folgenden wird die Definition eines Beispielprogramms illustriert:

Geben Sie den linken Teil einer Funktionsdefinition, gefolgt zum Zuweisungsoperator ":", ein.

Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

Klicken Sie auf die Schaltfläche "+1 Zeile". Dadurch wird eine vertikale Leiste mit einem Platzhalter für eine weitere Programmanweisung erstellt (ein Programm kann beliebig viele Anweisungen enthalten).

Klicken Sie auf den oberen Platzhalter, geben Sie "z" ein, und klicken Sie auf die Schaltfläche für lokale Zuweisung. (Beachten Sie, daß die Definition von z programmspezifisch ist und außerhalb des Programms nicht gilt.)

Schließen Sie die lokale Zuweisung ab, indem Sie in den Platzhalter rechts neben dem Pfeil "x/w" eingeben.

Der letzte Platzhalter muß stets den Wert enthalten, der vom Programm ausgegeben wird. Geben Sie in diesen Platzhalter "log(z)" ein.

Sie können nun beim Verwenden dieser Funktion ebenso vorgehen wie bei anderen Funktionen oder sie symbolisch auswerten.

Aufrufen eines QuickSheet-Beispiels


Bedingungsanweisungen

BEDINGUNGSANWEISUNGEN (nur für Mathcad Professional)

Mit einer bedingten Anweisung können Sie immer dann eine Programmanweisung ausführen, wenn bestimmte Bedingungen bestehen. Zum Einfügen einer Bedingungsanweisung gehen Sie wie folgt vor:

Klicken Sie auf den Platzhalter, in den Sie die Bedingungsanweisung einfügen möchten.

Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

Klicken Sie auf die Schaltfläche "if". Geben Sie nicht einfach "if" ein.

Geben Sie im rechten Platzhalter einen Booleschen Ausdruck ein.

Klicken Sie gegebenenfalls auf die Schaltfläche "+1 Zeile", wenn Platzhalter für weitere Anweisungen eingefügt werden sollen.

Klicken Sie auf den anderen Platzhalter, und klicken Sie auf die Schaltfläche "otherwise". Geben Sie nicht einfach "otherwise" ein.

Geben Sie in den verbleibenden Platzhalter den Wert ein, den das Programm ausgeben soll, wenn die Bedingung den Wert "falsch" aufweist.

Hinweis:

Wenn Sie vor einer "otherwise"-Anweisung mehrere "if"-Anweisungen einfügen, wird die "otherwise"-Anweisung nur dann ausgeführt, wenn alle Bedingungen den Wert "falsch" aufweisen.

Aufrufen eines QuickSheet-Beispiels


Programmschleifen

PROGRAMMSCHLEIFEN (nur Mathcad Professional)

Eine Schleife ist eine Programmanweisung, mit der eine Anweisung oder mehrere Anweisungen (Hauptteil der Schleife) wiederholt ausgeführt werden können, bis eine bestimmte Bedingung eintritt. Es gibt zwei verschiedene Arten von Schleifen:

"For"-Schleifen sind dann empfehlenswert, wenn Sie genau wissen, wie oft der Hauptteil der Schleife ausgeführt werden soll.

"While"-Schleifen sind empfehlenswert, wenn Sie die Ausführung bei Eintritt einer Bedingung beenden möchten, ohne daß Sie im voraus wissen, wann diese Bedingung eintreten wird.

Bei der Verwendung von Schleifen kann es notwendig sein, sie zu unterbrechen oder bestimmte Durchläufe zu steuern.


AUSGEBEN EINES WERTES AUS EINEM PROGRAMM

Standardmäßig wird von Programmen der Inhalt der letzten Zeile ausgegeben. Sie können über eine "return"-Anweisung jedoch auch einen Wert aus einem anderen Programmbereich ausgeben lassen.

Zum Einfügen einer "return"-Anweisung gehen Sie folgendermaßen vor:

Klicken Sie auf den Platzhalter, der die "return"-Anweisung enthalten soll.

Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

Klicken Sie auf die Schaltfläche "return". Geben Sie nicht einfach das Wort "return" ein.

Geben Sie im Platzhalter rechts neben "return" den Ausdruck ein, der ausgegeben werden soll.

"Return"-Anweisungen sind dann von Nutzen, wenn ein Wert aus einer bestimmten Schleife ausgegeben werden soll.


Erkennen von Fehlern

ERKENNEN VON FEHLERN (nur Mathcad Professional)

Wenn Sie beim Erkennen eines Fehlers in einem Ausdruck einen Alternativwert ausgeben möchten, verwenden Sie den Programmieroperator "on error":

Klicken Sie auf den Platzhalter, in den Sie die "on error"-Anweisung einfügen möchten.

Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

Klicken Sie auf die Schaltfläche "on error". Geben Sie nicht einfach die Worte "on error" ein.

Geben Sie im Platzhalter rechts neben "on error" den Ausdruck ein, der ausgegeben werden soll, sofern er erfolgreich ausgewertet wird.

Geben Sie im Platzhalter links neben "on error" den Ausdruck ein, der ausgegeben werden soll, wenn der Standardausdruck für die Ausgabe nicht ausgewertet werden kann. Fügen Sie mit der Schaltfläche "+ 1 Zeile" gegebenenfalls Platzhalter für weitere Anweisungen ein.

Der Ausdruck auf der rechten Seite wird ausgewertet und, soweit kein Fehler auftritt, ausgegeben. Tritt ein Fehler auf, wird das Argument auf der linken Seite ausgegeben.


SYMBOLISCHES AUSWERTEN EINES PROGRAMMS

Gehen Sie folgendermaßen vor, wenn Sie ein Programm definiert haben, das Sie symbolisch auswerten möchten:

Geben Sie den Namen der programmspezifisch definierten Funktion oder Variablen ein.

Drücken Sie Strg + Punkt, um den nach rechts gerichteten Pfeil einzufügen, der das symbolische Gleichheitszeichen darstellt.


Programmierbeispiele

PROGRAMMIERBEISPIELE (nur Mathcad Professional)

Die Programmierleiste von Mathcad kommt mit nur zehn Schaltflächen aus. Dementsprechend einfach ist die Programmierumgebung zu bedienen. Dennoch versteckt sich hinter diesem Minimalismus eine große Leistungsfähigkeit. In Kombination mit der umfangreichen numerischen Funktionalität von Mathcad und den abstrakten Datenstrukturen, die durch die verschachtelten Datenfelder in Mathcad verfügbar werden, haben Sie mit diesen zehn Programmieroperatoren die Möglichkeit, anspruchsvolle Programme in Mathcad zu schreiben.

Es stehen mehrere QuickSheets zur Verfügung, in denen weitere Programmierverfahren mit Subroutineaufrufen und Rekursionen erläutert werden. Zum Aufrufen dieser Beispiele gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Informationszentrum aus dem Menü Hilfe.

  2. Klicken Sie auf "QuickSheets" und dann auf "Programmierung".


Animationen (allgemein)

ANIMATIONEN

Animationen stellen ein sehr nützliches Instrument für die direkte und visuelle Überprüfung der numerischen Ausgabe dar. In Mathcad erstellen Sie Animationen mit Hilfe einer FRAME genannten Variable in Ihren Gleichungen. Mathcad erstellt daraufhin ein Video, indem eine Sequenz aus einzelnen "Momentaufnahmen" ("Bilder" oder "Frames" genannt) aufgezeichnet wird. Für jeden Wert von FRAME im angegebenen Bereich wird der Reihe nach ein solches Bild generiert.

Erstellen von Animationen

Wiedergeben von Animationen

Speichern von Animationen

Beispielanimationen


ERSTELLEN VON ANIMATIONEN

Sie können jedes beliebige FRAME animieren. Gehen Sie hierzu folgendermaßen vor:

  1. Erstellen Sie einen Bereich, dessen Aussehen von FRAME abhängt.

  2. Stellen Sie sicher, daß sich das Arbeitsblatt im automatischen Modus befindet.

  3. Wählen Sie Animieren aus dem Menü Ansicht, um das Dialogfeld "Animieren" zu öffnen.

  4. Umschließen Sie die Bereiche, die animiert werden sollen, mit einem Markierungsrechteck.

  5. Geben Sie im Dialogfeld die Anfangs- und Endwerte für FRAME ein.

  6. Klicken Sie auf "Animieren".

Im Dialogfeld wird eine Miniaturvorschau der Animation angezeigt. Mathcad zeichnet diese für jeden FRAME-Wert neu. Diese Vorschau-Animation entspricht nicht zwingend der Wiedergabegeschwindigkeit, da Sie zu diesem Zeitpunkt die Animation lediglich erstellen, sie aber noch nicht wiedergeben.


WIEDERGEBEN VON ANIMATIONEN

Nachdem Sie die Animation erstellt haben, wird im Dialogfeld "Wiedergeben" das erste Bild der Animation angezeigt. Jetzt können Sie die folgenden Schritte ausführen:

Wiedergeben der gesamten Animation durch Klicken auf die Wiedergabeschaltfläche

Anzeigen der Bilder nacheinander mit dem Schieberegler


SPEICHERN VON ANIMATIONEN

Nachdem Sie eine Animation erstellt haben, können Sie sie speichern. Sie können sie zu einem späteren Zeitpunkt wiedergeben lassen, ohne sie dazu zuvor noch einmal aufzeichnen zu müssen. Zum Speichern der Animation als Windows-AVI-Datei ist wie folgt vorzugehen:

  1. Das Dialogfeld "Animieren" muß geöffnet sein. (Sie öffnen das Dialogfeld mit dem Befehl Animieren aus dem Menü Ansicht.)

  2. Stellen Sie sicher, daß das erste Bild der Animation, die gespeichert werden soll, im Dialogfeld angezeigt wird.

  3. Ändern Sie erforderlichenfalls die Komprimierungsmethode für das Speichern der Dateien, indem Sie auf die Schaltfläche Optionen klicken.

  4. Klicken Sie auf die Schaltfläche "Speichern unter".


BEISPIELANIMATIONEN

Gehen Sie zum Anzeigen von Animationsbeispielen folgendermaßen vor:

  1. Öffnen Sie "QuickSheets" im Informationszentrum.

  2. Klicken Sie im Quicksheets-Inhaltsverzeichnis auf "Animationen".


IMPORTIEREN VON GRAFIKEN

Sie können zwar keine Bilder in Mathcad zeichnen, aber so gut wie alle Grafiken, die in anderen Anwendungen erstellt wurden, in ein Mathcad-Arbeitsblatt importieren. Grafiken können entweder als Bitmaps oder als OLE-Objekte importiert werden. Mit Hilfe der Bildverarbeitungsfunktionen können Sie die Grafik-Bilder als Matrix importieren, bearbeiten und dann wieder als Grafik-Bilddatei exportieren.

Arbeiten mit Bitmaps

Importieren eines Grafikbilds aus der Zwischenablage

Importieren von Bitmaps aus einer Datei

Einrahmen von Bitmaps

Ändern der Bitmap-Größe

Wiederherstellen der Ausgangsgröße einer Bitmap

Arbeiten mit OLE-Objekten

Importieren von Grafiken mit der Maus

Importieren eines Objekts aus der Zwischenablage

Direktes Einfügen von Objekten

Bearbeiten von Grafikobjekten

Bearbeiten von Verknüpfungen

Allgemein

Löschen eines Grafikbilds

Verschieben eines Grafikbilds

Bildverarbeitung

Übersicht über die Bildverarbeitung


IMPORTIEREN EINES GRAFIKBILDS AUS DER ZWISCHENABLAGE

Zum Importieren eines Grafikbilds aus einer anderen Anwendung über die Zwischenablage gehen Sie folgendermaßen vor:

  1. Kopieren Sie das Bild in die Zwischenablage.

  2. Klicken Sie mit der Maus auf die gewünschte Bildposition.

  3. Wählen Sie den Befehl Einfügen oder Inhalte einfügen aus dem Menü Bearbeiten, um das Bild in das Arbeitsblatt einzufügen.

Hinweis:

Wenn Sie Einfügen wählen, wird das Bild aus der Zwischenablage anhand der Standardinformationen eingefügt, die zusammen mit dem Bild in der Zwischenablage gespeichert sind. Soll das Bild als bestimmte Art von Objekt eingefügt werden (Bitmap, verknüpftes Objekt oder eingebettetes Objekt), wählen Sie den Befehl Inhalte einfügen.


IMPORTIEREN VON BITMAPS AUS EINER DATEI

Sie können Grafiken in ein Arbeitsblatt durch einen Verweis auf eine Datei einfügen, die diese Grafik enthält, anstatt sie über die Zwischenablage direkt einzufügen. Diese Vorgehensweise bietet mehrere Vorteile.

Zum Einfügen einer Grafik aus einer Bitmap-Datei gehen Sie folgendermaßen vor:

  1. Klicken Sie auf die gewünschte Bildposition, und wählen Sie Bild aus dem Menü Einfügen.

  2. Geben Sie ein doppeltes Anführungszeichen (") ein, um eine Zeichenfolge zu erstellen. Zwischen den Anführungszeichen erscheint eine Einfügemarke.

  3. Geben Sie den Pfadnamen der Bitmap-Datei ein.

Hinweise:

  • Wenn Sie die Datei auf der Festplatte ändern, müssen Sie in einen Grafikbereich klicken und Berechnen aus dem Menü Rechnen wählen, um das Arbeitsblatt zu aktualisieren.

  • Sobald Sie eine Bitmap anhand der genannten Schritte einfügen, können Sie ihre Größe verändern oder sie mit einem Rahmen versehen.

  • Sie können Bitmaps aus einer Datei auch mit einer der beiden folgenden Methoden importieren:

Einlesen der Datei als Datenmatrix

Einfügen der Datei als Objekt


IMPORTIEREN VON GRAFIKEN MIT DER MAUS

Zum Importieren eines Grafikbilds direkt aus einer anderen Anwendung gehen Sie folgendermaßen vor:

  1. Öffnen Sie die Quellanwendung.

  2. Ordnen Sie das Mathcad-Fenster und das Fenster der Quellanwendung nebeneinander auf dem Bildschirm an.

  3. Wählen Sie die Grafik in der Quellanwendung aus.

  4. Halten Sie die Maustaste gedrückt, und ziehen Sie den Cursor auf das Mathcad-Arbeitsblatt.

  5. Lassen Sie die Maustaste los, um die Grafik im Arbeitsblatt abzulegen.


Einfügen von Objekten

EINFÜGEN VON GRAFIKOBJEKTEN

Zum Einfügen einer neuen Grafik als Objekt in ein Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Wählen Sie Objekt aus dem Menü Einfügen. Das Dialogfeld "Objekt einfügen" wird geöffnet.

  2. Wählen Sie die Anwendung aus, in der es erstellt werden soll, und klicken Sie auf "OK".

  3. Die Grafik wird als eingebettetes Objekt eingefügt.

Zum Einfügen einer Grafik, die in einer vorhandenen Datei gespeichert ist, gehen Sie folgendermaßen vor:

  1. Wählen Sie Objekt aus dem Menü Einfügen. Das Dialogfeld "Objekt einfügen" wird geöffnet.

  2. Klicken Sie auf “Aus Datei erstellen:”, und legen Sie den Pfad zu der Datei fest, die die Grafik enthält.

  3. Klicken Sie auf “Verknüpfen”, wenn ein verknüpftes Objekt erstellt werden soll. Andernfalls wird das Objekt eingebettet.


BEARBEITEN EINES IMPORTIERTEN GRAFIKBILDS

Zum Bearbeiten eines Grafikbilds nach dem Einfügen in das Arbeitsblatt gehen Sie vor wie folgt:

  1. Doppelklicken Sie auf die Grafik.

  2. Stammt die Grafik aus einer Anwendung, die die Aktivierung in Fremdanwendungen unterstützt, wird das Grafikobjekt in einem gestrichelten Rahmen dargestellt und in Mathcad werden anstelle der eigenen Menüs und Symbolleisten die der Quellanwendung angezeigt. Stammt die Grafik hingegen aus einer Anwendung, die die Aktivierung in Fremdanwendungen nicht unterstützt oder handelt es sich um ein verknüpftes Objekt, so wird ein eigenes Fenster für die Bearbeitung geöffnet.

  3. Nehmen Sie die erforderlichen Änderungen vor.

Hinweis:

Wenn Sie eine Bitmap mit dem Befehl "Bild" einfügen oder ein Bild als Bitmap einfügen, können Sie die Bearbeitung nicht mit den obigen Schritten vornehmen.


BILDVERARBEITUNG

Die Bildverarbeitung läßt sich in vier Schritte unterteilen:

Einlesen des Bilds in eine Matrix

Durchführen mathematischer Transformationen für die Matrix

Anzeigen des Bilds

Speichern eines Bilds


ÖFFNEN DES INFORMATIONSZENTRUMS

Das Informationszentrum ist ein Elektronisches Buch, das in Mathcad bereits enthalten ist. Es enthält Informationen zu zahlreichen Themen, unter anderem auch ein Lernprogramm, ausführliche Einführungen zu bestimmten Mathcad-Funktionen sowie Verknüpfungen zum WWW.

Zum Öffnen des Informationszentrums gehen Sie folgendermaßen vor:

Wählen Sie den Befehl Informationszentrum aus dem Menü Hilfe.

Jetzt öffnen Sie ein neues Fenster, das die verschiedenen, verfügbaren Themen aufzeigt. Klicken Sie auf ein Thema, um es zu öffnen.


DIE SYMBOLLEISTE DES INFORMATIONSZENTRUMS

Mit der Symbolleiste des Informationszentrums können Sie Seiten im Informationszentrum verschieben, suchen, kopieren, drucken und speichern. Außerdem können Sie beliebige Dateien aus dem World Wide Web abrufen.

Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor über die Schaltfläche setzen, bis folgendes passiert:

  • In einem QuickInfo (kleinem Popup-Fenster) wird der Name der Schaltfläche angezeigt.

  • Eine Beschreibung der Schaltfläche erscheint in der Meldungszeile der Statusleiste.


DURCHSUCHEN DES INFORMATIONSZENTRUMS

Zum Suchen nach Informationen zu einem Thema gehen Sie folgendermaßen vor:

  1. Klicken Sie auf die Schaltfläche "Suchen" in der Symbolleiste oben im Fenster. Dadurch wird ein Dialogfeld geöffnet.

  2. Geben Sie ein Wort oder eine Wortfolge im Textfeld ein.

  3. Klicken Sie auf die Schaltfläche "Suchen" im Dialogfeld. Mathcad zeigt an, wie oft das Wort bzw. die Wortfolge im Informationszentrum vorkommt, in welchen Abschnitten, und wie oft in jedem Abschnitt.

  4. Zum Öffnen eines Bereichs doppelklicken Sie in der Auswahlliste auf seinen Namen.


NAVIGATION IM INFORMATIONSZENTRUM

Sie können sich im Informationszentrum auf zwei verschiedene Weisen bewegen:

Mit den Schaltflächen der Symbolleiste oben im Fenster.

Durch Klicken auf die entsprechenden Bereiche. Das Informationszentrum enthält ebenso wie diese Hilfedatei Sprungschalter. Diese Sprungschalter sind in der Regel unterstrichen oder auf andere Weise markiert.


DURCHGEHEN DES WWW VOM INFORMATIONSZENTRUM AUS

MathSoft unterhält speziell für Mathcad eine Site im World Wide Web. Sie können auch jede andere Homepage im WWW vom Informationszentrum aus aufrufen. Hierzu gehen Sie folgendermaßen vor:

Klicken Sie in der Symbolleiste des Informationszentrum auf die Schaltfläche "WWW-Symbolleiste". Daraufhin wird eine weitere Symbolleiste mit einer Adreßzeile eingeblendet:

Geben Sie im Feld "Adresse" eine URL für ein Dokument im Word Wide Web ein.

Mit den Schaltflächen links neben dem Feld "Adresse" können Sie eine Seite für einen späteren Besuch markieren, die aktuelle Seite neu laden oder die derzeitige Dateiübertragung unterbrechen.


KOPIEREN VON INFORMATIONEN AUS DEM INFORMATIONSZENTRUM

Zum Kopieren einer Seite aus dem Informationszentrum in das Arbeitsblatt gehen Sie vor wie folgt:

  1. Klicken Sie in der Symbolleiste "Informationszentrum" auf die Schaltfläche "Kopieren".

  2. Klicken Sie in das Hauptfenster des Arbeitsblatts.

  3. Wählen Sie den Befehl Einfügen aus dem Menü Bearbeiten.

Zum Ziehen eines Abschnitts aus dem Informationszentrum in Ihr Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Wählen Sie die Abschnitte oder Bereiche aus, die verschoben werden sollen.

  2. Setzen Sie den Mauszeiger in einen der Abschnitte oder Bereiche, die von einem Markierungsrechteck eingerahmt sind. Der Zeiger nimmt die Form einer kleinen Hand an.

  3. Halten Sie die Maustaste gedrückt.

  4. Ziehen Sie die Abschnitte bei gedrückter Maustaste aus dem Informationszentrum in das Arbeitsblatt.

  5. Sobald sich die Umrisse an den gewünschten Positionen befinden, lassen Sie die Maustaste wieder los.


EINFÜGEN VON ANMERKUNGEN IM INFORMATIONSZENTRUM

Sie können im Informationszentrum mit der Tastatur auf die gleiche Weise Änderungen eingeben wie in einem Arbeitsblatt.

Alles, was Sie im Informationszentrum hinzufügen oder ändern, wird in einer anderen Farbe dargestellt. Sie können diese Farbe einstellen, indem Sie im Menü Format den Befehl Farbe / Anmerkung wählen.

Wenn Sie Änderungen wieder rückgängig machen und das ursprüngliche Informationszentrum wiederherstellen möchten, müssen Sie nur das Fenster des Informationszentrums schließen oder die Anwendung beenden, ohne die Änderungen zu speichern.

Statt dessen können Sie auch die Änderungen speichern, das Original später abrufen oder das Original komplett wiederherstellen, ebenso wie bei jedem anderen Elektronischen Buch.


VERWENDEN DER WWW-FOREN

Die WWW-Foren erlauben die Bekanntmachung von Informationen und ermöglichen den Austausch von Ideen mit anderen Benutzern über das Internet. Voraussetzung für die Arbeit mit den WWW-Foren ist das Vorhandensein eines funktionierenden Internet-Anschlusses .

Um auf die WWW-Foren zugreifen zu können, ist wie folgt vorzugehen:

  1. Wählen Sie den Befehl Informationszentrum im Menü Hilfe, und klicken Sie auf "WWW-Foren".Daraufhin wird das Fenster mit den WWW-Foren geöffnet.

  2. Klicken Sie in der Liste der Foren links oben im Dialogfenster auf das gewünschte Forum, um es zu markieren.

  3. Klicken Sie dann auf eines der Themen in der Liste in der rechten oberen Ecke des Dialogfensters. Verwenden Sie gegebenenfalls die Bildlaufleisten, um sich alle Themen anzeigen zu lassen.

  4. In der unteren Hälfte des Fensters werden einige zusätzliche Informationen angezeigt. Anhand dieser Informationen können Sie feststellen, ob das Thema für Sie interessant ist. Wenn ja, können Sie es öffnen. Je nach Art der Datei passiert folgendes:

Wenn es sich bei der Datei um eine Textdatei handelt, erscheint im unteren Teil des Dialogfelds der Text der Datei.

Wenn es sich bei der Datei um ein Arbeitsblatt handelt, erscheint dieses in einem eigenen Arbeitsblatt-Fenster.

Wenn es sich bei der Datei um eine binäre Datei handelt, werden Sie aufgefordert anzugeben, wo die Datei geöffnet bzw. gespeichert werden soll.


ZUGANG ZUM INTERNET

Für den Anschluß Ihres Computers an das Internet benötigen Sie Software, mit der ein TCP/IP-Stack in Ihrem System erstellt werden kann. Wenn Sie über kein solches Stack verfügen, wird eine Fehlermeldung wie z. B. "WINSOCK.DLL nicht gefunden" angezeigt.

Software zum Erstellen eines solchen Stacks ist von vielen unterschiedlichen Quellen verfügbar. Weitere Angaben erhalten Sie von Ihrem Internet-Dienstanbieter oder Ihrem Systemverwalter.


SENDEN EINER TEXTNACHRICHT AN DIE WWW-FOREN

Zum Senden einer Textnachricht an die WWW-Foren gehen Sie folgendermaßen vor:

  1. Wählen Sie den Befehl Informationszentrum im Menü Hilfe, und klicken Sie auf "WWW-Foren", um das Fenster mit WWW-Foren zu öffnen.

  2. Klicken Sie auf das Forum, an das Sie Ihre Textnachricht senden wollen. Klicken Sie auf der rechten Seite auf ein Thema, wenn Sie auf eine Nachricht antworten wollen.

  3. Klicken Sie auf "Senden" bzw. "Antwort senden", um das Dialogfeld für Senden zu öffnen.

  4. Klicken Sie auf "Nachricht senden".

  5. Geben Sie in das Feld "Nachricht" den Text Ihrer Nachricht ein.

  6. Geben Sie in das Feld "Titel" einen Titel ein. Dies ist der Text, der erscheint, sobald jemand auf Ihre Nachricht klickt.

  7. Klicken Sie auf die Schaltfläche für Senden.

Ihre Nachricht wird daraufhin an den WWW-Foren-Server gesendet, und der Titel der Nachricht erscheint auf der rechten Seite des Fensters mit WWW-Foren.


SENDEN EINER DATEI AN DIE WWW-FOREN

Zum Senden einer Datei an die WWW-Foren gehen Sie folgendermaßen vor:

  1. Wählen Sie den Befehl Informationszentrum im Menü Hilfe, und klicken Sie auf "WWW-Foren", um das Fenster mit WWW-Foren zu öffnen.

  2. Klicken Sie auf das Forum, an das Sie Ihre Datei senden wollen. Klicken Sie auf der rechten Seite auf ein Thema, wenn Sie auf eine Nachricht antworten wollen.

  3. Klicken Sie auf "Senden" bzw. "Antwort senden", um das Dialogfeld für Senden zu öffnen.

  4. Klicken Sie auf "Andere Datei senden".

  5. Geben Sie in das Feld "Titel" einen Titel ein. Dies ist der Text, der erscheint, sobald jemand auf Ihre Nachricht klickt.

  6. Klicken Sie auf die Schaltfläche für Senden.

Ihre Datei wird daraufhin an den WWW-Foren-Server gesendet, und der Titel der Datei erscheint auf der rechten Seite des Fensters mit WWW-Foren.


SENDEN EINES ARBEITSBLATTS AN DIE WWW-FOREN

Zum Senden eines Arbeitsblatts an die WWW-Foren gehen Sie folgendermaßen vor:

  1. Wählen Sie den Befehl Informationszentrum im Menü Hilfe, und klicken Sie auf "WWW-Foren", um das Fenster mit WWW-Foren zu öffnen.

  2. Klicken Sie auf das Forum, an das Sie Ihr Arbeitsblatt senden wollen. Klicken Sie auf der rechten Seite auf ein Thema, wenn Sie auf eine Nachricht antworten wollen.

  3. Klicken Sie auf "Senden" bzw. "Antwort senden", um das Dialogfeld für Senden zu öffnen.

  4. Wenn das zu sendende Arbeitsblatt gerade geöffnet ist, klicken Sie auf "Aktuelle Datei senden". Andernfalls müssen Sie auf "Andere Datei senden" klicken.

  5. Geben Sie in das Feld "Titel" einen Titel ein. Dies ist der Text, der erscheint, sobald jemand auf Ihre Nachricht klickt.

  6. Klicken Sie auf die Schaltfläche für Senden.

Ihre Nachricht wird daraufhin an den WWW-Foren-Server gesendet, und der Titel des Arbeitsblatts erscheint auf der rechten Seite des Fensters mit WWW-Foren.


LÖSCHEN EINES THEMAS AUS DEN WWW-FOREN

Zum Löschen eines an die WWW-Foren gesendeten Themas gehen Sie folgendermaßen vor:

  1. Wählen Sie den Befehl Informationszentrum aus dem Menü Hilfe, und klicken Sie auf "WWW-Foren", um das Fenster mit den WWW-Foren zu öffnen.

  2. Klicken Sie auf das Forum, das das zu löschende Thema enthält.

  3. Klicken Sie dann auf das Thema, das gelöscht werden soll. Die Themen im Forum werden in der Liste auf der rechten Seite des Fensters angezeigt.

  4. Drücken Sie die Taste Entf.

Ihr Thema wird daraufhin aus der Liste auf der rechten Seite des Fensters entfernt.


Elektronische Mathcad-Bücher und Erweiterungspakete

DIE ELEKTRONISCHEN BÜCHER UND ERWEITERUNGSPAKETE VON MATHSOFT

Mit der MathSoft-Reihe Elektronischer Bücher und Erweiterungspakete erhalten Sie einen dynamischen, interaktiven Zugang zu Informationen, die Sie täglich benötigen und nutzen. In ihnen werden bestimmte Themen aus unterschiedlichen Bereichen behandelt, die vom Maschinenbau über erweiterte Mathematik bis hin zur Bildverarbeitung reichen.

Anders als herkömmliche Druckerzeugnisse bieten elektronische Bücher und Erweiterungspakete bestimmte Funktionen, die bei der Arbeit mit Mathcad äußerst nützlich sind:

  • Jede Seite ist ein dynamisches Arbeitsblatt, in dem Sie z. B. Werte und Gleichungen berechnen können.

  • Sie können Daten und Formeln in den Mathcad-Arbeitsblättern, die Sie erstellen, kopieren und einfügen.

  • Wenn Sie auf eine Überschrift oder einen Indexeintrag doppelklicken, wird der entsprechende Abschnitt geöffnet. Sie können das Buch auch seiten- oder kapitelweise durchsuchen.

  • Sie können eine elektronische Suche nach allen Textstellen durchführen, in denen ein bestimmtes Wort vorkommt.

  • Sie können den Inhalt verändern und die Änderungen gegebenenfalls speichern.

Nähere Informationen zu dem breiten Sortiment an elektronischen Büchern und Erweiterungspaketen, die von MathSoft erhältlich sind, erhalten Sie unter http://www.mathsoft.com/webstore und natürlich direkt bei MathSoft.


DURCHBLÄTTERN EINES ELEKTRONISCHEN BUCHS

Sie können sich in einem elektronischen Buch auf zweierlei Weise orientieren:

Mit Hilfe der Schaltflächen auf der Steuerleiste oben im Fenster.

Durch Klicken Sie mit der Maus auf die hervorgehobenen Bereiche. Elektronische Bücher enthalten ebenso wie diese Hilfedatei Hypertext-Verknüpfungen. Derartige Bereiche sind gewöhnlich unterstrichen oder anderweitig markiert, um ihre Funktion anzudeuten.


DURCHSUCHEN EINES ELEKTRONISCHEN BUCHS

Sie können Informationen zu einem Thema suchen, indem Sie in der Steuerungsleiste oben im Fenster auf die Schaltfläche "Startseite".

Außerdem können Sie wie folgt nach jedem Vorkommen einer Textzeichenfolge suchen:

  1. Klicken Sie in der Steuersymbolleiste oben am Fenster auf die Schaltfläche "Suchen".

  2. Geben Sie ein Wort in das Textfeld ein. In der Auswahlliste werden Wörter angezeigt, die die eingegebenen Zeichen enthalten.

  3. Klicken Sie auf die Schaltfläche "Suchen". Mathcad zeigt an, wie oft das Wort im Elektronischen Buch vorkommt, in welchen Abschnitten, und wie oft in den einzelnen Abschnitten.

  4. Um einen Abschnitt zu öffnen, klicken Sie auf seinen Namen in der Auswahlliste und dann auf die Schaltfläche "Gehe zu".

  5. Klicken Sie auf die Schaltfläche "Nächster". Die Anzeige wird nach unten gerollt, bis das nächste Vorkommen der Zeichenfolge im Buchfenster sichtbar ist. Die Schaltfläche wird abgeblendet, wenn das letzte Vorkommen erreicht ist.

  6. Mit der Schaltfläche "Voriger" blättern Sie im Buchfenster zurück zur vorherigen Textstelle, an der das gesuchte Wort vorkommt. Die Schaltfläche wird abgeblendet, wenn das erste Vorkommen erreicht ist.


KOPIEREN VON ANGABEN AUS EINEM ELEKTRONISCHEN BUCH

Zum Kopieren einer Seite aus einem elektronischen Buch in Ihr Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Klicken Sie in der Steuerleiste auf die Schaltfläche "Kopieren".

  2. Klicken Sie auf das Arbeitsblatt-Hauptfenster.

  3. Wählen Sie Einfügen aus dem Menü Bearbeiten.

Zum Ziehen eines elektronischen Buchbereichs in das Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Wählen Sie die Bereiche aus, die verschoben werden sollen.

  2. Ziehen Sie den Mauszeiger in einen Bereich, der von einem gestrichelten Markierungsrechteck umrahmt wird. Der Zeiger nimmt die Form einer kleinen Hand an.

  3. Halten Sie die Maustaste gedrückt.

  4. Ziehen Sie die Bereiche bei gedrückter Maustaste aus dem Informationszentrum in das Arbeitsblatt.

  5. Wenn sich die Umrisse an der gewünschten Position befinden, lassen Sie die Maustaste wieder los.


VERSEHEN EINES ELEKTRONISCHEN BUCHS MIT ANMERKUNGEN

Sie können im Elektronischen Buch ebenso Änderungen vornehmen wie in einem gewöhnlichen Mathcad-Arbeitsblatt. Diese Änderungen gehen aber verloren, wenn Sie das Buch schließen.

Sollen die Änderungen dauerhaft werden, wählen Sie Anmerkungen in Buch aus dem Kontextmenü Bücher im Fenster "Informationszentrum/Elektronisches Buch". Daraufhin geschieht folgendes:

Mathcad erstellt eine zusätzliche Kopie des elektronischen Buchs und speichert Ihre Änderungen dort.

Alle Änderungen werden in einer unterschiedlichen Farbe hervorgehoben.

Nachdem Mathcad eine Kopie Ihres elektronischen Buchs erstellt hat, wird stets die Kopie anstelle des Originals geöffnet, wenn Sie das elektronische Buch öffnen.


WEITERE ELEKTRONISCHE BÜCHER

MathSoft unterstützt eine wachsende Bibliothek Elektronischer Bücher .

Weitere Informationen sowie unseren Produktkatalog können Sie von uns unter der US-Telefonnummer 1-800-MATHCAD, oder per E-Mail unter den Adressen sales-info@mathsoft.com und int-info@mathsoft.co.uk anfordern. Die neuesten Produktinformationen finden Sie im MathSoft Internet-Webstore unter http://www.mathsoft.com/webstore.


ÖFFNEN EINES ELEKTRONISCHEN BUCHS

So öffnen Sie ein Erweiterungspaket:

  1. Wählen Sie Öffnen aus dem Menü Datei.

  2. Wählen Sie im Listenfeld “Dateityp” die Option “Mathcad-Bücher (*.hbk)”.

  3. Suchen Sie im Dialogfeld nach einem der verfügbaren elektronischen Bücher oder Erweiterungspakete, oder geben Sie den Namen eines elektronischen Buchs oder Erweiterungspakets ein.

Das elektronische Buch bzw. Erweiterungspaket wird im Fenster "Informationszentrum" geöffnet. Mit der Symbolleiste können Sie sich im Fenster bewegen.

Hinweis: Sie können die Funktionen des Erweiterungspakets auch dann nutzen, wenn es nicht geöffnet ist. Sobald ein Erweiterungspaket installiert ist, sind seine Funktionen jederzeit verfügbar.


VERZEICHNIS DER TASTATURBEFEHLE

In dieser Liste finden Sie alle Tastaturbefehle nach ihrer Funktion geordnet. Wenn Sie wissen möchten, was ein bestimmter Tastaturbefehl bewirkt, können Sie auf der Registerkarte "Suchen" nach dem Tastaturbefehl suchen.

Standardmäßig übernimmt Mathcad 8 die üblichen Windows-Tastaturbefehle für die meisten gängigen Operationen. Wenn Sie zuvor mit einer älteren Version von Mathcad gearbeitet haben, ziehen Sie eventuell die klassischen Mathcad-Tastaturbefehle vor. In diesem Fall wählen Sie Einstellungen aus dem Menü "Ansicht", und klicken Sie auf die Option "Standardmäßige Windows-Tastaturbefehle verwenden", um Sie zu deaktivieren.

Griechische Buchstaben

Operatoren

Arbeitsblätter und Fenster

Bearbeiten

Richtungs- und Bewegungstasten

Erstellen von Bereichen


GRIECHISCHE BUCHSTABEN

Zum Einfügen griechischer Buchstaben gehen Sie wie folgt vor:

Geben Sie den entsprechenden Buchstaben aus der untenstehenden Tabelle ein.

Drücken Sie Strg+G.

Sie können statt dessen auch auf den gewünschten Buchstaben in der Symbolleiste "Griechisch" klicken. Den griechischen Buchstaben pi können Sie auch eingeben, indem Sie Strg+Umschalt+p drücken.


Operatortasten

TASTEN ZUM ERSTELLEN VON OPERATOREN

Mit den folgenden Tasten werden Operatoren eingefügt. Mit einer Ausnahme (der Taste " ) entspricht ihre Funktion in der freien Fläche der in einer Gleichung.

Tastaturbefehl | Operator
! | Fakultät
" | Konjugiert komplexe Zahl
# | Bereichsprodukt
$ | Bereichssumme
& | Integralberechnung
' | Paar von Klammern
( | Linke Klammer
) | Rechte Klammer
* | Multiplikation oder inneres (Punkt) Produkt
+ | Addition
, | Trennt Argumente in einer Funktion Trennt abzubildende Ausdrücke auf der gleichen Achse Steht vor der zweiten Zahl im Bereich
; | Steht vor der letzten Zahl im Bereich
 | Negation oder Subtraktion
/ | Division
< | Kleiner als
> | Größer als
? | Ableitung
[ | Vektortieferstellung oder Matrixtieferstellung
\ | Quadratwurzel
^ | Exponentialberechnung
| | Absolutwert oder Determinante
Strg+1 | Transponieren
Strg+3 | Nicht gleich
Strg+4 | Summe der Elemente im Vektor
Strg+9 | Kleiner oder gleich
Strg+0 | Größer oder gleich
Strg+8 | Vektorprodukt
Strg+ | Vektorisieren
Strg+= | Gleich
Strg+6 | Hochgestellter Index
Strg+Umschalt+4 | Summierung
Strg+Umschalt+3 | Produkt
Strg+Umschalt+? | n-te Ableitung
Strg+\ | n-te Wurzel
Strg+Eingabetaste | Addition mit Zeilenumbruch
Strg+I | Unbestimmtes Integral
Strg+L | Grenzwert
Strg+A | Rechter Grenzwert
Strg+B | Linker Grenzwert
Strg+Punkt | Symbolisches Gleichheitszeichen
Strg+Umschalt+Punkt | Schlüsselwort symbolisches Gleichheitszeichen


TASTATURBEFEHLE FÜR DIE ARBEITSBLATT- UND FENSTERVERWALTUNG

Die folgenden Tastaturbefehle ermöglichen die Arbeit mit Fenstern und Arbeitsblättern als ganzes.

Strg+F4 Schließt das Arbeitsblatt.

Strg+F6 Aktiviert das nächste Fenster.

Strg+K Fügt einen Hyperlink ein oder ermöglicht seine Bearbeitung.

Umschalt+Eingabe Verläßt einen Textbereich.

Strg+N Erstellt ein neues Arbeitsblatt.

Strg+O Öffnet das Arbeitsblatt.

Strg+P Druckt ein Arbeitsblatt.

Strg+S Speichert ein Arbeitsblatt.

Alt+F4 Beenden.

Strg+R Zeichnet den Bildschirm neu.

F1 Öffnet das Hilfefenster.

F9 Berechnet den Bildschirm neu.

Umschalt+F1 Schaltet die kontextsensitive Hilfe ein bzw. aus.

Esc Schließt die kontextsensitive Hilfe oder unterbricht eine Berechnung.


TASTATURBEFEHLE FÜR DAS BEARBEITEN

Eingabe Fügt eine Leerzeile ein. Innerhalb von Text wird ein neuer Absatz eingefügt.

Entf Löscht eine Leerzeile. Innerhalb von Text oder Rechenbereichen wird das Zeichen rechts neben der Einfügelinie gelöscht.

Umschalt+Eingabe Innerhalb von Text wird eine neue Zeile im gleichen Absatz eingefügt.

Strg+Eingabe Fügt einen Seitenumbruch ein. Innerhalb von Text wird die Breite des Textbereichs bestimmt. In Rechenbereichen wird eine Addition mit dem Zeilenumbruch-Operator eingefügt.

Strg+A Innerhalb von Text wird der gesamte Text im Textbereich ausgewählt.

Strg+A In einer leeren Fläche werden alle Bereiche im Arbeitsblatt ausgewählt.

Strg+Umschalt+Eingabe In einem Bereich wird der Cursor nach außen unter den Bereich verschoben.

Strg+F Sucht ein Zeichen oder eine Zeichenfolge.

Strg+H Ersetzt ein Zeichen oder eine Zeichenfolge.

Strg+Z Macht den letzten Bearbeitungsschritt rückgängig.

Strg+Y Wiederherstellen. Stellt die rückgängig gemachte Aktion wieder her.

Strg+C Kopiert die Auswahl in die Zwischenablage

Strg+V Fügt den Inhalt der Zwischenablage in das Arbeitsblatt ein.

Strg+X Schneidet die Auswahl aus und stellt sie in die Zwischenablage.

Strg+E Öffnet das Dialogfeld "Funktion einfügen".

Strg+U Öffnet das Dialogfeld "Einheit einfügen".

Strg+Umschalt+J Ermöglicht die Eingabe von Zeichen in eckigen Klammern wie bei der chemischen Notation.

Strg+Umschalt+K Ermöglicht die Eingabe von Zeichen, mit denen normalerweise Operatoren eingefügt werden.

Einfg Wechselt in den Einfügemodus.


PFEIL- UND NAVIGATIONSTASTEN

Pfeil-nach-oben

Pfeil-nach-unten

Pfeil-nach-links

Pfeil-nach-rechts

Umschalt + Pfeil-nach-oben

Umschalt + Pfeil-nach-unten

Umschalt + Pfeil-nach-links

Umschalt + Pfeil-nach-rechts

Strg + Pfeil-nach-oben

Strg + Pfeil-nach-unten

Strg + Pfeil-nach-links

Strg + Pfeil-nach-rechts

Tabulator

Umschalt + Tabulator

Pos1

Ende

Strg + Pos1

Strg + Ende

Eingabe

Leertaste

Strg + Eingabetaste Fügt in leeren Bereichen einen Seitenumbruch ein.

Bild-auf Verschiebt die Fensteranzeige um etwa 80 % nach oben.

Bild-ab Verschiebt die Fensteranzeige um etwa 80 % nach unten.

Umschalt+Bild-auf Zeigt den vorhergehenden Seitenumbruch an.

Umschalt+ Bild-ab Zeigt den nächstfolgenden Seitenumbruch an.


TASTATURBEFEHLE FÜR DIE ERSTELLUNG VON BEREICHEN

@ Legt XY-Diagramm an.

Strg+7 Legt Kreisdiagramm an.

Strg+2 Legt Flächendiagramm an.

Strg+G Ändert das vorhergehende Zeichen von "griechisch" in "lateinisch" und umgekehrt.

Strg+M Erstellt eine Matrix oder einen Vektor.

Strg+Umschalt+A (In Textbereich) Fügt Rechendaten in Text ein.

Strg+Umschalt+A (Außerhalb von Text) Fügt den Operator für den linken Grenzwert ein.

Strg+Umschalt+B Fügt den Operator für den rechten Grenzwert ein.

Strg+Umschalt+J Stellt auf chemische Notation um. Erstellen Sie z. B. einen Bereich, in dem jeder eingegebene Ausdruck als einzelner Variablenname behandelt wird.

Strg+Umschalt+P Fügt den griechischen Buchstaben pi ein.

Strg+Umschalt+Z Fügt das Zeichen für Unendlichkeit ein.

Entf (in Bereich) Löscht den Bereich.


So erreichen Sie MathSoft, Inc:

USA & Kanada

Postanschrift:

MathSoft Inc.
101 Main St.
Cambridge, MA 02142
USA

Tel.: 1-800-MATHCAD oder 617-577-1017
Fax: 617-577-8829
E-Mail: sales-info@mathsoft.com
Web-Site: http://www.mathsoft.com

Technischer Kundendienst

Alle anderen Länder

Postanschrift:

MathSoft Interational
Knightway House
Park Street
Bagshot, Surrey
GU19 5AQ
Großbritannien

Tel.: +44 1276 452299
Fax: +44 1276 451224
E-Mail: int-info@mathsoft.co.uk
Web-Site: http://www.mathsoft.com

Technischer Kundendienst


Kontextsensitive Hilfe

Bei der Arbeit mit Mathcad steht eine kontextsensitive Hilfe zur Verfügung:

  • Klicken Sie bei Menübefehlen auf den Befehl. Die Hilfe wird in der Meldungszeile am unteren Fensterrand angezeigt

  • Bei Schaltflächen in Symbolleisten oder Paletten lassen Sie den Zeiger kurz über der Schaltfläche stehen. Daraufhin wird ein QuickInfo angezeigt.

  • Bei Fehlermeldungen, integrierten Funktionen und Variablen oder Operatoren klicken Sie auf das betreffende Element, und drücken Sie dann die Taste F1.

  • Bei mehreren Elementen drücken Sie Umschalt F1. Nachdem ein Fragezeichen als Mauszeiger angezeigt wird, können Sie auf das betreffende Element klicken. Sie können mit der Bearbeitung fortfahren, indem Sie Esc oder Umschalt F1 drücken, so daß der Mauszeiger wieder als Pfeil erscheint.

Verwandte Themen

Verwenden des Hilfesystems

Drucken aus dem Hilfesystem

Weiter Informationsquellen


Steuern des Hilfensters

Steuern des Hilfefensters

Standardmäßig ist der linke Bereich im Hilfefenster dreigeteilt und enthält Registerkarten zum Zugriff auf ein Inhaltsverzeichnis, einen Index und ein Modul zur Volltextsuche. Sie können jedoch auf Wunsch das dreigeteilte Fenster auch ausblenden. Außerdem können Sie das Inhaltsverzeichnis und den Index anweisen, nur bestimmte Themenkategorien anzuzeigen.

Ausblenden des dreigeteilten Fensters

Zum Ausblenden des dreigeteilten Fensters gehen Sie folgendermaßen vor:

Klicken Sie auf die Schaltfläche [image].

Um das dreigeteilte Fenster wieder einzublenden, klicken Sie auf die Schaltfläche [image].

Beschränken der Anzeige auf bestimmte Themen

Zum Anzeigen nur bestimmter Hilfethemen im Index und Inhaltsverzeichnis gehen Sie vor wie folgt:

Klicken Sie auf die Schaltfläche [image], und wählen Sie Anpassen.

Kreuzen Sie die Themen an, die angezeigt werden sollen.

Verwandte Themen

Verwenden des Hilfesystems

Drucken aus dem Hilfesystem

Steuern des Hilfefensters

Kontextsensitive Hilfe

Weitere Informationsquellen


Kopieren aus dem Hilfesystem

Zum Kopieren von Text aus dem Hilfesystem gehen Sie vor wie folgt:

  1. Wählen Sie den Text aus, indem Sie die Maustaste gedrückt halten und die Maus über den Text ziehen.

  2. Klicken Sie mit der rechten Maustaste auf den ausgewählten Text.

  3. Wählen Sie Kopieren aus dem Kontextmenü.

Verwandte Themen

Verwenden des Hilfesystems

Drucken aus dem Hilfesystem

Steuern des Hilfefensters

Kontextsensitive Hilfe

Weitere Informationsquellen


BESSELFUNKTION I0

I0(x) Gibt I0(x) zurück.

Argumente:

x muß eine reelle skalare Zahl sein.

x darf keine Einheiten haben.

Besselfunktionen entstehen typischerweise als Lösungen der Wellengleichung, wobei zylindrische Randbedingungen zugrundeliegen.

Diese modifizierte Besselfunktion der ersten Art ist die Lösung der folgenden Differentialgleichung:

wobei n=0 ist.


BESSELFUNKTION I1

I1(x) Gibt I1(x) zurück.

Argumente:

x muß eine reelle skalare Zahl sein.

x darf keine Einheiten haben.

Besselfunktionen entstehen typischerweise als Lösungen der Wellengleichung, wobei zylindrische Randbedingungen zugrundeliegen.

Diese modifizierte Besselfunktion der ersten Art ist die Lösung der folgenden Differentialgleichung:

wobei n=1 ist.


BESSELFUNKTION IN

In(m, x) Gibt Im(x) zurück.

Argumente:

x darf keine Einheiten haben.

m muß eine ganze Zahl zwischen 1 und einschließlich 100 sein.

Besselfunktionen entstehen typischerweise als Lösungen der Wellengleichung, wobei zylindrische Randbedingungen zugrundeliegen.

Diese modifizierte Besselfunktion der ersten Art ist die Lösung der folgenden Differentialgleichung:

wobei n=m ist.


BESSELFUNKTION J0

J0(x) Gibt J0(x) zurück.

Argumente:

x muß eine reelle skalare Zahl sein.

x darf keine Einheiten haben.

Besselfunktionen entstehen typischerweise als Lösungen der Wellengleichung, wobei zylindrische Randbedingungen zugrundeliegen.

Diese Besselfunktion der ersten Art ist die Lösung der folgenden Differentialgleichung:

wobei n=0 ist.


BESSELFUNKTION J1

J1(x) Gibt J1(x) zurück.

Argumente:

x muß eine reelle skalare Zahl sein.

x darf keine Einheiten haben.

Besselfunktionen entstehen typischerweise als Lösungen der Wellengleichung, wobei zylindrische Randbedingungen zugrundeliegen.

Diese Besselfunktion der ersten Art ist die Lösung der folgenden Differentialgleichung:

wobei n=1 ist.


BESSELFUNKTION JN

Jn(m, x) Gibt Jm(x) zurück.

Argumente:

x muß eine reelle skalare Zahl sein.

x darf keine Einheiten haben.

m muß eine ganze Zahl zwischen 1 und einschließlich 100 sein.

Besselfunktionen entstehen typischerweise als Lösungen der Wellengleichung, wobei zylindrische Randbedingungen zugrundeliegen.

Diese Besselfunktion der ersten Art ist die Lösung der folgenden Differentialgleichung:

wobei n=m ist.


BESSELFUNKTION K0

K0(x) Gibt K0(x) zurück.

Argumente:

x muß eine reelle skalare Zahl sein.

x darf keine Einheiten haben.

x muß größer als 0 sein.

Besselfunktionen entstehen typischerweise als Lösungen der Wellengleichung, wobei zylindrische Randbedingungen zugrundeliegen.

Diese modifizierte Besselfunktion der zweiten Art ist die Lösung der folgenden Differentialgleichung:

wobei n=0 ist.


BESSELFUNKTION K1

K1(x) Gibt K1(x) zurück.

Argumente:

x muß eine reelle skalare Zahl sein.

x darf keine Einheiten haben.

x muß größer als 0 sein.

Besselfunktionen entstehen typischerweise als Lösungen der Wellengleichung, wobei zylindrische Randbedingungen zugrundeliegen.

Diese modifizierte Besselfunktion der zweiten Art ist die Lösung der folgenden Differentialgleichung:

wobei n=1 ist.


BESSELFUNKTION KN

Kn(m, x) Gibt Km(x) zurück.

Argumente:

x darf keine Einheiten haben.

x muß größer als 0 sein.

m muß eine ganze Zahl zwischen 1 und einschließlich 100 sein.

Besselfunktionen entstehen typischerweise als Lösungen der Wellengleichung, wobei zylindrische Randbedingungen zugrundeliegen.

Diese modifizierte Besselfunktion der zweiten Art, Km(x), ist die Lösung der folgenden Differentialgleichung:

wobei n=m ist.


Glätten von Daten mit Hilfe eines Gaußschen Kerns

GLÄTTEN VON DATEN MIT HILFE EINES GAUSSSCHEN KERNS (nur in Mathcad Professional)

kgltt(vx,vy,b) Gibt einen aus m Elementen bestehenden Vektor zurück, der durch Glättung mit Hilfe eines Gaußschen Kerns entsteht. Bei den zurückgegebenen Werten handelt es sich um die gewichteten Mittel der Elemente in vy.

Argumente:

vx ist ein aus m Elementen bestehender Vektor aus reellen Zahlen. Bei strgltt müssen die Elemente von vx in aufsteigender Reihenfolge geordnet sein.

vy ist ein aus m Elementen bestehender Vektor aus reellen Zahlen.

b ist die Bandbreite des Glättungsfensters. Der Wert sollte einige Male größer als der Abstand zwischen x Datenpunkten sein.

Hinweise:

  • Diese Funktion ist vor allem für die Fälle geeignet, in denen die Daten entlang eines Bandes mit relativ konstanter Breite liegen.


GLÄTTEN VON DATEN MIT GLEITENDEN MITTELWERTEN

medgltt(vy,n) Gibt einen aus m Elementen bestehenden Vektor zurück, der durch die Glättung von vy mit gleitenden Mittelwerten entsteht.

Argumente:

vy ist ein aus m Elementen bestehender Vektor aus reellen Zahlen.

n ist die Breite des Fensters, in dem eine Glättung stattfinden soll. n muß eine ungerade Anzahl von Elementen sein, die kleiner als die der Elemente in vy ist.

Hinweise:

  • Diese Funktion ist die robusteste Anpassungsfunktion, da sie am wenigsten von störenden Datenpunkten beeinträchtigt werden kann.


Glätten von Daten mit Hilfe eines adaptiven Verfahrens

GLÄTTEN VON DATEN MIT HILFE EINES ADAPTIVEN VERFAHRENS (nur in Mathcad Professional)

strgltt(vx,vy) Gibt einen aus m Elementen bestehenden Vektor zurück, der durch die stückweise Ausführung eines symmetrischen linearen MKQ-Anpassungsverfahrens unter Berücksichtigung des k am nächsten stehenden Nachbarn entsteht, wobei k der jeweiligen Situation angepaßt wird.

Argumente:

vx ist ein aus m Elementen bestehender Vektor aus reellen Zahlen in aufsteigender Reihenfolge.

vy ist ein aus m Elementen bestehender Vektor aus reellen Zahlen.

Hinweise:

Dieses adaptive Glättungsverfahren eignet sich vor allem dann, wenn die Daten über ein Band verstreut liegen, dessen Breite stark veränderlich ist.


Y0 BESSELSCHE FUNKTION

Y0(x) Ergibt Y0(x).

Argumente:

x muß ein reeller Skalar sein.

x darf keine Einheiten haben.

x muß größer sein als 0.

Diese Besselsche Funktion der zweiten Art (Neumann-Funktion) bildet die Lösung der folgenden Differentialgleichung:

hierbei gilt: n = 0


Y1 BESSELSCHE FUNKTION

Y1(x) Ergibt Y1(x).

Argumente:

x muß ein reeller Skalar sein.

x darf keine Einheiten haben.

x muß größer sein als 0.

Diese Besselsche Funktion der zweiten Art (Neumann-Funktion) bildet die Lösung der folgenden Differentialgleichung:

hierbei gilt: n = 1


YN BESSELSCHE FUNKTION

Yn(m, x) Ergibt Ym(x).

Argumente:

x muß ein reeller Skalar sein.

x darf keine Einheiten haben.

x muß größer sein als 0.

m muß eine ganze Zahl zwischen 1 und 100 sein.

Diese Besselsche Funktion der zweiten Art (Neumann-Funktion) bildet die Lösung der folgenden Differentialgleichung:

hierbei gilt: n = m


Gaußsche hypergeometrische Funktion

fhyper(a,b,c,x) Gibt den Wert der Gaußschen hypergeometrischen Funktion, 2F1(a,b;c;x), zurück.

Argumente:

a, b und c sind reelle Skalare.

x ist ein reeller Skalar.

x liegt zwischen -1 und 1.

Die Gaußsche hypergeometrische Funktion ist die Lösung der folgenden Differentialgleichung:

Viele Funktionen sind Sonderfälle der Gaußschen hypergeometrischen Funktion. Beispiel:

ln(1+x)=x.fhyper(1,1,2,-x)

asin(x)=x.fhyper(.5,.5,1.5,x2)


Verwenden des Hilfesystems

Willkommen!

Willkommen beim HTML-Hilfesystem von Mathcad. Das Hilfesystem arbeitet in einem dreiteiligen Fenster, so daß Sie die benötigten Informationen leicht und schnell finden. Im dreiteiligen Fenster finden Sie drei Registerkarten, über die Sie Informationen abrufen können:

  • Auf der Registerkarte Inhalt steht ein Inhaltsverzeichnis bereit, das Ihnen eine Übersicht über die vorhandenen Themen und einen roten Faden durch die Hilfe bietet.

  • Auf der Registerkarte Index werden Sie über die angefragten Stichwörter zu den entsprechenden Themen geführt. Verwenden Sie den Index, wenn Sie bereits wissen, nach welchem Thema Sie suchen.

  • Im Register Suchen wird das gesamte Hilfesystem nach einem angeforderten Begriff bzw. einer angeforderten Wortfolge durchsucht. Die Volltextsuche ist nützlich, wenn Sie nur nach einem bestimmten Wort oder einem Satz suchen und nicht nach einem Thema.

Wenn Sie auf ein Thema doppelklicken, wird es rechts im Fenster angezeigt.

Welches Thema interessiert Sie als nächstes?

Weitere Informationen über Mathcad

Bedienung des Hilfefensters und Abrufen von Hilfethemen

Drucken aus der Hilfe

Kontextsensitive Hilfe

Weitere gedruckte oder online erhältliche Informationsquellen


DIALOGFELD "3D-DIAGRAMMFORMAT": REGISTERKARTE "ERWEITERT"

Nebel aktivieren

Schattiert das Diagramm so, als ob es von Nebel umgeben wäre. Weiter entfernte Teile des Diagramms werden verschwommen dargestellt, so daß der Eindruck von Tiefe entsteht. Diagramme werden bei aktiviertem Nebel langsamer gezeichnet.

Perspektive

Das Diagramm wird so dargestellt, als würde es aus einer Distanz betrachtet. Die Teile des Diagramms, die sich weiter weg befinden, werden kleiner dargestellt als die näheren Teile gleiche Größe. Geben Sie den Abstand im Textfeld "Sichtweite" ein.

Sichtweite

Gibt den Abstand an, wenn "Perspektive" aktiviert ist.

Vertikale Skalierung

Legt die Darstellungsgröße der großen Teile fest. Ist die vertikale Skalierung auf einen niedrigen Wert eingestellt, sind die Unterschiede in der Höhe kaum erkennbar. Bei 100 sind die Unterschiede so groß, daß das Diagramm den gesamten Rahmen einnimmt.

Farbzuordnung - Ansteigend X, Ansteigend Y, Ansteigend Z

Ordnet die Werte in der ausgewählten Farbzuordnung entsprechend den x-Werten, y-Werten oder z-Werten zu.

Farbzuordnung wählen

Bestimmt die Farbzuordnung, die für Füllungen, Linien und Punkte verwendet werden soll, wenn "Farbzuordnung" für alle drei Aspekte auf der Seite "Darstellung" aktiviert ist.

Glanz

Durch höhere Werte erscheint das Diagramm glänzender, wenn die Beleuchtung auf der Seite "Beleuchtung" aktiviert und die Oberfläche des Diagramms auf der Seite "Darstellung" gefüllt ist. Durch eine glänzendere Oberfläche wird mehr Glanzlicht reflektiert.

% Transparenz

Bei hohen Werten ist das Diagramm transparenter, so daß hindurchgesehen werden kann.

Polygonabstand

Hiermit werden Linien und eine gefüllte Oberfläche abgesetzt, wenn Linien gezogen und die Flächen eines Diagramms gefüllt sind. Ist hierfür Null festgelegt, können die Linien so dargestellt werden, als verliefen sie hinter der Fläche. Es entsteht der Eindruck von "Nähten".


DIALOGFELD "3D-DIAGRAMMFORMAT": REGISTERKARTE "DARSTELLUNG"

Fläche füllen

Füllt die Diagrammfläche mit einer Farbzuordnung oder mit einer im Abschnitt "Farboptionen" festgelegten Volltonfarbe.

Umrisse füllen

Füllt die Diagrammfläche entsprechend den x-, y- oder z-Konturen. Standardmäßig wird entsprechend den z-Werten gefüllt. Mit den Umrißoptionen auf der Seite "Spezial" können Sie die Füllung in eine andere Umrißrichtung vornehmen lassen: wählen Sie eine Umrißrichtung im Dropdown-Menü, und klicken Sie auf "Füllen", um diese Option zu aktivieren.

Hinweis: Sie können jeweils in bis zu 2 Umrißrichtungen füllen.

Keine Füllung

Die Oberfläche des Diagramms wird nicht gefüllt. Sie spiegelt kein Licht und hat keine Farbe.

Anderes Gitter

Füllt die Fläche des Diagramms mit zur Hälfte gefüllten Rechtecken.

Gleichmäßige Schattierung

Mischt die Farben in einem ausgefüllten Diagramm von Rechteck zu Rechteck, so daß die Farbgebung gleichmäßig wird. Diagramme werden langsamer gezeichnet, wenn "Gleichmäßige Schattierung" aktiviert ist.

Drahtmodell

Zeichnet Linien im Diagramm, so daß auf dem Diagramm ein Rahmen entsteht.

Umriß

Zeichnet Linien nur in Richtung der x-, y- oder z-Umrisse. Standardmäßig werden z-Umrisse gezeichnet. Mit den Umrißoptionen auf der Seite "Spezial" können Sie Linien in einer anderen Umrißrichtung zeichnen.

Keine Linien

Im Diagramm werden keine Linien gezeichnet.

Linien ausblenden

Blendet Linien aus, die in einem undurchsichtigen Diagramm nicht sichtbar wären.

Stärke

Bestimmt die Stärke der im Diagramm gezeichneten Linien.

Punkte zeichnen

Zeichnet Punkte bei den Datenwerten, aus denen das Diagramm besteht.

Symbol

Bestimmt das Symbol, das an die einzelnen Punkte gesetzt werden soll.

Größe

Bestimmt die Größe des Symbols an den einzelnen Punkten.

Farbzuordnung

Färbt die Fläche (Füllung) des Diagramms, der Linien oder der Punkte entsprechend den Werten in der Farbzuordnung, die in der Seite "Erweitert" festgelegt ist.

Volltonfarbe

Färbt die Fläche (Füllung) des Diagramms, der Linien oder der Punkte mit der Farbe, die im Feld auf der rechten Seite festgelegt ist.


DIALOGFELD "3D-DIAGRAMMFORMAT": REGISTERKARTE "ACHSEN"

Klicken Sie zum Formatieren der X-, Y- oder Z-Achse auf die entsprechende Registerkarte für die Achse im Dialogfeld.

Linien zeichnen

Zeichnet Linien bei jeder Gitterunterteilung auf der ausgewählten Achse.

HINWEIS: Die Gitterlinien werden auch durch die Optionen auf der Seite "Hintergrundebenen" gesteuert. Wenn Sie die Gitterlinien für eine Achse auf der Registerkarte "Achsen" festlegen, gilt dies für beide Hintergrundebenen der Achse. Wenn Sie die Gitterlinien auf der Registerkarte "Hintergrundebenen" festlegen, gilt dies nur für eine Hintergrundebene.

Teilstriche zeichnen

Zeichnet Teilstriche bei allen Gittern auf der ausgewählten Achse. Die Farbe der Teilstriche richtet sich nach der Achsenfarbe.

HINWEIS: Die Teilstriche werden auch durch die Optionen auf der Seite "Hintergrundebenen" bestimmt. Wenn Sie die Teilstriche für eine Achse auf der Registerkarte "Achsen" festlegen, gilt dies für die beiden Hintergrundebenen der Achse. Wenn Sie die Teilstriche auf der Registerkarte "Hintergrundebenen" festlegen, gilt dies nur für eine Hintergrundebene.

Autom. Gitterweite

Bestimmt automatisch die Anzahl der Gitterunterteilungen.

Linienfarbe

Bestimmt die Farbe der Gitterlinien.

Anzahl Gitterlinien

Bestimmt die Anzahl der Gitterlinien, die verwendet werden soll, wenn "Autom. Gitterweite" nicht aktiviert ist.

Linienstärke

Bestimmt die Stärke der Gitterlinien.

Achsenfarbe

Bestimmt die Farbe der Achse und der Teilstriche.

Numeriert

Zeigt für alle Gitterunterteilungen auf der ausgewählten Achse Zahlen an.

Achsenstärke

Bestimmt die Stärke der Achse.

Autom. Skalierung

Wählt die Achsenbegrenzungen automatisch aus.

Mindestwert

Bestimmt die untere Achsenbegrenzung, wenn "Autom. Skalierung" nicht aktiviert ist.

Höchstwert

Bestimmt die obere Achsenbegrenzung, wenn "Autom. Skalierung" nicht aktiviert ist.


Dialogfeld "3D-Diagrammformat": Registerkarte "Hintergrundebenen"

DIALOGFELD "3D-DIAGRAMMFORMAT" (REGISTERKARTE "HINTERGRUNDEBENEN")

Klicken Sie zum Formatieren der X-Y-, Y-Z- oder X-Z-Hintergrundebene auf die entsprechende Registerkarte im Dialogfeld.

Hintergrundebene füllen, Farbe

Füllt die Hintergrundebene mit der im Feld neben "Farbe" festgelegten Farbe.

Rahmen für Hintergrundebene, Farbe

Zeichnet in der im Feld neben "Farbe" festgelegten Farbe einen Rahmen um die Hintergrundebene.

Linien zeichnen

Zeichnet Gitter- oder Untergitterlinien auf einer bestimmten Achse.

HINWEIS: Die Gitterlinien werden auch durch die Optionen auf der Seite "Achsen" bestimmt. Wenn Sie die Gitterlinien für eine Achse auf der Registerkarte "Achsen" festlegen, gilt dies für die beiden Hintergrundebenen der Achse. Wenn Sie die Gitterlinien auf der Registerkarte "Hintergrundebenen" festlegen, gilt dies nur für eine Hintergrundebene.

Teilstriche zeichnen

Zeichnet Teilstriche an den Gitter- oder Untergitterunterteilungen auf einer bestimmten Achse.

HINWEIS: Die Teilstriche werden auch durch die Optionen auf der Seite "Achsen" bestimmt. Wenn Sie die Teilstriche für eine Achse auf der Registerkarte "Achsen" festlegen, gilt dies für die beiden Hintergrundebenen der Achse. Wenn Sie die Teilstriche auf der Registerkarte "Hintergrundebenen" festlegen, gilt dies nur für eine Hintergrundebene.

Linienfarbe

Bestimmt die Farbe der Gitter- oder Untergitterlinien.

Linienstärke

Bestimmt die Stärke der Gitter- oder Untergitterlinien.


DIALOGFELD "3D-DIAGRAMMFORMAT": REGISTERKARTE "ALLGEMEIN"

Rotation

Gibt den Drehungswinkel (in Grad) um die z-Achse an. Dies muß eine ganze Zahl zwischen -360 und 360 sein.

Rotation = 0
Sie schauen direkt auf die erste Spalte der Matrix herab. Die erste Zeile zeigt nach rechts.

Rotation = 90
Sie schauen direkt auf die erste Zeile der Matrix herab. Die erste Spalte zeigt nach links.

Sie können auch mit der Maus drehen.

Neigung

Bestimmt den Drehungswinkel (in Grad) um die x-Achse, der nach dem Drehen des Diagramms gebildet wird. Dies muß eine ganze Zahl zwischen 0 und 180 sein.

Sie können auch mit der Maus neigen.

Verdrehung

Bestimmt den Drehungswinkel (in Grad) um die z-Achse, der nach dem Drehen und Neigen des Diagramms gebildet wird. Dies muß eine ganze Zahl zwischen -360 und 360 sein.

Sie können auch mit der Maus verdrehen.

Zoom

Bestimmt den Vergrößerungsfaktor des Diagramms. Je höher der Vergrößerungsfaktor, desto näher befinden Sie sich am Diagramm. Dies muß ein Wert zwischen .01 und 100 sein.

Sie können auch mit der Maus vergrößern/verkleinern .

Achsenformat

Bestimmt, ob die Achsen im Vordergrund des Diagramms (Rundum) sichtbar sind, ob sie sich hinten links im Diagramm (Ecke) überschneiden, oder ob sie überhaupt angezeigt werden.

Gleiche Skalierung

Legt für alle Achsen eine bestimmte Skalierung fest.

Rahmen anzeigen

Zeichnet ein Rechteck um das gesamte Diagramm. Im Feld auf der rechten Seite wird die Farbe des Rahmens angegeben.

3D-Rahmen

Zeichnet einen Kasten um das Diagramm. Im Feld auf der rechten Seite wird die Farbe des Rahmens angegeben.

Darstellungsart

Fläche - Wandelt das Diagramm in ein Flächendiagramm um, in dem eine dreidimensionale Abbildung der Ebenenkurven einer Matrix angezeigt wird.

Umrißdiagramm - Wandelt das Diagramm in ein Umrißdiagramm um, in dem eine dreidimensionale Abbildung der auf eine Hintergrundebene projizierten Ebenenkurven einer Matrix dargestellt wird. Der Standard ist die xy-Hintergrundebene. Über die Dropdown-Liste der Umrißoptionen auf der Seite "Spezial" können Sie eine Projektion auf eine andere Hintergrundebene durchführen.

Datenpunkte - Wandelt das Diagramm in Punkte ohne Verbindung um.

Säulendiagramm - Wandelt das Diagramm in ein 3D-Säulendiagramm um, das eine Matrix in Form von Balken mit unterschiedlicher Höhe darstellt.

Vektorfeld - Wandelt das Diagramm in ein auf die xy-Hintergrundebene projiziertes Vektorfelddiagramm um.

Patch-Diagramm - Zeichnet bei allen Datenpunkten gleich ausgerichtete, nicht verbundene Stücke.


DIALOGFELD "3D-DIAGRAMMFORMAT": REGISTERKARTE "BELEUCHTUNG"

Über die Optionen links im Dialogfeld können Sie die allgemeine Beleuchtung steuern. Sie können ein gerichtetes Licht formatieren, wenn Sie im Dialogfeld auf die entsprechende Registerkarte wie z. B. "Licht 1" oder "Licht 2" klicken.

Beleuchtung aktivieren

Aktiviert alle Optionen auf der Registerkarte "Beleuchtung".

Umgebungslichtfarbe

Bestimmt die Farbe des Umgebungslichts.

Beleuchtungsschema

Zeigt eine Liste von integrierten Beleuchtungsschemen an.

Ein/Aus

Schaltet ein gerichtetes Licht ein oder aus.

Farbe streuen

Bestimmt die Farbe des Bereichs des gestreuten Lichts eines gerichteten Lichts.

Glanzfarbe

Bestimmt die Farbe (normalerweise Weiß) des Bereichs des Glanzlichts eines gerichteten Lichts. Dies ist von Nutzen, wenn der Glanzfaktor auf der Seite "Erweitert" bestimmt wird.

Lichtposition - X, Y, Z

Bestimmt die allgemeine Position eines gerichteten Lichts auf der X-, Y- und Z-Achse.

Unendlich entfernte Lichtquelle

Positioniert ein gerichtetes Licht in unendlicher Entfernung.


DIALOGFELD "3D-DIAGRAMMFORMAT": REGISTERKARTE "SPEZIAL"

Füllen

Füllt die Oberfläche des Diagramms in der Umrißrichtung, die im Dropdown-Menü unten im Abschnitt "Umrißoptionen" angegeben wird (standardmäßig Z-Umrisse).

Linien zeichnen

Zeichnet Linien in der Umrißrichtung, die im Dropdown-Menü unten im Abschnitt "Umrißoptionen" angegeben wird (standardgemäß Z-Umrisse).

Autom. Umrisse

Bestimmt automatisch die Anzahl der Umrißlinien, die in der Umrißrichtung gezeichnet werden sollen, die im Dropdown-Menü unten im Abschnitt "Umrißoptionen" angegeben sind (standardmäßig Z-Umrisse).

Numeriert

Zeigt Nummern auf den Umrißlinien an.

Nummer

Bestimmt die Anzahl der Umrißlinien, die in der Umrißrichtung gezeichnet werden sollen, die im Dropdown-Menü unten im Abschnitt "Umrißoptionen" angegeben ist (standardgemäß Z-Umrisse). Dies ist nur verfügbar, wenn "Autom. Umrisse" nicht aktiviert ist.

Z-Umrisse, X-Umrisse, Y-Umrisse

Bestimmt eine Umrißrichtung. Legen Sie nach dem Wählen einer Richtung die anderen Optionen im Abschnitt "Umrißoptionen" fest.

Säulendiagramm-Layout

Matrix

Gestapelt

Nebeneinander

Abstand

Bestimmt den Abstand zwischen Säulen.

Interpoliertes Gitter (Zeilen, Spalten)

Auf die Einstellungen in diesem Feld kann nur zugegriffen werden, wenn Ihr Flächendiagramm durch Umwandeln eines Streuungsdiagramms entstanden ist. In diesem Fall ist das Diagramm eigentlich eine interpolierte Fläche, die annähernd den Streuungsdaten entspricht.

Um die Dichte des für die Interpolation verwendeten Gitters zu ändern, können Sie in den entsprechenden Feldern die Anzahl der Zeilen und Spalten ändern. Werden Ihre Daten nicht ausreichend gut durch die Fläche dargestellt, ist es u. U. möglich, eine sinnvolle Interpolation zu erstellen. In diesem Fall erscheint in der Meldungszeile eine entsprechende Meldung.

Verbindungsart

Bestimmt, wie gezeichnete Punkte durch die Linie verbunden werden. Klicken Sie dazu auf eine der folgenden Optionen:

Zeilenfolge - Die Reihenfolge der Punkte auf den Vektoren

Ansteigend X - Mit ansteigenden x-Werten.

Ansteigend Y - Mit ansteigenden y-Werten.

Ansteigend Z - Mit ansteigenden z-Werten.


DIALOGFELD "3D-DIAGRAMMFORMAT": REGISTERKARTE "TITEL"

Graphtitel

Text zur Verwendung als Titel für das Diagramm.

Oben

Positioniert den Titel über dem Diagramm.

Unten

Positioniert den Titel unter dem Diagramm.

Ausblenden

Blendet den Titel auf dem Diagramm aus.


3D-DIAGRAMMASSISTENT

Zum Erstellen eines 3D-Diagramms können Sie die Befehle unter Diagramm im Menü Einfügen verwenden. Mit dem 3D-Diagrammassistenten können Sie die Formateinstellungen eines Diagramms beim Einfügen präziser festlegen.

Zum Verwenden des 3D-Diagrammassistenten gehen Sie folgendermaßen vor:

  1. Klicken Sie auf die Stelle in Ihrem Arbeitsblatt, an der das Diagramm eingefügt werden soll. Stellen Sie sicher, daß das Fadenkreuz angezeigt wird.

  2. Wählen Sie Diagramm \ 3D-Diagrammassistent im Menü Einfügen. Die erste Seite des 3D-Diagrammassistenten wird angezeigt.

  3. Wählen Sie den anzuzeigenden Typ von 3D-Diagramm aus, und klicken Sie auf "Weiter".

  4. Nehmen Sie die Auswahl für die Darstellung und Farbgebung des Diagramms auf den nachfolgenden Seiten des Assistenten vor. Klicken Sie auf “Fertig stellen”, damit ein Diagramm mit korrekten Achsen und einem leeren Platzhalter in das Arbeitsblatt eingefügt wird.

  5. Geben Sie Argumente in den Platzhalter ein.

  6. Klicken Sie auf eine Stelle außerhalb des Diagramms.

  7. Das Diagramm wird mit den im Assistenten festgelegten Einstellungen erstellt.


ÖFFNEN DER MIT EINER KOMPONENTE VERBUNDENEN ANWENDUNG

Nachdem Sie eine Anwendungskomponente in Ihr Mathcad-Arbeitsblatt eingefügt haben, können Sie mit Hilfe der Komponente Berechnungen in der mit ihr verbundenen Anwendung durchführen. Gehen Sie hierzu folgendermaßen vor:

Doppelklicken Sie auf die Komponente im Mathcad-Arbeitsblatt. Die Komponente wird entweder an Ort und Stelle oder in einem eigenen Bearbeitungsfenster geöffnet.

Bearbeiten Sie die Komponente Ihren Wünschen entsprechend.

Klicken Sie auf das Mathcad-Arbeitsblatt, damit die Komponente die Werte neu berechnen kann und Sie weiter in Mathcad arbeiten können.

Wenn Sie auf eine Stelle außerhalb der Komponente klicken, werden die Eingabevariablen an die Komponente übertragen und den Ausgabevariablen in Mathcad Felder zugeordnet. Nachdem die Ausgabevariablen in Mathcad erstellt worden sind, können Sie sie mit Hilfe der vordefinierten Mathcad-Funktionen und -Operatoren für Felder Ihren Wünschen entsprechend ändern.


HINZUFÜGEN EINES BEREICHS ZU ODER ENTFERNEN EINES BEREICHS AUS EINER MARKIERUNG

Zum Hinzufügen eines Bereichs zu oder Entfernen eines Bereichs aus einer Gruppe von bereits markierten Bereichen gehen Sie wie folgt vor:

Setzen Sie den Mauszeiger auf den Bereich.

Halten Sie die Strg-Taste gedrückt, und klicken Sie auf den Bereich.

Beim Klicken müssen Sie unbedingt Strg gedrückt halten. Andernfalls wird die Markierung der anderen zuvor markierten Bereiche wieder aufgehoben.


HINZUFÜGEN EINES TITELS ZU EINEM KREISDIAGRAMM

Zum Hinzufügen eines Titels zu einem Kreisdiagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, oder wählen Sie Diagramm / Kreisdiagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte Beschriftungen.

  3. Geben Sie im Textfeld den Titel für das Diagramm ein. Der Titel kann sowohl in Groß- als auch in Kleinschreibung eingegeben werden.

  4. Klicken Sie auf die Schaltfläche "Oben" oder "Unten".

  5. Klicken Sie auf “Titel anzeigen”. Lassen Sie dann durch Klicken auf "OK" den Titel des Diagrammbereichs anzeigen.

Zum Ausblenden des Titels deaktivieren Sie das Kontrollkästchen "Titel anzeigen". Um den Titel vollständig zu löschen, verwenden Sie die Rücktaste.


EINFÜGEN EINES TITELS IN EIN X-Y-DIAGRAMM

Zum Einfügen eines Titels in ein Diagramm gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte Beschriftungen.

  3. Geben Sie im Textfeld den Titel für das Diagramm ein. Der Titel kann sowohl in Groß- als auch in Kleinschreibung eingegeben werden.

  4. Klicken Sie auf die Schaltfläche "Oben" oder "Unten".

  5. Klicken Sie auf "Titel anzeigen". Lassen Sie dann durch Klicken auf "OK" den Titel des Diagrammbereichs anzeigen.

Um den Titel aus dem Textfeld zu entfernen, klicken Sie auf "Abbrechen", damit der ursprüngliche Zustand des Textfelds für den Titel wiederhergestellt wird.

Zum Ausblenden des Titels deaktivieren Sie das Kontrollkästchen "Titel anzeigen". Um den Titel vollständig zu löschen, verwenden Sie die Rücktaste.


HINZUFÜGEN ODER ENTFERNEN VON EINGABE- UND AUSGABEVARIABLEN

Wenn Sie eine Anwendungskomponente einfügen, möchten Sie vielleicht Eingabevariablen oder Ausgabevariablen hinzufügen oder entfernen. Gehen Sie hierzu folgendermaßen vor:

Klicken Sie einmal auf die Komponente, um sie auszuwählen.

Wenn Sie eine weitere Ausgabevariable hinzufügen möchten, wählen Sie im Kontextmenü den Befehl Ausgabevariable hinzufügen. Links neben ":=" wird ein neuer Platzhalter angezeigt.

Wenn Sie eine weitere Eingabevariable hinzufügen möchten, wählen Sie im Kontextmenü den Befehl Eingabevariable hinzufügen. Am unteren Rand der Komponente wird ein neuer Platzhalter angezeigt.

Wenn Sie eine Ausgabevariable löschen möchten, wählen Sie im Kontextmenü den Befehl Ausgabevariable entfernen. Der Ausgabeplatzhalter oder die Variable links neben ":=" wird daraufhin ausgeblendet. Wenn mehrere Ausgaben vorhanden waren, wird der letzte Ausgabeplatzhalter bzw. die letzte Variable nicht mehr angezeigt.

Wenn Sie eine Eingabevariable löschen möchten, wählen Sie im Kontextmenü den Befehl Eingabevariable entfernen. Die Eingabevariable oder der Platzhalter im unteren Bereich der Komponente wird daraufhin nicht mehr angezeigt. Wenn mehrere Eingaben vorhanden waren, wird der Platzhalter ganz rechts nicht mehr angezeigt.

Wenn Sie Ein- oder Ausgabevariablen in die Excel-Komponente einfügen, müssen Sie festlegen, in welchen Zellen der Komponente die neue Eingabe gespeichert wird, und wo die neue Ausgabe erscheinen soll. Gehen Sie hierzu folgendermaßen vor:

Klicken Sie einmal auf die Komponente, damit sie ausgewählt wird.

Wählen Sie im Kontextmenü den Befehl Eigenschaften.

Klicken Sie entweder auf die Registerkarte "Eingaben" oder auf die Registerkarte "Ausgaben", und legen Sie für jede Ein- bzw. Ausgabe einen Zellenbereich fest.


OPERATOR "ADDITION"

Tastaturbefehl: +

x + y

Gibt die Summe von x und y zurück.

Ist der Ausdruck so lang, daß er über den rechten Bildschirmrand hinausgeht, sollten Sie statt dessen Strg+Eingabe drücken. Daraufhin wird folgendes eingefügt:

Operanden:

x und y sind Skalare.

x und y müssen beide dieselbe Dimension haben.


Operator "Addition mit Zeilenumbruch"

ADDITION MIT ZEILENUMBRUCH

Tastaturbefehl: Strg+Eingabe

Wie Addition, wobei aber die beiden Glieder in verschiedenen Zeilen stehen.

Operanden:

x und y sind Skalare.

x und y müssen beide dieselbe Dimension haben.

Mit diesem Operator können Sie vermeiden, daß die Darstellung von Ausdrücken über den rechten Bildschirmrand hinausreicht und damit unübersichtlich wird.

Zum Umbrechen eines Ausdrucks mit diesem Operator gehen Sie wie folgt vor:

  1. Klicken Sie unmittelbar rechts neben dem Glied, das vor dem Pluszeichen steht, an dem der Ausdruck umgebrochen werden soll.

  2. Drücken Sie die Leertaste, bis alle Glieder, vom ersten bis zum ausgewählten Glied, sich zwischen den beiden Bearbeitungslinien befinden.

  3. Drücken Sie die Taste Entf. Das Pluszeichen unmittelbar nach den Bearbeitungslinien verschwindet.

  4. Drücken Sie jetzt Strg+Eingabe, um das Pluszeichen mit dem Zeilenumbruch einzugeben.

  5. Diesen Vorgang können Sie überall dort wiederholen, wo mehrere mit Pluszeichen verbundene Glieder vorhanden sind.


DIALOGFELD "ERWEITERTE OPTIONEN"

Im Dialogfeld "Erweiterte Optionen" finden Sie die folgenden Optionen und Schaltflächen:

Ableitungsschätzung

Damit wird das Verfahren zum näherungsweisen Berechnen der ersten partiellen Ableitungen gesteuert.

  • Wählen Sie "Nach vorne", um sich die Ergebnisse in einer Richtung vom aktuellen Punkt aus anzeigen zu lassen.

  • Wählen Sie "Zentral", um sich die Ergebnisse in zwei gegenläufigen Richtungen vom aktuellen Punkt aus anzeigen zu lassen. Dies kann zwar länger dauern, führt aber u. U. zu besseren Ergebnissen mit insgesamt weniger Iterationen.

Variablenschätzung

Damit wird das Verfahren zum Schätzen der Anfangswerte zu Beginn einer jeden Suche gesteuert.

  • Wählen Sie "Tangente", um von der Linientangente zur reduzierten Zielfunktion zu extrapolieren.

  • Wählen Sie "Quadratisch", um zum Minimum oder Maximum einer quadratischen Funktion zu extrapolieren, die der reduzierten Zielfunktion an deren jeweiligem Punkt angepaßt ist.

Lineare Variablenprüfung

Die lineare Variablenprüfung erspart Ihnen Zeit, indem davon ausgegangen wird, daß alle unbekannten Variablen in allen Bedingungen linear auftreten und daß die ersten partiellen Ableitungen in bezug auf diese Variablen konstant sind.

Verwenden Sie diese Option nur, wenn Sie sicher sind, daß nichtlinear erscheinende Variablen sich nicht in lineare ändern werden.

Hinweise:

  • Diese erweiterten Optionen stehen für das Gradientenverfahren bzw. für die Quasi-Newton-Methode zur Verfügung.

  • Diese Optionen sollten nur von erfahrenen Benutzern verwendet werden, und auch erst dann, wenn mit den Standardoptionen keine Lösung gefunden werden konnte bzw. wenn eine genaue Einflußnahme auf das Lösungsverfahren gewünscht wird.


ERWEITERTE ANSICHTSEINSTELLUNGEN FÜR EIN 3D-DIAGRAMM

Zum Steuern der Darstellungsweise eines 3D-Diagramms mit erweiterten Optionen gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Erweitert". Die Seite "Erweitert" enthält Optionen zum Formatieren der Ansicht und zum Festlegen der Details eines bestimmten Diagramms.

3. Mit den Optionen auf der Seite haben Sie folgende Möglichkeiten:

  • Nebel in das Diagramm einfügen

  • Das Diagramm so anzeigen lassen wie bei der Ansicht aus der Distanz

  • Die Unterschiede bei der Höhe eines Diagramms festlegen

  • Die zu verwendende Farbzuordnung wählen

  • Die Verwendung einer Farbzuordnung festlegen

  • Die glänzende Darstellung eines Diagramms festlegen

  • Die Transparenz eines Diagramms festlegen

  • Die Ausrichtung der Diagrammoberfläche mit den Diagrammlinien abstimmen

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", damit das Dialogfeld wieder ausgeblendet wird.


Airysche Funktionen

AIRYSCHE FUNKTIONEN (nur in Mathcad Professional)

Ai(x) Gibt den Wert der Airyschen Funktion der ersten Art zurück.

Bi(x) Gibt den Wert der Airyschen Funktion der zweiten Art zurück.

Argumente:

x muß eine reelle skalare Zahl sein.

x darf keine Einheiten haben.

x darf nicht größer als 103.892 sein.

Diese Funktionen sind unabhängige Lösungen der folgenden Differentialgleichung:


ALIASING

Da die Fourier-Transformation eine diskrete Näherung einer kontinuierlichen Transformation ist, treten u. U. versetzte Oberwellen auf. Dieser Effekt wird Aliasing genannt. Um Aliasing zu vermeiden, gehen Sie wie folgt vor:

Sorgen Sie dafür, daß das Signal eine endliche Bandbreite hat.

Sorgen Sie dafür, daß die Meßfrequenz mindestens das doppelte der Bandbreite beträgt (Nyquist-Frequenz).


AUSGERICHTETE AUSGABETABELLEN

Ausgabetabelle mit Ausrichtung "Mitte":

Ausgabetabelle mit Ausrichtung "Oben":

Ausgabetabelle mit Ausrichtung "Unten":

Ausgabetabelle mit Ausrichtung "Über":

Ausgabetabelle mit Ausrichtung "Unter":


AUSRICHTEN EINER AUSGABETABELLE

Zum Festlegen, wie eine Ausgabetabelle zu der angezeigten Variable oder dem Ausdruck ausgerichtet wird, gehen Sie wie folgt vor:

  1. Klicken Sie auf die Ausgabetabelle, um sie zu markieren.

  2. Klicken Sie mit der rechten Maustaste nochmals auf die Ausgabetabelle.

  3. Wählen Sie den Befehl Ausrichtung im Kontextmenü.

  4. Wählen Sie "Oben", "Mitte", "Unten", "Unter" oder "Über".


UMGEBUNGSLICHT

Umgebungslicht ist allgemeines Licht, das gleichmäßig auf den Bereich um ein Diagramm verteilt ist.


DIALOGFELD "ANIMIEREN"

Im Dialogfeld "Animieren" finden Sie die folgenden Optionen und Schaltflächen:

Von

Dient zur Eingabe des ersten Wertes für die integrierte Variable FRAME. Jeder Wert von FRAME erzeugt ein separates Bild in der Animationssequenz.

Bis

Dient zur Eingabe des letzten Wertes für die integrierte Variable FRAME. Jeder Wert von FRAME erzeugt ein separates Bild in der Animationssequenz.

Mit ... Bildern/s

Ermöglicht die Festlegung der Standardgeschwindigkeit, mit der die Animation wiedergegeben wird.

Da Sie die Wiedergabegeschwindigkeit auch während der Wiedergabe der Animation ändern können, ist dieser Wert nur dann von Bedeutung, wenn Sie Ihre Animation mit einer Tonspur versehen wollen.

Animieren

Durch Klicken auf diese Schaltfläche können Sie die Aufzeichnung der Animation starten. Diese Schaltfläche ist so lange abgeblendet, bis Sie in Ihrem Dokument einen Bereich für die Animation ausgewählt haben.

Speichern unter

Durch Klicken auf diese Schaltfläche können Sie eine aufgezeichnete Animation in einem für die meisten anderen Multimedia-Anwendungen geeigneten Format speichern.

Diese Schaltfläche steht nur dann zur Verfügung, wenn es etwas zu speichern gibt.

Optionen

Da Animationen in der Regel sehr viel Speicherplatz beanspruchen, speichert Mathcad sie in einem komprimierten Format. Wenn Sie auf diese Schaltfläche klicken, öffnet sich ein Dialogfeld mit einer Reihe von Optionen, in dem Sie das zu verwendende Komprimierungsverfahren festlegen können.

FRAME (Zähler)

Zeigt den Wert der integrierten Variable FRAME entsprechend dem Bild im darüberliegenden Feld (Bildvorschau) an.

Bildvorschau

Zeigt die Bilder (Frames) Ihrer Animationssequenz an, während sie aufgezeichnet werden. Beim ersten Mal kann es einen Moment dauern, bis die einzelnen Bilder erscheinen. Nach Beendigung der Aufzeichnung können Sie diese jedoch wesentlich schneller abspielen.

Dieses Feld ist leer, bis Sie den zu animierenden Bereich auswählen und auf die Schaltfläche "Animieren" klicken.


ANTISYMMETRISCHE TENSOR-FUNKTION

(i,j,k) Diese Funktion gibt den vollständigen antisymmetrischen Tensor der Ordnung 3 zurück. Wenn zwei gleiche Argumente vorhanden sind, ist das Ergebnis 0; bei geraden Permutationen lautet das Ergebnis 1 und bei ungeraden Permutationen -1.

Argumente:

i, j, und k müssen ganze Zahlen zwischen 0 und 2 (oder ORIGIN und ORIGIN+2) sein.


Funktion ANFÜGEN

ANFÜGEN EINER DATENDATEI AN EINE BEREITS BESTEHENDE

ANFÜGEN("datei") Fügt eine einzelne Zahl an die Datei datei an.

Argumente:

datei ist entweder ein Dateiname oder der Pfad zu einer ASCII-Datendatei.

datei ist als Zeichenfolge einzugeben.

Die Funktion ANFÜGEN wird normalerweise in Verbindung mit einem Vektor verwendet, der mit einer Bereichsvariable (als tiefgestelltem Index) versehen ist, wie z. B. in folgender Form:

i := 1 bis N

ANFÜGEN("datei.dat") :=

Im Beispiel oben wird die Liste der Zahlen im Vektor v an die bereits in datei.dat vorhandenen Zahlen angehängt.

Zu beachten ist, daß die Datei bereits vorhanden sein muß, damit ANFÜGEN funktioniert. Sie können ANFÜGEN nicht dazu benutzen, eine Datei zu erstellen. Die Funktion kann nur an eine vorhandene Datei Daten anhängen.

ACHTUNG: Mathcad 8 enthält diese Funktion nur, um die Kompatibilität mit älteren Mathcad-Versionen zu gewährleisten. Die Funktion ist jedoch veraltet und sollte nicht mehr verwendet werden. Verwenden Sie zum Schreiben von Daten in eine Datendatei statt dessen die Komponente "Dateien lesen/schreiben". Zum Anhängen von Daten an eine Datei sollte die Funktion PRNANFÜGEN verwendet werden.


ANFÜGEN VON DATEN AN BEREITS BESTEHENDE DATEIEN

PRNANFÜGEN("datei") Hängt ein Feld an die Datei datei an.

Argumente:

datei ist entweder der Dateiname einer strukturierten ASCII-Datendatei oder der volle Pfad zu dieser Datei.

datei ist als Zeichenfolge einzugeben.

Die Anzahl der Spalten in datei muß mit der Anzahl der Spalten im Feld übereinstimmen.

datei muß bereits vorhanden sein. Im Unterschied zu PRNSCHREIBEN kann mit der Funktion PRNANFÜGEN keine Datei erstellt werden. Mit dieser Funktion können nur Daten an eine bereits vorhandene Datei angehängt werden.

Beispiel:

PRNANFÜGEN("c:\daten\ergebnis.prn") := A

A ist eine Matrix, deren Werte zu den Werten addiert werden, die bereits in der Datei ergebnis.prn im Verzeichnis c:\daten vorhanden sind.

Hinweise:

  • PRNANFÜGEN ordnet die Daten in der ASCII-Datei entsprechend der ursprünglichen Matrix in Zeilen und Spalten an. Standardmäßig hängt PRNANFÜGEN vier signifikante Ziffern in Spalten mit einer Breite von acht Ziffern an. Um dies zu ändern, wählen Sie den Befehl Optionen im Menü Rechnen, und klicken Sie im Dialogfeld "Rechenoptionen" auf die Registerkarte "Vordefinierte Variablen". Ändern Sie die Werte für PRNPRECISION und PRNCOLWIDTH.

  • Wenn Sie das Argument dieser Funktion ändern, sollten Sie es stets aktualisieren. Klicken Sie dazu auf das Argument, und wählen Sie den Befehl Berechnen im Menü Rechnen.


ZUWEISEN EINER ANDEREN RECHENFORMATVORLAGE

Zum Ändern der mit einem bestimmten Namen oder einer bestimmten Zahl verknüpften Gleichungsformatvorlage gehen Sie wie folgt vor:

  1. Klicken Sie auf den Namen bzw. die Zahl.

  2. Wählen Sie Gleichung aus dem Menü Format.

  3. Wählen Sie im Dialogfeld "Gleichungsformat" ein Format aus der Dropdown-Liste. Sie finden hier mehrere vordefinierte Gleichungsformatvorlagen. Sie können aber auch mit Hilfe der verschiedenen "Benutzer"-Formatvorlagen eine neue Vorlage erstellen.

  4. Falls erforderlich, ändern Sie die Schriftattribute, die zu diesen Vorlagen gehören, indem Sie auf "Ändern..." klicken.

  5. Klicken Sie auf "OK", um die gewählte Formatvorlage dem gewünschten Namen zuzuweisen.

Bei Variablennamen müssen Sie auf die Schriftart achten. Wenn Sie z. B. eine Anweisung wie "x := 1" in Ihrem Dokument haben und Sie das Format in "x := 1" ändern, sind die x im weiteren Verlauf des Dokuments nicht definiert. Sie müssen diese dann mit dem gleichen Format verknüpfen, damit sie folgendermaßen aussehen: "x".


ANNÄHERUNGSLÖSUNGEN

Minfehl(var1, var2, ...) Gibt die Werte von var1, var2... zurück, die den Lösungen der Gleichungen und Ungleichungen in einem Lösungsblock am nächsten kommen.

Argumente:

var1, var2,... sind skalare Variablen des Gleichungssystems.

Verwendung der Funktion:

Um mit Hilfe der Funktion minfehl die angenäherte Lösung eines Gleichungssystems zu suchen, ist wie folgt vorzugehen:

Definieren Sie Schätzwerte für die unbekannten Variablen.

Geben Sie das Wort Vorgabe ein, um das Gleichungssystem zu starten.

Geben Sie unter Vorgabe mit Hilfe Boolescher Operatoren Gleichungen und Ungleichungen ein.

Verwenden Sie die Funktion minfehl.

Hinweise:

  • Der Unterschied zwischen minfehl und Suchen besteht darin, daß minfehl auch dann einen Wert zurückgibt, wenn der Lösungsalgorithmus die Lösung nicht weiter verbessern kann. Die Funktion Suchen dagegen gibt eine Fehlermeldung aus, aus der hervorgeht, daß keine Lösung gefunden werden konnte.

  • Andernfalls gibt sie einen Vektor zurück, dessen erstes Element var1, dessen zweites Element var2 usw. ist.

  • Mathcad wertet die Funktion minfehl nach der Levenberg-Marquardt-Methode aus. Für diese Methode muß ein Schätzwert für jede Unbekannte eingegeben werden, bevor die Suche nach Lösungen beginnen kann. Hat das System mehrere Lösungen, hängt die zurückgegebene Lösung davon ab, welche Schätzwerte eingegeben wurden. Auch mit zusätzlich eingefügten Ungleichungen können Sie Mathcad zur Suche nach anderen Lösungen zwingen.

Beispiel:

Annäherungslösung an ein System nichtlinearer Gleichungen


SYMBOLLEISTE "ARITHMETISCH"

Über die Symbolleiste "Arithmetisch" können Sie schnell auf grundlegende mathematische Operatoren und Funktionen zugreifen. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


Operator "Feldaddition"

FELDADDITION

Tastaturbefehl: +

A + B

Addiert die Elemente von A zu den entsprechenden Elementen von B.

A + x

Addiert x zu jedem Element in A.

Operanden:

A und B sind Felder mit derselben Anzahl von Zeilen und Spalten.

Die Elemente von A und B müssen dieselben Dimensionen haben.

x ist ein beliebiger Skalar, reell oder komplex.

x muß dieselben Dimensionen haben wie die Elemente von A.


Feldursprung

ORIGIN (STANDARD = 0)

Diese Konstante stellt den Anfangsindex aller Felder dar. Wenn Sie sie ändern möchten, wählen Sie Optionen / Registerkarte "Vordefinierte Variablen" aus dem Menü Rechnen.

Sie können ORIGIN auf eine beliebige ganze Zahl (positiv oder negativ) festlegen. Der Wert, den Sie für ORIGIN festlegen, wirkt sich auf alle Felder im Arbeitsblatt aus.


Operator "Feldsubtraktion"

FELDSUBTRAKTION

Tastaturbefehl: -

A - B

Subtrahiert die Elemente von B von den entsprechenden Elementen von A. A und B müssen dieselbe Anzahl von Zeilen und Spalten haben.

A - x

Wenn A ein Feld und x ein Skalar ist, dann ist A - x ein Feld, das durch Subtrahieren von x von jedem Element in A gebildet wird.

Operanden:

A und B sind Matrizen mit gleicher Anzahl von Zeilen und Spalten.

x ist ein Skalar.


Automatischer Berechnungsmodus

AUTOMATISCHER MODUS

Wenn Sie Mathcad starten, ist der automatische Modus eingestellt. Dies bedeutet, daß Mathcad Ergebnisse im Arbeitsblattfenster automatisch aktualisiert.

Vorteile des automatischen Modus...

Nachteile des automatischen Modus...

Merkmale des automatischen Modus...

Aktivieren des automatischen Modus...


VERMEIDEN VON NICHT DEFINIERTEN AUSDRÜCKEN

Stellen Sie vor dem Verwenden einer Variable oder Funktion sicher, daß sie im Arbeitsblatt bereits früher definiert wurde.

Wenn Sie sich nicht sicher sind, welche von zwei Gleichungen zuerst erscheint, wählen Sie den Befehl Bereiche aus dem Menü Ansicht, und überprüfen Sie die Ankerpunkte.


ACHSENEINSTELLUNGEN IN KREISDIAGRAMMEN

Zum Auswählen der Merkmale jeder Achse gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf ein Diagramm, oder wählen Sie Diagramm / Kreisdiagramm im Menü Format, damit ein Dialogfeld mit Registerkarten geöffnet wird.

  2. Klicken Sie auf die Registerkarte "Achsen".

  3. Nehmen Sie die erforderlichen Änderungen vor.

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld auszublenden.


Achseneinstellungen für ein 3D-Diagramm

ACHSENEINSTELLUNGEN FÜR 3D-DIAGRAMME

Zum Auswählen der Eigenschaften der Achse für ein 3D-Diagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf das Diagramm, damit ein Dialogfeld mit Registerkarten geöffnet wird.

2. Klicken Sie auf die Registerkarte "Achsen". Auf der Seite "Achsen" werden drei Registerkarten zum Formatieren der drei Achsen angezeigt.

3. Klicken Sie zum Formatieren einer Achse auf das entsprechende Achsenregister. Mit den Optionen auf der Seite haben Sie folgende Möglichkeiten:

  • Zeichnen von Gitterlinien oder Teilstrichen

  • Festlegen der Farbe und der Stärke der Gittelinien

  • Anzeigen von Zahlen auf den Rastern

  • Festlegen eigener Achsenbegrenzungen durch Deaktivieren von Autom. Skalierung und Eingeben von Mindest- und Höchstwerten

  • Festlegen der Farbe und der Stärke der Achse

  • Festlegen eines eigenen Gitters durch Deaktivieren von Autom. Gitterweite und Angeben der Anzahl der Gitterlinien

3. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", damit das Dialogfeld ausgeblendet wird.

Achsenstil

Zum Festlegen der Achsenanordnung gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Allgemein", damit die Seite "Allgemein" geöffnet wird. Geben Sie mit den Optionen im Abschnitt Achsenformat die Werte für "Rundum", "Ecke" oder "Gleiche Skalierung" ein. Klicken Sie auf "Kein", um die Achsen auszublenden.

3. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld auszublenden.


ACHSENEINSTELLUNGEN (X-Y-DIAGRAMME)

Zum Auswählen der Merkmale jeder Achse gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf ein Diagramm, oder wählen Sie Diagramm / X-Y-Diagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte X-Y-Achsen.

  3. Nehmen Sie die erforderlichen Änderungen vor.

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld auszublenden.


HINTERGRUNDEBENENEINSTELLUNGEN FÜR EIN 3D-DIAGRAMM

Zum Festlegen der Darstellung von Hintergrundebenen in einem 3D-Diagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Hintergrundebenen". Die Seite "Hintergrundebenen" enthält drei Registerkarten zum Formatieren der drei Hintergrundebenen.

3. Klicken Sie auf die Registerkarte der Hintergrundebene, die Sie formatieren möchten. Mit den Optionen auf der Seite haben Sie folgende Möglichkeiten:

  • Zeichnen von Gitterlinien oder Untergitterlinien

  • Zeichnen von Teilstrichen oder Unterteilstrichen

  • Bestimmen der Farbe und der Stärke der Gitterlinien und der Untergitterlinien

3. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld auzublenden.


SÄULENLAYOUTEINSTELLUNGEN (FÜR EIN 3D-SÄULENDIAGRAMM)

Zum Festlegen des Layouts der Säulen in einem 3D-Säulendiagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Spezial".

3. Die Seite "Spezial" enthält im Abschnitt "Säulendiagramm-Layout" folgende Optionen:

Matrix

Gestapelt

Nebeneinander

Abstand

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld auszublenden.


BESSELFUNKTIONEN

Besselfunktionen

J0(x)

J1(x)

Jn(m,x)

Y0(x)

Y1(x)

Yn(m,x)

Modifizierte Besselfunktionen

I0(x)

I1(x)

In(m,x)

K0(x)

K1(x)

Kn(m,x)

Airysche Funktionen

Ai(x)

Bi(x)

Bessel-Kelvin-Funktionen

bei(n,x)

ber(n,x)

Sphärische Besselfunktionen

js(n,x)

ys(n,x)


Bessel-Kelvin-Funktionen

BESSEL-KELVIN- FUNKTIONEN (nur in Mathcad Professional)

bei(n,x) Gibt den Wert der imaginären Bessel-Kelvin-Funktion n-ter Ordnung zurück.

ber(n,x) Gibt den Wert der reellen Bessel-Kelvin-Funktion n-ter Ordnung zurück.

Argumente:

n muß eine nicht-negative ganze Zahl sein.

n darf keine Einheiten haben.

x muß eine reelle skalare Zahl sein.

x darf keine Einheiten haben.

Die Funktion ber(n,x)+i*bei(n,x) ist eine Lösung der folgenden Differentialgleichung:


BETA-VERTEILUNG

dbeta(x,s1,s2) Gibt die Wahrscheinlichkeitsdichte für die Beta-Verteilung zurück.

pbeta(x,s1,s2) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qbeta(x,s1,s2) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rbeta(m,s1,s2) Gibt einen Vektor aus m Zufallszahlen zurück, die die Beta-Verteilung aufweisen.


BINOMIALVERTEILUNG

dbinom(k,n,p) Gibt die Wahrscheinlichkeitsdichte für die Binomialverteilung zurück.

pbinom(k,n,p) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qbinom(p,n,r) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rbinom(m,n,p) Gibt einen Vektor aus m Zufallszahlen zurück, die die Binomialverteilung aufweisen.


UNTERER RAND

Dabei handelt es sich um den Abstand zwischen dem unteren Rand des Papierblatts und dem unteren Rand des Druckbereichs. Wenn Ihr Arbeitsblatt mit einer Fußzeile versehen ist, erscheint diese innerhalb des Randbereichs an dessen oberer Grenze.


"Break"-Anweisung

"BREAK"-ANWEISUNG (Nur für Mathcad Professional)

Fügen Sie die "break"-Anweisung in eine Schleife ein, wenn Sie die Ausführung der Schleife an einem bestimmten Punkt abbrechen möchten.

Zum Einfügen einer "break"-Anweisung gehen Sie wie folgt vor:

Klicken Sie in den Platzhalter, in den Sie die "Break"-Anweisung setzen möchten.

Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

Klicken Sie auf die Schaltfläche "break". Geben Sie nicht einfach "break" ein.

Wenn Mathcad eine "break"-Anweisung im Hauptteil einer "for"- oder "while"-Schleife erkennt, geschieht folgendes:

  1. Die Ausführung der Schleife wird unterbrochen, und es wird der zuletzt berechnete Wert ausgegeben.

  2. Das Programm wird dann ab der ersten Zeile nach der Schleife fortgeführt.

Aufrufen eines QuickSheet-Beispiels


B-SPLINE-INTERPOLATION

bspline(vx,vy,u,n) Gibt einen Vektor mit den Koeffizienten einer B-Spline n-ten Grades für die Daten in vx und vy zurück, wobei die Knoten, die durch die Werte in u angezeigt werden, gegeben sind. Der zurückgegebene Vektor wird zum ersten Argument der Funktion interp.

interp(vs,vx,vy,x) Gibt einen B-Spline-interpolierten Wert von vy an einem Punkt x zurück, wobei vs das Ergebnis der Funktion bspline ist.

Argumente:

vx ist ein Vektor aus reellen Datenwerten in aufsteigender Reihenfolge. Diese entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. vy hat die gleiche Anzahl von Elementen wie vx.

u ist ein reeller Vektor mit n-1 weniger Elementen als vx (wobei n 1, 2 oder 3 ist). Die Elemente in u müssen in aufsteigender Reihenfolge angeordnet sein. Die Elemente enthalten die Werte der Knoten für die Interpolation. Das erste Element in u muß kleiner gleich dem ersten Element in vx sein. Das letzte Element in u muß größer gleich dem letzten Element in vx sein.

n ist eine ganze Zahl gleich 1, 2 oder 3 und gibt den Grad der individuellen stückweisen linearen (n=1), quadratischen (n=2) oder kubischen (n=3) Polynomanpassungen an.

vs ist ein Vektor, der von bspline zurückgegeben wird.

x ist der Wert der unabhängigen Variable, an der ein Ergebnis interpoliert werden soll. Dieser Wert sollte innerhalb des von vx angegebenen Bereichs liegen.

Mit der B-Spline-Interpolation können Sie eine Kurve durch eine Reihe von Punkten laufen lassen. Diese Kurve wird berechnet, indem drei nebeneinander liegende Punkte als Grundlage genommen werden, durch die ein Polynom n-ten Grades geführt wird. Diese Polynome werden dann an den Knoten miteinander verbunden, so daß sie die endgültige Kurve bilden.


bspline-Vektor

Die Elemente im Vektor werden durch bspline wie folgt zurückgegeben:

  • Das erste Element ist 4 und gibt an, daß der Vektor das Ergebnis der Funktion bspline ist.

  • Das zweite Element ist die Koeffizientenmatrix für die B-Spline-Anpassung.
  • Das dritte Element ist die Intervallmatrix, die der Anpassung entspricht.

Der von bspline zurückgegebene Vektor sollte stets an interp weitergegeben werden.


Integrierte Zeichenfolgefunktionen

VORDEFINIERTE ZEICHENFOLGEFUNKTIONEN

Die folgenden Funktionen eignen sich für die Arbeit mit Zeichenfolgen:

verket(S1,S2)

Hängt die Zeichenfolge S2 an das Ende von S1 an. Gibt eine Zeichenfolge zurück.

fehl(S)

Gibt die Zeichenfolge S als Fehlermeldung zurück.

IsString(x)

Gibt 1 zurück, wenn x eine Zeichenfolge ist, andernfalls wird 0 zurückgegeben.

zflän(S)

Bestimmt die Zahl der Zeichen in der Zeichenfolge S. Gibt eine ganze Zahl zurück.

subzf(S,n,m)

Extrahiert eine Subzeichenfolge von S, die mit dem Zeichen an Position n beginnt und höchstens m Zeichen aufweist. Die Argumente m und n müssen ganze Zahlen sein.

strtpos(S,SubS,x)

Sucht die Startposition der Subzeichenfolge SubS in S, die an Position x in S beginnt.

zfinzahl(S)

Wandelt eine Zahlen-Zeichenfolge S in eine Konstante um.

zahlinzf(x)

Wandelt die Zahl x in eine Zeichenfolge um.

zfinvek(S)

Wandelt eine Zeichenfolge S in einen Vektor aus ASCII-Codes um.

vekinzf(v)

Wandelt einen Vektor aus ASCII-Codes in eine Zeichenfolge um.


AUFZÄHLUNGSZEICHEN

Sie können Absätzen innerhalb eines Textbereiches runde schwarze Aufzählungszeichen zuweisen. Im Beispiel unten sind die drei Absätze mit Aufzählungszeichen versehen:

  • Zeile 1

  • Zeile 2
  • Zeile 3


Deaktivieren der automatischen Auswahl der Integrationsmethode

DEAKTIVIEREN DER AUTOMATISCHEN AUSWAHL DER INTEGRATIONSMETHODE (nur in Mathcad Professional)

Bei der Auswertung eines Integrals wird automatisch eine geeignete Integrationsmethode verwendet. Wenn Sie statt dessen jedoch selbst festlegen wollen, welche Integrationsmethode zum Einsatz kommt, müssen Sie die Option Autom. Auswahl deaktivieren und anschließend eine andere Integrationsmethode auswählen. Gehen Sie dazu wie folgt vor:

  1. Geben Sie das Integral ein, und lassen Sie von "Autom. Auswahl" ein Ergebnis zurückgeben.

  2. Klicken Sie mit der rechten Maustaste auf das Integral.

  3. Wählen Sie Autom. Auswahl im Kontextmenü, um diese Option zu deaktivieren.

  4. Klicken Sie nochmals mit der rechten Maustaste auf das Integral.

  5. Wählen Sie aus dem Kontextmenü die gewünschte Integrationsmethode aus.

Das Integral wird automatisch neu ausgewertet, und zwar mit der von Ihnen ausgewählten Methode. Diese Integrationsmethode wird von nun an so lange angewendet, bis Sie eine andere Methode auswählen oder wieder die Option Autom. Auswahl aktivieren.


SYMBOLLEISTE "DIFFERENTIAL/INTEGRAL"

Über die Symbolleiste "Differential/Integral" haben Sie schnellen Zugriff auf diesen Operatoren. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


CAUCHY-VERTEILUNG

dcauchy(x,l,s) Gibt die Wahrscheinlichkeitsdichte für die Cauchy-Verteilung zurück.

pcauchy(x,l,s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qcauchy(p,l,s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rcauchy(m,l,s) Gibt einen Vektor aus m Zufallszahlen zurück, die die Cauchy-Verteilung aufweisen.


ÄNDERN DER BEGRENZUNGEN DER RADIALEN ACHSE VON KREISDIAGRAMMEN

Zum Deaktivieren der standardgemäßen Begrenzungen der radialen Achse gehen Sie folgendermaßen vor:

  1. Klicken Sie auf das Kreisdiagramm, damit es ausgewählt wird. Es werden zwei weitere Zahlen rechts neben dem Kreisdiagramm angezeigt.

  2. Legen Sie den Ursprung des Kreisdiagramms fest, indem Sie auf die untere Zahl klicken und eine neue Zahl eingeben.

  3. Legen Sie eine Achsenbegrenzung für den Umfang des Diagramms fest, indem Sie auf die Zahl im oberen Platzhalter klicken und eine neue Zahl eingeben.

  4. Klicken Sie auf eine Stelle außerhalb des Diagrammbereichs.

Es ist nicht möglich, die standardgemäßen Winkelachsenbeschränkungen außer Kraft zu setzen. Für sie ist immer 0 Grad und 360 Grad festgelegt.


ÄNDERN DER ACHSENBEGRENZUNGEN VON X-Y-DIAGRAMMEN

Zum Ersetzen der standardgemäßen Achsenbegrenzungen gehen Sie folgendermaßen vor:

  1. Klicken Sie auf das Diagramm, um es auszuwählen. Es werden vier Zahlen angezeigt, für jede Achsenbegrenzung eine.

  2. Legen Sie die Achsenbegrenzung auf der horizontalen Achse fest, indem Sie auf die Zahl unter der entsprechenden x-Achsenbegrenzung klicken und sie durch die Zahl ersetzen, bei der die Achse enden soll.

  3. Führen Sie für die vertikale Achse dieselben Schritte bei der Zahl links von der korrekten Achsenbegrenzung durch.

  4. Klicken Sie auf eine Stelle außerhalb des Diagrammbereichs, damit das Diagramm mit den Zahlen neu angezeigt wird, die Sie als Achsenbegrenzung festgelegt haben.


Wechseln der Drucker

WECHSELN DES DRUCKERS

Wenn die Druckausgabe für das Arbeitsblatt in eine Datei oder auf einen anderen Drucker umgeleitet werden soll, gehen Sie wie folgt vor:

Wählen Sie den Befehl Drucken aus dem Menü Datei. Das Dialogfeld "Drucken" erscheint.

Klicken Sie auf "Druckereinrichtung", um das Dialogfeld "Druckereinrichtung" zu öffnen. Geben Sie den gewünschten Drucker an. Klicken Sie anschließend auf "OK".

Soll Ihr Ausdruck in eine Datei umgeleitet werden, klicken Sie auf "Druckausgabe in Datei umleiten".


ÄNDERN DER FARBE FÜR DIE HERVORHEBUNG VON GLEICHUNGEN ODER TEXT

Standardmäß ist die Hintergrundfarbe direkt unter einem hervorgehobenen Bereich gelb. Soll dies für alle hervorgehobenen Bereiche geändert werden, gehen Sie wie folgt vor:

  1. Wählen Sie Farbe / Hervorhebung im Menü Format.

  2. Wählen Sie eine Farbe im aufgerufenen Dialogfeld, oder klicken Sie auf "Farben definieren", wenn Sie eine eigene Farbe festlegen möchten.

Dies wirkt sich auf alle hervorgehobenen Bereiche im Arbeitsblatt aus. Zum Ändern der Hervorhebungsfarbe für nur einen Bereich gehen Sie folgendermaßen vor:

  1. Klicken Sie in den Bereich.

  2. Wählen Sie Eigenschaften im Menü Format.

  3. Klicken Sie auf die Registerkarte "Anzeige".

  4. Klicken Sie auf "Farbe auswählen", um eine andere Hintergrundfarbe als die Standardhintergrundfarbe festzulegen.

  5. Klicken Sie auf “OK”.


FESTLEGEN DER FARBE FÜR HERVORGEHOBENE ÄNDERUNGEN

Standardmäßig werden alle an einem Elektronischen Buch vorgenommenen Änderungen in einer unterschiedlichen Farbe hervorgehoben.

Sie können diese Farbe wie folgt ändern:

Wählen Sie Farbe / Anmerkung aus dem Menü Format.

Mathcad zeigt eine Palette mit verfügbaren Farben an.


ÄNDERN DER SCHRIFTART FÜR ALLE KONSTANTEN

Zum gleichzeitigen Ändern der Schriftart für alle Konstanten im Arbeitsblatt gehen Sie wie folgt vor:

  1. Wählen Sie Gleichung aus dem Menü Format.

  2. Stellen Sie sicher, daß im Dialogfeld die Option Konstanten gewählt ist.

  3. Klicken Sie auf "Ändern", und wählen Sie die gewünschten Schriftattribute aus.

  4. Klicken Sie auf "OK", um die Schriftattribute allen Konstanten im Arbeitsblatt zuzuweisen.

  5. Aus optischen Gründen sollten Sie sich überlegen, ob Sie die Schriftart für alle Variablen ändern möchten.

Wenn Sie die Schriftart nur für eine bestimmte Konstante ändern wollen, und nicht für alle Konstanten gleichzeitig, müssen Sie der betreffenden Konstante eine eigene benutzerdefinierte Formatvorlage zuweisen.


ÄNDERN DER SCHRIFTART FÜR ALLE VARIABLEN

Zum gleichzeitigen Ändern der Schriftart für alle Variablen im Arbeitsblatt gehen Sie wie folgt vor:

  1. Wählen Sie Gleichung aus dem Menü Format.

  2. Stellen Sie im Dialogfeld sicher, daß die Option Variablen markiert ist.

  3. Klicken Sie auf "Ändern", und wählen Sie die gewünschten Schriftattribute aus.

  4. Klicken Sie auf "OK", um die Schriftattribute allen Variablen im Arbeitsblatt zuzuweisen.

  5. Aus optischen Gründen sollten Sie sich überlegen, ob Sie die Schriftart für alle Konstanten ändern möchten.

Wenn Sie die Schriftart für eine bestimmte Variable ändern wollen, und nicht für alle Variablen gleichzeitig, müssen Sie der entsprechenden Variable eine eigene benutzerdefinierte Formatvorlage zuweisen.


ÄNDERN DER SCHRIFTART FÜR EINE BESTIMMTE VARIABLE ODER KONSTANTE

Zum Ändern der Schriftart für eine bestimmte Variable oder Konstante muß deren Formatvorlage geändert werden. Hierfür gibt es zwei Verfahren. Das erste ist obligatorisch, das zweite optional.

Zuweisen einer anderen Rechenformatvorlage zu einer markierten Variable oder Konstante

Ändern der mit der Rechenformatvorlage zusammenhängenden Schriftartattribute

Bei Variablennamen müssen Sie auf die Schriftart achten. Wenn Sie z. B. eine Anweisung wie "x := 1" in Ihrem Dokument haben und Sie das Attribut in "x := 1" ändern, sind die x im weiteren Verlauf des Dokuments nicht definiert. Sie müssen diese dann mit einem neuen Attribut verknüpfen, damit sie folgendermaßen aussehen: x.


ZEICHEN SUCHEN UND ERSETZEN

Mit den Dialogfeldern zum Suchen und Ersetzen können Sie zahlreiche Ziffern, Buchstaben und andere Zeichen in einem Arbeitsblatt suchen und gegebenenfalls ändern. Ziffern und Buchstaben können in jedem Bereich eines Arbeitsblatts vorkommen. Andere Zeichen, zum Beispiel runde Klammern, finden Sie nur in Textbereichen und Zeichenfolgen. Aus der folgenden Tabelle können Sie ersehen, welche Zeichen Sie in welchen Regionen suchen können.

Unterstütztes Zeichen: | Eingabe im Dialogfeld: | Durchsuchte Bereiche:
Buchstaben und Ziffern | Buchstaben und Ziffern | Alle
Griechische Buchstaben | Eingabe von \ gefolgt vom entsprechenden lateinischen Zeichen | Rechenbereich
Punkt | Eingabe von . | Alles (sucht im Rechenbereich nach dem Operator für tiefgestellte Zeichen)
Runde Klammern | Eingabe von ( bzw. ) | Text und Zeichenfolgen
Komma | Eingabe von , | Text und Zeichenfolgen
Leerzeichen | Drücken der Leertaste | Text und Zeichenfolgen
Plus und Minus | Eingabe von + oder - | Text und Zeichenfolgen
Tabulator | Eingabe von ^t | Text
Absatzzeichen | Eingabe von ^p | Text
Winkelzeichen | Eingabe von ^ | Text und Zeichenfolgen
Zeilenumbruch | Eingabe von ^L | Text
Umgekehrter Schrägstrich | Eingabe von ^\ | Text


IN VARIABLEN- UND FUNKIONSNAMEN ZUGELASSENE ZEICHEN

Variablen- und Funktionsnamen können folgende Zeichen enthalten:

Groß- und Kleinbuchstaben

Ziffern 0 bis 9

Das Symbol für Unendlichkeit

Zeichen `

Griechische Buchstaben

Unterstrich ( _ )

Prozentzeichen ( % )

Literalindizes


Tschebyscheffsche Polynomfunktionen

TSCHEBYSCHEFFSCHE POLYNOMFUNKTIONEN (nur in Mathcad Professional)

Tcheb(n,x) Gibt den Wert des Tschebyscheffschen Polynoms n-ten Grades der ersten Art bei x zurück.

Ucheb(n,x) Gibt den Wert des Tschebyscheffschen Polynoms n-ten Grades der zweiten Art bei x zurück.

Argumente:

n ist eine nicht-negative ganze Zahl.

x ist ein reeller Skalar.

Das Tschebyscheffsche Polynom der ersten Art ist eine Lösung für die folgende Differentialgleichung:

Das Tschebyscheffsche Polynom der zweiten Art ist eine Lösung der folgenden Differentialgleichung:


DIALOGFELD "RECHTSCHREIBUNG"

Wenn die Rechtschreibprüfung ein falsch geschriebenes Wort findet, wird das Dialogfeld "Rechtschreibprüfung" geöffnet. Die Rechtschreibprüfung betrachtet alle Wörter als fehlerhaft, die sie nicht in ihrem Wörterbuch findet.

Im Dialogfeld "Rechtschreibprüfung" finden Sie die folgenden Felder und Schaltflächen:

Nicht gefunden

Das Wort in diesem Feld wurde im Wörterbuch nicht gefunden. Es ist möglicherweise falsch geschrieben.

Ändern in

In diesem Feld werden Ersetzungsvorschläge für das falsch geschriebene Wort angezeigt. Wählen Sie einen Ersetzungsvorschlag aus, und klicken Sie auf "Ändern", um das falsch geschriebene Wort zu ersetzen.

Ignorieren

Mit dieser Schaltfläche geben Sie an, daß das Wort so bleiben soll, wie es ist. Im Unterschied zur Schaltfläche "Hinzufügen" wird das Wort jedoch nicht ins Wörterbuch aufgenommen.

Ändern

Mit dieser Schaltfläche wird das falsch geschriebene Wort durch den im Feld "Ändern in" ausgewählten Ersetzungsvorschlag ersetzt.

Hinzufügen

Mit dieser Schaltfläche geben Sie an, daß das Wort so bleiben soll, wie es ist. Das bisher nicht im Wörterbuch enthaltene Wort wird dabei ins Wörterbuch aufgenommen. Die Rechtschreibprüfung betrachtet das Wort dann bei künftigen Durchgängen als richtig geschrieben.

Vorschlagen

Zeigt weitere, jedoch nicht mehr so wahrscheinliche Ersetzungsvorschläge an.


CHEMISCHE NOTATION

Soll ein Variablenname einen Operator enthalten (zum Beispiel Hoch- oder Tiefstellungen), müssen Sie in einem besonderen Modus arbeiten, der sonst in erster Linie bei der chemischen Notation Verwendung findet:

  1. Drücken Sie Strg+Umschalt+J. Hierdurch wird ein Platzhalter eingefügt, der in eckige Klammern gesetzt wird.

  2. Geben Sie die Buchstaben, Ziffern und Operatoren für den Namen ein.

Beispiel:

Sie können Variablendefinitionen wie die folgende erstellen:


CHI-QUADRAT-VERTEILUNG

dchisq(x,d) Gibt die Chi-Quadrat-Verteilung zurück.

pchisq(x,d) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qchisq(p,d) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rchisq(m,d) Gibt einen Vektor aus m Zufallszahlen zurück, die die Chi-Quadrat-Verteilung aufweisen.


Cholesky-Dekomposition

CHOLESKY-DEKOMPOSITION (nur in Mathcad Professional)

cholesky(M) Gibt die untere Dreiecksmatrix L zurück, so daß gilt: .

Argumente:

M muß symmetrisch sein.

Diese Funktion verwendet nur den oberen dreieckigen Teil von M.


Dialogfeld "WWW-Foren"

FENSTER MIT WWW-FOREN

Wenn Sie im Informationszentrum auf "WWW-Foren" klicken, erscheint ein Fenster mit:

Foren auf der linken Seite

Die Forumnamen ändern sich im Laufe der Zeit, beziehen sich aber im Regelfall auf eine Vielzahl von Disziplinen. Jedes Forum enthält mindestens ein Thema. Die verfügbaren Themen können Sie sich durch Klicken auf den jeweiligen Forumnamen anzeigen lassen.

Themen auf der rechten Seite

Wenn Sie auf eines der Foren auf der linken Seite klicken, werden die Titel der Themen im jeweiligen Forum angezeigt. Wenn Sie auf eine der Nachrichten klicken, erscheinen im Fenster am unteren Rand Angaben zum Verfasser, zum Titel und zum Datum, an dem das Thema geschrieben wurde. Ist ein Thema eingerückt, handelt es sich um eine Antwort auf den vorherigen Beitrag. Handelt es sich bei dem Thema um eine Textdatei, wird diese im Fenster angezeigt. Handelt es sich bei dem Thema um ein Mathcad-Arbeitsblatt, wird dieses in einem eigenen Fenster geöffnet. Handelt es sich bei der Nachricht um eine andere Art von Dateien, werden Sie gefragt, ob die Datei sofort geöffnet oder auf Ihrer Festplatte gespeichert werden soll.

Außerdem können Sie die folgenden Schaltflächen verwenden:

Vorheriges

Öffnet das Thema vor dem aktuellen Thema.

Nächstes

Öffnet das nächste Thema im Forum.

Senden

Öffnet das Dialogfeld für Senden, mit dessen Hilfe Sie Ihr Thema an das Forum senden können, in dem Sie sich gerade befinden. Folgendes kann gesendet werden:

  • das aktive Arbeitsblatt

  • eine Datei, die an einer beliebigen Stelle in Ihrem System gespeichert ist

  • eine Textnachricht

Antwort senden

Öffnet das Dialogfeld für Senden, mit dessen Hilfe Sie auf das gegenwärtig angezeigte Thema antworten können. Sie können als Antwort folgendes senden:

  • das aktive Arbeitsblatt

  • eine Datei, die an einer beliebigen Stelle in Ihrem System gespeichert ist

  • eine Textnachricht

Aktualisieren

Bringt die Liste der Themen und Foren wieder auf den neuesten Stand.


Ausblenden bestimmter Regionen

AUSBLENDEN BESTIMMTER REGIONEN (nur in Mathcad Professional)

Nachdem Sie eine Region eingefügt haben, können Sie sie ausblenden, um die Bereiche in der Region unsichtbar zu machen. Gehen Sie hierzu folgendermaßen vor:

1. Klicken Sie mit der rechten Maustaste auf eine der Begrenzungslinien der Region.

2. Wählen Sie im Kontextmenü den Befehl Reduzieren. Die Begrenzungslinien der Region und Bereiche zwischen diesen Begrenzungslinien erscheinen daraufhin als eine einzige Linie,

und die Bereiche unterhalb der ausgeblendeten Region werden entsprechend nach oben verschoben.

Hinweise:

  • Die Linie, die eine ausgeblendete Region repräsentiert, kann ausgewählt (markiert) und mit der Maus an eine andere Position gezogen bzw. in ihrem Aussehen geändert werden; das Löschen oder Kopieren der Linie ist jedoch nicht möglich.

  • Die Bereiche innerhalb der ausgeblendeten Region werden weiterhin berechnet, aber sie erscheinen nicht auf dem Bildschirm. Um die Bereiche wieder sichtbar zu machen, müssen Sie die Region wieder einblenden.

  • Soll verhindert werden, daß andere eine ausgeblendete Region wieder einblenden können, können Sie die Region sperren.


ZUSAMMENFASSEN VON GLIEDERN

Zum Ausdrücken einer Summe von Gliedern als Polynom in einer bestimmten Variable gehen Sie folgendermaßen vor:

  1. Wählen Sie einen Variablennamen oder den Namen einer Funktion zusammen mit ihrem Argument aus, indem Sie ihn zwischen die Bearbeitungslinien plazieren

  2. Wählen Sie den Befehl Zusammenfassen aus dem Menü Symbolik.

Dadurch wird die Summe zu einem Polynom in der Variable bzw. Funktion umgeformt.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Sollten Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


COLLECTIONS

Inputs und Outputs sind vordefinierte Collections von DataValue-Objekten, die die Eingaben bzw. Ausgaben des skriptfähigen Objekts enthalten.

Mit Hilfe der Eigenschaft Count kann abgefragt werden, wie viele Elemente die Collection enthält. So läßt sich mit Outputs.Count die Anzahl der Ausgabevariablen ermitteln.

Die Methode Item wird verwendet, um ein bestimmtes Element in der Collection anzugeben. Die Festlegung einer bestimmten Eingabe oder Ausgabe erfolgt mit Hilfe von Inputs.Item(n) bzw. Outputs.Item(n), wobei n der Index der Ein- bzw. Ausgabe ist. Der Index n beginnt stets bei 0. Item ist die Standardmethode, so daß Sie bei Sprachen wie VBScript und JScript den Namen der Methode weglassen können. Wird keine Methode angegeben, wird automatisch die Standardmethode verwendet. Daraus folgt, daß Inputs(0) mit Inputs.Item(0) identisch ist. Mit (0) wird auf die erste Eingabe verwiesen.

Hinweis: Im Gegensatz zu VBScript ist in JScript bei der Angabe von Funktionen, Methoden, Objekten und Eigenschaften auf die Groß- und Kleinschreibung zu achten.


FARBEINSTELLUNGEN (3D-SÄULENDIAGRAMME)

Zum Festlegen der Farbe eines 3D-Säulendiagramms gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen auf der Seite "Ansicht" haben Sie folgende Möglichkeiten:

  • Füllen der Säulen mit einer Volltonfarbe oder entsprechend einer Farbzuordnung

  • Füllen der Säulen mit einer Farbe aus einer Farbzuordnung entsprechend den x-, y- oder z-Werten.

  • Entfernen sämtlicher Füllfarbe

  • Festlegen gleichmäßiger Übergänge für die Farben auf der Fläche

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld auszublenden.


Farbeinstellungen (Umrißdiagramme)

FARBEINSTELLUNGEN (UMRISSDIAGRAMME)

Zum Festlegen der Schattierung eines Umrißdiagramms gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen auf der Seite "Ansicht" haben Sie folgende Möglichkeiten:

  • Füllen des Diagramms mit Farbe entsprechend einer Farbzuordnung

  • Entfernen von Farbe

  • Füllen der Umrisse mit zur Hälfte gefüllten verbundenen Oberflächen

  • Festlegen gleichmäßiger Farbübergänge im Diagramm

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


FARBEINSTELLUNGEN (FLÄCHENDIAGRAMME)

Zum Festlegen der Farbe eines Flächendiagramms gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen auf der Seite "Ansicht" haben Sie folgende Möglichkeiten:

  • Füllen der Fläche mit einer Volltonfarbe oder entsprechend einer Farbzuordnung

  • Füllen der Umrisse der Fläche entsprechend einer Farbzuordnung

  • Entfernen sämtlicher Füllfarbe

  • Zeichnen der Fläche mit zur Hälfte gefüllten verbundenen Flächen

  • Festlegen gleichmäßiger Übergänge für die Farben auf der Fläche

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Farbeinstellungen (Vektorfelddiagramme)

FARBEINSTELLUNGEN (VEKTORFELDIAGRAMME)

Zum Festlegen der Farbe der Pfeilspitzen in einem Vektorfelddiagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen auf der Seite "Ansicht" haben Sie folgende Möglichkeiten:

  • Füllen der Pfeile mit einer Volltonfarbe oder entsprechend einer Farbzuordnung

  • Entfernen der Farbe von den Pfeilen

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Farbzuordnung

Eine Farbzuordnung ist eine Datei, die Daten enthält, mit denen verschiedenen Stufen eines Diagramms unterschiedliche Farben zugeordnet werden können. Mathcad bietet eine Reihe möglicher Farbzuordnungen, mit denen Sie Regenbogenfarben oder graue, rote, blaue und grüne Schattierungen zuweisen können. Sie haben auch die Möglichkeit, eigene Farben zu erstellen.

Eine Farbzuordnungsdatei ist eine *.CMP-Datei, die drei Spalten von Werten enthält, die für Stufen von Rot (Spalte 1), Grün (Spalte 2) und Blau (Spalte 3) stehen.

Normalerweise enthält eine Farbzuordnung 256 Zeilen. Jede Zeile von Werten entspricht einer aus Rot, Grün und Blau zusammengesetzten Farbe, der ein Graustufenwert zugeordnet ist. Wenn eine Farbzuordnung weniger als 256 Zeilen enthält, interpoliert Mathcad linear über 256 Werte.

Jeder Wert in einer Farbzuordnung muß eine ganze Zahl zwischen 0 und einschließlich 255 sein. Werte, die keine ganzen Zahlen sind, werden verkürzt. Werte, die nicht zwischen 0 und 255 liegen, werden auf 0 erhöht oder auf 255 verringert.

Standardmäßig prüft Mathcad den CMAPS-Ordner im Mathcad-Ordner auf *.CMP-Dateien. Sie können eine Farbzuordnungsdatei einem 3D-Diagramm zuordnen, indem Sie sie im Dialogfeld "3D-Diagrammformat" auswählen. Der CMAPS-Ordner enthält einige Farbzuordnungen. Sie können auch eigene Farbzuordnungen mit der Funktion SpeichernFarbwerte anlegen.

Hinweis:

Manche Farbzuordnungen wie Regenbogen, Graustufen, Rot, Grün und Blau sind in der 3D-Diagrammsteuerung integriert. Daher sind diese nicht als *.CMP-Dateien im Ordner CMAPS enthalten.


KOMBINATIONEN

combin(n,k) Gibt die Anzahl Teilmengen zurück, die aus n Objekten gebildet werden können, wenn jede Teilmenge die Größe k hat. Jede dieser Teilmengen wird als eine Kombination bezeichnet.

Argumente:

n und k sind ganze Zahlen größer als 0.

n muß größer als oder gleich k sein.

Hinweise:

  • Kombinationen und Permutationen ähneln sich, da es sich in beiden Fällen um Teilmengen einer Menge handelt. Im Unterschied zur Kombination ist jedoch bei der Permutation die interne Reihenfolge von Bedeutung.

  • Die Anzahl der Kombinationen wird üblicherweise wie folgt angegeben: .

Die Definition einer Kombination lautet:


KOMBINATORISCHE FUNKTIONEN

combin(n,k)

Gibt die Anzahl der Kombinationen von n Objekten bei Auswahl von k Objekten zurück.

permut(n,k)

Gibt die Anzahl der Permutationen von n Objekten bei Auswahl von k Objekten zurück.


Operator "Konjugiert-komplexe Zahl"

KONJUGIERT-KOMPLEXE ZAHL

Tastaturbefehl: "

Gibt die konjugiert-komplexe Zahl von x zurück:

Re(x) - i Im(x)

Operanden:

x muß ein Skalar sein.


FUNKTIONEN FÜR KOMPLEXE ZAHLEN

Re(Z) Realteil von Z

Im(Z) Imaginärteil von Z

arg(z) Argument von z, zwischen -p und p, einschließlich p.

Argumente:

Z kann ein reeller oder komplexer Skalar oder eine Matrix sein.

z kann ein reeller oder komplexer Skalar sein.

Verwandte Themen:

Felder als Argumente


FUNKTIONEN FÜR KOMPLEXE ZAHLEN

Re(Z)

Gibt den Realteil von Z zurück.

Im(Z)

Gibt den Imaginärteil von Z zurück.

arg(z)

Gibt das Argument von z, zwischen -p und p, zurück.

csign(z)

Gibt 0 zurück, wenn z=0. Ist Re(z)>0 oder (Re(z)=0 und Im(z)>0), wird 1 zurückgegeben, andernfalls -1.

signum(z)

Gibt 1 zurück, wenn z=0 und andernfalls z/|z|.


FFT/IFFT ODER CFFT/ICFFT

Verwenden Sie das Funktionspaar fft/ifft, wenn beide der folgenden Aussagen wahr sind:

Die Zeitbereichsdaten sind reell.

Der Datenvektor hat [image] Elemente (m>2).

Verwenden Sie das Funktionspaar cfft/icfft, wenn eine der folgenden Aussagen zutrifft:

Die Zeitbereichsdaten sind komplex.

Der Datenvektor hat nicht [image] Elemente.

Die Daten liegen in Matrixform, nicht in Vektorform vor.

Bei reellen Daten im Zeitbereich weist die Fourier-Transformation Konjugationssymmetrie auf. Aus diesem Grund läßt fft die redundante zweite Hälfte des Ergebnisses weg. Daher ist der Vektor, der durch fft zurückgegeben wird, nur halb so groß wie der Originalvektor.

Die Funktion ifft stellt diese redundante Hälfte wieder her. Daher sollten Sie die Funktionen fft und ifft stets zusammen verwenden.

Beim Funktionspaar cfft/icfft wird keine solche Symmetrie vorausgesetzt. Diese Funktionen sind zwar für reelle Daten weniger effizient, können aber trotzdem verwendet werden.


KOMPLEMENTÄRE FEHLERFUNKTION

Argumente:

x ist ein reeller Skalar.

Zwischen der komplementären Fehlerfunktion und der Fehlerfunktion besteht die folgende Beziehung:

erfc(x) = 1 - erf(x)


Bedingungszahl einer Matrix

BEDINGUNGSZAHL EINER MATRIX (nur in Mathcad Professional)

cond1(M) Gibt die Bedingungszahl der Matrix M auf der Basis der Norm [image] zurück.

cond2(M) Gibt die Bedingungszahl der Matrix M auf der Basis der Norm [image] zurück.

conde(M) Gibt die Bedingungszahl der Matrix M auf der Basis der euklidischen Norm zurück.

condi(M) Gibt die Bedingungszahl der Matrix M auf der Basis der infiniten Norm zurück.

Argumente:

M muß eine quadratische Matrix sein.


KONFIGURIEREN EINER KOMPONENTE

Nachdem Sie eine Komponente in Ihr Arbeitsblatt eingefügt haben, müssen Sie im Normalfall die Komponente konfigurieren, um festzulegen, wie sie mit den Eingaben aus Mathcad umgehen und was als Ausgabe gesendet werden soll. Zum Konfigurieren der Eigenschaften einer Komponente gehen Sie wie folgt vor:

Klicken Sie einmal auf die Komponente, um sie zu markieren.

Klicken Sie mit der rechten Maustaste auf die Komponente, um das Kontextmenü zu öffnen. Welche Optionen in diesem Kontextmenü zur Verfügung stehen, hängt davon ab, was für eine Komponente Sie markiert haben. In den meisten Fällen enthält das Kontextmenü jedoch mindestens die Befehle Ausschneiden, Kopieren und Eigenschaften.

Wählen Sie im Kontextmenü den Befehl Eigenschaften.

Welche Optionen im Dialogfeld "Eigenschaften" angezeigt werden, hängt davon ab, welche Komponente Sie zuvor markiert haben.


Konfluente hypergeometrische Funktion

KONFLUENTE HYPERGEOMETRISCHE FUNKTION (nur in Mathcad Professional)

mhyper(a,b,x) Gibt den Wert der konfluenten hypergeometrischen Funktion 1F1(a;b;x) oder M(a,b,x) zurück.

Argumente:

a und b sind reelle Skalare.

x ist ein reeller Skalar.

Die konfluente hypergeometrische Funktion ist die Lösung der folgenden Differentialgleichung:

Viele Funktionen sind Sonderfälle der konfluenten hypergeometrischen Funktion. Beispiel:

exp(x)=mhyper(1,1,x)

exp(x).sinh(x)=x.mhyper(1,2,2.x)


LÖSEN MIT DEM GRADIENTENVERFAHREN

Das Gradientenverfahren ist ein nichtlineares Verfahren, das bei den Funktionen Suchen, minfehl, minimieren und maximieren verwendet werden kann.

Sofern Sie mit Mathcad Professional arbeiten, wird das Gradientenverfahren über das Dialogfeld "Erweiterte Optionen" gesteuert. Gehen Sie zum Ändern dieser Optionen wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Lösungsfunktion: Suchen, minfehl, minimieren oder maximieren.

  2. Wählen Sie Erweiterte Optionen... aus dem Kontextmenü.

  3. Legen Sie im Dialogfeld "Erweiterte Optionen" die Einstellungen für die Optionen "Ableitungsschätzung", "Variablenschätzung" bzw. "Lineare Variablenprüfung" fest.

Diese Optionen sollten nur von erfahrenen Benutzern verwendet werden, und auch erst dann, wenn mit den Standardoptionen keine Lösung gefunden werden konnte bzw. wenn eine genaue Einflußnahme auf das Lösungsverfahren gewünscht wird.

Weitere Informationen zum Gradientenverfahren finden Sie in den Abschnitten zu den Lösungsalgorithmen.


Umrißdiagramme auf anderen Ebenen

UMRISSIAGRAMME AUF ANDEREN EBENEN

Wenn Sie ein Umrißdiagramm erstellen, sehen Sie standardmäßig die auf die XY-Hintergrundebene projizierten z-Konturen. Wenn Sie ein Umrißdiagramm abbilden und mindestens eine weitere Art von Diagramm erstellen, können Sie jedoch die x- oder y-Umrißlinien auf den XY- oder YZ-Hintergrundebenen anzeigen lassen. Gehen Sie hierzu folgendermaßen vor:

1. Doppelklicken Sie auf die Darstellung mehrerer Diagramme, damit ein Dialogfeld mit Registerkarten geöffnet wird.

2. Klicken Sie auf die Registerkarte "Spezial", um die Seite "Spezial" zu öffnen. Klicken Sie auf das Register, das dem Umrißdiagramm entspricht. (d. h., klicken Sie auf Diagramm 1, Diagramm 2, usw.)

3. Wählen Sie eine Umrißrichtung in dem Dropdown-Menü unten im Abschnitt "Umrißoptionen". Wählen Sie "X-Umrisse", wenn die Umrisse auf der XZ-Hintergrundebene sichtbar werden solle. Mit "Y-Umrisse" werden die Umrisse auf der YZ-Hintergrundebene sichtbar.

7. Klicken Sie auf "Linien zeichnen" in den Umrißoptionen, und/oder klicken Sie auf "Füllen", um die Umrisse mit Farbe zu füllen.

8. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", damit das Dialogfeld ausgeblendet wird.

Hinweis:

Wenn Sie andere Umrisse als die z-Umrisse formatieren, müssen Sie im Dropdown-Menü die Umrißrichtung wählen, bevor Sie andere Formatoptionen festlegen.


Steuern der Schreibweise von Daten mit Hilfe der Dateizugriffsfunktionen

STEUERN DER SCHREIBWEISE VON DATEN

Signifikante Stellen:

PRNSCHREIBEN verwendet zum Schreiben standardmäßig 4 signifikante Stellen. Diese Vorgabe können Sie ändern, indem Sie den Wert für die Variable PRNPRECISION ändern. Dazu steht Ihnen die entsprechende Option auf der Registerkarte "Vordefinierte Variablen" des Dialogfelds "Rechenoptionen" zur Verfügung, das Sie über den Befehl Optionen im Menü Rechnen öffnen können.

Spaltenbreite:

PRNSCHREIBEN schreibt Daten standardmäßig in Spalten mit einer Breite von 8 Zeichen. Diese Vorgabe können Sie ändern, indem Sie den Wert für PRNCOLWIDTH ändern. Dazu steht Ihnen die entsprechende Option auf der Registerkarte "Vordefinierte Variablen" des Dialogfelds "Rechenoptionen" zur Verfügung, das Sie über den Befehl Optionen im Menü Rechnen öffnen können.


Steuern von Iterationen in einer Schleife

STEUERN VON ITERATIONEN IN EINER SCHLEIFE (nur Mathcad Professional)

Programmschleifen sind dafür konzipiert, so lange fortgesetzt zu werden, bis eine bestimmte Bedingung erfüllt ist oder eine festgelegte Anzahl von Iterationen abgeschlossen wurde. Sie haben jedoch die Möglichkeit, eine Schleife während einer bestimmten Iteration anzuhalten und mit der nächsten Iteration fortzufahren. Dazu verwenden Sie eine "continue"-Anweisung.

Zum Einfügen einer "continue"-Anweisung gehen Sie folgendermaßen vor:

Klicken Sie auf einen Platzhalter, in den Sie die "continue"-Anweisung einfügen möchten.

Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung " zu öffnen, die die Programmierungsoperatoren enthält.

Klicken Sie auf die Schaltfläche "continue". Geben Sie nicht einfach das Wort "continue" ein.

Wenn das Programm eine “continue”-Anweisung erkennt, unterbricht es die Iteration, wechselt in die nächsthöhere Schleife, und fährt mit der nächsten Iteration fort.


Steuern der Berechnungsgenauigkeit

TOL (STANDARD = 0.001)

Diese Konstante stellt die Genauigkeit dar, mit der Integrale und Ableitungen berechnet werden. Sie bestimmt außerdem, wie lange eine Iteration in Gleichheitssystemen und in der Wurzel-Funktion fortdauert.

Festlegen von TOL auf niedrige Werte

Wenn Sie TOL auf einen sehr niedrigen Wert einstellen, werden alle Ergebnisse mit weitaus höherer Genauigkeit berechnet. Abhängig von den numerischen Eigenschaften des Ausdrucks kann dies zu erhöhter Berechnungszeit führen.

Außerdem kann es vorkommen, daß die Fehlermeldung Konnte Lösung nicht ermitteln angezeigt wird, wenn die numerischen Eigenschaften des Ausdrucks dazu führen, daß sich eine Lösung asymptotisch an eine Zahl annähert, die außerhalb des von TOL festgelegten Schwellenwerts liegt.

Festlegen von TOL auf hohe Werte

Hohe Werte für TOL verringern die Berechnungszeit; dies geht jedoch auf Kosten der Genauigkeit.


Steuern der Genauigkeit von Bedingungen

CTOL (STANDARD = 0.001)

Hierdurch wird bestimmt, wie genau eine Bedingung in einem Gleichungssystem erfüllt sein muß, damit eine Lösung als akzeptabel gilt. Ein Gleichungssystem, das von CTOL gesteuert wird, besteht aus dem Wort Vorgabe, mindestens einer Bedingung, die erfüllt werden muß, sowie einer Optimierungsfunktion: minimieren, maximieren, suchen oder minfehl. Damit die Funktion eine Lösung ausgibt, müssen die Bedingungen im Gleichungssystem erfüllt sein. Beispielsweise kann die Bedingung x<2 festgelegt werden; sie muß erfüllt werden, damit eine Lösung ausgegeben wird. Bei CTOL=0.001 gilt die Beschränkung als erfüllt, wenn x<2.001.

Sie können die Genauigkeit der Lösung bestimmen, indem Sie den Wert für CTOL einstellen. Je größer der Wert von CTOL ist, desto ungenauere Lösungen werden zugelassen. Je kleiner der Wert von CTOL ist, desto genauer sind die gefundenen Lösungen. Allerdings kann sich die Rechenzeit verlängern, die zur Erstellung der Lösung erforderlich ist.

Neudefinieren von CTOL...


Bestimmen des Erscheinungsbilds von Regionengrenzen

BESTIMMEN DES ERSCHEINUNGSBILDS VON REGIONSBEGRENZUNGSLINIEN

Sie können das Erscheinungsbild der Regionsbegrenzungslinien und der ausgeblendeten Regionsleiste für eine eingefügte Region verändern. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf eine der Grenzen oder auf die ausgeblendete Leiste.

  2. Wählen Sie den Befehl Eigenschaften aus dem Kontextmenü.

  3. Klicken Sie auf die Registerkarte Region, und führen Sie im Dialogfeld folgendes durch:

  • Geben Sie für die Region einen Namen (soweit vorhanden) an, und legen Sie fest, ob der Name auf dem Bildschirm angezeigt werden soll.

  • Geben Sie an, ob ein Zeitstempel auf den Grenzen erscheinen soll.

  • Geben Sie an, ob ein Symbol auf den Grenzen angezeigt werden soll.

  • Geben Sie an, ob der Rahmen auf den Grenzen angezeigt werden soll.


FESTLEGEN DER OPTIONEN FÜR DIE ANZEIGE EINES BESTIMMTEN ERGEBNISSES

Zum Festlegen der Anzeige einer bestimmten Zahl müssen Sie das lokale Ergebnisformat ändern. Gehen Sie hierzu folgendermaßen vor:

  1. Wählen Sie den Befehl Ergebnis aus dem Menü Format, oder doppelklicken Sie auf das Ergebnis, um das Dialogfeld Ergebnisformat aufzurufen.

  2. Stellen Sie sicher, daß die Option "Als Standard einrichten" NICHT aktiviert ist.

  3. Nehmen Sie die erforderlichen Änderungen im Dialogfeld Ergebnisformat vor, und klicken Sie auf "OK".

Wenn Sie "Als Standard einrichten" aktivieren, können sich die Änderungen auf alle Ergebnisse im Arbeitsblatt auswirken.


UMWANDLUNG IN GRAD

Von den inversen trigonometrischen Funktionen und der Funktion "winkel" werden jeweils Winkel in Radiant zurückgegeben. Sie können statt dessen mit dem Platzhalter für Einheiten am Ende der Gleichung das Ergebnis in Grad umwandeln. Siehe dazu das folgende Beispiel:


KOPIEREN VON MATRIZEN MIT NUMERISCHEN ERGEBNISSEN

Wenn das Ergebnis rechts des Gleichheitszeichens eine Matrix oder ein Vektor ist, müssen Sie die gesamte Matrix bzw. den gesamten Vektor auf einmal kopieren. Wollen Sie nur Teile des Feldes kopieren, muß dieses als Ausgabetabelle angezeigt werden.

Zum Kopieren des gesamten angezeigten Feldes (Matrix oder Vektor) gehen Sie wie folgt vor:

  1. Klicken Sie auf das Ergebnis, um es zwischen die Bearbeitungslinien zu setzen.

  2. Wählen Sie den Befehl Kopieren im Menü Bearbeiten. Dadurch wird das numerische Ergebnis in der angezeigten Genauigkeit in die Zwischenablage kopiert.

Nach dem Kopieren einer Matrix oder eines Vektors können Sie sie/ihn an eine andere Stelle im Arbeitsblatt oder in die meisten anderen Anwendungen kopieren.


KOPIEREN VON NUMERISCHEN ERGEBNISSEN

Zum Kopieren eines einzelnen numerischen Ergebnisses gehen Sie folgendermaßen vor:

  1. Klicken Sie auf das Ergebnis. Dadurch wird es zwischen die Bearbeitungslinien gesetzt.

  2. Wählen Sie Kopieren im Menü Bearbeiten. Dadurch wird das numerische Ergebnis mit der angezeigten Genauigkeit in die Zwischenablage kopiert.

Nach dem Kopieren eines numerischen Ergebnisses können Sie es an einer anderen Stelle im Arbeitsblatt oder in eine andere Anwendung einfügen.


KOPIEREN VON DATEN IN DIE ZWISCHENABLAGE

Wenn Sie die Ergebnisse Ihrer Berechnungen in Mathcad in eine andere Anwendung einfügen wollen, ohne sie als ganze Datei zu exportieren, können Sie die Daten in die Zwischenablage kopieren und von dort in die andere Anwendung einfügen. Gehen Sie hierzu folgendermaßen vor:

  1. Geben Sie "=" ein, um das Ergebnis einer Variable anzuzeigen.

  2. Wird das Ergebnis als Matrix angezeigt, doppelklicken Sie auf die Matrix, und stellen Sie die Anzeige mit den Optionen im Dialogfeld "Ergebnisformat" auf "Tabelle" ein.

  3. Klicken Sie mit der rechten Maustaste auf die Ausgabetabelle.

  4. Wählen Sie die Option zum Kopieren von Daten aus dem Kontextmenü.

  5. Öffnen Sie die andere Anwendung, und fügen Sie dort den Inhalt der Zwischenablage ein. (Dies geschieht normalerweise mit dem Befehl Einfügen im Menü Bearbeiten.)


Kopieren von Berechnungsergebnissen (allgemein)

KOPIEREN VON BERECHNUNGSERGEBNISSEN

Kopieren von numerischen Ergebnissen

Kopieren von Matrizen

Kopieren von Werten aus einer Ausgabetabelle mit Bildlaufleiste

Einschränkungen für das Kopieren numerischer Ergebnisse


KOPIEREN VON WERTEN AUS EINER AUSGABETABELLE

Zum Kopieren eines oder mehrerer Werte aus einer Ausgabetabelle gehen Sie wie folgt vor:

  1. Wählen Sie eine Gruppe von Werten aus.

  2. Klicken Sie mit der rechten Maustaste auf die Auswahl, und wählen Sie den Befeh zum Kopieren von Daten aus dem Kontextmenü. Dadurch wird das numerische Ergebnis mit der angezeigten Genauigkeit in die Zwischenablage kopiert.

Nachdem Sie einen oder mehrere Werte aus einer Ausgabetabelle kopiert haben, können Sie diese in Ihr Arbeitsblatt oder in die meisten anderen Anwendungen einfügen.


FUNKTION "KORR" (KORRELATION)

korr(A,B) Gibt den Pearsonschen Korrelationskoeffizienten (r) der Elemente in A und B zurück.

Argumente:

A und B sind aus m x n Elementen bestehende Felder.

Weitere Funktionen für die Datenanalyse...


FUNKTION "KVAR" (KOVARIANZ)

Argumente:

A und B sind aus m x n Elementen bestehende Felder.

Zu beachten ist, daß diese Funktion bei der Berechnung der Kovarianz durch mn und nicht durch mn-1 dividiert. Sie können die Kovarianz, die dem Nenner mn-1 entspricht, dadurch berechnen, daß Sie das Ergebnis dieser Funktion mit mn/(mn-1) multiplizieren.

Weitere Funktionen für die Datenanalyse...


ERSTELLEN EINES 3D-SÄULENDIAGRAMMS

Zum Erstellen eines 3D-Säulendiagramms gehen Sie folgendermaßen vor:

  1. Definieren Sie die Matrix der abzubildenden Elemente. Die Matrix muß aus mindestens zwei Zeilen und zwei Spalten bestehen.

  2. Wählen Sie Diagramm / 3D-Säulendiagramm im Menü Einfügen, damit ein 3D-Säulendiagrammbereich erstellt wird.

  3. Geben Sie im Platzhalter den Namen der abzubildenden Matrix ein.

  4. Klicken Sie auf eine Stelle außerhalb des Diagrammbereichs.

Mathcad zeichnet eine perspektivische Ansicht der Matrix als waagerecht gelagertes, zweidimensionales Raster im dreidimensionalen Raum. Die einzelnen Matrixelemente werden als Spalten mit einer bestimmten Höhe ober- bzw. unterhalb dieses Gitters dargestellt.

Komplexe oder imaginäre Punkte werden von Mathcad nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", von denen die reellen oder imaginären Teile herausgearbeitet werden.


ERSTELLEN EINER FARB-BMP-DATEI

RGBSCHREIBEN("datei") Schreibt ein Feld in die Datei datei. Das Feld muß aus ganzen Zahlen zwischen 0 und einschließlich 255 bestehen und 3n Spalten enthalten. Die ersten n/3 Spalten stehen für den Rotanteil des Bildes in der datei.bmp im aktuellen Verzeichnis. Die zweiten und dritten n/3 Spalten stehen für den Grün- und den Blauanteil desselben Bildes.

Argumente:

datei ist entweder der Dateiname einer BMP-Datei oder der vollständige Pfad zu einer BMP-Datei.

datei ist als Zeichenfolge einzugeben.

Verwandte Funktionen...


Erstellen eines Umrißdiagramms

ERSTELLEN EINES UMRISSDIAGRAMMS

Zum Erstellen eines Umrißdiagramms gehen Sie wie folgt vor:

  1. Definieren Sie die Matrix der abzubildenden Werte. Die Matrix muß mindestens zwei Zeilen und zwei Spalten aufweisen. Die besten Ergebnisse erzielen Sie, wenn die Zeilen und Spalten gleichmäßig voneinander entfernte Intervalle auf den Achsen repräsentieren.

  2. Wählen Sie Diagramm / Umrißdiagramm im Menü Einfügen, um einen Umrißdiagrammbereich zu erstellen.

  3. Fügen Sie den Namen der Matrix in den Platzhalter ein.

Mathcad interpoliert die Werte der Matrix linear, um auf diese Weise Niveaulinien zu bilden, die sich an keiner Stelle überschneiden. Mathcad stellt die Matrix im Diagramm dar, indem es sie so dreht, daß sich das Element (0,0) in der linken unteren Ecke befindet. Die Zeilen der Matrix entsprechen daher den Werten auf der x-Achse (nach rechts ansteigend), während die Spalten den Werten entlang der y-Achse entsprechen (nach oben ansteigend).

Komplexe oder imaginäre Punkte werden von Mathcad nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", von denen die reellen oder imaginären Teile herausgearbeitet werden.

Sie können ein Umrißdiagramm auch mit Hilfe von x-, y- und z-Datenpunkten anlegen. Zunächst erstellen Sie drei Vektoren: ein Vektor enthält die x-Werte, der zweite die y-Werte und der dritte die z-Werte. Erstellen Sie dann einen Umrißdiagramm-Bereich, und geben Sie die Namen der x-, y- und z-Vektoren in den Platzhalter ein (durch Kommas voneinander getrennt). Das daraufhin von Mathcad gezeichnete Umrißdiagramm entspricht einem 3D-Streuungsdiagramm, das in ein Umrißdiagramm umgewandelt wurde.


SCHREIBEN EINER GRAUSTUFEN-BMP-DATEI

BMPSCHREIBEN("datei") Schreibt ein Feld in die datei. Das Feld muß aus ganzen Zahlen zwischen 0 und einschließlich 255 bestehen.

Argumente:

datei ist der Pfadname für eine BMP-Datei.

datei wird als Zeichenfolge eingegeben.

Verwandte Funktionen...


ERSTELLEN EINES KREISDIAGRAMMS

Um ein Kreisdiagramm zu erstellen, gehen Sie wie folgt vor:

  1. Wählen Sie Diagramm / Kreisdiagramm im Menü Einfügen, um einen Kreisdiagrammbereich zu erstellen.

  2. Geben Sie in den Platzhalter unten in der Mitte eine Winkelvariable ein, nach der abgebildet werden soll. Geben Sie beispielsweise "A" ein, wenn Sie zuvor "A" als Bereichsvariable definiert hatten. (Definieren Sie nicht ‘A’, wenn Sie ein Quickplot erstellen möchten.)

  3. Fügen Sie in den linken Platzhalter einen abzubildenden radialen Ausdruck ein. Geben Sie beispielsweise "cos(A)" ein, wenn Sie den Kosinus der Variable A abbilden möchten.

Mathcad erstellt ein Kreisdiagramm, indem es r und q mit den folgenden Standardtransformationen x und y zuordnet:

x=r*cos( q ) und y=r*sin( q )

r und q können positive oder negative Werte sein.

Hinweise:

  • Komplexe oder imaginäre Punkte werden von Mathcad nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", von denen die reellen oder imaginären Teile herausgearbeitet werden.

  • Sie können mehrere Kreiskurven in einem Diagramm abbilden.

  • In den Mathcad-Quicksheets finden Sie Beispiele für Kreisdiagramme.


Erstellen eines dreidimensionalen Streuungsdiagramms aus 3 Datenvektoren

ERSTELLEN EINES 3D-STREUUNGSDIAGRAMMS AUS 3 DATENVEKTOREN

Zum Erstellen eines 3D-Streuungsdiagramms mit den x-, y- und z-Koordinaten aus drei Vektoren gehen Sie folgendermaßen vor:

1. Definieren Sie drei Vektoren, von denen jeder so viele Elemente aufweist, wie abzubildende Punkte vorhanden sind.

2. Wählen Sie Diagramm / 3D-Streuungsdiagramm im Menü Einfügen.

3. Geben Sie ( in den Platzhalter ein .

4. Geben Sie die Namen der Vektoren durch Kommas abgetrennt ein.

5. Geben Sie ) ein.

Komplexe oder imaginäre Punkte werden von Mathcad nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", von denen die reellen oder imaginären Teile herausgearbeitet werden.


ERSTELLEN EINES 3D-STREUUNGSDIAGRAMMS AUS EINER MATRIX VON DATENWERTEN

Zum Erstellen eines 3D-Streuungsdiagramms mit einer Matrix von Datenwerten gehen Sie folgendermaßen vor:

1. Definieren Sie die Matrix der abzubildenden Werte.

2. Wählen Sie Diagramm / 3D-Streuungsdiagramm im Menü Einfügen.

3. Geben Sie den Namen der Matrix in den Platzhalter ein.


ERSTELLEN EINES FLÄCHENDIAGRAMMS

Zum Erstellen eines Flächendiagramms gehen Sie wie folgt vor:

  1. Definieren Sie die Matrix der abzubildenden Elemente. Die Matrix muß aus mindestens zwei Zeilen und zwei Spalten bestehen.

  2. Wählen Sie Diagramm / Flächendiagramm im Menü Einfügen, damit ein Flächendiagrammbereich erstellt wird.

  3. Geben Sie den Namen der Matrix in den Platzhalter ein.

Mathcad zeichnet eine perspektivische Ansicht der Matrix als waagerecht gelagertes, zweidimensionales Raster im dreidimensionalen Raum. Jedes Matrixelement wird als Punkt mit der angegebenen Höhe über oder unter diesem Raster wiedergegeben. Komplexe oder imaginäre Punkte werden von Mathcad nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", von denen die reellen oder imaginären Teile herausgearbeitet werden.

Alternativ hierzu können Sie ein Flächendiagramm aus den Datenpunkten x, y und z erstellen. Zunächst erstellen Sie drei Vektoren: ein Vektor enthält die x-Werte, der zweite die y-Werte und der dritte die z-Werte. Erstellen Sie einen Flächendiagrammbereich, und geben Sie die Namen der Vektoren x, y und z, jeweils durch Komma getrennt, in den Platzhalter ein. Das von Mathcad generierte Flächendiagramm entspricht genau einem 3D-Streuungsdiagramm, das in ein Flächendiagramm umgewandelt wurde.


ERSTELLEN EINES VEKTORFELDDIAGRAMMS

Zum Erstellen einer grafischen Darstellung eines zweidimensionalen Vektorfelds gehen Sie wie folgt vor:

  1. Definieren Sie eine Matrix, die so viele Elemente enthält wie abzubildende Vektoren vorhanden sind.

  2. Jedes Matrixelement ist ein zweidimensionaler Vektor, der durch eine komplexe Zahl dargestellt wird. Der Realteil dieser Zahl ist die x-Komponente des Vektors. Der Imaginärteil ist die y-Komponente.

  3. Die Position eines Elements in einer Matrix richtet sich nach der Positition des entsprechenden Vektors in der xy-Ebene.

  4. Wählen Sie Diagramm / Vektorfelddiagramm im Menü Einfügen.

  5. Geben Sie den Namen der Matrix in den Platzhalter ein.

Sie können auch zwei reelle Matrizen verwenden, die über dieselbe Anzahl von Zeilen und Spalten verfügen. Die entsprechenden Elemente dieser Matrizen stellen die x- und y-Komponenten eines bestimmten Vektors dar. Sie würden dann die Namen dieser Matrizen durch Kommas abgetrennt und in Klammern in den Platzhalter einfügen.

Komplexe oder imaginäre Punkte werden von Mathcad nicht abgebildet. Verwenden Sie zum Abbilden des reellen oder komplexen Teils eines Punkts die Funktionen "Re" und "Im", von denen die reellen oder imaginären Teile herausgearbeitet werden.


Erstellen einer Matrix mit einer Funktion

ERSTELLEN VON MATRIZEN

matrix(m,n,f) Erstellt eine Matrix, in der das ij-te Element f(i,j) enthält, wobei gilt: i= 0,1..m-1 und j=0,1.. n-1.

Argumente:

m ist die Anzahl der Zeilen der Matrix.

n ist die Anzahl der Spalten der Matrix.

f ist eine Funktion von zwei Variablen.


ERSTELLEN UND BEARBEITEN VON TEXT

Einfügen von Text

Importieren von Text aus einer anderen Anwendung

Verschieben eines Textbereichs

Bearbeiten von Text

Einfügen von Rechenbereichen in Textbereiche

Erstellen eines Hyperlinks in Text


ERSTELLEN UND LADEN VON FARBZUORDNUNGEN

SpeichernFarbwerte("datei", M) Erstellt eine Farbzuordnungsdatei mit den Werten in M. Gibt die Anzahl der Zeilen in der Datei zurück.

LadeFarbwerte("datei") Gibt eine Matrix mit den Werten in der Farbzuordnungsdatei zurück.

Argumente:

"datei" ist der Name einer Farbzuordnung, die sich im Unterordner CMAPS des Mathcad-Ordners befindet.

datei wird als Zeichenfolge eingegeben.

M ist eine Matrix mit drei Spalten, deren Elemente ganze Zahlen zwischen 0 und 255 sind. Die Werte sind so angeordnet, daß sie für die Erstellung einer Farbzuordnung geeignet sind.

Beispiele:

Wenn gbmap eine 2x3-Matrix ist, gilt:

SpeichernFarbwerte("graublau", gbmap) = 2

A := LadenFarbwerte("graublau")

Hinweise:

  • Nach der Verwendung der Funktion SpeichernFarbwerte ist die Farbzuordnung auf der Registerkarte "Erweitert" im Dialogfeld "3D-Diagrammformat" verfügbar.

  • LadenFarbwerte ist dann von Nutzen, wenn Sie eine Farbzuordnung bearbeiten oder auf ihrer Grundlage eine neue Farbzuordnung erstellen möchten.

  • Werte in der Matrix M, die keine ganzen Zahlen sind, werden verkürzt.

  • Werte in der Matrix M, die nicht zwischen 0 und 255 liegen, werden auf 0 erhöht oder auf 255 verringert.


Erstellen eigener Funktionen

ERSTELLEN EIGENER FUNKTIONEN (Nur für Mathcad Professional)

Sie können die Möglichkeiten von Mathcad erweitern, indem Sie eigene Funktionen in C oder C++ schreiben. Von eigenen Funktionen können komplexe Skalare oder Felder akzeptiert und ausgegeben werden. Außerdem können eigene Funktionen beispielsweise Fehlermeldungen, Unterbrechungs- und Ausnahmeverarbeitung aufweisen.

Zur Erstellung eigener Funktionen müssen Sie zunächst mit den Strukturen und Funktionen, die von MathSoft zur Verfügung gestellt werden, Quellcode erstellen. Als nächstes kompilieren und verknüpfen Sie den Code, um eine DLL-Treiberdatei zu erzeugen.

Informationen zu den Strukturen und Funktionen, den Schritten zur Erzeugung einer DLL und weitere Einzelheiten finden Sie in der Datei Userdll.pdf auf der Mathcad CD-ROM. Überprüfen Sie auch von Zeit zu Zeit die MathSoft Web-Site (www.mathsoft.com), auf der Sie stets die aktuellsten Informationen erhalten.


Operator "Vektorprodukt"

VEKTORPRODUKT

Tastaturbefehl: Strg+8

Gibt das Vektorprodukt von u und v zurück.

Operanden:

u und v sind Spaltenvektoren mit drei Elementen.

ist ein Vektor mit den folgenden Eigenschaften:

Seine Richtung verläuft orthogonal zu u und v in der von der Rechtsregel bestimmten Richtung.

Sein absoluter Betrag ist | u || v |sin( [image]) wobei [image] den Winkel zwischen u und v angibt.


FADENKREUZ-CURSOR

Wo kann er erscheinen?

Wie kann er angezeigt werden?

Wie wird er verschoben?

Was ist seine Funktion?


Aktuelles Arbeitsverzeichnis

CWD-STANDARD = EINE VERZEICHNISZEICHENFOLGE

Diese Zeichenfolgenvariable gibt das Arbeitsverzeichnis an, mit dem Mathcad gegenwärtig arbeitet. Als Arbeitsverzeichnis gilt das Verzeichnis, in dem Dateien gespeichert werden und Mathcad nach Datendateien sucht.

Standardmäßig wird CWD als Wert das Verzeichnis zugewiesen, in dem Sie Mathcad installiert haben (also meistens c:\Programmdateien\Mathsoft\Mathcad). Um den Standardwert von CWD zu ändern, gehen Sie folgendermaßen vor:

Erstellen Sie ein Mathcad-Symbol auf dem Desktop Ihres Betriebssystems, wenn es nicht bereits vorhanden ist.

Legen Sie als Arbeitsverzeichnis bzw. "start in"-Verzeichnis das Verzeichnis fest, das Mathcad standardmäßig verwenden soll.


DIALOGFELD "SYMBOLLEISTE ANPASSEN"

Im Dialogfeld "Symbolleiste anpassen" finden Sie die folgenden Optionen und Schaltflächen:

Verfügbare Schaltflächen

Zeigt die Schaltflächen an, die der Symbolleiste hinzugefügt werden können.

Schaltflächen der Symbolleiste

Zeigt die Schaltflächen in der Symbolleiste im aktiven Fenster in der Reihenfolge ihres Erscheinens (von links nach rechts) an.

Hinzufügen

Fügt die in der Liste "Verfügbare Schaltflächen" markierte Schaltfläche in die Liste "Schaltflächen der Symbolleiste" ein. Sie können die Schaltfläche statt dessen auch direkt aus der Liste "Verfügbare Schaltflächen" auf die Liste "Schaltflächen der Symbolleiste" ziehen.

Entfernen

Verschiebt die in der Liste "Schaltflächen der Symbolleiste" markierte Schaltfläche in die Liste "Verfügbare Schaltflächen". Sie können die Schaltfläche statt dessen auch direkt aus der Liste "Schaltflächen der Symbolleiste" auf die Liste "Verfügbare Schaltflächen" ziehen.

Nach oben

Verschiebt die markierte Schaltfläche eine Zeile nach oben. Auf der Symbolleiste rückt die Schaltfläche eine Position nach links. Sie können die Schaltfläche statt dessen auch mit der Maus nach oben ziehen.

Nach unten

Verschiebt die markierte Schaltfläche eine Zeile nach unten. Auf der Symbolleiste rückt die Schaltfläche eine Position nach rechts. Sie können die Schaltfläche statt dessen auch mit der Maus nach unten ziehen.

Zurücksetzen

Stellt den ursprünglichen Zustand des Dialogfelds wieder her.


ANPASSEN VON SYMBOLLEISTEN

Sie können die Schaltflächen ändern, die in der Standardsymbolleiste und in der Formatsymbolleiste enthalten sind.

Zum Einfügen einer Schaltfläche in eine der Symbolleisten gehen Sie vor wie folgt:

  1. Klicken Sie mit der rechten Maustaste auf die Symbolleiste.

  2. Wählen Sie Anpassen... aus dem Kontextmenü. Mathcad öffnet daraufhin das Dialogfeld "Symbolleiste anpassen".

  3. Klicken Sie in der Liste "Verfügbare Schaltflächen" auf die gewünschte Schaltfläche.

  4. Klicken Sie dann entweder auf "Hinzufügen", oder ziehen Sie die Schaltfläche im Dialogfeld in den Bereich "Schaltflächen der Symbolleiste".

Zum Entfernen einer Schaltfläche aus der Symbolleiste gehen Sie vor wie folgt:

  1. Klicken Sie mit der rechten Maustaste auf die Symbolleiste.

  2. Wählen Sie Anpassen... aus dem Kontextmenü. Mathcad öffnet daraufhin das Dialogfeld "Symbolleiste anpassen".

  3. Klicken Sie in der Liste "Schaltflächen der Symbolleiste" auf die zu entfernende Schaltfläche.

  4. Klicken Sie entweder auf "Entfernen", oder ziehen Sie die Schaltfläche in den Dialogfeldbereich "Verfügbare Schaltflächen".

Zum Umordnen von Schaltflächen in einer Symbolleiste mit dem Dialogfeld "Symbolleiste anpassen" gehen Sie vor wie folgt:

  1. Klicken Sie auf eine Schaltfläche.

  2. Klicken Sie auf "Nach oben" oder "Nach unten", oder ziehen Sie die Schaltfläche nach oben oder unten.

Hinweise:

  • Zum Aus- oder Einblenden einer Symbolleiste wählen Sie den Befehl Symbolleisten aus dem Menü Ansicht.

  • Um eine Schaltfläche schnell aus einer Symbolleiste zu entfernen, halten Sie die Alt-Taste gedrückt, und ziehen Sie die Schaltfläche aus dem Mathcad-Fenster, so daß sie nicht mehr sichtbar ist.

  • Um eine Schaltfläche schnell aus einer Symbolleiste in eine andere zu verschieben, halten Sie die Alt-Taste gedrückt, und ziehen Sie sie auf eine andere Symbolleiste.

  • Um eine Symbolleiste schnell auszublenden, klicken Sie mit der rechten Maustaste auf eine angezeigte Symbolleiste, und wählen Sie dann Ausblenden aus dem Kontextmenü.


Spaltenbreite in Datendatei

PRNCOLWIDTH (STANDARD = 8)

Diese Konstante stellt die Spaltenbreite in ASCII-Dateien dar, die mit der Funktion PRNSCHREIBEN erstellt wurden.

Um sie zu ändern, wählen Sie Optionen / Registerkarte "Vordefinierte Variablen" aus dem Menü Rechnen.


DATAVALUE-OBJEKTE

Die Eigenschaft Value greift auf den Realteil eines DataValue zu. So gibt in VBScript oder JScript Inputs(0).Value den Realteil der ersten Eingabe zurück.

Die Eigenschaft IValue greift dagegen auf den Imaginärteil eines DataValue zu. So gibt in VBScript oder JScript Outputs(1).IValue den Imaginärteil der zweiten Eingabe zurück. Wenn es keinen Imaginärteil gibt, gibt IValue "NIL" zurück.

Die Eigenschaft IsComplex gibt "TRUE" zurück, wenn ein DataValue über einen gültigen Imaginärteil verfügt; andernfalls wird "FALSE" zurückgegeben. So gibt der Ausdruck (inputs(0).IsComplex) "FALSE" zurück, wenn die erste Eingabe nur einen Realteil hat.

Mit den Eigenschaften Rows und Cols können Sie sich die Anzahl der Zeilen und Spalten zurückgeben lassen.

Hinweis: Im Gegensatz zu VBScript ist in JScript bei der Angabe von Funktionen, Methoden, Objekten und Eigenschaften auf die Groß- und Kleinschreibung zu achten.


STANDARDEINSTELLUNGEN FÜR KREISDIAGRAMME

Um die Standardeinstellungen in einem Diagramm wiederherzustellen, gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie gegebenenfalls auf die Registerkarte Standardwerte.

  3. Klicken Sie auf die Schaltfläche "Standardwerte wiederherstellen".

Um die aktuellen Einstellungen zu den Standardwerten für ein bestimmtes Diagramm zu machen, gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte Standardwerte, falls erforderlich.

  3. Klicken Sie auf das Kontrollkästchen "Als Standard verwenden".

Um Standardwerte festzulegen, ohne ein Diagramm zu verwenden, gehen Sie wie folgt vor:

  1. Stellen Sie sicher, daß keine Diagramme ausgewählt sind.

  2. Wählen Sie Diagramm / Kreisdiagramm im Menü Format, um das Dialogfeld "Standardformate für Kreisdiagramme festlegen" aufzurufen.

  3. Ändern Sie die erforderlichen Einstellungen auf den Seiten Achsen und Spuren.

  4. Klicken Sie auf "OK", um die Änderungen zu bestätigen und das Dialogfeld zu schließen.


STANDARDEINSTELLUNGEN (X-Y-DIAGRAMME)

Um die Standardeinstellungen in einem Diagramm wiederherzustellen, gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie gegebenenfalls auf die Registerkarte Standardwerte.

  3. Klicken Sie auf die Schaltfläche "Standardwerte wiederherstellen".

Um die aktuellen Einstellungen zu den Standardwerten für ein bestimmtes Diagramm zu machen, gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie gegebenenfalls auf die Registerkarte Standardwerte.

  3. Klicken Sie auf das Kontrollkästchen "Als Standard verwenden".

Um Standardwerte festzulegen, ohne ein Diagramm zu verwenden, gehen Sie wie folgt vor:

  1. Stellen Sie sicher, daß keine Diagramme ausgewählt sind.

  2. Wählen Sie Diagramm / X-Y-Diagramm im Menü Format, damit das Dialogfeld mit den Registerkarten geöffnet wird.

  3. Ändern Sie gegebenenfalls Einstellungen auf den Seiten X-Y-Achsen und Spuren.

  4. Klicken Sie auf "OK", um die Änderungen zu bestätigen und das Dialogfeld zu schließen.


Definieren von Binäroperatoren

DEFINIEREN VON BINÄROPERATOREN (nur in Mathcad Professional)

Wenn ein bestimmter Operator in Mathcad nicht enthalten ist, können Sie diesen auf dieselbe Art definieren wie eine Funktion. Zum Definieren eines Binäroperators gehen Sie wie folgt vor:

Geben Sie den Namen des Operators ein.

Geben Sie "(", danach zwei durch ein Komma voneinander getrennte Operanden und schließlich ")" ein.

Geben Sie ":" ein.

Geben Sie im Platzhalter einen Ausdruck ein, der die Operanden enthält.


Definieren von einstelligen Operatoren

DEFINIEREN VON EINSTELLIGEN OPERATOREN (nur in Mathcad Professional)

Wenn ein bestimmter Operator in Mathcad nicht enthalten ist, können Sie diesen auf dieselbe Art definieren wie eine Funktion. Zum Definieren eines einstelligen Operators gehen Sie wie folgt vor:

Geben Sie den Namen des Operators ein.

Geben Sie "(" ein, dann den Operanden und wieder ")".

Geben Sie ":" ein.

Geben Sie in den Platzhalter einen Ausdruck ein, der den Operanden enthält.


DEFINIEREN EINER BEREICHSVARIABLE

Eine Bereichsvariable steht für eine Folge von Werten. Zum Definieren einer Bereichsvariable gehen Sie folgendermaßen vor:

Geben Sie den Namen der Variablen gefolgt von einem Doppelpunkt (:) ein.

Geben Sie im Platzhalter die erste Zahl aus der Folge von Werten ein.

Geben Sie ein Komma ein. (Bei der Definition von Wertefolgen, die in Einserschritten nach oben oder unten fortgesetzt werden, können Sie diesen und den nächsten Schritt überspringen.)

Geben Sie die zweite Zahl der Wertefolge ein.

Geben Sie einen Semikolon (;) ein. Er wird mit zwei Punkten dargestellt: ".."

Geben Sie im verbleibenden Platzhalter die letzte Zahl der Wertefolge ein.


GLOBALES DEFINIEREN VON VARIABLEN ODER FUNKTIONEN

Wenn Sie eine Variable oder Funktion definieren, gilt diese für alles, was sich im Arbeitsblatt rechts und unterhalb von ihr befindet. Wird die Variable oder Funktion jedoch global definiert, gilt sie für alle lokalen Definitionen ohne Rücksicht auf deren Position im Arbeitsblatt. Mit globalen Definitionen können Sie also die übliche Reihenfolge, in der Mathcad Ihr Arbeitsblatt auswertet, außer Kraft setzen.

Zum globalen Definieren einer Variable oder Funktion gehen Sie wie folgt vor:

Geben Sie einen Variablennamen oder eine Funktion ein, der/die definiert werden soll.

Geben Sie das Prioritätsgleichheitszeichen ein, indem Sie die Tilde-Taste (~) drücken.

Geben Sie einen Ausdruck mit Zahlen oder anderen global definierten Variablen oder Funktionen ein.


LÖSCHEN EINER AUSGEBLENDETEN REGION

Wenn Sie eine Region ausgeblendet haben, können Sie die Linie, die die ausgeblendete Region repräsentiert, genau wie jeden anderen Bereich löschen. Gehen Sie hierzu folgendermaßen vor:

Klicken Sie auf die Linie, die die ausgeblendete Region repräsentiert.

Drücken Sie Strg + D, oder wählen Sie den Befehl Löschen im Menü Bearbeiten.


LÖSCHEN VON GRAFIKBEREICHEN

Zum Löschen eines Grafikbereichs gehen Sie wie folgt vor:

  1. Klicken Sie auf den Grafikbereich. Daraufhin wird der Bereich von einem Markierungsrechteck mit drei Haltepunkten umgeben.

  2. Wählen Sie Ausschneiden oder Löschen im Menü Bearbeiten.

Zum Löschen mehrerer Grafikbereiche gehen Sie wie folgt vor:

  1. Halten Sie die Umschalttaste gedrückt, und klicken Sie auf alle auszuwählenden Bereiche. Sie können durch entsprechendes Ziehen mit der Maus auch mehrere Bereiche zusammen auswählen.

  2. Wählen Sie Ausschneiden oder Löschen im Menü Bearbeiten.


LÖSCHEN VON HYPERLINKS

Um einen Hyperlink zu löschen, gehen Sie folgendermaßen vor:

  1. Klicken Sie in den Bereich, der den Hyperlink enthält.

  2. Wählen Sie den Befehl "Hyperlink" aus dem Menü Einfügen.

  3. Klicken Sie im Dialogfeld "Hyperlink einfügen" auf den Befehl "Verknüpfung entfernen".

Befand sich die Verknüpfung in ausgewähltem Text, können Sie erkennen, daß der Text nicht mehr unterstrichen und fett angezeigt wird. Daraus läßt sich ersehen, daß die Verknüpfung aufgehoben worden ist.


LÖSCHEN EINER ZU SPERRENDEN REGION

Wenn Sie eine Region freigegeben haben, können Sie sie ebenso löschen wie andere Bereiche. Gehen Sie hierzu folgendermaßen vor:

Wählen Sie eine Regionsgrenze aus.

Wählen Sie den Befehl Ausschneiden aus dem Menü Bearbeiten.


LÖSCHEN EINES OPERATORS

Zum Löschen eines Operators gehen Sie folgendermaßen vor:

  1. Setzen Sie die Einfügelinie rechts neben den Operator, der gelöscht werden soll.

  2. Drücken Sie die Rücktaste.

Bei komplizierteren Ausdrücken wird hierdurch der zu löschende Operator durch eine stellvertretende Multiplikation ersetzt.


Definieren einer zu sperrenden oder auszublendenden Region

DEFINIEREN EINER ZU SPERRENDEN ODER AUSZUBLENDENDEN REGION (nur Mathcad Professional)

Zum Definieren einer zu sperrenden oder auszublendenden Region gehen Sie folgendermaßen vor:

1. Klicken Sie auf eine leere Stelle in der Nähe der Region, die gesperrt werden soll. Es erscheint ein Fadenkreuz.

2. Wählen Sie den Befehl Region aus dem Menü Einfügen. Mathcad fügt zwei Regionsbegrenzungslinien ein:

3. Markieren Sie diese Begrenzungslinien, und ziehen Sie sie gegebenenfalls mit der Maus, um ihre Größe anzupassen.

4. Erstellen Sie zwischen den Grenzen die zu sperrenden Bereiche, oder verschieben Sie Bereiche von anderen Positionen im Arbeitsblatt zwischen die Begrenzungslinien.

Nach dem Einfügen einer Region können Sie sie sperren und/oder ausblenden, so daß die enthaltenen Bereiche ausgeblendet werden.

Hinweise:

  • Das Arbeitsblatt kann beliebig viele Regionen enthalten; Sie können jedoch die Regionen nicht ineinander verschachteln.

  • Sie können das Erscheinungsbild der Regionsbegrenzungslinien ändern.


Operator "Determinante"

DETERMINANTE

Tastaturbefehl: |

| M |

Gibt die Determinante einer quadratischen Matrix zurück.

Operanden:

M ist eine quadratische Matrix.

Um den Betrag jedes Elements in einer Matrix zu ermitteln, gehen Sie wie folgt vor:

Setzen Sie | M | zwischen die Bearbeitungslinien.

Wenden Sie den Operator "Vektorisieren" (Strg+-) an.

Statt der numerischen Bestimmung von Determinanten können Sie die Determinanten auch symbolisch suchen.


Diagonalmatrix-Funktion

DIAGONALMATRIX-FUNKTION (nur in Mathcad Professional)

diag(v) Gibt eine Diagonalmatrix zurück, die auf ihrer Diagonalen die Elemente von v enthält.

Argumente:

v muß ein Vektor sein.


EIGENSCHAFTEN DER KOMPONENTE "EXCEL": REGISTERKARTE "Eingaben"

Mit Hilfe der Registerkarte "Eingaben" im Dialogfeld für Excel-Eigenschaften können Sie angeben, in welchen Zellen in der Komponente "Excel" die einzelnen Eingabedaten gespeichert werden sollen. Handelt es sich bei der Eingabe um einen einzelnen Wert, geben Sie die Zelle an, in der der Wert gespeichert werden soll. Besteht die Eingabe aus mehreren Werten, ist die Anfangszelle für die Werte einzugeben.

Die Anfangszelle ist die sich am weitesten links und am weitesten oben befindende Zelle, in der Datenwerte gespeichert sind. So würden die Daten bei einer Matrix von 10x10 als Eingabe und einer Anfangszelle C2 in den Bereich C2:L11 eingefügt werden.


EIGENSCHAFTEN DER KOMPONENTE "EXCEL": REGISTERKARTE "Ausgaben"

Mit Hilfe der Registerkarte "Ausgaben" im Dialogfeld für Excel-Eigenschaften können Sie angeben, aus welchen Zellen in der Komponente "Excel" die einzelnen Ausgabedaten abgerufen werden sollen. Beispiel: Wenn als erste Ausgabe die Werte in den Zellen A1, A2, B1 und B2 verwendet werden sollen, ist für "Ausgabe 1" "A1:B2" anzugeben.


Eigenschaften der Komponente "Datei lesen/schreiben": Registerkarte "Optionen"

EIGENSCHAFTEN DER KOMPONENTE "DATEIEN LESEN/SCHREIBEN": REGISTERKARTE "OPTIONEN"

Mit Hilfe der Registerkarte "Dateioptionen" des Dialogfelds "Eigenschaften" der Komponente "Dateien lesen" bzw. "Dateien schreiben" können Sie festlegen, daß nur bestimmte Zeilen oder Spalten einer Datendatei eingelesen werden:

  1. Geben Sie in das Feld neben Beginn bei Zeile die Nummer der Zeile ein, die den ersten einzulesenden Wert enthält.

  2. Geben Sie in das Feld neben Beginn bei Spalte die Nummer der Spalte ein, die den ersten einzulesenden Wert enthält.

2. Standardmäßig ist sowohl für die Zeilen als auch für die Spalten die Option Stop bei Datenende aktiviert. Auf diese Weise liest die Komponente "Datei lesen/schreiben" alle Werte vom Anfangswert bis zum Ende der Datei ein. Sie können aber die Option Stop bei Datenende auch durch Klicken deaktivieren und durch Eingabe eines Wertes in das Feld Stop bei Zeile oder/und Stop bei Spalte ein anderes Ende festlegen.


Eigenschaften der Komponente "MATLAB": Registerkarte "Eingaben"

EIGENSCHAFTEN DER KOMPONENTE "MATLAB": REGISTERKARTE "EINGABEVARIABLEN"

Mit Hilfe der Registerkarte "Eingabevariablen" des Dialogfelds für MATLAB-Eigenschaften können Sie Namen für die Eingabevariablen für die Komponente "MATLAB" festlegen.


EIGENSCHAFTEN DER KOMPONENTE "MATLAB": REGISTERKARTE "AUSGABEVARIABLEN"

Mit Hilfe der Registerkarte "Ausgabevariablen" des Dialogfelds für MATLAB-Eigenschaften können Sie Namen für die Ausgabevariablen für die Komponente "MATLAB" festlegen.


DIALOGFELD "ABSATZFORMAT"

Das Dialogfeld "Absatzformat" enthält die folgenden Elemente:

Einzug – Links, Rechts

Ermöglicht die Festlegung, um wieviel der Absatz vom linken bzw. rechten Rand des Textbereichs aus eingerückt werden soll (auf der Basis der im Betriebssystem festgelegten Einheit).

Extra

Ermöglicht spezielle Formen des Einrückens.

  • Wählen Sie Erste Zeile, um nur die erste Zeile des markierten Absatzes einzurücken. Um wieviel eingerückt werden soll, können Sie im Feld "um:" festlegen.

  • Wählen Sie Hängend, wenn alle Zeilen außer der ersten eingerückt werden sollen. Um wieviel eingerückt werden soll, können Sie im Feld "um:" festlegen.

um

Mit Hilfe dieses Feldes können Sie bei Absätzen, für die im Feld "Extra" die Option "Erste Zeile" oder "Hängend" gewählt wurde, festlegen, um wieviel der Absatz vom linken Rand des Textbereichs aus eingerückt werden soll (auf der Basis der im Betriebssystem festgelegten Einheit).

Aufzählungszeichen

Hier finden Sie eine Liste der Symbole, die den markierten Absätzen vorangestellt werden können.

  • Wählen Sie Aufzählungszeichen, wenn runde, schwarze Punkte verwendet werden sollen.

  • Wählen Sie Numerierung, wenn die Absätze durchnumeriert werden sollen (1, 2, 3 usw.).

Ausrichtung – Links, Rechts, Zentriert

Ermöglicht die Festlegung, ob der Text in den markierten Absätzen innerhalb des Textbereichs linksbündig, rechtsbündig oder zentriert dargestellt werden soll.


Dialogfeld "Eigenschaften": Registerkarte "Region"

DIALOGFELD "EIGENSCHAFTEN" (nur in Mathcad Professional)

Auf der Registerkarte "Region" des Dialogfelds "Eigenschaften" finden Sie die folgenden Optionen und Schaltflächen:

Regionsname

Geben Sie einen Namen für die Region ein. Dieser wird dann auf der Begrenzungslinie der Region angezeigt.

Rahmen

Wenn diese Option aktiviert ist, wird die Begrenzung der Region durch eine Linie dargestellt.

Symbol

Wenn diese Option aktiviert ist, erscheint links neben der Begrenzung der Region ein Symbol.

Name

Wenn diese Option aktiviert ist, erscheint der Name, den Sie im Textfeld "Region" festgelegt haben, auf der Begrenzungslinie der Region.

Zeitmarkierung (wenn Region gesperrt ist)

Wenn diese Option aktiviert ist, wird auf der Begrenzung der Region das Datum und die Uhrzeit der Sperrung angezeigt.


Dialogfeld "Eigenschaften": Registerkarte "Text"

DIALOGFELD "EIGENSCHAFTEN"

Auf der Registerkarte "Text" des Dialogfelds "Eigenschaften" finden Sie die folgenden Optionen und Schaltflächen:

Seitenbreite verwenden

Mit dieser Option legen Sie fest, daß ein Textbereich die gesamte Seitenbreite einnehmen soll.

Bereiche bei Eingabe nach unten verschieben

Mit dieser Option legen Sie fest, daß dann, wenn ein Textbereich so groß wird, daß er andere zu überlappen droht, diese nach unten verschoben werden.


Eigenschaften der Komponente "S-PLUS": Registerkarte "Graphtyp"

EIGENSCHAFTEN DER KOMPONENTEN "S-PLUS": REGISTERKARTE "GRAPHTYP"

Mit Hilfe der Optionen auf der Registerkarte "Graphtyp" können Sie festlegen, welche Art von Graph mit der Komponente "S-PLUS Graph" erstellt wird. Folgende Optionen stehen zur Auswahl: Liniendiagramm , GUI-Diagramm und das herkömmliche S-PLUS-Diagramm auf der Basis von Befehlen (Graphskript).


EIGENSCHAFTEN DER KOMPONENTE "S-PLUS": REGISTERKARTE "EINGABEVARIABLEN"

Mit Hilfe der Registerkarte "Eingabevariablen" des Dialogfelds für S-PLUS-Eigenschaften können Sie Namen für die Eingabevariablen für die Komponente "S-PLUS-Graph" oder die Komponente "S-PLUS-Skript" festlegen.


EIGENSCHAFTEN DER KOMPONENTE "S-PLUS": REGISTERKARTE "AUSGABEVARIABLEN"

Mit Hilfe der Registerkarte "Ausgabevariablen" des Dialogfelds für S-PLUS-Eigenschaften können Sie Namen für die Ausgabevariablen für die Komponente "S-PLUS-Graph" oder die Komponente "S-PLUS-Skript" festlegen.


DIFFERENZENGLEICHUNGEN

Sie können Bereichsvariablen in Verbindung mit Feldern verwenden, um eine Differenzengleichung auszuwerten. Das folgende Beispiel zeigt, wie ein Feld mit Fibonacci-Zahlen ausgefüllt wird.

Aufrufen eines QuickSheet-Beispiels


LÖSUNGSALGORITHMEN FÜR DIFFERENTIALGLEICHUNGEN

Mathcad enthält eine Reihe von Funktionen zum numerischen Lösen von Teildifferentialgleichungen.

Lösen von gewöhnlichen Differentialgleichungen

rkfest(y,x1,x2,npunkte,D)

Stetige Systeme

Bulstoer(y,x1,x2,npunkte,D)

Steife Systeme

Stiffb(y,x1,x2,npunkte,D,J)

Stiffr(y,x1,x2,npunkte,D,J)

Sich langsam ändernde Systeme

Rkadapt(y,x1,x2,npunkte,D)

Bestimmen des letzten Punktes im Integrationsintervall

bulstoer(y,x1,x2,gen,D,kmax,abst)

rkadapt(y,x1,x2,gen,D,kmax,abst)

stiff(y,x1,x2,gen,D,J,kmax,abst)

stiff(y,x1,x2,gen,D,J,kmax,abst)

Lösen von Zweipunktrandwertproblemen

grwanp(v1,v2,x1,x2,xf,D,lad1,lad2,entspr)

sgrw(v,x1,x2,D,lad1,lad2,entspr)

Lösen von partiellen Differentialgleichungen

relax(a,b,c,d,e,f,u,rjac)

multigit(M,nzyklus)


DIFFERENTIALGLEICHUNGEN MIT BESONDEREN EIGENSCHAFTEN

Folgen Sie dem Beispiel für die Verwendung von rkfest für eine oder mehrere Differentialgleichungen, aber verwenden Sie an Stelle von rkfest eine der folgenden Funktionen:

Bulstoer für stetige Systeme

Stiffb oder Stiffr für steife Systeme

Rkadapt für sich langsam ändernde Systeme


Operator "Differentiation"

ABLEITUNG

Tastaturbefehl: ?

Gibt die Ableitung von f(t) am Punkt t zurück.

Operanden:

f(t) ist eine skalarbewertete Funktion.

t ist der Punkt, an dem die Ableitung ausgewertet werden soll.

Zunächst muß festgelegt werden, an welchem Punkt die Ableitung ausgewertet werden soll. Beispiel:

Hinweise:

  • Im Beispiel ist das Ergebnis die Ableitung von f mit Bezug auf t bei Auswertung an dem oder den Punkten, an denen t zuvor definiert wurde.

  • Das Beispiel zeigt zwar eine Funktion nur einer Variablen, f kann aber eine Funktion jeder beliebigen Anzahl von Variablen sein.

  • Wenn f mehrere Terme hat, müssen diese in Klammern angegeben werden, damit sie innerhalb des Ableitungsoperators bleiben.

  • Beim Ableitungsalgorithmus von Mathcad kann davon ausgegangen werden, daß die erste Ableitung innerhalb von 7 oder 8 signifikanten Ziffern genau ist, vorausgesetzt, daß der Wert, an dem die Ableitung ausgewertet wird, sich nicht zu sehr in der Nähe einer Singularität der Funktion befindet.


Gestreutes Licht

Gestreutes Licht kommt aus einer bestimmten Richtung, aber es wird von einer Fläche gleichmäßig in unterschiedliche Richtungen gespiegelt. Durch gestreutes Licht wird ein Objekt hell dargestellt. Leuchtstofflampen sind hierfür ein gutes Beispiel.

Umgebungslicht und gestreutes Licht hat die größte Wirkung bei der Bestimmung der Farbe eines Diagramms.


DIMENSIONEN VON MATRIZEN

zeilen(A) Gibt die Anzahl der Zeilen in A zurück.

spalten(A) Gibt die Anzahl der Spalten in A zurück.

Argumente:

A kann ein Vektor oder eine Matrix sein.

Wenn A weder ein Vektor noch eine Matrix ist, geben sowohl zeilen als auch spalten 0 zurück.


GERICHTETES LICHT

Ein gerichtetes Licht geht von einer Quelle aus und leuchtet in einer bestimmten Richtung. Man kann sich gerichtetes Licht wie einen Scheinwerfer vorstellen, der von einer festen Position aus das Diagramm anleuchtet. Ein gerichtetes Licht besteht aus gestreutem Licht und Glanzlicht.


Deaktivieren von Gleichungen

AKTIVIEREN BZW. DEAKTIVIEREN VON GLEICHUNGEN

Um zu verhindern, daß ein Bereich, zum Beispiel eine Gleichung oder ein Diagramm, berechnet wird, gehen Sie folgendermaßen vor:

  1. Klicken Sie in die Gleichung.

  2. Wählen Sie Eigenschaften aus dem Menü Format, und klicken Sie auf die Registerkarte "Berechnung".

  3. Klicken Sie auf das Kontrollkästchen "Auswertung deaktivieren".

  4. Klicken Sie auf “OK”.

Durch ein kleines Feld neben der Gleichung wird angezeigt, daß sie ausgeschaltet (deaktiviert) ist. Sie aktivieren die Gleichung wieder, indem Sie die Schritte erneut durchführen.

Hinweise:

  • Sie können eine deaktivierte Gleichung ebenso bearbeiten wie andere Gleichungen. Eine deaktivierte Gleichung wirkt sich jedoch nicht auf andere Berechnungen aus, und in ihr werden auch keine Änderungen berücksichtigt, die Sie an anderen Gleichungen im Arbeitsblatt vornehmen.

  • Wenn Sie eine deaktivierte Gleichung verschieben, die ein Ergebnis zeigt, wird das Ergebnis aus der Anzeige gelöscht. Wenn Sie ein deaktiviertes Diagramm verschieben, wird der Inhalt des Diagramms aus der Anzeige gelöscht.


UNSTETIGE ODER BEDINGTE FUNKTIONEN

wenn(cond, wwert, fwert)

Gibt wwert zurück, wenn cond zutrifft, sonst wird fwert ausgegeben.

(m, n)

Kroneckersche Deltafunktion. Gibt 1 zurück, wenn m=n, andernfalls 0.

sign(x)

Vorzeichen einer Zahl. Gibt 0 zurück, wenn x=0. Ist x>0, wird 1 zurückgegeben, andernfalls -1.

(i,j,k)

Vollständig antisymmetrische Tensor-Funktion.

(x)

Heaviside-Sprungfunktion. Gibt 0 zurück, wenn x<0, andernfalls 1.


DISKRETE TRANSFORMATIONEN

fft(v)

Fourier-Transformation reeller Daten in Vektor v.

ifft(u)

Umkehrung von fft. Gibt v aus, wenn u=fft(v).

cfft(A)

Fourier-Transformation reeller oder komplexer Daten im Feld A.

icfft(B)

Umkehrung von cfft. Gibt A aus, wenn B=csft(A).

FFT(v)

Identisch mit fft(v), aber mit anderem Normalisierungsfaktor und anderer Zeichenkonvention.

CFFT(A)

Identisch mit cfft(v), aber mit anderem Normalisierungsfaktor und anderer Zeichenkonvention.

IFFT(u)

Identisch mit ifft(v), aber mit anderem Normalisierungsfaktor und anderer Zeichenkonvention.

ICFFT(B)

Identisch mit icfft(v), aber mit anderem Normalisierungsfaktor und anderer Zeichenkonvention.

wave(v)

Diskrete Wavelet-Transformation reeller Daten im Vektor v.

iwave(u)

Umkehrung von "wave". Gibt v aus, wenn u=wave(v).


ANZEIGEOPTIONEN FÜR EIN 3D-DIAGRAMM

Wenn Sie ein 3D-Diagramm erstellen, können Sie es als 3D-Diagramm eines anderen Typs anzeigen lassen, ohne das Diagramm neu zu erstellen. Gehen Sie hierzu folgendermaßen vor:

  1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

  2. Klicken Sie auf die Registerkarte "Allgemein", damit die Seite "Allgemein" geöffnet wird.

  3. Mit den Optionen im Abschnitt Darstellungsart können Sie beliebige 3D-Diagramme (außer parametrischen Flächendiagrammen und Vektorfelddiagrammen) in andere 3D-Diagrammtypen umwandeln.

  4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", damit das Dialogfeld ausgeblendet wird.

Ein Beispiel für die Darstellung eines Flächendiagramms mit unterschiedlichen Anzeigeoptionen finden Sie in den Mathcad-Quicksheets.


Anzeigen von verschachtelten Feldern

ANZEIGEN VON VERSCHACHTELTEN FELDERN (nur in Mathcad Professional)

Wenn Sie ein verschachteltes Feld mit Hilfe des Gleichheitszeichen anzeigen lassen, werden nicht alle Elemente in allen verschachtelten Feldern dargestellt. Eine solche Darstellung kann recht hinderlich sein, vor allem, wenn man bedenkt, daß ein Feld innerhalb eines Feldes selbst weitere Felder enthalten kann.

Statt dessen wird folgendes angezeigt:

  • eine Zahl, wenn es sich bei dem Feldelement um einen Skalar handelt.

  • ein geordnetes Paar "{m,n}", wenn es sich bei dem Feldelement um ein m x n Elemente großes Feld handelt.

Dies wird im folgenden Beispiel veranschaulicht:

Im Beispiel oben wird das Feld in Form einer Matrix angezeigt. Das vollständige Feld, das durch die Notation repräsentiert wird, können Sie sich anzeigen lassen, wenn Sie auf das Feld doppelklicken, um das Dialogfeld "Ergebnisformat" zu öffnen. Klicken Sie dort auf das Feld neben "Verschachtelte Matrizen erweitern".

Wenn Sie statt dessen das Feld in einer Ausgabetabelle anzeigen lassen, sehen Sie dieselbe Notation in einer Zelle der Tabelle. Soll das durch die Notation repräsentierte Feld vorübergehend in einer Zelle einer Ausgabetabelle angezeigt werden, doppelklicken Sie auf die Zelle, die die Notation enthält. Beispiel:


ANZEIGE SYMBOLISCHER ERGEBNISSE

Symbolisches Anzeigeformat

Große Antworten

Numerische Ergebnisse symbolischer Berechnungen

Spezielle Funktionen

Fehlermeldungen bei symbolischen Berechnungen


ANZEIGEN DES BILDES

Hierzu haben Sie zwei Möglichkeiten. Welche Möglichkeit Sie wählen, hängt davon ab, ob Sie das Bild mit der Funktion BMPLESEN oder RGBLESEN in eine Matrix einlesen:

Wenn Sie zum Erstellen der Bildmatrix die Funktion BMPLESEN verwendet haben...

Wenn Sie zum Erstellen der Bildmatrix RGBLESEN verwendet haben...


Operator "Division"

DIVISION

Tastaturbefehl: /

Gibt y geteilt durch x zurück. Wenn x=0, wird eine Fehlermeldung angezeigt, die darauf hinweist, daß eine Singularität vorliegt. Wenn es sich bei y um ein Feld handelt, teilt der Divisionsoperator jedes Element des Feldes durch x.

Operanden:

x und y sind Skalare.

x kann nicht 0 sein.

Beachten Sie, daß die unbestimmte Form 0/0 stets 0 ergibt.


ZIEHEN DER MAUS

Um die Maus zu ziehen, gehen Sie wie folgt vor:

  1. Drücken Sie die Maustaste, und halten Sie sie gedrückt.

  2. Verschieben Sie die Maus bei gedrückter Maustaste.


e (Basis des natürlichen Logarithmus)

BASIS DES NATÜRLICHEN LOGARITHMUS

Tastaturbefehl: e

Beschreibung: In numerischen Berechnungen der Wert von e auf 15 Dezimalstellen genau.

Der genaue Wert von e in symbolischen Berechnungen.


MENÜ "BEARBEITEN"

Rückgängig

Wiederholen

Ausschneiden

Kopieren

Einfügen

Inhalte einfügen...

Löschen

Alles markieren

Suchen

Ersetzen...

Gehe zu Seite...

Rechtschreibung...

Verknüpfungen...

Objekt


Bearbeiten eines Ausdrucks (allgemein)

BEARBEITEN EINES AUSDRUCKS

Beim Bearbeiten eines Ausdrucks werden zwei Schritte durchgeführt:

Setzen des rechten Teils des Ausdrucks zwischen die Bearbeitungslinien.

Drücken der korrekten Taste.

Die Funktionen der einzelnen Tasten richten sich danach, was sich zwischen den Bearbeitungslinien befindet. Klicken Sie unten auf den entsprechenden Ausdruck, um Beschreibungen der Funktionen der am häufigsten verwendeten Tastenkombinationen anzuzeigen, wenn sich die Bearbeitungslinien an der gezeigten Position befinden.


Bearbeitungslinien

BEARBBEITUNGSLINIEN

Wo können sie angezeigt werden?

Wie werden sie angezeigt?

Wie werden sie verschoben?

Was ist ihre Funktion?


BEARBEITEN VON VERKNÜPFUNGEN

Wenn Sie ein Objekt mit Objekt einfügen oder Inhalte einfügen mit einem Arbeitsblatt verknüpft haben, können Sie die Verknüpfung aktualisieren, verändern oder entfernen. Gehen Sie hierzu folgendermaßen vor:

Wählen Sie Verknüpfungen aus dem Menü Bearbeiten. Daraufhin wird das Dialogfeld "Verknüpfungen" geöffnet.


Bearbeiten der Komponenten "S-PLUS-Skript"

BEARBEITEN DER KOMPONENTE "S-PLUS-SKRIPT"

Zum Eingeben bzw. Bearbeiten des S-PLUS-Code in die/der Komponente "S-PLUS-Skript" ist wie folgt vorzugehen:

  1. Öffnen Sie den Skripteditor, indem Sie mit der rechten Maustaste auf die Komponente klicken und im Kontextmenü der Komponente den Befehl Skript bearbeiten wählen.

  2. Bearbeiten Sie das Skript.

  3. Wählen Sie den Befehl Schließen und Zurückkehren im Menü Datei des Skripteditors.

Das Skript wird ausgeführt, sobald Sie auf eine Stelle außerhalb der Komponente klicken. Wenn die Syntax eines S-PLUS-Programms nicht analysiert werden kann (weil der Text z. B. eine ungerade Zahl von Klammern enthält), oder wenn bei der Ausführung des Programms ein Fehler auftritt, erscheint ein Popup-Fenster.

Anmerkungen zum S-PLUS-Code für das Skript

Ihr S-PLUS-Code, der mehrere Anweisungen enthalten kann, wird in eine automatisch erstellte Funktion eingefügt, um die Komponente auszuführen. In diesem Code können temporäre Variablen verwendet werden; solche temporären Variablen sind jedoch außerhalb der Komponente nicht sichtbar (es sei denn, assign wird aufgerufen, um die S-PLUS-Datenbanken zu ändern). So könnte ein Skript z. B. out0 <- sin(in0) enthalten, um festzulegen, daß der Sinus der Eingabe ausgegeben werden soll.

Innerhalb eines Skripts kann auf die folgenden Variablen zugegriffen werden:

  • input.var.names und output.var.names sind Vektoren von Zeichenfolgen, die die Namen der Ein- und Ausgabevariablen für die Komponente angeben. Sie können diese Variablen in Skripts verwenden, bei denen sich die Zahl der Eingaben von der der Ausgaben unterscheidet.

  • first.call hat den Wert T, wenn das jeweilige Skript zum ersten Mal ausgeführt wird.

Mit Hilfe dieser Variable können statische Variablen initialisiert werden.

Wenn im Kontextmenü der Komponente die Option "Erfaßte Ergebnisse anzeigen" markiert ist, zeigt die Komponente den Text an, der bei der letzten Ausführung des S-PLUS-Programms erstellt wurde, einschließlich aller Druckvorgänge des Skripts, als wäre es von der S-PLUS-Befehlszeile aus gestartet worden. Die Erfassung dieses Textes kann dazu führen, daß das Skript langsamer ausgeführt wird. Fehlermeldungen werden jedoch in jedem Fall erfaßt, so daß nach dem Auftreten eines Fehlers auf die Anzeige der Fehlermeldung umgestellt werden kann.


SUCHEN NACH EIGENWERTEN

eigenwerte(M) Gibt einen Vektor zurück, dessen Elemente die Eigenwerte von M sind.

Argumente:

M muß eine quadratische Matrix sein.

z sollte ein Eigenwert von M sein.

z kann komplex sein.

Verwandte Themen

Suchen nach einem einzelnen Eigenvektor

Suchen nach mehreren Eigenvektoren

Suchen nach generalisierten Eigenwerten und Eigenvektoren


EIGENWERTE UND EIGENVEKTOREN

eigenvek(M,z)

Gibt einen Eigenvektor zurück, der mit dem Eigenwert z der Matrix M verbunden ist.

eigenwerte(M)

Gibt die Eigenwerte von M zurück.

eigenvektoren(M)

Ermittelt normalisierte Eigenvektoren, die den Eigenwerten der Matrix M entsprechen.

genwerte(M,N)

Ermittelt generalisierte Eigenwerte.

genvektoren(M)

Ermittelt generalisierte Eigenvektoren.


SUCHEN NACH EINEM EINZELNEN EIGENVEKTOR

eigenvek(M,z) Gibt einen Eigenvektor aus, der mit dem Eigenwert z der Matrix M verbunden ist. Der Eigenvektor ist entsprechend der Einheitenlänge normalisiert.

Argumente:

M muß eine quadratische Matrix sein.

z sollte ein Eigenwert von M sein.

z kann komplex sein.

Verwandte Themen

Suchen nach mehreren Eigenvektoren

Suchen nach Eigenwerten

Suchen nach generalisierten Eigenwerten und Eigenvektoren


Suchen nach allen Eigenvektoren einer Matrix

SUCHEN NACH ALLEN EIGENVEKTOREN EINER MATRIX (nur in Mathcad Professional)

eigenvektoren(M) Gibt eine Matrix aus, in der die normalisierten Eigenvektoren enthalten sind, die den Eigenwerten der Matrix M entsprechen. Die n-te Spalte der ausgegebenen Matrix ist ein Eigenvektor, der mit dem n-ten Eigenwert übereinstimmt, der von eigenwerte zurückgegeben wird.

Argumente:

M muß eine quadratische Matrix sein.

z muß ein Eigenwert von M sein

z kann komplex sein.

Verwandte Themen:

Suchen nach einem einzelnen Eigenvektor

Suchen nach Eigenwerten

Suchen nach generalisierten Eigenwerten und Eigenvektoren


EINGEBEN VON BINÄREN ZAHLEN

Zum Eingeben einer binären Zahl gehen Sie wie folgt vor:

  1. Geben Sie die Ziffern für die Zahl ein. Gültig sind die Ziffern 0 und 1.

  2. Geben Sie direkt hinter der letzten Ziffer in der Zahl den Buchstaben "b" (oder "B") ein.

Beispiel:

    1101b

Hinweis: Wegen der angedeuteten Multiplikation fügt Mathcad zwischen der letzten Ziffer und dem "b" möglicherweise ein kurzes Leerzeichen ein. Sie müssen dieses Leerzeichen löschen, indem Sie die Einfügemarke rechts von ihm positionieren und die Rücktaste drücken.


EINGEBEN VON KOMPLEXEN ZAHLEN

Zum Eingeben einer komplexen Zahl gehen Sie wie folgt vor:

  1. Geben Sie den reellen Teil ein.

  2. Geben Sie "+" (oder "-") ein.

  3. Geben Sie den Imaginärteil ein.

  4. Geben Sie i oder j ein. Zwischen dem Imaginärteil und dem i bzw. j darf es keine Leerstelle geben.

Beispiel:

1 + 2i 1 - 33.4j

3 + 1i 2 - 1j

Bei der Arbeit mit komplexen Zahlen sind oft die speziellen Funktionen und Operatoren von Mathcad zu empfehlen.


EINGEBEN VON HEXADEZIMALEN ZAHLEN

Zum Eingeben einer hexadezimalen Zahl gehen Sie wie folgt vor:

  1. Wenn es sich bei der ersten Ziffer der Zahl um einen der Buchstaben a bis f handelt, müssen Sie vor der Zahl eine "0" eingeben. Wenn Sie dies versäumen, wird das von Ihnen Eingegebene als Variable und nicht als Zahl interpretiert.

  2. Geben Sie die Ziffern für die Zahl ein. Sie können dazu die Zahlen 0 bis 9 und die Buchstaben a bis f verwenden.

  3. Geben Sie den Buchstaben "h" (oder "H") direkt hinter der letzten Ziffer in der Zahl ein.

Beispiel:

  1. 2b3ch

  2. 0a32H

Hinweis: Wegen der angedeuteten Multiplikation fügt Mathcad möglicherweise ein kurzes Leerzeichen zwischen der letzten Ziffer und dem "o" ein. Sie müssen dieses Leerzeichen löschen, indem Sie die Einfügemarke rechts davon positionieren und die Rücktaste drücken.


EINGEBEN VON IMAGINÄREN ZAHLEN

Um eine Zahl imaginär zu machen, muß ihr unmittelbar ein i oder j nachfolgen. Beispiel:

i -33.4j

1i

1j

Wenn Sie entweder i oder j separat eingeben, wird es als Variablenname und nicht als die imaginäre Einheit angesehen. Um die imaginären Zahlen i und j in Ihr Dokument einzufügen, müssen Sie "1i" bzw. "1j" eingeben. Die Ziffer "1" wird nicht mehr angezeigt, wenn Sie auf eine Stelle außerhalb der Zahl klicken.

Sie können zwar imaginäre Zahlen eingeben, auf die entweder i oder j folgt, aber Mathcad zeigt hinter diesen Zahlen normalerweise i an. Sie können festlegen, daß Mathcad imaginäre Zahlen mit j anzeigt, wenn Sie durch Wählen von Ergebnis im Menü Format das Dialogfeld Ergebnisformat aufrufen.


EINGEBEN VON ZAHLEN > 999

Beim Eingeben von Zahlen größer als 999 dürfen keine Trennungspunkte, Kommas oder Leerzeichen zwischen den einzelnen Hundertern, Tausendern usw. verwendet werden. Geben Sie die Ziffern einfach hintereinander ein.

Für Zehntausend ist die Eingabe beispielsweise "10000". Geben Sie nicht "10,000" oder "10.000" ein.

Kommas werden nur im Zusammenhang mit Bereichsvariablen und zur Eingabe von Indizes für Felder verwendet. Der Punkt darf nur als Dezimalkomma oder für die Eingabe von Literalindizes Verwendung finden.


EINGEBEN VON ZAHLEN IN WISSENSCHAFTLICHER SCHREIBWEISE

Zum Eingeben einer Zahl in wissenschaftlicher Schreibweise gehen Sie wie folgt vor:

  1. Geben Sie die Zahl ein, die zu einer Potenz von 10 erhoben werden soll.

  2. Geben Sie "*10^" ein.

  3. Geben Sie im leeren Platzhalter die korrekte Potenz von 10 ein.


EINGEBEN VON ZAHLEN MIT ANDEREN BASEN

Sie können Zahlen in binärer, oktaler oder hexadezimaler anstelle von dezimaler Form eingeben. Informationen dazu, wie Sie nichtdezimale Zahlen eingeben können, erhalten Sie, wenn Sie auf das entsprechende Thema klicken:

Eingeben von binären Zahlen

Eingeben von hexadezimalen Zahlen

Eingeben von oktalen Zahlen


EINGEBEN VON OKTALEN ZAHLEN

Zum Eingeben einer oktalen Zahl gehen Sie wie folgt vor:

  1. Geben Sie die Ziffern für die Zahl ein, die reell sein muß. Sie können dazu die Ziffern 0 bis 7 verwenden.

  2. Geben Sie den Buchstaben "o" (oder "O") direkt hinter der letzten Ziffer in der Zahl ein.

Beispiel:

    32o

Hinweis: Wegen der angedeuteten Multiplikation fügt Mathcad möglicherweise ein kurzes Leerzeichen zwischen der letzten Ziffer und dem "o" ein. Sie müssen dieses Leerzeichen löschen, indem Sie die Einfügemarke rechts davon positionieren und die Rücktaste drücken.


Gleichheitszeichen für die Definition (:=)

Eingabe...

Funktion...

Beschränkungen links von ":="...

Beschränkungen rechts von ":="...


Gleichheitszeichen für die Auswertung (=)

Eingabe...

Funktion...

Beschränkungen links von "="...

Beschränkungen rechts von "="...


Operator "Gleich"

GLEICH

Tastaturbefehl: Strg+=

x [image] y

Gibt 1 zurück, wenn x = y, andernfalls 0.

Operanden:

x und y können reelle oder komplexe Skalare bzw. Felder sein.


GLEICHHEITSZEICHEN

Es gibt zwei grundsätzlich unterschiedliche Arten von Gleichheitszeichen. Es gelten folgende Beschränkungen:

Das Auswertungsgleichheitszeichen

Das Zuweisungsgleichheitszeichen

Beachten Sie, daß durch keines dieser Gleichheitszeichen wirklich angegeben wird, daß die beiden Seiten eines Ausdrucks gleich sind.


DIALOGFELD "GLEICHUNGSFORMAT"

Im Dialogfeld "Gleichungsformat" finden Sie die folgenden Optionen und Schaltflächen:

Name der Vorlage

Liste der Formatvorlagen mit den folgenden Einträgen:

"Variablen" – Formatvorlage für alle Variablen im Arbeitsblatt
"Konstanten" – Formatvorlage für alle Zahlen im Arbeitsblatt
"Benutzer 1", "Benutzer 2" usw. – Formatvorlagen, die geändert, mit einem Namen versehen und einzelnen Konstanten oder Variablen zugewiesen werden können

Neuer Name der Vorlage

Geben Sie in dieses Feld einen neuen Namen ein, wenn die markierte Formatvorlage umbenannt werden soll. Dies ist im Normalfall nur für die Formatvorlagen "Benutzer 1", "Benutzer 2" usw. erforderlich.

Ändern

Klicken Sie hierauf, wenn Sie die Schriftart, den Schriftstil, die Schriftgröße oder die Schriftfarbe der ausgewählten Formatvorlage ändern wollen.

Standardfarbe für Gleichungen

Ermöglicht die Festlegung der Standardfarbe für Variablen und Konstanten.


FEHLERFUNKTION

Argumente:

x ist ein reeller Skalar.

Bei komplexem x ist fehlf(x) nicht definiert.

Zwischen der Fehlerfunktion und der komplementären Fehlerfunktion besteht die folgende Beziehung:

erfc(x) := 1 - fehlf(x)


FEHLERMELDUNGEN IN SYMBOLISCHEN BERECHNUNGEN

Folgende Meldungen können bei symbolischen Berechnungen angezeigt werden:

Argument zu groß

Zu langes Ergebnis.

Erwartet Feld oder Liste

Ausdruck enthält nicht-symbolische Operatoren

Gleitkommawerte werden nicht verarbeitet

Ungültige Funktionssyntax

Ganze Zahl zu groß

Ungültige Argumente

Bereichsfehler

Keine Antwort gefunden. Stapelgrenze erreicht.

Keine Antwort gefunden

Keine geschlossene Form gefunden für . . .

Objekt zu groß

Syntaxfehler


GAMMAFUNKTIONEN

G(z) Gibt den Wert der Eulerschen Gammafunktion von z zurück.

G(a,x) Gibt den Wert der unvollständigen Gammafunktion von x mit dem Parameter a zurück.

Argumente:

z ist eine reeller oder komplexer Skalar. z kann nicht 0, -1, -2... sein.

a ist ein positiver reeller Skalar.

x ist ein positiver reeller Skalar.

Die Eulersche Gammafunktion ist gegeben durch:

Die unvollständige Gammafunktion ist gegeben durch:

Folgende Beziehungen mit Gammafunktionen können sich als nützlich erweisen:

(a,0) = [image] (a)

(z + 1) = z [image] (z)

(z). (1 [image] - z) = p . csc(p . z)

(n + 1) = n!

Hinweise:

  • Bei komplexen z [image] ist (z) die analytische Fortsetzung der reellen Funktion.

  • Bei z = 0, -1, -2... ist (z) nicht definiert.


AUSWERTEN EINER FUNKTION

Zum Auswerten einer benutzerdefinierten Funktion gehen Sie wie folgt vor:

Positionieren Sie das Fadenkreuz durch Klicken unterhalb der Definition der Funktion, und geben Sie den Funktionsnamen gefolgt von einer linken Klammer ein.

Geben Sie eine Liste von durch Kommas abgetrennten Argumenten gefolgt von einer rechten Klammer ein.

Drücken Sie "=".


AUSWERTEN EINES AUSDRUCKS ÜBER EINEN BEREICH

Mathcad kann wiederholte Berechnungen ebenso einfach durchführen wie einzelne, indem es eine Bereichsvariable verwendet, also eine Variable, für die eine Folge von Werten möglich ist.

Zum Berechnen von Gleichungen für einen Wertebereich gehen Sie folgendermaßen vor:

Definieren Sie eine Bereichsvariable.

Werten Sie einen Ausdruck mit der Bereichsvariable aus.


SYMBOLLEISTE "AUSWERTUNG"

Über die Symbolleiste "Auswertung" haben Sie schnellen Zugriff auf die Auswertungsoperatoren, die Booleschen Operatoren und die angepaßten Operatoren. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


SORTIEREN VON DATEN IN EINER MATRIX NACH DEN WERTEN IN EINER BESTIMMTEN SPALTE

spsort(A,n) Gibt ein Feld zurück, das sich dadurch ergibt, daß die Zeilen von A so umgeordnet werden, bis die Werte in Spalte n in aufsteigender Reihenfolge angeordnet sind.

Argumente:

A ist eine Matrix.

Denken Sie daran, daß die Numerierung von Matrizen stets mit Zeile Null und Spalte Null beginnt, sofern Sie nicht den Wert der vordefinierten Variable ORIGIN ändern.


SORTIEREN VON DATEN IN UMGEKEHRTER REIHENFOLGE

umkehren(v) Gibt einen Vektor zurück, in dem sich die Elemente von v in umgekehrter Reihenfolge befinden.

Argumente:

v ist ein Vektor.


SORTIEREN VON DATEN IN EINER MATRIX NACH DEN WERTEN IN EINER BESTIMMTEN ZEILE

zsort(A,n) Gibt ein Feld zurück, das sich dadurch ergibt, daß die Zeilen von A so umgeordnet werden, bis die Werte in Zeile n in aufsteigender Reihenfolge angeordnet sind.

Argumente:

A ist eine Matrix.

Denken Sie daran, daß die Numerierung von Matrizen stets mit Zeile Null und Spalte Null beginnt, sofern Sie nicht den Wert der vordefinierten Variable ORIGIN ändern.


SORTIEREN VON DATEN IN AUF- BZW. ABSTEIGENDER REIHENFOLGE

sort(v) Gibt einen Vektor mit den Werten von v in aufsteigender Reihenfolge zurück.

Argumente:

v ist ein Vektor.

Denken Sie daran, daß die Numerierung von Matrizen stets mit Zeile Null und Spalte Null beginnt, sofern Sie nicht den Wert der vordefinierten Variable ORIGIN ändern.

Um einen Vektor in absteigender Reihenfolge zu sortieren, verwenden Sie die Funktion umkehren(v) wie folgt:

umkehren(sort(v))


Beispiele für die Umrißdiagrammformatierung

BEISPIELE FÜR DIE UMRISSDIAGRAMMFORMATIERUNG

Ein Umrißdiagramm, das entsprechend einer Farbzuordnung mit Farbe gefüllt wurde:

Ein Umrißdiagramm ohne Füllung:

Ein Umrißdiagramm mit einer Graustufenfarbzuordnung:

Ein Umrißdiagramm mit 8 Umrissen:

Ein Umrißdiagramm mit numerierten Umrissen:


BEISPIELE FÜR FLÄCHENDIAGRAMMFORMATIERUNG

Ein Flächendiagramm mit Farben entsprechend einer Farbzuordnung:

Ein Flächendiagramm mit Farben entsprechend einer Graustufenfarbzuordnung:

Ein Flächendiagramm mit einem Drahtmodell (links) und ohne Linien (rechts):


BEENDEN DES PROGRAMMS

Wählen Sie den Befehl Beenden im Menü Datei, um Mathcad vollständig zu beenden.

Wenn seit dem letzten Speichern des Arbeitsblatts Änderungen vorgenommen wurden, werden Sie aufgefordert, das Arbeitsblatt vor dem Schließen zu speichern.

Wenn Sie nur ein Arbeitsblatt schließen wollen, wählen Sie den Befehl Schließen aus dem Menü Datei.


Einblenden einer ausgeblendeten Region

EINBLENDEN EINER AUSGEBLENDETEN REGION (nur in Mathcad Professional)

Wenn Sie eine Region ausgeblendet und damit die in ihr enthaltenen Bereiche unsichtbar gemacht haben, können Sie die Region auch wieder einblenden, so daß die unsichtbar gemachten Bereiche wieder sichtbar werden. Zum Einblenden einer Region ist wie folgt vorzugehen:

1. Klicken Sie auf die Linie, die die ausgeblendete Region repräsentiert.

2. Wählen Sie den Befehl Region / Erweitern im Menü Format.

Statt der einzelnen Linie erscheinen nun wieder zwei Begrenzungslinien, zwischen denen die zuvor unsichtbar gemachten Bereiche angezeigt werden.

Die Bereiche, die sich unterhalb der Linie befanden, werden entsprechend nach unten verschoben.

Hinweis: Wenn eine ausgeblendete Region gesperrt ist, müssen Sie sie freigeben, bevor Sie sie wiederherstellen können.


ENTWICKELN VON AUSDRÜCKEN

Zum Ausmultiplizieren von Potenzen und Produkten von Polynomen gehen Sie folgendermaßen vor:

  1. Setzen Sie den zu entwickelnden Ausdruck (oder Teilausdruck) zwischen die Bearbeitungslinien.

  2. Wählen Sie den Befehl Entwickeln aus dem Menü Symbolik.

Besonderheiten beim Entwickeln von Ausdrücken:

Wenn es sich bei dem Ausdruck um einen Bruch handelt, wird der Zähler entwickelt und der Ausdruck in eine Summe von Funktionen umgeformt.

Sinus, Kosinus und Tangens der Summen von Variablen sowie ganzzahlige Vielfache von Variablen werden so weit wie möglich in Ausdrücke entwickelt, die lediglich Sinus und Cosinus für einzelne Variablen enthalten.

Wenn der Ausdruck nicht weiter entwickelt werden kann, wird er von diesem Befehl unverändert zurückgegeben.


EXPONENTIALVERTEILUNG

dexp(x,r) Gibt die Wahrscheinlichkeitsdichte für die Exponentialverteilung zurück.

pexp(x,r) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qexp(p,r) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rexp(m,r) Gibt einen Vektor aus m Zufallszahlen zurück, die die Exponentialverteilung aufweisen.


Operator "Potenzieren"

POTENZIEREN

Tastaturbefehl: ^

Gibt y hoch x zurück.

Operanden:

x und y sind Skalare.

x muß dimensionslos sein.


AUSDRUCKSTYP

IsScalar(x)

Gibt 1 zurück, wenn x ein Skalar ist, andernfalls 0.

IsArray(x)

Gibt 1 zurück, wenn x ein Vektor oder eine Matrix ist, andernfalls 0.

IsString(x)

Gibt 1 zurück, wenn x eine Zeichenfolge ist, andernfalls 0.


F-VERTEILUNG

dF(x,d1,d2) Gibt die Wahrscheinlichkeitsdichte für die F-Verteilung zurück.

pF(x,d1,d2) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qF(p,d1,d2) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rF(m,d1,d2) Gibt einen Vektor aus m Zufallszahlen zurück, die die F-Verteilung aufweisen.


Operator "Fakultät"

FAKULTÄT

Tastaturbefehl: !

n!

Gibt n(n-1)(n-2)...1 zurück.

Operanden:

n muß als natürliche Zahl angegeben werden.

Fakultäten für n>170 führen bei numerischer Auswertung zu einem Überlauf. Zum Auswerten von großen Fakultäten steht Ihnen jedoch der symbolische Prozessor zur Verfügung.

Für Bruchfakultäten ist die Gamma-Funktion zu verwenden, wobei folgende Beziehung gilt:

G(n+1) = n!


FAKTORISIEREN

Zum Umformen eines Ausdrucks in ein Produkt von Termen gehen Sie folgendermaßen vor:

  1. Setzen Sie den zu faktorisierenden Ausdruck (oder Teilausdruck) zwischen die Bearbeitungslinien.

  2. Wählen Sie den Befehl Faktorisieren aus dem Menü Symbolik.

Hinweise:

  • Zu beachten ist, daß mit diesem Befehl keine Ausdrücke faktorisiert werden können, die Konstanten mit Dezimalkomma enthalten.

  • Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


FOURIER-TRANSFORMATION KOMPLEXER DATEN

cfft(A) Gibt die Fourier-Transformation eines Vektors oder einer Matrix zurück. Das Ergebnis hat dieselbe Anzahl von Zeilen und Spalten wie A. Wenn A ein Vektor ist, wird das Ergebnis mit der folgenden Gleichung berechnet:

Dabei gibt n die Anzahl von Elementen in v an, und i ist die imaginäre Einheit.

Argumente:

A kann sowohl ein Vektor als auch eine Matrix sein.

Wenn

A ein Vektor ist, der [image] Elemente (m>2) hat, und...

alle Elemente im Vektor reell sind,

...verwenden Sie statt dessen fft. Bei solchen Vektoren ist die zweite Hälfte des Spektrums das Spiegelbild der ersten und braucht daher nicht berechnet zu werden.

Bei Matrixargumenten gibt cfft die zweidimensionale Fourier-Transformation zurück.


Fourier-Transformation komplexer Daten (alternative Form)

FOURIER-TRANSFORMATION KOMPLEXER DATEN

CFFT(A) Gibt die Fourier-Transformation eines Vektors oder einer Matrix zurück. Das Ergebnis hat dieselbe Anzahl von Zeilen und Spalten wie A. Wenn A ein Vektor ist, wird das Ergebnis mit der folgenden Gleichung berechnet:

Dabei gibt n die Anzahl von Elementen in v an, und i ist die imaginäre Einheit.

Argumente:

A kann sowohl ein Vektor als auch eine Matrix sein.

Wenn

A ein Vektor ist und [image] Elemente (m>2) hat, und...

alle Elemente im Vektor reell sind,

...verwenden Sie statt dessen FFT. Bei solchen Vektoren ist die zweite Hälfte des Spektrums das Spiegelbild der ersten und braucht daher nicht berechnet zu werden.

Bei Matrixargumenten gibt CFFT das Ergebnis der zweidimensionalen Fourier-Transformation zurück.


Fourier-Transformationen reeller Daten

FOURIER-TRANSFORMATION REELLER DATEN

fft(v) Gibt die Fourier-Transformation eines Vektors zurück. Das Ergebnis ist ein aus [image] Elementen bestehender Vektor, dessen k-tes Element gegeben ist durch:

Dabei gibt n die Anzahl von Elementen in v an, und i ist die imaginäre Einheit.

Argumente:

v muß [image] Elemente (m>2) haben.

Alle Elemente in v sind reell.

Hinweise:

  • Diese Funktion verwendet einen hocheffizienten Algorithmus für die schnelle Fourier-Transformation. Damit dies auch möglich ist, muß der von Ihnen mit fft verwendete Vektor [image] Elemente haben. Für Vektoren mit komplexen Werten oder einer beliebigen anderen Anzahl von Elementen sollten Sie statt dessen cfft verwenden.

  • Bei zweidimensionalen Fourier-Transformationen sollten Sie ebenfalls statt dessen cfft verwenden.

  • Wenn Sie fft verwenden, um zum Frequenzbereich zu gelangen, können Sie nur mit ifft zum Zeitbereich zurückkehren.


Fourier-Transformationen reeller Daten (alternative Form)

FOURIER-TRANSFORMATION REELLER DATEN

FFT(v) Gibt die Fourier-Transformation eines Vektors zurück. Das Ergebnis ist ein aus [image] Elementen bestehender Vektor, dessen k-tes Element gegeben ist durch:

Dabei gibt n die Anzahl von Elementen in v an, und i ist die imaginäre Einheit.

Argumente:

v muß [image] Elemente (m>2) haben.

Alle Elemente in v sind reell.

Für Vektoren mit komplexen Werten bzw. einer beliebigen Anzahl von Elementen sollten Sie statt dessen CFFT verwenden.

Für zweidimensionale Fourier-Transformationen ist statt dessen CFFT zu verwenden.


MENÜ "DATEI"

Neu

Öffnen

Aktualisieren

Schließen

Schließen und Zurückkehren

Speichern

Speichern unter...

Kopie speichern unter...

WWW-Foren...

Senden...

Seite einrichten...

Seitenansicht...

Drucken...

Liste zuletzt geöffneter Arbeitsblätter

Beenden


DIALOGFELD "SUCHEN"

Im Dialogfeld "Suchen" finden Sie die folgenden Optionen und Schaltflächen:

Suchen nach

Geben Sie die Zeichen ein, nach denen gesucht werden soll.

Nur ganzes Wort suchen

Wenn diese Option aktiviert ist, wird nur nach Wörtern gesucht, die nicht länger als die im Feld "Suchen nach" eingegebene Zeichenfolge sind.

Groß-/Kleinschreibung beachten

Wenn diese Option aktiviert ist, wird nur nach Text gesucht, der genau der Groß- bzw. Kleinschreibung der Zeichen im Feld "Suchen nach" entspricht.

In Textbereichen suchen

Wenn diese Option markiert ist, werden nur die Textbereiche nach dem angegebenen Text durchsucht.

In Rechenbereichen suchen

Wenn diese Option markiert ist, werden nur die Rechenbereiche nach dem angegebenen Text durchsucht.

Aufwärts

Mit dieser Schaltfläche können Sie angeben, daß Mathcad oberhalb der Position des Fadenkreuzes nach dem angegebenen Text suchen soll.

Abwärts

Mit dieser Schaltfläche können Sie angeben, daß Mathcad unterhalb der Position des Fadenkreuzes nach dem angegebenen Text suchen soll.

Weitersuchen

Mit dieser Schaltfläche können Sie angeben, daß Mathcad nach dem nächsten bzw. vorherigen Auftreten des Textes im Feld "Suchen nach" suchen soll.


ERMITTELN DER KOEFFIZIENTEN EINES POLYNOMS

Zum Umwandeln eines Ausdrucks in ein Polynom in einer bestimmten Variable oder bezüglich eines Unterausdrucks gehen Sie wie folgt vor:

  1. Wählen Sie den Teilausdruck aus, in dem der Ausdruck als Polynom behandelt werden solll.

  2. Wählen Sie den Befehl Polynom-Koeffizienten aus dem Menü Symbolik.

Es wird ein Vektor angezeigt, der die Koeffizienten des entsprechenden Polynoms enthält. Das erste Element des Vektors entspricht dem konstanten Term.


ANPASSEN BELIEBIGER FUNKTIONEN AN DATEN

genanp(vx,vy,vg,F) Ein Vektor mit den Parametern, mit denen sich eine Funktion f von x mit n Parametern u1...un am ehesten den Daten in vx und vy annähert.

Argumente:

vx ist ein Vektor aus Datenwerten. Diese entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten, die den y-Werten entsprechen. vy hat die gleiche Anzahl von Elementen wie vx.

vg ist entweder ein aus n Elementen bestehender Vektor mit Schätzwerten für die n Parameter oder ein Skalar (wenn n=1 ist).

F ist eine Funktion, die einen aus n + 1 Elementen bestehenden Vektor zurückgibt, der die Funktion f und deren partielle Ableitungen bezüglich ihrer n Parameter enthält. Wenn n=1, ist F ein Skalar.

n ist eine ganze Zahl.

Hinweise:

  • Diese Funktion erweist sich als nützlich, wenn Sie verschiedene gemessene x- und y-Werte haben und eine beliebige Funktion an Ihre Daten anpassen möchten.

  • Der Vektor der Schätzwerte wird für die Initialisierung benötigt.

  • Durch Herabsetzen des Wertes der vordefinierten Variable TOL läßt sich u. U. die Genauigkeit von genanp erhöhen.

Das folgende Beispiel zeigt die Verwendung von genanp:


"For"-Schleifen

"FOR"-SCHLEIFEN (nur Mathcad Professional)

Verwenden Sie eine "for"-Schleife, wenn Sie genau wissen, wie oft der Hauptteil der Schleife ausgeführt werden soll. Zum Einfügen einer "for"-Schleife gehen Sie wie folgt vor:

Klicken Sie in den Platzhalter, in den Sie die "For"-Schleife einfügen möchten.

Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

Klicken Sie auf die Schaltfläche "for". Geben Sie nicht einfach "for" ein.

Geben Sie in den Platzhalter links von "e" die Iterationsvariable ein.

Geben Sie in den Platzhalter rechts von "e" den Wertebereich für die Iterationsvariable ein. (In der Regel wird hier eine Bereichsvariable verwendet; Sie können jedoch auch einen Vektor oder eine Liste mit Skalaren und durch Kommata getrennte Vektoren verwenden.)

Klicken Sie gegebenenfalls auf die Schaltfläche "+1 Zeile", um Platzhalter für weitere Anweisungen aufzunehmen.

Wenn der Hauptteil der Schleife ausgeführt werden soll, bis eine Bedingung erfüllt ist, aber Sie nicht genau wissen, nach wie vielen Durchläufen dies der Fall sein wird, sollten Sie statt dessen eine "while"-Schleife verwenden.

Aufrufen eines QuickSheet-Beispiels


Format / Region / Ausblenden

FORMAT / REGION / AUSBLENDEN (nur in Mathcad Professional)

Blendet eine Region aus, die über den Befehl Region im Menü Einfügen eingefügt wurde. Die Begrenzungslinien der Region sowie die Bereiche dazwischen erscheinen daraufhin als eine Linie, die sich zwar verschieben, nicht aber löschen oder kopieren läßt. Die Bereiche, die sich unterhalb der ausgeblendeten Region befinden, verschieben sich entsprechend nach oben.

Soll eine ausgeblendete Region erweitert werden, um so verborgene Bereiche anzuzeigen, wählen Sie Region / Erweitern im Menü Format.


Format / Region / Erweitern

FORMAT / REGION / ERWEITERN (nur in Mathcad Professional)

Erweitert eine ausgeblendete Region, die über den Befehl Region / Ausblenden im Menü Format ausgeblendet wurde. Aus der Linie, die die ausgeblendete Region repräsentierte, werden zwei Begrenzungslinien, zwischen denen die zuvor ausgeblendeten Bereiche angezeigt werden. Die Bereiche, die sich unterhalb der Linie befunden haben, die die ausgeblendete Region repräsentierte, werden entsprechend nach unten verschoben.


SYMBOLLEISTE "FORMATIERUNG"

Auf der Symbolleiste "Formatierung" finden Sie Listenfelder und Schaltflächen, mit deren Hilfe Sie die Schriftmerkmale in Gleichungen und Text festlegen können. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.

Informationen dazu, wie die einzelnen Schaltflächen zu verwenden sind, erhalten Sie auch, wenn Sie auf einen der folgenden Schaltflächennamen klicken.

Format

Schriftart

Schriftgröße

Fettgedruckter Text

Kursiv geschriebener Text

Unterstrichener Text

Linksbündiger Text

Rechtsbündiger Text

Zentrierter Text

Aufzählungszeichen

Numerierung

Wenn Sie die Standard-Symbolleiste Ihren Vorstellungen entsprechend anpassen wollen, klicken Sie mit der rechten Maustaste, und wählen Sie Anpassen aus dem Kontextmenü.


MENÜ "FORMAT"

Gleichung...

Ergebnis...

Text...

Absatz...

Formatvorlage...

Eigenschaften...

Diagramm / X-Y-Diagramm...

Diagramm / Kreisdiagramm...

Diagramm / 3D-Diagramm...

Diagramm / Koordinaten ablesen...

Diagramm / Zoom...

Farbe / Hintergrund...

Farbe / Hervorhebung...

Farbe / Anmerkung...

Farbe / Standardpalette verwenden

Farbe / Palette optimieren

Bereiche trennen

Bereiche ausrichten / Horizontal

Bereiche ausrichten / Vertikal

Region / Sperren

Region / Freigeben

Region / Ausblenden

Region / Erweitern

Kopf-/Fußzeile...

Seiten jetzt neu umbrechen


FORMAT / SEITEN JETZT NEU UMBRECHEN

Bricht die Seiten automatisch so um, daß Bereiche im Arbeitsblatt nicht auf zwei Seiten erscheinen. Sie können diesen Befehl jederzeit wählen. Denken Sie aber daran, daß alle noch nicht berechneten Bereiche berechnet werden, wenn Sie diesen Befehl wählen.

Mathcad bricht ein Arbeitsblatt automatisch neu um, bevor dieses gedruckt bzw. in der Seitenansicht angezeigt wird, um so zu gewährleisten, daß kein Bereich sich über einen Seitenumbruch hinweg erstreckt und auf zwei separaten Seiten ausgedruckt wird.


FORMATIEREN VON TEXT

Ändern der Schriftarten

Ändern der Absatzattribute

Arbeiten mit Textformatvorlagen

Rechtschreibprüfung


FORMATIEREN EINER EINGABETABELLE

Wenn Sie eine Eingabetabelle einfügen, erscheint diese mit den Standardeinstellungen. Sie können aber das allgemeine Aussehen einer solchen Tabelle und die Art und Weise ändern, wie die Werte angezeigt werden.

Zum Ändern der Anzeigeeinstellungen von Zahlen in einer Eingabetabelle gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Tabelle.

  2. Wählen Sie aus dem Kontextmenü den Befehl Eigenschaften.

  3. Gehen Sie zur Registerkarte "Format", und legen Sie die Optionen wie gewünscht fest. Über die Schaltfläche "Schriftart" können Sie die Schriftart festlegen, in der die Zahlen in der Tabelle angezeigt werden.

Zum Einfügen von Zeilen und Spalten in eine Eingabetabelle gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf eine Zelle in der Tabelle.

  2. Wählen Sie im Kontextmenü den Befehl Zellen einfügen bzw. Zellen löschen.

  3. Klicken Sie auf "Zeile"/"Ganze Zeile" bzw. "Spalte"/"Ganze Spalte", und klicken Sie anschließend auf "OK".

Zum Vergrößern oder Verkleinern einer Tabelle gehen Sie wie folgt vor:

  1. Klicken Sie auf die Tabelle.

  2. Gehen Sie mit dem Cursor auf einen der Haltepunkte. Der Cursor nimmt die Form eines doppelseitigen Pfeils an.

  3. Drücken Sie die Maustaste, und halten Sie sie gedrückt.

  4. Ziehen Sie den Cursor in die Richtung, in der sich die Größe der Komponenten ändern soll.


FORMATIEREN ANGEZEIGTER EINHEITEN

Soll das Ergebnis als Bruch angezeigt werden, gehen Sie folgendermaßen vor:

  1. Doppelklicken Sie auf die Einheit, um das Dialogfeld "Ergebnisformat" zu öffnen.

  2. Klicken Sie auf die Option "Einheiten formatieren", um sie zu aktivieren.

  3. Klicken Sie auf "OK."

Beispiel:

wird beim Formatieren folgendermaßen umgeformt:

Hinweis: Soll Mathcad alle Einheiten in einem Arbeitsblatt automatisch vereinfachen, klicken Sie im Dialogfeld "Ergebnisformat" zuerst auf "Als Standard einrichten", bevor Sie auf "Einheiten formatieren" klicken.


FORMATIEREN VON ERGEBNISSEN

Die Art der Anzeige von Zahlen in Mathcad wird als Ergebnisformat bezeichnet. Sie können das Ergebnisformat für alle Ergebnisse in einem Arbeitsblatt oder für ein bestimmtes Ergebnis festlegen.

Steuern der Anzeige aller Ergebnisse

Steuern der Anzeige eines bestimmten Ergebnisses

Das Ergebnisformat wirkt sich nur auf die Anzeige eines Ergebnisses aus. Mathcad führt weiterhin alle Berechnungen mit voller Genauigkeit unabhängig von Formatierungsoptionen durch.


FOURIER-TRANSFORMATION

Zur Auswertung der Fourier-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie den Befehl Transformation / Fourier aus dem Menü Symbolik:

Mathcad gibt bei Fourier-Transformationen eine Funktion in der Variable w zurück. Wenn der zu transformierende Ausdruck bereits ein w enthält, wird statt dessen eine Funktion in der Variable ww zurückgegeben, um jegliche Zweideutigkeit zu vermeiden. Mit Hilfe des Befehls Variable / Ersetzen können Sie w durch eine andere Variable bzw. einen anderen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


FOURIER-TRANSFORMATIONEN

Wenn Sie weitere Informationen zu den einzelnen Funktionen benötigen, klicken Sie einfach auf den Namen der entsprechenden Funktion bzw. auf deren Argumente:

fft( A)

ifft( B)

FFT( A)

IFFT( B)


EINRAHMEN VON BITMAPS

Zum Einrahmen einer Bitmap, die mit dem Befehl "Bild" importiert wurde, gehen Sie vor wie folgt:

  1. Klicken Sie auf das Bild.

  2. Wählen Sie Eigenschaften aus dem Menü Format, und klicken Sie auf das Register "Anzeige".

  3. Klicken Sie auf das Feld mit der Beschriftung "Rahmen anzeigen".

  4. Klicken Sie auf "OK".


DEN KOEFFIZIENTEN ENTSPRECHENDE FREQUENZEN

Sowohl fft als auch cfft geben Vektoren zurück, deren Elemente die komplexen Amplituden der verschiedenen Frequenzen des Ausgangssignals sind.

Zur Wiederherstellung der eigentlichen Frequenzen muß folgendes bekannt sein:

die Abtastfrequenz des Ausgangssignals

die Anzahl der Messungen pro Ausgangssignal

Auf der Basis dieser Parameter wird die mit dem j-ten Element assoziierte Frequenz mit der folgenden Gleichung berechnet:


Funktionen für die Funktionsoptimierung

FUNKTIONSOPTIMIERUNG

minimieren(f, var1, var2,...)

Ermittelt die Werte, an denen eine Funktion ihren Minimalwert annimmt.

maximieren(f, var1, var2,...)

Ermittelt die Werte, an denen eine Funktion ihren Maximalwert annimmt.


FUNKTIONEN ZUR LÖSUNG VON GLEICHUNGEN

suchen(x,y,...)

Lösen von Gleichungssystemen

minfehl(x,y,...)

Näherungsweises Lösen von Gleichungssystemen

wurzel(f(x),x)

Lösen genau einer Gleichung für genau eine Unbekannte

llösen(M,v)

Lösen von Gleichungssystemen

nullstellen(v)

Löst nach den Wurzeln des Polynoms auf, dessen Koeffizienten durch v definiert sind.


Funktionen, die nur den Endwert einer Lösung auswerten

FUNKTIONEN, DIE NUR DEN ENDWERT EINER LÖSUNG AUSWERTEN (nur in Mathcad Professional)

bulstoer(y, x1, x2, gen, D, kmax, abst)
rkadapt(y, x1, x2, gen, D, kmax, abst)
stiffb(y, x1, x2, gen, D, J, kmax, abst)
stiffr(y, x1, x2, gen, D, J, kmax, abst)

Verwenden Sie diese Lösungsalgorithmen für Differentialgleichungen, wenn Sie nur den Wert der Lösung am Endpunkt der Integration benötigen. Jede Funktion entspricht einer bereits erörterten. Die Eigenschaften dieser Funktionen sind identisch mit denen der in den vorhergehenden Abschnitten beschriebenen Funktionen.

Argumente:

y muß ein Vektor aus n Anfangswerten oder ein Skalar sein.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung der Differentialgleichungen ausgewertet werden. Anfangswerte in y sind die Werte bei x1.

gen bestimmt die Genauigkeit der Lösung. Ein kleiner Wert für gen zwingt den Algorithmus, kleinere Schritte entlang der Trajektorie auszuführen, wodurch die Genauigkeit der Lösung erhöht wird. Werte für gen um 0.001 ergeben gewöhnlich exakte Lösungen.

D ist eine vektorwertige Funktion mit n Elementen, die die ersten Ableitungen der unbekannten Funktionen enthält.

J ist eine Funktion, die die aus n x (n+1) Elementen bestehende Matrix zurückgibt, deren erste Spalte Ableitungen enthält und deren andere Zeilen und Spalten die Jacobische Matrix für das System der Differentialgleichungen bilden.

kmax ist die Höchstzahl von Zwischenpunkten, die für die näherungsweise Lösung verwendet werden. Der Wert für kmax legt eine obere Grenze für die Anzahl der Zeilen der von diesen Funktionen zurückgegebenen Matrix fest.

abst ist der kleinste, zulässige Abstand zwischen den Werten, an denen die Lösungen angenähert werden sollen. Hierdurch wird eine untere Grenze für die Differenz zwischen zwei beliebigen Zahlen in der ersten Spalte der von der Funktion zurückgegebenen Matrix festgelegt.


Gammaverteilung

dgamma(x,s) Gibt die Wahrscheinlichkeitsdichte für die Gammaverteilung zurück.

pgamma(x,s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qgamma(p,s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rgamma(m,s) Gibt einen Vektor aus m Zufallszahlen zurück, die die Gammaverteilung aufweisen.


Gaußsche hypergeometrische Funktion

GAUSSSCHE HYPERGEOMETRISCHE FUNKTION (nur in Mathcad Professional)

fhyper(a,b,c,x) Gibt den Wert der Gaußschen hypergeometrischen Funktion, 2F1(a,b;c;x), zurück.

Argumente:

a, b und c sind reelle Skalare.

x ist ein reeller Skalar.

x liegt zwischen -1 und 1.

Die Gaußsche hypergeometrische Funktion ist die Lösung der folgenden Differentialgleichung:

Viele Funktionen sind Sonderfälle der Gaußschen hypergeometrischen Funktion. Beispiel:

ln(1+x)=x.fhyper(1,1,2,-x)

asin(x)=x.fhyper(.5,.5,1.5,x2)


Verallgemeinerte Eigenwerte und Eigenvektoren

VERALLGEMEINERTE EIGENWERTE UND EIGENVEKTOREN (nur in Mathcad Professional)

genwerte(M,N) Gibt einen Vektor v mit berechneten Eigenwerten zurück, die alle dem verallgemeinerten Eigenwertproblem entsprechen.

genvektoren (M,N) Gibt eine Matrix mit den normalisierten Eigenvektoren zurück, die den Eigenvektoren in v entsprechen, also dem Vektor, der von genwerte zurückgegeben wird. Die i-te Spalte dieser Matrix bildet den Eigenvektor x, der dem verallgemeinerten Eigenvektorproblem entspricht.

Argumente:

M und N müssen quadratische Matrizen sein.

Die Elemente von M und N müssen reell sein.

M und N müssen dieselbe Anzahl von Spalten haben.

Mit diesen Funktionen finden Sie verallgemeinerte Eigenwerte und Eigenvektoren. Zur Ermittlung einzelner Eigenwerte und Eigenvektoren verwenden Sie die Funktionen eigenwerte und eigenvek.


GEOMETRISCHE VERTEILUNG

dgeom(k,p) Gibt die Wahrscheinlichkeitsdichte für die geometrische Verteilung zurück.

pgeom(k,p) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qgeom(p,r) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rgeom(m,p) Gibt einen Vektor aus m Zufallszahlen zurück, die die geometrische Verteilung aufweisen.


GEOMETRISCHER MITTELWERT

Argumente:

A ist ein aus m x n Elementen bestehendes Feld.

Die Elemente von A müssen reell und größer als Null sein.

Hinweise:

  • Der geometrische Mittelwert kann zur Berechnung von Wachstumsraten verwendet werden.

  • hmean(A) < gmean(A) < mean( A )

Weitere Funktionen für die Datenanalyse...


ABLESEN VON DIAGRAMMKOORDINATEN

Um die Diagrammkoordinaten eines beliebigen Punktes im Diagramm anzuzeigen, gehen Sie wie folgt vor:

  1. Klicken Sie auf das Diagramm, damit es markiert wird, und wählen Sie dann Diagramm / Koordinaten ablesen im Menü Format, damit das Dialogfeld "Kreisdiagrammdaten ablesen" aufgerufen wird.

  2. Klicken Sie in den Diagrammbereich, und ziehen Sie die Maus entlang der Spur, deren Koordinaten Sie sehen möchten. Ein gepunkteter Fadenkreuz-Cursor springt von einem Punkt zum nächsten, während Sie ihn entlang der Spur ziehen.

  3. Die Koordinaten der jeweiligen Position des Fadenkreuz-Cursors werden in den Feldern "Radius" und "Winkel" angezeigt. Diese Koordinaten ändern sich entsprechend der Verschiebung der Maus.

  4. Wenn Sie die Maustaste loslassen, sehen Sie die Radius- und Winkelwerte des zuletzt ausgewählten Punkts im Dialogfeld.

Kopieren eines Koordinatenwerts in die Zwischenablage:

Klicken Sie auf die Schaltfläche "Radius kopieren" oder "Winkel kopieren", um die entsprechende Koordinate in die Zwischenablage einzufügen.


Ablesen der X-Y-Diagrammkoordinaten

ABLESEN DER DIAGRAMMKOORDINATEN

Zum Anzeigen der Koordinaten eines Punkts in einem Diagramm gehen Sie folgendermaßen vor:

  1. Klicken Sie auf das Diagramm, um es auszuwählen.

  2. Wählen Sie Diagramm / Koordinaten ablesen im Menü Format, damit das "X-Y-Koordinaten ablesen" geöffnet wird.

  3. Klicken Sie in den Diagrammbereich, und ziehen Sie die Maus entlang der Spur, deren Koordinaten Sie sehen möchten. Ein gepunkteter Fadenkreuz-Cursor springt von einem Punkt zum nächsten, während Sie ihn entlang der Spur ziehen.

  4. Sie sehen die Koordinaten entsprechend der Position des Fadenkreuz-Cursors in den Feldern "X-Wert" und "Y-Wert". Diese Koordinaten ändern sich entsprechend der Verschiebung der Maus.

  5. Wenn Sie die Maustaste loslassen, sehen Sie die x- und y-Werte des zuletzt ausgewählten Punkts im Dialogfeld.

Kopieren eines Koordinatenwerts in die Zwischenablage:

Klicken Sie auf die Schaltfläche "X kopieren" oder "Y kopieren", um die entsprechende Koordinate in die Zwischenablage einzufügen.


GLOBALE METHODEN

Die Funktion alert nimmt einen einzelnen Zeichenfolge-Parameter an, der beim Benutzer als Standard-Windows-Meldung mit einer "OK"-Schaltfläche angezeigt wird.

Die Funktion errmsg nimmt einen einzelnen Zeichenfolge-Parameter als erstes Argument an, der vom Skript als Fehlermeldung angezeigt wird, und sorgt dafür, daß die Ausführung des Skripts beendet wird. Der zweite, optionale Parameter ist ebenfalls eine Zeichenfolge. Mit ihm kann die Fehlerquelle angezeigt werden.

Hinweis: Im Gegensatz zu VBScript ist in JScript bei der Angabe von Funktionen, Methoden, Objekten und Eigenschaften auf die Groß- und Kleinschreibung zu achten.


SYMBOLLEISTE "DIAGRAMM"

Mit Hilfe der Schaltflächen der Symbolleiste "Diagramm" können Sie zwei- und dreidimensionale Diagramme einfügen. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


GRAFISCHES DARSTELLEN VON MEHREREN AUSDRÜCKEN

Sie können mehrere Kurven in einem Diagramm abbilden, wenn Sie ein Komma zwischen den Argumenten auf jeder Achse eingeben.

Zum grafischen Darstellen mehrerer unabhängiger Kurven im gleichen Achsensystem eines XY- oder eines Kreisdiagramms gehen Sie folgendermaßen vor:

  1. Wählen Sie Diagramm / Kreisdiagramm im Menü Einfügen, um einen Diagrammbereich zu erstellen.

  2. Geben Sie im mittleren Platzhalter unter der horizontalen Achse (oder dem unteren Platzhalter in einem Kreisdiagramm) den ersten abzubildenden Ausdruck ein. Geben Sie beispielsweise "m" ein, wenn "m" zuvor als Bereichsvariable definiert worden war.

  3. Geben Sie ein Komma ein. Rechts wird ein Platzhalter angezeigt.

  4. Geben Sie den zweiten Ausdruck ein.

  5. Sie können insgesamt bis zu 10 durch Kommas abgetrennte Ausdrücke einfügen.

  6. Geben Sie im mittleren Platzhalter neben der vertikalen Achse (oder dem linken Platzhalter in einem Kreisdiagramm) den ersten Ausdruck ein, der abgebildet werden soll. Geben Sie beispielsweise "m^2" ein, wenn Sie die Quadrate von "m" abbilden möchten.

  7. Geben Sie ein Komma ein, und fügen Sie den zweiten Ausdruck hinzu.

  8. Sie können noch weitere durch Kommas abgetrennte Ausdrücke hinzufügen; die Anzahl der Ausdrücke auf den einzelnen Achsen muß jedoch übereinstimmen.

Mathcad gleicht die Ausdrücke paarweise ab. Dann zeichnet es eine Spur für jedes Paar. Für jedes übereinstimmende Paar von Ausdrücken muß dieselbe Bereichsvariable verwendet werden, aber die Bereichsvariable für ein Paar muß nicht mit den Bereichsvariablen für die anderen Paare übereinstimmen.

Wenn Sie mehrere y-Achsen- oder Radialachsen-Ausdrücke im Vergleich zu einem x-Achsen- oder Winkelachsen-Ausdruck abbilden möchten, geben Sie einen Ausdruck auf der x-Achse (oder Winkelachse) und mehrere durch Kommas abgetrennte Ausdrücke auf der y-Achse (oder Radialachse) ein. Sie können bis zu 16 y-Achsenargumente abbilden.


ABBILDEN EINHEITLICHER POLYEDER

Polyhedron(S1) Generiert das einheitliche Polyeder, dessen Name, Nummerncode oder Wythoff-Symbol S1 ist.

PolyLookup(S2) Gibt einen Vektor zurück, der den Namen, den Dualnamen und das Wythoff-Symbol für das Polyeder enthält, dessen Nummerncode S2 ist.

Argumente:

S1 und S2 sind Zeichenfolgen.

S1 ist der Name eines Polyeders, seines Nummerncodes oder seines Wythoff-Symbols.

S2 ist der Nummerncode für ein Polyeder.

Arbeiten mit Polyedern:

Zum Erstellen eines Polyeders mit der Funktion Polyhedron gehen Sie folgendermaßen vor:

  1. Klicken Sie auf eine leere Stelle im Arbeitsblatt.

  2. Wählen Sie Diagramm / Flächendiagramm im Menü Einfügen.

  3. Geben Sie in den Platzhalter die Polyhedron-Funktion ein. Das Argument ist entweder ein Name, das #-Zeichen gefolgt von einer Nummer oder ein Wythoff-Symbol. Beispielsweise können Sie eingeben: Polyhedron("würfel") oder Polyhedron("#6") oder Polyhedron("3|2 4")

  4. Klicken Sie auf eine Stelle außerhalb des Diagramms.

Beispiel für die Arbeit mit PolyLookup:


Operator "Größer als"

GRÖSSER ALS

Tastaturbefehl: >

x > y

Gibt 1 zurück, wenn x > y, andernfalls 0.

Operanden:

x und y müssen reelle Skalare sein.


Operator "Größer gleich"

GRÖSSER GLEICH

Tastaturbefehl: Strg+0

x [image] y

Gibt 1 zurück, wenn x [image] y, andernfalls 0.

Operanden:

x und y müssen reelle Skalare sein.


Größter gemeinsamer Teiler

GRÖSSTER GEMEINSAMER TEILER

gcd(A) Gibt den größten gemeinsamen Teiler zurück, also die größte ganze Zahl, die alle Elemente in A glatt teilt.

Argumente:

A ist eine Matrix oder ein Vektor.

Die Elemente in A müssen reelle, nicht-negative ganze Zahlen sein.

Beispiele:


SYMBOLLEISTE "GRIECHISCH"

Mit Hilfe der Symbolleiste "Griechisch" können Sie griechische Buchstaben einfügen. Den Namen des griechischen Buchstabens, der mit einer bestimmten Schaltfläche eingefügt wird, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


MANUELLE SEITENUMBRÜCHE

Ein manueller Seitenumbruch wird auf dem Arbeitsblatt als durchgehende Linie dargestellt. Alles, was sich unter dieser Linie befindet, wird auf der nächsten Seite gedruckt.

Zum Einfügen eines manuellen Seitenumbruchs gehen Sie wie folgt vor:

Klicken Sie auf die Stelle, an der ein Seitenumbruch eingefügt werden soll. Stellen Sie sicher, daß die Linie keine Rechen- oder Textbereiche schneidet.

Wählen Sie den Befehl Seitenumbruch aus dem Menü Einfügen.

Zum Löschen eines Seitenumbruchs gehen Sie wie folgt vor:

Halten Sie die Umschalttaste gedrückt, und klicken Sie etwas rechts vom Knick der Seitenumbruchlinie am linken Rand des Fensters.

Wenn ein kleines, aus gestrichelten Linien bestehendes Feld neben dem Knick erscheint, wählen Sie den Befehl Ausschneiden aus dem Menü Bearbeiten.

Die manuellen Seitenumbrüche (dargestellt durch durchgehende Linien) dürfen nicht mit den automatischen Seitenumbrüchen (dargestellt durch gepunktete Linien) verwechselt werden. Wo automatische Seitenumbrüche eingefügt werden, hängt davon ab, welchen Drucker Sie als Standarddrucker für Ihr Betriebssystem festgelegt haben.


HARMONISCHER MITTELWERT

Argumente:

A ist ein aus m x n Elementen bestehendes Feld.

Alle Elemente von A müssen reell und positiv sein.

Hinweise:

  • Der harmonische Mittelwert ist das Reziproke des arithmetischen Mittelwerts der Reziproken.

  • hmean(A) < gmean( A ) < mean( A )

Weitere Funktionen für die Datenanalyse...


Dialogfeld "Kopfzeile/Fußzeile"

DIALOGFELD "KOPFZEILE/FUSSZEILE"

Zum Formatieren der Kopf- bzw. Fußzeile Ihres Arbeitsblatts steht Ihnen das Dialogfeld "Kopfzeile/Fußzeile" mit den Registerkarten "Kopfzeile" und "Fußzeile" zur Verfügung, die Sie durch Klicken auf den jeweiligen Reiter öffnen können. Auf den Registerkarten finden Sie die folgenden Optionen und Schaltflächen:

Textfelder "Links", "Zentriert", "Rechts"

Diese Felder zeigen Text oder Symbole an, aus dem bzw. denen Sie ersehen können, was in Ihrer Kopf- bzw. Fußzeile erscheinen wird. Das genaue Aussehen der Kopf- bzw. Fußzeile können Sie sich anzeigen lassen, indem Sie den Befehl Seitenansicht im Menü Datei wählen.

Hilfsmittel

Fügt den Namen Ihres Arbeitsblatts ein. Erscheint in den Textfeldern "Links", "Zentriert" und "Rechts" als {f}.

Fügt den Pfad zu Ihrem Arbeitsblatt ein. Erscheint im markierten Textfeld als {p}.

Fügt die Seitennummer ein. Erscheint im markierten Textfeld als {n}.

Fügt die Gesamtzahl der Seiten in Ihrem Arbeitsblatt ein. Erscheint im markierten Textfeld als {nn}.

Fügt das Datum ein, an dem Ihr Arbeitsblatt zuletzt gespeichert wurde. Erscheint im markierten Textfeld als {fd}.

Fügt die Uhrzeit ein, an der Ihr Arbeitsblatt zuletzt gespeichert wurde. Erscheint im markierten Textfeld als {ft}.

Fügt das aktuelle Datum ein. Erscheint im markierten Textfeld als {d}.

Fügt die aktuelle Uhrzeit ein. Erscheint im markierten Textfeld als {t}.

Format

Mit dieser Schaltfläche öffnen Sie ein weiteres Dialogfeld, in dem Sie die Schriftart für die Kopf- bzw. Fußzeile ändern können.

Bild

Mit dieser Schaltfläche können Sie eine Bitmap-Datei in die Kopf- bzw. Fußzeile einfügen. Erscheint im markierten Textfeld als {image}.

Bei folgender Seitennummer beginnen

Mit dieser Option können Sie festlegen, welche Seitennummer auf der ersten Seite erscheinen soll.

Unterschiedliche Kopf- und Fußzeile auf erster Seite

Wenn Sie diese Option aktivieren, wird das Dialogfeld um zwei zusätzliche Registerkarten erweitert, mit denen Sie der ersten Seite des Arbeitsblatts eine andere Kopf- bzw. Fußzeile zuweisen können.

Seite

Hiermit legen Sie fest, daß jede Seite mit einem Rahmen versehen werden soll.

Kopfzeile

Hiermit legen Sie fest, daß die Kopfzeile mit einem Rahmen versehen werden soll.

Fußzeile

Hiermit legen Sie fest, daß die Fußzeile mit einem Rahmen versehen werden soll.


MENÜ "HILFE"

Mathcad-Hilfe

Informationszentrum

Tips und Tricks...

Buch öffnen...

Info über Mathcad...


Hermitesche Polynomfunktion

HERMITESCHE POLYNOMFUNKTION (nur in Mathcad Professional)

Her(n,x) Gibt den Wert des Hermiteschen Polynoms n-ten Grades bei x zurück.

Argumente:

n ist eine nicht-negative ganze Zahl.

x ist ein reeller Skalar.

Das Hermitesche Polynom ist eine Lösung der folgenden Differentialgleichung:


HERVORHEBEN VON ANMERKUNGEN

Standardmäßig zeigt Mathcad alle an einem Elektronischen Buch vorgenommenen Änderungen in einer anderen Farbe.

Sie können diese Funktion wie folgt ausschalten:

Wählen Sie die Option Änderungen hervorheben aus dem Kontextmenü "Bücher" im Fenster "Informationszentrum/Elektronisches Buch".

Mathcad entfernt das Häkchen neben dem Menübefehl und zeigt jetzt auch Ihre Änderungen in der gewöhnlichen Textfarbe an.

Erneutes Aktivieren der Funktion:

Wählen Sie die Option Änderungen hervorheben aus dem Kontextmenü "Bücher" im Fenster "Informationszentrum/Elektronisches Buch".

Mathcad setzt ein Häkchen neben den Menübefehl und zeigt Ihre Änderungen in einer anderen Farbe an.


TIPS ZUM UMGANG MIT DER FUNKTION "wurzel"

Die Funktion wurzel beginnt die Suche nach den Wurzeln einer Funktion, indem sie sich schrittweise dem Wurzelwert nähert. Sobald der Betrag der Funktion an der vorgegebenen Wurzel unter dem Wert von TOL liegt, gibt die Funktion wurzel ein Ergebnis zurück. Andernfalls wird ein Fehler zurückgegeben.

Im folgenden finden Sie einige Tips für die effiziente Nutzung der Funktion wurzel:

Sie können die Genauigkeit der Funktion wurzel ändern, indem Sie einen anderen Wert für TOL einstellen. Um eine genauere Wurzel zu ermitteln, senken Sie den Wert von TOL. Wurde keine Wurzel gefunden, erhöhen Sie den Wert von TOL.

Enthält der Ausdruck mehrere Wurzeln, sollten Sie unterschiedliche Schätzwerte ausprobieren oder das optionale 3. und 4. Argument der Funktion wurzel verwenden, um das Intervall anzugeben, in dem die gewünschte Wurzel liegt.

Bei einem Ausdruck f(x) mit einer bekannten Wurzel a entspricht die Suche nach weiteren Wurzeln von f(x) dem Lösen nach Wurzeln der Gleichung h(x) = f(x) / (x-a). Das Ausdividieren solcher bekannter Wurzeln ist für die Auflösung zweier Wurzeln nützlich, die möglicherweise eng beieinander liegen. Oft findet man die Lösung für Wurzeln von h(x) wie hier definiert leichter als weitere Wurzeln von f(x) mit Hilfe unterschiedlicher Schätzwerte.

Die Funktion wurzel bietet sich an, wenn Sie nach der Wurzel eines Ausdrucks suchen, während Sie einen seiner Parameter variieren. Die einfachste Möglichkeit besteht dabei in der Definition einer Funktion mit der Funktion wurzel.


HISTOGRAMME

hist(intervalle,daten) Gibt ein Histogramm von Daten zurück:

Wenn intervalle ein Vektor ist, wird ein Vektor zurückgegeben, dessen i-tes Element die Anzahl der Punkte in daten angibt, die zwischen dem i-ten und dem (i+1)ten Element von intervalle liegen.

Wenn intervalle ein Skalar ist, wird ein Vektor zurückgegeben, der die Anzahl der Punkte in daten anzeigt, die in die Zahl der gleichmäßigen Intervalle fallen, die durch intervalle repräsentiert wird.

Argumente:

intervalle ist ein Skalar oder ein Vektor. Wenn es sich um einen Skalar handelt, stellt er die Anzahl der gleichmäßigen Intervalle dar, in die die Werte in daten sortiert werden. Handelt es sich bei intervalle um einen Vektor aus reellen Werten in aufsteigender Reihenfolge, stellen die Werte die Intervalle dar, in die die Elemente von daten sortiert werden.

daten ist ein Vektor aus reellen Datenwerten.


HYPERBOLISCHE FUNKTIONEN

sinh(z) cosh(z)

tanh(z) csch(z)

sech(z) coth(z)

Argumente:

z muß in Radiant angegeben werden.

z muß ein Skalar sein.

z muß dimensionslos sein.

Verwandte Themen

Felder als Argumente

Rundungsfehler bei numerischen Angaben

Beziehung zwischen trigonometrischen und hyperbolischen Funktionen

Definitionen für hyperbolische Funktionen


HYPERGEOMETRISCHE VERTEILUNG

dhypergeom(m,a,b,n) Gibt die Wahrscheinlichkeitsdichte für die hypergeometrische Verteilung zurück.

phypergeom(m,a,b,n) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qhypergeom(p,a,b,n) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rhypergeom(m,a,b,n) Gibt einen Vektor von m Zufallszahlen zurück, die eine hypergeometrische Verteilung aufweisen.


HYPERLINKS AUS NICHTTEXT-BEREICHEN

Grundsätzlich können Sie von jeder Stelle aus Hyperlinks erstellen; allerdings müssen Sie zwei entscheidende Nachteile in Kauf nehmen, wenn Sie als Auslöser der Verknüpfung keinen ausgewählten Text verwenden.

Wenn Sie einen Hyperlink mit Text als Auslöser erstellen, setzt Mathcad den Text automatisch fett und unterstrichen, um anzuzeigen, daß es sich um einen Hyperlink handelt. Bei anderen Auslöserobjekten ist diese Kennzeichnung nicht möglich.

Durch die Hyperlink-Verknüpfung wird die gewöhnliche Reaktion auf den Doppelklick aufgehoben. {bmc b.bmp} Wenn Sie zum Beispiel ein Diagramm als Hyperlink-Auslöser festlegen, können Sie durch Doppelklicken kein Formatierungsdialogfeld mehr öffnen.

Daher wird empfohlen, daß Sie zum Erstellen von Hyperlinks nur ausgewählten Text verwenden.


EINHEITSMATRIX

einheit(n) Gibt eine Einheitsmatrix aus n x n Elementen (Matrix aus Nullen mit Einsen entlang der Diagonalen) zurück.

Argumente:

n muß eine positive ganze Zahl sein.


"wenn"-Funktion

VERZWEIGUNGSFUNKTION

wenn(cond, x, y) Gibt x zurück, wenn die logische Bedingung cond wahr (ungleich Null) ist, andernfalls wird y zurückgegeben.

Argumente:

cond ist im Normalfall eine Bedingung, die einen logischen Operator einschließt. So sind z. B. die folgenden Verwendungen möglich:

(i < 2)

(x<1)*(x>0) für ein "und"-Gate

(x>1)+(x<0) für ein "oder"-Gate

x=4 für eine Gleichheit

x ist der Wert, der zurückgegeben wird, wenn cond wahr ist.

y ist der Wert, der zurückgegeben wird, wenn cond falsch ist.


IGNORIEREN VON DEFINITIONEN

Normalerweise übernimmt Mathcad alle bestehenden Definitionen, die es in Ihrem Arbeitsblatt findet, wenn Sie mit symbolischen Schlüsselwörtern arbeiten.

Soll Mathcad jedoch alle Definitionen im Arbeitsblatt ignorieren, können Sie einen Ausdruck mit den Befehlen im Menü Symbolik symbolisch auswerten.

Um Mathcad anzuweisen, bereits definierte Variablen oder Funktionen zu ignorieren, geben Sie eine rekursive Definition für die Variable an. Wenn im Arbeitsblatt zum Beispiel die Definition x:=10 enthalten ist, Mathcad die Definition jedoch beim symbolischen Auswerten ignorieren und annehmen soll, daß x nicht definiert ist, geben Sie folgendes ein: x:=x.

QuickSheet-Beispiel starten

Weitere Schlüsselwörter...


BILDTRANSFORMATIONEN

Nach dem Einlesen des Bilds in die Matrix mit der Funktion BMPLESEN oder RGBLESEN können Sie das Bild mit allen verfügbaren Rechenhilfsmitteln verändern. Die folgenden Beispiele sollen Ihnen einige Anregungen bieten:

Drehen eines Bilds...

Invertieren eines Bilds...

Erhöhen des Bildkontrasts...

Starten eines QuickSheet-Beispiels


Imaginäre Einheiten

I ODER J

Tastaturbefehl: 1i oder 1j

Beschreibung: Die imaginäre Einheit. Beachten Sie, daß Sie nicht i und j, sondern 1i und 1j eingeben müssen. In beiden Fällen wird der Zusatz "1" gelöscht, sobald Sie den Ausdruck verlassen.

Sie können auch Vielfache von i und j eingeben, z. B. 2i oder -2.5j.


IMPORTIEREN VON DATEN AUS EINER DATENDATEI

Wenn Sie Daten aus einer Datendatei einmalig in Mathcad importieren möchten, können Sie eine Eingabetabelle verwenden. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie im Arbeitsblatt auf eine leere Stelle, und wählen Sie den Befehl Komponente aus dem Menü Einfügen.

  2. Wählen Sie den Befehl "Eingabetabelle", und klicken Sie auf "Fertig stellen".

  3. Geben Sie im links angezeigten Platzhalter den Namen der Mathcad-Variablen ein, der diese Daten zugewiesen werden sollen.

  4. Klicken Sie mit der rechten Maustaste auf die Eingabetabelle. Ein Kontextmenü wird geöffnet.

  5. Wählen Sie Importieren.

  6. Das Dialogfeld "Aus Datei lesen" wird geöffnet. Wählen Sie im Feld "Dateityp" den Dateityp aus, der importiert werden soll. Geben Sie den Pfad zur entsprechenden Datendatei an, und klicken Sie auf "Öffnen".

Die Daten aus der Datendatei werden daraufhin im Arbeitsblatt in Tabellenform angezeigt und dem von Ihnen gewählten Variablennamen zugewiesen. Sie können dieses Mathcad-Feld nun mit Hilfe der vordefinierten Funktionen und Operatoren ganz nach Ihren Wünschen bearbeiten.


Unvollständige Betafunktion

UNVOLLSTÄNDIGE BETAFUNKTION (nur in Mathcad Professional)

ibeta(a,x,y) Gibt den Wert der unvollständigen Betafunktion von x und y mit dem Parameter a zurück.

Argumente:

a ist ein reeller Skalar zwischen 0 und einschließlich 1.

x und y sind reelle Skalare größer als Null.

Die unvollständige Betafunktion tritt häufig in Wahrscheinlichkeitsberechnungen auf. Sie ist durch folgende Formel definiert:


Unendlichkeit

Tastaturbefehl: Strg+z

Beschreibung: In numerischen Ausdrücken gilt hierfür:

In symbolischen Berechnungen steht dies für die gängige mathematische Definition von Unendlichkeit.


Operator "Skalarprodukt" (Inneres Produkt)

SKALARPRODUKT

Tastaturbefehl: *

Gibt das Skalarprodukt von u und v (auch "inneres Produkt" genannt) zurück.

Operanden:

u und v sind beides Vektoren mit derselben Anzahl von Elementen.

Das Skalarprodukt (inneres Produkt) ist ein Skalar, der durch die Multiplikation der jeweils einander entsprechenden Elemente von u und v und der anschließenden Summation der Ergebnisse entsteht. Das Skalarprodukt hat die folgenden Merkmale:

=| u || v |cos(q), wobei q den Winkel zwischen u und v angibt.

Wenn u und v orthogonal sind, ist ihr Skalarprodukt Null.

Das Skalarprodukt von u mit sich selbst ist einfach das Quadrat der Länge von u.


DIALOGFELD "FUNKTION EINFÜGEN"

Im Dialogfeld "Funktion einfügen" finden Sie die folgenden Optionen und Schaltflächen:

Funktionskategorie

Zeigt eine Liste der Kategorien der integrierten Funktionen an. Wenn Sie "Alle" wählen, werden alle verfügbaren Funktionen angezeigt.

Welche Kategorien angegeben werden, hängt davon ab, ob Sie zusätzliche Erweiterungen installiert oder eigene integrierte Funktionen geschrieben haben.

Funktionsname

Zeigt eine Liste aller integrierten Funktionen in der ausgewählten Kategorie an.

Syntax

Zeigt an, wie viele und welche Argumente für die ausgewählte Funktion erforderlich sind.

Beschreibung

Zeigt eine Beschreibung der ausgewählten Funktion an.

Schaltfläche "Einfügen"

Fügt die ausgewählte Funktion (zusammen mit Platzhaltern für ihre Argumente) in Ihr Arbeitsblatt ein.

Wenn Sie eine Funktion auf einen Ausdruck anwenden wollen, der bereits eingegeben wurde, schließen Sie den Ausdruck in Bearbeitungslinien ein, und klicken Sie dann auf diese Schaltfläche.

Schaltfläche "OK"

Fügt die ausgewählte Funktion (zusammen mit Platzhaltern für ihre Argumente) in Ihr Arbeitsblatt ein und schließt das Dialogfeld.

Schaltfläche "Hilfe"

Öffnet das Online-Hilfethema für die ausgewählte Funktion.


MENÜ "EINFÜGEN"

Diagramm / X-Y-Diagramm

Diagramm / Kreisdiagramm

Diagramm / Diagrammassistent...

Diagramm / Flächendiagramm

Diagramm / Umrißdiagramm

Diagramm / 3D-Streuungsdiagramm

Diagramm / 3D-Säulendiagramm

Diagramm / Vektorfelddiagramm

Matrix...

Funktion...

Einheit...

Bild

Fläche

Rechenbereich

Textbereich

Seitenumbruch

Hyperlink...

Verweis...

Komponente...

Objekt...


DIALOGFELD "OBJEKT EINFÜGEN"

Im Dialogfeld "Objekte einfügen" finden Sie die folgenden Optionen und Schaltflächen:

Neu erstellen

Ermöglicht es, eine Grafik einzufügen, die in einer vorhandenen Datei gespeichert ist.

Aus Datei erstellen:

Ermöglicht es, eine Grafik einzufügen, die in einer vorhandenen Datei gespeichert ist.

"Datei" oder "Objekttyp"

Wenn "Neu erstellen" markiert wurde, werden die Anwendungsprogramme aufgeführt, in denen das neue Objekt erstellt werden kann. Wenn "Aus Datei erstellen" gewählt wurde, können Sie hier den Dateinamen eingeben.

Durchsuchen

Ermöglicht die Suche nach der gewünschten Datei.

Verknüpfen

Verknüpft ein Objekt von einem OLE-Server mit Ihrem Arbeitsblatt. Änderungen an einer verknüpften Grafik wirken sich sowohl auf die Kopie in Mathcad als auch auf das Original aus. Diese Option ist nur verfügbar, wenn zuvor "Aus Datei erstellen" gewählt wurde.

Als Symbol

Zeigt das Objekt als Symbol an.


DIALOGFELD "EINHEIT EINFÜGEN"

Im Dialogfeld "Einheit einfügen" finden Sie die folgenden Optionen und Schaltflächen:

Dimension

Mit dieser Option können Sie festlegen, welche Einheiten in der Liste der Einheiten erscheinen sollen. Auf diese Weise werden in der Liste der Einheiten nur die Einheiten angezeigt, die die entsprechenden Dimensionen haben. Eine vollständige Liste aller Einheiten wird angezeigt, wenn Sie die Option "dimensionslos" am Anfang der Liste wählen.

Wenn Sie auf ein numerisches Ergebnis klicken, wird für dieses Ergebnis automatisch die Dimension festgelegt, die ihm entspricht.

System

Zeigt das Standard-Einheitensystem an. Das Einheitensystem können Sie ändern, indem Sie den Befehl Optionen im Menü Rechnen wählen und auf die Registerkarte "Einheitensystem" klicken.

Einheit

Zeigt eine Liste der Einheiten an, die für die ausgewählte Dimension verfügbar sind. Die vollständige Liste aller Einheiten können Sie sich anzeigen lassen, indem Sie in der Liste auf der linken Seite die Option "dimensionslos" wählen, die Sie ganz am Anfang der Liste finden.

Durch Doppelklicken auf eine Einheit wird diese in Ihr Arbeitsblatt eingefügt.

Einfügen

Fügt die ausgewählte Einheit in Ihr Arbeitsblatt ein.


EINFÜGEN EINER KOMPONENTE

Zum Einfügen einer Komponente in ein Mathcad-Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Klicken Sie im leeren Bereich des Mathcad-Arbeitsblatts auf die Stelle, an der Sie die Komponente einfügen möchten.

  2. Wählen Sie den Befehl Komponente im Menü Einfügen.

  3. Wählen Sie eine der Komponenten in der Liste, und klicken Sie auf "Weiter".

Je nach gewählter Komponente wird sofort die Komponente mit einigen Standardeigenschaften (eingefügt in das Arbeitsblatt) oder das Dialogfeld eines Assistenten angezeigt, um Ihnen die Einrichtung der Komponente zu erleichtern.

Jede Komponente hat eine eigene Struktur, also ist auch die Anzeige auf dem Bildschirm jeweils unterschiedlich. Alle Komponenten weisen einen oder mehrere Platzhalter entweder rechts neben dem ":=" oder im unteren Bereich der Komponente auf. Zum Beispiel kann die Excel-Komponente folgendermaßen aussehen, wenn Sie in das Arbeitsblatt eingefügt wird:

Die Platzhalter links neben ":=" stehen für die Ausgabevariablen, die die von der Komponente weitergeleiteten Daten enthalten. Der Platzhalter im unteren Bereich der Komponente steht für den Namen einer Eingabevariable, die die Komponente von Mathcad erhält. Die Anzahl der links oder unten angezeigten Platzhalter richtet sich entweder nach den Standardeigenschaften für die Komponente oder nach den Einstellungen, die Sie im Assistenten der Komponente angegeben haben.


EINFÜGEN GRIECHISCHER BUCHSTABEN

Zum Einfügen griechischer Buchstaben gehen Sie wie folgt vor:

  1. Geben Sie die lateinische Entsprechung aus der untenstehenden Tabelle ein.

  2. Setzen Sie die Einfügemarke direkt vor den Buchstaben, der durch einen griechischen Buchstaben ersetzt werden soll.

  3. Drücken Sie Strg+G.

Mit Strg+G können Sie zwischen griechischen und lateinischen Buchstaben umschalten. Wenn Sie die Einfügemarke direkt vor einen griechischen Buchstaben setzen und Strg+G drücken, wird der griechische Buchstabe durch den entsprechenden lateinischen ersetzt.

Verwandte Themen

Ändern der Schriftart für alle Variablen

Ändern der Schriftart für alle Konstanten

Ändern einer Rechenformatvorlage

Zuweisen einer Rechenformatvorlage zu einer bestimmten Variable oder Konstante


Operator "Integration"

BESTIMMTES INTEGRAL

Tastaturbefehl: &

Gibt das bestimmte Integral von f(x) von a bis b zurück.

Operanden:

f ist eine beliebige Funktion mit skalarem Wert, definiert über das geschlossene Interval [a,b].

x ist die Variable für die Integration.

a und b müssen reelle Skalare sein; f kann einen komplexen Wert haben.

Falls a und b eine Dimension haben, muß diese bei beiden übereinstimmen.

Beispiel:

Das Beispiel zeigt zwar eine Funktion nur einer Variablen, f kann aber eine Funktion jeder beliebigen Anzahl von Variablen sein.

Wenn Doppel- oder Mehrfachintegrale ausgewertet werden sollen, müssen Sie & mehrmals drücken.

Hinweise zur Integration:

Standardmäßig wird der Operator "Integration" numerisch mit der Funktion Autom. Auswahl ausgewertet. AutoSelect wählt den für das Integral geeignetsten Algorithmus aus. Wenn Sie wissen wollen, welche Ergebnisse durch andere Algorithmen ausgegeben werden, setzen Sie die automatische Algorithmusauswahl außer Kraft, und wählen Sie selbst einen Algorithmus aus.

Verwandte Themen

Symbolische Integration


INTELLIMATH

Die IntelliMath-Funktionen in Mathcad 8 helfen Ihnen dabei, Routineaufgaben und Standardoperationen schneller auszuführen. Zu den IntelliMath-Funktionen gehören:

  • Die Mathcad-Funktion für automatische Auswahl zur Lösung und Integration, die Ihre Aufgabenstellung analysiert und den jeweils am besten geeigneten Algorithmus auswählt.

  • Optimierung, die über die integrierten numerischen und symbolischen Verarbeitungsmodule die beste Lösung für ein mathematisches Problem sucht.

  • Die Möglichkeit, Einheiten während Ihrer Arbeit automatisch festzuhalten und umzurechnen.


INTERNET-SETUP

Gehen Sie zum Einrichten eines Proxy-Servers folgendermaßen vor:

  1. Wählen Sie den Befehl "Einstellungen" aus dem Menü Ansicht, und klicken Sie im Dialogfeld "Einstellungen" auf die Registerkarte "Internet".

  2. Wenn Sie nicht über einen direkten Internet-Anschluß verfügen, geben Sie einen Proxy-Servernamen für http ein.

  3. Wenn Sie ein anderes Protokoll als http verwenden möchten, geben Sie einen Proxy-Servernamen für das gewünschte Protokoll ein.

  4. Falls erforderlich, geben Sie die Port-Nummern für die verschiedenen Proxy-Server ein. Lassen Sie diese Felder leer, wenn Sie die Standardwerte übernehmen möchten.


FUNKTION "INTERP"

Die Funktion interp wird in verschiedenen Anwendungen verwendet:

Kubische Spline-Interpolation

Multivariable kubische Spline-Interpolation

Polynomregression

Multivariable Polynomregression


INTERPOLATIONS- UND PROGNOSEFUNKTIONEN

linterp(vx, vy, x)

Interpolierter Wert bei x, wenn die Punkte von vx und vy mit geraden Linien verbunden sind.

lspline(vx, vy)

Kubische Spline-Interpolation mit linearen Endbedingungen. Gibt den Vektor vs für die Verwendung mit der unten aufgeführten Interpolationsfunktion zurück.

pspline(vx, vy)

Kubische Spline-Interpolation mit parabolischen Endbedingungen. Gibt den Vektor vs für die Verwendung mit der unten aufgeführten Interpolationsfunktion zurück.

kspline(vx, vy)

Kubische Spline-Interpolation mit kubischen Endbedingungen. Gibt den Vektor vs für die Verwendung mit der unten aufgeführten Interpolationsfunktion zurück.

bspline(vx, vy, u, n)

B-Spline-Interpolation n-ten Grades; die gegebenen Knoten werden durch die Werte in u angegeben Gibt den Vektor vs für die Verwendung mit der unten aufgeführten Interpolationsfunktion zurück.

interp(vs, vx, vy, x)

Gibt den interpolierten Wert von x durch Spline-Interpolation zurück. vs ist der Vektor, der durch lspline, pspline, kspline oder bspline zurückgegeben wird.

prognose(v,m,n)

Gibt n prognostizierte Werte auf der Basis von m aufeinanderfolgenden Elementen in v zurück.


Unterbrechen der Berechnung

UNTERBRECHEN EINER BERECHNUNG

Zum Unterbrechen einer Berechnung gehen Sie wie folgt vor:

Drücken Sie die Esc-Taste.

Es wird eine Fehlermeldung angezeigt, in der die unterbrochene Gleichung angegeben wird.

Zum Wiederaufnehmen der Berechnung gehen Sie wie folgt vor:

Wählen Sie den Befehl Berechnen aus dem Menü Rechnen.


Inverse Fourier-Transformation komplexer Daten

INVERSE FOURIER-TRANSFORMATION

icfft(A) Gibt die inverse Fourier-Transformation analog zu cfft zurück.

Argumente:

A kann sowohl ein Vektor als auch eine Matrix sein.


Inverse Fourier-Transformation komplexer Daten (alternative Form)

INVERSE FOURIER-TRANSFORMATION

ICFFT(B) Gibt die inverse Fourier-Transformation analog zu CFFT zurück.

Argumente:

B kann sowohl ein Vektor als auch eine Matrix sein.


INVERSE FOURIER-TRANSFORMATION REELLER DATEN

ifft(u) Gibt die inverse Fourier-Transformation analog zu fft zurück. Das Ergebnis ist ein aus [image] Elementen bestehender Vektor, dessen k-tes Element gegeben ist durch:

Dabei gibt n die Anzahl von Elementen in v an, und i ist die imaginäre Einheit.

Argumente:

u ist ein Vektor mit [image] Elementen (m>2).

Hinweise:

  • Benutzen Sie diese Funktion nur, wenn die Ausgangsdaten rein reell sind. Bei komplexen Ausgangsdaten ist statt dessen icfft zu verwenden.

  • Diese Funktion arbeitet mit einem hocheffizienten Algorithmus für die schnelle Fourier-Transformation. Damit dies möglich ist, muß der mit ifft verwendete Vektor [image] Elemente haben. Handelt es sich bei den Vektoren um komplexe Werte oder verfügen die Vektoren über eine andere Anzahl von Elementen, verwenden Sie statt dessen icfft.

  • Soll eine zweidimensionale Fourier-Transformation ausgeführt werden, ist statt dessen ebenfalls icfft zu verwenden.

  • Wenn Sie fft verwenden, um zum Frequenzbereich zu gelangen, können Sie nur mit ifft zum Zeitbereich zurückkehren.


Inverse Fourier-Transformation reller Daten (alternative Form)

INVERSE FOURIER-TRANSFORMATION REELLER DATEN

IFFT(u) Gibt die inverse Fourier-Transformation analog zu FFT zurück. Das Ergebnis ist ein aus [image] Elementen bestehender Vektor, dessen k-tes Element gegeben ist durch:

Dabei gibt n die Anzahl von Elementen in v an, und i ist die imaginäre Einheit.

Argumente:

u ist ein Vektor mit [image] Elementen (m>2).

Benutzen Sie diese Funktion nur, wenn die Ausgangsdaten rein reell sind. Bei komplexen Ausgangsdaten ist statt dessen ICFFT zu verwenden.


INVERSE FOURIER-TRANSFORMATION

Zur Auswertung der inversen Fourier-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie Transformation / Fourier invers aus dem Menü Symbolik.

Mathcad gibt bei inversen Fourier-Transformationen eine Funktion in der Variable t zurück. Wenn der zu transformierende Ausdruck bereits ein t enthält, wird statt dessen eine Funktion in der Variable tt zurückgegeben. Mit Hilfe des Befehls Variable / Ersetzen können Sie t durch eine andere Variable bzw. einen anderen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


INVERSE HYPERBOLISCHE FUNKTIONEN

arsinh(z) acoth(z)

arcosh(z) acsch(z)

artanh(z) asech(z)

Argumente:

z muß ein Skalar sein.

z muß dimensionslos sein

Die zurückgegebenen Werte stammen aus dem Hauptzweig dieser Funktionen.

Verwandte Themen

Felder als Argumente

Rundungsfehler bei numerischen Angaben


INVERSE LAPLACE-TRANSFORMATION

Zur Auswertung der inversen Laplace-Transformation einer Funktion gehen Sie wie folgt vor:

Geben Sie den zu transformierenden Ausdruck ein.

Klicken Sie auf die Transformationsvariable.

Wählen Sie Transformation / Laplace invers aus dem Menü Symbolik.

Mathcad gibt bei inversen Laplace-Transformationen eine Funktion in der Variable t zurück. Wenn der zu transformierende Ausdruck bereits ein t enthält, wird statt dessen eine Funktion in der Variable tt zurückgegeben. Mit Hilfe des Befehls Variable / Ersetzen können Sie t durch eine andere Variable bzw. einen anderen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


INVERSE TRIGONOMETRISCHE FUNKTIONEN

asin(z) acsc(z)

acos(z) asec(z)

atan(z) acot(z)

atan2(x,y)

Argumente:

z muß ein Skalar sein.

z muß dimensionslos sein.

x und y sind Skalare.

Zurückgegebene Werte:

  • asin(z), atan(z), asec(z), acsc(z), acot(z) geben Winkelwerte in Radiant zwischen -pi/2 und pi zurück, wenn z real ist.

  • atan2(x,y) gibt einen Winkel (in Radiant ) zwischen -pi und pi (aber nicht -pi) von der x-Achse zu einer Linie zurück, die den Ursprung (0,0) und den Punkt (x,y) enthält.

  • acos(z) gibt einen Winkelwert in Radiant zwischen 0 und pi zurück, wenn z reell ist.

  • Die zurückgegebenen Werte stammen aus dem Hauptzweig dieser Funktionen.


INVERSE Z-TRANSFORMATION

Zur Auswertung der inversen z-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie Transformation / Z invers aus dem Menü Symbolik.

Mathcad gibt bei inversen z-Transformationen eine Funktion in der Variable n zurück. Wenn der zu transformierende Ausdruck bereits ein n enthält, wird statt dessen eine Funktion in der Variable nn zurückgegeben. Mit dem Befehl Variable / Ersetzen können Sie n durch eine andere Variable oder einen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


Funktion "IsArray"

FUNKTION "IsArray" (nur in Mathcad Professional)

IsArray(x) Gibt 1 zurück, wenn x eine Matrix oder ein Vektor ist. Andernfalls wird 0 zurückgegeben.

Argumente:

x ist ein Wert, ein Feld oder eine Zeichenfolge.

Beispiel:

Diese Funktion eignet sich am besten zur Verwendung in einer Bedingungsanweisung in einem Programm.


Funktion "IsScalar"

FUNkTION "IsScalar" (nur in Mathcad Professional)

IsScalar(x) Gibt 1 zurück, wenn x ein reeller oder komplexer Skalar ist. Andernfalls wird 0 zurückgegeben.

Argumente:

x ist ein Wert, ein Feld oder eine Zeichenfolge.

Beispiel:

Diese Funktion eignet am besten zur Verwendung in einer Bedingungsanweisung in einem Programm.


Funktion "IsString"

FUNKTION "IsString" (nur in Mathcad Professional)

IsString(x) Gibt 1 zurück, wenn x eine Zeichenfolge ist. Andernfalls wird 0 zurückgegeben.

Argumente:

x ist ein Wert, ein Feld oder eine Zeichenfolge.

Beispiel:

Diese Funktion eignet sich am besten zur Verwendung in einer Bedingungsanweisung in einem Programm.


ITERATION ÜBER EINEN WERTEBEREICH

Jede einmal durchführbare Berechnung ist auch über einen Bereich von Werten möglich. Nehmen wir beispielsweise an, Sie möchten eine Liste von x- und y-Werten für Punkte auf der Kreiskurve "r=cos(q) + 1" erstellen. Die Grundidee ist hier:

q soll Werte zwischen 0 und 2p annehmen. Definieren Sie q als Bereichsvariable oder als Vektor.

Für jedes q ergibt sich das entsprechende r aus "r=cos(q) + 1".

Für jedes r und q gilt, daß x und y durch die Gleichungen "x=r*cos(q)" und "y=r*sin(q)" bestimmt werden.

Dies kann mit Funktionen oder durch Definition von Vektoren erreicht werden.

Verwenden von Funktionen: | Verwenden von Vektoren:


Jacobische Polynom-Funktion

JACOBISCHE POLYNOM-FUNKTION (nur in Mathcad Professional)

Jac(n,a,b,x) Gibt den Wert des Jacobischen Polynoms n-ten Grades bei x mit den Parametern a und b zurück.

Argumente:

n ist eine nicht-negative ganze Zahl.

a und b sind reelle Skalare größer als -1.

x ist ein reeller Skalar.

Das Jacobische Polynom ist eine Lösung der folgenden Differentialgleichung:

Beachten Sie, daß das Tschebyscheffsche und das Legendresche Polynom Sonderfälle des Jacobischen Polynoms sind.


VERBINDEN VON FELDERN

erweitern(A,B) Gibt ein Feld zurück, das entsteht, indem B rechts neben A angeordnet wird.

stapeln(A, B) Gibt ein Feld zurück, das entsteht, indem B unterhalb von A angeordnet wird.

Argumente:

A und B müssen beide Vektoren oder Matrizen sein.

A und B müssen bei erweitern dieselbe Anzahl von Zeilen und bei stapeln dieselbe Anzahl von Spalten haben.


SCHLÜSSELWORT "annehmen"

Zur Berechnung eines Ausdrucks, der auf bestimmten Annahmen beruht, verwenden Sie das Schlüsselwort annehmen.

Soll Mathcad annehmen, daß eine Variable reell ist, geben Sie nach dem Schlüsselwort var=reell ein, wobei var für die Variable steht, die Sie eingeben.

Soll Mathcad annehmen, daß eine Variable reell ist und zwischen den reellen Zahlen a und b liegt, geben Sie nach dem Schlüsselwort var=ReellBereich(a,b) ein, wobei var für die Variable steht, die Sie eingeben.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "koeff"

Zum Umformen einer Gleichung in ein Polynom können Sie das Schlüsselwort koeff verwenden:

  1. Geben Sie den Ausdruck ein, der umgeformt werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort koeff ein.

  4. Geben Sie ein Komma und dann die Variable bzw. Funktion ein, für die Ihr Ausdruck als Polynom gelten soll.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "konvert"

Zum Umformen einer Gleichung in einen Teilbruch, können Sie das Schlüsselwort konvert zusammen mit teilbruch verwenden:

  1. Geben Sie den Ausdruck ein, der umgewandelt werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie konvert,teilbruch ein.

  4. Geben Sie ein Komma und dann die Variable im Nenner des Ausdrucks ein, der umgeformt werden soll.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "sammeln"

Sie können einen Ausdruck vereinfachen, indem Sie eine Summe von Termen als Polynom einer bestimmten Variable angeben:

Geben Sie den zu vereinfachenden Ausdruck ein.

Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

Geben Sie das Schlüsselwort sammeln ein.

Geben Sie ein Komma und danach die Variable bzw. den Ausdruck ein, nach der bzw. dem zusammengefaßt werden soll.

Drücken Sie die Eingabetaste.

Dadurch wird die Summe zu einem Polynom in der Variable bzw. Funktion umgeformt.

QuickSheet-Beispiel starten

Weitere Schlüsselwörter...


SCHLÜSSELWORT "komplex"

Im Normalfall gibt Mathcad symbolische Ergebnisse so weit vereinfacht wie möglich zurück. Zuweilen, vor allem bei der Arbeit mit komplexen Zahlen, ist es jedoch wünschenswert, die Ergebnisse in ihren jeweiligen Real- und Imaginärteil zerlegt zu sehen. Verwenden Sie das Schlüsselwort komplex, um Mathcad zur Ausgabe der Ergebnisse in der Form (a+i*b) anzuweisen, soweit dies möglich ist.

QuickSheet-Beispiel starten

Weitere Schlüsselwörter...


SCHLÜSSELWORT "entwickeln"

Verwenden Sie das Schlüsselwort entwickeln, um alle Potenzen und Produkte von Summen im markierten Ausdruck zu entwickeln. Soll ein Ausdruck in einer bestimmten Variable entwickelt werden, geben Sie nach dem Schlüsselwort "entwickeln" ein Komma und dann die Variable ein.

Sie können einen Ausdruck auch mit dem Befehl Entwickeln im Menü Symbolik entwickeln.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "faktor"

Verwenden Sie das Schlüsselwort faktor, wenn Sie einen Ausdruck in ein Produkt transformieren möchten. Auf diese Weise können Sie die folgenden Transformationen festlegen:

Polynom in ein Produkt aus Polynomen

ganze Zahl in ein Produkt aus Primzahlen

Summe aus rationalen Ausdrücken in einen einzigen Bruch

Soll ein Radikal faktorisiert werden, geben Sie nach dem Schlüsselwort faktor ein Komma und dann ein Radikal oder mehrere, durch Kommas getrennte Radikale ein.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "gleit"

Verwenden Sie das Schlüsselwort gleit, wenn Mathcad statt eines symbolischen Ergebnisses nach Möglichkeit eine Gleitkommazahl ausgeben soll.

Durch die Angabe einer ganzen Zahl hinter dem Schlüsselwort gleit können Sie festlegen, wie viele Stellen der Gleitkommazahl angezeigt werden sollen.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "fourier"

Verwenden Sie das Schlüsselwort fourier, wenn die inverse Z-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort fourier ein.

  4. Geben Sie ein Komma und die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort fourier gibt eine Funktion in der Variable w aus. Wenn der zu transformierende Ausdruck bereits ein w enthält, wird statt dessen eine Funktion in der Variable ww zurückgegeben, um jegliche Zweideutigkeit zu vermeiden. Mit dem Schlüsselwort ersetzen ersetzen Sie w durch eine andere Variable oder einen anderen Ausdruck.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "invfourier"

Verwenden Sie das Schlüsselwort invfourier, wenn die inverse Z-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort invfourier ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort invfourier gibt eine Funktion in der Variable t aus. Wenn der zu transformierende Ausdruck bereits ein t enthält, wird statt dessen eine Funktion in der Variable tt zurückgegeben. Mit dem Schlüsselwort ersetzen können Sie t durch eine andere Variable oder einen anderen Ausdruck ersetzen.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "invlaplace"

Verwenden Sie das Schlüsselwort invlaplace zu, wenn die inverse Laplace-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort invlaplace ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort invlaplace gibt eine Funktion in der Variable t aus. Wenn der zu transformierende Ausdruck bereits ein t enthält, wird statt dessen eine Funktion in der Variable tt zurückgegeben. Mit dem Schlüsselwort ersetzen können Sie t durch eine andere Variable oder einen anderen Ausdruck ersetzen.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "invztrans"

Verwenden Sie das Schlüsselwort invztrans, wenn die inverse Z-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort invztrans ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort invztrans gibt eine Funktion in der Variable n aus. Wenn der zu transformierende Ausdruck bereits ein n enthält, wird statt dessen eine Funktion in der Variable nn zurückgegeben. Mit dem Schlüsselwort ersetzen können Sie n durch eine andere Variable oder einen anderen Ausdruck ersetzen.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "laplace"

Verwenden Sie das Schlüsselwort laplace, wenn die Laplace-Transformation einer Funktion ausgewertet werden soll:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort laplace ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort laplace gibt eine Funktion in der Variable s aus. Wenn der zu transformierende Ausdruck bereits ein s enthält, wird statt dessen eine Funktion in der Variable ss zurückgegeben. Mit dem Schlüsselwort ersetzen können Sie s durch eine andere Variable oder einen anderen Ausdruck ersetzen.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "reihe"

Verwenden Sie das Schlüsselwort reihe, gefolgt von einer Variable, wenn ein Ausdruck in eine Reihe entwickelt werden soll, falls diese Variable den Wert Null annimmt.

Mit dem Schlüsselwort reihe werden bei Funktionen, die bei 0 analytisch sind, Taylorsche Reihen (Reihen in nichtnegativen Potenzen der Variable) und bei Funktionen, die bei 0 einen Pol endlicher Ordnung haben, Laurentsche Reihen entwickelt. Für Reihenentwicklungen um einen anderen Punkt als Null sind logische Gleichheitszeichen zu verwenden.

So führt

x+y reihe,x=2

eine Reihenentwicklung um den Punkt x=2 durch.

Hinweise:

  • Mit dem Schlüsselwort reihe wird eine Reihe 6. Ordnung entwickelt. Soll eine andere Ordnung für die Reihenentwicklung festgelegt werden, muß der Reihenentwicklungsvariable ein Komma und eine ganze Zahl (zur Angabe der Ordnung) nachfolgen. Bei der Ordnung handelt es sich um die Ordnung des Fehlerterms in der Reihenentwicklung. Wenn Mathcad z. B. sin(x) in eine Reihe in x entwickelt, gibt es eine Reihenentwicklung der Sinusfunktion in Potenzen von x zurück, wobei die höchste Potenz x5 ist. Der Fehler ist also O(x6).

  • Soll eine Reihe um mehr als eine Variable entwickelt werden, fügen Sie nach dem Schlüsselwort reihe ein Komma und die Variablen ein, die jeweils voneinander durch ein Komma getrennt sein müssen.

  • Durch Nutzung der Annäherungen, die Sie vom symbolischen Prozessor erhalten, kann es passieren, daß die Taylorsche Reihe bei einer Funktion nur in einem kleinen Intervall um den Mittelpunkt herum konvergiert. Hinzu kommt, daß Funktionen wie sin oder exp Reihen mit unbegrenzt vielen Termen haben, während die von Mathcad zurückgegebenen Polynome nur über einige wenige Terme verfügen (die genaue Anzahl hängt von der von Ihnen festgelegten Ordnung ab). Daher gilt für Annäherungen einer Funktion durch das von Mathcad zurückgegebene Polynom, daß die Annäherung in der Nähe des Mittelpunkts ausreichend genau ist, mit steigender Entfernung vom Mittelpunkt aber immer ungenauer werden kann.

  • Eine andere Möglichkeit, eine Reihe zu entwickeln, besteht darin, den Ausdruck einzugeben und dann auf die Variable zu klicken, für die Sie eine Reihenentwicklung finden möchten. Wählen Sie als nächstes Variable / Reihenentwicklung aus dem Menü Symbolik. In dem daraufhin erscheinenden Dialogfeld werden Sie aufgefordert, die Ordnung der Reihe festzulegen. Dieser Befehl steht nur für Reihen in einer einzelnen Variable zur Verfügung; alle anderen Variablen des Ausdrucks werden als Konstanten behandelt. Die Ergebnisse enthalten darüber hinaus den Fehler-Term, dargestellt mittels O-Notation. Löschen Sie diesen Fehler-Term, bevor Sie diese Reihe für weitere Berechnungen verwenden.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "vereinfachen"

Verwenden Sie das Schlüsselwort vereinfachen, um eine einfache algebraische Vereinfachung durchzuführen und trigonometrische und inverse Funktionsidentität anzuwenden.

  • Wenn Sie einen Ausdruck vereinfachen möchten, bei dem anzunehmen sei, daß die Unbestimmten reell sind, fügen Sie nach dem Schlüsselwort vereinfachen den Terminus annehmen=reell ein.

  • Wenn Sie einen Ausdruck vereinfachen möchten, bei dem anzunehmen sei, daß die Unbestimmten reell sind und zwischen den Werten a und b liegen, fügen Sie nach dem Schlüsselwort vereinfachen den Terminus annehmen=ReellBereich(a,b) ein, wobei für a und b reelle Zahlen bzw. unendlich eingegeben werden muß.

  • Sie können einen trigonometrischen Ausdruck vereinfachen, indem Sie eine der folgenden Identitäten anwenden:

Geben Sie nach dem Schlüsselwort vereinfachen den Terminus trig ein.

Sie können ein Ergebnis auch mit dem Befehl Vereinfachen im Menü Symbolik vereinfachen.

Weitere Schlüsselwörter...


Schlüsselwort "auflösen"

Verwenden Sie das Schlüsselwort auflösen, wenn ein Ausdruck symbolisch nach einer Variable aufgelöst werden soll:

  1. Geben Sie die Gleichung ein. Geben Sie das Gleichheitszeichen mit der Tastenkombination Strg+Gleichheitszeichen ein.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort auflösen ein.

  4. Geben Sie ein Komma und dann die Variable ein, nach der der Ausdruck aufgelöst werden soll.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Zum symbolischen Lösen eines Gleichungssystems gehen Sie wie folgt vor:

  1. Erstellen Sie einen Vektor mit n Zeilen und 1 Spalte, und fügen Sie in die Elementplatzhalter die Gleichungen des Systems ein. Geben Sie das Gleichheitszeichen mit der Tastenkombination Strg+Gleichheitszeichen ein.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort auflösen ein.

  4. Erstellen Sie einen Vektor mit n Zeilen und 1 Spalte, und fügen Sie in die Elementplatzhalter die Variablen ein, nach denen der Ausdruck aufgelöst werden soll.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "ersetzen"

Zum Ersetzen einer Variable im gesamten Arbeitsblatt durch eine andere Variable, einen Ausdruck oder eine Zahl gehen Sie folgendermaßen vor:

  1. Geben Sie den Ausdruck ein, der die zu ersetzende Variable enthält.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort ersetzen ein.

  4. Geben Sie ein Komma und dann eine Gleichung der Form var1=var2 ein, wobei var1 die Variable ist, die durch var2 ersetzt werden soll. Geben Sie das Gleichheitszeichen mit der Tastenkombination Strg+Gleichheitszeichen ein.

  5. Drücken Sie die Eingabetaste, um sich das Ergebnis anzeigen zu lassen.

Diese Operation kann einen unübersichtlichen Ausdruck ergeben. Sie können das Ergebnis jedoch mit dem Schlüsselwort vereinfachen kürzen.

Beachten Sie, daß dieser Befehl nur funktioniert, wenn Sie eine Variable durch einen Ausdruck ersetzen wollen. Dieser Befehl kann nicht verwendet werden, um einen Ausdruck durch einen anderen zu ersetzen. Zum Ersetzen von Ausdrücken durch andere Ausdrücke müssen Sie die Befehle Ausschneiden und Einfügen aus dem Menü Bearbeiten verwenden.

Weitere Schlüsselwörter...


SCHLÜSSELWORT "ztrans"

Mit dem Schlüsselwort ztrans werten Sie die Z-Transformation einer Funktion aus:

  1. Geben Sie die Funktion ein, die ausgewertet werden soll.

  2. Drücken Sie Strg+Umschalt+Punkt, um einen Platzhalter und das symbolische Gleichheitszeichen einzufügen.

  3. Geben Sie das Schlüsselwort ztrans ein.

  4. Geben Sie ein Komma und dann die Variable ein, in der die Transformation erfolgen soll.

  5. Drücken Sie die Eingabetaste.

Das Schlüsselwort ztrans gibt eine Funktion in der Variable z aus. Wenn der zu transformierende Ausdruck bereits ein z enthält, wird statt dessen eine Funktion in der Variable zz ausgegeben. Mit dem Schlüsselwort ersetzen können Sie z durch eine andere Variable oder einen anderen Ausdruck ersetzen.

Weitere Schlüsselwörter...


Knoten

Die "Knoten", die bei der B-Spline-Interpolation verwendet werden, sind die Werte, an denen die einzelnen Polynome aneinander angepaßt sind. Im Unterschied dazu handelt es sich bei den Knoten der anderen Splines stets um die x-Werte.


KRONECKER-SYMBOL-FUNKTION

(m,n) Gibt 1 zurück, wenn m = n ist. Andernfalls wird 0 zurückgegeben.

Argumente:

m und n müssen ganze Zahlen ohne Einheiten sein.

Da diese Funktion bei 0 eine Unstetigkeit aufweist, sollten Sie Ausdrücke, die diese Funktion einschließen, nicht über ein Intervall mit 0 integrieren. Statt dessen empfiehlt es sich, den Integrationsbereich in zwei Teilbereiche aufzuteilen, über jeden Bereich einzeln zu integrieren und die Ergebnisse dann zu addieren.

Aus demselben Grund ist die Ableitung dieser Funktion bei 0 nicht definiert.


WÖLBUNGSFUNKTION

Argumente:

A ist ein Vektor oder eine Matrix mit n Elementen. n [image] 4.

Die Standardableitung von A muß ungleich Null sein.

Hinweise:

  • Die Wölbung bestimmter Werte zeigt an, wie flach oder gewölbt eine Verteilung im Vergleich zur Normalverteilung ist. kurt(A)>0 zeigt an, daß die Verteilung relativ stark gewölbt ist. kurt(A)<0 zeigt an, daß die Verteilung relativ flach ist.

  • kurt(A)=1 steht für eine normale Verteilung.

Weitere Funktionen für die Datenanalyse...


BENENNEN VON ACHSEN IN EINEM KREISDIAGRAMM

Zum Benennen einer Achse in einem Diagramm gehen Sie wie folgt vor:

  1. Öffnen Sie durch Doppelklicken oder durch Wählen von Diagramm / Kreisdiagramm im Menü Format ein Dialogfeld mit Registerkarten.

  2. Klicken Sie auf die Registerkarte Beschriftungen.

  3. Geben Sie in diesem Dialogfeld eine Beschriftung für eine oder beide Achsen ein. Sie können hierbei Groß- und Kleinschreibung verwenden.

  4. Klicken Sie auf "OK", damit die festgelegten Beschriftungen angezeigt werden.

Um die Beschriftung aus den Textfeldern zu löschen, klicken Sie auf "Abbrechen", damit der Originalzustand der Textfelder für die Beschriftungen wiederhergestellt wird.

Zum vollständigen Löschen der Beschriftungen verwenden Sie die Rücktaste.


BESCHRIFTEN DER ACHSEN IN EINEM X-Y-DIAGRAMM

Zum Beschriften einer Achse in einem Diagramm gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Diagramm, oder wählen Sie Diagramm / X-Y-Diagramm im Menü Format, damit ein Dialogfeld mit Registerkarten geöffnet wird.

  2. Klicken Sie auf die Registerkarte Beschriftungen.

  3. Geben Sie in diesem Dialogfeld eine Beschriftung für eine oder beide Achsen ein. Sie können hierbei Groß- und Kleinschreibung verwenden.

  4. Klicken Sie auf "OK", damit die festgelegten Beschriftungen angezeigt werden.

Um die Beschriftung aus den Textfeldern zu löschen, klicken Sie auf "Abbrechen", damit der Originalzustand der Textfelder für die Beschriftungen wiederhergestellt wird.

Zum vollständigen Löschen der Beschriftungen verwenden Sie die Rücktaste.


Laguerresche Polynom-Funktion

LAGUERRESCHE POLYNOM-FUNKTION (nur in Mathcad Professional)

Lag(n,x) Gibt den Wert des Laguerreschen Polynoms n-ten Grades bei x zurück.

Argumente:

n ist eine nicht-negative ganze Zahl.

x ist ein reeller Skalar.

Das Laguerresche Polynom ist eine Lösung der folgenden Differentialgleichung:


LAPLACE-TRANSFORMATION

Zur Auswertung der Laplace-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie Transformation / Laplace im Menü Symbolik.

Mathcad gibt bei Laplace-Transformationen eine Funktion in der Variable s zurück. Wenn der zu transformierende Ausdruck bereits ein s enthält, wird statt dessen eine Funktion in der Variable ss zurückgegeben. Mit Hilfe des Befehls Variable ersetzen können Sie s durch eine andere Variable bzw. einen anderen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


KLEINSTES GEMEINSAMES VIELFACHES

lcm(A) Gibt das kleinste gemeinsame Vielfache, also die kleinste positive ganze Zahl zurück, die ein Vielfaches aller Werte in A ist.

Argumente:

A ist ein Vektor oder eine Matrix.

Die Elemente in A müssen reelle ganze Zahlen größer als 1 sein.

Beispiele:


Funktion für linke Inverse

FUNKTION FÜR LINKE INVERSE (nur in Mathcad Professional)

geninv(A) Gibt die linke inverse Matrix L von A zurück, so daß gilt:

Argumente:

A muß ein m x n Elemente großes Feld sein, wobei m [image] n ist.

A muß reelle Werte enthalten.


LEGENDENEINSTELLUNGEN IN KREISDIAGRAMMEN

Zum Erstellen einer Legende zur Identifizierung einer Spur gehen Sie wie folgt vor:

Doppelklicken Sie auf ein Diagramm, oder wählen Sie Diagramm / Kreisdiagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

Klicken Sie gegebenenfalls auf das Register Spuren.

Weisen Sie den einzelnen Spuren Namen zu, indem Sie auf die in der Spalte "Legendenname" aufgeführten Standardnamen in der Auswahlliste im Dialogfeld klicken. Der Name erscheint im Textfeld unter dieser Spalte.

Geben Sie zum Ändern des Names der Spur den neuen Namen im Textfeld unter der Spalte "Legendenname" ein.

Mit dem Kontrollkästchen "Legende ausblenden" können Sie festlegen, ob die Legende angezeigt oder ausgeblendet wird.

Mit dem Kontrollkästchen "Argumente ausblenden" können Sie festlegen, ob die für die Erstellung des Diagramms verwendeten Ausdrücke ebenfalls angezeigt werden.

Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld auszublenden.


LEGENDENEINSTELLUNGEN (X-Y-DIAGRAMME)

Zum Erstellen einer Legende zur Identifizierung einer Spur gehen Sie wie folgt vor:

Doppelklicken Sie auf ein Diagramm, oder wählen Sie Diagramm / X-Y-Diagramm im Menü Format, damit ein Dialogfeld mit Registerkarten geöffnet wird.

Klicken Sie gegebenenfalls auf die Registerkarte Spuren.

Weisen Sie den einzelnen Spuren Namen zu, indem Sie in der Spalte Legendenname der Liste in der Mitte des Dialogfelds auf die Standardnamen klicken. Der Name erscheint im Textfeld unter dieser Spalte.

Zum Ändern des Namens der Spur geben Sie den neuen Namen in dem Textfeld unter der Spalte "Legendenname" ein.

Mit dem Kontrollkästchen "Legende ausblenden" können Sie festlegen, ob die Legende angezeigt oder ausgeblendet werden soll.

Mit dem Kontrollkästchen "Argumente ausblenden" können Sie festlegen, ob die Ausdrücke, mit denen das Diagramm erstellt wurde, ebenfalls angezeigt werden.

Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Legendresche Polynom-Funktion

LEGENDRESCHE POLYNOM-FUNKTION (nur in Mathcad Professional)

Leg(n,x) Gibt den Wert des Legendreschen Polynoms n-ten Grades bei x zurück.

Argumente:

n ist eine nicht-negative ganze Zahl.

x ist ein reeller Skalar.

Das Legendresche Polynom ist eine Lösung der folgenden Differentialgleichung:


Operator "Kleiner als"

KLEINER ALS

Tastaturbefehl: <

x < y Gibt 1 zurück, wenn x < y, andernfalls 0.

Operanden:

x und y müssen reelle Skalare sein.


Operator "Kleiner gleich"

KLEINER GLEICH

Tastaturbefehl: Strg+9

x [image] y Gibt 1 zurück, wenn x [image] y, andernfalls 0.

Operanden:

x und y müssen reelle Skalare sein.


LÖSEN MIT DER LEVENBERG-MARQUARDT-METHODE

Die iterative Levenberg-Marquardt-Methode kann bei Lösungsprozessen zum Einsatz kommen, die durch die Funktionen minimieren, maximieren, suchen bzw. minfehl aufgerufen werden. Die Methode umfaßt folgendes:

Fehlervektor

Einzelschritte bei der Levenberg-Marquardt-Methode

Abbruchkriterien

Mathcad-Abweichungen von der Levenberg-Marquardt-Methode

Die Mathcad-Methode wurde dem Public Domain-Paket "MINPACK Algorithms" entnommen, das von Argonne National Laboratory in Argonne, Illinois (USA) entwickelt und veröffentlicht wurde. Weitere Informationen dazu siehe "User's Guide to Minpack I" von Jorge J. More, Burton S. Garbow und Kenneth E. Hillstrom, Argonne National Laboratory Publication ANL-80-74, 1980.


BELEUCHTEN EINES 3D-DIAGRAMMS

Überblick

Beleuchtung ist eine Möglichkeit, die Farbe und Schattierung eines 3D-Diagramms festzulegen, genau wie sich Beleuchtung in der Realität auf die Farbe von Objekten auswirkt.

In der Realität wird die Farbe eines Objekts ebenso von seiner Farbe wie dem Umgebungslicht bestimmt. Beispielsweise kann eine gelbe Kugel in trübem Licht gräulich aussehen, während das Gelb bei hellerer Beleuchtung klarer wird. Dies liegt daran, daß ein Objekt bei Lichteinwirkung das Licht je nach Farbe spiegelt und absorbiert. Zum Beispiel wird blaues Licht von einem blauen Objekt größtenteils reflektiert, während andere Farben absorbiert werden.

Die Farbe eines Diagramms hängt in gleichem Maß von der Farbe der Füllung ab wie von dem Licht, mit dem es beleuchtet wird. Sie können einem Diagramm Farbe zuweisen, indem Sie es mit einer Volltonfarbe füllen oder eine Farbzuordnung verwenden. Wenn Sie dann Beleuchtung aktivieren, kann sich die Farbe des Diagramms entsprechend der festgelegten Art und Farbe des Lichts ändern.

Lichteinstellungen

Licht auf einem Diagramm besteht aus:

  • Umgebungslicht

  • Gerichtetem Licht

Zum Festlegen der Beleuchtung für ein 3D-Diagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf das Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Beleuchtung", damit die Seite "Beleuchtung" angezeigt wird.

3. Mit den Optionen auf dieser Seite haben Sie folgende Möglichkeiten:

Aktivieren von Beleuchtung

Festlegen der Umgebungslichtfarbe

Wählen eines Beleuchtungsschemas

Festlegen der gestreuten Farbe und der Glanzfarbe eines gerichteten Lichts

Festlegen der Position eines gerichteten Lichts

Positionieren eines Lichts in großer Entfernung

3. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


GRENZWERTE

Zur Berechnung des Grenzwerts eines Ausdrucks gehen Sie folgendermaßen vor:

1. Drücken Sie Strg+L, um den Operator "Grenzwert" zu erstellen.

Drücken Sie Strg+Umschalt+B für einen Grenzwert von links.

Drücken Sie Strg+Umschalt+A für einen Grenzwert von rechts.

2. Geben Sie den Ausdruck in den Platzhalter rechts neben "lim" ein.

3. Geben Sie die Grenzwertvariable in den linken Platzhalter unterhalb von "lim" ein.

4. Geben Sie den Grenzwert in den rechten Platzhalter unterhalb von "lim" ein.

5. Drücken Sie die Leertaste, bis sich der gesamte Ausdruck zwischen den Bearbeitungslinien befindet.

6. Wählen Sie den Befehl Vereinfachen im Menü Symbolik.

Falls der Grenzwert nicht existiert, wird eine Fehlermeldung angezeigt.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


BESCHRÄNKUNGEN BEI BEREICHSVARIABLEN

Einige Bereichsvariablendefinitionen sind nicht zugelassen. Es gelten folgende Beschränkungen:

Die Zahl unmittelbar nach dem Komma (soweit vorhanden) muß zwischen den beiden anderen Zahlen liegen.

Alle Zahlen in der Definition müssen reelle Zahlen sein.

Die Dimensionen aller Zahlen (soweit vorhanden) im Bereich müssen übereinstimmen.

Eine Bereichsvariable kann nicht über eine andere Bereichsvariable definiert werden.

Eine Bereichsvariable kann nicht über eine Matrix oder einen Vektor definiert werden.


Einschränkungen beim Kopieren von numerischen Ergebnissen

EINSCHRÄNKUNGEN BEIM KOPIEREN VON ERGEBNISSEN

Wenn Sie das Ergebnis einer Berechnung in die Zwischenablage kopieren, weicht es dort in folgenden Punkten vom ursprünglichen Ergebnis des Arbeitsblatts ab:

Alle Zahlen in der Zwischenablage enthalten nur so viele Ziffern wie im ursprünglichen Ergebnis angezeigt wurden.

Mit dem Ergebnis verknüpfte Einheiten werden nicht in die Zwischenablage kopiert.

Nachfolgende Nullen werden nicht kopiert.

Verschachtelte Felder in einem Ergebnis werden als Nullen kopiert.


LINIENEINSTELLUNGEN (3D-SÄULENDIAGRAMME)

Zum Festlegen der Linien in einem 3D-Säulendiagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen auf der Seite "Darstellung" haben Sie folgende Möglichkeiten:

  • Zeichnen eines Rahmens aus Linien um die Säulen

  • Einfärben der Linien mit Volltonfarbe oder entsprechend einer Farbzuordnung

  • Entfernen von Linien aus dem Diagramm

  • Festlegen der Linienstärken

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


LINIENEINSTELLUNGEN (3D-STREUUNGSDIAGRAMME)

Sie können Linien zeichnen, um die Punkte in einem 3D-Streuungsdiagramm zu verbinden:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen auf der Seite "Darstellung" haben Sie folgende Möglichkeiten:

  • Zeichnen einer Linie als Verbindung zwischen den Punkten

  • Einfärben der Linien mit einer Farbe oder entsprechend einer Farbzuordnung.

  • Entfernen von Linien aus dem Diagramm

  • Festlegen der Linienstärke

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf.

Geben Sie zum Festlegen der Methode beim Verbinden von Punkten im Diagramm folgendermaßen vor:

1. Öffnen Sie durch Klicken auf die Registerkarte "Spezial" die Seite "Spezial".

2. Wählen Sie im Abschnitt "Verbindungsart" der Seite "Spezial" den Eintrag Zeilenfolge, Ansteigend X, Ansteigend Y oder Ansteigend Z.

3. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Linieneinstellungen (Umrißdiagramme)

LINIENEINSTELLUNGEN (UMRISSDIAGRAMME)

Zum Festlegen der Linien in einem Umrißdiagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen auf der Seite "Darstellung" haben Sie folgende Möglichkeiten:

  • Zeichnen von Linien mit einer Farbzuordnung

  • Entfernen von Linien aus dem Diagramm

  • Festlegen der Linienstärken

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf.

5. Klicken Sie zum Festlegen der Anzahl der Umrisse in einem Umrißdiagramm auf die Registerkarte "Spezial", um die Seite "Spezial" zu öffnen.

6. Wählen Sie eine Umrißrichtung in dem Dropdown-Menü am unteren Rand des Abschnitts "Umrißoptionen". Verwenden Sie "Z-Umrisse" (außer Sie haben das Umrißdiagramm auf einer anderen Hintergrundebene erstellt).

7. Mit den Optionen im Abschnitt "Umrißoptionen" haben Sie folgende Möglichkeiten:

  • Festlegen der Anzahl der Umrisse

  • Bestimmen, ob die Umrisse mit Zahlen beschriftet werden

8. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


LINIENEINSTELLUNGEN (FLÄCHENDIAGRAMME)

Zum Festlegen der Linien in einem Flächendiagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen auf der Seite "Darstellung" haben Sie folgende Möglichkeiten:

  • Zeichnen eines Rahmens mit Linien in Volltonfarbe oder entsprechend einer Farbzuordnung

  • Zeichnen von ausschließlich Umrißlinien mit einer Farbzuordnung

  • Entfernen von Linien aus dem Diagramm

  • Festlegen der Linienstärken

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


LINIENEINSTELLUNGEN (VEKTORFELDDIAGRAMME)

Zum Formatieren der Linien in einem Vektorfelddiagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf ein Diagramm, um ein Dialogfeld mit Registerkarten zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen auf der Seite "Darstellung" haben Sie folgende Möglichkeiten:

  • Einfärben der Linien mit Volltonfarbe oder entsprechend einer Farbzuordnung

  • Festlegen der Linienstärken

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


LINEARE KOMBINATION VON FUNKTIONEN

linanp(vx,vy,F) Gibt einen Vektor mit den Koeffizienten zurück, die verwendet wurden, um eine lineare Kombination der Funktionen in F zu erstellen, die sich am besten den Daten in vx und vy annähert.

Argumente:

vx ist ein Vektor aus Datenwerten. Diese entsprechen den x-Werten. Die Elemente müssen in aufsteigender Reihenfolge angeordnet sein. Sollte dies nicht der Fall sein, verwenden Sie die Funktion sort, um die Elemente entsprechend zu ordnen.

vy ist ein Vektor aus Datenwerten. Diese entsprechen den y-Werten. vy hat die gleiche Anzahl von Elementen wie vx.

F ist eine Funktion, die einen Vektor zurückgibt, dessen Elemente Funktionen sind, die eine lineare Funktion ergeben. Im Falle einer einzelnen linearen Funktion ist F ein Skalar.

Die Funktion linanp ist hilfreich, wenn Sie eine Gruppe von gemessenen x- und y-Werten haben und Sie Ihre Daten mit einer linearen Kombination beliebiger Funktionen modellieren wollen.

Das folgende Beispiel zeigt die Verwendung von linanp:


LINEARE INTERPOLATION

linterp(vx,vy,x) Gibt einen an x linear interpolierten Wert für die Datenvektoren vx und vy zurück.

Argumente:

vx ist ein Vektor aus reellen Datenwerten in aufsteigender Reihenfolge. Diese entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. vy hat die gleiche Anzahl von Elementen wie vx.

x ist der Wert der unabhängigen Variable, an der ein Ergebnis interpoliert werden soll. Dieser Wert sollte innerhalb des von vx angegebenen Bereichs liegen.

Bei der linearen Interpolation verbindet Mathcad die vorhandenen Datenpunkte durch gerade Linien und interpoliert nach einem bestimmten Wert. Das folgende Beispiel zeigt die Verwendung von linterp:


LÖSEN MIT DER LINEAREN METHODE

Diese Option (die Ihnen in Mathcad Professional zur Verfügung steht) wird verwendet, wenn Sie ein lineares Programm mit der Funktion suchen, minfehl, minimieren oder maximieren lösen und dazu eine lineare Programmierungsmethode benötigen.

Hinweise:

  • Ein lineares Programm verfügt über eine lineare Zielfunktion. Eine lineare Zielfunktion hat die folgende Form: c0*var1+c1*var2+...cn*varn. So ist z. B. die Funktion g(x,y):=x+y linear.

  • Die Bedingungen in einem linearen Programm müssen entweder Gleichungen oder Ungleichungen sein, die lineare Funktionen mit Konstanten vergleichen. Eine gültige Bedingung für ein lineares Programm ist z. B. x+2<5.

  • Wenn Sie die Option Linear wählen, müssen Sie im Gleichungssystem Schätzwerte definieren. Die Schätzwerte sind jedoch immateriell, so daß sie sich nicht auf die Lösung auswirken, es sei denn, es wird nach einem Matrix- oder Vektorergebnis aufgelöst. In diesem Fall gibt der Schätzwert für den Vektor bzw. die Matrix die Größe des zu suchenden Vektors bzw. der zu suchenden Matrix an.

  • Die Option Linear greift bei der Lösung nicht auf die vordefinierte Variable TOL zurück.

Bei der linearen Lösung kommt ein einseitiges Verfahren mit Verzweigungen und Grenzen zum Tragen. Weitere Informationen dazu finden Sie unter "Referenzmaterial zu den Lösungsalgorithmen".


LINEARE REGRESSION

neigung(vx,vy) Neigung der Linie, die am ehesten den Daten in vx und vy entspricht.

achsenabschn(vx,vy) Achsenabschnitt der Linie, die am ehesten den Daten in vx und vy entspricht.

Argumente:

vx ist ein Vektor aus reellen Datenwerten. Für die Funktion neigung ist vx ein Vektor aus reellen Datenwerten. Die Werte in vx entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. vy hat die gleiche Anzahl von Elementen wie vx.

Hinweise:

  • Die Funktionen neigung und achsenabschn sind nicht nur für vom Ursprung her lineare Daten, sondern auch für exponentielle Daten geeignet.

  • Die Gleichung für die Linie, die am ehesten Ihren Daten in vx und vy entspricht, ist y=m.x+b, wobei m das Ergebnis der Funktion neigung und b das Ergebnis der Funktion achsenabschn ist.

Im Beispiel unten wird gezeigt, wie Sie mit Hilfe der Funktionen neigung und achsenabschn eine lineare Regression durchführen können:


Liste der vordefinierten Einheiten

VORDEFINIERTE EINHEITEN

Dies ist die vollständige Liste der verfügbaren integrierten Einheiten. Mit Ausnahme der unterstrichenen Einheiten sind alle Einheiten in mindestens einem der Systeme SI, MKS, CGS oder US verfügbar. Eine Liste der derzeit verfügbaren Einheiten finden Sie im Dialogfeld "Einheit einfügen", wenn Sie den Befehl Einheit aus dem Menü Einfügen wählen.

A

acre

amp

atm

bhp

Bq

BTU

BTU15

c

C

cal

cal15

cal20

CBTU

cd

cm

coul

day

dcal

grad

dyn

Ehp

Erg

F-Verteilung

farad

fl_oz

ft

g

gal

galUK

Gauss

GHz

gm

Gy

H

ha

henry

hhp

hp

hpUK

h

Hz

Hza

IBTU

in

in_Hg

J

joule

K

K

kA

KA

kcal

kg

kgf

kHz

KHz

km

kmph

kV

KV

kW

kW

L

lb

lbf

Liter

lx

m

mBTU

mcal [image] W

mA

mH

Mol

Am

Fm

H

mph

mho

mg

MHz

mi

min

ml

mm

mph

mVN

nF

newtonW

Oe

oersted

ohm

oz

Pa

pF

poise

psi

R

radS

s

secsiemens

slugstatamp

statC

statF

statH

statOhm

statsiemens

statT

statV

statWb

stokes

str

Sv

T

tBTU

tcal

Tesla [T]

tons

t

torr

V

volt

W

watt

Wb

weber

yd

Jahr


LISTE DER NUMERISCHEN INTEGRATIONSMETHODEN

Romberg: Die Integration erfolgt unter Verwendung der Romberg-Methode, die für die meisten Integranden eingesetzt werden kann.

Adaptiv: Die Integration erfolgt unter Verwendung einer adaptiven Quadraturmethode; diese Methode eignet sich für Funktionen, die sich in einem bestimmten Intervall schnell ändern.

Unendlich an der Integrationsgrenze: Die Integration erfolgt unter Verwendung eines Algorithmus, der für Integrale geeignet ist, bei denen einer oder beide Grenzwerte unendlich sind. Bei der zu integrierenden Funktion muß es sich um eine reelle Funktion handeln.

Singularität an der Integrationsgrenze: Die Integration erfolgt unter Verwendung einer offenen Romberg-Methode, die für Integrale geeignet ist, die an einer oder beiden Integrationsgrenzen nicht existierten.


Sperren einer ausgeblendeten Region

SPERREN EINER AUSGEBLENDETEN REGION (nur in Mathcad Professional)

Nachdem Sie eine Region ausgeblendet haben, können Sie sie sperren, um so zu verhindern, daß andere die Bereiche innerhalb dieser Region bearbeiten können. Zum Sperren einer ausgeblendeten Region ist folgendermaßen vorzugehen:

  1. Klicken Sie auf die Linie, die die ausgeblendete Region repräsentiert.

  2. Wählen Sie den Befehl Region / Sperren im Menü Format.

  3. Geben Sie, falls gewünscht, ein Kennwort ein und bestätigen Sie dieses, indem Sie es erneut eingeben. Wenn Sie ein Kennwort eingeben, wird die Region erst wieder freigegeben, wenn das Kennwort angegeben wurde. Bei der Angabe des Kennworts ist auf die Groß- und Kleinschreibung zu achten. Jedes Arbeitsblatt kann mehrere gesperrte Regionen enthalten, die jeweils mit einem eigenen Kennwort versehen werden können. Wenn Sie ein Kennwort verwenden, sollten Sie darauf achten, daß Sie das Kennwort nicht vergessen.

  4. Klicken Sie auf "OK".

Links neben der Linie, die die ausgeblendete Region repräsentiert, erscheint ein Vorhängeschloß-Symbol, das anzeigt, daß die Region gesperrt ist.

Zum Freigeben einer ausgeblendeten Region gehen Sie wie folgt vor:

  1. Klicken Sie zwischen die Begrenzungslinien der Region, die freigegeben werden soll.

  2. Wählen Sie den Befehl Region / Freigeben im Menü Format. Wenn die Region mit einem Kennwort versehen wurde, werden Sie aufgefordert, das Kennwort einzugeben.

Hinweis: Gesperrte ausgeblendete Regionen müssen zunächst freigegeben werden, bevor Sie sie wieder einblenden (erweitern) können.


Sperren der definierten Region

SPERREN DER DEFINIERTEN REGION (nur Mathcad Professional)

Nach dem Einfügen einer Region können Sie sie sperren, damit andere Benutzer die enthaltenen Bereiche nicht verändern können. Zum Sperren einer Region gehen Sie wie folgt vor:

1. Klicken Sie zwischen die Regionsbegrenzungslinien.

2. Wählen Sie den Befehl Region / Sperren aus dem Menü Format. Daraufhin wird das Dialogfeld "Region sperren" geöffnet.

3. Wenn Sie die Sperre der Region durch ein Kennwort schützen möchten, geben Sie das gewünschte Kennwort zweimal ein. Beachten Sie, daß im Kennwort Groß- und Kleinbuchstaben voneinander unterschieden werden.

4. Klicken Sie auf "Bei Sperrung ausblenden", damit die Region gleich während des Sperrens ausgeblendet wird.

5. Klicken Sie auf "OK".

Die Darstellung der Regionsbegrenzungslinien verändert sich jetzt standardmäßig (siehe folgendes Beispiel):

Hinweise:

  • Jedes Arbeitsblatt kann über mehrere gesperrte Bereiche verfügen, die jeweils mit einem eigenen Kennwort versehen werden können. Wenn Sie ein Kennwort verwenden, sollten Sie darauf achten, daß Sie das Kennwort nicht vergessen.

  • Nach dem Sperren einer Region können Sie sie ausblenden, um die enthaltenen Bereiche unsichtbar zu machen.

  • Soll das gesamte Arbeitsblatt gesperrt werden, können Sie es schützen, anstatt eine Region zu sperren, die das ganze Arbeitsblatt enthält.


VERWENDEN VON LOESS UND REGRESS IN MEHRDIMENSIONALEN RÄUMEN

Mit loess und regress können Sie eine n-dimensionale Polynomfläche an eine Reihe von Punkten (x1, x2, ...xn, z) anpassen, indem Sie wie folgt vorgehen:

Jede zusätzliche unabhängige Variable erfordert eine weitere Spalte in Mxy.

Jede zusätzliche unabhängige Variable erfordert eine weitere Zeile in v.

Beschränkungen:

  • Die Funktion loess ist auf höchstens vier unabhängige Variablen beschränkt.

  • Für die Funktion regress können beliebig viele, unabhängige Variablen festgelegt werden. Bei mehr als vier unabhängigen Variablen oder bei einem Grad der Polynomfläche von mehr als vier benötigt regress jedoch wesentlich mehr Speicher und Rechenzeit.

Zudem muß die Zahl der Datenwerte m folgende Voraussetzung erfüllen:


LOGARITHMISCHE NORMALVERTEILUNG

dlnorm(x, m, s) Gibt die Wahrscheinlichkeitsdichte für die logarithmische Normalverteilung zurück.

plnorm(x, m, s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qlnorm(p, m, s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rlnorm(m, m, s) Gibt einen Vektor aus m Zufallszahlen zurück, die die logarithmische Normalverteilung aufweisen.


LOGARITHMUS- UND EXPONENTIALFUNKTIONEN

exp(z) Zahl e hoch z

log(z,b) Logarithmus z zur Basis b. Wenn b weggelassen wird, Logarithmus z zur Basis 10.

ln(z) natürlicher Logarithmus von z (Basis e)

Argumente:

z muß ein Skalar sein (real, komplex oder imaginär).

z muß dimensionslos sein.

Für die Funktionen log und ln muß z ungleich Null sein.

b ist ein optionales, positives Argument. b muß, wenn angegeben, ein Skalar sein. Wird b weggelassen, wird b gleich 10 gesetzt.

Bei komplexem z stammen die von den log-Funktionen zurückgegebenen Werte aus dem Hauptzweig dieser Funktionen. Anders ausgedrückt gilt:

ln(z) = ln(|z|) + i arg(z)

Verwandte Themen

Felder als Argumente

Rundungsfehler bei numerischen Angaben


LOGISTISCHE VERTEILUNG

dlogis(x,l,s) Gibt die Wahrscheinlichkeitsdichte für die logistische Verteilung zurück.

plogis(x,l,s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qlogis(p,l,s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rlogis(m,l,s) Gibt einen Vektor aus m Zufallszahlen zurück, die die logistische Verteilung aufweisen.


LU-Dekomposition

LU-DEKOMPOSITION (nur in Mathcad Professional)

lu(M) Gibt genau eine Matrix mit den drei quadratischen Matrizen P, L und U zurück, die jeweils dieselbe Größe wie M aufweisen und seitlich miteinander verbunden sind. Mit der Funktion submatrix können Sie diese kleineren Matrizen extrahieren.

Diese drei Matrizen erfüllen die Gleichung [image],

wobei L und U für die untere ("lower") bzw. obere ("upper") Dreiecksmatrix stehen.

Argumente:

M ist eine quadratische Matrix.


Operator "Betrag"

BETRAG

Tastaturbefehl: |

|x| Gibt den Betrag von x zurück.

Operanden:

x muß ein Skalar sein.

Wenn Sie die absoluten Beträge der einzelnen Elemente eines Feldes benötigen, müssen Sie diesen Operator zusammen mit dem Operator "Vektorisieren" verwenden.


Standardmäßige Auswertungsreihenfolge

STANDARDMÄSSIGE AUSWERTUNGSREIHENFOLGE

Mit einer Ausnahme werden alle mathematischen Ausdrücke in einem Arbeitsblatt so ausgewertet, wie sie auch gelesen werden: von oben nach unten und von links nach rechts. Sie können weitere Erklärungen aufrufen, indem Sie auf die entsprechenden Ausdrücke im Bild unten klicken.


MANTISSE EINER ZAHL

Um nur den dezimalen Teil einer positiven Zahl zu erhalten, können Sie folgendes definieren:

mantisse(x) := x - floor(x)


MANUELLER BERECHNUNGSMODUS

Wenn Sie Mathcad starten, ist der automatische Modus aktiv, was bedeutet, daß Mathcad Ergebnisse automatisch im Arbeitsblattfenster aktualisiert, wenn Sie Änderungen vornehmen. Falls Sie jedoch bei der Bearbeitung nicht abwarten möchten, bis die Berechnungen von Mathcad abgeschlossen werden, sollten Sie in den manuellen Modus umschalten.

Vorteile des manuellen Modus...

Nachteile des manuellen Modus...

Aktualisieren von Ergebnissen im manuellen Modus...

Merkmale des manuellen Modus...

Aktivieren des manuellen Modus...


MENÜ "RECHNEN"

Berechnen

Arbeitsblatt berechnen

Automatische Berechnung

Optimierung

Optionen


Dialogfeld "Rechenoptionen": Registerkarte "Berechnung"

DIALOGFELD "RECHENOPTIONEN"

Auf der Registerkarte "Berechnung" des Dialogfelds "Rechenoptionen" finden Sie die folgenden Optionen und Schaltflächen:

Automatisch neu berechnen

Wenn diese Option aktiviert ist, berechnet Mathcad alle sichtbaren Ergebnisse und Diagramme automatisch neu. Ist die Option nicht aktiviert, werden die Ergebnisse und Diagramme nur dann neu berechnet, wenn Sie den Befehl Berechnen bzw. Arbeitsblatt berechnen im Menü Rechnen wählen. Diese Option kann auch mit Hilfe des Befehls Automatische Berechnung im Menü Rechnen aktiviert bzw. deaktiviert werden.

Ausdrücke vor dem Berechnen optimieren

Wenn diese Option aktiviert ist, werden die Ausdrücke vor dem Berechnen so weit wie möglich optimiert. Der symbolische Prozessor versucht in diesem Fall, alle Ausdrücke rechts von ":=" bzw. "=" zu vereinfachen. Ist dies möglich, so kennzeichnet er den Bereich mit einem Sternchen und führt die Berechnung anhand des vereinfachten Ausdrucks durch. Sie können den vereinfachten Ausdruck einsehen, wenn Sie auf das Sternchen doppelklicken.


Dialogfeld "Rechenoptionen": Registerkarte "Vordefinierte Variablen"

DIALOGFELD "RECHENOPTIONEN"

Auf der Registerkarte "Vordefinierte Variablen" des Dialogfelds "Rechenoptionen" finden Sie die folgenden Optionen und Schaltflächen:

Startindex (ORIGIN)

Ermöglicht die Festlegung des Wertes der vordefinierten Variable ORIGIN, mit der der Startindex aller Felder in Ihrem Arbeitsblatt angegeben wird. Der Standardwert ist "0".

Konvergenztoleranz (TOL)

Ermöglicht die Festlegung des Wertes der vordefinierten Variable TOL, mit der die Genauigkeit festgelegt werden kann, mit der Integrale und Ableitungen ausgewertet werden. Außerdem kann mit TOL die Länge der Iteration in Gleichungssystemen und in der Wurzelfunktion gesteuert werden. Der Standardwert ist "0.001".

Genauigkeit (PRNPRECISION)

Ermöglicht die Festlegung des Wertes der vordefinierten Variable PRNPRECISION, mit der die Anzahl der signifikanten Stellen angegeben wird, die von der Funktion PRNSCHREIBEN bzw. PRNANFÜGEN beim Schreiben in eine ASCII-Datendatei verwendet werden sollen. Der Standardwert ist "4".

Spaltenbreite (PRNCOLWIDTH)

Ermöglicht die Festlegung des Wertes der vordefinierten Variable PRNCOLWIDTH, mit der die Breite der Spalten in ASCII-Datendateien angegeben wird, die mit Hilfe der Funktion PRNSCHREIBEN bzw. PRNANFÜGEN erstellt wurden. Der Standardwert ist "8".

Rekursivwert für Zufallszahlen

Weist eine Zufallszahlengenerator-Funktion an, eine bestimmte Folge von Zufallszahlen zu verwenden. Wenn Sie eine andere Folge von Zufallszahlen auswählen möchten, müssen Sie den Wert ändern. Der Standardwert ist "1".

Schaltfläche "Standardwerte wiederherstellen"

Setzt alle Werte auf die Standardwerte zurück. (Die Standardwerte werden rechts neben jedem Wert in runden Klammern angezeigt.)


SYMBOLLEISTE "RECHNEN"

Über die Schaltflächen auf der Symbolleiste "Rechnen" haben Sie schnellen Zugriff auf die anderen mathematischen Symbolleisten. Welche Symbolleiste mit einer bestimmten Schaltfläche geöffnet wird, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


Mathcad-Dokument-Objektmodell

MATHCAD-DOKUMENT-OBJEKTMODELL (nur in Mathcad Professional)

Beim Schreiben eines Programms in einem OLE-Automatisierungs-Client gelten für das Definieren und Erfassen von Variablen die folgenden Regeln:

  • Die in Mathcad definierten Variablen müssen in0, in1, in2 usw. genannt werden.

  • Die aus Mathcad bezogenen Variablen müssen out0, out1, out2 usw. genannt werden.

Verwenden Sie die folgenden Automatisierungsmethoden:

GetComplex(Name, Realteil, Imaginärteil): Mit dieser Methode werden komplexe Daten (Real- und Imaginärteil) aus der Mathcad-Variable Name gewonnen, wobei Name die Form out0, out1, out2 usw. hat.

SetComplex(Name, Realteil, Imaginärteil) weist der Mathcad-Variable Name komplexe Daten (Real- und Imaginärteil) zu, wobei Name die Form in0, in1, in2 usw. hat.

Recalculate startet die Neuberechnung des Mathcad-Dokuments.

SaveAs(Name) speichert das Mathcad-Dokument als Datei; der Pfad wird durch die Zeichenfolge Name angegeben.


DIALOGFELD "MATRIX EINFÜGEN"

Im Dialogfeld "Matrix einfügen" finden Sie die folgenden Optionen und Schaltflächen:

Zeilen

Geben Sie hier die Anzahl der Zeilen ein, die eingefügt oder erstellt werden sollen.

Spalten

Geben Sie hier die Anzahl der Spalten ein, die eingefügt oder erstellt werden sollen.

Einfügen

Wenn Sie auf diese Schaltfläche klicken, wird eine Matrix mit Platzhaltern eingefügt.

Sollen einer bereits existierenden Matrix weitere Zeilen hinzugefügt werden, fügt Mathcad die Zeilen mit leeren Platzhaltern unterhalb des ausgewählten Elements ein.

Sollen einer bereits existierenden Matrix Spalten hinzugefügt werden, fügt Mathcad die Spalten mit leeren Platzhaltern rechts neben dem ausgewählten Element ein.

Wenn diese Schaltfläche grau dargestellt ist, sollten Sie sicherstellen, daß Sie in den Feldern "Zeilen:" und "Spalten:" die Anzahl der Zeilen und Spalten für die neue Matrix eingetragen haben. Außerdem muß sich der Cursor auf einem Platzhalter oder im leeren Raum des Arbeitsblatts befinden.

Löschen

Mit dieser Schaltfläche können Sie Zeilen oder/und Spalten aus einer Matrix löschen:

Beim Löschen von Zeilen beginnt Mathcad mit der Zeile, in der sich das ausgewählte Element befindet, und löscht die Zeilen von diesem Element an abwärts.

Beim Löschen von Spalten beginnt Mathcad mit der Spalte, in der sich das ausgewählte Element befindet, und löscht die Spalte von diesem Element an nach rechts.


Operator "Matrixdivision"

MATRIXDIVISION

Tastaturbefehl: /

Dividiert jedes Element von A durch z.

Operanden:

A ist eine Matrix.

z ist ein Skalar ungleich Null.

Um jedes Element der aus m x n Elementen bestehenden Matrix A durch das jeweilige Element einer anderen aus m x n Elementen bestehenden Matrix B zu teilen, wählen Sie den gesamten Ausdruck aus, und drücken Sie dann Strg+-, um den Operator "Vektorisieren" einzufügen.


Operator "Matrixpotenzen"

MATRIXPOTENZEN

Tastaturbefehl: ^

Gibt, abhängig von n, eines der folgenden Ergebnisse zurück:

Ist n = 0, wird die Einheitsmatrix zurückgegeben, deren Dimensionen mit denen von M übereinstimmen.

Ist n = 1, wird lediglich M zurückgegeben.

Ist n = -1, wird die Inverse von M zurückgegeben, falls vorhanden.

Ist n eine positive ganze Zahl, wird M n-mal mit sich selbst multipliziert.

Ist n eine negative ganze Zahl, wird die Inverse von M n-mal mit sich selbst multipliziert.

Operanden:

M ist quadratisch.

n ist eine dimensionslose ganze Zahl.

Matrixpotenzen lassen sich symbolisch auswerten. Gehen Sie hierzu folgendermaßen vor:

Wählen Sie den auszuwertenden Ausdruck aus.

Wählen Sie den Befehl Vereinfachen im Menü Symbolik.


Operator "Inverse Matrix"

INVERSE MATRIX

Tastaturbefehl: ^-1

Gibt die Inverse einer Matrix zurück. Wenn es für M keine Inverse gibt, erscheint eine entsprechende Fehlermeldung.

Operanden:

M ist eine quadratische Matrix, für die es eine Inverse gibt.


Operator "Matrixmultiplikation"

MATRIXMULTIPLIKATION

Tastaturbefehl: *

Gibt das Matrixprodukt von A und B zurück.

Operanden:

A ist eine aus m x n Elementen bestehende Matrix.

B ist eine aus n x p Elementen bestehende Matrix.

Hinweise:

  • Ist A eine Matrix und x ein Skalar, ist das Produkt von A und x eine Matrix, in der jedes Element von A mit x multipliziert worden ist.

  • Zur Berechnung des gliedweisen Produkts von zwei gleich großen Feldern A und B wählen Sie den gesamten Ausdruck aus, und drücken Sie Strg+-, um den Operator "Vektorisieren" einzufügen.


Operator "Tiefgestellte Matrix"

TIEFGESTELLTE MATRIX

Tastaturbefehl: [

Gibt das mn-te Element von M zurück. Wenn M kein mn-tes Element hat, erscheint eine entsprechende Fehlermeldung.

Operanden:

M ist ein Feld.

m und n müssen dimensionslose ganze Zahlen sein.

Denken Sie daran, daß alle Felder standardmäßig bei 0 und nicht bei 1 beginnen. Für eine Matrix mit 10 Zeilen und 5 Spalten gilt:

m muß zwischen 0 und 9 liegen.

n muß zwischen 0 und 4 liegen.

Um dies zu ändern, wählen Sie den Befehl Optionen im Menü Rechnen, und klicken Sie im Dialogfeld "Rechenoptionen" auf die Registerkarte "Vordefinierte Variablen". Ändern Sie den Wert für "Startindex (ORIGIN)".


SYMBOLLEISTE "MATRIX"

Über die Symbolleiste "Matrix" haben Sie schnellen Zugriff auf die Matrix- und Vektoroperatoren. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


MAXIMA UND MINIMA EINES FELDES

max(A) Gibt das größte Element in A zurück.

min(A) Gibt das kleinste Element in A zurück.

Argumente:

A kann sowohl ein Vektor als auch eine Matrix sein.

Wenn A komplexe Elemente hat, gilt:

max(A) Gibt den größten Realteil plus i-mal den größten Imaginärteil zurück.

min(A) Gibt den kleinsten Realteil plus i-mal den kleinsten Imaginärteil zurück.


EINE FUNKTION MINIMIEREN BZW. MAXIMIEREN

Minimieren(f, var1, var2, ...) Gibt die Werte var1, var2, ... zurück, die die Bedingungen in einem Gleichungssystem erfüllen und die dafür sorgen, daß die Funktion f ihren kleinsten Wert annimmt.

Maximieren(f, var1, var2, ...) Gibt die Werte var1, var2, ... zurück, die die Bedingungen in einem Gleichungssystem erfüllen und die dafür sorgen, daß die Funktion f ihren größten Wert annimmt.

Argumente:

var1, var2, ... sind skalare Variablen im Gleichungssystem. Sie sind oberhalb des Gleichungssystems als Schätzwerte definiert.

f ist eine über dem Gleichungssystem definierte Funktion. So könnte sich z. B ein Argument g auf die Funktion g(x,y):=x/y beziehen.

Arbeiten mit den Funktionen:

Gehen Sie bei der Verwendung der Funktion minimieren bzw. maximieren wie folgt vor:

Definieren Sie die Funktion, die maximiert bzw. minimiert werden soll.

Definieren Sie Schätzwerte für die Variablen, nach denen aufgelöst werden soll.

Geben Sie das Wort Vorgabe ein, um das Gleichungssystem zu starten.

Geben Sie unter Vorgabe Gleichungen und Ungleichungen ein, die als Bedingungen fungieren. Verwenden Sie dazu Boolesche Operatoren.

Geben Sie die Funktion Minimieren bzw. Maximieren mit den entsprechenden Argumenten ein.

Hinweise:

  • Diese Funktionen geben einen Skalar zurück, wenn nur eine Variable enthalten ist. Andernfalls geben Sie einen Vektor zurück, dessen erstes Element var1, dessen zweites Element var2 usw. ist.

  • Wenn es keine Bedingungen gibt, muß das Wort Vorgabe nicht eingegeben werden.

  • Bei der Eingabe der Funktionen Minimieren und Maximieren brauchen Sie nicht auf die Groß- und Kleinschreibung zu achten.

Beispiel:

Lineare und nichtlineare Funktionen maximieren und minimieren


Funktion "mittelwert" (Mittelwert)

FUNKTION "MITTELWERT"

Argumente:

A ist ein m x n Elemente großes Feld.

Weitere Funktionen für die Datenanalyse...


Funktion "median" (Median)

FUNKTION "MEDIAN"

median(A) Gibt den Median der Elemente eines Feldes zurück. Dies ist der Wert, ober- und unterhalb dessen es keine gleiche Anzahl von Feldelementen gibt. Wenn die Anzahl der Elemente in A gerade ist, entspricht der Median dem arithmetischen Mittel der beiden Werte im Zentrum des Feldes.

Argumente:

A ist ein m x n Elemente großes Feld.

Weitere Funktionen für die Datenanalyse...


Menüs

MENÜBEFEHLE

Datei

Bearbeiten

Ansicht

Einfügen

Format

Rechnen

Symbolik

Fenster

Hilfe


METHODEN FÜR SORTIERFUNKTIONEN

Die Mathcad-Sortierroutine für die Sortierfunktionen sort, spsort und zsort arbeitet mit einem Stapelsortieralgorithmus. Eine vollständige Beschreibung finden Sie in Numerical Recipes in C von William H. Press, Brian P. Flannery, Saul A. Teukolosky und William T. Vetterling (Cambridge University Press, 1986).

Die Stapelsortierroutine ist keine stabile Sortierung. Wenn Sie also eine Matrix an einer Spalte sortieren, die gleiche Elemente enthält, werden die Zeilen mit diesen Elementen im sortierten Feld nebeneinander positioniert, erscheinen jedoch in zufälliger Reihenfolge.


VERSCHIEDENE FUNKTIONEN

mod(x, y)

Gibt x mod y zurück, den Rest aus der Division von x durch y.

winkel(x,y)

Winkel von der x-Achse zum Punkt (x,y).


FUNKTION "mode"

mode(A) Gibt den Wert in A zurück, der am häufigsten vorkommt.

Argumente:

A ist ein Vektor oder eine Matrix.

Wenn in A kein Wert häufiger auftritt als ein anderer, wird eine Fehlermeldung angezeigt, aus der hervorgeht, daß es keinen häufigsten Wert gibt.

Beispiel:

Weitere Funktionen für die Datenanalyse...


SYMBOLLEISTE "MODIFIKATOR"

Über die Schaltflächen auf der Symbolleiste "Modifikator" können Sie Modifikatoren einfügen, die für die symbolischen Schlüsselwörter auf der Symbolleiste "Symbolik" benötigt werden. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


ÄNDERN EINER RECHENFORMATVORLAGE

Zum Bearbeiten von mit einer bestimmten Gleichungsformatvorlage verknüpften Schriftattributen gehen sie wie folgt vor:

  1. Wählen Sie Gleichung aus dem Menü Format.

  2. Wählen Sie im Dialogfeld "Gleichungsformat" das Format aus, dessen Eigenschaften Sie ändern möchten. Der Name der gewählten Formatvorlage erscheint im Textfeld "Name der Vorlage". Sofern Sie nicht die Schriftart für alle Variablen bzw. alle Konstanten ändern wollen, müssen Sie die Änderungen an einer "Benutzer"-Formatvorlage vornehmen.

  3. Ändern Sie gegebenenfalls den Namen der Formatvorlage, indem Sie den neuen Namen im Textfeld "Neuer Name der Vorlage" eingeben. Eine Änderung des Namens der Vorlage ist vorteilhaft, weil man sich auf diese Weise leichter merken kann, über welche Schriftartattribute die Vorlage verfügt.

  4. Klicken Sie auf die Schaltfläche "Ändern".

  5. Wählen Sie die gewünschten Schriftattribute im Dialogfeld aus. Wenn Sie die Attributkombination nach Ihren Anforderungen bestimmt haben, wählen Sie im Schriftarten-Dialogfeld und im Dialogfeld "Gleichungsformat" jeweils "OK".

Wenn Sie die mit einer Rechenformatvorlage verknüpften Schriftartattribute ändern, ändert sich die Schriftart aller Variablen bzw. Konstanten, denen diese Formatvorlage zugewiesen ist.


ÄNDERN DER STANDARDVORLAGE

Wenn Sie ein Arbeitsblatt erstellen, wählen Sie eine Vorlage aus, auf der dieses Arbeitsblatt basieren soll. Standardmäßig verwendet Mathcad die Vorlage NORMAL.MCT. Ihnen stehen folgende Möglichkeiten zur Verfügung:

Sie können die Vorlage NORMAL.MCT wie jede andere Vorlage auch ändern, oder

Sie erstellen eine neue Vorlage und ersetzen die Vorlage NORMAL.MCT durch die neu erstellte Vorlage. Dieses Verfahren empfiehlt sich vor allem dann, wenn die Vorlage NORMAL.MCT unverändert erhalten bleiben soll. Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie die Datei NORMAL.MCT, die sich im Ordner "template" des Mathcad-Ordners befindet.

  2. Wählen Sie den Befehl Speichern unter im Menü Datei, und geben Sie einen Namen ein, wie z. B. NORMALALT.MCT. Auf diese Art und Weise können Sie die Vorlagen-Datei für eine spätere Verwendung speichern.

  3. Erstellen Sie eine neue Vorlage, die als Standardvorlage fungieren soll. Benennen Sie diese Vorlage "NORMAL.MCT", und speichern Sie sie im Ordner "template" des Mathcad-Ordners.


MODULUSFUNKTION

mod(x,y) Diese Funktion gibt den Rest aus der Division von x durch y zurück. Das Ergebnis hat dasselbe Vorzeichen wie x.

Argumente:

x und y sollten beide reelle Skalare sein.

y muß ungleich 0 sein.


VERSCHIEBEN VON GRAFIKBEREICHEN

Sie können einen Bereich verschieben, indem Sie ihn ausschneiden und an einer neuen Position einfügen oder ihn mit der Maus ziehen.

Ausschneiden und Einfügen

  1. Wählen Sie den oder die zu verschiebenden Bereiche aus.

  2. Wählen Sie Ausschneiden im Menü Bearbeiten.

  3. Klicken Sie auf die Position, an der Sie den oder die Bereiche einfügen möchten.

  4. Wählen Sie Einfügen im Menü Bearbeiten.

Ziehen eines Bereichs

  1. Wählen Sie den Bereich aus, indem Sie auf ihn klicken.

  2. Setzen Sie den Mauszeiger auf einen der Ränder des Markierungsrechtecks. Der Mauszeiger wechselt seine Form von einem Pfeil zu einer kleinen Hand.

  3. Drücken Sie die Maustaste, und halten Sie sie gedrückt, während Sie die Maus ziehen. Der Umriß des Bereichs verschiebt sich mit der Maus.

  4. Lassen Sie die Maustaste los, wenn sich der Umriß des Bereichs an der gewünschten Stelle befindet.

Ziehen mehrerer Bereiche

  1. Wählen Sie die Bereiche mit dem gestrichelten Markierungsrechteck aus.

  2. Setzen Sie den Mauszeiger in die Mitte eines der Bereiche. Der Mauszeiger wechselt seine Form von einem Pfeil zu einer kleinen Hand.

  3. Drücken Sie die Maustaste, und halten Sie sie gedrückt, während Sie die Maus ziehen. Der Umriß des Bereichs verschiebt sich mit der Maus.

  4. Lassen Sie die Maustaste los, wenn sich der Umriß des Bereichs an der gewünschten Stelle befindet.


Operator "Multiplikation"

MULTIPLIKATION

Tastaturbefehl: *

Gibt das Produkt von y und x zurück.

Operanden:

x und y sind Skalare.

Mathcad unterstützt auch die implizierte Multiplikation, d. h., Sie müssen nicht unbedingt den Multiplikationsoperator zwischen Konstanten und Variablen verwenden. Wenn Sie z. B. "5x" eingeben, versteht Mathcad dies als "5*x". Bei den Variablen o und h wird keine implizierte Multiplikation durchgeführt, da diese für die Eingabe von oktalen und hexadezimalen Zahlen reserviert sind.


Mehrwertige Funktionen

MEHRWERTIGE FUNKTIONEN UND OPERATOREN

Als allgemeine Regel gilt, daß Mathcad bei mehrwertigen Funktionen oder Operatoren stets 5 + .866i zurückgibt, und das trotz der Tatsache, daß die Kubikwurzel von -1 gewöhnlich mit 1 angegeben wird.

Die einzige Ausnahme von dieser Regel ist der Operator für die n-te Wurzel. Dieser Operator gibt immer eine reelle Wurzel zurück, falls es eine solche gibt.


MULTIVARIABLE KUBISCHE SPLINE-INTERPOLATION

Mit der zweidimensionalen kubischen Spline-Interpolation können Sie eine Fläche so durch ein Raster von Punkten verlaufen lassen, daß die erste und die zweite Ableitung der Kurve an jedem Punkt stetig ist. Diese Fläche entspricht einem kubischen Polynom in x und y, bei dem die erste und zweite Ableitung in der entsprechenden Richtung an jedem Rasterpunkt stetig ist.

kspline(Mxy,Mz) Gibt einen Vektor aus den zweiten Ableitungen für die Datenfelder Mxy und Mz zurück. Dieser Vektor wird als das erste Argument der Funktion interp verwendet. Die sich dabei ergebende Fläche ist an den Rändern des von Mxy abgedeckten Bereichs kubisch.

pspline(Mxy,Mz) Wie kspline, die sich ergebende Fläche ist jedoch an den Rändern parabolisch.

lspline(Mxy,Mz) Wie kspline, die sich ergebende Fläche ist jedoch an den Rändern linear.

interp(vs,Mxy,Mz,v) Führt eine Spline-Interpolation von Mz an den in v angegebenen x- und y-Koordinaten aus und gibt den sich dabei ergebenden Wert zurück.

Argumente:

Mxy it ein aus n x 2 Elementen bestehendes Feld mit den x- und y-Koordinaten entlang der Diagonale des rechtwinkligen Gitters, über das interpoliert werden soll.

Mz ist ein aus n x n Elementen bestehendes Feld mit reellen Daten. Dabei handelt es sich um die z-Werte, die den x- und y-Werten in Mxy entsprechen.

vs ist ein Vektor, der von einer der Funktionen kspline, pspline oder lspline generiert wurde.

v ist ein Vektor, der die beiden x- und y-Werte für den Punkt enthält, an dem der interpolierte Wert für z ermittelt werden soll. Zugunsten der Ergebnisgenauigkeit sollten für x und y Werte gewählt werden, die im Bereich der Gitterpunkte liegen.


MULTIVARIABLE POLYNOMREGRESSION

regress(Mxy,vz,k) Gibt einen Vektor zurück, mit dem interp die Polynomfläche k-ter Ordnung sucht, die den Datenwerten x, y und z am ehesten entspricht.

interp(vs,Mxy,vz,v) Gibt den z-Wert zurück, der den in v angegebenen Werten für x und y entspricht.

Argumente:

Mxy ist eine aus m x 2 Elementen bestehende Matrix mit x- und y-Koordinaten.

vz ist ein aus m Elementen bestehender Vektor, der die z-Koordinaten enthält, die den in Mxy angegebenen m Punkten entsprechen.

vs ist der von regress generierte Vektor.

n ist eine positive ganze Zahl, die die Ordnung der Polynomfläche für die Datenanpassung angibt. Für gewöhnlich gilt k < 5.

v ist ein Vektor mit zwei Elementen, die aus dem x- und dem y-Wert bestehen, für den Sie die entsprechende z-Koordinate auf der Regressionsfläche berechnen möchten.

Hinweise:

  • Die Funktion Regress erweist sich dann als nützlich, wenn Sie eine Reihe gemessener y-Werte haben, die x-Werten entsprechen, und Sie ein einzelnes Polynom beliebiger Ordnung an diese y-Werte anpassen wollen.

  • Für die Funktion regress können beliebig viele, unabhängige Variablen festgelegt werden. Bei mehr als vier unabhängigen Variablen oder bei einem Grad der Polynomfläche von mehr als vier benötigt regress jedoch wesentlich mehr Speicher und Rechenzeit.

Zudem muß die Zahl der Datenwerte m folgende Voraussetzung erfüllen:

  • Immer, wenn Sie die Funktion regress verwendet haben, sollten Sie die Funktion interp einsetzen.

  • Da die Funktion regress versucht, alle Ihre Datenpunkte mit einem einzigen Polynom abzudecken, kommt es zu keinem sinnvollen Ergebnis, wenn sich Ihre Daten nicht wie ein Einzelpolynom verhalten. Soll eine lokalisiertere Regression ausgeführt werden, verwenden Sie die Funktion loess.


Multivariable Polynomregression, lokalisiert

MULTIVARIABLE POLYNOMREGRESSION, LOKALISIERT (nur in Mathcad Professional)

loess(Mxy,vz,bereich) Gibt einen Vektor zurück, mit dem interp versucht, eine Reihe von Polynomflächen zweiter Ordnung zu finden, die den Datenwerten x, y und z, die in Mxy und vz festgelegt sind, innerhalb einer Umgebung von x- und y-Datenwerten am ehesten entsprechen. Dabei bestimmt bereich die Größe dieser Umgebung.

interp(vs,Mxy,vz,v) Gibt den z-Wert zurück, der den in v angegebenen Werten für x und y entspricht.

Argumente:

Mxy ist eine aus m x 2 Elementen bestehende Matrix mit x- und y-Koordinaten.

vz ist ein aus m Elementen bestehender Vektor, der die z-Koordinaten enthält, die den in Mxy angegebenen m Punkten entsprechen.

vs ist der Vektor, der von loess oder regress generiert wird.

bereich ist eine positive reelle Zahl, mit der die Größe der gewünschten Umgebung angegeben wird. Für bereich sind große Werte zu empfehlen, wenn sich die Daten über verschiedenen Bereichen von x sehr unterschiedlich verhalten. Allgemein ist bereich=0.75 als Standardwert gut geeignet.

v ist ein Vektor mit zwei Elementen, die aus den x- und y-Werten bestehen, für den Sie die entsprechende z-Koordinate auf der Regressionsfläche berechnen wollen.

Hinweise:

  • Sie können die Funktion loess verwenden, wenn Sie eine Reihe gemessener z-Werte haben, die x- und y-Werten entsprechen, und Sie eine Polynomfläche durch diese z-Werte anpassen wollen.

  • Die Funktion loess ist auf maximal vier unabhängige Variablen begrenzt.

  • Nach Verwendung der Funktion loess empfiehlt es sich stets, die Funktion interp zu verwenden.

  • loess versucht, unterschiedliche Polynome zweiter Ordnung in Abhängigkeit davon anzupassen, wo Sie sich auf der Kurve befinden. Dies geschieht, indem die Daten in einer engen Umgebung des Punktes, der Sie interessiert, geprüft werden. Mit dem Argument bereich können Sie die Größe dieser Umgebung festlegen. Wenn bereich größer wird, entspricht loess der Funktion regress mit n=2.


Operator "Negation"

NEGATION

Tastaturbefehl: -

-x

Gibt den negativen Wert des Operanden zurück.

Operanden:

x ist ein Skalar.


Operator "Negation von Feldern"

NEGATION VON FELDERN

Tastaturbefehl: -

-A

Gibt ein Feld mit derselben Größe wie A zurück, das die negativen Werte der einzelnen Elemente in A enthält. Entspricht der Multiplikation von A mit -1.

Operanden:

A ist ein Feld.


NEGATIVE BINOMIALVERTEILUNG

dnbinom(k,n,p) Gibt die Wahrscheinlichkeitsdichte für die negative Binomialverteilung zurück.

pnbinom(k,n,p) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qnbinom(p,n,r) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rnbinom(m,n,p) Gibt einen Vektor aus m Zufallszahlen zurück, die die negative Binomialverteilung aufweisen.


Norm einer Matrix

NORM EINER MATRIX (nur in Mathcad Professional)

norm1(M) Gibt die Norm [image] der Matrix M zurück.

norm2(M) Gibt die Norm [image] der Matrix M zurück.

norme(M) Gibt die Euklidische Norm der Matrix M zurück.

normi(M) Gibt die infinite Norm der Matrix M zurück.

Argumente:

M muß eine quadratische Matrix sein.


NORMALVERTEILUNG

dnorm(x, m , s) Gibt die Wahrscheinlichkeitsdichte für die Normalverteilung zurück.

pnorm(x, m, s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

knorm(x) Gibt die kumulative Wahrscheinlichkeitsverteilung mit dem Mittelwert 0 und der Varianz 1 zurück.

qnorm(p,m,s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rnorm(m,m,s) Gibt einen Vektor aus m Zufallszahlen zurück, die die Normalverteilung aufweisen.


Operator "Ungleich"

UNGLEICH

Tastaturbefehl: Strg+3

x [image] y

Gibt 1 zurück, wenn x [image] y, andernfalls 0.

Operanden:

x und y können reelle oder komplexe Skalare bzw. Felder sein.


Operator "n-te Ableitung"

N-TE ABLEITUNG

Tastaturbefehl: Strg+Umschalt+?

Gibt die n-te Ableitung von f(t) im Punkt t zurück.

Operanden:

f(t) ist eine Funktion mit einem Skalarwert.

t ist der Punkt, an dem die Ableitung ausgewertet werden soll.

n= 0, 1, 2, 3, 4 oder 5.

Zunächst muß festgelegt werden, an welchem Punkt die Ableitung ausgewertet werden soll. Beispiel:

Hinweise:

  • Im Beispiel oben handelt es sich bei dem zurückgegebenen Wert um die n-te Ableitung von f in t, ausgewertet an dem Punkt bzw. den Punkten, an denen t zuvor definiert wurde.

  • Das Beispiel zeigt zwar eine Funktion nur einer Variablen, f kann aber eine Funktion jeder beliebigen Anzahl von Variablen sein.

  • Wenn f mehrere Terme hat, müssen diese in Klammern angegeben werden, damit sie innerhalb des Ableitungsoperators bleiben.

  • Beim Ableitungsalgorithmus von Mathcad kann davon ausgegangen werden, daß die erste Ableitung innerhalb von 7 oder 8 signifikanten Ziffern genau ist, vorausgesetzt, daß der Wert, an dem die Ableitung ausgewertet wird, sich nicht zu sehr in der Nähe einer Singularität der Funktion befindet.


Operator "n-te Wurzel"

N-TE WURZEL

Tastaturbefehl: Strg+\

Gibt die n-te Wurzel von x zurück.

Operanden:

x muß ein Skalar sein.

n muß eine positive ganze Zahl sein.

Gibt eine reelle Wurzel zurück, wenn dies möglich ist. Wenn der Hauptwert der n-ten Wurzel von x zurückgegeben werden soll, müssen Sie statt dessen x zur 1/n-ten Potenz erheben.


ANZAHL DER ELEMENTE IN EINEM VEKTOR

länge(v) Gibt die Anzahl der Elemente im Vektor v zurück.

letzte(v) Gibt den Index des letzten Elements im Vektor v zurück.

Argumente:

v muß ein Vektor sein.

Zur Ermittlung der euklidischen Länge von v können Sie den Betragsoperator | verwenden.


NUMERIERUNGEN

Absätzen innerhalb eines Textbereichs können Sie eine fortlaufende Numerierung, wie z. B. 1,2,3,..., hinzufügen. So sind z. B. die folgenden drei Absätze mit einer Numerierung versehen:

  1. Zeile 1

  2. Zeile 2
  3. Zeile 3


NUMERISCHE ABLEITUNGSMETHODE

Der Ableitungsoperator von Mathcad berechnet Ableitungen einer Ordnung zwischen 0 und 5 (einschließlich) mit einer Abwandlung der Ridder-Methode. Sie beginnt mit der Bestimmung einer anfänglichen Schrittweite und dem Aufbau eines dreieckigen Annäherungsfelds. Dabei gilt folgende Vorgehensweise:

Mathcad berechnet den ersten Annäherungswert in der Tabelle mit einer Differenzannäherung, die am Punkt n+1 aufgeteilt wird:

Die restlichen Annäherungen in der ersten Zeile der Tabelle werden nach der aufgeteilten Differenzformel bei sinkender Schrittweite berechnet:

Die verbleibenden Elemente in dieser Annäherungstabelle werden mit gewichteten Mittelwerten früherer Elemente berechnet:

Der Fehler für eine bestimmte Annäherung des Ableitungswertes wird gegeben durch:

Angenommen, fehlmin sei das kleinste der Elemente i und j von fehl und abl sei die Annäherung des Ableitungswerts entsprechend fehlmin. Dann gelte:

hierbei steht E für die kleinste Zahl, die von der Ordnung abhängt. Mathcad gibt abl als Wert der Ableitung aus. Andernfalls markiert Mathcad die Ableitung durch eine Fehlermeldung.

Hinweis zum Algorithmus:

Beim Ridder-Algorithmus ist für die erste Ableitung eine Genauigkeit von 7 bis 8 signifikanten Ziffern zu erwarten, vorausgesetzt, der Wert, an dem Sie die Ableitung berechnen, liegt nicht zu nahe an einer Singularität der Funktion.


NUMERISCHE INTEGRATION

Von der Vielzahl bewährter numerischer Integrationsmethoden eignen sich bestimmte Methoden für bestimmte Integrale besser als für andere. Daher wertet Mathcad standardmäßig jedes Integral numerisch mit Hilfe der Funktion Automatische Auswahl aus. Die Aufgabe von "Automatische Auswahl" besteht darin, die geeignetste Integrationsmethode auszuwählen. Beispiel:

  1. Klicken Sie auf [image] auf der Symbolleiste "Differential/Integral", oder geben Sie & ein, um den Integraloperator einzufügen.

  2. Geben Sie in die Platzhalter Werte für die untere und die obere Integrationsgrenze, den Integranden und die Integrationsvariable ein.

  3. Drücken Sie die Taste =. Die Funktion "Automatische Auswahl" wertet das Integral aus, wählt den geeignetsten Algorithmus aus und gibt das Ergebnis zurück.

Wenn es Sie interessiert, welches Ergebnis von einer anderen Methode zurückgegeben worden wäre, können Sie die Funktion "Automatische Auswahl" außer Kraft setzen und selbst einen Algorithmus auswählen.


Numerische Probleme in inversen trigonometrischen Funktionen

NUMERISCHE PROBLEME

Da Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.


Numerische Probleme bei Besselfunktionen

NUMERISCHE PROBLEME

Da Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.


GENAUIGKEIT DES NUMERISCHEN VERFAHRENS

Da Mathcad als Allzweckrechenprogramm konzipiert ist, arbeitet es mit numerischen Methoden, die in vielen unterschiedlichen Situationen funktionieren. Ebenso wie bei allen numerischen Algorithmen lassen sich jedoch auch für die Methoden von Mathcad bestimmte Beispiele finden, deren Ergebnis falsch oder irreführend ist.

Sie können die Richtigkeit von Ergebnissen überprüfen und numerische Fehler vermeiden, wenn Sie sich an die folgenden Regeln halten:

Wenn Sie mit einer Mathcad-Funktion oder einem Operator arbeiten, der eine numerische Annäherung enthält, überprüfen Sie, ob das Ergebnis plausibel erscheint.

Befassen Sie sich mit den verfügbaren Informationen zu dem betreffenden Operator bzw. der Funktion. Wenn Sie glauben, daß die Mathcad-Methoden fehlschlagen könnten, formulieren Sie das Problem so um, daß es stabiler berechnet werden kann.

Machen Sie sich mit den numerischen Methoden vertraut, damit Sie abschätzen können, unter welchen Umständen falsche oder ungenaue Ergebnisse zustandekommen.

Stellen Sie die vordefinierte Variable TOL so ein, daß die gewünschte Genauigkeit und Geschwindigkeit für numerisch berechnete Antworten erzielt wird.


NUMERISCHE METHODE ZUR BERECHNUNG EINER INVERSEN MATRIX UND EINER DETERMINANTE

Zur Berechnung der Determinante oder der Inversen einer quadratischen Matrix M löst Mathcad die Matrix in eine untere ("lower") Dreiecksmatrix L und eine obere ("upper") Dreiecksmatrix U auf, dergestalt daß:

Dies wird als LU-Dekomposition der Matrix bezeichnet. Dadurch wird die Lösung eines Systems von Gleichungen:

durch einfache Ersetzungen durch die Elemente L, U und y durchgeführt.

Zur Berechnung der Inversen löst Mathcad die Gleichungen auf:

hierbei ist e ein Vektor mit 1 im Element j und 0 in allen anderen Elementen. Die Lösungsvektoren v für jedes j bilden die Spalten der inversen Matrix.

Die Determinante der Ausgangsmatrix ist einfach das Produkt der diagonalen Elemente von U, also der oberen Dreiecksmatrix in der LU-Dekomposition.


NUMERISCHE METHODEN

Im folgenden werden die numerischen Methoden beschrieben, mit denen Mathcad bei bestimmten Berechnungen arbeitet.

Integration

Ableitung

Wurzelfunktion

Lösen von Gleichungen

Matrixdeterminanten und Inverse Matrix

Sortieren

Faktor oder Zähler gleich Null

Genauigkeit des numerischen Verfahrens


NUMERISCHE ERGEBNISSE SYMBOLISCHER BERECHNUNGEN

Mit Hilfe symbolischer Berechnungen lassen sich oft auch numerische Ergebnisse ermitteln, vor allem in Fällen wie dem folgenden:

Die Ergebnisse aus dem symbolischen Prozessor hängen davon ab, ob die Konstanten in Ihrer Gleichung Dezimalstellen enthalten. Handelt es sich bei den Konstanten um reine rationale Zahlen wie 1/2 oder 4, versucht dieser symbolische Lösungsalgorithmus, eine exakte Lösung zu finden. Wenn Sie jedoch eine Dezimalzahl eingeben, zum Beispiel 0.5 statt 1/2, gibt der Algorithmus nur eine angenäherte numerische Antwort aus.

Sie können die numerische Berechnung durch den symbolischen Prozessor auch mit dem Befehl Gleitkomma im Untermenü Auswerten erzwingen.


OLE-AUTOMATISIERUNGS-CLIENT

Ein OLE-Automatisierungs-Client ist ein Anwendungsprogramm, in dem Sie ein Programm oder Makro schreiben können, das mit einem Objekt in Interaktion tritt. So ist z. B. Microsoft Excel 5.0 und höher ein solcher OLE-Automatisierungs-Client.

Informationen dazu, ob ein bestimmtes Anwendungsprogramm als OLE-Automatisierungs-Client fungieren kann, finden Sie in der Dokumentation zu diesem Anwendungsprogramm.


OFFENE ROMBERG-METHODE

Bei der offenen Integrationsmethode werden die vorläufigen Annäherungen über die Mittelpunkte der Teilintervalle ermittelt, so daß die Funktion nicht an den Endpunkten a und b berechnet werden muß. (Eine vollständige Beschreibung bietet der Artikel "Handheld Calculator Evaluates Integrals" von William Kahan, Ph.D., im Hewlett-Packard Journal, August 1980.) Die Stichproben konzentrieren sich an den Enden des Integrationsintervalls, wo singuläre Integranden oder Integranden mit einer endlichen Ableitung meistens die abruptesten Veränderungen erfahren. Bei jedem Schritt verdreifacht sich die Zahl der Teilintervalle.

Bei der offenen Romberg-Methode führt Mathcad die folgenden Schritte aus:

Berechnen einer offenen Annäherung für das Integral durch das Summieren der einzelnen Produkte aus dem Funktionswert am Mittelpunkt des Teilintervalls und der Weite dieses Teilintervalls. Die Prozedur beginnt mit nur einem Intervall und ergibt folgende Annäherung:

Bei der nächsten Annäherung werden drei Punkte, bei der übernächsten neun Punkte usw. bewertet. Zunächst sind die ersten drei Annäherungen zu erstellen.

Vergleichen der beiden letzten Romberg-Annäherungen nach folgendem Test:

Stimmen die beiden letzten Annäherungswerte gemäß dem Test überein, wird die letzte offene Annäherung als Wert des Intergrals ausgegeben. Ist dies nicht der Fall, wird die Zahl der Teilintervalle verdreifacht, und die Prozedur wird erneut ab Schritt 1 durchgeführt.

Mathcad begrenzt die Zahl der Durchgänge für die offene Romberg-Methode. Erreicht Mathcad bei der Routine die festgelegte Begrenzung, ohne daß eine Antwort ausgegeben wird, wird die fehlgeschlagene Konvergenz am Integral als Fehler angezeigt.


ÖFFNEN EINES ARBEITSBLATTS IN EINER ANDEREN ANWENDUNG

Wenn Sie eine RTF- Datei, die mit dem Befehl Speichern unter im Menü Datei erstellt worden ist, in einer anderen Anwendung öffnen, ist folgendes zu beachten:

Die Bereiche können nicht mehr bearbeitet werden. Sie lassen sich jedoch frei bewegen.

Die Bereiche werden am linken Rand ausgerichtet und nicht mehr entsprechend der Anordnung im Originalarbeitsblatt. Sie können aber frei verschoben werden.


Operand (Definition)

OPERAND

Ein Operand ist eine Zahl oder ein Ausdruck, die bzw. den der Operator als Grundlage für die Auswertung nimmt. Im Ausdruck "5! + 3" sind z. B. die Zahl "3" und der Ausdruck "5!" Operanden des Operators "plus". Die Zahl "5" ist ein Operand des Fakultätsoperators (!).

In der folgenden Tabelle sind Beispiele zu Operanden aufgeführt:


Operatoren und Funktionen für verschachtelte Felder

OPERATOREN UND FUNKTIONEN FÜR VERSCHACHTELTE FELDER (nur in Mathcad Professional)

Viele Feldoperatoren und -funktionen haben im Zusammenhang mit verschachtelten Feldern keine sinnvolle Bedeutung. Es ist z. B. nicht klar, was Matrixmultiplikation bedeutet oder was die Inverse tun soll.

Die folgenden Operatoren und Funktionen können jedoch auch im Zusammenhang mit verschachtelten Feldern verwendet werden:

Operatoren

Transponieren

Matrixindex

Hochgestellter Matrixindex

Vektorindex

Funktionen

erweitern

spalten

letzte

länge

zeilen

stapeln

submatrix


GEWÖHNLICHE DIFFERENTIALGLEICHUNGEN

Im Beispiel unten wird die Verwendung von rkfest zum Auswerten der Lösung einer Differentialgleichung zweiten Grades bei Punkten mit gleichmäßigem Abstand dargestellt.


ÜBERBLICK ÜBER SYMBOLISCHE TRANSFORMATIONEN

Wenn Sie Transformation im Menü Symbolik wählen, wird ein Untermenü mit sechs weiteren Befehlen geöffnet. Mit Hilfe dieser Befehle können Sie Fourier-, Laplace- und z-Transformationen sowie deren Umkehrungen durchführen.

Zum Transformieren eines Ausdrucks gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie Symbolik / Transformation im Menü Symbolik.

  4. Wählen Sie den entsprechenden Befehl für die gewünschte Transformation bzw. inverse Transformation.

Transformationen:

Fourier

Fourier invers

Laplace

Laplace invers

z

Z invers

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolische Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


DIALOGFELD "SEITE EINRICHTEN"

Im Dialogfeld "Seite einrichten" finden Sie die folgenden Optionen und Schaltflächen:

Größe

Ermöglicht die Angabe der Größe des Papiers in Ihrem Drucker.

Papierzufuhr

Ermöglicht die Angabe des Papierschachts, aus dem das zu bedruckende Papier entnommen werden soll.

Hochformat

Wenn diese Option aktiviert ist, wird die Seite im Hochformat gedruckt, also so, daß die längste Ausdehnung der Seite die von oben nach unten ist.

Querformat

Wenn diese Option aktiviert ist, wird die Seite im Querformat gedruckt, also so, daß die längste Ausdehnung der Seite die von links nach rechts ist. Diese Option ist dann sinnvoll, wenn Sie ein Arbeitsblatt ausdrucken lassen wollen, daß breiter als eine Seite ist.

Links

Mit dieser Option geben Sie an, wie groß der Abstand zwischen dem linken Rand des Blattes und dem linken Rand des Druckbereichs sein soll.

Rechts

Mit dieser Option geben Sie an, wie groß der Abstand zwischen dem rechten Rand des Blattes und dem rechten Rand des Druckbereichs sein soll. Der rechte Rand erscheint in Ihrem Fenster als durchgehende vertikale Linie. Eventuell müssen Sie sich mit Hilfe der Bildlaufleiste in Ihrem Fenster nach rechts bewegen, um diese Linie sehen zu können.

Verwechseln Sie diese Linie (den rechten Rand) nicht mit der gepunkteten vertikalen Linie am rechten Rand. Diese gepunktete vertikale Linie zeigt den rechten Rand des Papierblatts an. Wo sich diese gepunktete Linie befindet, hängt davon ab, welchen Standarddrucker Sie in Ihrem Betriebssystem festgelegt haben.

Oben

Mit dieser Option geben Sie an, wie groß der Abstand zwischen dem oberen Rand des Blattes und dem oberen Rand des Druckbereichs sein soll. Wenn Ihr Arbeitsblatt mit einer Kopfzeile versehen ist, erscheint diese innerhalb des Randbereichs an dessen unterer Grenze.

Unten

Mit dieser Option geben Sie an, wie groß der Abstand zwischen dem unteren Rand des Blattes und dem unteren Rand des Druckbereichs sein soll. Wenn Ihr Arbeitsblatt mit einer Fußzeile versehen ist, erscheint diese innerhalb des Randbereichs an dessen oberer Grenze.

Breite einer Seite drucken

Wenn diese Option aktiviert ist, wird nur das gedruckt, was sich links vom rechten Rand befindet.

Drucker...

Mit dieser Schaltfläche können Sie auf das Dialogfeld zur Änderung der aktuellen Druckereinstellungen zugreifen.


PARAMETRISCHE FLÄCHENDIAGRAMME

Parametrische Flächendiagramme heben die Bedingung auf, daß Flächen die Form z = f(x,y) haben müssen. Mit parametrischen Flächendiagrammen können Sie freie Flächen zeichnen.

1. Definieren Sie die drei Matrizen der abzubildenden Elemente. Diese Matrizen enthalten die x-, y- und z-Koordinaten der zu zeichnenden Punkte.

2. Wählen Sie Diagramm / Flächendiagramm im Menü Einfügen, damit ein Flächendiagrammbereich erstellt wird.

3. Geben Sie ( in den Platzhalter ein .

4. Geben Sie die Namen der Matrizen durch Kommas abgetrennt ein.

5. Geben Sie ) ein.

Hinweise:

  • Die drei Matrizen müssen über dieselbe Anzahl von Zeilen und Spalten verfügen.

  • Parametrische Flächendiagramme können nicht in einen anderen dreidimensionalen Diagrammtyp umgewandelt werden.


Teildifferentialgleichungen

PARTIELLE DIFFERENTIALGLEICHUNGEN

Zum Lösen der Poissonschen Gleichung in einem quadratischen Bereich gehen Sie wie folgt vor:

Verwenden Sie relax, wenn die Randbedingung eine Konstante entlang jeder Seite des Quadrats ist.

Verwenden Sie multigit, wenn die Randbedingung an allen vier Seiten Null ist.

Beispiele

Verwenden der Funktion relax

Verwenden der Funktion multigit


PARTIALBRUCHZERLEGUNG

Zum Entwickeln eines rationalen Ausdrucks in eine Summe von Brüchen mit linearen oder quadratischen Nennern gehen Sie folgendermaßen vor:

  1. Markieren Sie die Variable, die zum Faktorisieren der Nenner dienen soll.

  2. Wählen Sie Variable / Partialbruchzerlegung im Menü Symbolik.

Durch diesen Befehl wird versucht, den Nenner in Faktoren umzuwandeln, die in der gewählten Variable linear oder quadratisch (mit rationalen Koeffizienten) sind. Kann der Nenner nicht in der gewählten Variable faktorisiert werden, wird der Ausdruck unverändert ausgegeben.

Hinweise:

  • Mit diesem Befehl können Sie keine Ausdrücke entwickeln, die Bedingungen mit Dezimalpunkten enthalten.

  • Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


Prozent

%

Tastaturbefehl: %

Beschreibung: Diese Konstante ist auf 0.01 festgelegt. Mit Hilfe dieser Konstante können Sie leicht mit Prozentzahlen arbeiten. Beispiel:


PERMUTATIONEN

permut(n,k) Gibt die Anzahl der Möglichkeiten zurück, wie n Objekte bei Auswahl von k Objekten geordnet werden können. Jede dieser Reihenfolgen wird als eine Permutation bezeichnet.

Argumente:

n und k müssen ganze Zahlen größer als 0 sein, wobei k auch gleich 0 sein kann.

n muß größer als oder gleich k sein.

Hinweise:

  • Kombinationen und Permutationen ähneln sich, da es sich in beiden Fällen um Teilmengen einer Menge handelt. Im Unterschied zu einer Kombination ist aber bei einer Permutation die interne Reihenfolge von entscheidender Bedeutung.

  • Die Anzahl der Permutationen wird üblicherweise wie folgt angegeben: .

Die Definition einer Permutation lautet:


pi

Tastaturbefehl: p+Strg+g oder Strg+Umschalttaste+p

Beschreibung: Der Wert von p zu 15 Dezimalstellen in numerischen Berechnungen.

Der genaue Wert von p in symbolischen Berechnungen.


Platzhalter (Definition)

PLATZHALTER

Das kleine, schwarze Feld in einem Rechenbereich ist ein Platzhalter. Der Platzhalter zeigt an, daß der mathematische Ausdruck oder das Diagramm unvollständig ist. Um den Ausdruck bzw. das Diagramm zu vervollständigen, müssen Sie etwas Passendes in den Platzhalter eingeben.

Klicken Sie dazu auf den Platzhalter, und geben Sie das Gewünschte ein.


WIEDERGABEFENSTER

Klicken Sie auf die verschiedenen Teile des folgenden Bildes, um nähere Beschreibungen zu den einzelnen Elementen zu erhalten.


WIEDERGEBEN EINER ZUVOR GESPEICHERTEN ANIMATION

Gehen Sie zum Wiedergeben einer zuvor gespeicherten Animation (bzw. einer Windows AVI-Datei) wie folgt vor:

  1. Wählen Sie den Befehl Wiedergeben im Menü Ansicht. Das Dialogfeld "Wiedergeben" wird geöffnet.

  2. Klicken Sie auf [image] die Schaltfläche.

  3. Wählen Sie Öffnen aus dem eingeblendeten Menü.

  4. Doppelklicken Sie auf den Namen der Animation, die geöffnet werden soll.

  5. Spielen Sie die gesamte Animation durch Klicken auf die Wiedergabeschaltfläche ab.

  6. Sie können die Bilder auch nacheinander mit Hilfe des Schiebereglers anzeigen.


PUNKTOPTIONEN FÜR EIN 3D-DIAGRAMM

Zum Zeichnen und Formatieren der Punkte in einem 3D-Diagramm gehen Sie folgendermaßen vor:

1. Doppelklicken Sie auf das Diagramm, um das Dialogfeld "3D-Diagrammformat" zu öffnen.

2. Klicken Sie auf die Registerkarte "Darstellung".

3. Mit den Optionen im Abschnitt "Punktoptionen" der Seite "Darstellung" haben Sie folgende Möglichkeiten:

  • Zeichnen oder Entfernen von Punkten

  • Wählen von Symbolen für die einzelnen Punkte

  • Festlegen einer Größe für die Symbole

  • Einfärben der Symbole mit einer Volltonfarbe oder nach einer Farbzuordnung

4. Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "OK", um das Dialogfeld zu schließen.


ZEIGER

Der Zeiger oder Mauszeiger ist das Element, das sich beim Verschieben der Maus auf dem Bildschirm bewegt. Er kann viele verschiedene Formen annehmen. Klicken Sie unten auf das entsprechende Bild, wenn Sie genauere Angaben benötigen.

Plazieren eines Cursors

Ändern der Größe eines Bereichs

Ziehen eines Bereichs

Ziehen des mathematischen Ausdrucks


MAUSZEIGER (DEFINITION)

Der Mauszeiger ist das Symbol, das sich mit der Maus bewegt. Er kann drei verschiedene Formen annehmen:

Meistens wird der Mauszeiger als Pfeil dargestellt.

Wenn Sie den Mauszeiger über einen markierten Bereich hinaus verschieben, nimmt er die Form einer kleinen Hand an.

Wenn die Zwischenablage einen mathematischen Ausdruck enthält und Sie den Mauszeiger bei gedrückter Strg-Taste ziehen, nimmt er die Form eines Pfeils mit einem kleinen Kästchen an seiner Spitze an.


POISSON-VERTEILUNG

dpois(k, l ) Gibt die Wahrscheinlichkeitsdichte für die Poisson-Verteilung zurück.

ppois(k, l ) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qpois(p, l ) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rpois(m, l ) Gibt einen Vektor aus m Zufallszahlen zurück, die die Poisson-Verteilung aufweisen.


Poissonsche Gleichung

POISSONSCHE GLEICHUNG (nur in Mathcad Professional)

relax(a, b, c, d, e, f, u, rjac)

Gibt eine quadratische Matrix zurück, in der (1) die Position eines Elements in der Matrix der Position dieses Elements innerhalb des quadratischen Bereichs entspricht, und (2) der Wert sich dem Wert der Lösung an diesem Punkt annähert.

Argumente:

a, b, c, d, e sind quadratische Matrizen derselben Größe, die Koeffizienten der Differentialgleichung enthalten.

f ist eine quadratische Matrix, die für alle Punkte innerhalb des Quadrats den Quellterm enthält.

u ist eine quadratische Matrix, die Grenzwerte entlang der Ränder des Bereichs sowie Anfangsschätzwerte für die Lösung innerhalb des Bereichs enthält.

rjac ist ein Spektralradius der Jacobischen Iteration. Hiermit wird die Konvergenz des Relaxationsalgorithmus bestimmt. Sie kann zwischen 0 und 1 liegen, der optimale Wert hängt jedoch von den genauen Einzelheiten Ihres Problems ab.

Hinweise:

  • Diese Funktion verwendet das Relaxationsverfahren zum Ermitteln der Lösung.

  • Verwenden Sie die Funktion relax, wenn Sie den Wert kennen, den die unbekannte Funktion u(x, y) an allen vier Seiten eines quadratischen Bereichs annimmt.

  • Wenn die Randbedingung an allen vier Seiten des Gebiets für die Quadratintegration Null ist, ist statt dessen die Funktion multigit zu verwenden.

Beispiel:

Arbeiten mit der Funktion relax


Poissonsche Gleichung mit Null-Randbedingungen

POISSONSCHE GLEICHUNG MIT NULL-RANDBEDINGUNGEN (nur in Mathcad Professional)

multigit(M, nzyklus)

Gibt eine quadratische Matrix zurück, in der (1) die Position eines Elements in der Matrix der Position dieses Elements innerhalb des quadratischen Bereichs entspricht und (2) der Wert sich dem Wert der Lösung an diesem Punkt annähert.

Argumente:

M ist eine quadratische Matrix mit 1+2^n Zeilen, deren Elemente dem Quellterm am entsprechenden Punkt im Quadratgebiet entsprechen.

nzyklus ist die Anzahl der Zyklen auf jeder Ebene der multigit-Iteration. Der Wert 2 gibt im allgemeinen eine gute Annäherung an die Lösung.

Hinweise:

  • Wenn u(x, y) an allen vier Seiten des Quadrats Null ist, verwenden Sie die Funktion multigit. Diese Funktion löst das Problem häufig schneller als relax.

Beispiel:

Arbeiten mit der Funktion "multigit"


Kreiswinkelfunktionen

WINKEL

winkel(x,y) Diese Funktion gibt den Winkel (in Radiant) zwischen der positiven x-Achse und dem Punkt (x,y) zurück. Der zurückgegebene Wert liegt stets zwischen 0 und 2p (aber nicht gleich 2p).

atan2(x,y) Gibt den Winkel (in Radiant) zwischen der x-Achse und einer Linie an, die den Ursprung (0,0) und den Punkt (x,y) enthält. Der zurückgegebene Wert liegt stets zwischen -p und p (auch gleich p).

Argumente:

x und y müssen reell sein.

Hinweise:

Die Funktion atan2 steht zu den Funktionen atan und arg wie folgt in Beziehung:

atan2(x,y) = atan(y/x)

atan2(x,y) = arg(x + yi)

Die von der Funktion atan2 zurückgegebenen Werte (in Radiant) liegen stets zwischen -p und p (auch gleich p).

Wird ein positives Ergebnis zurückgegeben, wird der Winkel von der x-Achse aus entgegen dem Uhrzeigersinn gemessen.

Wird ein negatives Ergebnis zurückgegeben, wird der Winkel von der x-Achse aus im Uhrzeigersinn gemessen.

Verwandte Themen

Umwandlung in Grad


POLYNOMREGRESSION

regress(vx,vy,k) Gibt einen Vektor zurück, mit dem interp versucht, das Polynom k-ter Ordnung zu ermitteln, das den Datenwerten x und y in vx und vy am ehesten entspricht.

interp(vs,vx,vy,x) Gibt einen interpolierten Wert für y zurück, der x entspricht. Sie erhalten vs aus regress.

Argumente:

vx ist ein Vektor aus reellen Datenwerten in aufsteigender Reihenfolge. Diese entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. vy hat die gleiche Anzahl von Elementen wie vx.

vs ist ein Vektor, der von regress generiert wird.

k ist eine positive ganze Zahl, die die Ordnung des Polynoms angibt, das Sie an die Daten anpassen wollen. Für gewöhnlich gilt k < 5.

x ist der Wert der unabhängigen Variable, an der die Regressionskurve ausgewertet werden soll.

Hinweise:

  • Regress erweist sich als sinnvoll, wenn Sie verschiedene gemessene y-Werte haben, die x-Werten entsprechen, und ein einzelnes Polynom beliebiger Ordnung an diese y-Werte angepaßt werden soll.

  • Immer, wenn Sie die Funktion regress verwendet haben, sollten Sie die Funktion interp einsetzen.

  • Da die Funktion regress versucht, alle Ihre Datenpunkte mit einem einzigen Polynom abzudecken, kommt es zu keinem sinnvollen Ergebnis, wenn sich Ihre Daten nicht wie ein Einzelpolynom verhalten. Soll eine lokalisiertere Regression vorgenommen werden, ist die Funktion loess zu verwenden.

  • Wenn Sie eine Fläche an die Daten x, y und z anpassen wollen, verwenden Sie zum Ausführen der multivariablen Polynomregression die Funktion regress.


Polynomregression, lokalisiert

POLYNOMREGRESSION, LOKALISIERT (nur in Mathcad Professional)

loess(vx,vy,bereich) Gibt einen Vektor zurück, mit dem interp versucht, eine Reihe von Polynomen zweiter Ordnung zu ermitteln, die einer Umgebung der Datenwerte x und y in vx und vy am ehesten entspricht. bereich bestimmt die Größe der Umgebung.

interp(vs,vx,vy,x) Gibt einen interpolierten Wert für y zurück, der x entspricht. Sie erhalten vs aus loess oder regress.

Argumente:

vx ist ein Vektor aus reellen Datenwerten in aufsteigender Reihenfolge. Diese entsprechen den x-Werten.

vy ist ein Vektor aus reellen Datenwerten. Diese entsprechen den y-Werten. vy hat die gleiche Anzahl von Elementen wie vx.

vs ist ein Vektor, der von loess generiert wird.

bereich ist eine positive reelle Zahl, mit der die Größe der gewünschten Umgebung angegeben wird. Für bereich sind große Werte zu empfehlen, wenn sich die Daten über verschiedenen Bereichen von x sehr unterschiedlich verhalten. Allgemein ist bereich=0.75 als Standardwert gut geeignet.

x ist der Wert der unabhängigen Variable, an der die Regressionskurve ausgewertet werden soll.

Hinweise:

  • loess erweist sich als sinnvoll, wenn Sie verschiedene gemessene y-Werte haben, die x-Werten entsprechen, und ein einzelnes Polynom beliebiger Ordnung an diese y-Werte angepaßt werden soll.

  • Immer, wenn Sie die Funktion loess verwendet haben, sollten Sie die Funktion interp einsetzen.

  • Diese Funktion versucht, unterschiedliche Polynome zweiten Grades in Abhängigkeit davon, wo Sie sich auf der Kurve befinden, anzupassen. Dies erfolgt, indem die Daten in einer engen Umgebung des Punktes, der von Interesse ist, geprüft werden. Die Größe dieser Umgebung legen Sie über das Argument bereich fest. Wenn bereich größer wird, entspricht loess der Funktion regress mit n=2.

  • Wenn Sie eine Fläche an die Daten x, y und z anpassen sollen, verwenden Sie für die multivariable Polynomregression die Funktion loess.


FUNKTION "stdev" (STANDARDABWEICHUNG FÜR POPULATION)

stdev(A) Gibt die Quadratwurzel der Varianz der Elemente in A zurück.

Argumente:

A ist ein aus m x n Elementen bestehendes Feld.

Zu beachten ist, daß die Funktion stdev bei der Berechnung der Varianz durch n und nicht durch n-1 dividiert. Sie können die Standardabweichung, die dem Nenner n-1 entspricht, dadurch berechnen, daß Sie das Ergebnis dieser Funktion mit der Quadratwurzel von n/(n-1) multiplizieren.

Weitere Funktionen für die Datenanalyse...


FUNKTION "var" (POPULATIONSVARIANZ)

Argumente:

A ist ein aus m x n Elementen bestehendes Feld.

Zu beachten ist, daß diese Funktion bei der Berechnung der Varianz durch mn und nicht durch mn-1 dividiert. Sie können die Varianz, die dem Nenner mn-1 entspricht, dadurch berechnen, daß Sie das Ergebnis dieser Funktion mit mn/(mn-1) multiplizieren.

Weitere Funktionen für die Datenanalyse...


LEISTUNGS- UND PHASENSPEKTRUM

Die Funktionen fft und cfft geben den Real- und den Imaginärteil der Fourier-Transformation zurück. Mit Hilfe des Operators "Vektorisieren" können Sie deren Leistungs- und Phasenspektrum wiederherstellen:

Zum Verwenden des Operators "Vektorisieren" gehen Sie wie folgt vor:

Setzen Sie den gesamten Ausdruck zwischen Bearbeitungslinien.

Drücken Sie Strg+-.

Der Operator "Vektorisieren" bewirkt, daß der Operator "Betrag" den absoluten Wert jedes Elements in v, und nicht den absoluten Wert des Vektors v selbst, zurückgibt.


Genauigkeit in Datendateien

PRNPRECISION (STANDARD = 4)

Diese Konstante stellt die Anzahl der signifikanten Ziffern beim Schreiben in eine Datei mit der Funktion PRNSCHREIBEN dar.

Um sie zu ändern, wählen Sie Optionen / Registerkarte "Vordefinierte Variablen" aus dem Menü Rechnen.


DIALOGFELD "EINSTELLUNGEN"

Auf der Registerkarte "Allgemein" des Dialogfelds "Einstellungen" finden Sie die folgenden Optionen:

Tips und Tricks beim Programmstart anzeigen

Wenn diese Option aktiviert ist, erscheint bei jedem Starten von Mathcad das Dialogfeld "Tips und Tricks".

Informationszentrum beim Programmstart öffnen

Wenn diese Option aktiviert ist, erscheint bei jedem Starten von Mathcad das Fenster "Informationszentrum".

Standardmäßige Windows-Tastaturbefehle verwenden

Wenn diese Option aktiviert ist, gelten für bestimmte Operationen, wie z. B. für das Drucken und das Rückgängigmachen, die von den Standard-Windows-Anwendungen her bekannten Tastaturbefehle. Ist diese Option nicht aktiviert, gelten die Tastaturbefehle weiter, die von früheren Mathcad-Versionen her bekannt sind. Die jeweils gültigen Tastaturbefehle werden direkt neben den Menübefehlen in der Menüleiste angezeigt.

Kontextspezifische Gleichheitszeichen verwenden

Wenn diese Option aktiviert ist, wird durch Drücken der Taste "=" entweder ein Auswertungs-Gleichheitszeichen oder das Definitionssymbol (:=) eingefügt. Das Auswertungs-Gleichheitszeichen erscheint dann, wenn die Taste "=" rechts von einer definierten Variable gedrückt wird, und das Definitionssymbol wird eingefügt, wenn die Taste "=" rechts von einer undefinierten Variable betätigt wird.


Dialogfeld "Einstellungen": Registerkarte "Internet"

DIALOGFELD "EINSTELLUNGEN"

Auf der Registerkarte "Internet" des Dialogfelds "Einstellungen" finden Sie die folgenden Optionen und Schaltflächen:

Benutzername

Dies ist der Name, den Sie bei der ersten Ausführung des Installationsprogramms eingegeben haben. Dieser Name erscheint in Nachrichten, die Sie an die WWW-Foren senden.

E-Mail

Dies ist Ihre E-Mail-Adresse. Diese E-Mail-Adresse erscheint in Nachrichten, die Sie an die WWW-Foren senden.

WWW-Foren

Dies ist die URL -Adresse, mit der eine Verbindung hergestellt wird, wenn Sie den Befehl WWW-Foren im Menü Datei wählen. Der Standardwert in diesem Feld entspricht der URL-Adresse eines WWW-Foren-Servers, der von MathSoft unterhalten wird.

Server-Name

Wenn Sie auf einen Proxy-Server zurückgreifen, ist hier der Name des Computers einzugeben, der als Proxy für das entsprechende Protokoll verwendet werden soll.

Port

Wenn Sie auf einen Proxy-Server zurückgreifen, ist hier eine ganze Zahl größer als Null einzugeben, mit der Sie festlegen, welchen Port der entsprechenden Proxy-Server für die Kommunikation mit der Außenwelt verwenden soll. Lassen Sie dieses Feld leer, wenn Sie den Standardwert übernehmen möchten.


EXPERT SOLVER

Der Mathcad Expert Solver steht Nutzern von Mathcad Professional zur Verfügung, die für das Lösen von Gleichungen und Optimieren von Funktionen umfangreichere Analysemöglichkeiten benötigen. Der Expert Solver tritt dabei an die Stelle des einfachen Lösungsalgorithmus von Mathcad 8 Professional.

Der Mathcad Expert Solver bietet zusätzliche Lösungsalgorithmusfunktionen und -merkmale (wie z. B. die Unterstützung für quadratisches Programmieren), eine höhere Verarbeitungsggeschwindigkeit für lineare und nichtlineare Lösungsalgorithmen sowie die Möglichkeit, größere numerische Probleme lösen zu können. Mit dem Expert Solver sind Sie in der Lage, Probleme zu bearbeiten, die aus bis zu 500 nichtlinearen Variablen bzw. bis zu 1000 linearen Variablen bestehen.

Weitere Informationen zum Expert Solver-Paket und dazu, wie Sie es erwerben können, erhalten Sie bei MathSoft.


DIALOGFELD "DRUCKEN"

Im Dialogfeld "Drucken" finden Sie die folgenden Optionen und Schaltflächen:

Name

In diesem Feld können Sie festlegen, welcher Drucker verwendet werden soll. Standardmäßig sendet Mathcad den Druckauftrag an den von Ihnen als Standarddrucker festgelegten Drucker. Klicken Sie auf "Eigenschaften", wenn die Ausgabe auf einem anderen Drucker erfolgen soll.

Schaltfläche "Eigenschaften"

Wenn Sie hier klicken, wird ein Dialogfeld geöffnet, in dem Sie aus den bei Ihnen installierten Druckern einen Drucker auswählen sowie die Papiergröße, die Papierzufuhrquelle und die Ausrichtung (Quer- oder Hochformat) festlegen können. Weitere Informationen dazu finden Sie in der Dokumentation Ihres Betriebssystems.

Ausdruck in Datei

Gibt Ihr Arbeitsblatt direkt als Datei aus, statt es an einen Drucker zu senden.

Alles

Es werden alle Seiten des Arbeitsblatts gedruckt.

Seiten

Es wird ein bestimmter Seitenbereich gedruckt. Geben Sie in den Feldern "Von" und "Bis" den gewünschten Seitenbereich ein. Wenn Sie als Ausgabegerät einen Plotter festgelegt haben, können Sie immer nur eine Seite drucken.

Auswahl

Es werden nur die ausgewählten (markierten) Bereiche gedruckt. Falls die Option abgeblendet dargestellt ist, haben Sie keine Bereiche ausgewählt.

Exemplare

Mit dieser Option legen Sie fest, wie viele Exemplare des Arbeitsblatts gedruckt werden sollen. Wenn diese Option abgeblendet dargestellt ist, unterstützt Ihr Drucker diese Option wahrscheinlich nicht. Überprüfen Sie die Druckereinrichtung in Windows.


Bis zum rechten Rand drucken

Breite einer Seite drucken

Durch Klicken auf diese Option können Sie verhindern, daß die Bereiche gedruckt werden, die sich rechts vom rechten Rand befinden.


DRUCKEN EINER HERVORGEHOBENEN GLEICHUNG

Wenn Sie ein Arbeitsblatt ausdrucken, das hervorgehobene Gleichungen enthält, hängt es vom jeweils verwendeten Drucker ab, wie die Hervorhebung dargestellt wird. Bei einigen Druckern werden farbige Passagen schwarz gedruckt, so daß hervorgehobene Gleichungen nicht mehr erkennbar sind. Andere Drucker wiederum geben die gleiche Farbe in einer solchen Graustufe aus, daß die hervorgehobene Gleichung nicht unkenntlich wird. Auf einem Farbdrucker sollte die Gleichung in der gewählten Farbe gedruckt werden.


DRUCKEN BREITER ARBEITSBLÄTTER

Arbeitsblätter in Mathcad können breiter als ein Blatt Papier sein.

Um das Ausdrucken aller über den rechten Rand hinausgehenden Bereiche zu unterdrücken, gehen Sie wie folgt vor:

Wählen Sie den Befehl Seite einrichten aus dem Menü Datei.

Aktivieren Sie die Option "Breite einer Seite drucken".

Klicken Sie auf "OK".


PRODUKT MIT BEREICHSVARIABLEN

Tastaturbefehl: #

Gibt das Produkt des Ausdrucks X über den Bereich i zurück.

Operanden:

i muß ein Bereich von ganzen Zahlen sein.

X ist ein beliebiger Ausdruck.

Wenn X mehrere Glieder hat, müssen Sie diese in Klammern einschließen, um sie innerhalb des Operators zu halten.

Die Bereichsvariable i ist vor der Verwendung dieses Operators zu definieren. Beispiel:


PRODUKT OHNE BEREICHSVARIABLEN

Tastaturbefehl: Strg+Umschalt+3

Gibt das Produkt zurück, wobei i von m bis n des Ausdrucks X reicht.

Operanden:

i muß eine ganze Zahl sein.

X ist ein beliebiger Ausdruck.

m und n müssen ganze Zahlen sein, wobei m < n ist.

Wenn X mehrere Glieder hat, müssen Sie diese in Klammern einschließen, um sie innerhalb des Operators zu halten.

Die Variable i ist nur innerhalb dieses Operators definiert und steht daher in keinerlei Zusammenhang mit Variablendefinitionen außerhalb des Operators "Produkt".


Programmierleiste

PROGRAMMIERLEISTE (nur Mathcad Professional)

Die Programmierleiste bietet schnellen Zugriff auf die Operatoren, die bei der Programmierung benötigt werden. Sie können sehen, wozu die einzelnen Schaltflächen dienen, wenn Sie den Cursor im Haupt-Arbeitsblattfenster über die Schaltfläche setzen, bis folgendes passiert:

  • Der Name der Schaltfläche wird in einem QuickInfo, einem kleinen Popup-Fenster, angezeigt.

  • Eine Beschreibung der Schaltfläche erscheint in der Meldungszeile der Statusleiste.


QR-Dekomposition

QR-DEKOMPOSITION (nur in Mathcad Professional)

qr(A) Gibt eine Matrix zurück, deren erste n Spalten die quadratische, orthonormale Matrix Q enthalten, und deren restliche Spalten die obere Dreiecksmatrix R enthalten. Mit der Funktion submatrix können Sie diese kleineren Matrizen extrahieren.

Die Matrizen Q und R erfüllen die Gleichung [image].

Argumente:

A muß entweder ein Vektor oder eine Matrix sein.

Die Elemente von A müssen reell sein.


Quadratisch

QUADRATISCH (nur in Mathcad Professional)

Diese Option steht nur zur Verfügung, wenn Sie den Expert Solver installiert haben.

Wählen Sie diese Option, wenn Sie ein quadratisches Programm lösen und eine quadratische Programmierungsmethode zuweisen wollen.

Hinweise:

  • Unter einem quadratischen Programm versteht man ein Programm, in dem die Zielfunktion lineare und quadratische Glieder, z. B. in der Form a*x2 or c*x*y, enthält.

  • Wenn Sie die Option Quadratisch wählen, müssen im Gleichungssystem Schätzwerte enthalten sein. Die Schätzwerte sind jedoch immateriell, so daß sie sich nicht auf die Lösung auswirken, es sei denn, es wird nach einem Matrix- oder Vektorergebnis aufgelöst. In diesem Fall gibt der Schätzwert für den Vektor bzw. die Matrix die Größe des zu suchenden Vektors bzw. der zu suchenden Matrix an.

  • Die Option Quadratisch verwendet zur Lösung nicht die vordefinierte Variable TOL.

Weitere Informationen zum Arbeiten mit der Option "Quadratisch" finden Sie unter "Referenzmaterial zu den Lösungsalgorithmen".


LÖSEN MIT DER QUASI-NEWTON-METHODE

Die Quasi-Newton-Methode ist eine der nichtlinearen Methoden, die zusammen mit den Funktionen suchen, minfehl, minimieren und maximieren verwendet werden kann.

Die Steuerung der Quasi-Newton-Methode in Mathcad Professional erfolgt über die erweiterten Optionen. Zum Ändern dieser Optionen gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Lösungsfunktion: suchen, minfehl, minimieren oder maximieren.

  2. Wählen Sie den Befehl Erweiterte Optionen... aus dem Kontextmenü.

  3. Wählen Sie im Dialogfeld "Erweiterte Optionen" die Option "Ableitungsschätzung", "Variablenschätzung" oder "Lineare Variablenprüfung".

Diese Optionen sollten nur von erfahrenen Benutzern verwendet werden, und auch erst dann, wenn mit den Standardoptionen keine Lösung gefunden werden konnte bzw. wenn eine genaue Einflußnahme auf das Lösungsverfahren gewünscht wird.

Weitere Informationen zur Quasi-Newton-Methode finden Sie unter "Referenzmaterial zu den Lösungsalgorithmen".


RANG EINER MATRIX

rang(A) Gibt den Rang von A zurück.

Argumente:

A muß ein Vektor oder eine Matrix sein.

Die Elemente von A müssen reell sein.


Funktion LESEN

LESEN VON DATEN AUS EINER DATEI

LESEN("datei") Gibt einen einzelnen Eintrag aus der Datei datei zurück.

Argumente:

datei ist entweder ein Dateiname oder der Pfad zu einer ASCII-Datei.

datei wird als Zeichenfolge eingegeben.

datei muß Zahlen enthalten, die in Spalten angeordnet und durch Tabulator- oder Leerzeichen getrennt sind.

LESEN wird im Normalfall zusammen mit einer Bereichsvariable verwendet, wie z. B.:

i := 1 .. N

:= LESEN("datei.dat")

Damit wird ein Feld v erstellt, das die Zahlen in der Datei datei.dat enthält.

Die zu lesende Datei muß eine ASCII-Datei sein, die eine Liste aus durch Tabulator- oder Leerzeichen voneinander getrennten Dezimalzahlen enthält. Die Exponentialschreibweise, wie in

16E-2-16.125E-15,

ist erlaubt.

ACHTUNG: Mathcad 8 enthält diese Funktion nur, um die Kompatibilität mit älteren Mathcad-Versionen zu gewährleisten. Die Funktion ist jedoch veraltet und sollte nicht mehr verwendet werden. Verwenden Sie zum Lesen von Daten aus einer Datendatei statt dessen die Komponente "Dateien lesen/schreiben" bzw. die Funktion PRNLESEN.


Lesen einer BMP-DATEI als Farbbild

LESEN EINER DATEI ALS FARBBILD

RGBLESEN("datei") Gibt ein Feld zurück, das aus drei Untermatrizen mit nxn Elementen besteht. Jedes Element ist eine ganze Zahl zwischen 0 und 255. Die ersten n/3 Spalten stehen für den Rotanteil des Bilds in datei. Die zweite und dritte Folge von n/3 Spalten steht für den Grün- und den Blauanteil desselben Bildes. Die drei zusammengehörigen Matrixelemente bestimmen jeweils die Farbe des Pixels.

Argumente:

datei ist entweder ein Dateiname oder der Pfad zu einer BMP-, GIF-, JPG- oder TGA-Datei.

datei wird als Zeichenfolge eingegeben.

Die Aufteilung des Bildes in drei Gruppen aus jeweils n/3 Spalten erleichtert die Änderung des Bildes vor dessen Ausgabe auf dem Bildschirm. Vor der Anzeige sollten Sie das Bild jedoch in drei voneinander getrennte Matrizen mit jeweils n Spalten aufteilen, die Sie dann, durch Kommas getrennt, in den Platzhalter eingeben können.

Nach dem Einlesen einer Datei in Mathcad können Sie sie mit dem Bildoperator anzeigen lassen.

Verwandte Funktionen...


LESEN EINER BMP-DATEI ALS GRAUSTUFENBILD

BMPLESEN("datei") Gibt ein Feld ganzer Zahlen zwischen 0 (schwarz) und 255 (weiß) zurück, das eine Graustufenversion des Bildes in datei darstellt.

Argumente:

datei ist entweder ein Dateiname oder der Pfad zu einer BMP-Datei.

datei wird als Zeichenfolge eingegeben.

Nach dem Einlesen einer Datei in Mathcad können Sie sie mit dem Bildoperator anzeigen lassen.

Verwandte Funktionen...


Lesen und Schreiben komplexer Daten in ASCII-Datendateien

LESEN UND SCHREIBEN KOMPLEXER DATEN

Generell empfiehlt es sich, den Realteil und den Imaginärteil einer komplexen Zahl jeweils in eigene Dateien zu schreiben.

Angenommen, Z sei eine komplexe Matrix. Befehlsbeispiel:

PRNSCHREIBEN("z_real.prn") := Re(Z)

PRNSCHREIBEN("z_imag.prn") := Im(Z)

Um die auf diese Weise gespeicherten Daten einzulesen, geben Sie folgendes ein:

Z := PRNLESEN("z_real.prn") + 1i * PRNLESEN("z_imag.prn")


LESEN EINZELNER WERTE AUS EINER DATENDATEI

Wenn Sie mit Hilfe der Komponente "Dateien lesen/schreiben" Daten aus einer Datendatei lesen lassen, liest Mathcad standardmäßig die gesamte Datendatei. Sie können jedoch auch einzelne Zeilen oder Spalten lesen lassen. Gehen Sie dazu wie folgt vor:

Fügen Sie die Komponente "Dateien lesen/schreiben" ein, so daß Daten aus einer Datendatei gelesen werden.

Klicken Sie auf die Komponente "Dateien lesen/schreiben", um sie auszuwählen.

Wählen Sie den Befehl Eigenschaften aus dem Kontextmenü, damit das Dialogfeld "Eigenschaften" geöffnet wird.

Legen Sie in diesem Dialogfeld fest, an welchen Zeilen und Spalten mit dem Lesen begonnen und aufgehört werden soll.


Lesen aus einer anderen Datei

LESEN AUS EINER ANDEREN BZW. SCHREIBEN IN EINE ANDERE DATEI

Beim Einfügen der Komponente "Dateien lesen/schreiben" geben Sie an, aus welcher Datei gelesen bzw. in welche Datei geschrieben werden soll. Wenn Sie später aus einer anderen Datendatei lesen oder in eine Datendatei eines anderen Typs schreiben wollen, können Sie dies mit den folgenden Schritten tun:

Klicken Sie mit der rechten Maustaste auf die Komponente, und wählen Sie aus dem Kontextmenü der Komponente den Befehl Datei auswählen.... Daraufhin wird entweder das Dialogfeld "Aus Datei lesen" oder das Dialogfeld "In Datei schreiben" geöffnet.

Wählen Sie im Textfeld "Dateityp:" den Typ der Datei, in die geschrieben bzw. aus der gelesen werden soll, suchen Sie im Dialogfeld nach der Datendatei, wählen Sie sie aus, und klicken Sie auf "Öffnen".


EINLESEN DES BILDS IN EINE MATRIX

Als erster Schritt bei der Bildverarbeitung muß das Bild zur Verfügung gestellt werden, das verarbeitet werden soll. Sie können diesen Schritt durchführen, indem Sie das Bild von einem Datenträger in eine Matrix einlesen, so wie jede andere Datendatei.

Hierzu haben Sie zwei Möglichkeiten:

Erstellen Sie mit RGBLESEN oder einer anderen Funktion eine Matrix, die einer Datei entspricht. Beispiel:

M := RGBLESEN("datei")

Erstellen Sie mit BMPLESEN oder einer anderen Funktion eine Matrix, die der Graustufendarstellung einer bestimmten Datei entspricht. Beispiel:

M := BMPLESEN(”datei”)

Beachten Sie, daß die Funktionen in GROSSBUCHSTABEN stehen müssen.


Lesen von Daten aus einer Datendatei mit Hilfe einer Funktion

LESEN VON DATEN AUS EINER DATENDATEI

PRNLESEN("datei") Gibt ein Feld mit dem Inhalt der Datei datei zurück.

Argumente:

datei ist entweder ein Dateiname oder der vollständige Pfad zu einer strukturierten ASCII-Datendatei.

datei wird als Zeichenfolge eingegeben.

Beispiele:

Mit PRNLESEN("daten.prn") wird die Datei daten.prn eingelesen, die sich im Standardverzeichnis befindet.

Mit PRNLESEN ("c:\meins\final\ausgabe.prn") wird die Datei ausgabe.prn eingelesen, die sich im Verzeichnis c:\meins\final befindet.

Hinweis: Wenn Sie das Argument dieser Funktion ändern, sollten Sie es stets aktualisieren. Klicken Sie dazu auf das Argument, und wählen Sie den Befehl Berechnen im Menü Rechnen.


Rekursion

REKURSION (nur Mathcad Professional)

Rekursion ist eine Programmiersprache, in der eine Variable auf sich selbst bezogen definiert wird, wie im folgenden Beispiel gezeigt:

Rekursive Funktionsdefinitionen müssen immer mindestens zwei Teile enthalten:

Eine Initiierungsbedingung, die verhindert, daß die Rekursion in einer Endlosschleife endet.

Eine Definition der Funktion bezogen auf einen früheren Wert.

Das Konzept ähnelt der zugrunde liegenden mathematischen Induktion: wenn Sie f(n+1) aus f(n) erhalten können, und Sie kennen f(0), haben Sie alle erforderlichen Angaben über f.

Beachten Sie jedoch, daß rekursive Funktionsdefinitionen trotz ihrer Benutzerfreundlichkeit und Prägnanz nicht immer die am effektivsten zu verarbeitenden Definitionen sind. Möglicherweise erfolgt durch eine entsprechende Definition mit einer der Iterationsschleifen eine schnellere Auswertung.

Aufrufen eines QuickSheet-Beispiels


NEUDEFINIEREN VON INTEGRIERTEN MATHEMATISCHEN KONSTANTEN

Sie können den Wert folgender Konstanten ändern:

unendlich

p

e

i

j

%

Hierzu setzen Sie ":=" in Ihrem Arbeitsblatt auf die gleiche Weise ein wie eine Variable.

Verwandte Themen:

Neudefinieren von integrierten Systemkonstanten


NEUDEFINIEREN VON INTEGRIERTEN SYSTEMKONSTANTEN

Sie können den Wert folgender Konstanten ändern:

ORIGIN

PRNPRECISION

TOL

CTOL

PRNCOLWIDTH

Führen Sie einen der beiden folgenden Schritte aus:

Neudefinieren der Konstanten mit ":=" im Arbeitsblatt

Wählen des Befehls Optionen / Registerkarte "Vordefinierte Variablen" aus dem Menü Rechnen.

Verwandte Themen:

Neudefinieren von integrierten mathematischen Konstanten


REFERENZMATERIAL ZU DEN LÖSUNGSALGORITHMEN

Weitere Informationen zu den einzelnen Lösungmethoden, die beim Lösungsprozeß der Funktionen suchen, minfehl, minimieren und maximieren zum Einsatz kommen, finden Sie in:

Press, W. H., W. T. Flannery, S. A.Teukolsky und B. P. Vetterling.
Numerical Recipes in C
Cambridge University Press, New York, 1992

Polak, E. Optimization – Algorithms and Consistent Approximations Springer-Verlag, Berlin/Heidelberg, 1997

Winston, W. Operations Research: Applications and Algorithms Belmont, Wadsworth, 1994


Beziehung zu hyperbolischen Funktionen

DEFINITIONEN DER HYPERBOLISCHEN FUNKTIONEN


Beziehung zwischen trigonometrischen und hyperbolischen Funktionen

BEZIEHUNG ZU TRIGONOMETRISCHEN FUNKTIONEN


DIALOGFELD "ERSETZEN"

Das Dialogfeld "Ersetzen" enthält folgende Elemente:

Suchen nach:

Geben Sie die gesuchten Zeichen ein.

Ersetzen durch:

Geben Sie die Zeichen ein, die die Zeichen im Feld "Suchen nach:" ersetzen sollen.

Nur ganzes Wort suchen

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen im Feld "Suchen nach" nur als ganzes Wort und nicht als Bestandteil längerer Wörter gesucht werden sollen.

Groß-/Kleinschreibung beachten

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen genau der Groß-/Kleinschreibung entsprechen sollen, die Sie im Textfeld "Suchen nach:" eingeben.

In Textbereichen suchen

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen nur in den Textbereichen gesucht werden sollen.

In Rechenbereichen suchen

Markieren Sie dieses Kontrollkästchen, wenn die Zeichen nur in den Rechenbereichen (Gleichungen und Diagrammen) gesucht werden sollen.

Weitersuchen

Sucht die nächste bzw. vorangegangene Stelle, an der die Zeichen aus dem Textfeld "Suchen nach:" vorkommen.

Ersetzen

Ersetzt die derzeit ausgewählten Zeichen durch die Zeichen im Textfeld "Ersetzen durch:".

Alle ersetzen

Ersetzt die Zeichen im Feld "Suchen nach" überall im Suchbereich durch die Zeichen im Textfeld "Ersetzen durch:".


Ändern der Größe einer Komponente

ÄNDERN DER GRÖSSE EINER KOMPONENTE

Zum Vergrößern bzw. Verkleinern einer Komponente gehen Sie wie folgt vor:

Doppelklicken Sie auf die Komponente, um sie zu aktivieren.

Positionieren Sie den Mauszeiger über einem der Haltepunkte. Der Mauszeiger verwandelt sich in einen Doppelpfeil.

Drücken Sie die Maustaste, und halten Sie sie gedrückt.

Ziehen Sie den Haltepunkt der Komponente mit der Maus auf die gewünschte Größe.


Ändern der Größe von Ausgabetabellen mit Bildlaufleiste

ÄNDERN DER GRÖSSE VON AUSGABETABELLEN MIT BILDLAUFLEISTE

Zum Ändern der Größe einer Ausgabetabelle gehen Sie wie folgt vor:

  1. Klicken Sie auf die Ausgabetabelle. Um die Tabelle sollte ein Auswahlfeld mit Ankern an den Seiten angezeigt werden.

  2. Setzen Sie den Cursor so auf einen Anker, daß er die Form eines doppelseitigen Pfeils annimmt.

  3. Halten Sie die Maustaste gedrückt, und verschieben Sie die Maus. Die Ausgabetabelle wird in die Richtung gedehnt, in die Sie die Maus schieben.

  4. Wenn die Ausgabetabelle die gewünschte Größe hat, lassen Sie die Maustaste los.


Wiederherstellen der ursprünglichen Größe einer Bitmap

WIEDERHERSTELLEN DER URSPRÜNGLICHEN GRÖSSE EINES GRAFIKBILDS

Wenn Sie die Größe einer Bitmap geändert haben, können Sie die ursprüngliche Größe und das Seitenverhältnis folgendermaßen wiederherstellen:

  1. Klicken Sie auf das Bild.

  2. Wählen Sie Eigenschaften aus dem Menü Format, und klicken Sie auf die Registerkarte "Anzeige".

  3. Klicken Sie auf die Option "In Originalgröße anzeigen".

  4. Klicken Sie auf "OK."


WIEDERHERSTELLEN DER URSPRÜNGLICHEN VERSION DES ELEKTRONISCHEN BUCHS

Sie können den derzeit offenen Abschnitt wie folgt durch den ursprünglichen Abschnitt aus dem nicht veränderten Original des Elektronischen Buchs ersetzen:

Wählen Sie Abschnitt wiederherstellen aus dem Kontextmenü "Bücher" im Fenster "Informationszentrum/Elektronisches Buch".

Sie können das derzeit offene Elektronische Buch wie folgt durch die ursprüngliche, nicht veränderte Version des Elektronischen Buchs ersetzen:

Wählen Sie Alles wiederherstellen aus dem Kontextmenü "Bücher" im Fenster "Informationszentrum/Elektronisches Buch".

Zu beachten ist, daß diese Befehle bewirken, daß sämtliche je am derzeit offenen Abschnitt bzw. Buch vorgenommenen Änderungen verlorengehen.


BESCHRÄNKUNGEN BEI VARIABLEN- UND FUNKTIONSNAMEN

Namen dürfen nicht mit den Ziffern 0 bis 9, einem Unterstrich ( _ ), einem negativen Apostroph `, oder einem Prozentzeichen (%) beginnen.

Das Symbol für Unendlich kann nur als erstes Zeichen in einem Namen vorkommen.

Alle Zeichen in einem Namen müssen dieselbe Schriftart, Punktgröße und denselben Stil aufweisen.

Mathcad unterscheidet nicht zwischen Variablennamen und Funktionsnamen. Wenn Sie also f(x) definieren und später die Variable f festlegen, sehen Sie, daß Sie f(x) an keiner Stelle unter der Definition von f verwenden können.

Bestimmte Namen werden in Mathcad für vordefinierte Konstanten, Einheiten und Funktionen verwendet. Sie können diese Namen zwar neu definieren, sollten jedoch bedenken, daß nach der Definition ihre vordefinierte Bedeutung nicht mehr vorhanden ist. Wenn Sie zum Beispiel eine Variable namens mittelwert erstellen, steht die vordefinierte Funktion mittelwert(v) nicht mehr zur Verfügung.

Mathcad unterscheidet zwischen Groß- und Kleinbuchstaben. Zum Beispiel ist die Variable diam nicht mit DIAM identisch.

Mathcad unterscheidet Namen voneinander, die in verschiedenen Schriftarten gesetzt sind. Zum Beispiel ist BEREICH nicht mit BEREICH identisch


UMKEHRDARSTELLUNG

Diese Gleichung wird in Umkehrdarstellung hervorgehoben.

Sie können alles in Umkehrdarstellung hervorheben, indem Sie die Maustaste gedrückt halten und den Cursor entsprechend ziehen.


RECHTER RAND

Der rechte Rand wird als durchgehende vertikale Linie in Ihrem Fenster dargestellt. Eventuell müssen Sie sich mit Hilfe der Bildlaufleiste in Ihrem Fenster nach rechts bewegen, um diese Linie sehen zu können.

Verwechseln Sie diese Linie (den rechten Rand) nicht mit der gepunkteten vertikalen Linie am rechten Rand. Diese gepunktete vertikale Linie zeigt den rechten Rand des Papierblatts an. Wo sich diese gepunktete Linie befindet, hängt davon ab, welchen Standarddrucker Sie in Ihrem Betriebssystem festgelegt haben.


INTEGRATION NACH DER ROMBERG-METHODE

Mit der Romberg-Methode erfolgt eine schrittweise Annäherung an den Wert des Integrals, und es wird ein Wert zurückgegeben, sobald die Differenz der beiden letzten Annäherungswerte geringer ist als der Wert der vordefinierten Variable TOL.

Zur Berechnung des Integrals f(x) von a nach b führt Mathcad folgende Schritte durch:

  1. Berechnen einer Trapezformel

  2. Anpassen eines Polynoms an die Folge der bisher berechneten Trapez-Annäherungswerte und der entsprechenden Teilintervallweiten. Extrapolieren dieses Polynoms auf Nullweite zur Erzeugung einer Romberg-Annäherung für das Integral

  3. Vergleichen der beiden letzten Romberg-Annäherungen nach folgendem Test:

  5. Stimmen die beiden letzten Annäherungen nach diesem Test überein, wird geprüft, ob auch Annäherungen n-1 und n-2 übereinstimmen. Ist dies der Fall, wird die letzte Romberg-Annäherung als Wert des Integrals ausgegeben. Ist dies nicht der Fall, wird die Zahl der Teilintervalle verdoppelt, und die Prozedur wird erneut ab Schritt 1 durchgeführt.

Mathcad begrenzt die Zahl der Durchgänge für diese Prozedur. Erreicht die Routine die Begrenzung, ohne daß eine Konvergenz gegeben ist, oder weist die Integrandfunktion an einem oder beiden Endpunkten Singularität auf, geht Mathcad zu einer offenen Romberg-Methode über. Erreicht Mathcad bei der Routine die festgelegte Begrenzung, ohne daß eine Antwort ausgegeben wird, wird die fehlgeschlagene Konvergenz am Integral als Fehler angezeigt.

Hinweise zum Algorithmus:

Bei kleinen TOL-Werten kann die Konvergenz auch dann fehlschlagen, wenn das Integral einen endlichen Wert aufweist.

Mathcad kann allgemein keine Funktionen integrieren, bei denen im Inneren des Integrationsintervalls Singularität auftritt. Funktionen wie Schritt- und Sägezahnfunktionen mit zahlreichen endlichen Unstetigkeiten können ebenfalls zu nichtkonvergierenden Intervallen führen. Wenn Sie wissen, wo Singularitäten im Integranden auftreten, können Sie eine richtige numerische Berechnung oft dadurch erzielen, daß Sie das Integral in eine Summe von Integralen aufspalten, die diese Punkte als Grenzwerte enthalten. Ein Diagramm des Integranden kann bei der Suche der Problemstellen oft weiterhelfen.


ALGORITHMUS DER WURZELFUNKTION

Die wurzel -Funktion von Mathcad verwendet die Sekansmethode.


SEKANSMETHODE FÜR DIE SUCHE NACH WURZELN

Die Sekansmethode findet bei der wurzel -Funktion Anwendung, wenn lediglich zwei Argumente vorhanden sind (die optionalen 3. und 4. Argumente sind ausgeschlossen). Diese Methode funktioniert wie folgt:

Zur Berechnung von wurzel(f(x),x) setzt Mathcad x als Anfangsschätzwert ein, um die Wurzel von f(x) herauszufinden. Dabei gilt folgende Schrittfolge:

Ist |f(x)| < TOL, so ist x bereits die Wurzel, und x wird als Ergebnis ausgegeben.

Es sei n=1. Ist x ungleich 0, so sei h=TOL*x, andernfalls sei h=TOL. Folgende Definitionen werden durchgeführt:

Erhöhen von n um eins. Dann Berechnung der Geraden, mit der die Punkte verbunden werden.

Es sei x sub n gleich dem Punkt, an dem die Gerade die Nullachse schneidet.

Wenn

sonst zurückkehren zu Schritt 3.

Mathcad begrenzt die Zahl der Berechnungen, die Mathcad für eine Lösung der Funktion wurzel durchführt. Erreicht Mathcad bei der Routine die festgelegte Begrenzung, ohne daß eine Antwort ausgegeben wird, wird die Funktion wurzel als Fehler markiert.

Der Fehler kann folgende Ursachen haben:

Der Ausdruck enthält keine Wurzel.

Die Wurzel des Ausdrucks unterscheidet sich zu stark vom Anfangsschätzwert .

Im Ausdruck befinden sich zwischen dem ersten Schätzwert und der Wurzel lokale Höchst- oder Tiefstwerte.

Der Ausdruck weist zwischen dem Anfangsschätzwert und der Wurzel Unstetigkeiten auf.

Der Ausdruck weist eine komplexe Wurzel auf, während der Anfangsschätzwert aus einer reellen Zahl bestand (oder umgekehrt).

Damit die Funktion wurzel konvergiert, sollten Sie den Ausdruck als Diagramm darstellen, damit Sie feststellen können, ob und gegebenenfalls wo er ungefähr die x-Achse schneidet. Ändern Sie dann den Schätzwert entsprechend ab. Sie können auch den Wert von TOL ändern.


RUNDEN

rund(x,n) Gibt x gerundet auf n Dezimalstellen zurück. Wenn n nicht angegeben wird, wird x, gerundet auf die nächste ganze Zahl, zurückgegeben (n wird dabei 0 gesetzt). Wenn n<0, wird x, gerundet auf n Stellen links des Dezimalzeichens, zurückgegeben.

Argumente:

x ist ein reeller Skalar.

n muß eine ganze Zahl sein.

Beispiele:


ZEILENREDUZIERTE ECHELON-FORM EINER MATRIX

zref(A) Gibt die zeilenreduzierte Echelon-Form von A zurück.

Argumente:

A muß ein Vektor oder eine Matrix sein.

Die Elemente von A sollten reell sein.


S-PLUS-GRAPHTYPEN

Mit der Komponente "S-PLUS-Graph" können Sie eine Vielzahl von Diagrammtypen erstellen. Um auf die verschiedenen Graphtypen für die Komponente zugreifen zu können, ist wie folgt vorzugehen:

  1. Klicken Sie mit der rechten Maustaste auf die Komponente, und wählen Sie den Befehl Eigenschaften aus dem Kontextmenü.

  2. Wählen Sie eine der folgenden Optionen aus: "Liniendiagramm", "GUI-Diagramm" oder "Graphskript aufrufen".

  3. Geben Sie in den Komponenten-Platzhalter für die Eingabevariable die entsprechenden Felder ein. Nähere Angaben zur Anzahl und der Art der Felder, die für die einzelnen Graphtypen erforderlich sind, finden Sie in der S-PLUS-Dokumentation.

Liniendiagramm : Bei diesem Standard-Graphtyp können pro Graph 1 bis 4 Spuren dargestellt werden. Jede Eingabe wird als Matrix mit einer Spalte (als y-Werte interpretiert, für die die entsprechenden x-Werte gezeichnet werden sollen) oder als Matrix mit zwei Spalten (als x- und y-Werte interpretiert) ausgewertet.

GUI-Diagramm : Dieser Graphtyp unterstützt alle S-PLUS-Diagramme, die über die grafische Benutzeroberfläche (GUI) von S-PLUS verfügbar sind. Bei dieser Komponente werden die Eingaben als Matrizen interpretiert, die gebündelt wurden, um die an die Grapherstellungsroutinen gesendeten Datenspalten zu erhalten. Der jeweils zu verwendende Graphtyp kann über die Felder "Achsentyp" und "Diagrammtyp" festgelegt werden. Klicken Sie auf "Achsen-/Diagrammtyp auswählen", um das S-PLUS-Dialogfeld aufzurufen, in dem Sie die Diagrammtypen auswählen und sich die verschiedenen Typen anhand von Miniaturansichten ansehen können.

Hinweis: Bei GUI-Diagrammen können bestimmte Eingaben als Bedingungsvariablen behandelt werden, um Trellis-Diagramme (mit Bedingungen versehene, aus mehreren Bereichen bestehende Diagramme) zu erhalten. Klicken Sie dazu auf die Kontrollkästchen auf der Registerkarte "Eingabevariablen" des Dialogfelds "Eigenschaften".

"Graphskript aufrufen" : Dieser Graphtyp unterstützt alle Befehle, mit denen S-PLUS-Graphen nach Art der Version 3.3 generiert werden können. Zur Eingabe von Befehlen müssen Sie den Skripteditor öffnen. Wählen Sie dazu den Befehl Skript bearbeiten aus dem Kontextmenü der Komponente. Das Skript kann jeden beliebigen S-PLUS-Code mit Aufrufen von plot(), points() usw. zur Erstellung eines Graphs oder mehrerer Graphen enthalten. Zur Festlegung der Ein- und Ausgaben sowie der statischen Variablen stehen Ihnen wie im Falle der Komponente "S-PLUS-Skript" (siehe weiter unten) die Registerkarten "Eingabevariablen" und "Ausgabevariablen" des Dialogfelds "Eigenschaften" zur Verfügung. Wenn das Skript vollkommen leer ist, wird es standardmäßig als plot(in0) definiert. Auf die Variable graphsheet.name kann von innerhalb des Skripts zugegriffen werden, um den Namen des Graphblattes zu erhalten. Wenn Sie mit der Bearbeitung des Skripts fertig sind, wählen Sie den Befehl Schließen und Zurückkehren aus dem Skripteditor-Menü Datei.

Hinweis: Im Normalfall wird das Diagramm vor jedem Aufruf eines Skripts zur Aktualisierung des Graphs gelöscht. Sie können dies jedoch verhindern, indem Sie die Option "Diagramm vor jedem Aufruf löschen" auf der Registerkarte "Graphtyp" des Dialogfelds "Eigenschaften" deaktivieren. Auf diese Weise können Sie mehrere Diagramme auf unterschiedlichen Seiten zusammenfassen.


STANDARDABWEICHUNG BEI STICHPROBEN

stdev(v) Gibt die Quadratwurzel der Varianz der Elemente von v zurück.

Argumente:

v ist ein Vektor der Form m x 1.

Weitere Funktionen für die Datenanalyse...


VARIANZ BEI STICHPROBEN

Argumente:

v ist ein Vektor der Form m x 1.

Durch die Division der ins Quadrat gesetzten Abweichungen durch den Wert "Beispielgröße minus eins" anstatt einfach durch die Beispielgröße entsteht ein Schätzwert, der der tatsächlichen Populationsvarianz genauer entspricht.

Weitere Funktionen für die Datenanalyse...


BEISPIEL FÜR EIN VBA-MAKRO

Dieses in Excel erstellte Visual Basic-Makro übergibt Daten in den Zellen G7 bis H8 an die Mathcad-Variable in0. Mathcad addiert 1 zu diesen Werten. Die Ergebnisse, die in der Mathcad-Variable out0 gespeichert werden, werden an die Zellen G12 bis H13 zurückgegeben.

Sub ArbeitsblattAktualisieren()

Dim MathcadObject As Object
Dim outRe, outIm As Variant
Dim inRe, inIm As Variant
' Verweis auf das Mathcad-Objekt einfügen
Set MathcadObject = ActiveSheet.OLEObjects(1).Object
' Von Excel an Mathcad zu übergebende Werte einlesen
inRe = ActiveSheet.Range("G7:G8").Value
inIm = ActiveSheet.Range("H7:H8").Value
' Werte an Mathcad senden, der Variable in0 zuordnen,
' neu berechnen und Ergebnisse aus out0 wieder in Excel einlesen
Call MathcadObject.SetComplex("in0", inRe, inIm)
Call MathcadObject.Recalculate
Call MathcadObject.GetComplex("out0", outRe, outIm)
' Ergebniswerte in die ausgewählten Excel-Zellen einfügen
ActiveSheet.Range("G12:G13").Value = outRe
ActiveSheet.Range("H12:H13").Value = outIm

End Sub

Hinweise:

  • Zur Weitergabe reeller Daten an Mathcad sollte(n) die Zelle(n) Nullen für den Imaginärteil enthalten.

  • Weitere Informationen zum Schreiben von VBA-Makros finden Sie in der Online-Hilfe von Excel.


SPEICHERN EINES ARBEITSBLATTS ZUR VERWENDUNG IN EINER VORHERIGEN VERSION

Normalerweise sind Mathcad-Arbeitsblätter nur aufwärtskompatibel , Sie können ein Arbeitsblatt aber auch so speichern, daß es in einer vorherigen Version geöffnet werden kann.

Zum Speichern eines Arbeitsblatts, so daß es auch in einer vorherigen Version geöffnet werden kann, gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Speichern oder Speichern unter im Menü Datei.

  2. Wählen Sie unter "Dateityp" das gewünschte Dateiformat aus (z. B. "Mathcad 7-Dateien"), und geben Sie einen Dateinamen ein.

  3. Klicken Sie auf "Speichern". Unter Umständen wird eine Meldung ausgegeben, in der Sie gewarnt werden, daß einige Programmfunktionen in einer der vorherigen Versionen nicht zur Verfügung stehen.

Auch wenn Sie ein Arbeitsblatt öffnen, das Sie in einer vorherigen Version gespeichert haben, kann eine Warnmeldung erscheinen, die Sie darauf aufmerksam macht, daß bestimmte Funktionen nicht unterstützt werden. Funktionen, die nur in der Version verfügbar sind, in der das Arbeitsblatt erstellt wurde, erscheinen in der vorherigen Version als Bitmaps. Alle Bereiche, die von diesen Funktionen abhängig sind, geben Fehlermeldungen aus. Zu den Funktionen, die das betrifft, gehören auch die QuickPlots.


Speichern eines Arbeitsblatt als HTML-Datei

SPEICHERN EINES ARBEITSBLATTS ALS HTML-DATEI

Zum Speichern eines Arbeitsblatts im HTML-Format gehen Sie wie folgt vor:

  1. Wählen Sie den Befehl Speichern oder Speichern unter im Menü Datei.

  2. Wählen Sie in der Dropdown-Liste "Dateityp" die Option "HTML", und geben Sie einen Dateinamen ein.

  3. Klicken Sie auf "Speichern".

Die Datei wird als HTML-Datei gespeichert. Alle Gleichungen und Diagramme werden als *.JPG-Dateien gespeichert.


SPEICHERN DER ÄNDERUNGEN AM ELEKTRONISCHEN BUCH

Wenn Sie Änderungen an einem Elektronischen Buch speichern, haben Sie folgende Möglichkeiten:

Sie können Änderungen am Abschnitt speichern, der gerade geöffnet ist, oder

Sie können alle in beliebigen Abschnitten vorgenommenen Änderungen speichern.

Um nur die Änderungen im derzeit offenen Abschnitt zu speichern, gehen Sie folgendermaßen vor:

Wählen Sie Abschnitt speichern aus dem Kontextmenü "Bücher" im Fenster "Informationszentrum/Elektronisches Buch".

Um alle in beliebigen Abschnitten vorgenommenen Änderungen zu speichern, gehen Sie folgendermaßen vor:

Wählen Sie Alle Änderungen speichern aus dem Kontextmenü "Bücher" im Fenster "Informationszentrum/Elektronisches Buch".

Nachdem Sie eine Änderung an einem Abschnitt eines Elektronischen Buchs gespeichert haben, wird ein Sternchen (*) in der Titelleiste angezeigt, wenn dieser Abschnitt geöffnet ist.


SPEICHERN DES BILDS AUF EINEM DATENTRÄGER

Das transformierte Bild befindet sich normalerweise in einer Matrix. Damit dieses Bild auch von anderen Anwendungen genutzt werden kann, müssen Sie es wieder als Datei auf der Festplatte speichern. Hierzu haben Sie zwei Möglichkeiten:

Speichern des Bilds in Farbe...

Speichern der Graustufendaten...


Skalar (Definition)

SKALAR

Ein Skalar ist eine einzelne Zahl, z. B. 2 oder 34+2i. Alles, was kein Skalar ist, ist gewöhnlich ein Vektor oder eine Matrix.

Wenn etwas skalarwertig ist, wird ein Skalar als Ergebnis zurückgegeben. Beispielsweise ist cos(0) skalarwertig, da es die einzelne Zahl 1 zurückgibt. einheit(3) gibt jedoch eine 3x3-Matrix zurück. Diese Funktion ist daher nicht skalar-, sondern matrixwertig.


Modell für die Scriptable Object-Komponente

MODELL FÜR DIE SKRIPTOBJEKT-KOMPONENTE

Mit der Skriptobjekt-Komponente werden Objekte, Eigenschaften und Methoden vordefiniert, mit deren Hilfe Sie sie als Komponente in Mathcad nutzen können.

Collections

DataValue-Objekte

Globale Methoden


Erstellung eines Skripts für ein Mathcad-Dokument-Objekt – Beispiel

ERSTELLUNG EINES SKRIPTS FÜR EIN MATHCAD-DOKUMENT-OBJEKT – BEISPIEL (nur in Mathcad Professional)

Das folgende Beispiel zeigt, wie Sie mit Hilfe der VBA-Umgebung von Microsoft Excel der Variable in0 in einem Mathcad-Dokument-OLE-Objekt eine komplexe Zahl zuweisen, eine Berechnung in Mathcad starten und die Antwort dann an Excel zurückgeben lassen können:

  1. Wählen Sie den Befehl Objekt aus dem Excel-Menü Einfügen und markieren Sie daraufhin auf der Registerkarte "Neu" die Option "Mathcad-Dokument", bzw. wählen Sie auf der Registerkarte "Aus Datei erstellen" eines der bereits existierenden Mathcad-Arbeitsblätter aus. Klicken Sie auf "OK".

  2. Richten Sie Excel so ein, daß es Daten gibt, die an Mathcad übergeben werden können oder/und daß Zellen vorhanden sind, in denen die von Mathcad zurückgegebenen Daten gespeichert werden können.

  3. Fügen Sie ein Visual Basic-Makromodul ein, und geben Sie VBA-Code ein, der auf Daten in Ihrem Arbeitsblatt und die Variablen in Mathcad verweist; dies muß entsprechend dem Modell für Mathcad-Dokument-Objekte erfolgen.

  4. Starten Sie das Makro.

Klicken Sie hier, um ein Beispiel für das endgültige Excel-Arbeitsblatt zu sehen.

Hinweise:

  • Bevor Sie das Makro in Excel starten, müssen Sie im Excel-Arbeitsblatt zunächst auf das Mathcad-Objekt doppelklicken, um das verknüpfte Objekt zu aktivieren.

  • Hinweise dazu, wie Sie ein Makro in Excel einfügen und starten können, finden Sie in der Online-Hilfe von Excel.

  • Aktuelle Informationen zur und Beispiele für die OLE-Automatisierungsschnittstelle finden Sie auf der MathSoft-Website unter http://www.mathsoft.com/support/.


Erstellen eines Skripts für ein Objekt

ERSTELLEN EINES SKRIPTS FÜR EIN OBJEKT (nur in Mathcad Professional)

Zum Erstellen eines Skripts für ein Objekt gehen Sie folgendermaßen vor:

  1. Fügen Sie die Skriptobjekt-Komponente ein.

  2. Klicken Sie einmal auf die Komponente, damit sie ausgewählt wird.

  3. Wählen Sie Skript im Kontextmenü. Dadurch wird der Skripteditor geöffnet.

  4. Wählen Sie Schließen und Zurückkehren im Skripteditor-Menü Datei, wenn Sie das Skript fertiggestellt haben und mit der Arbeit im Mathcad-Arbeitsblatt fortfahren möchten.

Hinweis: Sie können den Namen des Skriptobjekts bearbeiten, wenn Sie mit der rechten Maustaste auf die Skriptobjekt-Komponente klicken und im Kontextmenü den Befehl Eigenschaften wählen.

Das Skriptobjekt wird im Arbeitsblatt angezeigt.


MARKIEREN ALLER BEREICHE ZWISCHEN ZWEI BEREICHEN

Zum Markieren aller Bereiche zwischen zwei Bereichen gehen Sie wie folgt vor:

Markieren Sie den ersten Bereich, indem Sie auf ihn klicken.

Setzen Sie den Zeiger auf den letzten Bereich.

Drücken Sie die Umschalttaste, und klicken Sie mit der Maus.

Beim Klicken mit der Maus müssen Sie unbedingt die Umschalttaste gedrückt halten. Andernfalls wird die Markierung der anderen zuvor markierten Bereiche wieder aufgehoben.


MARKIEREN VON GRAFIKBEREICHEN

Zum Markieren eines Grafikbereichs gehen Sie wie folgt vor:

  1. Klicken Sie in den Bereich. Dadurch wird er in ein Markierungsrechteck eingeschlossen. Es werden drei Haltepunkte angezeigt.

Zum Markieren mehrerer Grafikbereiche gehen Sie wie folgt vor:

  1. Klicken Sie mit der Maus auf eine Stelle außerhalb eines der Grafikbereiche. Hierdurch wird eine Ecke des Markierungsrechtecks verankert.

  2. Halten Sie die Maustaste gedrückt, und ziehen Sie den Mauszeiger über das Arbeitsblatt. Vom Markierungspunkt aus erscheint ein gestricheltes Markierungsrechteck.

  3. Lassen Sie die Maustaste los, wenn die auszuwählenden Grafikbereiche im Markierungsrechteck eingeschlossen sind. Die Bereiche innerhalb des Markierungsrechtecks sind nach dem Loslassen der Maustaste jeweils von einem gestrichelten Rechteck umgeben.

Eine andere Möglichkeit, mehrere Grafikbereiche zu markieren, besteht darin, bei gedrückter Strg-Taste auf die jeweiligen Bereiche zu klicken oder durch Drücken der Umschalttaste mehrere Bereiche mit einem Mal zu markieren.


AUSWÄHLEN VON TEXT

Zum Auswählen (Markieren) einer Gruppe von Zeichen gehen Sie folgendermaßen vor:

  1. Positionieren Sie die Einfügemarke an einem Ende des auszuwählenden Textes.

  2. Ziehen Sie die Maus an das andere Ende der gewünschten Auswahl.

  3. Wenn Sie das Ende erreicht haben, lassen Sie die Maustaste wieder los. Der ausgewählte Bereich wird andersfarbig unterlegt.

Text kann auch auf andere Art und Weise ausgewählt (markiert) werden:

  • Zum Auswählen von nur einem Wort doppelklicken Sie auf das Wort. Das Wort wird daraufhin unterlegt.

  • Zum Auswählen von nur einem Absatz klicken Sie dreimal auf ein Wort in dem entsprechenden Absatz.

  • Zum zeichenweisen, wortweisen oder zeilenweisen Auswählen von Textzeichen verwenden Sie die Pfeiltasten.


AUSWÄHLEN VON TEXTBEREICHEN

Gehen Sie zum Auswählen eines ganzen Textbereichs zum Verschieben folgendermaßen vor:

  1. Klicken Sie auf eine Stelle außerhalb des Textbereichs. Hierdurch wird eine Ecke des Markierungsrechtecks verankert.

  2. Drücken Sie die Maustaste, halten Sie sie gedrückt, und ziehen Sie den Mauszeiger über das Arbeitsblatt. Vom Markierungspunkt aus erscheint ein gestricheltes Markierungsrechteck.

  3. Lassen Sie die Maustaste los, wenn das Markierungsrechteck den Textbereich einschließt.

Sollen mehrere Textbereiche ausgewählt werden, ziehen Sie das gestrichelte Auswahlrechteck mit der Maus, bis es alle auszuwählenden Bereiche umfaßt.


ENTWICKELN EINES AUSDRUCKS IN EINE REIHE

Zum Entwickeln eines Ausdrucks in eine Taylor- oder Laurent-Reihe um 0 gehen Sie wie folgt vor:

  1. Wählen Sie die Variable aus, um die herum entwickelt werden soll.

  2. Wählen Sie Variable / Reihenentwicklung im Menü Symbolik.

  3. Sie werden aufgefordert, die Ordnung der Reihenentwicklung anzugeben. Wählen Sie eine Ordnung aus (die Standardvorgabe ist 6, der Höchstwert ist 99). Klicken Sie dann auf "OK".

Die entwickelte Reihe enthält am Ende ein Glied wie z. B. O(x^6). Gelingt es dem symbolischen Prozessor nicht, eine Reihe um 0 herum abzuleiten, wird die Funktion zurückgegeben, ohne daß irgendwelche Änderungen vorgenommen wurden. Zur Ableitung einer Reihe, deren Mittelpunkt nicht gleich Null ist, müssen Sie die Variable nur verschieben.

Zu beachten ist, daß die Taylorsche Reihe für eine Funktion möglicherweise nur in einen kleinen Intervall um den Mittelpunkt konvergiert. Hinzu kommt, daß Funktionen wie sin oder exp Reihen mit unbegrenzt vielen Gliedern haben (die genaue Anzahl hängt von der von Ihnen festgelegten Ordnung ab). Daher gilt für Annäherungen einer Funktion durch das von Reihenentwicklung zurückgegebene Polynom, daß die Annäherung in der Nähe des Mittelpunkts ausreichend genau ist, mit steigender Entfernung vom Mittelpunkt aber immer ungenauer werden kann.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


VORZEICHEN EINER KOMPLEXEN ZAHL

csgn(z) Gibt 0 zurück, wenn z=0. Ist Re(z)>0 oder (Re(z)=0 und Im(z)>0), wird 1 zurückgegeben, in allen anderen Fällen -1.

signum(z) Gibt 1 zurück, wenn z=0, andernfalls wird z/|z| zurückgegeben.

Argumente:

z ist eine reelle, imaginäre oder komplexe Zahl.


VORZEICHEN EINER REELLEN ZAHL

sign(x) Gibt 0 zurück, wenn x=0. Ist x>0, wird 1 zurückgegeben, in allen anderen Fällen -1.

Argumente:

x ist eine reelle Zahl.


SYMBOLISCHES VEREINFACHEN VON AUSDRÜCKEN

Zum algebraischen Vereinfachen eines Ausdrucks oder Teilausdrucks gehen Sie folgendermaßen vor:

  1. Setzen Sie den zu vereinfachenden Ausdruck (oder Teilausdruck) zwischen die Bearbeitungslinien.

  2. Wählen Sie Vereinfachen im Menü Symbolik.

Durch den Befehl Vereinfachen werden arithmetische Berechnungen durchgeführt, gemeinsame Faktoren gekürzt, einfache trigonometrische und inverse Funktionsidentitäten angewendet und Quadratwurzeln und Potenzen vereinfacht. Kann der Ausdruck nicht weiter vereinfacht werden, so wird er durch den Befehl Vereinfachen unverändert zurückgegeben.

Hinweise:

  • Enthält der zu vereinfachende Ausdruck Funktionen mit mehreren Zweigen, zum Beispiel eine Quadratwurzel oder inverse trigonometrische Funktionen, gibt der symbolische Prozessor möglicherweise ein Ergebnis aus, dessen numerisches Verhalten vom Ausgangsterminus abweicht.

  • Zu beachten ist, daß der symbolische Prozessor bei der Eingabe von Zahlen mit Dezimalkomma (im Mathcad-Arbeitsblatt: Dezimalpunkt) alle Ergebnisse hinter dem Komma (Punkt) rundet.

  • Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


VEREINFACHEN ANGEZEIGTER EINHEITEN

Zum Vereinfachen einer Gruppe von Einheiten zu einer Einheit (falls möglich) gehen Sie vor wie folgt:

  1. Doppelklicken Sie auf die Einheit, um das Dialogfeld "Ergebnisformat" zu öffnen.

  2. Klicken Sie auf die Option "Einheiten eventuell vereinfachen", um sie zu aktivieren.

  3. Klicken Sie auf "OK".

Beispiel:

wird folgendermaßen vereinfacht:

Hinweis: Soll Mathcad automatisch versuchen, alle Einheiten in einem Arbeitsblatt zu vereinfachen, klicken Sie im Dialogfeld "Ergebnisformat" zuerst auf "Als Standard einrichten", bevor Sie auf "Einheiten eventuell vereinfachen" klicken.


SIMULTANE DEFINITIONEN

Sie können mit Feldern mehrere Variablen gleichzeitig definieren. Gehen Sie hierzu folgendermaßen vor:

  1. Erstellen Sie einen Vektor oder eine Matrix.

  2. Geben Sie für die Elementplatzhalter Variablennamen ein.

  3. Geben Sie ":" ein, um einen Platzhalter zu erstellen.

  4. Erstellen Sie einen Vektor oder eine Matrix mit der gleichen Anzahl an Zeilen und Spalten wie der Vektor oder die Matrix auf der linken Seite.

  5. Geben Sie in den Platzhaltern Definitionen für die Variablen ein.

Mathcad wertet alle Elemente auf der rechten Seite aus, bevor die Zuweisungen auf der linken Seite vorgenommen werden. Daraus ergibt sich folgendes:

Kein Element auf der rechten Seite eines Ausdrucks kann von Elementen auf der linken Seite abhängig sein.

Jede Variable kann höchstens einmal auf der linken Seite vorkommen.

Aufrufen eines QuickSheet-Beispiels


Singulärwertdekomposition

SINGULÄRWERTDEKOMPOSITION (nur in Mathcad Professional)

svd(A)Gibt genau eine Matrix mit den gestapelten Matrizen U und V zurück. Mit der Funktion submatrix können Sie diese kleineren Matrizen extrahieren.

Die Matrizen U und V erfüllen die Gleichung [image],

wobei s für den Vektor steht, der von svds(A) zurückgegeben wird.

Argumente:

A muß ein aus m x n Elementen bestehendes Feld sein, wobei m [image] n ist.

Die Elemente von A müssen reell sein.


Singulärwerte

SINGULÄRWERTE (nur in Mathcad Professional)

svds(A) Gibt einen Vektor mit den Singulärwerten von A zurück.

Argumente:

A muß ein aus m x n Elementen bestehendes Feld sein, wobei m [image] n ist.

Die Elemente von A müssen reell sein.

Mit dem Ergebnis aus dieser Funktion kann die Singulärwertdekomposition einer Matrix durchgeführt werden.


SCHIEFE

Argumente:

A ist ein Vektor oder eine Matrix aus mindestens drei Elementen.

Die Standardabweichung von A muß ungleich 0 sein.

Hinweise:

  • Die Schiefe von Werten gibt die Asymmetrie über dem Mittelwert an. skew(A)=0 bedeutet, daß eine Verteilung über dem Mittelwert symmetrisch ist. skew(A)>0 bedeutet, daß sich der größte Teil der Verteilung nahe des Ursprungs befindet und sich der "Schwanz" zu den positiven Werten hin erstreckt. skew(A)<0 bedeutet, daß der Schwanz sich zu den negativen Werten hin erstreckt.

  • skew(A)=0 steht für die Normalverteilung.

Weitere Funktionen für die Datenanalyse...


Stetige Systeme

STETIGE SYSTEME (nur in Mathcad Professional)

Bulstoer(y, x1, x2, npunkte, D)

Gibt eine Matrix zurück, in der (1) die erste Spalte die Punkte enthält, an denen die Lösung ausgewertet wird, und (2) die anderen Spalten die entsprechenden Werte der Lösung sowie die ersten n-1 Ableitungen enthalten.

Argumente:

y muß ein Vektor aus n Anfangswerten bzw. ein Skalar sein.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird. Anfangswerte in y sind die Werte bei x1.

npunkte ist die Anzahl der Punkte hinter dem Anfangspunkt, an denen die Lösung angenähert werden soll. Hiermit wird die Anzahl der Zeilen
(1 + npunkte) in der Matrix bestimmt, die von Bulstoer zurückgegeben wird.

D ist eine vektorwertige Funktion mit n Elementen, die erste Ableitungen der unbekannten Funktionen enthält.

Hinweise:

  • Bulstoer verwendet das Bulirsch-Stoer-Verfahren, das etwas genauer ist als das von rkfest verwendete Runge-Kuttasche Verfahren.

  • Wenn Sie wissen, daß die Lösung stetig ist, verwenden Sie die Funktion Bulstoer an Stelle von rkfest.


AUTOMATISCHE SEITENUMBRÜCHE

Ein automatischer Seitenumbruch wird auf dem Arbeitsblatt als gepunktete Linie dargestellt. Alles, was sich unter dieser Linie befindet, wird auf der nächsten Seite gedruckt.

Automatische Seitenumbrüche werden automatisch durch den verwendeten Drucker eingefügt. Änderungen an diesen können Sie nur vornehmen, wenn Sie einen anderen Drucker wählen.

Wenn Sie bestimmen wollen, wo eine neue Seite beginnen soll, fügen Sie manuelle Seitenumbrüche ein.


Lösung mit adaptiven Schrittweiten

LÖSUNG MIT ADAPTIVEN SCHRITTWEITEN (nur in Mathcad Professional)

Rkadapt(y, x1, x2, npunkte, D)

Gibt eine Matrix zurück, in der (1) die erste Spalte die Punkte enthält, an denen die Lösung ausgewertet wird, und (2) die anderen Spalten die entsprechenden Werte der Lösung sowie die ersten n-1 Ableitungen enthalten.

Argumente:

y muß entweder ein Vektor aus n Anfangswerten oder ein Skalar sein.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird. Anfangswerte in y sind die Werte bei x1.

npunkte ist die Anzahl der Punkte hinter dem Anfangspunkt, an denen die Lösung angenähert werden soll. Hiermit wird die Anzahl der Zeilen (1 + npunkte) in der Matrix bestimmt, die von Rkadapt zurückgegeben wird.

D ist eine vektorwertige Funktion mit n Elementen, die erste Ableitungen der unbekannten Funktionen enthält.

Hinweise:

  • Anders als die Funktion rkfest , die in Schritten mit gleicher Weite integriert, um eine Lösung zu finden, untersucht Rkadapt, wie schnell sich eine Lösung ändert, und verändert die Schrittweite dementsprechend. Rkadapt verwendet beim Lösen der Differentialgleichung intern ungleichmäßige Schrittweiten, gibt die Lösung jedoch an Punkten mit gleichem Abstand zurück.


Lösungsprozeß

LÖSUNGSPROZESS

Wenn Sie die Mathcad-Funktionen suchen, minfehl, minimieren und maximieren verwenden, analysiert die Mathcad-Funktion Autom. Auswahl automatisch die Art des zu lösenden Problems und probiert geeignete Lösungsalgorithmen aus, um eine gültige Lösung zu erhalten.

Wenn Sie mit Mathcad Professional arbeiten, können Sie sehen, welcher Algorithmus verwendet wurde:

  1. Klicken Sie dazu mit der rechten Maustaste auf die Funktion. Daraufhin wird das Kontextmenü eingeblendet.

  2. Auto. Auswahl sowie eine der folgenden Methoden sind mit einem Häkchen versehen:

Linear
Nichtlinear / Gradientenverfahren
Nichtlinear / Quasi-Newton-Methode
Nichtlinear / Levenberg-Marquardt-Methode
Quadratisch

Autom. Auswahl wird stets standardmäßig verwendet. Damit wird Mathcad angewiesen, den entsprechenden Lösungsprozeß zu verwenden, um eine gültige Lösung zu finden. Handelt es sich um ein lineares Problem, wird die Methode "Linear" angewendet. Handelt es sich um ein quadratisches Problem, wird die Methode "Quadratisch" angewendet. Wird für das Problem ein nichtlinearer Lösungsalgorithmus benötigt, kommt das Gradientenverfahren zum Einsatz. Kommt keine Annäherung an das Ergebnis zustande, wird die Levenberg-Marquadt-Methode verwendet. Ist auch damit kein Ergebnis zu erzielen, wird auf die Quasi-Newton-Methode zurückgegriffen.

Obwohl es sich zumeist empfiehlt, Autom. Auswahl aktiviert zu haben, ist es möglich, mit Hilfe des Kontextmenüs manuell eine bestimmte Methode auszuwählen, sollte dies erforderlich sein.

Hinweise:

Um festzustellen, ob eine Lösung gültig ist, verwenden die meisten Lösungsalgorithmen die Werte der vordefinierten Variablen "TOL" und "CTOL". "CTOL" legt fest, wie genau Bedingungen erfüllt werden müssen, damit eine Lösung als gültig angesehen werden kann. "TOL" legt fest, wie genau die Lösung sein muß. Falls nötig, können Sie die Werte von "CTOL" und "TOL" anpassen.

Mit Mathcad Professional können Sie nach bis zu 200 Variablen bei bis zu 200 Bedingungen auflösen (Mathcad Standard bietet bis zu 50). Mit dem Expert Solver können noch größere Probleme gelöst werden.

Sollte es bei der Suche nach einer Lösung Schwierigkeiten geben, gehen Sie wie folgt vor:

  • Legen Sie für TOL oder CTOL größere Werte fest.

  • Probieren Sie verschiedene Schätzwerte aus, oder fügen Sie eine Ungleichung hinzu. Beachten Sie, daß komplexe Lösungen nur gefunden werden können, wenn auch ein komplexer Schätzwert vorgegeben wurde.

  • Verwenden Sie die Funktion minfehl anstelle von suchen, wenn Sie eine angenäherte Lösung haben wollen.

  • Verändern Sie im Falle einer nichtlinearen Lösungsmethode die Einstellungen unter "Erweiterte Optionen".


LÖSEN VON GLEICHUNGSSYSTEMEN

suchen(var1, var2, ...) Gibt die Werte von var1, var2... zurück, die die Gleichungen und Ungleichungen in einem Lösungsblock erfüllen. Bei der Auflösung nach n Variablen muß das Gleichungssystem n Gleichungen enthalten (wobei n höchstens 50 betragen darf).

Argumente:

var1, var2,... sind skalare Variablen im Gleichungssystem.

Arbeiten mit der Funktion:

Zum Lösen eines Gleichungssystems mit der Funktion suchen gehen Sie wie folgt vor:

Definieren Sie Schätzwerte für die unbekannten Variablen.

Geben Sie das Wort Vorgabe ein, um das Gleichungssystem zu starten.

Geben Sie unter Vorgabe mit Hilfe Boolescher Operatoren Gleichungen und Ungleichungen als Teil des Gleichungssystems ein.

Verwenden Sie die Funktion suchen.

Hinweise:

  • Andernfalls gibt die Funktion einen Vektor zurück, dessen erstes Element var1, dessen zweites Element var2 usw. ist.

  • Der Algorithmus der Funktion suchen beinhaltet einen speziellen Lösungsprozeß, bei dem aus mehreren verfügbaren Methoden eine geeignete Methode ausgewählt wird.

  • Sie können die Funktion suchen auf die gleiche Weise verwenden wie jede andere Funktion. Sie können zum Beispiel eine andere Funktion mit suchen definieren. Dadurch können Sie von einem Gleichungssystem aus andere Gleichungssysteme aufrufen oder einige der Parameter oder Konstanten in Ihrem Gleichungssystem variieren.

Beispiel:

Lösen eines Systems nichtlinearer Gleichungen


SORTIERFUNKTIONEN

Mathcad verfügt über drei Funktionen zum Sortieren von Feldern und über eine Funktion, mit der die Reihenfolge der Elemente von Feldern umgekehrt werden kann:

sort(v)

Gibt einen Vektor mit den in aufsteigender Reihenfolge sortierten Werten in v zurück. Wenn v komplexe Elemente enthält, wird der Imaginärteil ignoriert.

spsort(A,n)

Gibt ein Feld zurück, das dadurch gebildet wird, daß die Zeilen von A so umgestellt werden, daß die Spalte n in aufsteigender Reihenfolge sortiert ist. Wenn A komplexe Elemente enthält, wird der Imaginärteil ignoriert.

zsort(A,n)

Gibt ein Feld zurück, das dadurch gebildet wird, daß die Spalten von A so umgestellt werden, daß die Zeile n in aufsteigender Reihenfolge sortiert ist. Wenn A komplexe Elemente enthält, wird der Imaginärteil ignoriert.

umkehren(v)

Gibt einen Vektor zurück, in dem die Elemente von v in umgekehrter Reihenfolge sortiert sind. Wenn v komplexe Elemente enthält, wird der Imaginärteil ignoriert.

Verwandte Themen:

Vektoren und Matrizen


SPEZIELLE FUNKTIONEN

Tcheb(n,x)

Tschebyscheffsches Polynom n-ten Grades der ersten Art

Ucheb(n,x)

Tschebyscheffsches Polynom n-ten Grades der zweiten Art

Her(n,x)

Hermitesches Polynom n-ten Grades

Jac(n,a,b,x)

Jacobisches Polynom n-ten Grades mit den Parametern a und b

Lag(n,x)

Laguerresches Polynom n-ten Grades

Leg(n,x)

Legendresches Polynom n-ten Grades

fhyper(a,b,c,x)

Gaußsche hypergeometrische Funktion

mhyper(a,b,x)

Konfluente hypergeometrische Funktion

ibeta(a,x,y)

Unvollständige Beta-Funktion von x und y mit dem Parameter a

G( z )

Eulersche Gammafunktion

G( a,x )

Unvollständige Gammafunktion des Grades a


Spezielle Funktionen (nur bei symbolischen Berechnungen)

SPEZIELLE FUNKTIONEN

Symbolische Ergebnisse, die in die Zwischenablage gesetzt werden, unterliegen einer besonderen Syntax. Für Variablen können eingebettete Schriftart-Codes erscheinen. Die Ergebnisse können auch spezielle Operatoren und Funktionen enthalten:

Zum Einfügen der Antwort als Text in das Mathcad-Arbeitsblatt gehen Sie folgendermaßen vor:

  1. Klicken Sie in einen leeren Bereich.

  2. Wählen Sie Einfügen im Menü Bearbeiten.

Wählen Sie Speichern unter im Menü Datei der Zwischenablage, damit Sie eine lange Zwischenablagenantwort als separate Textdatei speichern können.

Symbolische Operatoren. Antworten mit diesen Operatoren können nicht mit den vordefinierten numerischen Operatoren ausgedrückt werden. Sie werden mit der Meldung "Ergebnis ist Maple-spezifisch" gekennzeichnet und in die Zwischenablage eingefügt.

Spezielle numerische Funktionen:

arcsec, arccosec, arccot, arcosech, arcscsh, arccoth

g

Catalansche Konstante

Chi(x)

Ci(x)

csgn(x)

dilog(x)

Dirac(x)

Ei(x)

fehlf(z)

FresnelC(x)

FresnelS(x)

GAMMA(z)

hypergeom(n1, n2..., d1, d2..., z)

LegendreE(x,k)

LegendreEc(k)

LegendreEc1(k)

LegendreF(x,k)

LegendreKc(k)

LegendreKc1(k)

LegendrePi(x,n,k)

LegendrePic(n,k)

LegendrePic1(n,k)

Psi(n,x)

Psi(x)

Shi(x)

Si(x)

signum(x)

W(x)

W(n,x)

Zeta(s)

Da es sich bei den speziellen Funktionen nicht um vordefinierte Funktionen handelt, können Sie sie nicht direkt durch Drücken von = berechnen. Um einen numerischen Wert für eine dieser Funktionen zu ermitteln, klicken Sie unten auf ihren Namen, und verwenden Sie den entsprechenden Ausdruck im Popup-Fenster:


Spezielle Funktionen zum Einlesen von Bilddateien

SPEZIELLE FUNKTIONEN ZUM EINLESEN VON BILDDATEIEN (nur in Mathcad Professional)

Mit den unten aufgeführten speziellen Funktionen werden Bilder folgender Formate eingelesen: BMP, GIF, JPG und TGA.

BILD_LESEN("datei") Erstellt ein Feld, das eine Graustufendarstellung der Bilddatei enthält.

HLS_LESEN("datei") Erstellt ein Feld, das die Farbinformationen in der Datei durch entsprechende Werte für Farbton, Helligkeit und Sättigung wiedergibt.

HSV_LESEN("datei") Erstellt ein Feld, das die Farbinformationen in der Datei durch entsprechende Werte für Farbton, Sättigung und Wert wiedergibt.

ROT_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich den Rotanteil.

GRÜN_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich den Grünanteil.

BLAU_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich den Blauanteil.

HLS_TON_LESEN ("datei") Extrahiert aus einem Farbbild ausschließlich die Farbtonkomponente.

HLS_HELL_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich die Helligkeitskomponente.

HLS_SAT_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich die Sättigungskomponente.

HSV_TON_LESEN ("datei") Extrahiert aus einem Farbbild ausschließlich die Farbtonkomponente.

HSV_SAT_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich die Sättigungskomponente.

HSV_WERT_LESEN("datei") Extrahiert aus einem Farbbild ausschließlich die Wertkomponente.

Argumente:

datei ist entweder ein Dateiname oder der Pfad zu einer BMP-Datei.

datei wird als Zeichenfolge eingegeben.

Diese Funktionen werden auf die gleiche Weise verwendet wie die Funktion BMPLESEN zum Einlesen einer Datei.

Verwandte Funktionen...


Spezielle Funktionen zum Schreiben von Bilddateien

SPEZIELLE FUNKTIONEN ZUM SCHREIBEN VON BILDDATEIEN (nur in Mathcad Professional)

HLS_SCHREIBEN("datei") Erstellt eine Farb-Bitmap-Datei aus einer Matrix, die das Bild im HLS-Format enthält.

HSV_SCHREIBEN("datei") Erstellt eine Farb-Bitmap-Datei aus einer Matrix, die das Bild im HSV-Format enthält.

Argumente:

datei ist entweder ein Dateiname oder der Pfad zu einer BMP-Datei.

datei wird als Zeichenfolge eingegeben.

Mit den oben aufgeführten speziellen Funktionen können Sie Dateien mit farbigen Bitmaps aus Matrizen erstellen, in denen das Bild im HLS- oder HSV-Format gespeichert ist.

Diese Funktionen werden auf die gleiche Weise verwendet wie die Funktion BMPSCHREIBEN zum Schreiben in eine Datei.

Verwandte Funktionen...


Festlegen der Lösungsmethode

FESTLEGEN DER LÖSUNGSMETHODE (nur in Mathcad Professional)

Es kann Situationen geben, in denen Sie manuell bestimmen möchten, welcher Lösungsprozeß für eine der Lösungsfunktionen suchen, minfehl, minimieren und maximieren zum Einsatz kommen soll. So ist es z. B. denkbar, daß Sie sich im Rahmen einer Tiefenanalyse auch das Ergebnis anzeigen lassen möchten, daß mittels einer anderen Methode als der Standardmethode ermittelt wird. Gehen Sie hierzu folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf den Funktionsnamen. Daraufhin erscheint das Kontextmenü.

  2. Wählen Sie eine der folgenden Methoden, sofern sie verfügbar ist:


GLANZLICHT

Glanzlicht strahlt aus einer bestimmten Richtung und wird in einer bestimmten Richtung von der Oberfläche reflektiert. Durch ein Glanzlicht entsteht normalerweise ein heller Punkt auf einem Objekt. Ein Scheinwerfer ist ein gutes Beispiel.

Glanzlicht hat keine größere Wirkung auf die Darstellungsweise eines Diagramms. Es ist jedoch zu empfehlen, wenn ein Diagramm glänzende Bereiche erhalten soll. Zum Beispiel kann ein Flächendiagramm, das auf der Seite "Darstellung" im Dialogfeld "3D-Diagrammformat" mit nur einem daraufstrahlenden weißen Glanzlicht erstellt wurde, sich extrem verändern, wenn Sie den Glanz auf der Seite "Erweitert" ändern.


Sphärische Besselfunktionen

SPHÄRISCHE BESSELFUNKTIONEN (nur in Mathcad Professional)

js(n,x) Gibt den Wert der sphärischen Besselfunktion erster Art, n-ter Ordnung zurück.

ys(n,x) Gibt den Wert der sphärischen Besselfunktion zweiter Art, n-ter Ordnung zurück.

Argumente:

n muß eine ganze Zahl =-200 sein.

x muß eine positive Zahl sein. Das Argument x kann bei js gleich 0 sein, wenn n [image] 0 ist.

x muß reell sein.

x darf keine Einheiten haben.

Diese Funktionen sind Lösungen der folgenden Differentialgleichung:


Operator "Quadratwurzel"

QUADRATWURZEL

Tastaturbefehl: \

Gibt die positive Quadratwurzel von x zurück.

Operanden:

x muß ein Skalar sein.

Bei negativem oder komplexem x wird die Quadratwurzel mit dem kleinsten Argument zurückgegeben.


STANDARDFEHLER

stdfehl(vx,vy) Gibt den Standardfehler einer einfachen linearen Regression für die in vx und vy beschriebenen Punkte zurück. Die Funktion mißt, wie eng die Datenpunkte über der Regressionslinie verteilt sind.

Argumente:

vx ist ein Vektor mit bekannten x-Werten in aufsteigender Reihenfolge. Er muß mindestens drei Zeilen haben.

vy ist ein Vektor mit bekannten y-Werten. Er muß mindestens drei Zeilen haben.

Weitere Funktionen für die Datenanalyse...


STANDARD-SYMBOLLEISTE

Über die auf der Standard-Symbolleiste befindlichen Schaltflächen haben Sie schnellen Zugriff auf viele Menübefehle. Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.

Sie können die Standard-Symbolleiste Ihren Vorstellungen entsprechend anpassen. Klicken Sie dazu mit der rechten Maustaste auf die Symbolleiste, und wählen Sie den Befehl Anpassen aus dem Kontextmenü.


STATISCHE VARIABLEN

Statische Variablen in der Komponente "S-PLUS-Skript" sind die Variablen, deren Werte bei den verschiedenen Aufrufen des Skripts erhalten bleiben.

Zum Deklarieren von statischen Variablen ist folgendermaßen vorzugehen:

Fügen Sie dem Feld "Statische Variablennamen" auf der Registerkarte "Eingabevariablen" des Dialogfelds "Eigenschaften" der Komponente die Namen der Variablen hinzu (durch Kommas voneinander getrennt).

Zu beachten ist dabei, daß alle statischen Variablen zurückgesetzt werden, sobald das Skript selbst geändert wird.


Ansicht / Statusleite

ANSICHT / STATUSLEISTE

Die Statusleiste befindet sich unmittelbar unterhalb der horizontalen Bildlaufleiste am unteren Rand des Haupt-Arbeitsblattfensters. Hier finden Sie eine Reihe von mitunter wichtigen Informationen:

  • Wenn Sie eine Gleichung bearbeiten, finden Sie in der Meldungszeile der Statusleiste Hinweise, was Sie als nächstes tun sollten.

  • Bleibt der Mauszeiger einen Moment über einer Symbolleisten-Schaltfläche stehen, wird in der Meldungszeile der Statusleiste eine Beschreibung dieser Schaltfläche angezeigt.

  • Rechts unten in der Statusleiste können Sie ablesen, auf welcher Seite Sie sich befinden.

  • Steht in der Statuszeile "Auto", bedeutet dies, daß sich das Arbeitsblatt im automatischen Modus befindet.

  • "Rech F9" bedeutet, daß das Arbeitsblatt sich im manuellen Modus befindet. In diesem Fall müssen Sie die Taste F9 drücken, um die Berechnung zu starten und die Ergebnisse anzeigen zu lassen.


Steife Systeme

STEIFE SYSTEME (nur in Mathcad Professional)

Stiffb(y, x1, x2, npunkte, D, J)
Stiffr(Y, x1, x2, npunkte, D, J)

Beide Funktionen geben eine Matrix zurück, in der (1) die erste Spalte die Punkte enthält, an denen die Lösung ausgewertet wird, und (2) die anderen Spalten die entsprechenden Werte der Lösung sowie die ersten n-1 Ableitungen enthalten.

Argumente:

y muß entweder ein Vektor aus n Anfangswerten oder ein einzelner Anfangswert sein.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird. Anfangswerte in y sind die Werte bei x1.

npunkte ist die Anzahl der Punkte hinter dem Anfangspunkt, an denen die Lösung angenähert werden soll. Hiermit wird die Anzahl der Zeilen
(1 + npunkte) in der Matrix bestimmt, die von Stiffb oder Stiffr zurückgegeben wird.

D ist eine vektorwertige Funktion mit n Elementen, die erste Ableitungen der unbekannten Funktionen enthält.

J ist eine Funktion, die eine aus n x (n+1) Elementen bestehende Matrix zurückgibt, deren erste Spalte Ableitungen enthält und deren andere Zeilen und Spalten die Jacobische Matrix für das System der Differentialgleichungen bilden.

Hinweise:

  • Stiffb verwendet das Bulirsch-Stoer-Verfahren für steife Systeme. Stiffr verwendet das Rosenbrock-Verfahren.

  • Verwenden Sie beim Lösen eines steifen Systems einen der beiden Lösungsalgorithmen für Differentialgleichungen (Stiffb und Stiffr), die speziell für steife Systeme entwickelt wurden.

Verwandte Themen:

Umwandeln einer Differentialgleichung in die Standardform, um einen Lösungsalgorithmus für Differentialgleichungen anwenden zu können

Andere Lösungsalgorithmen für Differentialgleichungen


STUDENTSCHE T-VERTEILUNG

dt(x,d) Gibt die Wahrscheinlichkeitsdichte für die t-Verteilung zurück.

pt(x,d) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qt(p,d) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rt(m,d) Gibt einen Vektor aus m Zufallszahlen zurück, die die Studentsche t-Verteilung aufweisen.


ERSETZEN

Zum Ersetzen einer Variable im gesamten Arbeitsblatt durch eine andere Variable, einen Ausdruck oder eine Zahl gehen Sie folgendermaßen vor:

  1. Wählen Sie aus, was durch die Variable ersetzt werden soll, und wählen Sie Kopieren im Menü Bearbeiten.

  2. Wählen Sie die Variable aus, die ersetzt werden soll.

  3. Wählen Sie Variable / Ersetzen im Menü Symbolik.

Diese Operation kann einen unübersichtlichen Ausdruck ergeben. Sie können das Ergebnis vereinfachen, indem Sie es markieren und Vereinfachen wählen.

Beachten Sie, daß dieser Befehl nur funktioniert, wenn Sie eine Variable durch einen Ausdruck ersetzen wollen. Dieser Befehl kann nicht verwendet werden, um einen Ausdruck durch einen anderen Ausdruck zu ersetzen. Zum Ersetzen von Ausdrücken durch andere Ausdrücke müssen Sie die Befehle Ausschneiden und Einfügen aus dem Menü Bearbeiten verwenden.


Operator "Subtraktion"

SUBTRAKTION

Tastaturbefehl: -

x - y

Subtrahiert y von x.

Wenn der sich ergebende Ausdruck so lang ist, daß er über den rechten Bildschirmrand hinausragt, empfiehlt es sich, statt dessen y zu negieren und die Tastenkombination Strg+Eingabe zu drücken. Daraufhin wird folgendes eingefügt:

Operanden:

x und y sind Skalare.

x und y müssen dieselbe Dimension haben.


SUMME DER VEKTORELEMENTE

Tastaturbefehl: Strg+4

v

Gibt die Summe aller Elemente im Vektor v zurück.

Operanden:

v ist ein Vektor.


SUMMATION MIT BEREICHSVARIABLEN

Tastaturbefehl: $

Gibt die Summe des Ausdrucks X über den Bereich i zurück.

Operanden:

i muß ein Bereich ganzer Zahlen sein.

X ist ein beliebiger Ausdruck.

Definieren Sie zunächst die Bereichsvariable i, und setzen Sie erst dann den Operator ein. Beispiel:

Zur Summierung mit einer variablen oberen Grenze der Summenbildung gehen Sie wie im folgenden Beispiel vor:

Wenn der Summand mehrere Glieder hat, müssen Sie diese in Klammern einschließen, um sie innerhalb des Operators zu halten.


SUMMATION OHNE BEREICHSVARIABLEN

Tastaturbefehl: Strg+Umschalt+4

Gibt die Summe über i zurück, wobei i von m bis n des Ausdrucks X reicht.

Operanden:

i muß eine ganze Zahl sein.

X ist ein beliebiger Ausdruck.

m und n müssen ganze Zahlen sein, wobei m < n ist.

Wenn der Summand mehrere Glieder hat, müssen Sie diese in Klammern einschließen, um sie innerhalb des Operators zu halten.

Die Variable i ist nur innerhalb dieses Operators definiert und steht daher in keinerlei Zusammenhang mit Variablendefinitionen außerhalb des Operators "Produkt".


OPERATOR "HOCHGESTELLTER INDEX"

Tastaturbefehl: Strg+6

Gibt die n-te Spalte des Feldes M zurück. Wenn M keine n-te Spalte hat, erscheint eine entsprechende Fehlermeldung.

Operanden:

M muß ein Feld sein.

n ist ein Skalar. n darf nicht komplex sein.

Denken Sie daran, daß alle Felder standardmäßig bei 0 und nicht bei 1 beginnen. Für eine Matrix mit 10 Spalten muß n zwischen 0 und 9 liegen. Um dies zu ändern, wählen Sie Optionen / Vordefinierte Variablen im Menü Rechnen, und ändern Sie den Wert für ORIGIN.

Beispiel:

Um eine Zeile aus einer Matrix zu erhalten, verwenden Sie den Operator "Hochgestellter Index" zusammen mit dem Operator "Transponieren" . Um z. B. die erste Zeile einer Matrix M zu erhalten, geben Sie M Strg+1 Strg+6 1 ein.


ÄNDERN DER AUSWERTUNGSREIHENFOLGE

Wenn Sie etwas unterhalb und/oder rechts von der Position definieren möchten, an der Sie es verwenden, müssen Sie das Symbol für eine globale Definition verwenden. Zum Einfügen des Gleichheitszeichens für globale Definitionen drücken Sie ~ (Tilde). Das Zeichen erscheint als Gleichheitszeichen mit drei Strichen. Weitere Erklärungen können Sie aufrufen, indem Sie auf die entsprechenden Ausdrücke im Bild unten klicken.

Beachten Sie, daß Ausdrücke, in denen ein Gleichheitszeichen für globale Definitionen vorkommt, von oben nach unten und von links nach rechts ausgewertet werden. Tatsächlich werden zwei Durchläufe in Ihrem Arbeitsblatt vorgenommen:

Beim ersten Durchlauf werden alle Zuordnungen vorgenommen, die das Gleichheitszeichen für globale Definitionen beinhalten.

Beim zweiten Durchlauf werden alle Zuordnungen vorgenommen, die ':=' beinhalten, und es werden Ergebnisse und Diagramme angezeigt.


SYMBOLISCHE OPTIMIERUNG

Im Normalfall wertet Mathcad Ausdrücke genau so aus, wie Sie sie eingegeben haben. Dies geschieht ungeachtet dessen, daß oft ein klein wenig Vereinfachung dazu führen würde, daß der Ausdruck sich wesentlich leichter auswerten läßt. Mit dem Befehl Optimierung im Menü Rechnen jedoch weisen Sie den numerischen Prozessor an, Ausdrücke vor den Berechnungen zu vereinfachen. Wenn Sie auf das Bild unten klicken, können Sie sehen, was dabei passiert.

Um alle Gleichungen in einem Arbeitsblatt zu optimieren, gehen Sie folgendermaßen vor:

  • Wählen Sie den Befehl Optimierung im Menü Rechnen.

Mathcad übergibt daraufhin alle Ausdrücke vor deren Auswertung zunächst dem symbolischen Prozessor, damit dieser sie vereinfachen kann. Wenn der symbolische Prozessor eine vereinfachte Form findet, wird der Ausdruck mit einem roten Sternchen markiert. Sie können den vereinfachten Ausdruck anzeigen lassen, indem Sie auf das Sternchen doppelklicken oder Popup anzeigen aus dem Kontextmenü des Ausdrucks wählen. Mathcad verwendet für alle nachfolgenden Berechnungen nun stets diese vereinfachte Form des Ausdrucks.

Soll Mathcad jedoch einen Ausdruck genau so berechnen, wie er eingegeben wurde, ohne daß er zuvor vereinfacht wird, klicken Sie auf die Gleichung, und wählen Sie Eigenschaften im Menü Format. Klicken Sie dann auf die Registerkarte "Berechnung", und aktivieren Sie die Option "Optimierung deaktivieren".

Wenn Sie nur einen bestimmen Ausdruck und nicht das gesamte Arbeitsblatt optimieren möchten, gehen Sie wie folgt vor:

  1. Klicken Sie auf die Gleichung, und wählen Sie Eigenschaften im Menü Format.

  2. Klicken Sie auf die Registerkarte "Berechnung", und aktivieren Sie dann das Kontrollkästchen neben dem Feld "Optimierung deaktivieren".

Wenn Mathcad den Ausdruck optimieren kann, wird dieser mit einem roten Sternchen markiert. Kann Mathcad den Ausdruck nicht optimieren, wird er mit einem blauen Sternchen versehen.


SYMBOLISCHE DIFFERENTIATION

Zum Differenzieren einer Funktion in bezug auf eine Variable gehen Sie folgendermaßen vor:

  1. Drücken Sie die Taste ?, um den Ableitungsoperator einzufügen.

  2. Geben Sie den zu differenzierenden Ausdruck und die Variable für die Differenzierung in die Platzhalter ein.

  3. Drücken Sie so lange die Leertaste, bis sich der gesamte Ausdruck zwischen den Bearbeitungslinien befindet.

  4. Wählen Sie den Befehl Vereinfachen im Menü Symbolik.

Zum Berechnen von Ableitungen höherer Ordnung drücken Sie Strg+Umschalt+?, damit der Operator für die Ableitung höherer Ordnung erstellt wird. Folgen Sie dann obigen Anweisungen.

Hinweis:

Bei Verwendung der symbolischen Befehle im Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


SYMBOLISCHES ANZEIGEFORMAT

Wählen Sie den Befehl Auswertungsformat im Menü Symbolik, um festzulegen, wo die symbolischen Ergebnisse erscheinen sollen. Folgende Möglichkeiten stehen zur Auswahl:

  • Die Option "Vertikal mit Einfügen von Zeilen" sorgt dafür, daß die Ergebnisse untereinander angezeigt werden, wobei zwischen den einzelnen Schritten eine Leerzeile über die Breite des gesamten Arbeitsblatts eingefügt wird.

  • Die Option "Vertikal ohne Einfügen von Zeilen" sorgt dafür, daß die Ergebnisse untereinander angezeigt werden, wobei aber benachbarte Bereiche zusammen bleiben, so daß Sie getrennte Berechnungen nebeneinander anstellen können

  • Die Option "Horizontal" sorgt dafür, daß die Ergebnisse rechts vom Ausgangsausdruck erscheinen.

Aktivieren Sie die Option "Kommentare anzeigen", um vor jedem Ergebnis einen entsprechenden Kommentar automatisch einfügen zu lassen. Sie können diese automatisch generierten Kommentare ebenso bearbeiten wie jeden anderen Textbereich.

Aktivieren Sie die Option "An Stelle auswerten", um den ursprünglichen Ausdruck durch die symbolische Antwort zu ersetzen. Diese Option ist vor allem dann praktisch, wenn Sie nur einen Teil eines längeren Ausdrucks transformieren möchten.


Symbolisches Gleichheitszeichen

SYMBOLISCHES GLEICHHEITSZEICHEN (STRG+.)

Zum Vereinfachen eines Ausdrucks mit Hilfe des symbolischen Gleichheitszeichens gehen Sie wie folgt vor:

Geben Sie den zu vereinfachenden Ausdruck ein.

Drücken Sie Strg+. (Punkt). Es erscheint das symbolische Gleichheitszeichen, das die Form eines nach rechts zeigenden Pfeils hat.

Klicken Sie auf eine Stelle außerhalb des Ausdrucks, oder drücken Sie die Eingabetaste. Rechts vom symbolischen Gleichheitszeichen erscheint daraufhin der transformierte Ausdruck.

Weitere Einzelheiten zum symbolischen Gleichheitszeichen:

  • Es ist ein aktiver Operator. Wenn Sie also im Arbeitsblatt etwas vor dem Zeichen (oberhalb oder links davon) verändern, aktualisiert Mathcad das Ergebnis automatisch.

  • Es nimmt bereits definierte Funktionen und Variablen zur Kenntnis und verwendet sie entsprechend. Sie können das symbolische Gleichheitszeichen jedoch anweisen, bestehende Definitionen zu ignorieren.

  • Es gilt für einen ganzen Ausdruck. Sie können mit dem symbolischen Gleichheitszeichen zum Beispiel nicht lediglich einen Teil eines Ausdrucks transformieren.


SYMBOLISCHES AUSWERTEN MIT MENÜBEFEHLEN

Zum symbolischen Auswerten eines Ausdrucks stehen Ihnen u. a. die Befehle im Menü Symbolik zur Verfügung. Bei der Arbeit mit dem Menü Symbolik funktionieren alle algebraischen Transformationen grundsätzlich nach dem gleichen Muster:

  1. Wählen Sie den Ausdruck aus (entweder ganz oder nur Teile davon).

  2. Wählen Sie den entsprechenden Befehl im Menü Symbolik.

Danach wird der transformierte Ausdruck im Arbeitsblatt angezeigt. Je nachdem, welches Auswertungsformat Sie eingestellt haben, ersetzt der transformierte Ausdruck entweder den gewählten Ausdruck, oder er wird unterhalb oder rechts neben den bisherigen Ausdruck eingefügt. Verläuft die symbolische Transformation erfolglos, bleibt der neue Ausdruck mit dem alten identisch.

Zu beachten ist, daß beim symbolischen Rechnen mit Menübefehlen keine automatische Aktualisierung der Transformation erfolgt, wenn Sie Änderungen am Arbeitsblatt vornehmen. Sollen beim symbolischen Rechnen Transformationen aktualisiert werden, müssen Sie daher mit der aktiven symbolischen Auswertung arbeiten.


SYMBOLISCHE INTEGRATION

Zum Berechnen eines unbestimmten Integrals gehen Sie folgendermaßen vor:

  1. Drücken Sie Strg+I zur Erstellung des Operators für das unbestimmte Integral.

  2. Füllen Sie die Platzhalter für den Integranden und die Integrationsvariable aus.

  3. Drücken Sie so lange die Leertaste, bis sich das gesamte Integral zwischen den Bearbeitungslinien befindet.

  4. Wählen Sie den Befehl Vereinfachen im Menü Symbolik.

Soll statt dessen ein bestimmtes Integral berechnet werden, drücken Sie & zur Erstellung des bestimmten Integraloperators, und befolgen Sie dann die Anweisungen oben. Der symbolische Prozessor von Mathcad sucht dann ein unbestimmtes Integral und subtrahiert seinen Wert am unteren Grenzwert der Integration vom Wert am oberen Grenzwert. Wenn Sie im Integranden oder in den Grenzwerten der Integration mit Dezimalzahlen arbeiten, wird eine numerische Annäherung von 20 Stellen angezeigt, soweit verfügbar.

Verfügt ein Integral nicht über einen Ausdruck in geschlossener Form, wird eine entsprechende Fehlermeldung angezeigt. Wenn Sie nur eine numerische Annäherung an ein bestimmtes Integral benötigen, sollten Sie statt dessen das Integral numerisch berechnen.

Zu beachten ist, daß die Antwort auf ein Integrationsproblem bei der Berechnung eines unbestimmten Integrals nicht eindeutig ist. Ist f(x) das Integral einer gegebenen Funktion, so ist f(x) + C das Integral für die Konstante C.

Hinweise:

  • Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


SYMBOLISCHES ERMITTELN DER MATRIXDETERMINANTE

Zum Ermitteln der Determinante einer quadratischen Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf die quadratische Matrix, und drücken Sie so oft die Leertaste, bis sich die Matrix zwischen den Bearbeitungslinien befindet.

  2. Wählen Sie Matrix / Determinante im Menü Symbolik.

Beachten Sie dabei, daß Sie die gesamte Matrix auswählen müssen, um diesen Befehl verwenden zu können. Das Definieren einer Variable als Matrix und das anschließende Auswählen dieser Variable ist nicht möglich.

Hinweis:

Bei Verwendung der symbolischen Befehle im Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


SYMBOLISCHES INVERTIEREN VON MATRIZEN

Zum Ermitteln der Inversen einer quadratischen Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf die quadratische Matrix, und drücken Sie so oft die Leertaste, bis sich die Matrix zwischen den Bearbeitungslinien befindet.

  2. Wählen Sie den Befehl Matrix / Invertieren im Menü Symbolik.

Beachten Sie dabei, daß Sie die gesamte Matrix auswählen müssen, um diesen Befehl verwenden zu können. Das Definieren einer Variable als Matrix und das anschließende Auswählen dieser Variable ist nicht möglich.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


SYMBOLISCHE MATRIXOPERATIONEN

Sie haben die Möglichkeit, Matrixausdrücke mit Operatoren symbolisch auszuwerten. Die meisten Matrixfunktionen werden auch symbolisch vereinfacht, wenn dies sinnvoll ist. Um einen Ausdruck mit Matrizen und Matrixoperatoren bzw. -funktionen symbolisch auszuwerten, gehen Sie wie folgt vor:

Klicken Sie auf den Ausdruck, und drücken Sie so oft die Leertaste, bis das zu berechnende Element sich vollständig zwischen den Bearbeitungslinien befindet.

Wählen Sie Vereinfachen im Menü Symbolik.

Zu beachten ist, daß viele dieser Transformationen nicht für die Matrix als ganzes gelten. Um z. B. die Ausdrücke in einer Matrix zu vereinfachen, müssen Sie den Befehl Vereinfachen für jedes Element einzeln wählen.


SYMBOLISCHES TRANSPONIEREN VON MATRIZEN

Zum Ermitteln der Transponierten einer Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf die Matrix, und drücken Sie so oft die Leertaste, bis sich die Matrix zwischen den Bearbeitungslinien befindet.

  2. Wählen Sie den Befehl Matrix / Transponieren im Menü Symbolik.

Beachten Sie dabei, daß Sie die gesamte Matrix auswählen müssen, um diesen Befehl verwenden zu können. Das Definieren einer Variable als Matrix und das anschließende Auswählen dieser Variable ist nicht möglich.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


ZU LANGE SYMBOLISCHE ERGEBNISSE

Fällt ein symbolisches Ergebnis so platzraubend aus, daß es im Arbeitsblatt nicht mehr problemlos angezeigt werden kann, werden Sie in einem Dialogfeld gefragt, ob das Ergebnis in die Zwischenablage gesetzt werden soll. Solche zu langen Ergebnisse entstehen häufig bei den folgenden Operationen:

  • Integrieren oder Differenzieren komplexer Ausdrücke

  • Symbolisches Ermitteln der Wurzeln von Polynomen

  • Symbolisches Auswerten von Funktionen, die ein sehr großes ganzzahliges Ergebnis haben

Wenn Sie eine umfangreiche Antwort in die Zwischenablage verlagern, können Sie das Ergebnis überprüfen, indem Sie die Zwischenablage öffnen. Symbolische Ergebnisse erscheinen in der Zwischenablage in einer Syntax, die etwa der einer Tabellenkalkulation entspricht.

Sie können dieses Ergebnis drucken, indem Sie es in ein Dokument einer Textverarbeitung einfügen. Sie können die Antwortzeichenfolge jedoch auch als Textbereich direkt in das Arbeitsblatt einfügen.


SYMBOLISCHE SUMMEN UND PRODUKTE

Zum symbolischen Auswerten von Summen und Produkten gehen Sie wie folgt vor:

  1. Drücken Sie die Tastenkombination Strg+Umschalt+4 bzw. Strg+Umschalt+3, um den Summations- bzw. den Produktoperator zu erstellen.

  2. Geben Sie einen Ausdruck und einen Bereich ein.

  3. Wählen Sie den Befehl Vereinfachen im Menü Symbolik.

Wenn der symbolische Prozessor keine geschlossene Form für die Summe oder das Produkt finden kann, gibt er

entweder eine explizite Summe bzw. ein entsprechendes Produkt oder

eine Meldung zurück, der zufolge für die Summe bzw. das Produkt keine geschlossene Form gefunden wurde.

Hinweis:

Wenn Sie mit den Befehlen im Menü Symbolik, wie z. B. Vereinfachen, arbeiten, werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Berechnung.


SYMBOLLEISTE "SYMBOLIK"

Mit den Schaltflächen auf der Symbolleiste "Symbolik" können Sie das symbolische Gleichheitszeichen und die symbolischen Schlüsselwörter einfügen. Klicken Sie auf die Schaltfläche "Modifikatoren". Daraufhin wird die Symbolleiste "Modifikatoren" eingeblendet.

Welche Funktionen die einzelnen Schaltflächen haben, erfahren Sie, wenn Sie mit dem Mauszeiger auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der Schaltfläche verweilen lassen, bis:

  • ein QuickInfo (ein kleines Popup-Fenster) die Bezeichnung der Schaltfläche anzeigt und

  • in der Meldungszeile der Statusleiste eine Beschreibung ihrer Funktion erscheint.


MENÜ "SYMBOLIK"

Auswerten / Symbolisch

Auswerten / Gleitkomma...

Auswerten / Komplex

Vereinfachen

Entwickeln

Faktorisieren

Zusammenfassen

Polynom-Koeffizienten

Variable / Auflösen

Variable / Ersetzen

Variable / Differenzieren

Variable / Integrieren

Variable/ Reihenentwicklung...

Variable / Partialbruchzerlegung

Matrix / Transponieren

Matrix / Invertieren

Matrix / Determinante

Transformation / Fourier

Transformation / Fourier invers

Transformation / Laplace

Transformation / Laplace invers

Transformation / Z

Transformation / Z invers

Auswertungsformat...


DIFFERENZENGLEICHUNGSSYSTEME

Das folgende Beispiel zeigt, wie mehrere gekoppelte Differenzengleichungen erstellt werden:

Aufrufen eines QuickSheet-Beispiels


Dialogfeld "Rechenoptionen": Registerkarte "Einheitensystem"

DIALOGFELD "RECHENOPTIONEN"

Auf der Registerkarte "Einheitensystem" des Dialogfelds "Rechenoptionen" finden Sie die folgenden Optionen und Schaltflächen:

SI (International)

Klicken Sie hier, wenn zur Anzeige der Ergebnisse die Einheiten Meter, Kilogramm, Sekunde, Ampere, Kelvin, Candela und Mol verwendet werden sollen, sofern nichts anderes festgelegt wurde. Beispiel:

MKS

Klicken Sie hier, wenn zur Anzeige der Ergebnisse die Einheiten Meter, Kilogramm, Sekunde, Coulomb und Kelvin verwendet werden sollen, sofern nichts anderes festgelegt wurde. Beispiel:

CGS

Klicken Sie hier, wenn zur Anzeige der Ergebnisse die Einheiten Zentimeter, Gramm und Sekunde verwendet werden sollen, sofern nichts anderes festgelegt wurde. Beispiel:

U.S.

Klicken Sie hier, wenn zur Anzeige der Ergebnisse die Einheiten Fuß, Pfund, Sekunde und Coulomb verwendet werden sollen, sofern nichts anderes festgelegt wurde. Beispiel:

Kein

Klicken Sie hier, um alle vordefinierten Einheiten zu deaktivieren. Bei den im folgenden Bild rot dargestellten Einheiten handelt es sich um undefinierte Einheiten. Beispiel:


SYSTEME VON DIFFERENTIALGLEICHUNGEN

Im Beispiel unten wird gezeigt, wie Sie mit Hilfe von rkfest die Lösungen für das System von Differentialgleichungen bei Punkten mit gleichmäßigem Abstand auswerten können.

Verwandte Themen:

Umwandeln einer Differentialgleichung in die Standardform, um einen Lösungsalgorithmus für Differentialgleichungen anwenden zu können

Lösungsalgorithmen für Differentialgleichungen


SYSTEME VON GEWÖHNLICHEN DIFFERENTIALGLEICHUNGEN

rkfest(y, x1, x2, npunkte, D)

Gibt eine Matrix zurück, in der (1) die erste Spalte die Punkte enthält, an denen die Lösung ausgewertet wird, und (2) die andere Spalte die entsprechenden Werte der Lösung sowie die ersten n-1 Ableitungen enthält.

Argumente:

y muß entweder ein Vektor aus n Anfangswerten oder ein einzelner Anfangswert sein.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird. Anfangswerte in y sind die Werte bei x1.

npunkte ist die Anzahl der Punkte hinter dem Anfangspunkt, an denen die Lösung angenähert werden soll. Hiermit wird die Anzahl der Zeilen (1 + npunkte) in der Matrix bestimmt, die von rkfest zurückgegeben wird.

D ist eine vektorwertige Funktion mit n Elementen, die die ersten Ableitungen der unbekannten Funktionen enthält.

Hinweise:

  • rkfest verwendet das Runge-Kuttasche Verfahren vierter Ordnung zum Lösen von Differentialgleichungen erster Ordnung.

  • Mit der Funktion rkfest können Sie sowohl eine einzelne Differentialgleichung als auch ein System von Differentialgleichungen lösen.

Beispiele:

Lösen einer Differentialgleichung zweiter Ordnung

Lösen eines Systems von Differentialgleichungen


TEXTEINFÜGEMARKE

Wo kann sie erscheinen?

Wie kann sie angezeigt werden?

Wie wird sie verschoben?

Was ist ihre Funktion?


EIGENSCHAFTEN VON TEXTBEREICHEN

Breite eines Textbereichs festlegen

Verhalten der Bereiche rechts bzw. unterhalb von Textbereichen bei Eingabe von Text festlegen


Die Mathcad-Produktreihe

DIE MATHCAD-PRODUKTPALETTE

Mathcad Professional Academic Edition ist das Software-Paket speziell für Schüler, Studierende und Lehrkräfte, die mit einem professionellen Programm arbeiten möchten. Die Academic Edition bietet die ganze Funktionspalette der Professional Edition sowie spezielle elektronische Inhalte und Ressourcen, und das alles zum Studententarif.

Mathcad Standard Edition ist die ideale Anwendung für alltägliche technische Berechnungen und ist einfach und schnell zu nutzen, wenn Papier, Bleistift, Taschenrechner und Tabellenkalkulationsprogramme zu umständlich sind.

Mathcad Professional bietet die volle technische Rechenleistung von Mathcad und ist eine der umfassendsten und vielseitigsten Rechenanwendung auf dem Markt. Diese Version verfügt über die meisten Funktionen aller Mathcad-Versionen.

Weitere Informationen zu den verschiedenen Mathcad-Versionen erhalten Sie direkt bei MathSoft oder bei Ihrem Händler vor Ort.


DIE STANDARDFORM EINER DIFFERENTIALGLEICHUNG

Der wichtigste Schritt bei der Vorbereitung einer Differentialgleichung für die Lösung durch Mathcad besteht darin, sie in die Standardform zu bringen, die für Mathcad-Lösungsalgorithmen erforderlich ist. Dabei werden aus einer Differentialgleichung alle Ableitungen höherer Ordnung entfernt, und es bleiben nur erste Ableitungen übrig. Ihre Differentialgleichung ist dann ein System von Differentialgleichungen erster Ordnung.

Zum Beispiel enthält die Differentialgleichung:

eine zweite Ableitung, die als erste Ableitung geschrieben werden kann:

Definieren Sie die beiden Funktionen als:

Nun enthält die Differentialgleichung zwei Funktionen und ist im wesentlichen ein System mit zwei Differentialgleichungen:

Der nächste Schritt ist die Erfassung dieser Daten in einer einzelnen vektorwertigen Funktion D für die Verwendung mit den Lösungsalgorithmen für Differentialgleichungen in Mathcad:


Oberer Rand

Dabei handelt es sich um den Abstand zwischen dem oberen Rand des Papierblatts und dem oberen Rand des Druckbereichs. Wenn Ihr Arbeitsblatt mit einer Kopfzeile versehen ist, erscheint diese innerhalb des Randbereichs an dessen unterer Grenze.


ABLESEN DER KOORDINATEN EINER MATRIX

sp(M) Gibt die Summe der Elemente entlang der Diagonale von M zurück.

Argumente:

M muß eine Quadratmatrix sein.


SPUREINSTELLUNGEN IN KREISDIAGRAMMEN

Zum Auswählen der Eigenschaften einer Spur gehen Sie wie folgt vor:

Doppelklicken Sie auf ein Diagramm, oder wählen Sie Diagramm / Kreidiagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

Klicken Sie auf die Registerkarte Spuren.

Klicken Sie auf den Namen der Spur unter der Spalte "Legendenname" der Liste in der Mitte des Dialogfelds. Die dieser Spur zugeordneten Eigenschaften erscheinen in den sechs Textfeldern unter den folgenden Spalten: Es gelten folgende Beschränkungen:

Legendenname

Symbol

Linie

Farbe

Format

Stärke

Sie können diese Eigenschaften ändern, wenn Sie durch Klicken auf den Pfeil neben dem entsprechenden Textfeld eine Dropdown-Liste mit Optionen aufrufen.

Sie können die Eigenschaften für eine andere Spur ändern, indem Sie in der Liste in der Mitte des Dialogfelds auf ihren Namen klicken. Ordnen Sie dann die Eigenschaften wie oben beschrieben zu.

Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


SPUREINSTELLUNGEN (X-Y-DIAGRAMME)

Zum Auswählen der Eigenschaften einer Spur gehen Sie wie folgt vor:

Doppelklicken Sie auf ein Diagramm, oder wählen Sie Diagramm / XY-Diagramm im Menü Format, um ein Dialogfeld mit Registerkarten zu öffnen.

Klicken Sie auf die Registerkarte Spuren.

Klicken Sie auf den Namen der Spur in der Spalte "Legendenname" der Liste in der Mitte des Dialogfelds. Die dieser Spur zugeordneten Eigenschaften erscheinen in den sechs Textfeldern unter den folgenden Spalten: Es gelten folgende Beschränkungen:

Legendenname

Symbol

Linie

Farbe

Format

Stärke

Sie können diese Eigenschaften ändern, wenn Sie durch Klicken auf den Pfeil neben dem entsprechenden Textfeld eine Dropdown-Liste mit Optionen aufrufen.

Sie können die Eigenschaften für eine andere Spur ändern, indem Sie in der Liste in der Mitte des Dialogfelds auf ihren Namen klicken. Ordnen Sie dann die Eigenschaften wie oben beschrieben zu.

Rufen Sie dann durch Klicken auf "Übernehmen" die Vorschau des Diagramms auf. Klicken Sie auf "Schließen" oder "OK", um das Dialogfeld zu schließen.


Operator "Transponieren"

TRANSPONIEREN

Tastaturbefehl: Strg+1

Gibt ein aus n x m Elementen bestehendes Feld zurück, das durch Vertauschen der Zeilen und Spalten eines aus m x n Elementen bestehenden Feldes gebildet wird.

Operanden:

M ist ein aus m x n Elementen bestehendes Feld.

Statt der numerischen Matrixtransponierung können Sie die Transponierte der Matrix auch symbolisch bestimmen.


TRIGONOMETRISCHE FUNKTIONEN

sin(z) cos(z)

tan(z) cosec(z)

sec(z) cot(z)

Argumente:

z muß in Radiant angegeben werden.

z muß ein Skalar sein (reell, komplex oder imaginär).

Verwandte Themen:

Felder als Argumente

Rundungsfehler bei numerischen Angaben

Verwendung von Gradangaben


ABBRUCHFUNKTIONEN

floor(x) Gibt die größte ganze Zahl [image] x zurück.

ceil(x) Gibt die kleinste ganze Zahl [image] x zurück.

trunc(x) Gibt den ganzzahligen Teil von x zurück. Der Bruchteil wird entfernt.

Argumente:

x muß reell sein.

Hinweis: Die Funktionen floor und trunc geben bei positiven Werten von x denselben Wert zurück. Bei negativen Werten von x unterscheiden sich die Ergebnisse. So ist floor(-2.6)=-3, aber trunc(-2.6)=-2.

Beispiele:


ZWEIPUNKT-RANDWERTPROBLEME

Um ein Anfangswertproblem n-ten Grades zu lösen, müssen Sie den Wert der Funktion sowie die ersten n-1 Ableitungen am Anfang des Integrationsintervalls kennen. Wenn Sie diese nicht kennen, jedoch

einige der Werte der Lösung und der Ableitungen am Anfang des Integrationsintervalls sowie

einige Werte der Lösung und der Ableitungen an anderer Stelle im Integrationsintervall kennen und

Sie zusammen n bekannte Werte haben,

können Sie nach den unbekannten Werten am Anfang des Integrationsintervalls auflösen und das Randwertproblem in ein Anfangswertproblem umwandeln, das mit rkfest und den anderen Lösungsalgorithmen für Differentialgleichungen gelöst werden kann.

Wenn Sie die Werte am Endpunkt des Integrationsintervalls kennen, verwenden Sie sgrw.

Wenn Sie die Werte in der Mitte des Integrationsintervalls kennen, verwenden Sie grwanp.

Beispiele

Verwenden der Funktion sgrw

Verwenden der Funktion grwanp


EINGEBEN VON SYMBOLEN IN EINEM NAMEN

Wenn Sie ein Symbol wie "$" eingeben, mit dem ein Mathcad-Operator erstellt wird, erhalten Sie normalerweise den Operator und nicht das eigentliche Symbol ($). Zum Eingeben des eigentlichen Symbols anstelle des Operators in einem Variablen- oder Funktionsnamen gehen Sie vor wie folgt:

  1. Geben Sie als erstes Zeichen des Namens einen Buchstaben oder eine Ziffer ein.

  2. Geben Sie Strg+Umschalt+K ein, damit ein spezieller Textmodus aktiviert wird.

  3. Geben Sie ein oder mehrere Symbole wie $ ein. Die Bearbeitungslinien werden rot. Dadurch wird angezeigt, daß Sie sich im speziellen Textmodus befinden.

  4. Geben Sie Strg+Umschalt+K erneut ein, um in den gewöhnlichen Rechenmodus zurückzukehren.

Beispiel:

Sie können Variablendefinitionen folgender Art erstellen:

x@3:00 := 20

sowie

a+b := 3.24 - 5


Funktion "rnd" (Zufallszahlengenerierung)

GLEICHMÄSSIGE VERTEILUNG

dunif(x,a,b) Gibt die gleichmäßige Verteilung zurück.

punif(x,a,b) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qunif(p,a,b) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rnd(x) Gibt eine gleichmäßig verteilte Zufallszahl zwischen 0 und x zurück.

runif(m,a,b) Gibt einen Vektor aus m Zufallszahlen zurück, die die gleichmäßige Verteilung aufweisen.


Einheitliches Polyeder, Definition

EINHEITLICHES POLYEDER

Einheitliche Polyeder sind regelmäßige Polyeder mit kongruenten Scheitelpunkten. Mit jedem ist ein Name, eine Zahl, ein Dual (der Name eines anderen Polyeders) und ein Wythoff-Symbol verknüpft.

Im folgenden werden einige einheitliche Polyeder aufgeführt:

Name | Zahlencode | Wythoff-Symbol | Dualname
Fünfeckiges Prisma | 1 | 2 5|2 | Fünfeckige Dipyramide
Ikosaeder | 27 | 5|2 3 | Dodekaeder
Würfel | 10 | 3|2 4 | Oktaeder

Zum Abbilden eines einheitlichen Polyeders können Sie die Funktion Polyhedron verwenden. Den Namen, das Wythoff-Symbol und den Dualnamen können Sie anhand des Nummerncodes eines Polyeders mit der Funktion PolyLookup nachsehen.

Ausführlichere Angaben zu einheitlichen Polyedern finden Sie in anderen Quellen.


EINHEITENPLATZHALTER

Wenn Sie auf ein numerisches Ergebnis klicken, erscheint rechts vom Ergebnis ein kleines schwarzes Kästchen. Dieses Kästchen ist der Einheitenplatzhalter.

Um diesen Platzhalter auszufüllen, klicken Sie auf ihn, und geben Sie den Namen einer Einheit ein.


HEAVISIDE-SPRUNGFUNKTION

(x) Gibt 0 zurück, wenn x negativ ist, andernfalls wird 1 zurückgegeben.

Argumente:

x muß ein reeller Skalar sein.

Da diese Funktion bei 0 eine Unstetigkeit aufweist, sollten Sie Ausdrücke, die diese Funktion einschließen, nicht über ein Intervall mit 0 integrieren. Statt dessen empfiehlt es sich, den Integrationsbereich in zwei Teilbereiche aufzuteilen, über jeden Bereich einzeln zu integrieren und die Ergebnisse dann zu addieren.

Aus demselben Grund ist die Ableitung dieser Funktion bei 0 nicht definiert.


Freigeben einer gesperrten Region

FREIGEBEN EINER GESPERRTEN REGION (nur Mathcad Professional)

Zum Freigeben einer gesperrten Region gehen Sie wie folgt vor:

  1. Klicken Sie zwischen die Grenzen der Region, die freigegeben werden soll.

  2. Wählen Sie den Befehl Region / Freigeben aus dem Menü Format. Falls zuvor ein Kennwort für die Region festgelegt wurde, werden Sie aufgefordert, dieses einzugeben.


Funktion "bis"

FUNKTION FÜR DIE ITERATION

bis(x, y) Mit dieser Funktion können Sie einen iterativen Prozeß auf der Grundlage einer Bedingung anhalten. Gibt y zurück, bis x negativ ist.

Argumente:

x ist ein Testausdruck (der normalerweise eine Negative enthält), die Funktion bis hält die Iteration an.

y ist der durch die Funktion bis bei jedem Iterationsschritt zurückgegebene Wert.

ACHTUNG: Mathcad 8 enthält diese Funktion nur, um die Kompatibilität mit älteren Mathcad-Versionen zu gewährleisten. Die Funktion ist jedoch veraltet und sollte nicht mehr verwendet werden. Verwenden Sie statt dessen eine Schleife in einem Programm.


Mcaduntitled

Mit der Rücktaste wird normalerweise gelöscht, was sich links von der Einfügelinie befindet. Wenn der zu löschende Ausdruck komplizierter ist als ein Name oder eine Zahl, wird er durch Drücken der Rücktaste jedoch wie gezeigt markiert. Wenn Sie die Rücktaste dann erneut drücken, wird er gelöscht. Dadurch ist unbeabsichtigtes Löschen eines Ausdrucks nahezu ausgeschlossen.


Variable FRAME

Diese integrierte Variable führt Animationen aus. Diese Variable darf nicht im Arbeitsblatt, sondern nur im Dialogfeld "Animieren" definiert werden.


Schieberegler im Dialogfeld "Playback"

Den Regler können Sie mit der Maus nach links oder rechts ziehen, um in der Animation vorwärts oder rückwärts zu gehen.


Animieren von Funktionsgraphen

Bei der Animation von Diagrammen empfiehlt es sich, die Achsenbegrenzungen selbst festzulegen und auf eine automatische Festlegung zu verzichten.

Werden die Achsenbegrenzungen automatisch festgelegt, erfolgt für jedes Bild der Animation eine Rücksetzung der Werte. Auf diese Weise ändert sich in Ihrer Animation nicht das Diagramm von Bild zu Bild, sondern es ändern sich nur die Achsenbegrenzungen.


Bildvorschau

Hier wird das erste Bild der Animation angezeigt, die wiedergegeben werden soll. Wenn keine Animation zur Wiedergabe verfügbar ist, wird dieses Feld nicht angezeigt.

Damit eine Animation verfügbar ist, müssen Sie entweder eine AVI-Datei öffnen oder im Dialogfeld "Animieren" eine Animation erstellen.


Schieberegler für die Wiedergabe von aufeinanderfolgenden Bildern

Verwenden Sie diesen Schieberegler wie eine Bildlaufleiste. Mit diesem Regler können Sie um ein Bild oder mehrere Bilder vorwärts- oder rückwärtsgehen.


Wiedergabeschaltfläche für Geschwindigkeit, Bildgröße etc.

Durch Klicken auf diese Schaltfläche rufen Sie ein Menü auf, mit Hilfe dessen Sie die Wiedergabegeschwindigkeit, die Größe des Bildes sowie verschiedene andere Konfigurationsoptionen festlegen können.

Mit diesem Menü können Sie außerdem eine vorhandene Datei öffnen.


Wiedergabeschaltfläche

Klicken Sie hierauf, um die Wiedergabe der Animation zu starten. Wenn die Animation bereits abgespielt wird, wird die Wiedergabe durch Klicken auf diese Schaltfläche gestoppt.


Säulenanordnung "Matrix"

Wenn diese Option aktiviert ist, werden die Säulen in der gleichen Weise angeordnet wie die entsprechenden Zahlen in der zugrundeliegenden Matrix.


Säulenanordnung "Übereinander"

Wenn diese Option aktiviert ist, werden alle Säulen, die Werte aus ein und derselben Spalte der Matrix darstellen, übereinander angeordnet.


Säulenanordnung "Nebeneinander"

Wenn diese Option aktiviert ist, werden alle Säulen, die Werte aus ein und derselben Spalte der Matrix darstellen, nebeneinander zusammengefaßt dargestellt.


Mcaduntitled00000041

Abstand

Dieser Wert bestimmt, wie weit die einzelnen Säulen voneinander entfernt sein sollen. Der von Ihnen eingegebene Wert gibt an, wieviel Prozent des Gitters durch den Säulenabstand beansprucht werden. Je größer der Wert ist, den Sie hier eingeben, desto dünner werden die einzelnen Säulen.


Order of ops

Im rechten Dokument weiter unten wurde versucht, die Variable y zu verwenden, bevor sie definiert wurde. Beachten Sie die Verfärbung von y zu rot. Dies weist darauf hin, daß die Variable nicht definiert wurde.

y muß, wie im linken Dokument gezeigt, oberhalb oder/und links von der Stelle definiert werden, wo die Variable zum ersten Mal verwendet wird.


Argumente von Funktionen

Als Argumente von Funktionen kommen Konstanten, Variablen oder Felder in Frage. Ein Beispiel für ein Feld als Argument finden Sie im Quicksheet mit dem Namen "Funktionen mit Feldwerten".


Aktive Schnittstelle

Wenn Sie eine Änderung im Arbeitsblatt vornehmen, aktualisiert Mathcad die Ergbnisse und zeichnet die Diagramme neu.


Wysiwyg-Schnittstelle

In Mathcad können Sie Gleichungen in einer Form eingeben, die Sie von Schaubildern oder Lehrbüchern gewohnt sind. Außerdem können Sie das, was auf dem Bildschirm erscheint, in exakt der gleichen Form ausdrucken lassen.


Verschieben der Symolleisten

Zum Verschieben einer Symbolleiste gehen Sie folgendermaßen vor:

Setzen Sie den Mauszeiger an eine Stelle außerhalb von Schaltflächen oder Textfeldern.

Drücken Sie die Maustaste, halten Sie sie gedrückt, und ziehen Sie die Maus.

Sie werden sehen, daß einige Symbolleisten entsprechend der Position, an die Sie sie ziehen, neu angeordnet werden. Andere behalten ihre Form unabhängig von der Verschiebung mit der Maus bei.


Unbenanntes Arbeitsblatt

Von hier aus können Sie ein neues Mathcad-Arbeitsblatt erstellen und Daten eingeben. Wenn Sie ein bereits gespeichertes Arbeitsblatt öffnen wollen, wählen Sie den Befehl Öffnen aus dem Menü Datei.


Automatischer Modus 1

Im automatischen Modus sind die im Fenster angezeigten numerischen Ergebnisse und Diagramme immer aktuell.


Automatischer Modus 2

Wenn das Arbeitsblatt viele berechnungsintensive Gleichungen enthält, kann das Durchblättern längere Zeit in Anspruch nehmen.


Automatischer Modus 3

Im automatischen Modus sehen Sie folgendes:

Das Wort "auto" wird in der Meldungszeile angezeigt.

Links von Automatische Berechnung im Menü Rechnen wird ein Häkchen angezeigt.


Automatischer Modus 4

Wählen Sie Automatische Berechnung im Menü Rechnen.


Manueller Modus

Im manuellen Modus können Sie Arbeitsblätter schneller durchblättern, weil zeitaufwendige Berechnungen nicht während dem Blättern durchgeführt werden müssen.


Mcaduntitled00000095

Die Ergebnisse im Arbeitsblatt sind möglicherweise nicht aktuell. Wenn dies der Fall ist, wird in der Meldungszeile das Wort "calc" angezeigt.


Mcaduntitled00000096

Zum Aktualisieren der Anzeige im Fenster:

Wählen Sie Berechnen im Menü Rechnen.

Mathcad führt die Berechnungen durch, die zum Aktualisieren aller im Arbeitsblattfenster enthaltenen Ergebnisse erforderlich sind. Wenn Sie nach unten blättern, um mehr vom Arbeitsblatt anzeigen zu lassen, müssen Sie eine Neuberechnung durchführen, um die aktuellen Ergebnisse anzuzeigen.

Alle Ergebnisse im Arbeitsblatt aktualisieren:

Wählen Sie Arbeitsblatt berechnen im Menü Rechnen.


Mcaduntitled00000097

Im manuellen Modus sehen Sie folgendes:

Das Wort "auto" wird nicht in der Meldungszeile angezeigt.

Das Wort "calc" kann in der Meldungszeile angezeigt werden.

Links neben dem Befehl Automatische Berechnung im Menü Rechnen wird kein Häkchen angezeigt.


Ansichtsbereiche

Durch Wahl von Bereiche im Menü Ansicht werden alle Bereiche eingerahmt und ihre Ankerpunkte angezeigt.


Zum Einfügen eines übergreifenden Gleichheitszeichens gehen Sie folgendermaßen vor

Zum Einfügen eines übergreifenden Gleichheitszeichens (Dreifachgleichheitszeichen) gehen Sie wie folgt vor:

Drücken Sie die Tilde-Taste (~).


Zum Einfügen von = gehen Sie folgendermaßen vor:

Zum Einfügen von = gehen Sie wie folgt vor:

Drücken Sie das Gleichheitszeichen (=).


Zum Einfügen von Strg = gehen Sie wie folgt vor:

Zum Einfügen eines fettgedruckten Gleichheitszeichens (Gleichungen mit Nebenbedingungen)

Drücken Sie Strg+=


Erklärung für x

Von ":=" wird der Wert "1" der Variable x zugewiesen. Sie fügen das ":=" ein, indem Sie die Doppelpunkttaste (:) drücken.

Der schwarze Punkt auf der linken Seite ist der "Ankerpunkt". Durch diesen Punkt ist die Position der Definition präzise festgelegt. Sie lassen Ankerpunkte anzeigen, indem Sie Bereiche im Menü Ansicht wählen.


Erklärung für f(z)

Hiermit wird eine f(z)-Funktion definiert. Beachten Sie, daß z nicht festgelegt werden muß, da es nur als Scheinargument verwendet wird. z muß nicht unbedingt bekannt sein, um eine Funktion damit definieren zu können.


Erklärung =

Das "=" verwendet den aktuellen Wert von x und zeigt ihn auf der rechten Seite an.


Mcaduntitled00000112

Hiermit wird die Funktion f am aktuellen Wert von x ausgewertet.


Mcaduntitled00000113

Hiermit wird x umdefiniert. Über diesem Punkt ist für x weiterhin "1" festgelegt. Unter diesem Punkt gilt "33" für "x".


Mcaduntitled00000114

Hiermit wird die Funktion f am aktuellen Wert von x ausgewertet. Da x nun 33 ist, gilt: f(x) = 3x = 99.


Falsche Position

Dieses Diagramm hat eine falsche Position, weil sich der Ankerpunkt (der schwarze Punkt auf der linken Seite) über dem Ankerpunkt befindet, an dem u definiert ist. Daher ist u noch nicht definiert, wenn dieses Diagramm ausgewertet wird. Nicht definierte Variablen werden rot angezeigt.


Mcaduntitled00000116

Hiermit wird u als Bereichsvariable definiert, indem ihm die Abfolge 1, 2, 3...10 zugeordnet wird. Bereichsvariablen sind für die Erstellung von Diagrammen unerläßlich.

Drücken Sie zum Einfügen von ".." die Strichpunkttaste (;).


Korrekte Position

Dieses Diagramm ist korrekt positioniert. Sowohl die Bereichsvariable u als auch die Funktion f sind vor dem Ankerpunkt in der oberen linken Ecke dieses Diagramms definiert.


Durchlaufen eines Arbeitsblatts

Der erste Durchlauf durch ein Arbeitsblatt dient dazu, alles zu berechnen, wofür eine allgemeine Definition besteht. Obwohl sich diese Gleichung in der Mitte der Seite befindet, stellt sie die erste eigentliche, allgemeine Definition dar. Dadurch genießt sie Priorität vor allen anderen Gleichungen, die das Symbol ':=' oder '=' enthalten.

Beim zweiten Durchlauf durch das Arbeitsblatt gilt diese Definition als zweite Definition im Arbeitsblatt und wird daher auch als zweite Definition berechnet.


Durchlauf eines Arbeitsblatts (2)

Es ist immer noch der erste Durchlauf im Arbeitsblatt aktiv. Bei diesem ersten Durchlauf werden globale Definitionen ausgewertet.

Dies ist die zweite globale Definition. Durch das globale Definitionssymbol erhält sie zwar die Priorität über Gleichungen mit a ':=' oder a '=', aber sie hat keine Priorität vor anderen globalen Definitionen, die sich darüber oder links von ihr befinden.

Beim zweiten Durchlauf duch das Arbeitsblatt wird diese globale Definition an dritter Stelle ausgewertet, weil sie die dritte Gleichung mit einem globalen Definitionsymbol ':=' oder a '=' ist.


Durchlauf eines Arbeitsblatts (3)

Damit ist der erste Durchlauf des Arbeitsblatts abgeschlossen, die Auswertung von Gleichungen mit einem globalen Definitionssymbol. Dies ist der Beginn des zweiten Durchlaufs, bei dem alle Gleichungen ausgewertet werden. Es werden Gleichungen mit einem ':=' oder a '=' ebenso wie die mit dem globalen Definitionssymbol ausgewertet. Diese Gleichung wird zuerst ausgewertet, weil sie sich über allen anderen befindet.


Durchlauf eines Arbeitsblatts (4)

Wir sind nun beim zweiten Durchlauf durch das Arbeitsblatt, bei dem globale Definitionen und Gleichungen mit einem a ':=' oder a '=' ausgewertet werden. Dies ist die zweite dieser Gleichungen.


Durchlauf eines Arbeitsblatts (5)

Wir sind nun am Ende des zweiten Durchlaufs des Arbeitsblatts, bei dem Gleichungen mit einem globalen Definitionssystem (einem a ':=' oder a '=') ausgewertet werden.

Dies ist die letzte auszuwertende Gleichung. Der Wert von y ergibt sich aus der aktuellsten Definition mit ':=' oder dem globalen Definitionssymbol.


Genauigkeit und Ordnung der Ableitung

Die Genauigkeit sinkt, je höher die Ordnung der Ableitung ist. Dabei gilt im allgemeinen, daß eine höhere Ordnung der Ableitung mit dem Sinken der Genauigkeit um eine Stelle einhergeht.


DIALOGFELD "MOMENTAN AUSGEWÄHLTES X-Y-DIAGRAMM FORMATIEREN": REGISTERKARTE "X-Y-ACHSEN"

Auf der Registerkarte "X-Y-Achsen" des Dialogfelds "Momentan ausgewähltes X-Y-Diagramm formatieren" finden Sie die folgenden Optionen und Schaltflächen:

Logarithmusskala

Ist diese Option aktiviert, verfügt die jeweilige Achse über eine logarithmische Einteilung. Die Achsenbegrenzungen müssen positiv sein.

Gitterlinien

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der entsprechenden Achse durch Gitterlinien ersetzt.

Numeriert

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der jeweiligen Achse numeriert.

Autom. Skalierung

Jedes Diagramm, das Sie erstellen, wird standardmäßig automatisch skaliert. Wenn diese Option aktiviert ist, erfolgt eine automatische Skalierung, wobei die Achse jeweils beim ersten Hauptstrich nach dem Ende der Daten aufhört. Ist diese Option nicht aktiviert, erfolgt keine automatische Skalierung, und die Achsengrenzen stimmen mit den Datengrenzen überein.

Markierungen anzeigen

Ermöglicht es Ihnen, Ihr Diagramm mit einer oder zwei horizontalen oder vertikalen Linien zu versehen. Wenn diese Option aktiviert ist, erscheinen auf der Achse zwei zusätzliche Platzhalter. Eine vertikale Linie fügen Sie hinzu, indem Sie auf einen der Platzhalter unter der x-Achse klicken und eingeben, an welcher Stelle die Linie gezeichnet werden soll. Für eine horizontale Linie führen Sie diesen Schritt in einem der Platzhalter links neben der y-Achse aus. Wählen Sie dann den Befehl Berechnen im Menü Rechnen, um das Diagramm neu zeichnen zu lassen.

Autom. Gitterweite

Wenn diese Option aktiviert ist, wird die Anzahl der Skalenmarkierungen automatisch ausgewählt. Ist die Option nicht aktiviert, müssen Sie im Feld "Anzahl Gitterlinien" die Anzahl der Teilstriche eingeben.

Anzahl Gitterlinien

Mit dieser Option können Sie angeben, wie viele Teilstriche (Haupt- und Hilfsstriche) erscheinen sollen, wenn "Autom. Gitterweite" nicht aktiviert ist. Geben Sie eine ganze Zahl zwischen 2 und 99 ein. Achten Sie darauf, daß Sie keine zu große Zahl eingeben. Ist die Zahl der Teilstriche zu groß, kann es passieren, daß die Beschriftungen der einzelnen Teilstriche zu dicht beieinander liegen.

"Achsenformat" – "Kasten", "Kreuz", "Kein"

Mit dieser Option legen Sie fest, wo im Diagramm, wenn überhaupt, sich die Achsen kreuzen sollen. Zur Wahl stehen die Option "Kreuz" (Achsen schneiden sich in der Mitte des Diagramms), "Kasten" (Achsen schneiden sich in der linken unteren Ecke des Diagramms) und "Kein" (Achsen werden gar nicht angezeigt).

Gleiche Skalierung

Wenn diese Option aktiviert ist, haben die x- und die y-Achse die gleiche Skaleneinteilung. Dies bedeutet, daß dann, wenn ein Zentimeter auf der x-Achse für 2 Einheiten steht, ein Zentimeter auf der y-Achse ebenfalls 2 Einheiten entspricht.

Ist diese Option nicht aktiviert, verfügen x- und y-Achse über nicht voneinander abhängige Skaleneinteilungen.


DIALOGFELD "MOMENTAN AUSGEWÄHLTES X-Y-DIAGRAMM FORMATIEREN": REGISTERKARTE "SPUREN"

Auf der Registerkarte "Spuren" des Dialogfelds "Momentan ausgewähltes X-Y-Diagramm formatieren" finden Sie die folgenden Optionen und Schaltflächen:

Legendenname

Dies ist der Name der Spur, der in der Legende erscheint.

Symbol

Hiermit können Sie festlegen, ob jeder Punkt auf der Kurve durch ein Symbol gekennzeichnet werden soll.

Wenn das Diagramm eine Vielzahl von Punkten enthält, die sehr eng beieinander liegen, ist es u. U. ratsam, die Option "Kein" zu wählen.

Linie

Hiermit können Sie festlegen, wie die Linie angezeigt werden soll. Die Linie kann durchgezogen, gepunktet oder gestrichelt sein. Auch eine Strich-Punkt-Linie ist möglich. Verschiedene Linienarten sind zur Unterscheidung unmarkierter Kurven in Schwarzweißdruck nützlich.

Farbe

Hiermit legen Sie die Farbe der jeweils ausgewählten Spur fest. Zur Wahl stehen die Farben rot, blau, grün, magenta, zyan (hellblau), braun, schwarz und weiß. Bei einfarbiger Anzeige wird diese Einstellung ignoriert.

Format

Hiermit legen Sie fest, ob die ausgewählte Spur als Kurve, als Symbole/Punkte oder als Säulendiagramm, als Fehlersäulen, als Stufenkurve oder als Zweigdiagramm dargestellt werden soll.

Stärke

Hiermit können Sie festlegen, mit welcher Dicke die Kurve dargestellt wird. Verwenden Sie 1 für dünne und 9 für dicke Kurven. Geben Sie "p" ein, um eine sehr dünne Kurve (einen Pixel breit) darzustellen. Beachten Sie jedoch, daß eine "p"-Kurve unter Umständen auf Druckern ohne entsprechende Auflösung nicht adäquat gedruckt wird. Mit dieser Option wird außerdem die Größe der Symbole festgelegt, mit denen die einzelnen Datenpunkte gekennzeichnet werden, falls zuvor unter "Symbol" eine andere Option als "Kein" ausgewählt wurde. Wenn Sie sich für spurartige Punkte entschieden haben, wird mit diesem Feld festgelegt, mit welcher Stärke die Punkte zur Kennzeichnung der einzelnen Datenpunkte gedruckt werden.

Argumente ausblenden

Aktivieren Sie dieses Feld, wenn Sie die mathematischen Ausdrücke ausblenden möchten, die Sie im mittleren Platzhalter jeder Achse eingegeben haben.

Legende ausblenden

Aktivieren Sie dieses Feld, um die Legende auszublenden, die unter dem Diagramm angezeigt wird.


DIALOGFELD "MOMENTAN AUSGEWÄHLTES X-Y-DIAGRAMM FORMATIEREN": REGISTERKARTE "BESCHRIFTUNGEN"

Auf der Registerkarte "Beschriftungen" des Dialogfelds "Momentan ausgewähltes X-Y-Diagramm formatieren" finden Sie die folgenden Optionen und Schaltflächen:

Titel

Geben Sie in dieses Feld einen Titel für das Diagramm ein.

Oben

Hiermit legen Sie fest, daß der Titel oberhalb des Diagramms erscheint, wenn die Option "Titel anzeigen" aktiviert wurde.

Unten

Hiermit legen Sie fest, daß der Titel unterhalb des Diagramms erscheint, wenn die Option "Titel anzeigen" aktiviert wurde.

Titel anzeigen

Wenn diese Option aktiviert ist, wird der im Feld "Titel" angegebene Titel des Diagramms angezeigt.

Achsenbeschriftungen

Hier können Sie den Text eingeben, der neben den Achsen erscheinen soll. Der Text erscheint jedoch nur, wenn das Kontrollkästchen neben dem Textfeld markiert ist. Soll der Text (vorübergehend) nicht angezeigt werden, müssen Sie die Markierung des Kontrollkästchens aufheben.


DIALOGFELD "MOMENTAN AUSGEWÄHLTES X-Y-DIAGRAMM FORMATIEREN": REGISTERKARTE "STANDARDWERTE"

Auf der Registerkarte "Standardwerte" des Dialogfelds "Momentan ausgewähltes X-Y-Diagramm formatieren" finden Sie die folgenden Optionen und Schaltflächen:

Standardwerte wiederherstellen

Hiermit werden alle Einstellungen im Dialogfeld auf die Standardeinstellungen für das Arbeitsblatt zurückgesetzt.

Als Standard verwenden

Wenn diese Option aktiviert ist, werden die Einstellungen im Dialogfeld als Standardeinstellungen für alle im weiteren neu angelegten Diagramme verwendet. Bereits vorhandene Diagramme werden dadurch nicht verändert.


DIALOGFELD "STANDARDFORMATE FÜR X-Y-DIAGRAMME FESTLEGEN": REGISTERKARTE "X-Y-ACHSEN"

Auf der Registerkarte "X-Y-Achsen" des Dialogfelds "Standardformate für X-Y-Diagramme festlegen" finden Sie die folgenden Optionen und Schaltflächen:

Logarithmusskala

Ist diese Option aktiviert, verfügt die jeweilige Achse über eine logarithmische Einteilung. Die Achsenbegrenzungen müssen positiv sein.

Gitterlinien

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der entsprechenden Achse durch Gitterlinien ersetzt.

Numeriert

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der jeweiligen Achse numeriert.

Autom. Skalierung

Jedes Diagramm, das Sie erstellen, wird standardmäßig automatisch skaliert. Wenn diese Option aktiviert ist, erfolgt eine automatische Skalierung, wobei die Achse jeweils beim ersten Hauptstrich nach dem Ende der Daten aufhört. Ist diese Option nicht aktiviert, erfolgt keine automatische Skalierung, und die Achsengrenzen stimmen mit den Datengrenzen überein.

Markierungen anzeigen

Ermöglicht es Ihnen, Ihr Diagramm mit einer oder zwei horizontalen oder vertikalen Linien zu versehen. Wenn diese Option aktiviert ist, erscheinen auf der Achse zwei zusätzliche Platzhalter. Eine vertikale Linie fügen Sie hinzu, indem Sie auf einen der Platzhalter unter der x-Achse klicken und eingeben, an welcher Stelle die Linie gezeichnet werden soll. Für eine horizontale Linie führen Sie diesen Schritt in einem der Platzhalter links neben der y-Achse aus. Wählen Sie dann den Befehl Berechnen im Menü Rechnen, um das Diagramm neu zeichnen zu lassen.

Autom. Gitterweite

Wenn diese Option aktiviert ist, wird die Anzahl der Skalenmarkierungen automatisch ausgewählt. Ist die Option nicht aktiviert, müssen Sie im Feld "Anzahl Gitterlinien" die Anzahl der Teilstriche eingeben.

Anzahl Gitterlinien

Mit dieser Option können Sie angeben, wie viele Teilstriche (Haupt- und Hilfsstriche) erscheinen sollen, wenn "Autom. Gitterweite" nicht aktiviert ist. Geben Sie eine ganze Zahl zwischen 2 und 99 ein. Achten Sie darauf, daß Sie keine zu große Zahl eingeben. Ist die Zahl der Teilstriche zu kurz, kann es passieren, daß die Beschriftungen der einzelnen Teilstriche zu dicht beieinander liegen.

"Achsenformat" – "Kasten", "Kreuz", "Kein"

Mit dieser Option legen Sie fest, wo im Diagramm, wenn überhaupt, sich die Achsen kreuzen sollen. Zur Wahl stehen die Option "Kreuz" (Achsen schneiden sich in der Mitte des Diagramms), "Kasten" (Achsen schneiden sich in der linken unteren Ecke des Diagramms) und "Kein" (Achsen werden gar nicht angezeigt).

Gleiche Skalierung

Wenn diese Option aktiviert ist, haben die x- und die y-Achse die gleiche Skaleneinteilung. Dies bedeutet, daß dann, wenn ein Zentimeter auf der x-Achse für 2 Einheiten steht, ein Zentimeter auf der y-Achse ebenfalls 2 Einheiten entspricht.

Ist diese Option nicht aktiviert, verfügen x- und y-Achse über nicht voneinander abhängige Skaleneinteilungen.


DIALOGFELD "STANDARDFORMATE FÜR X-Y-DIAGRAMME FESTLEGEN": REGISTERKARTE "SPUREN"

Auf der Registerkarte "Spuren" des Dialogfelds "Standardformate für X-Y-Diagramme festlegen" finden Sie die folgenden Optionen und Schaltflächen:

Legendenname

Dies ist der Name der Spur, der in der Legende erscheint.

Symbol

Hiermit können Sie festlegen, ob jeder Punkt auf der Kurve durch ein Symbol gekennzeichnet werden soll.

Wenn das Diagramm eine Vielzahl von Punkten enthält, die sehr eng beieinander liegen, ist es u. U. ratsam, die Option "Kein" zu wählen.

Linie

Hiermit können Sie festlegen, wie die Linie angezeigt werden soll. Die Linie kann durchgezogen, gepunktet oder gestrichelt sein. Auch eine Strich-Punkt-Linie ist möglich. Verschiedene Linienarten sind zur Unterscheidung unmarkierter Kurven in Schwarzweißdruck nützlich.

Farbe

Hiermit legen Sie die Farbe der jeweils ausgewählten Spur fest. Zur Wahl stehen die Farben rot, blau, grün, magenta, zyan (hellblau), braun, schwarz und weiß. Bei einfarbiger Anzeige wird diese Einstellung ignoriert.

Format

Hiermit legen Sie fest, ob die ausgewählte Spur als Kurve, als Symbole/Punkte oder als Säulendiagramm, als Fehlersäulen, als Stufenkurve oder als Zweigdiagramm dargestellt werden soll.

Stärke

Hiermit können Sie festlegen, mit welcher Dicke die Kurve dargestellt wird. Verwenden Sie 1 für dünne und 9 für dicke Kurven. Geben Sie "p" ein, um eine sehr dünne Kurve (einen Pixel breit) darzustellen. Beachten Sie jedoch, daß eine "p"-Kurve unter Umständen auf Druckern ohne entsprechende Auflösung nicht adäquat gedruckt wird. Mit dieser Option wird außerdem die Größe der Symbole festgelegt, mit denen die einzelnen Datenpunkte gekennzeichnet werden, falls zuvor unter "Symbol" eine andere Option als "Kein" ausgewählt wurde. Wenn Sie sich für spurartige Punkte entschieden haben, wird mit diesem Feld festgelegt, mit welcher Stärke die Punkte zur Kennzeichnung der einzelnen Datenpunkte gedruckt werden.

Argumente ausblenden

Aktivieren Sie dieses Feld, wenn Sie die mathematischen Ausdrücke ausblenden möchten, die Sie im mittleren Platzhalter jeder Achse eingegeben haben.

Legende ausblenden

Aktivieren Sie dieses Feld, um die Legende auszublenden, die unter dem Diagramm angezeigt wird.


DIALOGFELD "MOMENTAN AUSGEWÄHLTES KREISDIAGRAMM FORMATIEREN": REGISTERKARTE "ACHSEN"

Auf der Registerkarte "Achsen" des Dialogfelds "Momentan ausgewähltes Kreisdiagramm formatieren" finden Sie die folgenden Optionen und Schaltflächen:

Logarithmusskala

Ist diese Option aktiviert, verfügt die Kreisdiagrammachse über eine logarithmische Einteilung. Die Achsenbegrenzungen müssen positiv sein.

Gitterlinien

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der jeweiligen Achse durch Gitterlinien ersetzt.

Numeriert

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der jeweiligen Achse numeriert.

Markierungen anzeigen

Mit dieser Option können Sie Ihr Kreisdiagramm mit radialen Hilfslinien versehen. Gehen Sie hierzu folgendermaßen vor:

  • Klicken Sie auf das Kontrollkästchen "Markierungen anzeigen". Oben links im Diagramm werden zwei weitere Platzhalter angezeigt.

  • Klicken Sie auf einen der Platzhalter, und geben Sie den Wert ein, an dem eine Linie erscheinen soll. Wiederholen Sie diese Schritte für den anderen Platzhalter, um eine zweite radiale Hilfslinie hinzuzufügen.

Autom. Gitterweite

Wenn diese Option aktiviert ist, wird die Anzahl der Skalenmarkierungen automatisch ausgewählt.

Anzahl Gitterlinien

Mit dieser Option können Sie angeben, wie viele Gitterlinien erscheinen sollen, wenn "Autom. Gitterweite" nicht aktiviert ist. Geben Sie eine ganze Zahl zwischen 2 und 99 ein. Achten Sie darauf, daß Sie keine zu große Zahl eingeben. Ist die Zahl der Teilstriche zu groß, kann es passieren, daß die Beschriftungen der einzelnen Teilstriche zu dicht beieinander liegen.

"Achsenformat" – "Rundum", "Kreuz", "Kein"

Hiermit legen Sie fest, ob sich die Achsen in der Mitte des Diagramms schneiden sollen (Option "Kreuz") oder ob sie das Diagramm in einem Kreis umschließen sollen (Option "Rundum"). Wenn Sie "Kein" wählen, werden die Achsen nicht angezeigt.


DIALOGFELD "MOMENTAN AUSGEWÄHLTES KREISDIAGRAMM FORMATIEREN": REGISTERKARTE "SPUREN"

Auf der Registerkarte "Spuren" des Dialogfelds "Momentan ausgewähltes Kreisdiagramm formatieren" finden Sie die folgenden Optionen und Schaltflächen:

Legendenname

Dies ist der Name der Spur, der in der Legende erscheint.

Symbol

Hiermit können Sie festlegen, ob jeder Punkt auf der Kurve durch ein Symbol gekennzeichnet werden soll. Wenn das Diagramm eine Vielzahl von Punkten enthält, die sehr eng beieinander liegen, ist es u. U. ratsam, die Option "Kein" zu wählen.

Linie

Hiermit können Sie festlegen, wie die Linie angezeigt werden soll. Die Linie kann durchgezogen, gepunktet oder gestrichelt sein. Auch eine Strich-Punkt-Linie ist möglich. Verschiedene Linienarten sind zur Unterscheidung unmarkierter Kurven in Schwarzweißdruck nützlich.

Farbe

Hiermit legen Sie die Farbe der jeweils ausgewählten Spur fest. Zur Wahl stehen die Farben rot, blau, grün, magenta, zyan (hellblau), braun, schwarz und weiß. Bei einfarbiger Anzeige wird diese Einstellung ignoriert.

Format

Hiermit legen Sie fest, ob die ausgewählte Spur als Kurve, als Säulendiagramm, als Fehlersäulen, als Stufenkurve oder als Zweigdiagramm dargestellt werden soll.

Stärke

Hiermit können Sie festlegen, mit welcher Dicke die Kurve dargestellt wird. Verwenden Sie 1 für dünne und 9 für dicke Kurven. Geben Sie "p" ein, um eine sehr dünne Kurve (einen Pixel breit) darzustellen. Beachten Sie jedoch, daß eine "p"-Kurve unter Umständen auf Druckern ohne entsprechende Auflösung nicht adäquat gedruckt wird. Mit dieser Option wird außerdem die Größe der Symbole festgelegt, mit denen die einzelnen Datenpunkte gekennzeichnet werden, falls zuvor unter "Symbol" eine andere Option als "Kein" ausgewählt wurde. Wenn Sie sich für spurartige Punkte entschieden haben, wird mit diesem Feld festgelegt, mit welcher Stärke die Punkte zur Kennzeichnung der einzelnen Datenpunkte gedruckt werden.

Argumente ausblenden

Aktivieren Sie dieses Feld, wenn Sie die mathematischen Ausdrücke ausblenden möchten, die Sie im mittleren Platzhalter jeder Achse eingegeben haben.

Legende ausblenden

Aktivieren Sie dieses Feld, um die Legende auszublenden, die unter dem Diagramm angezeigt wird.


DIALOGFELD "MOMENTAN AUSGEWÄHLTES KREISDIAGRAMM FORMATIEREN": REGISTERKARTE "BESCHRIFTUNGEN"

Auf der Registerkarte "Beschriftungen" des Dialogfelds "Momentan ausgewähltes Kreisdiagramm formatieren" finden Sie die folgenden Optionen und Schaltflächen:

Titel

Geben Sie in dieses Feld einen Titel für das Diagramm ein.

Oben

Hiermit legen Sie fest, daß der Titel oberhalb des Diagramms erscheint, wenn die Option "Titel anzeigen" aktiviert wurde.

Unten

Hiermit legen Sie fest, daß der Titel unterhalb des Diagramms erscheint, wenn die Option "Titel anzeigen" aktiviert wurde.

Titel anzeigen

Wenn diese Option aktiviert ist, wird der im Feld "Titel" angegebene Titel des Diagramms angezeigt.


DIALOGFELD "MOMENTAN AUSGEWÄHLTES KREISDIAGRAMM FORMATIEREN": REGISTERKARTE "STANDARDWERTE"

Auf der Registerkarte "Standardwerte" des Dialogfelds "Momentan ausgewähltes Kreisdiagramm formatieren" finden Sie die folgenden Optionen und Schaltflächen:

Standardwerte wiederherstellen

Hiermit werden alle Einstellungen im Dialogfeld auf die Standardeinstellungen für das Arbeitsblatt zurückgesetzt.

Als Standard verwenden

Wenn diese Option aktiviert ist, werden die Einstellungen im Dialogfeld als Standardeinstellungen für alle im weiteren neu angelegten Diagramme verwendet. Bereits vorhandene Diagramme werden dadurch nicht verändert.


Dialogeld "Standardformate für Kreisdiagramme festlegen": Registerkarte "Achsen"

DIALOGFELD "STANDARDFORMATE FÜR KREISDIAGRAMME FESTLEGEN": REGISTERKARTE "ACHSEN"

Auf der Registerkarte "Achsen" des Dialogfelds "Standardformate für Kreisdiagramme festlegen" finden Sie die folgenden Optionen und Schaltflächen:

Logarithmusskala

Ist diese Option aktiviert, verfügt die Kreisdiagrammachse über eine logarithmische Einteilung. Die Achsenbegrenzungen müssen positiv sein.

Gitterlinien

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der entsprechenden Achse durch Gitterlinien ersetzt.

Numeriert

Wenn diese Option aktiviert ist, werden die Skalenmarkierungen auf der jeweiligen Achse numeriert.

Markierungen anzeigen

Mit dieser Option können Sie Ihr Kreisdiagramm mit radialen Hilfslinien versehen. Gehen Sie hierzu folgendermaßen vor:

  • Klicken Sie auf das Kontrollkästchen "Markierungen anzeigen". Oben links im Diagramm werden zwei weitere Platzhalter angezeigt.

  • Klicken Sie auf einen der Platzhalter, und geben Sie den Wert ein, an dem eine Linie erscheinen soll. Wiederholen Sie diese Schritte für den anderen Platzhalter, um eine zweite radiale Hilfslinie hinzuzufügen.

Autom. Gitterweite

Wenn diese Option aktiviert ist, wird die Anzahl der Skalenmarkierungen automatisch ausgewählt.

Anzahl Gitterlinien

Mit dieser Option können Sie angeben, wie viele Gitterlinien erscheinen sollen, wenn "Autom. Gitterweite" nicht aktiviert ist. Geben Sie eine ganze Zahl zwischen 2 und 99 ein. Achten Sie darauf, daß Sie keine zu große Zahl eingeben. Ist die Zahl der Teilstriche zu groß, kann es passieren, daß die Beschriftungen der einzelnen Teilstriche zu dicht beieinander liegen.

"Achsenformat" – "Rundum", "Kreuz", "Kein"

Hiermit legen Sie fest, ob sich die Achsen in der Mitte des Diagramms schneiden sollen (Option "Kreuz") oder ob sie das Diagramm in einem Kreis umschließen sollen (Option "Rundum"). Wenn Sie "Kein" wählen, werden die Achsen nicht angezeigt.


DIALOGFELD "STANDARDFORMATE FÜR KREISDIAGRAMME FESTLEGEN": REGISTERKARTE "SPUREN"

Auf der Registerkarte "Spuren" des Dialogfelds "Standardformate für Kreisdiagramme festlegen" finden Sie die folgenden Optionen und Schaltflächen:

Legendenname

Dies ist der Name der Spur, der in der Legende erscheint.

Symbol

Hiermit können Sie festlegen, ob jeder Punkt auf der Kurve durch ein Symbol gekennzeichnet werden soll. Wenn das Diagramm eine Vielzahl von Punkten enthält, die sehr eng beieinander liegen, ist es u. U. ratsam, die Option "Kein" zu wählen.

Linie

Hiermit können Sie festlegen, wie die Linie angezeigt werden soll. Die Linie kann durchgezogen, gepunktet oder gestrichelt sein. Auch eine Strich-Punkt-Linie ist möglich. Verschiedene Linienarten sind zur Unterscheidung unmarkierter Kurven in Schwarzweißdruck nützlich.

Farbe

Hiermit legen Sie die Farbe der jeweils ausgewählten Spur fest. Zur Wahl stehen die Farben rot, blau, grün, magenta, zyan (hellblau), braun, schwarz und weiß. Bei einfarbiger Anzeige wird diese Einstellung ignoriert.

Format

Hiermit legen Sie fest, ob die ausgewählte Spur als Kurve, als Säulendiagramm, als Fehlersäulen, als Stufenkurve oder als Zweigdiagramm dargestellt werden soll.

Stärke

Hiermit können Sie festlegen, mit welcher Dicke die Kurve dargestellt wird. Verwenden Sie 1 für dünne und 9 für dicke Kurven. Geben Sie "p" ein, um eine sehr dünne Kurve (einen Pixel breit) darzustellen. Beachten Sie jedoch, daß eine "p"-Kurve unter Umständen auf Druckern ohne entsprechende Auflösung nicht adäquat gedruckt wird. Mit dieser Option wird außerdem die Größe der Symbole festgelegt, mit denen die einzelnen Datenpunkte gekennzeichnet werden, falls zuvor unter "Symbol" eine andere Option als "Kein" ausgewählt wurde. Wenn Sie sich für spurartige Punkte entschieden haben, wird mit diesem Feld festgelegt, mit welcher Stärke die Punkte zur Kennzeichnung der einzelnen Datenpunkte gedruckt werden.

Argumente ausblenden

Aktivieren Sie dieses Feld, wenn Sie die mathematischen Ausdrücke ausblenden möchten, die Sie im mittleren Platzhalter jeder Achse eingegeben haben.

Legende ausblenden

Aktivieren Sie dieses Feld, um die Legende auszublenden, die unter dem Diagramm angezeigt wird.


WWW-FOREN

Es handelt sich um eine WWW-Seite, die von MathSoft unterhalten wird. Sie enthält Arbeitsblätter und andere Dokumente aus der ganzen Welt, die in Foren zusammengefaßt wurden. Mit Hilfe des Dialogfelds "WWW-Foren" kann man sich als Besucher der WWW-Foren problemlos in ausführliche Diskussionen zu einer Vielzahl von Themen einklinken und dabei Arbeitsblätter und andere Dokumente austauschen.


Popup-Menü

Das Menü, das erscheint, wenn Sie mit der rechten Maustaste auf einen Bereich klicken, den Sie zuvor durch Klicken mit der linken Maustaste markiert haben.


EINGABEVARIABLE

Eine Mathcad-Variable (ein Feld oder ein Skalar), deren Werte über eine Komponente an eine andere Anwendung oder Datenquelle weitergegeben werden.


AUSGABEVARIABLE

Eine Mathcad-Variable (eine Feld oder ein Skalar), die über eine Komponente mit Werten aus einer anderen Anwendung oder Datenquelle definiert wurde.


VORLAGE

Datei, auf deren Grundlage ein Mathcad-Arbeitsblatt erstellt werden kann. Eine Vorlage enthält benutzerdefinierte Angaben zum Layout und zur Formatierung des Arbeitsblatts. Die standardmäßige Dateinamenerweiterung für Vorlagen ist ".mct".


AUFWÄRT SKOMPATIBEL

Mathcad-Arbeitsblätter sind aufwärts kompatibel. Das heißt, daß ein Arbeitsblatt, das in einer früheren Mathcad-Version erstellt wurde, auch in höheren Versionen geöffnet werden kann.


AKTIVES ARBEITSBLATT

Das aktive Arbeitsblatt ist das Arbeitsblatt, auf das sich die meisten Menübefehle, Symbolleistenschaltflächen und Tastatureingaben auswirken. Welches Arbeitsblatt das aktive ist, erkennen Sie an der Titelleiste des jeweiligen Arbeitsblatt-Fensters. Sie müssen nur nach dem Arbeitsblattfenster suchen, deren Titelleiste farblich hervorgehoben ist.


ARGUMENTELISTE

Dies ist die Liste der Variablen zwischen den Klammern in einer Funktion. Beispiel:

f(x, y, z) := x + y + z + w

Die Argumenteliste wäre in diesem Fall:

x, y, z


URL

URL (Universal Resource Locator)

Dies ist der Pfadname (die Adresse) für eine bestimmte Datei im Internet. Die URL für die MathSoft-Homepage im WWW lautet "http://www.mathsoft.com".


ASCII-DATEI

Eine ASCII-Datei ist eine einfache Textdatei, die Sie in einem einfachen Texteditor, wie z. B. dem Editor von Windows oder SimpleText auf dem Macintosh, öffnen können. Die Datei enthält nur Buchstaben, Zahlen, Leerzeichen, Tabulatoren und Zeilenschaltungen. Viele Anwendungen können ihre Dokumente in dieser Form speichern. Im Normalfall wird zum Speichern von Informationen in einer ASCII-Datei der Befehl Speichern unter gewählt und die entsprechende Option aus der Liste der Dateitypen ausgewählt.


ARGUMENT EINER FUNKTION

Dieser Begriff bezieht sich auf alles, was zwischen den Klammern erscheint, wenn Sie eine Funktion verwenden oder definieren. Beispiel:


DEFINITIONSSYMBOL

:=

Dies ist der am häufigsten verwendete Zuordnungsoperator. Er wertet alles aus, was sich auf seiner rechten Seite befindet, und ordnet es dem Variablennamen auf der linken Seite zu.

Auf der linken Seite kann entweder ein Variablenname oder ein Funktionsname stehen, jedoch kein Ausdruck. Auf der rechten Seite muß ein Ausdruck stehen, dessen Ergebnis eine Zahl oder eine Funktionsdefinition ist. Alle Variablen oder Funktionen auf der rechten Seite müssen bereits definiert sein.


DIMENSIONEN

Eine Dimension ist eine physikalische Größe, die mit einer Zahl, einem Feld oder einer eine Zahl oder ein Feld darstellenden Variable verknüpft ist. Die folgenden Grunddimensionen können beliebig miteinander kombiniert werden:

Länge

Zeit

Masse

Ladung

Temperatur

Beachten Sie, daß eine Dimension keine Einheit ist. Eine Einheit gibt das Maß einer Dimension an. Die Dimension "Länge" kann z. B. mit den folgenden drei Einheiten gemessen werden: Meter (m), Zentimeter (cm) und Millimeter (mm).


PFADNAME

Ein Pfadname ist der vollständige DOS-Name für eine Datei. Wenn sich z. B. eine Datei mit dem Namen tuba.mcd in einem Unterverzeichnis mit der Bezeichnung \orchester\blech auf Ihrem Laufwerk A befindet, lautet der vollständige Pfadname:

A:\orchester\blech\tuba.mcd.


Dateiname

Ein Dateiname ist der Name für eine Datei einschließlich der jeweiligen Dateinamenerweiterung.

Beispiel: tuba.txt.


Variablenformat

Dies ist das standardmäßige Rechenformat, das jedem Variablen- oder Funktionsnamen zugewiesen wird, den Sie im Arbeitsblatt eingeben.


Konstanten format

Dies ist das standardmäßige Rechenformat, das jeder Konstante zugewiesen wird, die Sie im Arbeitsblatt eingeben.


BENUTZERDEFINIERTE RECHENFORMATE

Statt die Schriftart eines Namens bzw. einer Zahl direkt zu ändern, können Sie eine neue Rechenformatvorlage definieren, die Sie den Namen und Zahlen zuweisen.

Zum Definieren einer neuen Rechenformatvorlage gehen Sie wie folgt vor:

  1. Wählen Sie Gleichung aus dem Menü Format.

  2. Wählen Sie eine noch nicht verwendete Formatvorlage, zum Beispiel "Benutzer 1".

  3. Geben Sie im Feld “Neuer Name der Vorlage” einen Namen für die neue Rechenformatvorlage ein.

  4. Klicken Sie auf die Schaltfläche “Ändern”, und wählen Sie die Schriftart, die Größe und den Stil für die Formatvorlage aus.

  5. Klicken Sie auf “OK”.

Zum Zuweisen dieser Rechenformatvorlage zu einem bestimmten Namen bzw. zu einer Zahl gehen Sie wie folgt vor:

  1. Klicken Sie auf den Namen bzw. die Zahl.

  2. Wählen Sie den Befehl Gleichung aus dem Menü Format.

  3. Wählen Sie aus der Dropdown-Liste im Dialogfeld eine Rechenformatvorlage aus.

  4. Klicken Sie auf "OK", um die ausgewählte Formatvorlage dem ausgewählten Namen zuzuweisen.


Rechenformatvorlage

Eine Rechenformatvorlage enthält Angaben zur Schriftart, zur Schriftgröße und zum Schriftstil. Wenn Sie einen Variablennamen eingeben, weist Mathcad der Variable eine Gleichungsformatvorlage namens "Variablen" zu, für die eine bestimmte Schriftart, eine Schriftgröße und ein Schriftstil definiert ist. Auch wenn Sie eine Konstante eingeben, weist Mathcad dieser Konstante eine Rechenformatvorlage zu, diesmal die mit dem Namen "Konstanten", für die ebenfalls eine bestimmte Schriftart, eine Schriftgröße und ein Schriftstil definiert ist.

Wenn Sie sich anzeigen lassen möchten, welche Gleichungsformatvorlage einem bestimmten Namen oder einer bestimmten Zahl gegenwärtig zugewiesen ist, klicken Sie auf den Namen oder die Zahl, und schauen Sie sich den Namen der Rechenformatvorlage in der Schriftartleiste an. Statt dessen können Sie auch den Befehl Gleichung im Menü Format wählen.

Zum Ändern der Schriftartmerkmale einer Formatvorlage gehen Sie wie folgt vor:

Wählen Sie Gleichung aus dem Menü Format.

Wählen Sie eine Vorlage aus, und klicken Sie auf "Ändern".

Wenn einem Namen oder einer Zahl eine andere Gleichungsformatvorlage zugewiesen werden soll, gehen Sie wie folgt vor:

Klicken Sie auf den Namen bzw. die Zahl.

Wählen Sie Gleichung aus dem Menü Format.

Wählen Sie eine Vorlage aus, und klicken Sie auf "OK".


Grafikbereich

Ein Grafikbereich ist ein Bereich, der die folgenden Diagramme oder Bilder enthalten kann:

X-Y-Diagramm

Kreisdiagramm

Flächendiagramm

Umrißdiagramm

3D-Säulendiagramm

Vektorfeld-Diagramm

Streuungsdiagramm

Grafikbild

Zum Erstellen von Grafikbereichen stehen Ihnen verschiedene Befehle im Menü Einfügen zur Verfügung.


IMPORTIEREN VON DATEN AUS EINER DATEI

Der Vorgang, bei dem Daten aus einer externen Datendatei mit einem Mal in ein Mathcad-Arbeitsblatt übertragen werden.


EINLESEN VON DATEN AUS EINER DATEI

Der Vorgang, bei dem Daten aus einer externen Datendatei durch das Herstellen einer Verbindung zu dieser Datendatei in ein Mathcad-Arbeitsblatt übertragen werden. Wenn sich die Datendatei ändert, werden die Daten im Mathcad-Arbeitsblatt automatisch aktualisiert.


Exportieren von Daten in eine Datei

Der Vorgang, bei dem Daten aus einem Mathcad-Arbeitsblatt mit einem Mal in eine externe Datendatei übertragen werden.


Schreiben von Daten in eine Datei

Der Vorgang, bei dem Daten aus einem Mathcad-Arbeitsblatt durch das Herstellen einer Verbindung zu einer Datendatei in die externe Datendatei übertragen werden. Wenn sich die Daten im Mathcad-Arbeitsblatt ändern, werden die Daten in der Datendatei automatisch aktualisiert.


Windows-Bitmap-Grafik

Eine im Standard-Windows-Grafikformat gespeicherte Grafik.

Bitmap-Bilder können von einer Vielzahl von Windows-Anwendungen, z. B. von Paint (im Lieferumfang von Windows 95 enthalten), erstellt werden.

In Dateien gespeicherte Bitmap-Bilder haben gewöhnlich die Erweiterung ".bmp".


EINFÜGEMARKE

Die Einfügemarke wird durch eine rote, senkrechte Linie dargestellt, hinter der die Zeichen erscheinen, die Sie eingeben. Mit den Tasten [image] sowie [image] können Sie sie verschieben. Sie können auch auf die Stelle klicken, an der Sie die Einfügemarke wünschen.


FADENKREUZ

Wenn Sie auf eine leere Stelle klicken, erscheint das Fadenkreuz. Es zeigt an, wo das Zeichen, das Sie als nächstes eingeben, oder der Inhalt, den Sie aus der Zwischenablage einfügen, erscheint.

Zum Positionieren des Fadenkreuzes können Sie entweder auf die Stelle klicken, an der es erscheinen soll, oder die Richtungstasten, die Eingabetaste, die Leertaste bzw. die Nach-Oben- und Nach-Unten-Taste drücken.


OPERATOR

Mit Hilfe eines Operators werden eine oder mehrere Zahlen in eine dritte Zahl umgewandelt. Beispiele für Operatoren:

der Exponentenoperator in " [image] "

der Fakultätsoperator in "(x + z)!",

das Pluszeichen in "1 + 1",

das Integralzeichen in " [image] ".

Die Zahlen, auf die sich der Operator auswirkt, werden "Operanden" genannt.


ZWISCHENABLAGE

Die Zwischenablage ist ein temporärer Speicherbereich Ihres Betriebssystems.

Wenn Sie etwas in der Zwischenablage ablegen wollen, müssen Sie es zunächst markieren und dann im Menü Bearbeiten einen der folgenden Befehle wählen:

  • Mit Ausschneiden löschen Sie die Markierung aus dem Arbeitsblatt, und stellen sie in die Zwischenablage.

  • Mit Kopieren kopieren Sie die Markierung in die Zwischenablage, ohne daß sie aus dem Arbeitsblatt gelöscht wird.

Wenn Sie in die Zwischenablage kopieren oder ausschneiden, wird der bisherige Inhalt der Zwischenablage gelöscht.

Sie können den jeweiligen Inhalt der Zwischenablage mit den Befehlen Einfügen und Inhalte einfügen aus dem Menü Bearbeiten in das Arbeitsblatt einfügen.


Operator-Symbolleisten

Die Operator-Symbolleisten öffnen Sie, indem Sie auf die Schaltflächen direkt unter der Menüleiste klicken. Durch Klicken auf die Schaltflächen in diesen Symbolleisten werden die entsprechenden Operatoren eingefügt.


Leerer Raum

Dies ist der Raum zwischen Bereichen. Wenn Sie im leeren Raum klicken, erscheint ein Fadenkreuz.

Leerstellen, die Variablen und Operatoren in einer Gleichung voneinander trennen, werden nicht als leerer Raum bezeichnet.


BEARBEITUNGSLINIEN

Die Bearbeitungslinien helfen Ihnen bei der Markierung von Teilen eines Ausdrucks. Sie bestehen aus zwei Teilen:

  • Dem Unterstrich, also der horizontalen Bearbeitungslinie

  • Der Einfügelinie, also der vertikalen Bearbeitungslinie.

Zum Positionieren eines Ausdrucks zwischen den Bearbeitungslinien (siehe Beschreibung oben) gehen Sie wie folgt vor:

  1. Klicken Sie mit der Maus auf den Ausdruck.

  2. Falls erforderlich, verschieben Sie die Bearbeitungslinien mit den Richtungstasten.

  3. Falls erforderlich, können Sie die Bearbeitungslinien durch Drücken der Leertaste verlängern, bis sie den gesamten Ausdruck enthalten. Sie können auch auf verschiedene Teile des Ausdrucks klicken und so den Inhalt der Bearbeitungslinien verändern.

Im allgemeinen gilt:

All das, was unterstrichen ist und links der Einfügelinie steht, wird zum ersten Operator des eingegebenen Ausdrucks.


BEREICH

Alles, was Sie in Ihr Arbeitsblatt einfügen, befindet sich in einem Bereich. Die Schritte zum Markieren, Löschen und Verschieben von Bereichen sind stets dieselben, egal, was sich im Bereich befindet.

Wenn Sie auf einen Bereich klicken, erscheinen entweder zwei Bearbeitungslinien oder die Text-Einfügemarke. Wenn Sie außerhalb eines Bereichs klicken, wird ein kleines Fadenkreuz angezeigt.


LÖSUNGSBLOCK

Unter einem Lösungsblock versteht man eine Gruppe von Schritten, die zum Auflösen eines Gleichungssystems, eines Optimierungsproblems oder eines linearen Programmierungsproblems ausgeführt werden. Diese Lösungsschritte unterscheiden sich zwar geringfügig, gleich ist aber allen, daß sie das Wort Vorgabe, bestimmte Bedingungen und eine Lösungsfunktion beinhalten. Zusammengenommen ergibt das einen Lösungsblock.

Ein Lösungsblock setzt sich aus den folgenden Teilen zusammen:

  1. Wort Vorgabe. Dieses Wort muß als Variable in einem leeren Teil des Arbeitsblatts eingegeben werden.

  2. Bedingungen (bis zu 200) Die Gleichungen und Ungleichungen müssen mit Hilfe der Booleschen Operatoren, mit Ausnahme von Strg +3 ("ungleich"), eingegeben werden.

  3. Eine der folgenden Lösungsfunktionen:

suchen oder minfehl zum Lösen eines Gleichungssystems

maximieren oder minimieren zum Optimieren einer Funktion.

Die folgenden Dinge sind in Lösungsblöcken zu vermeiden:

  • Bereichsvariablen

  • Ungleichungen der Form a<b<c. Ein Ausdruck wie "x ist kleiner als 2 und größer als -2" würde durch den Ausdruck (x<2)*(x>-2) dargestellt.

  • Andere Lösungsblöcke. Jeder Lösungsblock darf nur einmal das Wort "Vorgabe" und nur eine Lösungsfunktion enthalten. Sie können jedoch am Ende des Lösungsblocks eine Funktion wie f(x):=Suchen(x) definieren und diese Funktion in einem anderen Lösungsblock verwenden.

  • Zuweisungen durch einen Zuweisungs-Operator. Zum Eingeben eines Gleichheitszeichens in Lösungsblöcken verwenden Sie Strg+=.

Beachten Sie, daß beim numerischen Lösen von Gleichungen andere Schritte vor dem Lösungsblock vorhanden sein müssen:

  • Sie müssen Schätzwerte für die Variablen definieren.

  • Bei den Funktionen maximieren bzw. minimieren muß die zu optimierende Funktion definiert sein.


OLE-SERVER

Eine Windows-Anwendung, die OLE-Objekte (Object Linking and Embedding) über die Zwischenablage exportieren kann.

Mit dieser Funktion können Sie das OLE-Objekt in derjenigen Anwendung bearbeiten, in der es erstellt wurde. Doppelklicken Sie hierzu auf das Objekt.


EINGEBETTETES OBJEKT

Ein Objekt, das die Anwendung, mit der es erstellt wurde, und eine Kopie seiner selbst im Anwendungsfenster öffnet, sobald Sie darauf doppelklicken. Wenn die Anwendung die Aktivierung an Ort und Stelle unterstützt, werden statt der Mathcad-Menüs und -Symbolleisten die Menüs und Symbolleisten der anderen Anwendung angezeigt, und um das Objekt erscheint eine gestrichelte Linie.

Jegliche Änderungen, die Sie am Objekt vornehmen, wirken sich nur auf das Objekt in Mathcad aus. Dies ist ungefähr so, als würden Sie eine Fotokopie anfertigen und Änderungen nur auf der Kopie vornehmen, während das Original unverändert bleibt.


VERKNÜPFTES OBJEKT

Ein Objekt, das die Anwendung, mit der es erstellt wurde, sowie eine Datei mit dem Objekt öffnet, sobald Sie darauf doppelklicken. Wenn die Anwendung die Aktivierung an Ort und Stelle unterstützt, werden statt der Mathcad-Menüs und -Symbolleisten die Menüs und Symbolleisten der anderen Anwendung angezeigt, und um das Objekt erscheint eine gestrichelte Linie.

Jegliche Änderungen, die Sie an dem Objekt vornehmen, wirken sich auf die Originaldatei aus, die das Objekt enthält.


Algebraische Transformation

Dies ist das einfache Umwandeln eines mathematischen Ausdrucks in einen anderen, äquivalenten Ausdruck.


BOOLESCHER AUSDRUCK

Dies ist ein Ausdruck, dessen Ergebnis entweder "wahr" oder "falsch" ist. Beispiel:

"1 > 2" ist ein Boolescher Ausdruck, weil sein Wert "FALSCH" ist.

"x = 2" ist ein Boolescher Ausdruck, weil er je nach dem Wert von "x", entweder "WAHR" oder "FALSCH" sein kann.

"1 + 1" ist KEIN Boolescher Ausdruck, weil er weder "WAHR" noch "FALSCH", sondern einfach nur "2" ist.


Informationszentrum

DAS INFORMATIONSZENTRUM

Das Informationszentrum ist eine Sammlung von Hilfsmitteln, mit denen Sie Mathcad optimal nutzen können. Dazu gehören zum Beispiel Referenztabellen, ein Mathcad-Lehrprogramm, Mathcad-Quicksheets sowie eine Verknüpfung zur WWW-Site von MathSoft.


QUICKPLOTS

Um in Mathcad ein Diagramm erstellen zu können, müssen Sie im Normalfall zuvor die Variablen in dem darzustellenden Ausdruck definiert haben. Quickplots können jedoch gezeichnet werden, ohne vorher Variablen zu definieren.

Wenn Sie z. B. x gegen x^2 darstellen möchten, müssen Sie x zuvor als eine Bereichsvariable definiert haben. Für ein Quickplot brauchen Sie x jedoch nicht zu definieren. Lassen Sie einfach x gegen x^2 darstellen. Mathcad wählt automatisch einen entsprechenden Bereich für x aus und zeichnet das Diagramm.


ELEKTRONISCHE BÜCHER

Ein Elektronisches Buch ist eine Sammlung von mehreren Hundert mit Hyperlinks versehenen, interaktiven Mathcad-Arbeitsblättern, die eine Vielzahl von unterschiedlichen Berechnungen demonstrieren, die in bestimmten Fachgebieten, wie Elektrotechnik, Statistik, Finanzwesen und höhere Mathematik, häufig verwendet werden. Das Elektronische Buch verfügt über ein Inhaltsverzeichnis, einen Index und Möglichkeiten für die Volltextsuche.

Das Informationszentrum stellt eine Art von Elektronischem Buch dar, das bereits in Mathcad enthalten ist. Eine Liste von Elektronischen Büchern, die Sie zusätzlich erwerben können, erhalten Sie bei MathSoft.


Funktionspakete

ERWEITERUNGSPAKETE (nur für Mathcad Professional)

Die Erweiterungspakete von Mathcad sind, wie die Elektronischen Bücher, eine Sammlung von mehreren Hundert mit Hyperlinks versehenen interaktiven Mathcad-Arbeitsblättern. Im Gegensatz zu einem Elektronischen Buch fügt das Erweiterungspaket Mathcad zusätzliche Funktionen hinzu. So wird Mathcad z. B. mit dem Erweiterungspaket für Signalverarbeitung um Funktionen für das Anlegen von digitalen Filtern erweitert. Für Erweiterungspakete ist Mathcad Professional erforderlich.


QuickSheets

Quicksheets sind Mathcad-Arbeitsblätter, die eine Vielzahl von Berechnungen demonstrieren. Um ein Quicksheet zu öffnen, wählen Sie den Befehl Informationszentrum im Menü Hilfe, und klicken Sie auf "Quicksheets". Sie können die Quicksheets nach einer bestimmten Funktion oder einem bestimmten Operator durchsuchen lassen. Dazu steht Ihnen die Schaltfläche "Suchen" in der Symbolleiste am oberen Rand des Fensters zur Verfügung.


"Rkadapt" für sich langsam ändernde Lösungen

Wenn sich die Lösung nicht schnell ändert, kann Rkadapt die Schrittweite anpassen, damit keine Verarbeitungszeit verlorengeht.


Steife Systeme

Ein System ist steif, wenn es in folgender Form ausgedrückt ist:

y=A x

Die Matrix A ist beinahe singulär.

Unter diesen Bedingungen oszilliert rkfest unter Umständen oder ist instabil.


Bulirsch-Stoer-Algorithmus

Wenn ein System keine Unstetigkeiten in seiner Lösung hat, ist der von Bulstoer verwendete Bulirsch-Stoer-Algorithmus etwas genauer als rkfest.


Differentialgleichung erster Ordnung

Eine Differentialgleichung erster Ordnung ist eine Gleichung, bei der die Ableitung höchster Ordnung der unbekannten Funktion die erste Ableitung ist.


Gewöhnliche Differentialgleichung

Eine gewöhnliche Differentialgleichung ist eine Differentialgleichung, in der die Unbekannte eine Funktion einer Variable ist.


Partielle Differentialgleichung

Eine partielle Differentialgleichung ist eine Differentialgleichung, in der die Unbekannte eine Funktion von zwei oder mehreren Variablen ist.


Wahrscheinlichkeitsdichte

Gibt die Wahrscheinlichkeit an, mit der eine Zufallsvariable einen bestimmten Wert annimmt.


Kumulative Wahrscheinlichkeitsverteilung

Geben die Wahrscheinlichkeit an, mit der eine Zufallsvariable einen Wert annimmt, der kleiner gleich dem angegebenen Wert ist. Die Berechnung erfolgt durch einfaches Integrieren (bzw. Summieren, wo erforderlich) der jeweiligen Wahrscheinlichkeitsdichte über einen entsprechenden Bereich.


Inverse kumulative Wahrscheinlichkeitsverteilung

Diese Funktionen haben eine Wahrscheinlichkeit als Argument und geben einen Wert zurück, der angibt, daß die Wahrscheinlichkeit, mit der eine Zufallsvariable kleiner gleich diesem Wert ist, der als Argument angegebenen Wahrscheinlichkeit entspricht.


Rekursivwert

Muß eine ganze Zahl zwischen 1 und 2147483647 sein.

Mit jedem Rekursivwert erhalten Sie eine andere Folge aus gleichmäßig verteilten Zufallszahlen.


Cursor (Bild)

Cursor sehen folgendermaßen aus:

Im Gegensatz zu Zeigern reagieren Cursor auf die Pfeiltasten. Cursor werden zur Eingabe verwendet. Sie können einen Cursor mit Zeigern an verschiedenen Stellen positionieren.


Zeiger (Bild)

Zeiger sehen folgendermaßen aus:

Anders als Cursor werden Zeiger mit der Maus bewegt. Sie können viele unterschiedliche Formen annehmen. Die häufigste ist:

Mit diesem Pfeilzeiger setzen Sie den Cursor an neue Positionen.


Pfeilzeiger

Wenn der Mauszeiger als Pfeil dargestellt wird, bewirkt ein Mausklick folgendes:

Sobald sie in einen Leerraum klicken, wird ein Fadenkreuz an die betreffende Stelle gesetzt.

Wenn Sie in Text klicken, wird eine Einfügemarke in den Text gesetzt.

Wenn Sie in einen Rechenbereich klicken, wird ein Bearbeitungslinienpaar eingefügt.


Buchzeiger

Wenn der Zeiger so aussieht, haben Sie Informationen aus einem Elektronischen Buch kopiert. Folgendes geschieht, wenn Sie doppelklicken, während der Zeiger diese Form hat:

Die kopierten Daten werden an der Stelle eingefügt, auf die der Zeiger zeigt.

Der Buchzeiger wird wieder durch den Standard-Pfeilzeiger ersetzt.


Handzeiger

KLEINER HANDZEIGER

Wenn der Handzeiger sichtbar ist, können Sie die Bereiche, die Sie markiert haben, mit der Maus an eine andere Stelle im Arbeitsblatt ziehen. Folgendermaßen erhalten Sie diesen Zeiger:

Wählen Sie einen oder mehrere Bereiche aus.

Setzen Sie den Pfeilzeiger an den Rand eines ausgewählten Bereiches. Dadurch wird der Pfeilzeiger als Hand angezeigt.

Wenn Sie nun das Handsymbol ziehen, verschieben sich die ausgewählten Bereiche mit.


Kästchenzeiger

Wenn der Zeiger so aussieht, können Sie einen ausgewählten mathematischen Ausdruck an eine neue Stelle kopieren. Folgendermaßen erhalten Sie diesen Zeiger:

Klicken Sie auf einen Ausdruck.

Halten Sie die Strg-Taste und die Maustaste gedrückt.

Ziehen Sie den Zeiger in einen leeren Bereich oder auf einen Platzhalter, und lassen Sie die Maustaste los, damit der ausgewählte Ausdruck abgelegt wird.


Doppelpfeilzeiger

Wenn der Mauszeiger als Doppelpfeil dargestellt wird, können Sie die Größe oder Form des Bereichs ändern, der gerade ausgewählt ist. Folgendermaßen erhalten Sie diesen Zeiger:

Wählen Sie einen Bereich aus.

Setzen Sie den Mauszeiger auf einen der drei Haltepunkte am Rand des Bereichs.

Wenn Sie nun die Maus verschieben, sehen Sie, wie sich die Größe des ausgewählten Bereichs ändert.


Cursor in leeren Bereichen

Der Fadenkreuz-Cursor kann nur außerhalb eines mathematischen Bereichs oder Textbereichs angezeigt werden.

Dies ist der einzige Cursor, der sich auf einer leeren Stelle in Ihrem Dokument befinden kann.


Klicken Sie auf eine leere Stelle.

Klicken Sie auf eine leere Stelle in Ihrem Dokument.


Mcaduntitled00000345

Klicken Sie auf eine andere leere Stelle, oder verwenden Sie die Richtungstasten zum Verschieben in die entsprechende Richtung. Mit Bild-nach-oben und Bild-nach-unten können Sie ihn in 80% der Fensterhöhe nach oben oder unten versetzen.


Klicken auf einen mathematischen Bereich, Fadenkreuz

Der als nächstes eingegebene Rechen- oder Textbereich beginnt an der Position des Fadenkreuzes.

Wenn Sie mit der Eingabe beginnen, wird der Cursor als Paar von Bearbeitungslinien oder als Texteinfügemarke angezeigt.


Anzeigen der Texteinfügemarke

Die Texteinfügemarke kann nur in einem Textbereich angezeigt werden.


Zum Einfügen von Text gehen Sie vor wie folgt:

Beginnen Sie mit einem Fadenkreuz-Cursor, und wählen Sie Textbereich im Menü Einfügen.


Verschieben der Texteinfügemarke

Folgendermaßen können Sie die Texteinfügemarke verschieben:

Mit den Richtungstasten

Durch Klicken in den Text


Mcaduntitled00000351

Sie können mit der Einfügemarke Zeichen ebenso einfügen und löschen wie in den gängigen Textverarbeitungsprogrammen.

Das als nächstes eingegebene Zeichen wird an der Einfügemarke angezeigt. Durch Drücken der Rück- oder der ENTF-Taste wird das Zeichen links bzw. rechts von der Einfügemarke gelöscht.


Mcaduntitled00000353

Bearbeitungslinien können nur in einem mathematischen Ausdruck angezeigt werden.


Mcaduntitled00000354

Klicken Sie auf eine beliebige Stelle in einem mathematischen Ausdruck.


Mcaduntitled00000355

STEUERN DER BEARBEITUNGSLINIEN

Mit den Pfeiltasten können Sie die Bearbeitungslinien in die vom Pfeil angezeigte Richtung verschieben.

Zum Verändern der Elemente zwischen den Bearbeitungslinien gehen Sie folgendermaßen vor:

Drücken Sie die Leertaste, um die verschiedenen Teile des Ausdrucks durchzugehen, die entsprechend ihrer aktuellen Position zwischen die Bearbeitungslinien gesetzt werden könnten.

Wenn Sie alle Teile des Ausdrucks durchgegangen sind, ohne daß der rechte Teil des Ausdrucks markiert werden konnte, klicken Sie auf einen Namen oder eine Ziffer an einer anderen Stelle im Ausdruck, und versuchen Sie es erneut. Durch jede neue Anfangsposition für die Bearbeitungslinien entsteht ein vollständiger neuer Ablauf, in dessen Übergangsstadien unterschiedliche Teile des Ausdrucks eingeschlossen werden.


Mcaduntitled00000356

Mit den Bearbeitungslinien wählen Sie Teile des mathematischen Ausdrucks aus. Wenn Sie einen Teil eines Ausdrucks zwischen die Bearbeitungslinien setzen, ist dies mit dem Einfassen in unsichtbare Klammern zu vergleichen.


VERWENDEN DER LEERTASTE

Mit der Leertaste können Sie verschiedene Teile eines mathematischen Ausdrucks auswählen. Was Sie auswählen, hängt davon ab, wo sich die Bearbeitungslinien anfangs befinden. Beispiel:


Mcaduntitled00000361

Sie können anzeigen lassen, welche Schritte aus welchen Gründen mit dem Ausdruck durchgeführt werden, indem Sie unten auf die entsprechenden Schaltflächen klicken.


Mcaduntitled00000362

Durch Drücken der Pfeil-nach-oben-Taste werden die Bearbeitungslinien nach oben versetzt.


Mcaduntitled00000363

Da die Bearbeitungslinien nicht weiter nach unten versetzt werden können, werden sie aus dem Ausdruck herausverschoben und unter dem Ausdruck als Fadenkreuz angezeigt.


Mcaduntitled00000364

Die Einfügelinie wird zum Element auf der rechten Seite verschoben.


Mcaduntitled00000366

Hiermit wird gelöscht, was sich unmittelbar rechts neben der Einfügelinie befindet. In diesem Fall wird der Exponent-Operator gelöscht.


Mcaduntitled00000367

Hiermit wird gelöscht, was sich unmittelbar links neben der Einfügelinie befindet, in diesem Fall die Variable "b". Das schwarze Rechteck ist ein Platzhalter, durch den angezeigt wird, wo Sie eine Eingabe vornehmen müssen, damit die Exponentialberechnung korrekt durchgeführt werden kann.


Mcaduntitled00000368

Durch Drücken der Leertaste verlängern Sie die Bearbeitungslinien, so daß ein größerer Teil des Ausdrucks zwischen sie paßt.


Mcaduntitled00000369

Durch Drücken der EINFG-Taste wird die Einfügelinie ganz auf die andere Seite verschoben. Mit der EINFG-Taste versetzen Sie die Einfügelinie jeweils von einer Seite auf die andere.


Mcaduntitled00000370

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten Operator Ihrer Eingabe.

In diesem Beispiel haben Sie den Operator "plus" eingegeben. Zwischen den Bearbeitungslinien befand sich das "b". Daher wurde das "b" der erste Operand von "plus".


Mcaduntitled00000371

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten Operator Ihrer Eingabe.

In diesem Beispiel ist der Operator "Quadratwurzel", und zwischen den Bearbeitungslinien befand sich das "b". Daher wurde das "b" in die Quadratwurzel aufgenommen.


Mcaduntitled00000372

Sie können anzeigen lassen, welche Schritte aus welchen Gründen mit dem Ausdruck durchgeführt werden, indem Sie unten auf die entsprechenden Schaltflächen klicken.


Mcaduntitled00000373

Durch Drücken der Pfeil-nach-oben-Taste werden die Bearbeitungslinien nach oben versetzt.


Mcaduntitled00000374

Da die Bearbeitungslinien nicht weiter nach unten versetzt werden können, werden sie aus dem Ausdruck herausverschoben und unter dem Ausdruck als Fadenkreuz angezeigt.


Mcaduntitled00000375

Da rechts von der Einfügelinie keine Elemente vorhanden sind, werden die Bearbeitungslinien durch Drücken der Pfeil-nach-rechts-Taste vollständig aus dem Ausdruck herausverschoben. Die Bearbeitungslinien werden rechts neben dem Ausdruck als Fadenkreuz angezeigt.


Mcaduntitled00000376

Da sich das "c" direkt links neben der Einfügelinie befindet, wird von den Bearbeitungslinien durch Drücken der Pfeil-nach-links-Taste nur das "c" ausgewählt.


Mcaduntitled00000377

Durch Drücken der ENTF-Taste wird gelöscht, was sich rechts neben der Einfügelinie befindet. Da dort nichts vorhanden ist, hat das Drücken der ENTF-Taste keine Wirkung.


Mcaduntitled00000378

Mit der Rücktaste wird normalerweise gelöscht, was sich links von der Einfügelinie befindet. Wenn der zu löschende Ausdruck komplizierter ist als ein Name oder eine Zahl, wird er durch Drücken der Rücktaste jedoch wie gezeigt markiert. Wenn Sie die Rücktaste dann erneut drücken, wird er gelöscht. Dadurch ist unbeabsichtigtes Löschen eines Ausdrucks nahezu ausgeschlossen.


Mcaduntitled00000379

Durch Drücken der Leertaste werden die Bearbeitungslinien so weit verlängert, daß sie nun den gesamten Nenner einschließen.


Mcaduntitled00000380

Die EINFG-Taste versetzt die Einfügemarke auf die andere Seite. Durch diese Taste wird die Einfügelinie jeweils von einer Seite auf die andere versetzt.


Mcaduntitled00000381

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten Operator Ihrer Eingabe.

In diesem Beispiel ist der Operator "plus", und die Einfügemarke schloß den gesamten Ausdruck "b zu c" ein. Deshalb wurde der ganze Ausdruck "b zu c" der erste Operand des "plus".


Mcaduntitled00000383

Sie können anzeigen lassen, welche Schritte aus welchen Gründen mit dem Ausdruck durchgeführt werden, indem Sie unten auf die entsprechenden Schaltflächen klicken.


Mcaduntitled00000384

Durch Drücken der Pfeil-nach-oben-Taste wird die Einfügemarke nach oben versetzt.


Mcaduntitled00000386

Da rechts neben der Einfügemarke nichts vorhanden ist, wird die Einfügemarke durch Drücken der Pfeil-nach-rechts-Taste ganz aus dem Ausdruck herausverschoben. Die Einfügemarke nimmt die Form eines Fadenkreuzes rechts neben dem Ausdruck an.


Mcaduntitled00000388

Durch Drücken der Entf-Taste wird gelöscht, was sich rechts neben der Einfügelinie befindet. Da dort nichts vorhanden ist, hat das Drücken der Entf-Taste keine Wirkung.


Rücktaste, Funktionsweise

Mit der Rücktaste wird gelöscht, was sich links von der Einfügemarke befindet.


Leertaste, Funktionsweise

Durch Drücken der Leertaste werden die Bearbeitungslinien so verlängert, daß sie nun den nächsten größeren Ausdruck einschließen, in diesem Fall "b zu c".


Mcaduntitled00000391

Hiermit wird die Einfügelinie auf die andere Seite verschoben. Mit der Einfg-Taste versetzen Sie die Einfügelinie jeweils von einer Seite auf die andere. Da die Länge des Variablennamens nur ein Zeichen beträgt, hat dies die gleiche Wirkung wie die Pfeil-nach-links-Taste.


Zuweisen eines Operators

Allgemein gilt, daß das Zeichen zwischen den Bearbeitungslinien der erste Operator wird, den Sie eingeben.

In diesem Beispiel ist der Operator "plus", und die Einfügemarke schloß nur das "c" ein. Daher wird das "c" der erste Operand des Plus. Beachten Sie den Platzhalter, für den Sie den zweiten Operanden des Plus eingeben müssen.


Zuweisen eines Operators (eine Komponente)

Allgemein gilt, daß das Zeichen zwischen den Bearbeitungslinien der erste (und in diesem Fall einzige) Operator ist, den Sie eingeben.

In diesem Beispiel ist der Operator "Quadratwurzel".


Mcaduntitled00000394

Sie können anzeigen lassen, welche Schritte aus welchen Gründen mit dem Ausdruck durchgeführt werden, indem Sie unten auf die entsprechenden Schaltflächen klicken.


Pfeil-nach-oben-Taste in mathematischen Bereichen

Durch Drücken der Pfeil-nach-oben-Taste wird die Einfügemarke nach oben versetzt.


Pfeil-nach-unten-Taste in mathematischen Bereichen

Durch Drücken der Pfeil-nach-unten-Taste wird die Einfügemarke nach unten versetzt. Da sich die Einfügemarke so weit unten wie möglich befindet, wird sie unter dem Ausdruck als Fadenkreuz angezeigt.


Pfeil-nach-rechts-Taste am Ende von mathematischen Bereichen

Da rechts neben der Einfügemarke nichts vorhanden ist, wird die Einfügemarke durch Drücken der Pfeil-nach-rechts-Taste ganz aus dem Ausdruck herausverschoben. Die Einfügemarke nimmt die Form eines Fadenkreuzes rechts neben dem Ausdruck an.


Pfeil-nach-links-Taste am Ende von mathematischen Bereichen

Durch Drücken der Pfeil-nach-links-Taste wird die Einfügelinie um ein Zeichen nach links versetzt. Das links angrenzende Zeichen ist das "c", daher schließt die Einfügemarke nun das "c" ein.


Die ENTF-Taste ist ohne Wirkung

Durch Drücken der ENTF-Taste wird gelöscht, was sich rechts neben der Einfügelinie befindet. Da dort nichts vorhanden ist, hat das Drücken der ENTF-Taste keine Wirkung.


Drücken der Leertaste

Durch Drücken der Leertaste werden die Bearbeitungslinien so verlängert, daß sie den nächsten größeren Ausdruck einschließen. Da die Bearbeitungslinien bereits den gesamten Nenner umfassen, muß der nächste größere Ausdruck der ganze Bruch sein.


EINFG-Taste

Mit der EINFG-Taste versetzen Sie die Einfügelinie jeweils von einer Seite auf die andere. Da sich der vertikale Zweig auf der rechten Seite befand, wird er durch Drücken der EINFG-Taste nach links versetzt.


Mcaduntitled00000403

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten Operator Ihrer Eingabe.

In diesem Beispiel ist der Operator "plus", und die Einfügemarke schloß den gesamten Nenner ein. Daher wird der ganze Nenner zum ersten Operanden von "plus". Beachten Sie den Platzhalter, für den Sie den zweiten Operanden des Plus eingeben müssen.


Mcaduntitled00000404

Normalerweise wird der Inhalt zwischen den Bearbeitungslinien zum ersten (und in diesem Fall einzigen) Operator Ihrer Eingabe.

In diesem Beispiel ist der Operator die Quadratwurzel, und die Einfügemarke schloß den gesamten Nenner ein. Demzufolge wird der gesamte Nenner zum Operanden der Quadratwurzel. Daher wird er in die Quadratwurzel verschoben wie gezeigt.


Zwei Arten von Minuszeichen

Es gibt zwei Arten von Minuszeichen. Hier hat es die Funktion in einem Ausdruck wie:

"-1" oder "-(x + z)"

Die andere Funktion ist die zwischen Zahlen wie z. B.:

"(x - z)"

Sie gehen beim Löschen dieser Art von Minuszeichen ebenso vor wie beim Löschen eines Pluszeichens.


Zum Berechnen eines Ausdrucks gehen Sie vor wie folgt:

Klicken Sie in den Ausdruck, und drücken Sie =.


Mcaduntitled00000458

Wertet aus, was sich links von "=" befindet und zeigt die Antwort rechts von "=" an.


Beschränkungen links des "="

Beschränkungen links von "="

Alle links vom Gleichheitszeichen stehenden Variablen oder Funktionen müssen bereits definiert worden sein.

Wenn Sie beispielsweise "x + 1 =" eingeben, und Sie haben "x" noch nicht definiert, erhalten Sie keine Antwort. In diesem Fall wird eine entsprechende Fehlermeldung angezeigt.


Beschränkungen rechts von "="

Es ist nicht möglich, Zeichen rechts vom "=" direkt zu bearbeiten. Sie können jedoch das Format oder die Einheit ändern, in dem/der die Zahlen angezeigt werden.


Klicken und Drücken:

Klicken Sie auf eine beliebige Stelle im Ausdruck, und drücken Sie ":" (die Doppelpunkttaste).


Rechts auswerten, links zuweisen

Wertet aus, was rechts vom ":=" steht und weist das Ergebnis den Zeichen zu, die links von ":=" stehen.


Beschränkungen links von ":="

Es ist nicht möglich, eine Zahl oder einen Ausdruck links von ":=" einzufügen.

Links von ":=" muß ein einfacher Variablenname, eine tiefgestellte Variable, eine Matrix von Variablennamen oder ein Funktionsname stehen.


Beschränkungen rechts von ":="

Alle Variablen oder Funktionen rechts vom Gleichheitszeichen müssen bereits definiert worden sein.

Wenn Sie zum Beispiel "y := x + 1 =" eingeben und "x" noch nicht definiert ist, kann y keine Zahl zugewiesen werden. In diesem Fall wird eine entsprechende Fehlermeldung angezeigt.


Fehlermeldungen erscheinen, wenn Sie klicken

Eine Fehlermeldung erscheint nur dann, wenn Sie auf den fehlerhaften Ausdruck klicken.


Häufig auftretende Fehler

Da Mathcad fehlerhafte Ausdrücke nicht verarbeitet, können in Ihrem Arbeitsblatt mehrere Fehlermeldungen angezeigt werden. Wenn der beanstandete Ausdruck beispielsweise eine Definition ist, bleibt die von ihm zu definierende Variable oder Funktion undefiniert. Dies kann dazu führen, daß alle Ausdrücke, die auf diese Variable oder Funktion zurückgreifen, ebenfalls undefiniert sind.


Vorgehensweise bei Anzeige von vielen Fehlermeldungen

KORRIGIEREN VON FEHLERN

Wenn Ihr Arbeitsblatt mehrere Ausdrücke mit Fehlermeldungen enthält, gehen Sie wie folgt vor:

Ermitteln Sie, welcher der fehlerhaften Ausdrücke der erste im Arbeitsblatt ist (am weitesten oben steht). Dieser Fehler ist wahrscheinlich der Grund für viele der anderen Fehler. (Wenn eine benutzerdefinierte Funktion als fehlerhaft gekennzeichnet ist, bestimmen Sie die tatsächliche Fehlerquelle anhand der Funktionsdefinition.)

Drücken Sie Umschalt + F1, und klicken Sie auf die Fehlermeldung, um nähere Informationen zur möglichen Ursache des Fehlers zu erhalten. Eine andere Möglichkeit wäre, den Fehler in der Fehlerliste der Hilfe nachzuschlagen.

Wenn Sie den Ausdruck und den Grund herausgefunden haben, durch den der Fehler ausgelöst wurde, können Sie ihn durch Bearbeiten dieses Ausdrucks beheben. Wenn Sie in den Ausdruck klicken und mit der Bearbeitung beginnen, entfernt Mathcad die Fehlermeldung. Wenn Sie auf eine Stelle außerhalb des Ausdrucks klicken, verarbeitet Mathcad ihn neu.


Die Anzahl Zeilen und/oder Spalten stehen in Konflikt

Die Anzahl Zeilen und/oder Spalten in diesem Feld stehen in Konflikt.

Sie haben versucht, eine Vektor- oder Matrixoperation an Feldern ungeeigneter Größe auszuführen. So ist es z. B. unzulässig, zwei ungleich große Matrizen zu addieren. Matrixmultiplikation erfordert, daß die Anzahl der Spalten in der ersten Matrix mit der Anzahl der Zeilen in der zweiten Matrix übereinstimmt.


Ausdruck links kann nicht definiert werden

Der Ausdruck links von dem Gleichheitszeichen kann nicht definiert werden.

Die linke Seite dieser Definition enthält etwas anderes als einen hier gültigen Ausdruck. Auf der linken Seite einer Definition können die folgenden Elemente eingefügt werden:

Variablennamen

Variablennamen mit tiefgestelltem Index

Variablennamen mit hochgestelltem Index

Explizite Vektoren oder Matrizen, die mit Hilfe des Befehls Matrix im Menü Einfügen erstellt wurden. Der Vektor bzw. die Matrix darf nur Variablennamen oder indizierte Variablennamen enthalten.

Funktionsnamen mit Argumenten: f(x,y).

Jeder andere Ausdruck ist unzulässig. Wenn Sie ein Ergebnis berechnen möchten, anstatt eine Variable zu definieren, müssen Sie anstelle eines Doppelpunkts das Gleichheitszeichen "=" eingeben.


Tiefgestellter Index nicht möglich

Sie haben einen Index für etwas anderes als einen Vektor oder eine Matrix verwendet.


Hochgestellter Index nicht möglich

Sie haben einen hochgestellten Index für etwas anderes als einen Vektor oder eine Matrix verwendet.


Definitionsstapelüberlauf

Diese Funktionsdefinition enthält zu viele verschachtelte Funktionen.


Keine Lösung für dieses System gefunden

Keine Lösung für dieses Gleichungssystem gefunden. Versuchen Sie es mit einem anderen Schätzwert, oder überprüfen Sie, ob wirklich eine Lösung existiert.

In manchen Fällen kann eine Lösung nicht einwandfrei ermittelt werden. Dies ist der Fall, wenn der Unterschied zwischen aufeinanderfolgenden Annäherungen an die Lösung größer als TOL ist, und:

der Lösungsalgorithmus einen Punkt erreicht, an dem eine weitere Reduzierung des Fehlers nicht mehr möglich ist.

der Lösungsalgorithmus einen Punkt erreicht, von dem aus es keine bevorzugte Richtung gibt, so daß für den Lösungsalgorithmus keine Basis für weitere Iterationen besteht, oder

der Lösungsalgorithmus seine Genauigkeitsgrenze erreicht. Dies ist oft der Fall, wenn Sie für TOL einen Wert unter 10^-15 festlegen.

Stellen Sie sicher, daß eine Lösung möglich ist. Versuchen Sie dann folgendes:

Erhöhen Sie den Wert von TOL,

verwenden Sie die Funktion minfehl statt der Funktion Suchen,

verwenden Sie einen anderen Schätzwert,

fügen Sie eine Ungleichheit hinzu, um einen unerwünschten Haltepunkt zu vermeiden, bzw.

ändern Sie die Parameter des Lösungsalgorithmus oder das Lösungsverfahren.


Ausdruck mit Einheiten kann nicht mit einer komplexen Zahl potenziert werden

Ein Ausdruck mit Einheiten kann nicht mit einer komplexen Zahl potenziert werden.

Dieser Ausdruck enthält Einheiten, die mit einer komplexen Zahl potenziert worden sind. Ein Ausdruck mit Einheiten kann nur mit einer reellen Zahl potenziert werden.


Diese Funktion ist an mindestens einem Punkt nicht definiert

Diese Funktion ist an mindestens einem der von Ihnen angegebenen Punkte nicht definiert.

Sie haben versucht, einen Operator oder eine Funktion an einem ungeeigneten Wert auszuwerten. Zum Beispiel wird dieser Fehler durch ln(0) ausgegeben. Dasselbe gilt für -3!, da Fakultät für negative Zahlen nicht definiert ist.


Eine Variable kann nur einmal definiert werden...

Eine Variable kann in einem Ausdruck nur einmal definiert werden.

Sie haben versucht, dieselbe Variable zweimal in derselben Definition auszuwerten. Diese Fehlermeldung wird z. B. angezeigt, wenn Sie einen Vektor auf der linken Seite eines := erstellen und denselben Namen in mehr als einem Element verwenden.


Gleichung zu groß

Dieser Ausdruck ist zu kompliziert für die Auswertung. Lösen Sie die Gleichung in zwei oder mehr kleinere Ausdrücke auf.


Diese Zahl ist nicht verständlich.

Dieser Ausdruck enthält eine Ziffer oder ein Dezimalzeichen an einer Stelle, wo dies nicht zugelassen ist. Wenn Sie beispielsweise versehentlich ".452." eingeben, wird diese Fehlermeldung angezeigt.


Argumente in Funktionsdefinitionen müssen Namen sein.

Die markierte Funktionsdefinition enthält eine unzulässige Argumentliste. Eine gültige Funktionsdefinition beginnt wie folgt:

Funktionsname(Argumentliste) := ...

Die Argumentliste muß ein Name oder eine Liste von durch Kommas getrennten Namen sein. Jeder andere Ausdruck ist unzulässig.

Diese Fehlermeldung erscheint auch, wenn Sie eine ungültige Liste in einem anderen Zusammenhang erstellen, wie z. B. in der Liste der y-Achsenausdrücke für ein Diagramm.


Es liegt ein Fehler im Gleichungssystem vor

Es liegt ein Fehler in dem Gleichungssystem vor, mit dem diese Funktion definiert wird. Möglicherweise ist ein Schätzwert erforderlich.

Diese Fehlermeldung erscheint, wenn Sie eine Benutzerfunktion auswerten, die in Abhängigkeit von einem Gleichungssystem definiert ist, das einen Fehler enthält.

Um den Fehler zu beheben, müssen Sie das Gleichungssystem korrigieren. Wenn Sie das Gleichungssystem direkt auswerten, statt eine Funktion damit zu definieren, wird eine spezifischere Fehlermeldung angezeigt.


Datendatei nicht völlig verständlich

Datendatei nicht völlig verständlich. Stammt diese Datei aus einer Tabellenkalkulation, muß sie als reiner ASCII-Text ("Nur Text") gespeichert werden.

Die Datei, auf die Sie mit LESEN bzw. PRNLESEN zugreifen wollen, hat nicht das benötigte Format.

Die Datei muß eine ASCII-Datei sein, wobei die einzelnen Zahlen durch Leerzeichen oder Tabulatoren voneinander getrennt sein müssen.

Wenn Sie PRNLESEN verwenden, müssen alle Zeilen in der Datendatei über die gleiche Anzahl von Werten verfügen. (Zeilen ohne Werte werden ignoriert.)

Falls die Datei das erforderliche Format aufweist und diese Fehlermeldung weiterhin angezeigt wird, sollten Sie Text aus der Datei entfernen.


Datendatei wurde nicht gefunden

Die zu verwendende Datendatei wurde nicht gefunden.

Die Funktion LESEN, PRNLESEN, RGBLESEN, ANFÜGEN oder PRNANFÜGEN konnte die Datei nicht finden, die Sie als Argument für diese Funktion angegeben haben.

Stellen Sie sicher, daß das Argument als Pfadname zur Datendatei angegeben wird.


Operation kann nicht auf das ganze Datenfeld angewendet werden

Diese Operation kann nicht auf das ganze Datenfeld auf einmal angewendet werden. Versuchen Sie, mit "Vektorisieren" die Operation Element für Element auszuführen.

Sie haben eine Funktion oder einen Operator, die bzw. der einen Skalar erfordert, in diesem Ausdruck auf einen Vektor oder eine Matrix angewendet.

Diese Fehlermeldung wird z. B. angezeigt, wenn Sie versuchen, einen Vektor durch einen anderen zu dividieren.

Wenn Sie eine Funktion oder einen Operator allen Elementen in einem Vektor oder einer Matrix zuweisen möchten, verwenden Sie den Operator "Vektorisieren".


Ungültiger Kontext. Drücken Sie F1, um die Hilfe aufzurufen.

Ungültiger Kontext. Drücken Sie F1 für Hilfe.

Die häufigsten Ursachen dieser Fehlermeldung sind:

Sie haben ein Semikolon an einer Stelle eingegeben, die keine zulässige Definition eines Bereichs ist. (Das Semikolon wird als zwei Punkte angezeigt.)

Sie haben an einer anderen Stelle als der linken Seite einer Definition die Funktion SCHREIBEN oder ANFÜGEN verwendet. Diese Funktionen dürfen nicht auf der rechten Seite einer Definition stehen.

Sie haben einen bereits vorhandenen Funktionsnamen als Variablennamen bzw. einen bereits vorhandenen Variablennamen als Funktionsnamen verwendet.

Sie haben ein [image] in einem Gleichungssystem verwendet.

Sie haben ein Arbeitsblatt geöffnet, das bestimmte Funktionen oder Merkmale enthält, die in diesem Programm nicht verfügbar sind.


In den Einheitenplatzhalter können nur reelle...

In den Einheitenplatzhalter können nur reelle Skalare ungleich Null eingegeben werden.

Sie haben einen ungültigen Ausdruck in den Platzhalter am Ende einer Berechnungsgleichung eingegeben. Dieser Platzhalter erfordert reelle Werte, Werte ungleich null oder Skalarwerte.


Name dieser Funktion ist nicht verständlich

Name dieser Funktion ist nicht verständlich. Verwenden Sie für die Multiplikation "*".

Folgender Fall ist eingetreten:

Sie haben einen Ausdruck verwendet, als wäre er eine Funktion, und

dieser Ausdruck bildet einen ungültigen Funktionsnamen.

Diese Fehlermeldung wird beispielsweise angezeigt, wenn Sie eine Zahl als Funktionsnamen verwenden: 6(x).


Geben Sie ORIGIN = ein, um zu überprüfen...

Geben Sie "ORIGIN=" ein, um zu überprüfen, welcher Wert für diesen Parameter festgelegt wurde. . . Es sollte eine ganze Zahl sein, deren Betrag geringer als 16 Millionen ist. Definieren Sie den Parameter gegebenenfalls neu.

Sie haben ORIGIN entweder als etwas anderes als eine Ganzzahl oder aber als eine ganze Zahl größer als 16.000.000 definiert.

Die Definition selbst wird nicht durch eine Fehlermeldung hervorgehoben. Sie sehen diese Fehlermeldung nur, wenn Sie versuchen, das nicht zulässige ORIGIN mit einem Vektor oder einer Matrix zu verwenden.


Definitionsweise dieser Bereichsvariablen nicht verständlich.

Sie haben eine Bereichsvariable mit einem nicht verständlichen Bereich definiert. Wenn Sie einen Bereich definieren, müssen Sie eine der folgenden Formen verwenden:

Bvar := n1 ..n2 (Eingabe: Bvar:n1;n2)

Bvar := n1,n2 ..n3 (Eingabe: Bvar:n1,n2;n3)

Die Definition eines Bereichs für eine Bereichsvariable darf höchstens 1 Komma und 1 Semikolon enthalten. Wenn Sie die zweite Form benutzen, muß der Wert von n2 zwischen den Werten von n1 und n3 liegen, darf aber nicht gleich n1 sein.


Geben Sie TOL= ein, um

Geben Sie "TOL=" ein, um die Toleranz zu überprüfen. . . Sie sollte größer als 0 und kleiner oder gleich 1 sein. Definieren Sie den Parameter gegebenenfalls neu.

Die vordefinierte Konstante TOL liegt außerhalb des zulässigen Bereichs.

Beheben Sie den Fehler, indem Sie für TOL einen Wert, der

größer als (aber nicht gleich) 0 und...

kleiner oder gleich 1 ist,

über dem angegebenen Ausdruck definieren.


Die Einheiten dieses Ausdrucks stehen in Konflikt zueinander.

Diese Fehlermeldung hat zwei wahrscheinliche Ursachen:

Sie addieren bzw. subtrahieren zwei Terme mit unterschiedlichen Einheiten.

Sie haben eine Matrix erstellt, deren Einheiten nicht alle über dieselben Einheiten verfügen.

Sie versuchen, ein Gleichungssystem nach unbekannten Variablen mit unterschiedlichen Einheiten aufzulösen. Hier ein Beispiel mit der korrekten Vorgehensweise:


Nicht bestimmbar, welche Einheiten das Ergebnis...

Nicht bestimmbar, welche Einheiten das Ergebnis dieser Operation haben soll.

Sie haben einen Ausdruck mit Einheiten mit einem Element potenziert, das eine Bereichsvariable oder einen Vektor enthält. Daher haben Sie keine Möglichkeit, die Dimensionen des Ergebnisses zu bestimmen. Wenn ein Ausdruck mit Einheiten definiert ist, kann er nur mit einer festen reellen Zahl potenziert werden.


Wert des tief- bzw. hochgestellten Index zu groß oder zu klein...

Wert des tief- bzw. hochgestellten Index zu groß (oder zu klein) für dieses Feld.

Bei diesem Ausdruck wird ein tiefgestellter oder hochgestellter Index verwendet, der sich auf ein nicht vorhandenes Feldelement bezieht.

Der tiefgestellte oder hochgestellte Index sollte nicht kleiner sein als der ORIGIN. Geben Sie "ORIGIN=" ein, damit angezeigt wird, wie ORIGIN festgelegt ist.


Auswertung einer Ableitung n-ter Ordnung nur möglich,...

Auswertung einer Ableitung n-ter Ordnung nur möglich, wenn n=0,1..5.

Die Ordnung ist nicht eine der folgenden Zahlen: 0,1,2...5. Wenn Sie eine höhere Ordnung auswerten möchten, tun Sie dies symbolisch .


Sie haben einen Rechenvorgang unterbrochen. Um fortzufahren,...

Sie haben einen Rechenvorgang unterbrochen. Um fortzufahren, klicken Sie hier, und wählen Sie den Befehl "Berechnen" im Menü "Rechnen".

Sie haben zum Stoppen einer Berechnung [Esc] gedrückt. Sie können die markierte Gleichung neu berechnen, indem Sie den Cursor in die Gleichung setzen und Berechnen im Menü Rechnen wählen.

Wenn Sie feststellen, daß Sie häufig die Berechnungen unterbrechen, um nicht jedesmal warten zu müssen, bis Mathcad die Berechnung des Arbeitsblatts beendet hat, empfiehlt es sich, in den manuellen Modus zu wechseln.


Liste zu lang

Sie haben zu viele durch Kommas getrennte Elemente in eine Liste eingegeben. Dies passiert normalerweise, wenn Sie versuchen, zu viele Ausdrücke auf einer Diagrammachse anzuordnen.


Ausdruck enthält ein überflüssiges Komma

Dieser Ausdruck enthält ein überflüssiges Komma.

Kommas können benutzt werden, um folgendes zu trennen:

Die Argumente einer Funktion.

Die ersten beiden Elemente eines Bereichs in der Definition einer Bereichsvariable.

Ausdrücke in einem Diagramm.

Elemente in einer Eingabetabelle.

Tiefgestellte Indizes in einer Matrix.

Jede andere Verwendung von Kommas löst diese Fehlermeldung aus. Zum Beispiel dürfen Zahlen weder durch Punkte noch durch Kommas unterteilt werden (wie im englischen Sprachgebrauch üblich). Geben Sie also statt 4.000 oder 4,000 für die Zahl Viertausend einfach 4000 ein.


Dieser Ausdruck ist nicht vollständig...

Dieser Ausdruck ist nicht vollständig. Sie müssen die Platzhalter ausfüllen.

Sie haben die markierten Platzhalter nicht ausgefüllt. Sie müssen Zahlen oder Ausdrücke in diese Platzhalter eingeben.


Operator fehlt

In diesem Ausdruck fehlt ein Operator an der markierten Position.


Das Vektorprodukt ist nur für Vektoren mit genau drei Elementen definiert.

Das Vektorprodukt ist nur für Vektoren mit drei Elementen definiert.


Dieses Feld muß mehr als eine Zeile bzw. Spalte haben.

Sie haben eine Operation ausgeführt, die eine Matrix erfordert. So muß z. B. beim Erstellen von Flächen- oder Umrißdiagrammen das dargestellte Feld eine Matrix sein, d. h. ein Feld mit mindestens zwei Zeilen oder Spalten. Bestimmte vordefinierte Funktionen erfordern ebenfalls Matrixargumente.


Diese Operation kann nur für ein Datenfeld ausgeführt werden

Diese Operation kann nur für ein Datenfeld ausgeführt werden, nicht für eine Zahl.

Sie haben eine Operation, die ein Feld erfordert, auf einen Skalar angewendet. Diese Fehlermeldung wird z. B. angezeigt, wenn Sie eine hochgestellte Variable als Skalar definieren. Da eine hochgestellte Variable eine Spalte einer Matrix darstellt, müssen Sie sie als Vektor definieren.

Bei Flächen- oder Umrißdiagrammen muß das dargestellte Feld mindestens zwei Zeilen oder zwei Spalten haben.


Keine Eingabe mit Einheiten oder Dimensionen zulässig.

In diesem Ausdruck werden dort Einheiten verwendet, wo Einheiten nicht zulässig sind.

Einheiten sind nicht zulässig in:

den Argumenten der meisten Funktionen,

in Exponenten und

in hoch- und tiefgestellten Indizes.


Muß aufsteigend sein

Die Werte in diesem Vektor müssen aufsteigend angeordnet sein. Geben Sie den Namen des Vektors ein, und drücken Sie "=", um zu überprüfen, welche Werte im Vektor enthalten sind.

Das erste Argument von lspline, pspline, kspline, linterp und hist sowie das zweite Argument von interp muß ein Vektor sein, dessen Elemente durchgehend aufsteigend geordnet sind.


Dies muß eine ganze Zahl sein.

Dieser Ausdruck enthält einen nicht ganzzahligen Ausdruck, obwohl eine ganze Zahl benötigt wird. Der Ausdruck beinhaltet u. U. einen Bruch.

Mögliche Fehlerursachen sind:

Hoch- und tiefgestellte Indizes

Argumente bestimmter Funktionen, wie z. B. der Funktion einheit oder der Funktion submatrix.

Zu beachten ist, daß Sie zwar Bereichsvariablen mit Bruchwerten definieren, diese aber nicht als tief- oder hochgestellte Indizes verwenden können.


Diese Funktion kann nicht ausgewertet werden, wenn ihr Argument Null ist.

Diese Funktion ist bei Null nicht definiert.


Es können nur positive Werte in Diagrammen dargestellt werden, wenn logarithmische Achsen verwendet werden.

Dieses xy- bzw. Kreisdiagramm hat eine logarithmische Achse, in der entweder die Begrenzungen oder einige der Werte nicht positiv sind.

Negative Zahlen und Null können nirgendwo auf eine logarithmische Achse gesetzt werden.


Diese Variable muß eine Bereichsvariable sein.

Dieser Ausdruck erfordert eine Bereichsvariable.

Wenn der Ausdruck eine Summation oder ein iteriertes Produkt enthält, stellen Sie sicher, daß der Index wirklich eine Bereichsvariable ist. Der Index steht unmittelbar unter dem Sigma bzw. Pi und müßte in einer vorherigen Anweisung definiert worden sein.


Dieser Wert muß reell sein

Dieser Wert muß reell sein. Der Imaginärteil muß Null sein.

Dieser Ausdruck enthält einen imaginär- oder komplexwertigen Ausdruck, der an dieser Stelle nicht zulässig ist.

Beispiele dafür sind Indizes, Lösungsalgorithmen für Differentialgleichungen in Mathcad Professional, mod und winkel.


Muß quadratisch sein

Diese Fehlermeldung betrifft eine nicht-quadratische Matrix in einer Operation oder Funktion, die eine quadratische Matrix erfordert. Beispiele sind Determinanten, Inversen, Potenzierungen sowie die Funktionen eigenwerte und eigenvek.


Dieser Wert muß ein Vektor sein

Dieser Wert muß ein Vektor sein. Er kann weder eine Matrix noch ein Skalar sein.

Diese Fehlermeldung betrifft eine Matrix oder einen Skalar in einer Operation, die einen Vektor (ein Feld mit einer Spalte) erfordert. Ein Beispiel ist der Operator Summe der Vektorelemente.


Es befindet sich ein Gleichungssystem innerhalb eines anderen

Es befindet sich ein Gleichungssystem innerhalb eines anderen. Für jede "Vorgabe" muß es eine entsprechende Funktion "Suchen" oder "Minfehl" geben.

Sie haben zwei "Vorgaben" hintereinander ohne eine Funktion "Suchen" oder "Minfehl" dazwischen festgelegt. Ein Gleichungssystem kann nicht ein anderes beinhalten.

Sie haben auch die Möglichkeit, eine Funktion als Gleichungssystem zu definieren und in einem anderen Gleichungssystem zu verwenden. In vielen Fällen bleibt die Wirkung gleich.


"Suchen" und "Minfehl" muß eine Vorgabe vorausgehen.

"Suchen" und "Minfehl" muß jeweils eine entsprechende "Vorgabe" vorausgehen.

Mit dieser Fehlermeldung werden die Funktionen Suchen und Minfehl versehen, wenn ihnen keine entsprechende "Vorgabe" vorausgeht. Jedes Gleichungssystem, das mit Suchen oder Minfehl endet, muß mit einem Bereich beginnen, der nur den Namen "Vorgabe" enthält.


Dies ist kein Skalar. Drücken Sie F1, um die Hilfe aufzurufen.

Sie haben einen Vektor oder einen Ausdruck mit einem Bereich bzw. einen anderen Ausdruck verwendet, für den ein Skalar erforderlich ist.

Diese Fehlermeldung wird z. B. angezeigt, wenn i eine Bereichsvariable ist und Sie versuchen, eine Gleichung wie x := i einzugeben. Sie können eine Bereichsvariable nicht in Abhängigkeit von einer anderen definieren.

Diese Meldung wird auch angezeigt, wenn Sie versuchen, einen Skalar als Bereichsvariable zu definieren. Wenn Sie eine neue Variable als Bereichsvariable definieren möchten, müssen Sie die Bereichsvariable auf der linken Seite der Definition als tiefgestellten Index verwenden:

Wenn Sie eine neue Variable als tiefgestellte Variable definieren möchten, verwenden Sie auch den tiefgestellten Index auf der linken Seite der Definition:


Dies muß der Name einer Funktion bzw. Variable sein.

Sie haben eine Zahl oder eine andere Kombination von Symbolen verwendet, wo ein Name erforderlich gewesen wäre, zum Beispiel als zweites Argument der wurzel-Funktion.


Keine Konvergenz gegen eine Lösung

Keine Konvergenz gegen eine Lösung. Die Integrandfunktion weist möglicherweise eine Singularität auf, oder das Integral ist unendlich.

Ergebnisse mit Integralen, Ableitungen und den Funktionen wurzel, suchen oder minfehl erfordern Wiederholung. Falls nach vielen Wiederholungen aufeinanderfolgende Schätzungen weiterhin um mehr als die erforderliche Toleranz abweichen, wird diese Fehlermeldung angezeigt.

Versuchen Sie, eine größere TOL festzulegen. Wenn Sie mit den Funktionen wurzel, suchen und minfehl arbeiten, können Sie es auch mit einem anderen Schätzwert versuchen.


Nicht genügend Speicher

Nicht genügend Speicher für diese Operation.

Es ist nicht ausreichend Arbeitsspeicher für diese Berechnung verfügbar. Versuchen Sie, etwas Speicherplatz zu schaffen, indem Sie das Feld oder die Matrix verkleinern (Mathcad belegt etwa 8 Byte Speicherplatz pro Matrixelement) oder große Bitmaps, Felder oder Matrizen löschen. Wenn Sie mit Windows 3.x arbeiten, können Sie auch versuchen, den von Windows verwendeten virtuellen Speicher zu erweitern.


Muß 1 mehrdimensionales Feld sein.

Sie haben mehrere Felder in den Platzhalter eines Umriß- oder Flächendiagramms eingegeben. In diesem Platzhalter ist jeweils nur ein Feld möglich, weil Umriß- und Flächendiagramme jeweils nur eine einzelne Fläche darstellen können.


Zahl mit einem Betrag größer als...

Zahl mit einem Betrag größer als 10^307 bei Auswertung dieses Ausdrucks gefunden.

Aufgrund von Beschränkungen bei der Darstellung von Zahlen in einem Computer können zu große Zahlen nicht dargestellt werden. Wenn ein Ausdruck eine solche Zahl enthält, wird diese Fehlermeldung angezeigt.

Speziell in komplizierten Berechnungen können Zwischenergebnisse für die Darstellung zu groß sein.


Auswertung bei einem oder mehreren...

Auswertung bei einem oder mehreren von Ihnen angegebenen Werten nicht möglich.

Diese Fehlermeldung besagt, daß Sie versucht haben, eine Funktion für einen Wert zu berechnen, der über den Genauigkeitsbereich der Funktion hinausgeht.

Eine solche Meldung wird z. B. angezeigt, wenn Sie versuchen, sin(10^100) auszuwerten. Da sich der Wert von sin(10^100) nach der Einerstelle von 10^100 richtet, hätte ein von Mathcad zurückgegebener Wert keine signifikanten Stellen. Anstelle eines sehr ungenauen Wertes wird eine solche Fehlermeldung angezeigt.


Singularität festgestellt

Singularität bei Auswertung dieses Ausdrucks festgestellt. Möglicherweise dividieren Sie durch Null.

Die Auswertung einer Funktion bzw. die Ausführung einer Operation erfolgte bei einem unzulässigen Wert. Diese Fehlermeldung wird z. B. angezeigt, wenn Sie durch Null dividieren oder versuchen, eine singuläre Matrix umzukehren.


Stapelüberlauf

Diese Fehlermeldung wird normalerweise angezeigt, wenn Sie versuchen, eine durch sich selbst definierte Funktion zu definieren. Dies ergibt eine rekursive Funktionsdefinition ohne Abschlußbedingung. Sie können diesen Fehler vermeiden, indem Sie einen neuen Funktionsnamen verwenden. Zum Beispiel ergibt "f(x):=f(x) + 5" den Fehler "Stapelüberlauf", kann aber in f2(x):=f(x)+2 geändert werden.

Generell sollte auf beiden Seiten eines ":=" nur dann derselbe Funktionsname verwendet werden, wenn die Funktion rekursiv definiert werden soll.


Dieser tiefgestellte Index ist zu groß.

Sie haben versucht, einen tief- oder hochgestellten Index zu verwenden, dessen Größe über der Obergrenze von 8 Millionen liegt.


Nur symbolischer Operator.

Sie haben versucht, einen Ausdruck numerisch auszuwerten, der symbolisch ausgewertet werden muß. Wenn Sie mit Operatoren wie "Unbestimmtes Integral" und "Grenzwert" arbeiten, müssen Sie den Ausdruck auswählen und Vereinfachen im Menü Rechnen wählen.


Diese Funktion benötigt mehr Argumente.

Dieser Ausdruck enthält eine Funktion mit weniger als der erforderlichen Anzahl von Argumenten.

Bei vordefinierten Funktionen drücken Sie Umschalt+F1, und klicken Sie auf den Funktionsnamen, um die richtige Anzahl und Art der Argumente einzusehen. Bei von Ihnen selbst definierten Funktionen müssen Sie die Definition überprüfen.


Dieses Gleichungssystem weist mehr...

Dieses Gleichungssystem weist mehr Unbekannte auf, als es Gleichungen gibt.

Diese Fehlermeldung erscheint bei Gleichungssystemen, bei denen die Anzahl von Bedingungen kleiner ist als die Zahl der zu lösenden Variablen. Fügen Sie "Dummy"-Bedingungen hinzu, oder verringern Sie die Anzahl der Variablen, nach denen aufgelöst werden soll.


Dieser Vektor sollte mehr Elemente haben.

Diese Fehlermeldung weist auf eine Fourier-Transformation, kubische Spline- oder lineare Interpolationsfunktion hin, die auf einen Vektor mit zu wenigen Elementen angewendet wurde.

Splines und lineare Interpolationen benötigen Vektoren mit mindestens zwei Elementen. Fourier-Transformationen und deren Inversen benötigen mindestens vier Elemente.


Zu wenige tiefgestellte Indizes

Sie haben für eine Matrix nur einen tiefgestellten Index verwendet. Zur Angabe eines Matrixelements müssen jedoch zwei Indizes verwendet werden, die durch ein Komma voneinander zu trennen sind.


Für Berechnung zu groß

Ein Ausdruck mit einem Feld konnte wegen mangelndem Speicherplatz nicht ausgewertet werden. Versuchen Sie, Speicher freizugeben, indem Sie das Feld bzw. die Matrix verkleinern oder große vorhandene Bitmaps, Felder oder Matrizen löschen.


Zu groß für Anzeige

Sie haben versucht, einen Vektor oder eine Matrix anzuzeigen, der/die zu groß für die Anzeige ist. Teilen Sie den Vektor oder die Matrix in Abschnitte auf, bevor Sie sie anzeigen.


Diese Funktion hat zu viele Argumente.

Der angezeigte Ausdruck enthält eine Funktion mit einer größeren Anzahl von Argumenten als benötigt werden.

Bei vordefinierten Funktionen drücken Sie Umschalt+F1, und klicken Sie auf den Funktionsnamen, um die richtige Anzahl und Art der Argumente einzusehen. Bei von Ihnen selbst definierten Funktionen müssen Sie die Definition überprüfen.


Ein System mit mehr als 50 Bedingungen

Ein System mit mehr als zweihundert Gleichungen kann nicht aufgelöst werden.

Sie haben in ein Gleichungssystem mehr als fünfzig Bedingungen aufgenommen.


Zu viele Indizes

Sie haben zwei oder mehr tiefgestellte Indizes für einen Vektor verwendet.


So viele Punkte können nicht dargestellt werden.

Sie haben versucht, mehr Punkte darzustellen, als in einem Diagramm möglich sind. Versuchen Sie, die Anzahl der Punkte auf maximal 150.000 zu beschränken.


Diese Variable bzw. Funktion ist oben nicht definiert

Diese Variable bzw. Funktion ist oben nicht definiert. (Name rot markiert)

Diese Variable oder Funktion ist nicht definiert. Um sie zu definieren, geben Sie den Variablen- bzw. Funktionsnamen und dahinter einen Doppelpunkt (:) sowie einen Ausdruck oder eine Zahl zu seiner Definition ein. Definieren Sie den Variablen- oder Funktionsnamen unbedingt oberhalb der Anweisungen, in denen Sie ihn verwenden möchten.

Die Meldung erscheint auch bei falscher Verwendung einer Variable in einer globalen Definition. Wenn Sie eine Variable auf der rechten Seite einer globalen Definition angeben, muß die Variable über der Definition, in der sie verwendet wird, global definiert worden sein. Wenn Sie eine lokal definierte Variable oder eine Variable verwenden, deren globale Definition unter der Position der Anwendung erfolgt, markiert Mathcad die Variable als nicht definiert.

HINWEIS: Die Fehlermeldung "Nicht definiert" deutet häufig darauf hin, daß eine andere Gleichung an früherer Stelle im Arbeitsblatt fehlerhaft ist. In dem Fall werden alle Ausdrücke, die den fehlerhaften Ausdruck enthalten, rot angezeigt.


Unterlauf

Aufgrund der Beschränkungen der Darstellung von Zahlen in einem Computer können zu kleine Zahlen nicht wiedergegeben werden. Wenn ein Ausdruck eine solche Zahl enthält, wird diese Fehlermeldung angezeigt.

Speziell in komplizierten Berechnungen können Zwischenergebnisse zu klein für die Darstellung sein.


Dieser Ausdruck enthält nur eine "(", aber keine ")".

Dieser Ausdruck enthält nicht dieselbe Anzahl von ( und ).


Dieser Vektor hat die falsche Anzahl Elemente.

Diese Fehlermeldung betrifft eine Fourier-Transformation, deren Argument die falsche Anzahl von Elementen enthält.

fft benötigt einen Vektor mit 2^n Elementen.

ifft benötigt einen Argumentvektor mit 2^n+1 Elementen, wobei n eine ganze Zahl größer als 0 ist.

Verwenden Sie cfft und icfft für Felder und Vektoren beliebiger Größe.


Dateiende

Sie haben versucht, mehr Datenwerte aus einer Datendatei abzulesen, als Werte in dieser Datei enthalten sind. Nehmen wir an, die Datei enthält zehn Zahlen, und Sie geben folgendes ein:

i:1;100

x[i:LESEN(datei)

Es wird diese Meldung angezeigt.


In einem Gleichungssystem kann keine Bereichsvariable verwendet werden.

Diese Meldung wird angezeigt, wenn Sie eine Bereichsvariable an falscher Stelle verwenden, zum Beispiel in einem Gleichungssystem.

Wenn Sie Iterationen mit einem Gleichungssystem ausführen wollen, sollten Sie versuchen, die Funktion in Abhängigkeit von dem Gleichungssystem zu definieren und diese Funktion zur Iteration zu verwenden.


SmartMath nicht verfügbar.

Der nach rechts gerichtete Pfeil ist ein "symbolisches Gleichheitszeichen" und wird bei der symbolischen Auswertung von Ausdrücken ähnlich verwendet wie bei der numerischen Auswertung mit "=".

In dieser Version der Software ist die symbolische Auswertung nicht verfügbar.


":=" nicht zulässig in einem Gleichungssystem

":=" nicht zulässig in einem Gleichungssystem. Verwenden Sie statt dessen die Schaltfläche "=" in der Symbolleiste "Ungleichheit".

Ein Gleichungssystem darf keine Zuordnungsanweisungen enthalten. Das Gleichungssystem sollte nur Boolesche Ausdrücke enthalten.


(Zeilen - 1) muß Potenz von 2 sein.

Diese Matrix muß 2^n Zeilen aufweisen.


Zu viele Iterationen.

Die Funktion hat bei der Suche nach einer Lösung die höchstmögliche Anzahl von Wiederholungen durchgeführt. Wenn diese Meldung bei der Verwendung der Funktion nullstellen angezeigt wird, kann der Grad des Polynoms hoch sein. Versuchen Sie, statt dessen symbolische Auflösungen für die Wurzeln vorzunehmen.


Grad des Polynoms muß zwischen 1 und 99 sein.

Der an die Funktion nullstellen weitergeleitete Vektor muß mindestens zwei und kann höchstens 99 Elemente enthalten.


Dimensionen müssen >4 sein.

Diese Matrix muß mindestens vier Zeilen und Spalten enthalten.


Endpunkte müssen sich unterscheiden.

Die Endpunkte des Intervalls, in denen die Lösung ausgewertet wird, müssen unterschiedlich sein. Diese Meldung erscheint häufig im Zusammenhang mit den Lösungsalgorithmen für Differentialgleichungen in Mathcad Professional.


Gleitkommafehler

Sie werten eine Funktion an einer Stelle aus, an der dies nicht zugelassen ist. So kann z. B. das fünfte Argument der Funktion relax in Mathcad Professional keine Nullen an den nicht zur Grenze gehörenden Positionen der Koeffizientenmatrix haben.


Ungültige Dimensionen

Diese Matrix enthält nicht die Zeilen oder Spalten, auf die Sie verweisen. Geben Sie den Namen der Matrix ein, und drücken Sie die Taste "=", um die Zahl der in der Matrix enthaltenen Zeilen und Spalten zu überprüfen.


Ungültige Bedingung

Innerhalb eines symbolischen Gleichungssystems in Mathcad Professional darf sich keine Ungleichheit befinden. Verwenden Sie ein numerisches Gleichungssystem, oder entfernen Sie die Ungleichheit.


Eingabe muß ein- oder zweidimensional sein.

Das erste Matrixargument in den Funktionen für kubische Spline-Kurven muß entweder eine oder zwei Spalten aufweisen. Für Interpolation multivariabler kubischer Spline-Kurven sind zwei Spalten erforderlich.


Ganze Zahl zu groß.

Dieser Wert ist für die Verarbeitung zu groß. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, die Umschalttaste + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Ganze Zahl zu klein.

Dieser Wert ist für die Verarbeitung zu klein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, die Umschalttaste + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Ungültiger Entwicklungspunkt

Mathcad kann den Ausdruck um den von Ihnen angegebenen Punkt nicht erweitern. Stellen Sie sicher, daß das Schlüsselwort reihe für die symbolische Reihenentwicklung in Mathcad Professional richtig verwendet wird.


Ungültiges Format

Die Argumente für diese Funktion sind möglicherweise nicht korrekt. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, die Umschalttaste + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Ungültige Matrixdimension...

Ungültige Matrixdimension. Weniger Zeilen als Spalten.

Das Argument der Funktion svd (in Mathcad Professional) muß ein m x n großes Feld sein, wobei m [image] n ist.


Loess kann nicht extrapolieren.

Sie versuchen, eine Interpolation eines Wertes durchzuführen, der größer ist als der Höchstwert im Datensatz. Sie müssen nach Werten interpolieren, die präzise zwischen Ihren Datenpunkten liegen.


Muß <= 10000 sein

Dieser Wert muß kleiner oder gleich 10000 sein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß >= 10^-16 sein

Dieser Wert muß größer oder gleich 10^-16 sein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß 1 komplexe Matrix oder 2 reelle Matrizen sein.

Beim Erstellen eines Vektorfelddiagramms geben Sie entweder eine Matrix mit komplexen Zahlen oder zwei reelle Matrizen mit der gleichen Anzahl von Zeilen und Spalten an.

Wenn Sie eine komplexe Matrix verwenden, sollte sie folgende Merkmale haben:

Die Zeilen und Spalten stehen für die x- bzw. y-Koordinaten.

Der reelle Teil eines jeden Matrixelements ist die x-Komponente des zu dieser Zeile und Spalte gehörigen Vektors.

Der imaginäre Teil eines jeden Matrixelements ist die y-Komponente des zu dieser Zeile und Spalte gehörigen Vektors.

Wenn Sie zwei aus m x n Elementen bestehende Matrizen reeller Zahlen verwenden, gilt:

Die erste Matrix sollte die x-Komponenten der Vektoren enthalten, und

die zweite Matrix sollte die y-Komponenten der Vektoren enthalten.


Muß ganze Zahl >=1 sein

Dieser Wert muß mindestens 1 betragen. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß Funktion sein.

Dieses Argument muß eine Funktion sein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß kleiner als die Anzahl der Datenpunkte sein.

Der Wert dieses Arguments muß kleiner als die Zahl der vorhandenen Datenpunkte sein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß ungerade ganze Zahl sein

Dieses Argument muß eine ungerade ganze Zahl sein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß positiv sein.

Dieser Wert muß positiv sein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß reeller Skalar sein.

Dieser Wert kann nicht komplex oder imaginär sein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß reeller Vektor sein.

Dieser Vektor kann keine komplexen oder imaginären Elemente aufweisen. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Diese Matrix muß quadratisch sein

Diese Matrix muß quadratisch sein. Sie sollte die gleiche Anzahl Zeilen wie Spalten haben.

Für einige der in Mathcad vordefinierten Funktionen sind Quadratmatrizen erforderlich. Drücken Sie Umschalt + F1, und klicken sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß weniger als 5 Faktoren haben

Muß weniger als fünf Faktoren haben.

Das erste Argument der Funktion loess in Mathcad Professional sollte eine reelle Matrix mit maximal 4 Spalten sein, in denen sich jeweils die Daten befinden, die einem bestimmten Faktor entsprechen.


Muß mehr als drei Beobachtungen haben.

Für diese Funktion ist ein Vektor mit mindestens 4 Elementen erforderlich.


Muß mehr Datenpunkte als Parameter haben.

Für die Funktion genanp muß es mehr Datenpunkte als unbekannte Parameter geben. Klicken Sie auf den Funktionsnamen im Arbeitsblatt, und drücken Sie Umschalt + F1, wenn Sie weitere Informationen über genanp benötigen.


Braucht mehr Datenpunkte als Parameter.

Bei der Funktion regress muß die Anzahl Ihrer Datenpunkte höher sein als der Grad des an die Daten anzupassenden Polynoms.


Keine Lösung gefunden.

Mathcad hat keine Lösung gefunden. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, um zu sehen, ob Sie die Funktion korrekt verwenden. Es ist jedoch möglich, daß keine Lösung vorhanden ist.


Nichtpositive bestimmte Matrix

Diese Matrix muß positiv und bestimmt sein. Dies ist dann der Fall, wenn ihre sämtlichen Eigenwerte reelle, positive Zahlen sind.


Anzahl Zeilen muß eine Potenz von 2 sein.

Diese Fehlermeldung betrifft eine Wavelet-Transformation, deren Argument die falsche Anzahl von Elementen enthält. Die Funktionen wave und iwave benötigen Vektoren mit 2^n reellen Elementen.


Wurzel nicht gefunden.

Für Ergebnisse von Lösungsalgorithmen für Differentialgleichungen wie sgrw (eine Funktion zum Ermitteln von fehlenden Anfangsbedingungen) sind Wiederholungen erforderlich. Wenn sich die Schätzungen nach vielen aufeinanderfolgenden Wiederholungen weiterhin beträchtlich unterscheiden, wird diese Fehlermeldung angezeigt. Versuchen Sie es mit anderen Schätzwerten.


Singuläre Matrix

Diese Matrix darf weder singulär noch fast singulär sein. Eine Matrix gilt als singulär, wenn ihre Determinante gleich null ist. Eine Matrix ist annähernd singulär, wenn sie eine hohe Bedingungszahl aufweist.


Ungleiche Felddimensionen

Mit dieser Meldung sind Funktionen oder Operatoren gekennzeichnet, für die zwei Matrizen erforderlich sind, deren Zahl von Zeilen und Spalten gleich ist.


Vektorelemente müssen unterschiedlich sein.

Die Elemente in diesem Vektor müssen verschieden sein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, um zu sehen, ob Sie die Funktion korrekt verwenden.


Matrixdimensionen inkompatibel.

Mit dieser Meldung werden Funktionen oder Operatoren gekennzeichnet, für die zwei Matrizen mit einer bestimmten Anzahl von Zeilen und Spalten erforderlich sind. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, um festzulegen, welche Größe die Matrizen haben müssen.


Zu viele Integrationsschritte.

Konvergieren an eine Lösung ist nicht möglich. Es wurden zu viele Integrationsschritte angetroffen.

Vom Algorithmus für diese Differentialgleichungsberechnung wurde keine Lösung gefunden. Ändern Sie Ihre Schätzwerte für die unbekannten Anfangsbedingungen. Möglicherweise ist jedoch für die von Ihnen angegebenen Grenzwerte keine Lösung vorhanden.


Diese Operation kann nur für eine Zahl oder ein Datenfeld ausgeführt werden.

Für die verwendete Funktion bzw. den verwendeten Operator ist eine einzelne Konstante, eine Matrix oder ein Vektor erforderlich.


Diese Operation kann nur für eine Funktion ausgeführt werden.

Dieses Argument muß eine Funktion sein. Drücken Sie, wenn Sie mit einer vordefinierten Funktion arbeiten, Umschalt + F1, und klicken Sie auf den Funktionsnamen, wenn Sie weitere Informationen benötigen.


Muß Zeichenfolge sein

Für die von Ihnen verwendete Funktion bzw. den Operator ist ein Zeichenfolge-Argument erforderlich.


Muß 3 Vektoren oder 1 Matrix haben

Sie müssen die Namen von drei Vektoren (durch Kommas voneinander getrennt) oder einen Namen oder eine Matrix angeben. Zum Beispiel ist dies erforderlich, wenn Sie ein Vektorfelddiagramm erstellen.


Keine Bitmaps in Arbeitsblatt gefunden.

Diese Fehlermeldung wird angezeigt, wenn Sie den Befehl Farbe / Palette optimieren aus dem Menü Format wählen. Dieser Befehl sollte nur verwendet werden, wenn Bitmaps in einem Arbeitsblatt eingebettet sind.


Alle Auswertungen ergaben einen Fehler oder ein komplexes Ergebnis.

Mathcad kann keine Punkte darstellen, weil keine reellen Werte zum Darstellen vorhanden sind. Diese Fehlermeldung kann angezeigt werden, wenn ein Fehler vorliegt oder alle Werte imaginär sind.


Warum benötigt fft reelle Zahlen?

Diese Bedingung ist erforderlich, weil das Funktionspaar fft/ifft den Umstand nutzt, daß bei reellen Daten die zweite Hälfte der Transformation einfach gleich der konjugierten ersten Hälfte ist. Mathcad ignoriert die zweite Hälfte des Ergebnisvektors und spart dadurch Zeit und Speicherplatz.


Warum benötigt fft 2^n?

Diese Bedingung ist erforderlich, weil das Funktionspaar fft/ifft einen hocheffizienten Algorithmus für die schnelle Fourier-Transformation verwendet, der 2^m Elemente benötigt.


Elemente im zurückgegebenen Vektor

Die Elemente des Vektors, die durch die Funktion fft zurückgegeben werden, entsprechen unterschiedlichen Frequenzen. Um die eigentliche Frequenz wiederherzustellen, muß die Abtastfrequenz des ursprünglichen Signals bekannt sein. Wenn v ein aus n Elementen bestehender Vektor ist, der an die Funktion fft übergeben wird, und die Abtastfrequenz f sub s ist, ist die c sub k entsprechende Frequenz:

Damit ist es unmöglich, Frequenzen oberhalb der Abtastfrequenz zu entdecken. Diese Einschränkung ist nicht auf Mathcad zurückzuführen, sie ist vielmehr ein mathematisches Problem. Um ein Signal von der Fourier-Transformation der entsprechenden Abtastproben wiederherzustellen, muß das Signal daher mit einer Frequenz abgetastet werden, die mindestens dessen doppelter Bandbreite entspricht.


Vektorargument für FFT

v ist ein Vektor mit [image] Elementen (m>2), die alle reell sind.

Für Vektoren, die diese Kriterien nicht erfüllen, können Sie statt dessen CFFT verwenden.


Vektor u

u ist ein Vektor mit [image] Elementen, wobei m>2 ist.


Matrix A für fft

A ist ein Vektor oder eine Matrix einer beliebigen Größe. Die Funktion wird aber schneller ausgeführt, wenn die Anzahl der Elemente des Vektors 2^m ist. Bei Vektoren, deren Länge eine große Primzahl ist, arbeitet der Algorithmus für die Fourier-Transformation nicht so schnell.


B ist ein Vektor oder eine Matrix.


Leistungsspektrum

Frequenzverteilung der Leistung. Diese wird mit der folgenden Gleichung berechnet:


Phasenspektrum

Frequenzverteilung der Phase. Diese wird mit der folgenden Gleichung berechnet:


Formatvorlagenschaltfläche auf der Symbolleiste

FORMATVORLAGE

Wenn sich der Cursor in einem Rechenbereich befindet, also zwischen Zahlen oder Variablen, wird in diesem Fenster die Gleichungsformatvorlage für diesen Rechenbereich angezeigt. Bei der Rechenformatvorlage handelt es sich um eine mathematische Variable, eine mathematische Konstante oder eine von Ihnen definierte Rechenformatvorlage.

Wenn sich der Cursor in einem Textbereich befindet, wird in diesem Fenster die Textformatvorlage angezeigt, die mit diesem Textbereich verknüpft ist. Im Fenster Schriftgrad werden die technischen Angaben zum betreffenden Textbereich wiedergegeben.


Schaltfläche für Schriftart auf der Symbolleiste

SCHRIFTART

Diese Auswahlliste zeigt den Schriftartnamen für den Text- oder Rechenbereich, in dem der Cursor gerade steht.

Um eine andere Schriftart anzugeben, blättern Sie durch die Liste der verfügbaren Schriftartfamilien. Wählen Sie die gewünschte Schriftart aus, und lassen Sie die Maustaste los.


Schaltfläche für Schriftgrad auf der Symbolleiste

SCHRIFTGRAD

Diese Auswahlliste zeigt den Schriftgrad des Text- bzw. Rechenbereichs, in dem der Cursor gerade steht.

Um einen neuen Schriftgrad auszuwählen, blättern Sie durch die Liste der verfügbaren Schriftgrade. Wählen Sie den gewünschten Schriftgrad, und lassen Sie die Maustaste los.


Schaltfläche für Fettdruck

FETTDRUCK

Klicken Sie auf diese Schaltfläche, um allen Text in dieser Art Bereich auf Fettdruck umzustellen.

Falls Sie bereits Text markiert haben und auf diese Schaltfläche klicken, erscheint der Text fettgedruckt.


Schaltfläche für Kursivschrift

KURSIVSCHRIFT

Klicken Sie auf diese Schaltfläche, um allen Text in dieser Bereichsart auf Kursivschrift umzustellen.

Falls Sie bereits Text markiert haben und auf diese Schaltfläche klicken, erscheint der Text kursiv.


Schaltfläche für unterstrichenen Text

UNTERSTRICHENER TEXT

Klicken Sie auf diese Schaltfläche, um allen Text in dieser Bereichsart unterstreichen zu lassen.

Falls Sie bereits Text markiert haben und auf diese Schaltfläche klicken, erscheint der Text unterstrichen.


Schaltfläche "Linksbündig"

LINKS AUSGERICHTETER TEXT

Klicken Sie auf diese Schaltfläche, um alle Zeilen eines Textbereichs linksbündig auszurichten.


Schaltfläche "Rechtsbündig"

RECHTS AUSGERICHTETER TEXT

Klicken Sie auf diese Schaltfläche, um alle Zeilen eines Textbereichs rechtsbündig auszurichten.


Schaltfläche "Zentriert"

ZENTRIERTER TEXT

Klicken Sie auf diese Schaltfläche, um alle Zeilen eines Textbereichs zentriert auszurichten.


Die Funktion

Die Funktion bis darf nicht in Gleichungen verwendet werden, in denen es mehr als eine Bereichsvariable gibt (z. B. bei Mehrfachsummationen). Mathcad stoppt alle Iterationen für alle Bereichsvariablen, sobald das erste Argument von bis zum ersten Mal negativ ist. Dadurch erhalten Sie im Normfall nicht das gewünschte Ergebnis.


Vermeiden Sie Endlosschleifen.

Achten Sie darauf, daß sich der Wert des Testausdrucks irgendwo in der Iteration tatsächlich ändert. Andernfalls geraten Sie in eine Endlosschleife. Sollten Sie in diese Situation geraten, können Sie die Berechnung mit Hilfe der Esc-Taste abbrechen.


Epsilon-Funktion

Mit dieser Funktion wird bestimmt, wie oft Sie zwei Zahlen tauschen müssen, um von einer Folge [i,j,k] zur Folge [0,1,2] zurückzukommen. Wenn die Zahl gerade ist, gibt die Funktion 1 zurück. Ist die Zahl ungerade, wird -1 zurückgegeben.

Beispiel: (2,0,1)=1, da Sie, um von [2,0,1] zu [0,1,2] zu gelangen, die Zahlen zweimal (und damit eine gerade Zahl) tauschen müssen. Andererseits gilt [image] (0,2,1)=-1, da Sie, um von [0,2,1] zu [0,1,2] gelangen, die Zahlen einmal (und damit eine ungerade Zahl) tauschen müssen.


Komplexe Argumente und Ergebnisse in trigonometrischen Funktionen

Komplexe Argumente und Ergebnisse werden mit Hilfe der folgenden Identitäten berechnet:


NUMERISCHE PROBLEME BEI TRIGONOMETRISCHEN FUNKTIONEN

Da die trigonometrischen Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.

Rundungsfehler bei trigonometrischen Funktionen treten in den folgenden Fällen auf:

Große Argumente

Bei reellen Argumenten, deren Betrag sich 109 nähert, beginnen diese Funktionen, ihre Genauigkeit zu verlieren. In diesem Fall erscheint eine Fehlermeldung, die auf den Genauigkeitsverlust hinweist.

Singularitäten

Die Tangensfunktion ist bei ganzzahligen Vielfachen von p/2 nicht definiert. Argumente, die sich in der Nähe dieser Singularität befinden, werden ungenau berechnet.

Vielfache von p

Da der von Computern verwendete Wert von p nur ein Näherungswert sein kann, ist sin(p) zwar 0 sehr nahe, aber nicht gleich. tan(p/2) ist nicht undefiniert, gibt aber eine sehr große Zahl zurück.

Wenn Sie genauere Werte benötigen, sollten Sie mit der symbolischen Auswertung arbeiten und dabei Dezimalbrüche verwenden, um Gleitkommaberechnungen zu erzwingen.


Numerische Probleme bei hyperbolischen trigonometrischen Funktionen

Numerische Probleme bei hyperbolischen Funktionen

Da Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.

Rundungsfehler bei hyperbolischen Funktionen treten in den folgenden Fällen auf:

Große Argumente

Bei sehr großen Argumenten kommt es zu kleinen Genauigkeitsfehlern.

Singularitäten

Sowohl cosh(x) als auch sinh(x) weisen keinerlei Begrenzungen auf, wenn das Argument in Richtung + bzw. - unendlich geht.


Rundungsfehler bei numerischen Angaben für inverse hyperbolische Funktionen

Da Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.


Komplexe Argumente

Komplexe Argumente für die Exponentialfunktion werden vorgegeben durch:

Komplexe Argumente für die natürliche Logarithmusfunktion geben zurück:


Rundung und exp und e^

NUMERISCHE PROBLEME BEI EXPONENTIALFUNKTIONEN

Da Funktionen unter Verwendung von Gleitkommazahlen mit doppelter Genauigkeit ausgewertet werden, kommt es unweigerlich zu Rundungsfehlern, die sich auf die Berechnungen auswirken. Dies gilt vor allem dann, wenn das Argument der Funktion extreme Werte annimmt.

exp und e^x

Die Funktion exp verwendet einen Algorithmus, der nicht einfach einen Näherungswert für e in eine Potenz erhebt. Bei sehr großen oder kleinen Werten im Exponenten ist die Funktion exp robuster.

Die genauesten Werte bei sehr großen Argumenten lassen sich mit Hilfe der symbolischen Auswertung von exp(x) mit einem dezimalen Argument für x erreichen. Beispiel: exp(300000).


Hauptwert 5+.866i

Der Wert 5 +.866i ist der Hauptwert, da er einen Winkel von lediglich 60 Grad von der positiven reellen Achse aus bildet. Die Zahl - 1 befindet sich dagegen genau auf der anderen Seite,

180 Grad von der positiven reellen Achse.


Popup-Menü "BÜCHER"

Zum Öffnen des Popup-Menüs "Bücher" klicken Sie mit der rechten Maustaste auf das geöffnete Elektronische Buchfenster.


Strukturierte Datendatei

Eine Datei, in der die Daten in Zeilen und Spalten angeordnet und durch Leerzeichen und Tabulatorschritte voneinander getrennt sind. Beispiel:

2 2 3

2 8 6

3 6 9

Ein Textvorsatz ist zulässig am Dateianfang. Sobald die Funktion PRNLESEN jedoch auf eine Zahl stößt, geht sie davon aus, daß der Datenbereich erreicht wurde. Der Textvorsatz darf also keine Zahlen wie Datumsangaben usw. enthalten.

Datendateien können Zahlen im E-Format enthalten. Beispiel:

16E-2 -16.125E-15 200 50

sind jeweils gültige Zahlen in der Datendatei.

Hexadezimale, oktale oder binäre Daten werden nicht unterstützt.


Unstrukturierte Datendatei

Eine Datei, die aus einer Reihe von Zahlen besteht, die durch Leerzeichen und/oder Tabulatorschritte voneinander getrennt sind.

Datendateien können Zahlen im E-Format enthalten. Beispiel:

16E-2 -16.125E-15 200 50

sind jeweils gültige Zahlen in der Datendatei.

Hexadezimale, oktale oder binäre Daten werden nicht unterstützt.


Datei (Argument von PRNLESEN)

datei

Dies ist die Zeichenfolge.

PRNLESEN geht davon aus, daß sich diese Datei im Standardverzeichnis befindet. Wenn die Daten aus einer Datei gelesen werden sollen, die in einem anderen Verzeichnis gespeichert ist, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


Datei (Argument zu PRNSCHREIBEN)

datei

Dies ist die Zeichenfolge. Ist bereits eine Datei gleichen Namens vorhanden, wird sie von PRNSCHREIBEN überschrieben.

PRNSCHREIBEN geht davon aus, daß sich diese Datei im Standardverzeichnis befindet. Soll die Datei in ein anderes Verzeichnis geschrieben werden, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


Datei (Argument zu PRNANFÜGEN)

datei

Dies ist die Zeichenfolge. Diese Datei muß dieselbe Anzahl von Zeilen wie die Matrix haben, die Sie anhängen wollen.

PRNANFÜGEN geht davon aus, daß sich diese Datei im Standardverzeichnis befindet. Wenn die Daten an eine Datei angefügt werden sollen, die sich in einem anderen Verzeichnis befindet, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.

Zu beachten ist, daß die Datei schon vorhanden sein muß, damit PRNANFÜGEN funktioniert. Sie können PRNANFÜGEN nicht dazu benutzen, eine Datei zu erstellen. Die Funktion kann nur an eine vorhandene Datei Daten anhängen.


Datei (Argument zu LESEN)

datei

Dies ist die Zeichenfolge.

Die Funktion LESEN geht davon aus, daß sich diese Datei im Standardverzeichnis befindet. Wenn die Daten aus einer Datei gelesen werden sollen, die in einem anderen Verzeichnis gespeichert ist, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


Datei (Argument zu SCHREIBEN)

datei

Dies ist die Zeichenfolge. Ist eine Datei gleichen Namens bereits vorhanden, wird sie von der Funktion SCHREIBEN überschrieben.

Die Funktion SCHREIBEN geht davon aus, daß sich diese Datei im Standardverzeichnis befindet. Soll die Datei in ein anderes Verzeichnis geschrieben werden, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


Datei (Argument zu ANFÜGEN)

datei

Dies ist die Zeichenfolge

Die Funktion ANFÜGEN geht davon aus, daß sich diese Datei im Standardverzeichnis befindet. Wenn die Daten an eine Datei angefügt werden sollen, die sich in einem anderen Verzeichnis befindet, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


An die Datei datei.prn anzuhängendes Feld.

Dieses Feld muß genauso viele Spalten haben wie die Datei datei.prn.


Feld, in das der Inhalt von

Feld, in das der Inhalt von datei geschrieben werden soll.


Feld, dessen Inhalt in die Datei

Feld, dessen Inhalt in die Datei datei geschrieben werden soll.


PFEIL-NACH-OBEN

In leerem Bereichen...

Verschiebt das Fadenkreuz nach oben. Wenn sich ein anderer Bereich unmittelbar darüber befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Verschiebt die Bearbeitungslinien nach oben. Wenn sie sich bereits ganz oben im Ausdruck befinden, werden sie ganz aus dem Ausdruck entfernt und im leeren Bereich unmittelbar darüber zu einem Fadenkreuz umgewandelt.

In Textbereichen...

Verschiebt die Texteinfügemarke in die vorhergehende Zeile. Ist dies bereits die erste Zeile, wird sie ganz aus dem Text entfernt und als Fadenkreuzcursor unmittelbar darüber angezeigt.


PFEIL-NACH-UNTEN

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach unten. Liegt ein weiterer Bereich unmittelbar darunter, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Versetzt die Bearbeitungslinien nach unten. Wenn sie sich bereits ganz unten im Ausdruck befinden, werden sie aus dem Rechenausdruck in den leeren Bereich unmittelbar darunter versetzt.

In Textbereichen...

Verschiebt die Texteinfügemarke in die nächste Zeile. Befindet sie sich bereits in der letzten Zeile, so wird sie ganz aus dem Text in den leeren Bereich versetzt.


PFEIL-NACH-LINKS

In leeren Bereichen...

Versetzt den Fadenkreuzcursor um eine Stelle nach links. Befindet sich unmittelbar links daneben ein weiterer Bereich, wird das Fadenkreuz in den Bereich gesetzt und wird dort entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Versetzt die Einfügelinie um ein Zeichen nach links. Befindet sie sich bereits am Beginn des Ausdrucks, so werden die Bearbeitungslinien aus dem Ausdruck in den leeren Bereich links daneben gesetzt und dort zu einem Fadenkreuz umgewandelt.

In Textbereichen...

Verschiebt die Einfügemarke um ein Zeichen nach links. Befindet sie sich bereits am Textanfang, erscheint sie links außerhalb des Textes im leeren Bereich.


PFEIL-NACH-RECHTS

In leeren Bereichen...

Verschiebt das Fadenkreuz eine Stelle nach rechts. Befindet sich unmittelbar rechts daneben ein weiterer Bereich, wird das Fadenkreuz in den Bereich gesetzt und wird dort entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Verschiebt die Einfügelinie um ein Zeichen nach rechts. Befindet sie sich bereits am Ende eines Ausdrucks, so werden die Bearbeitungslinien aus dem Text herausgenommen und als Fadenkreuz in den leeren Bereich rechts daneben gesetzt.

In Textbereichen...

Verschiebt die Einfügemarke um ein Zeichen nach rechts. Befindet sie sich bereits am Ende des Textes, so wird die Einfügemarke aus dem Text herausgenommen und als Fadenkreuz in den leeren Bereich rechts daneben gesetzt.


UMSCHALT + PFEIL-NACH-OBEN

In leeren Bereichen...

Verschiebt das Fadenkreuz nach oben. Wenn sich ein anderer Bereich unmittelbar darüber befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Die Bearbeitungslinien erscheinen außerhalb und direkt über dem Ausdruck als Fadenkreuz.

In Textbereichen...

Verschiebt die Einfügemarke um eine Zeile nach oben und markiert den gesamten Text zwischen der alten und der neuen Position der Einfügemarke.


UMSCHALT + PFEIL-NACH-UNTEN

In leeren Bereichen...

Verschiebt das Fadenkreuz nach unten. Wenn sich ein anderer Bereich unmittelbar darunter befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Die Bearbeitungslinien erscheinen außerhalb und direkt unter dem Ausdruck als Fadenkreuz.

In Textbereichen...

Verschiebt die Einfügemarke um eine Zeile nach unten und markiert den gesamten Text zwischen der alten und der neuen Position der Einfügemarke.


UMSCHALT + PFEIL-NACH-LINKS

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach links. Wenn sich ein anderer Bereich links daneben befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Erweitert den Auswahlbereich im Ausdruck links neben der vertikalen Bearbeitungslinie.

In Textbereichen...

Markiert das links neben der Einfügemarke befindliche Zeichen.


UMSCHALT + PFEIL-NACH-RECHTS

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach rechts. Wenn sich ein anderer Bereich rechts daneben befindet, erscheint das Fadenkreuz in diesem Bereich und wird entweder zu einer Texteinfügemarke oder zu einem Paar Bearbeitungslinien.

In Rechenbereichen...

Erweitert den Auswahlbereich im Ausdruck rechts neben der vertikalen Bearbeitungslinie.

In Textbereichen...

Markiert das rechts neben der Einfügemarke befindliche Zeichen.


TABULATORTASTE

In leeren Bereichen...

Verschiebt das Fadenkreuz nach rechts.

In Rechenbereichen...

Springt zum nächsten Platzhalter. Ist kein weiterer Platzhalter vorhanden, springen die Bearbeitungslinien aus dem Ausdruck heraus und erscheinen als Fadenkreuz im rechts davon befindlichen leeren Bereich.

In Textbereichen...

Fügt einen Tabulator ein.


UMSCHALT + TABULATOR

In leeren Bereichen...

Inaktiv.

In Rechenbereichen...

Springt zum vorhergehenden Platzhalter. Ist kein weiterer Platzhalter vorhanden, springen die Bearbeitungslinien aus dem Ausdruck heraus und erscheinen als Fadenkreuz im links davon befindlichen leeren Bereich.

In Textbereichen...

Fügt ein Leerzeichen ein.


STRG + PFEIL-NACH-OBEN

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach oben.

In Rechenbereichen...

Inaktiv.

In Textbereichen...

Verschiebt die Einfügemarke an den Anfang der aktuellen Zeile. Wenn sich die Einfügemarke bereits am Zeilenanfang befindet, erscheint sie am Anfang der vorhergehenden Zeile. Wenn sich die Einfügemarke bereits am Anfang der ersten Zeile befindet, springt sie aus dem Text und erscheint als Fadenkreuz im über dem Text befindlichen leeren Bereich.


STRG + PFEIL-NACH-UNTEN

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach unten.

In Rechenbereichen...

Inaktiv.

In Textbereichen...

Verschiebt die Einfügemarke an das Ende der aktuellen Zeile. Wenn sich die Einfügemarke bereits am Zeilenende befindet, springt sie zum Ende der nächsten Zeile. Befindet sich die Einfügemarke bereits am Ende der letzten Zeile, springt sie aus dem Text und erscheint als Fadenkreuz direkt unterhalb des Textes.


STRG + PFEIL-NACH-LINKS

In leeren Bereichen...

Verschiebt das Fadenkreuz um eine Stelle nach links.

In Rechenbereichen...

Setzt die vertikale Bearbeitungslinie links neben die horizontale Bearbeitungslinie, soweit noch nicht geschehen.

In Textbereichen...

Verschiebt die Einfügemarke an den Anfang des vorhergehenden Wortes. Wenn sich die Einfügemarke bereits am Textanfang befindet, springt sie aus dem Text und erscheint als Fadenkreuz im links davon befindlichen leeren Bereich.


STRG + PFEIL-NACH-RECHTS

In leeren Bereichen...

Verschiebt das Fadenkreuz eine Stelle nach rechts.

In Rechenbereichen...

Setzt die vertikale Bearbeitungslinie rechts neben die horizontale Bearbeitungslinie, soweit noch nicht geschehen.

In Textbereichen...

Verschiebt die Einfügemarke zum Ende des nächsten Wortes. Wenn sich die Einfügemarke bereits am Textende befindet, springt sie aus dem Text und erscheint als Fadenkreuz im rechts davon befindlichen leeren Bereich.


POS1

In leeren Bereichen...

Verschiebt das Fadenkreuz neben den vorhergehenden Bereich. Wenn sich das Fadenkreuz bereits am ersten Bereich befindet, ist dieser Tastaturbefehl unwirksam.

In Rechenbereichen...

Verschiebt die Bearbeitungslinien an den Anfang des Ausdrucks. Wenn sich die Bearbeitungslinien bereits dort befinden, ist dieser Tastaturbefehl unwirksam.

In Textbereichen...

Verschiebt die Texteinfügemarke an den Anfang der Zeile. Wenn sich die Einfügemarke bereits dort befindet, ist dieser Tastaturbefehl unwirksam.


ENDE

In leeren Bereichen...

Verschiebt das Fadenkreuz neben den nächsten Bereich. Wenn sich das Fadenkreuz bereits am letzten Bereich befindet, ist dieser Tastaturbefehl unwirksam.

In Rechenbereichen...

Verschiebt die Bearbeitungslinien zum Ende des Ausdrucks. Wenn sich die Bearbeitungslinien bereits dort befinden, ist dieser Tastaturbefehl unwirksam.

In Textbereichen...

Verschiebt die Texteinfügemarke an das Zeilenende. Wenn sich die Einfügemarke bereits dort befindet, ist dieser Tastaturbefehl unwirksam.


STRG + POS1

In leeren Bereichen...

Verschiebt das Fadenkreuz neben den ersten Bereich im Arbeitsblatt. Wenn sich das Fadenkreuz bereits am letzten Bereich befindet, ist dieser Tastaturbefehl unwirksam.

In Rechenbereichen...

Verschiebt die Bearbeitungslinien an den Anfang des Ausdrucks. Wenn sich die Bearbeitungslinien bereits dort befinden, ist dieser Tastaturbefehl unwirksam.

In Textbereichen...

Verschiebt die Texteinfügemarke an den Anfang der ersten Textzeile im aktuellen Textbereich. Wenn sich die Einfügemarke bereits dort befindet, ist dieser Tastaturbefehl unwirksam.


STRG + ENDE

In leeren Bereichen...

Verschiebt das Fadenkreuz neben den letzten Bereich im Arbeitsblatt. Wenn sich das Fadenkreuz bereits am letzten Bereich befindet, ist dieser Tastaturbefehl unwirksam.

In Rechenbereichen...

Verschiebt die Bearbeitungslinien zum Ende des Ausdrucks. Wenn sich die Bearbeitungslinien bereits dort befinden, ist dieser Tastaturbefehl unwirksam.

In Textbereichen...

Verschiebt die Texteinfügemarke an das Ende der letzten Textzeile im aktuellen Textbereich. Wenn sich die Einfügemarke bereits dort befindet, ist dieser Tastaturbefehl unwirksam.


EINGABE

In leeren Bereichen...

Verschiebt das Fadenkreuz eine Stelle nach unten und zum linken Rand des Arbeitsblatts.

In Rechenbereichen...

Entfernt die Bearbeitungslinien aus dem Ausdruck und setzt sie als Fadenkreuz in den leeren Bereich darunter.

In Textbereichen...

Beginnt eine neue Zeile in einem neuen Absatz.


LEERTASTE

In leeren Bereichen...

Verschiebt das Fadenkreuz eine Stelle nach rechts.

In Rechenbereichen...

Verlängert die Bearbeitungslinien so, daß ein größerer Teil des Ausdrucks zwischen den Bearbeitungslinien liegt. Enthält der Rechenbereich jedoch keine Operatoren, wird er dadurch in einen Textbereich umgewandelt.

In Textbereichen...

Fügt ein Leerzeichen ein.


ZIEHEN VON BEREICHEN IN EIN ANDERES DOKUMENT

Beim Ziehen von Bereichen in ein anderes Arbeitsblatt muß sehr vorsichtig vorgegangen werden. Wenn Sie den Cursor länger in der Nähe des Fensterrahmens belassen, wird statt dessen das Bild automatisch weitergeblättert.


EINFÜGEN EINER LEERZEILE

Zum Einfügen einer Leerzeile gehen Sie wie folgt vor:

  1. Klicken Sie an eine leere Stelle, über der Sie ein Leerzeile einfügen möchten. Es erscheint ein Fadenkreuz.

  2. Drücken Sie die Eingabetaste so oft, bis die gewünschte Anzahl an Leerzeilen eingefügt ist.


LÖSCHEN EINER LEERZEILE

Zum Löschen einer Leerzeile gehen Sie wie folgt vor:

  1. Klicken Sie auf eine leere Stelle über der Zeile, die gelöscht werden soll. Es erscheint ein Fadenkreuz.

  2. Drücken Sie die Entf-Taste so oft, bis die zu löschenden Leerzeilen entfernt worden sind.


HORIZONTALES AUSRICHTEN VON BEREICHEN

Zum Ausrichten von mehreren markierten Bereichen an einer horizontalen Linie zwischen dem obersten und dem untersten Bereich gehen Sie vor wie folgt:

Markieren Sie die Bereiche, die ausgerichtet werden sollen.

Wählen Sie Bereiche ausrichten / Horizontal aus dem Menü Format.

Zu beachten ist, daß es bei dieser Aktion zu einer Überschneidung von Bereichen kommen kann.


VERTIKALES AUSRICHTEN VON BEREICHEN

Zum Ausrichten von mehreren markierten Bereichen an einer vertikalen Linie in der Mitte zwischen dem äußeren linken und dem äußeren rechten Bereich gehen Sie vor wie folgt:

Markieren Sie die Bereiche, die Sie ausrichten möchten.

Wählen Sie Bereiche ausrichten / Vertikal aus dem Menü Format.

Zu beachten ist, daß es bei dieser Aktion zu einer Überschneidung von Bereichen kommen kann.


Sperregion

Sperregion (Nur Mathcad Professional)

Eine Sperregion ist der Bereich des Dokuments, der sich zwischen den unten dargestellten Vorhängeschlössern befindet. Sie können solche Regionen erstellen, sperren und freigeben, indem Sie die entsprechende Auswahl in den Befehlen unter Region im Menü Format treffen.


KOMPATIBLES E-MAIL-SYSTEM

Ein E-Mail-Programm ist kompatibel, wenn es dem MAPI-Standard entspricht. Beispiele für kompatible E-Mail-Systeme sind Microsoft Exchange, Microsoft Mail und Eudora.


BEARBEITEN / RÜCKGÄNGIG

Macht den zuletzt gewählten Bearbeitungsbefehl bzw. Tastenanschlag in einem bestimmten Bereich rückgängig.


BEARBEITEN / WIEDERHOLEN

Hebt den letzten Rückgängig-Befehl wieder auf.


BEARBEITEN / AUSSCHNEIDEN

Löscht den markierten Bereich und setzt ihn in die Zwischenablage.

Zu beachten ist, daß die Zwischenablage immer nur das zuletzt ausgeschnittene Element enthält.


BEARBEITEN / KOPIEREN

Kopiert den markierten Bereich in die Zwischenablage. Zum Einfügen des Bereichs wählen Sie den Befehl Einfügen im Menü Bearbeiten.


BEARBEITEN / EINFÜGEN

Fügt den Inhalt der Zwischenablage in das Arbeitsblatt ein.

Dabei bleibt der Inhalt der Zwischenablage unverändert, so daß er weiterhin zur Verfügung steht.


BEARBEITEN / GEHE ZU SEITE...

Wechselt zu einer bestimmten Seite. Der obere Seitenrand der gewünschten Seite erscheint oben im Fenster.


BEARBEITEN / LÖSCHEN

Löscht den markierten Bereich, ohne ihn in die Zwischenablage zu setzen.


BEARBEITEN / INHALTE EINFÜGEN

Öffnet das Dialogfeld "Inhalte einfügen", mit dem der Inhalt der Zwischenablage in einem entsprechend angegebenen Format in das Arbeitsblatt eingefügt werden kann. Soll z. B. ein Bild von einem OLE-Server nicht als eingebettetes oder verknüpftes Objekt, sondern als Bitmap eingefügt werden, öffnen Sie mit dem Befehl Inhalte einfügen das gleichnamige Dialogfeld, und wählen Sie dort die Option "Bitmap" aus.


BEARBEITEN / ALLES MARKIEREN

Markiert bestimmte oder alle Bereiche. Welche Bereiche markiert werden, hängt von der jeweiligen Position des Cursors ab:

  • Wenn sich der Cursor beim Wählen des Befehls in einem leeren Teil des Arbeitsblatts befindet, werden sämtliche Bereiche im Arbeitsblatt markiert (mit gestrichelten Rechtecken umschlossen).

  • Wenn sich der Cursor beim Wählen des Befehls in einem Textbereich befindet, wird der gesamte Text im Textbereich markiert.

  • Wenn sich der Cursor beim Wählen des Befehls in einem Ausdruck oder einem anderen Rechenbereich befindet, wird der jeweilige Bereich markiert.

Nachdem Sie einen oder mehrere Bereiche auf diese Art markiert (ausgewählt) haben, können Sie sie kopieren, ausschneiden oder löschen.


BEARBEITEN / SUCHEN...

Öffnet das Dialogfeld "Suchen", in dem Sie Buchstaben, Zahlen oder andere Zeichen eingeben können, nach denen gesucht werden soll. Mit diesem Befehl können Sie nach Zeichen in Text sowie in Variablen- und Funktionsnamen suchen. Bestimmte Zeichen (wie z. B. Kommas) werden aber nur innerhalb von Text oder Zeichenfolgen gesucht.


BEARBEITEN / ERSETZEN...

Öffnet das Dialogfeld "Ersetzen", in dem Sie die Buchstaben, Zahlen oder andere Zeichen eingeben können, die gesucht und ersetzt werden sollen. Geben Sie unter "Suchen nach" die Zeichen ein, nach denen gesucht werden soll. Geben Sie unter "Ersetzen durch" die Zeichenfolge ein, die anstelle der Zeichen im Feld "Suchen nach" eingefügt werden soll. Klicken Sie dann auf eine der drei folgenden Schaltflächen:

“Weitersuchen”: Sucht nach der nächsten Stelle, an der die gesuchte Zeichenfolge auftritt, und markiert diese.

“Ersetzen”: Ersetzt die jeweils markierte Zeichenfolge.

“Alle ersetzen”: Ersetzt die jeweils markierte Zeichenfolge und sucht nach dem nächsten Auftreten dieser Zeichenfolge.


Bearbeiten / Rechtschreibung...

Öffnet das Dialogfeld "Rechtschreibung", um die Rechtschreibung des markierten Textes zu überprüfen. Ist kein Text markiert, wird der gesamte Text im aktuellen Textbereich geprüft.

Beachten Sie, daß mit dieser Rechtschreibprüfung nur Text in Textbereichen, nicht aber die Rechtschreibung in Gleichungen überprüft wird.


BEARBEITEN / VERKNÜPFUNGEN...

Bearbeitet OLE-Verknüpfungen im Arbeitsblatt. Verknüpfungen können Sie erstellen, indem Sie den Befehl Inhalte einfügen im Menü Bearbeiten wählen. Befinden sich im Arbeitsblatt keine verknüpften Objekte, steht diese Option nicht zur Verfügung.


BEARBEITEN / OBJEKT

Mit diesem Befehl können Sie ein OLE-Objekt bearbeiten oder öffnen, das in ein Arbeitsblatt eingefügt wurde. Sie müssen einmal auf das Objekt klicken, damit dieser Menübefehl verfügbar wird.


DATEI / NEU

Öffnet ein Dialogfeld, das eine Reihe von Vorlagen enthält. Wenn Sie ein leeres, unbenanntes Arbeitsblatt erstellen möchten, wählen Sie "Leeres Arbeitsblatt".


DATEI / ÖFFNEN...

Zeigt eine Liste der Arbeitsblätter an, die im aktuellen Verzeichnis gespeichert sind. Sie können das gewünschte Arbeitsblatt öffnen, indem Sie auf den entsprechenden Listeneintrag doppelklicken.

Legen Sie im Feld "Dateityp" fest, was für Dateien angezeigt werden sollen (z. B. elektronische Bücher).


DATEI / SPEICHERN

Ist das aktuelle Arbeitsblatt neu erstellt worden, werden Sie nach diesem Befehl zur Eingabe eines Namens aufgefordert. Wurde das Arbeitsblatt jedoch bereits gespeichert, so wird die gespeicherte Kopie auf dem Datenträger durch den aktuellen Fensterinhalt ersetzt.

Sie haben hier die Möglichkeit, eine Datei als Arbeitsblatt, als Arbeitsblatt einer älteren Version, als RTF (Rich Text Format)-Datei oder als HTML-Datei zu speichern.


DATEI / SPEICHERN UNTER...

Fordert Sie zur Eingabe eines neuen Namens auf, unter dem das aktuelle Arbeitsblatt gespeichert wird. Sie können Ihre Datei in einem der folgenden Formate speichern:

als Mathcad-Arbeitsblatt

als Vorlage

als Arbeitsblatt im Format einer älteren Version

als RTF (Rich Text Format)-Datei

als HTML-Datei


Datei / Schließen

DATEI / SCHLIESSEN

Schließt das aktive Arbeitsblatt.

Wurde das Arbeitsblatt nach dem letzten Speichern noch verändert, werden Sie gefragt, ob die Änderungen im aktuellen Arbeitsblatt gespeichert werden sollen.


DATEI / WWW-FOREN...

Öffnet ein Dialogfeld, mit dem Sie Dateien in den MathSoft-WWW-Foren verwalten können. Im einzelnen können Sie in diesem Dialogfeld:

ein Arbeitsblatt aus den WWW-Foren laden oder

ein Arbeitsblatt öffnen, das sich im Internet befindet, oder

Ihr Arbeitsblatt in den WWW-Foren speichern.


DATEI / SENDEN...

Versendet das aktive Arbeitsblatt per E-Mail über ein beliebiges kompatibles E-Mail-System. Damit Sie diesen Befehl nutzen können, müssen Sie mit einem E-Mail-Server verbunden sein.


DATEI / SEITE EINRICHTEN...

Öffnet ein Dialogfeld, in dem Sie folgendes einstellen können:

die vier Seitenränder

ob auch die Bereiche (bzw. Teile von Bereichen), die über den rechten Rand hinausreichen, mitgedruckt werden sollen

Papierformat, Zufuhr und Ausrichtung


DATEI / SEITENANSICHT...

Verändert die Bildschirmdarstellung, so daß Sie das genaue Druckbild der aktuellen Arbeitsblattseite erkennen können. Sie können das Arbeitsblatt mit den Schaltflächen "Nächste Seite" und "Vorherige Seite" oben am Bildschirm durchgehen oder das Arbeitsblatt mit der Schaltfläche "Drucken" drucken.


DATEI / DRUCKEN...

Öffnet ein Dialogfeld, in dem Sie folgendes wählen können:

den zu druckenden Bereich, also das gesamte Arbeitsblatt, einen Seitenbereich oder nur die aktuelle Markierung

den zu druckenden Seitenbereich

Wenn Sie einen Plotter als Ausgabegerät gewählt haben, können Sie jeweils nur eine Seite drucken.

Die gewählten Einstellungen gelten nur für den aktuellen Druckauftrag.


DATEI / BEENDEN

Beendet das Programm.

Wenn Sie nur das aktuelle Arbeitsblatt schließen, aber mit dem Programm weiterarbeiten möchten, ist statt dessen der Befehl Schließen im Menü Datei zu wählen.


DATEI / VORHERIGE DATEIEN

Am unteren Ende des Menüs Datei werden die zuletzt geöffneten Arbeitsblätter aufgelistet. Wenn Sie auf eines dieser Arbeitsblätter klicken, wird es geöffnet.


DATEI / AKTUALISIEREN

Kopien des Arbeitsblatts, die in anderen Anwendungen enthalten sind, werden anhand der vorgenommenen Änderungen aktualisiert. Dieser Befehl ist nur verfügbar, wenn Sie ein Objekt bearbeiten, das in einer anderen Anwendung eingebettet ist, und die Bearbeitung in einem eigenen Fenster, nicht in der Anwendung selbst erfolgt.


Datei / Kopie speichern unter...

Fordert Sie zur Eingabe eines neuen Namens auf, unter dem das aktuelle Arbeitsblatt gespeichert wird. Sie haben hier die Möglichkeit, eine Datei als Arbeitsblatt, als ein Arbeitsblatt einer älteren Version oder als RTF (Rich Text Format)-Datei zu speichern. Dieser Befehl ist nur dann verfügbar, wenn Sie ein Mathcad-Objekt bearbeiten, das in eine andere Anwendung eingebettet ist, und die Bearbeitung in einem eigenen Fenster, nicht in der Anwendung selbst erfolgt.


Datei / Schließen und Zurückkehren

DATEI / SCHLIESSEN UND ZURÜCKKEHREN

Schließt das aktive Arbeitsblatt, das ein Mathcad-Objekt anzeigt. Wurde das Arbeitsblatt nach dem letzten Speichern noch verändert, werden Sie gefragt, ob die Änderungen im aktuellen Arbeitsblatt gespeichert werden sollen. Dieser Befehl ist nur dann verfügbar, wenn Sie ein Mathcad-Objekt bearbeiten, das in eine andere Anwendung eingebettet ist, und die Bearbeitung in einem eigenen Fenster, nicht in der Anwendung selbst erfolgt.


Neues Arbeitsblatt

Öffnet ein leeres, unbenanntes Arbeitsblatt mit der Vorlage "Leeres Arbeitsblatt".


Format / Absatz....

Öffnet ein Dialogfeld, in dem Sie Absatzattribute von Text, wie z. B. die Ausrichtung und Einzüge, ändern können. Hier können Sie auch festlegen, ob der Absatz mit Aufzählungszeichen oder Numerierungen versehen werden soll.


FORMAT / BEREICHE TRENNEN

Trennt alle Bereiche voneinander, die sich im Arbeitsblatt überschneiden. Zu beachten ist, daß dieser Befehl nicht rückgängig gemacht werden kann.


FORMAT / BEREICHE AUSRICHTEN / HORIZONTAL

Richtet markierte Bereiche an einer horizontalen Linie in der Mitte zwischen dem höchsten und dem tiefsten Bereich aus.

Zu beachten ist, daß es bei dieser Aktion zu einer Überschneidung von Bereichen kommen kann. Wählen Sie in diesem Fall Bereiche trennen im Menü Format.


FORMAT / BEREICHE AUSRICHTEN / VERTIKAL

Richtet markierte Bereiche an einer vertikalen Linie in der Mitte zwischen dem äußeren linken und dem äußeren rechten Bereich aus.

Zu beachten ist, daß es bei dieser Aktion zu einer Überschneidung von Bereichen kommen kann. Wählen Sie in diesem Fall Bereiche trennen im Menü Format.


Format / Kopf-/Fußzeile...

FORMAT / KOPF-/FUSSZEILE...

Öffnet ein Dialogfeld, in dem Sie Kopf- und Fußzeilen definieren können. Kopf- und Fußzeilen können nicht nur Text, sondern auch Seitenzahlen, das aktuelle Datum und die Uhrzeit sowie den Namen der gerade bearbeiteten Datei enthalten.


FORMAT / DIAGRAMM / X-Y-DIAGRAMM...

Ermöglicht die Festlegung der Standardeigenschaften aller X-Y-Diagramme im Arbeitsblatt. Sie können folgendes bestimmen:

Skalenmarkierungen

Gitterlinien

Kurventyp (Balken, Linie usw.)

Symbole zur Darstellung der einzelnen Punkte (+, x, usw.)

Kurvenfarbe

Linienstärke

Legenden

Achsentyp (linear oder logarithmisch)


FORMAT / DIAGRAMM / KREISDIAGRAMM...

Ermöglicht die Festlegung der Standardeigenschaften aller Kreisdiagramme. Sie können folgendes bestimmen:

Skalenmarkierungen

Gitterlinien

Kurventyp (Balken, Linien usw.)

Symbole zur Darstellung der Punkte auf den einzelnen Kurven (keine, + usw.)

Kurvenfarbe

Linienstärke

Legenden

Typ der Radialachse (linear oder logarithmisch)


FORMAT / DIAGRAMM / 3D-DIAGRAMM...

Ermöglicht die Festlegung der Standardeigenschaften des ausgewählten 3D-Diagramms. Sie können folgendes bestimmen:

den Diagrammtyp (Umriß-, Flächen-, Streuungs- oder Säulendiagramm)

die Farben

die Benennungen

die Anzeige von Gitterlinien und die Zahlen auf den Achsen

Umriß- und Vektorfelddiagramme ausgenommen, können Sie folgendes bestimmen:

den Betrachtungswinkel

die vertikale Skalierung (starke oder weniger starke Wiedergabe von Wertdifferenzen)

Hintergrundebenen

Die restlichen Diagrammeigenschaften hängen jeweils vom Typ des 3D-Diagramms ab.


FORMAT / DIAGRAMM / KOORDINATEN ABLESEN...

Ermöglicht das Ablesen der Koordinaten direkt aus dem ausgewählten Diagramm. Dieser Befehl ist nur dann im Menü enthalten, wenn Sie zuvor auf ein X-Y-Diagramm oder ein Kreisdiagramm geklickt haben.


FORMAT / DIAGRAMM / ZOOM...

Ermöglicht die vergrößerte Darstellung im ausgewählten Diagramm. Dieser Befehl ist nur dann im Menü enthalten, wenn Sie zuvor auf ein X-Y-Diagramm oder ein Kreisdiagramm geklickt haben.


FORMAT / FARBE / HINTERGRUND...

Öffnet eine Symbolleiste mit Farben, mit der Sie die Hintergrundfarbe des Haupt-Arbeitsblattfensters ändern können.


FORMAT / FARBE / HERVORHEBUNG...

Öffnet eine Symbolleiste mit Farben, mit der Sie die Farbe ändern können, die zur Hervorhebung von Bereichen genutzt wird.


FORMAT / FARBE / ANMERKUNG...

Öffnet eine Symbolleiste mit Farben, mit der Sie die Farbe festlegen können, in der Ihre Änderungen an einem Elektronischen Buch hervorgehoben werden.


FORMAT / FARBE / STANDARDPALETTE VERWENDEN

Ist diese Option aktiviert, zeigt Mathcad den Inhalt des Arbeitsblatts mit einer einzigen Standardfarbpalette aus 256 Farben an, sofern der Bildschirmtreiber 256 Farben unterstützt.

Ist diese Option nicht aktiviert, verwendet Mathcad zur Anzeige der einzelnen Bilder im Arbeitsblatt die jeweils am besten geeignete Farbpalette. Dadurch kann der Bildschirm beim Bewegen durch das Arbeitsblatt mittels Bildlaufleisten ("Rollen" bzw. "Scrollen") flackern, da für jede 256-Farben-Bitmap eine neue Palette geladen wird.


FORMAT / FARBE / PALETTE OPTIMIEREN

Optimiert die Standardfarbpalette, so daß alle Bitmaps im Arbeitsblatt mit der bestmöglichen 256-Farben-Palette dargestellt werden. Damit die neue Standardpalette aktiviert wird, muß die Option Farbe / Standardpalette verwenden im Menü Format aktiviert sein.


FORMAT / FORMATVORLAGE

Öffnet das Dialogfeld "Textformatvorlagen", in dem Sie eine Textformatvorlage erstellen oder bearbeiten können. Wenn Sie auf einen Textbereich klicken und diesen Befehl wählen, können Sie dem Textbereich mit diesem Dialogfeld eine Formatvorlage zuweisen.

Statt Formatvorlage im Menü Format zu wählen, können Sie einem Textbereich auch eine Formatvorlage zuweisen, indem Sie einfach in den Textbereich klicken und aus der äußersten linken Dropdown-Liste in der Symbolleiste "Formatierung" eine Formatvorlage auswählen.


FORMAT / EIGENSCHAFTEN

Dieser Befehl öffnet ein Dialogfeld mit mehreren Registerkarten. Mit den darin enthaltenen Optionen können Sie, abhängig von der Art des markierten Bereichs, folgende Einstellungen vornehmen:

Hervorheben eines Bereiches in einer Farbe Ihrer Wahl

Einfügen oder Entfernen eines Rahmens um ein Bild herum

Anzeigen eines Bildes in seiner Originalgröße

Ein- oder Ausschalten einer Berechnung durch Klicken auf “Auswertung deaktivieren"

Aktivieren oder Deaktivieren der Optimierung

Eigenschaften von Textbereichen festlegen, um die Breite und das Verhalten eines Textbereichs zu steuern

das Erscheinungsbild einer eingefügten Region steuern


FORMAT / ERGEBNIS...

Öffnet das Dialogfeld "Ergebnisformat" , in dem Sie festlegen können, wie numerische Ergebnisse angezeigt werden sollen.

Wenn Sie auf ein bestimmtes Ergebnis klicken und diese Option wählen, formatieren Sie ein Einzelergebnis, d. h., die Änderungen gelten nur für dieses eine Ergebnis.

Wenn Sie auf eine leere Stelle Ihres Arbeitsblatts klicken und diese Option wählen, formatieren Sie alle Ergebnisse im Arbeitsblatt.


FORMAT / GLEICHUNG...

Zeigt eine Liste der verfügbaren Gleichungsformatvorlagen an. Gleichungsformatvorlagen sind Zusammenstellungen von Schrifteigenschaften wie Größe, Farbe, Schriftart usw. Um eine Schriftart zu ändern, klicken Sie auf einen Namen oder eine Zahl, und wählen Sie eine Gleichungsformatvorlage aus der Liste.

Sie können auch die Schriftart für eine vorhandene Gleichungsformatvorlage ändern, indem Sie die Vorlage auswählen und auf "Ändern" klicken. Zu beachten ist hierbei, daß sich durch die Veränderung der Gleichungsformatvorlage die Schriftart sämtlicher Variablen ändert, denen die Vorlage zugewiesen ist.


FORMAT / TEXT...

Öffnet ein Dialogfeld, in dem Sie die Schriftart, die Schriftgröße, die Farbe und den Schriftstil der markierten Textzeichen ändern können.

Dieser Befehl wirkt sich nur auf Text aus. Soll die Schriftart einer Gleichung geändert werden, müssen Sie Gleichung aus dem Menü Format wählen.


Format / Region / Sperren

FORMAT / REGION / SPERREN (nur in Mathcad Professional)

Sperrt eine Region, die über den Befehl Region im Menü Einfügen eingefügt worden ist. Klicken Sie in den Bereich, bevor Sie diesen Befehl wählen.

Sie können gesperrten Bereichen ein Kennwort zuweisen, so daß eine Freigabe nur nach Eingabe des Kennworts möglich ist. Wenn Sie ein Kennwort festlegen, müssen Sie unbedingt dafür sorgen, daß Sie es nicht vergessen.


Format / Region / Freigeben

FORMAT / REGION / FREIGEBEN (nur in Mathcad Professional)

Gibt eine gesperrte Region frei, die über den Befehl Region im Menü Einfügen eingefügt worden ist. Wurde die Region mit einem Kennwort gesperrt, werden Sie vor der Freigabe aufgefordert, dieses Kennwort einzugeben.


Dialogfeld "Eigenschaften": Registerkarte "Anzeige"

DIALOGFELD "EIGENSCHAFTEN"

Auf der Registerkarte "Anzeige" des Dialogfelds "Eigenschaften" finden Sie die folgenden Optionen und Schaltflächen:

Bereich hervorheben

Markiert einen Bereich mit einer Farbe, so daß dieser hervorgehoben wird.

Farbe auswählen

Hiermit können Sie die Farbe auswählen, die zum Hervorheben des ausgewählten Bereichs verwendet werden soll, wenn die Option "Bereich hervorheben" aktiviert wird. Soll die Hervorhebungsfarbe für alle Bereiche im Arbeitsblatt ausgewählt werden, wählen Sie den Befehl Farbe / Hervorhebung im Menü Format.

2D-Rahmen

Wenn diese Option aktiviert ist, wird um das gerade markierte Bild bzw. die Bitmap ein Rahmen gezogen.

In Originalgröße anzeigen

Zeigt das Bild bzw. die Bitmap in der Originalgröße an.


 Hebt einen Bereich farbig hervor, falls markiert.


Wählt eine Hervorhebungsfarbe für den markierten Bereich, wenn "Bereich hervorheben" markiert ist

 Wählt eine Hervorhebungsfarbe für den markierten Bereich, sofern "Bereich hervorheben" aktiviert ist. Um eine Hervorhebungsfarbe für sämtliche Arbeitsblattbereiche zu bestimmen, wählen Sie Farbe / Hervorhebung aus dem Menü Format.


Fügt einen Rahmen um ein ausgewähltes Bild oder eine ausgewählte Bitmap hinzu bzw. löscht einen solchen Rahmen.


Wechselt die Anzeige des Bildes bzw. der Bitmap zwischen der ursprünglichen und der angepaßten Bildgröße

 Wechselt die Anzeige des Bildes bzw. der Bitmap zwischen der ursprünglichen und der angepaßten Bildgröße.


Dialogfeld "Eigenschaften": Registerkarte "Berechnung"

DIALOGFELD "EIGENSCHAFTEN"

Auf der Registerkarte "Berechnung" des Dialogfelds "Eigenschaften" finden Sie die folgenden Optionen und Schaltflächen:

Auswertung deaktivieren

Deaktiviert einen Bereich, so daß er nicht verarbeitet wird. Neben dem Bereich, für den die Auswertung deaktiviert wurde, erscheint ein schwarzes Kästchen.

Optimierung deaktivieren

Aktiviert bzw. deaktiviert die Optimierung für einen ausgewählten Ausdruck. Durch die Optimierung kann der symbolische Prozessor einen Ausdruck vereinfachen, bevor dieser von dem numerischen Prozessor berechnet wird.


HILFE / MATHCAD-HILFE

Öffnet ein Fenster mit einem Index, einem Inhaltsverzeichnis und einer Volltext-Suchfunktion für die Online-Hilfe.


HILFE / INFO ÜBER MATHCAD...

Zeigt die Nummer Ihrer Mathcad-Version an.


HILFE / INFORMATIONSZENTRUM...

Öffnet das Informationszentrum, das aus einer Sammlung von Online-Informationen zu den verschiedenen Mathcad-Funktionen sowie zu wissenschaftlichen und technischen Themen besteht.


HILFE / TIPS UND TRICKS...

Öffnet das Dialogfeld "Tips und Tricks", das einen von vielen Tips und Tricks anzeigt. Sie können hier alle verfügbaren Tips und Tricks durchgehen.

Soll das Dialogfeld "Tips und Tricks" nicht mehr beim Starten von Mathcad angezeigt werden, deaktivieren Sie die Option "Tips bei jedem Start anzeigen".


HILFE / BUCH ÖFFNEN...

Öffnet das Dialogfeld "Öffnen", in dem Sie ein Elektronisches Buch öffnen können. Gehen Sie in diesem Dialogfeld zu einer der *.hbk-Dateien (*.hbk ist das Dateiformat für Elektronische Bücher).


EINFÜGEN / VERWEIS

Hiermit können Sie Platz auf Ihrem Arbeitsblatt sparen, indem Sie alle Variablen- und Funktionsdefinitionen aus einem anderen Arbeitsblatt im aktuellen Arbeitsblatt verfügbar machen.

Öffnet das Dialogfeld "Verweis einfügen", in dem Sie die Datei festlegen können, auf die verwiesen werden soll. Wählen Sie ein Arbeitsblatt mit der Schaltfläche "Durchsuchen" aus, oder geben Sie den vollständigen Pfadnamen bzw. die URL ein, und klicken Sie dann auf "OK". Hierbei wird durch ein Symbol der Punkt gekennzeichnet, nach dem die eingefügten Definitionen verfügbar sind.

Dieser Befehl fügt den Arbeitsblattverweis an der Cursorposition ein. Sie löschen einen Verweis auf ein Arbeitsblatt, indem Sie das Symbol auswählen und Löschen im Menü Datei wählen.


EINFÜGEN / SEITENUMBRUCH

Fügt einen Seitenumbruch an der Position des Cursors ein.

Sie löschen einen Seitenumbruch, indem Sie auf die Stelle klicken, an der die Seitenumbruchslinie den linken Rand des Arbeitsblatts berührt. Wählen Sie dann Ausschneiden im Menü Bearbeiten.


EINFÜGEN / HYPERLINK

Öffnet das Dialogfeld "Hyperlink einfügen", in dem Sie einen Hyperlink erstellen, bearbeiten und entfernen können.

Bevor Sie auf diesen Befehl zugreifen können, müssen Sie zunächst in einen Bereich klicken. Ein Hyperlink ist mit dem Bereich verbunden. Wenn Sie auf den Bereich doppelklicken, wird ein anderes Arbeitsblatt (das sich auf einer Festplatte oder im Internet befindet) in einem Vollbildfenster oder einem Popup-Fenster geöffnet.


EINFÜGEN / DIAGRAMM / 3D-DIAGRAMMASSISTENT

Öffnet den 3D-Diagrammassistenten, der Sie durch das Erstellen eines dreidimensionalen Diagramms (Flächendiagramm, Umrißdiagramm, 3D-Säulendiagramm oder 3D-Streuungsdiagramm) führt.


EINFÜGEN / DIAGRAMM / X-Y-DIAGRAMM

Fügt den X-Y-Diagrammoperator mit den Platzhaltern für die x- und y-Werte sowie für die Achsenendpunkte ein. Um ein X-Y-Diagramm einer Funktion schnell zu erstellen, klicken Sie auf den mittleren Platzhalter auf der y-Achse, und geben Sie die Funktion ein.


EINFÜGEN / DIAGRAMM / KREISDIAGRAMM

Fügt den Kreisdiagrammoperator mit den Platzhaltern für eine Winkelvariable und einen radialen Ausdruck ein. Um ein Kreisdiagramm einer Funktion schnell zu erstellen, klicken Sie auf den Platzhalter links, und geben Sie den Funktionsausdruck ein.


EINFÜGEN / DIAGRAMM / FLÄCHENDIAGRAMM

Fügt den 3D-Diagrammoperator in Ihr Arbeitsblatt ein. Ein Flächendiagramm der Elemente einer Matrix erstellen Sie, indem Sie die Matrix in den Platzhalter eingeben. Die Zeilen und Spalten der Matrix stimmen mit der x- und der y-Achse überein. Die Werte der Matrixelemente selbst stellen die Höhe über der xy-Ebene dar.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen wollen, wählen Sie statt dessen Einfügen / Diagramm / 3D-Diagrammassistent.


Einfügen / Diagramm / Umrißdiagramm

EINFÜGEN / DIAGRAMM / UMRISSDIAGRAMM

Fügt den 3D-Diagrammoperator mit einem Platzhalter in Ihr Arbeitsblatt ein. Ein Umrißdiagramm der Elemente einer Matrix erstellen Sie, indem Sie die Matrix in den Platzhalter eingeben. Die Zeilen und Spalten der Matrix entsprechen der x- und der y-Achse. Die Werte der Matrixelemente selbst stellen die Umrisse über der xy-Ebene dar.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen wollen, wählen Sie statt dessen Einfügen / Diagramm / 3D-Diagrammassistent.


EINFÜGEN / DIAGRAMM / 3D-STREUUNGSDIAGRAMM

Fügt den 3D-Diagrammoperator in Ihr Arbeitsblatt ein. Ein Streuungsdiagramm einer willkürlichen Sammlung von Punkten in drei Dimensionen erstellen Sie, indem Sie in den Platzhalter drei Vektoren eingeben. Die Zeilen der Vektoren stehen für die x-, y- und z-Koordinaten der darzustellenden Punkte.

Sie können auch die Elemente einer Matrix darstellen lassen. Geben Sie dazu die Matrix in den Platzhalter ein. Die Zeilen und Spalten entsprechen der x- und der y-Achse. Der Wert des Feldelements selbst stellt die Höhe über der xy-Ebene dar. Die einzelnen Punkte werden nicht zu einer Fläche verbunden.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen wollen, wählen Sie statt dessen Einfügen / Diagramm / 3D-Diagrammassistent.


EINFÜGEN / DIAGRAMM / VEKTORFELDDIAGRAMM

Fügt den 3D-Diagrammoperator mit einem Platzhalter in Ihr Arbeitsblatt ein. Ein zweidimensionales Vektorfelddiagramm erstellen Sie, indem Sie in den Platzhalter eine Matrix eingeben. Die Zeilen und Spalten der Matrix entsprechen der x- und der y-Achse. Die Matrixelemente selbst sind komplexe Zahlen, deren reelle und imaginäre Teile den x- und y-Komponenten eines Vektors entsprechen, der mit einem bestimmten Wert von x und y verbunden ist.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen wollen, wählen Sie statt dessen Einfügen / Diagramm / 3D-Diagrammassistent.


EINFÜGEN / DIAGRAMM / 3D-SÄULENDIAGRAMM

Fügt den 3D-Diagrammoperator mit einem Platzhalter in Ihr Arbeitsblatt ein. Erstellen Sie ein dreidimensionales Säulendiagramm der Elemente in einer Matrix, indem Sie die Matrix in den Platzhalter eingeben. Die Zeilen und Spalten der Matrix entsprechen Werten von x und y. Die Werte der Matrixelemente selbst stellen die Höhen der Säulen über der xy-Ebene dar.

Wenn Sie das Erscheinungsbild des Diagramms (wie z. B. seine Farbe und seine Linien) beim Einfügen festlegen wollen, wählen Sie statt dessen Einfügen / Diagramm / 3D-Diagrammassistent.


EINFÜGEN / BILD

Fügt den Bildoperator mit einem darin enthaltenen Platzhalter ein. Das Einfügen einer Bitmap-Datei kann auf dreierlei Art und Weise erfolgen:

Geben Sie eine Zeichenfolge ein, die den Namen oder den Pfad zu einer Windows-Bitmap-Datei (BMP-Format) enthält, die im Platzhalter für ein Bild steht.

Geben Sie den Namen einer Matrix in den Platzhalter ein. Dadurch wird die Matrix mit bis zu 256 Graustufen angezeigt.

Geben Sie in den Platzhalter die Namen von drei Matrizen gleicher Größe (durch Kommas voneinander getrennt) ein, in denen die einem Farbbild entsprechenden Rot-, Grün- und Blauwerte enthalten sind. Dadurch wird ein Farbbild angezeigt.


Einfügen / Matrix...

Öffnet das Dialogfeld "Matrix einfügen", mit dem Sie an der Stelle, an der sich der Fadenkreuz-Cursor gerade befindet, einen Vektor oder eine Matrix erstellen können.

Falls sich der Cursor in einem Vektor oder einer Matrix befindet, haben Sie mit dieser Option die Möglichkeit, eine Zeile oder eine Spalte einzufügen oder zu löschen.


EINFÜGEN / EINHEIT...

Öffnet das Dialogfeld "Einheit einfügen", in dem Sie eine Liste der vordefinierten Einheiten finden.

Zum Formulieren eines Ergebnisses mit einer vordefinierten Einheit gehen Sie folgendermaßen vor:

Klicken Sie auf den Einheiten-Platzhalter rechts neben einem Ergebnis.

Markieren Sie in der Liste der Einheiten die gewünschte Einheit.

Klicken Sie auf Einfügen, damit die Einheit eingefügt wird.


EINFÜGEN / FUNKTION...

Öffnet das Dialogfeld "Funktion einfügen", in dem Sie eine Liste der vordefinierten Funktionen finden.

Sie erhalten Kurzbeschreibungen der Funktionen, indem Sie auf den Namen klicken und den Text lesen, der in dem Feld auf der rechten Seite angezeigt wird.

Zum Einfügen einer vordefinierten Funktion zusammen mit den erforderlichen Platzhaltern ist wie folgt vorzugehen:

Markieren Sie den Funktionsnamen in der Liste der Funktionen.

Klicken Sie auf Einfügen.


Einfügen / Objekt...

Zeigt ein Dialogfeld mit der Liste der OLE-Server an. Mit diesem Befehl fügen Sie ein OLE-Objekt in das Arbeitsblatt ein. Sie können ein neues Objekt erstellen oder eins aus einer vorhandenen Datei einfügen. Wählen Sie "Als Symbol", wenn anstelle des Objekts im Arbeitsblatt ein Symbol angezeigt werden soll.


EINFÜGEN / TEXTBEREICH

Erstellt an der Position des Fadenkreuz-Cursors einen Textbereich. Der Fadenkreuz-Cursor nimmt die Form einer dünnen vertikalen Linie an. Es wird ein Feld angezeigt, durch das die Größe des Textbereichs dargestellt wird. Dieses Feld wird ausgeblendet, wenn Sie auf eine Stelle außerhalb des Bereichs klicken.

Sie können die Breite eines Textbereichs ändern, indem Sie ihn auswählen und mit der Maus den rechten Rand des Auswahlrahmens ziehen.


EINFÜGEN / RECHENBEREICH

Fügt innerhalb von Text einen Rechenbereichsplatzhalter ein. Geben Sie einen Ausdruck, eine Variable, eine Funktion oder ein anderes Rechenelement in den Platzhalter ein.

Mit diesem Befehl können Sie auch in einem leeren Teil Ihres Arbeitsblatts einen Rechenbereichsplatzhalter erstellen. Normalerweise ist dies aber nicht nötig, da Sie Rechenelemente auch einfügen können, indem Sie einfach an der Position des Fadenkreuz-Cursors in einem leeren Teil Ihres Arbeitsblatts mit der Eingabe beginnen.

Rechenbereiche in Text verhalten sich aktiv. Das heißt, ein solcher Rechenbereich wirkt sich auf alle anderen Rechenbereiche des Arbeitsblatts aus, wie auch diese sich wiederum auf diesen Rechenbereich in Text auswirken. Sie deaktivieren einen Rechenbereich mit dem Befehl Eigenschaften im Menü Format.


EINFÜGEN / KOMPONENTE

Zeigt das Dialogfeld "Komponente einfügen" an. Wählen Sie eine einzufügende Komponente aus, und klicken Sie auf "OK".

Diese Menüoption ist nur verfügbar, wenn Sie auf eine leere Stelle im Arbeitsblatt klicken.


Einfügen / Region

EINFÜGEN / REGION (nur in Mathcad Professional)

Fügt Regionsbegrenzungslinien in Ihr Arbeitsblatt ein.

Plazieren Sie die Bereiche zwischen den Begrenzungslinien und sperren Sie die Region dann. Sie können die Region zusätzlich auch ausblenden.


RECHNEN / BERECHNEN

Aktualisiert alle sichtbaren Diagramme und numerischen Ergebnisse.

Mit diesem Befehl müssen Sie eigentlich nur arbeiten, wenn sich Mathcad im manuellen Berechnungsmodus befindet. Wenn Ergebnisse aktualisiert werden müssen, können Sie dies am Wort "Rech" in der Meldungszeile am unteren Fensterrand erkennen.

Sollen alle Diagramme und Ergebnisse im gesamten Arbeitsblatt aktualisiert werden, wählen Sie statt dessen den Befehl Arbeitsblatt berechnen im Menü Rechnen.

Tastaturkurzbefehl: Drücken Sie F9.


RECHNEN / ARBEITSBLATT BERECHNEN

Aktualisiert alle Diagramme und numerischen Ergebnisse im gesamten Arbeitsblatt.

Mit diesem Befehl müssen Sie eigentlich nur arbeiten, wenn sich Mathcad im manuellen Berechnungsmodus befindet. Wenn Ergebnisse aktualisiert werden müssen, können Sie dies am Wort "Rech" in der Meldungszeile am unteren Fensterrand erkennen.

Sollen nur die Diagramme und numerischen Ergebnisse aktualisiert werden, die gerade angezeigt werden, wählen Sie statt dessen den Befehl Berechnen im Menü Rechnen.


RECHNEN / AUTOMATISCHE BERECHNUNG

Schaltet zwischen dem manuellen und dem automatischen Modus um.

Ist der Befehl aktiviert, werden alle sichtbaren Ergebnisse automatisch aktualisiert, wenn Sie Änderungen im Arbeitsblatt vornehmen.

Ist der Befehl nicht aktiviert, werden die Ergebnisse erst dann aktualisiert, wenn Sie Berechnen im Menü Rechnen wählen.

Bei der Bearbeitung eines Arbeitsblatts mit aufwendigen Berechnungen läßt sich der manuelle Modus oft besser handhaben.


RECHNEN / OPTIMIERUNG

Aktiviert bzw. deaktiviert die symbolische Optimierung. Ob die Optimierung aktiviert ist, erkennen Sie daran, ob neben dem Befehl ein Häkchen vorhanden ist oder nicht.

Wenn die Optimierung aktiviert ist, versucht der symbolische Prozessor jeden Ausdruck, der sich rechts neben ":=" oder "=" befindet, zu vereinfachen. Ist dies möglich, so kennzeichnet er den Bereich mit einem Sternchen und führt die Berechnung anhand des vereinfachten Ausdrucks durch. Sie können den vereinfachten Ausdruck einsehen, wenn Sie auf das Sternchen doppelklicken.

Soll die Optimierung deaktiviert werden, wählen Sie diesen Menübefehl erneut.


Rechnen / Optionen...

Öffnet ein Dialogfeld mit mehreren Registerkarten:

  • Auf der Registerkarte "Vordefinierte Variablen" können Sie vordefinierte Variablen, wie z. B. "TOL" und "CTOL", ändern.

  • Auf der Registerkarte "Einheitensystem " können Sie ein Einheitensystem festlegen, mit dem Sie arbeiten wollen.

  • Auf der Registerkarte "Dimensionen" können Sie festlegen, welche Dimensionsnamen für die angezeigten Einheiten verwendet werden sollen.

  • Auf der Registerkarte "Berechnungen" können Sie die Berechnungen steuern, indem Sie sie deaktivieren oder symbolisch optimieren.


RECHNEN / OPTIONEN / REGISTERKARTE "VORDEFINIERTE VARIABLEN"

Öffnet ein Dialogfeld, in dem die Werte der folgenden vordefinierten Variablen geändert werden können:

TOL

CTOL

PRNPRECISION

ORIGIN

PRNCOLWIDTH

Rekursivwert für Zufallszahlen


RECHNEN / OPTIONEN / REGISTERKARTE "EINHEITENSYSTEM"

Öffnet ein Dialogfeld, in dem das Standardeinheitensystem geändert werden kann. Standardgemäß werden Ergebnisse in SI-Einheiten angegeben: m, kg, s, K, A, cd und mol (für Länge, Masse, Zeit, Temperatur, Ladung, Leuchtstärke und Stoff). Mit dieser Registerkarte des Dialogfelds "Optionen" können Sie festlegen, daß zur Anzeige der Ergebnisse Einheiten anderer Systeme verwendet werden sollen.


RECHNEN / OPTIONEN / REGISTERKARTE "BERECHNUNG"

Ruft ein Dialogfeld zum Festlegen von Berechnungsoptionen auf.


SYMBOLIK / AUSWERTEN / SYMBOLISCH

Wertet bestimmte Integrale, Ableitungen, Summationen (Additionen), Produkte, Funktionen und andere algebraische und Matrizenausdrücke symbolisch aus.


SYMBOLIK / AUSWERTEN / GLEITKOMMA...

Führt die symbolische Auswertung durch und gibt das Ergebnis, soweit möglich, als Zahl aus.


SYMBOLIK / AUSWERTEN / KOMPLEX

Führt die symbolische Auswertung durch und gibt das Ergebnis, soweit möglich, in komplexer Form wieder.


SYMBOLIK / VEREINFACHEN

Vereinfacht den markierten Ausdruck arithmetisch durch Kürzen von gemeinsamen Faktoren und mit Hilfe von grundlegenden trigonometrischen Regeln und Umkehrfunktionen.


SYMBOLIK / ENTWICKELN

Entwickelt alle Potenzen und Summenprodukte im ausgewählten Ausdruck.


SYMBOLIK / FAKTORISIEREN

Faktorisiert den ausgewählten Ausdruck zu einem Produkt, wenn der gesamte Ausdruck als Produkt notiert werden kann. Soll ein Teilausdruck eines größeren Ausdrucks faktorisiert werden, so markieren Sie den Teilausdruck. Mit diesem Befehl können Sie eine Summe von Brüchen zu einem einzigen Bruch zusammenfassen.


SYMBOLIK / ZUSAMMENFASSEN

Hierdurch werden im ausgewählten Teilausdruck die Terme gleicher Potenz zusammengefaßt. Der Teilausdruck kann aus einer einzigen Variable oder aus einer Funktion und ihrem Argument bestehen. Das Ergebnis ist ein Polynom im gewählten Teilausdruck.


SYMBOLIK / POLYNOM-KOEFFIZIENTEN

Ermittelt Koeffizienten eines Ausdrucks, falls dieser in einem gewählten Teilausdruck zu einem Polynom umgewandelt wurde.


SYMBOLIK / VARIABLE / AUFLÖSEN

Ermittelt den Wert der ausgewählten Variable, durch den der Ausdruck, der die Variable enthält, insgesamt Null ergibt.

Wenn Sie eine Variable in einer Gleichung oder Ungleichung auswählen, löst dieser Befehl die Gleichung bzw. Ungleichung nach der gewählten Variable auf.


SYMBOLIK / VARIABLE / ERSETZEN

Ersetzt die ausgewählte Variable überall durch den Inhalt der Zwischenablage.

Dieser Befehl wird folgendermaßen gehandhabt:

  1. Schneiden Sie den Ausdruck, der anstelle der Variable erscheinen soll, aus bzw. kopieren Sie ihn.

  2. Klicken Sie auf die Variable, die ersetzt werden soll, und wählen Sie diesen Menübefehl.


SYMBOLIK / VARIABLE / DIFFERENZIEREN

Differenziert den gesamten Ausdruck in bezug auf die ausgewählte Variable. Alle anderen Variablen werden als Konstanten behandelt.


SYMBOLIK / VARIABLE / INTEGRIEREN

Integriert den gesamten Ausdruck in bezug auf die ausgewählte Variable.


SYMBOLIK / VARIABLE / REIHENENTWICKLUNG...

Leitet eine Potenzreihe für einen Ausdruck in bezug auf eine Variable ab, die Sie im Ausdruck markieren. In einem Dialogfeld können Sie die Reihenfolge der Reihe bestimmen.


SYMBOLIK / VARIABLE / PARTIALBRUCHZERLEGUNG

Generiert eine Partialbruchzerlegung für einen Ausdruck. Wird eine solche Zerlegung gefunden, so sind die Nenner in der ausgewählten Variable linear oder Zweierpotenzen.


SYMBOLIK / MATRIX / TRANSPONIEREN

Vertauscht in der ausgewählten Matrix die Zeilen und Spalten.


SYMBOLIK / MATRIX / INVERTIEREN

Gibt die reziproke Matrix der ausgewählten quadratischen Matrix aus.


SYMBOLIK / MATRIX / DETERMINANTE

Gibt die Determinante der ausgewählten quadratischen Matrix aus.


SYMBOLIK / TRANSFORMATION / FOURIER

Berechnet die Fourier-Transformation für einen Ausdruck in bezug auf die im Ausdruck markierte Variable.


SYMBOLIK / TRANSFORMATION / FOURIER INVERS

Berechnet die reziproke Fourier-Transformation für einen Ausdruck in bezug auf die im Ausdruck markierte Variable.


SYMBOLIK / TRANSFORMATION / LAPLACE

Berechnet die Laplace-Transformation eines Ausdrucks in bezug auf die im Ausdruck markierte Variable.


SYMBOLIK / TRANSFORMATION / LAPLACE INVERS

Berechnet die reziproke Laplace-Transformation eines Ausdrucks in bezug auf die im Ausdruck markierte Variable.


SYMBOLIK / TRANSFORMATION / Z

Berechnet die Z-Transformation eines Ausdrucks in bezug auf die im Ausdruck markierte Variable.


SYMBOLIK / TRANSFORMATION / Z INVERS

Berechnet die reziproke Z-Transformation eines Ausdrucks in bezug auf die im Ausdruck markierte Variable.


SYMBOLIK / AUSWERTUNGSFORMAT...

Legt fest, wo Symbolergebnisse angegeben werden. Sie haben folgende Möglichkeiten:

Das Ergebnis kann mit oder ohne Kommentar unter den ausgewählten Ausdruck gesetzt werden.

Das Ergebnis kann mit oder ohne Kommentar rechts neben den ausgewählten Ausdruck gesetzt werden.

Der ausgewählte Ausdruck kann durch das Ergebnis ersetzt werden.


ANSICHT / BEREICHE

Hebt alle Bereiche in Feldern hervor, so daß erkennbar ist, wie groß diese sind und wo sich deren Ankerpunkte befinden.

Um die normale Arbeitsblattansicht wiederherzustellen, wählen Sie den Befehl erneut.


ANSICHT / ZOOM...

Öffnet das Dialogfeld "Zoom", in dem Sie die Ansicht eines Arbeitsblatts vergrößern bzw. verkleinern können. Wollen Sie eine genauere Ansicht haben, wählen Sie einen Zoom-Wert über 100 %.

Sollen Teile eines Arbeitsblatts angezeigt werden, die derzeit außerhalb des Bildschirmbereiches liegen, bzw. wenn das gesamte Arbeitsblatt angezeigt werden soll, wählen Sie einen Zoom-Wert unter 100 %.


ANSICHT / AKTUALISIEREN

Baut den Bildschirm neu auf.


ANSICHT / ANIMIEREN...

Öffnet ein Dialogfeld, in dem Sie eine Animation erstellen können. Hierzu müssen Sie folgendes tun:

  1. Erstellen Sie ein Element, das von der Variable FRAME abhängt. In der Regel ist dies ein Ausdruck oder ein Diagramm mit der Variable FRAME.

  2. Wählen Sie diesen Menübefehl.

  3. Legen Sie den Arbeitsbereich, der animiert werden soll, durch Ziehen mit der Maus fest.

  4. Legen Sie im Dialogfeld den Anfangs- und den Endwert für FRAME fest.

  5. Klicken Sie auf "Animieren".

Nach der Erstellung der Animation wird ein neues Fenster angezeigt, in dem Sie die Animation wiedergeben können.


ANSICHT / WIEDERGEBEN...

Öffnet das folgende Fenster, in dem vorhandene Animationsclips abgespielt werden:


ANSICHT / EINSTELLUNGEN

Öffnet das Dialogfeld "Einstellungen". Auf der Registerkarte "Allgemein" können Sie folgende Einstellungen festlegen:

  • Einstellungen beim Starten des Programms

  • Festlegen, ob Sie mit den Standard-Windows-Tastaturkurzbefehlen, z. B. für "Drucken" und "Rückgängig", arbeiten wollen.

Auf der Registerkarte "Internet" können Sie die Verbindungseinstellungen zum Internet festlegen.


ANSICHT / SYMBOLLEISTEN

Blendet folgende Symbolleisten ein bzw. aus:

Standard-Symbolleiste

Symbolleiste "Formatierung"

Symbolleiste "Rechnen"

Symbolleiste "Arithmetisch"

Symbolleiste "Auswertung"

Symbolleiste "Diagramm"

Symbolleiste "Matrix"

Symbolleiste "Differential/Integral"

Symbolleiste "Programmierung"

Symbolleiste "Griechisch"

Symbolleiste "Symbolik"

Symbolleiste "Modifikator"

Welche Funktion die jeweiligen Schaltflächen einer Symbolleiste haben, sehen Sie, wenn Sie mit dem Cursor auf das Haupt-Arbeitsblattfenster gehen und ihn so lange über der entsprechenden Schaltfläche verweilen lassen bis:

  • ein QuickInfo (kleines Popup-Fenster) mit der Bezeichnung der Schaltfläche erscheint, und

  • in der Meldungszeile der Statusleiste eine Beschreibung der Schaltfläche angezeigt wird.


FENSTER / ÜBERLAPPEND

Ordnet die inaktiven Arbeitsblattfenster so hinter dem aktiven Fenster an, daß ihre Titelleisten sichtbar bleiben.


FENSTER / NEBENEINANDER

Ordnet alle Arbeitsblattfenster so an, daß sie:

das Anwendungsfenster vollständig ausfüllen und

nebeneinander angezeigt werden, ohne sich dabei zu überschneiden.


FENSTER / UNTEREINANDER

Ordnet alle Arbeitsblattfenster so an, daß sie:

das Anwendungsfenster vollständig ausfüllen und

untereinander angezeigt werden, ohne sich dabei zu überschneiden.


FENSTER / SYMBOLE ANORDNEN

Arrangiert die Titelleisten aller minimierten Arbeitsblätter, die in der linken unteren Ecke des Anwendungsfensters erscheinen, so daß diese ein sauberes Bild ergeben.


Fenster / Liste der geöffneten Fenster

FENSTER / LISTE DER GEÖFFNETEN ARBEITSBLÄTTER

Alle geöffneten Arbeitsblätter werden im Menü "Fenster" aufgelistet. Das Fenster mit dem Häkchen an der Seite ist das aktive Arbeitsblatt. Wenn Sie ein anderes Arbeitsblatt zum aktiven Arbeitsblatt machen wollen, klicken Sie auf das entsprechende Arbeitsblatt in der Liste.


FENSTER / WEITERE FENSTER

Öffnet ein Dialogfeld mit der vollständigen Liste der geöffneten Arbeitsblätter. Dieser Menübefehl ist nur dann verfügbar, wenn mehr als zehn Arbeitsblätter geöffnet sind. Klicken Sie in der Liste auf das Arbeitsblatt, das Sie zum aktiven Arbeitsblatt machen möchten.


Buchstaben

Bei Namen wird nach Groß-/Kleinschreibung und nach der Schriftart unterschieden. Auch die Größe sowie der Stil sind Kriterien. Zum Beispiel beziehen sich ein fettgedrucktes F und ein kursives F auf unterschiedliche Variablen.

Alle Zeichen in einem Namen müssen dieselbe Schriftart haben. Lateinische und griechische Buchstaben können jedoch im selben Namen verwendet werden.


Ziffern in Variablennamen

Die Ziffern 0 bis 9 können außer als Anfangszeichen überall in einem Namen erscheinen. So ist z. B. der Name 'x2' zulässig, der Name '2x' dagegen nicht.


SYMBOL FÜR UNENDLICHKEIT

Um das Symbol für Unendlichkeit einzufügen, drücken Sie die Tastenkombination STRG+Z.


Literalindizes

LITERALINDEXOPERATOR

Eingabe eines Literalindex wie

vinit

  1. Geben Sie den ersten Teil des Namens (v) ein, d. h. den Teil vor der Tiefstellung.

  2. Geben Sie einen Punkt ein. Die Einfügemarke wird um eine halbe Zeile nach unten erweitert.

  3. Geben Sie die zweite Hälfte des Namens ein, also den Teil, der tiefgestellt werden soll (init).

Verwechseln Sie Literalindizes nicht mit Feldindizes. Sie wirken zwar ähnlich, sind jedoch grundverschieden.


Homepage

Dies ist die URL für eine von MathSoft verwaltete Web-Seite, die Arbeitsblätter und verwandte Dokumente enthält, die von Benutzern der MathSoft-Produkte in der ganzen Welt bereitgestellt wurden.


In zwei Fällen müssen Sie einen Proxy-Server festlegen:

Wenn Sie über keinen direkten Internet-Anschluß verfügen.

Wenn Sie ein anderes Protokoll als http verwenden möchten.


PROTOKOLL

Die "Sprache", die Sie für die Kommunikation mit der Außenwelt verwenden möchten. Die Wahlmöglichkeiten sind:

HTTP

ftp

gopher


DIALOGFELD "INHALTE EINFÜGEN"

Klicken Sie auf die verschiedenen Teile der folgenden Dialogfeld-Abbildung, um nähere Informationen zu den einzelnen Elementen zu erhalten:


Als Symbol

Zeigt das Objekt als Symbol an.


Welche Optionen in dieser Liste zur Verfügung stehen, hängt von dem Objekt ab, das Sie zuletzt in die Zwischenablage kopiert haben. Es sind folgende Einträge möglich:

BITMAP

Mathcad

Bild

Rich Text Format

Text

Dokument aus dem Anwendungsprogramm, in dem das Objekt kopiert wurde


Verknüpfung einfügen

Verknüpft ein Objekt von einem OLE-Server mit Ihrem Arbeitsblatt. Änderungen an einer verknüpften Grafik wirken sich sowohl auf die Kopie in Mathcad als auch auf das Original aus.

Diese Option ist nur verfügbar, wenn ein Objekt aus einer gespeicherten Datei kopiert wurde.


Einfügen

Bettet ein Objekt aus einem OLE-Server in Ihr Arbeitsblatt ein. Wenn ein Objekt eingebettet ist, wirken sich am Objekt vorgenommene Änderungen nur auf die Kopie im Mathcad-Arbeitsblatt aus. Das Ausgangsobjekt wird nicht verändert.


DIALOGFELD "VERKNÜPFUNGEN"

Klicken Sie auf die verschiedenen Teile der folgenden Dialogfeld-Abbildung, um nähere Informationen zu den einzelnen Elementen zu erhalten:


DIALOGFELD "ERGEBNISFORMAT"

Im Dialogfeld "Ergebnisformat" finden Sie die folgenden Optionen und Schaltflächen:

Angezeigte Genauigkeit

Mit dieser Option können Sie festlegen, wie viele Stellen rechts vom Dezimalzeichen angezeigt werden sollen. Dies wirkt sich nur auf die Anzeige aus. Berechnungen werden stets mit voller Genauigkeit durchgeführt, ohne daß sich die Anzahl der im Ergebnis anzuzeigenden Stellen in irgendeiner Weise auswirkt.

So wird z. B. die Zahl 123.5654 wie folgt angezeigt:

Angezeigte Genauigkeit | Ergebnis
1 | 123.6
32 | 123.57
3 | 123.565
4 | 123.5654
3 | 123.5654

Der Wert für "Angezeigte Genauigkeit" muß zwischen 0 und 15 liegen. Der Standardwert ist "3".

Nachfolgende Nullen anzeigen

Legt fest, ob Ergebnisse rechts vom Dezimalzeichen mit Nullen aufgefüllt werden sollen, um den unter "Angezeigte Genauigkeit" festgelegten Wert zu erreichen.

Wenn Sie z. B. für "Angezeigte Genauigkeit" den Wert "3" festgelegt haben, wird "3/2" als "1.5" angezeigt, solange "Nachfolgende Nullen anzeigen" nicht aktiviert ist. Wird die Option aktiviert, erscheint dieselbe Zahl als "1.500".

Exponentialschwelle

Mit dieser Option können Sie festlegen, wie groß der absolute Werte einer Zahl sein muß, bevor die Zahl in Exponentialschreibweise angezeigt wird.

Beispiele:

Exponentialschwelle | Ergebnis
3 | 1.123581*10^6
7 | 1.123581*10^6
7 | 1123581

Der Wert für "Exponentialschwelle" muß zwischen 0 und 15 liegen. Der Standardwert ist "3". Dies bedeutet, daß alle Zahlen außerhalb der Intervalle [.001, 1000] und [-1000,-.001] in Exponentialschreibweise angezeigt werden.

Komplexe Schwelle

Hiermit wird festgelegt, um wieviel größer der reelle oder imaginäre Teil einer Zahl sein muß, bevor die Anzeige des kleineren Teils unterdrückt wird.

So wird die Zahl 1+0.002i bei unterschiedlichen Werten für "Komplexe Schwelle" wie folgt angezeigt:

Komplexe Schwelle | Ergebnis
32 | 1
3 | 1+.002i
4 | 1+.002i

Der Wert für "Komplexe Schwelle" muß eine ganze Zahl zwischen 0 und 63 sein. Der Standardwert ist "10". Das bedeutet, daß z als reine reelle Zahl angezeigt wird, wenn gilt:

z wird als reine imaginäre Zahl dargestellt, wenn gilt:

Nullschwelle

Mit dieser Option legen Sie fest, wie nah ein Ergebnis an Null liegen muß, bevor es als Null angezeigt wird. So wird die Zahl 0.0001215 mit unterschiedlichen Werten für die Null-Toleranz wie folgt angezeigt:

Null-Toleranz | Angezeigtes Ergebnis
32 | 0
3 | 0
4 | .000125
3 | .000125

Der Wert für "Null-Toleranz" muß zwischen "0" und "307" liegen. Der Standardwert ist "15". Das bedeutet, daß Zahlen kleiner als [image] als Null dargestellt werden.

Dies kann jedoch nur festgelegt werden, wenn die Option "Als Standard einrichten" aktiviert ist.

Radix

Mit dieser Option legen Sie fest, ob eine Nummer als binäre Zahl (Basis 2), oktale Zahl (Basis 8), hexadezimale Zahl (Basis 16) oder Dezimalzahl (Basis 10) dargestellt wird.

Hinter binären, hexadezimalen und oktalen Zahlen erscheint der Buchstabe "b", "h" bzw. "o", um eine Verwechslung mit Dezimalzahlen auszuschließen. (Mathcad kann hexadezimale oder oktale Zahlen, die größer als 2^31 sind, nicht präzise anzeigen.)

Imaginärer Wert

Mit dieser Option können Sie festlegen, ob die berechneten Ergebnisse, die einen Imaginärteil enthalten, mit 'i' oder mit 'j' dargestellt werden.

Diese Einstellung steuert nur die Anzeige von berechneten Ergebnissen. Sie können weiterhin entweder 'i' oder 'j' verwenden, wenn Sie eine imaginäre Zahl eingeben.

Dies kann jedoch nur festgelegt werden, wenn die Option "Als Standard einrichten" aktiviert ist.

Matrix-Anzeigeformat

Gibt an, ob ein Feld in einer Ausgabetabelle oder in Matrixform angezeigt wird.

  • Wählen Sie "Matrix", wenn das Ergebnis in Matrixform angezeigt werden soll.

  • Wählen Sie "Tabelle", wenn das Feld als Ausgabetabelle erscheinen soll.

  • Wählen Sie "Automatisch", wenn das Feld, je nach Größe, als Tabelle oder als Matrix ausgegeben werden soll. Hat das Feld mehr als 10 Zeilen oder Spalten, erscheint eine Tabelle. Andernfalls erfolgt die Ausgabe als Matrix.

Verschachtelte Matrizen erweitern

Wenn Sie diese Option aktivieren, werden Felder innerhalb von Feldern ebenfalls vollständig angezeigt. Beispiel:

Einheiten formatieren

Wenn Sie diese Option aktivieren, wird die Anzeige der Einheiten so formatiert, daß sie eher der gebräuchlichen Schreibweise entspricht. Beispiel: Aus "sec-1 " wird "1/sec".

Einheiten eventuell vereinfachen

Mit dieser Option können Sie dafür sorgen, daß die einfachste Einheit verwendet wird. Beispiel: Aus "kg*m/sec2 " wird durch die Vereinfachung "N" (Newton).

Als Standard einrichten

Wenn diese Option aktiviert ist, werden sämtliche aktuellen Einstellungen im Dialogfeld auf alle Ergebnisse im Arbeitsblatt angewendet. Die Bereiche "Nullschwelle" und "Imaginärer Wert" sind abgeblendet, da sie nur für alle Ergebnisse geändert werden können, die nicht anderweitig formatiert wurden.

Wird diese Option nicht aktiviert, gelten die von Ihnen vorgenommenen Einstellungen nur für das gegenwärtig ausgewählte Ergebnis.

Ist gegenwärtig kein Ergebnis ausgewählt, steht diese Option nicht zur Verfügung.


Imaginäre Einheit

Hiermit wird festgelegt, ob Ergebnisse von Berechnungen mit einem imaginären Teil mit 'i' oder 'j' angezeigt werden.

Diese Einstellung steuert nur die Anzeige von berechneten Ergebnissen. Sie können weiterhin entweder 'i' oder 'j' verwenden, wenn Sie eine imaginäre Zahl eingeben.

Diese Festlegung ist nur möglich, wenn im Dialogfeld die Optionsschaltfläche "Als Standard für Arbeitsblatt einrichten" aktiviert ist.


ANZEIGEN VON FELDERGEBNISSEN IN EINER AUSGABETABELLE

Eine Möglichkeit, Feldergebnisse anzeigen zu lassen, ist die Ausgabetabelle:

Ausgabetabellen verfügen über die folgenden Eigenschaften:

  • Sofern sich die Ergebnisse über einen Rand der Tabelle hinaus erstrecken, wird am entsprechenden Rand eine Bildlaufleiste angezeigt.

  • Damit alle Werte sichtbar werden, können Sie die Größe einer Ausgabetabelle ändern.

  • Sie können Werte aus einer Ausgabetabelle kopieren und an einem freien Platz auf Ihrem Arbeitsblatt, in einen Platzhalter oder in eine andere Anwendung einfügen.

  • Werte, die in einer Ausgabetabelle angezeigt werden, können Sie auch in eine externe Datendatei exportieren.

  • Andere Aspekte einer Ausgabetabelle, wie z. B. die Art und Weise, in der die Werte angezeigt werden, können Sie festlegen, wenn Sie auf die entsprechende Ausgabetabelle klicken und den Befehl Ergebnis im Menü Format wählen.

  • Wenn Sie auf eine Zelle mit der Notation für verschachtelte Felder klicken, wird das verschachtelte Feld temporär in einer Ausgabetabelle angezeigt.

  • Die Ausrichtung einer Ausgabetabelle in bezug auf den Variablennamen links können Sie ebenfalls selbst festlegen.

  • Wenn Sie die Schriftart ändern wollen, in der die Werte in der Tabelle angezeigt werden, klicken Sie mit der rechten Maustaste auf die Tabelle, wählen Sie den Befehl Eigenschaften im Kontextmenü, und klicken Sie auf "Schriftart".

  • Um die Zeilen- und Spaltenbeschriftungen ein- bzw. auszublenden, klicken Sie mit der rechten Maustaste auf die Tabelle, wählen Sie den Befehl Eigenschaften im Kontextmenü, und klicken Sie auf "Spalten-/Zeilenbeschriftungen anzeigen".


Ein numerisches Ergebnis wird rechts vom Gleichheitszeichen "=" angezeigt.

NUMERISCHES ERGEBNIS

Ein numerisches Ergebnis wird rechts vom Gleichheitszeichen "=" angezeigt.


AUSWÄHLEN VON WERTEN AUS EINER AUSGABETABELLE

Zum Auswählen aller Werte in einer Ausgabetabelle gehen Sie wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Tabelle.

  2. Wählen Sie Alles markieren im Kontextmenü.

Zum Auswählen einer Gruppe von Werten aus einer Ausgabetabelle gehen Sie wie folgt vor:

  1. Klicken Sie auf die erste Zahl, die kopiert werden soll.

  2. Halten Sie die Maustaste gedrückt, und ziehen Sie die Maus in die Richtung der anderen Werte, die kopiert werden sollen.

Auswählen aller Werte in einer Zeile oder Spalte:

  1. Klicken Sie auf die Zeilen- oder Spaltenzahl, die links neben der Zeile oder oben in der Spalte angezeigt wird.

  2. Nebeneinanderliegende Zeilen oder Spalten wählen Sie aus, indem Sie den Mauszeiger bei gedrückter Maustaste über die Zeilen- bzw. Spaltenindizes ziehen.

Die ausgewählten Werte werden andersfarbig unterlegt, um anzuzeigen, daß sie ausgewählt wurden.


Einen Wert in einer Ausgabetabelle mit Bildlaufleiste wählen Sie aus, indem Sie einmal auf ihn klicken. Der

 ausgewählte Wert wird in Umkehrdarstellung hervorgehoben.


Verschachtelte Felder

Die folgende Abbildung zeigt verschachtelte Felder in Ergebnissen.


Hauptwert

Allgemein gibt es für jede Zahl n n-te Wurzeln. Für die Zahl 4 gibt es beispielsweise zwei gleichermaßen gültige Quadratwurzeln, nämlich 2 und -2.

Da aber nur einer dieser Werte zurückgegeben werden kann, muß es eine Möglichkeit geben zu wählen, welcher Wert zurückgegeben werden soll. Dazu wird der Hauptwert genommen, also der Wert mit dem kleinsten komplexen Argument. Da das Argument von 2 den Wert 0 und das von -2 den Wert [image] /2 hat, ist das Ergebnis 2. Dies ist zufällig auch die reelle Wurzel.


Binäroperator

Ein Operator mit zwei Operanden. Beispielsweise gilt "+" als Binäroperator, da er stets zwei Operanden miteinander verbindet, also "x + y". Hier sind x und y die beiden Operanden.


Einstelliger Operator

Ein Operator mit einem Operanden. Beispielsweise ist der Operator für die Fakultät, "!", ein einstelliger Operator, da er nach dem Muster "n!" verwendet wird. Hier ist n der Operand.

Die Quadratwurzel und die konjugiert komplexe Zahl sind weitere Beispiele für einen einstelligen Operator.


PRÄFIX-NOTATION

Mit der Präfix-Notation kann ein einstelliger Operator angezeigt werden. Bei der Präfix-Notation erscheint der Operator vor dem Operanden. Beispiel:


SUFFIX-NOTATION

Mit der Suffix-Notation kann ein einstelliger Operator angezeigt werden. Bei der Suffix-Notation erscheint der Operator nach dem Operanden. Beispiel:


SCHALTFLÄCHEN AUF DER SYMBOLLEISTE DER BENUTZERDEFINIERTEN OPERATOREN

Infix-Operator:

Suffix-Operator:

Präfix-Operator:

Baum-Operator:


INFIX-NOTATION

Mit der Infix-Notation kann ein Binäroperator angezeigt werden. Bei der Infix-Notation erscheint der Operator zwischen den Operanden. Beispiel:


BAUM-NOTATION

Die Baum-Notation ist eine weitere Art, Binäroperatoren anzuzeigen. Bei der Baum-Notation werden der Operator und die mit ihm verknüpften Operanden in einer Baumstruktur, wie unten dargestellt, angeordnet.


Standardachsenbegrenzungen der radialen Achse

Standardbegrenzungen der radialen Achse

Bei linearer Skalierung:

Als Obergrenze gilt der höchstmögliche radiale Wert der abgebildeten Funktion.

Die Untergrenze auf einer linearen Skala ist Null.

Bei logarithmischer Skalierung:

Als Obergrenze gilt die nächste Ganzzahlpotenz von Zehn über dem Höchstwert der Daten.

Als Untergrenze gilt die nächste Ganzzahlpotenz von Zehn unter dem Mindestwert der Daten.


Autom. Skalierung

Jedes Diagramm, das Sie erstellen, wird standardmäßig automatisch skaliert. Wenn "Autom. Skalierung" aktiviert ist, wird für jede Achsenbegrenzung die erste Hauptskalenmarkierung hinter dem Ende der Daten festgelegt.

Ist das Kontrollkästchen "Autom. Skalierung" nicht aktiviert, endet die Achse direkt mit dem letzten Datenpunkt. Deaktivieren Sie "Autom. Skalierung", wird das Diagramm bis zum Rand des Diagrammbereichs gezeichnet:

Klicken Sie auf das Kontrollkästchen "Autom. Skalierung" für eine Achse, wenn Sie sie deaktivieren möchten.


Als Standard verwenden

Hiermit können Sie die derzeitigen Diagrammformateinstellungen als Standard für alle ab diesem Zeitpunkt erstellten Kreisdiagramme festlegen.


Standardwerte wiederherstellen

Hiermit können Sie für alle Einstellungen im derzeit ausgewählten Kreisdiagramm die Standardwerte wiederherstellen.


Zusätzliche Seiten

Es folgt ein Beispiel für ein Arbeitsblatt, bei dem eine leere Seite gedruckt werden würde.


Optionen im Fenster "Seitenansicht"

Fenster "Seitenansicht"

Klicken Sie auf die verschiedenen Teile der folgenden Illustration, um Informationen zu deren Funktion zu erhalten.:


Drucken

Druckt Ihr Arbeitsblatt.


Nächste

Zeigt die nächste Seite Ihres Arbeitsblatts in der Seitenansicht an. Wenn diese Option abgeblendet dargestellt ist, verfügt Ihr Arbeitsblatt über keine weiteren Seiten.


Vorherige

Zeigt die vorhergehende Seite Ihres Arbeitsblatts in der Seitenansicht an. Wenn diese Option abgeblendet dargestellt ist, verfügt Ihr Arbeitsblatt über keine vorhergehenden Seiten.


Vergrößern

Vergrößert einen Teil Ihres Arbeitsblatts. Es gibt insgesamt zwei Vergrößerungsstufen.


Verkleinern

Macht alle Vergrößerungen rückgängig, so daß Sie Ihr Arbeitsblatt wieder in der von der Option "Seitenansicht" verwendeten normalen Größe sehen.


Zwei Seiten / Eine Seite

Schaltflächen, mit denen Sie zwischen den Optionen "Zwei Seiten" und "Eine Seite" hin- und herschalten können. Klicken Sie auf "Zwei Seiten", um zwei Seiten Ihres Arbeitsblatts gleichzeitig anzeigen zu lassen. Klicken Sie auf "Eine Seite", um sich nur eine Seite anzeigen zu lassen.


Schließen

Schließt das Fenster "Seitenansicht". Es erscheint wieder das Arbeitsblatt-Fenster.


Zoom-Cursor

Vergrößert den Teil Ihres Arbeitsblatts, über dem sich der Cursor befindet, wenn Sie mit der rechten Maustaste klicken. Um Ihr Arbeitsblatt in noch höherer Vergrößerung anzeigen zu lassen, können Sie nochmals mit der Maus klicken. Wenn Sie die maximale Vergrößerung erreicht haben und wiederum auf das Arbeitsblatt klicken, wird die Vergrößerung Ihres Arbeitsblatts wieder rückgängig gemacht.


Operator "+1 Zeile"

Operator "+1 Zeile" (nur Mathcad Professional)

Erstellt eine neue Zeile innerhalb eines Programms bzw. erstellt ein Unterprogramm, wenn "+1 Zeile" in den Platzhalter links von einem Operator wie "if" eingefügt wird.

Tastaturbefehl: ]


Lokaler Zuordnungsoperator

Lokale Zuordnung über den lokalen Zuordnungsoperator (nur Mathcad Professional)

Tastaturbefehl {

Mit diesem Operator definierte Variablen sind nur innerhalb des Programms definiert.


Programmieroperator "If"

"If"-Operator (nur Mathcad Professional)

Fügt eine "If"-Anweisung in ein Programm ein, um einen bedingten Vorgang durchzuführen.

Tastaturbefehl: }


Programmieroperatoren

+ 1 Zeile

while

otherwise

continue

local assignment

for

return

if

break

on error


DATEINAME

Dies ist der Name einer ASCII-Datei (im aktuellen Arbeitsverzeichnis), der als Zeichenfolge (durch Drücken von “) eingegeben wird. Beispiel:

PRNLESEN("höhe.prn") liest aus der Datei "höhe.prn" im aktuellen Arbeitsverzeichnis.

Wenn Sie Ein-/Ausgabevorgänge mit einer Datei durchführen möchten, die sich nicht im aktuellen Standardverzeichnis befindet, müssen Sie den Pfadnamen für die Datei als Zeichenfolge eingeben. Beispiel:

PRNLESEN(“c:\windows\daten\höhe.prn”) liest aus der Datei "höhe.prn" im Verzeichnis "c:\windows\daten".


Folge von Werten

Bereichsvariablen und die Wertefolgen, die sie annehmen können

Beispiele:

1,2..20 ergibt 1, 2, 3 ...20

20,19,..1 ergibt 20, 19, 18 ...1

1,1.1..5 ergibt 1, 1.1, 1.2 ...5

5,3..-7 ergibt 5, 3, 1, -1 ...-7

Um den zweifachen Punkt (..) zu erhalten, geben Sie immer einen Strichpunkt (;) ein.


Werte in Eingabetabellen zulässig

Werte in Eingabetabellen müssen aus den folgenden Kategorien stammen:

Zahl (oder Ausdruck, der eine Zahl ausgibt).

Feld (oder Ausdruck, der ein Feld ausgibt).

Alle Werte in einer Eingabetabelle müssen die gleiche Einheit aufweisen.


Geben Sie nicht mehr Zahlen ein, als Werte für die Bereichsvariable möglich sind.

Wenn Sie zum Beispiel die Bereichsvariable

M := 0..8

definieren, geben Sie nicht mehr als neun Werte in die Tabelle ein.


Nichtsinguläre Matrizen

Eine Matrix ist nichtsingulär, wenn ihre Zeilen linear unabhängig sind. D. h., keine Zeile der Matrix ist eine lineare Kombination der anderen Zeilen.

Es kann vorkommen, daß eine Matrix fast singulär ist. In diesem Fall gibt es eine lineare Kombination der anderen Zeilen, die in einem sehr großen Maße eine der Zeilen reproduziert. Dies kann zu größeren Schwierigkeiten bei der numerischen Berechnung der Inversion der Matrix führen.


Wenn zwischen x und y die folgende Beziehung besteht:

Exponentielle Daten

Wenn zwischen x und y die folgende Beziehung besteht:

y = A*exp(k*x)

können Sie die Funktionen neigung und achsenabschn auf den Logarithmus Ihrer Datenwerte anwenden und dabei folgendes nutzen:

ln(y) = ln(A) + k*x

In diesem Fall gilt:

A = exp(achsenabschn(vx,ln(vy)) und k = neigung(vx,ln(vy))

Die sich ergebende Anpassung gewichtet die Fehler anders als eine Exponentialanpassung mit der Methode der kleinsten Quadrate, stellt aber im Normalfall eine gute Annäherung dar.


Weitere Regressionsmethoden:

Lineare Kombination von Funktionen

Lineare Regression

Polynomregression

Multivariable Polynomregression

Beliebige Funktionen an Daten anpassen


Die Funktion

Die Funktion Regress gibt einen Vektor zurück, dessen erste drei Elemente Werte sind, die von der Funktion interp verwendet werden. Die restlichen Elemente sind die Koeffizienten des am besten eingepaßten Polynoms k-ter Ordnung.


Format für RGB-Bilder

Dies müßte eine m x 3n-Matrix sein. Sie können sich eine solche Matrix als Aneinanderreihung von drei m x n-Matrizen vorstellen:

Die ersten n Spalten stehen für die rote Farbkomponente n x m-Bilds. Die zweiten und dritten n Spalten stehen für den Grün- und Blauanteil desselben Bilds.


Matrix-Format for BMPLESEN

Dies müßte eine m x n-Matrix sein, in der jedes Element einem Pixel entspricht. Die Elemente der Matrix sind Zahlen, die den Grauanteil für das jeweilige Pixel angeben.

Die verschiedenen Zahlen haben folgende Bedeutung:

0 steht für Schwarz und 255 für Weiß.

Zahlen zwischen 0 und 255 stehen für Graustufen.

Zahlen unter 0 und über 255 gelten als Modulo von 255.

Dezimalzahlen werden auf die nächste ganze Zahl gerundet.


Drehen eines Bilds


Invertieren eines Bilds


Erhöhen des Bildkontrasts


ANZEIGEN EINES MIT BMPLESEN ERSTELLTEN BILDS

Wenn Sie die Matrix, die das Bild enthält, mit BMPLESEN erstellt haben, können Sie das Bild folgendermaßen anzeigen:

Klicken Sie auf die gewünschte Position des Bildes, und wählen Sie den Befehl Bild aus dem Menü Einfügen.

Geben Sie den Namen der Matrix in den Platzhalter ein.


ANZEIGEN EINES MIT RGBLESEN ERSTELLTEN BILDS

Wenn Sie die Matrix, die das Bild enthält, mit RGBLESEN erstellt haben, lassen Sie das Bild anzeigen wie folgt:

Teilen Sie die Matrix in seine Rot-, Grün- und Blau-Anteile auf, wie im folgenden Beispiel gezeigt:

Klicken Sie auf die gewünschte Position des Bildes, und wählen Sie den Befehl Bild aus dem Menü Einfügen.

Geben Sie die Namen des Platzhalters ein. Soll nur eine Farbkomponente, zum Beispiel der Rotanteil, angezeigt werden, müssen nach wie vor alle drei Matrizen angegeben werden, wobei jedoch die Matrizen für Grün und Blau nur Nullwerte enthalten dürfen.

Wenn Sie die drei Untermatrizen später wieder kombinieren möchten, erstellen Sie die folgende Funktion, die auf der Funktion erweitern aufbaut, und wenden Sie sie an: erweitern(X,Y,Z):=erweitern(X,erweitern(Y,Z))


Achten Sie darauf, daß die Matrizen in der richtigen Reihenfolge eingegeben werden müssen. Wenn Sie die Reihenfolge vertauschen,

 werden auch die Farbanteile vertauscht. Dies wird unten im Beispiels auf dieser Seite gezeigt.


SPEICHERN EINES BILDS IN FARBE

Zum Speichern eines Farbbilds in einer Datei verwenden Sie die Funktion RGBSCHREIBEN oder eine andere Funktion wie folgt:

Stellen Sie sicher, daß die Matrix, die das Bild enthält, das richtige Format aufweist.

Geben Sie folgendes ein, und ersetzen Sie "A" und "datei" dabei durch den Matrixnamen- und den Namen der Datei, in die Sie schreiben:

RGBSCHREIBEN("datei"):=A

Beachten Sie, daß die Funktionen in GROSSBUCHSTABEN stehen müssen.

Starten eines QuickSheet-Beispiels


SPEICHERN EINES GRAUSTUFENBILDS

Zum Speichern eines Graustufenbilds in eine Datei verwenden Sie die Funktion BMPSCHREIBEN wie folgt:

Stellen Sie sicher, daß die Matrix, die das Bild enthält, das richtige Format aufweist.

Geben Sie folgendes ein, und geben Sie dabei den Matrixnamen und den Namen der Datei an, in die Sie schreiben:

BMPSCHREIBEN(" Datei ") := M

Beachten Sie, daß die Funktionen in GROSSBUCHSTABEN stehen müssen.

Starten eines QuickSheet-Beispiels


Diese Vorgehensweise bietet folgende Vorteile:

Vorteile einer Datei

Verweisen mehrere Arbeitsblätter auf dasselbe Bild, ist nur ein Exemplar dieses Bilds erforderlich.

Wenn Sie ein Bild in mehreren Arbeitsblättern verändern möchten, brauchen Sie nur eine Bilddatei zu ändern. Änderungen an jedem einzelnen Arbeitsblatt sind nicht erforderlich.


Dies ist der Name der Bitmap-Datei, in die RGSCHREIBEN die Daten einfügt. Ist bereits eine Datei dieses Namens vorhanden, so wird sie von RGBSCHREIBEN überschrieben.

RGBSCHREIBEN geht davon aus, daß sich diese Datei im Standardverzeichnis befindet. Soll die Datei in ein anderes Verzeichnis geschrieben werden, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


Dies ist der Name der Bitmap-Datei, in die BMPSCHREIBEN die Daten einfügt. Ist bereits eine Datei dieses Namens vorhanden, so wird sie von BMPSCHREIBEN überschrieben.

BMPSCHREIBEN geht davon aus, daß sich diese Datei im Standardverzeichnis befindet. Soll die Datei in ein anderes Verzeichnis geschrieben werden, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


Dies ist der Name der Datei, die das Bild enthält.

Befindet sich die Datei nicht im Standardverzeichnis, müssen Sie den vollständigen Pfad zu der betreffenden Datei eingeben.


Seitenverhältnis

Verhältnis zwischen Länge und Breite.


Verwandte Funktionen für das Lesen von Bildern

VERWANDTE FUNKTIONEN

RGBLESEN

BMPLESEN

RGBSCHREIBEN

BMPSCHREIBEN

Spezielle Funktionen zum Lesen von Bilddateien

Spezielle Funktionen zum Schreiben von Bilddateien


rt image processing

Bildverarbeitung

Einlesen des Bildes in eine Matrix

Durchführen mathematischer Transformationen an der Matrix

Anzeigen des Bildes

Speichern des Bildes


DIE SCHALTFLÄCHENLEISTE "SYMBOLIK"

Anstatt ein Schlüsselwort über die Tastatur einzugeben, können Sie auch auf die Schlüsselwortschaltfläche in der Schaltflächenleiste "Symbolik" klicken. Klicken Sie auf die Schaltfläche [image] in der Rechenpalette, um die Schaltflächenleiste "Symbolik" zu öffnen:

Wenn Sie auf eine Schlüsselwortschaltfläche klicken, wird das Schlüsselwort eingeblendet, das für jedes zulässige Argument einen Platzhalter enthält. Löschen Sie die Platzhalter der optionalen Argumente, die Sie nicht verwenden möchten.


Schlüsselwörter

annehmen

koeff

sammeln

komplex

konvert

entwickeln

faktor

gleit

fourier

invfourier

invlaplace

invztrans

laplace

reihe

vereinfachen

auflösen

ersetzen

ztrans


Die Funktion "medgltt"

Die Auswertung der Funktion medgltt(vy,n) beginnt mit dem gleitenden Mittelwert des Eingabevektors vy. Dieser soll vy' genannt werden. Das i-te Element ist gegeben durch:

Anschließend berechnet die Funktion die Reste: vr=vy - vy`

Der Restvektor, vr, wird mit dem in Schritt 1 beschriebenen Verfahren geglättet. Dadurch entsteht der geglättete Restvektor vr`.

Die Funktion medgltt gibt die Summe dieser beiden geglätteten Vektoren zurück:

medgltt(vy,n) = vy` + vr`.

Bei medgltt bleiben der erste und der letzte (n-1)/2 Punkt unverändert. In der Praxis muß die Länge des Glättungsfensters, n, im Vergleich zur Länge des Datensatzes klein sein.


Die Funktion "kgltt"

Die

Funktion "kgltt" verwendet zur Berechnung der lokalen gewichteten Mittel des

Eingabevektors vy einen Gaußschen Kern. Für jedes Element im aus n Elementen bestehenden Vektor vy gibt die Funktion kgltt ein neues vy`-Element zurück. Dies ergibt sich aus:

und b eine Bandbreite ist, die Sie für die Funktion kgltt festlegen. Für die Bandbreite wird normalerweise ein Vielfaches des Abstands zwischen den Datenpunkten auf der X-Achse festgelegt. Dies hängt jedoch davon ab, wie groß das Fenster für die Glättung sein soll.


Singuläre Matrix

Eine Matrix gilt als singulär, wenn ihre Determinante gleich null ist. Eine Matrix ist annähernd singulär, wenn sie eine hohe Bedingungszahl aufweist.


n ist der Index einer Zeile

n

muß eine ganze Zahl sein, die eine der Zeilen in Feld A indiziert.

FÜR STARTINDEX = 0 (STANDARD) MUSS N ZWISCHEN 0 UND EINSCHLIESSLICH ZEILEN(

A)-1 LIEGEN.


n ist der Index einer Spalte

n

MUSS EINE GANZE ZAHL SEIN, VON DER EINE DER SPALTEN IN DER ANORDNUNG A INDIZIERT

WIRD.

Für STARTINDEX = 0 (Standard) muß n zwischen 1 und einschließlichh spalten(A)-1 liegen.


INTERPOLATION IN MATHCAD

Um den Wert für ein bestimmtes x zu finden, sucht Mathcad die beiden Punkte, zwischen denen der Wert liegt, und gibt den entsprechenden y-Wert auf dem kubischen Abschnitt zwischen dem Punktepaar zurück.

Bei x-Werten vor dem ersten bekannten Datenpunkt extrapoliert Mathcad den kubischen Abschnitt zwischen den ersten beiden Datenpunkten.

Bei x-Werten nach dem letzten bekannten Datenpunkt extrapoliert Mathcad den kubischen Abschnitt zwischen den letzten beiden Datenpunkten.


Die ersten drei von kspline, lspline und pspline ausgegebenen Werte werden von der Funktion "interp" verwendet. Die übrigen Elemente sind Koeffizienten zweiter Ableitung. Verwenden

 Sie die Funktion submatrix, wenn Sie nur auf die zweiten Ableitungen zugreifen möchten.


Andere Funktionen für die Datenanalyse

Mittelwert

Median

Standardabweichung bei Populationen

Standardabweichung bei Stichproben

Varianz bei Populationen

Varianz bei Stichproben

Kovarianz

Korrelation


Wie interpoliert Mathcad linear?

Um den Wert für ein bestimmtes x zu finden, sucht Mathcad die beiden Punkte, zwischen denen der Wert liegt, und gibt den entsprechenden y-Wert auf dem Geradenabschnitt zwischen dem Punktepaar zurück.

Bei x-Werten vor dem ersten bekannten Datenpunkt extrapoliert Mathcad die Gerade zwischen den ersten beiden Datenpunkten.

Bei x-Werten nach dem letzten bekannten Datenpunkt extrapoliert Mathcad die Gerade zwischen den letzten beiden Datenpunkten.


In der Standardperspektive verläuft die erste Zeile der Matrix von der hinteren

 linken Ecke des Gitters nach rechts, während sich die erste Spalte von der hinteren linken Ecke hin zum Betrachter verläuft.


Ablegen langer Ergebnisse

 Zu langes Ergebnis. In Zwischenablage speichern?

Die Antwort ist für die Anzeige als formatierter Rechenbereich zu groß. Sie können die Antwort in der Zwischenablage ablegen.


 Syntaxfehler

Für gewöhnlich die Folge einer symbolischen Operation, die auf einen ungeeigneten oder falsch geschriebenen Ausdruck angewendet wurde. Diese Fehlermeldung erscheint auch bei der symbolischen Auswertung von Ausdrücken, die Einheiten enthalten.


 Ungültige Argumente

Der symbolische Prozessor kann die angeforderte Operation für die vorgegebenen Argumente nicht durchführen. Diese Fehlermeldung erscheint z. B. dann, wenn Sie einem Feld eine Skalarfunktion zuweisen, ohne den Vektorisieren-Operator zu verwenden, und den Befehl Vereinfachen aus dem Menü Symbolik wählen.


 Ungültige Funktionssyntax

Ein Ausdruck wie z. B. (f)(x) kann nicht symbolisch ausgewertet werden.


 Ausdruck enthält nicht-symbolische Operatoren

Sie versuchen, eine symbolische Operation auf einen Ausdruck anzuwenden, der Operator- oder Variablenplatzhalter enthält.


 Keine Antwort gefunden

Bei der symbolischen Auswertung konnte keine genaue Lösung für die Gleichung gefunden werden, die Sie zu lösen versuchten.


 Keine Antwort gefunden. Stapelgrenze erreicht.

Bei der symbolischen Auswertung wurde die Grenze des internen Ausdrucksstapels erreicht, ohne daß die eigentlich gewünschte Auswertung oder Vereinfachung durchgeführt werden konnte.


Keine geschlossene Form für . . . gefunden

 Keine geschlossene Form für ... gefunden.

Bei der symbolischen Auswertung konnte kein unbegrenztes Integral für den zu integrierenden Ausdruck bzw. keine geschlossene Form für die Summe oder das Produkt, die bzw. das ausgewertet werden sollte, gefunden werden.


 Bereichsfehler

Bei der Suche nach einer numerischen Lösung für eine Gleichung versuchte der symbolische Prozessor, eine der vordefinierten Funktionen an einem Punkt auszuwerten, der sich außerhalb der entsprechenden Domäne befindet.


 Gleitkommawerte werden nicht verarbeitet

Der Befehl Faktorisieren wurde auf einen Ausdruck angewendet, der Dezimalbrüche enthält.


 Argument zu groß

Argument zu groß
Ganze Zahl zu groß
Objekt zu groß

Im allgemeinen das Ergebnis der Auswertung eines Ausdrucks mit einem Gleitkommawert, der größer als ca. 10 hoch 10 Milliarden ist.


 Erwartet Feld oder Liste

Operatoren in dem Ausdruck, der vereinfacht oder ausgewertet werden soll, benötigen Vektor- oder Matrixoperanden.


Mathcad sucht nach Taylor-Reihen (Reihen in nichtnegativen Potenzen der Variablen).

TAYLOR- ODER LAURENT-REIHEN

Mathcad kann Taylorsche Reihen (Reihen in nichtnegativen Potenzen der Variable) für Funktionen ermitteln, die bei Null analytisch sind, sowie Laurentsche Reihen für Funktionen, die bei Null einen Pol endlicher Ordnung aufweisen.


AUSDRÜCKE IN EINER REIHENENTWICKLUNG

Ein Ausdruck wie O(x^6) weist darauf hin, daß der Fehler bei der Verwendung der gegebenen Glieder der Reihe als Näherungswert bei der Annäherung von x an 0 durch die Konstante mal x^6 begrenzt ist.


Obwohl beispielsweise ln(x) keine Entwicklung bei 0 aufweist, können Sie eine Serie für ln um 1 berechnen, indem Sie ln(1 x) um 0 entwickeln.

ÜBERTRAGEN EINER VARIABLE

Obwohl beispielsweise ln(x) keine Entwicklung bei 0 aufweist, können Sie eine Serie für ln um 1 berechnen, indem Sie ln(1 [image] x) um 0 entwickeln.


Ziel des symbolischen Rechnens

Über symbolisches Rechnen erhalten Sie eine Antwort nicht numerischer Natur auf ein Problem.


Besonderheiten des symbolischen Rechnens

Das symbolische Rechnen bietet unter anderem folgende Vorzüge:

Die Beziehungen zwischen Variablen werden explizit wiedergegeben.

Die Ergebnisse sind unabhängig von Rundungsfehlern, numerischer Instabilität und anderen Problemen bei der numerischen Berechnung.

Folgende Nachteile können beim symbolischen Rechnen auftreten:

Die entstehenden Ausdrücke können sehr kompliziert werden.

Die genaue Form der Antwort ist oft schwer zu beeinflussen.


Symbolische Vereinfachung

Beispiel für symbolisches Rechnen:

3x - 2x

wird vereinfacht zu: x

Für die gleiche Aufgabe werden beim numerischen Rechnen (also nach der Eingabe eines Gleichheitszeichens) folgende Ergebnisse angezeigt:

Eine Fehlermeldung, falls x undefiniert ist oder

Der Wert von x, wenn x definiert ist.


VOLLSTÄNDIGES BZW. TEILWEISES AUSWÄHLEN EINES AUSDRUCKS

Wie signifikant das ist, was Sie jeweils auswählen, hängt davon ab, welchen Menübefehl Sie wählen. Meistens wird nur das transformiert, was sich zwischen den Bearbeitungslinien befindet. In bestimmten Fällen transformieren Sie den gesamten Ausdruck; allerdings erfährt das, was Sie auswählen, stets eine besondere Behandlung. Wenn Sie zum Beispiel über Operatoren ableiten, bilden Sie die Ableitung des gesamten Ausdrucks über die ausgewählten Elemente.


Erfolglose symbolische Transformation

Es gibt eine Reihe von Gründen dafür, daß bestimmte symbolische Transformationen nicht erfolgreich verlaufen. Sie haben möglicherweise versucht, einen Ausdruck zu faktorisieren, bei dem dies nicht möglich ist, oder einen Ausdruck zu vereinfachen, der nicht sinnvoll vereinfacht werden kann.


Sie können einen Ausdruck auswählen, indem Sie auf ihn klicken und die Leertaste so lange drücken, bis er sich zwischen den Bearbeitungslinien befindet. Zum Auswählen von Teilausdrücken müssen Sie möglicherweise Klammern einfügen

AUSWÄHLEN EINES AUSDRUCKS

Sie wählen einen Ausdruck aus, indem Sie auf ihn klicken und die Leertaste so lange drücken, bis er sich zwischen den Bearbeitungslinien befindet.

Zur Auswahl eines Teilausdrucks müssen Sie diesen in runde Klammern setzen, bevor Sie ihn auswählen können.


Zur Auswahl einer Variable klicken Sie auf die Variable, damit die Bearbeitungslinien in den Variablennamen gesetzt werden.


Der Operator “@” bezeichnet eine Funktionszusammenstellung. Zum Beispiel entspricht (sin@exp)(x) genau sin(exp(x)). ”@@” steht für wiederholte Erstellung; (f@@2)(x) entspricht also f(f(x)).

Der Operator “@” steht für die Funktionserstellung. Zum Beispiel entspricht (sin@exp)(x) genau sin(exp(x)). ”@@” steht für wiederholte Erstellung; (f@@2)(x) entspricht also f(f(x)).


Die Ableitung von f(x) in bezug auf x wird als “diff(f(x),x)” notiert. Die n-te Ableitung lautet "diff(f(x),x$n)".

Das Integral von f(x) in bezug auf x wird als "int(f(x),x)" notiert.


Eingebettete Schriftartcodes wie “MFNT_03_” vor Variablennamen stehen für die Schriftart, in der der Variablenname angezeigt werden soll.


Es gibt keine geschlossene Lösung für die Wurzel. Diese Wurzel wird als Wurzel eines anderen Polynoms dargestellt.

Wenn das Ergebnis in der Zwischenablage erscheinen soll, erscheint das Polynom in der Form

ROOTOF(H(_Z)),

wobei h(_Z) ein Polynom ist, dessen Wurzel auch eine Wurzel des ursprünglichen Ausdrucks ist.


Fehlerfunktion

FÜR |Z| 4 IST EIN BEREICH VON N=0 BIS 100 ZU VERWENDEN.


Legendresches vollständiges elliptisches Integral der zweiten Art

Definieren Sie LegendreE(X,K).

Definieren Sie dann

LegendreEc(k) = LegendreE(1,k)


Zugeordnetes Legendresches vollständiges elliptisches Integral der zweiten Art

Definieren Sie LegendreEc(K).

Definieren Sie dann


Legendresches vollständiges elliptisches Integral der ersten Art

Definieren Sie LegendreF(X,K).

Definieren Sie dann

LegendreKc(k) = LegendreF(1,k)


Zugeordnetes Legendresches vollständiges elliptisches Integral der ersten Art

Definieren Sie LegendreKc(k).

Definieren Sie dann


Legendresches vollständiges elliptisches Integral der dritten Art

Definieren Sie LegendrePi(X,N,K).

Definieren Sie dann

LegendrePic(n,k) = LegendrePi(1,n,k)


Zugeordnetes Legendresches vollständiges elliptisches Integral der dritten Art

Definieren Sie LegendrePic(N,K).

Definieren Sie dann


Lambertsche W-Funktion

Dabei handelt es sich um die Inverse von [image].

Zur Berechnung von W(A) verwenden Sie [image].


Lambertsche W-Funktion, n-ter Zweig

Dabei handelt es sich um den N-ten Zweig von W(A), der Inverse von [image].


Inverse trigonometrische Funktionen

Diese Funktionen können mit den reziproken Werten und internen Mathcad-Funktionen wie ACOS, ASIN berechnet werden.

Zum Beispiel können Sie folgendes definieren:

ARCSEC(x) := ASEC(1/X)


Vorgehensweise

Symbolische Berechnungen können auf zweierlei Arten durchgeführt werden:

Sie verwenden das symbolische Gleichheitszeichen, so daß die Ergebnisse ständig aktualisiert werden. Diese Methode ähnelt äußerlich sehr der Durchführung numerischer Berechnungen.

Sie verwenden Menübefehle. Mit dieser Methode können Sie genauer festlegen, wie das Ergebnis der symbolischen Berechnung ausgegeben werden soll.


Sie werten Ausdrücke mit dem Befehl "Auswerten / Symbolisch" symbolisch aus.

In den meisten Fällen verwenden Sie den Befehl "Auswerten / Symbolisch" im Menü "Symbolik" für die symbolische Auswertung von Ausdrücken.


Mit dem Befehl "Auswerten / Komplex" können Sie Ausdrücke auswerten, die komplexe Zahlen enthalten. Mathcad geht folgendermaßen vor:

Sie können mit dem Befehl "Auswerten / Komplex" im Menü "Symbolik" Ausdrücke auswerten, die komplexe Zahlen enthalten. Das Ergebnis der Auswertung wird, wenn dies möglich ist, in der Form a+bi angezeigt.


Werten Sie Konstanten wie Pi mit Gleitkomma aus

Verwenden Sie den Befehl "Gleitkomma" im Menü "Symbolik" zum Auswerten von Konstanten wie Pi. Geben Sie die Anzahl der Ziffern rechts vom Dezimalzeichen in dem Dialogfeld an, das durch diesen Befehl aufgerufen wird. Der Standardwert ist 20.


Andere Transformationen

Fourier

Laplace

z

Laplace invers

Fourier invers

Z invers


Die folgenden vordefinierten Funktionen behalten auch bei symbolischer Verwendung ihre Bedeutung bei:

Trigonometrische und hyperbolische Funktionen und ihre Inversen

Logarithmus- und Exponentialfunktionen

Funktionen Re und Im

Funktion fehlf

Gammafunktion

Funktion mod

Heaviside-Sprungfunktion

Funktionen min und max

Funktionen einheit und eigenwerte

Im allgemeinen stimmt die Bedeutung dieser Funktionen bei numerischen Berechnungen und bei symbolischen Transformationen überein. In drei Punkten gibt es jedoch Unterschiede:

Im Unterschied zur numerischen Funktion mod benötigt die symbolische Funktion mod einen ganzzahligen absoluten Betrag und akzeptiert ein Polynom als erstes Argument.

Bestimmte symbolische inverse trigonometrische Funktionen verwenden in der komplexen Ebene unterschiedliche Zweige.

Mit der Funktion eigenwerte können sowohl komplexe als auch reelle Matrizen symbolisch ausgewertet werden.


Rechte Randlinien

Rechter Rand

Der rechte Rand wird durch eine vertikale grüne Linie im Arbeitsblatt angezeigt. Ihr Dokument kann zwei solcher Linien enthalten:

eine gepunktete vertikale Linie, deren Position davon abhängt, welchen Drucker Sie auswählen

eine durchgehende vertikale Linie, deren Position Sie über den Befehl Seite einrichten im Menü Datei festlegen können.

Während der Eingabe von Text in den Textbereich vergrößert dieser sich so lange, bis er auf eine dieser beiden senkrechten Linien stößt.


Hängender Einzug

Als hängender Einzug wird die erste Zeile eines Absatzes bezeichnet, wenn sie links über alle anderen Zeilen des Absatzes hinausragt.


Standardschriftart

Dies ist die Schriftart, die bei der Eingabe von Text in einen Textbereich zunächst angezeigt wird. Sie wird durch die Textformatvorlage "Normal" bestimmt.


ZEICHENWEISES AUSWÄHLEN VON TEXT

Positionieren Sie die Einfügemarke an einem Ende des auszuwählenden Textes.

Drücken Sie die Umschalttaste und eine Pfeiltaste.

Mathcad markiert die Zeichen des Textes entsprechend der Richtung des Pfeils auf der gedrückten Pfeiltaste.


WORTWEISES AUSWÄHLEN VON TEXT

Positionieren Sie die Einfügemarke an einem Ende des auszuwählenden Textes.

Drücken Sie Strg+Umschalt und die linke oder rechte Pfeiltaste.

Mathcad markiert den Text von der Einfügemarke bis zum Beginn des aktuellen bzw. nächsten Wortes in der Richtung des Pfeils auf der gedrückten Taste.


ZEILENWEISES AUSWÄHLEN VON TEXT

Positionieren Sie die Einfügemarke an einem Ende des auszuwählenden Textes.

Drücken Sie Strg+Umschalt und die Pfeil-nach-oben bzw. Pfeil-nach-unten-Taste.

Mathcad markiert den Text von der Einfügemarke bis zum Beginn oder Ende einer Zeile.


Bewegen mit Hilfe der Pfeiltasten

 Verwenden Sie die Pfeiltasten, um die Einfügemarke zeichenweise oder zeilenweise im Text zu verschieben. Wenn Sie die Strg-Taste und eine Pfeiltaste drücken, wird die Einfügemarke wortweise bzw. absatzweise verschoben.


Schriftart

Die Schriftart bezeichnet die Schriftartfamilie, in der der Text dargestellt ist.


Schriftgrad

Der Schriftgrad bezeichnet die Größe der Zeichen in Punkten.


Schriftschnitt

Der Schriftschnitt bezeichnet das momentane Aussehen innerhalb der Schriftfamilie. Beispiele für Schriftschnitte sind fett, kursiv und unterstrichen.


Position

Die Position gibt an, ob der Text auf der Grundlinie bleibt oder hoch- bzw. tiefgestellt wird.


AUSRICHTUNG

Textabsätze können entweder am linken oder rechten Rand des Textbereichs ausgerichtet oder im Textbereich zentriert werden.

Die Ausrichtung können Sie über die entsprechenden Schaltflächen im Dialogfeld "Absatzformat" oder über die drei Schaltflächen zur Ausrichtung [image] ganz rechts auf der Symbolleiste "Formatierung" steuern.


Linksbündiger Text

Klicken Sie auf diese Schaltfläche, um den gesamten Text in einem Textbereich am linken Rand des Bereichs auszurichten.


Rechtsbündiger Text

Klicken Sie auf diese Schaltfläche, um den gesamten Text in einem Textbereich am rechten Rand des Bereichs auszurichten.


EINZÜGE

Im Dialogfeld "Absatzformat" können Sie festlegen, ob und wie Absätze eingezogen werden sollen:

  • Sollen alle Zeilen eines Absatzes um denselben Betrag eingezogen werden, geben Sie unter "Einzug" in den Textfeldern "Links" und "Rechts" einen Wert ein.

  • Soll die erste Zeile um einen anderen Betrag als die anderen Zeilen eines Absatzes eingezogen werden, wählen Sie im Feld "Extra" die Option "Erste Zeile", und geben Sie im Textfeld "um" einen Wert ein.

  • Soll der Absatz mit einem hängenden Einzug versehen werden, wobei alle Zeilen außer der ersten eingezogen werden, wählen Sie die Option "Hängend" im Feld "Extras", und geben Sie im Feld "um" einen Wert ein.


Wenn Sie eine neue Textformatvorlage auf einer vorhandenen Textformatvorlage aufbauen, werden alle Einstellungsänderungen

 an der vorhandenen Vorlage, die sich auf das neue Textformat auswirken, in den Textbereichen mit dem neuen Format übernommen. Außerdem werden die Einstellungen der neuen Textformatvorlage aktualisiert, so daß die geänderten Einstellungen auch für Bereiche gelten, denen Sie die Vorlage erst später zuweisen.


Textformatvolagen, Definition

Textformatvorlagen

Eine Textformatvorlage ist ein Attribut, mit dem Text Schriftarten und Absatzeigenschaften zugewiesen werden können. Standardmäßig wird für Text das standardmäßige "normale" Textformat mit speziellen Text- und Absatzeigenschaften verwendet.


EINFÜGEN VON TEXT

Wenn Sie Einfügen im Menü Bearbeiten wählen, fügen Sie den zuletzt kopierten oder ausgeschnittenen Text ein. Dieser Text wird an der Position des Cursors eingefügt.


Kopieren von Text

Wenn Sie "Kopieren"

im Menü "Bearbeiten"

wählen, ersetzen Sie den Inhalt der Zwischenablage durch den Text, den Sie

ausgewählt haben.


Ausschneiden von Text

Wenn Sie Ausschneiden im Menü Bearbeiten wählen, geschieht folgendes:

Der Inhalt der Zwischenablage wird durch den ausgewählten Text ersetzt.

Der ausgewählte Text wird aus dem Arbeitsblatt entfernt.


Textbereich

Rechteckiger Bereich, der für die Eingabe von Text reserviert ist. Textbereiche können beliebig breit sein und sich an jeder beliebigen Stelle des Dokuments befinden.


Rechenbereich

Als Rechenbereich gilt ein Bereich mit einem mathematischen Ausdruck oder einem Diagramm. Rechenbereiche sind "aktiv" oder "live", d. h. alle Änderungen innerhalb des Bereichs wirken sich unmittelbar auf andere Rechenbereiche im gesamten Arbeitsblatt aus.


TEXTFELD

Dies ist das Rechteck, das um einen Textbereich gelegt wird, wenn sich die Einfügemarke im Bereich befindet. Wenn Sie auf eine Stelle außerhalb des Textbereichs klicken, wird das Textfeld wieder ausgeblendet.


Grundeinheiten

Grundaleinheiten

Die Grundeinheiten werden für die Grunddimensionen der Länge, Masse, Zeit, Ladung, Temperatur, Leuchtstärke (SI-Einheitensystem) und Stoff (SI-Einheitensystem) verwendet. Die Grundeinheiten sind in jedem Einheitensystem unterschiedlich.

Einheitensystem Grundeinheiten

MKS Meter (m), Kilogramm (kg), Sekunden (sec), Coloumb (coul), Kelvin (K)

CGS Zentimeter (cm), Gramm (gm), Sekunden (sec), Coloumb (coul), Kelvin (K)

US Fuß (ft), Pfund (lb), Sekunden (sec), Coloumb (coul), Kelvin (K)

SI Meter (m), Kilogramm (kg), Sekunden (s), Ampere (A), Kelvin (K), Candella (cd), Mol (mol)


Unabhängig vom gewählten System stehen Ihnen die meisten Einheiten (von einigen

 Ausnahmen abgesehen) zur Verfügung. Wenn beispielsweise CGS ausgewählt ist, können Sie dennoch auch kg und lb verwenden, auch wenn diese im engeren Sinn nicht zum CGS-Einheitensystem gehören.


Dialogfeld "Rechenoptionen": Registerkarte "Dimensionen"

DIALOGFELD "RECHENOPTIONEN"

Auf der Registerkarte "Dimensionen" des Dialogfelds "Rechenoptionen" finden Sie die folgenden Optionen und Schaltflächen:

Dimensionen anzeigen

Klicken Sie hierauf, wenn bei der Anzeige der Ergebnisse statt der Standardeinheiten die unter "Dimensionsnamen" festgelegten Dimensionsnamen verwendet werden sollen.

Dimensionsnamen

Nachdem Sie auf das Feld neben "Dimensionen anzeigen" geklickt haben, können Sie hier jeden beliebigen Dimensionsnamen eingeben. Die Dimensionsnamen erscheinen daraufhin in Ihren Ergebnissen, sofern diese Einheiten beinhalten.


nur in CGS

Nur in CGS verfügbar.

In SI, MKS und US nicht verfügbar.


nur in SI und US

Nur in SI und US verfügbar

Nicht in CGS oder MKS verfügbar.


Nur in US

Nur in US verfügbar.

Nicht in SI, MKS oder CGS verfügbar.


Nur in SI

Nur in SI verfügbar.

Nicht in MKS, CGS oder US verfügbar.


Nur in MKS und US

Nur in MKS und US verfügbar.

Nicht in CGS oder SI verfügbar.


Nur in MKS, SI und US

Nur in MKS, SI und US verfügbar.

Nicht in CGS verfügbar.


Gitterlinien

Wenn dieses Kontrollkästchen aktiviert ist, werden die Skalenmarkierungen auf der jeweiligen Achse durch Gitterlinien ersetzt.


Numeriert

Wenn dieses Kontrollkästchen aktiviert ist, werden die Skalenmarkierungen auf der jeweiligen Achse numeriert.


Autom. Gitterweite

Wenn dieses Kontrollkästchen aktiviert ist, wird die Anzahl der Skalenmarkierungen automatisch ausgewählt.

Zum Festlegen einer anderen Anzahl von Skalenmarkierungen gehen Sie folgendermaßen vor:

DIE OPTION KANN DURCH KLICKEN DEAKTIVIERT WERDEN.

Geben Sie im Textfeld "Anz. Gitterlinien" eine ganze Zahl zwischen 1 und 99 ein. Achten Sie darauf, daß die Zahl, die Sie eingeben, nicht so groß ist, daß die Beschriftungen an den Skalenmarkierungen unübersichtlich werden.


Gitterweite Minimum/Maximum

Über die Textfelder "Minimum" und "Maximum" können Sie die Achsenbegrenzungen für die festgelegte Achse bestimmen. Da das Vektorfelddiagramm durch die Abbildung der Elemente einer Matrix entsteht, hat Mathcad keine Möglichkeit, die tatsächlichen Werte der x- und y-Achse zu erkennen. Die Zeilen- und Spaltenzahlen haben daher als Koordinaten keine wirkliche Bedeutung. Sie wirken sich lediglich auf die Darstellung aus. Standardmäßig sind der Mindest- und Höchstwert auf -1 bzw. 1 festgesetzt.


Zweidimensionales Vektorfeld

In einem Vektorfeld gehört zu jedem Punkt (x, y) ein Vektor. In einem Vektorfelddiagramm wird dieser Vektor als kleiner Pfeil dargestellt, der von jedem Punkt ausgeht. Die Länge und die Richtung des Pfeils entsprechen dem Betrag und der Richtung dieses zugehörigen Vektors.


Nur Datenpunkte

Normalerweise springt der Fadenkreuz-Cursor entlang einer Spur von einem Datenpunkt zum nächsten. Wenn sich der Fadenkreuz-Cursor überall im Diagramm mit dem Zeiger verschieben soll, müssen Sie das Kontrollkästchen "Nur Datenpunkte" deaktivieren.


Als Standard verwenden

Hiermit legen Sie die Einstellungen des derzeit ausgewählten X-Y-Diagramms als Standardeinstellungen für alle ab diesem Zeitpunkt erstellten X-Y-Diagramme fest.


Standardwerte wiederherstellen

Hiermit werden für das derzeit ausgewählte X-Y-Diagramm die standardgemäßen Diagrammeinstellungen wiederhergestellt.


HAUPTSEITE DES INFORMATIONSZENTRUMS

Die folgenden Themen stehen auf der Hauptseite des Informationszentrums bereit (in einigen Mathcad-Versionen kann die Themenliste von dieser Aufstellung etwas abweichen):

Übersicht

Allgemeine Einführung in die Rechenfunktionen von Mathcad.

Erste Schritte

Einführung in die grundlegenden Prinzipien bei der Arbeit mit Mathcad.

Erweiterte Themen

Lernprogramme zu den weiterführenden Themen wie der Lösung von Gleichungssystemen, der Programmierung und der Arbeit mit Animationen. Einige Abschnitt stammen aus dem meistgelesenen Elektronischen Buch The Mathcad Treasury.

QuickSheets

Reihe von Mathcad-Arbeitsblättern, in denen unterschiedliche Berechnungen vorgestellt werden. Zur Suche nach einem Quicksheet für eine bestimmte Funktion oder einen bestimmten Operator klicken Sie auf die Schaltfläche "Suchen" in der Symbolleiste oben im Fenster.

Referenztabellen

Ein Archiv nützlicher mathematischer und technischer Formeln, physikalischer Konstanten, Eigenschaften verschiedener Materialien und weiterer wichtiger Informationen, die Sie normalerweise in einem Handbuch nachschlagen müßten.

Mathcad in Aktion

Sammlung von Mathcad-Dateien, die nach Fachgebieten geordnet ist. Sie zeigen, wie Sie mit Mathcad die alltäglichen Probleme in Ihrem Fachgebiet bewältigen können. Viele dieser Dateien stammen aus verschiedenen Elektronischen Büchern.

Web-Bibliothek

Ruft eine Web-Site von MathSoft auf, auf der Mathcad-Arbeitsblätter zur Verfügung stehen.

WWW-Foren

Sie erhalten Zugang zu den WWW-Foren.

MathSoft.com

Baut die Verbindung zur Homepage von MathSoft im World Wide Web (www.mathsoft.com) auf.

Registrierung

Baut die Verbindung zur Produktregistrierungsseite auf der MathSoft-WWW-Site auf.

Kundendienst/Training

Zeigt, wie Sie Technische Unterstützung erhalten. Ermöglicht den Verbindungsaufbau zur Seite "Technical Support" auf der Word Wide-Web-Site von MathSoft.

Online-Verkauf

Baut die Verbindung zum Web Store von MathSoft auf, wo Sie weitere MathSoft-Produkte erwerben können.


 QuickSheets

Reihe von Mathcad-Arbeitsblättern, in denen unterschiedliche Berechnungen vorgestellt werden. Zur Suche nach einem Quicksheet für eine bestimmte Funktion oder einen bestimmten Operator klicken Sie auf die Schaltfläche "Suchen" in der Symbolleiste oben im Fenster.


DIALOGFELD FÜR VORLAGEN


VERSCHIEBEN EINES FENSTERS

Positionieren Sie den Mauszeiger auf der Titelleiste des Fensters, drücken Sie die Maustaste, und ziehen Sie das Fenster mit der Maus. Befindet sich das Fenster an der gewünschten Stelle, können Sie die Maustaste loslassen.


Ändern der Fenstergröße

ÄNDERN DER FENSTERGRÖSSE

Positionieren Sie den Mauszeiger auf den Rand des Fensters, drücken Sie die Maustaste, und ziehen Sie den Rand mit der Maus. Sobald das Fenster die gewünschte Größe hat, können Sie die Maustaste loslassen.


MAXIMIEREN EINES FENSTERS

Klicken Sie auf das Symbol für Maximieren in der rechten oberen Ecke des Fensters.


MINIMIEREN EINES FENSTERS

Klicken Sie auf das Symbol für Minimieren in der rechten oberen Ecke des Fensters.


Wählen Sie den Befehl Schließen im Menü Datei.

SCHLIESSEN EINES ARBEITSBLATTFENSTERS

Wählen Sie den Befehl Schließen aus dem Menü "Datei".


AKTIVIEREN EINES FENSTERS

Soll ein anderes Arbeitsblatt zum aktiven Fenster gemacht werden, klicken Sie entweder in das Arbeitsblatt, oder wählen Sie den Namen des Arbeitsblatts aus dem Menü Fenster.


STAPELN VON ARBEITSBLATTFENSTERN

Wählen Sie den Befehl Überlappend aus dem Menü Fenster. Dadurch wird das aktive Fenster so über alle anderen Fenster gelegt, daß die Titelleisten aller anderen Fenster noch sichtbar sind.


KACHELN VON ARBEITSBLATTFENSTERN

Wählen Sie entweder Untereinander oder Nebeneinander aus dem Menü Fenster.


RTF (Rich Text Format)

Dieses Dateiformat wird von einer zunehmenden Anzahl von Textverarbeitungsprogrammen und anderen Anwendungen erkannt. In RTF-Dateien können nicht nur einfacher Text, sondern auch Grafiken, Gleichungen, Schriftarten und Informationen zum Layout des Dokuments, wie z. B. zu Seitenumbrüchen, Randeinstellungen und Absatzformaten, gespeichert werden.


BEREICH

Ein Bereich ist eine Gleichung, ein Text, ein Diagramm oder ein anderes Objekt in einem Arbeitsblatt. Mit Hilfe des Befehls Bereiche im Menü Ansicht können Sie sich die Begrenzungen aller Bereiche im Arbeitsblatt anzeigen lassen.


DIALOGFELD "VERWEIS EINFÜGEN"

Im Dialogfeld "Verweis einfügen" finden Sie die folgenden Optionen und Schaltflächen:

Verweis auf Datei einfügen

Geben Sie hier den Namen der Datei ein, auf die verwiesen werden soll. Dabei muß es sich um ein Arbeitsblatt handeln, das entweder auf einem Ihrer Laufwerke oder im Internet bereitliegt. Um z. B. auf eine Datei namens CONFORM.MCD im Mathcad-Ordner zu verweisen, ist folgendes einzugeben:

c:\Programme\MathSoft\Mathcad\conform.mcd

Für einen Verweis auf eine Datei im World Wide Web können Sie eingeben:

http://www.mathsoft.com/coeffs.mcd

Relativen Pfad für Verweis verwenden

Mit dieser Option sorgen Sie dafür, daß die Angabe des Speicherortes der Datei, auf die verwiesen wird, relativ zum Mathcad-Arbeitsblatt erfolgt, das den Verweis enthält. Auf diese Weise bleibt der Verweis selbst dann gültig, wenn Sie die Datei, auf die verwiesen wird, und das Haupt-Arbeitsblatt an einen anderen Ort verschieben, ohne dabei die relative Verzeichnisstruktur zwischen beiden Dateien zu beeinträchtigen.

Damit Sie einen relativen Pfad angeben können, müssen sich die beiden Arbeitsblätter auf demselben lokalen Laufwerk bzw. demselben Netzlaufwerk befinden.

Wenn Sie einen relativen Pfad angeben, kann es vorkommen, daß er als absoluter Pfad angezeigt wird. Mathcad arbeitet intern trotzdem mit dem relativen Pfad.


Pfad zu einer Referenz

Als Verweis auf die Datei CONFORM.MCD im Mathcad-Ordner könnten Sie beispielsweise eingeben:

c:\Programme\mathsoft\mathcad\conform.mcd

Als Verweis auf eine Datei im World Wide Web könnten Sie eingeben:

http://www.mathsoft.com/coeffs.mcd


Relativer Pfad in einem Dateiverweis

Relativer Pfad

Mit Hilfe eines relativen Pfades können Sie den Speicherort der Datei, auf die verwiesen wird, relativ zum Mathcad-Arbeitsblatt festlegen, das den Verweis enthält. Auf diese Weise bleibt der Verweis auch dann gültig, wenn Sie die Datei, auf die verwiesen wird, und das Haupt-Arbeitsblatt verschieben, ohne dabei die relative Verzeichnisstruktur zwischen den beiden zu verändern. Damit Sie einen relativen Pfad angeben können, müssen sich die beiden Arbeitsblätter auf demselben lokalen Laufwerk bzw. demselben Netzlaufwerk befinden.

Wenn Sie einen relativen Pfad angeben, zeigt Mathcad am Ende des Pfads zum Verweis in Ihrem Arbeitsblatt ein großes "R" in Klammern an.


Arbeitsblatt, auf das verwiesen wird

Dabei muß es sich um ein Arbeitsblatt handeln, das entweder auf einem Ihrer Laufwerke oder im Internet gespeichert ist. Um z. B. auf eine Datei namens CONFORM.MCD zu verweisen, die sich im Mathcad-Ordner befindet, müssen Sie folgendes eingeben:

c:\Programme\MathSoft\Mathcad\conform.mcd

Für einen Verweis auf eine Datei, die im World Wide Web gespeichert ist, können Sie z. B. folgendes eingeben:

http://www.mathsoft.com/coeffs.mcd

Sobald Sie einen Verweis auf das Arbeitsblatt eingefügt haben, sollte es nicht mehr in ein anderes Verzeichnis verschoben werden. Verschieben Sie es, wird der Verweis ungültig. Wenn Sie das Mathcad-Arbeitsblatt, das den Verweis enthält, und das Arbeitsblatt, auf das verwiesen wird, zusammen verschieben wollen, ist darauf zu achten, daß die relative Verzeichnisstruktur zwischen den beiden Dokumenten erhalten bleibt und daß ein relativer Pfad definiert und verwendet wird.


In der Vorlage wird folgendes angegeben:

Standard-Texteigenschaften

Definitionen aller Rechenformatvorlagen

Definitionen aller Textformatvorlagen

Kopf- und Fußzeilen

Randbereiche für das Drucken

Numerische Ergebnisformate

Werte für die vordefinierten Mathcad-Variablen

Namen der Grundeinheiten in Mathcad

Standardeinheitensystem

Standardberechnungsmodus


Als Matrix wird eine tabellarische Anordnung von Zahlen bezeichnet.

MATRIX

Als Matrix wird eine tabellarische Anordnung von Zahlen bezeichnet.


Als Vektor wird ein Feld oder eine Matrix bezeichnet, die aus genau einer Zahlenspalte besteht.

VEKTOR

Als Vektor wird ein Feld oder eine Matrix bezeichnet, die aus genau einer Zahlenspalte besteht.


Verwenden Sie Tieferstellungen in einem Feld, wenn Sie auf einzelne Elemente im Feld verweisen möchten. Sie sollten z. B. Tieferstellungen einsetzen, wenn Sie

 ein Feld abbilden wollen, da jedes einzelne Element abgebildet werden soll.


DEFINIEREN VON FELDELEMENTEN

Zur Definition einzelner Feldelemente werden Indizes verwendet. Geben Sie z. B.:

v[3:6

ein, um das vierte Element des Vektors v zu definieren.

Beim Definieren von Feldelementen können Sie im Vektor auch Lücken lassen. Wenn beispielsweise v nicht definiert ist und Sie das dritte Element definieren, ist das erste und das zweite Element nicht definiert. Mathcad fügt für die undefinierten Elemente Nullen ein. Achten Sie darauf, nicht zu große Felder zu erstellen, indem Sie Elemente einzeln definieren.


EINFÜGEN VON ZEILEN

Zum Einfügen von einer oder mehrerer Zeilen in einen Vektor bzw. eine Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf ein Element in der Zeile, unter der Sie weitere Zeilen einfügen möchten.

  2. Wählen Sie Matrix im Menü Einfügen. Es erscheint ein Dialogfeld.

  3. Legen Sie die Anzahl der einzufügenden Zeilen fest.

  4. Klicken Sie auf "Einfügen".

Es werden eine oder mehrere Zeilen mit leeren Platzhaltern unter der Zeile angezeigt, in der das ausgewählte Element enthalten ist.


LÖSCHEN VON ZEILEN

Zum Löschen einer oder mehrerer Zeilen in einem Vektor bzw. einer Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf ein Element in der ersten Zeile, die gelöscht werden soll.

  2. Wählen Sie Matrix im Menü Einfügen. Es erscheint ein Dialogfeld.

  3. Legen Sie die Anzahl der zu löschenden Zeilen fest.

  4. Klicken Sie auf "Löschen".

Dadurch wird die Zeile mit dem ausgewählten Element zusammen mit der angegebenen Anzahl von darunterliegenden Zeilen gelöscht.


EINFÜGEN VON SPALTEN

Zum Einfügen einer oder mehrerer Spalten in eine Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf ein Element in der ersten Spalte, die Sie löschen möchten.

  2. Wählen Sie Matrix im Menü Einfügen. Es erscheint ein Dialogfeld.

  3. Legen Sie die Anzahl der einzufügenden Spalten fest.

  4. Klicken Sie auf "Einfügen".

Neben der Spalte, die das ausgewählte Element enthält, wird die angegebene Zahl von Spalten angezeigt. Rechts daneben erscheinen entsprechende leere Platzhalter.


LÖSCHEN VON SPALTEN

Zum Löschen einer oder mehrerer Spalten in einer Matrix gehen Sie wie folgt vor:

  1. Klicken Sie auf ein Element in der zu entfernenden Spalte bzw. in der Spalte, die sich links von den zu entfernenden Spalten befindet.

  2. Wählen Sie Matrix im Menü Einfügen. Es erscheint ein Dialogfeld.

  3. Legen Sie die Anzahl der zu löschenden Spalten fest.

  4. Klicken Sie auf "Löschen".

Dadurch wird die Spalte mit dem ausgewählten Element und die angegebene Anzahl von Spalten rechts von ihr gelöscht.


FELDERGEBNISSE IN FORM EINER MATRIX ANZEIGEN

Eine Möglichkeit, Vektor- bzw. Matrixergebnisse anzeigen zu lassen, ist die Matrixform:

Wenn Sie einen großen Vektor oder eine große Matrix statt in einer Ausgabetabelle als Feld anzeigen lassen, zeigt Mathcad lediglich die ersten 200 Zeilen und Spalten an. Mathcad weist mit einer Ellipse darauf hin, daß Zeilen und Spalten intern gespeichert sind, aber nicht angezeigt werden.


Überprüfung der Plausibilität von Ergebnissen

Bei einfachen Berechnungen reicht meist eine kurze Überprüfung, ob das Ergebnis sinnvoll ist. Bei komplizierteren Rechenvorgängen sollten Sie in Ihre Dokumente Redundanzüberprüfungen aufnehmen, mit denen Sie überschlagen können, ob das Ergebnis annähernd stimmt.


Der erste Trapez-Annäherungswert:

Beim zweiten Trapez-Annäherungswert wird die Zahl der Teilintervalle verdoppelt, wobei zwei Teilintervalle jeweils mit der Weite b-a/2 verwendet werden. Der Algorithmus beginnt mit der Berechnung der ersten drei Annäherungen und der Aufteilung des Intervalls jeweils in ein, zwei und vier Teilintervalle.


Die Romberg-Methode

Mit der Romberg-Methode werden die Annäherungswertfolge und die entsprechenden Teilintervallweiten extrapoliert, so daß die Konvergenz einer Folge von einfachen Trapez- oder Mittelpunktannäherungen an das Integral schneller vonstatten geht.


Der Variablenname "näherung" mit tiefgestelltem 0,1 usw. repräsentiert die internen

 Annäherungen in Mathcad an die Antwort. Nur der letzte Annäherungswert, also der Wert, der den Toleranztest von Mathcad besteht, steht dem Benutzer zur Verfügung.


Da bei der Integrationsmethode von Mathcad das Intervall in vier Teilintervalle aufgeteilt wird

 und sich dann die Anzahl der Punkte verdoppelt, kann es bei periodischen Funktionen mit einer Periode von 1/(2^n) mal der Intervallänge zu fehlerhaften Ergebnissen kommen. Um dies zu vermeiden, sollten Sie das Intervall in zwei Teilintervalle unterschiedlicher Größe aufteilen und die Integration über jedes Teilintervall einzeln durchführen.


Ableitungen von Stufen höher als 5

Obwohl der Ableitungsoperator von Mathcad keine Ableitungen von Stufen höher als 5 berechnet, können Sie Ableitungsoperatoren ineinander verschachteln und so Ableitungen höherer Stufen berechnen.


Der Fehlervektor

Der MINPACK-Algorithmus versucht, die Nullwerte eines Funktionsvektors zu finden oder im schlimmsten Fall die Zahl der Werte des Vektors, der senkrecht zu den Werten bestimmter Variablen stehen (also die Nullwerte), so gering wie möglich zu halten. Der von Mathcad eingesetzte Funktionsvektor ist ein Fehlervektor, dessen Elemente für die Fehler in den Bedingungen stehen. Diese Fehler werden wie folgt definiert:

Für Gleichheitsbedingungen (Bedingungen mit “=”):

Für Ungleichheitsbedingungen:

falls Ungleichheit gegeben ist, andernfalls:

Unter Mathcad wird der Levenberg-Marquardt-Algorithmus als Algorithmus über reelle Variablen behandelt. Wenn Sie nach einer komplexen Variable auflösen, behandelt Mathcad den reellen und den imaginären Bestandteil im Algorithmus jeweils als getrennte Variablen. Wenn Sie eine Gleichheitsbedingung auflösen, erstellt Mathcad zwei reelle Bedingungen für den Algorithmus, also einen für den reellen Teil und einen für den imaginären Teil.


EINZELSCHRITTE BEI DER LEVENBERG-MARQUARDT-METHODE

Bei der Levenberg-Marquardt-Methode handelt es sich um eine Quasi-Newtonsche Näherungsmethode (also um eine Variante der Gradientenmethode). Bei jedem Schritt schätzt Mathcad die ersten Teilableitungen der Fehler in bezug auf die aufzulösenden Variablen, so daß eine Jacobische Matrix (Funktionsmatrix) erstellt wird. Normalerweise kann Mathcad den nächsten Schätzwert durch Berechnung des Gauss-Newtonschen Schritts s für jede Variable bestimmen. In der Matrixnotation löst Mathcad die Matrixgleichung:

In dieser Gleichung steht J für die Jacobische Matrix, s für den durchzuführenden Schritt und x für den Vektor der aktuellen Schätzwerte für unbekannte Variablen. Beim ersten Schritt bildet x den Vektor für die Schätzwerte; bei jedem folgenden Schritt ist das neue x definiert als die Summe aus x plus s (dem Schrittvektor). Beachten Sie, daß bei der Berechnung dieses Schritts die Funktionsmatrix J umgekehrt wird.

Dieser Schritt kann nicht immer berechnet werden. Die Berechnung schlägt fehl, wenn die Funktionsmatrix nicht invertiert werden kann oder wenn die Zahl der Bedingungen die der zu lösenden Variablen übersteigt. In diesen Fällen gibt Mathcad die zusätzliche Bedingung vor, daß die folgende Menge auf ein Minimum reduziert wird:

Hier ist D der Vektor von Gewichtungsfaktoren, die aus den Normen der Spalten in der Jacobischen Matrix berechnet werden. In diesen Fällen wird s so berechnet, daß es die Minimierungskriterien erfüllt und gleichzeitig die Newtonsche Gleichung innerhalb der Funktionsmatrix auflöst.

Die Levenberg-Marquardt-Methode funktioniert nicht, wenn weniger Bedingungen als Variablen vorhanden sind. In einem solchen Fall gibt Mathcad einen Fehler aus.


ABBRUCHKRITERIEN

Die Levenberg-Marquardt-Methode wird beendet, wenn eines der folgenden Abbruchkriterien erfüllt ist:

Wenn es nicht mehr möglich ist, die Norm des Fehlers weiter signifikant zu reduzieren. In diesem Zusammenhang bedeutet "signifikant" um mehr als den größeren Wert von TOL und TOL*|err_vector|. Durch dieses Kriterium wird der Integrallöser angehalten, wenn keine weitere Fehlerreduzierung mehr möglich ist.

Wenn sich s relativ stark an Null annähert. Bei dieser Methode steht “relativ stark" für eine Norm, die kleiner als der größere Wert von TOL und TOL*|v| ist. Durch dieses Kriterium wird der Integrallöser angehalten, wenn für die Fortschreibung der Schätzwerte keine Richtung mehr vorgegeben ist.

Ist eine dieser Abbruchbedingungen erreicht, prüft Mathcad den Betrag des Fehlervektors und gibt eine Antwort aus:

Ist der Betrag des Fehlervektors kleiner oder gleich TOL, gibt Mathcad die Variablenwerte als Lösung aus.

Endet das Gleichungssystem mit der Funktion suchen und ist der Betrag des Fehlervektors größer als TOL, markiert Mathcad die Suchfunktion mit einem Fehler.

Endet das Gleichungssystem mit der Funktion minfehl und ist der Betrag des Fehlervektors größer als TOL, gibt Mathcad die Lösung aus, obwohl der Fehlervektor sich nicht an Null angenähert hat. Mathcad definiert als Wert für die Variable FEHL den Betrag des Fehlervektors.

Mathcad begrenzt die Zahl der Berechnungen, die Mathcad für eine Lösung des Gleichungssystems durchführt. Erreicht Mathcad die festgelegte Begrenzung, ohne daß eine Antwort ausgegeben wird, wird die Funktion suchen oder minfehl als Fehler markiert.

Mathcad gibt die Fehlermeldung aus, daß keine Lösung gefunden wurde, wenn die Differenz zwischen aufeinanderfolgenden Annäherungen an die Lösung größer ist als TOL und eine der folgenden Bedingungen eintritt:

Der Integrallöser kann den Fehler nicht weiter reduzieren. Versuchen Sie, für TOL einen größeren Wert festzulegen. Überprüfen Sie, ob Sie für die Suche einer komplexen Lösung die erforderlichen komplexen Schätzwerte angegeben haben.

Der Integrallöser befindet sich an einem Punkt, and dem es keine vorzuziehende Richtung gibt. Probieren Sie verschiedene Schätzwerte aus, oder fügen Sie eine Ungleichung hinzu.

Der Integrallöser erreicht die Grenze seiner Rechengenauigkeit. Aufgrund von Rundungsfehlern ist es unwahrscheinlich, daß weitere Berechnungen zu genaueren Lösungen führen. Dieser Fall tritt häufig ein, wenn Sie für TOL einen Wert unter 10^15 einstellen.


ABWEICHUNGEN VON DER LEVENBERG-MARQUARDT-METHODE

Die Levenberg-Marquardt-Methode wurde in einigen Punkten zugunsten einer verbesserten Praxistauglichkeit für Mathcad verändert:

Bei der ersten Unterbrechung des Algorithmus an einem Punkt, der keine Lösung darstellt, addiert Mathcad einen zufällig gewählten Betrag zu allen Variablen und beginnt von neuem. Dadurch kann ein Rechenabbruch aufgrund örtlicher Minimalwerte und anderer Werte, an denen keine Vorgaberichtung festgestellt werden kann, weitgehend vermieden werden. Mathcad führt diesen Schritt in jedem Lösungsvorgang nur einmal durch, also an der ersten Stelle, an der die Routine unterbrochen wird, ohne daß eine Lösung vorliegt.

Wenn Sie Ungleichheitsbedingungen in ein Gleichungssystem aufnehmen, löst Mathcad das nur aus den Ungleichheiten bestehende Teilsystem zuerst und bewertet erst dann die Gleichheitsbedingungen für die vollständige Lösung. Dadurch werden die Schätzwerte in einen Bereich gelegt, in der alle Ungleichheitsbedingungen erfüllt sind, bevor der eigentliche Algorithmus ausgeführt wird.


Mathcad führt die LU-Dekomposition mit Hilfe des Crout-Verfahrens mit partieller Pivotierung aus. Eine vollständige Beschreibung finden Sie in

 William T. Vetterling (Cambridge University Press, 1986), Seiten 31 bis 39.


Erstellen einer Zeichenfolge

ZEICHENFOLGEN

Als Zeichenfolge gilt eine Reihe von Zeichen, die zwischen zwei Anführungszeichen steht. Sie hat keinen numerischen Wert. Für Zeichenfolgen gelten keine Längenbegrenzungen. Sie werden stets als einzelne Textzeile im Arbeitsblatt wiedergegeben.

Als Zahlenzeichenfolge wird eine Zeichenfolge mit Zeichen beschrieben, die eine reelle, komplexe, negative oder positive Zahl, eine Gleitkommazahl oder eine Zahl in Exponentialschreibweise ergibt. Leerzeichen in Zahlenzeichenfolgen werden ignoriert.

Zur Erstellung einer Zeichenfolge gehen Sie folgendermaßen vor:

  1. Klicken Sie in einem mathematischen Ausdruck auf einen Platzhalter, oder klicken Sie auf eine leere Stelle im Arbeitsblatt, und wählen Sie den Befehl Rechenbereich aus dem Menü Einfügen.

  2. Geben Sie ein Anführungszeichen (“) ein. Zwischen den beiden Anführungszeichen können Sie eine Einfügelinie erkennen.

  3. Geben Sie eine Kombination aus Buchstaben, Ziffern und/oder anderen Zeichen ein.

Beispiele für Zeichenfolgen:

"Guten Morgen!"

"5.67e-2" (Zahlenzeichenfolge)

"-4.3 - 6.7i" (Zahlenzeichenfolge)


Dateien

UNTERSTÜTZTE DATENTYPEN

Mathcad unterstützt die folgenden Datendateitypen (Lesen und Schreiben):

Formatierter Text (*.prn)

Text mit Tabulatoren als Trennzeichen (*.dat, *.txt)

Durch Komma getrennte Werte (*.csv)

MATLAB MAT-Dateien (*.mat)

Excel-Dateien (*.xls)

Lotus 1-2-3-Dateien (*.wks, *.wk1, *.wk*)

Quattro Pro-Dateien (*.wq?, *.wb?)

dbase-Dateien (*.dbf)

S-Plus-Dateien


Einige der über die Komponente "Axum" verfügbaren Diagrammtypen

DIAGRAMME, DIE MIT DER AXUM-KOMPONENTE ERSTELLT WERDEN KÖNNEN

Zweidimensionale Diagramme

Streuung

Linie

Spline

Lowess

Gewichtete Fehlerquadrate

Säulen

Fehler - Säulen

Kurvenanpassung natürlicher Logarithmus

Kurvenanpassung exponential

Fläche

Histogramm

Kommentar

3D-Diagramme

Streuung

Linie

Regression

Dünne Fläche

Spline

Andere

Torte

Smith


DATENAUSTAUSCH

Daten werden von der Mathcad-Eingabevariable an die Komponente übertragen, und die Ausgabevariable überträgt die Ausgabe.


Muß zwischen zwei Sperrbereichen liegen.

Bevor Sie den Befehl Bereich / Sperren aus dem Menü Format aufrufen können, müssen Sie in eine gesperrte Region im Arbeitsblatt klicken.


DIESE OPERATION KANN NUR FÜR EINE ZEICHENFOLGE AUSGEFÜHRT WERDEN.

Für die von Ihnen verwendete Funktion bzw. den Operator ist ein Zeichenfolge-Argument erforderlich. Zum Beispiel wird für Zeichenfolgefunktionen normalerweise mindestens ein Zeichenfolgenargument benötigt.


Keine Sperre vorhanden.

Bevor Sie den Befehl Bereich / Sperren aus dem Menü Format aufrufen können, müssen Sie in eine gesperrte Region im Arbeitsblatt klicken.


ERSTE SEITE DES EXCEL-SETUP-ASSISTENTEN

Wenn Sie eine Verbindung mit einer Datei herstellen wollen, die bereits existiert, wählen Sie "Aus Datei erstellen", und geben Sie in das Textfeld den Namen des Pfades ein. Mit Hilfe der Schaltfläche "Durchsuchen" können Sie nach der Datei suchen. Klicken Sie dann auf "Öffnen". Soll keine Verbindung zu einer bereits existierenden Datei hergestellt werden, wählen Sie "Leeres Excel-Arbeitsblatt erstellen".

Klicken Sie auf "Als Symbol", wenn statt eines Teils der Excel-Datei lediglich ein Symbol in Ihrem Mathcad-Arbeitsblatt erscheinen soll.


Mit anderen Seiten des Excel-Setup-Assistenten können Sie folgendes festlegen:

EXCEL-SETUP-ASSISTENT

Auf den Seiten des Excel-Setup-Assistenten können Sie folgendes festlegen:

Anzahl der Ein- und Ausgabevariablen Sie können zwischen 0 und 4 Eingabevariablen und zwischen 0 und 4 Ausgabevariablen angeben.

Eingabebereiche: Die Zellen, in denen die Werte der einzelnen Mathcad-Eingabevariablen gespeichert werden. Geben Sie die Startzelle an. Die Startzelle ist die Zelle, in der sich das Element in der linken oberen Ecke des Datenfeldes befindet. Für eine Eingabevariable, die eine Matrix mit Werten enthält, können Sie beispielsweise A1 als Startzelle festlegen. Die Werte werden daraufhin in die Zellen A1 bis C3 eingefügt.

Ausgabebereiche: Die Zellen, deren Werte die Mathcad-Ausgabevariablen definieren. Geben Sie beispielsweise C2:L11 ein, wenn Sie die Werte in den Zellen C2 bis L11 extrahieren und eine Matrix erstellen möchten.


Beispiel für ein Skript-Objekt

Beispiel-Skript

Dieses Skript-Objekt akzeptiert zwei Eingabewerte und sendet zwei Ausgabewerte. Die Eingabewerte bestimmen, ob ein lächelndes oder ein blinzelndes Gesicht dargestellt wird. Das Skripteditor-Fenster zeigt einen Teil des zum Konfigurieren des Objekts verwendeten VBScript-Codes.


SKRIPTEDITOR

Der Skripteditor zeigt die Grundstruktur eines Skripts und drei Subroutinen zum Einfügen von Skript-Code. Die Argumente Inputs und Outputs für die Subroutine "Exec" entsprechen den Feldern mit Ein- und Ausgabedaten, mit denen das Objekt arbeitet; mit der Angabe Inputs(0) und Outputs(1) im Hauptteil der Subroutine wird auf die erste Eingabe- und die zweite Ausgabe verwiesen. Die Befehle in den einzelnen Abschnitten werden bei jeder Berechnung des Mathcad-Arbeitsblatts nacheinander ausgeführt.


UNTERSTÜTZTE SKRIPT-SPRACHEN

Beispiele für unterstützte Skript-Sprachen sind die neuesten Versionen von Microsoft JScript (JavaScript) und Microsoft VBScript (Visual Basic Scripting Edition). Weitere Informationen zu diesen Skript-Sprachen finden Sie auf der Microsoft-Website unter http://www.microsoft.com/scripting. Von dort können Sie sich auch die neuesten Versionen dieser Sprachen herunterladen.


JSCRIPT

Microsoft JScript ist ein schneller, portabler und leichter Interpreter für den Einsatz in Anwendungen, die mit ActiveX-Controls, OLE-Automatisierungsservern und Java-Applets arbeiten. JScript ist direkt mit VBScript (nicht jedoch mit Java) vergleichbar. Wie VBScript ist JScript ein reiner Interpreter (Umsetzungsprogramm), der Quellcode verarbeitet und nicht zur Erstellung von Einzel-Applets verwendet werden kann.


VBSCRIPT

Microsoft VBScript ist ein Bestandteil der Sprache Visual Basic für Applikationen, die in Microsoft Excel, Project, Access und dem Entwicklungssystem Visual Basic 4.0 zum Einsatz kommt. VBScript ist als kleine und leichte interpretierte Sprache konzipiert; sie setzt also keine reinen Typen ein (nur Varianten). Da VBScript außerdem als sicherer Bestandteil der Sprache konzipiert ist, beinhaltet es keine Dateiein-/Ausgabe und keinen direkten Zugriff auf das zugrundeliegende Betriebssystem.


KOMPONENTE

Bei einer Komponente handelt es sich um ein spezialisiertes OLE-Objekt, das Sie in ein Mathcad-Arbeitsblatt einfügen können, um auf diese Weise eine Verbindung zwischen dem Arbeitsblatt und einer Datenquelle bzw. einer anderer Anwendung, die Daten enthält, herzustellen.

Zum Einfügen einer Komponente wählen Sie den Befehl Komponente im Menü Einfügen. Die folgenden Komponenten sind verfügbar:

Axum: Mit dieser Komponente können Sie in einem Mathcad-Arbeitsblatt Axum-Graphen erstellen. Sie kann nur eingefügt werden, wenn Axum installiert ist.

Dateien lesen/schreiben: Diese Komponente ermöglicht das Lesen und Schreiben von Datendateien in einer Vielzahl von Formaten.

Excel: Mit dieser Komponente läßt sich eine Verknüpfung zwischen einem Mathcad-Arbeitsblatt und einer Excel-Datei herstellen.

Eingabetabelle: Diese Komponente dient zum Eingeben von Daten in eine tabellenkalkulationsartige Tabelle.

MATLAB: Mit dieser Komponente können Sie eine Verknüpfung zwischen einem Mathcad-Arbeitsblatt und einer MATLAB-Datei einfügen.

Skriptobjekt: Hiermit und mit Hilfe einer Skript-Sprache läßt sich eine benutzerdefinierte Komponente einfügen.


Assistenten

KOMPONENTENASSISTENTEN

Wenn Sie eine der folgenden Komponenten einfügen, wird ein Setup-Assistent angezeigt:

MATLAB-Komponente

Excel-Komponente

Datei lesen/schreiben-Komponente

Scriptable Object-Komponente

Mit dem Setup-Assistenten können Sie einige Eigenschaften der Komponente festlegen, bevor sie eingefügt wird.

Klicken Sie auf die Schaltfläche "Weiter", um mit dem Assistenten fortzufahren.

Klicken Sie auf die Schaltfläche "Zurück", um zu einer vorherigen Seite zurückzukehren.

Klicken Sie auf die Schaltfläche "Fertig stellen", um die Komponente in das Arbeitsblatt einzufügen.


Die Position des ersten Zeichens in einer Zeichenfolge ist definiert als 0.

Hinweis: Die Position des ersten Zeichens in einer Zeichenfolge hat den Positionswert Null. In der Zeichenfolge "dies ist ein Satz" ist z. B. der Buchstabe "d" das nullte Zeichen.


Schätzwert

SCHÄTZWERTE

Für das numerische Lösen von Gleichungen müssen Werte definiert sein, von denen aus der Lösungsalgorithmus seine Suche nach einer Lösung beginnen kann.

Zur Angabe eines solchen Schätzwerts brauchen Sie nur eine Variable zu definieren. Der von Ihnen gewählte Variablenname sollte mit den Variablenargumenten der Lösungsfunktion übereinstimmen.

Hinweise:

  • Wenn Sie die Funktion wurzel bei Ausdrücken mit mehreren Wurzeln verwenden, hängt es vom Schätzwert ab, auf welche Wurzel konvergiert wird.

  • Wenn Sie mit den Funktionen wurzel, suchen, minfehl, minimieren oder maximieren arbeiten, müssen Sie, wenn Sie eine komplexe Lösung erwarten, einen komplexen Schätzwert definieren.


Größe des Fehlervektors

GRÖSSE DES FEHLERVEKTORS

Die vordefinierte Variable ERR gibt die Größe des Fehlervektors für die näherungsweise Lösung an. Zur Bestimmung der Fehlergröße einzelner Lösungen von Unbekannten ist keine vordefinierte Variable verfügbar.


Pfadname für Hyperlinks

Beispiele für Hyperlink-Pfadnamen

Mit c:\Programme\MathSoft\Mathcad\conform.mcd wird ein Hyperlink zur Datei conform.mcd im Ordner "Mathcad" erstellt.

Mit http://www.mathsoft.com/coeffs.mcd wird ein Hyperlink zu einer Datei im Word Wide Web erstellt.


Relativer Pfad zu einer verknüpften Datei

Relativer Pfad

Geben Sie einen relativen Pfad an, wenn der Pfad der verknüpften Datei relativ zum Mathcad-Arbeitsblatt angegeben werden soll, das die Verknüpfung enthält. Dadurch bleibt die Verknüpfung auch dann noch gültig, wenn Sie die verknüpfte Datei und das Hauptarbeitsblatt zusammen verschieben und die Verzeichnisstruktur zwischen den beiden Dateien beibehalten. Damit Sie einen relativen Pfad angeben können, müssen sich die beiden Arbeitsblätter auf demselben lokalen Laufwerk bzw. demselben Netzlaufwerk befinden.

Wenn Sie einen relativen Pfad angeben, kann es vorkommen, daß er als absoluter Pfad angezeigt wird. Mathcad arbeitet intern trotzdem mit dem relativen Pfad.


Hyperlinks zu Mathcad-fremden Dateien

HYPERLINKS ZU ANDEREN DATEIEN

Sie können nicht nur Hyperlinks zwischen zwei Mathcad-Arbeitsblättern, sondern auch von einem Mathcad-Arbeitsblatt zu anderen Dateitypen erstellen (z. B. einer AVI-Datei). In diesem Fall können Sie die verknüpfte Datei nicht in einem Popup-Fenster im Mathcad-Programmrahmen darstellen lassen.


HYPERLINK

Als Hyperlink wird ein Bereich oder eine Gruppe von ausgewähltem Text bezeichnet, mit dem ein anderes Arbeitsblatt oder eine andere Datei durch Doppelklicken geöffnet wird.

Standardmäßig kennzeichnet fett hervorgehobener, unterstrichener Text eine Hyperlink-Verknüpfung. Liegt die Hyperlink-Verknüpfung jedoch in einem Bereich, der keinen Text enthält, gibt es keinen Anhaltspunkt, an dem man diese Verknüpfung erkennen kann. Daher sollten Sie die Hyperlinks stets mit ausgewähltem Text erstellen.


DIALOGFELD "HYPERLINK EINFÜGEN"

Im Dialogfeld "Hyperlink einfügen" finden Sie die folgenden Optionen und Schaltflächen:

Mit Datei oder URL verknüpfen

Geben Sie hier den Pfad zu der Datei auf dem lokalen Rechner oder einem fernen Rechner (z. B. im Netzwerk oder im Internet) ein, die sich öffnen soll, sobald Sie auf den Hyperlink doppelklicken. Der Pfad könnte z. B. so aussehen:

c:\windows\mcad5.mcd

oder so:

http://www.mathsoft.com/text.mcd

Beachten Sie, daß Arbeitsblätter, auf die auf diese Art und Weise verwiesen wurde, nicht mehr umbenannt oder an einen anderen Speicherort verschoben werden dürfen, da die Verknüpfung andernfalls ungültig wird. Wenn Sie allerdings das Mathcad-Arbeitsblatt, das den Hyperlink enthält, zusammen mit dem verknüpften Arbeitsblatt verschieben möchten, achten Sie darauf, daß die relative Verzeichnisstruktur zwischen den beiden Arbeitsblättern unverändert bleibt und daß im Hyperlink selbst ein relativer Pfad angegeben wird.

Relativen Pfad für Hyperlink verwenden

Diese Option sorgt dafür, daß der Speicherort der verknüpften Datei relativ zum Speicherort des Mathcad-Arbeitsblatts angegeben wird, das die Verknüpfung enthält. Auf diese Weise bleibt der Verweis selbst dann gültig, wenn Sie die verknüpfte Datei und das Haupt-Arbeitsblatt an einen anderen Ort verschieben, ohne dabei die relative Verzeichnisstruktur zwischen beiden Dateien zu beeinträchtigen.

Damit Sie einen relativen Pfad angeben können, müssen sich die beiden Arbeitsblätter auf demselben lokalen Laufwerk bzw. demselben Netzlaufwerk befinden.

Wenn Sie einen relativen Pfad angeben, kann es vorkommen, daß er als absoluter Pfad angezeigt wird. Mathcad arbeitet intern trotzdem mit dem relativen Pfad.

Als Popup-Dokument anzeigen

Mit dieser Option geben Sie an, daß das verknüpfte Arbeitsblatt in einem eigenen Popup-Fenster geöffnet werden soll.

Statusleistenmeldung, wenn sich Maus über Hyperlink befindet

Die hier eingegebene Meldung wird in der Statusleiste angezeigt, sobald der Mauszeiger auf den Hyperlink zeigt.

Verknüpfung entfernen

Mit dieser Schaltfläche deaktivieren Sie den mit dem ausgewählten Element assoziierten Hyperlink, so daß Mathcad nicht mehr zu einem anderen Arbeitsblatt springt oder es in einem Popup-Fenster öffnet, wenn auf das ausgewählte Element doppelgeklickt wird.


Verwenden von benutzerdefinierten Binäroperatoren

VERWENDEN VON BENUTZERDEFINIERTEN BINÄROPERATOREN (nur in Mathcad Professional)

Um einen von Ihnen bereits definierten Binäroperator einzufügen, klicken Sie an der Stelle, an der Sie den Operator einfügen möchten, und gehen Sie wie folgt vor:

  1. Öffnen Sie die Symbolleiste für Auswertung, die die Schaltflächen für die benutzerdefinierte Operatoren-Notation enthält.

  2. Klicken Sie auf [image] für die "Infix"-Notation bzw. auf [image] für die "Baum"-Notation.

  3. Geben Sie den Namen des Operators in den mittleren Platzhalter ein.

  4. Geben Sie in den anderen zwei Platzhaltern die Operanden ein.


Verwenden von benutzerdefinierten einstelligen Operatoren

VERWENDEN VON BENUTZERDEFINIERTEN EINSTELLIGEN OPERATOREN (nur in Mathcad Professional)

Um einen von Ihnen bereits definierten einstelligen Operator einzufügen, klicken Sie an der Stelle, an der Sie den Operator einfügen möchten, und gehen Sie wie folgt vor:

  1. Öffnen Sie die Symbolleiste für Auswertung, die die Schaltflächen für die benutzerdefinierte Operatoren-Notation enthält.

  2. Klicken Sie auf [image] für die Suffix-Notation bzw. auf [image] für die Präfix-Notation.

  3. Für eine Präfix-Notation geben Sie den Namen des Operators in den linken Platzhalter ein. Für eine Suffix-Notation geben Sie ihn in den rechten Platzhalter ein.

  4. Geben Sie in den anderen Platzhalter den Operanden ein.


Verändern der Größe von Textbereichen mit der Maus

VERÄNDERN DER GRÖSSE VON TEXTBEREICHEN MIT DER MAUS

Zum Ändern der Breite eines Textbereichs mit Hilfe der Maus gehen Sie wie folgt vor:

  1. Markieren Sie den Textbereich.

  2. Setzen Sie den Cursor auf einen Markierungspunkt an der Seite des Bereichs. Die Form des Cursors ändert sich zu einem Doppelpfeil.

  3. Ziehen Sie die Maus nach rechts bzw. links. Der Textbereich ändert beim Ziehen des Mauszeigers seine Größe.

  4. Wenn der Textbereich die gewünschte Größe hat, lassen Sie die Maustaste los.


Verwenden von Endwerten zum Ableiten von Anfangsbedingungen

VERWENDEN VON ENDWERTEN ZUM ABLEITEN VON ANFANGSBEDINGUNGEN (nur in Mathcad Professional)

sgrw(v, x1, x2, D, lad, entspr) Gibt einen Vektor zurück, der die Anfangswerte enthält, die bei x1 nicht definiert wurden.

Argumente:

v ist ein Vektor aus Schätzwerten für die bei x1 undefinierten Anfangswerte.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird.

D ist eine vektorwertige Funktion mit n Elementen, die die ersten Ableitungen der unbekannten Funktionen enthält.

lad ist eine vektorwertige Funktion, deren n Elemente den Werten der n unbekannten Funktionen bei x1 entsprechen. Einige der Werte sind Konstanten, die durch Ihre Anfangsbedingungen bestimmt sind. Andere sind zu Anfang unbekannt, werden jedoch durch sgrw gefunden. Wenn ein Wert unbekannt ist, verwenden Sie den entsprechenden Schätzwert von v.

entspr ist eine vektorwertige Funktion mit derselben Anzahl von Elementen wie v. Jedes Element ist die Differenz zwischen einer Anfangsbedingung bei x2, wie ursprünglich definiert, und dem entsprechenden Schätzwert aus der Lösung. Der Vektor entspr mißt, wie nah eine erwartete Lösung den Anfangsbedingungen bei x2 entspricht. Der Wert 0 für jedes Element bedeutet exakte Übereinstimmung.

Hinweise:

  • sgrw löst ein Zweipunktrandwertproblem, indem von den Endpunkten ausgegangen wird und die Trajektorien der Lösung sowie der Ableitungen am Zwischenpunkt verglichen werden.

  • sgrw berechnet die Anfangswerte, die die Lösung haben muß, damit sie den von Ihnen angegebenen Endwerten entspricht. Sie müssen dann die von sgrw zurückgegebenen Anfangswerte nehmen und das resultierende Anfangswertproblem lösen.

  • Wenn Sie die Lösung bei x1 und x2 kennen und n bekannte Werte haben, verwenden Sie sgrw zum Auswerten der fehlenden Anfangswerte bei x1. Sobald Sie über diese fehlenden Anfangswerte verfügen, haben Sie an Stelle eines Zweipunktrandwertproblems ein Anfangswertproblem.


Verwenden von Zwischenwerten zum Ableiten von Anfangsbedingungen

VERWENDEN VON ZWISCHENWERTEN ZUM ABLEITEN VON ANFANGSBEDINUNGEN (nur in Mathcad Professional)

grwanp(v1, v2, x1, x2, xf, D, lad1, lad2, entspr)

Gibt einen Vektor zurück, der die Anfangswerte enthält, die bei x1 nicht definiert wurden.

Argumente:

v1 ist ein Vektor von Schätzwerten für die bei x1 undefinierten Anfangswerte. +v2 ist ein Vektor aus Schätzwerten für die bei x2 undefinierten Anfangswerte.

x1, x2 sind Endpunkte des Intervalls, an dem die Lösung für Differentialgleichungen ausgewertet wird.

xf ist ein Punkt zwischen x1 und x2, an dem die Trajektorien der Lösungen, die bei x1 beginnen und die Trajektorien der Lösungen, die bei x2 beginnen, gleich sein müssen.

D ist eine vektorwertige Funktion mit n Elementen, die die ersten Ableitungen der unbekannten Funktionen enthält.

lad1 ist eine vektorwertige Funktion, deren n Elemente den Werten der n unbekannten Funktionen bei x1 entsprechen. Einige der Werte sind Konstanten, die durch Ihre Anfangsbedingungen bestimmt sind. Wenn ein Wert unbekannt ist, verwenden Sie den entsprechenden Schätzwert von v1.

lad2 entspricht der Funktion lad1, nur mit dem Unterschied, daß deren n Elemente den Werten der n unbekannten Funktionen bei x2 entsprechen.

entspr ist eine vektorwertige Funktion, mit der festgelegt wird, auf welche Art und Weise die Lösungen bei xf übereinstimmen sollen. Gewöhnlich definieren Sie entspr(xf, y) := y, damit die Lösungen für alle unbekannten Funktionen bei xf übereinstimmen.

Hinweise:

  • grwanp löst ein Zweipunktrandwertproblem, indem von den Endpunkten ausgegangen wird und die Trajektorien der Lösung sowie der Ableitungen an den Zwischenpunkten verglichen werden. Dieses Verfahren ist dann sehr nützlich, wenn die Ableitung im Integrationsintervall über eine Unstetigkeit verfügt.

Beispiel:

Verwenden der Funktion grwanp


Verwenden von QuickSheets zum Einfügen von Operatornamen

VERWENDEN VON QUICKSHEETS ZUM EINFÜGEN EINES OPERATORNAMENS (nur in Mathcad Professional)

Obwohl ein benutzerdefinierter Operator jeden beliebigen Namen haben kann, bestehen Operatornamen häufig aus mathematischen Symbolen, die nicht direkt über die Tastatur verfügbar sind. Diese Symbole können auf folgende einfache Art und Weise aus einem QuickSheet-Fenster gezogen werden:

  1. Öffnen Sie QuickSheets im Informationszentrum.

  2. Klicken Sie auf "Mathematische Symbole". Es werden verschiedene mathematische Symbole angezeigt, die nicht direkt über die Tastatur zu erhalten sind.

  3. Ziehen Sie das gewünschte mathematische Symbol auf Ihr Arbeitsblatt.

Sie können auch ein Symbol aus einer anderen Anwendung einfügen oder ein Zeichen über seinen ANSI-Code einfügen, soweit bekannt. Halten Sie dazu die Alt-Taste gedrückt, und geben Sie den ANSI-Code auf dem numerischen Tastenfeld ein.


Verwenden von QuickSheets zum Speichern benutzerdefinierter Operatoren

VERWENDEN VON QUICKSHEETS ZUM SPEICHERN BENUTZERDEFINIERTER OPERATOREN (nur in Mathcad Professional)

Wenn Sie einen Operator definiert haben, den Sie auch in anderen Arbeitsblättern anwenden möchten, sollten Sie ihn in einem QuickSheet speichern. Sie können ihn somit bei Bedarf einfach aus einem QuickSheet ziehen. Zum Speichern eines Operators in einem QuickSheet gehen Sie wie folgt vor:

  1. Öffnen Sie die QuickSheets im "Informationszentrum".

  2. Klicken Sie auf "Persönliche QuickSheets". Klicken Sie dann auf "Meine Operatoren".

  3. Ziehen Sie die gewünschten Definitionen oder Ausdrücke mit der Maus auf dieses QuickSheet.

  4. Schließen Sie die QuickSheets, und klicken Sie auf "Ja", wenn Mathcad Sie fragt, ob Ihre Änderungen gespeichert werden sollen.

Wenn Sie diesen Operator das nächste Mal benötigen, können Sie ihn von diesem QuickSheet auf das jeweilige Arbeitsblatt ziehen.


ARBEITEN MIT MEHREREN SCHLÜSSELWÖRTERN

Um das Ergebnis eines vorangegangenen Schlüsselworts weiter auszuwerten, können Sie mehrere Schlüsselwörter aneinanderreihen. Hierzu stehen Ihnen zwei Möglichkeiten offen. Mit der ersten Methode werden die Zwischenergebnisse aus jedem der Schlüsselwörter angezeigt. Mit der zweiten Methode wird nur das Endergebnis nach der Anwendung aller Schlüsselwörter gezeigt.

Um Zwischenergebnisse anzuzeigen, gehen Sie folgendermaßen vor:

Geben Sie den Ausdruck ein, der symbolisch ausgewertet werden soll, und drücken Sie Strg +Umschalt +Punkt. Geben Sie ein Schlüsselwort in den Platzhalter ein.

Drücken Sie die Eingabetaste, um sich das Ergebnis dieses Schlüsselworts anzeigen zu lassen.

Drücken Sie Strg +Umschalt +Punkt, und geben Sie ein weiteres Schlüsselwort ein.

Drücken Sie Strg +Punkt und dann die Eingabetaste, um sich das Endergebnis anzeigen zu lassen.

Um mehrere Schlüsselwörter anzuwenden, aber nur das Endergebnis anzuzeigen, gehen Sie folgendermaßen vor:

Geben Sie den Ausdruck ein, der symbolisch ausgewertet werden soll, und drücken Sie Strg +Umschalt +Punkt. Geben Sie ein Schlüsselwort in den Platzhalter ein.

Drücken Sie Strg +Umschalt +Punkt, um einen vertikalen Strich und einen Platzhalter einzufügen.

Geben Sie ein weiteres Schlüsselwort in den Platzhalter ein.

Drücken Sie entweder Strg +Umschalt +Punkt, um ein weiteres Schlüsselwort einzugeben, oder drücken Sie die Eingabetaste, um sich das Endergebnis anzeigen zu lassen.


VERWENDEN DER FUNKTION "GRWANP"

Verwandte Themen

Einzelheiten zur Funktion grwanp

Umwandeln einer Differentialgleichung in das Standardformat, das von einem Integrallöser für Differentialgleichungen verwendet werden kann

Weitere Integrallöser für Differentialgleichungen


Verändern der Größe von Textbereichen mit der Tastatur

VERÄNDERN DER GRÖSSE VON TEXTBEREICHEN MIT DER TASTATUR

Zum Ändern der Breite eines Textbereichs mit Hilfe der Tastatur gehen Sie wie folgt vor:

  1. Klicken Sie in den Textbereich, und verschieben Sie die Einfügemarke an die Stelle, an der die Zeilen des Textbereichs umgebrochen werden sollen.

  2. Drücken Sie Strg+Eingabe.

Beachten Sie, daß dieses Verfahren nur dazu verwendet werden kann, einen Textbereich schmaler zu machen. Wenn Sie einen Textbereich breiter machen wollen, müssen Sie die Maus verwenden.


VERWENDEN DER FUNKTION "MULTIGIT"

Verwandte Themen

Einzelheiten zur Funktion multigit

Umwandeln einer Differentialgleichung in das Standardformat, das von einem Integrallöser für Differentialgleichungen verwendet werden kann

Weitere Integrallöser für Differentialgleichungen


VERWENDEN DER FUNKTION "RELAX"

Verwandte Themen

Einzelheiten zur Funktion relax

Umwandeln einer Differentialgleichung in das Standardformat, das von einem Integrallöser für Differentialgleichungen verwendet werden kann

Weitere Integrallöser für Differentialgleichungen


Einzelheiten zur Funktion "sgrw"

VERWENDEN DER FUNKTION "SGRW"

Verwandte Themen

Einzelheiten zur Funktion sgrw

Umwandeln einer Differentialgleichung in das Standardformat, das von einem Integrallöser für Differentialgleichungen verwendet werden kann

Weitere Integrallöser für Differentialgleichungen


ARBEITEN MIT DEM SYMBOLISCHEN GLEICHHEITSZEICHEN BZW. DEN MENÜBEFEHLEN

Verwenden Sie zum Ausführen symbolischer Berechnungen entweder das symbolische Gleichheitszeichen oder die Menübefehle im Menü Symbolik.

Arbeiten mit dem symbolischen Gleichheitszeichen

Das Arbeiten mit dem symbolischen Gleichheitszeichen erfolgt in Mathcad, genau wie bei numerischen Berechnungen, "aktiv". Das heißt, daß Mathcad alle Variablen und Funktionen des Ausdrucks, der ausgewertet werden soll, daraufhin überprüft, ob sie bereits im Arbeitsblatt definiert worden sind. Findet Mathcad eine Definition, wird diese auch vom Programm verwendet. Alle anderen Variablen und Funktionen werden symbolisch ausgewertet. Nehmen Sie dann später Änderungen an Ihrem Arbeitsblatt vor, werden die Ergebnisse automatisch aktualisiert. Als nützlich erweist sich dies vor allem dann, wenn die symbolischen und numerischen Gleichungen des Arbeitsblatts miteinander verbunden sind.

Arbeiten mit den Menübefehlen im Menü "Symbolik"

Im Unterschied zur numerischen Bearbeitung und dem symbolischen Gleichheitszeichen handelt es sich bei den Menübefehlen im Menü Symbolik nicht um aktive Befehle. Das heißt, Sie können diese Befehle nur immer wieder einzeln auf ausgewählte Ausdrücke anwenden. Die Befehle "kennen" keine vorher eingegebenen Definitionen, und sie nehmen auch keine automatischen Aktualisierungen vor. Es empfiehlt sich daher, diese Menübefehle nur zu verwenden, wenn die symbolische Berechnung relativ separat vom Rest des Arbeitsblatts erfolgen soll und keine vorher vorgenommenen Definitionen eingebunden werden müssen.


Operator "Vektorbetrag"

VEKTORBETRAG

Tastaturbefehl: |

| v |

Gibt den Betrag des Vektors v zurück. Dies ist die Quadratwurzel der Summe des ins Quadrat gesetzten Betrages der Elemente in v.

Operanden:

v ist ein Vektor.

Zum Ermitteln des Betrages der einzelnen Elemente in einem Vektor gehen Sie wie folgt vor:

  1. Setzen Sie | v | zwischen die Bearbeitungslinien.

  2. Wenden Sie den Operator "Vektorisieren" an (Strg+-).


Operator "Tiefgestellter Vektorindex"

TIEFGESTELLTER VEKTORINDEX

Tastaturbefehl: [

Gibt das n-te Element von v zurück. Wenn v kein n-tes Element hat, erscheint eine entsprechende Fehlermeldung.

Operanden:

v ist ein Vektor (ein Feld mit einer Spalte).

n ist eine dimensionslose ganze Zahl.

Denken Sie daran, daß alle Felder standardmäßig bei 0 und nicht bei 1 beginnen. Für einen Vektor mit 10 Elementen muß n zwischen 0 und 9 liegen. Wenn Sie dies ändern wollen, wählen Sie den Befehl Optionen / Vordefinierte Variablen im Menü Rechnen, und ändern Sie den Wert für "ORIGIN".

Verwenden Sie beim Darstellen von Vektoren in Diagrammen tiefgestellte Indizes.


OPERATOR "VEKTORISIEREN"

Tastaturbefehl: Strg+-

Ändert die Bedeutung der Operatoren und Funktionen so, daß sie für jedes Element eines Feldes gelten. Dadurch können Sie Berechnungen gleichzeitig ausführen.

Operanden:

A und B sind Felder mit derselben Anzahl von Zeilen und Spalten.

Zum Vektorisieren eines Ausdrucks gehen Sie wie folgt vor:

  1. Setzen Sie den Ausdruck zwischen die Bearbeitungslinien.

  2. Drücken Sie Strg+-.

Beispiele:

Zur Ausführung einer Matrixmultiplikation von A und B würde folgendes angezeigt werden:

Zum Multiplizieren jedes Elements von A mit dem entsprechenden Element in B:

Hinweis:

Viele Funktionen und Operatoren führen automatisch Operationen an den Elementen eines Feldes aus, so daß nicht immer der Operator "Vektorisieren" verwendet werden muß. Setzen Sie den Operator "Vektorisieren" vor allem dann ein, wenn eine Funktion oder ein Operator eine spezielle Bedeutung für Felder hat. Im Beispiel oben hat die Multiplikation z. B. eine spezielle Bedeutung, wenn Sie auf Felder angewendet wird, und diese Bedeutung wird standardmäßig verwendet. Der Operator "Vektorisieren" muß verwendet werden, um eine elementweise Multiplikation zu erzwingen.


SYMBOLISCHES VEKTORISIEREN

Mit dem Vektorisierungsoperator wenden Sie eine vordefinierte Funktion auf alle Elemente einer Matrix an, wie unten gezeigt. Zur Anwendung des Vektorisierungsoperators markieren Sie den gesamten Ausdruck (Funktion und Matrixargument), und drücken Sie Strg+ -. Wählen Sie dann Vereinfachen im Menü Symbolik.


MENÜ "ANSICHT"

Symbolleisten

Statusleiste

Bereiche

Zoom...

Aktualisieren

Animieren...

Wiedergeben...

Einstellungen


EINSEHEN DER URSPRÜNGLICHEN VERSION DES ELEKTRONISCHEN BUCHS

Sie können den derzeit offenen Abschnitt aus dem nicht veränderten Exemplar des Elektronischen Buchs wie folgt vorübergehend einsehen:

Wählen Sie den Befehl Originalabschnitt einsehen aus dem Kontextmenü "Bücher" im Fenster "Informationszentrum/Elektronisches Buch".

Rückkehr zur geänderten Version des derzeit offenen Abschnitts:

Wählen Sie den Befehl Geänderten Abschnitt einsehen aus dem Kontextmenü "Bücher" im Fenster "Informationszentrum/Elektronisches Buch".


Wavelet-Transformationen

WAVELET-TRANSFORMATIONEN (nur in Mathcad Professional)

wave(v) Gibt die Wavelet-Transformation der Daten in v über den Daubechies-4-Koeffizienten-Wavelet-Filter zurück.

iwave(u) Gibt die zu wave inverse diskrete Wavelet-Transformation für die Daten in u zurück.

Argumente:

v und u müssen [image] Elemente haben, wobei m eine ganze Zahl ist.

Alle Elemente von v müssen reell sein.


WEIBULL-VERTEILUNG

dweibull(x,s) Gibt die Wahrscheinlichkeitsdichte für die Weibull-Verteilung zurück.

pweibull(x,s) Gibt die kumulative Wahrscheinlichkeitsverteilung zurück.

qweibull(p,s) Gibt die inverse kumulative Wahrscheinlichkeitsverteilung zurück.

rweibull(m,s) Gibt einen Vektor aus m Zufallszahlen zurück, die die Weibull-Verteilung aufweisen.


EINSCHRÄNKUNG AUF LETZTEN PUNKT

Wenn Sie an den Zwischenwerten der Lösung nicht interessiert sind, können Sie Verarbeitungszeit sowie Arbeitsspeicher sparen, indem Sie eine der folgenden Funktionen verwenden.

stiffb und stiffr für steife Systeme

rkadapt für sich langsam ändernde Systeme

bulstoer für stetige Systeme

Anders als bei den Funktionen, die mit Großbuchstaben geschrieben werden, geben Sie hier nicht die Anzahl der Punkte im Ergebnis an. Statt dessen müssen Sie den Genauigkeitsgrad angeben. Die Funktionen generieren dann eine Lösung mit der benötigten Anzahl von Elementen.

Verwandte Themen

Umwandeln einer Differentialgleichung in die Standardform, um einen Lösungsalgorithmus für Differentialgleichungen anwenden zu können

Andere Lösungsalgorithmen für Differentialgleichungen


While-Schleifen

"WHILE"-SCHLEIFEN (nur Mathcad Professional)

Verwenden Sie eine "while"-Schleife, wenn Sie möchten, daß eine Gruppe von Anweisungen solange ausgeführt wird, bis eine Bedingung erfüllt ist. Stellen Sie sicher, daß eine Anweisung vorhanden ist, aufgrund derer die Bedingung nicht erfüllt wird. Andernfalls wird die Schleife unendlich lange ausgeführt, und Sie müssen sie durch Drücken von Esc stoppen.

Zum Einfügen einer "while"-Schleife gehen Sie wie folgt vor:

Klicken Sie auf den Platzhalter, in den Sie die "while"-Schleife eingeben möchten.

Klicken Sie auf [image] auf der Symbolleiste "Rechnen", um die Symbolleiste "Programmierung" zu öffnen, die die Programmierungsoperatoren enthält.

Klicken Sie auf die Schaltfläche "while". Geben Sie nicht einfach "while" ein.

Geben Sie in den Platzhalter rechts neben "while" einen Booleschen Ausdruck ein. Klicken Sie gegebenenfalls in der Symbolleiste "Programmierung" auf die Schaltfläche "+1 Zeile", um Platzhalter für zusätzliche Anweisungen einzufügen.

Geben Sie in den Platzhalter unter "while" die Anweisung ein, die wiederholt ausgeführt werden soll. Fügen Sie mit der Schaltfläche "+ 1 Zeile" gegebenenfalls Platzhalter für weitere Anweisungen ein.

"While"-Schleifen sind dann nützlich, wenn Sie die Ausführung bei Eintreten einer Bedingung stoppen möchten und Sie nicht genau wissen, wann diese Bedingung eintritt. Wenn Sie genau wissen, wie viele Wiederholungen Sie benötigen, verwenden Sie statt dessen eine "for"-Schleife.

Aufrufen eines QuickSheet-Beispiels


MENÜ "FENSTER"

Überlappend

Untereinander

Nebeneinander

Symbole anordnen

Liste geöffneter Fenster

Weitere Fenster


VERWENDEN VON GRADANGABEN

Die trigonometrischen Funktionen gehen alle davon aus, daß das Argument in Radiant angegeben ist. Sie können aber auch eigene trigonometrische Funktionen definieren, die als Argumente Winkelangaben in Grad zulassen. Siehe dazu das folgende Beispiel:

Verwandte Themen:

Umwandlung in Grad


Funktion SCHREIBEN

SCHREIBEN VON DATEN AUF FESTPLATTE

SCHREIBEN("datei") Schreibt eine Zahl in die Datei datei.

Argumente:

datei ist entweder ein Dateiname oder der Pfad zu einer ASCII-Datei.

datei wird als Zeichenfolge eingegeben.

Die Funktion SCHREIBEN wird normalerweise zusammen mit einem Vektor und einer Bereichsvariable verwendet, wie z. B. in:

i := 1..N

SCHREIBEN("datei.dat") :=

Im Beispiel oben wird die Liste der Zahlen im Vektor v in die Datei datei.dat geschrieben.

ACHTUNG: Mathcad 8 enthält diese Funktion nur, um die Kompatibilität mit älteren Mathcad-Versionen zu gewährleisten. Die Funktion ist jedoch veraltet und sollte nicht mehr verwendet werden. Verwenden Sie zum Schreiben von Daten in eine Datendatei statt dessen die Komponente "Dateien lesen/schreiben" bzw. die Funktion PRNSCHREIBEN.


Schreiben von Daten in eine Datendatei mit Hilfe einer Funktion

SCHREIBEN VON DATEN AUF FESTPLATTE

PRNSCHREIBEN("datei") Schreibt ein Feld in die Datei datei.

Argumente:

datei ist entweder der Dateiname oder der vollständige Pfad zu einer ASCII-Datendatei.

datei wird als Zeichenfolge eingegeben.

Beispiel:

PRNSCHREIBEN("c:\daten\ergebnis.prn") := A

A ist eine Matrix, deren Werte in die im Verzeichnis c:\daten befindliche Datendatei ergebnis.prn geschrieben werden.

Hinweise:

  • PRNSCHREIBEN ordnet die Daten in der ASCII-Datei entsprechend der ursprünglichen Matrix in Zeilen und Spalten an. Standardmäßig schreibt PRNSCHREIBEN vier signifikante Ziffern in Spalten mit einer Breite von acht Ziffern. Sie können diese Vorgabe ändern, indem Sie den Befehl Optionen / Vordefinierte Variablen im Menü Rechnen wählen und die Werte für PRNPRECISION und PRNCOLWIDTH ändern.

  • Wenn Sie das Argument dieser Funktion ändern, sollten Sie es stets aktualisieren. Klicken Sie dazu auf das Argument, und wählen Sie den Befehl Berechnen im Menü Rechnen.


FAKTOR ODER ZÄHLER GLEICH NULL

Zugunsten der Effizienz nimmt Mathcad stets an, daß für jeden gegebenen Ausdruck x folgendes gilt:

0*x=0

sowie

0/x = 0

Stößt Mathcad auf eine Berechnung dieses Typs, wird x daher nicht berechnet. Dies hat folgende Konsequenzen:

Mathcad legt sofort den Nullwert als Ergebnis für solche Ausdrücke fest, selbst wenn für x eine zeitaufwendige Berechnung wie ein Integral oder eine Summierung erforderlich wäre.

Würde die Berechnung von x zu einem Fehler führen, bleibt dies unentdeckt, da Mathcad ohne eine Berechnung den Wert Null als Ergebnis ausgibt. In bestimmten Fällen ist dies wünschenswert, in anderen eher störend.

Mathcad gibt als Ergebnis für 0/0 anstelle eines Fehlers Null aus.


Vergrößern eines 3D-Diagramms

VERGRÖSSERN EINES 3D-DIAGRAMMS

Zum Vergrößern eines 3D-Diagramms gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm.

  2. Halten Sie die Umschalttaste und die Maustaste gedrückt.

  3. Ziehen Sie die Maus.

  4. Lassen Sie die Maustaste los, wenn der Vergrößerungsfaktor korrekt ist.

Zum Vergrößern eines 3D-Diagramms um einen bstimmten Betrag gehen Sie folgendermaßen vor:

  1. Klicken Sie mit der rechten Maustaste auf das Diagramm.

  2. Wählen Sie Eigenschaften im Popup-Menü.

  3. Klicken Sie im Dialogfeld auf die Registerkarte "Allgemein".

  4. Ändern Sie den Wert im Textfeld "Zoom".

Hinweis:

Wenn Sie mit einer IntelliMouse-kompatiblen Maus mit Mittelrad arbeiten, können Sie das Rad zum Vergrößern oder Verkleinern eines dreidimensionalen Diagramms drehen.


Vergrößern eines Kreisdiagramms

VERGRÖSSERN EINES KREISDIAGRAMMS

Zum Vergrößern eines Teils eines Diagramms gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Kreisdiagramm, um es auszuwählen, und wählen Sie dann Diagramm / Zoom im Menü Format, damit das Dialogfeld "Kreis-Zoom" aufgerufen wird.

  2. Setzen Sie den Zeiger in den Diagrammbereich, drücken Sie die Maustaste, und halten Sie sie gedrückt. Ziehen Sie die Maus, bis der gestrichelte Auswahlkreis den zu vergrößernden Bereich gerade umschließt.

  3. Lassen Sie die Maustaste los. Der Radius des ausgewählten Bereichs wird im Feld "Radius" des Dialogfelds "Kreis-Zoom" aufgeführt.

  4. Wählen Sie die Schaltfläche "Zoom", damit das Diagramm wieder angezeigt wird. Die Achsenbegrenzungen werden vorübergehend auf die im Dialogfeld "Kreis-Zoom" angegebenen Koordinaten festgelegt. Um diese Achsenbegrenzungen permanent anzuwenden, klicken Sie auf "OK."

  5. Wählen Sie "Zurück", wenn Sie den Zustand des Diagramms vor dem Vergrößern/Verkleinern wiederherstellen möchten. Falls Sie mehrmals Ausschnitte des Kreisdiagramms vergrößert haben, klicken Sie auf "Original", um das ursprüngliche Diagramm wiederherzustellen.


Vergrößern eines X-Y-Diagramms

VERGRÖSSERN EINES X-Y-DIAGRAMMS

Zum Vergrößern eines Teils eines Diagramms gehen Sie folgendermaßen vor:

  1. Klicken Sie in das Diagramm, damit es ausgewählt wird.

  2. Wählen Sie Diagramm / Zoom im Menü Format, damit das Dialogfeld "X-Y-Zoom" aufgerufen wird.

  3. Setzen Sie im Diagrammbereich den Zeiger auf eine Ecke des zu vergrößernden Bereichs, drücken Sie die Maustaste, und halten Sie sie gedrückt.

  4. Ziehen Sie die Maus so, daß der zu vergrößernde Bereich von einem gestrichelten Auswahlrahmen eingeschlossen wird.

  5. Klicken Sie auf "Zoom", damit das Diagramm neu angezeigt wird.

Wenn Sie auf "Zoom" klicken, werden als Achsenbegrenzungen vorübergehend die im Dialogfeld "Zoom" angegebenen Koordinaten festgelegt. Um diese Achsenbegrenzungen permanent anzuwenden, klicken Sie auf "OK."


Z-TRANSFORMATION

Zur Auswertung der z-Transformation einer Funktion gehen Sie wie folgt vor:

  1. Geben Sie den zu transformierenden Ausdruck ein.

  2. Klicken Sie auf die Transformationsvariable.

  3. Wählen Sie Transformation / z- im Menü Symbolik.

Mathcad gibt bei z-Transformationen eine Funktion in der Variable z zurück. Wenn der zu transformierende Ausdruck bereits ein z enthält, wird statt dessen eine Funktion in der Variable zz zurückgegeben. Mit dem Befehl Variable / Ersetzen können Sie z durch eine andere Variable oder einen Ausdruck ersetzen.

Hinweis:

Bei Verwendung der symbolischen Befehle aus dem Menü Symbolik werden die Variablendefinitionen in Ihrem Arbeitsblatt nicht berücksichtigt. Wenn Sie diese Art der aktiven symbolischen Berechnung benötigen, verwenden Sie anstelle der Menübefehle die aktive symbolische Auswertung.


Weitere Informationsquellen

Das Mathcad-Hilfesystem bietet umfassende Informationen zu den Mathcad-Funktionen. Zusätzlich gibt es jedoch weitere Informationsquellen, die für Sie von Interesse sein könnten:

Informationszentrum

Online-Informationszentrum in Mathcad, das eine Reihe von Lernprogrammen, Beispielen und Referenzmaterialien bietet.

WWW-Foren

Ein interaktiver World Wide Web-Dienst, über den Sie Kontakt mit einer Mathcad-Benutzergemeinde erhalten.

MathSoft Web-Site

Auf den verschiedenen Seiten stehen Mathcad-Beispieldateien, mathematisches Referenzmaterial, Berichte über mathematische Forschungen und Hinweise über Produkte für Mathcad und andere Anwendungen bereit, die von MathSoft angeboten werden.

Technischer Kundendienst

Der technische Kundendienst hält in einem automatisierten Telefonsystem und in einer Suchdatenbank im Internet Lösungen für zahlreiche Fragen bereit. Außerdem können Sie unsere Kundendienstmitarbeiter über E-Mail, Fax und Telefon direkt erreichen.

Verwandte Themen

Verwenden des Hilfesystems


Drucken aus dem Hilfesystem

Zum Drucken eines Themas aus dem Hilfesystem gehen Sie vor wie folgt:

Suchen Sie das Thema heraus, so daß es im Hilfefenster angezeigt wird, und klicken Sie auf die Schaltfläche [image].

ODER

Klicken Sie mit der rechten Maustaste auf das Thema im Inhaltsverzeichnis, und wählen Sie den Befehl Drucken aus dem Kontextmenü.

Hinweis:

Sollen alle Themen gedruckt werden, die mit einem bestimmten Thema verknüpft sind, so wählen Sie unten im Dialogfeld "Drucken" die Option "Alle durch Links verbundenen Dokumente drucken".

Verwandte Themen

Verwenden des Hilfesystems

Drucken aus dem Hilfesystem

Steuern des Hilfefensters

Kontextsensitive Hilfe

Weitere Informationsquellen


Technischer Kundendienst

Es gibt verschiedene Möglichkeiten, den technischen Kundendienst von Mathcad zu erreichen.

Web-Site des technischen Kundendiensts

Wenn Sie über einen Internet-Anschluß verfügen und Microsoft Internet Explorer geladen ist, können Sie die Verbindung zur Web-Site des technischen Kundendiensts von Mathsoft herstellen, der Mathcad-spezifische Informationen, Antworten auf häufige Fragen und damit verbundene Problemstellungen bietet.

Kontaktaufnahme mit dem technischen Kundendienst

In den USA und in Kanada

  • Automatisiertes Lösungszentrum und Faxabrufsystem:

  • E-Mail: support@mathsoft.com

  • Fax: 617-577-8829

  • Telefon: 617-577-1778

In allen anderen Ländern:

Hinweise zum zuständigen Kundendienstzentrum für Ihre Region finden Sie auf der technischen Kundendienstkarte. Auch das Kundendienstzentrum in Großbritannien kann Ihnen weiterhelfen:

  • Automatisiertes Lösungszentrum und Faxabrufsystem: +44 1276 475350

  • E-Mail: help@mathsoft.co.uk

  • Fax: +44 1276 451224

Verwandte Themen

Weitere Informationsquellen

Kontaktaufnahme mit MathSoft, Inc.