Allgemeines zu Taskplaner

Taskplaner

Mit Taskplaner können Sie die Ausführung von Befehlen, Programmen oder Skripten zeitlich planen:

  • Bevor Sie Taskplaner verwenden, lesen Sie das Thema Checkliste.
  • Hilfe zu bestimmten Tasks finden Sie unter Wie wird's gemacht.
  • Allgemeine Hintergrundinformationen finden Sie unter Konzepte.
  • Anweisungen zur Problemlösung finden Sie unter Fehlerbehebung.


Checkliste für den Terminplaner

Checkliste

In der folgenden Tabelle sind die Aktionen aufgeführt, die Sie mit dem Taskplaner am häufigsten durchführen. Eine vollständige Liste der Anweisungen zum Taskplaner finden Sie unter Wie wird's gemacht?.

Schritt | Referenz
Bevor Sie die Ausführung eines Tasks zeitlich planen können, müssen Sie einen Task hinzufügen. | Planen eines neuen Tasks
Sobald geplante Tasks erstellt sind, können Sie Programm, Zeitplan oder Kennzeichen eines bestimmten Tasks ändern. | Ändern eines geplanten Tasks
Geplante Tasks, die nicht mehr benötigt werden, können Sie vollständig entfernen. | Entfernen eines geplanten Tasks
Wenn ein geplanter Task gestartet wird, während Sie den Computer verwenden, können Sie den Task beenden und später erneut starten. | Beenden eines laufenden geplanten Tasks
Sie können die Ausführung aller geplanten Tasks vorübergehend beenden oder anhalten und sie zu einer späteren Zeit fortsetzen. | Vorübergehendes Anhalten aller Tasks


Wie wird's gemacht?

  • Zeitliches Planen von Tasks
  • Verwalten des Taskplaners


Planen von Tasks
  • Starten des Taskplaners
  • Planen eines neuen Tasks
  • Ändern eines geplanten Tasks
  • Entfernen eines geplanten Tasks
  • Beenden eines laufenden geplanten Tasks
  • Sofortiges Ausführen eines Tasks


Starten des Taskplaners

So starten Sie den Taskplaner

  • Sie können den Taskplaner starten, indem Sie zuerst auf Arbeitsplatz und danach auf Geplante Tasks doppelklicken.
  • Doppelklicken Sie auf Geplante Tasks und danach auf Geplanten Task hinzufügen, um den Assistenten für geplanten Tasks zu öffnen, der Sie beim Planen eines Tasks führt.


Planen eines Task

So planen Sie einen Task
  1. Starten Sie den Taskplaner.
  2. Doppelklicken Sie auf Geplanten Task hinzufügen.
  3. Befolgen Sie die Anweisungen im Assistenten für geplanten Tasks.

Hinweise

  • Wenn Sie erweiterte Einstellungen für diesen Task konfigurieren möchten, aktivieren Sie das Kontrollkästchen Weitere Eigenschaften für diesen Task beim Klicken auf "Fertig stellen" öffnen im letzten Bildschirm des Assistenten.
  • Wenn ein neuer Task bei jeder Ausführung wiederholt ausgeführt werden soll, aktivieren Sie das Kontrollkästchen Weitere Eigenschaften für diesen Task beim Klicken auf "Fertig stellen" öffnen im letzten Bildschirm des Assistenten und klicken danach auf das Registerblatt Zeitplan sowie auf Erweitert.
  • Wenn das Taskprogramm Parameter erfordert, aktivieren Sie das Kontrollkästchen Weitere Eigenschaften für diesen Task beim Klicken auf "Fertig stellen" öffnen im letzten Bildschirm des Assistenten, klicken anschließend auf das Registerblatt Task und geben sie nach dem Taskpfad in Ausführen ein.
  • Vergewissern Sie sich, dass Systemdatum und -zeit des Computers korrekt sind. Der Taskplaner benötigt diese Informationen, um zu wissen, wann geplante Tasks auszuführen sind. Um Datum und Uhrzeit zu überprüfen, oder zu ändern, doppelklicken Sie in der Taskleiste auf die Zeit.


Ändern eines geplanten Tasks

So ändern Sie einen geplanten Task
  1. Starten Sie den Taskplaner.
  2. Klicken Sie mit der rechten Maustaste auf den zu ändernden Task und danach auf Eigenschaften.
  3. Führen Sie eine oder mehrere der folgenden Aktionen durch:
    • Um das auszuführende Programm zu ändern, geben Sie in Ausführen den Pfad des neuen Programms ein.
    • Um den Zeitplan des Tasks zu ändern, klicken Sie auf das Registerblatt Zeitplan.
    • Um die Einstellungen für den Task zu ändern, klicken Sie auf das Registerblatt Einstellungen.

Hinweise

  • Wenn Sie die Benutzerkennung oder das auszuführende Programm ändern, müssen Sie das Kennwort für die Benutzerkennung angeben.
  • Wenn das Taskprogramm Befehlszeilenoptionen erfordert, geben Sie diese nach dem Taskpfad in Ausführen ein.
  • Wenn der Pfad des Taskprogramms Leerzeichen enthält, schließen Sie den gesamten Taskpfad in doppelte Anführungszeichen ("") ein.
  • Vergewissern Sie sich, dass Systemdatum und -zeit korrekt sind, da der Taskplaner diese Informationen zum Ausführen des geplanten Tasks benötigt. Um diese Informationen zu überprüfen oder zu ändern, doppelklicken Sie auf die Zeitanzeige auf der Taskleiste.


Entfernen eines geplanten Tasks

So entfernen Sie einen geplanten Task
  1. Starten Sie den Taskplaner.
  2. Klicken Sie mit der rechten Maustaste auf den zu entfernenden Task, und klicken Sie anschließend auf Löschen.

Hinweise

  • Durch das Entfernen eines geplanten Tasks wird nur der Zeitplan aus der Liste der Zeitpläne gelöscht. Die Programmdatei auf der Festplatte wird nicht entfernt.
  • Sie können einen geplanten Task auch entfernen, indem Sie die Taste ENTF drücken.


Beenden eines laufenden geplanten Tasks

So beenden Sie einen laufenden geplanten Task
  1. Starten Sie den Taskplaner.
  2. Klicken Sie mit der rechten Maustaste auf den zu beendenden Task, und klicken Sie anschließend auf Task beenden.

Hinweise

  • Wenn ein geplanter Task ein anderes Programm startet, beendet dieser Befehl nur den ursprünglich geplanten Task und nicht den zweiten.
  • Um einen beendeten Task erneut zu starten, klicken Sie mit der rechten Maustaste auf den Task, und klicken Sie anschließend auf Ausführen.


Sofortiges Ausführen eines Tasks

So führen Sie einen Task sofort aus
  1. Starten Sie den Taskplaner.
  2. Klicken Sie mit der rechten Maustaste auf den zu startenden Task, und klicken Sie anschließend auf Ausführen.

Hinweise

  • Sie können den Task beenden, indem Sie im Menü Datei auf Task beenden klicken.
  • Wenn ein Task hätte ausgeführt werden sollen, dies aber nicht geschehen ist, klicken Sie im Menü Optionen auf Protokoll anzeigen, um das Taskprotokoll zu untersuchen.


Verwalten des Taskplaners
  • Anzeigen eines Protokolls früherer geplanter Tasks
  • Anzeigen geplanter Tasks auf Remotecomputern
  • Vorübergehendes Anhalten aller Tasks
  • Anhalten des Taskplaners
  • Festlegen des AT-Dienstkontos


Anzeigen eines Protokolls früherer geplanter Tasks

So zeigen Sie ein Protokoll früherer geplanter Tasks an
  1. Starten Sie den Taskplaner.
  2. Klicken Sie im Menü Optionen auf Protokoll anzeigen.


Anzeigen von geplanten Tasks auf Remotecomputern

So zeigen Sie geplante Tasks auf Remotecomputern an
  1. Doppelklicken Sie auf dem Desktop auf Netzwerkumgebung.
  2. Doppelklicken Sie auf den Computer, auf dem Sie geplante Tasks anzeigen möchten.
  3. Klicken Sie auf Geplante Tasks.

Hinweise

  • Sie können Tasks auf einem Remotecomputer, auf dem Windows ausgeführt wird, nur dann anzeigen, wenn Sie Adminstrator des Remotecomputers sind.
  • Sie können Tasks auf einem Remotecomputer, auf dem Windows ausgeführt wird, nur dann bearbeiten, wenn auf dem Remotecomputer eine Software zur Remoteregistrierung installiert und die Freigabe x$ freigegeben ist. Dabei steht x für die Festplatte, auf dem sich der Ordner Geplante Tasks befindet. Auf dem Computer, auf dem Windows ausgeführt wird, muss außerdem eigens aufgeführt sein, dass Ihre Benutzerkennung Remoteregistrierungszugriff besitzt. Sie können festlegen, welche Benutzer Remoteregistrierungszugriff auf einen Computer besitzen, auf dem Windows ausgeführt wird, indem Sie in der Systemsteuerung auf Kennwörter klicken.


Vorübergehendes Anhalten aller Tasks

So halten Sie alle Tasks vorübergehend an
  1. Starten Sie den Taskplaner.

  2. Klicken Sie im Menü Optionen auf Taskplaner anhalten.

Hinweise

  • Dieser Befehl ist nützlich, wenn Sie gerade ein anderes Programm (z.B. ein Spiel) ausführen oder Software installieren und nicht möchten, dass gleichzeitig geplante Tasks ausgeführt werden.
  • Tasks, die ausgeführt worden wären, während der Taskplaner angehalten ist, werden erst wieder zu ihrer nächsten geplanten Zeit ausgeführt.
  • Um die Zeitpläne aller Tasks erneut zu aktivieren, klicken Sie im Menü Optionen auf Taskplaner fortsetzen.


Anhalten des Taskplaners

So halten Sie den Taskplaner an
  1. Starten Sie den Taskplaner.
  2. Klicken Sie im Menü Optionen auf Taskplaner beenden.

Hinweis

  • Wenn Sie den Taskplaner beenden, werden die geplanten Tasks nicht ausgeführt, und der Taskplaner wird beim nächsten Start von Windows nicht automatisch gestartet.


Festlegen des AT-Dienstkontos

So legen Sie das AT-Dienstkonto fest
  1. Starten Sie den Taskplaner.
  2. Klicken Sie im Menü Optionen auf AT-Dienstkonto.
  3. Klicken Sie auf Dieses Konto, und geben Sie danach die Benutzerkennung ein, die mit dem Befehl at geplante Tasks ausführen wird.
  4. Geben Sie in Kennwort und in Kennwortbestätigung das korrekte Kennwort der Benutzerkennung ein.

Hinweise

  • Der AT-Dienst ist nur in Windows NT verfügbar.
  • Sie können auch auf Systemkonto klicken. In diesem Fall führt der Taskplaner die mit dem Befehl at geplanten Tasks unter Verwendung des Kontos "LocalSystem" aus, für das Administratorrechte erforderlich sind.

  • Die von Ihnen angegebene Benutzerkennung muss die entsprechenden Rechte besitzen, um die Tasks auszuführen, die Sie mit dem Befehl at planen. Wenn Sie beispielsweise Programme planen, die nur von Administratoren ausgeführt werden können, muss es sich bei der angegebenen Benutzerkennung um eine Administratorkennung handeln.


Konzepte des Taskplaners

Konzepte

Dieser Abschnitt enthält allgemeine Hintergrundinformationen über den Taskplaner:

  • Einführung in den Taskplaner
  • Verwenden des Taskplaners
  • Taskplaner und der Befehl at
  • Taskplaner und Sicherheit
  • Fehlerbehebung


Einführung in den Taskplaner

Mit dem Taskplaner können Sie Tasks (z.B. die Defragmentierung) so planen, dass es zu der für Sie günstigsten Zeit ausgeführt wird. Der Taskplaner wird bei jedem Start von Windows gestartet und im Hintergrund ausgeführt.

Mit dem Taskplaner können Sie folgende Aktionen durchführen:

  • Einen Task so planen, dass er täglich, wöchentlich, monatlich oder zu bestimmten Zeiten (z.B. beim Systemstart) ausgeführt wird.
  • Den Zeitplan eines Tasks ändern.
  • Einen geplanten Task beenden.
  • Die Art ändern, in der ein Task zu einer festgelegten Zeit ausgeführt wird.


Verwenden des Taskplaners

Das Betriebssystem Windows installiert den Taskplaner automatisch. Um den Zeitplanungsdienst zu verwenden, doppelklicken Sie in Arbeitsplatz auf den Ordner Geplante Tasks.

Sie können Tasks hinzufügen, indem Sie auf Geplanten Task hinzufügen doppelklicken. Der Assistent für geplante Tasks wird gestartet. Sie können Tasks hinzufügen, indem Sie Skripts, Programme oder Dokumente vom Windows Explorer oder vom Desktop in das Fenster Geplante Tasks ziehen.

Sie können geplante Tasks mit dem Taskplaner auch ändern, löschen, anhalten oder beenden, ein Protokoll früherer geplanter Tasks anzeigen oder Tasks anzeigen, die auf einem Remotecomputer geplant sind.

Genaue Anweisungen zum Verwenden des Taskplaners finden Sie unter Wie wird's gemacht?.

Optimale Vorgehensweisen beim Einsatz des Taskplaners

Im Betriebssystem Windows können Sie mit dem Taskplaner die Ausführung jeder beliebigen Anwendung zeitlich planen. Um den Taskplaner optimal auszunutzen, vergewissern Sie sich, dass Systemdatum und -zeit des Computers korrekt sind, bevor Sie einen Task hinzufügen.


Verwenden von Taskplaner und "at"-Befehl

Taskplaner und der "at"-Befehl

Zusätzlich zum Taskplaner können Sie auch den Befehl at verwenden, um Tasks automatisch auszuführen.

Der Taskplaner ist nicht mit dem Befehl at identisch, doch arbeiten beide zusammen. Wenn Sie einen Task mit dem Befehl at planen, erscheint er in der Liste der Tasks im Taskplaner-Fenster.

Mit dem Taskplaner können Sie Eigenschaften eines Tasks ändern, der mit dem Befehl at geplant wurde. Wenn Sie dies jedoch tun, müssen Sie weiterhin den Taskplaner verwenden, um auf den Task zuzugreifen. Ein Zugriff über den Befehl at ist dann nicht mehr möglich.

Um die Benutzerkennung festzulegen, die mit dem Befehl at geplante Tasks ausführt, klicken Sie im Arbeitsplatz auf Geplante Tasks und im Menü Optionen auf AT Dienstkonto.

Hinweis

  • Der AT-Dienst ist nur unter Windows NT verfügbar.


Sicherheit im Taskplaner

Taskplaner und Sicherheit

Sie können im Taskplaner Sicherheitsvorkehrungen treffen, indem Sie einem bestimmten Task einen Benutzernamen und ein Kennwort zuweisen. Sobald Benutzername und Kennwort eingerichtet sind, kann der Task von einem anderen Benutzern weder abgebrochen noch gelöscht werden.

Hinweise

  • Diese Sicherheitsfunktion ist nur in Windows NT verfügbar.
  • Sie müssen einen Benutzernamen im Assistenten für geplante Tasks eingeben, bevor Sie mit dem Planen eines Tasks fortfahren können. Kennwörter sind nicht erforderlich.
  • Sie können ein Kennwort festlegen oder ändern, indem Sie das Kontrollkästchen Weitere Eigenschaften für diesen Task beim Klicken auf "Fertig stellen" öffnen im letzten Bildschirm des Assistenten aktivieren.


Fehlerbehebung im Taskplaner

Wenn ein geplanter Task nicht wie erwartet ausgeführt wird, klicken Sie mit der rechten Maustaste auf den Task, und klicken Sie danach auf Eigenschaften. Überprüfen Sie, ob auf der Registerkarte Task das Kontrollkästchen Aktiviert aktiviert ist. Überprüfen Sie, ob auf der Registerkarte Zeitplan der Zeitplan korrekt festgelegt ist.

Wenn ein Taskprogramm nicht korrekt ausgeführt wird, müssen Sie vielleicht Befehlszeilenoptionen hinzufügen. Um mehr über ein bestimmtes Programm und dessen Befehlszeilenoptionen zu erfahren, versuchen Sie eine der folgenden Aktionen:

  • Zeigen Sie, falls verfügbar, die Onlinehilfe für das Programm an.

  • Geben Sie an einer Eingabeaufforderung Folgendes ein (wobei Programm für den Namen des Programms steht):

    • Programm /?


Windows NT-Komponente nicht installiert

Dieses Programm konnte nicht gestartet werden.

Mögliche Ursachen:

    • Es wurde von einem Systemadministrator entfernt.
    • Der Systemadministrator hat die mit der Datei verknüpfte Richtlinie geändert.
    • Das Programm ist auf dem Computer nicht installiert.
    • Es wurde aus Versehen gelöscht.
    • Die Datei ist beschädigt.

Wenn ein Systemadministrator Ihren Computer steuert, sollten Sie ihn bitten herauszufinden, warum das Programm nicht gestartet werden kann.