DirectX 진단 도구

Microsoft DirectX 진단 도구 설명서에는 다음 내용이 포함되어 있습니다.

  • DirectX 진단 도구 개요
  • DirectX 진단 도구를 사용한 문제 진단
  • DirectX 구성 요소 테스트
  • 기본 주사율 다시 정의
  • 정보 저장
  • WHQL 디지털 서명 확인


DirectX 진단 도구 개요

Microsoft DirectX 진단 도구는 시스템에 설치된 DirectX 응용 프로그래밍 인터페이스(API) 구성 요소 및 드라이버에 대한 정보를 제공합니다. 이 도구를 사용하면 사운드/그래픽 출력과 Microsoft DirectPlay 서비스 공급자를 테스트할 수 있으며, 일부 하드웨어 가속 기능을 사용하지 않도록 설정할 수도 있습니다.

또한, 진단 도구는 고객 지원 전화 서비스를 이용할 때 담당자에게 필요한 정보를 제공하는 데에도 유용하게 사용됩니다. 진단 도구를 사용하여 수집한 정보를 저장해 두었다가 전자 메일로 보낼 수 있습니다.

정보는 여러 페이지에 걸쳐 나타나며 다른 페이지로 이동하려면 다음과 같은 방법을 사용합니다.

  • 탭 클릭
  • 다음 페이지 클릭
  • 포커스가 탭 위에 있을 때 위쪽 화살표 또는 아래쪽 화살표 키 누르기

진단 도구의 DirectX 파일, 음악, 입력과 같은 일부 페이지에는 테이블 형태로 정보가 표시됩니다. 사용자는 이 테이블을 정렬하여 원하는 상세 정보를 좀더 쉽게 찾을 수 있습니다.

테이블의 정보를 정렬하려면

  1. 테이블을 정렬하는 데 사용할 정보가 포함된 열을 확인합니다.
  2. 열 맨 위의 헤더 단추를 클릭합니다.

    해당 열의 항목들이 사전순 또는 숫자순으로 정렬됩니다. 이를 역순으로(예: Z에서 A로) 정렬하려면 헤더 단추를 다시 클릭합니다.

참고 참고

  • 디스플레이 카드의 메모리 용량 등의 일부 정보는 근사값일 수 있습니다.
  • DirectX 진단 도구로 모아둔 정보를 저장하는 방법에 대해 더 자세히 알고 싶으면 관련 항목을 클릭하십시오.

관련 항목

DirectX 구성 요소 테스트

정보 저장


DirectX 진단 도구를 사용한 문제 진단

Microsoft DirectX 응용 프로그램을 실행하는 데에 문제가 있는 경우, DirectX 진단 도구가 그 원인을 찾을 수 있도록 도와 드립니다. 다음과 같은 몇 가지 항목을 확인해야 합니다.

  • 잘못된 버전의 DirectX 구성 요소 DirectX 파일 페이지의 참고 섹션에서 베타 파일 및 디버그 파일에 대한 경고를 찾아 보십시오. 베타 파일은 이전의 시험 버전으로, 판매용 프로그램에는 설치할 수 없습니다. 프로그램 개발에 사용되는 디버그 버전 역시 최종 제품에 설치할 수 없으며, 구성 요소의 디버그 버전을 사용할 경우 일반 정품 버전에서보다 프로그램의 실행 속도가 현저히 느려집니다.
  • 하드웨어 가속 기능 없음 일부 프로그램은 Microsoft DirectDraw 또는 Direct3D 하드웨어 가속 기능을 사용할 수 없으면 매우 느려지거나 아예 실행되지 않습니다. 디스플레이 페이지의 DirectX 기능에서 DirectDraw, Direct3D, 또는 AGP 질감 가속이 "사용할 수 없음"으로 표시되어 있는지 확인하십시오. 사용할 수 없음으로 표시되어 있으면 하드웨어 업그레이드를 고려해 보십시오. 그렇지 않고, Windows Server 2003 계열의 제품을 사용하고 있다면 그래픽 가속 기능도 사용할 수 있도록 설정해야 합니다. 그렇게 하려면 제어판의 디스플레이에서 설정 탭을 선택한 다음 고급을 클릭합니다. 문제 해결 탭에서 하드웨어 가속 슬라이더를 최대로 옮기면 그래픽 가속 기능이 설정됩니다.
  • 장치 연결 안 됨 조이스틱이나 기타 입력 장치가 응답하지 않으면 제대로 설정되지 않은 것일 수 있습니다. DirectX 진단 도구의 입력 페이지에 장치가 나열되는지 확인하십시오. 없는 경우 제어판을 사용하여 장치를 추가합니다.
  • 서명되지 않은 드라이버 Microsoft에서는 서명되지 않은 드라이버가 DirectX의 최신 버전과 완전히 호환되는지 테스트하지 않았습니다. 따라서, Microsoft Windows Hardware Quality Lab(WHQL)에 의해 디지털 서명된 드라이버를 사용할 것을 권합니다.

참고 참고

  • 하드웨어 가속을 지원하는 원격 컴퓨터에서 터미널 서비스를 사용하여 작업할 경우, DirectX 진단 도구가 하드웨어 가속이 지원되는 것으로 표시할 수도 있습니다. 그러나 터미널 서비스는 하드웨어 가속을 사용할 수 없으므로 실제로는 이 기능이 지원되지 않습니다.

관련 항목

정보 저장

WHQL 디지털 서명 확인


DirectX 구성 요소 테스트

시스템에 연결된 각각의 모니터에서 Microsoft DirectDraw 및 Direct3D를 테스트할 수 있습니다. 또한 각 웨이브 출력 장치에서 DirectSound를, 음악 포트에서 DirectMusic를 테스트할 수도 있습니다.

DirectX 기능을 테스트하려면

  1. 해당 페이지에서 테스트 단추를 클릭합니다.
  2. 표시되는 내용을 읽습니다.
  3. 보기 또는 듣기 테스트를 시작합니다.
  4. 테스트가 제대로 수행되었는지 확인하는 메시지가 나타날 때까지 각 테스트를 실행합니다. 아니오라고 대답하면 테스트가 더 이상 실행되지 않습니다.

DirectMusic의 경우에는 테스트가 한 번 있습니다. 해당 음악이 제대로 재생되면 확인을 클릭합니다.

이용 가능한 서비스 공급자의 Microsoft DirectPlay 기능을 테스트할 수 있습니다.

DirectPlay를 테스트하려면

  1. 네트워크 페이지에서DirectPlay 테스트를 클릭합니다.
  2. DirectPlay 테스트 대화 상자에서 사용자 이름을 입력하고 서비스 공급자를 선택합니다.
  3. 새 세션 만들기를 선택하고 확인을 클릭합니다.
  4. 모뎀 연결을 선택한 경우에는 모뎀 연결 대화 상자에서 응답을 클릭하여 모뎀을 자동 응답 모드로 설정합니다.

이제 이 컴퓨터와 연결을 설정할 수 있는 다른 컴퓨터에서 Microsoft DirectX 진단 도구를 실행합니다.

  1. DirectPlay 테스트를 클릭합니다.
  2. 다른 사용자 이름을 입력합니다.
  3. 동일한 서비스 공급자를 선택합니다.
  4. 기존 세션에 참가 단추를 클릭하고 확인을 클릭합니다.

    일부 연결 형식의 경우 전화 번호 등의 자세한 정보를 입력하라는 메시지가 나타날 수 있습니다. 로컬 네트워크의 TCP/IP 연결의 경우 입력란을 비워둘 수 있습니다.

  5. 처음 컴퓨터에서 만든 세션 이름이 들어 있는 세션 목록에서 해당 세션 이름을 선택합니다.
  6. 이제 두 컴퓨터에 모두 채팅 대화 상자가 표시됩니다. 한 컴퓨터의 입력란에 메시지를 입력하고 보내기를 클릭합니다. 두 컴퓨터에서 채팅 대화 상자의 스크롤 영역에 메시지가 표시됩니다.


기본 주사율 다시 정의

사운드 페이지에서 하드웨어 가속 슬라이더를 움직여 수준을 달리 설정할 수 있습니다. 이러한 하드웨어 가속 수준을 변경하려면 시스템 관리자로 로그인해야 합니다. Microsoft DirectX 진단 도구를 닫은 후에도 변경된 수준은 유지됩니다.

Microsoft DirectDraw 또는 Direct3D의 하드웨어 가속을 사용하고 있는 경우, 이 기능을 해제할 수 있습니다. 그렇게 하려면 각 디스플레이 장치의 디스플레이 페이지로 가서 사용 안 함을 클릭합니다. 하드웨어 가속 기능을 해제한 후에는 DirectX 진단 도구를 닫더라도 다른 응용 프로그램에서 사용할 수 없습니다. 하드웨어 가속 기능을 다시 사용하려면 해당 디스플레이 페이지에서 사용을 클릭합니다.

참고 참고

  • DirectDraw 가속 기능을 해제하면 Direct3D에 대한 가속 기능도 사용할 수 없게 됩니다.

또한 DirectDraw 전체 화면 응용 프로그램에서 설정한 모니터 화면 주사율을 다시 정의할 수도 있습니다. 어떤 응용 프로그램에 디스플레이 문제가 있고 이 응용 프로그램에서 화면 주사율을 잘못 설정했다는 것이 틀림 없을 때만 이 작업을 수행해야 합니다.

화면 주사율을 다시 정의하려면

  1. 기타 도움말 페이지에서 다시 정의를 클릭합니다.
  2. DirectDraw 화면 주사율 다시 정의 대화 상자에서 값 다시 정의를 선택하고 모니터에 맞는 적절한 화면 주사율을 입력합니다.
  3. 확인을 클릭합니다.

화면 주사율 다시 정의를 취소하고 DirectDraw 응용 프로그램에서 기본 화면 주사율을 설정하려면

  1. 기타 도움말 페이지에서 다시 정의를 클릭합니다.
  2. DirectDraw 화면 주사율 다시 정의 대화 상자에서 기본값을 클릭합니다.


정보 저장

  1. Microsoft DirectX 진단 도구를 사용하여 수집한 정보를 저장하려면 모든 정보 저장을 클릭합니다.
  2. 모든 페이지의 정보가 원하는 위치에 파일로 저장됩니다. 파일의 이름도 선택할 수 있습니다. XML 파일로 저장하려면 파일 형식에서 XML 파일(*.xml)을 클릭합니다.

참고 참고

  • 또는, 명령 프롬프트에 다음과 같이 입력하여 정보를 저장할 수도 있습니다.

    dxdiag [/x outfile] [/t outfile]

    이 명령에서 /x는 데이터를 XML 파일로 저장하고, /t는 데이터를 텍스트 파일로 저장하며, outfile은 파일의 이름과 위치를 지정합니다.


WHQL 디지털 서명 확인

드라이버가 Microsoft Windows Hardware Quality Lab(WHQL)에서 디지털 서명된 것인지 확인할 때, DirectX 진단 도구는 인터넷에 연결하여 새로운 WHQL 인증서의 다운로드를 시도할 수도 있습니다. 이 프로세스가 진행되는 동안에는 시스템에서 정보를 검색할 수 없습니다. 처음 DirectX 진단 도구를 실행할 때 인터넷 연결을 허용할 것인지 묻는 메시지가 표시됩니다. 다음에는 이 메시지가 표시되지 않습니다. 이 설정을 변경하려면 시스템 페이지로 가서 WHQL 디지털 서명 확인의 선택을 취소합니다.

또는, 명령 프롬프트에 다음과 같이 입력하여 변경할 수도 있습니다.

dxdiag [/whql:on] [/whql:off]

이 명령에서 /whql:on은 DirectX 진단 도구가 WHQL 디지털 서명을 확인하도록 허용하고, /whql:off는 DirectX 진단 도구가 WHQL 디지털 서명을 확인하도록 허용하지 않습니다.