Herramienta de diagnóstico de DirectX

La documentación de la Herramienta de diagnóstico de Microsoft DirectX incluye los siguientes temas:

  • Información general acerca de la Herramienta de diagnóstico de DirectX
  • Usar la Herramienta de diagnóstico de DirectX para diagnosticar problemas
  • Probar los componentes de DirectX
  • Reemplazar el comportamiento predeterminado
  • Guardar información
  • Buscar firmas digitales de WHQL


Información general acerca de la Herramienta de diagnóstico de DirectX

La herramienta de diagnóstico de Microsoft DirectX proporciona información acerca de los componentes y controladores de la interfaz de programación de aplicaciones (API) de DirectX que están instalados en el sistema. Permite realizar pruebas de salida de sonido y gráficos, y de los proveedores de servicios de Microsoft DirectPlay. También permite deshabilitar algunas características de aceleración de hardware.

Se puede utilizar para recopilar información para el técnico cuando se efectúa una llamada a soporte. La información recopilada por la herramienta se puede guardar y pegarla en un mensaje de correo electrónico.

La información se presenta en varias páginas. Para pasar de una página a otra:

  • Haga clic en las fichas.
  • Haga clic en Página siguiente.
  • Haga clic en las teclas FLECHA IZQUIERDA o FLECHA DERECHA cuando el enfoque se encuentre en una ficha.

Determinadas páginas de la herramienta de diagnóstico, como Archivos de DirectX, Música o Entrada presentan información en una tabla. Puede ordenar la información de esas tablas para encontrar con más facilidad la información específica que busca.

Para ordenar la información de una tabla

  1. Identifique la columna que contenga la información por la cual desearía ordenar la tabla.
  2. Haga clic en el botón del encabezado en la parte superior de la columna.

    La tabla se ordenará alfabética o numéricamente según los elementos de esa columna. Para revertir la ordenación (de la Z a la A, en vez de la A a la Z, por ejemplo), haga clic de nuevo en el botón del encabezado.

* Notas

  • Determinada información, como la cantidad de memoria instalada en una tarjeta gráfica, puede ser aproximada.
  • Para obtener más detalles acerca de cómo guardar la información recopilada por la herramienta de diagnóstico de DirectX, haga clic en Temas relacionados.

Temas relacionados

Probar los componentes de DirectX

Guardar información


Usar la Herramienta de diagnóstico de DirectX para diagnosticar problemas

Si tiene algún problema al ejecutar aplicaciones que utilicen Microsoft DirectX, la Herramienta de diagnóstico de DirectX puede ayudarle a encontrar el origen del problema. Éstos son algunos de los síntomas que debe buscar:

  • Versiones incorrectas de los componentes de DirectX. En la sección Notas de la página Archivos de DirectX, busque advertencias acerca de versiones beta y archivos de depuración. Los archivos de versiones beta son versiones de prueba preliminares y no se deben instalar con programas comerciales. Las versiones de depuración, que se utilizan en el desarrollo de programas, no se deben instalar con el producto final. Las versiones de depuración de los componentes pueden ocasionar que los programas se ejecuten mucho más despacio de lo que lo harían con versiones comerciales.
  • Ausencia de aceleración de hardware. Algunos programas se ejecutan muy despacio, e incluso no funcionan, si no está disponible la aceleración de hardware de Microsoft DirectDraw o de Direct3D. En la página Pantalla, compruebe en la sección Características de DirectX si DirectDraw, Direct3D o la aceleración de Texturas AGP están marcadas como "No disponible". En ese caso, tenga en cuenta la posibilidad de actualizar el hardware. Si utiliza un producto de la familia Windows .NET Server 2003, puede que necesite habilitar la aceleración de gráficos. Para ello, haga clic en el icono Pantalla del Panel de control, seleccione la ficha Configuración y, a continuación, haga clic en Avanzada. Seleccione la ficha Solucionar problemas y, a continuación, mueva el control deslizante Aceleración de hardware hasta Completa.
  • El dispositivo no está conectado. Si un joystick u otro dispositivo de entrada no responde, es posible que no esté correctamente configurado. Asegúrese de que el dispositivo aparece en la página Entrada de la Herramienta de diagnóstico de DirectX. De lo contrario, utilice el Panel de control para agregar el dispositivo.
  • Controladores sin firmar. Microsoft no ha comprobado la compatibilidad con la versión más reciente de DirectX de los controladores sin firma. Se recomienda que utilice controladores firmados digitalmente por los Laboratorios de control de calidad del hardware para Windows (WHQL) de Microsoft.

* Nota

  • Si utiliza Servicios de Terminal Server para trabajar en un sistema remoto que admita aceleración de hardware, la Herramienta de diagnóstico de DirectX podría indicar compatibilidad con la aceleración de hardware. Sin embargo, los Servicios de Terminal Server no pueden utilizar aceleración de hardware y, por lo tanto, la compatibilidad no estará disponible.

Temas relacionados

Guardar información

Buscar firmas digitales de WHQL


Probar los componentes de DirectX

Puede probar Microsoft DirectDraw y Direct3D en cada monitor conectado al sistema. También puede probar DirectSound en cada dispositivo de salida de ondas y DirectMusic en cada puerto de música.

Para probar una función de DirectX

  1. Haga clic en el botón Prueba de la página correspondiente.
  2. Lea los mensajes que aparezcan.
  3. Observe o escuche las pruebas.
  4. Deje que se ejecute cada prueba hasta que aparezca un mensaje preguntando si se realizó correctamente. Si responde No, no se ejecutarán más pruebas.

Para DirectMusic sólo existe una prueba. Haga clic en Aceptar cuando compruebe si la música se reproduce correcta o incorrectamente.

Puede probar las funciones de Microsoft DirectPlay en cualquiera de los proveedores de servicios disponibles.

Para probar DirectPlay

  1. En la página Red, haga clic en Probar DirectPlay.
  2. En el cuadro de diálogo Probar DirectPlay, escriba un nombre de usuario y elija un proveedor de servicios.
  3. Seleccione Crear nueva sesión y haga clic en Aceptar.
  4. Si eligió una conexión mediante módem, haga clic en Contestar en el cuadro de diálogo Conexión del módem para poner el módem en modo de respuesta automática.

A continuación, ejecute la Herramienta de diagnóstico de Microsoft DirectX en otro equipo que pueda establecer con el primero la conexión seleccionada.

  1. Haga clic en Probar DirectPlay.
  2. Escriba un nombre de usuario distinto.
  3. Elija el mismo proveedor de servicios.
  4. Haga clic en Unirse a sesión existente y, luego, en Aceptar.

    En algunos tipos de conexión, es posible que se le pida más información, como un número de teléfono. Si utiliza una conexión TCP/IP en una red local puede dejar en blanco el cuadro de texto.

  5. En la Lista de sesiones que contiene el nombre de la sesión que creó en el primer equipo, seleccione el nombre de la sesión.
  6. Ambos equipos deben mostrar a continuación un cuadro de diálogo de charla. Escriba un mensaje en el cuadro de entrada de uno de los equipos y haga clic en Enviar. El mensaje debe aparecer en el área de desplazamiento del cuadro de diálogo de charla, en ambos equipos.


Reemplazar el comportamiento predeterminado

En la página Sonido puede mover el control deslizante para establecer un nivel diferente de aceleración de hardware. Debe ser administrador del sistema para cambiar los niveles de aceleración del hardware. El nivel que establezca permanecerá vigente después de cerrar la Herramienta de diagnóstico de Microsoft DirectX.

Si está disponible la aceleración de hardware para Microsoft DirectDraw o Direct3D, puede deshabilitarla si lo desea. Para ello, vaya a la página Pantalla de cada dispositivo de pantalla y haga clic en el botón Deshabilitar. Una vez haya deshabilitado la aceleración de hardware, ésta no estará disponible en ninguna aplicación, incluso después de cerrar la Herramienta de diagnóstico de DirectX. Para volver a habilitar la aceleración de hardware, haga clic en Habilitar, en la página Pantalla correspondiente.

* Nota

  • Al deshabilitar la aceleración de DirectDraw también se deshabilita la aceleración para Direct3D.

También puede reemplazar la frecuencia de actualización del monitor establecida para las aplicaciones DirectDraw que se ejecutan a pantalla completa. Sólo debe hacerlo si tiene algún problema de presentación con una aplicación y tiene un buen motivo para creer que la aplicación está utilizando una frecuencia de actualización no válida.

Para reemplazar una frecuencia de actualización

  1. En la página Más ayuda, haga clic en Suplantar.
  2. En el cuadro de diálogo Suplantar comportamiento de actualización de DirectDraw, seleccione Reemplazar valor y escriba una frecuencia de actualización válida para el monitor.
  3. Haga clic en Aceptar.

Para cancelar el reemplazo de la frecuencia de actualización y permitir que las aplicaciones DirectDraw establezcan su propia frecuencia

  1. En la página Más ayuda, haga clic en Suplantar.
  2. En el cuadro de diálogo Suplantar comportamiento de actualización de DirectDraw, haga clic en Valor predeterminado.


Guardar información

Para guardar información

  1. Para guardar la información recopilada con la Herramienta de diagnóstico de DirectX, haga clic en Guardar toda la información.
  2. La información de todas las páginas se guarda en un archivo con el nombre y la ubicación que usted elija. Para guardarlo como archivo XML, en Guardar como tipo, haga clic en Archivo XML (*.xml).

* Nota

  • También puede guardar información escribiendo lo siguiente en el símbolo del sistema:

    dxdiag [/x archivo_de_salida] [/t archivo_de_salida]

    En este comando, /x envía los datos a un archivo XML, /t envía los datos a un archivo de texto, y archivo_de_salida especifica el nombre y la ubicación del archivo.


Buscar firmas digitales de WHQL

Cuando compruebe que los controladores tienen firma digital de los Laboratorios de control de calidad del hardware para Windows (WHQL) de Microsoft, la Herramienta de diagnóstico de DirectX puede intentar conectarse a Internet para descargar nuevos certificados de WHQL. Durante este proceso no se recupera información del sistema. La herramienta le pedirá permiso para conectarse a Internet la primera vez que la ejecute. Esto sólo se le preguntará una vez. Para cambiar su respuesta, vaya a la página Sistema y seleccione Buscar firmas digitales de WHQL.

También puede cambiarla escribiendo lo siguiente en el símbolo del sistema:

dxdiag [/whql:on] [/whql:off]

En este comando, /whql:on permite que la Herramienta de diagnóstico de DirectX busque firmas digitales de WHQL, y /whql:off no permite que la Herramienta de diagnóstico de DirectX busque firmas digitales de WHQL.