DirectX-Diagnoseprogramm

Die Dokumentation zum Microsoft DirectX-Diagnoseprogramm enthält folgende Themen:

  • Übersicht zum DirectX-Diagnoseprogramm
  • Diagnostizieren von Problemen mit dem DirectX-Diagnoseprogramm
  • Testen von DirectX-Komponenten
  • Außerkraftsetzen von Standardverhalten
  • Speichern von Informationen
  • Überprüfen auf digitale WHQL-Signaturen


Übersicht zum DirectX-Diagnoseprogramm

Das Microsoft DirectX-Diagnoseprogramm stellt Informationen zu den API-Komponenten (Anwendungsprogrammierschnittstelle) und -Treibern von DirectX auf dem System bereit. Sie können damit die Sound- und Grafikausgabe sowie Microsoft DirectPlay-Dienstanbieter testen. Sie können außerdem bestimmte Funktionen für die Hardwarebeschleunigung deaktivieren.

Sie können mit dem Diagnoseprogramm Informationen sammeln, um sie einem Supportmitarbeiter zur Verfügung zu stellen. Sie können die mit dem Programm gesammelten Informationen speichern und sie in eine E-Mail-Nachricht einfügen.

Die Informationen werden auf mehreren Seiten dargestellt. Sie können folgendermaßen zwischen den Seiten wechseln:

  • Klicken auf die Registerkarten.
  • Klicken auf Nächste Seite.
  • Drücken der NACH-LINKS-Taste oder der NACH-RECHTS-Taste, wenn sich der Fokus auf einer Registerkarte befindet.

Auf bestimmten Seiten des Diagnoseprogramms, wie DirectX-Dateien, Musik oder Eingabe, werden Informationen in einer Tabelle angezeigt. Sie können die Informationen in diesen Tabellen sortieren, um die gesuchten Details leichter zu finden.

So sortieren Sie die Informationen in einer Tabelle

  1. Identifizieren Sie die Spalte mit den Informationen, nach denen die Tabelle sortiert werden soll.
  2. Klicken Sie auf die Headerschaltfläche ganz oben in der Spalte.

    Abhängig von den Elementen in der Spalte wird die Tabelle in alphabetischer oder numerischer Reihenfolge sortiert. Um in umgekehrter Reihenfolge zu sortieren (z. B. Z bis A statt A bis Z), klicken Sie erneut auf die Headerschaltfläche.

* Anmerkungen

  • Einige Informationen, beispielsweise zum Arbeitsspeicherumfang auf einer Grafikkarte, können ungefähre Angaben sein.
  • Weitere Informationen zum Speichern von Informationen, die mit dem DirectX-Diagnoseprogramm gesammelt werden, finden Sie unter "Verwandte Themen".

Verwandte Themen

Testen von DirectX-Komponenten

So speichern Sie Informationen


Diagnostizieren von Problemen mit dem DirectX-Diagnoseprogramm

Falls beim Ausführen von Microsoft DirectX-Anwendungen Probleme auftreten, können Sie mit dem DirectX-Diagnoseprogramm nach der Ursache suchen. Es folgen einige Hinweise auf häufige Problemursachen:

  • Falsche Versionen von DirectX-Komponenten. Suchen Sie auf der Seite DirectX-Dateien im Abschnitt Anmerkungen nach Warnungen zu Beta- und Debugdateien. Betadateien sind frühe Testversionen und sollten in kommerziellen Programmen nicht installiert werden. Debugversionen werden zum Entwickeln von Programmen verwendet und sollten nicht mit dem fertigen Produkt installiert werden. Debugversionen von Programmkomponenten können deutlich langsamer sein als Verkaufsversionen.
  • Fehlende Hardwarebeschleunigung. Einige Programme sind sehr langsam oder können gar nicht ausgeführt werden, wenn die Microsoft DirectDraw- oder Direct3D-Hardwarebeschleunigung nicht verfügbar ist. Überprüfen Sie auf der Seite Anzeige unter DirectX-Funktionen, ob die DirectDraw-, Direct3D- oder AGP-Oberflächenbeschleunigung als Nicht verfügbar gekennzeichnet ist. Falls dies zutrifft, sollten Sie möglicherweise die Hardware aktualisieren. Falls Sie ein Produkt der Windows .NET Server 2003-Produktfamilie verwenden, müssen Sie möglicherweise die Grafikbeschleunigung aktivieren. Öffnen Sie dazu in der Systemsteuerung den Eintrag Anzeige, und klicken Sie auf der Registerkarte Einstellungen auf Erweitert. Verschieben Sie auf der Registerkarte Problembehandlung den Schieberegler Hardwarebeschleunigung auf Maximal.
  • Nicht verbundenes Gerät. Falls ein Joystick oder ein anderes Eingabegerät nicht reagiert, ist dieses Gerät möglicherweise nicht ordnungsgemäß eingerichtet. Überprüfen Sie, ob das Gerät auf der Seite Eingabe des DirectX-Diagnoseprogramms angezeigt wird. Ist dies nicht Fall, fügen Sie das Gerät mithilfe der Systemsteuerung hinzu.
  • Nicht signierte Treiber. Nicht signierte Treiber wurden von Microsoft nicht auf vollständige Kompatibilität mit der neusten Version von DirectX getestet. Stattdessen empfiehlt sich die Verwendung von Treibern, die von Microsoft Windows Hardware Quality Labs (WHQL) digital signiert wurden.

* Anmerkung

  • Falls Sie Terminaldienste zur Arbeit auf einem Remotesystem verwenden, das die Hardwarebeschleunigung unterstützt, zeigt das DirectX-Diagnoseprogramm möglicherweise die Unterstützung für die Hardwarebeschleunigung an. Terminaldienste können die Hardwarebeschleunigung jedoch nicht verwenden, die Unterstützung steht demnach nicht zur Verfügung.

Verwandte Themen

So speichern Sie Informationen

Überprüfen auf digitale WHQL-Signaturen


Testen von DirectX-Komponenten

Sie können Microsoft DirectDraw und Direct3D auf jedem mit Ihrem System verbundenen Monitor testen. Außerdem können Sie DirectSound auf jedem Waveausgabegerät und DirectMusic an jedem Musikanschluss testen.

So testen Sie eine DirectX-Funktion

  1. Klicken Sie auf der entsprechenden Seite auf die Schaltfläche zum Testen.
  2. Lesen Sie alle angezeigten Meldungen.
  3. Sehen bzw. hören Sie die Testausgaben an.
  4. Brechen Sie die einzelnen Tests nicht ab, sondern warten Sie, bis in einer Meldung gefragt wird, ob der Test erfolgreich war. Wenn Sie auf Nein klicken, werden keine weiteren Tests ausgeführt.

Für DirectMusic gibt es genau einen Test. Klicken Sie auf OK, wenn Sie festgestellt haben, ob die Musik richtig wiedergegeben wird.

Sie können die Microsoft DirectPlay-Funktionalität mit jedem verfügbaren Dienstanbieter testen.

So testen Sie DirectPlay

  1. Klicken Sie auf der Seite Netzwerk auf DirectPlay testen.
  2. Geben Sie im Dialogfeld DirectPlay testen einen Benutzernamen ein, und wählen Sie einen Dienstanbieter aus.
  3. Wählen Sie Neue Sitzung erstellen aus, und klicken Sie auf OK.
  4. Wenn Sie eine Modemverbindung ausgewählt haben, klicken Sie im Dialogfeld Modemverbindung auf Antworten, um das Modem in den Modus für die automatische Anrufannahme zu versetzen.

Führen Sie nun das Microsoft DirectX-Diagnoseprogramm auf einem anderen Computer aus, der die ausgewählte Verbindung zum ersten Computer herstellen kann.

  1. Klicken Sie auf DirectPlay testen.
  2. Geben Sie einen anderen Benutzernamen ein.
  3. Wählen Sie denselben Dienstanbieter aus.
  4. Wählen Sie Bestehender Sitzung beitreten aus, und klicken Sie auf OK.

    Bei manchen Verbindungstypen werden Sie möglicherweise zum Bereitstellen weiterer Informationen aufgefordert, beispielsweise einer Telefonnummer. Für eine TCP/IP-Verbindung in einem lokalen Netzwerk können Sie das Textfeld leer lassen.

  5. Wählen Sie im Dialogfeld Sitzungsliste, das den Namen der auf dem ersten Computer erstellten Sitzung enthält, den Namen der Sitzung aus.
  6. Auf beiden Computern sollte nun ein Chatdialogfeld angezeigt werden. Geben Sie auf einem Computer eine Nachricht in das Eingabefeld ein, und klicken Sie dann auf Senden. Die Nachricht sollte auf beiden Computern im Bildlaufbereich des Chatdialogfeldes angezeigt werden.


Außerkraftsetzen von Standardverhalten

Auf der Seite Sound können Sie eine neue Hardwarebeschleunigungsstufe festlegen, indem Sie den Schieberegler verschieben. Nur Systemadministratoren können Hardwarebeschleunigungsstufen ändern. Diese Stufe bleibt nach dem Schließen des Microsoft DirectX-Diagnoseprogramms in Kraft.

Sie können die Hardwarebeschleunigung für Microsoft DirectDraw oder Direct3D deaktivieren, wenn sie verfügbar ist. Wechseln Sie hierzu für jedes Anzeigegerät zur Seite Anzeige, und klicken Sie auf Deaktivieren. Wenn Sie die Hardwarebeschleunigung deaktiviert haben, ist sie auch nach dem Schließen des Microsoft DirectX-Diagnoseprogramms nicht mehr für Anwendungen verfügbar. Klicken Sie auf der entsprechenden Seite Anzeige auf Aktivieren, um die Hardwarebeschleunigung wieder zu aktivieren.

* Anmerkung

  • Das Deaktivieren der DirectDraw-Beschleunigung deaktiviert auch die Beschleunigung für Direct3D.

Sie können auch die von DirectDraw-Vollbildanwendungen festgelegte Bildschirm-Aktualisierungsrate außer Kraft setzen. Dies sollten Sie nur ausführen, wenn bei einer Anwendung Anzeigeprobleme auftreten und Sie Grund zu der Annahme haben, dass die Anwendung eine ungültige Aktualisierungsrate festlegt.

So legen Sie eine Außerkraftsetzungs-Aktualisierungsrate fest

  1. Klicken Sie auf der Seite Weitere Hilfe auf die Schaltfläche Außer Kraft setzen.
  2. Wählen Sie im Dialogfeld DirectDraw-Aktualisierungsverhalten das Optionsfeld Wert für die Außerkraftsetzung aus, und geben Sie eine gültige Aktualisierungsrate für den Monitor ein.
  3. Klicken Sie auf OK.

So machen Sie die Außerkraftsetzungs-Aktualisierungsrate rückgängig und lassen zu, dass DirectDraw-Anwendungen ihre eigene Aktualisierungsrate festlegen

  1. Klicken Sie auf der Seite Weitere Hilfe auf die Schaltfläche Außer Kraft setzen.
  2. Wählen Sie im Dialogfeld DirectDraw-Aktualisierungsverhalten das Optionsfeld Standard aus, und klicken Sie auf OK.


Speichern von Informationen

So speichern Sie Informationen

  1. Klicken Sie zum Speichern der mit dem Microsoft DirectX-Diagnoseprogramm gesammelten Informationen auf Alle Informationen speichern.
  2. Informationen aus allen Seiten werden dann in einer Datei gespeichert. Den Dateinamen und -pfad können Sie auswählen. Zum Speichern der Informationen in einer XML-Datei klicken Sie unter Dateityp auf XML-Datei (*.xml).

* Anmerkung

  • Sie können zum Speichern von Informationen auch Folgendes an der Eingabeaufforderung eingeben:

    dxdiag [/x Ausgabedatei] [/t Ausgabedatei]

    Bei diesem Befehl dient die Option /x zum Senden von Daten an eine XML-Datei, /t dient zum Senden von Daten an eine Textdatei, und mit Ausgabedatei werden der Name und Pfad der Datei angegeben.


Überprüfen auf digitale WHQL-Signaturen

Wenn Sie überprüfen, ob die Treiber über digitale Signaturen von Microsoft Windows Hardware Quality Labs (WHQL) verfügen, stellt das DirectX-Diagnoseprogramm möglicherweise eine Verbindung zum Internet her, um neue WHQL-Zertifikate zu downloaden. Während dieses Vorgangs werden keine Informationen vom System abgerufen. Beim ersten Ausführen des Programms werden Sie gefragt, ob Sie die Berechtigung zum Herstellen einer Internetverbindung erteilen möchten. Diese Frage wird nur einmal gestellt. Zum Ändern Ihrer Antwort klicken Sie auf die Seite System, und aktivieren oder deaktivieren Sie die Option zum Überprüfen auf digitale WHQL-Signaturen.

Sie können zum Ändern dieser Einstellung auch Folgendes an der Eingabeaufforderung eingeben:

dxdiag [/whql:on] [/whql:off]

Bei diesem Befehl wird mit /whql:on zugelassen, dass das DirectX-Diagnoseprogramm auf digitale WHQL-Signaturen prüft, und mit /whql:off wird dies nicht zugelassen.