Diagnostikverktyget för DirectX

Dokumentationen för Microsofts diagnostikverktyg för DirectX innehåller följande avsnitt:

  • Diagnostikverktyget för DirectX, översikt
  • Använda diagnostikverktyget för DirectX för att diagnostisera problem
  • Testa DirectX-komponenter
  • Åsidosätta standardvärden
  • Spara information
  • Kontrollera digitala WHQL-signaturer


Diagnostikverktyget för DirectX, översikt

Med hjälp av Microsofts diagnostikverktyg för DirectX kan du få information om komponenterna och drivrutinerna för din dators API (programmeringsgränssnitt). Du kan använda programmet för att testa utdata för ljud och grafik och leverantörer av Microsoft DirectPlay-tjänst. Du kan också inaktivera vissa funktioner för maskinvaruacceleration.

Du kan använda diagnostikverktyget för att samla information åt en tekniker under ett supportsamtal. Den information som verktyget samlar in kan sparas och klistras in i ett e-postmeddelande.

Informationen presenteras på ett antal sidor. Du kan flytta från sida till sida genom att:

  • Klicka på flikarna.
  • Klicka på Nästa sida.
  • Trycka på VÄNSTERPIL eller HÖGERPIL när fokus är på en flik.

På vissa sidor i diagnostikverktyget, som till exempel DirectX-filer, Musik eller Indata, visas informationen i en tabell. Du kan sortera informationen i de här tabellerna så att du lättare hittar just den information som du letar efter.

Så här sorterar du information i en tabell

  1. Leta reda på den kolumn som innehåller den information du vill använda för att sortera tabellen.
  2. Klicka på kolumnrubriken överst i kolumnen.

    Tabellen sorteras i alfabetisk eller numerisk ordning, baserat på objekten i kolumnen. Om du vill vända på sorteringsordningen (Ö till A i stället för A till Ö, till exempel) klickar du på kolumnrubriken igen.

* Obs!

  • Viss information, till exempel mängden minne på ett bildskärmskort, kan vara ungefärlig.
  • Om du vill veta mer om hur du sparar information som har samlats in i diagnostikverktyget för DirectX klickar du på Närliggande information.

Närliggande information

Testa DirectX-komponenter

Spara information


Använda diagnostikverktyget för DirectX för att diagnostisera problem

Om det skulle uppstå problem när du kör Microsoft DirectX-program kan diagnostikverktyget för DirectX hjälpa dig att hitta orsaken till problemet. Här följer några saker som kan vara bra att titta efter:

  • Felaktiga versioner av DirectX-komponenter. Titta efter varningar om beta- och felsökningsfiler under Anmärkningar på sidan DirectX-filer. Beta-filer är tidiga testversioner och de bör inte installeras med kommersiell programvara. Felsökningsversioner, som används vid programutveckling, bör inte installeras med den slutgiltiga produkten. Felsökningsversionerna av komponenterna kan göra att program körs mycket långsammare än de skulle göra med de slutgiltiga versionerna.
  • Ingen maskinvaruacceleration. Vissa program körs väldigt långsamt eller inte alls om inte maskinvaruacceleration för Microsoft DirectDraw eller Direct3D är tillgänglig. Under DirectX-funktioner på sidan Bildskärm kan du se om DirectDraw, Direct3D eller AGP-strukturacceleration har markerats med "Inte tillgänglig". Om så är fallet kan det hända att du behöver uppgradera maskinvaran. Om du använder en produkt i Windows .NET Server 2003-familjen kan du behöva aktivera grafikacceleration. Du gör detta genom att öppna Bildskärm på Kontrollpanelen, välja fliken Inställningar och sedan klicka på Avancerat. Välj fliken Felsökning och flytta sedan skjutreglaget Maskinvaruacceleration till Fullständig.
  • Enheten inte ansluten. Om en styrspak eller annan indataenhet inte svarar kan det hända att den inte har installerats ordentligt. Se till att enheten finns på sidan Indata i diagnostikverktyget för DirectX. Om enheten inte visas lägger du till den med hjälp av Kontrollpanelen.
  • Osignerade drivrutiner. Osignerade drivrutiner är drivrutiner som inte har testats av Microsoft. Därför kanske de inte är helt kompatibla med den senaste versionen av DirectX. Du rekommenderas att använda drivrutiner som har signerats digitalt av Microsoft WHQL (Windows Hardware Quality Labs).

* Obs!

  • Om du använder Terminal Services för att arbeta på ett fjärrsystem som stöder maskinvaruacceleration kan diagnostikverktyget för DirectX ange att det finns stöd för maskinvaruacceleration. Det går emellertid inte att använda maskinvaruacceleration med Terminal Services, så det finns inget stöd.

Närliggande information

Spara information

Kontrollera digitala WHQL-signaturer


Testa DirectX-komponenter

Du kan testa Microsoft DirectDraw och Direct3D på de bildskärmar som är anslutna till systemet. Du kan också testa DirectSound på anslutna enheter för Wave-utdata och DirectMusic på alla anslutna musikportar.

Så här testar du en DirectX-funktion

  1. Klicka på knappen Testa på motsvarande sida.
  2. Läs eventuella meddelanden som visas.
  3. Titta eller lyssna på testerna.
  4. Kör varje test tills du ser en ruta där du ska svara på om testet lyckades. Om du svarar Nej körs inga fler test.

När det gäller DirectMusic finns det endast ett test. Klicka på OK när du anser att musiken spelas upp korrekt, eller om den inte gör det.

Du kan testa DirectPlay-funktionalitet hos de leverantörer som finns tillgängliga.

Så här testar du DirectPlay

  1. Klicka på Testa DirectPlay på sidan Nätverk.
  2. Ange ett användarnamn och välj en leverantör i dialogrutan Test av DirectPlay.
  3. Markera Skapa ny session och klicka sedan på OK.
  4. Om du har valt en modemanslutning klickar du på Svara i dialogrutan Modemanslutning så att modemet ställs i autosvarläge.

Kör Microsofts diagnostikverktyg för DirectX på en annan dator som kan upprätta den markerade anslutningen till den första datorn.

  1. Klicka på Testa DirectPlay.
  2. Ange ett annat användarnamn.
  3. Välj samma leverantör.
  4. Klicka på knappen Anslut till befintlig session och klicka sedan på OK.

    Det kan hända att du måste ange mer information för vissa typer av anslutningar, till exempel telefonnummer. När det gäller en TCP/IP-anslutning i ett lokalt nätverk kan du låta textrutan vara tom.

  5. Markera namnet på sessionen i den sessionslista som innehåller namnet på den session som du skapade på den första datorn.
  6. Nu ska båda datorerna visa en chat-dialogruta. Skriv ett meddelande i inmatningsrutan på den ena datorn och klicka sedan på Skicka. Meddelandet bör visas i det rullningsbara området i båda datorernas chat-dialogrutor.


Åsidosätta standardvärden

Du kan ändra maskinvaruacceleration genom att flytta ett skjutreglage på sidan Ljud. Du måste vara systemadministratör för att kunna ändra maskinvaruaccelerationen. Inställningen förblir aktiv när du har stängt Microsofts diagnostikverktyg för DirectX.

Du kan inaktivera maskinvaruaccelerationen för Microsoft DirectDraw eller Direct3D om en sådan acceleration är tillgänglig. Om du vill göra detta går du till sidan Bildskärm för de grafikkort som är installerade på datorn och klickar sedan på knappen Inaktivera. När du har inaktiverat maskinvaruaccelerationen är den inte längre tillgänglig för några program, inte ens när du har stängt diagnostikverktyget för DirectX. Om du vill aktivera maskinvaruaccelerationen igen klickar du på Aktivera på motsvarande bildskärmssida.

* Obs!

  • När du inaktiverar accelerationen i DirectDraw inaktiveras den också i Direct3D.

Du kan också ändra skärmens uppdateringsfrekvens som ställts in av program i helskärmsläge i DirectDraw. Detta bör du bara göra om du har problem med något program och om det verkar rimligt att tro att en ogiltig uppdateringsfrekvens har angetts av programmet.

Så här ändrar du uppdateringsfrekvensen

  1. Klicka på Åsidosätt på sidan Ytterligare hjälp.
  2. Markera Eget värde i dialogrutan Åsidosätt uppdateringsförfarande för DirectDraw och skriv in en giltig uppdateringsfrekvens för skärmen.
  3. Klicka på OK.

Så här ångrar du ändringen av uppdateringsfrekvensen och låter programmen i DirectDraw ange egna uppdateringsfrekvenser

  1. Klicka på Åsidosätt på sidan Ytterligare hjälp.
  2. Klicka på Standard i dialogrutan Åsidosätt uppdateringsförfarande för DirectDraw.


Spara information

Så här sparar du information

  1. Om du vill spara information som har samlats in med Microsofts diagnostikverktyg för DirectX klickar du på Spara all information.
  2. Information från alla sidor sparas i en fil, med ett namn och på en plats som du väljer. Om du vill spara som en XML-fil klickar du på XML-fil (*.xml) i Filformat.

* Obs!

  • Du kan också spara information genom att skriva följande på kommandoraden:

    dxdiag [/x utdatafil] [/t utdatafil]

    I det här kommandot skickar /x data till en XML-fil, /t skickar data till en textfil och utdatafil anger namn och plats för filen.


Kontrollera digitala WHQL-signaturer

När du verifierar att drivrutinerna har signerats digitalt av Microsoft WHQL (Windows Hardware Quality Labs) kan diagnostikverktyget för DirectX försöka ansluta till Internet för att hämta nya WHQL-certifikat. Under den här processen hämtas ingen information från systemet. Första gången du kör verktyget uppmanas du att ange om verktyget får ansluta till Internet. Den här uppmaningen visas bara en gång. Om du vill ändra inställningen går du till sidan System och markerar eller avmarkerar Kontrollera digitala WHQL-signaturer.

Du kan också ändra detta genom att skriva följande på kommandoraden:

dxdiag [/whql:on] [/whql:off]

I det här kommandot anger /whql:on att diagnostikverktyget för DirectX kan leta efter digitala WHQL-signaturer och /whql:off anger att diagnostikverktyget för DirectX inte kan leta efter digitala WHQL-signaturer.