Narzędzie diagnostyczne DirectX

W dokumentacji Narzędzia diagnostycznego DirectX firmy Microsoft są zawarte następujące tematy:

  • Omówienie Narzędzia diagnostycznego DirectX
  • Używanie Narzędzia diagnostycznego DirectX do diagnozowania problemów
  • Testowanie składników DirectX
  • Zmienianie zachowania domyślnego
  • Zapisywanie informacji
  • Sprawdzanie podpisów cyfrowych WHQL


Omówienie Narzędzia diagnostycznego DirectX

Narzędzie diagnostyczne DirectX firmy Microsoft wyświetla informacje dotyczące składników i sterowników interfejsu programowania aplikacji (API) DirectX, które zainstalowano w systemie. Narzędzie to umożliwia testowanie dźwięku i grafiki oraz usługodawców Microsoft DirectPlay. Ponadto pozwala ono wyłączyć niektóre funkcje przyspieszenia sprzętowego.

Narzędzia diagnostycznego można użyć do zebrania informacji, które należy podać podczas rozmowy telefonicznej z pracownikiem pomocy technicznej. Informacje zebrane przy użyciu tego narzędzia można zapisać i wkleić do wiadomości e-mail.

Informacje są wyświetlane na kilku stronach. Jest kilka sposobów przechodzenia między stronami:

  • Klikanie kart.
  • Klikanie przycisku Następna strona.
  • Naciskanie klawisza STRZAŁKA W LEWO lub STRZAŁKA W PRAWO wtedy, gdy fokus jest ustawiony na karcie.

Na niektórych stronach w narzędziu diagnostycznym, takich jak Pliki DirectX, Muzyka albo Wejście, informacje są wyświetlane w tabelach. Informacje w tych tabelach można posortować, aby łatwiej odnajdywać konkretne, poszukiwane szczegóły.

Aby posortować informacje w tabeli

  1. Określ kolumnę zawierającą informacje, na których podstawie chcesz posortować tabelę.
  2. Kliknij przycisk nagłówka u góry kolumny.

    Tabela zostanie posortowana w kolejności alfabetycznej albo liczbowej na podstawie elementów w tej kolumnie. Aby odwrócić kolejność sortowania (na przykład od Z do A zamiast od A do Z), kliknij ponownie przycisk nagłówka.

* Uwagi

  • Niektóre informacje, takie jak ilość pamięci zainstalowanej na karcie monitora, mogą być wartościami przybliżonymi.
  • Aby dowiedzieć się więcej o zapisywaniu informacji zbieranych przez Narzędzie diagnostyczne DirectX, kliknij łącze Tematy pokrewne.

Tematy pokrewne

Testowanie składników DirectX

Zapisywanie informacji


Używanie Narzędzia diagnostycznego DirectX do diagnozowania problemów

Jeżeli podczas korzystania z aplikacji DirectX firmy Microsoft występują problemy, Narzędzie diagnostyczne DirectX może pomóc w ustaleniu ich źródła. Należy uwzględnić między innymi następujące przyczyny występowania problemów:

  • Nieprawidłowe wersje składników DirectX. W polu Uwagi na stronie Pliki DirectX należy odszukać ostrzeżenia o plikach w wersji beta i plikach do debugowania. Pliki w wersjach beta są tworzone na wczesnych etapach testowania i nie powinny być instalowane razem z aplikacjami komercyjnymi. Wersje do debugowania, używane w fazie opracowywania programów, nie powinny być instalowane razem z produktami finalnymi. Składniki w wersjach do debugowania mogą powodować, że wykonywanie programów będzie wolniejsze niż w przypadku wersji handlowych.
  • Brak przyspieszenia sprzętowego. Jeżeli przyspieszenie sprzętowe Microsoft DirectDraw lub Direct3D jest niedostępne, niektóre programy działają bardzo wolno lub nie działają wcale. Na stronie Ekran w obszarze Funkcje DirectX należy sprawdzić, czy przyspieszenie DirectDraw, Direct3D lub przyspieszenie teksturowania AGP jest oznaczone jako „Niedostępne”. Jeśli przyspieszenie to jest niedostępne, konieczne może być zmodernizowanie sprzętu. Jeżeli natomiast jest używany produkt z rodziny Windows .NET Server 2003, może być konieczne włączenie przyspieszania grafiki. W tym celu w Panelu sterowania otwórz aplet Ekran, wybierz kartę Ustawienia, a następnie kliknij przycisk Zaawansowane. Wybierz kartę Rozwiązywanie problemów, a następnie przesuń suwak Przyspieszanie sprzętowe na pozycję Pełne.
  • Urządzenie nie jest podłączone. Jeśli joystick lub inne urządzenie wejściowe nie odpowiada, można przypuszczać, że jest ono nieprawidłowo skonfigurowane. Należy sprawdzić, czy urządzenie to jest uwzględnione na stronie Wejście w Narzędziu diagnostycznym DirectX. Jeśli urządzenie nie jest uwzględnione, należy je dodać za pomocą Panelu sterowania.
  • Niepodpisane sterowniki. Firma Microsoft nie testowała niepodpisanych sterowników pod względem ich pełnej zgodności z najnowszą wersją oprogramowania DirectX. Zaleca się używanie sterowników, które zostały cyfrowo podpisane przez laboratoria jakości sprzętu systemu Microsoft Windows (Microsoft Windows Hardware Quality Labs, WHQL).

* Uwaga

  • Jeżeli do pracy w systemie zdalnym, obsługującym przyspieszenie sprzętowe, są używane Usługi terminalowe, Narzędzie diagnostyczne DirectX może wskazywać, że przyspieszenie sprzętowe jest obsługiwane. Ponieważ jednak Usługi terminalowe nie mogą używać przyspieszenia sprzętowego, jego obsługa jest niedostępna.

Tematy pokrewne

Zapisywanie informacji

Sprawdzanie podpisów cyfrowych WHQL


Testowanie składników DirectX

Oprogramowanie Microsoft DirectDraw i Direct3D można testować na każdym monitorze podłączonym do systemu. Oprogramowanie DirectSound można testować na każdym urządzeniu wyjściowym WAVE, a oprogramowanie DirectMusic na każdym porcie muzycznym.

Aby przetestować funkcję DirectX

  1. Kliknij przycisk Testuj na odpowiedniej stronie.
  2. Przeczytaj wszystkie komunikaty, które się pojawią.
  3. Obejrzyj testy albo ich wysłuchaj.
  4. Kontynuuj każdy test do chwili, kiedy zostanie wyświetlony komunikat zawierający pytanie o pomyślny wynik testu. Jeżeli wybierzesz odpowiedź Nie, kolejne testy nie będą wykonywane.

W przypadku oprogramowania DirectMusic wykonywany jest jeden test. Gdy ustalisz, czy muzyka odtwarzana jest prawidłowo, kliknij przycisk OK.

Funkcję Microsoft DirectPlay można testować przy użyciu dowolnego dostępnego usługodawcy.

Aby przetestować funkcję DirectPlay

  1. Na stronie Sieć kliknij przycisk Testuj moduł DirectPlay.
  2. W oknie dialogowym Testowanie programu DirectPlay wpisz nazwę użytkownika i wybierz usługodawcę.
  3. Zaznacz opcję Utwórz nową sesję, a następnie kliknij przycisk OK.
  4. W przypadku połączenia modemowego kliknij przycisk Odpowiedz w oknie dialogowym Połączenie modemowe, aby przełączyć modem do trybu autoodpowiedzi.

Następnie uruchom Narzędzie diagnostyczne DirectX firmy Microsoft na innym komputerze, który może nawiązać wybrane połączenie z pierwszym komputerem.

  1. Kliknij przycisk Testuj moduł DirectPlay.
  2. Wpisz inną nazwę użytkownika.
  3. Wybierz tego samego usługodawcę.
  4. Kliknij przycisk Dołącz do istniejącej sesji, a następnie kliknij przycisk OK.

    W przypadku niektórych typów połączeń program może zażądać podania dodatkowych informacji, takich jak numer telefonu. Jeżeli wykorzystywane jest połączenie TCP/IP w sieci lokalnej, pole tekstowe można pozostawić puste.

  5. W polu Lista sesji, zawierającym nazwę sesji utworzonej na pierwszym komputerze, zaznacz nazwę odpowiedniej sesji.
  6. Okno dialogowe rozmowy powinno być wyświetlone na obu komputerach. Wpisz wiadomość w polu wprowadzania tekstu na jednym z komputerów, a następnie kliknij przycisk Wyślij. Wiadomość powinna pojawić się w przewijanym obszarze okna dialogowego rozmowy na obu komputerach.


Zmienianie zachowania domyślnego

Na stronie Dźwięk można ustawić różne poziomy przyspieszenia sprzętowego, przesuwając suwak. Poziomy przyspieszenia sprzętowego mogą być zmieniane tylko przez administratora systemu. Ustawiony poziom będzie obowiązywał po zamknięciu Narzędzia diagnostycznego DirectX firmy Microsoft.

Jeżeli przyspieszenie sprzętowe dla oprogramowania Microsoft DirectDraw lub Direct3D jest dostępne, można je wyłączyć. W tym celu dla każdego urządzenia wyświetlającego należy przejść do strony Ekran i kliknąć przycisk Wyłącz. Wyłączone przyspieszenie sprzętowe nie jest dostępne dla żadnej aplikacji, także po zamknięciu Narzędzia diagnostycznego DirectX. Aby ponownie włączyć przyspieszenie sprzętowe, należy kliknąć przycisk Włącz na stronie Ekran odpowiedniego urządzenia.

* Uwaga

  • Wyłączenie przyspieszenia DirectDraw powoduje również wyłączenie przyspieszenia dla składnika Direct3D.

Można również zmienić częstotliwość odświeżania monitora ustawioną przez pełnoekranowe aplikacje DirectDraw. Operację tę należy wykonywać tylko wtedy, gdy podczas korzystania z aplikacji występują problemy z monitorem i istnieje duże prawdopodobieństwo, że aplikacja ustawia nieprawidłową częstotliwość odświeżania.

Aby zmienić częstotliwość odświeżania

  1. Na stronie Więcej pomocy kliknij przycisk Zastąp.
  2. W oknie dialogowym Zmienianie zachowania funkcji odświeżania DirectDraw zaznacz opcję Wartość zastępcza i wprowadź częstotliwość odświeżania prawidłową dla monitora.
  3. Kliknij przycisk OK.

Aby anulować wprowadzone zmiany częstotliwości odświeżania i umożliwić aplikacjom DirectDraw ustawianie własnych częstotliwości odświeżania

  1. Na stronie Więcej pomocy kliknij przycisk Zastąp.
  2. W oknie dialogowym Zmienianie zachowania funkcji odświeżania DirectDraw kliknij opcję Domyślna.


Zapisywanie informacji

Aby zapisać informacje

  1. Aby zapisać informacje zebrane przy użyciu Narzędzia diagnostycznego DirectX, kliknij przycisk Zapisz wszystkie informacje.
  2. Informacje ze wszystkich stron są zapisywane w pliku, którego nazwę i lokalizację określa użytkownik. Aby zapisać informacje jako plik XML, na liście Zapisz jako typ kliknij pozycję Plik XML (*.xml).

* Uwaga

  • Informacje można zapisać także przez wpisanie w wierszu polecenia:

    dxdiag [/x plik_wyjściowy] [/t plik_wyjściowy]

    W poleceniu tym przełącznik /x powoduje wysłanie danych do pliku XML, przełącznik /t wysyła dane do pliku tekstowego, a parametr plik_wyjściowy określa nazwę i lokalizację pliku.


Sprawdzanie podpisów cyfrowych WHQL

Podczas próby weryfikacji, czy sterowniki są cyfrowo podpisane przez laboratoria jakości sprzętu systemu Microsoft Windows (Microsoft Windows Hardware Quality Labs, WHQL), Narzędzie diagnostyczne DirectX może próbować nawiązać połączenie z Internetem w celu pobrania nowych certyfikatów WHQL. W trakcie tego procesu żadne informacje nie są pobierane z systemu. Narzędzie prosi o zezwolenie na połączenie z Internetem przy pierwszym uruchomieniu. Prośba pojawia się tylko jeden raz. Aby zmienić odpowiedź, należy przejść do strony System i zaznaczyć albo wyczyścić pole wyboru Sprawdź, czy są podpisy cyfrowe WHQL.

Informacje można zmienić także przez wpisanie w wierszu polecenia:

dxdiag [/whql:on] [/whql:off]

W poleceniu tym przełącznik /whql:on zezwala Narzędziu diagnostycznemu DirectX na sprawdzanie, czy są podpisy cyfrowe WHQL, natomiast przełącznik /whql:off zabrania tej operacji.