Nástroj pro diagnostiku rozhraní DirectX

Dokumentace k Nástroji pro diagnostiku rozhraní Microsoft DirectX obsahuje následující témata:

  • Přehled Nástroje pro diagnostiku rozhraní DirectX
  • Použití Nástroje pro diagnostiku rozhraní DirectX k určení potíží
  • Testování součástí rozhraní DirectX
  • Přepsání výchozího nastavení
  • Ukládání informací
  • Kontrola digitálních podpisů WHQL


Přehled Nástroje pro diagnostiku rozhraní DirectX

Nástroj pro diagnostiku rozhraní Microsoft DirectX poskytuje informace o součástech a ovladačích rozhraní API (Application Programming Interface) DirectX v systému. Tento nástroj umožňuje testovat zvukový a grafický výstup a poskytovatele služeb součásti Microsoft DirectPlay. Umožňuje také zakázat některé funkce hardwarové akcelerace.

Můžete jej použít ke shromažďování informací pro technika při volání odborné pomoci. Informace shromážděné tímto nástrojem můžete uložit a vložit do e-mailové zprávy.

Informace jsou zobrazeny na několika kartách. Mezi kartami můžete přecházet následujícím způsobem:

  • Klepnutím na karty.
  • Klepnutím na tlačítko Další stránka.
  • Pokud je fokus na kartě, stiskněte klávesu ŠIPKA VLEVO nebo ŠIPKA VPRAVO.

Na některých kartách v Nástroji pro diagnostiku, jako jsou například Soubory rozhraní DirectX, Hudba nebo Vstup, se informace zobrazují v tabulce. Chcete-li vyhledávat specifické podrobnosti, můžete informace v těchto tabulkách seřadit.

Seřazení informací v tabulce

  1. Označte sloupec s informacemi, které chcete k seřazení tabulky použít.
  2. Klepněte na tlačítko v záhlaví v horní části sloupce.

    Tabulka bude seřazena v abecedním nebo číselném pořadí na základě položek v daném sloupci. Chcete-li změnit pořadí řazení (například od Z do A místo od A do Z), znovu klepněte na tlačítko v záhlaví.

* Poznámky

  • Některé informace, například velikost paměti grafické karty, mohou být pouze přibližné.
  • Podrobnosti o ukládání informací shromážděných Nástrojem pro diagnostiku DirectX získáte klepnutím na odkaz Příbuzná témata.

Příbuzná témata

Testování součástí rozhraní DirectX

Ukládání informací


Použití Nástroje pro diagnostiku rozhraní DirectX k určení potíží

Jestliže při spuštění aplikací rozhraní Microsoft DirectX dochází k potížím, může Nástroj pro diagnostiku rozhraní DirectX pomoci najít jejich příčinu. Snažte se vyhledat zejména následující položky:

  • Chybné verze součástí rozhraní DirectX. Ve skupinovém rámečku Poznámky na kartě Soubory rozhraní DirectX vyhledejte varování týkající se souborů pro testování a ladění. Soubory pro testování představují dřívější zkušební verze a neměly by být instalovány spolu s komerčními aplikacemi. Ladicí verze, které se používají při vývoji programů, by neměly být nainstalovány s finálním produktem. Použijete-li ladicí verze součástí, mohou programy pracovat mnohem pomaleji, než by tomu bylo u konečných verzí.
  • Nedostatečná hardwarová akcelerace. Není-li k dispozici hardwarová akcelerace Microsoft DirectDraw nebo Direct3D, poběží některé programy velmi pomalu nebo nepoběží vůbec. Na kartě Zobrazení ve skupinovém rámečku Funkce rozhraní DirectX zjistěte, zda je u součásti DirectDraw nebo Direct3D uvedeno označení "Není k dispozici". Jestliže ano, zvažte inovaci hardwaru. Pokud používáte produkty řady Windows .NET Server 2003, bude možná nutné grafickou akceleraci povolit. Chcete-li tak učinit, otevřete v Ovládacích panelech panel Zobrazení, vyberte kartu Nastavenía klepněte na tlačítko Upřesnit. Na kartě Poradce při potížích přesuňte jezdce v poli Hardwarová akcelerace k hodnotě Úplná.
  • Zařízení není připojeno. Jestliže pákový ovladač nebo jiné vstupní zařízení neodpovídá, nejsou pravděpodobně správně nastaveny. Ujistěte se, zda je zařízení uvedeno na kartě Vstup Nástroje pro diagnostiku rozhraní DirectX. Pokud tomu tak není, přidejte dané zařízení v okně Ovládací panely.
  • Nepodepsané ovladače. Necertifikované ovladače nebyly společností Microsoft podrobeny testům plné kompatibility s nejnovější verzí rozhraní DirectX. Je vhodné používat ovladače, které jsou zabezpečeny digitálním podpisem laboratoří Microsoft Windows Hardware Quality Labs (WHQL).

* Poznámka

  • Pokud pomocí Terminálové služby pracujete ve vzdáleném počítači, který podporuje hardwarovou akceleraci, bude pravděpodobně Nástroj pro diagnostiku rozhraní DirectX indikovat podporu hardwarové akcelerace. Terminálová služba však hardwarovou akceleraci používat nemůže. Podpora proto není k dispozici.

Příbuzná témata

Ukládání informací

Kontrola digitálních podpisů WHQL


Testování součástí rozhraní DirectX

Součásti Microsoft DirectDraw a Direct3D je možné testovat na všech monitorech připojených k počítači, součást DirectSound na všech zařízeních s výstupem wave a součást DirectMusic na všech hudebních portech.

Test funkce rozhraní DirectX

  1. Na příslušné stránce klepněte na tlačítko Test.
  2. Přečtěte si všechna hlášení, která se zobrazí.
  3. Přečtěte nebo poslechněte si testy.
  4. Po skončení každého testu se zobrazí zpráva s dotazem, zda byl test úspěšný. Pokud odpovíte Ne, nespustí se žádné další testy.

V případě součásti DirectMusic proběhne pouze jeden test. Jakmile se ujistíte, zda hudba hraje nebo nehraje správně, klepněte na tlačítko OK.

Funkčnost součásti Microsoft DirectPlay můžete testovat také u kteréhokoli poskytovatele služeb.

Test součásti DirectPlay

  1. Na kartě Síť klepněte na tlačítko Test rozhraní DirectPlay.
  2. V dialogovém okně Test rozhraní DirectPlay zadejte uživatelské jméno a zvolte poskytovatele služeb.
  3. Klepněte na přepínač Vytvořit novou relaci a klepněte na tlačítko OK.
  4. Pokud jste zvolili připojení pomocí modemu, klepněte na tlačítko Odpovědět v dialogovém okně Připojení modemem.

Spusťte Nástroj pro diagnostiku rozhraní Microsoft DirectX v jiném počítači, který s prvním počítačem může navázat vybrané připojení.

  1. Klepněte na tlačítko Test rozhraní DirectPlay.
  2. Zadejte jiné uživatelské jméno.
  3. Zvolte stejného poskytovatele služeb.
  4. Klepněte na přepínač Přidat se k existující relaci a potom na tlačítko OK.

    U některých typů připojení můžete být požádáni o další informace, například telefonní číslo. V případě připojení TCP/IP v místní síti můžete textové pole ponechat nevyplněné.

  5. V dialogovém okně Seznam relací, které obsahuje název relace vytvořené v prvním počítači, vyberte název relace.
  6. Na obou počítačích by se nyní mělo zobrazit dialogové okno konverzace. V jednom z počítačů zadejte do vstupního pole zprávu a klepněte na tlačítko Odeslat. Zpráva by se měla zobrazit v posuvné části dialogového okna konverzace na obou počítačích.


Přepsání výchozího nastavení

Na kartě Zvuk lze pomocí jezdce nastavit jinou úroveň hardwarové akcelerace. Úrovně hardwarové akcelerace mohou měnit pouze správci systému. Po ukončení Nástroje pro diagnostiku rozhraní Microsoft DirectX bude zvolená úroveň nadále používána.

Je-li k dispozici hardwarová akcelerace součástí Microsoft DirectDraw nebo Direct3D, můžete ji zakázat. U jednotlivých grafických zařízení přejděte na kartu Zobrazení a klepněte na tlačítko Zakázat. Po zakázání nebude tato hardwarová akcelerace k dispozici v žádné aplikaci ani poté, co Nástroj pro diagnostiku rozhraní DirectX ukončíte. Chcete-li hardwarovou akceleraci opět povolit, klepněte na tlačítko Povolit na příslušné kartě Zobrazení.

* Poznámka

  • Zakážete-li akceleraci součásti DirectDraw, bude zakázána také u součásti Direct3D.

Je také možné přepsat obnovovací frekvenci monitoru nastavenou aplikacemi používajícími rozhraní DirectDraw v režimu zobrazení na celé obrazovce. Tento krok je vhodné provést pouze v případě, že u aplikace dochází k problémům se zobrazením a máte odůvodněné obavy, že tato aplikace nastavuje neplatnou obnovovací frekvenci.

Přepsání obnovovaní frekvence:

  1. Na kartě Další nápověda klepněte na tlačítko Přepsat.
  2. V dialogovém okně Přepsat nastavení obnovovací frekvence klepněte na přepínač Nová hodnota a zadejte platnou obnovovací frekvenci monitoru.
  3. Klepněte na tlačítko OK.

Zrušení přepsaného nastavení obnovovací frekvence a povolení nastavení vlastní obnovovací frekvence v aplikacích používajících rozhraní DirectDraw:

  1. Na kartě Další nápověda klepněte na tlačítko Přepsat.
  2. V dialogovém okně Přepsat nastavení obnovovací frekvence klepněte na přepínač Výchozí.


Ukládání informací

Uložení informací

  1. Chcete-li uložit informace shromážděné Nástrojem pro diagnostiku rozhraní Microsoft DirectX, klepněte na tlačítko Uložit všechny informace.
  2. Informace ze všech stránek jsou uloženy do souboru s názvem a umístěním, které zvolíte. Chcete-li je uložit v souboru XML, klepněte v rozevíracím seznamu Typ souboru na položku soubor XML (*.xml).

* Poznámka

  • Informace můžete uložit také pomocí příkazového řádku zadáním příkazu:

    dxdiag [/x outfile] [/t outfile]

    V tomto příkazu /x slouží k odeslání dat do souboru XML, /t k odeslání dat do textového souboru a outfile určuje název a umístění souboru.


Kontrola digitálních podpisů WHQL

Poté, co ověříte, zda jsou ovladače opatřeny digitálním podpisem laboratoří Microsoft Windows Hardware Quality Labs (WHQL), může se Nástroj pro diagnostiku DirectX pokusit o spojení se sítí Internet za účelem stažení nových certifikátů WHQL. Během tohoto procesu nejsou ze systému načítány žádné informace. Při prvním spuštění vyžádá Nástroj pro diagnostiku váš souhlas s připojením k síti Internet. Požádání budete pouze jednou. Chcete-li odpověď změnit, klepněte na kartu Systém a zaškrtněte políčko Zkontrolovat digitální podpisy WHQL nebo jeho zaškrtnutí zrušte.

Změnu můžete provést také pomocí příkazového řádku zadáním příkazu:

dxdiag [/whql:on] [/whql:off]

V tomto příkazu /whql:on povolí Nástroji pro diagnostiku DirectX kontrolu digitálních podpisů WHQL a /whql:off tuto kontrolu nepovolí.