DirectX 诊断工具

Microsoft DirectX 诊断工具文档包括以下主题：

  • DirectX 诊断工具概述
  • 使用 DirectX 诊断工具诊断问题
  • 测试 DirectX 组件
  • 替代默认行为
  • 保存信息
  • 检查 WHQL 数字签名


DirectX 诊断工具概述

Microsoft DirectX 诊断工具提供有关系统的 DirectX 应用程序编程接口 (API) 组件和驱动程序的信息。它使您能够测试声音和图形输出以及 Microsoft DirectPlay 服务提供程序。它也使您能够禁用一些硬件加速功能。

您可以使用诊断工具为技术人员在支持电话中收集信息。您可以保存工具收集的信息，并将其粘贴到电子邮件中。

信息呈现在一系列页面上。要逐页查看，可以如下操作：

  • 单击选项卡。
  • 单击“下一页”。
  • 当输入焦点位于某个选项卡上时，按向左键或向右键。

诊断工具中的某些页面（例如 DirectX 文件、音乐或输入）会在表格里显示信息。您可以在那些表格里排列信息使得更轻松地找到要查找的特定详细信息。

在表格中排列信息

  1. 识别包含用来排列表格的信息的列。
  2. 单击列顶部的标头按钮。

    表格将按列项目的字母或数字顺序排序。要反向排列顺序（例如，是 Z 到 A，而不是 A 到 Z），请再单击标头按钮。

* 注意

  • 某些信息（如显示卡上的内存容量）可能是不精确的。
  • 要了解关于保存由 DirectX 诊断工具所收集信息的详细情况，请单击“相关主题”。

相关主题

测试 DirectX 组件

保存信息


使用 DirectX 诊断工具诊断问题

如果运行 Microsoft DirectX 应用程序时出现错误，DirectX 诊断工具就会帮助查找故障根源。下面是一些应该检查的情况：

  • DirectX 组件的版本不正确。在“DirectX 文件”页的“说明”区域中，查找有关 Beta 和调试文件的警告。Beta 文件是早期测试版本，并不应与商用程序一起安装。用于程序开发的调试版本不应与最终产品一起安装。组件的调试版本会使程序运行得比零售版本慢。
  • 缺少硬件加速。 如果 Microsoft DirectDraw 或 Direct3D 硬件加速不可用，有些程序运行速度非常慢或根本不能运行。在“显示”页上，在“DirectX 功能”下检查 DirectDraw、Direct3D 或 AGP 纹理加速是否标有“不可用”。如果标有“不可用”，您可能需要考虑升级硬件。或者如果您使用的是 Windows .NET Server 2003 家族中的某个产品，您可能需要启用图形加速。可以通过打开控制面板中的“显示”，选择“设置”选项卡，然后单击“高级”来完成此操作。选择“疑难解答”选项卡，然后将“硬件加速”滑块移动到“全”。
  • 没有连接设备。 如果游戏杆或其他输入设备没有反应，可能是设置不正确。确保在“DirectX 诊断工具”的“输入”页上已对该设备进行了说明。如果没有，请通过“控制面板”添加该设备。
  • 驱动程序未签名。 Microsoft 没有测试未签名的驱动程序是否与 DirectX 的最新版本完全兼容。建议使用经过 Microsoft Windows 硬件质量实验室 (WHQL) 数字签名的驱动程序。

* 注意

  • 如果使用“终端服务”在支持硬件加速的远程系统上工作，DirectX 诊断工具可能表明支持硬件加速。但是，终端服务无法使用硬件加速，因此支持是不可用的。

相关主题

保存信息

检查 WHQL 数字签名


测试 DirectX 组件

您可以在连接到系统的每台监视器上测试 Microsoft DirectDraw 和 Direct3D。您也可以在每个波形输出设备上测试 DirectSound，在每个音乐端口上测试 DirectMusic。

测试某个 DirectX 功能

  1. 单击相应页的“测试”按钮。
  2. 阅读出现的任何消息。
  3. 看或听测试的结果。
  4. 运行每个测试，直到出现一条询问测试是否成功的消息。如果回答“否”，那么就不再继续运行测试。

如果是 DirectMusic，则只有一项测试。对音乐播放状态正常与否感到满意后，单击“确定”。

可以在任何可用服务提供程序上测试 Microsoft DirectPlay 功能。

测试 DirectPlay

  1. 在“网络”页上，单击“测试 DirectPlay”。
  2. 在“DirectPlay 测试”对话框中，键入用户名并选择服务提供者。
  3. 选择“创建新会话”，然后单击“确定”。
  4. 如果选择了调制解调器连接，请在“调制解调器连接”对话框中单击“应答”，以便将调制解调器置于自动应答模式。

现在，在可以与第一台计算机建立选定连接的另一台计算机上运行 Microsoft DirectX 诊断工具。

  1. 单击“测试 DirectPlay”。
  2. 键入不同的用户名。
  3. 选择相同的服务提供程序。
  4. 单击“加入现有会话”按钮，然后单击“确定”。

    对于某些类型的连接，您可能需要提供更多信息（例如，电话号码）。对于局域网上的 TCP/IP 连接，可以将文本框保留为空白。

  5. 在包含在第一台计算机上创建的会话名称的“会话列表”里，选择会话的名称。
  6. 现在，两台计算机都应该显示聊天对话框。在其中一台计算机上的输入框中键入消息，并单击“发送”。该信息应该出现在两台计算机上的聊天对话框的滚动区域中。


替代默认行为

在“声音”页上，您可以通过移动滑块设置一个不同级别的硬件加速。要更改硬件加速级别，您必须是系统管理员。关闭 Microsoft DirectX 诊断工具后，该级别仍然有效。

可以对 Microsoft DirectDraw 或 Direct3D 禁用硬件加速（如果这种加速可用的话）。为此，转到每个显示设备的“显示”页，然后单击“禁用”。一旦禁用硬件加速，即使关闭 DirectX 诊断工具后，它对任何应用程序来说都是不可用的。要重新启用硬件加速，请在适当的“显示”页上单击“启用”。

* 注意

  • 禁用 DirectDraw 加速同时会禁用 Direct3D 的加速。

也可以替代 DirectDraw 全屏幕应用程序设置的显示器刷新率。只有在应用程序出现显示问题，并确认该应用程序设置了无效的刷新频率时，才能这么做。

设置替代刷新率

  1. 在“其他帮助”页上，单击“替代”。
  2. 在“替代 DirectDraw 刷新行为”对话框中，选择“替代值”并为显示器输入有效刷新率。
  3. 单击“确定”。

取消替代刷新率并让 DirectDraw 应用程序设置其自己的刷新率

  1. 在“其他帮助”页上，单击“替代”。
  2. 在“替代 DirectDraw 刷新行为”对话框里，单击“默认值”。


保存信息

  1. 要保存 Microsoft DirectX 诊断工具收集的信息，请单击“保存所有信息”。
  2. 来自所有页的信息保存在一个文件中，您可以选择该文件的名称和位置。要保存成 XML 文件，请在“保存类型”中单击“XML 文件(*.xml)”。

* 注意

  • 您还可以通过在命令提示符下键入以下命令来保存信息：

    dxdiag [/x outfile] [/t outfile]

    在此命令中，/x 是发送数据到 XML 文件，/t 是发送数据到文本文件，而 outfile 是指定文件的名称和位置。


检查 WHQL 数字签名

当验证驱动程序是否通过 Microsoft Windows 硬件质量实验室 (WHQL) 数字签名时，DirectX 诊断工具可以试着连接到 Internet 以下载新的 WHQL 证书。在此过程中，没有从系统上检索到信息。此工具会在第一次运行时，向您询问连接到 Internet 的权限。只有在第一次运行时才要求权限。要更改应答，请转到“系统”页，并选择或清除“检查 WHQL 数字签名”。

也可以通过在命令提示符下键入以下命令来进行更改：

dxdiag [/whql:on] [/whql:off]

在此命令中，/whql:on 允许 DirectX 诊断工具检查 WHQL 数字签名，/whql:off 不允许 DirectX 诊断工具检查 WHQL 数字签名。