Ferramenta de diagnóstico do DirectX

A documentação da Ferramenta de diagnóstico do Microsoft DirectX contém os seguintes tópicos:

  • Visão geral da Ferramenta de diagnóstico do DirectX
  • Usando a Ferramenta de diagnóstico do DirectX para diagnosticar problemas
  • Testando componentes do DirectX
  • Substituindo o comportamento padrão
  • Salvando as informações
  • Verificando as assinaturas digitais WHQL


Visão geral da Ferramenta de diagnóstico do DirectX

A Ferramenta de diagnóstico do Microsoft DirectX fornece informações sobre componentes e drivers da interface de programação de aplicativo (API) do DirectX no sistema. Ela permite que você teste as saídas de sons e de elementos gráficos e os provedores de serviços do Microsoft DirectPlay. Ela também permite que você desative alguns recursos de aceleração de hardware.

Você pode usar a ferramenta de diagnóstico para obter informações de um técnico durante uma chamada de suporte. Você também pode salvar as informações obtidas pela ferramenta e colá-las na mensagem de email.

As informações são apresentadas em várias páginas. Você pode passar de uma página para outra da seguinte forma:

  • Clique nas guias.
  • Clique em Próxima Página.
  • Pressione as teclas SETA PARA A ESQUERDA ou SETA PARA A DIREITA quando o foco estiver em uma guia.

Algumas páginas da ferramenta de diagnóstico, como por exemplo Arquivos do DirectX, Música ou Entrada, exibem informações em uma tabela. Você pode classificar as informações dessas tabelas de forma que seja possível encontrar mais facilmente os detalhes específicos que procura.

Para classificar informações em uma tabela

  1. Identifique a coluna com as informações que deseja usar para classificar a tabela.
  2. Clique no cabeçalho na parte superior da coluna.

    A tabela será classificada em ordem alfabética ou numérica com base nos itens da coluna. Para inverter a ordem de classificação (de Z a A, em vez de A a Z, por exemplo), clique no cabeçalho novamente.

* Observações

  • Algumas informações, como o volume de memória em uma placa de vídeo, podem ser aproximadas.
  • Para saber mais sobre como salvar informações obtidas pela ferramenta de diagnóstico do DirectX, clique em Tópicos relacionados.

Tópicos relacionados

Testando os componentes do DirectX

Salvando as informações


Usando a Ferramenta de diagnóstico do DirectX para diagnosticar problemas

Se houver problemas durante a execução dos aplicativos do Microsoft DirectX, a Ferramenta de diagnóstico do DirectX poderá ajudá-lo a encontrar a solução. Estes são alguns dos itens pelos quais você deve procurar:

  • Versões incorretas dos componentes do DirectX. Na seção Observações da página Arquivos do DirectX, procure os avisos sobre os arquivos beta e de depuração. Os arquivos beta são versões de teste anteriores e não devem ser instalados em programas comerciais. As versões de depuração, que são usadas no desenvolvimento de programas, não devem ser instaladas com o produto final. Essas versões dos componentes podem fazer com que os programas sejam executados muito mais lentamente do que seriam com as versões comerciais.
  • Falta de aceleração do hardware. Alguns programas são executados bem lentamente ou talvez nem sejam executados, a menos que as acelerações de hardware do Microsoft DirectDraw ou do Direct3D estejam disponíveis. Na página Vídeo, em Recursos do DirectX, verifique se as acelerações do DirectDraw, do Direct3D ou do AGP Texture estão marcadas como "Não disponíveis". Se estiverem, você deve pensar em atualizar o hardware. Ou se você estiver usando um produto da família do Windows .NET Server 2003, talvez seja necessário ativar a aceleração dos gráficos. Isso pode ser feito abrindo Vídeo no Painel de controle, selecionando a guia Configurações e clicando em Avançado. Selecione a guia Solucionar problemas e mova o controle deslizante Aceleração de hardware para Completa.
  • Dispositivo não conectado. Se um joystick ou outro dispositivo de entrada não responder, é possível que ele não esteja configurado corretamente. Certifique-se de que o dispositivo aparece na página Entrada da Ferramenta de diagnóstico do DirectX. Se não aparecer, adicione o dispositivo usando o Painel de controle.
  • Drivers não assinados. A Microsoft não verificou se os drivers não assinados são totalmente compatíveis com a versão mais recente do DirectX. Recomenda-se que você use drivers que são digitalmente assinados pelo Microsoft Windows Hardware Quality Labs (WHQL).

* Observação

  • Se você usar os serviços de terminal para trabalhar em um sistema remoto que ofereça suporte à aceleração de hardware, a Ferramenta de diagnóstico do DirectX deve indicar esse suporte. No entanto, os serviços de terminal não podem usar a aceleração de hardware; portanto, o suporte não estará disponível.

Tópicos relacionados

Salvando as informações

Verificando as assinaturas digitais WHQL


Testando os componentes do DirectX

Você pode testar o Microsoft DirectDraw e o Direct3D em cada monitor conectado ao sistema. E também pode testar o DirectSound em cada dispositivo de saída de som wave e o DirectMusic em cada porta de música.

Para testar um recurso do DirectX

  1. Clique no botão Teste na página apropriada.
  2. Leia as mensagens exibidas.
  3. Veja ou escute os testes.
  4. Execute todos os testes até aparecer uma mensagem perguntando se o teste obteve êxito. Se a resposta for Não, nenhum outro teste será executado.

No caso do DirectMusic, só há um teste. Clique em OK para indicar se a música está sendo reproduzida corretamente ou não.

Você pode testar a funcionalidade do Microsoft DirectPlay em qualquer provedor de serviços disponível.

Para testar o DirectPlay

  1. Na página Rede, clique em Testar DirectPlay.
  2. Na caixa de diálogo Teste do DirectPlay, digite um nome de usuário e escolha um provedor de serviços.
  3. Selecione Criar Nova Sessão e clique em OK.
  4. Se você escolheu uma conexão de modem, clique em Resposta na caixa de diálogo Conexão do modem para colocar o modem no modo de resposta automática.

Agora execute a Ferramenta de diagnóstico do Microsoft DirectX em outro computador que possa estabelecer a conexão selecionada com o primeiro computador.

  1. Clique em Testar DirectPlay.
  2. Digite um outro nome de usuário.
  3. Escolha o mesmo provedor de serviços.
  4. Clique no botão Ingressar na sessão existente e em OK.

    Para alguns tipos de conexão, talvez seja necessário fornecer mais informações como, por exemplo, um número de telefone. Para uma conexão TCP/IP em uma rede local, você pode deixar a caixa de texto em branco.

  5. Selecione o nome da sessão, na Lista de sessões que contém o nome da sessão que você criou no primeiro computador.
  6. Os dois computadores devem mostrar agora uma caixa de diálogo de bate-papo. Digite uma mensagem na caixa de entrada de um dos computadores e clique em Enviar. A mensagem deve ser exibida na área de rolagem da caixa de diálogo de bate-papo dos dois computadores.


Substituindo o comportamento padrão

Na página Som, você pode definir um nível de aceleração de hardware diferente movendo o controle deslizante. Você precisa ser administrador de sistema para poder alterar os níveis de aceleração de hardware. Esse nível permanecerá ativado até o fechamento da Ferramenta de diagnóstico do Microsoft DirectX.

Você pode desativar a aceleração de hardware do Microsoft DirectDraw ou do Direct3D caso essa aceleração esteja disponível. Para isso, vá até a página Vídeo de cada dispositivo de vídeo e clique no botão Desativar. Depois que você tiver desativado a aceleração de hardware, ela estará indisponível para todos os aplicativos, mesmo depois do fechamento da Ferramenta de diagnóstico do DirectX. Para reativá-la, clique em Ativar na página Vídeo apropriada.

* Observação

  • A desativação da aceleração do DirectDraw também desativará a aceleração do Direct3D.

Você também pode substituir a taxa de atualização do monitor definida pelos aplicativos de tela inteira do DirectDraw. Só faça isso se você tiver problemas de exibição em um aplicativo e achar que o aplicativo está definindo uma taxa de atualização inválida.

Para definir uma taxa de atualização de substituição

  1. Na página Mais ajuda, clique em Substituir.
  2. Na caixa de diálogo Substituir comportamento de atualização do DirectDraw, selecione Substituir valor e insira uma taxa de atualização válida para o monitor.
  3. Clique em OK.

Para cancelar a taxa de atualização de substituição e permitir que os aplicativos do DirectDraw definam sua própria taxa de atualização

  1. Na página Mais ajuda, clique em Substituir.
  2. Na caixa de diálogo Substituir comportamento de atualização do DirectDraw, clique em Padrão.


Salvar as informações

Para salvar as informações

  1. Para salvar as informações obtidas a partir da ferramenta de diagnóstico do Microsoft DirectX, clique em Salvar todas as informações.
  2. As informações de todas as páginas serão salvas em um arquivo, com um nome e em um local escolhido por você. Para salvar um arquivo XML, em Salvar como tipo, clique em Arquivo XML (*.xml).

* Observação

  • Você também pode salvar as informações digitando o seguinte no prompt de comando:

    dxdiag [/x outfile] [/t outfile]

    Nesse comando, /x envia os dados para um arquivo XML, /t, para um arquivo de texto, e outfile especifica o nome e o local do arquivo.


Verificando as assinaturas digitais WHQL

Depois que você conferir se seus drivers são digitalmente assinados pelo Microsoft Windows Hardware Quality Labs (WHQL), a ferramenta de diagnóstico do DirectX pode tentar estabelecer uma conexão com a Internet para fazer um download dos novos certificados WHQL. Durante esse processo, nenhuma informação é recuperada do sistema. A ferramenta irá pedir sua autorização para estabelecer uma conexão com a Internet na primeira vez em que você a executar. A autorização será solicitada apenas uma vez. Para alterar sua resposta, vá para a página do sistema e selecione ou desmarque Verificar as assinaturas digitais WHQL.

Essa alteração também pode ser feita digitando o seguinte no prompt de comando:

dxdiag [/whql:on] [/whql:off]

Nesse comando, /whql:on permite que a ferramenta de diagnóstico do DirectX verifique a presença de assinaturas digitais WHQL, e /whql:off não permite essa verificação.