DirectX 진단 도구

DirectX 진단 도구

Microsoft® DirectX® 진단 도구 도움말에는 다음과 같은 항목이 들어 있습니다.

  • DirectX 진단 도구 정보
  • 확인 사항
  • DirectX 구성 요소 테스트
  • 기본 동작 다시 정의


DirectX 진단 도구 정보

Microsoft® DirectX® 진단 도구는 사용자 시스템의 DirectX 응용 프로그래밍 인터페이스(API) 구성 요소 및 드라이버에 대한 정보를 제공합니다. 이 도구를 사용하면 사운드와 그래픽 출력 및 Microsoft DirectPlay® 서비스 공급자를 테스트할 수 있습니다. 또한 일부 하드웨어 가속 기능을 사용하지 않도록 설정할 수 있습니다.

진단 도구를 사용하여 고객 지원 전화를 하는 동안 기술 지원 담당자를 위해 정보를 수집하거나 이 도구로 수집한 정보를 저장하여 전자 메일 메시지에 첨부할 수도 있습니다.

정보는 여러 페이지에 걸쳐 소개되어 있습니다. 다음 방법 중 하나를 선택하여 각 페이지로 이동합니다.

  • 탭을 클릭합니다.
  • 다음 페이지 단추를 클릭합니다.
  • 입력 포커스가 탭에 있을 때 왼쪽 화살표 키 또는 오른쪽 화살표 키를 누릅니다.

모든 정보 저장 단추를 클릭하여 모든 정보를 텍스트 파일로 저장할 수도 있습니다.

참고 디스플레이 카드의 메모리 용량과 같은 일부 정보의 값은 근사값입니다.


확인 사항

Microsoft® DirectX® 응용 프로그램을 실행하는 동안 문제가 발생하면 DirectX 진단 도구가 문제의 원인을 찾을 수 있도록 도와줍니다. 확인해야 할 사항은 다음과 같습니다.

  • 잘못된 버전의 DirectX 구성 요소. DirextX 파일 페이지의 참고 부분에서 베타 파일과 디버그 파일에 대한 경고 내용을 확인합니다. 베타 파일은 초기 테스트 버전이므로 시판용 응용 프로그램과 함께 설치해서는 안됩니다. 디버그 버전은 프로그램 개발 중에 사용한 것으로 최종 버전과 함께 설치해서는 안되며 설치한 경우에는 DirectX 구성 요소의 일반 정품 버전에서 실행하는 것에 비해 응용 프로그램이 현저히 느리게 실행될 수 있습니다.
  • 하드웨어 가속 기능 결여. Microsoft DirectDraw® 또는 Direct3D® 하드웨어 가속을 사용할 수 없으면 일부 프로그램은 매우 느리게 실행되거나 전혀 실행되지 않습니다. 디스플레이 페이지의 DirectX 기능에서 DirectDraw, Direct3D 또는 AGP Texture 가속이 "사용할 수 없음"으로 표시되어 있는지 확인하십시오. 이 경우에는 하드웨어 업그레이드를 고려해 보십시오.
  • 연결되지 않은 장치. 조이스틱이나 다른 입력 장치가 작동하지 않으면 설치가 제대로 되어 있지 않을 수 있습니다. DirextX 진단 도구의 입력 페이지에 장치가 있는지 확인합니다. 없으면 제어판에서 장치를 추가합니다.
  • 인증되지 않은 드라이버. Microsoft는 인증되지 않은 드라이버가 최신 버전의 DirectX와 완전히 호환되는지 테스트하지 않았습니다. 해당 구성 요소 페이지에 인증되지 않은 드라이버 목록이 나열되어 있습니다.


DirectX 구성 요소 테스트

시스템에 연결된 모든 모니터에서 Microsoft® DirectDraw® Direct3D®를 테스트할 수 있습니다. 또한 모든 웨이브 출력 장치에서 DirectSound®를 테스트해 볼 수 있고 음악 포트에서 DirectMusic®을 테스트할 수 있습니다.

DirectX 기능을 테스트하려면 해당 페이지에서 테스트 단추를 클릭하고 나타나는 메시지를 읽은 다음 테스트 과정을 주의해서 보거나 들어 보십시오. 테스트가 성공적으로 실행되었는지 묻는 메시지가 나타날 때까지 각 테스트를 실행하십시오. 아니오로 응답하면 더 이상 테스트가 실행되지 않습니다.

DirectMusic의 경우에는 하나의 테스트가 있습니다. 음악이 원하는데로 정확히 연주되면 확인을 클릭합니다.

사용할 수 있는 서비스 공급자에서 Microsoft DirectPlay® 기능을 테스트할 수 있습니다.

프로시저 화살표 DirectPlay를 테스트하려면

  1. 네트워크 페이지에서 DirectPlay 테스트를 클릭합니다. DirectPlay 테스트 대화 상자에서 사용자 이름을 입력하고 서비스 공급자를 선택합니다. 새 세션 만들기를 선택한 다음 확인을 클릭합니다. 모뎀 연결을 선택한 경우에는 모뎀 연결 대화 상자에서 응답을 클릭하여 모뎀을 자동 응답 모드로 만듭니다.
  2. 테스트를 처음에 실행한 컴퓨터와 선택하여 연결할 수 있는 다른 컴퓨터에서 Microsoft DirectX® 진단 도구를 실행합니다. DirectPlay 테스트를 클릭하여 다른 사용자 이름을 입력하고 같은 서비스 공급자를 선택한 다음 기존 세션에 참가 단추를 클릭하고 확인을 클릭합니다.

    3. 일부 형식의 연결에서는 전화 번호와 같은 추가 정보를 제공하라는 메시지가 표시될 수도 있습니다. 로컬 네트워크의 TCP/IP 연결의 경우에는 입력란을 비워놓아도 됩니다.

  3. 두 번째 컴퓨터에서는 테스트를 처음 실행한 컴퓨터에서 만든 세션 이름을 포함하는 세션 목록에서 세션 이름을 선택한 다음 확인을 클릭합니다.
  4. 두 컴퓨터 모두에 채트 대화 상자가 표시됩니다. 한 컴퓨터의 입력란에서 메시지를 입력한 다음 보내기를 클릭합니다. 두 컴퓨터의 채트 대화 상자에 있는 스크롤 영역에 메시지가 나타납니다.


기본 동작 다시 정의

사운드 페이지에서 슬라이더를 이동하여 하드웨어 가속 수준을 설정할 수 있습니다. 설정된 가속 수준은 Microsoft® DirectX® 진단 도구를 닫은 후에도 유지됩니다.

참고 이 기능은 Microsoft Windows® 95에서는 사용할 수 없습니다.

Microsoft DirectDraw® 또는 Direct3D®용의 하드웨어 가속 기능을 사용할 수 있는 경우에는 이 기능을 사용하지 않도록 설정할 수 있습니다. 사용하지 않도록 설정하려면 해당 디스플레이 장치에 대한 디스플레이 페이지로 이동한 다음 사용 안함 단추를 클릭합니다. 하드웨어 가속 기능을 사용하지 않도록 설정한 경우에는 DirectX 진단 도구를 닫은 후에도 설정이 그대로 유지되므로 모든 응용 프로그램에서 하드웨어 가속을 사용할 수 없습니다. 하드웨어 가속 기능을 다시 사용하려면 해당 디스플레이 페이지에서 사용 단추를 클릭합니다.

참고 DirectDraw 가속 기능을 사용하지 않도록 설정하면 Direct3D 가속 기능도 사용하지 않도록 설정됩니다.

DirectDraw 전체 화면 응용 프로그램에서 설정한 모니터 화면 주사율을 다시 정의할 수도 있습니다. 응용 프로그램에 디스플레이 문제가 있고 응용 프로그램의 화면 주사율이 잘못 설정되었다는 확신이 있는 경우에만 화면 주사율을 다시 정의하십시오.

프로시저 화살표 화면 주사율을 다시 정의하려면

  1. 기타 도움말 페이지에서 다시 정의 단추를 클릭합니다.
  2. DirectDraw 화면 주사율 다시 정의 대화 상자에서 입력란을 선택한 다음 모니터에서 사용할 수 있는 화면 주사율을 입력합니다.

    3. 이 작업을 수행하면 다시 정의할 값 옵션 단추가 자동으로 선택됩니다.

  3. 확인을 클릭합니다.

프로시저 화살표 화면 주사율의 다시 정의할 값을 취소하고 DirectDraw 응용 프로그램의 기본 화면 주사율로 설정하려면

  1. 기타 도움말 페이지에서 다시 정의 단추를 클릭합니다.
  2. DirectDraw 화면 주사율 다시 정의 대화 상자에서 기본값 옵션 단추를 선택한 다음 확인을 클릭합니다.


도움말에 없는 항목

일치하는 항목이 없습니다. 가능한 몇가지 이유 및 해결책은 다음과 같습니다.

  • 대상 항목을 포함하는 파일(.chm)이 예상한 위치에 없습니다.

    • 해결책: MSDN Library 설치 프로그램을 다시 실행하십시오.

  • 현재 항목 또는 대상 항목을 포함하는 파일(.chm)이 최신 버전이 아니며 링크가 더 이상 유효하지 않습니다.

    • 해결책: 최신 버전의 MSDN Library를 설치하십시오.

  • CD-ROM 드라이브에 MSDN Library CD가 없습니다.

    • 해결책: CD-ROM 드라이브에 MSDN Library CD를 넣으십시오.