DirectX 診断ツール

DirectX 診断ツール

Microsoft® DirectX® 診断ツールのヘルプの内容は、次のとおりです。

  • DirectX 診断ツールについて
  • 問題の原因を特定する
  • DirectX コンポーネントのテストを行う
  • 既定の動作を変更する


DirectX 診断ツールについて

Microsoft® DirectX® 診断ツールは、システム上の DirectX アプリケーション プログラミング インターフェイス (API) コンポーネントおよびドライバに関する情報を提供します。これにより、サウンドやグラフィックの出力テストや、Microsoft DirectPlay® サービス プロバイダを有効にすることができます。また、一部のハードウェア アクセラレータの機能を無効にすることもできます。

このツールを使うと、サポート センターへの問い合わせ中に情報を収集し、サポート技術者に伝えることができます。また、ツールが収集した情報を保存し、電子メール メッセージに貼り付けることもできます。

情報は、数ページのタブに分けて表示されます。ページからページへ移動するには、次の方法があります。

  • タブをクリックする。
  • [次ページ] をクリックする。
  • 入力フォーカスがタブにあるときに、左右の方向キーを押す。

[情報をすべて保存] をクリックして、情報をテキスト ファイルに保存することもできます。

注 ディスプレイ カードのメモリ量など、一部の情報については、概算の場合があります。


問題の原因を特定する

Microsoft® DirectX® アプリケーションの実行中に問題が発生した場合に、DirectX 診断ツールを使って問題の原因を調べることができます。次のような問題がないか確認してください。

  • 誤ったバージョンの DirectX コンポーネント。
    [DirectX ファイル] ページの [注意] で、ベータ ファイルやデバッグ ファイルに関する警告がないか確認してください。ベータ ファイルは初期のテスト用バージョンで、商用アプリケーションと共にインストールすべきものではありません。デバッグ バージョンはプログラムを開発する際に使われるファイルで、これも最終製品と共にインストールすべきものではありません。デバッグ バージョンのコンポーネントがインストールされていると、製品版がインストールされている場合よりもアプリケーションの実行速度が大幅に低下することがあります。
  • ハードウェア アクセラレータの欠如。
    一部のプログラムは、Microsoft DirectDraw® または Direct3D® ハードウェア アクセラレータが利用できないと、実行速度が非常に低下するか、またはまったく動作しません。[ディスプレイ] ページの [DirectXの機能] で、DirectDraw アクセラレータ、Direct3D アクセラレータ、または AGP テクスチャ アクセラレータに "なし" と表示されていないことを確認してください。表示されている場合は、ハードウェアのアップグレードをお勧めします。
  • デバイスが接続されていない。
    ジョイスティックなどの入力デバイスが応答しない場合、正しくセットアップされていない可能性があります。そのデバイスが、DirectX 診断ツールの [入力] ページに表示されているかどうか確認してください。表示されていない場合は、コントロール パネルを使ってデバイスを追加します。
  • 認定されていないドライバ。
    未認定のドライバは、最新バージョンの DirectX と完全に互換性があるかどうかをマイクロソフトによってテストされていません。これらのドライバはそれぞれのコンポーネントのページに一覧表示されます。


DirectX コンポーネントのテストを行う

DirectX 診断ツールを使って、システムに接続されている各モニタでの Microsoft® DirectDraw® および Direct3D® のテスト、各 WAVE 出力デバイスでの DirectSound® のテスト、および各ミュージック ポートでの DirectMusic® のテストを行うことができます。

DirectX の機能をテストするには、適切なページで [テスト] をクリックし、表示されたメッセージを読んでテスト内容 (表示や音) を確認します。テストが成功したかどうかを確認するメッセージが表示されるまで、それぞれのテストを実行します。[いいえ] をクリックした場合は、それ以上テストは実行されません。

DirectMusic の場合は、単一のテストが行われます。演奏された音楽に問題がない場合、または正しく演奏されない場合、どちらの場合も [OK] をクリックします。

また、有効なサービス プロバイダ上の Microsoft DirectPlay® のテストを行うこともできます。

procedure arrow DirectPlay をテストするには

  1. [ネットワーク] ページで、[DirectPlay のテスト] をクリックします。[DirectPlay のテスト] ダイアログ ボックスで、ユーザー名を入力して、サービス プロバイダを選択します。[新しいセッションの作成] を選択し、[OK] をクリックします。モデム接続を選択していた場合は、[モデム接続] ダイアログ ボックスで [応答] をクリックしてモデムを接続待ちの状態にしてください。
  2. Microsoft DirectX® 診断ツールを 1 つ目のコンピュータと接続の確立が可能な、他のコンピュータ上で起動します。[DirectPlay のテスト] をクリックし、1 つ目のコンピュータとは異なるユーザー名を入力し、同じサービス プロバイダを選択します。[既存のセッションに参加] を選択し、[OK] をクリックします。

    3. 接続の種類によっては、電話番号などの情報の入力を求められます。ローカル ネットワーク上の TCP/IP 接続の場合には、このテキスト ボックスには何も入力する必要はありません。

  3. 2 つ目のコンピュータ上の [セッションの一覧] に 1 つ目のコンピュータ上で作成したセッション名が表示されます。セッション名を選択し、[OK] をクリックします。
  4. 両方のコンピュータでチャット ダイアログが表示されます。入力ボックスにメッセージを入力し、[送信] をクリックします。入力されたメッセージは、両方のコンピュータ上のチャット ダイアログにあるスクロール エリアに表示されます。


既定の動作を変更する

[サウンド] ページでスライダを操作して、ハードウェア アクセラレータの設定を変更することができます。ここでの設定は、Microsoft® DirectX® 診断ツールを終了した後もそのまま有効になります。

注 この機能は Microsoft Windows® 95 では無効です。

システムにインストールされている各ディスプレイ デバイスに対する [ディスプレイ] ページで [無効] をクリックすると、Microsoft DirectDraw® または Direct3D® (利用可能な場合) のハードウェア アクセラレータを無効にすることができます。無効にしたアクセラレータは DirectX 診断ツールを終了した後もそのままで、アプリケーションから利用することはできません。アクセラレータをもう一度有効にするには、[有効] クリックします。

注 DirectDraw アクセラレータを無効にすると、Direct3D のアクセラレータも無効になります。

また、DirectDraw の全画面表示アプリケーション使用時のモニタのリフレッシュ レートを変更することもできます。この変更は、特定のアプリケーションでディスプレイに関する問題が発生していて、そのアプリケーションが無効なリフレッシュ レートを設定していると考えられるような場合にだけ行ってください。

procedure arrow リフレッシュ レートを変更するには

  1. [それでも問題が解決しない場合] ページで、[上書き] をクリックします。
  2. [DirectDraw リフレッシュ レートの上書き] ダイアログ ボックスでエディット ボックスを選択し、モニタに対して有効なリフレッシュ レートを入力します。

    3. このボックスに値を入力すると、[上書き値] が自動的にオンになります。

  3. [OK] をクリックします。

procedure arrow リフレッシュ レートの変更を取り消して、DirectDraw アプリケーションが独自のリフレッシュ レートを設定できるようにするには

  1. [それでも問題が解決しない場合] ページで、[上書き] をクリックします。
  2. [DirectDraw リフレッシュ レートの上書き] ダイアログ ボックスで、[既定値] をオンにし、[OK] をクリックします。


トピックが見つかりません

一致するトピックがみつかりませんでした。次のような理由、および解決方法が考えられます。

  • 参照先のトピックを含むファイル (.chm) が想定された場所にありません。

    • 解決方法 : MSDN Library セットアップを再度実行してください。

  • 現在のトピック、または参照先のトピックを含むファイル (.chm) の期限が切れてリンクが無効になっています。

    • 解決方法 : MSDN Library の最新版をインストールします。

  • MSDN Library の CD が CD-ROM に入っていません。

    • 解決方法 : MSDN Library の CD を CD-ROM ドライブに挿入します。