Einführung

Secure4U ist ein Tool, mit dem der Systemadministrator das Sicherheitskonzept der Organisation auf jeder Einzelworkstation implementieren kann, indem er die Zugriffsrechte jeder Anwendung – ob bekannt oder nicht – steuert.

Durch das enorme Wachstum des Internets und die rasant gestiegene Nutzung von E-Mail und Internet werden inzwischen unzählige Anwendungen (ActiveX, Java, trojanische Pferde, usw.) über die ganze Welt verschickt und durch ahnungslose Benutzer aufgerufen, ohne dass der Systemadministrator die Kontrolle darüber hat. Die Bedrohungen durch „Love Letter", „WinExplorer.zip" oder „Back Orifice" sind wohl jedermann noch in bester Erinnerung.

Inzwischen wird auf den meisten aktiven Websites wegen der größeren Attraktivität mit Active Content gearbeitet. Unter Active Content versteht man Erweiterungen, mit denen zusätzliche Funktionalität in Webbrowser eingebaut werden kann (z. B. Menüs, Tabellenkalkulationsblätter oder Animationen). Um Active Content zu erstellen, werden ausführbare Programme neuen Typs (ActiveX , Java ) im Binärformat verwendet. Dies führt zu weiteren Sicherheitsproblemen. Wenn Ihr Webbrowser auf der gerade angezeigten Seite einen Verweis findet, lädt er automatisch den Active Content (der häufig aus unbekannten oder nicht erkennbaren Quellen stammt) herunter und führt den Code aus. Als Folge der Verbreitung und Nutzung des Mediums E-Mail werden jetzt unzählige unbekannte bzw. nicht erkannte Anwendungen über die ganze Welt verschickt und durch ahnungslose Benutzer aufgerufen, mit beträchtlichen Risiken für deren Computer und Unternehmensnetzwerke.

Der empfangene unbekannte Content kann schädlichen oder gefährlichen Code enthalten, der bei den Ressourcen auf Ihrem Computer und/oder in Ihrem Netzwerk beträchtlichen Schaden anrichten kann . Mit Active Content können auch Dateien oder Informationen abgefragt, kopiert und weggeschickt und schlicht die normale Nutzung Ihres Computers unmöglich gemacht werden. Secure4U kann Sie proaktiv sowohl vor Active Content (ActiveX, Java, Java-Skript oder VB-Skript) als auch vor anderem Mobile Code (einem unbekannten ausführbaren Programm) schützen, der in Ihr System eingebracht wird.

Die klassischen Firewalls, mit ihrer Funktion als Gateways für Ihr Netzwerk und Virenscanner stellen keinen proaktiven Schutz gegen diese Bedrohungen dar.

Funktionalität von Secure4U

Secure4U ist die erste kommerzielle Sicherheitslösung , die Workstations und Netzwerke gegen Angriffe durch Active Content jeder Art (ActiveX , Java und sonstiger ausführbarer Code) schützt, der aus dem Internet oder anderen Domänen zu Ihnen gelangt .

Mit Secure4U können Sie für jede Anwendung (ob bekannt oder unbekannt) eine geschlossene Umgebung (Sandbox) schaffen und ihre Zugriffsrechte für die Ressourcen Ihres Computers beschränken. Innerhalb dieser geschlossenen Umgebung ist die Ausführung von beliebigem Code ebenso wie der Zugriff durch die Anwendung auf die Systemressourcen möglich. Die Treiber, die Registry-Datenbank (mit allen Konfigurationen) sind ebenso wie das Dateisystem abgeschirmt und werden ständig überwacht, um die Vertraulichkeit und Integrität Ihres Systems zu schützen.

Bei der Installation von Secure4U durchsucht das Programm die Workstation nach bereits installierten oder bekannten Anwendungen. Zusätzlich richtet sie vorkonfigurierte Standard-Sandboxes für die gängigsten Webbrowser (Netscape Navigator und Internet Explorer) und E-Mail-Clients (Outlook und Outlook Express und Lotus Notes) sowie einen beschränkten Bereich für unbekannte Anwendungen (Gruppe der stark beschränkten Anwendungen) ein.

Secure4U überprüft die Aktivitäten der Anwendung. Die Sicherheitsmechanismen von Secure4U basieren auf einer Abstimmung mit einer Datenbank, die Verweise auf gefährliche Applets enthält. Es überprüft alle Aktionen und Zugriffe auf Ressourcen, blockiert aber nur verdächtige oder unerwünschte Aktionen. Secure4U ist somit die erste kommerzielle Software zur Überprüfung von Anwendungsverhalten, die schützt nicht nur vor beabsichtigten gefährlichen Angriffen schützt, sondern auch vor versehentlich fehlerhaften Anwendungen. Alle anderen Anwendungen innerhalb Ihrer Benutzerumgebung können ausgeführt werden und auf Ressourcen zugreifen, ohne durch Secure4U eingeschränkt zu werden. Sie können sich darüber informieren, welche Komponenten auf Ihrem Computer installiert und gerade aktiv sind, und woher sie stammen. Ebenso können Sie jederzeit überwachen, welche Aktionen eine Anwendung aktuell ausführt, und auf welche Ressourcen sie zugreift.

Secure4U richtet innerhalb einer Microsoft Windows-Workstation einen Sicherheitsbereich ein, führt transparente Ebenen in Ihr Betriebssystem ein und ist in vorhandene Netzwerksicherheitslösungen voll integrierbar. integrierbar. Dadurch stellt Secure4U einen Schutz vor Fehlern und Lücken innerhalb der Sicherheitsmechanismen des Webbrowsers und der Java Virtual Machine dar.


was schützt Secure4U

Schützen von Systemressourcen und -daten

Secure4U schützt die folgenden Ressourcen auf Ihrem Computer vor unerwünschten und verdächtigen Zugriffen und Änderungen:

Registry

Die Windows-Betriebssysteme speichern die Konfigurationen von System und Anwendungen in der Registry-Datenbank. Wenn ein gefährliches Applet Einstellungen innerhalb der Registry ändert, kann dies zur Folge haben, dass Sie nicht mehr mit bestimmten Anwendungen oder sogar dem ganzen System arbeiten können. Durch die Änderung der Registry kann ein gefährliches Applet außerdem unerwünschten Zugriff auf Ressourcen Ihres Computers erhalten.

Zugriff auf Dienste

Secure4U überwacht alle Zugriffe auf Systemdienste , die beschränkte Anwendungen gestartet haben. Ein gefährliches Applet kann Einstellungen von bestimmten Diensten ändern (bestimmte Dienste beenden oder auf bestimmte Dienste zugreifen) und so die Benutzung Ihres Computers unmöglich machen bzw. unerwünschten Zugriff auf Ressourcen oder Daten erhalten.

Gefährliche Systemaufrufe

Bestimmte Systemfunktionen sind ausschließlich für den Windows-internen Gebrauch oder für die Nutzung durch bestimmte Anwendungen bestimmt. Normalerweise besteht keinerlei Grund, diese Systemfunktionen zu nutzen. Gegen gefährliche Gerätezugriffe gibt es in Secure4U ebenfalls Schutzmechanismen. Secure4U schränkt die Verfügbarkeit dieser Systemeinstiegspunkte für beschränkte Anwendungen ein.

Zugriff auf das Dateisystem

Ein gefährliches Applet kann auf das Dateisystem zugreifen und so Zugriff auf Ihren ganzen Daten- und Dateibestand erhalten. Secure4U kann den Zugriff auf das Dateisystem entsprechend der gewählten Konfiguration beschränken . In einem typischen Szenario können Sie z. B. ein Verzeichnis einrichten, in dem aus dem Internet eingegangene Informationen gespeichert werden, und gleichzeitig für Ihren Webbrowser den Zugriff auf alle anderen Bereiche blockieren.

Zugreifen auf und Überwachen von IP-Ports und IP-Adressen

Secure4U kann den Zugriff auf IP-Ports durch beschränkte Anwendungen überwachen. Ein Applet kann über bestimmte IP-Ports Informationen per E-Mail in das Internet stellen oder die Verbindung mit einem beliebigen anderen Protokoll herstellen.

Steuern von Prozess-Starts

Secure4U kann das Starten einer weiteren Anwendung durch eine beschränkte Anwendung verhindern oder die Übernahme der gesicherten Umgebung einer beschränkten Anwendung erzwingen. Dies kann verhindern, dass gefährlicher Code vertrauenswürdige Anwendungen unbefugterweise aufruft.

Active Content, Viren, Inhalt filtern

Mit Secure4U können Sie Active Content verwalten und Ihren Computer gegen alle installierten ActiveX- und Java-Applets schützen. Secure4U sichert Ihren Computer ab, wenn ein neues Applet hinzukommt und aktiv wird. Im Falle eines ActiveX-Applets können Sie feststellen, wer das Applet erstellt hat, ob die Applet-Eigenschaften ordnungsgemäß angegeben sind, von welcher Site es heruntergeladen wurde, und wie es in Ihr System integriert ist. Zusätzlich können Sie auch jedes installierte ActiveX-Applet löschen.

Überprüfung auf Viren

Ist ein von Secure4U unterstützter Virenscanner installiert, so werden alle über Ihren Webbrowser empfangenen CAB-Dateien geöffnet und auf Viren überprüft, bevor sie auf dem Computer installiert werden. Für die eigentliche Virenprüfung ruft Secure4U über eine API oder eine Befehlszeile einen auf Ihrem Computer installierten Virenscanner auf. Secure4U unterstützt eine Reihe der gängigsten Virenscanner . Zusätzlich können Sie benutzerdefinierte, gängige Virenscanner mit Befehlszeilenparametern verwenden. Ihr Virenscanner arbeitet auch dann mit Secure4U zusammen, wenn er nicht per Befehlszeile steuerbar ist.

Cache-Verwaltung

Der Cache-Manager ist vollständig in die Secure4U Umgebung integriert. Der Cache-Manager ermöglicht das automatische Löschen von Sitzungsdaten in der Browser-Cachedatei.

Cookie-Verwaltung

Mit dem Cookie-Manager können alle Cookies für alle Benutzer bzw. Profile auf einem Computer blockiert, entfernt oder verwaltet und das Speichern von Cookies nach Website bzw. URL beschränkt werden.


Administrationstool Überblick

Das Secure4U Administrationstool stellt die Schnittstelle zur Verfügung, mit der der Administrator sämtliche Bestandteile und Komponenten von Secure4U interaktiv konfigurieren kann. Es besteht aus zwei Teilen: Sandbox & Firewall und Inhalt filtern. Sandbox & Firewall ist wiederum in den einfachen und den erweiterten Modus gegliedert.

Mit dem Secure4U Administrationstool kann der Systemadministrator Secure4U konfigurieren.


Die Menüs

Das lokale Secure4U Administrationstool weist derzeit folgende Menüs auf:

  • Menü Datei
  • Menü Bearbeiten
  • Menü Ansicht
  • Menü Hilfe


Menü Datei

Das Menü Datei enthält folgende Befehle:

  • Lokale Konfiguration speichern

  • Lokale Konfiguration wiederherstellen

  • Standardkonfiguration wiederherstellen

  • Beenden

Lokale Konfiguration speichern / wiederherstellen

Sie können Ihre aktuelle Konfiguration oder weitere Konfigurationen speichern und sie später wiederherstellen, indem Sie im Menü den Befehl Lokale Konfiguration speichern bzw. wiederherstellen auswählen.

Geben Sie den Namen der zu speichernden Konfiguration in das Feld Konfigurationskennung ein. Sie aktivieren dadurch die Schaltfläche Speichern, so dass die Konfiguration gespeichert werden kann. Wenn Sie diese Konfiguration wiederherstellen möchten, wählen Sie sie im Dialogfeld aus und klicken auf die Schaltfläche Wiederherstellen.

Standardkonfiguration wiederherstellen

Mit diesem Befehl können Sie die Systemkonfiguration mit den Einstellungen wiederherstellen, die Sie beim Einrichten des Systems gewählt haben.

Kennwort ändern

Sie können den Zugriff auf die Secure4U Administrationstools zur Konfiguration blockieren, indem Sie Ihr eigenes Kennwort auswählen. Bei der Eingabe des Kennworts lassen Sie die Spalte Altes Kennwort leer und geben in die übrigen Spalten Informationen ein. Wenn Sie die Blockierung des Zugriffs aufheben möchten, geben Sie das Kennwort in die Spalte Altes Kennwort ein und lassen die übrigen Spalten leer.

Beenden

Mit diesem Befehl beenden Sie das Secure4U Administrationstool und speichern alle Konfigurationsänderungen.


Menü Bearbeiten

Das Menü Bearbeiten enthält folgende Befehle:

  • Secure4U aktivieren

  • Secure4U deaktivieren

  • Neue Anwendungsgruppe erstellen

  • Audit

  • Ausführungseinstellungen

Secure4U aktivieren/deaktivieren

Sie können Secure4U aktivieren bzw. deaktivieren, indem Sie im Menü Bearbeiten Secure4U aktivieren bzw. Secure4U deaktivieren wählen. Bei deaktiviertem Secure4U erfolgt weder ein Schutz noch eine Überwachung. Bei aktiviertem Secure4U sind Schutz und Überwachung entsprechend den gewählten Secure4U Einstellungen gewährleistet.

Hinweis! Eine Deaktivierung von Secure4U ist sofort wirksam. Nach einer Aktivierung dagegen müssen Sie die beschränkten Anwendungen erneut starten, damit die Änderung wirksam wird.

Symbol

Status

Hinweis

Grün

Der normale Modus, und Secure4U ist aktiviert.

Rot

Die Verbindung zum Internet ist aktiv, und Secure4U ist aktiviert.

Grau

Wird das Secure4U Symbol in Grau dargestellt, so ist Secure4U deaktiviert.

Neue Anwendungsgruppe erstellen

Weitere Informationen zu diesem Befehl finden Sie im Kapitel „Erweiterter Modus / Erstellen einer Anwendungsgruppe“.

Audit

In der ersten Maske Audit-Einstellungen können Sie ein Verzeichnis für die Protokolldatei angeben.

Intervall für Protokollerstellung – dieser numerische Wert steht für die Anzahl der überwachten Ereignisse, bevor ein Eintrag ins Protokoll erfolgt.

Audit-Ebenen

Hier können Sie die Audit-Ebenen und -Aktionen neu definieren.

Wählen Sie einen Namen für die betreffende Audit-Ebene. Nach der Angabe des Namens ordnen Sie der betreffenden Ebene die gewünschten Aktionen zu. Eine Reihe von Audit-Ebenen sind identisch. Sie können sie jedoch umdefinieren. Hinweis: Je höher der numerische Wert, desto umfassender die Audits.

Der Standard-Zustand kann nicht wiederhergestellt werden. Die Standard-Zustände werden unten beschrieben.

Die Standard-Zustände sind wie folgt definiert:

Nr | Name | Beschreibung
0 | Ignorieren | Kein Audit
1 | Aktivitätsfenster | Aktivitätsfenster
2 | Aktivitätsfenster | Aktivitätsfenster
3 | Protokollieren in Datei | Aktivitätsfenster, Protokollieren in lokaler Datei
4 | Protokollieren in Datei | Aktivitätsfenster, Protokollieren in lokaler Datei
5 | Protokollieren in Datei | Aktivitätsfenster, Aktivitätsfenster immer oben, Protokollieren in lokaler Datei
6 | Lokale Warnmeldung | Aktivitätsfenster, Protokollieren in lokaler Datei, Anzeige eines Meldungsfeldes für den Benutzer

Die Bedeutungen im einzelnen:

  • Aktivitätsfenster – die Audit-Meldungen werden im Aktivitätsfenster angezeigt
  • Aktivitätsfenster immer oben – das Aktivitätsfenster wird ganz oben auf dem Fensterstapel angezeigt
  • Protokollieren in lokaler Datei – Ereignisse werden in eine bestimmte Datei geschrieben
  • Anzeige eines Meldungsfeldes für Benutzer – Auf dem lokalen Computer wird ein Meldungsfeld angezeigt

Alle Änderungen werden sofort wirksam.

Hinweis! Das XML-Format wird sowohl für das Protokollieren in einer lokalen Datei als auch für Netzwerk-Audits verwendet. Die erstellten Dateien können mit dem Internet Explorer ab Version 5.0 oder einer anderen Anwendung angezeigt werden, die das XML-Format unterstützt. Darüber hinaus enthält das Protokollverzeichnis eine XML-Skriptdatei (all.xml) zur Filterung und Analyse der erstellten Protokolle.

Ausführungseinstellungen

Sie können für dafür geeignete bestimmte Anwendungsgruppen z. B. zur Leistungssteigerung Secure4U Funktionsblöcke deaktivieren.

Sind bestimmte Sicherheitsüberprüfungen nicht erforderlich, können Sie sie deaktivieren. Die Deaktivierung sollte jedoch absoluten Ausnahmen vorbehalten sein, da dadurch zentrale Komponenten von Secure4U für beschränkte Gruppen möglicherweise deaktiviert werden.

Kernelmodus-Engine
  • Registry-Schutz – Schützt Zugriffe auf die Informationen in der Registry
  • Dateischutz – Schützt Zugriffe auf das Dateisystem
  • Schutz für Prozess-Starts – Schützt die Anwendung, die durch eine andere Anwendung gestartet (aufgerufen) wird
  • TCP/IP-Schutz – Schützt die TCP/IP-Ports und IP-Adressen.

System – Benutzermodus-Engine

Nähere Informationen dazu finden Sie im Kapitel „System“ unter „Verschiedenes“.

System – Kernelmodus-Engine
  • Schutz gegen gefährliche Gerätezugriffe – schützt die nachfolgend aufgeführten Komponenten
    • Trennen eines Laufwerks
    • Sperren eines Laufwerks
    • Einstellen der Komprimierung
    • Aufheben der Laufwerksperre
    • Ausgabe der Wechselfestplatte
    • Formatieren der Festplattenspuren
    • Laden der Wechselfestplatte
    • Entfernen der Wechselfestplatte
    • Neuzuweisung von Festplattenblöcken
    • Festlegen des Plattenlaufwerklayouts
    • Festlegen der Partitionsinformationen für die Festplatte
    • Überprüfen der Festplatte
    • Serial lsrmst-Insert
  • Schutz der E-/A-Ports – schützt Zugriffe auf LPT und COM
HTTP-Filter

Siehe „Inhalte filtern“.

Hinweis! Sie können für das HTTP-Filtern nur alle Einträge oder gar keinen auswählen. Die Auswahl einzelner Einträge ist nicht möglich.


Menü Ansicht

Mit den Befehlen in diesem Menü können Sie die Benutzerschnittstelle des Secure4U Administrationstools anpassen. Das Menü enthält folgende Befehle } :

  • Symbolleiste

  • Statusleiste

  • Einfacher Modus

  • Erweiterter Modus

  • Aktualisieren

Durch die (De-)Aktivierung dieser Befehle können Sie die Symbolleiste bzw. Statusleiste ein- bzw. ausblenden.

Symbolleiste

Die Symbolleiste besteht aus vier Symbolen. Mit dem ersten können Sie eine neue Anwendungsgruppe erstellen. Mit dem zweiten können Sie Secure4U aktivieren bzw. deaktivieren. Mit dem dritten Symbol schalten Sie das Administrationstool zwischen dem einfachen und dem erweiterten Modus um. Wenn Sie auf das vierte Symbol klicken, wird im Secure4U Administrationstool das Feld Info zu Secure4U angezeigt.

Statusleiste

Die Statusleiste wird am unteren Fensterrand angezeigt und informiert Sie über den Status jedes Befehls im Menü.

Einfacher Modus

Durch die Wahl dieses Symbols können Sie das Administrationstool in den einfachen Modus umschalten.

Erweiterter Modus

Durch die Wahl dieses Symbols können Sie das Administrationstool in den erweiterten Modus umschalten.

Aktualisieren

Durch die Wahl dieses Befehls aktualisieren Sie die aktuelle Ansicht.


Menü Hilfe

Das Menü Hilfe enthält folgende Befehle:

  • Hilfethemen

  • Secure4U im Web

  • Info zum Administrationstool

Hilfethemen

Sie können in der Onlinehilfe nach einem Hilfethema suchen. Wenn Sie weitere Hilfeinformationen benötigen, sollten Sie in diesem Benutzerhandbuch oder in den FAQs auf unserer Website nachschlagen. Sie können sich auch direkt über die E-Mail-Adresse support@Secure4U.com an uns wenden.

Secure4U im Web

Dieser Befehl enthält zwei Hyperlinks: Einen auf die Homepage von Secure4U (http://www.secure4u.de/) und einen weiteren auf die FAQs (http://www.secure4u.de/Support/faq.htm).


Einfacher Modus

Im einfachen Modus steht Ihnen eine Schnittstelle zur Verfügung, mit der Sie die Sicherheitsebene der ausgelieferten vorkonfigurierten Anwendungen auf einfache Weise ändern können. Dieses einfache Tool ist jedoch für komplexere Anforderungen nicht immer ausreichend. Für diese Fälle gibt es in Secure4U den erweiterten Modus.

Im Administrationsfenster des einfachen Modus werden im linken Fensterausschnitt drei Gruppen angezeigt:

  • Vorkonfigurierte Anwendungen

  • Benutzergruppen

  • Verzeichnisse


Vorkonfigurierte Anwendungen

Mit dieser Secure4U Komponente können Sie die Sicherheitsebene für bestimmte vordefinierte Anwendungen ändern: Outlook, Outlook Express, Internet Explorer, Netscape Communicator und Lotus Notes. Für jede vorkonfigurierte Anwendung stehen folgende Sicherheitsebenen zur Auswahl.

Sicherheitsebenen

Hoch | Die höchste Sicherheitsebene mit dem optimalen Schutz, auf der mit dem „sicheren Starten“ gearbeitet wird. Sicheres Starten bedeutet, dass die unbeschränkte Anwendung die Sicherheitsumgebung der beschränkten Anwendung übernimmt. Aus diesem Grund hat die gestartete Anwendung möglicherweise nicht Zugriff auf alle notwendigen Ressourcen. Der Zugriff ist nur für eine äußerst begrenzte Anzahl von Verzeichnissen (z. B. Download-Verzeichnisse) und Registry-Schlüsseln zugelassen. IP-Ports sind stark zugriffsbeschränkt. Hinweis! Dies kann zu Problemen führen, wenn Elemente von bestimmten Websites heruntergeladen werden, oder wenn Sie Daten über eine Firewall schicken. In diesem Fall sollten Sie die Sicherheitsebene vorübergehend niedriger setzen. Laden Sie stets nur Anwendungen herunter, die Sie wirklich kennen!
Mittlere | Wenn eine unbeschränkte Anwendung gestartet wird, übernimmt sie nicht die Sicherheitsumgebung der startenden Anwendung. Lesezugriff auf Dateien, vertrauliche Verzeichnisse ausgenommen. Der Schreibzugriff wird nur für eine sehr begrenzte Anzahl von Dateien zugelassen. (z. B. Download-Verzeichnisse) Lesezugriff auf die Registry, ausgenommen bestimmte Einträge. Die Sicherheitsebene für weniger zugriffsbeschränkte IP-Ports.
Niedrig | Voller Zugriff auf Dateien, ausgenommen vertrauliche, riskante und Systemverzeichnisse. Voller Zugriff auf die Registry, ausgenommen wenige schreibgeschützte Einträge.
Keine | Keinerlei Beschränkungen für die Anwendung. Diese Sicherheitsebene sollten Sie nur vorübergehend verwenden.

Wenn die neuen Einstellungen wirksam werden sollen, klicken Sie auf die Schaltfläche Sicherheitsebene ändern.

Der Schutzumfang für jede Sicherheitsebene hängt von der Konfiguration einer vordefinierten Datenbank ab. Wenn Sie die Zugriffsrechte einer vorkonfigurierten Anwendung ändern möchten, müssen Sie in den erweiterten Modus umschalten.


Anwendungsgruppen

Nach der Wahl von Anwendungsgruppen im linken Fensterausschnitt wird folgendes Fenster angezeigt. Hier können Sie die Sicherheitsebene für jede bekannte Anwendung wählen. Die Sicherheitsebenen entsprechen denjenigen für die vorkonfigurierten Anwendungen, die bereits oben beschrieben wurden.

Hinweis!

Da die Sicherheitsebenen fest zugewiesen sind, können bei der Ausführung einer beschränkten Anwendung Probleme auftreten. Wenn Sie der Anwendung andere Zugriffsrechte zuweisen möchten, müssen Sie den erweiterten Modus aktivieren.

Mittlerer Fensterausschnitt

Im mittleren Fensterausschnitt werden vier Anwendungsgruppen angezeigt. Jede dieser Anwendungsgruppen steht für eine vorkonfigurierte Sicherheitsebene:

· Unbeschränkt
· Niedrig
· Anwendungen mit mittlerem Risiko
· Stark beschränkte Anwendungen

Bei der Installation von Secure4U überprüft die Software die auf dem Computer vorhandenen Anwendungen (ausgenommen die vorkonfigurierten Anwendungen) und weist sie der Gruppe der unbeschränkten Anwendungen zu.

Wenn Sie mit der rechten Maustaste auf die Gruppe Unbeschränkte Anwendungen klicken, stehen Ihnen in einem Kontextmenü die Optionen Alle ausführbaren Programme in lokalen Laufwerken (zur Gruppe) hinzufügen, Einzelne Anwendung hinzufügen oder Teilbaum hinzufügen (alle ausführbaren Programme innerhalb des Verzeichnisses zur Gruppe hinzufügen) zur Auswahl.

Alle unbekannten Anwendungen, die nach der Installation von Secure4U hinzugekommen sind (z. B. aus dem Internet heruntergeladene bzw. per E-Mail eingegangene ausführbare Programme) werden automatisch den stark beschränkten Anwendungen zugeordnet. Danach kann ihnen eine der oben beschriebenen Sicherheitsebenen zugewiesen werden.

Wenn Sie mit der rechten Maustaste auf die Gruppe Stark beschränkte Anwendungen klicken, können Sie den Befehl Unbekannte Anwendungen suchen für alle lokalen Laufwerke wählen.

Fensterausschnitt oben rechts

Dieser Fensterausschnitt wird nur dann angezeigt, wenn Sie die Gruppe Unbeschränkte Anwendungen wählen. Er enthält den Verzeichnisbaum.

Wenn Sie mit der rechten Maustaste auf ein ausgewähltes Verzeichnis klicken, wird ein Kontextmenü angezeigt. In diesem Menü können Sie alle Anwendungen im ausgewählten Verzeichnis hinzufügen, alle Anwendungen im Teilbaum hinzufügen, alle Anwendungen im ausgewählten Verzeichnis oder Teilbaum löschen sowie eine Einzelanwendung hinzufügen.

Unterer Fensterausschnitt

Im unteren Fensterausschnitt werden alle Anwendungen innerhalb einer bestimmten Gruppe bzw. innerhalb eines bestimmten Verzeichnisses angezeigt.

Wenn Sie mit der rechten Maustaste auf eine Anwendung klicken, können Sie im angezeigten Kontextmenü einen Befehl zum Verschieben dieser Anwendung in eine andere Gruppe wählen. Eine weitere Möglichkeit ist, die betreffende Anwendung per Drag & Drop in die gewünschte Gruppe im mittleren Fensterausschnitt zu verschieben.


Verzeichnisse

Mit dieser Komponente können Sie das Verzeichnis angeben, auf das eine beschränkte Anwendung Zugriff haben soll. Sie können die (ungeschützten) Verzeichnisse auswählen, die für Daten aus dem Internet verwendet werden sollen. Zudem können Sie die (vertraulichen) Verzeichnisse angeben, die Sie dem Zugriff durch die beschränkten Anwendungen entziehen möchten.

Fensterausschnitt | Zugriff | Hinweis
Ungeschützt | Alle Anwendungen | Auf diese Verzeichnisse haben alle Anwendungen auf der Workstation Zugriff. In diese Verzeichnisse sollten Sie nur Ordner einfügen, die keine wichtigen Daten enthalten, z. B. nur temporär verwendete Ordner.
Vertraulich | Nur unbeschränkte Anwendungen | Auf diese Verzeichnisse haben nur unbeschränkte Anwendungen Zugriff.

Die Zugriffsrechte für alle anderen Verzeichnisse hängen von der Einstellung ab, die Sie in der vordefinierten Datenbank für die Sicherheitsebene der beschränkten Anwendung (hoch bis keine) auswählen.

Hinweis! Diese Verzeichnisse wurden bei der Installation von Secure4U angegeben. Sie können die ungeschützten oder vertraulichen Verzeichnisse für andere Ordner erweitern.

Hinzufügen und Löschen von Verzeichnissen

Sie können ein Verzeichnis zu einem ungeschützten oder vertraulichen Verzeichnis hinzufügen, indem Sie in der oberen rechten Ecke des betreffenden Verzeichnisfensterausschnitts auf Hinzufügen klicken. Wenn Sie ein Verzeichnis auswählen und dann auf Löschen klicken, wird das Verzeichnis mit sämtlichen darin enthaltenen Dateien aus dem Fensterausschnitt entfernt.

TIPP! Wenn in einem vertraulichen Verzeichnis Daten abgelegt sind und eine beschränkte, nach Ihrer Einschätzung vertrauenswürdige Anwendung Zugriff auf diese Daten haben soll, sollten Sie diese Anwendung in die Gruppe Unbeschränkte Anwendungen verschieben und danach auf den Ordner zugreifen, anstatt den Ordner zwischen den vertraulichen und den ungeschützten Verzeichnissen zu verschieben. Sie verhindern dadurch, dass alle Anwendungen auf den Ordner zugreifen können.


ERWEITERTER MODUS

Im erweiterten Modus steht Ihnen eine Schnittstelle zur Verfügung, mit der Sie die Zugriffsrechte jeder Anwendung auf der Workstation konfigurieren können.

Sie können den erweiterten Modus aktivieren, indem Sie den entsprechenden Befehl im Menü Ansicht wählen, oder indem Sie auf das Hammersymbol (Umschalter) in der Symbolleiste klicken.

Im Fenster Sandbox & Firewall für den erweiterten Modus gibt es im linken Fensterausschnitt sieben Administrationsgruppen:

  • Anwendungsgruppen

  • System

  • Dateisicherheit

  • Registry-Sicherheit

  • Firewall

  • Virenprüfung

  • Lernmodus


Anwendungsgruppen

Anwendungsgruppen haben im einfachen Modus eine ähnliche Konfiguration wie Benutzergruppen. Zusätzlich zu den vordefinierten Sicherheitsebenen können für alle beschränkten Anwendungen Einzelgruppen eingerichtet werden.

Die konfigurierten Anwendungsgruppen lassen sich in verschiedene Kategorien aufteilen. Die erste Kategorie enthält die Gruppen mit verschiedenen Sicherheitsebenen (unbeschränkte Anwendungen, Anwendungen mit niedrigem Risiko, Anwendungen mit mittlerem Risiko und stark beschränkte Anwendungen).

Die zweite Kategorie enthält die Gruppen, die speziell auf bestimmte Anwendungen wie Outlook, Internet Explorer, Netscape, usw. zugeschnitten sind.

Die dritte Kategorie enthält Gruppen für bestimmte Zwecke: MS-DOS-Anwendungen (nur unter MS Windows NT/2000; enthält alle 16-Bit-Anwendungen), Visual Basic-Skripts, Unbeschränkte gestartete Anwendungen (die Anwendung selbst wird als unbeschränkte Anwendung gestartet, unabhängig von der Anwendung, die sie aufgerufen hat). Alle Anwendungen, die innerhalb einer Anwendung aus der Gruppe der Installations-Anwendungen gestartet wurden, übernehmen die Sicherheitsebene der startenden Anwendung. Diese Gruppe sollte von vertrauenswürdigen Anwendungen verwendet werden, da diese einen unbeschränkten Zugriff benötigen.

Erstellen einer Anwendungsgruppe

Wenn Sie eine Anwendungsgruppe erstellen möchten, wählen Sie im Menü Bearbeiten den Befehl Neue Anwendungsgruppe erstellen, oder Sie klicken mit der rechten Maustaste auf eine bereits vorhandene Anwendungsgruppe und wählen im Kontextmenü denselben Befehl.

Geben Sie bitte einen eingängigen Namen für die Anwendungsgruppe ein, z. B. Büro, und legen Sie fest, ob die Gruppe beschränkt oder unbeschränkt sein soll. Sie können die Konfiguration der Anwendungsgruppe später ändern.

Sie können der Anwendungsgruppe eine oder mehrere Anwendungen hinzufügen, indem Sie in der oberen rechten Ecke des Fensterausschnitts auf die Schaltfläche Hinzufügen klicken. Wenn Sie eine Anwendung aus dem Fensterausschnitt und der Gruppe entfernen möchten, wählen Sie sie aus und klicken auf Löschen. Klicken Sie abschließend auf Fertig stellen. Ihr Fenster Anwendungsgruppen könnte nach der Erstellung einer neuen Anwendungsgruppe namens „Büro“, die z. B. die Anwendung WinWord enthält, wie unten dargestellt aussehen.

Hinzufügen einer Anwendung

Wenn Sie mit der rechten Maustaste auf eine der Anwendungen im rechten Fensterausschnitt klicken, können Sie der Gruppe eine weitere Anwendung hinzufügen oder die ausgewählte Anwendung in eine andere Gruppe verschieben.

Hinweis: Wenn Sie eine Anwendung aus einem verborgenen freigegebenen Pfad hinzufügen möchten, wählen Sie Anwendung hinzufügen und geben den Pfad manuell ein.

Wenn Sie eine Anwendungsgruppe entfernen möchten, klicken Sie mit der rechten Maustaste auf die betreffende Gruppe.

Hinweis! Nach dem Entfernen einer Anwendungsgruppe werden alle darin enthaltenen Anwendungen vom System als stark beschränkte (unbekannte) Anwendungen behandelt. Daher sollten Sie zuerst die Anwendungen in eine von Ihnen ausgewählte Gruppe verschieben.

Fensterausschnitt oben rechts

Dieser Fensterausschnitt wird nur dann angezeigt, wenn Sie die Gruppe Unbeschränkte Anwendungen wählen. Er enthält den Verzeichnisbaum.

Wenn Sie mit der rechten Maustaste auf ein ausgewähltes Verzeichnis klicken, wird ein Kontextmenü angezeigt. In diesem Menü können Sie alle Anwendungen im ausgewählten Verzeichnis hinzufügen, alle Anwendungen im Teilbaum hinzufügen und alle Anwendungen im ausgewählten Verzeichnis oder Teilbaum löschen.

Unterer Fensterausschnitt

Im unteren Fensterausschnitt werden alle Anwendungen innerhalb einer bestimmten Gruppe bzw. innerhalb eines bestimmten Verzeichnisses angezeigt.

Wenn Sie mit der rechten Maustaste auf eine Anwendung klicken, können Sie diese in eine der Gruppen im Kontextmenü verschieben. Eine weitere Möglichkeit ist, die betreffende Anwendung per Drag & Drop in die gewünschte Gruppe im mittleren Fensterausschnitt zu verschieben.


System

In dieser Secure4U Konfigurationskomponente können Sie die Zugriffsrechte für zentrale Systemkomponenten und funktionen auflisten und einrichten (z. B. Herunterfahren des Systems). Darüber hinaus können Sie für die Anzahl der von den Anwendungen geöffneten Fenster und die von ihnen belegte Arbeitsspeicherkapazität Obergrenzen einrichten.

Wenn Sie die Systemkomponente konfigurieren möchten, klicken Sie im linken Fensterausschnitt auf System. Im mittleren Fensterausschnitt werden drei Einträge angezeigt:

  • Dienste (nicht unter Windows 9x)

  • Prozesse

  • Verschiedenes


Dienste

Wenn Sie die Zugriffsrechte für Dienste einrichten möchten, klicken Sie im mittleren Fensterausschnitt auf den Eintrag Dienste. Das Administrationstool zeigt daraufhin im rechten Fensterausschnitt die Einstellungen für die ausgewählte Anwendungsgruppe an.

Einstellungen für den rechten Fensterausschnitt

Zugriff

Im oberen Bereich des rechten Fensterausschnitts stehen Ihnen vier der wichtigsten Zugriffsrechte zur Auswahl:

Freier, unbegrenzter Zugriff

Mit diesem Zugriffstyp erteilen Sie standardmäßig sämtliche möglichen Zugriffsrechte für alle Objekte innerhalb des Dateisystems bzw. im ausgewählten Laufwerk.

Schreibgeschützter Zugriff

Mit diesem Zugriffstyp erteilen Sie standardmäßig den reinen Lesezugriff für alle Objekte innerhalb des Dateisystems bzw. im ausgewählten Laufwerk.

Kein Zugriff

Mit diesem Zugriffstyp blockieren Sie standardmäßig den Zugriff auf alle Objekte innerhalb des Dateisystems bzw. im ausgewählten Laufwerk.

Benutzerdefinierter Zugriff

Mit diesem Zugriffstyp können Sie die erteilten Zugriffsrechte und Secure4U Aktionen exakt spezifizieren, indem Sie verschiedene Zugriffsrechte und Secure4U Aktivitäten zu einem benutzerdefinierten Zugriffstyp kombinieren. Im unteren Bereich des Dialogfeldes sind Registerkarten für die drei Aktionen Zugriff, Überwachen und Interaktiv enthalten.

Das Feld enthält sämtliche Optionen, die für jede der Registerkarten verfügbar sind. Diese Einstellungen basieren auf den Einstellungen, die in Windows NT/2000 für die Objektzugriffssicherheit verwendet werden. Auf der Registerkarte Zugriff können Sie die Zugriffsbeschränkungen einstellen, d. h., ob und auf welche Weise eine beschränkte Anwendung auf ein Objekt zugreifen kann. Auf der Registerkarte Überwachen können Sie die Aktionen angeben, die im Secure4U Aktivitätsfenster angezeigt werden sollen. Auf der Registerkarte Interaktiv schließlich können Sie den Umfang der Interaktivität von Secure4U festlegen, d. h., bei welchen Aktionen Secure4U eine Eingabeaufforderung anzeigt, bevor eine bestimmte Zugriffsanforderung ausführt.

Hinweis! Unter Windows 9x/ME ist die Funktion Interaktiv nicht für alle Objekte verfügbar.

Im rechten Bereich des Fensterausschnitts können Sie festlegen, auf welche Weise die Dateizugriffsbeschränkungen auch für die Dateien gelten sollen, die sich weiter oben oder unten in der Dateihierarchie befinden:

  • Berechtigungen vom übergeordneten Objekt übernehmen

Das Objekt hat dieselben sicherheitsrelevanten Berechtigungen wie das übergeordnete Objekt. Wenn die Sicherheitseinstellung des übergeordneten Objekts geändert wird, werden die sicherheitsrelevanten Berechtigungen für dieses Objekt automatisch entsprechend geändert.

  • Berechtigungen bei Teilobjekten ersetzen
    • Übernahme von übergeordnetem Objekt erzwingen

Alle Berechtigungen für den Teilbaum werden durch die Sicherheitseinstellungen des übergeordneten Objekts ersetzt. Sie übernehmen somit die Zugriffsberechtigungen des übergeordneten Objekts.

    • Eigene, explizite Berechtigungen erstellen

Bei dieser Einstellung werden die Sicherheitseinstellungen des übergeordneten Objekts für die unmittelbar untergeordneten Objekte (nur auf der nächstniedrigen Ebene) nicht übernommen. Wenn die sicherheitsrelevanten Berechtigungen derzeit somit denjenigen des übergeordneten Objekts entsprechen und Sie die Sicherheitseinstellung des übergeordneten Objekts ändern, so bleiben die Teilbaum-Berechtigungen von vorhandenen Objekten beim Erstellen von expliziten Berechtigungen für diese Objekte unverändert.

Farben und roter Stern im Verzeichnis

Mit den verschiedenen Farben können Sie für jeden Ordner unterschiedliche Zugriffstypen angeben.

Farbe | Zugriff
Rot | Kein Zugriff
Blau | Schreibgeschützt
Gelb | Uneingeschränkter Zugriff
Orange | Benutzerdefiniert

Der rote Stern in einem Verzeichnis zeigt an, dass ein Teil der bzw. alle Dateien oder Ordner im Teilbaum andere Einstellungen als das betreffende Objekt aufweisen.

Aktivieren von Änderungen / Einstellungen

Alle Änderungen an den Zugriffsbeschränkungen werden nach einer Änderung sofort wirksam.

Hinweis! Damit die neuen Einstellungen wirksam werden, müssen Sie auf Einstellen klicken.

Audit

In Secure4U können Sie die Audit-Ebene für jedes Objekt angeben. Hiermit legen Sie fest, was mit den überwachten Zugriffen geschehen soll (z. B. Anzeige im Aktivitätsfenster und Protokollieren in einer Datei). Je größer der numerische Wert, desto umfassender das Audit. Weitere Informationen dazu finden Sie im Kapitel „Die Menüs“ unter „Audit“.

Der unterste Bereich – Ja und Nein

Der untere Bereich des Fensterausschnitts enthält drei Registerkarten: Zugriff, Überwachen und Interaktiv. Der Fensterausschnitt Zugriff steuert die Zugriffsberechtigungen. Im Fensterausschnitt Überwachen können Sie die zu überwachende Aktion angeben. Bei aktiviertem Audit können Sie steuern, was angezeigt werden kann. Weitere Informationen dazu finden Sie im Kapitel „Secure4U Warnmeldung“.

Wenn Sie auf die Flags klicken, können Sie zwischen Ja und Nein (Kein Zugriff für die Anwendungsgruppe) umschalten.

Elemente der Registerkarten

Das Feld enthält sämtliche Optionen, die für jede der Registerkarten verfügbar sind. Auf der Registerkarte Zugriff können Sie die Zugriffsbeschränkungen einstellen, d. h., ob und auf welche Weise eine beschränkte Anwendung auf einen Dienst zugreifen kann. Auf der Registerkarte Überwachen können Sie die Aktionen angeben, die im Secure4U Aktivitätsfenster angezeigt werden sollen. Auf der Registerkarte Interaktiv schließlich können Sie den Umfang der Interaktivität von Secure4U festlegen, d. h., bei welchen Aktionen Secure4U eine Eingabeaufforderung anzeigt, bevor eine bestimmte Zugriffsanforderung ausgeführt wird.

Hinweis! Damit die neuen Einstellungen wirksam werden, müssen Sie auf Einstellen klicken.

Es gibt sieben Alternativen für den Zugriff auf Dienste:

  • Status des Dienstes abfragen
  • Dienst starten
  • Dienst beenden
  • Dienst entfernen
  • Dienst öffnen
  • Dienst installieren
  • Dienst steuern


Prozesse

Die Prozesskonfiguration läuft ähnlich wie die Dateikonfiguration ab. Die Elemente im rechten Fensterausschnitt entsprechen weitgehend den Elementen, die im Kapitel „Einstellungen für den rechten Fensterausschnitt“ beschrieben werden.

Starten

Beim Starten übernimmt die gestartete Anwendung die Sicherheitsumgebung der Anwendung, die die gestartete Anwendung aufruft. Beispiel: Sie haben in Outlook (der startenden Anwendung) eine E-Mail mit einem Word-Dokument erhalten. Wenn Sie die Anlagendatei öffnen möchten, ruft Outlook das Programm Microsoft Word auf und übermittelt ihm das Dokument in der Anlage. Microsoft Word ist in diesem Fall die gestartete Anwendung.

Es gibt folgende Zugriffsalternativen für das Starten:

  • DOS-Programm starten

  • Befehlsinterpreter starten

  • Nicht aufgelöster Prozess gestartet (Secure4U kann die Anwendung nicht finden)

  • Stark beschränkte Anwendungen gestartet (d. h. Starten einer unbekannten Anwendung)

  • Beschränkte Windows-Anwendungen gestartet

  • Unbeschränkte Windows-Anwendungen gestartet (die unbeschränkte Anwendung übernimmt die Zugriffsrechte der beschränkten Anwendungen).

  • Unsicheres Starten von unbeschränkten Anwendungen (deaktiviert die Übernahme der Zugriffsberechtigungen beim Starten von unbeschränkten Windows-Anwendungen)

Prozess-/Thread-Beendigung erzwingen

Wenn diese Option aktiviert ist, werden alle Thread- und Prozessmanipulationen für die ausgewählte Anwendungsgruppe dem definierten Sicherheitskonzept entsprechend eingeschränkt.

Hinweis! Durch eine Änderung der Zugriffsrechte kann es mit den Anwendungen, die Sie beschränken, zu Problemen kommen. Eine Anwendung mit zu stark beschränkten Zugriffsrechten ist nicht ablauffähig!


Verschiedenes

Die “verschiedenen” Zugriffsrechte werden auf ähnliche Weise wie die Zugriffsrechte für Dienste eingerichtet. Klicken Sie im mittleren Fensterausschnitt auf Sonstiges . Das Administrationstool zeigt dann die Zugriffsrechte der ausgewählten Anwendungsgruppe im rechten Fensterausschnitt an.

Für die ausgewählten Anwendungsgruppen stehen sieben Zugriffsrechte zur Auswahl. Wenn Sie eine Einstellung für einen Zugriffstyp ändern möchten, klicken Sie mit der rechten Maustaste und wählen die betreffende Secure4U Aktion im Kontextmenü aus.

Einstellung | Secure4U Aktivität
Gestatten | Secure4U gewährt vollen Zugriff
Überwachen | Secure4U überwacht sämtliche Zugriffsrechte diesen Typs
Interaktiv | Secure4U fragt den Benutzer, ob der Zugriff erlaubt oder blockiert werden soll (interaktives Blockieren)
Verhindern | Secure4U blockiert und überwacht automatisch alle Zugriffsanforderungen

Zusätzlich zu den sieben Zugriffstypen können Sie auch Obergrenzen für die zugewiesene Arbeitsspeicherkapazität und die Anzahl der Fenster einrichten.

Herunterfahren des Systems

Wenn diese Option aktiviert ist, kann die ausgewählte Anwendung keine Anforderungen zum Herunterfahren des Systems ausführen.

Systemzugriff niedriger Ebene

Wenn diese Option aktiviert ist, werden bestimmte ungewöhnlichere Anforderungen der ausgewählten Anwendung unterbunden.

Die folgenden Funktionen werden jedes Mal blockiert, wenn ein Systemzugriff niedriger Ebene verhindert wird:

  • AdjustTokenPrivileges
  • SetFileSecurity
  • SetKernelObjectSecurity
  • SetServiceObjectSecurity
  • SetSecurityInfo
  • SetNamedSecurityInfo
  • SetUserObjectSecurity
  • CreateProcessAsUser
  • CreateProcessWithLogonW
  • SHCreateProcessAsUserW

Die folgenden Systemfunktionen werden blockiert, wenn ein Systemzugriff niedriger Ebene verhindert wird und die Funktion in einem anderen Prozess als dem aufrufenden Prozess ablaufen soll

  • WriteProcessMemory
  • CreateRemoteThread
  • VirtualAllocEx
  • VirtualProtectEx

Gefährlicher Gerätezugriff

Wenn diese Option auf Verhindern gesetzt ist, werden bestimmte Zugriffsanforderungen wie beispielsweise das Formatieren der Festplatte durch die ausgewählte Anwendung unterbunden.

Folgende Gerätezugriffe werden blockiert:

  • Trennen eines Laufwerks
  • Sperren eines Laufwerks
  • Einstellen der Komprimierung
  • Aufheben der Laufwerksperre
  • Ausgabe der Wechselfestplatte
  • Formatieren der Festplattenspuren
  • Laden der Wechselfestplatte
  • Entfernen der Wechselfestplatte
  • Neuzuweisung von Festplattenblöcken
  • Festlegen des Plattenlaufwerklayouts
  • Festlegen der Partitionsinformationen für die Festplatte
  • Überprüfen der Festplatte
  • Serial lsrmst-Insert

Simulieren von Tastenanschlägen

Diese Option kann verhindern, dass eine Anwendung Tastenanschläge simuliert und dadurch auf dem Computer Schaden anrichtet.

Zugriff auf Druckeranschluss (LPT1)

Diese Option kann den Zugriff einer Anwendung auf den Druckeranschluss verhindern. Allerdings steht sie in Windows 9x nicht zur Verfügung.

Zugriff auf seriellen Anschluss (COM1 & 2)

Diese Option kann den Zugriff einer Anwendung auf den seriellen Anschluss verhindern. Allerdings steht sie in Windows 9x nicht zur Verfügung.

Speicher begrenzen

Mit diesem numerischen Wert können Sie die Speicherkapazität begrenzen, die die ausgewählte Anwendung für sich belegen kann. Der hier eingegebene Wert steht für die Anzahl der Bytes, die die betreffende Anwendung für sich belegen kann, bevor Secure4U weitere Anforderungen für Speicherbelegungen durch diese Anwendung zurückweist

Die Beschränkung der Speicherkapazität, die eine Anwendung belegen kann, kann einen Schutz gegen verschiedene Netzdienst-Sabotagen darstellen.

Fensterzahl begrenzen

Mit dieser Sicherheitsoption können Sie die Anzahl der Fenster begrenzen, die die ausgewählte Anwendung öffnen kann. Der eingegebene Wert steht für die Anzahl der Fenster oder Steuerelemente (Controls), die die Anwendung öffnen kann, bevor Secure4U weitere Anforderungen zum Öffnen von neuen Fenstern durch diese Anwendung zurückweist.

Die Begrenzung der Fensterzahl, die eine Anwendung öffnen kann, kann einen Schutz gegen verschiedene Netzdienst-Sabotagen darstellen.

Aktivieren von Änderungen / Einstellungen

Speicher- und Fensterlimitierungen werden nach dem Neustart der betreffenden Anwendung wirksam.

Hinweis! Damit die neuen Einstellungen wirksam werden, müssen Sie auf Einstellen klicken.


Dateisicherheit

Mit dieser Secure4U Konfigurationskomponente können Sie die Zugriffsrechte aller beschränkten und unbekannten Anwendungen für das Dateisystem auflisten und einrichten . Unter Windows 9x können Sie Dateisicherheitsmechanismen durchsetzen, die zur Dateizugriffssicherheit in Windows NT/2000 kompatibel sind.

Wenn Sie die Dateikonfigurationskomponente konfigurieren möchten, klicken Sie im linken Fensterausschnitt auf Dateisicherheit. Die lokalen Dateien auf der Workstation werden im mittleren Fensterausschnitt angezeigt:

Hinweis! Wenn Sie alle Dateien auf den Laufwerken bzw. in den Ordnern anzeigen möchten, klicken Sie mit der rechten Maustaste auf die Komponente Laufwerke im mittleren Fensterausschnitt. Wählen Sie im Kontextmenü dann Dateibeschränkungen anzeigen.

Hinweis! Wenn Sie die Zugriffsrechte für einen bestimmten Computer ändern, wirkt sich dies auch auf die verborgenen freigegebenen Pfade aus, die nicht angezeigt werden.

Einstellen der Dateizugriffsrechte

Secure4U enthält vorkonfigurierte Standardeinstellungen für eine Reihe von Anwendungen. Diese Standardeinstellungen werden immer dann verwendet, wenn keine angepassten Zugriffsrechte vorhanden sind. Wenn Sie die Zugriffsrechte für eine Anwendung oder eine Anwendungsgruppe ändern möchten, führen Sie die nachfolgend aufgeführten Schritte durch :

Wählen Sie im Konfigurationsabzweig Lokal des Konfigurationskomponentenbaumes die Komponente Dateien.

Das Secure4U Administrationstool zeigt den Verzeichnisbaum im mittleren Fensterausschnitt an. Wenn Sie für die ausgewählte Anwendungsgruppe ein Verzeichnis oder eine Datei auswählen, werden ihre Zugriffsrechtbeschränkungen für dieses Verzeichnis bzw. diese Datei im rechten Fensterausschnitt angezeigt.

Dieser Vorgang läuft ähnlich wie die Dateikonfiguration ab.

Die Elemente im rechten Fensterausschnitt entsprechen weitgehend den Elementen, die oben im Kapitel „Einstellungen für den rechten Fensterausschnitt“ beschrieben wurden.

Windows Sicherheits-Flags

Die konfigurierten Attribute sind folgenden Sicherheits-Flags von Windows NT zugeordnet:

  • Volle Kontrolle = alle nachfolgend aufgeführten Zugriffe
  • Lesen – Zeigt die Daten, Attribute, den Eigentümer sowie die Zugriffsrechte für die Datei an.
  • Schreiben – Berechtigung zum Schreiben in die Datei, zum Anhängen von Daten an die Datei sowie zum Lesen oder Ändern ihrer Attribute.
  • Ausführen – Ausführen einer Anwendung oder Auflisten des Verzeichnisinhalts.
  • Daten aus Datei lesen.
  • Daten in Datei schreiben.
  • Löschen – Versuchtes Löschen.
  • Daten anhängen – an eine Datei bzw. Hinzufügen einer Datei zu einem Verzeichnis.
  • Erweiterte Attribute lesen.
  • Erweiterte Attribute schreiben.
  • Dateiausführung.
  • Untergeordnetes Objekt entfernen.
  • Attribute für Lesezugriff.
  • Lesesteuerung – Versuchtes Lesen von Sicherheitsinformationen.
  • Schreiben in DAC – Versuchtes Ändern der DAC- (Discretionary Access Control-)Liste.
  • Eigentümer ändern – Ändern des Objekteigentümers.
  • Synchronisieren – Verwendung von Synchronisierungsfunktionen für das betreffende Objekt gestatten.


Registry-Sicherheit

Mit dieser Secure4U Konfigurationskomponente können Sie die Zugriffsrechte aller Anwendungen für die Registry-Datenbank auflisten und einrichten . Unter Microsoft Windows 9x können Sie Sicherheitseinstellungen für die Registry durchsetzen, die zur Zugriffssicherheit für die Registry unter Microsoft Windows NT/2000 kompatibel sind.

Wenn Sie die Sicherheitskomponente für die Registry konfigurieren möchten, klicken Sie im linken Fensterausschnitt auf Registry-Sicherheit. Die Registry auf der Workstation wird im mittleren Fensterausschnitt angezeigt:

Hinweis! Wenn Sie alle Werte in der Registry anzeigen möchten, klicken Sie mit der rechten Maustaste auf die Komponente Registry im mittleren Fensterausschnitt. Aktivieren Sie dann Wertebeschränkungen anzeigen im Kontextmenü.

Einstellen der zugriffsrechte für die Registry

Die Optionen für die Secure4U Registry-Sicherheit entsprechen weitgehend denjenigen für die Dateisicherheit und werden auf dieselbe Weise eingestellt. Secure4U enthält vorkonfigurierte Standardeinstellungen für eine Reihe von Anwendungen. Diese Standardeinstellungen werden immer dann verwendet, wenn keine angepassten Zugriffsrechte vorhanden sind. Wenn Sie die Zugriffsrechte einer Anwendung für die Registry ändern möchten, führen Sie die nachfolgend aufgeführten Schritte durch :

Wählen Sie im Konfigurationsabzweig Lokal des Konfigurationskomponentenbaumes die Komponente Registry.

Das Secure4U Administrationstool zeigt den Verzeichnisbaum im mittleren Fensterausschnitt an. Wenn Sie einen Registry-Schlüssel oder -Wert auswählen, werden die Zugriffsrechtbeschränkungen für die betreffende Anwendungsgruppe angezeigt.

Die Konfiguration entspricht weitgehend der Dateikonfiguration.


Firewall

Secure4U SU Professional weist zwei Komponenten für eine persönliche Firewall auf. Dadurch können Sie die Zugriffsrechte einer bestimmten Anwendung für IP-Ports und IP-Adressen einstellen.

  • IP-Ports

  • IP-Adressen


IP-Ports

Die Secure4U Standardzugriffsrechte für beschränkte Anwendungen sind darauf ausgerichtet, jeglichen Zugriff auf IP-Ports zu unterbinden. Die Zugriffsrechte für IP-Ports , die im Secure4U Administrationstool nicht angezeigt werden, werden vom Root-Eintrag IP Port übernommen (Standard: Zugriffe werden verhindert). Wenn Sie die Einstellung für eine oder mehrere beschränkte Anwendungen ändern möchten, führen Sie die nachfolgend aufgeführten Schritte aus:

Wählen Sie IP-Ports im mittleren Fensterausschnitt. Wenn Sie auf IP-Ports doppelklicken, wird die Anzahl der vorkonfigurierten Ports angezeigt. Die Zugriffsbeschränkungen für die ausgewählte

Über folgende Optionsfelder können Sie die Zugriffsoptionen einstellen, die eine bestimmte Anwendungsgruppe für IP-Ports haben soll:

· Freier, unbegrenzter Zugriff

Mit dieser Option gestattet Secure4U der ausgewählten Anwendung unbeschränkten Zugriff auf die IP-Ports. Secure4U leitet alle Anforderungen dieser Anwendung automatisch weiter, ohne eine Meldung anzuzeigen.

· Nur abgehend

Die Anwendung kann zwar die Verbindung zum IP-Port auf einem Remote-Computer aufbauen, aber nicht als Server fungieren, der die IP-Ports dem Netzwerk zur Verfügung stellt.

· Kein Zugriff

Wenn dieses Optionsfeld aktiviert ist, blockiert und überwacht Secure4U automatisch alle Zugriffsanforderungen der ausgewählten Anwendung(en) auf Ports.

· Benutzerdefinierter Zugriff

Die Einstellungen für die Registerkarten Zugriff, Überwachen und Interaktiv wurden bereits im Kapitel „Dateisicherheit“ beschrieben. Abgehend ist die Sicherheit beim Verbindungsaufbau mit einem Port auf einem anderen Rechner. Die Eingehende Sicherheit ermöglicht anderen Computern den Verbindungsaufbau mit einem Port, der durch die betreffende Anwendung bereitgestellt wird.

Audit-Ebene:

Sie können die Audit-Ebene für jeden Port angeben. Weitere Informationen dazu finden Sie im Kapitel „Die Menüs“ unter „Audit“.

Aktivieren von Änderungen / Einstellungen

Alle Änderungen an den Zugriffsbeschränkungen für die IP-Ports werden nach einer Änderung sofort wirksam.

Hinweis! Damit die neuen Einstellungen wirksam werden, müssen Sie auf Einstellen klicken.

Erstellen eines neuen Eintrags für einen IP-Port

Sie können in Secure4U spezielle Zugriffsbeschränkungen für einen IP-Port oder einen Bereich von IP-Ports erstellen, der nicht im aktuellen Port-Komponentenbaum enthalten ist. Wenn Sie einen Eintrag für eine bestimmte Portnummer hinzufügen möchten, klicken Sie mit der rechten Maustaste auf den Root-Komponenteneintrag IP-Ports im Baumfensterausschnitt.

Das jetzt angezeigte Kontextmenü enthält zwei Optionen: Einzelnen Port hinzufügen und Mehrere Ports hinzufügen. Wählen Sie eine Option aus dem Kontextmenü. Auf dem Bildschirm erscheint ein Dialogfeld, in dem Sie die Portnummer für den neuen Port bzw. Bereich von Ports angeben können.

Klicken Sie auf die Schaltfläche Neu, um Ihre Einstellungen zu bestätigen. Der neue Port bzw. Bereich von Ports wird dem Baum hinzugefügt.

Sie können jetzt die Zugriffsrechte jeder der beschränkten Anwendungsgruppen für diesen IP-Port einrichten.

Entfernen eines Eintrags für einen IP-Port

Sie können einen IP-Port oder einen Bereich von IP-Ports auch entfernen. Wenn Sie mit der rechten Maustaste auf den ausgewählten Port klicken, erscheint ein Kontextmenü mit der Option Explizite Beschränkungen entfernen. Wenn Sie diese Option wählen, entfernen Sie den IP-Port.


IP-Adressen

Wenn Sie die Zugriffsrechte eines Benutzers für bestimmte IP-Adressen beschränken möchten, können Sie in Secure4U IP-Adressbereiche einrichten.

Wenn Sie die Einstellung für eine oder mehrere beschränkte Anwendungen ändern möchten, führen Sie die nachfolgend aufgeführten Schritte aus:

Wählen Sie die Komponente IP-Adressen im mittleren Fensterausschnitt. Die Zugriffsbeschränkungen für die ausgewählte Anwendungsgruppe werden im rechten Fensterausschnitt angezeigt.

Wenn Sie mit der rechten Maustaste auf die Komponente IP Addresses klicken, wird ein Kontextmenü mit folgenden zwei Optionen angezeigt: Adressbereich hinzufügen und Alle Bereiche entfernen.

Adressbereich hinzufügen

Sie können jetzt den entsprechenden IP-Bereich hinzufügen oder Hostname wählen, so dass Secure4U die entsprechende IP-Adresse aus dem Internet abruft. (Dies ist selbstverständlich nur möglich, wenn die Workstation bereits über einen Internet-Zugang verfügt).

Sie können eine der folgenden Zugriffsrechtoptionen einstellen, die die ausgewählte Anwendungsgruppe für den angegebenen IP-Adressbereich haben soll: Jeglichen Zugriff zulassen, Zugriff überwachen, Benutzer vor Zugriff fragen und Jeglichen Zugriff unterbinden. Diese Befehle entsprechen weitgehend den Befehlen, die oben unter Verschiedenes beschrieben wurden.

Sie können die Audit-Ebene festlegen; weitere Informationen dazu finden Sie im Kapitel „Die Menüs“ unter „Audit“.

Alle Bereiche entfernen

Derzeit können Sie nur alle IP-Bereiche auf einmal entfernen.

Hinweis! Alle Änderungen an dieser Secure4U Konfigurationskomponente werden sofort aktiv.


Virenprüfung

Secure4U enthält Schutzmechanismen gegen schädlichen mobilen Code bzw. „moderne Viren“. Hierbei handelt es sich eigentlich um Anwendungen wie z. B. „Love Letter“ und „Back Orifice“, die sogar noch mehr Schaden anrichten können als Viren im herkömmlichen Sinn. Secure4U steuert die Zugriffsrechte einer bestimmten Anwendung. Somit wird ein Virus, der Dateien „innerhalb“ der Anwendung infiziert (z. B. Viren, die ausschließlich Word-Dateien „innerhalb“ der Word-Anwendung befallen) mit Secure4U nicht bekämpft. Daher sollten Sie zusammen mit Secure4U in jedem Fall einen Virenscanner einsetzen. Bei ordnungsgemäßer Konfiguration kommuniziert Secure4U mit dem Virenscanner auf Ihrer Workstation über Befehlszeilenparameter. Um diese Konstellation einzurichten, klicken Sie im linken Fensterausschnitt auf das Symbol Virenprüfung.

Suchen von installierten Virenscannern

Das Secure4U Administrationstool durchsucht bei der Installation das ganze Dateisystem nach ggf. installierten Virenscannern , die zusammen mit Secure4U verwendet werden können.

Auswählen eines Virenscanners

Die Liste enthält alle Virenscanner, die für Secure4U vorkonfiguriert sind.

Secure4U unterstützt die gängigsten marktüblichen Virenscanner. Eine Liste der Virenscanner, die Secure4U für die automatische Virenprüfung von eingegangenen Dokumenten, Komponenten und Archiven verwenden kann, steht im Support-Bereich der Secure4U Website unter der Adresse http://www.Secure4U.com/Support/ zur Verfügung.

Zusätzlich können wie nachfolgend beschrieben vom Benutzer angegebene, gängige Virenscanner mit Befehlszeilenparametern verwendet werden.

Hinweis! Sie müssen mit Secure4U nicht unbedingt einen Virenscanner einsetzen. Beide Produkte sind auch unabhängig voneinander ablauffähig.

Wenn ein Virenscanner, für den Secure4U vorkonfiguriert ist, nicht auf Ihren Festplatten vorhanden ist, so ist er in der Liste der verfügbaren Virenscanner abgeblendet.

Wenn Sie mit der rechten Maustaste auf einen der aufgeführten Virenscanner klicken, zeigt Secure4U das folgende Kontextmenü an:

N euen Viren-Checker hinzufügen

A usgewählte Konfiguration entfernen

Eigenschaften

T estlauf

Konfigurieren eines Virenscanners

Wenn Sie im Kontextmenü den Befehl Eigenschaften wählen.

In dem Dialogfeld können Sie die Parameter überprüfen, die Secure4U zum Aufrufen des betreffenden Virenscanners verwendet.

Erstellen eines benutzerdefinierten Virenscanners

Wenn Secure4U Ihren Virenscanner mit anderen Parametern aufrufen soll oder Sie einen neuen Virenscanner hinzufügen möchten, so wählen Sie im Kontextmenü den Befehl Neuen Viren-Checker hinzufügen.

HINWEIS! Für eine individuelle Konfiguration in Secure4U kommen nur Virenscanner in Frage, die mit Befehlszeilenparametern gesteuert werden können. Darüber hinaus muss der Virenscanner einen Rückgabewert liefern, der Secure4U den Status der überprüfte(n) Datei(en) mitteilt.

Im den Dialogfeld können Sie die Parameter für Ihren Virenscanner hinzufügen. Bei Fragen zu den Parametern, die von Ihrem Virenscanner verwendet werden, wenden Sie sich bitte an den Entwickler bzw. den Händler, bei dem Sie das Programm erworben haben.

Aktivieren von Änderungen / Einstellungen

Die Änderungen werden sofort aktiviert.


Lernmodus

Im Lernmodus werden Sicherheitsgruppen für neue Anwendungen erstellt. Sobald Sie den Lernmodus starten, verfolgt er alle Anforderungen und Anfragen aus der Registry, aus Dateien, von Ports, usw.

Wenn Sie mit dem Lernmodus arbeiten möchten, müssen Sie zunächst den Namen der Anwendungsgruppe angeben, die erstellt werden soll. Daraufhin können Sie die Gruppe auswählen und den Lernmodus starten.

Im Lernmodus sollten Sie alle Aktionen durchführen, die Sie zukünftig mit der Anwendung durchzuführen beabsichtigen. Wenn Sie den Lernmodus beenden möchten, klicken Sie auf die Schaltfläche Stopp.

Nach der Beendigung des Lernmodus müssen Sie angeben, ob Sie eine neue Gruppe erstellen möchten. Sobald Sie die benötigte Gruppe erstellt haben, sollten Sie die Einstellungen für die Gruppe überprüfen. Je länger Sie sich mit dem Lernmodus beschäftigen und sich Zeit zum Kennenlernen von Secure4U nehmen, desto effektiver und effizienter können Sie später damit arbeiten.

Hinweis! Derzeit werden die Zugriffe auf eine Einzeldatei aufgezeichnet. Die Schreibberechtigung für ein Verzeichnis legen Sie daher besser nach der Beendigung des Lernmodus im Bereich Dateisicherheit des Administrationstools fest.

Hinweis! Im Unterverzeichnis „Learning Mode“ des Secure4U Installationsverzeichnisses wird eine Datei in einem speziellen Textformat erstellt.


Inhalt filtern

Wenn Sie auf die Leiste Content filtern im linken Fensterausschnitt des Administrationstools klicken, werden die Tools für die Cache- und Cookie-Konfiguration angezeigt. Im Administrationsfenster Cache & Cookies auf der linken Seite werden sieben Administrationsgruppen angezeigt.
  • Cache-Konfiguration
  • Cache-Editor
  • Cookie-Konfiguration
  • Cookie-Editor
  • Eingegebene URLs
  • WWW-Inhalt filtern
  • E-Mail filtern


Cache-Konfiguration

Der Secure4U Konfigurations-Manager ermöglicht das automatische Löschen von Sitzungsdaten aus der Cache-Datei des Browsers. Wenn Sie Cache-Daten für einen bestimmten oder alle URLs speichern möchten, verwenden Sie den Fensterausschnitt Cache-Konfiguration. Secure4U zeigt das folgende Fenster an, wenn Sie die Komponente Cache-Konfiguration im Konfigurationsbaum wählen:

Im Fensterausschnitt Cache-Konfiguration können Sie die URL(s) hinzufügen, die beim Beenden von Secure4U nicht gelöscht werden sollte(n) (z. B. www.Secure4U.com wie in obiger Abbildung). Wenn Sie Cache nicht löschen aktivieren, verhindern Sie jegliches Löschen von Cache-Dateien.


Cache-Editor

Wenn Sie nicht nur mit einem Webbrowser arbeiten, können Sie angeben, welcher der Webbrowser zur Anzeige des Cache-Inhalts im Cache-Editor verwendet werden soll, und den lokalen Benutzer dieses Webbrowsers. Wählen Sie Browser und Benutzer aus den Dropdown-Listenfeldern aus.

Im unteren Bereich des Fensters wird der Inhalt des Caches in vier Spalten angezeigt :

  • Name der lokalen Datei

  • Ausgangs-URL

  • Letzter Zugriff

  • Dateigröße

Wenn Sie mit der rechten Maustaste auf eine im Cache gespeicherte Datei klicken, wird ein Kontextmenü mit drei Befehlen angezeigt:

  • Ausführen

  • Ausgewählte Einträge entfernen

  • Alle Listeneinträge entfernen

  • Eigenschaften

Ausführen

Hiermit können Sie die Datei anzeigen.

Ausgewählte Einträge entfernen

Hiermit löschen Sie den Eintrag bzw. die Einträge permanent (Sie können den Vorgang nicht rückgängig machen).

Alle Listeneinträge entfernen

Hiermit löschen Sie alle aufgelisteten Einträge permanent (Rückgängig machen nicht möglich).

Eigenschaften

Hiermit öffnen Sie ein Dialogfeld mit den Eigenschaften der im Cache gespeicherten Datei.

Filter anzeigen

Wenn Sie die Option Filter anzeigen aktivieren, wird das Filterverzeichnis in einem neuen Fensterausschnitt links im Fenster angezeigt. Bei der Wahl des Filterordners werden eine Reihe von Dateiordnern aufgelistet:

  • Text
  • Anwendung
  • Audio
  • Image
  • Video
  • Message

Jeder geöffnete Ordner enthält eine Reihe von } Dateierweiterungen. Wenn Sie auf eine der Dateierweiterungen klicken, wird im mittleren Fensterausschnitt ausschließlich die Cache-Datei mit Bezug zu dieser Erweiterung angezeigt.

Aktivieren von Änderungen / Einstellungen

Die Regeln zum Löschen der Cache-Datei werden aktiviert, und die Cache-Dateien werden am Ende der Anmeldeprozedur gelöscht.


Cookie-Konfiguration

Beim Versuch einer Cookie-Installation auf Ihrem Computer überprüft der Secure4U Cookie-Manager anhand seiner Cookie-Liste, ob der absendende URL/die absendende Site registriert ist. Abhängig von der gewählten Einstellung führt der Cookie-Manager die Aktion durch, die für diese Site angegeben wurde. Zusätzlich ermöglicht der Secure4U Cookie-Manager das automatische Löschen aller Cookies nach jeder Beendigung von Secure4U . Im Fensterausschnitt Cookie-Konfiguration können Sie angeben, dass Sie ein Cookie von einem bestimmten Ausgangs-URL oder von allen Ausgangs-URLs speichern möchten.

Der Fensterausschnitt Cookie-Konfiguration entspricht weitgehend dem Fensterausschnitt Cache-Konfiguration. Sie können den oder die URLs hinzufügen, für die Secure4U eine bestimmte Aktion ausführen soll, wenn ein Cookie von der Site heruntergeladen wird. Wenn Sie mit der rechten Maustaste auf einen URL-Eintrag im unteren Bereich des Fensters klicken, wird ein Kontextmenü mit folgenden Befehlen angezeigt:

  • Löschen
    Entfernt den URL aus der Liste.

  • Nie
    Alle von diesem URL/dieser Site empfangenen Cookies werden automatisch blockiert. Cookies von diesem URL/dieser Site sind nicht zulässig.

  • Immer
    Alle von diesem URL/dieser Site empfangenen Cookies werden automatisch auf Ihrem Computer gespeichert.

Sie können die von Secure4U durchgeführte Aktion im Aktivitätsfenster anzeigen.

Wenn Sie das Optionsfeld Alle Cookies nach der Sitzung entfernen aktivieren, werden bei der Beendigung von Secure4U alle Cookies gelöscht.

Wenn Sie das Optionsfeld Permanent zu diesem Objekt zuordnen aktivieren, werden alle Cookies akzeptiert, ausgenommen die mit Nie markierten Cookies.


Cookie-Editor

Wenn Sie nicht nur mit einem Webbrowser arbeiten, können Sie angeben, welcher der Webbrowser zur Anzeige der gespeicherten Cookies im Cache-Editor verwendet werden soll, und den lokalen Benutzer dieses Webbrowsers. Wählen Sie Browser und Benutzer aus den Dropdown-Listenfeldern aus.

Im unteren Bereich des Fenster werden die Cookies in vier Spalten angezeigt:

  • Cookie-Name

  • URL

  • Letzter Zugriff

  • Cookie-Wert

Wenn Sie mit der rechten Maustaste auf ein Cookie klicken, wird ein Kontextmenü mit drei Befehlen angezeigt:

  • Ausgewählte Einträge entfernen

  • Alle Listeneinträge entfernen

  • Eigenschaften

Ausgewählte Einträge entfernen

Hiermit löschen Sie den Eintrag bzw. die Einträge permanent (Sie können den Vorgang nicht rückgängig machen).

Alle Listeneinträge entfernen

Hiermit löschen Sie alle aufgelisteten Einträge permanent (Rückgängig machen nicht möglich).

Eigenschaften

Hiermit öffnen Sie ein Dialogfeld mit den Eigenschaften der Cookie-Datei. Das Dialogfeld entspricht weitgehend demjenigen für die Eigenschaften von Cache-Dateien.

Selbstlernmodus

Der URL-Erkennungsmechanismus benötigt die exakte Adresse, um ein Cookie von einer bestimmten Site ordnungsgemäß zu blockieren.

Allerdings verwenden viele Sites im Internet beim Platzieren von Cookies als URL nicht die tatsächliche Adresse ihrer Homepage. Daher zeigt Secure4U als eine Art Selbstlernmodus das Alarmfenster an, wenn eine unbekannte Site ein Cookie auf Ihrem Computer platzieren möchte.

Wenn Sie Permanent zu diesem Objekt zuordnen aktivieren, wird das Cookie der Liste des Cookie-Managers hinzugefügt.

Andernfalls werden die Einstellungen ausschließlich für das aktuelle Cookie verwendet. Die Aktivierung von Permanent zu diesem Objekt zuordnen ist nicht empfehlenswert, wenn auf einer Site Kennwörter oder Benutzernamen im Cookie gespeichert werden.

Wenn Secure4U das Platzieren eines Cookies blockiert oder die Erstellung eines Cookies automatisch bzw. durch den Benutzer zugelassen wird, werden Sie im Secure4U Aktivitätsfenster über jede dieser Aktionen informiert.

Alle derzeit auf Ihrem Computer vorhandenen Cookies werden im unteren Bereich des Aktivitätsfensters angezeigt.

Wenn Sie mit der rechten Maustaste auf einen Eintrag in der Liste klicken, können Sie ein Cookie entfernen oder seine Eigenschaften anzeigen.

Entfernen vorhandener Cookies

Sie können Cookies entweder wie oben beschrieben im Cookie-Manager des Administrationstools oder im Aktivitätsfenster entfernen. Wenn Sie ein vorhandenes Cookie im Aktivitätsfenster von Ihrem Computer entfernen möchten, klicken Sie mit der rechten Maustaste auf den betreffenden Eintrag und wählen im Kontextmenü den Befehl Entfernen. Das Cookie wird physisch gelöscht (Rückgängig machen nicht möglich). Weitere Informationen dazu finden Sie im Kapitel Secure4U Aktivitätsfenster in diesem Benutzerhandbuch.

Aktivieren von Änderungen / Einstellungen

Alle Änderungen an dieser Secure4U Konfigurationskomponente werden sofort aktiv.


Eingegebene URLs

Der Eintrag Eingegebene URLs wird weitgehend wie Cache-Inhalt und Cookies gehandhabt.

Wenn Sie mit der rechten Maustaste auf eine im Cache gespeicherte Datei klicken, wird ein Kontextmenü mit drei Befehlen angezeigt:

  • Ausgewählte Einträge entfernen

  • Alle Listeneinträge entfernen

Ausgewählte Einträge entfernen

Dieser Befehl löscht den von Ihnen gewählten eingegebenen URL.

Alle Listeneinträge entfernen

Hiermit löschen Sie alle aufgelisteten Einträge permanent (Rückgängig machen nicht möglich).

Aktivieren von Änderungen / Einstellungen

Alle Änderungen werden sofort wirksam.


WWW-Inhalt filtern

Die Menge an unnötigen und anstößigen Informationen, die inzwischen im Internet unterwegs ist, machte eine Funktion zum Filtern von WWW-Content erforderlich, um eine Selektion der (nicht) aus dem Web empfangenen Informationen zu ermöglichen.

Mit diesem Dienst können Webseiten mit bestimmten Wörtern, Themen oder Thesen zensiert werden. Vielleicht möchten Sie z. B. verhindern, dass einer Ihrer Mitarbeiter unerlaubterweise eine Webseite mit Begriffen wie „Sex“ oder „Spiele“ aufruft. In diesem Fall können Sie diese Wörter auf eine Liste setzen, nach der WWW-Content gefiltert wird. Wenn dann ein Mitarbeiter versucht, Websites aufzurufen, von der neue Spiele heruntergeladen oder anstößige Inhalte angezeigt werden können, wird der Zugriff auf diese Website unterbunden.


E-Mail filtern

Das Filtern von E-Mails wird zur Steuerung des Zugriffs auf unerwünschte oder gefährliche Mailings verwendet. In diesem Modus können Sie die Wörter angeben, von denen eine potentielle Bedrohung ausgeht, z. B. „vertraulich“, „privat“, „Sex“, usw. E-Mail-Anhänge mit diesen Wörtern können nicht versandt werden.

Andererseits können Sie durch das Filtern der E-Mails erreichen, dass E-Mails mit vertraulichen Informationen ausschließlich an bestimmte Adressen versandt werden, die auf Ihrer „vertrauenswürdigen Liste“ aufgeführt sind. Diese Liste kann Mitarbeiter Ihres Unternehmens enthalten. Dies ermöglicht Ihnen das interne Versenden von Dokumenten mit geschäftskritischem Inhalt.

Beispiel: Wenn Sie E-Mails an Mitarbeiter Ihres Unternehmens senden möchten (JoeSmith@yourcompany.de und MaryJones@yourcompany.de), so geben Sie als Adresse @yourcompany.de ein. Die E-Mails werden so an die Mitarbeiter Ihres Unternehmens gesandt.