Neue Features in IEAK

Sie können den Assistenten für die Internet Explorer-Anpassung und den IEAK-Profil-Manager (beide im Lieferumfang von IEAK enthalten) verwenden, um Internet Explorer anzupassen, einzusetzen und zu verwalten. Weitere Informationen über den Inhalt von IEAK finden Sie unter Lieferumfang von IEAK

Dies sind einige der wesentlichen neuen Features von IEAK:

  • Anpassung und Verteilung der MSN Messenger Service-Clientsoftware Sie können in Ihr Paket den MSN Messenger Service-Client aufnehmen und diesen mit Branding-Informationen versehen, indem Sie den Namen und das Logo Ihrer Organisation verwenden. Das Setup-Programm für den angepassten Messenger Service-Client wird in eine eigene ausführbare Datei gepackt. Sie können dem Paket den angepassten Messenger Service-Client als Windows Update Setup-Komponente hinzufügen. Sie können auch das Setup-Programm für den Messenger Service-Client unabhängig vom Setup-Programm für Internet Explorer verteilen.
  • Festlegen des Installationszeitpunkts für angepasste Komponenten Sie können festlegen, ob eine angepasste Komponente installiert wird, bevor Internet Explorer installiert wird, oder aber, ob die angepasste Komponente erst dann installiert wird, wenn die Installation von Internet Explorer erfolgreich abgeschlossen wurde. Sie können auch festlegen, dass die Komponente erst nach dem Neustart des Systems installiert wird. Diese Ebene der Steuerung ermöglicht die problemlose Verteilung von Systemaktualisierungen, wenn Ihr Paket Systemaktualisierungen für eine oder mehrere angepasste Komponenten enthält. Weitere Informationen erhalten Sie unter Zusammenfassen von Microsoft-Updates in angepasste Komponenten.
  • Auswählen der zu konfigurierenden Richtlinien Alle Praktiken und Einschränkungen des Systems, die Sie im IEAK-Assistenten einstellen und anschließend mit Hilfe des IEAK-Profil-Managers verwalten können, können für Benutzer mit den Betriebssystemen Windows 95, Windows 98 und Windows Millennium Edition konfiguriert werden. Sie können jedoch nur eine Teilmenge dieser Praktiken und Einschränkungen des Systems für Benutzer einrichten, die Windows NT bzw. Windows 2000 verwenden, wenn diese keine Administratorrechte haben. Sie können auf der Grundlage der Zielplattform und der Benutzerrechte für das jeweilige Paket in IEAK auswählen, welche Richtlinien angezeigt werden sollen. Weitere Informationen erhalten Sie unter Verwalten von Microsoft Internet Explorer unter Windows 2000.
  • Installation von Paketen, die Administratorrechte nach dem Neustart des Computers erfordern. Sie können Ihr Paket so anpassen, dass nach dem Neustart des Computers die Administratorrechte beibehalten werden. Dies ermöglicht, das Paket manuell oder als Bestandteil einer automatischen Verteilungsmethode, wie beispielsweise über SMS (Systems Management Server) an die Benutzer zu verteilen. In beiden Fällen ist es nicht erforderlich, dass die Benutzer, die sich nach der Installation an dem System anmelden, über Administratorrechte verfügen.
  • Entfernen der Verknüpfungen und Symbole für Outlook Express, für den Assistenten für den Internetzugang und für Channels. Sie können Outlook Express in Ihr Paket aufnehmen und die Installation so konfigurieren, dass auf dem Desktop des Benutzers, im Startmenü und auf der Schnellstartsymbolleiste keine Verknüpfungen zum Programm Outlook Express angezeigt werden. Sie können auf gleichermaßen auch Verknüpfungen mit Channels und dem Assistenten für den Internetzugang von der Schnellstartsymbolleiste des Benutzers entfernen.
  • Erstellen von Paketen für die 32-Bit-Windows-Plattform Diese IEAK-Version erzeugt nur angepasste Browserpakete für 32-Bit-Windows-Plattformen. Um angepasste Pakete für die 16-Bit-Windows- oder die UNIX-Plattform zu erstellen, müssen Sie das Internet Explorer Administration Kit, Version 5.0, verwenden.

Weitere Informationen über die Neuigkeiten in Internet Explorer 5.5 finden Sie in der Hilfe, die zusammen mit dem Produkt installiert wird.


Inhalt von Microsoft Internet Explorer Administration Kit

Microsoft Internet Explorer Administration Kit (IEAK) enthält Programme und Tools, mit denen Sie Internet Explorer anpassen und verwalten können.

Sie haben folgende Möglichkeiten:

  • Anpassen des Browsers und anderer Internetkomponenten an die Anforderungen Ihres Unternehmens oder der Benutzer. Beispielsweise können Sie die Linkleiste und die Favoritenliste so anpassen, dass sie auf Ihre Organisation verweisen oder nützliche Informationen liefern.
  • Konfigurieren der Einstellungen vor der Installation, damit Sie die Optionen nicht auf jedem Computer einzeln einstellen müssen.
  • Anpassen von Setup, damit weniger Eingriffe erforderlich sind und Ihre speziellen Programme installiert werden.
  • Falls Sie Firmenadministrator sind, können Sie steuern, welche Einstellungen Ihre Mitarbeiter ändern können. Auf diese Weise stellen Sie sicher, dass die Sicherheit, die Verbindung und andere wesentliche Einstellungen Ihren Firmenstandards entsprechen.

Vor der Verwendung von IEAK sollten Sie festlegen, welche Einstellungen Sie anpassen möchten, die benötigten Grafiken oder angepassten Dateien vorbereiten und die Distributionsmethode bestimmen. Darüber hinaus sollten Sie sich mit den Programmen und Tools in IEAK vertraut machen.

Weitere Informationen über neue Merkmale dieser Version von IEAK finden Sie unter Neue Features in IEAK

Tools in Internet Explorer Administration Kit

Assistent für die Internet Explorer-Anpassung

Der Anpassungsassistent bietet in fünf Stufen Schritt-für-Schritt-Anweisungen zum Erstellen angepasster Internet Explorer-Pakete.

Internet Explorer Administration Kit-Profil-Manager

Der Profil-Manager ermöglicht Ihnen die automatische Änderung der Einstellungen und Einschränkungen für die Benutzer, nachdem Internet Explorer bereits installiert ist. Weitere Informationen hierzu finden Sie unter Verwenden des IEAK-Profil-Managers.

IEAK-Toolkit

Das IEAK-Toolkit enthält nützliche Programme und Beispieldateien, wie den IExpress-Assistenten, Beispiele für Anmelde- und Addon-Dateien, grafische Vorlagen und andere Tools. Diese Objekte befinden sich im Ordner \Toolkit innerhalb der IEAK-Ordnerstruktur.

Hilfe zu Internet Explorer Administration Kit

Der Index, das Inhaltsverzeichnis und die Volltextsuche helfen Ihnen dabei, die gewünschten Themen zu finden. Vom Inhaltsverzeichnis können Sie ein "Buch" bzw. eine Zusammenstellung verwandter Themen ausdrucken.


Hardware- und Systemanforderungen

Anforderungen für Internet Explorer

Informationen zu Hardware- und Softwareanforderungen für eine bestimmte Internet Explorer-Version finden Sie in der Infodatei zu dieser Version.

Zusätzliche Hardwareanforderungen für die Erstellung angepasster Installationspakete

Bevor Sie den Assistenten für die Internet Explorer-Anpassung starten, überprüfen Sie die Menge des verfügbaren Speicherplatzes auf dem Ziellaufwerk (auf dem Sie Ihr angepasstes Paket erstellen). Das Ziellaufwerk kann ein Laufwerk desselben Computers sein, auf dem Sie den Anpassungsassistenten ausführen, dies ist jedoch keine Bedingung.

Kalkulieren Sie für die Erstellung von IEAK-Paketen folgende zusätzliche Systemanforderungen für Internet Explorer ein:

  • Je nach Anzahl der für das Installationspaket vorgesehenen Komponenten, die Sie downloaden, benötigen Sie bis zu 100 MB freien Speicherplatz.
  • Für jedes angepasste Paket, das Sie erstellen, kann sich der Speicherplatzbedarf um zusätzliche 100 MB erhöhen. Wenn Sie ein Paket für einen anderen Medientyp erstellen, beispielsweise eine CD-ROM, gilt dies als separates Paket.

Anforderungen für IEAK

Die IEAK-Pakete müssen auf einem Computer erstellt werden, auf dem Internet Explorer 5.5 installiert ist, und der unter einem beliebigen 32-Bit-Windows-Betriebssystem (mit Ausnahme von Windows NT 3.51) betrieben wird.

Auf Windows NT 4.0-Computern muss Service Pack 3 (oder höher) installiert sein.

Diese IEAK-Version erzeugt nur angepasste Browserpakete für 32-Bit-Windows-Plattformen. Um angepasste Pakete für die 16-Bit-Windows- oder die UNIX-Plattform zu erstellen, müssen Sie das Internet Explorer Administration Kit, Version 5, verwenden. Um angepasste Pakete für Macintosh zu erstellen, müssen Sie das Internet Explorer Administration Kit für Macintosh verwenden.

Sie können die IEAK-Versionen 5.0 und 5.5 auf demselben Rechner ausführen; installieren Sie einfach jedes Programm in ein eigenes Verzeichnis.

Anforderungen auf Seiten der Benutzer

Falls die Benutzer Windows NT oder Windows 2000 verwenden, müssen Sie, wenn die Benutzer nach der Installation oder Deinstallation von Internet Explorer aus Ihrem IEAK-Paket ihre Computer zum ersten Mal neu starten, Administrationsrechte für diesen Rechner besitzen.

Weitere Informationen über die Installation von Internet Explorer auf den Rechnern der Benutzer finden Sie unter Wechseln von anderen Versionen oder Produkten und Verwalten von Microsoft Internet Explorer unter Windows 2000.


Vertreiben von Internet Explorer

IEAK unterstützt Sie dabei, Internet Explorer im Rahmen des Installationsvorgangs für ein anderes Programm zu vertreiben. Als unabhängiger Softwareanbieter (Independent Software Vendor - ISV) können Sie beispielsweise die Installation von Internet Explorer so anpassen, dass anstelle von Internet Explorer Ihr angepasstes Programm dem Benutzer Installationsoptionen und Rückmeldungen liefert.

Für den Vertrieb von Internet Explorer können Sie mit Hilfe des Assistenten zur Internet Explorer-Anpassung ein IEAK-Paket erstellen. Wählen Sie in Schritt 1 des Assistenten für die Internet Explorer-Anpassung die Option Inhaltsanbieter (Content Provider)/Entwickler.

Sie können das Erscheinungsbild und die Funktionalität des Browsers und des Windows Update Setup-Programms anpassen, wenn Ihr Lizenzvertrag dies gestattet. Außerdem können Sie die Funktionen und die Anmutung des Windows Update Setup-Programms für den Benutzer mit folgenden Optionen anpassen:

  • Ausführen von Setup im Batchmodus
  • Parameter für die Ausführung von Internet Explorer-Setup im Batchmodus
  • Parameter für die Installation von IExpress im Batchmodus
  • Arbeiten mit Setup-Informationsdateien (.inf)


Übersicht für Internetinhaltsanbieter

Microsoft® Internet Explorer Administration Kit (IEAK) ermöglicht es Internetinhaltsanbietern (ICPs) und unabhängigen Softwarelieferanten (ISVs), einen angepassten Browser für Kunden zu erstellen, die bereits über Internetkonten verfügen.

Als Internetinhaltsanbieter können Sie auch einen angepassten Browser erstellen, wenn Sie planen, den Microsoft-Informationsserver in Ihr angepasstes Paket einzubeziehen. Dieser Informationsserver, der Informationen zu Internetdienstanbietern in Ihrer Region zur Verfügung stellt, wird von Microsoft betrieben. Über diesen Informationsserver können Sie eine Verbindung mit Anmeldeservern herstellen.

Sie können dieses Kit verwenden, um die folgenden Aufgaben zu erledigen:

Anpassen des Setup-Programms

  • Anpassen des Erscheinungsbildes des Windows Update Setup-Programms und Konfigurieren von Installationsmodi (z. B. Standardinstallation oder Minimale Installation).
  • Verweisen der Benutzer auf Internetserver, auf denen sie die aktuellsten Versionen von Produkten erhalten können.
  • Festlegen der Sprachversion von Internet Explorer, die im Installationspaket enthalten sein soll. Pro Sprachversion, die Sie erstellen möchten, müssen Sie den Assistenten für die Internet Explorer-Anpassung einmal ausführen.

Anpassen des Browsers und der Channels

  • Festlegen der Start-, Such- und Unterstützungsseiten.
  • Aufnehmen von Links und Ordnern in die Favoritenliste.
  • Ändern der Titelleiste und der Logos des Browsers.
  • Hinzufügen eines Channels oder einer Channelkategorie.

Verwenden des Internet Explorer-Logos

Gemäß den Bestimmungen des Lizenzvertrags müssen Sie das Internet Explorer-Logo auf Ihren Verpackungen und Werbematerialien sowie auf Ihrer Website verwenden. Besuchen Sie die IEAK-Website. Dort finden Sie Informationen zu Logos, kamerafertige Druckvorlagen und Beispiele.

Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.

Wichtig

  • In Abhängigkeit von Ihrem Lizenzvertrag stehen einige Features möglicherweise nicht zur Verfügung. Weitere Informationen finden Sie in Ihrem Vertrag.


ICP: Vorbereiten der Ausführung des Assistenten

Internet
inhaltsanbieter

Vorbereiten der Ausführung des Assistenten

Vor der Ausführung des Assistenten für die Internet Explorer-Anpassung sollten Sie die benötigten Informationen bereithalten und angepasste Bitmaps erstellen.

Ermitteln Sie die grundsätzlichen Plattformanforderungen

  • Stellen Sie sicher, dass der Computer, auf dem Sie Ihr Paket erstellen, sowie die Computer, auf denen Sie das Paket installieren, die Hardware- und Systemanforderungen erfüllen.
  • Legen Sie die Verschlüsselungsstufe für Ihre Browserpakete fest. Informationen zur Verschlüsselung von Internet Explorer finden Sie auf der IEAK-Website.

Entscheiden Sie sich für ein Distributionsverfahren

Entscheiden Sie, wie Sie Ihr angepasstes Paket verteilen möchten (CD, Download, LAN oder Disketten). Nachdem der Assistent für die Internet Explorer-Anpassung Ihr Paket erstellt hat, müssen Sie die Dateien auf das ausgewählte Medium verschieben. Wenn Sie ein downloadbares Paket erstellt haben, müssen Sie das Paket in das entsprechende Verzeichnis auf Ihrem Server verschieben.

Wenn Sie Ihr Browserpaket auf einem Internetserver bereitstellen möchten, müssen Sie den Pfad zum Server sowie den URL kennen, von dem die Dateien gedownloadet werden. Erstellen Sie dann einen Ordner auf dem Webserver, beispielsweise CIE, in den Sie alle Dateien und Ordner kopieren, die zu Ihrem angepassten Browser gehören. Sie können beispielsweise den Serverpfad C:\Inetpub\Wwwroot\Cie erstellen. Wenn Computername das virtuelle Stammverzeichnis für diesen Webserver ist, lautet der entsprechende URL http://Computername/Cie/.

Erwerben Sie ein digitales Zertifikat

Treffen Sie die grundlegenden Vorbereitungen für das Signieren bestimmter Dateien, beispielsweise der vom Assistenten für die Internet Explorer-Anpassung erstellten Anpassungsdateien sowie aller angepassten Komponenten, falls Sie die Dateien über das Internet bzw. über ein Intranet bereitstellen, das nicht speziell konfiguriert wurde. Durch die Sicherheitsfeatures des Browsers werden Benutzer davor gewarnt oder daran gehindert, nicht signierte Dateien zu downloaden. Digitale Signaturen identifizieren die Quelle von Programmen und garantieren, dass der Code seit dem Signieren nicht geändert wurde.

Der Assistent für die Internet Explorer-Anpassung kann Ihre Dateien signieren, falls Sie über ein Veröffentlichungszertifikat einer Zertifizierungsstelle verfügen. Um die Zertifikate für die Verwendung in IEAK vorzubereiten, können Sie diese mit dem Assistenten für Zertifikatimport auf Ihren Computer importieren. Falls Sie eine Datei mit der Erweiterung .spc erhalten haben, können Sie den Assistenten für den Zertifikatimport starten, indem Sie in Windows-Explorer oder Arbeitsplatz auf die .SPC-Datei klicken.

Die Zertifikatverwaltung kann außerdem von Internet Explorer aus geöffnet werden. Klicken Sie dazu auf das Menü Extras und dann auf Internetoptionen. Wählen Sie anschließend die Registerkarte Inhalt aus, und klicken Sie auf Zertifikate. Klicken Sie auf Importieren, um den Assistenten für Zertifikatimport zu starten, und folgen Sie dann den Schritten im Assistenten.

Erstellen Sie die Verzeichnisstruktur auf dem Computer, auf dem Sie das Paket erstellen

Ordnername | Beschreibung
\CIE | Übergeordnetes Stammverzeichnis für alle von IEAK erstellten und vom angepassten Paket verwendeten Dateien
\CIE\Bitmaps | Angepasste Bitmapdateien (für Ihren angepassten Browser benötigte Grafikdateien)

Erstellen Sie die gewünschten Grafiken

Sie haben die Möglichkeit, die folgenden Bitmaps in Ihrem Browser anzupassen. Speichern Sie die Bitmaps im Ordner \CIE\Bitmaps, bevor Sie den Assistenten für die Internet Explorer-Anpassung ausführen.

Der angepasste Hintergrund und die Schaltflächen werden nur auf Computern angezeigt, die 256 Farben (8-Bit) darstellen können. Auf Computern, die 16 Farben (4-Bit) darstellen können, werden eine Standardhintergrundbitmap und Schaltflächen mit geringer Auflösung angezeigt.

  • Eine Hintergrundbitmap für den automatischen CD-ROM-Begrüßungsbildschirm (wenn Sie ein CD-ROM-Paket erstellen).

    Wenn Sie planen, Ihren angepassten Browser auf einer CD zu vertreiben, müssen Sie Bitmaps als Teil des automatischen Begrüßungsbildschirms erstellen, der angezeigt wird, nachdem der Benutzer die CD in das CD-ROM-Laufwerk eingelegt hat. Wie Sie diese Bitmap erstellen, erfahren Sie unter Erstellen einer Bitmap für den automatischen Begrüßungsbildschirm.

  • Angepasste Grafiken für die CD-ROM-Schaltflächen (wenn Sie ein CD-ROM-Paket erstellen).
  • Zwei angepasste Bitmaps für den Assistenten für Windows Update Setup (falls Sie dessen Erscheinungsbild ändern möchten): Eine Bitmap im Format 162x312 Pixel für die linke Seite des ersten Bildschirms des Assistenten sowie eine Bitmap im Format 496x56 Pixel für den oberen Rand der übrigen Bildschirme des Assistenten.
  • Eine angepasste Symbolleistenbitmap (die als Hintergrund der Schaltflächen und Menüs angezeigt wird).
  • Zwei statische 256-Farben-Bitmapbilder (das eine im Format 38x38 Pixel, das andere im Format 22x22 Pixel), die Sie als eigenes Logo in den Internet Explorer-Browser einfügen können.
  • Zwei animierte 256-Farben-Bitmapbilder mit (das eine im Format 38x38 Pixel, das andere im Format 22x22 Pixel), die Sie als eigenes animiertes Logo in den Internet Explorer-Browser einfügen können.

    Zwei Tools sind in IEAK enthalten, die Sie beim Erstellen und Anzeigen angepasster, animierter Bitmaps für Ihren Browser unterstützen. Informationen zur Verwendung dieser Tools finden Sie unter Tools für animierte Bitmaps.

Ermitteln Sie die URLs für die Start-, Such- und Supportseiten

Es ist sinnvoll, eine Unterstützungsseite zu erstellen, die angezeigt wird, wenn Ihre Benutzer beim Installieren des Browsers auf Probleme stoßen. Wenn Sie den Assistenten zur Internet Explorer-Anpassung ausführen, werden Sie zur Eingabe der URLs dieser Seiten aufgefordert.

Anmerkungen

  • Weitere Informationen zum Setup finden Sie unter Windows Update Setup für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.


ICP: Schritt 1 des Assistenten: Informationen sammeln

Internet
inhaltsanbieter

Schritt 1 des Assistenten: Informationen sammeln

Im ersten Schritt des Assistenten für die Internet Explorer-Anpassung werden Inhaltsanbieter oder unabhängige Softwarelieferanten aufgefordert, folgende Informationen einzugeben:

  • Ihr Firmenname und Ihr zehnstelliger Anpassungscode. Der Anpassungscode befindet sich bei den weiteren Informationen zu Ihrem Administration Kit, die Sie von Microsoft erhalten haben.
  • Ihre Rolle entsprechend dem Lizenzvertrag. Sie müssen angeben, ob Sie Inhaltsanbieter oder Entwickler, Dienstanbieter oder Firmenadministrator sind.
  • Der Speicherort der Dateien, an dem das angepasste Browserpaket erstellt werden soll.
  • Die Sprache des Browserpakets, das Sie erstellen. Sie müssen den Assistenten für die Internet Explorer-Anpassung für jede internationale Version ausführen, die erstellt werden soll.
  • Die Distributionsmedien, die Sie einsetzen möchten, beispielsweise CD-ROM oder Download.
  • Die Features, die angepasst werden sollen. Beispielsweise müssen nicht alle Bildschirme des IEAK-Assistenten angezeigt werden, wenn Sie nur geringfügige Änderungen am Browser vornehmen möchten.

Anmerkung

  • Der Assistent für die Internet Explorer-Anpassung wird nur dann ordnungsgemäß ausgeführt, wenn Internet Explorer 5.5 installiert ist. Weitere Informationen hierzu finden Sie unter Hardware- und Systemanforderungen.


ICP: Schritt 2 des Assistenten: Angabe der Setup-Parameter

Internet-
inhaltsanbieter

Schritt 2 des Assistenten: Angabe der Setup-Parameter

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung werden Inhaltsanbieter aufgefordert, folgende Maßnahmen durchzuführen:

  • Downloaden oder Aktualisieren aller Microsoft-Komponenten mit Hilfe der Automatischen Versionssynchronisierung (AVS). Sie müssen Internet Explorer downloaden, aber Sie können selbst festlegen, welche anderen Komponenten von Internet Explorer gedownloadet werden sollen.
  • Auswählen aller angepassten Komponenten, die einbezogen werden sollen.

    Sie können bis zu zehn weitere Komponenten angeben. Bei diesen Komponenten handelt es sich um selbst extrahierende Dateien (.EXE) oder um komprimierte Kabinettdateien (.CAB).


ICP: Schritt 3 des Assistenten: Anpassen von Setup

Internet
inhaltsanbieter

Schritt 3 des Assistenten: Anpassen des Setup-Programms

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung können Inhaltsanbieter festlegen, wie das Windows Update Setup-Programm aussehen und arbeiten soll:

  • Anpassen des automatischen Begrüßungsbildschirms bei CD-ROMS, falls Sie ein CD-ROM-Paket erstellen.
  • Anpassen weiterer CD-Optionen, falls Sie ein CD-ROM-Paket erstellen.
  • Anpassen des Assistenten für Windows Update Setup für Internet Explorer und andere Internetprogramme. Diese Einstellungen beeinflussen den optischen Eindruck des Setup-Programms für den Benutzer.
  • Festlegen von bis zu zehn verschiedenen Installationsoptionen und Angeben der bei den unterschiedlichen Optionen jeweils einbezogenen Komponenten.
  • Festlegen von bis zu 10 Sites, von denen der Downloadvorgang für das Paket stattfinden soll.
  • Festlegen, wie Benutzer Aktualisierungen für ihre Komponenten erhalten.
  • Festlegen, ob das Setup-Programm vorhandene Komponenten erkennt, und Feinabstimmung, welche Komponenten von Benutzern angepasst werden können.
  • Festlegen, ob gedownloadete, jedoch nicht in alle Pakete eingefügte Komponenten den Benutzern über das Internet Explorer-Feature Installation bei Bedarf zur Verfügung gestellt werden.
  • Festlegen der Angaben zur Zertifizierungsstelle, falls Sie ein digitales Zertifikat besitzen, damit das Signieren der Programme während der Erstellung des IEAK-Pakets erfolgen kann.

Anmerkungen

  • Weitere Informationen zum Setup-Programm finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.
  • Ein Flussdiagramm zur Erläuterung der Prozesse bei der Verwendung des Assistenten für die Internet Explorer-Anpassung bei der Erstellung von angepassten Paketen erhalten Sie unter Erstellen angepasster Pakete mit IEAK.


ICP: Schritt 4 des Assistenten: Anpassung des Browsers

Internet-
inhaltsanbieter

Schritt 4 des Assistenten: Anpassung des Browsers

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung können Inhaltsanbieter Folgendes anpassen:

  • Die Titelleiste des Browsers und die Hintergrundbitmap der Symbolleiste. Wenn Sie eine Bitmap auswählen, stellen Sie sicher, dass bei den Farben genügend Kontrast gegenüber dem Text vorhanden ist.
  • Symbolleistenschaltflächen des Browsers. Sie können angepasste Symbolleistenschaltflächen hinzufügen, um Skripts und Programme auszuführen.
  • Das animierte Internet Explorer-Logo in der oberen rechten Ecke des Browsers.
  • Start-, Such- und Onlinesupportseiten des Browsers.
  • Favoriten, Favoritenordner und Links der Linkleiste.
  • Channels. Sie können einen Channel oder eine Channelkategorie, also einen Ordner mit Channels, hinzufügen.
  • "Willkommen"-Seite, die angezeigt wird, wenn die Benutzer ihren Browser zum ersten Mal starten.
  • Benutzeragententext. Eine Kennzeichnung für den Benutzeragent ist optional. Auf diese Weise kann die Verwendung Ihres angepassten Browsers verfolgt werden.

Anmerkungen

  • Weitere Informationen zum Setup-Programm finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.


ICP: Schritt 5 des Assistenten: Komponentenanpassung

Internet
inhaltsanbieter

Schritt 5 des Assistenten: Komponentenanpassung

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung können Inhaltsanbieter Folgendes anpassen:

  • Festlegen der Standardprogramme, wie z. B. die Standardprogramme für E-Mail und zur Bearbeitung von HTML-Dateien.
  • Branding-Informationen im MSN Messenger Service, wenn Ihr Paket eine angepasste Version Messenger Service-Clients beinhaltet.
  • Medienelemente für den MSN Messenger Service, wenn bei der angepassten Installation des Messenger Service-Clients Grafiken, Werbungen oder Soundelemente geändert werden sollen.
  • Konteninformationen für den MSN Messenger Service, wenn bei der angepassten Installation des Messenger Service-Clients die Passport-Standardkonten bzw. die Einstellungen für die Integrierung von E-Mail geändert werden sollen.
  • Systemrichtlinien und -Einstellungen zur Voreinstellung von Internetoptionen.


ICP: Verteilen Ihres Browserpakets

Internet
inhaltsanbieter

Verteilen Ihres Browserpakets

Standardmäßig erstellt der Assistent für die Internet Explorer-Anpassung Dateien, die die Benutzer aus dem Internet downloaden können. Sie können ein angepasstes Browserpaket jedoch auch auf einer CD verteilen. Eine vollständige Liste der möglichen Distributionsmedien erhalten Sie unter Auswahl der Medien.

Downloadbare Dateien

Wenn Sie das Browserpaket auf einem Internet- oder Intranetserver erstellen, müssen Sie Ihre Website so einrichten, dass Benutzer die Dateien downloaden können. Sie können beispielsweise eine Seite erstellen, auf der Sie Downloadinformationen sowie einen Link für das Installationsmodul IE5setup.exe hinterlegen.

Wenn Sie das Browserpaket auf Ihrer Festplatte oder einem Netzlaufwerk erstellt haben, müssen Sie die folgenden Objekte auf einen Internet- oder Intranetserver verschieben:

  • Den Ordner, der die Sprachversion und die Ordnerinhalte enthält, die Sie hinterlegen. Angenommen, der Ordner für die englische Version heißt En, dann müssen Sie den Ordner En sowie die Dateien, die er enthält, verschieben. Dieser Ordner befindet sich in den Ordnern für den gewählten Medientyp, wie z. B. Download, und die gewünschte Plattform. IEAK 5.5 unterstützt nur die Plattform "Win32". Zum Anpassen von UNIX- und 16-Bit-Windows-Clients müssen Sie IEAK 5.0x verwenden.
  • Die Datei namens Ie5sites.dat. Diese Datei zeigt auf die Downloadsite (oder die Sites), die Sie beim Ausführen des Assistenten für die Internet Explorer-Anpassung angegeben haben.

Eine Abbildung hierzu finden Sie unter Einrichten von Dateien für den Vertrieb.

Ein Flussdiagramm zur Erläuterung der durch den Assistenten für die Internet Explorer-Anpassung erstellten Dateien erhalten Sie unter Erstellen angepasster Pakete mit IEAK.

Signieren Ihrer angepassten Pakete

Webbrowser haben Sicherheitsfeatures, die verhindern, dass Benutzer schädliche Programme downloaden. Abhängig von der Sicherheitsstufe und der Plattform kann das Downloaden von Programmen verhindert oder eine Warnung ausgegeben werden, wenn diese Programme nicht digital signiert sind.

Die angepassten .CAB-Dateien, die vom Assistenten für die Internet Explorer-Anpassung erstellt wurden, sollten signiert werden. Dies erübrigt sich jedoch, wenn Sie die lokale Intranetzone mit der Sicherheitseinstellung Niedrig vorkonfigurieren. Alle angepassten Komponenten, die mit Ihrem Browserpaket für diese Plattformen verteilt werden, sollten ebenfalls signiert werden. Wenn Sie über ein digitales Zertifikat verfügen, kann der Assistent für die Internet Explorer-Anpassung diese Dateien automatisch signieren.

Anmerkungen

  • Für das Signieren der Kabinettdateien und der angepassten Programme sind zwei Schritte erforderlich: Anfordern eines digitalen Zertifikats und Angeben der Zertifikatsinformationen beim Ausführen des Assistenten für die Internet Explorer-Anpassung. Weitere Informationen hierzu finden Sie unter Signieren Ihrer Programme.
  • Möglicherweise müssen Sie die Groß-/Kleinschreibung bei Namen von Dateien ändern, die auf einem FTP-Server bereitgestellt werden sollen, der UNIX ausführt. Im Folgenden sind die Richtlinien aufgeführt, die Sie für bestimmte UNIX-Betriebssysteme beachten sollten.
    • Solaris UNIX
      Bei Verwendung eines FTP-Servers, der UNIX ausführt und bei dem die Groß-/Kleinschreibung relevant ist, müssen Sie sicherstellen, dass der Name Ihres .CAB-Ordners nicht groß geschrieben wird. Folgende Dateinamen werden jedoch in Großbuchstaben angegeben: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB und IE5SITES.DAT.
    • AT&T UNIX
      Auf einem AT&T UNIX FTP-Server müssen alle Dateinamen groß geschrieben werden.
    • IRIX UNIX (Silicon Graphics)
      Folgende Dateinamen müssen groß geschrieben werden: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB und IE5SITES.DAT. Außerdem sollten Sie die in IE.CIF aufgeführten Dateinamen mit einem Texteditor so ändern, dass sie mit der tatsächlichen Schreibweise der Dateien übereinstimmen.

CD-ROM

Falls Sie Ihren angepassten Browser auf CD für Windows 95- und Windows 98-Benutzer vertreiben, wird durch das Autorun-Programm ein automatischer Begrüßungsbildschirm angezeigt, wenn der Benutzer die CD in das Laufwerk einlegt. Dieser Bildschirm bietet die Wahl zwischen dem Installieren Ihres angepassten Browsers und der Anzeige weiterer Informationen. Wenn die aktuelle Version von Internet Explorer bereits installiert ist, erkennt das Autorun-Programm dies. Der Browser wird im sogenannten Kioskmodus ausgeführt, wenn die Datei Start.htm geladen wird.

Weitere Informationen

Weitergehende Informationen zu Windows Update Setup finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme. Eine Schemadarstellung des Downloadvorgangs finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.


ICP: Verfahren zur Verteilung Ihres Messenger Service-Clients

Internet
inhaltsanbieter

Verfahren zur Verteilung Ihres Messenger Service-Clients

Falls Sie den MSN Messenger Service als eine Installationsoption integriert haben, erstellt der Assistent für die Internet Explorer-Anpassung ein separates Paket für den Download des Messenger Service-Clients aus dem Internet oder von einem Intranetserver.

Downloadbare Dateien

Wenn Sie das Messenger Service-Clientpaket auf einem Internet- oder Intranetserver erstellen, sollten Sie Ihre Website so einrichten, dass Benutzer die Dateien downloaden können. Sie können beispielsweise eine Seite erstellen, auf der Sie Downloadinformationen sowie einen Link für die Setup-Datei (Mmssetup.exe) für den Messenger Service-Client hinterlegen.

Wenn Sie die Datei Mmssetup.exe auf Ihrer Festplatte oder einem Netzlaufwerk erstellt haben, müssen Sie die Dateien für alle bereitgestellten Sprachversionen auf einen Internet- oder Intranetserver verschieben. Im Messenger-Ordner Ihres Versionsverzeichnisses wird für jede Sprachversion ein Unterordner erstellt. So befindet sich beispielsweise die englische Version von Mmssetup.exe im Unterordner En. Falls Sie bei der Anpassung einen Download-URL angegeben haben, sollten Sie auf dieser Downloadseite einen Link zu der Datei Mmssetup.exe erstellen. Alle für die Verteilung der angepassten Version des Messenger Service-Clients erforderlichen Komponenten sind in dieser ausführbaren Datei enthalten.

Signieren der Messenger Service-Clientinstallation

Wenn Sie beim Ausführen des IEAK-Assistenten ein digitales Zertifikat für das Signieren des Browserpakets festgelegt haben, wird dieses Zertifikat auch für das Signieren der alleinstehenden Programmversion von Mmssetup.exe verwendet. Weitergehende Informationen erhalten Sie unter Digitale Signaturen und unter Signieren Ihrer Programme.

Messenger Service-Clients als Komponente Ihres Browserpakets

Der angepasste Messenger Service-Client wird auch als Komponente des Browserpakets installiert, wenn Sie festgelegt haben, dass MSN Messenger Service in den Installationsoptionen enthalten ist. Für den angepassten Messenger Service-Client wird eine eigene .CAB-Datei erstellt, und der Client wird bei der Ausführung von Ie5setup.exe als Komponente installiert. Nähere Einzelheiten zur Verteilung des kompletten Browserpakets finden Sie unter Verteilen Ihres Browserpakets.

Messenger Service-Clients und Firewalls

Wenn Sie erweiterte Proxyeinstellungen zur Nachrichtenübermittlung über Firewalls hinweg benötigen, sollten Sie keinen Download-URL festlegen. Darüber hinaus müssen Sie Text bearbeiten, um eine Setup-Datei zur Vorkonfiguration der Proxyoptionen zu erstellen. Weitergehende Informationen erhalten Sie unter Erweiterte Anpassung für den Messenger Service-Client.


Übersicht für Internetdienstanbieter

Microsoft® Internet Explorer Administration Kit (IEAK) ermöglicht es Internetdienstanbietern (ISP), für ihre Kunden einen angepassten Browser sowie ein Anmeldepaket für Internetdienste zu erstellen.

Sie können dieses Kit verwenden, um die folgenden Aufgaben zu erledigen:

Anpassen des Setup-Programms

  • Anpassen des Erscheinungsbildes des Windows Update Setup-Programms und Konfigurieren der Installationsmodi (z. B. Standardinstallation oder Minimale Installation).
  • Verweisen der Benutzer auf Internetserver, auf denen sie die aktuellsten Versionen von Produkten erhalten können.
  • Integrieren von weiteren Programmen, angepassten Skripts oder Wartungsskripts in Internet Explorer.
  • Festlegen der Sprachversion von Internet Explorer, die im Installationspaket enthalten sein soll. Sie müssen den Assistenten für die Internet Explorer-Anpassung für jede Sprachversion, die Sie erstellen möchten, einmal ausführen.

Anpassen des Browsers und der Channels

  • Festlegen der Start-, Such- und Unterstützungsseiten.
  • Aufnehmen von Links und Ordnern in die Favoritenliste.
  • Ändern der Titelleiste und der Logos des Browsers.
  • Hinzufügen eines Channels oder einer Channelkategorie.

Eine Abbildung mit Erläuterungen, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.

Steuern, wie sich die Kunden bei Ihrem Dienst anmelden

  • Implementieren eines Anmeldeserverpakets: Wenn ein Benutzer noch nicht bei Ihrem Dienst angemeldet ist, können Sie dem Benutzer ein aktives Konto zur Verfügung stellen, indem Sie einen einfach zu implementierenden HTML-basierten Anmeldeserver verwenden.
  • Implementieren eines serverlosen Pakets: Wenn ein Benutzer bereits ein Konto bei Ihrem oder einem anderen Dienst besitzt, können Sie die Site des Benutzers durch einen angepassten Browser aktualisieren, indem Sie ein vereinfachtes Verfahren ohne einen Server verwenden. Bei diesem Pakettyp muss der Benutzer einige abschließende Einstellungen bei der Installation angeben.

Ein Beispiel für den Anmeldevorgang finden Sie unter ISP-Anmeldevorgang.

Verwenden des Internet Explorer-Logos

Gemäß den Bestimmungen des Lizenzvertrags müssen Sie das Internet Explorer-Logo auf Ihren Verpackungen und Werbematerialien sowie auf Ihrer Website verwenden. Die Grafikvorlagen für Ihre Website, für Verpackungen und für Werbematerialien finden Sie im Ordner \<IEAK-Programmordner>\Toolkit\Graphics\Samples\.

Wichtig

  • In Abhängigkeit von Ihrem Lizenzvertrag stehen einige Features möglicherweise nicht zur Verfügung. Weitere Informationen finden Sie in Ihrem Vertrag.


Internetdienstanbieter: Internetanmeldeoptionen

Internet-
dienstanbieter

Internetanmeldeoptionen

Ein Internetanmeldeserver (ISS) automatisiert das Aufnahme neuer Kunden in die Kundendatenbank des Internetdienstanbieters. Der Internetanmeldeserver fragt von jedem neuen Kunden Informationen ab, fügt diese Informationen zur Kundendatenbank des Internetdienstanbieters hinzu und sendet anschließend ein Konfigurationspaket zurück an den Computer des Kunden. Das Konfigurationspaket enthält Informationen, die verwendet werden, um den Internetbrowser des Kunden für anschließende Verbindungen zu den Diensten des Internetdienstanbieters zu konfigurieren.

Um einen neuen Kunden zur Datenbank des ISP hinzufügen, führt der Internetanmeldeserver folgende Aktionen aus:

  • Herstellung einer Verbindung zwischen dem Computer des Benutzers und dem Anmeldeserver.
  • Erhebung der Anmeldeinformationen vom Kunden.
  • Abwicklung der Annahme oder Ablehnung der ISP-Dienste durch den Kunden.

Bei Verwendung von IEAK stehen zur Durchführung der Internetanmeldung drei Optionen zur Verfügung:

  • Serverbasierte Anmeldung unter Verwendung des Assistenten für den Internetzugang (empfohlen)
  • Serverbasierte Anmeldung im Kioskmodus
  • Serverlose Anmeldung

Wenn eine Anmeldeserver vorhanden ist, sollten Sie der serverbasierten Anmeldung den Vorzug geben, da Änderungen an Einstellungen sich leichter auf dem Server vornehmen lassen als auf einem Client. Von den zwei verschiedenen serverbasierten Optionen wird das ICW-Verfahren empfohlen, da hierbei eine standardmäßige Schnittstelle in Form eines Assistenten eingesetzt wird, die sich an Ihre Anforderungen anpassen lässt. Wenn Sie ein ISP sind, können Sie den Assistenten für den Internetzugang als Tool festlegen, mit dem die Kunden sich anmelden und ihre Computer für Internetdienste konfigurieren.

Weitere Informationen hierzu finden Sie unter Implementieren eines serverbasierten Anmeldeverfahrens.

Wichtig

  • Falls Sie das Single-Disk Branding-Verfahren einsetzen, verwenden Sie nicht die Anmeldung mit dem Assistenten für den Internetzugang, wenn Sie absehen können, dass bestimmte Benutzer mit Internet Explorer 4.01 Service Pack 1 (oder früheren Versionen) arbeiten. Erstellen Sie statt dessen für diese Kunden ein separates Paket mit Anmeldung im Kioskmodus.

Codebeispiele im IEAK-Toolkit

Anpassbare Lösungen für die Internetanmeldung finden Sie im IEAK-Toolkit. Der Code steht sowohl im ASP (Active Server Pages)- als auch im Perl-Format zur Verfügung. Dies ermöglicht es, mit minimalem Aufwand ein ICW-Anmeldeverfahren für Webserver auf verschiedenen Plattformen zu erstellen. Wenn Sie den Beispielcode verwenden, müssen Sie lediglich den Anmeldeserver in Ihre Registrierungs- und Abrechnungssysteme integrieren. Falls Sie das Referenzserverprogramm von Windows nutzen, ist der Anmeldeservercode für IEAK-Anmeldungen ähnlich dem Code für Referenzserverregistrierungen.

Anmerkung

  • Da die IEAK-Lösung mehrere Internetanmeldedateien (.ISP) für unterschiedliche Benutzeranforderungen einschließt, müssen Sie auch die Dynamic HTML-Datenbindungskomponente in Ihr angepasstes Paket aufnehmen.

Erstellen mehrerer angepasster Versionen von Internet Explorer

Wenn Sie mehrere angepasste Versionen von Internet Explorer erstellen und dabei viele der Einstellungen in einigen oder allen Versionen gleich bleiben, können Sie den Vorgang vereinfachen. Weitere Informationen hierzu finden Sie unter Erstellen mehrerer Versionen des Browsers.


Internetdienstanbieter: Implementieren eines serverbasierten Anmeldepakets

Internet-
dienstanbieter

Implementieren eines serverbasierten Anmeldeverfahrens

Das serverbasierte Anmeldeverfahren automatisiert die Vorgänge der Registrierung und Einrichtung neuer und vorhandener Benutzer. Bei diesem Verfahren werden mit Hilfe eines Internetanmeldeservers (ISS) Informationen über die einzelnen Benutzer eingeholt. Der Anmeldeserver fügt die Daten Ihrer Kundendatenbank hinzu und sendet danach ein Konfigurationspaket an den Computer des Benutzers zurück. Dieses Paket konfiguriert den Browser für anschließende Verbindungen zu Ihren Internetdiensten.

Von ISPs können die folgenden serverbasierten Anmeldeverfahren angewendet werden.

  • Assistent für den Internetzugang: Im Assistenten für die Internet Explorer-Anpassung können Sie den Assistenten für den Internetzugang (ICW = Internet Connection Wizard) als Tool angeben, mit dem die Kunden sich anmelden und ihre Computer für Internetdienste konfigurieren. Dieses Verfahren wird empfohlen, da hierbei eine standardmäßige Schnittstelle in Form eines Assistenten eingesetzt wird, die sich an die Anforderungen der jeweiligen Organisation und Benutzer anpassen lässt. Das ICW-Feature zur automatischen Konfiguration ermöglicht es außerdem, Einstellungen für Benutzer zu konfigurieren, die bereits über Internetkonten verfügen.
  • Kioskmodus (Vollbildschirm): Im Assistenten für die Internet Explorer-Anpassung können Sie festlegen, dass die von Ihnen erstellten Anmeldebildschirme im sogenannten Kioskmodus angezeigt werden, d. h. den gesamten Bildschirm ausfüllen.

Eine Schemadarstellung des Anmeldevorgangs finden Sie unter ISP-Anmeldevorgang.

Erstellen eines angepassten Pakets mit serverbasiertem Anmeldeverfahren

Um ein angepasstes Browserpaket zu erstellen, das ein serverbasiertes Anmeldeverfahren enthält, geben Sie in Schritt 4 des Assistenten für die Internet Explorer-Anpassung Folgendes an:

  • Als Anmeldeverfahren entweder Serverbasierte Anmeldung unter Verwendung des Assistenten für den Internetzugang (empfohlen) oder Serverbasierte Anmeldung im Kioskmodus.
  • Den Pfad zu dem Ordner, der die angepassten Anmeldedateien enthält. Mit Hilfe dieser Dateien können die Benutzer ihre Computer zum Herstellen einer Verbindung zu Ihrem Anmeldeserver konfigurieren.
  • Die Anmeldeserverinformation, wie etwa die Parameter für die DFÜ-Netzwerkverbindung, welche die Benutzer zum Herstellen der Verbindung mit Ihrem Anmeldeserver benötigen, sowie den URL der ersten Onlineanmeldeseite.
  • Die ICW-Anpassungsinformationen, beispielsweise die Titelleiste und angepasste Grafiken (falls Sie die Option Serverbasierte Anmeldung unter Verwendung des Assistenten für den Internetzugang (empfohlen) ausgewählt haben).

Um sicherzustellen, dass Ihr Paket ordnungsgemäß installiert wird, muss der Ordner, in dem sich Ihre angepassten Anmeldedateien befinden, außerdem Folgendes enthalten:

  • Signup.htm - Diese HTML-Seite liefert Informationen über Ihre Internetdienste und muss einen Link zu der vorgesehenen HTML-Seite auf dem Anmeldeserver enthalten. Sie können einfach die Beispieldatei Signup.htm anpassen, die sich im Ordner IEAK-Programmordner\Toolkit\Isp\Server\Kiosk befindet. Beispielsweise können Sie Angaben zum technischen Support machen oder Links zu Internetanmeldedateien (ISP) einfügen.
  • Signup.isp - Diese Internetanmeldedatei wird für die Einwahl beim Anmeldeserver verwendet und wird in Signup.htm referenziert. Die Datei sollte auch einen Link zum URL des Serverskripts enthalten, das die Interneteinstellungsdateien (.INS) erzeugt. Die Parameter in der Internetanmeldedatei können Sie mit Hilfe des Assistenten für die Internet Explorer-Anpassung bearbeiten. Der Assistent für die Internet Explorer-Anpassung erzeugt auch weitere .INS-Dateien für den Anmeldevorgang.
  • Sämtliche anderen Anmeldedateien - Alle zugehörigen Dateien, einschließlich .GIF- und .JPG-Grafikdateien, müssen im gleichen Ordner gespeichert sein wie Ihre angepassten Anmeldedateien. Beispielsweise können Sie eine angepasste Version der Datei Install.gif einbinden.

Verteilen eines angepassten Pakets mit serverbasiertem Anmeldeverfahren

Bei einem serverbasierten Anmeldeverfahren verläuft der Anmeldevorgang für Ihr angepasstes Browserpaket in drei Schritten:

  1. Der Computer des Benutzers stellt eine Verbindung mit dem Anmeldeserver her.
  2. Ein Dialogfeld auf HTML/HTTP-Basis sammelt Informationen vom Benutzer und fügt diese Kundeninformationen in Ihre Kundendatenbank ein.
  3. Der Anmeldeserver schickt ein Konfigurationspaket zurück an den Computer des Kunden. Das Paket enthält Informationen zur Konfiguration und zum Branding. Außerdem enthält es die lokale Rufnummer, unter der der Kunde auf den Internetdienstanbieter zugreifen kann.

    4. Beachten Sie, dass bei einer Einstellung der Sicherheitsoptionen des Benutzers auf Hoch der Anmeldeserver nicht ordnungsgemäß arbeitet, da die erforderlichen Dateien nicht auf den Computer des Benutzers gedownloadet werden können.

Herstellen der Verbindung mit dem Anmeldeserver

Der Benutzer öffnet das Anmeldeprogramm, welches Internet Explorer startet, den Anmeldeserver anwählt und eine anfängliche Verbindungsanforderung übermittelt. Daraufhin führt der Anmeldeserver folgende Aktionen aus:

  • Er nimmt die Anforderung vom Computer des Benutzers (dem HTTP-Client) entgegen und stellt eine HTTP-Verbindung her.
  • Er erstellt einen lokalen Datenspeicher, in dem die Informationen gesammelt werden, die der Benutzer eingibt.
  • Er weist der Arbeitssitzung eine eindeutige Zugriffsnummer zu, die in alle folgenden HTTP-Transaktionen mit dem Client eingebettet wird.

Bei HTTP handelt es sich um ein sitzungsloses Protokoll. Der Anmeldeserver arbeitet jedoch in einem sitzungsorientierten Modus. Er verwendet die Zugriffsnummer der Arbeitssitzung, um alle Transaktionen zu identifizieren, die mit dem Anmeldevorgang für einen bestimmten Benutzer verknüpft sind. Bei der Zugriffsnummer der Arbeitssitzung kann es sich beispielsweise um eine automatisch erzeugte fortlaufende Nummer handeln, die dieser Transaktion durch Ihre Datenbank zugewiesen wird.

Zusammenstellen der Anmeldeinformationen des Benutzers

Der Anmeldeserver sammelt die Benutzerinformationen mittels einer Folge von HTML-Seiten, die den Benutzer schrittweise durch den Anmeldevorgang führen, ähnlich wie ein Assistent in einem Windows-Programm. Diese Seiten werden vom Anmeldeserver auf Anforderung auf den Computer des Benutzers geladen. Der Anmeldevorgang wird abgeschlossen, wenn der Benutzer auf die entsprechende Schaltfläche auf der letzten HTML-Seite klickt, um die Anmeldevereinbarung entweder anzunehmen oder abzulehnen.

Inhalte und Format der HTML-Seiten können Sie selbst festlegen. Üblicherweise enthält jede HTML-Seite folgende Elemente:

  • Ein Formular, das der Benutzer ausfüllen muss.
  • Navigationsschaltflächen, auf die der Benutzer klickt, um vorwärts oder rückwärts zwischen Seiten zu wechseln.
  • Eine Schaltfläche, auf die der Benutzer klicken kann, um den Anmeldevorgang abzubrechen.

Jedes HTML-Formular enthält auch Steuerelemente zum Aufnehmen von Eingabetext, zum Navigieren zwischen Seiten und zur Identifizierung der Sitzung. Das Formular sammelt Informationen vom Benutzer, die an den Anmeldeserver weitergeleitet werden, wenn der Benutzer auf eine Navigationsschaltfläche klickt. Darüber hinaus kann der Anmeldeserver die Daten überprüfen und eine Korrekturseite an den Computer des Benutzers übermitteln, wenn die Daten nicht gültig sind.

Anmerkung

  • Achten Sie darauf, die HTML-Datei im richtigen Ordner auf dem Anmeldeserver zu speichern. Die Datei Signup.isp enthält einen Link zu den Serverdateien für 32-Bit-Windows-Versionen, während die Datei Signup.htm einen Link zu den Serverdateien für 16-Bit-Windows-Versionen enthält.

Rücksenden eines Konfigurationspakets an den Computer des Benutzers

Nachdem der Benutzer die Anmeldevereinbarung akzeptiert hat, erstellt der Anmeldeserver ein Konfigurationspaket mit einer .INS-Datei (erzeugt durch den Assistenten für die Internet Explorer-Anpassung), das Informationen über den Kunden und die von Ihnen angebotenen Internetdienste enthält. Die .INS-Datei enthält entweder nur Verbindungseinstellungen oder komplette Einstellungen für Verbindung, Browser und E-Mail einschließlich Grafiken.

Der Anmeldeserver sendet das Konfigurationspaket zurück an den Computer des Benutzers, indem er auf die .INS-Datei zurückgreift, die entweder unmittelbar erzeugt oder einfach an den Clientcomputer weitergeleitet wird. Danach kann der Computer die Installation des angepassten Browserpakets fortsetzen. Falls der Benutzer die Anmeldevereinbarung ablehnt oder den Vorgang beendet, leitet der Anmeldeserver den Computer des Benutzers zu einer Datei um, die für den Abbruch des Anmeldevorgangs sorgt.

Das Konfigurationspaket enthält folgende Informationen:

  • Daten für die Konfiguration der Internetverbindungen
  • Funktionen des Benutzerkontos (einschließlich E-Mail und Newsreader)
  • Branding-Informationen, mit denen das Erscheinungsbild des Anmeldepakets auf Ihre Organisation abgestimmt wird
  • Die lokale Rufnummer, unter welcher der Kunde auf Ihre Internetdienste zugreifen kann

Die ersten beiden Datentypen werden in einem integrierten Vorgang vom Anmeldeserver erzeugt. Der Assistent für die Internet Explorer-Anpassung bereitet die .INS-Datei für Branding-Informationen vor. Einige Einstellungen, wie beispielsweise Entry, User, Phone, Device, Server und TCP/IP, können nicht im Assistenten angegeben werden. Diese Angaben müssen Sie manuell in die .INS-Datei einfügen.

Falls Sie eine Reihe verschiedener angepasster Versionen von Internet Explorer mit spezifischen Branding-Informationen für verschiedene Benutzergruppen anbieten möchten, können Sie mehrere Sätze von Branding-Informationen speichern, die der Anmeldeserver in die .INS-Datei lädt. Beispielsweise können Sie angepasste Versionen mit verschiedenen Logos, Titelleisten, Favoriten, Such- und Startseiten sowie speziellen Links oder Pfaden zur Online-Unterstützung erstellen. Dabei sind die CDs, die Sie an Benutzer verteilen, identisch; sie werden jedoch mit unterschiedlichen Branding-Informationen versehen, wenn die Benutzer sich für Internetdienste anmelden.

Verwendung von Anmeldeservern mit Internet Information Server

Wenn Sie IIS als Anmeldeserver verwenden, müssen Sie den Internetanmeldeserver dahingehend konfigurieren, dass er dem Client eine DHCP-IP-Adresse zuweist, wenn dieser eine Verbindung zum Server herstellt. Der Anmeldevorgang ist relativ kurz; die Gültigkeitsdauer der IP-Adresse kann daher sehr kurzfristig sein, möglicherweise nur einige Minuten.

Da die Verarbeitung des Anmeldevorgang über eine Punkt-zu-Punkt-DFÜ-Verbindung erfolgt, müssen die dem DHCP-Server zugewiesenen IP-Adressen keine formal zugewiesenen IP-Adressen sein. Es liegt in Ihrem Ermessen, ob es sich bei den DHCP-IP-Adressen um gültige oder um willkürliche Adressen handelt.

Registrieren des MIME-Typs der ".INS"-Datei

Damit der Client die .INS-Datei automatisch verarbeitet, müssen Sie einen MIME-Typ für die .INS-Datei beim Anmeldeserver registrieren. Dieser MIME-Typ wurde als "application/x-Internet-signup" bestimmt. Wenn der Client eine .INS-Datei anfordert, antwortet der Anmeldeserver mit diesem MIME-Typ, der die entsprechende Installationsanwendung auf der Clientseite startet.

MIME-Typen müssen manuell in der Registrierung bearbeitet werden. Um der Registrierung den MIME-Typ der .INS-Datei hinzuzufügen, tragen Sie mit Hilfe von Regedt32.exe die folgenden Informationen ein:

Fügen Sie unter dem Schlüssel
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\InetInfo\Parameters\MimeMap

folgenden Wert hinzu:
application/x-internet-signup,ins,,5

Mit diesem Wert ist keine Zeichenfolge verknüpft. Weitere Informationen zum Einrichten der MIME-Typen finden Sie außerdem in der IIS-Hilfe.

Anmerkung

  • Damit die Registrierungseinstellungen wirksam werden, müssen alle IIS-Dienste nach dem Hinzufügen des neuen MIME-Typs beendet werden. Es reicht nicht aus, nur den Web-Veröffentlichungsdienst anzuhalten und dann neu zu starten. (In der Praxis werden die Dienste FTP und Gopher in der Anmeldeserverkonfiguration wahrscheinlich nicht ausgeführt.)


Internetdienstanbieter: Einrichten eines Anmeldeservers im Kioskmodus (Vollbildschirm)

Internet-
dienstanbieter

Einrichten eines Anmeldeservers im Kioskmodus (Vollbildschirm)

Ein Internetanmeldeserver (ISS) ist ein HTTP-Server (Hypertext Transfer Protocol), der das Hinzufügen neuer Kunden zu der Kundendatenbank eines Internetdienstanbieters (ISP) automatisiert. Der Internetanmeldeserver sammelt Informationen von jedem neuen Kunden, fügt diese Informationen zur Kundendatenbank des Internetdienstanbieters hinzu und sendet anschließend Daten zurück an den Computer des Kunden. Mit diesem Informationspaket wird der Internetbrowser des Benutzers für die Verwendung der Dienste des ISPs konfiguriert.

Eine Schemadarstellung des Anmeldevorgangs finden Sie unter ISP-Anmeldevorgang.

Der Internetanmeldeserver führt beim Hinzufügen eines neuen Kunden zu der Datenbank des Internetdienstanbieters folgende Aktionen aus:

  1. Herstellen einer HTTP-Verbindung zum Computer des Kunden.
  2. Erhebung der Anmeldeinformationen vom Kunden.
  3. Behandlung der Zustimmung oder Ablehnung der Dienste des Internetdienstanbieters durch den Kunden.

Zur Bearbeitung dieser Aufgaben können Sie den Beispielcode anpassen, der für die Internetanmeldung mit dem Assistenten für den Internetzugang erstellt wurde. Dieser Beispielcode ist im IEAK-Toolkit enthalten, das sich im Ordner \<IEAK-Programmordner>\Toolkit\ISP\Server\ICW\ befindet.

Die folgenden Themen beschreiben die Entwicklung eines Anmeldeverfahrens für den Assistenten für den Internetzugang. In diesen Themen wird eine getestete, umfassende Anmeldelösung erläutert, die für die meisten Fälle empfehlenswert ist. Allerdings können Sie das Anmeldeverfahren auch anpassen, um den besonderen Bedürfnissen Ihres Unternehmens gerecht zu werden.

  • Internetanmeldung mit dem Assistenten für den Internetzugang
  • Codierungsanforderungen für die Bildschirme des Assistenten für den Internetzugang
  • Arbeiten mit den Beispielanmeldedateien des Assistenten für den Internetzugang
  • Erstellen der Datei Icwsign.htm, der Fehlerbildschirme und des Bildschirms Fertig stellen für die Anmeldung mit dem Assistenten für den Internetzugang
  • Erstellen von Bildschirmen für die Anmeldung mit dem Assistenten für den Internetzugang


Internetanmeldung mit dem Assistenten für den Internetzugang

Wenn Sie Internetdienstanbieter (ISP) sind, können Sie den Assistenten für den Internetzugang (Internet Connection Wizard - ICW) als Tool festlegen, mit dem die Kunden sich anmelden und ihre Computer für die Nutzung Ihrer Internetdienste konfigurieren. Sie können serverbasierte Lösungen erstellen, bei denen Informationen mit den Bildschirmen des Assistenten für den Internetzugang ausgetauscht werden. Dieses Feature steht für die serverlose Anmeldung nicht zur Verfügung.

Anpassbare Lösungen für die Internetanmeldung enthält das IEAK-Toolkit, das sich im Ordner \<IEAK-Programmordner>\Toolkit\ISP\Server\ICW\ befindet. Der Code steht sowohl im ASP (Active Server Pages)-Format als auch im Perl-Format zur Verfügung. Dies ermöglicht es, mit minimalem Aufwand einen ICW-Anmeldeserver für Webserver auf verschiedenen Plattformen zu erstellen. Wenn Sie den Beispielcode verwenden, müssen Sie lediglich den Anmeldeserver in Ihre Registrierungs- und Abrechnungssysteme integrieren.

Falls Sie das Referenzserverprogramm von Windows nutzen, ist der Anmeldeservercode für IEAK-Anmeldungen und Referenzserverregistrierungen ähnlich.

Eine Schemadarstellung des Anmeldevorgangs finden Sie unter ISP-Anmeldevorgang.

Die folgenden Themen beschreiben die Entwicklung eines Anmeldeverfahrens für den Assistenten für den Internetzugang. In diesen Themen wird eine getestete, umfassende Anmeldelösung erläutert, die in den meisten Fällen empfohlen wird. Allerdings können Sie das Anmeldeverfahren auch anpassen, um den besonderen Bedürfnissen Ihres Unternehmens gerecht zu werden.

  • Codierungsanforderungen für die Bildschirme des Assistenten für den Internetzugang
  • Arbeiten mit den Beispielanmeldedateien für den Assistenten für den Internetzugang
  • Erstellen der Datei Icwsign.htm, der Fehlerbildschirme und des Bildschirms Fertig stellen für die Anmeldung mit dem Assistenten für den Internetzugang
  • Erstellen von Bildschirmen für die Anmeldung mit dem Assistenten für den Internetzugang
  • Verwenden der automatischen Konfiguration des Assistenten für den Internetzugang für die ISP-Anmeldung

Wichtig

  • Falls Sie das Single-Disk Branding-Verfahren einsetzen, verwenden Sie nicht die Anmeldung mit dem Assistenten für den Internetzugang, wenn Sie absehen können, dass bestimmte Benutzer mit Internet Explorer 4.01 Service Pack 1 (oder früheren Versionen) arbeiten. Erstellen Sie statt dessen für diese Kunden ein separates Paket mit Anmeldung im Kioskmodus.


Arbeiten mit den Beispielanmeldedateien für den Assistenten für den Internetzugang

Wenn Sie vor dem Erstellen eigener Dateien den Anmeldevorgang simulieren möchten, können Sie hierzu die Beispieldateien aus dem IEAK-Toolkit im Ordner \<IEAK-Programmordner>\Toolkit\ISP\Server\ICW\ verwenden. Die Beispieldateien vermitteln eine allgemeine Vorstellung davon, wie der Anmeldevorgang abläuft und welche Art von Informationen angegeben werden müssen.

Führen Sie dazu die folgenden Schritte aus:

  1. Erstellen Sie im Verzeichnis Wwwroot auf Ihrem Server ein Verzeichnis namens Signup.
  2. Kopieren Sie die Dateien aus dem IEAK-Toolkit in das Verzeichnis Signup.
  3. Ändern Sie alle Verweise in den Dateien dahingehend, dass diese auf Ihren Anmeldeserver verweisen.
  4. Ändern Sie im HTML-Code der Anmeldeserver-Seiten alle Vorkommen von Acme ISP in den Namen Ihres Unternehmens.
  5. Ändern Sie die letzte Seite des Anmeldeservers auf Ihre .INS-Einstellungen um.


Kodierungs- und Eingabehilfenanforderungen für die Anmeldung mit dem Assistenten für den Internetzugang

Internet-
dienstanbieter

Codierungsanforderungen für die Bildschirme des Assistenten für den Internetzugang

Der neue IEAK-Anmeldemechanismus über den Assistenten für den Internetzugang basiert auf dem Konzept, dass ein Internetanmeldeserver im Aussehen und Verhalten einem Windows-Standardassistenten angepasst ist. Der Assistent für den Internetzugang nutzt zwar die Leistungsfähigkeit und Flexibilität von HTML, verwendet jedoch eine andere Formatierung als diese Sprache.

Die HTML-Seiten des Assistenten verwenden die Windows-Systemfarben und -schriften und müssen außerdem die Eingabehilfenanforderungen erfüllen. Soweit nicht anders angegeben, dürfen die HTML-Seiten des Assistenten keine besonderen HTML-Formatierungen, wie beispielsweise Tabellen mit sichtbaren Umrahmungen, Bilder oder Verankerungen, enthalten. Es sind nur Standardtext und Formularelemente (falls erforderlich) zulässig. Tabellen mit unsichtbaren Umrahmungen können als Layout verwendet werden.

Standardmäßig sollte keine HTML-Seite außer der Seite Icwsign.htm Farb- oder Schriftartenattribute enthalten, damit die Systemfarben des Benutzers angezeigt werden. Der übergeordnete Assistent legt die Schriftschnitte und -farben fest, damit diese dem System des Benutzers entsprechen.

Für das Implementieren von Formularen in die HTML-Seiten wird lediglich vorausgesetzt, dass die Formulare die NAME-Parameter in den <FORM>-Elementen verwenden, die in der Spezifikation angegeben sind. Sie können alle Tokennamen für andere Elemente in Ihren HTML-Seiten angeben; diese Elemente werden dann an den Anmeldeserver übermittelt.

Funktion der Schaltflächen "Zurück" und "Weiter"

Für die Anmeldung im ICW-Modus gelten besondere Anforderungen, die erfüllt sein müssen, damit die Schaltflächen Zurück und Weiter im Assistenten für den Internetzugang einwandfrei funktionieren.

Der in IEAK enthaltene Anmeldeserver-Beispielcode entspricht bereits diesen Anforderungen.

Die Schaltfläche "Zurück"

Damit die Schaltfläche Zurück ordnungsgemäß funktioniert, müssen Sie der Anmeldeserver-Seite ein FORM-Element hinzufügen, das den URL für die Schaltfläche Zurück angibt. Um die zuvor im Anmeldevorgang ermittelten Dateien beizubehalten, müssen Sie alle Daten, die erhalten werden sollen, an den URL für die Schaltfläche Zurück anfügen.

Im Folgenden sehen Sie das FORM-Element für die Schaltfläche Zurück, das erforderlich ist, um den Benutzer zur vorherigen Seite des Anmeldevorgangs zurückzuführen. Die Daten werden als Name/Wert-Paare an den URL angefügt:

<FORM NAME="ZURÜCK"
      ACTION="http://eigenerserver/seite2.asp"?vorname=robert&nachname=schmidt&adresse=...">
</FORM>

Anmerkung

  • Das Element NAME und dessen Wert müssen komplett groß geschrieben werden, da beim ICW die Groß-/Kleinschreibung gilt.

Die Schaltfläche "Weiter"

Damit die Schaltfläche Weiter ordnungsgemäß funktioniert, müssen Sie der Anmeldeserver-Seite ein FORM-Element hinzufügen, das den URL für die Schaltfläche Weiter angibt. Damit die ermittelten Daten an die nächste Seite des Anmeldevorgangs weitergeleitet werden, müssen Sie auf jeder Seite Ihres Anmeldeservers versteckte Formularfelder hinzufügen, welche die auf diesem sowie allen vorherigen Bildschirmen gesammelten Datenelemente enthält. Der URL, auf den verwiesen wird, muss Code enthalten, der die Daten aus der vorherigen Seite ermittelt und die nächste Seite des Anmeldevorgangs anzeigt.

Im Folgenden sehen Sie das FORM-Element für die Schaltfläche Weiter, das erforderlich ist, um den Benutzer zur nächsten Seite des Anmeldevorgangs weiterzuleiten.

<FORM NAME="WEITER"
      ACTION="http://eigenerserver/seite2.asp">
</FORM>

Anforderungen für Eingabehilfen

Um zu gewährleisten, dass der Zugriff auf sämtliche Elemente auf der Seite auch ausschließlich über die Tastatur möglich ist, sollte jedes Formularelement den folgenden Anforderungen entsprechen:

  • Jedem Element muss eine Zugriffstaste (Hotkey) zugeordnet sein. Verwenden Sie den Internet Explorer-Parameter ACCESSKEY= im <INPUT>-Tag. Der Buchstabe der Zugriffstaste sollte mit einem Unterstrich hervorgehoben werden. Dies erreichen Sie mit Hilfe des <U>-Tags. Die Buchstaben z, f, g, w und o sind für den Assistenten für den Internetzugang reserviert und können nicht als Zugriffstasten verwendet werden. Weitere Informationen zum ACCESSKEY-Parameter finden Sie im MSDN Online Web Workshop.
  • Alle Elemente auf der Seite müssen in der TAB-Tastenreihenfolge des Assistenten für den Internetzugang enthalten sein. Um in die TAB-Tastenreihenfolge des des Assistenten für den Internetzugang aufgenommen zu werden, muss das Element über eine eindeutige ID im <INPUT>-Tag verfügen.
  • Jedem Element sollte eine Bezeichnung zugeordnet sein. Bezeichnungen für die verschiedenen Eingabetypen für HTML-Formulare werden mit Hilfe des Internet Explorer-Parameters LABEL= zugeordnet.

Beispiel

Das folgende Optionsschaltflächen-Formularelement erfüllt alle ICW-Eingabehilfenanforderungen:

<INPUT ID="option2"
       TYPE="radio"
       NAME="Rechnung"
       VALUE="Stunde"
       ACCESSKEY="s"
       CHECKED
>
<LABEL for="option2">
    5 <U>S</U>tunden pro Monat für 10 EUR.
</LABEL>

HTML- und Designanforderungen

Jede Seite des Assistenten für den Internetzugang sollte über folgende Designelemente verfügen und folgenden Designrichtlinien entsprechen.

Wichtig

  • Es sind nur Text und HTML-Formularelemente zulässig. Bilder, Hyperlinks und Bildlaufleisten sind nicht erlaubt.

Stylesheet

Geben Sie keine Schriftartentypen oder Farbattribute an. Der übergeordnete Assistent legt diese Attribute fest. Bei Verwendung eines <TABLE>-Tags in Ihren Fehlerseiten muss dieser folgenden Style enthalten:

<TABLE style="font: 8pt 'ms sans serif' buttontext">
</TABLE>

Erforderliche Formularelemente

Diese Seite muss vier HTML <FORM>-Elemente enthalten, welche die verschiedenen Eigenschaften für die Seite angeben:

Element | Anforderungen
Eindeutige PAGEID für die Seite. | Das Element NAME des Formulars muss "PAGEID" lauten (Groß-/Kleinschreibung beachten). Das Attribut ACTION des Formulars muss eine eindeutige ID sein, die mit keiner anderen PAGEID der Seiten im ISP-Abschnitt des Assistenten identisch ist (z. B. <FORM NAME="PAGEID" ACTION="Seite4"></FORM>).
Funktion der Schaltfläche Zurück. | Das Element NAME für das Formular muss "BACK" lauten (Groß-/Kleinschreibung beachten). Das Attribut ACTION für dieses Formular sollte der absolute URL für die vorherige Seite sein (beispielsweise ACTION="HTTP://signup/bin/page1.cgi"); allerdings werden auf dieser Seite keine Daten bereitgestellt.
Charakteristika der Seite | Das Formular wird durch NAME "PAGETYPE" gekennzeichnet (Groß-/Kleinschreibung beachten). Da es sich hierbei um einen Standard-Frame handelt, dessen gesamtes Feld vom Internetdienstanbieter festgelegt wird, muss das Formularattribut ACTION mit einer leeren Zeichenfolge angegeben werden (z.B. ACTION="").
Funktion der Schaltfläche Weiter | Das Element NAME für das Formular muss "NEXT" lauten (Groß-/Kleinschreibung beachten). Hierbei handelt es sich um das Formular, das die eigentlichen Formularelemente enthält, die an den ISP-Anmeldeserver zurückgesendet werden. Es gelten keine Beschränkungen für die Tokennamen für die <INPUT>-Elemente des Formulars. Das Attribut ACTION für das Formular sollte der absolute URL sein, unter dem die Formularinformationen abgelegt werden. Der URL, den Sie auf Ihrem Server bereitstellen, sollte ein Skript enthalten, das die Daten empfängt und anschließend die nächste HTML-Seite des Assistenten anzeigt.


Verwenden der automatischen Konfiguration des Assistenten für den Internetzugang für die ISP-Anmeldung

Die automatische Konfiguration des Assistenten für den Internetzugang des ermöglicht es Benutzern, die bereits ein Konto bei einem Internetdienstanbieter haben, eine Kontoeinstellung automatisch neu zu konfigurieren. Ein neuer Computer kann mit Hilfe dieses Features für das gleiche Internetkonto konfiguriert werden, das auf einem vorher verwendeten Computer oder einem Computer am Arbeitsplatz eingerichtet war. Zusätzlich leistet dieses Feature wertvolle Hilfe, wenn die Interneteinstellungen des Benutzers beschädigt werden. Das Feature Autokonfiguration stellt die jeweiligen Einstellungen wieder her; der Benutzer muss lediglich die Benutzer-ID, das Kennwort und den POP-Server kennen.

Bei angepassten Versionen von Internet Explorer können Benutzer den Autokonfigurationsserver von der Internet Explorer-CD aus erreichen, indem sie auf den entsprechenden Link auf der Seite Icwsign.htm klicken. Dieser Link verbindet den Benutzer mit dem Registrierungsserver für die automatische Konfiguration. Nachdem der Benutzer mit Ihrem Anmeldeserver verbunden wurde, können Sie ihn auffordern, Benutzername, Kennwort und POP-Server einzugeben. Unter Verwendung dieser Informationen können Sie eine .INS-Datei an den Computer des Benutzers senden, um das Benutzerkonto neu zu konfigurieren.

Zwei Verfahren zur Unterstützung der automatischen Konfiguration des Assistenten für den Internetzugang

Es gibt zwei Verfahren für die Wiederherstellung von Benutzerkonten mit Hilfe der automatischen Konfiguration des Assistenten für den Internetzugang:

  • Fordern Sie den Benutzer auf, Benutzername, Kennwort und POP-Server einzugeben. Diese Informationen reichen bereits aus, um die .INS-Datei neu zu erstellen, an den Benutzer zu senden und das Konto neu zu konfigurieren. Falls Sie sich Gedanken über einen möglichen Missbrauch dieses Features machen, können Sie die Kreditkartennummer des Benutzers erneut anfordern und sie anhand der Registrierungsdatenbank überprüfen.
  • Speichern Sie die INS-Dateien zusammen mit den übrigen Konteninformationen des Benutzers. Stellt ein Benutzer eine Verbindung zum Autokonfigurationsserver her, so kann er die .INS-Datei anfordern, indem er lediglich den Benutzernamen und das Kennwort eingibt. Der Autokonfigurationsserver sucht daraufhin das entsprechende Benutzerkonto und übermittelt eine Kopie der ursprünglichen .INS-Datei des Benutzers. Hierbei gilt ebenso wie beim vorangegangenen Verfahren: Falls Sie einen möglichen Missbrauch dieses Features befürchten, können Sie die Kreditkartennummer des Benutzers erneut anfordern und sie anhand der Registrierungsdatenbank überprüfen.

Folgen Sie zum Einrichten der automatischen Konfiguration des Assistenten für den Internetzugang den Codierungsanforderungen für die Bildschirme des Assistenten für den Internetzugang, und entwerfen Sie die ISP-Seiten Kontenanmeldung/E-Mail, POP-Auswahl sowie Fertig stellen.


Internetdienstanbieter: Implementieren eines serverlosen Anmeldepakets

Internet-
dienstanbieter

Implementieren eines serverlosen Anmeldepakets

Das serverlose Anmeldeverfahren ermöglicht Benutzern die Installation Ihres angepassten Internet Explorer-Browsers von einer CD, von Disketten oder mit Hilfe downloadbarer Dateien. Während des Installationsvorgangs müssen die Benutzer nur ihren Benutzernamen, das Kennwort und die Verbindungsinformationen eingeben, um ein Konto einzurichten und unter Verwendung Ihres angepassten Browsers eine Verbindung zum Internet herzustellen. Internetdienstanbieter (ISPs) haben die Möglichkeit, Benutzereinstellungen anzupassen, ohne einen Anmeldeserver einzusetzen. Da Konfigurationsinformationen mit dem IEAK-Paket vertrieben werden und somit nur lokal auf dem Computer des Benutzers verfügbar sind, ist dieses Verfahren ein weniger dynamischer Prozess als die serverbasierte Anmeldung.

Das serverlose Anmeldeverfahren eignet sich nicht zum Anpassen des Assistenten für den Internetzugang.

Erstellen eines angepassten Pakets mit serverlosem Anmeldeverfahren

Um ein angepasstes Browserpaket zu erstellen, das ein serverloses Anmeldeverfahren enthält, geben Sie in Schritt 4 des Assistenten für die Internet Explorer-Anpassung Folgendes an:

  • Serverlose Anmeldung als verwendetes Anmeldeverfahren.
  • Den Pfad zu dem Ordner, der die angepassten Anmeldedateien enthält. Mit Hilfe dieser Dateien können die Benutzer ihre Computer für Internetdienste konfigurieren.
  • Die Parameter für die DFÜ-Netzwerkverbindung, die die Benutzer zum Herstellen der Verbindung zu Internetdiensten benötigen.

Um sicherzustellen, dass Ihr Paket ordnungsgemäß installiert wird, muss der Ordner, in dem sich Ihre angepassten Anmeldedateien befinden, außerdem Folgendes enthalten:

  • Signup.htm - Diese HTML-Seite liefert Informationen über Ihren Internetdienst and muss einen Link zu der .INS-Datei aufweisen, die die Konfigurationseinstellungen für Ihr angepasstes Browserpaket enthält.
  • Sämtliche anderen Anmeldedateien - Alle zugehörigen Dateien, einschließlich .GIF- und .JPG-Grafikdateien, müssen im gleichen Ordner gespeichert sein wie Ihre angepassten Anmeldedateien. Beispielsweise können Sie angepasste Versionen der Dateien Install.gif und Logohere.gif einbinden.

Verteilen eines angepassten Pakets mit serverlosem Anmeldeverfahren

Ihr angepasstes Paket umfasst eine Konfigurationsdatei mit dem Namen Install.ins, die die Einstellungen enthält, die Sie für den angepassten Browser festgelegt haben. Anders als bei dem Internetanmeldeserver-Verfahren enthält diese .INS-Datei keine benutzerspezifischen Konfigurationsinformationen. Wenn der Benutzer das Anmeldeprogramm ausführt, wird durch einen Link auf der lokalen HTML-Seite die .INS-Datei gestartet. Der Benutzer gibt den Benutzernamen, das Kennwort und die Verbindungsinformationen ein. Anschließend konfiguriert die .INS-Datei das Konto des Benutzers für den Zugang zum Internet mit dem angepassten Browser.

Nachteile der Verwendung eines serverlosen Anmeldeverfahrens

Da die Konfigurationsdatei mit dem IEAK-Paket vertrieben wird, können Sie Benutzereinstellungen nicht dynamisch auf dem Anmeldeserver ändern.

Der üblicherweise verwendete Anmeldeserver sammelt Informationen zu einem Benutzer und erstellt daraus eine angepasste Konfigurationsdatei, die auf den Computer des Benutzers gedownloadet wird. Bestimmte Software im Internet Explorer-Installationspaket verwendet die Konfigurationsdatei, um den Computer zu konfigurieren.

In der serverlosen Version wird die Konfigurationsdatei vor dem Versand des Pakets erstellt und in das Installationspaket aufgenommen. Aus diesem Grund enthält die Konfigurationsdatei keinerlei benutzerspezifische Konfigurationsinformationen. Die Konfigurationsdatei Install.ins wird als Link von der lokalen HTML-Seite aufgerufen und konfiguriert die meisten Einstellungen von Internet Explorer. Da die Konfigurationsdatei im Installationspaket enthalten ist, wird sie zu einer lokalen Datei auf dem Computer des Benutzers.

Um diesen Nachteil auszugleichen, wird bei Verwendung der Option Erweitert im Rahmen des serverlosen Anmeldevorgangs durch ein ActiveX-Steuerelement (Installx.exe) schnell eine .INS-Datei erzeugt, welche die Benutzerinformationen aufnimmt. Internet Explorer nutzt dann diese vom ActiveX-Steuerelement erstellte Datei zur Konfiguration der Benutzereinstellungen.


Internetdienstanbieter: Vorbereiten der Ausführung des Assistenten

Internet-
dienstanbieter

Vorbereiten der Ausführung des Assistenten

Vor der Ausführung des Assistenten für die Internet Explorer-Anpassung sollten Sie die benötigten Informationen bereithalten und angepasste Bitmaps erstellen.

Ermitteln Sie die grundsätzlichen Plattformanforderungen

  • Stellen Sie sicher, dass der Computer, auf dem Sie Ihr Paket erstellen, sowie die Computer, auf denen Sie das Paket installieren, die Hardware- und Systemanforderungen erfüllen.
  • Legen Sie die Verschlüsselungsstufe für Ihre Browserpakete fest. Informationen zur Verschlüsselung von Internet Explorer finden Sie auf der IEAK-Website.

Entscheiden Sie sich für ein Distributionsverfahren

Entscheiden Sie, wie Sie Ihr angepasstes Paket verteilen möchten (CD, Download, LAN oder Disketten). Nachdem der Assistent für die Internet Explorer-Anpassung Ihr Paket erstellt hat, müssen Sie die Dateien auf das ausgewählte Medium verschieben. Wenn Sie ein downloadbares Paket erstellt haben, müssen Sie das Paket in das entsprechende Verzeichnis auf Ihrem Server verschieben.

Wenn Sie Ihr Browserpaket auf einem Internetserver bereitstellen möchten, müssen Sie den Pfad zum Server sowie den URL kennen, von dem die Dateien gedownloadet werden. Erstellen Sie dann einen Ordner auf dem Webserver, beispielsweise CIE, in den Sie alle Dateien und Ordner kopieren, die zu Ihrem angepassten Browser gehören. Sie können beispielsweise den Serverpfad C:\Inetpub\Wwwroot\Cie erstellen. Wenn Computername das virtuelle Stammverzeichnis für diesen Webserver ist, lautet der entsprechende URL http://Computername/Cie/.

Erwerben Sie ein digitales Zertifikat

Treffen Sie die grundlegenden Vorbereitungen für das Signieren bestimmter Dateien, beispielsweise der vom Assistenten für die Internet Explorer-Anpassung erstellten Anpassungsdateien sowie aller angepassten Komponenten, falls Sie die Dateien über das Internet bzw. über ein Intranet bereitstellen, das nicht speziell konfiguriert wurde. Durch die Sicherheitsfeatures des Browsers werden Benutzer davor gewarnt oder daran gehindert, nicht signierte Dateien zu downloaden. Digitale Signaturen identifizieren die Quelle von Programmen und garantieren, dass der Code seit dem Signieren nicht geändert wurde.

Der Assistent für die Internet Explorer-Anpassung kann Ihre Dateien signieren, falls Sie über ein Veröffentlichungszertifikat einer Zertifizierungsstelle verfügen. Um die Zertifikate für die Verwendung durch den IEAK vorzubereiten, können Sie diese mit dem Assistenten für Zertifikatimport auf Ihren Computer importieren. Falls Sie eine Datei mit der Erweiterung .SPC erhalten haben, können Sie den Assistenten für den Zertifikatimport starten, indem Sie in Windows-Explorer oder Arbeitsplatz auf die .SPC -Datei klicken.

Die Zertifikatverwaltung kann außerdem von Internet Explorer aus geöffnet werden. Klicken Sie dazu auf das Menü Extras und dann auf Internetoptionen. Wählen Sie anschließend die Registerkarte Inhalt aus, und klicken Sie auf Zertifikate. Klicken Sie auf Importieren, um den Assistenten für Zertifikatimport zu starten, und folgen Sie dann den Schritten im Assistenten.

Erstellen Sie die Verzeichnisstruktur auf dem Computer, auf dem Sie das Paket erstellen

Erstellen Sie die folgende Ordnerstruktur:

Ordnername | Beschreibung
\CIE | Übergeordnetes Stammverzeichnis für alle von IEAK erstellten und vom angepassten Paket verwendeten Dateien
\CIE\Custom | Angepasste Dateien (wie beispielsweise Signup.isp, Signup.htm, Icwsign.htm, Install.ins und Cancel.ins, entsprechend der gewählten Anmeldemethode) für serverbasierte Anmeldung
\CIE\Dist | Zielverzeichnis für die Dateien (dieser Ordner ist nur erforderlich, wenn Sie Ihr Browserpaket auf einer Festplatte oder einem Netzlaufwerk erstellen)
\CIE\Bitmaps | Angepasste Bitmapdateien (für Ihren angepassten Browser benötigte Grafikdateien)

So kopieren Sie die erforderlichen Anmeldedateien in die Ordnerstruktur

  1. Markieren Sie alle Dateien in den folgenden Unterordnern, in denen IEAK installiert ist: \<IEAK-Programmordner>\Toolkit\Isp\Servless für serverlose Internetanmeldung oder <IEAK-Programmordner>\Toolkit\Isp\Server\ für serverbasierte Internetanmeldung.
  2. Kopieren Sie diese Dateien in das Verzeichnis CIE\Custom.

Legen Sie ein Anmeldeverfahren fest und passen Sie die Anmeldedateien an

In Ihrem angepassten Paket können Sie festlegen, auf welche Weise sich Benutzer bei Ihrem Dienst anmelden und eine Verbindung zum Internet herstellen können. Sie können einen serverbasierten oder einen serverlosen Anmeldevorgang wählen oder auch die Anmeldemöglichkeit ganz deaktivieren (zur Distribution von Softwareupdates an vorhandene Benutzer). Im IEAK-Toolkit finden Sie Beispieldateien für HTML-Seiten, die jeweils diese Anmeldeverfahren unterstützen.

Weitere Informationen über die verschiedenen Optionen finden Sie unter Internetanmeldeoptionen.

Eine Schemadarstellung des Anmeldevorgangs finden Sie unter ISP-Anmeldevorgang.

Erstellen Sie die gewünschten Grafiken

Sie haben die Möglichkeit, die folgenden Bitmaps in Ihrem Browser anzupassen. Speichern Sie die Bitmaps im Ordner \CIE\Bitmaps, bevor Sie den Assistenten für die Internet Explorer-Anpassung ausführen.

Der angepasste Hintergrund und die Schaltflächen werden nur auf Computern angezeigt, die 256 Farben (8-Bit) darstellen können. Auf Computern, die 16 Farben (4-Bit) darstellen können, werden eine Standardhintergrundbitmap und Schaltflächen mit geringer Auflösung angezeigt.

  • Eine Hintergrundbitmap für den automatischen CD-ROM-Begrüßungsbildschirm (wenn Sie ein CD-ROM-Paket erstellen).

    Wenn Sie planen, Ihren angepassten Browser auf einer CD zu vertreiben, müssen Sie Bitmaps als Teil des automatischen Begrüßungsbildschirms erstellen, der angezeigt wird, nachdem der Benutzer die CD in das CD-ROM-Laufwerk eingelegt hat. Wie Sie diese Bitmap erstellen, erfahren Sie unter Erstellen einer Bitmap für den automatischen Begrüßungsbildschirm.

  • Angepasste Grafiken für die CD-ROM-Schaltflächen (wenn Sie ein CD-ROM-Paket erstellen).
  • Zwei angepasste Bitmaps für den Assistenten für Windows Update Setup (falls Sie dessen Erscheinungsbild ändern möchten): Eine Bitmap im Format 162x312 Pixel für die linke Seite des ersten Bildschirms des Assistenten sowie eine Bitmap im Format 496x56 Pixel für den oberen Rand der übrigen Bildschirme des Assistenten.
  • Eine angepasste Symbolleistenbitmap (die als Hintergrund der Schaltflächen und Menüs angezeigt wird).
  • Zwei statische 256-Farben-Bitmapbilder (das eine im Format 38x38 Pixel, das andere im Format 22x22 Pixel), die Sie als eigenes Logo in den Internet Explorer einfügen können.
  • Zwei animierte 256-Farben-Bitmapbilder mit (das eine im Format 38x38 Pixel, das andere im Format 22x22 Pixel), die Sie als eigenes animiertes Logo in den Internet Explorer einfügen können.

    Zwei Tools sind in IEAK enthalten, die Sie beim Erstellen und Anzeigen angepasster, animierter Bitmaps für Ihren Browser unterstützen. Informationen zur Verwendung dieser Tools finden Sie unter Tools für animierte Bitmaps.

Eine vollständige Liste aller Grafiken finden Sie unter Erstellen angepasster Grafiken.

Ermitteln Sie die URLs für die Start-, Such- und Supportseiten

Es ist sinnvoll, eine Supportseite zu erstellen, die angezeigt wird, wenn Ihre Benutzer beim Installieren des Browsers auf Probleme stoßen. Wenn Sie den Assistenten zur Internet Explorer-Anpassung ausführen, werden Sie zum Eingeben der URLs dieser Seiten aufgefordert.

Anmerkungen

  • Weitere Informationen zum Setup-Programm finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.


Internetdienstanbieter: Schritt 1 des Assistenten: Informationen sammeln

Internet-
dienstanbieter

Schritt 1 des Assistenten: Informationen sammeln

In diesem Schritt des Assistenten zur Internet Explorer-Anpassung werden Internetdienstanbieter aufgefordert, folgende Angaben zu machen:

  • Firmenname und zehnstelliger Anpassungscode. Der Anpassungscode befindet sich bei den weiteren Informationen zu Ihrem Administration Kit, die Sie von Microsoft erhalten haben.
  • Ihre Funktion entsprechend dem Ihrem Lizenzvertrag. Sie müssen angeben, ob Sie Inhaltsanbieter oder Entwickler, Dienstanbieter oder Firmenadministrator sind.
  • Speicherort der Dateien zur Erstellung des angepassten Browserpakets.
  • Sprache des Browserpakets, das Sie erstellen. Sie müssen den Assistenten für die Internet Explorer-Anpassung für jede internationale Version ausführen, die erstellt werden soll.
  • Distributionsmedien, die Sie einsetzen möchten, beispielsweise CD-ROM oder Download.
  • Features, die angepasst werden sollen. Beispielsweise müssen Sie nicht alle Bildschirme des IEAK-Assistenten zu durchlaufen, wenn Sie nur geringfügige Änderungen am Browser vornehmen möchten.

Anmerkung

  • Der Assistent für die Internet Explorer-Anpassung wird nur dann ordnungsgemäß ausgeführt, wenn Internet Explorer 5.5 installiert ist. Weitere Informationen finden Sie unter Hardware- und Systemanforderungen.


Internetdienstanbieter: Schritt 2 des Assistenten: Angabe der Setup-Parameter

Internet-
dienstanbieter

Schritt 2 des Assistenten: Angabe der Setup-Parameter

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung werden Internetdienstanbieter aufgefordert, folgende Maßnahmen durchzuführen:

  • Downloaden oder Aktualisieren aller Microsoft-Komponenten mit Hilfe der Automatischen Versionssynchronisierung (AVS). Sie müssen Internet Explorer downloaden, aber Sie können selbst festlegen, welche anderen Komponenten von Internet Explorer gedownloadet werden sollen.
  • Auswählen aller angepassten Komponenten, die einbezogen werden sollen.

    Sie können bis zu zehn weitere Komponenten angeben. Bei diesen Komponenten handelt es sich um selbst extrahierende Dateien (.EXE) oder um komprimierte Kabinettdateien (.CAB).


Internetdienstanbieter: Schritt 3 des Assistenten: Anpassen von Setup

Internet-
dienstanbieter

Schritt 3 des Assistenten: Anpassen von Setup

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung können Internetdienstanbieter festlegen, wie das Windows Update Setup-Programm aussehen und arbeiten soll:

  • Anpassen des automatischen Begrüßungsbildschirms bei CD-ROMS, falls Sie ein CD-ROM-Paket erstellen.
  • Anpassen weiterer CD-ROM-Optionen, wenn Sie ein CD-ROM-Paket erstellen.
  • Anpassen des Assistenten für Windows Update Setup für Internet Explorer und andere Internetprogramme. Diese Einstellungen beeinflussen den optischen Eindruck des Setup-Programms für den Benutzer.
  • Festlegen von bis zu zehn verschiedenen Installationsoptionen und Angeben der bei den unterschiedlichen Optionen jeweils einbezogenen Komponenten.
  • Festlegen von bis zu 10 Sites, von denen der Downloadvorgang für das Paket stattfinden soll.
  • Festlegen, wie Benutzer Aktualisierungen für ihre Komponenten erhalten.
  • Festlegen, ob das Setup-Programm vorhandene Komponenten erkennt, und Feinabstimmung, welche Komponenten von Benutzern angepasst werden können.
  • Festlegen, ob gedownloadete, jedoch nicht in alle Pakete eingefügte Komponenten den Benutzern über das Internet Explorer-Feature Installation bei Bedarf zur Verfügung gestellt werden.
  • Importieren eines angepassten Profils aus dem Connection Manager Administration Kit (CMAK).
  • Festlegen der Angaben zur Zertifizierungsstelle, falls Sie ein digitales Zertifikat besitzen, damit das Signieren der Programme während der Erstellung des IEAK-Pakets erfolgen kann.

Anmerkungen

  • Weitere Informationen zum Setup-Programm finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.
  • Ein Flussdiagramm zur Erläuterung der Prozesse bei der Verwendung des Assistenten für die Internet Explorer-Anpassung bei der Erstellung von angepassten Paketen erhalten Sie unter Erstellen angepasster Pakete mit IEAK.


Internetdienstanbieter: Schritt 4 des Assistenten: Anpassung des Browsers

Internet-
dienstanbieter

Schritt 4 des Assistenten: Anpassung des Browsers

In diesem Schritt des Assistenten zur Internet Explorer-Anpassung können Internetdienstanbieter die folgenden Objekte anpassen:

  • Die Titelleiste des Browsers und die Hintergrundbitmap der Symbolleiste. Wenn Sie eine Bitmap auswählen, stellen Sie sicher, dass die Farben gegenüber dem Text genügend Kontrast lassen.
  • Symbolleistenschaltflächen des Browsers. Sie können angepasste Symbolleistenschaltflächen hinzufügen, um Skripts und Programme auszuführen.
  • Das animierte Internet Explorer-Logo in der oberen rechten Ecke des Browsers.
  • Start-, Such- und Onlinesupportseiten des Browsers.
  • Favoriten, Favoritenordner und Links der Linkleiste.
  • Channels. Sie können einen Channel oder eine Channelkategorie hinzufügen. Channelkategorien sind Ordner, die Channels enthalten.
  • "Willkommen"-Seite, die angezeigt wird, wenn die Benutzer ihren Browser zum ersten Mal starten.
  • Benutzeragententext. Der Benutzeragentbezeichner ist optional; er stellt ein Verfahren zum Verfolgen des Einsatzes Ihres angepassten Browsers dar.
  • Die Verbindungseinstellungen des Benutzers durch Anpassen der Einstellungen, Importieren der Einstellungen oder Löschen der vorhandenen Einstellungen des Benutzers.
  • Proxyeinstellungen.
  • Ursprungszertifikat.
  • Methode der Benutzeranmeldung.
  • Anmeldedateien. Sie können den Pfad zu dem Ordner angeben, der die Anmeldedateien enthält, und entscheiden, ob Sie diese Dateien bearbeiten möchten.
  • Parameter für die DFÜ-Netzwerkverbindung und Dateien für Interneteinstellungen, welche die Kunden verwenden, um eine Verbindung zu Ihrem Internetanmeldeserver herzustellen.
  • Einstellungen des Assistenten für den Internetzugang, falls Benutzer diesen Assistenten zur Anmeldung zu Ihren Diensten nutzen.

Anmerkungen

  • Weitere Informationen zum Setup-Programm finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.


Internetdienstanbieter: Schritt 5 des Assistenten: Komponentenanpassung

Internet-
dienstanbieter

Schritt 5 des Assistenten: Komponentenanpassung

In diesem Schritt des Assistenten zur Internet Explorer-Anpassung können Internetdienstanbieter die folgenden Objekte anpassen:

  • Einstellung der Standardprogramme, wie z. B. die Standardprogramme für E-Mail und zur Bearbeitung von HTML-Dateien.
  • News- und Mail-Server der Benutzer, falls Sie Outlook Express in das angepasste Paket aufnehmen.
  • Einstellungen der IMAP-E-Mail-Server für die Benutzer, falls Sie Outlook Express verteilen und einen IMAP-Server einsetzen.
  • Angepasste Inhalte in Outlook Express, beispielsweise durch Erstellen einer eigenen E-Mail-Nachricht zur Begrüßung neuer Benutzer und durch Anpassen des Infobereichs, der Benutzern beim Programmstart angezeigt wird.
  • Angepasste Einstellungen für Outlook Express, wie standardmäßige Mail- und News-Clients, Hilfe für Benutzer, die weitere Mailkonten benötigen, und eine Datei mit standardmäßigen Nachrichtenregeln für die Benutzer.
  • Einstellungen der Benutzeroberfläche von Outlook Express, beispielsweise Anzeigen oder Ausblenden der Ordnerleiste, der Ordnerliste, der MSN Messenger-Kontakte, der Statusleiste oder der Outlook-Leiste.
  • Einstellungen der Nachrichtenerstellung in Outlook Express, wenn Sie einen Rechtsvorbehalt oder eine Signatur für Beiträge in Internet-Newsgroups oder E-Mail-Nachrichten verwenden möchten.
  • Verzeichnisdienst des Windows-Adressbuchs, wenn Sie den Benutzern Internetverzeichnisdienste anbieten und LDAP (Lightweight Directory Access Protocol)-Server anpassen möchten.
  • Branding-Informationen in MSN Messenger Service, falls Ihr Paket eine angepasste Version des Messenger Service-Clients beinhaltet.
  • Medienelemente in MSN Messenger Service, wenn Grafiken, Werbungen oder Soundelemente geändert werden sollen, die bei einer angepassten Installation des Messenger Service-Clients angezeigt werden.
  • Konteninformationen in MSN Messenger Service, wenn die in der angepassten Installation des Messenger Service-Clients verwendeten Passport-Standardkonten bzw. Einstellungen für die E-Mail-Integration geändert werden sollen.
  • Systemrichtlinien und Einstellungen zur Voreinstellung von Internetoptionen.


Internetdienstanbieter: Verteilen Ihres Browserpakets

Internet-
dienstanbieter

Verteilen Ihres Browserpakets

Standardmäßig erstellt der Assistent für die Internet Explorer-Anpassung Dateien, welche die Benutzer aus dem Internet downloaden können. Sie können ein angepasstes Browserpaket jedoch auch auf einer CD verteilen. Eine vollständige Liste der möglichen Distributionsmedien erhalten Sie unter Auswahl der Medien.

Downloadbare Dateien

Internetdienstanbieter können Benutzern eine einzelne Datei zur Verfügung stellen, welche das Installationsmodul enthält. Dies führt dann den Download der Anwendungskomponenten von einem Internetserver aus.

Wenn Sie das Browserpaket auf einem Internetserver erstellt haben, müssen Sie Ihre Website so einrichten, dass Benutzer die Dateien downloaden können. Sie können beispielsweise eine Seite erstellen, auf der Sie Downloadinformationen sowie einen Link für das Installationsmodul IE5setup.exe hinterlegen.

Wenn Sie das Browserpaket auf Ihrer Festplatte oder einem Netzlaufwerk erstellt haben, müssen Sie die folgenden Objekte auf Ihren Internet- oder Intranetserver verschieben:

  • Den Ordner, der die Sprachversion und die Ordnerinhalte enthält, die Sie hinterlegen. Angenommen, der Ordner für die englische Version heißt En, dann müssen Sie den Ordner En sowie die Dateien, die er enthält, verschieben. Dieser Ordner befindet sich in den Ordnern für den gewählten Medientyp, wie z. B. Download, und die gewünschte Plattform. IEAK 5.5 unterstützt nur die Plattform "Win32". Zum Anpassen von UNIX- und 16-Bit-Windows-Clients müssen Sie IEAK 5.0x verwenden.
  • Die Datei namens Ie5sites.dat. Diese Datei zeigt auf die Downloadsite (oder die Sites), die Sie beim Ausführen des Assistenten für die Internet Explorer-Anpassung angegeben haben.

    • Eine Abbildung hierzu finden Sie unter Bereitstellen von Dateien für die Distribution.

    Ein Flussdiagramm zur Erläuterung der durch den Assistenten für die Internet Explorer-Anpassung erstellten Dateien erhalten Sie unter Erstellen angepasster Pakete mit IEAK.

Signieren Ihrer angepassten Pakete

Webbrowser haben Sicherheitsfeatures, die verhindern, dass Benutzer schädliche Programme downloaden. Abhängig von der Sicherheitsstufe und der Plattform kann das Downloaden von Programmen verhindert oder eine Warnung ausgegeben werden, wenn diese Programme nicht digital signiert sind.

Die angepassten .CAB-Dateien, die vom Assistenten für die Internet Explorer-Anpassung erstellt wurden, sollten signiert werden. Dies erübrigt sich jedoch, wenn Sie die lokale Intranetzone mit der Sicherheitseinstellung Niedrig bzw. Sehr niedrig vorkonfigurieren. Alle angepassten Komponenten, die mit Ihrem Browserpaket für diese Plattformen verteilt werden, sollten ebenfalls signiert werden. Wenn Sie über ein digitales Zertifikat verfügen, kann der Assistent für die Internet Explorer-Anpassung diese Dateien automatisch signieren.

Anmerkungen

  • Für das Signieren der Kabinettdateien und der angepassten Programme sind zwei Schritte erforderlich: Anfordern eines digitalen Zertifikats und Angeben der Zertifikatsinformationen beim Ausführen des Assistenten für die Internet Explorer-Anpassung. Weitere Informationen hierzu finden Sie unter Signieren Ihrer Programme.
  • Möglicherweise müssen Sie die Groß-/Kleinschreibung bei Namen von Dateien ändern, die auf einem FTP-Server bereitgestellt werden sollen, der UNIX ausführt. Im Folgenden sind die Richtlinien aufgeführt, die Sie für bestimmte UNIX-Betriebssysteme beachten sollten.
    • Solaris UNIX
      Bei Verwendung eines FTP-Servers, der UNIX ausführt und bei dem Groß-/Kleinschreibung relevant ist, müssen Sie sicherstellen, dass der Name Ihres .CAB-Ordners nicht groß geschrieben wird. Folgende Dateinamen werden jedoch in Großbuchstaben angegeben: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB und IE5SITES.DAT.
    • AT&T UNIX
      Auf einem AT&T UNIX FTP-Server müssen alle Dateinamen groß geschrieben werden.
    • IRIX UNIX (Silicon Graphics)
      Folgende Dateinamen müssen groß geschrieben werden: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB und IE5SITES.DAT. Außerdem sollten Sie die in IE.CIF aufgeführten Dateinamen mit einem Texteditor so ändern, dass sie mit der tatsächlichen Schreibweise der Dateien übereinstimmen.

CD-ROM

Wenn Sie den angepassten Browser für Benutzer von Windows 95 vertreiben, wird der Begrüßungsbildschirm eines Autorun-Programms angezeigt, sobald der Benutzer die CD einlegt. Dieses Programm bietet dem Benutzer die Wahl, entweder den angepassten Browser zu installieren oder weitere Informationen anzuzeigen. Wenn die aktuelle Version von Internet Explorer bereits installiert ist, erkennt das Autorun-Programm dies. Der Browser wird im sogenannten Kioskmodus angezeigt, wenn die Datei Start.htm geladen wird.

Weitere Informationen

Weitergehende Informationen zu Windows Update Setup finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme. Eine Schemadarstellung des Downloadvorgangs finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.


Internetdienstanbieter: Verfahren zur Verteilung Ihres Messenger Service-Clients

Internet-
dienstanbieter

Verfahren zur Verteilung Ihres Messenger Service-Clients

Falls Sie MSN Messenger Service als eine Installationsoption integriert haben, erstellt der Assistent für die Internet Explorer-Anpassung ein separates Paket für den Download des angepassten Messenger Service-Clients aus dem Internet.

Downloadbare Dateien

Wenn Sie das Messenger Service-Clientpaket auf einem Internetserver erstellt haben, sollten Sie Ihre Website so einrichten, dass Benutzer die Dateien downloaden können. Beispielsweise können Sie eine Seite erstellen, die Downloadinformationen sowie einen Link zum Installationsprogramm (Mmssetup.exe) für den Messenger Service-Client enthält.

Wenn Sie die Datei Mmssetup.exe auf Ihrer Festplatte oder einem Netzlaufwerk erstellt haben, müssen Sie die Dateien für alle bereitgestellten Sprachversionen auf einen Internetserver verschieben. Im Messenger-Ordner Ihres Versionsverzeichnisses wird für jede Sprachversion ein Unterordner erstellt. So befindet sich beispielsweise die englische Version von Mmssetup.exe im Unterordner En. Falls Sie bei der Anpassung einen Download-URL angegeben haben, erstellen Sie auf dieser Downloadseite einen Link zur Datei Mmssetup.exe. Alle für die Distribution der angepassten Version des Messenger Service-Clients erforderlichen Komponenten sind in dieser ausführbaren Datei enthalten.

Signieren der Messenger Service-Clientinstallation

Wenn Sie beim Ausführen des IEAK-Assistenten ein digitales Zertifikat für das Signieren des Browserpakets festgelegt haben, wird dieses Zertifikat auch für das Signieren der alleinstehenden Programmversion von Mmssetup.exe verwendet. Weitergehende Informationen erhalten Sie unter Digitale Signaturen und unter Signieren Ihrer Programme.

Messenger Service-Clients als Komponente Ihres Browserpakets

Der angepasste Messenger Service-Client wird auch als Komponente des Browserpakets installiert, wenn Sie festgelegt haben, dass MSN Messenger Service in den Installationsoptionen enthalten ist. Für den angepassten Messenger Service-Client wird eine eigene .CAB-Datei erstellt, und der Client wird bei der Ausführung von Ie5setup.exe als Komponente installiert. Nähere Einzelheiten zur Distribution des kompletten Browserpakets finden Sie unter Verteilen Ihres Browserpakets.

Messenger Service-Clients und Firewalls

Wenn Sie erweiterte Proxyeinstellungen zur Nachrichtenübermittlung über Firewalls hinweg benötigen, sollten Sie keinen Download-URL festlegen. Darüber hinaus müssen Sie Text bearbeiten, um eine Setup-Datei zur Vorkonfiguration der Proxyoptionen zu erstellen. Weitergehende Informationen erhalten Sie unter Erweiterte Anpassung für den Messenger Service-Client.


Übersicht für Firmenadministratoren

Microsoft Internet Explorer Administration Kit (IEAK) ermöglicht das Erstellen einer angepassten automatischen Installation von Microsoft Internet Explorer, die den Anforderungen Ihrer Organisation entspricht.

Sie können dieses Kit verwenden, um die folgenden Aufgaben zu erledigen:

Anpassen des Setup-Programms

  • Anpassen des Erscheinungsbildes des Windows Update Setup-Programms und Konfigurieren von Installationsmodi (beispielsweise Standard- oder Minimale Installation).
  • Verweisen auf Internet- oder Intranetserver, damit die Benutzer die aktuellsten Produktversionen erhalten.
  • Integrieren interner Programme, angepasster Skripts oder Wartungsskripts in die Internet Explorer-Installation bei den Benutzern.
  • Angeben der Sprachversion von Internet Explorer, die im Installationspaket enthalten sein soll. Sie müssen den Assistenten für die Internet Explorer-Anpassung für jede Sprachversion, die Sie erstellen möchten, einmal ausführen.

Anpassen von Browser und Windows Desktop Update

  • Angeben der Start-, Such- und Supportseiten, die Sie verwenden möchten.
  • Aufnehmen von Links und Ordnern in die Favoritenliste.
  • Ändern der Titelleiste und der Logos des Browsers.
  • Konfigurieren und Steuern der Windows Desktop-Aktualisierung einschließlich Active Desktop-Objekten, Desktopsymbolleisten, der Systemsteuerung und des Arbeitsplatzes.
  • Steuern, welche Channels auf Ihren Firmendesktops angezeigt werden.
  • Erstellen eines Standarddesktops für Ihre Organisation und Festlegen der Einstellungen, die ein Benutzer ändern kann.

Eine Abbildung zur Anwendung von Branding-Informationen auf ein Paket erhalten Sie unter Anpassungsmöglichkeiten.

Verwalten der Sicherheit und der Bewertungen

  • Vorinstallieren von Zertifikaten auf dem Computer eines Benutzers und Verhindern, dass Benutzer andere Zertifikate downloaden.
  • Voreinstellen der Bewertungskonfigurationen Ihrer Benutzer entsprechend der Firmenrichtlinien.
  • Einstellen eines Firmen-Standardrechtsvorbehalts für beliebige Newsgroup-Beiträge, die von Benutzern in Ihrer Organisation erstellt werden.
  • Verwenden von Sicherheitszonen, um verschiedene Sicherheitsebenen und Vertrauenszonen einzurichten.
  • Festlegen von Proxyeinstellungen für Adressen und Anschlüsse.

Wichtig

  • In Abhängigkeit von Ihrem Lizenzvertrag stehen einige Features möglicherweise nicht zur Verfügung. Weitere Informationen finden Sie in Ihrem Vertrag.


Firmenadministrator: Vorbereiten der Ausführung des Assistenten

Firmen-
administrator

Vorbereiten der Ausführung des Assistenten

Vor der Ausführung des Assistenten für die Internet Explorer-Anpassung sollten Sie die benötigten Informationen bereithalten und angepasste Bitmaps erstellen.

Ermitteln Sie die grundsätzlichen Plattformanforderungen

  • Stellen Sie sicher, dass der Computer, auf dem Sie Ihr Paket erstellen, sowie die Computer, auf denen Sie Ihr Paket installieren, den Hardware- und Systemanforderungen entsprechen.
  • Ermitteln Sie die Verschlüsselungsebenen für Ihre Browserpakete. Informationen zur Verschlüsselung unter Internet Explorer finden Sie auf der IEAK-Website.

Entscheiden Sie sich für ein Distributionsverfahren

Entscheiden Sie, wie Sie Ihr angepasstes Paket verteilen möchten (CD, Download, LAN oder Disketten). Nachdem der Assistent für die Internet Explorer-Anpassung Ihr Paket erstellt hat, müssen Sie die Dateien entsprechend dem ausgewählten Medium verschieben. Wenn Sie ein downloadbares Paket erstellt haben, müssen Sie das Paket in das entsprechende Verzeichnis auf Ihrem Server verschieben.

Wenn Sie Ihr Browserpaket auf einem Internetserver bereitstellen möchten, müssen Sie den Pfad zum Server sowie den URL kennen, von dem die Dateien gedownloadet werden. Erstellen Sie dann einen Ordner auf dem Webserver, beispielsweise CIE, in den Sie alle Dateien und Ordner kopieren, die zu Ihrem angepassten Browser gehören. Sie können beispielsweise den Serverpfad C:\Inetpub\Wwwroot\Cie erstellen. Wenn Computername das virtuelle Stammverzeichnis für diesen Webserver ist, lautet der entsprechende URL http://Computername/Cie/.

Erwerben Sie ein digitales Zertifikat

Treffen Sie die grundlegenden Vorbereitungen für das Signieren bestimmter Dateien, beispielsweise der vom Assistenten für die Internet Explorer-Anpassung erstellten Anpassungsdateien sowie aller angepassten Komponenten, falls Sie die Dateien über das Internet bzw. über ein Intranet bereitstellen, das nicht speziell konfiguriert wurde. Durch die Sicherheitsfeatures des Browsers werden Benutzer davor gewarnt oder daran gehindert, nicht signierte Dateien zu downloaden. Digitale Signaturen identifizieren die Quelle von Programmen und garantieren, dass der Code seit dem Signieren nicht geändert wurde.

Der Assistent für die Internet Explorer-Anpassung kann Ihre Dateien signieren, falls Sie über ein Veröffentlichungszertifikat einer Zertifizierungsstelle verfügen. Um die Zertifikate für die Verwendung durch den IEAK vorzubereiten, können Sie diese mit dem Assistenten für Zertifikatimport auf Ihren Computer importieren. Falls Sie eine Datei mit der Erweiterung .spc erhalten haben, können Sie den Assistenten für den Zertifikatimport starten, indem Sie in Windows-Explorer oder Arbeitsplatz auf die .SPC-Datei klicken.

Die Zertifikatverwaltung kann außerdem von Internet Explorer aus geöffnet werden. Klicken Sie dazu auf das Menü Extras und dann auf Internetoptionen. Wählen Sie anschließend die Registerkarte Inhalt aus, und klicken Sie auf Zertifikate. Klicken Sie auf Importieren, um den Assistenten für Zertifikatimport zu starten, und folgen Sie dann den Schritten auf dem Bildschirm.

Entscheiden Sie, ob Sie die Windows Desktop-Aktualisierung für Ihre Firma konfigurieren möchten.

Erstellen Sie auf dem Computer, auf dem Sie das Paket erstellen, die Verzeichnisstruktur

Ordnername | Beschreibung
\CIE | Übergeordnetes Stammverzeichnis für alle von IEAK erstellten und vom angepassten Paket verwendeten Dateien
\CIE\Bitmaps | Angepasste Bitmapdateien (für Ihren angepassten Browser benötigte Grafikdateien)

Erstellen Sie die gewünschten Grafiken

Optional können Sie die folgenden Bitmaps in Ihrem Browser anpassen. Speichern Sie die Bitmaps im Ordner \CIE\Bitmaps, bevor Sie den Assistenten für die Internet Explorer-Anpassung ausführen.

Der angepasste Hintergrund und die Schaltflächen werden nur auf Computern angezeigt, die 256 Farben (8-Bit) darstellen können. Auf Computern, die 16 Farben (4-Bit) darstellen können, werden eine Standardhintergrundbitmap und Schaltflächen mit geringer Auflösung angezeigt.

  • Eine Hintergrundbitmap für den automatischen CD-ROM-Begrüßungsbildschirm (wenn Sie ein CD-ROM-Paket erstellen).

    Wenn Sie planen, Ihren angepassten Browser auf einer CD zu vertreiben, müssen Sie Bitmaps als Teil des automatischen Begrüßungsbildschirms erstellen, der angezeigt wird, nachdem der Benutzer die CD in das CD-ROM-Laufwerk eingelegt hat. Wie Sie diese Bitmap erstellen, erfahren Sie unter Erstellen einer Bitmap für den automatischen Begrüßungsbildschirm.

  • Angepasste Grafiken für die CD-ROM-Schaltflächen (wenn Sie ein CD-ROM-Paket erstellen).
  • Zwei angepasste Bitmaps für den Assistenten für Windows Update Setup (falls Sie dessen Erscheinungsbild ändern möchten): Eine 162x312-Pixel-Bitmap für die linke Seite des ersten Bildschirms des Assistenten sowie eine 496x56-Pixel-Bitmap für den oberen Rand der übrigen Bildschirme des Assistenten.
  • Eine angepasste Symbolleistenbitmap (die als Hintergrund der Schaltflächen und Menüs angezeigt wird).
  • Zwei statische Bitmapgrafiken mit 256 Farben (eine 38x38-Pixel-Grafik und eine 22x22-Pixel-Grafik), die Sie verwenden können, um den Internet Explorer-Browser mit Ihrem Logo zu versehen.
  • Zwei animierte Bitmapgrafiken mit 256 Farben (eine 38x38-Pixel-Grafik und eine 22x22-Pixel-Grafik), die Sie verwenden können, um den Internet Explorer-Browser mit einem animierten Logo zu versehen.

    Zwei Tools sind in IEAK enthalten, die Sie beim Erstellen und Anzeigen angepasster, animierter Bitmaps für Ihren Browser unterstützen. Informationen zur Verwendung dieser Tools finden Sie unter Tools für animierte Bitmaps.

Eine vollständige Liste aller Grafiken finden Sie unter Erstellen angepasster Grafiken.

Ermitteln Sie die URLs für die Start-, Such- und Supportseiten

Es ist sinnvoll, eine Unterstützungsseite zu erstellen, die angezeigt wird, wenn Ihre Benutzer beim Installieren des Browsers auf Probleme stoßen. Wenn Sie den Assistenten zur Internet Explorer-Anpassung ausführen, werden Sie zur Eingabe der URLs dieser Seiten aufgefordert.

Planen Sie Ihre Sicherheits- und Windows Desktop-Aktualisierungsstrategien

Sie können viele der Benutzeroptionen anpassen und steuern, beispielsweise die Sicherheit und die Windows Desktop-Aktualisierung.. Sie sollten Ihre Strategie planen, bevor Sie den Assistenten zur Internet Explorer-Anpassung ausführen.

Anmerkungen

  • Weitere Informationen zum Setup finden Sie unter Setup für Windows Update für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.


Firmenadministrator: Schritt 1 des Assistenten: Informationen sammeln

Firmen-
administrator

Schritt 1 des Assistenten: Informationen sammeln

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung wird der Firmenadministrator aufgefordert, folgende Informationen einzugeben:

  • Firmenname und zehnstelliger Anpassungscode. Der Anpassungscode befindet sich bei den weiteren Informationen zu Ihrem Administration Kit, die Ihnen von Microsoft zugesandt wurden.
  • Ihre Rolle entsprechend dem Lizenzvertrag. Sie müssen angeben, ob Sie Inhaltsanbieter oder -entwickler, Dienstanbieter oder Firmenadministrator sind.
  • Der Speicherort der Dateien, an dem das angepasste Browserpaket erstellt werden soll.
  • Die Sprache des Browserpakets, das Sie erstellen. Sie müssen den Anpassungsassistenten für jede internationale Version ausführen, die erstellt wird.
  • Die Vertriebsmedien, die Sie zu verwenden beabsichtigen, beispielsweise CD-ROM oder Download über ein Intranet oder das Internet.
  • Die Features, die angepasst werden sollen. Beispielsweise müssen nicht alle Bildschirme des IEAK-Assistenten angezeigt werden, wenn Sie nur geringfügige Änderungen am Browser vornehmen möchten.

Anmerkung

  • Der Assistent für die Internet Explorer-Anpassung kann nur dann ordnungsgemäß ausgeführt werden, wenn Internet Explorer 5.5 installiert ist. Weitere Informationen finden Sie unter Hardware- und Systemanforderungen.


Firmenadministrator: Schritt 2 des Assistenten: Angabe der Setup-Parameter

Firmen-
administrator

Schritt 2 des Assistenten: Angabe der Setup-Parameter

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung wird der Firmenadministrator aufgefordert, folgende Schritte durchzuführen:

  • Downloaden oder Aktualisieren der Microsoft-Komponenten mit Hilfe der Automatischen Versionssynchronisierung (AVS). Sie müssen Internet Explorer downloaden, aber Sie können selbst festlegen, welche anderen Komponenten von Internet Explorer gedownloadet werden sollen.
  • Auswählen der angepassten Komponenten, die eingeschlossen werden sollen.

    Sie können bis zu zehn weitere Komponenten angeben. Bei diesen Komponenten handelt es sich um selbst extrahierende Dateien (.EXE) oder um komprimierte Kabinettdateien (.CAB).


Firmenadministrator: Schritt 3 des Assistenten: Anpassen von Setup

Firmen-
administrator

Schritt 3 des Assistenten: Anpassen von Setup

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung kann der Firmenadministrator Erscheinungsbild und Funktionalität des Windows Update Setup-Programms festlegen:

  • Anpassen des automatischen Begrüßungsbildschirms einer CD-ROM, wenn Sie ein CD-ROM-Paket erstellen.
  • Anpassen weiterer CD-ROM-Optionen, wenn Sie ein CD-ROM-Paket erstellen.
  • Anpassen des Assistenten für Windows Update Setup für Internet Explorer und andere Internetprogramme. Diese Einstellungen beeinflussen das Erscheinungsbild des Setup-Programms.
  • Festlegen, ob das Paket "nicht sichtbar" installiert werden soll, also automatisch, ohne oder mit nur wenigen Eingabeaufforderungen für die Benutzer.
  • Festlegen von bis zu zehn verschiedenen Installationsoptionen und der bei den unterschiedlichen Optionen jeweils enthaltenen Komponenten.
  • Festlegen von bis zu zehn Sites, von denen der Downloadvorgang für das Paket stattfinden soll. Sie können bis zu zehn Sites angeben, es sei denn, Sie führen als Firmenadministrator eine automatische Installation durch.
  • Festlegen, wie Benutzer Aktualisierungen für ihre Komponenten erhalten.
  • Festlegen, an welchem Speicherort Internet Explorer auf den Computern Ihrer Benutzer installiert werden soll, und ob Benutzer den Installationsordner ändern können.
  • Festlegen, ob Benutzer Setup anpassen können, ob Deinstallationsinformationen installiert werden, ob Internet Explorer zusammen mit einer früheren Version auf demselben Computer installiert werden kann, und ob Internet Explorer Standardbrowser ist.
  • Festlegen, dass Windows Update Setup erkennt, ob eine Komponente vorhanden ist, und genaues Abstimmen, welche Komponenten von Benutzern angepasst werden können.
  • Festlegen, ob Komponenten, die gedownloadet, jedoch nicht in alle Pakete eingefügt wurden, den Benutzern über das Internet Explorer-Feature Installation bei Bedarf zur Verfügung gestellt werden.
  • Festlegen, ob die Webbrowser-Funktionalität in den Desktop und die Ordner integriert werden soll . Diese Funktionalität ist in Windows 98 integriert.
  • Festlegen der Informationen zur Zertifizierungsinstanz, wenn Sie über ein digitales Zertifikat verfügen, sodass das Signieren der Programme während des Erstellens des IEAK-Pakets stattfinden kann.

Anmerkungen

  • Weitere Informationen zu Setup finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung zur Anwendung von Branding-Informationen auf ein Paket erhalten Sie unter Anpassungsmöglichkeiten.
  • Ein Flussdiagramm zur Erläuterung der Prozesse bei der Verwendung des Assistenten für die Internet Explorer-Anpassung bei der Erstellung von angepassten Paketen erhalten Sie unter Erstellen angepasster Pakete mit IEAK.


Firmenadministrator: Schritt 4 des Assistenten: Anpassung des Browsers

Firmen-
administrator

Schritt 4 des Assistenten: Anpassung des Browsers

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung können Firmenadministratoren Folgendes anpassen:

  • Die Titelleiste des Browsers und die Hintergrundbitmap der Symbolleiste. Wenn Sie eine Bitmap auswählen, stellen Sie sicher, dass zwischen den Farben und dem Text genügend Kontrast vorhanden ist.
  • Symbolleistenschaltflächen des Browsers. Sie können angepasste Symbolleistenschaltflächen hinzufügen, um Skripts und Programme auszuführen.
  • Das animierte Internet Explorer-Logo in der oberen rechten Ecke des Browsers.
  • Start-, Such- und Onlinesupportseiten des Browsers.
  • Favoriten, Ordner Favoriten und Links der Linkleiste.
  • Channels, um es Benutzern zu ermöglichen, Inhalte zu empfangen, die automatisch aktualisiert werden.
  • "Willkommen"-Seite, die angezeigt wird, wenn die Benutzer den Browser zum ersten Mal starten.
  • Anpassung von Active Desktop, wenn Sie zusätzlich die Windows Desktop-Aktualisierung installieren. Damit dieser Bildschirm angezeigt wird, muss Active Desktop auf dem Erstellungscomputer installiert sein.
  • Einstellungen der Desktop-Symbolleiste. Sie können die Einstellungen der Desktop-Symbolleiste von Ihrem eigenen Computer als Standard für Ihre Firma importieren. Damit dieser Bildschirm angezeigt wird, muss Active Desktop auf dem Computer installiert sein.
  • Arbeitsplatz und Systemsteuerung durch Angabe eigener Dateien Mycomp.htt und Controlp.htt, wenn Sie zusätzlich Windows Desktop-Aktualisierung installieren. Damit dieser Bildschirm angezeigt wird, muss Active Desktop auf dem Computer installiert sein.
  • Benutzeragententext. Eine Kennzeichnung für den Benutzeragent ist optional; er stellt ein Verfahren zum Verfolgen der Verwendung Ihres angepassten Browsers dar.
  • Die Verbindungseinstellungen des Benutzers durch Anpassen der Einstellungen, Importieren der Einstellungen oder Löschen der vorhandenen Einstellungen des Benutzers.
  • Automatische Konfiguration. Sie können einen Pfad für Dateien angeben, die Ihren Browser automatisch konfigurieren.
  • Proxyeinstellungen.
  • Einstellungen für Sicherheitszertifikate und Authenticode.
  • Einstellungen für Sicherheitszonen und Inhaltsbewertungen.

Anmerkungen

  • Weitere Informationen zu Setup finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung zur Anwendung von Branding-Informationen auf ein Paket erhalten Sie unter Anpassungsmöglichkeiten.


Firmenadministrator: Schritt 5 des Assistenten: Komponentenanpassung

Firmen-
administrator

Schritt 5 des Assistenten: Komponentenanpassung

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung können Firmenadministratoren Folgendes anpassen:

  • Festlegungen der Standardprogramme, wie z. B. die Standardprogramme für E-Mail und zur Bearbeitung von HTML-Dateien.
  • News- und Mail-Server der Benutzer, falls Sie Outlook Express in das angepasste Paket aufnehmen.
  • Einstellungen der IMAP-E-Mail-Server für die Benutzer, falls Sie Outlook Express verteilen und einen IMAP-Server einsetzen.
  • Angepasste Inhalte in Outlook Express, indem Sie eine eigene E-Mail-Nachricht zur Begrüßung neuer Benutzer erstellen und indem Sie den Infobildschirm anpassen, der Benutzern beim Programmstart angezeigt wird.
  • Angepasste Einstellungen für Outlook Express, wie standardmäßige Mail- und News-Clients, Hilfe für Benutzer, die weitere Mailkonten benötigen, und eine Datei mit standardmäßigen Nachrichtenregeln für die Benutzer.
  • Einstellungen der Benutzeroberfläche von Outlook Express, beispielsweise Anzeigen oder Ausblenden der Ordnerleiste, der Ordnerliste, der MSN Messenger-Kontakte, der Statusleiste oder der Outlook-Leiste.
  • Einstellungen der Nachrichtenerstellung in Outlook Express, wenn Sie einen Rechtsvorbehalt oder eine Signatur für Beiträge in Internet-Newsgroups oder E-Mail-Nachrichten verwenden möchten.
  • Verzeichnisdienst des Windows-Adressbuchs, wenn Sie den Benutzern Internetverzeichnisdienste anbieten und LDAP (Lightweight Directory Access Protocol)-Server anpassen möchten.
  • Integrieren von Branding-Informationen in den MSN Messenger Service, wenn Ihr Paket eine angepasste Version des Messenger Service-Clients enthält.
  • Medienelemente für den MSN Messenger Service, wenn bei der angepassten Installation des Messenger Service-Clients Grafiken, Werbungen oder Soundelemente geändert werden sollen.
  • Konteninformationen für den MSN Messenger Service, wenn bei der angepassten Installation des Messenger Service-Clients die Passport-Standardkonten bzw. die Einstellungen für die Integrierung von E-Mail geändert werden sollen.
  • Systemrichtlinien und Einstellungen zur Voreinstellung oder Steuerung von Einstellungen, einschließlich Optionen für den Browser, E-Mail, Sicherheit und den Desktop.
  • Abstimmung auf bestimmte Systemrichtlinien und Einschränkungen, je nach verwendetem Betriebssystem. Falls die Benutzer Windows NT oder Windows 2000 verwenden, müssen manche Praktiken und Einschränkungen über den Windows NT-Systemrichtlinien-Editor oder Windows 2000-Gruppenrichtlinie statt über den IEAK-Anpassungsassistenten oder den IEAK-Profil-Manager verwaltet werden.


Firmenadministrator: Verteilen Ihres Browserpakets

Firmen-
administrator

Verteilen Ihres Browserpakets

Standardmäßig erstellt der Assistent für die Internet Explorer-Anpassung Dateien, die die Benutzer aus dem Internet downloaden können. Sie können ein angepasstes Browserpaket jedoch auch auf einer CD verteilen. Eine vollständige Liste der möglichen Distributionsmedien erhalten Sie unter Auswahl der Medien.

Downloadbare Dateien

Wenn Sie das Browserpaket auf einem Internet- oder Intranetserver erstellen, müssen Sie Ihre Website so einrichten, dass Benutzer die Dateien downloaden können. Sie können beispielsweise eine Seite erstellen, auf der Sie Downloadinformationen sowie einen Link für das Installationsmodul IE5setup.exe hinterlegen.

Wenn Sie das Browserpaket auf Ihrer Festplatte oder einem Netzlaufwerk erstellt haben, müssen Sie die folgenden Objekte auf Ihren Internet- oder Intranetserver verschieben:

  • Den Ordner, der die Sprachversion und die Ordnerinhalte enthält, die Sie hinterlegen. Angenommen, der Ordner für die englische Version heißt En, dann müssen Sie den Ordner En sowie die Dateien, die er enthält, verschieben. Dieser Ordner befindet sich in den Ordnern für den gewählten Medientyp, wie z. B. Download, und die gewünschte Plattform. IEAK 5.5 unterstützt nur die Plattform "Win32". Zum Anpassen von UNIX- und 16-Bit-Windows-Clients müssen Sie IEAK 5.0x verwenden.
  • Die Datei namens Ie5sites.dat. Diese Datei zeigt auf die Downloadsite (oder die Sites), die Sie beim Ausführen des Assistenten für die Internet Explorer-Anpassung angegeben haben.

Ihre Benutzer installieren den Browser, indem sie auf IE5setup.exe klicken. Diese Datei befindet sich im Ordner für Ihre Sprach- und Plattformversion innerhalb des Ordners \Download, beispielsweise für die englische Version \Download\Win32\En.

Eine Abbildung hierzu finden Sie unter Einrichten von Dateien für den Vertrieb.

Ein Flussdiagramm zur Erläuterung der durch den Assistenten für die Internet Explorer-Anpassung erstellten Dateien erhalten Sie unter Erstellen angepasster Pakete mit IEAK.

Signieren Ihrer angepassten Pakete

Webbrowser haben Sicherheitsfeatures, die verhindern, dass Benutzer schädliche Programme downloaden. Abhängig von der Sicherheitsebene und dem Betriebssystem kann das Downloaden von Programmen verhindert oder eine Warnung ausgegeben werden, wenn diese Programme nicht digital signiert sind.

Die angepassten .CAB-Dateien, die vom Assistenten für die Internet Explorer-Anpassung erstellt wurden, sollten signiert werden. Dies erübrigt sich jedoch, wenn Sie die lokale Intranetzone mit der Sicherheitseinstellung Niedrig vorkonfigurieren. Alle angepassten Komponenten, die mit Ihrem Browserpaket für diese Betriebssysteme verteilt werden, sollten ebenfalls signiert werden. Wenn Sie über ein digitales Zertifikat verfügen, kann der Assistent für die Internet Explorer-Anpassung diese Dateien automatisch signieren.

Anmerkungen

  • Für das Signieren der Kabinettdateien und der angepassten Programme sind zwei Schritte erforderlich: das Anfordern eines digitalen Zertifikats und das Angeben der Informationen über das digitale Zertifikat beim Ausführen des Anpassungsassistenten. Weitere Informationen hierzu finden Sie unter Signieren Ihrer Programme.
  • Möglicherweise müssen Sie die Groß-/Kleinschreibung bei Namen von Dateien ändern, die auf einem FTP-Server bereitgestellt werden sollen, der UNIX ausführt. Im Folgenden sind die Richtlinien aufgeführt, die Sie für bestimmte UNIX-Betriebssysteme beachten sollten.
    • Solaris UNIX
      Bei Verwendung eines FTP-Servers, der UNIX ausführt und bei dem die Groß-/Kleinschreibung relevant ist, müssen Sie sicherstellen, dass der Name Ihres .CAB-Ordners nicht groß geschrieben wird. Folgende Dateinamen werden jedoch in Großbuchstaben angegeben: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB und IE5SITES.DAT.
    • AT&T UNIX
      Auf einem AT&T UNIX FTP-Server müssen alle Dateinamen groß geschrieben werden.
    • IRIX UNIX (Silicon Graphics)
      Folgende Dateinamen müssen groß geschrieben werden: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB und IE5SITES.DAT. Außerdem sollten Sie die in IE.CIF aufgeführten Dateinamen mit einem Texteditor so ändern, dass sie mit der tatsächlichen Schreibweise der Dateien übereinstimmen.

CD-ROM

Wenn Sie Ihren angepassten Browser für Windows 95 oder Windows 98-Benutzer vertreiben, wird ein Begrüßungsbildschirm mit dem Autorun-Programm angezeigt, wenn der Benutzer die CD in das Laufwerk einlegt. Dieses Programm bietet die Wahl zwischen dem Installieren Ihres angepassten Browsers und der Anzeige weiterer Informationen. Wenn die aktuelle Version von Internet Explorer bereits installiert ist, erkennt das Autorun-Programm dies. Der Browser wird im sogenannten Kioskmodus angezeigt, wenn die Datei Start.htm geladen wird.

Mit dem Assistenten für Windows Update Setup können Sie Ihre Dateien auf einem Intranet- oder Internetserver bereitstellen. Sie können auch eine CD-ROM-Version für Benutzer erstellen, die noch nicht über Zugriff auf das Internet verfügen.

Weitere Informationen

Weitergehende Informationen zu Windows Update Setup finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme. Eine Schemadarstellung des Downloadvorgangs finden Sie unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.


Firmenadministrator: Verfahren zur Verteilung Ihres Messenger Service-Clients

Firmen-
administrator

Verfahren zur Verteilung Ihres Messenger Service-Clients

Falls Sie den MSN Messenger Service als eine Installationsoption integriert haben, erstellt der Assistent für die Internet Explorer-Anpassung ein separates Paket für den Download des angepassten Clients für den Messenger Service aus dem Internet oder von einem Intranetserver.

Downloadbare Dateien

Wenn Sie das Messenger Service-Clientpaket auf einem Internet- oder Intranetserver erstellen, sollten Sie Ihre Website so einrichten, dass Benutzer die Dateien downloaden können. Sie können beispielsweise eine Seite erstellen, auf der Sie Downloadinformationen sowie einen Link für die Setup-Datei (Mmssetup.exe) für den Messenger Service-Client hinterlegen.

Wenn Sie die Datei Mmssetup.exe auf Ihrer Festplatte oder einem Netzlaufwerk erstellt haben, müssen Sie die Dateien für alle bereitgestellten Sprachversionen auf einen Internet- oder Intranetserver verschieben. Im Messenger-Ordner Ihres Versionsverzeichnisses wird für jede Sprachversion ein Unterordner erstellt. So befindet sich beispielsweise die englische Version von Mmssetup.exe im Ordner En. Falls Sie bei der Anpassung einen Download-URL angegeben haben, sollten Sie auf dieser Downloadseite einen Link zu der Datei Mmssetup.exe erstellen. Alle für die Verteilung der angepassten Version des Messenger Service-Clients erforderlichen Komponenten sind in dieser ausführbaren Datei enthalten.

Signieren der Messenger Service-Clientinstallation

Wenn Sie beim Ausführen des IEAK-Assistenten ein digitales Zertifikat für das Signieren des Browserpakets festgelegt haben, wird dieses Zertifikat auch für das Signieren der alleinstehenden Programmversion von Mmssetup.exe verwendet. Weitergehende Informationen erhalten Sie unter Digitale Signaturen und unter Signieren Ihrer Programme.

Messenger Service-Clients als Komponente Ihres Browserpakets

Der angepasste Messenger Service-Client wird auch als Komponente des Browserpakets installiert, wenn Sie festgelegt haben, dass MSN Messenger Service in den Installationsoptionen enthalten ist. Für den angepassten Messenger Service-Client wird eine eigene .CAB-Datei erstellt, und der Client wird bei der Ausführung von Ie5setup.exe als Komponente installiert. Nähere Einzelheiten zur Verteilung des kompletten Browserpakets finden Sie unter Verteilen Ihres Browserpakets.

Messenger Service-Clients und Firewalls

Wenn Sie erweiterte Proxyeinstellungen zur Nachrichtenübermittlung über Firewalls hinweg benötigen, sollten Sie keinen Download-URL festlegen. Darüber hinaus müssen Sie Text bearbeiten, um eine Setup-Datei zur Vorkonfiguration der Proxyoptionen zu erstellen. Weitergehende Informationen erhalten Sie unter Erweiterte Anpassung für den Messenger-Client.


Verwalten von Benutzereinstellungen

Nachdem die Benutzeroptionen eingerichtet wurden und der Browser verteilt wurde, können Administratoren diese Einstellungen auch weiterhin verwalten. Durch Speichern einer .INS-Masterdatei auf dem Server, die bei jeder Anmeldung gedownloadet wird, können Administratoren die Einstellungen der Benutzeroptionen fortlaufend anpassen. Durch Einbindung entsprechender Angaben in vorhandene Anmeldeskripts können Administratoren Benutzereinstellungen von einem zentralen Server aus verwalten und regelmäßig aktualisieren.

Unter Verwendung des IEAK-Profil-Managers können Konfigurationsdateien einfach verwaltet werden. Mit dem Profil-Manager können Sie .INS-Dateien öffnen und Änderungen an den Einstellungen vornehmen, beispielsweise für den Proxyserver, die Startseite, die Suchleiste und die LDAP (Lightweight Directory Access Protocol)-Informationen.

Bei Systemen unter Windows 2000 können Sie bestimmte Benutzereinstellungen auch in Gruppenrichtlinie verwalten.

Nach der Installation können Administratoren alle zulässigen Herausgeberzertifikate (und Sitezertifikate) remote verwalten, indem sie Zertifikate zu der zulässigen Liste hinzufügen oder Zertifikate aus ihr entfernen.


Verwenden des IEAK-Profil-Managers

Vor der Installation von Internet Explorer können Sie mit Hilfe des Assistenten zur Internet Explorer-Anpassung Ihre angepassten Pakete so vorkonfigurieren, dass die automatische Browserkonfiguration und die automatische Erkennung aktiviert wird. Mittels dieser Features suchen die Computer der Benutzer automatisch die (auf Ihrem Server geführte) .INS-Autokonfigurationsdatei und nutzen sie, um die Browserkonfigurationseinstellungen in festgelegten Zeitintervallen zu aktualisieren.

Nachdem Internet Explorer installiert ist, können Sie die Browserkonfigurationseinstellungen auf den Computern der Benutzer mit Hilfe des IEAK-Profil-Managers warten. Mit dem IEAK-Profil-Manager können Sie .INS-Autokonfigurationsdateien öffnen und Einstellungen verändern, beispielsweise Optionen für digitale Signaturen und Sicherheitszonen.

Sie können die automatische Browserkonfiguration auch mit Hilfe des IEAK-Profil-Managers aktivieren, falls dieses Feature nicht bereits vor der Installation vorkonfiguriert worden ist. Die automatische Erkennung (falls aktiviert) ermittelt jeweils die aktualisierte .INS-Autokonfigurationsdatei; Sie können jedoch die automatische Browserkonfiguration auf den Clientcomputern auch manuell einstellen.

Wenn Sie Firmenadministrator sind, kann der IEAK-Profil-Manager Sie beim Verwalten Ihrer Versionen von Internet Explorer unterstützen, indem er schnellen und einfachen Zugriff auf die Systemeinstellungen von einem zentralen Ort aus ermöglicht. Zur Anwendung der automatischen Konfiguration müssen Sie ein Profil erstellen, bestehend aus einer .INS-Datei und den vom Profil-Manager erzeugten Kabinettdateien (.CAB). Das Profil enthält Informationen, die zur Konfiguration der Browser der Benutzer verwendet werden. Nachdem Sie das Profil erstellt haben, wird es auf einem Server gespeichert.

Wenn Sie den Assistenten zur Internet Explorer-Anpassung ausführen, geben Sie den Serverpfad für die .INS-Datei ein. Falls Sie Benutzereinstellungen später ändern müssen, bearbeiten Sie einfach die .INS-Datei. Die Änderungen werden auf den Computern der Benutzer beim nächsten Starten der Browser oder entsprechend einem von Ihnen festgelegten Zeitplan wirksam.

Weitere Informationen zur Einrichtung der automatischen Browserkonfiguration finden Sie unter Einstellungen und Einschränkungen.

Aktualisieren der Browserkonfigurationseinstellungen

Der Assistent für die Internet Explorer-Anpassung erstellt für jedes angepasste Paket, das Sie zusammenstellen, eine .INS-Autokonfigurationsdatei. Standardmäßig erhält diese Datei den Namen Install.ins, Sie können jedoch die Datei auch für jedes angepasste Paket individuell benennen.

Nach der Installation des Browsers können Sie mit dem IEAK-Profil-Manager die Konfigurationseinstellungen aktualisieren, indem Sie die .INS-Autokonfigurationsdatei öffnen, die Einstellungen ändern und danach die Datei speichern. Immer wenn Sie die .INS-Autokonfigurationsdatei speichern, aktualisiert der IEAK-Profil-Manager auch für die zugehörigen Dateien.

Sie können zwei verschiedene Arten von Konfigurationseinstellungen verändern:

  • Einstellungen für den Assistenten

    Diese Einstellungen betreffen Optionen für den Browser und andere Komponenten, die Sie ursprünglich in den Schritten 2 bis 5 des Assistenten zur Internet Explorer-Anpassung konfiguriert hatten.

  • Praktiken und Einschränkungen

    Diese Einstellungen beziehen sich auf Optionen für den Browser und andere Komponenten, die Sie ursprünglich im Bildschirm Praktiken und Einschränkungen in Schritt 5 des Assistenten zur Internet Explorer-Anpassung konfiguriert hatten.

Verwalten der automatischen Konfiguration

Mittels eines URLs für die automatische Konfiguration können Sie den Browser des Benutzers automatisch auf das IEAK-Profil verweisen. Sie können entweder die .INS-Datei angeben oder eine .ASP (Active Server Pages)-Datei erstellen und angeben, die automatisch eine INS-Datei erzeugt.

Außerdem können Sie Skriptdateien im .JS-, .JVS- oder .PAC- Format angeben, die Ihnen das Konfigurieren und Verwalten von erweiterten Proxyeinstellungen gestatten. Wenn Sie URLs sowohl für automatische Konfiguration als auch für automatischen Proxy (Autoproxy) angeben, wird der Autoproxy-URL mit in die .INS-Datei aufgenommen. Die richtige Form der URL ist http://share/test.ins.

So aktivieren Sie die automatische Konfiguration

  1. Aktivieren Sie das Kontrollkästchen Automatische Konfiguration aktivieren.
  2. Geben Sie im Feld URL für AutoKonfiguration (.INS-Datei) den URL für die .INS- oder .ASP-Datei ein, die angezeigt werden soll.
  3. Geben Sie unter URL für Autoproxy (.JS-, .JVS- oder .PAC-Datei) den URL für das Autoproxy-Skript ein.

So führen Sie den IEAK-Profil-Manager aus

  1. Klicken Sie im Startmenü auf Programme, zeigen Sie auf Microsoft IEAK 5.5, und klicken Sie dann auf IEAK-Profil-Manager.
  2. Klicken Sie im Menü Datei auf Öffnen, und öffnen Sie dann die zu bearbeitende .INS-Datei, oder klicken Sie auf Neu, um eine neue .INS-Datei zu erstellen.

    Um mit den Richtliniendateien eines anderen Betriebssystems zu arbeiten, klicken Sie im Menü Plattform auf die gewünschte Option.

  3. Klicken Sie zum Ändern der Einstellungen auf Einstellungen für den Assistenten oder auf Praktiken und Einschränkungen, um die Einstellungskategorien anzuzeigen.
  4. Klicken Sie im linken Ausschnitt auf die Kategorie, die Sie ändern möchten, und ändern Sie dann die gewünschten Optionen im rechten Ausschnitt.
  5. Klicken Sie im Menü Datei auf Speichern.

    Geben Sie den Pfad für Ihre .INS-Datei, den URL für Ihre .CAB-Dateien sowie die Namen Ihrer .CAB-Dateien ein, falls diese von den vorgegebenen Standards abweichen.

Der Standardspeicherort der .INS-Autokonfigurationsdatei ist der Ordner
\Versionsverzeichnis\Ins\Betriebssystem\Sprache. Beispielsweise wird eine für die Windows-32-Bit-Platform erstellte englische Version der .INS-Datei im Ordner \Build1\Ins\Win32\En gespeichert.

Bevor Sie die Konfigurationseinstellungen auf den Computern der Benutzer aktualisieren, sollten Sie die .INS-Autokonfigurationsdatei und die zugehörigen, vom IEAK-Profil-Manager erzeugten .CAB-Dateien in ein Arbeitsverzeichnis kopieren und die Konfiguration testen. Nachdem Sie Ihre Änderungen überprüft haben, kopieren Sie die neue .INS-Autokonfigurationsdatei auf den Server in der Produktionsumgebung. Die automatische Browserkonfigurationsfunktion aktualisiert dann die Konfigurationseinstellungen auf den Computern der Benutzer.

Anmerkungen

  • Ändert sich die Versionsnummer der .INS-Datei nicht, werden keine neuen .CAB-Dateien gedownloadet. Die Versionsnummer setzt sich aus dem Datum der Änderung der .INS-Datei und der Anzahl der an der Datei durchgeführten Änderungen zusammen.
  • Wenn Sie mit .ADM-Dateien vertraut sind, können Sie Praktiken und Einschränkungen verwenden, die Sie in eigenen .ADM-Dateien gespeichert haben, indem Sie auf Richtlinie und anschließend auf Importieren klicken.
  • Falls Sie die automatische Konfiguration verwenden und sowohl Internet Explorer 5 (oder später) als auch Internet Explorer 4.0 von derselben Konfigurationsdatei unterstützen lassen, werden bestimmte Einstellungen, die für die beiden Versionen unterschiedlich sind, nicht für Internet Explorer 4.0 konfiguriert.

Vom IEAK-Profil-Manager erzeugte Dateien

Wenn Sie Konfigurationseinstellungen aktualisieren und speichern, erzeugt der IEAK-Profil-Manager folgende Dateien:

Dateityp | Funktion
Autokonfigurationsdatei (.INS) | Diese Datei enthält die Einstellungen für Browser und Zusatzkomponenten, die Internet Explorer für die aktuelle Browserkonfiguration auf den Computern der Benutzer verwendet. Diese Einstellungen können Sie im Bereich Einstellungen für den Assistenten des IEAK-Profil-Managers ändern.
Kabinettdateien (.CAB) | Diese Dateien werden verwendet, um die Installationsdateien zu organisieren, die per Download auf die Computer des Benutzers geladen werden. Die vom IEAK-Profil-Manager erzeugten .CAB-Dateien sollten Sie mit einer digitalen Signatur versehen. Weitere Informationen zum Signieren von .CAB-Dateien finden Sie unter Signieren Ihrer Programme. Die .CAB-Dateien für die automatische Konfiguration enthalten außerdem Informationsdateien (.INF).
Informationsdateien (.INF) | Diese Dateien enthalten die Systemrichtlinien und Einschränkungen, die das Betriebssystem zur Aktualisierung der Systemkonfiguration auf den Computern der Benutzer verwendet. Diese Einstellungen können Sie im Bereich Praktiken und Einschränkungen des IEAK-Profil-Managers ändern. Jede .INF-Datei enthält darüber hinaus Versionsinformationen. Wenn Sie die Konfigurationseinstellungen ändern aktualisiert der IEAK-Profil-Manager die betreffenden .INF-Dateien und deren Versionsinformationen und stellt die zugehörigen .CAB-Dateien erneut zusammen.

Internet Explorer downloadet und verarbeitet die Inhalte der .INS-Autokonfigurationsdatei und nimmt die erforderlichen Konfigurationsänderungen auf den Computern der Benutzer vor. Außerdem downloadet und entpackt Internet Explorer die zugehörigen .CAB-Dateien, die das Betriebssystem verarbeiten soll. Ist die Versionsnummer der .INS-Autokonfigurationsdatei unverändert, werden keine neuen .CAB-Dateien gedownloadet. Die Versionsnummer setzt sich aus dem Datum der Änderung der .INS-Datei und der Revisionsnummer für die Datei zusammen.

Eine Darstellung der automatischen Konfiguration finden Sie unter So funktioniert die automatische Konfiguration.

Erstellen eindeutiger Konfigurationen für verschiedene Gruppen von Benutzern

Wenn die Benutzer unterschiedliche Anforderungen haben, oder wenn Sie die Konfigurationseinstellungen für bestimmte Benutzer unabhängig von anderen ändern möchten, können Sie mehrere .INS-Autokonfigurationsdateien erstellen. Mit Hilfe des IEAK-Profil-Managers können Sie unterschiedliche Konfigurationen für die einzelnen Gruppen festlegen und diese separat als Benutzergruppe.INS-Dateien speichern, wobei Benutzergruppe den eindeutigen Namen einer jeden Benutzergruppe repräsentiert. Der IEAK-Profil-Manager erzeugt die zugehörigen .INS-Dateien automatisch. Beispielsweise können Sie eine separate Konfiguration für die Finanzabteilung festlegen und diese Konfiguration unter dem Namen Finanz.ins speichern. Der IEAK-Profil-Manager erzeugt dann die erforderlichen zugehörigen .CAB-Dateien.

Anmerkung

  • Falls Sie mehrere .INS-Autokonfigurationsdateien erstellen, achten Sie darauf, dass die angepassten Pakete auf die Verwendung der richtigen Datei konfiguriert sind. Sie können auch eine automatisierte Serverlösung vorsehen, die es ermöglicht, mehrere .INS-Dateien zu verwenden, ohne die angepassten Pakete neu zusammenstellen zu müssen.

Verwenden angepasster Richtlinienvorlagen

Der IEAK-Profil-Manager verwendet einen Standardsatz von Windows-Richtlinienvorlagen- oder Administrationsdateien (.ADM), um die Regeln für Systemrichtlinien und Einschränkungen zu festzulegen. Die .ADM-Dateien sowie Systemrichtlinien und Einschränkungen sind Standardfeatures der 32-Bit- und 16-Bit-Windows-Plattformen. Falls Sie mit .ADM-Dateien vertraut sind, können Sie eigene Vorlagen erstellen und zusätzliche Einschränkungen festlegen. Weitere Informationen hierzu finden Sie in der Dokumentation zu Windows 2000.

Mit dem IEAK-Profil-Manager können Sie ihre eigenen .ADM-Dateien importieren und den aktualisierten Konfigurationseinstellungen beifügen. Der IEAK-Profil-Manager erzeugt eine zugeordnete .INF-Datei mit dem Dateinamenspräfix der angepassten .ADM-Datei, die Sie importieren. Wenn Sie beispielsweise eine Datei mit dem Namen Custom.adm importieren, wird eine Datei Custom.inf erzeugt und den zugehörigen .CAB-Dateien hinzugefügt. Weitere Informationen zur Verwendung von angepassten .ADM-Dateien finden Sie unter Einstellungen und Einschränkungen.

Ändern des Speicherorts einer ".INS"-Autokonfigurationsdatei

Wenn Sie die .INS-Autokonfigurationsdatei auf einen anderen Produktionsserver verlagern müssen, können Sie den IEAK-Profil-Manager verwenden, um den URL für die automatische Browserkonfiguration zu aktualisieren. Falls die .INS-Autokonfigurationsdatei so eingerichtet ist, dass die Aktualisierung in einem festgelegten Zeitintervall nach der Aktualisierung des URL für die automatische Browserkonfiguration erfolgt, müssen Sie zwei Intervalle abwarten, bis die Änderung wirksam wird.

So aktualisieren Sie den URL für die automatische Browserkonfiguration

  1. Klicken Sie auf das Menü Start, zeigen Sie auf Programme, zeigen Sie auf Microsoft IEAK 5.5, und klicken Sie dann auf IEAK-Profil-Manager.
  2. Klicken Sie im Menü Datei auf Öffnen, und klicken Sie dann auf die .INS-Autokonfigurationsdatei Ihres angepassten Browserpakets.
  3. Klicken Sie unter Einstellungen für den Assistenten auf Automatische Browserkonfiguration.
  4. Geben Sie im Feld URL für AutoKonfiguration (.INS-Datei) den neuen Serverpfad ein.
  5. Klicken Sie im Menü Datei auf Speichern unter. Geben Sie einen Namen für die Datei unter Beibehaltung der Erweiterung .ins ein.
  6. Geben Sie den neuen Serverspeicherort der .INS-Datei ein, um ihn an den neu eingegebenen URL anzupassen, den URL der .CAB-Dateien sowie die Namen der .CAB-Dateien.

    Sie müssen alle im Versionsordner erstellten .CAB-Dateien in den Ordner kopieren, der auch Ihre .INS-Datei enthält.

Wenn der Benutzer den Browser startet und die Aktualisierung der Konfigurationseinstellungen gemäß dem Zeitplan fällig ist, wird der Verweis auf den URL für die automatische Browserkonfiguration auf dem Computer des Benutzers aktualisiert. Zu diesem Zeitpunkt verwendet der Browser noch immer die Einstellungen aus der ursprünglichen .INS-Autokonfigurationsdatei (z. B. http://bisherigerPfad/Default.ins).

Startet der Benutzer danach den Browser erneut und die Konfigurationsdateien sind wiederum fällig zur Aktualisierung, liest der Browser nun die neue .INS-Autokonfigurationsdatei (z. B. http://neuerPfad/Default.ins). Wenn Sie sicher sind, dass die Einstellungen auf den Computern sämtlicher Benutzer aktualisiert wurden, können Sie die Kopie der .INS-Autokonfigurationsdatei aus dem ursprünglichen Speicherort entfernen.

Verwenden des Profil-Managers zur Verwaltung von Windows 2000-Systemen

Wenn Sie Setup für die Verteilung von Internet Explorer unter Windows 2000 im Hintergrund ausführen, können Sie mit dem IEAK-Profil-Manager angepasste Einstellungen für Internet Explorer festlegen. Diese Einstellungen werden konfiguriert, während Setup im Hintergrund ausgeführt wird. Mit dem Profil-Manager können Sie .INS-Dateien und ggf. Kabinettdateien (.CAB) erstellen. Die .INS-Datei wird im Abschnitt [Branding] der Datei Unattend.txt festgelegt. Weitere Informationen erhalten Sie in der Dokumentation zu Windows 2000-Setup.

Um Windows 2000 als Plattform festzulegen, klicken Sie im Menü Plattform auf Windows 2000. Klicken Sie unter Einstellungen für den Assistenten auf die Objekte, die Sie anpassen möchten.

Im IEAK-Profil-Manager stehen für die Windows 2000-Plattform keine Einschränkungen zur Verfügung, über die die Einstellungen festgelegt werden können, die vom Benutzer angepasst werden dürfen. Verwenden Sie Gruppenrichtlinie, um Einschränkungen für die Windows 2000-Plattform einzurichten. Weitere Informationen erhalten Sie, indem Sie in der Windows 2000-Hilfe nach "Gruppenrichtlinie" suchen.

Außerdem sind im IEAK-Profil-Manager für die Windows 2000-Plattform auch keine Optionen für digitale Zertifikate vorgesehen, da Windows 2000 über erweiterte Funktionen zur Verwaltung von Zertifikaten verfügt. Weitere Informationen erhalten Sie, indem Sie in der Windows 2000-Hilfe nach digitale Zertifikate suchen.


IEAK-Referenzen

Hintergrundinformationen über IEAK erhalten Sie unter folgenden Themen:

  • Verwalten von Microsoft Internet Explorer unter Windows 2000
  • Branding und Anpassen von Grafiken
  • Sicherheit in Internet Explorer
  • Anpassen des Messenger Service-Clients
  • Vertreiben von Internet Explorer
  • Ausführen von Setup im Batchmodus
  • Regelmäßiges Aktualisieren von Benutzern
  • Windows Update Setup für Internet Explorer und andere Internetprogramme
  • Arbeiten mit Setup-Informationsdateien (.INF)
  • Dateitypen
  • Konfigurieren der automatischen Suche
  • Anpassen der Suchleiste und des Suchassistenten

Weitere Ressourcen

Besuchen Sie die folgenden Websites, um nach den neuesten Ressourcen und Aktualisierungen der Technologie zu suchen:

  • IEAK-Website
  • Microsoft Security Advisor-Website
  • MSDN Online Web Workshop
  • Corporate Windows Update-Website


Konfigurieren der automatischen Suche

Sie können die automatische Suche in der Weise anpassen, dass Benutzer lediglich ein natürlichsprachliches Wort in das Feld Adressen eingeben müssen, um nach häufig besuchten Seiten im Internet zu suchen. Die Benutzer brauchen sich dann nicht mehr die URLs für alle Seiten zu merken, die Sie festgelegt haben; hierdurch wird den Benutzern der Zugang zu wichtigen Informationen erleichtert.

Beispielsweise können Sie für eine bestimmte Webseite mit Rechnungen festlegen, dass sie angezeigt wird, wenn ein Benutzer lediglich den Begriff Rechnung in die Adressleiste eingibt, auch wenn der URL dieser Seite das Wort Rechnung gar nicht enthält. Wenn Sie Firmenadministrator sind, finden Sie im nächsten Thema Hinweise zum Anpassen der automatischen Suche. Falls Sie Internetinhaltsanbieter (ICP) oder Internetdienstanbieter (ISP) sind, erhalten Sie weitere Informationen, indem Sie eine E-Mail-Nachricht an autosrch@microsoft.com senden.

Dieses Feature ist bereits für den Bereich des Internet aktiviert. Wenn beispielsweise ein Benutzer bestimmte gängige Ausdrücke in das Feld Adressen eingibt, wird eine dem Ausdruck zugeordnete Website angezeigt. Falls dem Ausdruck keine Website eindeutig zugeordnet werden kann (beispielsweise, wenn es mehrere Übereinstimmungen gibt), wird eine Webseite mit den besten Suchergebnissen angezeigt.

Im URL der angezeigten Website ist nicht notwendigerweise der genaue Suchausdruck enthalten. Wenn eine Website existiert, deren Domänenname gleich dem eingegebenen Ausdruck ist, diese jedoch nicht die beste Bewertung für den Suchausdruck erhalten hat (beispielsweise, wenn der Suchausdruck der URL-Adresse ohne die Affixe "www." und ".com" entspricht), so wird der Benutzer auf die Site umgeleitet, die die beste Bewertung für den Begriff erhalten hat. Standardmäßig wird der Benutzer gefragt, bevor er umgeleitet wird.

So richten Sie die automatische Suche ein

  1. Erstellen Sie eine Skriptdatei (.ASP), die eine bedingte Überprüfung auf bestimmte Suchausdrücke durchführt, und stellen Sie sie auf einem Intranetserver an folgendem Speicherort bereit:

    http://ieautosearch/response.asp?MT=%1&srch=%2

    Eine Beschreibung der Parameter %1 und %2 finden Sie unter Parameter zur Konfiguration des URL für die automatische Suche (unten).

    Falls Sie nicht IIS (Internet Information Server) verwenden, müssen Sie diesen URL der Adresse, an der sich das Skript befindet, neu zuweisen.

  2. Wenn Sie diese Einstellung im Assistenten für die Internet Explorer-Anpassung ändern, klicken Sie im Bildschirm Praktiken und Einschränkungen in Schritt 5 auf Interneteinstellungen.

    - ODER -

    Falls Sie diese Einstellung im Profil-Manager ändern, klicken Sie auf Praktiken und Einschränkungen und anschließend auf Interneteinstellungen.

  3. Klicken Sie auf Erweiterte Einstellungen, und geben Sie dann unter Suchen in das Textfeld Anbieter-Schlüsselwort suchen den Ausdruck Intranet ein.

Anmerkungen

  • Statt Suchergebnisse anzeigen zu lassen, können Sie unter Verwendung von Praktiken und Einschränkungen den Benutzer auch zu einer anderen Site umleiten. Klicken Sie hierzu auf Erweiterte Einstellungen. Wählen Sie unter Suchen im Feld Bei der Suche über die Adressleiste die Option Zur wahrscheinlichsten Site wechseln.
  • Wenn Sie Firmenadministrator in einer Organisation sind, die nicht über einen Internetzugang verfügt, und Sie die Suche nicht anpassen möchten, können Sie auf Wunsch die automatische Suche mit Hilfe von Praktiken und Einschränkungen deaktivieren. Klicken Sie hierzu auf Erweiterte Einstellungen. Wählen Sie unter Suchen im Feld Bei der Suche über die Adressleiste die Option Nicht in Adressleiste suchen.

Parameter zur Konfiguration des URL für die automatische Suche

Konfigurieren Sie den URL für die automatische Suche http://ieautosearch/response.asp?MT=%1&srch=%2, indem Sie die beiden durch das Prozentzeichen (%) repräsentierten Parameter ersetzen. Diese beiden Werte müssen Teil der URL-Adresse sein.

Parameter | Wert
%1 | Die vom Benutzer in das Feld Adresse eingegebene Zeichenfolge.
%2 | Vom Benutzer ausgewählter Suchtyp.
 | 3 | Ergebnisse anzeigen und zur wahrscheinlichsten Site wechseln
 | 2 | Zur wahrscheinlichsten Site wechseln
 | 1 | Ergebnisse im Hauptfenster anzeigen
 | 0 | Keine Suche über das Feld Adresse

Beispiel für AutoSearch-Skript (".ASP")

<%@ Language=VBScript %>

<%
' search enthält die in die Adressleiste vom Benutzer
' eingegebenen Wörter außer "go" und
' "find" sowie Trennzeichen wie
' "+" (für Leerzeichen).
' Bei Benutzereingabe von
' "Apfelkuchen" search = "Apfelkuchen".
' Bei Benutzereingabe von
' "find Apfelkuchen" search = "Apfelkuchen".
search = Request.QueryString("MT")
search = UCase(search)
searchOption = Request.QueryString("srch")

' Dies ist eine einfache if/then/else-Anweisung,
' die den Browser zu der gewünschten Site
' umleitet, ausgehend von der
' Benutzereingabe.
' Beispiel: Kostenbericht ist eine Intranetseite
 ' zum Ausfüllen eines Kostenberichtes
if (search = "NEUEINSTELLUNG") then
Response.Redirect("http://admin/hr/newhireforms.htm")
elseif (search = "BIBLIOTHEK") then
Response.Redirect("http://library/catalog")
elseif (search = "KOSTENBERICHT") then
Response.Redirect("http://expense")
elseif (search = "KANTINE") then
Response.Redirect("http://cafe/menu/")
else
' Wird keine Übereinstimmung gefunden,
' Standard-IE-AutoSearch-Server verwenden
Response.Redirect("http://auto.search.msn.com/response.asp?MT="
+ search + "&srch=" + searchOption +
"&prov=&utf8")
end if

%>

Informationen über weitere Möglichkeiten zur Anpassung des Suchvorgangs finden Sie unter Anpassen der Suchleiste und des Suchassistenten.


Anpassen der Suchleiste und des Suchassistenten

Die Suchleiste ermöglicht Benutzern das Starten von Suchläufen und das Anzeigen der Ergebnisse. Wenn der Benutzer auf die Schaltfläche Suchen klickt, wird die Suchleiste auf der linken Seite des Browserfensters in einem Bereich angezeigt, der als Explorerleiste bezeichnet wird.

Der Microsoft Windows Suchassistent wird in der Suchleiste geöffnet und stellt den Benutzern eine einheitliche Umgebung für verschiedenartige Suchvorgänge zur Verfügung. Statt zunächst die Suchmaschine aufzurufen, die sie verwenden möchten, können die Benutzer mit Hilfe von Optionsfeldern direkt den gesuchten Informationstyp angeben.

Internet Explorer ist vom Benutzer dahingehend anpassbar, dass die Suchleiste immer eine bestimmte Suchmaschine verwendet. Als Internetdienstanbieter oder Firmenadministrator können Sie dagegen die Suchleiste unter Verwendung von JScript (kompatibel mit der Sprachspezifikation ECMA 262), Visual Basic Scripting Edition (VBScript), ActiveX-Steuerelementen, Dynamic HTML, Framesets, Cascading Stylesheets (CSS) und anderen mit dem Internet Explorer-Browser kompatiblen Technologien auf die Anforderungen Ihrer Organisation abstimmen. Geben Sie den URL für die Suchleiste im Bildschirm Wichtige URLs in Schritt 4 des Assistenten für die Internet Explorer-Anpassung an.

Suchergebnisse werden üblicherweise in der Suchleiste angezeigt. Es ist für Benutzer von entscheidender Bedeutung, dass sie das Ergebnis jedes Suchdienstes auf einfache Weise verwenden können. Mit Hilfe der Funktionen der Suchleiste können Sie ausführliche Informationen speichern, wie Textzusammenfassungen, URLs oder Dateigrößen. Diese Informationen werden in QuickInfos angezeigt, die jeweils eingeblendet werden, wenn der Mauszeiger über ein Suchergebnis bewegt wird. Mit Hilfe der QuickInfos bleibt die Ergebnisseite übersichtlich und bietet dem Benutzer dennoch mehr Detailinformationen.

Richtlinien zum Anpassen der Benutzeroberfläche der Suchleiste

Halten Sie sich beim Erstellen einer eigenen Suchleiste an die folgenden Richtlinien, um eine einwandfreie Funktion der Suchleiste innerhalb der Explorerleiste zu gewährleisten.

  • Ergebnisseiten sollten immer die Möglichkeit bieten, eine neue Suche zu starten. Daher sollten sie innerhalb der ersten 20 Prozent des Inhaltsbereichs stets Schaltflächen zum Ändern und Ausführen der Suche enthalten.
  • Seiten sollten in die Suchleiste passen, die 200 Pixel breit ist. Wenn Sie Tabellen oder andere HTML-Layoutelemente verwenden, stellen Sie sicher, dass auch diese nicht über diese Breite hinausgehen. Andernfalls müssen horizontale Bildlaufleisten angezeigt werden, die den Platz für Inhalte reduzieren und den Benutzer zu weiteren Aktionen zwingen. Wenn Sie Hintergrund- oder andere Informationen anzeigen möchten, ohne zusätzlichen Platz in Anspruch zu nehmen, können Sie QuickInfos verwenden.
  • Sie können Dynamic HTML, ActiveX-Technologie, Java und Cascading Stylesheets verwenden, um dynamische Effekte zu erzeugen und Multimedia zu implementieren. Denken Sie jedoch daran, dass der Platz für die Suchleiste begrenzt ist.
  • Die Standardgröße der Suchleiste beträgt 200 Pixel in der Breite und umfasst die gesamte vertikale Größe des Browserfensters, die 430 Pixel beträgt. In diesem Bereich können sich je nach Ihren Anforderungen Werbeanzeigen, Branding-Informationen und Suchinformationen befinden. Der Benutzer kann die Größe dieses Bereichs anpassen.
  • Da die Suchleiste nur begrenzten Platz bietet, sollten Sie bei der Gestaltung der Benutzeroberfläche Prioritäten setzen. Als Faustregel gilt: Bieten Sie dem Benutzer die optimalen Informationen, ohne die Seite mit grafischen Elementen zu überladen. Von oben nach unten sollte die Oberfläche in der Regel folgende Elemente enthalten:
    • Ihre Branding-Informationen
    • Felder für Suchabfragen, die verfeinert werden können
    • Suchergebnisse
    • Werbeanzeigen oder andere Dienste
    Es wird empfohlen, Werbung am unteren Rand der Seite zu platzieren, damit die Benutzer keinen Bildlauf durchführen müssen, um ihre Suchergebnisse zu sehen.
  • Falls die Seite doch einen Bildlauf erfordert, stellen Sie sicher, dass eine beträchtliche Anzahl von tatsächlichen Ergebnissen (nicht von Kategorieergebnissen) sofort sichtbar ist.
  • Die Links für die Suchergebnisse oder "Treffer" werden normalerweise in der Suchleiste angezeigt. Wenn der Benutzer auf diese Links klickt, sollte die zugehörige Webseite im Hauptfenster des Browsers angezeigt werden. Vermeiden Sie das Anzeigen von Webseiten in der Suchleiste, da diese keine Schaltflächen für Zurück und Vorwärts enthält.

Techniken zum Anpassen des Suchassistenten

Der Suchassistent lässt sich an spezielle Suchanforderungen anpassen. Beispielsweise können zusätzliche Informationen über Suchergebnisse in der QuickInfo gespeichert werden und Suchergebnisse auf einer besonderen Webseite markiert werden.

Markieren von Suchtreffern

Mit der NavigateAndFind-Methode kann in Webseiten nach einem Wort oder Ausdruck gesucht werden. Diese Methode lädt eine bestimmte Webseite und durchsucht das Dokument nach dem Vorkommen einer angegebenen Zeichenfolge. Wird eine übereinstimmende Zeichenfolge gefunden, wird diese im Dokument markiert.

Beispiel

Das folgende Beispiel öffnet die Microsoft-Website und sucht nach den Worten "Microsoft Corporation":

window.external.NavigateAndFind("http://www.microsoft.com","Microsoft Corporation");

QuickInfos und Link-Zusammenfassungen

Um Platz im Browserfenster zu sparen und die Übersichtlichkeit der Suchergebnisse zu erhöhen, bietet Internet Explorer die Möglichkeit, spezielle Informationen zu Links in QuickInfos aufzunehmen. Dazu legen Sie das TITLE-Attribut eines HTML-Anker-Tags fest.

Beispiel

Das folgende Beispiel zeigt Zusatzinformationen über den Link an:

<A HREF="http://www.acme-sports.com" TITLE="Neueste Sportnachrichten und Tabellen, stündlich aktualisiert.
Interviews mit Siegern.">Neueste Sportnachrichten</A>

Zeigen Sie auf diesen Link, um zu sehen, wie das Ergebnis angezeigt wird: Neueste Sportnachrichten

Erzwungene Zeilenumbrüche in QuickInfos

In der QuickInfo erfolgt nach 7,5 cm automatisch ein Zeilenumbruch. Die QuickInfo kann mindestens einen Absatz enthalten. Allerdings kann der Text nur 1.024 Zeichen umfassen. Sie können eine neue Zeile oder Tabulatorzeichen in der Zusammenfassung erzwingen, indem Sie die reservierten Zeichen &#10 und &#13 für Wagenrücklauf und Zeilenvorschub bzw. &#09 für Tabulatoren verwenden.

Beispiel

Das folgende Beispiel fügt nach Zeile 1 der QuickInfo einen Wagenrücklauf und Zeilenvorschub ein:

<A HREF="http://www.microsoft.com"
   TITLE="Text in Zeile 1&#10;&#13;
   Text in Zeile 2&#10;
   &#09;Text in Zeile 3&#10;
   &#09;Text in Zeile 4">
Verwenden mehrerer Zeilen in QuickInfos</A>

Zeigen Sie auf diesen Link, um zu sehen, wie das Ergebnis angezeigt wird: Verwenden mehrerer Zeilen in QuickInfos

Weitere Informationen zu Scripting und Dynamic HTML finden Sie im MSDN Online Web Workshop.

Weitere Informationen über die automatische Suchfunktion, bei der Benutzer Suchausdrücke in die Symbolleiste Adressen eingeben können, finden Sie unter Konfigurieren der automatischen Suche.


Dateitypen

Dateityp | Beschreibung
.ADM | In Administrationsdateien (.ADM) werden die Systemrichtlinien und Einschränkungen für Desktop, Shell und Sicherheit festgelegt. Die in einer .ADM-Datei festgelegten Einstellungen können Sie mit dem Internet Explorer Administration Kit (IEAK) oder dem Windows Systemrichtlinien-Editor anpassen und beschränken. Eine Liste der Systemrichtlinien und Einschränkungen, die Sie aus standardmäßigen .ADM-Dateien festlegen können, finden Sie unter Verwenden des IEAK-Profil-Managers.
.ASP | Falls Sie Internet Explorer über einen Webserver vertreiben, können Sie Active Server Page-Dateien (.ASP) in Ihr angepasstes Browserpaket integrieren. Mit Hilfe von .ASP-Dateien können Sie Skripts in Ihre HTML-Seiten einbetten und damit dynamische, interaktive Webinhalte erzeugen. Beispielsweise können Sie Anmeldeseiten erstellen, über die Ihre Benutzer den Browser downloaden und sich für Internetdienste anmelden können. Im Assistenten zur Internet Explorer-Anpassung oder im IEAK-Profil-Manager können Sie auf die .ASP-Dateien verweisen. Die Resource Kit-CD enthält Beispiele für .ASP-Dateien.
.BAT | Eine ASCII-Textdatei mit einer Folge von Befehlen auf Betriebssystemebene, die ggf. Parameter und Operatoren enthält, welche die Batchbefehlssprache unterstützt. Wenn Benutzer an der Eingabeaufforderung den Namen der Stapelverarbeitungsdatei eingeben, arbeitet der Computer die Befehle nacheinander ab.
.BMP, .GIF, .JPEG, .JPG | Internet Explorer kann statische und animierte Grafiken in den Dateiformaten .BMP, .GIF, .JPEG oder .JPG beinhalten. Zusätzlich zu den mit dem IEAK gelieferten Grafikdateien können Sie auch eigene Grafiken erstellen und sie in Ihr angepasstes Browserpaket einbinden. So können Sie beispielsweise das Internet Explorer-Logo oder den automatischen Begrüßungsbildschirm durch eigene statische oder animierte Grafiken ersetzen. Das IEAK enthält zwei Tools, die Sie bei der Erstellung angepasster Animationsgrafiken unterstützen. Weitere Informationen zu den Anforderungen für Grafiken, die Sie anpassen können, finden Sie unter Erstellen angepasster Grafiken.
.CAB | In Kabinettdateien (.CAB) sind komprimierte Installationsdateien organisiert und gespeichert, die auf den Computer des Benutzers kopiert werden. Das Windows Update Setup-Programm (IE5Setup.exe) downloadet die .CAB-Dateien, die für die Internet Explorer-Installation benötigt werden, auf den Computer des Benutzers. Diese .CAB-Dateien können sowohl Browserkomponenten als auch angepasste Komponenten enthalten. Nachdem die Dateien erfolgreich gedownloadet wurden, ist Windows Update Setup abgeschlossen. Das IEAK enthält eine Reihe von Tools, die Sie beim Erstellen von .CAB-Dateien für angepasste Komponenten unterstützen.
.CDF | Channeldefinitionsformatdateien (.CDF) ermöglichen, die Distribution von Webinhalten oder Softwareupdates an die Benutzer über Channels vorzunehmen. Die .CDF-Datei enthält einen Index der Ressourcen, die in einem Channel zur Verfügung stehen, sowie einen empfohlenen Zeitplan für die Aktualisierung des Channels auf den Computern der Benutzer. Das Abonnieren eines Channels bewirkt, dass der lokale Cache auf dem Computer des Benutzers mit neuen Informationen gemäß den Angaben aktualisiert wird, die der Herausgeber in der .CDF-Datei festgelegt hat.
.CIF | Eine Komponenteninformationsdatei (.CIF) mit dem Namen IESetup.cif identifiziert die Komponenten, die zusammen mit Internet Explorer installiert werden können, einschließlich neue oder aktualisierte Komponenten. In der .CIF-Datei besitzt jede Komponente eine zugeordnete ComponentID. Das Windows Update Setup-Programm liest die .CIF-Datei, um festzustellen, ob eine Komponente mit einer bestimmten ComponentID bereits installiert ist, und ob eine neuere Version zur Installation zur Verfügung steht.
.CMP | Verbindungsprofildateien (.CMP) werden vom CMAK (Connection Manager Administration Kit) erzeugt und enthalten Informationen, die vom Benutzer festgelegt werden. Bearbeiten Sie .CMP-Dateien nicht, da alle Änderungen, die Sie vornehmen, durch den Benutzer überschrieben werden können.
.CMS | Dienstanbieterdateien (.CMS) werden vom CMAK erzeugt und legen die Konfiguration des Telefonbuchs sowie der meisten anderen Funktionen der Dienstprofile fest. Durch Bearbeiten der .CMS-Datei für ein Dienstprofil lassen sich sehr komplexe Anpassungen durchführen.
.EXE | Die ausführbare Datei (.EXE) mit dem Namen IE5Setup.exe ist das Installationsprogramm, das den Installationsvorgang steuert. Diese .EXE-Datei downloadet die .CAB-Dateien, von denen Ihr angepasstes Browserpaket auf den Computern der Benutzer installiert wird. Die .CAB-Dateien enthalten wiederum selbstextrahierende .EXE-Dateien für den Browser und die angepassten Komponenten.
.HTT | Die HTML-Vorlagendateien (.HTT) enthalten anpassbare Vorlagen für den Arbeitsplatz (Mycomp.htt), die Systemsteuerung (Controlp.htt), Drucker (Printers.htt) und die Standard-Webansicht für Ordner (Folder.htt). Mit Hilfe eines Text- oder HTML-Editors können Sie diese Dateien mit speziellen Anleitungen, Logos oder Links zu Websites versehen. Die Vorlagendateien Mycomp.htt und Controlp.htt können Sie in Ihr angepasstes Browserpaket übernehmen. Die Vorlagen in Printers.htt und Folder.htt müssen Sie direkt auf den Computern der Benutzer anpassen.
.INF | Normalerweise enthält jede .CAB-Datei von Internet Explorer eine zugeordnete Informationsdatei (.INF), welche weitere Installationsinformationen bereitstellt. Die .INF-Datei kann auf Dateien in einer .CAB-Datei oder auf Dateien an anderen URLs verweisen.
.INS | Das Windows Update Setup-Programm enthält eine Interneteinstellungsdatei (.INS), mit der der Browser und dessen Komponenten konfiguriert werden. Durch Anpassen von Kopien dieser .INS-Datei können Sie mehrere verschiedene Versionen Ihres Browserpakets erstellen. Mit Hilfe des IEAK-Profil-Managers können Sie außerdem .INS-Dateien zur Aktualisierung von Internet Explorer-Konfigurationseinstellungen erstellen, speichern und laden.
.ISP | Wenn Sie in Ihr angepasstes Browserpaket einen Anmeldevorgang integrieren, stellt eine Internetanmeldungsdatei (.ISP) mit dem Namen Signup.isp Anmeldeinformationen für Ihre Internetdienste bereit. Die Parameter in der Internetanmeldungsdatei können Sie mit Hilfe des Assistenten zur Internet Explorer-Anpassung bearbeiten. Bei Anwendung einer serverbasierten Anmeldungsmethode enthält diese Anmeldungsdatei außerdem einen Link zum URL des Serverskripts, das Ihre .INS-Konfigurationsdatei erzeugt.
.PAC, .JS, .JVS | Mit Hilfe eines Texteditors können Sie eine Autoproxy-Skriptdatei für Ihr angepasstes Browserpaket erstellen. Eine Autoproxy-Skriptdatei kann eine JScript- (.JS), JavaScript- (.JVS) oder Proxy-Autokonfigurations (.PAC)-Datei sein. Wird eine Autoproxy-Skriptdatei angegeben, so verwendet Internet Explorer dieses Skript, um dynamisch zu ermitteln, ob die Verbindung zu einem Host direkt oder unter Verwendung des Proxyservers hergestellt wird. In Schritt 4 des Assistenten für die Internet Explorer-Anpassung können Sie einen Autoproxy-URL für die Konfiguration und Pflege erweiterter Proxyeinstellungen angeben.
.PDF | Falls Sie Microsoft Systems Management Server für die Distribution von Internet Explorer verwenden, besteht Ihr angepasstes Browserpaket aus einem Ordner mit Installationsdateien und einer Paketdefinitionsdatei (.PDF). Diese Datei mit dem Namen IE5.pdf enthält ein Setup-Programm, Installationsoptionen und die Befehlszeilensyntax zur automatischen Installation von Internet Explorer auf Ihrem Server oder den Computern der Benutzer. Mittels der .PDF-Datei lässt sich die Installation ohne Eingriffe seitens des Administrators oder der Benutzer durchführen.
.PVK | Eine Datei für Privatschlüssel, die den einer digitalen Signatur zugeordneten privaten Schlüssel enthält.
.PWL | Eine Datei, die das Windows-Kennwort eines Benutzers dieses Computers enthält.
.SED | Verbindungsprofildateien (.SED) werden vom CMAK erzeugt und enthalten Anweisungen zur Erstellung einer selbstextrahierenden ausführbaren Datei (.EXE) für Ihre Dienstprofile. Verändern Sie .SED-Dateien nicht.
.SPC | Eine Datei für Zertifikate von Softwareherausgebern. Zertifikatdateien enthalten den Namen und andere Informationen, die den Besitzer des Zertifikats identifizieren, den diesem Zertifikat zugeordneten öffentlichen Schlüssel, eine Seriennummer, die Gültigkeitsdauer des Zertifikats sowie die digitale Signatur der Zertifizierungsstelle, die das Zertifikat ausgegeben hat.


Erstellen angepasster Grafiken

Bevor Sie die Grafiken für das Logo vorbereiten, lesen Sie in Ihrem Lizenzvertrag nach, ob die beabsichtigte Anpassung für Sie legal ist.

Windows Update Setup-Programm

Grafik | Größe und Art | Zusätzliche Anmerkungen
Vertikal links | .BMP-Datei, 162x312 Pixel, 256 Farben | Die vertikale Grafik wird auf der ersten Seite des Assistenten für Windows Update Setup angezeigt.
Horizontal oben | .BMP-Datei, 496x56 Pixel, 256 Farben | Die horizontale Grafik wird auf allen Folgeseiten des Assistenten nach der ersten Seite angezeigt. Dieses horizontale Banner am oberen Rand muss transparent wie beispielsweise ein Wasserzeichen sein, damit der Text auf der Benutzeroberfläche lesbar bleibt.

Internet Explorer-Browser

Eine Abbildung, die zeigt, an welchen Stellen die verschiedenen Grafiken in Ihrem angepassten Browser platziert werden können, finden Sie unter Anpassungsmöglichkeiten.

Grafik | Größe und Art | Zusätzliche Anmerkungen
Statisches Logo .BMP-Dateien, 38x38 Pixel
und 22x22 Pixel 		Erstellen Sie zwei Bitmaps (eine 38x38-Pixel-Grafik und eine 22x22-Pixel-Grafik) mit 256 Farben. Speichern Sie diese Dateien im Ordner für angepasste Bitmaps (CIE\Bitmaps). Wenn der Browser nicht aktiv ist, wird der erste Frame Ihres animierten Logos als statisches Logo verwendet.
Animiertes Logo .BMP-Dateien, 38x38 Pixel
und 22x22 Pixel, für jeden Animationsframe 		Erstellen Sie pro Animationsframe zwei Bitmaps (eine 38x38-Pixel-Grafik und eine 22x22-Pixel-Grafik) mit 256 Farben. Speichern Sie diese Dateien im Ordner für angepasste Bitmaps (CIE\Bitmaps). Wenn der Browser nicht aktiv ist, wird der erste Frame Ihres animierten Logos als statisches Logo verwendet.

Mit Hilfe der IEAK-Tools für animierte Bitmaps können Sie die Bitmaps für das animierte Logo im richtigen Format und der richtigen Reihenfolge zusammenstellen. Das animierte Logo muss einen vertikalen Stapel von Animationszellenbildern enthalten, die den Animationsregeln für Internet Explorer entsprechen.

Animationsregeln für das Intenet Explorer-Logo

  • Die Zellen 1 bis 4 sind Einführungszellen, die abgespielt werden, wenn Internet Explorer mit dem Browsen beginnt.
  • Die Zellen 5 bis x (wobei x die Gesamtzahl der Zellen ist) werden als Schleife wiedergegeben, bis der Browse-Vorgang abgeschlossen ist.
Symbolleistenhintergrund | Keine festgelegte Größe | Der Hintergrund sollte der Größe der Symbolleiste entsprechen und hell genug sein, um schwarzen Text anzeigen zu können.
Symbolleistenschaltfläche des Browsers | Zwei Symboldateien, mit Schwarzweiß- und Farbgrafiken für den aktiven und inaktiven Zustand | Weitere Informationen finden Sie unter Erstellen von Symbolen für Internet Explorer.
Symbole für die Favoritenliste | .BMP-Datei, 16x16 Pixel, für jedes Objekt, das angepasst werden soll
Autorun-Begrüßungsbildschirm (wenn Sie das angepasste Paket auf CD verteilen) | Bitmap, 540x357 Pixel (wird angezeigt, wenn der Benutzer die CD einlegt) | Bevor Sie den Begrüßungsbildschirm erstellen, müssen Sie alle 24-Bit-Grafiken in eine 256-Farben-Palette umwandeln. Weitere Informationen hierzu finden Sie unter Erstellen einer Bitmap für den automatischen Begrüßungsbildschirm.
Channels Für jeden Channel:
  • ein 32x32 Pixel großes Symbol
  • eine 80x32 Pixel große Grafik für die Channelleiste
  • eine 194x32 Pixel große Grafik für den Channelausschnitt
 Die 80x32-Pixel- und die 194x32-Pixel-Grafik können im .GIF-, .BMP- oder .JPEG-Format vorliegen.

Assistent für den Internetzugang, Internetanmeldung

Grafik | Größe und Art
Oberes Bild, wird in der oberen rechten Ecke des Assistenten für den Internetzugang angezeigt | .BMP-Datei, 49x49 Pixel
Vertikales Bild, wird auf der linken Seite der Bildschirme des Assistenten für den Internetzugang angezeigt | .BMP-Datei, 164x458 Pixel

Anmerkung

  • Der Assistent für den Internetzugang ist bei einer serverlosen Anmeldung nicht verfügbar.

Verzeichnisdienst des Windows-Adressbuchs (verwendet in Outlook Express)

Größe und Art | Zusätzliche Anmerkungen
.BMP-Datei, 134x38 Pixel | Verwenden Sie die 16-Farben-Palette von Windows

MSN Messenger Service-Anpassung

Größe und Art | Zusätzliche Anmerkungen
.GIF-Datei, 234x50 Pixel | Nehmen Sie einen weißen Hintergrund (RGB-Wert 255,255,255), und verwenden Sie keine transparenten Channels. Verwenden Sie eine browsergeeignete Farbpalette.


Tools für animierte Bitmaps

Bevor Sie die Grafiken für das Logo vorbereiten, lesen Sie in Ihrem Lizenzvertrag nach, ob Sie diese Anpassung legal durchführen dürfen.

Zwei separate Tools sind in IEAK enthalten, die Sie beim Erstellen angepasster, animierter Bitmaps für Ihren Browser unterstützen:

  • Das Tool für das Erstellen animierter Bitmaps arbeitet mit einer Folge durchlaufend nummerierter Bitmaps und stapelt sie in einer Bitmap in der richtigen Form für Animationen.
  • Das Tool für die Vorschau animierter Bitmaps ermöglicht eine Vorschau der Bitmap. Dieses Tool kann auch verwendet werden, um beliebige Bitmaps, die im richtigen Format vorliegen, anzuzeigen.

Stellen Sie sicher, dass Sie die richtige Größe und das richtige Format für die Bitmaps verwenden. Weitere Informationen hierzu finden Sie unter Erstellen angepasster Grafiken.

Anmerkung

  • Diese Tools werden Administratoren als Hilfsmittel zur Verfügung gestellt und sind nicht für den Vertrieb als unterstützte Microsoft-Produkte bestimmt. Beide Tools befinden sich im Ordner \<IEAK-Programmordner>\Toolkit\Graphics\Tools.

Tool für das Erstellen animierter Bitmaps ("Makebmp.exe")

Um dieses Tool auszuführen, geben Sie an der MS-DOS-Eingabeaufforderung Folgendes ein:

makebmp Basisname AnzahlDateien Ausgabename

Syntaxelement | Bedeutung
makebmp | Name des Tools
Basisname | Gemeinsamer Basisdateiname für alle Dateien (ohne Zahlen und die Erweiterung .bmp)
AnzahlDateien | Anzahl der Bitmaps, die nacheinander zu der Animationsdatei hinzugefügt werden sollen
Ausgabename | Name der Ausgabedatei (die Dateierweiterung .bmp muss angegeben werden)

Beispiel

Um die Dateien bitmap0.bmp bis bitmap19.bmp zu kombinieren, geben Sie Folgendes ein:

makebmp bitmap 20 final.bmp

Anmerkung

  • Nummerieren Sie die verwendeten Dateien fortlaufend, beginnend bei 0 (beispielsweise iebmp0.bmp, iebmp1.bmp, iebmp2.bmp...). Iebmp24.bmp. Der Basisdateiname dieser 25 Dateien ist Iebmp.

Vorschau animierter Bitmaps ("Animbmp.exe")

Sie können die Vorschau entweder von einer MS-DOS-Eingabeaufforderung aus oder aus Windows Explorer starten. Nachdem Animbmp.exe gestartet wurde, können Sie eine Vorschau der animierten Bitmap auf zwei Arten anzeigen: Ziehen Sie die Datei in das Feld, oder klicken Sie im Menü Datei auf Öffnen. Die einleitenden Frames werden nur einmal angezeigt. Anschließend wird die Bitmap in einer fortlaufenden Schleife angezeigt.


Erstellen einer Bitmap für den automatischen Begrüßungsbildschirm

Diese Anleitungen setzen voraus, dass Sie mit 24-Bit-RGB-Bitmap-Dateien arbeiten. Wenn es sich bei Ihrer Datei nicht um eine 24-Bit-RGB-Bitmap handelt, müssen Sie sie umwandeln.

  1. Erstellen Sie eine 256-Farben-Bitmap (540 x 357 Pixel).

    Diese Bitmap sollte eine Einführung in das Produkt und Beschriftungen für die beiden Schaltflächen enthalten: eine Schaltfläche für die Installation von Internet Explorer und eine Schaltfläche zum Anzeigen weiterer Informationen.

  2. Erstellen Sie in Ihrem Grafikprogramm eine Arbeitsdatei für Ihre Palette. Fügen Sie hierzu sowohl Ihre Hintergrund- als auch die Schaltflächendatei in eine einzige Datei ein. Stellen Sie sicher, dass die Dateien nebeneinander eingefügt werden und sich nicht überlappen.
  3. Speichern Sie diese Datei unter dem Namen Palette.bmp.

Anmerkung

  • Die Abmessungen der Bitmap sind von Bedeutung, da das Dialogfeld an die Abmessungen der Bitmap angepasst wird. Ist die Bitmap nicht breit genug, wird der Text des Dialogfelds unter Umständen abgeschnitten.


Erstellen von Symbolleistensymbolen für Internet Explorer

Beim Erstellen eines Symbols müssen Sie jede Grafik in zwei Formaten für die beiden Statusarten der Symbolleisten bereitstellen (in Graustufen für den Standardstatus und farbig für den aktiven Status, wenn der Benutzer mit der Maus auf die Leiste zeigt). Außerdem muss jede Grafik in zwei Farbtiefen vorliegen.

Erstellen Ihrer Bilder

  1. Nachdem Sie die Bilder in einem Grafikprogramm erstellt haben, speichern Sie die 16-Farben- und 256-Farben-Bilder in separaten Dateien.
  2. Indizieren Sie jede Datei für die entsprechende Palette, entweder für die 16-Farben-Palette oder die Halbtonpalette von Windows. Reservieren Sie ein bestimmtes Farbfeld als Farbe, die für Transparenz steht.
  3. Speichern Sie die Dateien als Bitmapdateien.

Es folgt eine Zusammenfassung der erforderlichen Grafiken:

Symbolstatus Größe in Pixel Farbtiefe/Palette Umrandung Erscheinungsbild Beispiel
Aktiv 20x20 Windows-Halbtonpalette (256 Farben) Symbolartiger Rahmen: Farbe an oberen und linken Rändern, schwarz an unteren und rechten Rändern
  • Farbbild
  • Mehr Schattierungen und 3D-Effekte als 16-Farben-Bild
  • Lichtquelle von links oben und Schattierung wo angebracht
 Aktiver Status: 256 Farben, 20x20 Pixel
20x20 Windows-Palette (16 Farben) Schwarz, außer dies beeinträchtigt die Lesbarkeit des Symbols
  • Farbbild
  • Wenig Schattierung, flacheres Erscheinungsbild
 Aktiver Status: 16 Farben, 20x20 Pixel
16x16 Windows-Palette (16 Farben) Schwarz, außer dies beeinträchtigt die Lesbarkeit des Symbols
  • Farbbild
  • Wenig Schattierung, flacheres Erscheinungsbild
 Aktiver Status: 16 Farben, 16x16 Pixel
Standard 20x20 Windows-Halbtonpalette (256 Farben) Symbolartiger Rahmen: Graustufen an oberen und linken Rändern, schwarz an unteren und rechten Rändern
  • Graustufenbild
  • Mehr Schattierungen und 3D-Effekte als 16-Farben-Bild
  • Lichtquelle von links oben und Schattierung wo angebracht
 Aktiver Status: 256 Farben, 20x20 Pixel
20x20 Windows-Palette (16 Farben) Schwarz, außer dies beeinträchtigt die Lesbarkeit des Symbols
  • Graustufenbild
  • Wenig Schattierung, flacheres Erscheinungsbild
 Aktiver Status: 16 Farben, 20x20 Pixel
16x16 Windows-Palette (16 Farben) Schwarz, außer dies beeinträchtigt die Lesbarkeit des Symbols
  • Graustufenbild
  • Wenig Schattierung, flacheres Erscheinungsbild
 Standardstatus: 16 Farben, 16x16 Pixel

Stellen Sie sicher, dass die sichtbaren Übergänge zwischen den Standardbildern und den aktiven Bildern möglichst fließend sind. Dies lässt sich am einfachsten überprüfen, indem Sie mit einem Bildbearbeitungsprogramm separate Ebenen für die Standardbilder und die aktiven Bilder einrichten, sodass Sie die Bilder übereinander liegend anzeigen können.

Umwandeln der Bitmapgrafiken in Symbole

Für jedes Symbol müssen Sie zwei .ICO-Dateien erstellen:

  • Die erste .ICO-Datei enthält die aktiven Bilder (Farbe) in beiden Formaten und Farbtiefen.
  • Die zweite .ICO-Datei enthält die Standardbilder (Graustufen) in beiden Formaten und Farbtiefen.

Wir empfehlen Ihnen, die Symbole mit Hilfe eines Grafikprogramms und die .ICO-Dateien unter Verwendung einer Entwicklungsumgebung wie Microsoft Visual C++ Development Studio zu erstellen.

Beispiel

Die beiden Symboldateien des Startseitensymbols enthalten die folgenden Bilder:

Aktiver Status </TH> <TH CLASS= Standardstatus </TH> </TR> <TR> <TD ALIGN= Symbol für aktiven Status Symbol für Standardstatus

So erstellen Sie Symboldateien in Visual C++

  1. Öffnen Sie die Bitmapdateien.
  2. Klicken Sie im Menü Datei auf Neu, und klicken Sie dann in der Registerkarte Dateien auf Symbol-Datei. Standardmäßig wird in dem Symbolfenster, das geöffnet wird, ein 32x32-Pixel großes Standardgeräteabbild angezeigt.
  3. Klicken Sie im Menü Bild auf Neues Geräteabbild. Klicken Sie auf Benutzerdefiniert, und erstellen Sie dann folgende Geräteabbilder:
    • Ein 22x20-Pixel-Bild mit 16 Farben
    • Ein 22x20-Pixel-Bild mit 256 Farben
    • Ein 18x16-Pixel-Bild mit 16 Farben

    Anmerkung

    • Die Geräteabbilder sind zwei Pixel breiter als die Bilder. Zentrieren Sie daher die Bilder innerhalb des Geräteabbildbereichs.
  4. Löschen Sie das 32x32-Pixel-Standardgeräteabbild.
  5. Kopieren Sie die Farbbilder aus Ihren Bitmapdateien, und fügen Sie sie in der entsprechenden Geräteabbildgröße und -farbtiefe ein.
  6. Wenn der Hintergrund transparent sein soll, wählen Sie die Farbe, die für Transparenz steht, in der Farbpalette aus, und füllen Sie damit den Hintergrund jedes Bildes, für das Transparenz gewünscht wird.
  7. Speichern Sie die Datei als .ICO-Datei.

Die standardmäßige .ICO-Datei für Graustufenbilder können Sie mit demselben Verfahren erstellen.


Hinzufügen eines Benutzeragententexts

Einige Firmen führen Sitestatistiken. Sie ermitteln beispielsweise, wie häufig auf ihre Inhalte zugegriffen wird und welche Webbrowser dazu verwendet werden. Benutzeragententext hilft bei der Identifikation des Browsertyps.

Wenn Sie Browserstatistiken führen und Ihre Informationen den Benutzeragententext enthalten, können Sie die Verwendung Ihres angepassten Browsers verfolgen. Im Assistenten für die Internet Explorer-Anpassung können Sie Zeichen am Ende des Benutzeragententexts anhängen, um ihn anzupassen.

Ihre angepasste Zeichenfolge wird in allen Statistiken, die den Benutzeragententext verwenden, angezeigt. Denken Sie daran, dass andere Firmen, die ebenfalls Statistiken führen, Ihre angepasste Zeichenfolge sehen können. Vermeiden Sie daher die Verwendung einer Zeichenfolge, die andere nicht sehen sollen.

Beispiel

Dies ist ein Beispiel für Benutzeragententext:

Mozilla/4.0(compatible; MSIE 5.5; Windows NT; EigenerAngepassterText)

Anmerkung

Der Benutzeragententext sollte nicht mehr als 2000 Zeichen enthalten.


Sicherheit in Internet Explorer

Mit Internet Explorer können Sie die Sicherheit auf verschiedene Arten steuern: durch Sitezertifikate, Authenticode™-Herausgeber und Sicherheitszonen. Sie können Zertifikate auf den Computern der Benutzer vorinstallieren und verhindern, dass Benutzer andere Zertifikate downloaden. Sie können auch Bewertungen bzw. Filter für die Inhalte einstellen, die Benutzer anzeigen.

Firmenadministratoren können Sicherheitseinstellungen und Bewertungen in Schritt 4 und Schritt 5 des Assistenten für die Internet Explorer-Anpassung eingeben.

Informationen zu Sicherheitszonen

Die Sicherheitsoptionen von Explorer ermöglichen das Zuweisen bestimmter Websites zu verschiedenen Zonen. Dabei ist das Kriterium die Vertrauenswürdigkeit der Inhalte der Website.

Wenn Sie Internet Explorer installieren, werden die folgenden Sicherheitszonen eingerichtet:

  • Eine Internetzone, die standardmäßig alle Internetsites enthält.
  • Eine Lokale Intranetzone für Computer, die mit einem lokalen Netzwerk verbunden sind.
  • Eine Zone für vertrauenswürdige Sites, der Sie Sites zuweisen können, denen Sie vertrauen.
  • Eine Zone für eingeschränkte Sites, der Sie Sites zuweisen können, denen Sie nicht vertrauen.
  • Eine Zone Arbeitsplatz, welche die Dateien auf dem lokalen Computer umfasst.

Folgende vier Standard-Sicherheitseinstellungen sind auf diese Zonen anwendbar: Hoch, Mittel, Niedrig und Sehr niedrig. Darüber hinaus können Sie für jede Zone benutzerdefinierte Sicherheitsstufen einstellen.

Sie können alle Sicherheitseinstellungen anzeigen, indem Sie in der Systemsteuerung auf das Symbol Internet und anschließend auf die Registerkarte Sicherheit klicken. Ausführliche Informationen zu diesen Optionen und ihrer Interaktion finden Sie unter Sicherheitsoptionen in Internet Explorer.

Denken Sie daran, dass die Sicherheit im Internet nur so gut wie Ihre Einstellungen ist. Internet Explorer bietet Ihnen die Informationen, die Sie benötigen, um die richtigen Sicherheitsentscheidungen zu treffen, und enthält flexible Hilfsprogramme, um diese Entscheidungen zu implementieren.

Sie können Sicherheitsoptionen mit Hilfe des Assistenten für die Internet Explorer-Anpassung vordefinieren und festlegen, ob Benutzer diese Einstellungen ändern können. Wenn Sie keine Voreinstellung für die Sicherheitsoptionen treffen, sollten Sie den Benutzern unter Umständen entsprechend den Anforderungen Ihrer Organisation und dem Erfahrungsstand der Benutzer Empfehlungen für die optimale Sicherheitsstufe geben.

Anmerkungen

  • Wenn die für das zu erstellende Paket des Internet Explorer-Browsers gewählte Sprache von der Sprache des Internet Explorer-Browsers auf Ihrem Computer abweicht, weist die Sicherheitszonenoberfläche des erstellten Browsers unter Umständen nicht interpretierbare Zeichen auf.
  • Die Zone Arbeitsplatz können Sie ausschließlich in IEAK konfigurieren, die Einstellungen sind auf der Browseroberfläche nicht verfügbar. Es wird empfohlen, grundsätzlich die Standardeinstellungen für diese Zone zu verwenden, sofern in Ihrer Organisation nicht besondere Anforderungen bestehen. Eine niedrigere Sicherheitseinstellung könnte ein Sicherheitsrisiko bedeuten, während eine höhere Sicherheitseinstellung die Funktionalität beeinträchtigen kann.

Weitere Informationen erhalten Sie unter folgenden Themen:

Einrichten der Internetzone

Die Internetzone besteht aus allen Sites, die nicht in anderen Zonen enthalten sind. Standardmäßig ist für die Internetzone die Sicherheitsstufe Mittel festgelegt. Wenn Sie beim Arbeiten im Internet mögliche Sicherheitsprobleme so weit wie möglich ausschließen möchten, können Sie die Einstellung auf Hoch setzen. Wenn Sie die Sicherheitseinstellung erhöhen, wird verhindert, dass einige Webseiten bestimmte potenziell gefährliche Operationen durchführen. Andererseits können hierdurch aber auch sinnvolle Funktionen nicht mehr zur Verfügung stehen, und einige Seiten arbeiten möglicherweise nicht mehr einwandfrei.

Sie können benutzerdefinierte Einstellungen wählen und so jede einzelne Sicherheitsentscheidung für die Zone kontrollieren. Klicken Sie hierfür in der Systemsteuerung auf das Symbol Internet, anschließend auf die Registerkarte Sicherheit und dann auf Stufe anpassen.

Hinzufügen von Sites zu den Zonen der vertrauenswürdigen und eingeschränkten Sites

Sie können bestimmte Websites, denen Sie mehr oder weniger als denen in der Internetzone oder der lokalen Intranetzone vertrauen, zwei Zonen zuweisen. Um Sites zu diesen Zonen hinzuzufügen, wählen Sie zuerst die Zone und klicken dann auf Sites.

Der Zone für vertrauenswürdige Sites wird standardmäßig die Sicherheitsstufe Sehr niedrig zugewiesen. Diese Sicherheitsstufe bezieht sich auf höchst vertrauenswürdige Sites (beispielsweise auf Firmen, mit denen Sie häufig Geschäfte machen), die manchmal als "Extranet" bezeichnet werden. Wenn Sie eine Site der Zone für vertrauenswürdige Sites zuordnen, kann die Site leistungsfähigere Operationen durchführen. Außerdem fordert Internet Explorer Sie weniger häufig auf, Sicherheitsentscheidungen zu treffen. Fügen Sie dieser Zone eine Site nur dann hinzu, wenn Sie glauben, dass die Inhalte der Site Ihrem Computer niemals schaden können. Es wird dringend empfohlen, für die Zone für vertrauenswürdige Sites das Protokoll HTTPS: zu verwenden oder auf andere Art sicherzustellen, dass Verbindungen zu der Site sicher sind.

Der Zone eingeschränkter Sites wird standardmäßig die Sicherheitsstufe Hoch zugewiesen. Wenn Sie eine Site der Zone eingeschränkter Sites zuordnen, kann die Site nur minimale, sehr sichere Operationen durchführen. Diese Zone bezieht sich auf den seltenen Fall einer Site, der Sie nicht vertrauen. Wenn Sie eine hohe Sicherheitsstufe für Inhalte sicherstellen, die nicht vertrauenswürdig sind, arbeiten viele Seiten in dieser Zone nicht einwandfrei.

Einrichten der lokalen Intranetzone (für Netzwerkadministratoren)

Um die Sicherheit zu gewährleisten, ist es zwingend erforderlich, dass die lokale Intranetzone zusammen mit dem Proxyserver und dem Firewall eingerichtet wird. Alle Sites in der Zone sollten "innerhalb des Firewalls" liegen, und Proxyserver sollten so konfiguriert sein, dass die Auflösung eines externen DNS-Namens in dieser Zone nicht erlaubt wird. Das Konfigurieren der Sicherheit der Clientzone erfordert umfassende Kenntnisse über die vorhandenen Netzwerkkonfiguration, Proxyserver und sicheren Firewalls. Wenn Sie diese Kenntnisse nicht besitzen, setzen Sie sich mit Ihrem Netzwerkadministrator in Verbindung.

Standardmäßig besteht die lokale Intranetzone aus lokalen Domänennamen und solchen, die in Proxyumgehungen auf der Registerkarte Verbindung angegeben wurden. Sie konfigurieren diese Einstellungen im Bildschirm Verbindungseinstellungen des Assistenten für die Internet Explorer-Anpassung. Beachten Sie, dass jetzt für jeden Benutzer mehrere Verbindungseinstellungen konfiguriert werden können. Der Netzwerkadministrator sollte bestätigen, dass diese Einstellungen für die Installation tatsächlich sicher sind, oder die Einstellungen so anpassen, dass sie sicher werden.

Beim Einrichten der Zone können Sie angeben, welche URL-Kategorien berücksichtigt werden sollen. Sie können außerdem bestimmte Sites zu der Zone hinzufügen.

So geben Sie im Browser die URL-Kategorien an, die in der Zone enthalten sein sollen

  1. Klicken Sie im Menü Extras von Internet Explorer auf Internetoptionen und dann auf die Registerkarte Sicherheit.
  2. Klicken Sie auf die Zone Lokales Intranet und dann auf Sites.
  3. Aktivieren Sie nach Bedarf die folgenden Kontrollkästchen:

    Alle lokalen Sites (Intranet), die nicht in anderen Zonen aufgeführt sind, einbeziehen
    Alle Sites, die den Proxyserver umgehen, einbeziehen
    Alle Netzwerkpfade (UNCs) einbeziehen

Anmerkungen

  • Um eine bestimmte Site zu dieser Zone hinzuzufügen, klicken Sie auf Erweitert, geben den URL ein und klicken dann auf Hinzufügen. Um die Serverüberprüfung zu verwenden, aktivieren Sie das Kontrollkästchen Für die Sites in dieser Zone ist eine Serverüberprüfung (https:) erforderlich.
  • Um URL-Kategorien für Ihre IEAK-Pakete anzugeben, klicken Sie im Bildschirm Sicherheitseinstellungen des Assistenten für die Internet Explorer-Anpassung auf Importieren der aktuellen Einstellungen der Sicherheitszonen und dann auf Einstellungen ändern.

Die Optionen der lokalen Intranetzone unterliegen den folgenden Regeln. Beachten Sie, dass das Hinzufügen einer Site Vorrang vor den folgenden Regeln hat:

  • Alle lokalen Sites (Intranet), die nicht in anderen Zonen aufgeführt sind, einbeziehen: Intranetsites besitzen Namen, die keine Punkte enthalten, beispielsweise http://local). Ein Sitename wie beispielsweise http://www.microsoft.com ist nicht lokal, da er Punkte enthält. Diese Site wird daher der Internetzone zugewiesen. Die Regel für Intranetsitenamen gilt für URLs, die mit "file:" oder mit "http:" beginnen.
  • Alle Sites, die den Proxyserver umgehen, einbeziehen: Typische Intranetkonfigurationen verwenden einen Proxyserver, um auf das Internet mit einer direkten Verbindung zu Intranetservern zuzugreifen. Diese Einstellung verwendet derartige Konfigurationsinformationen, um für die Zonendefinition Intranet- von Internetinhalten zu unterscheiden. Ist der Proxyserver auf andere Weise konfiguriert, sollten Sie die Option deaktivieren und die Dateien, die der lokalen Intranetzone zugewiesen werden, über andere Optionen bestimmen. In Systemen, die nicht über einen Proxyserver verfügen, wirkt sich die Einstellung nicht aus.
  • Alle Netzwerkpfade (UNCs) einbeziehen: Netzwerkpfade (beispielsweise \\local\file.txt) werden normalerweise für lokale Netzwerkinhalte verwendet, die in der lokalen Intranetzone enthalten sein sollen. Sollen einige Netzwerkpfade nicht in der lokalen Intranetzone enthalten sein, sollten Sie die Option deaktivieren und die Dateien, die der lokalen Intranetzone zugewiesen werden, über andere Optionen bestimmen. Beispielsweise ist es in bestimmten CIFS (Common Internet File System)-Konfigurationen möglich, dass sich ein Netzwerkpfad auf Internetinhalte bezieht.

Nachdem die lokale Intranetzone als sicher bestätigt wurde, können Sie überlegen, ob Sie die Sicherheitsstufe der Zone auf Niedrig oder Sehr niedrig setzen, damit ein größerer Umfang leistungsfähiger Operationen durchgeführt werden kann. Sie können auch einzelne Sicherheitseinstellungen im Dialogfeld Sicherheitseinstellungen anpassen.

Wenn Teile Ihres Intranets weniger sicher oder auf andere Art nicht vertrauenswürdig sind, können sie aus dieser Zone ausgeschlossen werden, indem sie der Zone eingeschränkter Sites zugewiesen werden.

Die lokale Intranetzone sollte über IEAK konfiguriert werden. Sie können jedoch auch die Optionen der Registerkarte Sicherheit des Dialogfelds Internetoptionen verwenden.

Arbeiten mit Domänennamensuffixen

Wenn Sie auf einen Webserver über eine Kurzform der Adresse ohne Domänenangabe verweisen möchten, können Sie ein Domänennamensuffix verwenden. Beispielsweise kann auf einen Webserver mit dem Namen beispiel.microsoft.com als beispiel verwiesen werden. Auf dieselben Inhalte kann außerdem durch die Eingabe http://beispiel.microsoft.com oder http://beispiel zugegriffen werden.

Um diese Möglichkeit einzurichten, müssen Sie das Domänensuffix zur Suchreihenfolge für Domänensuffixe in den TCP/IP-Eigenschaften hinzufügen. Hierzu führen Sie folgende Schritte aus:

  1. Klicken Sie mit der rechten Maustaste auf das Symbol Netzwerkumgebung, und klicken Sie dann auf Eigenschaften.
  2. Öffnen Sie das Dialogfeld Eigenschaften von Mirosoft TCP/IP.
  3. Klicken Sie auf die DNS-Registerkarte, und fügen Sie dann unter Suchreihenfolge für Domänensuffix die gewünschten Informationen hinzu.

Es ist wichtig, dass die Sicherheitszonen für diese Konfiguration ordnungsgemäß eingerichtet werden. Standardmäßig wird der URL ohne Punkte (http://beispiel) der lokalen Intranetzone zugerechnet, während der URL mit Punkten (http://beispiel.microsoft.com) zur Internetzone zählt. Daher müssen Sie die Zoneneinstellungen ändern, wenn Sie eine derartige Konfiguration verwenden und es keine Proxyserverumgehung gibt, um Inhalte eindeutig der richtigen Zone zuzuordnen.

Je nachdem, ob die über das Domänensuffix zugänglichen Inhalte als Intranet- oder Internetinhalte zu betrachten sind, müssen Sie die fraglichen Site-URLs den entsprechenden Zonen zuordnen. Um URLs wie http://beispiel der Internetzone zuzuweisen, deaktivieren Sie das Kontrollkästchen Alle lokalen Sites (Intranet), die nicht in anderen Zonen aufgeführt sind, einbeziehen für die lokale Intranetzone und nehmen die Site in die Siteliste der Zone auf.

Weitere Anmerkungen zur Sicherheit, die alle Zonen betreffen

Webinhalte können entweder über den DNS (Domain Name System)-Namen oder die IP (Internet Protocol)-Adresse angesprochen werden. Bei Sites, die beide Verfahren verwenden, ist es wichtig, beide Bezüge auf die gleiche Zone zu konfigurieren. Im Allgemeinen sind lokale Intranetsites entweder über den lokalen Namen oder über die IP-Adresse in der Proxyumgehungsliste zu identifizieren. Alle anderen Namen und IP-Adressen werden der Internetzone zugewiesen. Wenn jedoch ein Sitename in die Siteliste der Zone für vertrauenswürdige oder für eingeschränkte Sites eingegeben wird, seine IP-Adresse hingegen nicht, wird die Site als Teil der Internetzone behandelt, wenn auf sie über die IP-Adresse zugegriffen wird.

Beachten Sie, dass ein Benutzer Inhalte von einer Zone in eine andere kopieren kann, wodurch unter Umständen die eingestellte Sicherheitsstufe des Inhalts erhöht oder erniedrigt werden kann.

Falls Sie die automatische Konfiguration verwenden und sowohl Internet Explorer 5 (oder später) als auch Internet Explorer 4 von derselben Konfigurationsdatei unterstützen lassen, werden bestimmte Einstellungen, die für die beiden Versionen unterschiedlich sind, nicht für Internet Explorer 4 konfiguriert.


Sicherheitsoptionen in Internet Explorer

Über die Sicherheitszonen von Internet Explorer können Sie Sicherheitsoptionen für Webinhalte angeben. Eine Zone stellt eine Zusammenstellung von Websites dar, denen Sie die gleiche Vertrauenswürdigkeitsstufe zuordnen. Sie fügen eine Website einer bestimmten Zone hinzu und stellen dann entsprechende Sicherheitsoptionen für diese Zone ein.

Sie können die Standardeinstellungen von Internet Explorer so anpassen, dass sie den Sicherheitsfeatures Ihres Systems am besten entsprechen. Für ein sicheres Intranet können Sie beispielsweise in der Regel eine Sicherheitseinstellung von Niedrig oder eine geeignete angepasste Einstellung verwenden (nachdem die lokale Intranetzone für den Firewall konfiguriert wurde).

Die folgenden Absätze beschreiben ausführlich die Bedeutung der Sicherheitsoptionen von Internet Explorer, damit Sie die richtigen Sicherheitsentscheidungen für jede Option in jeder Zone treffen können. Alle Sicherheitsoptionen beziehen sich auf den Internet Explorer-Browser sie gelten nicht systemweit. Andere Internetprogramme ignorieren teilweise diese Optionen.

Um die Firmensicherheitsoptionen einzustellen, müssen Sie die Einstellungen mit IEAK bearbeiten. Der Benutzer zeigt die Sicherheitsoptionen im Browser an, indem er im Menü Extras auf Internetoptionen und dann auf die Registerkarte Sicherheit klickt. Um benutzerdefinierte Einstellungen anzuzeigen, wählt der Benutzer eine Sicherheitszone aus und klickt dann auf Stufe anpassen.

Weitere Informationen erhalten Sie unter folgenden Themen:

ActiveX-Steuerelemente und Plugins

Diese Optionen steuern, wie ActiveX-Steuerelemente und -Plugins vom Administrator genehmigt, gedownloadet, ausgeführt und für Scripting freigegeben werden. Weitere Informationen über das Verwalten und Genehmigen von ActiveX-Steuerelementen finden Sie unter Verwalten von ActiveX-Steuerelementen.

Wenn ein Benutzer ein ActiveX-Steuerelement von einer anderen Site als derjenigen downloadet, in der das Steuerelement verwendet wird, verwendet Internet Explorer die restriktivere Zoneneinstellung der beiden Sites. Wenn beispielsweise ein Benutzer eine Webseite innerhalb einer Zone anzeigt, die einen Download erlaubt (Aktivieren), der Code jedoch aus einer anderen Zone gedownloadet wird, die eine Benutzereingabe erfordert, wird die Benutzereingabeeinstellung verwendet.

ActiveX-Steuerelemente ausführen, die für Scripting sicher sind
Diese Option bestimmt, ob ein als sicher für Scripting markiertes ActiveX-Steuerelement mit einem Skript interagieren kann. Beachten Sie, dass Steuerelemente, die als sicher für die Initialisierung gekennzeichnet sind und mit PARAM-Tags geladen werden, durch diese Option nicht betroffen werden. Diese Option wird ignoriert, wenn ActiveX-Steuerelemente initialisieren und ausführen, die nicht sicher sind auf Aktivieren gesetzt wurde, da diese Einstellung jegliche Objektsicherheit umgeht. Sie können nicht unsichere Steuerelemente skripten, während Sie das Scripting sicherer Steuerelemente blockieren.

ActiveX-Steuerelemente initialisieren und ausführen, die nicht sicher sind
ActiveX-Steuerelemente werden entweder als sicher oder unsicher klassifiziert. Diese Option steuert, ob ein Skript mit unsicheren Steuerelementen interagieren darf. Unsichere Steuerelemente sind nicht zur Verwendung auf Internetwebseiten gedacht, können jedoch in bestimmten Fällen auf Seiten verwendet werden, bei denen absolut sicher ist, dass die Steuerelemente nicht in böswilliger Absicht eingesetzt werden. Die Objektsicherheit sollte erzwungen werden, wenn nicht alle ActiveX-Steuerelemente und Skript, die möglicherweise mit Seiten der Zone interagieren, vertrauenswürdig sind. Die Einstellungen lauten folgendermaßen:

ActiveX-Steuerelemente und Plugins ausführen
Diese Option legt fest, ob ActiveX-Steuerelemente und -Plugins auf Seiten aus der angegebenen Zone ausgeführt werden können. Das Deaktivieren dieser Option verhindert die Ausführung aller ActiveX-Steuerelemente und Plugins; daher werden die anderen ActiveX-Einstellungen ignoriert. Download, Ausführung und Scripting von ActiveX-Steuerelementen stellen drei verschiedene Schritte mit gesonderten Optionen dar. Bei den Downloadoptionen wird zwischen signierten und nicht signierten Steuerelementen unterschieden. Scriptingoptionen können für sichere und unsichere Steuerelemente gesondert eingestellt werden. Ob ein Steuerelement sicher für Scripting (oder Initialisierung) ist, wird vom Autor des Steuerelements bestimmt und sollte nicht mit dem Signieren verwechselt werden; Signieren und Sicherheit sind voneinander unabhängig. Weitere Informationen finden Sie im MSDN Online Web Workshop.

Download von signierten ActiveX-Steuerelementen
Diese Option ermöglicht Benutzern den Download signierter ActiveX-Steuerelemente von Seiten aus dieser Zone. Die Einstellungen lauten folgendermaßen:

  • Aktivieren ermöglicht den Benutzern einen nicht sichtbaren Download beliebiger signierter Steuerelemente.
  • Eingabeaufforderung zeigt eine Warnung an, bevor Benutzer Steuerelemente downloaden, die von nicht vertrauenswürdigen Herausgebern signiert wurden. Bei dieser Einstellung können Benutzer weiterhin einen unsichtbaren Download von durch vertrauenswürdige Herausgeber signiertem Code durchführen.
  • Ablehnen verhindert, dass Benutzer signierte Steuerelemente downloaden.

Download von unsignierten ActiveX-Steuerelementen
Diese Option ermöglicht Benutzern den Download unsignierter ActiveX-Steuerelemente von Seiten aus dieser Zone. Diese Art von Code ist möglicherweise gefährlich, insbesondere dann, wenn er aus einer nicht vertrauenswürdigen Zone stammt.

  • Aktivieren setzt die Objektsicherheit außer Kraft. ActiveX-Steuerelemente werden ausgeführt, mit Parametern geladen und geskriptet, ohne dass die Objektsicherheit für nicht vertrauenswürdige Daten oder Skripts eingestellt wird. Diese Einstellung wird nicht empfohlen, außer in sicheren und verwalteten Zonen. Durch diese Einstellung werden sowohl unsichere als auch sichere Steuerelemente initialisiert und geskriptet, und die Option ActiveX-Steuerelemente ausführen, die für Scripting sicher sind wird ignoriert.
  • Eingabeaufforderung versucht, die Objektsicherheit zu erzwingen. Wenn das ActiveX-Steuerelement jedoch nicht für nicht vertrauenswürdige Daten oder Skripts sicher gemacht werden kann, erhält der Benutzer die Option, das Steuerelement mit Parametern oder geskriptet zu laden.
  • Deaktivieren erzwingt die Objektsicherheit für nicht vertrauenswürdige Daten oder Skripts. ActiveX-Steuerelemente, die nicht sicher gemacht werden können, werden nicht mit Parametern oder geskriptet geladen.

Java

Java-Einstellungen

Die Java-Optionen stehen nur zur Verfügung, wenn die Microsoft virtual machine (Microsoft VM) installiert ist.

Diese Optionen steuern den Download und die Ausführung von Java innerhalb der Zone. Bei Java-Downloads werden, wenn ein Steuerelement von einer anderen Site gedownloadet wird als der, in der die Seite verwendet wird, die Einstellungen der restriktiveren Zone der beiden Sites verwendet. Wenn beispielsweise ein Benutzer auf eine Webseite innerhalb einer Zone zugreift, die einen Download erlaubt, der Code jedoch aus einer anderen Zone gedownloadet wird, die eine Benutzereingabe erfordert, wird die Benutzereingabeeinstellung verwendet.

Die Optionseinstellungen legen Folgendes fest:

  • Die maximale Berechtigungsstufe, die signierten Anwendungen, die aus der Zone gedownloadet werden, unsichtbar gewährt wird.
  • Die Berechtigungen, die unsignierten Applets gewährt werden, die aus der Zone gedownloadet werden.
  • Die Berechtigungen, die Skripts auf Seiten in der Zone gewährt werden, die Applets aufrufen.

Die fünf Optionen lauten folgendermaßen:

  • Benutzerdefiniert steuert die Berechtigungseinstellungen individuell. Im Dialogfeld Angepasste Zugriffsrechte gibt die Registerkarte Nicht signiert die Berechtigungen sowohl für unsignierte Applets als auch für Skripts an, die Java aufrufen. Die Registerkarte Ohne Hinweis zugelassen gibt die Grenze an, bis zu der Applets unsichtbar Berechtigungen gewährt werden.
  • Niedrige Sicherheit ermöglicht das ungehinderte Ausführen aller Operationen durch Applets.
  • Mittlere Sicherheit ermöglicht das Ausführen von Applets in ihrer Sandbox, einem Speicherbereich, außerhalb dessen das Programm keine Aufrufe durchführen kann. Außerdem bietet die Option Möglichkeiten wie beispielsweise "scratch space" (einen sicheren Speicherbereich auf dem Clientcomputer) sowie benutzergesteuerte Dateieingabe/-ausgabe.
  • Hohe Sicherheit ermöglicht das Ausführen von Applets in ihrer Sandbox.
  • Java deaktivieren ermöglicht kein Ausführen von Applets.

Scripting

Active Scripting
Diese Option legt fest, ob Skriptcode auf Seiten der Zone ausgeführt wird.

Scripting von Java-Applets
Diese Option bestimmt, ob Skripts in der Zone Objekte verwenden können, die innerhalb von Java-Applets definiert sind, sodass das Skript auf der Seite mit dem Java-Applet interagieren kann.

Download

Dateidownload
Diese Option steuert, ob Dateidownloads aus der Zone zulässig sind. Diese Option wird durch die Zone der Seite festgelegt, die den Downloadlink enthält, nicht durch die Zone, aus der die Datei übertragen wird.

Schriftartdownload
Diese Option legt fest, ob Benutzer HTML-Schriftarten von Seiten in der Zone downloaden dürfen.

Benutzerauthentifizierung

Anmeldung

Die HTTP-Authentifizierung berücksichtigt die Sicherheitsrichtlinien der Zone für Anmeldeinformationen, die einen der vier folgenden Werte haben können:

  • Automatische Anmeldung nur in der Intranetzone: Fordert zur Eingabe von Benutzer-ID und Kennwort in anderen Zonen auf. Nachdem der Benutzer die Eingaben vorgenommen hat, kann dieser Wert unsichtbar für die restliche Sitzung weiter verwendet werden.
  • Anonyme Anmeldung: Deaktiviert die HTTP-Authentifizierung; das Gastkonto wird nur für CIFS (Common Internet File System) verwendet.
  • Nach Benutzername und Kennwort fragen: Fordert zur Eingabe von Benutzer-ID und -kennwort auf. Nachdem der Benutzer die Eingaben vorgenommen hat, kann dieser Wert unsichtbar für die restliche Sitzung weiter verwendet werden.
  • Automatische Anmeldung mit aktuellem Benutzernamen und Kennwort: Die Anmeldeinformationen werden unter Umständen unsichtbar durch NTLM (Windows NT Herausforderung/Rückmeldung) geprüft, ein Authentifizierungsprotokoll zwischen einem Endbenutzerclient und einem Anwendungsserver, bevor die Eingabeaufforderung angezeigt wird.

Verschiedenes

Auf Datenquellen über Domänengrenzen hinweg zugreifen
Diese Option gibt an, ob Komponenten, die Verbindungen zu Datenquellen herstellen, Verbindungen zu einem anderen Server aufbauen dürfen, um Daten zu ermitteln. Dies gilt nur für Datenbindungen, beispielsweise für aktive Datenobjekte. Die Einstellungen lauten folgendermaßen:

  • Aktivieren ermöglicht den Datenbankzugriff auf jede beliebige Quelle, auch in anderen Domänen.
  • Eingabeaufforderung erfordert eine Benutzereingabe, bevor der Datenbankzugriff auf jede beliebige Quelle in anderen Domänen ermöglicht wird.
  • Deaktivieren ermöglicht den Datenbankzugriff nur auf dieselbe Domäne, in der sich die Seite befindet.

Unverschlüsselte Formulardaten übermitteln
Diese Option bestimmt, ob HTML-Seiten in der Zone Formulare an Server der Zone senden oder von diesen empfangen können. Formulare, die mit SSL (Secure Sockets Layer)-Verschlüsselung gesendet werden, sind immer zulässig; diese Einstellung wirkt sich nur auf das Übergeben von Formulardaten aus, die nicht SSL-verschlüsselt sind.

Anwendungen und Dateien in einem IFRAME starten
Diese Option steuert, ob Benutzer Anwendungen und Dateien von einem IFRAME-Tag (das ein Verzeichnis eines Ordners enthält) auf Webseiten dieser Zone starten können.

Installation von Desktopobjekten
Diese Option steuert, ob Benutzer Desktop-Elemente von Webseiten der Zone installieren können.

Ziehen und Ablegen oder Kopieren und Einfügen von Dateien
Diese Option steuert, ob Benutzer Ziehen und Ablegen oder Kopieren und Einfügen verwenden können, um Dateien von Webseiten innerhalb der Zone zu kopieren.

Zugriffsrechte für Softwarechannel
Die Einstellungen lauten folgendermaßen:

  • Niedrige Sicherheit ermöglicht Folgendes:
    • E-Mail-Benachrichtigung
    • Autodownload
    • Autoinstallation
  • Mittlere Sicherheit ermöglicht Folgendes:
    • E-Mail-Benachrichtigung
    • Autodownload
  • Hohe Sicherheit ermöglicht Folgendes:
    • Keines der Softwarechannel-Verteilungsfeatures

Cookies

Cookies pro Sitzung annehmen (nicht gespeichert)
Bestimmt die Einstellungen für Cookies, Textdateien, in denen Benutzereinstellungen gespeichert werden und die von einer Website verwendet werden, während der Benutzer die Site besucht. Beispielsweise bestimmt diese Einstellung, ob ein "virtueller Einkaufswagen" erstellt werden kann, während ein Benutzer online einkauft. Sitzungsspezifische Cookies bleiben nicht auf der Festplatte gespeichert.

Die Einstellungen lauten folgendermaßen:

  • Aktivieren bedeutet, dass Cookies automatisch akzeptiert werden.
  • Eingabeaufforderung bedeutet, dass eine Benutzereingabe erforderlich ist, bevor ein Cookie erstellt wird.
  • Deaktivieren bedeutet, dass keine Cookies erstellt werden. Wenn Sie sitzungsabhängige Cookies deaktivieren, arbeiten einige Websites unter Umständen nicht ordnungsgemäß.

Cookies annehmen, die gespeichert sind
Bestimmt die Einstellungen für Cookies, die für zukünftige Browsersitzungen auf der Festplatte des Benutzers gespeichert werden. Beispielsweise legt diese Einstellung fest, ob eine Liste von Einstellungen oder der Name eines Benutzers für den nächsten Besuch des Benutzers aufbewahrt werden.

Die Einstellungen lauten folgendermaßen:

  • Aktivieren bedeutet, dass dauerhaft gespeicherte Cookies automatisch akzeptiert werden.
  • Eingabeaufforderung bedeutet, dass eine Benutzereingabe erforderlich ist, bevor ein dauerhaftes Cookie erstellt wird.
  • Deaktivieren bedeutet, dass keine dauerhaften Cookies erstellt werden. Wenn Sie dauerhafte Cookies deaktivieren, bewahren einige Websites ihre Einstellungen nicht bis zur Rückkehr des Benutzers in die Site auf.

Sicherheitsoptionen, die nicht konfiguriert werden können

Die folgenden Optionen sind fest eingestellt und können nicht vom Benutzer bearbeitet werden. Die Zoneneinstellungen Hoch, Mittel, Niedrig und Sehr niedrig wirken sich nicht auf das Verhalten dieser Optionen aus.

Starten aus Webansicht
Diese Option steuert, ob Benutzer Programme und Dateien aus einem Ordner, der als Webseite angezeigt wird, starten können. Diese Einstellung betrifft Benutzer von Windows 98 sowie Benutzer, die eine Aktualisierung von Internet Explorer 4 vorgenommen haben und die Windows Desktop-Aktualisierung verwenden. Die Zone des anpassenden Webinhalts, nicht die Zone des Ordners selbst, bestimmt diese Einstellung:

Arbeitsplatz | Lokales Intranet | Vertrauenswürdige Sites | Internet | Eingeschränkte Sites
Aktivieren | Aktivieren | Aktivieren | Eingabeaufforderung | Eingabeaufforderung


Verwalten von ActiveX-Steuerelementen

IEAK 5 verfügt über ein neues Feature, mit dem der Administrator angeben kann, welche ActiveX-Steuerelemente in einer bestimmten Zone ausgeführt werden dürfen. In zwei Szenarien bietet dieses Feature eine umfassendere Verwendungskontrolle für ActiveX-Steuerelemente und somit eine höhere Sicherheitsstufe.

Szenario 1: Eingeschränkte Verwendung von ActiveX-Steuerelementen im Internet

Viele Organisationen machen ausgiebigen Gebrauch von ActiveX-Steuerelementen im lokalen Intranet, möchten jedoch die Verwendung von ActiveX-Steuerelementen außerhalb des Firewalls (d. h. in der Internetzone) einschränken. Während bei lokalen Intranetinhalten davon ausgegangen werden kann, dass sie mit verwendeten Steuerelementen keine bösartigen Ziele verfolgen, sind diese Steuerelemente zur Verwendung auf Internetwebseiten nicht geeignet. Indem der Administrator nur bestimmte generische Steuerelemente zur Verwendung im Internet zulässt, können Sites, die Steuerelemente verwenden, weiterhin unterstützt werden, während gleichzeitig die unerwünschte Verwendung anderer Steuerelemente in dieser Zone unterbunden wird.

Beispielsweise möchten Sie als Administrator einerseits die Verwendung von ActiveX-Steuerelementen einschränken und gleichzeitig zulassen, dass eine wichtige Internetsite (etwa die eines Geschäftspartners oder Dienstanbieters) mit ActiveX-Steuerelementen arbeitet. Besuchen Sie die Site, und ermitteln Sie die verwendeten ActiveX-Steuerelemente, indem Sie nach neuen Einträgen im Unterordner Downloaded Program Files des Windows-Ordners suchen. Führen Sie das am Ende dieses Themas aufgeführte Verfahren durch, um anzugeben, dass die Steuerelemente vom Administrator genehmigt sind.

Nach der Konfiguration dürfen genau diese Steuerelemente in der Site ausgeführt werden. Versuche einer Internetsite, andere Steuerelemente zu verwenden, beispielsweise die für das Intranet bestimmten, werden blockiert.

Szenario 2: Eingeschränkte Verwendung von ActiveX-Steuerelementen

Sie erreichen eine umfassendere Kontrolle, indem Sie alle genehmigten ActiveX-Steuerelemente auflisten und dann nur die Ausführung dieser genehmigten Steuerelemente durch den Browser zulassen. Allerdings bedeutet es einen beträchtlichen Aufwand, alle Steuerelemente aufzuzählen, die der Administrator zulassen möchte. Daher ist dieser Ansatz nur empfehlenswert, wenn die Gesamtzahl der Steuerelemente relativ niedrig ist.

Bestimmen Sie, welche Steuerelemente zur Verwendung in jeder Site genehmigt werden. Für Zonen mit Sites, die diese Steuerelemente verwenden dürfen, führen Sie das Verfahren am Ende dieses Themas durch, um anzugeben, dass die Steuerelemente vom Administrator genehmigt sind. Für Zonen mit Sites, die diese Steuerelemente nicht verwenden dürfen, wählen Sie Deaktivieren im Bereich ActiveX-Steuerelemente und Plugins ausführen. Jetzt können nur die angegebenen Steuerelemente auf Webseiten ausgeführt werden, und zwar nur in den erlaubten Zonen.

Wählen der ActiveX-Steuerelemente

Einige häufig verwendete ActiveX-Steuerelemente sind in der Datei der vom Administrator genehmigten ActiveX-Steuerelemente Axaa.adm aufgeführt, die in IEAK enthalten ist. Diese Liste stellt keine Empfehlung dar, sie enthält lediglich einige der im Web gängigen ActiveX-Steuerelemente. Als Administrator sollten Sie selbst einschätzen, welche dieser Steuerelemente (oder auch keine) zur Verwendung in Ihrer Organisation geeignet sind. Sie können die Datei bearbeiten und beliebige Steuerelemente hinzufügen. Standardmäßig werden keine Steuerelemente als genehmigt aufgeführt. Falls Sie weitere Steuerelemente hinzufügen möchten, nachdem die Benutzer Internet Explorer bereits installiert haben, können Sie die automatische Konfiguration verwenden.

Um anzugeben, dass ActiveX-Steuerelemente von einem Administrator genehmigt werden müssen, und um die genehmigten Steuerelemente festzulegen, führen Sie die folgenden Schritte aus:

  1. Zeigen Sie die Einstellungen für ActiveX-Steuerelemente in der Datei Axaa.adm an, die sich im Unterordner \Policies\<Sprache> des IEAK-Ordners befindet. Falls Sie der Liste weitere Steuerelemente hinzufügen möchten, beispielsweise solche, die in Ihrer Organisation erstellt wurden, bearbeiten Sie die Datei Axaa.adm in einem Texteditor.

    Für den Fall, dass Sie die ursprünglichen Einstellungen wiederherstellen möchten, sollten Sie eine Sicherungskopie dieser Datei erstellen.

  2. Klicken Sie im Bildschirm Sicherheitseinstellungen des Assistenten für die Internet Explorer-Anpassung auf Importieren der aktuellen Einstellungen der Sicherheitszonen, und klicken Sie dann auf Einstellungen ändern.
  3. Wählen Sie die Zone aus, für die Sie ActiveX-Steuerelemente verwalten möchten, und klicken Sie dann auf Stufe anpassen.
  4. Klicken Sie im Bereich ActiveX-Steuerelemente und Plugins ausführen auf Vom Administrator genehmigt.
  5. Wiederholen Sie die letzten beiden Schritte so lange, bis Sie alle gewünschten Zonen eingerichtet haben.
  6. Klicken Sie im Bildschirm Praktiken und Einschränkungen in Schritt 5 des Anpassungsassistenten auf die Kategorie Steuerungsmanagement, um ihren Inhalt anzuzeigen, und aktivieren Sie die Kontrollkästchen der Steuerelemente, die Sie genehmigen möchten.


Signieren Ihrer Programme

Sie können jetzt IEAK verwenden, um die angepassten Pakete digital zu signieren. Digitale Signaturen geben an, woher Programme kommen, und gewährleisten, dass sie nicht verändert wurden. Das Signieren Ihrer angepassten Browserpakete sowie aller angepassten Programme stellt sicher, dass Benutzer keine Warnmeldungen erhalten, wenn sie die angepassten Browser installieren.

Zunächst benötigen Sie jedoch ein digitales Zertifikat, mit dem Sie Ihre Dateien signieren. Beim Ausführen des Assistenten für die Internet Explorer-Anpassung müssen Sie den Speicherort des Zertifikats angeben. Während das Paket erstellt wird, werden die Dateien dann vom Assistenten signiert. Weitere Informationen zum Anfordern von digitalen Zertifikaten finden Sie im Abschnitt "Bezugsquellen für digitale Zertifikate"

Wenn Sie angepasste Pakete über das Internet verteilen möchten, müssen Sie die erstellten angepassten .CAB-Dateien (*.cab) vom IEAK signieren lassen. Falls Sie die angepassten Pakete über ein Intranet verteilen möchten, signieren Sie die angepassten Dateien, oder konfigurieren Sie die lokale Intranetzone mit der Sicherheitseinstellung Niedrig vor. Bei der Standardsicherheitseinstellung können Benutzer unsignierte Programme bzw. unsignierten Code nicht downloaden. Weitere Informationen über Sicherheitszonen finden Sie unter Sicherheit in Internet Explorer.

Die folgenden angepassten Dateien werden signiert:

Dateiname | Funktion dieser Datei
Branding.cab | Branding-Informationen für Windows Update Setup
Desktop.cab | Windows Desktop-Aktualisierung
ecif.cab | Identifiziert die Microsoft Internet-Komponenten, die als Bestandteile des Windows Update Setup-Programms installiert werden
IE5setup.exe | Windows Update Setup-Programm
Mmssetup.exe | Setup-Programm für den MSN Messenger Service-Client
MMSsetup.cab | Branding-Informationen für den MSN Messenger Service-Client
Custom<n>.cab | Angepasste Komponenten, die nach dem Neustart des Systems installiert werden. Jede Komponente ist in einer separaten, nummerierten CAB-Datei zusammengestellt.

Ein Flussdiagramm zur Erläuterung, wie der Assistent für die Internet Explorer-Anpassung diese Dateien erstellt, finden Sie unter Erstellen angepasster Pakete mit IEAK.

Anmerkungen

  • Möglicherweise wird verhindert, dass Benutzer ActiveX-Steuerelemente oder Java-Pakete installieren, die nicht signiert sind.
  • Außerdem müssen Sie alle angepassten Programme (entweder im EXE- oder CAB-Format) signieren, die Sie in Ihr Browserpaket aufnehmen.
  • Falls Ihre Organisation voraussichtlich die Installation bei Bedarf via Internet einsetzen wird, müssen Sie die .CAB-Dateien signieren und den Server, auf dem sich die .CAB-Dateien befinden, in den Sicherheitseinstellungen als vertrauenswürdigen Server angeben. Für eine reine Intranetsite können Sie auch die Sicherheitsstufe Niedrig einstellen. Weitere Informationen über dieses Feature finden Sie unter Verwalten der Installation bei Bedarf.

    Ist die Sicherheitsstufe Ihres Intranets auf Mittel oder höher eingestellt, müssen Sie Ihre Netzwerkserver als vertrauenswürdige Server angeben. Führen Sie hierfür die folgenden Schritte aus:

    1. Klicken Sie auf der Seite Sicherheitseinstellungen im Assistenten auf Importieren der aktuellen Einstellungen für Sicherheitszonen, und klicken Sie dann auf Einstellungen ändern.
    2. Wählen Sie die Zone Lokales Intranet aus, und klicken Sie dann auf Sites.
    3. Deaktivieren Sie das Kontrollkästchen Alle Netzwerkpfade (UNCs) einbeziehen, und klicken Sie dann auf OK.
    4. Wählen Sie die Zone Vertrauenswürdige Sites aus, klicken Sie auf Sites, geben Sie den Pfad des Downloadservers an, und klicken Sie dann auf Hinzufügen.
    5. Wiederholen Sie den vorherigen Schritt für jeden Downloadserver, der als vertrauenswürdig eingestuft werden soll.

Weitere Informationen erhalten Sie unter folgenden Themen.

Bezugsquellen für digitale Zertifikate

Digitale Zertifikate stellen einen Bestandteil der Authenticode(tm)-Technologie dar, durch welche die Herkunft von Programmen gekennzeichnet und sichergestellt wird, dass Programme nicht verändert wurden. Zertifikate sind entweder von einer Zertifizierungsstelle oder von einem privat betriebenen Zertifikatserver erhältlich. Es gibt kommerzielle und individuelle Zertifikate.

Weitere Informationen zu Authenticode und zur Sicherheit finden Sie in der Microsoft Security Advisor-Website unter http://www.microsoft.com/security/.

Wie signieren Sie ".CAB"-Dateien und angepasste Programme?

Nachdem Sie ein Zertifikat erhalten haben, müssen Sie den Code signieren. Tools zum Signieren von Code erhalten Sie vom Microsoft Site Builder Network Workshop.

Daneben müssen Sie die öffentlichen und privaten Schlüssel kennen, bei denen es sich um zusammengehörige Schlüsselmengen handelt, die der Softwareherausgeber für die Verschlüsselung und Entschlüsselung erstellt. Die Schlüssel werden zu dem Zeitpunkt erstellt, zu dem das Zertifikat von einer Zertifizierungsagentur (CA) angefordert wird. Sie werden auf Ihrem Computer erzeugt, und Ihr privater Schlüssel wird niemals an die Zertifizierungsagentur oder einen anderen Empfänger gesendet.

Was passiert, wenn Zertifikate ablaufen?

Das Ablaufen von Zertifikaten bietet zusätzliche Sicherheit. Wenn beispielsweise eine Universität alle Studierenden mit digitalen Kennungen (IDs) zertifiziert, läuft jede ID ab, wenn die oder der Studierende die Universität verlässt. Code, der mit einem abgelaufenen Zertifikat signiert ist, ist ungültig. Nachdem das Zertifikat abgelaufen ist, muss der Softwareherausgeber den Code neu signieren und neue Versionen dieses Codes bereitstellen.

Softwareherausgeber können Code mit einem Zeitstempel versehen, um zu beweisen, dass das Zertifikat gültig war, als der Code signiert wurde. Der signierte Code bleibt dann sogar gültig, nachdem das Zertifikat abgelaufen ist.

So können Sie mit Authenticode steuern, was der Benutzer sehen kann

Wenn Sie Firmenadministrator sind, können Sie Sicherheitszonen vorkonfigurieren, Inhaltsfilter voreinstellen und Zertifizierungsstellen anpassen. Ferner können Sie durch Festlegen von Systemrichtlinien und Einschränkungen regeln, ob Benutzer ihre Sicherheitseinstellungen ändern können. Informationen zu bestimmten Einstellungen finden Sie unter Sicherheitsoptionen in Internet Explorer.

Sie können sicherstellen, dass Benutzer Warnungen erhalten, wenn sie versuchen, potenziell unsichere Inhalte anzuzeigen. Außerdem können Sie verhindern, dass Benutzer nicht signierte ActiveX-Steuerelemente und Java-Pakete downloaden.

Was passiert, wenn Sie Ihren Code signieren?

Der Vorgang der Codesignierung ist einfach und sicher. Sie müssen die technischen Einzelheiten der Codesignierung nicht kennen, um Ihren Code zu signieren.

Nachdem der Code entwickelt und getestet wurde, signiert ein Softwareherausgeber den Code. Der Herausgeber verwendet ein Signierprogramm, beispielsweise Signcode.exe, um einen Hash-Algorithmus auf den Code anzuwenden und so einen Auszug der Datei zu erstellen. Dieser Auszug wird von dem Programm auf Betriebssystemebene mit dem privaten Schlüssel verschlüsselt und mit dem Namen des Hash-Algorithmus und dem CA-Zertifikat (das den Namen des Herausgebers, den öffentlichen Schlüssel usw. enthält) zu einer Struktur kombiniert, die als Signaturblock bezeichnet wird. Anschließend wird der Block erneut in die Codedatei eingebettet, und die Datei ist bereit zur Verteilung über das Internet. Beachten Sie, dass eine signierte .CAB-Datei ebenfalls einen Signaturblock enthält.

Wenn der Benutzer die Datei aus dem Internet downloadet, ruft die Downloadanwendung eine Überprüfungsfunktion auf. Auf den Aufruf hin extrahiert das Betriebssystem den Signaturblock, bestimmt die CA, die das Zertifikat herausgegeben hat, und entschlüsselt mit Hilfe des öffentlichen Schlüssels den Auszug. Anschließend wird unter Verwendung des im Signaturblock angegebenen Hash-Algorithmus ein zweiter Auszug erstellt. Wenn der Code seit dem Signieren nicht geändert wurde, entspricht der neue Auszug dem alten. Wenn sich die beiden Auszüge nicht entsprechen, wurde entweder der Code geändert, oder der öffentliche und der private Schlüssel bilden kein entsprechendes Paar. In beiden Fällen wird der Code als verdächtig eingestuft, und der Benutzer erhält eine Warnung.


Erweiterte Anpassung des Messenger Service-Clients

Falls Ihr angepasster Messenger Service-Client hinter einem Firewall (beispielsweise in einem Firmen-Intranet) verwendet wird, können Sie den Client für die Unterstützung von Proxyservern vorkonfigurieren. Allerdings können Sie die vom Messenger Service-Client verwendeten Proxyeinstellungen nicht im IEAK-Assistenten konfigurieren. Um eine Proxyserveranpassung in die Installationsdatei des Messenger Service-Clients aufzunehmen, müssen Sie statt dessen eine der Konfigurationsdateien bearbeiten und anschließend den Assistenten erneut ausführen. In den meisten Fällen ist jedoch eine Proxyserveranpassung nicht erforderlich, da das Messaging-Protokoll auf TCP basiert und normalerweise in allen Situationen funktioniert, in denen der Benutzer nicht durch einen Firewall abgeschirmt ist.

Wichtig

  • Falls Sie Proxyeinstellungen konfigurieren, geben Sie im Abschnitt MSN Messenger Service Branding des IEAK-Assistenten keinen Download-URL an. Der Download-URL ist in der E-Mail-Einladung des Clients enthalten, und Einladungen sind nicht notwendigerweise auf Benutzer beschränkt, die sich hinter Ihrem Firewall befinden und Ihren Proxyserver verwenden. Lassen Sie das Feld für den Download-URL leer, sodass die E-Mail-Einladung auf die standardmäßige Installationsdatei des MSN Messenger Service-Clients verweist, und informieren Sie Ihre Benutzer, dass die E-Mail-Einladung kein sinnvolles Werkzeug für die Distribution des Clients innerhalb Ihrer angepassten Proxyumgebung darstellt.

So konfigurieren Sie die Proxyeinstellungen des Messenger Service-Clients

  1. Führen Sie den IEAK-Assistenten aus, und richten Sie nach Ihren Anforderungen alle benötigten Konfigurationen für den angepassten Messenger Service-Client und weitere Komponenten ein. Dadurch wird eine Ursprungsversion der Konfigurationsdateien und Installationspakete sowohl für Internet Explorer als auch den Messenger Service-Client erzeugt. Sie werden jedoch diese ursprünglichen Installationspakete nicht verwenden, sondern sie zum Erstellen neuer Pakete nutzen.
  2. Suchen Sie die Datei Msmsgs.in_, die beim Ausführen des Assistenten erstellt wurde. Diese Datei befindet sich innerhalb des Versionsordners in den jeweiligen Unterordnern des Ordners Ins für das Betriebssystem und die Sprache. (Pfadbeispiel: Build-Ordner\Ins\Win32\De\Msmsgs.in_.) Öffnen Sie die Datei Msmsgs.in_ mit einem Texteditor , z. B. dem Windows-Editor.
  3. Falls Sie einen Proxyserver angeben, fügen Sie folgende Textzeile am Ende der Datei ein:
    ProxyOn=1
  4. Legen Sie als Proxyservertyp entweder SOCKS4 oder SOCKS5 fest, indem Sie eine der folgenden Textzeilen hinzufügen:
    ProxyVersion=4
    oder
    ProxyVersion=5
  5. Geben Sie den Standort des Proxyservers durch Hinzufügen der folgenden Textzeile an:
    ProxyServer=[DNS-Name oder IP-Adresse]
  6. Geben Sie den Anschluss an, den der Proxyserver für die ursprüngliche Verbindungsaufnahme verwendet, indem Sie folgende Textzeile hinzufügen:
    ProxyPort=1080
    1080 ist der Standardanschluss für SOCKS4. Geben Sie eine andere Anschlussnummer ein, wenn Ihr Proxyserver anders konfiguriert ist.
  7. Speichern Sie die Datei unter ihrem ursprünglichen Namen, und beenden Sie den Texteditor.
  8. Führen Sie den IEAK-Assistenten erneut aus. Klicken Sie im Bildschirm Dateiablage des IEAK-Assistenten auf die Schaltfläche Weitere Optionen.
  9. Wählen Sie im Dialogfeld Weitere Optionen den Speicherort, an dem der IEAK-Assistent die Datei Install.ins gespeichert hat, und wählen Sie sie aus. Der Verweis auf die Datei Install.ins ermöglicht das Laden aller vorherigen Einstellungen, obwohl die Anpassungseinstellungen für den Messenger Service-Client in der Datei Msmsgs.in_ enthalten sind. Klicken Sie auf OK.
  10. Fahren Sie mit dem Ausführen des Assistenten fort, um die neuen .EXE- und .CAB-Dateien für den Messenger Service-Client, aber auch für komplette Browserpakete zu erzeugen.

Das Setup-Programm konfiguriert nun den Messenger Service-Client dahingehend vor, dass die Verbindung zum Messagingserver über den angegebenen Proxyserver hergestellt wird. Falls das Protokoll SOCKS5 verwendet wird und eine Benutzerauthentifizierung erfolgt, bevor die Verbindung zu Ihrem Proxyserver aktiviert werden kann, müssen die Benutzer im Dialogfeld Optionen | Verbindung des angepassten Messenger Service-Clients ihre netzwerkspezifischen Benutzernamen und Kennwörter eingeben. Alle Proxyoptionen sind nach der Installation vom Benutzer mit Hilfe von Messenger Service-Clientoptionen konfigurierbar.


Werbeinhalte in Ihrem angepassten Messenger Service-Client

Mit Hilfe der .XML-Datei für Werbeinhalte können Sie im Werbebereich des Hauptfensters des Messenger Service-Clients eigene werbliche Inhalte einfügen. Beim MSN Messenger Service-Client werden diese Werbeinhalte von MSN verwaltet. Wenn Sie eine .XML-Werbeinhaltedatei angeben, werden Ihre Werbeinhalte und die von MSN vorgegebenen Werbeinhalte abwechselnd nach folgendem zeitlichen Schema eingeblendet:

Inhalt | Dauer
Ihr Logo (festgelegt im Feld Logo) | ca. 7,5 Sekunden
MSN-Netzwerk-Kompatibilitätslogo | ca. 7,5 Sekunden
Ihre Werbeinhalte (festgelegt in der .XML-Datei) | ca. 45 Sekunden
Ihr Logo (festgelegt im Feld Logo) | ca. 7,5 Sekunden
MSN-Netzwerk-Kompatibilitätslogo | ca. 7,5 Sekunden
Von MSN vorgegebene Inhalte | ca. 45 Sekunden

Dieses Schema wiederholt sich etwa alle 120 Sekunden.

Die .XML-Datei wird auf einem Webserver in Ihrer Site verwaltet. Sie können stets die gleiche .XML-Datei verwenden oder sie gegen eine neue Datei an demselben Speicherort austauschen, um aktuelle Werbeinhalte einzubringen (der URL darf nicht geändert werden). Der Messenger Service-Client kann so konfiguriert werden, dass er den Server im Abstand von fünf Minuten auf neue .XML-Dateien überprüft und diese downloadet. Sie können dieselben Inhalte im Bereich für Werbeinhalte weiterhin anzeigen oder für jede Werbeeinblendung unterschiedliche Inhalte anzeigen, indem Sie mehr als eine "article-group" angeben. Sie können bis zu fünf "article-groups" festlegen. Weitere Informationen finden Sie unter Werbesequenzen für Messenger Service im .XML-Dateiformat.

Tipps zu Formatierungen

"article-groups" können eines der folgenden Elemente enthalten:

  • Ein großes .GIF-Bild im Format 234x60 Pixel. Diese .GIF-Grafik kann animiert sein.
  • Bis zu drei Textlinks. Die Links werden als Liste mit Aufzählungszeichen dargestellt.
  • Bis zu drei Textlinks und eine kleinformatige Grafik im .GIF-Format. Diese .GIF-Grafik kann animiert sein. Die Links werden als Liste mit Aufzählungszeichen dargestellt, und die Grafik wird linksbündig neben den Links angezeigt. Da durch die Breite der Grafik die verfügbare Fläche zur Anzeige der Links eingeschränkt wird, wird empfohlen, eine Grafik mit den Abmessungen von 60x60 Pixel zu verwenden. Die Grafik sollte auf keinen Fall höher als 60 Pixel sein.

Wird der Werbetext abgeschnitten, so werden die Textlinks nicht umbrochen, und die Bildlaufleisten werden nicht ordnungsgemäß angezeigt. Abgeschnittene Textlinks können mit einer Ellipse (...) enden. In diesem Fall wird der Textlink "Hier erscheint ein sehr langer Linktext" als "Hier erscheint e..." angezeigt. Der Umfang von Grafiken und Linktext sollte so gering sein, dass dieses Problem nicht entsteht. Benutzer können zwar die Größe des Hauptfensters ändern, im Normalfall dürfte jedoch die schmale Standardbreite des Fensters beibehalten werden.

Anmerkung

  • "article-groups" mit Links verfügen in der Regel über ein ansprechenderes Erscheinungsbild und sind leichter zu bemerken, wenn Sie mit einer Grafik versehen sind.


Werbesequenzen für Messenger Service im ".XML"-Dateiformat

Die .XML-Datei für Werbeinhalte wird über einen Server an Ihrem Standort bereitgestellt und wird mit Hilfe eines Messenger Service-Clients in konfigurierbaren Abständen aktualisiert. Die Zeichenfolgen in der Datei sollten UTF-8-codiert sein (ASCII wird automatisch UTF-8-codiert), und BOM-Verfahren (Byte Order Mark) sind erlaubt. Das durch den XML-Code festgelegte Format muss genau befolgt werden, damit der Inhalt in den Messenger Service-Clients ordnungsgemäß angezeigt wird. Microsoft übernimmt für Fehler bei der XML-Codierung und für deren Auswirkungen keinerlei Verantwortung. Allgemeine Informationen zum Einbinden von Werbeinhalten in Ihren angepassten Messenger Service-Client finden Sie unter Werbeinhalt in Ihrem angepassten Messenger Service-Client.

Tag-Referenztabelle

Tag | Beschreibung | Übergeordnet
msn-data | Erforderlich. Der übergeordnete Container für Werbeinhalte. | (keines)
RefreshLogin | Erforderlich. Ein Boole'scher Wert, über den festgelegt wird, wann neue Inhalte gedownloadet werden. Ist RefreshLogin auf True gesetzt, wird bei jeder Anmeldung eines Benutzers eine neue .XML-Datei vom Server gedownloadet, und der Aktualisierungszeitgeber wird auf den Wert "0" zurückgesetzt. Ist RefreshLogin auf False gesetzt, werden die Inhalte nicht bei jeder Anmeldung aktualisiert, sondern nur, wenn das Aktualisierungsintervall erreicht wird, und der Aktualisierungszeitgeber zwischen zwei Anmeldungen übertragen wird. Empfohlene Einstellung: RefreshLogin=True. Sie können den Wert für RefreshLogin auf False setzen, wenn Sie befürchten, dass Ihr XML-Server zu Spitzenzeiten oder nach einem Ausfall durch vermehrte Anfragen sehr hohen Datenbelastungen ausgesetzt ist. | msn-data
RefreshInterval | Erforderlich. Die Zeitdauer in Minuten, bis die .XML-Datei auf dem Client erneut vollständig aktualisiert wird. Wenn der Benutzer sich abmeldet und RefreshLogin den Wert False hat, wird der Wert des Zeitgebers in die nächste Sitzung übernommen. Der minimale Wert ist 5, der maximale Wert ist 10080 (eine Woche). | msn-data
article-group | Container für Artikel-Zusammenstellungen. Über die Artikelgruppe werden jeweils die Inhalte festgelegt, die im Bereich für Werbeinhalte angezeigt werden. Ist mehr ale eine Artikelgruppe verfügbar, werden die verfügbaren Artikelgruppen reihum angezeigt. In der .XML-Datei mit den Werbeinhalten muss mindestens eine, und es dürfen höchstens fünf Artikelgruppen festgelegt sein. Artikelgruppen dürfen nicht mehr als drei Links und eine Grafik enthalten. | msn-data
article | Container für die einzelnen Artikel. Ein Artikel kann entweder ein Link (dies ist die Standardeinstellung) oder ein Bild sein. In diesem Fall muss der Container mit <article type="image"> festgelegt werden. | article-group
image-url | Legt den URL fest, der mit der Grafik verknüpft sein soll. Ist nur verfügbar, wenn <article type="image"> angegeben wurde. Im Bereich für Werbeinhalte können nur .GIF-Dateien angezeigt werden. Das JPEG-Format ist nicht zulässig. Die empfohlenen Abmessungen für die Grafik betragen 60x60 Pixel, wenn Sie eine Grafik und mehrere Links anzeigen möchten. Wenn Sie nur eine einzelne Grafik und keine Links anzeigen möchten (beispielsweise ein Werbebanner), so sollten die Abmessungen 234x60 Pixel nicht überschreiten. Sie können animierte .GIF-Dateien verwenden. | article type="image"
url | Legt den URL fest, zu dem in einem neuen Browserfenster gewechselt wird, wenn der Benutzer auf den Link bzw. die Grafik klickt. | article
titel | Legt den Text fest, der dem Benutzer als Linkziel angezeigt wird. Sollte nur verwendet werden, wenn nicht <article type="image"> angegeben wurde. | article

Beispiel

<?xml version="1.0"?>
<msn-data>
 <RefreshLogin>True</RefreshLogin>
 <RefreshInterval>360</RefreshInterval>

 <article-group>

  <article type="image">
   <image-url>http://msdn.microsoft.com/workshop/graphics/icons/xml.gif</image-url>
   <url>http://msdn.microsoft.com/xml/index.asp</url>
  </article>

  <article>
   <title>Einzelheiten über XML erfahren Sie bei MSDN</title>
   <url>http://msdn.microsoft.com/xml/index.asp</url>
  </article>

  <article>
   <title>XML-Entwicklerleitfaden von MSDN</title>
   <url>http://msdn.microsoft.com/xml/xmlguide/default.asp</url>
  </article>

  <article>
   <title>Chatten über XML</title>
   <url>http://msdn.microsoft.com/chats/xml.asp</url>
  </article>

 </article-group>

 <article-group>

  <article>
   <title>MSN Messenger Service - FAQ</title>
   <url>http://messenger.msn.com/support/knownissues.asp</url>
  </article>

  <article>
   <title>MSN Messenger Service-Downloads</title>
   <url>http://messenger.msn.com/download/download.asp</url>
  </article>

  <article>
   <title>MSN Messenger Service - International</title>
   <url>http://messenger.msn.com/support/intl_map.asp</url>
  </article>

 </article-group>

</msn-data>


Ausführen von Setup im Batchmodus

Der Assistent für die Internet Explorer-Anpassung ermöglicht es Ihnen, die Funktionen und die Benutzerführung des Windows Update Setup-Programms zu steuern. Darüber hinaus können Sie den Installationsablauf weiter steuern, indem Sie Batchdateien, Befehlszeilenparameter oder eine Kombination beider Möglichkeiten anwenden. Diese Methoden sind unabhängig davon anwendbar, ob Internet Explorer einzeln oder mit Microsoft Office installiert wird.

In den meisten Fällen bietet die Batchdateimethode einen größeren Steuerungsspielraum bei der Installation einzelner Komponenten und erfordert weniger Schritte. Die Befehlszeilenparameter werden für die Abwärtskompatibilität und zur Unterstützung benutzerdefinierter Lösungen bereitgestellt.

Erstellen einer Batchdatei

Verwenden Sie zum Erstellen einer Batchdatei einen Texteditor wie den Microsoft Editor, und nennen Sie die Datei IEbatch.txt. Wenn Sie planen, die Batchdatei mittels Befehlszeilenparametern aufzurufen, können Sie auch andere Namen für die Batchdatei verwenden, jedoch muss in der Befehlszeilenparameter-Syntax stets auf den richtigen Dateinamen verwiesen werden. Weitere Informationen hierzu erhalten Sie unter Batchdateisyntax. Ein Beispiel hierzu finden Sie unter Beispieldatei für die Installation im Batchmodus.

Verwenden von Batchdateien zur Verteilung von Internet Explorer

Wenn Sie Internet Explorer über das Internet oder ein Intranet verteilen, können Sie die Batchdatei auf der Site bereitstellen, von der Benutzer Internet Explorer downloaden. Wenn Sie andere Medien zur Verteilung von Internet Explorer wählen, wie beispielsweise eine CD oder eine Diskette, können Sie die Batchdatei auf dem entsprechenden Medium speichern. Legen Sie sie in dem gleichen Ordner ab, in dem sich auch die Datei Ie5setup.exe befindet.

Die Batchdatei kann an einem separaten Ort gespeichert werden, falls die Datei zu dem Zeitpunkt, an dem das IEAK-Paket erstellt wurde, nicht verfügbar war, oder falls Sie die Setup-Optionen, die Sie in Ihrem angepassten IEAK-Paket festgelegt haben, vorübergehend oder dauerhaft ändern möchten.

Ausführen des Setup-Programms mit Befehlszeilenparametern

Wenn Sie Internet Explorer und andere Komponenten mit Ihrem Produkt bündeln, verwenden Sie üblicherweise Befehlszeilenparameter, um das IEAK-Paket als integrierten Bestandteil Ihres Setup-Programms zu installieren. Falls Sie den Installationsvorgang mit Hilfe von Befehlszeilenparametern anpassen möchten, können Sie dazu entweder den in IEAK enthaltenen IExpress-Assistenten verwenden oder Ihre Installationsdateien mit einem anderen Programm zusammenstellen.

Weitere Informationen finden Sie unter Parameter für die Ausführung von Internet Explorer-Setup im Batchmodus und Parameter für die Installation von IExpress im Batchmodus.

Gründe für das Ausführen des Setup-Programms über die Befehlszeile oder eine Batchdatei

Folgende Gründe können für das Einfügen weiterer Steuerelemente in das Windows Update Setup-Programm maßgeblich sein:

Implementieren einer automatischen Installation

Wenn Sie Firmenadministrator sind, möchten Sie Internet Explorer wahrscheinlich außerhalb der normalen Büroarbeitszeit an die Benutzer zu verteilen. IEAK ermöglicht eine "nicht sichtbare" Installation, bei der nur wenige Benutzereingriffe erforderlich sind; möglicherweise möchten Sie jedoch in irgendeiner Weise Einfluss auf diesen Vorgang nehmen. Mit Hilfe von Einstellungen in der Batchtextdatei oder durch Befehlszeilenparameter können Sie festlegen, welche Meldungen für den Benutzer sichtbar sind und ob der Computer nach Abschluss der Installation neu gestartet wird.

Vertreiben von Internet Explorer

Sind Sie ein unabhängiger Softwareanbieter, können Sie Internet Explorer in Ihr Programm integrieren und Internet Explorer auch ohne Symbole und Browseroberfläche installieren. Verwenden Sie hierzu eine Batchdatei mit der Option Redist oder dem Parameter /X. Weitere Informationen erhalten Sie unter Parameter für die Ausführung von Internet Explorer-Setup im Batchmodus.

Erhalten zusätzlicher Steuerungsmöglichkeiten für bestimmte Komponenten

Mittels einer Batchdatei lassen sich Komponenten installieren und steuern, unabhängig davon, ob diese Komponenten in Ihrem IEAK-Paket enthalten sind. Außerdem können Sie die Installationsmodi (z. B. Standard oder Minimal) einschränken, die den Benutzern zur Verfügung stehen. Verwenden Sie zum Kennzeichnen Ihrer Komponente die ComponentID, eine Zeichenfolge wie etwa NetMeeting. Die Angabe der ComponentID finden Sie in der Datei Iesetup.cif.

Ändern von Setup-Optionen, ohne das IEAK-Paket neu zu erstellen

Möglicherweise müssen Sie Internet Explorer in einer bestimmten Art und Weise einrichten und möchten Ihr IEAK-Paket deshalb nicht neu erstellen. Mittels einer Batchdatei oder durch Parameter können Sie die Einstellungen ändern, die Sie beim Erstellen des Pakets zuvor im Assistenten zur Internet Explorer-Anpassung festgelegt haben.


Batchdateisyntax

Sie können eine Batchdatei verwenden, um den Installationsvorgang und den Assistenten für Windows Update Setup für Internet Explorer und Internetprogramme in umfassenderer Weise zu steuern. Die folgende Tabelle enthält die Abschnitte und Einträge für die Batchdatei. Weitere Informationen zur Verwendung einer Batchdatei finden Sie unter Ausführen von Setup im Batchmodus. Eine komplette Beispieldatei finden Sie unter Beispieldatei für die Installation im Batchmodus.

Abschnitte in einer Batchdatei:

[Options]

[Welcome]

[SetupChoice]

[Custom]

[Download]

[DownloadSite]

[PrepareSetup]

[Diskspace]

[Progress]

[RebootPartial]

[Finish]

[Reboot]

[Upgrade]

[Options]
SaveUninstallInfo=[0,1]
ExtraSection=
Quiet=[A,C,U]
ShowErrors=[0,1]
Display=[0,1]

Angaben in diesem Abschnitt | Beschreibung
SaveUninstallInfo=[0,1] Legt fest, ob Informationen über das Entfernen von Komponenten gespeichert werden sollen.
  • 0 gibt an, dass Informationen nicht gespeichert werden. Wenn Sie diesen Parameter verwenden, kann Internet Explorer nicht über die Systemsteuerung deinstalliert werden.
  • 1 (Standardwert) gibt an, dass Informationen gespeichert werden.
ExtraSection=Abschnitt1[,Abschnitt2,...] | Führt die in der Datei Iesetup.inf angegebenen Abschnitte aus. Trennen Sie die Abschnitte durch Kommas (z. B. Abschnitt1, Abschnitt2, Abschnitt3).
Quiet=[A,C,U] Stellt den automatischen Modus dar, in dem die Installation mit wenigen oder gar keinen Benutzereingaben ausgeführt wird.
  • A gibt den administrativen Modus an, in dem die Installation für den Benutzer nicht sichtbar ist und keine Fehlerprüfung durchgeführt wird.
  • C hält die Schaltfläche Abbrechen auf der Fortschrittseite verborgen.
  • U gibt an, dass die Installation für den Benutzer nicht sichtbar ist, es sei denn, eine erforderliche Eingabe (z. B. Downloadordner) ist nicht verfügbar.
ShowErrors=[0,1] Legt fest, ob dem Benutzer Setup-Fehler angezeigt werden sollen.
  • 0 gibt an, dass Setup auf jede Meldung ohne Benutzereingabe die Standardaktion durchführt.
  • 1 (Standardwert) legt fest, dass dem Benutzer Setup-Fehler angezeigt werden.
Zum Seitenanfang

[Welcome]
Display=[0,1]

Angaben in diesem Abschnitt Beschreibung
Display=[0,1] Legt fest, ob der "Willkommen"-Bildschirm von Setup auf dem Computer des Benutzers angezeigt werden soll.
  • 0 gibt an, dass der "Willkommen"-Bildschirm von Setup nicht für den Benutzer angezeigt wird.
  • 1 (Standardwert) gibt an, dass der "Willkommen"-Bildschirm von Setup für den Benutzer angezeigt wird.
Zum Seitenanfang

[SetupChoice]
Display=[0,1]
SetupChoice=[0,1]

Angaben in diesem Abschnitt Beschreibung
Display=[0,1] Legt fest, ob auf dem Computer des Benutzers der Bildschirm angezeigt wird, in dem der Benutzer die Setup-Option zum Anpassen oder Nichtanpassen von Setup wählen kann.
  • 0 gibt an, dass der Bildschirm Setup-Typ nicht für den Benutzer angezeigt wird.
  • 1 (Standardwert) gibt an, dass der Bildschirm Setup-Typ für den Benutzer angezeigt wird.
SetupChoice=[0,1] Legt fest, welche Setup-Option gewählt wird.
  • 0 (Standardwert) gibt Jetzt installieren - Typisches Setup für Komponenten ausführen an.
  • 1 gibt Benutzerdefinierte Installation an.
Zum Seitenanfang

[Custom]
Display=[0,1]
InstallDir=Ordnername
InstallDirRO=[0,1]
UseInfInstallDir=[0,1]
SetupMode=[0,1,2]
SetupModeRO=[0,1]
Component=[ComponentID_1, ComponentID_2, ...]
ComponentListRO=[0,1]
DownloadOnly=[0,1]
DownloadOnlyRO=[0,1]
IECompat=[0,1]
IECompatRO=[0,1]
IECompatShow=[0,1]
ShowAdvanced=[0,1]
IEDefault=[0,1]
IEDefaultRO=[0,1]

Angaben in diesem Abschnitt | Beschreibung
Display=[0,1] Legt fest, ob der Bildschirm Optionen für Komponenten, in dem die Benutzer Komponenten auswählen und auf Erweitert klicken können, um weitere Optionen anzugeben, auf dem Computer des Benutzers angezeigt wird.
  • 0 gibt an, dass der Bildschirm Optionen für Komponenten nicht für den Benutzer angezeigt wird.
  • 1 (Standardwert) gibt an, dass der Bildschirm Optionen für Komponenten für den Benutzer angezeigt wird.
InstallDir=Ordnername | Gibt den Ordner für die Installation von Dateien an. Wenn Sie diese Einstellung nicht verwenden, verwendet Setup die aktuellen Einstellungen in der Datei Iesetup.inf. Haben Sie eine frühere Version von Internet Explorer installiert, wird in denselben Ordner installiert, in dem sich auch die frühere Version befindet.
InstallDirRO=[0,1] Legt fest, ob der Benutzer den Installationsordner ändern kann.
  • 0 (Standardwert) gibt an, dass der Benutzer den Installationsordner ändern kann.
  • 1 gibt an, dass der Benutzer den Installationsordner nicht ändern kann.
UseInfInstallDir=[0,1] Gibt den Ordner an, in den Internet Explorer installiert wird.
  • 0 (Standardwert) gibt an, dass Setup den Standardinstallationsordner verwendet, bzw. den Ordner, in dem bereits eine frühere Version von Internet Explorer installiert ist.
  • 1 gibt an, dass es sich bei dem Installationsordner um den in der Datei Iesetup.inf angegebenen Ordner handelt.
SetupMode=[0,1,2] Legt fest, welche Art von Installation durchgeführt wird.
  • 0 gibt den Installationstyp Minimal an.
  • 1 (Standardwert) gibt den Installationstyp Typisch an.
  • 2 gibt den Installationstyp Vollständig an.
SetupModeRO=[0,1] Legt fest, ob der Benutzer den Installationstyp ändern kann.
  • 0 gibt an, dass der Benutzer den Installationstyp ändern kann.
  • 1 (Standardwert) gibt an, dass der Benutzer den Installationstyp nicht ändern kann.
Component=[ComponentID1[,ComponentID2,...]]

Gibt an, dass nur die in der Einstellung Component= angegebenen Komponenten installiert werden. ComponentID ist eine Zeichenfolge, die eine Komponente eindeutig kennzeichnet; Sie finden die entsprechende Zeichenfolge in den Komponentenabschnitten der Datei Iesetup.cif. Weitere Informationen zu ComponentIDs finden Sie auch auf der IEAK-Website.
ComponentListRO=[0,1]

Legt fest, ob der Benutzer angeben kann, welche Komponenten installiert werden (zusätzlich zu den Komponenten des Installationstyps), oder ob er dies nicht kann.

  • 0 (Standardwert) gibt an, dass der Benutzer die Liste der Komponenten ändern kann.
  • 1 gibt an, dass der Benutzer die Liste der Komponenten nicht ändern kann.
DownloadOnly=[0,1] Legt fest, ob Internet Explorer nur gedownloadet oder gedownloadet und installiert wird.
  • 0 (Standardwert) gibt an, dass die Dateien gedownloadet und dann installiert werden.
  • 1 gibt an, dass die Dateien gedownloadet, jedoch nicht installiert werden.
DownloadOnlyRO=[0,1] Legt fest, ob der Benutzer angeben kann, dass die Dateien gedownloadet oder gedownloadet und installiert werden oder ob er dies nicht kann.
  • 0 (Standardwert) gibt an, dass der Benutzer diese Einstellung ändern kann.
  • 1 gibt an, dass der Benutzer diese Einstellung nicht ändern kann.
IECompat=[0,1] Legt fest, ob Internet Explorer 5 (oder später) auf demselben Computer wie Internet Explorer 4 installiert wird, sodass die Funktionen beider Programme verfügbar sind.
  • 0 gibt an, dass Internet Explorer 5 (oder später) nicht auf demselben Computer wie Internet Explorer 4 installiert werden kann.
  • 1 (Standardwert) gibt an, dass Internet Explorer 5 (oder später) zur Zusammenarbeit mit Internet Explorer 4 auf demselben Computer installiert werden kann.
IECompatRO=[0,1] Legt fest, ob der Benutzer bestimmen darf, dass Internet Explorer 4-Funktionen parallel zu Internet Explorer 5 (oder später) verwendet werden können.
  • 0 (Standardwert) gibt an, dass der Benutzer diese Einstellung ändern kann.
  • 1 gibt an, dass der Benutzer diese Einstellung nicht ändern kann.
IECompatShow=[0,1] Legt fest, ob das Kontrollkästchen Kompatibilität angezeigt wird, das es Benutzern ermöglicht, Internet Explorer 5 (oder später) auf demselben Computer wie Internet Explorer 4 auszuführen.
  • 0 gibt an, dass das Kontrollkästchen im Assistenten nicht angezeigt wird.
  • 1 (Standardwert) gibt an, dass das Kontrollkästchen im Assistenten angezeigt wird.
ShowAdvanced=[0,1] Legt fest, ob die Schaltfläche Erweitert im Bildschirm Optionen für Komponenten im Assistenten für Windows Update Setup angezeigt wird. Durch Klicken auf die Schaltfläche Erweitert werden die Optionen Nur Download, Kompatibilität und Dateitypen nicht zuordnen angezeigt.
  • 0 gibt an, dass die Schaltfläche Erweitert nicht im Assistenten angezeigt wird.
  • 1 (Standardwert) gibt an, dass die Schaltfläche Erweitert im Assistenten angezeigt wird.
IEDefault=[0,1] Legt fest, ob Internet Explorer Standardbrowser sein soll.
  • 0 gibt an, dass Internet Explorer nicht Standardbrowser sein soll.
  • 1 (Standardwert) gibt an, dass Internet Explorer Standardbrowser sein soll.
IEDefaultRO=[0,1] Gibt an, ob die Benutzer festlegen können, ob Internet Explorer ihr Standardbrowser sein soll.
  • 0 gibt an, dass die Benutzer festlegen können, ob Internet Explorer ihr Standardbrowser sein soll.
  • 1 (Standardwert) gibt an, dass die Benutzer nicht festlegen können, ob Internet Explorer ihr Standardbrowser sein soll.
Zum Seitenanfang

[Download]
Display=[0,1]
DownloadDir=Ordnername
DownloadDirRO=[0,1]
DownloadOS=[0,1]
DownloadOSRO=[0,1]

Angaben in diesem Abschnitt | Beschreibung
Display=[0,1] Legt fest, ob die Option zum Downloaden oder Installieren von Dateien auf dem Computer des Benutzers angezeigt werden soll.
  • 0 gibt an, dass die Option zum Downloaden oder Installieren von Dateien nicht für den Benutzer angezeigt wird.
  • 1 (Standardwert) gibt an, dass die Option zum Downloaden oder Installieren von Dateien für den Benutzer angezeigt wird.
DownloadDir=Ordnername | Gibt den Ordner für den Download von Dateien an. Wenn Sie diese Einstellung nicht verwenden, erstellt Setup auf dem Laufwerk mit dem größten verfügbaren Speicherplatz einen Ordner namens Windows Update Setup-Dateien.
DownloadDirRO=[0,1] Legt fest, ob die Benutzer den Ordner ändern können, in den die Dateien gedownloadet werden.
  • 0 (Standardwert) gibt an, dass die Benutzer den Downloadordner ändern können.
  • 1 gibt an, dass die Benutzer den Downloadordner nicht ändern können.
DownloadOS=[0,1] Legt fest, dass die Dateien für ein bestimmtes Betriebssystem gedownloadet werden (diese Einstellung ist nur gültig, wenn die Dateien gedownloadet, aber nicht installiert werden (DownloadOnly=1)).
  • 0 (Standardwert) gibt das aktuelle Betriebssystem an.
  • 1 gibt Windows 95, Windows 98, Windows Millennium Edition, Windows NT und Windows 2000 an.
DownloadOSRO=[0,1] Legt fest, ob die Benutzer das Betriebssystem für die Dateien angeben können, die auf ihren Computer gedownloadet werden.
  • 0 (Standardwert) gibt an, dass die Benutzer diese Einstellung ändern können.
  • 1 gibt an, dass die Benutzer diese Einstellung nicht ändern können.
Zum Seitenanfang

[DownloadSite]
Display=[0,1]
DownloadLocation=URL
DownloadSiteList=URL

Angaben in diesem Abschnitt | Beschreibung
Display=[0,1] Legt fest, ob die Downloadsites für den Benutzer angezeigt werden.
  • 0 gibt an, dass die Downloadsites nicht für den Benutzer angezeigt werden.
  • 1 (Standardwert) gibt an, dass die Downloadsites für den Benutzer angezeigt werden.
DownloadLocation=URL | Gibt die Adresse der Website an, von der Benutzer .CAB-Dateien downloaden, falls die Verteilung über das Web erfolgt. Haben Sie für diesen Abschnitt Display=0 verwendet bzw. einen Parameter, der das Anzeigen dieser Seite verändert, sollten Sie eine Downloadsite eingeben.
DownloadSiteList=URL | Gibt den Ordner für die Liste der Downloadsites an; standardmäßig ist diese Liste in der Datei Ie5sites.dat enthalten. Wenn Sie diese Einstellung nicht verwenden, verwendet Setup die aktuellen Einstellungen in der Datei Iesetup.inf.
Zum Seitenanfang

[PrepareSetup]
Display=[0,1]

Angaben in diesem Abschnitt Beschreibung
Display=[0,1] Legt fest, ob der Bildschirm Setup wird vorbereitet auf dem Computer des Benutzers angezeigt werden soll.
  • 0 gibt an, dass der Bildschirm Setup wird vorbereitet für den Benutzer nicht angezeigt wird.
  • 1 (Standardwert) gibt an, dass der Bildschirm Setup wird vorbereitet für den Benutzer angezeigt wird.
Zum Seitenanfang

[Diskspace]
Display=[0,1]

Angaben in diesem Abschnitt Beschreibung
Display=[0,1] Legt fest, ob der erforderliche Speicherplatzbedarf auf dem Computer des Benutzers angezeigt werden soll.
  • 0 gibt an, dass der erforderliche Speicherplatzbedarf nicht auf dem Computer des Benutzers angezeigt wird. Verfügt der Benutzer nicht über ausreichend Festplattenspeicher, wird Setup geschlossen.
  • 1 (Standardwert) gibt an, dass der erforderliche Speicherplatzbedarf auf dem Computer des Benutzers angezeigt wird.
Zum Seitenanfang

[Progress]
Display=[0,1]

Angaben in diesem Abschnitt Beschreibung
Display=[0,1] Legt fest, ob der Installationsfortschritt für den Benutzer angezeigt werden soll.
  • 0 gibt an, dass der Installationsfortschritt für den Benutzer nicht angezeigt wird.
  • 1 (Standardwert) gibt an, dass der Installationsfortschritt für den Benutzer angezeigt wird.
Zum Seitenanfang

[RebootPartial]
Display=[0,1]

Angaben in diesem Abschnitt Beschreibung
Display=[0,1] Legt fest, ob der Bildschirm Installation unvollständig bei Fehlschlagen der Installation einer Komponente angezeigt werden soll.
  • 0 gibt an, dass der Bildschirm Installation unvollständig bei Fehlschlagen der Installation einer Komponente nicht angezeigt wird.
  • 1 (Standardwert) gibt an, dass der Bildschirm Installation unvollständig bei Fehlschlagen der Installation einer Komponente angezeigt wird.
Zum Seitenanfang

[Finish]
Display=[0,1]

Angaben in diesem Abschnitt Beschreibung
Display=[0,1] Legt fest, ob die Meldung angezeigt werden soll, dass der Computer nach der Installation neu gestartet wird.
  • 0 gibt an, dass die Meldung, dass der Computer nach der Installation neu gestartet wird, nicht angezeigt wird. Wenn Sie den Neustart nach der Installation deaktivieren möchten, müssen Sie 0 angeben.
  • 1 (Standardwert) gibt an, dass die Meldung, dass der Computer nach der Installation neu gestartet wird, angezeigt wird.
Zum Seitenanfang

[Reboot]
Reboot=[0,1]

Angaben in diesem Abschnitt Beschreibung
Reboot=[0,1] Legt fest, ob der Computer nach der Installation neu gestartet werden soll.
  • 0 gibt an, dass der Computer nach der Installation nicht neu gestartet werden soll. Wenn Sie den Neustart deaktivieren, sollte Ihr Programm den Neustart des Computers steuern. Internet Explorer ist nicht einwandfrei konfiguriert, bevor der Computer neu gestartet wurde.
  • 1 (Standardwert) gibt an, dass der Computer nach der Installation neu gestartet werden soll.
Zum Seitenanfang

[Upgrade]
ReinstallAll=[0,1]

Angaben in diesem Abschnitt Beschreibung
ReinstallAll=[0,1] Legt fest, ob alle Komponenten neu installiert werden, wenn Setup ein zweites Mal ausgeführt wird.
  • 0 (Standardwert) gibt an, dass Setup kein zweites Mal ausgeführt wird, wenn alle Komponenten bereits installiert sind.
  • 1 gibt an, dass alle Komponenten neu installiert werden.
Zum Seitenanfang


Parameter für die Installation von IExpress im Batchmodus

Der IExpress-Assistent unterstützt Sie beim Übergeben von Installationsparametern von einem Programm an ein anderes. Wenn IExpress mit Internet Explorer-Parametern verwendet wird, werden diese folgendermaßen in den IExpress-Ausdruck eingefügt:

Ie5setup <IExpress-Parameter> /c:" ie5wzd <Internet Explorer-Parameter>"

IExpress-Parameter

Die folgenden IExpress-Parameter werden häufig eingesetzt, um den Extraktionsvorgang während der Installation zu steuern. Diese Parameter sind nicht auf Internet Explorer beschränkt.

Parameter | Aktion
/Q | Legt den automatischen Modus fest, bzw. unterdrückt Eingabeaufforderungen während der Extraktion von Dateien. Dieser Parameter bewirkt jedoch nicht die Unterdrückung von Eingabeaufforderungen beim Ausführen des Windows Update Setup-Programms.
/Q:U | Legt den teilweise automatischen Benutzermodus fest, bei dem Benutzer einige wenige Eingaben vornehmen müssen.
/Q:A | Legt den automatischen Administratormodus fest, bei dem Benutzer keinerlei Eingaben vornehmen müssen.
/C:<UNC-Speicherort> | Gibt den Pfad und Namen der Datei Setup.inf oder Setup.exe an.
/R:N | Legt fest, dass der Computer nach der Installation nicht neu gestartet wird.
/R:A | Legt fest, dass der Computer nach der Installation immer neu gestartet wird.
/R:S | Legt fest, dass der Computer nach der Installation ohne Rückfrage an den Benutzer neu gestartet wird.
/T:<Verzeichnispfad> | Gibt den Zielordner an, in den die Dateien extrahiert werden.

Weitere Informationen über IExpress finden Sie unter IExpress-Technologie und der IExpress-Assistent.

Eine vollständige Liste der IExpress-Installationsparameter finden Sie unter Parameter für die Installation von IExpress im Batchmodus.


IExpress-Technologie und der IExpress-Assistent

IExpress ist eine Technologie, die dazu konzipiert wurde, das Erstellen eines Setup-Programms zu vereinfachen. Mit Hilfe der Schritt-für-Schritt-Anleitungen des IExpress-Assistenten können Sie selbstextrahierende Dateien erstellen, die automatisch das in ihnen enthaltene Setup-Programm ausführen. Das Setup-Programm kann eine .INF-Datei oder ein ausführbares Programm sein. Die IExpress-Technologie entfernt nach der Installation automatisch die Installationsdateien. Dies spart Zeit und vermeidet Frustrationen beim Benutzer.

Der IExpress-Assistent kann Sie bei speziellen Installationen Ihres angepassten Browserpakets unterstützen. Beispielsweise können Sie festlegen, ob der Computer nach der Installation neu gestartet wird. Sie finden den IExpress-Assistenten (IExpress.exe) im Ordner \<IEAK-Programmordner>\IEAK\Tools. Manche Auswahloptionen, die Sie im Assistenten festlegen, entsprechen bestimmten Parametern für die Installation im Batchmodus.

IExpress nutzt eine sogenannte Self-Extraction Directive-Datei (.SED) zum Speichern von Information zu Ihrem Paket. Wenn Sie den IExpress-Assistenten ausführen, können Sie eine vorhandenen .SED-Datei verwenden oder mit Hilfe des Assistenten eine neue .SED-Datei erstellen. Die .SED-Datei enthält Informationen und Anweisungen zum Setup-Paket.

Falls Sie mit IExpress eine selbstextrahierende Datei erstellen, welche eine andere Sprache als der Assistent zur Internet Explorer-Anpassung verwendet, kopieren Sie die Dateien Wextract.exe und Advpack.dll aus dem Ordner \<IEAK-Programmordner>\Iebin\<lang>\Optional in den Ordner \<IEAK-Programmordner>\Tools (in dem sich auch die Dateien Iexpress.exe, Makecab.exe, W95inf32.dll und W95inf16.dll befinden). Fügen Sie Advpack.dll zu Ihrem Paket hinzu.

Features der IExpress-Technologie

  • Automatische Installation von Internet Explorer ohne Benutzereingriff.
  • Unterstützung für Upgrades, ohne eine vorherige Version deinstallieren zu müssen.
  • Unterstützung für Aktualisierung oder Neuinstallation der gleichen Version.
  • Installation ohne Neustart von Computern unter Windows 98 OSR2.

Einstellungsmöglichkeiten in von IExpress verwendeten ".INF"-Dateien

  • Festlegen, ob das selbstinstallierende Paket für Administratoren oder allgemeine Benutzer bestimmt ist.
  • Festlegen mehrerer Ausführungsarten des eingebetteten Installationsbefehls, beispielsweise der Modi Normal oder Automatisch.
  • Festlegen, ob die IExpress-.DLL-Dateien (Anwendungsbibliotheken) auf dem Computer eines Benutzers aktualisiert werden sollen, wenn sie älter als die aktuellen .DLL-Dateien sind.
  • Festlegen von Zielversionen, mit denen das Paket kompatibel ist; beispielsweise des Versionsbereichs des Betriebssystems, des Browserversionsbereichs oder eines Anwendungsversionsbereichs (begrenzt auf eine Dateiversion oder mehrere Dateiversionen).
  • Festlegen im Batchmodus, ob der Benutzer bei gleichzeitiger Ausführung einer anderen Kopie des Pakets gewarnt wird, ob die gleichzeitige Ausführung zweier Pakete verhindert wird oder ob keine Aktion erfolgt.
  • Aktualisieren und Hinzufügen von Dateien zum IExpress-Paket mit dem Dienstprogramm UPDFILE, ohne das Paket neu erstellen zu müssen.
  • Ersetzen von Runonce durch RunOnceEx (wenn die aktuellere Version von Iernonce.dll vorhanden ist). Der Autor erhält so die Kontrolle über die Reihenfolge der Aufgabenausführung sowie eine Statusanzeige.
  • Bereitstellen eines Mechanismus zum Einrichten der erforderlichen Unterstützung für Benutzer mit wechselnden Arbeitsplätzen für Firmenadministratoren.
  • Bereitstellen eines Verfahrens zum Erstellen von Paketen mit vorkonfigurierten Desktops, die dem Benutzer angepasste Inhalte präsentieren, für Internetinhaltsanbieter und Internetdienstanbieter.
  • Unterstützung für mehrere Downloadsites.
  • Unterstützung für interne und externe Entwicklung, Anpassung, Erweiterung und verbessertes Debugging.
  • Speicherplatzminimierung durch Aufräumen der Festplatte (Papierkorb, OcCache, Wininet-Cache, temporäres Verzeichnis) während der Installation, während der Deinstallation und im Wartungsmodus.
  • Unterstützung für den erweiterten Nicht-SBCS-Zeichensatz.
  • Unterstützung des .INF-Dateiformats beim Downloaden von Internetkomponenten.

Weitere Informationen hierzu finden Sie unter Arbeiten mit Setup-Informationsdateien (.INF).


Parameter für die Ausführung von Internet Explorer-Setup im Batchmodus

In manchen Fällen ist es wünschenswert, steuern zu können, wie das Windows Update Setup-Programm bei den Benutzern ausgeführt wird. Durch die Verwendung von Befehlszeilenparametern können Sie den Installationsmodus wählen, einen automatischen Modus bestimmen (der Benutzereingaben überflüssig macht oder reduziert) oder festlegen, ob der Computer nach der Installation neu gestartet wird.

Wahlweise können Sie diese Parameter auch von den Benutzern festlegen lassen, während Windows Update Setup-Programm ausgeführt wird. Im Normalfall wird Internet Explorer jedoch zur Batchinstallation in ein anderes Programm, beispielsweise IExpress, integriert.

Internet Explorer-Parameter

Folgende Parameter können Sie zur Steuerung von Internet Explorer Setup verwenden:

Parameter | Aktion
/Q | Legt einen automatischen Modus weitgehend ohne Benutzereingaben fest ("Hands-free"-Modus). Der Benutzer wird nur zur Eingabe von Informationen aufgefordert, die nicht angegeben wurden.
/Q:A | Legt einen automatischen Modus völlig ohne Benutzereingaben fest.
/Q:C | Legt einen automatischen Modus ohne Anzeige der Schaltfläche Abbrechen fest, sodass der Benutzer die Installation nicht abbrechen kann. Dieser Parameter wird vom Assistenten zur Internet Explorer-Anpassung verwendet, wenn Sie die Installation als Firmenadministrator durchführen und die Option Automatische Installation auswählen.
/B:Dateiname | Gibt die zu verwendende Batchskriptdatei an.
/M[:Legt den Installationsmodus fest. Bei angepassten IEAK-Paketen bezieht sich 0 auf die erste Installationsoption, 1 auf die zweite Installationsoption usw. (beispielsweise 0=Minimal, 1=Typisch, 2=Vollständig). Sie können in IEAK bis zu zehn Installationsmodi angeben.

Wenn der Parameter /M ohne Zusatz einer Zahl verwendet wird, geht das Setup-Programm davon aus, dass kein Modus verwendet werden soll, und installiert nur die angegebenen Komponenten. Wird der Parameter überhaupt nicht angegeben, verwendet Setup den in der .INF-Datei festgelegten Standardmodus.
/E:ComponentID[, ...] | Gibt zusätzliche Komponenten an, die unabhängig vom gewählten Installationsmodus installiert werden sollen. Mit diesem Parameter können Sie Komponenten festlegen, die nicht Bestandteil des Installationstyps sind, den Sie im Anpassungsassistenten festgelegt haben. Die Angabe dieses Parameters setzt auch Einstellungen in der Batchdatei außer Kraft. ComponentID ist eine Zeichenfolge, die eine Komponente eindeutig bezeichnet. Sie finden die entsprechende Zeichenfolge in den Komponentenabschnitten der Datei Iesetup.cif.
/S:""#e"" Bezeichnet den Quellpfad von Ie5setup.exe. ""#e"" bezieht sich auf den vollständigen Pfad und den Namen der .EXE-Datei.

Anmerkung

  • Der Pfad muss in zwei Paare von doppelten Anführungszeichen eingeschlossen werden.
/R:N | Legt fest, dass der Computer nach der Installation nicht neu gestartet wird. Wenn Sie mit diesem Parameter den Neustart des Computers nach Beendigung des Windows Update Setup-Programms unterdrücken, muss ein Neustart durch das Installationsprogramm Ihrer angepassten Komponente ausgeführt werden. Internet Explorer ist nicht ordnungsgemäß konfiguriert, bevor der Computer neu gestartet wurde.
/D | Legt fest, dass Sie nur die Dateien für das aktuelle Betriebssystem downloaden möchten.
/D:1 | Legt fest, dass Sie die Dateien für die Betriebssysteme Microsoft Windows und Windows NT downloaden möchten.
/G:Abschnitt[, ...] | Führt nur die in Iesetup.inf angegebenen Installationsabschnitte aus. Trennen Sie die Abschnitte durch Kommas voneinander.
/X | Installiert Internet Explorer ohne Shell, Symbole und Links. Diese Option ist sinnvoll, wenn Sie in Ihrer eigenen Anwendung Browsersteuerelemente verwenden möchten.
/X:1 | Installiert Internet Explorer mit Shell, Symbolen oder Links, übernimmt jedoch nicht die standardmäßigen Browser- oder HTTP-Protokoll-Verknüpfungen.
/P | Liefert Angaben über die erforderlichen Komponenten und den benötigten Festplattenspeicher für eine Installation. Mit dieser Option können Sie ermitteln, wie viel Speicherplatz bei Verwendung der gewählten Installationsoptionen belegt wird. Weitere Informationen hierzu finden Sie im weiter unten folgenden Abschnitt Kalkulieren der Größe der Internet Explorer-Installation.

Anmerkung

  • Wenn Internet Explorer auf einem Computer installiert wird, auf dem Internet Explorer 4 zuvor noch nicht ausgeführt worden ist, und die Benutzer die Möglichkeit zur Nutzung von Channels erhalten sollen, fügen Sie Ihrer Installation das Offline Browsing-Paket als Komponente unter der jeweiligen Installationsoption hinzu. Ist diese Komponente nicht Bestandteil aller Installationsoptionen, so sollten Sie das Offline Browsing-Paket mit Hilfe des Parameters /E: und der ComponentID MobilePk als benötigte Komponente hinzufügen.

Bei IExpress verwendete Internet Explorer-Befehlszeilenparameter

Der IExpress-Assistent unterstützt Sie beim Übergeben von Installationsparametern von einem Programm an ein anderes. Wenn IExpress mit Internet Explorer-Parametern verwendet wird, werden diese folgendermaßen in den IExpress-Ausdruck eingefügt:

Ie5setup <IExpress-Parameter> /c:" ie5wzd <Internet Explorer-Parameter>"

Eine vollständige Liste der IExpress-Installationsparameter finden Sie unter Parameter für die Installation von IExpress im Batchmodus.

Beispiele

Es folgen einige Beispiele für Befehle zur Installation von Internet Explorer.

  • Der folgende Ausdruck führt eine automatische Installation aus. Es wird keine Eingabeaufforderung angezeigt, und der Computer wird nach der Installation nicht neu gestartet.

    ie5setup.exe /C:"ie5wzd /S:""#e"" /Q /R:N"

  • Der folgende Ausdruck setzt die Siteliste der Datei Ie5sites.dat außer Kraft und installiert Internet Explorer vom angegebenen Speicherort aus. Es handelt sich um eine einzelne Befehlszeile, die zur besseren Lesbarkeit in drei Textzeilen gegliedert aufgeführt wird.

    ie5setup.exe
    /C:"ie5wzd
    /S:""\\ihrserver.com\verzeichnis\ie5setup.exe"""

    Dieser Ausdruck wird verwendet, um Benutzer an einen anderen Downloadstandort (beispielsweise in einem anderen Land oder einer anderen Region) zu verweisen, ohne das IEAK-Paket neu erstellen zu müssen.

Kalkulieren der Größe der Internet Explorer-Installation

Mit Hilfe der Parameter für den Batchmodus können Sie Informationen zur Internet Explorer-Installation an Ihr angepasstes IEAK-Paket übergeben. Dafür gibt es zwei Hauptgründe. Erstens wird der für die Installation von Internet Explorer benötigte Speicherplatz angegeben (und zwar dynamisch anhand der vom Benutzer gewählten Optionen), und zweitens werden Informationen über den Fortschritt des Installationsvorgangs angezeigt.

Bei Verwendung des Parameters /P werden diese Informationen während der Installation in der Registrierung gespeichert. Anhand dieser Angaben gibt das Windows Update Setup-Programm folgende Zusatzinformationen an den Registrierungszweig HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo zurück:

Teilschlüssel | Datentyp | Wert
InstallSize | Zeichenfolge | Anzahl KB (Tatsächliche Größe der Installation)
AdminRights | Binärwert | 1 oder 0
EstimatedCopy | Zeichenfolge | Anzahl KB Dieser Wert ist normalerweise größer als InstallSize, da für den Installationsvorgang zusätzlicher Speicherplatz benötigt wird. Verwenden Sie ihn als Anhaltspunkt, wie die Fortschrittsinformationen in einer grafischen Kalkulationsanzeige aussehen würden).

Windows Update Setup-Rückgabecodes und Status

Nachdem eine Anwendung installiert wurde bzw. die Installation einer Anwendung fehlgeschlagen ist, muss das Ergebnis von Setup dokumentiert werden. Da IE5wzd.exe in Ie5setup.exe eingebunden ist, können die Rückgabecodes nicht direkt ausgegeben werden. Statt dessen gibt das Setup-Programm nach Abschluss der Installation diese Informationen im Registrierungszweig HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo zurück. Jedes fehlgeschlagene HRESULT in diesem Zweig bezeichnet einen bestimmten Fehler.

Teilschlüssel | Datentyp | Wert
Complete | Zeichenfolge | DWORD, welches das HRESULT von Setup folgendermaßen angibt:
 |  | 0 | Erfolgreiche Installation.
 |  | 0x80100003 | Dateien für die angeforderte Installation wurden nicht gefunden.
 |  | 0x80100001 | Installation teilweise erfolgreich. Eine oder mehrere Komponenten wurden nicht gedownloadet/installiert. Eine Liste dieser Komponenten finden Sie unter dem Teilschlüssel FailedComponents.
 |  | 0x80100002 | Installation teilweise erfolgreich, jedoch Abbruch von Setup durch den Benutzer. Eine oder mehrere Komponenten wurden nicht gedownloadet/installiert.

Für Objekte, die nicht vollständig installiert wurden, gibt Setup außerdem folgende Informationen zurück:

Teilschlüssel | Datentyp | Wert
FailedComponents | MultiSZ | <Namen der Komponenten aus CIFID>null<Name der Komponente...>
InstallStatus | Binärwert | 0 | Installation erfolgreich abgeschlossen.
 |  | 1 | Installation angehalten. Der Benutzer hat die Installation abgebrochen und wird aufgefordert, den Abbruch zu bestätigen.
 |  | 2 | Kein Abbruch, Installation fortsetzen.
 |  | 3 | Ja, Abbruch bestätigt, Setup-Programm möglichst bald beenden. In einigen Fällen muss möglicherweise ein in Bearbeitung befindlicher Task, wie beispielsweise das Kopieren oder Extrahieren von Dateien, noch beendet werden.


Regelmäßiges Aktualisieren von Benutzern

Die Benutzer können automatisch benachrichtigt werden, wenn eine neue Version von Internet Explorer verfügbar ist. Sie können steuern, ob Internet Explorer eine Überprüfung dieser aktualisierten Informationen vornimmt und, wenn dies der Fall ist, wie oft eine solche Überprüfung durchgeführt wird.

Verfahren:

  • Wenn eine neue Version von Internet Explorer festgestellt wird, wird die Homepage (oder Startseite) des Benutzers vorübergehend durch eine Seite zur Aktualisierungsbenachrichtigung ersetzt. Auf dieser Seite können die Benutzer ihre Browser aktualisieren, die Seite zur Liste Favoriten hinzufügen oder die Aktualisierung abbrechen.
  • Standardmäßig wird die Microsoft Internet Explorer-Seite für Microsoft Windows Update als Seite zur Aktualisierungsbenachrichtigung verwendet. Sie können aber auch eine angepasste Webseite anzeigen, auf der Produktaktualisierungsinformationen oder sogar Firmennews verfügbar sind. Beispielsweise könnten Sie eine Webseite erstellen, um die Benutzer über neue Internet Explorer-Versionen, neue Serverpfade und Firmennews zu informieren.

    Über die Seite zur Aktualisierungsbenachrichtigung können Sie in regelmäßigen Abständen Informationen im .HTM-Format an die Benutzer verteilen. Wenn Sie diese Informationen über Channels und mit Hilfe des .CDF-Formats an die Benutzer verteilen möchten, steht diese Funktion natürlich ebenso zur Verfügung.

  • Beim nächsten Start des Browsers wird die Standardstartseite des Benutzers angezeigt.

Sie können die Einstellungen für die Seite zur Aktualisierungsbenachrichtigung festlegen, indem Sie folgende Schritte ausführen:

  1. Wenn Sie diese Einstellung im Assistenten für die Internet Explorer-Anpassung ändern, müssen Sie im Bildschirm Praktiken und Einschränkungen in Schritt 5 auf Interneteinstellungen klicken.

    - ODER -

    Falls Sie diese Einstellung im Profil-Manager ändern, müssen Sie auf Praktiken und Einschränkungen und anschließend auf Interneteinstellungen klicken.

  2. Aktivieren Sie das Kontrollkästchen Automatische Überprüfung auf Aktualisierungen von Internet Explorer.
  3. Klicken Sie auf der linken Seite des Bildschirms auf Aktualisierungen der Komponenten.
  4. Wenn Sie die Windows Update-Standardseite verwenden möchten, sollten Sie den Standard-URL nicht ersetzen.

    Möchten Sie eine angepasste Seite verwenden, geben Sie die Adresse dieser Seite im Feld URL, die für Updates angezeigt werden soll ein.

  5. Geben Sie unter Intervall für die Updateüberprüfung (in Tagen) die Anzahl der Tage ein, die zwischen den Intervallen liegen soll, in denen auf aktualisierte Informationen geprüft wird.

Wenn Sie planen, eine Standardseite für Ihre Organisation zu erstellen, schauen Sie sich die Beispieldatei Ieupdate.htm im Ordner \<IEAK-Programmordner>\Toolkit an.

Anmerkung

  • Sowohl im Profil-Manager als auch im Bildschirm Praktiken und Einschränkungen des Assistenten können Sie im Bereich Interneteinschränkungen festlegen, ob im Bildschirm Aktualisierungen von Komponenten eine regelmäßige Überprüfung auf Aktualisierungen für Internet Explorer und Internettools erfolgen soll.


Automatische Erkennung und Konfiguration der Browsereinstellungen

Sie können Ihr Netzwerk so konfigurieren, dass Internet Explorer beim ersten Ausführen automatisch konfiguriert wird. Auf diese Weise können der Verwaltungsaufwand und unter Umständen die Anfragen beim Help Desk zu Browsereinstellungen reduziert werden.

Die automatische Erkennung von Browsereinstellungen, die auf WPAD (Web Proxy AutoDiscovery) basiert, wird sowohl von DHCP (Dynamic Host Configuration Protocol) als auch von DNS (Domain Name System) unterstützt. Mit den entsprechenden Einstellungen können DHCP- und DNS-Server die Browsereinstellungen automatisch erkennen und konfigurieren. Dieses Feature beruht auf bestehenden Technologien zur automatischen Konfiguration, mit deren Hilfe ein Browser von einem zentralen Standort aus über einen URL zur automatischen Konfiguration (.INS-Datei) oder eine Javascript Proxy-Konfigurationsdatei (.JS-, JVS- oder .PAC-Datei) konfiguriert werden kann.

Mit der automatischen Erkennung kann ein Browser beim Starten automatisch konfiguriert werden, sogar dann, wenn er nicht zuerst durch den Administrator konfiguriert wurde. Sollte beispielsweise ein Benutzer eine nicht angepasste Version des Browsers aus dem Internet downloaden anstelle einer angepassten Version, die auf dem Server der Firma zur Verfügung steht, zu installieren, so kann die automatische Erkennung den Browser dieses Benutzers automatisch konfigurieren und anpassen.

Wenn Sie in IEAK festlegen möchten, dass die automatische Erkennung der Browsereinstellungen verwendet wird, aktivieren Sie im Bildschirm Automatische Konfiguration des Assistenten zur automatischen Anpassung von Internet Explorer das Kontrollkästchen Automatische Ermittlung von Konfigurationseinstellungen. Eine Darstellung der automatischen Konfiguration finden Sie unter So funktioniert die automatische Konfiguration.

Automatische Erkennung von Browsereinstellungen für DHCP und DNS

DHCP-Server ermöglichen es dem Administrator, globale und Subnet-spezifische TCP/IP-Parameter zentral festzulegen und Parameter für Clients zu festzulegen, die reservierte Adressen verwenden. Wird ein Clientcomputer zwischen Subnets verschoben, so wird er beim Start automatisch für TCP/IP neu konfiguriert.

Wichtig

  • Der DHCP-Server muss wie der DHCP-Server in Windows 2000 die DHCPINFORM-Nachricht unterstützen.

Bei DNS (Domain Name Service) handelt es sich um einen Satz von Protokollen und Diensten in einem TCP/IP-Netzwerk, der es Benutzern erlaubt, unter Verwendung hierarchischer benutzerfreundlicher Namen nach anderen Computern (häufig als "Hosts" bezeichnet) zu suchen, anstatt numerische IP-Adressen verwenden zu müssen.

Die Verwendung von DHCP mit der automatischen Erkennung bietet sich vor allem für LAN (Local Area Network)-basierte Benutzer an, wohingegen DNS die Erkennung der Einstellungen sowohl bei LAN-basierten als auch bei DFÜ-Benutzern aktiviert. Im Vergleich zu DNS, auf das Netzwerk- und DFÜ-Benutzer zurückgreifen können, bietet DHCP schnelleren Zugriff für LAN-Benutzer sowie größere Flexibilität bei der Angabe der Konfigurationsdateien.

Um die automatische Erkennung von Browsereinstellungen zu ermöglichen, müssen Sie auf DNS-Servern und/oder DHCP-Servern bestimmte Einstellungen konfigurieren.

Weitere Informationen erhalten Sie unter folgenden Themen.

Aktivieren der automatische Erkennung von Browsereinstellungen bei DHCP

Um die automatische Erkennung von Browsereinstellungen auf einem DHCP-Server einzurichten, müssen Sie einen neuen Optionstyp mit der Codenummer 252 erstellen. Geben Sie für den Wert, der zu dem Code gehört, den URL ein, der auf Ihre Konfigurationsdatei verweist. Hierbei kann es sich um eine Konfigurationsdatei mit der Erweiterung .PAC, .JVS, .JS oder .INS handeln.

Weitergehende Informationen zur Konfiguration des DHCP-Servers erhalten Sie in der Serverdokumentation.

Beispiele

http://www.microsoft.com/webproxy.pac

http://marketing/config.ins

http://###.#.###.#/account.pac

Aktivieren der automatische Erkennung bei DNS

Um die automatische Erkennung von Browsereinstellungen für DNS zu aktivieren, müssen Sie entweder den Hosteintrag oder den CNAME-"Alias"-Eintrag in der DNS-Datenbankdatei konfigurieren.

Hosteintrag

Ein Hosteintrag wird für die statische Zuordnung von Host (Computer)-Namen zu IP-Adressen innerhalb einer Zone verwendet. Ein Hosteintrag enthält Einträge für alle Hosts, die statische Zuordnungen erfordern, wie z. B. Arbeitsstationen, Namensserver und Mailserver.

Die Syntax lautet: <Hostname> IN A <IP-Adresse von Host>

Beispiel:

corserv | IN | A | 192.55.200.143
Namensserver2 | IN | A | 192.55.200.2
Mailserver1 | IN | A | 192.55.200.51

CNAME-Eintrag

Diese Einträge werden gelegentlich auch als "Aliasnamen" bezeichnet; im technischen Bereich dagegen ist die Bezeichnung CNAME-Eintrag ("kanonischer Name") geläufig. Diese Einträge ermöglichen es, mit mehr als einem Namen auf einen einzelnen Host zu verweisen. Beispielsweise erleichtert die Verwendung kanonischer Namen die Verwaltung sowohl eines FTP-Servers als auch eines Webservers auf demselben Computer.

So konfigurieren Sie eine DNS-Datenbankdatei für die automatische Erkennung von Browsereinstellungen

  • Geben Sie in der DNS-Datenbankdatei einen Hosteintrag namens wpad ein, der auf die IP-Adresse des Webservers verweist, der die .PAC-, .JVS-, .JS- oder .INS-Datei für die automatische Konfiguration enthält.

    Oder geben Sie einen CNAME-Alias namens wpad ein, der auf den Namen (den aufgelösten Namen, nicht die IP-Adresse) des Servers verweist, der die .PAC-, .JVS-, .JS- oder .INS-Datei für die automatische Konfiguration enthält.

Anmerkungen

  • Nachdem der Eintrag hinzugefügt und die Datenbankdatei an den Server übermittelt wurde, sollte der DNS-Name wpad.domain.com zu demselben Computernamen wie Ihr Server aufgelöst werden, der die Datei für die automatische Konfiguration enthält.

  • Bei der Verwendung von DNS erstellt Internet Explorer eine Standard-URL-Vorlage auf der Grundlage des Hostnamens wpad.

    Beispiel:

    http://wpad.domain.com/wpad.dat

    Folglich müssen Sie auf dem Webserver wpad eine Datei oder einen Umleitungspunkt namens wpad.dat einrichten, der den Inhalt der Datei für die automatische Konfiguration übermittelt.


Verwalten der Installation bei Bedarf

Wenn Benutzer Internet Explorer installieren, können sie die gewünschten Komponenten auswählen. Auf diese Weise lässt sich einerseits steuern, wie viel Speicherplatz belegt wird, und andererseits die Download- und Installationszeit begrenzen. Beim Browsen im Web werden die Benutzer unter Umständen feststellen, dass sie weitere Komponenten benötigen.

Besuchen Benutzer eine Webseite, die eine noch nicht installierte Anwendung oder Komponente benötigt, werden sie von der Automatischen Installation aufgefordert, die erforderlichen Objekte zu installieren.

Als Firmenadministrator oder Internetdienstanbieter (ISP) können Sie dieses Feature mit Hilfe von IEAK steuern.

Anmerkung

  • Falls Ihre Organisation voraussichtlich die Installation bei Bedarf via Internet einsetzen wird, müssen Sie die .CAB-Dateien signieren und den Server, auf dem sich die .CAB-Dateien befinden, in den Sicherheitseinstellungen als vertrauenswürdigen Server angeben. Für eine reine Intranetsite können Sie auch die Sicherheitsstufe Niedrig einstellen. Weitere Informationen hierzu finden Sie unter Signieren Ihrer Programme.

    Ist die Sicherheitsstufe Ihres Intranets auf Mittel oder höher eingestellt, müssen Sie folgendermaßen vorgehen, um die Netzwerkserver als vertrauenswürdige Server anzugeben:

    1. Klicken Sie im Bildschirm Sicherheitseinstellungen des Assistenten auf Importieren der aktuellen Einstellungen der Sicherheitszonen, und klicken Sie dann auf Einstellungen ändern.
    2. Wählen Sie die Zone Lokales Intranet aus, und klicken Sie dann auf Sites.
    3. Deaktivieren Sie das Kontrollkästchen Alle Netzwerkpfade (UNCs) einbeziehen, und klicken Sie dann auf OK.
    4. Wählen Sie die Zone Vertrauenswürdige Sites aus, klicken Sie auf Sites, geben Sie den Pfad des Downloadservers an, und klicken Sie dann auf Hinzufügen.
    5. Wiederholen Sie den vorherigen Schritt für jeden Downloadserver, der als vertrauenswürdig eingestuft werden soll.


Verwalten der Windows Desktop-Aktualisierung

Microsoft Windows Desktop-Aktualisierung verleiht dem Desktop und den Ordnern ein Erscheinungsbild ähnlich einer Webseite. Obwohl die Windows Desktop-Aktualisierung kein Bestandteil von Internet Explorer 5 (oder später) ist, können Sie sie in Ihr IEAK-Paket aufnehmen. Windows 98, Windows 98, Zweite Ausgabe, Windows Millennium Edition und Windows 2000 verfügen bereits über diese Desktop-Features.

Wenn Sie beabsichtigen, die Windows Desktop-Aktualisierung zu installieren und anzupassen, muss die Windows Desktop-Aktualisierung auf dem Erstellungscomputer in einer der folgenden Konfigurationen ausgeführt werden:

  • Windows 98
  • Windows 98, Zweite Ausgabe
  • Windows Millennium Edition
  • Windows 2000
  • Bei anderen Windows-Versionen müssen Sie ein Upgrade von Internet Explorer 4.0 mit installierter Windows Desktop-Aktualisierung auf Internet Explorer 5.5 durchführen.

Die Windows Desktop-Aktualisierung kann bei der Einstellung eines Standarddesktops in Unternehmen hilfreich sein.

Wenn die Windows Desktop-Aktualisierung installiert ist, können die Benutzer ihre Computer auf die gleiche Weise durchsuchen wie das Web. Der Webbrowser und die Internet Explorer-Menüs Wechseln zu und Favoriten sind in Windows durchgängig verfügbar. Benutzer können ihren Desktops auch "aktive Inhalte" hinzufügen, beispielsweise einen Börsenticker, die Taskleiste oder Ordner, und sie können festlegen, dass Dateien durch einfaches Klicken geöffnet oder ausgeführt werden sollen.

Außerdem können Sie steuern, ob Benutzer diese Einstellungen ändern können. Sie können auch die Sicherheits- und Proxyeinstellungen steuern. Sie können diese Einstellungen im Bildschirm Praktiken und Einschränkungen in Schritt 5 des Assistenten für die Internet Explorer-Anpassung angeben, oder Sie können den IEAK-Profil-Manager verwenden. Anschließend können Sie die Profile fortlaufend steuern, indem Sie das Feature Automatische Konfiguration verwenden.

Anmerkung

  • Wenn Sie die Windows Desktop-Aktualisierung als Komponente in Ihr Paket aufnehmen, muss die im IEAK-Paket verwendete Sprache mit der Sprache des Betriebssystems der Benutzer übereinstimmen. Wenn ein Benutzer versucht, den Browser und die Windows Desktop-Aktualisierung in einer anderen Sprache zu installieren, wird nur der Browser installiert.


Einstellungen und Einschränkungen

Systemrichtlinien und Einschränkungen für Internet Explorer bieten einen leistungsfähigen Mechanismus zur Optimierung der Steuerbarkeit und Verwaltbarkeit von Computern. Die Systemrichtlinien und Einschränkungen sind in einer Richtliniendatei gespeichert und regeln die Benutzer- und Computerzugriffsrechte, indem sie die standardmäßigen Registrierungswerte bei der Anmeldung des Benutzers außer Kraft setzen.

Mit Hilfe des Assistenten für die Internet Explorer-Anpassung können Sie Systemrichtlinien und Einschränkungen vordefinieren und eine standardmäßige Internet Explorer-Konfiguration als Bestandteil Ihres angepassten Browserpakets erstellen. Nach der Internet Explorer-Installation können Sie über den IEAK-Profil-Manager die Systemrichtlinien und Einschränkungen auf den Computern der Benutzer zentral verwalten und aktualisieren. Falls einzelne Benutzergruppen spezielle Anforderungen haben, können Sie auch mit dem IEAK-Profil-Manager für jede Gruppe unterschiedliche Richtliniendateien (.INS) erstellen.

Systemrichtlinien und Einschränkungen können Sie beispielsweise für folgende Aufgaben einsetzen:

  • Festlegen der Features, die der Benutzer ändern kann, beispielsweise den Active Desktop und die Internet Explorer-Symbolleisten.
  • Verwalten der Bandbreite und Steuern des Verhaltens und Erscheinungsbildes von Internet Explorer.
  • Angeben von Serverlisten für Komponenten wie z. B. Microsoft NetMeeting, und Einrichten einer Seite für die regelmäßige Aktualisierung der Computer der Benutzer.
  • Festlegen, welche Programme für E-Mail und für Internettelefonie verwendet werden.
  • Vordefinieren der Verbindungseinstellungen der Benutzer. Falls Sie mehrere Verbindungseinstellungen verwalten müssen, können Sie auch ein angepasstes Profil aus dem Verbindungs-Manager-Verwaltungskit (Connection Manager Administration Kit, CMAK) importieren.

Eine Schemadarstellung dieses Features finden Sie unter Systemrichtlinien und Einschränkungen.

Vorteile der Verwendung von Systemrichtlinien und Einschränkungen

Der Verwendung von Systemrichtlinien und Einschränkungen bringt Organisationen folgende Vorteile:

  • Systemrichtlinien und Einschränkungen ermöglichen die Einrichtung einer standardmäßigen Internet Explorer-Konfiguration. Sie können für Ihre Benutzer ein angepasstes Browserpaket erstellen, das die allgemeinen Einstellungen für Browserfeatures und -funktionen bereits enthält.
  • Durch Systemrichtlinien und Einschränkungen können Sie auch die Features einschränken, auf die der Benutzer in Internet Explorer Zugriff erhält. Beispielsweise können Sie NetMeeting-Optionen vordefinieren, um den Audio- und Videozugriff zu steuern. Außerdem können sie auf Wunsch bestimmte Features und Funktionen deaktivieren, sodass sie auf den Computern der Benutzer entweder gar nicht oder nur abgeblendet angezeigt werden.
  • Das Einrichten von Systemrichtlinien und Einschränkungen ermöglicht auch das Ändern standardmäßiger Registrierungswerte. Mit den Einstellungen in einer Richtliniendatei können Sie Registrierungswerte für mehrere Computer festlegen und müssen die Einstellungen nicht einzeln auf jedem Benutzercomputer einrichten.

Vorüberlegungen zum Einrichten von Systemrichtlinien und Einschränkungen

Vor der Implementierung von Systemrichtlinien und Einschränkungen sollten Sie folgende Fragen klären:

  • Welche Typen von Systemrichtlinien und Einschränkungen möchten Sie zentral festlegen und verwalten? Soll beispielsweise der Zugriff auf NetMeeting-Features beschränkt werden?
  • Soll ein Satz von standardmäßigen Systemrichtlinien und Einschränkungen für alle Benutzer und Computer gelten, oder möchten Sie mehrere Richtliniendateien für verschiedene Benutzergruppen erstellen? Verschiedene Gruppen von Benutzern haben möglicherweise jeweils unterschiedliche Anforderungen.
  • Welche Form der Sicherheitseinstellungen möchten Sie implementieren? Sie können sämtliche Einstellungen sperren, die Einstellungen selbst steuern, sie jedoch für mobile Benutzer zum Download bereitstellen, oder angepasste Einstellungen konfigurieren, welche die Benutzer dann ändern können.

    Berücksichtigen Sie die möglichen Auswirkungen dieser Einstellungen, insbesondere wenn es Benutzer mit wechselnden Arbeitsplätzen gibt, die Computer mit anderen Personen gemeinsam nutzen. Welche Auswirkung bringt beispielsweise das Entfernen von Desktopsymbolen oder das Sperren der Änderung von Sicherheitseinstellungen für Benutzer mit sich? Stellen Sie sicher, dass die Benutzer wissen, auf welche Features sie Zugriff haben.

  • Sollen die Richtliniendateien an einem zentralen Ort oder auf den Computern der Benutzer gespeichert werden? Es kann unter Umständen sinnvoll sein, die Dateien auf einem Server zu speichern, damit Benutzer mit wechselnden Arbeitplätzen von jedem Computer aus auf die Einstellungen zugreifen können. Diese Konfiguration ist beispielsweise dann sinnvoll, wenn ein Benutzer, der wenig restriktive Sicherheitseinstellungen benötigt, am Computer eines anderen Benutzers arbeiten muss, für den restriktivere Sicherheitseinstellungen gelten.

Verwalten von Systemrichtlinien und Einschränkungen für Windows NT und Windows 2000

Alle Praktiken und Einschränkungen des Systems, die Sie im IEAK-Assistenten einstellen und anschließend mit Hilfe des IEAK-Profil-Managers verwalten können, können für Benutzer mit den Betriebssystemen Windows 95, Windows 98 und Windows Millennium Edition konfiguriert werden.

Sie können jedoch für Benutzer ohne Administratorrechte unter Windows NT bzw. Windows 2000 nur eine Teilmenge dieser Systemrichtlinien und -einschränkungen einrichten. Es wird empfohlen, statt dessen den Windows NT-Systemrichtlinien-Editor bzw. Windows 2000-Gruppenrichtlinie zu verwenden, um die verbleibenden Praktiken und Einschränkungen für diese Benutzer zu konfigurieren. Weitere Informationen erhalten Sie unter Verwalten von Microsoft Internet Explorer unter Windows 2000.

Einrichten und Verwalten von Systemrichtlinien und Einschränkungen

Sie können Praktiken und Einschränkungen auf zwei Arten festlegen:

  • In Schritt 5 des Assistenten für die Internet Explorer-Anpassung.
  • Im Profil-Manager unter Verwendung der automatischen Konfiguration.

Um den Profil-Manager einzusetzen, erstellen Sie zunächst ein neues Benutzerprofil oder öffnen ein bestehendes Profil. Dann erweitern Sie die Ordner so lange, bis die zu ändernde Einstellung oder Einschränkung angezeigt wird. Weitere Informationen über die einzelnen Kategorien von Praktiken und Einschränkungen erhalten Sie, indem Sie auf den Ordner für die betreffende Kategorie klicken.

Bei der automatischen Konfiguration bleiben Browsereinstellungen und Einschränkungen an dem Speicherort erhalten, den Sie im Assistenten für die Internet Explorer-Anpassung oder im Dialogfeld Internetoptionen angegeben haben.

So überprüfen Sie die automatischen Konfigurationseinstellungen auf den Computern der Benutzer

  1. Klicken Sie im Browser auf das Menü Extras.
  2. Klicken Sie auf Internetoptionen.
  3. Klicken Sie auf die Registerkarte Verbindungen und dann auf LAN-Einstellungen.

    Überprüfen Sie, ob die Option Automatisches Konfigurationsskript verwenden aktiviert ist, und überprüfen Sie den Pfad im Feld Adresse.

Erstellen und Verwalten von Richtlinien für Ihre angepassten Programme

Beim Arbeiten mit dem Assistenten für die Internet Explorer-Anpassung können Sie die Praktiken und Einschränkungen verwenden, die Sie in Ihren eigenen.ADM-Dateien eingerichtet haben, indem Sie auf Richtlinie und anschließend auf Importieren klicken. Sie finden anpassbare .ADM-Dateien im Ordner IEAK-Programmordner\Policies im Unterordner für die entsprechende Sprache.


Verwenden der Proxyserverauswahl und der Proxyserverumgehungslisten

Durch die Verwendung eines Proxyservers kann der Administrator den Zugriff auf das Internet beschränken. Sie können den Proxyserver entweder im Assistenten für die Internet Explorer-Anpassung, im IEAK-Profil-Manager oder im Browser festlegen. Darüber hinaus können Sie auf der Seite Praktiken und Einschränkungen im Assistenten für die Internet Explorer-Anpassung oder im IEAK-Profil-Manager die Möglichkeiten des Benutzers zum Ändern von Proxyservereinstellungen einschränken.

Detaillierte Anweisungen zum Konfigurieren der Einstellungen für die Proxyserverauswahl und -umgehung mit Hilfe von IEAK finden Sie auf den Bildschirmen Automatische Konfiguration und Proxyeinstellungen in Schritt 4 des Assistenten zur Internet Explorer-Anpassung.

Anmerkung

  • Das Feature Proxyserverumgehung kann die Verwendung von JavaScript oder JScript für die Auswahl eines Proxyservers überflüssig machen.

So konfigurieren Sie die Einstellungen für die Proxyserverauswahl und die Proxyserverumgehung

  1. Klicken Sie im Menü Extras von Internet Explorer auf Internetoptionen.
  2. Klicken Sie auf die Registerkarte Verbindungen und dann auf LAN-Einstellungen.
  3. Aktivieren Sie im Bereich Proxyserver das Kontrollkästchen Proxyserver verwenden.
  4. Klicken Sie auf Erweitert, und geben Sie dann für jedes Internetprotokoll, das unterstützt wird, die Adresse des Proxyservers und die Anschlussnummer ein.

    Anmerkungen

    • In den meisten Fällen wird nur ein einziger Proxyserver für alle Protokolle verwendet. Wenn dies zutrifft, geben Sie die Adresse des Proxyservers und die Anschlussnummer für die Einstellung HTTP ein, und aktivieren Sie dann das Kontrollkästchen Für alle Protokolle denselben Server verwenden.
    • Bei Proxyserveradressen, die nicht mit einem Protokoll (wie beispielsweise "http://" oder "ftp://") beginnen, wird angenommen, dass es sich um HTTP-Proxyserver vom Typ CERN handelt. Beispielsweise wird der Eintrag "proxy" analog zum Eintrag "http://proxy" behandelt. Bei FTP-Gateways, beispielsweise dem TIS FTP-Gateway und dem WinGate Win95 Modem FTP-Proxyserver, sollte der Proxyserver mit dem Protokoll "ftp://" vor dem Proxynamen aufgelistet werden. Ein FTP-Gateway namens "ftpproxy" sollte beispielsweise als "ftp://ftpproxy" eingegeben werden.
  5. Um bei komplexeren Adressen den Proxyserver zu umgehen, geben Sie die Adressen im Feld Für Adressen, die wie folgt beginnen, keinen Proxyserver verwenden: ein.

    Ein Eintrag für die Umgehung eines Proxyservers kann mit einem Protokolltyp beginnen, beispielsweise mit http://, https://, ftp:// oder gopher://. Wenn ein Protokolltyp verwendet wird, bezieht sich der Ausnahmeeintrag nur auf Anforderungen mit diesem Protokoll. Beachten Sie, dass für den Protokollwert kein Unterschied zwischen Groß- und Kleinschreibung gilt. Mehrere Einträge sollten durch ein Semikolon (;) getrennt werden.

    Als nächstes müssen Sie eine Internetadresse, eine IP-Adresse oder einen Domänennamen eingeben. Wenn kein Protokoll angegeben wird, wird jede Anforderung, bei der die Adresse verwendet wird, umgangen. Wenn ein Protokoll angegeben wird, werden Anforderungen mit dieser Adresse nur dann umgangen, wenn es sich um den angegebenen Protokolltyp handelt. Ebenso wie bei Protokolltypen wird auch bei Adresseinträgen keine Groß- und Kleinschreibung unterschieden.

    Schließlich kann eine Anschlussnummer hinzugefügt werden. Wenn diese angegeben wird, wird die Anforderung nur verarbeitet, wenn alle zuvor genannten Anforderungen erfüllt sind und die Anforderung die angegebene Anschlussnummer verwendet.

    Im Ausnahmedialogfeld kann ein Platzhalterzeichen ( * ) anstelle von null oder mehr Zeichen verwendet werden.

Beispiele für Platzhalterzeichen

Sie können Platzhalterzeichen in folgenden Situationen verwenden:

  • Geben Sie einen Platzhalter am Anfang einer Internetadresse, einer IP-Adresse oder eines Domänennamens ein, um alle Serveradressen mit einer gemeinsamen Endung zu umgehen. Verwenden Sie beispielsweise "*.beispiel.com", um alle Einträge zu umgehen, die auf ".beispiel.com" enden (so wie "ein.beispiel.com" und "www.beispiel.com").
  • Geben Sie einen Platzhalter in der Mitte einer Internetadresse, einer IP-Adresse oder eines Domänennamens ein, um alle Serveradressen mit einem gemeinsamen Anfang und einer gemeinsamen Endung zu umgehen. Beispielsweise deckt der Eintrag "www.*.com" alle Einträge ab, die mit "www" beginnen und mit "com" enden (beispielsweise "www.irgendwo.com", "www.beinahe.überall.com" usw.).
  • Geben Sie einen Platzhalter am Ende einer Internetadresse, einer IP-Adresse oder eines Domänennamens ein, um alle Serveradressen mit einem gemeinsamen Anfang zu umgehen. Verwenden Sie beispielsweise "www.irgendwo.*", um alle Einträge zu umgehen, die mit "www.irgendwo." beginnen (so wie "www.irgendwo.com", "www.irgendwo.org", "www.irgendwo.anders.com").
  • Geben Sie mehrere Platzhalter ein, um Adressen mit ähnlichen Mustern zu umgehen. Verwenden Sie beispielsweise "123.1*.66.*", um Adressen wie "123.144.66.12", "123.133.66.15" und "123.187.66.13" zu umgehen.

Anmerkung

  • Platzhalter sind ein hilfreiches Mittel; sie müssen jedoch mit Vorsicht verwendet werden. Wenn Sie beispielsweise "www.*.com" eingeben, umgeht Internet Explorer den Proxyserver bei fast allen Websites.


Verwalten von Microsoft Internet Explorer unter Windows 2000

Auf Computern unter Windows 2000 können Sie Microsoft Internet Explorer nach der Verbreitung unter Verwendung von Gruppenrichtlinien anpassen. Sie können beispielsweise die Startseite für den Benutzer vorgeben und seine Favoritenlinks anpassen. Mit Hilfe von Gruppenrichtlinie können Windows 2000-Administratoren die Einstellungen für Benutzer und Computer über Standorte, Domänen und Organisationseinheiten hinweg steuern.

Das Verfahren zum Ausführen von Gruppenrichtlinie hängt vom Typ der zu verwaltenden Gruppe ab. Weitere Informationen zum Ausführen von Gruppenrichtlinie finden Sie unter dem Stichwort Gruppenrichtlinie in der Hilfe zu Windows 2000.

Weitere Informationen erhalten Sie unter:

Verwenden von Gruppenrichtlinie zur Verwaltung und Anpassung von Internet Explorer

  1. Klicken Sie in Gruppenrichtlinie auf Benutzerkonfiguration.
  2. Klicken Sie auf Windows-Einstellungen, und klicken Sie anschließend auf Internet Explorer verwalten.
  3. Klicken Sie auf das Symbol für das zu ändernde Feature.
  4. Doppelklicken Sie auf den Titel des Features, das Sie ändern möchten.
  5. Nehmen Sie die gewünschten Änderungen an den Einstellungen vor.

Anmerkungen

  • Wenn Sie den IEAK-Profil-Manager verwenden, um Internet Explorer mit Hilfe der automatischen Konfiguration auf anderen Plattformen zu verwalten, möchten Sie möglicherweise die Gruppenrichtlinie-Einstellungen in eine .INS-Datei und ggf. in .CAB-Dateien exportieren. So können Sie die Einstellungen für Windows 2000 auch zur Konfiguration der Einstellungen für andere Plattformen übernehmen.
  • Wenn Sie ein OEM Preinstallation Kit verwenden, können Sie den Assistenten für die Internet Explorer-Anpassung verwenden, um Windows 2000 vor der Verteilung anzupassen.
  • Falls Sie das Windows 2000-Setup im Hintergrund ausführen, können Sie mit dem IEAK-Profil-Manager die benötigten Anpassungsdateien für das Branding des Browsers erstellen. Weitere Informationen hierzu erhalten Sie in der Dokumentation zu Windows 2000.

Exportieren von Gruppenrichtlinie-Einstellungen für Internet Explorer

In Windows 2000 können Sie mit Hilfe von Gruppenrichtlinie alle Einstellungen von Internet Explorer in eine .INS-Datei und ggf. auch in .CAB-Dateien exportieren. Diese Einstellungen können dann bei der automatischen Konfiguration von Computern verwendet werden, die unter anderen Betriebssystemen ausgeführt werden.

So exportieren Sie Internet Explorer-Einstellungen bei Windows 2000

  1. Klicken Sie in Gruppenrichtlinie auf Benutzerkonfiguration.
  2. Klicken Sie auf Windows-Einstellungen, und klicken Sie dann mit der rechten Maustaste auf den Internet Explorer-Bildschirm mit den zu exportierenden Einstellungen.
  3. Klicken Sie auf Browsereinstellungen exportieren.
  4. Geben Sie den Namen der .INS-Datei und ggf. die Namen der .CAB-Dateien ein, in die Sie die Einstellungen exportieren möchten.
  5. Geben Sie die URL-Adressen der Dateien auf dem Webserver ein.

Features, die mit Gruppenrichtlinie konfigurierbar sind

Mit Hilfe von Gruppenrichtlinie können Sie folgende Bereiche anpassen und verwalten:

  • Benutzerschnittstelle und Erscheinungsbild des Browsers
  • Verbindungseinstellungen, wie beispielsweise DFÜ- oder LAN (Local Area Network)-Verbindungen und den Benutzeragententext
  • Angepasste URLs für Favoriten, die Suchleiste und die Startseite
  • Sicherheitseinstellungen wie Sicherheitszonen und Inhaltsfilter
  • Standardprogramme für allgemeine Internetaufgaben (Lesen von E-Mail-Nachrichten und Anzeigen von Newsgroups)

Wichtig

  • Unabhängig von den Installationsoptionen, die Sie für Ihr Paket konfigurieren, zeigt das Windows Update Setup-Programm für Benutzer des Betriebssystems Windows 2000 nur eine einzige Installationsoption an. Diese Installationsoption beinhaltet den vollständigen Satz der Microsoft-Internetkomponenten und darüber hinaus alle angepassten Komponenten, die in dem Paket enthalten sind.


Installieren von Internet Explorer in Verbindung mit Microsoft Office

Mit Hilfe des Assistenten für die Angepasste Installation (Custom Installation Wizard, CIW) können Sie die Methode der Verteilungvon Office-Programmen an Ihre Benutzer anpassen. Um den Installationsvorgang zu vereinfachen, ist IEAK für die Zusammenarbeit mit CIW ausgelegt.

Falls Sie Internet Explorer in Ihr angepasstes Office-Paket aufnehmen möchten, haben Sie zwei Möglichkeiten:

  • Wenn Sie keine Anpassung von Internet Explorer vornehmen möchten, können Sie Internet Explorer-Komponenten mittels CIW installieren; Sie müssen dann nicht IEAK verwenden.
  • Falls Sie jedoch planen, eine angepasste Version von Internet Explorer als Bestandteil Ihres Office-Pakets zu verteilen, klicken Sie auf die Schaltfläche Anpassen im Bildschirm IE 5-Installationsoptionen anpassen im Assistenten für die Office-Installation. Der Assistent für die Angepasste Installation startet dann IEAK.

Ausführen von IEAK vom Assistenten für die Angepasste Office-Installation aus

Der Assistent für die Internet Explorer-Anpassung wird im Firmenadministrator-Modus mit folgenden Einstellungen ausgeführt:

  • Distributionsmedium ist Flat (alle Dateien befinden sich in einem Verzeichnis).
  • Zwei Installationsoptionen stehen zur Verfügung: Die Namen dieser Optionen können nicht geändert werden, Sie können jedoch angeben, welche Komponenten mit jeder Installationsoption installiert werden.
  • Sämtliche von IEAK erstellten .CAB-Dateien und angepassten Komponenten werden im selben Ordner abgelegt. Der Standardname dieses Ordners ist IE5_cust.

Nach der Fertigstellung Ihres Anpassungspakets wird im Bildschirm IE 5-Installationsoptionen anpassen der Dateiname und Pfad zum Windows Update Setup-Programm (IE5Setup.exe) angezeigt.

Damit IEAK als Teil von CIW verwendet werden kann, müssen die erforderlichen Versionen von Internet Explorer und IEAK auf dem Computer installiert sein, auf dem Sie das angepasste Paket erstellen.

Anmerkung

  • Bei IEAK-Paketen, die mit dem Assistenten für die Angepasste Office-Installation erstellt wurden, werden bei der Installation Benutzeroptionen für Internet Explorer aus dem Windows Update Setup-Programm nicht angezeigt. Die Benutzeroberfläche von Windows Update Setup wird durch den Assistenten für die Angepasste Office-Installation bestimmt.


Wechseln von anderen Versionen oder Produkten zu Internet Explorer 5

Bevor Ihre Mitarbeiter oder Kunden Internet Explorer 5 installieren, sollten Sie bestimmte Fragen klären, die unter Umständen aufkommen.

Aktualisieren von Internet Explorer 5

Das Internet Explorer Setup-Programm installiert die aktualisierte Version über eine installierte Version von Internet Explorer 5 und importiert Proxyeinstellungen, Favoriten und Cookies aus der vorherigen Version.

Aktualisieren von Internet Explorer 4

Das Internet Explorer Setup-Programm installiert die aktualisierte Version über eine installierte Version von Internet Explorer 4 und importiert Proxyeinstellungen, Favoriten und Cookies aus der vorherigen Version. Allerdings müssen Sie alle Plug-Ins, die Sie beibehalten möchten, erneut installieren.

Internet Explorer 4 und Internet Explorer 5.x können nebeneinander auf dem gleichen Rechner ausgeführt werden.

Wenn Sie den Benutzern den Active Desktop aus Internet Explorer 4.0 zur Verfügung stellen möchten, können Sie den Desktop in Ihre Internet Explorer-Browserpakete für Windows 95- und Windows NT 4.0-Benutzer aufnehmen. Verwenden beispielsweise einige Benutzer den Active Desktop aus Internet Explorer 4.0, während andere Benutzer von Internet Explorer 3 zu Internet Explorer 5 wechseln, möchten Sie möglicherweise allen Benutzern den Active Desktop zur Verfügung stellen.

Active Desktop ist bereits in Windows 98 enthalten.

Aktualisieren von Internet Explorer 3

Das Internet Explorer Setup-Programm installiert über eine installierte Version von Internet Explorer 3 und importiert Proxyeinstellungen, Favoriten und Cookies aus der vorherigen Version. Allerdings müssen Sie alle Plug-Ins, die Sie beibehalten möchten, erneut installieren.

Migrieren von Netscape Navigator 3 oder 4

Bei der Installation von Internet Explorer können Sie Proxyeinstellungen, Favoriten und Cookies aus Netscape importieren. Allerdings müssen Sie alle Plug-Ins, die Sie beibehalten möchten, erneut installieren. Während der Installation von Internet Explorer können Sie wählen, ob Internet Explorer Ihr Standardbrowser werden soll.

Installieren von Internet Explorer in Verbindung mit Microsoft Office

Weitere Informationen hierzu finden Sie unter Installieren von Internet Explorer in Verbindung mit Microsoft Office.


Windows Update Setup für Internet Explorer und andere Internetprogramme

Der Assistent für Windows Update Setup (IE5Setup.exe) erleichtert Administratoren den Vertrieb von Internet Explorer. Darüber hinaus wird es den Benutzern erleichtert, Internet Explorer zu installieren und fehlgeschlagene Installationen wiederherzustellen.

Der Setup-Assistent ist klein und kompakt; er enthält nur ein Minimum an Code, den der Client für den Internetzugang und die Downloadgrundfunktionen benötigt.

Mit Hilfe von IEAK können Sie Windows Update Setup an die Anforderungen Ihrer Benutzer anpassen.

Vorteile des Assistenten für Windows Update Setup

Durch dieses kleine Setup-Paket kann das Windows Update Setup-Programm Informationen über den Hostcomputer sammeln, bevor der Download beginnt. Setup verwendet diese Informationen, um den Download der .CAB-Dateien für den Internet Explorer intelligent zu verwalten und die Installation so effizient und problemlos wie möglich zu gestalten. Der Download dieses kleinen Setup-Pakets zu Anfang des Vorgangs bietet viele Vorteile, z. B.:

  • Geschwindigkeit: Es dauert etwa zwei Minuten, die Datei IE5Setup.exe über eine Verbindung mit 28 Kbit/s zu downloaden.
  • Benutzer erhalten in einem frühen Stadium des Installationsvorgangs eine Rückmeldung, wenn nicht genügend Speicherplatz auf der Festplatte zur Verfügung steht (statt eine lange Downloadphase abwarten zu müssen, die möglicherweise fehlschlägt).
  • Alle Benutzeroptionen werden am Anfang zusammengestellt, sodass Benutzer nicht anwesend sein müssen, während die Dateien gedownloadet und installiert werden.
  • Wenn die Verbindung zu einem Verteilungsserver nicht zuverlässig ist und neu hergestellt werden muss, fährt der Download an dem Punkt fort, an dem er zuvor fehlgeschlagen ist. Durch diesen Vorgang nähert sich der Benutzer bei jeder Ausführung des Setup-Programms weiter einer vollständigen Installation, anstatt ganz neu beginnen zu müssen.
  • Wenn eine Verbindung zu einem Vertriebsserver nicht erneut hergestellt werden kann, stellt Setup automatisch eine Verbindung zu anderen Vertriebsservern her.
  • Benutzer erhalten sinnvolle Informationen zum Fortschritt des Downloads (nicht nur die Anzahl der Bytes pro Sekunde, sondern auch die Zeitdauer in Minuten, bis die Installation vollständig ist).
  • Wenn die aktuelle Version einer Komponente bereits installiert ist, werden die entsprechenden Dateien nicht nochmals installiert.
  • Sie können ein angepasstes Downloadpaket erstellen und ausführen, ohne Setup neu schreiben zu müssen.
  • Überflüssige temporäre Dateien können von der Festplatte entfernt werden, um freien Speicherplatz für die Installation zu schaffen.

Eine Darstellung dieses Vorgangs zeigt die Abbildung Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.

Installation anderer Komponenten mit Internet Explorer

Zusätzlich zum Internet Explorer-Browser können Sie noch andere Internetkomponenten von Microsoft oder anderen Anbietern in Ihre angepasste Version von Windows Update Setup integrieren. Der Assistent für die Internet Explorer-Anpassung vereinfacht Ihnen die Anzeige der aktuellsten Software, die gedownloadet werden kann. Mit dem angepassten Paket können Benutzer bei der Installation des Browsers diese Komponenten ganz einfach zusammen mit anderen angepassten Programmen installieren.

Die Microsoft-Komponenten reichen von Tools für Webautoren bis hin zur Unterstützung für mehrere Sprachen. Die Reihe der verfügbaren Komponenten wird fortwährend aktualisiert. Die aktuellste Liste wird jeweils im Assistenten für die Internet Explorer-Anpassung angezeigt, wenn Ihre Internetverbindung aktiv ist.

Informationen zu den neuesten Produktaktualisierungen finden Sie in der Windows Update Corporate-Website.

So funktioniert Windows Update Setup

Nachdem IE5setup.exe alle erforderlichen Informationen vom Benutzer und vom Computer ermittelt hat, werden die benötigten .CAB-Dateien von einem der offiziellen Microsoft-Verteilungsserver im Internet gedownloadet. Da das Setup-Programm bereits alle auf dem Computer vorhandenen Internet Explorer-Komponenten ermittelt und den Benutzer nach den gewünschten Komponenten gefragt hat, werden keine überflüssigen .CAB-Dateien gedownloadet.

Die nächste Stufe des Setup-Programms verwendet das traditionelle Setup-Programm (ACME), das von den meisten Microsoft-Produkten eingesetzt wird. An diesem Punkt besteht der einzige Unterschied zwischen dem Setup-Assistenten und dem traditionellen Setup-Programm darin, dass sich die .CAB-Dateien in einem Ordner auf dem lokalen Festplattenlaufwerk statt auf einem Wechselmedium oder einem Netzlaufwerk befinden.

Wenn Sie Intranetadministrator sind, können Sie ein angepasstes Setuppaket erstellen (das auch als IExpress-Paket bezeichnet wird), ohne das Windows Update Setup-Programm neu schreiben zu müssen. Zu diesem Zweck erstellen Sie eine angepasste Version von IE5setup.exe unter Verwendung des Tools IExpress.

Um eine Feinabstimmung des Installationsvorgangs zu ermöglichen, können Sie zusätzliche Befehlszeilenparameter festlegen. Weitere Informationen erhalten Sie unter Parameter für die Ausführung von Internet Explorer-Setup im Batchmodus.

Anpassen von Windows Update Setup

Sie können Windows Update Setup auf verschiedene Weisen anpassen. Beispielsweise können Sie Internet Explorer-Komponenten hinzufügen oder bis zu 10 verschiedene Installationsoptionen erstellen. Dadurch können Sie Alternativen zu den standardmäßigen Internet Explorer-Installationsoptionen Standard, Minimal und Vollständig anbieten. Mehrere Installationsoptionen bereitzustellen, kann von großem Nutzen sein, wenn für verschiedene Mitarbeiter unterschiedliche Nutzungsanforderungen oder Begrenzungen des Festplattenspeichers gelten.

Wichtig

  • Unabhängig von den Installationsoptionen, die Sie für Ihr Paket konfigurieren, zeigt das Windows Update Setup für Benutzer des Betriebssystems Windows 2000 nur eine einzige Installationsoption an. Diese Installationsoption beinhaltet das vollständigen Satz der Microsoft-Internetkomponenten und darüber hinaus alle angepassten Komponenten, die in dem Paket enthalten sind.

In manchen Fällen kann es günstiger sein, mögliche Irritationen bei Benutzern zu reduzieren, indem Sie bestimmte Vorgaben im Setup-Programm festlegen. Sie können Internet Explorer so konfigurieren, dass die Installation ohne oder mit nur wenigen Eingaben der Benutzer durchgeführt wird. Diese Installationsmethode wird auch als "automatische Installation" bezeichnet.

Installationen mit eingeschränktem Eingabeaufwand werden häufig dazu genutzt, Internet Explorer zu Zeiten zu installieren, in denen die Benutzer nicht anwesend sind. Diese Installationsmethoden können Sie durch die Anwendung von Befehlszeilenparametern oder Batchdateien noch weiter anpassen. Da die Auswahloptionen für die Benutzer bereits durch Sie festgelegt werden, kann nur eine Option für die "automatische Installation" erstellt werden.

Wenn Sie sämtliche Benutzerrückmeldungen einschließlich Fehlermeldungen und Statusinformationen unterdrücken, sollten Sie in Ihrem Installationsplan Fehlerbehandlungsmaßnahmen vorsehen. Falls kein automatischer Neustart nach der Installation ausgeführt wird, müssen Sie den Neustart in Ihrem angepassten Programm oder Skript berücksichtigen, damit sichergestellt ist, dass Internet Explorer ordnungsgemäß eingerichtet wird. Weitere Informationen über diese Optionen finden Sie unter Automatische Installation.

Es kann unter Umständen vorteilhaft sein, bei der Installation von Internet Explorer die Installation eigener angepasster Komponenten (beispielsweise Virenprüfprogramme oder -skripts) vorzusehen. Sie können bis zu 10 angepasste Komponenten in Ihr angepasstes Paket aufnehmen.

Darüber hinaus können Sie das Erscheinungsbild des Setup-Programms ändern, beispielsweise eigene Bitmaps hinzufügen oder spezifische Beschreibungen für die verschiedenen Installationsoptionen bereitstellen.

Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten. Ein Flussdiagramm zur Erläuterung der Prozesse bei der Verwendung des Assistenten für die Internet Explorer-Anpassung bei der Erstellung von angepassten Paketen erhalten Sie unter Erstellen angepasster Pakete mit IEAK.

Aufzeichnen von Installationsproblemen in Protokolldateien

Verbesserte Protokollierungsfeatures vereinfachen die Fehlerbehandlung von Installationsproblemen durch den Benutzer, den Administrator und Microsoft. Der Setup-Assistent erstellt die folgenden beiden Protokolldateien, die Sie bei der Erkennung der Fehler unterstützen, die auftreten können. Die Protokolldateien befinden sich entweder im Ordner Windows oder im Ordner Winnt:

  • Active Setup Log.txt: Protokolliert alle Aktionen während der Installation durch den Setup-Assistenten oder der Komponenteninstallation. Untersuchen Sie diese Protokolldatei, wenn Internet Explorer-Komponenten nicht einwandfrei installiert werden. Weitere Informationen finden Sie unter Fehlerprotokollinformationen für Active Setup Log.txt.
  • RunOnceEx Log.txt: Protokolliert alle Aktionen während der DLL (Dynamic Link Library)-Registrierung. Untersuchen Sie diese Protokolldatei, wenn Sie eine Meldung erhalten, dass eine bestimmte .DLL-Datei nicht einwandfrei registriert wurde, oder wenn während der abschließenden Phase des Installationsvorgangs ein unerwartetes Dialogfeld angezeigt wird.


Bereitstellen von Addon-Komponenten für Benutzer

Nachdem Sie Ihr angepasstes Browserpaket erstellt haben, möchten Sie es möglicherweise auf Sites bereitstellen, von denen es Benutzer downloaden können. Diese Sites geben Sie in Schritt 3 des Assistenten für die Internet Explorer-Anpassung an. Sie können außerdem festlegen, wo Ihre Benutzer neue Komponenten oder Komponentenaktualisierungen erhalten können. Diese werden als Addon-Komponenten bezeichnet.

Wenn der Benutzer auf Extras und dann auf Windows Update klickt, öffnet der Browser den von Ihnen angegebenen URL für Addon-Komponenten. Dies geschieht ebenfalls, wenn der Benutzer in der Systemsteuerung auf Software, auf Microsoft Internet Explorer 5.5 und Internettools und dann auf Hinzufügen/Entfernen klickt und anschließend Eine Komponente hinzufügen auswählt.

Anmerkung

  • Der von Ihnen festgelegte URL für Addon-Komponenten sollte der vollständige Pfad zu Addon.htm sein (z. B. http://MeinServer/addons/addon.htm).

Web-Beispielseiten für Addon-Komponenten

Das IEAK-Toolkit enthält eine Web-Beispielseite für Addon-Komponenten, Addon.htm, die Sie anpassen können. Diese Seite befindet sich im Ordner \<IEAK-Programmordner>\Toolkit\Addons\HTML. Sie bietet außerdem Links zu den Dateien Head.htm, Main.htm und Info.htm.

Im Folgenden sehen Sie eine Beschreibung der vier Beispieldateien im Ordner \<IEAK-Programmordner>\Toolkit\Addons\HTML:

  • Addon.htm: Frameset, das sich auf diese beiden Dateien bezieht:
    • Head.htm: Vorspannframe für den Titel
    • Main.htm: Hauptframe mit Installationsskripts und Verknüpfung zu Info.htm
  • Info.htm: Informationen zu allen verfügbaren Komponenten

Die meisten Änderungen werden in der Datei Main.htm vorgenommen, die aus drei Teilen besteht:

  • Installationsskripts
  • Tabelle der Kontrollkästchen, Komponentennamen und -größen
  • Setup ActiveX-Steuerelement

Verwendung der Beispieldateien

Kopieren Sie alle vier Dateien in Ihren Downloadordner oder in den von Ihnen angegebenen Pfad, und bearbeiten Sie sie anschließend in einem Texteditor oder einem HTML-Editor.

Damit die Skripts einwandfrei funktionieren, müssen die Dateien folgendermaßen eingerichtet sein:

  • Die Datei IEcif.cab sollte sich auf einem Webserver befinden.
  • In Main.htm sollte der Eintrag L_cab_Address= unter <script LANGUAGE="VBScript"> auf den Speicherort von IEcif.cab zeigen.
  • Die Tabelle in Main.htm sollte nur die Komponenten enthalten, die Sie von Microsoft gedownloadet haben und zur Verfügung stellen möchten.

So fügen Sie neue Komponenten hinzu

  1. Stellen Sie sicher, dass Sie den Download der Komponenten während der Automatischen Versionssynchronisierung (AVS) durchgeführt haben.
  2. Schlagen Sie den richtigen Namen der Komponente in IESetup.cif nach.
  3. Fügen Sie dann ein Kontrollkästchen mit dem betreffenden Namen zu Addon.htm hinzu.

Wenn Sie ein erfahrener Webseitenautor sind, brauchen Sie nicht die in IEAK vorhandenen Vorlagen verwenden.

Informationen für erfahrene Webseitenautoren

In Main.htm werden zwei Skriptsprachen verwendet: JScript und Visual Basic Script Edition (VBScript). Der JScript-Code enthält die Funktion Install(). Diese Funktion wird aufgerufen, wenn der Benutzer unten auf der Seite auf die Schaltfläche Installieren klickt. Sie steuert den Ablauf des Installationsvorgangs. Die Funktion Install() ruft mehrere der VBScript-Unterroutinen auf.

Die Skripts verwenden die Eigenschaft name (Teil des Tags input) der Kontrollkästchen, um die Datei IESetup.cif zu lesen. Diese Datei ist in der Datei IEcif.cab enthalten und wird von der Unterroutine Window_onLoad() geöffnet.

Anmerkung

  • Windows 95- und Windows NT-Benutzerkomponenten können unterschiedliche Namen aufweisen. Sie finden diese Informationen in der Datei IESetup.cif.

Um herauszufinden, ob eine Komponente bereits installiert ist, können Sie die VBScript-Unterroutine IsComponentInstalled() verwenden.

IsComponentInstalled(ComponentID)

ComponentID ist gleich dem Namen des Kontrollkästchens und dem Wert in der Datei IESetup.cif.

Rückgabecode | Bedeutung
0 | Komponente ist nicht installiert
1 | Komponente ist bereits installiert
2 | Komponente ist zwar installiert, es ist jedoch eine neuere Version verfügbar
3 | Sperrung der Benutzersicherheit: Kein Status angegeben

Wenn die erste Komponente mit dieser Methode überprüft wird, aktiviert die ActiveX-Engine ein Sicherheitsdialogfeld, das die Erlaubnis anfordert, den Status installierter Komponenten auf dem Computer des Benutzers zu überprüfen. Wenn der Benutzer Nein wählt, ist der Rückgabecode für alle Komponenten 3.


Zusammenfassen von Microsoft-Updates in angepassten Komponenten

Referenz

Zusammenfassen von Microsoft-Updates in angepasste Komponenten

Möglicherweise möchten Sie abgesehen von der verfügbaren Version eine Version einer Microsoft-Komponente unter Verwendung der Automatischen Versionssynchronisierung (AVS) installieren. So ist z. B. möglicherweise ein Patch (QFE) über Windows Update verfügbar, von dem Sie möchten, dass Ihre Benutzer es installieren, das jedoch über die Automatische Versionssynchronisierung (AVS) nicht zur Verfügung steht. Es ist ebenfalls möglich, dass Ihre Firma oder Organisation standardmäßig eine andere Version einer Microsoft-Komponente verwendet, die im Lieferumfang von Internet Explorer enthalten ist, wie z. B. NetMeeting, und Sie beabsichtigen, diese Version an Stelle der in dem mit dem IEAK-Assistenten erstellten Paket enthaltenen Version für Ihre Benutzer beizubehalten.

In den genannten Fällen können Sie ein Paket dieser Dateien als angepasste Komponente in Ihr angepasstes Paket aufnehmen.

Um die Anzahl der durch die Benutzer durchgeführten Systemneustarts so gering wie möglich zu halten, können Sie den Zeitpunkt, an dem diese Komponente installiert werden soll, in Abhängigkeit von den anderen während des Installationsvorgangs durchzuführenden Schritten wählen. Sie können die Komponente vor oder nach der Installation von Internet Explorer - oder nach dem erforderlichen Systemneustart - installieren.

Weitere Informationen finden Sie unter Downloadsite und Automatische Versionssynchronisierung (AVS) und unter Angepasste Komponenten hinzufügen: Installationsbedingungen.


Deinstallieren einer angepassten Komponente

Wenn Sie das Deinstallationsprogramm für Ihre angepasste Komponente bei der Ausführung von Setup registrieren, können die Benutzer das Programm mit Hilfe des Programms Software in der Systemsteuerung deinstallieren. Ein Beispiel für eine Deinstallationsdatei finden Sie in der Datei Uncheck.inf im Unterordner \<IEAK-Programmordner>\Toolkit\Inf des IEAK-Toolkits.

Ihre Anwendung muss dem folgenden Registrierungsschlüssel die unten aufgeführten Einträge hinzufügen, um das Deinstallationsprogramm so zu registrieren, das ein Eintrag unter Software in der Systemsteuerung erstellt wird:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\Anwendungsname

Dieser Registrierungsschlüssel wird auch von Windows Update Setup verwendet, um zu überprüfen, ob die Komponente ordnungsgemäß installiert wurde.

Teilschlüssel | Datentyp | Wert
DisplayName | Zeichenfolge | Der Anzeigename für die Anwendung
UninstallString | Zeichenfolge | Vollständige Befehlszeile mit Pfadinformationen zur Deinstallation der Anwendung Verwenden Sie keine Stapelverarbeitungsdatei oder Unterprozess.

Der Wert für Anwendungsname muss dem Wert von Deinstallationsschlüssel im Bildschirm Angepasste Komponenten hinzufügen im Assistenten für die Internet Explorer-Anpassung entsprechen.

Weitere Informationen finden Sie unter Bereitstellen der Funktion zum Deinstallieren in einem .INF-Skript.


Arbeiten mit Setup-Informationsdateien ("

Referenz

Arbeiten mit Setup-Informationsdateien (".INI")

Eine Informationsdatei (.INF) ist eine Textdatei, in der die Dateien angegeben sind, die vorhanden sein müssen oder gedownloadet werden müssen, damit Ihre Komponente unter 32-Bit-Versionen von Windows ausgeführt werden kann. Der Internet Component Download-Dienst verwendet diese Anweisungen zum Installieren und Registrieren von Softwarekomponenten, die aus dem Internet gedownloadet wurden, sowie der Dateien, die für die Komponenten erforderlich sind. Der Internet Component Download-Dienst ist seit Version 3.0 Bestandteil von Internet Explorer.

Ein Internet-Softwaredistributionseinheit ist ein "Paket" bestehend aus einer Kabinettdatei (.CAB), die eine .INF-Datei enthält. Eine Distributionseinheit kann darüber hinaus eine Softwarekomponente enthalten, wie z. B. ein ActiveX-Steuerelement (.OCX), eine .DLL-Datei, eine .EXE-Datei, eine Java Class-Datei oder ein Applet. Wenn durch das Attribut CODEBASE eines OBJECT-Elements auf einer Webseite auf eine Kabinettdatei verwiesen wird, die eine .INF-Datei enthält, behandelt Internet Explorer 3.0 und höher die Kabinettdatei automatisch als Softwarevertriebseinheit.

Mit Hilfe von .INF-Dateien können Sie angepasste Softwareinstallationsanweisungen erstellen, die Registrierungseinträge und Zielverzeichnisse enthalten. Eine .INF-Datei kann eingeschränkte Plattformunabhängigkeit bereitstellen und eingeschränkte Softwareabhängigkeiten festlegen.

Die folgenden Themen bieten weitere Informationen über das Arbeiten mit .INF-Dateien:

  • Definition zu Setup-Informationsdateien (.INF)
  • Bearbeiten von Ordnern und Dateien mit Setup-Informationsdateien (.INF)
  • Erweiterungen für Windows Setup
  • Bereitstellen der Funktion zum Deinstallieren in einem .INF-Skript
  • Erweiterte Anpassung für den Messenger Service-Client
  • Verwenden der RunOnce-Technologie
  • Beispiel-.INF-Datei für den Downloaddienst für Komponenten

Anmerkung

  • Weitere Informationen zum Internet Component Download-Dienst finden Sie im MSDN Online Web Workshop.


Erweiterungen für Windows Setup

Es gibt drei Möglichkeiten, Windows Setup zu erweitern:

  • Führen Sie die Windows-.INF-Dateien mit Hilfe von Rundll.exe von der Befehlszeile aus.
  • Installieren Sie, als Alternative zur Softwareinstallation über das Dialogfeld Eigenschaften von Software in der Systemsteuerung, optionale Windows-Softwarekomponenten von 32-Bit-Programmcode aus.
  • Erstellen Sie ein Symbol auf dem Windows-Desktop, auf das der Benutzer klicken kann, um eine .INF-Datei auszuführen. Auf diese Weise sparen Sie sich die Entwicklung von Installationsprogramm-Code.

Ausführen der ".INF"-Dateien von der Befehlszeile aus

Mit Hilfe der Windows-Systembefehle Rundll.exe bzw. Rundll32.exe können Sie einen Installationsabschnitt in einer .INF-Datei ausführen. Die Syntax der Befehlszeile lautet folgendermaßen:

rundll setupx.dll,InstallHinfSection <Abschnitt> <Neustartmodus> <Inf-Name>

Der Parameter <Abschnitt> steht für einen Installationsabschnitt in der .INF-Datei. Beispielsweise wird mit folgender Befehlszeile die optionale Komponente Spiele installiert. Falls Setup festlegt, dass ein Neustart des Computers erforderlich ist, wird der Benutzer außerdem gefragt, ob der Computer unmittelbar nach Abschluss der Installation neu gestartet werden soll. (Die Bedeutung der Werte für den Parameter <Neustartmodus> wird weiter unten unter "Verwenden der Parameter für den Neustart-Modus" erläutert.)

Rundll setupx.dll,InstallHinfSection Spiele 4 applets.inf

Anmerkungen

  • Dieser Befehl setzt voraus, das der zum Installieren der Dateien erforderliche Festplattenspeicher verfügbar ist. Es werden keine Überprüfungen auf freien Speicherplatz vorgenommen.
  • Ihre Installationsanwendung darf keinen Code enthalten, der nach dem Aufruf von rundll oder rundll32 ausgeführt wird. Wenn die Steuerung einmal an Setupx.dll übergegangen ist, wird möglicherweise ein Neustart des Computers durchgeführt. Wenn Ihr Installationsvorgang zusätzlichen Code erfordert, der nach dem Aufruf von rundll oder rundll32 durch den vorhandenen Code ausgeführt wird, verwenden Sie die RunOnce-Liste in Ihrer .INF-Datei.
  • Verwenden Sie die RunOnce-Liste nicht zum Ausführen der zu installierenden optionalen Komponente.

Verwenden der Parameter für den Neustart-Modus

Es stehen fünf Neustart-Modi zur Verfügung:

define HOW_NEVER_REBOOT 0
define HOW_ALWAYS_SILENT_REBOOT 1
define HOW_ALWAYS_PROMPT_REBOOT 2
define HOW_SILENT_REBOOT 3
define HOW_PROMPT_REBOOT 4

Gibt <Inf-Name> statt einer Windows-.INF-Datei eine eigene .INF-Datei an, müssen Sie zu den oben angezeigten Werten den Wert 128 addieren. Im Beispiel oben, mit dem die optionale Komponente Spiele installiert wird, ist <Neustartmodus> auf den Wert 4 gesetzt. Dies ist erforderlich, da es sich bei Applets.inf um eine Windows-.INF-Datei handelt. Wenn Sie eine optionale Komponente installieren, die über eine eigene .INF-Datei verfügt, müssen Sie <Neustartmodus> auf 132 setzen. Falls Sie zum Parameter <Neustartmodus> den Wert 128 addieren, müssen sich sämtliche zu installierenden Dateien auf dem Installationsdatenträger im selben Ordner wie Ihre .INF-Datei befinden.

Anmerkung

  • Die einzig empfohlene Wert für <Neustartmodus> ist 4, falls die .INF-Datei eine Windows 95-.INF-Datei ist, bzw. 132, falls die .INF-Datei von Ihnen bereitgestellt wird. Die Verwendung der übrigen oben angezeigten Werte kann einen unnötigen Neustart des Computers verursachen oder einen Neustart des Computers verhindern, obwohl dieser erforderlich ist.

In der folgenden Liste werden die einzelnen Neustartmodi erläutert:

NeverReboot
Setzen Sie <Neustartmodus> auf 0 oder 128. Der Computer wird in keinem Fall neu gestartet. Es bleibt der Entscheidung des Clients überlassen, ob der Computer neu gestartet werden soll. Für Setup bedeutet dies, dass eine Datei C:\Windows\Wininit.ini vorhanden ist, für die als Größe nicht null Byte angegeben ist.

AlwaysSilentReboot
Setzen Sie <Neustartmodus> auf 1 oder 129. Der Benutzer wird nicht zum Neustart des Computers aufgefordert, aber der Computer wird immer neu gestartet.

AlwaysPromptReboot
Setzen Sie <Neustartmodus> auf 2 oder 130. Der Benutzer wird immer gefragt, ob der Computer neu gestartet werden soll. Setup versucht nicht, festzustellen, ob ein Neustart des Computers erforderlich ist.

SilentReboot
Setzen Sie <Neustartmodus> auf 3 oder 131. Wenn Setup feststellt, dass der Computer neu gestartet werden muss, wird dies ohne Benutzereingaben ausgeführt.

PromptReboot
Setzen Sie <Neustartmodus> auf 4 oder 132. Wenn Setup feststellt, dass der Computer neu gestartet werden muss, wird für den Benutzer ein entsprechendes Dialogfeld angezeigt.

Zurück zum Anfang der Datei

Installieren optionaler Komponenten aus 32-Bit-Anwendungscode

Nach der Installation von Windows auf einem Computer müssen Sie gegebenenfalls eine oder mehrere der optionalen Windows-Komponenten hinzufügen (beispielsweise Spiele). Diese Art von Installation, die sich anschließt, nachdem Setup zuerst Windows installiert hat, wird als Wartungsinstallation bezeichnet. In der Regel wird die Wartungsinstallation aus Windows heraus durch Klicken auf das Symbol Software in der Systemsteuerung gestartet. Hersteller und Anbieter der optionalen Softwarekomponente können jedoch auch wie folgt vorgehen: Sie können die optionale Komponente über die Verwendung des Aufrufs CreateProcess in einer 32-Bit-Anwendung installieren.

Anmerkung

  • Die unten beschriebene Installation einer optionalen Komponente über CreateProcess darf nur in 32-Bit-Anwendungen durchgeführt werden.

Sie können eine optionale Komponente aus einer 32-Bit-Anwendung installieren, indem Sie eine Kombination aus den unten beschriebenen Verfahren verwenden.

Überprüfen der Registrierung

Überprüfen Sie zunächst die Registrierung, um festzustellen, ob die optionale Komponente derzeit installiert ist (oder suchen Sie nach den Dateien). Der Registrierungsschlüssel, in dem sich die Informationen über alle derzeit installierten optionalen Komponenten befinden, lautet wie folgt:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents]

Unter diesem Schlüssel finden sich Werte, die auf Teilschlüssel verweisen, und jeder Teilschlüssel enthält Informationen über die installierten optionalen Komponenten sowie Informationen, die zum Installieren einer neuen optionalen Komponente benötigt werden. Angenommen, Sie möchten Spiele als optionale Komponente installieren. Um festzustellen, ob Spiele installiert ist, überprüfen Sie folgenden Teilschlüsselwert unter dem Schlüssel "OptionalComponents":

"Spiele"="Spiele"

Öffnen Sie anschließend den Schlüssel "Spiele" unter dem Schlüssel mit den optionalen Komponenten, um Folgendes anzuzeigen:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents\Spiele]
"INF"="applets.inf"
"Section"="Spiele"
"Installed"="0"

Dies zeigt, das die optionale Komponente Spiele auf diesem Windows-Computer nicht installiert ist, da das Flag "Installed" auf 0 gesetzt ist.

Codieren des Funktionsaufrufs "CreateProcess"

Verwenden Sie zum Installieren einer optionalen Komponente, wie z. B. Spiele, die Werte "INF" und "Section" aus dem oben stehenden Schlüssel in einem CreateProcess-Aufruf, der Setupx.dll über rundll ausführt. Dies führt zum gleichen Ergebnis wie die Installation einer Komponente über Software in der Systemsteuerung. Die Syntax des Parameters lpCommandLine im Aufruf CreateProcess sieht wie folgt aus:

rundll setupx.dll,InstallHinfSection <section> <Neustartmodus> <Inf-Name>

Die Werte für die Parameter <Abschnitt> und <Inf-Name> finden Sie in dem oben beschriebenen Registrierungsschlüssel. Beispielsweise wird mit dem folgenden CreateProcess-Aufruf die optionale Komponente Spiele installiert. Falls Windows Setup feststellt, dass ein Neustart des Computers erforderlich ist, wird der Benutzer außerdem gefragt, ob der Computer unmittelbar nach Abschluss der Installation neu gestartet werden soll. (Die Bedeutung der Werte für den Parameter <Neustartmodus> wird weiter unten im Abschnitt "Verwenden der Parameter für den Neustart-Modus" erläutert.)

rundll setupx.dll,InstallHinfSection Spiele 4 applets.inf

Anmerkung

  • Es wird empfohlen, vor der Installation der Komponente den verfügbaren freien Speicherplatz zu überprüfen. Dabei ist zu beachten, dass Speicherplatz für Auslagerungsdateien vorhanden sein muss.

Ihre Installationsanwendung darf keinen Code enthalten, der nach dem CreateProcess-Aufruf ausgeführt wird. Wenn die Steuerung einmal an Setupx.dll übergegangen ist, wird durch den zusätzlichen Code möglicherweise ein Neustart des Computers ausgelöst. Wenn Ihr Installationsvorgang zusätzlichen Code erfordert, der nach dem Aufruf von CreateProcess durch den vorhandenen Code ausgeführt wird, verwenden Sie die RunOnce-Liste in Ihrer .INF-Datei.

Anmerkung

  • Verwenden Sie die RunOnce-Liste nicht zum Ausführen der zu installierenden optionalen Komponente.

Ausführen einer ".INF"-Datei durch Klicken mit der rechten Maustaste

Setup erkennt in .INF-Dateien den Namen eines bestimmten Installationsabschnitts, DefaultInstall, mit denen optionale Komponenten installiert werden. Wenn Sie einen Abschnitt [DefaultInstall] in Ihrer .INF-Datei verwenden, kann der Benutzer bei 32-Bit-Versionen von Windows auf der Benutzeroberfläche mit der rechten Maustaste auf ein Dateisymbol für die .INF-Datei klicken, um den Abschnitt [DefaultInstall] auszuführen. (Nachdem der Benutzer mit der rechten Maustaste auf das Symbol für die .INF-Datei geklickt hat, wird ein Popup-Menü angezeigt, in dem der Benutzer die Option Installieren wählen muss, damit der Abschnitt [DefaultInstall] tatsächlich ausgeführt wird.)

Das Verwenden eines Installationsabschnitts namens [DefaultInstall] in Ihrer .INF-Datei stellt eine praktische Methode dar, die optionale Komponente zu installieren. Dies ist besonders während der Entwicklung der Anwendung hilfreich. Wenn Sie eine Installationsanwendung schreiben möchten, verfügen Sie bereits vor der Entwicklung des Codes für die Installationsanwendung über eine Methode zum Installieren der optionalen Komponente.

Im Folgenden sehen Sie ein Beispiel für den Abschnitt DefaultInstall mit typischen Einträgen:

[DefaultInstall]
CopyFiles=QCD.copy.prog, QCD.copy.hlp, QCD.copy.win, QCD.copy.sys, QCD.copy.inf
UpdateInis=QCD.Links
AddReg=QCD.reg, QCD.run
Uninstall=FlexiCD_remove


Bearbeiten von Ordnern und Dateien mit Setup-Informationsdateien (".INI")

Referenz

Bearbeiten von Ordnern und Dateien mit Setup-Informationsdateien (.INF)

Mit Hilfe von .INF-Dateien können Sie Dateien und Ordner auf unterschiedliche Weise bearbeiten. Im Folgenden werden einige wichtige Möglichkeiten genannt:

  • Erstellen von Ordnern und Links in Ordnern
  • Erstellen und Löschen langer Dateinamen
  • Festlegen von Attributen für Dateien und Ordner
  • Kopieren von Dateien in den Ordner Programme

Erstellen von Ordnern und Links in Ordnern

Das Erstellen eines Ordners im Ordner Programme oder das Erstellen von Links in einem Ordner wird von der Shell durchgeführt, nachdem eine Komponente installiert wurde. Setup sucht in der Datei Setup.ini nach dem Abschnitt [progman.groups] und analysiert diesen dann, um Ordner und Links in diesen Ordnern zu erstellen.

Wenn Sie eine Komponente installieren, für die ein Ordner oder Links im Ordner Programme erforderlich sind, müssen Sie einen Abschnitt namens UpdateInis erstellen, der die entsprechenden Einträge in der Datei Setup.ini erstellt. Die Datei Setup.ini verwendet die nachstehende Syntax, um Ordner und Links zu erstellen. Beachten Sie, dass Ordner relativ zum Startmenü sind.

[progman.groups]
Ordner_1=Name_Ordner_1
Ordner_2=Name_Ordner_2
:
Ordner_n=Name_Ordner_n

[Ordner_1]
Link-Name, .EXE-Name, Symboldateiname, Symbolindex, Profil

Wenn im Feld Profil kein Wert angegeben wird, wird der Link stets zum Ordner hinzugefügt.

Anmerkungen

  • Falls .EXE-Name ein Nullelement ist, wird es aus der Gruppe gelöscht, sofern es dort vorhanden ist.
  • Weist die Beschreibung eines Ordners oder eines Links ein Leerzeichen auf, müssen Sie doppelte Anführungszeichen verwenden, damit die Beschreibung in der Datei Setup.ini angezeigt wird. Siehe die Beispiele unten.

Beispiel: Spiele

[Optionale Komponenten]
Spiele

[Spiele]
OptionDesc= %GAMES_DESC%
CopyFiles= wingames.files
UpdateInis= wingames.links
[wingames.files]
cards.dll
freecell.exe
freecell.hlp
mshearts.exe
mshearts.hlp
sol.exe
sol.hlp
winmine.exe
winmine.hlp

[wingames.links]
setup.ini, progman.groups,, "gamesfolder=%GAMES_DESC%" ;creates folder
setup.ini, gamesfolder,, """Solitär"",SOL.EXE,,," ;creates link
setup.ini, gamesfolder,, "Minesweeper,WINMINE.EXE,,," ;creates link
setup.ini, gamesfolder,, ""Hearts"",MSHEARTS.EXE,,,";creates link
setup.ini, gamesfolder,, "FreeCell,FREECELL.EXE,,," ;creates link

Ergebnis: Der Eintrag für "Spiele" wird im Dialogfeld Optionale Komponenten in Setup angezeigt, und es wird auf Wunsch im Ordner Programme ein Ordner namens Spiele erstellt, der Links zu Solitär, MineSweeper, Hearts und FreeCell enthält.

Erstellen und Löschen langer Dateinamen

Der Basisschlüssel der Registrierung für Umbenennungsvorgänge lautet wie folgt:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RenameFiles

Der Basisschlüssel der Registrierung für Löschvorgänge lautet wie folgt:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\DeleteFiles

Die einzelnen Gruppen mit Umbenennungs- und Löschvorgängen werden einem Teilschlüssel unter dem jeweiligen Schlüssel zugeordnet. Die Gruppen mit Vorgängen sind auf das Umbenennen oder Löschen von Dateien in einem einzelnen Ordner beschränkt. Sie müssen mindestens zwei Einträge in jeden Teilschlüssel einfügen, damit ein Umbenennungs- oder Löschvorgang in Kraft tritt: den Ordnerpfad für die umzubenennenden oder zu löschenden Dateien sowie den eigentlichen Umbenennungs- bzw. Löschvorgang.

Der erste Schlüssel in jeder Gruppe von Vorgängen ist der Ordnereintrag. Jeder Eintrag für einen Umbenennungsvorgang in dem betreffenden Ordner ist ein Eintrag mit folgendem Format: "alter_kurzer_Name"="neuer_langer_Name,[Attrib_Flag]".

Das optionale Attrib_Flag dient der Festlegung von Dateiattributen während des Umbenennungsvorgangs. Das Flag setzt sich aus folgenden Werten zusammen:

1 | READONLY
2 | HIDDEN
3 | SYSTEM

Wenn Sie mehrere Attribute für eine Datei oder einen Ordner festlegen möchten, müssen Sie die Flags zusammen zuordnen; um beispielsweise die Attribute READONLY und HIDDEN festzulegen, müsste Attrib_Flag 3 sein.

Im folgenden Beispiel sehen Sie den Abschnitt AddReg, der für den Ordner \Windows\System\Sample die Attribute "System" und "Versteckt" festlegt:

HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,,,%11% HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,SAMPLE,,"SAMPLE,6"

Anmerkung

  • Sie sollten ausschließlich Großbuchstaben verwenden, um sicherzustellen, dass der Dateiname kurz bleibt.

Jeder Eintrag für einen Löschvorgang in dem betreffenden Ordner ist ein Eintrag mit folgendem Format: "beliebiger_Schlüsselname"="langer_zu_löschender_Name".

Im folgenden Beispiel sehen Sie den Abschnitt AddReg, der folgende Aktionen ausführt:

  • Umbenennen der Datei Altname.txt in Neuer langer Name.txt im Ordner C:\Beispiel.
  • Umbenennen der Datei Readme.txt in Meine Anwendung Readme.txt im Ordner Windows.

[MyAppShort2Long]
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Beispiel,,,C:\Beispiel
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Beispiel,altname.txt,,"Neuer langer Name.txt"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,readme.txt,,"Meine Anwendung Readme.txt"

Im folgenden Beispiel sehen Sie den Abschnitt AddReg, der folgende Aktionen ausführt:

  • Löschen der Datei Neuer langer Name.txt aus dem Ordner C:\Beispiel.
  • Löschen der Datei Meine Anwendung Readme.txt aus dem Ordner Windows.

[MyAppDelLong]
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Beispiel,,,C:\Beispiel
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Beispiel,altname.txt,,"Neuer langer Name.txt"
 HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,readme.txt,,"Meine Anwendung Readme.txt"

Wenn diese Umbenennungen und Löschvorgänge verarbeitet worden sind, werden die Einträge aus der Registrierung gelöscht.

Anmerkung

  • Während des Umbenennungsvorgangs wird die Zieldatei gelöscht, bevor Dateien umbenannt werden. Wird derselbe Umbenennungsvorgang ein zweites Mal in die Warteschlange eingereiht, kann dies den Verlust der Datei zur Folge haben. Angenommen, eine Bitmap soll von Bild.bmp in Echt tolles 3D-Bild.bmp umbenannt werden. Wenn diese Umbenennung ein zweites Mal durchgeführt wird, existiert Echt tolles 3D-Bild.bmp bereits und wird daher gelöscht, bevor die Umbenennung tatsächlich stattfindet. Ausgenommen hiervon ist der Fall, dass es sich bei dem vorhandenen Zieldateinamen um einen Ordner handelt.

Festlegen von Attributen für Dateien und Ordner

Beim Festlegen der Attribute für eine Datei oder einen Ordner sind dieselben Richtlinien zu beachten wie beim Erstellen von langen Dateinamen mit einem optionalen Flag.

Details hierzu finden Sie im Abschnitt "Erstellen und Löschen von langen Dateinamen".

Kopieren von Dateien in den Ordner "Programme"

Im folgenden Beispiel werden drei Dateien in den Ordner Programme\Zubehör kopiert und Links zu einer der Dateien eingerichtet:

[WordPadInstall]
CopyFiles = WordPadCopyFiles
UpdateInis = WordPadInis

[DestinationDirs]
WordPadCopyFiles = 24,%PROGRAMF%\%ACCESSOR%

[WordPadCopyFiles]
mswd6_32.wpc
wordpad.exe
write32.wpc
[WordPadInis]
setup.ini, progman.groups,, "group4=%APPS_DESC%" ;erstellt Ordner Zubehör (falls nicht bereits vorhanden)
setup.ini, group4,, """%WORDPAD_LINK%"", ""%24%\%PROGRAMF%\%ACCESSOR%\WORDPAD.EXE""" ;erstellt Link in Ordner Zubehör

[Strings]
APPS_DESC = "Zubehör"
WORDPAD_LINK = "WordPad"
; Ordnernamen - die kurzen Versionen müssen mit den verkürzten
; 8-Zeichen-Namen für die langen Versionen übereinstimmen, da es ansonsten zu Problemen kommt.
PROGRAMF = "Progra~1" ; erste 6 Zeichen von Programme, + "~1"
ACCESSOR = "Zubehör" ; ist kein langer Name

Einschränkungen für ".INF"-Dateien

  • Verzeichnisse können nicht gelöscht werden.
  • Dateien können nicht an eine andere Stelle verschoben werden, wenn RenFiles verwendet wird. (Mit dem Befehl RenFiles kann nur eine Datei an Ort und Stelle umbenannt werden.)
  • Es können keine Kopien einer Datei erstellt werden. (Mit dem Befehl CopyFiles können Dateien nur vom Quelldatenträger in das Zielverzeichnis kopiert werden.)


Bereitstellen von Deinstallationsfunktionen in einem

Referenz

Bereitstellen von Deinstallationsfunktionen in einem ".INF"-Skript

Sie können in Ihren .INF-Dateien eine Deinstallationsfunktion vorsehen, indem Sie einen Install-Abschnitt hinzufügen, durch den zunächst die Dateien, die Einträge in der Registrierung sowie Verknüpfungen entfernt und dann Ihre Komponente zur Liste der Programme hinzugefügt werden, die über das Dialogfeld Software der Systemsteuerung deinstalliert werden können. Ein Beispiel hierfür ist im IEAK-Toolkit im Ordner \<IEAK-Programmordner>\Toolkit\inf\ enthalten.

Um Ihre Komponente zum Dialogfeld Eigenschaften von Software der Systemsteuerung hinzuzufügen, tragen Sie einen neuen Schlüssel mit Werten unter dem folgenden Registrierungsschlüssel ein:

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Anwendungsname,"DisplayName",,"Beschreibung"

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Anwendungsname,"UninstallString",,"Befehlszeile"

Beschreibung
Diese Zeichenfolge wird im Listenfeld des Dialogfelds Eigenschaften von Software angezeigt.

Befehlszeile
Diese Befehlszeile wird ausgeführt, wenn die Komponente im Listenfeld des Dialogfelds Eigenschaften von Software ausgewählt wird. Um einen Abschnitt einer .INF-Datei auszuführen, können Sie den Einstiegspunkt InstallHinfSection (weiter unten erläutert) in Setupx.dll verwenden.

Die folgenden AddReg-Beispieleinträge fügen den Namen "Meine Testanwendung" zum Listenfeld im Dialogfeld Eigenschaften von Software hinzu und führen den Install-Abschnitt Remove_TestApp in Test.inf aus:

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"DisplayName",,"Meine Testanwendung"

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"UninstallString",,"RunDll setupx.dll,InstallHinfSection Remove_TestApp 4 test.inf"

Anmerkungen

  • Das Installationsskript muss die .INF-Datei in den Ordner Windows\Inf kopieren, wenn Ihre Komponente installiert wird. Dies ist das Standardverzeichnis, das durchsucht wird, wenn der Einstiegspunkt InstallHinfSection in Setupx.dll aufgerufen wird.
  • Das Deinstallationsskript sollte den Schlüssel entfernen, den Sie unter dem Registrierungsschlüssel Uninstall erstellt haben, damit Ihr Programm nach der Deinstallation nicht mehr im Listenfeld des Dialogfelds Eigenschaften von Software aufgeführt wird.


Beispiel-".INF"-Datei für den Downloaddienst für Komponenten

;Die unten stehende Beispiel-.INF-Datei führt folgende Funktionen aus:
; - Kopiert Dateien in die Ordner Windows, System, Inf und Hilfe.
; - Erstellt eine Anzahl von Registrierungseinträgen (einschließlich Einträge, die
;   die Namen der kopierten Dateien in lange Dateinamen umwandeln).
; - Erstellt einen Link im Menü Hilfe.
; - Stellt einen Deinstallationsbereich zur Verfügung, der den Deinstallationsvorgang
;   im Dialogfeld Software in der Systemsteuerung registriert.

; - Verwendet ersetzbare Zeichenfolgen zur Vereinfachung der Lokalisierung.

[Version]
Signature=$CHICAGO$

[DestinationDirs]
SampleCopy = 24,%PROGRAMF%\Beispiel
SampleDel = 24,%PROGRAMF%\Beispiel
SampleWinCopy = 25
SampleSysCopy = 11
SampleINFCopy = 17
SampleHLPCopy = 18

[DefaultInstall]
CopyFiles = SampleCopy, SampleWinCopy, SampleSysCopy, SampleINFCopy, SampleHLPCopy
AddReg = SampleRegisterApp, SampleRegUninstall, SampleRenameFiles
UpdateInis = SampleAddLinks

[RemoveSample]
DelFiles = SampleWinCopy, SampleSysCopy, SampleINFCopy, SampleHLPCopy
DelReg = SampleUnRegisterApp, SampleRegUninstall
AddReg = SampleRemoveLFNs
UpdateInis = SampleRemoveLinks

[SampleCopy]
sample.bmp

[SampleWinCopy]
beispiel.exe

[SampleSysCopy]
beispiel.dll

[SampleINFCopy]
beispiel.inf

[SampleHLPCopy]
beispiel.hlp

[SampleRegisterApp]
;Erstellt einen beliebigen Registrierungseintrag (für die private Nutzung von Beispiel.exe):
HKLM,Software\Sample,Installed,,"1"

[SampleUnRegisterApp]
;Löscht den Registrierungseintrag (dadurch wird der gesamte Schlüssel gelöscht):
HKLM,Software\Sample

[SampleRegUninstall]
;Fügt einen Eintrag zur Deinstallation des Programms zum Dialogfeld Software in der Systemsteuerung hinzu:
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"DisplayName",,"Beispielanwendung"
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"UninstallString",,"RunDll setupx.dll,InstallHinfSection RemoveSample 4 beispiel.inf"

[SampleRenameFiles]
;Benennt 8.3-Dateinamen in lange Dateinamen um:
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,,,"%24%\%PROGRAMF%\Beispiel"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,beispiel.bmp,,"Beispeilbitmap.bmp"

[SampleRemoveLFNs]
;Löscht Dateien mit langen Dateinamen während der Deinstallation:
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,,,"%24%\%PROGRAMF%\Beispiel"
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,beispiel.bmp,,"Beispielbitmap.bmp"

[SampleAddLinks]
;Fügt eine Verknüpfung zu Beispiel.exe im Startmenü hinzu:
setup.ini, progman.groups,, "Beispiel=%SampleFolder%" ;erstellt Ordner
setup.ini, Beispiel,, """%SampleDesc%"", %25%\SAMPLE.EXE" ;erstellt Verknüpfung

[SampleRemoveLinks]
;Entfernt Verknüpfung zu Sample.exe im Startmenü während der Deinstallation:
setup.ini, progman.groups,, "Beispiel=%SampleFolder%" ;erstellt Ordner
setup.ini, Beispiel,, """%SampleDesc%""" ;löscht Verknüpfung

[SourceDisksNames]
99 = %DiskName%,Sample,0

[SourceDisksFiles]
beispiel.exe = 1,,13456
beispiel.dll = 1,,20987
beispiel.bmp = 1,,64098
beispiel.hlp = 1,,55441
beispiel.inf = 1,,5687

[Strings]
PROGRAMF = "PROGRA~1"
Beispielordner = "Beispiele"
SampleDesc = "Beispielanwendung"
DiskName = "Beispielanwendung-Installationsdatenträger"


Definition zu Setup-Informationsdateien (".INF")

Eine einfache .INF-Datei enthält die unten aufgeführten Abschnitte (komplexere .INF-Dateien können zusätzliche Abschnitte enthalten). Bei fett formatierten Abschnittsnamen handelt es sich um reservierte Schlüsselwörter. Kursiv formatierte Abschnittsnamen sind beliebige vom Autor der .INF-Datei gewählte Namen:

  • Versionsabschnitt
  • Installationsabschnitte
    • Abschnitte für das Kopieren von Dateien ("CopyFiles")
    • Abschnitte für das Umbenennen von Dateien ("RenFiles")
    • Abschnitte für das Löschen von Dateien ("DelFiles")
    • Abschnitte für das Aktualisieren von ".INI"-Dateien ("UpdateInis")
    • Abschnitte für das Aktualisieren von ".INI"-Feldern ("UpdateIniFields")
    • Abschnitte für das Hinzufügen von Registrierungseinträgen ("AddReg")
    • Abschnitte für das Löschen von Registrierungseinträgen ("DelReg")
    • Abschnitte für das Hinzufügen von ".INI"-Dateien zur Registrierung ("Ini2Reg")
    • Abschnitte für das Aktualisieren von "Config.sys" ("UpdateCfgSys")
    • Abschnitte für das Aktualisieren von "Autoexec.bat" ("UpdateAutoBat")
  • Abschnitt "DestinationDirs"
  • Abschnitt "SourceDisksNames"
  • Abschnitt "SourceDisksFiles"
  • Abschnitt "Strings"
  • Abschnitt "Optional Components"
[Version] | Grundlegende Versionsinformationen zum Überprüfen der .INF-Datei.
[DefaultInstall] | Standardmäßig ausgeführter Installationsabschnitt. Enthält Zeiger auf andere Abschnitte, die Dateien für Kopier- und Löschvorgänge, Aktualisierungen der Registrierung, Aktualisierungen für .INI-Dateien usw. angeben.
[OtherInstall] | Verwendet das gleiche Format wie der Abschnitt [DefaultInstall], muss jedoch explizit aufgerufen werden. Nützlich zur Festlegung der Deinstallationsmethode für eine Komponente.
[DestinationDirs] | Gibt den Bereich auf der Festplatte an, in den die Dateien eines Abschnitts kopiert werden sollen bzw. aus dem sie gelöscht oder für den sie umbenannt werden sollen (z. B. \Windows oder Windows\System).
[FileCopy/Delete/RenameSection(s)] | Listet die Dateien für die Kopier-, Lösch- und Umbenennungsvorgänge auf.
[RegistryUpdateSection(s)] | Gibt Zusätze oder Löschungen für die Registrierung an.
[IniFileUpdateSection(s)] | Gibt Aktualisierungen für .INI-Dateien an. In diesem Abschnitt werden Links eingerichtet.
[SourceDisksNames] | Nennt Datenträger, auf denen die Dateien sich befinden.
[SourceDisksFiles] | Listet den jeweiligen Datenträger auf, auf dem sich die Datei befindet.
[Strings] | Listet die oben verwendeten lokalisierbaren Zeichenfolgen auf.
Zurück zum Anfang der Datei

Versionsabschnitt

[Version]
Signature="$Chicago$"
LayoutFile=Dateiname.inf
Legt die Standardkopfzeile für alle Windows-.INF-Dateien fest. Beachten Sie, dass Windows bei einer anders als "$Chicago$" lautenden Signatur die .INF-Dateien aller von Windows erkannten Geräteklassen nicht als solche akzeptiert.

Bei der Erkennung der Signaturzeichenfolge wird nicht zwischen Groß- und Kleinschreibung unterschieden. Beispielsweise können Sie sowohl "$Chicago$" als auch "$CHICAGO$" schreiben.

Dateiname.inf
Gibt den Namen der .INF-Datei an, welche die zum Installieren dieser Komponente erforderlichen Layoutinformationen (Quelldatenträger und -dateien) enthält. Diese Zeile ist optional. Falls nicht an anderer Stelle angegeben, müssen die Abschnitte SourceDisksNames und SourceDisksFiles in dieser .INF-Datei angegeben werden.

Im Folgenden sehen Sie ein typisches Beispiel für einen Version-Abschnitt:

[Version]
Signature="$CHICAGO$"

Zurück zum Anfang der Datei

Installationsabschnitte

[Installationsabschnittsname]

Copyfiles = Dateilistenabschnitt[,Dateilistenabschnitt]...
Renfiles = Dateilistenabschnitt[,Dateilistenabschnitt]...
Delfiles = Dateilistenabschnitt[,Dateilistenabschnitt]...
UpdateInis = Update-Ini-Abschnitt[,Update-Ini-Abschnitt]...
UpdateIniFields = Update-Inifelder-Abschnitt[,Update-Inifelder-Abschnitt]...
AddReg = Registrierungserweiterungsabschnitt[,Registrierungserweiterungsabschnitt]...
DelReg = Registrierungslöschabschnitt[,Registrierungslöschabschnitt]...
Ini2Reg = Ini-Zu-Registrierung-Abschnitt[,Ini-Zu-Registrierung-Abschnitt]...
UpdateCfgSys = Konfigurierungsaktualisierungsabschnitt
UpdateAutoBat =Autoexec-Aktualisierungsabschnitt

Gibt die zusätzlichen Abschnitte in der .INF-Datei an, die Installationsinformationen für die Komponente enthalten.

Nicht alle in der obigen Syntax angezeigten Elementtypen werden im Abschnitt Install benötigt. Bei Verwendung eines Elementtyps muss dieser den Namen eines Abschnitts in der .INF-Datei angeben. (Ausgenommen hiervon ist das Element CopyFiles, das unter Verwendung des Zeichens "@" zusammen mit einem Dateinamen eine einzelne Datei ohne Angabe eines Abschnittsnamens kopieren kann.) Der Abschnittsname muss aus druckbaren Zeichen bestehen.

Es kann nur jeweils ein Elementtyp in einem Install-Abschnitt verwendet werden. In einem Element kann mehr als ein Abschnittsname aufgeführt werden, allerdings muss jedem zusätzlichen Namen ein Komma vorangestellt werden.

Installationsabschnittsname
Wenn Sie dem Install-Abschnitt den Namen [DefaultInstall] geben, wird er ausgeführt, wenn Sie mit der rechten Maustaste auf die .INF-Datei klicken und dann auf Installieren klicken. Dieser Abschnitt wird außerdem ausgeführt, wenn Sie eine .INF-Datei mit dem Cabpack-Assistenten als Setup-Option auswählen.

Im Folgenden sehen Sie ein typisches Beispiel für einen Install-Abschnitt . Dieser enthält die Elemente Copyfiles und AddReg , welche die Abschnitte angeben, die Informationen über die zu installierenden Dateien enthalten.

[EigeneAnwendung]
Copyfiles=EigeneAnwendungWinDateien, EigeneAnwendungSysDateien, @SRSutil.exe
AddReg=EigeneAnwendungRegEinträge

Wenn Sie in diesem Beispiel den Abschnitt [EigeneAnwendung] in [DefaultInstall] umbenennen, wird der Install-Abschnitt ausgeführt, wenn Sie mit der rechten Maustaste auf die .INF-Datei klicken und dann auf Installieren klicken.

Das Element CopyFiles verfügt über eine besondere Schreibweise, die es ermöglicht, eine einzelne Datei direkt aus der Copy-Zeile zu kopieren. Sie können eine einzelne Datei kopieren, indem Sie dem Dateinamen das Symbol @ voranstellen. Das Zielverzeichnis für Dateien, die mittels dieser Schreibweise kopiert werden, ist DefaultDestDir, wie im Abschnitt DestinationDirs festgelegt. Das folgende Beispiel zeigt, wie einzelne Dateien kopiert werden:

CopyFiles=DateiAbschnitt1,@MeineDatei.txt,@AndereDatei.txt,LetzterAbschnittName

Zurück zum Anfang der Datei

Abschnitte für das Kopieren von Dateien (CopyFiles)

[CopyFiles-section-name]
destination-file-name[, source-file-name][,temporary-file-name][,flag]
[destination-file-name[,source-file-name][, temporary-file-name]][,flag]

Listet die Namen der Dateien auf, die aus einem Quelldatenträger in ein Zielverzeichnis kopiert werden sollen. Der mit den einzelnen Dateien verknüpfte Quelldatenträger und das Zielverzeichnis werden in anderen Abschnitten der .INF-Datei angegeben. Der Dateilistenabschnitt-Name muss im Element CopyFiles in einem Install-Abschnitt angezeigt werden.

Beachten Sie, dass Sie den Kopiervorgang für eine einzelne Datei im Element CopyFiles des Install-Abschnitts selbst angeben können, ohne einen CopyFiles-Abschnitt erstellen zu müssen. Verwenden Sie hierzu das Sonderzeichen "@", um zu erreichen, dass eine einzelne Datei kopiert wird. Ein Beispiel zur Verwendung des Zeichens "@" in einem Element vom Typ CopyFiles finden Sie in den Referenzinformationen zum Installationsabschnitt. Das Kopieren einer einzelnen Datei mit der beschriebenen Methode ist gewissen Einschränkungen unterworfen, da die Namen der Quell- sowie Zieldatei in diesem Fall identisch sein müssen; die Verwendung einer temporären Datei ist nicht möglich.

destination-file-name
Name der Zieldatei. Ist für die Quelldatei kein Name angegeben, ist dies auch der Name der Quelldatei.

source-file-name
Name der Quelldatei. Sind die Namen der Quell- sowie Zieldatei für den Kopiervorgang identisch, braucht der Name der Quelldatei nicht angegeben zu werden.

temporary-file-name
Name einer temporären Datei für den Kopiervorgang. Das Installationsprogramm kopiert die Quelldatei, weist ihr jedoch den Namen der temporären Datei zu. Beim nächsten Start des Betriebssystems benennt das Installationsprogramm die temporäre Datei in den Namen der Zieldatei um. Dies ist sinnvoll, wenn Dateien in ein Ziel kopiert werden, das zu diesem Zeitpunkt geöffnet ist oder von Windows verwendet wird.

flag
Optionaler Parameter, der verwendet wird, um besondere Aktionen während des Installationsvorgangs durchzuführen. Mehrere Flags können verwendet werden, indem aus den Werten ein kombiniertes Flag erstellt wird. Folgende gültige Flags stehen zur Verfügung:

1 | Für CopyFiles: Warnung, wenn Benutzer versucht, Datei zu überspringen.
1 | Für DelFiles: Wenn sich die Datei in Verwendung befindet, reihen Sie verzögerte Löschvorgänge in die Warteschlange in Wininit.ini ein. Andernfalls wird eine Datei, die derzeit verwendet wird, nicht gelöscht.
2 | Wichtig für Setup: Erlauben Sie dem Benutzer nicht, Dateien zu überspringen.
4 | Ignorieren Sie die Versionsprüfung und kopieren Sie die Datei stets. Dadurch wird eine neuere Datei überschrieben.
8 | Erzwingen Sie die Umbenennung. Setup behandelt diese Datei so, als sei sie in Verwendung. Dies geschieht nur, wenn die Datei bereits auf dem Computer des Benutzers vorhanden ist.
16 | Falls die Datei im Zielbereich bereits vorhanden ist, kopieren Sie sie nicht.
32 | Unterdrücken Sie das Dialogfeld Versionskonflikt, und überschreiben Sie keine neueren Dateien.

Mit dem folgenden Beispiel werden drei Dateien kopiert:

[CopyTheseFilesSec]
Datei11 ; kopiert Datei 11
Datei21, Datei22, Datei23 ; kopiert Datei22, vorübergehende Dateinamenänderung in Datei23
Datei31, Datei32 ; kopiert Datei32 in Datei31

Alle in diesem Beispiel verwendeten Quelldateinamen müssen in einem SourceDisksFiles-Abschnitt festgelegt werden, und die Nummern der logischen Datenträger, die im Abschnitt SourceDisksFiles angegeben werden, müssen in einem SourceDisksNames -Abschnitt festgelegt sein. Alternativ können Sie die Datei Layout.inf verwenden, um diese Informationen bereitzustellen.

Zurück zum Anfang der Datei

Abschnitte für das Umbenennen von Dateien (RenFiles)

[rename-files-section-name]
new-file-name, old-file-name
.
.
Listet die Namen der Dateien für die Umbenennung auf. Der Name des Abschnitts muss im Element Renfiles in einem Install-Abschnitt der .INF-Datei angegeben werden.

new-file-name
Neuer Name der Datei.

old-file-name
Alter Name der Datei.

Im folgenden Beispiel wird Datei42 in Datei41, Datei52 in Datei51 und Datei62 in Datei61 umbenannt:

[RenameOldFilesSec]
Datei41, Datei42
Datei51, Datei52
Datei61, Datei62

Alle in diesem Beispiel verwendeten alten Dateinamen (Datei42, Datei52 und Datei62) müssen im Abschnitt SourceDisksFiles festgelegt werden, und die Nummern der logischen Datenträger, die im Abschnitt SourceDisksFiles angezeigt werden, müssen im Abschnitt SourceDisksNames festgelegt werden.

Zurück zum Anfang der Datei

Abschnitte zum Löschen von Dateien (DelFiles)

[ Dateilistenabschnitt]
file-name[,,,flag]
.
.
Im Abschnitt DelFiles werden die Namen der zu löschenden Dateien aufgelistet. Der Dateilistenabschnitt-Name muss im Element Delfiles in einem Install-Abschnitt angezeigt werden.

file-name
Gibt die zu löschende Datei an.

flag
Optionaler Parameter, mit dem Windows veranlasst wird, die in diesem Element genannte Datei zu löschen, wenn diese während des Installationsvorgangs verwendet wird. Um Windows anzuweisen, den Datei-Löschvorgang bis zum Neustart des Computers aufzuschieben, setzen Sie den Wert für den Parameter flag auf 1. Falls eine mit der Parametereinstellung flag=1 gekennzeichnete Datei nicht gelöscht werden kann, da sie gerade in Verwendung ist, wird ein Neustart des Systems durchgeführt, nachdem die Geräteinstallation abgeschlossen wurde.

Wenn Sie zusammen mit einem file-name-Parameter nicht den Parameterwert flag=1 verwenden, wird die Datei nicht aus dem Computer gelöscht, falls sie während der Ausführung des DelFiles-Abschnitts in Verwendung ist.

Mit dem folgenden Beispiel werden drei Dateien gelöscht:

[DeleteOldFilesSec]
Datei1
Datei2
Datei3

Zurück zum Anfang der Datei

Abschnitte für das Aktualisieren von ".INI"-Dateien (UpdateInis)

[ Update-Ini-Abschnitt-name]
ini-file, ini-section, [old-ini-entry], [new-ini-entry], [flags]
.

.
Ersetzt, löscht oder fügt vollständige Einträge zur angegebenen .INI-Datei hinzu Der Abschnittsname, Update-Ini-Abschnittsname, muss im Element UpdateInis in einem Install-Abschnitt der .INF-Datei angezeigt werden.

ini-file
Name der .INI-Datei, die den zu ändernden Eintrag enthält. Weitere Informationen zur Angabe des .INI-Dateinamens finden Sie in den Anmerkungen weiter unten.

ini-section
Name des Abschnitts, der den zu ändernden Eintrag enthält.

old-ini-entry
Optional. Normalerweise im Format Key=Value.

new-ini-entry
Optional. Normalerweise im Format Key=Value. Entweder der Schlüssel oder der Wert können ersetzbare Zeichenfolgen angeben. %Zeichenfolge1% kann beispielsweise entweder der im Parameter new-ini-entry angegebene Schlüssel oder der dort angegebene Wert sein; wobei die %Zeichenfolge1% ersetzende Zeichenfolge im Abschnitt Strings der .INF-Datei festgelegt ist.

flags
Optionale Aktionsflags. Folgende Werte sind möglich:

0 Standardwert. Ist der Schlüssel old-ini-entry in einem Eintrag in der .INI-Datei vorhanden, so wird dieser Eintrag durch new-ini-entry ersetzt. Beachten Sie, dass lediglich die Schlüssel des Parameters old-ini-entry und des Eintrags in der .INF-Datei übereinstimmen müssen; die Werte der Einträge werden ignoriert.

Um new-ini-entry ohne Bedingung zur .INI-Datei hinzuzufügen, setzen Sie old-ini-entry auf NULL. Um old-ini-entry ohne Bedingung aus der .INI-Datei zu löschen, setzen Sie new-ini-entry auf NULL.

1 | Sind sowohl Schlüssel als auch Wert von old-ini-entry in einem Eintrag in der .INI-Datei vorhanden, so wird dieser Eintrag durch new-ini-entry ersetzt. Beachten Sie, dass der Parameter old-ini-entry und der Eintrag in der .INF-Datei in Bezug auf Schlüssel wie auch auf Wert übereinstimmen müssen, damit der Eintrag ersetzt werden kann. Im Gegensatz dazu steht die Verwendung eines Aktionsflag-Werts von 0, wobei lediglich die Schlüssel übereinstimmen müssen, damit die Ersetzung stattfinden kann.
2 Ist der Schlüssel im Parameter old-ini-entry in der .INI-Datei nicht vorhanden, wird kein Vorgang für die .INI-Datei durchgeführt.

Sind der Schlüssel im Parameter old-ini-entry sowie der Schlüssel im Parameter new-ini-entry jeweils in einem Eintrag in der .INI-Datei vorhanden, so wird der Eintrag in der .INI-Datei, der mit dem Schlüssel im Parameter new-ini-entry übereinstimmt, gelöscht, und der Eintrag in der .INI-Datei, der mit dem Parameter old-ini-entry übereinstimmt, wie folgt behandelt: der Schlüssel des Eintrags in der .INI-Datei wird durch den Schlüssel im Parameter new-ini-entry ersetzt.

Ist der Schlüssel im Parameter old-ini-entry in einem Eintrag in der .INI-Datei vorhanden, der Schlüssel im Parameter new-ini-entry hingegen nicht , so wird ein Eintrag zur .INI-Datei hinzugefügt, der sich aus dem Schlüssel im Parameter new-ini-entry und dem alten Wert zusammensetzt.

Beachten Sie, dass die Übereinstimmung des Parameters old-ini-entry und des Eintrags in der .INI-Datei nur in Bezug auf den Schlüssel gegeben ist, nicht auf Schlüssel und Wert.

3 | Ebenso, wie der Wert 2 für den Parameter Flag (siehe oben) eine Ausnahme darstellt, ist auch die Übereinstimmung des Parameters old-ini-entry mit einem Eintrag in der .INF-Datei in Bezug Schlüssel und auf Wert ein Sonderfall.
Beim Angeben von Schlüssel und Wert kann ein Sternchen (*) als Platzhalterzeichen verwendet werden. Es wird richtig interpretiert.

Der ini-file-Name kann eine Zeichenfolge oder ein Zeichenfolgeschlüssel sein. Ein Zeichenfolgeschlüssel besitzt das Format %strkey%, wobei strkey im Abschnitt Strings in der .INF-Datei festgelegt ist. In beiden Fällen muss der Name ein gültiger Dateiname sein.

Der Name sollte den Namen des Ordners enthalten, in dem sich die Datei befindet; jedoch sollte der Ordnername als LDID (Logical Directory Identifier) angegeben werden, nicht mit seinem tatsächlichen Namen. Während der Installation ersetzt das Installationsprogramm eine LDID durch einen tatsächlichen Namen.

Eine LDID besitzt das Format %ldid%, wobei ldid zu den vordefinierten Bezeichnern zählt oder ein im Abschnitt DestinationDirs festgelegter Bezeichner ist. Beachten Sie, dass der umgekehrte Schrägstrich bei der Ersetzung der Konstanten LDID_BOOT und LDID_BOOTHOST in den Pfad eingefügt wird. Beispielsweise 0kann LDID_BOOT durch C:\ ersetzt werden. Allerdings können Sie wählen, ob Sie den umgekehrten Schrägstrich in Ihrer .INF-Datei verwenden oder nicht. So kann entweder "%30%boot.ini" oder "%30%\boot.ini" als Verweis auf BOOT..ini im Stammverzeichnis des Boot-Laufwerks verwendet werden.

Die folgenden Beispiele stellen einzelne Elemente im Abschnitt einer .INF-Datei für das Aktualisieren von .INI-Dateien dar:

%11%\sample.ini, Section1,, Value1=2 ; fügt neuen Eintrag hinzu
%11%\sample.ini, Section2, Value3=*, ; löscht alten Eintrag
%11%\sample.ini, Section4, Value5=1, Value5=4 ; ersetzt alten Eintrag

Die Elemente der folgenden Gruppe im Abschnitt einer .INF-Datei zum Aktualisieren von .INI-Dateien arbeiten zusammen, um einen Vorgang auf den Boot-Abschnitt von SYSTEM.ini durchzuführen. Unter Verwendung der Bedingungen, die in den Parameter flags der .INF-Dateielemente integriert sind, wird der Eintrag "comm.drv=comm.drv" zum Abschnitt Boot hinzugefügt, es sei denn, die Einträge "comm.drv=*vcoscomm.drv" oder "comm.drv=*r0dmdcom.drv" sind im Boot-Abschnitt bereits vorhanden. In diesem Fall wird der vorhandene Eintrag beibehalten, und der Eintrag "comm.drv=comm.drv" wird nicht zur .INI-Datei hinzugefügt. Anderes ausgedrückt: Nachdem die vier unten angezeigten Einträge in der .INF-Datei ausgeführt wurden, ist ein Eintrag vom Typ "comm.drv=" im Boot-Abschnitt der .INI-Datei vorhanden: "comm.drv=*vcoscomm.drv" oder "comm.drv=*r0dmdcom.drv" oder "comm.drv=comm.drv."

system.ini, boot, "comm.drv=*vcoscomm.drv","~CommDrvTemp~=*", 3
system.ini, boot, "comm.drv=*r0dmdcom.drv","~CommDrvTemp~=*", 3
system.ini, boot,,"comm.drv=comm.drv"
system.ini, boot, "~CommDrvTemp~=*","comm.drv=*", 3

Zurück zum Anfang der Datei

Abschnitte für das Aktualisieren von ".INI"-Feldern (UpdateIniFields)

[ Update-Inifelder-Abschnitt-Name ]
ini-file, ini-section, profile-name, [old-field], [new-field],[flags]
.
.
Ersetzt, löscht und fügt Felder zum Wert eines bestimmten .INI-Eintrags hinzu. Im Gegensatz zum Abschnitt für das Aktualisieren von .INI-Dateien ersetzt, löscht oder fügt dieser Abschnittstyp Komponenten eines Werts, nicht den vollständigen Wert, zu einem Eintrag in einer .INI-Datei hinzu. Der Abschnittsname, Update-Inifelder-Abschnitt-Name, muss im Element UpdateIniFields in einem Install-Abschnitt der .INI-Datei angezeigt werden.

ini-file
Name der .INI-Datei, die den zu ändernden Eintrag enthält. Weitere Informationen zur Angabe des .INI-Dateinamens finden Sie unter dem Thema, das Erläuterungen zum Abschnittstyp für das Aktualisieren von .INI-Dateien enthält.

ini-section
Name des Abschnitts der .INI-Datei, der den zu ändernden Eintrag enthält.

profile-name
Name des zu ändernden Eintrags.

old-field
Zu löschender Feldwert.

new-field
Feldwert, der hinzugefügt werden soll, falls nicht bereits vorhanden.

flags
Gibt an, ob die Parameter old-field und new-field so behandelt werden, als ob sie ein Platzhalterzeichen verwenden, und/oder welches Trennzeichen beim Anfügen eines neuen Felds an einen Eintrag in der .INI-Datei verwendet werden soll. Folgende Werte sind möglich:

Wert | Bedeutung
0 | (Standardwert) Das Zeichen "*" wird bei der Suche nach übereinstimmenden Feldern als solches aufgefasst, und nicht als Platzhalterzeichen. Beim Hinzufügen eines neuen Feldes zu einem Eintrag wird ein Leerzeichen (" ") als Trennzeichen verwendet.
1 | Das Zeichen "*" wird bei der Suche nach übereinstimmenden Feldern als Platzhalterzeichen aufgefasst. Beim Hinzufügen eines neuen Feldes zu einem Eintrag wird ein Leerzeichen (" ") als Trennzeichen verwendet.
2 | Das Zeichen "*" wird bei der Suche nach übereinstimmenden Feldern als solches aufgefasst, und nicht als Platzhalterzeichen. Beim Hinzufügen eines neuen Feldes zu einem Eintrag wird ein Komma (",") als Trennzeichen verwendet.
3 | Das Zeichen "*" wird bei der Suche nach übereinstimmenden Feldern als Platzhalterzeichen aufgefasst. Beim Hinzufügen eines neuen Feldes zu einem Eintrag wird ein Komma (",") als Trennzeichen verwendet.
Alle Kommentare in der Zeile der .INI-Datei werden entfernt, da sie nach den Änderungen möglicherweise nicht mehr zutreffend sind. Bei der Verarbeitung von Feldern in dieser Zeile der .INI-Datei werden Leerzeichen, Tabulatoren und Kommas als Feldtrennzeichen verwendet. Wenn jedoch das neue Feld an die Zeile angefügt wird, wird ein Leerzeichen als Trennzeichen verwendet.
Zurück zum Anfang der Datei

Abschnitte für das Hinzufügen von Registrierungseinträgen (AddReg)

[ Registrierungserweiterungsabschnitt]
reg-root-string, [subkey], [value-name], [flag], [value]
[reg-root-string, [subkey], [value-name], [flag], [value]]
.
.
Fügt Teilschlüssel oder Wertenamen zur Registrierung hinzu, wobei der Wert optional gesetzt wird. Der Registrierungserweiterungsabschnitt-Name muss in einem Element vom Typ AddReg in einem Install-Abschnitt angezeigt werden.

reg-root-string
Name der Registrierungsbasis. Folgende Werte sind möglich:

HKCR entspricht HKEY_CLASSES_ROOT
HKCU entspricht HKEY_CURRENT_USER
HKLM entspricht HKEY_LOCAL_MACHINE
HKU entspricht HKEY_USERS.
HKR bedeutet relativ zum Schlüssel, der in GenInstallEx übergeben wird

subkey
Optional. Gibt den Teilschlüssel an, der festgelegt werden soll. Besitzt das Format Schlüssel1\Schlüssel2\Schlüssel3.... Dieser Parameter kann als ersetzbare Zeichenfolge ausgedrückt werden. So könnten Sie beispielsweise %Subkey1% verwenden, wobei die %Subkey1% ersetzende Zeichenfolge im Abschnitt Strings der .INF-Datei festgelegt ist.

value-name
Optional. Gibt den Wertenamen für subkey an. Was den Zeichenfolgetyp angeht, so wird der Wert des im Parameter subkey angegebenen Teilschlüssels auf eine Nullzeichenfolge gesetzt, falls für den Parameter value-name kein Wert festgelegt wird. Beachten Sie, dass der Parameter value-name als ersetzbare Zeichenfolge ausgedrückt werden kann. So könnten Sie beispielsweise %Valname1% verwenden, wobei die %Valname1% ersetzende Zeichenfolge im Abschnitt Strings der .INF-Datei festgelegt ist.

flag
Optional. Legt den Wertetyp fest und gibt an, ob der Registrierungsschlüssel ersetzt wird, falls er bereits vorhanden ist.

Wert | Bedeutung
0 | (Standard) Wert ist eine ANSI-Zeichenfolge. Schlüssel wird ersetzt, falls bereits vorhanden.
1 | Wert ist eine hexadezimale Zahl. Schlüssel wird ersetzt, falls bereits vorhanden.
2 | Wert ist eine ANSI-Zeichenfolge. Schlüssel wird nicht ersetzt, falls bereits vorhanden.
3 | Wert ist eine hexadezimale Zahl. Schlüssel wird nicht ersetzt, falls bereits vorhanden.
value
Optional. Zu setzender Wert. Kann entweder eine ANSI-Zeichenfolge oder eine Zahl in hexadezimaler Schreibweise und INTEL-Format sein. Jedes Element mit einem Binärwert kann über die 128-Byte-Grenze hinaus erweitert werden, indem ein umgekehrter Schrägstrich (\) gesetzt wird. Darüber hinaus kann ein Zeichenfolgeschlüssel mit dem Format %strkey% angegeben werden. strkey muss im Abschnitt Strings der .INF-Datei festgelegt sein. Verwenden Sie %%, wenn Sie ein %-Zeichen in die Zeile eintragen möchten.

Es sind mindestens zwei Felder erforderlich; eines enthält möglicherweise keinen Wert. Aus diesem Grund muss mindestens ein Komma gesetzt werden, wenn Sie dieses Format verwenden.

Die zwei Elemente im folgenden AddReg-Beispielabschnitt fügen zwei Wertenamen zur Registrierung hinzu. Beachten Sie, dass %25% zum Ordner Windows des Computers erweitert wird.

[MyAppRegEntries]
HKLM,Software\MyApp,ProgramName,,"Meine Anwendung"
HKLM,Software\MyApp,"Programmverzeichnis",,"%25%\MyApp.exe"

Zurück zum Anfang der Datei

Abschnitte für das Löschen von Registrierungseinträgen (DelFiles)

[ Registrierungslöschabschnitt]
reg-root-string, subkey, [value-name]
[reg-root-string, subkey, [value-name]]
.
.
Löscht einen Teilschlüssel oder Wertenamen aus der Registrierung. Der Registrierungslöschabschnitt-Name muss im Element DelReg in einem Install-Abschnitt angezeigt werden.

reg-root-string
Name der Registrierungsbasis. Folgende Werte sind möglich:

HKCR entspricht HKEY_CLASSES_ROOT
HKCU entspricht HKEY_CURRENT_USER
HKLM entspricht HKEY_LOCAL_MACHINE
HKU entspricht HKEY_USERS.
HKR bedeutet relativ zum Schlüssel, der in GenInstallEx übergeben wird

subkey
Gibt den zu löschenden Teilschlüssel an. Besitzt das Format Schlüssel1\Schlüssel2\Schlüssel3... Dieser Parameter kann als ersetzbare Zeichenfolge ausgedrückt werden. So können Sie beispielsweise %Subkey1% verwenden, wobei die %Subkey1% ersetzende Zeichenfolge im Abschnitt Strings der .INF-Datei festgelegt ist.

value-name
Optional. Gibt den Wertenamen für subkey an. Beachten Sie, dass der Parameter value-name als ersetzbare Zeichenfolge ausgedrückt werden kann. So könnten Sie beispielsweise %Valname1% verwenden, wobei die %Valname1% ersetzende Zeichenfolge im Abschnitt Strings der .INF-Datei festgelegt ist.

Dieser Abschnittstyp kann eine beliebige Anzahl von Elementen enthalten. Jedes Element löscht einen Teilschlüssel oder Wertenamen aus der Registrierung.

Abschnitte für das Hinzufügen von ".INI"-Dateien zur Registrierung (Ini2Reg)

[ Ini-Zu-Registrierung-Abschnitt]
ini-file, ini-section, [ini-key], reg-root-string, subkey[,flags]
.
.
Verschiebt Zeilen oder Abschnitte aus einer .INI-Datei in die Registrierung, wobei ein Registrierungseintrag unter dem angegebenen Schlüssel in der Registrierung erstellt oder ersetzt wird. Der Abschnittsname Ini-Zu-Registrierung-Abschnitt muss im Element Ini2Reg in einem Install-Abschnitt der .INF-Datei angezeigt werden.

ini-file
Name der .INI-Datei, die den zu kopierenden Schlüssel enthält. Weitere Informationen zur Angabe des .INI-Dateinamens finden Sie in den Kommentaren der Referenzinformationen zum Abschnittstyp für das Aktualisieren von .INI-Dateien.

ini-section
Name des Abschnitts in der .INI-Datei, der den zu kopierenden Schlüssel enthält.

ini-key
Name des Schlüssels in der .INI-Datei, der in die Registrierung kopiert werden soll. Falls für ini-key kein Wert angegeben ist, wird der gesamte Abschnitt in den angegebenen Registrierungsschlüssel kopiert.

reg-root-string
Name der Registrierungsbasis. Folgende Werte sind möglich:

HKCR entspricht HKEY_CLASSES_ROOT
HKCU entspricht HKEY_CURRENT_USER
HKLM entspricht HKEY_LOCAL_MACHINE
HKU entspricht HKEY_USERS.
HKR bedeutet relativ zum Schlüssel, der in GenInstallEx übergeben wird

subkey
Gibt den Teilschlüssel an, in den der Wert gespeichert werden soll. Besitzt das Format Schlüssel1\Schlüssel2\Schlüssel3...

flags
Gibt an, ob der .INI-Schlüssel nach der Übertragung in die Registrierung gespeichert wird, und ob der Wert in der Registrierung überschrieben wird, falls der Registrierungsschlüssel bereits vorhanden ist. Folgende Werte sind möglich:

Wert | Bedeutung
0 | (Standardwert) Der .INI-Eintrag wird nicht aus der .INI-Datei gelöscht, nachdem die Informationen des Eintrags in die Registrierung verschoben wurden. Ist der Teilschlüssel in der Registrierung bereits vorhanden, wird der aktuelle Wert nicht ersetzt.
1 | Der .INI-Eintrag wird aus der .INI-Datei gelöscht, nachdem die Informationen des Eintrags in die Registrierung verschoben wurden. Ist der Teilschlüssel in der Registrierung bereits vorhanden, wird der aktuelle Wert nicht ersetzt.
2 | Der .INI-Eintrag wird nicht aus der .INI-Datei gelöscht, nachdem die Informationen des Eintrags in die Registrierung verschoben wurden. Ist der Teilschlüssel in der Registrierung bereits vorhanden, wird der aktuelle Wert durch den Wert aus dem .INI-Dateieintrag ersetzt.
3 | Der .INI-Eintrag wird aus der .INI-Datei gelöscht, nachdem die Informationen des Eintrags in die Registrierung verschoben wurden. Ist der Teilschlüssel in der Registrierung bereits vorhanden, wird der aktuelle Wert durch den Wert aus dem .INI-Dateieintrag ersetzt.
Angenommen, die Datei Win.ini weist folgenden Eintrag auf:

[Windows]
CursorBlinkRate=15

Existiert unter Systemsteuerung/Desktop kein Teilschlüssel CursorBlinkRate, so erstellt das folgende Element in einem Ini File to Registry-Abschnitt den Teilschlüssel, setzt den Wert des Teilschlüssels auf 15 und lässt die ursprüngliche Zeile in WIN.ini unverändert:

win.ini,Windows,CursorBlinkRate,HKCU,"Systemsteuerung\Desktop"

Ist der Teilschlüssel bereits vorhanden, setzt das .INF-Dateielement den Wert des Teilschlüssels auf 15 und lässt die ursprüngliche Zeile in WIN.ini unverändert.

Abschnitte für das Aktualisieren von Config.sys (UpdateCfgSys)

[ Konfigurierungsaktualisierungsabschnitt]
Buffers=legal-dos-buffer-value
DelKey=key
DevAddDev=driver-name,configkeyword[,flag][,param-string]
DevDelete=device-driver-name
DevRename=current-dev-name,new-dev-name
Files=legal-dos-files-value
PrefixPath=ldid[,ldid]
RemKey=key
Stacks=dos-stacks-values

Stellt Befehle zum Hinzufügen, Löschen oder Umbenennen von Befehlen in der Datei Config.sys bereit. Der Abschnittsname, Konfigurierungsaktualisierungsabschnitt-Name, muss im Element UpdateConfigSys in einem Install-Abschnitt der .INF-Datei angezeigt werden.

Es werden nicht alle in der obigen Syntax angezeigten Elementtypen benötigt. Ein Abschnitt für das Aktualisieren von Config.sys kann je nach Bedarf beliebig viele DevRename, DevDelete, DevAddDev, DelKey und RemKey-Elemente enthalten; jedoch können die Elemente Buffers, Files und Stacks nur jeweils einmal in einem Abschnitt verwendet werden. Beim Verarbeiten eines Abschnitts für das Aktualisieren von Config.sys behandelt das Installationsprogramm zunächst alle DevRenames-Elemente, dann alle DevDelete-Elemente und zuletzt die DevAddDev-Elemente. Syntax und Bedeutung der einzelnen Elementtypen, die in einem Abschnitt für das Aktualisieren von Config.sys verwendet werden können, finden Sie weiter unten in diesem Thema.

Buffers-Element

Buffers=legal-dos-buffer-value
Legt die Anzahl der Dateipuffer fest. Wie beim Element Stacks vergleicht das Installationsprogramm auch bei diesem Element den vorhandenen Wert mit dem vorgeschlagenem Wert und stellt die Dateipuffer stets auf den größeren der beiden Werte ein.

legal-dos-buffers-value
Ein gültiger Wert für MS-DOS-Puffer.

DelKey-Element

DelKey=key
Bewirkt, dass der Config.sys-Befehl mit dem angegebenen Schlüssel in der Datei Config.sys auskommentiert wird. Beispielsweise würde das Element

DelKey=Break

der .INF-Datei bewirken, dass der Befehl Break=on in der Datei Config.sys auskommentiert wird.

Das Element DelKey wirkt sich in der gleichen Weise wie das Element RemKey aus. In einem Abschnitt der .INF-Datei können mehrere DelKey und/oder RemKey -Elemente vorhanden sein.

key
Der Schlüssel des Config.sys-Befehls, der auskommentiert werden soll.

DevAddDev-Element

DevAddDev=driver-name,configkeyword[,flag][,param-string]
Fügt einen Geräte oder Installations-Befehl zur Datei Config.sys hinzu.

driver-name
Name des Treibers oder der ausführbaren Datei, der bzw. die hinzugefügt werden soll. Das Installationsprogramm überprüft die Dateinamenerweiterung, um sicherzustellen, dass diese .SYS oder .EXE lautet.

configkeyword
Befehlsname. Kann Geräte- oder Installationsbefehl sein.

flag
Optionales Flag für die Positionierung. Falls 0, wird der Befehl unten in der Datei angeordnet. Falls 1, wird der Befehl oben angeordnet. Ist kein Flag gesetzt, wird standardmäßig 0 verwendet.

param-string
Optionale Befehlsparameter. Müssen für den angegebenen Gerätetreiber oder die ausführbare Datei gültig sein.

DevDelete-Element

DevDelete=device-driver-name
Löscht alle Zeilen, die den angegebenen Dateinamen aus der Datei Config.sys enthalten.

device-driver-name
Name eines Datei- oder Gerätetreibers. Das Installationsprogramm durchsucht die Datei Config.sys nach dem Namen und löscht alle Dateien, in denen dieser enthalten ist. Da MS-DOS in Config.sys keine impliziten Dateinamenerweiterungen erlaubt, muss jeder device-driver-name die Dateinamenerweiterung explizit angeben.

Im folgenden Beispiel löscht das Element DevDelete in einem Abschnitt zum Aktualisieren von Config.sys die Zeilen 1 und 3, nicht jedoch Zeile 2, der Config.sys-Beispieldatei:

DevDelete=Dateiname.sys

;; Zeilen in Config.sys
Device=Foo.sys ;; Zeile #1
Install=foo.exe ;; Zeile #2
Device=Foo.sys /d:b800 /I:3 ;; Zeile #3

DevRename-Element

DevRename=current-dev-name,new-dev-name
Benennt einen Gerätetreiber in der Datei Config.sys um.

device-driver-name
Name des Gerätetreibers oder der ausführbaren Datei, der bzw. die umbenannt werden soll. Das Installationsprogramm sucht den Namen auf der rechten Seite eines Geräte- oder Installations-Befehls in der Datei Config.sys.

new-dev-name
Neuer Name für Treiber oder ausführbare Datei.

Files-Element

Files=legal-dos-files-value
Legt die maximale Anzahl von geöffneten Dateien in der Datei Config.sys fest. Wie beim Element Stacks vergleicht das Installationsprogramm auch bei diesem Element den vorhandenen Wert mit dem vorgeschlagenen Wert und stellt die maximale Anzahl von geöffneten Dateien stets auf den größeren der beiden Werte ein.

legal-dos-files-value
Ein gültiger Wert für MS-DOS-Dateien.

PrefixPath-Element

PrefixPath=ldid[,ldid]...
Hängt den mit der angegebenen LDID verknüpften Pfad an den Pfadbefehl an.

ldid
Kann einen der vordefinierten LDID-Werte oder einen neuen in der .INF-Datei festgelegten Wert annehmen. Eine Definition aller vordefinierten LDID-Werte finden Sie in den Referenzinformationen zum Abschnitt DestinationDirs.

RemKey-Element

RemKey=key
Bewirkt, dass der Config.sys-Befehl mit dem angegebenen Schlüssel in der Datei Config.sys auskommentiert wird. Beispielsweise würde das Element

RemKey=Break

bewirken, dass der Befehl Break=on in der Datei Config.sys auskommentiert wird.

Das Element RemKey wirkt sich in der gleichen Weise wie das Element DelKey aus. In einem Abschnitt der .INF-Datei können mehrere RemKeyund/oder DelKey-Elemente vorhanden sein.

key
Der Schlüssel des Config.sys-Befehls, der auskommentiert werden soll.

Stacks-Element

Stacks=dos-stacks-values
Legt die Anzahl und Größe von Stapeln in der Datei Config.sys fest. Das Installationsprogramm vergleicht den vorhandenen Wert mit dem vorgeschlagenen Wert und stellt die Stapel stets auf den größeren der beiden Werte ein. Enthält Config.sys beispielsweise stacks=9.218, und eine .INF-Datei enthält stacks=5.256, dann stellt das Installationsprogramm den neuen Wert auf stacks=9.256 ein.

legal-dos-stacks-value
Ein gültiger Wert für MS-DOS-Stacks.

Zurück zum Anfang der Datei

Abschnitte für das Aktualisieren von Autoexec.bat (UpdateAutoBat)

[ Autoexec-Aktualisierungsabschnitt]
CmdAdd=command-name[,command-parameters]
CmdDelete=command-name
PrefixPath=ldid[,ldid]
RemOldPath=ldid[,ldid]
TmpDir=ldid[,subdir]
UnSet=env-var-name

Stellt Befehle zum Bearbeiten von Zeilen in der Datei Autoexec.bat zur Verfügung. Der Abschnittsname, Autoexec-Aktualisierungsabschnitt-Name, muss im Element UpdateAutoBat in einem Install-Abschnitt der .INF-Datei angezeigt werden.

Nicht alle in der obigen Syntax angezeigten Elementtypen werden im einem Abschnitt zum Aktualisieren von Autoexec.bat benötigt. Der Abschnitt kann je nach Bedarf beliebig viele CmdAdd, CmdDelete und UnSet-Elemente enthalten; jedoch kann nur jeweils ein PrefixPath, RemOldPath und TmpDir-Element in einer .INF-Datei verwendet werden. Die Syntax und Bedeutung der einzelnen Elementtypen wird weiter unten in diesem Thema erläutert.

Das Installationsprogramm verarbeitet die CmdDelete-Elemente vor den CmdAdd-Elementen.

CmdAdd -Element

CmdAdd =command-name[,"command-parameters"]
Fügt die angegebenen und optionalen Befehlsparameter am Ende der Datei Autoexec.bat hinzu.

command-name
Name einer ausführbaren Datei, mit oder ohne Erweiterung. Ist der Dateiname ebenfalls in den Abschnitten SourceDisksFiles und DestinationDirs der .INF-Datei festgelegt, so fügt das Installationsprogramm den entsprechenden Pfad zum Dateinamen hinzu, bevor dieser in die Datei Autoexec.bat geschrieben wird.

command-parameters
Ein in doppelte Anführungsstriche gesetzte Zeichenfolge oder eine ersetzbare Zeichenfolge, wie z. B. %String1% oder %Myparam%, wobei die %String1% und %Myparam% ersetzenden Zeichenfolgen im Abschnitt Strings der .INF-Datei festgelegt sind. Das Installationsprogramm hängt die Zeichenfolge an command-name an, bevor die Zeile an das Ende der Datei Autoexec.bat angefügt wird. Das Format dieser Zeile ist von den Befehlszeilenanforderungen für die angegebene ausführbare Datei abhängig.

CmdDelete-Element

CmdDelete=command-name
Löscht alle Zeilen aus Autoexec.bat, die den angegebenen Befehlsnamen enthalten. Das Installationsprogramm sucht nach allen Vorkommen des angegebenen Namens mit der Dateinamenerweiterung .EXE, .COM und .BAT und löscht diese.

command-name
Name einer ausführbaren Datei ohne Erweiterung.

PrefixPath-Element

PrefixPath=ldid[,ldid]...
Hängt den mit der angegebenen LDID verknüpften Pfad an den Pfadbefehl an.

ldid
Kann einen der vordefinierten LDID-Werte oder einen neuen in der .INF-Datei festgelegten Wert annehmen. Eine Definition aller vordefinierten LDID-Werte finden Sie in den Referenzinformationen zum Abschnitt DestinationDirs.

RemOldPath-Element

RemOldPath=ldid[,ldid]
Entfernt den mit der angegebenen LDID verknüpften Pfad aus dem Pfadbefehl. Installiert der Benutzer beispielsweise die neue Version von Windows in C:\Newwin und behält eine alte Kopie in C:\Windows bei, entfernt das folgende Element der .INF-Datei C:\Windows aus der Pfad-Umgebungsvariablen:

RemOldPath=10

ldid
Kann einen der vordefinierten LDID-Werte oder einen neuen in der .INF-Datei festgelegten Wert einnehmen. Eine Definition aller vordefinierten LDID-Werte finden Sie in den Referenzinformationen zum Abschnitt DestinationDirs.

TmpDir-Element

TmpDir=ldid[,subdir]
Erstellt innerhalb des durch die LDID angegebenen Ordners einen temporären Ordner, falls nicht bereits vorhanden.

ldid
Kann einen der vordefinierten LDID-Werte oder einen neuen in der .INF-Datei festgelegten Wert annehmen. Eine Definition aller vordefinierten LDID-Werte finden Sie in den Referenzinformationen zum Abschnitt DestinationDirs.

subdir
Ein Pfadname. Falls ldid\subdir nicht bereits vorhanden ist, wird dieser Pfad erstellt.

UnSet-Element

UnSet=env-var-name
Entfernt alle Set-Befehle aus der Datei Autoexec.bat, die den Namen der angegebenen Umgebungsvariablen enthalten.

env-var-name
Name einer Umgebungsvariablen.

Zurück zum Anfang der Datei

DestinationDirs-Abschnitt

[DestinationDirs]
Dateilistenabschnitt =ldid[, subdir ]
.
.
[DefaultDestDir=ldid[, subdir ]]

Der Abschnitt DestinationDirs festgelegt die Zielverzeichnisse für die in file-list sections angegebenen Vorgänge. Dabei handelt es sich entweder um die Abschnitte CopyFiles, RenFiles oder DelFiles. Optional kann für die Abschnitte CopyFiles, RenFiles und DelFiles in der .INF-Datei, die im Abschnitt DestinationDirs nicht explizit genannt werden, ein Standard-Zielordner angegeben werden.

Dateilistenabschnitt
Name eines CopyFiles, RenFiles oder DelFiles-Abschnitts. Eines der folgenden Elemente in einem Install-Abschnitt muss einen Verweis auf diesen Namen enthalten: Copyfiles, RenFiles oder DelFiles.

ldid
Eine LDID (Logical Disk Identifier). Folgende Werte sind möglich:

00 | LDID ohne Wert - dient zum Erstellen einer neuen LDID
01 | Quelllaufwerk:\Pfadname
10 | Ordner Machine (entspricht dem Ordner Windows in einer serverbasierten Installation).
11 | Ordner System
12 | Ordner IOSubsys
13 | Ordner Command
17 | Ordner Inf
18 | Ordner Help
20 | Schriftarten
21 | Anzeigeprogramme
22 | VMM32
23 | Ordner Color
24 | Basis des Laufwerks, auf dem sich der Ordner Windows befindet.
25 | Ordner Windows
26 | Reserviertes Boot-Gerät für Windows (Winboot)
28 | Host Winboot
30 | Basisordner des Boot-Laufwerks
31 | Basisordner für Hostlaufwerk eines virtuellen Boot-Laufwerks
subdir
Name des Ordners in dem durch LDID benannten Ordner, der als Zielordner verwendet werden soll.

Das optionale Element DefaultDestDir stellt ein Standard-Zielverzeichnis für alle CopyFiles-Elemente bereit, welche die Schreibweise zum direkten Kopieren (@Dateiname) verwenden, bzw. für alle im Abschnitt DestinationDirs nicht angegebenen CopyFiles, RenFiles und DelFiles-Abschnitte. Wird im Abschnitt DestinationDirs kein DefaultDestDir-Element verwendet, so wird LDID_WIN als Standardordner festgelegt.

Im folgenden Beispiel wird als Zielordner für den Abschnitt MoveMiniPort Windows\Iosybsys und als Standardordner für die weiteren Abschnitte der Ordner Bin auf dem Boot-Laufwerk festgelegt:

[DestinationDirs]
MoveMiniPort=12 ; Ziel für den Abschnitt MoveMiniPort ist
; windows\iosubsys
DefaultDestDirs=30,bin ; Direkte Kopien werden gespeichert in boot:\bin

Zurück zum Anfang der Datei

SourceDisksNames-Abschnitt

[SourceDisksNames]
disk-ordinal="disk-description",disk-label,disk-serial-number
.
.
Kennzeichnet und benennt den/die Datenträger, welche die Quelldateien für Dateikopiervorgänge und Umbenennungen enthalten.

disk-ordinal
Eine eindeutige Nummer zur Kennzeichnung eines Quelldatenträgers. Sind mehrere Quelldatenträger vorhanden, muss jeder Datenträger durch eine eindeutige Ordnungszahl gekennzeichnet sein.

disk-description
Eine Zeichenfolge oder ein Zeichenfolgeschlüssel zur Beschreibung des Inhalts oder Zwecks des Datenträgers. Diese Zeichenfolge wird vom Installationsprogramm für den Benutzer angezeigt, damit dieser den Datenträger identifizieren kann. Die Beschreibung wird in doppelte Anführungszeichen gesetzt.

disk-label
Datenträgerbezeichnung des Quelldatenträgers, die bei dessen Formatierung festgelegt wird.

disk-serial-number
Wird nicht verwendet. Wert muss 0 sein.

Das unten stehende Beispiel gibt einen Quelldatenträger an. Die Datenträgerbeschreibung wird als Zeichenfolgeschlüssel angezeigt:

[SourceDisksNames]
55 = %ID1%, Instd1, 0

[Strings]
ID1="Mein Anwendungs-Installationsdatenträger 1"

Zurück zum Anfang der Datei
SourceDisksFiles-Abschnitt

[SourceDisksFiles]
file name=disk-number[,subdir] [,file-size]
.
.
color=#000000Nennt die bei der Installation verwendeten Quelldateien und gibt die Quelldatenträger an, auf denen sich die Dateien befinden.

color=#000000Dateiname
color=#000000Name der Datei auf dem Quelldatenträger.

disk-number
color=#000000Ordnungszahl des Quelldatenträgers, auf dem sich die Datei befindet. Die Ordnungszahl muss im Abschnitt SourceDisksNames festgelegt sein und muss einen Wert größer oder gleich 1 annehmen (Null ist kein gültiger Wert für den Parameter disk-number).

subdir
Optionaler Parameter, der den Unterordner auf dem Quelldatenträger angibt, in dem sich die Datei befindet. Wird dieser Parameter nicht verwendet, gilt der Basisordner des Quelldatenträgers als Standardordner.

file-size Optionaler Parameter, der die Größe der Datei in Byte angibt.

color=#000000Der folgende SourceDisksFiles-Beispielabschnitt gibt eine einzelne Quelldatei, Srs01.386, auf dem Datenträger mit der Ordnungszahl 1 an:

[SourceDisksFiles]
SRS01.386 = 1

Zurück zum Anfang der Datei

Strings-Abschnitt

[Strings]
strings-key=value
.
.
Gibt einen oder mehrere Zeichenfolgeschlüssel an. Als Zeichenfolgeschlüssel bezeichnet man einen Namen, der eine Folge von druckbaren Zeichen darstellt. Obwohl der Abschnitt Strings normalerweise der letzte Abschnitt in der .INF-Datei ist, kann ein in diesem Abschnitt festgelegter Zeichenfolgeschlüssel beliebig in der .INF-Datei verwendet werden, je nachdem, wo die entsprechende Zeichenfolge gebraucht wird. Das Installationsprogramm erweitert den Zeichenfolgeschlüssel der angegebenen Zeichenfolge entsprechend und verwendet ihn zur weiteren Verarbeitung. Ein Zeichenfolgeschlüssel muss in Prozentzeichen (%) gesetzt werden.

strings-key
Ein eindeutiger Name aus Buchstaben und Ziffern.

value
Eine Zeichenfolge aus Buchstaben, Ziffern oder anderen druckbaren Zeichen. Die Zeichenfolge sollte in doppelte Anführungszeichen gesetzt werden, falls der entsprechende Zeichenfolgeschlüssel in einem Elementtyp verwendet wird, der dies verlangt.

Der Strings-Abschnitt erleichtert die Übersetzung von Zeichenfolgen für den internationalen Markt, indem sämtliche Zeichenfolgen, die angezeigt werden, auf der Benutzeroberfläche abgebildet werden, sobald die .INF-Datei in einem einzelnen Abschnitt der .INF-Datei verwendet wird. Zeichenfolgeschlüssel müssen nach Möglichkeit immer verwendet werden.

Das folgende Beispiel zeigt den Strings-Abschnitt für eine .INF-Beispieldatei.

[Strings]
String0="Meine Anwendung"
String1="INFO-Datei meiner Anwendung"
String2="CX2590 SCSI-Adapter"

Zurück zum Anfang der Datei

Optional Components-Abschnitt

[Optional Components]
Installationsabschnittsname
[Installationsabschnittsname]
.
.
Listet Install-Abschnitte auf, die angezeigt werden, sobald der Benutzer auf das Symbol Software in der Systemsteuerung, dann auf die Registerkarte Windows Setup und schließlich auf die Schaltfläche Diskette klickt. Die Install-Abschnitte werden als Kontrollkästchen in der Liste angezeigt.

Beachten Sie, dass der Abschnitt Optional Components ignoriert wird, wenn Sie eine .INF-Datei durch Klicken mit der rechten Maustaste oder durch Auswählen des Verbs "Installieren" ausführen. Wenn Sie eine .INF-Datei auf diese Weise ausführen, wird der Abschnitt [DefaultInstall] ausgeführt. Der Abschnitt Optional Components wird ebenfalls ignoriert, wenn die .INF-Datei über den Einstiegspunkt InstallHinfSection in Setupx.dll ausgeführt wird. Wenn Sie eine .INF-Datei über den Einstiegspunkt setupx ausführen, wird der im Parameter für den Einstiegspunkt angegebene Install-Abschnitt ausgeführt.

Für die Install-Abschnitte gilt das gleiche Format wie zuvor erläutert, und folgende zusätzliche Schlüssel können zum Abschnitt Install hinzugefügt werden, um die Oberfläche im Dialogfeld Diskette zu erstellen:

OptionDesc=option-description
Tip=tip-description
InstallDefault=0 | 1 ; Gibt an, ob diese Komponente standardmäßig installiert werden soll. 1=Yes, 0=No.
IconIndex=icon-index
Parent= Installationsabschnittsname
Needs=Installationsabschnittsname, [Installationsabschnittsname]
Include=inf-file, [inf-file]

option-description
Zeichenfolgewert, der als Name der Komponente im Listenfeld verwendet wird. Der Parameter option-description kann %String1% sein, wobei die %String1% ersetzende Zeichenfolge im Abschnitt Strings der .INF-Datei festgelegt ist.

option-description
Zeichenfolgewert, der im Feld Beschreibung angezeigt wird, sobald die Komponente im Listenfeld ausgewählt wird. Der Parameter tip-description ist auf 255 Zeichen begrenzt und kann %String1% sein, wobei die %String1% ersetzende Zeichenfolge im Abschnitt Strings der .INF-Datei festgelegt ist.

icon-index
Numerischer Wert, der das verkleinerte Symbol festlegt, das neben dem Komponentennamen angezeigt wird. Folgende Werte sind gültig:
0 Computer (Gehäuse und Bildschirm)
1 IC (Integrated Circuit)-Chip
2 Bildschirm
3 Netzwerkkabel
4 Windows-Flagge
5 Maus
6 Tastatur (3 Tasten)
7 Telefon
8 Lautsprecher
9 Festplatten
10 COMM-Stecker
11 Diamond (Standardwert)
12 Aktiviertes Kontrollkästchen
13 Deaktiviertes Kontrollkästchen
14 Drucker
15 Netzkarte
16 Wie 0
17 Wie 0, mit einer Hand als Freigabesymbol
18 Unbekannt (Fragezeichen)
19 Atwork
20 Abgeblendetes Kontrollkästchen
21 DFÜ-Netzwerk
22 Direkte Kabelverbindung
23 Aktenkoffer
24 Exchange
25 Teilprüfung
26 Gruppe Zubehör
27 Gruppe Multimedia
28 Schnellansicht
29 MSN
30 Taschenrechner
31 Defragmentierung
32 Originaldokument
33 DriveSpace
34 Solitär
35 HyperTerminal
36 Objektmanager
37 Paint
38 Bildschirmschoner
39 WordPad
40 Zwischenablage-Viewer
41 Eingabehilfen
42 Sicherung
43 Bitmap-Dokument
44 Zeichentabelle
45 Mauszeiger
46 Net Watcher
47 Wahlhilfe
48 Systemmonitor
49 Hilfedokumentation
50 Globus (internationale Einstellungen)
51 Audiokomprimierung
52 CD-Spieler
53 Medienwiedergabe
54 Audioschema
55 Videoclip
56 Videokomprimierung
57 Lautstärkeregelung
58 Musica-Audioschema
59 Jungle-Audioschema
60 Robotz-Audioschema
61 Utopia-Audioschema

Parent
Das auf der Oberfläche Optionale Komponenten angezeigte Listenfeld kann aus mehreren Ebenen bestehen. Handelt es sich bei der optionalen Komponente um eine untergeordnete Komponente, gibt Parent= keyword den übergeordneten Install-Abschnitt an.

Needs
Existieren für diese Komponente Abhängigkeiten von anderen Komponenten, werden hiermit die für die Komponente erforderlichen Install-Abschnitte angegeben. Wenn die Komponente ausgewählt ist, erhält der Benutzer eine Warnung mit dem Hinweis, dass diese Komponente die Komponente(n) erfordert, die in dem in der Zeile Needs= aufgelisteten Install-Abschnitt bzw. Abschnitten beschrieben werden.

Beachten Sie, dass sich die in der Zeile Needs= aufgelisteten Install-Abschnitte in derselben .INF-Datei befinden müssen. Werden jedoch abhängige Komponenten aus anderen .INF-Dateien in der Zeile Needs= aufgeführt, müssen diese .INF-Dateien in der Zeile Include= angegeben werden.

Include
Das Include-Element ermöglicht es, .INF-Dateien anzugeben, die Setup beim Laden Ihrer .INF-Datei ebenfalls in den Speicher laden muss, da diese .INF-Dateien Abschnitte enthalten, die zusätzlich zu den Installationsabschnitten in Ihrer .INF-Datei ausgeführt werden müssen. Das Element Needs gibt die Namen der Abschnitte an, die in der/den eingefügten .INF-Datei(en) ausgeführt werden sollen.

Das folgende Beispiel festgelegt zwei Installationsabschnitte in Optional Components; jeder Installationsabschnitt verwendet die zusätzlichen Einträge, um Oberflächenelemente und Abhängigkeiten anzugeben.

[Optional Components]
InstallMyToys
InstallGames

[InstallMyToys]
OptionDesc=%Toys_DESC%
Tip=%Toys_TIP%
IconIndex=35 ;Verkleinertes Telefonsymbol für Dialogfelder
Parent=MailApps
Needs=MSMAIL, MAPI, MicrosoftNetwork
Include=mos.inf, msmail.inf
CopyFiles=MyToysFiles
UpdateInis=MyToysLinks
AddReg=MyToysRegItems

[InstallOtherApps]
OptionDesc=%Other_DESC%
Tip=%Other_TIP%
IconIndex=4 ;Verkleinertes Fenstersymbol für Dialogfelder
CopyFiles=OtherFiles
UpdateInis=OtherLinks
AddReg=OtherRegItems

[Strings]
Toys_DESC="Mail-Dienstprogramme"
Toys_TIP="Zusätzliche Dienstprogramme zum Senden und Verwalten von Nachrichten"
Other_DESC="Weitere nützliche Dienstprogramme"
Other_TIP="Taschenrechner, Datenträgerüberprüfung und Systemmonitor"

Zurück zum Anfang der Datei


Verwenden der RunOnce-Technologie

Sie können beliebige Programme nach der Ausführung einer .INF-Datei starten, indem Sie entsprechende Einträge zum Registrierungsschlüssel RunOnce hinzufügen. Die RunOnce-Einträge werden ausgeführt, wenn der Computer zum nächsten Mal neu gestartet wird und ein Benutzer sich beim System anmeldet (falls eine Systemanmeldung angewendet wird).

Der Registrierungsschlüssel RunOnce ermöglicht es, Programme einmalig in Windows zu starten und festzulegen, ob sie "unsichtbar" (d. h. ohne Benutzereingriff) ausgeführt werden oder als Bestandteil einer Liste von Programmen oder Aktionen, die für den Benutzer sichtbar sind. Der Verweis auf das Programm wird dann gelöscht, damit das Programm nicht erneut ausgeführt wird.

Damit Programme unsichtbar ausgeführt werden, fügen Sie Beschreibungszeichenfolge=Befehlszeile-Einträge unter dem folgenden Registrierungsschlüssel hinzu:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce

Um Programme zu starten, die synchron unter dem Windows RunOnce-Manager ausgeführt werden, fügen Sie Beschreibungszeichenfolge=Befehlszeile-Einträge unter dem folgenden Registrierungsschlüssel hinzu:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup

Im nachstehenden Beispiel sehen Sie einen AddReg-Abschnitt, der folgende Vorgänge auslöst:

  • Starten von Anwendung.exe (im Ordner Windows) ohne Benutzeroberfläche.

    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce,"SilentApp",,"%25%\anwendung.exe"

  • Starten von Test.exe (im Ordner System) und Anzeigen der Meldung "Die folgenden Komponenten werden jetzt von Windows Setup installiert":
    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup,"Testprogramm",,"%11%\test.exe"

Anmerkung

  • Die beschreibende Zeichenfolge unter dem Registrierungsschlüssel Setup wird auf der Benutzeroberfläche angezeigt.


IEAK-Beispiele

Dieser Abschnitt enthält Musterskripts zur automatischen Proxyserver-Konfiguration, Beispiele für Dateien für die Installation im Batchmodus und eine .INF-Beispieldatei. Darüber hinaus beinhaltet dieser Abschnitt Schemadarstellungen zur Verdeutlichung einiger Internet Explorer- und IEAK-Konzepte.

  • JavaScript oder JScript Autoproxy-Beispieldateien
  • Beispiel-.INF-Datei für den Downloaddienst für Komponenten
  • Beispieldatei für die Installation im Batchmodus
  • Darstellungen der IEAK-Konzepte

Weitere Beispiele, wie etwa Beispieldateien für die Erstellung serverbasierter Anmeldepakete oder Beispielseiten zum Downloaden und Installieren von Addon-Komponenten, finden Sie im IEAK-Toolkit.


Inhalt des IEAK-Toolkits

Das IEAK-Toolkit enthält nützliche Tools, Programme und Beispieldateien. Die Komponenten des Toolkits befinden sich im Ordner \<IEAK-Programmordner>\Toolkit und den zugehörigen Unterordnern.

Im Ordner Toolkit finden Sie eine Referenz für .ISP- und .INS-Dateien mit dem Namen Insref.xls.

Ordner "Addons"

Dieser Ordner enthält Beispielseiten für Addon-Komponenten.

Ordner "Corp"

Dieser Ordner enthält Beispiele für .INS-Dateien zur automatischen Konfiguration sowie anpassbare Active Server Page-Skripts (.ASP). Die .ASP-Dateien wurden für Webserver entwickelt, auf denen Internet Information Server 3.0 (oder höher) ausgeführt wird. Sie können jedoch mit jedem Standardwebbrowser angezeigt werden.

Ordner "Graphics"

Dieser Ordner enthält Beispielgrafiken und Tools.

Ordner "Inf"

Dieser Ordner enthält ein Beispiel für eine .INF-Datei zum Erstellen eines Deinstallationsprogramms.

Ordner "ISP"

Dieser Ordner enthält verschiedene Tools und Beispiele für Internetdienstanbieter (ISPs):

  • Ein Tool (ISP-Datei-Assistent) zum Konfigurieren der DFÜ-Informationen.
  • Ein Tool (Inetlogn.exe) zum Zwischenspeichern des jeweiligen Benutzerkennworts, damit der Benutzer es nicht bei jeder Anmeldung erneut eingeben muss.
  • Beispielskripts, Tools und anpassbare Lösungen für serverbasierte Anmeldepakete, Anmeldepakete mit integriertem Assistenten für den Internetzugang und für serverlose Anmeldepakete.


Darstellungen der IEAK-Konzepte

Die folgenden Schemadarstellunggen zeigen die wichtigsten Funktionen und Konzepte des IEAK.

Erfahrung des Benutzers bei der Internet Explorer-Installation von einem mit IEAK erstellten Paket

Windows Update Setup für Internet Explorer und andere Internetprogramme

Anpassungsmöglichkeiten

So funktioniert die automatische Konfiguration

Erstellen eines Pakets mit Hilfe des IEAK

Erstellung angepasster Pakete durch IEAK

Automatische Versionssynchronisierung (AVS)

Bereitstellen von Dateien für die Distribution

Anmelden im Internet

ISP-Anmeldevorgang

Firmenadministratoren

Systemrichtlinien und Einstellungen


JavaScript oder JScript Autoproxy-Beispieldateien

Die folgenden Skripts stellen Beispiele dafür dar, wie eine .PAC-Datei verwendet werden kann, um einen Autoproxy-URL anzugeben. Um diese Funktionen verwenden zu können, müssen Sie die Proxynamen, Anschlussnummern und IP-Adressen ändern.

Anmerkungen

  • Die Funktionen isInNet, isResolvable und dnsResolve fragen einen DNS-Server ab.
  • Verweise auf Object Model-Objekte, -Eigenschaften oder -Methoden bewirken, dass die Proxy-Autokonfigurationsdatei ohne Anzeige einer Fehlermeldung fehlschlägt. Beispielsweise verursachen die Verweise window.open(...), alert(...) und password(...) Fehler beim Ausführen der Proxy-Autokonfigurationsdatei in Internet Explorer.

Beispiel 1: Lokale Hosts stellen eine direkte Verbindung her, alle anderen Hosts stellen die Verbindung über einen Proxyserver her

Mit der folgenden Funktion wird überprüft, ob es sich bei dem Hostnamen um einen lokalen Host handelt. Wenn dies der Fall ist, wird überprüft, ob es sich um eine direkte Verbindung handelt. Handelt es sich bei dem Hostnamen nicht um einen lokalen Host, wird die Verbindung über einen Proxyserver (Proxyserver) hergestellt.

Funktion FindProxyForURL(url, host)
  {
    if (isPlainHostName(host))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Mit der Funktion isPlainHostName wird überprüft, ob der Hostname Punkte enthält. Wenn dies der Fall ist, wird False zurückgegeben, andernfalls True.

Beispiel 2: Hosts innerhalb eines Firewalls stellen eine direkte Verbindung her, externe Server stellen die Verbindung über einen Proxyserver her

Mit der folgenden Funktion wird überprüft, ob es sich bei dem Host entweder um einen "einfachen" Hostnamen handelt (d. h. der Domänenname ist nicht enthalten), oder ob er Teil einer bestimmten Domäne (.firma.com), der Hostname jedoch nicht www oder home ist.

Funktion FindProxyForURL(url, host)
  {
    if ((isPlainHostName(host) ||
      dnsDomainIs(host, ".firma.com")) &&
      !localHostOrDomainIs(host, "www.firma.com") &&
      !localHostOrDoaminIs(host, "home.firma.com"))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Anmerkungen

  • Die Funktion localHostOrDomainIs wird nur für URLs in der lokalen Domäne ausgeführt.
  • Die Funktion dnsDomainIs gibt True zurück, wenn die Domäne des Hostnamens der angegebenen Domäne entspricht.

Beispiel 3: Falls der Host auflösbar ist, direkte Verbindung herstellen. Andernfalls die Verbindung über einen Proxyserver herstellen.

Die folgende Funktion fordert den DNS-Server auf, den an ihn übergebenen Hostnamen aufzulösen. Wenn dies möglich ist, wird eine direkte Verbindung hergestellt. Wenn dies nicht möglich ist, wird die Verbindung über einen Proxyserver hergestellt. Dieses Verfahren ist sinnvoll, wenn ein interner DNS-Server für die Auflösung aller internen Hostnamen verwendet wird.

Funktion FindProxyForURL(url, host)
  {
    if (isResolvable(host))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Siehe die Anmerkung zur Funktion dnsResolve() am Anfang der Seite.

Beispiel 4: Falls der Host sich innerhalb des angegebenen Subnets befindet, direkte Verbindung herstellen. Andernfalls Verbindungen über einen Proxyserver herstellen.

Die folgende Funktion vergleicht ein angegebenes IP-Adressenmuster und eine -maske mit dem Hostnamen. Dieses Verfahren ist sinnvoll, wenn zu bestimmten Hosts in einem Subnet eine direkte Verbindung hergestellt werden soll, zu anderen eine Verbindung über einen Proxyserver.

Funktion FindProxyForURL(url, host)
  {
    if (isInNet(host, "999.99.9.9", "255.0.255.0"))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Siehe die Anmerkung zur Funktion isInNet am Anfang der Seite.

Die Funktion isInNet(Host, Muster, Maske) gibt True zurück, wenn die IP-Adresse des Hosts dem angegebenen Muster entspricht. Die Maske gibt an, welcher Teil der IP-Adresse entsprechen soll (255=Entsprechung, 0=ignorieren).

Beispiel 5: Verbindungstyp anhand der Hostdomäne bestimmen

Die folgende Funktion legt eine direkte Verbindung fest, wenn der Host lokal ist. Wenn der Host nicht lokal ist, bestimmt diese Funktion auf der Basis der Hostdomäne, welcher Proxyserver verwendet werden soll. Dieses Verfahren ist sinnvoll, wenn der Hostdomänenname eines der Kriterien für die Proxyserverauswahl darstellt.

Funktion FindProxyForURL(url, host)
  {
    if (isPlainHostName(host))
      return "DIRECT";
    else if (shExpMatch(host, "*.com"))
      return "PROXY comproxy:80";
    else if (shExpMatch(host, "*.edu"))
      return "PROXY eduproxy:80";
    else
      return "PROXY proxy";
  }

Die Funktion shExpMatch(str, shexp) gibt True zurück, wenn str dem Wert von shexp bezüglich der Shell-Ausdrucksmuster entspricht.

Beispiel 6: Verbindungstyp anhand des verwendeten Protokolls bestimmen

Die folgende Funktion extrahiert das verwendete Protokoll und nimmt entsprechend die Proxyserverauswahl vor. Wenn für das Protokoll keine Entsprechung gefunden wird, wird eine direkte Verbindung hergestellt. Dieses Verfahren ist sinnvoll, wenn das verwendete Protokoll eines der Kriterien für die Proxyserverauswahl darstellt.

Funktion FindProxyForURL(url, host)
  {
    if (url.substring(0, 5) == "http:") {
      return "PROXY proxy:80";
    }
    else if (url.substring(0, 4) == "ftp:") {
      return "PROXY fproxy:80";
    }
    else if (url.substring(0, 7) == "gopher:") {
      return "PROXY gproxy";
    }
    else if (url.substring(0, 6) == "https:") {
      return "PROXY secproxy:8080";
    }
    else {
      return "DIRECT";
    }
  }

Die Funktion substring extrahiert die angegebene Anzahl von Zeichen aus einer Zeichenfolge.

Beispiel 7: Proxyservereinstellung bestimmen, indem überprüft wird, ob der Hostname der IP-Adresse entspricht

Die folgende Funktion nimmt eine Proxyserverauswahl vor, indem sie den Hostnamen in eine IP-Adresse übersetzt und diese mit einer angegebenen Zeichenfolge vergleicht.

Funktion FindProxyForURL(url, host)
  {
    if (dnsResolve(host) == "999.99.99.999") {  // = http://secproxy
      return "PROXY secproxy:8080";
    }
    else {
      return "PROXY proxy:80";
    }
  }

Siehe die Anmerkung zur Funktion dnsResolve am Anfang der Seite.

Beispiel 8: Wenn die IP-Adresse des Hosts der angegebenen IP-Adresse entspricht, Verbindung über einen Proxyserver herstellen, andernfalls direkt

Die folgende Funktion stellt ein anderes Verfahren zur Proxyserverauswahl dar, das auf der Angabe einer IP-Adresse beruht. In diesem Beispiel wird anders als in Beispiel 7 der Funktionsaufruf verwendet, um die numerische IP-Adresse explizit abzufragen (Beispiel 7 verwendet die Funktion dnsResolve, um den Hostnamen in die numerische IP-Adresse zu übersetzen).

Funktion FindProxyForURL(url, host)
  {
    if (myIpAddress() == "999.99.999.99") {
      return "PROXY proxy:80";
    }
    else {
      return "DIRECT";
    }
  }

Die Funktion myIpAddress gibt die IP-Adresse (Ganzzahlformat mit Punkten) des Hosts zurück, auf dem der Browser ausgeführt wird.

Beispiel 9: Wenn der Hostname Punkte enthält, Verbindung über einen Proxyserver herstellen. Andernfalls direkte Verbindung herstellen.

Die folgende Funktion prüft, wie viele Punkte der Hostname enthält. Wenn der Hostname Punkte enthält, wird die Verbindung über einen Proxyserver hergestellt. Wenn der Hostname keine Punkte enthält, wird eine direkte Verbindung hergestellt. Dies ist ein alternatives Verfahren zur Bestimmung der Verbindungstypen auf der Basis der Charakteristika des Hostnamens.

Funktion FindProxyForURL(url, host)
  {
    if (dnsDomainLevels(host) > 0) {  // wenn Anzahl der Punkte in host > 0
      return "PROXY proxy:80";
    }
    return "DIRECT";
  }

Die Funktion dnsDomainLevels gibt einen ganzzahligen Wert zurück, der der Anzahl der Punkte im Hostnamen entspricht.

Beispiel 10: Wochentage festlegen, an denen die Verbindung über einen Proxyserver hergestellt werden soll, und andere Wochentage, an denen eine direkte Verbindung verwendet werden soll

Die folgende Funktion bestimmt den Verbindungstyp durch die Angabe der Wochentage, an denen ein Proxyserver verwendet werden soll. An Tagen, die nicht in den durch die Parameter festgelegten Zeitraum fallen, wird eine direkte Verbindung verwendet. Diese Funktion kann in den Fällen sinnvoll eingesetzt werden, in denen Sie einen Proxyserver verwenden möchten, wenn das Datenaufkommen hoch ist; eine direkte Verbindung wird nur bei geringem Datenaufkommen verwendet.

Funktion FindProxyForURL(url, host)
  {
    if(weekdayRange("WED", "SAT", "GMT"))
      return "PROXY proxy:80";
    else
      return "DIRECT";
  }

Die Funktion weekdayRange(Tag1 [,Tag2] [,GMT] ) gibt zurück, ob die aktuelle Systemzeit in den durch die Parameter Tag1, Tag2 und GMT angegebenen Bereich fällt. Nur der erste Parameter ist erforderlich. Der Parameter GMT setzt voraus, dass die Zeitangaben der Greenwich Mean Time statt der örtlichen Zeitzone entsprechen.


Beispieldatei für die Installation im Batchmodus

;Beispiel einer einfachen "Iebatch.txt"-Datei mit einer Auswahl von Installationsordnern,
;führt die erste Installationsoption in der Liste aus und startet den Computer automatisch neu.

[Welcome]
Display=0

[SetupChoice]
Display=0

[Custom]
Display=0
Mode=0
InstallDir=c:\Int_exp\de

[Download]
Display=0
DownloadDir=c:\Int_exp\download\

[Finish]
Display=0

[Reboot]
Reboot=1

Weitere Informationen erhalten Sie unter folgenden Themen.

  • Ausführen von Setup im Batchmodus
  • Batchdateisyntax


Problembehandlung beim Anpassen von Paketen

Wenn Ihr angepasstes Paket auf dem Computer des Benutzers nicht erwartungsgemäß ausgeführt wird, liegt möglicherweise ein Problem in Zusammenhang mit einem der folgenden Szenarien vor:

Beim Ausführen von Windows Update Setup auf dem Computer des Benutzers tritt ein Fehler auf

Falls in Windows Update Setup ein Fehler auftritt bietet die Datei Active Setup Log.txt wichtige Hinweise zum Behandeln der Installationsfehler. Die Datei Active Setup Log.txt enthält ein Protokoll des gesamten Installationsvorgangs, von dem Moment der Ausführung von IE5Setup.exe bis zum Abschluss des Downloads der letzten .CAB-Datei.

Wenn IE5Setup.exe ausgeführt wird, wird Active Setup Log.txt in dem Ordner erstellt, in dem Windows installiert ist (gewöhnlich C:\Windows). Falls eine Datei Active Setup Log.txt von einer vorhergehenden Installationssitzung von Internet Explorer vorhanden ist, wird sie in Active Setup Log.bak umbenannt.

Das Protokoll beginnt mit Datum und Uhrzeit des Starts von Setup und endet mit Datum und Uhrzeit des erfolgreichen Downloads der letzten .CAB-Datei. Während Sie den Setup-Assistenten durcharbeiten, werden fortwährend Einträge in dieser Datei verzeichnet. Sie stellt die informativste Protokolldatei dar, um festzustellen, wodurch ein Downloadfehler verursacht wurde und wann er aufgetreten ist. Die meisten Einträge in dieser Datei werden ebenfalls in die Registrierung geschrieben; diese Daten werden zur Unterstützung einer sicheren Wiederherstellung aufgezeichnet.

Anhand der Fehlercodes können Sie feststellen, bei welcher Aktion von Setup der Fehler auftrat und was den Fehler verursacht hat. Weitere Informationen zu den Fehlercodes finden Sie unter Fehlerprotokollinformationen für Active Setup Log.txt.

Während der Ausführung von Windows Update Setup tritt ein Fehler beim Downloaden der Dateien auf

Windows Update Setup bietet die Möglichkeit, während der Installation zwischen Servern zu wechseln, um einen maximalen Durchsatz zu erzielen oder um auf eine nicht antwortende Verteilungssite zu reagieren. Ein Serverwechsel erfolgt, wenn Windows Update Setup erkennt, dass der Durchsatz null bzw. weniger als ein Byte in zwei Minuten beträgt.

Bei einer Zeitüberschreitung der Verbindung versucht Setup, eine Verbindung zur nächsten Downloadsite in der Liste herzustellen und die Installation am Anfang der teilweise gedownloadeten .CAB-Datei fortzusetzen. Wechselt Setup bei einer Zeitüberschreitung der Verbindung den Server nicht, wird versucht, die Verbindung zur Downloadsite erneut herzustellen und die Installation an dem Punkt wieder aufzunehmen, an dem sie unterbrochen wurde. Kann die Verbindung zur Downloadsite nicht erneut aufgebaut werden, werden Sie gefragt, ob Sie die Installation abbrechen oder erneut versuchen möchten.

Wenn die erste angegebene Site nicht erreicht werden kann (beispielsweise aufgrund von Serverproblemen), kann Windows Update Setup die verbleibenden Sites nicht aufrufen. Um das Problem zu lösen, müssen Sie die Angabe der ersten Site mit folgendem Befehl überschreiben:

<Pfad>\ie5setup.exe /C:"ie5wzd.exe /S:""<Pfad>\ie5setup.exe"" /L:""http://mein Webserver/meine Website/ie5sites.dat"""

<Pfad> ist der Ordner, in dem sich die Datei IE5setup.exe befindet.

Beispiel

Im Folgenden ein Beispiel der Syntax, die Benutzern nach dem ersten Download der Site angezeigt wird. Das Beispiel besteht aus einer Befehlszeile, die unter Verwendung dreier Textzeilen angezeigt wird, um bessere Lesbarkeit zu gewährleisten.

C:\ie5setup.exe /C:"ie5wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\ie5setup.exe""
/L:""http://<NeueServerAdresse>/<DownloadVerz>/ie5sites.dat """

Auswahl des Installationsmodus für Windows 2000-Benutzer nicht verfügbar

Unabhängig von den Installationsoptionen, die Sie für Ihr Paket konfigurieren, zeigt Windows Update Setup-Programm für Benutzer des Betriebssystems Windows 2000 nur eine einzige Installationsoption an. Diese Installationsoption beinhaltet den vollständigen Satz der Microsoft-Internetkomponenten und darüber hinaus alle angepassten Komponenten, die in dem Paket enthalten sind.

Über AutoKonfiguration aufgebrachte Branding-Informationen werden bei Computern unter Windows 2000 nicht angewendet

Änderungen der Branding-Informationen, die über die AutoKonfiguration an Benutzer verteilt werden, werden nicht angewendet, wenn in Gruppenrichtlinie unter Windows 2000 die Richtlinie zur Blockierung von externem Branding aktiviert ist. Diese Richtlinie verhindert das Aufbringen von Brandinginformationen auf Internetprogramme, wie bei der Anpassung von Internet Explorer- und Outlook Express-Logos und -Titelleisten durch Drittanbieter wie Internetdienstanbieter und Internetinhaltsanbieter. Weitere Informationen erhalten Sie unter Verwalten von Microsoft Internet Explorer unter Windows 2000.

Verbleiben von Internet Explorer 4 anstelle von Internet Explorer 5 nach der Deinstallation eines Version 5.5-Pakets

Wenn die folgende Software auf dem Computer eines Benutzers installiert und anschließend deinstalliert wird, so bleibt folgende Konfiguration:

  1. Ausgangssituation: Auf dem Computer des Benutzers ist Internet Explorer 4 installiert.
  2. Internet Explorer 5 wird über ein mit IEAK erstelltes angepasstes Paket oder über eine andere Quelle installiert.
  3. Internet Explorer 5.5 wird über ein mit IEAK erstelltes angepasstes Paket oder über eine andere Quelle installiert.
  4. Internet Explorer 5.5 wird deinstalliert.

Konfiguration nach diesen Schritten: Auf dem Computer des Benutzers ist Internet Explorer 4 installiert. Sie müssen Internet Explorer 5 erneut installieren, um diese Version des Browsers zu verwenden.

Deinstallation von Komponenten unmöglich

Wenn die Deinstallation fehlschlägt, stellt das wichtigste Tool zur Problembehandlung das Deinstallationsprotokoll IE5 Uninstall Log.txt dar, das sich im Ordner \Windows befindet. In diesem Protokoll wird der gesamte Deinstallationsvorgang Schritt für Schritt aufgezeichnet, einschließlich jeder Hinzufügung oder Löschung von Dateien, jeder Hinzufügung, Änderung oder Löschung von Registrierungseinträgen und aller Dialogfelder, die dem Benutzer angezeigt werden.

Das Protokoll ist in "Durchläufe" unterteilt, die den verschiedenen Phasen einer Deinstallation entsprechen. Einträge im Protokoll weisen außerdem eine Objektnummer auf, die dem Zeileneintrag in Setup.stf entspricht. Zeilen ohne Objektnummer beruhen auf Internet Explorer 5-spezifischen angepassten Aktionen und sind in der Datei IE5.inf oder in einer .INF-Datei von einer Deinstallation einer externen Komponente enthalten.

Falls Sie Internet Explorer nicht mit Hilfe des Symbols Software der Systemsteuerung deinstallieren können, wurden unter Umständen Deinstallationsinformationen auf dem Computer gelöscht. Die wesentlichen Deinstallationsdateien sind:

  • IE5bak.dat
  • IE5bak.ini
  • Integrated Browser.dat
  • Integrated Browser.ini.

Das erweiterte Dialogfeld zum Deinstallieren von Internet Explorer bietet die Option, diese Sicherungsinformationen zu deinstallieren, allerdings wird dadurch eine zukünftige Deinstallation von Internet Explorer unmöglich.

Weitere Informationen zur Deinstallation von angepassten Komponenten erhalten Sie unter Bereitstellen der Funktion zum Deinstallieren in einem .INF-Skript und Deinstallieren einer angepassten Komponente.

Fehler bei der Internetanmeldung mit dem Assistenten für den Internetzugang bei Single-Disk-Branding

Falls Sie das Single-Disk Branding-Verfahren einsetzen, verwenden Sie nicht die Anmeldung mit dem Assistenten für den Internetzugang, wenn Sie absehen können, dass bestimmte Benutzer mit Internet Explorer 4.01 Service Pack 1 (oder früheren Versionen) arbeiten. Erstellen Sie statt dessen für diese Kunden ein separates Paket mit Anmeldung im Kioskmodus.


Problembehandlung bei der Verwendung des Assistenten zur Anpassung von Internet Explorer

Überprüfen Sie die folgenden Einstellungen, wenn Sie bestimmte Bildschirme im Assistenten für die Internet Explorer-Anpassung nicht finden können:

  • Stellen Sie sicher, dass Sie die richtige Rolle/Position ausgewählt haben (ICP (Internetinhaltsanbieter)/ISV (Unabhängiger Softwareanbieter), ISP (Internetdienstanbieter) oder Firmenadministrator).
  • Stellen Sie sicher, dass Sie das richtige Betriebssystem ausgewählt haben.
  • Stellen Sie sicher, dass im Bildschirm Auswahl von Features alle Features, die Sie anpassen möchten, ausgewählt sind. Wenn das Kontrollkästchen für ein Feature nicht aktiviert ist, werden die Bildschirme für das Feature nicht angezeigt.
  • Zur Anpassung von Outlook Express müssen Sie überprüfen, ob Sie die Dateien für Outlook Express gedownloadet haben und Outlook Express zu mindestens einem der Installationsmodi hinzugefügt haben.

Wenn Sie beabsichtigen, die Windows Desktop-Aktualisierung anzupassen, muss die Windows Desktop-Aktualisierung auf dem Erstellungscomputer in einer der folgenden Konfigurationen ausgeführt werden:

  • Windows 98
  • Windows 98, Zweite Ausgabe
  • Windows Millennium Edition
  • Windows 2000
  • Bei anderen Windows-Versionen müssen Sie ein Upgrade von Internet Explorer 4.0 mit installierter Windows Desktop-Aktualisierung auf Internet Explorer 5.5 durchführen.

Anmerkung

  • Wenn Sie eine automatische Installation einrichten oder den Assistenten für die Internet Explorer-Anpassung vom Assistenten für die Office-Installation aus ausführen, stehen einige Anpassungsoptionen nicht zur Verfügung.


Fehlerprotokollinformationen der Datei "Active Setup Log.txt"

Die Datei Active Setup Log.txt kann Sie bei der Problembehandlung bei Windows Update Setup-Fehlern unterstützen und Sie über den Status von Setup zum Zeitpunkt des Fehlers informieren. Im Protokoll finden Sie folgende Einträge:

Protokolleintrag | Bedeutung
0 | Initialisierung (Erstellen eines temporären Ordners, Prüfen des Speicherplatzes)
1 | Abhängigkeiten (Überprüfen aller Abhängigkeiten)
2 | Download der Dateien vom Server
3 | Kopieren der Dateien vom Downloadspeicherort in den temporären Installationsordner
4 | Wiederholen des Downloads und erneutes Ausführen von Setup, da ein Timeoutfehler oder ein anderer Downloadfehler aufgetreten ist
5 | Prüfen der Vertrauenswürdigkeit und Prüfen der Berechtigungen
6 | Extraktion der Dateien
7 | Ausführen des Setup-Programms (einer .INF- oder .EXE-Datei)
8 | Installation abgeschlossen
9 | Download beendet und alle Dateien erfolgreich gedownloadet

Allgemeine Fehlercodes:

Fehlercode | Bedeutung
80100003 | Dateien wurden während der Installation nicht im Downloadordner gefunden.
800bxxxx | Ein Fehlercode, der mit 800b beginnt, bedeutet einen Fehler der Vertrauenswürdigkeit.
800Cxxxx | Ein Fehlercode, der mit 800C beginnt, ist ein Urlmon-Fehler.

Beispiele

Allgemeine Beispiele:

800C005: Datei oder Server konnte nicht gefunden werden.

800C00B: Verbindungstimeout.

8004004: Installation durch den Benutzer abgebrochen.


Glossar

A

Active Desktop
Eine von zwei Komponenten, die bei der Windows Desktop-Aktualisierung installiert werden. Benutzer, die den Active Desktop verwenden, können dem Desktop, der Taskleiste oder Ordnern aktive Inhalte, wie beispielsweise ein Laufband mit Aktienkursen, hinzuzufügen. Dateien können auch durch einfaches Klicken geöffnet und ausgeführt werden. Der Active Desktop kann über IEAK deaktiviert werden, auch wenn die Windows Desktop-Aktualisierung installiert ist.
Addon-Komponente
Komponente, die nicht in Ihrem Paket enthalten ist, aber von den Benutzern nach Abschluss von Windows Update Setup installiert werden kann.
.ADM-Datei (Systemrichtlinien-Vorlagendatei)
Eine Datei zur Festlegung der Systemrichtlinien und Einschränkungen, die Sie für den Desktop, die Shell und die Systemsicherheit festlegen können. Siehe Systemrichtlinien.
Adresse
In Bezug auf das Internet der Name einer Website, zu der Benutzer eine Verbindung herstellen können, wie beispielsweise www.microsoft.de, oder die Adresse eines E-Mail-Empfängers, wie beispielsweise name@firma.de. Websiteadressen beginnen normalerweise mit dem Namen des Protokolls (beispielsweise ftp:// oder http://), gefolgt von dem Namen der Organisation, welche die Website unterhält. Das Suffix kennzeichnet die Art der Organisation. Adressen kommerzieller Sites enden häufig mit dem Suffix .com.
Angepasste Komponente
Komponente, die Sie zusätzlich zu den Internetkomponenten, die Sie bei Microsoft mit Hilfe von AVS (Automatische Versionssynchronisierung) gedownloadet haben, in Ihr Paket aufnehmen.
Angepasster Messenger Service-Client
Die Variante der Clientsoftware, die erstellt wird, wenn Sie einen MSN Messenger Service-Client mit Branding-Informationen wie Ihrem eigenen Logo, spezifischen Download-URLs und anderen Anpassungen versehen.
Angepasstes Paket
Enthält angepasste Versionen aller Installationstools, des Browsercodes und zusätzlicher Komponenten, die erforderlich sind, um Internet Explorer schnell und problemlos in der Organisation zu verteilen.
Anmeldepaket
Eine Reihe von HTML-Seiten zur Zusammenstellung der Anmeldeinformationen für einen Kunden und zur Übermittlung dieser Informationen auf Anforderung an den ISP-Anmeldeserver. Diese Folge von Seiten führt den Kunden ähnlich wie ein Assistent in einem Windows-Programm schrittweise durch den Anmeldevorgang.
Anmeldeserver
Siehe Internetanmeldeserver.
Anmeldung
Nach der Installation von Internet Explorer können die Features zur Anmeldung verwendet werden, um den Kundenregistrierungsprozess durchzuführen. Serverbasierte Anmeldung ermöglicht einen hohen Grad an Flexibilität und passt sich dynamisch an verschiedene Anmeldeoptionen an. Sie erfordert jedoch die Verwendung von CGI- oder ActiveX-Skripts auf einem Webserver. Die serverlose Anmeldung erfordert keinen Anmeldeserver. Wenn Sie sich für die serverlose Methode entscheiden, fordert der Assistent für die Internet Explorer-Anpassung Sie auf, die für das Steuern des Anmeldevorgangs erforderlichen Informationen zur Verfügung zu stellen.
Anpassungassistent
Siehe Assistent zur Internet Explorer-Anpassung.
Anpassungscode
Lizenzcode, der für Organisationen beim Downloaden von IEAK (Internet Explorer Administration Kit) ausgestellt wird. Der Lizenzcode wird nicht zur Installation von IEAK, sondern nur zur Erstellung von IEAK-Paketen benötigt.
Assistent für den Internetzugang (ICW)
Ein Tool, das Benutzern dabei hilft, sich bei einem Internetdienst anzumelden, und die für die Herstellung einer Verbindung mit dem Internet erforderlichen Schritte zur Konfiguration der Software automatisch durchführt. ISPs können den Assistenten für den Internetzugang entsprechend den Anforderungen der Kunden anpassen und vorkonfigurieren.
Assistent für die Internet Explorer-Anpassung
Die Hauptkomponente von IEAK, mit deren Hilfe eine angepasste Version von Internet Explorer zur Installation in einer bestimmten Organisation erstellt werden kann.
Authenticode
Eine Technologie, die es ermöglicht, die Firma oder die Person zu ermitteln, die eine Software herausgibt und zu überprüfen, dass diese seit dem Herausgeben nicht verändert wurde. Firmenadministratoren können Sicherheitseinstellungen und Filter vorkonfigurieren und Zertifizierungsstellen anpassen, sodass Ihre Benutzer keine unsignierte Software downloaden. Der Administrator kann ferner durch Systemrichtlinien und Einschränkungen festlegen, ob Benutzer ihre Sicherheitseinstellungen ändern können.
Automatische Installation
Siehe Installation bei Bedarf.
Automatische Konfiguration
Ein Vorgang, der es Firmenadministratoren ermöglicht, Benutzereinstellungen und Systemrichtlinien und Einschränkungen für Internet Explorer von zentraler Stelle aus zu verwalten und zu aktualisieren. Der Zeiger auf eine Datei zur automatischen Konfiguration kann manuell im Browser eingestellt oder bei der Browserinstallation über IEAK konfiguriert werden.
Automatische Suche
Ein Feature von Internet Explorer, das es Benutzern ermöglicht, Wörter in der Adressleiste einzugeben, um nach häufig besuchten Seiten im Internet zu suchen. Die Benutzer müssen sich dabei nicht an die exakten URL-Adressen dieser Seiten erinnern.
Automatische Versionssynchronisierung (AVS)
Technologie, die automatisch bei jedem Ausführen von IEAK für alle Internet Explorer-Komponenten überprüft, ob aktualisierte Versionen verfügbar sind. Aktualisierte Komponenten können bei Microsoft gedownloadet und in neu erstellte IEAK-Pakete aufgenommen werden.
Automatischer Begrüßungsbildschirm bei CD-Installation
Bildschirm, der automatisch angezeigt wird, wenn eine Installations-CD für Internet Explorer in das CD-ROM-Laufwerk der Arbeitsstation eingelegt wird. Der automatische Begrüßungsbildschirm enthält normalerweise eine Schaltfläche zur Installation von Internet Explorer 5.5, eine Schaltfläche Abbrechen und eine angepasste Grafik.
Automatischer Proxy
Ein Feature, das es einem Administrator ermöglicht, Internet Explorer so zu konfigurieren, dass der Browser dynamisch ermittelt, ob die Verbindung zu einem Host direkt oder unter Verwendung des Proxyservers hergestellt wird.
Autoproxy-Skript
In IEAK sind dies Dateien im JScript- (.JS), JavaScript- (.JVS) oder Proxy-Autokonfigurations (.PAC)-Dateiformat mit denen Sie erweiterte Proxyeinstellungen konfigurieren und pflegen können. Wird eine Autoproxy-Skriptdatei angegeben, verwendet Internet Explorer dieses Skript, um dynamisch zu ermitteln, ob die Verbindung zu einem Host direkt oder unter Verwendung des Proxyservers hergestellt wird.
Autoproxy-URL
Der Speicherort der Autoproxy-Skriptdatei. Durch Bearbeiten dieser Datei können Sie die Proxyeinstellungen für mehrere Benutzer von einem zentralen Ort aus steuern.
Autorun
Siehe Automatischer Begrüßungsbildschirm bei CD-Installation.

B

Batchdatei (.BAT)
Eine ASCII-Textdatei mit einer Folge von Befehlen auf Betriebssystemebene, die ggf. Parameter und Operatoren enthält, welche die Batchbefehlssprache unterstützt. Wenn der Benutzer an der Eingabeaufforderung den Namen der Batchdatei eingibt, arbeitet der Computer die Befehle nacheinander ab.
Benutzeragententext
Text zur Kennzeichnung der spezifischen Version des Browsers und seiner Herkunft.
Benutzer
Hier für die Person verwendet, die Internet Explorer und weitere Komponenten aus einem angepassten IEAK-Paket auf einem Computer installiert.
Bereiche (Realms)
Ein Feature von CMAK, das beim Herstellen der Verbindung zu einem Verbindungs-Manager-Dienst ein Präfix (z. B. firma) oder Suffix (z. B. @firma.de) zu einem Benutzernamen hinzufügt.
Bitmap
Dateiformat für Bilder, die zur Anpassung der Grafiken in einem IEAK-Paket verwendet werden.
Branding
Anpassen des Internet Explorer-Browsers und der zugehörigen Komponenten, des Assistenten für Windows Update Setup und des CD-Autorun-Bildschirms mit den spezifischen Emblemen, Logos, Einstellungen und Konfigurationsinformationen einer Organisation. Durch die eingefügten Branding-Informationen unterscheidet sich das Firmenpaket von einer allgemeinen Internet Explorer-Installation.

C

Channel und Kategorien
Ein Channel ist eine Website, die für Informationsempfangsprogramme aktiviert ist. Dieser Mechanismus wird durch sogenannte Channeldefinitionsformatdateien (.CDF-Dateien) ermöglicht. Channels können in Kategorien unterteilt und auf dem Desktop des Benutzers platziert werden.
Chat
Siehe MSN Messenger Service.
CMAK (Connection Manager Administration Kit)
Ein Tool zum Erstellen, Bearbeiten und Verwalten von Profilen für den Verbindungs-Manager. Der Verbindungs-Manager ist eine Wählhilfe für Clients. CMAK ist in Windows 2000 Server und im Windows 2000 Administration Kit enthalten.
Codesignierung
Der Vorgang des digitalen Signierens eines fertiggestellten Internet Explorer-Pakets mit einem digitalen Zertifikat. Für das Signieren der Pakete sind zwei Schritte erforderlich: das Anfordern eines digitalen Zertifikats und das Signieren des Codes.

D

Dateipfad
Der physische Speicherort der Distributionsdateien auf einem Webserver. Beispielsweise C:\Inetpub\Wwwroot\Ie5\Download.
Desktop-Aktualisierung
Siehe Windows Desktop-Aktualisierung.
DFÜ-Netzwerkverbindungen
Herstellen einer Verbindung mit einem Datenübermittlungsnetzwerk über ein öffentliches Telefonnetz statt über ein dediziertes Festnetz oder anderes privates Netzwerk.
DHCP (Dynamic Host Configuration Protocol)
Ein TCP/IP-Protokoll nach Industriestandard, das Computern IP-Konfigurationen zuweist. Ein DHCP-Servercomputer übernimmt die Zuweisung, und die Clientcomputer rufen den Server auf, um eine IP-Adresse zu erhalten.
Digitale Signatur
Eine Personenauthentifizierungsverfahren, das auf Verschlüsselung und geheimen Autorisierungscodes zum "Unterzeichnen" elektronischer Dokumente beruht.
Digitales Zertifikat.
Ein elektronisches Zertifikat, das von einer Zertifizierungsstelle ausgegeben wird und durch das die Herkunft von Software und die Integrität des Installationspakets überprüft werden können. Administratoren sollten ihren Code mit einem digitalen Zertifikat signieren, wenn sie beabsichtigen, ein Internet Explorer-Paket über das Internet zu verteilen.
DNS (Domain Name System)
Eine Gruppe von Richtlinien und Regeln, die von der Internetgemeinschaft im Laufe der Zeit entwickelt worden ist, die es ermöglicht, zur Navigation im Internet Adressen entweder in Form von Domänennamen (wie z. B. bluestem.prairienet.org) oder als IP-Adressen (wie 192.12.3.4) anzugeben. Die von Benutzern verwendeten Domänennamen werden automatisch in die entsprechende numerische IP-Adresse umgewandelt, die die Software zum Weiterleiten von IP-Paketen benötigt.
DNS-Server
Ein von einem ISP (Internetdienstanbieter) betriebener Computer, der Hostnamen die jeweiligen IP-Adressen zuordnet. Manche ISPs stellen eine spezifische DNS-Adresse zur Verfügung.
Domänenname
Der Name der Netzwerkverbindung, die vom DNS zur Festlegung des Eigentümers der Organisation in einer Hierarchie verwendet wird: server.organisation.typ. Beispielsweise bezeichnet die Adresse www.whitehouse.gov den Webserver des Weißen Hauses, das Teil der US-Regierung ist. In E-Mail-Adressen befindet sich der Domänenname stets hinter dem "@"-Zeichen.
Downloadsite
Ein HTTP- oder FTP-Server, über den die Benutzer Ihr Paket downloaden können. Bei einer Zeitüberschreitung der Verbindung versucht das Windows Update Setup-Programm, eine Verbindung zur nächsten in der Datei IE5Sites.dat aufgeführten Downloadsite herzustellen und die Installation am Anfang der .CAB-Datei fortzusetzen.
Dynamisches HTML
Eine Zusammenstellung von Features, welche die Möglichkeiten des ursprünglichen HTML erweitern, und den Webautoren mehr Flexibilität, zusätzliche Designoptionen und kreatives Steuern des Erscheinungsbildes und des Verhaltens von Webseiten ermöglichen.

E

Endbenutzer
Siehe Benutzer.
Explorerleiste
Die linke Seite des Browserfensters, in der die Suchleiste, die Verlaufsleiste und die Favoritenleiste angezeigt werden, wenn der Benutzer auf die entsprechende Symbolleistenschaltfläche klickt Benutzer können auch eine benutzerdefinierte Explorerleiste und eine entsprechende Symbolleistenschaltfläche zum Anzeigen dieser Leiste erstellen.

F

Favoriten
Vordefinierte Links zu Websites Favoriten werden auch als "Lesezeichen" bezeichnet. Im Internet Explorer können Favoriten so konfiguriert werden, dass der Benutzer automatisch benachrichtigt wird, wenn sich der Inhalt der Seiten ändert.
Firmenadministrator
Die Person, die für das Einrichten und die Wartung von Computern und Software in einem Unternehmen verantwortlich ist. Administratoren verwalten auch Benutzer- und Gruppenkonten, weisen Kennwörter und Berechtigungen zu und helfen Benutzern bei Netzwerkproblemen.

G

Gateway
Ein Computer, der mit mehreren physischen Netzwerken verbunden ist, die Pakete untereinander austauschen und weiterleiten können.
Gruppenrichtlinie
Ein Verwaltungstool für Systemrichtlinien in Windows 2000.
GUID
Die GUID (Globally Unique Identifier) ermöglicht es, Programme und Objekte voneinander zu unterscheiden. Wenn Sie IEAK verwenden, können Sie für jede angepasste Komponente eine GUID erstellen. Die Zahlenfolge basiert auf Systeminformationen und anderen Parametern, wie beispielsweise der Uhrzeit. Wenn Ihr Computer eine Netzwerkkarte mit einer Hardwareadresse für eine 48-Bit-IEEE-Netzwerkkarte hat, wird diese global eindeutige Adresse in die GUID integriert. Andernfalls wird eine zufällige Pseudoadresse aus Computerstatusinformationen erstellt.

H

HTML (Hypertext Markup Language)
Die Sprache, die zum Erstellen und Entwerfen von Webseiten verwendet wird. HTML stellt Webautoren eine Reihe sogenannter Tags zur Verfügung, über die z. B. Seitenlayout und Textformat festgelegt und Grafiken und Multimediaobjekte eingebunden werden können.
HTTP (Hypertext Transfer Protocol)
Ein Protokoll, das die Übertragung von Hypertextdaten wie beispielsweise Webseiten über das Internet ermöglicht, wenn der Browser mit einem entsprechenden Server verbunden ist.

I

ICP (Internetinhaltsanbieter)
Organisation, die Inhalte für die Bereitstellung im Web vorbereitet.
.INF-Datei (Informationsdatei)
Datei, welche dem Windows Update Setup-Programm für Internet Explorer 5.5 und Internettools die Informationen liefert, die zum Einrichten eines Geräts oder Programms benötigt werden. Die Datei enthält eine Liste gültiger Konfigurationen, die Namen der Treiberdateien für ein Gerät oder ein Programm usw.
.INS-Datei (Interneteinstellungsdatei)
Eine Datei, die Interneteinstellungen für das Windows Update Setup-Programm bereitstellt, um den Browser und andere Komponenten zu konfigurieren. Sie können mehrere Versionen Ihres Browserpakets erstellen, indem Sie für jedes Paket eine andere .INS-Datei verwenden. Verwenden Sie den IEAK-Profil-Manager, um .INS-Dateien zu erstellen, zu speichern und zu laden.
IEAK (Internet Explorer Administration Kit)
Eine Zusammenstellung von Tools, mit denen Firmenadministratoren, ISPs und ICPs angepasste Internet Explorer-Pakete für eine Organisation erstellen, verteilen und verwalten können. Im Lieferumfang von IEAK ist der Assistent für die Internet Explorer-Anpassung, der IEAK-Profil-Manager und das IEAK-Toolkit enthalten.
IMAP (Internet Message Access Protocol)
Ein häufig verwendetes Protokoll zum Empfang von E-Mail-Nachrichten. Es ermöglicht einem E-Mail-Client, auf eine E-Mail-Datei auf einem anderen Computer im Netzwerk zuzugreifen und diese zu verändern, ohne sie auf den lokalen Computer downloaden zu müssen. Es wird hauptsächlich von Benutzer in Firmen verwendet, die ihre E-Mail an einem Remotestandort lesen möchten. Vergleichen Sie hierzu POP3.
IMAP-Server
Ein Server, der unter Verwendung von IMAP den Zugriff auf einige seiner Ordner ermöglicht. Vergleichen Sie hierzu POP3-Server.
Infofeld
Siehe Outlook Express-Infofeld.
Inhaltsfilter
Microsoft Internet Explorer unterstützt den Administrator bei der Kontrolle der Inhalte, auf die der Computer im Internet zugreifen kann. Der Administrator kann Einstellungen vornehmen, sodass der Benutzer nur geeignete Inhalte anzeigen kann und z. B. bestimmte Inhalte aus den Bereichen Sprache, Nacktaufnahmen, Sex und Gewalt ausgeklammert werden. Siehe auch PICS (Parental Internet Content Selection).
Installation bei Bedarf
Ein Feature, das Benutzer auffordert, auf ihrem Computer noch nicht installierte Komponenten dann zu installieren, wenn eine Webseite angezeigt werden soll, die diese Komponente voraussetzt. Das IEAK ermöglicht Ihnen, die Verfügbarkeit dieses Features für die Benutzer zu beschränken.
Installation im Hintergrund
Konfigurieren des Windows Update Setup-Programms in der Form, dass die Benutzer nicht aufgefordert werden, Entscheidungen bezüglich Installationsoptionen zu treffen und weder über den Status noch über Fehler bei der Installation informiert werden. Diese Option ist nur für Firmenadministratoren verfügbar. Vergleichen Sie hierzu Installation ohne Benutzereingaben, interaktive Installation.
Installation ohne Benutzereingaben
Konfigurieren des Windows Update Setup-Programms in der Form, dass die Benutzer keine Entscheidungen eingeben müssen, aber über den Status und möglicherweise auftretende Fehler bei der Installation informiert werden. Diese Option ist nur für Firmenadministratoren verfügbar. Vergleichen Sie hierzu Installation im Hintergrund, interaktive Installation.
Interaktive Installation
Konfigurieren des Windows Update Setup-Programms in der Form, dass Benutzer während der Installation aufgefordert werden, Auswahlentscheidungen zu treffen. Diese Option ist nur für Firmenadministratoren verfügbar. Vergleichen Sie hierzu Installation im Hintergrund, interaktive Installation.
Internet Component Download (Dienst)
Ein Systemdienst zum Downloaden und Installieren von Software über Websites im Internet und in Intranets. Dieser Dienst ermöglicht auch die Überprüfung von Zertifikaten. Der Internet Component Download-Dienst wird von Microsoft Internet Explorer ab Version 3.0 unterstützt.
Internet Explorer Administration Kit
Siehe IEAK (Internet Explorer Administration Kit).
Internetanmeldeserver (ISS)
Ein HTTP (Hypertext Transfer Protocol)-Server, der das Hinzufügen neuer Kunden zu der Kundendatenbank eines Internetdienstanbieters automatisiert. Der Internetanmeldeserver sammelt Informationen von jedem Kunden, fügt diese Informationen zur Kundendatenbank des Internetdienstanbieters hinzu und übergibt anschließend ein Konfigurationspaket zurück an den Computer des Kunden. Das Konfigurationspaket enthält Informationen, die verwendet werden, um den Internetbrowser des Kunden für anschließende Verbindungen zu den Diensten des Internetdienstanbieters zu konfigurieren.
Internetdienstanbieter (ISP)
Eine Organisation, die einen oder mehrere Server betreibt, die direkt mit dem Internet verbunden sind. Benutzer, die über keine direkte Verbindung mit dem Internet verfügen, stellen normalerweise eine Verbindung über einen Dienstanbieter her. Um einen solchen Anschluss zu erhalten, lassen sich die Benutzer ein Konto bei einem Dienstanbieter einrichten.
IP-Adresse (Internet Protocol-Adresse)
Die Adresse eines Computers als Zahlenfolge. Einige ISPs stellen Benutzern die IP-Adresse ihres Servers zur Verfügung. Wenn Sie nicht sicher sind, ob Sie eine IP-Adresse eingeben müssen, wenden Sie sich an Ihren Internetdienstanbieter.
ISDN (Integrated Services Digital Network)
Ein weltweites digitales Netzwerksystem zur Kommunikation, das von den meisten Telefongesellschaften angeboten wird. ISDN wird zum Hochgeschwindigkeitsdatenaustausch im Internet, bei kommerziellen Onlinediensten und für Firmennetzwerke eingesetzt.
ISV (Independant Software Vendor - Unabhängiger Softwarelieferant)
Ein Drittanbieter von Software; eine Person oder eine Organisation, die unabhängig Computersoftware entwickelt.

J

K

Kabinettdatei (.CAB)
Eine Bibliothek von komprimierten Installationsdateien, die zu einer einzigen Datei zusammengefasst sind, um die Dateigröße und die damit verbundene Downloadzeit für Webinhalte aus dem Internet oder von firmeneigenen Intranetservern zu reduzieren. Im Lieferumfang von IEAK sind Tools enthalten, mit deren Hilfe angepasste Komponenten in einer oder mehreren .CAB-Dateien zusammengefasst werden können, die Sie dann in Ihr IEAK-Paket integrieren können.
Kioskmodus für Startseite
Eine Seite im Kioskmodus (Vollbildschirm), d. h. ohne die Symbol- und Menüleiste des Browsers, welche nach der Installation von Internet Explorer angezeigt wird.
Komponente
Der Administrator kann viele Internetkomponenten von Microsoft und anderen Anbietern zusammen mit dem Internet Explorer-Browser vertreiben. Beispiele für solche Komponenten sind Outlook Express, Microsoft NetMeeting und MSN Messenger Service-Client.
Kunde
Siehe Benutzer.

L

Lab
Eine Gruppe von Computern, die nicht produktiv eingesetzt, sondern beispielsweise zum Testen von Internet Explorer-Paketen verwendet werden. Das Lab sollte nicht mit der Softwarepilotgruppe verwechselt werden.
LDAP (Lightweight Directory Access Protocol)
Ein offener Standard zum Speichern und Abrufen von Namen, E-Mail-Adressen, Telefonnummern und anderen Daten von Personen. Das Windows-Adressbuch unterstützt das LDAP-Protokoll für den Zugriff auf Verzeichnisdienste. Die Zugriffsinformationen für die beliebtesten Verzeichnisdienste sind bereits integriert. Administratoren haben die Möglichkeit, einen weiteren Dienst für die Benutzer festzulegen.

M

Medium
Physisches Material zur Speicherung computerbasierter Informationen. Übliche Distributionsmedien für IEAK-Pakete sind CD-ROM, Web-Download und Diskette.
MIME (Multipurpose Internet Mail Extensions)
Ein Standard, der als Erweiterung zu SMTP die Übermittlung von Daten wie Videosequenzen, Sound und Binärdateien über das Internet ermöglicht, ohne dass die Daten in das ASCII-Format konvertiert werden.
Modus
Eine Untermenge der Funktionalität des Assistenten für die Internet Explorer-Anpassung, deren Umfang von den Lizenzanforderungen Ihrer Organisation abhängt. Bei der Ausführung des Assistenten für die Internet Explorer-Anpassung stehen drei Modi zur Auswahl: ICP (Internetinhaltsanbieter), ISP (Internetdienstanbieter) und Firmenadministrator. Die Versionsnummer des mit IEAK erstellten Pakets besteht aus einem Zwei-Buchstaben-Code, über den der Modus angegeben wird, in dem das IEAK-Paket erstellt wurde (IC für ICP, IS für ISP bzw. CO für Firmenadministratoren).
MSN Messenger Service
Ein direkter Nachrichtenübermittlungsdienst von Microsoft, über den Benutzer mit anderen Personen über das Internet Daten austauschen können. Der MSN Messenger Service-Client (bzw. eine angepasste Version dieses Clients) können in Ihr Browserpaket integriert oder als eigenständiger ausführbare Installationsdatei verteilt werden.

N

Namensauflösung
Der Prozess, über den die Zuordnung von Computeradressen zu Computernamen im Netzwerk erfolgt. Die Namensauflösung ermöglicht es Computern, andere Computer im Netzwerk zu finden, und eine Verbindung mit ihnen herzustellen.
Newsgroups
Siehe Usenet.
NNTP (Network News Transfer Protocol)
Das Protokoll, über das in einem Netzwerk News-Nachrichten an die entsprechenden Server und Clients (Newsreader) im Internet verteilt werden.

O

Ohne Anmeldung
Eine ISP-Installation, die für Kabelmodem-Provider entwickelt wurde. Im Lieferumfang dieser Installation ist der Assistent für den Internetzugang nicht enthalten. Der Benutzer muss nach der Installation von Internet Explorer auf dem Computer keine Dienstanmeldung durchführen.
Outlook Express-Infofeld
Ein Bereich, in dem Inhaltsanbieter nützliche Informationen und Links bereitstellen können. Administratoren können diesen Abschnitt durch Einfügen von Rufnummern zur Produktunterstützung, FAQs (Frequently Asked Questions) und Informationen zu ihrer Firma anpassen.

P

Paket
Eine Zusammenstellung von Software für eine angepasste Installation von Internet Explorer. Ein Paket umfasst die gesamte Software und alle Dateien, die für die Installation, Konfiguration und Ausführung von Internet Explorer erforderlich sind. Mit IEAK können Pakete für verschiedene Typen von Installationsmedien konfiguriert werden. Siehe auch Angepasstes Paket.
Passport
Ein Internet-Authentifizierungsdienst von Microsoft. Ein Passport wird verwendet, um sich beim MSN Messenger Service oder einem angepassten Messenger Service-Client anzumelden.
PICS (Parental Internet Content Selection)
Regeln, nach denen ICPs mittels Metatags Webinhalte freiwillig anhand von verbindlichen PICS-Kriterien bewerten. Anhand der Werte in diesen Tags kann dann für Benutzer der Zugriff auf bestimmte Websites gesperrt werden. Siehe auch Inhaltsfilter.
Pilotgruppe
Eine repräsentative Gruppe von Computern in der Produktionsumgebung, auf denen ein Internet Explorer-Paket getestet wird, bevor es in der gesamten Organisation verbreitet wird. Anders als bei einem Testlab werden in einer Pilotgruppe Computer und Benutzer aus der Produktionsumgebung eingesetzt.
Plattform
Ein Clienttyp, wie beispielsweise Windows 2000, Windows NT 4.0, Windows Millennium Edition, Windows 98, Windows 3.x, Macintosh oder UNIX.
Platzhalterzeichen
Ein Zeichen auf der Tastatur, das stellvertretend für ein oder mehrere Zeichen verwendet wird. Das Sternchen (*) z. B. steht normalerweise für ein oder mehrere Zeichen, und das Fragezeichen (?) steht normalerweise für ein einzelnes Zeichen. Platzhalterzeichen werden in Betriebssystemen oft verwendet, um mehrere Dateien mit einem einzigen Ausdruck anzugeben.
POP3 (Post Office Protocol 3)
Ein häufig verwendetes Protokoll zum Empfang von E-Mail-Nachrichten. Dieses Protokoll wird häufig von ISP verwendet. POP3-Server ermöglichen den Zugriff auf einen einzigen Posteingang, während IMAP-Server den Zugriff auf mehrere serverseitige Ordner ermöglichen. Vergleichen Sie hierzu IMAP und SMTP.
POP3-Server
Server, der Zugriff auf einen einzigen Posteingangsordner ermöglicht. Vergleichen Sie hierzu IMAP-Server.
Profil-Manager
Ein Tool, das im Lieferumfang von IEAK enthalten ist, mit dem Administratoren Browser und automatische Konfigurationseinstellungen für den Desktop erstellen und dynamisch verwalten können.
Proxyserver
Eine Firewall-Komponente zur Organisation der Datenübermittlung zwischen dem Internet und dem LAN (Local Network Area), das darüber hinaus weitere Funktionen, wie beispielsweise Zwischenspeicherung von Dokumenten und Zugriffssteuerung, zur Verfügung stellt. Durch den Einsatz eines Proxyservers kann die Systemleistung verbessert werden, indem häufig abgerufene Daten, wie beispielsweise eine beliebte Webseite, direkt bereitgestellt werden. Darüber hinaus können Anforderungen, die der Besitzer des Internetzugangs als unerwünscht erachtet, wie beispielsweise unautorisierte Zugriffsversuche auf eigene Dateien, herausgefiltert und unterbunden werden. IEAK bietet die Möglichkeit, Proxyeinstellungen automatisch zu konfigurieren.

Q

R

RAS (Remote Access Service), DFÜ-Netzwerk
Ein Dienst, der für Mitarbeiter an Telearbeitsplätzen oder auf Reisen sowie für Systemadministratoren, welche die Server überwachen und verwalten, den Remotezugriff auf das Netzwerk ermöglicht.
Registrierung
Eine zentrale, hierarchisch strukturierte Datenbank zur Speicherung von Informationen über die Konfiguration eines Computers für ein oder mehrere Benutzer, Anwendungen und Hardwaregeräte. Die Registrierungsdatenbank enthält Daten, auf die das Betriebssystem während des Betriebs fortlaufend zugreift. Zu diesen Daten gehören Profile für jeden Benutzer, für alle auf dem Computer installierten Anwendungen und die mit diesen Anwendungen verknüpften Dokumenttypen, Eigenschaften für Ordner und Symbole für Anwendungen, Informationen zu den Hardwarekomponenten des Systems und dazu, welche Anschlüsse verwendet werden.
Registrierungsschlüssel
Ein Bezeichner für einen Datensatz oder eine Gruppe von Datensätzen in der Registrierungsdatenbank.
Richtlinie
Siehe Systemrichtlinien.

S

Schnellstartsymbolleiste
Ein spezieller Symbolleistenbereich neben der Schaltfläche Start, der dazu dient, Benutzern einen schnellen Zugriff auf das Web, E-Mail, den Desktop und andere grundlegende Systemdienste sowie auf Programme oder andere häufig verwendete Symbole zu ermöglichen. Diese Symbolleiste steht generell dem Benutzer zur eigenen Gestaltung zur Verfügung.
Serverbasierte Anmeldung
Siehe Anmeldung.
Serverlose Anmeldung
Siehe Anmeldung.
Setup im Batchmodus
Ausführen des Setup-Programms über einen Befehl in einer Batchdatei oder direkt von der Eingabeaufforderung aus.
Shell-Integration
Eine der beiden Komponenten, die bei der Windows Desktop-Aktualisierung installiert werden. Über die Shell-Integration können Benutzer die Computer auf dieselbe Weise durchsuchen, wie das Internet. Die Menüs Wechseln zu und Favoriten stehen den Benutzern überall zur Verfügung.
Sicherheitszone
Bei Internet Explorer ein Segment des Internets oder des Intranets, dem eine bestimmte Sicherheitsstufe zugewiesen wird, in Abhängigkeit von dem Vertrauen des Administrators in die Inhalte dieser Website. Über Sicherheitszonen kann der Administrator den Zugang zu bestimmten Websites einschränken.
Single-Disk Branding
Anpassen einer vorhandenen Installation von Internet Explorer, einschließlich der Internetanmeldung bei einem ISP, ohne dass Internet Explorer erneut installiert werden muss. Die Option bietet Ihnen nicht die Möglichkeit, angepasste Komponenten zu Paketen zusammenzustellen und zu installieren.
Skriptdatei
Siehe Autoproxy-Skript.
SMTP (Simple Mail Transfer Protocol)
Ein Protokoll zur Übermittlung und zum Senden von E-Mail-Nachrichten von Server zu Server. Für das Abrufen der Nachrichten wird ein anderes Protokoll (beispielsweise POP3) verwendet. Vergleichen Sie hierzu POP3.
SPA (Secure Password Authentication - Sichere Kennwortauthentifizierung)
Ein Protokoll, bei dem der Server verschlüsselte Kennwörter zur Bestätigung der Benutzerkennung verwendet.
SSL (Secure Sockets Layer)
Ein Protokoll, das mittels Verschlüsselung und Entschlüsselung sicheren Datenaustausch gewährleistet. Dieses Protokoll gewährleistet Vertraulichkeit bei der Datenübertragung in Netzwerken durch eine Kombination von Verschlüsselungsverfahren mit öffentlichem Schlüssel und der Mengenverschlüsselung.
Startseite
Im Internet Explorer ist die Startseite die Seite, die angezeigt wird, wenn der Browser gestartet wird. Im Gegensatz dazu wird "Homepage" als allgemeine Bezeichnung für die Hauptseite einer Website verwendet, welche üblicherweise ein Hauptmenü oder Inhaltsverzeichnis mit Links zu anderen Seiten innerhalb der Website enthält.
Systemrichtlinien
Einstellungen, mit denen der Administrator das Verhalten von Programmen, Netzwerkressourcen und dem Betriebssystem für Benutzer und Computer in einer Organisation festlegen und steuern kann.

T

TCP/IP (Transmission Control Protocol/Internet Protocol)
Eine Gruppe von Protokollen, mit deren Hilfe Computer miteinander Daten austauschen können.
Titelleistentext
Der Text in der Titelleiste eines Anwendungsprogramms. Bei einigen Komponenten eines Internet Explorer-Pakets, nämlich dem Browser selbst, dem Autorun-Bildschirm, Outlook Express und dem MSN Messenger Service-Client, kann der Titelleistentext mit Branding-Informationen versehen werden.

U

URL (Uniform Resource Locator)
Eine Webadresse, beispielsweise "http://www.microsoft.de". Siehe Adresse.
URL für automatische Konfiguration
Der Speicherort der .INS-Datei mit den Interneteinstellungen zur Konfiguration des Browsers in diesem Paket. Mit Hilfe der .INS-Datei können Sie die Einstellungen mehrerer Benutzer von einem zentralen Ort aus steuern.
Usenet
Gruppen im Usenet werden auch als Newsgroups bezeichnet. Die Usenet-Gruppen sind textbasierte Newsgroups, die als "Schwarzes Brett" dienen, über das alle Benutzer Nachrichten bereitstellen können.

V

Verbindungseinstellungen
Einstellungen, die Internet Explorer zum Herstellen der Verbindung mit dem Internet verwendet. Die Verbindungseinstellungen bestehen üblicherweise aus einer Reihe von Einstellungen für DFÜ-Netzwerkeinträge wie Proxyeinstellungen, Konten, Kennwörter und Modemkonfigurationen.
Verbindungs-Manager
Ein vielfältig einsetzbares Wählprogramm für Internetclients, das Sie mit Hilfe von CMAK anpassen können.
Verbindungs-Manager-Profil
Ein Verfahren zur Automatisierung von DFÜ-Verbindungen, ähnlich wie DFÜ-Netzwerkeinträge.
Verbreitung
Der Prozess der flächendeckenden Verteilung und Installation eines Softwareprogramms in der ganzen Organisation. Zu unterscheiden von der Softwarepilotierung, wo bestimmte Software zunächst zu Testzwecken einer kleineren Gruppe von Benutzern zur Verfügung gestellt wird, damit diese Probleme ermitteln und bewerten können, die möglicherweise bei der tatsächlichen Verteilung auftreten.
Verschlüsselung
Ein Verfahren zur Chiffrierung von Daten, damit nur autorisierte Personen diese anzeigen oder verwenden können.
Versionsverwaltung
Es gibt zwei verschiedene Arten der Versionsverwaltung für Internet Explorer: Jedem Internet Explorer-Paket wird eine Versionsnummer zugewiesen. Durch diese Art der Versionsverwaltung kann sichergestellt werden, dass neuere Versionen eines Pakets nicht durch ältere Versionen desselben Pakets überschrieben werden. Auch die einzelnen Komponenten in Internet Explorer tragen Versionsnummern, damit eine Komponente nicht gedownloadet oder installiert wird, wenn sie auf dem Clientcomputer bereits vorhanden ist. Die Versionsnummer besteht aus einem Zwei-Buchstaben-Code, über den der Modus angegeben wird, in dem das IEAK-Paket erstellt wurde (IC für ICP, IS für ISP bzw. CO für Firmenadministratoren).

W

Wasserzeichen
Bitmap, die im Hintergrund der Internet Explorer-Symbolleiste angezeigt wird. Weisen Sie dem Wasserzeichen eine Farbe zu, die den Text oder die Grafiken der Symbolleistenschaltflächen nicht überdeckt.
Webansichten für Ordner
Administratoren können das Erscheinungsbild des Arbeitsplatzes und der Systemsteuerung auf den Computern ihres Unternehmens anpassen, indem Sie die HTTP-Dateien bearbeiten, die für diese als Vorlage dienen. Das Feature zum Anzeigen von Ordnern als Website setzt voraus, dass die Windows Desktop-Aktualisierung installiert ist.
Webpfad
In Zusammenhang mit IEAK ist der Webpfad der für die Verbindung des Browsers mit den Installationsdateien von Internet Explorer verwendete Pfad. Ein Beispiel dafür wäre "www.meinefirma.com/ie5".
"Willkommen"-Seite
Die Seite, die beim ersten Ausführen von Internet Explorer angezeigt wird. Danach wird bei jedem Start von Internet Explorer die Startseite des Benutzers angezeigt.
Windows Desktop-Aktualisierung
Die Windows Desktop-Aktualisierung besteht aus zwei Komponenten: Active Desktop und Shell-Integration. Die Windows Desktop-Aktualisierung ist im Lieferumfang von Windows 98, Windows 98, Zweite Ausgabe, Windows Millennium Edition und Windows 2000 bereits enthalten. Daher wird diese Komponente auf Computern mit einem der oben aufgeführten Betriebssysteme nicht erneut installiert.
Windows Update Setup-Programm
Das Setup-Programm zur Installation von Internet Explorer und anderen Internetkomponenten. IEAK ermöglicht das Anpassen von Windows Update Setup, um dem Benutzer einen wirkungsvollen Eindruck von Ihrem Unternehmen zu vermitteln.
WINS (Windows Internet Name Service)
Ein Namensauflösungsdienst, der Computernamen in Windows-Netzwerken in IP-Adressen für Routingumgebungen umwandelt. Der Server, auf dem dieser Dienst ausgeführt wird, übernimmt die Namensregistrierungen, Abfragen und Veröffentlichungen.
WPAD (Web Proxy AutoDiscovery)
Ein Standardnetzwerkprotokoll, über das Internetclientsoftware automatisch Zwischenspeicherungsdienste in einem Netzwerk ermittelt und mit diesen kommuniziert.

X

Y

Z

Zertifikat
Siehe Digitales Zertifikat.
Zertifizierungsstellen (CAs)
Firmen wie z. B. VeriSign oder GTE, die digitale Zertifikate herausgeben. Diese Firmen sind anerkannte Quellen zur Überprüfung der Authentizität von Zertifikaten; ihre Aufgabe ist es, Softwarepakete digital zu signieren und somit zu authentifizieren.
Zone
Siehe Sicherheitszone.
Zwischenspeicher (Cache)
Ein Bereich auf der Festplatte, in dem Bild-, Text- und andere Dateien gespeichert werden, die der Benutzer vorher im Internet angezeigt hat.


Downloaden und Verteilen Ihres angepassten Browserpakets

Nachdem Sie auf Fertig stellen geklickt haben, erstellt der Assistent Ihr angepasstes Browserpaket. In den meisten Fällen bestehen die nächsten Schritte aus dem Vorbereiten der Dateien zum Download aus dem Web und dem anschließenden Vorbereiten der entsprechenden Medien (beispielsweise CDs) für den Vertrieb. Weitere Informationen über Medienformate finden Sie unter Auswahl der Medien.

Programme und Kabinettdateien, die über das Internet vertrieben werden bzw. über ein Intranet, das nicht speziell konfiguriert wurde, müssen digital signiert werden. Digitale Signaturen geben an, woher Programme kommen, und gewährleisten, dass die betreffenden Programme nicht verändert wurden. Weitere Informationen finden Sie unter Signieren Ihrer Programme. Wenn Sie festgelegt haben, dass Ihre Programme und angepassten Dateien vom Assistenten für die Internet Explorer-Anpassung signiert werden, findet dieser Vorgang während des Erstellens der Pakete durch den Assistenten statt. Haben Sie keine solche Festlegung getroffen, müssen Sie Ihre Programme und Dateien signieren, bevor Benutzer diese downloaden.

Die Schritte, die Sie nun zum Vertrieb Ihres angepassten Browsers durchführen müssen, sind je nach Ihrer Funktion und den für den Vertrieb verwendeten Medien unterschiedlich. Weitere Informationen erhalten Sie, wenn Sie unten auf den entsprechenden Link klicken:

  • Internetinhaltsanbieter (ICP) oder -entwickler
  • Internetdienstanbieter (ISP)
  • Firmenadministrator


Was ist eine Kabinettdatei?

Eine Kabinettdatei (.CAB) ist eine Bibliothek mit komprimierten Dateien, die als einzelne Datei gespeichert ist. Kabinettdateien werden verwendet, um Installationsdateien zu organisieren, die auf dem Computer des Benutzers kopiert werden. Eine große komprimierte Datei kann auf mehrere .CAB-Dateien verteilt werden.

Seit einigen Jahren verwendet Microsoft .CAB-Dateien, um Software zu komprimieren, die auf Disketten vertrieben wird. Ursprünglich wurden diese Dateien eingesetzt, um die Anzahl der Disketten zu verringern, die mit einem Produkt ausgeliefert wurden. Heute werden .CAB-Dateien verwendet, um die Dateigröße und die damit verbundene Downloadzeit für Webinhalte zu reduzieren, die sich im Internet oder auf Intranetfirmenservern befinden.

Eine .CAB-Datei ist normalerweise eine Informationsdatei (.INF), die weitere Installationsinformationen zur Verfügung stellt. Die .INF-Datei kann sich auf .CAB-Dateien oder auf andere Dateien an anderen URLs beziehen.

IEAK enthält eine Sammlung von Tools, die Sie beim Erstellen von Kabinettdateien und beim Arbeiten mit der IExpress-Technik unterstützen.

Das ".CAB"-Format

Jede in einer .CAB-Datei komprimierte Datei wird vollständig in einem einzelnen Ordner gespeichert. Eine .CAB-Datei kann einen oder mehrere Ordner oder Teile eines Ordners enthalten. Daher wird eine komprimierte Datei, auch wenn sie nicht in eine .CAB-Datei passt, in einem Ordner gespeichert, der mehrere .CAB-Dateien umfasst. Eine solche Reihe von .CAB-Dateien bildet eine Menge. Jede .CAB-Datei enthält Namensinformationen für die logisch benachbarten .CAB-Dateien.

Das .CAB-Format, das für den Download von Internet Explorer-Komponenten verwendet wird, ist ein nichtproprietäres Format, das auf Lempel-Ziv-Komprimierung beruht.

Digitale Signaturen

Eine .CAB-Datei kann wie ein ActiveX-Steuerelement digital signiert sein. Eine digitale Signatur bietet Softwareentwicklern Sicherheit. Die Signatur verbindet den Namen eines Softwarevertreibers mit einer bestimmten Datei. .CAB-Dateien können unter Verwendung der Authenticode™-Technologie signiert werden.

Die Verwendung von .CAB-Dateien kann Vorteile für die Endbenutzer bringen, da mehrere Dateien mit einem einzelnen Zertifikat gedownloadet werden können, das einem Benutzer vor dem Download präsentiert wird. Informationen über diese Technologie sind im MSDN Online Web Workshop erhältlich.

Wenn Sie Ihr Steuerelement als "Sicher für Scripting" kennzeichnen, informieren Sie Benutzer damit, dass ein Skript auf einer HTML-Seite Ihr Steuerelement nicht verwenden kann, um Schaden auf Ihrem Computer zu verursachen oder Informationen abzufragen, die nicht freiwillig gegeben wurden.

Wenn Sie Ihr Steuerelement als "Sicher für Initialisierung" markieren, informieren Sie Benutzer damit, dass HTML-Autoren ihren Computern keinen Schaden zufügen können, wenn sie Ihrem Steuerelement bei der Initialisierung durch die Seite ungültige Daten übermitteln.

Anmerkung

  • Es ist möglich, die Tools zur Codesignatur zu verwenden, um vollständige .CAB-Dateien unter Verwendung eines digitalen Zertifikats zu signieren.


Arbeiten mit Channels

Mit dem Channels-Feature in Internet Explorer können Sie angeben, welche Inhalte gedownloadet werden sollen und wann dies geschieht. Sie können die aktuellsten Nachrichten und Firmeninformationen zur Verfügung stellen. Wenn Ihre Benutzer ein Update von Internet Explorer 4 durchführen oder Windows 98 installiert ist, können sie Channels in einer Channelleiste auf ihrem Desktop anzeigen.

Ein Channel stellt eine Website dar, die für Programme, die Informationen empfangen, aktiviert wurde. Der Mechanismus, der dies ermöglicht, ist die .CDF (Channel Definition Format)-Datei. Sie können für Channels die Inhalte verwenden, die bereits vorhanden sind, beispielsweise Webseiten und Grafiken. Möglicherweise möchten Sie diese Inhalte anders strukturieren, damit sichergestellt ist, dass Benutzer die richtigen Inhalte in organisierter Form erhalten.

Wenn Sie Channels für mehrere Betriebssysteme erstellen, sollten Sie sicherstellen, dass Ihre Inhalte richtig angezeigt werden und auf allen Plattformen lesbar sind.

Channeldefinitionsformatdatei

Die .CDF-Datei enthält einen Index der Ressourcen, die in einem Channel zur Verfügung stehen, sowie einen empfohlenen Zeitplan für die Aktualisierung des Channels auf dem lokalen Computer. Außerdem beinhaltet die .CDF-Datei bestimmte Tags, die Logos, die zu aktualisierenden Dateien und den Aktualisierungsplan angeben.

Wenn die .CDF-Datei für ein Objekt des Channels das Element ABSTRACT enthält, können Benutzer eine Beschreibung des jeweiligen Objekts anzeigen. Zusammenfassungen werden als QuickInfo angezeigt, wenn der Benutzer den Cursor über einem Objekt positioniert. Webpublisher können dieses Feature einsetzen, um den Inhalt einer bestimmten Webseite zu beschreiben oder die Aufmerksamkeit der Benutzer zu wecken und sie anzuregen, sich diese Inhalte sofort anzusehen.

Anmerkung

  • Wenn Sie eine .CDF-Datei für einen angepassten Channel in IEAK angeben, sollte die .CDF-Datei nicht das LOGO-Element mit IMAGE- oder ICON-Attributen enthalten.

Weitere Ressourcen

Das .CDF-Format basiert auf XML (eXtensible Markup Language), einem Standard für das Speichern und Übertragen strukturierter Daten. Ebenso wie ein HTML-Dokument enthält ein auf XML basierendes Dokument Text, der mit Tags versehen ist. Weitere Informationen und Beispiele finden Sie im MSDN Online Web Workshop.


Schemadarstellung zu Systemrichtlinien und Einstellungen

 Systemrichtlinien und Einstellungen


Schemadarstellung zur Automatischen Versionssynchronisierung (AVS)

 Automatische Versionssynchronisierung (AVS)


Schemadarstellung zur Funktionsweise der automatischen Konfiguration

 So funktioniert die automatische Konfiguration


Schemadarstellung zum Bereitstellen von Dateien für die Distribution

 Bereitstellen von Dateien für die Distribution


Schemadarstellung zur Erstellung angepasster Pakete durch IEAK

 Erstellung angepasster Pakete durch IEAK


Internetanmeldung mit dem Assistenten für den Internetzugang

Internet-
dienstanbieter

Erstellen von Bildschirmen für die Anmeldung mit dem Assistenten für den Internetzugang

Alle Seiten des Assistenten für den Internetzugang müssen die unter Codierungsanforderungen für die Bildschirme des Assistenten für den Internetzugang beschriebenen Standards einhalten.

Erstellen des Bildschirms "Name und Adresse" für die Anmeldung mit dem Assistenten für den Internetzugang

Wenn der Benutzer eine Verbindung zu Ihrem Anmeldeserver herstellt, wird auf dem Anmeldeserver zunächst der Bildschirm Name und Adresse angezeigt.

Der HTML-Bereich Name und Adresse wird in einem Frame im Assistenten angezeigt. Die Abmessungen des Frames betragen 444x273 Pixel. Es werden keine Bildlaufleisten angezeigt, wenn die HTML-Seite diese Abmessungen überschreitet.

Erstellen des Bildschirms "Rechnungsoptionen" für die Anmeldung mit dem Assistenten für den Internetzugang

Im Bildschirm Rechnungsoptionen können Sie die verschiedenen Optionen der Abrechnung für den Dienst darstellen, unter denen der Benutzer wählen kann. Die Optionen stehen in einem HTML-Formular innerhalb eines Frames im Fenster für den Assistenten zur Verfügung.

Der Benutzer sollte die Möglichkeit haben, die gewünschte Option mittels eines HTML-Optionsfeldes zu aktivieren. Standardmäßig muss eines der Optionsfelder aktiviert sein. Ist es erforderlich, mehrere Optionen zu aktivieren, können Sie auch HTML-Kontrollkästchen in den Frame einfügen.

Die HTML-Datei mit den Rechnungsoptionen, die Sie zur Verfügung stellen möchten, wird in einem Floating Frame im Assistenten angezeigt. Die Abmessungen des Frames betragen 444x273 Pixel. Es werden keine Bildlaufleisten angezeigt, wenn die HTML-Seite diese Abmessungen überschreitet.

Erstellen des Bildschirms "Zahlungsmethode" für die Anmeldung mit dem Assistenten für den Internetzugang

Auf der Seite Zahlungsmethode geben die Benutzer ihre gewünschte Zahlungsmethode für den Internetdienst an. Der ISP entscheidet, welche Zahlungsmethoden in der betreffenden Liste angeboten werden. Die Informationen werden in dem Formular gesammelt, das in einem Frame unter der Auswahl angezeigt wird. Diese ändert sich je nach der in der Liste gewählten Zahlungsoption.

Sie können folgende Zahlungsmethoden anbieten:

  • Kreditkarte (Sie können den Kartentyp angeben, wie z. B. Visa oder American Express)
  • Kundenkarte
  • Rechnung
  • Über Telefonrechnung

Erstellen des ISP-Bildschirms "Kontoanmeldung/E-Mail" des für die Anmeldung mit dem Assistenten für den Internetzugang

Die vierte Anmeldeserverseite ist die Seite Kontoanmeldung/E-Mail, auf welcher der Benutzer eine ID für die Kontoanmeldung und/oder E-Mail sowie ein Kennwort angeben kann.

Die vom Anmeldeserver übermittelte HTML-Seite Kontoanmeldung/E-Mail wird in einem Floating Frame im Assistenten angezeigt. Die Abmessungen des Frames betragen 444x273 Pixel. Es werden keine Bildlaufleisten angezeigt, wenn die HTML-Seite diese Abmessungen überschreitet.

Erstellen des ISP-Bildschirms "POP-Auswahl" des für die Anmeldung mit dem Assistenten für den Internetzugang

Auf der Seite POP-Auswahl wählen die Benutzer eine lokale Rufnummer für den Internetzugang aus.

Die vom ISP-Anmeldeserver übermittelte HTML-Seite POP-Auswahl wird in einem Floating Frame im Assistenten angezeigt. Die Abmessungen des Frames betragen 444x273 Pixel. Es werden keine Bildlaufleisten angezeigt, wenn die HTML-Seite diese Abmessungen überschreitet.

Es sollte vermieden werden, den Benutzer ein zweites Mal zum Eingeben einer Vorwahl oder Rufnummer aufzufordern. Alle Vorwahl- oder Rufnummernfelder in dem Frame sollten mit den Informationen vorausgefüllt sein, die der ISP-Anmeldeserver bereits aus dem Formular Name/Adresse erhalten hat.

Erstellen des ISP-Bildschirms "Allgemeine Geschäftsbedingungen" des für die Anmeldung mit dem Assistenten für den Internetzugang

Auf dem Bildschirm Allgemeine Geschäftsbedingungen des Internetdienstanbieters (ISP) werden die Vertragsvereinbarungen angezeigt, die der Benutzer lesen muss, um den Dienst zu abonnieren. Um sicherzustellen, dass der Benutzer die Vereinbarungen akzeptiert, wird die ICW-Schaltfläche Weiter erst angezeigt, nachdem der Benutzer auf Ich stimme dem Vertrag zu geklickt hat.

Durch Klicken auf die Schaltfläche Kopie speichern kann der Benutzer die HTML-Datei mit den Vereinbarungen speichern und zu einem späteren Zeitpunkt anzeigen. Nach dem Klicken auf die Schaltfläche wird der Benutzer aufgefordert, einen Dateinamen und Pfad zum Speichern der Datei anzugeben.

Die vom ISP-Anmeldeserver übermittelte HTML-Seite Allgemeine Geschäftsbedingungen wird in einem Floating Frame mit einer 2 Pixel breiten Umrandung im Assistenten angezeigt. Die Breite des Frames beträgt 426 Pixel (ohne die 2 Pixel breite Umrandung und die vertikale Bildlaufleiste). Es wird keine horizontale Bildlaufleiste angezeigt, wenn die HTML-Seite diese Abmessungen überschreitet.

Am Anfang des Bildschirms Allgemeine Geschäftsbedingungen sollte sich der Titel des Dokuments und eine Anleitung befinden, wie der Benutzer das Vertragsdokument auf der ISP-Website des finden kann, wenn er es erneut anzeigen oder ausdrucken möchte.

Anmerkung

  • Für diesen Bildschirm sind keine Eingabehilfenanforderungen verfügbar, da hier keine HTML-Formularelemente erlaubt sind.


Erstellen der Datei "Icwsign.htm", der Fehlerbildschirme und des Bildschirms "Fertig stellen" für die Anmeldung mit dem Assistenten für den Internetzugang

Für die Anmeldung mit dem Assistenten für den Internetzugang sollten Sie einen Einstiegsbildschirm für den Benutzer, nämlich Icwsign.htm, die Fehlerseiten sowie die Seite Fertig stellen entwerfen.

Der erste Bildschirm: "Icwsign.htm"

Der erste Bildschirm, der nach der Installation von Internet Explorer und dem Neustart des Computers dem Benutzer angezeigt wird, ist die Seite Icwsign.htm mit Branding-Informationen. Auf dieser Seite findet der Benutzer eine Begrüßungsmeldung des Internetdienstanbieters und erhält eine der folgenden Aufforderungen: (a) zum Starten des Anmeldevorgangs auf Weiter zu klicken, falls für die Anmeldung nur eine einzige ISP-Datei erforderlich ist, oder (b) zunächst die Stadt oder Region anzugeben, in der die Einwahl stattfindet, damit der Assistent für den Internetzugang die entsprechende Datei des ISP-Anmeldeservers auswählen kann.

Klickt der Benutzer auf Weiter, wählt der Assistent für den Internetzugang die entsprechende Nummer und verbindet den Benutzer mit dem ISP-Anmeldeserver des. Diese Seite wird in IEAK festgelegt und in Ihre angepasste Internet Explorer-Version aufgenommen. Sie wird nicht auf dem Anmeldeserver geführt.

Fehlerseiten für die Anmeldung mit dem Assistenten für den Internetzugang

Sind die an den Anmeldeserver übergebenen Daten zu irgendeinem Zeitpunkt während des Anmeldevorgangs ungültig, kann der Server eine HTML-Seite mit einer aussagekräftigen Fehlermeldung anzeigen. Wenn der Kunde beispielsweise einen E-Mail-Namen anfordert, der bereits vergeben ist, können Sie Alternativen vorschlagen und den Kunden bitten, sich für einen andere E-Mail-Adresse zu entscheiden.

Die vom ISP-Anmeldeserver gesendete HTML-Fehlerseite wird in einem Floating Frame im Assistenten angezeigt. Die Abmessungen des Frames betragen 444x273 Pixel. Es werden keine Bildlaufleisten angezeigt, wenn die HTML-Seite diese Abmessungen überschreitet.

Der Frame sollte Text enthalten, der den Benutzer darüber informiert, dass die eingegebenen Daten ungültig waren, und Formularelemente anbieten, in welche der Benutzer die neuen Daten eingeben kann.

Informationen über HTML-Design und erforderliche Formularelemente finden Sie unter Codierungsanforderungen für die Bildschirme des Assistenten für den Internetzugang.

Die Seite "Fertig stellen" für die Anmeldung mit dem Assistenten für den Internetzugang

Klickt der Benutzer auf der ISP-Seite Fertig stellen auf Weiter, wird die .INS-Datei verarbeitet, und der Computer wird für das neue Internetkonto konfiguriert. Nach diesem Schritt wird der letzte Bildschirm des Assistenten für den Internetzugang angezeigt, die den Benutzer darüber informiert, dass die Internetverbindung geschaltet ist, und ihm die ersten Schritte zum Browsen im Internet erläutert. Diese Seite bietet keine durch den Internetdienstanbieter konfigurierbare Oberfläche.

Die Seite Fertig stellen bietet außerdem die Möglichkeit, sofort mit dem Browsen zu beginnen, sofern der Benutzer das Kontrollkästchen Für sofortiges Browsen aktiviert.

Über den Wert StartURL in der .INS-Datei können Sie die Seite angeben, die der Browser beim ersten Öffnen anzeigt.

Verwenden der ".INS"-Datei zum Konfigurieren eines Benutzer-Referenzcomputers

Nachdem der Benutzer den Anmeldevorgang abgeschlossen hat, muss der Anmeldeserver Informationen zum Konfigurieren des Benutzercomputers für den Internetzugang zurückgeben. Die .INS-Datei, die am Ende des Anmeldevorgangs gedownloadet wurde, enthält diese Informationen.


Suchen nach weiteren Informationen im Internet

Im Internet können Sie weitere Informationen erhalten und Ihr IEAK-Konto verwalten.

Weitere Informationen hierzu finden Sie in der IEAK-Website. Diese Website wird regelmäßig aktualisiert, sodass Sie dort immer die neuesten Informationen finden.


Erstellen mehrerer Versionen des Browsers

Verwenden Sie dieses Verfahren, um verschiedene Versionen des Browsers zu erstellen (beispielsweise Versionen mit verschiedenen Mail-Servern), bei denen viele Einstellungen gleich sind.

Der Assistent für die Internet Explorer-Anpassung zeigt die Einstellungen an, die Sie für die Originalversion Ihres angepassten Browsers festgelegt haben. Diese Einstellungen werden in der Datei Install.ins gespeichert. Durch Umbenennen der .INS-Dateien können Sie schnell Änderungen an jeder Version Ihres angepassten Browsers vornehmen.

  1. Erstellen Sie unter Verwendung des Assistenten eine Version Ihres angepassten Browsers.
  2. Benennen Sie die Datei Install.ins um, die sich im Ordner CIE\Custom befindet. Wenn Sie beispielsweise eine Version für Benutzer in Texas benötigen, können Sie die Datei Texas.ins nennen.
  3. Öffnen Sie die Datei Signup.htm im Ordner CIE\Custom. Erstellen Sie in dieser Datei einen Link zur Datei Texas.ins.
  4. Führen Sie den Assistenten nochmals aus, und geben Sie denselben angepassten Ordner als Zielverzeichnis für die Ausgabedateien an.

    5. Stellen Sie sicher, dass die Assistenteneinstellungen für alle Versionen gleich sind. Ändern Sie nur die folgenden Einstellungen für jede Version:

    • Logo
    • Titelleistentext
    • Favoriten
    • Linkleiste
    • Startseite und Suchleiste
    • Mailserver und Domäne
  5. Wiederholen Sie die Schritte 2 bis 4, bis Sie alle Versionen Ihres angepassten Browsers erstellt haben.

Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.


Erstellen einer ".ISP"-Datei

Wenn Sie in Ihr angepasstes Browserpaket einen Anmeldevorgang integrieren, stellt eine Internetanmeldungsdatei (.ISP) mit dem Namen Signup.isp Informationen für die Einwahl zu Ihren Internetdiensten bereit. Bei Anwendung einer serverbasierten Anmeldungsmethode enthält diese Anmeldungsdatei außerdem einen Link zum URL des Serverskripts, das Ihre .INS-Konfigurationsdatei erzeugt. Das IEAK-Toolkit enthält ein Tool, ISP-Datei-Assistenten, mit dem Sie Ihre .ISP-Datei automatisch erstellen können.

Zur Installation des ISP-Datei-Assistenten doppelklicken Sie auf Filewiz.exe im Ordner \<IEAK-Programmordner>\Toolkit\ISP\Wizard.

So starten Sie den ISP-Datei-Assistenten
  • Klicken Sie auf das Menü Start, zeigen Sie auf Programme, und klicken Sie dann auf ISP-Datei-Assistent.
  • Folgen Sie den Anweisungen des Assistenten, um eine ISP-Datei mit Ihren angepassten Einstellungen zu erstellen.

Anmerkung

  • Sie können verhindern, dass eine Standardortsvorwahl vorgegeben wird, indem Sie ein Flag in der .ISP-Datei entsprechend setzen. Die Syntax für dieses Flag lautet:
    Dial_As_Is=Yes

    Dieses Flag ist beispielsweise dann sinnvoll, wenn einige Benutzer von einem anderen Vorwahlbereich als der Standardortsvorwahl aus anrufen. Falls die Benutzer nicht wissen, dass die Standardortsvorwahl von ihrem tatsächlichen Vorwahlbereich abweicht, könnten unerwartet Gebühren für Ferngespräche anfallen.


Ihr Leitfaden zu Microsoft Product Support Services

Wenn Sie eine Frage haben

Wenn Sie Fragen zu Ihrem Microsoft-Produkt haben, empfiehlt es sich, im Handbuch und der Online-Hilfe nachzusehen. Weitere technische Hilfestellungen sowie Informationen erhalten Sie auch im Internet auf unseren Online Support-Seiten. Wenn Sie telefonische Unterstützung benötigen, wenden Sie sich bitte an den Technischen Support von Microsoft (Microsoft Product Support Services).

Wenn Sie anrufen, sollten Sie sich an Ihrem Computer befinden und die Produktdokumentation griffbereit vor sich haben. Bitte geben Sie bei telefonischen Anfragen Folgendes an:

  • Die Microsoft Produkt-Bezeichnung und die Versionsnummer des von Ihnen verwendeten Produkts.
  • Die von Ihnen benutzte Hardware (ggf. einschließlich der Netzwerkhardware).
  • Das von Ihnen eingesetzte Betriebssystem.
  • Den genauen Wortlaut von eventuell am Bildschirm angezeigten Meldungen.
  • Eine Beschreibung des Problems und der aktuellen Arbeitsschritte, bevor das Problem auftrat.
  • Eine Beschreibung Ihres Vorgehens beim Versuch, das Problem selbst zu lösen.

Microsoft Product Support Services

Microsoft unterstützt Sie mit einer breiten Palette von Dienstleistungen: Im Internet finden Sie nicht nur den kostenfreien Online Support, sondern auch Informationen zu unserem umfangreichen deutschsprachigen Supportangebot:

www.microsoft.com/germany/support

Kostenfreier Online Support

Im Zentrum der Microsoft Product Support Services steht der kostenlose Online Support. Hier erhalten alle Anwender schnell und einfach Informationen und Hilfe zur Selbsthilfe für den optimalen Einsatz der Microsoft-Software. Der Online Support ist rund um die Uhr kostenlos im Internet verfügbar und bietet Ihnen folgende Services:

  • Knowledge Base - Kein Problem ist zu schwer, kein Begriff zu schwierig - in der deutschsprachigen Knowledge Base finden Sie Tausende von Artikeln unserer Supportspezialisten. Der schnellste Weg zur Problemlösung rund um die Uhr: Einfach Stichwort eingeben und Produkt auswählen.
  • Frequently Asked Questions - Sie haben Fragen - wir die Antworten. In den "Frequently Asked Questions" (FAQs) finden Sie eine Sammlung der Problemstellungen, die am häufigsten an unsere Supportmitarbeiter herangetragen werden. Gerade wenn Sie die exakte Ursache Ihres Problems nicht kennen, eignen sich die FAQs als erste Anlaufstelle.
  • Troubleshooter - Der Troubleshooter ist Ihr Supportassistent, der Ihr Problem durch Fragen mit verschiedenen Antwortmöglichkeiten eingrenzt und so die Lösung vereinfacht.
  • Downloads - Damit Sie immer auf dem neuesten Stand der Entwicklung sind, bietet unser Downloadbereich aktuelle Updates, Produktergänzungen und Service Packs. Auch kostenlose Software und Betaversionen halten wir dort für Sie bereit.
  • Newsgroups - Zu vielen Microsoft-Produkten gibt es eine eigene Newsgroup, in denen sich unsere deutschsprachigen Kunden gegenseitig helfen. Mit einem speziellen Programm fördern wir ein hohes fachliches Niveau und eine freundliche Atmosphäre in unseren Newsgroups. Probieren Sie es aus: Schildern Sie dort Ihr Problem, wenn Sie einmal nicht weiterkommen.

Sämtliche deutschsprachigen, webbasierten Dienstleistungen sind unter der folgenden Adresse verfügbar:

www.microsoft.com/germany/support

Hier finden Sie auch die professionellen Service-Desks für Entwickler, Microsoft-Handelspartner und IT-Spezialisten.

Kostenfreie technische Anfragen

Kunden, die Desktop-Betriebssysteme wie Windows 98, Desktop-Anwendungen wie Office 2000 oder Consumer Products wie Encarta, Money oder Spiele im Fachhandel erwerben, haben auch die Möglichkeit, zwei kostenlose Anfragen an unsere Supportspezialisten zu stellen - telefonisch und zukünftig auch via Internet. Egal ob Sie Fragen zur Installation oder Bedienung haben - hier wird Ihnen freundlich und schnell geholfen. Sie tragen nur die Telefonkosten (z.B. in Deutschland DM 0,24 pro Minute).

Das Angebot der kostenlosen technischen Anfragen an Microsoft gilt nicht für Software, die bereits auf einem neuen PC vorinstalliert war (sogenannte OEM-Lizenzen), und für Lizenzen, die im Rahmen von Lizenzierungsprogrammen für Unternehmen erworben wurden (z. B. OPEN, SELECT). In diesem Fall wenden Sie sich für kostenlose Unterstützung bitte an Ihren Händler oder den Hersteller des PCs. Die Adressen finden Sie in der Dokumentation zu Ihrem PC und für die gängigsten Hersteller auch online unter:

www.microsoft.com/germany/support

Sie erreichen uns von Montag bis Freitag zwischen 8:00 Uhr und 18:00 Uhr unter folgenden Rufnummern:

Wenn Sie von Deutschland aus anrufen: 01805/67 22 55*
Wenn Sie von Österreich aus anrufen: 01-502-22 22 55
Wenn Sie von der Schweiz aus anrufen: 0848/80-22 55

Zeiten und Verfügbarkeit des Supports unterliegen den aktuellen Bedingungen der Microsoft-Niederlassung in Ihrer Nähe und können - mit einer angemessenen Übergangszeit - von Zeit zu Zeit geändert werden.

Kostenpflichtige technische Anfragen

Egal ob Sie Ihre beiden kostenlosen Anfragen bereits genutzt haben oder Lizenzen ohne Anspruch auf kostenlose Unterstützung (etwa OEM-Lizenzen, OPEN, SELECT) einsetzen - wir lassen Sie nicht allein. Unsere Supportspezialisten beantworten Ihre Fragen in diesen Fällen gerne gegen Gebühr.

Wenden Sie sich für weitere Informationen bitte an die Vertragsberatung:

Wenn Sie von Deutschland aus anrufen: 01805/67 23 30*
Wenn Sie von Österreich aus anrufen: 01-502-22 23 30
Wenn Sie von der Schweiz aus anrufen: 0848/80-23 30

Aktuelle Informationen zu den Microsoft Product Support Services finden Sie auch im Internet:

www.microsoft.com/germany/support

*DM 0,24/Min. € 0,12/Min.

Weitere nützliche Microsoft Services

Das Microsoft TechNet -Abonnement: Fachwissen auf Abruf:

Wenn technische Schwierigkeiten auftreten, bleibt oft keine Zeit lange nach Lösungen zu suchen. Hilfe bietet hierbei das Microsoft TechNet-Abonnement: Sie erhalten jeden Monat eine CD-ROM mit dem aktuellen Fachwissen unserer IT-Spezialisten. So bekommen Sie einen Großteil technischer Probleme selbst in den Griff.

www.microsoft.com/germany/technet/cd

Wissen aus erster Hand - Microsoft Press

Der Microsoft Press Verlag bietet umfangreiche Buchreihen zu den wichtigsten Produkten von Microsoft an. Diese helfen Ihnen, Ihr Microsoft-Produkt schnell kennenzulernen und erfolgreich einzusetzen.

www.microsoft.com/germany/mspress

Allgemeine Informationen - Microsoft Direkt

Bei Fragen zur allgemeinen Produktverfügbarkeit, zu Preisen, Updatemöglichkeiten und dem Lieferumfang eines Produkts wenden Sie sich bitte an:

Für Deutschland:

Microsoft Direkt
Postfach 11 99
33410 Verl
Telefon: 01805/25 11 99
Fax: 01805/25 11 91

Für Österreich:

Microsoft InfoService
Postfach 262
1101 Wien
Telefon: 0 8000 123-345
Fax: (02236) 64595
Email: infoservice@microsoft.at
Montag - Freitag 9:00 - 17:00 Uhr

Für die Schweiz:

Microsoft Info-Service
Postfach
8021 Zürich
Email: infoservice@microsoft.ch
Fax: 01 / 311 72 27

Microsoft Niederlassungen

Deutschland:

Edisonstr.1
85713 Unterschleißheim
Telefon: 089 / 3176-0
Fax: 089 / 3176-1000

Österreich:

Microsoft Ges.m.b.H
Favoritenstraße 321
A-1100 Wien
Telefon: 01 - 610 64 - 0
Fax: 01 - 610 64 - 200

Schweiz:

Microsoft AG
Alte Winterthurerstr. 14a
CH-8304 Wallisellen / Zürich
Telefon: 01 / 839 61 11
Fax: 01 / 831 08 69


Hilfe zum Microsoft Internet Explorer Administration Kit

Internet Explorer Administration Kit

unterstützt Sie beim Anpassen, Einsetzen und Verwalten von Internet Explorer.

Präsentieren Sie das Web aus Ihrer persönlichen Sicht. In der Hilfe erhalten Sie alle erforderlichen Informationen.

square bullet Index durchsuchen

square bullet Volltextsuche durchführen

square bullet Hilfethemen drucken

(c) 1999-2000 Microsoft Corporation. Alle Rechte vorbehalten. Nutzungsbestimmungen.
Fotos: Rob Goldman/CORBIS


Firmenname und Anpassungscode

In diesem Bildschirm können Sie den Namen Ihrer Firma oder Organisation und den zehnstelligen Anpassungscode eingeben, und die Rolle auswählen, die Ihrem Lizenzvertrag entspricht..

Name der Firma
Geben Sie den Namen Ihrer Firma oder Organisation ein. Dieser Name ist nicht der Name, der in der Titelleiste des Browsers angezeigt wird. Diese Einstellung wird zu einem späteren Zeitpunkt im Assistenten für die Internet Explorer-Anpassung vornehmen.
Anpassungscode
Sie haben Ihren Anpassungscode mit der Post oder per E-Mail erhalten, nachdem Sie sich auf der IEAK Website registriert haben. Sie müssen sich bei Microsoft registrieren, um eine Lizenz zu erhalten, die Sie dazu berechtigt, Internet Explorer und zugehörige Produkte legal weiterzugeben.

Dieser Anpassungscode ist erforderlich. Sie können den Assistenten ohne diesen Code nicht ausführen. Bewahren Sie den Anpassungscode an einem sicheren Ort auf, und geben Sie ihn nicht an unbefugte Personen oder Organisationen weiter.

Anmerkungen

  • Der Assistent für die Internet Explorer-Anpassung wird zunächst mit einem Standardanpassungscode ausgeliefert. Mit diesem Anpassungscode können Sie alle Bildschirme des Assistenten anzeigen. Sie können jedoch kein angepasstes Installationspaket erstellen.
  • Wenn Sie Ihren Anpassungscode verloren haben, finden Sie auf der Website zu IEAK weitere Informationen.
Rolle/Position
Wählen Sie die Ihre Position aus, aus der sie angepasste Pakete mit IEAK erstellen und verteilen möchten.
  • Inhaltsanbieter (Content Provider)/Entwickler - wenn Sie eigene Inhalte, Verknüpfungen und Funktionen für Benutzer anbieten.
  • Dienstanbieter (Service Provider) - wenn Sie Internetdienste für Benutzer anbieten.
  • Firmenadministrator - wenn Sie Internetsoftware und -dienste für eine Firma oder eine sonstige Organisation verwalten.

Wichtig

  • Sie müssen die Rolle festlegen, die Ihrem Lizenzvertrag entspricht.


Auswahl der Sprache

Wählen Sie die gewünschte Sprache aus der Liste Zielsprache. Wenn die gewünschte Sprache nicht in der Liste enthalten ist, beenden Sie den Assistenten, legen Sie die IEAK-CD mit der gewünschten Sprachversion ein, und führen Sie dann den Assistenten erneut aus.

Sie müssen den Assistenten für die Internet Explorer-Anpassung für jede Sprachversion von Internet Explorer, die Sie erstellen möchten, einmal ausführen. Wenn Sie die Einstellungen für mehrere Versionen nutzen möchten, sollten Sie für alle Versionen stets den gleichen Zielordner angeben. Die lokalisierten Versionen werden dann in verschiedenen Unterordnern des Zielordners gespeichert.

Beispiel

Sei beispielsweise En der Zielordner für die englische und De der Zielordner für die deutsche Sprachversion.

Wenn Sie als Zielordner C:\Cie\Build1\ angeben, wird Ihr angepasstes Paket mit einer downloadbaren englischen Sprachversion von Internet Explorer in folgendem Ordner erstellt:
C:\Cie\Build1\Download\Win32\En

Ihr angepasstes Paket mit einer downloadbaren deutschen Sprachversion von Internet Explorer wird im folgenden Ordner erstellt:
C:\Cie\Build1\Download\Win32\De

Anmerkungen

  • Ihre Benutzer können Internet Explorer in einer Sprachversion installieren, die von der des auf ihrem Computer befindlichen Betriebssystems abweicht.
  • Wenn Sie jedoch die Windows Desktop-Aktualisierung als Komponente in Ihr Paket aufnehmen, muss die im IEAK-Paket verwendete Sprache mit der Sprache des Betriebssystems der Benutzer übereinstimmen. Wenn ein Benutzer versucht, den Browser und die Windows Desktop-Aktualisierung in einer anderen Sprache zu installieren, wird nur der Browser installiert.
  • IEAK 5.5 unterstützt nur die Plattform "Win32". Zum Anpassen von UNIX- und 16-Bit-Windows-Clients müssen Sie IEAK 5.0x verwenden.


Auswahl der Medien

In diesem Bildschirm legen Sie fest, welche Art von Medien für den Vertrieb des Pakets verwendet wird.

Download
Wählen Sie diese Option aus, um ein Paket zum Downloaden über ein Intranet oder über das Internet zu erstellen. Sie können die angepassten Pakete auf der Festplatte erstellen und sie dann auf einen Internetserver bzw. Intranetserver verschieben, wenn Sie Firmenadministrator sind. Die Pakete können auch direkt auf dem Server erstellt werden, indem Sie den Serverpfad als Zielordner angeben. Weitere Informationen finden Sie unter Pfade zu den Dateien.
CD-ROM
Wenn Sie eine Version auf CD erstellen, können Sie auch "Autorun"-Informationen festlegen. Diese Option ordnet Ihr angepasstes Paket in eine Reihe von Ordnern ein und bietet eine Autorun-Unterstützung in Form eines Bildschirms, den Benutzer sehen, wenn sie die CD-ROM in ihre Computer einlegen.
Flat (alle Dateien befinden sich in einem Verzeichnis)
Wenn Sie Ihr Paket in einem LAN erstellen oder wenn Sie planen, das Paket in ein LAN zu verschieben, wählen Sie diese Option aus, damit alle erforderlichen Dateien in einem Ordner unter dem Zielordner abgelegt werden (wie z. B. C:\Cie\Lan).
Single Disk Branding
Wählen Sie diese Option aus, um eine bestehende Installation von Internet Explorer anzupassen (Version 4.01 SP1, die mit Windows 98 und höheren Versionen ausgeliefert wurde). Diese Option erstellt die Datei Setup.exe im Ordner BrndOnly des Speicherorts Ihrer Version. Sie können diese Datei auf einem beliebigen Medium oder Server erstellen. Wenn die Datei ausgeführt wird, passt sie die Features von Internet Explorer an, ohne Internet Explorer zu installieren; hierzu gehört u. a. auch die Internetanmeldung für Internetdienstanbieter. Sie können weder angepasste Komponenten noch Verbindungs-Manager-Profile in ein Single-Disk Branding-Paket integrieren, da der Umfang des entstehenden Pakets den verfügbaren Speicherplatz auf einer Diskette übersteigen würde.

Wichtig

  • Falls Sie das Single-Disk Branding-Verfahren einsetzen, verwenden Sie nicht die Anmeldung mit dem Assistenten für den Internetzugang, wenn Sie absehen können, dass bestimmte Benutzer mit Internet Explorer 4.01 Service Pack 1 (oder früheren Versionen) arbeiten. Erstellen Sie statt dessen für diese Kunden ein separates Paket mit Anmeldung im Kioskmodus.


Dateiablage

Sie können den Zielordner, in dem das IEAK-Paket erstellt wird, sowie den Ordner, in den die Komponenten gedownloadet werden, ändern.

Zielordner
Der Zielordner ist der Ordner, in dem die angepassten Dateien abgelegt wurden, wenn der Assistent abgeschlossen ist. Sie können das Paket zunächst auf der Festplatte erstellen und es dann auf einen Internet- oder Intranetserver verschieben, oder Sie können es direkt auf dem Server erstellen.

Unterordner für jede lokalisierte Version werden im Zielordner erstellt, den Sie für jede Plattform und für jeden Medientyp angeben.

Wenn Sie das Paket auf der Festplatte oder dem Netzlaufwerk erstellen, lautet das empfohlene Ziel C:\Cie\Dist. Falls Sie das Paket auf einem Webserver erstellen, der von Ihrer Festplatte ausgeführt wird, sollte das Ziel der Pfad zum Webserver sein.

Eine Abbildung hierzu finden Sie unter Einrichten von Dateien für den Vertrieb.

Beispiel Speicherort des Zielordners

Wenn Sie beispielsweise den Zielordner C:\Inetpub\Wwwroot\Cie\Dist
festlegen, wird die deutsche Sprachversion für die Windows-Plattform im Ordner C:\Inetpub\Wwwroot\Cie\Dist\Download\Win32\DE erstellt.

Weitere Optionen
Zum Anpassen des Speicherorts und Prozesses zum Downloaden von Dateien oder zum Importieren von Einstellungen einer vorhandenen .INS-Datei klicken Sie auf Weitere Optionen.
Überprüfen mit der automatischen Versionssynchronisierung auf neuere Komponenten
IEAK kann im Internet nach der neuesten Version von Komponenten suchen, wenn Sie Ihr Internet Explorer-Paket erstellen. Mit diesem Feature können Sie ermitteln, ob neue Versionen verfügbar sind, seit Sie den Assistenten für die Internet Explorer-Anpassung zum letzten Mal ausgeführt haben.

Wenn Sie das IEAK aus dem Internet gedownloadet haben, müssen Sie den Assistenten für die Anpassung mit der Automatischen Versionssynchronisierung (AVS) mindestens einmal ausführen, sodass der Assistent nach aktualisierten Versionen von Komponenten suchen kann.

Pfad für die .INS-Datei für das Importieren von Einstellungen
Zum Importieren von Einstellungen aus einer vorhandenen .ins-Datei als Ausgangspunkt für ein neues IEAK-Paket geben Sie den vollständigen Pfad ein. Das Importieren von Einstellungen kann Zeit sparen, wenn Ihr neues Paket ähnliche Einstellungen haben soll. Sie können jedoch alle gewünschten Einstellungen ändern.
Ordner für den Komponentendownload
Die Komponenten und Installationsdateien, die Sie downloaden, werden in dem von Ihnen angegebenen Ordner abgelegt. Das Feature Automatische Versionssynchronisierung (AVS) überprüft diesen Ordner automatisch, um festzustellen, ob die neuesten Komponenten verfügbar sind. Mit AVS werden nur die Komponenten gedownloadet, die seit dem letzten Download geändert wurden. Es wird empfohlen, diesen Ordner nicht zu ändern, so dass die Komponenten synchronisiert bleiben.

Sie sollten diesen Ordner nur ändern, wenn Sie planen, die Dateien beizubehalten, die bei der letzten Ausführung des Assistenten gedownloadet wurden, und wenn Sie einen neuen Satz Komponenten downloaden möchten.


Auswahl von Features

Sie können festlegen, welche weiteren Bildschirme des Assistenten angezeigt werden, indem Sie die Kontrollkästchen auf diesem Bildschirm aktivieren oder deaktivieren. Wenn Sie beispielsweise planen, nur Links und URLs anzupassen, können Sie die anderen Kontrollkästchen deaktivieren, so dass keine anderen Bildschirme angezeigt werden. Wenn Sie bereits jetzt Ihre Optionen auswählen, können Sie Ihr Paket schneller und problemloser erstellen, da der Assistent für die Internet Explorer-Anpassung nur die benötigten Bildschirme anzeigt.

Wechseln Sie zum Bildschirm Dateiablage zurück, und klicken Sie dann auf die Schaltfläche Weitere Optionen um eine bestehende .INS -Datei zu importieren, wenn Sie die Konfiguration eines bereits erstellten IEAK-Pakets als Grundgerüst für dieses Paket verwenden möchten. Während des Erstellvorgangs für das neue Paket können Sie alle importierten Optionen nachträglich ändern.


Übersicht zu Schritt 1: Informationen sammeln

Assistent

Schritt 1: Informationen sammeln

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung werden Sie zur Eingabe grundlegender Informationen aufgefordert, wie z. B. zur Eingabe der Sprache des von Ihnen erstellten Pakets und Informationen dazu, welche Features in diesem Paket angepasst werden sollen.

Die verfügbaren Optionen hängen davon ab, welche der folgenden Positionen bzw. Funktionen Sie haben:

  • Internetinhaltsanbieter
  • Internetdienstanbieter
  • Firmenadministrator

Anmerkung

  • Der Assistent für die Internet Explorer-Anpassung kann nur dann ausgeführt werden, wenn Internet Explorer 5.5 oder höher installiert ist. Weitere Informationen finden Sie unter Hardware- und Systemanforderungen.


Downloadsite und Automatische Versionssynchronisierung

In diesen Schritten wird der Download der neuesten Programme und Tools von Microsoft durchgeführt. Wenn Sie bereits über die neueste Version einer Komponente verfügen, werden Sie gefragt, ob Sie diese beibehalten möchten. Möglicherweise müssen Sie vorübergehend Virenprüfprogramme deaktivieren, um den Download von Komponenten durchzuführen; in diesem Fall wird eine entsprechende Meldung angezeigt.

Microsoft Downloadsite
Wählen Sie die Site aus, von der Sie die neueste Version von Internet Explorer und Internettools downloaden. Klicken Sie auf Weiter, um den Bildschirm Automatische Versionssynchronisierung im Assistenten für die Internet Explorer-Anpassung anzuzeigen.
Download von Internet Explorer-Komponenten
Downloaden Sie die neueste Version der Microsoft-Komponenten, die im Feld angezeigt werden. Der Status der einzelnen Komponenten wird wie folgt angezeigt:
Symbol | Bedeutung
Rotes X | Der Download dieser Komponente wurde noch nicht durchgeführt.
Gelbes Ausrufezeichen | Von dieser Komponente befindet sich lediglich eine veraltete Version an Ihrem Downloadspeicherort.
Grünes Häkchen | Die aktuellste Version dieser Komponente befindet sich an Ihrem Downloadspeicherort.

Sie müssen den Internet Explorer-Webbrowser downloaden, um über diesen Schritt hinaus fortfahren zu können.

Wenn Sie mehr als eine Komponente downloaden oder aktualisieren möchten, wählen Sie alle gewünschten Komponenten aus und klicken dann auf Synchronisieren.. Um alle verfügbaren Komponenten zu downloaden, klicken Sie auf Alles synchronisieren..

In einigen Fällen sind aktuellere Versionen mancher Komponenten und Softwarepatches über die Automatische Versionssynchronisierung (AVS) auf der Windows Update-Website verfügbar. Wenn Sie andere Versionen von Dateien in Ihr Paket aufnehmen möchten, können Sie die Dateien als angepasste Komponente zusammenstellen. Weitere Informationen erhalten Sie unter Zusammenfassen von Microsoft-Updates in angepasste Komponenten.

Eine Abbildung zur Automatischen Versionssynchronisierung (AVS) finden Sie unter Automatische Versionssynchronisierung.

Informationen zu den neuesten Produktaktualisierungen finden Sie in der Corporate Windows Update-Website.

Während dieses Schrittes im Assistenten wird der Download der Installationsdateien für Internet Explorer und weitere Komponenten auf Ihren Computer durchgeführt. Es wird empfohlen, eine Kopie dieser Dateien auf der Festplatte zu belassen. Auf diese Weise ist es einfacher, zu einem späteren Zeitpunkt das Paket erneut zu erstellen. Beim erneuten Erstellen Ihres Pakets kann der Assistent für die Internet Explorer-Anpassung überprüfen, ob neuere Versionen der jeweiligen Programme verfügbar sind.

Anmerkungen

  • Wenn Sie im Dialogfeld Weitere Optionen in Schritt 1 des Assistenten für die Internet Explorer-Anpassung das Kontrollkästchen Überprüfen mit der Automatischen Versionssynchronisierung auf neuere Komponenten deaktiviert haben (siehe Dateiablage), kann der Assistent nicht überprüfen, ob die jeweils neuesten Versionen der Komponenten vorhanden sind. Die Symbole werden dann nicht grün angezeigt, selbst wenn die neueste Version vorhanden ist. Bei den Komponenten, deren Download bereits durchgeführt wurde, werden die Symbole gelb angezeigt. Bei Komponenten, deren Download noch nicht durchgeführt wurde, werden die Symbole rot angezeigt. Wenn Sie die Versionssynchronisierung deaktiviert haben, können Sie in diesem Schritt des Assistenten bestimmte Komponenten nicht downloaden.
  • Weitergehende Informationen zu Komponenten und ComponentID-Zeichenfolgen finden Sie auf der IEAK-Website .


Angepasste Komponenten hinzufügen

Sie können bis zu zehn angepasste Komponenten hinzufügen, die von den Benutzern zusammen mit dem Browser installiert werden können. Bei diesen Komponenten kann es sich um komprimierte Kabinettdateien (.CAB) oder um selbst extrahierende ausführbare Dateien (.exe) handeln. Möglicherweise möchten Sie eine andere Version einer Microsoft-Komponente installieren, als die Version, die bei Verwendung der Automatischen Versionssynchronisierung (AVS) installiert wird.

Es wird empfohlen, dass Sie den gesamten angepassten Code signieren, der über das Internet gedownloadet wird. Durch die Codesignatur können sich die Benutzer sicher sein, dass der Code vertrauenswürdig ist, bevor der Downloadvorgang auf deren Computer stattfindet. Wenn Internet Explorer mit den Standardeinstellungen arbeitet, werden nichtsignierte Codes zurückgewiesen.

Einige der folgenden Optionen sind nicht auf allen Plattformen verfügbar.

Befehl
Wenn Sie eine .CAB-Datei angeben, müssen Sie auch einen Befehl zur Dekomprimierung der .CAB-Datei festlegen.
Komponente
Geben Sie den Namen der Komponente in dieses Feld ein. Dieser Name wird im Installationsbildschirm angezeigt, während die Benutzer die Software installieren.
Beschreibung
Geben Sie bis zu 511 Zeichen zur Beschreibung der Komponente ein. Dieser Text wird im Setup angezeigt, wenn die Benutzer auf die Komponente zeigen.
GUID
Wenn Ihr Programm bereits über einen global eindeutigen Bezeichner oder eine GUID verfügt, geben Sie diesen in das Feld ein. Verfügt Ihr Programm über keine GUID, wird eine GUID für Sie erzeugt. Eine GUID legt eine eindeutige Identität für Programme, Objekte und andere Elemente fest.
Ort
Geben Sie den Pfad zu Ihrem Programm an, oder klicken Sie auf Durchsuchen, um den Speicherort der Datei anzugeben.
Parameter
Sie können beliebige Parameter und Schalter angeben, die für die Ausführung des angepassten Programms erforderlich sind. Sie können z. B. das Programm "nicht sichtbar" - mit wenigen oder keinen Benutzeraufforderungen - installieren, so dass die Benutzer weder Aufforderungen für Ihr Programm noch für Internet Explorer sehen. Verwenden Sie zum expliziten Ausschluss von Installationsaufforderungen den Parameter /q:a.
Deinstallationsschlüssel
Windows Update Setup vergleicht diesen Wert mit dem Wert unter HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\Anwendungsname, um sicherzustellen, dass die Komponente ordnungsgemäß installiert wurde.

Weitere Informationen finden Sie unter Deinstallieren einer angepassten Komponente.

Bestätigen
Bei Programmen, die über das Internet installiert werden, sind normalerweise digitale Signaturen erforderlich, die deren Herkunft kennzeichnen und garantieren, dass der Code seit der Signatur nicht geändert wurde. Abhängig von den Sicherheitseinstellungen des Browsers können die Benutzer gewarnt werden, bevor der Downloadvorgang für ein solches Programm durchgeführt wird. Zertifizierungsinstanzen stellen öffentliche und private Schlüssel zur Verfügung, die für die Signatur von Code benötigt werden. Um festzustellen, ob ein Programm digital signiert wurde, klicken Sie auf Bestätigen. Wenn Sie während der Ausführung des Assistenten für die Internet Explorer-Anpassung die restlichen Dateien signieren, wird diese Komponente ebenfalls mit dem Zertifikat signiert.

Weitere Informationen zur Codesignierung erhalten Sie über die Microsoft Security Advisor-Website.

Version
Setup verwendet die Versionsnummer um die zu installierenden mit den bereits auf dem Computer installierten Komponenten zu vergleichen. Bei der erneuten Installation einer Komponente behält das Programm die neuere Version bei. Die Versionsnummer liefert Hinweise auf die Version des Programms und kann sicherstellen, dass die jeweils neueste Version des Programms installiert ist. Das richtige Format für diese Versionsnummer hat folgende Struktur: xxxx,xxxx,xxxx,xxxx.

Installationsbedingungen

Vor Internet Explorer installieren
Aktivieren Sie dieses Kontrollkästchen, wenn Sie eine angepasste Komponente installieren müssen, bevor Internet Explorer installiert wird (z. B. zur Ausführung einer Stapelverarbeitungsdatei, um Benutzereinstellungen vorzukonfigurieren).
Nach Internet Explorer installieren
Aktivieren Sie dieses Kontrollkästchen, wenn Sie mit Hilfe von AVS ein oder mehrere Softwarepatches für Internet Explorer (QFEs) oder eine andere Version einer Komponente installieren möchten, als in Basis-Internet Explorer-Paket enthalten ist.

Anmerkung

  • Wenn Sie von einer Komponente eine andere Version verwenden als die entsprechende Basisversion von Internet Explorer (beispielsweise bei DirectAnimation oder NetMeeting) und diese Komponenten als angepasste Komponente in ein Paket aufnehmen, so verdoppelt sich die Downloadzeit für diese Komponenten, da diese zwei Mal gedownloadet werden.
Installation nach Neustart
Aktivieren Sie dieses Kontrollkästchen, wenn Ihr angepasstes Paket Service Packs für das Betriebssystem oder Updates für Microsoft Java Virtual Machine (VM)enthält.
Nur installieren, wenn Internet Explorer bereits installiert wurde
Legt fest, dass die betreffende Komponente erst dann auf dem Computer des Benutzers installiert wird, wenn auch Internet Explorer ordnungsgemäß installiert ist.

Anmerkungen

  • Im Lieferumfang von IEAK sind Tools zur Erstellung von IExpress-Skripts enthalten.. Weitere Tools finden Sie im MSDN Online Web Workshop. Allgemeine Informationen zur Setup-Technologie finden Sie unter Windows Update Setup für Internet Explorer und andere Internetprogramme.
  • Eine Abbildung mit Erläuterungen, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen und angepasste Komponenten installieren können, finden Sie unter Anpassungsmöglichkeiten .


Übersicht zu Schritt 2: Angabe der Setup-Parameter

Assistent

Schritt 2: Angabe der Setup-Parameter

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung können Sie die Komponenten Ihres angepassten Pakets festlegen.

Die verfügbaren Optionen hängen davon ab, über welche der folgenden Positionen bzw. Funktionen Sie verfügen:

  • Internetinhaltsanbieter
  • Internetdienstanbieter
  • Firmenadministrator


Anpassen von Setup

Sie können das Erscheinungsbild für Windows Update Setup festlegen. Dabei können Sie die Titelleiste und die Grafik ändern, die angezeigt wird, wenn die Benutzer den Assistenten für Windows Update Setup ausführen. Wenn Sie angepasste Komponenten zu einer Gruppe zusammenfassen, können Sie dafür einen Namen festlegen.

Text für die Titelleiste des Assistenten
Dieser Text wird in der Titelleiste des Setup-Assistenten angezeigt, wenn die Benutzer diesen Assistenten ausführen. Der Text wird hingegen nicht in der Titelleiste des angepassten Browsers angezeigt. Sie können den Titel des Browsers zu einem späteren Zeitpunkt im Assistenten für die Internet Explorer-Anpassung anpassen.
Pfad für das linke (erste Seite) bzw. obere (alle anderen Seiten) Bitmap des Assistenten
Diese Grafiken passen das Erscheinungsbild des Setup-Assistenten an. Sie sollten keine Grafiken mit komplexen Linien und Mustern verwenden.

Anmerkung

  • Der Setup-Assistent enthält zwei 256-Farben-Bitmaps. Die linke vertikale Bitmap (auf dem ersten Bildschirm des Setup-Assistenten) hat die Abmessungen 162x312 Pixel. Die Abmessungen der oberen horizontalen Bitmap (auf den verbleibenden Seiten des Setup-Assistenten) betragen 496x56 Pixel. Die horizontale Grafik wird hinter einigen Setup-Anweisungen angezeigt, so dass Sie eine Bitmap verwenden sollten, die die Lesbarkeit nicht beeinträchtigt.
Installationstitel der angepassten Komponenten
Sie können die angepassten Komponenten installieren, wenn Sie die Installation des angepassten Browsers durchführen. Wenn Sie mehr als eine angepasste Komponente angegeben haben, können Sie diese als Gruppe benennen - beispielsweise können Sie eine Komponentengruppe wie "Vulkan Kaffee AG-Inventurprogramme" erstellen. Dieser Name wird im Windows Update Setup-Assistenten angezeigt, wenn die Benutzer das angepasste Paket installieren. Geben Sie den Titel ein, der angezeigt werden soll.

Eine Abbildung mit Erläuterungen, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen und angepasste Komponenten installieren können, finden Sie unter Anpassungsmöglichkeiten.


Anpassen des Verbindungs-Managers

Das im Lieferumfang von IEAK enthaltene CMAK (Connection Manager Administration Kit) ist ein Tool zur Einstellung und Verwaltung der Konfiguration, mit der Benutzer eine Verbindung mit dem Internet oder dem privaten Firmennetz herstellen. Mit CMAK können Sie das Erscheinungsbild und die Einstellungen für die Microsoft-Verbindungs-Manager-Wählhilfe mit eigenen angepassten Symbolen, angepassten Hilfedateien und animierten Grafiken ändern.

CMAK ist nicht im Lieferumfang von IEAK 5.5 enthalten. CMAK ist Bestandteil von Windows 2000 Server und dem Windows 2000 Administration Pack. Eine ältere Version von CMAK ist im Lieferumfang von IEAK 5 enthalten.

Wenn Sie bereits mit Hilfe von CMAK ein angepasstes Profil erstellt haben, können Sie es unter der Verwendung des Assistenten für die Internet Explorer-Anpassung in Ihr Installationspaket importieren.

Angepasstes Profil verwenden
Wenn Sie bereits ein angepasstes Profil erstellt haben, geben Sie den Pfad des Profils ein, das für dieses Browserpaket verwendet werden soll. In dem Profil sind die angepassten Inhalte und die Verbindungsmethoden festgelegt.

Anmerkungen

  • CMAK erstellt eine selbstextrahierende ausführbare Datei (*.exe), die sich selbst auf den Benutzercomputern installiert. Wenn die Benutzer dann auf das angepasste Symbol klicken, um eine Verbindung zum Internet herzustellen, wird das von Ihnen erstellte angepasste Wählhilfe-Dialogfeld angezeigt.
  • Die vom CMAK erstellte .EXE-Datei muss nicht digital signiert werden, bevor Sie sie in das IEAK aufnehmen. Wenn Sie die IEAK-Dateien signieren, wird die CMAK-Datei ebenfalls signiert.

Weitere Informationen finden Sie in der Onlinehilfe im Connection Manager Administration Kit.


Benutzerführung

Sie können die Benutzerführung bei der Ausführung des Windows Update Setup-Programms anpassen.

Automatische Installation

Wenn Sie den Benutzern während der Installation durch Windows Update Setup Auswahlmöglichkeiten zur Verfügung stellen möchten, klicken Sie auf Interaktive Installation. Die Benutzer können die Installationsart, die Downloadsite und den Ordner für die Installation festlegen. Alle Dialogfelder zur Ausgabe von Statusinformationen bzw. Fehlermeldungen zur Installation werden angezeigt.

Es sind zwei Arten von automatischer Installation verfügbar.

Klicken Sie auf Hands-free Installation, wenn Sie für alle Benutzereingaben Voreinstellungen verwenden möchten, den Benutzern jedoch Statusinformationen und Fehlermeldungen angezeigt werden sollen.

Klicken Sie auf Vollständig automatische Installation, wenn der angepasste Browser installiert werden soll, ohne dass den Benutzern Statusinformationen oder Fehlermeldungen angezeigt werden. Diese Option entspricht einer Installation von Internet Explorer unter Verwendung des Schalters /Q:A.

Für weitere Anpassungen der Installation stehen zusätzliche Internet Explorer-Batch-Setup-Parameter und Iexpress-Batch-Setup-Parameter zur Verfügung.

Wie stellt sich dem Benutzer die vollständig automatischen Installation bzw. die Hands-free Installation dar?

Bei der Installation im Hintergrund (Hands-free oder vollständig automatisch) werden die folgenden Schritte durchgeführt:

  • Bestätigen aller Eingabeaufforderungen zum Durchführen und Fortsetzen des Setup-Programms.
  • Akzeptieren des Lizenzvertrags.
  • Angeben, dass Internet Explorer installiert und nicht nur gedownloadet wird.
  • Durchführen der festgelegten Art der Installation (wie Standard oder Benutzerdefiniert), die Sie für dieses Installationspaket festgelegt haben.
  • Installieren von Internet Explorer in dem von Ihnen angegebenen Ordner, sofern Internet Explorer noch nicht installiert wurde. In diesem Fall wird die neue Version des Browsers in dem gleichen Ordner installiert wie die vorherige Version.
  • Stellt eine Verbindung zur ersten für dieses Paket festgelegte Downloadsite her.

Keiner dieser Modi erfordert eine Benutzereingabe. Die Benutzer können auch nicht den Installationsstatus von Windows Update Setup verfolgen. Bei einer Installation im Hintergrund wird den Benutzern auch keine Fehlermeldung angezeigt, wenn die Installation nicht erfolgreich durchgeführt werden konnte. Die Option bietet sich für Installationen an, die durchgeführt werden, wenn kein Benutzer anwesend ist.

Anmerkung

  • Bei einer automatischen Installation können Sie nur eine einzige Installationsoption und nur eine Downloadsite angeben.

Benutzerrechte

Das unter Windows NT und unter Windows 2000 verwendete Sicherheitsmodell ermöglicht es, auf Computern die Softwareinstallationen durch Benutzer zu unterbinden. Bei der Installation und nach dem Neustart des Computers sind Administratorrechte erforderlich, um wichtige Systemdateien zu registrieren. Durch diese Anforderung können bei der Verteilung neuer Versionen von Internet Explorer auf Systemen, an denen sich nach der Installation des Pakets Benutzer ohne Administratorrechte anmelden, Probleme auftreten.

Nach Neustart Anmeldung mit Standardbenutzerrechten ermöglichen
Aktivieren Sie dieses Kontrollkästchen, um Ihr Paket so anzupassen, dass nach dem Neustart des Computers eine Anmeldung mit Administratorrechten erfolgt. Nach dem Neustart des Computers und der Anmeldung durch den Benutzer wird die Registrierung der Internet Explorer-Systemdateien von der Windows-Installer-Komponente abgeschlossen. Dies ermöglicht, das Paket manuell oder als Bestandteil einer automatischen Verteilungsmethode, wie beispielsweise über SMS (Systems Management Server) an die Benutzer zu verteilen. In beiden Fällen ist es nicht erforderlich, dass die Benutzer, die sich nach der Installation an dem System anmelden, über Administratorrechte verfügen.

Bei der Installation eines IEAK-Pakets auf Computern, die unter Windows 95, Windows 98 oder Windows Millennium Edition ausgeführt werden, sind keine Administratorrechte erforderlich, da diese Betriebssysteme nicht die Registrierung von Dateien auf dem Computer verwalten.

Wird das Paket auf einem SMS-Client installiert, so erzeugt die Komponente eine Statusdatei (.MIF-Datei). SMS verwendet diese Datei, um zu ermitteln, ob das Paket erfolgreich installiert wurde.

Wichtig

  • Stellen Sie sicher, dass das für Ihr Paket ausgewählte Medienformat eine flache Ordnerstruktur beinhaltet, dass sich also alle Dateien in einem Ordner befinden, wenn Sie diese Option wählen.
  • Stellen Sie bei Verwendung dieser Option sicher, dass Windows-Setup keine weitere Installation durchführt, wenn der Benutzer das Paket installiert.
  • Verwenden Sie dieses Verfahren nicht, wenn Internet Explorer als Bestandteil einer anderen Windows-Setup-Installation, wie beispielsweise Microsoft Office 2000, installiert wird.
  • Führen Sie umfangreiche Tests durch, bevor Sie dieses Paket an die Benutzer verteilen, um alle möglichen Fälle von Benutzereingaben zu erfassen, bevor Sie diese Option wählen.


Installationsoptionen

Sie können bis zu zehn Installationsoptionen festlegen, wie beispielsweise Standard und Benutzerdefiniert, um zu bestimmen, welche Browserkomponenten und angepassten Komponenten unter Verwendung der jeweiligen Optionen installiert werden. Als Administrator in einer Firma können Sie nur eine Installationsoption (bzw. einen Installationsmodus) angeben, wenn Sie für dieses Paket die Installation im Hintergrund gewählt haben.

Wichtig

  • Unabhängig von den Installationsoptionen, die Sie für Ihr Paket konfigurieren, zeigt Windows Update Setup für Benutzer des Betriebssystems Windows 2000 nur eine einzige Installationsoption an. Diese Installationsoption beinhaltet den vollständigen Satz der Microsoft-Internetkomponenten und darüber hinaus alle angepassten Komponenten, die in dem Paket enthalten sind.
Option
Wählen Sie die gewünschte Standardinstallationsoption, oder klicken Sie auf Neu, um eine neue Setup-Option zu erstellen. Geben Sie eine Beschreibung für die Option ein, und fügen Sie dann die gewünschten Komponenten hinzu, oder entfernen Sie sie, indem Sie auf die Pfeile klicken.

Wenn Sie ISP sind, können Sie bei Bedarf unterschiedliche Setup-Optionen für bestimmte Kundengruppen erstellen. Wenn Sie Firmenadministrator sind, können Sie nach Belieben unterschiedliche Setup-Optionen für die verschiedenen Abteilungen des Unternehmens festlegen.

Beschreibung
Geben Sie eine Beschreibung für die Installationsoption ein, beispielsweise eine Liste der installierten Komponenten und Programme. Dieser Text wird den Benutzern im Windows Update Setup angezeigt.

Anmerkung

  • Geben Sie ein Kaufmännischen Und-Zeichen ein (&), um im Beschreibungstext einen Unterstrich darzustellen. Geben Sie zwei Kaufmännische Und-Zeichen ein (&&), um im Beschreibungstext ein Kaufmännischen Und-Zeichen darzustellen.
Verfügbare Komponenten
Die Liste der verfügbaren Komponenten umfasst die Komponenten von Internet Explorer, die Sie gedownloadet haben, und alle angepassten Komponenten, die Sie festgelegt haben. Gehen Sie zu Schritt 2 des Assistenten zurück, wenn Sie weitere Komponenten zu dieser Liste hinzufügen möchten.
Zu installierende Komponenten
Diese Liste enthält die Komponenten, die bei der Option installiert werden, die im Feld Option angezeigt wird. Klicken Sie auf die einzelnen Pfeile, um eine einzelne Komponente hinzuzufügen oder zu entfernen, oder klicken Sie auf die Doppelpfeile, um alle verfügbaren Komponenten hinzuzufügen oder zu entfernen.

Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen und bestimmte Komponenten installieren können, finden Sie unter Anpassungsmöglichkeiten.

Anmerkung

  • Wenn Sie Internet Explorer auf einem Computer installieren, auf dem Internet Explorer 4 noch nicht ausgeführt wurde, und die Benutzer die Möglichkeit zur Nutzung von Channels erhalten sollen, fügen Sie Ihrer Installation das Offline-Browserpaket als Komponente unter der jeweiligen Installationsoption hinzu.


Downloadsites für Komponenten

Sie müssen mindestens eine Downloadsite mit einem HTTP- oder FTP-Server angeben, von der Benutzer das Paket downloaden können. Sie können bis zu zehn Sites angeben. Alle Microsoft-Komponenten und alle angepassten Komponenten müssen unter jedem unten angegebenen URL zur Verfügung stehen.

Site-Name
Geben Sie den Namen der Site ein. Sie können einen benutzerfreundlichen Anzeigenamen angeben, der die Erkennung der Site erleichtert. Verwenden Sie keine Kommas in dem Namen.
Site-URL
Geben Sie den URL der Site ein. Die Datei Ie5sites.dat wird aktualisiert, und ein Unterordner für die Sprache des Pakets angelegt - beispielsweise EN für Englisch - wird an den URL angehängt.
Site-Region
Geben Sie an, wo sich die Site befindet, beispielsweise Stadt, Bundesland, Kanton oder Land.
Angepasste Downloadsites
Die von Ihnen angegebenen Sites werden in diesen Spalten angezeigt.

Anmerkung

  • Als Administrator in einer Firma können Sie nur eine Downloadsite angeben, wenn Sie die Installation im Hintergrund gewählt haben.

Eine Schemadarstellung finden Sie unter Bereitstellen von Dateien für den Vertrieb und unter Assistent für Windows Update Setup für Internet Explorer und andere Internetprogramme.

Maßnahmen, die ergriffen werden müssen, falls der URL der ersten angegebenen Site nicht erreicht werden kann

Wenn die erste angegebene Site nicht erreicht werden kann (beispielsweise aufgrund von Serverproblemen), kann Setup die verbleibenden Sites nicht aufrufen. Um das Problem zu lösen, müssen Sie die Angabe der ersten Site mit folgendem Befehl überschreiben:

<Pfad>\ie5setup.exe /C:"ie5wzd.exe /S:""<Pfad>\ie5setup.exe"" /L:""http://Mein Webserver/Meine Website/ie5sites.dat"""

<Pfad> ist der Ordner, in dem sich die Datei IE5setup.exe befindet.

Beispiel

Im Folgenden ein Beispiel der Syntax, die Benutzern nach dem ersten Download der Site angezeigt wird. Das Beispiel besteht aus einer Befehlszeile, die unter Verwendung dreier Textzeilen angezeigt wird, um bessere Lesbarkeit zu gewährleisten.

C:\ie5setup.exe /C:"ie5wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\ie5setup.exe""
/L:""http://<NeueServerAdresse>/<DownloadVerz>/ie5sites.dat """


Komponentendownload

Wenn eine neue Version von Internet Explorer verfügbar ist, können Benutzer Internet Explorer aktualisieren, indem sie im Menü Extras auf Windows Update klicken. Benutzern wird diese Seite ebenfalls angezeigt, indem sie in der Systemsteuerung auf Software, dann auf Microsoft Internet Explorer 5.5 und Internettools und anschließend auf Hinzufügen/Entfernen klicken.

Der Standardspeicherort zum Abrufen von Produktupdates befindet sich auf der Site bzw. den Sites, von denen die Benutzer ihre angepassten Browser gedownloadet haben. Sie können jedoch auch Ihre angepasste Addon-Seite angeben, über die Benutzer zusätzliche Addon-Komponenten downloaden können.

Nach der Installation Komponenten von Microsoft downloaden
Durch Aktivieren dieses Kontrollkästchens wird festgelegt, dass nach der Installation alle Komponenten von Microsoft-Sites gedownloadet werden.
URL für Addon-Komponentenseite:
Geben Sie einen anderen URL an, falls Sie gewährleisten möchten, dass Benutzer Softwareupdates (Addon-Komponenten) von anderen Speicherorten abrufen können.

Anmerkung

  • Die in früheren Versionen von Internet Explorer Administration Kit verfügbare Konfigurations-ID und Versionsnummer, die zuvor auf diesem Bildschirm angezeigt wurden, werden nicht mehr benötigt. Diese Werte werden automatisch erzeugt. Die Anpassungen (oder auch Branding-Versionen), die Sie mit Hilfe von Internet Explorer Administration Kit generieren, werden, unabhängig von Versionsnummer und Konfigurations-ID, immer installiert.


Installationsordner

Wenn Sie Firmenadministrator sind, können Sie den Speicherort für die Installation von Internet Explorer und anderen Internetkomponenten festlegen. Sie können auch festlegen, ob Benutzer den von Ihnen angegebenen Ordner ändern können.

Wenn den Benutzern die Änderung des von Ihnen angegebenen Ordners gestattet sein soll, aktivieren Sie das Kontrollkästchen Auswahl des Installationsverzeichnisses durch den Benutzer zulassen. Bei Aktivierung dieses Kontrollkästchens wird die von Ihnen unten getroffene Auswahl als Standardordner angezeigt.

Wenn Sie auf Im angegebenen untergeordneten Ordner des Ordners "Windows" installieren oder auf Im angegebenen untergeordneten Ordner des Ordners "Programme" installieren klicken, wird Internet Explorer in dem Unterordner installiert, der im Feld angegeben ist.

Wenn Sie das Kontrollkästchen Vollständigen Pfad des Installationsordners angeben aktivieren, können Sie den vollständigen Pfad eingeben, in dem die Installation erfolgen soll. Falls dieser Pfad auf dem Datenträger des Benutzers nicht vorhanden ist, wird er erstellt.

Anmerkung

  • Falls Internet Explorer bereits auf dem Computer des Benutzers installiert ist, wird die neue Version über die alte Version installiert. Der angepasste Browser wird dann nicht in dem Ordner installiert, den Sie angegeben haben.


Installationsoptionen (Firmenadministratoren)

Sie können festlegen, in welchem Umfang Benutzer die Funktionalität von Windows Update Setup anpassen können, falls dies überhaupt der Fall sein soll.

Angepasste Installationsoptionen deaktivieren
Benutzer können Komponenten hinzufügen oder entfernen, um das Setup weitergehend anzupassen. Aktivieren Sie dieses Kontrollkästchen, wenn verhindert werden soll, dass Benutzer bestimmte Komponenten hinzufügen oder entfernen.
Das Speichern von Deinstallationsinformationen deaktivieren
Windows Update Setup speichert Deinstallationsinformationen automatisch. Wenn Sie Speicherplatz sparen möchten, können Sie dieses Feature deaktivieren, indem Sie das Kontrollkästchen aktivieren. In diesem Fall können Benutzer Internet Explorer 5 jedoch nicht entfernen, indem sie in der Systemsteuerung auf Software klicken.
Internet Explorer Kompatibilitätsmodus deaktivieren
Unter Verwendung der Internet Explorer-Kompatibilitätsoption können Benutzer Webseitenfeatures von Internet Explorer 4 auf demselben Computer wie Internet Explorer 5 ausführen. Aktivieren Sie das Kontrollkästchen, um dieses Feature zu deaktivieren.
Internet Explorer wird als Standardbrowser verwendet
Wählen Sie eine von drei Optionen, um Internet Explorer als Standardbrowser festzulegen und um zu bestimmen, ob die Benutzer diese Auswahl treffen können. Der Standardbrowser wird ausgeführt, wenn die Benutzer .HTM-, .HTML- und andere Dateitypen öffnen. Die Option legt auch fest, ob Windows Media Player das Standardprogramm zur Wiedergabe von Multimediadateien sein soll.

Anmerkung

  • Wenn Sie eine automatische Installation durchführen oder Internet Explorer für die Verteilung in Verbindung mit Microsoft Office mit Hilfe des Assistenten für die Angepasste Office-Installation anpassen, werden die Benutzeroptionen für Internet Explorer während der Ausführung von Setup nicht angezeigt.


Windows Desktop-Aktualisierung

Windows Desktop-Aktualisierung verleiht dem Desktop und den Ordnern ein Erscheinungsbild ähnlich einer Webseite. Obwohl die Windows Desktop-Aktualisierung nicht Bestandteil von Internet Explorer, Version 5 oder höher ist, können Sie diese dennoch in Ihr IEAK-Paket aufnehmen. Benutzern, die Windows 98 (oder höhere Betriebssystemversionen) verwenden, stehen diese Desktop-Features bereits zur Verfügung.

Wenn Sie die Windows Desktop-Aktualisierung installieren, können Sie ihre Einstellungen zu einem späteren Zeitpunkt im Assistenten anpassen, wenn der Computer, auf dem Sie die Version erstellen, eine der folgenden Konfigurationen hat:

  • Windows 98
  • Windows 98, Zweite Ausgabe
  • Windows Millennium Edition
  • Windows 2000
  • Bei anderen Windows-Versionen müssen Sie ein Upgrade von Internet Explorer 4.0 mit installierter Windows Desktop-Aktualisierung auf Internet Explorer 5.5 durchführen.

Die Windows Desktop-Aktualisierung kann bei der Einstellung eines Standarddesktops in Unternehmen hilfreich sein.

Soll die Windows Desktop-Aktualisierung in das angepasste Paket integriert werden?
Klicken Sie auf Ja, um die Windows Desktop-Aktualisierung zu installieren. Klicken Sie auf Nein, wenn Sie diese Komponente nicht installieren möchten.


Erweiterte Installationsoptionen

Windows Update Setup kann weiter angepasst werden, indem Sie Setup ermitteln lassen, ob eine Komponente vorhanden ist. Außerdem können Sie eine Feinabstimmung der Komponenten vornehmen, die Benutzer hinzufügen können, wenn sie das Setup anpassen.

Optimieren des Webdownloads
Setup kann erkennen, ob die gleiche Version einer Komponente bereits auf dem Computer des Benutzers installiert ist. Falls bereits eine Version derselben Komponente installiert ist und diese von Internet Explorer unterstützt wird, wird sie nicht von Setup gedownloadet. Hierdurch kann die Downloadzeit für Benutzer verringert werden.

Anmerkung

  • Versuchen Sie nicht, das Paket für die Verbreitung über das Internet zu optimieren, wenn Sie von einer Komponente eine andere Version installieren möchten, als die Version, die in den Internet Explorer-.CAB-Dateien enthalten ist, die Sie bereits über die Automatische Versionssynchronisierung (AVS) gedownloadet haben. Weitere Informationen erhalten Sie unter Zusammenfassen von Microsoft-Updates in angepasste Komponenten.
Für bestimmte Komponenten verhindern, dass Benutzer Setup anpassen
Falls die Benutzer ihre Installation anpassen können, Sie aber verhindern möchten, dass die Benutzer bestimmte Komponenten anpassen, deaktivieren Sie die Kontrollkästchen für die Komponenten, die von den Benutzern nicht angepasst werden sollen. Bei Windows Update Setup wird die Option Installation erzwingen in der rechten Spalte neben den Komponenten angezeigt, die automatisch zusammen mit dem Browser installiert werden.


Komponenten auf Medien

Die Komponenten in dieser Liste wurden auf Ihren Computer gedownloadet, aber nicht in einen der Modi von Windows Update Setup integriert. Die von Ihnen ausgewählten Komponenten können für die Installation zur Verfügung gestellt werden, wenn die Benutzer versuchen, ein Feature zu verwenden, das diese Komponenten benötigt. Dieses Feature wird als Installation bei Bedarf bezeichnet.


Digitale Signaturen

Wenn Sie ein Herausgeberzertifikat einer Zertifizierungsinstanz oder von Microsoft Certificate Server besitzen, können Sie Ihr angepasstes Paket in diesem Schritt des Assistenten signieren. Weitere Informationen über Zertifikate finden Sie unter Signieren Ihrer Programme.

Um die Zertifikate für die Verwendung durch den IEAK vorzubereiten, können Sie diese mit dem Assistenten für Zertifikatimport auf Ihren Computer importieren. Falls Sie eine Datei mit der Erweiterung .SPC erhalten haben, können Sie den Assistenten für den Zertifikatimport starten, indem Sie in Windows-Explorer oder Arbeitsplatz auf die .SPC-Datei klicken.

Sie können den Assistenten für Zertifikatimport ebenfalls in Internet Explorer öffnen, indem Sie im Menü Extras auf Internetoptionen und anschließend auf der Registerkarte Inhalt auf Zertifikate klicken. Klicken Sie auf Importieren, um den Assistenten für Zertifikatimport zu starten, und folgen Sie dann den Schritten im Assistenten.

Firmenname im Zertifikat
Falls sich ein Herausgeberzertifikat auf Ihrem Computer befindet, wird der entsprechende Firmenname in diese Liste angezeigt.
Dateien für Zertifikate von Softwareherausgebern (.spc)
Geben Sie den Namen der mit dem Zertifikat verknüpften .SPC-Datei ein, oder klicken Sie auf Durchsuchen, um den Speicherort der Datei anzugeben.
Datei für Privatschlüssel (.pvk)
Geben Sie den Namen der mit dem Zertifikat verknüpften .PVK-Datei ein, oder klicken Sie auf Durchsuchen, um den Speicherort der Datei anzugeben.
Beschreibungstext
Geben Sie den Text für das Dialogfeld ein, das angezeigt wird, wenn Benutzer mit diesem Zertifikat signierte Programme downloaden.
URL für weitere Informationen
Geben Sie den in diesem Dialogfeld angezeigten URL ein, auf den Benutzer klicken können, um weitere Informationen über das Zertifikat und Ihr Unternehmen zu erhalten.


Anpassungen für CD Autorun

Wenn Sie eine Version des angepassten Browsers für den Vertrieb auf CD erstellen, können Sie einen Begrüßungsbildschirm erstellen, der automatisch angezeigt wird, nachdem der Benutzer die CD in das Laufwerk eingelegt hat.

Das Bild muss eine Bitmapgrafik mit 256 Farben sein und die Abmessungen 540x357 Pixel haben. Weitere Informationen über das Erstellen solcher Grafiken finden Sie unter Erstellen der Bitmap für den automatischen Begrüßungsbildschirm. Weitere Informationen über Grafiken finden Sie unter Erstellen angepasster Grafiken.

Falls Sie einen automatischen Begrüßungsbildschirm verwenden, können Sie eine Hintergrundbitmap und Beschriftungen für zwei Schaltflächen bereitstellen: eine Schaltfläche für die Installation von Internet Explorer und eine Schaltfläche zum Anzeigen weiterer Informationen. Sie können außerdem auch die Titelleiste und die Farbe des Textes anpassen.

Text der Titelleiste
Dieser Text wird in der Titelleiste des automatischen Begrüßungsbildschirms angezeigt.
Ort der angepassten Hintergrundbitmap
Sie können eine Bitmapgrafik angeben, die hinter dem Text angezeigt wird. Achten Sie darauf, dass die Farben im Hintergrundbild sich von der Textfarbe gut abheben.
Farbe für normalen Text
Durch diese Einstellung wird die Farbe aller Textelemente bestimmt, die nicht zu einem Hyperlink gehören.
Farbe für markierten Text
Durch diese Einstellung wird die Farbe der Hyperlinks auf der Seite festgelegt.
Stil der Schaltfläche
Sie können das Erscheinungsbild der Schaltflächen bestimmen, auf die die Benutzer klicken, um Internet Explorer zu installieren oder um weitere Informationen anzuzeigen.
  • Standard-Schaltflächen entsprechen den Schaltflächen, die Sie aus Standardsoftware kennen.
  • 3D-Bitmap-Schaltflächen verfügen über ein dreidimensionales Aussehen.
  • Angepasste Schaltflächenbitmaps basieren auf einer von Ihnen erstellten Bitmapgrafik. Klicken Sie auf Durchsuchen, um den Pfad der Grafik anzugeben.


Weitere CD-Optionen

Die CD-Installation kann weiter angepasst werden, indem Sie eine Informationsdatei hinzufügen - die gelegentlich als Infodatei oder Readme-Datei bezeichnet wird - und eine besondere Webseite nach der Installation anzeigen lassen.

Textdatei mit weiteren Informationen
Geben Sie den Pfad und Dateinamen der Datei an, die den Benutzern nach der Installation angezeigt werden sollen. Standardmäßig enthält der automatische CD-Begrüßungsbildschirm einen Link zu dieser Datei. Falls Sie den Namen der Datei ändern, müssen Sie den Pfad im automatischen Begrüßungsbildschirm ebenfalls ändern.
Startseite im Kioskmodus verwenden
Geben Sie den Pfad und Dateinamen der .HTM-Datei an, die angezeigt werden soll, nachdem der Benutzer Internet Explorer installiert hat. Diese Seite wird im Kioskmodus (Vollbildschirm) angezeigt, in dem die Symbol- und die Menüleiste des Browsers nicht zu sehen sind. Alle mit dieser Seite zusammenhängenden Grafiken sollten im gleichen Ordner wie die .HTM-Datei abgelegt werden.


Übersicht zu Schritt 3: Anpassen von Setup

Assistent

Schritt 3: Anpassen von Setup

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung geben Sie an, wie Windows Update Setup angepasst wird.

Die verfügbaren Optionen hängen davon ab, welche der folgenden Positionen bzw. Funktionen Sie haben:

  • Internetinhaltsanbieter
  • Internetdienstanbieter
  • Firmenadministrator


Browsertitel

Sie können den Text anpassen, der in der Titelleiste des Internet Explorer-Webbrowsers sowie von Outlook Express angezeigt wird, wenn Outlook Express im Lieferumfang Ihres Pakets enthalten ist. Geben Sie den Text ein, der angezeigt werden soll. Er wird an den Text "Microsoft Internet Explorer von" oder "Outlook Express von" angehängt.

Titelleiste anpassen
Um die Titelleisten anzupassen, aktivieren Sie das Kontrollkästchen Titelleiste anpassen und geben dann den Text ein, der im Feld Text der Titelleiste angezeigt werden soll.
Hintergrundbitmap der Symbolleiste anpassen
Sie können eine angepasste Bitmap für die Symbolleiste angeben. Diese Bitmap wird als Hintergrund hinter Schaltflächen und Dropdownmenüs angezeigt. Der Hintergrund sollte die Größe der Symbolleiste besitzen und hell genug sein, um schwarzen Text darstellen zu können. Weitere Informationen finden Sie unter Erstellen angepasster Grafiken.

Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.


Schaltflächen für die Symbolleisten

Die Schaltflächen der Symbolleiste können im Browser des Benutzers angepasst werden. Sie können das Skript oder das Programm, das von den Schaltflächen aufgerufen wird, sowie das Erscheinungsbild festlegen. Weitere Informationen zur Entwicklung angepasster Programme finden Sie im MSDN Online Web Workshop. Weitere Informationen über das Entwerfen von Symbolleistensymbolen finden Sie unter Erstellen von Symbolen für Internet Explorer.

Vorhandene Symbolleisten-Schaltflächen löschen
Aktivieren Sie dieses Kontrollkästchen, um die vorhandenen Symbolleistenschaltflächen im Browser des Benutzers zu löschen.
Hinzufügen
Sie können angepasste Symbolleisten zur Ausführung von Skripts oder ausführbaren Dateien hinzufügen. Wenn Sie auf Hinzufügen klicken, werden Sie zur Eingabe weiterer Informationen aufgefordert, wie z. B. Symbol, Überschrift und die Aktion, die die Schaltfläche ausführen soll.
Symbolleistentext (erforderlich)
Sie müssen eine Überschrift oder Beschriftung angeben, die unterhalb der Schaltfläche angezeigt wird, wenn der Benutzer sowohl den Text als auch das Symbol auf den Symbolleistenschaltflächen anzeigt. Die empfohlene Maximalgröße ist 10 Zeichen.
Symbolleisten-Aktion, als Skriptdatei oder ausführbare Datei (erforderlich)
Sie müssen das Skript oder die ausführbare Datei angeben, die ausgeführt wird, wenn der Benutzer auf die Symbolleistenschaltfläche klickt.
Farbiges Symbol der Symbolleiste (erforderlich)
Sie müssen ein farbiges Symbol angeben, das dann auf den Symbolleistenschaltflächen angezeigt wird. Das Symbol besteht aus 20x20 Pixel großen Bildern für aktive und inaktive Zustände. Weitere Informationen finden Sie im MSDN Online Web Workshop.
Graustufensymbol der Symbolleiste (erforderlich)
Sie können ein Graustufensymbol für die Symbolleiste angeben, das dann auf Schwarzweißbildschirmen ordnungsgemäß angezeigt wird.
Standardmäßige Anzeige dieser Schaltfläche in der Symbolleiste
Aktivieren Sie dieses Kontrollkästchen, um die angegebene Symbolleistenschaltflächen standardmäßig im Browser des Benutzers anzuzeigen.

Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.


Internet Explorer-Logo

Das Internet Explorer-Logo in der oberen rechten Ecke des Browsers verfügt über zwei Zustände: animiert, wenn der Browser verwendet wird, und statisch, wenn keine Aktionen stattfinden. Sie können die Logobitmap durch Ihre eigene animierte oder statische Bitmap ersetzen.

Anpassen des animierten Logos

Wenn Sie eine animierte Bitmap verwenden, wird der erste Frame statisch angezeigt, wenn keine Aktionen im Browser stattfinden. Die verbleibenden Frames werden mit Animationen angezeigt, wenn der Browser verwendet wird.

Um Ihr eigenes animiertes Logo zu verwenden, müssen Sie zwei animierte Bitmaps zur Verfügung stellen: eine Bitmap mit den Abmessungen 22x22 Pixel und eine Bitmap mit den Abmessungen 38x38 Pixel.

Geben Sie die Pfade der kleinen und der großen angepassten, animierten Bitmap in den zur Verfügung stehenden Feldern ein. Animierte Beispielbitmaps sind im Lieferumfang des IEAK-Toolkits enthalten, das bei der Installation von IEAK im Ordner <IEAK-Programmordner>\Toolkit installiert wurde.

Anpassen des statischen Logos

Wenn Sie eine statische Bitmap verwenden, wird diese unabhängig davon, ob Aktionen im Browser stattfinden oder nicht, immer statisch angezeigt. Um Ihr eigenes statisches Logo zu verwenden, müssen Sie zwei Bitmaps zur Verfügung stellen: eine Bitmap mit den Abmessungen 22x22 Pixel und eine Bitmap mit den Abmessungen 38x38 Pixel.

Geben Sie die Pfade der kleinen und der großen angepassten, animierten Bitmap in den Feldern dieses Bildschirms ein.

Anmerkungen

  • Zwei Tools sind in IEAK enthalten, die Sie beim Erstellen angepasster, animierter Bitmaps für Ihren Browser unterstützen. Eines der Tools wird verwendet, um Bitmaps im oben beschriebenen Format zu stapeln. Das andere Tool zeigt eine Vorschau der Animation an. Informationen zur Verwendung dieser Tools finden Sie unter Tools für animierte Bitmaps.
  • Weitere Informationen zu den Grafiken, die Sie in IEAK anpassen können, finden Sie unter Erstellen angepasster Grafiken.
  • Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen versehen können, finden Sie unter Anpassungsmöglichkeiten.


Wichtige URLs

Sie können die URLs für die Start-, die Such- und die Onlinesupportseiten angeben.

URL der Startseite
Die Startseite, die manchmal auch als Homepage bezeichnet wird, wird angezeigt, wenn der Benutzer auf die Schaltfläche Startseite klickt. Internet Explorer kann eine Standardstartseite anzeigen, oder Sie können einen URL für Ihre eigene Seite angeben.

Geben Sie den URL für die zu verwendende Startseite im Feld URL der Startseite ein. Wenn Sie die Standardstartseite von Internet Explorer verwenden möchten, klicken Sie auf Standardseite.

URL der Suchleiste
Die Suchleiste wird in der Explorerleiste auf der linken Seite des Bildschirms angezeigt. Mit dieser Leiste kann der Benutzer gleichzeitig die Suchabfrage und die Suchergebnisse anzeigen. In der Suchleiste werden bereits mehrere Suchmaschinen angezeigt. Sie können die URL-Adresse für diese Seite gegebenenfalls überschreiben. Weitere Informationen finden Sie unter Anpassen der Suchleiste und des Suchassistenten.
URL der Onlinesupportseite
In Internet Explorer erhalten Sie Supportinformationen, indem Sie auf Hilfe und dann auf Onlinesupport klicken. Es wird empfohlen, eine Supportseite zu erstellen und den Benutzern zur Verfügung zu stellen.

Geben Sie den URL der angepassten Supportseiten im Feld URL der Online-Supportseite ein. Wenn Sie die Standardsupportseite von Internet Explorer verwenden möchten, klicken Sie auf Standardseite.


Favoriten und Links

Sie können den Ordner Favoriten und die Linkleiste anpassen, indem Sie Links zu Sites hinzufügen, die sich auf Ihre Firma oder Ihre Dienste beziehen. Wenn Sie beispielsweise Internetinhaltsanbieter (ICP) sind, der sich auf Unterhaltung spezialisiert hat, können Sie Links zu unterhaltsamen Sites zur Verfügung stellen.

Die Linkleiste wird standardmäßig oben auf dem Bildschirm des Benutzers angezeigt; sie enthält eine Sammlung von Standardlinks. Sie können Links zu den Standardordnern hinzufügen oder neue Ordner hinzufügen. Wenn ein Benutzer auf Favoriten klickt, wird die Favoritenliste auf der linken Seite des Fensters angezeigt.

Favoriten und Links am Anfang der Liste in der angegebenen Reihenfolge anzeigen
Aktivieren Sie dieses Kontrollkästchen, damit die von Ihnen ausgewählten Favoriten an den Anfang der Favoritenliste des Benutzers verschoben werden, sodass sie leichter vom Benutzer gefunden werden können. Wenn Sie dieses Kontrollkästchen aktivieren, sind die Schaltflächen Nach oben und Nach unten verfügbar.
Vorhandene Favoriten und Links löschen (nur Firmenadministratoren)
Aktivieren Sie dieses Kontrollkästchen, um die Einträge in der Favoriten- und der Linkliste des Benutzers zu löschen. Es wird empfohlen, diese Einstellung mit Vorsicht zu verwenden, da durch sie die Links und Favoriten entfernt werden, die die Benutzer eingerichtet haben.
Nur die Favoriten löschen, die durch den Administrator erstellt wurden (nur Firmenadministratoren)
Aktivieren Sie dieses Kontrollkästchen, um nur die Einträge in der Favoriten- und der Linkliste des Benutzers zu löschen, die Sie für den Benutzer eingerichtet haben.

Eine Abbildung, die zeigt, wie Sie Ihr angepasstes Browserpaket mit Branding-Informationen und angepassten Links versehen können, finden Sie unter Anpassungsmöglichkeiten.

So fügen Sie der Favoritenliste oder der Linkleiste einen Ordner manuell hinzu

  1. Klicken Sie auf Favoriten, Links oder einen Ordner unter Favoriten bzw. Links, und klicken Sie dann auf Ordner hinzufügen.
  2. Geben Sie den Namen Ihres Ordners im Feld Name ein. Es kann sich um einen Anzeigenamen handeln, durch den Benutzer besser erkennen können, welche Arten von Links sich im Ordner befinden.

Anmerkung

  • Semikolons und Schrägstriche sind in Ordnerbezeichnungen nicht zulässig.

So importieren Sie einen Ordner mit Links auf Ihrem Computer in die Favoritenliste oder die Linkleiste

  1. Klicken Sie auf Favoriten, Links oder einen Ordner unter Favoriten bzw. Links, und klicken Sie dann auf Importieren.
  2. Geben Sie im Dialogfeld Nach Ordner suchen den Speicherort des gewünschten Ordners mit den Links auf Ihrem Computer an. Wahrscheinlich befindet sich dieser Ordner im Ordner \Windows\Favoriten.

So fügen Sie der Favoritenliste oder der Linkleiste eine Webseite hinzu

  1. Klicken Sie auf Favoriten, Links oder einen Ordner unter Favoriten oder Links, und klicken Sie dann auf URL hinzufügen.
  2. Geben Sie im Dialogfeld Details einen Namen für die Seite in das Feld Name ein. Es kann sich um einen Anzeigenamen handeln, durch den Benutzer besser erkennen können, auf welche Seite der Link verweist.
  3. Geben Sie das Ziel Ihres Links im Feld URL ein.
  4. Wenn Sie für diesen Link ein angepasstes Symbol mit den Abmessungen 16x16 Pixel festlegen möchten, geben Sie den Namen der Bitmapdatei in das Feld Symbol ein.

    Weitere Informationen finden Sie unter Erstellen angepasster Grafiken.

  5. Wenn Sie Firmenadministrator sind, aktivieren Sie das Kontrollkästchen Offline verfügbar machen, damit diese Seite auch dann für die Benutzer verfügbar ist, wenn sie keine Verbindung mit dem Internet besteht. Diese Option ist häufig für Benutzer mit Laptopcomputern hilfreich.
  6. Klicken Sie auf OK, um das Dialogfeld Details zu schließen.

Anmerkungen

  • Um einen Link zu testen, klicken Sie in der Liste auf den entsprechenden URL und dann auf URL testen.
  • Sie können dem Ordner Favoriten bis zu 200 Links hinzufügen.
  • Zum Entfernen eines Eintrags aus der Favoritenliste oder der Linkleiste klicken Sie mit der rechten Maustaste auf den Ordner und dann auf Entfernen.


"Willkommen"-Seite

Internet Explorer zeigt eine "Willkommen"-Seite an, wenn der Browser das erste Mal gestartet wird. Sie können die Internet Explorer-Standard-"Willkommen"-Seite anzeigen oder Ihre eigene, angepasste "Willkommen"-Seite angeben.

Microsoft Internet Explorer 5-"Willkommen"-Seite anzeigen (Standard)
Wählen Sie diese Option aus, um die Standard-"Willkommen"-Seite von Internet Explorer anzuzeigen.
Keine "Willkommen"-Seite anzeigen
Wählen Sie diese Option aus, wenn Sie keine "Willkommen"-Seite anzeigen möchten. Die erste Seite, die in diesem Fall angezeigt wird, ist die Startseite.
Angepasste "Willkommen"-Seite verwenden (URL unten angeben)
Wählen Sie diese Option aus, wenn Sie eine angepasste "Willkommen"-Seite verwenden möchten, und geben Sie dann den URL in das unten stehende Feld ein.

Anmerkung

  • Die "Willkommen"-Seite wird nur angezeigt, wenn die Benutzer über eine Verbindung mit dem Internet oder dem Intranet verfügen.


Channels

Sie können einen angepassten Channel oder eine Channelkategorie (Ordner) hinzufügen bzw. die Channeleinstellungen von Ihrem Computer importieren. Beim Importieren von Channels lassen sich diese weiter anpassen. Sie können z. B. Ihre Channeleinstellungen importieren, dabei jedoch einen der importierten Channels löschen.

Zum Hinzufügen von Channels sollten Sie bereits über Informationen zu Ihrem Channel oder der Channelkategorie verfügen, beispielsweise den Pfad der Bilder, sowie die Titel kennen, die Sie verwenden möchten. Außerdem sollten Sie über eine Channeldefinitionsformat-Datei (.CDF-Datei) für jeden Channel verfügen.

Falls Ihr angepasstes Internet Explorer-Paket möglicherweise auf einem Computer installiert wird, auf dem Internet Explorer 4 nie installiert wurde, und Sie den Benutzern die Möglichkeit zur Nutzung von Channels anbieten möchten, sollten Sie sicherstellen, dass das Offline Browsing-Paket bei allen Installationsoptionen, die in Ihrem angepassten Paket verfügbar sind, auf dem Zielcomputer installiert wird. Falls Sie Benutzern die Möglichkeit bieten, ihre Setup-Optionen anzupassen, müssen Sie festlegen, dass diese Option nicht als angepasste Installationsoption angezeigt werden soll. Deaktivieren Sie hierzu auf der Seite Erweiterte Installationsoptionen das Kontrollkästchen Offline suchen. Unter Windows Update Setup wird nun in der rechten Spalte für diese Komponente Installation erzwingen angezeigt.

Vorhandene Channels löschen
Wenn Sie Firmenadministrator sind, können die vorhandenen Einstellungen auf den Computern der Benutzer gelöscht werden, indem Sie dieses Kontrollkästchen aktivieren.
Standardmäßig Channelleiste auf dem Desktop anzeigen
Wenn Sie Firmenadministrator sind und die Windows Desktop-Aktualisierung einrichten oder Internet Explorer auf Computern unter Windows 98 installieren, können Sie die Channelleiste standardmäßig auf den Desktops der Benutzer einrichten.
Channel hinzufügen
Zum Hinzufügen eines Channels klicken Sie auf Channel hinzufügen und geben dann die folgenden Informationen an:
Channeltitel (erforderlich)
Geben Sie den Titel des Channels an. Dieser wird in der Favoritenliste des Benutzers angezeigt.
Webserver-URL für Channeldefinitionsdatei (erforderlich)
Geben Sie den URL der .CDF-Datei für diesen Channel ein. Die .CDF-Datei stellt Informationen dazu zur Verfügung, wann und wie Ihre Inhalte aktualisiert werden sollen.
Pfad für Channeldefinitionsdatei
Geben Sie den Pfad für den Speicherort der .CDF-Datei (auf der lokalen Festplatte oder im Netzwerk) ein, oder klicken Sie auf Durchsuchen, um den Speicherort der Datei anzugeben.
Pfad für kleine Channelbitmap
Geben Sie den Pfad für das schmale Channelbild an, oder klicken Sie auf Durchsuchen, um die Bitmap zu suchen.
Pfad für Channelsymbol
Geben Sie den Pfad für das Channelsymbol ein, oder klicken Sie auf Durchsuchen, um es zu suchen.
Offline verfügbar machen
Aktivieren Sie dieses Kontrollkästchen, um den Channel offline zur Verfügung zu stellen. Wenn Inhalt offline verfügbar gemacht wird, können Benutzer diesen Inhalt auch dann lesen, wenn ihre Computer nicht mit dem Internet verbunden sind. Beispielsweise können sie auf ihren Laptop-Computern Inhalte anzeigen, ohne über eine Netzwerk- oder Internetverbindung zu verfügen.

Anmerkung

  • Wenn Sie eine .CDF-Datei für einen angepasste Channel angeben, stellen Sie sicher, dass die .CDF-Datei keine LOGO-Tags mit den Parametern IMAGE oder ICON enthält.
  • Verwenden Sie die folgende Syntax, wenn Sie einen Channel innerhalb einer Channelkategorie hinzufügen:
    <Kategorienname>\<Channelname>

    Beispiel
    Eigene Kategorie\Eigener Channel

Hinzufügen einer Channelkategorie (Ordner mit Channels)
Zum Hinzufügen einer Channelkategorie klicken Sie auf Kategorie hinzufügen und geben dann die folgenden Informationen an:
Titel der Kategorie
Geben Sie den Titel der Channelkategorie ein.
HTML-Datei der Kategorie
Geben Sie den URL die HTML-Seite für Ihre Kategorie ein.
Pfad für kleine Kategoriebitmap
Geben Sie den Pfad für das schmale Bild der Kategorie ein. Weitere Informationen finden Sie unter Erstellen angepasster Grafiken.
Pfad für Kategoriesymbol
Geben Sie den Pfad des Symbols ein, das für Ihre Kategorie angezeigt wird.
Bearbeiten von Channels
Zum Bearbeiten eines Channels oder einer Channelkategorie, die Sie hinzugefügt oder importiert haben, klicken Sie auf Bearbeiten. Das Dialogfeld mit den Bild- und Pfadeinstellungen wird angezeigt.
Entfernen von Channels
Zum Entfernen eines Channels oder einer Kategorie, den bzw. die Sie hinzugefügt oder importiert haben, wählen Sie das Element aus und klicken dann auf Entfernen.
Importieren von Channels
Zum Importieren der Channeleinstellungen von Ihrem Computer klicken Sie auf Importieren. Der Assistent braucht nicht geschlossen werden, wenn Sie die Channeleinstellungen vor dem Importieren ändern möchten. Wechseln Sie einfach zu Ihrem Browser, ändern Sie die Channeleinstellungen, und wechseln Sie dann wieder zurück zum Assistenten.
Den Link 'Channels anzeigen' aus der Schnellstartleiste löschen
Wenn Sie dieses Kontrollkästchen aktivieren, wird die Verknüpfung Channels anzeigen von der Schnellstartsymbolleiste entfernt.


Active Desktop

Über Active Desktop können Benutzer Webinhalte auf ihre Desktops übertragen, beispielsweise Wetterkarten, die regelmäßig aktualisiert werden. Sie können die Einstellungen Ihres Desktops als Firmenstandard importieren, damit alle Benutzer den gleichen Desktop haben. In nächsten Schritt des Assistenten können Sie festlegen, ob Benutzer diese Einstellungen ändern können.

Damit Ihre Active Desktop-Einstellungen importiert werden können, müssen Sie die Windows Desktop-Aktualisierung in das Browserpaket integrieren und den Desktop auf dem Computer, auf dem Sie die Version erstellen, ausführen.

Um Ihre aktuellen Einstellungen als Standarddesktop für Ihre Firma zu verwenden, klicken Sie auf Die aktuellen Active Desktop-Komponenten importieren. Klicken Sie auf Einstellungen ändern, um Ihre aktuellen Einstellungen zu ändern, damit Sie sie importieren können. Klicken Sie auf Active Desktop nicht anpassen, wenn Sie die Desktops der Benutzer nicht anpassen möchten.


Desktopsymbolleisten

Mit dem neuen Desktop können Benutzer Symbolleisten zu der Windows-Taskleiste in Ihrem IEAK-Paket hinzufügen. Hierdurch wird der Zugriff auf Programme, Dateien, Ordner, Abonnements und bevorzugte Webseiten noch einfacher. Außerdem können Sie Symbolleisten an beliebigen Stellen auf dem Desktop, der in Ihrem IEAK-Paket enthalten ist, positionieren und ihre Größe ändern.

Zum Festlegen von Desktopsymbolleisten müssen Sie die Windows Desktop-Aktualisierung in das Browserpaket integrieren und den Desktop auf dem Computer, auf dem Sie die Version erstellen, ausführen.

Sie können Ihre aktuellen Einstellungen importieren, indem Sie auf Importieren der aktuellen Einstellungen der Desktopsymbolleisten klicken. Wenn Sie wünschen, dass die Benutzer die Standardeinstellungen der Symbolleiste übernehmen, klicken Sie auf Keine Anpassung der Desktopsymbolleisten.

Die folgenden vier Symbolleisten können an beliebiger Stelle hinzugefügt werden:

  • Die Symbolleiste Schnellstart stellt Verknüpfungen zu mehreren häufig verwendeten Features von Internet Explorer zur Verfügung: zum Desktop, zum Webbrowser, zu Outlook Express und zu den Channels.
  • Die Symbolleiste Adressen ermöglicht das Anzeigen einer Internetadresse (URL), ohne zuvor den Internet Explorer-Browser öffnen zu müssen.
  • Die Symbolleiste Links stellt Verknüpfungen zu wichtigen Websites (z. B. www.microsoft.com) zur Verfügung. Auf diese Weise können Sie die Verknüpfungen aktivieren, ohne zuerst den Internet Explorer-Browser öffnen zu müssen.
  • Die Symbolleiste Desktop enthält alle Verknüpfungen Ihres Desktops und organisiert diese an einem zentralen Ort.

Zusätzlich zu den bereits bestehenden Symbolleisten können Sie eine Symbolleiste aus den Inhalten jedes beliebigen Ordners erstellen. Zum Beispiel ließe sich eine Symbolleiste für die Systemsteuerung erstellen oder eine Symbolleiste mit Symbolen für jeden Ihrer monatlichen Verkaufsberichte.

So erstellen Sie eine neue Symbolleiste

  1. Klicken Sie mit der rechten Maustaste auf die Taskleiste, zeigen Sie auf Symbolleisten, und klicken Sie auf Neue Symbolleiste.
  2. Geben Sie den Pfad des Ordners oder die Adresse der Internetsite ein, der oder die als Symbolleiste angezeigt werden soll, oder wählen Sie diese aus der Liste aus.

Anmerkungen

  • Um eine Symbolleiste auf den Desktop zu verschieben, ziehen Sie sie mit der Maus an die gewünschte Position, und passen Sie anschließend ihre Größe entsprechend an.
  • Um eine Symbolleiste mit Ihren bevorzugten Verknüpfungen zu erhalten, erstellen Sie auf Ihrer Festplatte einen Ordner, in dem Sie die gewünschten Verknüpfungen ablegen. Anschließend können Sie für diesen Ordner eine Symbolleiste erstellen.


Webansichten für Ordner

Sie können das Aussehen des Arbeitsplatzes und der Systemsteuerung auf den Computern Ihrer Firma anpassen, indem Sie die Dateien bearbeiten, die für diese als Vorlage dienen. Wenn der Benutzer dann die Windows Desktop-Aktualisierung installiert, werden Arbeitsplatz und Systemsteuerung als Webseiten angezeigt. Sie können diese Ordner beispielsweise anpassen, um Anweisungen, ein Firmenlogo oder Links zu Support- oder Firmensites zur Verfügung zu stellen.

Zum Festlegen von Webansichten für Ordner müssen Sie die Windows Desktop-Aktualisierung in das Browserpaket integrieren und den Desktop auf dem Computer, auf dem Sie die Version erstellen, ausführen.

Verwenden Sie hierzu die folgenden Vorlagendateien:

  • Mycomp.htt für den Arbeitsplatz
  • Controlp.htt für die Systemsteuerung

Wenn Sie die Windows Desktop-Aktualisierung auf Ihrem Computer installiert haben, befinden sich diese Dateien im Ordner C:\Windows\Web oder C:\WinNT. Sie können sie mit einem Texteditor öffnen, beispielsweise mit Editor oder einem HTML-Editor. Es wird empfohlen, eine Sicherungskopie dieser Dateien zu erstellen, bevor Sie sie bearbeiten, damit Sie bei Bedarf den Originalzustand wiederherstellen können.

Sie können diese Dateien auf verschiedene Weisen ändern, indem Sie eigene Links oder Grafiken hinzufügen, Farben ändern oder auch, indem Sie festlegen, welche Inhalte (Symbole und Dateinamen) angezeigt werden. Sie haben die Möglichkeit, beispielsweise die Symbole der Systemsteuerung nicht anzuzeigen und statt dessen grafische Schaltflächen zur Verfügung zu stellen, auf die Benutzer nur für diejenigen Einstellungen klicken können, die Sie zur Verfügung stellen möchten.

Diese Dateien verwenden Active Scripting, beispielsweise JavaScript, JScript oder Visual Basic Scripting Edition (VBScript). Die vorhandenen Dateien Mycomp.htt und Controlp.htt sowie weitere Dateien des Desktops (Folder.htt und Printers.htt) verwenden JavaScript. Sie können einige Teile dieser Dateien ohne Scripting bearbeiten, oder Sie können das entsprechende Scripting hinzufügen oder bearbeiten, wenn Sie mit Scripting vertraut sind.

Diese Vorlagendateien sind HTML-Dateien sehr ähnlich, mit Ausnahme der drei Variablen %THISDIRNAME%, %THISDIRPATH% und %TEMPLATEDIR%, die durch einen MIME-Filter verarbeitet und durch die richtigen Datei- oder Pfadangaben ersetzt werden. Diese Variablen werden eingesetzt, um Links zu externen Dateien wie beispielsweise Grafiken anzugeben. Obwohl sich diese Vorlagendateien im Ordner C:\Windows\Web oder C:\WinNT befinden, werden sie im Ordner \Temp verarbeitet. Aus diesem Grund sind die Pfadinformationen erforderlich, damit sichergestellt wird, dass die Links zu anderen Objekten funktionieren.

Es ist wichtig, dass Sie sicherstellen, dass die angepassten Versionen von Arbeitsplatz und der Systemsteuerung ihre Anzeigegröße entsprechend der Bildschirmauflösung des Benutzers anpassen und dass sie einwandfrei angezeigt werden. In den Dateien Mycomp.htt und Controlp.htt wird die folgende Syntax verwendet, um die einwandfreie Größenanpassung zu gewährleisten:

<SCRIPT LANGUAGE="JavaScript">
  window.onresize = fixSize;
</SCRIPT>

Diese Dateien verwenden das Objekt FileList, um die Inhalte (Symbole und Dateinamen) des Arbeitsplatzes und der Systemsteuerung darzustellen. Im Arbeitsplatz wird ein Tortendiagramm, das den verfügbaren freien Speicherplatz anzeigt, durch das Objekt PieChart dargestellt. Diese Objekte sind optional.

Weitere Informationen über Scripting finden Sie im MSDN Online Web Workshop.

Im Arbeitsplatz und der Systemsteuerung werden Infos aus der Registrierung angezeigt, wenn ein Benutzer auf ein Objekt zeigt. Diese Infos bieten eine kurze Beschreibung des betreffenden Objekts.

Sie können auch die Vorlagendateien Printers.htt (Drucker) und Folder.htt (Standardwebansicht für Ordner) in den Ordnern C:\Windows\Web oder C:\Win\NT Ihres Computers oder der Computer der Benutzer anpassen. Diese Dateien können nicht in Ihrem angepassten IEAK-Paket enthalten sein.

Wenn gewünscht, können Sie eine HTML-Datei zur Verfügung stellen, anstatt die .HTT-Dateien zu bearbeiten. Zu diesem Zweck müssen Sie die entsprechenden Verweise auf PersistMoniker in der Registrierung in PersistFile ändern und diese Verweise auf Ihre angepasste Datei zeigen lassen.

Anmerkung

  • Das Ändern von Werten der Registrierung kann sich negativ auf das Betriebssystem auswirken. Sie ändern Registrierungswerte auf eigene Gefahr.


Angepasste Desktop-Komponente

Sie können dem Desktop der Benutzer eine angepasste Active Desktop-Komponente hinzufügen. Diese Komponente kann ein Channel (.CDF-Datei), eine Webseite (HTML-Datei) oder ein Bild im .GIF- oder Bitmapformat sein.

Zum Festlegen einer angepassten Desktop-Komponente müssen Sie die Windows Desktop-Aktualisierung in das Browserpaket integrieren und den Desktop auf dem Computer ausführen, auf dem Sie die Version erstellen.

URL der Desktop-Komponente oder Dateipfad
Geben Sie die Datei und den Dateipfad an. Klicken Sie auf Durchsuchen, um den Speicherort der Datei anzugeben. Wenn Sie in dieser Komponente andere Dateien angeben, beispielsweise .GIF-Dateien oder eine andere Webseite, stellen Sie sicher, dass sich diese im gleichen Ordner wie die Komponente befinden.


Benutzeragententext

Einige Firmen führen Sitestatistiken. Sie zeichnen beispielsweise auf, wie oft und mit welcher Art von Webbrowser auf ihre Inhalte zugegriffen wurde. Der Benutzeragententext unterstützt Sie bei der Identifikation des Browsertyps.

Angepasster Text, der dem Benutzeragententext hinzugefügt wird
Die Zeichenfolge, die Sie in diesem Feld eingeben, wird an den Benutzeragententext des angepassten Browsers angehängt. Sie müssen den Benutzeragententext nicht anpassen, es sei denn, dass Sie die Verwendung Ihres angepassten Browsers verfolgen und Browserstatistiken aus anderen Internetsites sammeln möchten. Bitte beachten Sie, dass andere Firmen, die Sitestatistiken führen, den angepassten Text anzeigen können.


Automatische Konfiguration

Sie können Dateien URLs zuweisen, die automatisch die angepassten Browser konfigurieren. Dieses Feature ist sinnvoll, wenn Sie die Einstellungen mehrerer Benutzer von einem zentralen Ort aus steuern möchten.

Sie können Optionen konfigurieren, indem Sie .INS-Dateien verwenden, die auch als IEAK-Profile bezeichnet werden. Wenn Sie mit .INS-Dateien arbeiten, können Sie Proxy-Standardeinstellungen verwenden. Außerdem können Sie Skriptdateien in den Formaten .JS, .JVS oder .PAC angeben, die Ihnen das Konfigurieren und Verwalten von erweiterten Proxyeinstellungen ermöglichen.

Netzwerkserver, die DNS (Domain Name System) oder DHCP (Dynamic Host Configuration Protocol) einsetzen, können automatisch die Einstellungen eines Browsers ermitteln und konfigurieren, wenn der Benutzer den Browser zum ersten Mal im Netzwerk ausführt. Weitere Informationen finden Sie unter Automatische Erkennung und Konfiguration von Proxyeinstellungen.

Wenn Sie URLs sowohl für automatische Konfiguration als auch für automatischen Proxy (Autoproxy) angeben, wird der Autoproxy-URL in die .INS-Datei aufgenommen. Die richtige Schreibweise für den URL ist http://share/test.ins.

Um die automatische Konfiguration zu ermöglichen, aktivieren Sie das Kontrollkästchen Automatische Konfiguration aktivieren. Geben Sie im Feld URL für AutoKonfiguration (.INS-Datei) den URL für die .INS- oder .ASP-Datei ein, die angezeigt werden soll. Geben Sie im Feld URL für Autoproxy (.JS, .JVS oder .PAC-Datei) den URL für das Autoproxy-Skript ein.

Weitere Informationen über Autoproxy-Dateien finden Sie unter JavaScript oder JScript Autoproxy-Beispieldateien. Weitere Informationen zur Proxyauswahl und -umgehung finden Sie unter Verwenden von Proxyserverauswahl und Proxyserverumgehungslisten.

Zur automatischen Erkennung von Proxyservereinstellungen aktivieren Sie das Kontrollkästchen Automatische Ermittlung von Konfigurationseinstellungen.

Automatische Konfiguration alle xx Minuten durchführen
Sie können das Intervall für das Feature Autokonfiguration in Minuten angeben. Wenn Sie Null oder keinen Wert eingeben, wird die automatische Konfiguration nur durchgeführt, wenn der Computer des Benutzers neu gestartet wird.


Verbindungseinstellungen

Sie können für Ihre Benutzer vordefinierte Verbindungseinstellungen festlegen, indem Sie die Verbindungseinstellungen von Ihrem Computer importieren.

Die zu importierenden Einstellungen können angezeigt werden, indem Sie im Browser im Menü Extras auf Internetoptionen und anschließend auf die Registerkarte Verbindungen klicken. Klicken Sie zum Anzeigen der DFÜ-Einstellungen auf Einstellungen und zum Anzeigen der Netzwerkeinstellungen auf LAN-Einstellungen. Die Adresse für die automatische Konfiguration wird jedoch nicht importiert.

Kein Anpassen der Verbindungseinstellungen
Wählen Sie diese Option, wenn Sie keine vordefinierten Benutzereinstellungen verwenden möchten.
Aktuelle Verbindungseinstellungen importieren von diesem Computer
Wählen Sie diese Option, wenn als vordefinierte Benutzereinstellungen die von Ihrem Computer importierten Werte verwendet werden sollen. Klicken Sie auf Einstellungen ändern, wenn Sie die von Ihrem Computer importierten Einstellungen ändern möchten
Vorhandene DFÜ-Verbindungseinstellungen löschen
Als Firmenadministrator aktivieren Sie dieses Kontrollkästchen, um die bestehenden Einstellungen auf den Computern der Benutzer zu löschen.
Alle Verknüpfungen mit dem Assistenten für den Internetzugang entfernen
Wenn Sie dieses Kontrollkästchen aktivieren, werden die Verknüpfungen des Assistenten für den Internetzugang von der Schnellstartsymbolleiste entfernt.

Anmerkung

  • Als Firmenadministrator können Sie auch Systempraktiken und Einschränkungen verwenden, um festzulegen, ob Benutzer ihre Verbindungseinstellungen ändern können. Praktiken und Einschränkungen können in Schritt 5 des Assistenten für die Internet Explorer-Anpassung oder über die automatische Konfiguration festgelegt werden.


Proxyeinstellungen

Sie können die Proxyserver angeben, zu denen Benutzer Verbindungen herstellen. Ein Proxyserver dient als Sicherheitsbarriere zwischen dem Benutzer einer Arbeitsstation und dem Internet. Durch den Proxyserver wird die Steuerung der Verwaltung sowie die Zwischenspeicherung von Diensten ermöglicht.

Wenn Sie Proxyserver für einen der aufgelisteten Dienste einsetzen möchten, aktivieren Sie das Kontrollkästchen Proxyeinstellungen aktivieren.

Geben Sie die Adresse des Proxyservers rechts neben dem entsprechenden aufgelisteten Dienst ein. Geben Sie die Anschlussnummer (häufig 80) in die entsprechenden Felder unter Anschluss ein.

Um für alle Dienste die gleichen Einstellungen zu verwenden, aktivieren Sie das Kontrollkästchen Für alle Adressen den selben Proxyserver verwenden.

In bestimmten Fällen möchten Sie möglicherweise keinen Proxyserver verwenden, beispielsweise für Adressen in Ihrem Intranet. Sie können die entsprechenden Adressen in das Feld unter Für Adressen, die wie folgt beginnen, keinen Proxyserver verwenden eingeben. Verwenden Sie ein Semikolon, um die einzelnen Einträge zu trennen. Um Proxyserver für alle Adressen in Ihrem Intranet zu umgehen, aktivieren Sie das Kontrollkästchen Keinen Proxyserver für lokale Adressen (Intranet) verwenden.

Weitere Informationen finden Sie unter Verwenden von Proxyserverauswahl und Proxyserverumgehungslisten.


Hinzufügen eines Ursprungszertifikats

Sie können ein Ursprungszertifikat zu Ihrem angepassten IEAK-Paket hinzufügen, indem Sie den URL im Feld Pfad für neues Ursprungszertifikat eingeben. Hierdurch wird eine Vertrauensebene gebildet, die weiter unten in der Hierarchie eingeordnete Zertifikate übernehmen können. Jedes Zertifikat wird auf ein übergeordnetes Zertifikat untersucht, bis das Ursprungszertifikat erreicht ist.


Anmelde-Methode

Wenn Sie ein Internetdienstanbieter (ISP) sind, können Sie angeben, auf welche Weise sich Benutzer bei Ihrem Dienst anmelden und eine Verbindung zum Internet herstellen können.

Serverbasierte Anmeldung unter Verwendung des Assistenten für den Internetzugang (empfohlen)
Die Methode Internetanmeldeserver bietet vollständige Flexibilität und lässt sich dynamisch einer Reihe von Anmeldeoptionen zuordnen. Sie erstellen Serverlösungen, die Informationen mit den Bildschirmen des Assistenten für den Internetzugang austauschen. Weitere Informationen finden Sie unter Internetanmeldung mit dem Assistenten für den Internetzugang.
Serverbasierte Anmeldung über den Kioskmodus
Die Methode Internetanmeldeserver bietet vollständige Flexibilität und lässt sich dynamisch einer Reihe von Anmeldeoptionen zuordnen. Sie erstellen Serverlösungen, die Informationen mit dem Browser im Kioskmodus (Vollbildschirm) austauschen, ohne dass die Symbolleistenschaltflächen angezeigt werden. Weitere Informationen finden Sie unter Einrichten eines Anmeldeservers im Kioskmodus (Vollbildschirm).
Serverlose Anmeldung
Die serverlose Anmeldemethode erfordert keinen Anmeldeserver. Wenn Sie sich für die serverlose Methode entscheiden, fordert der Assistent für die Internet Explorer-Anpassung Sie auf, die für das Steuern des Anmeldevorgangs erforderlichen Informationen zur Verfügung zu stellen. Wenn Sie diese Option wählen, werden Sie aufgefordert, Wähl-, Gateway- und Kennwortinformationen einzugeben. Sie können die Anmeldeseite auch mit Hilfe des Assistenten für die Internet Explorer-Anpassung testen. Das serverlose Anmeldeverfahren ist nicht zum Anpassen des Assistenten für den Internetzugang geeignet.
Keine Anmeldung
Geben Sie diese Methode an, wenn Sie nicht wünschen, dass Benutzer einen Anmeldevorgang durchlaufen, wenn Sie ihren angepassten Browser installieren. Diese Option kann hilfreich sein, wenn Kabelmodems verwendet werden.

Ein Beispiel für den Anmeldevorgang finden Sie unter ISP-Anmeldevorgang.


Anmeldedateien

Damit Benutzer ihre Computer so konfigurieren können, dass diese eine Verbindung zu Ihren Servern herstellen können, müssen Sie angepasste Anmeldedateien erstellen. Weitere Informationen finden Sie unter Einrichten eines Anmeldeservers und Internetanmeldung mit dem Assistenten für den Internetzugang.

Bei der ersten dieser Dateien muss es sich um eine HTML-Seite handeln, die Informationen zu Ihrem Dienst enthält. Für die Internetanmeldung im Kioskmodus muss diese Datei Signup.htm heißen, und sie muss einen Link zu der entsprechenden HTML-Seite auf Ihrem Anmeldeserver enthalten. Für die Internetanmeldung mit dem Assistenten für den Internetzugang muss der Name dieser Datei Icwsign.htm lauten.

Auf der Seite Anmeldedateien wird das Arbeitsverzeichnis für die Anmeldedateien angezeigt. Wenn Sie bereits Ihre Anmeldedateien bearbeitet haben, klicken Sie auf Dateien kopieren, um diese in das Arbeitsverzeichnis zu kopieren. Aktivieren Sie das Kontrollkästchen Die ".ISP"-Dateieinträge überprüfen/ändern bzw. Die ".INS"-Dateieinträge überprüfen/ändern, wenn Sie Einstellungen in den .ISP-Dateien oder .INS-Dateien mit Hilfe der Seiten, die im Schritt 4 des Assistenten angezeigt werden, überprüfen oder ändern möchten.

Alle Anmeldedateien einschließlich der Grafikdateien müssen im gleichen Ordner gespeichert werden. Sie müssen für diesen Ordner Lese- und Schreibberechtigung besitzen, da der Assistent die Attribute aller Dateien in Lese-/Schreibberechtigung ändern muss.

Festlegen angepasster Anmeldedateien
Geben Sie den Pfad des Ordners ein, der Ihre Anmeldedateien enthält, oder klicken Sie auf Durchsuchen, um den Speicherort des Ordners anzugeben.

Anmerkung

  • Weitere Informationen zu .ISP-Dateien erhalten Sie unter Erstellen einer.ISP-Datei.


Informationen für den Anmeldeserver und Dateien für Interneteinstellungen

Im Bildschirm mit den Anmeldeserverinformationen können die DFÜ-Verbindungen der Benutzer konfiguriert werden, sodass diese eine Verbindung zum Internetserver herstellen können.

Im Bildschirm für die Dateien mit den Interneteinstellungen legen Sie die Einstellungen fest, die der Assistent für die Internet Explorer-Anpassung zum Erstellen einer .INS-Datei verwendet. Die .INS-Datei kann auf dem Server bereitgestellt oder in das angepasste Paket integriert werden, das Sie für die serverlose Anmeldung erstellen.

Name der Verbindung
Geben Sie den Namen Ihres Anmeldeservers ein. Es kann sich um einen Anzeigenamen handeln.
Dateiname
Geben Sie den Dateinamen für Ihre Datei ein. Für Anmeldeparameter sollte die Datei die Erweiterung .ISP haben; für Interneteinstellungen sollte die Datei die Erweiterung .INS haben.
Verbindungseigenschaften
Geben Sie die Ortskennzahl, die Telefonnummer, den Landeskennzahl und die Länder-ID für diese Verbindung ein.
Support-Telefonnummer
Hier können Sie die Telefonnummer des Technischen Support angeben.
URL für die erste Onlineanmeldeseite
Geben Sie die URL-Adresse für die erste Seite des Anmeldevorgangs ein.
Weitere Optionen
Klicken Sie auf Weitere Optionen, um die folgenden Wähl- und Gatewayeinstellungen festzulegen
Statische DNS-Adresse verwenden
Das DNS (Domain Name System) stellt eine Sammlung von Protokollen und Diensten für TCP/IP (Transmission Control Protocol/Internet Protocol)-Netzwerke dar. DNS ermöglicht die Verwendung von "Anzeigenamen" wie beispielsweise www.microsoft.com anstelle numerischer Adressen. Um sicherzustellen, dass alle DNS-Server beim Versuch, Namen und IP-Adressen einander zuzuordnen, durchsucht werden, aktivieren Sie dieses Kontrollkästchen und geben manuell eine primäre und eine alternative Adresse ein.
Anmeldung erforderlich
Verwenden Sie diese Option, um sicherzustellen, dass auf dem Clientcomputer der Windows-Anmeldedienst aktiviert ist. Durch Angabe eines Windows-Kennwortes steht der Zugriff auf den Windows-Kennwortzwischenspeicher, in dem das ISP-Kennwort gespeichert wird, zur Verfügung. Diese Option ist besonders hilfreich, wenn Sie lange, zufällig gewählte Zeichenfolgen als Kennwort zuweisen. Diese Option ist nur für Windows 95- und Windows 98-Clients gültig.
TCP/IP aushandeln
Diese Option legt fest, ob TCP/IP beim Herstellen einer Internetverbindung als Protokoll vereinbart wird.
LCP deaktivieren
Zeigt an, ob beim Herstellen einer Verbindung über das Point-to-Point-Protokoll die LCP (Link Control Protocol)-Erweiterungen verwendet werden sollen. Unterstützt der Anmeldeserver die LCP-Erweiterungen nicht, sollten Sie LCP auf dem Clientcomputer, der sich an Ihrem Server anmeldet, deaktivieren. Diese Option ist nur für Windows NT 4.0-Clients gültig.
Nummer wie angezeigt wählen
Verhindert das Wählen einer standardmäßig eingestellten Vorwahl. Sie können dieses Flag setzen, wenn einige Benutzer beispielsweise von einer anderen Vorwahl aus anrufen als von der Standardvorwahl. Falls die Benutzer nicht wissen, dass sich die Standardvorwahl von ihrer aktuellen Vorwahl unterscheidet, könnten unerwartet Gebühren für Ferngespräche anfallen.
Kennwort verschlüsseln
Diese Option legt fest, dass nur verschlüsselte Kennwörter an Ihren Computer gesendet oder von ihm akzeptiert werden. Diese Option ist sinnvoll, wenn Sie zusätzliche Sicherheit für die Verbindung benötigen. Der Computer, zu dem Sie eine Verbindung herstellen, muss verschlüsselte Kennwörter unterstützen, damit diese Option wirksam werden kann.
Softwarekomprimierung verwenden
Diese Option legt fest, ob eingehende oder ausgehende Informationen vor dem Senden komprimiert werden. Diese Option eignet sich zum Beschleunigen der Informationsübertragung. Komprimierung findet nur statt, wenn beide Computer kompatible Komprimierung verwenden.
IP-Header-Komprimierung verwenden
Die TCP/IP-Header-Komprimierung verbessert die Effizienz der Bandbreitenausnutzung bei langsamen seriellen Verbindungen. Normalerweise optimiert sie die Datenübertragung zwischen Computern.

Wenn ein kleinerer Header erstellt wird, der die Verbindung identifiziert und die Felder angibt, die sich geändert haben, müssen weniger Bytes übertragen werden. Damit die Komprimierung ordnungsgemäß ausgeführt werden kann, müssen die Pakete in der richtigen Reihenfolge eingehen. Komprimierung ist nicht immer erwünscht. Wenn Sie beispielsweise eine ältere Ausrüstung einsetzen, können Sie die Komprimierung möglicherweise nicht verwenden. Damit die wechselseitige Funktionalität gewahrt bleibt, sollten IP-Treiber für serielle Leitungen, die Header-Komprimierung erlauben, ein durch den Benutzer konfigurierbares Flag haben, um die Komprimierung deaktivieren zu können.

Standard-Gateway verwenden
Diese Option legt fest, ob IP (Internet Protocol)-Verkehr standardmäßig an die WAN (Wide Area Network)-Verbindung umgeleitet wird. Ein Gateway stellt eine Verbindung oder einen Austauschpunkt dar, die oder der zwei Netzwerke verbindet, die andernfalls inkompatibel wären.
Aktuelle Branding-Informationen für diese Dateien liefern
Aktivieren Sie dieses Kontrollkästchen, wenn alle angepassten Branding-Informationen, die Sie im Assistenten für die Internet Explorer-Anpassung festgelegt haben, in diese Anmeldedatei übernommen werden sollen.
Name der Branding-Cabinett-Datei (.CAB)
Geben Sie den Namen der Kabinettdatei (.CAB-Datei) ein, die Ihre Brandinginformation enthält. Bei der Angabe eines Dateinamens sollten Sie keinesfalls vorhandene Dateien überschreiben.
URL für die Branding-Cabinett-Datei (.CAB)
Geben Sie den URL an, unter dem die Branding-Kabinettdatei (.CAB-Datei) zu finden ist oder bereitgestellt wird.

Anmerkung

  • Wenn Sie verhindern möchten, dass eine Standardvorwahl festgelegt wird, können Sie ein Flag in der .ISP-Datei entsprechend setzen. Die Syntax für dieses Flag lautet:
    Dial_As_Is=Yes

    Weitere Informationen erhalten Sie unter Erstellen einer .ISP-Datei.


Assistent für den Internetzugang

Sie können den Assistenten für den Internetzugang (Internet Connection Wizard - ICW) als das Tool angeben, mit dem sich die Benutzer bei den Internetdiensten anmelden. Sie können Serverlösungen erstellen, die Informationen mit den Fenstern des Assistenten für den Internetzugang austauschen. Dieses Feature steht für die serverlose Anmeldung nicht zur Verfügung.

Text der Titelleiste
Aktivieren Sie dieses Kontrollkästchen, um anzugeben, dass die Kunden den Assistenten für den Internetzugang zur Anmeldung bei Ihren Diensten verwendet.
Linkes Bild
Geben Sie den Pfad der Bitmapdatei mit den Abmessungen 164x458 Pixel an, die auf der linken Seite des Assistenten für den Internetzugang angezeigt wird.
Oberes Bild
Geben Sie den Pfad der Bitmapdatei mit den Abmessungen 49x49 Pixel an, die in der oberen rechten Ecke des Assistenten für den Internetzugang angezeigt wird.

Anmerkungen

  • Um sicherzustellen, dass der Assistent für den Internetzugang mit Ihrem Server interagieren kann, müssen Sie die Dynamic HTML-Datenbindung in Ihr Browserpaket einschließen. Datenbindung ermöglicht, dass auf der Seite des Assistenten die Liste der ISP-Dateien aus Signup.txt angezeigt wird. Sie können angeben, dass diese Option nicht als angepasste Installationsoption angezeigt werden soll, die Benutzer von der Installation ausschließen können. Deaktivieren Sie hierzu auf der Seite Erweiterte Installationsoptionen das Kontrollkästchen Dynamic HTML Datenbindung. Unter Windows Update Setup wird nun in der rechten Spalte für diese Komponente Installation erzwingen angezeigt.
  • Ein Beispiel für den Anmeldevorgang finden Sie unter ISP-Anmeldevorgang.


Sicherheit

Zertifizierungsinstanzen und Authenticode™ können Unterstützung bei der Verwaltung der Sicherheit bieten.

Sie können Zertifizierungsinstanzen verwenden, um die Sites zu kontrollieren, von denen Benutzer bestimmte Inhalte downloaden können, beispielsweise ActiveX-Steuerelemente und Java-Anwendungen. Siteinstanzen stellen eine Form digitaler Zertifikate für eine Internetsite dar. Wenn Sie die Authenticode-Technologie einsetzen, geben sie an, woher Programme stammen, und stellen sicher, dass sie nicht geändert wurden.

Sie können diese Einstellungen von Ihrem Computer importieren. Klicken Sie auf Aktuelle Zertifizierungsagenturen importieren, und klicken Sie dann auf Einstellungen ändern, wenn Sie die Einstellungen ändern möchten, die Sie für die Computer der Benutzer verwenden werden.

Mit der Zertifikatverwaltung können Sie die Informationen über die Zertifizierungsinstanzen anzeigen und verwalten. Zertifikate können sich auf Netzwerkserver-Authentifizierung, Netzwerkclient-Authentifizierung, sichere E-Mail-Authentifizierung und die Softwareherausgabe beziehen.

Authenticode ermöglicht es, Softwareherausgeber und Zertifizierungsagenturen als vertrauenswürdig einzustufen. Sie können diese Einstellungen auch von Ihrem Computer importieren. Klicken Sie auf Aktuelle Authenticode-Sicherheitsinformationen importieren, und klicken Sie dann auf Einstellungen ändern, wenn Sie die Einstellungen ändern möchten, die Sie für die Computer der Benutzer verwenden werden.


Sicherheitseinstellungen

Wenn Sie Firmenadministrator sind, können Sie Sicherheitszonen und Inhaltsfilter für Ihre Firma verwalten. Sie können die Einstellungen für jede Sicherheitszone anpassen. Über Inhaltsbewertungen können Sie verhindern, dass Benutzer Inhalte anzeigen, die als unangemessen betrachtet werden können.

Sicherheitszonen
Klicken Sie auf Importieren der aktuellen Einstellungen für Sicherheitszonen, und klicken Sie dann auf Einstellungen ändern, wenn Sie die Einstellungen ändern möchten, die auf den Computern der Benutzer installiert werden. In Schritt 5 können Sie außerdem festlegen, ob Benutzer ihre Sicherheitseinstellungen ändern können.
Inhaltsfilter
Microsoft Internet Explorer unterstützt Sie bei der Kontrolle der Inhalte, auf die Ihr Computer im Internet zugreifen kann. Sie können die Einstellungen für entsprechende Inhalte in vier Bereichen anpassen: Sprache, Nacktaufnahmen, Sex und Gewalt.

Klicken Sie auf Importieren der aktuellen Einstellungen der Inhaltsfilter, und klicken Sie dann auf Einstellungen ändern, wenn Sie die Einstellungen ändern möchten, die auf den Computern der Benutzer installiert werden. Die Einstellungen können mit dem Inhaltsratgeber geändert werden.

Anmerkungen

  • Der Inhaltsratgeber verwendet bei seiner ersten Aktivierung sehr vorsichtige Bewertungsstandards. Sie können diese Einstellungen an Ihre eigenen Vorstellungen anpassen.
  • Nicht alle Internetinhalte werden bewertet. Wenn Sie anderen Benutzern erlauben, nicht bewertete Sites anzuzeigen, enthalten einige dieser Sites möglicherweise unerwünschtes Material.


Übersicht zu Schritt 4: Anpassung des Browsers

Assistent

Schritt 4: Anpassung des Browsers

In diesem Schritt des Assistenten für die Internet Explorer-Anpassung können Sie das Erscheinungsbild und das Verhalten von Internet Explorer anpassen.

Die verfügbaren Optionen hängen davon ab, über welche der folgenden Positionen bzw. Funktionen Sie verfügen:

  • Internetinhaltsanbieter
  • Internetdienstanbieter
  • Firmenadministrator

Anmerkung

  • Die Verfügbarkeit einiger Optionen, wie z. B. die Anpassung von Logos, hängt außerdem von Ihrem Lizenzvertrag ab. Weitere Informationen finden Sie in Ihrem Vertrag.


Erfassen von Praktiken und Einschränkungen

Die zentrale Verwaltung von Systemrichtlinien und -einschränkungen kann Ihnen helfen, die Desktop-Umgebung in Ihrer ganzen Organisation konsistent zu halten und Folgekosten durch Supporttätigkeiten zu verringern.

Alle Praktiken und Einschränkungen des Systems, die Sie im IEAK-Assistenten einstellen und anschließend mit Hilfe des IEAK-Profil-Managers verwalten können, können für Benutzer mit den Betriebssystemen Windows 95, Windows 98 und Windows Millennium Edition konfiguriert werden.

Sie können jedoch für Benutzer ohne Administratorrechte unter Windows NT bzw. Windows 2000 nur eine Teilmenge dieser Systemrichtlinien und -einschränkungen einrichten. Es wird empfohlen, statt dessen den Windows NT-Systemrichtlinien-Editor bzw. Windows 2000-Gruppenrichtlinie zu verwenden, um die restlichen Praktiken und Einschränkungen für diese Benutzer zu konfigurieren. Weitere Informationen erhalten Sie unter Verwalten von Microsoft Internet Explorer unter Windows 2000.

Aller IEAK-Richtlinien anzeigen
Eine vollständige Konfiguration der Systemrichtlinien und -einschränkungen ist für alle Benutzer der Betriebssysteme Windows 95, Windows 98 und Windows Millennium Edition und für Benutzer mit Administratorrechten unter Windows NT und Windows 2000 möglich.
Nur Richtlinien Nicht-Administratoren anzeigen
Wählen Sie diese Option aus, um die Teilmenge der Praktiken und Einschränkungen zu konfigurieren, die für Benutzer ohne Administratorrechte unter einem der Betriebssysteme Windows NT bzw. Windows 2000 gelten.


Programme (Registerkarte)

Sie können Ihre Standardprogrammeinstellungen importieren, wie z. B. bestimmte Programme für E-Mail und zur Bearbeitung von HTML-Dateien. Diese Einstellungen befinden sich auf der Registerkarte Programme des Dialogfelds Internetoptionen.

Wenn Sie keine Voreinstellung der Einstellungen der Benutzer vornehmen möchten, klicken Sie auf Kein Anpassen der Programmeinstellungen. Zum Importieren der Einstellungen auf Ihren Computer klicken Sie auf Importieren der aktuellen Programmeinstellungen. Zum Ändern der Einstellungen und anschließenden Importieren klicken Sie auf Importieren der aktuellen Programmeinstellungen und dann auf Einstellungen ändern.


Outlook Express-Server und -Konten

Nachstehend finden Sie weitere Informationen zu Outlook Express-Servern und -Konten.

Server

Sie können die E-Mail- und News-Server für Outlook Express angeben und festlegen, ob Benutzer bei der Anmeldung SPA (Secure Password Authentication, Authentifizierung mit sicherem Kennwort) verwenden müssen, um auf den Server zuzugreifen.

Posteingang
Wählen Sie das Protokoll aus, das auf Ihren Mailservern ausgeführt wird. Sie können POP3, das von den meisten Internetabonnenten für E-Mail verwendet wird, oder IMAP auswählen, das hauptsächlich von Benutzer in Firmen verwendet wird, die ihre E-Mail von einem Remotestandort aus lesen möchten. POP3-Server ermöglichen den Zugriff auf einen einzigen Posteingang, während IMAP-Server den Zugriff auf mehrere serverseitige Ordner ermöglichen.
Server
Geben Sie die vollständige Serveradresse in das Textfeld ein (z. B. pop01.microsoft.com). Klicken Sie dann auf Anmeldung mit gesichertem Kennwort (Secure Password Authentication - SPA), wenn Ihr POP3- oder IMAP-Server die Authentifizierung über einen SSPI-Anbieter, z. B. NTLM, erfordert.
Server für Postausgang (SMTP)
Der Server für ausgehende Mail-Nachrichten ist ein SMTP-Server. In einigen Fällen kann der SMTP-Server den gleichen Namen wie der POP3-Server haben (z. B. smtp.microsoft.com). Geben Sie die vollständige SMTP-Serveradresse in das Textfeld ein. Klicken Sie dann auf Anmeldung mit gesichertem Kennwort (Secure Password Authentication - SPA), wenn Ihr SMTP-Server die Authentifizierung über einen SSPI-Anbieter, z. B. NTLM, erfordert.
Internet-Newsserver (NNTP)
Das NNTP (Network News Transfer Protocol)-Protokoll dient zum Übertragen von News-Nachrichten an NNTP-Server und NNTP-Clients (Newsreader) im Internet (NNTP). Geben Sie die NNTP-Adresse in das Textfeld ein (z. B. nntp.microsoft.com). Klicken Sie dann auf Anmeldung mit gesichertem Kennwort (Secure Password Authentication - SPA), wenn Ihr NNTP-Server die Authentifizierung über einen SSPI-Anbieter, z. B. NTLM, erfordert.

Konten

Benutzerkonten, wie z. B. Mail- und News-Konten, werden entsprechend den von Ihnen angegebenen Einschränkungen konfiguriert.

Schreibgeschützte Servernamen verwenden
Wählen Sie diese Option aus, um Kontoeinstellungen zu erstellen, die von Benutzern angezeigt, jedoch nicht geändert werden können.
Zugriff auf Konten deaktivieren
Wählen Sie diese Option aus, um zu verhindern, dass Benutzer vorkonfigurierte Konten löschen oder ändern, oder weitere Konten erstellen. Diese Option sollte ausschließlich von Firmenadministratoren verwendet werden.


IMAP-Einstellungen für Outlook Express

In diesem Bildschirm können Sie die Standard-IMAP-Einstellungen für die Benutzer festlegen. Diese Einstellungen sind für die Benutzer vorkonfiguriert, wenn sie ihre IMAP-Konten erstellen.

Pfad des Stammordners
Der Pfad des Stammordners ist die Mailbox, die alle Benutzerordner auf dem IMAP-Server enthält. Bei Cyrus-Servern müssen die Ordner aller Benutzer im Posteingangsordner enthalten sein. Bei IMAP-Servern auf Unix-Basis wird die Mail in der Regel in einem eigenen Ordner im Stammordner des Benutzers gespeichert (z. B. ~benutzername/Mail). Der Pfad des Stammordners darf nicht mit einem Hierarchiezeichen beendet werden. So ist z. B. ~benutzername/Mail ein gültiger Stammordnerpfad, während ~benutzername/Mail/ ungültig ist. Einige IMAP-Server, wie z. B. Microsoft Exchange Server, benötigen keinen Stammordnerpfad.
Besondere Ordner auf dem IMAP-Server speichern
Wenn Sie festlegen möchten, dass die Ordner für die gesendeten und gerade verarbeiteten Nachrichten der Benutzer auf dem IMAP-Server erstellt werden sollen, wählen Sie Besondere Ordner auf dem IMAP-Server speichern aus.
Pfad für "Gesendete Objekte"
Geben Sie den Pfad für den Ordner Gesendete Objekte ein. Dieser Pfad wird von allen Benutzern verwendet, die IMAP-Konten erstellen.
Pfad für "Entwürfe"
Geben Sie den Pfad für den Ordner Entwürfe ein. Dieser Pfad wird von allen Benutzern verwendet, für die Sie IMAP-Konten erstellen.
Alle Ordner auf neue Nachrichten überprüfen
Wenn beim Start von Outlook Express und in den vom Benutzer festgelegten regelmäßigen Überprüfungsintervallen alle abonnierten Ordner eines IMAP-Benutzers im Hinblick auf Änderungen der Anzahl der Nachrichten überprüft werden sollen, wählen Sie Alle Ordner auf neue Nachrichten überprüfen aus. Falls diese Option nicht ausgewählt ist, sucht Outlook Express nur im Posteingang nach neuen Nachrichten.


Angepasster Inhalt für Outlook Express

Sie können Outlook Express ein individuelles Erscheinungsbild geben und neue Benutzer mit einer E-Mail-Nachricht willkommen heißen.

Infofeld

Das Outlook Express-Infofeld ist ein Bereich, in dem Inhaltsanbieter hilfreiche Informationen und Links bereitstellen können. Sie können diesen Abschnitt durch Rufnummern zur Produktunterstützung, häufig gestellte Fragen (FAQs, Frequently Asked Questions) und Informationen zu Ihrer Firma anpassen.

Das Infofeld wird als ein 50 Pixel hoher Bereich am unteren Rand des Outlook Express-Hauptfensters angezeigt. Sie können das Infofeld über eine HTML-Datei anpassen, bei der es sich entweder um eine lokale Datei oder um eine Internetadresse handelt (URL). Wenn Sie eine lokale Datei angeben, wird diese Datei zunächst in Ihr IEAK-Distributionspaket und danach während der Installation auf den Computer des Benutzers kopiert.

Anmerkung

  • Das Infofeld wird nicht als Teil der Outlook Express-Benutzeroberfläche angezeigt, wenn kein URL und keine Datei in IEAK festgelegt werden.
URL
Geben Sie den URL der HTML-Datei ein, die Sie für das Infofeld verwenden möchten.
Lokale Datei
Falls Sie in dem vorhergehenden Textfeld keinen URL eingegeben haben, können Sie den Pfad zu der lokalen HTML-Datei eingeben, die Sie für das Infofeld verwenden, oder auf Durchsuchen klicken, um den Speicherort dieser Datei anzugeben. Wenn es sich um eine lokale Datei handelt, können Sie außerdem ein Bild angeben, das kopiert werden soll.

Willkommen-Nachricht

Sie können auch eine "Willkommen"-Nachricht als ersten Eintrag im Posteingang jedes Benutzers zur Verfügung stellen. Bei dieser "Willkommen"-Nachricht handelt es sich um eine HTML-Datei. Sie müssen außerdem den Namen des Absenders (beispielsweise den Namen Ihrer Firma oder Organisation) und die E-Mail-Adresse des Empfängers angeben.

Anmerkung

  • IEAK bietet keine Möglichkeit, der Willkommensnachricht ein Bild hinzuzufügen. Wenn Sie die Willkommensnachricht jedoch außerhalb von IEAK bearbeiten, können Sie einen Link zu einem Bild im Web hinzufügen.
HTML-Pfad
Geben Sie den Pfad der HTML-Datei ein, die Sie senden möchten, oder klicken Sie auf Durchsuchen, um den Speicherort dieser Datei anzugeben.
Sender:
Geben Sie den Namen der Firma oder der Person ein, die die Willkommensnachricht sendet, beispielsweise "Vulkan-Administration". Der Name wird in der Zeile Von der Willkommensnachricht angezeigt.
Antwort an
Geben Sie die E-Mail-Adresse der Firma oder der Person ein, die die Willkommensnachricht sendet. Benutzer können eine E-Mail-Nachricht an diese Adresse senden, wenn sie Frage oder Anliegen haben.


Angepasste Einstellungen für Outlook Express

Legen Sie auf diesem Bildschirm alle Einstellungen fest, die für alle Benutzer gelten sollen. Zu diesen Standardeinstellungen gehört die Einstellung eines Standard-E-Mail- und -News-Clients. Außerdem können Sie Informationen bereitstellen, die Benutzer benötigen, um weitere E-Mail-Konten zu erhalten. Schließlich können Sie auch eine Datei mit Standardnachrichtenregeln für Benutzer bereitstellen.

Verwenden von Outlook Express als Standardprogramm
Falls Outlook Express immer dann gestartet werden soll, wenn ein Benutzer auf eine E-Mail-Verknüpfung in Internet Explorer klickt, aktivieren Sie das entsprechende Kontrollkästchen E-Mail. Die Einstellung für den Standard-E-Mail-Client wird außerdem von zahlreichen Programmen verwendet, wenn Dokumente über E-Mail gesendet werden. Beachten Sie, dass hierdurch jeder aktuelle Standard-Mail-Client ersetzt wird, den der Benutzer angegeben hat.

Falls Outlook Express immer dann gestartet werden soll, wenn ein Benutzer auf einen News-Link in Internet Explorer klickt, aktivieren Sie das Kontrollkästchen News.

Newsgroups-Feld
Verwenden Sie dieses Feld zur Eingabe der Namen von einer oder mehreren Newsgroups, die von Benutzern automatisch abonniert werden sollen. Beispielsweise kann Ihr ISP oder Unternehmen mehrere Newsgroups eingerichtet haben, die Unterstützung und Informationen für Benutzer bieten. Sie könnten dieses Feature einsetzen, um diese Newsgroups von neuen Benutzern abonnieren zu lassen.
Erstellung neuer Konten
Sie können einen Menüeintrag hinzufügen, mit dessen Hilfe Benutzer ein weiteres Mail-Konto von Ihrem Internetdienstanbieter erhalten können. Dieser Eintrag wird zum Menü Neues Konto einrichten in Outlook Express hinzugefügt. Geben Sie den Namen Ihres Internetdienstanbieters in das Feld Dienstname ein (z. B. Acme ISP). Geben Sie anschließend einen URL in das Feld Dienst-URL ein. Wenn der Benutzer diesen Dienstnamen aus dem Menü auswählt, wird die Webseite geöffnet. Eine Kontonummer, die in der INS-Datei angegeben werden kann, und ein eindeutiger Bezeichner für den Benutzer werden an den Internetdienstanbieter gesendet, wenn die Webseite geöffnet wird.
Alle Outlook Express-Links löschen
Wenn Sie dieses Kontrollkästchen aktivieren, werden auf dem Desktop des Benutzers und in seinem Startmenü keine Links mehr angezeigt, und das Outlook Express-Symbol wird von der Schnellstartsymbolleiste entfernt.


Anzeigeeinstellungen für Outlook Express

Sie können bestimmte Ansichten anpassen, die festlegen, ob bestimmte Elemente von Outlook Express angezeigt werden. Außerdem können Sie anpassen, wie diese Ansichten angezeigt werden.

Standard
Mit Hilfe dieser Einstellungen können Sie bestimmen, welche Elemente der Outlook Express-Oberfläche in die Standardansicht für neue Benutzer integriert werden.
  • Aktivieren Sie das Kontrollkästchen Ordnerleiste, damit die Ordnerleiste den Benutzern standardmäßig angezeigt wird.
  • Wenn die Outlook-Leiste - eine horizontale Leiste mit bestimmten Ordnern, z. B. dem Posteingang - angezeigt werden soll, wählen Sie Outlook-Leiste.
  • Zum Anzeigen einer Liste mit E-Mail- und News-Ordnern in der linken Spalte aktivieren Sie das Kontrollkästchen Ordnerliste.
  • Zum Anzeigen der Statusleiste am unteren Rand des Outlook Express-Fensters wählen Sie Statusleiste.
  • Wenn die MSN Messenger Service-Kontakte des Benutzers (sofern MSN Messenger Service installiert und konfiguriert wurde) sowie Adressen von E-Mail-Empfängern aufgelistet werden sollen, aktivieren Sie das Kontrollkästchen Kontakte.
  • Zum Anzeigen eines Tipps bei jedem Start von Outlook Express aktivieren Sie das Kontrollkästchen Tipps und Tricks.
Symbolleiste
Sie können wählen, ob Benutzern die Symbolleiste angezeigt werden soll und ob die Symbolleiste Text enthalten soll. Die Symbolleiste wird am oberen Rand des Outlook Express-Fensters angezeigt. Sie enthält Schaltflächen, die allgemeinen Befehlen entsprechen und vom Benutzer konfiguriert werden können.
Vorschau anzeigen
Sie haben die Möglichkeit, der Standardansicht von Mail- und News-Nachrichten für Benutzer eine Nachrichtenvorschau hinzuzufügen. Die Vorschau kann entweder in einem horizontalen Bereich unterhalb der Nachrichtenliste oder in einem vertikalen Bereich oberhalb und rechts der Nachrichtenliste angezeigt werden. Die Vorschau enthält einen Bereich mit einer Vorschaukopfzeile, in der Kopfzeileninformationen von Nachrichten angezeigt werden, wie z. B. die Zeilen Von, An, Cc und Betreff einer Nachricht.


Outlook Express-Einstellungen für das Verfassen von Nachrichten

Signaturen
Sie können eine Standardsignatur hinzufügen, wie z. B. eine Haftungsausschlussklausel, die in Outlook Express-Newsgroup- oder E-Mail-Nachrichten angezeigt wird. Ein solcher Haftungsausschluss wird häufig verwendet, um deutlich zu machen, dass es sich bei Beiträgen von Angestellten einer Firma, die im Internet zur Verfügung gestellt werden, nicht um offizielle Beiträge der Firma handelt. Die Standardgröße für Signaturen beträgt 1 KB.

Sie können festlegen, dass Signaturen nur an Newsgroup-Beiträge, nur an E-Mail-Nachrichten oder an beide angehängt werden sollen.

HTML als Standard für die Erstellung von Mailnachrichten bzw. Newsnachrichten verwenden
Standardmäßig werden E-Mail-Nachrichten in HTML erstellt, während News-Beiträge in Textformat verfasst werden. Diese Einstellungen können überschrieben werden. Beispielsweise kann in einer Umgebung, die nur über eine begrenzte Bandbreite verfügt oder in der zahlreiche Benutzer nur einfache E-Mail-Programme einsetzen, die kein HTML unterstützten, eine Änderung der Standardeinstellung in Textformat sinnvoll sein. Genauso kann jedoch auch in einer Firmenumgebung, in der alle Benutzer einen HTML-fähigen Newsreader einsetzen, die Änderung der Standardeinstellung für News-Beiträge in HTML eine sinnvolle Lösung darstellen.


Adressbuch-Verzeichnisdienst

Verzeichnisdienste sind leistungsfähige Suchwerkzeuge, die Ihren Benutzern beim Suchen nach Personen und Firmen auf der ganzen Welt wertvolle Hilfe leisten können. Das Windows-Adressbuch unterstützt das LDAP (Lightweight Directory Access Protocol)-Protokoll für den Zugriff auf Verzeichnisdienste. Die Zugriffsinformationen für die beliebtesten Verzeichnisdienste sind bereits integriert. Sie haben die Möglichkeit, einen weiteren Dienst für die Benutzer festzulegen.

Dienstname
Geben Sie den Anzeigenamen für Ihren LDAP-Dienst ein. Dies ist der Name, der den Benutzern angezeigt wird.
Servername
Geben Sie den Namen des hinzuzufügenden Verzeichnisdienstes an, wie z. B. ldap.AcmeISP.com oder ldap.switchboard.com. Falls die Authentifizierung über ein SSPI-Paket, wie z. B. NTLM, für Benutzer erfolgen soll, die auf diese Dienste zugreifen, aktivieren Sie das Kontrollkästchen Anmeldung mit gesichetem Kennwort. Eine grundlegende Authentifizierung mit einer Kombination aus Benutzername und Kennwort kann über .INS-Dateien konfiguriert werden.
Dienstwebsite
Geben Sie den URL für die Homepage des Verzeichnisdienstes ein.

Verfahren zum Anzeigen der Verzeichnisdienst-Homepage unter Windows 95, Windows 98 und Windows NT

  1. Klicken Sie auf Start, zeigen Sie auf Suchen, und klicken Sie auf Personen.
  2. Wählen Sie im Dialogfeld Personen suchen aus der Liste Suchen in die Homepage des Verzeichnisdienstes aus, und klicken Sie anschließend auf Website.

    Wählen Sie die Homepage des Verzeichnisdienstes aus, und klicken Sie dann auf Website.

Verfahren zum Anzeigen der Verzeichnisdienst-Homepage unter Windows 2000 und Windows Millennium Edition

  1. Klicken Sie auf Start, zeigen Sie auf Suchen, und klicken Sie auf Personen.
  2. Wählen Sie im Dialogfeld Personen suchen aus der Liste Suchen in die Homepage des Verzeichnisdienstes aus, und klicken Sie anschließend auf Website.
Suchbasis
Wird manchmal auch als Ursprung oder Basis bezeichnet. Die Suchbasis ist die Ebene in der Hierarchie, auf der ein bestimmter LDAP-Server durchsucht werden soll. Bei der Suchbasis kann es sich um ein Land, eine Organisation oder eine andere Gruppierung handeln. Wenn keine Suchbasis angegeben wurde, lautet die Outlook Express-Standardeinstellungen für die Suchbasis "c=us". Wenn keine Suchbasis festgelegt werden soll, geben Sie NULL ein.
Dienstbitmap
Sie können eine angepasste Bitmapdatei mit den Abmessungen 134x38 Pixel und mit 16 Farben angeben. Um eine einheitliche Farbzuordnung sicherzustellen, wird dringend empfohlen, beim Erstellen der Bitmap nur die 16-Bit-Farbpalette von Windows zu verwenden. Klicken Sie auf Durchsuchen, um den Speicherort der Bitmapdatei auf Ihrem Computer anzugeben.
Suchtimeout
Sie können die Dauer festlegen, bis eine Suchanforderung wegen Zeitüberschreitung abgebrochen wird. Verwenden Sie den Schieberegler, um einen Zeitwert zwischen 30 Sekunden und 5 Minuten einzustellen.
Maximale Anzahl der Übereinstimmungen
Sie können die maximale Anzahl von Ergebnissen festlegen, die an die Benutzer zurückgegeben werden. Geben Sie die Zahl in dieses Feld ein.
Namensauflösung
Aktivieren Sie das KontrollkästchenDie Namen beim Senden von Nachrichten mit diesem Server überprüfen, um festzulegen, dass Outlook Express bei der Namensauflösung diesen Server verwendet, wenn ein Benutzer eine Nachricht sendet. Mit dieser Einstellung sucht Outlook Express nach E-Mail-Adressen für die Namen, die in die Zeilen An, Cc und Bcc einer E-Mail-Nachricht eingegeben werden.


Praktiken und Einschränkungen

Je nach Ihrer Funktion können Sie in Ihrer Organisation bei den Mitarbeitercomputern bestimmte Einstellungen vornehmen, beispielsweise des Desktops, der Internetkomponenten, des Betriebssystems und der Sicherheit.

Internetinhaltsanbieter, Internetdienstanbieter und Firmenadministratoren können für ihre Benutzer bestimmte Standardeinstellungen festlegen. Darüber hinaus können Firmenadministratoren zahlreiche Einstellungen anpassen und einschränken. Beispielsweise kann festgelegt werden, ob Benutzer Drucker löschen können oder ob sie neue Elemente zu ihren Desktops hinzufügen dürfen.

Weitere Informationen finden Sie unter Einstellungen und Einschränkungen.

Alle Praktiken und Einschränkungen des Systems, die Sie im IEAK-Assistenten einstellen und anschließend mit Hilfe des IEAK-Profil-Managers verwalten können, können für Benutzer mit den Betriebssystemen Windows 95, Windows 98 und Windows Millennium Edition konfiguriert werden.

Sie können jedoch für Benutzer ohne Administratorrechte unter Windows NT bzw. Windows 2000 nur eine Teilmenge dieser Systemrichtlinien und -einschränkungen einrichten. Es wird empfohlen, statt dessen den Windows NT-Systemrichtlinien-Editor bzw. Windows 2000-Gruppenrichtlinie zu verwenden, um die verbleibenden Praktiken und Einschränkungen für diese Benutzer zu konfigurieren. Weitere Informationen erhalten Sie unter Verwalten von Microsoft Internet Explorer unter Windows 2000.

Sie sollten die Auswirkungen dieser Sicherheitseinstellungen für Benutzer kennen und verstehen, insbesondere wenn es Benutzer gibt, die häufig an verschiedenen Computern arbeiten oder Computer mit anderen Benutzern gemeinsam verwenden. Weitere Informationen finden Sie in der unten stehenden Anmerkung.

So legen Sie Systempraktiken und -einschränkungen fest

  1. Doppelklicken Sie auf die jeweiligen Kategorien, um die Optionen anzuzeigen.
  2. Aktivieren oder deaktivieren Sie die Kontrollkästchen wie gewünscht.

Anmerkungen

  • Die im Assistenten angezeigten Einstellungen sind in Verwaltungsdateien (.ADM-Dateien) enthalten, die im Lieferumfang von IEAK enthalten sind. Wenn Sie mit .ADM-Dateien vertraut sind, können Sie mit Hilfe des Assistenten für die Internet Explorer-Anpassung die Richtlinien und Einstellungen festlegen, die Sie in Ihren .ADM-Dateien gespeichert haben, indem Sie auf Importieren klicken.

    Die ausgewählten Einstellungen und Einschränkungen können als .INS-Dateien gespeichert werden. Mit Hilfe der .INS-Dateien können .INF-Dateien für Ihre angepassten Pakete erstellt werden. Weitergehende Informationen zur Beziehung zwischen .ADM-Dateien und .INF-Dateien finden Sie unter Systemrichtlinien und Einstellungen.

  • Um sicherzustellen, dass die Einstellung Vertrauenswürdige Herausgeber für den Sicherheitsbereich der Interneteinschränkungen wirksam ist, sollten Sie überprüfen, ob die Sicherheitszonen und Richtlinien richtig eingerichtet wurden.

Benutzereinstellungen können an einem zentralen Ort gespeichert werden und dann Benutzern zur Verfügung gestellt werden, wenn diese sich an unterschiedlichen Computern anmelden. Diese Konfiguration ist beispielsweise sinnvoll, wenn ein Benutzer mit wenig restriktiven Sicherheitseinstellungen an einem Computer eines anderen Benutzers arbeiten muss, für den restriktivere Sicherheitseinstellungen gelten.

Anpassen der Sicherheitseinstellungen

Sie können drei typische Stufen für die Anpassung der Sicherheitseinstellungen zulassen:

  • Steuern bzw. "Festlegen" aller Einstellungen.

    So legen Sie alle Einstellungen fest

    1. Klicken Sie auf Interneteinstellungen und dann auf Sicherheitsseite.
    2. Aktivieren Sie das Kontrollkästchen Die Einstellungen für Sicherheitszonen statisch festlegen.
  • Steuern der Benutzereinstellungen, wobei Profile für Benutzer mit wechselnden Arbeitsplätzen gedownloadet werden können.

    Sie können festlegen, dass die Einstellungen nicht geändert werden können, ohne die Möglichkeiten für Benutzer mit wechselnden Arbeitsplätzen einzuschränken, für die andere Profile gelten. Das Windows-Feature für Benutzer mit wechselnden Arbeitsplätzen ermöglicht den Download von benutzerspezifischen Einstellungen von einem Server.

    So legen Sie fest, dass Benutzer die Richtlinien für Zonen nicht ändern können

    1. Klicken Sie auf Interneteinstellungen und dann auf Sicherheitsseite.
    2. Aktivieren Sie das Kontrollkästchen Benutzer können Einstellungen für die Sicherheitszonen nicht ändern.

    So legen Sie fest, dass Benutzer keine Sites hinzufügen oder löschen können

    1. Klicken Sie auf Interneteinstellungen und dann auf Sicherheitsseite.
    2. Aktivieren Sie das Kontrollkästchen Benutzer können Sites zu Zonen nicht hinzufügen oder aus ihnen entfernen.
  • Anpassen der anfänglichen Einstellungen, wobei die Benutzer diese selbst ändern können

    In diesem Schritt des Assistenten können Sie zahlreiche Benutzereinstellungen festlegen, wie beispielsweise Sicherheitsstufen und Filter. Durch das Anpassen der Einstellungen in diesem Schritt wird nicht festgelegt, ob der jeweilige Benutzer die Einstellungen auch selbst ändern kann oder nicht.


Aufbringen von Branding-Informationen auf MSN Messenger Service

Sie können einen Produktnamen für Ihre angepasste Version des Messenger Service-Clients und einen Download-URL für den angepassten Client festlegen.

Produktname
Wählen Sie eine der folgenden Optionen für den Produktnamen:
  • Wählen Sie Option 1, um als kurzen Produktnamen MSN Messenger Service festzulegen. Geben Sie eine Zeichenfolge in das Textfeld hinter MSN Messenger Service - von ein. Als langer Produktname wird dann MSN Messenger Service von [Ihre Organisation] verwendet. Es wird empfohlen, diese Option zu verwenden.
  • Wählen Sie Option 2, um einen eindeutigen, unverwechselbaren Produktnamen festzulegen. Geben Sie den kurzen Produktnamen in das Feld Produktname ein. Als langer Produktname wird dann [Ihr eindeutiger Produktname] (powered by MSN) verwendet. Hinweis: Für die Auswahl des Produktnamens und des Logos trägt Ihre Firma die alleinige Verantwortung. Stellen Sie sicher, dass der ausgewählte Name und das Logo in Absprache mit der Rechtsabteilung überprüft werden.

Der kurze Produktname wird im angepassten Client in der Taskleiste, der Prozessliste, der Hilfe sowie als eingebetteter Text in einigen weiteren Dialogfeldern des Produkts angezeigt. Der lange Produktname wird im Dialogfeld Info (das über das Menü ? (Hilfe) geöffnet wird), in der Titelleiste des Hauptfensters und in der Titelleiste des Dialogfeldes MSN Messenger Service anmelden angezeigt. Der Produktname darf keines der folgenden Zeichen enthalten: + " % / \ : * ? < > | & .

Internationale Versionen und Produktname
MSN Messenger Service ist in 27 Sprachversionen verfügbar, die Anzahl der Sprachen, in denen IEAK verfügbar ist, ist jedoch geringer. Daher ist es möglich, dass im IEAK-Assistenten für einige Sprachen nicht die Zeichenfolge nicht in ihrer Übersetzung angezeigt wird. Die Version der angepassten Installation jedoch enthält die ordnungsgemäß übersetzte Zeichenfolge. Auch die Zeichenfolgen provided by (von) und (powered by MSN) ((powered by MSN)) sind für alle 27 Sprachversionen als Übersetzung verfügbar, selbst, wenn diese Zeichenfolgen im IEAK-Assistenten nicht ordnungsgemäß angezeigt werden. Wenn eine dieser Zeichenfolgen im IEAK-Assistenten nicht in der richtigen Sprachversion angezeigt werden, öffnen Sie die Konfigurationsdatei Msmsgs.in_ in einem Texteditor, und überprüfen Sie, ob die vollständigen Zeichenfolgen richtig sind.
Download-URL
Geben einen Download-URL für den angepassten Client ein. IEAK erstellt für den angepassten Messenger Service-Client ein eigenes Setup-Paket. Wenn ein Benutzer im Client den Assistenten zum Hinzufügen von Kontakten ausführt, so kann eine E-Mail-Nachricht, die einen Link zu dem Download-URL enthält, als Einladung erstellt und an den neuen Kontakt gesendet werden. Der angegebene Download-URL sollte eine HTML-Seite Ihrer Website sein, die Erläuterungen zu dem Messenger Service-Client und Installationsanweisungen enthält. Die HTML-Seite sollte einen Link enthalten, über den das angepasste Installationsprogramm auf Ihrer Site gedownloadet bzw. ausgeführt werden kann. Wenn Sie keinen Download-URL angeben, wird die Standardinstallationsseite der MSN Messenger Service-Website verwendet.


Aufbringen von Branding-Informationen auf MSN Messenger Service (Medien)

Sie können ein angepasstes Logo festlegen, das in vielen Bereichen des Clients für den Messenger Service als Logo für Branding-Informationen verwendet werden kann. Sie können außerdem angepasste Sounds für eingehende Nachrichten festlegen. In einigen Fällen müssen Dateinamen, die Sie für die folgenden Objekte festlegen, im ASCII-Format vorliegen. Dateinamen, die nicht im ASCII-Format vorliegen, werden durch die entsprechenden Standard-ASCII-Versionen ersetzt.

Logo
Geben Sie den Pfad Ihrer angepassten .GIF-Datei ein, oder klicken Sie auf Durchsuchen, um danach zu suchen. Die Abmessungen des Logos sollten 234x50 Pixel betragen. Da das Logo in Bereichen mit weißem Hintergrund angezeigt werden wird, sollte der Hintergrund des Logos ebenfalls weiß sein (RGB-Wert 255, 255, 255) und keine Transparenz-Austauschfarbe besitzen. Das Logo wird im Bereich für Werbeinhalte, im Dialogfeld Hilfe sowie in den Assistenten zum Hinzufügen eines Kontaktes und für neue Benutzer angezeigt. Es wird dringend empfohlen, dass Sie bei der Anpassung ein eigenes Logo zur Verfügung zu stellen. Wird kein Logo angegeben, wird statt dessen das "MSN Messenger Service"-Logo angezeigt.
URL für das Logo
Geben Sie einen URL ein, wie beispielsweise den der Homepage Ihrer Site, mit dem die .GIF-Datei Ihres Logos verknüpft werden soll. Wenn ein Benutzer im Bereich für Werbeinhalte des Messenger Service-Clients auf Ihr Logo klickt, wird eine neue Instanz des Browsers mit dem entsprechenden URL geöffnet. Wird kein URL angegeben, besteht keine Verknüpfung zu dem Logo.
Sounddateien
Um die Befehle Onlinekontakt, Neue E-Mail-Nachricht oder Neuer News-Beitrag ausführen zu können, geben Sie den Speicherort einer .WAV-Datei an, oder klicken Sie auf Durchsuchen, um nach einer Audiodatei zu suchen. Das Zuweisen von Sounds für eingehende Nachrichten ist optional. Wurden keine Sounds festgelegt, verwendet der Client Standardsounds. Benutzer können Sounds ebenfalls über die Registerkarte Allgemein im Dialogfeld Optionen des Clients auswählen. Die Samplingrate für diese .WAV-Dateien sollte bei 11,025 kHz, 22,05 kHz oder 44,1 kHz liegen. Testen Sie Ihre Sounds, und stellen Sie sicher, dass der Sound auch bei häufiger Wiedergabe durch den Benutzer beim Arbeiten mit der Software nicht als störend empfunden wird.
Onlinekontakt
Dieser Sound wird immer dann abgespielt, wenn eine Person in der Kontaktliste des Benutzers eine Verbindung mit dem Internet herstellt.
Neue E-Mail-Nachricht
Dieser Sound wird immer dann abgespielt, wenn eine neue E-Mail-Nachricht für einen Benutzer eintrifft. Dieses Feature ist aktuell nur in Verbindung mit einem MSN Hotmail-E-Mail-Konto verfügbar.
Neuer News-Beitrag
Dieser Sound wird immer dann abgespielt, wenn ein Benutzer eine neue Sofortnachricht oder mehrere aufeinander folgende Nachrichten in einem Sofortnachrichtenfenster im Hintergrund empfängt.
.XML-Datei
Geben Sie den URL des .XML-Dokuments an, das zum Generieren von Inhalten verwendet wird, die im Bereich für Werbeinhalte des Clients angezeigt werden sollen. Weitergehende Informationen über das .XML-Format und die zugehörigen Definitionen finden Sie unter Werbesequenzen für Messenger Service im .XML-Dateiformat. Allgemeine Informationen finden Sie unter Werbeinhalt in Ihrem angepassten Messenger Service-Client. Wurde keine .XML-Datei angegeben, zeigt der Client für den Messenger Service Werbeinhalte von MSN Messenger Service an.


MSN Messenger Service-Konten

Passports und Anmelden am Messenger Service

Benutzer, die sich an einem Server anmelden, müssen über ein Passport-Konto verfügen, das von einer der Passport-Domäneninstanzen bereitgestellt wird. Benutzer benötigen für die Anmeldung kein Passport-Konto in bestimmten Domänen; es ist jedes Passport-Konto in jeder Domäne gleichermaßen gültig. Weitere Informationen über Passports und Domäneninstanzen sowie über allgemeine Fragen in Zusammenhang mit Passports und Messenger Service-Konten finden Sie auf der Passport-Website.

Domain
Wählen Sie die von Ihnen bevorzugte Passport-Ausgabedomäne aus der Liste aus. Diese wird als erste Domäne in der Domänenliste angezeigt, wenn ein Benutzer das Anmelde-Dialogfeld öffnet, ebenso in den Assistenten zum Kontakt hinzufügen und für neue Benutzer. Es ist sinnvoll, diese Domäne anzugeben, wenn Sie wissen, dass die Mehrzahl der Benutzer von einer bestimmten Domäneninstanz herausgegebene Passports verwendet. Es wird empfohlen, die Domäneninstanzen hotmail.com oder passport.com zu verwenden.

Anmerkung

  • Weitere Passport-Domäneninstanzen, die aktuell nicht in dieser Liste enthalten sind, stehen zukünftig möglicherweise online zur Verfügung.. Wenn die gewünschte Domäneninstanz in dieser Liste nicht angezeigt wird, geben Sie den Namen der Domäneninstanz direkt in das Textfeld Domäne ein.
Anmelde-URL
In diesem Feld wird der URL angegeben, zu dem in einem Browserfenster gewechselt wird, wenn der Benutzer auf die Schaltfläche Anmelden in der Registerkarte Konten des Dialogfeldes Optionen des Clients klickt. Wenn Sie in der Liste Domäne "hotmail.com" oder "passport.com" festgelegt haben, ist die Angabe dieses URLs optional. Wenn Sie jedoch keine bestehende Domäne festgelegt haben, ist diese Angabe erforderlich. Wenn Sie keinen URL angeben und aus der Liste Domäne einen der Einträge "hotmail.com" oder "passport.com" ausgewählt haben, so wechselt der Benutzer durch Klicken auf die Schaltflächen zum Anmelden bei Passport (Anmelden) zu der entsprechenden Seite für die Registrierung in der Domäne. Gegebenenfalls sollte der URL eine direkte Verknüpfung zur Registrierungsseite einer Passport-Domäneninstanz oder eine Verknüpfung zu einer von Ihnen besuchten angepassten Seite darstellen und dem Benutzer somit Ausschluss über den Passport-Registrierungsprozess geben. Diese angepasste Seite sollte dann über eine Verknüpfung zur Registrierungsseite der Passport-Domäneninstanz verfügen.

Falls Ihre Site über eine Passport-SiteID verfügt, können Sie dem URL, der Benutzer an den Passport-Registrierungsserver verweist, Ihre SiteID und Ihren ReturnURL hinzufügen, um das Aufbringen zusätzlicher Branding-Informationen zu ermöglichen. Weitere Informationen über SiteIDs, das Aufbringen zusätzlicher Branding-Informationen und den Zugriff auf von Passport-Domäneninstanzen verwaltete Webseiten finden Sie im Passport-SDK oder auf der Passport-Developerwebsite.

Mailserver
Der Messenger Service-Client kann so konfiguriert werden, dass für bestimmte Operationen verschiedene Mailserver verwendet werden. Dies bezieht sich vor allem auf die Schaltfläche E-Mail auf der Symbolleiste des Clients, und den Menübefehl Mail senden, der über das Kontextmenü verfügbar ist. Standardmäßig wird bei Messenger Service-Clients MSN Hotmail als Mail-Service verwendet. Die aktuelle Version des Messenger Service-Clients unterstützt die Benachrichtigung beim Eintreffen neuer E-Mail-Nachrichten ausschließlich die Option für Hotmail-E-Mail. Darüber hinaus stehen Ihnen für den Client zwei weitere Optionen zur Unterstützung von Mailservern zur Verfügung:
  • Wenn Sie einen Web-basierten E-Mail-Dienst unterstützen, aktivieren Sie URL für die Homepage eines E-Mail-Dienstes bereitstellen. Geben Sie den URL der Seite zur Erstellung von E-Mail-Nachrichten Ihres Mail-Services in das Feld URL für E-Mail ein. Wenn der Benutzer auf die Schaltfläche E-Mail oder aus dem Kontextmenü den Befehl Senden an wählt, um eine E-Mail an einen bestimmten Benutzer zu senden, so wird diese Adresse in einem neuen Browserfenster geöffnet. Über diesen URL werden keine Benutzer-spezifischen Informationen weitergeleitet. Daher muss der Benutzer die Authentifizierungsinformationen für Ihr E-Mail-System wahrscheinlich erneut eingeben, wenn das System nicht Cookie-basiert ist, und der Benutzer bereits angemeldet war. Auch die Kontakt-E-Mail-Adresse kann bei Verwendung dieser Option nicht automatisch in die Zeile für den Empfänger eingegeben werden. Benachrichtigungen beim Eintreffen neuer E-Mail-Nachrichten sind für diese Art von Web-basierter Dienstinstallation nicht verfügbar. Normalerweise eignet sich diese Option am ehesten für ICP.
  • Wählen Sie Use the default mail client on the end user's computer, um den Standard-E-Mail-Client zu verwenden. Der Standard-E-Mail-Client ist der Client, der in der Registrierung für das mailto:-Protokoll festgelegt wurde. Normalerweise handelt es sich um einen POP3-Mail-Client. Geben Sie den Computernamen für Ihren Mailserver (POP3) in das Feld Posteingang ein. Wählen Sie Anmeldung mit SPA (Gesicherte Kennwortauthentifizierung), wenn der POP3-Mailserver dies unterstützt.

    Wenn ein Benutzer auf die Schaltfläche E-Mail klickt oder aus dem Kontextmenü den Befehl Senden an wählt, um eine E-Mail an einen anderen Benutzer zu senden, so wird die Standardanwendung für E-Mail geöffnet. Der Client für MSN Messenger Service, Version 2.1, unterstützt nicht die Überprüfung externer POP3-Server um eine Benachrichtigung beim Eintreffen neuer E-Mail-Nachrichten anzuzeigen. Wenn Sie den Standort eines POP3-Mailservers und die entsprechende Einstellung für Anmeldung mit SPA (Gesicherte Kennwortauthentifizierung) festlegen, so werden Benachrichtigungen beim Eintreffen neuer E-Mail-Nachrichten angezeigt, wenn der Messenger Service-Client in einer zukünftigen Version dies ermöglicht. Informationen zu Updates erhalten Sie über die MSN Messenger Service-Website. In der Regel eignet sich diese Option am ehesten für ISP.


Übersicht zu Schritt 5: Komponentenanpassung

Assistent

Schritt 5: Komponentenanpassung

In diesem Schritt können Sie mit Hilfe des Assistenten für die Internet Explorer-Anpassung die Einstellungen, Praktiken und Einschränkungen für die Komponenten Ihres angepassten Pakets festlegen.

Die verfügbaren Optionen hängen davon ab, welche der folgenden Positionen bzw. Funktionen Sie haben:

  • Internetinhaltsanbieter
  • Internetdienstanbieter
  • Firmenadministrator